All Packages (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
All Packages

Core ECMAScript-compliant ActionScript classes are in the Top Level package. The flash.* packages contain the ActionScript classes for Adobe® Flash® Player 9.

Flex classes are in the mx.* packages.

Package | Description
Top Level | The top level contains the core ActionScript classes and global functions.
flash.accessibility | The flash.accessibility package contains classes for supporting accessibility in Flash content and applications.
flash.display | The flash.display package contains the core classes that the Flash Player uses to build visual displays.
flash.errors | The flash.errors package contains a set of commonly used error classes.
flash.events | The flash.events package supports the new DOM event model and includes the EventDispatcher base class.
flash.external | The flash.external package contains the ExternalInterface class which can be used to communicate with the Flash Player's container.
flash.filters | The flash.filters package contains classes for bitmap filter effects.
flash.geom | The flash.geom package contains geometry classes, such as points, rectangles and transformation matrixes, to support the BitmapData class and the bitmap caching feature.
flash.media | The flash.media package contains classes for working with multimedia assets such as sound and video.
flash.net | The flash.net package contains classes for sending and receiving from the network, such as URL downloading and Flash Remoting.
flash.printing | The flash.printing package contains classes for printing Flash-based content.
flash.profiler | The flash.profiler package contains functions used for debugging and profiling ActionScript code.
flash.system | The flash.system package contains classes for accessing system-level functionality, such as security, multilanguage content, etc.
flash.text | The flash.text package contains classes for working with text fields, text formatting, text metrics, style sheets, and layout.
flash.ui | The flash.ui package contains user interface classes, such as classes for interacting with the mouse and keyboard.
flash.utils | The flash.utils package contains utility classes, such as data structures like ByteArray.
flash.xml | The flash.xml package contains Flash Player's legacy XML support, and other Flash Player-specific XML functionality.
mx.binding.utils | The mx.binding.utils package contains the classes for creating binding watchers and for defining bindings in ActionScript.
mx.charts | The mx.charts package contains the classes for Flex Charting.
mx.charts.chartClasses | The mx.charts.chartClasses package contains the base classes for the Flex charting components.
mx.charts.effects | The mx.charts.effects package contains the effect classes for the Flex charting components.
mx.charts.effects.effectClasses | The mx.charts.effects.effectClasses package contains the effect instance classes for the Flex charting components.
mx.charts.events | The mx.charts.events package contains the classes that define chart event objects.
mx.charts.renderers | The mx.charts.renderers package contains the item renderer classes for the Flex charting components.
mx.charts.series | The mx.charts.series package contains the series classes for the Flex charting components.
mx.charts.series.items | The mx.charts.series.items package contains the items series classes for the Flex charting components.
mx.charts.series.renderData | The mx.charts.series.renderData package contains the data classes for the Flex charting components.
mx.collections | The mx.collections package contains the classes for the Flex collection components.
mx.collections.errors | The mx.collections.errors package contains the error classes for the Flex collection components.
mx.containers | The mx.containers package contains the container classes.
mx.containers.accordionClasses | The mx.containers.accordionClasses package contains the classes used by the Accordion container.
mx.controls | The mx.controls package contains the Flex user-interface controls.
mx.controls.dataGridClasses | The mx.controls.dataGridClasses package contains the classes used by the DataGrid control.
mx.controls.listClasses | The mx.controls.listClasses package contains the classes used by the list-based controls.
mx.controls.menuClasses | The mx.controls.menuClasses package contains the classes used by the menu-based controls.
mx.controls.scrollClasses | The mx.controls.scrollClasses package contains the classes used by controls that support scroll bars.
mx.controls.sliderClasses | The mx.controls.sliderClasses package contains the classes used by the Slider control.
mx.controls.textClasses | The mx.controls.textClasses package contains the classes used by the text-based controls.
mx.controls.treeClasses | The mx.controls.treeClasses package contains the classes used by the Tree control.
mx.controls.videoClasses | The mx.controls.videoClasses package contains the classes used by the VideoDisplay control.
mx.core | The mx.core package contains the base classes and interfaces, such as UIComponent, used by Flex.
mx.data | The mx.data package contains classes for working with the Flex Data Management Service.
mx.data.errors | The mx.data.errors package contains the error classes used with the Flex Data Management Service.
mx.data.events | The mx.data.events package contains the event classes used with the Flex Data Management Service.
mx.data.messages | The mx.data.messages package contains the messages used with the Flex Data Management Service.
mx.data.mxml |
mx.data.utils |
mx.effects | The mx.effects package contains the Factory classes to support behaviors.
mx.effects.easing | The mx.effects.easing package contains the easing classes used by effects.
mx.effects.effectClasses | The mx.effects.effectClasses package contains the effect implementation classes corresponding to the effect factory classes in the mx.effects package.
mx.events | The mx.events package contains the classes that define Flex event objects.
mx.formatters | The mx.formatters package contains the classes to support data formatting.
mx.graphics | The mx.graphics package contains drawing classes.
mx.logging | The mx.logging package contains the logging classes.
mx.logging.errors | The mx.logging.errors package contains the error classes used by the logging components.
mx.logging.targets | The mx.logging.targets package contains the target classes used by the logging components.
mx.managers | The mx.managers package contains the Flax manager classes, such as DragManager and HistoryManager.
mx.messaging | The mx.messaging package contains the messaging classes used with Flex Data Services.
mx.messaging.channels | The mx.messaging.channels package contains the messaging channel classes used with Flex Data Services.
mx.messaging.config | The mx.messaging.config package contains the messaging configuration classes used with Flex Data Services.
mx.messaging.errors | The mx.messaging.errors package contains the messaging error classes used with Flex Data Services.
mx.messaging.events | The mx.messaging.events package contains the messaging event classes used used with Flex Data Services.
mx.messaging.management | The mx.messaging.management package contains the bean management classes used with Flex Data Services.
mx.messaging.messages | The mx.messaging.messages package contains the message classes used with Flex Data Services.
mx.preloaders | The mx.preloaders package contains the classes used by the download progress bar.
mx.printing | The mx.printing package contains the printing classes.
mx.resources | The mx.resources package contains the classes used to support localization.
mx.rpc | The mx.rpc package contains the RPC classes.
mx.rpc.events | The mx.rpc.events package contains the RPC event classes.
mx.rpc.http | The mx.rpc.http package contains the HTTPService classes.
mx.rpc.http.mxml | The mx.rpc.http.mxml package contains the HTTP service MXML classes.
mx.rpc.mxml | The mx.rpc.mxml package contains the RPC MXML interface.
mx.rpc.remoting | The mx.rpc.remoting package contains the remote object classes.
mx.rpc.remoting.mxml | The mx.rpc.remoting.mxml package contains the remote object MXML classes.
mx.rpc.soap | The mx.rpc.soap package contains the web service classes.
mx.rpc.soap.mxml | The mx.rpc.soap.mxml package contains the web service MXML class.
mx.rpc.xml | The mx.rpc.xml package contains the RPC XML-related classes.
mx.skins | The mx.skins package contains the classes that define the skinning components.
mx.skins.halo | The mx.skins.halo package contains the classes used to skin Flex user-interface controls.
mx.states | The mx.states package contains the classes to support view states.
mx.styles | The mx.styles package contains the classes used by the Flex styles components.
mx.utils | The mx.utils package contains Flex utility classes.
mx.validators | The mx.validators package contains the classes to support data validation.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


Top Level Constants and Functions Summary (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference |  | All Packages | All Classes | Language Elements | Index | Appendixes | Conventions | Adobe Logo
Top Level | Functions | Constants | Classes

The top level contains the core ActionScript classes and global functions.

Global Functions
Function | Description
Array | Creates a new array.
Boolean | Converts the expression parameter to a Boolean value and returns the value.
decodeURI | Decodes an encoded URI into a string.
decodeURIComponent | Decodes an encoded URI component into a string.
encodeURI | Encodes a string into a valid URI (Uniform Resource Identifier).
encodeURIComponent | Encodes a string into a valid URI component.
escape | Converts the parameter to a string and encodes it in a URL-encoded format, where most nonalphanumeric characters are replaced with % hexadecimal sequences.
int | Converts a given numeric value to an integer value.
isFinite | Returns true if the value is a finite number, or false if the value is Infinity or -Infinity.
isNaN | Returns true if the value is NaN(not a number).
isXMLName | Determines whether the specified string is a valid name for an XML element or attribute.
Number | Converts a given value to a Number value.
Object | Every value in ActionScript 3.0 is an object, which means that calling Object() on a value returns that value.
parseFloat | Converts a string to a floating-point number.
parseInt | Converts a string to an integer.
String | Returns a string representation of the specified parameter.
trace | Displays expressions, or writes to log files, while debugging.
uint | Converts a given numeric value to an unsigned integer value.
unescape | Evaluates the parameter str as a string, decodes the string from URL-encoded format (converting all hexadecimal sequences to ASCII characters), and returns the string.
XML | Converts an object to an XML object.
XMLList | Converts an object to an XMLList object.
Global Constants
Constant | Description
Infinity | A special value representing positive Infinity.
-Infinity | A special value representing negative Infinity.
NaN | A special member of the Number data type that represents a value that is "not a number" (NaN).
undefined | A special value that applies to untyped variables that have not been initialized or dynamic object properties that are not initialized.
Classes
Class | Description
ArgumentError | The ArgumentError class represents an error that occurs when the arguments supplied in a function do not match the arguments defined for that function.
arguments | An arguments object is used to store and access a function's arguments.
Array | The Array class lets you access and manipulate arrays.
Boolean | A Boolean object is a data type that can have one of two values, either true or false, used for logical operations.
Class | A Class object is created for each class definition in a program.
Date | The Date class represents date and time information.
DefinitionError | The DefinitionError class represents an error that occurs when user code attempts to define an identifier that is already defined.
Error | The Error class contains information about an error that occurred in a script.
EvalError | The EvalError class represents an error that occurs when user code calls the eval() function or attempts to use the new operator with the Function object.
Function | A function is the basic unit of code that can be invoked in ActionScript.
int | The int class lets you work with the data type representing a 32-bit signed integer.
Math | The Math class contains methods and constants that represent common mathematical functions and values.
Namespace | The Namespace class contains methods and properties for defining and working with namespaces.
Number | A data type representing an IEEE-754 double-precision floating-point number.
Object | The Object class is at the root of the ActionScript class hierarchy.
QName | QName objects represent qualified names of XML elements and attributes.
RangeError | A RangeError exception is thrown when a numeric value is outside the acceptable range.
ReferenceError | A ReferenceError exception is thrown when a reference to an undefined property is attempted on a sealed (nondynamic) object.
RegExp | The RegExp class lets you work with regular expressions, which are patterns that you can use to perform searches in strings and to replace text in strings.
SecurityError | The SecurityError exception is thrown when some type of security violation takes place.
String | The String class is a data type that represents a string of characters.
SyntaxError | A SyntaxError exception is thrown when a parsing error occurs.
TypeError | A TypeError exception is thrown when the actual type of an operand is different from the expected type.
uint | The uint class provides methods for working with a data type representing a 32-bit unsigned integer.
URIError | A URIError exception is thrown when one of the global URI handling functions is used in a way that is incompatible with its definition.
VerifyError | The VerifyError class represents an error that occurs when a malformed or corrupted SWF file is encountered.
XML | The XML class contains methods and properties for working with XML objects.
XMLList | An XMLList object is an ordered collection of properties.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


Top Level Constants and Functions Details (Flex™ 2 Language Reference)

Top Level | Functions | Constants

Top level or global functions are available in any part of a SWF file where ActionScript is used, or in any user-defined class. Most of the global functions from ActionScript 2.0 have been migrated into classes.
Global Functions
Function |  | Defined by
 | Array(... args):Array Creates a new array. | Top Level
 | Boolean(expression:Object):Boolean Converts the expression parameter to a Boolean value and returns the value. | Top Level
 | decodeURI(uri:String):String Decodes an encoded URI into a string. | Top Level
 | decodeURIComponent(uri:String):String Decodes an encoded URI component into a string. | Top Level
 | encodeURI(uri:String):String Encodes a string into a valid URI (Uniform Resource Identifier). | Top Level
 | encodeURIComponent(uri:String):String Encodes a string into a valid URI component. | Top Level
 | escape(str:String):String Converts the parameter to a string and encodes it in a URL-encoded format, where most nonalphanumeric characters are replaced with % hexadecimal sequences. | Top Level
 | int(value:Number):int Converts a given numeric value to an integer value. | Top Level
 | isFinite(num:Number):Boolean Returns true if the value is a finite number, or false if the value is Infinity or -Infinity. | Top Level
 | isNaN(num:Number):Boolean Returns true if the value is NaN(not a number). | Top Level
 | isXMLName(str:String):Boolean Determines whether the specified string is a valid name for an XML element or attribute. | Top Level
 | Number(expression:Object):Number Converts a given value to a Number value. | Top Level
 | Object(value:Object):Object Every value in ActionScript 3.0 is an object, which means that calling Object() on a value returns that value. | Top Level
 | parseFloat(str:String):Number Converts a string to a floating-point number. | Top Level
 | parseInt(str:String, radix:uint = 0):Number Converts a string to an integer. | Top Level
 | String(expression:Object):String Returns a string representation of the specified parameter. | Top Level
 | trace(... arguments):void Displays expressions, or writes to log files, while debugging. | Top Level
 | uint(value:Number):uint Converts a given numeric value to an unsigned integer value. | Top Level
 | unescape(str:String):String Evaluates the parameter str as a string, decodes the string from URL-encoded format (converting all hexadecimal sequences to ASCII characters), and returns the string. | Top Level
 | XML(expression:Object):XML Converts an object to an XML object. | Top Level
 | XMLList(expression:Object):XMLList Converts an object to an XMLList object. | Top Level

Top level or global constants are available in every script, and are visible to every Timeline and scope in your document.
Global Constants
Constant |  | Defined by
 | Infinity : Number A special value representing positive Infinity. | Top Level
 | -Infinity : Number A special value representing negative Infinity. | Top Level
 | NaN : Number A special member of the Number data type that represents a value that is "not a number" (NaN). | Top Level
 | undefined : * A special value that applies to untyped variables that have not been initialized or dynamic object properties that are not initialized. | Top Level
Function detail
Array () function
public function Array(... args):Array

Creates a new array. The array can be of length zero or more, or an array populated by a list of specified elements, possibly of different data types. The number and data type of the arguments you use determine the contents of the returned array.

  • Calling Array() with no arguments returns an empty array.
  • Calling Array() with a single integer argument returns an array of the specified length, but whose elements have undefined values.
  • Calling Array() with a list of specific values returns an array with elements that contain each of the specified values.
Using the Array() function is similar to creating an array with the Array class constructor.

Use the as operator for explicit type conversion, or type casting, when the argument is not a primitive value. For more information, see the Example section of this entry.

Parameters
... args — You can pass no arguments for an empty array, a single integer argument for an array of a specific length, or a series of comma-separated values of various types for an array populated with those values.

Returns
Array — An array of length zero or more.

See also

Array class
as operator

Example
The following example demonstrates the behavior of the Array() function when an argument is not a primitive value. A common use case of casting to an array is the conversion of an Object instance that stores its values in array format. If Array() is called with an argument of type Object, or any other non-primitive data type, a reference to the object is stored in an element of the new array. In other words, if the only argument passed is an object, a reference to that object becomes the first element of the new array.
var obj:Object = [ "a", "b", "c" ];

var newArray:Array = Array( obj );

trace(newArray == obj);    // Output: false
trace(newArray[0] == obj); // Output: true
trace(newArray[0][0])      // Output: a
trace(newArray[0][1])      // Output: b
trace(newArray[0][2])      // Output: c

To cast obj to an array, use the as operator, which returns an array reference if obj is a valid array and null otherwise:
var obj:Object = [ "a", "b", "c" ];

var newArray:Array = obj as Array;

trace(newArray == obj); // Output: true
trace(newArray[0]);     // Output: a
trace(newArray[1]);     // Output: b
trace(newArray[2]);     // Output: c

Boolean () function
public function Boolean(expression:Object):Boolean

Converts the expression parameter to a Boolean value and returns the value.

The return value depends on the data type and value of the argument, as described in the following table:

Input Value | Example | Return Value
0 | 0 | false
NaN | NaN | false
Number (not 0 or NaN) | 4 | true
Empty string "" false
Non-empty string | "6" | true
null | null | false
undefined | undefined | false
instance of Object class var obj:Object = new Object();
Boolean(obj) 		true
No argument | Boolean() | false

Unlike previous versions of ActionScript, the Boolean() function returns the same results as does the Boolean class constructor.

Parameters
expression:Object — An expression or object to convert to Boolean.

Returns
Boolean — The result of the conversion to Boolean.

See also

Data type descriptions
Type conversions
decodeURI () function
public function decodeURI(uri:String):String

Decodes an encoded URI into a string. Returns a string in which all characters previously encoded by the encodeURI function are restored to their unencoded representation.

The following table shows the set of escape sequences that are not decoded to characters by the decodeURI function. Use decodeURIComponent() to decode the escape sequences in this table.

Escape sequences not decoded | Character equivalents
%23 | #
%24 | $
%26 | &
%2B | +
%2C | ,
%2F | /
%3A | :
%3B | ;
%3D | =
%3F | ?
%40 | @
Parameters
uri:String — A string encoded with the encodeURI function.

Returns
String — A string in which all characters previously escaped by the encodeURI function are restored to their unescaped representation.

See also

decodeURIComponent()
encodeURI()
encodeURIComponent()

Example
package {
    import flash.display.Sprite;

    public class DecodeURIExample extends Sprite {
        public function DecodeURIExample() {
            var uri:String = "http://www.example.com/application.jsp?user=<user name='some user'></user>";
            var encoded:String = encodeURI(uri);
            var decoded:String = decodeURI(encoded);
            trace(uri);        // http://www.example.com/application.jsp?user=<user name='some user'></user>
            trace(encoded);    // http://www.example.com/application.jsp?user=%3Cuser%20name='some%20user'%3E%3C/user%3E
            trace(decoded);    // http://www.example.com/application.jsp?user=<user name='some user'></user>
        }
    }
}

decodeURIComponent () function
public function decodeURIComponent(uri:String):String

Decodes an encoded URI component into a string. Returns a string in which all characters previously escaped by the encodeURIComponent function are restored to their uncoded representation.

This function differs from the decodeURI() function in that it is intended for use only with a part of a URI string, called a URI component. A URI component is any text that appears between special characters called component separators (: / ; and ? ). Common examples of a URI component are "http" and "www.adobe.com".

Another important difference between this function and decodeURI() is that because this function assumes that it is processing a URI component it treats the escape sequences that represent special separator characters (; / ? : @ & = + $ , #) as regular text that should be decoded.

Parameters
uri:String — A string encoded with the encodeURIComponent function.

Returns
String — A string in which all characters previously escaped by the encodeURIComponent function are restored to their unescaped representation.

See also

decodeURI()
encodeURI()
encodeURIComponent()
encodeURI () function
public function encodeURI(uri:String):String

Encodes a string into a valid URI (Uniform Resource Identifier). Converts a complete URI into a string in which all characters are encoded as UTF-8 escape sequences unless a character belongs to a small group of basic characters.

The following table shows the entire set of basic characters that are not converted to UTF-8 escape sequences by the encodeURI function.

Characters not encoded
0 1 2 3 4 5 6 7 8 9
a b c d e f g h i j k l m n o p q r s t u v w x y z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
; / ? : @ & = + $ , #
- _ . ! ~ * ' ( )
Parameters
uri:String — A string representing a complete URI.

Returns
String — A string with certain characters encoded as UTF-8 escape sequences.

See also

decodeURI()
decodeURIComponent()
encodeURIComponent()

Example
package {
    import flash.display.Sprite;

    public class EncodeURIExample extends Sprite {
        public function EncodeURIExample() {
            var uri:String = "http://www.example.com/application.jsp?user=<user name='some user'></user>";
            var encoded:String = encodeURI(uri);
            var decoded:String = decodeURI(encoded);
            trace(uri);        // http://www.example.com/application.jsp?user=<user name='some user'></user>
            trace(encoded);    // http://www.example.com/application.jsp?user=%3Cuser%20name='some%20user'%3E%3C/user%3E
            trace(decoded);    // http://www.example.com/application.jsp?user=<user name='some user'></user>
        }
    }
}

encodeURIComponent () function
public function encodeURIComponent(uri:String):String

Encodes a string into a valid URI component. Converts a substring of a URI into a string in which all characters are encoded as UTF-8 escape sequences unless a character belongs to a very small group of basic characters.

The encodeURIComponent() function differs from the encodeURI() function in that it is intended for use only with a part of a URI string, called a URI component. A URI component is any text that appears between special characters called component separators (: / ; and ? ). Common examples of a URI component are "http" and "www.adobe.com".

Another important difference between this function and encodeURI() is that because this function assumes that it is processing a URI component it treats the special separator characters (; / ? : @ & = + $ , #) as regular text that should be encoded.

The following table shows all characters that are not converted to UTF-8 escape sequences by the encodeURIComponent function.

Characters not encoded
0 1 2 3 4 5 6 7 8 9
a b c d e f g h i j k l m n o p q r s t u v w x y z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
- _ . ! ~ * ' ( )
Parameters
uri:String

Returns
String

See also

decodeURI()
decodeURIComponent()
encodeURI()
escape () function
public function escape(str:String):String

Converts the parameter to a string and encodes it in a URL-encoded format, where most nonalphanumeric characters are replaced with % hexadecimal sequences. When used in a URL-encoded string, the percentage symbol (%) is used to introduce escape characters, and is not equivalent to the modulo operator (%).

The following table shows all characters that are not converted to escape sequences by the escape() function.

Characters not encoded
0 1 2 3 4 5 6 7 8 9
a b c d e f g h i j k l m n o p q r s t u v w x y z
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
@ - _ . * + /
Parameters
str:String — The expression to convert into a string and encode in a URL-encoded format.

Returns
String — A URL-encoded string.

See also

unescape()
int () function
public function int(value:Number):int

Converts a given numeric value to an integer value. Decimal values are truncated at the decimal point.

Parameters
value:Number — A value to be converted to an integer.

Returns
int — The converted integer value.

See also

uint()
Data type descriptions
Type conversions
isFinite () function
public function isFinite(num:Number):Boolean

Returns true if the value is a finite number, or false if the value is Infinity or -Infinity. The presence of Infinity or -Infinity indicates a mathematical error condition such as division by 0.

Parameters
num:Number — A number to evaluate as finite or infinite.

Returns
Boolean — Returns true if it is a finite number or false if it is infinity or negative infinity.
isNaN () function
public function isNaN(num:Number):Boolean

Returns true if the value is NaN(not a number). The isNaN() function is useful for checking whether a mathematical expression evaluates successfully to a number. The NaN value is a special member of the Number data type that represents a value that is "not a number."

Note: The NaN value is not a member of the int or uint data types.

The following table describes the return value of isNaN() on various input types and values.

Input Type/Value | Example | Return Value
0 divided by 0 | isNaN(0/0) | true
Non-zero number divided by 0 | isNaN(5/0) | false
Square root of a negative number | isNaN(Math.sqrt(-1)) | true
Arcsine of number greater than 1 or less than 0 | isNaN(Math.asin(2)) | true
String that can be converted to Number | isNaN("5") | false
String that cannot be converted to Number | isNaN("5a") | true
Parameters
num:Number — A numeric value or mathematical expression to evaluate.

Returns
Boolean — Returns true if the value is NaN(not a number) and false otherwise.
isXMLName () function
public function isXMLName(str:String):Boolean

Determines whether the specified string is a valid name for an XML element or attribute.

Parameters
str:String — A string to evaluate.

Returns
Boolean — Returns true if the str argument is a valid XML name; false otherwise.
Number () function
public function Number(expression:Object):Number

Converts a given value to a Number value. The following table shows the result of various input types:

Input Type/Value | Example | Return Value
undefined | Number(undefined) | NaN
null | Number(null) | 0
true | Number(true) | 1
false | Number(false) | 0
NaN | Number(NaN) | NaN
Empty string | Number("") | 0
String that converts to Number | Number("5") | The number (e.g. 5)
String that does not convert to Number | Number("5a") | NaN

Parameters
expression:Object — A value to be converted to a number.

Returns
Number — The converted number value.

See also

Data type descriptions
Type conversions
XML type conversion
Object () function
public function Object(value:Object):Object

Every value in ActionScript 3.0 is an object, which means that calling Object() on a value returns that value.

Parameters
value:Object — An object or a number, string, or Boolean value to convert.

Returns
Object — The value specified by the value parameter.

See also

Data type descriptions
parseFloat () function
public function parseFloat(str:String):Number

Converts a string to a floating-point number. The function reads, or parses, and returns the numbers in a string until it reaches a character that is not a part of the initial number. If the string does not begin with a number that can be parsed, parseFloat() returns NaN. White space preceding valid integers is ignored, as are trailing nonnumeric characters.

Parameters
str:String — The string to read and convert to a floating-point number.

Returns
Number — A number or NaN (not a number).
parseInt () function
public function parseInt(str:String, radix:uint = 0):Number

Converts a string to an integer. If the specified string in the parameters cannot be converted to a number, the function returns NaN. Strings beginning with 0x are interpreted as hexadecimal numbers. Unlike in previous versions of ActionScript, integers beginning with 0 are not interpreted as octal numbers. You must specify a radix of 8 for octal numbers. White space and zeroes preceding valid integers are ignored, as are trailing nonnumeric characters.

Parameters
str:String — A string to convert to an integer.
radix:uint (default = 0) — An integer representing the radix (base) of the number to parse. Legal values are from 2 to 36.

Returns
Number — A number or NaN (not a number).
String () function
public function String(expression:Object):String

Returns a string representation of the specified parameter.

The following table shows the result of various input types:

Input Type/Value | Return Value
undefined | undefined
null | "null"
true | "true"
false | "false"
NaN | "NaN"
String | String
Object | Object.toString()
Number | String representation of the number
Parameters
expression:Object — An expression to convert to a string.

Returns
String — A string representation of the value passed for the expression parameter.

See also

Data type descriptions
Type conversions
Introduction to regular expressions
trace () function
public function trace(... arguments):void

Displays expressions, or writes to log files, while debugging. A single trace statement can support multiple arguments. If any argument in a trace statement includes a data type other than a String, the trace function invokes the associated toString() method for that data type. For example, if the argument is a Boolean value the trace function invokes Boolean.toString() and displays the return value.

Parameters
... arguments — One or more (comma separated) expressions to evaluate. For multiple expressions, a space is inserted between each expression in the output.

Example
The following example uses the class TraceExample to show how the trace() method can be used to print a simple string. Generally, the message will be printed to a "Debug" console.
package {
    import flash.display.Sprite;

    public class TraceExample extends Sprite {

        public function TraceExample() {
            trace("Hello World");
        }
    }
}

uint () function
public function uint(value:Number):uint

Converts a given numeric value to an unsigned integer value. Decimal values are truncated at the decimal point.

The following table describes the return value of uint() on various input types and values.

Input Type/Value | Example | Return Value
undefined | uint(undefined) | 0
null | uint(null) | 0
0 | uint(0) | 0
NaN | uint(NaN) | 0
Positive floating-point number | uint(5.31) | Truncated unsigned integer (e.g. 5)
Negative floating-point number | uint(-5.78) | Truncates to integer then applies rule for negative integers
Negative integer | uint(-5) | Sum of uint.MAX_VALUE and the negative integer (for example, uint.MAX_VALUE + (-5))
true | uint(true) | 1
false | uint(false) | 0
Empty String | uint("") | 0
String that converts to Number | uint("5") | The number()
String that does not convert to Number | uint("5a") | 0
Parameters
value:Number — A value to be converted to an integer.

Returns
uint — The converted integer value.

See also

int()
Data type descriptions
Type conversions
unescape () function
public function unescape(str:String):String

Evaluates the parameter str as a string, decodes the string from URL-encoded format (converting all hexadecimal sequences to ASCII characters), and returns the string.

Parameters
str:String — A string with hexadecimal sequences to escape.

Returns
String — A string decoded from a URL-encoded parameter.
XML () function
public function XML(expression:Object):XML

Converts an object to an XML object.

The following table describes return values for various input types.

Parameter Type | Return Value
Boolean | Value is first converted to a string, then converted to an XML object.
Null | A runtime error occurs (TypeError exception).
Number | Value is first converted to a string, then converted to an XML object.
Object | Converts to XML only if the value is a String, Number or Boolean value. Otherwise a runtime error occurs (TypeError exception).
String | Value is converted to XML.
Undefined | A runtime error occurs (TypeError exception).
XML | Input value is returned unchanged.
XMLList | Returns an XML object only if the XMLList object contains only one property of type XML. Otherwise a runtime error occurs (TypeError exception).
Parameters
expression:Object — Object to be converted to XML.

Returns
XML — An XML object containing values held in the converted object.

See also

XMLList()
XML objects
XMLList () function
public function XMLList(expression:Object):XMLList

Converts an object to an XMLList object.

The following table describes return values for various input types.

Parameter Type | Return Value
Boolean | Value is first converted to a string, then converted to an XMLList object.
Null | A runtime error occurs (TypeError exception).
Number | Value is first converted to a string, then converted to an XMLList object.
Object | Converts to XMLList only if the value is a String, Number or Boolean value. Otherwise a runtime error occurs (TypeError exception).
String | Value is converted to an XMLList object.
Undefined | A runtime error occurs (TypeError exception).
XML | Value is converted to an XMLList object.
XMLList | Input value is returned unchanged.
Parameters
expression:Object — Object to be converted into an XMLList object.

Returns
XMLList — An XMLList object containing values held in the converted object.

See also

XML()
Constant detail
Infinity constant
public const Infinity:Number

A special value representing positive Infinity. The value of this constant is the same as Number.POSITIVE_INFINITY.

See also

Number.POSITIVE_INFINITY

Example
The result of division by 0 is Infinity, but only when the divisor is a positive number.

trace(0 / 0);  // Output: NaN
trace(7 / 0);  // Output: Infinity
trace(-7 / 0); // Output: -Infinity

-Infinity constant
public const -Infinity:Number

A special value representing negative Infinity. The value of this constant is the same as Number.NEGATIVE_INFINITY.

See also

Number.NEGATIVE_INFINITY

Example
The result of division by 0 is -Infinity, but only when the divisor is a negative number.

trace(0 / 0);  // Output: NaN
trace(7 / 0);  // Output: Infinity
trace(-7 / 0); // Output: -Infinity

NaN constant
public const NaN:Number

A special member of the Number data type that represents a value that is "not a number" (NaN). When a mathematical expression results in a value that cannot be expressed as a number, the result is NaN. The following list describes common expressions that result in NaN.

  • Division by 0 results in NaN only if the divisor is also 0. If the divisor is greater than 0, division by 0 results in Infinity. If the divisor is less than 0, division by 0 results in -Infinity;
  • Square root of a negative number;
  • The arcsine of a number outside the valid range of 0 to 1;
  • Infinity subtracted from Infinity;
  • Infinity or -Infinity divided by Infinity or -Infinity;
  • Infinity or -Infinity multiplied by 0;

The NaN value is not a member of the int or uint data types.

The NaN value is not considered equal to any other value, including NaN, which makes it impossible to use the equality operator to test whether an expression is NaN. To determine whether a number is the NaN function, use isNaN().

See also

isNaN()
Number.NaN
undefined constant
public const undefined:*

A special value that applies to untyped variables that have not been initialized or dynamic object properties that are not initialized. In ActionScript 3.0, only variables that are untyped can hold the value undefined, which is not true in ActionScript 1.0 and ActionScript 2.0. For example, both of the following variables are undefined because they are untyped and unitialized:

  • var foo;
  • var bar:*;

The undefined value also applies to uninitialized or undefined properties of dynamic objects. For example, if an object is an instance of the Object class, the value of any dynamically added property is undefined until a value is assigned to that property.

Results vary when undefined is used with various functions:

  • The value returned by String(undefined) is "undefined" (undefined is converted to a string).
  • The value returned by Number(undefined) is NaN.
  • The value returned by int(undefined) and uint(undefined) is 0.
  • The value returned by Object(undefined) is a new Object instance.
  • When the value undefined is assigned to a typed variable, the value is converted to the default value of the data type.

Do not confuse undefined with null. When null and undefined are compared with the equality (==) operator, they compare as equal. However, when null and undefined are compared with the strict equality (===) operator, they compare as not equal.

See also

null

Example
In the following example, an untyped variable, myVar is declared but not initialized. The value of myVar is undefined because the variable is untyped. This is true whether the variable has no type annotation or uses the special (*) untyped annotation (var myVar:*;).

// trace value of untyped and uninitialized variable
var myVar;
trace(myVar);           // Output: undefined

The same rule applies to uninitialized properties of a dynamic object. For example, given an instance, obj, of the dynamic class A, the value of obj.propName, which is an uninitialized property of the obj instance, is undefined.

dynamic class A {}
var obj:A = new A()

// trace undefined property of obj
trace(obj.propName); // Output: undefined

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


ArgumentError (Flex™ 2 Language Reference)

Class ArgumentError | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class ArgumentError
Inheritance | ArgumentError Inheritance Error Inheritance Object

The ArgumentError class represents an error that occurs when the arguments supplied in a function do not match the arguments defined for that function. This error occurs, for example, when a function is called with the wrong number of arguments, an argument of the incorrect type, or an invalid argument.

View the examples.

See also

Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ArgumentError(message:String = "") Creates an ArgumentError object. | ArgumentError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
ArgumentError () constructor
public function ArgumentError(message:String = "")

Creates an ArgumentError object.

Parameters
message:String (default = "") — A string associated with the error.
Examples

The following example shows how an ArgumentError error is generated and handled within a try..catch statement. The println() function takes one argument, a single string, but because two strings are supplied, the error is thrown. Typically, the compiler might catch such an error, but the this[] syntax in the try statement bypasses the compiler's syntax checking for the function.
package {
    import flash.display.Sprite;

    public class ArgumentErrorExample extends Sprite {
        public function ArgumentErrorExample() {
                println("Hello World");

                try {
                    this["println"]("Hello", "World");
                }
                catch(e:ArgumentError) {
                    trace(e);
                }
        }

        public function println(str:String):void {
            trace(str);
        }
    }
}

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00


arguments (Flex™ 2 Language Reference)

Class arguments | Properties | Methods | Examples
Package | Top Level
Class | public class arguments
Inheritance | arguments Inheritance Object

An arguments object is used to store and access a function's arguments. Within a function's body, you can access its arguments object by using the local arguments variable.

The arguments are stored as array elements: the first is accessed as arguments[0], the second as arguments[1], and so on. The arguments.length property indicates the number of arguments passed to the function. There may be a different number of arguments passed than the function declares.

Unlike previous versions of ActionScript, ActionScript 3.0 has no arguments.caller property. To get a reference to the function that called the current function, you must pass a reference to that function as an argument. An example of this technique can be found in the example for arguments.callee.

ActionScript 3.0 includes a new ...(rest) keyword that is recommended instead of the arguments class.

View the examples.

See also

...(rest)
Function

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | callee : Function A reference to the currently executing function. | arguments
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | length : Number The number of arguments passed to the function. | arguments
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
callee property
public var callee:Function

A reference to the currently executing function.

Example
The following code shows how to get a reference to the function that calls the function named secondFunction(). The firstFunction() function has the Boolean argument of true to demonstrate that secondFunction() successfully calls firstFunction() and to prevent an infinite loop of each function calling the other.

Because the callSecond parameter is true, firstFunction() calls secondFunction() and passes a reference to itself as the only argument. The function secondFunction() receives this argument and stores it using a parameter named caller, which is of data type Function. From within secondFunction(), the caller parameter is then used to call the firstFunction function, but this time with the callSecond argument set to false.

When execution returns to firstFunction(), the trace() statement is executed because callSecond is false.

  package {
    import flash.display.Sprite;

    public class ArgumentsExample extends Sprite {
        private var count:int = 1;

        public function ArgumentsExample() {
            firstFunction(true);
        }

        public function firstFunction(callSecond:Boolean) {
            trace(count + ": firstFunction");
            if(callSecond) {
                secondFunction(arguments.callee);
            }
            else {
                trace("CALLS STOPPED");
            }
        }

        public function secondFunction(caller:Function) {
            trace(count + ": secondFunction\n");
            count++;
            caller(false);
        }
    }
}

length property
public var length:Number

The number of arguments passed to the function. This may be more or less than the function declares.

Examples

The following example shows uses for various arguments properties, such as callee and length.
package {
    import flash.display.Sprite;

    public class ArgumentsExample extends Sprite {
        public function ArgumentsExample() {
                println("Hello World");
        }

        public function println(str:String):void {
            trace(arguments.callee == this.println); // true
            trace(arguments.length);                 // 1
            trace(arguments[0]);                     // Hello World
            trace(str);                                // Hello World
        }
    }
}


Array (Flex™ 2 Language Reference)

Class Array | Properties | Methods | Constants | Examples
Package | Top Level
Class | public dynamic class Array
Inheritance | Array Inheritance Object

The Array class lets you access and manipulate arrays. Array indices are zero-based, which means that the first element in the array is [0], the second element is [1], and so on. To create an Array object, you use the new Array() constructor . Array() can also be invoked as a function. In addition, you can use the array access ([]) operator to initialize an array or access the elements of an array.

You can store a wide variety of data types in an array element, including numbers, strings, objects, and even other arrays. You can create a multidimensional array by creating an indexed array and assigning to each of its elements a different indexed array. Such an array is considered multidimensional because it can be used to represent data in a table.

Arrays are sparse arrays, meaning there might be an element at index 0 and another at index 5, but nothing in the index positions between those two elements. In such a case, the elements in positions 1 through 4 are undefined, which indicates the absence of an element, not necessarily the presence of an element with the value undefined.

Array assignment is by reference rather than by value. When you assign one array variable to another array variable, both refer to the same array:

 var oneArray:Array = new Array("a", "b", "c");
 var twoArray:Array = oneArray; // Both array variables refer to the same array.
 twoArray[0] = "z";
 trace(oneArray);               // Output: z,b,c.

Do not use the Array class to create associative arrays (also called hashes), which are data structures that contain named elements instead of numbered elements. To create associative arrays, use the Object class. Although ActionScript permits you to create associative arrays using the Array class, you cannot use any of the Array class methods or properties with associative arrays.

You can extend the Array class and override or add methods. However, you must specify the subclass as dynamic or you will lose the ability to store data in an array.

View the examples.

See also

[] (array access)
Object class
Function parameters

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | length : uint A non-negative integer specifying the number of elements in the array. | Array
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Array(numElements:int = 0) Lets you create an array of the specified number of elements. | Array
 | Array(... values) Lets you create an array that contains the specified elements. | Array
 | concat(... args):Array Concatenates the elements specified in the parameters with the elements in an array and creates a new array. | Array
 | every(callback:Function, thisObject:* = null):Boolean Executes a test function on each item in the array until an item is reached that returns false for the specified function. | Array
 | filter(callback:Function, thisObject:* = null):Array Executes a test function on each item in the array and constructs a new array for all items that return true for the specified function. | Array
 | forEach(callback:Function, thisObject:* = null):void Executes a function on each item in the array. | Array
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | indexOf(searchElement:*, fromIndex:int = 0):int Searches for an item in an array by using strict equality (===) and returns the index position of the item. | Array
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | join(sep:*):String Converts the elements in an array to strings, inserts the specified separator between the elements, concatenates them, and returns the resulting string. | Array
 | lastIndexOf(searchElement:*, fromIndex:int = 0x7fffffff):int Searches for an item in an array, working backward from the last item, and returns the index position of the matching item using strict equality (===). | Array
 | map(callback:Function, thisObject:* = null):Array Executes a function on each item in an array, and constructs a new array of items corresponding to the results of the function on each item in the original array. | Array
 | pop():Object Removes the last element from an array and returns the value of that element. | Array
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | push(... args):uint Adds one or more elements to the end of an array and returns the new length of the array. | Array
 | reverse():Array Reverses the array in place. | Array
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | shift():Object Removes the first element from an array and returns that element. | Array
 | slice(startIndex:int = 0, endIndex:int = -1):Array Returns a new array that consists of a range of elements from the original array, without modifying the original array. | Array
 | some(callback:Function, thisObject:* = null):Boolean Executes a test function on each item in the array until an item is reached that returns true. | Array
 | sort(... args):Array Sorts the elements in an array. | Array
 | sortOn(fieldName:Object, options:Object = null):Array Sorts the elements in an array according to one or more fields in the array. | Array
 | splice(startIndex:int, deleteCount:uint, ... values):Array Adds elements to and removes elements from an array. | Array
 | toLocaleString():String Returns a string that represents the elements in the specified array. | Array
 | toString():String Returns a string that represents the elements in the specified array. | Array
 | unshift(... args):uint Adds one or more elements to the beginning of an array and returns the new length of the array. | Array
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CASEINSENSITIVE : uint = 1 [static] Specifies case-insensitive sorting for the Array class sorting methods. | Array
 | DESCENDING : uint = 2 [static] Specifies descending sorting for the Array class sorting methods. | Array
 | NUMERIC : uint = 16 [static] Specifies numeric (instead of character-string) sorting for the Array class sorting methods. | Array
 | RETURNINDEXEDARRAY : uint = 8 [static] Specifies that a sort returns an array that consists of array indices. | Array
 | UNIQUESORT : uint = 4 [static] Specifies the unique sorting requirement for the Array class sorting methods. | Array
Property detail
length property
length:uint [read-write]

A non-negative integer specifying the number of elements in the array. This property is automatically updated when new elements are added to the array. When you assign a value to an array element (for example, my_array[index] = value), if index is a number, and index+1 is greater than the length property, the length property is updated to index+1.

Note: If you assign a value to the length property that is shorter than the existing length, the array will be truncated.

Implementation
    public function get length():uint
    public function set length(value:uint):void

Example
The following code creates an Array object names with the string element Bill. It then uses the push() method to add another string element Kyle. The length of the array, as determined by the length property, was one element before the use of push() and is two elements after push() is called. Another string, Jeff, is added to make the length of names three elements. The shift() method is then called twice to remove Bill and Kyle, making the final array of length one.

var names:Array = new Array("Bill");
names.push("Kyle");
trace(names.length); // 2

names.push("Jeff");
trace(names.length); // 3

names.shift();
names.shift();
trace(names.length); // 1

Constructor detail
Array () constructor
public function Array(numElements:int = 0)

Lets you create an array of the specified number of elements. If you don't specify any parameters, an array containing 0 elements is created. If you specify a number of elements, an array is created with numElements number of elements.

Note: This class shows two constructor method entries because the constructor accepts variable types of arguments. The constructor behaves differently depending on the type and number of arguments passed, as detailed in each entry. ActionScript 3.0 does not support method or constructor overloading.

Parameters
numElements:int (default = 0) — An integer that specifies the number of elements in the array.

Throws
RangeError — The argument is a number that is not an integer greater than or equal to 0.

See also

[] array access
Array.length

Example
The following example creates the Array object myArr with no arguments and an initial length of 0:
package {
    import flash.display.Sprite;

    public class Array_Array extends Sprite {

        public function Array_Array() {
            var myArr:Array = new Array();
            trace(myArr.length); // 0
        }
    }
}

The following example creates an Array object with 5 initial elements, with a length of 5, and populates the first element with the string "one", and adds the string element "six" to the end of the array by using the push() method:
package {
    import flash.display.Sprite;

    public class Array_Array_2 extends Sprite {

        public function Array_Array_2() {
            var myArr:Array = new Array(5);
            trace(myArr.length); // 5
            myArr[0] = "one";
            myArr.push("six");
            trace(myArr);         // one,,,,,six
            trace(myArr.length); // 6
        }
    }
}

Array () constructor
public function Array(... values)

Lets you create an array that contains the specified elements. You can specify values of any type. The first element in an array always has an index (or position) of 0.

Note: This class shows two constructor entries because the constructor accepts variable types of arguments. The constructor behaves differently depending on the type and number of arguments passed, as detailed in each entry. ActionSript 3.0 does not support method or constructor overloading.

Parameters
... values — A comma-separated list of one or more arbitrary values.

Note: If only a single numeric parameter is passed to the Array constructor, it is assumed to specify the array's length property.

Throws
RangeError — The argument is a number that is not an integer greater than or equal to 0.

See also

[] array access
Array.length

Example
The following example creates a new Array object with an initial length of 3, populates the array with the string elements one, two, and three, and then converts the elements to a string.
package {
    import flash.display.Sprite;

    public class Array_Array_3 extends Sprite {

        public function Array_Array_3() {
            var myArr:Array = new Array("one", "two", "three");
            trace(myArr.length); // 3
            trace(myArr);          // one,two,three
        }
    }
}

Method detail
concat () method
AS3 function concat(... args):Array

Concatenates the elements specified in the parameters with the elements in an array and creates a new array. If the parameters specify an array, the elements of that array are concatenated.

Parameters
... args — A value of any data type (such as numbers, elements, or strings) to be concatenated in a new array. If you don't pass any values, the new array is a duplicate of the original array.

Returns
Array — An array that contains the elements from this array followed by elements from the parameters.

Example
The following code creates four Array objects:
  • The numbers array, which contains the numbers 1, 2, and 3.
  • The letters array, which contains the letters a, b, and c.
  • The numbersAndLetters array, which calls the concat() method to produce the array [1,2,3,a,b,c].
  • The lettersAndNumbers array, which calls the concat() method to produce the array [a,b,c,1,2,3].

var numbers:Array = new Array(1, 2, 3);
var letters:Array = new Array("a", "b", "c");
var numbersAndLetters:Array = numbers.concat(letters);
var lettersAndNumbers:Array = letters.concat(numbers);

trace(numbers);       // 1,2,3
trace(letters);       // a,b,c
trace(numbersAndLetters); // 1,2,3,a,b,c
trace(lettersAndNumbers); // a,b,c,1,2,3

every () method
AS3 function every(callback:Function, thisObject:* = null):Boolean

Executes a test function on each item in the array until an item is reached that returns false for the specified function. You use this method to determine whether all items in an array meet a criterion, such as having values less than a particular number.

For this method, the second parameter, thisObject, must be null if the first parameter, callback, is a method closure. Suppose you create a function in a movie clip called me:

     function myFunction(){
        //your code here
     }

Suppose you then use the filter() method on an array called myArray:

     myArray.filter(myFunction, me);

Because myFunction is a member of the Timeline class, which cannot be overridden by me, Flash Player will throw an exception. You can avoid this runtime error by assigning the function to a variable, as follows:

     var foo:Function = myFunction() {
         //your code here
         };
     myArray.filter(foo, me);
Parameters
callback:Function — The function to run on each item in the array. This function can contain a simple comparison (for example, item < 20) or a more complex operation, and is invoked with three arguments; the value of an item, the index of an item, and the Array object:
    function callback(item:*, index:int, array:Array):void;
thisObject:* (default = null) — An object to use as this for the function.

Returns
Boolean — A Boolean value of true if all items in the array return true for the specified function; otherwise, false.

See also

Array.some()

Example
The following example tests two arrays to determine whether every item in each array is a number. It also outputs the results of the test, showing that isNumeric is true for the first array and false for the second:
package {
    import flash.display.Sprite;
    public class Array_every extends Sprite {
        public function Array_every() {
            var arr1:Array = new Array(1, 2, 4);
            var res1:Boolean = arr1.every(isNumeric);
            trace("isNumeric:", res1); // true

            var arr2:Array = new Array(1, 2, "ham");
            var res2:Boolean = arr2.every(isNumeric);
            trace("isNumeric:", res2); // false
        }
        private function isNumeric(element:*, index:int, arr:Array):Boolean {
            return (element is Number);
        }
    }
}

filter () method
AS3 function filter(callback:Function, thisObject:* = null):Array

Executes a test function on each item in the array and constructs a new array for all items that return true for the specified function. If an item returns false, it is not included in the new array.

For this method, the second parameter, thisObject, must be null if the first parameter, callback, is a method closure. Suppose you create a function in a movie clip called me:

     function myFunction(){
        //your code here
     }

Suppose you then use the filter() method on an array called myArray:

     myArray.filter(myFunction, me);

Because myFunction is a member of the Timeline class, which cannot be overridden by me, Flash Player will throw an exception. You can avoid this runtime error by assigning the function to a variable, as follows:

     var foo:Function = myFunction() {
         //your code here
         };
     myArray.filter(foo, me);
Parameters
callback:Function — The function to run on each item in the array. This function can contain a simple comparison (for example, item < 20) or a more complex operation, and is invoked with three arguments; the value of an item, the index of an item, and the Array object:
    function callback(item:*, index:int, array:Array):void;
thisObject:* (default = null) — An object to use as this for the function.

Returns
Array — A new array that contains all items from the original array that returned true.

See also

Array.map()

Example
The following example creates an array of all employees who are managers:
package {
    import flash.display.Sprite;
    public class Array_filter extends Sprite {
        public function Array_filter() {
            var employees:Array = new Array();
            employees.push({name:"Employee 1", manager:false});
            employees.push({name:"Employee 2", manager:true});
            employees.push({name:"Employee 3", manager:false});
            trace("Employees:");
            employees.forEach(traceEmployee);

            var managers:Array = employees.filter(isManager);
            trace("Managers:");
            managers.forEach(traceEmployee);
        }
        private function isManager(element:*, index:int, arr:Array):Boolean {
            return (element.manager == true);
        }
        private function traceEmployee(element:*, index:int, arr:Array):void {
            trace("\t" + element.name + ((element.manager) ? " (manager)" : ""));
        }
    }
}

forEach () method
AS3 function forEach(callback:Function, thisObject:* = null):void

Executes a function on each item in the array.

For this method, the second parameter, thisObject, must be null if the first parameter, callback, is a method closure. Suppose you create a function in a movie clip called me:

     function myFunction(){
        //your code here
     }

Suppose you then use the filter() method on an array called myArray:

     myArray.filter(myFunction, me);

Because myFunction is a member of the Timeline class, which cannot be overridden by me, Flash Player will throw an exception. You can avoid this runtime error by assigning the function to a variable, as follows:

     var foo:Function = myFunction() {
         //your code here
         };
     myArray.filter(foo, me);
Parameters
callback:Function — The function to run on each item in the array. This function can contain a simple command (for example, a trace() statement) or a more complex operation, and is invoked with three arguments; the value of an item, the index of an item, and the Array object:
    function callback(item:*, index:int, array:Array):void;
thisObject:* (default = null) — An object to use as this for the function.

Example
The following example runs the trace() statement in the traceEmployee() function on each item in the array:
package {
    import flash.display.Sprite;
    public class Array_forEach extends Sprite {
        public function Array_forEach() {
            var employees:Array = new Array();
            employees.push({name:"Employee 1", manager:false});
            employees.push({name:"Employee 2", manager:true});
            employees.push({name:"Employee 3", manager:false});
            trace(employees);
            employees.forEach(traceEmployee);
        }
        private function traceEmployee(element:*, index:int, arr:Array):void {
            trace(element.name + " (" + element.manager + ")");
        }
    }
}

The following example also runs the trace() statement in a slightly altered traceEmployee() function on each item in the array:
package {
    import flash.display.Sprite;
    public class Array_forEach_2 extends Sprite {
        public function Array_forEach_2() {
            var employeeXML:XML = <employees>
                    <employee name="Steven" manager="false" />
                    <employee name="Bruce" manager="true" />
                    <employee name="Rob" manager="false" />
                </employees>;
            var employeesList:XMLList = employeeXML.employee;
            var employeesArray:Array = new Array();
            for each (var tempXML:XML in employeesList) {
                employeesArray.push(tempXML);
            }
            employeesArray.sortOn("@name");
            employeesArray.forEach(traceEmployee);
        }
        private function traceEmployee(element:*, index:Number, arr:Array):void {
            trace(element.@name + ((element.@manager == "true") ? " (manager)" : ""));
        }
    }
}

indexOf () method
AS3 function indexOf(searchElement:*, fromIndex:int = 0):int

Searches for an item in an array by using strict equality (===) and returns the index position of the item.

Parameters
searchElement:* — The item to find in the array.
fromIndex:int (default = 0) — The location in the array from which to start searching for the item.

Returns
int — A zero-based index position of the item in the array. If the searchElement argument is not found, the return value is -1.

See also

Array.lastIndexOf()
=== (strict equality)

Example
The following example displays the position of the specified array:
package {
    import flash.display.Sprite;
    public class Array_indexOf extends Sprite {
        public function Array_indexOf() {
            var arr:Array = new Array(123,45,6789);
            arr.push("123-45-6789");
            arr.push("987-65-4321");

            var index:int = arr.indexOf("123");
            trace(index); // -1

            var index2:int = arr.indexOf(123);
            trace(index2); // 0
        }
    }
}

join () method
AS3 function join(sep:*):String

Converts the elements in an array to strings, inserts the specified separator between the elements, concatenates them, and returns the resulting string. A nested array is always separated by a comma (,), not by the separator passed to the join() method.

Parameters
sep:* — A character or string that separates array elements in the returned string. If you omit this parameter, a comma is used as the default separator.

Returns
String — A string consisting of the elements of an array converted to strings and separated by the specified parameter.

See also

String.split()

Example
The following code creates an Array object myArr with elements one, two, and three and then a string containing one and two and three using the join() method.

var myArr:Array = new Array("one", "two", "three");
var myStr:String = myArr.join(" and ");
trace(myArr); // one,two,three
trace(myStr); // one and two and three

The following code creates an Array object specialChars with elements (, ), -, and a blank space and then creates a string containing (888) 867-5309. Then, using a for loop, it removes each type of special character listed in specialChars to produce a string (myStr) that contains only the digits of the phone number remaining: 888675309. Note that other characters, such as +, could have been added to specialChars and then this routine would work with international phone number formats.

var phoneString:String = "(888) 867-5309";

var specialChars:Array = new Array("(", ")", "-", " ");
var myStr:String = phoneString;

var ln:uint = specialChars.length;
for(var i:uint; i < ln; i++) {
    myStr = myStr.split(specialChars[i]).join("");
}

var phoneNumber:Number = new Number(myStr);

trace(phoneString); // (888) 867-5309
trace(phoneNumber); // 8888675309

lastIndexOf () method
AS3 function lastIndexOf(searchElement:*, fromIndex:int = 0x7fffffff):int

Searches for an item in an array, working backward from the last item, and returns the index position of the matching item using strict equality (===).

Parameters
searchElement:* — The item to find in the array.
fromIndex:int (default = 0x7fffffff) — The location in the array from which to start searching for the item. The default is the maximum value allowed for an index. If you do not specify fromIndex, the search starts at the last item in the array.

Returns
int — A zero-based index position of the item in the array. If the searchElement argument is not found, the return value is -1.

See also

Array.indexOf()
=== (strict equality)

Example
The following example displays the position of the specified array:
package {
    import flash.display.Sprite;
    public class Array_lastIndexOf extends Sprite {
        public function Array_lastIndexOf() {
            var arr:Array = new Array(123,45,6789,123,984,323,123,32);

            var index:int = arr.indexOf(123);
            trace(index); // 0

            var index2:int = arr.lastIndexOf(123);
            trace(index2); // 6
        }
    }
}

map () method
AS3 function map(callback:Function, thisObject:* = null):Array

Executes a function on each item in an array, and constructs a new array of items corresponding to the results of the function on each item in the original array.

For this method, the second parameter, thisObject, must be null if the first parameter, callback, is a method closure. Suppose you create a function in a movie clip called me:

     function myFunction(){
        //your code here
     }

Suppose you then use the filter() method on an array called myArray:

     myArray.filter(myFunction, me);

Because myFunction is a member of the Timeline class, which cannot be overridden by me, Flash Player will throw an exception. You can avoid this runtime error by assigning the function to a variable, as follows:

     var foo:Function = myFunction() {
         //your code here
         };
     myArray.filter(foo, me);
Parameters
callback:Function — The function to run on each item in the array. This function can contain a simple command (such as changing the case of an array of strings) or a more complex operation, and is invoked with three arguments; the value of an item, the index of an item, and the Array object:
    function callback(item:*, index:int, array:Array):void;
thisObject:* (default = null) — An object to use as this for the function.

Returns
Array — A new array that contains the results of the function on each item in the original array.

See also

Array.filter()

Example
The following example changes all items in the array to use uppercase letters:
package {
    import flash.display.Sprite;
    public class Array_map extends Sprite {
        public function Array_map() {
            var arr:Array = new Array("one", "two", "Three");
            trace(arr); // one,two,Three

            var upperArr:Array = arr.map(toUpper);
            trace(upperArr); // ONE,TWO,THREE
        }
        private function toUpper(element:*, index:int, arr:Array):String {
            return String(element).toUpperCase();
        }
    }
}

pop () method
AS3 function pop():Object

Removes the last element from an array and returns the value of that element.

Returns
Object — The value of the last element (of any data type) in the specified array.

See also

Array.push()
Array.shift()
Array.unshift()

Example
The following code creates an Array object letters with elements a, b, and c. The last element (c) is then removed from the array using the pop() method and assigned to the String object letter.

var letters:Array = new Array("a", "b", "c");
trace(letters); // a,b,c
var letter:String = letters.pop();
trace(letters); // a,b
trace(letter);     // c

push () method
AS3 function push(... args):uint

Adds one or more elements to the end of an array and returns the new length of the array.

Parameters
... args — One or more values to append to the array.

Returns
uint — An integer representing the length of the new array.

See also

Array.pop()
Array.shift()
Array.unshift()

Example
The following code creates an empty Array object letters and then populates the array with the elements a, b, and c using the push() method.

var letters:Array = new Array();

letters.push("a");
letters.push("b");
letters.push("c");

trace(letters.toString()); // a,b,c

The following code creates an Array object letters, which is initially populated with the element a. The push() method is then used once to add the elements b and c to the end of the array, which is three elements after the push.

var letters:Array = new Array("a");
var count:uint = letters.push("b", "c");

trace(letters); // a,b,c
trace(count);   // 3

reverse () method
AS3 function reverse():Array

Reverses the array in place.

Returns
Array — The new array.

Example
The following code creates an Array object letters with elements a, b, and c. The order of the array elements is then reversed using the reverse() method to produce the array [c,b,a].

var letters:Array = new Array("a", "b", "c");
trace(letters); // a,b,c
letters.reverse();
trace(letters); // c,b,a

shift () method
AS3 function shift():Object

Removes the first element from an array and returns that element. The remaining array elements are moved from their original position, i, to i-1.

Returns
Object — The first element (of any data type) in an array.

See also

Array.pop()
Array.push()
Array.unshift()

Example
The following code creates the Array object letters with elements a, b, and c. The shift() method is then used to remove the first element (a) from letters and assign it to the string firstLetter.

var letters:Array = new Array("a", "b", "c");
var firstLetter:String = letters.shift();
trace(letters);     // b,c
trace(firstLetter); // a

slice () method
AS3 function slice(startIndex:int = 0, endIndex:int = -1):Array

Returns a new array that consists of a range of elements from the original array, without modifying the original array. The returned array includes the startIndex element and all elements up to, but not including, the endIndex element.

If you don't pass any parameters, a duplicate of the original array is created.

Parameters
startIndex:int (default = 0) — A number specifying the index of the starting point for the slice. If start is a negative number, the starting point begins at the end of the array, where -1 is the last element.
endIndex:int (default = -1) — A number specifying the index of the ending point for the slice. If you omit this parameter, the slice includes all elements from the starting point to the end of the array. If end is a negative number, the ending point is specified from the end of the array, where -1 is the last element.

Returns
Array — An array that consists of a range of elements from the original array.

Example
The following code creates an Array object letters with elements [a,b,c,d,e,f]. The array someLetters is then created by calling the slice() method on elements one (b) through three (d), resulting in an array with elements b and c.

var letters:Array = new Array("a", "b", "c", "d", "e", "f");
var someLetters:Array = letters.slice(1,3);

trace(letters);     // a,b,c,d,e,f
trace(someLetters); // b,c

The following code creates an Array object letters with elements [a,b,c,d,e,f].The array someLetters is then created by calling the slice() method on element two (c), resulting in an array with elements [c,d,e,f].

var letters:Array = new Array("a", "b", "c", "d", "e", "f");
var someLetters:Array = letters.slice(2);

trace(letters);     // a,b,c,d,e,f
trace(someLetters); // c,d,e,f

The following code creates an Array object letters with elements [a,b,c,d,e,f]. The array someLetters is then created by calling the slice() method on the second to last element from the end (e), resulting in an array with elements e and f.

var letters:Array = new Array("a", "b", "c", "d", "e", "f");
var someLetters:Array = letters.slice(-2);

trace(letters);     // a,b,c,d,e,f
trace(someLetters); // e,f

some () method
AS3 function some(callback:Function, thisObject:* = null):Boolean

Executes a test function on each item in the array until an item is reached that returns true. Use this method to determine whether any items in an array meet a criterion, such as having a value less than a particular number.

For this method, the second parameter, thisObject, must be null if the first parameter, callback, is a method closure. Suppose you create a function in a movie clip called me:

     function myFunction(){
        //your code here
     }

Suppose you then use the filter() method on an array called myArray:

     myArray.filter(myFunction, me);

Because myFunction is a member of the Timeline class, which cannot be overridden by me, Flash Player will throw an exception. You can avoid this runtime error by assigning the function to a variable, as follows:

     var foo:Function = myFunction() {
         //your code here
         };
     myArray.filter(foo, me);
Parameters
callback:Function — The function to run on each item in the array. This function can contain a simple comparison (for example item < 20) or a more complex operation, and is invoked with three arguments; the value of an item, the index of an item, and the Array object:
    function callback(item:*, index:int, array:Array):void;
thisObject:* (default = null) — An object to use as this for the function.

Returns
Boolean — A Boolean value of true if any items in the array return true for the specified function; otherwise false.

See also

every()

Example
The following example displays which values are undefined:
package {
    import flash.display.Sprite;
    public class Array_some extends Sprite {
        public function Array_some() {
            var arr:Array = new Array();
            arr[0] = "one";
            arr[1] = "two";
            arr[3] = "four";
            var isUndef:Boolean = arr.some(isUndefined);
            if (isUndef) {
                trace("array contains undefined values: " + arr);
            } else {
                trace("array contains no undefined values.");
            }
        }
        private function isUndefined(element:*, index:int, arr:Array):Boolean {
            return (element == undefined);
        }
    }
}

sort () method
AS3 function sort(... args):Array

Sorts the elements in an array. This method sorts according to Unicode values. (ASCII is a subset of Unicode.)

By default, Array.sort() works in the following way:

  • Sorting is case-sensitive (Z precedes a).
  • Sorting is ascending (a precedes b).
  • The array is modified to reflect the sort order; multiple elements that have identical sort fields are placed consecutively in the sorted array in no particular order.
  • All elements, regardless of data type, are sorted as if they were strings, so 100 precedes 99, because "1" is a lower string value than "9".

To sort an array by using settings that deviate from the default settings, you can either use one of the sorting options described in the sortOptions portion of the ...args parameter description, or you can create your own custom function to do the sorting. If you create a custom function, you call the sort() method, and use the name of your custom function as the first argument (compareFunction)

Parameters
... args — The arguments specifying a comparison function and one or more values that determine the behavior of the sort.

This method uses the syntax and argument order Array.sort(compareFunction, sortOptions) with the arguments defined as follows:

  • compareFunction - A comparison function used to determine the sorting order of elements in an array. This argument is optional. A comparison function should take two arguments to compare. Given the elements A and B, the result of compareFunction can have one of the following three values:
    • -1, if A should appear before B in the sorted sequence
    • 0, if A equals B
    • 1, if A should appear after B in the sorted sequence
  • sortOptions - One or more numbers or defined constants, separated by the | (bitwise OR) operator, that change the behavior of the sort from the default. This argument is optional. The following values are acceptable for sortOptions:
    • 1 or Array.CASEINSENSITIVE
    • 2 or Array.DESCENDING
    • 4 or Array.UNIQUESORT
    • 8 or Array.RETURNINDEXEDARRAY
    • 16 or Array.NUMERIC
    For more information, see the Array.sortOn() method.

Note: The Array.sort() method is defined in the ECMAScript (ECMA-262) edition 3 language specification, but the array sorting options introduced in Flash Player 7 are Flash-specific extensions to ECMA-262.

Returns
Array — The return value depends on whether you pass any arguments, as described in the following list:
  • If you specify a value of 4 or Array.UNIQUESORT for the sortOptions argument of the ...args parameter and two or more elements being sorted have identical sort fields, Flash returns a value of 0 and does not modify the array.
  • If you specify a value of 8 or Array.RETURNINDEXEDARRAY for the sortOptions argument of the ...args parameter, Flash returns a sorted numeric array of the indices that reflects the results of the sort and does not modify the array.
  • Otherwise, Flash returns nothing and modifies the array to reflect the sort order.

See also

| (bitwise OR)
Array.sortOn()

Example
The following code creates the Array object vegetables with elements [spinach, green pepper, cilantro, onion, avocado]. The array is then sorted by the sort() method, which is called with no parameters. The result is vegetables sorted in alphabetical order ([avocado, cilantro, green pepper, onion, spinach]).

var vegetables:Array = new Array("spinach",
                 "green pepper",
                 "cilantro",
                 "onion",
                 "avocado");

trace(vegetables); // spinach,green pepper,cilantro,onion,avocado
vegetables.sort();
trace(vegetables); // avocado,cilantro,green pepper,onion,spinach

The following code creates the Array object vegetables with elements [spinach, green pepper, Cilantro, Onion, and Avocado]. The array is then sorted by the sort() method, which is called with no parameters the first time; the result is [Avocado,Cilantro,Onion,green pepper,spinach]. Then sort() is called on vegetables again with the CASEINSENSITIVE constant as a parameter. The result is vegetables sorted in alphabetical order ([Avocado, Cilantro, green pepper, Onion, spinach]).

var vegetables:Array = new Array("spinach",
                 "green pepper",
                 "Cilantro",
                 "Onion",
                 "Avocado");

vegetables.sort();
trace(vegetables); // Avocado,Cilantro,Onion,green pepper,spinach
vegetables.sort(Array.CASEINSENSITIVE);
trace(vegetables); // Avocado,Cilantro,green pepper,Onion,spinach

The following code creates the empty Array object vegetables, which is then populated through five calls to push(). Each time push() is called, a new Vegetable object is created by a call to the Vegetable() constructor, which accepts a String (name) and Number (price) object. Calling push() five times with the values shown results in the following array: [lettuce:1.49, spinach:1.89, asparagus:3.99, celery:1.29, squash:1.44]. The sort() method is then used to sort the array, resulting in the array [asparagus:3.99, celery:1.29, lettuce:1.49, spinach:1.89, squash:1.44].
var vegetables:Array = new Array();
vegetables.push(new Vegetable("lettuce", 1.49));
vegetables.push(new Vegetable("spinach", 1.89));
vegetables.push(new Vegetable("asparagus", 3.99));
vegetables.push(new Vegetable("celery", 1.29));
vegetables.push(new Vegetable("squash", 1.44));

trace(vegetables);
// lettuce:1.49, spinach:1.89, asparagus:3.99, celery:1.29, squash:1.44

vegetables.sort();

trace(vegetables);
// asparagus:3.99, celery:1.29, lettuce:1.49, spinach:1.89, squash:1.44

//The following code defines the Vegetable class
class Vegetable {
    private var name:String;
    private var price:Number;

    public function Vegetable(name:String, price:Number) {
        this.name = name;
        this.price = price;
    }

    public function toString():String {
        return " " + name + ":" + price;
    }
}

The following example is exactly the same as the previous one, except that the sort() method is used with a custom sort function (sortOnPrice), which sorts according to price instead of alphabetically. Note that the new function getPrice() extracts the price.

var vegetables:Array = new Array();
vegetables.push(new Vegetable("lettuce", 1.49));
vegetables.push(new Vegetable("spinach", 1.89));
vegetables.push(new Vegetable("asparagus", 3.99));
vegetables.push(new Vegetable("celery", 1.29));
vegetables.push(new Vegetable("squash", 1.44));

trace(vegetables);
// lettuce:1.49, spinach:1.89, asparagus:3.99, celery:1.29, squash:1.44

vegetables.sort(sortOnPrice);

trace(vegetables);
// celery:1.29, squash:1.44, lettuce:1.49, spinach:1.89, asparagus:3.99

function sortOnPrice(a:Vegetable, b:Vegetable):Number {
    var aPrice:Number = a.getPrice();
    var bPrice:Number = b.getPrice();

    if(aPrice > bPrice) {
        return 1;
    } else if(aPrice < bPrice) {
        return -1;
    } else  {
        //aPrice == bPrice
        return 0;
    }
}

// The following code defines the Vegetable class and should be in a separate package.
class Vegetable {
    private var name:String;
    private var price:Number;

    public function Vegetable(name:String, price:Number) {
        this.name = name;
        this.price = price;
    }

    public function getPrice():Number {
        return price;
    }

    public function toString():String {
        return " " + name + ":" + price;
    }
}

The following code creates the Array object numbers with elements [3,5,100,34,10]. A call to sort() without any parameters sorts alphabetically, producing the undesired result [10,100,3,34,5]. To properly sort numeric values, you must pass the constant NUMERIC to the sort() method, which sorts numbers as follows: [3,5,10,34,100].

Note: The default behavior of the sort() function is to handle each entity as a string. The Array.NUMERIC argument does not actually convert other data types to the Number data type; it simply allows the sort algorithm to recognize numbers.

var numbers:Array = new Array(3,5,100,34,10);

trace(numbers); // 3,5,100,34,10
numbers.sort();
trace(numbers); // 10,100,3,34,5
numbers.sort(Array.NUMERIC);
trace(numbers); // 3,5,10,34,100

sortOn () method
AS3 function sortOn(fieldName:Object, options:Object = null):Array

Sorts the elements in an array according to one or more fields in the array. The array should have the following characteristics:

  • The array is an indexed array, not an associative array.
  • Each element of the array holds an object with one or more properties.
  • All of the objects have at least one property in common, the values of which can be used to sort the array. Such a property is called a field.

If you pass multiple fieldName parameters, the first field represents the primary sort field, the second represents the next sort field, and so on. Flash sorts according to Unicode values. (ASCII is a subset of Unicode.) If either of the elements being compared does not contain the field that is specified in the fieldName parameter, the field is assumed to be set to undefined, and the elements are placed consecutively in the sorted array in no particular order.

By default, Array.sortOn() works in the following way:

  • Sorting is case-sensitive (Z precedes a).
  • Sorting is ascending (a precedes b).
  • The array is modified to reflect the sort order; multiple elements that have identical sort fields are placed consecutively in the sorted array in no particular order.
  • Numeric fields are sorted as if they were strings, so 100 precedes 99, because "1" is a lower string value than "9".

Flash Player 7 added the options parameter, which you can use to override the default sort behavior. To sort a simple array (for example, an array with only one field), or to specify a sort order that the options parameter doesn't support, use Array.sort().

To pass multiple flags, separate them with the bitwise OR (|) operator:

  my_array.sortOn(someFieldName, Array.DESCENDING | Array.NUMERIC);

Flash Player 8 added the ability to specify a different sorting option for each field when you sort by more than one field. In Flash Player 8 and later, the options parameter accepts an array of sort options such that each sort option corresponds to a sort field in the fieldName parameter. The following example sorts the primary sort field, a, using a descending sort; the secondary sort field, b, using a numeric sort; and the tertiary sort field, c, using a case-insensitive sort:

  Array.sortOn (["a", "b", "c"], [Array.DESCENDING, Array.NUMERIC, Array.CASEINSENSITIVE]);

Note: The fieldName and options arrays must have the same number of elements; otherwise, the options array is ignored. Also, the Array.UNIQUESORT and Array.RETURNINDEXEDARRAY options can be used only as the first element in the array; otherwise, they are ignored.

Parameters
fieldName:Object — A string that identifies a field to be used as the sort value, or an array in which the first element represents the primary sort field, the second represents the secondary sort field, and so on.
options:Object (default = null) — One or more numbers or names of defined constants, separated by the bitwise OR (|) operator, that change the sorting behavior. The following values are acceptable for the options parameter:
  • Array.CASEINSENSITIVE or 1
  • Array.DESCENDING or 2
  • Array.UNIQUESORT or 4
  • Array.RETURNINDEXEDARRAY or 8
  • Array.NUMERIC or 16

Code hinting is enabled if you use the string form of the flag (for example, DESCENDING) rather than the numeric form (2).

Returns
Array — The return value depends on whether you pass any parameters:
  • If you specify a value of 4 or Array.UNIQUESORT for the options parameter, and two or more elements being sorted have identical sort fields, a value of 0 is returned and the array is not modified.
  • If you specify a value of 8 or Array.RETURNINDEXEDARRAY for the options parameter, an array is returned that reflects the results of the sort and the array is not modified.
  • Otherwise, nothing is returned and the array is modified to reflect the sort order.

See also

| (bitwise OR)
Array.sort()

Example
The following code creates an empty Array object vegetables and the array is then populated using five calls to push(). Each time push() is called, a new Vegetable object is created by calling the Vegetable() constructor, which accepts a String (name) and Number (price) object. Calling push() five times with the values shown results in the following array: [lettuce:1.49, spinach:1.89, asparagus:3.99, celery:1.29, squash:1.44]. The sortOn() method is then used with the name parameter to produce the following array: [asparagus:3.99, celery:1.29, lettuce:1.49, spinach:1.89, squash:1.44]. The sortOn() method is then called again with the price parameter, and the NUMERIC and DESCENDING constants to produce an array sorted by numbers in descending order: [asparagus:3.99, spinach:1.89, lettuce:1.49, squash:1.44, celery:1.29].

var vegetables:Array = new Array();
vegetables.push(new Vegetable("lettuce", 1.49));
vegetables.push(new Vegetable("spinach", 1.89));
vegetables.push(new Vegetable("asparagus", 3.99));
vegetables.push(new Vegetable("celery", 1.29));
vegetables.push(new Vegetable("squash", 1.44));

trace(vegetables);
// lettuce:1.49, spinach:1.89, asparagus:3.99, celery:1.29, squash:1.44

vegetables.sortOn("name");
trace(vegetables);
// asparagus:3.99, celery:1.29, lettuce:1.49, spinach:1.89, squash:1.44

vegetables.sortOn("price", Array.NUMERIC | Array.DESCENDING);
trace(vegetables);
// asparagus:3.99, spinach:1.89, lettuce:1.49, squash:1.44, celery:1.29

class Vegetable {
    public var name:String;
    public var price:Number;

    public function Vegetable(name:String, price:Number) {
        this.name = name;
        this.price = price;
    }

    public function toString():String {
        return " " + name + ":" + price;
    }
}

The following code creates an empty Array object records and the array is then populated using three calls to push(). Each time push() is called, the strings name and city and a zip number are added to records. Three for loops are used to print the array elements. The first for loop prints the elements in the order in which they were added. The second for loop is run after records has been sorted by name and then city using the sortOn() method. The third for loop produces different output because records is re-sorted by city then by name.

var records:Array = new Array();
records.push({name:"john", city:"omaha", zip:68144});
records.push({name:"john", city:"kansas city", zip:72345});
records.push({name:"bob", city:"omaha", zip:94010});

for(var i:uint = 0; i < records.length; i++) {
    trace(records[i].name + ", " + records[i].city);
}
// Results:
// john, omaha
// john, kansas city
// bob, omaha

trace("records.sortOn('name', 'city');");
records.sortOn(["name", "city"]);
for(var i:uint = 0; i < records.length; i++) {
    trace(records[i].name + ", " + records[i].city);
}
// Results:
// bob, omaha
// john, kansas city
// john, omaha

trace("records.sortOn('city', 'name');");
records.sortOn(["city", "name"]);
for(var i:uint = 0; i < records.length; i++) {
    trace(records[i].name + ", " + records[i].city);
}
// Results:
// john, kansas city
// bob, omaha
// john, omaha

The following code creates an empty Array object users and the array is then populated using four calls to push(). Each time push() is called, a User object is created with the User() constructor and a name string and age uint are added to users. The resulting array set is [Bob:3,barb:35,abcd:3,catchy:4].

The array is then sorted in the following ways:

  1. By name only, producing the array [Bob:3,abcd:3,barb:35,catchy:4]
  2. By name and using the CASEINSENSITIVE constant, producing the array [abcd:3,barb:35,Bob:3,catchy:4]
  3. By name and using the CASEINSENSITIVE and DESCENDING constants, producing the array [catchy:4,Bob:3,barb:35,abcd:3]
  4. By age only, producing the array [abcd:3,Bob:3,barb:35,catchy:4]
  5. By age and using the NUMERIC constant, producing the array [Bob:3,abcd:3,catchy:4,barb:35]
  6. By age and using the DESCENDING and NUMERIC constants, producing the array [barb:35,catchy:4,Bob:3,abcd:3]

An array called indices is then created and assigned the results of a sort by age and using the NUMERIC and RETURNINDEXEDARRAY constants, resulting in the array [Bob:3,abcd:3,catchy:4,barb:35], which is then printed out using a for loop.

class User {
    public var name:String;
    public var age:Number;
    public function User(name:String, age:uint) {
        this.name = name;
        this.age = age;
    }

    public function toString():String {
        return this.name + ":" + this.age;
    }
}

var users:Array = new Array();
users.push(new User("Bob", 3));
users.push(new User("barb", 35));
users.push(new User("abcd", 3));
users.push(new User("catchy", 4));

trace(users); // Bob:3,barb:35,abcd:3,catchy:4

users.sortOn("name");
trace(users); // Bob:3,abcd:3,barb:35,catchy:4

users.sortOn("name", Array.CASEINSENSITIVE);
trace(users); // abcd:3,barb:35,Bob:3,catchy:4

users.sortOn("name", Array.CASEINSENSITIVE | Array.DESCENDING);
trace(users); // catchy:4,Bob:3,barb:35,abcd:3

users.sortOn("age");
trace(users); // abcd:3,Bob:3,barb:35,catchy:4

users.sortOn("age", Array.NUMERIC);
trace(users); // Bob:3,abcd:3,catchy:4,barb:35

users.sortOn("age", Array.DESCENDING | Array.NUMERIC);
trace(users); // barb:35,catchy:4,Bob:3,abcd:3

var indices:Array = users.sortOn("age", Array.NUMERIC | Array.RETURNINDEXEDARRAY);
var index:uint;
for(var i:uint = 0; i < indices.length; i++) {
    index = indices[i];
    trace(users[index].name, ": " + users[index].age);
}

// Results:
// Bob : 3
// abcd : 3
// catchy : 4
// barb : 35

splice () method
AS3 function splice(startIndex:int, deleteCount:uint, ... values):Array

Adds elements to and removes elements from an array. This method modifies the array without making a copy.

Note: To override this method in a subclass of Array, use ...args for the parameters, as this example shows:

  public override function splice(...args) {
    // your statements here
  }
Parameters
startIndex:int — An integer that specifies the index of the element in the array where the insertion or deletion begins. You can use a negative integer to specify a position relative to the end of the array (for example, -1 is the last element of the array).
deleteCount:uint — An integer that specifies the number of elements to be deleted. This number includes the element specified in the startIndex parameter. If you do not specify a value for the deleteCount parameter, the method deletes all of the values from the startIndex element to the last element in the array. If the value is 0, no elements are deleted.
... values — An optional list of one or more comma-separated values, or an array, to insert into the array at the position specified in the startIndex parameter.

Returns
Array — An array containing the elements that were removed from the original array.

Example
The following code creates the Array object vegetables with the elements [spinach, green pepper, cilantro, onion, avocado]. The splice() method is then called with the parameters 2 and 2, which assigns cilantro and onion to the spliced array. The vegetables array then contains [spinach,green pepper,avocado]. The splice() method is called a second time using the parameters 1, 0, and the spliced array to assign [spinach,cilantro,onion,green pepper,avocado] to vegetables.

var vegetables:Array = new Array("spinach",
                 "green pepper",
                 "cilantro",
                 "onion",
                 "avocado");

var spliced:Array = vegetables.splice(2, 2);
trace(vegetables); // spinach,green pepper,avocado
trace(spliced);    // cilantro,onion

vegetables.splice(1, 0, spliced);
trace(vegetables); // spinach,cilantro,onion,green pepper,avocado

toLocaleString () method
public function toLocaleString():String

Returns a string that represents the elements in the specified array. Every element in the array, starting with index 0 and ending with the highest index, is converted to a concatenated string and separated by commas. In the ActionScript 3.0 implementation, this method returns the same value as the Array.toString() method.

Returns
String — A string of array elements.

See also

Array.toString()
toString () method
public function toString():String

Returns a string that represents the elements in the specified array. Every element in the array, starting with index 0 and ending with the highest index, is converted to a concatenated string and separated by commas. To specify a custom separator, use the Array.join() method.

Returns
String — A string of array elements.

See also

String.split()
Array.join()

Example
The following code creates an Array, converts the values to strings, and stores them in the vegnums variable of the String data type.

var vegetables:Array = new Array();
vegetables.push(1);
vegetables.push(2);
vegetables.push(3);
vegetables.push(4);
vegetables.push(5);
var vegnums:String = vegetables.toString();
trace(vegnums+",6");
// 1,2,3,4,5,6

unshift () method
AS3 function unshift(... args):uint

Adds one or more elements to the beginning of an array and returns the new length of the array. The other elements in the array are moved from their original position, i, to i+1.

Parameters
... args — One or more numbers, elements, or variables to be inserted at the beginning of the array.

Returns
uint — An integer representing the new length of the array.

See also

Array.pop()
Array.push()
Array.shift()

Example
The following code creates the empty Array object names. The strings Bill and Jeff are added by the push() method, and then the strings Alfred and Kyle are added to the beginning of names by two calls to the unshift() method.

var names:Array = new Array();
names.push("Bill");
names.push("Jeff");

trace(names); // Bill,Jeff

names.unshift("Alfred");
names.unshift("Kyle");

trace(names); // Kyle,Alfred,Bill,Jeff

Constant detail
CASEINSENSITIVE constant
public static const CASEINSENSITIVE:uint = 1

Specifies case-insensitive sorting for the Array class sorting methods. You can use this constant for the options parameter in the sort() or sortOn() method.

The value of this constant is 1.

See also

Array.sort()
Array.sortOn()
DESCENDING constant
public static const DESCENDING:uint = 2

Specifies descending sorting for the Array class sorting methods. You can use this constant for the options parameter in the sort() or sortOn() method.

The value of this constant is 2.

See also

Array.sort()
Array.sortOn()
NUMERIC constant
public static const NUMERIC:uint = 16

Specifies numeric (instead of character-string) sorting for the Array class sorting methods. Including this constant in the options parameter causes the sort() and sortOn() methods to sort numbers as numeric values, not as strings of numeric characters. Without the NUMERIC constant, sorting treats each array element as a character string and produces the results in Unicode order.

For example, given the array of values [2005, 7, 35], if the NUMERIC constant is not included in the options parameter, the sorted array is [2005, 35, 7], but if the NUMERIC constant is included, the sorted array is [7, 35, 2005].

This constant applies only to numbers in the array; it does not apply to strings that contain numeric data such as ["23", "5"].

The value of this constant is 16.

See also

Array.sort()
Array.sortOn()
RETURNINDEXEDARRAY constant
public static const RETURNINDEXEDARRAY:uint = 8

Specifies that a sort returns an array that consists of array indices. You can use this constant for the options parameter in the sort() or sortOn() method, so you have access to multiple views of the array elements while the original array is unmodified.

The value of this constant is 8.

See also

Array.sort()
Array.sortOn()
UNIQUESORT constant
public static const UNIQUESORT:uint = 4

Specifies the unique sorting requirement for the Array class sorting methods. You can use this constant for the options parameter in the sort() or sortOn() method. The unique sorting option terminates the sort if any two elements or fields being sorted have identical values.

The value of this constant is 4.

See also

Array.sort()
Array.sortOn()
Examples

The following example creates a new Array object myArr with no arguments and an initial length of 0:
package {
    import flash.display.Sprite;

    public class ArrayExample extends Sprite {
        public function ArrayExample() {
            var myArr:Array = new Array();
            trace(myArr.length); // 0
        }
    }
}


Boolean (Flex™ 2 Language Reference)

Class Boolean | Properties | Methods | Examples
Package | Top Level
Class | public final class Boolean
Inheritance | Boolean Inheritance Object

A Boolean object is a data type that can have one of two values, either true or false, used for logical operations. Use the Boolean class to retrieve the primitive data type or string representation of a Boolean object.

To create a Boolean object, you can use the constructor or the global function, or assign a literal value. It doesn't matter which technique you use; in ActionScript 3.0, all three techniques are equivalent. (This is different from JavaScript, where a Boolean object is distinct from the Boolean primitive type.)

The following lines of code are equivalent:

var flag:Boolean = true;
var flag:Boolean = new Boolean(true);
var flag:Boolean = Boolean(true);

View the examples.

See also

Data type descriptions
Type conversions

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Boolean(expression:Object = false) Creates a Boolean object with the specified value. | Boolean
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns the string representation ("true" or "false") of the Boolean object. | Boolean
 | valueOf():Boolean Returns true if the value of the specified Boolean object is true; false otherwise. | Boolean
Constructor detail
Boolean () constructor
public function Boolean(expression:Object = false)

Creates a Boolean object with the specified value. If you omit the expression parameter, the Boolean object is initialized with a value of false. If you specify a value for the expression parameter, the method evaluates it and returns the result as a Boolean value according to the rules in the global Boolean() function.

Parameters
expression:Object (default = false) — Any expression.

See also

Boolean()
Data type descriptions
Type conversions

Example
The following code creates a new Boolean object, initialized to a value of false called myBoolean:
 var myBoolean:Boolean = new Boolean();

Method detail
toString () method
AS3 function toString():String

Returns the string representation ("true" or "false") of the Boolean object. The output is not localized, and is "true" or "false" regardless of the system language.

Returns
String — The string "true" or "false".

Example
This example creates a variable of type Boolean and then uses the toString() method to convert the value to a string for use in an array of strings:
  var myStringArray:Array = new Array("yes", "could be");
  var myBool:Boolean = 0;
  myBool.toString();
  myStringArray.push(myBool);
  trace(myStringArray); // yes,could be,false

valueOf () method
AS3 function valueOf():Boolean

Returns true if the value of the specified Boolean object is true; false otherwise.

Returns
Boolean — A Boolean value.

Example
The following example shows how this method works, and also shows that the value of a new Boolean object is false:
  var myBool:Boolean = new Boolean();
  trace(myBool.valueOf());   // false
  myBool = (6==3+3);
  trace(myBool.valueOf());   // true

Examples

The following example toggles and displays each corresponding value for the Boolean object:
 package {
    import flash.display.Sprite;

    public class BooleanExample extends Sprite {
        private var flag:Boolean;

        public function BooleanExample() {
            trace(flag);    // false
            toggle();
            trace(flag);    // true
            toggle();
            trace(flag);    // false
        }

        private function toggle():void{
            flag = !flag;
        }
    }
}


Class (Flex™ 2 Language Reference)

Class Class | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class Class
Inheritance | Class Inheritance Object

A Class object is created for each class definition in a program. Every Class object is an instance of the Class class. The Class object contains the static properties and methods of the class. The class object creates instances of the class when invoked using the new operator.

Some methods, such as flash.net.getClassByAlias(), return an object of type Class. Other methods may have a parameter of type Class, such as flash.net.registerClassAlias().

The class name is the reference to the Class object, as this example shows:

 class Foo {
 }

The class Foo{} statement is the class definition that creates the Class object Foo. Additionally, the statement new Foo() will create a new instance of class Foo, and the result will be of type Foo.

Use the class statement to declare your classes. Class objects are useful for advanced techniques, such as assigning classes to an existing instance object at runtime, as shown in the "Examples" section below.

Any static properties and methods of a class live on the class's Class object. Class, itself, declares prototype.

Generally, you do not need to declare or create variables of type Class manually. However, in the following code, a class is assigned as a public Class property circleClass, and you can refer to this Class property as a property of the main Library class:

 package {
  import flash.display.Sprite;
  public class Library extends Sprite {

   public var circleClass:Class = Circle;
   public function Library() {
   }
  }
 }

 import flash.display.Shape;
 class Circle extends Shape {
  public function Circle(color:uint = 0xFFCC00, radius:Number = 10) {
   graphics.beginFill(color);
   graphics.drawCircle(radius, radius, radius);
  }
 }

Another SWF file can load the resulting Library.swf file and then instantiate objects of type Circle. The following example shows one way to get access to a child SWF file's assets. (Other techniques include using flash.utils.getDefnitionByName() or importing stub definitions of the child SWF file.)

 package {
  import flash.display.Sprite;
  import flash.display.Shape;
  import flash.display.Loader;
  import flash.net.URLRequest;
  import flash.events.Event;
  public class LibaryLoader extends Sprite {
   public function LibaryLoader() {
    var ldr:Loader = new Loader();
    var urlReq:URLRequest = new URLRequest("Library.swf");
    ldr.load(urlReq);
    ldr.contentLoaderInfo.addEventListener(Event.COMPLETE, loaded);
   }
   private function loaded(event:Event):void {
    var library:Object = event.target.content;
    var circle:Shape = new library.circleClass();
    addChild(circle);
   }
  }
 }

In ActionScript 3.0, you can create embedded classes for external assets (such as images, sounds, or fonts) that are compiled into SWF files. In earlier versions of ActionScript, you associated those assets using a linkage ID with the MovieClip.attachMovie() method. In ActionScript 3.0, each embedded asset is represented by a unique embedded asset class. Therefore, you can use the new operator to instantiate the asset's associated class and call methods and properties on that asset.

For example, if you are using an MXML compiler to generate SWF files, you would create an embedded class as follows:

     [Embed(source="bratwurst.jpg")]
     public var imgClass:Class;

And, to instantiate it, you write the following:

     var myImg:Bitmap = new imgClass();

View the examples.

See also

Object.prototype
new operator
Classes
Advanced topics

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Examples

The following example shows how to use Class objects to defer until runtime the decision about which class to instantiate using the following steps:
  1. Declare two classes as ClassA and ClassB.
  2. Declare a variable of type Class named classToConstruct and one of type Boolean chooseClassA, which is set to true in this case, but your code could use a custom test expression to set the value of that variable.
package {
    import flash.display.Sprite;

    public class ClassExample extends Sprite {
        public function ClassExample() {
            var classToConstruct:Class;
            var classInstance:Object;

            classToConstruct = ClassA;
            classInstance = new classToConstruct();
            trace(classInstance);    // [object ClassA]

            classToConstruct = ClassB;
            classInstance = new classToConstruct();
            trace(classInstance);    // [object ClassB]
        }
    }
}

class ClassA {
}

class ClassB {
}


Date (Flex™ 2 Language Reference)

Class Date | Properties | Methods | Examples
Package | Top Level
Class | public final dynamic class Date
Inheritance | Date Inheritance Object

The Date class represents date and time information. An instance of the Date class represents a particular point in time for which the properties such as month, day, hours, and seconds can be queried or modified. The Date class lets you retrieve date and time values relative to universal time (Greenwich mean time, now called universal time or UTC) or relative to local time, which is determined by the local time zone setting on the operating system that is running Flash Player. The methods of the Date class are not static but apply only to the individual Date object specified when the method is called. The Date.UTC() and Date.parse() methods are exceptions; they are static methods.

The Date class handles daylight saving time differently, depending on the operating system and Flash Player version. Flash Player 6 and later versions handle daylight saving time on the following operating systems in these ways:

  • Windows - the Date object automatically adjusts its output for daylight saving time. The Date object detects whether daylight saving time is employed in the current locale, and if so, it detects the standard-to-daylight saving time transition date and times. However, the transition dates currently in effect are applied to dates in the past and the future, so the daylight saving time bias might calculate incorrectly for dates in the past when the locale had different transition dates.
  • Mac OS X - the Date object automatically adjusts its output for daylight saving time. The time zone information database in Mac OS X is used to determine whether any date or time in the present or past should have a daylight saving time bias applied.
  • Mac OS 9 - the operating system provides only enough information to determine whether the current date and time should have a daylight saving time bias applied. Accordingly, the date object assumes that the current daylight saving time bias applies to all dates and times in the past or future.

Flash Player 5 handles daylight saving time on the following operating systems as follows:

  • Windows - the U.S. rules for daylight saving time are always applied, which leads to incorrect transitions in Europe and other areas that employ daylight saving time but have different transition times than the U.S. Flash correctly detects whether daylight saving time is used in the current locale.

To use the Date class, construct a Date instance using the new operator.

ActionScript 3.0 adds several new accessor properties that can be used in place of many Date class methods that access or modify Date instances. ActionScript 3.0 also includes several new variations of the toString() method that are included for ECMA-262 3rd Edition compliance, including: Date.toLocaleString(), Date.toTimeString(), Date.toLocaleTimeString(), Date.toDateString(), and Date.toLocaleDateString().

To compute relative time or time elapsed, see the getTimer() method in the flash.utils package.

View the examples.

See also

flash.utils.getTimer()
Working with Dates and Times

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | date : Number The day of the month (an integer from 1 to 31) specified by a Date object according to local time. | Date
 | dateUTC : Number The day of the month (an integer from 1 to 31) of a Date object according to universal time (UTC). | Date
 | day : Number [read-only] The day of the week (0 for Sunday, 1 for Monday, and so on) specified by this Date according to local time. | Date
 | dayUTC : Number [read-only] The day of the week (0 for Sunday, 1 for Monday, and so on) of this Date according to universal time (UTC). | Date
 | fullYear : Number The full year (a four-digit number, such as 2000) of a Date object according to local time. | Date
 | fullYearUTC : Number The four-digit year of a Date object according to universal time (UTC). | Date
 | hours : Number The hour (an integer from 0 to 23) of the day portion of a Date object according to local time. | Date
 | hoursUTC : Number The hour (an integer from 0 to 23) of the day of a Date object according to universal time (UTC). | Date
 | milliseconds : Number The milliseconds (an integer from 0 to 999) portion of a Date object according to local time. | Date
 | millisecondsUTC : Number The milliseconds (an integer from 0 to 999) portion of a Date object according to universal time (UTC). | Date
 | minutes : Number The minutes (an integer from 0 to 59) portion of a Date object according to local time. | Date
 | minutesUTC : Number The minutes (an integer from 0 to 59) portion of a Date object according to universal time (UTC). | Date
 | month : Number The month (0 for January, 1 for February, and so on) portion of a Date object according to local time. | Date
 | monthUTC : Number The month (0 [January] to 11 [December]) portion of a Date object according to universal time (UTC). | Date
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | seconds : Number The seconds (an integer from 0 to 59) portion of a Date object according to local time. | Date
 | secondsUTC : Number The seconds (an integer from 0 to 59) portion of a Date object according to universal time (UTC). | Date
 | time : Number The number of milliseconds since midnight January 1, 1970, universal time, for a Date object. | Date
 | timezoneOffset : Number [read-only] The difference, in minutes, between the computer's local time and universal time (UTC). | Date
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Date(yearOrTimevalue:Object, month:Number, date:Number = 1, hour:Number = 0, minute:Number = 0, second:Number = 0, millisecond:Number = 0)
Constructs a new Date object that holds the specified date and time.
Date
getDate():Number
Returns the day of the month (an integer from 1 to 31) specified by a Date object according to local time.
Date
getDay():Number
Returns the day of the week (0 for Sunday, 1 for Monday, and so on) specified by this Date according to local time.
Date
getFullYear():Number
Returns the full year (a four-digit number, such as 2000) of a Date object according to local time.
Date
getHours():Number
Returns the hour (an integer from 0 to 23) of the day portion of a Date object according to local time.
Date
getMilliseconds():Number
Returns the milliseconds (an integer from 0 to 999) portion of a Date object according to local time.
Date
getMinutes():Number
Returns the minutes (an integer from 0 to 59) portion of a Date object according to local time.
Date
getMonth():Number
Returns the month (0 for January, 1 for February, and so on) portion of this Date according to local time.
Date
getSeconds():Number
Returns the seconds (an integer from 0 to 59) portion of a Date object according to local time.
Date
getTime():Number
Returns the number of milliseconds since midnight January 1, 1970, universal time, for a Date object.
Date
getTimezoneOffset():Number
Returns the difference, in minutes, between the computer's local time and universal time (UTC).
Date
getUTCDate():Number
Returns the day of the month (an integer from 1 to 31) of a Date object, according to universal time (UTC).
Date
getUTCDay():Number
Returns the day of the week (0 for Sunday, 1 for Monday, and so on) of this Date according to universal time (UTC).
Date
getUTCFullYear():Number
Returns the four-digit year of a Date object according to universal time (UTC).
Date
getUTCHours():Number
Returns the hour (an integer from 0 to 23) of the day of a Date object according to universal time (UTC).
Date
getUTCMilliseconds():Number
Returns the milliseconds (an integer from 0 to 999) portion of a Date object according to universal time (UTC).
Date
getUTCMinutes():Number
Returns the minutes (an integer from 0 to 59) portion of a Date object according to universal time (UTC).
Date
getUTCMonth():Number
Returns the month (0 [January] to 11 [December]) portion of a Date object according to universal time (UTC).
Date
getUTCSeconds():Number
Returns the seconds (an integer from 0 to 59) portion of a Date object according to universal time (UTC).
Date
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
parse(date:String):Number
[static] Converts a string representing a date into a number equaling the number of milliseconds elapsed since January 1, 1970, UTC.
Date
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
setDate(day:Number):Number
Sets the day of the month, according to local time, and returns the new time in milliseconds.
Date
setFullYear(year:Number, month:Number, day:Number):Number
Sets the year, according to local time, and returns the new time in milliseconds.
Date
setHours(hour:Number, minute:Number, second:Number, millisecond:Number):Number
Sets the hour, according to local time, and returns the new time in milliseconds.
Date
setMilliseconds(millisecond:Number):Number
Sets the milliseconds, according to local time, and returns the new time in milliseconds.
Date
setMinutes(minute:Number, second:Number, millisecond:Number):Number
Sets the minutes, according to local time, and returns the new time in milliseconds.
Date
setMonth(month:Number, day:Number):Number
Sets the month and optionally the day of the month, according to local time, and returns the new time in milliseconds.
Date
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setSeconds(second:Number, millisecond:Number):Number
Sets the seconds, according to local time, and returns the new time in milliseconds.
Date
setTime(millisecond:Number):Number
Sets the date in milliseconds since midnight on January 1, 1970, and returns the new time in milliseconds.
Date
setUTCDate(day:Number):Number
Sets the day of the month, in universal time (UTC), and returns the new time in milliseconds.
Date
setUTCFullYear(year:Number, month:Number, day:Number):Number
Sets the year, in universal time (UTC), and returns the new time in milliseconds.
Date
setUTCHours(hour:Number, minute:Number, second:Number, millisecond:Number):Number
Sets the hour, in universal time (UTC), and returns the new time in milliseconds.
Date
setUTCMilliseconds(millisecond:Number):Number
Sets the milliseconds, in universal time (UTC), and returns the new time in milliseconds.
Date
setUTCMinutes(minute:Number, second:Number, millisecond:Number):Number
Sets the minutes, in universal time (UTC), and returns the new time in milliseconds.
Date
setUTCMonth(month:Number, day:Number):Number
Sets the month, and optionally the day, in universal time(UTC) and returns the new time in milliseconds.
Date
setUTCSeconds(second:Number, millisecond:Number):Number
Sets the seconds, and optionally the milliseconds, in universal time (UTC) and returns the new time in milliseconds.
Date
toDateString():String
Returns a string representation of the day and date only, and does not include the time or timezone.
Date
toLocaleDateString():String
Returns a String representation of the day and date only, and does not include the time or timezone.
Date
toLocaleString():String
Returns a String representation of the day, date, time, given in local time.
Date
toLocaleTimeString():String
Returns a String representation of the time only, and does not include the day, date, year, or timezone.
Date
toString():String
Returns a String representation of the day, date, time, and timezone.
Date
toTimeString():String
Returns a String representation of the time and timezone only, and does not include the day and date.
Date
toUTCString():String
Returns a String representation of the day, date, and time in universal time (UTC).
Date
UTC(year:Number, month:Number, date:Number = 1, hour:Number = 0, minute:Number = 0, second:Number = 0, millisecond:Number = 0):Number
[static] Returns the number of milliseconds between midnight on January 1, 1970, universal time, and the time specified in the parameters.
Date
valueOf():Number
Returns the number of milliseconds since midnight January 1, 1970, universal time, for a Date object.
Date
Property detail
date property
date:Number [read-write]

The day of the month (an integer from 1 to 31) specified by a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get date():Number
    AS3 function set date(value:Number):void

See also

getDate()
setDate()
Managing calendar dates and times
dateUTC property
dateUTC:Number [read-write]

The day of the month (an integer from 1 to 31) of a Date object according to universal time (UTC).

Implementation
    AS3 function get dateUTC():Number
    AS3 function set dateUTC(value:Number):void

See also

getUTCDate()
setUTCDate()
day property
day:Number [read-only]

The day of the week (0 for Sunday, 1 for Monday, and so on) specified by this Date according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get day():Number

See also

getDay()
Managing calendar dates and times
dayUTC property
dayUTC:Number [read-only]

The day of the week (0 for Sunday, 1 for Monday, and so on) of this Date according to universal time (UTC).

Implementation
    AS3 function get dayUTC():Number

See also

getUTCDay()
fullYear property
fullYear:Number [read-write]

The full year (a four-digit number, such as 2000) of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get fullYear():Number
    AS3 function set fullYear(value:Number):void

See also

getFullYear()
setFullYear()
Managing calendar dates and times
fullYearUTC property
fullYearUTC:Number [read-write]

The four-digit year of a Date object according to universal time (UTC).

Implementation
    AS3 function get fullYearUTC():Number
    AS3 function set fullYearUTC(value:Number):void

See also

getUTCFullYear()
setUTCFullYear()
hours property
hours:Number [read-write]

The hour (an integer from 0 to 23) of the day portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get hours():Number
    AS3 function set hours(value:Number):void

See also

getHours()
setHours()
Managing calendar dates and times
hoursUTC property
hoursUTC:Number [read-write]

The hour (an integer from 0 to 23) of the day of a Date object according to universal time (UTC).

Implementation
    AS3 function get hoursUTC():Number
    AS3 function set hoursUTC(value:Number):void

See also

getUTCHours()
setUTCHours()
milliseconds property
milliseconds:Number [read-write]

The milliseconds (an integer from 0 to 999) portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get milliseconds():Number
    AS3 function set milliseconds(value:Number):void

See also

getMilliseconds()
setMilliseconds()
Managing calendar dates and times
millisecondsUTC property
millisecondsUTC:Number [read-write]

The milliseconds (an integer from 0 to 999) portion of a Date object according to universal time (UTC).

Implementation
    AS3 function get millisecondsUTC():Number
    AS3 function set millisecondsUTC(value:Number):void

See also

getUTCMilliseconds()
setUTCMilliseconds()
minutes property
minutes:Number [read-write]

The minutes (an integer from 0 to 59) portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get minutes():Number
    AS3 function set minutes(value:Number):void

See also

getMinutes()
setMinutes()
Managing calendar dates and times
minutesUTC property
minutesUTC:Number [read-write]

The minutes (an integer from 0 to 59) portion of a Date object according to universal time (UTC).

Implementation
    AS3 function get minutesUTC():Number
    AS3 function set minutesUTC(value:Number):void

See also

getUTCMinutes()
setUTCMinutes()
month property
month:Number [read-write]

The month (0 for January, 1 for February, and so on) portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get month():Number
    AS3 function set month(value:Number):void

See also

getMonth()
setMonth()
Managing calendar dates and times
monthUTC property
monthUTC:Number [read-write]

The month (0 [January] to 11 [December]) portion of a Date object according to universal time (UTC).

Implementation
    AS3 function get monthUTC():Number
    AS3 function set monthUTC(value:Number):void

See also

getUTCMonth()
setUTCMonth()
seconds property
seconds:Number [read-write]

The seconds (an integer from 0 to 59) portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Implementation
    AS3 function get seconds():Number
    AS3 function set seconds(value:Number):void

See also

getSeconds()
setSeconds()
Managing calendar dates and times
secondsUTC property
secondsUTC:Number [read-write]

The seconds (an integer from 0 to 59) portion of a Date object according to universal time (UTC).

Implementation
    AS3 function get secondsUTC():Number
    AS3 function set secondsUTC(value:Number):void

See also

getUTCSeconds()
setUTCSeconds()
time property
time:Number [read-write]

The number of milliseconds since midnight January 1, 1970, universal time, for a Date object. Use this method to represent a specific instant in time when comparing two or more Date objects.

Implementation
    AS3 function get time():Number
    AS3 function set time(value:Number):void

See also

getTime()
setTime()
timezoneOffset property
timezoneOffset:Number [read-only]

The difference, in minutes, between the computer's local time and universal time (UTC).

Implementation
    AS3 function get timezoneOffset():Number

See also

getTimezoneOffset()
Constructor detail
Date () constructor
public function Date(yearOrTimevalue:Object, month:Number, date:Number = 1, hour:Number = 0, minute:Number = 0, second:Number = 0, millisecond:Number = 0)

Constructs a new Date object that holds the specified date and time.

The Date() constructor takes up to seven parameters (year, month, ..., millisecond) to specify a date and time to the millisecond. The date that the newly constructed Date object contains depends on the number, and data type, of arguments passed.

  • If you pass no arguments, the Date object is assigned the current date and time.
  • If you pass one argument of data type Number, the Date object is assigned a time value based on the number of milliseconds since January 1, 1970 0:00:000 GMT, as specified by the lone argument.
  • If you pass one argument of data type String, and the string contains a valid date, the Date object contains a time value based on that date.
  • If you pass two or more arguments, the Date object is assigned a time value based on the argument values passed, which represent the date's year, month, date, hour, minute, second, and milliseconds.

If you pass a string to the Date class constructor, the date can be in a variety of formats, but must at least include the month, date, and year. For example, Feb 1 2005 is valid, but Feb 2005 is not. The following list indicates some of the valid formats:

  • Day Month Date Hours:Minutes:Seconds GMT Year (for instance, "Tue Feb 1 00:00:00 GMT-0800 2005", which matches toString())
  • Day Month Date Year Hours:Minutes:Seconds AM/PM (for instance, "Tue Feb 1 2005 12:00:00 AM", which matches toLocaleString())
  • Day Month Date Year (for instance, "Tue Feb 1 2005", which matches toDateString())
  • Month/Day/Year (for instance, "02/01/2005")
  • Month/Year (for instance, "02/2005")
Parameters
yearOrTimevalue:Object — If other parameters are specified, this number represents a year (such as 1965); otherwise, it represents a time value. If the number represents a year, a value of 0 to 99 indicates 1900 through 1999; otherwise all four digits of the year must be specified. If the number represents a time value (no other parameters are specified), it is the number of milliseconds before or after 0:00:00 GMT January 1, 1970; a negative values represents a time before 0:00:00 GMT January 1, 1970, and a positive value represents a time after.
month:Number — An integer from 0 (January) to 11 (December).
date:Number (default = 1) — An integer from 1 to 31.
hour:Number (default = 0) — An integer from 0 (midnight) to 23 (11 p.m.).
minute:Number (default = 0) — An integer from 0 to 59.
second:Number (default = 0) — An integer from 0 to 59.
millisecond:Number (default = 0) — An integer from 0 to 999 of milliseconds.

See also

getMonth()
getDate()
getFullYear()
Managing calendar dates and times
Method detail
getDate () method
AS3 function getDate():Number

Returns the day of the month (an integer from 1 to 31) specified by a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — The day of the month (1 - 31) a Date object represents.

See also

getMonth()
getFullYear()

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getDate() method is then called, which retrieves the day of the month.
package {
    import flash.display.Sprite;

    public class DateExample extends Sprite {

        public function DateExample() {
            var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
            trace(someBirthday);            // Sat Nov 30 01:20:00 GMT-0800 1974
            trace(someBirthday.getDate()); // 30
        }
    }
}

getDay () method
AS3 function getDay():Number

Returns the day of the week (0 for Sunday, 1 for Monday, and so on) specified by this Date according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — A numeric version of the day of the week (0 - 6) a Date object represents.

Example
The following example creates a new Array object weekDayLabels, with elements [Sunday,Monday,Tuesday,Wednesday,Thursday,Friday,Saturday] and a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getDay() method is then called twice, which first shows the day of the month as 6 and then shows the day of the week using weekDayLabels.

var weekDayLabels:Array = new Array("Sunday",
                    "Monday",
                    "Tuesday",
                    "Wednesday",
                    "Thursday",
                    "Friday",
                    "Saturday");

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday);                       // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getDay());            // 6
trace(weekDayLabels[someBirthday.getDay()]); // Saturday

getFullYear () method
AS3 function getFullYear():Number

Returns the full year (a four-digit number, such as 2000) of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — The full year a Date object represents.

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getFullYear() method is then called, which retrieves the four-digit year.

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday);           // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getFullYear()); // 1974

getHours () method
AS3 function getHours():Number

Returns the hour (an integer from 0 to 23) of the day portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — The hour (0 - 23) of the day a Date object represents.

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getHours() and getMinutes() methods are then called, which retrieves the hours and the minutes in 24-hour format. Finally, a string localTime is created and assigned to the result of a call to the function getUSClockTime(), which, in turn calls getHours() and getMinutes() again, resulting in the time 03:05 PM.

var someBirthday:Date = new Date(1974, 10, 30, 15, 5);

trace(someBirthday); // Sat Nov 30 15:20:00 GMT-0800 1974
trace(someBirthday.getHours() + ":" + someBirthday.getMinutes()); // 15:5

var localTime:String = getUSClockTime(someBirthday.getHours(), someBirthday.getMinutes());
trace(localTime);    // 03:05 PM

function getUSClockTime(hrs:uint, mins:uint):String {
    var modifier:String = "PM";
    var minLabel:String = doubleDigitFormat(mins);

    if(hrs > 12) {
        hrs = hrs-12;
    } else if(hrs == 0) {
        modifier = "AM";
        hrs = 12;
    } else if(hrs < 12) {
        modifier = "AM";
    }

    return (doubleDigitFormat(hrs) + ":" + minLabel + " " + modifier);
}

function doubleDigitFormat(num:uint):String {
    if(num < 10) {
        return ("0" + num);
    }
    return num;
}

getMilliseconds () method
AS3 function getMilliseconds():Number

Returns the milliseconds (an integer from 0 to 999) portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — The milliseconds portion of a Date object.

Example
The following example creates a new Date object now with no parameters. The getMilliseconds() method is then called, which retrieves the milliseconds of the Date object now at the time it was created.

var now:Date = new Date();
trace(now.getMilliseconds());

getMinutes () method
AS3 function getMinutes():Number

Returns the minutes (an integer from 0 to 59) portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — The minutes portion of a Date object.

Example
The following example creates a new Date object now with no parameters. The getMinutes() method is then called, which retrieves the minutes of the Date object now at the time it was created.

var now:Date = new Date();
trace(now);
trace(now.getMinutes());

getMonth () method
AS3 function getMonth():Number

Returns the month (0 for January, 1 for February, and so on) portion of this Date according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — The month (0 - 11) portion of a Date object.

Example
The following example creates a new Array object monthLabels, with elements January through December and a new Date object now with no parameters. The getMonth() method is then called twice, which first returns the month number and then the month name of the month the Date object now was created.

var monthLabels:Array = new Array("January",
                  "February",
                  "March",
                  "April",
                  "May",
                  "June",
                  "July",
                  "August",
                  "September",
                  "October",
                  "November",
                  "December");

var now:Date = new Date();
trace(now.getMonth());
trace(monthLabels[now.getMonth()]);

getSeconds () method
AS3 function getSeconds():Number

Returns the seconds (an integer from 0 to 59) portion of a Date object according to local time. Local time is determined by the operating system on which Flash Player is running.

Returns
Number — The seconds (0 to 59) portion of a Date object.

Example
The following example creates a new Date object now with no parameters. The getSeconds() method is then called, which retrieves the seconds of the Date object now at the time it was created.

var now:Date = new Date();
trace(now.getSeconds());

getTime () method
AS3 function getTime():Number

Returns the number of milliseconds since midnight January 1, 1970, universal time, for a Date object. Use this method to represent a specific instant in time when comparing two or more Date objects.

Returns
Number — The number of milliseconds since Jan 1, 1970 that a Date object represents.

Example
The following example creates a new Date object mlk with parameters year (1929), month (0 = January), and day (15). The getTime() method is then called, which retrieves the milliseconds since midnight January 1, 1970, which is negative since the year is set to 1929.

var mlk:Date = new Date(1929, 0, 15);
trace(mlk);           // Tue Jan 15 00:00:00 GMT-0800 1929
trace(mlk.getTime()); // -1292601600000

The following example creates a new Date object now with no parameters and then uses the following DateMath (created below) class methods to add time to the original Date object now from the time it was created:
  • addSeconds(): adds 30 seconds to now.
  • addMinutes(): adds 30 minutes to now.
  • addHours(): adds 6 hours to the Date object now.
  • addDays(): adds 30 days to the Date object now.
  • addWeeks(): adds 4 weeks to now.

var now:Date = new Date();
trace(now);
trace(DateMath.addSeconds(now, 30));
trace(DateMath.addMinutes(now, 30));
trace(DateMath.addHours(now, 6));
trace(DateMath.addDays(now, 30));
trace(DateMath.addWeeks(now, 4));

class DateMath {
    public static function addWeeks(date:Date, weeks:Number):Date {
        return addDays(date, weeks*7);
    }

    public static function addDays(date:Date, days:Number):Date {
        return addHours(date, days*24);
    }

    public static function addHours(date:Date, hrs:Number):Date {
        return addMinutes(date, hrs*60);
    }

    public static function addMinutes(date:Date, mins:Number):Date {
        return addSeconds(date, mins*60);
    }

    public static function addSeconds(date:Date, secs:Number):Date {
        var mSecs:Number = secs * 1000;
        var sum:Number = mSecs + date.getTime();
        return new Date(sum);
    }
}
Note: it's important to use getTime when performing Date arithmetic because it will continue to work during leap years and doesn't require a bunch of if logic like following pseudo-code:
  function addMonths(num:Number):void {
      currentMonth = currentMonth + num;
      if(currentMonth > 12) {
          currentYear++;
          currentMonth = currentMonth - 12;
      }
  }

getTimezoneOffset () method
AS3 function getTimezoneOffset():Number

Returns the difference, in minutes, between the computer's local time and universal time (UTC).

Returns
Number — Difference, in minutes, of local time and universal time (UTC).

Example
The following example creates a new Date object now with no parameters. The getTimezoneOffset() method is then called, which retrieves the difference (in minutes) of the time now was created and Universal Time. The time zone offset is then converted to hours by dividing the result by 60.

var date:Date = new Date();
trace(date.getTimezoneOffset() / 60);

getUTCDate () method
AS3 function getUTCDate():Number

Returns the day of the month (an integer from 1 to 31) of a Date object, according to universal time (UTC).

Returns
Number — The UTC day of the month (1 to 31) that a Date object represents.

See also

getDate()

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getUTCDate() method is then called, which retrieves the day of the month, according to the UTC.

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday);             // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getUTCDate()); // 30

getUTCDay () method
AS3 function getUTCDay():Number

Returns the day of the week (0 for Sunday, 1 for Monday, and so on) of this Date according to universal time (UTC).

Returns
Number — The UTC day of the week (0 to 6) that a Date object represents.

See also

getDay()

Example
The following example creates a new Array object weekDayLabels, with elements [Sunday,Monday,Tuesday,Wednesday,Thursday,Friday,Saturday] and a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getUTCDay() method is then called twice, which first shows the day of the month as 6 and then shows the day of the week using weekDayLabels, according to the UTC.

var weekDayLabels:Array = new Array("Sunday",
                    "Monday",
                    "Tuesday",
                    "Wednesday",
                    "Thursday",
                    "Friday",
                    "Saturday");

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday);           // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getUTCDay()); // 6
trace(weekDayLabels[someBirthday.getUTCDay()]); // Saturday

getUTCFullYear () method
AS3 function getUTCFullYear():Number

Returns the four-digit year of a Date object according to universal time (UTC).

Returns
Number — The UTC four-digit year a Date object represents.

See also

getFullYear()

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getUTCFullYear() method is then called, which retrieves the four-digit year, according to the UTC.

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday);                 // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getUTCFullYear()); // 1974

getUTCHours () method
AS3 function getUTCHours():Number

Returns the hour (an integer from 0 to 23) of the day of a Date object according to universal time (UTC).

Returns
Number — The UTC hour of the day (0 to 23) a Date object represents.

See also

getHours()

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The getHours() and getMinutes() methods are then called, which retrieves the hours and the minutes in 24-hour format. Finally, a string localTime is created and assigned to the result of a call to the function getUSClockTime(), which, in turn calls getHours() and getMinutes() again, resulting in the time 03:05 PM. Lastly, a String variable utcTime is created in the same manner as localTime, and in this case, the result is the same.

var someBirthday:Date = new Date(1974, 10, 30, 15, 5);

trace(someBirthday); // Sat Nov 30 15:20:00 GMT-0800 1974
trace(someBirthday.getHours() + ":" + someBirthday.getMinutes()); // 15:5

var localTime:String = getUSClockTime(someBirthday.getHours(), someBirthday.getMinutes());
trace(localTime);    // 03:05 PM

var utcTime:String = getUSClockTime(someBirthday.getUTCHours(), someBirthday.getUTCMinutes());
trace(utcTime);      // 11:05 PM

function getUSClockTime(hrs:uint, mins:uint):String {
    var modifier:String = "PM";
    var minLabel:String = doubleDigitFormat(mins);

    if(hrs > 12) {
        hrs = hrs-12;
    } else if(hrs == 0) {
        modifier = "AM";
        hrs = 12;
    } else if(hrs < 12) {
        modifier = "AM";
    }

    return (doubleDigitFormat(hrs) + ":" + minLabel + " " + modifier);
}

function doubleDigitFormat(num:uint):String {
    if(num < 10) {
        return ("0" + num);
    }
    return num;
}

getUTCMilliseconds () method
AS3 function getUTCMilliseconds():Number

Returns the milliseconds (an integer from 0 to 999) portion of a Date object according to universal time (UTC).

Returns
Number — The UTC milliseconds portion of a Date object.

Example
The following example creates a new Date object now with no parameters. The getUTCMilliseconds() method is then called, which retrieves the milliseconds of the Date object now at the time it was created, according to the UTC

var now:Date = new Date();
trace(now.getUTCMilliseconds());

getUTCMinutes () method
AS3 function getUTCMinutes():Number

Returns the minutes (an integer from 0 to 59) portion of a Date object according to universal time (UTC).

Returns
Number — The UTC minutes portion of a Date object.

Example
The following example creates a new Date object now with no parameters. The getUTCMinutes() method is then called, which retrieves the minutes of the Date object now at the time it was created, according to the UTC

var now:Date = new Date();
trace(now.getUTCMinutes());

getUTCMonth () method
AS3 function getUTCMonth():Number

Returns the month (0 [January] to 11 [December]) portion of a Date object according to universal time (UTC).

Returns
Number — The UTC month portion of a Date object.

See also

getMonth()

Example
The following example creates a new Array object monthLabels, with elements January through December and a new Date object now with no parameters. The getUTCMonth() method is then called twice, which first returns the month number and then the month name of the month the Date object now was created, according to the UTC

var monthLabels:Array = new Array("January",
                  "February",
                  "March",
                  "April",
                  "May",
                  "June",
                  "July",
                  "August",
                  "September",
                  "October",
                  "November",
                  "December");

var now:Date = new Date();
trace(now.getMonth());
trace(now.getUTCMonth());
trace(monthLabels[now.getUTCMonth()]);

getUTCSeconds () method
AS3 function getUTCSeconds():Number

Returns the seconds (an integer from 0 to 59) portion of a Date object according to universal time (UTC).

Returns
Number — The UTC seconds portion of a Date object.

Example
The following example creates a new Date object now with no parameters. The getUTCSeconds() method is then called, which retrieves the seconds of the Date object now at the time it was created, according to the UTC

var now:Date = new Date();
trace(now.getUTCSeconds());

parse () method
public static function parse(date:String):Number

Converts a string representing a date into a number equaling the number of milliseconds elapsed since January 1, 1970, UTC.

Parameters
date:String — A string representation of a date, which conforms to the format for the output of Date.toString(). The date format for the output of Date.toString() is:
     Day Mon DD HH:MM:SS TZD YYYY

For example:

     Wed Apr 12 15:30:17 GMT-0700 2006

The Time Zone Designation (TZD) is always in the form GMT-HHMM or UTC-HHMM indicating the hour and minute offset relative to Greenwich Mean Time (GMT), which is now also called universal time (UTC). The year month and day terms can be separated by a forward slash (/) or by spaces, but never by a dash (-). Other supported formats include the following (you can include partial representations of these formats; that is, just the month, day, and year):

     MM/DD/YYYY HH:MM:SS TZD
     HH:MM:SS TZD Day Mon/DD/YYYY
     Mon DD YYYY HH:MM:SS TZD
     Day Mon DD HH:MM:SS TZD YYYY
     Day DD Mon HH:MM:SS TZD YYYY
     Mon/DD/YYYY HH:MM:SS TZD
     YYYY/MM/DD HH:MM:SS TZD

Returns
Number — A number representing the milliseconds elapsed since January 1, 1970, UTC.

See also

Date.toString()

Example
The following example assigns a date string to dateParsed for November 30, 1974. The Date.parse() method is then called, which converts the date into milliseconds since January 1, 1970.
var dateParsed:String = "Sat Nov 30 1974";

var milliseconds:Number = Date.parse(dateParsed);
trace(milliseconds); // output 155030400000

setDate () method
AS3 function setDate(day:Number):Number

Sets the day of the month, according to local time, and returns the new time in milliseconds. Local time is determined by the operating system on which Flash Player is running.

Parameters
day:Number — An integer from 1 to 31.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The method getDate() is then called, which retrieves the day of the month. Next setDate() is called with the day parameter set to 20 and then getDate() is called again, which retrieves the newly set day of month.

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday);            // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getDate()); // 30

someBirthday.setDate(20);
trace(someBirthday.getDate()); // 20

setFullYear () method
AS3 function setFullYear(year:Number, month:Number, day:Number):Number

Sets the year, according to local time, and returns the new time in milliseconds. If the month and day parameters are specified, they are set to local time. Local time is determined by the operating system on which Flash Player is running.

Calling this method does not modify the other fields of the Date but Date.getUTCDay() and Date.getDay() can report a new value if the day of the week changes as a result of calling this method.

Parameters
year:Number — A four-digit number specifying a year. Two-digit numbers do not represent four-digit years; for example, 99 is not the year 1999, but the year 99.
month:Number — An integer from 0 (January) to 11 (December).
day:Number — A number from 1 to 31.

Returns
Number — The new time, in milliseconds.

See also

getUTCDay()
getDay()

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The method getFullYear() is then called, which retrieves the four-digit year. Next setFullYear() is called with the year parameter set to 2000 and then getFullYear() is called again, which retrieves the newly set year.

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday);           // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getFullYear()); // 1974

someBirthday.setFullYear(2000);
trace(someBirthday.getFullYear()); // 2000

setHours () method
AS3 function setHours(hour:Number, minute:Number, second:Number, millisecond:Number):Number

Sets the hour, according to local time, and returns the new time in milliseconds. Local time is determined by the operating system on which Flash Player is running.

Parameters
hour:Number — An integer from 0 (midnight) to 23 (11 p.m.).
minute:Number — An integer from 0 to 59.
second:Number — An integer from 0 to 59.
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The methods getHours() and getMinutes() are then called, which retrieves the hours and minutes. Next setHours() is called with the hour parameter set to 12 and then getHours() and getMinutes() are called again, which retrieves the newly set hours and minutes.

var someBirthday:Date = new Date(1974, 10, 30, 15, 20);

trace(someBirthday); // Sat Nov 30 15:20:00 GMT-0800 1974
trace(someBirthday.getHours() + ":" + someBirthday.getMinutes()); // 15:20

someBirthday.setHours(12);
trace(someBirthday.getHours() + ":" + someBirthday.getMinutes()); // 12:20

setMilliseconds () method
AS3 function setMilliseconds(millisecond:Number):Number

Sets the milliseconds, according to local time, and returns the new time in milliseconds. Local time is determined by the operating system on which Flash Player is running.

Parameters
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object now with no parameters. The method getMilliseconds() is then called, which retrieves the milliseconds when now was created. Then another new Date object before with an additional call to setMilliseconds() with the millisecond parameter set to 4 and getMilliseconds() is called again, which retrieves the newly set milliseconds.

var now:Date = new Date();
trace(now);
trace(now.getMilliseconds());

var before:Date = new Date(now.setMilliseconds(4));
trace(before);
trace(before.getMilliseconds());

setMinutes () method
AS3 function setMinutes(minute:Number, second:Number, millisecond:Number):Number

Sets the minutes, according to local time, and returns the new time in milliseconds. Local time is determined by the operating system on which Flash Player is running.

Parameters
minute:Number — An integer from 0 to 59.
second:Number — An integer from 0 to 59.
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object now with no parameters. The method getMinutes() is then called, which retrieves the minutes when now was created. Then another new Date object before with an additional call to setMinutes() with the minute parameter set to 0 and getMinutes() is called again, which retrieves the newly set minutes.

var now:Date = new Date();
trace(now);
trace(now.getMinutes());

var before:Date = new Date(now.setMinutes(0));
trace(before);
trace(before.getMinutes());

setMonth () method
AS3 function setMonth(month:Number, day:Number):Number

Sets the month and optionally the day of the month, according to local time, and returns the new time in milliseconds. Local time is determined by the operating system on which Flash Player is running.

Parameters
month:Number — An integer from 0 (January) to 11 (December).
day:Number — An integer from 1 to 31.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Array object monthLabels, with elements January through December and a new month object now with no parameters. The method getMonth() is then called, which retrieves the month in which now was created. Next setMonth() is called with the month parameter set to 0 and then getMonth() is called again, which retrieves the newly set month..

var monthLabels:Array = new Array("January",
                  "February",
                  "March",
                  "April",
                  "May",
                  "June",
                  "July",
                  "August",
                  "September",
                  "October",
                  "November",
                  "December");

var now:Date = new Date();
trace(now.getMonth());
trace(monthLabels[now.getMonth()]);

now.setMonth(0);
trace(now.getMonth());             // 0
trace(monthLabels[now.getMonth()]); // January

setSeconds () method
AS3 function setSeconds(second:Number, millisecond:Number):Number

Sets the seconds, according to local time, and returns the new time in milliseconds. Local time is determined by the operating system on which Flash Player is running.

Parameters
second:Number — An integer from 0 to 59.
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object now with no parameters. The method getseconds() is then called, which retrieves the seconds when now was created. Then the setSeconds() is called with the second parameter set to 0 and getSeconds() is called again, which retrieves the newly set seconds.

var now:Date = new Date();
trace(now.getSeconds());

now.setSeconds(0);
trace(now.getSeconds()); // 0

setTime () method
AS3 function setTime(millisecond:Number):Number

Sets the date in milliseconds since midnight on January 1, 1970, and returns the new time in milliseconds.

Parameters
millisecond:Number — An integer value where 0 is midnight on January 1, universal time (UTC).

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object now with no parameters. The setTime() method is then called, with the millisecond parameter set to -1292601600000, which sets the time to Tue Jan 15 00:00:00 GMT-0800 1929.

var now:Date = new Date();
trace(now);

now.setTime(-1292601600000);
trace(now); // Tue Jan 15 00:00:00 GMT-0800 1929

setUTCDate () method
AS3 function setUTCDate(day:Number):Number

Sets the day of the month, in universal time (UTC), and returns the new time in milliseconds. Calling this method does not modify the other fields of a Date object, but the Date.getUTCDay() and Date.getDay() methods can report a new value if the day of the week changes as a result of calling this method.

Parameters
day:Number — A number; an integer from 1 to 31.

Returns
Number — The new time, in milliseconds.

See also

getUTCDay()
getDay()

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The method getUTCDate() is called and correctly returns the day of the month. Next setUTCDate() is called with the day parameter set to 1 and a trace() statement confirms the date was correctly set.

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday); // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getUTCDate()); // 30

someBirthday.setUTCDate(1);
trace(someBirthday); // Fri Nov 1 01:20:00 GMT-0800 1974

setUTCFullYear () method
AS3 function setUTCFullYear(year:Number, month:Number, day:Number):Number

Sets the year, in universal time (UTC), and returns the new time in milliseconds.

Optionally, this method can also set the month and day of the month. Calling this method does not modify the other fields, but the Date.getUTCDay() and Date.getDay() methods can report a new value if the day of the week changes as a result of calling this method.

Parameters
year:Number — An integer that represents the year specified as a full four-digit year, such as 2000.
month:Number — An integer from 0 (January) to 11 (December).
day:Number — An integer from 1 to 31.

Returns
Number — An integer.

See also

getUTCDay()
getDay()

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The method getUTCFullYear() is called and correctly returns the four-digit year. Next setUTCFullYear() is called with the year parameter set to 1975 and a trace() statement confirms the year was correctly set.

var someBirthday:Date = new Date(1974, 10, 30, 1, 20);
trace(someBirthday); // Sat Nov 30 01:20:00 GMT-0800 1974
trace(someBirthday.getUTCFullYear()); // 1974

someBirthday.setUTCFullYear(1975);
trace(someBirthday); // Thu Nov 30 01:20:00 GMT-0800 1975

setUTCHours () method
AS3 function setUTCHours(hour:Number, minute:Number, second:Number, millisecond:Number):Number

Sets the hour, in universal time (UTC), and returns the new time in milliseconds. Optionally, the minutes, seconds, and milliseconds can be specified.

Parameters
hour:Number — An integer from 0 (midnight) to 23 (11 p.m.).
minute:Number — An integer from 0 to 59.
second:Number — An integer from 0 to 59.
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20). The methods getHours(), getMinutes(), getUTCHours(), and getUTCMinutes() are then called, which retrieves the hours and minutes. Next setUTCHours() is called with the hour parameter set to 12 and then the methods getHours(), getMinutes(), getUTCHours(), and getUTCMinutes() are re-called and correctly display the updated hour.

var someBirthday:Date = new Date(1974, 10, 30, 15, 20);

trace(someBirthday); // Sat Nov 30 15:20:00 GMT-0800 1974
trace(someBirthday.getHours() + ":" + someBirthday.getMinutes());     // 15:20
trace(someBirthday.getUTCHours() + ":" + someBirthday.getUTCMinutes()); // 23:20

someBirthday.setUTCHours(12);
trace(someBirthday.getHours() + ":" + someBirthday.getMinutes());     // 4:20
trace(someBirthday.getUTCHours() + ":" + someBirthday.getUTCMinutes()); // 12:20

setUTCMilliseconds () method
AS3 function setUTCMilliseconds(millisecond:Number):Number

Sets the milliseconds, in universal time (UTC), and returns the new time in milliseconds.

Parameters
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object now with no parameters. The method getUTCMilliseconds() is then called, which retrieves the UTCMilliseconds when now was created. Then another new Date object before with an additional call to setUTCMilliseconds() with the millisecond parameter set to 4 and getUTCMilliseconds() is called again, which retrieves the newly set milliseconds.

var now:Date = new Date();
trace(now);
trace(now.getUTCMilliseconds());

var before:Date = new Date(now.setUTCMilliseconds(4));
trace(before);
trace(before.getUTCMilliseconds());

setUTCMinutes () method
AS3 function setUTCMinutes(minute:Number, second:Number, millisecond:Number):Number

Sets the minutes, in universal time (UTC), and returns the new time in milliseconds. Optionally, you can specify the seconds and milliseconds.

Parameters
minute:Number — An integer from 0 to 59.
second:Number — An integer from 0 to 59.
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object now with no parameters. The method getUTCMinutes() is then called, which retrieves the UTCMinutes when now was created. Then another new Date object before with an additional call to setUTCMinutes() with the minute parameter set to 0 and getUTCMinutes() is called again, which retrieves the newly set minutes.

var now:Date = new Date();
trace(now);
trace(now.getUTCMinutes());

var before:Date = new Date(now.setUTCMinutes(0));
trace(before);
trace(before.getUTCMinutes());

setUTCMonth () method
AS3 function setUTCMonth(month:Number, day:Number):Number

Sets the month, and optionally the day, in universal time(UTC) and returns the new time in milliseconds. Calling this method does not modify the other fields, but the Date.getUTCDay() and Date.getDay() methods might report a new value if the day of the week changes as a result of calling this method.

Parameters
month:Number — An integer from 0 (January) to 11 (December).
day:Number — An integer from 1 to 31.

Returns
Number — The new time, in milliseconds.

See also

getDay()

Example
The following example creates a new Array object UTCMonthLabels, with elements January through December and a new UTCMonth object now with no parameters. The method getUTCMonth() is then called, which retrieves the UTCMonth in which now was created. Next setUTCMonth() is called with the month parameter set to 0 and then getUTCMonth() is called again, which retrieves the newly set month..

var UTCMonthLabels:Array = new Array("January",
                  "February",
                  "March",
                  "April",
                  "May",
                  "June",
                  "July",
                  "August",
                  "September",
                  "October",
                  "November",
                  "December");

var now:Date = new Date();
trace(now.getUTCMonth());
trace(UTCMonthLabels[now.getUTCMonth()]);

now.setUTCUTCMonth(0);
trace(now.getUTCMonth());              // 0
trace(UTCMonthLabels[now.getUTCMonth()]); // January

setUTCSeconds () method
AS3 function setUTCSeconds(second:Number, millisecond:Number):Number

Sets the seconds, and optionally the milliseconds, in universal time (UTC) and returns the new time in milliseconds.

Parameters
second:Number — An integer from 0 to 59.
millisecond:Number — An integer from 0 to 999.

Returns
Number — The new time, in milliseconds.

Example
The following example creates a new Date object now with no parameters. The method getUTCSeconds() is then called, which retrieves the seconds when now was created. Then the setUTCSeconds() is called with the second parameter set to 0 and getUTCSeconds() is called again, which retrieves the newly set seconds.

var now:Date = new Date();
trace(now.getUTCSeconds());

now.setUTCSeconds(0);
trace(now.getUTCSeconds()); // 0

toDateString () method
AS3 function toDateString():String

Returns a string representation of the day and date only, and does not include the time or timezone. Contrast with the following methods:

  • Date.toTimeString(), which returns only the time and timezone
  • Date.toString(), which returns not only the day and date, but also the time and timezone.

Returns
String — The string representation of day and date only.

See also

toString()

Example
The following example creates a new Date object now with no parameters and then the following methods are called within a trace() statement
  • toString: displays all parameters for now at the time now was created.
  • toDateString(): displays the day, month, and year parameters for the time now was created.

var now:Date = new Date();
trace(now);
trace(now.toDateString());

toLocaleDateString () method
AS3 function toLocaleDateString():String

Returns a String representation of the day and date only, and does not include the time or timezone. This method returns the same value as Date.toDateString. Contrast with the following methods:

  • Date.toTimeString(), which returns only the time and timezone
  • Date.toString(), which returns not only the day and date, but also the time and timezone.

Returns
String — The String representation of day and date only.

See also

toDateString()
toTimeString()
toString()
toLocaleString () method
AS3 function toLocaleString():String

Returns a String representation of the day, date, time, given in local time. Contrast with the Date.toString() method, which returns the same information (plus the timezone) with the year listed at the end of the string.

Returns
String — A string representation of a Date object in the local timezone.
toLocaleTimeString () method
AS3 function toLocaleTimeString():String

Returns a String representation of the time only, and does not include the day, date, year, or timezone. Contrast with the Date.toTimeString() method, which returns the time and timezone.

Returns
String — The string representation of time and timezone only.

See also

toTimeString()
toString () method
AS3 function toString():String

Returns a String representation of the day, date, time, and timezone. The date format for the output is:

     Day Mon Date HH:MM:SS TZD YYYY

For example:

     Wed Apr 12 15:30:17 GMT-0700 2006

Returns
String — The string representation of a Date object.

Example
The following example creates a new Date object now with no parameters and then toString is called within a trace() statement, which displays all parameters for now at the time now was created.

var now:Date = new Date();
trace(now);

toTimeString () method
AS3 function toTimeString():String

Returns a String representation of the time and timezone only, and does not include the day and date. Contrast with the Date.toDateString() method, which returns only the day and date.

Returns
String — The string representation of time and timezone only.

See also

toDateString()
toUTCString () method
AS3 function toUTCString():String

Returns a String representation of the day, date, and time in universal time (UTC). For example, the date February 1, 2005 is returned as Tue Feb 1 00:00:00 2005 UTC.

Returns
String — The string representation of a Date object in UTC time.

See also

toString()
UTC () method
public static function UTC(year:Number, month:Number, date:Number = 1, hour:Number = 0, minute:Number = 0, second:Number = 0, millisecond:Number = 0):Number

Returns the number of milliseconds between midnight on January 1, 1970, universal time, and the time specified in the parameters. This method uses universal time, whereas the Date constructor uses local time.

This method is useful if you want to pass a UTC date to the Date class constructor. Because the Date class constructor accepts the millisecond offset as an argument, you can use the Date.UTC() method to convert your UTC date into the corresponding millisecond offset, and send that offset as an argument to the Date class constructor:

Parameters
year:Number — A four-digit integer that represents the year (for example, 2000).
month:Number — An integer from 0 (January) to 11 (December).
date:Number (default = 1) — An integer from 1 to 31.
hour:Number (default = 0) — An integer from 0 (midnight) to 23 (11 p.m.).
minute:Number (default = 0) — An integer from 0 to 59.
second:Number (default = 0) — An integer from 0 to 59.
millisecond:Number (default = 0) — An integer from 0 to 999.

Returns
Number — The number of milliseconds since January 1, 1970 and the specified date and time.

Example
The following example creates a new Date object someBirthday with parameters year (1974), month (10 = November), day (30), hour (1) and minute (20) using local time. Then a call to UTC() within a setTime() method resets the same parameters to universal time.

var someBirthday:Date = new Date(1974, 10, 30, 15, 20);
trace(someBirthday.toString());

someBirthday.setTime(Date.UTC(1974, 10, 30, 15, 20));
trace(someBirthday.toString());

valueOf () method
AS3 function valueOf():Number

Returns the number of milliseconds since midnight January 1, 1970, universal time, for a Date object.

Returns
Number — The number of milliseconds since January 1, 1970 that a Date object represents.

Example
The following example creates a new Date object now with no parameters The getTime() method is then called, which retrieves the number of milliseconds between the time now was created and midnight on January 1, 1970, and then valueOf() is called, which retrieves the same thing.

var now:Date = new Date();
trace(now.getTime());
trace(now.valueOf());

Examples

The following example shows various uses of the Date() constructor to assign the following variables:
  • myDate1 calls Date() with no parameters, which sets myDate1 to the current date and time (according to your current system's date and time).
  • myDate2 calls Date() with the year (2000), month (0 = January), and day (1) parameters passed to it.
  • myDate3 calls Date() with the year (65 = 1965), month (2 = March), the day (6), the hour (9), the minute (30), the second (15) and the millisecond-+ (0) passed as parameters.
  • myDate4 calls Date() with the time value representing the number of milliseconds before (since the value is negative) 0:00:00 GMT January 1, 1970.

package {
    import flash.display.Sprite;

    public class DateExample extends Sprite{
        public function DateExample() {
            var myDate1:Date = new Date();
            trace(myDate1); // [NOW]

            var myDate2:Date = new Date(2000, 0, 1);
            trace(myDate2); // Sat Jan 1 00:00:00 GMT-0800 2000

            var myDate3:Date = new Date(65, 2, 6, 9, 30, 15, 0);
            trace(myDate3); // Sat Mar 6 09:30:15 GMT-0800 1965

            var myDate4:Date = new Date(-14159025000);
            trace(myDate4); // Sun Jul 20 19:56:15 GMT-0700 1969
        }
    }
}


DefinitionError (Flex™ 2 Language Reference)

Class DefinitionError | Properties | Methods
Package | Top Level
Class | public dynamic class DefinitionError
Inheritance | DefinitionError Inheritance Error Inheritance Object

The DefinitionError class represents an error that occurs when user code attempts to define an identifier that is already defined. This error commonly occurs in redefining classes, interfaces, and functions.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DefinitionError(message:String = "") Creates a new DefinitionError object. | DefinitionError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
DefinitionError () constructor
public function DefinitionError(message:String = "")

Creates a new DefinitionError object.

Parameters
message:String (default = "")


Error (Flex™ 2 Language Reference)

Class Error | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class Error
Inheritance | Error Inheritance Object
Subclasses | ArgumentError, CollectionViewError, CursorError, DataListError, DataServiceError, DefinitionError, EvalError, Fault, IllegalOperationError, InvalidCategoryError, InvalidFilterError, InvalidSWFError, IOError, ItemPendingError, MemoryError, MessagingError, NoDataAvailableError, RangeError, ReferenceError, ScriptTimeoutError, SecurityError, SortError, StackOverflowError, SyntaxError, TypeError, UnresolvedConflictsError, URIError, VerifyError, VideoError

The Error class contains information about an error that occurred in a script. In developing ActionScript 3.0 applications, when you run your compiled code in the debugger version of Flash Player, a dialog box displays exceptions of type Error, or of a subclass, to help you troubleshoot the code. You create an Error object by using the Error constructor function. Typically, you throw a new Error object from within a try code block that is caught by a catch or finally code block.

You can also create a subclass of the Error class and throw instances of that subclass.

View the examples.

See also

Working with the debugger version of Flash Player
Creating custom error classes
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | errorID : int [read-only] Contains the reference number associated with the specific error message. | Error
 | message : String Contains the message associated with the Error object. | Error
 | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Error(message:String = "", id:int = 0) Creates a new Error object. | Error
 | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
errorID property
errorID:int [read-only]

Contains the reference number associated with the specific error message. For a custom Error object, this number is the value from the id parameter supplied in the constructor.

Implementation
    public function get errorID():int
message property
public var message:String

Contains the message associated with the Error object. By default, the value of this property is "Error". You can specify a message property when you create an Error object by passing the error string to the Error constructor function.

See also

statements.html#throw
statements.html#try..catch..finally
name property
public var name:String

Contains the name of the Error object. By default, the value of this property is "Error".

See also

statements.html#throw
statements.html#try..catch..finally
Constructor detail
Error () constructor
public function Error(message:String = "", id:int = 0)

Creates a new Error object. If message is specified, its value is assigned to the object's Error.message property.

Parameters
message:String (default = "") — A string associated with the Error object; this parameter is optional.
id:int (default = 0) — A reference number to associate with the specific error message.

See also

statements.html#throw
statements.html#try..catch..finally

Example
The following example creates a new Error object err and then, using the Error() constructor, assigns the string "New Error Message" to err.

var err:Error = new Error();
trace(err.toString());    // Error

err = new Error("New Error Message");
trace(err.toString());    // Error: New Error Message

Method detail
getStackTrace () method
public function getStackTrace():String

Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). As shown in the following example, the first line of the return value is the string representation of the exception object, followed by the stack trace elements:

  TypeError: null cannot be converted to an object
      at com.xyz.OrderEntry.retrieveData(OrderEntry.as:995)
      at com.xyz.OrderEntry.init(OrderEntry.as:200)
      at com.xyz.OrderEntry.$construct(OrderEntry.as:148)

Returns
String — A string representation of the call stack.
toString () method
public override function toString():String

Returns the string "Error" by default or the value contained in Error.message property, if defined.

Returns
String — The error message.

See also

Error.message
statements.html#throw
statements.html#try..catch..finally

Example
The following example creates a new Error object err and then, using the Error() constructor, assigns the string "New Error Message" to err. Finally, the message property is set to "Another New Error Message", which overwrites "New Error Message".

var err:Error = new Error();
trace(err.toString());    // Error

err = new Error("New Error Message");
trace(err.toString());    // Error: New Error Message

err.message = "Another New Error Message";
trace(err.toString());    // Error: Another New Error Message

Examples

The following example uses the ErrorExample class to show how a custom error can be generated. This is accomplished with the following steps:
  1. A local variable nullArray of Array type is declared, but notice that a new Array object is never created.
  2. The constructor attempts to load a value into the uninitialized array by using the push() method within an error handling code segment that catches a custom error by using the CustomError class, which extends Error.
  3. When the CustomError is thrown, the constructor catches it and then outputs an error message by using the trace() statement.
package
{
    import flash.display.Sprite;
    public class ErrorExample extends Sprite
    {
        private var nullArray:Array;
        public function ErrorExample()
        {
            try
            {
                nullArray.push("item");
            }
            catch(e:Error)
            {
                throw new CustomError("nullArray is null");
            }
        }
    }
}

class CustomError extends Error
{
    public function CustomError(message:String)
    {
        super(message);
    }
}


EvalError (Flex™ 2 Language Reference)

Class EvalError | Properties | Methods
Package | Top Level
Class | public dynamic class EvalError
Inheritance | EvalError Inheritance Error Inheritance Object

The EvalError class represents an error that occurs when user code calls the eval() function or attempts to use the new operator with the Function object. Calling eval() and calling new with the Function object are not supported.

See also

Error handling in ActionScript 3.0
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | EvalError(message:String = "") Creates a new EvalError object. | EvalError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
EvalError () constructor
public function EvalError(message:String = "")

Creates a new EvalError object.

Parameters
message:String (default = "") — A string associated with the error.

See also

Error handling in ActionScript 3.0
Responding to error events and status


Function (Flex™ 2 Language Reference)

Class Function | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class Function
Inheritance | Function Inheritance Object

A function is the basic unit of code that can be invoked in ActionScript. Both user-defined and built-in functions in ActionScript are represented by Function objects, which are instances of the Function class.

Methods of a class are slightly different than Function objects. Unlike an ordinary function object, a method is tightly linked to its associated class object. Therefore, a method or property has a definition that is shared among all instances of the same class. Methods can be extracted from an instance and treated as "bound" methods (retaining the link to the original instance). For a bound method, the this keyword points to the original object that implemented the method. For a function, this points to the associated object at the time the function is invoked.

View the examples.

See also

Methods

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | apply(thisObject:Object, argArray:Array = null):void Specifies the value of thisObject to be used within any function that ActionScript calls. | Function
 | call(thisObject:Object, parameter1:String = null):void Invokes the function represented by a Function object. | Function
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
apply () method
AS3 function apply(thisObject:Object, argArray:Array = null):void

Specifies the value of thisObject to be used within any function that ActionScript calls. This method also specifies the parameters to be passed to any called function. Because apply() is a method of the Function class, it is also a method of every Function object in ActionScript.

The parameters are specified as an Array object, unlike Function.call(), which specifies parameters as a comma-delimited list. This is often useful when the number of parameters to be passed is not known until the script actually executes.

Returns the value that the called function specifies as the return value.

Parameters
thisObject:Object — The object to which the function is applied.
argArray:Array (default = null) — An array whose elements are passed to the function as parameters.

See also

Function.call()
call () method
AS3 function call(thisObject:Object, parameter1:String = null):void

Invokes the function represented by a Function object. Every function in ActionScript is represented by a Function object, so all functions support this method.

In almost all cases, the function call (()) operator can be used instead of this method. The function call operator produces code that is concise and readable. This method is primarily useful when the thisObject parameter of the function invocation needs to be explicitly controlled. Normally, if a function is invoked as a method of an object within the body of the function, thisObject is set to myObject, as shown in the following example:

  myObject.myMethod(1, 2, 3);

In some situations, you might want thisObject to point somewhere else; for example, if a function must be invoked as a method of an object, but is not actually stored as a method of that object:

  myObject.myMethod.call(myOtherObject, 1, 2, 3);

You can pass the value null for the thisObject parameter to invoke a function as a regular function and not as a method of an object. For example, the following function invocations are equivalent:

  Math.sin(Math.PI / 4)
  Math.sin.call(null, Math.PI / 4)

Returns the value that the called function specifies as the return value.

Parameters
thisObject:Object — An object that specifies the value of thisObject within the function body.
parameter1:String (default = null) — A parameter to be passed to the function. You can specify zero or more parameters.

See also

Function.apply()
Examples

The following example uses the FunctionExample, SimpleCollection, EventBroadcaster, and EventListener classes to show various uses of functions in ActionScript. This is accomplished with the following steps:
  1. The constructor for FunctionExample creates a local variable named simpleColl, which is populated with an array of integers ranging from 1 to 8.
  2. The simpleColl object is printed using trace().
  3. An EventListener object, listener, is added to simpleColl.
  4. When the insert() and remove() functions are called, the listener responds to their events.
  5. A second SimpleCollection object is created named greaterThanFourColl.
  6. The greaterThanFourColl object is assigned the result of simpleColl.select() with the argument 4 and an anonymous function. The SimpleCollection object's select method is an internal iterator that uses the anonymous function parameter as a block.
package {
    import flash.display.Sprite;

    public class FunctionExample extends Sprite {
        public function FunctionExample() {
            var simpleColl:SimpleCollection;
            simpleColl = new SimpleCollection(0, 1, 2, 3, 4, 5, 6, 7, 8);
            trace(simpleColl);        // 0, 1, 2, 3, 4, 5, 6, 7, 8

            var listener:EventListener = new EventListener();
            simpleColl.addListener(listener);
            simpleColl.insert(9);        // itemInsertedHandler: 9
            simpleColl.remove(8);        // itemRemovedHandler: 8
            trace(simpleColl);        // 0, 1, 2, 3, 4, 5, 6, 7, 9

            var greaterThanFourColl:SimpleCollection;
            greaterThanFourColl = simpleColl.select(4, function(item:int, value:int){ return item > value });
            trace(greaterThanFourColl);    // 5, 6, 7, 9
        }
    }
}

import flash.display.Sprite;

class EventBroadcaster {
    private var listeners:Array;

    public function EventBroadcaster() {
        listeners = new Array();
    }

    public function addListener(obj:Object):void {
        removeListener(obj);
        listeners.push(obj);
    }

    public function removeListener(obj:Object):void {
        for(var i:uint = 0; i < listeners.length; i++) {
            if(listeners[i] == obj) {
                listeners.splice(i, 1);
            }
        }
    }

    public function broadcastEvent(evnt:String, ...args):void {
        for(var i:uint = 0; i < listeners.length; i++) {
            listeners[i][evnt].apply(listeners[i], args);
        }
    }
}

class SimpleCollection extends EventBroadcaster {
    private var arr:Array;
        public function SimpleCollection(... args) {
        arr = (args.length == 1 && !isNaN(args[0])) ? new Array(args[0]) : args;
    }

    public function insert(obj:Object):void {
        remove(obj);
        arr.push(obj);
        broadcastEvent("itemInsertedHandler", obj);
    }

    public function remove(obj:Object):void {
        for(var i:uint = 0; i < arr.length; i++) {
            if(arr[i] == obj) {
                var obj:Object = arr.splice(i, 1)[0];
                broadcastEvent("itemRemovedHandler", obj);
            }
        }
    }

    public function select(val:int, fn:Function):SimpleCollection {
        var col:SimpleCollection = new SimpleCollection();
        for(var i:uint = 0; i < arr.length; i++) {
            if(fn.call(this, arr[i], val)) {
                col.insert(arr[i]);
            }
        }
        return col;
    }

    public function toString():String {
        var str:String = new String();
        for(var i:uint = 0; i < arr.length - 1; i++) {
            str += arr[i] + ", ";
        }
        str += arr[arr.length - 1];
        return str;
    }
}

class EventListener {
    public function EventListener() {
    }

    public function itemInsertedHandler(obj:Object):void {
        trace("itemInsertedHandler: " + obj);
    }

    public function itemRemovedHandler(obj:Object):void {
        trace("itemRemovedHandler: " + obj);
    }
}


int (Flex™ 2 Language Reference)

Class int | Properties | Methods | Constants | Examples
Package | Top Level
Class | public final class int
Inheritance | int Inheritance Object

The int class lets you work with the data type representing a 32-bit signed integer. The range of values represented by the int class is -2,147,483,648 (-2^31) to 2,147,483,647 (2^31-1).

The properties of the int class are static, which means that you don't need an object to use them, so you don't need to use the constructor. The methods, however, are not static, which means that you do need an object to use them. You can create an int object by using the int class constructor or by declaring a variable of type int and assigning the variable a literal value.

The int data type is useful for loop counters and other situations where a floating point number is not needed, and is similar to the int data type in Java and C++. The default value of a variable typed as int is 0

If you are working with numbers that exceed int.MAX_VALUE, consider using Number.

The following example calls the toString() method of the int class, which returns the string 1234:

 var myint:int = 1234;
 myint.toString();

The following example assigns the value of the MIN_VALUE property to a variable declared without the use of the constructor:

 var smallest:int = int.MIN_VALUE;

View the examples.

See also

uint
Number
Data type descriptions
Type conversions

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | int(num:Object) Constructor; creates a new int object. | int
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toExponential(fractionDigits:uint):String Returns a string representation of the number in exponential notation. | int
 | toFixed(fractionDigits:uint):String Returns a string representation of the number in fixed-point notation. | int
 | toPrecision(precision:uint):String Returns a string representation of the number either in exponential notation or in fixed-point notation. | int
 | toString(radix:uint):String Returns the string representation of an int object. | int
 | valueOf():int Returns the primitive value of the specified int object. | int
Public Constants
Constant |  | Defined by
 | MAX_VALUE : int = 2147483647 [static] The largest representable 32-bit signed integer, which is 2,147,483,647. | int
 | MIN_VALUE : int = -2147483648 [static] The smallest representable 32-bit signed integer, which is -2,147,483,648. | int
Constructor detail
int () constructor
public function int(num:Object)

Constructor; creates a new int object. You must use the int constructor when using int.toString() and int.valueOf(). You do not use a constructor when using the properties of an int object. The new int constructor is primarily used as a placeholder. An int object is not the same as the int() function that converts a parameter to a primitive value.

Parameters
num:Object — The numeric value of the int object being created or a value to be converted to a number. The default value is 0 if value is not provided.

See also

int.toString()
int.valueOf()
Data type descriptions
Type conversions

Example
The following code constructs new int objects:
  var n1:int = new int(3.4);
  var n2:int = new int(-10);

Method detail
toExponential () method
AS3 function toExponential(fractionDigits:uint):String

Returns a string representation of the number in exponential notation. The string contains one digit before the decimal point and up to 20 digits after the decimal point, as specified by the fractionDigits parameter.

Parameters
fractionDigits:uint — An integer between 0 and 20, inclusive, that represents the desired number of decimal places.

Returns
String

Throws
RangeError — Throws an exception if the fractionDigits argument is outside the range 0 to 20.

Example
The following example shows how toExponential(2) returns a string in exponential notation.

var num:Number = 315003;
trace(num.toExponential(2)); // Output: 3.15e+5

toFixed () method
AS3 function toFixed(fractionDigits:uint):String

Returns a string representation of the number in fixed-point notation. Fixed-point notation means that the string will contain a specific number of digits after the decimal point, as specified in the fractionDigits parameter. The valid range for the fractionDigits parameter is from 0 to 20. Specifying a value outside this range throws an exception.

Parameters
fractionDigits:uint — An integer between 0 and 20, inclusive, that represents the desired number of decimal places.

Returns
String

Throws
RangeError — Throws an exception if the fractionDigits argument is outside the range 0 to 20.

Example
The following example shows how toFixed(3) returns a string that rounds to three decimal places.

var num:Number = 7.31343;
trace(num.toFixed(3)); // Output: 7.313

The following example shows how toFixed(2) returns a string that adds trailing zeroes.

var num:Number = 4;
trace(num.toFixed(2)); // Output: 4.00

toPrecision () method
AS3 function toPrecision(precision:uint):String

Returns a string representation of the number either in exponential notation or in fixed-point notation. The string will contain the number of digits specified in the precision parameter.

Parameters
precision:uint — An integer between 1 and 21, inclusive, that represents the desired number of digits to represent in the resulting string.

Returns
String

Throws
RangeError — Throws an exception if the precision argument is outside the range 1 to 21.

Example
The following example shows how toPrecision(3) returns a string with only three digits. The string is in fixed-point notation because exponential notation is not required.

var num:Number = 31.570;
trace(num.toPrecision(3)); // Output: 31.6

The following example shows how toPrecision(3) returns a string with only three digits. The string is in exponential notation because the resulting number does not contain enough digits for fixed-point notation.

var num:Number = 4000;
trace(num.toPrecision(3)); // Output: 4.00e+3

toString () method
AS3 function toString(radix:uint):String

Returns the string representation of an int object.

Parameters
radix:uint — Specifies the numeric base (from 2 to 36) to use for the number-to-string conversion. If you do not specify the radix parameter, the default value is 10.

Returns
String — A string.

Example
The following example uses 2 and 8 for the radix parameter and returns a string that contains the corresponding representation of the number 9:
  var myint:int = new int(9);
  trace(myint.toString(2)); // output: 1001
  trace(myint.toString(8)); // output: 11

The following example results in a hexadecimal value.

  var r:int = new int(250);
  var g:int = new int(128);
  var b:int = new int(114);
  var rgb:String = "0x"+ r.toString(16)+g.toString(16)+b.toString(16);
  trace(rgb); // 0xfa8072

valueOf () method
AS3 function valueOf():int

Returns the primitive value of the specified int object.

Returns
int — An int value.

Example
The following example results in the primative value of the numSocks object.
  var numSocks:int = new int(2);
  trace(numSocks.valueOf()); // 2

Constant detail
MAX_VALUE constant
public static const MAX_VALUE:int = 2147483647

The largest representable 32-bit signed integer, which is 2,147,483,647.

Example
The following ActionScript displayswrites the largest and smallest representable int objects to the Output panelto the log file:
 trace("int.MIN_VALUE = "+int.MIN_VALUE);
 trace("int.MAX_VALUE = "+int.MAX_VALUE);

This code logsdisplays the following values:

 int.MIN_VALUE = -2147483648
 int.MAX_VALUE = 2147483647

MIN_VALUE constant
public static const MIN_VALUE:int = -2147483648

The smallest representable 32-bit signed integer, which is -2,147,483,648.

Example
The following ActionScript displayswrites the largest and smallest representable int objects to the Output panel to the log file:
     trace("int.MIN_VALUE = "+int.MIN_VALUE);
     trace("int.MAX_VALUE = "+int.MAX_VALUE);

This code logsdisplays the following values:

 int.MIN_VALUE = -2147483648
 int.MAX_VALUE = 2147483647

Examples

The following example uses the IntExample class to show how to work with and check the validity of int data types:
  1. Two int variables a and b are declared in the constructor.
  2. The two ints are added using the method addIntegers().
  3. A third int variable c is assigned the outcome of parseInteger(), which checks the validity of the string passed to it to ensure that it is an integer value in the acceptable range for int data types and returns an int equal to the integer value of the string if it is valid.
  4. The int variables a and c are added together using addIntegers().
package {
    import flash.display.Sprite;

    public class IntExample extends Sprite {
        public function IntExample() {
            var a:int = 512;
            var b:int = -128;

            trace(addIntegers(a, b)); // 384

            var c:int = parseInteger("32");

            trace(addIntegers(a, c)); // 544
        }

        public function addIntegers(a:int, b:int):int {
            return a + b;
        }

        public function parseInteger(str:String):int {
            var num:Number = parseInt(str);
            if(!isNaN(num) && num <= int.MAX_VALUE && num >= int.MIN_VALUE) {
                return int(num);
            }

            return 0;
        }

    }
}


Math (Flex™ 2 Language Reference)

Class Math | Properties | Methods | Constants
Package | Top Level
Class | public final class Math
Inheritance | Math Inheritance Object

The Math class contains methods and constants that represent common mathematical functions and values.

Use the methods and properties of this class to access and manipulate mathematical constants and functions. All the properties and methods of the Math class are static and must be called using the syntax Math.method(parameter) or Math.constant. In ActionScript, constants are defined with the maximum precision of double-precision IEEE-754 floating-point numbers.

Several Math class methods use the measure of an angle in radians as a parameter. You can use the following equation to calculate radian values before calling the method and then provide the calculated value as the parameter, or you can provide the entire right side of the equation (with the angle's measure in degrees in place of degrees) as the radian parameter.

To calculate a radian value, use the following formula:

 radians = degrees * Math.PI/180

To calculate degrees from radians, use the following formula:

 degrees = radians * 180/Math.PI

The following is an example of passing the equation as a parameter to calculate the sine of a 45° angle:

Math.sin(45 * Math.PI/180) is the same as Math.sin(.7854)

Note: The Math functions acos, asin, atan, atan2, cos, exp, log, pow, sin, and sqrt may result in slightly different values depending on the algorithms used by the CPU or operating system. Flash Player calls on the CPU (or operating system if the CPU doesn't support floating point calculations) when performing the calculations for the listed functions, and results have shown slight variations depending upon the CPU or operating system in use.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | abs(val:Number):Number [static] Computes and returns an absolute value for the number specified by the parameter val. | Math
 | acos(val:Number):Number [static] Computes and returns the arc cosine of the number specified in the parameter val, in radians. | Math
 | asin(val:Number):Number [static] Computes and returns the arc sine for the number specified in the parameter val, in radians. | Math
 | atan(val:Number):Number [static] Computes and returns the value, in radians, of the angle whose tangent is specified in the parameter val. | Math
 | atan2(y:Number, x:Number):Number [static] Computes and returns the angle of the point y/x in radians, when measured counterclockwise from a circle's x axis (where 0,0 represents the center of the circle). | Math
 | ceil(val:Number):Number [static] Returns the ceiling of the specified number or expression. | Math
 | cos(angleRadians:Number):Number [static] Computes and returns the cosine of the specified angle in radians. | Math
 | exp(val:Number):Number [static] Returns the value of the base of the natural logarithm (e), to the power of the exponent specified in the parameter x. | Math
 | floor(val:Number):Number [static] Returns the floor of the number or expression specified in the parameter val. | Math
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | log(val:Number):Number [static] Returns the natural logarithm of the parameter val. | Math
 | max(val1:Number, val2:Number, ... rest):Number [static] Evaluates val1 and val2 (or more values) and returns the largest value. | Math
 | min(val1:Number, val2:Number, ... rest):Number [static] Evaluates val1 and val2 (or more values) and returns the smallest value. | Math
 | pow(val1:Number, val2:Number):Number [static] Computes and returns val1 to the power of val2. | Math
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | random():Number [static] Returns a pseudo-random number n, where 0 <= n < 1. | Math
 | round(val:Number):Number [static] Rounds the value of the parameter val up or down to the nearest integer and returns the value. | Math
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | sin(angleRadians:Number):Number [static] Computes and returns the sine of the specified angle in radians. | Math
 | sqrt(val:Number):Number [static] Computes and returns the square root of the specified number. | Math
 | tan(angleRadians:Number):Number [static] Computes and returns the tangent of the specified angle. | Math
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | E : Number = 2.71828182845905 [static] A mathematical constant for the base of natural logarithms, expressed as e. | Math
 | LN10 : Number = 2.302585092994046 [static] A mathematical constant for the natural logarithm of 10, expressed as loge10, with an approximate value of 2.302585092994046. | Math
 | LN2 : Number = 0.6931471805599453 [static] A mathematical constant for the natural logarithm of 2, expressed as loge2, with an approximate value of 0.6931471805599453. | Math
 | LOG10E : Number = 0.4342944819032518 [static] A mathematical constant for the base-10 logarithm of the constant e (Math.E), expressed as log10e, with an approximate value of 0.4342944819032518. | Math
 | LOG2E : Number = 1.442695040888963387 [static] A mathematical constant for the base-2 logarithm of the constant e, expressed as log2e, with an approximate value of 1.442695040888963387. | Math
 | PI : Number = 3.141592653589793 [static] A mathematical constant for the ratio of the circumference of a circle to its diameter, expressed as pi, with a value of 3.141592653589793. | Math
 | SQRT1_2 : Number = 0.7071067811865476 [static] A mathematical constant for the square root of one-half, with an approximate value of 0.7071067811865476. | Math
 | SQRT2 : Number = 1.4142135623730951 [static] A mathematical constant for the square root of 2, with an approximate value of 1.4142135623730951. | Math
Method detail
abs () method
public static function abs(val:Number):Number

Computes and returns an absolute value for the number specified by the parameter val.

Parameters
val:Number — The number whose absolute value is returned.

Returns
Number — The absolute value of the specified paramater.
acos () method
public static function acos(val:Number):Number

Computes and returns the arc cosine of the number specified in the parameter val, in radians.

Parameters
val:Number — A number from -1.0 to 1.0.

Returns
Number — The arc cosine of the parameter val.
asin () method
public static function asin(val:Number):Number

Computes and returns the arc sine for the number specified in the parameter val, in radians.

Parameters
val:Number — A number from -1.0 to 1.0.

Returns
Number — A number between negative pi divided by 2 and positive pi divided by 2.
atan () method
public static function atan(val:Number):Number

Computes and returns the value, in radians, of the angle whose tangent is specified in the parameter val. The return value is between negative pi divided by 2 and positive pi divided by 2.

Parameters
val:Number — A number that represents the tangent of an angle.

Returns
Number — A number between negative pi divided by 2 and positive pi divided by 2.
atan2 () method
public static function atan2(y:Number, x:Number):Number

Computes and returns the angle of the point y/x in radians, when measured counterclockwise from a circle's x axis (where 0,0 represents the center of the circle). The return value is between positive pi and negative pi. Note that the first parameter to atan2 is always the y coordinate.

Parameters
y:Number — The y coordinate of the point.
x:Number — The x coordinate of the point.

Returns
Number — A number.

See also

Math.acos()
Math.asin()
Math.atan()
Math.cos()
Math.sin()
Math.tan()
ceil () method
public static function ceil(val:Number):Number

Returns the ceiling of the specified number or expression. The ceiling of a number is the closest integer that is greater than or equal to the number.

Parameters
val:Number — A number or expression.

Returns
Number — An integer that is both closest to, and greater than or equal to, the parameter val.

See also

Math.floor()
Math.round()
cos () method
public static function cos(angleRadians:Number):Number

Computes and returns the cosine of the specified angle in radians. To calculate a radian, see the overview of the Math class.

Parameters
angleRadians:Number — A number that represents an angle measured in radians.

Returns
Number — A number from -1.0 to 1.0.

See also

Math.acos()
Math.asin()
Math.atan()
Math.atan2()
Math.sin()
Math.tan()
exp () method
public static function exp(val:Number):Number

Returns the value of the base of the natural logarithm (e), to the power of the exponent specified in the parameter x. The constant Math.E can provide the value of e.

Parameters
val:Number — The exponent; a number or expression.

Returns
Number — e to the power of the parameter val.

See also

Math.E
floor () method
public static function floor(val:Number):Number

Returns the floor of the number or expression specified in the parameter val. The floor is the closest integer that is less than or equal to the specified number or expression.

Parameters
val:Number — A number or expression.

Returns
Number — The integer that is both closest to, and less than or equal to, the parameter val.
log () method
public static function log(val:Number):Number

Returns the natural logarithm of the parameter val.

Parameters
val:Number — A number or expression with a value greater than 0.

Returns
Number — The natural logarithm of parameter val.
max () method
public static function max(val1:Number, val2:Number, ... rest):Number

Evaluates val1 and val2 (or more values) and returns the largest value.

Parameters
val1:Number — A number or expression.
val2:Number — A number or expression.
... rest — A number or expression. Math.max() can accept multiple arguments.

Returns
Number — The largest of the parameters val1 and val2 (or more values).

See also

Math.min()
min () method
public static function min(val1:Number, val2:Number, ... rest):Number

Evaluates val1 and val2 (or more values) and returns the smallest value.

Parameters
val1:Number — A number or expression.
val2:Number — A number or expression.
... rest — A number or expression. Math.min() can accept multiple arguments.

Returns
Number — The smallest of the parameters val1 and val2 (or more values).

See also

Math.max()
pow () method
public static function pow(val1:Number, val2:Number):Number

Computes and returns val1 to the power of val2.

Parameters
val1:Number — A number to be raised by the power of the parameter val2.
val2:Number — A number specifying the power that the parameter val2 is raised by.

Returns
Number — The value of val1 raised to the power of val2.
random () method
public static function random():Number

Returns a pseudo-random number n, where 0 <= n < 1. The number returned is calculated in an undisclosed manner, and pseudo-random because the calculation inevitably contains some element of non-randomness.

Returns
Number — A pseudo-random number.
round () method
public static function round(val:Number):Number

Rounds the value of the parameter val up or down to the nearest integer and returns the value. If val is equidistant from its two nearest integers (that is, if the number ends in .5), the value is rounded up to the next higher integer.

Parameters
val:Number — The number to round.

Returns
Number — The parameter val rounded to the nearest whole number.

See also

Math.ceil()
Math.floor()
sin () method
public static function sin(angleRadians:Number):Number

Computes and returns the sine of the specified angle in radians. To calculate a radian, see the overview of the Math class.

Parameters
angleRadians:Number — A number that represents an angle measured in radians.

Returns
Number — A number; the sine of the specified angle (between -1.0 and 1.0).

See also

Math.acos()
Math.asin()
Math.atan()
Math.atan2()
Math.cos()
Math.tan()
sqrt () method
public static function sqrt(val:Number):Number

Computes and returns the square root of the specified number.

Parameters
val:Number — A number or expression greater than or equal to 0.

Returns
Number — If the parameter val is greater than or equal to zero, a number; otherwise NaN (not a number).
tan () method
public static function tan(angleRadians:Number):Number

Computes and returns the tangent of the specified angle. To calculate a radian, see the overview of the Math class.

Parameters
angleRadians:Number — A number that represents an angle measured in radians.

Returns
Number — The tangent of the parameter angleRadians.

See also

Math.acos()
Math.asin()
Math.atan()
Math.atan2()
Math.cos()
Math.sin()
Constant detail
E constant
public static const E:Number = 2.71828182845905

A mathematical constant for the base of natural logarithms, expressed as e. The approximate value of e is 2.71828182845905.

LN10 constant
public static const LN10:Number = 2.302585092994046

A mathematical constant for the natural logarithm of 10, expressed as loge10, with an approximate value of 2.302585092994046.

LN2 constant
public static const LN2:Number = 0.6931471805599453

A mathematical constant for the natural logarithm of 2, expressed as loge2, with an approximate value of 0.6931471805599453.

LOG10E constant
public static const LOG10E:Number = 0.4342944819032518

A mathematical constant for the base-10 logarithm of the constant e (Math.E), expressed as log10e, with an approximate value of 0.4342944819032518.

The Math.log() method computes the natural logarithm of a number. Multiply the result of Math.log() by Math.LOG10E to obtain the base-10 logarithm.

LOG2E constant
public static const LOG2E:Number = 1.442695040888963387

A mathematical constant for the base-2 logarithm of the constant e, expressed as log2e, with an approximate value of 1.442695040888963387.

The Math.log method computes the natural logarithm of a number. Multiply the result of Math.log() by Math.LOG2E to obtain the base-2 logarithm.

PI constant
public static const PI:Number = 3.141592653589793

A mathematical constant for the ratio of the circumference of a circle to its diameter, expressed as pi, with a value of 3.141592653589793.

SQRT1_2 constant
public static const SQRT1_2:Number = 0.7071067811865476

A mathematical constant for the square root of one-half, with an approximate value of 0.7071067811865476.

SQRT2 constant
public static const SQRT2:Number = 1.4142135623730951

A mathematical constant for the square root of 2, with an approximate value of 1.4142135623730951.


Namespace (Flex™ 2 Language Reference)

Class Namespace | Properties | Methods | Examples
Package | Top Level
Class | public final class Namespace
Inheritance | Namespace Inheritance Object

The Namespace class contains methods and properties for defining and working with namespaces. There are three scenarios for using namespaces:
  • Namespaces of XML objects Namespaces associate a namespace prefix with a Uniform Resource Identifier (URI) that identifies the namespace. The prefix is a string used to reference the namespace within an XML object. If the prefix is undefined, when the XML is converted to a string, a prefix is automatically generated.
  • Namespace to differentiate methods Namespaces can differentiate methods with the same name to perform different tasks. If two methods have the same name but separate namespaces, they can perform different tasks.
  • Namespaces for access control Namespaces can be used to control access to a group of properties and methods in a class. If you place the properties and methods into a private namespace, they are inaccessible to any code that does not have access to that namespace. You can grant access to the group of properties and methods by passing the namespace to other classes, methods or functions.

This class shows two forms of the constructor method because each form accepts different parameters.

This class (along with the XML, XMLList, and QName classes) implements powerful XML-handling standards defined in ECMAScript for XML (E4X) specification (ECMA-357 edition 2).

View the examples.

See also

XML
XMLList
QName
ECMAScript for XML (E4X) specification (ECMA-357 edition 2)
Using XML namespaces

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | prefix : String The prefix of the namespace. | Namespace
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | uri : String The Uniform Resource Identifier (URI) of the namespace. | Namespace
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Namespace(uriValue:*) Creates a Namespace object. | Namespace
 | Namespace(prefixValue:*, uriValue:*) Creates a Namespace object according to the values of the prefixValue and uriValue parameters. | Namespace
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Equivalent to the Namespace.uri property. | Namespace
 | valueOf():String Returns the URI value of the specified object. | Namespace
Property detail
prefix property
prefix:String [read-write]

The prefix of the namespace.

Implementation
    public function get prefix():String
    public function set prefix(value:String):void
uri property
uri:String [read-write]

The Uniform Resource Identifier (URI) of the namespace.

Implementation
    public function get uri():String
    public function set uri(value:String):void
Constructor detail
Namespace () constructor
public function Namespace(uriValue:*)

Creates a Namespace object. The values assigned to the uri and prefix properties of the new Namespace object depend on the type of value passed for the uriValue parameter:

  • If no value is passed, the prefix and uri properties are set to an empty string.
  • If the value is a Namespace object, a copy of the object is created.
  • If the value is a QName object, the uri property is set to the uri property of the QName object.

Note: This class shows two constructor entries because each form accepts different parameters. The constructor behaves differently depending on the type and number of parameters passed, as detailed in each entry. ActionSript 3.0 does not support method or constructor overloading.

Parameters
uriValue:* — The Uniform Resource Identifier (URI) of the namespace.
Namespace () constructor
public function Namespace(prefixValue:*, uriValue:*)

Creates a Namespace object according to the values of the prefixValue and uriValue parameters. This constructor requires both parameters.

The value of the prefixValue parameter is assigned to the prefix property as follows:

  • If undefined is passed, prefix is set to undefined.
  • If the value is a valid XML name, as determined by the isXMLName() function, it is converted to a string and assigned to the prefix property.
  • If the value is not a valid XML name, the prefix property is set to undefined.

The value of the uriValue parameter is assigned to the uri property as follows:

  • If a QName object is passed, the uri property is set to the value of the QName object's uri property.
  • Otherwise, the uriValue parameter is converted to a string and assigned to the uri property.

Note: This class shows two constructor method entries because each form accepts different parameters. The constructor behaves differently depending on the type and number of arguments passed, as detailed in each entry. ActionSript 3.0 does not support method or constructor overloading.

Parameters
prefixValue:* — The prefix to use for the namespace.
uriValue:* — The Uniform Resource Identifier (URI) of the namespace.
Method detail
toString () method
AS3 function toString():String

Equivalent to the Namespace.uri property.

Returns
String — The Uniform Resource Identifier (URI) of the namespace, as a string.
valueOf () method
AS3 function valueOf():String

Returns the URI value of the specified object.

Returns
String — The Uniform Resource Identifier (URI) of the namespace, as a string.
Examples

The following example shows how to work with namespaces defined in XML objects. This is accomplished with the following steps:
  1. The example defines three Namespace objects, each with a unique URI that defines a namespace.
  2. The example defines an XML variable named myXML and assigns it to the return value of getRSS(). The getRSS() method defines an XML object that contains several namespaces and returns that XML object.
  3. The example declares and evaluates an Array variable by calling the parseRSS() method with myXML passed to it. In parseRSS(), the default XML namespace is defined as rss and the example defines an XMLList variable by assigning the list of item objects in myXML. An array is created and populated with various nodes within myXML.item. The array is then returned.
  4. The elements in the array are printed using a for loop and three calls to trace().
package {
    import flash.display.Sprite;

    public class NamespaceExample extends Sprite {
        private var rss:Namespace = new Namespace("http://purl.org/rss/1.0/");
        private var rdf:Namespace = new Namespace("http://www.w3.org/1999/02/22-rdf-syntax-ns#");
        private var dc:Namespace  = new Namespace("http://purl.org/dc/elements/1.1/");

        public function NamespaceExample() {
            var myXML:XML = getRSS();
            var rssItems:Array = parseRSS(myXML);

            var len:uint = rssItems.length;
            for (var i:uint; i < len; i++) {
                trace(rssItems[i].title);
                trace(rssItems[i].creator);
                trace(rssItems[i].date);
                // Adobe Flash Developer Center
                // Adobe
                // 2005-08-08
                // Flex Developer Center
                // Adobe
                // 2005-10-16
            }
        }

        private function parseRSS(rssXML:XML):Array {
            default xml namespace = rss;

            var items:XMLList = rssXML.item;

            var arr:Array = new Array();
            var len:uint = items.length();
            for (var i:uint; i < len; i++) {
                arr.push({title:items[i].title, creator:items[i].dc::creator, date:items[i].dc::date});
            }

            return arr;
        }

        private function getRSS():XML {
            var myXML:XML =  <rdf:RDF
              xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
              xmlns="http://purl.org/rss/1.0/"
              xmlns:dc="http://purl.org/dc/elements/1.1/"
            >
              <channel rdf:about="http://www.xml.com/cs/xml/query/q/19">
                <title>Test RSS</title>
                <link>http://www.adobe.com/</link>
                <description>This is a test RSS document.</description>
                <language>en-us</language>
                <items>
                  <rdf:Seq>
                <rdf:li rdf:resource="http://www.adobe.com/devnet/flash/"/>
                <rdf:li rdf:resource="http://www.adobe.com/devnet/flex/"/>
                  </rdf:Seq>
                </items>
              </channel>
              <item rdf:about="http://www.adobe.com/devnet/flash/">
                <title>Adobe Flash Developer Center</title>
                <link>http://www.adobe.com/devnet/flash/</link>
                <description>Welcome to the Flash Developer Center</description>
                <dc:creator>Adobe</dc:creator>
                <dc:date>2005-08-08</dc:date>
              </item>
              <item rdf:about="http://www.adobe.com/devnet/flex/">
                <title>Flex Developer Center</title>
                <link>http://www.adobe.com/devnet/flex/</link>
                <description>Welcome to the Flex Developer Center</description>
                <dc:creator>Adobe</dc:creator>
                <dc:date>2005-10-16</dc:date>
              </item>
            </rdf:RDF>;

            return myXML;
        }
    }
}

The following example shows how namespaces can be used to differentiate methods that have the same name but perform different tasks. In this example, three methods named hello() reside in separate namespaces; each returns a different string when called.
package {

    import flash.display.Sprite;

    public class Namespace_2_Example extends Sprite {
        public function Namespace_2_Example() {
            var vocab:MultilingualVocabulary = new MultilingualVocabulary();

            trace(vocab.hello());    // hello

            var languages:Array = vocab.getLanguages();

            for (var i:uint; i < languages.length; i++) {
                var ns:Namespace = languages[i];
                if (ns != null) {
                    trace(ns.toString() + ": " + vocab.ns::hello());
                    // hello
                    // MultilingualVocabulary:Hawaiian: aloha
                    // MultilingualVocabulary:French: bon jour
                }
            }
        }
    }
}

class MultilingualVocabulary {
    public namespace French;
    public namespace Hawaiian;
    private var languages:Array;

    public function MultilingualVocabulary() {
        languages = new Array(Hawaiian, French);
    }

    public function hello():String {
        return "hello";
    }

    Hawaiian function hello():String {
        return "aloha";
    }

    French function hello():String {
        return "bon jour";
    }

    public function getLanguages():Array {
        return languages;
    }
}

The following example uses namespace names to select an appropriate variable value. It shows how you can store a namespace value in a variable and use that variable to refer to objects within that namespace.

The example defines namespaces and colors that correspond to mouse states for a rectangular button. Each time the button is drawn, the example applies the appropriate color (out is red; over is yellow; down is white) by referencing the bgcolor variable for the corresponding namespace (out, over, down).

package {
    import flash.display.Sprite;

    public class Namespace_3_Example extends Sprite {
        public function Namespace_3_Example() {
            addChild(new StateButton("Press Me."));
        }
    }
}

import flash.display.Sprite;
import flash.text.TextField;
import flash.events.Event;
import flash.events.MouseEvent;

class StateButton extends Sprite{
    private namespace out;
    private namespace over;
    private namespace down;
    private var label:TextField;
    private var labelTxt:String;
    private var ns:Namespace;
    out var bgColor:Number = 0xFF0000;
    over var bgColor:Number = 0xFFFF00;
    down var bgColor:Number = 0xFFFFFF;

    public function StateButton(str:String) {
        buttonMode = true;
        labelTxt = str;
        ns = out;
        draw();
        addLabel();
        addListeners();
    }

    private function addLabel():void {
        label = new TextField();
        label.text = labelTxt;
        label.width = 50;
        label.height = 20;
        label.mouseEnabled = false;
        addChild(label);
    }

    private function addListeners():void {
        addEventListener(MouseEvent.MOUSE_UP, mouseOverHandler);
        addEventListener(MouseEvent.MOUSE_OUT, mouseOutHandler);
        addEventListener(MouseEvent.MOUSE_OVER, mouseOverHandler);
        addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
    }

    private function mouseOutHandler(e:Event):void {
        ns = out;
        draw();
    }

    private function mouseOverHandler(e:Event):void {
        ns = over;
        draw();
    }

    private function mouseDownHandler(e:Event):void {
        ns = down;
        draw();
    }

    private function draw():void {
        this.graphics.clear();
        this.graphics.beginFill(ns::bgColor);
        this.graphics.drawRect(0, 0, 60, 20);
    }
}


Number (Flex™ 2 Language Reference)

Class Number | Properties | Methods | Constants | Examples
Package | Top Level
Class | public final class Number
Inheritance | Number Inheritance Object

A data type representing an IEEE-754 double-precision floating-point number. You can manipulate primitive numeric values by using the methods and properties associated with the Number class. This class is identical to the JavaScript Number class.

The properties of the Number class are static, which means you do not need an object to use them, so you do not need to use the constructor.

The Number data type adheres to the double-precision IEEE-754 standard.

The Number data type is useful when you need to use floating-point values. Flash Player handles int and uint data types more efficiently than Number, but Number is useful in situations where the range of values required exceeds the valid range of the int and uint data types. The Number class can be used to represent integer values well beyond the valid range of the int and uint data types. The Number data type can use up to 53 bits to represent integer values, compared to the 32 bits available to int and uint. The default value of a variable typed as Number is NaN (Not a Number).

View the examples.

See also

int
uint
Data type descriptions
Type conversions

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Number(num:Object) Creates a Number object with the specified value. | Number
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toExponential(fractionDigits:uint):String Returns a string representation of the number in exponential notation. | Number
 | toFixed(fractionDigits:uint):String Returns a string representation of the number in fixed-point notation. | Number
 | toPrecision(precision:uint):String Returns a string representation of the number either in exponential notation or in fixed-point notation. | Number
 | toString(radix:Number = 10):String Returns the string representation of the specified Number object (myNumber). | Number
 | valueOf():Number Returns the primitive value type of the specified Number object. | Number
Public Constants
Constant |  | Defined by
 | MAX_VALUE : Number [static] The largest representable number (double-precision IEEE-754). | Number
 | MIN_VALUE : Number [static] The smallest representable non-negative, non-zero, number (double-precision IEEE-754). | Number
 | NaN : Number [static] The IEEE-754 value representing Not a Number (NaN). | Number
 | NEGATIVE_INFINITY : Number [static] Specifies the IEEE-754 value representing negative infinity. | Number
 | POSITIVE_INFINITY : Number [static] Specifies the IEEE-754 value representing positive infinity. | Number
Constructor detail
Number () constructor
public function Number(num:Object)

Creates a Number object with the specified value. This constructor has the same effect as the Number() public native function that converts an object of a different type to a primitive numeric value.

Parameters
num:Object — The numeric value of the Number instance being created or a value to be converted to a Number. The default value is 0 if num is not specified. Using the constructor without specifying a num parameter is not the same as declaring a variable of type Number with no value assigned (such as var myNumber:Number), which defaults to NaN. A number with no value assigned is undefined and the equivalent of new Number(undefined).

See also

Number.toString()
Number.valueOf()
Data type descriptions
Type conversions
Method detail
toExponential () method
AS3 function toExponential(fractionDigits:uint):String

Returns a string representation of the number in exponential notation. The string contains one digit before the decimal point and up to 20 digits after the decimal point, as specified by the fractionDigits parameter.

Parameters
fractionDigits:uint — An integer between 0 and 20, inclusive, that represents the desired number of decimal places.

Returns
String

Throws
RangeError — Throws an exception if the fractionDigits argument is outside the range 0 to 20.

Example
The following example shows how toExponential(2) returns a string in exponential notation.

var num:Number = 315003;
trace(num.toExponential(2)); // Output: 3.15e+5

toFixed () method
AS3 function toFixed(fractionDigits:uint):String

Returns a string representation of the number in fixed-point notation. Fixed-point notation means that the string will contain a specific number of digits after the decimal point, as specified in the fractionDigits parameter. The valid range for the fractionDigits parameter is from 0 to 20. Specifying a value outside this range throws an exception.

Parameters
fractionDigits:uint — An integer between 0 and 20, inclusive, that represents the desired number of decimal places.

Returns
String

Throws
RangeError — Throws an exception if the fractionDigits argument is outside the range 0 to 20.

Example
The following example shows how toFixed(3) returns a string that rounds to three decimal places.

var num:Number = 7.31343;
trace(num.toFixed(3)); // Output: 7.313

The following example shows how toFixed(2) returns a string that adds trailing zeroes.

var num:Number = 4;
trace(num.toFixed(2)); // Output: 4.00

toPrecision () method
AS3 function toPrecision(precision:uint):String

Returns a string representation of the number either in exponential notation or in fixed-point notation. The string will contain the number of digits specified in the precision parameter.

Parameters
precision:uint — An integer between 1 and 21, inclusive, that represents the desired number of digits to represent in the resulting string.

Returns
String

Throws
RangeError — Throws an exception if the precision argument is outside the range 1 to 21.

Example
The following example shows how toPrecision(3) returns a string with only three digits. The string is in fixed-point notation because exponential notation is not required.

var num:Number = 31.570;
trace(num.toPrecision(3)); // Output: 31.6

The following example shows how toPrecision(3) returns a string with only three digits. The string is in exponential notation because the resulting number does not contain enough digits for fixed-point notation.

var num:Number = 4000;
trace(num.toPrecision(3)); // Output: 4.00e+3

toString () method
AS3 function toString(radix:Number = 10):String

Returns the string representation of the specified Number object (myNumber). If the value of the Number object is a decimal number without a leading zero (such as .4), Number.toString() adds a leading zero (0.4).

Parameters
radix:Number (default = 10) — Specifies the numeric base (from 2 to 36) to use for the number-to-string conversion. If you do not specify the radix parameter, the default value is 10.

Returns
String — The numeric representation of the Number object as a string.
valueOf () method
AS3 function valueOf():Number

Returns the primitive value type of the specified Number object.

Returns
Number — The primitive type value of the Number object.
Constant detail
MAX_VALUE constant
public static const MAX_VALUE:Number

The largest representable number (double-precision IEEE-754). This number is approximately 1.79e+308.

MIN_VALUE constant
public static const MIN_VALUE:Number

The smallest representable non-negative, non-zero, number (double-precision IEEE-754). This number is approximately 5e-324. The smallest representable number overall is actually -Number.MAX_VALUE.

NaN constant
public static const NaN:Number

The IEEE-754 value representing Not a Number (NaN).

See also

isNaN()
NEGATIVE_INFINITY constant
public static const NEGATIVE_INFINITY:Number

Specifies the IEEE-754 value representing negative infinity. The value of this property is the same as that of the constant -Infinity.

Negative infinity is a special numeric value that is returned when a mathematical operation or function returns a negative value larger than can be represented.

POSITIVE_INFINITY constant
public static const POSITIVE_INFINITY:Number

Specifies the IEEE-754 value representing positive infinity. The value of this property is the same as that of the constant Infinity.

Positive infinity is a special numeric value that is returned when a mathematical operation or function returns a value larger than can be represented.

Examples

The following example shows how a number with six digits after the decimal place is truncated (with rounding) to a number with two digits after the decimal point.

package {
    import flash.display.Sprite;

    public class NumberExample extends Sprite {
        public function NumberExample() {
            var num:Number = new Number(10.456345);
            var str:String = num.toFixed(2);
            trace(num); // 10.456345
            trace(str); // 10.46
        }
    }
}


Object (Flex™ 2 Language Reference)

Class Object | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class Object
Subclasses | AbstractMessage, AbstractTarget, Accessibility, AccessibilityProperties, ActionScriptVersion, AddChild, AntiAliasType, ApplicationDomain, arguments, Array, ArrayUtil, AxisLabel, AxisLabelSet, Back, BaseListData, BindingUtils, BitmapData, BitmapDataChannel, BitmapFill, BitmapFilter, BitmapFilterQuality, BitmapFilterType, BlendMode, Boolean, Bounce, BoundedValue, BoxDirection, ButtonLabelPlacement, ByteArray, Capabilities, CapsStyle, ChangeWatcher, ChartState, Circular, Class, ClassFactory, CollectionEventKind, ColorTransform, ColorUtil, ComponentDescriptor, Conflict, ConflictDetector, ContainerCreationPolicy, ContainerLayout, ContextMenuBuiltInItems, CreditCardValidatorCardType, CSMSettings, Cubic, CuePointManager, CurrencyValidatorAlignSymbol, CursorBookmark, CursorManager, CursorManagerPriority, DataDescription, DataGridEventReason, DataService, Date, DateBase, DateChooserEventDetail, DefaultDataDescriptor, DeferredInstanceFromClass, DeferredInstanceFromFunction, DescribeTypeCache, Dictionary, DisplacementMapFilterMode, DragManager, DragSource, EdgeMetrics, EffectTargetFilter, Elastic, Endian, Error, Event, EventDispatcher, EventPhase, EventPriority, Exponential, ExternalInterface, FileFilter, FlexPrintJob, FlexPrintJobScaleType, FocusManager, Font, FontStyle, FontType, Formatter, FormItemDirection, FrameLabel, Function, GradientEntry, GradientType, Graphics, GraphicsUtil, GridFitType, HaloColors, HistoryManager, HitData, ID3Info, IMEConversionMode, InstanceCache, int, InterpolationMethod, ItemResponder, JointStyle, Keyboard, KeyLocation, LegendData, Linear, LineScaleMode, LineSeriesSegment, ListBaseSeekPending, ListBaseSelectionData, ListEventReason, ListRowInfo, LoaderConfig, LoaderContext, Locale, Log, LogEventLevel, Managed, Math, Matrix, MBeanFeatureInfo, MBeanInfo, Mouse, Namespace, NameUtil, Number, NumberBase, NumberBaseRoundType, Object, ObjectEncoding, ObjectInstance, ObjectName, ObjectUtil, PageInformation, PixelSnapping, Point, PopUpManager, PopUpManagerChildList, PrintJobOptions, PrintJobOrientation, ProgressBarDirection, ProgressBarLabelPlacement, ProgressBarMode, PropertyChangeEventKind, PropertyChanges, Proxy, QName, Quadratic, Quartic, Quintic, Rectangle, RectangularDropShadow, RegExp, RemoveChild, RenderData, ResourceBundle, Responder, Scene, ScrollBarDirection, ScrollEventDetail, ScrollEventDirection, ScrollPolicy, Security, SecurityDomain, SecurityPanel, ServerConfig, SetProperty, SetStyle, SharedObjectFlushStatus, SimpleXMLDecoder, SimpleXMLEncoder, Sine, SliderDirection, SliderEventClickTarget, SOAPHeader, SolidColor, SoundLoaderContext, SoundMixer, SoundTransform, SpreadMethod, StageAlign, StageQuality, StageScaleMode, String, StringUtil, Stroke, StyleManager, SWFVersion, SwitchSymbolFormatter, System, TextColorType, TextDisplayMode, TextFieldAutoSize, TextFieldType, TextFormat, TextFormatAlign, TextLineMetrics, TextRange, TextRenderer, TextSnapshot, TileBaseDirection, TileDirection, Transform, Transition, UIComponentCachePolicy, UIDUtil, uint, UpdateCollectionRange, URLLoaderDataFormat, URLRequest, URLRequestHeader, URLRequestMethod, URLUtil, URLVariables, ValidationResult, XML, XMLList, XMLNode, XMLNodeType, XMLUtil, ZipCodeValidatorDomainType

The Object class is at the root of the ActionScript class hierarchy. Objects are created by constructors using the new operator syntax, and can have properties assigned to them dynamically. Objects can also be created by assigning an object literal, as in:
var obj:Object = {a:"foo", b:"bar"}

All classes that don't declare an explicit base class extend the built-in Object class.

You can use the Object class to create associative arrays. At its core, an associative array is an instance of the Object class, and each key-value pair is represented by a property and its value. Another reason to declare an associative array using the Object data type is that you can then use an object literal to populate your associative array (but only at the time you declare it). The following example creates an associative array using an object literal, accesses items using both the dot operator and the array access operator, and then adds a new key-value pair by creating a new property:

 var myAssocArray:Object = {fname:"John", lname:"Public"};
 trace(myAssocArray.fname);     // Output: John
 trace(myAssocArray["lname"]);  // Output: Public
 myAssocArray.initial = "Q";
 trace(myAssocArray.initial);   // Output: Q

ActionScript 3.0 has two types of inheritance: class inheritance and prototype inheritance:

  • Class inheritance - is the primary inheritance mechanism and supports inheritance of fixed properties. A fixed property is a variable, constant or method declared as part of a class definition. Every class definition is now represented by a special class object that stores information about the class.
  • Prototype inheritance - is the only inheritance mechanism in previous versions of ActionScript and serves as an alternate form of inheritance in ActionScript 3.0. Each class has an associated prototype object, and the properties of the prototype object are shared by all instances of the class. When a class instance is created, it has a reference to its class's prototype object, which serves as a link between the instance and its associated class prototype object. At run time, when a property is not found on a class instance, the delegate, which is the class prototype object, is checked for that property. If the prototype object does not contain the property, the process continues with the prototype object's delegate checking in consecutively higher levels in the hierarchy until Flash Player finds the property.

Both class inheritance and prototype inheritance can exist simultaneously, as shown in the following example:

 class A {
     var x = 1
     prototype.px = 2
 }
 dynamic class B extends A {
     var y = 3
     prototype.py = 4
 }

 var b = new B()
 b.x // 1 via class inheritance
 b.px // 2 via prototype inheritance from A.prototype
 b.y // 3
 b.py // 4 via prototype inheritance from B.prototype

 B.prototype.px = 5
 b.px // now 5 because B.prototype hides A.prototype

 b.px = 6
 b.px // now 6 because b hides B.prototype

Using functions instead of classes, you can construct custom prototype inheritance trees. With classes, the prototype inheritance tree mirrors the class inheritance tree. However, since the prototype objects are dynamic, you can add and delete prototype-based properties at run time.

View the examples.

See also

prototype
Data type descriptions

Public Properties
Property |  | Defined by
 | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Method |  | Defined by
 | Object() Creates an Object object and stores a reference to the object's constructor method in the object's constructor property. | Object
 | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns the string representation of the specified object. | Object
 | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
constructor property
public var constructor:Object

A reference to the class object or constructor function for a given object instance. If an object is an instance of a class, the constructor property holds a reference to the class object. If an object is created with a constructor function, the constructor property holds a reference to the constructor function. Do not confuse a constructor function with a constructor method of a class. A constructor function is a Function object used to create objects, and is an alternative to using the class keyword for defining classes.

If you use the class keyword to define a class, the class's prototype object is assigned a property named constructor that holds a reference to the class object. An instance of the class inherits this property from the prototype object. For example, the following code creates a new class, A, and a class instance named myA:

  dynamic class A {}
  trace(A.prototype.constructor);      // [class A]
  trace(A.prototype.constructor == A); // true
  var myA:A = new A();
  trace(myA.constructor == A);         // true

Advanced users may choose to use the function keyword instead of the class keyword to define a Function object that can be used as a template for creating objects. Such a function is called a constructor function because you can use it in conjunction with the new operator to create objects. If you use the function keyword to create a constructor function, its prototype object is assigned a property named constructor that holds a reference to the constructor function. If you then use the constructor function to create an object, the object inherits the constructor property from the constructor function's prototype object. For example, the following code creates a new constructor function, f, and an object named myF:

  function f() {}
  trace(f.prototype.constructor);      // function Function() {}
  trace(f.prototype.constructor == f); // true
  var myF = new f();
  trace(myF.constructor == f);         // true

Note: The constructor property is writable, which means that user code can change its value with an assignment statement. Changing the value of the constructor property is not recommended, but if you write code that depends on the value of the constructor property, you should ensure that the value is not reset. The value can be changed only when the property is accessed through the prototype object (for example, className.prototype.constructor).

See also

Class
Function
prototype
Methods
prototype property
public static var prototype:Object

A reference to the prototype object of a class or function object. The prototype property is automatically created and attached to any class or function object that you create. This property is static in that it is specific to the class or function that you create. For example, if you create a class, the value of the prototype property is shared by all instances of the class and is accessible only as a class property. Instances of your class cannot directly access the prototype property.

A class's prototype object is a special instance of that class that provides a mechanism for sharing state across all instances of a class. At run time, when a property is not found on a class instance, the delegate, which is the class prototype object, is checked for that property. If the prototype object does not contain the property, the process continues with the prototype object's delegate checking in consecutively higher levels in the hierarchy until Flash Player finds the property.

Note: In ActionScript 3.0, prototype inheritance is not the primary mechanism for inheritance. Class inheritance, which drives the inheritance of fixed properties in class definitions, is the primary inheritance mechanism in ActionScript 3.0.

See also

Advanced topics
Constructor detail
Object () constructor
public function Object()

Creates an Object object and stores a reference to the object's constructor method in the object's constructor property.

See also

Data type descriptions
Method detail
hasOwnProperty () method
AS3 function hasOwnProperty(name:String):Boolean

Indicates whether an object has a specified property defined. This method returns true if the target object has a property that matches the string specified by the name parameter, and false otherwise. The following types of properties cause this method to return true for objects that are instances of a class (as opposed to class objects):

  • Fixed instance properties—variables, constants, or methods defined by the object's class that are not static;
  • Inherited fixed instance properties—variables, constants, or methods inherited by the object's class;
  • Dynamic properties—properties added to an object after it is instantiated (outside of its class definition). To add dynamic properties, the object's defining class must be declared with the dynamic keyword.

The following types of properties cause this method to return false for objects that are instances of a class:

  • Static properties—variables, constants, or methods defined with the static keyword in an object's defining class or any of its superclasses;
  • Prototype properties—properties defined on a prototype object that is part of the object's prototype chain. In ActionScript 3.0, the prototype chain is not used for class inheritance, but still exists as an alternative form of inheritance. For example, an instance of the Array class can access the valueOf() method because it exists on Object.prototype, which is part of the prototype chain for the Array class. Although you can use valueOf() on an instance of Array, the return value of hasOwnProperty("valueOf") for that instance is false.

ActionScript 3.0 also has class objects, which are direct representations of class definitions. When called on class objects, the hasOwnProperty() method returns true only if a property is a static property defined on that class object. For example, if you create a subclass of Array named CustomArray, and define a static property in CustomArray named foo, a call to CustomArray.hasOwnProperty("foo") returns true. For the static property DESCENDING defined in the Array class, however, a call to CustomArray.hasOwnProperty("DESCENDING") returns false.

Note: Methods of the Object class are dynamically created on Object's prototype. To redefine this method in a subclass of Object, do not use the override keyword. For example, A subclass of Object implements function hasOwnProperty():Boolean instead of using an override of the base class.

Parameters
name:String — The property of the object.

Returns
Boolean — If the target object has the property specified by the name parameter this value is true, otherwise false.
isPrototypeOf () method
AS3 function isPrototypeOf(theClass:Object):Boolean

Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. This method returns true if the object is in the prototype chain of the object specified by the theClass parameter. The method returns false if the target object is absent from the prototype chain of the theClass object, and also if the theClass parameter is not an object.

Note: Methods of the Object class are dynamically created on Object's prototype. To redefine this method in a subclass of Object, do not use the override keyword. For example, A subclass of Object implements function isPrototypeOf():Boolean instead of using an override of the base class.

Parameters
theClass:Object — The class to which the specified object may refer.

Returns
Boolean — If the object is in the prototype chain of the object specified by the theClass parameter this value is true, otherwise false.
propertyIsEnumerable () method
AS3 function propertyIsEnumerable(name:String):Boolean

Indicates whether the specified property exists and is enumerable. If true, then the property exists and can be enumerated in a for..in loop. The property must exist on the target object because this method does not check the target object's prototype chain.

Properties that you create are enumerable, but built-in properties are generally not enumerable.

Note: Methods of the Object class are dynamically created on Object's prototype. To redefine this method in a subclass of Object, do not use the override keyword. For example, A subclass of Object implements function propertyIsEnumerable():Boolean instead of using an override of the base class.

Parameters
name:String — The property of the object.

Returns
Boolean — If the property specified by the name parameter is enumerable this value is true, otherwise false.
setPropertyIsEnumerable () method
public function setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void

Sets the availability of a dynamic property for loop operations. The property must exist on the target object because this method does not check the target object's prototype chain.

Parameters
name:String — The property of the object.
isEnum:Boolean (default = true) — If set to false, the dynamic property does not show up in for..in loops, and the method propertyIsEnumerable() returns false.

See also

propertyIsEnumerable()
toString () method
public function toString():String

Returns the string representation of the specified object.

Note: Methods of the Object class are dynamically created on Object's prototype. To redefine this method in a subclass of Object, do not use the override keyword. For example, A subclass of Object implements function toString():String instead of using an override of the base class.

Returns
String — A string representation of the object.
valueOf () method
public function valueOf():Object

Returns the primitive value of the specified object. If this object does not have a primitive value, the object itself is returned.

Note: Methods of the Object class are dynamically created on Object's prototype. To redefine this method in a subclass of Object, do not use the override keyword. For example, A subclass of Object implements function valueOf():Object instead of using an override of the base class.

Returns
Object — The primitive value of this object or the object itself.

See also

Object.toString()
Examples

The following example uses the classes ObjectExample and Circle to demonstrate the dynamic nature of the Object class, and how value objects can be transformed into Shape objects and then added to the stage at the specified x/y coordinates.

The example creates the value objects firstInitObj and secondInitObj. The custom class Circle accepts the value object and loops over it while setting its matching internal properties to those defined in the value object.

package {
    import flash.display.Sprite;

    public class ObjectExample extends Sprite {
        public function ObjectExample() {
            var firstInitObj:Object = new Object();
            firstInitObj.bgColor = 0xFF0000;
            firstInitObj.radius = 25;
            firstInitObj.xCenter = 25;
            firstInitObj.yCenter = 25;

            var firstCircle:Circle = new Circle(firstInitObj);
            addChild(firstCircle);
            firstCircle.x = 50;
            firstCircle.y = 50;

            var secondInitObj:Object = {bgColor:0xCCCCCC, radius:50, xCenter:50, yCenter:50};

            var secondCircle:Circle = new Circle(secondInitObj);
            addChild(secondCircle);
            secondCircle.x = 100;
            secondCircle.y = 100;
        }

    }
}

import flash.display.Shape;

class Circle extends Shape {
    public var bgColor:Number = 0xFFFFFF;
    public var radius:Number = 0;
    public var xCenter:Number = 0;
    public var yCenter:Number = 0;

    public function Circle(initObj:Object) {
        for(var i:String in initObj) {
            this[i] = initObj[i];
        }
        draw();
    }

    public function draw():void {
        graphics.beginFill(bgColor);
        graphics.drawCircle(xCenter, yCenter, radius);
        graphics.endFill();
    }
}


QName (Flex™ 2 Language Reference)

Class QName | Properties | Methods | Examples
Package | Top Level
Class | public final class QName
Inheritance | QName Inheritance Object

QName objects represent qualified names of XML elements and attributes. Each QName object has a local name and a namespace Uniform Resource Identifier (URI). When the value of the namespace URI is null, the QName object matches any namespace. Use the QName constructor to create a new QName object that is either a copy of another QName object or a new QName object with a uri from a Namespace object and a localName from a QName object.

Methods specific to E4X can use QName objects interchangeably with strings. E4X methods are in the QName, Namespace, XML, and XMLList classes. These E4X methods, which take a string, can also take a QName object. This interchangeability is how namespace support works with, for example, the XML.child() method.

The QName class (along with the XML, XMLList, and Namespace classes) implements powerful XML-handling standards defined in ECMAScript for XML (E4X) specification (ECMA-357 edition 2).

A qualified identifier evaluates to a QName object. If the QName object of an XML element is specified without identifying a namespace, the uri property of the associated QName object is set to the global default namespace. If the QName object of an XML attribute is specified without identifying a namespace, the uri property is set to an empty string.

View the examples.

See also

XML
XMLList
Namespace
ECMAScript for XML (E4X) specification (ECMA-357 edition 2)

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | localName : String [read-only] The local name of the QName object. | QName
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | uri : String [read-only] The Uniform Resource Identifier (URI) of the QName object. | QName
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | QName(qname:QName) Creates a QName object that is a copy of another QName object. | QName
 | QName(uri:Namespace, localName:QName) Creates a QName object with a URI object from a Namespace object and a localName from a QName object. | QName
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string composed of the URI, and the local name for the QName object, separated by "::". | QName
 | valueOf():QName Returns the QName object. | QName
Property detail
localName property
localName:String [read-only]

The local name of the QName object.

Implementation
    public function get localName():String
uri property
uri:String [read-only]

The Uniform Resource Identifier (URI) of the QName object.

Implementation
    public function get uri():String
Constructor detail
QName () constructor
public function QName(qname:QName)

Creates a QName object that is a copy of another QName object. If the parameter passed to the constructor is a QName object, a copy of the QName object is created. If the parameter is not a QName object, the parameter is converted to a string and assigned to the localName property of the new QName instance. If the parameter is undefined or unspecified, a new QName object is created with the localName property set to the empty string.

Note: This class shows two constructor entries because each form accepts different parameters. The constructor behaves differently depending on the type and number of parameters passed, as detailed in each entry. ActionSript 3.0 does not support method or constructor overloading.

Parameters
qname:QName — The QName object to be copied. Objects of any other type are converted to a string that is assigned to the localName property of the new QName object.
QName () constructor
public function QName(uri:Namespace, localName:QName)

Creates a QName object with a URI object from a Namespace object and a localName from a QName object. If either parameter is not the expected data type, the parameter is converted to a string and assigned to the corresponding property of the new QName object. For example, if both parameters are strings, a new QName object is returned with a uri property set to the first parameter and a localName property set to the second parameter. In other words, the following permutations, along with many others, are valid forms of the constructor:

QName (uri:Namespace, localName:String);
QName (uri:String, localName: QName);
QName (uri:String, localName: String);

If you pass null for the uri parameter, the uri property of the new QName object is set to null.

Note: This class shows two constructor entries because each form accepts different parameters. The constructor behaves differently depending on the type and number of parameters passed, as detailed in each entry. ActionSript 3.0 does not support method or constructor overloading.

Parameters
uri:Namespace — A Namespace object from which to copy the uri value. A parameter of any other type is converted to a string.
localName:QName — A QName object from which to copy the localName value. A parameter of any other type is converted to a string.
Method detail
toString () method
AS3 function toString():String

Returns a string composed of the URI, and the local name for the QName object, separated by "::".

The format depends on the uri property of the QName object:
If uri == ""
toString returns localName
else if uri == null
toString returns *::localName
else toString returns uri::localName

Returns
String — The qualified name, as a string.
valueOf () method
AS3 function valueOf():QName

Returns the QName object.

Returns
QName — The primitive value of a QName instance.
Examples

The following example shows how to create a QName instance and use it to select XML elements. Two ways of creating a QName are shown:
  1. Creating a Namespace instance and then using it as input to the QName constructor. This approach is best if you want to use the Namespace.prefix property for other purposes later.
  2. Creating a QName instance using a simple string value for the uri parameter in the QName constructor.

This code does the following things:

  1. Defines an XML variable named rssXML.
  2. Creates a new Namespace object with the prefix dc.
  3. Creates a new QName object using the Namespace object and the local name creator.
  4. Calls the showDescendants() method, which uses the XML.descendants() method to get an XMLList instance containing all the descendant elements whose qualified name matches the given QName instance.
  5. Displays the qualified name and the text value of each element in the list using a for each loop.
  6. Creates another QName object using a string value for the uri parameter and the local name date.
  7. Calls the showDescendants() method again to display the name and text value of the descendant elements.
package
{
    import flash.display.Sprite;

    public class QNameExample extends Sprite
    {
        public function QNameExample()
        {
            var rssXML:XML =  <rdf:RDF
              xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
              xmlns="http://purl.org/rss/1.0/"
              xmlns:dc="http://purl.org/dc/elements/1.1/">
              <channel rdf:about="http://www.xml.com/cs/xml/query/q/19">
                <title>Test RSS</title>
                <link>http://www.adobe.com/</link>
                <description>This is a test RSS document.</description>
                <language>en-us</language>
                <items>
                  <rdf:Seq>
                <rdf:li rdf:resource="http://www.adobe.com/devnet/flash/"/>
                <rdf:li rdf:resource="http://www.adobe.com/devnet/flex/"/>
                  </rdf:Seq>
                </items>
              </channel>
              <item rdf:about="http://www.adobe.com/devnet/flash/">
                <title>Flash Developer Center</title>
                <link>http://www.adobe.com/devnet/flash/</link>
                <description>Welcome to the Flash Developer Center</description>
                <dc:creator>Adobe</dc:creator>
                <dc:date>2005-08-08</dc:date>
              </item>
              <item rdf:about="http://www.adobe.com/devnet/flex/">
                <title>Flex Developer Center</title>
                <link>http://www.adobe.com/devnet/flex/</link>
                <description>Welcome to the Flex Developer Center</description>
                <dc:creator>Adobe</dc:creator>
                <dc:date>2005-10-16</dc:date>
              </item>
            </rdf:RDF>;

            var dcNamespace:Namespace = new Namespace("dc", "http://purl.org/dc/elements/1.1/");
            var creatorQName:QName = new QName(dcNamespace, "creator");
            trace(creatorQName.uri); // http://purl.org/dc/elements/1.1/
            trace(creatorQName.localName); // creator

            showDescendants(rssXML, creatorQName);

            var dateQName:QName = new QName("http://purl.org/dc/elements/1.1/", "date");
            trace(dateQName.uri); // http://purl.org/dc/elements/1.1/
            trace(dateQName.localName); // date

            showDescendants(rssXML, dateQName);
        }

        public function showDescendants(xmlData:XML, qualifiedName:QName):void
        {
            var decendantList:XMLList = xmlData.descendants(qualifiedName);

            for each (var element:XML in decendantList)
            {
                trace(element.name()); // the fully qualified name,
                                       // like "http://purl.org/dc/elements/1.1/::creator"
                trace(element); // the simple text value of each element, like "Adobe"
            }
        }
    }
}


RangeError (Flex™ 2 Language Reference)

Class RangeError | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class RangeError
Inheritance | RangeError Inheritance Error Inheritance Object

A RangeError exception is thrown when a numeric value is outside the acceptable range. When working with arrays, referring to an index position of an array item that does not exist will throw a RangeError exception. Using Number.toExponential(), Number.toPrecision(), and Number.toFixed() methods will throw a RangeError exception in cases where the arguments are outside the acceptable range of numbers. You can extend Number.toExponential(), Number.toPrecision(), and Number.toFixed() to avoid throwing a RangeError. Other situations that cause this exception to be thrown include the following:
  • Any Flash Player API that expects a depth number is invoked with an invalid depth number.
  • Any Flash Player API that expects a frame number is invoked with an invalid frame number.
  • Any Flash Player API that expects a layer number is invoked with an invalid layer number.

View the examples.

See also

Number.toExponential()
Number.toPrecision()
Number.toFixed()
Error handling in ActionScript 3.0
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RangeError(message:String = "") Creates a new RangeError object. | RangeError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
RangeError () constructor
public function RangeError(message:String = "")

Creates a new RangeError object.

Parameters
message:String (default = "") — Contains the message associated with the RangeError object.

See also

Error handling in ActionScript 3.0
Responding to error events and status
Examples

The following example shows how a RangeError exception can be generated and handled within a try..catch statement.
package {
    import flash.display.Sprite;

    public class RangeErrorExample extends Sprite {

        public function RangeErrorExample() {
            var child:Sprite = new Sprite();
            try {
                addChildAt(child, 1);
            }
            catch(e:RangeError) {
                trace(e);
            }
        }
    }
}


ReferenceError (Flex™ 2 Language Reference)

Class ReferenceError | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class ReferenceError
Inheritance | ReferenceError Inheritance Error Inheritance Object

A ReferenceError exception is thrown when a reference to an undefined property is attempted on a sealed (nondynamic) object. References to undefined variables will result in ReferenceError exceptions to inform you of potential bugs and help you troubleshoot application code.

However, you can refer to undefined properties of a dynamic class without causing a ReferenceError exception to be thrown. For more information, see the dynamic keyword.

View the examples.

See also

dynamic keyword
Error handling in ActionScript 3.0
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ReferenceError(message:String = "") Creates a new ReferenceError object. | ReferenceError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
ReferenceError () constructor
public function ReferenceError(message:String = "")

Creates a new ReferenceError object.

Parameters
message:String (default = "") — Contains the message associated with the ReferenceError object.

See also

Error handling in ActionScript 3.0
Responding to error events and status
Examples

The following example shows how a ReferenceError exception can be generated and handled within a try..catch statement.
package {
    import flash.display.Sprite;

    public class ReferenceErrorExample extends Sprite {

        public function ReferenceErrorExample() {
            try {
                this["someMember"] = true;
            }
            catch(e:ReferenceError) {
                trace(e);
            }
        }
    }
}


RegExp (Flex™ 2 Language Reference)

Class RegExp | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class RegExp
Inheritance | RegExp Inheritance Object

The RegExp class lets you work with regular expressions, which are patterns that you can use to perform searches in strings and to replace text in strings.

You can create a new RegExp object by using the new RegExp() constructor or by assigning a RegExp literal to a variable:

 var pattern1:RegExp = new RegExp("test-\\d", "i");
     var pattern2:RegExp = /test-\d/i;

For more information, see "Using Regular Expressions" in Programming ActionScript 3.0.

View the examples.

See also

String.match()
String.replace()
String.search()
Introduction to regular expressions

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dotall : Boolean [read-only] Specifies whether the dot character (.) in a regular expression pattern matches new-line characters. | RegExp
 | extended : Boolean [read-only] Specifies whether to use extended mode for the regular expression. | RegExp
 | global : Boolean [read-only] Specifies whether to use global matching for the regular expression. | RegExp
 | ignoreCase : Boolean [read-only] Specifies whether the regular expression ignores case sensitivity. | RegExp
 | lastIndex : Number Specifies the index position in the string at which to start the next search. | RegExp
 | multiline : Boolean [read-only] Specifies whether the m (multiline) flag is set. | RegExp
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | source : String [read-only] Specifies the pattern portion of the regular expression. | RegExp
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RegExp(re:String, flags:String) Lets you construct a regular expression from two strings. | RegExp
 | exec(str:String):Object Performs a search for the regular expression on the given string str. | RegExp
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | test(str:String):Boolean Tests for the match of the regular expression in the given string str. | RegExp
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
dotall property
dotall:Boolean [read-only]

Specifies whether the dot character (.) in a regular expression pattern matches new-line characters. Use the s flag when constructing a regular expression to set dotall = true.

Implementation
    public function get dotall():Boolean

See also

Flags and properties

Example
The following example shows the effect of the s (dotall) flag on a regular expression:
var str:String = "<p>Hello\n"
        + "again</p>"
        + "<p>Hello</p>";

var pattern:RegExp = /<p>.*?<\/p>/;
trace(pattern.dotall) // false
trace(pattern.exec(str)); // <p>Hello</p>

pattern = /<p>.*?<\/p>/s;
trace(pattern.dotall) // true
trace(pattern.exec(str));

extended property
extended:Boolean [read-only]

Specifies whether to use extended mode for the regular expression. When a RegExp object is in extended mode, white space characters in the constructor string are ignored. This is done to allow more readable constructors.

Use the x flag when constructing a regular expression to set extended = true.

Implementation
    public function get extended():Boolean

See also

Flags and properties

Example
The following example shows different ways to construct the same regular expression. In each, the regular expression is to match a phone number pattern of xxx-xxx-xxxx or (xxx) xxx-xxxx or (xxx)xxx-xxxx. The second regular expression uses the x flag, causing the white spaces in the string to be ignored.
var rePhonePattern1:RegExp = /\d{3}-\d{3}-\d{4}|\(\d{3}\)\s?\d{3}-\d{4}/;
var str:String = "The phone number is (415)555-1212.";

trace(rePhonePattern1.extended) // false
trace(rePhonePattern1.exec(str)); // (415)555-1212

var rePhonePattern2:RegExp = / \d{3}-\d{3}-\d{4}  |   \( \d{3} \) \ ? \d{3}-\d{4}  /x;
trace(rePhonePattern2.extended) // true
trace(rePhonePattern2.exec(str)); // (415)555-1212

global property
global:Boolean [read-only]

Specifies whether to use global matching for the regular expression. When global == true, the lastIndex property is set after a match is found. The next time a match is requested, the regular expression engine starts from the lastIndex position in the string. Use the g flag when constructing a regular expression to set global to true.

Implementation
    public function get global():Boolean

See also

Flags and properties

Example
The following example shows the effect setting the g (global) flag on the exec() method:
var pattern:RegExp = /foo\d/;
var str:String = "foo1 foo2";
trace(pattern.global); // false
trace(pattern.exec(str)); // foo1
trace(pattern.lastIndex); // 0
trace(pattern.exec(str)); // foo1

pattern = /foo\d/g;
trace(pattern.global); // true
trace(pattern.exec(str)); // foo1
trace(pattern.lastIndex); // 4
trace(pattern.exec(str)); // foo2

ignoreCase property
ignoreCase:Boolean [read-only]

Specifies whether the regular expression ignores case sensitivity. Use the i flag when constructing a regular expression to set ignoreCase = true.

Implementation
    public function get ignoreCase():Boolean

See also

Flags and properties

Example
The following example shows the effect of setting the i (ignoreCase) flag:
var pattern:RegExp = /bob/;
var str:String = "Bob bob";
trace(pattern.ignoreCase); // false
trace(pattern.exec(str)); // bob

pattern = /bob/i;
trace(pattern.ignoreCase); // true
trace(pattern.exec(str)); // Bob

lastIndex property
lastIndex:Number [read-write]

Specifies the index position in the string at which to start the next search. This property affects the exec() and test() methods of the RegExp class. However, the match(), replace(), and search() methods of the String class ignore the lastIndex property and start all searches from the beginning of the string.

When the exec() or test() method finds a match and the g (global) flag is set to true for the regular expression, the method automatically sets the lastIndex property to the index position of the character after the last character in the matching substring of the last match. If the g (global) flag is set to false, the method does not set the lastIndexproperty.

You can set the lastIndex property to adjust the starting position in the string for regular expression matching.

Implementation
    public function get lastIndex():Number
    public function set lastIndex(value:Number):void

See also

Flags and properties

Example
The following example shows the effect of setting the lastIndex property, and it shows how it is updated after a call to the exec() method on a regular expression in which the g (global) flag is set:
var pattern:RegExp = /\w\d/g;
var str:String = "a1 b2 c3 d4";
pattern.lastIndex = 2;
trace(pattern.exec(str)); // b2
trace(pattern.lastIndex); // 5
trace(pattern.exec(str)); // c3
trace(pattern.lastIndex); // 8
trace(pattern.exec(str)); // d4
trace(pattern.lastIndex); // 11
trace(pattern.exec(str)); // null

multiline property
multiline:Boolean [read-only]

Specifies whether the m (multiline) flag is set. If it is set, the caret (^) and dollar sign ($) in a regular expression match before and after new lines. Use the m flag when constructing a regular expression to set multiline = true.

Implementation
    public function get multiline():Boolean

See also

Flags and properties

Example
The following example shows the effect setting the m (multiline) flag:
var pattern:RegExp = /^bob/;
var str:String = "foo\n"
                + "bob";
trace(pattern.multiline); // false
trace(pattern.exec(str)); // null

pattern = /^bob/m;
trace(pattern.multiline); // true
trace(pattern.exec(str)); // bob

source property
source:String [read-only]

Specifies the pattern portion of the regular expression.

Implementation
    public function get source():String

See also

Flags and properties

Example
The following code outputs the source parameter for two regular expressions:
var re1:RegExp = /aabb/gi;
trace (re1.source); // aabb

var re2:RegExp = new RegExp("x+y*", "i");
trace(re2.source); // x+y*

Constructor detail
RegExp () constructor
public function RegExp(re:String, flags:String)

Lets you construct a regular expression from two strings. One string defines the pattern of the regular expression, and the other defines the flags used in the regular expression.

Parameters
re:String — The pattern of the regular expression (also known as the constructor string). This is the main part of the regular expression (the part that goes within the "/" characters).

Notes:

  • Do not include the starting and trailing "/" characters; use these only when defining a regular expression literal without using the constructor. For example, the following two regular expressions are equivalent:
    •  var re1:RegExp = new RegExp("bob", "i");
        var re2:RegExp = /bob/i;
  • In a regular expression that is defined with the RegExp() constructor method, to use a metasequence that begins with the backslash (\) character, such as \d (which matches any digit), type the backslash character twice. For example, the following two regular expressions are equivalent:
    •  var re1:RegExp = new RegExp("\\d+", "");
        var re2:RegExp = /\d/;

    In the first expression, you must type the backlash character twice in this case, because the first parameter of the RegExp() constructor method is a string, and in a string literal you must type a backslash character twice to have it recognized as a single backslash character.
flags:String — The modifiers of the regular expression. These can include the following:
  • g — When using the replace() method of the String class, specify this modifier to replace all matches, rather than only the first one. This modifier corresponds to the global property of the RegExp instance.
  • i — The regular expression is evaluated without case sensitivity. This modifier corresponds to the ignoreCase property of the RegExp instance.
  • s — The dot (.) character matches new-line characters. Note This modifier corresponds to the dotall property of the RegExp instance.
  • m — The caret (^) character and dollar sign ($) match before and after new-line characters. This modifier corresponds to the multiline property of the RegExp instance.
  • x — White space characters in the re string are ignored, so that you can write more readable constructors. This modifier corresponds to the extended property of the RegExp instance.

All other characters in the flags string are ignored.

See also

Introduction to regular expressions
Method detail
exec () method
AS3 function exec(str:String):Object

Performs a search for the regular expression on the given string str.

If the g (global) flag is not set for the regular expression, then the search starts at the beginning of the string (at index position 0); the search ignores the lastIndex property of the regular expression.

If the g (global) flag is set for the regular expression, then the search starts at the index position specified by the lastIndex property of the regular expression. If the search matches a substring, the lastIndex property changes to match the position of the end of the match.

Parameters
str:String — The string to search.

Returns
Object — If there is no match, null; otherwise, an object with the following properties:
  • An array, in which element 0 contains the complete matching substring, and other elements of the array (1 through n) contain substrings that match parenthetical groups in the regular expression
  • index — The character position of the matched substring within the string
  • input — The string (str)

See also

String.match()
String.search()
Methods for using regular expressions with strings

Example
When the g (global) flag is not set in the regular expression, then you can use exec() to find the first match in the string:
         var myPattern:RegExp = /(\w*)sh(\w*)/ig;
         var str:String = "She sells seashells by the seashore";
         var result:Object = myPattern.exec(str);
         trace(result);

The result object is set to the following:

  • result[0] is set to "She" (the complete match).
  • result[1] is set to an empty string (the first matching parenthetical group).
  • result[2] is set to "e" (the second matching parenthetical group).
  • result.index is set to 0.
  • result.input is set to the input string: "She sells seashells by the seashore".

In the following example, the g (global) flag is set in the regular expression, so you can use exec() repeatedly to find multiple matches:

         var myPattern:RegExp = /(\w*)sh(\w*)/ig;
         var str:String = "She sells seashells by the seashore";
         var result:Object = myPattern.exec(str);
                  while (result != null) {
             trace ( result.index, "\t", result);
             result = myPattern.exec(str);
         }

This code results in the following output:

            0      She,,e
            10     seashells,sea,ells
            27     seashore,sea,ore

test () method
AS3 function test(str:String):Boolean

Tests for the match of the regular expression in the given string str.

If the g (global) flag is not set for the regular expression, then the search starts at the beginning of the string (at index position 0); the search ignores the lastIndex property of the regular expression.

If the g (global) flag is set for the regular expression, then the search starts at the index position specified by the lastIndex property of the regular expression. If the search matches a substring, the lastIndex property changes to match the position of the end of the match.

Parameters
str:String — The string to test.

Returns
Boolean — If there is a match, true; otherwise, false.

See also

Methods for using regular expressions with strings

Example
The following example shows the use of the test() method on a regular expression in which the g (global) flag is set:
var re1:RegExp = /\w/g;
var str:String = "a b c";
trace (re1.lastIndex); // 0
trace (re1.test(str)); // true
trace (re1.lastIndex); // 1
trace (re1.test(str)); // true
trace (re1.lastIndex); // 3
trace (re1.test(str)); // true
trace (re1.lastIndex); // 5
trace (re1.test(str)); // false

Examples

The following example shows how you can use regular expressions to parse strings and return a new string or a Boolean value, based on the string passed in. The informalizeGreeting() method simply replaces the word Hello with Hi, regardless of case. It also strips out the surname in the name in the string (assuming that name matches the specified pattern). In the validateEmail() and validatePhoneNumber() methods, the string passed is checked to see if its pattern matches a valid email address or a specific phone number pattern, and the methods return Boolean values based on the results.
package {
    import flash.display.Sprite;

    public class RegExpExample extends Sprite {
        public function RegExpExample() {
            var formalGreeting:String = "Hello, John Smith.";
            trace(informalizeGreeting(formalGreeting));    // Hi, John.

            var validEmail:String = "name@domain.com";
            trace(validateEmail(validEmail));        // true

            var invalidEmail:String = "foo";
            trace(validateEmail(invalidEmail));  // false

            var validPhoneNumber:String = "415-555-1212";
            trace(validatePhoneNumber(validPhoneNumber));    // true

            var invalidPhoneNumber:String = "312-867-530999";
            trace(validatePhoneNumber(invalidPhoneNumber));  // false
        }
        private function informalizeGreeting(str:String):String {
            var pattern:RegExp = new RegExp("hello, (\\w+) \\w+", "i");
            return str.replace(pattern, "Hi, $1");
        }
        private function validateEmail(str:String):Boolean {
            var pattern:RegExp = /(\w|[_.\-])+@((\w|-)+\.)+\w{2,4}+/;
            var result:Object = pattern.exec(str);
            if(result == null) {
                return false;
            }
            return true;
        }
        private function validatePhoneNumber(str:String):Boolean {
            var pattern:RegExp = /^\d{3}-\d{3}-\d{4}$/;
            var result:Object = pattern.exec(str);
            if(result == null) {
                return false;
            }
            return true;
        }
    }
}


SecurityError (Flex™ 2 Language Reference)

Class SecurityError | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class SecurityError
Inheritance | SecurityError Inheritance Error Inheritance Object

The SecurityError exception is thrown when some type of security violation takes place.

Examples of security errors:

  • An unauthorized property access or method call is made across a security sandbox boundary.
  • An attempt was made to access a URL not permitted by the security sandbox.
  • A socket connection was attempted to an unauthorized port number, e.g. a port below 1024 without a policy file present.
  • An attempt was made to access the user's camera or microphone, and the request to access the device was denied by the user.

View the examples.

See also

Responding to error events and status
Flash Player Security

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SecurityError(message:String = "") Creates a new SecurityError object. | SecurityError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
SecurityError () constructor
public function SecurityError(message:String = "")

Creates a new SecurityError object.

Parameters
message:String (default = "")

See also

Flash Player Security
Examples

The following example shows how a SecurityError error can be generated and handled within a try...catch statement by attempting to connect to a port number that is one larger than the maximum allowed.
package {
    import flash.display.Sprite;
    import flash.net.Socket;

    public class SecurityErrorExample extends Sprite {

        public function SecurityErrorExample() {
            try {
                var host:String = "www.[yourDomain].com";
                var socket:Socket = new Socket();
                socket.connect(host, 65536);
            }
            catch(e:SecurityError) {
                trace(e);
            }
        }
    }
}


String (Flex™ 2 Language Reference)

Class String | Properties | Methods | Examples
Package | Top Level
Class | public final class String
Inheritance | String Inheritance Object

The String class is a data type that represents a string of characters. The String class provides methods and properties that let you manipulate primitive string value types. You can convert the value of any object into a String data type object using the String() function.

All the methods of the String class, except for concat(), fromCharCode(), slice(), and substr(), are generic, which means the methods call toString() before performing their operations, and you can use these methods with other non-String objects.

Because all string indexes are zero-based, the index of the last character for any string x is x.length - 1.

You can call any of the methods of the String class whether you use the constructor method new String() to create a new string variable or simply assign a string literal value. Unlike previous versions of ActionScript, it makes no difference whether you use the constructor, the global function, or simply assign a string literal value. The following lines of code are equivalent:

 var str:String = new String("foo");
 var str:String = "foo";
 var str:String = String("foo");

When setting a string variable to undefined, Adobe® Flash® Player coerces undefined to null. So, the statement:

 var s:String = undefined;
sets the value to null instead of undefined. Use the String() function if you need to use undefined.

View the examples.

See also

String Function
Data type descriptions
Type conversions
Working with Strings
Introduction to regular expressions

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | length : int [read-only] An integer specifying the number of characters in the specified String object. | String
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | String(val:String) Creates a new String object initialized to the specified string. | String
 | charAt(index:Number = 0):String Returns the character in the position specified by the index parameter. | String
 | charCodeAt(index:Number = 0):Number Returns the numeric Unicode character code of the character at the specified index. | String
 | concat(... args):String Appends the supplied arguments to the end of the String object, converting them to strings if necessary, and returns the resulting string. | String
 | fromCharCode(... charCodes):String [static] Returns a string comprising the characters represented by the Unicode character codes in the parameters. | String
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | indexOf(val:String, startIndex:Number = 0):int Searches the string and returns the position of the first occurrence of val found at or after startIndex within the calling string. | String
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | lastIndexOf(val:String, startIndex:Number = 0x7FFFFFFF):int Searches the string from right to left and returns the index of the last occurrence of val found before startIndex. | String
 | localeCompare(other:String, ... values):int Compares the sort order of two or more strings and returns the result of the comparison as an integer. | String
 | match(pattern:*):Array Matches the specifed pattern against the string. | String
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | replace(pattern:*, repl:Object):String Matches the specifed pattern against the string and returns a new string in which the first match of pattern is replaced with the content specified by repl. | String
 | search(pattern:*):int Searches for the specifed pattern and returns the index of the first matching substring. | String
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | slice(startIndex:Number = 0, endIndex:Number = 0x7fffffff):String Returns a string that includes the startIndex character and all characters up to, but not including, the endIndex character. | String
 | split(delimiter:*, limit:Number = 0x7fffffff):Array Splits a String object into an array of substrings by dividing it wherever the specified delimiter parameter occurs. | String
 | substr(startIndex:Number = 0, len:Number = 0x7fffffff):String Returns a substring consisting of the characters that start at the specified startIndex and with a length specified by len. | String
 | substring(startIndex:Number = 0, endIndex:Number = 0x7fffffff):String Returns a string consisting of the character specified by startIndex and all characters up to endIndex - 1. | String
 | toLocaleLowerCase():String Returns a copy of this string, with all uppercase characters converted to lowercase. | String
 | toLocaleUpperCase():String Returns a copy of this string, with all lowercase characters converted to uppercase. | String
 | toLowerCase():String Returns a copy of this string, with all uppercase characters converted to lowercase. | String
Inherited | toString():String Returns the string representation of the specified object. | Object
 | toUpperCase():String Returns a copy of this string, with all lowercase characters converted to uppercase. | String
 | valueOf():String Returns the primitive value of a String instance. | String
Property detail
length property
length:int [read-only]

An integer specifying the number of characters in the specified String object.

Because all string indexes are zero-based, the index of the last character for any string x is x.length - 1.

Implementation
    public function get length():int

See also

The length property
Constructor detail
String () constructor
public function String(val:String)

Creates a new String object initialized to the specified string.

Note: Because string literals use less overhead than String objects and are generally easier to use, you should use string literals instead of the String class unless you have a good reason to use a String object rather than a string literal.

Parameters
val:String — The initial value of the new String object.

See also

Data type descriptions
Type conversions
Introduction to regular expressions
Method detail
charAt () method
AS3 function charAt(index:Number = 0):String

Returns the character in the position specified by the index parameter. If index is not a number from 0 to string.length - 1, an empty string is returned.

This method is similar to String.charCodeAt() except that the returned value is a character, not a 16-bit integer character code.

Parameters
index:Number (default = 0) — An integer specifying the position of a character in the string. The first character is indicated by 0, and the last character is indicated by my_str.length - 1.

Returns
String — The character at the specified index. Or an empty string if the specified index is outside the range of this string's indices.

See also

charCodeAt()
Working with characters in strings
charCodeAt () method
AS3 function charCodeAt(index:Number = 0):Number

Returns the numeric Unicode character code of the character at the specified index. If index is not a number from 0 to string.length - 1, NaN is returned.

This method is similar to String.charAt() except that the returned value is a 16-bit integer character code, not the actual character.

Parameters
index:Number (default = 0) — An integer that specifies the position of a character in the string. The first character is indicated by 0, and the last character is indicated by my_str.length - 1.

Returns
Number — The Unicode character code of the character at the specified index. Or NaN if the index is outside the range of this string's indices.

See also

charAt()
Working with characters in strings
concat () method
AS3 function concat(... args):String

Appends the supplied arguments to the end of the String object, converting them to strings if necessary, and returns the resulting string. The original value of the source String object remains unchanged.

Parameters
... args — Zero or more values to be concatenated.

Returns
String — A new string consisting of this string concatenated with the specified parameters.

See also

Concatenating strings
fromCharCode () method
AS3 static function fromCharCode(... charCodes):String

Returns a string comprising the characters represented by the Unicode character codes in the parameters.

Parameters
... charCodes — A series of decimal integers that represent Unicode values.

Returns
String — The string value of the specified Unicode character codes.

See also

Function parameters
Working with characters in strings
indexOf () method
AS3 function indexOf(val:String, startIndex:Number = 0):int

Searches the string and returns the position of the first occurrence of val found at or after startIndex within the calling string. This index is zero-based, meaning that the first character in a string is considered to be at index 0--not index 1. If val is not found, the method returns -1.

Parameters
val:String — The substring for which to search.
startIndex:Number (default = 0) — An optional integer specifying the starting index of the search.

Returns
int — The index of the first occurrence of the specified substring or -1.

See also

lastIndexOf()
Finding substrings and patterns in strings
lastIndexOf () method
AS3 function lastIndexOf(val:String, startIndex:Number = 0x7FFFFFFF):int

Searches the string from right to left and returns the index of the last occurrence of val found before startIndex. The index is zero-based, meaning that the first character is at index 0, and the last is at string.length - 1. If val is not found, the method returns -1.

Parameters
val:String — The string for which to search.
startIndex:Number (default = 0x7FFFFFFF) — An optional integer specifying the starting index from which to search for val. The default is the maximum value allowed for an index. If startIndex is not specified, the search starts at the last item in the string.

Returns
int — The position of the last occurrence of the specified substring or -1 if not found.

See also

indexOf()
Finding substrings and patterns in strings
localeCompare () method
AS3 function localeCompare(other:String, ... values):int

Compares the sort order of two or more strings and returns the result of the comparison as an integer. While this method is intended to handle the comparison in a locale-specific way, the ActionScript 3.0 implementation does not produce a different result from other string comparisons such as the equality (==) or inequality (!=) operators. If the strings are equivalent, the return value is 0. If the original string value precedes the string value specified by other, the return value is a negative integer, the absolute value of which represents the number of characters that separates the two string values. If the original string value comes after other, the return value is a positive integer, the absolute value of which represents the number of characters that separates the two string values.

Parameters
other:String — A string value to compare.
... values — Optional set of more strings to compare.

Returns
int — The value 0 if the strings are equal. Otherwise, a negative integer if the original string precedes the string argument and a positive integer if the string argument precedes the original string. In both cases the absolute value of the number represents the difference between the two strings.
match () method
AS3 function match(pattern:*):Array

Matches the specifed pattern against the string.

Parameters
pattern:* — The pattern to match, which can be any type of object, but it is typically either a string or a regular expression. If the pattern is not a regular expression or a string, then the method converts it to a string before executing.

Returns
Array — An array of strings consisting of all substrings in the string that match the specified pattern.

If pattern is a regular expression, in order to return an array with more than one matching substring, the g (global) flag must be set in the regular expression:

  • If the g (global) flag is not set, the return array will contain no more than one match, and the lastIndex property of the regular expression remains unchanged.
  • If the g (global) flag is set, the method starts the search at the beginning of the string (index position 0). If a matching substring is an empty string (which can occur with a regular expression such as /x*/), the method adds that empty string to the array of matches, and then continues searching at the next index position. The lastIndex property of the regular expression is set to 0 after the method completes.

If no match is found, the method returns null. If you pass no value (or an undefined value) as the pattern parameter, the method returns null.

See also

RegExp
Finding substrings and patterns in strings
Introduction to regular expressions
replace () method
AS3 function replace(pattern:*, repl:Object):String

Matches the specifed pattern against the string and returns a new string in which the first match of pattern is replaced with the content specified by repl. The pattern parameter can be a string or a regular expression. The repl parameter can be a string or a function; if it is a function, the string returned by the function is inserted in place of the match. The original string is not modified.

In the following example, only the first instance of "sh" (case-sensitive) is replaced:

 var myPattern:RegExp = /sh/;
 var str:String = "She sells seashells by the seashore.";
 trace(str.replace(myPattern, "sch"));
    // She sells seaschells by the seashore.

In the following example, all instances of "sh" (case-sensitive) are replaced because the g (global) flag is set in the regular expression:

 var myPattern:RegExp = /sh/g;
 var str:String = "She sells seashells by the seashore.";
 trace(str.replace(myPattern, "sch"));
    // She sells seaschells by the seaschore.

In the following example, all instance of "sh" are replaced because the g (global) flag is set in the regular expression and the matches are not case-sensitive because the i (ignoreCase) flag is set:

 var myPattern:RegExp = /sh/gi;
 var str:String = "She sells seashells by the seashore.";
 trace(str.replace(myPattern, "sch"));
    // sche sells seaschells by the seaschore.
Parameters
pattern:* — The pattern to match, which can be any type of object, but it is typically either a string or a regular expression. If you specify a pattern parameter that is any object other than a string or a regular expression, the toString() method is applied to the parameter and the replace() method executes using the resulting string as the pattern.
repl:Object — Typically, the string that is inserted in place of the matching content. However, you can also specify a function as this parameter. If you specify a function, the string returned by the function is inserted in place of the matching content.

When you specify a string as the repl parameter and specify a regular expression as the pattern parameter, you can use the following special $ replacement codes in the repl string:

$ Code | Replacement Text
$$ | $
$& | The matched substring.
$` | The portion of the string that precedes the matched substring. Note that this code uses the straight left single quote character (`), not the straight single quote character (') or the left curly single quote character (‘).
$' | The portion of string that follows the matched substring. Note that this code uses the straight single quote character (').
$n | The nth captured parenthetical group match, where n is a single digit 1-9 and $n is not followed by a decimal digit.
$nn | The nnth captured parenthetical group match, where nn is a two-digit decimal number (01-99). If the nnth capture is undefined, the replacement text is an empty string.

For example, the following shows the use of the $2 and $1 replacement codes, which represent the first and second capturing group matched:

var str:String = "flip-flop";
 var pattern:RegExp = /(\w+)-(\w+)/g;
 trace(str.replace(pattern, "$2-$1")); // flop-flip

When you specify a function as the repl, the replace() method passes the following parameters to the function:

  • The matching portion of the string.
  • Any captured parenthetical group matches are provided as the next arguments. The number of arguments passed this way will vary depending on the number of parenthetical matches. You can determine the number of parenthetical matches by checking arguments.length - 3 within the function code.
  • The index position in the string where the match begins.
  • The complete string.

For example, consider the following:

 var str1:String = "abc12 def34";
 var pattern:RegExp = /([a-z]+)([0-9]+)/;
 var str2:String = str1.replace(pattern, replFN);
 trace (str2);   // 12abc 34def

 function replFN():String {
  return arguments[2] + arguments[1];
 }

The call to the replace() method uses a function as the repl parameter. The regular expression (/([a-z]([0-9]/g) is matched twice. The first time, the pattern matches the substring "abc12", and the following list of arguments is passed to the function:

 {"abc12", "abc", "12", 0, "abc12 def34"}

The second time, the pattern matches the substring "def23", and the following list of arguments is passed to the function:

 {"def34", "def", "34", 6, "abc123 def34"}

Returns
String — The resulting string. Note that the source string remains unchanged.

See also

RegExp
Finding substrings and patterns in strings
Introduction to regular expressions
search () method
AS3 function search(pattern:*):int

Searches for the specifed pattern and returns the index of the first matching substring. If there is no matching substring, the method returns -1.

Parameters
pattern:* — The pattern to match, which can be any type of object but is typically either a string or a regular expression.. If the pattern is not a regular expression or a string, then the method converts it to a string before executing. Note that if you specify a regular expression, the method ignores the global flag ("g") of the regular expression, and it ignores the lastIndex property of the regular expression (and leaves it unmodified). If you pass an undefined value (or no value), the method returns -1.

Returns
int — The index of the first matching substring, or -1 if there is no match. Note that the string is zero-indexed; the first character of the string is at index 0, the last is at string.length - 1.

See also

RegExp
Finding substrings and patterns in strings
Introduction to regular expressions
slice () method
AS3 function slice(startIndex:Number = 0, endIndex:Number = 0x7fffffff):String

Returns a string that includes the startIndex character and all characters up to, but not including, the endIndex character. The original String object is not modified. If the endIndex parameter is not specified, then the end of the substring is the end of the string. If the character indexed by startIndex is the same as or to the right of the character indexed by endIndex, the method returns an empty string.

Parameters
startIndex:Number (default = 0) — The zero-based index of the starting point for the slice. If startIndex is a negative number, the slice is created from right-to-left, where -1 is the last character.
endIndex:Number (default = 0x7fffffff) — An integer that is one greater than the index of the ending point for the slice. The character indexed by the endIndex parameter is not included in the extracted string. If endIndex is a negative number, the ending point is determined by counting back from the end of the string, where -1 is the last character. The default is the maximum value allowed for an index. If this parameter is omitted, String.length is used.

Returns
String — A substring based on the specified indices.

See also

substr()
substring()
Finding substrings and patterns in strings
split () method
AS3 function split(delimiter:*, limit:Number = 0x7fffffff):Array

Splits a String object into an array of substrings by dividing it wherever the specified delimiter parameter occurs.

If the delimiter parameter is a regular expression, only the first match at a given position of the string is considered, even if backtracking could find a nonempty substring match at that position. For example:

  var str:String = "ab";
  var results:Array = str.split(/a*?/); // results == ["","b"]

  results = str.split(/a*/); // results == ["","b"].)

If the delimiter parameter is a regular expression containing grouping parentheses, then each time the delimiter is matched, the results (including any undefined results) of the grouping parentheses are spliced into the output array. For example

  var str:String = "Thi5 is a tricky-66 example.";
  var re:RegExp = /(\d+)/;
  var results:Array = str.split(re);
      // results == ["Thi","5"," is a tricky-","66"," example."]

If the limit parameter is specified, then the returned array will have no more than the specified number of elements.

If the delimiter is an empty string, an empty regular expression, or a regular expression that can match an empty string, each single character in the string is output as an element in the array.

If the delimiter parameter is undefined, the entire string is placed into the first element of the returned array.

Parameters
delimiter:* — The pattern that specifies where to split this string. This can be any type of object but is typically either a string or a regular expression. If the delimiter is not a regular expression or string, then the method converts it to a string before executing.
limit:Number (default = 0x7fffffff) — The maximum number of items to place into the array. The default is the maximum value allowed.

Returns
Array — An array of substrings.

See also

Array.join()
RegExp
Finding substrings and patterns in strings
Introduction to regular expressions
substr () method
AS3 function substr(startIndex:Number = 0, len:Number = 0x7fffffff):String

Returns a substring consisting of the characters that start at the specified startIndex and with a length specified by len. The original string is unmodified.

Parameters
startIndex:Number (default = 0) — An integer that specified the index of the first character to be used to create the substring. If startIndex is a negative number, the starting index is determined from the end of the string, where -1 is the last character.
len:Number (default = 0x7fffffff) — The number of characters in the substring being created. The default value is the maximum value allowed. If len is not specified, the substring includes all the characters from startIndex to the end of the string.

Returns
String — A substring based on the specified parameters.

See also

Finding substrings and patterns in strings
substring () method
AS3 function substring(startIndex:Number = 0, endIndex:Number = 0x7fffffff):String

Returns a string consisting of the character specified by startIndex and all characters up to endIndex - 1. If endIndex is not specified, String.length is used. If the value of startIndex equals the value of endIndex, the method returns an empty string. If the value of startIndex is greater than the value of endIndex, the parameters are automatically swapped before the function executes. The original string is unmodified.

Parameters
startIndex:Number (default = 0) — An integer specifying the index of the first character used to create the substring. Valid values for startIndex are 0 through String.length. If startIndex is a negative value, 0 is used.
endIndex:Number (default = 0x7fffffff) — An integer that is one greater than the index of the last character in the extracted substring. Valid values for endIndex are 0 through String.length. The character at endIndex is not included in the substring. The default is the maximum value allowed for an index. If this parameter is omitted, String.length is used. If this parameter is a negative value, 0 is used.

Returns
String — A substring based on the specified parameters.

See also

Finding substrings and patterns in strings
toLocaleLowerCase () method
AS3 function toLocaleLowerCase():String

Returns a copy of this string, with all uppercase characters converted to lowercase. The original string is unmodified. While this method is intended to handle the conversion in a locale-specific way, the ActionScript 3.0 implementation does not produce a different result from the toLowerCase() method.

Returns
String — A copy of this string with all uppercase characters converted to lowercase.

See also

toLowerCase()
toLocaleUpperCase () method
AS3 function toLocaleUpperCase():String

Returns a copy of this string, with all lowercase characters converted to uppercase. The original string is unmodified. While this method is intended to handle the conversion in a locale-specific way, the ActionScript 3.0 implementation does not produce a different result from the toUpperCase() method.

Returns
String — A copy of this string with all lowercase characters converted to uppercase.

See also

toUpperCase()
toLowerCase () method
AS3 function toLowerCase():String

Returns a copy of this string, with all uppercase characters converted to lowercase. The original string is unmodified.

This method converts all characters (not simply A-Z) for which Unicode lowercase equivalents exist:

  var str:String = " JOSÉ BARÇA";
  trace(str.toLowerCase()); // josé barça

These case mappings are defined in the UnicodeData.txt file and the SpecialCasings.txt file, as defined in the Unicode Character Database specification.

Returns
String — A copy of this string with all uppercase characters converted to lowercase.

See also

toUpperCase()
Converting strings between uppercase and lowercase
toUpperCase () method
AS3 function toUpperCase():String

Returns a copy of this string, with all lowercase characters converted to uppercase. The original string is unmodified.

This method converts all characters (not simply a-z) for which Unicode uppercase equivalents exist:

  var str:String = "José Barça";
  trace(str.toUpperCase()); // JOSÉ BARÇA

These case mappings are defined in the UnicodeData.txt file and the SpecialCasings.txt file, as defined in the Unicode Character Database specification.

Returns
String — A copy of this string with all lowercase characters converted to uppercase.

See also

toLowerCase()
Converting strings between uppercase and lowercase
valueOf () method
AS3 function valueOf():String

Returns the primitive value of a String instance. This method is designed to convert a String object into a primitive string value. Because Flash Player automatically calls valueOf() when necessary, you rarely need to explicitly call this method.

Returns
String — The value of the string.
Examples

The following example uses the StringExample and StringHelper classes to show how various methods of the String class are used. This is accomplished using the following steps:
  1. The constructor for StringExample declares several local String instances, which are initialized with various strings and a new StringHelper object.
  2. The StringHelper class has the following methods:
    • replace(): calls the split() and join() methods of String to remove a substring of the string passed in with a new one.
    • trim(): calls both trimBack() and trimFront() using the strings passed in and returns the updated string.
    • trimFront():recursively removes all characters that match the char parameter, starting from the front of the string and working toward the end, until the first character in the string does not match char and returns the updated string.
    • trimBack(): recursively removes all characters that match the char parameter, starting from the end of the string and working backward, until the last character in the string does not match char and returns the updated string.
    • stringToCharacter(): returns the first character of the string passed to it.
  3. Three strings are then produced using the declared string variables with a call to the replace() method used to produce the second string and trim() to produce the third string.
package {
    import flash.display.Sprite;

    public class StringExample extends Sprite {
        public function StringExample() {
            var companyStr:String = new String("     Company X");
            var productStr:String = "Product Z Basic     ";
            var emptyStr:String = " ";
            var strHelper:StringHelper = new StringHelper();

            var companyProductStr:String = companyStr + emptyStr + productStr;
            trace("'" + companyProductStr + "'");    // '     Company X Product Z Basic     '

            companyProductStr = strHelper.replace(companyProductStr, "Basic", "Professional");
            trace("'" + companyProductStr + "'");    // '     Company X Product Z Professional     '

            companyProductStr = strHelper.trim(companyProductStr, emptyStr);
            trace("'" + companyProductStr + "'");    // 'Company X Product Z Professional'
        }
    }
}

class StringHelper {
    public function StringHelper() {
    }

    public function replace(str:String, oldSubStr:String, newSubStr:String):String {
        return str.split(oldSubStr).join(newSubStr);
    }

    public function trim(str:String, char:String):String {
        return trimBack(trimFront(str, char), char);
    }

    public function trimFront(str:String, char:String):String {
        char = stringToCharacter(char);
        if (str.charAt(0) == char) {
            str = trimFront(str.substring(1), char);
        }
        return str;
    }

    public function trimBack(str:String, char:String):String {
        char = stringToCharacter(char);
        if (str.charAt(str.length - 1) == char) {
            str = trimBack(str.substring(0, str.length - 1), char);
        }
        return str;
    }

    public function stringToCharacter(str:String):String {
        if (str.length == 1) {
            return str;
        }
        return str.slice(0, 1);
    }
}


SyntaxError (Flex™ 2 Language Reference)

Class SyntaxError | Properties | Methods
Package | Top Level
Class | public dynamic class SyntaxError
Inheritance | SyntaxError Inheritance Error Inheritance Object

A SyntaxError exception is thrown when a parsing error occurs.
  • ActionScript does not support the eval function or the Function constructor, two features that require an ActionScript compiler to be present to work. Therefore, ActionScript cannot throw SyntaxError exceptions in the cases described in the ECMAScript (ECMA-262) edition 3 language specification.
    •
  • ActionScript throws SyntaxError exceptions when an invalid regular expression is parsed by the RegExp class.
  • ActionScript throws SyntaxError exceptions when invalid XML is parsed by the XML class.
  • SyntaxError exceptions are thrown in accordance with the ECMAScript for XML (E4X) specification (ECMA-357)
    •

See also

RegExp class
XML class
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SyntaxError(message:String = "") Creates a new SyntaxError object. | SyntaxError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
SyntaxError () constructor
public function SyntaxError(message:String = "")

Creates a new SyntaxError object.

Parameters
message:String (default = "") — Contains the message associated with the SyntaxError object.

See also

Responding to error events and status


TypeError (Flex™ 2 Language Reference)

Class TypeError | Properties | Methods | Examples
Package | Top Level
Class | public dynamic class TypeError
Inheritance | TypeError Inheritance Error Inheritance Object

A TypeError exception is thrown when the actual type of an operand is different from the expected type.

In addition, this exception is thrown when:

  • An actual parameter to a function or method could not be coerced to the formal parameter type.
  • A value is assigned to a variable and cannot be coerced to the variable's type.
  • The right side of the is or instanceof operator is not a valid type.
  • The super keyword is used illegally.
  • A property lookup results in more than one binding, and is therefore ambiguous.
  • A method is invoked on an incompatible object. For example, a TypeError exception is thrown if a RegExp class method is "grafted" onto a generic object and then invoked.

View the examples.

See also

is operator
instanceof operator
super statement
RegExp class
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TypeError(message:String = "") Creates a new TypeError object. | TypeError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
TypeError () constructor
public function TypeError(message:String = "")

Creates a new TypeError object.

Parameters
message:String (default = "") — Contains the message associated with the TypeError object.

See also

Responding to error events and status
Examples

The following example shows how a TypeError exception can be generated and handled within a try..catch statement.
package {
    import flash.display.DisplayObject;
    import flash.display.Sprite;

    public class TypeErrorExample extends Sprite {
        public function TypeErrorExample() {
            try {
                var child:Object = new Object();
                addChild(DisplayObject(child));
            }
            catch(e:TypeError) {
                trace(e);
            }
        }
    }
}


uint (Flex™ 2 Language Reference)

Class uint | Properties | Methods | Constants | Examples
Package | Top Level
Class | public final class uint
Inheritance | uint Inheritance Object

The uint class provides methods for working with a data type representing a 32-bit unsigned integer. Because an unsigned integer can only be positive, its maximum value is twice that of the int class.

The range of values represented by the uint class is 0 to 4,294,967,295 (2^32-1).

You can create a uint object by declaring a variable of type uint and assigning the variable a literal value. The default value of a variable of type uint is 0.

The uint class is primarily useful for pixel color values (ARGB and RGBA) and other situations where the int data type does not work well. For example, the number 0xFFFFFFFF, which represents the color value white with an alpha value of 255, can't be represented using the int data type because it is not within the valid range of the int values.

The following example creates a uint object and calls the toString() method:

 var myuint:uint = 1234;
 trace(myuint.toString()); // output: 1234

The following example assigns the value of the MIN_VALUE property to a variable without the use of the constructor:

 var smallest:uint = uint.MIN_VALUE;
 trace(smallest.toString()); // output: 0

View the examples.

See also

int
Number
Data type descriptions
Type conversions

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | uint(num:Object) Creates a new uint object. | uint
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toExponential(fractionDigits:uint):String Returns a string representation of the number in exponential notation. | uint
 | toFixed(fractionDigits:uint):String Returns a string representation of the number in fixed-point notation. | uint
 | toPrecision(precision:uint):String Returns a string representation of the number either in exponential notation or in fixed-point notation. | uint
 | toString(radix:uint):String Returns the string representation of a uint object. | uint
 | valueOf():uint Returns the primitive uint type value of the specified uint object. | uint
Public Constants
Constant |  | Defined by
 | MAX_VALUE : uint = 4294967295 [static] The largest representable 32-bit unsigned integer, which is 4,294,967,295. | uint
 | MIN_VALUE : uint = 0 [static] The smallest representable unsigned integer, which is 0. | uint
Constructor detail
uint () constructor
public function uint(num:Object)

Creates a new uint object. You can create a variable of uint type and assign it a literal value. The new uint() constructor is primarily used as a placeholder. A uint object is not the same as the uint() function, which converts a parameter to a primitive value.

Parameters
num:Object — The numeric value of the uint object being created, or a value to be converted to a number. If num is not provided, the default value is 0.

See also

Data type descriptions
Type conversions

Example
The following code constructs two new uint objects; the first by assigning a literal value, and the second by using the constructor function:
  var n1:uint = 3;
  var n2:uint = new uint(10);

Method detail
toExponential () method
AS3 function toExponential(fractionDigits:uint):String

Returns a string representation of the number in exponential notation. The string contains one digit before the decimal point and up to 20 digits after the decimal point, as specified by the fractionDigits parameter.

Parameters
fractionDigits:uint — An integer between 0 and 20, inclusive, that represents the desired number of decimal places.

Returns
String

Throws
RangeError — Throws an exception if the fractionDigits argument is outside the range 0 to 20.

Example
The following example shows how toExponential(2) returns a string in exponential notation.

var num:Number = 315003;
trace(num.toExponential(2)); // Output: 3.15e+5

toFixed () method
AS3 function toFixed(fractionDigits:uint):String

Returns a string representation of the number in fixed-point notation. Fixed-point notation means that the string will contain a specific number of digits after the decimal point, as specified in the fractionDigits parameter. The valid range for the fractionDigits parameter is from 0 to 20. Specifying a value outside this range throws an exception.

Parameters
fractionDigits:uint — An integer between 0 and 20, inclusive, that represents the desired number of decimal places.

Returns
String

Throws
RangeError — Throws an exception if the fractionDigits argument is outside the range 0 to 20.

Example
The following example shows how toFixed(3) returns a string that rounds to three decimal places.

var num:Number = 7.31343;
trace(num.toFixed(3)); // Output: 7.313

The following example shows how toFixed(2) returns a string that adds trailing zeroes.

var num:Number = 4;
trace(num.toFixed(2)); // Output: 4.00

toPrecision () method
AS3 function toPrecision(precision:uint):String

Returns a string representation of the number either in exponential notation or in fixed-point notation. The string will contain the number of digits specified in the precision parameter.

Parameters
precision:uint — An integer between 1 and 21, inclusive, that represents the desired number of digits to represent in the resulting string.

Returns
String

Throws
RangeError — Throws an exception if the precision argument is outside the range 1 to 21.

Example
The following example shows how toPrecision(3) returns a string with only three digits. The string is in fixed-point notation because exponential notation is not required.

var num:Number = 31.570;
trace(num.toPrecision(3)); // Output: 31.6

The following example shows how toPrecision(3) returns a string with only three digits. The string is in exponential notation because the resulting number does not contain enough digits for fixed-point notation.

var num:Number = 4000;
trace(num.toPrecision(3)); // Output: 4.00e+3

toString () method
AS3 function toString(radix:uint):String

Returns the string representation of a uint object.

Parameters
radix:uint — Specifies the numeric base (from 2 to 36) to use for the number-to-string conversion. If you do not specify the radix parameter, the default value is 10.

Returns
String — The string representation of the uint object.

Example
The following example uses 2 and 8 for the radix parameters and returns a string value with the corresponding representation of the number 9:
  var myuint:uint = 9;
  trace(myuint.toString(2)); // output: 1001
  trace(myuint.toString(8)); // output: 11
The following example creates hexadecimal values:
  var r:uint = 250;
  var g:uint = 128;
  var b:uint = 114;
  var rgb:String = "0x" + r.toString(16) + g.toString(16) + b.toString(16);
  trace(rgb); // 0xfa8072

valueOf () method
AS3 function valueOf():uint

Returns the primitive uint type value of the specified uint object.

Returns
uint — The primitive uint type value of this uint object.

Example
The following example outputs the primitive value of the numSocks object.
  var numSocks:uint = 2;
  trace(numSocks.valueOf()); // 2

Constant detail
MAX_VALUE constant
public static const MAX_VALUE:uint = 4294967295

The largest representable 32-bit unsigned integer, which is 4,294,967,295.

Example
The following ActionScript displays the largest and smallest representable uint values:
 trace("uint.MIN_VALUE = " + uint.MIN_VALUE);
 trace("uint.MAX_VALUE = " + uint.MAX_VALUE);

The values are:

 uint.MIN_VALUE = 0
 uint.MAX_VALUE = 4294967295

MIN_VALUE constant
public static const MIN_VALUE:uint = 0

The smallest representable unsigned integer, which is 0.

Example
The following ActionScript displays the largest and smallest representable uint values:
  trace("uint.MIN_VALUE = " + uint.MIN_VALUE);
  trace("uint.MAX_VALUE = " + uint.MAX_VALUE);

The values are:

  uint.MIN_VALUE = 0
  uint.MAX_VALUE = 4294967295

Examples

The following example declares a uint i within a for loop, which prints out the digits 0 to 9 (since uint defaults to 0).

package {
    import flash.display.Sprite;

    public class UintExample extends Sprite {
        public function UintExample() {
            for(var i:uint; i < 10; i++) {
                trace(i);
            }
        }
    }
}


URIError (Flex™ 2 Language Reference)

Class URIError | Properties | Methods
Package | Top Level
Class | public dynamic class URIError
Inheritance | URIError Inheritance Error Inheritance Object

A URIError exception is thrown when one of the global URI handling functions is used in a way that is incompatible with its definition. This exception is thrown when an invalid URI is specified to a function that expects a valid URI, such as the Socket.connect() method.

See also

flash.net.Socket.connect()
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | URIError(message:String = "") Creates a new URIError object. | URIError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
URIError () constructor
public function URIError(message:String = "")

Creates a new URIError object.

Parameters
message:String (default = "") — Contains the message associated with the URIError object.

See also

Responding to error events and status


VerifyError (Flex™ 2 Language Reference)

Class VerifyError | Properties | Methods
Package | Top Level
Class | public dynamic class VerifyError
Inheritance | VerifyError Inheritance Error Inheritance Object

The VerifyError class represents an error that occurs when a malformed or corrupted SWF file is encountered.

See also

Loader class
Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | VerifyError(message:String = "") Creates a new VerifyError object. | VerifyError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
VerifyError () constructor
public function VerifyError(message:String = "")

Creates a new VerifyError object.

Parameters
message:String (default = "") — Contains the message associated with the VerifyError object.


XML (Flex™ 2 Language Reference)

Class XML | Properties | Methods | Examples
Package | Top Level
Class | public final dynamic class XML
Inheritance | XML Inheritance Object

The XML class contains methods and properties for working with XML objects. The XML class (along with the XMLList, Namespace, and QName classes) implements the powerful XML-handling standards defined in ECMAScript for XML (E4X) specification (ECMA-357 edition 2).

Use the toXMLString() method to return a string representation of the XML object regardless of whether the XML object has simple content or complex content.

Note: The XML class (along with related classes) from ActionScript 2.0 has been renamed XMLDocument and moved into the flash.xml package. It is included in ActionScript 3.0 for backward compatibility.

View the examples.

See also

Namespace
QName
XMLList
XML.toXMLString()
ECMAScript for XML (E4X) specification (ECMA-357 edition 2)
XML objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | ignoreComments : Boolean [static] Determines whether XML comments are ignored when XML objects parse the source XML data. | XML
 | ignoreProcessingInstructions : Boolean [static] Determines whether XML processing instructions are ignored when XML objects parse the source XML data. | XML
 | ignoreWhitespace : Boolean [static] Determines whether white space characters at the beginning and end of text nodes are ignored during parsing. | XML
 | prettyIndent : int [static] Determines the amount of indentation applied by the toString() and toXMLString() methods when the XML.prettyPrinting property is set to true. | XML
 | prettyPrinting : Boolean [static] Determines whether the toString() and toXMLString() methods normalize white space characters between some tags. | XML
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | XML(value:Object) Creates a new XML object. | XML
 | addNamespace(ns:Object):XML Adds a namespace to the set of in-scope namespaces for the XML object. | XML
 | appendChild(child:Object):XML Appends the given child to the end of the XML object's properties. | XML
 | attribute(attributeName:*):XMLList Returns the XML value of the attribute that has the name matching the attributeName parameter. | XML
 | attributes():XMLList Returns a list of attribute values for the given XML object. | XML
 | child(propertyName:Object):XMLList Lists the children of an XML object. | XML
 | childIndex():int Identifies the zero-indexed position of this XML object within the context of its parent. | XML
 | children():XMLList Lists the children of the XML object in the sequence in which they appear. | XML
 | comments():XMLList Lists the properties of the XML object that contain XML comments. | XML
 | contains(value:XML):Boolean Compares the XML object against the given value parameter. | XML
 | copy():XML Returns a copy of the given XML object. | XML
 | defaultSettings():Object [static] Returns an object with the following properties set to the default values: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting. | XML
 | descendants(name:Object = *):XMLList Returns all descendants (children, grandchildren, great-grandchildren, and so on) of the XML object that have the given name parameter. | XML
 | elements(name:Object = *):XMLList Lists the elements of an XML object. | XML
 | hasComplexContent():Boolean Checks to see whether the XML object contains complex content. | XML
 | hasOwnProperty(p:String):Boolean Checks to see whether the object has the property specified by the p parameter. | XML
 | hasSimpleContent():Boolean Checks to see whether the XML object contains simple content. | XML
 | inScopeNamespaces():Array Lists the namespaces for the XML object, based on the object's parent. | XML
 | insertChildAfter(child1:Object, child2:Object):* Inserts the given child2 parameter after the child1 parameter in this XML object and returns the resulting object. | XML
 | insertChildBefore(child1:Object, child2:Object):* Inserts the given child2 parameter before the child1 parameter in this XML object and returns the resulting object. | XML
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | length():int For XML objects, this method always returns the integer 1. | XML
 | localName():Object Gives the local name portion of the qualified name of the XML object. | XML
 | name():Object Gives the qualified name for the XML object. | XML
 | namespace(prefix:String = null):* If no parameter is provided, gives the namespace associated with the qualified name of this XML object. | XML
 | namespaceDeclarations():Array Lists namespace declarations associated with the XML object in the context of its parent. | XML
 | nodeKind():String Specifies the type of node: text, comment, processing-instruction, attribute, or element. | XML
 | normalize():XML For the XML object and all descendant XML objects, merges adjacent text nodes and eliminates empty text nodes. | XML
 | parent():* Returns the parent of the XML object. | XML
 | prependChild(value:Object):XML Inserts a copy of the provided child object into the XML element before any existing XML properties for that element. | XML
 | processingInstructions(name:String = "*"):XMLList If a name parameter is provided, lists all the children of the XML object that contain processing instructions with that name. | XML
 | propertyIsEnumerable(p:String):Boolean Checks whether the property p is in the set of properties that can be iterated in a for..in statement applied to the XML object. | XML
 | removeNamespace(ns:Namespace):XML Removes the given namespace for this object and all descendants. | XML
 | replace(propertyName:Object, value:XML):XML Replaces the properties specified by the propertyName parameter with the given value parameter. | XML
 | setChildren(value:Object):XML Replaces the child properties of the XML object with the specified set of XML properties, provided in the value parameter. | XML
 | setLocalName(name:String):void Changes the local name of the XML object to the given name parameter. | XML
 | setName(name:String):void Sets the name of the XML object to the given qualified name or attribute name. | XML
 | setNamespace(ns:Namespace):void Sets the namespace associated with the XML object. | XML
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setSettings(... rest):void [static] Sets values for the following XML properties: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting. | XML
 | settings():Object [static] Retrieves the following properties: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting. | XML
 | text():XMLList Returns an XMLList object of all XML properties of the XML object that represent XML text nodes. | XML
 | toString():String Returns a string representation of the XML object. | XML
 | toXMLString():String Returns a string representation of the XML object. | XML
 | valueOf():XML Returns the XML object. | XML
Property detail
ignoreComments property
ignoreComments:Boolean [read-write]

Determines whether XML comments are ignored when XML objects parse the source XML data. By default, the comments are ignored (true). To include XML comments, set this property to false. The ignoreComments property is used only during the XML parsing, not during the call to any method such as myXMLObject.child(*).toXMLString(). If the source XML includes comment nodes, they are kept or discarded during the XML parsing.

Implementation
    public static function get ignoreComments():Boolean
    public function set ignoreComments(value:Boolean):void

See also

XML.child()
XML.toXMLString()

Example
This example shows the effect of setting XML.ignoreComments to false and to true:
XML.ignoreComments = false;
var xml1:XML =
        <foo>
            <!-- comment -->
        </foo>;
trace(xml1.toXMLString()); // <foo><!-- comment --></foo>

XML.ignoreComments = true;
var xml2:XML =
        <foo>
            <!-- example -->
        </foo>;
trace(xml2.toXMLString()); // <foo/>

ignoreProcessingInstructions property
ignoreProcessingInstructions:Boolean [read-write]

Determines whether XML processing instructions are ignored when XML objects parse the source XML data. By default, the processing instructions are ignored (true). To include XML processing instructions, set this property to false. The ignoreProcessingInstructions property is used only during the XML parsing, not during the call to any method such as myXMLObject.child(*).toXMLString(). If the source XML includes processing instructions nodes, they are kept or discarded during the XML parsing.

Implementation
    public static function get ignoreProcessingInstructions():Boolean
    public function set ignoreProcessingInstructions(value:Boolean):void

See also

XML.child()
XML.toXMLString()

Example
This example shows the effect of setting XML.ignoreProcessingInstructions to false and to true:
XML.ignoreProcessingInstructions = false;
var xml1:XML =
        <foo>
            <?exampleInstruction ?>
        </foo>;
trace(xml1.toXMLString()); // <foo><?exampleInstruction ?></foo>

XML.ignoreProcessingInstructions = true;
var xml2:XML =
        <foo>
            <?exampleInstruction ?>
        </foo>;
trace(xml2.toXMLString()); // <foo/>

ignoreWhitespace property
ignoreWhitespace:Boolean [read-write]

Determines whether white space characters at the beginning and end of text nodes are ignored during parsing. By default, white space is ignored (true). If a text node is 100% white space and the ignoreWhitespace property is set to true, then the node is not created. To show white space in a text node, set the ignoreWhitespace property to false.

Implementation
    public static function get ignoreWhitespace():Boolean
    public function set ignoreWhitespace(value:Boolean):void

Example
This example shows the effect of setting XML.ignoreWhitespace to false and to true:
XML.ignoreWhitespace = false;
var xml1:XML = <foo>    </foo>;
trace(xml1.children().length()); // 1

XML.ignoreWhitespace = true;
var xml2:XML = <foo>    </foo>;
trace(xml2.children().length()); // 0

prettyIndent property
prettyIndent:int [read-write]

Determines the amount of indentation applied by the toString() and toXMLString() methods when the XML.prettyPrinting property is set to true. Indentation is applied with the space character, not the tab character. The default value is 2.

Implementation
    public static function get prettyIndent():int
    public function set prettyIndent(value:int):void

See also

prettyPrinting
toString()
toXMLString()

Example
This example shows the effect of setting the XML.prettyIndent static property:
var xml:XML = <foo><bar/></foo>;
XML.prettyIndent = 0;
trace(xml.toXMLString());

XML.prettyIndent = 1;
trace(xml.toXMLString());

XML.prettyIndent = 2;
trace(xml.toXMLString());

prettyPrinting property
prettyPrinting:Boolean [read-write]

Determines whether the toString() and toXMLString() methods normalize white space characters between some tags. The default value is true.

Implementation
    public static function get prettyPrinting():Boolean
    public function set prettyPrinting(value:Boolean):void

See also

prettyIndent
toString()
toXMLString()

Example
This example shows the effect of setting XML.prettyPrinting static property:
var xml:XML = <foo><bar/></foo>;
XML.prettyPrinting = false;
trace(xml.toXMLString());

XML.prettyPrinting = true;
trace(xml.toXMLString());

Constructor detail
XML () constructor
public function XML(value:Object)

Creates a new XML object. You must use the constructor to create an XML object before you call any of the methods of the XML class.

Use the toXMLString() method to return a string representation of the XML object regardless of whether the XML object has simple content or complex content.

Parameters
value:Object — Any object that can be converted to XML with the top-level XML() function.

See also

top-level XML() function
XML.toXMLString()
XML objects
Method detail
addNamespace () method
AS3 function addNamespace(ns:Object):XML

Adds a namespace to the set of in-scope namespaces for the XML object. If the namespace already exists in the in-scope namespaces for the XML object (with a prefix matching that of the given parameter), then the prefix of the existing namespace is set to undefined. If the input parameter is a Namespace object, it's used directly. If it's a QName object, the input parameter's URI is used to create a new namespace; otherwise, it's converted to a String and a namespace is created from the String.

Parameters
ns:Object — The namespace to add to the XML object.

Returns
XML — The new XML object, with the namespace added.

See also

XML objects

Example
This example uses a namespace defined in one XML object and applies it to another XML object:
var xml1:XML = <ns:foo xmlns:ns="www.example.com/ns" />;
var nsNamespace:Namespace = xml1.namespace();

var xml2:XML = <bar />;
xml2.addNamespace(nsNamespace);
trace(xml2.toXMLString()); // <bar xmlns:ns="www.example.com/ns"/>

appendChild () method
AS3 function appendChild(child:Object):XML

Appends the given child to the end of the XML object's properties. The appendChild() method takes an XML object, an XMLList object, or any other data type that is then converted to a String.

Use the delete (XML) operator to remove XML nodes.

Parameters
child:Object — The XML object to append.

Returns
XML — The resulting XML object.

See also

delete (XML) operator
E4X: A new approach to XML processing
XML objects
Assembling and transforming XML objects

Example
This example appends a new element to the end of the child list of an XML object:
var xml:XML =
        <body>
            <p>hello</p>
        </body>;

xml.appendChild(<p>world</p>);
trace(xml.p[0].toXMLString()); // <p>hello</p>
trace(xml.p[1].toXMLString()); // <p>world</p>

attribute () method
AS3 function attribute(attributeName:*):XMLList

Returns the XML value of the attribute that has the name matching the attributeName parameter. Attributes are found within XML elements. In the following example, the element has an attribute named "gender" with the value "boy": <first gender="boy">John</first>.

The attributeName parameter can be any data type; however, String is the most common data type to use. When passing any object other than a QName object, the attributeName parameter uses the toString() method to convert the parameter to a string.

If you need a qualified name reference, you can pass in a QName object. A QName object defines a namespace and the local name, which you can use to define the qualified name of an attribute. Therefore calling attribute(qname) is not the same as calling attribute(qname.toString()).

Parameters
attributeName:* — The name of the attribute.

Returns
XMLList — An XMLList object or an empty XMLList object. Returns an empty XMLList object when an attribute value has not been defined.

See also

XML.attributes()
QName
Namespace
XML.elements()
attribute identifier (@) operator
XML objects
Traversing XML structures

Example
This example shows a QName object passed into the attribute() method. The localName property is attr and the namespace property is ns.
 var xml:XML = <ns:node xmlns:ns = "http://uri" ns:attr = '7' />
 var qn:QName = new QName("http://uri", "attr");
 trace (xml.attribute(qn)); // 7

To return an attribute with a name that matches an ActionScript reserved word, use the attribute() method instead of the attribute identifier (@) operator, as in the following example:
 var xml:XML = <example class="first" />
 trace(xml.attribute("class"));

attributes () method
AS3 function attributes():XMLList

Returns a list of attribute values for the given XML object. Use the name() method with the attributes() method to return the name of an attribute. Use @* to return the names of all attributes.

Returns
XMLList — The list of attribute values.

See also

XML.attribute()
XML.name()
@ operator
XML objects
Traversing XML structures

Example
The following example returns the name of the attribute:
var xml:XML=<example id='123' color='blue'/>
trace(xml.attributes()[1].name()); //color

This example returns the names of all the attributes:

var xml:XML = <example id='123' color='blue'/>
var attNamesList:XMLList = xml.@*;

trace (attNamesList is XMLList); // true
trace (attNamesList.length()); // 2

for (var i:int = 0; i < attNamesList.length(); i++)
{
    trace (typeof (attNamesList[i])); // xml
    trace (attNamesList[i].nodeKind()); // attribute
    trace (attNamesList[i].name()); // id and color
}

child () method
AS3 function child(propertyName:Object):XMLList

Lists the children of an XML object. An XML child is an XML element, text node, comment, or processing instruction.

Use the propertyName parameter to list the contents of a specific XML child. For example, to return the contents of a child named <first>, use child.name("first"). You can generate the same result by using the child's index number. The index number identifies the child's position in the list of other XML children. For example, name.child(0) returns the first child in a list.

Use an asterisk (*) to output all the children in an XML document. For example, doc.child("*").

Use the length() method with the asterisk (*) parameter of the child() method to output the total number of children. For example, numChildren = doc.child("*").length().

Parameters
propertyName:Object — The element name or integer of the XML child.

Returns
XMLList — An XMLList object of child nodes that match the input parameter.

See also

XML.elements()
XMLList class
XML.length()
XML objects
Traversing XML structures

Example
This example shows the use of the child() method to identify child elements with a specified name:
var xml:XML =
        <foo>
            <bar>text1</bar>
            <bar>text2</bar>
        </foo>;
trace(xml.child("bar").length());  // 2
trace(xml.child("bar")[0].toXMLString()); // <bar>text1</bar>
trace(xml.child("bar")[1].toXMLString()); // <bar>text2</bar>

childIndex () method
AS3 function childIndex():int

Identifies the zero-indexed position of this XML object within the context of its parent.

Returns
int — The position of the object. Returns -1 as well as positive integers.

See also

XML objects

Example
This example shows the use of the childIndex() method:
var xml:XML =
            <foo>
                <bar />
                text
                <bob />
            </foo>;
trace(xml.bar.childIndex()); // 0
trace(xml.bob.childIndex()); // 2

children () method
AS3 function children():XMLList

Lists the children of the XML object in the sequence in which they appear. An XML child is an XML element, text node, comment, or processing instruction.

Returns
XMLList — An XMLList object of the XML object's children.

See also

XML objects

Example
This example shows the use of the children() method:
XML.ignoreComments = false;
XML.ignoreProcessingInstructions = false;
var xml:XML =
        <foo id="22">
            <bar>44</bar>
            text
            <!-- comment -->
            <?instruction ?>
        </foo>;
trace(xml.children().length()); // 4
trace(xml.children()[0].toXMLString()); // <bar>44</bar>
trace(xml.children()[1].toXMLString()); // text
trace(xml.children()[2].toXMLString()); // <!-- comment -->
trace(xml.children()[3].toXMLString()); // <?instruction ?>

comments () method
AS3 function comments():XMLList

Lists the properties of the XML object that contain XML comments.

Returns
XMLList — An XMLList object of the properties that contain comments.

See also

XML objects

Example
This example shows the use of the comments() method:
XML.ignoreComments = false;
var xml:XML =
        <foo>
            <!-- example -->
            <!-- example2 -->
        </foo>;
trace(xml.comments().length()); // 2
trace(xml.comments()[1].toXMLString()); // <!-- example2 -->

contains () method
AS3 function contains(value:XML):Boolean

Compares the XML object against the given value parameter.

Parameters
value:XML — A value to compare against the current XML object.

Returns
Boolean — If the XML object matches the value parameter, then true; otherwise false.

See also

XML objects

Example
This example shows the use of the contains() method:
var xml:XML =
        <order>
            <item>Rice</item>
            <item>Kung Pao Shrimp</item>
        </order>;
trace(xml.item[0].contains(<item>Rice</item>)); // true
trace(xml.item[1].contains(<item>Kung Pao Shrimp</item>)); // true
trace(xml.item[1].contains(<item>MSG</item>)); // false

copy () method
AS3 function copy():XML

Returns a copy of the given XML object. The copy is a duplicate of the entire tree of nodes. The copied XML object has no parent and returns null if you attempt to call the parent() method.

Returns
XML — The copy of the object.

See also

XML objects

Example
This example shows that the copy() method creates a new instance of an XML object. When you modify the copy, the original remains unchanged:
var xml1:XML = <foo />;
var xml2:XML = xml1.copy();
xml2.appendChild(<bar />);
trace(xml1.bar.length()); // 0
trace(xml2.bar.length()); // 1

defaultSettings () method
AS3 static function defaultSettings():Object

Returns an object with the following properties set to the default values: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting. The default values are as follows:

  • ignoreComments = true
  • ignoreProcessingInstructions = true
  • ignoreWhitespace = true
  • prettyIndent = 2
  • prettyPrinting = true

Note: You do not apply this method to an instance of the XML class; you apply it to XML, as in the following code: var df:Object = XML.defaultSettings().

Returns
Object — An object with properties set to the default settings.

See also

XML.ignoreComments
XML.ignoreProcessingInstructions
XML.ignoreWhitespace
XML.prettyIndent
XML.prettyPrinting
XML.setSettings()
XML.settings()
XML objects

Example
The following example shows: how to apply some custom settings (for including comments and processing instructions) prior to setting an XML object; how to then revert back to the default settings before setting another XML object; and then how to set the custom settings again (for setting any more XML objects):
XML.ignoreComments = false;
XML.ignoreProcessingInstructions = false;
var customSettings:Object = XML.settings();

var xml1:XML =
        <foo>
            <!-- comment -->
            <?instruction ?>
        </foo>;
trace(xml1.toXMLString());
//    <foo>
//        <!-- comment -->
//         <?instruction ?>
//    </foo>

XML.setSettings(XML.defaultSettings());
var xml2:XML =
        <foo>
            <!-- comment -->
            <?instruction ?>
        </foo>;
trace(xml2.toXMLString());

descendants () method
AS3 function descendants(name:Object = *):XMLList

Returns all descendants (children, grandchildren, great-grandchildren, and so on) of the XML object that have the given name parameter. The name parameter is optional. The name parameter can be a QName object, a String data type or any other data type that is then converted to a String data type.

To return all descendants, use the "*" parameter. If no parameter is passed, the string "*" is passed and returns all descendants of the XML object.

Parameters
name:Object (default = *) — The name of the element to match.

Returns
XMLList — An XMLList object of matching descendants. If there are no descendants, returns an empty XMLList object.

See also

descendant accessor (..) operator

Example
To return descendants with names that match ActionScript reserved words, use the descendants() method instead of the descendant (..) operator, as in the following example:
var xml:XML =
  <enrollees>
    <student id="239">
        <class name="Algebra" />
        <class name="Spanish 2"/>
    </student>
    <student id="206">
        <class name="Trigonometry" />
        <class name="Spanish 2" />
    </student>
  </enrollees>
trace(xml.descendants("class"));

The following example shows that the descendants() method returns an XMLList object that contains all descendant objects, including children, grandchildren, and so on:
XML.ignoreComments = false;
var xml:XML =
        <body>
            <!-- comment -->
            text1
            <a>
                <b>text2</b>
            </a>
        </body>;
trace(xml.descendants("*").length()); // 5
trace(xml.descendants("*")[0]); // // <!-- comment -->
trace(xml.descendants("*")[1].toXMLString()); // text1
trace(xml.descendants("a").toXMLString()); // <a><b>text2</b></a>
trace(xml.descendants("b").toXMLString()); // <b>text2</b>

elements () method
AS3 function elements(name:Object = *):XMLList

Lists the elements of an XML object. An element consists of a start and an end tag; for example <first></first>. The name parameter is optional. The name parameter can be a QName object, a String data type, or any other data type that is then converted to a String data type. Use the name parameter to list a specific element. For example, the element "first" returns "John" in this example: <first>John</first>.

To list all elements, use the asterisk (*) as the parameter. The asterisk is also the default parameter.

Use the length() method with the asterisk parameter to output the total number of elements. For example, numElement = addressbook.elements("*").length().

Parameters
name:Object (default = *) — The name of the element. An element's name is surrounded by angle brackets. For example, "first" is the name in this example: <first></first>.

Returns
XMLList — An XMLList object of the element's content. The element's content falls between the start and end tags. If you use the asterisk (*) to call all elements, both the element's tags and content are returned.

See also

XML.child()
XMLList class
XML.length()
XML.attribute()
XML dot (.) operator
XML objects

Example
The following example shows that the elements() method returns a list of elements only — not comments, text properties, or processing instructions:
var xml:XML =
        <foo>
            <!-- comment -->
            <?instruction ?>
            text
            <a>1</a>
            <b>2</b>
        </foo>;
trace(xml.elements("*").length()); // 2
trace(xml.elements("*")[0].toXMLString()); // <a>1</a>
trace(xml.elements("b").length()); // 1
trace(xml.elements("b")[0].toXMLString()); // <b>2</b>

To return elements with names that match ActionScript reserved words, use the elements() method instead of the XML dot (.) operator, as in the following example:
var xml:XML =
 <student id="206">
    <class name="Trigonometry" />
    <class name="Spanish 2" />
 </student>
trace(xml.elements("class"));

hasComplexContent () method
AS3 function hasComplexContent():Boolean

Checks to see whether the XML object contains complex content. An XML object contains complex content if it has child elements. XML objects that representing attributes, comments, processing instructions, and text nodes do not have complex content. However, an object that contains these can still be considered to contain complex content (if the object has child elements).

Returns
Boolean — If the XML object contains complex content, true; otherwise false.

See also

XML.hasSimpleContent()
XML objects

Example
The following example shows an XML object with one property named a that has simple content and one property named a that has complex content:
var xml:XML =
        <foo>
            <a>
                text
            </a>
            <a>
                <b/>
            </a>
        </foo>;
trace(xml.a[0].hasComplexContent()); // false
trace(xml.a[1].hasComplexContent()); // true

trace(xml.a[0].hasSimpleContent()); // true
trace(xml.a[1].hasSimpleContent()); // false

hasOwnProperty () method
AS3 function hasOwnProperty(p:String):Boolean

Checks to see whether the object has the property specified by the p parameter.

Parameters
p:String — The property to match.

Returns
Boolean — If the property exists, true; otherwise false.

See also

XML objects

Example
The following example uses the hasOwnProperty() method to ensure that a property (b) exists prior to evaluating an expression (b == "11") that uses the property:
var xml:XML =
        <foo>
            <a />
            <a>
                <b>10</b>
            </a>
            <a>
                <b>11</b>
            </a>
        </foo>;
trace(xml.a.(hasOwnProperty("b") && b == "11"));
If the last line in this example were the following, Flash Player would throw an exception since the first element named a does not have a property named b:

trace(xml.a.(b == "11"));

The following example uses the hasOwnProperty() method to ensure that a property (item) exists prior to evaluating an expression (item.contains("toothbrush")) that uses the property:
var xml:XML =
        <orders>
            <order id='1'>
                <item>toothbrush</item>
                <item>toothpaste</item>
            </order>
            <order>
                <returnItem>shoe polish</returnItem>
            </order>
        </orders>;
trace(xml.order.(hasOwnProperty("item") && item.contains("toothbrush")));

hasSimpleContent () method
AS3 function hasSimpleContent():Boolean

Checks to see whether the XML object contains simple content. An XML object contains simple content if it represents a text node, an attribute node, or an XML element that has no child elements. XML objects that represent comments and processing instructions do not contain simple content.

Returns
Boolean — If the XML object contains simple content, true; otherwise false.

See also

XML.hasComplexContent()
XML objects

Example
The following example shows an XML object with one property named a that has simple content and one property named a that has complex content:
var xml:XML =
        <foo>
            <a>
                text
            </a>
            <a>
                <b/>
            </a>
        </foo>;
trace(xml.a[0].hasComplexContent()); // false
trace(xml.a[1].hasComplexContent()); // true

trace(xml.a[0].hasSimpleContent()); // true
trace(xml.a[1].hasSimpleContent()); // false

inScopeNamespaces () method
AS3 function inScopeNamespaces():Array

Lists the namespaces for the XML object, based on the object's parent.

Returns
Array — An array of Namespace objects.

See also

XML objects
insertChildAfter () method
AS3 function insertChildAfter(child1:Object, child2:Object):*

Inserts the given child2 parameter after the child1 parameter in this XML object and returns the resulting object. If the child1 parameter is null, the method inserts the contents of child2 before all children of the XML object (in other words, after none). If child1 is provided, but it does not exist in the XML object, the XML object is not modified and undefined is returned.

If you call this method on an XML child that is not an element (text, attributes, comments, pi, and so on) undefined is returned.

Use the delete (XML) operator to remove XML nodes.

Parameters
child1:Object — The object in the source object that you insert before child2.
child2:Object — The object to insert.

Returns
* — The resulting XML object or undefined.

See also

XML.insertChildBefore()
delete (XML) operator
XML objects
Assembling and transforming XML objects

Example
The following example appends an element to the end of the child elements of an XML object:
var xml:XML =
        <menu>
            <item>burger</item>
            <item>soda</item>
        </menu>;
xml.insertChildAfter(xml.item[0], <saleItem>fries</saleItem>);
trace(xml);
The trace() output is the following:
 <menu>
      <item>burger</item>
      <saleItem>fries</saleItem>
      <item>soda</item>
  </menu>

insertChildBefore () method
AS3 function insertChildBefore(child1:Object, child2:Object):*

Inserts the given child2 parameter before the child1 parameter in this XML object and returns the resulting object. If the child1 parameter is null, the method inserts the contents of child2 after all children of the XML object (in other words, before none). If child1 is provided, but it does not exist in the XML object, the XML object is not modified and undefined is returned.

If you call this method on an XML child that is not an element (text, attributes, comments, pi, and so on) undefined is returned.

Use the delete (XML) operator to remove XML nodes.

Parameters
child1:Object — The object in the source object that you insert after child2.
child2:Object — The object to insert.

Returns
* — The resulting XML object or undefined.

See also

XML.insertChildAfter()
delete (XML) operator
XML objects
Assembling and transforming XML objects

Example
The following example appends an element to the end of the child elements of an XML object:
var xml:XML =
        <menu>
            <item>burger</item>
            <item>soda</item>
        </menu>;
xml.insertChildBefore(xml.bar[0], <saleItem>fries</saleItem>);
trace(xml);
The trace() output is the following:
<menu>
      <saleItem>fries</saleItem>
      <item>burger</item>
      <item>soda</item>
  </menu>

length () method
AS3 function length():int

For XML objects, this method always returns the integer 1. The length() method of the XMLList class returns a value of 1 for an XMLList object that contains only one value.

Returns
int — Always returns 1 for any XML object.

See also

XML objects
localName () method
AS3 function localName():Object

Gives the local name portion of the qualified name of the XML object.

Returns
Object — The local name as either a String or null.

See also

XML objects

Example
The following example illustrates the use of the localName() method:
var xml:XML =
        <soap:Envelope xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
            soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

                        <soap:Body xmlns:wx = "http://example.com/weather">
                <wx:forecast>
                    <wx:city>Quito</wx:city>
                </wx:forecast>
            </soap:Body>
        </soap:Envelope>;

trace(xml.localName()); // Envelope

name () method
AS3 function name():Object

Gives the qualified name for the XML object.

Returns
Object — The qualified name is either a QName or null.

See also

XML.attributes()
operators.html#attribute_identifier
XML objects

Example
The following example illustrates the use of the name() method to get the qualified name of an XML object:
var xml:XML =
        <soap:Envelope xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
            soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

                        <soap:Body xmlns:wx = "http://example.com/weather">
                <wx:forecast>
                    <wx:city>Quito</wx:city>
                </wx:forecast>
            </soap:Body>
        </soap:Envelope>;

trace(xml.name().localName); // Envelope
trace(xml.name().uri); // "http://www.w3.org/2001/12/soap-envelope"

The following example illustrates the use of the name() method called on an XML property, on a text element, and on an attribute:
var xml:XML =
        <foo x="15" y="22">
            text
        </foo>;

trace(xml.name().localName); // foo
trace(xml.name().uri == ""); // true
trace(xml.children()[0]); // text
trace(xml.children()[0].name()); // null
trace(xml.attributes()[0]); // 15
trace(xml.attributes()[0].name()); // x

namespace () method
AS3 function namespace(prefix:String = null):*

If no parameter is provided, gives the namespace associated with the qualified name of this XML object. If a prefix parameter is specified, the method returns the namespace that matches the prefix parameter and that is in scope for the XML object. If there is no such namespace, the method returns undefined.

Parameters
prefix:String (default = null) — The prefix you want to match.

Returns
* — Returns null, undefined, or a namespace.

See also

XML objects

Example
The following example uses the namespace() method to get the namespace of an XML object and assign it to a Namespace object named soap which is then used in identifying a property of the xml object (xml.soap::Body[0]):
var xml:XML =
        <soap:Envelope xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
            soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">

                        <soap:Body xmlns:wx = "http://example.com/weather">
                <wx:forecast>
                    <wx:city>Quito</wx:city>
                </wx:forecast>
            </soap:Body>
        </soap:Envelope>;

var soap:Namespace = xml.namespace();
trace(soap.prefix); // soap
trace(soap.uri); // http://www.w3.org/2001/12/soap-envelope

var body:XML = xml.soap::Body[0];
trace(body.namespace().prefix); // soap
trace(xml.namespace().uri); // http://www.w3.org/2001/12/soap-envelope
trace(body.namespace("wx").uri); // "http://example.com/weather"

The following example uses the namespace() method to get the default namespace for a node, as well as the namespace for a specific prefix ("dc"):
var xml:XML =
        <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
            xmlns:dc="http://purl.org/dc/elements/1.1/"
            xmlns="http://purl.org/rss/1.0/">
                <!-- ... -->
        </rdf:RDF>;

trace(xml.namespace()); // http://www.w3.org/1999/02/22-rdf-syntax-ns#
trace(xml.namespace("dc")); // http://purl.org/dc/elements/1.1/
trace(xml.namespace("foo")); // undefined

namespaceDeclarations () method
AS3 function namespaceDeclarations():Array

Lists namespace declarations associated with the XML object in the context of its parent.

Returns
Array — An array of Namespace objects.

See also

XML.namespace()
XML objects

Example
The following example outputs the namespace declarations of an XML object:
var xml:XML =
        <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
            xmlns:dc="http://purl.org/dc/elements/1.1/"
            xmlns="http://purl.org/rss/1.0/">

            <!-- ... -->

        </rdf:RDF>;

for (var i:uint = 0; i < xml.namespaceDeclarations().length; i++) {
    var ns:Namespace = xml.namespaceDeclarations()[i];
    var prefix:String = ns.prefix;
    if (prefix == "") {
        prefix = "(default)";
    }
    trace(prefix + ":" , ns.uri);
}
The trace() output is the following:
rdf: http://www.w3.org/1999/02/22-rdf-syntax-ns#
 dc: http://purl.org/dc/elements/1.1/
 (default): http://purl.org/rss/1.0/

nodeKind () method
AS3 function nodeKind():String

Specifies the type of node: text, comment, processing-instruction, attribute, or element.

Returns
String — The node type used.

See also

Operators.html#attribute_identifier
XML objects

Example
This example traces all five node types:
XML.ignoreComments = false;
XML.ignoreProcessingInstructions = false;

var xml:XML =
    <example id="10">
        <!-- this is a comment -->
        <?test this is a pi ?>
        and some text
    </example>;

trace (xml.nodeKind()); // element
trace (xml.children()[0].nodeKind()); // comment
trace (xml.children()[1].nodeKind()); // processing-instruction
trace (xml.children()[2].nodeKind()); // text
trace (xml.@id[0].nodeKind()); // attribute

normalize () method
AS3 function normalize():XML

For the XML object and all descendant XML objects, merges adjacent text nodes and eliminates empty text nodes.

Returns
XML — The resulting normalized XML object.

See also

XML objects

Example
The following example shows the effect of calling the normalize() method:
var xml:XML = <body></body>;
xml.appendChild("hello");
xml.appendChild(" world");
trace(xml.children().length()); // 2
xml.normalize();
trace(xml.children().length()); // 1

parent () method
AS3 function parent():*

Returns the parent of the XML object. If the XML object has no parent, the method returns undefined.

Returns
* — The parent XML object. Returns either a String or undefined.

See also

XML objects
Traversing XML structures

Example
The following example uses the parent() method to identify the parent element of a specific element in an XML structure:
var xml:XML =
    <body>
        <p id="p1">Hello</p>
        <p id="p2">Test:
            <ul>
                <li>1</li>
                <li>2</li>
            </ul>
        </p>
    </body>;
var node:XML = xml.p.ul.(li.contains("1"))[0]; // == <ul> ... </ul>
trace(node.parent().@id); // p2

prependChild () method
AS3 function prependChild(value:Object):XML

Inserts a copy of the provided child object into the XML element before any existing XML properties for that element.

Use the delete (XML) operator to remove XML nodes.

Parameters
value:Object — The object to insert.

Returns
XML — The resulting XML object.

See also

delete (XML) operator
XML objects
Assembling and transforming XML objects

Example
The following example uses the prependChild() method to add an element to the begining of a child list of an XML object:
var xml:XML =
        <body>
            <p>hello</p>
        </body>;

xml.prependChild(<p>world</p>);
trace(xml.p[0].toXMLString()); // <p>world</p>
trace(xml.p[1].toXMLString()); // <p>hello</p>

processingInstructions () method
AS3 function processingInstructions(name:String = "*"):XMLList

If a name parameter is provided, lists all the children of the XML object that contain processing instructions with that name. With no parameters, the method lists all the children of the XML object that contain any processing instructions.

Parameters
name:String (default = "*") — The name of the processing instructions to match.

Returns
XMLList — A list of matching child objects.

See also

XML objects

Example
The following example uses the processingInstructions() method to get an array of processing instructions for an XML object:
XML.ignoreProcessingInstructions = false;
var xml:XML =
    <body>
            foo
            <?xml-stylesheet href="headlines.css" type="text/css" ?>
            <?instructionX ?>

    </body>;

trace(xml.processingInstructions().length()); // 2
trace(xml.processingInstructions()[0].name()); // xml-stylesheet

propertyIsEnumerable () method
AS3 function propertyIsEnumerable(p:String):Boolean

Checks whether the property p is in the set of properties that can be iterated in a for..in statement applied to the XML object. Returns true only if toString(p) == "0".

Parameters
p:String — The property that you want to check.

Returns
Boolean — If the property can be iterated in a for..in statement, true; otherwise, false.

See also

XML objects

Example
The following example shows that, for an XML object, the propertyNameIsEnumerable() method returns a value of true only for the value 0; whereas for an XMLList object, the return value is true for each valid index value for the XMLList object:
var xml:XML =
        <body>
             <p>Hello</p>
               <p>World</p>
        </body>;

trace(xml.propertyIsEnumerable(0)); // true
trace(xml.propertyIsEnumerable(1)); // false

for (var propertyName:String in xml) {
    trace(xml[propertyName]);
}

var list:XMLList = xml.p;
trace(list.propertyIsEnumerable(0)); // true
trace(list.propertyIsEnumerable(1)); // true
trace(list.propertyIsEnumerable(2)); // false

for (var propertyName:String in list) {
    trace(list[propertyName]);
}

removeNamespace () method
AS3 function removeNamespace(ns:Namespace):XML

Removes the given namespace for this object and all descendants. The removeNamespaces() method does not remove a namespace if it is referenced by the object's qualified name or the qualified name of the object's attributes.

Parameters
ns:Namespace — The namespace to remove.

Returns
XML — A copy of the resulting XML object.

See also

XML objects

Example
The following example shows how to remove a namespace declaration from an XML object:
var xml:XML =
    <rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
        xmlns:dc="http://purl.org/dc/elements/1.1/"
        xmlns="http://purl.org/rss/1.0/">

        <!-- ... -->

    </rdf:RDF>;

trace(xml.namespaceDeclarations().length); // 3
trace(xml.namespaceDeclarations()[0] is String); //
var dc:Namespace = xml.namespace("dc");
xml.removeNamespace(dc);
trace(xml.namespaceDeclarations().length); // 2

replace () method
AS3 function replace(propertyName:Object, value:XML):XML

Replaces the properties specified by the propertyName parameter with the given value parameter. If no properties match propertyName, the XML object is left unmodified.

Parameters
propertyName:Object — Can be a numeric value, an unqualified name for a set of XML elements, a qualified name for a set of XML elements, or the asterisk wildcard ("*"). Use an unqualified name to identify XML elements in the default namespace.
value:XML — The replacement value. This can be an XML object, an XMLList object, or any value that can be converted with toString().

Returns
XML — The resulting XML object, with the matching properties replaced.

See also

XML objects

Example
The following example illustrates calling the replace() method with an integer as the first parameter:
var xml:XML =
    <body>
        <p>Hello</p>
        <p>World</p>
        <hr/>
    </body>;

xml.replace(1, <p>Bob</p>);
trace(xml);
This results in the following trace() output:

 <body>
     <p>Hello</p>
     <p>Bob</p>
     <hr/>
 </body>

The following example calls replace() method with a string as the first parameter:
var xml:XML =
    <body>
        <p>Hello</p>
        <p>World</p>
        <hr/>
    </body>;

xml.replace("p", <p>Hi</p>);
trace(xml);
This results in the following trace() output:

 <body>
     <p>Hi</p>
     <hr/>
 </body>;

The following example illustrates calling the replace() method with a QName as the first parameter:
var xml:XML =
    <ns:body xmlns:ns = "myNS">
        <ns:p>Hello</ns:p>
        <ns:p>World</ns:p>
        <hr/>
    </ns:body>;

var qname:QName = new QName("myNS", "p");
xml.replace(qname, <p>Bob</p>);
trace(xml);
This results in the following trace() output:

 <ns:body xmlns:ns = "myNS">
     <p>Bob</p>
     <hr/>
 </ns:body>

The following example illustrates calling the replace() method with the string "" as the first parameter:
var xml:XML =
    <body>
        <p>Hello</p>
        <p>World</p>
        <hr/>
    </body>;

xml.replace("*", <img src = "hello.jpg"/>);
trace(xml);
This results in the following trace() output:

 <body>
     <img src="hello.jpg"/>
 </body>

setChildren () method
AS3 function setChildren(value:Object):XML

Replaces the child properties of the XML object with the specified set of XML properties, provided in the value parameter.

Parameters
value:Object — The replacement XML properties. Can be a single XML object or an XMLList object.

Returns
XML — The resulting XML object.

See also

XML objects

Example
The following example illustrates calling the setChildren() method, first using an XML object as the parameter, and then using an XMLList object as the parameter:
var xml:XML =
    <body>
        <p>Hello</p>
        <p>World</p>
    </body>;

var list:XMLList = xml.p;

xml.setChildren(<p>hello</p>);
trace(xml);

//    <body>
//        <p>hello</p>
//    </body>

xml.setChildren(list);
trace(xml);

//    <body>
//        <p>Hello</p>
//        <p>World</p>
//    </body>

setLocalName () method
AS3 function setLocalName(name:String):void

Changes the local name of the XML object to the given name parameter.

Parameters
name:String — The replacement name for the local name.

See also

XML objects

Example
The following example uses the setLocalName() method to change the local name of an XML element:
var xml:XML =
    <ns:item xmlns:ns="http://example.com">
        toothbrush
    </ns:item>;

xml.setLocalName("orderItem");
trace(xml.toXMLString()); // <ns:orderItem xmlns:ns="http://example.com">toothbrush</ns:orderItem>

setName () method
AS3 function setName(name:String):void

Sets the name of the XML object to the given qualified name or attribute name.

Parameters
name:String — The new name for the object.

See also

XML objects

Example
The following example uses the setName() method to change the name of an XML element:
var xml:XML =
    <item>
        toothbrush
    </item>;

xml.setName("orderItem");
trace(xml.toXMLString()); // <orderItem>toothbrush</orderItem>

setNamespace () method
AS3 function setNamespace(ns:Namespace):void

Sets the namespace associated with the XML object.

Parameters
ns:Namespace — The new namespace.

See also

XML objects

Example
The following example uses the soap namespace defined in one XML object and applies it to the namespace of another XML object (xml2):
var xml1:XML =
        <soap:Envelope xmlns:soap="http://www.w3.org/2001/12/soap-envelope"
            soap:encodingStyle="http://www.w3.org/2001/12/soap-encoding">
            <!-- ... -->
        </soap:Envelope>;
var ns:Namespace = xml1.namespace("soap");

var xml2:XML =
    <Envelope>
        <Body/>
    </Envelope>;

xml2.setNamespace(ns);

trace(xml2);

setSettings () method
AS3 static function setSettings(... rest):void

Sets values for the following XML properties: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting. The following are the default settings, which are applied if no setObj parameter is provided:

  • XML.ignoreComments = true
  • XML.ignoreProcessingInstructions = true
  • XML.ignoreWhitespace = true
  • XML.prettyIndent = 2
  • XML.prettyPrinting = true

Note: You do not apply this method to an instance of the XML class; you apply it to XML, as in the following code: XML.setSettings().

Parameters
... rest — An object with each of the following properties:
  • ignoreComments
  • ignoreProcessingInstructions
  • ignoreWhitespace
  • prettyIndent
  • prettyPrinting

See also

ignoreComments
ignoreProcessingInstructions
ignoreWhitespace
prettyIndent
prettyPrinting
defaultSettings()
settings()
Function parameters
XML objects

Example
The following example shows: how to apply some custom settings (for including comments and processing instructions) prior to setting an XML object; how to then revert back to the default settings before setting another XML object; and then how to set the custom settings again (for setting any more XML objects):
XML.ignoreComments = false;
XML.ignoreProcessingInstructions = false;
var customSettings:Object = XML.settings();

var xml1:XML =
        <foo>
            <!-- comment -->
            <?instruction ?>
        </foo>;
trace(xml1.toXMLString());
//    <foo>
//        <!-- comment -->
//         <?instruction ?>
//    </foo>

XML.setSettings(XML.defaultSettings());
var xml2:XML =
        <foo>
            <!-- comment -->
            <?instruction ?>
        </foo>;
trace(xml2.toXMLString());

settings () method
AS3 static function settings():Object

Retrieves the following properties: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting.

Returns
Object — An object with the following XML properties:
  • ignoreComments
  • ignoreProcessingInstructions
  • ignoreWhitespace
  • prettyIndent
  • prettyPrinting

See also

XML.ignoreComments
XML.ignoreProcessingInstructions
XML.ignoreWhitespace
XML.prettyIndent
XML.prettyPrinting
XML.defaultSettings()
XML.setSettings()

Example
The following example shows: how to apply some custom settings (for including comments and processing instructions) prior to setting an XML object; how to then revert back to the default settings before setting another XML object; and then how to set the custom settings again (for setting any more XML objects):
XML.ignoreComments = false;
XML.ignoreProcessingInstructions = false;
var customSettings:Object = XML.settings();

var xml1:XML =
        <foo>
            <!-- comment -->
            <?instruction ?>
        </foo>;
trace(xml1.toXMLString());
//    <foo>
//        <!-- comment -->
//         <?instruction ?>
//    </foo>

XML.setSettings(XML.defaultSettings());
var xml2:XML =
        <foo>
            <!-- comment -->
            <?instruction ?>
        </foo>;
trace(xml2.toXMLString());

text () method
AS3 function text():XMLList

Returns an XMLList object of all XML properties of the XML object that represent XML text nodes.

Returns
XMLList — The list of properties.

See also

XML objects

Example
The following example uses the text() method to get the text nodes of an XML object:
var xml:XML =
        <body>
            text1
            <hr/>
            text2
        </body>;
trace(xml.text()[0]); // text1
trace(xml.text()[1]); // text2

toString () method
AS3 function toString():String

Returns a string representation of the XML object. The rules for this conversion depend on whether the XML object has simple content or complex content:

  • If the XML object has simple content, toString() returns the String contents of the XML object with the following stripped out: the start tag, attributes, namespace declarations, and end tag.
  • If the XML object has complex content, toString() returns an XML encoded String representing the entire XML object, including the start tag, attributes, namespace declarations, and end tag.

To return the entire XML object every time, use toXMLString().

Returns
String — The string representation of the XML object.

See also

XML.hasSimpleContent()
XML.hasComplexContent()
XML.toXMLString()
XML type conversion

Example
The following example shows what the toString() method returns when the XML object has simple content:
var test:XML = <type name="Joe">example</type>;
trace(test.toString()); //example

The following example shows what the toString() method returns when the XML object has complex content:
var test:XML =
<type name="Joe">
    <base name="Bob"></base>
    example
</type>;
trace(test.toString());
  // <type name="Joe">
  // <base name="Bob"/>
  // example
  // </type>

toXMLString () method
AS3 function toXMLString():String

Returns a string representation of the XML object. Unlike the toString() method, the toXMLString() method always returns the start tag, attributes, and end tag of the XML object, regardless of whether the XML object has simple content or complex content. (The toString() method strips out these items for XML objects that contain simple content.)

Returns
String — The string representation of the XML object.

See also

XML.toString()
XML objects
XML type conversion

Example
The following example shows the difference between using the toString() method (which is applied to all parameters of a trace() method, by default) and using the toXMLString() method:
var xml:XML =
        <p>hello</p>;
trace(xml); // hello
trace(xml.toXMLString()); // <p>hello</p>

valueOf () method
AS3 function valueOf():XML

Returns the XML object.

Returns
XML — The primitive value of an XML instance.

See also

XML objects

Example
The following example shows that the value returned by the valueOf() method is the same as the source XML object:
var xml:XML = <p>hello</p>;
trace(xml.valueOf() === xml); // true

Examples

The following example first creates an XML variable and adds nodes to it. Then XML properties are used to find and print XML nodes. Notice that the "at" (@) symbol is used in several of the trace() calls to locate information by tag name.
package {
    import flash.display.Sprite;

    public class XmlExample extends Sprite {
        public function XmlExample() {
            var employees:XML =
                <employees>
                    <employee ssn="123-123-1234">
                        <name first="John" last="Doe"/>
                        <address>
                            <street>11 Main St.</street>
                            <city>San Francisco</city>
                            <state>CA</state>
                            <zip>98765</zip>
                        </address>
                    </employee>
                    <employee ssn="789-789-7890">
                        <name first="Mary" last="Roe"/>
                        <address>
                            <street>99 Broad St.</street>
                            <city>Newton</city>
                            <state>MA</state>
                            <zip>01234</zip>
                        </address>
                    </employee>
                </employees>;

            trace(employees.employee[0].address.zip);   // 98765

            trace(employees.employee[1].@ssn);          // 789-789-7890

            trace(employees.employee.name);             // <name first="John" last="Doe"/>
                                                        // <name first="Mary" last="Roe"/>

            trace(employees..zip[0]);                   // 98765

            trace(employees..@ssn[1]);                  // 789-789-7890

            trace(employees..name);                     // <name first="John" last="Doe"/>
                                                        // <name first="Mary" last="Roe"/>

            trace(employees.employee[0].address.*);     // <street>11 Main St.</street>
                                                        // <city>San Francisco</city>
                                                        // <state>CA</state>
                                                        // <zip>98765</zip>
            var node:String = "zip";
            trace(employees.employee[0].address[node]); // 98765

            var attribute:String = "ssn";
            trace(employees.employee[1].@[attribute]);  // 789-789-7890

            for each (var num:XML in employees..@ssn) {
                trace(num);                             // 123-123-1234
            }                                           // 789-789-7890

            var ssnToFind:String = "789-789-7890";
            trace(employees.employee.(@ssn == ssnToFind).toXMLString());
                                                        // <employee ssn="789-789-7890">
                                                        // <name first="Mary" last="Roe"/>
                                                        // <address>
                                                        // <street>99 Broad St.</street>
                                                        // <city>Newton</city>
                                                        // <state>MA</state>
                                                        // <zip>01234</zip>
                                                        // </address>
                                                        // </employee>
        }
    }
}


XMLList (Flex™ 2 Language Reference)

Class XMLList | Properties | Methods | Examples
Package | Top Level
Class | public final dynamic class XMLList
Inheritance | XMLList Inheritance Object

An XMLList object is an ordered collection of properties. An XMLList object represents an XML document, an XML fragment, or an arbitrary collection of XML objects.

An XMLList object with one XML element is treated the same as an XML object. When there is one XML element, all methods that are available for the XML object are also available for the XMLList object.

In the following example, example.two is an XMLList object of length 1, so you can call any XML method on it.

 var example2 = <example><two>2</two></example>;

The following table lists the XML methods that are not included in the XMLList class, but that you can use when your XMLList object has only one XML element. If you attempt to use these methods with anything other than one XML element (zero or more than one element), an exception is thrown.

XML methods
addNamespace()
appendChild()
childIndex()
inScopeNamespace()
insertChildAFter()
insertChildBefore()
name()
namespace()
localName()
namespaceDeclarations()
nodeKind()
prependChild()
removeNamespace()
replace()
setChildren()
setLocalName()
setName()
setNamespace()

This class (along with the XML, Namespace, and QName classes) implements powerful XML-handling standards defined in ECMAScript for XML (E4X) specification (ECMA-357 edition 2).

View the examples.

See also

XML
Namespace
QName

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | XMLList(value:Object) Creates a new XMLList object. | XMLList
 | attribute(attributeName:*):XMLList Calls the attribute() method of each XML object and returns an XMLList object of the results. | XMLList
 | attributes():XMLList Calls the attributes() method of each XML object and returns an XMLList object of attributes for each XML object. | XMLList
 | child(propertyName:Object):XMLList Calls the child() method of each XML object and returns an XMLList object that contains the results in order. | XMLList
 | children():XMLList Calls the children() method of each XML object and returns an XMLList object that contains the results. | XMLList
 | comments():XMLList Calls the comments() method of each XML object and returns an XMLList of comments. | XMLList
 | contains(value:XML):Boolean Checks whether the XMLList object contains an XML object that is equal to the given value parameter. | XMLList
 | copy():XMLList Returns a copy of the given XMLList object. | XMLList
 | descendants(name:Object = *):XMLList Returns all descendants (children, grandchildren, great-grandchildren, and so on) of the XML object that have the given name parameter. | XMLList
 | elements(name:Object = *):XMLList Calls the elements() method of each XML object. | XMLList
 | hasComplexContent():Boolean Checks whether the XMLList object contains complex content. | XMLList
 | hasOwnProperty(p:String):Boolean Checks for the property specified by p. | XMLList
 | hasSimpleContent():Boolean Checks whether the XMLList object contains simple content. | XMLList
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | length():int Returns the number of properties in the XMLList object. | XMLList
 | normalize():XMLList Merges adjacent text nodes and eliminates empty text nodes for each of the following: all text nodes in the XMLList, all the XML objects contained in the XMLList, and the descendants of all the XML objects in the XMLList. | XMLList
 | parent():Object Returns the parent of the XMLList object if all items in the XMLList object have the same parent. | XMLList
 | processingInstructions(name:String = "*"):XMLList If a name parameter is provided, lists all the children of the XMLList object that contain processing instructions with that name. | XMLList
 | propertyIsEnumerable(p:String):Boolean Checks whether the property p is in the set of properties that can be iterated in a for..in statement applied to the XMLList object. | XMLList
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | text():XMLList Calls the text() method of each XML object and returns an XMLList object that contains the results. | XMLList
 | toString():String Returns a string representation of all the XML objects in an XMLList object. | XMLList
 | toXMLString():String Returns a string representation of all the XML objects in an XMLList object. | XMLList
 | valueOf():XMLList Returns the XMLList object. | XMLList
Constructor detail
XMLList () constructor
public function XMLList(value:Object)

Creates a new XMLList object.

Parameters
value:Object — Any object that can be converted to an XMLList object by using the top-level XMLList() function.

See also

top-level XMLList() function
Method detail
attribute () method
AS3 function attribute(attributeName:*):XMLList

Calls the attribute() method of each XML object and returns an XMLList object of the results. The results match the given attributeName parameter. If there is no match, the attribute() method returns an empty XMLList object.

Parameters
attributeName:* — The name of the attribute that you want to include in an XMLList object.

Returns
XMLList — An XMLList object of matching XML objects or an empty XMLList object.

See also

XML.attribute()
XML.attributes()
XMLList objects
attributes () method
AS3 function attributes():XMLList

Calls the attributes() method of each XML object and returns an XMLList object of attributes for each XML object.

Returns
XMLList — An XMLList object of attributes for each XML object.

See also

XML.attribute()
XML.attributes()
XMLList objects
child () method
AS3 function child(propertyName:Object):XMLList

Calls the child() method of each XML object and returns an XMLList object that contains the results in order.

Parameters
propertyName:Object — The element name or integer of the XML child.

Returns
XMLList — An XMLList object of child nodes that match the input parameter.

See also

XML.child()
XMLList objects
children () method
AS3 function children():XMLList

Calls the children() method of each XML object and returns an XMLList object that contains the results.

Returns
XMLList — An XMLList object of the children in the XML objects.

See also

XML.children()
XMLList objects
comments () method
AS3 function comments():XMLList

Calls the comments() method of each XML object and returns an XMLList of comments.

Returns
XMLList — An XMLList of the comments in the XML objects.

See also

XML.comments()
XMLList objects
contains () method
AS3 function contains(value:XML):Boolean

Checks whether the XMLList object contains an XML object that is equal to the given value parameter.

Parameters
value:XML — An XML object to compare against the current XMLList object.

Returns
Boolean — If the XMLList contains the XML object declared in the value parameter, then true; otherwise false.

See also

XMLList objects
copy () method
AS3 function copy():XMLList

Returns a copy of the given XMLList object. The copy is a duplicate of the entire tree of nodes. The copied XML object has no parent and returns null if you attempt to call the parent() method.

Returns
XMLList — The copy of the XMLList object.

See also

XMLList objects
descendants () method
AS3 function descendants(name:Object = *):XMLList

Returns all descendants (children, grandchildren, great-grandchildren, and so on) of the XML object that have the given name parameter. The name parameter can be a QName object, a String data type, or any other data type that is then converted to a String data type.

To return all descendants, use the asterisk (*) parameter. If no parameter is passed, the string "*" is passed and returns all descendants of the XML object.

Parameters
name:Object (default = *) — The name of the element to match.

Returns
XMLList — An XMLList object of the matching descendants (children, grandchildren, and so on) of the XML objects in the original list. If there are no descendants, returns an empty XMLList object.

See also

XML.descendants()
XMLList objects
elements () method
AS3 function elements(name:Object = *):XMLList

Calls the elements() method of each XML object. The name parameter is passed to the descendants() method. If no parameter is passed, the string "*" is passed to the descendants() method.

Parameters
name:Object (default = *) — The name of the elements to match.

Returns
XMLList — An XMLList object of the matching child elements of the XML objects.

See also

XML.elements()
hasComplexContent () method
AS3 function hasComplexContent():Boolean

Checks whether the XMLList object contains complex content. An XMLList object is considered to contain complex content if it is not empty and either of the following conditions is true:

  • The XMLList object contains a single XML item with complex content.
  • The XMLList object contains elements.

Returns
Boolean — If the XMLList object contains complex content, then true; otherwise false.

See also

hasSimpleContent()
XML.hasComplexContent()
XML.hasSimpleContent()
XMLList objects
hasOwnProperty () method
AS3 function hasOwnProperty(p:String):Boolean

Checks for the property specified by p.

Parameters
p:String — The property to match.

Returns
Boolean — If the parameter exists, then true; otherwise false.

See also

XMLList objects
hasSimpleContent () method
AS3 function hasSimpleContent():Boolean

Checks whether the XMLList object contains simple content. An XMLList object is considered to contain simple content if one or more of the following conditions is true:

  • The XMLList object is empty
  • The XMLList object contains a single XML item with simple content
  • The XMLList object contains no elements

Returns
Boolean — If the XMLList contains simple content, then true; otherwise false.

See also

hasComplexContent()
XML.hasComplexContent()
XML.hasSimpleContent()
XMLList objects
length () method
AS3 function length():int

Returns the number of properties in the XMLList object.

Returns
int — The number of properties in the XMLList object.

See also

XMLList objects
normalize () method
AS3 function normalize():XMLList

Merges adjacent text nodes and eliminates empty text nodes for each of the following: all text nodes in the XMLList, all the XML objects contained in the XMLList, and the descendants of all the XML objects in the XMLList.

Returns
XMLList — The normalized XMLList object.

See also

XMLList objects
parent () method
AS3 function parent():Object

Returns the parent of the XMLList object if all items in the XMLList object have the same parent. If the XMLList object has no parent or different parents, the method returns undefined.

Returns
Object — Returns the parent XML object.

See also

XMLList objects
processingInstructions () method
AS3 function processingInstructions(name:String = "*"):XMLList

If a name parameter is provided, lists all the children of the XMLList object that contain processing instructions with that name. With no parameters, the method lists all the children of the XMLList object that contain any processing instructions.

Parameters
name:String (default = "*") — The name of the processing instructions to match.

Returns
XMLList — An XMLList object that contains the processing instructions for each XML object.

See also

XML.processingInstructions()
XMLList objects
propertyIsEnumerable () method
AS3 function propertyIsEnumerable(p:String):Boolean

Checks whether the property p is in the set of properties that can be iterated in a for..in statement applied to the XMLList object. This is true only if toNumber(p) is greater than or equal to 0 and less than the length of the XMLList object.

Parameters
p:String — The index of a property to check.

Returns
Boolean — If the property can be iterated in a for..in statement, then true; otherwise false.

See also

XMLList objects
text () method
AS3 function text():XMLList

Calls the text() method of each XML object and returns an XMLList object that contains the results.

Returns
XMLList — An XMLList object of all XML properties of the XMLList object that represent XML text nodes.

See also

XML.text()
XMLList objects
toString () method
AS3 function toString():String

Returns a string representation of all the XML objects in an XMLList object. The rules for this conversion depend on whether the XML object has simple content or complex content:

  • If the XML object has simple content, toString() returns the string contents of the XML object with the following stripped out: the start tag, attributes, namespace declarations, and end tag.
  • If the XML object has complex content, toString() returns an XML encoded string representing the entire XML object, including the start tag, attributes, namespace declarations, and end tag.

To return the entire XML object every time, use the toXMLString() method.

Returns
String — The string representation of the XML object.

See also

hasComplexContent()
hasSimpleContent()
toXMLString()
XMLList objects
XML type conversion

Example
The following example shows what the toString() method returns when the XML object has simple content:
var test:XML = <type name="Joe">example</type>;
trace(test.toString()); //example

The following example shows what the toString() method returns when the XML object has complex content:
var test:XML =
<type name="Joe">
    <base name="Bob"></base>
    example
</type>;
trace(test.toString());
  // <type name="Joe">
  // <base name="Bob"/>
  // example
  // </type>

toXMLString () method
AS3 function toXMLString():String

Returns a string representation of all the XML objects in an XMLList object. Unlike the toString() method, the toXMLString() method always returns the start tag, attributes, and end tag of the XML object, regardless of whether the XML object has simple content or complex content. (The toString() method strips out these items for XML objects that contain simple content.)

Returns
String — The string representation of the XML object.

See also

toString()
XMLList objects
XML type conversion
valueOf () method
AS3 function valueOf():XMLList

Returns the XMLList object.

Returns
XMLList — Returns the current XMLList object.

See also

XMLList objects
Examples

The following example creates an XML property named books and adds several items with book publisher and name tags to a node named books. Then the showBooksByPublisher() method is called, which takes the XMLList and returns each item matching the publisher, "Addison-Wesley."
package {
    import flash.display.Sprite;

    public class XMLListExample extends Sprite {
        private var books:XML;

        public function XMLListExample() {
            books =    <books>
                        <book publisher="Addison-Wesley" name="Design Patterns" />
                        <book publisher="Addison-Wesley" name="The Pragmatic Programmer" />
                        <book publisher="Addison-Wesley" name="Test Driven Development" />
                        <book publisher="Addison-Wesley" name="Refactoring to Patterns" />
                        <book publisher="O'Reilly Media" name="The Cathedral & the Bazaar" />
                        <book publisher="O'Reilly Media" name="Unit Test Frameworks" />
                    </books>;

            showBooksByPublisher("Addison-Wesley");
        }

        private function showBooksByPublisher(name:String):void {
            var results:XMLList = books.book.(@publisher == name);
            showList(results);
        }

        private function showList(list:XMLList):void {
            var item:XML;
            for each(item in list) {
                trace("item: " + item.toXMLString());
            }
        }
    }
}


flash.accessibility Summary (Flex™ 2 Language Reference)

Package flash.accessibility | Classes

The flash.accessibility package contains classes for supporting accessibility in Flash content and applications.

Classes
Class | Description
Accessibility | The Accessibility class manages communication with screen readers.
AccessibilityProperties | The AccessibilityProperties class lets you control the presentation of Flash objects to accessibility aids, such as screen readers.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.accessibility.Accessibility (Flex™ 2 Language Reference)

Class Accessibility | Properties | Methods | Examples
Package | flash.accessibility
Class | public final class Accessibility
Inheritance | Accessibility Inheritance Object

The Accessibility class manages communication with screen readers. Screen readers are a type of assistive technology for visually impaired users that provides an audio version of screen content. The methods of the Accessibility class are static—that is, you don't have to create an instance of the class to use its methods.

To get and set accessible properties for a specific object, such as a button, movie clip, or text field, use the DisplayObject.accessibilityProperties property. To determine whether the player is running in an environment that supports accessibility aids, use the Capabilities.hasAccessibility property.

View the examples.

See also

flash.display.DisplayObject.accessibilityProperties
flash.system.Capabilities.hasAccessibility
Socket

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | active : Boolean [static][read-only] Indicates whether a screen reader is currently active and the player is communicating with it. | Accessibility
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
 | updateProperties():void [static] Tells Flash Player to apply any accessibility changes made by using the DisplayObject.accessibilityProperties property. | Accessibility
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
active property
active:Boolean [read-only]

Indicates whether a screen reader is currently active and the player is communicating with it. Use this method when you want your application to behave differently in the presence of a screen reader.

Note: If you call this method within 1 or 2 seconds of the first appearance of the Flash® window in which your document is playing, you might get a return value of false even if there is an active accessibility client. This happens because of an asynchronous communication mechanism between Flash and accessibility clients. You can work around this limitation by ensuring a delay of 1 to 2 seconds after loading your document before calling this method.

To determine whether the player is running in an environment that supports screen readers, use the Capabilities.hasAccessibility property. Implementation
    public static function get active():Boolean

See also

flash.system.Capabilities.hasAccessibility
updateProperties()
Method detail
updateProperties () method
public static function updateProperties():void

Tells Flash Player to apply any accessibility changes made by using the DisplayObject.accessibilityProperties property. You need to call this method for your changes to take effect.

If you modify the accessibility properties for multiple objects, only one call to the Accessibility.updateProperties() method is necessary; multiple calls can result in reduced performance and erroneous screen reader output.

Throws
IllegalOperationError — Accessibility is not supported in this version of Flash Player. Do not call the Accessibility.updateProperties() method if the flash.system.Capabilities.hasAccessibility property is false.

See also

active
flash.display.DisplayObject.accessibilityProperties
flash.system.Capabilities.hasAccessibility
Examples

The following example uses AccessibilityExample, CustomAccessibleButton, CustomSimpleButton, and ButtonDisplayState sample classes to create an accessibility-compliant menu that works with most screen readers. The example carries out the following tasks:
  1. It traces the Accessibility.active property to determine whether a screen reader is currently active and the player is communicating with it.
  2. If the active property returns true, the example calls the updateProperties() method to apply the accessibility changes made to the buttons in this example.
  3. The example calls the flash.utils.setTimeout() method, specifying that the updateAccessibility() closure method should be called after 2 seconds.

Note: Call setTimeout() before checking Accessibility.active to give Flash Player the 2 seconds it needs to connect to a screen reader if one is available. If you do not supply a sufficient delay time, the setTimeout call might return false even if a screen reader is available.

The following example processes the Accessibility.updateProperties() method only if the call to Accessibility.active returns true, which occurs only if Flash Player is currently connected to an active screen reader. If updateProperties is called without an active screen reader, it throws an IllegalOperationError exception.

package {
    import flash.display.Sprite;
    import flash.accessibility.Accessibility;
    import flash.utils.setTimeout;

    public class AccessibilityExample extends Sprite {
        public static const BUTTON_WIDTH:uint = 90;
        public static const BUTTON_HEIGHT:uint = 20;

        private var gutter:uint = 5;
        private var menuLabels:Array = new Array("PROJECTS", "PORTFOLIO", "CONTACT");
        private var menuDescriptions:Array = new Array("Learn more about our projects"
                                                     , "See our portfolio"
                                                     , "Get in touch with our team");

        public function AccessibilityExample() {
            configureAssets();
            setTimeout(updateAccessibility, 2000);
        }

        private function updateAccessibility():void {
            trace("Accessibility.active: " + Accessibility.active);
            if(Accessibility.active) {
                Accessibility.updateProperties();
            }
        }

        private function configureAssets():void {
            var child:CustomAccessibleButton;
            for(var i:uint; i < menuLabels.length; i++) {
                child = new CustomAccessibleButton();
                child.y = (numChildren * (BUTTON_HEIGHT + gutter));
                child.setLabel(menuLabels[i]);
                child.setDescription(menuDescriptions[i]);
                addChild(child);
            }
        }
    }
}

import flash.accessibility.AccessibilityProperties;
import flash.display.Shape;
import flash.display.SimpleButton;
import flash.display.Sprite;
import flash.events.Event;
import flash.text.TextFormat;
import flash.text.TextField;

class CustomAccessibleButton extends Sprite {
    private var button:SimpleButton;
    private var label:TextField;
    private var description:String;
    private var _name:String;

    public function CustomAccessibleButton(_width:uint = 0, _height:uint = 0) {
        _width = (_width == 0) ? AccessibilityExample.BUTTON_WIDTH : _width;
        _height = (_height == 0) ? AccessibilityExample.BUTTON_HEIGHT : _height;

        button = buildButton(_width, _height);
        label = buildLabel(_width, _height);

        addEventListener(Event.ADDED, addedHandler);
    }

    private function addedHandler(event:Event):void {
        trace("addedHandler: " + this._name);
        var accessProps:AccessibilityProperties = new AccessibilityProperties();
        accessProps.name = this._name;
        accessProps.description = description;
        accessibilityProperties = accessProps;
        removeEventListener(Event.ADDED, addedHandler);
    }

    private function buildButton(_width:uint, _height:uint):SimpleButton {
        var child:SimpleButton = new CustomSimpleButton(_width, _height);
        addChild(child);
        return child;
    }

    private function buildLabel(_width:uint, _height:uint):TextField {
        var format:TextFormat = new TextFormat();
        format.font = "Verdana";
        format.size = 11;
        format.color = 0xFFFFFF;
        format.align = TextFormatAlign.CENTER;
        format.bold = true;

        var child:TextField = new TextField();
        child.y = 1;
        child.width = _width;
        child.height = _height;
        child.selectable = false;
        child.defaultTextFormat = format;
        child.mouseEnabled = false;

        addChild(child);
        return child;
    }

    public function setLabel(text:String):void {
        label.text = text;
        this._name = text;
    }

    public function setDescription(text:String):void {
        description = text;
    }
}

class CustomSimpleButton extends SimpleButton {
    private var upColor:uint = 0xFFCC00;
    private var overColor:uint = 0xCCFF00;
    private var downColor:uint = 0x00CCFF;

    public function CustomSimpleButton(_width:uint, _height:uint) {
        downState = new ButtonDisplayState(downColor, _width, _height);
        overState = new ButtonDisplayState(overColor, _width, _height);
        upState = new ButtonDisplayState(upColor, _width, _height);
        hitTestState = new ButtonDisplayState(upColor, _width, _height);
        useHandCursor = true;
    }
}

class ButtonDisplayState extends Shape {
    private var bgColor:uint;
    private var _width:uint;
    private var _height:uint;

    public function ButtonDisplayState(bgColor:uint, _width:uint, _height:uint) {
        this.bgColor = bgColor;
        this._width = _width;
        this._height = _height;
        draw();
    }

    private function draw():void {
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, _width, _height);
        graphics.endFill();
    }
}


flash.accessibility.AccessibilityProperties (Flex™ 2 Language Reference)

Class AccessibilityProperties | Properties | Methods | Examples
Package | flash.accessibility
Class | public class AccessibilityProperties
Inheritance | AccessibilityProperties Inheritance Object

The AccessibilityProperties class lets you control the presentation of Flash objects to accessibility aids, such as screen readers.

You can attach an AccessibilityProperties object to any display object, but Flash Player will read your AccessibilityProperties object only for certain kinds of objects: entire SWF files (as represented by DisplayObject.root), container objects (DisplayObjectContainer and subclasses), buttons (SimpleButton and subclasses), and text (TextField and subclasses).

The name property of these objects is the most important property to specify because accessibility aids provide the names of objects to users as a basic means of navigation. Do not confuse AccessibilityProperties.name with DisplayObject.name; these are separate and unrelated. The AccessibilityProperties.name property is a name that is read aloud by the accessibility aids, whereas DisplayObject.name is essentially a variable name visible only to ActionScript code.

The properties of AccessibilityProperties objects override the corresponding settings available in the Accessibility panel during authoring.

To determine whether Flash Player is running in an environment that supports accessibility aids, use the Capabilities.hasAccessibility property. If you modify AccessibilityProperties objects, you need to call the Accessibility.updateProperties() method for the changes to take effect.

The following Property table lists the name and data type of each property its equivalent setting in the Accessibility panel, and the kinds of objects to which the property can be applied.

View the examples.

See also

flash.accessibility.Accessibility.updateProperties()
flash.display.DisplayObject.accessibilityProperties
flash.display.InteractiveObject.tabIndex
flash.system.Capabilities.hasAccessibility

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | description : String Provides a description for this display object in the accessible presentation. | AccessibilityProperties
 | forceSimple : Boolean If true, causes Flash® Player to exclude child objects within this display object from the accessible presentation. | AccessibilityProperties
 | name : String Provides a name for this display object in the accessible presentation. | AccessibilityProperties
 | noAutoLabeling : Boolean If true, disables the Flash Player default auto-labeling system. | AccessibilityProperties
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | shortcut : String Indicates a keyboard shortcut associated with this display object. | AccessibilityProperties
 | silent : Boolean If true, excludes this display object from accessible presentation. | AccessibilityProperties
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AccessibilityProperties() Creates a new AccessibilityProperties object. | AccessibilityProperties
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
description property
public var description:String

Provides a description for this display object in the accessible presentation. If you have a lot of information to present about the object, it is best to choose a concise name and put most of your content in the description property. Applies to whole SWF files, containers, buttons, and text.

forceSimple property
public var forceSimple:Boolean

If true, causes Flash® Player to exclude child objects within this display object from the accessible presentation. The default is false. Applies to whole SWF files and containers.

name property
public var name:String

Provides a name for this display object in the accessible presentation. Applies to whole SWF files, containers, buttons, and text. Do not confuse with DisplayObject.name, which is unrelated.

noAutoLabeling property
public var noAutoLabeling:Boolean

If true, disables the Flash Player default auto-labeling system. Auto-labeling causes text objects inside buttons to be treated as button names, and text objects near text fields to be treated as text field names. The default is false. Applies only to whole SWF files.

shortcut property
public var shortcut:String

Indicates a keyboard shortcut associated with this display object. Supply this string only for UI controls that you have associated with a shortcut key. Applies to containers, buttons, and text.

Note: Assigning this property does not automatically assign the specified key combination to this object; you must do that yourself, for example, by listening for a KeyboardEvent.

The syntax for this string uses long names for modifier keys, and the plus(+) character to indicate key combination. Examples of valid strings are "Ctrl+F", "Ctrl+Shift+Z", and so on.

silent property
public var silent:Boolean

If true, excludes this display object from accessible presentation. The default is false. Applies to whole SWF files, containers, buttons, and text.

Constructor detail
AccessibilityProperties () constructor
public function AccessibilityProperties()

Creates a new AccessibilityProperties object.

Examples

The following example uses the AccessibilityExample, CustomAccessibleButton, CustomSimpleButton, and ButtonDisplayState classes to create an accessibility-compliant menu that works with common screen readers. The main functionality of the AccessibilityProperties class is as follows:
  1. Call configureAssets, which creates a custom button and sets its label and description. These are the values that the screen reader conveys to the end user.
  2. Call setTimeOut() to ensure that Flash Player has enough time to detect the screen reader before updating the properties.

Note: Call setTimeout() before checking Accessibility.active. to give Flash Player the 2 seconds it needs to connect to a screen reader, if one is available. If you do not provide a sufficient delay time, the setTimeout call might return false, even if a screen reader is available.

The following example processes the Accessibility.updateProperties() method only if the call to Accessibility.active returns true, which occurs only if Flash Player is currently connected to an active screen reader. If updateProperties is called without an active screen reader, it throws an IllegalOperationError exception.

package {
    import flash.display.Sprite;
    import flash.accessibility.Accessibility;
    import flash.utils.setTimeout;

    public class AccessibilityPropertiesExample extends Sprite {
        public static const BUTTON_WIDTH:uint = 90;
        public static const BUTTON_HEIGHT:uint = 20;

        private var gutter:uint = 5;
        private var menuLabels:Array = new Array("PROJECTS", "PORTFOLIO", "CONTACT");
        private var menuDescriptions:Array = new Array("Learn more about our projects"
                                                     , "See our portfolio"
                                                     , "Get in touch with our team");

        public function AccessibilityPropertiesExample() {
            configureAssets();
            setTimeout(updateAccessibility, 2000);
        }

        private function updateAccessibility():void {
            trace("Accessibility.active: " + Accessibility.active);
            if(Accessibility.active) {
                Accessibility.updateProperties();
            }
        }

        private function configureAssets():void {
            var child:CustomAccessibleButton;
            for(var i:uint; i < menuLabels.length; i++) {
                child = new CustomAccessibleButton();
                child.y = (numChildren * (BUTTON_HEIGHT + gutter));
                child.setLabel(menuLabels[i]);
                child.setDescription(menuDescriptions[i]);
                addChild(child);
            }
        }
    }

import flash.accessibility.AccessibilityProperties;
import flash.display.Shape;
import flash.display.SimpleButton;
import flash.display.Sprite;
import flash.events.Event;
import flash.text.TextFormat;
import flash.text.TextField;

class CustomAccessibleButton extends Sprite {
    private var button:SimpleButton;
    private var label1:TextField;
    private var description:String;
    private var _name:String;

    public function CustomAccessibleButton(_width:uint = 0, _height:uint = 0) {
        _width = (_width == 0) ? AccessibilityPropertiesExample.BUTTON_WIDTH : _width;
        _height = (_height == 0) ? AccessibilityPropertiesExample.BUTTON_HEIGHT : _height;

        button = buildButton(_width, _height);
        label1 = buildLabel(_width, _height);

        addEventListener(Event.ADDED, addedHandler);
    }

    private function addedHandler(event:Event):void {
        trace("addedHandler: " + name);
        var accessProps:AccessibilityProperties = new AccessibilityProperties();
        accessProps.name = this._name;
        accessProps.description = description;
        accessibilityProperties = accessProps;
        removeEventListener(Event.ADDED, addedHandler);
    }

    private function buildButton(_width:uint, _height:uint):SimpleButton {
        var child:SimpleButton = new CustomSimpleButton(_width, _height);
        addChild(child);
        return child;
    }

    private function buildLabel(_width:uint, _height:uint):TextField {
        var format:TextFormat = new TextFormat();
        format.font = "Verdana";
        format.size = 11;
        format.color = 0xFFFFFF;
        format.align = TextFormatAlign.CENTER;
        format.bold = true;

        var child:TextField = new TextField();
        child.y = 1;
        child.width = _width;
        child.height = _height;
        child.selectable = false;
        child.defaultTextFormat = format;
        child.mouseEnabled = false;

        addChild(child);
        return child;
    }

    public function setLabel(text:String):void {
        label1.text = text;
        this._name = text;
    }

    public function setDescription(text:String):void {
        description = text;
    }
}

class CustomSimpleButton extends SimpleButton {
    private var upColor:uint = 0xFFCC00;
    private var overColor:uint = 0xCCFF00;
    private var downColor:uint = 0x00CCFF;

    public function CustomSimpleButton(_width:uint, _height:uint) {
        downState = new ButtonDisplayState(downColor, _width, _height);
        overState = new ButtonDisplayState(overColor, _width, _height);
        upState = new ButtonDisplayState(upColor, _width, _height);
        hitTestState = new ButtonDisplayState(upColor, _width, _height);
        useHandCursor = true;
    }
}

class ButtonDisplayState extends Shape {
    private var bgColor:uint;
    private var _width:uint;
    private var _height:uint;

    public function ButtonDisplayState(bgColor:uint, _width:uint, _height:uint) {
        this.bgColor = bgColor;
        this._width = _width;
        this._height = _height;
        draw();
    }

    private function draw():void {
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, _width, _height);
        graphics.endFill();
    }
}
}


flash.display Summary (Flex™ 2 Language Reference)

Package flash.display | Interfaces | Classes

The flash.display package contains the core classes that the Flash Player uses to build visual displays.

Interfaces
Interface | Description
IBitmapDrawable | The IBitmapDrawable interface is implemented by objects that can be passed as the source parameter of the draw() method of the BitmapData class.
Classes
Class | Description
ActionScriptVersion | The ActionScriptVersion class is an enumeration of constant values that indicate the language version of a loaded SWF file.
AVM1Movie | AVM1Movie is a simple class that represents AVM1 movie clips, which use ActionScript 1.0 or 2.0.
Bitmap | The Bitmap class represents display objects that represent bitmap images.
BitmapData | The BitmapData class lets you work with the data (pixels) of a Bitmap object.
BitmapDataChannel | The BitmapDataChannel class is an enumeration of constant values that indicate which channel to use: red, blue, green, or alpha transparency.
BlendMode | A class that provides constant values for visual blend mode effects.
CapsStyle | The CapsStyle class is an enumeration of constant values that specify the caps style to use in drawing lines.
DisplayObject | The DisplayObject class is the base class for all objects that can be placed on the display list.
DisplayObjectContainer | The DisplayObjectContainer class is the base class for all objects that can serve as display object containers on the display list.
FrameLabel | The FrameLabel object contains properties that specify a frame number and the corresponding label name.
GradientType | The GradientType class provides values for the type parameter in the beginGradientFill() and lineGradientFill() methods of the flash.display.Graphics class.
Graphics | The Graphics class contains a set of methods that you can use to create a vector shape.
InteractiveObject | The InteractiveObject class is the abstract base class for all display objects with which you can interact: mouse, keyboard, and focus.
InterpolationMethod | The InterpolationMethod class provides values for the interpolationMethod parameter in the Graphics.beginGradientFill() and Graphics.lineGradientStyle() methods.
JointStyle | The JointStyle class is an enumeration of constant values that specify the joint style to use in drawing lines.
LineScaleMode | The LineScaleMode class provides values for the scaleMode parameter in the Graphics.lineStyle() method.
Loader | The Loader class is used to load SWF files or image (JPG, PNG, or GIF) files.
LoaderInfo | The LoaderInfo class provides information about a loaded SWF file or a loaded image file (JPEG, GIF, or PNG).
MorphShape | The MorphShape class represents MorphShape objects on the display list.
MovieClip | The MovieClip class inherits from the following classes: Sprite, DisplayObjectContainer, InteractiveObject, DisplayObject, and EventDispatcher.
PixelSnapping | The PixelSnapping class is an enumeration of constant values for setting the pixel snapping options by using the pixelSnapping property of a Bitmap object.
Scene | The Scene class includes properties for identifying the name, labels, and number of frames in a scene.
Shape | The Shape class is used to create lightweight shapes by using the ActionScript drawing application program interface (API).
SimpleButton | The SimpleButton class lets you control all instances of button symbols in a SWF file.
SpreadMethod | The SpreadMethod class provides values for the spreadMethod parameter in the beginGradientFill() and lineGradientStyle() methods of the Graphics class.
Sprite | The Sprite class is a basic display list building block: a display list node that can display graphics and can also contain children.
Stage | The Stage class represents the main drawing area.
StageAlign | The StageAlign class provides constant values to use for the Stage.align property.
StageQuality | The StageQuality class provides values for the Stage.quality property.
StageScaleMode | The StageScaleMode class provides values for the Stage.scaleMode property.
SWFVersion | The SWFVersion class is an enumeration of constant values that indicate the file format version of a loaded SWF file.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.display.ActionScriptVersion (Flex™ 2 Language Reference)

Class ActionScriptVersion | Properties | Methods | Constants
Package | flash.display
Class | public final class ActionScriptVersion
Inheritance | ActionScriptVersion Inheritance Object

The ActionScriptVersion class is an enumeration of constant values that indicate the language version of a loaded SWF file. The language version constants are provided for use in checking the actionScriptVersion property of a flash.display.LoaderInfo object.

See also

flash.display.LoaderInfo.actionScriptVersion

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ACTIONSCRIPT2 : uint = 2 [static] ActionScript language version 2.0 and earlier. | ActionScriptVersion
 | ACTIONSCRIPT3 : uint = 3 [static] ActionScript language version 3.0. | ActionScriptVersion
Constant detail
ACTIONSCRIPT2 constant
public static const ACTIONSCRIPT2:uint = 2

ActionScript language version 2.0 and earlier.

ACTIONSCRIPT3 constant
public static const ACTIONSCRIPT3:uint = 3

ActionScript language version 3.0.


flash.display.AVM1Movie (Flex™ 2 Language Reference)

Class AVM1Movie | Properties | Methods | Events
Package | flash.display
Class | public class AVM1Movie
Inheritance | AVM1Movie Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

AVM1Movie is a simple class that represents AVM1 movie clips, which use ActionScript 1.0 or 2.0. (AVM1 is the ActionScript virtual machine used to run ActionScript 1.0 and 2.0. AVM2 is the ActionScript virtual machine used to run ActionScript 3.0.) When a Flash Player 8, or older, SWF file is loaded by a Loader object, an AVM1Movie object is created. The AVM1Movie object can use methods and properties inherited from the DisplayObject class (such as x, y, width, and so on). However, no interoperability (such as calling methods or using parameters) between the AVM1Movie object and AVM2 objects is allowed.

There are several restrictions on an AVM1 SWF file loaded by an AVM2 SWF file:

  • The loaded AVM1Movie object operates as a psuedo-root object for the AVM1 SWF file and all AVM1 SWF files loaded by it (as if the ActionScript 1.0 lockroot property were set to true). The AVM1 movie is always the top of any ActionScript 1.0 or 2.0 code execution in any children. The _root property for loaded children is always this AVM1 SWF file, unless the lockroot property is set in a loaded AVM1 SWF file.
  • The AVM1 content cannot load files into levels. For example, it cannot load files by calling loadMovieNum("url", levelNum).
  • The AVM1 SWF file that is loaded by an AVM2 SWF file cannot load another SWF file into this. That is, it cannot load another SWF file over itself. However, child Sprite objects, MovieClip objects, or other AVM1 SWF files loaded by this SWF file can load into this.

See also

DisplayObject
Loader
Understanding the display architecture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject


flash.display.Bitmap (Flex™ 2 Language Reference)

Class Bitmap | Properties | Methods | Events | Examples
Package | flash.display
Class | public class Bitmap
Inheritance | Bitmap Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | FlexBitmap

The Bitmap class represents display objects that represent bitmap images. These can be images that you load with the flash.display.Loader class, or they can be images that you create with the Bitmap() constructor.

The Bitmap() constructor allows you to create a Bitmap object that contains a reference to a BitmapData object. After you create a Bitmap object, use the addChild() or addChildAt() method of the parent DisplayObjectContainer instance to place the bitmap on the display list.

A Bitmap object can share its BitmapData reference among several Bitmap objects, independent of translation or rotation properties. Because you can create multiple Bitmap objects that reference the same BitmapData object, multiple display objects can use the same complex BitmapData object without incurring the memory overhead of a BitmapData object for each display object instance.

A BitmapData object can be drawn to the screen by a Bitmap object in one of two ways: by using the vector renderer as a fill-bitmap shape, or by using a faster pixel-copying routine. The pixel-copying routine is substantially faster than the vector renderer, but the Bitmap object must meet certain conditions to use it:

  • No stretching, rotation, or skewing can be applied to the Bitmap object.
  • No color transform can be applied to the Bitmap object.
  • No blend mode can be applied to the Bitmap object.
  • No clipping can be done through mask layers or setMask() methods.
  • The image itself cannot be a mask.
  • The destination coordinates must be on a whole pixel boundary.

If you load a Bitmap object from a domain other than that of the Loader object used to load the image, and there is no cross-domain policy file that permits access to the domain of the Loader object, then a script in that domain cannot access the Bitmap object or its properties and methods. For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

Note: The Bitmap class is not a subclass of the InteractiveObject class, so it cannot dispatch mouse events. However, you can use the addEventListener() method of the display object container that contains the Bitmap object.

View the examples.

See also

flash.display.Loader
flash.display.BitmapData
Understanding the display architecture
Creating and manipulating bitmaps

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | bitmapData : BitmapData The BitmapData object being referenced. | Bitmap
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
 | pixelSnapping : String Controls whether or not the Bitmap object is snapped to the nearest pixel. | Bitmap
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | smoothing : Boolean Controls whether or not the bitmap is smoothed when scaled. | Bitmap
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Bitmap(bitmapData:BitmapData = null, pixelSnapping:String = "auto", smoothing:Boolean = false)
Initializes a Bitmap object to refer to the specified BitmapData object.
Bitmap
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
bitmapData property
bitmapData:BitmapData [read-write]

The BitmapData object being referenced.

Implementation
    public function get bitmapData():BitmapData
    public function set bitmapData(value:BitmapData):void
pixelSnapping property
pixelSnapping:String [read-write]

Controls whether or not the Bitmap object is snapped to the nearest pixel. The PixelSnapping class includes possible values:

  • PixelSnapping.NEVER—No pixel snapping occurs.
  • PixelSnapping.ALWAYS—The image is always snapped to the nearest pixel, independent of transformation.
  • PixelSnapping.AUTO—The image is snapped to the nearest pixel if it is drawn with no rotation or skew and it is drawn at a scale factor of 99.9% to 100.1%. If these conditions are satisfied, the bitmap image is drawn at 100% scale, snapped to the nearest pixel. Internally, this value allows the image to be drawn as fast as possible using the vector renderer.

Implementation
    public function get pixelSnapping():String
    public function set pixelSnapping(value:String):void
smoothing property
smoothing:Boolean [read-write]

Controls whether or not the bitmap is smoothed when scaled. If true, the bitmap is smoothed when scaled. If false, the bitmap is not smoothed when scaled.

Implementation
    public function get smoothing():Boolean
    public function set smoothing(value:Boolean):void
Constructor detail
Bitmap () constructor
public function Bitmap(bitmapData:BitmapData = null, pixelSnapping:String = "auto", smoothing:Boolean = false)

Initializes a Bitmap object to refer to the specified BitmapData object.

Parameters
bitmapData:BitmapData (default = null) — The BitmapData object being referenced.
pixelSnapping:String (default = "auto") — Whether or not the Bitmap object is snapped to the nearest pixel.
smoothing:Boolean (default = false) — Whether or not the bitmap is smoothed when scaled. For example, the following examples show the same bitmap scaled by a factor of 3, with smoothing set to false (left) and true (right):

Examples

The following example uses the BitmapExample class to load the "Image.gif" image into a DisplayObject in the default location (x = 0, y = 0). A copy of Image.gif is then placed to the right of the original, which has new colors applied to pixels that pass a test using the threshold() method. This task is accomplished using the following steps:
  1. A property url is created, which is the location and name of the image file
  2. The class constructor calls the configureAssets() method, which, in turn, calls the completeHandler() method.
  3. configureAssets() creates a Loader object, which then instantiates an event listener, which is dispatched when completeHandler() completes the image manipulation.
  4. Next, the buildChild() method creates a new instance of a URLRequest object, request, with url passed so the file name and location are known.
  5. The request object is passed to the loader.load() method, which loads the image into memory via a display object.
  6. The image is then placed on the display list, which promptly displays the image on screen at coordinates x = 0, y = 0.
  7. The completeHandler() method then performs the following tasks:
    1. Creates a second Loader object, along with a Bitmap object, which is initialized with the Loader object.
    2. Creates a second Bitmap object, duplicate, which in turn calls the duplicateImage() method, which creates a duplicate of the original image.
    3. Creates a BitmapData object, which is assigned to the duplicate object's BitmapData object.
    4. Creates a new Rectangle object initialized with the same coordinates, width, and height as the original image.
    5. Creates a new Point object, which defaults to x = 0, y = 0.
    6. Creates the following variables:
      • operation: applies the new color when the threshold value is >= the original.
      • threshold: the value against which each pixel is compared is set to light gray with an alpha of 0xCC.
      • color: the color that the pixels will be set to that pass the threshold test, which is solid yellow in this case.
      • mask: set to the exact opposite of color, (transparent blue).
      • copySource: set to false, indicating that the pixel values are not copied in the event the threshold value does not pass. This value has no meaning because the image is duplicated and only pixels that pass the threshold test are changed.
    7. Calls the threshold() method by using the preceding variables. The resulting threshold equation is as follows: if (current pixel Value & 0x000000FF) >= (0xCCCCCCCC & 0x000000FF) then set pixel to 0xFFFFFF00.

Notes:

  • You will need to compile the SWF file with "Local playback security" set to "Access local files only".
  • This example requires that a file named Image.gif be placed in the same directory as your SWF file.
  • It is recommended that you use an image up to 80 pixels wide.

package {
    import flash.display.Bitmap;
    import flash.display.BitmapData;
    import flash.display.Loader;
    import flash.display.Sprite;
    import flash.events.*;
    import flash.geom.Point;
    import flash.geom.Rectangle;
    import flash.net.URLRequest;

    public class BitmapExample extends Sprite {
        private var url:String = "Image.gif";
        private var size:uint = 80;

        public function BitmapExample() {
            configureAssets();
        }

        private function configureAssets():void {
            var loader:Loader = new Loader();
            loader.contentLoaderInfo.addEventListener(Event.COMPLETE, completeHandler);
            loader.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);

            var request:URLRequest = new URLRequest(url);
            loader.x = size * numChildren;
            loader.load(request);
            addChild(loader);
        }

        private function duplicateImage(original:Bitmap):Bitmap {
            var image:Bitmap = new Bitmap(original.bitmapData.clone());
            image.x = size * numChildren;
            addChild(image);
            return image;
        }

        private function completeHandler(event:Event):void {
            var loader:Loader = Loader(event.target.loader);
            var image:Bitmap = Bitmap(loader.content);

            var duplicate:Bitmap = duplicateImage(image);
            var bitmapData:BitmapData = duplicate.bitmapData;
            var sourceRect:Rectangle = new Rectangle(0, 0, bitmapData.width, bitmapData.height);
            var destPoint:Point = new Point();
            var operation:String = ">=";
            var threshold:uint = 0xCCCCCCCC;
            var color:uint = 0xFFFFFF00;
            var mask:uint = 0x000000FF;
            var copySource:Boolean = true;

            bitmapData.threshold(bitmapData,
                                 sourceRect,
                                 destPoint,
                                 operation,
                                 threshold,
                                 color,
                                 mask,
                                 copySource);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("Unable to load image: " + url);
        }
    }
}


flash.display.BitmapData (Flex™ 2 Language Reference)

Class BitmapData | Properties | Methods | Examples
Package | flash.display
Class | public class BitmapData
Inheritance | BitmapData Inheritance Object
Implements | IBitmapDrawable

The BitmapData class lets you work with the data (pixels) of a Bitmap object. You can use the methods of the BitmapData class to create arbitrarily sized transparent or opaque bitmap images and manipulate them in various ways at runtime. You can also access the BitmapData for a bitmap image that you load with the flash.display.Loader class.

This class lets you separate bitmap rendering operations from the internal display updating routines of Flash Player. By manipulating a BitmapData object directly, you can create complex images without incurring the per-frame overhead of constantly redrawing the content from vector data.

The methods of the BitmapData class support effects that are not available through the filters available to non-bitmap display objects.

A BitmapData object contains an array of pixel data. This data can represent either a fully opaque bitmap or a transparent bitmap that contains alpha channel data. Either type of BitmapData object is stored as a buffer of 32-bit integers. Each 32-bit integer determines the properties of a single pixel in the bitmap.

Each 32-bit integer is a combination of four 8-bit channel values (from 0 to 255) that describe the alpha transparency and the red, green, and blue (ARGB) values of the pixel. (For ARGB values, the most significant byte represents the alpha channel value, followed by red, green, and blue.)

The four channels (alpha, red, green, and blue) are represented as numbers when you use them with the BitmapData.copyChannel() method or the DisplacementMapFilter.componentX and DisplacementMapFilter.componentY properties, and these numbers are represented by the following constants in the BitmapDataChannel class:

  • BitmapDataChannel.ALPHA
  • BitmapDataChannel.RED
  • BitmapDataChannel.GREEN
  • BitmapDataChannel.BLUE

You can attach BitmapData objects to a Bitmap object by using the bitmapData property of the Bitmap object.

You can use a BitmapData object to fill a Graphics object by using the Graphics.beginBitmapFill() method.

The maximum width and maximum height of a BitmapData object is 2880 pixels.

Calls to any method or property of a BitmapData object throw an ArgumentError error if the BitmapData object is invalid (for example, if it has height == 0 and width == 0) or it has been disposed of via dispose().

View the examples.

See also

flash.display.Bitmap.bitmapData
flash.display.Graphics.beginBitmapFill()
flash.display.Loader
Creating and manipulating bitmaps

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | height : int [read-only] The height of the bitmap image in pixels. | BitmapData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rect : Rectangle [read-only] The rectangle that defines the size and location of the bitmap image. | BitmapData
 | transparent : Boolean [read-only] Defines whether the bitmap image supports per-pixel transparency. | BitmapData
 | width : int [read-only] The width of the bitmap image in pixels. | BitmapData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BitmapData(width:int, height:int, transparent:Boolean = true, fillColor:uint = 0xFFFFFFFF)
Creates a BitmapData object with a specified width and height.
BitmapData
applyFilter(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, filter:BitmapFilter):void
Takes a source image and a filter object and generates the filtered image.
BitmapData
clone():BitmapData
Returns a new BitmapData object that is a clone of the original instance with an exact copy of the contained bitmap.
BitmapData
colorTransform(rect:Rectangle, colorTransform:ColorTransform):void
Adjusts the color values in a specified area of a bitmap image by using a ColorTransform object.
BitmapData
compare(otherBitmapData:BitmapData):Object
Compares two BitmapData objects.
BitmapData
copyChannel(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, sourceChannel:uint, destChannel:uint):void
Transfers data from one channel of another BitmapData object or the current BitmapData object into a channel of the current BitmapData object.
BitmapData
copyPixels(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, alphaBitmapData:BitmapData = null, alphaPoint:Point = null, mergeAlpha:Boolean = false):void
Provides a fast routine to perform pixel manipulation between images with no stretching, rotation, or color effects.
BitmapData
dispose():void
Frees memory that is used to store the BitmapData object.
BitmapData
draw(source:IBitmapDrawable, matrix:Matrix = null, colorTransform:ColorTransform = null, blendMode:String = null, clipRect:Rectangle = null, smoothing:Boolean = false):void
Draws the source display object onto the bitmap image, using the Flash Player vector renderer.
BitmapData
fillRect(rect:Rectangle, color:uint):void
Fills a rectangular area of pixels with a specified ARGB color.
BitmapData
floodFill(x:int, y:int, color:uint):void
Performs a flood fill operation on an image starting at an (x, y) coordinate and filling with a certain color.
BitmapData
generateFilterRect(sourceRect:Rectangle, filter:BitmapFilter):Rectangle
Determines the destination rectangle that the applyFilter() method call affects, given a BitmapData object, a source rectangle, and a filter object.
BitmapData
getColorBoundsRect(mask:uint, color:uint, findColor:Boolean = true):Rectangle
Determines a rectangular region that either fully encloses all pixels of a specified color within the bitmap image (if the findColor parameter is set to true) or fully encloses all pixels that do not include the specified color (if the findColor parameter is set to false).
BitmapData
getPixel(x:int, y:int):uint
Returns an integer that represents an RGB pixel value from a BitmapData object at a specific point (x, y).
BitmapData
getPixel32(x:int, y:int):uint
Returns an ARGB color value that contains alpha channel data and RGB data.
BitmapData
getPixels(rect:Rectangle):ByteArray
Generates a byte array from a rectangular region of pixel data.
BitmapData
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
hitTest(firstPoint:Point, firstAlphaThreshold:uint, secondObject:Object, secondBitmapDataPoint:Point = null, secondAlphaThreshold:uint = 1):Boolean
Performs pixel-level hit detection between one bitmap image and a point, rectangle, or other bitmap image.
BitmapData
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
lock():void
Locks an image so that any objects that reference the BitmapData object, such as Bitmap objects, are not updated when this BitmapData object changes.
BitmapData
merge(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, redMultiplier:uint, greenMultiplier:uint, blueMultiplier:uint, alphaMultiplier:uint):void
Performs per-channel blending from a source image to a destination image.
BitmapData
noise(randomSeed:int, low:uint = 0, high:uint = 255, channelOptions:uint = 7, grayScale:Boolean = false):void
Fills an image with pixels representing random noise.
BitmapData
paletteMap(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, redArray:Array = null, greenArray:Array = null, blueArray:Array = null, alphaArray:Array = null):void
Remaps the color channel values in an image that has up to four arrays of color palette data, one for each channel.
BitmapData
perlinNoise(baseX:Number, baseY:Number, numOctaves:uint, randomSeed:int, stitch:Boolean, fractalNoise:Boolean, channelOptions:uint = 7, grayScale:Boolean = false, offsets:Array = null):void
Generates a Perlin noise image.
BitmapData
pixelDissolve(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, randomSeed:int = 0, numPixels:int = 0, fillColor:uint = 0):int
Performs a pixel dissolve either from a source image to a destination image or by using the same image.
BitmapData
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
scroll(x:int, y:int):void
Scrolls an image by a certain (x, y) pixel amount.
BitmapData
setPixel(x:int, y:int, color:uint):void
Sets a single pixel of a BitmapData object.
BitmapData
setPixel32(x:int, y:int, color:uint):void
Sets the color and alpha transparency values of a single pixel of a BitmapData object.
BitmapData
setPixels(rect:Rectangle, inputByteArray:ByteArray):void
Converts a byte array into a rectangular region of pixel data.
BitmapData
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
threshold(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, operation:String, threshold:uint, color:uint = 0, mask:uint = 0xFFFFFFFF, copySource:Boolean = false):uint
Tests pixel values in an image against a specified threshold and sets pixels that pass the test to new color values.
BitmapData
Inherited
toString():String
Returns the string representation of the specified object.
Object
unlock(changeRect:Rectangle = null):void
Unlocks an image so that any objects that reference the BitmapData object, such as Bitmap objects, are updated when this BitmapData object changes.
BitmapData
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Property detail
height property
height:int [read-only]

The height of the bitmap image in pixels.

Implementation
    public function get height():int
rect property
rect:Rectangle [read-only]

The rectangle that defines the size and location of the bitmap image. The top and left of the rectangle are 0; the width and height are equal to the width and height in pixels of the BitmapData object.

Implementation
    public function get rect():Rectangle
transparent property
transparent:Boolean [read-only]

Defines whether the bitmap image supports per-pixel transparency. You can set this value only when you construct a BitmapData object by passing in true for the transparent parameter of the constructor. Then, after you create a BitmapData object, you can check whether it supports per-pixel transparency by determining if the value of the transparent property is true.

Implementation
    public function get transparent():Boolean
width property
width:int [read-only]

The width of the bitmap image in pixels.

Implementation
    public function get width():int
Constructor detail
BitmapData () constructor
public function BitmapData(width:int, height:int, transparent:Boolean = true, fillColor:uint = 0xFFFFFFFF)

Creates a BitmapData object with a specified width and height. If you specify a value for the fillColor parameter, every pixel in the bitmap is set to that color.

By default, the bitmap is created as transparent, unless you pass the value false for the transparent parameter. After you create an opaque bitmap, you cannot change it to a transparent bitmap. Every pixel in an opaque bitmap uses only 24 bits of color channel information. If you define the bitmap as transparent, every pixel uses 32 bits of color channel information, including an alpha transparency channel.

The maximum width and maximum height of a BitmapData object is 2880 pixels. If you specify a width or height value that is greater than 2880, a new instance is not created.

Parameters
width:int — The width of the bitmap image in pixels.
height:int — The height of the bitmap image in pixels.
transparent:Boolean (default = true) — Specifies whether the bitmap image supports per-pixel transparency. The default value is true (transparent). To create a fully transparent bitmap, set the value of the transparent parameter to true and the value of the fillColor parameter to 0x00000000 (or to 0). Setting the transparent property to false can result in minor improvements in rendering performance.
fillColor:uint (default = 0xFFFFFFFF) — A 32-bit ARGB color value that you use to fill the bitmap image area. The default value is 0xFFFFFFFF (solid white).

Throws
ArgumentError — width and/or height are invalid (less than or equal to zero, greater than 2880)
Method detail
applyFilter () method
public function applyFilter(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, filter:BitmapFilter):void

Takes a source image and a filter object and generates the filtered image.

This method relies on the behavior of built-in filter objects, which determine the destination rectangle that is affected by an input source rectangle.

After a filter is applied, the resulting image can be larger than the input image. For example, if you use a BlurFilter class to blur a source rectangle of (50,50,100,100) and a destination point of (10,10), the area that changes in the destination image is larger than (10,10,60,60) because of the blurring. This happens internally during the applyFilter() call.

If the sourceRect parameter of the sourceBitmapData parameter is an interior region, such as (50,50,100,100) in a 200 x 200 image, the filter uses the source pixels outside the sourceRect parameter to generate the destination rectangle.

If the BitmapData object and the object specified as the sourceBitmapData parameter are the same object, Flash Player uses a temporary copy of the object to perform the filter. For best performance, avoid this situation.

Parameters
sourceBitmapData:BitmapData — The input bitmap image to use. The source image can be a different BitmapData object or it can refer to the current BitmapData instance.
sourceRect:Rectangle — A rectangle that defines the area of the source image to use as input.
destPoint:Point — The point within the destination image (the current BitmapData instance) that corresponds to the upper-left corner of the source rectangle.
filter:BitmapFilter — The filter object that you use to perform the filtering operation. Each type of filter has certain requirements, as follows:
  • BlurFilter — This filter can use source and destination images that are either opaque or transparent. If the formats of the images do not match, the copy of the source image that is made during the filtering matches the format of the destination image.
  • BevelFilter, DropShadowFilter, GlowFilter, ChromeFilter — The destination image of these filters must be a transparent image. Calling DropShadowFilter or GlowFilter creates an image that contains the alpha channel data of the drop shadow or glow. It does not create the drop shadow onto the destination image. If you use any of these filters with an opaque destination image, an exception is thrown (ActionScript 3.0).
  • ConvolutionFilter — This filter can use source and destination images that are either opaque or transparent.
  • ColorMatrixFilter — This filter can use source and destination images that are either opaque or transparent.
  • DisplacementMapFilter — This filter can use source and destination images that are either opaque or transparent, but the source and destination image formats must be the same.

Throws
TypeError — The sourceBitmapData, sourceRect, destPoint or filter are null.
IllegalOperationError — The transparency of the BitmapData objects are not compatible with the filter operation.

See also

flash.filters.BevelFilter
flash.filters.BlurFilter
flash.filters.ColorMatrixFilter
flash.filters.ConvolutionFilter
flash.filters.DisplacementMapFilter
flash.filters.DropShadowFilter
flash.filters.GlowFilter
flash.display.DisplayObject.filters

Example
The following example shows how to apply a blur filter to a BitmapData instance:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Point;
import flash.geom.Rectangle;
import flash.filters.BlurFilter;

var bmd:BitmapData = new BitmapData(80, 30, false, 0xFFCC00);
var rect:Rectangle = new Rectangle(10, 10, 40, 10);
bmd.fillRect(rect, 0xFF0000);

var pt:Point = new Point(10, 10);
var filter:BlurFilter = new BlurFilter();
bmd.applyFilter(bmd, rect, pt, filter);

var bm:Bitmap = new Bitmap(bmd);
addChild(bm);

clone () method
public function clone():BitmapData

Returns a new BitmapData object that is a clone of the original instance with an exact copy of the contained bitmap.

Returns
BitmapData — A new BitmapData object that is identical to the original.

Example
The following example shows how to clone a BitmapData instance, and it shows that when you modify the cloned BitmapData instance, the original remains unmodified:

import flash.display.Bitmap;
import flash.display.BitmapData;

var bmd1:BitmapData = new BitmapData(100, 80, true, 0x00000000);
var bmd2:BitmapData = bmd1.clone();

bmd1.setPixel32(1, 1, 0xFFFFFFFF);

trace(bmd1.getPixel32(1, 1));        // 4294967295 == 0xFFFFFFFF
trace(bmd2.getPixel32(1, 1));        // 0

var bm1:Bitmap = new Bitmap(bmd1);
this.addChild(bm1);
var bm2:Bitmap = new Bitmap(bmd2);
this.addChild(bm2);
bm2.x = 110;

colorTransform () method
public function colorTransform(rect:Rectangle, colorTransform:ColorTransform):void

Adjusts the color values in a specified area of a bitmap image by using a ColorTransform object. If the rectangle matches the boundaries of the bitmap image, this method transforms the color values of the entire image.

Parameters
rect:Rectangle — A Rectangle object that defines the area of the image in which the ColorTransform object is applied.
colorTransform:ColorTransform — A ColorTransform object that describes the color transformation values to apply.

Throws
TypeError — The rect or colorTransform are null.

See also

flash.geom.ColorTransform
flash.geom.Rectangle

Example
The following example shows how to apply a color transform to the left half (rectangle) of a BitmapData object:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;
import flash.geom.ColorTransform;

var bmd:BitmapData = new BitmapData(80, 30, false, 0xFF0000);

var cTransform:ColorTransform = new ColorTransform();
cTransform.alphaMultiplier = 0.5
var rect:Rectangle = new Rectangle(0, 0, 40, 30);
bmd.colorTransform(rect, cTransform);

var bm:Bitmap = new Bitmap(bmd);
addChild(bm);

compare () method
public function compare(otherBitmapData:BitmapData):Object

Compares two BitmapData objects. If the two BitmapData objects have the same dimensions (width and height), the method returns a new BitmapData object, in which each pixel is the "difference" between the pixels in the two source objects:

  • If two pixels are equal, the difference pixel is 0x00000000.
  • If two pixels have different RGB values (ignoring the alpha value), the difference pixel is 0xFFRRGGBB where RR/GG/BB are the individual difference values between red, green, and blue channels. Alpha channel differences are ignored in this case.
  • If only the alpha channel value is different, the pixel value is 0xZZFFFFFF, where ZZ is the difference in the alpha value.

For example, consider the following two BitmapData objects:

  var bmd1:BitmapData = new BitmapData(50, 50, true, 0xFFFF0000);
  var bmd2:BitmapData = new BitmapData(50, 50, true, 0xCCFFAA00);
  var diffBmpData:BitmapData = bmd1.compare(bmd2);

Note: The colors used to fill the two BitmapData objects have slightly different RGB values (0xFF0000 and 0xFFAA00). The result of the compare() method is a new BitmapData object with each pixel showing the difference in the RGB values between the two bitmaps.

Consider the following two BitmapData objects, in which the RGB colors are the same, but the alpha values are different:

  var bmd1:BitmapData = new BitmapData(50, 50, true, 0xFFFFAA00);
  var bmd2:BitmapData = new BitmapData(50, 50, true, 0xCCFFAA00);
  var diffBmpData:BitmapData = bmd1.compare(bmd2);

The result of the compare() method is a new BitmapData object with each pixel showing the difference in the alpha values between the two bitmaps.

If the BitmapData objects are equivalent (with the same width, height, and identical pixel values), the method returns the number 0.

If the widths of the BitmapData objects are not equal, but the heights are the same, the method returns the number -3.

If the heights of the BitmapData objects are not equal, but the widths are the same, the method returns the number -4.

The following example compares two Bitmap objects with different widths (50 and 60):

  var bmd1:BitmapData = new BitmapData(100, 50, false, 0xFFFF0000);
  var bmd2:BitmapData = new BitmapData(100, 60, false, 0xFFFFAA00);
  trace(bmd1.compare(bmd2)); // -3
Parameters
otherBitmapData:BitmapData — The BitmapData object to compare with the source BitmapData object.

Returns
Object — If the two BitmapData objects have the same dimensions (width and height), the method returns a new BitmapData object that has the difference between the two objects (see the main discussion). If the BitmapData objects are equivalent, the method returns the number 0. If the widths of the BitmapData objects are not equal, the method returns the number -3. If the heights of the BitmapData objects are not equal, the method returns the number -4.

Throws
TypeError — The otherBitmapData is null.

Example
The following example shows the value of a pixel in the BitmapData object that results from comparing two BitmapData objects of the same dimensions:

import flash.display.Bitmap;
import flash.display.BitmapData;

var bmd1:BitmapData = new BitmapData(50, 50, true, 0xFFFFAA00);
var bmd2:BitmapData = new BitmapData(50, 50, true, 0xCCFFAA00);
var diffBmpData:BitmapData = BitmapData(bmd1.compare(bmd2));
var diffValue:String = diffBmpData.getPixel32(1, 1).toString(16);
trace (diffValue); // 33ffffff

var bm1:Bitmap = new Bitmap(bmd1);
addChild(bm1);
var bm2:Bitmap = new Bitmap(bmd2);
addChild(bm2);
bm2.x = 60;

copyChannel () method
public function copyChannel(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, sourceChannel:uint, destChannel:uint):void

Transfers data from one channel of another BitmapData object or the current BitmapData object into a channel of the current BitmapData object. All of the data in the other channels in the destination BitmapData object are preserved.

The source channel value and destination channel value can be one of following values:

  • BitmapDataChannel.RED
  • BitmapDataChannel.GREEN
  • BitmapDataChannel.BLUE
  • BitmapDataChannel.ALPHA
Parameters
sourceBitmapData:BitmapData — The input bitmap image to use. The source image can be a different BitmapData object or it can refer to the current BitmapData object.
sourceRect:Rectangle — The source Rectangle object. To copy only channel data from a smaller area within the bitmap, specify a source rectangle that is smaller than the overall size of the BitmapData object.
destPoint:Point — The destination Point object that represents the upper-left corner of the rectangular area where the new channel data is placed. To copy only channel data from one area to a different area in the destination image, specify a point other than (0,0).
sourceChannel:uint — The source channel. Use a value from the BitmapDataChannel class (BitmapDataChannel.RED, BitmapDataChannel.BLUE, BitmapDataChannel.GREEN, BitmapDataChannel.ALPHA).
destChannel:uint — The destination channel. Use a value from the BitmapDataChannel class (BitmapDataChannel.RED, BitmapDataChannel.BLUE, BitmapDataChannel.GREEN, BitmapDataChannel.ALPHA).

Throws
TypeError — The sourceBitmapData, sourceRect or destPoint are null.

See also

flash.geom.Rectangle

Example
The following example shows how to copy the red channel in a BitmapData object to its own blue channel in a 20 x 20 pixel region:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;
import flash.geom.Point;

var bmd:BitmapData = new BitmapData(100, 80, false, 0x00FF0000);

var rect:Rectangle = new Rectangle(0, 0, 20, 20);
var pt:Point = new Point(10, 10);
bmd.copyChannel(bmd, rect, pt, BitmapDataChannel.RED, BitmapDataChannel.BLUE);

var bm:Bitmap = new Bitmap(bmd);
this.addChild(bm);

copyPixels () method
public function copyPixels(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, alphaBitmapData:BitmapData = null, alphaPoint:Point = null, mergeAlpha:Boolean = false):void

Provides a fast routine to perform pixel manipulation between images with no stretching, rotation, or color effects. This method copies a rectangular area of a source image to a rectangular area of the same size at the destination point of the destination BitmapData object.

If you include the alphaBitmap and alphaPoint parameters, you can use a secondary image as an alpha source for the source image. If the source image has alpha data, both sets of alpha data are used to composite pixels from the source image to the destination image. The alphaPoint parameter is the point in the alpha image that corresponds to the upper-left corner of the source rectangle. Any pixels outside the intersection of the source image and alpha image are not copied to the destination image.

The mergeAlpha property controls whether or not the alpha channel is used when a transparent image is copied onto another transparent image. To copy pixels (with no alpha used), set the mergeAlpha property to false, and all pixels are copied from source to destination. By default, the mergeAlpha property is true.

Parameters
sourceBitmapData:BitmapData — The input bitmap image from which to copy pixels. The source image can be a different BitmapData instance, or it can refer to the current BitmapData instance.
sourceRect:Rectangle — A rectangle that defines the area of the source image to use as input.
destPoint:Point — The destination point that represents the upper-left corner of the rectangular area where the new pixels are placed.
alphaBitmapData:BitmapData (default = null) — A secondary, alpha BitmapData object source.
alphaPoint:Point (default = null) — The point in the alpha BitmapData object source that corresponds to the upper-left corner of the sourceRect parameter.
mergeAlpha:Boolean (default = false) — To use the alpha channel, set the value to true. To copy pixels with no alpha channel, set the value to false.

Throws
TypeError — The sourceBitmapData, sourceRect, destPoint are null.

Example
The following example shows how to copy pixels from a 20 x 20 pixel region in one BitmapData object to another BitmapData object:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;
import flash.geom.Point;

var bmd1:BitmapData = new BitmapData(40, 40, false, 0x000000FF);
var bmd2:BitmapData = new BitmapData(80, 40, false, 0x0000CC44);

var rect:Rectangle = new Rectangle(0, 0, 20, 20);
var pt:Point = new Point(10, 10);
bmd2.copyPixels(bmd1, rect, pt);

var bm1:Bitmap = new Bitmap(bmd1);
this.addChild(bm1);
var bm2:Bitmap = new Bitmap(bmd2);
this.addChild(bm2);
bm2.x = 50;

dispose () method
public function dispose():void

Frees memory that is used to store the BitmapData object.

When the dispose() method is called on an image, the width and height of the image are set to 0. All subsequent calls to methods or properties of this BitmapData instance fail, and an exception is thrown.

Example
The following example shows the effect of calling a method of a BitmapData object after a call to the dispose() method (an exception is thrown):
import flash.display.BitmapData;

var myBitmapData:BitmapData = new BitmapData(100, 80, false, 0x000000FF);
trace(myBitmapData.getPixel(1, 1)); // 255 == 0xFF

myBitmapData.dispose();
try {
    trace(myBitmapData.getPixel(1, 1));
} catch (error:Error) {
    trace(error); // ArgumentError
}

draw () method
public function draw(source:IBitmapDrawable, matrix:Matrix = null, colorTransform:ColorTransform = null, blendMode:String = null, clipRect:Rectangle = null, smoothing:Boolean = false):void

Draws the source display object onto the bitmap image, using the Flash Player vector renderer. You can specify matrix, colorTransform, blendMode, and a destination clipRect parameter to control how the rendering performs. Optionally, you can specify whether the bitmap should be smoothed when scaled (this works only if the source object is a BitmapData object).

This method directly corresponds to how objects are drawn with the standard vector renderer for objects in the authoring tool interface.

The source display object does not use any of its applied transformations for this call. It is treated as it exists in the library or file, with no matrix transform, no color transform, and no blend mode. To draw a display object (such as a movie clip) by using its own transform properties, you can copy its transform property object to the transform property of the Bitmap object that uses the BitmapData object.

Security note: The source object and (in the case of a Sprite or MovieClip object) all of its child objects must come from the same domain as the caller, or must be in a SWF file that is accessible to the caller by having called the Security.allowDomain() method. If these conditions are not met, the draw() method does not draw anything.

Parameters
source:IBitmapDrawable — The display object or BitmapData object to draw to the BitmapData object. (The DisplayObject and BitmapData classes implement the IBitmapDrawable interface.)
matrix:Matrix (default = null) — A Matrix object used to scale, rotate, or translate the coordinates of the bitmap. If you do not want to apply a matrix transformation to the image, set this parameter to an identity matrix, created with the default new Matrix() constructor, or pass a null value.
colorTransform:ColorTransform (default = null) — A ColorTransform object that you use to adjust the color values of the bitmap. If no object is supplied, the bitmap image's colors are not transformed. If you must pass this parameter but you do not want to transform the image, set this parameter to a ColorTransform object created with the default new ColorTransform() constructor.
blendMode:String (default = null) — A string value, from the flash.display.BlendMode class, specifying the blend mode to be applied to the resulting bitmap.
clipRect:Rectangle (default = null) — A Rectangle object that defines the area of the source object to draw. If you do not supply this value, no clipping occurs and the entire source object is drawn.
smoothing:Boolean (default = false) — A Boolean value that determines whether a BitmapData object is smoothed when scaled.

Throws
ArgumentError — The source parameter is not a BitmapData or DisplayObject object.
SecurityError — The source object and (in the case of a Sprite or MovieClip object) all of its child objects do not come from the same domain as the caller, or are not in a SWF file that is accessible to the caller by having called the Security.allowDomain() method.
ArgumentError — The source is null or not a valid IBitmapDrawable object.

See also

flash.display.BlendMode
flash.geom.ColorTransform
flash.geom.Matrix

Example
The following example shows how to draw a TextField object to a BitmapData object:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.text.TextField;

var tf:TextField = new TextField();
tf.text = "bitmap text";

var myBitmapData:BitmapData = new BitmapData(80, 20);
myBitmapData.draw(tf);
var bmp:Bitmap = new Bitmap(myBitmapData);
this.addChild(bmp);

fillRect () method
public function fillRect(rect:Rectangle, color:uint):void

Fills a rectangular area of pixels with a specified ARGB color.

Parameters
rect:Rectangle — The rectangular area to fill.
color:uint — The ARGB color value that fills the area. ARGB colors are often specified in hexadecimal format; for example, 0xFF336699.

Throws
TypeError — The rect is null.

See also

flash.geom.Rectangle

Example
The following example shows how to fill a rectangular region of a BitmapData object with blue:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;

var myBitmapData:BitmapData = new BitmapData(40, 40, false, 0x0000FF00);

var rect:Rectangle = new Rectangle(0, 0, 20, 20);
myBitmapData.fillRect(rect, 0x0000FF);

var bm:Bitmap = new Bitmap(myBitmapData);
addChild(bm);

floodFill () method
public function floodFill(x:int, y:int, color:uint):void

Performs a flood fill operation on an image starting at an (x, y) coordinate and filling with a certain color. The floodFill() method is similar to the paint bucket tool in various paint programs. The color is an ARGB color that contains alpha information and color information.

Parameters
x:int — The x coordinate of the image.
y:int — The y coordinate of the image.
color:uint — The ARGB color to use as a fill.

Example
The following example shows how to fill a region of a BitmapData object — that is, the region surrounding the pixel defined by the point (10, 10) iin which all colors march the color at that point — with red

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;

var myBitmapData:BitmapData = new BitmapData(40, 40, false, 0x0000FF00);

var rect:Rectangle = new Rectangle(0, 0, 20, 20);
myBitmapData.fillRect(rect, 0x000000FF);
rect = new Rectangle(15, 15, 25, 25);
myBitmapData.fillRect(rect, 0x000000FF);

myBitmapData.floodFill(10, 10, 0x00FF0000);

var bm:Bitmap = new Bitmap(myBitmapData);
addChild(bm);

generateFilterRect () method
public function generateFilterRect(sourceRect:Rectangle, filter:BitmapFilter):Rectangle

Determines the destination rectangle that the applyFilter() method call affects, given a BitmapData object, a source rectangle, and a filter object.

For example, a blur filter normally affects an area larger than the size of the original image. A 100 x 200 pixel image that is being filtered by a default BlurFilter instance, where blurX = blurY = 4 generates a destination rectangle of (-2,-2,104,204). The generateFilterRect() method lets you find out the size of this destination rectangle in advance so that you can size the destination image appropriately before you perform a filter operation.

Some filters clip their destination rectangle based on the source image size. For example, an inner DropShadow does not generate a larger result than its source image. In this API, the BitmapData object is used as the source bounds and not the source rect parameter.

Parameters
sourceRect:Rectangle — A rectangle defining the area of the source image to use as input.
filter:BitmapFilter — A filter object that you use to calculate the destination rectangle.

Returns
Rectangle — A destination rectangle computed by using an image, the sourceRect parameter, and a filter.

Throws
TypeError — The sourceRect or filter are null.

Example
The following example shows how you can use the generateFilterRect() method to determine the rectangular area that the result of a blur filter will occupy. The results of the generateFilterRect() method are output by the trace() function:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Point;
import flash.geom.Rectangle;
import flash.filters.BlurFilter;

var bmd:BitmapData = new BitmapData(80, 30, false, 0xFFCC00);
var rect:Rectangle = new Rectangle(10, 10, 40, 10);
bmd.fillRect(rect, 0xFF0000);

var pt:Point = new Point(10, 10);
var filter:BlurFilter = new BlurFilter();

trace(bmd.generateFilterRect(rect, filter));
// (x=8, y=8, w=44, h=14)

bmd.applyFilter(bmd, rect, pt, filter);
var bm:Bitmap = new Bitmap(bmd);
addChild(bm);
Note that the generateFilterRect() method does not apply the filter. Call the applyFilter() method to apply the filter.

getColorBoundsRect () method
public function getColorBoundsRect(mask:uint, color:uint, findColor:Boolean = true):Rectangle

Determines a rectangular region that either fully encloses all pixels of a specified color within the bitmap image (if the findColor parameter is set to true) or fully encloses all pixels that do not include the specified color (if the findColor parameter is set to false).

For example, if you have a source image and you want to determine the rectangle of the image that contains a nonzero alpha channel, pass {mask: 0xFF000000, color: 0x00000000} as parameters. If the findColor parameter is set to true, the entire image is searched for the bounds of pixels for which (value & mask) == color (where value is the color value of the pixel). If the findColor parameter is set to false, the entire image is searched for the bounds of pixels for which (value & mask) != color (where value is the color value of the pixel). To determine white space around an image, pass {mask: 0xFFFFFFFF, color: 0xFFFFFFFF} to find the bounds of nonwhite pixels.

Parameters
mask:uint — A hexadecimal value, specifying the bits of the ARGB color to consider. The color value is combined with this hexadecimal value, by using the & (bitwise AND) operator.
color:uint — A hexadecimal value, specifying the ARGB color to match (if findColor is set to true) or not to match (if findColor is set to false).
findColor:Boolean (default = true) — If the value is set to true, returns the bounds of a color value in an image. If the value is set to false, returns the bounds of where this color doesn't exist in an image.

Returns
Rectangle — The region of the image that is the specified color.

Example
The following example creates a BitmapData object with red in the top half of its pixels. It then calls the getColorBoundsRect() method to determine the rectangle in which pixels are red (0xFF0000), and then it calls the same method to determine the rectangle in which pixels are not red (by setting the findColor parameter to false:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;

var bmd:BitmapData = new BitmapData(80, 40, false, 0xFFFFFF);
var rect:Rectangle = new Rectangle(0, 0, 80, 20);
bmd.fillRect(rect, 0xFF0000);

var mask:uint = 0xFFFFFF;
var color:uint = 0xFF0000;
var redBounds:Rectangle = bmd.getColorBoundsRect(mask, color, true);
trace(redBounds); // (x=0, y=0, w=80, h=20)

var notRedBounds:Rectangle = bmd.getColorBoundsRect(mask, color, false);
trace(notRedBounds); // (x=0, y=20, w=80, h=20)

var bm:Bitmap = new Bitmap(bmd);
addChild(bm);

getPixel () method
public function getPixel(x:int, y:int):uint

Returns an integer that represents an RGB pixel value from a BitmapData object at a specific point (x, y). The getPixel() method returns an unmultiplied pixel value. No alpha information is returned.

All pixels in a BitmapData object are stored as premultiplied color values. A premultiplied image pixel has the red, green, and blue color channel values already multiplied by the alpha data. For example, if the alpha value is 0, the values for the RGB channels are also 0, independent of their unmultiplied values. This loss of data can cause some problems when you perform operations. All BitmapData methods take and return unmultiplied values. The internal pixel representation is converted from premultiplied to unmultiplied before it is returned as a value. During a set operation, the pixel value is premultiplied before the raw image pixel is set.

Parameters
x:int — The x position of the pixel.
y:int — The y position of the pixel.

Returns
uint — A number that represents an RGB pixel value. If the (x, y) coordinates are outside the bounds of the image, the method returns 0. If the bitmap was created as an opaque bitmap and not a transparent bitmap, and the point specified is within the bounds of the image, the method returns an error code of -1.

See also

getPixel32()
setPixel()

Example
The following example creates a BitmapData object filled with red, then uses the getPixel() method to determine the color value in the upper-left pixel:
import flash.display.BitmapData;

var bmd:BitmapData = new BitmapData(80, 40, false, 0xFF0000);

var pixelValue:uint = bmd.getPixel(1, 1);
trace(pixelValue.toString(16)); // ff0000;

getPixel32 () method
public function getPixel32(x:int, y:int):uint

Returns an ARGB color value that contains alpha channel data and RGB data. This method is similar to the getPixel() method, which returns an RGB color without alpha channel data.

All pixels in a BitmapData object are stored as premultiplied color values. A premultiplied image pixel has the red, green, and blue color channel values already multiplied by the alpha data. For example, if the alpha value is 0, the values for the RGB channels are also 0, independent of their unmultiplied values. This loss of data can cause some problems when you perform operations. All BitmapData methods take and return unmultiplied values. The internal pixel representation is converted from premultiplied to unmultiplied before it is returned as a value. During a set operation, the pixel value is premultiplied before the raw image pixel is set.

Parameters
x:int — The x position of the pixel.
y:int — The y position of the pixel.

Returns
uint — A number representing an ARGB pixel value. If the (x, y) coordinates are outside the bounds of the image, 0 is returned.

See also

getPixel()
setPixel32()

Example
The following example creates a BitmapData object filled with a color, then uses the getPixel32() method to determine the color value in the upper-left pixel, and then determines the hexidecimal values for each color component (alpha, red, green, and blue):
import flash.display.BitmapData;

var bmd:BitmapData = new BitmapData(80, 40, true, 0xFF44AACC);

var pixelValue:uint = bmd.getPixel32(1, 1);
var alpha:uint = pixelValue >> 24 & 0xFF;
var red:uint = pixelValue >> 16 & 0xFF;
var green:uint = pixelValue >> 8 & 0xFF;
var blue:uint = pixelValue & 0xFF;

trace(alpha.toString(16)); // ff
trace(red.toString(16)); // 44
trace(green.toString(16)); // aa
trace(blue.toString(16)); // cc

getPixels () method
public function getPixels(rect:Rectangle):ByteArray

Generates a byte array from a rectangular region of pixel data. Writes an unsigned integer (a 32-bit unmultiplied pixel value) for each pixel into the byte array.

Parameters
rect:Rectangle — A rectangular area in the current BitmapData object.

Returns
ByteArray — A ByteArray representing the pixels in the given Rectangle.

Throws
TypeError — The rect is null.

See also

flash.utils.ByteArray

Example
The following example creates a BitmapData object filled with random noise pixels, then uses the getPixels() method to fill a ByteArray object with the pixel values of the BitmapData object
import flash.display.BitmapData;
import flash.geom.Rectangle;
import flash.utils.ByteArray;

var bmd:BitmapData = new BitmapData(80, 40, true);
var seed:int = int(Math.random() * int.MAX_VALUE);
bmd.noise(seed);

var bounds:Rectangle = new Rectangle(0, 0, bmd.width, bmd.height);
var pixels:ByteArray = bmd.getPixels(bounds);

hitTest () method
public function hitTest(firstPoint:Point, firstAlphaThreshold:uint, secondObject:Object, secondBitmapDataPoint:Point = null, secondAlphaThreshold:uint = 1):Boolean

Performs pixel-level hit detection between one bitmap image and a point, rectangle, or other bitmap image. No stretching, rotation, or other transformation of either object is considered when the hit test is performed.

If an image is an opaque image, it is considered a fully opaque rectangle for this method. Both images must be transparent images to perform pixel-level hit testing that considers transparency. When you are testing two transparent images, the alpha threshold parameters control what alpha channel values, from 0 to 255, are considered opaque.

Parameters
firstPoint:Point — A position of the upper-left corner of the BitmapData image in an arbitrary coordinate space. The same coordinate space is used in defining the secondBitmapPoint parameter.
firstAlphaThreshold:uint — The highest alpha channel value that is considered opaque for this hit test.
secondObject:Object — A Rectangle, Point, Bitmap, or BitmapData object.
secondBitmapDataPoint:Point (default = null) — A point that defines a pixel location in the second BitmapData object. Use this parameter only when the value of secondObject is a BitmapData object.
secondAlphaThreshold:uint (default = 1) — The highest alpha channel value that is considered opaque in the second BitmapData object. Use this parameter only when the value of secondObject is a BitmapData object and both BitmapData objects are transparent.

Returns
Boolean — A value of true if a hit occurs; otherwise, false.

Throws
ArgumentError — The secondObject parameter is not a Point, Rectangle, Bitmap, or BitmapData object.
TypeError — The firstPoint is null.

Example
The following example creates a BitmapData object that is only opaque in a rectangular region (20, 20, 40, 40) and calls the hitTest() method with a Point object as the secondObject. In the first call, the Point object defines the upper-left corner of the BitmapData object, which is not opaque, and in the second call, the Point object defines the center of the BitmapData object, which is opaque.
import flash.display.BitmapData;
import flash.geom.Rectangle;
import flash.geom.Point;

var bmd1:BitmapData = new BitmapData(80, 80, true, 0x00000000);
var rect:Rectangle = new Rectangle(20, 20, 40, 40);
bmd1.fillRect(rect, 0xFF0000FF);

var pt1:Point = new Point(1, 1);
trace(bmd1.hitTest(pt1, 0xFF, pt1)); // false
var pt2:Point = new Point(40, 40);
trace(bmd1.hitTest(pt1, 0xFF, pt2)); // true

lock () method
public function lock():void

Locks an image so that any objects that reference the BitmapData object, such as Bitmap objects, are not updated when this BitmapData object changes. To improve performance, use this method along with the unlock() method before and after numerous calls to the setPixel() or setPixel32() method.

See also

setPixel()
setPixel32()
unlock()

Example
The following example creates a BitmapData object based on the bitmapData property of a Bitmap object, picture. It then calls the lock() method before calling a complicated custom function, complexTransformation(), that modifies the BitmapData object. (The picture object and the complexTransformation() function are not defined in this example.) Even if the complexTransformation() function updates the bitmapData property of the picture object, changes are not reflected until the code calls the unlock() method on the bitmapData object:
import flash.display.BitmapData;

var bitmapData:BitmapData = picture.bitmapData;
bitmapData.lock();
bitmapData = complexTransformation(bitmapData);
bitmapData.unlock();
picture.bitmapData = bitmapData;

merge () method
public function merge(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, redMultiplier:uint, greenMultiplier:uint, blueMultiplier:uint, alphaMultiplier:uint):void

Performs per-channel blending from a source image to a destination image. The following formula is used for each channel:

new red dest = (red source * redMultiplier) + (red dest * (256 - redMultiplier) / 256;

The redMultiplier, greenMultiplier, blueMultiplier, and alphaMultiplier values are the multipliers used for each color channel. Their valid range is from 0 to 256.

Parameters
sourceBitmapData:BitmapData — The input bitmap image to use. The source image can be a different BitmapData object, or it can refer to the current BitmapData object.
sourceRect:Rectangle — A rectangle that defines the area of the source image to use as input.
destPoint:Point — The point within the destination image (the current BitmapData instance) that corresponds to the upper-left corner of the source rectangle.
redMultiplier:uint — A number by which to multiply the red channel value.
greenMultiplier:uint — A number by which to multiply the green channel value.
blueMultiplier:uint — A number by which to multiply the blue channel value.
alphaMultiplier:uint — A number by which to multiply the alpha transparency value.

Throws
TypeError — The sourceBitmapData, sourceRect or destPoint are null.

Example
The following example creates two BitmapData objects. Both are 100 x 80 pixels in size. The first is filled with green and the second is filled with red. The code calls the merge() method, merging the second BitmapData pixels into the first BitmapData object, but only on a specified rectangular area:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;
import flash.geom.Point;

var bmd1:BitmapData = new BitmapData(100, 80, true, 0xFF00FF00);
var bmd2:BitmapData = new BitmapData(100, 80, true, 0xFFFF0000);
var rect:Rectangle = new Rectangle(0, 0, 20, 20);
var pt:Point = new Point(20, 20);
var mult:uint = 0x80; // 50%
bmd1.merge(bmd2, rect, pt, mult, mult, mult, mult);

var bm1:Bitmap = new Bitmap(bmd1);
addChild(bm1);
var bm2:Bitmap = new Bitmap(bmd2);
addChild(bm2);
bm2.x = 110;

noise () method
public function noise(randomSeed:int, low:uint = 0, high:uint = 255, channelOptions:uint = 7, grayScale:Boolean = false):void

Fills an image with pixels representing random noise.

Parameters
randomSeed:int — The random seed number to use. If you keep all other parameters the same, you can generate different pseudo-random results by varying the random seed value. The noise function is a mapping function, not a true random-number generation function, so it creates the same results each time from the same random seed.
low:uint (default = 0) — The lowest value to generate for each channel (0 to 255).
high:uint (default = 255) — The highest value to generate for each channel (0 to 255).
channelOptions:uint (default = 7) — A number that can be a combination of any of the four color channel values (BitmapDataChannel.RED, BitmapDataChannel.BLUE, BitmapDataChannel.GREEN, and BitmapDataChannel.ALPHA). You can use the logical OR operator (|) to combine channel values.
grayScale:Boolean (default = false) — A Boolean value. If the value is true, a grayscale image is created by setting all of the color channels to the same value. The alpha channel selection is not affected by setting this parameter to true.

See also

flash.display.BitmapDataChannel.RED
flash.display.BitmapDataChannel.BLUE
flash.display.BitmapDataChannel.GREEN
flash.display.BitmapDataChannel.ALPHA

Example
The following example creates two BitmapData objects and calls the noise() method on both. However, the grayscale parameter is set to false for the call to the noise() method of the first object, and it is set to true for the call to the noise() method of the second object:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.display.BitmapDataChannel;

var bmd1:BitmapData = new BitmapData(80, 80);
var bmd2:BitmapData = new BitmapData(80, 80);

var seed:int = int(Math.random() * int.MAX_VALUE);
bmd1.noise(seed, 0, 0xFF, BitmapDataChannel.RED, false);
bmd2.noise(seed, 0, 0xFF, BitmapDataChannel.RED, true);

var bm1:Bitmap = new Bitmap(bmd1);
this.addChild(bm1);
var bm2:Bitmap = new Bitmap(bmd2);
this.addChild(bm2);
bm2.x = 90;

paletteMap () method
public function paletteMap(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, redArray:Array = null, greenArray:Array = null, blueArray:Array = null, alphaArray:Array = null):void

Remaps the color channel values in an image that has up to four arrays of color palette data, one for each channel.

Flash Player uses the following steps to generate the resulting image:

  1. After the red, green, blue, and alpha values are computed, they are added together using standard 32-bit-integer arithmetic.
  2. The red, green, blue, and alpha channel values of each pixel are extracted into separate 0 to 255 values. These values are used to look up new color values in the appropriate array: redArray, greenArray, blueArray, and alphaArray. Each of these four arrays should contain 256 values.
  3. After all four of the new channel values are retrieved, they are combined into a standard ARGB value that is applied to the pixel.

Cross-channel effects can be supported with this method. Each input array can contain full 32-bit values, and no shifting occurs when the values are added together. This routine does not support per-channel clamping.

If no array is specified for a channel, the color channel is copied from the source image to the destination image.

You can use this method for a variety of effects such as general palette mapping (taking one channel and converting it to a false color image). You can also use this method for a variety of advanced color manipulation algorithms, such as gamma, curves, levels, and quantizing.

Parameters
sourceBitmapData:BitmapData — The input bitmap image to use. The source image can be a different BitmapData object, or it can refer to the current BitmapData instance.
sourceRect:Rectangle — A rectangle that defines the area of the source image to use as input.
destPoint:Point — The point within the destination image (the current BitmapData object) that corresponds to the upper-left corner of the source rectangle.
redArray:Array (default = null) — If redArray is not null, red = redArray[source red value] else red = source rect value.
greenArray:Array (default = null) — If greenArray is not null, green = greenArray[source green value] else green = source green value.
blueArray:Array (default = null) — If blueArray is not null, blue = blueArray[source blue value] else blue = source blue value.
alphaArray:Array (default = null) — If alphaArray is not null, alpha = alphaArray[source alpha value] else alpha = source alpha value.

Throws
TypeError — The sourceBitmapData, sourceRect or destPoint are null.

Example
The following example creates a green BitmapData object with a red center square, and then uses the paletteMap() method to swap red with green in the bottom rectangular half of the BitmapData object:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;
import flash.geom.Point;

var myBitmapData:BitmapData = new BitmapData(80, 80, false, 0x00FF0000);
myBitmapData.fillRect(new Rectangle(20, 20, 40, 40), 0x0000FF00);

var redArray:Array = new Array(256);
var greenArray:Array = new Array(256);

for(var i:uint = 0; i < 255; i++) {
    redArray[i] = 0x00000000;
    greenArray[i] = 0x00000000;
}

redArray[0xFF] = 0x0000FF00;
greenArray[0xFF] = 0x00FF0000;

var bottomHalf:Rectangle = new Rectangle(0, 0, 100, 40);
var pt:Point = new Point(0, 0);
myBitmapData.paletteMap(myBitmapData, bottomHalf, pt, redArray, greenArray);

var bm1:Bitmap = new Bitmap(myBitmapData);
addChild(bm1);

perlinNoise () method
public function perlinNoise(baseX:Number, baseY:Number, numOctaves:uint, randomSeed:int, stitch:Boolean, fractalNoise:Boolean, channelOptions:uint = 7, grayScale:Boolean = false, offsets:Array = null):void

Generates a Perlin noise image.

The Perlin noise generation algorithm interpolates and combines individual random noise functions (called octaves) into a single function that generates more natural-seeming random noise. Like musical octaves, each octave function is twice the frequency of the one before it. Perlin noise has been described as a "fractal sum of noise" because it combines multiple sets of noise data with different levels of detail.

You can use Perlin noise functions to simulate natural phenomena and landscapes, such as wood grain, clouds, and mountain ranges. In most cases, the output of a Perlin noise function is not displayed directly but is used to enhance other images and give them pseudo-random variations.

Simple digital random noise functions often produce images with harsh, contrasting points. This kind of harsh contrast is not often found in nature. The Perlin noise algorithm blends multiple noise functions that operate at different levels of detail. This algorithm results in smaller variations among neighboring pixel values.

Note: The Perlin noise algorithm is named for Ken Perlin, who developed it after generating computer graphics for the 1982 film Tron. Perlin received an Academy Award for Technical Achievement for the Perlin noise function in 1997.

Parameters
baseX:Number — Frequency to use in the x direction. For example, to generate a noise that is sized for a 64 x 128 image, pass 64 for the baseX value.
baseY:Number — Frequency to use in the y direction. For example, to generate a noise that is sized for a 64 x 128 image, pass 128 for the baseY value.
numOctaves:uint — Number of octaves or individual noise functions to combine to create this noise. Larger numbers of octaves create images with greater detail. Larger numbers of octaves also require more processing time.
randomSeed:int — The random seed number to use. If you keep all other parameters the same, you can generate different pseudo-random results by varying the random seed value. The Perlin noise function is a mapping function, not a true random-number generation function, so it creates the same results each time from the same random seed.
stitch:Boolean — A Boolean value. If the value is true, the method attempts to smooth the transition edges of the image to create seamless textures for tiling as a bitmap fill.
fractalNoise:Boolean — A Boolean value. If the value is true, the method generates fractal noise; otherwise, it generates turbulence. An image with turbulence has visible discontinuities in the gradient that can make it better approximate sharper visual effects like flames and ocean waves.
channelOptions:uint (default = 7) — A number that can be a combination of any of the four color channel values (BitmapDataChannel.RED, BitmapDataChannel.BLUE, BitmapDataChannel.GREEN, and BitmapDataChannel.ALPHA). You can use the logical OR operator (|) to combine channel values.
grayScale:Boolean (default = false) — A Boolean value. If the value is true, a grayscale image is created by setting each of the red, green, and blue color channels to identical values. The alpha channel value is not affected if this value is set to true.
offsets:Array (default = null) — An array of points that correspond to x and y offsets for each octave. By manipulating the offset values you can smoothly scroll the layers of a perlinNoise image. Each point in the offset array affects a specific octave noise function.

Example
The following example creates a 200 x 200 pixel BitmapData object that calls the perlinNoise() method to generate a red and blue watercolor effect:

import flash.display.Bitmap;
import flash.display.BitmapData;

var bmd:BitmapData = new BitmapData(200, 200, false, 0x00CCCCCC);

var seed:Number = Math.floor(Math.random() * 10);
var channels:uint = BitmapDataChannel.RED | BitmapDataChannel.BLUE;
bmd.perlinNoise(100, 80, 6, seed, false, true, channels, false, null);

var bm:Bitmap = new Bitmap(bmd);
addChild(bm);

pixelDissolve () method
public function pixelDissolve(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, randomSeed:int = 0, numPixels:int = 0, fillColor:uint = 0):int

Performs a pixel dissolve either from a source image to a destination image or by using the same image. Flash Player uses a randomSeed value to generate a random pixel dissolve. The return value of the function must be passed in on subsequent calls to continue the pixel dissolve until it is finished.

If the source image does not equal the destination image, pixels are copied from the source to the destination by using all of the properties. This process allows dissolving from a blank image into a fully populated image.

If the source and destination images are equal, pixels are filled with the color parameter. This process allows dissolving away from a fully populated image. In this mode, the destination point parameter is ignored.

Parameters
sourceBitmapData:BitmapData — The input bitmap image to use. The source image can be a different BitmapData object, or it can refer to the current BitmapData instance.
sourceRect:Rectangle — A rectangle that defines the area of the source image to use as input.
destPoint:Point — The point within the destination image (the current BitmapData instance) that corresponds to the upper-left corner of the source rectangle.
randomSeed:int (default = 0) — The random seed to use to start the pixel dissolve.
numPixels:int (default = 0) — The default is 1/30 of the source area (width x height).
fillColor:uint (default = 0) — An ARGB color value that you use to fill pixels whose source value equals its destination value.

Returns
int — The new random seed value to use for subsequent calls.

Throws
TypeError — The sourceBitmapData, sourceRect or destPoint are null.
TypeError — The numPixels value is negative

Example
The following example uses the pixelDissolve() method to convert a grey BitmapData object to a red one by dissolving 40 pixels at a time until all pixels have changed colors:
import flash.display.BitmapData;
import flash.display.Bitmap;
import flash.geom.Point;
import flash.geom.Rectangle;
import flash.utils.Timer;
import flash.events.TimerEvent;

var bmd:BitmapData = new BitmapData(100, 80, false, 0x00CCCCCC);
var bitmap:Bitmap = new Bitmap(bmd);
addChild(bitmap);

var tim:Timer = new Timer(20);
tim.start();
tim.addEventListener(TimerEvent.TIMER, timerHandler);

function timerHandler(event:TimerEvent):void {
    var randomNum:Number = Math.floor(Math.random() * int.MAX_VALUE);
    dissolve(randomNum);
}

function dissolve(randomNum:Number):void {
    var rect:Rectangle = bmd.rect;
    var pt:Point = new Point(0, 0);
    var numberOfPixels:uint = 100;
    var red:uint = 0x00FF0000;
    bmd.pixelDissolve(bmd, rect, pt, randomNum, numberOfPixels, red);
    var grayRegion:Rectangle = bmd.getColorBoundsRect(0xFFFFFFFF, 0x00CCCCCC, true);
    if(grayRegion.width == 0 && grayRegion.height == 0 ) {
        tim.stop();
    }
}

scroll () method
public function scroll(x:int, y:int):void

Scrolls an image by a certain (x, y) pixel amount. Edge regions outside the scrolling area are left unchanged.

Parameters
x:int — The amount by which to scroll horizontally.
y:int — The amount by which to scroll vertically.

Example
The following example shows the effect of scrolling a Bitmap data object 40 pixels to the right:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.geom.Rectangle;

var bmd:BitmapData = new BitmapData(80, 80, true, 0xFFCCCCCC);
var rect:Rectangle = new Rectangle(0, 0, 40, 40);
bmd.fillRect(rect, 0xFFFF0000);

var bm:Bitmap = new Bitmap(bmd);
addChild(bm);

trace (bmd.getPixel32(50, 20).toString(16)); // ffcccccccc

bmd.scroll(30, 0);

trace (bmd.getPixel32(50, 20).toString(16)); // ffff0000

setPixel () method
public function setPixel(x:int, y:int, color:uint):void

Sets a single pixel of a BitmapData object. The current alpha channel value of the image pixel is preserved during this operation. The value of the RGB color parameter is treated as an unmultiplied color value.

Note: To increase performance, when you use the setPixel() or setPixel32() method repeatedly, call the lock() method before you call the setPixel() or setPixel32() method, and then call the unlock() method when you have made all pixel changes. This process prevents objects that reference this BitmapData instance from updating until you finish making the pixel changes.

Parameters
x:int — The x position of the pixel whose value changes.
y:int — The y position of the pixel whose value changes.
color:uint — The resulting RGB color for the pixel.

See also

getPixel()
setPixel32()
lock()
unlock()

Example
The following example uses the setPixel() method to draw a red line in a BitmapData object:

import flash.display.Bitmap;
import flash.display.BitmapData;

var bmd:BitmapData = new BitmapData(80, 80, false, 0xCCCCCC);

for (var i:uint = 0; i < 80; i++) {
    var red:uint = 0xFF0000;
    bmd.setPixel(i, 40, red);
}

var bm:Bitmap = new Bitmap(bmd);
addChild(bm);

setPixel32 () method
public function setPixel32(x:int, y:int, color:uint):void

Sets the color and alpha transparency values of a single pixel of a BitmapData object. This method is similar to the setPixel() method; the main difference is that the setPixel32() method takes an ARGB color value that contains alpha channel information.

All pixels in a BitmapData object are stored as premultiplied color values. A premultiplied image pixel has the red, green, and blue color channel values already multiplied by the alpha data. For example, if the alpha value is 0, the values for the RGB channels are also 0, independent of their unmultiplied values. This loss of data can cause some problems when you perform operations. All BitmapData methods take and return unmultiplied values. The internal pixel representation is converted from premultiplied to unmultiplied before it is returned as a value. During a set operation, the pixel value is premultiplied before the raw image pixel is set.

Note: To increase performance, when you use the setPixel() or setPixel32() method repeatedly, call the lock() method before you call the setPixel() or setPixel32() method, and then call the unlock() method when you have made all pixel changes. This process prevents objects that reference this BitmapData instance from updating until you finish making the pixel changes.

Parameters
x:int — The x position of the pixel whose value changes.
y:int — The y position of the pixel whose value changes.
color:uint — The resulting ARGB color for the pixel. If the bitmap is opaque (not transparent), the alpha transparency portion of this color value is ignored.

See also

setPixel()
getPixel32()
lock()
unlock()

Example
The following example uses the setPixel32() method to draw a transparent (alpha == 0x60) red line in a BitmapData object:

import flash.display.Bitmap;
import flash.display.BitmapData;

var bmd:BitmapData = new BitmapData(80, 80, true, 0xFFCCCCCC);

for (var i:uint = 0; i < 80; i++) {
    var red:uint = 0x60FF0000;
    bmd.setPixel32(i, 40, red);
}

var bm:Bitmap = new Bitmap(bmd);
addChild(bm);

setPixels () method
public function setPixels(rect:Rectangle, inputByteArray:ByteArray):void

Converts a byte array into a rectangular region of pixel data. For each pixel, the ByteArray.readUnsignedInt() method is called and the return value is written into the pixel. If the byte array ends before the full rectangle is written, the function returns. The data in the byte array is expected to be 32-bit ARGB pixel values. No seeking is performed on the byte array before or after the pixels are read.

Parameters
rect:Rectangle — Specifies the rectangular region of the BitmapData object.
inputByteArray:ByteArray — A ByteArray object that consists of 32-bit unmultiplied pixel values to be used in the rectangular region.

Throws
EOFError — The inputByteArray object does not include enough data to fill the area of the rect rectangle. The method fills as many pixels as possible before throwing the exception.
TypeError — The rect or inputByteArray are null.

See also

flash.utils.ByteArray.readUnsignedInt()

Example
The following example uses the getPixels() and setPixels() methods to copy pixels from one BitmapData object to another:

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.utils.ByteArray;
import flash.geom.Rectangle;

var bmd1:BitmapData = new BitmapData(100, 100, true, 0xFFCCCCCC);
var bmd2:BitmapData = new BitmapData(100, 100, true, 0xFFFF0000);

var rect:Rectangle = new Rectangle(0, 0, 100, 100);
var bytes:ByteArray = bmd1.getPixels(rect);

bytes.position = 0;
bmd2.setPixels(rect, bytes);

var bm1:Bitmap = new Bitmap(bmd1);
addChild(bm1);
var bm2:Bitmap = new Bitmap(bmd2);
addChild(bm2);
bm2.x = 110;

threshold () method
public function threshold(sourceBitmapData:BitmapData, sourceRect:Rectangle, destPoint:Point, operation:String, threshold:uint, color:uint = 0, mask:uint = 0xFFFFFFFF, copySource:Boolean = false):uint

Tests pixel values in an image against a specified threshold and sets pixels that pass the test to new color values. Using the threshold() method, you can isolate and replace color ranges in an image and perform other logical operations on image pixels.

The threshold() method's test logic is as follows:

  1. If ((pixelValue & mask) operation (threshold & mask)), then set the pixel to color;
  2. Otherwise, if copySource == true, then set the pixel to corresponding pixel value from sourceBitmap.

The operation parameter specifies the comparison operator to use for the threshold test. For example, by using "==" as the operation parameter, you can isolate a specific color value in an image. Or by using {operation: "<", mask: 0xFF000000, threshold: 0x7F000000, color: 0x00000000}, you can set all destination pixels to be fully transparent when the source image pixel's alpha is less than 0x7F. You can use this technique for animated transitions and other effects.

Parameters
sourceBitmapData:BitmapData — The input bitmap image to use. The source image can be a different BitmapData object or it can refer to the current BitmapData instance.
sourceRect:Rectangle — A rectangle that defines the area of the source image to use as input.
destPoint:Point — The point within the destination image (the current BitmapData instance) that corresponds to the upper-left corner of the source rectangle.
operation:String — One of the following comparison operators, passed as a String: "<", "<=", ">", ">=", "==", "!="
threshold:uint — The value that each pixel is tested against to see if it meets or exceeds the threshhold.
color:uint (default = 0) — The color value that a pixel is set to if the threshold test succeeds. The default value is 0x00000000.
mask:uint (default = 0xFFFFFFFF) — The mask to use to isolate a color component.
copySource:Boolean (default = false) — If the value is true, pixel values from the source image are copied to the destination when the threshold test fails. If the value is false, the source image is not copied when the threshold test fails.

Returns
uint — The number of pixels that were changed.

Throws
TypeError — The sourceBitmapData, sourceRect destPoint or operation are null.
ArgumentError — The operation string is not a valid operation

Example
The following example uses the perlinNoise() method to add a blue and red pattern to one BitmapData object, and then uses the threshold() method to copy those pixels from the first BitmapData object to a second one, replacing those pixels in which the red value is greater than 0x80 (50%) with a pixel set to transparent red (0x20FF0000):

import flash.display.Bitmap;
import flash.display.BitmapData;
import flash.display.BitmapDataChannel;
import flash.geom.Point;
import flash.geom.Rectangle;

var bmd1:BitmapData = new BitmapData(200, 200, true, 0xFFCCCCCC);

var seed:int = int(Math.random() * int.MAX_VALUE);
var channels:uint = BitmapDataChannel.RED | BitmapDataChannel.BLUE;
bmd1.perlinNoise(100, 80, 12, seed, false, true, channels, false, null);

var bitmap1:Bitmap = new Bitmap(bmd1);
addChild(bitmap1);

var bmd2:BitmapData = new BitmapData(200, 200, true, 0xFFCCCCCC);
var pt:Point = new Point(0, 0);
var rect:Rectangle = new Rectangle(0, 0, 200, 200);
var threshold:uint =  0x00800000;
var color:uint = 0x20FF0000;
var maskColor:uint = 0x00FF0000;
bmd2.threshold(bmd1, rect, pt, ">", threshold, color, maskColor, true);

var bitmap2:Bitmap = new Bitmap(bmd2);
bitmap2.x = bitmap1.x + bitmap1.width + 10;
addChild(bitmap2);

unlock () method
public function unlock(changeRect:Rectangle = null):void

Unlocks an image so that any objects that reference the BitmapData object, such as Bitmap objects, are updated when this BitmapData object changes. To improve performance, use this method along with the lock() method before and after numerous calls to the setPixel() or setPixel32() method.

Parameters
changeRect:Rectangle (default = null) — The area of the BitmapData object that has changed. If you do not specify a value for this parameter, the entire area of the BitmapData object is considered changed.

See also

lock()
setPixel()
setPixel32()

Example
The following example creates a BitmapData object based on the bitmapData property of a Bitmap object, picture. It then calls the lock() method before calling a complicated custom function, complexTransformation(), that modifies the BitmapData object. (The picture object and the complexTransformation() function are not defined in this example.) Even if the complexTransformation() function updates the bitmapData property of the picture object, changes are not reflected until the code calls the unlock() method on the bitmapData object:
import flash.display.BitmapData;

var bitmapData:BitmapData = picture.bitmapData;
bitmapData.lock();
bitmapData = complexTransformation(bitmapData);
bitmapData.unlock();
picture.bitmapData = bitmapData;

Examples

The following example uses the class BitmapDataExample to load the image Image.gif into a DisplayObject in the default location (0, 0). A copy of Image.gif is then placed to the right of the original, which has new colors applied to pixels that pass a test using the threshold() method. The task is accomplished using the following steps:
  1. A url property is created, which is the location and name of the image file
  2. The class constructor creates a Loader object, which then instantiates an event listener, which is dispatched when the completeHandler() method completes the image manipulation.
  3. The request URLRequest object is then passed to loader.load(), which loads the image into memory by using a display object.
  4. The image is then placed on the display list, which displays the image on screen at coordinates x = 0, y = 0.
  5. The completeHandler() method then does the following:
    • Creates a second Loader, along with a Bitmap object, which is initialized with the Loader object.
    • Creates a second Bitmap object, duplicate, which in turn calls the duplicateImage() method, which creates a duplicate of the original image.
    • Creates a BitmapData object that is assigned to the duplicate object's BitmapData object.
    • Creates a new Rectangle object initialized with the same coordinates, width, and height as the original image.
    • Creates a new Point object, which defaults to x = 0, y = 0.
    • Creates the following variables:
      • operation — Applies the new color when the threshold value is greater than or equal to the original.
      • threshold — The value against which each pixel is compared (in this example, light gray with an alpha of 0xCC).
      • color — The color that the pixels are set to that pass the threshold test, which is solid yellow in this case.
      • mask — The exact opposite of color (transparent blue).
      • copySource — Set to false, indicating the pixel values are not copied if the threshold value does not pass. This value has no meaning because the image is duplicated and only pixels that pass the threshold test are changed.
    • Calls the threshold() method using the preceding variables. The resulting threshold equation is as follows: if (current pixel Value & 0x000000FF) >= (0xCCCCCCCC & 0x000000FF) then set pixel to 0xFFFFFF00.

Notes:

  • You will need to compile the SWF file with Local Playback Security set to Access Local Files Only.
  • This example requires that a file named Image.gif be placed in the same directory as your SWF file.
  • It is recommended that you use an image of up to approximately 80 pixels in width.

package {
    import flash.display.Bitmap;
    import flash.display.BitmapData;
    import flash.display.Loader;
    import flash.display.Sprite;
    import flash.events.*;
    import flash.geom.Point;
    import flash.geom.Rectangle;
    import flash.net.URLRequest;

    public class BitmapDataExample extends Sprite {
        private var url:String = "Image.gif";
        private var size:uint = 80;

        public function BitmapDataExample() {
            configureAssets();
        }

        private function configureAssets():void {
            var loader:Loader = new Loader();
            loader.contentLoaderInfo.addEventListener(Event.COMPLETE, completeHandler);
            loader.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);

            var request:URLRequest = new URLRequest(url);
            loader.x = size * numChildren;
            loader.load(request);
            addChild(loader);
        }

        private function duplicateImage(original:Bitmap):Bitmap {
            var image:Bitmap = new Bitmap(original.bitmapData.clone());
            image.x = size * numChildren;
            addChild(image);
            return image;
        }

        private function completeHandler(event:Event):void {
            var loader:Loader = Loader(event.target.loader);
            var image:Bitmap = Bitmap(loader.content);

            var duplicate:Bitmap = duplicateImage(image);
            var bitmapData:BitmapData = duplicate.bitmapData;
            var sourceRect:Rectangle = new Rectangle(0, 0, bitmapData.width, bitmapData.height);
            var destPoint:Point = new Point();
            var operation:String = ">=";
            var threshold:uint = 0xCCCCCCCC;
            var color:uint = 0xFFFFFF00;
            var mask:uint = 0x000000FF;
            var copySource:Boolean = true;

            bitmapData.threshold(bitmapData,
                                 sourceRect,
                                 destPoint,
                                 operation,
                                 threshold,
                                 color,
                                 mask,
                                 copySource);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("Unable to load image: " + url);
        }
    }
}


flash.display.BitmapDataChannel (Flex™ 2 Language Reference)

Class BitmapDataChannel | Properties | Methods | Constants
Package | flash.display
Class | public final class BitmapDataChannel
Inheritance | BitmapDataChannel Inheritance Object

The BitmapDataChannel class is an enumeration of constant values that indicate which channel to use: red, blue, green, or alpha transparency.

When you call some methods, you can use the bitwise OR operator (|) to combine BitmapDataChannel constants to indicate multiple color channels.

The BitmapDataChannel constants are provided for use as values in the following:

  • The sourceChannel and destChannel parameters of the flash.display.BitmapData.copyChannel() method
  • The channelOptions parameter of the flash.display.BitmapData.noise() method
  • The flash.filters.DisplacementMapFilter.componentX and flash.filters.DisplacementMapFilter.componentY properties

See also

flash.display.BitmapData.copyChannel()
flash.display.BitmapData.noise()
flash.filters.DisplacementMapFilter.componentX
flash.filters.DisplacementMapFilter.componentY

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ALPHA : uint = 8 [static] The alpha channel. | BitmapDataChannel
 | BLUE : uint = 4 [static] The blue channel. | BitmapDataChannel
 | GREEN : uint = 2 [static] The green channel. | BitmapDataChannel
 | RED : uint = 1 [static] The red channel. | BitmapDataChannel
Constant detail
ALPHA constant
public static const ALPHA:uint = 8

The alpha channel.

BLUE constant
public static const BLUE:uint = 4

The blue channel.

GREEN constant
public static const GREEN:uint = 2

The green channel.

RED constant
public static const RED:uint = 1

The red channel.


flash.display.BlendMode (Flex™ 2 Language Reference)

Class BlendMode | Properties | Methods | Constants
Package | flash.display
Class | public final class BlendMode
Inheritance | BlendMode Inheritance Object

A class that provides constant values for visual blend mode effects. These constants are used in the following:
  • The blendMode property of the flash.display.DisplayObject class.
  • The blendMode parameter of the draw() method of the flash.display.BitmapData class

See also

flash.display.DisplayObject.blendMode
flash.display.BitmapData.draw()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ADD : String = "add" [static] Adds the values of the constituent colors of the display object to the colors of its background, applying a ceiling of 0xFF. | BlendMode
 | ALPHA : String = "alpha" [static] Applies the alpha value of each pixel of the display object to the background. | BlendMode
 | DARKEN : String = "darken" [static] Selects the darker of the constituent colors of the display object and the colors of the background (the colors with the smaller values). | BlendMode
 | DIFFERENCE : String = "difference" [static] Compares the constituent colors of the display object with the colors of its background, and subtracts the darker of the values of the two constituent colors from the lighter value. | BlendMode
 | ERASE : String = "erase" [static] Erases the background based on the alpha value of the display object. | BlendMode
 | HARDLIGHT : String = "hardlight" [static] Adjusts the color of each pixel based on the darkness of the display object. | BlendMode
 | INVERT : String = "invert" [static] Inverts the background. | BlendMode
 | LAYER : String = "layer" [static] Forces the creation of a transparency group for the display object. | BlendMode
 | LIGHTEN : String = "lighten" [static] Selects the lighter of the constituent colors of the display object and the colors of the background (the colors with the larger values). | BlendMode
 | MULTIPLY : String = "multiply" [static] Multiplies the values of the display object constituent colors by the constituent colors of the background color, and normalizes by dividing by 0xFF, resulting in darker colors. | BlendMode
 | NORMAL : String = "normal" [static] The display object appears in front of the background. | BlendMode
 | OVERLAY : String = "overlay" [static] Adjusts the color of each pixel based on the darkness of the background. | BlendMode
 | SCREEN : String = "screen" [static] Multiplies the complement (inverse) of the display object color by the complement of the background color, resulting in a bleaching effect. | BlendMode
 | SUBTRACT : String = "subtract" [static] Subtracts the values of the constituent colors in the display object from the values of the background color, applying a floor of 0. | BlendMode
Constant detail
ADD constant
public static const ADD:String = "add"

Adds the values of the constituent colors of the display object to the colors of its background, applying a ceiling of 0xFF. This setting is commonly used for animating a lightening dissolve between two objects.

For example, if the display object has a pixel with an RGB value of 0xAAA633, and the background pixel has an RGB value of 0xDD2200, the resulting RGB value for the displayed pixel is 0xFFC833 (because 0xAA + 0xDD > 0xFF, 0xA6 + 0x22 = 0xC8, and 0x33 + 0x00 = 0x33).

ALPHA constant
public static const ALPHA:String = "alpha"

Applies the alpha value of each pixel of the display object to the background. This requires the blendMode property of the parent display object be set to flash.display.BlendMode.LAYER.

DARKEN constant
public static const DARKEN:String = "darken"

Selects the darker of the constituent colors of the display object and the colors of the background (the colors with the smaller values). This setting is commonly used for superimposing type.

For example, if the display object has a pixel with an RGB value of 0xFFCC33, and the background pixel has an RGB value of 0xDDF800, the resulting RGB value for the displayed pixel is 0xDDCC00 (because 0xFF > 0xDD, 0xCC < 0xF8, and 0x33 > 0x00 = 33).

DIFFERENCE constant
public static const DIFFERENCE:String = "difference"

Compares the constituent colors of the display object with the colors of its background, and subtracts the darker of the values of the two constituent colors from the lighter value. This setting is commonly used for more vibrant colors.

For example, if the display object has a pixel with an RGB value of 0xFFCC33, and the background pixel has an RGB value of 0xDDF800, the resulting RGB value for the displayed pixel is 0x222C33 (because 0xFF - 0xDD = 0x22, 0xF8 - 0xCC = 0x2C, and 0x33 - 0x00 = 0x33).

ERASE constant
public static const ERASE:String = "erase"

Erases the background based on the alpha value of the display object. This process requires that the blendMode property of the parent display object be set to flash.display.BlendMode.LAYER.

HARDLIGHT constant
public static const HARDLIGHT:String = "hardlight"

Adjusts the color of each pixel based on the darkness of the display object. If the display object is lighter than 50% gray, the display object and background colors are screened, which results in a lighter color. If the display object is darker than 50% gray, the colors are multiplied, which results in a darker color. This setting is commonly used for shading effects.

INVERT constant
public static const INVERT:String = "invert"

Inverts the background.

LAYER constant
public static const LAYER:String = "layer"

Forces the creation of a transparency group for the display object. This means that the display object is precomposed in a temporary buffer before it is processed further. The precomposition is done automatically if the display object is precached by means of bitmap caching or if the display object is a display object container that has at least one child object with a blendMode setting other than "normal".

LIGHTEN constant
public static const LIGHTEN:String = "lighten"

Selects the lighter of the constituent colors of the display object and the colors of the background (the colors with the larger values). This setting is commonly used for superimposing type.

For example, if the display object has a pixel with an RGB value of 0xFFCC33, and the background pixel has an RGB value of 0xDDF800, the resulting RGB value for the displayed pixel is 0xFFF833 (because 0xFF > 0xDD, 0xCC < 0xF8, and 0x33 > 0x00 = 33).

MULTIPLY constant
public static const MULTIPLY:String = "multiply"

Multiplies the values of the display object constituent colors by the constituent colors of the background color, and normalizes by dividing by 0xFF, resulting in darker colors. This setting is commonly used for shadows and depth effects.

For example, if a constituent color (such as red) of one pixel in the display object and the corresponding color of the pixel in the background both have the value 0x88, the multiplied result is 0x4840. Dividing by 0xFF yields a value of 0x48 for that constituent color, which is a darker shade than the color of the display object or the color of the background.

NORMAL constant
public static const NORMAL:String = "normal"

The display object appears in front of the background. Pixel values of the display object override the pixel values of the background. Where the display object is transparent, the background is visible.

OVERLAY constant
public static const OVERLAY:String = "overlay"

Adjusts the color of each pixel based on the darkness of the background. If the background is lighter than 50% gray, the display object and background colors are screened, which results in a lighter color. If the background is darker than 50% gray, the colors are multiplied, which results in a darker color. This setting is commonly used for shading effects.

SCREEN constant
public static const SCREEN:String = "screen"

Multiplies the complement (inverse) of the display object color by the complement of the background color, resulting in a bleaching effect. This setting is commonly used for highlights or to remove black areas of the display object.

SUBTRACT constant
public static const SUBTRACT:String = "subtract"

Subtracts the values of the constituent colors in the display object from the values of the background color, applying a floor of 0. This setting is commonly used for animating a darkening dissolve between two objects.

For example, if the display object has a pixel with an RGB value of 0xAA2233, and the background pixel has an RGB value of 0xDDA600, the resulting RGB value for the displayed pixel is 0x338400 (because 0xDD - 0xAA = 0x33, 0xA6 - 0x22 = 0x84, and 0x00 - 0x33 < 0x00).


flash.display.CapsStyle (Flex™ 2 Language Reference)

Class CapsStyle | Properties | Methods | Constants | Examples
Package | flash.display
Class | public final class CapsStyle
Inheritance | CapsStyle Inheritance Object

The CapsStyle class is an enumeration of constant values that specify the caps style to use in drawing lines. The constants are provided for use as values in the caps parameter of the flash.display.Graphics.lineStyle() method. You can specify the following three types of caps:

View the examples.

See also

flash.display.Graphics.lineStyle()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | NONE : String = "none" [static] Used to specify no caps in the caps parameter of the flash.display.Graphics.lineStyle() method. | CapsStyle
 | ROUND : String = "round" [static] Used to specify round caps in the caps parameter of the flash.display.Graphics.lineStyle() method. | CapsStyle
 | SQUARE : String = "square" [static] Used to specify square caps in the caps parameter of the flash.display.Graphics.lineStyle() method. | CapsStyle
Constant detail
NONE constant
public static const NONE:String = "none"

Used to specify no caps in the caps parameter of the flash.display.Graphics.lineStyle() method.

ROUND constant
public static const ROUND:String = "round"

Used to specify round caps in the caps parameter of the flash.display.Graphics.lineStyle() method.

SQUARE constant
public static const SQUARE:String = "square"

Used to specify square caps in the caps parameter of the flash.display.Graphics.lineStyle() method.

Examples

The following example uses the CapsStyleExample class to draw three parallel lines, each with a different line cap style.
  1. The properties of each line are set as follows:
    • The line length is set to 80 pixels.
    • The border color is set to orange.
    • The border size is set to 30 pixels.
    • The highlight color is set to gray.
    • The highlight size is set to 0 pixels.
    • The alpha is set to 1, making it solid.
    • The pixel hinting is set to false (strokes not hinted to full pixels).
    • The line scale mode is set to normal, which scales the thickness.
    • The joint style of the border caps are set to MITER.
    • The miter limit is set to 1, indicating that the miter is cut off close to the line.
  2. The class constructor creates three vertical lines, starting at x = 0, y = 0 by calling the drawLine() method three times using the three different line cap styles (none, round, and square). Each of the three calls to the drawLine() method uses the cap style and properties listed previously to draw a vertical line and associated line highlight. The calls first create a new child Shape object and then use methods of the Graphics class to set the line style and draw the lines and highlights. Each instance of child is added to the display list and drawn on the stage.
  3. The connected line segments are redrawn by using the refreshLayout() method at y = 80 pixels and starting at x = 80 pixels, with a 25-pixel separation between the line segments.
package {
    import flash.display.CapsStyle;
    import flash.display.DisplayObject;
    import flash.display.Graphics;
    import flash.display.JointStyle;
    import flash.display.LineScaleMode;
    import flash.display.Shape;
    import flash.display.Sprite;

    public class CapsStyleExample extends Sprite {
        private var lineLength:uint            = 80;
        private var borderColor:uint           = 0xFFCC00;
        private var borderSize:uint            = 30;
        private var highlightColor:uint        = 0x666666;
        private var highlightSize:uint         = 0;
        private var gutter:uint                = 25;
        private var borderAlpha:uint           = 1;
        private var borderPixelHinting:Boolean = false;
        private var borderScaleMode:String     = LineScaleMode.NORMAL;
        private var borderJointStyle:String    = JointStyle.MITER;
        private var borderMiterLimit:uint      = 1;

        public function CapsStyleExample() {
            drawLine(CapsStyle.NONE);
            drawLine(CapsStyle.ROUND);
            drawLine(CapsStyle.SQUARE);
            refreshLayout();
        }

        private function drawLine(capsStyle:String):void {
            var child:Shape = new Shape();
            child.graphics.lineStyle(borderSize,
                                     borderColor,
                                     borderAlpha,
                                     borderPixelHinting,
                                     borderScaleMode,
                                     capsStyle,
                                     borderJointStyle,
                                     borderMiterLimit);
            child.graphics.lineTo(0, 0);
            child.graphics.lineTo(0, lineLength);
            child.graphics.endFill();

            child.graphics.moveTo(0, 0);
            child.graphics.lineStyle(highlightSize, highlightColor);
            child.graphics.lineTo(0, 0);
            child.graphics.lineTo(0, lineLength);

            addChild(child);
        }

        private function refreshLayout():void {
            var ln:uint = numChildren;
            var child:DisplayObject;
            var lastChild:DisplayObject = getChildAt(0);
            lastChild.x = lineLength;
            lastChild.y = lineLength;
            for (var i:uint = 1; i < ln; i++) {
                child = getChildAt(i);
                child.x = gutter + lastChild.x + lastChild.width;
                child.y = lineLength;
                lastChild = child;
            }
        }
    }
}


flash.display.DisplayObject (Flex™ 2 Language Reference)

Class DisplayObject | Properties | Methods | Events | Examples
Package | flash.display
Class | public class DisplayObject
Inheritance | DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IBitmapDrawable
Subclasses | AVM1Movie, Bitmap, InteractiveObject, MorphShape, Shape, StaticText, Video

The DisplayObject class is the base class for all objects that can be placed on the display list. The display list manages all objects displayed in Flash Player. Use the DisplayObjectContainer class to arrange the display objects in the display list. DisplayObjectContainer objects can have child display objects, while other display objects, such as Shape and TextField objects, are "leaf" nodes that have only parents and siblings, no children.

The DisplayObject class supports basic functionality like the x and y position of an object, as well as more advanced properties of the object such as its transformation matrix.

DisplayObject is an abstract base class; therefore, you cannot call DisplayObject directly. Invoking new DisplayObject() throws an ArgumentError exception. All display objects inherit from the DisplayObject class. If you create a custom subclass of the DisplayObject class, it must extend a subclass of the DisplayObject class that has a valid new constructor.

Some properties previously used in the ActionScript 1.0 and 2.0 MovieClip, TextField, and Button classes (such as _alpha, _height, _name, _width, _x, _y, and others) have equivalents in the ActionScript 3.0 DisplayObject class that are renamed so that they no longer begin with the underscore (_) character.

For more information, see the "Display Programming" chapter of the Programming ActionScript 3.0 book.

View the examples.

See also

flash.display.DisplayObjectContainer
Understanding the display architecture
Working with display objects
Example: Applying a matrix transformation to a display object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
 | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
 | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | height : Number Indicates the height of the display object, in pixels. | DisplayObject
 | loaderInfo : LoaderInfo [read-only] Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
 | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | mouseX : Number [read-only] Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
 | mouseY : Number [read-only] Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
 | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | parent : DisplayObjectContainer [read-only] Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | root : DisplayObject [read-only] For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
 | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
 | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
 | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
 | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
 | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | stage : Stage [read-only] The Stage of the display object. | DisplayObject
 | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | visible : Boolean Whether or not the display object is visible. | DisplayObject
 | width : Number Indicates the width of the display object, in pixels. | DisplayObject
 | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
 | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
 | added | Dispatched when a display object is added to the display list. | DisplayObject
 | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
 | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
 | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
 | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
accessibilityProperties property
accessibilityProperties:AccessibilityProperties [read-write]

The current accessibility options for this display object. If you modify the accessibilityProperties property or any of the fields within accessibilityProperties, you must call the Accessibility.updateProperties() method to make your changes take effect.

Note: For an object created in the Flash authoring environment, the value of accessibilityProperties is prepopulated with any information you entered in the Accessibility panel for that object.

Implementation
    public function get accessibilityProperties():AccessibilityProperties
    public function set accessibilityProperties(value:AccessibilityProperties):void

See also

flash.accessibility.Accessibility.updateProperties()
flash.accessibility.AccessibilityProperties

Example
The following example shows how the to attach a simple AccessibilityProperties object to a TextField instance:

import flash.text.TextField;
import flash.accessibility.AccessibilityProperties;
import flash.accessibility.Accessibility;
import flash.system.Capabilities;

var tf:TextField = new TextField();
tf.text = "hello";

var accessProps:AccessibilityProperties = new AccessibilityProperties();
accessProps.name = "Greeting";

tf.accessibilityProperties = accessProps;

if (Capabilities.hasAccessibility) {
    Accessibility.updateProperties();
}

trace(tf.accessibilityProperties.name); // Greeting

alpha property
alpha:Number [read-write]

Indicates the alpha transparency value of the object specified. Valid values are 0 (fully transparent) to 1 (fully opaque). The default value is 1. Display objects with alpha set to 0 are active, even though they are invisible.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void

Example
The following code sets the alpha property of a sprite to 50% when the mouse rolls over the sprite:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFF0000);
circle.graphics.drawCircle(40, 40, 40);
addChild(circle);

circle.addEventListener(MouseEvent.MOUSE_OVER, dimObject);
circle.addEventListener(MouseEvent.MOUSE_OUT, restoreObject);

function dimObject(event:MouseEvent):void {
    event.target.alpha = 0.5;
}

function restoreObject(event:MouseEvent):void {
    event.target.alpha = 1.0;
}

blendMode property
blendMode:String [read-write]

A value from the BlendMode class that specifies which blend mode to use. A bitmap can be drawn internally in two ways. If you have a blend mode enabled or an external clipping mask, the bitmap is drawn by adding a bitmap-filled square shape to the vector render. If you attempt to set this property to an invalid value, Flash Player sets the value to BlendMode.NORMAL.

Flash Player applies the blendMode property on each pixel of the display object. Each pixel is composed of three constituent colors (red, green, and blue), and each constituent color has a value between 0x00 and 0xFF. Flash Player compares each constituent color of one pixel in the movie clip with the corresponding color of the pixel in the background. For example, if blendMode is set to BlendMode.LIGHTEN, Flash Player compares the red value of the display object with the red value of the background, and uses the lighter of the two as the value for the red component of the displayed color.

The following table describes the blendMode settings. The flash.display.BlendMode class defines string values you can use. The illustrations in the table show blendMode values applied to a circular display object (2) superimposed on another display object (1).

String (flash.display.BlendMode Constant) Value | Illustration | Description
BlendMode.NORMAL |  | The display object appears in front of the background. Pixel values of the display object override those of the background. Where the display object is transparent, the background is visible.
BlendMode.LAYER |  | Forces the creation of a transparency group for the display object. This means that the display object is pre-composed in a temporary buffer before it is processed further. This is done automatically if the display object is pre-cached using bitmap caching or if the display object is a display object container with at least one child object with a blendMode setting other than BlendMode.NORMAL.
BlendMode.MULTIPLY |  | Multiplies the values of the display object constituent colors by the colors of the background color, and then normalizes by dividing by 0xFF, resulting in darker colors. This setting is commonly used for shadows and depth effects. For example, if a constituent color (such as red) of one pixel in the display object and the corresponding color of the pixel in the background both have the value 0x88, the multiplied result is 0x4840. Dividing by 0xFF yields a value of 0x48 for that constituent color, which is a darker shade than the color of the display object or the color of the background.
BlendMode.SCREEN |  | Multiplies the complement (inverse) of the display object color by the complement of the background color, resulting in a bleaching effect. This setting is commonly used for highlights or to remove black areas of the display object.
BlendMode.LIGHTEN |  | Selects the lighter of the constituent colors of the display object and the color of the background (the colors with the larger values). This setting is commonly used for superimposing type. For example, if the display object has a pixel with an RGB value of 0xFFCC33, and the background pixel has an RGB value of 0xDDF800, the resulting RGB value for the displayed pixel is 0xFFF833 (because 0xFF > 0xDD, 0xCC < 0xF8, and 0x33 > 0x00 = 33).
BlendMode.DARKEN |  | Selects the darker of the constituent colors of the display object and the colors of the background (the colors with the smaller values). This setting is commonly used for superimposing type. For example, if the display object has a pixel with an RGB value of 0xFFCC33, and the background pixel has an RGB value of 0xDDF800, the resulting RGB value for the displayed pixel is 0xDDCC00 (because 0xFF > 0xDD, 0xCC < 0xF8, and 0x33 > 0x00 = 33).
BlendMode.DIFFERENCE |  | Compares the constituent colors of the display object with the colors of its background, and subtracts the darker of the values of the two constituent colors from the lighter value. This setting is commonly used for more vibrant colors. For example, if the display object has a pixel with an RGB value of 0xFFCC33, and the background pixel has an RGB value of 0xDDF800, the resulting RGB value for the displayed pixel is 0x222C33 (because 0xFF - 0xDD = 0x22, 0xF8 - 0xCC = 0x2C, and 0x33 - 0x00 = 0x33).
BlendMode.ADD |  | Adds the values of the constituent colors of the display object to the colors of its background, applying a ceiling of 0xFF. This setting is commonly used for animating a lightening dissolve between two objects. For example, if the display object has a pixel with an RGB value of 0xAAA633, and the background pixel has an RGB value of 0xDD2200, the resulting RGB value for the displayed pixel is 0xFFC833 (because 0xAA + 0xDD > 0xFF, 0xA6 + 0x22 = 0xC8, and 0x33 + 0x00 = 0x33).
BlendMode.SUBTRACT |  | Subtracts the values of the constituent colors in the display object from the values of the background color, applying a floor of 0. This setting is commonly used for animating a darkening dissolve between two objects. For example, if the display object has a pixel with an RGB value of 0xAA2233, and the background pixel has an RGB value of 0xDDA600, the resulting RGB value for the displayed pixel is 0x338400 (because 0xDD - 0xAA = 0x33, 0xA6 - 0x22 = 0x84, and 0x00 - 0x33 < 0x00).
BlendMode.INVERT |  | Inverts the background.
BlendMode.ALPHA |  | Applies the alpha value of each pixel of the display object to the background. This requires the blendMode setting of the parent display object to be set to BlendMode.LAYER. For example, in the illustration, the parent display object, which is a white background, has blendMode = BlendMode.LAYER.
BlendMode.ERASE |  | Erases the background based on the alpha value of the display object. This requires the blendMode of the parent display object to be set to BlendMode.LAYER. For example, in the illustration, the parent display object, which is a white background, has blendMode = BlendMode.LAYER.
BlendMode.OVERLAY |  | Adjusts the color of each pixel based on the darkness of the background. If the background is lighter than 50% gray, the display object and background colors are screened, which results in a lighter color. If the background is darker than 50% gray, the colors are multiplied, which results in a darker color. This setting is commonly used for shading effects.
BlendMode.HARDLIGHT |  | Adjusts the color of each pixel based on the darkness of the display object. If the display object is lighter than 50% gray, the display object and background colors are screened, which results in a lighter color. If the display object is darker than 50% gray, the colors are multiplied, which results in a darker color. This setting is commonly used for shading effects.
Implementation
    public function get blendMode():String
    public function set blendMode(value:String):void

See also

flash.display.BlendMode

Example
The following code creates two sprite objects, a square and a circle, and sets the blend mode of the circle (in the foreground) to BlendMode.SUBTRACT when the pointer rolls over the circle:
import flash.display.Sprite;
import flash.display.BlendMode;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFF88CC);
square.graphics.drawRect(0, 0, 80, 80);
addChild(square);

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xAA0022);
circle.graphics.drawCircle(40, 40, 40);
addChild(circle);

circle.addEventListener(MouseEvent.MOUSE_OVER, dimObject);
circle.addEventListener(MouseEvent.MOUSE_OUT, restoreObject);

function dimObject(event:MouseEvent):void {
    event.target.blendMode = BlendMode.SUBTRACT;
}

function restoreObject(event:MouseEvent):void {
    event.target.blendMode = BlendMode.NORMAL;
}

cacheAsBitmap property
cacheAsBitmap:Boolean [read-write]

If set to true, Flash Player caches an internal bitmap representation of the display object. This caching can increase performance for display objects that contain complex vector content.

All vector data for a display object that has a cached bitmap is drawn to the bitmap instead of the main display. The bitmap is then copied to the main display as unstretched, unrotated pixels snapped to the nearest pixel boundaries. Pixels are mapped 1 to 1 with the parent object. If the bounds of the bitmap change, the bitmap is recreated instead of being stretched.

No internal bitmap is created unless the cacheAsBitmap property is set to true.

After you set the cacheAsBitmap property to true, the rendering does not change, however the display object performs pixel snapping automatically. The animation speed can be significantly faster depending on the complexity of the vector content.

The cacheAsBitmap property is automatically set to true whenever you apply a filter to a display object (when its filter array is not empty), and if a display object has a filter applied to it, cacheAsBitmap is reported as true for that display object, even if you set the property to false. If you clear all filters for a display object, the cacheAsBitmap setting changes to what it was last set to.

A display object does not use a bitmap even if the cacheAsBitmap property is set to true and instead renders from vector data in the following cases:

  • The bitmap is too large: greater than 2880 pixels in either direction.
  • The bitmap fails to allocate (out of memory error).

The cacheAsBitmap property is best used with movie clips that have mostly static content and that do not scale and rotate frequently. With such movie clips, cacheAsBitmap can lead to performance increases when the movie clip is translated (when its x and y position is changed).

Implementation
    public function get cacheAsBitmap():Boolean
    public function set cacheAsBitmap(value:Boolean):void

See also

opaqueBackground

Example
The following example applies a drop shadow to a Shape instance. It then traces the value of the cacheAsBitmap property, which is set to true when the filter is applied:
import flash.display.Sprite;
import flash.filters.DropShadowFilter

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xAA0022);
circle.graphics.drawCircle(40, 40, 40);

addChild(circle);

trace(circle.cacheAsBitmap); // false

var filter:DropShadowFilter = new DropShadowFilter();
circle.filters = [filter];

trace(circle.cacheAsBitmap); // true

filters property
filters:Array [read-write]

An indexed array that contains each filter object currently associated with the display object. The flash.filters package contains several classes that define specific filters you can use.

Filters can be applied in the Flash authoring tool at design-time, or at runtime by using ActionScript code. To apply a filter by using ActionScript, you must make a temporary copy of the entire filters array, modify the temporary array, then assign the value of the temporary array back to the filters array. You cannot directly add a new filter object to the filters array. The following code has no effect on the target display object, named myDisplayObject:

     myDisplayObject.filters[0].push(myDropShadow);

To add a filter by using ActionScript, perform the following steps (assume that the target display object is named myDisplayObject):

  1. Create a new filter object by using the constructor method of your chosen filter class.
  2. Assign the value of the myDisplayObject.filters array to a temporary array, such as one named myFilters.
  3. Add the new filter object to the myFilters temporary array.
  4. Assign the value of the temporary array to the myDisplayObject.filters array.

If the filters array is undefined, you do not need to use a temporary array. Instead, you can directly assign an array literal that contains one or more filter objects that you create. The first example in the Examples section adds a drop shadow filter by using code that handles both defined and undefined filters arrays.

To modify an existing filter object, you must use the technique of modifying a copy of the filters array:

  1. Assign the value of the filters array to a temporary array, such as one named myFilters.
  2. Modify the property by using the temporary array, myFilters. For example, to set the quality property of the first filter in the array, you could use the following code: myFilters[0].quality = 1;
  3. Assign the value of the temporary array to the filters array.

At load time, if a display object has an associated filter, it is marked to cache itself as a transparent bitmap. From this point forward, as long as the display object has a valid filter list, the player caches the display object as a bitmap. This source bitmap is used as a source image for the filter effects. Each display object usually has two bitmaps: one with the original unfiltered source display object and another for the final image after filtering. The final image is used when rendering. As long as the display object does not change, the final image does not need updating.

The flash.filters package includes classes for filters. For example, to create a DropShadow filter, you would write:

     import flash.filters.DropShadowFilter
     var myFilter:DropShadowFilter = new DropShadowFilter (distance, angle, color, alpha, blurX, blurY, quality, inner, knockout)

You can use the is operator to determine the type of filter assigned to each index position in the filter array. For example, the following code shows how to determine the position of the first filter in the filters array that is a DropShadowFilter:

     import flash.text.TextField;
     import flash.filters.*;
     var tf:TextField = new TextField();
     var filter1:DropShadowFilter = new DropShadowFilter();
     var filter2:GradientGlowFilter = new GradientGlowFilter();
     tf.filters = [filter1, filter2];

     tf.text = "DropShadow index: " + filterPosition(tf, DropShadowFilter).toString(); // 0
     addChild(tf)

     function filterPosition(displayObject:DisplayObject, filterClass:Class):int {
         for (var i:uint = 0; i < displayObject.filters.length; i++) {
             if (displayObject.filters[i] is filterClass) {
                 return i;
             }
         }
         return -1;
     }
Implementation
    public function get filters():Array
    public function set filters(value:Array):void

See also

flash.filters package
height property
height:Number [read-write]

Indicates the height of the display object, in pixels.

Implementation
    public function get height():Number
    public function set height(value:Number):void

Example
The following code creates two TextField objects and adjusts the height property of each based on the textHeight property of each; it also positions the second text field by setting its y property:
import flash.text.TextField;

var tf1:TextField = new TextField();
tf1.text = "Text Field 1";
tf1.border = true;
tf1.wordWrap = true;
tf1.width = 40;
tf1.height = tf1.textHeight + 5;
addChild(tf1);

var tf2:TextField = new TextField();
tf2.text = "Text Field 2";
tf2.border = true;
tf2.wordWrap = true;
tf2.width = 40;
tf2.height = tf2.textHeight + 5;
tf2.y = tf1.y + tf1.height + 5;
addChild(tf2);

loaderInfo property
loaderInfo:LoaderInfo [read-only]

Returns a LoaderInfo object containing information about loading the file to which this display object belongs. The loaderInfo property is defined only for the root display object of a SWF file or for a loaded Bitmap (not for a Bitmap that is drawn with ActionScript). To find the loaderInfo object associated with the SWF file that contains a display object named myDisplayObject, use myDisplayObject.root.loaderInfo.

A large SWF file can monitor its download by calling this.root.loaderInfo.addEventListener(Event.COMPLETE, func).

Implementation
    public function get loaderInfo():LoaderInfo

See also

LoaderInfo class

Example
The following code assumes that this refers to a display object. The code outputs the URL of the root SWF file for the display object:
 trace (this.loaderInfo.url);

mask property
mask:DisplayObject [read-write]

The calling display object is masked by the specified mask object. To ensure that masking works when the Stage is scaled, the mask display object must be in an active part of the display list. The mask object itself is not drawn. Set mask to null to remove the mask.

To be able to scale a mask object, it must be on the display list. To be able to drag a mask Sprite object (by calling its startDrag() method), it must be on the display list. To call the startDrag() method for a mask sprite based on a mouseDown event being dispatched by the sprite, set the sprite's buttonMode property to true.

Implementation
    public function get mask():DisplayObject
    public function set mask(value:DisplayObject):void

Example
The following code creates a TextField object as well as a Sprite object that is set as a mask for the TextField object. When the user clicks the text field, the drag() event listener function calls the startDrag() method of the mask Sprite object:
import flash.text.TextField;
import flash.display.Sprite;
import flash.events.MouseEvent;

var tf:TextField = new TextField();
tf.text = "Lorem ipsum dolor sit amet, consectetur adipisicing elit, "
            + "sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. "
tf.selectable = false;
tf.wordWrap = true;
tf.width = 150;
addChild(tf);

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFF0000);
square.graphics.drawRect(0, 0, 40, 40);
addChild(square);

tf.mask = square;

tf.addEventListener(MouseEvent.MOUSE_DOWN, drag);
tf.addEventListener(MouseEvent.MOUSE_UP, noDrag);

function drag(event:MouseEvent):void {
    square.startDrag();
}
function noDrag(event:MouseEvent):void {
    square.stopDrag();
}

mouseX property
mouseX:Number [read-only]

Indicates the x coordinate of the mouse position, in pixels.

Implementation
    public function get mouseX():Number

Example
The following code creates a Sprite object and traces the mouseX and mouseY positions when the user clicks the sprite:
import flash.display.Sprite;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFF0000);
square.graphics.drawRect(0, 0, 200, 200);
addChild(square);

square.addEventListener(MouseEvent.CLICK, traceCoordinates);

function traceCoordinates(event:MouseEvent):void {
    trace(square.mouseX, square.mouseY);
}

mouseY property
mouseY:Number [read-only]

Indicates the y coordinate of the mouse position, in pixels.

Implementation
    public function get mouseY():Number

Example
The following code creates a Sprite object and traces the mouseX and mouseY positions when the user clicks the sprite:
import flash.display.Sprite;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFF0000);
square.graphics.drawRect(0, 0, 200, 200);
addChild(square);

square.addEventListener(MouseEvent.CLICK, traceCoordinates);

function traceCoordinates(event:MouseEvent):void {
    trace(square.mouseX, square.mouseY);
}

name property
name:String [read-write]

Indicates the instance name of the DisplayObject. The object can be identified in the child list of its parent display object container by calling the getChildByName() method of the display object container.

Implementation
    public function get name():String
    public function set name(value:String):void

Throws
IllegalOperationError — If you are attempting to set this property on an object that was placed on the timeline in the Flash authoring tool.

Example
The following code creates two Sprite object and traces the associated name property when the user clicks either of the objects:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFF0000);
circle1.graphics.drawCircle(40, 40, 40);
circle1.name = "circle1";
addChild(circle1);
circle1.addEventListener(MouseEvent.CLICK, traceName);

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0x0000FF);
circle2.graphics.drawCircle(140, 40, 40);
circle2.name = "circle2";
addChild(circle2);
circle2.addEventListener(MouseEvent.CLICK, traceName);

function traceName(event:MouseEvent):void {
    trace(event.target.name);
}

opaqueBackground property
opaqueBackground:Object [read-write]

Specifies whether the display object is opaque with a certain background color. A transparent bitmap contains alpha channel data and is drawn transparently. An opaque bitmap has no alpha channel (and renders faster than a transparent bitmap). If the bitmap is opaque, you specify its own background color to use.

If set to a number value, the surface is opaque (not transparent) with the RGB background color that the number specifies. If set to null (the default value), the display object has a transparent background.

The opaqueBackground property is intended mainly for use with the cacheAsBitmap property, for rendering optimization. For display objects in which the cacheAsBitmap property is set to true, setting opaqueBackground can improve rendering performance.

The opaque background region is not matched when calling the hitTestPoint() method with the shapeFlag parameter set to true.

The opaque background region does not respond to mouse events.

Implementation
    public function get opaqueBackground():Object
    public function set opaqueBackground(value:Object):void

See also

cacheAsBitmap
hitTestPoint()

Example
The following code creates a Shape object with a blue circle and sets its opaqueBackground property to red (0xFF0000):
import flash.display.Shape;

var circle:Shape = new Shape();
circle.graphics.beginFill(0x0000FF);
circle.graphics.drawCircle(40, 40, 40);
circle.opaqueBackground = 0xFF0000;
addChild(circle);

parent property
parent:DisplayObjectContainer [read-only]

Indicates the DisplayObjectContainer object that contains this display object. Use the parent property to specify a relative path to display objects that are above the current display object in the display list hierarchy.

You can use parent to move up multiple levels in the display list as in the following:

     this.parent.parent.alpha = 20;
Implementation
    public function get parent():DisplayObjectContainer

Throws
SecurityError — The parent display object belongs to a security sandbox to which you do not have access. You can avoid this situation by having the parent movie call the Security.allowDomain() method.

Example
The following code creates three Sprite objects and shows how the parent property reflects the display list hierarchy:

import flash.display.Sprite;

var sprite1:Sprite = new Sprite();
sprite1.name = "sprite1";
var sprite2:Sprite = new Sprite();
sprite2.name = "sprite2";
var sprite3:Sprite = new Sprite();
sprite3.name = "sprite3";

sprite1.addChild(sprite2);
sprite2.addChild(sprite3);

trace(sprite2.parent.name); // sprite1
trace(sprite3.parent.name); // sprite2
trace(sprite3.parent.parent.name); // sprite1

root property
root:DisplayObject [read-only]

For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. For a Bitmap object representing a loaded image file, the root property is the Bitmap object itself. For the instance of the main class of the first SWF file loaded, the root property is the display object itself. The root property of the Stage object is the Stage object itself. The root property is set to null for any display object that has not been added to the display list, unless it has been added to a display object container that is off the display list but that is a child of the top-most display object in a loaded SWF file.

For example, if you create a new Sprite object by calling the Sprite() constructor method, its root property is null until you add it to the display list (or to a display object container that is off the display list but that is a child of the top-most display object in a SWF file).

For a loaded SWF file, even though the Loader object used to load the file may not be on the display list, the top-most display object in the SWF file has its root property set to itself. The Loader object does not have its root property set until it is added as a child of a display object for which the root property is set.

Implementation
    public function get root():DisplayObject

Example
The following code shows the difference between the root property for the Stage object, for a display object (a Loader object) that is not loaded (both before and after it has been added to the display list), and for a loaded object (a loaded Bitmap object):
import flash.display.Loader;
import flash.net.URLRequest;
import flash.events.Event;

trace(stage.root); // [object Stage]

var ldr:Loader = new Loader();
trace (ldr.root); // null

addChild(ldr);
trace (ldr.root); // [object ...]

var urlReq:URLRequest = new URLRequest("example.jpg");
ldr.load(urlReq);

ldr.contentLoaderInfo.addEventListener(Event.COMPLETE, loaded);

function loaded(event:Event):void {
    trace(ldr.content.root); // [object Bitmap]
}

rotation property
rotation:Number [read-write]

Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. Values from 0 to 180 represent clockwise rotation; values from 0 to -180 represent counterclockwise rotation. Values outside this range are added to or subtracted from 360 to obtain a value within the range. For example, the statement my_video.rotation = 450 is the same as my_video.rotation = 90.

Implementation
    public function get rotation():Number
    public function set rotation(value:Number):void

Example
The following code creates a Sprite object and rotates the object when the user clicks it:

import flash.display.Sprite;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFFCC00);
square.graphics.drawRect(-50, -50, 100, 100);
square.x = 150;
square.y = 150;
addChild(square);

square.addEventListener(MouseEvent.CLICK, rotate);

function rotate(event:MouseEvent):void {
        square.rotation += 15;
}

scale9Grid property
scale9Grid:Rectangle [read-write]

The current scaling grid that is in effect. If set to null, the entire display object is scaled normally when any scale transformation is applied.

When you define the scale9Grid property, the display object is divided into a grid with nine regions based on the scale9Grid rectangle, which defines the center region of the grid. The eight other regions of the grid are the following areas:

  • The upper-left corner outside of the rectangle
  • The area above the rectangle
  • The upper-right corner outside of the rectangle
  • The area to the left of the rectangle
  • The area to the right of the rectangle
  • The lower-left corner outside of the rectangle
  • The area below the rectangle
  • The lower-right corner outside of the rectangle

You can think of the eight regions outside of the center (defined by the rectangle) as being like a picture frame that has special rules applied to it when scaled.

When the scale9Grid property is set and a display object is scaled, all text and gradients are scaled normally; however, for other types of objects the following rules apply:

  • Content in the center region is scaled normally.
  • Content in the corners is not scaled.
  • Content in the top and bottom regions is scaled horizontally only. Content in the left and right regions is scaled vertically only.
  • All fills (including bitmaps, video, and gradients) are stretched to fit their shapes.

If a display object is rotated, all subsequent scaling is normal (and the scale9Grid property is ignored).

For example, consider the following display object and a rectangle that is applied as the display object's scale9Grid:

The display object.
The red rectangle shows the scale9Grid.

When the display object is scaled or stretched, the objects within the rectangle scale normally, but the objects outside of the rectangle scale according to the scale9Grid rules:

Scaled to 75%:
Scaled to 50%:
Scaled to 25%:
Stretched horizontally 150%:

A common use for setting scale9Grid is to set up a display object to be used as a component, in which edge regions retain the same width when the component is scaled.

Implementation
    public function get scale9Grid():Rectangle
    public function set scale9Grid(value:Rectangle):void

Throws
ArgumentError — If you pass an invalid argument to the method.

See also

flash.geom.Rectangle

Example
The following code creates a Shape object with a rectangle drawn in its graphics property. The rectangle has a 20-pixel-thick line as the border and it is filled with a gradient. The timer event calls the scale() function, which scales the Shape object by adjusting the scaleX and scaleY properties. The scale9Grid applied to the Shape object prevents the rectangle's border line from scaling — only the gradient fill scales:

import flash.display.Shape;
import flash.display.GradientType;
import flash.display.SpreadMethod;
import flash.display.InterpolationMethod;
import flash.geom.Matrix;
import flash.geom.Rectangle;
import flash.utils.Timer;
import flash.events.TimerEvent;

var square:Shape = new Shape();
square.graphics.lineStyle(20, 0xFFCC00);
var gradientMatrix:Matrix = new Matrix();
gradientMatrix.createGradientBox(15, 15, Math.PI, 10, 10);
square.graphics.beginGradientFill(GradientType.RADIAL,
            [0xffff00, 0x0000ff],
            [100, 100],
            [0, 0xFF],
            gradientMatrix,
            SpreadMethod.REFLECT,
            InterpolationMethod.RGB,
            0.9);
square.graphics.drawRect(0, 0, 100, 100);

var grid:Rectangle = new Rectangle(20, 20, 60, 60);
square.scale9Grid = grid ;

addChild(square);

var tim:Timer = new Timer(100);
tim.start();
tim.addEventListener(TimerEvent.TIMER, scale);

var scaleFactor:Number = 1.01;

function scale(event:TimerEvent):void {
    square.scaleX *= scaleFactor;
    square.scaleY *= scaleFactor;

    if (square.scaleX > 2.0) {
        scaleFactor = 0.99;
    }
    if (square.scaleX < 1.0) {
        scaleFactor = 1.01;
    }
}

scaleX property
scaleX:Number [read-write]

Indicates the horizontal scale (percentage) of the object as applied from the registration point. The default registration point is (0,0). 1.0 equals 100% scale.

Scaling the local coordinate system affects the x and y property settings, which are defined in whole pixels.

Implementation
    public function get scaleX():Number
    public function set scaleX(value:Number):void

Example
The following code creates a Sprite object with a rectangle drawn in its graphics property. When the user clicks the sprite, it scales by 10%:

import flash.display.Sprite;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFFCC00);
square.graphics.drawRect(0, 0, 100, 100);
addChild(square);

square.addEventListener(MouseEvent.CLICK, scale);

function scale(event:MouseEvent):void {
    square.scaleX *= 1.10;
    square.scaleY *= 1.10;
}

scaleY property
scaleY:Number [read-write]

Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. The default registration point is (0,0). 1.0 is 100% scale.

Scaling the local coordinate system affects the x and y property settings, which are defined in whole pixels.

Implementation
    public function get scaleY():Number
    public function set scaleY(value:Number):void

Example
The following code creates a Sprite object with a rectangle drawn in its graphics property. When the user clicks the sprite, it scales by 10%:

import flash.display.Sprite;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFFCC00);
square.graphics.drawRect(0, 0, 100, 100);
addChild(square);

square.addEventListener(MouseEvent.CLICK, scale);

function scale(event:MouseEvent):void {
    square.scaleX *= 1.10;
    square.scaleY *= 1.10;
}

scrollRect property
scrollRect:Rectangle [read-write]

The scroll rectangle bounds of the display object. The display object is cropped to the size defined by the rectangle, and it scrolls within the rectangle when you change the x and y properties of the scrollRect object.

The properties of the scrollRect Rectangle object use the display object's coordinate space and are scaled just like the overall display object. The corner bounds of the cropped window on the scrolling display object are the origin of the display object (0,0) and the point defined by the width and height of the rectangle. They are not centered around the origin, but use the origin to define the upper-left corner of the area. A scrolled display object always scrolls in whole pixel increments.

You can scroll an object left and right by setting the x property of the scrollRect Rectangle object. You can scroll an object up and down by setting the y property of the scrollRect Rectangle object. If the display object is rotated 90° and you scroll it left and right, the display object actually scrolls up and down.

Implementation
    public function get scrollRect():Rectangle
    public function set scrollRect(value:Rectangle):void

See also

flash.geom.Rectangle

Example
The following example shows how the scrollRect property defines the scrolling area for a display object, circle. When you click the circle object, the clicked() event handler method adjusts the y property of the scrollRect property of the circle object, causing the object to scroll down:

import flash.display.Sprite;
import flash.geom.Rectangle;
import flash.events.MouseEvent;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFFCC00);
circle.graphics.drawCircle(200, 200, 200);
circle.scrollRect = new Rectangle(0, 0, 200, 200);
addChild(circle);

circle.addEventListener(MouseEvent.CLICK, clicked);

function clicked(event:MouseEvent):void {
    var rect:Rectangle = event.target.scrollRect;
    rect.y -= 5;
    event.target.scrollRect = rect;
}

stage property
stage:Stage [read-only]

The Stage of the display object. A Flash application has only one Stage object. For example, you can create and load multiple display objects into the display list, and the stage property of each display object refers to the same Stage object (even if the display object belongs to a loaded SWF file).

If a display object is not added to the display list, its stage property is set to null.

Implementation
    public function get stage():Stage

Example
The following code creates two TextField objects and uses the width property of the Stage object to position the text fields:

import flash.text.TextField;

var tf1:TextField = new TextField();
tf1.text = "Text Field 1";
tf1.border = true;
tf1.x = 10;
addChild(tf1);
tf1.width = tf1.stage.stageWidth / 2 - 10;

var tf2:TextField = new TextField();
tf2.text = "Text Field 2";
tf2.border = true;
tf2.x = tf1.x + tf1.width + 5;
addChild(tf2);
tf2.width = tf2.stage.stageWidth / 2 - 10;

trace(stage.stageWidth);

transform property
transform:Transform [read-write]

An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. The specific properties — matrix, colorTransform, and three read-only properties (concatenatedMatrix, concatenatedColorTransform, and pixelBounds) — are described in the entry for the Transform class.

Each of the transform object's properties is itself an object. This concept is important because the only way to set new values for the matrix or colorTransform objects is to create a new object and copy that object into the transform.matrix or transform.colorTransform property.

For example, to increase the tx value of a display object's matrix, you must make a copy of the entire matrix object, then copy the new object into the matrix property of the transform object:

    var myMatrix:Object = myDisplayObject.transform.matrix;
    myMatrix.tx += 10;
    myDisplayObject.transform.matrix = myMatrix;

You cannot directly set the tx property. The following code has no effect on myDisplayObject:

    myDisplayObject.transform.matrix.tx += 10;

You can also copy an entire transform object and assign it to another display object's transform property. For example, the following code copies the entire transform object from myOldDisplayObj to myNewDisplayObj:

myNewDisplayObj.transform = myOldDisplayObj.transform;

The resulting display object, myNewDisplayObj, now has the same values for its matrix, color transform, and pixel bounds as the old display object, myOldDisplayObj.

Implementation
    public function get transform():Transform
    public function set transform(value:Transform):void

See also

Transform class
Using Matrix objects

Example
The following code sets up a square Sprite object. When the user clicks the sprite, the transformer() method adjusts the colorTransform and matrix properties of the transform property of the sprite:

import flash.display.Sprite;
import flash.geom.ColorTransform;
import flash.geom.Matrix;
import flash.geom.Transform;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.lineStyle(20, 0xFF2200);
square.graphics.beginFill(0x0000DD);
square.graphics.drawRect(0, 0, 100, 100);
addChild(square);

var resultColorTransform:ColorTransform = new ColorTransform();
resultColorTransform.alphaMultiplier = 0.5;
resultColorTransform.redOffset = 155;
resultColorTransform.greenMultiplier = 0.5;

var skewMatrix:Matrix = new Matrix(1, 1, 0, 1);

square.addEventListener(MouseEvent.CLICK, transformer);

function transformer(event:MouseEvent):void {
    var transformation:Transform = square.transform;
    var tempMatrix:Matrix = square.transform.matrix;
    tempMatrix.concat(skewMatrix);
    square.transform.colorTransform = resultColorTransform;

    square.transform.matrix = tempMatrix;
}

visible property
visible:Boolean [read-write]

Whether or not the display object is visible. Display objects that are not visible are disabled. For example, if visible=false for an InteractiveObject instance, it cannot be clicked.

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void

Example
The following code uses a Timer object to call a function that periodically changes the visible property of a display object, resulting in a blinking effect:

import flash.text.TextField;
import flash.utils.Timer;
import flash.events.TimerEvent;

var tf:TextField = new TextField();
tf.text = "Hello.";
addChild(tf);

var tim:Timer = new Timer(250);
tim.start();
tim.addEventListener(TimerEvent.TIMER, blinker);

function blinker(event:TimerEvent):void {
    tf.visible = !tf.visible;
}

width property
width:Number [read-write]

Indicates the width of the display object, in pixels.

Implementation
    public function get width():Number
    public function set width(value:Number):void

Example
The following code sets up a square Sprite object. When the user clicks the sprite, the widen() method increases the width property of the sprite:

import flash.display.Sprite;
import flash.events.MouseEvent;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFF0000);
square.graphics.drawRect(0, 0, 100, 100);
addChild(square);

square.addEventListener(MouseEvent.CLICK, widen);

function widen(event:MouseEvent):void {
    square.width += 10;
}

x property
x:Number [read-write]

Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. If the object is inside a DisplayObjectContainer that has transformations, it is in the local coordinate system of the enclosing DisplayObjectContainer. Thus, for a DisplayObjectContainer rotated 90° counterclockwise, the DisplayObjectContainer's children inherit a coordinate system that is rotated 90° counterclockwise. The object's coordinates refer to the registration point position.

Implementation
    public function get x():Number
    public function set x(value:Number):void

Example
The following code sets up a circle Sprite object. A Timer object is used to change the x property of the sprite every 50 milliseconds:

import flash.display.Sprite;
import flash.utils.Timer;
import flash.events.TimerEvent;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFF0000);
circle.graphics.drawCircle(100, 100, 100);
addChild(circle);

var tim:Timer = new Timer(50);
tim.start();
tim.addEventListener(TimerEvent.TIMER, bounce);

var xInc:Number = 2;

function bounce(event:TimerEvent):void {
    circle.x += xInc;
    if (circle.x > circle.width) {
        xInc = -2;
    }
    if (circle.x < 0) {
        xInc = 2;
    }
}

y property
y:Number [read-write]

Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. If the object is inside a DisplayObjectContainer that has transformations, it is in the local coordinate system of the enclosing DisplayObjectContainer. Thus, for a DisplayObjectContainer rotated 90° counterclockwise, the DisplayObjectContainer's children inherit a coordinate system that is rotated 90° counterclockwise. The object's coordinates refer to the registration point position.

Implementation
    public function get y():Number
    public function set y(value:Number):void

Example
The following code creates two TextField objects and adjusts the height property of each based on the textHeight property of each; it also positions the second text field by setting its y property:
import flash.text.TextField;

var tf1:TextField = new TextField();
tf1.text = "Text Field 1";
tf1.border = true;
tf1.wordWrap = true;
tf1.width = 40;
tf1.height = tf1.textHeight + 5;
addChild(tf1);

var tf2:TextField = new TextField();
tf2.text = "Text Field 2";
tf2.border = true;
tf2.wordWrap = true;
tf2.width = 40;
tf2.height = tf2.textHeight + 5;
tf2.y = tf1.y + tf1.height + 5;
addChild(tf2);

Method detail
getBounds () method
public function getBounds(targetCoordinateSpace:DisplayObject):Rectangle

Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object. Consider the following code, which shows how the rectangle returned can vary depending on the targetCoordinateSpace parameter that you pass to the method:

     var container:Sprite = new Sprite();
     container.x = 100;
     container.y = 100;
     this.addChild(container);
     var contents:Shape = new Shape();
     contents.graphics.drawCircle(0,0,100);
     container.addChild(contents);
     trace(contents.getBounds(container));
      // (x=-100, y=-100, w=200, h=200)
     trace(contents.getBounds(this));
      // (x=0, y=0, w=200, h=200)

Note: Use the localToGlobal() and globalToLocal() methods to convert the display object's local coordinates to display coordinates, or display coordinates to local coordinates, respectively.

The getBounds() method is similar to the getRect() method; however, the Rectangle returned by the getBounds() method includes any strokes on shapes, whereas the Rectangle returned by the getRect() method does not. For an example, see the description of the getRect() method.

Parameters
targetCoordinateSpace:DisplayObject — The display object that defines the coordinate system to use.

Returns
Rectangle — The rectangle that defines the area of the display object relative to the targetCoordinateSpace object's coordinate system.

See also

getRect()
globalToLocal()
localToGlobal()
getRect () method
public function getRect(targetCoordinateSpace:DisplayObject):Rectangle

Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes. The values that the getRect() method returns are the same or smaller than those returned by the getBounds() method.

Note: Use localToGlobal() and globalToLocal() methods to convert the display object's local coordinates to Stage coordinates, or Stage coordinates to local coordinates, respectively.

Parameters
targetCoordinateSpace:DisplayObject — The display object that defines the coordinate system to use.

Returns
Rectangle — The rectangle that defines the area of the display object relative to the targetCoordinateSpace object's coordinate system.

See also

getBounds()

Example
The following example shows how the getBounds() method can return a larger rectangle than the getRect() method does, because of the additional area taken up by strokes. In this case, the triangle sprite includes extra strokes because of the width and jointStyle parameters of the lineStyle() method. The trace() output (in the last two lines) shows the differences between the getRect() and getBounds() rectangles:

import flash.display.CapsStyle;
import flash.display.JointStyle;
import flash.display.LineScaleMode;
import flash.display.Sprite;
import flash.geom.Rectangle;

var triangle:Sprite = new Sprite();
var color:uint = 0xFF0044;
var width:Number = 20;
var alpha:Number = 1.0;
var pixelHinting:Boolean = true;
var scaleMode:String = LineScaleMode.NORMAL;
var caps:String = CapsStyle.SQUARE;
var joints:String = JointStyle.MITER;
triangle.graphics.lineStyle(width, color, alpha, pixelHinting, scaleMode, caps, joints);

var triangleSide:Number = 100;
triangle.graphics.moveTo(0, 0);
triangle.graphics.lineTo(0, triangleSide);
triangle.graphics.lineTo(triangleSide, triangleSide);
triangle.graphics.lineTo(0, 0);

addChild(triangle);

trace(triangle.getBounds(this)); // (x=-10, y=-24.1, w=134.10000000000002, h=134.1)
trace(triangle.getRect(this));     // (x=0, y=0, w=100, h=100)

globalToLocal () method
public function globalToLocal(point:Point):Point

Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.

To use this method, first create an instance of the Point class. The x and y values that you assign represent global coordinates because they relate to the origin (0,0) of the main display area. Then pass the Point instance as the parameter to the globalToLocal() method. The method returns a new Point object with x and y values that relate to the origin of the display object instead of the origin of the Stage.

Parameters
point:Point — An object created with the Point class. The Point object specifies the x and y coordinates as properties.

Returns
Point — A Point object with coordinates relative to the display object.

See also

localToGlobal()
flash.geom.Point class

Example
The following code creates a Shape object and shows the result of calling the hitTestPoint() method, using different points as parameters. The globalToLocal() method converts the point from Stage coordinates to the coordinate space of the shape:

import flash.display.Shape;
import flash.geom.Point;

var circle:Shape = new Shape();
circle.graphics.beginFill(0x0000FF);
circle.graphics.drawCircle(40, 40, 40);
circle.x = 10;
addChild(circle);

var point1:Point = new Point(0, 0);
trace(circle.hitTestPoint(point1.x, point1.y, true)); // false
trace(circle.hitTestPoint(point1.x, point1.y, false)); // false
trace(circle.globalToLocal(point1)); // [x=-10, y=0]

var point2:Point = new Point(10, 1);
trace(circle.hitTestPoint(point2.x, point2.y, true)); // false
trace(circle.hitTestPoint(point2.x, point2.y, false)); // true
trace(circle.globalToLocal(point2)); // [x=0, y=1]

var point3:Point = new Point(30, 20);
trace(circle.hitTestPoint(point3.x, point3.y, true)); // true
trace(circle.hitTestPoint(point3.x, point3.y, false)); // true
trace(circle.globalToLocal(point3)); // [x=20, y=20]

hitTestObject () method
public function hitTestObject(obj:DisplayObject):Boolean

Evaluates the display object to see if it overlaps or intersects with the obj display object.

Parameters
obj:DisplayObject — The display object to test against.

Returns
Boolean — true if the display objects intersect; false if not.

Example
The following code creates three Shape objects and shows the result of calling the hitTestObject() method:

import flash.display.Shape;

var circle1:Shape = new Shape();
circle1.graphics.beginFill(0x0000FF);
circle1.graphics.drawCircle(40, 40, 40);
addChild(circle1);

var circle2:Shape = new Shape();
circle2.graphics.beginFill(0x00FF00);
circle2.graphics.drawCircle(40, 40, 40);
circle2.x = 50;
addChild(circle2);

var circle3:Shape = new Shape();
circle3.graphics.beginFill(0xFF0000);
circle3.graphics.drawCircle(40, 40, 40);
circle3.x = 100;
circle3.y = 67;
addChild(circle3);

trace(circle1.hitTestObject(circle2)); // true
trace(circle1.hitTestObject(circle3)); // true
trace(circle2.hitTestObject(circle3)); // true

hitTestPoint () method
public function hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean

Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters. The x and y parameters specify a point in the coordinate space of the Stage, not the display object container that contains the display object (unless that display object container is the Stage).

Parameters
x:Number — The x coordinate to test against this object.
y:Number — The y coordinate to test against this object.
shapeFlag:Boolean (default = false) — Whether to check against the actual pixels of the object (true) or the bounding box (false).

Returns
Boolean — true if the display object overlaps or intersects with the specified point; false otherwise.

See also

opaqueBackground

Example
The following code creates a Shape object and shows the result of calling the hitTestPoint() method, using different points as parameters. The globalToLocal() method converts the point from Stage coordinates to the coordinate space of the shape:

import flash.display.Shape;
import flash.geom.Point;

var circle:Shape = new Shape();
circle.graphics.beginFill(0x0000FF);
circle.graphics.drawCircle(40, 40, 40);
circle.x = 10;
addChild(circle);

var point1:Point = new Point(0, 0);
trace(circle.hitTestPoint(point1.x, point1.y, true)); // false
trace(circle.hitTestPoint(point1.x, point1.y, false)); // false
trace(circle.globalToLocal(point1)); // [x=-10, y=0]

var point2:Point = new Point(10, 1);
trace(circle.hitTestPoint(point2.x, point2.y, true)); // false
trace(circle.hitTestPoint(point2.x, point2.y, false)); // true
trace(circle.globalToLocal(point2)); // [x=0, y=1]

var point3:Point = new Point(30, 20);
trace(circle.hitTestPoint(point3.x, point3.y, true)); // true
trace(circle.hitTestPoint(point3.x, point3.y, false)); // true
trace(circle.globalToLocal(point3)); // [x=20, y=20]

localToGlobal () method
public function localToGlobal(point:Point):Point

Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.

This method allows you to convert any given x and y coordinates from values that are relative to the origin (0,0) of a specific display object (local coordinates) to values that are relative to the origin of the Stage (global coordinates).

To use this method, first create an instance of the Point class. The x and y values that you assign represent local coordinates because they relate to the origin of the display object.

You then pass the Point instance that you created as the parameter to the localToGlobal() method. The method returns a new Point object with x and y values that relate to the origin of the Stage instead of the origin of the display object.

Parameters
point:Point — The name or identifier of a point created with the Point class, specifying the x and y coordinates as properties.

Returns
Point — A Point object with coordinates relative to the Stage.

See also

globalToLocal()
flash.geom.Point class
Using Point objects
Flash Player Security

Example
The following code creates a Sprite object. The mouseX and mouseY properties of the sprite are in the coordinate space of the display object. This code uses the localToGlobal() method to translate these properties to the global (Stage) coordinates:

import flash.display.Sprite;
import flash.events.MouseEvent;
import flash.geom.Point;

var square:Sprite = new Sprite();
square.graphics.beginFill(0xFFCC00);
square.graphics.drawRect(0, 0, 100, 100);
square.x = 100;
square.y = 200;

addChild(square);

square.addEventListener(MouseEvent.CLICK, traceCoordinates)

function traceCoordinates(event:MouseEvent):void {
    var clickPoint:Point = new Point(square.mouseX, square.mouseY);
    trace("display object coordinates:", clickPoint);
    trace("stage coordinates:", square.localToGlobal(clickPoint));
}

Event detail
activate event
Event object type: flash.events.Event
Event.type property = flash.events.Event.ACTIVATE

Dispatched when Flash Player gains operating system focus and becomes active.

Defines the value of the type property of an activate event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the ACTIVATE event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
added event
Event object type: flash.events.Event
Event.type property = flash.events.Event.ADDED

Dispatched when a display object is added to the display list. The following methods trigger this event: DisplayObjectContainer.addChild(), DisplayObjectContainer.addChildAt().

Defines the value of the type property of an added event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The DisplayObject instance being added to the display list. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.DisplayObjectContainer.addChild()
flash.display.DisplayObjectContainer.addChildAt()
deactivate event
Event object type: flash.events.Event
Event.type property = flash.events.Event.DEACTIVATE

Dispatched when Flash Player loses operating system focus and is becoming inactive.

Defines the value of the type property of a deactivate event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the DEACTIVATE event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
enterFrame event
Event object type: flash.events.Event
Event.type property = flash.events.Event.ENTER_FRAME

Dispatched when the playhead is entering a new frame. If the playhead is not moving, or if there is only one frame, this event is dispatched continuously in conjunction with the frame rate. This event is dispatched simultaneously to all display objects listenting for this event.

Defines the value of the type property of an enterFrame event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the ENTER_FRAME event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
removed event
Event object type: flash.events.Event
Event.type property = flash.events.Event.REMOVED

Dispatched when a display object is about to be removed from the display list. Two methods of the DisplayObjectContainer class generate this event: removeChild() and removeChildAt().

The following methods of a DisplayObjectContainer object also generate this event if an object must be removed to make room for the new object: addChild(), addChildAt(), and setChildIndex().

Defines the value of the type property of a removed event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The DisplayObject instance to be removed from the display list. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
render event
Event object type: flash.events.Event
Event.type property = flash.events.Event.RENDER

Dispatched when the display list is about to be updated and rendered. This event provides the last opportunity for objects listening for this event to make changes before the display list is rendered. Flash Player renders the display list as the default behavior. You must call the invalidate() method of the Stage object each time you want Flash Player to send a render event. Render events are dispatched to an object only if there is mutual trust between it and the object that called Stage.invalidate().

Note: This event is not dispatched if the Flash Player window is not rendering. This is the case when the Flash Player window is either minimized or obscured.

Defines the value of the type property of a render event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; the default behavior cannot be canceled.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the RENDER event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
Examples

The following example uses the DisplayObjectExample class to draw an orange square in the corner of the Stage and then respond to events by displaying text information for each event. This task is accomplished by performing the following steps:
  1. Class properties are declared for the color and size of the square.
  2. The constructor calls the draw() method, which draws an orange square on the Stage at the default coordinates of x = 0, y = 0.
  3. The following event listener methods are attached to the square:
    • addedHandler() listens for added events, dispatched when the square is added to the display list.
    • enterFrameHandler() listens for enterFrame events, which have no real meaning in this example.
    • removedHandler() listens for removed events, dispatched when the square is removed from the display list, which happens when the square is clicked.
    • clickHandler() listens for click events, dispatched when the orange square is clicked.
    • renderHandler() listens for render events after the display list is updated.

package {
    import flash.display.Sprite;

    public class DisplayObjectExample extends Sprite {
        public function DisplayObjectExample() {
            var child:CustomDisplayObject = new CustomDisplayObject();
            addChild(child);
        }
    }
}

import flash.display.DisplayObject;
import flash.display.Sprite;
import flash.display.Stage;
import flash.display.StageAlign;
import flash.display.StageScaleMode;
import flash.events.*;

class CustomDisplayObject extends Sprite {
    private var bgColor:uint = 0xFFCC00;
    private var size:uint    = 80;

    public function CustomDisplayObject() {
        draw();
        addEventListener(Event.ADDED, addedHandler);
        addEventListener(Event.ENTER_FRAME, enterFrameHandler);
        addEventListener(Event.REMOVED, removedHandler);
        addEventListener(MouseEvent.CLICK, clickHandler);
        addEventListener(Event.RENDER, renderHandler);
    }

    private function draw():void {
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, size, size);
        graphics.endFill();
    }

    private function clickHandler(event:MouseEvent):void {
        trace("clickHandler: " + event);
        parent.removeChild(this);
    }

    private function addedHandler(event:Event):void {
        trace("addedHandler: " + event);
        stage.scaleMode = StageScaleMode.NO_SCALE;
        stage.align = StageAlign.TOP_LEFT;
        stage.addEventListener("resize", resizeHandler);
    }

    private function enterFrameHandler(event:Event):void {
        trace("enterFrameHandler: " + event);
        removeEventListener("enterFrame", enterFrameHandler);
    }

    private function removedHandler(event:Event):void {
        trace("removedHandler: " + event);
        stage.removeEventListener("resize", resizeHandler);
    }

    private function renderHandler(event:Event):void {
        trace("renderHandler: " + event);
    }

    private function resizeHandler(event:Event):void {
        trace("resizeHandler: " + event);
    }
}


flash.display.DisplayObjectContainer (Flex™ 2 Language Reference)

Class DisplayObjectContainer | Properties | Methods | Events | Examples
Package | flash.display
Class | public class DisplayObjectContainer
Inheritance | DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | Loader, Sprite, Stage

The DisplayObjectContainer class is the base class for all objects that can serve as display object containers on the display list. The display list manages all objects displayed in Flash Player. Use the DisplayObjectContainer class to arrange the display objects in the display list. Each DisplayObjectContainer object has its own child list for organizing the z-order of the objects. The z-order is the front-to-back order that determines which object is drawn in front, which is behind, and so on.

DisplayObject is an abstract base class; therefore, you cannot call DisplayObject directly. Invoking new DisplayObject() throws an ArgumentError exception.

The DisplayObjectContainer class is an abstract base class for all objects that can contain child objects. It cannot be instantiated directly; calling the new DisplayObjectContainer() constructor throws an ArgumentError exception.

For more information, see the "Display Programming" chapter of the Programming ActionScript 3.0 book.

View the examples.

See also

flash.display.DisplayObject
Understanding the display architecture
Working with display objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | numChildren : int [read-only] Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | textSnapshot : TextSnapshot [read-only] Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DisplayObjectContainer()
Calling the new DisplayObjectContainer() constructor throws an ArgumentError exception.
DisplayObjectContainer
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
mouseChildren property
mouseChildren:Boolean [read-write]

Determines whether or not the children of the object are mouse enabled. If an object is mouse enabled, a user can interact with it by using a mouse. The default is true.

This property is useful when you create a button with an instance of the Sprite class (instead of using the SimpleButton class). When you use a Sprite instance to create a button, you can choose to decorate the button by using the addChild() method to add additional Sprite instances. This process can cause unexpected behavior with mouse events because the Sprite instances you add as children can become the target object of a mouse event when you expect the parent instance to be the target object. To ensure that the parent instance serves as the target objects for mouse events, you can set the mouseChildren property of the parent instance to false.

No event is dispatched by setting this property. You must use the addEventListener() method to create interactive functionality.

Implementation
    public function get mouseChildren():Boolean
    public function set mouseChildren(value:Boolean):void

See also

flash.display.Sprite.buttonMode
flash.events.EventDispatcher.addEventListener()

Example
The following example sets up a Sprite object (a type of display object container) named container and shows that when you set its mouseChildren property to false, the target of a mouseClick event is the container object, not any one of its child objects:
import flash.display.Sprite;
import flash.events.MouseEvent;

var container:Sprite = new Sprite();
container.name = "container";
addChild(container);

var circle:Sprite = new Sprite();
circle.name = "circle";
circle.graphics.beginFill(0xFFCC00);
circle.graphics.drawCircle(40, 40, 40);

container.addChild(circle);

container.mouseChildren = false;

container.addEventListener(MouseEvent.CLICK, clicked);

function clicked(event:MouseEvent):void {
    trace(event.target.name); // container
}

numChildren property
numChildren:int [read-only]

Returns the number of children of this object.

Implementation
    public function get numChildren():int

See also

Advantages of the ActionScript 3.0 display list approach

Example
The following example sets up two Sprite objects named container1 and container2. A Sprite is a type of display object container. The example calls the addChild() method to set up the display hierarchy: container1 is a child of container2, and two other display objects, circle1 and circle2, are children of container1. The calls to the trace() method show the number of children of each object. Note that grandchildren are not included in the numChildren count:
import flash.display.Sprite;

var container1:Sprite = new Sprite();
var container2:Sprite = new Sprite();

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFFCC00);
circle1.graphics.drawCircle(40, 40, 40);

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0x00CCFF);
circle2.graphics.drawCircle(80, 40, 40);

container2.addChild(container1);
container1.addChild(circle1);
container1.addChild(circle2);

trace(container1.numChildren); // 2
trace(container2.numChildren); // 1
trace(circle1.numChildren); // 0
trace(circle2.numChildren); // 0

tabChildren property
tabChildren:Boolean [read-write]

Determines whether the children of the object are tab enabled. Enables or disables tabbing for the children of the object.

Implementation
    public function get tabChildren():Boolean
    public function set tabChildren(value:Boolean):void

Throws
IllegalOperationError — Calling this property of the Stage object throws an exception. The Stage object does not implement this property.

Example
The following example creates a container1 display object container and adds two tab-enabled display objects, circle1 and circle2, to its child list:
import flash.display.Sprite;

var container:Sprite = new Sprite();
container.tabChildren = true;

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFFCC00);
circle1.graphics.drawCircle(40, 40, 40);
circle1.tabEnabled = true;

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0x00CCFF);
circle2.graphics.drawCircle(120, 40, 40);
circle2.tabEnabled = true;

container.addChild(circle1);
container.addChild(circle2);
To see the results of this example, compile and run the file. When you click one of the circles, you can press the TAB key to switch the display object that has focus (indicated by a yellow highlight rectangle).

textSnapshot property
textSnapshot:TextSnapshot [read-only]

Returns a TextSnapshot object for this DisplayObjectContainer instance.

Implementation
    public function get textSnapshot():TextSnapshot

See also

flash.text.TextSnapshot

Example
The following example works only in the Flash authoring environment. Flex does not include any ways of adding static text to a file. To prepare the Flash file for this example, add one or more static text fields in the first frame of a movie. Then insert the following script into the first frame and run the file. The output will be the static text that you added:
trace(this.textSnapshot.getText(0, this.textSnapshot.charCount));

Constructor detail
DisplayObjectContainer () constructor
public function DisplayObjectContainer()

Calling the new DisplayObjectContainer() constructor throws an ArgumentError exception. You can, however, call constructors for the following subclasses of DisplayObjectContainer:

  • new Loader()
  • new Sprite()
  • new MovieClip()

Method detail
addChild () method
public function addChild(child:DisplayObject):DisplayObject

Adds a child DisplayObject instance to this DisplayObjectContainer instance. The child is added to the front (top) of all other children in this DisplayObjectContainer instance. (To add a child to a specific index position, use the addChildAt() method.)

If you add a child object that already has a different display object container as a parent, the object is removed from the child list of the other display object container.

Parameters
child:DisplayObject — The DisplayObject instance to add as a child of this DisplayObjectContainer instance.

Returns
DisplayObject — The DisplayObject instance that you pass in the child parameter.

Events
added:Event — Dispatched when a display object is added to the display list.

Throws
ArgumentError — Throws if the child is the same as the parent.

See also

addChildAt()
Advantages of the ActionScript 3.0 display list approach
Working with display objects
Working with display objects
Working with display objects

Example
The following example sets up two Sprite objects named container1 and container2. A Sprite is a type of display object container. The example calls the addChild() method to set up the display hierarchy: container1 is a child of container2, and two other display objects, circle1 and circle2, are children of container1. The calls to the trace() method show the number of children of each object. Note that grandchildren are not included in the numChildren count:
import flash.display.Sprite;

var container1:Sprite = new Sprite();
var container2:Sprite = new Sprite();

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFFCC00);
circle1.graphics.drawCircle(40, 40, 40);

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0x00CCFF);
circle2.graphics.drawCircle(80, 40, 40);

container2.addChild(container1);
container1.addChild(circle1);
container1.addChild(circle2);

trace(container1.numChildren); // 2
trace(container2.numChildren); // 1
trace(circle1.numChildren); // 0
trace(circle2.numChildren); // 0

addChildAt () method
public function addChildAt(child:DisplayObject, index:int):DisplayObject

Adds a child DisplayObject instance to this DisplayObjectContainer instance. The child is added at the index position specified. An index of 0 represents the back (bottom) of the display list for this DisplayObjectContainer object.

For example, the following example shows three display objects, labeled a, b, and d, at index positions 0, 2, and 1, respectively:

If you add a child object that already has a different display object container as a parent, the object is removed from the child list of the other display object container.

Parameters
child:DisplayObject — The DisplayObject instance to add as a child of this DisplayObjectContainer instance.
index:int — The index position to which the child is added. If you specify a currently occupied index position, the child object that exists at that position and all higher positions are moved up one position in the child list.

Returns
DisplayObject — The DisplayObject instance that you pass in the child parameter.

Events
added:Event — Dispatched when a display object is added to the display list.

Throws
RangeError — Throws if the index position does not exist in the child list.
ArgumentError — Throws if the child is the same as the parent.

See also

addChild()
Advantages of the ActionScript 3.0 display list approach
Working with display objects
Working with display objects
Working with display objects

Example
The following example creates a container display object container and adds a display objects circle1 to its display list. Then, by calling container.addChildAt(circle2, 0), it adds the circle2 object to index position zero (the back), and moves the circle1 object to index position 1:
import flash.display.Sprite;

var container:Sprite = new Sprite();

var circle1:Sprite = new Sprite();
var circle2:Sprite = new Sprite();

container.addChild(circle1);
container.addChildAt(circle2, 0);

trace(container.getChildAt(0) == circle2); // true
trace(container.getChildAt(1) == circle1); // true

areInaccessibleObjectsUnderPoint () method
public function areInaccessibleObjectsUnderPoint(point:Point):Boolean

Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point. By default, content from one domain cannot access objects from another domain unless they are permitted to do so with a call to the Security.allowDomain() method.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

The point parameter is in the coordinate space of the Stage, which may differ from the coordinate space of the display object container (unless the display object container is the Stage). You can use the globalToLocal() and the localToGlobal() methods to convert points between these coordinate spaces.

Parameters
point:Point — The point under which to look.

Returns
Boolean — true if the point contains child display objects with security restrictions.

See also

flash.system.Security.allowDomain()
getObjectsUnderPoint()
DisplayObject.globalToLocal()
DisplayObject.localToGlobal()

Example
The following code creates a display object container named container. The next block of code uses a Loader object to load a JPEG file named "test.jpg" from a remote file server. Note that the checkPolicyFile property of the LoaderContext object used as a parameter in the load() method is set to false. Once the file is loaded, the code calls the loaded() method, which in turn calls container.areInaccessibleObjectsUnderPoint(), which returns a value of true because the loaded content is assumed to be from an inaccessible domain:
import flash.display.Sprite;
import flash.display.Loader;
import flash.system.LoaderContext;
import flash.net.URLRequest;
import flash.events.Event;
import flash.geom.Point;

var container:Sprite = new Sprite();

var urlReq:URLRequest = new URLRequest("http://localhost/RemoteFile.swf");
var ldr:Loader = new Loader();
var context:LoaderContext = new LoaderContext();
context.checkPolicyFile = false;
ldr.load(urlReq, context);

ldr.contentLoaderInfo.addEventListener(Event.COMPLETE, loaded);
ldr.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, urlNotFound);

function loaded(event:Event):void {
    var pt:Point = new Point(1, 1);
    trace(container.areInaccessibleObjectsUnderPoint(pt)); // true
}

function urlNotFound(event:Event):void {
    trace("The URL was not found.");
}
This example assumes that the SWF file produced by this code is loaded from a different domain than that of the JPEG file, and that the loaded JPEG file occupies the point (1, 1).

contains () method
public function contains(child:DisplayObject):Boolean

Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself. The search includes the entire display list including this DisplayObjectContainer instance. Grandchildren, great-grandchildren, and so on each return true.

Parameters
child:DisplayObject — The child object to test.

Returns
Boolean — true if the child object is a child of the DisplayObjectContainer or the container itself; otherwise false.

Example
The following example sets up a number of Sprite objects and adds some to the child list of others. (A Sprite object is a type of display object container.) The relationship between various objects is shown by calling the contains() method:
import flash.display.Sprite;

var sprite1:Sprite = new Sprite();
var sprite2:Sprite = new Sprite();
var sprite3:Sprite = new Sprite();
var sprite4:Sprite = new Sprite();

sprite1.addChild(sprite2);
sprite2.addChild(sprite3);

trace(sprite1.contains(sprite1)); // true
trace(sprite1.contains(sprite2)); // true
trace(sprite1.contains(sprite3)); // true
trace(sprite1.contains(sprite4)); // false

getChildAt () method
public function getChildAt(index:int):DisplayObject

Returns the child display object instance that exists at the specified index.

Parameters
index:int — The index position of the child object.

Returns
DisplayObject — The child display object at the specified index position.

Throws
RangeError — Throws if the index does not exist in the child list.
SecurityError — This child display object belongs to a sandbox to which you do not have access. You can avoid this situation by having the child movie call Security.allowDomain().

See also

getChildByName()

Example
The following example creates a display object container named container and then adds a three display objects to the child list of the container object. The calls to the getChildAt() method then reveal the positions of the child objects:
import flash.display.Sprite;

var container:Sprite = new Sprite();

var sprite1:Sprite = new Sprite();
var sprite2:Sprite = new Sprite();
var sprite3:Sprite = new Sprite();

container.addChild(sprite1);
container.addChild(sprite2);
container.addChildAt(sprite3, 0);

trace(container.getChildAt(0) == sprite3); // true
trace(container.getChildAt(1) == sprite1); // true
trace(container.getChildAt(2) == sprite2); // true

getChildByName () method
public function getChildByName(name:String):DisplayObject

Returns the child display object that exists with the specified name. If more that one child display object has the specified name, the method returns the first object in the child list.

The getChildAt() method is faster than the getChildByName() method. The getChildAt() method accesses a child from a cached array, whereas the getChildByName() method has to traverse a linked list to access a child.

Parameters
name:String — The name of the child to return.

Returns
DisplayObject — The child display object with the specified name.

Throws
SecurityError — This child display object belongs to a sandbox to which you do not have access. You can avoid this situation by having the child movie call the Security.allowDomain() method.

See also

getChildAt()
flash.display.DisplayObject.name
Advantages of the ActionScript 3.0 display list approach

Example
The following example creates a display object container named container and then adds two child display objects to the container. Then, the code calls the getChildByName() and getChildIndex() methods to return the index position of the child of the container object that has the name "sprite1".
import flash.display.Sprite;
import flash.display.DisplayObject;

var container:Sprite = new Sprite();

var sprite1:Sprite = new Sprite();
sprite1.name = "sprite1";
var sprite2:Sprite = new Sprite();
sprite2.name = "sprite2";

container.addChild(sprite1);
container.addChild(sprite2);

var target:DisplayObject = container.getChildByName("sprite1");
trace(container.getChildIndex(target)); // 0

getChildIndex () method
public function getChildIndex(child:DisplayObject):int

Returns the index position of a child DisplayObject instance.

Parameters
child:DisplayObject — The DisplayObject instance to identify.

Returns
int — The index position of the child display object to identify.

Throws
ArgumentError — Throws if the child parameter is not a child of this object.

Example
The following example creates a display object container named container and then adds two child display objects to the container. Then, the code calls the getChildByName() and getChildIndex() methods to return the index position of the child of the container object that has the name "sprite1".
import flash.display.Sprite;
import flash.display.DisplayObject;

var container:Sprite = new Sprite();

var sprite1:Sprite = new Sprite();
sprite1.name = "sprite1";
var sprite2:Sprite = new Sprite();
sprite2.name = "sprite2";

container.addChild(sprite1);
container.addChild(sprite2);

var target:DisplayObject = container.getChildByName("sprite1");
trace(container.getChildIndex(target)); // 0

getObjectsUnderPoint () method
public function getObjectsUnderPoint(point:Point):Array

Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance. Any child objects that are inaccessible for security reasons are omitted from the returned array. To determine whether this security restriction affects the returned array, call the areInaccessibleObjectsUnderPoint() method.

The point parameter is in the coordinate space of the Stage, which may differ from the coordinate space of the display object container (unless the display object container is the Stage). You can use the globalToLocal() and the localToGlobal() methods to convert points between these coordinate spaces.

Parameters
point:Point — The point under which to look.

Returns
Array — An array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.

See also

areInaccessibleObjectsUnderPoint()
DisplayObject.globalToLocal()
DisplayObject.localToGlobal()

Example
The following example creates a display object container named container and then adds two overlapping child display objects to the container. Then the code calls the getObjectsUnderPoint() twice — first using a point that touches only one object, then using a point where the objects overlap — and the length of the return Array shows the number of objects at each point in the container:
import flash.display.Sprite;
import flash.geom.Point;

var container:Sprite = new Sprite();

var square1:Sprite = new Sprite();
square1.graphics.beginFill(0xFFCC00);
square1.graphics.drawRect(0, 0, 40, 40);

var square2:Sprite = new Sprite();
square2.graphics.beginFill(0x00CCFF);
square2.graphics.drawRect(20, 0, 30, 40);

container.addChild(square1);
container.addChild(square2);

var pt:Point = new Point(10, 20);
var objects:Array = container.getObjectsUnderPoint(pt);
trace(objects.length); // 1

pt = new Point(35, 20);
objects = container.getObjectsUnderPoint(pt);
trace(objects.length);  // 2

removeChild () method
public function removeChild(child:DisplayObject):DisplayObject

Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance. The parent property of the removed child is set to null , and the object is garbage collected if no other references to the child exist. The index positions of any display objects above the child in the DisplayObjectContainer are decreased by 1.

The garbage collector is the process by which Flash Player reallocates unused memory space. When a variable or object is no longer actively referenced or stored somewhere, the garbage collector sweeps through and wipes out the memory space it used to occupy if no other references to it exist.

Parameters
child:DisplayObject — The DisplayObject instance to remove.

Returns
DisplayObject — The DisplayObject instance that you pass in the child parameter.

Throws
ArgumentError — Throws if the child parameter is not a child of this object.

Example
The following example creates a display object container named container and then adds two child display objects to the container. An event listener is added to the container object, so that when the user clicks a child object of the container, the removeChild() method removes the child clicked from the child list of the container:

import flash.display.DisplayObject;
import flash.display.Sprite;
import flash.events.MouseEvent;

var container:Sprite = new Sprite();
addChild(container);

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFFCC00);
circle1.graphics.drawCircle(40, 40, 40);

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0x00CCFF);
circle2.graphics.drawCircle(120, 40, 40);

container.addChild(circle1);
container.addChild(circle2);

container.addEventListener(MouseEvent.CLICK, clicked);

function clicked(event:MouseEvent):void {
    container.removeChild(DisplayObject(event.target));
}

removeChildAt () method
public function removeChildAt(index:int):DisplayObject

Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer. The parent property of the removed child is set to null, and the object is garbage collected if no other references to the child exist. The index positions of any display objects above the child in the DisplayObjectContainer are decreased by 1.

The garbage collector is the process by which Flash Player reallocates unused memory space. When a variable or object is no longer actively referenced or stored somewhere, the garbage collector sweeps through and wipes out the memory space it used to occupy if no other references to it exist.

Parameters
index:int — The child index of the DisplayObject to remove.

Returns
DisplayObject — The DisplayObject instance that was removed.

Throws
SecurityError — This child display object belongs to a sandbox to which the calling object does not have access. You can avoid this situation by having the child movie call the Security.allowDomain() method.
RangeError — Throws if the index does not exist in the child list.

Example
The following example creates a display object container named container and then adds two child display objects to the container. The code then shows that when you call the removeChildAt() method to remove the child at the lowest index position (0), any other child object in the list moves down one position:
import flash.display.Sprite;

var container:Sprite = new Sprite();

var sprite1:Sprite = new Sprite();
sprite1.name = "sprite1";
var sprite2:Sprite = new Sprite();
sprite2.name = "sprite2";

container.addChild(sprite1);
container.addChild(sprite2);

trace(container.numChildren) // 2
container.removeChildAt(0);
trace(container.numChildren) // 1
trace(container.getChildAt(0).name); // sprite2

setChildIndex () method
public function setChildIndex(child:DisplayObject, index:int):void

Changes the position of an existing child in the display object container. This affects the layering of child objects. For example, the following example shows three display objects, labeled a, b, and c, at index positions 0, 1, and 2, respectively:

When you use the setChildIndex() method and specify an index position that is already occupied, the child that occupies that position and all objects higher in the child list move up one position in the list. For example, if the display object container in the previous example is named container, you can swap the position of the display objects labeled a and b by calling the following code:

container.setChildIndex(container.getChildAt(1), 0);

This code results in the following arrangement of objects:

Parameters
child:DisplayObject — The child DisplayObject instance for which you want to change the index number.
index:int — The resulting index number for the child display object.

Throws
RangeError — Throws if the index does not exist in the child list.
ArgumentError — Throws if the child parameter is not a child of this object.

See also

addChildAt()
getChildIndex()

Example
The following example creates a display object container named container and then adds three slightly overlapping child display objects to the container. When the user clicks any of these objects, the clicked() method calls the setChildIndex() method to move the clicked object to the top-most position in the child list of the container object:
import flash.display.Sprite;
import flash.events.MouseEvent;

var container:Sprite = new Sprite();
addChild(container);

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFF0000);
circle1.graphics.drawCircle(40, 40, 40);
circle1.addEventListener(MouseEvent.CLICK, clicked);

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0x00FF00);
circle2.graphics.drawCircle(100, 40, 40);
circle2.addEventListener(MouseEvent.CLICK, clicked);

var circle3:Sprite = new Sprite();
circle3.graphics.beginFill(0x0000FF);
circle3.graphics.drawCircle(70, 80, 40);
circle3.addEventListener(MouseEvent.CLICK, clicked);

container.addChild(circle1);
container.addChild(circle2);
container.addChild(circle3);
addChild(container);

function clicked(event:MouseEvent):void {
    var circle:Sprite = Sprite(event.target);
    var topPosition:uint = container.numChildren - 1;
    container.setChildIndex(circle, topPosition);
}

swapChildren () method
public function swapChildren(child1:DisplayObject, child2:DisplayObject):void

Swaps the z-order (front-to-back order) of the two specified child objects. All other child objects in the display object container remain in the same index positions.

Parameters
child1:DisplayObject — The first child object.
child2:DisplayObject — The second child object.

Throws
ArgumentError — Throws if either child parameter is not a child of this object.

Example
The following example creates a display object container named container, then adds two child display objects to the container, and then shows the effect of a call to the swapChildren() method:
import flash.display.Sprite;

var container:Sprite = new Sprite();

var sprite1:Sprite = new Sprite();
sprite1.name = "sprite1";
var sprite2:Sprite = new Sprite();
sprite2.name = "sprite2";

container.addChild(sprite1);
container.addChild(sprite2);

trace(container.getChildAt(0).name); // sprite1
trace(container.getChildAt(1).name); // sprite2

container.swapChildren(sprite1, sprite2);

trace(container.getChildAt(0).name); // sprite2
trace(container.getChildAt(1).name); // sprite1

swapChildrenAt () method
public function swapChildrenAt(index1:int, index2:int):void

Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list. All other child objects in the display object container remain in the same index positions.

Parameters
index1:int — The index position of the first child object.
index2:int — The index position of the second child object.

Throws
RangeError — If either index does not exist in the child list.

Example
The following example creates a display object container named container, then adds three child display objects to the container, and then shows how a call to the swapChildrenAt() method rearranges the child list of the display object container:
import flash.display.Sprite;

var container:Sprite = new Sprite();

var sprite1:Sprite = new Sprite();
sprite1.name = "sprite1";
var sprite2:Sprite = new Sprite();
sprite2.name = "sprite2";
var sprite3:Sprite = new Sprite();
sprite3.name = "sprite3";

container.addChild(sprite1);
container.addChild(sprite2);
container.addChild(sprite3);

trace(container.getChildAt(0).name); // sprite1
trace(container.getChildAt(1).name); // sprite2
trace(container.getChildAt(2).name); // sprite3

container.swapChildrenAt(0, 2);

trace(container.getChildAt(0).name); // sprite3
trace(container.getChildAt(1).name); // sprite2
trace(container.getChildAt(2).name); // sprite1

Examples

The following example uses the class DisplayObjectContainerExample to create five orange squares in succession. This task is accomplished by performing the following steps:
  1. The constructor calls the configureAssets() method.
  2. The configureAssets() method creates child and lastChild Sprite objects.
  3. A for loop creates the five orange squares and positions them one after another.
  4. Each time a CustomSprite object is created, its constructor calls the draw() method of the CustomSprite object, which creates a 50-by-50-pixel square by calling the beginFill(), drawRect(), and endFill() methods of the Graphics class. The addChild() method adds each square to the display list.

package {
    import flash.display.DisplayObject;
    import flash.display.Sprite;

    public class DisplayObjectContainerExample extends Sprite {
        private var gutter:uint     = 5;
        private var childCount:uint = 5;

        public function DisplayObjectContainerExample() {
            configureAssets();
        }

        private function configureAssets():void {
            var child:Sprite = new CustomSprite();
            var lastChild:Sprite = child;
            for (var i:uint = 1; i <= childCount; i++) {
                child = new CustomSprite();
                child.x = lastChild.x + lastChild.width + gutter;
                addChild(child);
                lastChild = child;
            }
        }
    }
}

import flash.display.Sprite;

class CustomSprite extends Sprite {
    private var size:uint = 50;
    private var bgColor:uint = 0xFFCC00;

    public function CustomSprite() {
        draw(size, size);
    }

    private function draw(w:uint, h:uint):void {
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, w, h);
        graphics.endFill();
    }
}


flash.display.FrameLabel (Flex™ 2 Language Reference)

Class FrameLabel | Properties | Methods
Package | flash.display
Class | public final class FrameLabel
Inheritance | FrameLabel Inheritance Object

The FrameLabel object contains properties that specify a frame number and the corresponding label name. The Scene class includes a labels property, which is an array of FrameLabel objects for the scene.

See also

Scene.labels
MovieClip.currentLabel
MovieClip.currentScene
MovieClip.scenes
MovieClip.gotoAndPlay()
MovieClip.gotoAndStop()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | frame : int [read-only] The frame number containing the label. | FrameLabel
 | name : String [read-only] The name of the label. | FrameLabel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
frame property
frame:int [read-only]

The frame number containing the label.

Implementation
    public function get frame():int
name property
name:String [read-only]

The name of the label.

Implementation
    public function get name():String


flash.display.GradientType (Flex™ 2 Language Reference)

Class GradientType | Properties | Methods | Constants
Package | flash.display
Class | public final class GradientType
Inheritance | GradientType Inheritance Object

The GradientType class provides values for the type parameter in the beginGradientFill() and lineGradientFill() methods of the flash.display.Graphics class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | LINEAR : String = "linear" [static] Value used to specify a linear gradient fill. | GradientType
 | RADIAL : String = "radial" [static] Value used to specify a radial gradient fill. | GradientType
Constant detail
LINEAR constant
public static const LINEAR:String = "linear"

Value used to specify a linear gradient fill.

RADIAL constant
public static const RADIAL:String = "radial"

Value used to specify a radial gradient fill.


flash.display.Graphics (Flex™ 2 Language Reference)

Class Graphics | Properties | Methods | Examples
Package | flash.display
Class | public final class Graphics
Inheritance | Graphics Inheritance Object

The Graphics class contains a set of methods that you can use to create a vector shape. Display objects that support drawing include Sprite and Shape objects. Each of these classes includes a graphics property that is a Graphics object. The following are among those helper functions provided for ease of use: drawRect(), drawRoundRect(), drawCircle(), and drawEllipse().

You cannot create a Graphics object directly from ActionScript code. If you call new Graphics(), an exception is thrown.

The Graphics class is final; it cannot be subclassed.

View the examples.

See also

Drawing vector graphics

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
beginBitmapFill(bitmap:BitmapData, matrix:Matrix = null, repeat:Boolean = true, smooth:Boolean = false):void
Fills a drawing area with a bitmap image.
Graphics
beginFill(color:uint, alpha:Number = 1.0):void
Specifies a simple one-color fill that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
Graphics
beginGradientFill(type:String, colors:Array, alphas:Array, ratios:Array, matrix:Matrix = null, spreadMethod:String = "pad", interpolationMethod:String = "rgb", focalPointRatio:Number = 0):void
Specifies a gradient fill that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
Graphics
clear():void
Clears the graphics that were drawn to this Graphics object, and resets fill and line style settings.
Graphics
curveTo(controlX:Number, controlY:Number, anchorX:Number, anchorY:Number):void
Draws a curve using the current line style from the current drawing position to (anchorX, anchorY) and using the control point that (controlX, controlY) specifies.
Graphics
drawCircle(x:Number, y:Number, radius:Number):void
Draws a circle.
Graphics
drawEllipse(x:Number, y:Number, width:Number, height:Number):void
Draws an ellipse.
Graphics
drawRect(x:Number, y:Number, width:Number, height:Number):void
Draws a rectangle.
Graphics
drawRoundRect(x:Number, y:Number, width:Number, height:Number, ellipseWidth:Number, ellipseHeight:Number):void
Draws a rounded rectangle.
Graphics
endFill():void
Applies a fill to the lines and curves that were added since the last call to the beginFill(), beginGradientFill(), or beginBitmapFill() method.
Graphics
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
lineGradientStyle(type:String, colors:Array, alphas:Array, ratios:Array, matrix:Matrix = null, spreadMethod:String = "pad", interpolationMethod:String = "rgb", focalPointRatio:Number = 0):void
Specifies a gradient for the line style that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
Graphics
lineStyle(thickness:Number, color:uint = 0, alpha:Number = 1.0, pixelHinting:Boolean = false, scaleMode:String = "normal", caps:String = null, joints:String = null, miterLimit:Number = 3):void
Specifies a line style that Flash uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
Graphics
lineTo(x:Number, y:Number):void
Draws a line using the current line style from the current drawing position to (x, y); the current drawing position is then set to (x, y).
Graphics
moveTo(x:Number, y:Number):void
Moves the current drawing position to (x, y).
Graphics
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Method detail
beginBitmapFill () method
public function beginBitmapFill(bitmap:BitmapData, matrix:Matrix = null, repeat:Boolean = true, smooth:Boolean = false):void

Fills a drawing area with a bitmap image. The bitmap can be repeated or tiled to fill the area. The fill remains in effect until you call the beginFill(), beginBitmapFill(), or beginGradientFill() method. Calling the clear() method clears the fill.

Flash Player does not render the fill until the endFill() method is called. (The drawCircle(), drawEllipse(), drawRect(), and drawRoundRect() methods automatically invoke the endFill() method.)

Parameters
bitmap:BitmapData — A transparent or opaque bitmap image that contains the bits to be displayed.
matrix:Matrix (default = null) — A matrix object (of the flash.geom.Matrix class), which you can use to define transformations on the bitmap. For instance, you can use the following matrix to rotate a bitmap by 45 degrees (pi/4 radians):
  matrix = new flash.geom.Matrix();
  matrix.rotate(Math.PI/4);
repeat:Boolean (default = true) — If true, the bitmap image repeats in a tiled pattern. If false, the bitmap image does not repeat, and the edges of the bitmap are used for any fill area that extends beyond the bitmap.

For example, consider the following bitmap (a 20 x 20-pixel checkerboard pattern):

When repeat is set to true (as in the following example), the bitmap fill repeats the bitmap:

When repeat is set to false, the bitmap fill uses the edge pixels for the fill area outside of the bitmap:
smooth:Boolean (default = false) — If false, upscaled bitmap images are rendered by using a nearest-neighbor algorithm and look pixelated. If true, upscaled bitmap images are rendered by using a bilinear algorithm. Rendering by using the nearest neighbor algorithm is usually faster.

See also

endFill()
beginFill()
beginGradientFill()
beginFill () method
public function beginFill(color:uint, alpha:Number = 1.0):void

Specifies a simple one-color fill that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object. The fill remains in effect until you call the beginFill(), beginBitmapFill(), or beginGradientFill() method. Calling the clear() method clears the fill.

Flash Player does not render the fill until the endFill() method is called. (The drawCircle(), drawEllipse(), drawRect(), and drawRoundRect() methods automatically invoke the endFill() method.)

Parameters
color:uint — The color of the fill (0xRRGGBB).
alpha:Number (default = 1.0) — The alpha value of the fill (0.0 to 1.0).

See also

endFill()
beginBitmapFill()
beginGradientFill()
beginGradientFill () method
public function beginGradientFill(type:String, colors:Array, alphas:Array, ratios:Array, matrix:Matrix = null, spreadMethod:String = "pad", interpolationMethod:String = "rgb", focalPointRatio:Number = 0):void

Specifies a gradient fill that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object. The fill remains in effect until you call the beginFill(), beginBitmapFill(), or beginGradientFill() method. Calling the clear() method clears the fill.

Flash Player does not render the fill until the endFill() method is called. (The drawCircle(), drawEllipse(), drawRect(), and drawRoundRect() methods automatically invoke the endFill() method.)

Parameters
type:String — A value from the GradientType class that specifies which gradient type to use: GradientType.LINEAR or GradientType.RADIAL.
colors:Array — An array of RGB hexadecimal color values to be used in the gradient; for example, red is 0xFF0000, blue is 0x0000FF, and so on. You can specify up to 15 colors. For each color, be sure you specify a corresponding value in the alphas and ratios parameters.
alphas:Array — An array of alpha values for the corresponding colors in the colors array; valid values are 0 to 1. If the value is less than 0, the default is 0. If the value is greater than 1, the default is 1.
ratios:Array — An array of color distribution ratios; valid values are 0 to 255. This value defines the percentage of the width where the color is sampled at 100%. The value 0 represents the left-hand position in the gradient box, and 255 represents the right-hand position in the gradient box.

Note: This value represents positions in the gradient box, not the coordinate space of the final gradient, which might be wider or thinner than the gradient box. Specify a value for each value in the colors parameter.

For example, for a linear gradient that includes two colors, blue and green, the following example illustrates the placement of the colors in the gradient based on different values in the ratios array:

ratios | Gradient
[0, 127] |
[0, 255] |
[127, 255] |

The values in the array must increase sequentially; for example, [0, 63, 127, 190, 255].

matrix:Matrix (default = null) — A transformation matrix as defined by the flash.geom.Matrix class. The flash.geom.Matrix class includes a createGradientBox() method, which lets you conveniently set up the matrix for use with the beginGradientFill() method.
spreadMethod:String (default = "pad") — A value from the SpreadMethod class that specifies which spread method to use, either: SpreadMethod.PAD, SpreadMethod.REFLECT, or SpreadMethod.REPEAT.

For example, consider a simple linear gradient between two colors:

  import flash.geom.*
  import flash.display.*
  var fillType:String = GradientType.LINEAR;
  var colors:Array = [0xFF0000, 0x0000FF];
  var alphas:Array = [100, 100];
  var ratios:Array = [0x00, 0xFF];
  var matr:Matrix = new Matrix();
  matr.createGradientBox(20, 20, 0, 0, 0);
  var spreadMethod:String = SpreadMethod.PAD;
  this.graphics.beginGradientFill(fillType, colors, alphas, ratios, matr, spreadMethod);
  this.graphics.drawRect(0,0,100,100);

This example uses SpreadMethod.PAD for the spread method, and the gradient fill looks like the following:

If you use SpreadMethod.REFLECT for the spread method, the gradient fill looks like the following:

If you use SpreadMethod.REPEAT for the spread method, the gradient fill looks like the following:
interpolationMethod:String (default = "rgb") — A value from the InterpolationMethod class that specifies which value to use: InterpolationMethod.linearRGB or InterpolationMethod.RGB

For example, consider a simple linear gradient between two colors (with the spreadMethod parameter set to SpreadMethod.REFLECT). The different interpolation methods affect the appearance as follows:

InterpolationMethod.LINEAR_RGB | InterpolationMethod.RGB
focalPointRatio:Number (default = 0) — A number that controls the location of the focal point of the gradient. 0 means that the focal point is in the center. 1 means that the focal point is at one border of the gradient circle. -1 means that the focal point is at the other border of the gradient circle. A value less than -1 or greater than 1 is rounded to -1 or 1. For example, the following example shows a focalPointRatio set to 0.75:

Throws
ArgumentError — If the type parameter is not valid.

See also

endFill()
beginFill()
beginBitmapFill()
flash.geom.Matrix.createGradientBox()
flash.display.GradientType
flash.display.SpreadMethod
Using Matrix objects
clear () method
public function clear():void

Clears the graphics that were drawn to this Graphics object, and resets fill and line style settings.

curveTo () method
public function curveTo(controlX:Number, controlY:Number, anchorX:Number, anchorY:Number):void

Draws a curve using the current line style from the current drawing position to (anchorX, anchorY) and using the control point that (controlX, controlY) specifies. The current drawing position is then set to (anchorX, anchorY). If the movie clip in which you are drawing contains content created with the Flash drawing tools, calls to the curveTo() method are drawn underneath this content. If you call the curveTo() method before any calls to the moveTo() method, the default of the current drawing position is (0, 0). If any of the parameters are missing, this method fails and the current drawing position is not changed.

The curve drawn is a quadratic Bezier curve. Quadratic Bezier curves consist of two anchor points and one control point. The curve interpolates the two anchor points and curves toward the control point.

Parameters
controlX:Number — A number that specifies the horizontal position of the control point relative to the registration point of the parent display object.
controlY:Number — A number that specifies the vertical position of the control point relative to the registration point of the parent display object.
anchorX:Number — A number that specifies the horizontal position of the next anchor point relative to the registration point of the parent display object.
anchorY:Number — A number that specifies the vertical position of the next anchor point relative to the registration point of the parent display object.
drawCircle () method
public function drawCircle(x:Number, y:Number, radius:Number):void

Draws a circle. You must set the line style, fill, or both before you call the drawCircle() method, by calling the linestyle(), lineGradientStyle(), beginFill(), beginGradientFill(), or beginBitmapFill() method.

Parameters
x:Number — The x location of the center of the circle relative to the registration point of the parent display object (in pixels).
y:Number — The y location of the center of the circle relative to the registration point of the parent display object (in pixels).
radius:Number — The radius of the circle (in pixels).

See also

drawEllipse()
lineStyle()
lineGradientStyle()
beginFill()
beginGradientFill()
beginBitmapFill()
drawEllipse () method
public function drawEllipse(x:Number, y:Number, width:Number, height:Number):void

Draws an ellipse. You must set the line style, fill, or both before you call the drawEllipse() method, by calling the linestyle(), lineGradientStyle(), beginFill(), beginGradientFill(), or beginBitmapFill() method.

Parameters
x:Number — A number indicating the horizontal position relative to the registration point of the parent display object (in pixels).
y:Number — A number indicating the vertical position relative to the registration point of the parent display object (in pixels).
width:Number — The width of the ellipse (in pixels).
height:Number — The height of the ellipse (in pixels).

See also

drawCircle()
lineStyle()
lineGradientStyle()
beginFill()
beginGradientFill()
beginBitmapFill()
drawRect () method
public function drawRect(x:Number, y:Number, width:Number, height:Number):void

Draws a rectangle. You must set the line style, fill, or both before you call the drawRect() method, by calling the linestyle(), lineGradientStyle(), beginFill(), beginGradientFill(), or beginBitmapFill() method.

Parameters
x:Number — A number indicating the horizontal position relative to the registration point of the parent display object (in pixels).
y:Number — A number indicating the vertical position relative to the registration point of the parent display object (in pixels).
width:Number — The width of the rectangle (in pixels).
height:Number — The height of the rectangle (in pixels).

Throws
ArgumentError — If the width or height parameters are not a number (Number.NaN).

See also

lineStyle()
lineGradientStyle()
beginFill()
beginGradientFill()
beginBitmapFill()
drawRoundRect()
drawRoundRect () method
public function drawRoundRect(x:Number, y:Number, width:Number, height:Number, ellipseWidth:Number, ellipseHeight:Number):void

Draws a rounded rectangle. You must set the line style, fill, or both before you call the drawRoundRect() method, by calling the linestyle(), lineGradientStyle(), beginFill(), beginGradientFill(), or beginBitmapFill() method.

Parameters
x:Number — A number indicating the horizontal position relative to the registration point of the parent display object (in pixels).
y:Number — A number indicating the vertical position relative to the registration point of the parent display object (in pixels).
width:Number — The width of the round rectangle (in pixels).
height:Number — The height of the round rectangle (in pixels).
ellipseWidth:Number — The width of the ellipse used to draw the rounded corners (in pixels).
ellipseHeight:Number — The height of the ellipse used to draw the rounded corners (in pixels). Optional; if no value is specified, the default value matches that provided for the ellipseWidth parameter.

Throws
ArgumentError — If the width, height, ellipseWidth or ellipseHeight parameters are not a number (Number.NaN).

See also

lineStyle()
lineGradientStyle()
beginFill()
beginGradientFill()
beginBitmapFill()
drawRect()
endFill () method
public function endFill():void

Applies a fill to the lines and curves that were added since the last call to the beginFill(), beginGradientFill(), or beginBitmapFill() method. Flash uses the fill that was specified in the previous call to the beginFill(), beginGradientFill(), or beginBitmapFill() method. If the current drawing position does not equal the previous position specified in a moveTo() method and a fill is defined, the path is closed with a line and then filled.

See also

beginFill()
beginBitmapFill()
beginGradientFill()
lineGradientStyle () method
public function lineGradientStyle(type:String, colors:Array, alphas:Array, ratios:Array, matrix:Matrix = null, spreadMethod:String = "pad", interpolationMethod:String = "rgb", focalPointRatio:Number = 0):void

Specifies a gradient for the line style that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object. The line style remains in effect until you call the lineStyle() method or the lineGradientStyle() method with different parameters. You can call the lineGradientStyle() method in the middle of drawing a path to specify different styles for different line segments within a path.

Call lineStyle() before you call lineGradientStyle() to enable a stroke, otherwise the value of the line style remains undefined.

Calls to clear() set the line style back to undefined.

Parameters
type:String — A value from the GradientType class that specifies which gradient type to use, either GradientType.LINEAR or GradientType.RADIAL.
colors:Array — An array of RGB hex color values to be used in the gradient (for example, red is 0xFF0000, blue is 0x0000FF, and so on).
alphas:Array — An array of alpha values for the corresponding colors in the colors array; valid values are 0 to 100. If the value is less than 0, Flash Player uses 0. If the value is greater than 100, Flash Player uses 100.
ratios:Array — An array of color distribution ratios; valid values are from 0 to 255. This value defines the percentage of the width where the color is sampled at 100%. The value 0 represents the left-hand position in the gradient box, and 255 represents the right-hand position in the gradient box. This value represents positions in the gradient box, not the coordinate space of the final gradient, which might be wider or thinner than the gradient box. Specify a value for each value in the colors parameter.

For example, for a linear gradient that includes two colors, blue and green, the following figure illustrates the placement of the colors in the gradient based on different values in the ratios array:

ratios | Gradient
[0, 127] |
[0, 255] |
[127, 255] |

The values in the array must increase, sequentially; for example, [0, 63, 127, 190, 255].

matrix:Matrix (default = null) — A transformation matrix as defined by the flash.geom.Matrix class. The flash.geom.Matrix class includes a createGradientBox() method, which lets you conveniently set up the matrix for use with the lineGradientStyle() method.
spreadMethod:String (default = "pad") — A value from the SpreadMethod class that specifies which spread method to use:

SpreadMethod.PAD | SpreadMethod.REFLECT | SpreadMethod.REPEAT
interpolationMethod:String (default = "rgb") — A value from the InterpolationMethod class that specifies which value to use. For example, consider a simple linear gradient between two colors (with the spreadMethod parameter set to SpreadMethod.REFLECT). The different interpolation methods affect the appearance as follows:

InterpolationMethod.LINEAR_RGB | InterpolationMethod.RGB
focalPointRatio:Number (default = 0) — A number that controls the location of the focal point of the gradient. The value 0 means the focal point is in the center. The value 1 means the focal point is at one border of the gradient circle. The value -1 means that the focal point is at the other border of the gradient circle. Values less than -1 or greater than 1 are rounded to -1 or 1. The following image shows a gradient with a focalPointRatio of -0.75:

See also

flash.geom.Matrix.createGradientBox()
flash.display.GradientType
flash.display.SpreadMethod
Using Matrix objects
lineStyle () method
public function lineStyle(thickness:Number, color:uint = 0, alpha:Number = 1.0, pixelHinting:Boolean = false, scaleMode:String = "normal", caps:String = null, joints:String = null, miterLimit:Number = 3):void

Specifies a line style that Flash uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object. The line style remains in effect until you call the lineGradientStyle() method or the lineStyle() method with different parameters. You can call lineStyle() in the middle of drawing a path to specify different styles for different line segments within the path.

Note: Calls to the clear() method set the line style back to undefined.

Parameters
thickness:Number — An integer that indicates the thickness of the line in points; valid values are 0 to 255. If a number is not specified, or if the parameter is undefined, a line is not drawn. If a value of less than 0 is passed, the default is 0. The value 0 indicates hairline thickness; the maximum thickness is 255. If a value greater than 255 is passed, the default is 255.
color:uint (default = 0) — A hexadecimal color value of the line; for example, red is 0xFF0000, blue is 0x0000FF, and so on. If a value is not indicated, the default is 0x000000 (black). Optional. -
alpha:Number (default = 1.0) — A number that indicates the alpha value of the color of the line; valid values are 0 to 1. If a value is not indicated, the default is 1 (solid). If the value is less than 0, the default is 0. If the value is greater than 1, the default is 1.
pixelHinting:Boolean (default = false) — A Boolean value that specifies whether to hint strokes to full pixels. This affects both the position of anchors of a curve and the line stroke size itself. With pixelHinting set to true, Flash Player hints line widths to full pixel widths. With pixelHinting set to false, disjoints can appear for curves and straight lines. For example, the following illustrations show how Flash Player renders two rounded rectangles that are identical, except that the pixelHinting parameter used in the lineStyle() method is set differently (the images are scaled by 200%, to emphasize the difference):

If a value is not supplied, the line does not use pixel hinting.
scaleMode:String (default = "normal") — A value from the LineScaleMode class that specifies which scale mode to use:
  • LineScaleMode.NORMAL—Always scale the line thickness when the object is scaled (the default).
  • LineScaleMode.NONE—Never scale the line thickness.
  • LineScaleMode.VERTICAL—Do not scale the line thickness if the object is scaled vertically only. For example, consider the following circles, drawn with a one-pixel line, and each with the scaleMode parameter set to LineScaleMode.VERTICAL. The circle on the left is scaled vertically only, and the circle on the right is scaled both vertically and horizontally:

  • LineScaleMode.HORIZONTAL—Do not scale the line thickness if the object is scaled horizontally only. For example, consider the following circles, drawn with a one-pixel line, and each with the scaleMode parameter set to LineScaleMode.HORIZONTAL. The circle on the left is scaled horizontally only, and the circle on the right is scaled both vertically and horizontally:

caps:String (default = null) — A value from the CapsStyle class that specifies the type of caps at the end of lines. Valid values are: CapsStyle.NONE, CapsStyle.ROUND, and CapsStyle.SQUARE. If a value is not indicated, Flash uses round caps.

For example, the following illustrations show the different capsStyle settings. For each setting, the illustration shows a blue line with a thickness of 30 (for which the capsStyle applies), and a superimposed black line with a thickness of 1 (for which no capsStyle applies):

joints:String (default = null) — A value from the JointStyle class that specifies the type of joint appearance used at angles. Valid values are: JointStyle.BEVEL, JointStyle.MITER, and JointStyle.ROUND. If a value is not indicated, Flash uses round joints.

For example, the following illustrations show the different joints settings. For each setting, the illustration shows an angled blue line with a thickness of 30 (for which the jointStyle applies), and a superimposed angled black line with a thickness of 1 (for which no jointStyle applies):

Note: For joints set to JointStyle.MITER, you can use the miterLimit parameter to limit the length of the miter.
miterLimit:Number (default = 3) — A number that indicates the limit at which a miter is cut off. Valid values range from 1 to 255 (and values outside of that range are rounded to 1 or 255). This value is only used if the jointStyle is set to "miter". The miterLimit value represents the length that a miter can extend beyond the point at which the lines meet to form a joint. The value expresses a factor of the line thickness. For example, with a miterLimit factor of 2.5 and a thickness of 10 pixels, the miter is cut off at 25 pixels.

For example, consider the following angled lines, each drawn with a thickness of 20, but with miterLimit set to 1, 2, and 4. Superimposed are black reference lines showing the meeting points of the joints:

Notice that a given miterLimit value has a specific maximum angle for which the miter is cut off. The following table lists some examples:

miterLimit value: | Angles smaller than this are cut off:
1.414 | 90 degrees
2 | 60 degrees
4 | 30 degrees
8 | 15 degrees

See also

LineScaleMode
CapsStyle
JointStyle
lineTo () method
public function lineTo(x:Number, y:Number):void

Draws a line using the current line style from the current drawing position to (x, y); the current drawing position is then set to (x, y). If the display object in which you are drawing contains content that was created with the Flash drawing tools, calls to the lineTo() method are drawn underneath the content. If you call lineTo() before any calls to the moveTo() method, the default position for the current drawing is (0, 0). If any of the parameters are missing, this method fails and the current drawing position is not changed.

Parameters
x:Number — A number that indicates the horizontal position relative to the registration point of the parent display object (in pixels).
y:Number — A number that indicates the vertical position relative to the registration point of the parent display object (in pixels).
moveTo () method
public function moveTo(x:Number, y:Number):void

Moves the current drawing position to (x, y). If any of the parameters are missing, this method fails and the current drawing position is not changed.

Parameters
x:Number — A number that indicates the horizontal position relative to the registration point of the parent display object (in pixels).
y:Number — A number that indicates the vertical position relative to the registration point of the parent display object (in pixels).
Examples

The following example uses the GraphicsExample class to draw a circle, a rounded rectangle, and a square. This task is accomplished by using the following steps:
  1. Declare a size property for later use in determining the size of each shape.
  2. Declare properties that set the background color to orange, the border color to dark gray, the border size to 0 pixels, the corner radius to 9 pixels, and set the space between the stage edge and the other objects to be 5 pixels.
  3. Use the properties declared in the preceding steps along with the built in methods of the Graphics class to draw the circle, rounded rectangle, and square at coordinates x = 0, y = 0.
  4. Redraw each of the shapes along the top of the stage, starting at x = 5, y = 5, with a 5-pixel spacing between shapes.

package {
    import flash.display.DisplayObject;
    import flash.display.Graphics;
    import flash.display.Shape;
    import flash.display.Sprite;

    public class GraphicsExample extends Sprite {
        private var size:uint         = 80;
        private var bgColor:uint      = 0xFFCC00;
        private var borderColor:uint  = 0x666666;
        private var borderSize:uint   = 0;
        private var cornerRadius:uint = 9;
        private var gutter:uint       = 5;

        public function GraphicsExample() {
            doDrawCircle();
            doDrawRoundRect();
            doDrawRect();
            refreshLayout();
        }

        private function refreshLayout():void {
            var ln:uint = numChildren;
            var child:DisplayObject;
            var lastChild:DisplayObject = getChildAt(0);
            lastChild.x = gutter;
            lastChild.y = gutter;
            for (var i:uint = 1; i < ln; i++) {
                child = getChildAt(i);
                child.x = gutter + lastChild.x + lastChild.width;
                child.y = gutter;
                lastChild = child;
            }
        }

        private function doDrawCircle():void {
            var child:Shape = new Shape();
            var halfSize:uint = Math.round(size / 2);
            child.graphics.beginFill(bgColor);
            child.graphics.lineStyle(borderSize, borderColor);
            child.graphics.drawCircle(halfSize, halfSize, halfSize);
            child.graphics.endFill();
            addChild(child);
        }

        private function doDrawRoundRect():void {
            var child:Shape = new Shape();
            child.graphics.beginFill(bgColor);
            child.graphics.lineStyle(borderSize, borderColor);
            child.graphics.drawRoundRect(0, 0, size, size, cornerRadius);
            child.graphics.endFill();
            addChild(child);
        }

        private function doDrawRect():void {
            var child:Shape = new Shape();
            child.graphics.beginFill(bgColor);
            child.graphics.lineStyle(borderSize, borderColor);
            child.graphics.drawRect(0, 0, size, size);
            child.graphics.endFill();
            addChild(child);
        }
    }
}


flash.display.IBitmapDrawable (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Interface IBitmapDrawable
Package | flash.display
Interface | public interface IBitmapDrawable
Subinterfaces | IFlexDisplayObject
Implementors | BitmapData, DisplayObject

The IBitmapDrawable interface is implemented by objects that can be passed as the source parameter of the draw() method of the BitmapData class. These objects are of type BitmapData or DisplayObject.

See also

flash.display.BitmapData.draw()
flash.display.BitmapData
flash.display.DisplayObject


flash.display.InteractiveObject (Flex™ 2 Language Reference)

Class InteractiveObject | Properties | Methods | Events | Examples
Package | flash.display
Class | public class InteractiveObject
Inheritance | InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | DisplayObjectContainer, SimpleButton, TextField

The InteractiveObject class is the abstract base class for all display objects with which you can interact: mouse, keyboard, and focus.

You cannot instantiate the InteractiveObject class directly. A call to the new InteractiveObject() constructor throws an ArgumentError exception.

ContextMenu is supported as the property menu.

View the examples.

See also

Understanding the display architecture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
 | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
InteractiveObject()
Calling the new InteractiveObject() constructor throws an ArgumentError exception.
InteractiveObject
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
 | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
 | focusIn | Dispatched after a display object gains focus. | InteractiveObject
 | focusOut | Dispatched after a display object loses focus. | InteractiveObject
 | keyDown | Dispatched when the user presses a key. | InteractiveObject
 | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
 | keyUp | Dispatched when the user releases a key. | InteractiveObject
 | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
 | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
 | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
 | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
 | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
 | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
 | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
 | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
 | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
 | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
 | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
contextMenu property
contextMenu:ContextMenu [read-write]

Specifies the context menu associated with this object.

Implementation
    public function get contextMenu():ContextMenu
    public function set contextMenu(value:ContextMenu):void
doubleClickEnabled property
doubleClickEnabled:Boolean [read-write]

Specifies whether the object receives doubleClick events. The default value is false, which means that by default an InteractiveObject instance does not receive doubleClick events. If the doubleClickEnabled property is set to true, the instance receives doubleClick events within its bounds. The mouseEnabled property of the InteractiveObject instance must also be set to true for the object to receive doubleClick events.

No event is dispatched by setting this property. You must use the addEventListener() method to add an event listener for the doubleClick event.

Implementation
    public function get doubleClickEnabled():Boolean
    public function set doubleClickEnabled(value:Boolean):void

See also

doubleClick
mouseEnabled
flash.display.DisplayObjectContainer.mouseChildren
focusRect property
focusRect:Object [read-write]

Specifies whether this object displays a focus rectangle. A value of null indicates that this object obeys the stageFocusRect property set on the Stage.

Implementation
    public function get focusRect():Object
    public function set focusRect(value:Object):void
mouseEnabled property
mouseEnabled:Boolean [read-write]

Specifies whether this object receives mouse messages. The default value is true, which means that by default any InteractiveObject instance that is on the display list receives mouse events. If mouseEnabled is set to false, the instance does not receive any mouse events. Any children of this instance on the display list are not affected. To change the mouseEnabled behavior for all children of an object on the display list, use flash.display.DisplayObjectContainer.mouseChildren.

No event is dispatched by setting this property. You must use the addEventListener() method to create interactive functionality.

Implementation
    public function get mouseEnabled():Boolean
    public function set mouseEnabled(value:Boolean):void

See also

flash.display.DisplayObjectContainer.mouseChildren
tabEnabled property
tabEnabled:Boolean [read-write]

Specifies whether this object is in the tab order. If this object is in the tab order, the value is true; otherwise, the value is false.

Implementation
    public function get tabEnabled():Boolean
    public function set tabEnabled(value:Boolean):void
tabIndex property
tabIndex:int [read-write]

Specifies the tab ordering of objects in a SWF file. The tabIndex property is -1 by default, meaning no tab index is set for the object.

If any currently displayed object in the SWF file contains a tabIndex property, automatic tab ordering is disabled, and the tab ordering is calculated from the tabIndex properties of objects in the SWF file. The custom tab ordering includes only objects that have tabIndex properties.

The tabIndex property can be a non-negative integer. The objects are ordered according to their tabIndex properties, in ascending order. An object with a tabIndex value of 1 precedes an object with a tabIndex value of 2. If two objects have the same tabIndex value, the object that precedes the other in the default tab ordering precedes the other object.

The custom tab ordering that the tabIndex property defines is flat. This means that no attention is paid to the hierarchical relationships of objects in the SWF file. All objects in the SWF file with tabIndex properties are placed in the tab order, and the tab order is determined by the order of the tabIndex values.

Implementation
    public function get tabIndex():int
    public function set tabIndex(value:int):void
Constructor detail
InteractiveObject () constructor
public function InteractiveObject()

Calling the new InteractiveObject() constructor throws an ArgumentError exception. You can, however, call constructors for the following subclasses of InteractiveObject:

  • new SimpleButton()
  • new TextField()
  • new Loader()
  • new Sprite()
  • new MovieClip()

Event detail
click event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.CLICK

Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. For a click event to occur, it must always follow this series of events in the order of occurrence: mouseDown event, then mouseUp. The target object must be identical for both of these events; otherwise the click event does not occur. Any number of other mouse events can occur at any time between the mouseDown or mouseUp events; the click event still occurs.

Defines the value of the type property of a click event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
doubleClick event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.DOUBLE_CLICK

Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. For a doubleClick event to occur, it must immediately follow the following series of events: mouseDown, mouseUp, click, mouseDown, mouseUp. All of these events must share the same target as the doubleClick event. The second click, represented by the second mouseDown and mouseUp events, must occur within a specific period of time after the click event. The allowable length of this period varies by operating system and can often be configured by the user. If the target is a selectable text field, the word under the pointer is selected as the default behavior. If the target InteractiveObject does not have its doubleClickEnabled flag set to true it receives two click events.

The doubleClickEnabled property defaults to false.

The double-click text selection behavior of a TextField object is not related to the doubleClick event. Use TextField.doubleClickEnabled to control TextField selections.

Defines the value of the type property of a doubleClick event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

doubleClickEnabled
focusIn event
Event object type: flash.events.FocusEvent
FocusEvent.type property = flash.events.FocusEvent.FOCUS_IN

Dispatched after a display object gains focus. This situation happens when a user highlights the object with a pointing device or keyboard navigation. The recipient of such focus is called the target object of this event, while the corresponding InteractiveObject instance that lost focus because of this change is called the related object. A reference to the related object is stored in the receiving object's relatedObject property. The shiftKey property is not used. This event follows the dispatch of the previous object's focusOut event.

Defines the value of the type property of a focusIn event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | 0; applies only to keyFocusChange events.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | false; applies only to keyFocusChange events.
target | The InteractiveObject instance that has just received focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
focusOut event
Event object type: flash.events.FocusEvent
FocusEvent.type property = flash.events.FocusEvent.FOCUS_OUT

Dispatched after a display object loses focus. This happens when a user highlights a different object with a pointing device or keyboard navigation. The object that loses focus is called the target object of this event, while the corresponding InteractiveObject instance that receives focus is called the related object. A reference to the related object is stored in the target object's relatedObject property. The shiftKey property is not used. This event precedes the dispatch of the focusIn event by the related object.

Defines the value of the type property of a focusOut event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | 0; applies only to keyFocusChange events.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | false; applies only to keyFocusChange events.
target | The InteractiveObject instance that has just lost focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
keyDown event
Event object type: flash.events.KeyboardEvent
KeyboardEvent.type property = flash.events.KeyboardEvent.KEY_DOWN

Dispatched when the user presses a key. Mappings between keys and specific characters vary by device and operating system. This event type is generated after such a mapping occurs but before the processing of an input method editor (IME). IMEs are used to enter characters, such as Chinese ideographs, that the standard QWERTY keyboard is ill-equipped to produce. This event occurs before the keyUp event.

Defines the value of the type property of a keyDown event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
charCode | The character code value of the key pressed or released.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | The key code value of the key pressed or released.
keyLocation | The location of the key on the keyboard.
shiftKey | true if the Shift key is active; false if it is inactive.
target | The InteractiveObject instance with focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
keyFocusChange event
Event object type: flash.events.FocusEvent
FocusEvent.type property = flash.events.FocusEvent.KEY_FOCUS_CHANGE

Dispatched when the user attempts to change focus by using keyboard navigation. The default behavior of this event is to change the focus and dispatch the corresponding focusIn and focusOut events.

This event is dispatched to the object that currently has focus. The related object for this event is the InteractiveObject instance that receives focus if you do not prevent the default behavior. You can prevent the change in focus by calling the preventDefault() method in an event listener that is properly registered with the target object. Flash Player changes the focus and dispatches focusIn and focusOut events as the default behavior.

Defines the value of the type property of a keyFocusChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | The key code value of the key pressed to trigger a keyFocusChange event.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | true if the Shift key modifier is activated; false otherwise.
target | The InteractiveObject instance that currently has focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
keyUp event
Event object type: flash.events.KeyboardEvent
KeyboardEvent.type property = flash.events.KeyboardEvent.KEY_UP

Dispatched when the user releases a key. Mappings between keys and specific characters vary by device and operating system. This event type is generated after such a mapping occurs but before the processing of an input method editor (IME). IMEs are used to enter characters, such as Chinese ideographs, that the standard QWERTY keyboard is ill-equipped to produce. This event occurs after a keyDown event and has the following characteristics:

Defines the value of the type property of a keyUp event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
charCode | Contains the character code value of the key pressed or released.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | The key code value of the key pressed or released.
keyLocation | The location of the key on the keyboard.
shiftKey | true if the Shift key is active; false if it is inactive.
target | The InteractiveObject instance with focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
mouseDown event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.MOUSE_DOWN

Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. If the target is a SimpleButton instance, the SimpleButton instance displays the downState display object as the default behavior. If the target is a selectable text field, the text field begins selection as the default behavior.

Defines the value of the type property of a mouseDown event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
mouseFocusChange event
Event object type: flash.events.FocusEvent
FocusEvent.type property = flash.events.FocusEvent.MOUSE_FOCUS_CHANGE

Dispatched when the user attempts to change focus by using a pointer device. The default behavior of this event is to change the focus and dispatch the corresponding focusIn and focusOut events.

This event is dispatched to the object that currently has focus. The related object for this event is the InteractiveObject instance that receives focus if you do not prevent the default behavior. You can prevent the change in focus by calling preventDefault() in an event listener that is properly registered with the target object. The shiftKey property is not used. Flash Player changes the focus and dispatches focusIn and focusOut events as the default behavior.

Defines the value of the type property of a mouseFocusChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | 0; applies only to keyFocusChange events.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | false; applies only to keyFocusChange events.
target | The InteractiveObject instance that currently has focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
mouseMove event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.MOUSE_MOVE

Dispatched when a user moves the pointing device while it is over an InteractiveObject. If the target is a text field that the user is selecting, the selection is updated as the default behavior.

Defines the value of the type property of a mouseMove event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
mouseOut event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.MOUSE_OUT

Dispatched when the user moves a pointing device away from an InteractiveObject instance. The event target is the object previously under the pointing device. The relatedObject is the object the pointing device has moved to. If the target is a SimpleButton instance, the button displays the upState display object as the default behavior.

Defines the value of the type property of a mouseOut event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device now points.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
mouseOver event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.MOUSE_OVER

Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. The relatedObject is the object that was previously under the pointing device. If the target is a SimpleButton instance, the object displays the overState or upState display object, depending on whether the mouse button is down, as the default behavior.

Defines the value of the type property of a mouseOver event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device was pointing.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
mouseUp event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.MOUSE_UP

Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. If the target is a SimpleButton instance, the object displays the upState display object. If the target is a selectable text field, the text field ends selection as the default behavior.

Defines the value of the type property of a mouseUp event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
mouseWheel event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.MOUSE_WHEEL

Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. If the target is a text field, the text scrolls as the default behavior.

Defines the value of the type property of a mouseWheel event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
delta | The number of lines that that each notch on the mouse wheel represents.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
rollOut event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.ROLL_OUT

Dispatched when the user moves a pointing device away from an InteractiveObject instance. The event target is the object previously under the pointing device or a parent of that object. The relatedObject is the object that the pointing device has moved to. The rollOut events are dispatched consecutively up the parent chain of the object, starting with the object and ending with the highest parent that is neither the root nor an ancestor of the relatedObject.

The purpose of the rollOut event is to simplify the coding of rollover behaviors for display object containers with children. When the mouse leaves the area of a display object or the area of any of its children to go to an object that is not one of its children, the display object dispatches the rollOut event. This is different behavior than that of the mouseOut event, which is dispatched each time the mouse leaves the area of any child object of the display object container, even if the mouse remains over another child object of the display object container.

Defines the value of the type property of a rollOut event object.

This event has the following properties:

Property | Value
bubbles | false
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device now points.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
rollOver event
Event object type: flash.events.MouseEvent
MouseEvent.type property = flash.events.MouseEvent.ROLL_OVER

Dispatched when the user moves a pointing device over an InteractiveObject instance. The event target is the object under the pointing device or a parent of that object. The relatedObject is the object that was previously under the pointing device. The rollOver events are dispatched consecutively down the parent chain of the object, starting with the highest parent that is neither the root nor an ancestor of the relatedObject and ending with the object.

The purpose of the rollOver event is to simplify the coding of rollout behaviors for display object containers with children. When the mouse leaves the area of a display object or the area of any of its children to go to an object that is not one of its children, the display object dispatches the rollOver event. This is different behavior than that of the mouseOver event, which is dispatched each time the mouse enters the area of any child object of the display object container, even if the mouse was already over another child object of the display object container.

Defines the value of the type property of a rollOver event object.

This event has the following properties:

Property | Value
bubbles | false
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device was pointing.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
tabChildrenChange event
Event object type: flash.events.Event
Event.type property = flash.events.Event.TAB_CHILDREN_CHANGE

Dispatched when the value of the object's tabChildren flag changes.

Defines the value of the type property of a tabChildrenChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object whose tabChildren flag has changed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
tabEnabledChange event
Event object type: flash.events.Event
Event.type property = flash.events.Event.TAB_ENABLED_CHANGE

Dispatched when the object's tabEnabled flag changes.

Defines the value of the type property of a tabEnabledChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The InteractiveObject whose tabEnabled flag has changed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
tabIndexChange event
Event object type: flash.events.Event
Event.type property = flash.events.Event.TAB_INDEX_CHANGE

Dispatched when the value of the object's tabIndex property changes.

Defines the value of the type property of a tabIndexChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object whose tabIndex has changed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
Examples

The following example uses the InteractiveObjectExample class, which in turn uses the ChildSprite class to draw a rectangle and then manipulate that rectangle based on various mouse events. This task is accomplished by performing the following steps:
  1. In the InteractiveObjectExample constructor, a new ChildSprite object of type Sprite called child is created, which calls the ChildSprite constructor method to draw the shape and add mouse events for the shape (as explained in the following steps). The child object is added to the top of the display list at coordinates x = 0, y = 0.
  2. In the ChildSprite class, declare the size and overSize properties that are used later in the draw() method and MouseEvent methods.
  3. Declare properties that set the background color to orange, the mouse-over color to dark yellow, and the mouse-down color to light blue.
  4. In the ChildSprite constructor, an orange square is drawn by using methods from the Graphics class and the draw() method.
  5. The constructor adds four MouseEvent event listener methods:
    • mouseOverHandler: redraws a larger 60 x 60 pixel square with a dark-yellow color at the original coordinates.
    • mouseOutHandler: returns the square to its original size and color.
    • mouseDownHandler: redraws a larger 60 x 60 pixel square with a light-blue color at the original coordinates.
    • mouseUpHandler: same as mouseOverHandler.

package {
    import flash.display.Sprite;

    public class InteractiveObjectExample extends Sprite {

        public function InteractiveObjectExample() {
            var child:Sprite = new ChildSprite();
            addChild(child);
        }
    }
}

import flash.display.Sprite;
import flash.events.MouseEvent;

class ChildSprite extends Sprite {
    private var size:uint = 50;
    private var overSize:uint = 60;
    private var backgroundColor:uint = 0xFFCC00;
    private var overColor:uint = 0xCCFF00;
    private var downColor:uint = 0x00CCFF;

    public function ChildSprite() {
        buttonMode = true;
        draw(size, size, backgroundColor);
        addEventListener(MouseEvent.MOUSE_OVER, mouseOverHandler);
        addEventListener(MouseEvent.MOUSE_OUT, mouseOutHandler);
        addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
        addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
    }

    private function draw(w:uint, h:uint, bgColor:uint):void {
        graphics.clear();
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, w, h);
        graphics.endFill();
    }

    public function mouseOverHandler(event:MouseEvent):void {
        trace("mouseOverHandler");
        draw(overSize, overSize, overColor);
    }

    public function mouseOutHandler(event:MouseEvent):void {
        trace("mouseOutHandler");
        draw(size, size, backgroundColor);
    }

    public function mouseDownHandler(event:MouseEvent):void {
        trace("mouseDownHandler");
        draw(overSize, overSize, downColor);
    }

    public function mouseUpHandler(event:MouseEvent):void {
        trace("mouseUpHandler");
        draw(overSize, overSize, overColor);
    }
}


flash.display.InterpolationMethod (Flex™ 2 Language Reference)

Class InterpolationMethod | Properties | Methods | Constants
Package | flash.display
Class | public final class InterpolationMethod
Inheritance | InterpolationMethod Inheritance Object

The InterpolationMethod class provides values for the interpolationMethod parameter in the Graphics.beginGradientFill() and Graphics.lineGradientStyle() methods. This parameter determines the RGB space that Flash Player uses when rendering the gradient.

See also

flash.display.Graphics.beginGradientFill()
flash.display.Graphics.lineGradientStyle()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | LINEAR_RGB : String = "linearRGB" [static] Specifies that the linear RGB interpolation method should be used. | InterpolationMethod
 | RGB : String = "rgb" [static] Specifies that the RGB interpolation method should be used. | InterpolationMethod
Constant detail
LINEAR_RGB constant
public static const LINEAR_RGB:String = "linearRGB"

Specifies that the linear RGB interpolation method should be used. This means that Flash Player uses an RGB color space based on a linear RGB color model.

See also

RGB
RGB constant
public static const RGB:String = "rgb"

Specifies that the RGB interpolation method should be used. This means that Flash Player uses the exponential sRGB (standard RGB) space when rendering the gradient. The sRGB space is a W3C-endorsed standard that defines a non-linear conversion between red, green, and blue component values and the actual intensity of the visible component color.

For example, consider a simple linear gradient between two colors (with the spreadMethod parameter set to SpreadMethod.REFLECT). The different interpolation methods affect the appearance as follows:

InterpolationMethod.LINEAR_RGB | InterpolationMethod.RGB

See also

LINEAR_RGB


flash.display.JointStyle (Flex™ 2 Language Reference)

Class JointStyle | Properties | Methods | Constants | Examples
Package | flash.display
Class | public final class JointStyle
Inheritance | JointStyle Inheritance Object

The JointStyle class is an enumeration of constant values that specify the joint style to use in drawing lines. These constants are provided for use as values in the joints parameter of the flash.display.Graphics.lineStyle() method. The method supports three types of joints: miter, round, and bevel, as the following example shows:

View the examples.

See also

flash.display.Graphics.lineStyle()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BEVEL : String = "bevel" [static] Specifies beveled joints in the joints parameter of the flash.display.Graphics.lineStyle() method. | JointStyle
 | MITER : String = "miter" [static] Specifies mitered joints in the joints parameter of the flash.display.Graphics.lineStyle() method. | JointStyle
 | ROUND : String = "round" [static] Specifies round joints in the joints parameter of the flash.display.Graphics.lineStyle() method. | JointStyle
Constant detail
BEVEL constant
public static const BEVEL:String = "bevel"

Specifies beveled joints in the joints parameter of the flash.display.Graphics.lineStyle() method.

MITER constant
public static const MITER:String = "miter"

Specifies mitered joints in the joints parameter of the flash.display.Graphics.lineStyle() method.

ROUND constant
public static const ROUND:String = "round"

Specifies round joints in the joints parameter of the flash.display.Graphics.lineStyle() method.

Examples

The following example uses the JointStyleExample class to show the result of three different joint styles applied to three sets of joined lines. This task is accomplished by performing the following steps:
  1. The properties of each line are set as follows:
    • The line length is set to 80 pixels.
    • The border color is set to orange.
    • The border size is set to 30 pixels.
    • The highlight color is set to gray.
    • The highlight size is set to zero pixels.
    • The alpha is set to 1, making it solid.
    • The pixel hinting is set to false (strokes not hinted to full pixels).
    • The line scale mode is set to normal, which scales the thickness.
    • The border caps and miter limit are declared but not set, so the default values are used.
  2. The class constructor creates three sets of two connected line segments. The segments start at x = 0, y = 0 by calling the doDrawCorner() method three times using the three joint styles (miter, round, and bevel). Each of the three calls to doDrawCorner() uses the joint style and properties previously listed to draw two connected line segments and associated line highlights. This is done by first creating a new Shape object child and then using methods of the Graphics class to set the line style and draw the lines and highlights. Each instance of child is added to the display list and promptly drawn on the stage.
  3. The connected line segments are then redrawn by using the refreshLayout() method at y = 80 pixels and starting at x = 80 pixels, with a 25-pixel separation between the line segments.
package {
    import flash.display.DisplayObject;
    import flash.display.Graphics;
    import flash.display.JointStyle;
    import flash.display.LineScaleMode;
    import flash.display.Shape;
    import flash.display.Sprite;

    public class JointStyleExample extends Sprite {
        private var size:uint                  = 80;
        private var borderColor:uint           = 0xFFCC00;
        private var borderSize:uint            = 30;
        private var highlightColor:uint        = 0x666666;
        private var highlightSize:uint         = 0;
        private var gutter:uint                = 25;
        private var borderAlpha:uint           = 1;
        private var borderPixelHinting:Boolean = false;
        private var borderScaleMode:String     = LineScaleMode.NORMAL;
        private var borderCaps:String;
        private var borderMiterLimit:uint;

        public function JointStyleExample() {
            doDrawCorner(JointStyle.MITER);
            doDrawCorner(JointStyle.ROUND);
            doDrawCorner(JointStyle.BEVEL);
            refreshLayout();
        }

        private function doDrawCorner(jointStyle:String):void {
            var halfSize:uint = Math.round(size / 2);
            var child:Shape = new Shape();
            child.graphics.lineStyle(borderSize,
                                     borderColor,
                                     borderAlpha,
                                     borderPixelHinting,
                                     borderScaleMode,
                                     borderCaps,
                                     jointStyle,
                                     borderMiterLimit);
            child.graphics.lineTo(0, 0);
            child.graphics.lineTo(size, 0);
            child.graphics.lineTo(halfSize, size);
            child.graphics.endFill();

            child.graphics.moveTo(0, 0);
            child.graphics.lineStyle(highlightSize, highlightColor);
            child.graphics.lineTo(0, 0);
            child.graphics.lineTo(size, 0);
            child.graphics.lineTo(halfSize, size);

            addChild(child);
        }

        private function refreshLayout():void {
            var ln:uint = numChildren;
            var child:DisplayObject;
            var lastChild:DisplayObject = getChildAt(0);
            lastChild.x = size;
            lastChild.y = size;
            for (var i:uint = 1; i < ln; i++) {
                child = getChildAt(i);
                child.x = gutter + lastChild.x + lastChild.width;
                child.y = size;
                lastChild = child;
            }
        }
    }
}


flash.display.LineScaleMode (Flex™ 2 Language Reference)

Class LineScaleMode | Properties | Methods | Constants
Package | flash.display
Class | public final class LineScaleMode
Inheritance | LineScaleMode Inheritance Object

The LineScaleMode class provides values for the scaleMode parameter in the Graphics.lineStyle() method.

See also

flash.display.Graphics.lineStyle()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line scales only vertically. | LineScaleMode
 | NONE : String = "none" [static] With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line never scales. | LineScaleMode
 | NORMAL : String = "normal" [static] With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line always scales when the object is scaled (the default). | LineScaleMode
 | VERTICAL : String = "vertical" [static] With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line scales only horizontally. | LineScaleMode
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line scales only vertically. For example, consider the following circles, drawn with a one-pixel line, and each with the scaleMode parameter set to LineScaleMode.VERTICAL. The circle on the left is scaled only vertically, and the circle on the right is scaled both vertically and horizontally.

NONE constant
public static const NONE:String = "none"

With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line never scales.

NORMAL constant
public static const NORMAL:String = "normal"

With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line always scales when the object is scaled (the default).

VERTICAL constant
public static const VERTICAL:String = "vertical"

With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line scales only horizontally. For example, consider the following circles, drawn with a one-pixel line, and each with the scaleMode parameter set to LineScaleMode.HORIZONTAL. The circle on the left is scaled only horizontally, and the circle on the right is scaled both vertically and horizontally.


flash.display.Loader (Flex™ 2 Language Reference)

Class Loader | Properties | Methods | Events | Examples
Package | flash.display
Class | public class Loader
Inheritance | Loader Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Loader class is used to load SWF files or image (JPG, PNG, or GIF) files. Use the load() method to initiate loading. The loaded display object is added as a child of the Loader object.

Use the URLLoader class to load text or binary data.

The Loader class overrides the following methods that it inherits, because a Loader object can only have one child display object—the display object that it loads. Calling the following methods throws an exception: addChild(), addChildAt(), removeChild(), removeChildAt(), and setChildIndex(). To remove a loaded display object, you must remove the Loader object from its parent DisplayObjectContainer child array.

Note: The ActionScript 2.0 MovieClipLoader and LoadVars classes are not used in ActionScript 3.0. The Loader and URLLoader classes replace them.

When you use the Loader class, consider the Flash Player security model:

  • You can load content from any accessible source.
  • Loading is not allowed if the calling SWF file is in a network sandbox and the file to be loaded is local.
  • If the loaded content is a SWF file written with ActionScript 3.0, it cannot be cross-scripted by a SWF file in another security sandbox unless that cross-scripting arrangement was approved through a call to the System.allowDomain() or the System.allowInsecureDomain() method in the loaded content file.
  • If the loaded content is an AVM1 SWF file (written using ActionScript 1.0 or 2.0), it cannot be cross-scripted by an AVM2 SWF file (written using ActionScript 3.0). However, you can communicate between the two SWF files by using the LocalConnection class.
  • If the loaded content is an image, its data cannot be accessed by a SWF file outside of the security sandbox, unless the domain of that SWF file was included in a cross-domain policy file at the origin domain of the image.
  • Movie clips in the local-with-file-system sandbox cannot script movie clips in the local-with-networking sandbox, and the reverse is also prevented.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

When loading a SWF file from an untrusted source (such as a domain other than that of the Loader object's root SWF file), you may want to define a mask for the Loader object, to prevent the loaded content (which is a child of the Loader object) from drawing to portions of the Stage outside of that mask, as shown in the following code:

import flash.display.*;
 import flash.net.URLRequest;
 var rect:Shape = new Shape();
 rect.graphics.beginFill(0xFFFFFF);
 rect.graphics.drawRect(0, 0, 100, 100);
 rect.graphics.endFill();
 addChild(rect);
 var ldr:Loader = new Loader();
 ldr.mask = rect;
 var url:String = "http://www.unknown.example.com/content.swf";
 var urlReq:URLRequest = new URLRequest(url);
 ldr.load(urlReq);
 addChild(ldr);

View the examples.

See also

flash.display.LoaderInfo
flash.net.URLLoader
flash.display.DisplayObject
Understanding the display architecture
Loading content dynamically

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | content : DisplayObject [read-only] Contains the root display object of the SWF file or image (JPG, PNG, or GIF) file that was loaded by using the load() method. | Loader
 | contentLoaderInfo : LoaderInfo [read-only] Returns a LoaderInfo object corresponding to the object being loaded. | Loader
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Loader()
Creates a Loader object that you can use to load files, such as SWF, JPEG, GIF, or PNG files.
Loader
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
close():void
Cancels a load() method operation that is currently in progress for the Loader instance.
Loader
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
load(request:URLRequest, context:LoaderContext = null):void
Loads a SWF, JPEG, progressive JPEG, unanimated GIF, or PNG file into an object that is a child of this Loader object.
Loader
loadBytes(bytes:ByteArray, context:LoaderContext = null):void
Loads from binary data stored in a ByteArray object.
Loader
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns the string representation of the specified object.
Object
unload():void
Removes a child of this Loader object that was loaded by using the load() method.
Loader
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
content property
content:DisplayObject [read-only]

Contains the root display object of the SWF file or image (JPG, PNG, or GIF) file that was loaded by using the load() method.

Implementation
    public function get content():DisplayObject

Throws
SecurityError — The loaded SWF file or image file belongs to a security sandbox to which you do not have access. For a loaded SWF file, you can avoid this situation by having the file call the Security.allowDomain() method or by having the loading file specify a loaderContext parameter with its securityDomain property set to SecurityDomain.currentDomain when you call the load() or loadBytes() method.

See also

flash.display.DisplayObject
flash.display.Loader.load()
contentLoaderInfo property
contentLoaderInfo:LoaderInfo [read-only]

Returns a LoaderInfo object corresponding to the object being loaded. LoaderInfo objects are shared between the Loader object and the loaded content object. The LoaderInfo object supplies loading progress information and statistics about the loaded file.

Implementation
    public function get contentLoaderInfo():LoaderInfo

See also

flash.display.LoaderInfo
Constructor detail
Loader () constructor
public function Loader()

Creates a Loader object that you can use to load files, such as SWF, JPEG, GIF, or PNG files. Call the load() method to load the asset as a child of the Loader instance. You can then add the Loader object to the display list (for instance, by using the addChild() method of a DisplayObjectContainer instance). The asset appears on the Stage as it loads.

You can also use a Loader instance "offlist," that is without adding it to a display object container on the display list. In this mode, the Loader instance might be used to load a SWF file that contains additional modules of an application.

To detect when the SWF file is finished loading, you can use the events of the LoaderInfo object associated with the contentLoaderInfo property of the Loader object. At that point, the code in the module SWF file can be executed to initialize and start the module. In the offlist mode, a Loader instance might also be used to load a SWF file that contains components or media assets. Again, you can use the LoaderInfo object event notifications to detect when the components is finished loading. At that point, the application can start using the components and media assets in the library of the SWF file by instantiating the ActionScript 3.0 classes that represent those components and assets.

To determine the status of a Loader object, monitor the following events that the LoaderInfo object associated with the contentLoaderInfo property of the Loader object:

  • The open event is dispatched when loading begins.
  • The ioError or securityError event is dispatched if the file cannot be loaded or if an error occured during the load process.
  • The progress event fires continuously while the file is being loaded.
  • The complete event is dispatched when a file completes downloading, but before the loaded movie clip's methods and properties are available.
  • The init event is dispatched after the properties and methods of the loaded SWF file are accessible, so you can begin manipulating the loaded SWF file. This event is dispatched before the complete handler. In streaming SWF files, the init event can occur significantly earlier than the complete event. For most purposes, use the init handler.

See also

flash.display.Loader.load()
flash.display.LoaderInfo
Method detail
close () method
public function close():void

Cancels a load() method operation that is currently in progress for the Loader instance.

See also

flash.display.Loader.load()
load () method
public function load(request:URLRequest, context:LoaderContext = null):void

Loads a SWF, JPEG, progressive JPEG, unanimated GIF, or PNG file into an object that is a child of this Loader object. If you load an animated GIF file, only the first frame is displayed. As the Loader object can contain only a single child, issuing a subsequent load() request terminates the previous request, if still pending, and commences a new load.

A SWF file or image loaded into a Loader object inherits the position, rotation, and scale properties of the parent display objects of the Loader object.

Use the unload() method to remove movies or images loaded with this method, or to cancel a load operation that is in progress.

When you use the load() method, consider the Flash Player security model:

  • You can load content from any accessible source.
  • Loading is not allowed if the calling SWF file is in a network sandbox and the file to be loaded is local.
  • If the loaded content is a SWF file, it cannot be scripted by a SWF file in another security sandbox unless that cross-scripting arrangement was approved through a call to the Security.allowDomain() method in the loaded content file.
  • SWF files written in ActionScript 1.0 or 2.0, which are loaded as AVM1Movie objects, cannot cross-script SWF files written in ActionScript 3.0, which are loaded as Sprite or MovieClip objects. You can use the LocalConnection class to have these files communicate with each other.
  • If the loaded content is an image, its data cannot be accessed by a SWF file outside of the security sandbox, unless the domain of that SWF file was included a cross-domain policy file at the origin domain of the image.
  • Movie clips in the local-with-file-system sandbox cannot cross-script movie clips in the local-with-networking sandbox, and the reverse is also prevented.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
request:URLRequest — The absolute or relative URL of the SWF, JPEG, GIF, or PNG file to be loaded. A relative path must be relative to the main SWF file. Absolute URLs must include the protocol reference, such as http:// or file:///. Filenames cannot include disk drive specifications.
context:LoaderContext (default = null) — A LoaderContext object, which has properties that define the following:
  • Whether or not Flash Player should check for the existence of a policy file upon loading the object
  • The ApplicationDomain for the loaded object
  • The SecurityDomain for the loaded object

For complete details, see the description of the properties in the LoaderContext class.

Events
complete:Event — Dispatched when the file has completed loading. The complete event is always dispatched after the init event.
httpStatus:HTTPStatusEvent — Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code.
init:Event — Dispatched when the properties and methods of the loaded SWF file are accessible. The init event always precedes the complete event.
ioError:IOErrorEvent — Dispatched when an input or output error occurs that causes a load operation to fail.
open:Event — Dispatched when the loading operation starts.
progress:ProgressEvent — Dispatched as data is received while load operation progresses.
securityError:SecurityErrorEvent — Dispatched if the load operation attempts to load data from a server outside the security sandbox.
unload:Event — Dispatched when a loaded object is removed.

Throws
SecurityError — The value of LoaderContext.securityDomain must be either null or SecurityDomain.currentDomain. This reflects the fact that you can only place the loaded media in its natural security sandbox or your own (the latter requires a policy file).
SecurityError — Local SWF files may not set LoaderContext.securityDomain to anything other than null. It is not permitted to import non-local media into a local sandbox, or to place other local media in anything other than its natural sandbox.
SecurityError — If this SWF file is from an untrusted local sandbox and is attempting to access a network URL.
SecurityError — If the applicationDomain or securityDomain properties of the context parameter are from a disallowed domain.
SecurityError — If a local SWF file is attempting to use the securityDomain property of the context parameter.

See also

contentLoaderInfo
flash.net.URLRequest
flash.display.DisplayObject
flash.display.Loader.unload()
flash.display.LoaderInfo
flash.system.LoaderContext
Loading content dynamically
loadBytes () method
public function loadBytes(bytes:ByteArray, context:LoaderContext = null):void

Loads from binary data stored in a ByteArray object.

Parameters
bytes:ByteArray — A ByteArray object. The contents of the ByteArray can be any of the file formats supported by the Loader class: SWF, GIF, JPEG, or PNG.
context:LoaderContext (default = null) — A LoaderContext object. Only the applicationDomain property of the LoaderContext object applies; the checkPolicyFile and securityDomain properties of the LoaderContext object do not apply.

Throws
ArgumentError — If the length property of the ByteArray object is not greater than 0.
IllegalOperationError — If the checkPolicyFile or securityDomain property of the context parameter are non-null.
SecurityError — If the provided applicationDomain property of the context property is from a disallowed domain.

See also

flash.utils.ByteArray
flash.system.LoaderContext.applicationDomain
Loading content dynamically
unload () method
public function unload():void

Removes a child of this Loader object that was loaded by using the load() method. The property of the associated LoaderInfo object is reset to null. The child is not necessarily destroyed because other objects might have references to it; however, it is no longer a child of the Loader object.

As a best practice, before you unload a child SWF file, you should explicitly close any streams in the child SWF file's objects, such as LocalConnection, NetConnection, NetStream, and Sound objects. Otherwise, audio in the child SWF file might continue to play, even though the child SWF file was unloaded. To close streams in the child SWF file, add an event listener to the child that listens for the unload event. When the parent calls Loader.unload(), the unload event is dispatched to the child. The following code shows how you might do this:

function closeAllStreams(evt:Event) {
    myNetStream.close();
    mySound.close();
    myNetConnection.close();
    myLocalConnection.close();
}

myMovieClip.loaderInfo.addEventListener(Event.UNLOAD, closeAllStreams);

See also

Loader.load()
flash.media.Sound.close()
flash.net.LocalConnection.close()
flash.net.NetConnection.close()
flash.net.NetStream.close()
delete operator
Examples

The following example uses the LoaderExample class to illustrate how various event listeners are used. This task is accomplished by performing the following steps:
  1. A url property is created, which is the location and name of the image file
  2. In the LoaderExample constructor, a new Loader object named loader is created, which is then passed to the configureListeners() method, described in step 3.
  3. The constructor creates a new instance of a URLRequest object, request, with url passed so that the file name and location are known.
  4. The request object is passed to the loader object's load() method, which loads the image onto the display list.
  5. A clickHandler event listener is registered for the click event on the loader. After a mouse click, the loaded image is unloaded.
  6. The configureListeners() method adds seven event listeners by using the following methods:
    • The completeHandler() method executes when the image finishes loading.
    • The httpStatusHandler() method executes if the image is not loaded locally and only if the network request is made available and the Flash Player can detect it.
    • The initHandler() method executes before the completeHandler() method and after the progressHandler() method. Generally, the init event is more useful when loading SWF files.
    • The ioErrorHandler() method executes if the image file is not available or not accessible.
    • The openHandler() method executes when the image file is first opened.
    • The progressHandler() method executes when the image file starts to load and again when the image is finished loading.
    • The unLoadHandler() method executes when the image is unloaded by using the unload() method when the user clicks the image.

Keep in mind the following requirements:

  • This example requires that you place a file named Image.gif in the same directory as the compiled SWF file. Use an image that has an area that fits within the dimensions of the main SWF file.
  • Although this example makes use of all events available to the LoaderInfo object, most situations require only a subset. In particular, when loading only an image file, the complete event (and perhaps the ioError event) are sufficient when loading a local image.
package {
    import flash.display.Loader;
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.URLRequest;

    public class LoaderExample extends Sprite {
        private var url:String = "Image.gif";

        public function LoaderExample() {
            var loader:Loader = new Loader();
            configureListeners(loader.contentLoaderInfo);
            loader.addEventListener(MouseEvent.CLICK, clickHandler);

            var request:URLRequest = new URLRequest(url);
            loader.load(request);

            addChild(loader);
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(Event.INIT, initHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(Event.UNLOAD, unLoadHandler);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
        }

        private function initHandler(event:Event):void {
            trace("initHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler: bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function unLoadHandler(event:Event):void {
            trace("unLoadHandler: " + event);
        }

        private function clickHandler(event:MouseEvent):void {
            trace("clickHandler: " + event);
            var loader:Loader = Loader(event.target);
            loader.unload();
        }
    }
}


flash.display.LoaderInfo (Flex™ 2 Language Reference)

Class LoaderInfo | Properties | Methods | Events | Examples
Package | flash.display
Class | public class LoaderInfo
Inheritance | LoaderInfo Inheritance EventDispatcher Inheritance Object

The LoaderInfo class provides information about a loaded SWF file or a loaded image file (JPEG, GIF, or PNG). LoaderInfo objects are available for any display object. The information provided includes load progress, the URLs of the loader and loaded content, the number of bytes total for the media, and the nominal height and width of the media.

You can access LoaderInfo objects in two ways:

  • The contentLoaderInfo property of a flash.display.Loader object— The contentLoaderInfo property is always available for any Loader object. For a Loader object that has not called the load() or loadBytes() method, or that has not sufficiently loaded, attempting to access many of the properties of the contentLoaderInfo property throws an error.
  • The loaderInfo property of a display object.

The contentLoaderInfo property of a Loader object provides information about the content that the Loader object is loading, whereas the loaderInfo property of a DisplayObject provides information about the root SWF file for that display object.

The loaderInfo property of an object loaded with a Loader object (a SWF file or a bitmap) refers to the same LoaderInfo object as the contentLoaderInfo property of the Loader object. In other words, a LoaderInfo object is shared between a loaded object file and the Loader object that loaded it. Because the instance of the main class of the SWF file has no Loader object, the loaderInfo property is the only way to access the LoaderInfo for the instance of the main class of the SWF file.

The following diagram shows the different uses of the LoaderInfo object—for the instance of the main class of the SWF file, for the contentLoaderInfo property of a Loader object, and for the loaderInfo property of a loaded object:

An image of different LoaderInfo situations

When a loading operation is not complete, some properties of the contentLoaderInfo property of a Loader object are not available. You can obtain some properties, such as bytesLoaded, bytesTotal, url, loaderURL, and applicationDomain. When the loaderInfo object dispatches the init event, you can access all properties of the loaderInfo object and the loaded image or SWF file.

Note: All properties of LoaderInfo objects are read-only.

The EventDispatcher.dispatchEvent() method, which the Loaderinfo class inherits from the EventDispatcher class, is not applicable to LoaderInfo objects. If you call dispatchEvent() on a LoaderInfo object, an IllegalOperationError exception is thrown.

View the examples.

See also

flash.display.Loader
flash.display.Loader.content
flash.display.DisplayObject
flash.display.DisplayObject.loaderInfo
Loading content dynamically

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | actionScriptVersion : uint [read-only] The ActionScript version of the loaded SWF file. | LoaderInfo
 | applicationDomain : ApplicationDomain [read-only] When an external SWF file is loaded, all ActionScript 3.0 definitions contained in the loaded class are stored in the applicationDomain property. | LoaderInfo
 | bytesLoaded : uint [read-only] The number of bytes that are loaded for the media. | LoaderInfo
 | bytesTotal : uint [read-only] The number of compressed bytes in the entire media file. | LoaderInfo
 | childAllowsParent : Boolean [read-only] Expresses the trust relationship from content (child) to the Loader (parent). | LoaderInfo
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | content : DisplayObject [read-only] The loaded object associated with this LoaderInfo object. | LoaderInfo
 | contentType : String [read-only] The MIME type of the loaded file. | LoaderInfo
 | frameRate : Number [read-only] The nominal frame rate, in frames per second, of the loaded SWF file. | LoaderInfo
 | height : int [read-only] The nominal height of the loaded file. | LoaderInfo
 | loader : Loader [read-only] The Loader object associated with this LoaderInfo object. | LoaderInfo
 | loaderURL : String [read-only] The URL of the SWF file that initiated the loading of the media described by this LoaderInfo object. | LoaderInfo
 | parameters : Object [read-only] An object that contains name-value pairs that represent the parameters provided to the loaded SWF file. | LoaderInfo
 | parentAllowsChild : Boolean [read-only] Expresses the trust relationship from Loader (parent) to the content (child). | LoaderInfo
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | sameDomain : Boolean [read-only] Expresses the domain relationship between the loader and the content: true if they have the same origin domain; false otherwise. | LoaderInfo
 | sharedEvents : EventDispatcher [read-only] An EventDispatcher instance that can be used to exchange events across security boundaries. | LoaderInfo
 | swfVersion : uint [read-only] The file format version of the loaded SWF file. | LoaderInfo
 | url : String [read-only] The URL of the media being loaded. | LoaderInfo
 | width : int [read-only] The nominal width of the loaded content. | LoaderInfo
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | complete | Dispatched when data has loaded successfully. | LoaderInfo
 | httpStatus | Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code. | LoaderInfo
 | init | Dispatched when the properties and methods of a loaded SWF file are accessible. | LoaderInfo
 | ioError | Dispatched when an input or output error occurs that causes a load operation to fail. | LoaderInfo
 | open | Dispatched when a load operation starts. | LoaderInfo
 | progress | Dispatched when data is received as the download operation progresses. | LoaderInfo
 | securityError | Dispatched if a call to the load() method of a Loader object attempts to load data from a server outside the security sandbox. | LoaderInfo
 | unload | Dispatched by a LoaderInfo object whenever a loaded object is removed by using the unload() method of the Loader object, or when a second load is performed by the same Loader object and the original content is removed prior to the load beginning. | LoaderInfo
Property detail
actionScriptVersion property
actionScriptVersion:uint [read-only]

The ActionScript version of the loaded SWF file. The language version is specified by using the enumerations in the ActionScriptVersion class, such as ActionScriptVersion.ACTIONSCRIPT2 and ActionScriptVersion.ACTIONSCRIPT3.

Note: This property always has a value of either ActionScriptVersion.ACTIONSCRIPT2 or ActionScriptVersion.ACTIONSCRIPT3. ActionScript 1.0 and 2.0 are both reported as ActionScriptVersion.ACTIONSCRIPT2 (version 2.0). This property only distinguishes ActionScript 1.0 and 2.0 from ActionScript 3.0.

Implementation
    public function get actionScriptVersion():uint

Throws
Error — If the file is not downloaded sufficiently to retrieve the requested information.
Error — If the file is not a SWF file.

See also

flash.display.ActionScriptVersion
applicationDomain property
applicationDomain:ApplicationDomain [read-only]

When an external SWF file is loaded, all ActionScript 3.0 definitions contained in the loaded class are stored in the applicationDomain property.

All code in a SWF file is defined to exist in an application domain. The current application domain is where your main application runs. The system domain contains all application domains, including the current domain, which means that it contains all Flash Player classes.

All application domains, except the system domain, have an associated parent domain. The parent domain of your main application's applicationDomain is the system domain. Loaded classes are defined only when their parent doesn't already define them. You cannot override a loaded class definition with a newer definition.

For usage examples of application domains, see the "Client System Environment" chapter in Programming ActionScript 3.0.

Implementation
    public function get applicationDomain():ApplicationDomain

Throws
SecurityError — This security sandbox of the caller is not allowed to access this ApplicationDomain.

See also

flash.system.ApplicationDomain
Loading content dynamically
ApplicationDomain class
bytesLoaded property
bytesLoaded:uint [read-only]

The number of bytes that are loaded for the media. When this number equals the value of bytesTotal, all of the bytes are loaded.

Implementation
    public function get bytesLoaded():uint
bytesTotal property
bytesTotal:uint [read-only]

The number of compressed bytes in the entire media file.

Before the first progress event is dispatched by this LoaderInfo object's corresponding Loader object, bytesTotal is 0. After the first progress event from the Loader object, bytesTotal reflects the actual number of bytes to be downloaded.

Implementation
    public function get bytesTotal():uint

See also

flash.events.ProgressEvent
flash.display.Loader
childAllowsParent property
childAllowsParent:Boolean [read-only]

Expresses the trust relationship from content (child) to the Loader (parent). If the child has allowed the parent access, true; otherwise, false. This property is set to true if the child object has called the allowDomain() method to grant permission to the parent domain or if a cross-domain policy is loaded at the child domain that grants permission to the parent domain. If child and parent are in the same domain, this property is set to true.

For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

Implementation
    public function get childAllowsParent():Boolean

Throws
Error — Thrown if the file is not downloaded sufficiently to retrieve the requested information.
content property
content:DisplayObject [read-only]

The loaded object associated with this LoaderInfo object.

Implementation
    public function get content():DisplayObject

Throws
SecurityError — If the object accessing this API is prevented from accessing the loaded object due to security restrictions. This situation can occur, for instance, when a Loader object attempts to access the contentLoaderInfo.content property and it is not granted security permission to access the loaded content.

For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.
contentType property
contentType:String [read-only]

The MIME type of the loaded file. The value is null if not enough of the file has loaded for Flash Player to determine the type. The following list gives the possible values:

  • "application/x-shockwave-flash"
  • "image/jpeg"
  • "image/gif"
  • "image/png"

Implementation
    public function get contentType():String
frameRate property
frameRate:Number [read-only]

The nominal frame rate, in frames per second, of the loaded SWF file. This number is often an integer, but need not be.

This value may differ from the actual frame rate in use. Flash Player only uses a single frame rate for all loaded SWF files at any one time, and this frame rate is determined by the nominal frame rate of the main SWF file. Also, Flash Player might not be able to achieve the main frame rate, depending on hardware, sound synchronization, and other factors.

Implementation
    public function get frameRate():Number

Throws
Error — If the file is not downloaded sufficiently to retrieve the requested information.
Error — If the file is not a SWF file.
height property
height:int [read-only]

The nominal height of the loaded file. This value might differ from the actual height at which the content is displayed, since the loaded content or its parent display objects might be scaled.

Implementation
    public function get height():int

Throws
Error — If the file is not downloaded sufficiently to retrieve the requested information.
loader property
loader:Loader [read-only]

The Loader object associated with this LoaderInfo object. If this LoaderInfo object is the loaderInfo property of the instance of the main class of the SWF file, no Loader object is associated.

Implementation
    public function get loader():Loader

Throws
SecurityError — If the object accessing this API is prevented from accessing the Loader object because of security restrictions. This can occur, for instance, when a loaded SWF file attempts to access its loaderInfo.loader property and it is not granted security permission to access the loading SWF file.

For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.
loaderURL property
loaderURL:String [read-only]

The URL of the SWF file that initiated the loading of the media described by this LoaderInfo object. For the instance of the main class of the SWF file, this URL is the same as the SWF file's own URL.

Implementation
    public function get loaderURL():String
parameters property
parameters:Object [read-only]

An object that contains name-value pairs that represent the parameters provided to the loaded SWF file.

You can use a for-in loop to extract all the names and values from the parameters object.

The two sources of parameters are: the query string in the URL of the main SWF file, and the value of the FlashVars HTML parameter (this affects only the main SWF file).

The parameters property replaces the ActionScript 1.0 and 2.0 technique of providing SWF file parameters as properties of the main timeline.

The value of the parameters property is null for Loader objects that contain SWF files that use ActionScript 1.0 or 2.0. It is only non-null for Loader objects that contain SWF files that use ActionScript 3.0.

Implementation
    public function get parameters():Object
parentAllowsChild property
parentAllowsChild:Boolean [read-only]

Expresses the trust relationship from Loader (parent) to the content (child). If the parent has allowed the child access, true; otherwise, false. This property is set to true if the parent object called the allowDomain() method to grant permission to the child domain or if a cross-domain policy file is loaded at the parent domain granting permission to the child domain. If child and parent are in the same domain, this property is set to true.

For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

Implementation
    public function get parentAllowsChild():Boolean

Throws
Error — Thrown if the file is not downloaded sufficiently to retrieve the requested information.
sameDomain property
sameDomain:Boolean [read-only]

Expresses the domain relationship between the loader and the content: true if they have the same origin domain; false otherwise.

Implementation
    public function get sameDomain():Boolean

Throws
Error — Thrown if the file is not downloaded sufficiently to retrieve the requested information.
sharedEvents property
sharedEvents:EventDispatcher [read-only]

An EventDispatcher instance that can be used to exchange events across security boundaries. Even when the loader and the loadee do not trust one another, both can access sharedEvents.

Implementation
    public function get sharedEvents():EventDispatcher
swfVersion property
swfVersion:uint [read-only]

The file format version of the loaded SWF file. The file format is specified using the enumerations in the SWFVersion class, such as SWFVersion.FLASH7 and SWFVersion.FLASH9.

Implementation
    public function get swfVersion():uint

Throws
Error — If the file is not downloaded sufficiently to retrieve the requested information.
Error — If the file is not a SWF file.

See also

flash.display.SWFVersion
url property
url:String [read-only]

The URL of the media being loaded.

Before the first progress event is dispatched by this LoaderInfo object's corresponding Loader object, the value of the url property might reflect only the initial URL specified in the call to the load() method of the Loader object. After the first progress event, the url property reflects the media's final URL, after any redirects and relative URLs are resolved.

Implementation
    public function get url():String

See also

flash.display.Loader.load()
width property
width:int [read-only]

The nominal width of the loaded content. This value might differ from the actual width at which the content is displayed, since the loaded content or its parent display objects might be scaled.

Implementation
    public function get width():int

Throws
Error — If the file is not downloaded sufficiently to retrieve the requested information.
Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched when data has loaded successfully. The complete event is always dispatched after the init event.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

Loader.load()
httpStatus event
Event object type: flash.events.HTTPStatusEvent
HTTPStatusEvent.type property = flash.events.HTTPStatusEvent.HTTP_STATUS

Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code.

Defines the value of the type property of a httpStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
status | The HTTP status code returned by the server.
target | The network object receiving an HTTP status code.

See also

Loader.load()
init event
Event object type: flash.events.Event
Event.type property = flash.events.Event.INIT

Dispatched when the properties and methods of a loaded SWF file are accessible. A LoaderInfo object dispatches the init event when the following two conditions exist:

  • All properties and methods associated with the loaded object and those associated with the LoaderInfo object are accessible.
  • The constructors for all child objects have completed.

The init event always precedes the complete event.

Defines the value of the type property of an init event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The LoaderInfo object associated with the SWF file being loaded.

See also

Loader.load()
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input or output error occurs that causes a load operation to fail.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.

See also

Loader.load()
open event
Event object type: flash.events.Event
Event.type property = flash.events.Event.OPEN

Dispatched when a load operation starts.

Defines the value of the type property of an open event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has opened a connection.

See also

Loader.load()
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched when data is received as the download operation progresses.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.

See also

Loader.load()
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched if a call to the load() method of a Loader object attempts to load data from a server outside the security sandbox. To prevent this error, you can place a policy file on the server. Details about the error are included in the text property of the dispatched SecurityErrorEvent object.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

flash.system.Security
flash.display.Loader.load()
Flash Player Security
unload event
Event object type: flash.events.Event
Event.type property = flash.events.Event.UNLOAD

Dispatched by a LoaderInfo object whenever a loaded object is removed by using the unload() method of the Loader object, or when a second load is performed by the same Loader object and the original content is removed prior to the load beginning.

Defines the value of the type property of an unload event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The LoaderInfo object associated with the SWF file being unloaded or replaced.

See also

Loader.load()
Loader.unload()
Examples

The following example uses the LoaderInfoExample class to display an image on the stage. This is accomplished by performing the following steps:
  1. A property url is created, which is the location and name of the image.
  2. The class constructor creates a Loader object named loader.
  3. The loader object instantiates an event listener to ensure that the image loads properly.
  4. The constructor creates a new instance of a URLRequest object, request, with url passed so that the file name and location are known.
  5. The request object is then passed to the load() method of the loader object, which loads the image onto the display list.

Important: This example requires that you add a file named Image.gif in the same directory as the compiled SWF file. Use an image that has an area that fits within the dimensions of the main SWF file.

package {
    import flash.display.Loader;
    import flash.display.LoaderInfo;
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.URLRequest;

    public class LoaderInfoExample extends Sprite {
        private var url:String = "Image.gif";

        public function LoaderInfoExample() {
            var loader:Loader = new Loader();
            loader.contentLoaderInfo.addEventListener(Event.INIT, initHandler);
            loader.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            var request:URLRequest = new URLRequest(url);
            loader.load(request);
            addChild(loader);
        }

        private function initHandler(event:Event):void {
            var loader:Loader = Loader(event.target.loader);
            var info:LoaderInfo = LoaderInfo(loader.contentLoaderInfo);
            trace("initHandler: loaderURL=" + info.loaderURL + " url=" + info.url);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }
    }
}


flash.display.MorphShape (Flex™ 2 Language Reference)

Class MorphShape | Properties | Methods | Events
Package | flash.display
Class | public final class MorphShape
Inheritance | MorphShape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The MorphShape class represents MorphShape objects on the display list. You cannot create MorphShape objects directly in ActionScript; they are created when you create a shape tween in the Flash authoring tool.

See also

Understanding the display architecture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject


flash.display.MovieClip (Flex™ 2 Language Reference)

Class MovieClip | Properties | Methods | Events | Examples
Package | flash.display
Class | public dynamic class MovieClip
Inheritance | MovieClip Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | FlexMovieClip, SystemManager

The MovieClip class inherits from the following classes: Sprite, DisplayObjectContainer, InteractiveObject, DisplayObject, and EventDispatcher.

Unlike the Sprite object, a MovieClip object has a timeline.

The methods for the MovieClip class provide the same functionality as actions that target movie clips. Some additional methods do not have equivalent actions in the Actions toolbox in the Actions panel in the Flash authoring tool.

If you modify any of the following properties of a MovieClip object that contains a motion tween, Flash Player stops the playhead in that MovieClip object: alpha, blendMode, filters, height, opaqueBackground, rotation, scaleX, scaleY, scale9Grid, scrollRect, transform, visible, width, x, or y. However, it does not stop the playhead in any child MovieClip objects of that MovieClip object.

View the examples.

See also

Understanding the display architecture
Controlling ActionScript 3.0 movie clips

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | currentFrame : int [read-only] Specifies the number of the frame in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
 | currentLabel : String [read-only] The current label in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
 | currentLabels : Array [read-only] Returns an array of FrameLabel objects from the current scene. | MovieClip
 | currentScene : Scene [read-only] The current scene in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | enabled : Boolean A Boolean value that indicates whether a movie clip is enabled. | MovieClip
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
 | framesLoaded : int [read-only] The number of frames that are loaded from a streaming SWF file. | MovieClip
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
 | scenes : Array [read-only] An array of Scene objects, each listing the name, the number of frames, and the frame labels for a scene in the MovieClip instance. | MovieClip
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | totalFrames : int [read-only] The total number of frames in the MovieClip instance. | MovieClip
 | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | MovieClip
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MovieClip()
Creates a new MovieClip instance.
MovieClip
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
gotoAndPlay(frame:Object, scene:String = null):void
Starts playing the SWF file at the specified frame.
MovieClip
gotoAndStop(frame:Object, scene:String = null):void
Brings the playhead to the specified frame of the movie clip and stops it there.
MovieClip
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
nextFrame():void
Sends the playhead to the next frame and stops it.
MovieClip
nextScene():void
Moves the playhead to the next scene of the MovieClip instance.
MovieClip
play():void
Moves the playhead in the timeline of the movie clip.
MovieClip
prevFrame():void
Sends the playhead to the previous frame and stops it.
MovieClip
prevScene():void
Moves the playhead to the previous scene of the MovieClip instance.
MovieClip
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
stop():void
Stops the playhead in the movie clip.
MovieClip
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
currentFrame property
currentFrame:int [read-only]

Specifies the number of the frame in which the playhead is located in the timeline of the MovieClip instance. If the movie clip has multiple scenes, this value is the frame number in the current scene.

Implementation
    public function get currentFrame():int

See also

Controlling ActionScript 3.0 movie clips

Example
The following code uses the gotoAndStop() method and the currentFrame property to direct the playhead of the mc1 movie clip to advance five frames ahead of its current location and stop:
mc1.gotoAndStop(mc1.currentFrame + 5);

currentLabel property
currentLabel:String [read-only]

The current label in which the playhead is located in the timeline of the MovieClip instance.

Implementation
    public function get currentLabel():String

See also

Controlling ActionScript 3.0 movie clips

Example
The following code illustrates how to access the currentLabel property of a MovieClip object named mc1:
trace(mc1.currentLabel);

currentLabels property
currentLabels:Array [read-only]

Returns an array of FrameLabel objects from the current scene. If the MovieClip instance does not use scenes, the array includes all frame labels from the entire MovieClip instance.

Implementation
    public function get currentLabels():Array

See also

flash.display.FrameLabel
Controlling ActionScript 3.0 movie clips

Example
The following code illustrates how to use the currentLabels property of a MovieClip object named mc1:
import flash.display.FrameLabel;

var labels:Array = mc1.currentLabels;

for (var i:uint = 0; i < labels.length; i++) {
    var label:FrameLabel = labels[i];
    trace("frame " + label.frame + ": " + label.name);
}

currentScene property
currentScene:Scene [read-only]

The current scene in which the playhead is located in the timeline of the MovieClip instance.

Implementation
    public function get currentScene():Scene

See also

Scene
Controlling ActionScript 3.0 movie clips

Example
The following code illustrates how to use the currentScene property of a MovieClip object named mc1:
import flash.display.Scene;

var scene:Scene = mc1.currentScene;
trace(scene.name + ": " + scene.numFrames + " frames");

enabled property
enabled:Boolean [read-write]

A Boolean value that indicates whether a movie clip is enabled. The default value of enabled is true. If enabled is set to false, the movie clip's Over, Down, and Up frames are disabled. The movie clip continues to receive events (for example, mouseDown, mouseUp, keyDown, and keyUp).

The enabled property governs only the button-like properties of a movie clip. You can change the enabled property at any time; the modified movie clip is immediately enabled or disabled. If enabled is set to false, the object is not included in automatic tab ordering.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void

Example
The following code illustrates how to use the enabled property to disable the button-like properties of a MovieClip object named mc1:
mc1.enabled = false;

framesLoaded property
framesLoaded:int [read-only]

The number of frames that are loaded from a streaming SWF file. You can use the frameLoaded property to determine whether the contents of a specific frame and all the frames before it loaded and are available locally in the browser. You can also use it to monitor the downloading of large SWF files. For example, you might want to display a message to users indicating that the SWF file is loading until a specified frame in the SWF file finishes loading.

If the movie clip contains multiple scenes, the framesLoaded property returns the number of frames loaded for all scenes in the movie clip.

Implementation
    public function get framesLoaded():int

See also

Loader class
Controlling ActionScript 3.0 movie clips

Example
The following code illustrates how to use the framesLoaded property and the totalFrames property to determine if a streaming MovieClip object named mc1 is fully loaded:
if (mc1.framesLoaded == mc1.totalFrames) {
    trace("OK.");
}

scenes property
scenes:Array [read-only]

An array of Scene objects, each listing the name, the number of frames, and the frame labels for a scene in the MovieClip instance.

Implementation
    public function get scenes():Array

See also

Scene
Controlling ActionScript 3.0 movie clips

Example
The following code illustrates how to use the scenes property of a MovieClip object named mc1:
import flash.display.Scene;

for (var i:uint = 0; i < mc1.scenes.length; i++) {
    var scene:Scene = mc1.scenes[i];
    trace("scene " + scene.name + ": " + scene.numFrames + " frames");
}

totalFrames property
totalFrames:int [read-only]

The total number of frames in the MovieClip instance.

If the movie clip contains multiple frames, the totalFrames property returns the total number of frames in all scenes in the movie clip.

Implementation
    public function get totalFrames():int

See also

Controlling ActionScript 3.0 movie clips

Example
The following code illustrates the use of the totalFrames property of a MovieClip object named mc1:
 trace(mc1.totalFrames);

trackAsMenu property
trackAsMenu:Boolean [read-write]

Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. The trackAsMenu property lets you create menus. You can set the trackAsMenu property on any SimpleButton or MovieClip object. The default value of the trackAsMenu property is false.

You can change the trackAsMenu property at any time; the modified movie clip immediately uses the new behavior.

Implementation
    public function get trackAsMenu():Boolean
    public function set trackAsMenu(value:Boolean):void

Example
The following code illustrates how to use the trackAsMenu property to enable mouse release events for a MovieClip object named mc1:
 mc1.trackAsMenu = true;

Constructor detail
MovieClip () constructor
public function MovieClip()

Creates a new MovieClip instance. After creating the MovieClip, call the addChild() or addChildAt() method of a display object container that is onstage.

Method detail
gotoAndPlay () method
public function gotoAndPlay(frame:Object, scene:String = null):void

Starts playing the SWF file at the specified frame. This happens after all remaining actions in the frame have finished executing. To specify a scene as well as a frame, specify a value for the scene parameter.

Parameters
frame:Object — A number representing the frame number, or a string representing the label of the frame, to which the playhead is sent. If you specify a number, it is relative to the scene you specify. If you do not specify a scene, Flash Player uses the current scene to determine the global frame number to play. If you do specify a scene, the playhead jumps to the frame number in the specified scene.
scene:String (default = null) — The name of the scene to play. This parameter is optional.

See also

Controlling ActionScript 3.0 movie clips

Example
The following code uses the gotoAndPlay() method to direct the playhead of the mc1 movie clip to advance five frames ahead of its current location:
mc1.gotoAndPlay(mc1.currentFrame + 5);

The following code uses the gotoAndPlay() method to direct the playhead of the mc1 movie clip to the frame labeled "intro" in the scene named "Scene 12":
mc1.gotoAndPlay("intro", "Scene 12");

gotoAndStop () method
public function gotoAndStop(frame:Object, scene:String = null):void

Brings the playhead to the specified frame of the movie clip and stops it there. This happens after all remaining actions in the frame have finished executing. If you want to specify a scene in addition to a frame, specify a scene parameter.

Parameters
frame:Object — A number representing the frame number, or a string representing the label of the frame, to which the playhead is sent. If you specify a number, it is relative to the scene you specify. If you do not specify a scene, Flash Player uses the current scene to determine the global frame number at which to go to and stop. If you do specify a scene, the playhead goes to the frame number in the specified scene and stops.
scene:String (default = null) — The name of the scene. This parameter is optional.

Throws
ArgumentError — If the scene or frame specified are not found in this movie clip.

See also

Controlling ActionScript 3.0 movie clips

Example
The following code uses the gotoAndStop() method and the currentFrame property to direct the playhead of the mc1 movie clip to advance five frames ahead of its current location and stop:
mc1.gotoAndStop(mc1.currentFrame + 5);

The following code uses the gotoAndStop() to direct the playhead of the mc1 movie clip to the frame labeled "finale" in the scene named "Scene 12" and stop the playhead:
mc1.gotoAndStop("finale", "Scene 12");

nextFrame () method
public function nextFrame():void

Sends the playhead to the next frame and stops it. This happens after all remaining actions in the frame have finished executing.

See also

prevFrame()
Controlling ActionScript 3.0 movie clips

Example
In the following example, two SimpleButton objects control the timeline. The prev button moves the playhead to the previous frame, and the nextBtn button moves the playhead to the next frame:

import flash.events.MouseEvent;

mc1.stop();
prevBtn.addEventListener(MouseEvent.CLICK, goBack);
nextBtn.addEventListener(MouseEvent.CLICK, goForward);

function goBack(event:MouseEvent):void {
    mc1.prevFrame();
}

function goForward(event:MouseEvent):void {
    mc1.nextFrame();
}

nextScene () method
public function nextScene():void

Moves the playhead to the next scene of the MovieClip instance. This happens after all remaining actions in the frame have finished executing.

See also

Controlling ActionScript 3.0 movie clips

Example
In the following example, two SimpleButton objects control the timeline. The prevBtn button moves the playhead to the previous scene, and the nextBtn button moves the playhead to the next scene:

import flash.events.MouseEvent;

mc1.stop();
prevBtn.addEventListener(MouseEvent.CLICK, goBack);
nextBtn.addEventListener(MouseEvent.CLICK, goForward);

function goBack(event:MouseEvent):void {
    mc1.prevScene();
}

function goForward(event:MouseEvent):void {
    mc1.nextScene();
}

play () method
public function play():void

Moves the playhead in the timeline of the movie clip.

See also

gotoAndPlay()
Controlling ActionScript 3.0 movie clips

Example
The following code uses the stop() method to stop a movie clip named mc1 and to resume playing when the user clicks the text field named continueText:

import flash.text.TextField;
import flash.events.MouseEvent;

var continueText:TextField = new TextField();
continueText.text = "Play movie...";
addChild(continueText);

mc1.stop();
continueText.addEventListener(MouseEvent.CLICK, resumeMovie);

function resumeMovie(event:MouseEvent):void {
    mc1.play();
}

prevFrame () method
public function prevFrame():void

Sends the playhead to the previous frame and stops it. This happens after all remaining actions in the frame have finished executing.

See also

Controlling ActionScript 3.0 movie clips

Example
In the following example, two SimpleButton objects control the timeline. The prev button moves the playhead to the previous frame, and the nextBtn button moves the playhead to the next frame:

import flash.events.MouseEvent;

mc1.stop();
prevBtn.addEventListener(MouseEvent.CLICK, goBack);
nextBtn.addEventListener(MouseEvent.CLICK, goForward);

function goBack(event:MouseEvent):void {
    mc1.prevFrame();
}

function goForward(event:MouseEvent):void {
    mc1.nextFrame();
}

prevScene () method
public function prevScene():void

Moves the playhead to the previous scene of the MovieClip instance. This happens after all remaining actions in the frame have finished executing.

See also

Controlling ActionScript 3.0 movie clips

Example
In the following example, two SimpleButton objects control the timeline. The prevBtn button moves the playhead to the previous scene, and the nextBtn button moves the playhead to the next scene:

import flash.events.MouseEvent;

mc1.stop();
prevBtn.addEventListener(MouseEvent.CLICK, goBack);
nextBtn.addEventListener(MouseEvent.CLICK, goForward);

function goBack(event:MouseEvent):void {
    mc1.prevScene();
}

function goForward(event:MouseEvent):void {
    mc1.nextScene();
}

stop () method
public function stop():void

Stops the playhead in the movie clip.

See also

Controlling ActionScript 3.0 movie clips
Examples

The following example uses the MovieClipExample class to illustrate how to monitor various properties of a MovieClip. This task is accomplished by performing the following steps:
  1. The constructor function defines a text field, which is used to display values of properties of the MovieClipExample object (which extends MovieClip).
  2. The return value of the getPropertiesString() method is used as text for the outputText text field. The getPropertiesString() method returns a string that is populated with values of the following properties of the movie clip: currentFrame, currentLabel, currentScene, framesLoaded, totalFrames, and trackAsMenu.
  3. Two lines of code in the constructor function adjust the width and height properties of the outputText text field.
  4. The last line of the constructor function adds the outputText text field to the display list.

package {
    import flash.display.MovieClip;
    import flash.text.TextField;

    public class MovieClipExample extends MovieClip {

        public function MovieClipExample() {
            var outputText:TextField = new TextField();
            outputText.text = getPropertiesString();
            outputText.width = stage.stageWidth;
            outputText.height = outputText.textHeight;
            addChild(outputText);
        }

        private function getPropertiesString():String {
            var str:String = ""
                + "currentFrame: " + currentFrame + "\n"
                + "currentLabel: " + currentLabel + "\n"
                + "currentScene: " + currentScene + "\n"
                + "framesLoaded: " + framesLoaded + "\n"
                + "totalFrames: " + totalFrames + "\n"
                + "trackAsMenu: " + trackAsMenu + "\n";
            return str;
        }
    }
}


flash.display.PixelSnapping (Flex™ 2 Language Reference)

Class PixelSnapping | Properties | Methods | Constants
Package | flash.display
Class | public final class PixelSnapping
Inheritance | PixelSnapping Inheritance Object

The PixelSnapping class is an enumeration of constant values for setting the pixel snapping options by using the pixelSnapping property of a Bitmap object.

See also

flash.display.Bitmap.pixelSnapping

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ALWAYS : String = "always" [static] A constant value used in the pixelSnapping property of a Bitmap object to specify that the bitmap image is always snapped to the nearest pixel, independent of any transformation. | PixelSnapping
 | AUTO : String = "auto" [static] A constant value used in the pixelSnapping property of a Bitmap object to specify that the bitmap image is snapped to the nearest pixel if it is drawn with no rotation or skew and it is drawn at a scale factor of 99.9% to 100.1%. | PixelSnapping
 | NEVER : String = "never" [static] A constant value used in the pixelSnapping property of a Bitmap object to specify that no pixel snapping occurs. | PixelSnapping
Constant detail
ALWAYS constant
public static const ALWAYS:String = "always"

A constant value used in the pixelSnapping property of a Bitmap object to specify that the bitmap image is always snapped to the nearest pixel, independent of any transformation.

AUTO constant
public static const AUTO:String = "auto"

A constant value used in the pixelSnapping property of a Bitmap object to specify that the bitmap image is snapped to the nearest pixel if it is drawn with no rotation or skew and it is drawn at a scale factor of 99.9% to 100.1%. If these conditions are satisfied, the image is drawn at 100% scale, snapped to the nearest pixel. Internally, this setting allows the image to be drawn as fast as possible by using the vector renderer.

NEVER constant
public static const NEVER:String = "never"

A constant value used in the pixelSnapping property of a Bitmap object to specify that no pixel snapping occurs.


flash.display.Scene (Flex™ 2 Language Reference)

Class Scene | Properties | Methods
Package | flash.display
Class | public final class Scene
Inheritance | Scene Inheritance Object

The Scene class includes properties for identifying the name, labels, and number of frames in a scene. The MovieClip class includes a currentScene property, which is a Scene object that identifies the scene in which the playhead is located in the timeline of the MovieClip instance. The scenes property of the MovieClip class is an array of Scene objects. Also, the gotoAndPlay() and gotoAndStop() methods of the MovieClip class use Scene objects as parameters.

See also

MovieClip.currentScene
MovieClip.scenes
MovieClip.gotoAndPlay()
MovieClip.gotoAndStop()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | labels : Array [read-only] An array of FrameLabel objects for the scene. | Scene
 | name : String [read-only] The name of the scene. | Scene
 | numFrames : int [read-only] The number of frames in the scene. | Scene
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
labels property
labels:Array [read-only]

An array of FrameLabel objects for the scene. Each FrameLabel object contains a frame property, which specifies the frame number corresponding to the label, and a name property.

Implementation
    public function get labels():Array

See also

FrameLabel
name property
name:String [read-only]

The name of the scene.

Implementation
    public function get name():String
numFrames property
numFrames:int [read-only]

The number of frames in the scene.

Implementation
    public function get numFrames():int


flash.display.Shape (Flex™ 2 Language Reference)

Class Shape | Properties | Methods | Events | Examples
Package | flash.display
Class | public class Shape
Inheritance | Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | FlexShape

The Shape class is used to create lightweight shapes by using the ActionScript drawing application program interface (API). The Shape class includes a graphics property, which lets you access methods from the Graphics class.

The Sprite class also includes a graphicsproperty, and it includes other features not available to the Shape class. For example, a Sprite object is a display object container, whereas a Shape object is not (and cannot contain child display objects). For this reason, Shape objects consume less memory than Sprite objects that contain the same graphics.

View the examples.

See also

flash.display.Graphics
Understanding the display architecture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | graphics : Graphics [read-only] Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Shape()
Creates a new Shape object.
Shape
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
graphics property
graphics:Graphics [read-only]

Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur.

Implementation
    public function get graphics():Graphics

See also

Drawing vector graphics
Constructor detail
Shape () constructor
public function Shape()

Creates a new Shape object.

Examples

The following example uses the ShapeExample class to draw a circle, a rounded rectangle, and a square. This task is accomplished by performing the following steps:
  1. Declare a size property for later use in determining the size of each shape.
  2. Declare properties that set the background color to orange, the border color to dark gray, the border size to 0 pixels, the corner radius to 9 pixels, and set the space between the stage edge and the other objects to be 5 pixels.
  3. Use the properties declared in the preceding steps along with the built-in methods of the Graphics class to draw the circle, rounded rectangle, and square at coordinates x = 0, y = 0.
  4. Redraw each of the shapes along the top of the stage, starting at x = 5, y = 5, with a 5-pixel spacing between shapes by using the refreshLayout() method.

package {
    import flash.display.DisplayObject;
    import flash.display.Graphics;
    import flash.display.JointStyle;
    import flash.display.LineScaleMode;
    import flash.display.Shape;
    import flash.display.Sprite;

    public class ShapeExample extends Sprite {
        private var size:uint           = 80;
        private var bgColor:uint       = 0xFFCC00;
        private var borderColor:uint  = 0x666666;
        private var borderSize:uint   = 0;
        private var cornerRadius:uint = 9;
        private var gutter:uint       = 5;

        public function ShapeExample() {
            doDrawCircle();
            doDrawRoundRect();
            doDrawRect();
            refreshLayout();
        }

        private function refreshLayout():void {
            var ln:uint = numChildren;
            var child:DisplayObject;
            var lastChild:DisplayObject = getChildAt(0);
            lastChild.x = gutter;
            lastChild.y = gutter;
            for (var i:uint = 1; i < ln; i++) {
                child = getChildAt(i);
                child.x = gutter + lastChild.x + lastChild.width;
                child.y = gutter;
                lastChild = child;
            }
        }

        private function doDrawCircle():void {
            var child:Shape = new Shape();
            var halfSize:uint = Math.round(size/2);
            child.graphics.beginFill(bgColor);
            child.graphics.lineStyle(borderSize, borderColor);
            child.graphics.drawCircle(halfSize, halfSize, halfSize);
            child.graphics.endFill();
            addChild(child);
        }

        private function doDrawRoundRect():void {
            var child:Shape = new Shape();
            child.graphics.beginFill(bgColor);
            child.graphics.lineStyle(borderSize, borderColor);
            child.graphics.drawRoundRect(0, 0, size, size, cornerRadius);
            child.graphics.endFill();
            addChild(child);
        }

        private function doDrawRect():void {
            var child:Shape = new Shape();
            child.graphics.beginFill(bgColor);
            child.graphics.lineStyle(borderSize, borderColor);
            child.graphics.drawRect(0, 0, size, size);
            child.graphics.endFill();
            addChild(child);
        }
    }
}


flash.display.SimpleButton (Flex™ 2 Language Reference)

Class SimpleButton | Properties | Methods | Events | Examples
Package | flash.display
Class | public class SimpleButton
Inheritance | SimpleButton Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | FlexSimpleButton

The SimpleButton class lets you control all instances of button symbols in a SWF file. After you create an instance of a button in the authoring tool, you can use the methods and properties of the SimpleButton class to manipulate buttons with ActionScript.

You can give a button an instance name in the Property inspector. SimpleButton instance names are displayed in the Movie Explorer and in the Insert Target Path dialog box in the Actions panel.

In ActionScript 3.0, you can also use the new SimpleButton() constructor to create a SimpleButton instance:

 var myButton:SimpleButton = new SimpleButton();
 var downSprite:Sprite = new Sprite();
 downSprite.graphics.lineStyle(2, 0x202020);
 downSprite.graphics.beginFill(0x00FF00);
 downSprite.graphics.drawRect(10, 10, 50, 50);

 var upSprite:Sprite = new Sprite();
 upSprite.graphics.lineStyle(2, 0x202020);
 upSprite.graphics.beginFill(0xFFFF00);
 upSprite.graphics.drawRect(10, 10, 50, 50);

 myButton.upState = upSprite;
 myButton.overState = upSprite;
 myButton.downState = downSprite;
 myButton.useHandCursor = true;
 myButton.hitTestState = upSprite;

 this.addChild(myButton);

The SimpleButton class inherits from the InteractiveObject class.

View the examples.

See also

InteractiveObject class
Understanding the display architecture
Working with SimpleButton objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
 | downState : DisplayObject Specifies a display object that is used as the visual object for the button "Down" state —the state that the button is in when the user clicks the hitTestState object. | SimpleButton
 | enabled : Boolean A Boolean value that specifies whether a button is enabled. | SimpleButton
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
 | hitTestState : DisplayObject Specifies a display object that is used as the hit testing object for the button. | SimpleButton
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | overState : DisplayObject Specifies a display object that is used as the visual object for the button over state — the state that the button is in when the mouse is positioned over the button. | SimpleButton
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | soundTransform : SoundTransform The SoundTransform object assigned to this button. | SimpleButton
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | SimpleButton
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | upState : DisplayObject Specifies a display object that is used as the visual object for the button up state — the state that the button is in when the mouse is not positioned over the button. | SimpleButton
 | useHandCursor : Boolean A Boolean value that, when set to true, indicates whether Flash Player displays the hand cursor when the mouse rolls over a button. | SimpleButton
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SimpleButton(upState:DisplayObject = null, overState:DisplayObject = null, downState:DisplayObject = null, hitTestState:DisplayObject = null)
Creates a new SimpleButton instance.
SimpleButton
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
downState property
downState:DisplayObject [read-write]

Specifies a display object that is used as the visual object for the button "Down" state —the state that the button is in when the user clicks the hitTestState object.

Implementation
    public function get downState():DisplayObject
    public function set downState(value:DisplayObject):void

See also

hitTestState
overState
upState
enabled property
enabled:Boolean [read-write]

A Boolean value that specifies whether a button is enabled. When a button is disabled (the enabled property is set to false), the button is visible but cannot be clicked. The default value is true. This property is useful if you want to disable part of your navigation; for example, you might want to disable a button in the currently displayed page so that it can't be clicked and the page cannot be reloaded.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void
hitTestState property
hitTestState:DisplayObject [read-write]

Specifies a display object that is used as the hit testing object for the button. For a basic button, set the hitTestState property to the same display object as the overState property. If you do not set the hitTestState property, the SimpleButton is inactive — it does not respond to mouse and keyboard events.

Implementation
    public function get hitTestState():DisplayObject
    public function set hitTestState(value:DisplayObject):void

See also

downState
overState
upState
overState property
overState:DisplayObject [read-write]

Specifies a display object that is used as the visual object for the button over state — the state that the button is in when the mouse is positioned over the button.

Implementation
    public function get overState():DisplayObject
    public function set overState(value:DisplayObject):void

See also

downState
hitTestState
upState
soundTransform property
soundTransform:SoundTransform [read-write]

The SoundTransform object assigned to this button. A SoundTransform object includes properties for setting volume, panning, left speaker assignment, and right speaker assignment. This SoundTransform object applies to all states of the button. This SoundTransform object affects only embedded sounds.

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void

See also

flash.media.SoundTransform
trackAsMenu property
trackAsMenu:Boolean [read-write]

Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. The trackAsMenu property lets you create menus. You can set the trackAsMenu property on any SimpleButton or MovieClip object. If the trackAsMenu property does not exist, the default behavior is false.

You can change the trackAsMenu property at any time; the modified button immediately takes on the new behavior.

Implementation
    public function get trackAsMenu():Boolean
    public function set trackAsMenu(value:Boolean):void
upState property
upState:DisplayObject [read-write]

Specifies a display object that is used as the visual object for the button up state — the state that the button is in when the mouse is not positioned over the button.

Implementation
    public function get upState():DisplayObject
    public function set upState(value:DisplayObject):void

See also

downState
hitTestState
overState
useHandCursor property
useHandCursor:Boolean [read-write]

A Boolean value that, when set to true, indicates whether Flash Player displays the hand cursor when the mouse rolls over a button. If this property is set to false, the arrow pointer cursor is displayed instead. The default is true.

You can change the useHandCursor property at any time; the modified button immediately uses the new cursor behavior.

Implementation
    public function get useHandCursor():Boolean
    public function set useHandCursor(value:Boolean):void
Constructor detail
SimpleButton () constructor
public function SimpleButton(upState:DisplayObject = null, overState:DisplayObject = null, downState:DisplayObject = null, hitTestState:DisplayObject = null)

Creates a new SimpleButton instance. Any or all of the display objects that represent the various button states can be set as parameters in the constructor.

Parameters
upState:DisplayObject (default = null) — The initial value for the SimpleButton up state.
overState:DisplayObject (default = null) — The initial value for the SimpleButton over state.
downState:DisplayObject (default = null) — The initial value for the SimpleButton down state.
hitTestState:DisplayObject (default = null) — The initial value for the SimpleButton hitTest state.
Examples

The following example uses the SimpleButtonExample class, which in turn uses the CustomSimpleButton class, and this class then instantiates four ButtonDisplayState objects. The result is a button that is created in the shape of a square, whose background color changes based on the mouse state by overriding instance properties of the SimpleButton class. This is accomplished by performing the following steps:
  1. In the SimpleButtonExample() constructor, a new CustomSimpleButton object of type SimpleButton, called button, is created, which calls the CustomSimpleButton constructor method. The button object is the added to the display list. The button's color and size are determined in the steps that follow.
  2. In the CustomSimpleButton class, instance properties are declared that are later used to control the size and background color of button, based on the state it is in (orange in the normal state, dark yellow in the mouse over state, an light blue in the mouse down state). In all of the button's states, the size of the square is set to 80 pixels by using the size property.
  3. The constructor function for the CustomSimpleButton class sets the downState, overState, upState, hitTestState, and useHandCursor properties with four instances of the ButtonDisplayState class.
  4. In the ButtonDisplayState class, the constructor sets the value of the square's size and background color and calls the draw() method.
  5. The draw() method redraws the square with the size and background color set in the constructor based on the button's state.
package {
    import flash.display.Sprite;

    public class SimpleButtonExample extends Sprite {
        public function SimpleButtonExample() {
            var button:CustomSimpleButton = new CustomSimpleButton();
            addChild(button);
        }
    }
}

import flash.display.DisplayObject;
import flash.display.Shape;
import flash.display.SimpleButton;

class CustomSimpleButton extends SimpleButton {
    private var upColor:uint   = 0xFFCC00;
    private var overColor:uint = 0xCCFF00;
    private var downColor:uint = 0x00CCFF;
    private var size:uint      = 80;

    public function CustomSimpleButton() {
        downState      = new ButtonDisplayState(downColor, size);
        overState      = new ButtonDisplayState(overColor, size);
        upState        = new ButtonDisplayState(upColor, size);
        hitTestState   = new ButtonDisplayState(upColor, size * 2);
        hitTestState.x = -(size / 4);
        hitTestState.y = hitTestState.x;
        useHandCursor  = true;
    }
}

class ButtonDisplayState extends Shape {
    private var bgColor:uint;
    private var size:uint;

    public function ButtonDisplayState(bgColor:uint, size:uint) {
        this.bgColor = bgColor;
        this.size    = size;
        draw();
    }

    private function draw():void {
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, size, size);
        graphics.endFill();
    }
}


flash.display.SpreadMethod (Flex™ 2 Language Reference)

Class SpreadMethod | Properties | Methods | Constants
Package | flash.display
Class | public final class SpreadMethod
Inheritance | SpreadMethod Inheritance Object

The SpreadMethod class provides values for the spreadMethod parameter in the beginGradientFill() and lineGradientStyle() methods of the Graphics class.

The following example shows the same gradient fill using various spread methods:

SpreadMethod.PAD | SpreadMethod.REFLECT | SpreadMethod.REPEAT

See also

flash.display.Graphics.beginGradientFill()
flash.display.Graphics.lineGradientStyle()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | PAD : String = "pad" [static] Specifies that the gradient use the pad spread method. | SpreadMethod
 | REFLECT : String = "reflect" [static] Specifies that the gradient use the reflect spread method. | SpreadMethod
 | REPEAT : String = "repeat" [static] Specifies that the gradient use the repeat spread method. | SpreadMethod
Constant detail
PAD constant
public static const PAD:String = "pad"

Specifies that the gradient use the pad spread method.

REFLECT constant
public static const REFLECT:String = "reflect"

Specifies that the gradient use the reflect spread method.

REPEAT constant
public static const REPEAT:String = "repeat"

Specifies that the gradient use the repeat spread method.


flash.display.Sprite (Flex™ 2 Language Reference)

Class Sprite | Properties | Methods | Events | Examples
Package | flash.display
Class | public class Sprite
Inheritance | Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | DownloadProgressBar, FlexSprite, MovieClip, Preloader

The Sprite class is a basic display list building block: a display list node that can display graphics and can also contain children.

A Sprite object is similar to a movie clip, but does not have a timeline. Sprite is an appropriate base class for objects that do not require timelines. For example, Sprite would be a logical base class for user interface (UI) components that typically do not use the timeline.

The Sprite class is new in ActionScript 3.0. It provides an alternative to the functionality of the MovieClip class, which retains all the functionality of previous ActionScript releases to provide backward compatibility.

View the examples.

See also

Understanding the display architecture

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
 | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
 | dropTarget : DisplayObject [read-only] Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
 | graphics : Graphics [read-only] Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
 | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Sprite()
Creates a new Sprite instance.
Sprite
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
buttonMode property
buttonMode:Boolean [read-write]

Specifies the button mode of this sprite. If true, this sprite behaves as a button, which means that it triggers the display of the hand cursor when the mouse passes over the sprite and can receive a click event if the enter or space keys are pressed when the sprite has focus. You can suppress the display of the hand cursor by setting the useHandCursor property to false, in which case the pointer is displayed.

Although it is better to use the SimpleButton class to create buttons, you can use the buttonMode property to give a sprite some button-like functionality. To include a sprite in the tab order, set the tabEnabled property (inherited from the InteractiveObject class and false by default) to true. Additionally, consider whether you want the children of your sprite to be mouse enabled. Most buttons do not enable mouse interactivity for their child objects because it confuses the event flow. To disable mouse interactivity for all child objects, you must set the mouseChildren property (inherited from the DisplayObjectContainer class) to false.

If you use the buttonMode property with the MovieClip class (which is a subclass of the Sprite class), your button might have some added functionality. If you include frames labeled _up, _over, and _down, Flash Player provides automatic state changes (functionality similar to that provided in previous versions of ActionScript for movie clips used as buttons). These automatic state changes are not available for sprites, which have no timeline, and thus no frames to label.

Implementation
    public function get buttonMode():Boolean
    public function set buttonMode(value:Boolean):void

See also

SimpleButton
Sprite.useHandCursor
InteractiveObject.tabEnabled
DisplayObjectContainer.mouseChildren

Example
The following example creates two sprites and sets the buttonMode property to true for one and false for the other. When you compile and run the application, both sprites respond to mouse events, but only the one in which buttonMode is set to true uses the hand cursor and is included in the tab order:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFFCC00);
circle1.graphics.drawCircle(40, 40, 40);
circle1.buttonMode = true;
circle1.addEventListener(MouseEvent.CLICK, clicked);

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0xFFCC00);
circle2.graphics.drawCircle(120, 40, 40);
circle2.buttonMode = false;
circle2.addEventListener(MouseEvent.CLICK, clicked);

function clicked(event:MouseEvent):void {
    trace ("Click!");
}

addChild(circle1);
addChild(circle2);

dropTarget property
dropTarget:DisplayObject [read-only]

Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped.

Implementation
    public function get dropTarget():DisplayObject

See also

startDrag()
stopDrag()

Example
The following example creates a circle sprite and two target sprites. The startDrag() method is called on the circle sprite when the user positions the cursor over the sprite and presses the mouse button, and the stopDrag() method is called when the user releases the mouse button. This lets the user drag the sprite. On release of the mouse button, the mouseRelease() method is called, which in turn traces the name of the dropTarget object — the one to which the user dragged the circle sprite:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFFCC00);
circle.graphics.drawCircle(0, 0, 40);

var target1:Sprite = new Sprite();
target1.graphics.beginFill(0xCCFF00);
target1.graphics.drawRect(0, 0, 100, 100);
target1.name = "target1";

var target2:Sprite = new Sprite();
target2.graphics.beginFill(0xCCFF00);
target2.graphics.drawRect(0, 200, 100, 100);
target2.name = "target2";

addChild(target1);
addChild(target2);
addChild(circle);

circle.addEventListener(MouseEvent.MOUSE_DOWN, mouseDown)

function mouseDown(event:MouseEvent):void {
    circle.startDrag();
}
circle.addEventListener(MouseEvent.MOUSE_UP, mouseReleased);

function mouseReleased(event:MouseEvent):void {
    circle.stopDrag();
    trace(circle.dropTarget.name);
}

graphics property
graphics:Graphics [read-only]

Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur.

Implementation
    public function get graphics():Graphics

See also

Drawing vector graphics

Example
The following example creates a circle sprite and uses its graphics property to draw a circle with a yellow (0xFFCC00) fill:
import flash.display.Sprite;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFFCC00);
circle.graphics.drawCircle(40, 40, 40);
addChild(circle);

hitArea property
hitArea:Sprite [read-write]

Designates another sprite to serve as the hit area for a sprite. If the hitArea property does not exist or the value is null or undefined, the sprite itself is used as the hit area. The value of the hitArea property can be a reference to a Sprite object.

You can change the hitArea property at any time; the modified sprite immediately uses the new hit area behavior. The sprite designated as the hit area does not need to be visible; its graphical shape, although not visible, is still detected as the hit area.

Note: You must set to false the mouseEnabled property of the sprite designated as the hit area. Otherwise, your sprite button might not work because the sprite designated as the hit area receives the mouse events instead of your sprite button.

Implementation
    public function get hitArea():Sprite
    public function set hitArea(value:Sprite):void

Example
The following example creates a circle sprite and a square sprite. The square sprite is the hitArea for the circle sprite. So when the user clicks the square sprite, the circle sprite dispatches a click event:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFFCC00);
circle.graphics.drawCircle(0, 0, 40);

var square:Sprite = new Sprite();
square.graphics.beginFill(0xCCFF00);
square.graphics.drawRect(200, 0, 100, 100);

circle.hitArea = square;
square.mouseEnabled = false;

circle.addEventListener(MouseEvent.CLICK, clicked);

function clicked(event:MouseEvent):void{
    trace(event.target == circle); // true
    trace(event.target == square); // false
}

addChild(circle);
addChild(square);

soundTransform property
soundTransform:SoundTransform [read-write]

Controls sound within this sprite.

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void

See also

flash.media.SoundTransform

Example
The following example creates a sprite named container and adds a Loader object to its child list. The Loader object loads a SWF file. When the user clicks the link in the tf text field true, the mute() method sets the volume property of the soundTransform property of the container sprite:
import flash.display.Sprite;
import flash.display.Loader;
import flash.events.IOErrorEvent;
import flash.events.MouseEvent;
import flash.net.URLRequest;
import flash.text.TextField;
import flash.media.SoundTransform;

var container:Sprite = new Sprite();
addChild(container);

var ldr:Loader = new Loader;
var urlReq:URLRequest = new URLRequest("SoundPlayer.swf");
ldr.load(urlReq);

container.addChild(ldr);
ldr.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, urlNotFound);

var tf:TextField = new TextField();
tf.htmlText = "<a href = 'event:Mute'>Mute / Unmute</a>";
addChild(tf);

var mySoundTransform:SoundTransform = new SoundTransform();
mySoundTransform.volume = 1;

tf.addEventListener(MouseEvent.CLICK, mute);

function mute(event:MouseEvent):void {
    if (mySoundTransform.volume == 0) {
        mySoundTransform.volume = 1;
    } else {
        mySoundTransform.volume = 0;
    }
    container.soundTransform = mySoundTransform;
}

function urlNotFound(event:IOErrorEvent):void {
    trace("The URL was not found.");
}

useHandCursor property
useHandCursor:Boolean [read-write]

A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. The default value of the useHandCursor property is true. If useHandCursor is set to true, the pointing hand used for buttons appears when the mouse rolls over a button sprite. If useHandCursor is false, the arrow pointer is used instead.

You can change the useHandCursor property at any time; the modified sprite immediately takes on the new cursor appearance.

Note: If your sprite has child sprites, you might want to set the mouseChildren property to false. For example, if you want a hand cursor to appear over a Flex <mx:Label> control, set the useHandCursor and buttonMode properties to true, and the mouseChildren property to false.

 Implementation
    public function get useHandCursor():Boolean
    public function set useHandCursor(value:Boolean):void

See also

buttonMode
DisplayObjectContainer.mouseChildren

Example
The following example creates two sprites and sets the buttonMode property to true for both, yet it sets the useHandCursor property to true for one and false for the other. When you compile and run the application, both sprites respond as buttons (and are included in the tab order), but only the one in which useHandCursor is set to true uses the hand cursor:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle1:Sprite = new Sprite();
circle1.graphics.beginFill(0xFFCC00);
circle1.graphics.drawCircle(40, 40, 40);
circle1.buttonMode = true;
circle1.useHandCursor = true;
circle1.addEventListener(MouseEvent.CLICK, clicked);

var circle2:Sprite = new Sprite();
circle2.graphics.beginFill(0xFFCC00);
circle2.graphics.drawCircle(120, 40, 40);
circle2.buttonMode = true;
circle2.useHandCursor = false;
circle2.addEventListener(MouseEvent.CLICK, clicked);

function clicked(event:MouseEvent):void {
    trace ("Click!");
}

addChild(circle1);
addChild(circle2);

Constructor detail
Sprite () constructor
public function Sprite()

Creates a new Sprite instance. After you create the Sprite instance, call the DisplayObjectContainer.addChild() or DisplayObjectContainer.addChildAt() method to add the Sprite to a parent DisplayObjectContainer.

Method detail
startDrag () method
public function startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void

Lets the user drag the specified sprite. The sprite remains draggable until explicitly stopped through a call to the Sprite.stopDrag() method, or until another sprite is made draggable. Only one sprite is draggable at a time.

Parameters
lockCenter:Boolean (default = false) — Specifies whether the draggable sprite is locked to the center of the mouse position (true), or locked to the point where the user first clicked the sprite (false).
bounds:Rectangle (default = null) — Value relative to the coordinates of the Sprite's parent that specify a constraint rectangle for the Sprite.

See also

dropTarget
stopDrag()

Example
The following example creates a circle sprite and two target sprites. The startDrag() method is called on the circle sprite when the user positions the cursor over the sprite and presses the mouse button, and the stopDrag() method is called when the user releases the mouse button. This lets the user drag the sprite. On release of the mouse button, the mouseRelease() method is called, which in turn traces the name of the dropTarget object — the one to which the user dragged the circle sprite:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFFCC00);
circle.graphics.drawCircle(0, 0, 40);

var target1:Sprite = new Sprite();
target1.graphics.beginFill(0xCCFF00);
target1.graphics.drawRect(0, 0, 100, 100);
target1.name = "target1";

var target2:Sprite = new Sprite();
target2.graphics.beginFill(0xCCFF00);
target2.graphics.drawRect(0, 200, 100, 100);
target2.name = "target2";

addChild(target1);
addChild(target2);
addChild(circle);

circle.addEventListener(MouseEvent.MOUSE_DOWN, mouseDown)

function mouseDown(event:MouseEvent):void {
    circle.startDrag();
}
circle.addEventListener(MouseEvent.MOUSE_UP, mouseReleased);

function mouseReleased(event:MouseEvent):void {
    circle.stopDrag();
    trace(circle.dropTarget.name);
}

stopDrag () method
public function stopDrag():void

Ends the startDrag() method. A sprite that was made draggable with the startDrag() method remains draggable until a stopDrag() method is added, or until another sprite becomes draggable. Only one sprite is draggable at a time.

See also

dropTarget
startDrag()

Example
The following example creates a circle sprite and two target sprites. The startDrag() method is called on the circle sprite when the user positions the cursor over the sprite and presses the mouse button, and the stopDrag() method is called when the user releases the mouse button. This lets the user drag the sprite. On release of the mouse button, the mouseRelease() method is called, which in turn traces the name of the dropTarget object — the one to which the user dragged the circle sprite:
import flash.display.Sprite;
import flash.events.MouseEvent;

var circle:Sprite = new Sprite();
circle.graphics.beginFill(0xFFCC00);
circle.graphics.drawCircle(0, 0, 40);

var target1:Sprite = new Sprite();
target1.graphics.beginFill(0xCCFF00);
target1.graphics.drawRect(0, 0, 100, 100);
target1.name = "target1";

var target2:Sprite = new Sprite();
target2.graphics.beginFill(0xCCFF00);
target2.graphics.drawRect(0, 200, 100, 100);
target2.name = "target2";

addChild(target1);
addChild(target2);
addChild(circle);

circle.addEventListener(MouseEvent.MOUSE_DOWN, mouseDown)

function mouseDown(event:MouseEvent):void {
    circle.startDrag();
}
circle.addEventListener(MouseEvent.MOUSE_UP, mouseReleased);

function mouseReleased(event:MouseEvent):void {
    circle.stopDrag();
    trace(circle.dropTarget.name);
}

Examples

The following example uses the SpriteExample class to draw an orange square on the stage, and then dispatches events whenever the user clicks or drags the square. This task is accomplished by performing the following steps:
  1. Declare the size property (100 x 100 pixels) and the background color (orange) for later use in drawing the square.
  2. The constructor then creates a new child Sprite object and uses it to add two event listeners and their associated methods: mouseDownHandler() and mouseUpHandler().
  3. The child Sprite object is then passed to the draw() method, which draws the orange square.
  4. The child is then placed on the display list by a call to the addChild() method.
  5. The event listeners work as follows:
    • mouseDownHandler(): when the user clicks the Sprite object, this method adds a mouseMove event listener, the mouseMoveHandler() method, which processes the mouse moves. Then the startDrag() method is called, which allows the Sprite object to be dragged.
    • mouseUpHandler(): when the mouse button is released, the mouseMove event listener is removed and the stopDrag() method is called, which freezes the orange square in place.
    • mouseMoveHandler: as long as the left mouse button is being held down, this method instructs the player to continuously redraw the orange square.

Note: Each of the event listener methods declares a local sprite variable, which is assigned the target property of the event.

package {
    import flash.display.Sprite;
    import flash.events.*;

    public class SpriteExample extends Sprite {
        private var size:uint    = 100;
        private var bgColor:uint = 0xFFCC00;

        public function SpriteExample() {
            var child:Sprite = new Sprite();
            child.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
            child.addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
            draw(child);
            addChild(child);
        }

        private function mouseDownHandler(event:MouseEvent):void {
            trace("mouseDownHandler");
            var sprite:Sprite = Sprite(event.target);
            sprite.addEventListener(MouseEvent.MOUSE_MOVE, mouseMoveHandler);
            sprite.startDrag();
        }

        private function mouseUpHandler(event:MouseEvent):void {
            trace("mouseUpHandler");
            var sprite:Sprite = Sprite(event.target);
            sprite.removeEventListener(MouseEvent.MOUSE_MOVE, mouseMoveHandler);
            sprite.stopDrag();
        }

        private function mouseMoveHandler(event:MouseEvent):void {
            trace("mouseMoveHandler");
            event.updateAfterEvent();
        }

        private function draw(sprite:Sprite):void {
            sprite.graphics.beginFill(bgColor);
            sprite.graphics.drawRect(0, 0, size, size);
            sprite.graphics.endFill();
        }
    }
}


flash.display.Stage (Flex™ 2 Language Reference)

Class Stage | Properties | Methods | Events | Examples
Package | flash.display
Class | public class Stage
Inheritance | Stage Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Stage class represents the main drawing area. The Stage represents the entire area where Flash® content is shown.

The Stage object is not globally accessible. You need to access it through the stage property of a DisplayObject instance.

The Stage class has several ancestor classes — DisplayObjectContainer, InteractiveObject, DisplayObject, and EventDispatcher — from which it inherits properties and methods. Many of these properties and methods are either inapplicable to Stage objects, or require security checks when called on a Stage object. The properties and methods that require security checks are documented as part of the Stage class.

In addition, the following inherited properties are inapplicable to Stage objects. If you try to set them, an IllegalOperationError is thrown. These properties may always be read, but since they cannot be set, they will always contain default values.

  • accessibilityProperties
  • alpha
  • blendMode
  • cacheAsBitmap
  • contextMenu
  • filters
  • focusRect
  • loaderInfo
  • mask
  • mouseEnabled
  • name
  • opaqueBackground
  • rotation
  • scale9Grid
  • scaleX
  • scaleY
  • scrollRect
  • tabEnabled
  • tabIndex
  • transform
  • visible
  • x
  • y

View the examples.

See also

Understanding the display architecture
Working with display objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
 | align : String A value from the StageAlign class that specifies the alignment of the stage in Flash Player or the browser. | Stage
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | focus : InteractiveObject The interactive object with keyboard focus; or null if focus is not set or if the focused object belongs to a security sandbox to which the calling object does not have access. | Stage
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
 | frameRate : Number Gets and sets the frame rate of the stage. | Stage
 | height : Number Indicates the height of the display object, in pixels. | Stage
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | Stage
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | numChildren : int [read-only] Returns the number of children of this object. | Stage
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : String A value from the StageQuality class that specifies which rendering quality Flash Player uses. | Stage
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
 | scaleMode : String A value from the StageScaleMode class that specifies which scale mode to use. | Stage
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | showDefaultContextMenu : Boolean Specifies whether to show or hide the default items in the Flash Player context menu. | Stage
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | stageFocusRect : Boolean Specifies whether or not objects display a glowing border when they have focus. | Stage
 | stageHeight : int The current height, in pixels, of the Stage. | Stage
 | stageWidth : int Specifies the current width, in pixels, of the Stage. | Stage
 | tabChildren : Boolean Determines whether the children of the object are tab enabled. | Stage
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | textSnapshot : TextSnapshot [read-only] Returns a TextSnapshot object for this DisplayObjectContainer instance. | Stage
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
 | width : Number Indicates the width of the display object, in pixels. | Stage
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
Stage
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
Stage
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
Stage
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
Stage
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
Stage
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
invalidate():void
Calling the invalidate() method signals Flash Player to alert display objects on the next opportunity it has to render the display list (for example, when the playhead advances to a new frame).
Stage
isFocusInaccessible():Boolean
Determines whether the Stage.focus property returns null for security reasons.
Stage
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
Stage
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
Stage
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
Stage
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
Stage
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
 | mouseLeave | Dispatched by the Stage object when the mouse pointer moves out of the Flash Player window area. | Stage
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
 | resize | Dispatched when the scaleMode property of the Stage object is set to StageScaleMode.NO_SCALE and the SWF file is resized. | Stage
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
align property
align:String [read-write]

A value from the StageAlign class that specifies the alignment of the stage in Flash Player or the browser. The following are valid values:

Value | Vertical Alignment | Horizontal
StageAlign.TOP | Top | Center
StageAlign.BOTTOM | Bottom | Center
StageAlign.LEFT | Center | Left
StageAlign.RIGHT | Center | Right
StageAlign.TOP_LEFT | Top | Left
StageAlign.TOP_RIGHT | Top | Right
StageAlign.BOTTOM_LEFT | Bottom | Left
StageAlign.BOTTOM_RIGHT | Bottom | Right

The align property is only available to an object that is in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the calling object by calling the Security.allowDomain() method or the Security.alowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

Implementation
    public function get align():String
    public function set align(value:String):void

See also

flash.display.StageAlign
focus property
focus:InteractiveObject [read-write]

The interactive object with keyboard focus; or null if focus is not set or if the focused object belongs to a security sandbox to which the calling object does not have access.

Implementation
    public function get focus():InteractiveObject
    public function set focus(value:InteractiveObject):void

Throws
Error — Throws an error if focus cannot be set to the target.
frameRate property
frameRate:Number [read-write]

Gets and sets the frame rate of the stage. The frame rate is defined as frames per second. By default the rate is set to the frame rate of the first SWF file loaded. Valid range for the frame rate is from 0.01 to 1000 frames per second.

Note: Flash Player might not be able to follow high frame rate settings, either because the target platform is not fast enough or the player is synchronized to the vertical blank timing of the display device (usually 60 Hz on LCD devices). In some cases, a target platform might also choose to lower the maximum frame rate if it anticipates high CPU usage.

Implementation
    public function get frameRate():Number
    public function set frameRate(value:Number):void

Throws
SecurityError — Calling the frameRate property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
height property
height:Number [read-write]

Indicates the height of the display object, in pixels.

Implementation
    public function get height():Number
    public function set height(value:Number):void

Throws
SecurityError — Referencing the height property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
IllegalOperationError — It is always illegal to set the height property of a Stage object, even if the calling object is the Stage owner (the main SWF file).
mouseChildren property
mouseChildren:Boolean [read-write]

Determines whether or not the children of the object are mouse enabled. If an object is mouse enabled, a user can interact with it by using a mouse. The default is true.

This property is useful when you create a button with an instance of the Sprite class (instead of using the SimpleButton class). When you use a Sprite instance to create a button, you can choose to decorate the button by using the addChild() method to add additional Sprite instances. This process can cause unexpected behavior with mouse events because the Sprite instances you add as children can become the target object of a mouse event when you expect the parent instance to be the target object. To ensure that the parent instance serves as the target objects for mouse events, you can set the mouseChildren property of the parent instance to false.

No event is dispatched by setting this property. You must use the addEventListener() method to create interactive functionality.

Implementation
    public function get mouseChildren():Boolean
    public function set mouseChildren(value:Boolean):void

Throws
SecurityError — Referencing the mouseChildren property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
numChildren property
numChildren:int [read-only]

Returns the number of children of this object.

Implementation
    public function get numChildren():int

Throws
SecurityError — Referencing the numChildren property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
quality property
quality:String [read-write]

A value from the StageQuality class that specifies which rendering quality Flash Player uses. The following are valid values:

  • StageQuality.LOW—Low rendering quality. Graphics are not anti-aliased, and bitmaps are not smoothed.
  • StageQuality.MEDIUM—Medium rendering quality. Graphics are anti-aliased using a 2 x 2 pixel grid, but bitmaps are not smoothed. This setting is suitable for movies that do not contain text.
  • StageQuality.HIGH—High rendering quality. Graphics are anti-aliased using a 4 x 4 pixel grid, and bitmaps are smoothed if the movie is static. This is the default rendering quality setting that Flash Player uses.
  • StageQuality.BEST—Very high rendering quality. Graphics are anti-aliased using a 4 x 4 pixel grid and bitmaps are always smoothed.
Note: The operating system draws the device fonts, which are therefore unaffected by the quality property.

Implementation
    public function get quality():String
    public function set quality(value:String):void

Throws
SecurityError — Calling the quality property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

flash.display.StageQuality
scaleMode property
scaleMode:String [read-write]

A value from the StageScaleMode class that specifies which scale mode to use. The following are valid values:

  • StageScaleMode.EXACT_FIT—The entire Flash application is visible in the specified area without distortion while maintaining the original aspect ratio of the application. Borders can appear on two sides of the application.
  • StageScaleMode.SHOW_ALL—The entire Flash application is visible in the specified area without trying to preserve the original aspect ratio. Distortion can occur.
  • StageScaleMode.NO_BORDER—The entire Flash application fills the specified area, without distortion but possibly with some cropping, while maintaining the original aspect ratio of the application.
  • StageScaleMode.NO_SCALE—The entire Flash application is fixed, so that it remains unchanged even as the size of the player window changes. Cropping might occur if the player window is smaller than the content.

Implementation
    public function get scaleMode():String
    public function set scaleMode(value:String):void

Throws
SecurityError — Calling the scaleMode property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

flash.display.StageScaleMode
showDefaultContextMenu property
showDefaultContextMenu:Boolean [read-write]

Specifies whether to show or hide the default items in the Flash Player context menu.

If the showDefaultContextMenu property is set to true (the default), all context menu items appear. If the showDefaultContextMenu property is set to false, only the Settings and About Adobe Flash Player menu items appear.

Implementation
    public function get showDefaultContextMenu():Boolean
    public function set showDefaultContextMenu(value:Boolean):void

Throws
SecurityError — Calling the showDefaultContextMenu property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
stageFocusRect property
stageFocusRect:Boolean [read-write]

Specifies whether or not objects display a glowing border when they have focus.

Implementation
    public function get stageFocusRect():Boolean
    public function set stageFocusRect(value:Boolean):void

Throws
SecurityError — Calling the stageFocusRect property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
stageHeight property
stageHeight:int [read-write]

The current height, in pixels, of the Stage.

When the value of the Stage.scaleMode property is set to StageScaleMode.NO_SCALE, the stageHeight property represents the height of the Flash Player window. When the value of Stage.scaleMode is not set to StageScaleMode.NO_SCALE, stageHeight represents the height of the SWF file.

Implementation
    public function get stageHeight():int
    public function set stageHeight(value:int):void

Throws
SecurityError — Calling the stageHeight property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

flash.display.StageScaleMode
stageWidth property
stageWidth:int [read-write]

Specifies the current width, in pixels, of the Stage.

When the value of the scaleMode property is set to StageScaleMode.NO_SCALE, the stageWidth property represents the width of Flash Player. This means that the stageWidth property varies as you resize the Flash Player window. When the value of the scaleMode property is not set to StageScaleMode.NO_SCALE, the stageWidth property represents the width of the SWF file as set during authoring in the Document Properties dialog box. This means that the value of the stageWidth property stays constant as you resize the Flash Player window.

Implementation
    public function get stageWidth():int
    public function set stageWidth(value:int):void

Throws
SecurityError — Calling the stageWidth property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

flash.display.StageScaleMode
tabChildren property
tabChildren:Boolean [read-write]

Determines whether the children of the object are tab enabled. Enables or disables tabbing for the children of the object.

Implementation
    public function get tabChildren():Boolean
    public function set tabChildren(value:Boolean):void

Throws
SecurityError — Referencing the tabChildren property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
textSnapshot property
textSnapshot:TextSnapshot [read-only]

Returns a TextSnapshot object for this DisplayObjectContainer instance.

Implementation
    public function get textSnapshot():TextSnapshot

Throws
IllegalOperationError — Referencing the textSnapshot property of a Stage object throws an exception because the Stage class does not implement this property. To avoid this, call the textSnapshot property of a display object container other than the Stage object.
width property
width:Number [read-write]

Indicates the width of the display object, in pixels.

Implementation
    public function get width():Number
    public function set width(value:Number):void

Throws
SecurityError — Referencing the width property of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
IllegalOperationError — It is always illegal to set the width property of a Stage object, even if you are the Stage owner.
Method detail
addChild () method
public override function addChild(child:DisplayObject):DisplayObject

Adds a child DisplayObject instance to this DisplayObjectContainer instance. The child is added to the front (top) of all other children in this DisplayObjectContainer instance. (To add a child to a specific index position, use the addChildAt() method.)

If you add a child object that already has a different display object container as a parent, the object is removed from the child list of the other display object container.

Parameters
child:DisplayObject — The DisplayObject instance to add as a child of this DisplayObjectContainer instance.

Returns
DisplayObject — The DisplayObject instance that you pass in the child parameter.

Throws
SecurityError — Calling the addChild() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

Working with display objects
addChildAt () method
public override function addChildAt(child:DisplayObject, index:int):DisplayObject

Adds a child DisplayObject instance to this DisplayObjectContainer instance. The child is added at the index position specified. An index of 0 represents the back (bottom) of the display list for this DisplayObjectContainer object.

For example, the following example shows three display objects, labeled a, b, and d, at index positions 0, 2, and 1, respectively:

If you add a child object that already has a different display object container as a parent, the object is removed from the child list of the other display object container.

Parameters
child:DisplayObject — The DisplayObject instance to add as a child of this DisplayObjectContainer instance.
index:int — The index position to which the child is added. If you specify a currently occupied index position, the child object that exists at that position and all higher positions are moved up one position in the child list.

Returns
DisplayObject — The DisplayObject instance that you pass in the child parameter.

Throws
SecurityError — Calling the addChildAt() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

Working with display objects
addEventListener () method
public override function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event. You can register event listeners on all nodes in the display list for a specific type of event, phase, and priority.

After you successfully register an event listener, you cannot change its priority through additional calls to addEventListener(). To change a listener's priority, you must first call removeListener(). Then you can register the listener again with the new priority level.

Keep in mind that after the listener is registered, subsequent calls to addEventListener() with a different type or useCapture value result in the creation of a separate listener registration. For example, if you first register a listener with useCapture set to true, it listens only during the capture phase. If you call addEventListener() again using the same listener object, but with useCapture set to false, you have two separate listeners: one that listens during the capture phase and another that listens during the target and bubbling phases.

You cannot register an event listener for only the target phase or the bubbling phase. Those phases are coupled during registration because bubbling applies only to the ancestors of the target node.

If you no longer need an event listener, remove it by calling removeEventListener(), or memory problems could result. Objects with registered event listeners are not automatically removed from memory because the garbage collector does not remove objects that still have references.

Copying an EventDispatcher instance does not copy the event listeners attached to it. (If your newly created node needs an event listener, you must attach the listener after creating the node). However, if you move an EventDispatcher instance, the event listeners attached to it move along with it.

If the event listener is being registered on a node while an event is being processed on this node, the event listener is not triggered during the current phase but can be triggered during a later phase in the event flow, such as the bubbling phase.

If an event listener is removed from a node while an event is being processed on the node, it is still triggered by the current actions. After it is removed, the event listener is never invoked again (unless registered again for future processing).

Parameters
type:String — The type of event.
listener:Function — The listener function that processes the event. This function must accept an Event object as its only parameter and must return nothing, as this example shows:

function(evt:Event):void

The function can have any name.
useCapture:Boolean (default = false) — Determines whether the listener works in the capture phase or the target and bubbling phases. If useCapture is set to true, the listener processes the event only during the capture phase and not in the target or bubbling phase. If useCapture is false, the listener processes the event only during the target or bubbling phase. To listen for the event in all three phases, call addEventListener twice, once with the useCapture set to true, then again with useCapture set to false.
priority:int (default = 0) — The priority level of the event listener. The priority is designated by a signed 32-bit integer. The higher the number, the higher the priority. All listeners with priority n are processed before listeners of priority n-1. If two or more listeners share the same priority, they are processed in the order in which they were added. The default priority is 0.
useWeakReference:Boolean (default = false) — Determines whether the reference to the listener is strong or weak. A strong reference (the default) prevents your listener from being garbage-collected. A weak reference does not.

Throws
SecurityError — Calling the addEventListener method of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this situation, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

Working with display objects
dispatchEvent () method
public override function dispatchEvent(event:Event):Boolean

Dispatches an event into the event flow. The event target is the EventDispatcher object upon which the dispatchEvent() method is called.

Parameters
event:Event — The Event object that is dispatched into the event flow. If the event is being redispatched, a clone of the event is created automatically. After an event is dispatched, its target property cannot be changed, so you must create a new copy of the event for redispatching to work.

Returns
Boolean — A value of true if the event was successfully dispatched. A value of false indicates failure or that preventDefault() was called on the event.

Throws
SecurityError — Calling the dispatchEvent() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
hasEventListener () method
public override function hasEventListener(type:String):Boolean

Checks whether the EventDispatcher object has any listeners registered for a specific type of event. This allows you to determine where an EventDispatcher object has altered handling of an event type in the event flow hierarchy. To determine whether a specific event type actually triggers an event listener, use willTrigger().

The difference between hasEventListener() and willTrigger() is that hasEventListener() examines only the object to which it belongs, whereas willTrigger() examines the entire event flow for the event specified by the type parameter.

When hasEventListener() is called from a LoaderInfo object, only the listeners that the caller can access are considered.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type is registered; false otherwise.

Throws
SecurityError — Calling the hasEventListener() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
invalidate () method
public function invalidate():void

Calling the invalidate() method signals Flash Player to alert display objects on the next opportunity it has to render the display list (for example, when the playhead advances to a new frame). After you call the invalidate() method, when the display list is next rendered, Flash Player sends a render event to each display object that has registered to listen for the render event. You must call the invalidate() method each time you want Flash Player to send render events.

The render event gives you an opportunity to make changes to the display list immediately before it is actually rendered. This lets you defer updates to the display list until the latest opportunity. This can increase performance by eliminating unnecessary screen updates.

The render event is dispatched only to display objects that are in the same security domain as the code that calls the stage.invalidate() method, or to display objects from a security domain that has been granted permission via the Security.allowDomain() method.

See also

flash.events.Event.RENDER
isFocusInaccessible () method
public function isFocusInaccessible():Boolean

Determines whether the Stage.focus property returns null for security reasons. In other words, isFocusInaccessible returns true if the object that has focus belongs to a security sandbox to which the SWF file does not have access.

Returns
Boolean — true if the object that has focus belongs to a security sandbox to which the SWF file does not have access.
removeChildAt () method
public override function removeChildAt(index:int):DisplayObject

Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer. The parent property of the removed child is set to null, and the object is garbage collected if no other references to the child exist. The index positions of any display objects above the child in the DisplayObjectContainer are decreased by 1.

The garbage collector is the process by which Flash Player reallocates unused memory space. When a variable or object is no longer actively referenced or stored somewhere, the garbage collector sweeps through and wipes out the memory space it used to occupy if no other references to it exist.

Parameters
index:int — The child index of the DisplayObject to remove.

Returns
DisplayObject — The DisplayObject instance that was removed.

Throws
SecurityError — Calling the removeChildAt() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the object to be removed. To avoid this, the owner of that object can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
setChildIndex () method
public override function setChildIndex(child:DisplayObject, index:int):void

Changes the position of an existing child in the display object container. This affects the layering of child objects. For example, the following example shows three display objects, labeled a, b, and c, at index positions 0, 1, and 2, respectively:

When you use the setChildIndex() method and specify an index position that is already occupied, the child that occupies that position and all objects higher in the child list move up one position in the list. For example, if the display object container in the previous example is named container, you can swap the position of the display objects labeled a and b by calling the following code:

container.setChildIndex(container.getChildAt(1), 0);

This code results in the following arrangement of objects:

Parameters
child:DisplayObject — The child DisplayObject instance for which you want to change the index number.
index:int — The resulting index number for the child display object.

Throws
SecurityError — Calling the setChildIndex() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
swapChildrenAt () method
public override function swapChildrenAt(index1:int, index2:int):void

Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list. All other child objects in the display object container remain in the same index positions.

Parameters
index1:int — The index position of the first child object.
index2:int — The index position of the second child object.

Throws
SecurityError — Calling the swapChildrenAt() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the owner of either of the objects to be swapped. To avoid this, the object owners can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
willTrigger () method
public override function willTrigger(type:String):Boolean

Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type. This method returns true if an event listener is triggered during any phase of the event flow when an event of the specified type is dispatched to this EventDispatcher object or any of its descendants.

The difference between the hasEventListener() and the willTrigger() methods is that hasEventListener() examines only the object to which it belongs, whereas the willTrigger() method examines the entire event flow for the event specified by the type parameter.

When willTrigger() is called from a LoaderInfo object, only the listeners that the caller can access are considered.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type will be triggered; false otherwise.

Throws
SecurityError — Calling the willTrigger() method of a Stage object throws an exception for any caller that is not in the same security sandbox as the Stage owner (the main SWF file). To avoid this, the Stage owner can grant permission to the domain of the caller by calling the Security.allowDomain() method or the Security.allowInsecureDomain() method. For more information, see the "Security" chapter in Programming ActionScript 3.0.
Event detail
mouseLeave event
Event object type: flash.events.Event
Event.type property = flash.events.Event.MOUSE_LEAVE

Dispatched by the Stage object when the mouse pointer moves out of the Flash Player window area.

Defines the value of the type property of a mouseLeave event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Stage object. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
resize event
Event object type: flash.events.Event
Event.type property = flash.events.Event.RESIZE

Dispatched when the scaleMode property of the Stage object is set to StageScaleMode.NO_SCALE and the SWF file is resized.

Defines the value of the type property of a resize event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Stage object.
Examples

The following example uses the StageExample class to dispatch events whenever the stage is activated or resized. This is accomplished by performing the following steps:
  1. The class constructor first sets the Flash application to be fixed, regardless of the size of the Flash Player window and then adds two event listeners with the activateHandler() and resizeHandler() methods.
  2. The activateHandler() method runs when the left mouse button is clicked.
  3. The resizeHandler() method runs when the stage is resized.
package {
    import flash.display.Sprite;
    import flash.display.StageAlign;
    import flash.display.StageScaleMode;
    import flash.events.Event;

    public class StageExample extends Sprite {

        public function StageExample() {
            stage.scaleMode = StageScaleMode.NO_SCALE;
            stage.align = StageAlign.TOP_LEFT;
            stage.addEventListener(Event.ACTIVATE, activateHandler);
            stage.addEventListener(Event.RESIZE, resizeHandler);
        }

        private function activateHandler(event:Event):void {
            trace("activateHandler: " + event);
        }

        private function resizeHandler(event:Event):void {
            trace("resizeHandler: " + event);
            trace("stageWidth: " + stage.stageWidth + " stageHeight: " + stage.stageHeight);
        }
    }
}


flash.display.StageAlign (Flex™ 2 Language Reference)

Class StageAlign | Properties | Methods | Constants
Package | flash.display
Class | public final class StageAlign
Inheritance | StageAlign Inheritance Object

The StageAlign class provides constant values to use for the Stage.align property.

See also

flash.display.Stage.align

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BOTTOM : String = "B" [static] Specifies that the Stage is aligned at the bottom. | StageAlign
 | BOTTOM_LEFT : String = "BL" [static] Specifies that the Stage is aligned in the bottom-left corner. | StageAlign
 | BOTTOM_RIGHT : String = "BR" [static] Specifies that the Stage is aligned in the bottom-right corner. | StageAlign
 | LEFT : String = "L" [static] Specifies that the Stage is aligned on the left. | StageAlign
 | RIGHT : String = "R" [static] Specifies that the Stage is aligned to the right. | StageAlign
 | TOP : String = "T" [static] Specifies that the Stage is aligned at the top. | StageAlign
 | TOP_LEFT : String = "TL" [static] Specifies that the Stage is aligned in the top-left corner. | StageAlign
 | TOP_RIGHT : String = "TR" [static] Specifies that the Stage is aligned in the top-right corner. | StageAlign
Constant detail
BOTTOM constant
public static const BOTTOM:String = "B"

Specifies that the Stage is aligned at the bottom.

BOTTOM_LEFT constant
public static const BOTTOM_LEFT:String = "BL"

Specifies that the Stage is aligned in the bottom-left corner.

BOTTOM_RIGHT constant
public static const BOTTOM_RIGHT:String = "BR"

Specifies that the Stage is aligned in the bottom-right corner.

LEFT constant
public static const LEFT:String = "L"

Specifies that the Stage is aligned on the left.

RIGHT constant
public static const RIGHT:String = "R"

Specifies that the Stage is aligned to the right.

TOP constant
public static const TOP:String = "T"

Specifies that the Stage is aligned at the top.

TOP_LEFT constant
public static const TOP_LEFT:String = "TL"

Specifies that the Stage is aligned in the top-left corner.

TOP_RIGHT constant
public static const TOP_RIGHT:String = "TR"

Specifies that the Stage is aligned in the top-right corner.


flash.display.StageQuality (Flex™ 2 Language Reference)

Class StageQuality | Properties | Methods | Constants
Package | flash.display
Class | public final class StageQuality
Inheritance | StageQuality Inheritance Object

The StageQuality class provides values for the Stage.quality property.

See also

flash.display.Stage.quality

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BEST : String = "best" [static] Specifies very high rendering quality: graphics are anti-aliased using a 4 x 4 pixel grid and bitmaps are always smoothed. | StageQuality
 | HIGH : String = "high" [static] Specifies high rendering quality: graphics are anti-aliased using a 4 x 4 pixel grid, and bitmaps are smoothed if the movie is static. | StageQuality
 | LOW : String = "low" [static] Specifies low rendering quality: graphics are not anti-aliased, and bitmaps are not smoothed. | StageQuality
 | MEDIUM : String = "medium" [static] Specifies medium rendering quality: graphics are anti-aliased using a 2 x 2 pixel grid, but bitmaps are not smoothed. | StageQuality
Constant detail
BEST constant
public static const BEST:String = "best"

Specifies very high rendering quality: graphics are anti-aliased using a 4 x 4 pixel grid and bitmaps are always smoothed.

HIGH constant
public static const HIGH:String = "high"

Specifies high rendering quality: graphics are anti-aliased using a 4 x 4 pixel grid, and bitmaps are smoothed if the movie is static.

LOW constant
public static const LOW:String = "low"

Specifies low rendering quality: graphics are not anti-aliased, and bitmaps are not smoothed.

MEDIUM constant
public static const MEDIUM:String = "medium"

Specifies medium rendering quality: graphics are anti-aliased using a 2 x 2 pixel grid, but bitmaps are not smoothed. This setting is suitable for movies that do not contain text.


flash.display.StageScaleMode (Flex™ 2 Language Reference)

Class StageScaleMode | Properties | Methods | Constants
Package | flash.display
Class | public final class StageScaleMode
Inheritance | StageScaleMode Inheritance Object

The StageScaleMode class provides values for the Stage.scaleMode property.

See also

flash.display.Stage.scaleMode

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | EXACT_FIT : String = "exactFit" [static] Specifies that the entire Adobe® Flash® application be visible in the specified area without trying to preserve the original aspect ratio. | StageScaleMode
 | NO_BORDER : String = "noBorder" [static] Specifies that the entire Flash application fill the specified area, without distortion but possibly with some cropping, while maintaining the original aspect ratio of the application. | StageScaleMode
 | NO_SCALE : String = "noScale" [static] Specifies that the size of the Flash application be fixed, so that it remains unchanged even as the size of the player window changes. | StageScaleMode
 | SHOW_ALL : String = "showAll" [static] Specifies that the entire Flash application be visible in the specified area without distortion while maintaining the original aspect ratio of the application. | StageScaleMode
Constant detail
EXACT_FIT constant
public static const EXACT_FIT:String = "exactFit"

Specifies that the entire Adobe® Flash® application be visible in the specified area without trying to preserve the original aspect ratio. Distortion can occur.

NO_BORDER constant
public static const NO_BORDER:String = "noBorder"

Specifies that the entire Flash application fill the specified area, without distortion but possibly with some cropping, while maintaining the original aspect ratio of the application.

NO_SCALE constant
public static const NO_SCALE:String = "noScale"

Specifies that the size of the Flash application be fixed, so that it remains unchanged even as the size of the player window changes. Cropping might occur if the player window is smaller than the content.

SHOW_ALL constant
public static const SHOW_ALL:String = "showAll"

Specifies that the entire Flash application be visible in the specified area without distortion while maintaining the original aspect ratio of the application. Borders can appear on two sides of the application.


flash.display.SWFVersion (Flex™ 2 Language Reference)

Class SWFVersion | Properties | Methods | Constants
Package | flash.display
Class | public final class SWFVersion
Inheritance | SWFVersion Inheritance Object

The SWFVersion class is an enumeration of constant values that indicate the file format version of a loaded SWF file. The SWFVersion constants are provided for use in checking the swfVersion property of a flash.display.LoaderInfo object.

See also

flash.display.LoaderInfo.swfVersion

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | FLASH1 : uint = 1 [static] SWF file format version 1.0. | SWFVersion
 | FLASH2 : uint = 2 [static] SWF file format version 2.0. | SWFVersion
 | FLASH3 : uint = 3 [static] SWF file format version 3.0. | SWFVersion
 | FLASH4 : uint = 4 [static] SWF file format version 4.0. | SWFVersion
 | FLASH5 : uint = 5 [static] SWF file format version 5.0. | SWFVersion
 | FLASH6 : uint = 6 [static] SWF file format version 6.0. | SWFVersion
 | FLASH7 : uint = 7 [static] SWF file format version 7.0. | SWFVersion
 | FLASH8 : uint = 8 [static] SWF file format version 8.0. | SWFVersion
 | FLASH9 : uint = 9 [static] SWF file format version 9.0. | SWFVersion
Constant detail
FLASH1 constant
public static const FLASH1:uint = 1

SWF file format version 1.0.

FLASH2 constant
public static const FLASH2:uint = 2

SWF file format version 2.0.

FLASH3 constant
public static const FLASH3:uint = 3

SWF file format version 3.0.

FLASH4 constant
public static const FLASH4:uint = 4

SWF file format version 4.0.

FLASH5 constant
public static const FLASH5:uint = 5

SWF file format version 5.0.

FLASH6 constant
public static const FLASH6:uint = 6

SWF file format version 6.0.

FLASH7 constant
public static const FLASH7:uint = 7

SWF file format version 7.0.

FLASH8 constant
public static const FLASH8:uint = 8

SWF file format version 8.0.

FLASH9 constant
public static const FLASH9:uint = 9

SWF file format version 9.0.


flash.errors Summary (Flex™ 2 Language Reference)

Package flash.errors | Classes

The flash.error package contains error classes that are part of the Flash Player Application Programming Interface (API), rather than part of the ActionScript core language.

The ActionScript core language is the part of the language that complies with the ECMAScript standard. The Flash Player API is the part of the language that is specific to ActionScript. The flash.error package relates to Flash Player specific functionality (Flash Player API).

The error classes that are not part of the flash.error package are top level core classes that are based on the ECMAScript standard.

Note: In ActionScript 3.0, exceptions are the primary mechanism for reporting runtime errors. Error events are a secondary mechanism that are used when errors are encountered during an asynchronous operation, such as a call to the Loader.load() method.

Classes
Class | Description
EOFError | An EOFError exception is thrown when you attempt to read past the end of the available data.
IllegalOperationError | The IllegalOperationError exception is thrown when a method is not implemented or the implementation doesn't cover the current usage.
InvalidSWFError |
IOError | The IOError exception is thrown when some type of input or output failure occurs.
MemoryError | The MemoryError exception is thrown when a memory allocation request fails.
ScriptTimeoutError | The ScriptTimeoutError exception is thrown when the script timeout interval is reached.
StackOverflowError | ActionScript throws a StackOverflowError exception when the stack available to the script is exhausted.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.errors.EOFError (Flex™ 2 Language Reference)

Class EOFError | Properties | Methods | Examples
Package | flash.errors
Class | public dynamic class EOFError
Inheritance | EOFError Inheritance IOError Inheritance Error Inheritance Object

An EOFError exception is thrown when you attempt to read past the end of the available data. For example, an EOFError is thrown when one of the read methods in the IDataInput interface is called and there is insufficient data to satisfy the read request.

View the examples.

See also

flash.utils.ByteArray
flash.utils.IDataInput
flash.net.Socket
flash.net.URLStream
Working with the debugger version of Flash Player
flash.error package Error classes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | EOFError(message:String = "") Creates a new EOFError object. | EOFError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
EOFError () constructor
public function EOFError(message:String = "")

Creates a new EOFError object.

Parameters
message:String (default = "") — A string associated with the error object.
Examples

The following example uses the EOFErrorExample class to show the error generated if an attempt is made to read past the end of the available data. This is accomplished with the following steps:
  1. The constructor creates a ByteArray object byteArr and writes a Boolean value of false into the byte stream using writeBoolean().
  2. The position of byteArr is reset to 0 (start of the data stream).
  3. A single byte is removed from the data stream using readBoolean(). The data stream now contains no data.
  4. Within an error handling code segment set to catch EOFError objects, readBoolean() is called a second time and the EOFError is caught and passed to a trace() statement, which outputs the error message associated with EOFError objects.
package {
    import flash.display.Sprite;
    import flash.errors.EOFError;
    import flash.utils.ByteArray;

    public class EOFErrorExample extends Sprite {
        public function EOFErrorExample() {
            var byteArr:ByteArray = new ByteArray();

            byteArr.writeBoolean(false);
            trace(byteArr.length);        // 1

            byteArr.position = 0;
            try {
                trace(byteArr.readBoolean());    // false
            }
            catch(e:EOFError) {
                trace(e);
            }
            try {
                trace(byteArr.readBoolean());
            }
            catch(e:EOFError) {
                trace(e);        // EOFError: Error #2030: End of file was encountered.
            }
        }
    }
}


flash.errors.IllegalOperationError (Flex™ 2 Language Reference)

Class IllegalOperationError | Properties | Methods | Examples
Package | flash.errors
Class | public dynamic class IllegalOperationError
Inheritance | IllegalOperationError Inheritance Error Inheritance Object

The IllegalOperationError exception is thrown when a method is not implemented or the implementation doesn't cover the current usage. Examples of illegal operation error exceptions include:
  • A base class, such as DisplayObjectContainer, provides more functionality than a Stage can support (such as masks)
  • Certain accessibility methods are called when Flash Player is compiled without accessibility support
  • The mms.cfg setting prohibits a FileReference action
  • ActionScript tries to run a FileReference.browse() call when a browse dialog box is already open
  • ActionScript tries to use an unsupported protocol for a FileReference object (such as FTP)
  • Authoring-only features are invoked from a run-time player.
  • An attempt is made to set the name of a Timeline-placed object.
    •

View the examples.

See also

flash.error package Error classes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | IllegalOperationError(message:String = "") Creates a new IllegalOperationError object. | IllegalOperationError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
IllegalOperationError () constructor
public function IllegalOperationError(message:String = "")

Creates a new IllegalOperationError object.

Parameters
message:String (default = "") — A string associated with the error object.
Examples

The following example shows the use of an IllegalOperationError handler.
package {
    import flash.display.DisplayObject;
    import flash.display.Sprite;
    import flash.errors.IllegalOperationError;

    public class IllegalOperationErrorExample extends Sprite {
        public function IllegalOperationErrorExample() {
            var child:Sprite = new Sprite();
            try {
                addChild(child);
            }
            catch(e:IllegalOperationError) {
                trace(e);
            }
        }

        public override function addChild(child:DisplayObject):DisplayObject {
            throw new IllegalOperationError("addChild cannot be performed on the IllegalOperationErrorExample class");
        }
    }
}


flash.errors.InvalidSWFError (Flex™ 2 Language Reference)

Class InvalidSWFError | Properties | Methods
Package | flash.errors
Class | public dynamic class InvalidSWFError
Inheritance | InvalidSWFError Inheritance Error Inheritance Object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object


flash.errors.IOError (Flex™ 2 Language Reference)

Class IOError | Properties | Methods | Examples
Package | flash.errors
Class | public dynamic class IOError
Inheritance | IOError Inheritance Error Inheritance Object
Subclasses | EOFError

The IOError exception is thrown when some type of input or output failure occurs. For example, an IOError exception is thrown if a read/write operation is attempted on a socket that has not connected or that has become disconnected.

View the examples.

See also

Working with the debugger version of Flash Player
flash.error package Error classes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | IOError(message:String = "") Creates a new IOError object. | IOError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
IOError () constructor
public function IOError(message:String = "")

Creates a new IOError object.

Parameters
message:String (default = "") — A string associated with the error object.
Examples

The following example throws an IOError exception when it attempts to close a Sound stream that has never been loaded.
package {
    import flash.display.Sprite;
    import flash.errors.IOError;
    import flash.media.Sound;

    public class IOErrorExample extends Sprite
    {
        public function IOErrorExample()
        {
            var music:Sound = new Sound();
            try {
                  music.close();
                  trace("Stream closed.");
            } catch (error:IOError) {
                  trace("The stream could not be closed, or the stream was not open.");
            }
        }
    }
}


flash.errors.MemoryError (Flex™ 2 Language Reference)

Class MemoryError | Properties | Methods | Examples
Package | flash.errors
Class | public dynamic class MemoryError
Inheritance | MemoryError Inheritance Error Inheritance Object

The MemoryError exception is thrown when a memory allocation request fails.

On a desktop machine, memory allocation failures are rare unless an allocation request is extremely large. For example, a 32-bit Windows program can access only 2GB of address space, so a request for 10 billion bytes is impossible.

By default, Flash Player does not impose a limit on how much memory an ActionScript program can allocate.

View the examples.

See also

flash.error package Error classes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MemoryError(message:String = "") Creates a new MemoryError object. | MemoryError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
MemoryError () constructor
public function MemoryError(message:String = "")

Creates a new MemoryError object.

Parameters
message:String (default = "") — A string associated with the error object.
Examples

The following example shows one method of generating a MemoryError.
package {
    import flash.display.Sprite;
    import flash.errors.MemoryError;
    import flash.utils.setInterval;

    public class MemoryErrorExample extends Sprite {
        private var crashingStr:String;
        private var intervalId:Number;

        public function MemoryErrorExample() {
            crashingStr = "abcdefghijklmnopqrstuvwxyz";
            intervalId = setInterval(doubleString, 50);
        }

        public function exhaustMemory():void {
            try {
                crashingStr += crashingStr;
            }
            catch(e:MemoryError) {
                trace(e);
            }
        }
    }
}


flash.errors.ScriptTimeoutError (Flex™ 2 Language Reference)

Class ScriptTimeoutError | Properties | Methods | Examples
Package | flash.errors
Class | public dynamic class ScriptTimeoutError
Inheritance | ScriptTimeoutError Inheritance Error Inheritance Object

The ScriptTimeoutError exception is thrown when the script timeout interval is reached. The script timeout interval is 15 seconds. There are two XML attributes that you can add to the mx:Application tag: scriptTimeLimit (the number of seconds until script timeout) and scriptRecursionLimit (the depth of recursive calls permitted).

Two ScriptTimeoutError exceptions are thrown. The first exception you can catch and exit cleanly. If there is no exception handler, the uncaught exception terminates execution. The second exception is thrown but cannot be caught by user code; it goes to the uncaught exception handler. It is uncatchable to prevent Flash® Player from hanging indefinitely.

View the examples.

See also

flash.error package Error classes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ScriptTimeoutError(message:String = "") Creates a new ScriptTimeoutError object. | ScriptTimeoutError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
ScriptTimeoutError () constructor
public function ScriptTimeoutError(message:String = "")

Creates a new ScriptTimeoutError object.

Parameters
message:String (default = "") — A string associated with the error object.
Examples

The following example uses the sample ScriptTimeoutErrorExample class to show the error generated in the event of script timeout. This is accomplished with the following steps:
  1. A keepLooking Boolean property is declared.
  2. The constructor calls the lockMachine() method within an error handling code segment that catches ScriptTimeoutError objects.
  3. The lockMachine() method contains an endless while loop.
  4. After awhile, the ScriptTimeoutError is thrown. The constructor catches it, outputs an error message through the trace statement and resets the keepLooking Boolean to false, which terminates the while loop in lockMachine().
package {
    import flash.display.Sprite;
    import flash.errors.ScriptTimeoutError;

    public class ScriptTimeoutErrorExample extends Sprite {
        private var keepLooping:Boolean = true;

        public function ScriptTimeoutErrorExample() {
            try {
                lockMachine();
            }
            catch(e:ScriptTimeoutError) {
                trace(e);    // ScriptTimeoutError: Error #1502: A script has executed for longer than 15 seconds
                keepLooping = false;
            }
        }

        private function lockMachine():void {
            while(keepLooping){
            }
        }
    }
}


flash.errors.StackOverflowError (Flex™ 2 Language Reference)

Class StackOverflowError | Properties | Methods | Examples
Package | flash.errors
Class | public dynamic class StackOverflowError
Inheritance | StackOverflowError Inheritance Error Inheritance Object

ActionScript throws a StackOverflowError exception when the stack available to the script is exhausted. ActionScript uses a stack to store information about each method call made in a script, such as the local variables that the method uses. The amount of stack space available varies from system to system.

A StackOverflowError exception might indicate that infinite recursion has occurred, in which case a termination case needs to be added to the function. It also might indicate that the recursive algorithm has a proper terminating condition but has exhausted the stack anyway. In this case, try to express the algorithm iteratively instead.

View the examples.

See also

Responding to error events and status

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | StackOverflowError(message:String = "") Creates a new StackOverflowError object. | StackOverflowError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
StackOverflowError () constructor
public function StackOverflowError(message:String = "")

Creates a new StackOverflowError object.

Parameters
message:String (default = "") — A string associated with the error object.
Examples

The following example uses the sample StackOverflowErrorExample class to show the error generated in the event of a stack overflow. This is accomplished using the following steps:
  1. The constructor calls the method lockMachine() within an error handling code segment that catches StackOverflowError objects.
  2. The lockMachine() method calls itself until the stack overflows.
  3. After the StackOverflowError is thrown, the constructor catches it and then outputs an error message through the trace statement.
package {
    import flash.display.Sprite;
    import flash.errors.StackOverflowError;

    public class StackOverflowErrorExample extends Sprite {
        public function StackOverflowErrorExample() {
            try {
                lockMachine();
            }
            catch(e:StackOverflowError) {
                trace(e);    // StackOverflowError: Error #1023: Stack overflow.
            }
        }

        private function lockMachine():void {
            lockMachine();
        }
    }
}


flash.events Summary (Flex™ 2 Language Reference)

Package flash.events | Interfaces | Classes

The flash.events package supports the new DOM event model and includes the EventDispatcher base class.

Interfaces
Interface | Description
IEventDispatcher | The IEventDispatcher interface defines methods for adding or removing event listeners, checks whether specific types of event listeners are registered, and dispatches events.
Classes
Class | Description
ActivityEvent | Flash® Player dispatches an ActivityEvent object whenever a camera or microphone reports that it has become active or inactive.
AsyncErrorEvent | Flash® Player dispatches an AsyncErrorEvent when an exception is thrown from native asynchronous code, which could be from, for example, LocalConnection, NetConnection, SharedObject, or NetStream.
ContextMenuEvent | Flash® Player dispatches ContextMenuEvent objects when a user generates or interacts with the context menu.
DataEvent | Flash® Player dispatches DataEvent objects when raw data has completed loading into Flash Player.
ErrorEvent | Flash® Player dispatches ErrorEvent objects when an error causes a network operation to fail.
Event | The Event class is used as the base class for the creation of Event objects, which are passed as parameters to event listeners when an event occurs.
EventDispatcher | The EventDispatcher class implements the IEventDispatcher interface and is the base class for the DisplayObject class.
EventPhase | The EventPhase class provides values for the eventPhase property of the Event class.
FocusEvent | Flash® Player dispatches FocusEvent objects when the user changes the focus from one object in the display list to another.
HTTPStatusEvent | Flash® Player dispatches HTTPStatusEvent objects when a network request returns an HTTP status code.
IMEEvent | Flash® Player dispatches IMEEvent objects when a user enters text using an input method editor (IME).
IOErrorEvent | Flash® Player dispatches an IOErrorEvent object when an error causes a send or load operation to fail.
KeyboardEvent | Flash® Player dispatches KeyboardEvent objects in response to user input through a keyboard.
MouseEvent | Flash® Player dispatches MouseEvent objects into the event flow whenever mouse events occur.
NetStatusEvent | Flash® Player dispatches NetStatusEvent objects when a NetConnection, NetStream, or SharedObject object reports its status.
ProgressEvent | Flash® Player dispatches ProgressEvent objects when a load operation has begun or a socket has received data.
SecurityErrorEvent | Flash® Player dispatches SecurityErrorEvent objects to report the occurrence of a security error.
StatusEvent | Flash® Player dispatches StatusEvent objects when a device, such as a camera or microphone, or an object such as a LocalConnection object reports its status.
SyncEvent | Flash® Player dispatches SyncEvent objects when a remote SharedObject instance has been updated by the server.
TextEvent | Flash® Player dispatches TextEvent objects when a user enters text in a text field or clicks a hyperlink in an HTML-enabled text field.
TimerEvent | Flash® Player dispatches TimerEvent objects whenever a Timer object reaches the interval specified by the Timer.delay property.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.events.ActivityEvent (Flex™ 2 Language Reference)

Class ActivityEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class ActivityEvent
Inheritance | ActivityEvent Inheritance Event Inheritance Object

Flash® Player dispatches an ActivityEvent object whenever a camera or microphone reports that it has become active or inactive. There is only one type of activity event: ActivityEvent.ACTIVITY.

View the examples.

See also

ActivityEvent.ACTIVITY

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | activating : Boolean Indicates whether the device is activating (true) or deactivating (false). | ActivityEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ActivityEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, activating:Boolean = false) Creates an event object that contains information about activity events. | ActivityEvent
 | clone():Event Creates a copy of an ActivityEvent object and sets the value of each property to match that of the original. | ActivityEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the ActivityEvent object. | ActivityEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
 | ACTIVITY : String = "activity" [static] The ActivityEvent.ACTIVITY constant defines the value of the type property of an activity event object. | ActivityEvent
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
activating property
activating:Boolean [read-write]

Indicates whether the device is activating (true) or deactivating (false).

Implementation
    public function get activating():Boolean
    public function set activating(value:Boolean):void
Constructor detail
ActivityEvent () constructor
public function ActivityEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, activating:Boolean = false)

Creates an event object that contains information about activity events. Event objects are passed as parameters to Event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of activity event: ActivityEvent.ACTIVITY.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling phase of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
activating:Boolean (default = false) — Indicates whether the device is activating (true) or deactivating (false). Event listeners can access this information through the activating property.

See also

ActivityEvent.ACTIVITY
Method detail
clone () method
public override function clone():Event

Creates a copy of an ActivityEvent object and sets the value of each property to match that of the original.

Returns
Event — A new ActivityEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the ActivityEvent object. The following format is used:

[ActivityEvent type=value bubbles=value cancelable=value activating=value]

Returns
String — A string that contains all the properties of the ActivityEvent object.
Constant detail
ACTIVITY constant
public static const ACTIVITY:String = "activity"

The ActivityEvent.ACTIVITY constant defines the value of the type property of an activity event object.

This event has the following properties:

Property | Value
activating | true if the device is activating or false if it is deactivating.
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object beginning or ending a session, such as a Camera or Microphone object.

See also

flash.media.Camera.activity
flash.media.Microphone.activity
Examples

The following example demonstrates the use of the ActivityEvent class by attaching an event listener method named activityHandler() to the microphone and generating text information every time the microphone generates an activity event.

package {
    import flash.display.Sprite;
    import flash.events.ActivityEvent;
    import flash.media.Microphone;

    public class ActivityEventExample extends Sprite {
        public function ActivityEventExample() {
            var mic:Microphone = Microphone.getMicrophone();
            mic.addEventListener(ActivityEvent.ACTIVITY, activityHandler);
        }

        private function activityHandler(event:ActivityEvent):void {
            trace("event: " + event);
            trace("event.activating: " + event.activating);
        }
    }
}


flash.events.AsyncErrorEvent (Flex™ 2 Language Reference)

Class AsyncErrorEvent | Properties | Methods | Constants
Package | flash.events
Class | public class AsyncErrorEvent
Inheritance | AsyncErrorEvent Inheritance ErrorEvent Inheritance TextEvent Inheritance Event Inheritance Object

Flash® Player dispatches an AsyncErrorEvent when an exception is thrown from native asynchronous code, which could be from, for example, LocalConnection, NetConnection, SharedObject, or NetStream. There is only one type of asynchronous error event: AsyncErrorEvent.ASYNC_ERROR.

See also

ASYNC_ERROR

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | error : Error The exception that was thrown. | AsyncErrorEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | text : String For a textInput event, the character or sequence of characters entered by the user. | TextEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AsyncErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "", error:Error = null) Creates an AsyncErrorEvent object that contains information about asyncError events. | AsyncErrorEvent
 | clone():Event Creates a copy of the AsyncErrorEvent object and sets the value of each property to match that of the original. | AsyncErrorEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the AsyncErrorEvent object. | AsyncErrorEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
 | ASYNC_ERROR : String = "asyncError" [static] The AsyncErrorEvent.ASYNC_ERROR constant defines the value of the type property of an asyncError event object. | AsyncErrorEvent
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ERROR : String = "error" [static] Defines the value of the type property of an error event object. | ErrorEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | LINK : String = "link" [static] Defines the value of the type property of a link event object. | TextEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | TEXT_INPUT : String = "textInput" [static] Defines the value of the type property of a textInput event object. | TextEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
error property
public var error:Error

The exception that was thrown.

Constructor detail
AsyncErrorEvent () constructor
public function AsyncErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "", error:Error = null)

Creates an AsyncErrorEvent object that contains information about asyncError events. AsyncErrorEvent objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of error event: ErrorEvent.ERROR.
bubbles:Boolean (default = false) — Determines whether the Event object bubbles. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
text:String (default = "") — Text to be displayed as an error message. Event listeners can access this information through the text property.
error:Error (default = null) — The exception that occurred.
Method detail
clone () method
public override function clone():Event

Creates a copy of the AsyncErrorEvent object and sets the value of each property to match that of the original.

Returns
Event — A new AsyncErrorEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the AsyncErrorEvent object. The string is in the following format:

[AsyncErrorEvent type=value bubbles=value cancelable=value ... error=value]

Returns
String — A string that contains all the properties of the AsyncErrorEvent object.
Constant detail
ASYNC_ERROR constant
public static const ASYNC_ERROR:String = "asyncError"

The AsyncErrorEvent.ASYNC_ERROR constant defines the value of the type property of an asyncError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object experiencing a network operation failure.
error | The error that triggered the event.


flash.events.ContextMenuEvent (Flex™ 2 Language Reference)

Class ContextMenuEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class ContextMenuEvent
Inheritance | ContextMenuEvent Inheritance Event Inheritance Object

Flash® Player dispatches ContextMenuEvent objects when a user generates or interacts with the context menu. Users generate the context menu by clicking the secondary button of the user's pointing device (usually a mouse or a trackball). There are two types of ContextMenuEvent objects:
  • ContextMenuEvent.MENU_ITEM_SELECT
  • ContextMenuEvent.MENU_SELECT

View the examples.

See also

ContextMenu class
ContextMenuItem class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contextMenuOwner : InteractiveObject The display list object to which the menu is attached. | ContextMenuEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | mouseTarget : InteractiveObject The display list object on which the user right-clicked to display the context menu. | ContextMenuEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ContextMenuEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, mouseTarget:InteractiveObject = null, contextMenuOwner:InteractiveObject = null) Creates an Event object that contains specific information about menu events. | ContextMenuEvent
 | clone():Event Creates a copy of the ContextMenuEvent object and sets the value of each property to match that of the original. | ContextMenuEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the ContextMenuEvent object. | ContextMenuEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | MENU_ITEM_SELECT : String = "menuItemSelect" [static] Defines the value of the type property of a menuItemSelect event object. | ContextMenuEvent
 | MENU_SELECT : String = "menuSelect" [static] Defines the value of the type property of a menuSelect event object. | ContextMenuEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
contextMenuOwner property
contextMenuOwner:InteractiveObject [read-write]

The display list object to which the menu is attached. This could be the mouse target (mouseTarget) or one of its ancestors in the display list.

Implementation
    public function get contextMenuOwner():InteractiveObject
    public function set contextMenuOwner(value:InteractiveObject):void
mouseTarget property
mouseTarget:InteractiveObject [read-write]

The display list object on which the user right-clicked to display the context menu. This could be the display list object to which the menu is attached (contextMenuOwner) or one of its display list descendants.

Implementation
    public function get mouseTarget():InteractiveObject
    public function set mouseTarget(value:InteractiveObject):void
Constructor detail
ContextMenuEvent () constructor
public function ContextMenuEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, mouseTarget:InteractiveObject = null, contextMenuOwner:InteractiveObject = null)

Creates an Event object that contains specific information about menu events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Possible values are:
  • ContextMenuEvent.MENU_ITEM_SELECT
  • ContextMenuEvent.MENU_SELECT
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
mouseTarget:InteractiveObject (default = null) — The display list object on which the user right-clicked to display the context menu. This could be the contextMenuOwner or one of its display list descendants.
contextMenuOwner:InteractiveObject (default = null) — The display list object to which the menu is attached. This could be the mouseTarget or one of its ancestors in the display list.

See also

ContextMenuEvent.MENU_ITEM_SELECT
ContextMenuEvent.MENU_SELECT
Method detail
clone () method
public override function clone():Event

Creates a copy of the ContextMenuEvent object and sets the value of each property to match that of the original.

Returns
Event — A new ContextMenuEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the ContextMenuEvent object. The string is in the following format:

[ContextMenuEvent type=value bubbles=value cancelable=value ... contextMenuOwner=value]

Returns
String — A string that contains all the properties of the ContextMenuEvent object.
Constant detail
MENU_ITEM_SELECT constant
public static const MENU_ITEM_SELECT:String = "menuItemSelect"

Defines the value of the type property of a menuItemSelect event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
contextMenuOwner | The display list object to which the menu is attached.
currentTarget | The object that is actively processing the Event object with an event listener.
mouseTarget | The display list object on which the user right-clicked to display the context menu.
target | The ContextMenuItem object that has been selected. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.ui.ContextMenuItem.menuItemSelect
MENU_SELECT constant
public static const MENU_SELECT:String = "menuSelect"

Defines the value of the type property of a menuSelect event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
contextMenuOwner | The display list object to which the menu is attached.
currentTarget | The object that is actively processing the Event object with an event listener.
mouseTarget | The display list object on which the user right-clicked to display the context menu.
target | The ContextMenu object that is about to be displayed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.ui.ContextMenu.menuSelect
Examples

The following example uses the ContextMenuEventExample class to remove the default context menu items from the Stage and add a new menu item that changes the color of a square on the Stage. The example carries out the following tasks:
  1. The myContextMenu property is declared and then assigned to a new ContextMenu object and the redRectangle property (of type Sprite) is declared.
  2. The removeDefaultItems() method is called. This method removes all built-in context menu items except Print.
  3. The addCustomMenuItems() method is called. This method places a Reverse Colors menu item in the defaultItems array by using the push() method of Array. A menuItemSelect event listener is added to the ContextMenuItem object and the associated method is called menuItemSelectHandler(). This method prints some trace() statements whenever the user selects Reverse Colors from the context menu. In addition the red square becomes black and the black text becomes red.
  4. Back in the constructor, a menuSelect event listener is added, along with the associated method menuSelectHandler(), which simply prints out three trace() statements every time an item in the context menu is selected.
  5. The constructor calls addChildren(), which draws a red square and adds it to the display list, which immediately displays the square.
  6. Finally, myContextMenu is assigned to the context menu of the redRectangle property, so that the custom context menu is displayed only when the mouse pointer is over the square.
package {
    import flash.ui.ContextMenu;
    import flash.ui.ContextMenuItem;
    import flash.ui.ContextMenuBuiltInItems;
    import flash.events.ContextMenuEvent;
    import flash.display.Sprite;
    import flash.display.Shape;
    import flash.text.TextField;

    public class ContextMenuEventExample extends Sprite {
        private var myContextMenu:ContextMenu;
        private var menuLabel:String = "Reverse Colors";
        private var textLabel:String = "Right Click";
        private var redRectangle:Sprite;
        private var label:TextField;
        private var size:uint = 100;
        private var black:uint = 0x000000;
        private var red:uint = 0xFF0000;

        public function ContextMenuEventExample() {
            myContextMenu = new ContextMenu();
            removeDefaultItems();
            addCustomMenuItems();
            myContextMenu.addEventListener(ContextMenuEvent.MENU_SELECT, menuSelectHandler);

            addChildren();
            redRectangle.contextMenu = myContextMenu;
        }

        private function addChildren():void {
            redRectangle = new Sprite();
            redRectangle.graphics.beginFill(red);
            redRectangle.graphics.drawRect(0, 0, size, size);
            addChild(redRectangle);
            redRectangle.x = size;
            redRectangle.y = size;
            label = createLabel();
            redRectangle.addChild(label);
        }

        private function removeDefaultItems():void {
            myContextMenu.hideBuiltInItems();
            var defaultItems:ContextMenuBuiltInItems = myContextMenu.builtInItems;
            defaultItems.print = true;
        }

        private function addCustomMenuItems():void {
            var item:ContextMenuItem = new ContextMenuItem(menuLabel);
            myContextMenu.customItems.push(item);
            item.addEventListener(ContextMenuEvent.MENU_ITEM_SELECT, menuItemSelectHandler);
        }

        private function menuSelectHandler(event:ContextMenuEvent):void {
            trace("menuSelectHandler: " + event);
        }

        private function menuItemSelectHandler(event:ContextMenuEvent):void {
            trace("menuItemSelectHandler: " + event);
            var textColor:uint = (label.textColor == black) ? red : black;
            var bgColor:uint = (label.textColor == black) ? black : red;
            redRectangle.graphics.clear();
            redRectangle.graphics.beginFill(bgColor);
            redRectangle.graphics.drawRect(0, 0, size, size);
            label.textColor = textColor;
        }

        private function createLabel():TextField {
            var txtField:TextField = new TextField();
            txtField.text = textLabel;
            return txtField;
        }
    }
}


flash.events.DataEvent (Flex™ 2 Language Reference)

Class DataEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class DataEvent
Inheritance | DataEvent Inheritance TextEvent Inheritance Event Inheritance Object

Flash® Player dispatches DataEvent objects when raw data has completed loading into Flash Player. There is only one type of data event: DataEvent.DATA.

View the examples.

See also

flash.net.XMLSocket

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | data : String The raw data loaded into Flash Player. | DataEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | text : String For a textInput event, the character or sequence of characters entered by the user. | TextEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, data:String = "") Creates an event object that contains information about data events. | DataEvent
 | clone():Event Creates a copy of the DataEvent object and sets the value of each property to match that of the original. | DataEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the DataEvent object. | DataEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
 | DATA : String = "data" [static] Defines the value of the type property of a data event object. | DataEvent
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | LINK : String = "link" [static] Defines the value of the type property of a link event object. | TextEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | TEXT_INPUT : String = "textInput" [static] Defines the value of the type property of a textInput event object. | TextEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
data property
data:String [read-write]

The raw data loaded into Flash Player.

Implementation
    public function get data():String
    public function set data(value:String):void
Constructor detail
DataEvent () constructor
public function DataEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, data:String = "")

Creates an event object that contains information about data events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of data event: DataEvent.DATA.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling phase of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
data:String (default = "") — The raw data loaded into Flash Player. Event listeners can access this information through the data property.

See also

flash.net.XMLSocket
DataEvent.DATA
Method detail
clone () method
public override function clone():Event

Creates a copy of the DataEvent object and sets the value of each property to match that of the original.

Returns
Event — A new DataEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the DataEvent object. The string is in the following format:

[DataEvent type=value bubbles=value cancelable=value data=value]

Returns
String — A string that contains all the properties of the DataEvent object.
Constant detail
DATA constant
public static const DATA:String = "data"

Defines the value of the type property of a data event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
data | The raw data loaded into Flash Player.
target | The XMLSocket object receiving data.

See also

flash.net.XMLSocket.data
Examples

The following example creates an XMLSocket and connects it to a socket server running on port 8080 of yourDomain. An event listener is attached to the XMLSocket object that listens for data events, which are dispatched whenever raw data is received.

Notes:

  • To generate a securityError event in this example, you need to compile the SWF file with "Local playback security" set to "Access network only".
  • You need a server running on [yourDomain] using port 8080.

package {
    import flash.display.Sprite;
    import flash.events.DataEvent;
    import flash.net.XMLSocket;

    public class DataEventExample extends Sprite {
        private var hostName:String = "[yourDomain]";
        private var port:uint = 8080;
        private var socket:XMLSocket;

        public function DataEventExample() {
            socket = new XMLSocket();
            socket.addEventListener(DataEvent.DATA, dataHandler);
            socket.connect(hostName, port);
        }

        private function dataHandler(event:DataEvent):void {
            trace("dataHandler: " + event.data);
        }
    }
}


flash.events.ErrorEvent (Flex™ 2 Language Reference)

Class ErrorEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class ErrorEvent
Inheritance | ErrorEvent Inheritance TextEvent Inheritance Event Inheritance Object
Subclasses | AsyncErrorEvent, IOErrorEvent, SecurityErrorEvent

Flash® Player dispatches ErrorEvent objects when an error causes a network operation to fail. There is only one type of error event: ErrorEvent.ERROR.

The ErrorEvent class also serves as the base class for the IOErrorEvent and SecurityErrorEvent classes.

You can check for error events that do not have any listeners by using the debugger version of Flash Player. The debugger version of Flash Player displays these events as strings (defined by the text parameter of the ErrorEvent constructor).

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | text : String For a textInput event, the character or sequence of characters entered by the user. | TextEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "") Creates an Event object that contains information about error events. | ErrorEvent
 | clone():Event Creates a copy of the ErrorEvent object and sets the value of each property to match that of the original. | ErrorEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the ErrorEvent object. | ErrorEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | ERROR : String = "error" [static] Defines the value of the type property of an error event object. | ErrorEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | LINK : String = "link" [static] Defines the value of the type property of a link event object. | TextEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | TEXT_INPUT : String = "textInput" [static] Defines the value of the type property of a textInput event object. | TextEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
ErrorEvent () constructor
public function ErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "")

Creates an Event object that contains information about error events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of error event: ErrorEvent.ERROR.
bubbles:Boolean (default = false) — Determines whether the Event object bubbles. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
text:String (default = "") — Text to be displayed as an error message. Event listeners can access this information through the text property.
Method detail
clone () method
public override function clone():Event

Creates a copy of the ErrorEvent object and sets the value of each property to match that of the original.

Returns
Event — A new ErrorEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the ErrorEvent object. The string is in the following format:

[ErrorEvent type=value bubbles=value cancelable=value text=value]

Returns
String — A string that contains all the properties of the ErrorEvent object.
Constant detail
ERROR constant
public static const ERROR:String = "error"

Defines the value of the type property of an error event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object experiencing a network operation failure.
text | Text to be displayed as an error message.
Examples

The following example demonstrates the use of a single error handler (errorHandler()) that captures multiple types of error events. If there is an ioError event, the handler attempts to load from the network, which then throws a securityError.

Note: This example does not work if you have a file named MissingFile.xml in the same directory as your SWF file.

package {
    import flash.display.Sprite;
    import flash.net.URLLoader;
    import flash.net.URLRequest;
    import flash.events.*;

    public class ErrorEventExample extends Sprite {
        private var loader:URLLoader;
        private var request:URLRequest;

        public function ErrorEventExample() {
            loader = new URLLoader();
            loader.addEventListener(IOErrorEvent.IO_ERROR, errorHandler);
            loader.addEventListener(SecurityErrorEvent.SECURITY_ERROR, errorHandler);

            request = new URLRequest();
            loadFromFileSystem();
        }

        private function loadFromFileSystem():void {
            request.url = "MissingFile.xml";
            loader.load(request);
        }

        private function loadFromNetwork():void {
            request.url = "http://www.[yourDomain].com/MissingFile.xml";
            loader.load(request);
        }

        private function errorHandler(event:ErrorEvent):void {
            trace("errorHandler: " + event);
            if(event is IOErrorEvent) {
                loadFromNetwork();
            }
        }
    }
}


flash.events.Event (Flex™ 2 Language Reference)

Class Event | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class Event
Inheritance | Event Inheritance Object
Subclasses | ActivityEvent, CalendarLayoutChangeEvent, ChannelEvent, ChildExistenceChangedEvent, CloseEvent, CollectionEvent, ColorPickerEvent, ContextMenuEvent, CuePointEvent, DataConflictEvent, DataGridEvent, DateChooserEvent, DividerEvent, DropdownEvent, DynamicEvent, EffectEvent, FlexEvent, FocusEvent, HTTPStatusEvent, IndexChangedEvent, ItemClickEvent, KeyboardEvent, ListEvent, LoadEvent, LogEvent, MessageEvent, MessageFaultEvent, MouseEvent, MoveEvent, NetStatusEvent, NumericStepperEvent, ProgressEvent, PropertyChangeEvent, ResizeEvent, ScrollEvent, SliderEvent, StateChangeEvent, StatusEvent, SyncEvent, TextEvent, TimerEvent, ToolTipEvent, TreeEvent, TweenEvent, ValidationResultEvent, VideoEvent

The Event class is used as the base class for the creation of Event objects, which are passed as parameters to event listeners when an event occurs.

The properties of the Event class carry basic information about an event, such as the event's type or whether the event's default behavior can be canceled. For many events, such as the events represented by the Event class constants, this basic information is sufficient. Other events, however, may require more detailed information. Events associated with a mouse click, for example, need to include additional information about the location of the click event and whether any keys were pressed during the click event. You can pass such additional information to event listeners by extending the Event class, which is what the MouseEvent class does. The Flash® Player API defines several Event subclasses for common events that require additional information. Events associated with each of the Event subclasses are described in the documentation for each class.

The methods of the Event class can be used in event listener functions to affect the behavior of the event object. Some events have an associated default behavior. For example, the doubleClick event has an associated default behavior that highlights the word under the mouse pointer at the time of the event. Your event listener can cancel this behavior by calling the preventDefault() method. You can also make the current event listener the last one to process an event by calling the stopPropogation() or stopImmediatePropogation() method.

View the examples.

See also

flash.events.EventDispatcher
About events
About the Event class
Using events
Manually dispatching events
Event propagation
Event priorities
Using event subclasses
About keyboard events
Event objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bubbles : Boolean [read-only] Indicates whether an event is a bubbling event. | Event
 | cancelable : Boolean [read-only] Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentTarget : Object [read-only] The object that is actively processing the Event object with an event listener. | Event
 | eventPhase : uint [read-only] The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | target : Object [read-only] The event target. | Event
 | type : String [read-only] The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Event(type:String, bubbles:Boolean = false, cancelable:Boolean = false) Creates an Event object to pass as a parameter to event listeners. | Event
 | clone():Event Duplicates an instance of an Event subclass. | Event
 | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
 | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
 | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
 | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
 | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
 | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
 | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
 | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
 | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
 | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
 | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
 | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
 | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
 | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
 | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
 | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
 | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
 | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
 | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
 | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
bubbles property
bubbles:Boolean [read-only]

Indicates whether an event is a bubbling event. If the event can bubble, this value is true; otherwise it is false.

When an event occurs, it moves through the three phases of the event flow: the capture phase, which flows from the top of the display list hierarchy to the node just before the target node; the target phase, which comprises the target node; and the bubbling phase, which flows from the node subsequent to the target node back up the display list hierarchy.

Some events, such as the activate and unload events, do not have a bubbling phase. The bubbles property has a value of false for events that do not have a bubbling phase.

Implementation
    public function get bubbles():Boolean

See also

Event objects
cancelable property
cancelable:Boolean [read-only]

Indicates whether the behavior associated with the event can be prevented. If the behavior can be canceled, this value is true; otherwise it is false.

Implementation
    public function get cancelable():Boolean

See also

Event.preventDefault()
Event objects
currentTarget property
currentTarget:Object [read-only]

The object that is actively processing the Event object with an event listener. For example, if a user clicks an OK button, the current target could be the node containing that button or one of its ancestors that has registered an event listener for that event.

Implementation
    public function get currentTarget():Object

See also

Event objects
eventPhase property
eventPhase:uint [read-only]

The current phase in the event flow. This property can contain the following numeric values:

  • 1 The capture phase (EventPhase.CAPTURING_PHASE).
  • 2 The target phase (EventPhase.AT_TARGET).
  • 3 The bubbling phase (EventPhase.BUBBLING_PHASE).

Implementation
    public function get eventPhase():uint

See also

Event objects
target property
target:Object [read-only]

The event target. This property contains the target node. For example, if a user clicks an OK button, the target node is the display list node containing that button.

Implementation
    public function get target():Object

See also

Event objects
type property
type:String [read-only]

The type of event. The type is case-sensitive.

Implementation
    public function get type():String

See also

Event objects
Constructor detail
Event () constructor
public function Event(type:String, bubbles:Boolean = false, cancelable:Boolean = false)

Creates an Event object to pass as a parameter to event listeners.

Parameters
type:String — The type of the event, accessible as Event.type.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. The default value is false.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. The default values is false.
Method detail
clone () method
public function clone():Event

Duplicates an instance of an Event subclass.

Returns a new Event object that is a copy of the original instance of the Event object. You do not normally call clone(); the EventDispatcher class calls it automatically when you redispatch an event—that is, when you call dispatchEvent(event) from a handler that is handling event.

The new Event object includes all the properties of the original.

When creating your own custom Event class, you must override the inherited Event.clone() method in order for it to duplicate the properties of your custom class. If you do not set all the properties that you add in your event subclass, those properties will not have the correct values when listeners handle the redispatched event.

In this example, PingEvent is a subclass of Event and therefore implements its own version of clone().

  class PingEvent extends Event {
   var URL:String;

  public override function clone():Event {
        return new PingEvent(type, bubbles, cancelable, URL);
     }
  }

Returns
Event — A new Event object that is identical to the original.

See also

Event objects
formatToString () method
public function formatToString(className:String, ... arguments):String

A utility function for implementing the toString() method in your custom Event class. Overriding the toString() method is recommended, but not required.

  class PingEvent extends Event {
   var URL:String;

  public override function toString():String {
   return formatToString("PingEvent", "type", "bubbles", "cancelable", "eventPhase", "URL");
     }
  }

Parameters
className:String — The name of your custom Event class. In the previous example, the className parameter is PingEvent.
... arguments — The properties of the Event class and the properties that you add in your custom Event class. In the previous example, the ...arguments parameter includes type, bubbles, cancelable, eventPhase, and URL.

Returns
String — The name of your custom Event class and the String value of your ...arguments parameter.
isDefaultPrevented () method
public function isDefaultPrevented():Boolean

Checks whether preventDefault() has been called on the event. If preventDefault() has been called, returns true; otherwise, returns false.

Returns
Boolean — If preventDefault() has been called, returns true; otherwise, returns false.

See also

flash.events.Event.preventDefault()
Event objects
preventDefault () method
public function preventDefault():void

Cancels an event's default behavior if that behavior can be canceled.

Many events have associated behaviors that Flash Player carries out by default. For example, if a user types a character into a text field, the default behavior is that the character is displayed in the text field. Because the TextEvent.TEXT_INPUT event's default behavior can be canceled, you can use the preventDefault() method to prevent the character from appearing.

An example of a behavior that is not cancelable is the default behavior associated with the Event.REMOVED event, which is generated whenever Flash Player is about to remove a display object from the display list. The default behavior (removing the element) cannot be canceled, so the preventDefault() method has no effect on this default behavior.

You can use the Event.cancelable property to check whether you can prevent the default behavior associated with a particular event. If the value of Event.cancelable is true, then preventDefault() can be used to cancel the event; otherwise, preventDefault() has no effect.

See also

flash.events.Event.isDefaultPrevented()
Event.cancelable
Event objects
stopImmediatePropagation () method
public function stopImmediatePropagation():void

Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. This method takes effect immediately, and it affects event listeners in the current node. In contrast, the stopPropagation() method doesn't take effect until all the event listeners in the current node finish processing.

Note: This method does not cancel the behavior associated with this event; see preventDefault() for that functionality.

See also

flash.events.Event.stopPropagation()
flash.events.Event.preventDefault()
Event objects
stopPropagation () method
public function stopPropagation():void

Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. This method does not affect any event listeners in the current node (currentTarget). In contrast, the stopImmediatePropagation() method prevents processing of event listeners in both the current node and subsequent nodes. Additional calls to this method have no effect. This method can be called in any phase of the event flow.

Note: This method does not cancel the behavior associated with this event; see preventDefault() for that functionality.

See also

flash.events.Event.stopImmediatePropagation()
flash.events.Event.preventDefault()
toString () method
public function toString():String

Returns a string containing all the properties of the Event object. The string is in the following format:

[Event type=value bubbles=value cancelable=value]

Returns
String — A string containing all the properties of the Event object.

See also

Event objects
Constant detail
ACTIVATE constant
public static const ACTIVATE:String = "activate"

Defines the value of the type property of an activate event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the ACTIVATE event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.DisplayObject.activate
DEACTIVATE
ADDED constant
public static const ADDED:String = "added"

Defines the value of the type property of an added event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The DisplayObject instance being added to the display list. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.DisplayObject.added
REMOVED
CANCEL constant
public static const CANCEL:String = "cancel"

Defines the value of the type property of a cancel event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | A reference to the object on which the operation is canceled.

See also

flash.net.FileReference.cancel
CHANGE constant
public static const CHANGE:String = "change"

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.text.TextField.change
flash.events.TextEvent.TEXT_INPUT
CLOSE constant
public static const CLOSE:String = "close"

Defines the value of the type property of a close event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object whose connection has been closed.

See also

flash.net.Socket.close
flash.net.XMLSocket.close
COMPLETE constant
public static const COMPLETE:String = "complete"

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.LoaderInfo.complete
flash.media.Sound.complete
flash.net.FileReference.complete
flash.net.URLLoader.complete
flash.net.URLStream.complete
Working with external data
CONNECT constant
public static const CONNECT:String = "connect"

Defines the value of the type property of a connect event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Socket or XMLSocket object that has established a network connection.

See also

flash.net.Socket.connect
flash.net.XMLSocket.connect
DEACTIVATE constant
public static const DEACTIVATE:String = "deactivate"

Defines the value of the type property of a deactivate event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the DEACTIVATE event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.DisplayObject.deactivate
ACTIVATE
ENTER_FRAME constant
public static const ENTER_FRAME:String = "enterFrame"

Defines the value of the type property of an enterFrame event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the ENTER_FRAME event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.DisplayObject.enterFrame
ID3 constant
public static const ID3:String = "id3"

Defines the value of the type property of an id3 event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Sound object loading the MP3 for which ID3 data is now available. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.media.Sound.id3
INIT constant
public static const INIT:String = "init"

Defines the value of the type property of an init event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The LoaderInfo object associated with the SWF file being loaded.

See also

flash.display.LoaderInfo.init
MOUSE_LEAVE constant
public static const MOUSE_LEAVE:String = "mouseLeave"

Defines the value of the type property of a mouseLeave event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Stage object. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.Stage.mouseLeave
flash.events.MouseEvent
OPEN constant
public static const OPEN:String = "open"

Defines the value of the type property of an open event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has opened a connection.

See also

flash.display.LoaderInfo.open
flash.media.Sound.open
flash.net.FileReference.open
flash.net.URLLoader.open
flash.net.URLStream.open
REMOVED constant
public static const REMOVED:String = "removed"

Defines the value of the type property of a removed event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The DisplayObject instance to be removed from the display list. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.DisplayObject.removed
ADDED
RENDER constant
public static const RENDER:String = "render"

Defines the value of the type property of a render event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; the default behavior cannot be canceled.
currentTarget | The object that is actively processing the Event object with an event listener.
target | Any DisplayObject instance with a listener registered for the RENDER event. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.DisplayObject.render
flash.display.Stage.invalidate()
RESIZE constant
public static const RESIZE:String = "resize"

Defines the value of the type property of a resize event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Stage object.

See also

flash.display.Stage.resize
SCROLL constant
public static const SCROLL:String = "scroll"

Defines the value of the type property of a scroll event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The TextField object that has been scrolled. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.text.TextField.scroll
SELECT constant
public static const SELECT:String = "select"

Defines the value of the type property of a select event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The FileReference object on which an item has been selected.

See also

flash.net.FileReference.select
SOUND_COMPLETE constant
public static const SOUND_COMPLETE:String = "soundComplete"

Defines the value of the type property of a soundComplete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Sound object on which a sound has finished playing.

See also

flash.media.SoundChannel.soundComplete
TAB_CHILDREN_CHANGE constant
public static const TAB_CHILDREN_CHANGE:String = "tabChildrenChange"

Defines the value of the type property of a tabChildrenChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object whose tabChildren flag has changed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.tabChildrenChange
TAB_ENABLED_CHANGE constant
public static const TAB_ENABLED_CHANGE:String = "tabEnabledChange"

Defines the value of the type property of a tabEnabledChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The InteractiveObject whose tabEnabled flag has changed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.tabEnabledChange
TAB_INDEX_CHANGE constant
public static const TAB_INDEX_CHANGE:String = "tabIndexChange"

Defines the value of the type property of a tabIndexChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object whose tabIndex has changed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.tabIndexChange
UNLOAD constant
public static const UNLOAD:String = "unload"

Defines the value of the type property of an unload event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The LoaderInfo object associated with the SWF file being unloaded or replaced.

See also

flash.display.LoaderInfo.unload
Examples

The following example uses the EventExample class and the Square custom class to demonstrate how to manage event bubbling.
package {
    import flash.display.Sprite;
    import flash.events.Event;
    import flash.events.MouseEvent;

    public class EventExample extends Sprite {

        public function EventExample() {
            var square_0:Square = new Square(300, 0x336633);
            addChild(square_0);

            var square_1:Square = new Square(250, 0x669966);
            square_0.addChild(square_1);

            var square_2:Square = new Square(200, 0x66CC66);
            square_1.addChild(square_2);

            var square_3:Square = new Square(150, 0xAA0000);
            square_3.shouldBubble = false;
            square_2.addChild(square_3);

            var square_4:Square = new Square(100, 0x66FF66);
            square_3.addChild(square_4);

            var square_5:Square = new Square(50, 0xCC0000);
            square_5.shouldBubble = false;
            square_4.addChild(square_5);

            this.addEventListener(MouseEvent.CLICK, clickHandler);
        }

        private function clickHandler(e:Event):void {
            trace(">> stage: " + e.type + " event from " + e.target.name + " called on " + this.name);
            trace(">> --------------------------------------------");
        }
    }
}

import flash.display.Sprite;
import flash.events.Event;
import flash.events.MouseEvent;

class Square extends Sprite {
    private var sideLen:int;
    private var color:Number;
    public var shouldBubble:Boolean = true;

    public function Square(sideLen:int, color:Number) {
        this.sideLen = sideLen;
        this.color = color;
        init();
        draw();
    }

    private function init():void {
        buttonMode = true;
        this.addEventListener(MouseEvent.CLICK, firstClickHandler);
        this.addEventListener(MouseEvent.CLICK, secondClickHandler);
        this.addEventListener(MouseEvent.CLICK, thirdClickHandler);
    }

    private function draw():void {
        this.graphics.beginFill(color);
        this.graphics.drawRect(0, 0, sideLen, sideLen);
    }

    private function firstClickHandler(e:Event):void {
        trace(">> 1e: " + e.type + " event from " + e.target.name + " called on " + this.name);
        if(!shouldBubble) {
            e.stopPropagation();
        }
    }

    private function secondClickHandler(e:Event):void {
        trace(">> 2e: " + e.type + " event from " + e.target.name + " called on " + this.name);
        if(!shouldBubble) {
            e.stopImmediatePropagation();
            trace(">> --------------------------------------------");
        }
    }

    private function thirdClickHandler(e:Event):void {
        trace(">> 3e: " + e.type + " event from " + e.target.name + " called on " + this.name);
    }
}


flash.events.EventDispatcher (Flex™ 2 Language Reference)

Class EventDispatcher | Properties | Methods | Examples
Package | flash.events
Class | public class EventDispatcher
Inheritance | EventDispatcher Inheritance Object
Implements | IEventDispatcher
Subclasses | AbstractInvoker, AsyncToken, AxisBase, Camera, Channel, ChannelSet, ChartItem, ContextMenu, ContextMenuItem, CSSStyleDeclaration, DataStore, DataTransform, DisplayObject, Effect, EffectInstance, EffectManager, FileReference, FileReferenceList, IME, LayoutManager, LoaderInfo, LocalConnection, LogLogger, MessageAgent, Microphone, NetConnection, NetStream, PrintJob, RadioButtonGroup, SetEventHandler, SharedObject, Socket, Sort, SortField, Sound, SoundChannel, State, StyleSheet, Timer, ToolTipManager, Tween, URLLoader, URLStream, Validator, XMLSocket

The EventDispatcher class implements the IEventDispatcher interface and is the base class for the DisplayObject class. The EventDispatcher class allows any object on the display list to be an event target and as such, to use the methods of the IEventDispatcher interface.

Event targets are an important part of the Flash® Player event model. The event target serves as the focal point for how events flow through the display list hierarchy. When an event such as a mouse click or a keypress occurs, Flash Player dispatches an event object into the event flow from the root of the display list. The event object then makes its way through the display list until it reaches the event target, at which point it begins its return trip through the display list. This round-trip journey to the event target is conceptually divided into three phases: the capture phase comprises the journey from the root to the last node before the event target's node, the target phase comprises only the event target node, and the bubbling phase comprises any subsequent nodes encountered on the return trip to the root of the display list.

In general, the easiest way for a user-defined class to gain event dispatching capabilities is to extend EventDispatcher. If this is impossible (that is, if the class is already extending another class), you can instead implement the IEventDispatcher interface, create an EventDispatcher member, and write simple hooks to route calls into the aggregated EventDispatcher.

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
EventDispatcher(target:IEventDispatcher = null)
Aggregates an instance of the EventDispatcher class.
EventDispatcher
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Constructor detail
EventDispatcher () constructor
public function EventDispatcher(target:IEventDispatcher = null)

Aggregates an instance of the EventDispatcher class.

The EventDispatcher class is generally used as a base class, which means that most developers do not need to use this constructor function. However, advanced developers who are implementing the IEventDispatcher interface need to use this constructor. If you are unable to extend the EventDispatcher class and must instead implement the IEventDispatcher interface, use this constructor to aggregate an instance of the EventDispatcher class.

Parameters
target:IEventDispatcher (default = null) — The target object for events dispatched to the EventDispatcher object. This parameter is used when the EventDispatcher instance is aggregated by a class that implements IEventDispatcher; it is necessary so that the containing object can be the target for events. Do not use this parameter in simple cases in which a class extends EventDispatcher.
Method detail
addEventListener () method
public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event. You can register event listeners on all nodes in the display list for a specific type of event, phase, and priority.

After you successfully register an event listener, you cannot change its priority through additional calls to addEventListener(). To change a listener's priority, you must first call removeListener(). Then you can register the listener again with the new priority level.

Keep in mind that after the listener is registered, subsequent calls to addEventListener() with a different type or useCapture value result in the creation of a separate listener registration. For example, if you first register a listener with useCapture set to true, it listens only during the capture phase. If you call addEventListener() again using the same listener object, but with useCapture set to false, you have two separate listeners: one that listens during the capture phase and another that listens during the target and bubbling phases.

You cannot register an event listener for only the target phase or the bubbling phase. Those phases are coupled during registration because bubbling applies only to the ancestors of the target node.

If you no longer need an event listener, remove it by calling removeEventListener(), or memory problems could result. Objects with registered event listeners are not automatically removed from memory because the garbage collector does not remove objects that still have references.

Copying an EventDispatcher instance does not copy the event listeners attached to it. (If your newly created node needs an event listener, you must attach the listener after creating the node). However, if you move an EventDispatcher instance, the event listeners attached to it move along with it.

If the event listener is being registered on a node while an event is being processed on this node, the event listener is not triggered during the current phase but can be triggered during a later phase in the event flow, such as the bubbling phase.

If an event listener is removed from a node while an event is being processed on the node, it is still triggered by the current actions. After it is removed, the event listener is never invoked again (unless registered again for future processing).

Parameters
type:String — The type of event.
listener:Function — The listener function that processes the event. This function must accept an Event object as its only parameter and must return nothing, as this example shows:

function(evt:Event):void

The function can have any name.
useCapture:Boolean (default = false) — Determines whether the listener works in the capture phase or the target and bubbling phases. If useCapture is set to true, the listener processes the event only during the capture phase and not in the target or bubbling phase. If useCapture is false, the listener processes the event only during the target or bubbling phase. To listen for the event in all three phases, call addEventListener twice, once with the useCapture set to true, then again with useCapture set to false.
priority:int (default = 0) — The priority level of the event listener. The priority is designated by a signed 32-bit integer. The higher the number, the higher the priority. All listeners with priority n are processed before listeners of priority n-1. If two or more listeners share the same priority, they are processed in the order in which they were added. The default priority is 0.
useWeakReference:Boolean (default = false) — Determines whether the reference to the listener is strong or weak. A strong reference (the default) prevents your listener from being garbage-collected. A weak reference does not.

Throws
ArgumentError — The listener specified is not a function.

See also

Event listeners
dispatchEvent () method
public function dispatchEvent(event:Event):Boolean

Dispatches an event into the event flow. The event target is the EventDispatcher object upon which the dispatchEvent() method is called.

Parameters
event:Event — The Event object that is dispatched into the event flow. If the event is being redispatched, a clone of the event is created automatically. After an event is dispatched, its target property cannot be changed, so you must create a new copy of the event for redispatching to work.

Returns
Boolean — A value of true if the event was successfully dispatched. A value of false indicates failure or that preventDefault() was called on the event.

Throws
Error — The event dispatch recursion limit has been reached.
hasEventListener () method
public function hasEventListener(type:String):Boolean

Checks whether the EventDispatcher object has any listeners registered for a specific type of event. This allows you to determine where an EventDispatcher object has altered handling of an event type in the event flow hierarchy. To determine whether a specific event type actually triggers an event listener, use willTrigger().

The difference between hasEventListener() and willTrigger() is that hasEventListener() examines only the object to which it belongs, whereas willTrigger() examines the entire event flow for the event specified by the type parameter.

When hasEventListener() is called from a LoaderInfo object, only the listeners that the caller can access are considered.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type is registered; false otherwise.

See also

willTrigger()
removeEventListener () method
public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Removes a listener from the EventDispatcher object. If there is no matching listener registered with the EventDispatcher object, a call to this method has no effect.

Parameters
type:String — The type of event.
listener:Function — The listener object to remove.
useCapture:Boolean (default = false) — Specifies whether the listener was registered for the capture phase or the target and bubbling phases. If the listener was registered for both the capture phase and the target and bubbling phases, two calls to removeEventListener() are required to remove both, one call with useCapture() set to true, and another call with useCapture() set to false.

See also

Event listeners
willTrigger () method
public function willTrigger(type:String):Boolean

Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type. This method returns true if an event listener is triggered during any phase of the event flow when an event of the specified type is dispatched to this EventDispatcher object or any of its descendants.

The difference between the hasEventListener() and the willTrigger() methods is that hasEventListener() examines only the object to which it belongs, whereas the willTrigger() method examines the entire event flow for the event specified by the type parameter.

When willTrigger() is called from a LoaderInfo object, only the listeners that the caller can access are considered.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type will be triggered; false otherwise.
Examples

The following example uses the classes EventDispatcherExample and CustomDispatcher, a subclass of EventDispatcher, to show how a custom event is created and dispatched. The example carries out the following tasks:
  1. The constructor of EventDispatcherExample creates a local variable dispatcher and assigns it to a new CustomDispatcher instance.
  2. Inside CustomDispatcher, a string is set so that the event has the name action, and the doAction() method is declared. When called, this method creates the action event and dispatches it using EventDispatcher.dispatchEvent().
  3. The dispatcher property is then used to add the action event listener and associated subscriber method actionHandler(), which simply prints information about the event when it is dispatched.
  4. The doAction() method is invoked, dispatching the action event.
package {
    import flash.display.Sprite;
    import flash.events.Event;

    public class EventDispatcherExample extends Sprite {

        public function EventDispatcherExample() {
            var dispatcher:CustomDispatcher = new CustomDispatcher();
            dispatcher.addEventListener(CustomDispatcher.ACTION, actionHandler);
            dispatcher.doAction();
        }

        private function actionHandler(event:Event):void {
            trace("actionHandler: " + event);
        }
    }
}

import flash.events.EventDispatcher;
import flash.events.Event;

class CustomDispatcher extends EventDispatcher {
    public static var ACTION:String = "action";

    public function doAction():void {
        dispatchEvent(new Event(CustomDispatcher.ACTION));
    }
}


flash.events.EventPhase (Flex™ 2 Language Reference)

Class EventPhase | Properties | Methods | Constants
Package | flash.events
Class | public final class EventPhase
Inheritance | EventPhase Inheritance Object

The EventPhase class provides values for the eventPhase property of the Event class.

See also

Event class
EventDispatcher class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | AT_TARGET : uint = 2 [static] The target phase, which is the second phase of the event flow. | EventPhase
 | BUBBLING_PHASE : uint = 3 [static] The bubbling phase, which is the third phase of the event flow. | EventPhase
 | CAPTURING_PHASE : uint = 1 [static] The capturing phase, which is the first phase of the event flow. | EventPhase
Constant detail
AT_TARGET constant
public static const AT_TARGET:uint = 2

The target phase, which is the second phase of the event flow.

BUBBLING_PHASE constant
public static const BUBBLING_PHASE:uint = 3

The bubbling phase, which is the third phase of the event flow.

CAPTURING_PHASE constant
public static const CAPTURING_PHASE:uint = 1

The capturing phase, which is the first phase of the event flow.


flash.events.FocusEvent (Flex™ 2 Language Reference)

Class FocusEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class FocusEvent
Inheritance | FocusEvent Inheritance Event Inheritance Object

Flash® Player dispatches FocusEvent objects when the user changes the focus from one object in the display list to another. There are four types of focus events:
  • FocusEvent.FOCUS_IN
  • FocusEvent.FOCUS_OUT
  • FocusEvent.KEY_FOCUS_CHANGE
  • FocusEvent.MOUSE_FOCUS_CHANGE

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | keyCode : uint The key code value of the key pressed to trigger a keyFocusChange event. | FocusEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relatedObject : InteractiveObject A reference to the complementary InteractiveObject instance that is affected by the change in focus. | FocusEvent
 | shiftKey : Boolean Indicates whether the Shift key modifier is activated, in which case the value is true. | FocusEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | FocusEvent(type:String, bubbles:Boolean = true, cancelable:Boolean = false, relatedObject:InteractiveObject = null, shiftKey:Boolean = false, keyCode:uint = 0) Creates an Event object with specific information relevant to focus events. | FocusEvent
 | clone():Event Creates a copy of the FocusEvent object and sets the value of each property to match that of the original. | FocusEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the FocusEvent object. | FocusEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | FOCUS_IN : String = "focusIn" [static] Defines the value of the type property of a focusIn event object. | FocusEvent
 | FOCUS_OUT : String = "focusOut" [static] Defines the value of the type property of a focusOut event object. | FocusEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | KEY_FOCUS_CHANGE : String = "keyFocusChange" [static] Defines the value of the type property of a keyFocusChange event object. | FocusEvent
 | MOUSE_FOCUS_CHANGE : String = "mouseFocusChange" [static] Defines the value of the type property of a mouseFocusChange event object. | FocusEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
keyCode property
keyCode:uint [read-write]

The key code value of the key pressed to trigger a keyFocusChange event.

Implementation
    public function get keyCode():uint
    public function set keyCode(value:uint):void
relatedObject property
relatedObject:InteractiveObject [read-write]

A reference to the complementary InteractiveObject instance that is affected by the change in focus. For example, when a focusOut event occurs, the relatedObject represents the InteractiveObject instance that has gained focus.

Implementation
    public function get relatedObject():InteractiveObject
    public function set relatedObject(value:InteractiveObject):void
shiftKey property
shiftKey:Boolean [read-write]

Indicates whether the Shift key modifier is activated, in which case the value is true. Otherwise, the value is false. This property is used only if the FocusEvent is of type keyFocusChange.

Implementation
    public function get shiftKey():Boolean
    public function set shiftKey(value:Boolean):void
Constructor detail
FocusEvent () constructor
public function FocusEvent(type:String, bubbles:Boolean = true, cancelable:Boolean = false, relatedObject:InteractiveObject = null, shiftKey:Boolean = false, keyCode:uint = 0)

Creates an Event object with specific information relevant to focus events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Possible values are: FocusEvent.FOCUS_IN, FocusEvent.FOCUS_OUT, FocusEvent.KEY_FOCUS_CHANGE, and FocusEvent.MOUSE_FOCUS_CHANGE.
bubbles:Boolean (default = true) — Determines whether the Event object participates in the bubbling stage of the event flow.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled.
relatedObject:InteractiveObject (default = null) — Indicates the complementary InteractiveObject instance that is affected by the change in focus. For example, when a focusIn event occurs, relatedObject represents the InteractiveObject that has lost focus.
shiftKey:Boolean (default = false) — Indicates whether the Shift key modifier is activated.
keyCode:uint (default = 0) — Indicates the code of the key pressed to trigger a keyFocusChange event.

See also

FOCUS_IN
FOCUS_OUT
KEY_FOCUS_CHANGE
MOUSE_FOCUS_CHANGE
Method detail
clone () method
public override function clone():Event

Creates a copy of the FocusEvent object and sets the value of each property to match that of the original.

Returns
Event — A new FocusEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the FocusEvent object. The string is in the following format:

[FocusEvent type=value bubbles=value cancelable=value relatedObject=value shiftKey=value]

Returns
String — A string that contains all the properties of the FocusEvent object.
Constant detail
FOCUS_IN constant
public static const FOCUS_IN:String = "focusIn"

Defines the value of the type property of a focusIn event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | 0; applies only to keyFocusChange events.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | false; applies only to keyFocusChange events.
target | The InteractiveObject instance that has just received focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.focusIn
FOCUS_OUT constant
public static const FOCUS_OUT:String = "focusOut"

Defines the value of the type property of a focusOut event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | 0; applies only to keyFocusChange events.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | false; applies only to keyFocusChange events.
target | The InteractiveObject instance that has just lost focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.focusOut
KEY_FOCUS_CHANGE constant
public static const KEY_FOCUS_CHANGE:String = "keyFocusChange"

Defines the value of the type property of a keyFocusChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | The key code value of the key pressed to trigger a keyFocusChange event.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | true if the Shift key modifier is activated; false otherwise.
target | The InteractiveObject instance that currently has focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.keyFocusChange
MOUSE_FOCUS_CHANGE constant
public static const MOUSE_FOCUS_CHANGE:String = "mouseFocusChange"

Defines the value of the type property of a mouseFocusChange event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | 0; applies only to keyFocusChange events.
relatedObject | The complementary InteractiveObject instance that is affected by the change in focus.
shiftKey | false; applies only to keyFocusChange events.
target | The InteractiveObject instance that currently has focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.mouseFocusChange
Examples

The following example uses the FocusEventExample and CustomSprite classes to show how focus can be used in conjunction with items drawn on the Stage to capture events and print information. This example carries out the following tasks:
  1. It declares the properties child (of type Sprite) and childCount (of type uint).
  2. A for loop creates five light blue squares at (0,0). It begins by assigning child to a new CustomSprite instance. Each time a CustomSprite object is created, the following happens:
    • The size property of type uint is set to 50 pixels and bgColor is set to light blue.
    • The buttonMode and useHandCursor properties of the Sprite class are set to true within the constructor.
    • An event listener of type click is instantiated, along with the associated subscriber clickHandler(). The subscriber method creates a local variable target of type Sprite and assigns it whichever box was clicked. The Stage's focus is then assigned to target.
    • The draw() method is called, which creates a 50 x 50 pixel square by calling the beginFill(), drawRect(), and endFill() methods of the Graphics class and the instance properties.
  3. In the for loop, the configureListeners() method is called, which instantiates three event listeners/subscribers:
    • focusIn/focusInHandler() is dispatched after the click event for whichever display list object (box) is clicked.
    • focusOut/focusOutHandler() is dispatched when another box is clicked or if the focus leaves the Stage (for example, by clicking outside Flash Player).
    • keyFocusChange/keyFocusChangeHandler() is dispatched if you use the Tab key or the left-arrow or right-arrow keys to select a display list object. The keyFocusChangeHandler() method traps the left-arrow and right-arrow keys, however, and calls the preventDefault() method to disable them.
  4. In the for loop, each square is added to the display list and displayed (all in the same area) by means of addChild().
  5. The constructor then calls refreshLayout(), which distributes the orange squares across the top (y = 0) of the display with 5 pixels separating each square.
package {
    import flash.display.Sprite;
    import flash.display.DisplayObject;
    import flash.events.FocusEvent;
    import flash.events.IEventDispatcher;

    public class FocusEventExample extends Sprite {
        private var gutter:uint = 5;
        private var childCount:uint = 5;

        public function FocusEventExample() {
            var child:Sprite;
            for(var i:uint; i < childCount; i++) {
                child = new CustomSprite();
                configureListeners(child);
                addChild(child);
            }
            refreshLayout();
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(FocusEvent.FOCUS_IN, focusInHandler);
            dispatcher.addEventListener(FocusEvent.FOCUS_OUT, focusOutHandler);
            dispatcher.addEventListener(FocusEvent.KEY_FOCUS_CHANGE, keyFocusChangeHandler);
            dispatcher.addEventListener(FocusEvent.MOUSE_FOCUS_CHANGE, mouseFocusChangeHandler);
        }

        private function refreshLayout():void {
            var ln:uint = numChildren;
            var child:DisplayObject = getChildAt(0);
            var lastChild:DisplayObject = child;
            for(var i:uint = 1; i < ln; i++) {
                child = getChildAt(i);
                child.x = lastChild.x + lastChild.width + gutter;
                lastChild = child;
            }
        }

        private function focusInHandler(event:FocusEvent):void {
            var target:CustomSprite = CustomSprite(event.target);
            trace("focusInHandler: " + target.name);
        }

        private function focusOutHandler(event:FocusEvent):void {
            var target:CustomSprite = CustomSprite(event.target);
            trace("focusOutHandler: " + target.name);
        }

        private function keyFocusChangeHandler(event:FocusEvent):void {
            if(event.keyCode == 39 || event.keyCode == 37){
                event.preventDefault()
            }
            var target:CustomSprite = CustomSprite(event.target);
            trace("keyFocusChangeHandler: " + target.name);
        }
        private function mouseFocusChangeHandler(event:FocusEvent):void {
            var target:CustomSprite = CustomSprite(event.target);
            trace("mouseFocusChangeHandler: " + target.name);
        }
    }
}

import flash.display.Sprite;
import flash.events.MouseEvent;

class CustomSprite extends Sprite {
    private var size:uint = 50;
    private var bgColor:uint = 0x00CCFF;

    public function CustomSprite() {
        buttonMode = true;
        useHandCursor = true;
        addEventListener(MouseEvent.CLICK, clickHandler);
        draw(size, size);
    }

    private function draw(w:uint, h:uint):void {
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, w, h);
        graphics.endFill();
    }

    private function clickHandler(event:MouseEvent):void {
        var target:Sprite = Sprite(event.target);
        trace("clickHandler: " + target.name);
        stage.focus = target;
    }
}


flash.events.HTTPStatusEvent (Flex™ 2 Language Reference)

Class HTTPStatusEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class HTTPStatusEvent
Inheritance | HTTPStatusEvent Inheritance Event Inheritance Object

Flash® Player dispatches HTTPStatusEvent objects when a network request returns an HTTP status code. There is only one type of HTTPStatus event: HTTPStatusEvent.HTTP_STATUS.

HTTPStatusEvent objects are always sent before error or completion events. An HTTPStatusEvent object does not necessarily indicate an error condition; it simply reflects the HTTP status code (if any) that is provided by the networking stack. Some Flash Player environments may be unable to detect HTTP status codes; a status code of 0 is always reported in these cases.

View the examples.

See also

HTTP_STATUS

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | status : int [read-only] The HTTP status code returned by the server. | HTTPStatusEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | HTTPStatusEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, status:int = 0) Creates an Event object that contains specific information about HTTP status events. | HTTPStatusEvent
 | clone():Event Creates a copy of the HTTPStatusEvent object and sets the value of each property to match that of the original. | HTTPStatusEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the HTTPStatusEvent object. | HTTPStatusEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | HTTP_STATUS : String = "httpStatus" [static] Defines the value of the type property of a httpStatus event object. | HTTPStatusEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
status property
status:int [read-only]

The HTTP status code returned by the server. For example, a value of 404 indicates that the server has not found a match for the requested URI. HTTP status codes can be found in sections 10.4 and 10.5 of the HTTP specification at ftp://ftp.isi.edu/in-notes/rfc2616.txt.

If Flash Player cannot get a status code from the server, or if it cannot communicate with the server, the default value of 0 is passed to your ActionScript code. A value of 0 can be generated in any player (for example, if a malformed URL is requested), and a value of 0 is always generated by the Flash Player plug-in when it is run in the following browsers, which do not pass HTTP status codes to the player: Netscape, Mozilla, Safari, Opera, and Internet Explorer for the Macintosh.

Implementation
    public function get status():int
Constructor detail
HTTPStatusEvent () constructor
public function HTTPStatusEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, status:int = 0)

Creates an Event object that contains specific information about HTTP status events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of HTTPStatus event: HTTPStatusEvent.HTTP_STATUS.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
status:int (default = 0) — Numeric status. Event listeners can access this information through the status property.

See also

HTTP_STATUS
Method detail
clone () method
public override function clone():Event

Creates a copy of the HTTPStatusEvent object and sets the value of each property to match that of the original.

Returns
Event — A new HTTPStatusEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the HTTPStatusEvent object. The string is in the following format:

[HTTPStatusEvent type=value bubbles=value cancelable=value status=value]

Returns
String — A string that contains all the properties of the HTTPStatusEvent object.
Constant detail
HTTP_STATUS constant
public static const HTTP_STATUS:String = "httpStatus"

Defines the value of the type property of a httpStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
status | The HTTP status code returned by the server.
target | The network object receiving an HTTP status code.

See also

flash.display.LoaderInfo.httpStatus
flash.net.URLLoader.httpStatus
flash.net.URLStream.httpStatus
Examples

The following example attempts to load a nonexistent file from the root web directory at http://www.[yourDomain].com, which should dispatch an httpStatusHandler event with a status of 404, indicating that the file was not found. The httpStatusHandler event is handled by httpStatusHandler(), which simply prints two lines of information about the event.

Notes:

  1. You need to compile the SWF file with "Local Playback Security" set to "Access Network Only" to generate a securityError event in this example.
  2. You need a server running on http://www.[yourDomain].com and listening on port 80 or you will receive an httpStatusHandler event with status code 0 instead of 404.
  3. You must not have a file named MissingFile.html at the root web directory of http://www.[yourDomain].com or you will not receive the correct httpStatusHandler event.

package {
    import flash.display.Sprite;
    import flash.net.URLLoader;
    import flash.net.URLRequest;
    import flash.events.HTTPStatusEvent;

    public class HTTPStatusEventExample extends Sprite {

        public function HTTPStatusEventExample() {
            var loader:URLLoader = new URLLoader();
            loader.addEventListener(HttpStatusEvent.HTTP_STATUS, httpStatusHandler);

            var request:URLRequest = new URLRequest("http://www.[yourDomain].com/MissingFile.html");
            loader.load(request);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
            trace("status: " + event.status);
        }
    }
}


flash.events.IEventDispatcher (Flex™ 2 Language Reference)

Interface IEventDispatcher | Methods | Examples
Package | flash.events
Interface | public interface IEventDispatcher
Subinterfaces | IAxis, ICollectionView, IFlexDisplayObject, IFocusManagerContainer, ILayoutManagerClient, IList, IListItemRenderer, ILogger, IPreloaderDisplay, IPropertyChangeNotifier, ISystemManager, IViewCursor
Implementors | AbstractService, DataService, EventDispatcher

The IEventDispatcher interface defines methods for adding or removing event listeners, checks whether specific types of event listeners are registered, and dispatches events.

Event targets are an important part of the Flash® Player event model. The event target serves as the focal point for how events flow through the display list hierarchy. When an event such as a mouse click or a keypress occurs, Flash Player dispatches an Event object into the event flow from the root of the display list. The Event object makes a round-trip journey to the event target, which is conceptually divided into three phases: the capture phase includes the journey from the root to the last node before the event target's node; the target phase includes only the event target node; and the bubbling phase includes any subsequent nodes encountered on the return trip to the root of the display list.

In general, the easiest way for a user-defined class to gain event dispatching capabilities is to extend EventDispatcher. If this is impossible (that is, if the class is already extending another class), you can instead implement the IEventDispatcher interface, create an EventDispatcher member, and write simple hooks to route calls into the aggregated EventDispatcher.

View the examples.

Public Methods
Method Defined by
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Method detail
addEventListener () method
public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event. You can register event listeners on all nodes in the display list for a specific type of event, phase, and priority.

After you successfully register an event listener, you cannot change its priority through additional calls to addEventListener(). To change a listener's priority, you must first call removeListener(). Then you can register the listener again with the new priority level.

After the listener is registered, subsequent calls to addEventListener() with a different value for either type or useCapture result in the creation of a separate listener registration. For example, if you first register a listener with useCapture set to true, it listens only during the capture phase. If you call addEventListener() again using the same listener object, but with useCapture set to false, you have two separate listeners: one that listens during the capture phase, and another that listens during the target and bubbling phases.

You cannot register an event listener for only the target phase or the bubbling phase. Those phases are coupled during registration because bubbling applies only to the ancestors of the target node.

When you no longer need an event listener, remove it by calling EventDispatcher.removeEventListener(); otherwise, memory problems might result. Objects with registered event listeners are not automatically removed from memory because the garbage collector does not remove objects that still have references.

Copying an EventDispatcher instance does not copy the event listeners attached to it. (If your newly created node needs an event listener, you must attach the listener after creating the node.) However, if you move an EventDispatcher instance, the event listeners attached to it move along with it.

If the event listener is being registered on a node while an event is also being processed on this node, the event listener is not triggered during the current phase but may be triggered during a later phase in the event flow, such as the bubbling phase.

If an event listener is removed from a node while an event is being processed on the node, it is still triggered by the current actions. After it is removed, the event listener is never invoked again (unless it is registered again for future processing).

Parameters
type:String — The type of event.
listener:Function — The listener function that processes the event. This function must accept an Event object as its only parameter and must return nothing, as this example shows:

function(evt:Event):void

The function can have any name.
useCapture:Boolean (default = false) — Determines whether the listener works in the capture phase or the target and bubbling phases. If useCapture is set to true, the listener processes the event only during the capture phase and not in the target or bubbling phase. If useCapture is false, the listener processes the event only during the target or bubbling phase. To listen for the event in all three phases, call addEventListener() twice, once with useCapture set to true, then again with useCapture set to false.
priority:int (default = 0) — The priority level of the event listener. Priorities are designated by a 32-bit integer. The higher the number, the higher the priority. All listeners with priority n are processed before listeners of priority n-1. If two or more listeners share the same priority, they are processed in the order in which they were added. The default priority is 0.
useWeakReference:Boolean (default = false) — Determines whether the reference to the listener is strong or weak. A strong reference (the default) prevents your listener from being garbage-collected. A weak reference does not.
dispatchEvent () method
public function dispatchEvent(event:Event):Boolean

Dispatches an event into the event flow. The event target is the EventDispatcher object upon which dispatchEvent() is called.

Parameters
event:Event — The Event object dispatched into the event flow.

Returns
Boolean — A value of true unless preventDefault() is called on the event, in which case it returns false.
hasEventListener () method
public function hasEventListener(type:String):Boolean

Checks whether the EventDispatcher object has any listeners registered for a specific type of event. This allows you to determine where an EventDispatcher object has altered handling of an event type in the event flow hierarchy. To determine whether a specific event type will actually trigger an event listener, use IEventDispatcher.willTrigger().

The difference between hasEventListener() and willTrigger() is that hasEventListener() examines only the object to which it belongs, whereas willTrigger() examines the entire event flow for the event specified by the type parameter.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type is registered; false otherwise.

See also

willTrigger()
removeEventListener () method
public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Removes a listener from the EventDispatcher object. If there is no matching listener registered with the EventDispatcher object, a call to this method has no effect.

Parameters
type:String — The type of event.
listener:Function — The listener object to remove.
useCapture:Boolean (default = false) — Specifies whether the listener was registered for the capture phase or the target and bubbling phases. If the listener was registered for both the capture phase and the target and bubbling phases, two calls to removeEventListener() are required to remove both: one call with useCapture set to true, and another call with useCapture set to false.
willTrigger () method
public function willTrigger(type:String):Boolean

Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type. This method returns true if an event listener is triggered during any phase of the event flow when an event of the specified type is dispatched to this EventDispatcher object or any of its descendants.

The difference between hasEventListener() and willTrigger() is that hasEventListener() examines only the object to which it belongs, whereas willTrigger() examines the entire event flow for the event specified by the type parameter.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type will be triggered; false otherwise.
Examples

The following example uses the IEventDispatcherExample and DecoratedDispatcher sample classes to show how the IEventDispatcher class can be implemented and used. The example accomplishes this by implementing each method of DecoratedDispatcher in the same manner as in EventDispatcher. Within the constructor for IEventDispatcherExample, a new instance (named decorDispatcher) of the DecoratedDispatcher class is constructed and the decorDispatcher variable is used to call addEventListener() with the custom event doSomething, which is then handled by didSomething(), which prints a line of text using trace().

package {
        import flash.events.Event;
        import flash.display.Sprite;

        public class IEventDispatcherExample extends Sprite {
                public function IEventDispatcherExample() {
                        var decorDispatcher:DecoratedDispatcher = new DecoratedDispatcher();
                        decorDispatcher.addEventListener("doSomething", didSomething);
                        decorDispatcher.dispatchEvent(new Event("doSomething"));
                }

                public function didSomething(evt:Event):void {
                        trace(">> didSomething");
                }
        }
}

import flash.events.IEventDispatcher;
import flash.events.EventDispatcher;
import flash.events.Event;

class DecoratedDispatcher implements IEventDispatcher {
    private var dispatcher:EventDispatcher;

    public function DecoratedDispatcher() {
        dispatcher = new EventDispatcher(this);
    }

    public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void{
        dispatcher.addEventListener(type, listener, useCapture, priority);
    }

    public function dispatchEvent(evt:Event):Boolean{
        return dispatcher.dispatchEvent(evt);
    }

    public function hasEventListener(type:String):Boolean{
        return dispatcher.hasEventListener(type);
    }

    public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void{
        dispatcher.removeEventListener(type, listener, useCapture);
    }

    public function willTrigger(type:String):Boolean {
        return dispatcher.willTrigger(type);
    }
}


flash.events.IMEEvent (Flex™ 2 Language Reference)

Class IMEEvent | Properties | Methods | Constants
Package | flash.events
Class | public class IMEEvent
Inheritance | IMEEvent Inheritance TextEvent Inheritance Event Inheritance Object

Flash® Player dispatches IMEEvent objects when a user enters text using an input method editor (IME). IMEs are generally used to enter text from languages that have ideographs instead of letters, such as Japanese, Chinese, and Korean. There is only one IME event: IMEEvent.IME_COMPOSITION.

See also

flash.system.IME
flash.events.IMEEvent.IME_COMPOSITION

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | text : String For a textInput event, the character or sequence of characters entered by the user. | TextEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | IMEEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "") Creates an Event object with specific information relevant to IME events. | IMEEvent
 | clone():Event Creates a copy of the IMEEvent object and sets the value of each property to match that of the original. | IMEEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the IMEEvent object. | IMEEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
 | IME_COMPOSITION : String = "imeComposition" [static] Defines the value of the type property of an imeComposition event object. | IMEEvent
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | LINK : String = "link" [static] Defines the value of the type property of a link event object. | TextEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | TEXT_INPUT : String = "textInput" [static] Defines the value of the type property of a textInput event object. | TextEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
IMEEvent () constructor
public function IMEEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "")

Creates an Event object with specific information relevant to IME events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one IME event: IMEEvent.IME_COMPOSITION.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
text:String (default = "") — The reading string from the IME. This is the initial string as typed by the user, before selection of any candidates. The final composition string is delivered to the object with keyboard focus in a TextEvent.TEXT_INPUT event. Event listeners can access this information through the text property.

See also

flash.system.IME
flash.events.IMEEvent.IME_COMPOSITION
Method detail
clone () method
public override function clone():Event

Creates a copy of the IMEEvent object and sets the value of each property to match that of the original.

Returns
Event — A new IMEEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the IMEEvent object. The string is in the following format:

[IMEEvent type=value bubbles=value cancelable=value text=value]

Returns
String — A string that contains all the properties of the IMEEvent object.
Constant detail
IME_COMPOSITION constant
public static const IME_COMPOSITION:String = "imeComposition"

Defines the value of the type property of an imeComposition event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The IME object.

See also

flash.system.IME.imeComposition
IME class


flash.events.IOErrorEvent (Flex™ 2 Language Reference)

Class IOErrorEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class IOErrorEvent
Inheritance | IOErrorEvent Inheritance ErrorEvent Inheritance TextEvent Inheritance Event Inheritance Object

Flash® Player dispatches an IOErrorEvent object when an error causes a send or load operation to fail.

You can check for error events that do not have any listeners by using the debugger version of Flash Player. Flash Player displays the string defined by the text parameter of the IOErrorEvent constructor. There is only one type of input/output error event: IOErrorEvent.IO_ERROR.

View the examples.

See also

IO_ERROR

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | text : String For a textInput event, the character or sequence of characters entered by the user. | TextEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | IOErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "") Creates an Event object that contains specific information about ioError events. | IOErrorEvent
 | clone():Event Creates a copy of the IOErrorEvent object and sets the value of each property to match that of the original. | IOErrorEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the IOErrorEvent object. | IOErrorEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ERROR : String = "error" [static] Defines the value of the type property of an error event object. | ErrorEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | IO_ERROR : String = "ioError" [static] Defines the value of the type property of an ioError event object. | IOErrorEvent
Inherited | LINK : String = "link" [static] Defines the value of the type property of a link event object. | TextEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | TEXT_INPUT : String = "textInput" [static] Defines the value of the type property of a textInput event object. | TextEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
IOErrorEvent () constructor
public function IOErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "")

Creates an Event object that contains specific information about ioError events. Event objects are passed as parameters to Event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of input/output error event: IOErrorEvent.IO_ERROR.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
text:String (default = "") — Text to be displayed as an error message. Event listeners can access this information through the text property.

See also

IO_ERROR
Method detail
clone () method
public override function clone():Event

Creates a copy of the IOErrorEvent object and sets the value of each property to match that of the original.

Returns
Event — A new IOErrorEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the IOErrorEvent object. The string is in the following format:

[IOErrorEvent type=value bubbles=value cancelable=value text=value]

Returns
String — A string that contains all the properties of the IOErrorEvent object.
Constant detail
IO_ERROR constant
public static const IO_ERROR:String = "ioError"

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.

See also

flash.display.LoaderInfo.ioError
flash.media.Sound.ioError
flash.net.Socket.ioError
flash.net.FileReference.ioError
flash.net.NetConnection.ioError
flash.net.NetStream.ioError
flash.net.URLLoader.ioError
flash.net.URLStream.ioError
flash.net.XMLSocket.ioError
Examples

The following example uses the IOErrorEventExample class to show how an error event object is dispatched when an attempt is made to load a nonexistent file. The example carries out the following tasks:
  1. The class constructor creates a new instance of a URLLoader object and assigns it to the variable loader.
  2. The URLLoader instance instantiates an event listener of type ioError, which has an associated subscriber method ioErrorHandler(), which simply prints information about the event using trace().
  3. Next, the constructor creates a new instance of a URLRequest object, request, passing MissingFile.xml so that the name and location of the missing file are known.
  4. The request variable is then passed to loader.load(), which attempts to load the missing file. Since the file is missing, the event handler dispatches an ioError event.

Notes:

  • You need to compile the SWF file with "Local Playback Security" set to "Access Local Files Only".
  • Make sure that you do not have a file named "MissingFile.xml" at the same level as your SWF file.

package {
    import flash.display.Sprite;
    import flash.events.IOErrorEvent;
    import flash.net.URLLoader;
    import flash.net.URLRequest;

    public class IOErrorEventExample extends Sprite {
        public function IOErrorEventExample() {
            var loader:URLLoader = new URLLoader();
            loader.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);

            var request:URLRequest = new URLRequest("MissingFile.xml");
            loader.load(request);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }
    }
}


flash.events.KeyboardEvent (Flex™ 2 Language Reference)

Class KeyboardEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class KeyboardEvent
Inheritance | KeyboardEvent Inheritance Event Inheritance Object

Flash® Player dispatches KeyboardEvent objects in response to user input through a keyboard. There are two types of keyboard events: KeyboardEvent.KEY_DOWN and KeyboardEvent.KEY_UP

Because mappings between keys and specific characters vary by device and operating system, use the TextEvent event type for processing character input.

To listen globally for key events, listen on the Stage for the capture and target or bubble phase.

View the examples.

See also

KEY_DOWN
KEY_UP
KeyLocation
About keyboard events
Handling keyboard events
Understanding the keyCode and charCode properties
Understanding KeyboardEvent precedence

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | altKey : Boolean Reserved for future use. | KeyboardEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | charCode : uint Contains the character code value of the key pressed or released. | KeyboardEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | ctrlKey : Boolean Indicates whether the Control key is active (true) or inactive (false). | KeyboardEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | keyCode : uint The key code value of the key pressed or released. | KeyboardEvent
 | keyLocation : uint Indicates the location of the key on the keyboard. | KeyboardEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | shiftKey : Boolean Indicates whether the Shift key modifier is active (true) or inactive (false). | KeyboardEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | KeyboardEvent(type:String, bubbles:Boolean = true, cancelable:Boolean = false, charCode:uint = 0, keyCode:uint = 0, keyLocation:uint = 0, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false) Creates an Event object that contains specific information about keyboard events. | KeyboardEvent
 | clone():Event Creates a copy of the KeyboardEvent object and sets the value of each property to match that of the original. | KeyboardEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the KeyboardEvent object. | KeyboardEvent
 | updateAfterEvent():void Instructs Flash Player to render after processing of this event completes, if the display list has been modified | KeyboardEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | KEY_DOWN : String = "keyDown" [static] Defines the value of the type property of a keyDown event object. | KeyboardEvent
 | KEY_UP : String = "keyUp" [static] Defines the value of the type property of a keyUp event object. | KeyboardEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
altKey property
altKey:Boolean [read-write]

Reserved for future use. This property is not currently supported.

Implementation
    public function get altKey():Boolean
    public function set altKey(value:Boolean):void
charCode property
charCode:uint [read-write]

Contains the character code value of the key pressed or released. The character code values are English keyboard values. For example, if you press Shift+3, charCode is # on a Japanese keyboard, just as it is on an English keyboard.

Note: When an input method editor (IME) is running, charCode does not report accurate character codes.

Implementation
    public function get charCode():uint
    public function set charCode(value:uint):void

See also

flash.system.IME
ctrlKey property
ctrlKey:Boolean [read-write]

Indicates whether the Control key is active (true) or inactive (false).

Note: The Command key modifier on Macintosh systems must be represented using this key modifier.

Implementation
    public function get ctrlKey():Boolean
    public function set ctrlKey(value:Boolean):void
keyCode property
keyCode:uint [read-write]

The key code value of the key pressed or released.

Note: When an input method editor (IME) is running, keyCode does not report accurate key codes.

Implementation
    public function get keyCode():uint
    public function set keyCode(value:uint):void

See also

flash.system.IME
keyLocation property
keyLocation:uint [read-write]

Indicates the location of the key on the keyboard. This is useful for differentiating keys that appear more than once on a keyboard. For example, you can differentiate between the left and right Shift keys by the value of this property: KeyLocation.LEFT for the left and KeyLocation.RIGHT for the right. Another example is differentiating between number keys pressed on the standard keyboard (KeyLocation.STANDARD) versus the numeric keypad (KeyLocation.NUM_PAD).

Implementation
    public function get keyLocation():uint
    public function set keyLocation(value:uint):void
shiftKey property
shiftKey:Boolean [read-write]

Indicates whether the Shift key modifier is active (true) or inactive (false).

Implementation
    public function get shiftKey():Boolean
    public function set shiftKey(value:Boolean):void
Constructor detail
KeyboardEvent () constructor
public function KeyboardEvent(type:String, bubbles:Boolean = true, cancelable:Boolean = false, charCode:uint = 0, keyCode:uint = 0, keyLocation:uint = 0, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false)

Creates an Event object that contains specific information about keyboard events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Possible values are: KeyboardEvent.KEY_DOWN and KeyboardEvent.KEY_UP
bubbles:Boolean (default = true) — Determines whether the Event object participates in the bubbling stage of the event flow.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled.
charCode:uint (default = 0) — The character code value of the key pressed or released. The character code values returned are English keyboard values. For example, if you press Shift+3, the getASCIICode() method returns # on a Japanese keyboard, just as it does on an English keyboard.
keyCode:uint (default = 0) — The key code value of the key pressed or released.
keyLocation:uint (default = 0) — The location of the key on the keyboard.
ctrlKey:Boolean (default = false) — Indicates whether the Control key modifier is activated.
altKey:Boolean (default = false) — Reserved for future use (not currently supported).
shiftKey:Boolean (default = false) — Indicates whether the Shift key modifier is activated.

See also

KEY_DOWN
KEY_UP
Method detail
clone () method
public override function clone():Event

Creates a copy of the KeyboardEvent object and sets the value of each property to match that of the original.

Returns
Event — A new KeyboardEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the KeyboardEvent object. The string is in the following format:

[KeyboardEvent type=value bubbles=value cancelable=value ... shiftKey=value]

Returns
String — A string that contains all the properties of the KeyboardEvent object.
updateAfterEvent () method
public function updateAfterEvent():void

Instructs Flash Player to render after processing of this event completes, if the display list has been modified

Constant detail
KEY_DOWN constant
public static const KEY_DOWN:String = "keyDown"

Defines the value of the type property of a keyDown event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
charCode | The character code value of the key pressed or released.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | The key code value of the key pressed or released.
keyLocation | The location of the key on the keyboard.
shiftKey | true if the Shift key is active; false if it is inactive.
target | The InteractiveObject instance with focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.keyDown
KEY_UP constant
public static const KEY_UP:String = "keyUp"

Defines the value of the type property of a keyUp event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
charCode | Contains the character code value of the key pressed or released.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
keyCode | The key code value of the key pressed or released.
keyLocation | The location of the key on the keyboard.
shiftKey | true if the Shift key is active; false if it is inactive.
target | The InteractiveObject instance with focus. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.keyUp
Examples

The following example uses the KeyboardEventExample class to show keyboard events and their listener functions. The example carries out the following tasks:
  1. It declares properties for later use in setting a square's background color and size.
  2. It creates a new Sprite instance named child.
  3. Using methods of Sprite, it draws a light-blue square that it displays on the Stage at default coordinates (0,0) by calling the addChild() method.
  4. It adds two keyboard type event listeners:
    • keyDown/keyDownHandler which is dispatched whenever any key is pressed. The subscriber method prints information about the event using the trace() statement.
    • keyUp/keyUpHandler which is dispatched when a key is released.

In some instances, you may need to click the Stage for the keyboard events to work.

package {
    import flash.display.Sprite;
    import flash.display.DisplayObject;
    import flash.events.*;

    public class KeyBoardEventExample extends Sprite {
        private var bgColor:uint = 0x00CCFF;
        private var size:uint = 80;

        public function KeyBoardEventExample() {
            var child:Sprite = new Sprite();
            child.graphics.beginFill(bgColor);
            child.graphics.drawRect(0, 0, size, size);
            child.graphics.endFill();
            addChild(child);
            stage.focus = child;
            child.addEventListener(KeyboardEvent.KEY_DOWN, keyDownHandler);
            child.addEventListener(KeyboardEvent.KEY_UP, keyUpHandler);
        }

        private function keyDownHandler(event:KeyboardEvent):void {
            trace("keyDownHandler: " + event.keyCode);
            trace("ctrlKey: " + event.ctrlKey);
            trace("keyLocation: " + event.keyLocation);
            trace("shiftKey: " + event.shiftKey);
            trace("altKey: " + event.altKey);
        }

        private function keyUpHandler(event:KeyboardEvent):void {
            trace("keyUpHandler: " + event.keyCode);
        }
    }
}


flash.events.MouseEvent (Flex™ 2 Language Reference)

Class MouseEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class MouseEvent
Inheritance | MouseEvent Inheritance Event Inheritance Object
Subclasses | ChartItemEvent, DragEvent, FlexMouseEvent, LegendMouseEvent

Flash® Player dispatches MouseEvent objects into the event flow whenever mouse events occur. A mouse event is usually generated by a user input device, such as a mouse or a trackball, that uses a pointer.

When nested nodes are involved, mouse events target the deepest possible nested node that is visible in the display list. This node is called the target node. To have a target node's ancestor receive notification of a mouse event, use EventDispatcher.addEventListener() on the ancestor node with the type parameter set to the specific mouse event you want to detect.

View the examples.

See also

Handling keyboard-related MouseEvents

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | altKey : Boolean Reserved for future use. | MouseEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
 | buttonDown : Boolean Indicates whether the primary mouse button is pressed (true) or not (false). | MouseEvent
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | ctrlKey : Boolean Indicates whether the Control key is active (true) or inactive (false). | MouseEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | delta : int Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. | MouseEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | localX : Number The horizontal coordinate at which the event occurred relative to the containing sprite. | MouseEvent
 | localY : Number The vertical coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relatedObject : InteractiveObject A reference to a display list object that is related to the event. | MouseEvent
 | shiftKey : Boolean Indicates whether the Shift key is active (true) or inactive (false). | MouseEvent
 | stageX : Number [read-only] The horizontal coordinate at which the event occurred in global Stage coordinates. | MouseEvent
 | stageY : Number [read-only] The vertical coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MouseEvent(type:String, bubbles:Boolean = true, cancelable:Boolean = false, localX:Number, localY:Number, relatedObject:InteractiveObject = null, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false, buttonDown:Boolean = false, delta:int = 0) Creates an Event object that contains information about mouse events. | MouseEvent
 | clone():Event Creates a copy of the MouseEvent object and sets the value of each property to match that of the original. | MouseEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the MouseEvent object. | MouseEvent
 | updateAfterEvent():void Instructs Flash Player to render after processing of this event completes, if the display list has been modified. | MouseEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
 | CLICK : String = "click" [static] Defines the value of the type property of a click event object. | MouseEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | DOUBLE_CLICK : String = "doubleClick" [static] Defines the value of the type property of a doubleClick event object. | MouseEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | MOUSE_DOWN : String = "mouseDown" [static] Defines the value of the type property of a mouseDown event object. | MouseEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
 | MOUSE_MOVE : String = "mouseMove" [static] Defines the value of the type property of a mouseMove event object. | MouseEvent
 | MOUSE_OUT : String = "mouseOut" [static] Defines the value of the type property of a mouseOut event object. | MouseEvent
 | MOUSE_OVER : String = "mouseOver" [static] Defines the value of the type property of a mouseOver event object. | MouseEvent
 | MOUSE_UP : String = "mouseUp" [static] Defines the value of the type property of a mouseUp event object. | MouseEvent
 | MOUSE_WHEEL : String = "mouseWheel" [static] Defines the value of the type property of a mouseWheel event object. | MouseEvent
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | ROLL_OUT : String = "rollOut" [static] Defines the value of the type property of a rollOut event object. | MouseEvent
 | ROLL_OVER : String = "rollOver" [static] Defines the value of the type property of a rollOver event object. | MouseEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
altKey property
altKey:Boolean [read-write]

Reserved for future use.

Implementation
    public function get altKey():Boolean
    public function set altKey(value:Boolean):void
buttonDown property
buttonDown:Boolean [read-write]

Indicates whether the primary mouse button is pressed (true) or not (false).

Implementation
    public function get buttonDown():Boolean
    public function set buttonDown(value:Boolean):void
ctrlKey property
ctrlKey:Boolean [read-write]

Indicates whether the Control key is active (true) or inactive (false). On Macintosh computers, you must use this property to represent the Command key.

Implementation
    public function get ctrlKey():Boolean
    public function set ctrlKey(value:Boolean):void
delta property
delta:int [read-write]

Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. A positive delta value indicates an upward scroll; a negative value indicates a downward scroll. Typical values are 1 to 3, but faster rotation may produce larger values. This setting depends on the device and operating system and is usually configurable by the user. This property applies only to the MouseEvent.mouseWheel event.

Implementation
    public function get delta():int
    public function set delta(value:int):void
localX property
localX:Number [read-write]

The horizontal coordinate at which the event occurred relative to the containing sprite.

Implementation
    public function get localX():Number
    public function set localX(value:Number):void
localY property
localY:Number [read-write]

The vertical coordinate at which the event occurred relative to the containing sprite.

Implementation
    public function get localY():Number
    public function set localY(value:Number):void
relatedObject property
relatedObject:InteractiveObject [read-write]

A reference to a display list object that is related to the event. For example, when a mouseOut event occurs, relatedObject represents the display list object to which the pointing device now points. This property applies only to the mouseOut and mouseOver events.

Implementation
    public function get relatedObject():InteractiveObject
    public function set relatedObject(value:InteractiveObject):void
shiftKey property
shiftKey:Boolean [read-write]

Indicates whether the Shift key is active (true) or inactive (false).

Implementation
    public function get shiftKey():Boolean
    public function set shiftKey(value:Boolean):void
stageX property
stageX:Number [read-only]

The horizontal coordinate at which the event occurred in global Stage coordinates. This property is calculated when the localX property is set.

Implementation
    public function get stageX():Number
stageY property
stageY:Number [read-only]

The vertical coordinate at which the event occurred in global Stage coordinates. This property is calculated when the localY property is set.

Implementation
    public function get stageY():Number
Constructor detail
MouseEvent () constructor
public function MouseEvent(type:String, bubbles:Boolean = true, cancelable:Boolean = false, localX:Number, localY:Number, relatedObject:InteractiveObject = null, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false, buttonDown:Boolean = false, delta:int = 0)

Creates an Event object that contains information about mouse events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Possible values are: MouseEvent.CLICK, MouseEvent.DOUBLE_CLICK, MouseEvent.MOUSE_DOWN, MouseEvent.MOUSE_MOVE, MouseEvent.MOUSE_OUT, MouseEvent.MOUSE_OVER, MouseEvent.MOUSE_UP, MouseEvent.MOUSE_WHEEL, MouseEvent.ROLL_OUT, and MouseEvent.ROLL_OVER.
bubbles:Boolean (default = true) — Determines whether the Event object participates in the bubbling phase of the event flow.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled.
localX:Number — The horizontal coordinate at which the event occurred relative to the containing sprite.
localY:Number — The vertical coordinate at which the event occurred relative to the containing sprite.
relatedObject:InteractiveObject (default = null) — The complementary InteractiveObject instance that is affected by the event. For example, when a mouseOut event occurs, relatedObject represents the display list object to which the pointing device now points.
ctrlKey:Boolean (default = false) — Indicates whether the Control key is activated.
altKey:Boolean (default = false) — Reserved for future use.
shiftKey:Boolean (default = false) — Indicates whether the Shift key is activated.
buttonDown:Boolean (default = false) — Indicates whether the primary mouse button is pressed.
delta:int (default = 0) — Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. A positive delta value indicates an upward scroll; a negative value indicates a downward scroll. Typical values are 1 to 3, but faster rotation may produce larger values. This parameter is used only for the MouseEvent.mouseWheel event.
Method detail
clone () method
public override function clone():Event

Creates a copy of the MouseEvent object and sets the value of each property to match that of the original.

Returns
Event — A new MouseEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the MouseEvent object. The string is in the following format:

[MouseEvent type=value bubbles=value cancelable=value ... delta=value]

Returns
String — A string that contains all the properties of the MouseEvent object.
updateAfterEvent () method
public function updateAfterEvent():void

Instructs Flash Player to render after processing of this event completes, if the display list has been modified.

Constant detail
CLICK constant
public static const CLICK:String = "click"

Defines the value of the type property of a click event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.click
DOUBLE_CLICK constant
public static const DOUBLE_CLICK:String = "doubleClick"

Defines the value of the type property of a doubleClick event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.doubleClick
MOUSE_DOWN constant
public static const MOUSE_DOWN:String = "mouseDown"

Defines the value of the type property of a mouseDown event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.mouseDown
MOUSE_MOVE constant
public static const MOUSE_MOVE:String = "mouseMove"

Defines the value of the type property of a mouseMove event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.mouseMove
MOUSE_OUT constant
public static const MOUSE_OUT:String = "mouseOut"

Defines the value of the type property of a mouseOut event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device now points.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.mouseOut
MOUSE_OVER constant
public static const MOUSE_OVER:String = "mouseOver"

Defines the value of the type property of a mouseOver event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device was pointing.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.mouseOver
MOUSE_UP constant
public static const MOUSE_UP:String = "mouseUp"

Defines the value of the type property of a mouseUp event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.mouseUp
MOUSE_WHEEL constant
public static const MOUSE_WHEEL:String = "mouseWheel"

Defines the value of the type property of a mouseWheel event object.

This event has the following properties:

Property | Value
bubbles | true
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; the default behavior cannot be canceled.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
delta | The number of lines that that each notch on the mouse wheel represents.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.mouseWheel
ROLL_OUT constant
public static const ROLL_OUT:String = "rollOut"

Defines the value of the type property of a rollOut event object.

This event has the following properties:

Property | Value
bubbles | false
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device now points.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.rollOut
ROLL_OVER constant
public static const ROLL_OVER:String = "rollOver"

Defines the value of the type property of a rollOver event object.

This event has the following properties:

Property | Value
bubbles | false
buttonDown | true if the primary mouse button is depressed; false otherwise.
cancelable | false; there is no default behavior to cancel.
ctrlKey | true if the Control key is active; false if it is inactive.
currentTarget | The object that is actively processing the Event object with an event listener.
relatedObject | The display list object to which the pointing device was pointing.
localX | The horizontal coordinate at which the event occurred relative to the containing sprite.
localY | The vertical coordinate at which the event occurred relative to the containing sprite.
shiftKey | true if the Shift key is active; false if it is inactive.
stageX | The horizontal coordinate at which the event occurred in global stage coordinates.
stageY | The vertical coordinate at which the event occurred in global stage coordinates.
target | The InteractiveObject instance under the pointing device. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

flash.display.InteractiveObject.rollOver
Examples

The following example uses the MouseEventExample and ChildSprite classes to show how mouse events are dispatched using a simple image. This example carries out the following tasks:
  1. The example declares properties for the size (100 x 100 pixels) and the background color (orange) for later use in drawing the square.
  2. The constructor creates a new ChildSprite object child. Its constructor first draws an orange 100 x 100 pixel square at coordinates (0,0) by calling its draw() method and then adds seven event listeners/subscribers.
    • click/clickHandler(): Dispatched when the user single-clicks with the left mouse button over the square.
    • doubleClick/doubleClickHandler(): Dispatched when the user double-clicks the left mouse button over the square.
    • mouseDown/mouseDownHandler(): When the ChildSprite object (the orange square) is clicked, a trace() message is printed to the screen, and then ChildSprite.draw() is called, which draws a dark yellow square in place of the light blue one drawn in mouseOverHandler(). The mouseDownHandler() method also adds a mouseMoveevent listener and the mouseMoveHandler() subscriber (described below), which processes the mouse moves. Then the startDrag() method is called, which allows the Sprite object to be dragged.
    • mouseOut/mouseOutHandler(): Dispatched whenever the pointer leaves the square area. The draw() method is called to return the square to its normal size and color.
    • mouseOver/mouseOverHandler(): Dispatched when the mouse pointer is over the square. This method redraws the square so that it is larger and its background color is dark yellow.
    • mouseUp/mouseUpHandler(): When the user releases the mouse button, the mouseMove event listener is removed and stopDrag is called, which freezes the square in place.
    • mouseMove/mouseMoveHandler(): As long as the user is pressing the left mouse button, this method instructs Flash Player to continuously redraw the orange square.
    • mouseWheel/mouseWheelHandler(): Dispatched when the user rotates the mouse wheel over the square.
  3. The ChildSprite instance child is then added to the display list by means of addChild(), which promptly draws the orange square.

Notes:

  • The MouseEventExample class should be the document root.
  • Some of the event methods listed above declare a local variable sprite, which is assigned the cast of event.target to type Sprite.

package {
    import flash.display.Sprite;

    public class MouseEventExample extends Sprite {
        private var size:uint = 100;
        private var bgColor:uint = 0xFFCC00;

        public function MouseEventExample() {
            var child:ChildSprite = new ChildSprite();
            addChild(child);
        }
    }
}

import flash.display.Sprite;
import flash.events.MouseEvent;

class ChildSprite extends Sprite {
    private var size:uint = 50;
    private var overSize:uint = 60;
    private var backgroundColor:uint = 0xFFCC00;
    private var overColor:uint = 0xCCFF00;
    private var downColor:uint = 0x00CCFF;

    public function ChildSprite() {
        draw(size, size, backgroundColor);
        addEventListener(MouseEvent.CLICK, clickHandler);
        addEventListener(MouseEvent.DOUBLE_CLICK, doubleClickHandler);
        addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler);
        addEventListener(MouseEvent.MOUSE_OUT, mouseOutHandler);
        addEventListener(MouseEvent.MOUSE_OVER, mouseOverHandler);
        addEventListener(MouseEvent.MOUSE_UP, mouseUpHandler);
        addEventListener(MouseEvent.MOUSE_WHEEL, mouseWheelHandler);
    }

    private function draw(w:uint, h:uint, bgColor:uint):void {
        graphics.clear();
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, w, h);
        graphics.endFill();
    }

    private function clickHandler(event:MouseEvent):void {
        trace("clickHandler");
    }

    private function doubleClickHandler(event:MouseEvent):void {
        trace("doubleClickHandler");
    }

    private function mouseDownHandler(event:MouseEvent):void {
        trace("mouseDownHandler");
        draw(overSize, overSize, downColor);

        var sprite:Sprite = Sprite(event.target);
        sprite.addEventListener(MouseEvent.MOUSE_MOVE, mouseMoveHandler);
        sprite.startDrag();
    }

    private function mouseMoveHandler(event:MouseEvent):void {
        trace("mouseMoveHandler");
        event.updateAfterEvent();
    }

    private function mouseOutHandler(event:MouseEvent):void {
        trace("mouseOutHandler");
        draw(size, size, backgroundColor);
    }

    private function mouseOverHandler(event:MouseEvent):void {
        trace("mouseOverHandler");
        draw(overSize, overSize, overColor);
    }

    private function mouseWheelHandler(event:MouseEvent):void {
        trace("mouseWheelHandler delta: " + event.delta);
    }

    private function mouseUpHandler(event:MouseEvent):void {
        trace("mouseUpHandler");
        var sprite:Sprite = Sprite(event.target);
        sprite.removeEventListener(MouseEvent.MOUSE_MOVE, mouseMoveHandler);
        sprite.stopDrag();
        draw(overSize, overSize, overColor);
    }
}


flash.events.NetStatusEvent (Flex™ 2 Language Reference)

Class NetStatusEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class NetStatusEvent
Inheritance | NetStatusEvent Inheritance Event Inheritance Object

Flash® Player dispatches NetStatusEvent objects when a NetConnection, NetStream, or SharedObject object reports its status. There is only one type of status event: NetStatusEvent.NET_STATUS.

View the examples.

See also

flash.net.NetConnection
flash.net.NetStream
flash.net.SharedObject
NetStatusEvent.NET_STATUS

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | info : Object An object with properties that describe the object's status or error condition. | NetStatusEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | NetStatusEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, info:Object = null) Creates an Event object that contains information about netStatus events. | NetStatusEvent
 | clone():Event Creates a copy of the NetStatusEvent object and sets the value of each property to match that of the original. | NetStatusEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the NetStatusEvent object. | NetStatusEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
 | NET_STATUS : String = "netStatus" [static] Defines the value of the type property of a netStatus event object. | NetStatusEvent
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
info property
info:Object [read-write]

An object with properties that describe the object's status or error condition.

The information object could have a code property containing a string that represents a specific event or a level property containing a string that is either "status" or "error".

The information object could also be something different. The code and level properties might not work for some implementations and some servers might send different objects. For example, Flex Data Services sends Message objects that cause coercion errors if you try to access the code or level property.

The following table describes the possible values of the code and level properties.

Code property | Level property | Meaning
NetStream.Buffer.Empty | "status" | Data is not being received quickly enough to fill the buffer. Data flow will be interrupted until the buffer refills, at which time a NetStream.Buffer.Full message will be sent and the stream will begin playing again.
NetStream.Buffer.Full | "status" | The buffer is full and the stream will begin playing.
NetStream.Buffer.Flush | "status" | Data has finished streaming, and the remaining buffer will be emptied.
NetStream.Publish.Start | "status" | Publish was successful.
NetStream.Publish.BadName | "error" | Attempt to publish a stream which is already being published by someone else.
NetStream.Publish.Idle | "status" | The publisher of the stream has been idling for too long.
NetStream.Unpublish.Success | "status" | The unpublish operation was successfuul.
NetStream.Play.Start | "status" | Playback has started.
NetStream.Play.Stop | "status" | Playback has stopped.
NetStream.Play.Failed | "error" | An error has occurred in playback for a reason other than those listed elsewhere in this table, such as the subscriber not having read access.
NetStream.Play.StreamNotFound | "error" | The FLV passed to the play() method can't be found.
NetStream.Play.Reset | "status" | Caused by a play list reset.
NetStream.Play.PublishNotify | "status" | The initial publish to a stream is sent to all subscribers.
NetStream.Play.UnpublishNotify | "status" | An unpublish from a stream is sent to all subscribers.
NetStream.Pause.Notify | "status" | The stream is paused.
NetStream.Unpause.Notify | "status" | The stream is resumed.
NetStream.Record.Start | "status" | Recording has started.
NetStream.Record.NoAccess | "error" | Attempt to record a stream that is still playing or the client has no access right.
NetStream.Record.Stop | "status" | Recording stopped.
NetStream.Record.Failed | "error" | An attempt to record a stream failed.
NetStream.Seek.Failed | "error" | The seek fails, which happens if the stream is not seekable.
NetStream.Seek.InvalidTime | "error" | For video downloaded with progressive download, the user has tried to seek or play past the end of the video data that has downloaded thus far, or past the end of the video once the entire file has downloaded. The message.details property contains a time code that indicates the last valid position to which the user can seek.
NetStream.Seek.Notify | "status" | The seek operation is complete.
NetConnection.Call.BadVersion | "error" | Packet encoded in an unidentified format.
NetConnection.Call.Failed | "error" | The NetConnection.call method was not able to invoke the server-side method or command.
NetConnection.Call.Prohibited | "error" | An Action Message Format (AMF) operation is prevented for security reasons. Either the AMF URL is not in the same domain as the SWF file, or the AMF server does not have a policy file that trusts the domain of the SWF file.
NetConnection.Connect.Closed | "status" | The connection was closed successfully.
NetConnection.Connect.Failed | "error" | The connection attempt failed.
NetConnection.Connect.Success | "status" | The connection attempt succeeded.
NetConnection.Connect.Rejected | "error" | The connection attempt did not have permission to access the application.
NetConnection.Connect.AppShutdown | "error" | The specified application is shutting down.
NetConnection.Connect.InvalidApp | "error" | The application name specified during connect is invalid.
SharedObject.Flush.Success | "status" | The "pending" status is resolved and the SharedObject.flush() call succeeded.
SharedObject.Flush.Failed | "error" | The "pending" status is resolved, but the SharedObject.flush() failed.
SharedObject.BadPersistence | "error" | A request was made for a shared object with persistence flags, but the request cannot be granted because the object has already been created with different flags.
SharedObject.UriMismatch | "error" | An attempt was made to connect to a NetConnection object that has a different URI (URL) than the shared object.

If you consistently see errors regarding the buffer, try changing the buffer using the NetStream.bufferTime property.

Implementation
    public function get info():Object
    public function set info(value:Object):void

See also

NetConnection class
NetStream class
Constructor detail
NetStatusEvent () constructor
public function NetStatusEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, info:Object = null)

Creates an Event object that contains information about netStatus events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of status event: NetStatusEvent.NET_STATUS.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
info:Object (default = null) — An object containing properties that describe the object's status. Event listeners can access this object through the info property.

See also

flash.events.NetStatusEvent.NET_STATUS
Method detail
clone () method
public override function clone():Event

Creates a copy of the NetStatusEvent object and sets the value of each property to match that of the original.

Returns
Event — A new NetStatusEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the NetStatusEvent object. The string is in the following format:

[NetStatusEvent type=value bubbles=value cancelable=value info=value]

Returns
String — A string that contains all the properties of the NetStatusEvent object.
Constant detail
NET_STATUS constant
public static const NET_STATUS:String = "netStatus"

Defines the value of the type property of a netStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
info | An object with properties that describe the object's status or error condition.
target | The NetConnection or NetStream object reporting its status.

See also

flash.events.NetStatusEvent.info
flash.net.NetConnection.netStatus
flash.net.NetStream.netStatus
flash.net.SharedObject.netStatus
Examples

The following example uses a Video object with the NetConnection and NetStream classes to load and play an FLV file.

In this example, the netStatusHandler method is registered as a listener for the NetStatusEvent event NetConnection.netStatus. When the status (success or failure) of the NetConnection.connect() attempt is determined, the netStatus event triggers this method. If the attempt to connect to the NetConnection object is successful (in other words, if the info property of the NetStatusEvent object dispatched by the netStatus event has a code property that indicates success), the code creates the Video and NetStream objects and calls the Video.attachNetStream() and NetStream.play() methods.

Note: To run this example, you need an FLV file whose name and location match the variable passed to videoURL; in this case, an FLV file called Video.flv that is in the same directory as the SWF file.

 package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.media.Video;
    import flash.net.NetConnection;
    import flash.net.NetStream;

    public class NetStatusEventExample extends Sprite {
        private var videoURL:String = "Video.flv";
        private var connection:NetConnection;
        private var stream:NetStream;

        public function NetStatusEventExample() {
            connection = new NetConnection();
            connection.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            connection.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            connection.connect(null);
        }

        private function netStatusHandler(event:NetStatusEvent):void {
            switch (event.info.code) {
                case "NetConnection.Connect.Success":
                    connectStream();
                    break;
                case "NetStream.Play.StreamNotFound":
                    trace("Unable to locate video: " + videoURL);
                    break;
            }
        }

        private function connectStream():void {
            var stream:NetStream = new NetStream(connection);
            stream.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            stream.addEventListener(AsyncErrorEvent.ASYNC_ERROR, asyncErrorHandler);
            var video:Video = new Video();
            video.attachNetStream(stream);
            stream.play(videoURL);
            addChild(video);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function asyncErrorHandler(event:AsyncErrorEvent):void {
            // ignore AsyncErrorEvent events.
        }

    }
 }


flash.events.ProgressEvent (Flex™ 2 Language Reference)

Class ProgressEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class ProgressEvent
Inheritance | ProgressEvent Inheritance Event Inheritance Object
Subclasses | RSLEvent

Flash® Player dispatches ProgressEvent objects when a load operation has begun or a socket has received data. These events are usually generated when SWF files, images or data are loaded into Flash Player. There are two types of progress events: ProgressEvent.PROGRESS and ProgressEvent.SOCKET_DATA.

View the examples.

See also

LoaderInfo class
Socket class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
 | bytesLoaded : uint The number of items or bytes loaded when the listener processes the event. | ProgressEvent
 | bytesTotal : uint The total number of items or bytes that will be loaded if the loading process succeeds. | ProgressEvent
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ProgressEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, bytesLoaded:uint = 0, bytesTotal:uint = 0) Creates an Event object that contains information about progress events. | ProgressEvent
 | clone():Event Creates a copy of the ProgressEvent object and sets each property's value to match that of the original. | ProgressEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the ProgressEvent object. | ProgressEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
 | PROGRESS : String = "progress" [static] Defines the value of the type property of a progress event object. | ProgressEvent
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
 | SOCKET_DATA : String = "socketData" [static] Defines the value of the type property of a socketData event object. | ProgressEvent
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
bytesLoaded property
bytesLoaded:uint [read-write]

The number of items or bytes loaded when the listener processes the event.

Implementation
    public function get bytesLoaded():uint
    public function set bytesLoaded(value:uint):void
bytesTotal property
bytesTotal:uint [read-write]

The total number of items or bytes that will be loaded if the loading process succeeds.

Implementation
    public function get bytesTotal():uint
    public function set bytesTotal(value:uint):void
Constructor detail
ProgressEvent () constructor
public function ProgressEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, bytesLoaded:uint = 0, bytesTotal:uint = 0)

Creates an Event object that contains information about progress events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Possible values are:ProgressEvent.PROGRESS and ProgressEvent.SOCKET_DATA.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled.
bytesLoaded:uint (default = 0) — The number of items or bytes loaded at the time the listener processes the event.
bytesTotal:uint (default = 0) — The total number of items or bytes that will be loaded if the loading process succeeds.
Method detail
clone () method
public override function clone():Event

Creates a copy of the ProgressEvent object and sets each property's value to match that of the original.

Returns
Event — A new ProgressEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the ProgressEvent object. The string is in the following format:

[ProgressEvent type=value bubbles=value cancelable=value bytesLoaded=value bytesTotal=value]

Returns
String — A string that contains all the properties of the ProgressEvent object.
Constant detail
PROGRESS constant
public static const PROGRESS:String = "progress"

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.

See also

flash.display.LoaderInfo.progress
flash.media.Sound.progress
flash.net.FileReference.progress
flash.net.URLLoader.progress
flash.net.URLStream.progress
SOCKET_DATA constant
public static const SOCKET_DATA:String = "socketData"

Defines the value of the type property of a socketData event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event.
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | 0; this property is not used by socketData event objects.
target | The Socket object reporting progress.

See also

flash.net.Socket.socketData
Examples

The following example uses the ProgressEventExample class to illustrate how various event listeners are used when a file is being downloaded. The example carries out the following tasks:
  1. The properties downloadURL and fileName are created, which indicate the location and name of the download file.
  2. In the ProgressEventExample constructor, a new FileReference object named file is created and then passed to the configureListeners() method.
  3. The downloadURL and fileName properties are then passed to file.download(), which prompts for the location to download the file.
  4. The configureListeners() method adds seven event listeners and their associated subscriber methods:
    1. cancel/cancelHandler() is dispatched if the file download is canceled.
    2. complete/complereHandler() is dispatched when the file download process is finished.
    3. ioError/ioErrorHandler() is dispatched if the download file is unavailable or inaccessible.
    4. open/openHandler() is dispatched when the download operation has started.
    5. progress/progressHandler() is dispatched when the download process begins and again when it ends.
    6. securityError/securityErrorHandler is dispatched if the local playback security setting does not match the type of data access for the download file (local versus network); see the notes below.
    7. select/selectHandler() is dispatched when the download object is selected.

Notes:

  • You need to compile the SWF file with Local Playback Security set to Access Network Files Only.
  • This example requires a file named SomeFile.pdf.
  • Although this example makes use of all events available to the FileReference object, most situations require only a subset.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.URLRequest;

    public class ProgressEventExample extends Sprite {
        private var downloadURL:String = "http://www.[yourDomain].com/SomeFile.pdf";
        private var fileName:String = "SomeFile.pdf";
        private var file:FileReference;

        public function ProgressEventExample() {
            var request:URLRequest = new URLRequest(downloadURL);
            file = new FileReference();
            configureListeners(file);
            file.download(request, fileName);
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.CANCEL, cancelHandler);
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(Event.SELECT, selectHandler);
        }

        private function cancelHandler(event:Event):void {
            trace("cancelHandler: " + event);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            var file:FileReference = FileReference(event.target);
            trace("progressHandler: name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function selectHandler(event:Event):void {
            var file:FileReference = FileReference(event.target);
            trace("selectHandler: name=" + file.name + " URL=" + downloadURL);
        }
    }
}


flash.events.SecurityErrorEvent (Flex™ 2 Language Reference)

Class SecurityErrorEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class SecurityErrorEvent
Inheritance | SecurityErrorEvent Inheritance ErrorEvent Inheritance TextEvent Inheritance Event Inheritance Object

Flash® Player dispatches SecurityErrorEvent objects to report the occurrence of a security error. Security errors reported through this class are generally from asynchronous operations, such as loading data, in which security violations may not manifest immediately. Your event listener can access the object's text property to determine what operation was attempted and any URLs that were involved. If there are no event listeners, the debugger version of Flash Player automatically displays an error message that contains the contents of the text property. There is one type of security error event: SecurityErrorEvent.SECURITY_ERROR.

Security error events are the final events dispatched for any target object. This means that any other events, including generic error events, are not dispatched for a target object that experiences a security error.

View the examples.

See also

Security class
SECURITY_ERROR
Flash Player Security

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | text : String For a textInput event, the character or sequence of characters entered by the user. | TextEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SecurityErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "") Creates an Event object that contains information about security error events. | SecurityErrorEvent
 | clone():Event Creates a copy of the SecurityErrorEvent object and sets the value of each property to match that of the original. | SecurityErrorEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the SecurityErrorEvent object. | SecurityErrorEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ERROR : String = "error" [static] Defines the value of the type property of an error event object. | ErrorEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | LINK : String = "link" [static] Defines the value of the type property of a link event object. | TextEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
 | SECURITY_ERROR : String = "securityError" [static] The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object. | SecurityErrorEvent
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | TEXT_INPUT : String = "textInput" [static] Defines the value of the type property of a textInput event object. | TextEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
SecurityErrorEvent () constructor
public function SecurityErrorEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "")

Creates an Event object that contains information about security error events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of error event: SecurityErrorEvent.SECURITY_ERROR.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
text:String (default = "") — Text to be displayed as an error message. Event listeners can access this information through the text property.

See also

SECURITY_ERROR
Method detail
clone () method
public override function clone():Event

Creates a copy of the SecurityErrorEvent object and sets the value of each property to match that of the original.

Returns
Event — A new securityErrorEvent object with property values that match those of the original.

See also

Flash Player Security
toString () method
public override function toString():String

Returns a string that contains all the properties of the SecurityErrorEvent object. The string is in the following format:

[securityErrorEvent type=value bubbles=value cancelable=value text=value]

Returns
String — A string that contains all the properties of the SecurityErrorEvent object.

See also

Flash Player Security
Constant detail
SECURITY_ERROR constant
public static const SECURITY_ERROR:String = "securityError"

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

flash.display.LoaderInfo.securityError
flash.net.FileReference.securityError
flash.net.LocalConnection.securityError
flash.net.NetConnection.securityError
flash.net.Socket.securityError
flash.net.URLLoader.securityError
flash.net.URLStream.securityError
flash.net.XMLSocket.securityError
Flash Player Security
Examples

The following example uses the SecurityErrorEventExample class to show how a listener method securityErrorHandler() can be instantiated and set to listen for securityError events to be dispatched. These events occur when network files are accessed with the local playback set to access only local files or when local files are accessed with playback set to access only network files.

Note: You need to compile the SWF file with Local Playback Security set to Access Local Files Only to generate a securityError event in this example.

package {
    import flash.display.Sprite;
    import flash.net.URLLoader;
    import flash.net.URLRequest;
    import flash.events.SecurityErrorEvent;

    public class SecurityErrorEventExample extends Sprite {
        public function SecurityErrorEventExample() {
            var loader:URLLoader = new URLLoader();
            loader.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);

            var request:URLRequest = new URLRequest("http://www.[yourDomain].com");
            loader.load(request);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }
    }
}


flash.events.StatusEvent (Flex™ 2 Language Reference)

Class StatusEvent | Properties | Methods | Constants
Package | flash.events
Class | public class StatusEvent
Inheritance | StatusEvent Inheritance Event Inheritance Object

Flash® Player dispatches StatusEvent objects when a device, such as a camera or microphone, or an object such as a LocalConnection object reports its status. There is only one type of status event: StatusEvent.STATUS.

See also

flash.media.Camera
flash.media.Microphone
flash.net.LocalConnection

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | code : String A description of the object's status. | StatusEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | level : String The category of the message, such as "status", "warning" or "error". | StatusEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | StatusEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, code:String = "", level:String = "") Creates an Event object that contains information about status events. | StatusEvent
 | clone():Event Creates a copy of the StatusEvent object and sets the value of each property to match that of the original. | StatusEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the StatusEvent object. | StatusEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
 | STATUS : String = "status" [static] Defines the value of the type property of a status event object. | StatusEvent
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
code property
code:String [read-write]

A description of the object's status.

Implementation
    public function get code():String
    public function set code(value:String):void

See also

flash.media.Camera
flash.media.Microphone
flash.net.LocalConnection
level property
level:String [read-write]

The category of the message, such as "status", "warning" or "error".

Implementation
    public function get level():String
    public function set level(value:String):void

See also

flash.media.Camera
flash.media.Microphone
flash.net.LocalConnection
Constructor detail
StatusEvent () constructor
public function StatusEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, code:String = "", level:String = "")

Creates an Event object that contains information about status events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of status event: StatusEvent.STATUS.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
code:String (default = "") — A description of the object's status. Event listeners can access this information through the code property.
level:String (default = "") — The category of the message, such as "status", "warning" or "error". Event listeners can access this information through the level property.

See also

STATUS
Method detail
clone () method
public override function clone():Event

Creates a copy of the StatusEvent object and sets the value of each property to match that of the original.

Returns
Event — A new StatusEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the StatusEvent object. The string is in the following format:

[StatusEvent type=value bubbles=value cancelable=value code=value level=value]

Returns
String — A string that contains all the properties of the StatusEvent object.
Constant detail
STATUS constant
public static const STATUS:String = "status"

Defines the value of the type property of a status event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
code | A description of the object's status.
currentTarget | The object that is actively processing the Event object with an event listener.
level | The category of the message, such as "status", "warning" or "error".
target | The object reporting its status.

See also

flash.media.Camera.status
flash.media.Microphone.status
flash.net.LocalConnection.status


flash.events.SyncEvent (Flex™ 2 Language Reference)

Class SyncEvent | Properties | Methods | Constants
Package | flash.events
Class | public class SyncEvent
Inheritance | SyncEvent Inheritance Event Inheritance Object

Flash® Player dispatches SyncEvent objects when a remote SharedObject instance has been updated by the server. There is only one type of sync event: SyncEvent.SYNC.

See also

SharedObject class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | changeList : Array An array with properties that describe the array's status. | SyncEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SyncEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, changeList:Array = null) Creates an Event object that contains information about sync events. | SyncEvent
 | clone():Event Creates a copy of the SyncEvent object and sets the value of each property to match that of the original. | SyncEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the SyncEvent object. | SyncEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
 | SYNC : String = "sync" [static] Defines the value of the type property of a sync event object. | SyncEvent
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
changeList property
changeList:Array [read-write]

An array with properties that describe the array's status.

Implementation
    public function get changeList():Array
    public function set changeList(value:Array):void

See also

NetConnection class
NetStream class
Constructor detail
SyncEvent () constructor
public function SyncEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, changeList:Array = null)

Creates an Event object that contains information about sync events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. There is only one type of sync event: SyncEvent.SYNC.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
changeList:Array (default = null) — An array of objects that describe the synchronization with the remote SharedObject. Event listeners can access this object through the changeList property.
Method detail
clone () method
public override function clone():Event

Creates a copy of the SyncEvent object and sets the value of each property to match that of the original.

Returns
Event — A new SyncEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the SyncEvent object. The string is in the following format:

[SyncEvent type=value bubbles=value cancelable=value list=value]

Returns
String — A string that contains all the properties of the SyncEvent object.
Constant detail
SYNC constant
public static const SYNC:String = "sync"

Defines the value of the type property of a sync event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
changeList | An array with properties that describe the array's status.
target | The SharedObject instance that has been updated by the server.

See also

flash.net.SharedObject.sync


flash.events.TextEvent (Flex™ 2 Language Reference)

Class TextEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class TextEvent
Inheritance | TextEvent Inheritance Event Inheritance Object
Subclasses | DataEvent, ErrorEvent, IMEEvent

Flash® Player dispatches TextEvent objects when a user enters text in a text field or clicks a hyperlink in an HTML-enabled text field. There are two types of text events: TextEvent.LINK and TextEvent.TEXT_INPUT.

View the examples.

See also

flash.text.TextField

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | text : String For a textInput event, the character or sequence of characters entered by the user. | TextEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TextEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "") Creates an Event object that contains information about text events. | TextEvent
 | clone():Event Creates a copy of the TextEvent object and sets the value of each property to match that of the original. | TextEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the TextEvent object. | TextEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | LINK : String = "link" [static] Defines the value of the type property of a link event object. | TextEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
 | TEXT_INPUT : String = "textInput" [static] Defines the value of the type property of a textInput event object. | TextEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
text property
text:String [read-write]

For a textInput event, the character or sequence of characters entered by the user. For a link event, the text of the event attribute of the href attribute of the <a> tag.

Implementation
    public function get text():String
    public function set text(value:String):void

Example
The following code shows that the link event is dispatched when a user clicks the hypertext link:
 import flash.text.TextField;
 import flash.events.TextEvent;

 var tf:TextField = new TextField();
 tf.htmlText = "<a href='event:myEvent'>Click Me.</a>";
 tf.addEventListener("link", clickHandler);
 addChild(tf);

 function clickHandler(e:TextEvent):void {
  trace(e.type); // link
  trace(e.text); // myEvent
 }

Constructor detail
TextEvent () constructor
public function TextEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, text:String = "")

Creates an Event object that contains information about text events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property. Possible values are: TextEvent.LINK and TextEvent.TEXT_INPUT.
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling phase of the event flow. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
text:String (default = "") — One or more characters of text entered by the user. Event listeners can access this information through the text property.

See also

flash.text.TextField
Method detail
clone () method
public override function clone():Event

Creates a copy of the TextEvent object and sets the value of each property to match that of the original.

Returns
Event — A new TextEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the TextEvent object. The string is in the following format:

[TextEvent type=value bubbles=value cancelable=value text=value]

Returns
String — A string that contains all the properties of the TextEvent object.
Constant detail
LINK constant
public static const LINK:String = "link"

Defines the value of the type property of a link event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The text field containing the hyperlink that has been clicked. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
text | The remainder of the URL after "event:"

See also

text
flash.text.TextField.link
TEXT_INPUT constant
public static const TEXT_INPUT:String = "textInput"

Defines the value of the type property of a textInput event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The text field into which characters are being entered. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
text | The character or sequence of characters entered by the user.

See also

flash.text.TextField.textInput
text
Examples

The following example uses the TextEventExample class to create text fields and to listen for various text events on them. The example carries out the following tasks:
  1. The example declares constants for two URLs to be used later.
  2. The example declares two variables of type TextField to be used later.
  3. The class constructor calls the following two methods:
    • init() initializes the TextField objects and add event listeners to them.
    • draw() adds the TextFields to the display list and assigns the text to be displayed.
  4. The listeners linkHandler() and textInputHandler() react to the events according to their event type. The linkHandler() method opens a web browser if one is not open already and navigates to the clicked URL. The textInputHandler() method simply displays information every time a key is pressed in the associated text field.

Note: The domain shown in this example is fictitious and [yourDomain] should be replaced with a real domain.

package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.text.TextFieldType;
    import flash.text.TextFieldAutoSize;
    import flash.events.TextEvent;
    import flash.events.TextEvent;
    import flash.net.URLRequest;
    import flash.net.navigateToURL;

    public class TextEventExample extends Sprite {
        private const DOMAIN_1_URL:String = "http://www.[yourDomain].com";
        private const DOMAIN_2_URL:String = "http://www.[yourDomain].com";
        private var linkTxt:TextField;
        private var textInputTxt:TextField;

        public function TextEventExample() {
            init();
            draw();
        }

        private function init():void {
            linkTxt = new TextField();
            linkTxt.addEventListener(TextEvent.LINK, linkHandler);
            linkTxt.height = 60;
            linkTxt.autoSize = TextFieldAutoSize.LEFT;
            linkTxt.multiline = true;

            textInputTxt = new TextField();
            textInputTxt.addEventListener(TextEvent.TEXT_INPUT, textInputHandler);
            textInputTxt.type = TextFieldType.INPUT;
            textInputTxt.background = true;
            textInputTxt.border = true;
            textInputTxt.height = 20;
        }

        private function draw():void {
            addChild(linkTxt);
            linkTxt.htmlText += createLink(DOMAIN_1_URL, "Click to go to first domain");
            linkTxt.htmlText += "<br />";
            linkTxt.htmlText += createLink(DOMAIN_2_URL, "Click to go to second domain");

            addChild(textInputTxt);
            textInputTxt.y = linkTxt.height;
            textInputTxt.text = "type here";
        }

        private function createLink(url:String, text:String):String {
            var link:String = "";
            link += "<font color='#0000FF'>";
            link += "<u>";
            link += "<b>";
            link += "<a href='event:" + url + "'>" + text + "</a>";
            link += "</b>";
            link += "</u>";
            link += "</font>";
            return link;
        }

        private function linkHandler(e:TextEvent):void {
            var request:URLRequest = new URLRequest(e.text);
            navigateToURL(request);
        }

        private function textInputHandler(e:TextEvent):void {
            trace(">> ============================");
            trace(">> e.text: " + e.text);
            trace(">> textInputTxt.text: " + textInputTxt.text);
        }
    }
}


flash.events.TimerEvent (Flex™ 2 Language Reference)

Class TimerEvent | Properties | Methods | Constants | Examples
Package | flash.events
Class | public class TimerEvent
Inheritance | TimerEvent Inheritance Event Inheritance Object

Flash® Player dispatches TimerEvent objects whenever a Timer object reaches the interval specified by the Timer.delay property.

View the examples.

See also

flash.utils.Timer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TimerEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false) Creates an Event object with specific information relevant to timer events. | TimerEvent
 | clone():Event Creates a copy of the TimerEvent object and sets each property's value to match that of the original. | TimerEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string that contains all the properties of the TimerEvent object. | TimerEvent
 | updateAfterEvent():void Instructs Flash Player to render after processing of this event completes, if the display list has been modified | TimerEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
 | TIMER : String = "timer" [static] Defines the value of the type property of a timer event object. | TimerEvent
 | TIMER_COMPLETE : String = "timerComplete" [static] Defines the value of the type property of a timerComplete event object. | TimerEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
TimerEvent () constructor
public function TimerEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false)

Creates an Event object with specific information relevant to timer events. Event objects are passed as parameters to event listeners.

Parameters
type:String — The type of the event. Event listeners can access this information through the inherited type property.
bubbles:Boolean (default = false) — Determines whether the Event object bubbles. Event listeners can access this information through the inherited bubbles property.
cancelable:Boolean (default = false) — Determines whether the Event object can be canceled. Event listeners can access this information through the inherited cancelable property.
Method detail
clone () method
public override function clone():Event

Creates a copy of the TimerEvent object and sets each property's value to match that of the original.

Returns
Event — A new TimerEvent object with property values that match those of the original.
toString () method
public override function toString():String

Returns a string that contains all the properties of the TimerEvent object. The string is in the following format:

[TimerEvent type=value bubbles=value cancelable=value]

Returns
String — A string that contains all the properties of the TimerEvent object.
updateAfterEvent () method
public function updateAfterEvent():void

Instructs Flash Player to render after processing of this event completes, if the display list has been modified

Constant detail
TIMER constant
public static const TIMER:String = "timer"

Defines the value of the type property of a timer event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Timer object that has reached its interval.

See also

flash.utils.Timer.timer
TIMER_COMPLETE constant
public static const TIMER_COMPLETE:String = "timerComplete"

Defines the value of the type property of a timerComplete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Timer object that has completed its requests.

See also

flash.utils.Timer.timerComplete
Examples

The following example uses the TimerExample class to show how a listener method timerHandler() can be instantiated and set to listen for a new TimerEvent to be dispatched, which happens when the Timer's start() method is called.
package {
    import flash.utils.Timer;
    import flash.events.TimerEvent;
    import flash.display.Sprite;

    public class TimerEventExample extends Sprite {

        public function TimerEventExample() {
            var myTimer:Timer = new Timer(1000, 2);
            myTimer.addEventListener(TimerEvent.TIMER, timerHandler);
            myTimer.start();
        }

        public function timerHandler(event:TimerEvent):void {
            trace("timerHandler: " + event);
        }
    }
}


flash.external Summary (Flex™ 2 Language Reference)

Package flash.external | Classes

The flash.external package contains the ExternalInterface class which can be used to communicate with the Flash Player's container.

Classes
Class | Description
ExternalInterface | The ExternalInterface class is the External API, an application programming interface that enables straightforward communication between ActionScript and the Flash Player container; for example, an HTML page with JavaScript, or a desktop application with Flash Player embedded.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.external.ExternalInterface (Flex™ 2 Language Reference)

Class ExternalInterface | Properties | Methods | Examples
Package | flash.external
Class | public final class ExternalInterface
Inheritance | ExternalInterface Inheritance Object

The ExternalInterface class is the External API, an application programming interface that enables straightforward communication between ActionScript and the Flash Player container; for example, an HTML page with JavaScript, or a desktop application with Flash Player embedded. Use of ExternalInterface is recommended for all JavaScript-ActionScript communication.

Using JavaScript on the HTML page, you can call an ActionScript function in Flash Player. The ActionScript function can return a value, and JavaScript receives it immediately as the return value of the call.

This functionality is a replacement for the older fscommand() method.

ExternalInterface is supported in the following combinations of browser and operating system:

Browser | Operating System
Internet Explorer 5.0 and later | Windows |
Netscape 8.0 and later | Windows | Macintosh
Mozilla 1.7.5 and later | Windows | Macintosh
Firefox 1.0 and later | Windows | Macintosh
Safari 1.3 and later |  | Macintosh

ExternalInterface requires the user's web browser to support either ActiveX or the NPRuntime API that is exposed by some browsers for plug-in scripting. See http://www.mozilla.org/projects/plugins/npruntime.html.

Note: When embedding SWF files within an HTML page, make sure that the id and name attributes of the <object> and <embed> tags do not include characters such as: . (period), -, +, *, /, and \.

From ActionScript, you can do the following on the HTML page:

  • Call any JavaScript function.
  • Pass any number of arguments, with any names.
  • Pass various data types (Boolean, Number, String, and so on).
  • Receive a return value from the JavaScript function.

From JavaScript on the HTML page, you can:

  • Call an ActionScript function.
  • Pass arguments using standard function call notation.
  • Return a value to the JavaScript function.

Note: Flash Player does not currently support SWF files embedded within HTML forms.

View the examples.

See also

flash.system.fscommand()
Using the ExternalInterface API to access JavaScript from Flex
Accessing Flex from JavaScript
About ExternalInterface API security in Flex
About the External API
Using the ExternalInterface class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | available : Boolean [static][read-only] Indicates whether this player is in a container that offers an external interface. | ExternalInterface
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | objectID : String [static][read-only] Returns the id attribute of the <object> tag in Internet Explorer, or the name attribute of the <embed> tag in Netscape. | ExternalInterface
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | addCallback(functionName:String, closure:Function):void [static] Registers an ActionScript method as callable from the container. | ExternalInterface
 | call(functionName:String, ... arguments):* [static] Calls a function exposed by the Flash Player container, passing zero or more arguments. | ExternalInterface
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
available property
available:Boolean [read-only]

Indicates whether this player is in a container that offers an external interface. If the external interface is available, this property is true; otherwise, it is false.

Note: When using the External API with HTML, you should always check that the HTML has fully loaded before attempting to call any JavaScript methods.

Implementation
    public static function get available():Boolean

See also

Using the ExternalInterface class

Example
The following example uses the available property to determine whether the player is in a container that offers an external interface.
  package {
    import flash.text.TextField;
    import flash.display.MovieClip;
    import flash.external.ExternalInterface;

    public class extint_test extends MovieClip {
      public function extint_test() {
        var isAvailable:Boolean = ExternalInterface.available;
        var availTxt:TextField = new TextField();
        availTxt.text = isAvailable.toString();
        addChild(availTxt);
      }
    }
  }

objectID property
objectID:String [read-only]

Returns the id attribute of the <object> tag in Internet Explorer, or the name attribute of the <embed> tag in Netscape.

Implementation
    public static function get objectID():String

See also

Using the ExternalInterface class
Method detail
addCallback () method
public static function addCallback(functionName:String, closure:Function):void

Registers an ActionScript method as callable from the container. After a successful invocation of addCallBack(), the registered function in Flash Player can be called by JavaScript or ActiveX code in the container.

Parameters
functionName:String — The name by which the container can invoke the function.
closure:Function — The function closure to invoke. This could be a free-standing function, or it could be a method closure referencing a method of an object instance. By passing a method closure, the callback can actually be directed at a method of a particular object instance.

Throws
Error — An error is thrown if the container does not support incoming calls. This is supported only in Internet Explorer for Windows and browsers that use the NPRuntime API such as Mozilla 1.7.5 and later or Firefox 1.0 and later.
SecurityError — A callback with the specified name has already been added by ActionScript in a sandbox to which you do not have access; you cannot overwrite that callback. You can work around this by having the ActionScript that originally called the addCallback() method also call the Security.allowDomain() method.
SecurityError — The containing environment belongs to a security sandbox to which the calling code does not have access. To fix this problem:
  1. In the <object> tag for the SWF file in the containing HTML page, set the following parameter:

    <param name="allowScriptAccess" value="always" />

  2. In the SWF file, add the following ActionScript:

    flash.system.Security.allowDomain(sourceDomain)

See also

flash.system.Security.allowDomain()
Using the ExternalInterface class
call () method
public static function call(functionName:String, ... arguments):*

Calls a function exposed by the Flash Player container, passing zero or more arguments. If the desired function is not available, the call returns null; otherwise it returns the value provided by the function. Recursion is not permitted; a recursive call produces a null response.

If the container is an HTML page, this method invokes a JavaScript function in a <script> element.

If the container is some other ActiveX container, this method fires the FlashCall ActiveX event with the specified name, and the container processes the event.

If the container is hosting the Netscape plug-in, you can either write custom support for the new NPRuntime interface or embed an HTML control and embed Flash Player within the HTML control. If you embed an HTML control, you can communicate with Flash Player through a JavaScript interface that talks to the native container application.

Parameters
functionName:String — The name of the function to call in the container.
... arguments — The arguments to pass to the function in the container. You can specify zero or more parameters, separating them by commas. They may be of any ActionScript data type. When the call is to a JavaScript function, the ActionScript types are automatically marshaled into JavaScript types; when the call is to some other ActiveX container, the parameters are encoded in the request message.

Returns
* — The response received from the container. If the call failed -- for example, if there is no such function in the container, or the interface is not available, or a recursion occurred, or there is a security issue, null is returned and an error is thrown.

Throws
Error — An error is thrown if the container does not support outgoing calls. This is supported only in Internet Explorer for Windows and browsers that use the NPRuntime API such as Mozilla 1.7.5 and later or Firefox 1.0 and later.
SecurityError — The containing environment belongs to a security sandbox to which the calling code does not have access. You can work around this by setting an appropriate value for allowScriptAccess in the containing environment (usually by using the allowScriptAccess <object>/<embed> tags in HTML).

See also

Using the ExternalInterface class
Examples

The following example demonstrates sending data between Flash Player and an HTML container.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.external.ExternalInterface;
    import flash.text.TextField;
    import flash.utils.Timer;
    import flash.text.TextFieldType;
    import flash.text.TextFieldAutoSize;

    public class ExternalInterfaceExample extends Sprite {
        private var input:TextField;
        private var output:TextField;
        private var sendBtn:Sprite;

        public function ExternalInterfaceExample() {
            input = new TextField();
            input.type = TextFieldType.INPUT;
            input.background = true;
            input.border = true;
            input.width = 350;
            input.height = 18;
            addChild(input);

            sendBtn = new Sprite();
            sendBtn.mouseEnabled = true;
            sendBtn.x = input.width + 10;
            sendBtn.graphics.beginFill(0xCCCCCC);
            sendBtn.graphics.drawRoundRect(0, 0, 80, 18, 10, 10);
            sendBtn.graphics.endFill();
            sendBtn.addEventListener(MouseEvent.CLICK, clickHandler);
            addChild(sendBtn);

            output = new TextField();
            output.y = 25;
            output.width = 450;
            output.height = 325;
            output.multiline = true;
            output.wordWrap = true;
            output.border = true;
            output.text = "Initializing...\n";
            addChild(output);

            if (ExternalInterface.available) {
                try {
                    output.appendText("Adding callback...\n");
                    ExternalInterface.addCallback("sendToActionScript", receivedFromJavaScript);
                    if (checkJavaScriptReady()) {
                        output.appendText("JavaScript is ready.\n");
                    } else {
                        output.appendText("JavaScript is not ready, creating timer.\n");
                        var readyTimer:Timer = new Timer(100, 0);
                        readyTimer.addEventListener(TimerEvent.TIMER, timerHandler);
                        readyTimer.start();
                    }
                } catch (error:SecurityError) {
                    output.appendText("A SecurityError occurred: " + error.message + "\n");
                } catch (error:Error) {
                    output.appendText("An Error occurred: " + error.message + "\n");
                }
            } else {
                output.appendText("External interface is not available for this container.");
            }
        }
        private function receivedFromJavaScript(value:String):void {
            output.appendText("JavaScript says: " + value + "\n");
        }
        private function checkJavaScriptReady():Boolean {
            var isReady:Boolean = ExternalInterface.call("isReady");
            return isReady;
        }
        private function timerHandler(event:TimerEvent):void {
            output.appendText("Checking JavaScript status...\n");
            var isReady:Boolean = checkJavaScriptReady();
            if (isReady) {
                output.appendText("JavaScript is ready.\n");
                Timer(event.target).stop();
            }
        }
        private function clickHandler(event:MouseEvent):void {
            if (ExternalInterface.available) {
                ExternalInterface.call("sendToJavaScript", input.text);
            }
        }
    }
}
In order to test the previous ActionScript code, embed the generated SWF file using the following HTML template:
  <!-- saved from url=(0014)about:internet -->
  <html lang="en">
  <head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <title>ExternalInterfaceExample</title>
  <script language="JavaScript">
      var jsReady = false;
      function isReady() {
          return jsReady;
      }
      function pageInit() {
          jsReady = true;
          document.forms["form1"].output.value += "\n" + "JavaScript is ready.\n";
      }
      function thisMovie(movieName) {
          if (navigator.appName.indexOf("Microsoft") != -1) {
              return window[movieName];
          } else {
              return document[movieName];
          }
      }
      function sendToActionScript(value) {
          thisMovie("ExternalInterfaceExample").sendToActionScript(value);
      }
      function sendToJavaScript(value) {
          document.forms["form1"].output.value += "ActionScript says: " + value + "\n";
      }
  </script>
  </head>
  <body onload="pageInit();">

      <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
              id="ExternalInterfaceExample" width="500" height="375"
              codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab">
          <param name="movie" value="ExternalInterfaceExample.swf" />
          <param name="quality" value="high" />
          <param name="bgcolor" value="#869ca7" />
          <param name="allowScriptAccess" value="sameDomain" />
          <embed src="ExternalInterfaceExample.swf" quality="high" bgcolor="#869ca7"
              width="500" height="375" name="ExternalInterfaceExample" align="middle"
              play="true" loop="false" quality="high" allowScriptAccess="sameDomain"
              type="application/x-shockwave-flash"
              pluginspage="http://www.macromedia.com/go/getflashplayer">
          </embed>
      </object>

      <form name="form1" onsubmit="return false;">
          <input type="text" name="input" value="" />
          <input type="button" value="Send" onclick="sendToActionScript(this.form.input.value);" /><br />
          <textarea cols="60" rows="20" name="output" readonly="true">Initializing...</textarea>
      </form>

  </body>
  </html>


flash.filters Summary (Flex™ 2 Language Reference)

Package flash.filters | Classes

The flash.filters package contains classes for bitmap filter effects. Filters let you apply rich visual effects, such as blur, bevel, glow, and drop shadows, to display objects.

Classes
Class | Description
BevelFilter | The BevelFilter class lets you add a bevel effect to display objects.
BitmapFilter | The BitmapFilter class is the base class for all image filter effects.
BitmapFilterQuality | The BitmapFilterQuality class contains values to set the rendering quality of a BitmapFilter object.
BitmapFilterType | The BitmapFilterType class contains values to set the type of a BitmapFilter.
BlurFilter | The BlurFilter class lets you apply a blur visual effect to display objects.
ColorMatrixFilter | The ColorMatrixFilter class lets you apply a 4 x 5 matrix transformation on the RGBA color and alpha values of every pixel in the input image to produce a result with a new set of RGBA color and alpha values.
ConvolutionFilter | The ConvolutionFilter class applies a matrix convolution filter effect.
DisplacementMapFilter | The DisplacementMapFilter class uses the pixel values from the specified BitmapData object (called the displacement map image) to perform a displacement of an object.
DisplacementMapFilterMode | The DisplacementMapFilterMode class provides values for the mode property of the DisplacementMapFilter class.
DropShadowFilter | The DropShadowFilter class lets you add a drop shadow to display objects.
GlowFilter | The GlowFilter class lets you apply a glow effect to display objects.
GradientBevelFilter | The GradientBevelFilter class lets you apply a gradient bevel effect to display objects.
GradientGlowFilter | The GradientGlowFilter class lets you apply a gradient glow effect to display objects.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.filters.BevelFilter (Flex™ 2 Language Reference)

Class BevelFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class BevelFilter
Inheritance | BevelFilter Inheritance BitmapFilter Inheritance Object

The BevelFilter class lets you add a bevel effect to display objects. A bevel effect gives objects such as buttons a three-dimensional look. You can customize the look of the bevel with different highlight and shadow colors, the amount of blur on the bevel, the angle of the bevel, the placement of the bevel, and a knockout effect. You can apply the filter to any display object (that is, objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

To create a new filter, use the constructor new BevelFilter(). The use of filters depends on the object to which you apply the filter:

  • To apply filters to movie clips, text fields, buttons, and video, use the filters property (inherited from DisplayObject). Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the value of the cacheAsBitmap property of the object is set to true. If you remove all filters, the original value of cacheAsBitmap is restored.

This filter supports Stage scaling. However, it does not support general scaling, rotation, and skewing. If the object itself is scaled (if the scaleX and scaleY properties are not set to 100%), the filter is not scaled. It is scaled only when the user zooms in on the Stage.

A filter is not applied if the resulting image exceeds 2880 pixels in width or height. If, for example, you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image exceeds the limit of 2880 pixels.

View the examples.

See also

flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
flash.display.BitmapData.applyFilter()
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | angle : Number The angle of the bevel. | BevelFilter
 | blurX : Number The amount of horizontal blur, in pixels. | BevelFilter
 | blurY : Number The amount of vertical blur, in pixels. | BevelFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | distance : Number The offset distance of the bevel. | BevelFilter
 | highlightAlpha : Number The alpha transparency value of the highlight color. | BevelFilter
 | highlightColor : uint The highlight color of the bevel. | BevelFilter
 | knockout : Boolean Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document. | BevelFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : int The number of times to apply the filter. | BevelFilter
 | shadowAlpha : Number The alpha transparency value of the shadow color. | BevelFilter
 | shadowColor : uint The shadow color of the bevel. | BevelFilter
 | strength : Number The strength of the imprint or spread. | BevelFilter
 | type : String The placement of the bevel on the object. | BevelFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | BevelFilter(distance:Number = 4.0, angle:Number = 45, highlightColor:uint = 0xFFFFFF, highlightAlpha:Number = 1.0, shadowColor:uint = 0x000000, shadowAlpha:Number = 1.0, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1, quality:int = 1, type:String = "inner", knockout:Boolean = false) Initializes a new BevelFilter instance with the specified parameters. | BevelFilter
 | clone():BitmapFilter Returns a copy of this filter object. | BevelFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
angle property
angle:Number [read-write]

The angle of the bevel. Valid values are from 0 to 360°. The default value is 45°.

The angle value represents the angle of the theoretical light source falling on the object and determines the placement of the effect relative to the object. If the distance property is set to 0, the effect is not offset from the object and, therefore, the angle property has no effect.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void
blurX property
blurX:Number [read-write]

The amount of horizontal blur, in pixels. Valid values are from 0 to 255 (floating point). The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16, and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurX():Number
    public function set blurX(value:Number):void
blurY property
blurY:Number [read-write]

The amount of vertical blur, in pixels. Valid values are from 0 to 255 (floating point). The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16, and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurY():Number
    public function set blurY(value:Number):void
distance property
distance:Number [read-write]

The offset distance of the bevel. Valid values are in pixels (floating point). The default is 4.

Implementation
    public function get distance():Number
    public function set distance(value:Number):void
highlightAlpha property
highlightAlpha:Number [read-write]

The alpha transparency value of the highlight color. The value is specified as a normalized value from 0 to 1. For example, .25 sets a transparency value of 25%. The default value is 1.

Implementation
    public function get highlightAlpha():Number
    public function set highlightAlpha(value:Number):void
highlightColor property
highlightColor:uint [read-write]

The highlight color of the bevel. Valid values are in hexadecimal format, 0xRRGGBB. The default is 0xFFFFFF.

Implementation
    public function get highlightColor():uint
    public function set highlightColor(value:uint):void
knockout property
knockout:Boolean [read-write]

Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document. The default value is false (no knockout).

Implementation
    public function get knockout():Boolean
    public function set knockout(value:Boolean):void
quality property
quality:int [read-write]

The number of times to apply the filter. The default value is BitmapFilterQuality.LOW, which is equivalent to applying the filter once. The value BitmapFilterQuality.MEDIUM applies the filter twice; the value BitmapFilterQuality.HIGH applies it three times. Filters with lower values are rendered more quickly.

For most applications, a quality value of low, medium, or high is sufficient. Although you can use additional numeric values up to 15 to achieve different effects, higher values are rendered more slowly. Instead of increasing the value of quality, you can often get a similar effect, and with faster rendering, by simply increasing the values of the blurX and blurY properties.

You can use the following BitmapFilterQuality constants to specify values of the quality property:

  • BitmapFilterQuality.LOW
  • BitmapFilterQuality.MEDIUM
  • BitmapFilterQuality.HIGH

Implementation
    public function get quality():int
    public function set quality(value:int):void
shadowAlpha property
shadowAlpha:Number [read-write]

The alpha transparency value of the shadow color. This value is specified as a normalized value from 0 to 1. For example, .25 sets a transparency value of 25%. The default is 1.

Implementation
    public function get shadowAlpha():Number
    public function set shadowAlpha(value:Number):void
shadowColor property
shadowColor:uint [read-write]

The shadow color of the bevel. Valid values are in hexadecimal format, 0xRRGGBB. The default is 0x000000.

Implementation
    public function get shadowColor():uint
    public function set shadowColor(value:uint):void
strength property
strength:Number [read-write]

The strength of the imprint or spread. Valid values are from 0 to 255. The larger the value, the more color is imprinted and the stronger the contrast between the bevel and the background. The default value is 1.

Implementation
    public function get strength():Number
    public function set strength(value:Number):void
type property
type:String [read-write]

The placement of the bevel on the object. Inner and outer bevels are placed on the inner or outer edge; a full bevel is placed on the entire object. Valid values are the BitmapFilterType constants:

  • BitmapFilterType.INNER
  • BitmapFilterType.OUTER
  • BitmapFilterType.FULL

Implementation
    public function get type():String
    public function set type(value:String):void

Throws
TypeError — The string is null when being set
Constructor detail
BevelFilter () constructor
public function BevelFilter(distance:Number = 4.0, angle:Number = 45, highlightColor:uint = 0xFFFFFF, highlightAlpha:Number = 1.0, shadowColor:uint = 0x000000, shadowAlpha:Number = 1.0, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1, quality:int = 1, type:String = "inner", knockout:Boolean = false)

Initializes a new BevelFilter instance with the specified parameters.

Parameters
distance:Number (default = 4.0) — The offset distance of the bevel, in pixels (floating point).
angle:Number (default = 45) — The angle of the bevel, from 0 to 360 degrees.
highlightColor:uint (default = 0xFFFFFF) — The highlight color of the bevel, 0xRRGGBB.
highlightAlpha:Number (default = 1.0) — The alpha transparency value of the highlight color. Valid values are 0.0 to 1.0. For example, .25 sets a transparency value of 25%.
shadowColor:uint (default = 0x000000) — The shadow color of the bevel, 0xRRGGBB.
shadowAlpha:Number (default = 1.0) — The alpha transparency value of the shadow color. Valid values are 0.0 to 1.0. For example, .25 sets a transparency value of 25%.
blurX:Number (default = 4.0) — The amount of horizontal blur in pixels. Valid values are 0 to 255.0 (floating point).
blurY:Number (default = 4.0) — The amount of vertical blur in pixels. Valid values are 0 to 255.0 (floating point).
strength:Number (default = 1) — The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the bevel and the background. Valid values are 0 to 255.0.
quality:int (default = 1) — The quality of the bevel. Valid values are 0 to 15, but for most applications, you can use BitmapFilterQuality constants:
  • BitmapFilterQuality.LOW
  • BitmapFilterQuality.MEDIUM
  • BitmapFilterQuality.HIGH

Filters with lower values render faster. You can use the other available numeric values to achieve different effects.
type:String (default = "inner") — The type of bevel. Valid values are BitmapFilterType constants: BitmapFilterType.INNER, BitmapFilterType.OUTER, or BitmapFilterType.FULL.
knockout:Boolean (default = false) — Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document.

See also

BitmapFilterQuality
BitmapFilterType
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new BevelFilter instance with all the same properties as the original BevelFilter instance.
Examples

The following example creates a dark yellow square and applies a bevel with a bright yellow (0xFFFF00) highlight and a blue (0x0000FF) shadow. The general workflow for this example is as follows:
  1. Import the required classes.
  2. Declare three properties used in the draw() function, which draws the object to which the bevel filter is applied.
  3. Create the BevelFilterExample() constructor function, which does the following:
    • Calls the draw() function, which is declared later.
    • Declares a variable filter as a BitmapFilter object and assigns it to the return of a call to getBitmapFilter().
    • Creates a new Array object myFilters and adds filter to the array, and assigns myFilters to the filters property of BevelFilterExample object. This applies all filters found in myFilters, which in this case is only filter.
  4. Create the getBitmapFilter function to create and set properties for the filter.
  5. Create the draw() function. This function uses methods of the Graphics class, accessed through the graphics property of the Sprite class, to draw the square.
package {
    import flash.display.Sprite;
    import flash.filters.BevelFilter;
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.BitmapFilterType;

    public class BevelFilterExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint    = 80;
        private var offset:uint  = 50;

        public function BevelFilterExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            var distance:Number       = 5;
            var angleInDegrees:Number = 45;
            var highlightColor:Number = 0xFFFF00;
            var highlightAlpha:Number = 0.8;
            var shadowColor:Number    = 0x0000FF;
            var shadowAlpha:Number    = 0.8;
            var blurX:Number          = 5;
            var blurY:Number          = 5;
            var strength:Number       = 5;
            var quality:Number        = BitmapFilterQuality.HIGH;
            var type:String           = BitmapFilterType.INNER;
            var knockout:Boolean      = false;

            return new BevelFilter(distance,
                                   angleInDegrees,
                                   highlightColor,
                                   highlightAlpha,
                                   shadowColor,
                                   shadowAlpha,
                                   blurX,
                                   blurY,
                                   strength,
                                   quality,
                                   type,
                                   knockout);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.filters.BitmapFilter (Flex™ 2 Language Reference)

Class BitmapFilter | Properties | Methods | Examples
Package | flash.filters
Class | public class BitmapFilter
Inheritance | BitmapFilter Inheritance Object
Subclasses | BevelFilter, BlurFilter, ColorMatrixFilter, ConvolutionFilter, DisplacementMapFilter, DropShadowFilter, GlowFilter, GradientBevelFilter, GradientGlowFilter

The BitmapFilter class is the base class for all image filter effects.

The BevelFilter, BlurFilter, ColorMatrixFilter, ConvolutionFilter, DisplacementMapFilter, DropShadowFilter, GlowFilter, GradientBevelFilter, and GradientGlowFilter classes all extend the BitmapFilter class. You can apply these filter effects to any display object.

You can neither directly instantiate nor extend BitmapFilter.

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | clone():BitmapFilter Returns a BitmapFilter object that is an exact copy of the original BitmapFilter object. | BitmapFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
clone () method
public function clone():BitmapFilter

Returns a BitmapFilter object that is an exact copy of the original BitmapFilter object.

Returns
BitmapFilter — A BitmapFilter object.
Examples

The following example shows how several filters may be applied to a given DisplayObject object and tracked using the filters property.
package {
    import flash.display.Sprite;
    import flash.filters.*;

    public class BitmapFilterExample extends Sprite {
        public function BitmapFilterExample() {
            trace(this.filters.length);             // 0

            var tmpFilters:Array = this.filters;
            tmpFilters.push(FilterFactory.createFilter(FilterFactory.BEVEL_FILTER));
            tmpFilters.push(FilterFactory.createFilter(FilterFactory.GLOW_FILTER));
            this.filters = tmpFilters;

            trace(this.filters.length);             // 2
            trace(this.filters[0] is BitmapFilter); // true
            trace(this.filters[0] is BevelFilter);  // true
            trace(this.filters[1] is BitmapFilter); // true
            trace(this.filters[1] is GlowFilter);   // true
        }
    }
}

import flash.filters.*;
class FilterFactory {
    public static var BEVEL_FILTER:String = "BevelFilter";
    public static var BevelFilterConstructor:Class = BevelFilter;

    public static var BLUR_FILTER:String = "BlurFilter";
    public static var BlurFilterConstructor:Class = BlurFilter;

    public static var COLOR_MATRIX_FILTER:String = "ColorMatrixFilter";
    public static var ColorMatrixFilterConstructor:Class = ColorMatrixFilter;

    public static var CONVOLUTION_FILTER:String = "ConvolutionFilter";
    public static var ConvolutionFilterConstructor:Class = ConvolutionFilter;

    public static var DISPLACEMENT_MAP_FILTER:String = "DisplacementMapFilter";
    public static var DisplacementMapFilterConstructor:Class = DisplacementMapFilter;

    public static var DROP_SHADOW_FILTER:String = "DropShadowFilter";
    public static var DropShadowFilterConstructor:Class = DropShadowFilter;

    public static var GLOW_FILTER:String = "GlowFilter";
    public static var GlowFilterConstructor:Class = GlowFilter;

    public static var GRADIENT_BEVEL_FILTER:String = "GradientBevelFilter";
    public static var GradientBevelFilterConstructor:Class = GradientBevelFilter;

    public static var GRADIENT_GLOW_FILTER:String = "GradientGlowFilter";
    public static var GradientGlowFilterConstructor:Class = GradientGlowFilter;

    public static function createFilter(type:String):BitmapFilter {
        return new FilterFactory[type + "Constructor"]();
    }
}


flash.filters.BitmapFilterQuality (Flex™ 2 Language Reference)

Class BitmapFilterQuality | Properties | Methods | Constants | Examples
Package | flash.filters
Class | public final class BitmapFilterQuality
Inheritance | BitmapFilterQuality Inheritance Object

The BitmapFilterQuality class contains values to set the rendering quality of a BitmapFilter object.

View the examples.

See also

BevelFilter
BlurFilter
GlowFilter
DropShadowFilter
GradientBevelFilter
GradientGlowFilter

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HIGH : int = 3 [static] Defines the high quality filter setting. | BitmapFilterQuality
 | LOW : int = 1 [static] Defines the low quality filter setting. | BitmapFilterQuality
 | MEDIUM : int = 2 [static] Defines the medium quality filter setting. | BitmapFilterQuality
Constant detail
HIGH constant
public static const HIGH:int = 3

Defines the high quality filter setting.

LOW constant
public static const LOW:int = 1

Defines the low quality filter setting.

MEDIUM constant
public static const MEDIUM:int = 2

Defines the medium quality filter setting.

Examples

The following example draws a gray square and applies a BevelFilter object to it. The example sets the quality property by using the constant BitmapFilterQuality.HIGH.

package {
    import flash.display.Sprite;
    import flash.filters.BevelFilter;
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.BitmapFilterType;

    public class BitmapFilterQualityExample extends Sprite {
        private var bgColor:uint = 0x999999;
        private var size:uint    = 80;
        private var offset:uint  = 50;

        public function BitmapFilterQualityExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            var distance:Number       = 5;
            var angleInDegrees:Number = 45;
            var highlightColor:Number = 0xCCCCCC;
            var highlightAlpha:Number = 0.8;
            var shadowColor:Number    = 0x808080;
            var shadowAlpha:Number    = 0.8;
            var blurX:Number          = 5;
            var blurY:Number          = 5;
            var strength:Number       = 5;
            var quality:Number        = BitmapFilterQuality.HIGH;
            var type:String           = BitmapFilterType.INNER;
            var knockout:Boolean      = false;

            return new BevelFilter(distance,
                                   angleInDegrees,
                                   highlightColor,
                                   highlightAlpha,
                                   shadowColor,
                                   shadowAlpha,
                                   blurX,
                                   blurY,
                                   strength,
                                   quality,
                                   type,
                                   knockout);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.filters.BitmapFilterType (Flex™ 2 Language Reference)

Class BitmapFilterType | Properties | Methods | Constants | Examples
Package | flash.filters
Class | public final class BitmapFilterType
Inheritance | BitmapFilterType Inheritance Object

The BitmapFilterType class contains values to set the type of a BitmapFilter.

View the examples.

See also

BevelFilter
GradientBevelFilter
GradientGlowFilter

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | FULL : String = "full" [static] Defines the setting that applies a filter to the entire area of an object. | BitmapFilterType
 | INNER : String = "inner" [static] Defines the setting that applies a filter to the inner area of an object. | BitmapFilterType
 | OUTER : String = "outer" [static] Defines the setting that applies a filter to the outer area of an object. | BitmapFilterType
Constant detail
FULL constant
public static const FULL:String = "full"

Defines the setting that applies a filter to the entire area of an object.

INNER constant
public static const INNER:String = "inner"

Defines the setting that applies a filter to the inner area of an object.

OUTER constant
public static const OUTER:String = "outer"

Defines the setting that applies a filter to the outer area of an object.

Examples

The following example draws a gray square and applies a BevelFilter object to it. The example sets the type property by using the constant BitmapFilterType.HIGH.

package {
    import flash.display.Sprite;
    import flash.filters.BevelFilter;
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.BitmapFilterType;

    public class BitmapFilterTypeExample extends Sprite {
        private var bgColor:uint = 0x999999;
        private var size:uint    = 80;
        private var offset:uint  = 50;

        public function BitmapFilterTypeExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            var distance:Number       = 5;
            var angleInDegrees:Number = 45;
            var highlightColor:Number = 0xCCCCCC;
            var highlightAlpha:Number = 0.8;
            var shadowColor:Number    = 0x808080;
            var shadowAlpha:Number    = 0.8;
            var blurX:Number          = 5;
            var blurY:Number          = 5;
            var strength:Number       = 5;
            var quality:Number        = BitmapFilterQuality.HIGH;
            var type:String           = BitmapFilterType.INNER;
            var knockout:Boolean      = false;

            return new BevelFilter(distance,
                                   angleInDegrees,
                                   highlightColor,
                                   highlightAlpha,
                                   shadowColor,
                                   shadowAlpha,
                                   blurX,
                                   blurY,
                                   strength,
                                   quality,
                                   type,
                                   knockout);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.filters.BlurFilter (Flex™ 2 Language Reference)

Class BlurFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class BlurFilter
Inheritance | BlurFilter Inheritance BitmapFilter Inheritance Object

The BlurFilter class lets you apply a blur visual effect to display objects. A blur effect softens the details of an image. You can produce blurs that range from a softly unfocused look to a Gaussian blur, a hazy appearance like viewing an image through semi-opaque glass. When the quality property of this filter is set to low, the result is a softly unfocused look. When the quality property is set to high, it approximates a Gaussian blur filter. You can apply the filter to any display object (that is, objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

To create a new filter, use the constructor new BevelFilter(). The use of filters depends on the object to which you apply the filter:

  • To apply filters to movie clips, text fields, buttons, and video, use the filters property (inherited from DisplayObject). Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the cacheAsBitmap property of the display object is set to true. If you remove all filters, the original value of cacheAsBitmap is restored.

This filter supports Stage scaling. However, it does not support general scaling, rotation, and skewing. If the object itself is scaled (scaleX and scaleY are not set to 100%), the filter effect is not scaled. It is scaled only when the user zooms in on the Stage.

A filter is not applied if the resulting image exceeds 2880 pixels in width or height. If, for example, you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image exceeds the limit of 2880 pixels.

View the examples.

See also

flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
flash.display.BitmapData.applyFilter()
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | blurX : Number The amount of horizontal blur. | BlurFilter
 | blurY : Number The amount of vertical blur. | BlurFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : int The number of times to perform the blur. | BlurFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | BlurFilter(blurX:Number = 4.0, blurY:Number = 4.0, quality:int = 1) Initializes the filter with the specified parameters. | BlurFilter
 | clone():BitmapFilter Returns a copy of this filter object. | BlurFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
blurX property
blurX:Number [read-write]

The amount of horizontal blur. Valid values are from 0 to 255 (floating point). The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurX():Number
    public function set blurX(value:Number):void
blurY property
blurY:Number [read-write]

The amount of vertical blur. Valid values are from 0 to 255 (floating point). The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurY():Number
    public function set blurY(value:Number):void
quality property
quality:int [read-write]

The number of times to perform the blur. The default value is BitmapFilterQuality.LOW, which is equivalent to applying the filter once. The value BitmapFilterQuality.MEDIUM applies the filter twice; the value BitmapFilterQuality.HIGH applies it three times and approximates a Gaussian blur. Filters with lower values are rendered more quickly.

For most applications, a quality value of low, medium, or high is sufficient. Although you can use additional numeric values up to 15 to increase the number of times the blur is applied, higher values are rendered more slowly. Instead of increasing the value of quality, you can often get a similar effect, and with faster rendering, by simply increasing the values of the blurX and blurY properties.

You can use the following BitmapFilterQuality constants to specify values of the quality property:

  • BitmapFilterQuality.LOW
  • BitmapFilterQuality.MEDIUM
  • BitmapFilterQuality.HIGH
Implementation
    public function get quality():int
    public function set quality(value:int):void
Constructor detail
BlurFilter () constructor
public function BlurFilter(blurX:Number = 4.0, blurY:Number = 4.0, quality:int = 1)

Initializes the filter with the specified parameters. The default values create a soft, unfocused image.

Parameters
blurX:Number (default = 4.0) — The amount to blur horizontally. Valid values are from 0 to 255.0 (floating-point value).
blurY:Number (default = 4.0) — The amount to blur vertically. Valid values are from 0 to 255.0 (floating-point value).
quality:int (default = 1) — The number of times to apply the filter. You can specify the quality using the BitmapFilterQuality constants:
  • flash.filters.BitmapFilterQuality.LOW
  • flash.filters.BitmapFilterQuality.MEDIUM
  • flash.filters.BitmapFilterQuality.HIGH

High quality approximates a Gaussian blur. For most applications, these three values are sufficient. Although you can use additional numeric values up to 15 to achieve different effects, be aware that higher values are rendered more slowly.
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new BlurFilter instance with all the same properties as the original BlurFilter instance.
Examples

The following example creates a dark yellow square and applies a Gaussian-style blur filter to it. The general workflow for this example is as follows:
  1. Import the required classes.
  2. Declare three properties used in the draw() function, which draws the object to which the blur filter is applied.
  3. Create the BlurFilterExample() constructor function, which does the following:
    • Calls the draw() function, which is declared later.
    • Declares a filter variable as a BitmapFilter object and assigns it to the return of a call to getBitmapFilter().
    • Creates a new Array object myFilters and adds filter to the array, and assigns myFilters to the filters property of the BlurFilterExample object. This applies all filters found in myFilters, which in this case is only filter.
  4. Create the getBitmapFilter() function to create and set properties for the filter.
  5. Create the draw() function. This function uses methods of the Graphics class, accessed through the graphics property of the Sprite class, to draw the square.

package {
    import flash.display.Sprite;
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.BlurFilter;

    public class BlurFilterExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint    = 80;
        private var offset:uint  = 50;

        public function BlurFilterExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            var blurX:Number = 30;
            var blurY:Number = 30;
            return new BlurFilter(blurX, blurY, BitmapFilterQuality.HIGH);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.filters.ColorMatrixFilter (Flex™ 2 Language Reference)

Class ColorMatrixFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class ColorMatrixFilter
Inheritance | ColorMatrixFilter Inheritance BitmapFilter Inheritance Object

The ColorMatrixFilter class lets you apply a 4 x 5 matrix transformation on the RGBA color and alpha values of every pixel in the input image to produce a result with a new set of RGBA color and alpha values. It allows saturation changes, hue rotation, luminance to alpha, and various other effects. You can apply the filter to any display object (that is, objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

Note: For RGBA values, the most significant byte represents the red channel value, followed by green, blue, and then alpha.

To create a new color matrix filter, use the syntax new ColorMatrixFilter(). The use of filters depends on the object to which you apply the filter:

  • To apply filters to movie clips, text fields, buttons, and video, use the filters property (inherited from DisplayObject). Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the cacheAsBitmap property of the display object is set to true. If you remove all filters, the original value of cacheAsBitmap is restored.

A filter is not applied if the resulting image would exceed 2880 pixels in width or height. For example, if you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image reaches the 2880-pixel limit.

View the examples.

See also

flash.display.BitmapData.getPixel()
flash.display.BitmapData.applyFilter()
flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | matrix : Array An array of 20 items for 4 x 5 color transform. | ColorMatrixFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ColorMatrixFilter(matrix:Array = null) Initializes a new ColorMatrixFilter instance with the specified parameters. | ColorMatrixFilter
 | clone():BitmapFilter Returns a copy of this filter object. | ColorMatrixFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
matrix property
matrix:Array [read-write]

An array of 20 items for 4 x 5 color transform. The matrix property cannot be changed by directly modifying its value (for example, myFilter.matrix[2] = 1;). Instead, you must get a reference to the array, make the change to the reference, and reset the value.

The color matrix filter separates each source pixel into its red, green, blue, and alpha components as srcR, srcG, srcB, srcA. To calculate the result of each of the four channels, the value of each pixel in the image is multiplied by the values in the transformation matrix. An offset, between -255 and 255, can optionally be added to each result (the fifth item in each row of the matrix). The filter combines each color component back into a single pixel and writes out the result. In the following formula, a[0] through a[19] correspond to entries 0 through 19 in the 20-item array that is passed to the matrix property:

 redResult   = (a[0]  * srcR) + (a[1]  * srcG) + (a[2]  * srcB) + (a[3]  * srcA) + a[4]
 greenResult = (a[5]  * srcR) + (a[6]  * srcG) + (a[7]  * srcB) + (a[8]  * srcA) + a[9]
 blueResult  = (a[10] * srcR) + (a[11] * srcG) + (a[12] * srcB) + (a[13] * srcA) + a[14]
 alphaResult = (a[15] * srcR) + (a[16] * srcG) + (a[17] * srcB) + (a[18] * srcA) + a[19]

For each color value in the array, a value of 1 is equal to 100% of that channel being sent to the output, preserving the value of the color channel.

The calculations are performed on unmultiplied color values. If the input graphic consists of premultiplied color values, those values are automatically converted into unmultiplied color values for this operation.

Two optimized modes are available:

Alpha only. When you pass to the filter a matrix that adjusts only the alpha component, as shown here, the filter optimizes its performance:

     1 0 0 0 0
     0 1 0 0 0
     0 0 1 0 0
     0 0 0 N 0  (where N is between 0.0 and 1.0)

Faster version. Available only with SSE/AltiVec accelerator-enabled processors, such as Intel® Pentium 3 and later and Apple® G4 and later. The accelerator is used when the multiplier terms are in the range -15.99 to 15.99 and the adder terms a[4], a[9], a[14], and a[19] are in the range -8000 to 8000.

Implementation
    public function get matrix():Array
    public function set matrix(value:Array):void

Throws
TypeError — The Array is null when being set
Constructor detail
ColorMatrixFilter () constructor
public function ColorMatrixFilter(matrix:Array = null)

Initializes a new ColorMatrixFilter instance with the specified parameters.

Parameters
matrix:Array (default = null) — An array of 20 items arranged as a 4 x 5 matrix.
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new ColorMatrixFilter instance with all of the same properties as the original one.
Examples

The following example applies different color matrix filters to an image file. The filter constructor calls buildChild() four times to load and display four instances of the image. The first call to buildChild() takes null as an argument, applying no filter to the first instance. Each subsequent call to buildChild() takes as an argument a function that applies a different color matrix filter to each subsequent instance of the image.

The buildChild() function creates a new Loader object named loader. For each call to buildChild(), attach an event listener to the Loader object to listen for complete events, which are handled by the function passed to buildChild().

The applyRed(), applyGreen(), and applyBlue() functions use different values for the matrix array to achieve different effects.

Note: For best results, use an image approximately 80 pixels in width. The name and location of the image file should match the value you pass to the url property. For example, the value passed to url in the example points to an image file named "Image.jpg" that is in the same directory as your SWF file.

package {
    import flash.display.DisplayObject;
    import flash.display.Loader;
    import flash.display.Sprite;
    import flash.events.Event;
    import flash.events.IOErrorEvent;
    import flash.filters.ColorMatrixFilter;
    import flash.net.URLRequest;

    public class ColorMatrixFilterExample extends Sprite {
        private var size:uint  = 140;
        private var url:String = "Image.jpg";

        public function ColorMatrixFilterExample() {
            buildChild(null);
            buildChild(applyRed);
            buildChild(applyGreen);
            buildChild(applyBlue);
        }

        private function buildChild(loadHandler:Function):void {
            var loader:Loader = new Loader();
            loader.x = numChildren * size;
            loader.y = size;
            loader.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            if (loadHandler != null) {
                loader.contentLoaderInfo.addEventListener(Event.COMPLETE, loadHandler);
            }

            var request:URLRequest = new URLRequest(url);
            loader.load(request);
            addChild(loader);
        }

        private function applyRed(event:Event):void {
            var child:DisplayObject = DisplayObject(event.target.loader);
            var matrix:Array = new Array();
            matrix = matrix.concat([1, 0, 0, 0, 0]); // red
            matrix = matrix.concat([0, 0, 0, 0, 0]); // green
            matrix = matrix.concat([0, 0, 0, 0, 0]); // blue
            matrix = matrix.concat([0, 0, 0, 1, 0]); // alpha

            applyFilter(child, matrix);
        }

        private function applyGreen(event:Event):void {
            var child:DisplayObject = DisplayObject(event.target.loader);
            var matrix:Array = new Array();
            matrix = matrix.concat([0, 0, 0, 0, 0]); // red
            matrix = matrix.concat([0, 1, 0, 0, 0]); // green
            matrix = matrix.concat([0, 0, 0, 0, 0]); // blue
            matrix = matrix.concat([0, 0, 0, 1, 0]); // alpha

            applyFilter(child, matrix);
        }

        private function applyBlue(event:Event):void {
            var child:DisplayObject = DisplayObject(event.target.loader);
            var matrix:Array = new Array();
            matrix = matrix.concat([0, 0, 0, 0, 0]); // red
            matrix = matrix.concat([0, 0, 0, 0, 0]); // green
            matrix = matrix.concat([0, 0, 1, 0, 0]); // blue
            matrix = matrix.concat([0, 0, 0, 1, 0]); // alpha

            applyFilter(child, matrix);
        }

        private function applyFilter(child:DisplayObject, matrix:Array):void {
            var filter:ColorMatrixFilter = new ColorMatrixFilter(matrix);
            var filters:Array = new Array();
            filters.push(filter);
            child.filters = filters;
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("Unable to load image: " + url);
        }
    }
}


flash.filters.ConvolutionFilter (Flex™ 2 Language Reference)

Class ConvolutionFilter | Properties | Methods | Examples
Package | flash.filters
Class | public class ConvolutionFilter
Inheritance | ConvolutionFilter Inheritance BitmapFilter Inheritance Object

The ConvolutionFilter class applies a matrix convolution filter effect. A convolution combines pixels in the input image with neighboring pixels to produce an image. A wide variety of image effects can be achieved through convolutions, including blurring, edge detection, sharpening, embossing, and beveling. You can apply the filter to any display object (that is, objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

To create a convolution filter, use the syntax new ConvolutionFilter(). The use of filters depends on the object to which you apply the filter:

  • To apply filters to movie clips, text fields, buttons, and video, use the filters property (inherited from DisplayObject). Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the value of the cacheAsBitmap property of the object is set to true. If you clear all filters, the original value of cacheAsBitmap is restored.

A filter is not applied if the resulting image exceeds 2880 pixels in width or height. For example, if you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image exceeds the limit of 2880 pixels.

View the examples.

See also

flash.display.BitmapData.applyFilter()
flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
matrix
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number The alpha transparency value of the substitute color. | ConvolutionFilter
 | bias : Number The amount of bias to add to the result of the matrix transformation. | ConvolutionFilter
 | clamp : Boolean Indicates whether the image should be clamped. | ConvolutionFilter
 | color : uint The hexadecimal color to substitute for pixels that are off the source image. | ConvolutionFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | divisor : Number The divisor used during matrix transformation. | ConvolutionFilter
 | matrix : Array An array of values used for matrix transformation. | ConvolutionFilter
 | matrixX : Number The x dimension of the matrix (the number of columns in the matrix). | ConvolutionFilter
 | matrixY : Number The y dimension of the matrix (the number of rows in the matrix). | ConvolutionFilter
 | preserveAlpha : Boolean Indicates if the alpha channel is preserved without the filter effect or if the convolution filter is applied to the alpha channel as well as the color channels. | ConvolutionFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ConvolutionFilter(matrixX:Number = 0, matrixY:Number = 0, matrix:Array = null, divisor:Number = 1.0, bias:Number = 0.0, preserveAlpha:Boolean = true, clamp:Boolean = true, color:uint = 0, alpha:Number = 0.0) Initializes a ConvolutionFilter instance with the specified parameters. | ConvolutionFilter
 | clone():BitmapFilter Returns a copy of this filter object. | ConvolutionFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
alpha:Number [read-write]

The alpha transparency value of the substitute color. Valid values are 0 to 1.0. The default is 0. For example, .25 sets a transparency value of 25%.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
bias property
bias:Number [read-write]

The amount of bias to add to the result of the matrix transformation. The bias increases the color value of each channel, so that dark colors appear brighter. The default value is 0.

Implementation
    public function get bias():Number
    public function set bias(value:Number):void
clamp property
clamp:Boolean [read-write]

Indicates whether the image should be clamped. For pixels off the source image, a value of true indicates that the input image is extended along each of its borders as necessary by duplicating the color values at each respective edge of the input image. A value of false indicates that another color should be used, as specified in the color and alpha properties. The default is true.

Implementation
    public function get clamp():Boolean
    public function set clamp(value:Boolean):void
color property
color:uint [read-write]

The hexadecimal color to substitute for pixels that are off the source image. It is an RGB value with no alpha component. The default is 0.

Implementation
    public function get color():uint
    public function set color(value:uint):void
divisor property
divisor:Number [read-write]

The divisor used during matrix transformation. The default value is 1. A divisor that is the sum of all the matrix values smooths out the overall color intensity of the result. A value of 0 is ignored and the default is used instead.

Implementation
    public function get divisor():Number
    public function set divisor(value:Number):void
matrix property
matrix:Array [read-write]

An array of values used for matrix transformation. The number of items in the array must equal matrixX * matrixY.

A matrix convolution is based on an n x m matrix, which describes how a given pixel value in the input image is combined with its neighboring pixel values to produce a resulting pixel value. Each result pixel is determined by applying the matrix to the corresponding source pixel and its neighboring pixels.

For a 3 x 3 matrix convolution, the following formula is used for each independent color channel:

 dst (x, y) = ((src (x-1, y-1) * a0 + src(x, y-1) * a1....
                   src(x, y+1) * a7 + src (x+1,y+1) * a8) / divisor) + bias

Certain filter specifications perform faster when run by a processor that offers SSE (Streaming SIMD Extensions). The following are criteria for faster convolution operations:

  • The filter must be a 3x3 filter.
  • All the filter terms must be integers between -127 and +127.
  • The sum of all the filter terms must not have an absolute value greater than 127.
  • If any filter term is negative, the divisor must be between 2.00001 and 256.
  • If all filter terms are positive, the divisor must be between 1.1 and 256.
  • The bias must be an integer.
Implementation
    public function get matrix():Array
    public function set matrix(value:Array):void

Throws
TypeError — The Array is null when being set
matrixX property
matrixX:Number [read-write]

The x dimension of the matrix (the number of columns in the matrix). The default value is 0.

Implementation
    public function get matrixX():Number
    public function set matrixX(value:Number):void
matrixY property
matrixY:Number [read-write]

The y dimension of the matrix (the number of rows in the matrix). The default value is 0.

Implementation
    public function get matrixY():Number
    public function set matrixY(value:Number):void
preserveAlpha property
preserveAlpha:Boolean [read-write]

Indicates if the alpha channel is preserved without the filter effect or if the convolution filter is applied to the alpha channel as well as the color channels. A value of false indicates that the convolution applies to all channels, including the alpha channel. A value of true indicates that the convolution applies only to the color channels. The default value is true.

Implementation
    public function get preserveAlpha():Boolean
    public function set preserveAlpha(value:Boolean):void
Constructor detail
ConvolutionFilter () constructor
public function ConvolutionFilter(matrixX:Number = 0, matrixY:Number = 0, matrix:Array = null, divisor:Number = 1.0, bias:Number = 0.0, preserveAlpha:Boolean = true, clamp:Boolean = true, color:uint = 0, alpha:Number = 0.0)

Initializes a ConvolutionFilter instance with the specified parameters.

Parameters
matrixX:Number (default = 0) — The x dimension of the matrix (the number of columns in the matrix). The default value is 0.
matrixY:Number (default = 0) — The y dimension of the matrix (the number of rows in the matrix). The default value is 0.
matrix:Array (default = null) — The array of values used for matrix transformation. The number of items in the array must equal matrixX * matrixY.
divisor:Number (default = 1.0) — The divisor used during matrix transformation. The default value is 1. A divisor that is the sum of all the matrix values evens out the overall color intensity of the result. A value of 0 is ignored and the default is used instead.
bias:Number (default = 0.0) — The bias to add to the result of the matrix transformation. The default value is 0.
preserveAlpha:Boolean (default = true) — A value of false indicates that the alpha value is not preserved and that the convolution applies to all channels, including the alpha channel. A value of true indicates that the convolution applies only to the color channels. The default value is true.
clamp:Boolean (default = true) — For pixels that are off the source image, a value of true indicates that the input image is extended along each of its borders as necessary by duplicating the color values at the given edge of the input image. A value of false indicates that another color should be used, as specified in the color and alpha properties. The default is true.
color:uint (default = 0) — The hexadecimal color to substitute for pixels that are off the source image.
alpha:Number (default = 0.0) — The alpha of the substitute color.
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — BitmapFilter A new ConvolutionFilter instance with all the same properties as the original ConvolutionMatrixFilter instance.
Examples

The following example applies different convolution filters to an image file. The filter constructor calls buildChild() four times to load and display four instances of the image. Each call to buildChild() takes as an argument a function that applies no filter to the first instance and a different convolution filter to each subsequent instance.

The buildChild() function creates a new Loader object named loader. For each call to buildChild(), attach an event listener to the Loader object to listen for complete events, which are handled by the function passed to buildChild().

The applyBrightness(), applySharpness(), and applyOutline() functions use different values for the matrix array to achieve different ConvolutionFilter effects.

Note: For best results, use an image approximately 80 pixels in width. The name and location of the image file should match the value you pass to the url property. For example, the value passed to url in the example points to an image file named "Image.jpg" that is in the same directory as your SWF file.

package {
    import flash.display.DisplayObject;
    import flash.display.Loader;
    import flash.display.Sprite;
    import flash.events.*;
    import flash.filters.BitmapFilter;
    import flash.filters.ConvolutionFilter;
    import flash.net.URLRequest;
    import flash.text.TextField;
    import flash.text.TextFieldAutoSize;

    public class ConvolutionFilterExample extends Sprite {
        private var size:uint = 140;
        private var url:String = "Image.jpg";

        public function ConvolutionFilterExample() {
            buildChild(applyNothing);
            buildChild(applyBrightness);
            buildChild(applySharpness);
            buildChild(applyOutline);
        }

        private function buildChild(loadHandler:Function):void {
            var loader:Loader = new Loader();
            loader.x = numChildren * size;
            loader.y = size;
            loader.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            if(loadHandler != null) {
                loader.contentLoaderInfo.addEventListener(Event.COMPLETE, loadHandler);
            }

            var request:URLRequest = new URLRequest(url);
            loader.load(request);
            addChild(loader);
        }

        private function applyNothing(event:Event):void {
            var child:DisplayObject = DisplayObject(event.target.loader);
            applyLabel(child, "no filter");
        }

        private function applyBrightness(event:Event):void {
            var child:DisplayObject = DisplayObject(event.target.loader);
            var matrix:Array = [5, 5, 5,
                                5, 0, 5,
                                5, 5, 5];
            applyFilter(child, matrix);
            applyLabel(child, "brightness");
        }

        private function applySharpness(event:Event):void {
            var child:DisplayObject = DisplayObject(event.target.loader);
            var matrix:Array = [0, -1, 0,
                               -1, 20, -1,
                                0, -1, 0];
            applyFilter(child, matrix);
            applyLabel(child, "sharpness");
        }

        private function applyOutline(event:Event):void {
            var child:DisplayObject = DisplayObject(event.target.loader);
            var matrix:Array = [-30, 30, 0,
                                -30, 30, 0,
                                -30, 30, 0];
            applyFilter(child, matrix);
            applyLabel(child, "outline");
        }

        private function applyFilter(child:DisplayObject, matrix:Array):void {
            var matrixX:Number = 3;
            var matrixY:Number = 3;
            var divisor:Number = 9;
            var filter:BitmapFilter = new ConvolutionFilter(matrixX, matrixY, matrix, divisor);
            var filters:Array = new Array();
            filters.push(filter);
            child.filters = filters;
        }

        private function applyLabel(child:DisplayObject, label:String):void {
            var tf:TextField = new TextField();
            tf.x = child.x;
            tf.y = child.height;
            tf.autoSize = TextFieldAutoSize.LEFT;
            tf.text = label;
            addChild(tf);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("Unable to load image: " + url);
        }
    }
}


flash.filters.DisplacementMapFilter (Flex™ 2 Language Reference)

Class DisplacementMapFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class DisplacementMapFilter
Inheritance | DisplacementMapFilter Inheritance BitmapFilter Inheritance Object

The DisplacementMapFilter class uses the pixel values from the specified BitmapData object (called the displacement map image) to perform a displacement of an object. You can use this filter to apply a warped or mottled effect to any object that inherits from the DisplayObject class, such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

The use of filters depends on the object to which you apply the filter:

  • To apply filters to a display object, use the filters property of the display object. Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image.

If you apply a filter to a display object, the value of the cacheAsBitmap property of the display object is set to true. If you clear all filters, the original value of cacheAsBitmap is restored.

The filter uses the following formula:

dstPixel[x, y] = srcPixel[x + ((componentX(x, y) - 128) * scaleX) / 256, y + ((componentY(x, y) - 128) *scaleY) / 256)

where componentX(x, y) gets the componentX property color value from the mapBitmap property at (x - mapPoint.x ,y - mapPoint.y).

The map image used by the filter is scaled to match the Stage scaling. It is not scaled when the object itself is scaled.

This filter supports Stage scaling. However, general scaling, rotation, and skewing are not supported. If the object itself is scaled (if the scaleX and scaleY properties are set to a value other than 1.0), the filter effect is not scaled. It is scaled only when the user zooms in on the Stage.

View the examples.

See also

flash.display.BitmapData.applyFilter()
flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number Specifies the alpha transparency value to use for out-of-bounds displacements. | DisplacementMapFilter
 | color : uint Specifies what color to use for out-of-bounds displacements. | DisplacementMapFilter
 | componentX : uint Describes which color channel to use in the map image to displace the x result. | DisplacementMapFilter
 | componentY : uint Describes which color channel to use in the map image to displace the y result. | DisplacementMapFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | mapBitmap : BitmapData A BitmapData object containing the displacement map data. | DisplacementMapFilter
 | mapPoint : Point A value that contains the offset of the upper-left corner of the target display object from the upper-left corner of the map image. | DisplacementMapFilter
 | mode : String The mode for the filter. | DisplacementMapFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | scaleX : Number The multiplier to use to scale the x displacement result from the map calculation. | DisplacementMapFilter
 | scaleY : Number The multiplier to use to scale the y displacement result from the map calculation. | DisplacementMapFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DisplacementMapFilter(mapBitmap:BitmapData = null, mapPoint:Point = null, componentX:uint = 0, componentY:uint = 0, scaleX:Number = 0.0, scaleY:Number = 0.0, mode:String = "wrap", color:uint = 0, alpha:Number = 0.0) Initializes a DisplacementMapFilter instance with the specified parameters. | DisplacementMapFilter
 | clone():BitmapFilter Returns a copy of this filter object. | DisplacementMapFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
alpha:Number [read-write]

Specifies the alpha transparency value to use for out-of-bounds displacements. It is specified as a normalized value from 0.0 to 1.0. For example, .25 sets a transparency value of 25%. The default value is 0. Use this property if the mode property is set to DisplacementMapFilterMode.COLOR.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
color property
color:uint [read-write]

Specifies what color to use for out-of-bounds displacements. The valid range of displacements is 0.0 to 1.0. Values are in hexadecimal format. The default value for color is 0. Use this property if the mode property is set to DisplacementMapFilterMode.COLOR.

Implementation
    public function get color():uint
    public function set color(value:uint):void
componentX property
componentX:uint [read-write]

Describes which color channel to use in the map image to displace the x result. Possible values are BitmapDataChannel constants:

  • BitmapDataChannel.ALPHA
  • BitmapDataChannel.BLUE
  • BitmapDataChannel.GREEN
  • BitmapDataChannel.RED

Implementation
    public function get componentX():uint
    public function set componentX(value:uint):void

See also

flash.display.BitmapDataChannel
componentY property
componentY:uint [read-write]

Describes which color channel to use in the map image to displace the y result. Possible values are BitmapDataChannel constants:

  • BitmapDataChannel.ALPHA
  • BitmapDataChannel.BLUE
  • BitmapDataChannel.GREEN
  • BitmapDataChannel.RED

Implementation
    public function get componentY():uint
    public function set componentY(value:uint):void

See also

flash.display.BitmapDataChannel
mapBitmap property
mapBitmap:BitmapData [read-write]

A BitmapData object containing the displacement map data.

Implementation
    public function get mapBitmap():BitmapData
    public function set mapBitmap(value:BitmapData):void

Throws
TypeError — The BitmapData is null when being set

See also

flash.display.BitmapData
mapPoint property
mapPoint:Point [read-write]

A value that contains the offset of the upper-left corner of the target display object from the upper-left corner of the map image.

Implementation
    public function get mapPoint():Point
    public function set mapPoint(value:Point):void

Throws
TypeError — The Point is null when being set

See also

flash.geom.Point
mode property
mode:String [read-write]

The mode for the filter. Possible values are DisplacementMapFilterMode constants:

  • DisplacementMapFilterMode.WRAP — Wraps the displacement value to the other side of the source image.
  • DisplacementMapFilterMode.CLAMP — Clamps the displacement value to the edge of the source image.
  • DisplacementMapFilterMode.IGNORE — If the displacement value is out of range, ignores the displacement and uses the source pixel.
  • DisplacementMapFilterMode.COLOR — If the displacement value is outside the image, substitutes the values in the color and alpha properties.

Implementation
    public function get mode():String
    public function set mode(value:String):void

Throws
TypeError — The String is null when being set
ArgumentError — The mode string is not one of the valid types

See also

flash.filters.DisplacementMapFilterMode
scaleX property
scaleX:Number [read-write]

The multiplier to use to scale the x displacement result from the map calculation.

Implementation
    public function get scaleX():Number
    public function set scaleX(value:Number):void
scaleY property
scaleY:Number [read-write]

The multiplier to use to scale the y displacement result from the map calculation.

Implementation
    public function get scaleY():Number
    public function set scaleY(value:Number):void
Constructor detail
DisplacementMapFilter () constructor
public function DisplacementMapFilter(mapBitmap:BitmapData = null, mapPoint:Point = null, componentX:uint = 0, componentY:uint = 0, scaleX:Number = 0.0, scaleY:Number = 0.0, mode:String = "wrap", color:uint = 0, alpha:Number = 0.0)

Initializes a DisplacementMapFilter instance with the specified parameters.

Parameters
mapBitmap:BitmapData (default = null) — A BitmapData object containing the displacement map data.
mapPoint:Point (default = null) — A value that contains the offset of the upper-left corner of the target display object from the upper-left corner of the map image.
componentX:uint (default = 0) — Describes which color channel to use in the map image to displace the x result. Possible values are the BitmapDataChannel constants.
componentY:uint (default = 0) — Describes which color channel to use in the map image to displace the y result. Possible values are the BitmapDataChannel constants.
scaleX:Number (default = 0.0) — The multiplier to use to scale the x displacement result from the map calculation.
scaleY:Number (default = 0.0) — The multiplier to use to scale the y displacement result from the map calculation.
mode:String (default = "wrap") — The mode of the filter. Possible values are the DisplacementMapFilterMode constants.
color:uint (default = 0) — Specifies the color to use for out-of-bounds displacements. The valid range of displacements is 0.0 to 1.0. Use this parameter if mode is set to DisplacementMapFilterMode.COLOR.
alpha:Number (default = 0.0) — Specifies what alpha value to use for out-of-bounds displacements. It is specified as a normalized value from 0.0 to 1.0. For example, .25 sets a transparency value of 25%. The default is 1.0. Use this parameter if mode is set to DisplacementMapFilterMode.COLOR.

See also

flash.display.BitmapDataChannel
flash.filters.DisplacementMapFilterMode
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new DisplacementMapFilter instance with all the same properties as the original one.
Examples

The following example draws a square with a radial gradient fill, creates a text field, creates a BitmapData object, and applies a displacement map filter to the DisplacementMapFilterExample object. The general workflow for this example is as follows:
  1. The class defines variables for the background color, for the text field label, and for the size and offset that will be used in various functions.
  2. The constructor function calls the draw() method, which uses the methods of the Graphics class to draw a square with a radial gradient fill. Note that graphics is a property of the DisplacementMapFilterExample object, which extends Sprite.
  3. The constructor function calls the createLabel() method, which creates a text field displaying the value of labelText and adds it to the display list.
  4. The constructor function calls the createFilter() method, which does the following:
    • Creates a variable named filter for the filter object.
    • Calls the getDisplacementMapFilter() method and assigns its return value to the filter variable.
    • Passes filter to the filters property of the DisplacementFilterExample object (the main class).
  5. The getBitmapFilter() method creates a BitmapData object named mapBitmap and assigns it the results of the createBitmapData() method. The mapBitmap object, along with other variables, defines a new displacement map filter.
  6. The createBitmapData() method creates a new BitmapData object that is based on the current contents of the DisplacementMapFilterExample object. It creates a new bitmap based on bitmapData and adds the bitmap to the Stage.
package {
    import flash.display.Bitmap;
    import flash.display.BitmapData;
    import flash.display.BitmapDataChannel;
    import flash.display.GradientType;
    import flash.display.SpreadMethod;
    import flash.display.Sprite;
    import flash.filters.BitmapFilter;
    import flash.filters.DisplacementMapFilter;
    import flash.filters.DisplacementMapFilterMode;
    import flash.geom.Matrix;
    import flash.geom.Point;
    import flash.text.TextField;

    public class DisplacementMapFilterExample extends Sprite {
        private var bgColor:uint     = 0xFFCC00;
        private var size:uint        = 200;
        private var offset:uint      = 90;
        private var labelText:String = "Watch the text bend with the displacement map";

        public function DisplacementMapFilterExample() {
            draw();
            createLabel();
            createFilter();
        }

        private function createFilter():void {
            var filter:BitmapFilter = getBitmapFilter();
            filters = new Array(filter);
        }

        private function getBitmapFilter():BitmapFilter {
            var mapBitmap:BitmapData = createBitmapData();
            var mapPoint:Point       = new Point(0, 0);
            var channels:uint        = BitmapDataChannel.RED;
            var componentX:uint      = channels;
            var componentY:uint      = channels;
            var scaleX:Number        = 0.5;
            var scaleY:Number        = -30;
            var mode:String          = DisplacementMapFilterMode.CLAMP;
            var color:uint           = 0;
            var alpha:Number         = 0;
            return new DisplacementMapFilter(mapBitmap,
                                             mapPoint,
                                             componentX,
                                             componentY,
                                             scaleX,
                                             scaleY,
                                             mode,
                                             color,
                                             alpha);
        }

        private function draw():void {
            var matrix:Matrix = new Matrix();
            matrix.createGradientBox(size, size);
            graphics.beginGradientFill(GradientType.RADIAL,
                                       [0xFF0000, 0x0000FF],
                                       [100, 100],
                                       [55, 200],
                                       matrix,
                                       SpreadMethod.PAD);
            graphics.drawRect(0, 0, size, size);
        }

        private function createBitmapData():BitmapData {
            var bitmapData:BitmapData = new BitmapData(size, size, true, bgColor);
            bitmapData.draw(this, new Matrix());
            var bitmap:Bitmap = new Bitmap(bitmapData);
            bitmap.x = size;
            addChild(bitmap);
            return bitmapData;
        }

        private function createLabel():void {
            var tf:TextField = new TextField();
            tf.text = labelText;
            tf.y = offset;
            tf.width = size;
            addChild(tf);
        }
    }
}


flash.filters.DisplacementMapFilterMode (Flex™ 2 Language Reference)

Class DisplacementMapFilterMode | Properties | Methods | Constants
Package | flash.filters
Class | public final class DisplacementMapFilterMode
Inheritance | DisplacementMapFilterMode Inheritance Object

The DisplacementMapFilterMode class provides values for the mode property of the DisplacementMapFilter class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CLAMP : String = "clamp" [static] Clamps the displacement value to the edge of the source image. | DisplacementMapFilterMode
 | COLOR : String = "color" [static] If the displacement value is outside the image, substitutes the values in the color and alpha properties. | DisplacementMapFilterMode
 | IGNORE : String = "ignore" [static] If the displacement value is out of range, ignores the displacement and uses the source pixel. | DisplacementMapFilterMode
 | WRAP : String = "wrap" [static] Wraps the displacement value to the other side of the source image. | DisplacementMapFilterMode
Constant detail
CLAMP constant
public static const CLAMP:String = "clamp"

Clamps the displacement value to the edge of the source image. Use with the DisplacementMapFilter.mode property.

See also

flash.filters.DisplacementMapFilter.mode
COLOR constant
public static const COLOR:String = "color"

If the displacement value is outside the image, substitutes the values in the color and alpha properties. Use with the DisplacementMapFilter.mode property.

See also

flash.filters.DisplacementMapFilter.mode
IGNORE constant
public static const IGNORE:String = "ignore"

If the displacement value is out of range, ignores the displacement and uses the source pixel. Use with the DisplacementMapFilter.mode property.

See also

flash.filters.DisplacementMapFilter.mode
WRAP constant
public static const WRAP:String = "wrap"

Wraps the displacement value to the other side of the source image. Use with the DisplacementMapFilter.mode property.

See also

flash.filters.DisplacementMapFilter.mode


flash.filters.DropShadowFilter (Flex™ 2 Language Reference)

Class DropShadowFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class DropShadowFilter
Inheritance | DropShadowFilter Inheritance BitmapFilter Inheritance Object

The DropShadowFilter class lets you add a drop shadow to display objects. The shadow algorithm is based on the same box filter that the blur filter uses. You have several options for the style of the drop shadow, including inner or outer shadow and knockout mode. You can apply the filter to any display object (that is, objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

The use of filters depends on the object to which you apply the filter:

  • To apply filters to display objects use the filters property (inherited from DisplayObject). Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the value of the cacheAsBitmap property of the display object is set to true. If you clear all filters, the original value of cacheAsBitmap is restored.

This filter supports Stage scaling. However, it does not support general scaling, rotation, and skewing. If the object itself is scaled (if scaleX and scaleY are set to a value other than 1.0), the filter is not scaled. It is scaled only when the user zooms in on the Stage.

A filter is not applied if the resulting image exceeds 2880 pixels in width or height. If, for example, you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image exceeds the limit of 2880 pixels.

View the examples.

See also

flash.display.BitmapData.applyFilter()
flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number The alpha transparency value for the shadow color. | DropShadowFilter
 | angle : Number The angle of the shadow. | DropShadowFilter
 | blurX : Number The amount of horizontal blur. | DropShadowFilter
 | blurY : Number The amount of vertical blur. | DropShadowFilter
 | color : uint The color of the shadow. | DropShadowFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | distance : Number The offset distance for the shadow, in pixels. | DropShadowFilter
 | hideObject : Boolean Indicates whether or not the object is hidden. | DropShadowFilter
 | inner : Boolean Indicates whether or not the shadow is an inner shadow. | DropShadowFilter
 | knockout : Boolean Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document. | DropShadowFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : int The number of times to apply the filter. | DropShadowFilter
 | strength : Number The strength of the imprint or spread. | DropShadowFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DropShadowFilter(distance:Number = 4.0, angle:Number = 45, color:uint = 0, alpha:Number = 1.0, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1.0, quality:int = 1, inner:Boolean = false, knockout:Boolean = false, hideObject:Boolean = false) Creates a new DropShadowFilter instance with the specified parameters. | DropShadowFilter
 | clone():BitmapFilter Returns a copy of this filter object. | DropShadowFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
alpha:Number [read-write]

The alpha transparency value for the shadow color. Valid values are 0.0 to 1.0. For example, .25 sets a transparency value of 25%. The default value is 1.0.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
angle property
angle:Number [read-write]

The angle of the shadow. Valid values are 0 to 360 degrees (floating point). The default value is 45.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void
blurX property
blurX:Number [read-write]

The amount of horizontal blur. Valid values are 0 to 255.0 (floating point). The default value is 4.0.

Implementation
    public function get blurX():Number
    public function set blurX(value:Number):void
blurY property
blurY:Number [read-write]

The amount of vertical blur. Valid values are 0 to 255.0 (floating point). The default value is 4.0.

Implementation
    public function get blurY():Number
    public function set blurY(value:Number):void
color property
color:uint [read-write]

The color of the shadow. Valid values are in hexadecimal format 0xRRGGBB. The default value is 0x000000.

Implementation
    public function get color():uint
    public function set color(value:uint):void
distance property
distance:Number [read-write]

The offset distance for the shadow, in pixels. The default value is 4.0 (floating point).

Implementation
    public function get distance():Number
    public function set distance(value:Number):void
hideObject property
hideObject:Boolean [read-write]

Indicates whether or not the object is hidden. The value true indicates that the object itself is not drawn; only the shadow is visible. The default is false (the object is shown).

Implementation
    public function get hideObject():Boolean
    public function set hideObject(value:Boolean):void
inner property
inner:Boolean [read-write]

Indicates whether or not the shadow is an inner shadow. The value true indicates an inner shadow. The default is false, an outer shadow (a shadow around the outer edges of the object).

Implementation
    public function get inner():Boolean
    public function set inner(value:Boolean):void
knockout property
knockout:Boolean [read-write]

Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document. The default is false (no knockout).

Implementation
    public function get knockout():Boolean
    public function set knockout(value:Boolean):void
quality property
quality:int [read-write]

The number of times to apply the filter. The default value is BitmapFilterQuality.LOW, which is equivalent to applying the filter once. The value BitmapFilterQuality.MEDIUM applies the filter twice; the value BitmapFilterQuality.HIGH applies it three times. Filters with lower values are rendered more quickly.

For most applications, a quality value of low, medium, or high is sufficient. Although you can use additional numeric values up to 15 to achieve different effects, higher values are rendered more slowly. Instead of increasing the value of quality, you can often get a similar effect, and with faster rendering, by simply increasing the values of the blurX and blurY properties.

Implementation
    public function get quality():int
    public function set quality(value:int):void

See also

flash.filters.BitmapFilterQuality
strength property
strength:Number [read-write]

The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the shadow and the background. Valid values are from 0 to 255.0. The default is 1.0.

Implementation
    public function get strength():Number
    public function set strength(value:Number):void
Constructor detail
DropShadowFilter () constructor
public function DropShadowFilter(distance:Number = 4.0, angle:Number = 45, color:uint = 0, alpha:Number = 1.0, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1.0, quality:int = 1, inner:Boolean = false, knockout:Boolean = false, hideObject:Boolean = false)

Creates a new DropShadowFilter instance with the specified parameters.

Parameters
distance:Number (default = 4.0) — Offset distance for the shadow, in pixels.
angle:Number (default = 45) — Angle of the shadow, 0 to 360 degrees (floating point).
color:uint (default = 0) — Color of the shadow, in hexadecimal format 0xRRGGBB. The default value is 0x000000.
alpha:Number (default = 1.0) — Alpha transparency value for the shadow color. Valid values are 0.0 to 1.0. For example, .25 sets a transparency value of 25%.
blurX:Number (default = 4.0) — Amount of horizontal blur. Valid values are 0 to 255.0 (floating point).
blurY:Number (default = 4.0) — Amount of vertical blur. Valid values are 0 to 255.0 (floating point).
strength:Number (default = 1.0) — The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the shadow and the background. Valid values are 0 to 255.0.
quality:int (default = 1) — The number of times to apply the filter. Use the BitmapFilterQuality constants:
  • BitmapFilterQuality.LOW
  • BitmapFilterQuality.MEDIUM
  • BitmapFilterQuality.HIGH

For more information about these values, see the quality property description.
inner:Boolean (default = false) — Indicates whether or not the shadow is an inner shadow. A value of true specifies an inner shadow. A value of false specifies an outer shadow (a shadow around the outer edges of the object).
knockout:Boolean (default = false) — Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document.
hideObject:Boolean (default = false) — Indicates whether or not the object is hidden. A value of true indicates that the object itself is not drawn; only the shadow is visible.

See also

flash.filters.BitmapFilterQuality
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new DropShadowFilter instance with all the properties of the original DropShadowFilter instance.
Examples

The following example creates a yellow square and applies a drop shadow to it. The general workflow of this example is as follows:
  1. Declare three properties that are used to draw the square to which the filter is applied.
  2. Create the constructor function. The constructor calls the draw() method, which uses methods of the Graphics class accessed through the graphics property of Sprite to draw an orange square.
  3. In the constructor, declare a variable filter as a BitmapFilter object and assign it to the return value of a call to getBitmapFilter(). The getBitmapFilter() method defines the drop shadow filter used.
  4. Create a new Array object myFilters and add filter to the array. Assign the myFilters array to the filters property of the DropShadowFilterExample object. This applies all filters found in myFilters, which in this case is only filter.

package {
    import flash.display.Sprite;
    import flash.events.Event;
    import flash.events.MouseEvent;
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.DropShadowFilter;

    public class DropShadowFilterExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint    = 80;
        private var offset:uint  = 50;

        public function DropShadowFilterExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            var color:Number = 0x000000;
            var angle:Number = 45;
            var alpha:Number = 0.8;
            var blurX:Number = 8;
            var blurY:Number = 8;
            var distance:Number = 15;
            var strength:Number = 0.65;
            var inner:Boolean = false;
            var knockout:Boolean = false;
            var quality:Number = BitmapFilterQuality.HIGH;
            return new DropShadowFilter(distance,
                                        angle,
                                        color,
                                        alpha,
                                        blurX,
                                        blurY,
                                        strength,
                                        quality,
                                        inner,
                                        knockout);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.filters.GlowFilter (Flex™ 2 Language Reference)

Class GlowFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class GlowFilter
Inheritance | GlowFilter Inheritance BitmapFilter Inheritance Object

The GlowFilter class lets you apply a glow effect to display objects. You have several options for the style of the glow, including inner or outer glow and knockout mode. The glow filter is similar to the drop shadow filter with the distance and angle properties of the drop shadow filter set to 0. You can apply the filter to any display object (that is, objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

The use of filters depends on the object to which you apply the filter:

  • To apply filters to display objects, use the filters property (inherited from DisplayObject). Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the cacheAsBitmap property of the display object is set to true. If you clear all filters, the original value of cacheAsBitmap is restored.

This filter supports Stage scaling. However, it does not support general scaling, rotation, and skewing. If the object itself is scaled (if scaleX and scaleY are set to a value other than 1.0), the filter is not scaled. It is scaled only when the user zooms in on the Stage.

A filter is not applied if the resulting image exceeds 2880 pixels in width or height. For example, if you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image exceeds the limit of 2880 pixels.

View the examples.

See also

flash.display.BitmapData.applyFilter()
flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
flash.display.DisplayObject.scaleX
flash.display.DisplayObject.scaleY
flash.filters.DropShadowFilter.distance
flash.filters.DropShadowFilter.angle
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number The alpha transparency value for the color. | GlowFilter
 | blurX : Number The amount of horizontal blur. | GlowFilter
 | blurY : Number The amount of vertical blur. | GlowFilter
 | color : uint The color of the glow. | GlowFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | inner : Boolean Specifies whether the glow is an inner glow. | GlowFilter
 | knockout : Boolean Specifies whether the object has a knockout effect. | GlowFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : int The number of times to apply the filter. | GlowFilter
 | strength : Number The strength of the imprint or spread. | GlowFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | GlowFilter(color:uint = 0xFF0000, alpha:Number = 1.0, blurX:Number = 6.0, blurY:Number = 6.0, strength:Number = 2, quality:int = 1, inner:Boolean = false, knockout:Boolean = false) Initializes a new GlowFilter instance with the specified parameters. | GlowFilter
 | clone():BitmapFilter Returns a copy of this filter object. | GlowFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
alpha:Number [read-write]

The alpha transparency value for the color. Valid values are 0 to 1. For example, .25 sets a transparency value of 25%. The default value is 1.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
blurX property
blurX:Number [read-write]

The amount of horizontal blur. Valid values are 0 to 255 (floating point). The default value is 6. Values that are a power of 2 (such as 2, 4, 8, 16, and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurX():Number
    public function set blurX(value:Number):void
blurY property
blurY:Number [read-write]

The amount of vertical blur. Valid values are 0 to 255 (floating point). The default value is 6. Values that are a power of 2 (such as 2, 4, 8, 16, and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurY():Number
    public function set blurY(value:Number):void
color property
color:uint [read-write]

The color of the glow. Valid values are in the hexadecimal format 0xRRGGBB. The default value is 0xFF0000.

Implementation
    public function get color():uint
    public function set color(value:uint):void
inner property
inner:Boolean [read-write]

Specifies whether the glow is an inner glow. The value true indicates an inner glow. The default is false, an outer glow (a glow around the outer edges of the object).

Implementation
    public function get inner():Boolean
    public function set inner(value:Boolean):void
knockout property
knockout:Boolean [read-write]

Specifies whether the object has a knockout effect. A value of true makes the object's fill transparent and reveals the background color of the document. The default value is false (no knockout effect).

Implementation
    public function get knockout():Boolean
    public function set knockout(value:Boolean):void
quality property
quality:int [read-write]

The number of times to apply the filter. The default value is BitmapFilterQuality.LOW, which is equivalent to applying the filter once. The value BitmapFilterQuality.MEDIUM applies the filter twice; the value BitmapFilterQuality.HIGH applies it three times. Filters with lower values are rendered more quickly.

For most applications, a quality value of low, medium, or high is sufficient. Although you can use additional numeric values up to 15 to achieve different effects, higher values are rendered more slowly. Instead of increasing the value of quality, you can often get a similar effect, and with faster rendering, by simply increasing the values of the blurX and blurY properties.

Implementation
    public function get quality():int
    public function set quality(value:int):void

See also

flash.filters.BitmapFilterQuality
strength property
strength:Number [read-write]

The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the glow and the background. Valid values are 0 to 255. The default is 2.

Implementation
    public function get strength():Number
    public function set strength(value:Number):void
Constructor detail
GlowFilter () constructor
public function GlowFilter(color:uint = 0xFF0000, alpha:Number = 1.0, blurX:Number = 6.0, blurY:Number = 6.0, strength:Number = 2, quality:int = 1, inner:Boolean = false, knockout:Boolean = false)

Initializes a new GlowFilter instance with the specified parameters.

Parameters
color:uint (default = 0xFF0000) — The color of the glow, in the hexadecimal format 0xRRGGBB. The default value is 0xFF0000.
alpha:Number (default = 1.0) — The alpha transparency value for the color. Valid values are 0 to 1. For example, .25 sets a transparency value of 25%.
blurX:Number (default = 6.0) — The amount of horizontal blur. Valid values are 0 to 255 (floating point). Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.
blurY:Number (default = 6.0) — The amount of vertical blur. Valid values are 0 to 255 (floating point). Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.
strength:Number (default = 2) — The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the glow and the background. Valid values are 0 to 255.
quality:int (default = 1) — The number of times to apply the filter. Use the BitmapFilterQuality constants:
  • BitmapFilterQuality.LOW
  • BitmapFilterQuality.MEDIUM
  • BitmapFilterQuality.HIGH

For more information, see the description of the quality property.
inner:Boolean (default = false) — Specifies whether the glow is an inner glow. The value true specifies an inner glow. The value false specifies an outer glow (a glow around the outer edges of the object).
knockout:Boolean (default = false) — Specifies whether the object has a knockout effect. The value true makes the object's fill transparent and reveals the background color of the document.

See also

BitmapFilterQuality
GlowFilter.quality
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new GlowFilter instance with all the properties of the original GlowFilter instance.
Examples

The following example draws a square and applies a blur filter to it. The general workflow of the example is as follows:
  1. Import the required classes.
  2. Declare three properties used in the draw method, which uses methods of the Graphics class accessed through the graphics property of Sprite to draw an orange square.
  3. Create the constructor function, which does the following:
    • Calls the draw method.
    • Creates a new BitmapFilter object named filter and assigns it the return value of a call to getBitmapFilter(), which defines the filter.
    • Creates a new array named myFilters and adds filter to it.
    • Assigns myFilters to the filters property of the BevelFilterExample object. This applies all filters found in myFilters, which in this case is only filter.

package {
    import flash.display.Sprite;
    import flash.events.Event;
    import flash.events.MouseEvent;
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.GlowFilter;

    public class GlowFilterExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint    = 80;
        private var offset:uint  = 50;

        public function GlowFilterExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            var color:Number = 0x33CCFF;
            var alpha:Number = 0.8;
            var blurX:Number = 35;
            var blurY:Number = 35;
            var strength:Number = 2;
            var inner:Boolean = false;
            var knockout:Boolean = false;
            var quality:Number = BitmapFilterQuality.HIGH;

            return new GlowFilter(color,
                                  alpha,
                                  blurX,
                                  blurY,
                                  strength,
                                  quality,
                                  inner,
                                  knockout);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.filters.GradientBevelFilter (Flex™ 2 Language Reference)

Class GradientBevelFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class GradientBevelFilter
Inheritance | GradientBevelFilter Inheritance BitmapFilter Inheritance Object

The GradientBevelFilter class lets you apply a gradient bevel effect to display objects. A gradient bevel is a beveled edge, enhanced with gradient color, on the outside, inside, or top of an object. Beveled edges make objects look three-dimensional. You can apply the filter to any display object (that is, objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

The use of filters depends on the object to which you apply the filter:

  • To apply filters to display objects, use the filters property. Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the cacheAsBitmap property of the display object is set to true. If you clear all filters, the original value of cacheAsBitmap is restored.

This filter supports Stage scaling. However, it does not support general scaling, rotation, and skewing; if the object itself is scaled (if scaleX and scaleY are set to a value other than 1.0), the filter effect is not scaled. It is scaled only when the user zooms in on the Stage.

A filter is not applied if the resulting image exceeds 2880 pixels in width or height. For example, if you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image exceeds the limit of 2880 pixels.

View the examples.

See also

GradientBevelFilter.ratios
flash.display.BitmapData.applyFilter()
BevelFilter
flash.display.DisplayObject.filters
flash.display.DisplayObject.cacheAsBitmap
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphas : Array An array of alpha transparency values for the corresponding colors in the colors array. | GradientBevelFilter
 | angle : Number The angle, in degrees. | GradientBevelFilter
 | blurX : Number The amount of horizontal blur. | GradientBevelFilter
 | blurY : Number The amount of vertical blur. | GradientBevelFilter
 | colors : Array An array of RGB hexadecimal color values to use in the gradient. | GradientBevelFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | distance : Number The offset distance. | GradientBevelFilter
 | knockout : Boolean Specifies whether the object has a knockout effect. | GradientBevelFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : int The number of times to apply the filter. | GradientBevelFilter
 | ratios : Array An array of color distribution ratios for the corresponding colors in the colors array. | GradientBevelFilter
 | strength : Number The strength of the imprint or spread. | GradientBevelFilter
 | type : String The placement of the bevel effect. | GradientBevelFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | GradientBevelFilter(distance:Number = 4.0, angle:Number = 45, colors:Array = null, alphas:Array = null, ratios:Array = null, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1, quality:int = 1, type:String = "inner", knockout:Boolean = false) Initializes the filter with the specified parameters. | GradientBevelFilter
 | clone():BitmapFilter Returns a copy of this filter object. | GradientBevelFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alphas property
alphas:Array [read-write]

An array of alpha transparency values for the corresponding colors in the colors array. Valid values for each element in the array are 0 to 1. For example, .25 sets a transparency value of 25%.

The alphas property cannot be changed by directly modifying its values. Instead, you must get a reference to alphas, make the change to the reference, and then set alphas to the reference.

The colors, alphas, and ratios properties are related. The first element in the colors array corresponds to the first element in the alphas array and in the ratios array, and so on.

Implementation
    public function get alphas():Array
    public function set alphas(value:Array):void

Throws
TypeError — The Array is null when being set

See also

GradientBevelFilter.colors
GradientBevelFilter.ratios
angle property
angle:Number [read-write]

The angle, in degrees. Valid values are 0 to 360. The default is 45.

The angle value represents the angle of the theoretical light source falling on the object. The value determines the angle at which the gradient colors are applied to the object: where the highlight and the shadow appear, or where the first color in the array appears. The colors are then applied in the order in which they appear in the array.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void

See also

GradientBevelFilter.ratios
blurX property
blurX:Number [read-write]

The amount of horizontal blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurX():Number
    public function set blurX(value:Number):void
blurY property
blurY:Number [read-write]

The amount of vertical blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurY():Number
    public function set blurY(value:Number):void
colors property
colors:Array [read-write]

An array of RGB hexadecimal color values to use in the gradient. For example, red is 0xFF0000, blue is 0x0000FF, and so on.

The colors property cannot be changed by directly modifying its values. Instead, you must get a reference to colors, make the change to the reference, and then set colors to the reference.

The colors, alphas, and ratios properties are related. The first element in the colors array corresponds to the first element in the alphas array and in the ratios array, and so on.

Implementation
    public function get colors():Array
    public function set colors(value:Array):void

Throws
TypeError — The Array is null when being set

See also

GradientBevelFilter.alphas
GradientBevelFilter.ratios
distance property
distance:Number [read-write]

The offset distance. Valid values are 0 to 8. The default value is 4.0.

Implementation
    public function get distance():Number
    public function set distance(value:Number):void
knockout property
knockout:Boolean [read-write]

Specifies whether the object has a knockout effect. A knockout effect makes the object's fill transparent and reveals the background color of the document. The value true specifies a knockout effect; the default is false (no knockout effect).

Implementation
    public function get knockout():Boolean
    public function set knockout(value:Boolean):void
quality property
quality:int [read-write]

The number of times to apply the filter. The default value is BitmapFilterQuality.LOW, which is equivalent to applying the filter once. The value BitmapFilterQuality.MEDIUM applies the filter twice; the value BitmapFilterQuality.HIGH applies it three times. Filters with lower values are rendered more quickly.

For most applications, a quality value of low, medium, or high is sufficient. Although you can use additional numeric values up to 15 to achieve different effects, higher values are rendered more slowly. Instead of increasing the value of quality, you can often get a similar effect, and with faster rendering, by simply increasing the values of the blurX and blurY properties.

Implementation
    public function get quality():int
    public function set quality(value:int):void

See also

BitmapFilterQuality
GradientBevelFilter.ratios
ratios property
ratios:Array [read-write]

An array of color distribution ratios for the corresponding colors in the colors array. Valid values for each element in the array are 0 to 255.

The ratios property cannot be changed by directly modifying its values. Instead, you must get a reference to ratios, make the change to the reference, and then set ratios to the reference.

The colors, alphas, and ratios properties are related. The first element in the colors array corresponds to the first element in the alphas array and in the ratios array, and so on.

To understand how the colors in a gradient bevel are distributed, think first of the colors that you want in your gradient bevel. Consider that a simple bevel has a highlight color and shadow color; a gradient bevel has a highlight gradient and a shadow gradient. Assume that the highlight appears on the top-left corner, and the shadow appears on the bottom-right corner. Assume that one possible usage of the filter has four colors in the highlight and four in the shadow. In addition to the highlight and shadow, the filter uses a base fill color that appears where the edges of the highlight and shadow meet. Therefore the total number of colors is nine, and the corresponding number of elements in the ratios array is nine.

If you think of a gradient as composed of stripes of various colors, blending into each other, each ratio value sets the position of the color on the radius of the gradient, where 0 represents the outermost point of the gradient and 255 represents the innermost point of the gradient. For a typical usage, the middle value is 128, and that is the base fill value. To get the bevel effect shown in the image below, assign the ratio values as follows, using the example of nine colors:

  • The first four colors range from 0-127, increasing in value so that each value is greater than or equal to the previous one. This is the highlight bevel edge.
  • The fifth color (the middle color) is the base fill, set to 128. The pixel value of 128 sets the base fill, which appears either outside the shape (and around the bevel edges) if the type is set to outer; or inside the shape, effectively covering the object's own fill, if the type is set to inner.
  • The last four colors range from 129-255, increasing in value so that each value is greater than or equal to the previous one. This is the shadow bevel edge.

If you want an equal distribution of colors for each edge, use an odd number of colors, where the middle color is the base fill. Distribute the values between 0-127 and 129-255 equally among your colors, then adjust the value to change the width of each stripe of color in the gradient. For a gradient bevel with nine colors, a possible array is [16, 32, 64, 96, 128, 160, 192, 224, 235]. The following image depicts the gradient bevel as described:

Keep in mind that the spread of the colors in the gradient varies based on the values of the blurX, blurY, strength, and quality properties, as well as the ratios values.

Implementation
    public function get ratios():Array
    public function set ratios(value:Array):void

Throws
TypeError — The Array is null when being set

See also

GradientBevelFilter.alphas
GradientBevelFilter.colors
flash.display.Graphics.beginGradientFill()
strength property
strength:Number [read-write]

The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the bevel and the background. Valid values are 0 to 255. A value of 0 means that the filter is not applied. The default value is 1.

Implementation
    public function get strength():Number
    public function set strength(value:Number):void

See also

GradientBevelFilter.ratios
type property
type:String [read-write]

The placement of the bevel effect. Possible values are BitmapFilterType constants:

  • BitmapFilterType.OUTER — Bevel on the outer edge of the object
  • BitmapFilterType.INNER — Bevel on the inner edge of the object
  • BitmapFilterType.FULL — Bevel on top of the object

Implementation
    public function get type():String
    public function set type(value:String):void
Constructor detail
GradientBevelFilter () constructor
public function GradientBevelFilter(distance:Number = 4.0, angle:Number = 45, colors:Array = null, alphas:Array = null, ratios:Array = null, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1, quality:int = 1, type:String = "inner", knockout:Boolean = false)

Initializes the filter with the specified parameters.

Parameters
distance:Number (default = 4.0) — The offset distance. Valid values are 0 to 8.
angle:Number (default = 45) — The angle, in degrees. Valid values are 0 to 360.
colors:Array (default = null) — An array of RGB hexadecimal color values to use in the gradient. For example, red is 0xFF0000, blue is 0x0000FF, and so on.
alphas:Array (default = null) — An array of alpha transparency values for the corresponding colors in the colors array. Valid values for each element in the array are 0 to 1. For example, .25 sets a transparency value of 25%.
ratios:Array (default = null) — An array of color distribution ratios; valid values are 0 to 255.
blurX:Number (default = 4.0) — The amount of horizontal blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.
blurY:Number (default = 4.0) — The amount of vertical blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.
strength:Number (default = 1) — The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the bevel and the background. Valid values are 0 to 255. A value of 0 means that the filter is not applied.
quality:int (default = 1) — The quality of the filter. Use BitmapFilterQuality constants:
  • BitmapFilterQuality.LOW
  • BitmapFilterQuality.MEDIUM
  • BitmapFilterQuality.HIGH

For more information, see the description of the quality property.
type:String (default = "inner") — The placement of the bevel effect. Possible values are BitmapFilterType constants:
  • BitmapFilterType.OUTER — Bevel on the outer edge of the object
  • BitmapFilterType.INNER — Bevel on the inner edge of the object
  • BitmapFilterType.FULL — Bevel on top of the object
knockout:Boolean (default = false) — Specifies whether a knockout effect is applied. The value true makes the object's fill transparent and reveals the background color of the document.

See also

GradientBevelFilter.quality
GradientBevelFilter.ratios
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new GradientBevelFilter instance with all the same properties as the original GradientBevelFilter instance.
Examples

The following example draws a square and applies a gradient bevel filter to it. The general workflow of this example is as follows:
  1. Import the required classes.
  2. Declare global variables to define the square and the filter.
  3. Create the constructor functions, which does the following:
    • Calls the draw() method, which uses methods of the Graphics class accessed through the graphics property of Sprite to draw a gray square.
    • Creates a BitmapFilter object named filter and assigns it the return value of a call to getBitmapFilter(), which creates the filter.
    • Creates a new array named myFilters and adds filter to it.
    • Assigns myFilters to the filters property of the GradientBevelFilterExample object. This applies all filters found in myFilters, which in this case is only filter.

package {
    import flash.display.Sprite;
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.BitmapFilterType;
    import flash.filters.GradientBevelFilter;

    public class GradientBevelFilterExample extends Sprite {
        private var bgColor:uint     = 0xCCCCCC;
        private var size:uint        = 80;
        private var offset:uint      = 50;
        private var distance:Number  = 5;
        private var angleInDegrees:Number = 225; // opposite 45 degrees
        private var colors:Array     = [0xFFFFFF, 0xCCCCCC, 0x000000];
        private var alphas:Array     = [1, 0, 1];
        private var ratios:Array     = [0, 128, 255];
        private var blurX:Number     = 8;
        private var blurY:Number     = 8;
        private var strength:Number  = 2;
        private var quality:Number   = BitmapFilterQuality.HIGH
        private var type:String      = BitmapFilterType.INNER;
        private var knockout:Boolean = true;

        public function GradientBevelFilterExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            return new GradientBevelFilter(distance,
                                           angleInDegrees,
                                           colors,
                                           alphas,
                                           ratios,
                                           blurX,
                                           blurY,
                                           strength,
                                           quality,
                                           type,
                                           knockout);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.filters.GradientGlowFilter (Flex™ 2 Language Reference)

Class GradientGlowFilter | Properties | Methods | Examples
Package | flash.filters
Class | public final class GradientGlowFilter
Inheritance | GradientGlowFilter Inheritance BitmapFilter Inheritance Object

The GradientGlowFilter class lets you apply a gradient glow effect to display objects. A gradient glow is a realistic-looking glow with a color gradient that you can control. You can apply a gradient glow around the inner or outer edge of an object or on top of an object. You can apply the filter to any display object (objects that inherit from the DisplayObject class), such as MovieClip, SimpleButton, TextField, and Video objects, as well as to BitmapData objects.

The use of filters depends on the object to which you apply the filter:

  • To apply filters to display objects, use the filters property. Setting the filters property of an object does not modify the object, and you can remove the filter by clearing the filters property.
  • To apply filters to BitmapData objects, use the BitmapData.applyFilter() method. Calling applyFilter() on a BitmapData object takes the source BitmapData object and the filter object and generates a filtered image as a result.

If you apply a filter to a display object, the cacheAsBitmap property of the display object is set to true. If you clear all filters, the original value of cacheAsBitmap is restored.

This filter supports Stage scaling. However, it does not support general scaling, rotation, and skewing; if the object itself is scaled (if scaleX and scaleY are set to a value other than 1.0), the filter effect is not scaled. It is scaled only when the user zooms in on the Stage.

A filter is not applied if the resulting image exceeds 2880 pixels in width or height. For example, if you zoom in on a large movie clip with a filter applied, the filter is turned off if the resulting image exceeds the limit of 2880 pixels.

View the examples.

See also

GradientGlowFilter.ratios
flash.display.BitmapData.applyFilter()
flash.display.DisplayObject.cacheAsBitmap
flash.display.DisplayObject.filters
GlowFilter class
Using filters in Flex

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphas : Array An array of alpha transparency values for the corresponding colors in the colors array. | GradientGlowFilter
 | angle : Number The angle, in degrees. | GradientGlowFilter
 | blurX : Number The amount of horizontal blur. | GradientGlowFilter
 | blurY : Number The amount of vertical blur. | GradientGlowFilter
 | colors : Array An array of colors that defines a gradient. | GradientGlowFilter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | distance : Number The offset distance of the glow. | GradientGlowFilter
 | knockout : Boolean Specifies whether the object has a knockout effect. | GradientGlowFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : int The number of times to apply the filter. | GradientGlowFilter
 | ratios : Array An array of color distribution ratios for the corresponding colors in the colors array. | GradientGlowFilter
 | strength : Number The strength of the imprint or spread. | GradientGlowFilter
 | type : String The placement of the filter effect. | GradientGlowFilter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | GradientGlowFilter(distance:Number = 4.0, angle:Number = 45, colors:Array = null, alphas:Array = null, ratios:Array = null, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1, quality:int = 1, type:String = "inner", knockout:Boolean = false) Initializes the filter with the specified parameters. | GradientGlowFilter
 | clone():BitmapFilter Returns a copy of this filter object. | GradientGlowFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alphas property
alphas:Array [read-write]

An array of alpha transparency values for the corresponding colors in the colors array. Valid values for each element in the array are 0 to 1. For example, .25 sets the alpha transparency value to 25%.

The alphas property cannot be changed by directly modifying its values. Instead, you must get a reference to alphas, make the change to the reference, and then set alphas to the reference.

The colors, alphas, and ratios properties are related. The first element in the colors array corresponds to the first element in the alphas array and in the ratios array, and so on.

Implementation
    public function get alphas():Array
    public function set alphas(value:Array):void

Throws
TypeError — The Array is null when being set

See also

GradientGlowFilter.colors
GradientGlowFilter.ratios
angle property
angle:Number [read-write]

The angle, in degrees. Valid values are 0 to 360. The default is 45.

The angle value represents the angle of the theoretical light source falling on the object and determines the placement of the effect relative to the object. If distance is set to 0, the effect is not offset from the object, and therefore the angle property has no effect.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void
blurX property
blurX:Number [read-write]

The amount of horizontal blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16, and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurX():Number
    public function set blurX(value:Number):void
blurY property
blurY:Number [read-write]

The amount of vertical blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. The default value is 4. Values that are a power of 2 (such as 2, 4, 8, 16, and 32) are optimized to render more quickly than other values.

Implementation
    public function get blurY():Number
    public function set blurY(value:Number):void
colors property
colors:Array [read-write]

An array of colors that defines a gradient. For example, red is 0xFF0000, blue is 0x0000FF, and so on.

The colors property cannot be changed by directly modifying its values. Instead, you must get a reference to colors, make the change to the reference, and then set colors to the reference.

The colors, alphas, and ratios properties are related. The first element in the colors array corresponds to the first element in the alphas array and in the ratios array, and so on.

Implementation
    public function get colors():Array
    public function set colors(value:Array):void

Throws
TypeError — The Array is null when being set

See also

GradientGlowFilter.alphas
GradientGlowFilter.ratios
distance property
distance:Number [read-write]

The offset distance of the glow. The default value is 4.

Implementation
    public function get distance():Number
    public function set distance(value:Number):void
knockout property
knockout:Boolean [read-write]

Specifies whether the object has a knockout effect. A knockout effect makes the object's fill transparent and reveals the background color of the document. The value true specifies a knockout effect; the default value is false (no knockout effect).

Implementation
    public function get knockout():Boolean
    public function set knockout(value:Boolean):void
quality property
quality:int [read-write]

The number of times to apply the filter. The default value is BitmapFilterQuality.LOW, which is equivalent to applying the filter once. The value BitmapFilterQuality.MEDIUM applies the filter twice; the value BitmapFilterQuality.HIGH applies it three times. Filters with lower values are rendered more quickly.

For most applications, a quality value of low, medium, or high is sufficient. Although you can use additional numeric values up to 15 to achieve different effects, higher values are rendered more slowly. Instead of increasing the value of quality, you can often get a similar effect, and with faster rendering, by simply increasing the values of the blurX and blurY properties.

Implementation
    public function get quality():int
    public function set quality(value:int):void

See also

flash.filters.BitmapFilterQuality
ratios property
ratios:Array [read-write]

An array of color distribution ratios for the corresponding colors in the colors array. Valid values are 0 to 255.

The ratios property cannot be changed by directly modifying its values. Instead, you must get a reference to ratios, make the change to the reference, and then set ratios to the reference.

The colors, alphas, and ratios properties are related. The first element in the colors array corresponds to the first element in the alphas array and in the ratios array, and so on.

Think of the gradient glow filter as a glow that emanates from the center of the object (if the distance value is set to 0), with gradients that are stripes of color blending into each other. The first color in the colors array is the outermost color of the glow. The last color is the innermost color of the glow.

Each value in the ratios array sets the position of the color on the radius of the gradient, where 0 represents the outermost point of the gradient and 255 represents the innermost point of the gradient. The ratio values can range from 0 to 255 pixels, in increasing value; for example [0, 64, 128, 200, 255]. Values from 0 to 128 appear on the outer edges of the glow. Values from 129 to 255 appear in the inner area of the glow. Depending on the ratio values of the colors and the type value of the filter, the filter colors might be obscured by the object to which the filter is applied.

In the following code and image, a filter is applied to a black circle movie clip, with the type set to "full". For instructional purposes, the first color in the colors array, pink, has an alpha value of 1, so it shows against the white document background. (In practice, you probably would not want the first color showing in this way.) The last color in the array, yellow, obscures the black circle to which the filter is applied:

 var colors:Array = [0xFFCCFF, 0x0000FF, 0x9900FF, 0xFF0000, 0xFFFF00];
 var alphas:Array = [1, 1, 1, 1, 1];
 var ratios:Array = [0, 32, 64, 128, 225];
 var myGGF:GradientGlowFilter = new GradientGlowFilter(0, 0, colors, alphas, ratios, 50, 50, 1, 2, "full", false);

To achieve a seamless effect with your document background when you set the type value to "outer" or "full", set the first color in the array to the same color as the document background, or set the alpha value of the first color to 0; either technique makes the filter blend in with the background.

If you make two small changes in the code, the effect of the glow can be very different, even with the same ratios and colors arrays. Set the alpha value of the first color in the array to 0, to make the filter blend in with the document's white background; and set the type property to "outer" or "inner". Observe the results, as shown in the following images.

Keep in mind that the spread of the colors in the gradient varies based on the values of the blurX, blurY, strength, and quality properties, as well as the ratios values.

Implementation
    public function get ratios():Array
    public function set ratios(value:Array):void

Throws
TypeError — The Array is null when being set

See also

GradientGlowFilter.colors
GradientGlowFilter.alphas
flash.display.Graphics.beginGradientFill()
strength property
strength:Number [read-write]

The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the glow and the background. Valid values are 0 to 255. A value of 0 means that the filter is not applied. The default value is 1.

Implementation
    public function get strength():Number
    public function set strength(value:Number):void
type property
type:String [read-write]

The placement of the filter effect. Possible values are flash.filters.BitmapFilterType constants:

  • BitmapFilterType.OUTER — Glow on the outer edge of the object
  • BitmapFilterType.INNER — Glow on the inner edge of the object; the default.
  • BitmapFilterType.FULL — Glow on top of the object

Implementation
    public function get type():String
    public function set type(value:String):void

Throws
TypeError — The string is null when being set
Constructor detail
GradientGlowFilter () constructor
public function GradientGlowFilter(distance:Number = 4.0, angle:Number = 45, colors:Array = null, alphas:Array = null, ratios:Array = null, blurX:Number = 4.0, blurY:Number = 4.0, strength:Number = 1, quality:int = 1, type:String = "inner", knockout:Boolean = false)

Initializes the filter with the specified parameters.

Parameters
distance:Number (default = 4.0) — The offset distance of the glow.
angle:Number (default = 45) — The angle, in degrees. Valid values are 0 to 360.
colors:Array (default = null) — An array of colors that defines a gradient. For example, red is 0xFF0000, blue is 0x0000FF, and so on.
alphas:Array (default = null) — An array of alpha transparency values for the corresponding colors in the colors array. Valid values for each element in the array are 0 to 1. For example, a value of .25 sets the alpha transparency value to 25%.
ratios:Array (default = null) — An array of color distribution ratios. Valid values are 0 to 255. This value defines the percentage of the width where the color is sampled at 100 percent.
blurX:Number (default = 4.0) — The amount of horizontal blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.
blurY:Number (default = 4.0) — The amount of vertical blur. Valid values are 0 to 255. A blur of 1 or less means that the original image is copied as is. Values that are a power of 2 (such as 2, 4, 8, 16 and 32) are optimized to render more quickly than other values.
strength:Number (default = 1) — The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the glow and the background. Valid values are 0 to 255. The larger the value, the stronger the imprint. A value of 0 means the filter is not applied.
quality:int (default = 1) — The number of times to apply the filter. Use the BitmapFilterQuality constants:
  • BitmapFilterQuality.LOW
  • BitmapFilterQuality.MEDIUM
  • BitmapFilterQuality.HIGH

For more information, see the description of the quality property.
type:String (default = "inner") — The placement of the filter effect. Possible values are the flash.filters.BitmapFilterType constants:
  • BitmapFilterType.OUTER — Glow on the outer edge of the object
  • BitmapFilterType.INNER — Glow on the inner edge of the object; the default.
  • BitmapFilterType.FULL — Glow on top of the object
knockout:Boolean (default = false) — Specifies whether the object has a knockout effect. A knockout effect makes the object's fill transparent and reveals the background color of the document. The value true specifies a knockout effect; the default is false (no knockout effect).
Method detail
clone () method
public override function clone():BitmapFilter

Returns a copy of this filter object.

Returns
BitmapFilter — A new GradientGlowFilter instance with all the same properties as the original GradientGlowFilter instance.
Examples

The following example draws a square and applies a gradient glow filter to it. The general workflow of the example is as follows:
  1. Import the required classes.
  2. Declare global variables used to define the square and filter.
  3. Create the constructor function, which does the following:
    • Calls the draw() method, which uses methods of the Graphics class accessed through the graphics property of Sprite to draw a square.
    • Creates a BitmapFilter object named filter and assigns it the return value of a call to getBitmapFilter(), which creates the filter.
    • Creates a new array named myFilters and adds filter to it.
    • Assigns myFilters to the filters property of the GradientGlowFilterExample object. This applies all filters found in myFilters, which in this case is only filter.
package {
    import flash.filters.BitmapFilter;
    import flash.filters.BitmapFilterQuality;
    import flash.filters.BitmapFilterType;
    import flash.filters.GradientGlowFilter;
    import flash.display.Sprite;

    public class GradientGlowFilterExample extends Sprite {
        private var bgColor:uint = 0xCCCCCC;
        private var size:uint    = 80;
        private var offset:uint  = 50;

        private var distance:Number  = 0;
        private var angleInDegrees:Number = 45;
        private var colors:Array     = [0xFFFFFF, 0xFF0000, 0xFFFF00, 0x00CCFF];
        private var alphas:Array     = [0, 1, 1, 1];
        private var ratios:Array     = [0, 63, 126, 255];
        private var blurX:Number     = 50;
        private var blurY:Number     = 50;
        private var strength:Number  = 2.5;
        private var quality:Number   = BitmapFilterQuality.HIGH;
        private var type:String      = BitmapFilterType.OUTER;
        private var knockout:Boolean = false;

        public function GradientGlowFilterExample() {
            draw();
            var filter:BitmapFilter = getBitmapFilter();
            var myFilters:Array = new Array();
            myFilters.push(filter);
            filters = myFilters;
        }

        private function getBitmapFilter():BitmapFilter {
            return new GradientGlowFilter(distance,
                                          angleInDegrees,
                                          colors,
                                          alphas,
                                          ratios,
                                          blurX,
                                          blurY,
                                          strength,
                                          quality,
                                          type,
                                          knockout);
        }

        private function draw():void {
            graphics.beginFill(bgColor);
            graphics.drawRect(offset, offset, size, size);
            graphics.endFill();
        }
    }
}


flash.geom Summary (Flex™ 2 Language Reference)

Package flash.geom | Classes

The flash.geom package contains geometry classes, such as points, rectangles and transformation matrixes, to support the BitmapData class and the bitmap caching feature.

Classes
Class | Description
ColorTransform | The ColorTransform class lets you adjust the color values in a display object.
Matrix | The Matrix class represents a transformation matrix that determines how to map points from one coordinate space to another.
Point | The Point object represents a location in a two-dimensional coordinate system, where x represents the horizontal axis and y represents the vertical axis.
Rectangle | A Rectangle object is an area defined by its position, as indicated by its top-left corner point (x, y) and by its width and its height.
Transform | The Transform class collects data about color transformations and coordinate transformations that are applied to a display object.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.geom.ColorTransform (Flex™ 2 Language Reference)

Class ColorTransform | Properties | Methods | Examples
Package | flash.geom
Class | public class ColorTransform
Inheritance | ColorTransform Inheritance Object

The ColorTransform class lets you adjust the color values in a display object. The color adjustment or color transformation can be applied to all four channels: red, green, blue, and alpha transparency.

When a ColorTransform object is applied to a display object, a new value for each color channel is calculated like this:

  • New red value = (old red value * redMultiplier) + redOffset
  • New green value = (old green value * greenMultiplier) + greenOffset
  • New blue value = (old blue value * blueMultiplier) + blueOffset
  • New alpha value = (old alpha value * alphaMultiplier) + alphaOffset

If any of the color channel values is greater than 255 after the calculation, it is set to 255. If it is less than 0, it is set to 0.

You can use ColorTransform objects in the following ways:

  • In the colorTransform parameter of the colorTransform() method of the BitmapData class
  • As the colorTransform property of a Transform object (which can be used as the transform property of a display object)

You must use the new ColorTransform() constructor to create a ColorTransform object before you can call the methods of the ColorTransform object.

Color transformations do not apply to the background color of a movie clip (such as a loaded SWF object). They apply only to graphics and symbols that are attached to the movie clip.

View the examples.

See also

flash.geom.Transform
flash.display.DisplayObject.transform
flash.display.BitmapData.colorTransform()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphaMultiplier : Number A decimal value that is multiplied with the alpha transparency channel value. | ColorTransform
 | alphaOffset : Number A number from -255 to 255 that is added to the alpha transparency channel value after it has been multiplied by the alphaMultiplier value. | ColorTransform
 | blueMultiplier : Number A decimal value that is multiplied with the blue channel value. | ColorTransform
 | blueOffset : Number A number from -255 to 255 that is added to the blue channel value after it has been multiplied by the blueMultiplier value. | ColorTransform
 | color : uint The RGB color value for a ColorTransform object. | ColorTransform
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | greenMultiplier : Number A decimal value that is multiplied with the green channel value. | ColorTransform
 | greenOffset : Number A number from -255 to 255 that is added to the green channel value after it has been multiplied by the greenMultiplier value. | ColorTransform
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | redMultiplier : Number A decimal value that is multiplied with the red channel value. | ColorTransform
 | redOffset : Number A number from -255 to 255 that is added to the red channel value after it has been multiplied by the redMultiplier value. | ColorTransform
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ColorTransform(redMultiplier:Number = 1.0, greenMultiplier:Number = 1.0, blueMultiplier:Number = 1.0, alphaMultiplier:Number = 1.0, redOffset:Number = 0, greenOffset:Number = 0, blueOffset:Number = 0, alphaOffset:Number = 0)
Creates a ColorTransform object for a display object with the specified color channel values and alpha values.
ColorTransform
concat(second:ColorTransform):void
Concatenates the ColorTranform object specified by the second parameter with the current ColorTransform object and sets the current object as the result, which is an additive combination of the two color transformations.
ColorTransform
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
toString():String
Formats and returns a string that describes all of the properties of the ColorTransform object.
ColorTransform
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Property detail
alphaMultiplier property
public var alphaMultiplier:Number

A decimal value that is multiplied with the alpha transparency channel value.

If you set the alpha transparency value of a display object directly by using the alpha property of the DisplayObject instance, it affects the value of the alphaMultiplier property of that display object's transform.colorTransform property.

See also

flash.display.DisplayObject.alpha
alphaOffset property
public var alphaOffset:Number

A number from -255 to 255 that is added to the alpha transparency channel value after it has been multiplied by the alphaMultiplier value.

blueMultiplier property
public var blueMultiplier:Number

A decimal value that is multiplied with the blue channel value.

blueOffset property
public var blueOffset:Number

A number from -255 to 255 that is added to the blue channel value after it has been multiplied by the blueMultiplier value.

color property
color:uint [read-write]

The RGB color value for a ColorTransform object.

When you set this property, it changes the three color offset values (redOffset, greenOffset, and blueOffset) accordingly, and it sets the three color multiplier values (redMultiplier, greenMultiplier, and blueMultiplier) to 0. The alpha transparency multiplier and offset values do not change.

When you pass a value for this property, use the format 0xRRGGBB. RR, GG, and BB each consist of two hexadecimal digits that specify the offset of each color component. The 0x tells the ActionScript compiler that the number is a hexadecimal value.

Implementation
    public function get color():uint
    public function set color(value:uint):void
greenMultiplier property
public var greenMultiplier:Number

A decimal value that is multiplied with the green channel value.

greenOffset property
public var greenOffset:Number

A number from -255 to 255 that is added to the green channel value after it has been multiplied by the greenMultiplier value.

redMultiplier property
public var redMultiplier:Number

A decimal value that is multiplied with the red channel value.

redOffset property
public var redOffset:Number

A number from -255 to 255 that is added to the red channel value after it has been multiplied by the redMultiplier value.

Constructor detail
ColorTransform () constructor
public function ColorTransform(redMultiplier:Number = 1.0, greenMultiplier:Number = 1.0, blueMultiplier:Number = 1.0, alphaMultiplier:Number = 1.0, redOffset:Number = 0, greenOffset:Number = 0, blueOffset:Number = 0, alphaOffset:Number = 0)

Creates a ColorTransform object for a display object with the specified color channel values and alpha values.

Parameters
redMultiplier:Number (default = 1.0) — The value for the red multiplier, in the range from 0 to 1.
greenMultiplier:Number (default = 1.0) — The value for the green multiplier, in the range from 0 to 1.
blueMultiplier:Number (default = 1.0) — The value for the blue multiplier, in the range from 0 to 1.
alphaMultiplier:Number (default = 1.0) — The value for the alpha transparency multiplier, in the range from 0 to 1.
redOffset:Number (default = 0) — The offset value for the red color channel, in the range from -255 to 255.
greenOffset:Number (default = 0) — The offset value for the green color channel, in the range from -255 to 255.
blueOffset:Number (default = 0) — The offset for the blue color channel value, in the range from -255 to 255.
alphaOffset:Number (default = 0) — The offset for alpha transparency channel value, in the range from -255 to 255.
Method detail
concat () method
public function concat(second:ColorTransform):void

Concatenates the ColorTranform object specified by the second parameter with the current ColorTransform object and sets the current object as the result, which is an additive combination of the two color transformations. When you apply the concatenated ColorTransform object, the effect is the same as applying the second color transformation after the original color transformation.

Parameters
second:ColorTransform — The ColorTransform object to be combined with the current ColorTransform object.
toString () method
public function toString():String

Formats and returns a string that describes all of the properties of the ColorTransform object.

Returns
String — A string that lists all of the properties of the ColorTransform object.
Examples

The following example uses the TransformExample class to create a simple sprite in the shape of a square filled with a gradient pattern. Each time the user clicks the square, the application transforms the colors of the square sprite, adding to the red color channel and lightening the blue color channel. This is accomplished with the following steps:
  1. The constructor creates a new sprite object target.
  2. The CustomButton() constructor calls the draw() method, which draws a gradient square in the sprite.
  3. The CustomButton() constructor adds a click event listener for the sprite, which is handled by the clickHandler() method.
  4. In the clickHandler() method, two properties are set to the redOffset and blueOffset properties of the current color transformation. Each is adjusted by 25. Then the transform.colorTransform property of the square sprite is modified to use the new offset values. Each time the user clicks the square, the call to the clickHandler() method modifies the color of the square, by augmenting its red color value and diminishing its blue color value.
package {
    import flash.display.Sprite;
    import flash.display.GradientType;
    import flash.geom.ColorTransform;
    import flash.events.MouseEvent;

    public class ColorTransformExample extends Sprite {
        public function ColorTransformExample() {
            var target:Sprite = new Sprite();
            draw(target);
            addChild(target);
            target.useHandCursor = true;
            target.buttonMode = true;
            target.addEventListener(MouseEvent.CLICK, clickHandler)
        }
        public function draw(sprite:Sprite):void {
            var red:uint = 0xFF0000;
            var green:uint = 0x00FF00;
            var blue:uint = 0x0000FF;
            var size:Number = 100;
            sprite.graphics.beginGradientFill(GradientType.LINEAR, [red, blue, green], [1, 0.5, 1], [0, 200, 255]);
            sprite.graphics.drawRect(0, 0, 100, 100);
        }
        public function clickHandler(event:MouseEvent):void {
            var rOffset:Number = transform.colorTransform.redOffset + 25;
            var bOffset:Number = transform.colorTransform.redOffset - 25;
            this.transform.colorTransform = new ColorTransform(1, 1, 1, 1, rOffset, 0, bOffset, 0);
        }
    }
}


flash.geom.Matrix (Flex™ 2 Language Reference)

Class Matrix | Properties | Methods | Examples
Package | flash.geom
Class | public class Matrix
Inheritance | Matrix Inheritance Object

The Matrix class represents a transformation matrix that determines how to map points from one coordinate space to another. You can perform various graphical transformations on a display object by setting the properties of a Matrix object, applying that Matrix object to the matrix property of a Transform object, and then applying that Transform object as the transform property of the display object. These transformation functions include translation (x and y repositioning), rotation, scaling, and skewing.

Together these types of transformations are known as affine transformations. Affine transformations preserve the straightness of lines while transforming, so that parallel lines stay parallel.

To apply a transformation matrix to a display object, you create a Transform object, set its matrix property to the transformation matrix, and then set the transform property of the display object to the Transform object. Matrix objects are also used as parameters of some methods, such as the following:

  • The draw() method of a BitmapData object
  • The beginBitmapFill() method, beginGradientFill() method, or lineGradientStyle() method of a Graphics object

A transformation matrix object is a 3 x 3 matrix with the following contents:

Matrix class properties in matrix notation

In traditional transformation matrixes, the u, v, and w properties provide extra capabilities. The Matrix class can only operate in two-dimensional space, so it always assumes that the property values u and v are 0.0, and that the property value w is 1.0. The effective values of the matrix are as follows:

Matrix class properties in matrix notation showing assumed values for u, v, and w

You can get and set the values of all six of the other properties in a Matrix object: a, b, c, d, tx, and ty.

The Matrix class supports the four major types of transformations: translation, scaling, rotation, and skewing. You can set three of these transformations by using specialized methods, as described in the following table:

Transformation | Method | Matrix values | Display result | Description
Translation (displacement) | translate(tx, ty) | Matrix notation of translate method parameters | Illustration of translate method effects | Moves the image tx pixels to the right and ty pixels down.
Scaling | scale(sx, sy) | Matrix notation of scale method parameters | Illustration of scale method effects | Resizes the image, multiplying the location of each pixel by sx on the x axis and sy on the y axis.
Rotation | rotate(q) | Matrix notation of rotate method properties | Illustration of rotate method effects | Rotates the image by an angle q, which is measured in radians.
Skewing or shearing | None; must set the properties b and c | Matrix notation of skew function properties | Illustration of skew function effects | Progressively slides the image in a direction parallel to the x or y axis. The b property of the Matrix object represents the tangent of the skew angle along the y axis; the c property of the Matrix object represents the tangent of the skew angle along the x axis.

Each transformation function alters the current matrix properties so that you can effectively combine multiple transformations. To do this, you call more than one transformation function before applying the matrix to its display object target (by using the transform property of that display object).

Use the new Matrix() constructor to create a Matrix object before you can call the methods of the Matrix object.

View the examples.

See also

flash.display.DisplayObject.transform
flash.geom.Transform
flash.display.BitmapData.draw()
flash.display.Graphics.beginBitmapFill()
flash.display.Graphics.beginGradientFill()
flash.display.Graphics.lineGradientStyle()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | a : Number The value in the first row and first column of the Matrix object, which affects the positioning of pixels along the x axis when scaling or rotating an image. | Matrix
 | b : Number The value in the first row and second column of the Matrix object, which affects the positioning of pixels along the y axis when rotating or skewing an image. | Matrix
 | c : Number The value in the second row and first column of the Matrix object, which affects the positioning of pixels along the x axis when rotating or skewing an image. | Matrix
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | d : Number The value in the second row and second column of the Matrix object, which affects the positioning of pixels along the y axis when scaling or rotating an image. | Matrix
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | tx : Number The distance by which to translate each point along the x axis. | Matrix
 | ty : Number The distance by which to translate each point along the y axis. | Matrix
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Matrix(a:Number = 1, b:Number = 0, c:Number = 0, d:Number = 1, tx:Number = 0, ty:Number = 0) Creates a new Matrix object with the specified parameters. | Matrix
 | clone():Matrix Returns a new Matrix object that is a clone of this matrix, with an exact copy of the contained object. | Matrix
 | concat(m:Matrix):void Concatenates a matrix with the current matrix, effectively combining the geometric effects of the two. | Matrix
 | createBox(scaleX:Number, scaleY:Number, rotation:Number = 0, tx:Number = 0, ty:Number = 0):void Includes parameters for scaling, rotation, and translation. | Matrix
 | createGradientBox(width:Number, height:Number, rotation:Number = 0, tx:Number = 0, ty:Number = 0):void Creates the specific style of matrix expected by the beginGradientFill() and lineGradientStyle() methods of the Graphics class. | Matrix
 | deltaTransformPoint(point:Point):Point Given a point in the pretransform coordinate space, returns the coordinates of that point after the transformation occurs. | Matrix
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | identity():void Sets each matrix property to a value that causes a null transformation. | Matrix
 | invert():void Performs the opposite transformation of the original matrix. | Matrix
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | rotate(angle:Number):void Applies a rotation transformation to the Matrix object. | Matrix
 | scale(sx:Number, sy:Number):void Applies a scaling transformation to the matrix. | Matrix
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a text value listing the properties of the Matrix object. | Matrix
 | transformPoint(point:Point):Point Returns the result of applying the geometric transformation represented by the Matrix object to the specified point. | Matrix
 | translate(dx:Number, dy:Number):void Translates the matrix along the x and y axes, as specified by the dx and dy parameters. | Matrix
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
a property
public var a:Number

The value in the first row and first column of the Matrix object, which affects the positioning of pixels along the x axis when scaling or rotating an image.

Example
The following example creates the Matrix object myMatrix and sets its a value.
     import flash.geom.Matrix;

     var myMatrix:Matrix = new Matrix();
     trace(myMatrix.a);  // 1

     myMatrix.a = 2;
     trace(myMatrix.a);  // 2

b property
public var b:Number

The value in the first row and second column of the Matrix object, which affects the positioning of pixels along the y axis when rotating or skewing an image.

Example
The following example creates the Matrix object myMatrix and sets its b value.
     import flash.geom.Matrix;

     var myMatrix:Matrix = new Matrix();
     trace(myMatrix.b);  // 0

     var degrees:Number = 30;
     var radians:Number = (degrees/180) * Math.PI;
     myMatrix.b = Math.tan(radians);
     trace(myMatrix.b);       // 0.5773502691896257

c property
public var c:Number

The value in the second row and first column of the Matrix object, which affects the positioning of pixels along the x axis when rotating or skewing an image.

Example
The following example creates the Matrix object myMatrix and sets its c value.
     import flash.geom.Matrix;

     var myMatrix:Matrix = new Matrix();
     trace(myMatrix.c);  // 0

     var degrees:Number = 30;
     var radians:Number = (degrees/180) * Math.PI;
     myMatrix.c = Math.tan(radians);
     trace(myMatrix.c);  // 0.5773502691896257

d property
public var d:Number

The value in the second row and second column of the Matrix object, which affects the positioning of pixels along the y axis when scaling or rotating an image.

Example
The following example creates the Matrix object myMatrix and sets its d value.
     import flash.geom.Matrix;

     var myMatrix:Matrix = new Matrix();
     trace(myMatrix.d);  // 1

     myMatrix.d = 2;
     trace(myMatrix.d);  // 2

tx property
public var tx:Number

The distance by which to translate each point along the x axis. This represents the value in the third row and first column of the Matrix object.

Example
The following example creates the Matrix object myMatrix and sets its tx value.

     import flash.geom.Matrix;

     var myMatrix:Matrix = new Matrix();
     trace(myMatrix.tx);  // 0

     myMatrix.tx = 50;  // 50
     trace(myMatrix.tx);

ty property
public var ty:Number

The distance by which to translate each point along the y axis. This represents the value in the third row and second column of the Matrix object.

Example
The following example creates the Matrix object myMatrix and sets its ty value.

     import flash.geom.Matrix;

     var myMatrix:Matrix = new Matrix();
     trace(myMatrix.ty);  // 0

     myMatrix.ty = 50;
     trace(myMatrix.ty);  // 50

Constructor detail
Matrix () constructor
public function Matrix(a:Number = 1, b:Number = 0, c:Number = 0, d:Number = 1, tx:Number = 0, ty:Number = 0)

Creates a new Matrix object with the specified parameters. In matrix notation, the properties are organized like this:

Matrix class properties in matrix notation showing assumed values for u, v, and w

If you do not provide any parameters to the new Matrix() constructor, it creates an identity matrix with the following values:

a = 1 | b = 0
c = 0 | d = 1
tx = 0 | ty = 0

In matrix notation, the identity matrix looks like this:

Matrix class properties in matrix notation

Parameters
a:Number (default = 1) — The value in the first row and first column of the new Matrix object.
b:Number (default = 0) — The value in the first row and second column of the new Matrix object.
c:Number (default = 0) — The value in the second row and first column of the new Matrix object.
d:Number (default = 1) — The value in the second row and second column of the new Matrix object.
tx:Number (default = 0) — The value in the third row and first column of the new Matrix object.
ty:Number (default = 0) — The value in the third row and second column of the new Matrix object.

Example
The following example creates matrix_1 by sending no parameters to the Matrix() constructor and matrix_2 by sending parameters to it. Notice that matrix_1, which was created with no parameters, results in an identity matrix with the values a=1, b=0, c=0, d=1, tx=0, ty=0.
    import flash.geom.Matrix;

    var matrix_1:Matrix = new Matrix();
    trace(matrix_1);  // (a=1, b=0, c=0, d=1, tx=0, ty=0)

    var matrix_2:Matrix = new Matrix(1, 2, 3, 4, 5, 6);
    trace(matrix_2);  // (a=1, b=2, c=3, d=4, tx=5, ty=6)

Method detail
clone () method
public function clone():Matrix

Returns a new Matrix object that is a clone of this matrix, with an exact copy of the contained object.

Returns
Matrix — A Matrix object.
concat () method
public function concat(m:Matrix):void

Concatenates a matrix with the current matrix, effectively combining the geometric effects of the two. In mathematical terms, concatenating two matrixes is the same as combining them using matrix multiplication.

For example, if matrix m1 scales an object by a factor of four, and matrix m2 rotates an object by 1.5707963267949 radians (Math.PI/2), then m1.concat(m2) transforms m1 into a matrix that scales an object by a factor of four and rotates the object by Math.PI/2 radians.

This method replaces the source matrix with the concatenated matrix. If you want to concatenate two matrixes without altering either of the two source matrixes, first copy the source matrix by using the clone() method, as shown in the Class Examples section.

Parameters
m:Matrix — The matrix to be concatenated to the source matrix.
createBox () method
public function createBox(scaleX:Number, scaleY:Number, rotation:Number = 0, tx:Number = 0, ty:Number = 0):void

Includes parameters for scaling, rotation, and translation. When applied to a matrix it sets the matrix's values based on those parameters.

Using the createBox() method lets you obtain the same matrix as you would if you applied the identity(), rotate(), scale(), and translate() methods in succession. For example, mat1.createBox(2,2,Math.PI/4, 100, 100) has the same effect as the following:

     import flash.geom.Matrix;
          var mat1:Matrix = new Matrix();
     mat1.identity();
     mat1.rotate(Math.PI/4);
     mat1.scale(2,2);
     mat1.translate(10,20);
Parameters
scaleX:Number — The factor by which to scale horizontally.
scaleY:Number — The factor by which scale vertically.
rotation:Number (default = 0) — The amount to rotate, in radians.
tx:Number (default = 0) — The number of pixels to translate (move) to the right along the x axis.
ty:Number (default = 0) — The number of pixels to translate (move) down along the y axis.

See also

flash.display.Graphics.beginBitmapFill()
Using Matrix objects

Example
The following example sets the x scale, y scale, rotation, x location, and y location of myMatrix by calling its createBox() method.

package
{
    import flash.display.Shape;
    import flash.display.Sprite;
    import flash.geom.Matrix;
    import flash.geom.Transform;

    public class Matrix_createBox extends Sprite
    {
        public function Matrix_createBox()
        {
             var myMatrix:Matrix = new Matrix();
             trace(myMatrix.toString());  // (a=1, b=0, c=0, d=1, tx=0, ty=0)

             myMatrix.createBox(1, 2, Math.PI/4, 50, 100);
             trace(myMatrix.toString());
             // (a=0.7071067811865476, b=1.414213562373095, c=-0.7071067811865475,
             //  d=1.4142135623730951, tx=100, ty=200)

             var rectangleShape:Shape = createRectangle(20, 80, 0xFF0000);
             addChild(rectangleShape);

             var rectangleTrans:Transform = new Transform(rectangleShape);
             rectangleTrans.matrix = myMatrix;
        }

        public function createRectangle(w:Number, h:Number, color:Number):Shape
        {
            var rect:Shape = new Shape();
            rect.graphics.beginFill(color);
            rect.graphics.drawRect(0, 0, w, h);
            addChild(rect);
            return rect;
        }
    }
}

createGradientBox () method
public function createGradientBox(width:Number, height:Number, rotation:Number = 0, tx:Number = 0, ty:Number = 0):void

Creates the specific style of matrix expected by the beginGradientFill() and lineGradientStyle() methods of the Graphics class. Width and height are scaled to a scaleX/scaleY pair and the tx/ty values are offset by half the width and height.

For example, consider a gradient with the following characteristics:

  • GradientType.LINEAR
  • Two colors, green and blue, with the ratios array set to [0, 255]
  • SpreadMethod.PAD
  • InterpolationMethod.LINEAR_RGB

The following illustrations show gradients in which the matrix was defined using the createGradientBox() method with different parameter settings:

createGradientBox() settings Resulting gradient
width = 25;
height = 25;
rotation = 0;
tx = 0;
ty = 0;
width = 25;
height = 25;
rotation = 0;
tx = 25;
ty = 0;
width = 50;
height = 50;
rotation = 0;
tx = 0;
ty = 0;
width = 50;
height = 50;
rotation = Math.PI / 4; // 45°
tx = 0;
ty = 0;
Parameters
width:Number — The width of the gradient box.
height:Number — The height of the gradient box.
rotation:Number (default = 0) — The amount to rotate, in radians.
tx:Number (default = 0) — The distance, in pixels, to translate to the right along the x axis. This value is offset by half of the width parameter.
ty:Number (default = 0) — The distance, in pixels, to translate down along the y axis. This value is offset by half of the height parameter.

See also

flash.display.Graphics.beginGradientFill()
flash.display.Graphics.lineGradientStyle()
Using Matrix objects

Example
The following example sets the x scale, y scale, rotation, x location, and y location of myMatrix by calling its createBox() method.

package
{
    import flash.display.GradientType;
    import flash.display.Sprite;
    import flash.geom.Matrix;

    public class Matrix_createGradientBox extends Sprite
    {
        public function Matrix_createGradientBox()
        {
             var myMatrix:Matrix = new Matrix();
             trace(myMatrix.toString());          // (a=1, b=0, c=0, d=1, tx=0, ty=0)

             myMatrix.createGradientBox(200, 200, 0, 50, 50);
             trace(myMatrix.toString());          // (a=0.1220703125, b=0, c=0, d=0.1220703125, tx=150, ty=150)

             var colors:Array = [0xFF0000, 0x0000FF];
             var alphas:Array = [100, 100];
             var ratios:Array = [0, 0xFF];

             this.graphics.beginGradientFill(GradientType.LINEAR, colors, alphas, ratios, myMatrix);
             this.graphics.drawRect(0, 0, 300, 200);
        }
    }
}

deltaTransformPoint () method
public function deltaTransformPoint(point:Point):Point

Given a point in the pretransform coordinate space, returns the coordinates of that point after the transformation occurs. Unlike the standard transformation applied using the transformPoint() method, the deltaTransformPoint() method's transformation does not consider the translation parameters tx and ty.

Parameters
point:Point — The point for which you want to get the result of the matrix transformation.

Returns
Point — The point resulting from applying the matrix transformation.
identity () method
public function identity():void

Sets each matrix property to a value that causes a null transformation. An object transformed by applying an identity matrix will be identical to the original.

After calling the identity() method, the resulting matrix has the following properties: a=1, b=0, c=0, d=1, tx=0, ty=0.

In matrix notation, the identity matrix looks like this:

Matrix class properties in matrix notation

invert () method
public function invert():void

Performs the opposite transformation of the original matrix. You can apply an inverted matrix to an object to undo the transformation performed when applying the original matrix.

Example
The following example creates a halfScaleMatrix by calling the invert() method of doubleScaleMatrix. It then demonstrates that the two are Matrix inverses of one another -- matrices that undo any transformations performed by the other -- by creating originalAndInverseMatrix which is equal to noScaleMatrix.

package
{
    import flash.display.Shape;
    import flash.display.Sprite;
    import flash.geom.Matrix;
    import flash.geom.Transform;

    public class Matrix_invert extends Sprite
    {
        public function Matrix_invert()
        {
            var rect0:Shape = createRectangle(20, 80, 0xFF0000);
            var rect1:Shape = createRectangle(20, 80, 0x00FF00);
            var rect2:Shape = createRectangle(20, 80, 0x0000FF);
            var rect3:Shape = createRectangle(20, 80, 0x000000);

            var trans0:Transform = new Transform(rect0);
            var trans1:Transform = new Transform(rect1);
            var trans2:Transform = new Transform(rect2);
            var trans3:Transform = new Transform(rect3);

            var doubleScaleMatrix:Matrix = new Matrix(2, 0, 0, 2, 0, 0);
            trans0.matrix = doubleScaleMatrix;
            trace(doubleScaleMatrix.toString());  // (a=2, b=0, c=0, d=2, tx=0, ty=0)

            var noScaleMatrix:Matrix = new Matrix(1, 0, 0, 1, 0, 0);
            trans1.matrix = noScaleMatrix;
            rect1.x = 50;
            trace(noScaleMatrix.toString());  // (a=1, b=0, c=0, d=1, tx=0, ty=0)

            var halfScaleMatrix:Matrix = doubleScaleMatrix.clone();
            halfScaleMatrix.invert();
            trans2.matrix = halfScaleMatrix;
            rect2.x = 100;
            trace(halfScaleMatrix.toString());  // (a=0.5, b=0, c=0, d=0.5, tx=0, ty=0)

            var originalAndInverseMatrix:Matrix = doubleScaleMatrix.clone();
            originalAndInverseMatrix.concat(halfScaleMatrix);
            trans3.matrix = originalAndInverseMatrix;
            rect3.x = 150;
            trace(originalAndInverseMatrix.toString());  // (a=1, b=0, c=0, d=1, tx=0, ty=0)
        }

        public function createRectangle(w:Number, h:Number, color:Number):Shape
        {
            var rect:Shape = new Shape();
            rect.graphics.beginFill(color);
            rect.graphics.drawRect(0, 0, w, h);
            addChild(rect);
            return rect;
        }
    }
}

rotate () method
public function rotate(angle:Number):void

Applies a rotation transformation to the Matrix object.

The rotate() method alters the a, b, c, and d properties of the Matrix object. In matrix notation, this is the same as concatenating the current matrix with the following:

Matrix notation of scale method parameters

Parameters
angle:Number — The rotation angle in radians.

See also

Using Matrix objects
scale () method
public function scale(sx:Number, sy:Number):void

Applies a scaling transformation to the matrix. The x axis is multiplied by sx, and the y axis it is multiplied by sy.

The scale() method alters the a and d properties of the Matrix object. In matrix notation, this is the same as concatenating the current matrix with the following matrix:

Matrix notation of scale method parameters

Parameters
sx:Number — A multiplier used to scale the object along the x axis.
sy:Number — A multiplier used to scale the object along the y axis.

See also

Using Matrix objects
toString () method
public function toString():String

Returns a text value listing the properties of the Matrix object.

Returns
String — A string containing the values of the properties of the Matrix object: a, b, c, d, tx, and ty.
transformPoint () method
public function transformPoint(point:Point):Point

Returns the result of applying the geometric transformation represented by the Matrix object to the specified point.

Parameters
point:Point — The point for which you want to get the result of the Matrix transformation.

Returns
Point — The point resulting from applying the Matrix transformation.
translate () method
public function translate(dx:Number, dy:Number):void

Translates the matrix along the x and y axes, as specified by the dx and dy parameters.

Parameters
dx:Number — The amount of movement along the x axis to the right, in pixels.
dy:Number — The amount of movement down along the y axis, in pixels.

See also

Using Matrix objects
Examples

The following example uses the MatrixExample class to show how a large gradient-filled square can be created. This is accomplished with the following steps:
  1. The application creates a new Matrix object myMatrix, and it uses the trace() method to output the default property values for the myMatrix object.
  2. The application calls the createGradientBox() with the width and height parameters set to 200 pixels, no rotation, and the distance to translate along the x and y axes set to 50 pixels.
  3. The application prints the myMatrix object again to show the change after calling createGradientBox().
  4. The application sets up three variables to control how the gradient box is filled:
    • colors: Sets the gradient colors to range between solid red and solid blue.
    • alphas: Sets the opacity to solid.
    • ratios: Sets the distribution of the colors to be equal for both red and blue.
  5. The application calls the graphics method beginGradientFill(), which operates on the myMatrix object, and it calls the lineTo() method, resulting in the gradient-filled box.
package {
    import flash.geom.Matrix;
    import flash.display.Sprite;
    import flash.display.GradientType;

    public class MatrixExample extends Sprite {

        public function MatrixExample() {
            var myMatrix:Matrix = new Matrix();
            trace(myMatrix.toString());    // (a=1, b=0, c=0, d=1, tx=0, ty=0)

            myMatrix.createGradientBox(200, 200, 0, 50, 50);
            trace(myMatrix.toString());    // (a=0.1220703125, b=0, c=0, d=0.1220703125, tx=150, ty=150)

            var colors:Array = [0xFF0000, 0x0000FF];
            var alphas:Array = [100, 100];
            var ratios:Array = [0, 0xFF];
            graphics.beginGradientFill(GradientType.LINEAR, colors, alphas, ratios, myMatrix);
            graphics.lineTo(0, 300);
            graphics.lineTo(300, 300);
            graphics.lineTo(300, 0);
            graphics.lineTo(0, 0);
        }
    }
}


flash.geom.Point (Flex™ 2 Language Reference)

Class Point | Properties | Methods | Examples
Package | flash.geom
Class | public class Point
Inheritance | Point Inheritance Object

The Point object represents a location in a two-dimensional coordinate system, where x represents the horizontal axis and y represents the vertical axis.

The following code creates a point at (0,0):

var myPoint:Point = new Point();

Methods and properties of the following classes use Point objects:

  • BitmapData
  • DisplayObject
  • DisplayObjectContainer
  • DisplacementMapFilter
  • Matrix
  • Rectangle

You can use the new Point() constructor to create a Point object.

View the examples.

See also

flash.display.BitmapData
flash.display.DisplayObject
flash.display.DisplayObjectContainer
flash.filters.DisplacementMapFilter
flash.geom.Matrix
flash.geom.Rectangle
Using Point objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | length : Number [read-only] The length of the line segment from (0,0) to this point. | Point
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number The horizontal coordinate of the point. | Point
 | y : Number The vertical coordinate of the point. | Point
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Point(x:Number = 0, y:Number = 0) Creates a new point. | Point
 | add(v:Point):Point Adds the coordinates of another point to the coordinates of this point to create a new point. | Point
 | clone():Point Creates a copy of this Point object. | Point
 | distance(pt1:Point, pt2:Point):Number [static] Returns the distance between pt1 and pt2. | Point
 | equals(toCompare:Point):Boolean Determines whether two points are equal. | Point
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | interpolate(pt1:Point, pt2:Point, f:Number):Point [static] Determines a point between two specified points. | Point
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | normalize(thickness:Number):void Scales the line segment between (0,0) and the current point to a set length. | Point
 | offset(dx:Number, dy:Number):void Offsets the Point object by the specified amount. | Point
 | polar(len:Number, angle:Number):Point [static] Converts a pair of polar coordinates to a Cartesian point coordinate. | Point
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | subtract(v:Point):Point Subtracts the coordinates of another point from the coordinates of this point to create a new point. | Point
 | toString():String Returns a string that contains the values of the x and y coordinates. | Point
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
length property
length:Number [read-only]

The length of the line segment from (0,0) to this point.

Implementation
    public function get length():Number

See also

Point.polar()
x property
public var x:Number

The horizontal coordinate of the point. The default value is 0.

See also

Using Point objects
y property
public var y:Number

The vertical coordinate of the point. The default value is 0.

See also

Using Point objects
Constructor detail
Point () constructor
public function Point(x:Number = 0, y:Number = 0)

Creates a new point. If you pass no parameters to this method, a point is created at (0,0).

Parameters
x:Number (default = 0) — The horizontal coordinate.
y:Number (default = 0) — The vertical coordinate.
Method detail
add () method
public function add(v:Point):Point

Adds the coordinates of another point to the coordinates of this point to create a new point.

Parameters
v:Point — The point to be added.

Returns
Point — The new point.
clone () method
public function clone():Point

Creates a copy of this Point object.

Returns
Point — The new Point object.
distance () method
public static function distance(pt1:Point, pt2:Point):Number

Returns the distance between pt1 and pt2.

Parameters
pt1:Point — The first point.
pt2:Point — The second point.

Returns
Number — The distance between the first and second points.

See also

Using Point objects
equals () method
public function equals(toCompare:Point):Boolean

Determines whether two points are equal. Two points are equal if they have the same x and y values.

Parameters
toCompare:Point — The point to be compared.

Returns
Boolean — A value of true if the object is equal to this Point object; false if it is not equal.
interpolate () method
public static function interpolate(pt1:Point, pt2:Point, f:Number):Point

Determines a point between two specified points. The parameter f determines where the new interpolated point is located relative to the two end points specified by parameters pt1 and pt2. The closer the value of the parameter f is to 1.0, the closer the interpolated point is to the first point (parameter pt1). The closer the value of the parameter f is to 0, the closer the interpolated point is to the second point (parameter pt2).

Parameters
pt1:Point — The first point.
pt2:Point — The second point.
f:Number — The level of interpolation between the two points. Indicates where the new point will be, along the line between pt1 and pt2. If f=1, pt1 is returned; if f=0, pt2 is returned.

Returns
Point — The new, interpolated point.
normalize () method
public function normalize(thickness:Number):void

Scales the line segment between (0,0) and the current point to a set length.

Parameters
thickness:Number — The scaling value. For example, if the current point is (0,5), and you normalize it to 1, the point returned is at (0,1).

See also

length
offset () method
public function offset(dx:Number, dy:Number):void

Offsets the Point object by the specified amount. The value of dx is added to the original value of x to create the new x value. The value of dy is added to the original value of y to create the new y value.

Parameters
dx:Number — The amount by which to offset the horizontal coordinate, x.
dy:Number — The amount by which to offset the vertical coordinate, y.
polar () method
public static function polar(len:Number, angle:Number):Point

Converts a pair of polar coordinates to a Cartesian point coordinate.

Parameters
len:Number — The length coordinate of the polar pair.
angle:Number — The angle, in radians, of the polar pair.

Returns
Point — The Cartesian point.

See also

length
Math.round()
Using Point objects
subtract () method
public function subtract(v:Point):Point

Subtracts the coordinates of another point from the coordinates of this point to create a new point.

Parameters
v:Point — The point to be subtracted.

Returns
Point — The new point.
toString () method
public function toString():String

Returns a string that contains the values of the x and y coordinates. The string has the form "(x=x, y=y)", so calling the toString() method for a point at 23,17 would return "(x=23, y=17)".

Returns
String — The string representation of the coordinates.
Examples

The following example uses the PointExample class to create a number of new Point objects at various x,y coordinates and then uses the trace() method to output the results of various class methods.
package {
    import flash.display.Sprite;
    import flash.geom.Point;

    public class PointExample extends Sprite {

        public function PointExample() {
        var point1:Point = new Point();
        trace(point1);  // (x=0, y=0)

        var point2:Point = new Point(6, 8);
        trace(point2); // (x=6, y=8)

        trace(Point.interpolate(point1, point2, 0.5)); // (x=3, y=4)

        trace(Point.distance(point1, point2)); // 10

        trace(point1.add(point2)); // (x=6, y=8)

        var point3:Point = point2.clone();
        trace(point2.equals(point3)); // true

        point3.normalize(2.5);
        trace(point3); // (x=1.5, y=2)

        trace(point2.subtract(point3)); // (x=4.5, y=6)

        trace(point1.offset(2, 3)); //

        var angle:Number = Math.PI * 2 * (30 / 360); // 30°
        trace(Point.polar(4, angle)) // (x=3.464101615137755, y=1.9999999999999998)
        }
    }
}


flash.geom.Rectangle (Flex™ 2 Language Reference)

Class Rectangle | Properties | Methods | Examples
Package | flash.geom
Class | public class Rectangle
Inheritance | Rectangle Inheritance Object
Subclasses | RoundedRectangle

A Rectangle object is an area defined by its position, as indicated by its top-left corner point (x, y) and by its width and its height.

The x, y, width, and height properties of the Rectangle class are independent of each other; changing the value of one property has no effect on the others. However, the right and bottom properties are integrally related to those four properties. For example, if you change the value of the right property, the value of the width property changes; if you change the bottom property, the value of the height property changes.

The following methods and properties use Rectangle objects:

  • The applyFilter(), colorTransform(),
 copyChannel(), copyPixels(), draw(), fillRect(),
 generateFilterRect(), getColorBoundsRect(), getPixels(),
 merge(), paletteMap(), pixelDisolve(), setPixels(), and
 threshold() methods, and the rect property of the BitmapData class
  • The getBounds() and getRect() methods, and the scrollRect and scale9Grid properties of the DisplayObject class
  • The getCharBoundaries() method of the TextField class
  • The pixelBounds property of the Transform class
  • The bounds parameter for the startDrag() method of the Sprite class
  • The printArea parameter of the addPage() method of the PrintJob class

You can use the new Rectangle() constructor to create a Rectangle object.

Note: The Rectangle class does not define a rectangular Shape display object. To draw a rectangular Shape object onscreen, use the drawRect() method of the Graphics class.

View the examples.

See also

flash.display.DisplayObject.scrollRect
flash.display.BitmapData
flash.display.DisplayObject
flash.text.TextField.getCharBoundaries()
flash.geom.Transform.pixelBounds
flash.display.Sprite.startDrag()
flash.printing.PrintJob.addPage()
Using Rectangle objects
Setting size, scale, and orientation

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bottom : Number The sum of the y and height properties. | Rectangle
 | bottomRight : Point The location of the Rectangle object's bottom-right corner, determined by the values of the right and bottom properties. | Rectangle
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | height : Number The height of the rectangle, in pixels. | Rectangle
 | left : Number The x coordinate of the top-left corner of the rectangle. | Rectangle
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | right : Number The sum of the x and width properties. | Rectangle
 | size : Point The size of the Rectangle object, expressed as a Point object with the values of the width and height properties. | Rectangle
 | top : Number The y coordinate of the top-left corner of the rectangle. | Rectangle
 | topLeft : Point The location of the Rectangle object's top-left corner, determined by the x and y coordinates of the point. | Rectangle
 | width : Number The width of the rectangle, in pixels. | Rectangle
 | x : Number The x coordinate of the top-left corner of the rectangle. | Rectangle
 | y : Number The y coordinate of the top-left corner of the rectangle. | Rectangle
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Rectangle(x:Number = 0, y:Number = 0, width:Number = 0, height:Number = 0) Creates a new Rectangle object with the top-left corner specified by the x and y parameters and with the specified width and height parameters. | Rectangle
 | clone():Rectangle Returns a new Rectangle object with the same values for the x, y, width, and height properties as the original Rectangle object. | Rectangle
 | contains(x:Number, y:Number):Boolean Determines whether the specified point is contained within the rectangular region defined by this Rectangle object. | Rectangle
 | containsPoint(point:Point):Boolean Determines whether the specified point is contained within the rectangular region defined by this Rectangle object. | Rectangle
 | containsRect(rect:Rectangle):Boolean Determines whether the Rectangle object specified by the rect parameter is contained within this Rectangle object. | Rectangle
 | equals(toCompare:Rectangle):Boolean Determines whether the object specified in the toCompare parameter is equal to this Rectangle object. | Rectangle
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | inflate(dx:Number, dy:Number):void Increases the size of the Rectangle object by the specified amounts, in pixels. | Rectangle
 | inflatePoint(point:Point):void Increases the size of the Rectangle object. | Rectangle
 | intersection(toIntersect:Rectangle):Rectangle If the Rectangle object specified in the toIntersect parameter intersects with this Rectangle object, returns the area of intersection as a Rectangle object. | Rectangle
 | intersects(toIntersect:Rectangle):Boolean Determines whether the object specified in the toIntersect parameter intersects with this Rectangle object. | Rectangle
 | isEmpty():Boolean Determines whether or not this Rectangle object is empty. | Rectangle
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | offset(dx:Number, dy:Number):void Adjusts the location of the Rectangle object, as determined by its top-left corner, by the specified amounts. | Rectangle
 | offsetPoint(point:Point):void Adjusts the location of the Rectangle object using a Point object as a parameter. | Rectangle
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | setEmpty():void Sets all of the Rectangle object's properties to 0. | Rectangle
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Builds and returns a string that lists the horizontal and vertical positions and the width and height of the Rectangle object. | Rectangle
 | union(toUnion:Rectangle):Rectangle Adds two rectangles together to create a new Rectangle object, by filling in the horizontal and vertical space between the two rectangles. | Rectangle
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
bottom property
bottom:Number [read-write]

The sum of the y and height properties.

Implementation
    public function get bottom():Number
    public function set bottom(value:Number):void

See also

y
height
Using Rectangle objects
bottomRight property
bottomRight:Point [read-write]

The location of the Rectangle object's bottom-right corner, determined by the values of the right and bottom properties.

Implementation
    public function get bottomRight():Point
    public function set bottomRight(value:Point):void

See also

flash.geom.Point
height property
public var height:Number

The height of the rectangle, in pixels. Changing the height value of a Rectangle object has no effect on the x, y, and width properties.

See also

x
y
height
Using Rectangle objects
left property
left:Number [read-write]

The x coordinate of the top-left corner of the rectangle. Changing the left property of a Rectangle object has no effect on the y and height properties. However it does affect the width property, whereas changing the x value does not affect the width property.

The value of the left property is equal to the value of the x property.

Implementation
    public function get left():Number
    public function set left(value:Number):void

See also

x
y
width
height
Using Rectangle objects
right property
right:Number [read-write]

The sum of the x and width properties.

Implementation
    public function get right():Number
    public function set right(value:Number):void

See also

x
width
Using Rectangle objects
size property
size:Point [read-write]

The size of the Rectangle object, expressed as a Point object with the values of the width and height properties.

Implementation
    public function get size():Point
    public function set size(value:Point):void

See also

flash.geom.Point
top property
top:Number [read-write]

The y coordinate of the top-left corner of the rectangle. Changing the top property of a Rectangle object has no effect on the x and width properties. However it does affect the height property, whereas changing the y value does not affect the height property.

The value of the top property is equal to the value of the y property.

Implementation
    public function get top():Number
    public function set top(value:Number):void

See also

x
y
width
height
Using Rectangle objects
topLeft property
topLeft:Point [read-write]

The location of the Rectangle object's top-left corner, determined by the x and y coordinates of the point.

Implementation
    public function get topLeft():Point
    public function set topLeft(value:Point):void

See also

flash.geom.Point
x
y
width property
public var width:Number

The width of the rectangle, in pixels. Changing the width value of a Rectangle object has no effect on the x, y, and height properties.

See also

x
y
height
Using Rectangle objects
x property
public var x:Number

The x coordinate of the top-left corner of the rectangle. Changing the value of the x property of a Rectangle object has no effect on the y, width, and height properties.

The value of the x property is equal to the value of the left property.

See also

left
Using Rectangle objects
y property
public var y:Number

The y coordinate of the top-left corner of the rectangle. Changing the value of the y property of a Rectangle object has no effect on the x, width, and height properties.

The value of the y property is equal to the value of the top property.

See also

x
width
height
top
Using Rectangle objects
Constructor detail
Rectangle () constructor
public function Rectangle(x:Number = 0, y:Number = 0, width:Number = 0, height:Number = 0)

Creates a new Rectangle object with the top-left corner specified by the x and y parameters and with the specified width and height parameters. If you call this function without parameters, a rectangle with x, y, width, and height properties set to 0 is created.

Parameters
x:Number (default = 0) — The x coordinate of the top-left corner of the rectangle.
y:Number (default = 0) — The y coordinate of the top-left corner of the rectangle.
width:Number (default = 0) — The width of the rectangle, in pixels.
height:Number (default = 0) — The height of the rectangle, in pixels.

See also

x
y
width
height
Method detail
clone () method
public function clone():Rectangle

Returns a new Rectangle object with the same values for the x, y, width, and height properties as the original Rectangle object.

Returns
Rectangle — A new Rectangle object with the same values for the x, y, width, and height properties as the original Rectangle object.

See also

x
y
width
height
contains () method
public function contains(x:Number, y:Number):Boolean

Determines whether the specified point is contained within the rectangular region defined by this Rectangle object.

Parameters
x:Number — The x coordinate (horizontal position) of the point.
y:Number — The y coordinate (vertical position) of the point.

Returns
Boolean — A value of true if the Rectangle object contains the specified point; otherwise false.

See also

flash.geom.Point
containsPoint () method
public function containsPoint(point:Point):Boolean

Determines whether the specified point is contained within the rectangular region defined by this Rectangle object. This method is similar to the Rectangle.contains() method, except that it takes a Point object as a parameter.

Parameters
point:Point — The point, as represented by its x and y coordinates.

Returns
Boolean — A value of true if the Rectangle object contains the specified point; otherwise false.

See also

contains()
flash.geom.Point
containsRect () method
public function containsRect(rect:Rectangle):Boolean

Determines whether the Rectangle object specified by the rect parameter is contained within this Rectangle object. A Rectangle object is said to contain another if the second Rectangle object falls entirely within the boundaries of the first.

Parameters
rect:Rectangle — The Rectangle object being checked.

Returns
Boolean — A value of true if the Rectangle object that you specify is contained by this Rectangle object; otherwise false.
equals () method
public function equals(toCompare:Rectangle):Boolean

Determines whether the object specified in the toCompare parameter is equal to this Rectangle object. This method compares the x, y, width, and height properties of an object against the same properties of this Rectangle object.

Parameters
toCompare:Rectangle — The rectangle to compare to this Rectangle object.

Returns
Boolean — A value of true if the object has exactly the same values for the x, y, width, and height properties as this Rectangle object; otherwise false.

See also

x
y
width
height
inflate () method
public function inflate(dx:Number, dy:Number):void

Increases the size of the Rectangle object by the specified amounts, in pixels. The center point of the Rectangle object stays the same, and its size increases to the left and right by the dx value, and to the top and the bottom by the dy value.

Parameters
dx:Number — The value to be added to the left and the right of the Rectangle object. The following equation is used to calculate the new width and position of the rectangle:
 x -= dx;
 width += 2 * dx;
dy:Number — The value to be added to the top and the bottom of the Rectangle. The following equation is used to calculate the new height and position of the rectangle:
 y -= dy;
 height += 2 * dy;

See also

x
y
Using Rectangle objects
inflatePoint () method
public function inflatePoint(point:Point):void

Increases the size of the Rectangle object. This method is similar to the Rectangle.inflate() method except it takes a Point object as a parameter.

The following two code examples give the same result:

  rect1=new flash.geom.Rectangle(0,0,2,5);
  rect1.inflate(2,2)

  rect1=new flash.geom.Rectangle(0,0,2,5);
  pt1=new flash.geom.Point(2,2);
  rect1.inflatePoint(pt1)
Parameters
point:Point — The x property of this Point object is used to increase the horizontal dimension of the Rectangle object. The y property is used to increase the vertical dimension of the Rectangle object.

See also

flash.geom.Point
Using Rectangle objects
intersection () method
public function intersection(toIntersect:Rectangle):Rectangle

If the Rectangle object specified in the toIntersect parameter intersects with this Rectangle object, returns the area of intersection as a Rectangle object. If the rectangles do not intersect, this method returns an empty Rectangle object with its properties set to 0.

Parameters
toIntersect:Rectangle — The Rectangle object to compare against to see if it intersects with this Rectangle object.

Returns
Rectangle — A Rectangle object that equals the area of intersection. If the rectangles do not intersect, this method returns an empty Rectangle object; that is, a rectangle with its x, y, width, and height properties set to 0.

See also

Using Rectangle objects
intersects () method
public function intersects(toIntersect:Rectangle):Boolean

Determines whether the object specified in the toIntersect parameter intersects with this Rectangle object. This method checks the x, y, width, and height properties of the specified Rectangle object to see if it intersects with this Rectangle object.

Parameters
toIntersect:Rectangle — The Rectangle object to compare against this Rectangle object.

Returns
Boolean — A value of true if the specified object intersects with this Rectangle object; otherwise false.

See also

x
y
width
height
Using Rectangle objects
isEmpty () method
public function isEmpty():Boolean

Determines whether or not this Rectangle object is empty.

Returns
Boolean — A value of true if the Rectangle object's width or height is less than or equal to 0; otherwise false.
offset () method
public function offset(dx:Number, dy:Number):void

Adjusts the location of the Rectangle object, as determined by its top-left corner, by the specified amounts.

Parameters
dx:Number — Moves the x value of the Rectangle object by this amount.
dy:Number — Moves the y value of the Rectangle object by this amount.

See also

Using Rectangle objects
offsetPoint () method
public function offsetPoint(point:Point):void

Adjusts the location of the Rectangle object using a Point object as a parameter. This method is similar to the Rectangle.offset() method, except that it takes a Point object as a parameter.

Parameters
point:Point — A Point object to use to offset this Rectangle object.

See also

flash.geom.Point
Using Rectangle objects
setEmpty () method
public function setEmpty():void

Sets all of the Rectangle object's properties to 0. A Rectangle object is empty if its width or height is less than or equal to 0.

This method sets the values of the x, y, width, and height properties to 0.

See also

x
y
width
height
toString () method
public function toString():String

Builds and returns a string that lists the horizontal and vertical positions and the width and height of the Rectangle object.

Returns
String — A string listing the value of each of the following properties of the Rectangle object: x, y, width, and height.

See also

x
y
width
height
union () method
public function union(toUnion:Rectangle):Rectangle

Adds two rectangles together to create a new Rectangle object, by filling in the horizontal and vertical space between the two rectangles.

Parameters
toUnion:Rectangle — A Rectangle object to add to this Rectangle object.

Returns
Rectangle — A new Rectangle object that is the union of the two rectangles.

See also

Using Rectangle objects
Examples

The following example uses the RectangleExample class to create three new Rectangle objects at various x,y coordinates and with various heights and widths and then uses the trace() method to confirm that the Rectangle instances were successfully created. Then a Boolean variable isContained is assigned to the result of the call to the containsRect() method, which determines that the second rectangle does not fully enclose the third rectangle.
package {
    import flash.display.Sprite;
    import flash.geom.Rectangle;

    public class RectangleExample extends Sprite {

        public function RectangleExample() {
            var firstRect:Rectangle = new Rectangle();
            trace(firstRect);  // (x=0, y=0, w=0, h=0)
            var secondRect:Rectangle = new Rectangle(1, 3, 11, 13);
            trace(secondRect); // (x=1, y=3, w=11, h=13)
            var thirdRect:Rectangle = new Rectangle(5, 8, 17, 19);
            trace(thirdRect);  // (x=5, y=8, w=17, h=19)
            var isContained:Boolean = secondRect.containsRect(thirdRect);
            trace(isContained); // false
        }
    }
}


flash.geom.Transform (Flex™ 2 Language Reference)

Class Transform | Properties | Methods | Examples
Package | flash.geom
Class | public class Transform
Inheritance | Transform Inheritance Object

The Transform class collects data about color transformations and coordinate transformations that are applied to a display object.

A Transform object is normally obtained by getting the value of the transform property from a display object. You can also use the new Transform() constructor to create a new Transform object.

View the examples.

See also

flash.display.DisplayObject.transform
flash.geom.ColorTransform
flash.geom.Matrix

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | colorTransform : ColorTransform A ColorTransform object containing values that universally adjust the colors in the display object. | Transform
 | concatenatedColorTransform : ColorTransform [read-only] A ColorTransform object representing the combined color transformations applied to the display object and all of its parent objects, back to the root level. | Transform
 | concatenatedMatrix : Matrix [read-only] A Matrix object representing the combined transformation matrixes of the display object and all of its parent objects, back to the root level. | Transform
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | matrix : Matrix A Matrix object containing values that affect the scaling, rotation, and translation of the display object. | Transform
 | pixelBounds : Rectangle [read-only] A Rectangle object that defines the bounding rectangle of the display object on the Stage. | Transform
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
colorTransform property
colorTransform:ColorTransform [read-write]

A ColorTransform object containing values that universally adjust the colors in the display object.

Implementation
    public function get colorTransform():ColorTransform
    public function set colorTransform(value:ColorTransform):void

Throws
TypeError — The colorTransform is null when being set

See also

flash.geom.ColorTransform
concatenatedColorTransform property
concatenatedColorTransform:ColorTransform [read-only]

A ColorTransform object representing the combined color transformations applied to the display object and all of its parent objects, back to the root level. If different color transformations have been applied at different levels, all of those transformations are concatenated into one ColorTransform object for this property.

Implementation
    public function get concatenatedColorTransform():ColorTransform

See also

flash.geom.ColorTransform
concatenatedMatrix property
concatenatedMatrix:Matrix [read-only]

A Matrix object representing the combined transformation matrixes of the display object and all of its parent objects, back to the root level. If different transformation matrixes have been applied at different levels, all of those matrixes are concatenated into one matrix for this property.

Implementation
    public function get concatenatedMatrix():Matrix
matrix property
matrix:Matrix [read-write]

A Matrix object containing values that affect the scaling, rotation, and translation of the display object.

Implementation
    public function get matrix():Matrix
    public function set matrix(value:Matrix):void

Throws
TypeError — The matrix is null when being set

See also

flash.geom.Matrix
pixelBounds property
pixelBounds:Rectangle [read-only]

A Rectangle object that defines the bounding rectangle of the display object on the Stage.

Implementation
    public function get pixelBounds():Rectangle
Examples

The following example uses the TransformExample class to skew the bottom side of a square sprite filled with a gradient pattern. Each time the user clicks the square, the application transforms the sprite, by skewing it. This is accomplished with the following steps:
  1. The CustomButton() constructor creates a new sprite object target.
  2. The CustomButton() constructor calls the draw() method, which draws a gradient square in the sprite.
  3. The CustomButton() constructor adds a click event listener for the sprite, which is handled by the clickHandler() method.
  4. The clickHandler() method creates a new Matrix object, skewMatrix, set to apply a skew affect. Another matrix, tempMatrix, is assigned to the current transformation matrix of the sprite, and then it is combined with the skewMatrix using the concat() method. This matrix is assigned to the assigned to the transform.matrix property of the square sprite. Each time the user clicks the square, the call to the clickHandler() modifies the shape of the square, by skewing it.
package {
    import flash.display.Sprite;
    import flash.display.GradientType;
    import flash.geom.Matrix;
    import flash.events.MouseEvent;

    public class TransformExample extends Sprite {
        public function TransformExample() {
            var target:Sprite = new Sprite();
            draw(target);
            addChild(target);
            target.useHandCursor = true;
            target.buttonMode = true;
            target.addEventListener(MouseEvent.CLICK, clickHandler)
        }
        public function draw(sprite:Sprite):void {
            var red:uint = 0xFF0000;
            var green:uint = 0x00FF00;
            var blue:uint = 0x0000FF;
            var size:Number = 100;
            sprite.graphics.beginGradientFill(GradientType.LINEAR, [red, blue, green], [1, 0.5, 1], [0, 200, 255]);
            sprite.graphics.drawRect(0, 0, 100, 100);
        }
        public function clickHandler(event:MouseEvent):void {
            var skewMatrix:Matrix = new Matrix();
            skewMatrix.c = 0.25;
            var tempMatrix:Matrix = this.transform.matrix;
            tempMatrix.concat(skewMatrix);
            this.transform.matrix = tempMatrix;
        }
    }
}


flash.media Summary (Flex™ 2 Language Reference)

Package flash.media | Classes

The flash.media package contains classes for working with multimedia assets such as sound and video. It also contains the video and audio classes available in Flash Communication Server.

Classes
Class | Description
Camera | The Camera class is primarily for use with Flash Media Server, but can be used in a limited way without the server.
ID3Info | The ID3Info class contains properties that reflect ID3 metadata.
Microphone | The Microphone class lets you capture audio from a microphone attached to the computer that is running Flash Player.
Sound | The Sound class lets you work with sound in an application.
SoundChannel | The SoundChannel class controls a sound in an application.
SoundLoaderContext | The SoundLoaderContext class provides security checks for SWF files that load sound.
SoundMixer | The SoundMixer class contains static properties and methods for global sound control in the SWF file.
SoundTransform | The SoundTransform class contains properties for volume and panning.
Video | The Video class enables you to display live streaming video in an application without embedding it in your SWF file.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.media.Camera (Flex™ 2 Language Reference)

Class Camera | Properties | Methods | Events | Examples
Package | flash.media
Class | public final class Camera
Inheritance | Camera Inheritance EventDispatcher Inheritance Object

The Camera class is primarily for use with Flash Media Server, but can be used in a limited way without the server.

The Camera class lets you capture video from a video camera attached to the computer that is running Adobe Flash Player—for example, to monitor a video feed from a web camera attached to your local system. (Flash provides similar audio capabilities; for more information, see the Microphone class entry.)

Warning: When a SWF file tries to access the camera returned by the getCamera() method, Flash Player displays a dialog box that lets the user allow or deny access to the camera. (Make sure your application window size is at least 215 x 138 pixels for the Camera class examples; this is the minimum size Flash requires to display the dialog box.) End users and administrative users can also disable camera access on a per-site or global basis.

To create or reference a Camera object, use the getCamera() method.

View the examples.

See also

flash.media.Microphone

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | activityLevel : Number [read-only] A numeric value that specifies the amount of motion the camera is detecting. | Camera
 | bandwidth : int [read-only] An integer that specifies the maximum amount of bandwidth the current outgoing video feed can use, in bytes. | Camera
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentFPS : Number [read-only] The rate at which the camera is capturing data, in frames per second. | Camera
 | fps : Number [read-only] The maximum rate at which you want the camera to capture data, in frames per second. | Camera
 | height : int [read-only] The current capture height, in pixels. | Camera
 | index : int [read-only] A zero-based integer that specifies the index of the camera, as reflected in the array returned by the names property. | Camera
 | keyFrameInterval : int [read-only] Specifies which video frames are transmitted in full (called keyframes) instead of being interpolated by the video compression algorithm. | Camera
 | loopback : Boolean [read-only] Specifies whether a local view of what the camera is capturing is compressed and decompressed (true), as it would be for live transmission using Flash Media Server, or uncompressed (false). | Camera
 | motionLevel : int [read-only] A numeric value that specifies the amount of motion required to invoke the activity event. | Camera
 | motionTimeout : int [read-only] The number of milliseconds between the time the camera stops detecting motion and the time the activity event is invoked. | Camera
 | muted : Boolean [read-only] A Boolean value that specifies whether the user has denied access to the camera (true) or allowed access (false) in the Flash Player Privacy panel. | Camera
 | name : String [read-only] A string that specifies the name of the current camera, as returned by the camera hardware. | Camera
 | names : Array [static][read-only] Retrieves an array of strings reflecting the names of all available cameras without displaying the Flash Player Privacy panel. | Camera
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : int [read-only] An integer specifying the required level of picture quality, as determined by the amount of compression being applied to each video frame. | Camera
 | width : int [read-only] The current capture width, in pixels. | Camera
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getCamera(name:String = null):Camera
[static] Returns a reference to a Camera object for capturing video.
Camera
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setKeyFrameInterval(keyFrameInterval:int):void
Specifies which video frames are transmitted in full (called keyframes) instead of being interpolated by the video compression algorithm.
Camera
setLoopback(compress:Boolean = false):void
Specifies whether to use a compressed video stream for a local view of the camera.
Camera
setMode(width:int, height:int, fps:Number, favorArea:Boolean = true):void
Sets the camera capture mode to the native mode that best meets the specified requirements.
Camera
setMotionLevel(motionLevel:int, timeout:int = 2000):void
Specifies how much motion is required to dispatch the activity event.
Camera
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setQuality(bandwidth:int, quality:int):void
Sets the maximum amount of bandwidth per second or the required picture quality of the current outgoing video feed.
Camera
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | activity | Dispatched when a camera begins or ends a session. | Camera
 | status | Dispatched when a camera reports its status. | Camera
Property detail
activityLevel property
activityLevel:Number [read-only]

A numeric value that specifies the amount of motion the camera is detecting. Values range from 0 (no motion is being detected) to 100 (a large amount of motion is being detected). The value of this property can help you determine if you need to pass a setting to the setMotionLevel() method.

If the camera is available but is not yet being used because the Video.attachCamera() method has not been called, this property is set to -1.

If you are streaming only uncompressed local video, this property is set only if you have assigned a function to the event handler. Otherwise, it is undefined.

Implementation
    public function get activityLevel():Number

See also

motionLevel
setMotionLevel()
bandwidth property
bandwidth:int [read-only]

An integer that specifies the maximum amount of bandwidth the current outgoing video feed can use, in bytes. A value of 0 means that Flash video can use as much bandwidth as needed to maintain the desired frame quality.

To set this property, use the setQuality() method.

Implementation
    public function get bandwidth():int

See also

setQuality()
currentFPS property
currentFPS:Number [read-only]

The rate at which the camera is capturing data, in frames per second. This property cannot be set; however, you can use the setMode() method to set a related property—fps—which specifies the maximum frame rate at which you would like the camera to capture data.

Implementation
    public function get currentFPS():Number

See also

setMode()
fps property
fps:Number [read-only]

The maximum rate at which you want the camera to capture data, in frames per second. The maximum rate possible depends on the capabilities of the camera; that is, if the camera doesn't support the value you set here, this frame rate will not be achieved.

  • To set a desired value for this property, use the setMode() method.
  • To determine the rate at which the camera is currently capturing data, use the currentFPS property.

Implementation
    public function get fps():Number

See also

currentFPS
setMode()
height property
height:int [read-only]

The current capture height, in pixels. To set a value for this property, use the setMode() method.

Implementation
    public function get height():int

See also

width
setMode()
index property
index:int [read-only]

A zero-based integer that specifies the index of the camera, as reflected in the array returned by the names property.

Implementation
    public function get index():int

See also

names
getCamera()
keyFrameInterval property
keyFrameInterval:int [read-only]

Specifies which video frames are transmitted in full (called keyframes) instead of being interpolated by the video compression algorithm. The default value is 15, which means that every 15th frame is a keyframe.

Implementation
    public function get keyFrameInterval():int
loopback property
loopback:Boolean [read-only]

Specifies whether a local view of what the camera is capturing is compressed and decompressed (true), as it would be for live transmission using Flash Media Server, or uncompressed (false). The default value is false.

To set this value, use Camera.setLoopback(). To set the amount of compression used when this property is true, use Camera.setQuality().

Implementation
    public function get loopback():Boolean

See also

setLoopback()
setQuality()
motionLevel property
motionLevel:int [read-only]

A numeric value that specifies the amount of motion required to invoke the activity event. Acceptable values range from 0 to 100. The default value is 50.

Video can be displayed regardless of the value of the motionLevel property. For more information, see setMotionLevel().

Implementation
    public function get motionLevel():int

See also

setMotionLevel()
motionTimeout property
motionTimeout:int [read-only]

The number of milliseconds between the time the camera stops detecting motion and the time the activity event is invoked. The default value is 2000 (2 seconds).

To set this value, use setMotionLevel().

Implementation
    public function get motionTimeout():int

See also

setMotionLevel()
muted property
muted:Boolean [read-only]

A Boolean value that specifies whether the user has denied access to the camera (true) or allowed access (false) in the Flash Player Privacy panel. When this value changes, the statusevent is dispatched.

Implementation
    public function get muted():Boolean

See also

getCamera()
status
name property
name:String [read-only]

A string that specifies the name of the current camera, as returned by the camera hardware.

Implementation
    public function get name():String

See also

names
getCamera()
names property
names:Array [read-only]

Retrieves an array of strings reflecting the names of all available cameras without displaying the Flash Player Privacy panel. This array behaves in the same way as any other ActionScript array, implicitly providing the zero-based index of each camera and the number of cameras on the system (by means of names.length). For more information, see the names Array class entry.

Calling the names property requires an extensive examination of the hardware, and it may take several seconds to build the array. In most cases, you can just use the default camera.

Implementation
    public static function get names():Array

See also

getCamera()
index
name
quality property
quality:int [read-only]

An integer specifying the required level of picture quality, as determined by the amount of compression being applied to each video frame. Acceptable quality values range from 1 (lowest quality, maximum compression) to 100 (highest quality, no compression). The default value is 0, which means that picture quality can vary as needed to avoid exceeding available bandwidth.

To set this property, use the setQuality() method.

Implementation
    public function get quality():int

See also

setQuality()
width property
width:int [read-only]

The current capture width, in pixels. To set a desired value for this property, use the setMode() method.

Implementation
    public function get width():int

See also

setMode()
Method detail
getCamera () method
public static function getCamera(name:String = null):Camera

Returns a reference to a Camera object for capturing video. To actually begin capturing the video, you must attach the Camera object to a Video object (see Video.attachVideo() ).

Multiple calls to the getCamera() method reference the same camera. Thus, if your code contains code like firstCam:Camera = getCamera() and secondCam:Camera = getCamera(), both firstCam and secondCam reference the same camera, which is the user's default camera.

In general, you shouldn't pass a value for the name parameter; simply use getCamera() to return a reference to the default camera. By means of the Camera settings panel (discussed later in this section), the user can specify the default camera Flash should use.

When a SWF file tries to access the camera returned by getCamera(), Flash Player displays a dialog box that lets the user choose whether to allow or deny access to the camera. (Make sure your application window size is at least 215 x 138 pixels; this is the minimum size Flash requires to display the dialog box.) When the user responds to this dialog box, Flash Player returns an information object in the status event that indicates the user's response: Camera.muted indicates the user denied access to a camera; Camera.unmuted indicates the user allowed access to a camera. To determine whether the user has denied or allowed access to the camera without handling the status event, use the muted property.

The user can also specify permanent privacy settings for a particular domain by right-clicking (Windows) or Control-clicking (Macintosh) while a SWF file is playing, selecting Settings, opening the Privacy panel, and selecting Remember.

You can't use ActionScript to set the Allow or Deny value for a user, but you can display the Privacy panel for the user by calling Security.showSettings(SecurityPanel.PRIVACY). If the user selects Remember, Flash Player no longer asks the user whether to allow or deny SWF files from this domain access to your camera.

If getCamera() returns null, either the camera is in use by another application, or there are no cameras installed on the system. To determine whether any cameras are installed, use the names.length property. To display the Flash Player Camera Settings panel, which lets the user choose the camera to be referenced by getCamera(), use System.showSettings(SecurityPanel.CAMERA).

Scanning the hardware for cameras takes time. When Flash finds at least one camera, the hardware is not scanned again for the lifetime of the player instance. However, if Flash doesn't find any cameras, it will scan each time getCamera is called. This is helpful if a user has forgotten to connect the camera; if your SWF file provides a Try Again button that calls getCamera, Flash can find the camera without the user having to restart the SWF file.

Parameters
name:String (default = null) — Specifies which camera to get, as determined from the array returned by the names property. For most applications, get the default camera by omitting this parameter.

Returns
Camera — If the name parameter is not specified, this method returns a reference to the default camera or, if it is in use by another application, to the first available camera. (If there is more than one camera installed, the user may specify the default camera in the Flash Player Camera Settings panel.) If no cameras are available or installed, the method returns null.

Events
status:StatusEvent — Dispatched when a camera reports its status. If the value of the code property is "Camera.muted", the user has refused to allow the SWF file access to the user's camera. If the value of the code property is "Camera.unmuted", the user has allowed the SWF file access to the user's camera.

See also

index
muted
names
setMode()
status
Video.attachCamera()
setKeyFrameInterval () method
public function setKeyFrameInterval(keyFrameInterval:int):void

Specifies which video frames are transmitted in full (called keyframes) instead of being interpolated by the video compression algorithm. This method is generally applicable only if you are transmitting video using Flash Media Server.

The Flash Video compression algorithm compresses video by transmitting only what has changed since the last frame of the video; these portions are considered to be interpolated frames. Frames of a video can be interpolated according to the contents of the previous frame. A keyframe, however, is a video frame that is complete; it is not interpolated from prior frames.

To determine how to set a value for the keyFrameInterval parameter, consider both bandwidth use and video playback accessibility. For example, specifying a higher value for keyFrameInterval (sending keyframes less frequently) reduces bandwidth use. However, this may increase the amount of time required to position the playhead at a particular point in the video; more prior video frames may have to be interpolated before the video can resume.

Conversely, specifying a lower value for keyFrameInterval (sending keyframes more frequently) increases bandwidth use because entire video frames are transmitted more often, but may decrease the amount of time required to seek a particular video frame within a recorded video.

Parameters
keyFrameInterval:int — A value that specifies which video frames are transmitted in full (as keyframes) instead of being interpolated by the video compression algorithm. A value of 1 means that every frame is a keyframe, a value of 3 means that every third frame is a keyframe, and so on. Acceptable values are 1 through 48.

See also

keyFrameInterval
setLoopback () method
public function setLoopback(compress:Boolean = false):void

Specifies whether to use a compressed video stream for a local view of the camera. This method is generally applicable only if you are transmitting video using Flash Media Server; setting compress to true lets you see more precisely how the video will appear to users when they view it in real time.

Although a compressed stream is useful for testing purposes, such as previewing video quality settings, it has a significant processing cost, because the local view is not simply compressed; it is compressed, edited for transmission as it would be over a live connection, and then decompressed for local viewing.

To set the amount of compression used when you set compress to true, use Camera.setQuality().

Parameters
compress:Boolean (default = false) — Specifies whether to use a compressed video stream (true) or an uncompressed stream (false) for a local view of what the camera is receiving.

See also

setQuality()
setMode () method
public function setMode(width:int, height:int, fps:Number, favorArea:Boolean = true):void

Sets the camera capture mode to the native mode that best meets the specified requirements. If the camera does not have a native mode that matches all the parameters you pass, Flash selects a capture mode that most closely synthesizes the requested mode. This manipulation may involve cropping the image and dropping frames.

By default, Flash drops frames as needed to maintain image size. To minimize the number of dropped frames, even if this means reducing the size of the image, pass false for the favorArea parameter.

When choosing a native mode, Flash tries to maintain the requested aspect ratio whenever possible. For example, if you issue the command myCam.setMode(400, 400, 30), and the maximum width and height values available on the camera are 320 and 288, Flash sets both the width and height at 288; by setting these properties to the same value, Flash maintains the 1:1 aspect ratio you requested.

To determine the values assigned to these properties after Flash selects the mode that most closely matches your requested values, use the width, height, and fps properties.

Parameters
width:int — The requested capture width, in pixels. The default value is 160.
height:int — The requested capture height, in pixels. The default value is 120.
fps:Number — The requested rate at which the camera should capture data, in frames per second. The default value is 15.
favorArea:Boolean (default = true) — Specifies whether to manipulate the width, height, and frame rate if the camera does not have a native mode that meets the specified requirements. The default value is true, which means that maintaining capture size is favored; using this parameter selects the mode that most closely matches width and height values, even if doing so adversely affects performance by reducing the frame rate. To maximize frame rate at the expense of camera height and width, pass false for the favorArea parameter.

See also

fps
height
width
setMotionLevel () method
public function setMotionLevel(motionLevel:int, timeout:int = 2000):void

Specifies how much motion is required to dispatch the activity event. Optionally sets the number of milliseconds that must elapse without activity before Flash considers motion to have stopped and dispatches the event.

Note: Video can be displayed regardless of the value of the motionLevel parameter. This parameter determines only when and under what circumstances the event is dispatched—not whether video is actually being captured or displayed.

  • To prevent the camera from detecting motion at all, pass a value of 100 for the motionLevel parameter; the activity event is never dispatched. (You would probably use this value only for testing purposes—for example, to temporarily disable any handlers that would normally be triggered when the event is dispatched.)
  • To determine the amount of motion the camera is currently detecting, use the activityLevel property.

    Motion sensitivity values correspond directly to activity values. Complete lack of motion is an activity value of 0. Constant motion is an activity value of 100. Your activity value is less than your motion sensitivity value when you're not moving; when you are moving, activity values frequently exceed your motion sensitivity value.

This method is similar in purpose to the Microphone.setSilenceLevel() method; both methods are used to specify when the activity event should be dispatched. However, these methods have a significantly different impact on publishing streams:

  • Microphone.setSilenceLevel() is designed to optimize bandwidth. When an audio stream is considered silent, no audio data is sent. Instead, a single message is sent, indicating that silence has started.
  • setMotionLevel() is designed to detect motion and does not affect bandwidth usage. Even if a video stream does not detect motion, video is still sent.
Parameters
motionLevel:int — Specifies the amount of motion required to dispatch the activity event. Acceptable values range from 0 to 100. The default value is 50.
timeout:int (default = 2000) — Specifies how many milliseconds must elapse without activity before Flash considers activity to have stopped and dispatches the activity event. The default value is 2000 milliseconds (2 seconds).

See also

motionLevel
motionTimeout
Microphone.setSilenceLevel()
setQuality () method
public function setQuality(bandwidth:int, quality:int):void

Sets the maximum amount of bandwidth per second or the required picture quality of the current outgoing video feed. This method is generally applicable only if you are transmitting video using Flash Media Server.

Use this method to specify which element of the outgoing video feed is more important to your application—bandwidth use or picture quality.

  • To indicate that bandwidth use takes precedence, pass a value for bandwidth and 0 for quality. Flash will transmit video at the highest quality possible within the specified bandwidth. If necessary, Flash will reduce picture quality to avoid exceeding the specified bandwidth. In general, as motion increases, quality decreases.
  • To indicate that quality takes precedence, pass 0 for bandwidth and a numeric value for quality. Flash will use as much bandwidth as required to maintain the specified quality. If necessary, Flash will reduce the frame rate to maintain picture quality. In general, as motion increases, bandwidth use also increases.
  • To specify that both bandwidth and quality are equally important, pass numeric values for both parameters. Flash will transmit video that achieves the specified quality and that doesn't exceed the specified bandwidth. If necessary, Flash will reduce the frame rate to maintain picture quality without exceeding the specified bandwidth.
Parameters
bandwidth:int — Specifies the maximum amount of bandwidth that the current outgoing video feed can use, in bytes per second. To specify that Flash video can use as much bandwidth as needed to maintain the value of quality, pass 0 for bandwidth. The default value is 16384.
quality:int — An integer that specifies the required level of picture quality, as determined by the amount of compression being applied to each video frame. Acceptable values range from 1 (lowest quality, maximum compression) to 100 (highest quality, no compression). To specify that picture quality can vary as needed to avoid exceeding bandwidth, pass 0 for quality.

See also

getCamera()
quality
Event detail
activity event
Event object type: flash.events.ActivityEvent
ActivityEvent.type property = flash.events.ActivityEvent.ACTIVITY

Dispatched when a camera begins or ends a session.

The ActivityEvent.ACTIVITY constant defines the value of the type property of an activity event object.

This event has the following properties:

Property | Value
activating | true if the device is activating or false if it is deactivating.
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object beginning or ending a session, such as a Camera or Microphone object.
status event
Event object type: flash.events.StatusEvent
StatusEvent.type property = flash.events.StatusEvent.STATUS

Dispatched when a camera reports its status. If the value of the code property is "Camera.muted", the user has refused to allow the SWF file access to the user's camera. If the value of the code property is "Camera.unmuted", the user has allowed the SWF file access to the user's camera.

Defines the value of the type property of a status event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
code | A description of the object's status.
currentTarget | The object that is actively processing the Event object with an event listener.
level | The category of the message, such as "status", "warning" or "error".
target | The object reporting its status.

See also

Camera.getCamera()
Examples

The following example shows the image from a camera after acknowledging the security warning. The Stage is set such that it cannot be scaled and is aligned to the top-left of the player window. The activity event is dispatched at the start and end (if any) of the session and is captured by the activityHandler() method, which prints out information about the event.

Note: A camera must be attached to your computer for this example to work correctly.

package {
    import flash.display.Sprite;
    import flash.display.StageAlign;
    import flash.display.StageScaleMode;
    import flash.events.*;
    import flash.media.Camera;
    import flash.media.Video;

    public class CameraExample extends Sprite {
        private var video:Video;

        public function CameraExample() {
            stage.scaleMode = StageScaleMode.NO_SCALE;
            stage.align = StageAlign.TOP_LEFT;

            var camera:Camera = Camera.getCamera();

            if (camera != null) {
                camera.addEventListener(ActivityEvent.ACTIVITY, activityHandler);
                video = new Video(camera.width * 2, camera.height * 2);
                video.attachCamera(camera);
                addChild(video);
            } else {
                trace("You need a camera.");
            }
        }

        private function activityHandler(event:ActivityEvent):void {
            trace("activityHandler: " + event);
        }
    }
}


flash.media.ID3Info (Flex™ 2 Language Reference)

Class ID3Info | Properties | Methods
Package | flash.media
Class | public final dynamic class ID3Info
Inheritance | ID3Info Inheritance Object

The ID3Info class contains properties that reflect ID3 metadata. You can get additional metadata for MP3 files by accessing the id3 property of the Sound class; for example, mySound.id3.TIME. For more information, see the entry for Sound.id3 and the ID3 tag definitions at http://www.id3.org.

See also

Sound.id3

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | album : String The name of the album; corresponds to the ID3 2.0 tag TALB. | ID3Info
 | artist : String The name of the artist; corresponds to the ID3 2.0 tag TPE1. | ID3Info
 | comment : String A comment about the recording; corresponds to the ID3 2.0 tag COMM. | ID3Info
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | genre : String The genre of the song; corresponds to the ID3 2.0 tag TCON. | ID3Info
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | songName : String The name of the song; corresponds to the ID3 2.0 tag TIT2. | ID3Info
 | track : String The track number; corresponds to the ID3 2.0 tag TRCK. | ID3Info
 | year : String The year of the recording; corresponds to the ID3 2.0 tag TYER. | ID3Info
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
album property
public var album:String

The name of the album; corresponds to the ID3 2.0 tag TALB.

artist property
public var artist:String

The name of the artist; corresponds to the ID3 2.0 tag TPE1.

comment property
public var comment:String

A comment about the recording; corresponds to the ID3 2.0 tag COMM.

genre property
public var genre:String

The genre of the song; corresponds to the ID3 2.0 tag TCON.

songName property
public var songName:String

The name of the song; corresponds to the ID3 2.0 tag TIT2.

track property
public var track:String

The track number; corresponds to the ID3 2.0 tag TRCK.

year property
public var year:String

The year of the recording; corresponds to the ID3 2.0 tag TYER.


flash.media.Microphone (Flex™ 2 Language Reference)

Class Microphone | Properties | Methods | Events | Examples
Package | flash.media
Class | public final class Microphone
Inheritance | Microphone Inheritance EventDispatcher Inheritance Object

The Microphone class lets you capture audio from a microphone attached to the computer that is running Flash Player.

The Microphone class is primarily for use with a server, such as Flash Media Server or Flex. However, you can also use the Microphone class in a limited fashion without a server—for example, to transmit sound from the microphone through the speakers on the local computer. You attach a Microphone object to a NetStream object to stream audio from a microphone.

Caution: Flash Player displays a Privacy dialog box that lets the user choose whether to allow or deny access to the microphone. Make sure that your application window size is at least 215 x 138 pixels; this is the minimum size required to display the dialog box.

To create or reference a Microphone object, use the Microphone.getMicrophone() method.

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | activityLevel : Number [read-only] The amount of sound the microphone is detecting. | Microphone
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | gain : Number The microphone gain—that is, the amount by which the microphone should multiply the signal before transmitting it. | Microphone
 | index : int [read-only] The index of the microphone, as reflected in the array returned by Microphone.names. | Microphone
 | muted : Boolean [read-only] Specifies whether the user has denied access to the microphone (true) or allowed access (false). | Microphone
 | name : String [read-only] The name of the current sound capture device, as returned by the sound capture hardware. | Microphone
 | names : Array [static][read-only] The names of all available sound capture devices. | Microphone
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rate : int The rate at which the microphone is capturing sound, in kHz. | Microphone
 | silenceLevel : Number [read-only] The amount of sound required to activate the microphone and dispatch the activity event. | Microphone
 | silenceTimeout : int [read-only] The number of milliseconds between the time the microphone stops detecting sound and the time the activity event is dispatched. | Microphone
 | soundTransform : SoundTransform Controls the sound of this microphone object when it is in loopback mode. | Microphone
 | useEchoSuppression : Boolean [read-only] Returns true if echo suppression is enabled; false otherwise. | Microphone
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getMicrophone(index:int = 0):Microphone
[static] To create or reference a Microphone object, use the Microphone.getMicrophone() method to get the index value of the current microphone.
Microphone
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setLoopBack(state:Boolean = true):void
Sets the microphone into loopback mode or turns it off.
Microphone
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setSilenceLevel(silenceLevel:Number, timeout:int = -1):void
Sets the minimum input level that should be considered sound and (optionally) the amount of silent time signifying that silence has actually begun.
Microphone
setUseEchoSuppression(useEchoSuppression:Boolean):void
Specifies whether to use the echo suppression feature of the audio codec.
Microphone
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | activity | Dispatched when a microphone begins or ends a session. | Microphone
 | status | Dispatched when a microphone reports its status. | Microphone
Property detail
activityLevel property
activityLevel:Number [read-only]

The amount of sound the microphone is detecting. Values range from 0 (no sound is detected) to 100 (very loud sound is detected). The value of this property can help you determine a good value to pass to the Microphone.setSilenceLevel() method.

If the microphone is available but is not yet being used because Microphone.getMicrophone() has not been called, this property is set to -1.

Implementation
    public function get activityLevel():Number

See also

flash.media.Microphone.getMicrophone()
flash.media.Microphone.setSilenceLevel()
flash.media.Microphone.gain
gain property
gain:Number [read-write]

The microphone gain—that is, the amount by which the microphone should multiply the signal before transmitting it. A value of 0 tells Flash to multiply by 0; that is, the microphone transmits no sound.

You can think of this setting like a volume knob on a stereo: 0 is no volume and 50 is normal volume. Numbers below 50 specify lower than normal volume, while numbers above 50 specify higher than normal volume. Valid values are 0-100. The user can change this value in the Flash Player Microphone Settings panel.

Implementation
    public function get gain():Number
    public function set gain(value:Number):void

See also

flash.media.Microphone.setUseEchoSuppression()
index property
index:int [read-only]

The index of the microphone, as reflected in the array returned by Microphone.names.

Implementation
    public function get index():int

See also

flash.media.Microphone.getMicrophone()
flash.media.Microphone.names
muted property
muted:Boolean [read-only]

Specifies whether the user has denied access to the microphone (true) or allowed access (false). When this value changes, Microphone.onStatus is invoked. For more information, see Microphone.getMicrophone().

Implementation
    public function get muted():Boolean

See also

flash.media.Microphone.getMicrophone()
flash.media.Microphone.status
name property
name:String [read-only]

The name of the current sound capture device, as returned by the sound capture hardware.

Implementation
    public function get name():String

See also

flash.media.Microphone.getMicrophone()
flash.media.Microphone.names
names property
names:Array [read-only]

The names of all available sound capture devices. The names are returned without having to display the Flash Player Privacy Settings panel to the user. This array provides the zero-based index of each sound capture device and the number of sound capture devices on the system, through the Microphone.names.length property. For more information, see the Array class entry.

Calling Microphone.names requires an extensive examination of the hardware, and it may take several seconds to build the array. In most cases, you can just use the default microphone.

Note: To determine the name of the current microphone, use the name property.

Implementation
    public static function get names():Array

See also

flash.media.Microphone.name
flash.media.Microphone.getMicrophone()
rate property
rate:int [read-write]

The rate at which the microphone is capturing sound, in kHz. The default value is 8 kHz if your sound capture device supports this value. Otherwise, the default value is the next available capture level above 8 kHz that your sound capture device supports, usually 11 kHz.

Implementation
    public function get rate():int
    public function set rate(value:int):void
silenceLevel property
silenceLevel:Number [read-only]

The amount of sound required to activate the microphone and dispatch the activity event. The default value is 10.

Implementation
    public function get silenceLevel():Number

See also

flash.media.Microphone.gain
flash.media.Microphone.setSilenceLevel()
silenceTimeout property
silenceTimeout:int [read-only]

The number of milliseconds between the time the microphone stops detecting sound and the time the activity event is dispatched. The default value is 2000 (2 seconds).

To set this value, use the Microphone.setSilenceLevel() method.

Implementation
    public function get silenceTimeout():int

See also

flash.media.Microphone.setSilenceLevel()
soundTransform property
soundTransform:SoundTransform [read-write]

Controls the sound of this microphone object when it is in loopback mode.

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void
useEchoSuppression property
useEchoSuppression:Boolean [read-only]

Returns true if echo suppression is enabled; false otherwise. The default value is false unless the user has selected Reduce Echo in the Flash Player Microphone Settings panel.

Implementation
    public function get useEchoSuppression():Boolean

See also

flash.media.Microphone.setUseEchoSuppression()
Method detail
getMicrophone () method
public static function getMicrophone(index:int = 0):Microphone

To create or reference a Microphone object, use the Microphone.getMicrophone() method to get the index value of the current microphone. You can then pass this value to methods of the Microphone class.

Parameters
index:int (default = 0) — The index value of the microphone.

Returns
Microphone

Events
status:StatusEvent — Dispatched when a microphone reports its status. If the value of the code property is "Microphone.muted", the user has refused to allow the SWF file access to the user's microphone. If the value of the code property is "Microphone.unmuted", the user has allowed the SWF file access to the user's microphone.

See also

Microphone.status
setLoopBack () method
public function setLoopBack(state:Boolean = true):void

Sets the microphone into loopback mode or turns it off. This method reroutes microphone sound to the local speaker.

Parameters
state:Boolean (default = true)
setSilenceLevel () method
public function setSilenceLevel(silenceLevel:Number, timeout:int = -1):void

Sets the minimum input level that should be considered sound and (optionally) the amount of silent time signifying that silence has actually begun.

  • To prevent the microphone from detecting sound at all, pass a value of 100 for silenceLevel; the activity is never dispatched.
  • To determine the amount of sound the microphone is currently detecting, use Microphone.activityLevel.

Activity detection is the ability to detect when audio levels suggest that a person is talking. When someone is not talking, bandwidth can be saved because there is no need to send the associated audio stream. This information can also be used for visual feedback so that users know they (or others) are silent.

Silence values correspond directly to activity values. Complete silence is an activity value of 0. Constant loud noise (as loud as can be registered based on the current gain setting) is an activity value of 100. After gain is appropriately adjusted, your activity value is less than your silence value when you're not talking; when you are talking, the activity value exceeds your silence value.

This method is similar in purpose to Camera.setMotionLevel(); both methods are used to specify when the activity event is dispatched. However, these methods have a significantly different impact on publishing streams:

  • Camera.setMotionLevel() is designed to detect motion and does not affect bandwidth usage. Even if a video stream does not detect motion, video is still sent.
  • Microphone.setSilenceLevel() is designed to optimize bandwidth. When an audio stream is considered silent, no audio data is sent. Instead, a single message is sent, indicating that silence has started.
Parameters
silenceLevel:Number — The amount of sound required to activate the microphone and dispatch the activity event. Acceptable values range from 0 to 100.
timeout:int (default = -1) — The number of milliseconds that must elapse without activity before Flash Player considers sound to have stopped and dispatches the dispatch event. The default value is 2000 (2 seconds). (Note: The default value shown in the signature, -1, is an internal value that indicates to Flash Player to use 2000.)

See also

flash.media.Camera.setMotionLevel()
flash.media.Microphone.activityLevel
flash.media.Microphone.activity
flash.media.Microphone.gain
flash.media.Microphone.silenceLevel
flash.media.Microphone.silenceTimeout
setUseEchoSuppression () method
public function setUseEchoSuppression(useEchoSuppression:Boolean):void

Specifies whether to use the echo suppression feature of the audio codec. The default value is false unless the user has selected Reduce Echo in the Flash Player Microphone Settings panel.

Echo suppression is an effort to reduce the effects of audio feedback, which is caused when sound going out the speaker is picked up by the microphone on the same computer. (This is different from echo cancellation, which completely removes the feedback.)

Generally, echo suppression is advisable when the sound being captured is played through speakers — instead of a headset — on the same computer. If your SWF file allows users to specify the sound output device, you may want to call Microphone.setUseEchoSuppression(true) if they indicate they are using speakers and will be using the microphone as well.

Users can also adjust these settings in the Flash Player Microphone Settings panel.

Parameters
useEchoSuppression:Boolean — A Boolean value indicating whether echo suppression should be used (true) or not (false).

See also

flash.media.Microphone.setUseEchoSuppression()
flash.media.Microphone.useEchoSuppression
Event detail
activity event
Event object type: flash.events.ActivityEvent
ActivityEvent.type property = flash.events.ActivityEvent.ACTIVITY

Dispatched when a microphone begins or ends a session.

The ActivityEvent.ACTIVITY constant defines the value of the type property of an activity event object.

This event has the following properties:

Property | Value
activating | true if the device is activating or false if it is deactivating.
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object beginning or ending a session, such as a Camera or Microphone object.
status event
Event object type: flash.events.StatusEvent
StatusEvent.type property = flash.events.StatusEvent.STATUS

Dispatched when a microphone reports its status. If the value of the code property is "Microphone.muted", the user has refused to allow the SWF file access to the user's microphone. If the value of the code property is "Microphone.unmuted", the user has allowed the SWF file access to the user's microphone.

Defines the value of the type property of a status event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
code | A description of the object's status.
currentTarget | The object that is actively processing the Event object with an event listener.
level | The category of the message, such as "status", "warning" or "error".
target | The object reporting its status.

See also

Microphone.getMicrophone()
Examples

The following example captures sound using echo suppression from a microphone after the user allows access to their computer's microphone. The Security.showSettings() method displays the Flash Player dialog box, which requests permission to access the user's microphone. The call to setLoopBack(true) reroutes input to the local speaker, so you can hear the sound while you run the example.

Two listeners listen for activity and status events. The activity event is dispatched at the start and end (if any) of the session and is captured by the activityHandler() method, which traces information on the event. The status event is dispatched if the attached microphone object reports any status information; it is captured and traced using the statusHandler() method.

Note: A microphone must be attached to your computer for this example to work correctly.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.media.Microphone;
    import flash.system.Security;

    public class MicrophoneExample extends Sprite {
        public function MicrophoneExample() {
            var mic:Microphone = Microphone.getMicrophone();
            Security.showSettings("2");
            mic.setLoopBack(true);

            if (mic != null) {
                mic.setUseEchoSuppression(true);
                mic.addEventListener(ActivityEvent.ACTIVITY, activityHandler);
                mic.addEventListener(StatusEvent.STATUS, statusHandler);
            }
        }

        private function activityHandler(event:ActivityEvent):void {
            trace("activityHandler: " + event);
        }

        private function statusHandler(event:StatusEvent):void {
            trace("statusHandler: " + event);
        }
    }
}


flash.media.Sound (Flex™ 2 Language Reference)

Class Sound | Properties | Methods | Events | Examples
Package | flash.media
Class | public class Sound
Inheritance | Sound Inheritance EventDispatcher Inheritance Object
Subclasses | SoundAsset

The Sound class lets you work with sound in an application. The Sound class lets you create a new Sound object, load and play an external MP3 file into that object, close the sound stream, and access data about the sound, such as information about the number of bytes in the stream and ID3 metadata. More detailed control of the sound is performed through the sound source — the SoundChannel or Microphone object for the sound — and through the properties in the SoundTransform class that control the output of the sound to the computer's speakers.

To control sounds that are embedded in a SWF file, use the properties in the SoundMixer class.

Note: The ActionScript 3.0 Sound API differs from ActionScript 2.0. In ActionScript 3.0, you cannot take sound objects and arrange them in a hierarchy to control their properties.

When you use this class, consider the Flash Player security model:

  • Loading and playing a sound is not allowed if the calling SWF file is in a network sandbox and the sound file to be loaded is local.
  • By default, loading and playing a sound is not allowed if the calling SWF is local and tries to load and play a remote sound. A user must grant explicit permission to allow this.
  • Certain operations dealing with sound are restricted. The data in a loaded sound cannot be accessed by a SWF file in a different domain unless you implement a cross-domain policy file. Sound-related APIs that fall under this restriction are Sound.id3, SoundMixer.computeSpectrum(), SoundMixer.bufferTime, and the SoundTransform class.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

View the examples.

See also

Microphone
SoundChannel
SoundMixer
SoundTransform

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bytesLoaded : uint [read-only] Returns the currently available number of bytes in this sound object. | Sound
 | bytesTotal : int [read-only] Returns the total number of bytes in this sound object. | Sound
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | id3 : ID3Info [read-only] Provides access to the metadata that is part of an MP3 file. | Sound
 | isBuffering : Boolean [read-only] Returns the buffering state of external MP3 files. | Sound
 | length : Number [read-only] The length of the current sound in milliseconds. | Sound
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | url : String [read-only] The URL from which this sound was loaded. | Sound
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Sound(stream:URLRequest = null, context:SoundLoaderContext = null)
Creates a new Sound object.
Sound
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
close():void
Closes the stream, causing any download of data to cease.
Sound
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
load(stream:URLRequest, context:SoundLoaderContext = null):void
Initiates loading of an external MP3 file from the specified URL.
Sound
play(startTime:Number = 0, loops:int = 0, sndTransform:SoundTransform = null):SoundChannel
Generates a new SoundChannel object to play back the sound.
Sound
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | complete | Dispatched when data has loaded successfully. | Sound
 | id3 | Dispatched by a Sound object when ID3 data is available for an MP3 sound. | Sound
 | ioError | Dispatched when an input/output error occurs that causes a load operation to fail. | Sound
 | open | Dispatched when a load operation starts. | Sound
 | progress | Dispatched when data is received as a load operation progresses. | Sound
Property detail
bytesLoaded property
bytesLoaded:uint [read-only]

Returns the currently available number of bytes in this sound object. This is usually only useful for externally loaded files.

Implementation
    public function get bytesLoaded():uint
bytesTotal property
bytesTotal:int [read-only]

Returns the total number of bytes in this sound object.

Implementation
    public function get bytesTotal():int
id3 property
id3:ID3Info [read-only]

Provides access to the metadata that is part of an MP3 file.

MP3 sound files can contain ID3 tags, which provide metadata about the file. If an MP3 sound that you load using the Sound.load() method contains ID3 tags, you can query these properties. Only ID3 tags that use the UTF-8 character set are supported.

Flash Player 9 and later supports ID3 2.0 tags, specifically 2.3 and 2.4. The following tables list the standard ID3 2.0 tags and the type of content the tags represent. The Sound.id3 property provides access to these tags through the format my_sound.id3.COMM, my_sound.id3.TIME, and so on. The first table describes tags that can be accessed either through the ID3 2.0 property name or the ActionScript property name. The second table describes ID3 tags that are supported but do not have predefined properties in ActionScript.

ID3 2.0 tag | Corresponding ActionScript property
COMM | Sound.id3.comment
TALB | Sound.id3.album
TCON | Sound.id3.genre
TIT2 | Sound.id3.songName
TPE1 | Sound.id3.artist
TRCK | Sound.id3.track
TYER | Sound.id3.year

The following table describes ID3 tags that are supported but do not have predefined properties in ActionScript. You access them by calling mySound.id3.TFLT, mySound.id3.TIME, and so on.

Property | Description
TFLT | File type
TIME | Time
TIT1 | Content group description
TIT2 | Title/song name/content description
TIT3 | Subtitle/description refinement
TKEY | Initial key
TLAN | Languages
TLEN | Length
TMED | Media type
TOAL | Original album/movie/show title
TOFN | Original filename
TOLY | Original lyricists/text writers
TOPE | Original artists/performers
TORY | Original release year
TOWN | File owner/licensee
TPE1 | Lead performers/soloists
TPE2 | Band/orchestra/accompaniment
TPE3 | Conductor/performer refinement
TPE4 | Interpreted, remixed, or otherwise modified by
TPOS | Part of a set
TPUB | Publisher
TRCK | Track number/position in set
TRDA | Recording dates
TRSN | Internet radio station name
TRSO | Internet radio station owner
TSIZ | Size
TSRC | ISRC (international standard recording code)
TSSE | Software/hardware and settings used for encoding
TYER | Year
WXXX | URL link frame

When using this property, consider the Flash Player security model:

  • The id3 property of a Sound object is always permitted for SWF files that are in the same security sandbox as the sound file. For files in other sandboxes, there are security checks.
  • When you load the sound, using the load() method of the Sound class, you can specify a context parameter, which is a SoundLoaderContext object. If you set the checkPolicyFile property of the SoundLoaderContext object to true, Flash Player checks for a cross-domain policy file on the server from which the sound is loaded. If there is a cross-domain policy file, and the file permits the domain of the loading SWF file, then the file is allowed to access the id3 property of the Sound object; otherwise it is not.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Implementation
    public function get id3():ID3Info

See also

SoundLoaderContext.checkPolicyFile
isBuffering property
isBuffering:Boolean [read-only]

Returns the buffering state of external MP3 files. If the value is true, any playback is currently suspended while the object waits for more data.

Implementation
    public function get isBuffering():Boolean
length property
length:Number [read-only]

The length of the current sound in milliseconds.

Implementation
    public function get length():Number
url property
url:String [read-only]

The URL from which this sound was loaded. This property is applicable only to Sound objects that were loaded using the Sound.load() method. For Sound objects that are associated with a sound asset from a SWF's library, the value of the url property is null.

When you first call Sound.load(), the url property initially has a value of null, because the final URL is not yet known. The url property will have a non-null value as soon as an open event is dispatched from the Sound object.

The url property contains the final, absolute URL from which a sound was loaded. The value of url is usually the same as the value passed to the stream parameter of Sound.load(). However, if you passed a relative URL to Sound.load() the value of the url property will represent the absolute URL. Additionally, if the original URL request is redirected by an HTTP server, the value of the url property reflects the final URL from which the sound file was actually downloaded. This reporting of an absolute, final URL is equivalent to the behavior of LoaderInfo.url.

Implementation
    public function get url():String

See also

flash.media.Sound.load()
flash.display.LoaderInfo.url
Constructor detail
Sound () constructor
public function Sound(stream:URLRequest = null, context:SoundLoaderContext = null)

Creates a new Sound object. If you pass a valid URLRequest object to the Sound constructor, the constructor automatically calls the load() function for the Sound object. If you do not pass a valid URLRequest object to the Sound constructor, you must call the load() function for the Sound object yourself, or the stream will not load.

Once load() is called on a Sound object, you can't later load a different sound file into that Sound object. To load a different sound file, create a new Sound object.

Parameters
stream:URLRequest (default = null) — The URL that points to an external MP3 file.
context:SoundLoaderContext (default = null) — Minimum number of milliseconds of MP3 data to hold in the Sound object's buffer. The Sound object waits until it has at least this much data before beginning playback and before resuming playback after a network stall. The default value is 1000 (one second).
Method detail
close () method
public function close():void

Closes the stream, causing any download of data to cease. No data may be read from the stream after the close() method is called.

Throws
IOError — The stream could not be closed, or the stream was not open.
load () method
public function load(stream:URLRequest, context:SoundLoaderContext = null):void

Initiates loading of an external MP3 file from the specified URL. If you provide a valid URLRequest object to the Sound constructor, the constructor calls Sound.load() for you. You only need to call Sound.load() yourself if you don't pass a valid URLRequest object to the Sound constructor or you pass a null value.

Once load() is called on a Sound object, you can't later load a different sound file into that Sound object. To load a different sound file, create a new Sound object.

When using this method, consider the Flash Player security model:
  • Calling Sound.load() is not allowed if the calling SWF file is in the local-with-file-system sandbox and the sound is in a network sandbox.
  • Access from the local-trusted or local-with-networking sandbox requires permission from a website through a cross-domain policy file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
stream:URLRequest — A URL that points to an external MP3 file.
context:SoundLoaderContext (default = null) — Minimum number of milliseconds of MP3 data to hold in the Sound object's buffer. The Sound object waits until it has at least this much data before beginning playback and before resuming playback after a network stall. The default value is 1000 (one second).

Throws
IOError — A network error caused the load to fail.
SecurityError — Local untrusted SWF files may not communicate with the Internet. You can work around this by reclassifying this SWF file as local-with-networking or trusted.
play () method
public function play(startTime:Number = 0, loops:int = 0, sndTransform:SoundTransform = null):SoundChannel

Generates a new SoundChannel object to play back the sound. This method returns a SoundChannel object, which you access to stop the sound and to monitor volume. (To control the volume, panning, and balance, access the SoundTransform object assigned to the sound channel.)

Parameters
startTime:Number (default = 0) — The initial position in milliseconds at which playback should start.
loops:int (default = 0) — Defines the number of times a sound loops before the sound channel stops playback.
sndTransform:SoundTransform (default = null) — The initial SoundTransform object assigned to the sound channel.

Returns
SoundChannel — A SoundChannel object, which you use to control the sound. This method returns null if you have no sound card or if you run out of available sound channels. The maximum number of sound channels available at once is 32.

See also

SoundChannel.stop()
SoundMixer.stopAll()
Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched when data has loaded successfully.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

Sound.load()
id3 event
Event object type: flash.events.Event
Event.type property = flash.events.Event.ID3

Dispatched by a Sound object when ID3 data is available for an MP3 sound.

Defines the value of the type property of an id3 event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Sound object loading the MP3 for which ID3 data is now available. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

Sound.id3
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input/output error occurs that causes a load operation to fail.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.

See also

Sound.load()
open event
Event object type: flash.events.Event
Event.type property = flash.events.Event.OPEN

Dispatched when a load operation starts.

Defines the value of the type property of an open event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has opened a connection.

See also

Sound.load()
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched when data is received as a load operation progresses.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.

See also

Sound.load()
Examples

The following example displays information about sound events that take place as an MP3 file is opened and played. To run this example, place a file named MySound.mp3 in the same directory as your SWF file.
package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.media.Sound;
    import flash.media.SoundChannel;
    import flash.net.URLRequest;

    public class SoundExample extends Sprite {
        private var url:String = "MySound.mp3";
        private var song:SoundChannel;

        public function SoundExample() {
            var request:URLRequest = new URLRequest(url);
            var soundFactory:Sound = new Sound();
            soundFactory.addEventListener(Event.COMPLETE, completeHandler);
            soundFactory.addEventListener(Event.ID3, id3Handler);
            soundFactory.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            soundFactory.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            soundFactory.load(request);
            song = soundFactory.play();
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function id3Handler(event:Event):void {
            trace("id3Handler: " + event);
        }

        private function ioErrorHandler(event:Event):void {
            trace("ioErrorHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler: " + event);
        }
    }
}


flash.media.SoundChannel (Flex™ 2 Language Reference)

Class SoundChannel | Properties | Methods | Events | Examples
Package | flash.media
Class | public final class SoundChannel
Inheritance | SoundChannel Inheritance EventDispatcher Inheritance Object

The SoundChannel class controls a sound in an application. Each sound playing in an Adobe® Flash® application is assigned to a sound channel, and the application can have multiple sound channels that are mixed together. The SoundChannel class contains a stop() method, properties for monitoring the amplitude (volume) of the channel, and a property for setting a SoundTransform object to the channel.

View the examples.

See also

Sound
SoundTransform

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | leftPeak : Number [read-only] The current amplitude (volume) of the left channel, from 0 (silent) to 1 (full amplitude). | SoundChannel
 | position : Number [read-only] The current position of the playhead within the sound. | SoundChannel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rightPeak : Number [read-only] The current amplitude (volume) of the right channel, from 0 (silent) to 1 (full amplitude). | SoundChannel
 | soundTransform : SoundTransform The SoundTransform object assigned to the sound channel. | SoundChannel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
stop():void
Stops the sound playing in the channel.
SoundChannel
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | soundComplete | Dispatched when a sound has finished playing. | SoundChannel
Property detail
leftPeak property
leftPeak:Number [read-only]

The current amplitude (volume) of the left channel, from 0 (silent) to 1 (full amplitude).

Implementation
    public function get leftPeak():Number
position property
position:Number [read-only]

The current position of the playhead within the sound. If the sound is looped, the position is reset to 0 at the beginning of each loop.

Implementation
    public function get position():Number
rightPeak property
rightPeak:Number [read-only]

The current amplitude (volume) of the right channel, from 0 (silent) to 1 (full amplitude).

Implementation
    public function get rightPeak():Number
soundTransform property
soundTransform:SoundTransform [read-write]

The SoundTransform object assigned to the sound channel. A SoundTransform object includes properties for setting volume, panning, left speaker assignment, and right speaker assignment.

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void

See also

SoundTransform
Method detail
stop () method
public function stop():void

Stops the sound playing in the channel.

Event detail
soundComplete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.SOUND_COMPLETE

Dispatched when a sound has finished playing.

Defines the value of the type property of a soundComplete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Sound object on which a sound has finished playing.
Examples

The following example loads an MP3 file, plays it, and displays information about sound events that take place as the MP3 file is loaded and played. A Timer object provides updated information about the position of the playhead every 50 milliseconds. To run this example, place a file named MySound.mp3 in the same directory as your SWF file.
package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.media.Sound;
    import flash.media.SoundChannel;
    import flash.net.URLRequest;
    import flash.utils.Timer;

    public class SoundChannelExample extends Sprite {
        private var url:String = "MySound.mp3";
        private var soundFactory:Sound;
        private var channel:SoundChannel;
        private var positionTimer:Timer;

        public function SoundChannelExample() {
            var request:URLRequest = new URLRequest(url);
            soundFactory = new Sound();
            soundFactory.addEventListener(Event.COMPLETE, completeHandler);
            soundFactory.addEventListener(Event.ID3, id3Handler);
            soundFactory.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            soundFactory.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            soundFactory.load(request);

            channel = soundFactory.play();
            channel.addEventListener(Event.SOUND_COMPLETE, soundCompleteHandler);

            positionTimer = new Timer(50);
            positionTimer.addEventListener(TimerEvent.TIMER, positionTimerHandler);
            positionTimer.start();
        }

        private function positionTimerHandler(event:TimerEvent):void {
            trace("positionTimerHandler: " + channel.position.toFixed(2));
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function id3Handler(event:Event):void {
            trace("id3Handler: " + event);
        }

        private function ioErrorHandler(event:Event):void {
            trace("ioErrorHandler: " + event);
            positionTimer.stop();
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler: " + event);
        }

        private function soundCompleteHandler(event:Event):void {
            trace("soundCompleteHandler: " + event);
            positionTimer.stop();
        }
    }
}


flash.media.SoundLoaderContext (Flex™ 2 Language Reference)

Class SoundLoaderContext | Properties | Methods
Package | flash.media
Class | public class SoundLoaderContext
Inheritance | SoundLoaderContext Inheritance Object

The SoundLoaderContext class provides security checks for SWF files that load sound. SoundLoaderContext objects are passed as an argument to the constructor and the load() method of the Sound class.

When you use this class, consider the Flash® Player security model:

  • Loading and playing a sound is not allowed if the calling SWF file is in a network sandbox and the sound file to be loaded is local.
  • By default, loading and playing a sound is not allowed if the calling SWF is local and tries to load and play a remote sound. A user must grant explicit permission to allow this.
  • Certain operations dealing with sound are restricted. The data in a loaded sound cannot be accessed by a SWF file in a different domain unless you implement a cross-domain policy file. Sound-related APIs that fall under this restriction are the Sound.id3 property and the SoundMixer.computeSpectrum(), SoundMixer.bufferTime, and SoundTransform() methods.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bufferTime : Number = 1000 The number of seconds to preload a streaming sound into a buffer before the sound starts to stream. | SoundLoaderContext
 | checkPolicyFile : Boolean = false Specifies whether Flash Player should try to download a cross-domain policy file from the loaded sound's server before beginning to load the sound. | SoundLoaderContext
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SoundLoaderContext(bufferTime:Number = 1000, checkPolicyFile:Boolean = false) Creates a new sound loader context object. | SoundLoaderContext
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
bufferTime property
public var bufferTime:Number = 1000

The number of seconds to preload a streaming sound into a buffer before the sound starts to stream.

Note that you cannot override the value of SoundLoaderContext.bufferTime by setting the global SoundMixer.bufferTime property. The SoundMixer.bufferTime property affects the buffer time for embedded streaming sounds in a SWF and is independent of dynamically created Sound objects (that is, Sound objects created in ActionScript).

checkPolicyFile property
public var checkPolicyFile:Boolean = false

Specifies whether Flash Player should try to download a cross-domain policy file from the loaded sound's server before beginning to load the sound. This property applies to sound that is loaded from outside the calling SWF file's own domain using the Sound.load() method.

Set this property to true when you load a sound from outside the calling SWF file's own domain and you need low-level access to the sound's data from ActionScript. Examples of low-level access to a sound's data include referencing the Sound.id3 property to get an ID3Info object or calling the SoundMixer.computeSpectrum() method to get sound samples from the loaded sound. If you try to access sound data without setting the checkPolicyFile property to true at loading time, you may get a SecurityError exception because the required policy file has not been downloaded.

If you don't need low-level access to the sound data that you are loading, avoid setting checkPolicyFile to true. Checking for a policy file consumes network bandwidth and might delay the start of your download, so it should only be done when necessary.

When you call Sound.load() with SoundLoaderContext.checkPolicyFile set to true, Flash Player must either successfully download a relevant cross-domain policy file or determine that no such policy file exists before it begins downloading the specified sound. Flash Player performs the following actions, in this order, to verify the existence of a policy file:

  • Flash Player considers policy files that have already been downloaded.
  • Flash Player tries to download any pending policy files specified in calls to Security.loadPolicyFile().
  • Flash Player tries to download a policy file from the default location that corresponds to the sound's URL, which is /crossdomain.xml on the same server as URLRequest.url. (The sound's URL is specified in the url property of the URLRequest object passed to Sound.load() or the Sound constructor.)

In all cases, Flash Player requires that an appropriate policy file exist on the sound's server, that it provide access to the sound file at URLRequest.url by virtue of the policy file's location, and that it allow the domain of the calling SWF file to access the sound, through one or more <allow-access-from> tags.

If you set checkPolicyFile to true, Flash Player waits until the policy file is verified before loading the sound. You should wait to perform any low-level operations on the sound data, such as calling Sound.id3 or SoundMixer.computeSpectrum(), until progress and complete events are dispatched from the Sound object.

If you set checkPolicyFile to true but no appropriate policy file is found, you will not receive an error until you perform an operation that requires a policy file, and then Flash Player throws a SecurityError exception. After you receive a complete event, you can test whether a relevant policy file was found by getting the value of Sound.id3 within a try block and seeing if a SecurityError is thrown.

Be careful with checkPolicyFile if you are downloading sound from a URL that uses server-side HTTP redirects. Flash Player tries to retrieve policy files that correspond to the url property of the URLRequest object passed to Sound.load(). If the final sound file comes from a different URL because of HTTP redirects, then the initially downloaded policy files might not be applicable to the sound's final URL, which is the URL that matters in security decisions.

If you find yourself in this situation, here is one possible solution. After you receive a progress or complete event, you can examine the value of the Sound.url property, which contains the sound's final URL. Then call the Security.loadPolicyFile() method with a policy file URL that you calculate based on the sound's final URL. Finally, poll the value of Sound.id3 until no exception is thrown.

For more information on policy files, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

See also

flash.media.Sound.load()
flash.media.Sound.id3
flash.media.SoundMixer.computeSpectrum()
flash.media.Sound.url
flash.system.Security.loadPolicyFile()
Loading content dynamically
Constructor detail
SoundLoaderContext () constructor
public function SoundLoaderContext(bufferTime:Number = 1000, checkPolicyFile:Boolean = false)

Creates a new sound loader context object.

Parameters
bufferTime:Number (default = 1000) — The number of seconds to preload a streaming sound into a buffer before the sound starts to stream.
checkPolicyFile:Boolean (default = false) — Specifies whether Flash Player should check for the existence of a cross-domain policy file upon loading the object (true) or not.


flash.media.SoundMixer (Flex™ 2 Language Reference)

Class SoundMixer | Properties | Methods
Package | flash.media
Class | public final class SoundMixer
Inheritance | SoundMixer Inheritance Object

The SoundMixer class contains static properties and methods for global sound control in the SWF file. The SoundMixer class controls embedded streaming sounds in a SWF; it does not control dynamically created Sound objects (that is, Sound objects created in ActionScript).

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bufferTime : int [static] The number of seconds to preload an embedded streaming sound into a buffer before it starts to stream. | SoundMixer
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | soundTransform : SoundTransform [static] The SoundTransform object that controls global sound properties. | SoundMixer
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | areSoundsInaccessible():Boolean [static] Determines whether any sounds are not accessible due to security restrictions. | SoundMixer
 | computeSpectrum(outputArray:ByteArray, FFTMode:Boolean = false, stretchFactor:int = 0):void [static] Takes a snapshot of the current sound wave and places it into the specified ByteArray object. | SoundMixer
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | stopAll():void [static] Stops all sounds currently playing. | SoundMixer
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
bufferTime property
bufferTime:int [read-write]

The number of seconds to preload an embedded streaming sound into a buffer before it starts to stream. The data in a loaded sound, including its buffer time, cannot be accessed by a SWF file that is in a different domain unless you implement a cross-domain policy file. For more information about security and sound, see the Sound class description.

The SoundMixer.bufferTime property only affects the buffer time for embedded streaming sounds in a SWF and is independent of dynamically created Sound objects (that is, Sound objects created in ActionScript). The value of SoundMixer.bufferTime cannot override or set the default of the buffer time specified in the SoundLoaderContext object that is passed to the Sound.load() method.

Implementation
    public static function get bufferTime():int
    public function set bufferTime(value:int):void

See also

Sound
soundTransform property
soundTransform:SoundTransform [read-write]

The SoundTransform object that controls global sound properties. A SoundTransform object includes properties for setting volume, panning, left speaker assignment, and right speaker assignment. This SoundTransform object only affects sounds embedded within a SWF file. The SoundTransform object used in this property provides final sound settings that are applied to all sounds after any individual sound settings are applied.

Implementation
    public static function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void

See also

SoundTransform
Method detail
areSoundsInaccessible () method
public static function areSoundsInaccessible():Boolean

Determines whether any sounds are not accessible due to security restrictions. For example, a sound loaded from a domain other than that of the SWF file is not accessible if the server for the sound has no cross-domain policy file that grants access to the domain of the SWF file. The sound can still be loaded and played, but low-level operations, such as getting ID3 metadata for the sound, cannot be performed on inaccessible sounds.

Returns
Boolean

See also

computeSpectrum()
computeSpectrum () method
public static function computeSpectrum(outputArray:ByteArray, FFTMode:Boolean = false, stretchFactor:int = 0):void

Takes a snapshot of the current sound wave and places it into the specified ByteArray object. The values are formatted as normalized floating-point values, in the range -1.0 to 1.0. The ByteArray object passed to the outputArray parameter is overwritten with the new values. The size of the ByteArray object created is fixed to 512 floating-point values, where the first 256 values represent the left channel, and the second 256 values represent the right channel.

Note: This method is subject to local file security restrictions and restrictions on cross-domain loading. If you are working with local SWF files or sounds loaded from a server in a different domain than the calling SWF, you might need to address sandbox restrictions through a cross-domain policy file. For more information, see the Sound class description. In addition, this method cannot be used to extract data from RTMP streams, even when it is called by SWF files that reside in the same domain as the RTMP server.

Parameters
outputArray:ByteArray — A ByteArray object that holds the values associated with the sound. If any sounds are not available due to security restrictions (areSoundsInaccessible == true), the outputArray object is left unchanged. If all sounds are stopped, the outputArray object is filled with zeros.
FFTMode:Boolean (default = false) — A Boolean value indicating whether a Fourier transformation is performed on the sound data first. Setting this parameter to true causes the method to return a frequency spectrum instead of the raw sound wave. In the frequency spectrum, low frequencies are represented on the left and high frequencies are on the right.
stretchFactor:int (default = 0) — The resolution of the sound samples. If you set the stretchFactor value to 0, data is sampled at 44.1 KHz; with a value of 1, data is sampled at 22.05 KHz; with a value of 2, data is sampled 11.025 KHz; and so on.

See also

areSoundsInaccessible()
Sound
SoundLoaderContext.checkPolicyFile
stopAll () method
public static function stopAll():void

Stops all sounds currently playing.

This method does not stop the playhead. Sounds set to stream will resume playing as the playhead moves over the frames in which they are located.

When using this property, consider the Flash Player security model:

  • By default, calling the soundMixer.stopAll() method stops only sounds in the same security sandbox as the object that is calling the method. Any sounds whose playback was not started from the same sandbox as the calling object are not stopped.
  • When you load the sound, using the load() method of the Sound class, you can specify a context parameter, which is a SoundLoaderContext object. If you set the checkPolicyFile property of the SoundLoaderContext object to true, Flash Player checks for a cross-domain policy file on the server from which the sound is loaded. If the server has a cross-domain policy file, and the file permits the domain of a SWF file, then the file can stop the loaded sound by using the soundMixer.stopAll() method; otherwise it cannot.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper


flash.media.SoundTransform (Flex™ 2 Language Reference)

Class SoundTransform | Properties | Methods | Examples
Package | flash.media
Class | public final class SoundTransform
Inheritance | SoundTransform Inheritance Object

The SoundTransform class contains properties for volume and panning. The following objects contain a soundTransform property, the value of which is a SoundTransform object: Microphone, NetStream, SimpleButton, SoundChannel, SoundMixer, and Sprite.

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | leftToLeft : Number A value, from 0 (none) to 1 (all), specifying how much of the left input is played in the left speaker. | SoundTransform
 | leftToRight : Number A value, from 0 (none) to 1 (all), specifying how much of the left input is played in the right speaker. | SoundTransform
 | pan : Number The left-to-right panning of the sound, ranging from -1 (full pan left) to 1 (full pan right). | SoundTransform
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rightToLeft : Number A value, from 0 (none) to 1 (all), specifying how much of the right input is played in the left speaker. | SoundTransform
 | rightToRight : Number A value, from 0 (none) to 1 (all), specifying how much of the right input is played in the right speaker. | SoundTransform
 | volume : Number The volume, ranging from 0 (silent) to 1 (full volume). | SoundTransform
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SoundTransform(vol:Number = 1, panning:Number = 0) Creates a SoundTransform object. | SoundTransform
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
leftToLeft property
leftToLeft:Number [read-write]

A value, from 0 (none) to 1 (all), specifying how much of the left input is played in the left speaker.

Implementation
    public function get leftToLeft():Number
    public function set leftToLeft(value:Number):void
leftToRight property
leftToRight:Number [read-write]

A value, from 0 (none) to 1 (all), specifying how much of the left input is played in the right speaker.

Implementation
    public function get leftToRight():Number
    public function set leftToRight(value:Number):void
pan property
pan:Number [read-write]

The left-to-right panning of the sound, ranging from -1 (full pan left) to 1 (full pan right). A value of 0 represents no panning (balanced center between right and left).

Implementation
    public function get pan():Number
    public function set pan(value:Number):void
rightToLeft property
rightToLeft:Number [read-write]

A value, from 0 (none) to 1 (all), specifying how much of the right input is played in the left speaker.

Implementation
    public function get rightToLeft():Number
    public function set rightToLeft(value:Number):void
rightToRight property
rightToRight:Number [read-write]

A value, from 0 (none) to 1 (all), specifying how much of the right input is played in the right speaker.

Implementation
    public function get rightToRight():Number
    public function set rightToRight(value:Number):void
volume property
volume:Number [read-write]

The volume, ranging from 0 (silent) to 1 (full volume).

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
Constructor detail
SoundTransform () constructor
public function SoundTransform(vol:Number = 1, panning:Number = 0)

Creates a SoundTransform object.

Parameters
vol:Number (default = 1) — The volume, ranging from 0 (silent) to 1 (full volume).
panning:Number (default = 0) — The left-to-right panning of the sound, ranging from -1 (full pan left) to 1 (full pan right). A value of 0 represents no panning (center).
Examples

The following example loads and plays an MP3 file. As the MP3 file plays, move the mouse; the volume and panning change as you move the mouse over the Stage. To run this example, place a file named MySound.mp3 in the same directory as your SWF file.
package {
    import flash.display.Sprite;
    import flash.display.StageAlign;
    import flash.display.StageScaleMode;
    import flash.events.*;
    import flash.media.Sound;
    import flash.media.SoundChannel;
    import flash.media.SoundTransform;
    import flash.net.URLRequest;
    import flash.utils.Timer;

    public class SoundTransformExample extends Sprite {
        private var url:String = "MySound.mp3";
        private var soundFactory:Sound;
        private var channel:SoundChannel;
        private var positionTimer:Timer;

        public function SoundTransformExample() {
            stage.align = StageAlign.TOP_LEFT;
            stage.scaleMode = StageScaleMode.NO_SCALE;

            var request:URLRequest = new URLRequest(url);
            soundFactory = new Sound();
            soundFactory.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            soundFactory.load(request);
            channel = soundFactory.play();
            stage.addEventListener(MouseEvent.MOUSE_MOVE, mouseMoveHandler);
        }

        private function ioErrorHandler(event:Event):void {
            trace("ioErrorHandler: " + event);
        }

        private function setPan(pan:Number):void {
            trace("setPan: " + pan.toFixed(2));
            var transform:SoundTransform = channel.soundTransform;
            transform.pan = pan;
            channel.soundTransform = transform;
        }

        private function setVolume(volume:Number):void {
            trace("setVolume: " + volume.toFixed(2));
            var transform:SoundTransform = channel.soundTransform;
            transform.volume = volume;
            channel.soundTransform = transform;
        }

        private function mouseMoveHandler(event:MouseEvent):void {
            var halfStage:uint = Math.floor(stage.stageWidth / 2);
            var xPos:uint = event.stageX;
            var yPos:uint = event.stageY;
            var value:Number;
            var pan:Number;

            if (xPos > halfStage) {
                value = xPos / halfStage;
                pan = value - 1;
            } else if (xPos < halfStage) {
                value = (xPos - halfStage) / halfStage;
                pan = value;
            } else {
                pan = 0;
            }

            var volume:Number = 1 - (yPos / stage.stageHeight);

            setVolume(volume);
            setPan(pan);

        }
    }
}


flash.media.Video (Flex™ 2 Language Reference)

Class Video | Properties | Methods | Events | Examples
Package | flash.media
Class | public class Video
Inheritance | Video Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Video class enables you to display live streaming video in an application without embedding it in your SWF file. You can capture and play live video using the Camera.getCamera() method. You can also use the Video class to play back Flash® Video (FLV) files over HTTP or from the local file system. For more information, see the NetConnection class and NetStream class entries.

Flash Player 9 supports publish and playback of FLV files encoded with either the Sorenson or the On2 VP6 codec and also supports an alpha channel. The On2 VP6 video codec uses less bandwidth than older technologies, and offers additional deblocking and deringing filters.

As with other display objects that are on the display list, you can control various properties of Video objects. For example, you can move the Video object around on the Stage by using its x and y properties, you can change its size using its height and width properties, and so on.

To play a video stream, use the .attachCamera() or .attachStream() method to attach the video to the Video object and add the Video object to the display list using addChild().

  1. If the Library panel isn't visible, select Window > Library to display it.
  2. Add an embedded Video object to the library by clicking the Options menu on the right side of the Library panel title bar and selecting New Video.
  3. Drag the Video object to the Stage and use the Property inspector to give it a unique instance name, such as my_video. (Do not name it Video.)

Note: The Video class is not a subclass of the InteractiveObject class, so it cannot dispatch mouse events. However, you can use the addEventListener() method of the display object container that contains the Video object.

View the examples.

See also

flash.media.Camera.getCamera()
flash.net.NetConnection
flash.net.NetStream
Understanding the display architecture
Working with video

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | deblocking : int Indicates the type of filter applied to decoded video as part of post-processing. | Video
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | smoothing : Boolean Specifies whether the video should be smoothed (interpolated) when it is scaled. | Video
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | videoHeight : int [read-only] An integer specifying the height of the video stream, in pixels. | Video
 | videoWidth : int [read-only] An integer specifying the width of the video stream, in pixels. | Video
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Video(width:int = 320, height:int = 240)
Creates a new Video instance.
Video
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
attachCamera(camera:Camera):void
Specifies a video stream from a camera to be displayed within the boundaries of the Video object in the application window.
Video
attachNetStream(netStream:NetStream):void
Specifies a video stream to be displayed within the boundaries of the Video object in the application window.
Video
clear():void
Clears the image currently displayed in the Video object.
Video
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
deblocking property
deblocking:int [read-write]

Indicates the type of filter applied to decoded video as part of post-processing. The default value is 0, which lets the video compressor apply a deblocking filter as needed.

Compression of video can result in undesired artifacts. You can use the deblocking property to set filters that reduce blocking and, for video compressed using the On2 codec, ringing.

Blocking refers to visible imperfections between the boundaries of the blocks that compose each video frame. Ringing refers to distorted edges around elements within a video image.

Two deblocking filters are available: one in the Sorenson codec and one in the On2 VP6 codec. In addition, a deringing filter is available when you use the On2 VP6 codec. To set a filter, use one of the following values:

  • 0—Lets the video compressor apply the deblocking filter as needed.
  • 1—Does not use a deblocking filter.
  • 2—Uses the Sorenson deblocking filter.
  • 3—For On2 video only, uses the On2 deblocking filter but no deringing filter.
  • 4—For On2 video only, uses the On2 deblocking and deringing filter.
  • 5—For On2 video only, uses the On2 deblocking and a higher-performance On2 deringing filter.

If a value greater than 2 is selected for video when you are using the Sorenson codec, the Sorenson decoder defaults to 2.

Using a deblocking filter has an effect on overall playback performance, and it is usually not necessary for high-bandwidth video. If a user's system is not powerful enough, the user may experience difficulties playing back video with a deblocking filter enabled.

Implementation
    public function get deblocking():int
    public function set deblocking(value:int):void
smoothing property
smoothing:Boolean [read-write]

Specifies whether the video should be smoothed (interpolated) when it is scaled. For smoothing to work, the player must be in high quality mode. The default value is false (no smoothing).

Implementation
    public function get smoothing():Boolean
    public function set smoothing(value:Boolean):void
videoHeight property
videoHeight:int [read-only]

An integer specifying the height of the video stream, in pixels. For live streams, this value is the same as the Camera.height property of the Camera object that is capturing the video stream. For FLV files, this value is the height of the file that was exported as FLV.

You may want to use this property, for example, to ensure that the user is seeing the video at the same size at which it was captured, regardless of the actual size of the Video object on the Stage.

Implementation
    public function get videoHeight():int

See also

flash.media.Camera.height
videoWidth property
videoWidth:int [read-only]

An integer specifying the width of the video stream, in pixels. For live streams, this value is the same as the Camera.width property of the Camera object that is capturing the video stream. For FLV files, this value is the width of the file that was exported as an FLV file.

You may want to use this property, for example, to ensure that the user is seeing the video at the same size at which it was captured, regardless of the actual size of the Video object on the Stage.

Implementation
    public function get videoWidth():int

See also

flash.media.Camera.width
Constructor detail
Video () constructor
public function Video(width:int = 320, height:int = 240)

Creates a new Video instance. If no values for the width and height parameters are supplied, the default values are used. You can also set the width and height properties of the Video object after the initial construction, using Video.width and Video.height. When a new Video object is created, values of zero for width or height are not allowed; if you pass zero, the defaults will be applied.

After creating the Video, call the DisplayObjectContainer.addChild() or DisplayObjectContainer.addChildAt() method to add the Video object to a parent DisplayObjectContainer object.

Parameters
width:int (default = 320) — The width of the video, in pixels.
height:int (default = 240) — The height of the video, in pixels.
Method detail
attachCamera () method
public function attachCamera(camera:Camera):void

Specifies a video stream from a camera to be displayed within the boundaries of the Video object in the application window.

Parameters
camera:Camera — A Camera object that is capturing video data. To drop the connection to the Video object, pass null.

See also

Video.attachNetStream()
flash.media.Camera
attachNetStream () method
public function attachNetStream(netStream:NetStream):void

Specifies a video stream to be displayed within the boundaries of the Video object in the application window. The video stream is either an FLV file being displayed by means of the NetStream.play() command, a Camera object, or null. If the value of the netStream parameter is null, video is no longer played within the object.

You don't need to use this method if the FLV file contains only audio; the audio portion of FLV files is played automatically when the NetStream.play() method is called. To control the audio associated with an FLV file, use the soundTransform property of the NetStream object that plays the FLV file.

Parameters
netStream:NetStream — A NetStream object. To drop the connection to the Video object, pass null.

See also

Video.attachCamera()
flash.net.NetStream.soundTransform
SoundTransform
clear () method
public function clear():void

Clears the image currently displayed in the Video object. This is useful when you want to display standby information without having to hide the Video object.

See also

Video.attachCamera()
Examples

The following example uses a Video object with the NetConnection and NetStream classes to load and play an FLV file. To run this example, you need an FLV file whose name and location match the variable passed to videoURL, in this case, an FLV file called Video.flv that is in the same directory as the SWF file.

In this example, the code that creates the Video and NetStream objects and calls Video.attachNetStream() and NetStream.play() is placed in a handler function. The handler is called only if the attempt to connect to the NetConnection object is successful, which is when the netStatus event returns an info object with a code property that indicates success. It is recommended that you wait for a successful connection before calling NetStream.play().

 package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.media.Video;
    import flash.net.NetConnection;
    import flash.net.NetStream;

    public class VideoExample extends Sprite {
        private var videoURL:String = "Video.flv";
        private var connection:NetConnection;
        private var stream:NetStream;

        public function VideoExample() {
            connection = new NetConnection();
            connection.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            connection.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            connection.connect(null);
        }

        private function netStatusHandler(event:NetStatusEvent):void {
            switch (event.info.code) {
                case "NetConnection.Connect.Success":
                    connectStream();
                    break;
                case "NetStream.Play.StreamNotFound":
                    trace("Unable to locate video: " + videoURL);
                    break;
            }
        }

        private function connectStream():void {
            var stream:NetStream = new NetStream(connection);
            stream.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            stream.addEventListener(AsyncErrorEvent.ASYNC_ERROR, asyncErrorHandler);
            var video:Video = new Video();
            video.attachNetStream(stream);
            stream.play(videoURL);
            addChild(video);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function asyncErrorHandler(event:AsyncErrorEvent):void {
            // ignore AsyncErrorEvent events.
        }
    }
 }


flash.net Summary (Flex™ 2 Language Reference)

Package flash.net | Functions | Interfaces | Classes

The flash.net package contains classes for sending and receiving from the network, such as URL downloading and Flash Remoting.

Functions
Function | Description
getClassByAlias | Looks up a class that previously had an alias registered through a call to the registerClassAlias() method.
navigateToURL | Opens or replaces a window in the application that contains the Flash Player container (usually a browser).
registerClassAlias | Preserves the class (type) of an object when the object is encoded in Action Message Format (AMF).
sendToURL | Sends a URL request to a server, but ignores any response.
Interfaces
Interface | Description
IDynamicPropertyOutput | This interface controls the serialization of dynamic properties of dynamic objects.
IDynamicPropertyWriter | This interface is used with the IDynamicPropertyOutput interface to control the serialization of dynamic properties of dynamic objects.
Classes
Class | Description
FileFilter | The FileFilter class is used to indicate what files on the user's system are shown in the file-browsing dialog box that is displayed when FileReference.browse() or FileReferenceList.browse() is called.
FileReference | The FileReference class provides a means to upload and download files between a user's computer and a server.
FileReferenceList | The FileReferenceList class provides a means to let users select one or more files for uploading.
LocalConnection | The LocalConnection class lets you create a LocalConnection object that can invoke a method in another LocalConnection object, either within a single SWF file or between multiple SWF files.
NetConnection | The NetConnection class lets you invoke commands on a remote application server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, and to play streaming Flash Video (FLV) files from either an HTTP address or a local drive.
NetStream | The NetStream class opens a one-way streaming connection between Flash Player and a server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, or between Flash Player and the local file system through a connection made available by a NetConnection object.
ObjectEncoding | The ObjectEncoding class allows classes that serialize objects (such as NetStream, NetConnection, SharedObject, and ByteArray) to work with prior versions of ActionScript.
Responder | The Responder class provides an object that is used in NetConnection.call() to handle return values from the server.
SharedObject | The SharedObject class is used to read and store limited amounts of data on a user's computer or on a server.
SharedObjectFlushStatus | The SharedObjectFlushStatus class provides values for the code returned from a call to the SharedObject.flush() method.
Socket | The Socket class enables ActionScript code to make socket connections and to read and write raw binary data.
URLLoader | The URLLoader class downloads data from a URL as text, binary data, or URL-encoded variables.
URLLoaderDataFormat | The URLLoaderDataFormat class provides values that specify how downloaded data is received.
URLRequest | The URLRequest class captures all of the information in a single HTTP request.
URLRequestHeader | A URLRequestHeader object encapsulates a single HTTP request header and consists of a name/value pair.
URLRequestMethod | The URLRequestMethod class provides values that specify whether the URLRequest object should use the POST method or the GET method when sending data to a server.
URLStream | The URLStream class provides low-level access to downloading URLs.
URLVariables | The URLVariables class allows you to transfer variables between a Flash® application and a server.
XMLSocket | The XMLSocket class implements client sockets that let the computer that is running Flash Player communicate with a server computer identified by an IP address or domain name.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.net Details (Flex™ 2 Language Reference)

Package flash.net | Functions

The flash.net package contains package-level functions for opening a new browser window, sending a URL request to a server, and dealing with class aliases.
Public Functions
Function |  | Defined by
 | getClassByAlias(aliasName:String):Class Looks up a class that previously had an alias registered through a call to the registerClassAlias() method. | flash.net
 | navigateToURL(request:URLRequest, window:String = null):void Opens or replaces a window in the application that contains the Flash Player container (usually a browser). | flash.net
 | registerClassAlias(aliasName:String, classObject:Class):void Preserves the class (type) of an object when the object is encoded in Action Message Format (AMF). | flash.net
 | sendToURL(request:URLRequest):void Sends a URL request to a server, but ignores any response. | flash.net
Function detail
getClassByAlias () function
public function getClassByAlias(aliasName:String):Class

Looks up a class that previously had an alias registered through a call to the registerClassAlias() method.

This method does not interact with the flash.utils.getDefinitionByName() method.

Parameters
aliasName:String — The alias to find.

Returns
Class — The class associated with the given alias. If not found, an exception will be thrown.

Throws
ReferenceError — The alias was not registered.

See also

registerClassAlias()
navigateToURL () function
public function navigateToURL(request:URLRequest, window:String = null):void

Opens or replaces a window in the application that contains the Flash Player container (usually a browser).

Parameters
request:URLRequest — A URLRequest object that specifies the URL to navigate to.
window:String (default = null) — The browser window or HTML frame in which to display the document indicated by the request parameter. You can enter the name of a specific window or use one of the following values:
  • "_self" specifies the current frame in the current window.
  • "_blank" specifies a new window.
  • "_parent" specifies the parent of the current frame.
  • "_top" specifies the top-level frame in the current window.

If you do not specify a value for this parameter, a new empty window is created. In the stand-alone player, you can either specify a new ("_blank") window or a named window. The other values don't apply.

Throws
SecurityError — This error is thrown in the following situations:
  • Local untrusted SWF files may not communicate with the Internet. You can avoid this situation by reclassifying this SWF file as local-with-networking or trusted.
  • A navigate operation attempted to evaluate a scripting pseudo-URL, but the containing document (usually an HTML document in a browser) is from a sandbox to which you do not have access. You can avoid this situation by specifying allowScriptAccess="always" in the containing document.
  • You cannot navigate the special windows "_self", "_top", or "_parent" if your SWF file is contained by an HTML page that has set the allowScriptAccess to "none", or to "sameDomain" when the domains of the HTML file and the SWF file do not match.
  • You cannot navigate a window with a nondefault name from within a SWF file that is in the local-with-filesystem sandbox.

See also

Using the navigateToURL() method in Flex

Example
The following example opens the URL http://www.adobe.com in a new browser window and passes data about a user session, captured in a URLVariables object, to the web server.
package {
    import flash.display.Sprite;
    import flash.net.navigateToURL;
    import flash.net.URLRequest;
    import flash.net.URLVariables;

    public class NavigateToURLExample extends Sprite {

        public function NavigateToURLExample() {
            var url:String = "http://www.adobe.com";
            var variables:URLVariables = new URLVariables();
            variables.exampleSessionId = new Date().getTime();
            variables.exampleUserLabel = "Your Name";
            var request:URLRequest = new URLRequest(url);
            request.data = variables;
            try {
                navigateToURL(request);
            }
            catch (e:Error) {
                // handle error here
            }
        }
    }
}

registerClassAlias () function
public function registerClassAlias(aliasName:String, classObject:Class):void

Preserves the class (type) of an object when the object is encoded in Action Message Format (AMF). When you encode an object into AMF, this function saves the alias for its class, so that you can recover the class when decoding the object. If the encoding context did not register an alias for an object's class, the object is encoded as an anonymous object. Similarly, if the decoding context does not have the same alias registered, an anonymous object is created for the decoded data.

LocalConnection, ByteArray, SharedObject, NetConnection and NetStream are all examples of classes that encode objects in AMF.

The encoding and decoding contexts do not need to use the same class for an alias; they can intentionally change classes, provided that the destination class contains all of the members that the source class serializes.

Parameters
aliasName:String — The alias to use.
classObject:Class — The class associated with the given alias.

Throws
TypeError — If either parameter is null.

See also

ObjectEncoding class

Example
This example uses the registerClassAlias() function to register an alias (com.example.eg) for the class ExampleClass. Because an alias is registered for the class, the object is able to be deserialized as an instance of ExampleClass, and the code outputs true. If the registerClassAlias() call were removed, the code would output false.
package {
    import flash.display.Sprite;
    import flash.net.registerClassAlias;
    import flash.utils.ByteArray;

    public class RegisterClassAliasExample extends Sprite {
        public function RegisterClassAliasExample() {
            registerClassAlias("com.example.eg", ExampleClass);
            var eg1:ExampleClass = new ExampleClass();
            var ba:ByteArray = new ByteArray();
            ba.writeObject(eg1);
            ba.position = 0;
            var eg2:* = ba.readObject();
            trace(eg2 is ExampleClass); // true
        }
    }
}

class ExampleClass {}

sendToURL () function
public function sendToURL(request:URLRequest):void

Sends a URL request to a server, but ignores any response.

To examine the server response, use the URLLoader.load() method instead.

When you use this function, consider the Flash Player security model:

  • For Flash Player 8, you cannot use this function if the calling SWF file is in an untrusted local sandbox.
  • For Flash Player 7 and later, you cannot use this function if the calling SWF file is a local file.

For more information, see the Flash Player 9 Security white paper at http://www.adobe.com/go/fp9_0_security.

Parameters
request:URLRequest — A URLRequest object specifying the URL to send data to.

Throws
SecurityError — Local untrusted SWF files cannot communicate with the Internet. You can avoid this situation by reclassifying this SWF file as local-with-networking or trusted.

Example
The following example passes data about a user session, captured in a URLVariables object, to the application at http://www.yourDomain.com/application.jsp.
 package {
    import flash.display.Sprite;
    import flash.net.URLRequest;
    import flash.net.URLVariables;
    import flash.net.sendToURL;

    public class SendToURLExample extends Sprite {

        public function SendToURLExample() {
            var url:String = "http://www.yourDomain.com/application.jsp";
            var variables:URLVariables = new URLVariables();
            variables.sessionId = new Date().getTime();
            variables.userLabel = "Your Name";

            var request:URLRequest = new URLRequest(url);
            request.data = variables;
            trace("sendToURL: " + request.url + "?" + request.data);
            try {
                sendToURL(request);
            }
            catch (e:Error) {
                // handle error here
            }
        }
    }
}

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.net.FileFilter (Flex™ 2 Language Reference)

Class FileFilter | Properties | Methods
Package | flash.net
Class | public final class FileFilter
Inheritance | FileFilter Inheritance Object

The FileFilter class is used to indicate what files on the user's system are shown in the file-browsing dialog box that is displayed when FileReference.browse() or FileReferenceList.browse() is called. FileFilter instances are passed to a browse() function. If you use a FileFilter instance, extensions and file types that aren't specified in the FileFilter instance are filtered out; that is, they are not available to the user to select for uploading. If no FileFilter object is passed to browse(), all files are shown in the dialog box.

You can use FileFilter instances in one of two ways:

  • A description with Windows file extensions only
  • A description with Windows file extensions and Macintosh file types

The two formats are not interchangeable within a single browse() call. You must use one or the other.

You can pass one or more FileFilter instances to FileReference.browse() or FileReferenceList.browse(). The following examples show different ways to create and pass FileFilter instances to a browse() call (for Windows only). The first example creates FileFilter instances outside of the browse() call:

 var imagesFilter:FileFilter = new FileFilter("Images", "*.jpg;*.gif;*.png");
 var docFilter:FileFilter = new FileFilter("Documents", "*.pdf;*.doc;*.txt");
 var myFileReference:FileReference = new FileReference();
 myFileReference.browse([imagesFilter, docFilter]);

The second example creates FileFilter instances within the browse() call:

 myFileReference.browse( [ new FileFilter("Images", "*.jpg;*.gif;*.png"), new FileFilter("Flash Movies", "*.swf") ] );

The list of extensions in the FileFilter.extension property is used to filter the files in Windows, depending on the file selected by the user. It is not actually displayed in the dialog box; to display the file types for users, you must list the file types in the description string as well as in the extension list. The description string is displayed in the dialog box in Windows. (It is not used on the Macintosh.) On the Macintosh, if you supply a list of Macintosh file types, that list is used to filter the files. If not, the list of Windows extensions is used.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | description : String The description string for the filter. | FileFilter
 | extension : String A list of file extensions. | FileFilter
 | macType : String A list of Macintosh file types. | FileFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | FileFilter(description:String, extension:String, macType:String = null) Creates a new FileFilter instance. | FileFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
description property
description:String [read-write]

The description string for the filter. The description is visible to the user in the dialog box that opens when FileReference.browse() or FileReferenceList.browse() is called. The description string contains a string, such as "Images (*.gif, *.jpg, *.png)", that can help instruct the user on what file types can be uploaded or downloaded. Note that the actual file types that are supported by this FileReference object are stored in the extension property.

Implementation
    public function get description():String
    public function set description(value:String):void
extension property
extension:String [read-write]

A list of file extensions. This list indicates the types of files that you want to show in the file-browsing dialog box. (The list is not visible to the user; the user sees only the value of the description property.) The extension property contains a semicolon-delimited list of Windows file extensions, with a wildcard (*) preceding each extension, as shown in the following string: "*.jpg;*.gif;*.png".

Implementation
    public function get extension():String
    public function set extension(value:String):void
macType property
macType:String [read-write]

A list of Macintosh file types. This list indicates the types of files that you want to show in the file-browsing dialog box. (This list itself is not visible to the user; the user sees only the value of the description property.) The macType property contains a semicolon-delimited list of Macintosh file types, as shown in the following string: "JPEG;jp2_;GIFF".

Implementation
    public function get macType():String
    public function set macType(value:String):void
Constructor detail
FileFilter () constructor
public function FileFilter(description:String, extension:String, macType:String = null)

Creates a new FileFilter instance.

Parameters
description:String — The description string that is visible to users when they select files for uploading.
extension:String — A list of file extensions that indicate which Windows file formats are visible to users when they select files for uploading.
macType:String (default = null) — A list of Macintosh file types that indicate which file types are visible to users when they select files for uploading. If no value is passed, this parameter is set to null.


flash.net.FileReference (Flex™ 2 Language Reference)

Class FileReference | Properties | Methods | Events | Examples
Package | flash.net
Class | public class FileReference
Inheritance | FileReference Inheritance EventDispatcher Inheritance Object

The FileReference class provides a means to upload and download files between a user's computer and a server. An operating-system dialog box prompts the user to select a file to upload or a location for download. Each FileReference object refers to a single file on the user's disk and has properties that contain information about the file's size, type, name, creation date, modification date, and creator type (Macintosh only).

FileReference instances are created in two ways:

  • When you use the new operator with the FileReference constructor: var myFileReference = new FileReference();
  • When you call the FileReferenceList.browse() method, which creates an array of FileReference objects.

During an upload operation, all the properties of a FileReference object are populated by calls to the FileReference.browse() or FileReferenceList.browse() methods. During a download operation, the name property is populated when the select event is dispatched; all other properties are populated when the complete event is dispatched.

The browse() method opens an operating-system dialog box that prompts the user to select a file for upload. The FileReference.browse() method lets the user select a single file; the FileReferenceList.browse() method lets the user select multiple files. After a successful call to the browse() method, call the FileReference.upload() method to upload one file at a time. The FileReference.download() method prompts the user for a location to save the file and initiates downloading from a remote URL.

The FileReference and FileReferenceList classes do not let you set the default file location for the dialog box that the browse() or download() methods generate. The default location shown in the dialog box is the most recently browsed folder, if that location can be determined, or the desktop. The classes do not allow you to read from or write to the transferred file. They do not allow the SWF file that initiated the upload or download to access the uploaded or downloaded file or the file's location on the user's disk.

The FileReference and FileReferenceList classes also do not provide methods for authentication. With servers that require authentication, you can download files with the Flash® Player browser plug-in, but uploading (on all players) and downloading (on the stand-alone or external player) fails. Listen for FileReference events to determine whether operations complete successfully and to handle errors.

For uploading and downloading operations, a SWF file can access files only within its own domain, including any domains that a cross-domain policy file specifies. Put a policy file on the file server if the SWF initiating the upload or download doesn't come from the same domain as the file server.

While calls to the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() methods are executing, SWF file playback pauses on stand-alone and external players for Mac OS X 10.1 and earlier.

The following sample HTTP POST request is sent from Flash Player to a server-side script if no parameters are specified:

  POST /handler.cfm HTTP/1.1
  Accept: text/*
  Content-Type: multipart/form-data;
  boundary=----------Ij5ae0ae0KM7GI3KM7ei4cH2ei4gL6
  User-Agent: Shockwave Flash
  Host: www.example.com
  Content-Length: 421
  Connection: Keep-Alive
  Cache-Control: no-cache

  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="Filename"

  MyFile.jpg
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="photo"; filename="MyFile.jpg"
  Content-Type: application/octet-stream

  FileDataHere
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="Upload"

  Submit Query
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7--

Flash Player sends the following HTTP POST request if the user specifies the parameters "api_sig", "api_key", and "auth_token":

  POST /handler.cfm HTTP/1.1
  Accept: text/*
  Content-Type: multipart/form-data;
  boundary=----------Ij5ae0ae0KM7GI3KM7ei4cH2ei4gL6
  User-Agent: Shockwave Flash
  Host: www.example.com
  Content-Length: 421
  Connection: Keep-Alive
  Cache-Control: no-cache

  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="Filename"

  MyFile.jpg
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="api_sig"

  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="api_key"

  XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="auth_token"

  XXXXXXXXXXXXXXXXXXXXXX
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="photo"; filename="MyFile.jpg"
  Content-Type: application/octet-stream

  FileDataHere
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7
  Content-Disposition: form-data; name="Upload"

  Submit Query
  ------------Ij5GI3GI3ei4GI3ei4KM7GI3KM7KM7--

View the examples.

See also

FileReferenceList
Working with file upload and download

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | creationDate : Date [read-only] The creation date of the file on the local disk. | FileReference
 | creator : String [read-only] The Macintosh creator type of the file. | FileReference
 | modificationDate : Date [read-only] The date that the file on the local disk was last modified. | FileReference
 | name : String [read-only] The name of the file on the local disk. | FileReference
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | size : uint [read-only] The size of the file on the local disk in bytes. | FileReference
 | type : String [read-only] The file type. | FileReference
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FileReference()
Creates a new FileReference object.
FileReference
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
browse(typeFilter:Array = null):Boolean
Displays a file-browsing dialog box that lets the user select a file to upload.
FileReference
cancel():void
Cancels any ongoing upload or download operation on this FileReference object.
FileReference
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
download(request:URLRequest, defaultFileName:String = null):void
Opens a dialog box that lets the user download a file from a remote server.
FileReference
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
upload(request:URLRequest, uploadDataFieldName:String = "Filedata", testUpload:Boolean = false):void
Starts the upload of a file selected by a user to a remote server.
FileReference
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | cancel | Dispatched when a file upload or download is canceled by the user. | FileReference
 | complete | Dispatched when download is complete or when upload generates an HTTP status code of 200. | FileReference
 | httpStatus | Dispatched when an upload fails and an HTTP status code is available to describe the failure. | FileReference
 | ioError | Dispatched when the upload or download fails. | FileReference
 | open | Dispatched when an upload or download operation starts. | FileReference
 | progress | Dispatched periodically during the file upload or download operation. | FileReference
 | securityError | Dispatched when a call to the FileReference.upload() or FileReference.download() method tries to upload a file to a server or get a file from a server that is outside the caller's security sandbox. | FileReference
 | select | Dispatched when the user selects a file for upload or download from the file-browsing dialog box. | FileReference
Property detail
creationDate property
creationDate:Date [read-only]

The creation date of the file on the local disk. If the FileReference object was not populated, a call to get the value of this property returns null.

Implementation
    public function get creationDate():Date

Throws
IllegalOperationError — If the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() method was not called successfully, an exception is thrown with a message indicating that functions were called in the incorrect sequence or an earlier call was unsuccessful. In this case, the value of the creationDate property is null.
IOError — If the file information cannot be accessed, an exception is thrown with a message indicating a file I/O error.

See also

FileReference.browse()
creator property
creator:String [read-only]

The Macintosh creator type of the file. In Windows, this property is null. If the FileReference object was not populated, a call to get the value of this property returns null.

Implementation
    public function get creator():String

Throws
IllegalOperationError — On Macintosh, if the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() method was not called successfully, an exception is thrown with a message indicating that functions were called in the incorrect sequence or an earlier call was unsuccessful. In this case, the value of the creator property is null.

See also

FileReference.browse()
Working with file upload and download
modificationDate property
modificationDate:Date [read-only]

The date that the file on the local disk was last modified. If the FileReference object was not populated, a call to get the value of this property returns null.

Implementation
    public function get modificationDate():Date

Throws
IllegalOperationError — If the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() method was not called successfully, an exception is thrown with a message indicating that functions were called in the incorrect sequence or an earlier call was unsuccessful. In this case, the value of the modificationDate property is null.
IOError — If the file information cannot be accessed, an exception is thrown with a message indicating a file I/O error.

See also

FileReference.browse()
name property
name:String [read-only]

The name of the file on the local disk. If the FileReference object was not populated, a call to get the value of this property returns null.

All the properties of a FileReference object are populated by calling the browse() method. Unlike other FileReference properties, if you call the download() method, the name property is populated when the select event is dispatched.

Implementation
    public function get name():String

Throws
IllegalOperationError — If the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() method was not called successfully, an exception is thrown with a message indicating that functions were called in the incorrect sequence or an earlier call was unsuccessful. In this case, the value of the name property is null.

See also

FileReference.browse()
size property
size:uint [read-only]

The size of the file on the local disk in bytes. If size is 0, an exception is thrown.

Implementation
    public function get size():uint

Throws
IllegalOperationError — If the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() method was not called successfully, an exception is thrown with a message indicating that functions were called in the incorrect sequence or an earlier call was unsuccessful. In this case, the value of the size property is 0.
IOError — If the file cannot be opened or read, or if a similar error is encountered in accessing the file, an exception is thrown with a message indicating a file I/O error. In this case, the value of the size property is 0.

See also

FileReference.browse()
type property
type:String [read-only]

The file type. In Windows, this property is the file extension. On the Macintosh, this property is the four-character file type. If the FileReference object was not populated, a call to get the value of this property returns null.

Implementation
    public function get type():String

Throws
IllegalOperationError — If the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() method was not called successfully, an exception is thrown with a message indicating that functions were called in the incorrect sequence or an earlier call was unsuccessful. In this case, the value of the type property is null.
Constructor detail
FileReference () constructor
public function FileReference()

Creates a new FileReference object. When populated, a FileReference object represents a file on the user's local disk.

See also

FileReference.browse()
Method detail
browse () method
public function browse(typeFilter:Array = null):Boolean

Displays a file-browsing dialog box that lets the user select a file to upload. The dialog box is native to the user's operating system. The user can select a file on the local computer or from other systems, for example, through a UNC path on Windows.

When you call this method and the user successfully selects a file, the properties of this FileReference object are populated with the properties of that file. Each subsequent time that the FileReference.browse() method is called, the FileReference object's properties are reset to the file that the user selects in the dialog box. Only one browse() or download() session can be performed at a time (because only one dialog box can be invoked at a time).

Using the typeFilter parameter, you can determine which files the dialog box displays.

Parameters
typeFilter:Array (default = null) — An array of FileFilter instances used to filter the files that are displayed in the dialog box. If you omit this parameter, all files are displayed. For more information, see the FileFilter class.

Returns
Boolean — Returns true if the parameters are valid and the file-browsing dialog box opens. The browse method returns false if the dialog box does not open, if another browse session is already in progress, or if you use the typelist parameter but fail to provide a description or extension string in any element in the array.

Events
select:Event — Dispatched when the user successfully selects an item from the Browse file chooser.
cancel:Event — Dispatched when the user cancels the file upload Browse window.

Throws
IllegalOperationError — Thrown in the following situations: 1) Another FileReference or FileReferenceList browse session is in progress; only one file browsing session may be performed at a time. 2) A setting in the user's mms.cfg file prohibits this operation.
ArgumentError — If the typeFilter array contains FileFilter objects that are incorrectly formatted, an exception is thrown. For information on the correct format for FileFilter objects, see the FileFilter class.

See also

select event
cancel event
FileReference.download()
FileReferenceList.browse()
Working with file upload and download
cancel () method
public function cancel():void

Cancels any ongoing upload or download operation on this FileReference object. Calling this method does not dispatch the cancel event; that event is dispatched only when the user cancels the operation by dismissing the file upload or download dialog box.

download () method
public function download(request:URLRequest, defaultFileName:String = null):void

Opens a dialog box that lets the user download a file from a remote server. Although Flash Player has no restriction on the size of files you can upload or download, the player officially supports uploads or downloads of up to 100 MB.

The download() method first opens an operating-system dialog box that asks the user to enter a filename and select a location on the local computer to save the file. When the user selects a location and confirms the download operation (for example, by clicking Save), the download from the remote server begins. Listeners receive events to indicate the progress, success, or failure of the download. To ascertain the status of the dialog box and the download operation after calling download(), your ActionScript code must listen for events such as cancel, open, progress, and complete.

The FileReference.upload() and FileReference.download() functions are nonblocking. These functions return after they are called, before the file transmission is complete. In addition, if the FileReference object goes out of scope, any upload or download that is not yet completed on that object is canceled upon leaving the scope. Be sure that your FileReference object remains in scope for as long as the upload or download is expected to continue.

When the file is downloaded successfully, the properties of the FileReference object are populated with the properties of the local file. The complete event is dispatched if the download is successful.

Only one browse() or download() session can be performed at a time (because only one dialog box can be invoked at a time).

This method supports downloading of any file type, with either HTTP or HTTPS.

Note: If your server requires user authentication, only SWF files running in a browser — that is, using the browser plug-in or ActiveX control — can provide a dialog box to prompt the user for a user name and password for authentication, and only for downloads. For uploads using the plug-in or ActiveX control, or for uploads and downloads using the stand-alone or external player, the file transfer fails.

When you use this method, consider the Flash Player security model:

  • Loading operations are not allowed if the calling SWF file is in an untrusted local sandbox.
  • The default behavior is to deny access between sandboxes. A website can enable access to a resource by adding a cross-domain policy file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
request:URLRequest — The URLRequest object. The url property of the URLRequest object should contain the URL of the file to download to the local computer. If this parameter is null, an exception is thrown. To send POST or GET parameters to the server, set the value of URLRequest.data to your parameters, and set URLRequest.method to either URLRequestMethod.POST or URLRequestMethod.GET.

On some browsers, URL strings are limited in length. Lengths greater than 256 characters may fail on some browsers or servers.
defaultFileName:String (default = null) — The default filename displayed in the dialog box for the file to be downloaded. This string must not contain the following characters: / \ : * ? " < > | %

If you omit this parameter, the filename of the remote URL is parsed and used as the default.

Events
open:Event — Dispatched when a download operation starts.
progress:ProgressEvent — Dispatched periodically during the file download operation.
complete:Event — Dispatched when the file download operation successfully completes.
cancel:Event — Dispatched when the user dismisses the dialog box.
select:Event — Dispatched when the user selects a file for download from the dialog box.
securityError:SecurityErrorEvent — Dispatched when a download fails because of a security error.
ioError:IOErrorEvent — Dispatched for any of the following reasons:
  • An input/output error occurs while the file is being read or transmitted.
  • The SWF file tries to download a file from a server that requires authentication, within the standalone or external player. During download, the standalone and external players do not provide a means for users to enter passwords. If a SWF file in these players tries to download a file from a server that requires authentication, the download fails. File download can succeed only in the ActiveX control and browser plug-in players.

Throws
IllegalOperationError — Thrown in the following situations: 1) Another browse session is in progress; only one file browsing session can be performed at a time. 2) The value passed to request does not contain a valid path or protocol. 3) The filename to download contains prohibited characters. 4) A setting in the user's mms.cfg file prohibits this operation.
SecurityError — Local untrusted SWF files may not communicate with the Internet. To avoid this situation, reclassify this SWF file as local-with-networking or trusted. This exception is thrown with a message indicating the filename and the URL that may not be accessed because of local file security restrictions.
ArgumentError — If url.data is of type ByteArray, an exception is thrown. For use with the FileReference.upload() and FileReference.download() methods, url.data can only be of type URLVariables or String.
MemoryError — This error can occur for the following reasons: 1) Flash Player cannot convert the URLRequest.data parameter from UTF8 to MBCS. This error is applicable if the URLRequest object passed to the FileReference.download() method is set to perform a GET operation and if System.useCodePage is set to true. 2) Flash Player cannot allocate memory for the POST data. This error is applicable if the URLRequest object passed to the FileReference.download() method is set to perform a POST operation.

See also

FileReference.browse()
FileReferenceList.browse()
FileReference.upload()
Working with file upload and download

Example
The following example shows usage of the download event object. To run this example, change the downloadURL.url property to point to an actual domain and file, rather than the fictional http://www.[yourDomain].com/SomeFile.pdf. You might also need to compile the SWF file with Local playback security set to Access network only or to update Flash Player security settings to allow this file network access.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.URLRequest;
    import flash.net.FileFilter;

    public class FileReference_download extends Sprite {
        private var downloadURL:URLRequest;
        private var fileName:String = "SomeFile.pdf";
        private var file:FileReference;

        public function FileReference_download() {
            downloadURL = new URLRequest();
            downloadURL.url = "http://www.[yourDomain].com/SomeFile.pdf";
            file = new FileReference();
            configureListeners(file);
            file.download(downloadURL, fileName);
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.CANCEL, cancelHandler);
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(Event.SELECT, selectHandler);
        }

        private function cancelHandler(event:Event):void {
            trace("cancelHandler: " + event);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            var file:FileReference = FileReference(event.target);
            trace("progressHandler name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function selectHandler(event:Event):void {
            var file:FileReference = FileReference(event.target);
            trace("selectHandler: name=" + file.name + " URL=" + downloadURL.url);
        }
    }
}

upload () method
public function upload(request:URLRequest, uploadDataFieldName:String = "Filedata", testUpload:Boolean = false):void

Starts the upload of a file selected by a user to a remote server. Although Flash Player has no restriction on the size of files you can upload or download, the player officially supports uploads or downloads of up to 100 MB. You must call the FileReference.browse() or FileReferenceList.browse() method before you call this method.

Listeners receive events to indicate the progress, success, or failure of the upload. Although you can use the FileReferenceList object to let users select multiple files for upload, you must upload the files one by one; to do so, iterate through the FileReferenceList.fileList array of FileReference objects.

The FileReference.upload() and FileReference.download() functions are nonblocking. These functions return after they are called, before the file transmission is complete. In addition, if the FileReference object goes out of scope, any upload or download that is not yet completed on that object is canceled upon leaving the scope. Be sure that your FileReference object remains in scope for as long as the upload or download is expected to continue.

The file is uploaded to the URL passed in the url parameter. The URL must be a server script configured to accept uploads. Flash Player uploads files by using the HTTP POST method. The server script that handles the upload should expect a POST request with the following elements:

  • Content-Type of multipart/form-data
  • Content-Disposition with a name attribute set to "Filedata" by default and a filename attribute set to the name of the original file
  • The binary contents of the file

For a sample POST request, see the description of the uploadDataFieldName parameter. You can send POST or GET parameters to the server with the upload() method; see the description of the request parameter.

If the testUpload parameter is true, and the file to be uploaded is bigger than approximately 10 KB, Flash Player on Windows first sends a test upload POST operation with zero content before uploading the actual file, to verify that the transmission is likely to succeed. Flash Player then sends a second POST operation that contains the actual file content. For files smaller than 10 KB, Flash Player performs a single upload POST with the actual file content to be uploaded. Flash Player on Macintosh does not perform test upload POST operations.

Note: If your server requires user authentication, only SWF files running in a browser — that is, using the browser plug-in or ActiveX control — can provide a dialog box to prompt the user for a username and password for authentication, and only for downloads. For uploads using the plug-in or ActiveX control, or for uploads and downloads using the stand-alone or external player, the file transfer fails.

When you use this method, consider the following restrictions for the Flash Player security model:

  • Loading operations are not allowed if the calling SWF file is in an untrusted local sandbox.
  • The default behavior is to deny access between sandboxes. A website can enable access to a resource by adding a cross-domain policy file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
request:URLRequest — The URLRequest object; the url property of the URLRequest object should contain the URL of the server script configured to handle upload through HTTP POST calls. On some browsers, URL strings are limited in length. Lengths greater than 256 characters may fail on some browsers or servers. If this parameter is null, an exception is thrown.

The URL can be HTTP or, for secure uploads, HTTPS. To use HTTPS, use an HTTPS url in the url parameter. If you do not specify a port number in the url parameter, Flash Player uses port 80 for HTTP and port 443 for HTTPS, by default.

To send POST or GET parameters to the server, set the data property of the URLRequest object to your parameters, and set the method property to either URLRequestMethod.POST or URLRequestMethod.GET.
uploadDataFieldName:String (default = "Filedata") — The field name that precedes the file data in the upload POST operation. The uploadDataFieldName value must be non-null and a non-empty String. By default, the value of uploadDataFieldName is "Filedata", as shown in the following sample POST request:
 Content-Type: multipart/form-data; boundary=AaB03x
 --AaB03x
 Content-Disposition: form-data; name="Filedata"; filename="example.jpg"
 Content-Type: application/octet-stream
 ... contents of example.jpg ...
 --AaB03x--
testUpload:Boolean (default = false) — A setting to request a test file upload. If testUpload is true, for files larger than 10 KB, Flash Player attempts a test file upload POST with a Content-Length of 0. The test upload checks whether the actual file upload will be successful and that server authentication, if required, will succeed. A test upload is only available for Windows players.

Events
open:Event — Dispatched when an upload operation starts.
progress:ProgressEvent — Dispatched periodically during the file upload operation.
complete:Event — Dispatched when the file upload operation completes successfully.
securityError:SecurityErrorEvent — Dispatched when an upload fails because of a security violation.
httpStatus:HTTPStatusEvent — Dispatched when an upload fails because of an HTTP error.
ioError:IOErrorEvent — Invoked in any of the following situations:
  • The upload fails because of an input/output error while Flash Player is reading, writing, or transmitting the file.
  • The upload fails because the SWF file tries to upload a file to a server that requires authentication (such as a user name and password). During upload, Flash Player does not provide a means for users to enter passwords.
  • The upload fails because the url parameter contains an invalid protocol. FileReference.upload() must use HTTP or HTTPS.

Throws
SecurityError — Local untrusted SWF files may not communicate with the Internet. To avoid this situation, reclassify this SWF file as local-with-networking or trusted. This exception is thrown with a message indicating the name of the local file and the URL that may not be accessed.
IllegalOperationError — Thrown in the following situations: 1) Another FileReference or FileReferenceList browse session is in progress; only one file browsing session may be performed at a time. 2) The URL parameter is not a valid path or protocol. File upload must use HTTP, and file download must use FTP or HTTP. 3) The uploadDataFieldName parameter is set to null. 4) A setting in the user's mms.cfg file prohibits this operation.
ArgumentError — Thrown in the following situations: 1) The uploadDataFieldName parameter is an empty string. 2) url.data is of type ByteArray. For use with the FileReference.upload() and FileReference.download() methods, url.data may only be of type URLVariables or String.
MemoryError — This error can occur for the following reasons: 1) Flash Player cannot convert the URLRequest.data parameter from UTF8 to MBCS. This error is applicable if the URLRequest object passed to FileReference.upload() is set to perform a GET operation and if System.useCodePage is set to true. 2) Flash Player cannot allocate memory for the POST data. This error is applicable if the URLRequest object passed to FileReference.upload() is set to perform a POST operation.

See also

FileReference.browse()
FileReferenceList.browse()
FileReference.download()
FileReferenceList.fileList
Working with file upload and download
Event detail
cancel event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CANCEL

Dispatched when a file upload or download is canceled by the user.

Defines the value of the type property of a cancel event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | A reference to the object on which the operation is canceled.

Example
The following example shows usage of the cancel event object. To run this example, change the downloadURL.url property to point to an actual domain and file, rather than the fictional http://www.[yourDomain].com/SomeFile.pdf. You might also need to compile the SWF file with Local playback security set to Access network only or to update Flash Player security settings to allow this file network access.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.URLRequest;

    public class FileReference_event_cancel extends Sprite {
        private var downloadURL:URLRequest;
        private var fileName:String = "SomeFile.pdf";
        private var file:FileReference;

        public function FileReference_event_cancel() {
            downloadURL = new URLRequest();
            downloadURL.url = "http://www.[yourDomain].com/SomeFile.pdf";
            file = new FileReference();
            file.addEventListener(Event.CANCEL, cancelHandler);
            file.download(downloadURL, fileName);
        }
        private function cancelHandler(event:Event):void {
            trace("cancelHandler: " + event);
        }
    }
}

complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched when download is complete or when upload generates an HTTP status code of 200. For file download, this event is dispatched when Flash Player finishes downloading the entire file to disk. For file upload, this event is dispatched after the Flash Player receives an HTTP status code of 200 from the server receiving the transmission.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

Example
The following example shows usage of the complete event object. To run this example, change the downloadURL.url property to point to an actual domain and file, rather than the fictional http://www.[yourDomain].com/SomeFile.pdf. You might also need to compile the SWF file with Local playback security set to Access network only or to update Flash Player security settings to allow this file network access.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.URLRequest;

    public class FileReference_event_complete extends Sprite {
        private var downloadURL:URLRequest;
        private var fileName:String = "SomeFile.pdf";
        private var file:FileReference;

        public function FileReference_event_complete() {
            downloadURL = new URLRequest();
            downloadURL.url = "http://www.[yourDomain].com/SomeFile.pdf";
            file = new FileReference();
            configureListeners(file);
            file.download(downloadURL, fileName);
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.CANCEL, cancelHandler);
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(Event.SELECT, selectHandler);
        }

        private function cancelHandler(event:Event):void {
            trace("cancelHandler: " + event);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            var file:FileReference = FileReference(event.target);
            trace("progressHandler name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function selectHandler(event:Event):void {
            var file:FileReference = FileReference(event.target);
            trace("selectHandler: name=" + file.name + " URL=" + downloadURL.url);
        }
    }
}

See also

FileReference.download()
FileReference.upload()
httpStatus event
Event object type: flash.events.HTTPStatusEvent
HTTPStatusEvent.type property = flash.events.HTTPStatusEvent.HTTP_STATUS

Dispatched when an upload fails and an HTTP status code is available to describe the failure. The httpStatus event is dispatched, followed by an ioError event.

The httpStatus event is dispatched only for upload failures. Because of the way that Flash Player relies on the browser during file download, this event is not applicable for download failures. If a download fails because of an HTTP error, the error is reported as an I/O error.

Defines the value of the type property of a httpStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
status | The HTTP status code returned by the server.
target | The network object receiving an HTTP status code.

See also

FileReference.upload()
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when the upload or download fails. A file transfer can fail for one of the following reasons:

  • An input/output error occurs while the player is reading, writing, or transmitting the file.
  • The SWF file tries to upload a file to a server that requires authentication (such as a user name and password). During upload, Flash Player does not provide a means for users to enter passwords. If a SWF file tries to upload a file to a server that requires authentication, the upload fails.
  • The SWF file tries to download a file from a server that requires authentication, within the stand-alone or external player. During download, the stand-alone and external players do not provide a means for users to enter passwords. If a SWF file in these players tries to download a file from a server that requires authentication, the download fails. File download can succeed only in the ActiveX control and browser plug-in players.
  • The value passed to the url parameter in the upload() method contains an invalid protocol. Valid protocols are HTTP and HTTPS.

Important: Only Flash applications running in a browser — that is, using the browser plug-in or ActiveX control — can provide a dialog box to prompt the user to enter a user name and password for authentication, and then only for downloads. For uploads using the plug-in or ActiveX control, or for upload or download using either the stand-alone or the external player, the file transfer fails.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.

See also

FileReference.download()
FileReference.upload()
open event
Event object type: flash.events.Event
Event.type property = flash.events.Event.OPEN

Dispatched when an upload or download operation starts.

Defines the value of the type property of an open event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has opened a connection.

Example
The following example shows usage of the download event object. To run this example, change the downloadURL.url property to point to an actual domain and file, rather than the fictional http://www.[yourDomain].com/SomeFile.pdf. You might also need to compile the SWF file with Local playback security set to Access network only or to update Flash Player security settings to allow this file network access.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.URLRequest;
    import flash.net.FileFilter;

    public class FileReference_download extends Sprite {
        private var downloadURL:URLRequest;
        private var fileName:String = "SomeFile.pdf";
        private var file:FileReference;

        public function FileReference_download() {
            downloadURL = new URLRequest();
            downloadURL.url = "http://www.[yourDomain].com/SomeFile.pdf";
            file = new FileReference();
            configureListeners(file);
            file.download(downloadURL, fileName);
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.CANCEL, cancelHandler);
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(Event.SELECT, selectHandler);
        }

        private function cancelHandler(event:Event):void {
            trace("cancelHandler: " + event);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            var file:FileReference = FileReference(event.target);
            trace("progressHandler name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function selectHandler(event:Event):void {
            var file:FileReference = FileReference(event.target);
            trace("selectHandler: name=" + file.name + " URL=" + downloadURL.url);
        }
    }
}

See also

FileReference.download()
FileReference.upload()
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched periodically during the file upload or download operation. The progress event is dispatched while Flash Player transmits bytes to a server, and it is periodically dispatched during the transmission, even if the transmission is ultimately not successful. To determine if and when the file transmission is actually successful and complete, listen for the complete event.

In some cases, progress events are not received. For example, when the file being transmitted is very small or the upload or download happens very quickly a progress event might not be dispatched.

File upload progress cannot be determined on Macintosh platforms earlier than OS X 10.3. The progress event is called during the upload operation, but the value of the bytesLoaded property of the progress event is -1, indicating that the progress cannot be determined.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.

Example
The following example shows usage of the progress event. To run this example, change the downloadURL.url property to point to an actual domain and file, rather than the fictional http://www.[yourDomain].com/SomeFile.pdf. You might also need to compile the SWF file with Local playback security set to Access network only or to update Flash Player security settings to allow this file network access.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.URLRequest;

    public class FileReference_event_progress extends Sprite {
        private var downloadURL:URLRequest;
        private var fileName:String = "SomeFile.pdf";
        private var file:FileReference;

        public function FileReference_event_progress() {
            downloadURL = new URLRequest();
            downloadURL.url = "http://www.[yourDomain].com/SomeFile.pdf";
            file = new FileReference();
            file.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            file.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            file.addEventListener(Event.COMPLETE, completeHandler);
            file.download(downloadURL, fileName);
        }

        private function progressHandler(event:ProgressEvent):void {
            var file:FileReference = FileReference(event.target);
            trace("progressHandler: name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }
    }
}

See also

FileReference.complete
flash.events.ProgressEvent
FileReference.download()
FileReference.upload()
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched when a call to the FileReference.upload() or FileReference.download() method tries to upload a file to a server or get a file from a server that is outside the caller's security sandbox. The value of the text property that describes the specific error that occurred is normally "securitySandboxError". The calling SWF file may have tried to access a SWF file outside its domain and does not have permission to do so. You can try to remedy this error by using a cross-domain policy file.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

FileReference.download()
FileReference.upload()
Flash Player Security
select event
Event object type: flash.events.Event
Event.type property = flash.events.Event.SELECT

Dispatched when the user selects a file for upload or download from the file-browsing dialog box. (This dialog box opens when you call the FileReference.browse(), FileReferenceList.browse(), or FileReference.download() method.) When the user selects a file and confirms the operation (for example, by clicking OK), the properties of the FileReference object are populated.

The select event acts slightly differently depending on what method invokes it. When the select event is dispatched after a browse() call, Flash Player can read all the FileReference object's properties, because the file selected by the user is on the local file system. When the select event occurs after a download() call, Flash Player can read only the name property, because the file hasn't yet been downloaded to the local file system at the moment the select event is dispatched. When the file is downloaded and the complete event dispatched, Flash Player can read all other properties of the FileReference object.

Defines the value of the type property of a select event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The FileReference object on which an item has been selected.

Example
The following example shows usage of the select event object. To run this example, change the uploadURL.url property to point to an actual domain and file, rather than the fictional http://www.[yourDomain].com/SomeFile.pdf. You might also need to compile the SWF file with Local playback security set to Access network only or to update Flash Player security settings to allow this file network access. In order for this example to run from your desktop, your server also needs to have a crossdomain.xml file posted. If the ioErrorHandler() function is triggered, you probably need to update the provided uploadURL with a valid url that is configured to receive uploads.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.URLRequest;

    public class FileReference_event_select extends Sprite {
        private var uploadURL:URLRequest;
        private var file:FileReference;

        public function FileReference_event_select() {
            uploadURL = new URLRequest();
            uploadURL.url = "http://www.[yourDomain].com/yourUploadHandlerScript.cfm";
            file = new FileReference();
            file.addEventListener(Event.SELECT, selectHandler);
            file.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            file.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            file.addEventListener(Event.COMPLETE, completeHandler);
            file.browse();
        }

        private function selectHandler(event:Event):void {
            var file:FileReference = FileReference(event.target);
            trace("selectHandler: name=" + file.name + " URL=" + uploadURL.url);
            file.upload(uploadURL);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            var file:FileReference = FileReference(event.target);
            trace("progressHandler: name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }
    }
}

Examples

The following example displays the data format and status information for a file loaded at runtime.

Note: To run this example, change the uploadURL.url property to point to an actual URL, rather than the fictional one in the example. The URL should point to a file named yourUploadHandlerScript.cfm in the root web directory of the URL specified. Based on your configuration, you might also need to compile the SWF file with Local Playback Security set to Access Network Only or to update Flash Player security settings to allow this file network access.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileFilter;
    import flash.net.FileReference;
    import flash.net.URLRequest;

    public class FileReferenceExample extends Sprite {
        private var uploadURL:URLRequest;
        private var file:FileReference;

        public function FileReferenceExample() {
            uploadURL = new URLRequest();
            uploadURL.url = "http://www.[yourDomain].com/yourUploadHandlerScript.cfm";
            file = new FileReference();
            configureListeners(file);
            file.browse(getTypes());
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.CANCEL, cancelHandler);
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(Event.SELECT, selectHandler);
        }

        private function getTypes():Array {
            var allTypes:Array = new Array(getImageTypeFilter(), getTextTypeFilter());
            return allTypes;
        }

        private function getImageTypeFilter():FileFilter {
            return new FileFilter("Images (*.jpg, *.jpeg, *.gif, *.png)", "*.jpg;*.jpeg;*.gif;*.png");
        }

        private function getTextTypeFilter():FileFilter {
            return new FileFilter("Text Files (*.txt, *.rtf)", "*.txt;*.rtf");
        }

        private function cancelHandler(event:Event):void {
            trace("cancelHandler: " + event);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            var file:FileReference = FileReference(event.target);
            trace("progressHandler name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function selectHandler(event:Event):void {
            var file:FileReference = FileReference(event.target);
            trace("selectHandler: name=" + file.name + " URL=" + uploadURL.url);
            file.upload(uploadURL);
        }
    }
}


flash.net.FileReferenceList (Flex™ 2 Language Reference)

Class FileReferenceList | Properties | Methods | Events | Examples
Package | flash.net
Class | public class FileReferenceList
Inheritance | FileReferenceList Inheritance EventDispatcher Inheritance Object

The FileReferenceList class provides a means to let users select one or more files for uploading. A FileReferenceList object represents a group of one or more local files on the user's disk as an array of FileReference objects. For detailed information and important considerations about FileReference objects and the FileReference class, which you use with FileReferenceList, see the FileReference class.

To work with the FileReferenceList class:

  • Instantiate the class: var myFileRef = new FileReferenceList();
  • Call the FileReferenceList.browse() method, which opens a dialog box that lets the user select one or more files for upload: myFileRef.browse();
  • After the browse() method is called successfully, the fileList property of the FileReferenceList object is populated with an array of FileReference objects.
  • Call FileReference.upload() on each element in the fileList array.

The FileReferenceList class includes a browse() method and a fileList property for working with multiple files.

View the examples.

See also

FileReference

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | fileList : Array [read-only] An array of FileReference objects. | FileReferenceList
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FileReferenceList()
Creates a new FileReferenceList object.
FileReferenceList
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
browse(typeFilter:Array = null):Boolean
Displays a file-browsing dialog box that lets the user select one or more local files to upload.
FileReferenceList
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | cancel | Dispatched when the user dismisses the file-browsing dialog box. | FileReferenceList
 | select | Dispatched when the user selects one or more files to upload from the file-browsing dialog box. | FileReferenceList
Property detail
fileList property
fileList:Array [read-only]

An array of FileReference objects.

When the FileReferenceList.browse() method is called and the user has selected one or more files from the dialog box that the browse() method opens, this property is populated with an array of FileReference objects, each of which represents the files the user selected. You can then use this array to upload each file with the FileReference.upload()method. You must upload one file at a time.

The fileList property is populated anew each time browse() is called on that FileReferenceList object.

The properties of FileReference objects are described in the FileReference class documentation.

Implementation
    public function get fileList():Array

See also

FileReference
FileReference.upload()
FileReferenceList.browse()
Working with file upload and download
Constructor detail
FileReferenceList () constructor
public function FileReferenceList()

Creates a new FileReferenceList object. A FileReferenceList object contains nothing until you call the browse() method on it and the user selects one or more files. When you call browse() on the FileReference object, the fileList property of the object is populated with an array of FileReference objects.

See also

FileReference
FileReferenceList.browse()
Method detail
browse () method
public function browse(typeFilter:Array = null):Boolean

Displays a file-browsing dialog box that lets the user select one or more local files to upload. The dialog box is native to the user's operating system. When you call this method and the user successfully selects files, the fileList property of this FileReferenceList object is populated with an array of FileReference objects, one for each file that the user selects. Each subsequent time that the FileReferenceList.browse() method is called, the FileReferenceList.fileList property is reset to the file(s) that the user selects in the dialog box.

Using the typeFilter parameter, you can determine which files the dialog box displays.

Only one FileReference.browse(), FileReference.download(), or FileReferenceList.browse() session can be performed at a time on a FileReferenceList object (because only one dialog box can be opened at a time).

Parameters
typeFilter:Array (default = null) — An array of FileFilter instances used to filter the files that are displayed in the dialog box. If you omit this parameter, all files are displayed. For more information, see the FileFilter class.

Returns
Boolean — Returns true if the parameters are valid and the file-browsing dialog box opens.

Events
select:Event — Invoked when the user has successfully selected an item for upload from the dialog box.
cancel:Event — Invoked when the user dismisses the dialog box by clicking Cancel or by closing it.

Throws
IllegalOperationError — Thrown for the following reasons: 1) Another FileReference or FileReferenceList browse session is in progress; only one file browsing session may be performed at a time. 2) A setting in the user's mms.cfg file prohibits this operation.
ArgumentError — If the typeFilter array does not contain correctly formatted FileFilter objects, an exception is thrown. For details on correct filter formatting, see the FileFilter documentation.

See also

FileReference.browse()
FileReference class
FileFilter class
Working with file upload and download
Event detail
cancel event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CANCEL

Dispatched when the user dismisses the file-browsing dialog box. (This dialog box opens when you call the FileReferenceList.browse(), FileReference.browse(), or FileReference.download() methods.)

Defines the value of the type property of a cancel event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | A reference to the object on which the operation is canceled.

See also

FileReferenceList.browse()
select event
Event object type: flash.events.Event
Event.type property = flash.events.Event.SELECT

Dispatched when the user selects one or more files to upload from the file-browsing dialog box. (This dialog box opens when you call the FileReferenceList.browse(), FileReference.browse(), or FileReference.download() methods.) When the user selects a file and confirms the operation (for example, by clicking Save), the FileReferenceList object is populated with FileReference objects that represent the files that the user selects.

Defines the value of the type property of a select event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The FileReference object on which an item has been selected.

See also

FileReferenceList.browse()
Examples

The following example shows how you can use events to manage the upload of multiple files. The CustomFileReferenceList class extends FileReferenceList and includes a complete event, which is dispatched when each individual file in the FileReferenceList object is uploaded. The LIST_COMPLETE event in the FileReferenceListExample class is dispatched when all the files in the FileReferenceList object have been uploaded.

To run this example, place a script that is written to accept a file upload at http://www.[yourDomain].com/yourUploadHandlerScript.cfm. Based on the location of your SWF file and where you are uploading files to, you also might need to compile the SWF file with Local Playback Security set to Access Network Only or update Flash® Player security settings to allow this file network access. If your upload server is remote and you run this example from your desktop computer, your server must have a crossdomain.xml file.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.FileReference;
    import flash.net.FileReferenceList;

    public class FileReferenceListExample extends Sprite {
        public static var LIST_COMPLETE:String = "listComplete";
        public function FileReferenceListExample() {
            initiateFileUpload();
        }

        private function initiateFileUpload():void {
            var fileRef:CustomFileReferenceList = new CustomFileReferenceList();
            fileRef.addEventListener(FileReferenceListExample.LIST_COMPLETE, listCompleteHandler);
            fileRef.browse(fileRef.getTypes());
        }

        private function listCompleteHandler(event:Event):void {
            trace("listCompleteHandler");
        }
    }
}

import flash.events.*;
import flash.net.FileReference;
import flash.net.FileReferenceList;
import flash.net.FileFilter;
import flash.net.URLRequest;

class CustomFileReferenceList extends FileReferenceList {
    private var uploadURL:URLRequest;
    private var pendingFiles:Array;

    public function CustomFileReferenceList() {
        uploadURL = new URLRequest();
        uploadURL.url = "http://www.[yourDomain].com/yourUploadHandlerScript.cfm";
        initializeListListeners();
    }

    private function initializeListListeners():void {
        addEventListener(Event.SELECT, selectHandler);
        addEventListener(Event.CANCEL, cancelHandler);
    }

    public function getTypes():Array {
        var allTypes:Array = new Array();
        allTypes.push(getImageTypeFilter());
        allTypes.push(getTextTypeFilter());
        return allTypes;
    }

    private function getImageTypeFilter():FileFilter {
        return new FileFilter("Images (*.jpg, *.jpeg, *.gif, *.png)", "*.jpg;*.jpeg;*.gif;*.png");
    }

    private function getTextTypeFilter():FileFilter {
        return new FileFilter("Text Files (*.txt, *.rtf)", "*.txt;*.rtf");
    }

    private function doOnComplete():void {
        var event:Event = new Event(FileReferenceListExample.LIST_COMPLETE);
        dispatchEvent(event);
    }

    private function addPendingFile(file:FileReference):void {
        trace("addPendingFile: name=" + file.name);
        pendingFiles.push(file);
        file.addEventListener(Event.OPEN, openHandler);
        file.addEventListener(Event.COMPLETE, completeHandler);
        file.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        file.addEventListener(ProgressEvent.PROGRESS, progressHandler);
        file.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
        file.upload(uploadURL);
    }

    private function removePendingFile(file:FileReference):void {
        for (var i:uint; i < pendingFiles.length; i++) {
            if (pendingFiles[i].name == file.name) {
                pendingFiles.splice(i, 1);
                if (pendingFiles.length == 0) {
                    doOnComplete();
                }
                return;
            }
        }
    }

    private function selectHandler(event:Event):void {
        trace("selectHandler: " + fileList.length + " files");
        pendingFiles = new Array();
        var file:FileReference;
        for (var i:uint = 0; i < fileList.length; i++) {
            file = FileReference(fileList[i]);
            addPendingFile(file);
        }
    }

    private function cancelHandler(event:Event):void {
        var file:FileReference = FileReference(event.target);
        trace("cancelHandler: name=" + file.name);
    }

    private function openHandler(event:Event):void {
        var file:FileReference = FileReference(event.target);
        trace("openHandler: name=" + file.name);
    }

    private function progressHandler(event:ProgressEvent):void {
        var file:FileReference = FileReference(event.target);
        trace("progressHandler: name=" + file.name + " bytesLoaded=" + event.bytesLoaded + " bytesTotal=" + event.bytesTotal);
    }

    private function completeHandler(event:Event):void {
        var file:FileReference = FileReference(event.target);
        trace("completeHandler: name=" + file.name);
        removePendingFile(file);
    }

    private function httpErrorHandler(event:Event):void {
        var file:FileReference = FileReference(event.target);
        trace("httpErrorHandler: name=" + file.name);
    }

    private function ioErrorHandler(event:Event):void {
        var file:FileReference = FileReference(event.target);
        trace("ioErrorHandler: name=" + file.name);
    }

    private function securityErrorHandler(event:Event):void {
        var file:FileReference = FileReference(event.target);
        trace("securityErrorHandler: name=" + file.name + " event=" + event.toString());
    }
}


flash.net.IDynamicPropertyOutput (Flex™ 2 Language Reference)

Interface IDynamicPropertyOutput | Methods
Package | flash.net
Interface | public interface IDynamicPropertyOutput

This interface controls the serialization of dynamic properties of dynamic objects. You use this interface with the IDynamicPropertyWriter interface and the ObjectEncoding.dynamicPropertyWriter property.

See also

IDynamicPropertyWriter
ObjectEncoding.dynamicPropertyWriter

Public Methods
Method |  | Defined by
 | writeDynamicProperty(name:String, value:*):void Adds a dynamic property to the binary output of a serialized object. | IDynamicPropertyOutput
Method detail
writeDynamicProperty () method
public function writeDynamicProperty(name:String, value:*):void

Adds a dynamic property to the binary output of a serialized object. When the object is subsequently read (using a method such as readObject), it contains the new property. You can use this method to exclude properties of dynamic objects from serialization; to write values to properties of dynamic objects; or to create new properties for dynamic objects.

Parameters
name:String — The name of the property. You can use this parameter either to specify the name of an existing property of the dynamic object or to create a new property.
value:* — The value to write to the specified property.

See also

IDynamicPropertyWriter
ObjectEncoding.dynamicPropertyWriter


flash.net.IDynamicPropertyWriter (Flex™ 2 Language Reference)

Interface IDynamicPropertyWriter | Methods
Package | flash.net
Interface | public interface IDynamicPropertyWriter

This interface is used with the IDynamicPropertyOutput interface to control the serialization of dynamic properties of dynamic objects. To use this interface, assign an object that implements the IDynamicPropertyWriter interface to the ObjectEncoding.dynamicPropertyWriter property.

See also

IDynamicPropertyOutput
ObjectEncoding.dynamicPropertyWriter

Public Methods
Method |  | Defined by
 | writeDynamicProperties(obj:Object, output:IDynamicPropertyOutput):void Writes the name and value of an IDynamicPropertyOutput object to an object with dynamic properties. | IDynamicPropertyWriter
Method detail
writeDynamicProperties () method
public function writeDynamicProperties(obj:Object, output:IDynamicPropertyOutput):void

Writes the name and value of an IDynamicPropertyOutput object to an object with dynamic properties. If ObjectEncoding.dynamicPropertyWriter is set, this method is invoked for each object with dynamic properties.

Parameters
obj:Object — The object to write to.
output:IDynamicPropertyOutput — The IDynamicPropertyOutput object that contains the name and value to dynamically write to the object.

See also

IDynamicPropertyOutput
ObjectEncoding.dynamicPropertyWriter


flash.net.LocalConnection (Flex™ 2 Language Reference)

Class LocalConnection | Properties | Methods | Events | Examples
Package | flash.net
Class | public class LocalConnection
Inheritance | LocalConnection Inheritance EventDispatcher Inheritance Object

The LocalConnection class lets you create a LocalConnection object that can invoke a method in another LocalConnection object, either within a single SWF file or between multiple SWF files. Local connections enable this kind of communication between SWF files without the use of fscommand() or JavaScript. LocalConnection objects can communicate only among SWF files that are running on the same client computer, but they can be running in different applications — for example, a SWF file running in a browser and a SWF file running in a projector. (A projector is a SWF file saved in a format that can run as a stand-alone application — that is, without Flash Player.)

LocalConnection objects created in ActionScript 3.0 can communicate with LocalConnection objects created in ActionScript 1.0 or 2.0. The reverse is also true: LocalConnection objects created in ActionScript 1.0 or 2.0 can communicate with LocalConnection objects created in ActionScript 3.0. Flash Player handles this communication between LocalConnection objects of different versions automatically.

To understand how to use LocalConnection objects to implement communication between two SWF files, it is helpful to identify the commands used in each file. One SWF file is called the sending SWF file; it is the file that contains the method to be invoked. The sending SWF file must contain a LocalConnection object and a call to the send() method. The other SWF file is called the receiving SWF file; it is the file that invokes the method. The receiving SWF file must contain another LocalConnection object and a call to the connect() method.

Your use of send() and connect() differs depending on whether the SWF files are in the same domain, in different domains with predictable domain names, or in different domains with unpredictable or dynamic domain names. The following paragraphs explain the three different situations, with code samples for each.

Same domain. This is the simplest way to use a LocalConnection object, to allow communication only between LocalConnection objects that are located in the same domain, because Flash Player allows same-domain communication by default. When two SWF files from the same domain communicate, you do not need to implement any special security measures, and you simply pass the same value for the connectionName parameter to both the connect() and send() methods:

// receivingLC is in http://www.domain.com/receiving.swf
receivingLC.connect('myConnection');

// sendingLC is in http://www.domain.com/sending.swf
// myMethod() is defined in sending.swf
sendingLC.send('myConnection', 'myMethod');

Different domains with predictable domain names. When two SWF files from different domains communicate, you need to allow communication between the two domains by calling the allowDomain() method. You also need to qualify the connection name in the send() method with the receiving LocalConnection object's domain name:

// receivingLC is in http://www.domain.com/receiving.swf
receivingLC.allowDomain('www.anotherdomain.com');
receivingLC.connect('myConnection');

// sendingLC is in http://www.anotherdomain.com/sending.swf
sendingLC.send('www.domain.com:myConnection', 'myMethod');

Different domains with unpredictable domain names. Sometimes, you might want to make the SWF file with the receiving LocalConnection object more portable between domains. To avoid specifying the domain name in the send() method, but to indicate to Flash Player that the receiving and sending LocalConnection objects are not in the same domain, precede the connection name with an underscore (_), in both the connect() and send() calls. To allow communication between the two domains, call the allowDomain() method and pass the domains from which you want to allow LocalConnection calls. Alternatively, pass the wildcard (*) argument to allow calls from all domains:

// receivingLC is in http://www.domain.com/receiving.swf
receivingLC.allowDomain('*');
receivingLC.connect('_myConnection');

// sendingLC is in http://www.anotherdomain.com/sending.swf
sendingLC.send('_myConnection', 'myMethod');

You can use LocalConnection objects to send and receive data within a single SWF file, but this is not a typical implementation.

For more information about the send() and connect() methods, see the discussion of the connectionName parameter in the LocalConnection.send() and LocalConnection.connect()entries. Also, see the allowDomain() and domain entries.

View the examples.

See also

flash.net.LocalConnection.send()
flash.net.LocalConnection.allowDomain()
flash.net.LocalConnection.domain
Connecting to other Flash Player instances

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | client : Object Indicates the object on which callback methods are invoked. | LocalConnection
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | domain : String [read-only] A string representing the domain of the location of the current SWF file. | LocalConnection
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LocalConnection()
Creates a LocalConnection object.
LocalConnection
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
allowDomain(... domains):void
Specifies one or more domains that can send LocalConnection calls to this LocalConnection instance.
LocalConnection
allowInsecureDomain(... domains):void
Specifies one or more domains that can send LocalConnection calls to this LocalConnection object.
LocalConnection
close():void
Closes (disconnects) a LocalConnection object.
LocalConnection
connect(connectionName:String):void
Prepares a LocalConnection object to receive commands from a send() command (called the sending LocalConnection object).
LocalConnection
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(connectionName:String, methodName:String, ... arguments):void
Invokes the method named methodName on a connection opened with the connect(connectionName) method (the receiving LocalConnection object).
LocalConnection
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | asyncError | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code. | LocalConnection
 | securityError | Dispatched if a call to LocalConnection.send() attempts to send data to a different security sandbox. | LocalConnection
 | status | Dispatched when a LocalConnection object reports its status. | LocalConnection
Property detail
client property
client:Object [read-write]

Indicates the object on which callback methods are invoked. The default object is this, the local connection being created. You can set the client property to another object, and callback methods are invoked on that other object.

Implementation
    public function get client():Object
    public function set client(value:Object):void

Throws
TypeError — The client property must be set to a non-null object.

See also

Connecting to other Flash Player instances
domain property
domain:String [read-only]

A string representing the domain of the location of the current SWF file.

In SWF files published for Flash Player 9 or later, the returned string is the exact domain of the current SWF file, including subdomains. For example, if the SWF file is located at www.adobe.com, this command returns "www.adobe.com".

If the current SWF file is a local file residing on the client computer, this command returns "localhost".

The most common ways to use this property are to include the domain name of the sending LocalConnection object as a parameter to the method you plan to invoke in the receiving LocalConnection object, or to use it with LocalConnection.allowDomain() to accept commands from a specified domain. If you are enabling communication only between LocalConnection objects that are located in the same domain, you probably don't need to use this property.

Implementation
    public function get domain():String

See also

flash.net.LocalConnection.allowDomain()
flash.net.LocalConnection.connect()
Constructor detail
LocalConnection () constructor
public function LocalConnection()

Creates a LocalConnection object. You can use LocalConnection objects to enable communication between different SWF files that are running on the same client computer.

See also

flash.net.LocalConnection.connect()
flash.net.LocalConnection.send()
Method detail
allowDomain () method
public function allowDomain(... domains):void

Specifies one or more domains that can send LocalConnection calls to this LocalConnection instance.

When using this method, consider the Flash Player security model. By default, a LocalConnection object is associated with the sandbox of the SWF file that created it, and cross-domain calls to LocalConnection objects are not allowed unless you call the LocalConnection.allowDomain() method in the receiving SWF file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

Note: The allowDomain() method has changed from the form it had in ActionScript 1.0 and 2.0. In those earlier versions, allowDomain was a callback method that you implemented. In ActionScript 3.0, allowDomain() is a built-in method of LocalConnection that you call. With this change, allowDomain() works in much the same way as flash.system.Security.allowDomain().

Parameters
... domains — One or more strings that name the domains from which you want to allow LocalConnection calls. This parameter has two special cases:
  • You can specify a wildcard character "*" to allow calls from all domains.
  • You can specify the string "localhost" to allow calls to this SWF file from SWF files that are installed locally. Flash Player 8 introduced security restrictions on local SWF files. By default, a SWF file that is allowed to access the Internet cannot also have access to the local file system. If you specify "localhost", any local SWF file can access this SWF file.

Throws
ArgumentError — All parameters specified must be non-null strings.

See also

flash.system.Security.allowDomain()
flash.display.LoaderInfo.url
Connecting to other Flash Player instances
Connecting to other Flash Player instances
Flash Player Security
allowInsecureDomain () method
public function allowInsecureDomain(... domains):void

Specifies one or more domains that can send LocalConnection calls to this LocalConnection object.

The allowInsecureDomain() method works just like the allowDomain() method, except that the allowInsecureDomain() method additionally permits SWF files from non-HTTPS origins to send LocalConnection calls to SWF files from HTTPS origins. This difference is meaningful only if you call the allowInsecureDomain() method from a SWF file that was loaded using HTTPS. You must call the allowInsecureDomain() method even if you are crossing a non-HTTPS/HTTPS boundary within the same domain; by default, LocalConnection calls are never permitted from non-HTTPS SWF files to HTTPS SWF files, even within the same domain.

Calling allowInsecureDomain() is not recommended, because it can compromise the security offered by HTTPS. When you load a SWF file over HTTPS, you can be reasonably sure that that SWF file will not be tampered with during delivery over the network. If you then permit a non-HTTPS SWF file to make LocalConnection calls to the HTTPS SWF file, you are accepting calls from a SWF file that may in fact have been tampered with during delivery. This generally requires extra vigilance because you cannot trust the authenticity of LocalConnection calls arriving at your HTTPS SWF file.

By default, SWF files hosted using the HTTPS protocol can be accessed only by other SWF files hosted using the HTTPS protocol. This implementation maintains the integrity provided by the HTTPS protocol.

Using this method to override the default behavior is not recommended, because it compromises HTTPS security. However, you might need to do so, for example, if you need to permit access to HTTPS files published for Flash Player 9 or later from HTTP files published for Flash Player 6 or earlier.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
... domains — One or more strings that name the domains from which you want to allow LocalConnection calls. There are two special cases for this parameter:
  • You can specify the wildcard character "*" to allow calls from all domains. Specifying "*" does not include local hosts.
  • You can specify the string "localhost" to allow calls to this SWF file from SWF files that are installed locally. Flash Player 8 introduced security restrictions on local SWF files. A SWF file that is allowed to access the Internet cannot also have access to the local file system. If you specify "localhost", any local SWF file can access this SWF file. Remember that you must also designate the calling SWF file as a local-with-networking SWF file at authoring time.

Throws
ArgumentError — All parameters specified must be non-null strings.

See also

flash.net.LocalConnection.allowDomain()
Connecting to other Flash Player instances
Flash Player Security
close () method
public function close():void

Closes (disconnects) a LocalConnection object. Issue this command when you no longer want the object to accept commands — for example, when you want to issue a connect() command using the same connectionName parameter in another SWF file.

Throws
ArgumentError — The LocalConnection instance is not connected, so it cannot be closed.

See also

flash.net.LocalConnection.connect()
connect () method
public function connect(connectionName:String):void

Prepares a LocalConnection object to receive commands from a send() command (called the sending LocalConnection object). The object used with this command is called the receiving LocalConnection object. The receiving and sending objects must be running on the same client computer.

To avoid a race condition, define the methods attached to the receiving LocalConnection object before calling this method, as shown in the LocalConnection class example.

By default, Flash Player resolves connectionName into a value of "superdomain:connectionName", where superdomain is the superdomain of the SWF file that contains the connect() command. For example, if the SWF file that contains the receiving LocalConnection object is located at www.someDomain.com, connectionName resolves to "someDomain.com:connectionName". (If a SWF file is located on the client computer, the value assigned to superdomain is "localhost".)

Also by default, Flash Player lets the receiving LocalConnection object accept commands only from sending LocalConnection objects whose connection name also resolves into a value of "superdomain:connectionName". In this way, Flash makes it simple for SWF files that are located in the same domain to communicate with each other.

If you are implementing communication only between SWF files in the same domain, specify a string for connectionName that does not begin with an underscore (_) and that does not specify a domain name (for example, "myDomain:connectionName"). Use the same string in the connect(connectionName) method.

If you are implementing communication between SWF files in different domains, specifying a string for connectionName that begins with an underscore (_) makes the SWF file with the receiving LocalConnection object more portable between domains. Here are the two possible cases:

  • If the string for connectionNamedoes not begin with an underscore (_), Flash Player adds a prefix with the superdomain and a colon (for example, "myDomain:connectionName"). Although this ensures that your connection does not conflict with connections of the same name from other domains, any sending LocalConnection objects must specify this superdomain (for example, "myDomain:connectionName"). If the SWF file with the receiving LocalConnection object is moved to another domain, the player changes the prefix to reflect the new superdomain (for example, "anotherDomain:connectionName"). All sending LocalConnection objects would have to be manually edited to point to the new superdomain.
  • If the string for connectionNamebegins with an underscore (for example, "_connectionName"), Flash Player does not add a prefix to the string. This means that the receiving and sending LocalConnection objects use identical strings for connectionName. If the receiving object uses allowDomain() to specify that connections from any domain will be accepted, the SWF file with the receiving LocalConnection object can be moved to another domain without altering any sending LocalConnection objects.

For more information, see the discussion in the class overview and the discussion of connectionName in send(), and also the allowDomain() and domain entries.

Note: Colons are used as special characters to separate the superdomain from the connectionName string. A string for connectionName that contains a colon is not valid.

Parameters
connectionName:String — A string that corresponds to the connection name specified in the send() command that wants to communicate with the receiving LocalConnection object.

Throws
TypeError — The value passed to the connectionName parameter must be non-null.
ArgumentError — This error can occur for three reasons: 1) The string value passed to the connectionName parameter was null. Pass a non-null value. 2) The value passed to the connectionName parameter contained a colon (:). Colons are used as special characters to separate the superdomain from the connectionName string in the send() method, not the connect()method. 3) The LocalConnection instance is already connected.

See also

flash.net.LocalConnection.send()
flash.net.LocalConnection.allowDomain()
flash.net.LocalConnection.domain
Connecting to other Flash Player instances
send () method
public function send(connectionName:String, methodName:String, ... arguments):void

Invokes the method named methodName on a connection opened with the connect(connectionName) method (the receiving LocalConnection object). The object used with this command is called the sending LocalConnection object. The SWF files that contain the sending and receiving objects must be running on the same client computer.

There is a 40 kilobyte limit to the amount of data you can pass as parameters to this command. If send() throws an ArgumentError but your syntax is correct, try dividing the send() requests into multiple commands, each with less than 40K of data.

As discussed in the connect() entry, Flash Player adds the current superdomain to connectionName by default. If you are implementing communication between different domains, you need to define connectionName in both the sending and receiving LocalConnection objects in such a way that Flash does not add the current superdomain to connectionName. You can do this in one of the following two ways:

  • Use an underscore (_) at the beginning of connectionName in both the sending and receiving LocalConnection objects. In the SWF file that contains the receiving object, use LocalConnection.allowDomain() to specify that connections from any domain will be accepted. This implementation lets you store your sending and receiving SWF files in any domain.
  • Include the superdomain in connectionName in the sending LocalConnection object — for example, myDomain.com:myConnectionName. In the receiving object, use LocalConnection.allowDomain() to specify that connections from the specified superdomain will be accepted (in this case, myDomain.com) or that connections from any domain will be accepted.

Note: You cannot specify a superdomain in connectionName in the receiving LocalConnection object — you can do this in only the sending LocalConnection object.

When using this method, consider the Flash Player security model. By default, a LocalConnection object is associated with the sandbox of the SWF file that created it, and cross-domain calls to LocalConnection objects are not allowed unless you call the LocalConnection.allowDomain() method in the receiving SWF file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
connectionName:String — Corresponds to the connection name specified in the connect() command that wants to communicate with the sending LocalConnection object.
methodName:String — The name of the method to be invoked in the receiving LocalConnection object. The following method names cause the command to fail: send, connect, close, allowDomain, allowInsecureDomain, client, and domain.
... arguments — Additional optional parameters to be passed to the specified method.

Events
securityError:SecurityErrorEvent — LocalConnection.send() attempted to communicate with a SWF file from a security sandbox to which the calling code does not have access. You can work around this in the receiver's implementation of LocalConnection.allowDomain().
status:StatusEvent — If the value of the level property is "status", the call was successful; if the value is "error", the call failed. The call can fail if the receiving SWF file refuses the connection.

Throws
TypeError — The value of either connectionName or methodName is null. Pass non-null values for these parameters.
ArgumentError — This error can occur for one of the following reasons: 1) The value of either connectionName or methodName is an empty string. Pass valid strings for these parameters. 2) The method specified in methodName is restricted. 3) The serialized message that is being sent is too large (larger than 40K).

See also

flash.net.LocalConnection.allowDomain()
flash.net.LocalConnection.connect()
flash.net.LocalConnection.domain
Connecting to other Flash Player instances
Connecting to other Flash Player instances
Event detail
asyncError event
Event object type: flash.events.AsyncErrorEvent
AsyncErrorEvent.type property = flash.events.AsyncErrorEvent.ASYNC_ERROR

Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code.

The AsyncErrorEvent.ASYNC_ERROR constant defines the value of the type property of an asyncError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object experiencing a network operation failure.
error | The error that triggered the event.
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched if a call to LocalConnection.send() attempts to send data to a different security sandbox.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

send()
Flash Player Security
status event
Event object type: flash.events.StatusEvent
StatusEvent.type property = flash.events.StatusEvent.STATUS

Dispatched when a LocalConnection object reports its status. If LocalConnection.send() is successful, the value of the status event object's level property is "status"; if the call fails, the level property is "error". If the receiving SWF file refuses the connection, the call can fail without notification to the sending SWF file.

Defines the value of the type property of a status event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
code | A description of the object's status.
currentTarget | The object that is actively processing the Event object with an event listener.
level | The category of the message, such as "status", "warning" or "error".
target | The object reporting its status.

See also

LocalConnection.send()
Examples

This example consists of two ActionScript classes which should be compiled into two separate SWF files:

In the LocalConnectionSenderExample SWF file, a LocalConnection instance is created, and when the button is pressed the call() method is used to call the method named lcHandler in the SWF file with the connection name "myConnection," passing the contents of the TextField as a parameter.

In the LocalConnectionReceiverExample SWF file, a LocalConnection instance is created and the connect() method is called to designate this SWF file as the recipient of messages that are addressed to the connection named "myConnection." In addition, this class includes a public method named lcHandler(); this method is the one that is called by the LocalConnectionSenderExample SWF file. When it's called, the text that is passed in as a parameter is appended to the TextField on the Stage.

Note: To test the example, both SWF files must be loaded on the same computer simultaneously.

// Code in LocalConnectionSenderExample.as
package {
    import flash.display.Sprite;
    import flash.events.MouseEvent;
    import flash.net.LocalConnection;
    import flash.text.TextField;
    import flash.text.TextFieldType;
    import flash.events.StatusEvent;
    import flash.text.TextFieldAutoSize;

    public class LocalConnectionSenderExample extends Sprite {
        private var conn:LocalConnection;

        // UI elements
        private var messageLabel:TextField;
        private var message:TextField;
        private var sendBtn:Sprite;

        public function LocalConnectionSenderExample() {
            buildUI();
            sendBtn.addEventListener(MouseEvent.CLICK, sendMessage);
            conn = new LocalConnection();
            conn.addEventListener(StatusEvent.STATUS, onStatus);
        }

        private function sendMessage(event:MouseEvent):void {
            conn.send("myConnection", "lcHandler", message.text);
        }

        private function onStatus(event:StatusEvent):void {
            switch (event.level) {
                case "status":
                    trace("LocalConnection.send() succeeded");
                    break;
                case "error":
                    trace("LocalConnection.send() failed");
                    break;
            }
        }

        private function buildUI():void {
            const hPadding:uint = 5;
            // messageLabel
            messageLabel = new TextField();
            messageLabel.x = 10;
            messageLabel.y = 10;
            messageLabel.text = "Text to send:";
            messageLabel.autoSize = TextFieldAutoSize.LEFT;
            addChild(messageLabel);

            // message
            message = new TextField();
            message.x = messageLabel.x + messageLabel.width + hPadding;
            message.y = 10;
            message.width = 120;
            message.height = 20;
            message.background = true;
            message.border = true;
            message.type = TextFieldType.INPUT;
            addChild(message);

            // sendBtn
            sendBtn = new Sprite();
            sendBtn.x = message.x + message.width + hPadding;
            sendBtn.y = 10;
            var sendLbl:TextField = new TextField();
            sendLbl.x = 1 + hPadding;
            sendLbl.y = 1;
            sendLbl.selectable = false;
            sendLbl.autoSize = TextFieldAutoSize.LEFT;
            sendLbl.text = "Send";
            sendBtn.addChild(sendLbl);
            sendBtn.graphics.lineStyle(1);
            sendBtn.graphics.beginFill(0xcccccc);
            sendBtn.graphics.drawRoundRect(0, 0, (sendLbl.width + 2 + hPadding + hPadding), (sendLbl.height + 2), 5, 5);
            sendBtn.graphics.endFill();
            addChild(sendBtn);
        }
    }
}

// Code in LocalConnectionReceiverExample.as
package {
    import flash.display.Sprite;
    import flash.net.LocalConnection;
    import flash.text.TextField;

    public class LocalConnectionReceiverExample extends Sprite {
        private var conn:LocalConnection;
        private var output:TextField;

        public function LocalConnectionReceiverExample()     {
            buildUI();

            conn = new LocalConnection();
            conn.client = this;
            try {
                conn.connect("myConnection");
            } catch (error:ArgumentError) {
                trace("Can't connect...the connection name is already being used by another SWF");
            }
        }

        public function lcHandler(msg:String):void {
            output.appendText(msg + "\n");
        }

        private function buildUI():void {
            output = new TextField();
            output.background = true;
            output.border = true;
            output.wordWrap = true;
            addChild(output);
        }
    }
}


flash.net.NetConnection (Flex™ 2 Language Reference)

Class NetConnection | Properties | Methods | Events | Examples
Package | flash.net
Class | public class NetConnection
Inheritance | NetConnection Inheritance EventDispatcher Inheritance Object

The NetConnection class lets you invoke commands on a remote application server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, and to play streaming Flash Video (FLV) files from either an HTTP address or a local drive. Typically, you use NetConnection objects with NetStream objects.

When you use this class, consider the Flash Player security model:

  • Loading and playing an audio or video file is not allowed if the calling SWF file is in a network sandbox and the file to be loaded is local.
  • By default, loading and playing an audio or video file is not allowed if the calling SWF is local and tries to load and play a remote file. A user must grant explicit permission to allow this.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

Some of the properties and methods in the NetStream class are intended for use primarily with a server, such as Flash Media Server or Flex. They may contain additional server-side functionality. For additional documentation, see the NetStream class in Flash Media Server documentation.

Note: This class was dynamic in ActionScript 2.0 but is now sealed. To write callback methods for this class, you can either extend the class and define the callback methods in your subclass, or you can use the client property to refer to an object and define the callback methods on that object.

View the examples.

See also

client
NetStream

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | client : Object Indicates the object on which callback methods should be invoked. | NetConnection
 | connected : Boolean [read-only] Indicates whether Flash Player has connected to a server through a persistent RTMP connection (true) or not (false). | NetConnection
 | connectedProxyType : String [read-only] If a successful connection is made, indicates the method that was used to make it: a direct connection, the CONNECT method, or HTTP tunneling. | NetConnection
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | defaultObjectEncoding : uint [static] The default object encoding (AMF version) for NetConnection objects created in the SWF file. | NetConnection
 | objectEncoding : uint The object encoding (AMF version) for this NetConnection instance. | NetConnection
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | proxyType : String Determines whether native SSL is used for RTMPS instead of HTTPS, and whether the CONNECT method of tunneling is used to connect through a proxy server. | NetConnection
 | uri : String [read-only] The URI of the application server that was passed to NetConnection.connect(), if connect was used to connect to a server. | NetConnection
 | usingTLS : Boolean [read-only] Indicates whether a secure connection was made using native Transport Layer Security (TLS) rather than HTTPS. | NetConnection
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NetConnection()
Creates a NetConnection object that you can use with a NetStream object to invoke commands on a remote application server or to play back streaming video (FLV) files locally or from a server.
NetConnection
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
addHeader(operation:String, mustUnderstand:Boolean = false, param:Object = null):void
Adds a context header to the AMF packet structure.
NetConnection
call(command:String, responder:Responder, ... arguments):void
Invokes a command or method on the server running Flash Media Server, or on an application server, to which the application instance is connected.
NetConnection
close():void
Closes the connection that was opened locally or with the server and dispatches the netStatus event with a code property of NetConnection.Connect.Close.
NetConnection
connect(command:String, ... arguments):void
Opens a connection to a server.
NetConnection
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | asyncError | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code. | NetConnection
 | ioError | Dispatched when an input or output error occurs that causes a network operation to fail. | NetConnection
 | netStatus | Dispatched when a NetConnection object is reporting its status or error condition. | NetConnection
 | securityError | Dispatched if a call to NetConnection.call() attempts to connect to a server outside the caller's security sandbox. | NetConnection
Property detail
client property
client:Object [read-write]

Indicates the object on which callback methods should be invoked. The default is this NetConnection instance. If you set the client property to another object, callback methods will be invoked on that object.

Implementation
    public function get client():Object
    public function set client(value:Object):void

Throws
TypeError — The client property must be set to a non-null object.
connected property
connected:Boolean [read-only]

Indicates whether Flash Player has connected to a server through a persistent RTMP connection (true) or not (false). When connected through HTTP, this property is always false. It is always true for AMF connections to application servers.

Implementation
    public function get connected():Boolean
connectedProxyType property
connectedProxyType:String [read-only]

If a successful connection is made, indicates the method that was used to make it: a direct connection, the CONNECT method, or HTTP tunneling. Possible values are "none", "HTTP", "HTTPS", and "CONNECT". This property is valid only when a NetConnection object is connected. This property is used in Flex applications and Flash Media Server applications. In Flash Player 9, this property is applicable only when RTMP, RTMPS, or RTMPT is used. The CONNECT method is applicable only to users who are connected to the network by a proxy server.

You can read this property to determine which method of connection was used. This property returns "none" if a direct connection was made, "HTTP" if HTTP tunneling was used, "HTTPS" if secure HTTPS tunneling was used, and "CONNECT" if the proxy CONNECT method was used.

Implementation
    public function get connectedProxyType():String

Throws
ArgumentError — An attempt was made to access this property when the NetConnection instance was not connected.
defaultObjectEncoding property
defaultObjectEncoding:uint [read-write]

The default object encoding (AMF version) for NetConnection objects created in the SWF file. When an object is written to or read from binary data, the defaultObjectEncoding property indicates which Action Message Format version should be used: the ActionScript 3.0 format or the ActionScript 1.0 and ActionScript 2.0 format.

By default, NetConnection.defaultObjectEncoding is set to use the ActionScript 3.0 format, AMF3. Changing NetConnection.defaultObjectEncoding does not affect existing NetConnection instances; it affects only instances that are created subsequently.

To set an object's encoding separately (rather than setting object encoding for the entire SWF file), set the objectEncoding property of the NetConnection object instead.

For more detailed information, see the description of the objectEncoding property.

Implementation
    public static function get defaultObjectEncoding():uint
    public function set defaultObjectEncoding(value:uint):void

See also

NetConnection.objectEncoding
flash.net.ObjectEncoding
objectEncoding property
objectEncoding:uint [read-write]

The object encoding (AMF version) for this NetConnection instance. The default value of this property is the value of defaultObjectEncoding. Acceptable values are ObjectEncoding.AMF3 and ObjectEncoding.AMF0.

It's important to understand this property if your ActionScript 3.0 SWF file needs to communicate with servers released prior to Flash Player 9.

When an object is written to or read from binary data, the objectEncoding property indicates which Action Message Format version should be used: the ActionScript 3.0 format (ObjectEncoding.AMF3) or the ActionScript 1.0 and ActionScript 2.0 format (ObjectEncoding.AMF0). When you use NetConnection objects to connect to a server, three scenarios are possible:

  • Connecting exclusively to a server that was released with or after Flash Player 9, such as Flex 2. The default value of defaultObjectEncoding is ObjectEncoding.AMF3. All NetConnection instances created in this SWF file use AMF3 serialization, so you don't need to tell Flash Player which AMF encoding to use.
  • Connecting exclusively to a server that was released prior to Flash Player 9, such as Flex 1.5 and Flash Media Server 2. In this scenario, set the static defaultObjectEncoding property to ObjectEncoding.AMF0. All NetConnection instances created in this SWF file use AMF0 serialization. You don't need to set the objectEncoding property.
  • Connecting to multiple servers that use different encoding versions. Instead of using defaultObjectEncoding, set the object encoding on a per-connection basis using the objectEncoding property for each connection. Set it to ObjectEncoding.AMF0 to connect to servers that use AMF0 encoding, such as Flex 1.5 and Flash Media Server 2, and set it to ObjectEncoding.AMF3 to connect to servers that use AMF3 encoding, such as Flex 2.

Changing defaultObjectEncoding does not affect existing NetConnection instances; it affects only instances that are created subsequently.

Once the NetConnection instance is connected, its objectEncoding property is read-only.

If you use the wrong encoding to connect to a server, Flash Player dispatches the netStatus event. The NetStatusEvent.info property contains an information object with a code property value of NetConnection.Connect.Failed, and a description explaining that the object encoding is incorrect.

Implementation
    public function get objectEncoding():uint
    public function set objectEncoding(value:uint):void

Throws
ReferenceError — An attempt was made to set the value of the objectEncoding property while the NetConnection instance was connected.
ArgumentError — This property was set to a value other than ObjectEncoding.AMF0 or ObjectEncoding.AMF3.

See also

defaultObjectEncoding
flash.net.ObjectEncoding
proxyType property
proxyType:String [read-write]

Determines whether native SSL is used for RTMPS instead of HTTPS, and whether the CONNECT method of tunneling is used to connect through a proxy server. Acceptable values are "none", "HTTP", "CONNECT", and "best". This property is used in Flex applications and Flash Media Server 2 applications.

In Flash Player 9, this property is applicable only when using RTMP, RTMPS, or RTMPT. The CONNECT method is applicable only to users who are connected to the network by a proxy server.

The proxyType property determines which fallback methods are tried if the initial connection attempt fails. You must set the proxyType property before calling the NetConnection.connect() method. This property determines whether to try to use native Transport Layer Security (TLS), and how to work with proxy servers that your application encounters when attempting to make a connection.

In Flash Player 9, the default value for this property is "none"; if you do not change this value, Flash Player uses HTTPS tunneling for RTMPS. If the property is set to "best", the optimal method of connecting is established, attempting the best method first and then falling back to other methods if they fail. For RTMPS connections, native SSL sockets are used by default, and a fallback to other methods is used if necessary. If the property is set to "HTTP" and a direct connection fails, the old method of HTTP tunneling is used. If the property is set to "CONNECT" and a direct connection fails, the CONNECT method of tunneling is used. If that fails, the connection will not fall back to HTTP tunneling.

Implementation
    public function get proxyType():String
    public function set proxyType(value:String):void
uri property
uri:String [read-only]

The URI of the application server that was passed to NetConnection.connect(), if connect was used to connect to a server. If NetConnection.connect() hasn't yet been called or if no URI was passed, this property is undefined.

Implementation
    public function get uri():String
usingTLS property
usingTLS:Boolean [read-only]

Indicates whether a secure connection was made using native Transport Layer Security (TLS) rather than HTTPS. This property is valid only when a NetConnection object is connected.

Implementation
    public function get usingTLS():Boolean

Throws
ArgumentError — An attempt was made to access this property when the NetConnection instance was not connected.
Constructor detail
NetConnection () constructor
public function NetConnection()

Creates a NetConnection object that you can use with a NetStream object to invoke commands on a remote application server or to play back streaming video (FLV) files locally or from a server. After creating the NetConnection object, use connect() to make the actual connection.

Playing external FLV files provides several advantages over embedding video in a Flash document, such as better performance, better memory management, and independent video and Flash frame rates.

If your ActionScript 3.0 SWF file needs to communicate with servers released prior to Flash Player 9, you might need to adjust the NetConnection object's objectEncoding property.

See also

flash.net.NetConnection.connect()
objectEncoding
Method detail
addHeader () method
public function addHeader(operation:String, mustUnderstand:Boolean = false, param:Object = null):void

Adds a context header to the AMF packet structure. This header is sent with every future AMF packet. If you call NetConnection.addHeader() using the same name, the new header replaces the existing header, and the new header persists for the duration of the NetConnection object. You can remove a header by calling NetConnection.addHeader() with the name of the header to remove an undefined object. This method is relevant when used with a server, such as Flex or Flash Media Server.

Parameters
operation:String — Identifies the header and the ActionScript object data associated with it.
mustUnderstand:Boolean (default = false) — A value of true indicates that the server must understand and process this header before it handles any of the following headers or messages.
param:Object (default = null) — Any ActionScript object.
call () method
public function call(command:String, responder:Responder, ... arguments):void

Invokes a command or method on the server running Flash Media Server, or on an application server, to which the application instance is connected. You must create a server-side function to pass to this method.

Parameters
command:String — A method specified in the form [objectPath/]method. For example, the someObject/doSomething command tells the remote server to invoke the clientObject.someObject.doSomething() method, with all the optional ... arguments parameters. If the object path is missing, clientObject.doSomething() is invoked on the remote server.
responder:Responder — An optional object that is used to handle return values from the server. The Responder object can have two defined methods to handle the returned result: result and status. If an error is returned as the result, status is invoked; otherwise, result is invoked.
... arguments — Optional arguments that can be of any ActionScript type, including a reference to another ActionScript object. These arguments are passed to the method specified in the command parameter when the method is executed on the remote application server.

Events
securityError:SecurityErrorEvent — A call attempted to communicate with a server outside the caller's security sandbox. You can avoid this problem by using a policy file on the server.
close () method
public function close():void

Closes the connection that was opened locally or with the server and dispatches the netStatus event with a code property of NetConnection.Connect.Close.

This method disconnects all NetStream objects running over this connection; any queued data that has not been sent is discarded. (To terminate local or server streams without closing the connection, use NetStream.close().) If you call this method and then want to reconnect, you must recreate the NetStream object.

This method also disconnects all remote shared objects running over this connection. However, you don't need to recreate the shared object to reconnect. Instead, you can just call SharedObject.connect() to reestablish the connection to the shared object. Also, any data in the shared object that was queued when you issued NetConnection.close() will be sent after you reestablish a connection to the shared object.

See also

NetStream
flash.events.NetStatusEvent.info
connect () method
public function connect(command:String, ... arguments):void

Opens a connection to a server. Through this connection, you can play back audio or video (FLV) files from an HTTP address or from the local file system, or you can invoke commands on a remote server.

When using this method, consider the Flash Player security model and the following security considerations:

  • By default, the website denies access between sandboxes. The website can enable access to a resource by using a cross-domain policy file.
  • A website can deny access to a resource by adding server-side ActionScript application logic in Flash Media Server.
  • You cannot use the NetConnection.connect() method if the calling SWF file is in the local-with-file-system sandbox.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
command:String — Set this parameter to null if you are connecting to video without a server (that is, video on the local computer that is running the SWF file).

If you are connecting to a server, set this parameter to the URI of the application on the server that runs when the connection is made. Use the following format (items in brackets are optional):

protocol:[//host][:port]/appname/[instanceName]

If the SWF file is served from the same host where the server is installed, you can omit the host parameter. If you omit the instanceName parameter, Flash Player connects to the application's default instance (_definst_).
... arguments — Optional parameters of any type to be passed to the application specified in command. If the application is unable to process the parameters in the order in which they are received, netStatusEvent is dispatched with the code property set to NetConnection.Connect.Rejected.

Throws
ArgumentError — The URI passed to the command parameter is improperly formatted.
IOError — The connection failed. This might happen if you call connect() from within a netStatus event handler, which is not allowed.
SecurityError — Local untrusted SWF files cannot communicate with the Internet. You can avoid this problem by reclassifying this SWF file as local-with-networking or trusted.

See also

flash.net.NetStream
Event detail
asyncError event
Event object type: flash.events.AsyncErrorEvent
AsyncErrorEvent.type property = flash.events.AsyncErrorEvent.ASYNC_ERROR

Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code.

The AsyncErrorEvent.ASYNC_ERROR constant defines the value of the type property of an asyncError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object experiencing a network operation failure.
error | The error that triggered the event.
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input or output error occurs that causes a network operation to fail.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.
netStatus event
Event object type: flash.events.NetStatusEvent
NetStatusEvent.type property = flash.events.NetStatusEvent.NET_STATUS

Dispatched when a NetConnection object is reporting its status or error condition. The netStatus event contains an info property, which is an information object that contains specific information about the event, such as whether a connection attempt succeeded or failed.

Defines the value of the type property of a netStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
info | An object with properties that describe the object's status or error condition.
target | The NetConnection or NetStream object reporting its status.

See also

flash.events.NetStatusEvent.info
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched if a call to NetConnection.call() attempts to connect to a server outside the caller's security sandbox.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

NetConnection.call()
Flash Player Security
Examples

The following example uses a Video object with the NetConnection and NetStream classes to load and play an FLV file. To run this example, you need an FLV file whose name and location match the variable passed to videoURL; in this case, an FLV file called Video.flv that is in the same directory as the SWF file.

In this example, the code that creates the Video and NetStream objects and calls the Video.attachNetStream() and NetStream.play() methods is placed in a handler function. The handler is called only if the attempt to connect to the NetConnection object is successful; that is, when the netStatus event returns an info object with a code property that indicates success. It is recommended that you wait for a successful connection before you call NetStream.play().

package {
    import flash.display.Sprite;
    import flash.events.NetStatusEvent;
    import flash.events.SecurityErrorEvent;
    import flash.media.Video;
    import flash.net.NetConnection;
    import flash.net.NetStream;
    import flash.events.Event;

    public class NetConnectionExample extends Sprite {
        private var videoURL:String = "Video.flv";
        private var connection:NetConnection;
        private var stream:NetStream;

        public function NetConnectionExample() {
            connection = new NetConnection();
            connection.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            connection.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            connection.connect(null);
        }

        private function netStatusHandler(event:NetStatusEvent):void {
            switch (event.info.code) {
                case "NetConnection.Connect.Success":
                    connectStream();
                    break;
                case "NetStream.Play.StreamNotFound":
                    trace("Stream not found: " + videoURL);
                    break;
            }
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function connectStream():void {
            var stream:NetStream = new NetStream(connection);
            stream.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            stream.client = new CustomClient();
            var video:Video = new Video();
            video.attachNetStream(stream);
            stream.play(videoURL);
            addChild(video);
        }
    }
}

class CustomClient {
    public function onMetaData(info:Object):void {
        trace("metadata: duration=" + info.duration + " width=" + info.width + " height=" + info.height + " framerate=" + info.framerate);
    }
    public function onCuePoint(info:Object):void {
        trace("cuepoint: time=" + info.time + " name=" + info.name + " type=" + info.type);
    }
}


flash.net.NetStream (Flex™ 2 Language Reference)

View comments | RSS feed
Class NetStream | Properties | Methods | Events | Examples
Package | flash.net
Class | public class NetStream
Inheritance | NetStream Inheritance EventDispatcher Inheritance Object

The NetStream class opens a one-way streaming connection between Flash Player and a server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, or between Flash Player and the local file system through a connection made available by a NetConnection object. A NetStream object is like a channel inside a NetConnection object; this channel can either publish audio and/or video data, using NetStream.publish(), or subscribe to a published stream and receive data, using NetStream.play(). You can publish or play live (real-time) data and previously recorded data. You can also use NetStream objects to send text messages to all subscribed clients (see the NetStream.send() method).

Playing external FLV files provides several advantages over embedding video in a Flash document, such as better performance and memory management, and independent video and Flash frame rates. This class provides several methods and properties you can use to track the progress of the file as it loads and plays, and to give the user control over playback (stopping, pausing, and so on).

Some of the properties and methods in the NetStream class are intended for use primarily with a server, such as Flash Media Server or Flex. They may contain additional server-side functionality. For additional documentation, see the NetStream class in Flash Media Server documentation.

For more information on video playback, see "Playing back external FLV files dynamically" in Learning ActionScript 2.0 in Flash.

General workflow for streaming audio or video. The following steps summarize the general sequence of actions required for publishing real-time audio and video:

  1. Create a NetConnection object.
  2. Use the NetConnection.connect() method to connect the application instance to the server.
  3. Create a NetStream object to create a data stream over the connection.
  4. Use the NetStream.attachAudio()method to capture and send audio over the stream, and use the NetStream.attachVideo() method to capture and send video over the stream.
  5. Use the NetStream.publish() method to give this stream a unique name and send data over the stream to the server so that others can receive it. You can also record the data as you publish it, so that users can play it back later.

    SWF files that subscribe to this stream will use the name passed to publish() in their call to play() and will call the same NetConnection.connect() method as the publisher. They will have to call the Video.attachNetStream() method to stream the video and the NetStream.play() method to play it.

View the examples.

See also

flash.media.Video
flash.net.NetConnection
send()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bufferLength : Number [read-only] The number of seconds of data currently in the buffer. | NetStream
 | bufferTime : Number Specifies how long to buffer messages before starting to display the stream. | NetStream
 | bytesLoaded : uint [read-only] The number of bytes of data that have been loaded into the player. | NetStream
 | bytesTotal : uint [read-only] The total size in bytes of the file being loaded into the player. | NetStream
 | checkPolicyFile : Boolean Specifies whether Flash Player should try to download a cross-domain policy file from the loaded FLV file's server before beginning to load the FLV file. | NetStream
 | client : Object Specifies the object on which callback methods are invoked. | NetStream
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentFPS : Number [read-only] The number of frames per second being displayed. | NetStream
 | liveDelay : Number [read-only] The number of seconds of data in the subscribing stream's buffer in live (unbuffered) mode. | NetStream
 | objectEncoding : uint [read-only] The object encoding (AMF version) for this NetStream object. | NetStream
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | soundTransform : SoundTransform Controls sound in this NetStream object. | NetStream
 | time : Number [read-only] The position of the playhead, in seconds. | NetStream
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NetStream(connection:NetConnection)
Creates a stream that can be used for playing FLV files through the specified NetConnection object.
NetStream
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
attachAudio(microphone:Microphone):void
Specifies an audio stream sent over the NetStream object, from a Microphone object passed as the source.
NetStream
attachCamera(theCamera:Camera, snapshotMilliseconds:int = -1):void
Starts capturing video from the specified source, or stops capturing if theCamera is set to null.
NetStream
close():void
Stops playing all data on the stream, sets the time property to 0, and makes the stream available for another use.
NetStream
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
pause():void
Pauses playback of a video stream.
NetStream
play(... arguments):void
Begins playback of external audio or a video (FLV) file.
NetStream
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
publish(name:String = null, type:String = null):void
Sends streaming audio, video, and text messages from a client to a server, such as Flash Media Server 2, optionally recording the stream during transmission.
NetStream
receiveAudio(flag:Boolean):void
Specifies whether incoming audio plays on the stream.
NetStream
receiveVideo(flag:Boolean):void
Specifies whether incoming video will play on the stream.
NetStream
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
resume():void
Resumes playback of a video stream that is paused.
NetStream
seek(offset:Number):void
Seeks the keyframe closest to the specified location (an offset, in seconds, from the beginning of the stream).
NetStream
send(handlerName:String, ... arguments):void
Sends a message on the specified stream to all subscribing clients.
NetStream
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
togglePause():void
Pauses or resumes playback of a stream.
NetStream
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | asyncError | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code. | NetStream
 | ioError | Dispatched when an input or output error occurs that causes a network operation to fail. | NetStream
 | netStatus | Dispatched when a NetStream object is reporting its status or error condition. | NetStream
 | onCuePoint | Invoked when an embedded cue point is reached while playing an FLV file. | NetStream
 | onMetaData | Dispatched when Flash Player receives descriptive information embedded in the FLV file being played. | NetStream
 | onPlayStatus | Dispatched when a NetStream object has completely played a stream. | NetStream
Property detail
bufferLength property
bufferLength:Number [read-only]

The number of seconds of data currently in the buffer. You can use this property with the bufferTime property to estimate how close the buffer is to being full — for example, to display feedback to a user who is waiting for data to be loaded into the buffer.

Implementation
    public function get bufferLength():Number

See also

bufferTime
bytesLoaded
bufferTime property
bufferTime:Number [read-write]

Specifies how long to buffer messages before starting to display the stream. For example, to make sure that the first 15 seconds of the stream play without interruption, set bufferTime to 15; Flash Player begins playing the stream only after 15 seconds of data are buffered.

The default value is 0.1 (one-tenth of a second). To determine the number of seconds currently in the buffer, use the bufferLength property.

Implementation
    public function get bufferTime():Number
    public function set bufferTime(value:Number):void

See also

bufferLength
time
bytesLoaded property
bytesLoaded:uint [read-only]

The number of bytes of data that have been loaded into the player. You can use this property with the bytesTotal property to estimate how close the buffer is to being full — for example, to display feedback to a user who is waiting for data to be loaded into the buffer.

Implementation
    public function get bytesLoaded():uint

See also

bytesTotal
bufferLength
bytesTotal property
bytesTotal:uint [read-only]

The total size in bytes of the file being loaded into the player.

Implementation
    public function get bytesTotal():uint

See also

bytesLoaded
bufferTime
checkPolicyFile property
checkPolicyFile:Boolean [read-write]

Specifies whether Flash Player should try to download a cross-domain policy file from the loaded FLV file's server before beginning to load the FLV file. This property applies when you are using a NetStream object for progressive video download (standalone FLV files), or when you are loading FLV files that are outside the calling SWF file's own domain. This property is ignored when you are using a NetStream object to get an RTMP asset.

Set this property to true when you are loading an FLV file from outside the calling SWF file's domain and you need to use the BitmapData.draw() method for pixel-level access to the video. If you call BitmapData.draw() without setting the checkPolicyFile property to true at loading time, you may get a SecurityError exception because the required policy file was not downloaded.

If you don't need pixel-level access to the video you are loading, avoid setting checkPolicyFile to true. Checking for a policy file consumes network bandwidth and may delay the start of your download.

When you call the NetStream.play() method with checkPolicyFile set to true, Flash Player must either successfully download a relevant cross-domain policy file or determine that no such policy file exists before it begins downloading the object specified in your call to NetStream.play(). To verify the existence of a policy file, Flash Player performs the following actions, in this order:

  1. Flash Player considers policy files that have already been downloaded.
  2. Flash Player tries to download any pending policy files specified in calls to the Security.loadPolicyFile() method.
  3. Flash Player tries to download a policy file from the default location that corresponds to the URL you passed to NetStream.play(), which is /crossdomain.xml on the same server as that URL.

In all cases, Flash Player requires that an appropriate policy file exist on the video's server, that it provide access to the object at the URL you passed to play() based on the policy file's location, and that it allow the domain of the calling SWF to access the video, through one or more <allow-access-from> tags.

If you set checkPolicyFile to true, Flash Player waits until the policy file is verified before downloading the video. Wait to perform any pixel-level operations on the video data, such as calling BitmapData.draw(), until you receive onMetaData or NetStatus events from your NetStream object.

If you set checkPolicyFile to true but no relevant policy file is found, you won't receive an error until you perform an operation that requires a policy file, and then Flash Player throws a SecurityError exception.

Be careful with checkPolicyFile if you are downloading an FLV file from a URL that uses server-side HTTP redirects. Flash Player tries to retrieve policy files that correspond to the initial URL that you specify in NetStream.play(). If the final FLV file comes from a different URL because of HTTP redirects, the initially downloaded policy files might not be applicable to the FLV file's final URL, which is the URL that matters in security decisions.

For more information on policy files, see the "Flash Player Security" chapter of Programming ActionScript 3.0.

Implementation
    public function get checkPolicyFile():Boolean
    public function set checkPolicyFile(value:Boolean):void

See also

flash.display.BitmapData.draw()
flash.system.Security.loadPolicyFile()
netStatus
onMetaData
play()
Loading content dynamically
client property
client:Object [read-write]

Specifies the object on which callback methods are invoked. The default object is this, the NetStream object being created. If you set the client property to another object, callback methods will be invoked on that other object.

Implementation
    public function get client():Object
    public function set client(value:Object):void

Throws
TypeError — The client property must be set to a non-null object.
currentFPS property
currentFPS:Number [read-only]

The number of frames per second being displayed. If you are exporting FLV files to be played back on a number of systems, you can check this value during testing to help you determine how much compression to apply when exporting the file.

Implementation
    public function get currentFPS():Number
liveDelay property
liveDelay:Number [read-only]

The number of seconds of data in the subscribing stream's buffer in live (unbuffered) mode. This property specifies the current network transmission delay (lag time).

This property is intended primarily for use with a server, such as Flash Media Server; for more information, see the class description.

You can get the value of this property to roughly gauge the transmission quality of the stream and communicate it to the user.

Implementation
    public function get liveDelay():Number
objectEncoding property
objectEncoding:uint [read-only]

The object encoding (AMF version) for this NetStream object. The NetStream object inherits its objectEncoding value from the associated NetConnection object. It's important to understand this property if your ActionScript 3.0 SWF file needs to communicate with servers released prior to Flash Player 9. For more information, see the objectEncoding property description in the NetConnection class.

The value of this property depends on whether the stream is local or remote. Local streams, where null was passed to the NetConnection.connect() method, return the value of NetConnection.defaultObjectEncoding. Remote streams, where you are connecting to a server, return the object encoding of the connection to the server.

If you try to read this property when not connected, or if you try to change this property, Flash Player throws an exception.

Implementation
    public function get objectEncoding():uint

See also

NetConnection.objectEncoding
ObjectEncoding
soundTransform property
soundTransform:SoundTransform [read-write]

Controls sound in this NetStream object. For more information, see the SoundTransform class.

Implementation
    public function get soundTransform():SoundTransform
    public function set soundTransform(value:SoundTransform):void

See also

flash.media.SoundTransform
time property
time:Number [read-only]

The position of the playhead, in seconds.

Implementation
    public function get time():Number

See also

bufferLength
bytesLoaded
Constructor detail
NetStream () constructor
public function NetStream(connection:NetConnection)

Creates a stream that can be used for playing FLV files through the specified NetConnection object.

Parameters
connection:NetConnection — A NetConnection object.

Throws
ArgumentError — The NetConnection instance is not connected.

See also

flash.net.NetConnection
flash.media.Video.attachCamera()
Method detail
attachAudio () method
public function attachAudio(microphone:Microphone):void

Specifies an audio stream sent over the NetStream object, from a Microphone object passed as the source. This method is available only to the publisher of the specified stream.

This method is intended primarily for use with a server, such as Flash Media Server; for more information, see the class description.

You can call this method before or after you call the publish() method and actually begin transmitting. Subscribers who want to hear the audio must call the NetStream.play() method. You can control the sound properties of this audio stream through the soundTransform property of the specified Microphone object.

Parameters
microphone:Microphone — The source of the audio stream to be transmitted.

See also

play()
flash.media.Microphone
attachCamera () method
public function attachCamera(theCamera:Camera, snapshotMilliseconds:int = -1):void

Starts capturing video from the specified source, or stops capturing if theCamera is set to null. This method is available only to the publisher of the specified stream.

This method is intended primarily for use with a server, such as Flash Media Server; for more information, see the class description.

After attaching the video source, you must call NetStream.publish() to begin transmitting. Subscribers who want to display the video must call the NetStream.play() and Video.attachCamera() methods to display the video on the Stage.

You can use snapshotMilliseconds to send a single snapshot (by providing a value of 0) or a series of snapshots — in effect, time-lapse footage — by providing a positive number that adds a trailer of the specified number of milliseconds to the video feed. The trailer extends the display time of time the video message is displayed. By repeatedly calling attachCamera() with a positive value for snapshotMilliseconds, the sequence of alternating snapshots and trailers create time-lapse footage. For example, you could capture one frame per day and append it to a video file. When a subscriber plays the file, each frame remains onscreen for the specified number of milliseconds and then the next frame is displayed.

The purpose of the snapshotMilliseconds parameter is different from the fps parameter you can set with Camera.setMode(). When you specify snapshotMilliseconds, you control how much time elapses between recorded frames. When you specify fps using Camera.setMode(), you are controlling how much time elapses during recording and playback.

For example, suppose you want to take a snapshot every 5 minutes for a total of 100 snapshots. You can do this in two ways:

  • You can issue a NetStream.attachCamera(myCamera, 500) command 100 times, once every 5 minutes. This takes 500 minutes to record, but the resulting file will play back in 50 seconds (100 frames with 500 milliseconds between frames).
  • You can issue a Camera.setMode() command with an fps value of 1/300 (one per 300 seconds, or one every 5 minutes), and then issue a NetStream.attachCamera(source) command, letting the camera capture continuously for 500 minutes. The resulting file will play back in 500 minutes — the same length of time that it took to record — with each frame being displayed for 5 minutes.

Both techniques capture the same 500 frames, and both approaches are useful; the approach to use depends primarily on your playback requirements. For example, in the second case, you could be recording audio the entire time. Also, both files would be approximately the same size.

Parameters
theCamera:Camera — The source of the video transmission. Valid values are a Camera object (which starts capturing video) and null. If you pass null, Flash Player stops capturing video, and any additional parameters you send are ignored.
snapshotMilliseconds:int (default = -1) — Specifies whether the video stream is continuous, a single frame, or a series of single frames used to create time-lapse photography.
  • If you omit this parameter, Flash Player captures all video until you pass a value of null to attachCamera.
  • If you pass 0, Flash Player captures only a single video frame. Use this value to transmit "snapshots" within a preexisting stream. Flash interprets invalid, negative, or nonnumeric arguments as 0.
  • If you pass a positive number, Flash captures a single video frame and then appends a pause of the specified length as a trailer on the snapshot. Use this value to create time-lapse photography effects.
close () method
public function close():void

Stops playing all data on the stream, sets the time property to 0, and makes the stream available for another use. This command also deletes the local copy of an FLV file that was downloaded through HTTP. Although Flash Player deletes the local copy of the FLV file that it creates, a copy of the video might persist in the browser's cache directory. If you must completely prevent caching or local storage of the FLV file, use Flash Media Server 2.

See also

pause()
play()
pause () method
public function pause():void

Pauses playback of a video stream. Calling this method does nothing if the video is already paused.

See also

close()
play()
resume()
togglePause()
play () method
public function play(... arguments):void

Begins playback of external audio or a video (FLV) file. To view video data, you must create a Video object and call the Video.attachNetStream() method; audio being streamed with the video, or an FLV file that contains only audio, is played automatically. To stream audio from a microphone, use the NetStream.attachAudio() method and control some aspects of the audio through the Microphone object.

To control the audio associated with an FLV file, you can use the DisplayObjectContainer.addChild() method to route the audio to an object on the display list; you can then create a Sound object to control some aspects of the audio. For more information, see the DisplayObjectContainer.addChild() method.

If the FLV file can't be found, the netStatus event is dispatched. To stop a stream that is currently playing, use the close() method.

When you use this method, consider the Flash Player security model.

  • Calling NetStream.play() is not allowed if the calling SWF file is in the local-with-file-system sandbox and the resource is in a remote sandbox.
  • Network sandbox access from the local-trusted or local-with-networking sandbox requires permission from the website through a cross-domain policy file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
... arguments — The location of the FLV file to play, as a URLRequest object or a string. You can play local FLV files that are stored in the same directory as the SWF file or in a subdirectory; however, you can't navigate to a higher-level directory.

Throws
SecurityError — Local untrusted SWF files cannot communicate with the Internet. You can work around this restriction by reclassifying this SWF file as local-with-networking or trusted.
ArgumentError — At least one parameter must be specified.

See also

DisplayObjectContainer.addChild()
publish () method
public function publish(name:String = null, type:String = null):void

Sends streaming audio, video, and text messages from a client to a server, such as Flash Media Server 2, optionally recording the stream during transmission. This method is available only to the publisher of the specified stream.

This method is intended primarily for use with a server, such as Flash Media Server 2; for more information, see the class description.

Don't use this method to let a client play a stream that has already been published and recorded. Instead, create a NetStream instance for that client and call the play() method:

  var subscribeNS:NetStream = new NetStream(myNetConnection);
  subscribeNS.play("streamToPlay");

With Flash Media Server 2, when you record a stream, Flash creates an FLV file and stores it in a subdirectory of the applications directory on the server. Each stream is stored in a directory whose name matches the application instance name value passed to the command parameter of the NetConnection.connect() method. Flash Player creates these directories automatically; you don't have to create one for each instance name. For example, the following code shows how you would connect to a specific instance of an application that is stored in a directory named lectureSeries in your applications directory. A file named lecture.flv is stored in a subdirectory named /yourAppsFolder/lectureSeries/streams/Monday:

  var myNC:NetConnection = new NetConnection();
  myNC.connect("rtmp://server.domain.com/lectureSeries/Monday");
  var myNS:NetStream = new NetStream(myNC);
  myNS.publish("lecture", "record");

The following example shows how to connect to a different instance of the same application but issue an identical publish command. A file named lecture.flv is stored in a subdirectory named /yourAppsFolder/lectureSeries/streams/Tuesday.

  var myNC:NetConnection = new NetConnection();
  myNC.connect("rtmp://server.domain.com/lectureSeries/Tuesday");
  var myNS:NetStream = new NetStream(my_nc);
  myNS.publish("lecture", "record");

If you don't pass a value for the instance name, that matches the value passed to the name property is stored in a subdirectory named /yourAppsFolder/appName/streams/_definst_ (for "default instance"). For more information on using instance names, see the NetConnection.connect() method. For information on playing back FLV files, see the NetStream.play() method.

This method can dispatch a netStatus event with several different information objects. For example, if someone is already publishing on a stream with the specified name, the netStatus event is dispatched with a code property of NetStream.Publish.BadName. For more information, see the netStatus event.

Parameters
name:String (default = null) — A string that identifies the stream. If you pass false, the publish operation stops. Clients that subscribe to this stream must pass this same name when they call NetStream.play(). You don't need to include a file extension for the stream name.
type:String (default = null) — A string that specifies how to publish the stream. Valid values are "record", "append", and "live". The default value is "live".
  • If you pass "record", Flash Player publishes and records live data, saving the recorded data to a new FLV file with a name matching the value passed to the name parameter. The file is stored on the server in a subdirectory within the directory that contains the server application. If the file already exists, it is overwritten.
  • If you pass "append", Flash Player publishes and records live data, appending the recorded data to an FLV file with a name that matches the value passed to the name parameter, stored on the server in a subdirectory within the directory that contains the server application. If no file with a matching name the name parameter is found, it is created.
  • If you omit this parameter or pass "live", Flash Player publishes live data without recording it. If a file with a name that matches the value passed to the name parameter exists, it is deleted.

See also

NetConnection.connect()
play()
netStatus
receiveAudio () method
public function receiveAudio(flag:Boolean):void

Specifies whether incoming audio plays on the stream. This method is available only to clients subscribed to the specified stream, not to the stream's publisher.

This method is intended primarily for use with a server, such as Flash Media Server; for more information, see the class description.

You can call this method before or after you call the NetStream.play() method and actually begin receiving the stream. For example, you can attach these methods to a button the user clicks to mute and unmute the incoming audio stream.

If the specified stream contains only audio data, passing a value of false to this method stops NetStream.time from further incrementing.

Parameters
flag:Boolean — Specifies whether incoming audio plays on the specified stream (true) or not (false). The default value is true.
receiveVideo () method
public function receiveVideo(flag:Boolean):void

Specifies whether incoming video will play on the stream. This method is available only to clients subscribed to the specified stream, not to the stream's publisher.

This method is intended primarily for use with a server, such as Flash Media Server 2; for more information, see the class description.

You can call this method before or after you call the NetStream.play() method and actually begin receiving the stream. For example, you can attach these methods to a button the user presses to show or hide the incoming video stream.

If the specified stream contains only video data, passing a value of false to this method stops NetStream.time from further incrementing.

Parameters
flag:Boolean — Specifies whether incoming video plays on the specified stream (true) or not (false). The default value is true.
resume () method
public function resume():void

Resumes playback of a video stream that is paused. If the video is already playing, calling this method does nothing.

See also

close()
pause()
play()
togglePause()
seek () method
public function seek(offset:Number):void

Seeks the keyframe closest to the specified location (an offset, in seconds, from the beginning of the stream). The stream resumes playing when that location is reached.

Parameters
offset:Number — The approximate time value, in seconds, to move to in an FLV file. The playhead moves to the video keyframe that's closest to offset.
  • To return to the beginning of the stream, pass 0 for offset.
  • To seek forward from the beginning of the stream, pass the number of seconds to advance. For example, to position the playhead at 15 seconds from the beginning, use myStream.seek(15).
  • To seek relative to the current position, pass NetStream.time + n or NetStream.time - n to seek n seconds forward or backward, respectively, from the current position. For example, to rewind 20 seconds from the current position, use NetStream.seek(NetStream.time - 20).

The precise location to which a video seeks depends on the frames per second (fps) setting at which it was exported. Therefore, if you export the same video at 6 fps and 30 fps, and you use myStream.seek(15) for both video objects, the videos seek to two different locations.

See also

play()
time
send () method
public function send(handlerName:String, ... arguments):void

Sends a message on the specified stream to all subscribing clients. This method is available only to the publisher of the specified stream.

This method is intended primarily for use with a server, such as Flash Media Server 2; for more information, see the class description.

To process and respond to the message, create a handler in the format myStream.HandlerName.

Flash Player does not serialize methods or their data, object prototype variables, or non-enumerable variables. For display objects, Flash Player serializes the path but none of the data.

Parameters
handlerName:String — The message to be sent; also the name of the ActionScript handler to receive the message. The handler name can be only one level deep (that is, it can't be of the form parent/child) and is relative to the stream object. Do not use a reserved term for a handler name. For example, using "close" as a handler name will cause the method to fail.
... arguments — Optional arguments that can be of any type. They are serialized and sent over the connection, and the receiving handler receives them in the same order. If a parameter is a circular object (for example, a linked list that is circular), the serializer handles the references correctly.

See also

play()
client

Example
The following example sets up two NetStream objects in the same file. One NetStream object, ns1. is used to call the send() method, and the other, ns2, registers a client object that registers a handler function for the send() call:
  import flash.net.NetConnection;
  import flash.net.NetStream;
  import flash.events.NetStatusEvent;
  import flash.media.Video;
  import flash.utils.setTimeout;

  var nc:NetConnection = new NetConnection();
  nc.objectEncoding = 0;
  nc.addEventListener("netStatus", onNCStatus);
  nc.connect("rtmp://www.example.com/MyApp/MyInstance");
  var ns1:NetStream;
  var vid:Video = new Video(300,300);
  addChild(vid);
  var obj:Object = new Object();
  obj.myFunction = function(event:String):void {
   trace(event);
  }

  function onNCStatus(event:NetStatusEvent):void {
   if(event.info.code == "NetConnection.Connect.Success") {
    ns1 = new NetStream(nc);
    ns1.play("MyVideo");
    vid.attachNetStream(ns1);
    ns1.client = obj;
    ns1.publish("dummy", "live");

    var ns2:NetStream = new NetStream(nc);
    ns2.play("dummy");
    ns2.client = obj;

    setTimeout(sendHello, 3000);
   }
  }

  function sendHello():void {
    ns1.send("myFunction", "hello");
  }

togglePause () method
public function togglePause():void

Pauses or resumes playback of a stream. The first time you call this method, it pauses play; the next time, it resumes play. You could use this method to let users pause or resume playback by pressing a single button.

See also

close()
play()
pause()
resume()
Event detail
asyncError event
Event object type: flash.events.AsyncErrorEvent
AsyncErrorEvent.type property = flash.events.AsyncErrorEvent.ASYNC_ERROR

Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code. This event is dispatched when a server calls a method on the client that is not defined.

The AsyncErrorEvent.ASYNC_ERROR constant defines the value of the type property of an asyncError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object experiencing a network operation failure.
error | The error that triggered the event.

See also

NetStream.onPlayStatus
NetStream.onMetaData
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input or output error occurs that causes a network operation to fail.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.
netStatus event
Event object type: flash.events.NetStatusEvent
NetStatusEvent.type property = flash.events.NetStatusEvent.NET_STATUS

Dispatched when a NetStream object is reporting its status or error condition. The netStatus event contains an info property, which is an information object that contains specific information about the event, such as if a connection attempt succeeded or failed.

Defines the value of the type property of a netStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
info | An object with properties that describe the object's status or error condition.
target | The NetConnection or NetStream object reporting its status.

See also

flash.events.NetStatusEvent.info
onCuePoint event

Invoked when an embedded cue point is reached while playing an FLV file. You can use this handler to trigger actions in your code when the video reaches a specific cue point, which lets you synchronize other actions in your application with video playback events.

This event is intended primarily for use with a server, such as Flash Media Server 2; for more information, see the class description. It is not part of the Flash Player API, but is included in this language reference for your convenience. You cannot use the addEventListener() method, or any other EventDispatcher methods, to listen for or process this event. Rather, you must define a single callback function and attach it directly to one of the following objects:

  • The object referenced by the client property of a NetStream instance.
  • An instance of a NetStream subclass. NetStream is a sealed class, which means that properties or methods cannot be added to a NetStream object at runtime. However, you can create a subclass of NetStream and define your event handler in the subclass or make the subclass dynamic and add the event handler function to an instance of the subclass.

The following types of cue points can be embedded in an FLV file:

  • A navigation cue point specifies a keyframe within the FLV file and the cue point's time property corresponds to that exact keyframe. Navigation cue points are often used as bookmarks or entry points to let users navigate through the video file.
  • An event cue point is specified by time, whether or not that time corresponds to a specific keyframe. An event cue point usually represents a time in the video when something happens that could be used to trigger other application events.

The onCuePoint event object has the following properties:

Property | Description
name | The name given to the cue point when it was embedded in the FLV file.
parameters | A associative array of name/value pair strings specified for this cue point. Any valid string can be used for the parameter name or value.
time | The time in seconds at which the cue point occurred in the video file during playback.
type | The type of cue point that was reached, either navigation or event.

You can define cue points in an FLV file when you first encode the file, or when you import a video clip in the Flash authoring tool by using the Video Import wizard.

The onMetaData event also retrieves information about the cue points in a video file. However the onMetaData event gets information about all of the cue points before the video begins playing. The onCuePoint event receives information about a single cue point at the time specified for that cue point during playback.

Generally, to have your code respond to a specific cue point at the time it occurs, use the onCuePoint event to trigger some action in your code.

You can use the list of cue points provided to the onMetaData event to let the user start playing the video at predefined points along the video stream. Pass the value of the cue point's time property to the NetStream.seek() method to play the video from that cue point.

See also

client
onMetaData
onMetaData event

Dispatched when Flash Player receives descriptive information embedded in the FLV file being played.

This special event is primarily intended for use with a server, such as Flash Media Server; for more information, see the class description. It is not technically part of the Flash Player API, but is included in this language reference for your convenience. You cannot use the addEventListener() method, or any other EventDispatcher methods, to listen for or process this event. Rather, you must define a single callback function and attach it directly to one of the following objects:

  • The object that the client property of a NetStream instance references.
  • An instance of a NetStream subclass. NetStream is a sealed class, which means that properties or methods cannot be added to a NetStream object at runtime. However, you can create a subclass of NetStream and define your event handler in the subclass or make the subclass dynamic and add the event handler function to an instance of the subclass.

The Flash Video Exporter utility (version 1.1 or later) embeds a video's duration, creation date, data rates, and other information into the video file itself. Different video encoders embed different sets of meta data.

This event is triggered after a call to the NetStream.play() method, but before the video playhead has advanced.

In many cases, the duration value embedded in FLV metadata approximates the actual duration but is not exact. In other words, it does not always match the value of the NetStream.time property when the playhead is at the end of the video stream.

See also

NetConnection
client
asyncError
onCuePoint
play()
time
onPlayStatus event

Dispatched when a NetStream object has completely played a stream. This handler returns information objects that provide information in addition to what's returned by the netStatus event. You can use this handler to trigger actions in your code when a NetStream object has switched from one stream to another stream in a playlist (as indicated by the information object NetStream.Play.Switch) or when a NetStream object has played to the end (as indicated by the information object NetStream.Play.Complete). To respond to this event, you must create a function to process the information object sent by the server.

This event is intended primarily for use with a server, such as Flash Media Server; for more information, see the class description. It is not part of the Flash Player API, but is included in this language reference for your convenience. You cannot use the addEventListener() method, or any other EventDispatcher methods, to listen for or process this event. Rather, you must define a single callback function and attach it directly to one of the following objects:

  • The object that the client property of a NetStream instance references.
  • An instance of a NetStream subclass. NetStream is a sealed class, which means that properties or methods cannot be added to a NetStream object at runtime. However, you can create a subclass of NetStream and define your event handler in the subclass or make the subclass dynamic and add the event handler function to an instance of the subclass.

This event can return an information object with the following properties:

Code property | Level property | Meaning
NetStream.Play.Switch | "status" | The subscriber is switching from one stream to another in a playlist.
NetStream.Play.Complete | "status" | Playback has completed.

See also

client
flash.events.NetStatusEvent.NET_STATUS
asyncError
onMetaData
onCuePoint
Examples

The following example uses a Video object with the NetConnection and NetStream classes to load and play an FLV file. To run this example, you need an FLV file whose name and location match the variable passed to videoURL; in this case, an FLV file called Video.flv that is in the same directory as the SWF file.

In this example, the code that creates the Video and NetStream objects and calls the Video.attachNetStream() and NetStream.play() methods is placed in a handler function. The handler is called only if the attempt to connect to the NetConnection object is successful; that is, when the netStatus event returns an info object with a code property that indicates success. It is recommended that you wait for a successful connection before you call NetStream.play().

package {
    import flash.display.Sprite;
    import flash.events.NetStatusEvent;
    import flash.events.SecurityErrorEvent;
    import flash.media.Video;
    import flash.net.NetConnection;
    import flash.net.NetStream;
    import flash.events.Event;

    public class NetConnectionExample extends Sprite {
        private var videoURL:String = "Video.flv";
        private var connection:NetConnection;
        private var stream:NetStream;

        public function NetConnectionExample() {
            connection = new NetConnection();
            connection.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            connection.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            connection.connect(null);
        }

        private function netStatusHandler(event:NetStatusEvent):void {
            switch (event.info.code) {
                case "NetConnection.Connect.Success":
                    connectStream();
                    break;
                case "NetStream.Play.StreamNotFound":
                    trace("Stream not found: " + videoURL);
                    break;
            }
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function connectStream():void {
            var stream:NetStream = new NetStream(connection);
            stream.addEventListener(NetStatusEvent.NET_STATUS, netStatusHandler);
            stream.client = new CustomClient();
            var video:Video = new Video();
            video.attachNetStream(stream);
            stream.play(videoURL);
            addChild(video);
        }
    }
}

class CustomClient {
    public function onMetaData(info:Object):void {
        trace("metadata: duration=" + info.duration + " width=" + info.width + " height=" + info.height + " framerate=" + info.framerate);
    }
    public function onCuePoint(info:Object):void {
        trace("cuepoint: time=" + info.time + " name=" + info.name + " type=" + info.type);
    }
}

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

djtechwriter said on Jun 28, 2006 at 5:51 PM :
The Netstream.play() description needs the following clarification about playing a remote FLV file:

A SWF file in the local-trusted or local-with-networking sandbox can load and play an FLV file from the remote sandbox, but cannot access that remote FLV file's data without explicit permission in the form of a cross-domain policy file. The NetStream.checkPolicyFile property description has more information on this issue.

- Dave Jacowitz, Flash Team

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/flash/net/NetStream.html


flash.net.ObjectEncoding (Flex™ 2 Language Reference)

Class ObjectEncoding | Properties | Methods | Constants
Package | flash.net
Class | public final class ObjectEncoding
Inheritance | ObjectEncoding Inheritance Object

The ObjectEncoding class allows classes that serialize objects (such as NetStream, NetConnection, SharedObject, and ByteArray) to work with prior versions of ActionScript.

Object encoding controls how objects are represented in Action Message Format (AMF). Flash Player uses AMF to enable efficient communication between a Flash application and a remote server. AMF encodes remote procedure calls into a compact binary representation that can be transferred over HTTP/HTTPS or the RTMP/RTMPS protocol used by Flash Media Server. ActionScript objects and data values are serialized into this binary format, which is generally more compact than other representations, such as XML.

Flash Player 9 can serialize in two different formats, AMF3 and AMF0. AMF3, the default serialization used for ActionScript 3.0, provides various advantages over AMF0, which is used for ActionScript 1.0 and 2.0. AMF3 sends data over the network more efficiently than AMF0. AMF3 supports sending int and uint objects as integers and supports data types that are available only in ActionScript 3.0, such as ByteArray, XML, and IExternalizable. It is available only in ActionScript 3.0 and with servers that use AMF3 encoding, such as Flex 2.

The ByteArray, NetConnection, NetStream, SharedObject, Socket, and URLStream classes contain an objectEncoding property that is assigned a constant from the ObjectEncoding class. The behavior of the objectEncoding property differs depending on the object; each class's objectEncoding property description explains the behavior more thoroughly.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dynamicPropertyWriter : IDynamicPropertyWriter [static] Allows greater control over the serialization of dynamic properties of dynamic objects. | ObjectEncoding
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | AMF0 : uint = 0 [static] Specifies that objects are serialized using the Action Message Format for ActionScript 1.0 and 2.0. | ObjectEncoding
 | AMF3 : uint = 3 [static] Specifies that objects are serialized using the Action Message Format for ActionScript 3.0. | ObjectEncoding
 | DEFAULT : uint = 3 [static] Specifies the default (latest) format for the current player. | ObjectEncoding
Property detail
dynamicPropertyWriter property
dynamicPropertyWriter:IDynamicPropertyWriter [read-write]

Allows greater control over the serialization of dynamic properties of dynamic objects. When this property is set to null, the default value, dynamic properties are serialized using native code, which writes all dynamic properties excluding those whose value is a function.

You can use this property to exclude properties of dynamic objects from serialization; to write values to properties of dynamic objects; or to create new properties for dynamic objects. To do so, set this property to an object that implements the IDynamicPropertyWriter interface. For more information, see the IDynamicPropertyWriter interface.

Implementation
    public static function get dynamicPropertyWriter():IDynamicPropertyWriter
    public function set dynamicPropertyWriter(value:IDynamicPropertyWriter):void

See also

IDynamicPropertyWriter
Constant detail
AMF0 constant
public static const AMF0:uint = 0

Specifies that objects are serialized using the Action Message Format for ActionScript 1.0 and 2.0.

AMF3 constant
public static const AMF3:uint = 3

Specifies that objects are serialized using the Action Message Format for ActionScript 3.0.

DEFAULT constant
public static const DEFAULT:uint = 3

Specifies the default (latest) format for the current player. Because object encoding control is only available in Flash® Player 9 and later, the earliest format used will be the Action Message Format for ActionScript 3.0.

For example, if an object has the objectEncoding property set to flash.net.ObjectEncoding.DEFAULT, Flash Player uses AMF3 encoding. If, in the future, a later version of Flash Player introduces a new AMF version and you republish your content, the player will use that new AMF version. You can use this constant only if you're not concerned at all about interoperability with previous versions of Flash Player.


flash.net.Responder (Flex™ 2 Language Reference)

Class Responder | Properties | Methods
Package | flash.net
Class | public class Responder
Inheritance | Responder Inheritance Object
Subclasses | MessageResponder

The Responder class provides an object that is used in NetConnection.call() to handle return values from the server.

See also

NetConnection.call()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Responder(result:Function, status:Function = null) Creates a new Responder object. | Responder
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
Responder () constructor
public function Responder(result:Function, status:Function = null)

Creates a new Responder object. You pass a Responder object to NetConnection.call() to handle return values from the server. You may pass null for either or both parameters.

Parameters
result:Function — The function invoked if the call to the server succeeds and returns a result.
status:Function (default = null) — The function invoked if the server returns an error.


flash.net.SharedObject (Flex™ 2 Language Reference)

Class SharedObject | Properties | Methods | Events | Examples
Package | flash.net
Class | public class SharedObject
Inheritance | SharedObject Inheritance EventDispatcher Inheritance Object

The SharedObject class is used to read and store limited amounts of data on a user's computer or on a server. Shared objects offer real-time data sharing between multiple client SWF files and objects that are persistent on the local computer or remote server. Local shared objects are similar to browser cookies and remote shared objects are similar to real-time data transfer devices. To use remote shared objects, you need a server, such as Adobe Flex or Adobe's Macromedia Flash Media Server 2.

Some of the properties and methods in the NetStream class are intended for use primarily with a server, such as Flash Media Server 2 or Flex. They may contain additional server-side functionality. For additional documentation, see the NetStream class in Flash Media Server documentation.

Three common uses of shared objects are described below:

  • Maintaining local persistence. This is the simplest way to use a shared object, and does not require a server. For example, you can call SharedObject.getLocal() to create a shared object in a Flash Player application, such as a calculator with memory. When the user closes the calculator, Flash Player saves the last value in a shared object on the user's computer. The next time the calculator is run, it contains the values it had previously. Alternatively, if you set the shared object's properties to null before the calculator application is closed, the next time the application runs, it opens without any prior values.

    • Another example of maintaining local persistence is tracking user preferences or other data for a complex website, such as a record of which articles a user read on a news site. Tracking this information would allow you to display articles that have already been read differently from new, unread articles. Storing this information on the user's computer reduces server load.

  • Storing and sharing data on a server. One example is a phone book application that can work either online or offline. When an Internet connection is available, the application retrieves up-to-date information from a remote shared object on a server. When no connection is available, the application uses the latest data saved in local shared objects.
  • Sharing data in real time. A shared object can share data among multiple clients in real time. For example, you can open a remote shared object that stores real-time data, such as a list of users connected to a chat room, that is visible to all clients connected to the object. When a user enters or leaves the chat room, the object is updated and all clients that are connected to the object see the revised list of chat room users.

To create a local shared object, use the following syntax:

 var so:SharedObject = SharedObject.getLocal("userHighScore");
 so.data.highScore = new Number(1234567890);
 so.flush();

In the example, the shared object is explicitly flushed, or written to a disk. When an application closes, shared objects are automatically flushed; however, flushing is shown here to demonstrate the step of writing data to a disk.

Local disk space considerations: Local shared objects can be very useful, but they have some limitations that are important to consider as you design your application. Sometimes your SWF files may not be allowed to write local shared objects, and sometimes the data stored in local shared objects can be deleted without your knowledge. Flash Player users can manage the disk space that is available to individual domains or to all domains. When users decrease the amount of disk space available, some local shared objects may be deleted. Flash Player users also have privacy controls that can prevent third-party domains (domains other than the domain in the current browser address bar) from reading or writing local shared objects.

Note: SWF files that are stored and run on the local computer, not from a remote server, can always write third-party shared objects to disk, even if the user does not allow writing of shared objects to disk by third-party domains. For more information about third-party shared objects, see the discussion about third-party content on the Global Storage Settings panel in Flash Player Help.

Adobe recommends that you check for failures that are related to the amount of disk space and to user privacy controls. Perform these checks when you call getLocal() and flush():

  • SharedObject.getLocal() — Flash Player throws an exception when a call to this method fails, such as when the user has disabled third-party shared objects and the domain of your SWF file does not match the domain in the browser address bar.
  • SharedObject.flush() — Flash Player throws an exception when a call to this method fails. It returns SharedObjectFlushStatus.FLUSHED when it succeeds. It returns SharedObjectFlushStatus.PENDING when additional storage space is needed. Flash Player prompts the user to allow an increase in storage space for locally saved information. Thereafter, the netStatus event is dispatched with an information object indicating whether the flush failed or succeeded.

If your SWF file attempts to create or modify local shared objects, make sure that your SWF file is at least 215 pixels wide and at least 138 pixels high (the minimum dimensions for displaying the dialog box that prompts users to increase their local shared object storage limit). If your SWF file is smaller than these dimensions and an increase in the storage limit is required, SharedObject.flush() fails, returning SharedObjectFlushedStatus.PENDING and dispatching the netStatus event.

View the examples.

See also

flush()
getLocal()
netStatus

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | client : Object Indicates the object on which callback methods are invoked. | SharedObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object [read-only] The collection of attributes assigned to the data property of the object; these attributes can be shared and stored. | SharedObject
 | defaultObjectEncoding : uint [static] The default object encoding (AMF version) for all local shared objects created in the SWF file. | SharedObject
 | fps : Number [write-only] Specifies the number of times per second that a client's changes to a shared object are sent to the server. | SharedObject
 | objectEncoding : uint The object encoding (AMF version) for this shared object. | SharedObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | size : uint [read-only] The current size of the shared object, in bytes. | SharedObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
clear():void
For local shared objects, purges all of the data and deletes the shared object from the disk.
SharedObject
close():void
Closes the connection between a remote shared object and the server.
SharedObject
connect(myConnection:NetConnection, params:String = null):void
Connects to a remote shared object on the server through the specified connection.
SharedObject
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
flush(minDiskSpace:int = 0):String
Immediately writes a locally persistent shared object to a local file.
SharedObject
getLocal(name:String, localPath:String = null, secure:Boolean = false):SharedObject
[static] Returns a reference to a locally persistent shared object that is available only to the current client.
SharedObject
getRemote(name:String, remotePath:String = null, persistence:Object = false, secure:Boolean = false):SharedObject
[static] Returns a reference to an object that can be shared across multiple clients by means of a server, such as Flash Media Server.
SharedObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(... arguments):void
Broadcasts a message to all clients connected to the specified remote shared object, including the client that sent the message.
SharedObject
setDirty(propertyName:String):void
Indicates to the server that the value of a property (defined with the data property) in the shared object has changed.
SharedObject
setProperty(propertyName:String, value:Object = null):void
Updates the value of a property (defined with the data property) in a shared object and indicates to the server that the value of the property has changed.
SharedObject
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | asyncError | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code. | SharedObject
 | netStatus | Dispatched when a SharedObject instance is reporting its status or error condition. | SharedObject
 | sync | Dispatched when a remote shared object (SharedObject) has been updated by the server. | SharedObject
Property detail
client property
client:Object [read-write]

Indicates the object on which callback methods are invoked. The default object is this. You can set the client property to another object, and callback methods will be invoked on that other object.

Implementation
    public function get client():Object
    public function set client(value:Object):void

Throws
TypeError — The client property must be set to a non-null object.
data property
data:Object [read-only]

The collection of attributes assigned to the data property of the object; these attributes can be shared and stored. Each attribute can be an object of any ActionScript or JavaScript type — Array, Number, Boolean, ByteArray, XML, and so on. For example, the following lines assign values to various aspects of a shared object:

  var items_array:Array = new Array(101, 346, 483);
  var currentUserIsAdmin:Boolean = true;
  var currentUserName:String = "Ramona";

  var my_so:SharedObject = SharedObject.getLocal("superfoo");
  my_so.data.itemNumbers = items_array;
  my_so.data.adminPrivileges = currentUserIsAdmin;
  my_so.data.userName = currentUserName;

  for (var prop in my_so.data) {
    trace(prop+": "+my_so.data[prop]);
  }

All attributes of a shared object's data property are saved if the object is persistent, and the shared object contains the following information:

  userName: Ramona
  adminPrivileges: true
  itemNumbers: 101,346,483

Note: Do not assign values directly to the data property of a shared object, as in so.data = someValue; Flash Player ignores these assignments.

To delete attributes for local shared objects, use code such as delete so.data.attributeName; setting an attribute to null or undefined for a local shared object does not delete the attribute.

To create private values for a shared object — values that are available only to the client instance while the object is in use and are not stored with the object when it is closed — create properties that are not named data to store them, as shown in the following example:

  var my_so:SharedObject = SharedObject.getLocal("superfoo");
  my_so.favoriteColor = "blue";
  my_so.favoriteNightClub = "The Bluenote Tavern";
  my_so.favoriteSong = "My World is Blue";

  for (var prop in my_so) {
    trace(prop+": "+my_so[prop]);
  }

The shared object contains the following data:

  favoriteSong: My World is Blue
  favoriteNightClub: The Bluenote Tavern
  favoriteColor: blue
  data: [object Object]
Implementation
    public function get data():Object

See also

getLocal()
defaultObjectEncoding property
defaultObjectEncoding:uint [read-write]

The default object encoding (AMF version) for all local shared objects created in the SWF file. When local shared objects are written to disk, the SharedObject.defaultObjectEncoding property indicates which Action Message Format version should be used: the ActionScript 3.0 format (AMF3) or the ActionScript 1.0 or 2.0 format (AMF0).

For more information about object encoding, including the difference between encoding in local and remote shared objects, see the description of the objectEncoding property.

The default value of SharedObject.defaultObjectEncoding is set to use the ActionScript 3.0 format, AMF3. If you need to write local shared objects that ActionScript 2.0 or 1.0 SWF files can read, set SharedObject.defaultObjectEncoding to use the ActionScript 1.0 or ActionScript 2.0 format, flash.net.ObjectEncoding.AMF0, at the beginning of your script, before you create any local shared objects. All local shared objects created thereafter will use AMF0 encoding and can interact with older content. You cannot change the objectEncoding value of existing local shared objects by setting SharedObject.defaultObjectEncoding after the local shared objects have been created.

To set the object encoding on a per-object basis, rather than for all shared objects created by the SWF file, set the objectEncoding property of the local shared object instead.

Implementation
    public static function get defaultObjectEncoding():uint
    public function set defaultObjectEncoding(value:uint):void

See also

objectEncoding property
ObjectEncoding class
fps property
fps:Number [write-only]

Specifies the number of times per second that a client's changes to a shared object are sent to the server.

Use this method when you want to control the amount of traffic between the client and the server. For example, if the connection between the client and server is relatively slow, you may want to set fps to a relatively low value. Conversely, if the client is connected to a multiuser application in which timing is important, you may want to set fps to a relatively high value.

If you want to manually control when updates are sent, set fps to 0 when you want to send changes to the server. For example, if you want to let the user push a button that sends updates to the server, attach myRemoteSharedObject.fps(0) to the button.

Regardless of the value you pass for fps, changes are not sent to the server until the sync event has been dispatched. That is, if the response time from the server is slow, updates may be sent to the server less frequently than the value specified in this property.

Implementation
    public function set fps(value:Number):void
objectEncoding property
objectEncoding:uint [read-write]

The object encoding (AMF version) for this shared object. When a local shared object is written to disk, the objectEncoding property indicates which Action Message Format version should be used: the ActionScript 3.0 format (AMF3) or the ActionScript 1.0 or 2.0 format (AMF0).

Object encoding is handled differently depending if the shared object is local or remote.

  • Local shared objects. You can get or set the value of the objectEncoding property for local shared objects. The value of objectEncoding affects what formatting is used for writing this local shared object. If this local shared object must be readable by ActionScript 2.0 or 1.0 SWF files, set objectEncoding to ObjectEncoding.AMF0. Even if object encoding is set to write AMF3, Flash Player can still read AMF0 local shared objects. That is, if you use the default value of this property, ObjectEncoding.AMF3, your SWF file can still read shared objects created by ActionScript 2.0 or 1.0 SWF files.
  • Remote shared objects. When connected to the server, a remote shared object inherits its objectEncoding setting from the associated NetConnection instance (the instance used to connect to the remote shared object). When not connected to the server, a remote shared object inherits the defaultObjectEncoding setting from the associated NetConnection instance.

    Because the value of a remote shared object's objectEncoding property is determined by the NetConnection instance, this property is read-only for remote shared objects.

Implementation
    public function get objectEncoding():uint
    public function set objectEncoding(value:uint):void

Throws
ReferenceError — You attempted to set the value of the objectEncoding property on a remote shared object. This property is read-only for remote shared objects because its value is determined by the associated NetConnection instance.

See also

defaultObjectEncoding
flash.net.ObjectEncoding
size property
size:uint [read-only]

The current size of the shared object, in bytes.

Flash calculates the size of a shared object by stepping through all of its data properties; the more data properties the object has, the longer it takes to estimate its size. Estimating object size can take significant processing time, so you may want to avoid using this method unless you have a specific need for it.

Implementation
    public function get size():uint

See also

Storing local data

Example
The following code creates a SharedObject object using an id "thehobbit". A property named username is added to the data property of the SharedObject object. The size property is then traced, which returns the value indicated.

import flash.net.SharedObject;

// if these get copied or not
var mySo:SharedObject = SharedObject.getLocal("thehobbit");
mySo.data.username = "bilbobaggins";
trace(mySo.size); // 55

Method detail
clear () method
public function clear():void

For local shared objects, purges all of the data and deletes the shared object from the disk. The reference to the shared object is still active, but its data properties are deleted.

For remote shared objects, this method disconnects the object and purges all of the data; if the shared object is locally persistent, the method also deletes the shared object from the disk. The reference to the shared object is still active, but its data properties are deleted.

Example
The following code creates (and on subsequent executions, retrieves) a SharedObject object using an id with the value of hostName. A property named username is added to the data property of the SharedObject object. The clear() method is finally called, which wipes out all information that was added to the data object (in this case was a single property named username).

package {
    import flash.net.SharedObject;

    public class SharedObject_clear {
        private var hostName:String = "yourDomain";
        private var username:String = "yourUsername";

        public function SharedObject_clear() {
            var mySo:SharedObject = SharedObject.getLocal(hostName);
            if(mySo.data.username == null) {
                mySo.data.username = username;
                trace("set: " + mySo.data.username); // yourUsername
            }
            else {
                mySo.clear();
                trace("cleared: " + mySo.data.username); // undefined
            }
        }
    }
}

close () method
public function close():void

Closes the connection between a remote shared object and the server. If a remote shared object is locally persistent, the user can make changes to the local copy of the object after this method is called. Any changes made to the local object are sent to the server the next time the user connects to the remote shared object.

connect () method
public function connect(myConnection:NetConnection, params:String = null):void

Connects to a remote shared object on the server through the specified connection. Use this method after issuing SharedObject.getRemote(). After a successful connection, the sync event is dispatched.

Before attempting to work with a remote shared object, first check for a return value of true, indicating a successful connection, and then wait until the sync event is dispatched. If you fail to do so, any changes you make to the object locally — before the sync event is dispatched — may be lost.

Note: The sync event is not dispatched if this call returns false.

Parameters
myConnection:NetConnection — A NetConnection object (such as one used to communicate with Flash Media Server) that is using the Real-Time Messaging Protocol (RTMP).
params:String (default = null)

Throws
Error — Flash Player could not connect to the specified remote shared object. Verify that the NetConnection instance is valid and connected and that the remote shared object was successfully created on the server.

See also

getRemote()
NetConnection
flush () method
public function flush(minDiskSpace:int = 0):String

Immediately writes a locally persistent shared object to a local file. If you don't use this method, Flash Player writes the shared object to a file when the shared object session ends — that is, when the SWF file is closed, when the shared object is garbage-collected because it no longer has any references to it, or when you call SharedObject.clear() or SharedObject.close().

If this method returns SharedObjectFlushStatus.PENDING, Flash Player displays a dialog box asking the user to increase the amount of disk space available to objects from this domain. To allow space for the shared object to grow when it is saved in the future, which avoids return values of PENDING, pass a value for minDiskSpace. When Flash Player tries to write the file, it looks for the number of bytes passed to minDiskSpace, instead of looking for enough space to save the shared object at its current size.

For example, if you expect a shared object to grow to a maximum size of 500 bytes, even though it might start out much smaller, pass 500 for minDiskSpace. If Flash asks the user to allot disk space for the shared object, it asks for 500 bytes. After the user allots the requested amount of space, Flash won't have to ask for more space on future attempts to flush the object (as long as its size doesn't exceed 500 bytes).

After the user responds to the dialog box, this method is called again and the netStatus event is dispatched with a code property of SharedObject.Flush.Success or SharedObject.Flush.Failed.

Parameters
minDiskSpace:int (default = 0) — The minimum disk space, in bytes, that must be allotted for this object.

Returns
String — Either of the following values:
  • SharedObjectFlushStatus.PENDING: The user has permitted local information storage for objects from this domain, but the amount of space allotted is not sufficient to store the object. Flash Player prompts the user to allow more space.
  • SharedObjectFlushStatus.FLUSHED: The shared object has been successfully written to a file on the local disk.

Throws
Error — Flash Player cannot write the shared object to disk. This error might occur if the user has permanently disallowed local information storage for objects from this domain.

Note: Local content can always write shared objects from third-party domains (domains other than the domain in the current browser address bar) to disk, even if writing of third-party shared objects to disk is disallowed.

See also

clear()
Storing local data

Example
The following code creates (and on subsequent executions, retrieves) a SharedObject object using an id with the value of hostName. A property named username is added to the data property of the SharedObject object. The flush() method is then called, followed by a check to see if the string pending, or a boolean value of true or false was returned. One should be aware that all open SharedObject instances will automatically be flushed whenever the current instance of the Flash Player is closed.
package {
    import flash.net.SharedObject;

    public class SharedObject_flush {
        private var hostName:String = "yourDomain";
        private var username:String = "yourUsername";

        public function SharedObject_flush() {
            var mySo:SharedObject = SharedObject.getLocal(hostName);
            mySo.data.username = username;
            var flushResult:Object = mySo.flush();
            trace("flushResult: " + flushResult);
            trace(mySo.data.username); // yourUsername
        }
    }
}

getLocal () method
public static function getLocal(name:String, localPath:String = null, secure:Boolean = false):SharedObject

Returns a reference to a locally persistent shared object that is available only to the current client. If the shared object does not already exist, this method creates one. If any values passed to getLocal() are invalid or if the call fails, Flash Player throws an exception.

The following code shows how you assign the returned shared object reference to a variable:

var so:SharedObject = SharedObject.getLocal("savedData");

Note: If the user has chosen to never allow local storage for this domain, the object is not saved locally, even if a value for localPath is specified. The exception to this rule is local content. Local content can always write shared objects from third-party domains (domains other than the domain in the current browser address bar) to disk, even if writing of third-party shared objects to disk is disallowed.

To avoid name conflicts, Flash looks at the location of the SWF file that is creating the shared object. For example, if a SWF file at www.myCompany.com/apps/stockwatcher.swf creates a shared object named portfolio, that shared object does not conflict with another object named portfolio that was created by a SWF file at www.yourCompany.com/photoshoot.swf because the SWF files originate from different directories.

Although the localPath parameter is optional, you should give some thought to its use, especially if other SWF files need to access the shared object. If the data in the shared object is specific to one SWF file that will not be moved to another location, then use of the default value makes sense. If other SWF files need access to the shared object, or if the SWF file that creates the shared object will later be moved, then the value of this parameter affects how accessible the shared object will be. For example, if you create a shared object with localPath set to the default value of the full path to the SWF file, no other SWF file can access that shared object. If you later move the original SWF file to another location, not even that SWF file can access the data already stored in the shared object.

To avoid inadvertently restricting access to a shared object, use the localpath parameter. The most permissive approach is to set localPath to / (slash), which makes the shared object available to all SWF files in the domain, but increases the likelihood of name conflicts with other shared objects in the domain. A more restrictive approach is to append localPath with folder names that are in the full path to the SWF file. For example, for a portfolio shared object created by the SWF file at www.myCompany.com/apps/stockwatcher.swf, you could set the localPath parameter to /, /apps, or /apps/stockwatcher.swf. You must determine which approach provides optimal flexibility for your application.

When using this method, consider the Flash Player security model:

  • You cannot access shared objects across sandbox boundaries.
  • Users can restrict shared object access by using the Flash Player Settings dialog box or the Settings Manager. By default, an application can create shared objects of up 100 KB of data per domain. Administrators and users can also place restrictions on the ability to write to the file system.

Suppose you publish SWF file content to be played back as local files (either locally installed SWF files or EXE files), and you need to access a specific shared object from more than one local SWF file. In this situation, be aware that for local files, two different locations might be used to store shared objects. The domain that is used depends on the security permissions granted to the local file that created the shared object. Local files can have three different levels of permissions:

  1. Access to the local filesystem only.
  2. Access to the network only.
  3. Access to both the network and the local filesystem.

Local files with access to the local filesystem (level 1 or 3) store their shared objects in one location. Local files without access to the local filesystem (level 2) store their shared objects in another location.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
name:String — The name of the object. The name can include forward slashes (/); for example, work/addresses is a legal name. Spaces are not allowed in a shared object name, nor are the following characters:
  ~ % & \ ; : " ' , < > ? #
localPath:String (default = null) — The full or partial path to the SWF file that created the shared object, and that determines where the shared object will be stored locally. If you do not specify this parameter, the full path is used.
secure:Boolean (default = false) — Determines whether access to this shared object is restricted to SWF files that are delivered over an HTTPS connection. If your SWF file is delivered over HTTPS, this parameter's value has the following effects:
  • If this parameter is set to true, Flash Player creates a new secure shared object or gets a reference to an existing secure shared object. This secure shared object can be read from or written to only by SWF files delivered over HTTPS that call SharedObject.getLocal() with the secure parameter set to true.
  • If this parameter is set to false, Flash Player creates a new shared object or gets a reference to an existing shared object that can be read from or written to by SWF files delivered over non-HTTPS connections.

If your SWF file is delivered over a non-HTTPS connection and you try to set this parameter to true, the creation of a new shared object (or the access of a previously created secure shared object) fails and null is returned. Regardless of the value of this parameter, the created shared objects count toward the total amount of disk space allowed for a domain.

The following diagram shows the use of the secure parameter:

Returns
SharedObject — A reference to a shared object that is persistent locally and is available only to the current client. If Flash Player can't create or find the shared object (for example, if localPath was specified but no such directory exists), this method throws an exception.

Throws
Error — Flash Player cannot create the shared object for whatever reason. This error might occur is if persistent shared object creation and storage by third-party Flash content is prohibited (does not apply to local content). Users can prohibit third-party persistent shared objects on the Global Storage Settings panel of the Settings Manager, located at http://www.adobe.com/support/documentation/en/flashplayer/help/settings_manager03.html.

See also

Storing local data
getRemote () method
public static function getRemote(name:String, remotePath:String = null, persistence:Object = false, secure:Boolean = false):SharedObject

Returns a reference to an object that can be shared across multiple clients by means of a server, such as Flash Media Server. If the shared object does not already exist, this method creates one.

The following code shows how you assign the returned shared object reference to a variable:

var myRemote_so:SharedObject = SharedObject.getRemote(name, remotePath, persistence);

To create a shared object that is available only to the current client, use SharedObject.getLocal().

After calling this method, use SharedObject.connect() to connect the object to the application server, as shown in the following code:

     var myNC:NetConnection = new NetConnection();
     myNC.connect("rtmp://[yourDomain].com/applicationName");
     var myRemoteSO:SharedObject = SharedObject.getRemote("mo", myNC.uri, false);
     myRemoteSO.connect(myNC);

To confirm that the local and remote copies of the shared object are synchronized, use the sync event.

All clients that want to share this object must pass the same values for the name and remotePath parameters. For additional information about remote shared objects, see SharedObject.getRemote() in the Flash Media Server documentation.

Parameters
name:String — The name of the object. The name can include forward slashes (/); for example, work/addresses is a legal name. Spaces are not allowed in a shared object name, nor are the following characters:
~ % & \ ; :  " ' , > ? ? #
remotePath:String (default = null) — The URI of the server on which the shared object will be stored. This URI must be identical to the URI of the NetConnection object passed to the SharedObject.connect() method.
persistence:Object (default = false) — Specifies whether the attributes of the shared object's data property are persistent locally, remotely, or both. This parameter can also specify where the shared object will be stored locally. Acceptable values are as follows:
  • A value of false specifies that the shared object is not persistent on the client or server.
  • A value of true specifies that the shared object is persistent only on the server.
  • A full or partial local path to the shared object indicates that the shared object is persistent on the client and the server. On the client, it is stored in the specified path; on the server, it is stored in a subdirectory within the application directory.

Note: If the user has chosen to never allow local storage for this domain, the object will not be saved locally, even if a local path is specified for persistence. For more information, see the class description.
secure:Boolean (default = false) — Determines whether access to this shared object is restricted to SWF files that are delivered over an HTTPS connection. For more information, see the description of the secure parameter in the getLocal method entry.

Returns
SharedObject — A reference to an object that can be shared across multiple clients.

Throws
Error — Flash Player can't create or find the shared object. This might occur if nonexistent paths were specified for the remotePath and persistence parameters.

See also

connect()
getLocal()
Storing local data
send () method
public function send(... arguments):void

Broadcasts a message to all clients connected to the specified remote shared object, including the client that sent the message. To process and respond to the message, create a handler function to send to the shared object.

Parameters
... arguments — One or more arguments: A string that identifies the message; the name of one or more handler functions to attach to the shared object; and optional parameters that can be of any type. They are serialized and sent over the connection, and the receiving handler receives them in the same order. If a parameter is a circular object (for example, a linked list that is circular), the serializer handles the references correctly.

Note: Do not use a reserved term for the function names. For example, myRemoteSO.send("close") will fail.
setDirty () method
public function setDirty(propertyName:String):void

Indicates to the server that the value of a property (defined with the data property) in the shared object has changed. This method marks properties as changed (dirty) and is used in server-side ActionScript.

You create properties for a shared object using the SharedObject.data property or simply by creating new, uniquely named SharedObject properties. For more information about the difference between these two techniques, see the SharedObject.data property.

The SharedObject.setProperty() method implements the setDirty() method. In most cases, such as when the value of a property is a primitive type like String or Number, you would use setProperty() instead of setDirty(). However, when the value of a property is an object that contains its own properties, use setDirty() to indicate when a value within the object has changed.

Parameters
propertyName:String — The name of the property that has changed.

See also

SharedObject.data (client-side property)
setProperty()
setProperty () method
public function setProperty(propertyName:String, value:Object = null):void

Updates the value of a property (defined with the data property) in a shared object and indicates to the server that the value of the property has changed. The setProperty() method explicitly marks properties as changed (dirty) and is used in server-side ActionScript. Some servers, such as Flash Media Server, require an explicit call to setProperty() to indicate when a property of the shared object has changed.

If you call SharedObject.setProperty() on the server side, it invokes a change notification through the sync event on the client side for any Flash Player client that is using the shared object. The propertyName parameter on the server side is the same as an attribute of the data property on the client side. For example, the following lines of code are all equivalent: the first two lines are server-side ActionScript, and the third and fourth are client-side ActionScript:

  setProperty("nameVal", "foo");
  setDirty("nameVal");
  data["nameVal"] = "foo";
  data.nameVal = "foo";

Users of Flash Media Server can find additional information on server-side ActionScript and remote shared objects in the Flash Media Server Server-Side ActionScript Language Reference.

Note: The SharedObject.setProperty() method implements the setDirty() method. In most cases, such as when the value of a property is a primitive type like String or Number, you would use setProperty() instead of setDirty. However, when the value of a property is an object that contains its own properties, use setDirty() to indicate when a value within the object has changed. In general, it is a good idea to call setProperty() rather than setDirty(), because setProperty() updates a property value only when that value has changed, whereas setDirty() forces synchronization on all subscribed clients.

Parameters
propertyName:String — The name of the property in the shared object.
value:Object (default = null) — The value of the property (an ActionScript object), or null to delete the property.

See also

SharedObject.data (client-side property)
Event detail
asyncError event
Event object type: flash.events.AsyncErrorEvent
AsyncErrorEvent.type property = flash.events.AsyncErrorEvent.ASYNC_ERROR

Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code.

The AsyncErrorEvent.ASYNC_ERROR constant defines the value of the type property of an asyncError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object experiencing a network operation failure.
error | The error that triggered the event.
netStatus event
Event object type: flash.events.NetStatusEvent
NetStatusEvent.type property = flash.events.NetStatusEvent.NET_STATUS

Dispatched when a SharedObject instance is reporting its status or error condition. The netStatus event contains an info property, which is an information object that contains specific information about the event, such as whether a connection attempt succeeded or whether the shared object was successfully written to the local disk.

Defines the value of the type property of a netStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
info | An object with properties that describe the object's status or error condition.
target | The NetConnection or NetStream object reporting its status.

See also

flash.events.NetStatusEvent.info
sync event
Event object type: flash.events.SyncEvent
SyncEvent.type property = flash.events.SyncEvent.SYNC

Dispatched when a remote shared object (SharedObject) has been updated by the server.

Defines the value of the type property of a sync event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
changeList | An array with properties that describe the array's status.
target | The SharedObject instance that has been updated by the server.

See also

getRemote()
Examples

The following code creates (and on subsequent executions, retrieves) a shared object object using the ID "application-name". When the Save button is clicked, the saveValue() method attempts to save a property named savedValue to the data property of the SharedObject object. If Flash Player must ask for permission to save the data, when the user grants or denies permission the onFlushStatus() method is called. When the Clear button is clicked, the clearValue() method deletes the value saved in savedValue; the next time the SWF file is loaded, the value that is retrieved is undefined.
package {
    import flash.display.Sprite;
    import flash.events.MouseEvent;
    import flash.events.NetStatusEvent;
    import flash.net.SharedObject;
    import flash.net.SharedObjectFlushStatus;
    import flash.text.TextField;
    import flash.text.TextFieldAutoSize;
    import flash.text.TextFieldType;

    public class SharedObjectExample extends Sprite {

        private var mySo:SharedObject;

        public function SharedObjectExample() {
            buildUI();
            saveBtn.addEventListener(MouseEvent.CLICK, saveValue);
            clearBtn.addEventListener(MouseEvent.CLICK, clearValue);

            mySo = SharedObject.getLocal("application-name");
            output.appendText("SharedObject loaded...\n");
            output.appendText("loaded value: " + mySo.data.savedValue + "\n\n");
        }

         private function saveValue(event:MouseEvent):void {
            output.appendText("saving value...\n");
            mySo.data.savedValue = input.text;

            var flushStatus:String = null;
            try {
                flushStatus = mySo.flush(10000);
            } catch (error:Error) {
                output.appendText("Error...Could not write SharedObject to disk\n");
            }
            if (flushStatus != null) {
                switch (flushStatus) {
                    case SharedObjectFlushStatus.PENDING:
                        output.appendText("Requesting permission to save object...\n");
                        mySo.addEventListener(NetStatusEvent.NET_STATUS, onFlushStatus);
                        break;
                    case SharedObjectFlushStatus.FLUSHED:
                        output.appendText("Value flushed to disk.\n");
                        break;
                }
            }
            output.appendText("\n");
        }

        private function clearValue(event:MouseEvent):void {
            output.appendText("Cleared saved value...Reload SWF and the value should be \"undefined\".\n\n");
            delete mySo.data.savedValue;
        }

        private function onFlushStatus(event:NetStatusEvent):void {
            output.appendText("User closed permission dialog...\n");
            switch (event.info.code) {
                case "SharedObject.Flush.Success":
                    output.appendText("User granted permission -- value saved.\n");
                    break;
                case "SharedObject.Flush.Failed":
                    output.appendText("User denied permission -- value not saved.\n");
                    break;
            }
            output.appendText("\n");

            mySo.removeEventListener(NetStatusEvent.NET_STATUS, onFlushStatus);
        }

        // UI elements
        private var inputLbl:TextField;
        private var input:TextField;
        private var output:TextField;
        private var saveBtn:Sprite;
        private var clearBtn:Sprite;

        private function buildUI():void {
            // input label
            inputLbl = new TextField();
            addChild(inputLbl);
            inputLbl.x = 10;
            inputLbl.y = 10;
            inputLbl.text = "Value to save:";

            // input TextField
            input = new TextField();
            addChild(input);
            input.x = 80;
            input.y = 10;
            input.width = 100;
            input.height = 20;
            input.border = true;
            input.background = true;
            input.type = TextFieldType.INPUT;

            // output TextField
            output = new TextField();
            addChild(output);
            output.x = 10;
            output.y = 35;
            output.width = 250;
            output.height = 250;
            output.multiline = true;
            output.wordWrap = true;
            output.border = true;
            output.background = true;

            // Save button
            saveBtn = new Sprite();
            addChild(saveBtn);
            saveBtn.x = 190;
            saveBtn.y = 10;
            saveBtn.useHandCursor = true;
            saveBtn.graphics.lineStyle(1);
            saveBtn.graphics.beginFill(0xcccccc);
            saveBtn.graphics.drawRoundRect(0, 0, 30, 20, 5, 5);
            var saveLbl:TextField = new TextField();
            saveBtn.addChild(saveLbl);
            saveLbl.text = "Save";
            saveLbl.selectable = false;

            // Clear button
            clearBtn = new Sprite();
            addChild(clearBtn);
            clearBtn.x = 230;
            clearBtn.y = 10;
            clearBtn.useHandCursor = true;
            clearBtn.graphics.lineStyle(1);
            clearBtn.graphics.beginFill(0xcccccc);
            clearBtn.graphics.drawRoundRect(0, 0, 30, 20, 5, 5);
            var clearLbl:TextField = new TextField();
            clearBtn.addChild(clearLbl);
            clearLbl.text = "Clear";
            clearLbl.selectable = false;
        }
    }
}


flash.net.SharedObjectFlushStatus (Flex™ 2 Language Reference)

Class SharedObjectFlushStatus | Properties | Methods | Constants
Package | flash.net
Class | public final class SharedObjectFlushStatus
Inheritance | SharedObjectFlushStatus Inheritance Object

The SharedObjectFlushStatus class provides values for the code returned from a call to the SharedObject.flush() method.

See also

SharedObject.flush()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | FLUSHED : String = "flushed" [static] Indicates that the flush completed successfully. | SharedObjectFlushStatus
 | PENDING : String = "pending" [static] Indicates that the user is being prompted to increase disk space for the shared object before the flush can occur. | SharedObjectFlushStatus
Constant detail
FLUSHED constant
public static const FLUSHED:String = "flushed"

Indicates that the flush completed successfully.

See also

SharedObject.flush()
PENDING constant
public static const PENDING:String = "pending"

Indicates that the user is being prompted to increase disk space for the shared object before the flush can occur.

See also

SharedObject.flush()


flash.net.Socket (Flex™ 2 Language Reference)

Class Socket | Properties | Methods | Events | Examples
Package | flash.net
Class | public class Socket
Inheritance | Socket Inheritance EventDispatcher Inheritance Object
Implements | IDataInput, IDataOutput

The Socket class enables ActionScript code to make socket connections and to read and write raw binary data. It is similar to XMLSocket but does not dictate the format of the received or transmitted data.

The Socket class is useful for working with servers that use binary protocols.

When you use this class, consider the Flash Player security model:

  • Data loading is not allowed if the calling SWF file is in the local-with-file-system sandbox and the target resource is from a network sandbox.
  • Data loading is also not allowed if the calling SWF file is from a network sandbox and the target resource is local.
  • The calling SWF file and the network resource being accessed must be in exactly the same domain. For example, a SWF file at adobe.com can connect only to a server daemon at adobe.com.
  • Websites can permit cross-domain access to a resource through a cross-domain policy file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

View the examples.

See also

Socket connections

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bytesAvailable : uint [read-only] The number of bytes of data available for reading in the input buffer. | Socket
 | connected : Boolean [read-only] Indicates whether this Socket object is currently connected. | Socket
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | endian : String Indicates the byte order for the data; possible values are constants from the flash.utils.Endian class, Endian.BIG_ENDIAN or Endian.LITTLE_ENDIAN. | Socket
 | objectEncoding : uint Controls the version of AMF used when writing or reading an object. | Socket
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Socket(host:String = null, port:int = 0)
Creates a Socket object.
Socket
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
close():void
Closes the socket.
Socket
connect(host:String, port:int):void
Connects the socket to the specified host and port.
Socket
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
flush():void
Flushes any accumulated data in the socket's output buffer.
Socket
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
readBoolean():Boolean
Reads a Boolean value from the socket.
Socket
readByte():int
Reads a signed byte from the socket.
Socket
readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void
Reads the number of data bytes specified by the length parameter from the socket.
Socket
readDouble():Number
Reads an IEEE 754 double-precision floating-point number from the socket.
Socket
readFloat():Number
Reads an IEEE 754 single-precision floating-point number from the socket.
Socket
readInt():int
Reads a signed 32-bit integer from the socket.
Socket
readMultiByte(length:uint, charSet:String):String
Reads a multibyte string from the byte stream, using the specified character set.
Socket
readObject():*
Reads an object from the socket, encoded in AMF serialized format.
Socket
readShort():int
Reads a signed 16-bit integer from the socket.
Socket
readUnsignedByte():uint
Reads an unsigned byte from the socket.
Socket
readUnsignedInt():uint
Reads an unsigned 32-bit integer from the socket.
Socket
readUnsignedShort():uint
Reads an unsigned 16-bit integer from the socket.
Socket
readUTF():String
Reads a UTF-8 string from the socket.
Socket
readUTFBytes(length:uint):String
Reads the number of UTF-8 data bytes specified by the length parameter from the socket, and returns a string.
Socket
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
writeBoolean(value:Boolean):void
Writes a Boolean value to the socket.
Socket
writeByte(value:int):void
Writes a byte to the socket.
Socket
writeBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void
Writes a sequence of bytes from the specified byte array.
Socket
writeDouble(value:Number):void
Writes an IEEE 754 double-precision floating-point number to the socket.
Socket
writeFloat(value:Number):void
Writes an IEEE 754 single-precision floating-point number to the socket.
Socket
writeInt(value:int):void
Writes a 32-bit signed integer to the socket.
Socket
writeMultiByte(value:String, charSet:String):void
Writes a multibyte string from the byte stream, using the specified character set.
Socket
writeObject(object:*):void
Write an object to the socket in AMF serialized format.
Socket
writeShort(value:int):void
Writes a 16-bit integer to the socket.
Socket
writeUnsignedInt(value:uint):void
Writes a 32-bit unsigned integer to the socket.
Socket
writeUTF(value:String):void
Writes the following data to the socket: a 16-bit unsigned integer, which indicates the length of the specified UTF-8 string in bytes, followed by the string itself.
Socket
writeUTFBytes(value:String):void
Writes a UTF-8 string to the socket.
Socket
Events
Event |  | Summary | Defined by
 | close | Dispatched when the server closes the socket connection. | Socket
 | connect | Dispatched when a network connection has been established. | Socket
 | ioError | Dispatched when an input/output error occurs that causes a send or load operation to fail. | Socket
 | securityError | Dispatched if a call to Socket.connect() attempts to connect either to a server outside the caller's security sandbox or to a port lower than 1024. | Socket
 | socketData | Dispatched when a socket has received data. | Socket
Property detail
bytesAvailable property
bytesAvailable:uint [read-only]

The number of bytes of data available for reading in the input buffer.

Your code must access bytesAvailable to ensure that sufficient data is available before trying to read it with one of the read methods.

Implementation
    public function get bytesAvailable():uint
connected property
connected:Boolean [read-only]

Indicates whether this Socket object is currently connected. A call to this property returns a value of true if the socket is currently connected, or false otherwise.

Implementation
    public function get connected():Boolean
endian property
endian:String [read-write]

Indicates the byte order for the data; possible values are constants from the flash.utils.Endian class, Endian.BIG_ENDIAN or Endian.LITTLE_ENDIAN.

The default value is Endian.BIG_ENDIAN.

Implementation
    public function get endian():String
    public function set endian(value:String):void

See also

flash.utils.Endian
objectEncoding property
objectEncoding:uint [read-write]

Controls the version of AMF used when writing or reading an object.

Implementation
    public function get objectEncoding():uint
    public function set objectEncoding(value:uint):void

See also

ObjectEncoding class
readObject()
writeObject()
Constructor detail
Socket () constructor
public function Socket(host:String = null, port:int = 0)

Creates a Socket object. If no parameters are specified, an initially disconnected socket is created. If parameters are specified, a connection is attempted to the specified host and port.

Parameters
host:String (default = null) — The name of the host to connect to. If this parameter is not specified, an initially disconnected socket is created.
port:int (default = 0) — The port number to connect to. If this parameter is not specified, an initially disconnected socket is created.

Events
connect:Event — Dispatched when a network connection has been established.
ioError:IOErrorEvent — Dispatched when an input/output error occurs that causes the connection to fail.
securityError:SecurityErrorEvent — Dispatched if a call to Socket.connect() attempts to connect either to a server outside the caller's security sandbox or to a port lower than 1024. You can work around either problem by using a cross-domain policy file on the server. For more information about policy files for sockets, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

Throws
SecurityError — This error occurs for the following reasons:
  • Local untrusted SWF files cannot communicate with the Internet. You can work around this problem by reclassifying this SWF file as local-with-networking or trusted.
  • You cannot specify a socket port higher than 65535.
Method detail
close () method
public function close():void

Closes the socket. You cannot read or write any data after the close() method has been called.

The close event is dispatched only when the server closes the connection; it is not dispatched when you call the close() method.

You can reuse the Socket object by calling the connect() method on it again.

Throws
IOError — The socket could not be closed, or the socket was not open.
connect () method
public function connect(host:String, port:int):void

Connects the socket to the specified host and port. If the connection fails immediately, either an event is dispatched or an exception is thrown: an error event is dispatched if a host was specified, and an exception is thrown if no host was specified. Otherwise, the status of the connection is reported by an event. If the socket is already connected, the existing connection is closed first.

By default, the value you pass for host must be in the same domain and the value you pass for port must be 1024 or higher. For example, a SWF file at adobe.com can connect only to a server daemon running at adobe.com. If you want to connect to a socket on a different host than the one from which the connecting SWF file was served, or if you want to connect to a port lower than 1024 on any host, you must obtain an xmlsocket: policy file from the host to which you are connecting. For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

Parameters
host:String — The name of the host to connect to. If no host is specified, the host that is contacted is the host where the calling SWF file resides. If you do not specify a host, use an event listener to determine whether the connection was successful.
port:int — The port number to connect to.

Events
connect:Event — Dispatched when a network connection has been established.
ioError:IOErrorEvent — Dispatched if a host is specified and an input/output error occurs that causes the connection to fail.
securityError:SecurityErrorEvent — Dispatched if a call to Socket.connect() attempts to connect to either a server outside the caller's security sandbox or to a port lower than 1024. You can work around either problem by using a cross-domain policy file on the server. For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

Throws
IOError — No host was specified and the connection failed.
SecurityError — This error occurs for the following reasons:
  • Local untrusted SWF files may not communicate with the Internet. You can work around this by reclassifying this SWF file as local-with-networking or trusted.
  • You cannot specify a socket port higher than 65535.
flush () method
public function flush():void

Flushes any accumulated data in the socket's output buffer. Data written by the write methods is not immediately transmitted; it is queued until the flush() method is called.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.
readBoolean () method
public function readBoolean():Boolean

Reads a Boolean value from the socket. After reading a single byte, the method returns true if the byte is nonzero, and false otherwise.

Returns
Boolean — A value of true if the byte read is nonzero, otherwise false.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readByte () method
public function readByte():int

Reads a signed byte from the socket.

Returns
int — A value from -128 to 127.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readBytes () method
public function readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void

Reads the number of data bytes specified by the length parameter from the socket. The bytes are read into the specified byte array, starting at the position indicated by offset.

Parameters
bytes:ByteArray — The ByteArray object to read data into.
offset:uint (default = 0) — The offset at which data reading should begin in the byte array.
length:uint (default = 0) — The number of bytes to read. The default value of 0 causes all available data to be read.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readDouble () method
public function readDouble():Number

Reads an IEEE 754 double-precision floating-point number from the socket.

Returns
Number

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readFloat () method
public function readFloat():Number

Reads an IEEE 754 single-precision floating-point number from the socket.

Returns
Number

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readInt () method
public function readInt():int

Reads a signed 32-bit integer from the socket.

Returns
int — A value from -2147483648 to 2147483647.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readMultiByte () method
public function readMultiByte(length:uint, charSet:String):String

Reads a multibyte string from the byte stream, using the specified character set.

Parameters
length:uint — The number of bytes from the byte stream to read.
charSet:String — The string denoting the character set to use to interpret the bytes. Possible character set strings include "shift_jis", "CN-GB", and "iso-8859-1". For a complete list, see Supported Character Sets.

Returns
String — A UTF-8 encoded string.

Throws
EOFError — There is insufficient data available to read.
readObject () method
public function readObject():*

Reads an object from the socket, encoded in AMF serialized format.

Returns
* — The deserialized object

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

ObjectEncoding
readShort () method
public function readShort():int

Reads a signed 16-bit integer from the socket.

Returns
int — A value from -32768 to 32767.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readUnsignedByte () method
public function readUnsignedByte():uint

Reads an unsigned byte from the socket.

Returns
uint — A value from 0 to 255.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readUnsignedInt () method
public function readUnsignedInt():uint

Reads an unsigned 32-bit integer from the socket.

Returns
uint — A value from 0 to 4294967295.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readUnsignedShort () method
public function readUnsignedShort():uint

Reads an unsigned 16-bit integer from the socket.

Returns
uint — A value from 0 to 65535.

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readUTF () method
public function readUTF():String

Reads a UTF-8 string from the socket. The string is assumed to be prefixed with an unsigned short integer that indicates the length in bytes.

Returns
String

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
readUTFBytes () method
public function readUTFBytes(length:uint):String

Reads the number of UTF-8 data bytes specified by the length parameter from the socket, and returns a string.

Parameters
length:uint — The number of bytes to read.

Returns
String

Throws
EOFError — There is insufficient data available to read.
IOError — An I/O error occurred on the socket, or the socket is not open.
writeBoolean () method
public function writeBoolean(value:Boolean):void

Writes a Boolean value to the socket. This method writes a single byte, with either a value of 1 (true) or 0 (false).

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:Boolean — The value to write to the socket: 1 (true) or 0 (false).

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeByte () method
public function writeByte(value:int):void

Writes a byte to the socket.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:int — The value to write to the socket. The low 8 bits of the value are used; the high 24 bits are ignored.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeBytes () method
public function writeBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void

Writes a sequence of bytes from the specified byte array. The write operation starts at the position specified by offset.

If you omit the length parameter the default length of 0 causes the method to write the entire buffer starting at offset.

If you also omit the offset parameter, the entire buffer is written.

If offset or length is out of range, they are adjusted to match the beginning and end of the bytes array.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
bytes:ByteArray — The ByteArray object to write data from.
offset:uint (default = 0) — The zero-based offset into the bytes ByteArray object at which data writing should begin.
length:uint (default = 0) — The number of bytes to write. The default value of 0 causes the entire buffer to be written, starting at the value specified by the offset parameter.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeDouble () method
public function writeDouble(value:Number):void

Writes an IEEE 754 double-precision floating-point number to the socket.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:Number — The value to write to the socket.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeFloat () method
public function writeFloat(value:Number):void

Writes an IEEE 754 single-precision floating-point number to the socket.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:Number — The value to write to the socket.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeInt () method
public function writeInt(value:int):void

Writes a 32-bit signed integer to the socket.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:int — The value to write to the socket.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeMultiByte () method
public function writeMultiByte(value:String, charSet:String):void

Writes a multibyte string from the byte stream, using the specified character set.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:String — The string value to be written.
charSet:String — The string denoting the character set to use to interpret the bytes. Possible character set strings include "shift_jis", "CN-GB", and "iso-8859-1". For a complete list, see Supported Character Sets.

See also

flush()
writeObject () method
public function writeObject(object:*):void

Write an object to the socket in AMF serialized format.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
object:* — The object to be serialized.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
ObjectEncoding
writeShort () method
public function writeShort(value:int):void

Writes a 16-bit integer to the socket. The bytes written are as follows:

(v >> 8) & 0xff v & 0xff

The low 16 bits of the parameter are used; the high 16 bits are ignored.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:int — The value to write to the socket.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeUnsignedInt () method
public function writeUnsignedInt(value:uint):void

Writes a 32-bit unsigned integer to the socket.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:uint — The value to write to the socket.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeUTF () method
public function writeUTF(value:String):void

Writes the following data to the socket: a 16-bit unsigned integer, which indicates the length of the specified UTF-8 string in bytes, followed by the string itself.

Before writing the string, the method calculates the number of bytes needed to represent all characters of the string.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:String — The string to write to the socket.

Throws
RangeError — The length is larger than 65535.
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
writeUTFBytes () method
public function writeUTFBytes(value:String):void

Writes a UTF-8 string to the socket.

Note: Data written by this method is not immediately transmitted; it is queued until the flush() method is called.

Parameters
value:String — The string to write to the socket.

Throws
IOError — An I/O error occurred on the socket, or the socket is not open.

See also

flush()
Event detail
close event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CLOSE

Dispatched when the server closes the socket connection. The close event is dispatched only when the server closes the connection; it is not dispatched when you call the Socket.close() method.

Defines the value of the type property of a close event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object whose connection has been closed.
connect event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CONNECT

Dispatched when a network connection has been established.

Defines the value of the type property of a connect event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Socket or XMLSocket object that has established a network connection.
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input/output error occurs that causes a send or load operation to fail.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched if a call to Socket.connect() attempts to connect either to a server outside the caller's security sandbox or to a port lower than 1024.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

Socket.connect()
Flash Player Security
socketData event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.SOCKET_DATA

Dispatched when a socket has received data. Events of type socketData do not use the ProgressEvent.bytesTotal property.

Defines the value of the type property of a socketData event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event.
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | 0; this property is not used by socketData event objects.
target | The Socket object reporting progress.
Examples

The following example reads from and writes to a socket and outputs information transmitted during socket events. Highlights of the example follow:
  1. The constructor creates a CustomSocket instance named socket and passes the host name localhost and port 80 as arguments. Since CustomSocket extends Socket, a call to super() calls Socket's constructor with localhost as the host name and 80 as the port number.
  2. The example then calls the configureListeners() method, which adds listeners for Socket events.

Note: To run the example, you need a server running on the same domain where the SWF resides (in the example, localhost) and listening on port 80.

package {
    import flash.display.Sprite;

    public class SocketExample extends Sprite {

        public function SocketExample() {
            var socket:CustomSocket = new CustomSocket("localhost", 80);
        }
    }
}

import flash.errors.*;
import flash.events.*;
import flash.net.Socket;

class CustomSocket extends Socket {
    private var response:String;

    public function CustomSocket(host:String = null, port:uint = 0) {
        super(host, port);
        configureListeners();
    }

    private function configureListeners():void {
        addEventListener(Event.CLOSE, closeHandler);
        addEventListener(Event.CONNECT, connectHandler);
        addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
        addEventListener(ProgressEvent.SOCKET_DATA, socketDataHandler);
    }

    private function writeln(str:String):void {
        str += "\n";
        try {
            writeUTFBytes(str);
        }
        catch(e:IOError) {
            trace(e);
        }
    }

    private function sendRequest():void {
        trace("sendRequest");
        response = "";
        writeln("GET /");
        flush();
    }

    private function readResponse():void {
        var str:String = readUTFBytes(bytesAvailable);
        response += str;
    }

    private function closeHandler(event:Event):void {
        trace("closeHandler: " + event);
        trace(response.toString());
    }

    private function connectHandler(event:Event):void {
        trace("connectHandler: " + event);
        sendRequest();
    }

    private function ioErrorHandler(event:IOErrorEvent):void {
        trace("ioErrorHandler: " + event);
    }

    private function securityErrorHandler(event:SecurityErrorEvent):void {
        trace("securityErrorHandler: " + event);
    }

    private function socketDataHandler(event:ProgressEvent):void {
        trace("socketDataHandler: " + event);
        readResponse();
    }
}


flash.net.URLLoader (Flex™ 2 Language Reference)

Class URLLoader | Properties | Methods | Events | Examples
Package | flash.net
Class | public class URLLoader
Inheritance | URLLoader Inheritance EventDispatcher Inheritance Object

The URLLoader class downloads data from a URL as text, binary data, or URL-encoded variables. It is useful for downloading text files, XML, or other information to be used in a dynamic, data-driven application.

A URLLoader object downloads all of the data from a URL before making it available to ActionScript. It sends out notifications about the progress of the download, which you can monitor through the bytesLoaded and bytesTotal properties, as well as through dispatched events.

The value you pass for the url parameter must, by default, be in exactly the same domain. For example, a SWF file at www.adobe.com can load data only from sources that are also at www.adobe.com. To load data from a different domain, place a cross-domain policy file on the server hosting the SWF file.

When using this method, consider the Adobe® Flash® Player security model:

For Flash Player 8 and later:

  • Data loading is not allowed if the calling SWF file is in the local-with-file-system sandbox and the target resource is from a network sandbox.
  • Data loading is also not allowed if the calling SWF file is from a network sandbox and the target resource is local.

For Flash Player 7 and later:

  • Websites can permit cross-domain access to a resource through a cross-domain policy file.
  • In SWF files of any version running in Flash Player 7 and later, url must be in exactly the same domain. For example, a SWF file at www.adobe.com can load data only from sources that are also at www.adobe.com.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

In SWF files that are running in a version of the player earlier than Flash Player 7, url must be in the same superdomain as the SWF file that is issuing this call. A superdomain is derived by removing the leftmost component of a file's URL. For example, a SWF file at www.adobe.com can load data from sources at store.adobe.com because both files are in the same superdomain named adobe.com.

View the examples.

See also

URLRequest
URLVariables
URLStream
Reading external XML documents
Working with external data

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bytesLoaded : uint = 0 Indicates the number of bytes that have been loaded thus far during the load operation. | URLLoader
 | bytesTotal : uint = 0 Indicates the total number of bytes in the downloaded data. | URLLoader
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : * The data received from the load operation. | URLLoader
 | dataFormat : String = "text" Controls whether the downloaded data is received as text (URLLoaderDataFormat.TEXT), raw binary data (URLLoaderDataFormat.BINARY), or URL-encoded variables (URLLoaderDataFormat.VARIABLES). | URLLoader
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
URLLoader(request:URLRequest = null)
Creates a URLLoader object.
URLLoader
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
close():void
Closes the load operation in progress.
URLLoader
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
load(request:URLRequest):void
Sends and loads data from the specified URL.
URLLoader
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | complete | Dispatched after all the received data is decoded and placed in the data property of the URLLoader object. | URLLoader
 | httpStatus | Dispatched if a call to URLLoader.load() attempts to access data over HTTP and the current Flash Player environment is able to detect and return the status code for the request. | URLLoader
 | ioError | Dispatched if a call to URLLoader.load() results in a fatal error that terminates the download. | URLLoader
 | open | Dispatched when the download operation commences following a call to the URLLoader.load() method. | URLLoader
 | progress | Dispatched when data is received as the download operation progresses. | URLLoader
 | securityError | Dispatched if a call to URLLoader.load() attempts to load data from a server outside the security sandbox. | URLLoader
Property detail
bytesLoaded property
public var bytesLoaded:uint = 0

Indicates the number of bytes that have been loaded thus far during the load operation.

bytesTotal property
public var bytesTotal:uint = 0

Indicates the total number of bytes in the downloaded data. This property contains 0 while the load operation is in progress and is populated when the operation is complete.

data property
public var data:*

The data received from the load operation. This property is populated only when the load operation is complete. The format of the data depends on the setting of the dataFormat property:

If the dataFormat property is URLLoaderDataFormat.TEXT, the received data is a string containing the text of the loaded file.

If the dataFormat property is URLLoaderDataFormat.BINARY, the received data is a ByteArray object containing the raw binary data.

If the dataFormat property is URLLoaderDataFormat.VARIABLES, the received data is a URLVariables object containing the URL-encoded variables.

See also

URLLoaderDataFormat
URLLoader.dataFormat
dataFormat property
public var dataFormat:String = "text"

Controls whether the downloaded data is received as text (URLLoaderDataFormat.TEXT), raw binary data (URLLoaderDataFormat.BINARY), or URL-encoded variables (URLLoaderDataFormat.VARIABLES).

If the value of the dataFormat property is URLLoaderDataFormat.TEXT, the received data is a string containing the text of the loaded file.

If the value of the dataFormat property is URLLoaderDataFormat.BINARY, the received data is a ByteArray object containing the raw binary data.

If the value of the dataFormat property is URLLoaderDataFormat.VARIABLES, the received data is a URLVariables object containing the URL-encoded variables.

The default value is URLLoaderDataFormat.TEXT.

See also

URLLoaderDataFormat
Constructor detail
URLLoader () constructor
public function URLLoader(request:URLRequest = null)

Creates a URLLoader object.

Parameters
request:URLRequest (default = null) — A URLRequest object specifying the URL to download. If this parameter is omitted, no load operation begins. If specified, the load operation begins immediately (see the load entry for more information).

See also

URLLoader.load()
Method detail
close () method
public function close():void

Closes the load operation in progress. Any load operation in progress is immediately terminated. If no URL is currently being streamed, an invalid stream error is thrown.

load () method
public function load(request:URLRequest):void

Sends and loads data from the specified URL. The data can be received as text, raw binary data, or URL-encoded variables, depending on the value you set for the dataFormat property. Note that the default value of the dataFormat property is text. If you want to send data to the specified URL, you can set the data property in the URLRequest object.

Note: If a file being loaded contains non-ASCII characters (as found in many non-English languages), it is recommended that you save the file with UTF-8 or UTF-16 encoding as opposed to a non-Unicode format like ASCII.

By default, the URL you load must be in exactly the same domain as the calling SWF file. For example, a SWF file at www.adobe.com can load data only from sources that are also at www.adobe.com. To load data from a different domain, put a cross-domain policy file on the server hosting the SWF file.

When using this method, consider the Flash Player security model:

For Flash Player 8 and later:

  • Data loading is not allowed if the calling SWF file is in the local-with-file-system sandbox and the target resource is from a network sandbox.
  • Data loading is also not allowed if the calling SWF file is from a network sandbox and the target resource is local.

For Flash Player 7 and later websites can permit cross-domain access to a resource through a cross-domain policy file. In SWF files of any version running in Flash Player 7 and later, url must be in exactly the same domain. For example, a SWF file at www.adobe.com can load data only from sources that are also at www.adobe.com.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

In SWF files that are running in a version of the player earlier than Flash Player 7, url must be in the same superdomain as the SWF file that is issuing this call. A superdomain is derived by removing the leftmost component of a file's URL. For example, a SWF file at www.adobe.com can load data from sources at store.adobe.com because both files are in the same superdomain of adobe.com.

 Parameters
request:URLRequest — A URLRequest object specifying the URL to download.

Events
complete:Event — Dispatched after data has loaded successfully.
httpStatus:HTTPStatusEvent — If access is over HTTP, and the current Flash Player environment supports obtaining status codes, you may receive these events in addition to any complete or error event.
ioError:IOErrorEvent — The load operation could not be completed.
progress:ProgressEvent — Dispatched when data is received as the download operation progresses.
securityError:SecurityErrorEvent — A load operation attempted to retrieve data from a server outside the caller's security sandbox. This may be worked around using a policy file on the server.
open:Event — Dispatched when a load operation commences.

Throws
ArgumentError — URLRequest.requestHeader objects may not contain certain prohibited HTTP request headers. For more information, see the URLRequestHeader class description.
MemoryError — This error can occur for the following reasons: 1) Flash Player cannot convert the URLRequest.data parameter from UTF8 to MBCS. This error is applicable if the URLRequest object passed to load() is set to perform a GET operation and if System.useCodePage is set to true. 2) Flash Player cannot allocate memory for the POST data. This error is applicable if the URLRequest object passed to load is set to perform a POST operation.
SecurityError — Local untrusted SWF files may not communicate with the Internet. This may be worked around by reclassifying this SWF file as local-with-networking or trusted.
TypeError — The value of the request parameter or the URLRequest.url property of the URLRequest object passed are null.

See also

URLRequestHeader
URLRequest.requestHeaders
URLRequest.data
Working with external data
Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched after all the received data is decoded and placed in the data property of the URLLoader object. The received data may be accessed once this event has been dispatched.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.

See also

URLLoader.load()
httpStatus event
Event object type: flash.events.HTTPStatusEvent
HTTPStatusEvent.type property = flash.events.HTTPStatusEvent.HTTP_STATUS

Dispatched if a call to URLLoader.load() attempts to access data over HTTP and the current Flash Player environment is able to detect and return the status code for the request. (Some browser environments may not be able to provide this information.) Note that the httpStatus event (if any) is sent before (and in addition to) any complete or error event.

Defines the value of the type property of a httpStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
status | The HTTP status code returned by the server.
target | The network object receiving an HTTP status code.

See also

URLLoader.load()
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched if a call to URLLoader.load() results in a fatal error that terminates the download.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.

See also

URLLoader.load()
open event
Event object type: flash.events.Event
Event.type property = flash.events.Event.OPEN

Dispatched when the download operation commences following a call to the URLLoader.load() method.

Defines the value of the type property of an open event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has opened a connection.

See also

URLLoader.load()
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched when data is received as the download operation progresses.

Note that with a URLLoader object, it is not possible to access the data until it has been received completely. So, the progress event only serves as a notification of how far the download has progressed. To access the data before it's entirely downloaded, use a URLStream object.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.

See also

URLLoader.load()
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched if a call to URLLoader.load() attempts to load data from a server outside the security sandbox.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

URLLoader.load()
Flash Player Security
Examples

The following example loads and displays the data found in a local text file. It also traces event handling information.

Note: To run this example, put a file named urlLoaderExample.txt in the same directory as your SWF file. That file should only contain the following line of text:

answer=42&question=unknown

The example code does the following:

  1. The constructor function creates a URLLoader instance named loader and a URLRequest instance named request, which contains the location and name of the file to be loaded.
  2. The loader object is passed to the configureListeners() method, which adds listeners for each of the supported URLLoader events.
  3. The request object is then passed to loader.load(), which loads the text file.
  4. When the URLLoader has finished loading the text file the Event.COMPLETE event fires, triggering the completeHandler() method. The completeHandler() method creates a URLVariables object from the text loaded from the file. The URLVariables object converts URL-encoded name/value pairs into ActionScript properties to make it easier to manipulate the loaded data.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.*;

    public class URLLoaderExample extends Sprite {
        public function URLLoaderExample() {
            var loader:URLLoader = new URLLoader();
            configureListeners(loader);

            var request:URLRequest = new URLRequest("urlLoaderExample.txt");
            try {
                loader.load(request);
            } catch (error:Error) {
                trace("Unable to load requested document.");
            }
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        }

        private function completeHandler(event:Event):void {
            var loader:URLLoader = URLLoader(event.target);
            trace("completeHandler: " + loader.data);

            var vars:URLVariables = new URLVariables(loader.data);
            trace("The answer is " + vars.answer);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler loaded:" + event.bytesLoaded + " total: " + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }
    }
}


flash.net.URLLoaderDataFormat (Flex™ 2 Language Reference)

Class URLLoaderDataFormat | Properties | Methods | Constants | Examples
Package | flash.net
Class | public final class URLLoaderDataFormat
Inheritance | URLLoaderDataFormat Inheritance Object

The URLLoaderDataFormat class provides values that specify how downloaded data is received.

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BINARY : String = "binary" [static] Specifies that downloaded data is received as raw binary data. | URLLoaderDataFormat
 | TEXT : String = "text" [static] Specifies that downloaded data is received as text. | URLLoaderDataFormat
 | VARIABLES : String = "variables" [static] Specifies that downloaded data is received as URL-encoded variables. | URLLoaderDataFormat
Constant detail
BINARY constant
public static const BINARY:String = "binary"

Specifies that downloaded data is received as raw binary data.

TEXT constant
public static const TEXT:String = "text"

Specifies that downloaded data is received as text.

VARIABLES constant
public static const VARIABLES:String = "variables"

Specifies that downloaded data is received as URL-encoded variables.

Examples

The following example uses the URLLoaderDataFormatExample class to display data format and status information for a file loaded at runtime. This is accomplished using the following steps:
  1. The class constructor creates a URLLoader instance named loader and a URLRequest instance named request, which is the location and name of the file to be loaded.
  2. The loader object is passed to the configureListeners() method, which adds listeners for each of the supported URLLoader events:
    • completeHandler(): listens for the complete event, which is dispatched after TextFile.txt has successfully loaded.
    • openHandler(): listens for the open event, dispatched upon start of the download (to the player) of TextFile.txt.
    • progressHandler(): listens for the progress events, dispatched when data is received as the download operation progresses.
    • securityErrorHandler(): listens for securityError events, which would be dispatched if the text file was accessed with the wrong local playback security setting.
    • httpStatusHandler(): listens for httpStatusHandler events, which will not be dispatched in this case since TextFile.txt is local.
    • ioErrorHandler(): listens for ioError events, which would happen only if there were a serious problem with the file, such as if it were missing.
  3. The request object is then passed to the loader.load() method, which loads the text file into memory using a DisplayObject object.

Notes:

  • You will need to compile the SWF file with "Local playback security" set to "Access local files only".
  • This example requires that a file named TextFile.txt be placed in the same directory as your SWF file. If you would like to see this example identify binary or URL-encoded data files, you will need to provide the file in the proper data format and change TextFile.txt to the name and location of the new file.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.*;

    public class URLLoaderDataFormatExample extends Sprite {
        private var source:String = "TextFile.txt";
        private var dataFormat:String = URLLoaderDataFormat.TEXT;

        public function URLLoaderDataFormatExample () {
            var loader:URLLoader = new URLLoader();
            loader.dataFormat = dataFormat;
            configureListeners(loader);
            var request:URLRequest = new URLRequest(source);
            try {
                loader.load(request);
            } catch (error:Error) {
                trace("Error loading requested document: " + source);
            }
        }

        private function configureListeners(dispatcher:URLLoader):void {
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        }

        private function completeHandler(event:Event):void {
            var loader:URLLoader = URLLoader(event.target);
            switch(loader.dataFormat) {
                case URLLoaderDataFormat.TEXT :
                    trace("completeHandler (text): " + loader.data);
                    break;
                case URLLoaderDataFormat.BINARY :
                    trace("completeHandler (binary): " + loader.data);
                    break;
                case URLLoaderDataFormat.VARIABLES :
                    trace("completeHandler (variables): " + loader.data);
                    break;
            }
        }

        private function httpStatusHandler(event:Event):void {
            trace("httpStatusHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler loaded:" + event.bytesLoaded + " total: " + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }
    }
}


flash.net.URLRequest (Flex™ 2 Language Reference)

Class URLRequest | Properties | Methods | Examples
Package | flash.net
Class | public final class URLRequest
Inheritance | URLRequest Inheritance Object

The URLRequest class captures all of the information in a single HTTP request. URLRequest objects are passed to the load() methods of URLStream, URLLoader, Loader and other loading operations to initiate URL downloads, as well as to the upload() and download() methods of the FileReference class.

By default, the URL that you pass to the url parameter must be in exactly the same domain as the calling SWF file, including subdomains. For example, www.adobe.com and store.adobe.com are different domains. To load data from a different domain, place a cross-domain policy file on the server that is hosting the SWF file.

When you use this class, consider the Adobe® Flash® Player security model:

  • Data loading is not allowed if the calling SWF file is in the local-with-file-system sandbox and the target resource is from a network sandbox.
  • Data loading is also not allowed if the calling SWF file is from a network sandbox and the target resource is local.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

View the examples.

See also

URLRequestHeader
URLLoader
URLStream
FileReference
Working with external data

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contentType : String The MIME content type of any POST data. | URLRequest
 | data : Object An object containing data to be transmitted with the URL request. | URLRequest
 | method : String Controls whether the HTTP form submission method is a GET or POST operation. | URLRequest
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | requestHeaders : Array The array of HTTP request headers to be appended to the HTTP request. | URLRequest
 | url : String The URL to be requested. | URLRequest
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | URLRequest(url:String = null) Creates a URLRequest object. | URLRequest
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
contentType property
contentType:String [read-write]

The MIME content type of any POST data.

Note:The FileReference.upload() and FileReference.download() methods do not support the URLRequest.contentType parameter.

Implementation
    public function get contentType():String
    public function set contentType(value:String):void
data property
data:Object [read-write]

An object containing data to be transmitted with the URL request.

This property is used with the method property. If the value of URLRequest.method is POST, the data is transmitted with the URLRequest object with the HTTP POST method.

If the value of URLRequest.method is GET, the data defines variables to be sent with the URLRequest object with the HTTP GET method.

The URLRequest API offers binary POST support and support for URL-encoded variables, as well as support for strings. The data object can be of ByteArray, URLVariables, or String type.

The way in which the data is used depends on the type of object used:

  • If the object is a ByteArray object, the binary data of the ByteArray object is used as POST data. For GET, data of ByteArray type is not supported. Also, data of ByteArray type is not supported for FileReference.upload() and FileReference.download().
  • If the object is a URLVariables object and the method is POST, the variables are encoded using x-www-form-urlencoded format and the resulting string is used as POST data. An exception is a call to FileReference.upload(), in which the variables are sent as separate fields in a multipart/form-data post.
  • If the object is a URLVariables object and the method is GET, the URLVariables object defines variables to be sent with the URLRequest object.
  • Otherwise, the object is converted to a string, and the string is used as the POST or GET data.

This data is not sent until a method, such as navigateToURL() or FileReference.upload(), uses the URLRequest object.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

URLRequest.method
URLRequestMethod
URLVariables
flash.utils.ByteArray

Example
The following example opens the remote application hosted at http://www.[yourDomain].com/application.jsp in a new browser window and passes data about a user session, captured in a URLVariables object, to the application.

Highlights of the example follow:

  1. The constructor function creates a URLRequest instance named request, taking the URL of the remote application as a parameter.
  2. A URLVariables object is created and two of its properties are assigned values.
  3. The URLVariables object is assigned to the data property of the URLRequest object.
  4. The example calls navigateToURL, which opens a new browser window to the remote application's URL.

Note: To run the example, the remote application URL in the example must be replaced with a working URL. Additionally, you would need server code to process the information captured by Flash Player in the URLVariables object.

package {
    import flash.display.Sprite;
    import flash.net.navigateToURL;
    import flash.net.URLRequest;
    import flash.net.URLVariables;

    public class URLVariablesExample extends Sprite {

        public function URLVariablesExample() {
            var url:String = "http://www.[yourDomain].com/application.jsp";
            var request:URLRequest = new URLRequest(url);
            var variables:URLVariables = new URLVariables();
            variables.exampleSessionId = new Date().getTime();
            variables.exampleUserLabel = "guest";
            request.data = variables;
            navigateToURL(request);
        }
    }
}

method property
method:String [read-write]

Controls whether the HTTP form submission method is a GET or POST operation. Valid values are URLRequestMethod.GET or URLRequestMethod.POST.

The default value is URLRequestMethod.GET.

Implementation
    public function get method():String
    public function set method(value:String):void

Throws
ArgumentError — If the value parameter is not URLRequestMethod.GET or URLRequestMethod.POST.

See also

URLRequestMethod class
Working with external data

Example
The following example opens the remote application hosted at http://www.[yourDomain].com/application.jsp in a new browser window and passes data about a user session, captured in a URLVariables object, to the application. It explicitly sets the value of the URLRequest.method property to URLRequestMethod.POST.

Highlights of the example follow:

  1. The constructor function creates a URLRequest instance named request, taking the URL of the remote application as a parameter.
  2. A URLVariables object is created and two of its properties are assigned values.
  3. The URLVariables object is assigned to the data property of the URLRequest object.
  4. The value of the URLRequest.method property is set to URLRequestMethod.POST.
  5. The example calls navigateToURL, which opens a new browser window to the remote application's URL.

Note: To run the example, the remote application URL in the example must be replaced with a working URL. Additionally, you would need server code to process the information captured by Flash Player in the URLVariables object.

package {
    import flash.display.Sprite;
    import flash.net.navigateToURL;
    import flash.net.URLRequest;
    import flash.net.URLRequestMethod;
    import flash.net.URLVariables;

    public class URLRequest_method extends Sprite {

        public function URLRequest_method() {
            var url:String = "http://www.[yourDomain].com/application.jsp";
            var request:URLRequest = new URLRequest(url);

            var variables:URLVariables = new URLVariables();
            variables.exampleSessionId = new Date().getTime();
            variables.exampleUserLabel = "guest";
            request.data = variables;
            request.method = URLRequestMethod.POST;

            navigateToURL(request);
        }
    }
}

requestHeaders property
requestHeaders:Array [read-write]

The array of HTTP request headers to be appended to the HTTP request. The array is composed of URLRequestHeader objects. Each object in the array must be a URLRequestHeader object that contains a name string and a value string, as follows:

  var rhArray:Array = new Array(new URLRequestHeader("Content-Type", "text/html"));

Flash Player imposes certain restrictions on request headers; for more information, see the URLRequestHeader class description.

The FileReference.upload() and FileReference.download() methods do not support the URLRequest.requestHeaders parameter.

Implementation
    public function get requestHeaders():Array
    public function set requestHeaders(value:Array):void

See also

URLRequestHeader
url property
url:String [read-write]

The URL to be requested. By default, the URL must be in exactly the same domain as the calling SWF file, including subdomains. For example, SWF files at www.adobe.com and store.adobe.com are in different domains. To load data from a different domain, put a cross-domain policy file on the server that is hosting the SWF file. For more information, see the security documentation described in the URLRequest class description.

Implementation
    public function get url():String
    public function set url(value:String):void
Constructor detail
URLRequest () constructor
public function URLRequest(url:String = null)

Creates a URLRequest object. If System.useCodePage is true, the request is encoded using the system code page, rather than Unicode. If System.useCodePage is false, the request is encoded using Unicode, rather than the system code page.

Parameters
url:String (default = null) — The URL to be requested. You can set the URL later by using the url property.

See also

flash.system.System.useCodePage
Examples

The following example creates a new Loader object and passes it a URLRequest object that contains the path to an XML file. If the loading operation is successful, a complete event is dispatched and the data in the XML file traces to the output. Additional event handlers capture other events, including error events.

To run this example, place a file named XMLFile.xml in the same directory as your SWF file.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.*;

    public class URLRequestExample extends Sprite {

        public function URLRequestExample() {
            var loader:URLLoader = new URLLoader();
            configureListeners(loader);

            var request:URLRequest = new URLRequest("XMLFile.xml");
            try {
                loader.load(request);
            } catch (error:Error) {
                trace("Unable to load requested document.");
            }
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        }

        private function completeHandler(event:Event):void {
            var loader:URLLoader = URLLoader(event.target);
            trace("completeHandler: " + loader.data);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler loaded:" + event.bytesLoaded + " total: " + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }
    }
}


flash.net.URLRequestHeader (Flex™ 2 Language Reference)

View comments | RSS feed
Class URLRequestHeader | Properties | Methods | Examples
Package | flash.net
Class | public final class URLRequestHeader
Inheritance | URLRequestHeader Inheritance Object

A URLRequestHeader object encapsulates a single HTTP request header and consists of a name/value pair. URLRequestHeader objects are used in the requestHeaders property of the URLRequest class.

The following request headers cannot be used: Accept-Ranges, Age, Allow, Allowed, Connection, Content-Length, Content-Location, Content-Range, ETag, Host, Last-Modified, Location, Max-Forwards, Proxy-Authenticate, Proxy-Authorization, Public, Range, Retry-After, Server, TE, Trailer, Transfer-Encoding, Upgrade, URI, Vary, Via, Warning, WWW-Authenticate, x-flash-version.

URLRequestHeader objects are restricted in length. If the cumulative length of a URLRequestHeader object (the length of the name property plus the value property) or an array of URLRequestHeader objects used in the URLRequest.requestHeaders property exceeds the acceptable length, Adobe® Flash® Player throws an exception.

View the examples.

See also

URLRequest
URLLoader

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | name : String An HTTP request header name (such as Content-Type or SOAPAction). | URLRequestHeader
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | value : String The value associated with the name property (such as text/plain). | URLRequestHeader
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | URLRequestHeader(name:String = "", value:String = "") Creates a new URLRequestHeader object that encapsulates a single HTTP request header. | URLRequestHeader
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
name property
public var name:String

An HTTP request header name (such as Content-Type or SOAPAction).

value property
public var value:String

The value associated with the name property (such as text/plain).

Constructor detail
URLRequestHeader () constructor
public function URLRequestHeader(name:String = "", value:String = "")

Creates a new URLRequestHeader object that encapsulates a single HTTP request header. URLRequestHeader objects are used in the requestHeaders property of the URLRequest class.

Parameters
name:String (default = "") — An HTTP request header name (such as Content-Type or SOAPAction).
value:String (default = "") — The value associated with the name property (such as text/plain).
Examples

The following example adds a single HTTP request header to an array in a URLRequest object and then loads data from an XML file and displays event information. Highlights of the example follow:
  1. The constructor function creates a URLLoader instance named loader and a URLRequest instance named request, which contains the location and name of the file to be loaded.
  2. The loader object is passed to the configureListeners() method, which adds listeners for each of the supported URLLoader events.
  3. The example creates a URLRequestHeader instance with the parameters name = pragma and value = no-cache.
  4. The HTML request header is then added to the end of the requestHeaders array.
  5. Then request is passed to the loader.load() method, which loads the XML file.

Note: To run the example, put a file named XMLFile.xml in the same directory as your SWF file.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.URLLoader;
    import flash.net.URLRequest;
    import flash.net.URLRequestHeader;
    import flash.net.URLRequestMethod;
    import flash.net.URLVariables;

    public class URLRequestHeaderExample extends Sprite {
        public function URLRequestHeaderExample() {
            var loader:URLLoader = new URLLoader();
            configureListeners(loader);

            var header:URLRequestHeader = new URLRequestHeader("pragma", "no-cache");
            var request:URLRequest = new URLRequest("http://www.[yourdomain].com/greeting.cfm");
            request.data = new URLVariables("name=John+Doe");
            request.method = URLRequestMethod.POST;
            request.requestHeaders.push(header);
            try {
                loader.load(request);
            } catch (error:Error) {
                trace("Unable to load requested document.");
            }
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        }

        private function completeHandler(event:Event):void {
            var loader:URLLoader = URLLoader(event.target);
            trace("completeHandler: " + loader.data);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler loaded:" + event.bytesLoaded + " total: " + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }
    }
}

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

djtechwriter said on Jun 28, 2006 at 5:13 PM :
The following request headers not mentioned in the overview also cannot be used:

Referer, Get, Post, Put, Delete, Options, and Trace.

Dave Jacowitz
Flash Team
djtechwriter said on Jun 29, 2006 at 2:05 PM :
Restricted terms are not case-sensitive (so GET, Get, and get are all restricted).

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/flash/net/URLRequestHeader.html


flash.net.URLRequestMethod (Flex™ 2 Language Reference)

Class URLRequestMethod | Properties | Methods | Constants | Examples
Package | flash.net
Class | public final class URLRequestMethod
Inheritance | URLRequestMethod Inheritance Object

The URLRequestMethod class provides values that specify whether the URLRequest object should use the POST method or the GET method when sending data to a server.

View the examples.

See also

URLRequest
URLVariables

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | GET : String = "GET" [static] Specifies that the URLRequest object is a GET. | URLRequestMethod
 | POST : String = "POST" [static] Specifies that the URLRequest object is a POST. | URLRequestMethod
Constant detail
GET constant
public static const GET:String = "GET"

Specifies that the URLRequest object is a GET.

POST constant
public static const POST:String = "POST"

Specifies that the URLRequest object is a POST.

Examples

The following example loads and displays the data found in a local text file. It also traces event handling information.

Note:To run this example, put a file named example.txt in the same directory as your SWF file. That file should be a simple text file containing a few words or lines of text.

The example code does the following:

  1. The constructor function creates a URLLoader instance named loader.
  2. The loader object is passed to the configureListeners() method, which adds listeners for each of the supported URLLoader events.
  3. A URLRequest instance named request is created, which specifies name of the file to be loaded.
  4. The method property of the request is set to URLRequestMethod.POST.
  5. The request object is then passed to loader.load(), which loads the text file.
  6. When the URLLoader has finished loading the text file the Event.COMPLETE event fires, triggering the completeHandler() method. The completeHandler() method simply traces the data property, the contents of the text file.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.*;

    public class URLRequestMethodExample extends Sprite {

        public function URLRequestMethodExample() {
            var loader:URLLoader = new URLLoader();
            configureListeners(loader);

            var request:URLRequest = new URLRequest("example.txt");

            request.method = URLRequestMethod.POST;
            loader.load(request);
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        }

        private function completeHandler(event:Event):void {
            var loader:URLLoader = URLLoader(event.target);
            trace("completeHandler: " + loader.data);
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler loaded:" + event.bytesLoaded + " total: " + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }
    }
}


flash.net.URLStream (Flex™ 2 Language Reference)

Class URLStream | Properties | Methods | Events | Examples
Package | flash.net
Class | public class URLStream
Inheritance | URLStream Inheritance EventDispatcher Inheritance Object
Implements | IDataInput

The URLStream class provides low-level access to downloading URLs. Data is made available to ActionScript immediately as it is downloaded, instead of waiting until the entire file is complete as with URLLoader. The URLStream class also lets you close a stream before it finishes downloading. The contents of the downloaded file are made available as raw binary data.

The read operations in URLStream are nonblocking. This means that you must use the bytesAvailable property to determine whether sufficient data is available before reading it. An EOFError exception is thrown if insufficient data is available.

All binary data is encoded by default in big-endian format, with the most significant byte first.

The security rules that apply to URL downloading with the URLStream class are identical to the rules applied to URLLoader objects. Policy files may be downloaded as needed. Local file security rules are enforced, and security warnings are raised as needed.

View the examples.

See also

URLLoader
URLRequest

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bytesAvailable : uint [read-only] Returns the number of bytes of data available for reading in the input buffer. | URLStream
 | connected : Boolean [read-only] Indicates whether this URLStream object is currently connected. | URLStream
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | endian : String Indicates the byte order for the data; possible values are BIG_ENDIAN or LITTLE_ENDIAN. | URLStream
 | objectEncoding : uint Controls the version of Action Message Format (AMF) used when writing or reading an object. | URLStream
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
close():void
Immediately closes the stream and cancels the download operation.
URLStream
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
load(request:URLRequest):void
Begins downloading the URL specified in the request parameter.
URLStream
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
readBoolean():Boolean
Reads a Boolean value from the stream.
URLStream
readByte():int
Reads a signed byte from the stream.
URLStream
readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void
Reads length bytes of data from the stream.
URLStream
readDouble():Number
Reads an IEEE 754 double-precision floating-point number from the stream.
URLStream
readFloat():Number
Reads an IEEE 754 single-precision floating-point number from the stream.
URLStream
readInt():int
Reads a signed 32-bit integer from the stream.
URLStream
readMultiByte(length:uint, charSet:String):String
Reads a multibyte string of specified length from the byte stream using the specified character set.
URLStream
readObject():*
Reads an object from the socket, encoded in Action Message Format (AMF).
URLStream
readShort():int
Reads a signed 16-bit integer from the stream.
URLStream
readUnsignedByte():uint
Reads an unsigned byte from the stream.
URLStream
readUnsignedInt():uint
Reads an unsigned 32-bit integer from the stream.
URLStream
readUnsignedShort():uint
Reads an unsigned 16-bit integer from the stream.
URLStream
readUTF():String
Reads a UTF-8 string from the stream.
URLStream
readUTFBytes(length:uint):String
Reads a sequence of length UTF-8 bytes from the stream, and returns a string.
URLStream
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | complete | Dispatched when data has loaded successfully. | URLStream
 | httpStatus | Dispatched if a call to URLStream.load() attempts to access data over HTTP, and the current Flash Player is able to detect and return the status code for the request. | URLStream
 | ioError | Dispatched when an input/output error occurs that causes a load operation to fail. | URLStream
 | open | Dispatched when a load operation starts. | URLStream
 | progress | Dispatched when data is received as the download operation progresses. | URLStream
 | securityError | Dispatched if a call to URLStream.load() attempts to load data from a server outside the security sandbox. | URLStream
Property detail
bytesAvailable property
bytesAvailable:uint [read-only]

Returns the number of bytes of data available for reading in the input buffer. Your code must call the bytesAvailable property to ensure that sufficient data is available before you try to read it with one of the read methods.

Implementation
    public function get bytesAvailable():uint
connected property
connected:Boolean [read-only]

Indicates whether this URLStream object is currently connected. A call to this property returns a value of true if the URLStream object is connected, or false otherwise.

Implementation
    public function get connected():Boolean
endian property
endian:String [read-write]

Indicates the byte order for the data; possible values are BIG_ENDIAN or LITTLE_ENDIAN.

The default value is Endian.BIG_ENDIAN.

Implementation
    public function get endian():String
    public function set endian(value:String):void

See also

flash.utils.Endian
objectEncoding property
objectEncoding:uint [read-write]

Controls the version of Action Message Format (AMF) used when writing or reading an object.

Implementation
    public function get objectEncoding():uint
    public function set objectEncoding(value:uint):void

See also

readObject()
ObjectEncoding class
Method detail
close () method
public function close():void

Immediately closes the stream and cancels the download operation. No data can be read from the stream after the close() method is called.

Throws
IOError — The stream could not be closed, or the stream was not open.
load () method
public function load(request:URLRequest):void

Begins downloading the URL specified in the request parameter.

Note: If a file being loaded contains non-ASCII characters (as found in many non-English languages), it is recommended that you save the file with UTF-8 or UTF-16 encoding, as opposed to a non-Unicode format like ASCII.

If the loading operation fails immediately, an IOError or SecurityError (including the local file security error) exception is thrown describing the failure. Otherwise, an open event is dispatched if the URL download starts downloading successfully, or an error event is dispatched if an error occurs.

When using this method, consider the Adobe® Flash® Player security model:

  • Data loading is not allowed if the calling SWF file is in the local-with-file-system sandbox and the target resource is from a network sandbox.
  • Data loading is also not allowed if the calling SWF file is from a network sandbox and the target resource is local.
  • By default, the URL you load must be in exactly the same domain as the calling SWF file. For example, a SWF file at www.adobe.com can load data only from sources that are also at www.adobe.com. To load data from a different domain, put a cross-domain policy file on the server hosting the SWF file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
request:URLRequest — A URLRequest object specifying the URL to download. If the value of this parameter or the URLRequest.url property of the URLRequest object passed are null, Flash Player throws a null pointer error.

Events
complete:Event — Dispatched after data has loaded successfully.
httpStatus:HTTPStatusEvent — If access is by HTTP, and the current Flash Player environment supports obtaining status codes, you may receive these events in addition to any complete or error event.
ioError:IOErrorEvent — The load operation could not be completed.
open:Event — Dispatched when a load operation starts.
securityError:SecurityErrorEvent — A load operation attempted to retrieve data from a server outside the caller's security sandbox. This may be worked around using a policy file on the server.

Throws
ArgumentError — URLRequest.requestHeader objects may not contain certain prohibited HTTP request headers. For more information, see the URLRequestHeader class description.
MemoryError — This error can occur for the following reasons:
  1. Flash Player cannot convert the URLRequest.data parameter from UTF8 to MBCS. This error is applicable if the URLRequest object passed to load() is set to perform a GET operation and if System.useCodePage is set to true.
  2. Flash Player cannot allocate memory for the POST data. This error is applicable if the URLRequest object passed to load is set to perform a POST operation.
SecurityError — Local untrusted SWF files may not communicate with the Internet. This may be worked around by reclassifying this SWF file as local-with-networking or trusted.
readBoolean () method
public function readBoolean():Boolean

Reads a Boolean value from the stream. A single byte is read, and true is returned if the byte is nonzero, false otherwise.

Returns
Boolean

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readByte () method
public function readByte():int

Reads a signed byte from the stream.

The returned value is in the range -128...127.

Returns
int

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readBytes () method
public function readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void

Reads length bytes of data from the stream. The bytes are read into the ByteArray object specified by bytes, starting offset bytes into the ByteArray object.

Parameters
bytes:ByteArray — The ByteArray object to read data into.
offset:uint (default = 0) — The offset into bytes at which data read should begin. Defaults to 0.
length:uint (default = 0) — The number of bytes to read. The default value of 0 will cause all available data to be read.

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readDouble () method
public function readDouble():Number

Reads an IEEE 754 double-precision floating-point number from the stream.

Returns
Number

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readFloat () method
public function readFloat():Number

Reads an IEEE 754 single-precision floating-point number from the stream.

Returns
Number

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readInt () method
public function readInt():int

Reads a signed 32-bit integer from the stream.

The returned value is in the range -2147483648...2147483647.

Returns
int

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readMultiByte () method
public function readMultiByte(length:uint, charSet:String):String

Reads a multibyte string of specified length from the byte stream using the specified character set.

Parameters
length:uint — The number of bytes from the byte stream to read.
charSet:String — The string denoting the character set to use to interpret the bytes. Possible character set strings include "shift_jis", "CN-GB", "iso-8859-1", and others. For a complete list, see Supported Character Sets.

Returns
String — UTF-8 encoded string.

Throws
EOFError — There is insufficient data available to read.
readObject () method
public function readObject():*

Reads an object from the socket, encoded in Action Message Format (AMF).

Returns
* — The deserialized object.

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.

See also

ObjectEncoding
readShort () method
public function readShort():int

Reads a signed 16-bit integer from the stream.

The returned value is in the range -32768...32767.

Returns
int

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readUnsignedByte () method
public function readUnsignedByte():uint

Reads an unsigned byte from the stream.

The returned value is in the range 0...255.

Returns
uint

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readUnsignedInt () method
public function readUnsignedInt():uint

Reads an unsigned 32-bit integer from the stream.

The returned value is in the range 0...4294967295.

Returns
uint

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readUnsignedShort () method
public function readUnsignedShort():uint

Reads an unsigned 16-bit integer from the stream.

The returned value is in the range 0...65535.

Returns
uint

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readUTF () method
public function readUTF():String

Reads a UTF-8 string from the stream. The string is assumed to be prefixed with an unsigned short indicating the length in bytes.

Returns
String

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
readUTFBytes () method
public function readUTFBytes(length:uint):String

Reads a sequence of length UTF-8 bytes from the stream, and returns a string.

Parameters
length:uint — A sequence of UTF-8 bytes.

Returns
String

Throws
EOFError — There is insufficient data available to read. If a local SWF file triggers a security warning, Flash Player prevents the URLStream data from being available to ActionScript. When this happens, the bytesAvailable property returns 0 even if data has been received, and any of the read methods throws an EOFError exception.
IOError — An I/O error occurred on the stream, or the stream is not open.
Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched when data has loaded successfully.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
httpStatus event
Event object type: flash.events.HTTPStatusEvent
HTTPStatusEvent.type property = flash.events.HTTPStatusEvent.HTTP_STATUS

Dispatched if a call to URLStream.load() attempts to access data over HTTP, and the current Flash Player is able to detect and return the status code for the request. (Some browser environments may not be able to provide this information.) Note that the httpStatus (if any) will be sent before (and in addition to) any complete or error event.

Defines the value of the type property of a httpStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
status | The HTTP status code returned by the server.
target | The network object receiving an HTTP status code.

See also

URLStream.load()
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input/output error occurs that causes a load operation to fail.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.

See also

URLStream.load()
open event
Event object type: flash.events.Event
Event.type property = flash.events.Event.OPEN

Dispatched when a load operation starts.

Defines the value of the type property of an open event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has opened a connection.

See also

URLStream.load()
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched when data is received as the download operation progresses. Data that has been received can be read immediately using the methods of the URLStream class.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.

See also

URLStream.load()
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched if a call to URLStream.load() attempts to load data from a server outside the security sandbox.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

URLStream.load()
Flash Player Security
Examples

The following example loads a SWF file and parses the beginning of its header to indicate compression and version number information.

To run the example, place a file named URLStreamExample.swf in the same directory as your SWF file.

package {
    import flash.display.Sprite;
    import flash.errors.*;
    import flash.events.*;
    import flash.net.URLRequest;
    import flash.net.URLStream;

    public class URLStreamExample extends Sprite {
        private static const ZLIB_CODE:String = "CWS";
        private var stream:URLStream;

        public function URLStreamExample() {
            stream = new URLStream();
            var request:URLRequest = new URLRequest("URLStreamExample.swf");
            configureListeners(stream);
            try {
                stream.load(request);
            } catch (error:Error) {
                trace("Unable to load requested URL.");
            }
        }

        private function configureListeners(dispatcher:EventDispatcher):void {
            dispatcher.addEventListener(Event.COMPLETE, completeHandler);
            dispatcher.addEventListener(HTTPStatusEvent.HTTP_STATUS, httpStatusHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(Event.OPEN, openHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
        }

        private function parseHeader():void {
            trace("parseHeader");
            trace("isCompressed: " + isCompressed());
            trace("version: " + stream.readByte());
        }

        private function isCompressed():Boolean {
            return (stream.readUTFBytes(3) == ZLIB_CODE);
        }

        private function completeHandler(event:Event):void {
            trace("completeHandler: " + event);
            parseHeader();
        }

        private function openHandler(event:Event):void {
            trace("openHandler: " + event);
        }

        private function progressHandler(event:Event):void {
            trace("progressHandler: " + event);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }

        private function httpStatusHandler(event:HTTPStatusEvent):void {
            trace("httpStatusHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }
    }
}


flash.net.URLVariables (Flex™ 2 Language Reference)

Class URLVariables | Properties | Methods | Examples
Package | flash.net
Class | public dynamic class URLVariables
Inheritance | URLVariables Inheritance Object

The URLVariables class allows you to transfer variables between a Flash® application and a server. Use URLVariables objects with methods of the URLLoader class, with the data property of the URLRequest class, and with flash.net package functions.

View the examples.

See also

URLLoader
Working with external data

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | URLVariables(source:String = null) Creates a new URLVariables object. | URLVariables
 | decode(source:String):void Converts the variable string to properties of the specified URLVariables object. | URLVariables
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string containing all enumerable variables, in the MIME content encoding application/x-www-form-urlencoded. | URLVariables
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
URLVariables () constructor
public function URLVariables(source:String = null)

Creates a new URLVariables object. You pass URLVariables objects to the data property of URLRequest objects.

If you call the URLVariables constructor with a string, the decode() method is automatically called to convert the string to properties of the URLVariables object.

Parameters
source:String (default = null) — A URL-encoded string containing name/value pairs.
Method detail
decode () method
public function decode(source:String):void

Converts the variable string to properties of the specified URLVariables object.

This method is used internally by the URLVariables events. Most users do not need to call this method directly.

Parameters
source:String — A URL-encoded query string containing name/value pairs.

Throws
Error — The source parameter must be a URL-encoded query string containing name/value pairs.

See also

Working with external data
toString () method
public function toString():String

Returns a string containing all enumerable variables, in the MIME content encoding application/x-www-form-urlencoded.

Returns
String — A URL-encoded string containing name/value pairs.
Examples

The following example opens the remote application hosted at http://www.[yourDomain].com/application.jsp in a new browser window and passes data about a user session, captured in a URLVariables object, to the application.

Highlights of the example follow:

  1. The constructor function creates a URLRequest instance named request, taking the URL of the remote application as a parameter.
  2. A URLVariables object is created and two of its properties are assigned values.
  3. The URLVariables object is assigned to the data property of the URLRequest object.
  4. The example calls navigateToURL, which opens a new browser window to the remote application's URL.

Note: To run the example, the remote application URL in the example must be replaced with a working URL. Additionally, you would need server code to process the information captured by Flash Player in the URLVariables object.

package {
    import flash.display.Sprite;
    import flash.net.navigateToURL;
    import flash.net.URLRequest;
    import flash.net.URLVariables;

    public class URLVariablesExample extends Sprite {

        public function URLVariablesExample() {
            var url:String = "http://www.[yourDomain].com/application.jsp";
            var request:URLRequest = new URLRequest(url);
            var variables:URLVariables = new URLVariables();
            variables.exampleSessionId = new Date().getTime();
            variables.exampleUserLabel = "guest";
            request.data = variables;
            navigateToURL(request);
        }
    }
}


flash.net.XMLSocket (Flex™ 2 Language Reference)

Class XMLSocket | Properties | Methods | Events | Examples
Package | flash.net
Class | public class XMLSocket
Inheritance | XMLSocket Inheritance EventDispatcher Inheritance Object

The XMLSocket class implements client sockets that let the computer that is running Flash Player communicate with a server computer identified by an IP address or domain name. The XMLSocket class is useful for client-server applications that require low latency, such as real-time chat systems. A traditional HTTP-based chat solution frequently polls the server and downloads new messages using an HTTP request. In contrast, an XMLSocket chat solution maintains an open connection to the server, which lets the server immediately send incoming messages without a request from the client. To use the XMLSocket class, the server computer must run a daemon that understands the protocol used by the XMLSocket class. The protocol is described in the following list:
  • XML messages are sent over a full-duplex TCP/IP stream socket connection.
  • Each XML message is a complete XML document, terminated by a zero (0) byte.
  • An unlimited number of XML messages can be sent and received over a single XMLSocket connection.

The XMLSocket.connect() method can connect only to TCP port numbers greater than or equal to 1024. One consequence of this restriction is that the server daemons that communicate with the XMLSocket object must also be assigned to port numbers greater than or equal to 1024. Port numbers below 1024 are often used by system services such as FTP, Telnet, and HTTP, so XMLSocket objects are barred from these ports for security reasons. The port number restriction limits the possibility that these resources will be inappropriately accessed and abused.

Setting up a server to communicate with the XMLSocket object can be challenging. If your application does not require real-time interactivity, use the URLLoader class instead of the XMLSocket class. To use the methods of the XMLSocket class, you must first use the constructor, new XMLSocket, to create an XMLSocket object.

When you use this class, consider the Flash Player security model:

  • Sending or receiving data is not allowed if the calling SWF file is in the local-with-file-system sandbox and the target resource is from a network sandbox.
  • Sending or receiving data is also not allowed if the calling SWF file is from a network sandbox and the target resource is local.
  • The calling SWF file and the network resource being accessed must be in exactly the same domain. For example, a SWF file at www.adobe.com can send or receive data only from sources that are also at www.adobe.com.
  • Websites can permit cross-domain access to a resource through a cross-domain policy file.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper

View the examples.

See also

flash.net.URLLoader.load()
flash.net.URLLoader
Socket connections

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | connected : Boolean [read-only] Indicates whether this XMLSocket object is currently connected. | XMLSocket
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
XMLSocket(host:String = null, port:int = 0)
Creates a new XMLSocket object.
XMLSocket
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
close():void
Closes the connection specified by the XMLSocket object.
XMLSocket
connect(host:String, port:int):void
Establishes a connection to the specified Internet host using the specified TCP port.
XMLSocket
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(object:*):void
Converts the XML object or data specified in the object parameter to a string and transmits it to the server, followed by a zero (0) byte.
XMLSocket
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | close | Dispatched when the server closes the socket connection. | XMLSocket
 | connect | Dispatched after a successful call to the XMLSocket.connect() method. | XMLSocket
 | data | Dispatched after raw data is sent or received. | XMLSocket
 | ioError | Dispatched when an input/output error occurs that causes a send or receive operation to fail. | XMLSocket
 | securityError | Dispatched if a call to the XMLSocket.connect() method attempts to connect either to a server outside the caller's security sandbox or to a port lower than 1024. | XMLSocket
Property detail
connected property
connected:Boolean [read-only]

Indicates whether this XMLSocket object is currently connected. You can also check whether the connection succeeded by registering for the connect event and ioError event.

Implementation
    public function get connected():Boolean

See also

connect
ioError
Constructor detail
XMLSocket () constructor
public function XMLSocket(host:String = null, port:int = 0)

Creates a new XMLSocket object. The XMLSocket object is not initially connected to any server. You must call the XMLSocket.connect() method to connect the object to a server.

Parameters
host:String (default = null) — A fully qualified DNS domain name or an IP address in the form aaa.bbb.ccc.ddd. You can also specify null to connect to the host server on which the SWF file resides. If the SWF file issuing this call is running in a web browser, host must be in the same domain as the SWF file.
port:int (default = 0) — The TCP port number on the host used to establish a connection. The port number must be 1024 or greater, unless a policy file is being used.

See also

connect()
Method detail
close () method
public function close():void

Closes the connection specified by the XMLSocket object. The close event is dispatched only when the server closes the connection; it is not dispatched when you call the close() method.

See also

connect()
Socket connections
connect () method
public function connect(host:String, port:int):void

Establishes a connection to the specified Internet host using the specified TCP port. By default you can only connect to port 1024 or higher, unless you are using a policy file.

If the XMLSocket.connected property is true, the initial stage of the connection process is successful. If the XMLSocket.connected property is false, a connection could not be established.

If you specify null for the host parameter, the host contacted is the one where the SWF file calling XMLSocket.connect() resides. For example, if the SWF file was downloaded from www.adobe.com, specifying null for the host parameter is the same as entering the IP address for www.adobe.com.

In SWF files running in a version of the player earlier than Flash Player 7, host must be in the same superdomain as the SWF file that is issuing this call. For example, a SWF file at www.adobe.com can send or receive variables from a SWF file at store.adobe.com because both files are in the same superdomain of adobe.com.

In SWF files of any version running in Flash Player 7 or later, host must be in exactly the same domain. For example, a SWF file at www.adobe.com that is published for Flash Player 5, but is running in Flash Player 7 or later can send or receive variables only from SWF files that are also at www.adobe.com. If you want to send or receive variables from a different domain, you can place a cross-domain policy file on the server hosting the SWF file that is being accessed.

By default, the value you pass for host must be in exactly the same domain and the value you pass for port must be 1024 or above. For example, a SWF file at www.adobe.com can send or receive variables only from SWF files that are also at www.adobe.com. If you want to connect to a socket on a different host than the one from which the connecting SWF file was served, or if you want to connect to a port lower than 1024 on any host, you must obtain an xmlsocket: policy file from the host to which you are connecting. For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

 Parameters
host:String — A fully qualified DNS domain name or an IP address in the form aaa.bbb.ccc.ddd. You can also specify null to connect to the host server on which the SWF file resides. If the SWF file issuing this call is running in a web browser, host must be in the same domain as the SWF file.
port:int — The TCP port number on the host used to establish a connection. The port number must be 1024 or greater, unless a policy file is being used.

Events
securityError:SecurityErrorEvent — A connect operation attempted to connect to a server outside the caller's security sandbox, and/or to a port lower than 1024. Either problem may be worked around using an XMLSocket policy file on the server.
data:DataEvent — Dispatched when raw data has been received.
connect:Event — Dispatched when network connection has been established.

Throws
SecurityError — Local untrusted SWF files may not communicate with the Internet. This may be worked around by reclassifying this SWF file as local-with-networking or trusted.
SecurityError — You may not specify a socket port higher than 65535.

See also

flash.events.Event.CONNECT
Socket connections
send () method
public function send(object:*):void

Converts the XML object or data specified in the object parameter to a string and transmits it to the server, followed by a zero (0) byte. If object is an XML object, the string is the XML textual representation of the XML object. The send operation is asynchronous; it returns immediately, but the data may be transmitted at a later time. The XMLSocket.send() method does not return a value indicating whether the data was successfully transmitted.

If you do not connect the XMLSocket object to the server using XMLSocket.connect()), the XMLSocket.send() operation fails.

Parameters
object:* — An XML object or other data to transmit to the server.

Throws
IOError — The XMLSocket object is not connected to the server.

See also

connect()
Socket connections
Event detail
close event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CLOSE

Dispatched when the server closes the socket connection. The close event is dispatched only when the server closes the connection; it is not dispatched when you call the XMLSocket.close() method.

Defines the value of the type property of a close event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object whose connection has been closed.
connect event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CONNECT

Dispatched after a successful call to the XMLSocket.connect() method.

Defines the value of the type property of a connect event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Socket or XMLSocket object that has established a network connection.
data event
Event object type: flash.events.DataEvent
DataEvent.type property = flash.events.DataEvent.DATA

Dispatched after raw data is sent or received.

Defines the value of the type property of a data event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
data | The raw data loaded into Flash Player.
target | The XMLSocket object receiving data.
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input/output error occurs that causes a send or receive operation to fail.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched if a call to the XMLSocket.connect() method attempts to connect either to a server outside the caller's security sandbox or to a port lower than 1024.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.

See also

XMLSocket.connect()
Flash Player Security
Examples

The following example uses the class XMLSocketExample class to send data using an XMLSocket and print information during XMLSocket events. This is accomplished using the following steps:
  1. The XMLSocketExample constructor creates a XMLSocket instance named socket and passes socket to ConfigureListeners() (described below) and then calls the connect() method of XMLSocket using the host name "localhost" and port number of 8080.
  2. The configureListeners() method is then called, which adds listeners for each of the supported XMLSocket events:
    • closeHandler(): listens for the close event, which is dispatched after the network connection has been closed.
    • connectHandler(): listens for the connect event, dispatched when the network connection has been established.
    • dataHandler(): listens for the data events, dispatched every time the XMLSocket receives new data.
    • progressHandler(): listens for the progress events, dispatched when a call to send() has been made and while the send is ongoing.
    • securityErrorHandler(): listens for securityError events, which would be dispatched if an attempt was made to access the XMLSocket with the wrong local playback security setting or using a port lower than 1024.
    • ioErrorHandler(): listens for ioError events, which would happen only if an operation to send or receive data failed.

Notes:

  • You will need to compile the SWF file with "Local playback security" set to "Access network only".
  • You will need a server running on [yourDomain] using port 8080 for this example to work.

package {
    import flash.display.Sprite;
    import flash.events.*;
    import flash.net.XMLSocket;

    public class XMLSocketExample extends Sprite {
        private var hostName:String = "localhost";
        private var port:uint = 8080;
        private var socket:XMLSocket;

        public function XMLSocketExample() {
            socket = new XMLSocket();
            configureListeners(socket);
            socket.connect(hostName, port);
        }

        public function send(data:Object):void {
            socket.send(data);
        }

        private function configureListeners(dispatcher:IEventDispatcher):void {
            dispatcher.addEventListener(Event.CLOSE, closeHandler);
            dispatcher.addEventListener(Event.CONNECT, connectHandler);
            dispatcher.addEventListener(DataEvent.DATA, dataHandler);
            dispatcher.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
            dispatcher.addEventListener(ProgressEvent.PROGRESS, progressHandler);
            dispatcher.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
        }

        private function closeHandler(event:Event):void {
            trace("closeHandler: " + event);
        }

        private function connectHandler(event:Event):void {
            trace("connectHandler: " + event);
        }

        private function dataHandler(event:DataEvent):void {
            trace("dataHandler: " + event);
        }

        private function ioErrorHandler(event:IOErrorEvent):void {
            trace("ioErrorHandler: " + event);
        }

        private function progressHandler(event:ProgressEvent):void {
            trace("progressHandler loaded:" + event.bytesLoaded + " total: " + event.bytesTotal);
        }

        private function securityErrorHandler(event:SecurityErrorEvent):void {
            trace("securityErrorHandler: " + event);
        }
    }
}


flash.printing Summary (Flex™ 2 Language Reference)

Package flash.printing | Classes

The flash.printing package contains classes for printing Flash-based content.

Classes
Class | Description
PrintJob | The PrintJob class lets you create content and print it to one or more pages.
PrintJobOptions | The PrintJobOptions class contains properties to use with the options parameter of the PrintJob.addPage() method.
PrintJobOrientation | This class provides values that are used by the PrintJob.orientation property for the image position of a printed page.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.printing.PrintJob (Flex™ 2 Language Reference)

Class PrintJob | Properties | Methods | Examples
Package | flash.printing
Class | public class PrintJob
Inheritance | PrintJob Inheritance EventDispatcher Inheritance Object

The PrintJob class lets you create content and print it to one or more pages. This class lets you render content that is visible, dynamic or off-screen to the user, prompt users with a single Print dialog box, and print an unscaled document with proportions that map to the proportions of the content. This capability is especially useful for rendering and printing dynamic content, such as database content and dynamic text.

Use the PrintJob() constructor to create a print job.

Additionally, with properties populated by PrintJob.start(), your document can read your user's printer settings, such as page height, width, and image orientation, and you can configure your document to format, dynamically, Flash content that is appropriate for the printer settings. The user layout properties populated by PrintJob.start() are read-only and cannot be changed by Flash Player.

Note: ActionScript 3.0 does not restrict a PrintJob object to a single frame (as did previous versions of ActionScript). However, since the operating system displays print status information to the user after the user has clicked the OK button in the Print dialog box, you should call PrintJob.addPage() and PrintJob.send() as soon as possible to send pages to the spooler. A delay reaching the frame containing the PrintJob.send() call will delay the printing process.

Additionally, a 15 second script timeout limit applies to the following intervals:

  • PrintJob.start() and the first PrintJob.addPage()
  • PrintJob.addPage() and the next PrintJob.addPage()
  • The last PrintJob.addPage() and PrintJob.send()

If any of the above intervals span more than 15 seconds, the next call to PrintJob.start() on the PrintJob instance returns false, and the next PrintJob.addPage() on the PrintJob instance causes Flash Player to throw a runtime exception.

View the examples.

See also

What's new for the PrintJob class using ActionScript 3.0

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | orientation : String [read-only] The image orientation for printing. | PrintJob
 | pageHeight : int [read-only] The height of the actual printable area on the page, in points. | PrintJob
 | pageWidth : int [read-only] The width of the actual printable area on the page, in points. | PrintJob
 | paperHeight : int [read-only] The overall paper height, in points. | PrintJob
 | paperWidth : int [read-only] The overall paper width, in points. | PrintJob
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PrintJob()
Creates a PrintJob object that you can use to print one or more pages.
PrintJob
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
addPage(sprite:Sprite, printArea:Rectangle = null, options:PrintJobOptions = null, frameNum:int = 0):void
Sends the specified Sprite object as a single page to the print spooler.
PrintJob
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send():void
Sends spooled pages to the printer after PrintJob.start() and PrintJob.addPage() have been successful.
PrintJob
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
start():Boolean
Displays the operating system's Print dialog box, starts spooling, and sets the PrintJob read-only property values.
PrintJob
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
orientation property
orientation:String [read-only]

The image orientation for printing. This property is a value from the PrintJobOrientation class. This property is available only after a call to the PrintJob.start() method has been made.

Implementation
    public function get orientation():String

See also

PrintJobOrientation class
pageHeight property
pageHeight:int [read-only]

The height of the actual printable area on the page, in points. Any user-set margins are ignored. This property is available only after a call to the PrintJob.start() method has been made.

Implementation
    public function get pageHeight():int

See also

Setting size, scale, and orientation
pageWidth property
pageWidth:int [read-only]

The width of the actual printable area on the page, in points. Any user-set margins are ignored. This property is available only after a call to the PrintJob.start() method has been made.

Implementation
    public function get pageWidth():int

See also

Setting size, scale, and orientation
paperHeight property
paperHeight:int [read-only]

The overall paper height, in points. This property is available only after a call to the PrintJob.start() method has been made.

Implementation
    public function get paperHeight():int
paperWidth property
paperWidth:int [read-only]

The overall paper width, in points. This property is available only after a call to the PrintJob.start() method has been made.

Implementation
    public function get paperWidth():int
Constructor detail
PrintJob () constructor
public function PrintJob()

Creates a PrintJob object that you can use to print one or more pages. After you create a PrintJob object, you need to use (in the following sequence) the PrintJob.start(), PrintJob.addPage(), and then PrintJob.send() methods to send the print job to the printer.

For example, you can replace the [params] placeholder text for the my_pj.addPage() method calls with custom parameters as shown in the following code:

 // create PrintJob object
 var my_pj:PrintJob = new PrintJob();

 // display Print dialog box, but only initiate the print job
 // if start returns successfully.
 if (my_pj.start()) {

    // add specified page to print job
    // repeat once for each page to be printed
    try {
      my_pj.addPage([params]);
    }
    catch(e:Error) {
      // handle error
    }
    try {
      my_pj.addPage([params]);
    }
    catch(e:Error) {
     // handle error
    }

    // send pages from the spooler to the printer, but only if one or more
    // calls to addPage() was successful. You should always check for successful
    // calls to start() and addPage() before calling send().
    my_pj.send();
 }

You cannot create a second PrintJob object while the first one is still active. If you create a second PrintJob object (by calling new PrintJob()) while the first PrintJob object is still active, the second PrintJob object will not be created. So, you may check for the my_pj value before creating a second PrintJob.

Throws
IllegalOperationError — Throws an exception if another PrintJob object is still active.

See also

PrintJob.addPage()
PrintJob.send()
PrintJob.start()
Method detail
addPage () method
public function addPage(sprite:Sprite, printArea:Rectangle = null, options:PrintJobOptions = null, frameNum:int = 0):void

Sends the specified Sprite object as a single page to the print spooler. Before using this method, you must create a PrintJob object and then use PrintJob.start(). Then, after calling PrintJob.addPage() one or more times for a print job, you use PrintJob.send() to send the spooled pages to the printer. In other words, after you create a PrintJob object, use (in the following sequence) PrintJob.start(), PrintJob.addPage(), and then PrintJob.send() to send the print job to the printer. You can use PrintJob.addPage() multiple times after a single call to PrintJob.start() to print several pages at once.

If PrintJob.addPage() causes Flash Player to throw an exception (for example, if you haven't called PrintJob.start() or the user canceled the print job), any subsequent calls to PrintJob.addPage() will fail. However, if previous calls to PrintJob.addPage() were successful, the concluding PrintJob.send() command sends the successfully spooled pages to the printer.

If the print job takes more than 15 seconds to complete a PrintJob.addPage() operation, Flash Player will throw an exception on the next Print.addPage() call.

If you pass a value for the printArea parameter, the x and y coordinates of the printArea object map to the upper-left corner (0,0 coordinates) of the printable area on the page. The printable area is described by the read-only pageHeight and pageWidth properties set by PrintJob.start(). Because the printout aligns with the upper-left corner of the printable area on the page, when the area defined in printArea is bigger than the printable area on the page, the printout is cropped to the right or bottom (or both) of the area defined by printArea. If you don't pass a value for printArea and the Stage is larger than the printable area, the same type of clipping occurs. If you don't pass a value for printArea and the screen is larger than the printable area, the same type of clipping takes place.

If you want to scale a Sprite object before you print it, set scale properties (see flash.display.DisplayObject.scaleX and flash.display.DisplayObject.scaleY) before calling this method, and set them back to their original values after printing. The scale of a Sprite object has no relation to printArea. That is, if you specify a print area that is 50 x 50 pixels, 2500 pixels are printed. If you scale the Sprite object, the same 2500 pixels are printed, but the Sprite object is printed at the scaled size.

The Flash Player printing feature supports PostScript and non-PostScript printers. Non-PostScript printers convert vectors to bitmaps.

Parameters
sprite:Sprite — The instance name of the Sprite to print.
printArea:Rectangle (default = null) — A Rectangle object that specifies the area to print.

A rectangle's width and height are pixel values. A printer uses points as print units of measurement. Points are a fixed physical size (1/72 inch), but the size of a pixel, onscreen, depends on the resolution of the particular screen. So, the conversion rate between pixels and points depends on the printer settings and whether the sprite is scaled. An unscaled sprite that is 72 pixels wide will print out one inch wide, with one point equal to one pixel, independent of screen resolution.

You can use the following equivalencies to convert inches or centimeters to twips or points (a twip is 1/20 of a point):

  • 1 point = 1/72 inch = 20 twips
  • 1 inch = 72 points = 1440 twips
  • 1 cm = 567 twips

If you omit the printArea parameter, or if it is passed incorrectly, the full area of sprite is printed.

If you don't want to specify a value for printArea but want to specify a value for options or frameNum, pass null for printArea.
options:PrintJobOptions (default = null) — An optional parameter that specifies whether to print as vector or bitmap. The default value is null, which represents a request for vector printing. To print sprite as a bitmap, set the printAsBitmap property of the PrintJobOptions object to true. Remember the following suggestions when determining whether to set printAsBitmap to true:
  • If the content that you're printing includes a bitmap image, set printAsBitmap to true to include any alpha transparency and color effects.
  • If the content does not include bitmap images, omit this parameter to print the content in higher quality vector format.

If options is omitted or is passed incorrectly, vector printing is used. If you don't want to specify a value for options but want to specify a value for frameNumber, pass null for options.
frameNum:int (default = 0) — An optional number that lets you specify which frame to print; passing a frameNum does not cause the ActionScript on that frame to be invoked. If you omit this parameter, the current frame in sprite is printed. An optional number that is used in the Flash authoring environment. When writing Flex applications, you should omit this parameter or pass a value of 0.

Note: If you previously used print(), printAsBitmap(), printAsBitmapNum(), or printNum() to print from Flash, you might have used a #p frame label on multiple frames to specify which pages to print. To use PrintJob.addPage() to print multiple frames, you must use a PrintJob.addPage() method for each frame; #p frame labels are ignored. For one way to do this programmatically, see the Example section.

Throws
Error — Throws an exception if you haven't called PrintJob.start() or the user canceled the print job

See also

PrintJob.send()
PrintJob.start()
DisplayObject class
What's new for the PrintJob class using ActionScript 3.0
Printing a page
Setting size, scale, and orientation
send () method
public function send():void

Sends spooled pages to the printer after PrintJob.start() and PrintJob.addPage() have been successful. Calls to PrintJob.send() will not be successful if the call to PrintJob.start() fails, or PrintJob.addpage() throws an exception. So, you should check for PrintJob.start() to return true, and catch any PrintJob.addpage() exceptions before calling PrintJob.send(). For example:

  var my_pj:PrintJob = new PrintJob();
    if (my_pj.start()) {
    try {
      my_pj.addPage([params]);
   }
    catch(e:Error) {
      // handle error
   }
      my_pj.send();
  }

See also

PrintJob.addPage()
PrintJob.start()
Printing a page
start () method
public function start():Boolean

Displays the operating system's Print dialog box, starts spooling, and sets the PrintJob read-only property values. The Print dialog box lets the user change print settings. When the PrintJob.start() method returns successfully (the user clicks OK in the Print dialog box), the following read-only properties are populated, representing the user's current print settings:

Property | Type | Units | Notes
PrintJob.paperHeight | Number | Points | Overall paper height.
PrintJob.paperWidth | Number | Points | Overall paper width.
PrintJob.pageHeight | Number | Points | Height of actual printable area on the page; any user-set margins are ignored.
PrintJob.pageWidth | Number | Points | Width of actual printable area on the page; any user-set margins are ignored.
PrintJob.orientation | String |  | "portrait" (flash.printing.PrintJobOrientation.PORTRAIT) or "landscape" (flash.printing.PrintJobOrientation.LANDSCAPE).

Note: If the user cancels the Print dialog box, the properties are not populated.

After the user clicks OK in the Print dialog box, the player begins spooling a print job to the operating system. Because the operating system then begins displaying information to the user about the printing progress, you should call the PrintJob.addPage() and PrintJob.send() calls as soon as possible to send pages to the spooler. You can use the read-only height, width, and orientation properties this method populates to format the printout.

Test to see if this method returns true (when the user clicks OK in the operating system's Print dialog box) before any subsequent calls to PrintJob.addPage() and PrintJob.send():

  var my_pj:PrintJob = new PrintJob();
     if(my_pj.start()) {
       // addPage() and send() statements here
     }

For the given print job instance, if any of the following intervals last more than 15 seconds the next call to PrintJob.start() will return false:

  • PrintJob.start() and the first PrintJob.addPage()
  • One PrintJob.addPage() and the next PrintJob.addPage()
  • The last PrintJob.addPage() and PrintJob.send()

Returns
Boolean — A value of true if the user clicks OK when the Print dialog box appears; false if the user clicks Cancel or if an error occurs.

See also

PrintJob.addPage()
PrintJob.send()
What's new for the PrintJob class using ActionScript 3.0
Printing a page
Examples

The following example uses the class PrintJobExample to create a small document and then send the document to the printer. This is accomplished using the following steps:
  1. Declare two variables of type Sprite named sheet1 and sheet2.
  2. Call init(), which assigns a new Sprite instance to both sheet1 and sheet2 and then calls createSheet() using different arguments.
  3. createSheet() does the following:
    1. The Sprite object passed in is used to draw a rectangle with a light-gray background, a one-pixel black border, and that is 100 pixels wide by 200 pixels high at x = 0, y = 0.
    2. A new TextField object is created named txt with the same dimensions as the Sprite, the wordWrap property set to true, and the text property set to the String passed as an argument to createSheet().
    3. If the Object argument passed is not null, create a new Sprite instance named img that is used to draw a white rectangle using the coordinate and dimension properties of the Object passed. The white rectangle is added to the display list of the Sprite object using addChild().
    4. The txt TextField is added to the display list of the Sprite object using addChild().
  4. Back in the constructor, the print method that is enabled (not commented out) is called. Since the methods are very similar, printOnePerPage() is described below.
  5. printOnePerPage() does the following:
    1. Declare a new PrintJob object named pj and pagesToPrint as a uint.
    2. Open the operating system's native print dialog box and wait for user to click OK.
    3. Check the orientation and if Landscape is selected, throw an error and exit.
    4. Set up the page height and width for sheet1 and sheet2.
    5. Send sheet1 and sheet2 to the print spooler using addPage().
    6. If the number of pages to print is > 0, print all spooled pages.
  6. The draw() method is called, which re-sizes the two Sprite properties to fit on the stage and re-positions sheet2 such that it is just right of sheet1.

Note: the constructor is set up such that one of three printing methods (one sheet per page, two sheets per page, or printing on the top half of the page) can be selected, based on preference. This example will not work correctly unless exactly two of the print methods are disabled using code comments. The example is set up such that printOnePerPage() will be called.

package {
    import flash.printing.PrintJob;
    import flash.printing.PrintJobOrientation;
    import flash.display.Stage;
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.geom.Rectangle;

    public class PrintJobExample extends Sprite {
        private var sheet1:Sprite;
        private var sheet2:Sprite;

        public function PrintJobExample() {
            init();
            printOnePerPage();
//            printTwoPerPage();
//            printTopHalf();
            draw();
        }

        private function init():void {
            sheet1 = new Sprite();
            createSheet(sheet1, "Once upon a time...", {x:10, y:50, width:80, height:130});

            sheet2 = new Sprite();
            createSheet(sheet2, "There was a great story to tell, and it ended quickly.\n\nThe end.", null);
        }

        private function createSheet(sheet:Sprite, str:String, imgValue:Object):void {
            sheet.graphics.beginFill(0xEEEEEE);
            sheet.graphics.lineStyle(1, 0x000000);
            sheet.graphics.drawRect(0, 0, 100, 200);
            sheet.graphics.endFill();

            var txt:TextField = new TextField();
            txt.height = 200;
            txt.width = 100;
            txt.wordWrap = true;
            txt.text = str;

            if(imgValue != null) {
                var img:Sprite = new Sprite();
                img.graphics.beginFill(0xFFFFFF);
                img.graphics.drawRect(imgValue.x, imgValue.y, imgValue.width, imgValue.height);
                img.graphics.endFill();
                sheet.addChild(img);
            }
            sheet.addChild(txt);
        }

        private function printOnePerPage():void {
            var pj:PrintJob = new PrintJob();
            var pagesToPrint:uint = 0;
            if(pj.start()) {
                if(pj.orientation == PrintJobOrientation.LANDSCAPE) {
                    throw new Error("Without embedding fonts you must print one sheet per page with an orientation of portrait.");
                }

                sheet1.height = pj.pageHeight;
                sheet1.width = pj.pageWidth;
                sheet2.height = pj.pageHeight;
                sheet2.width = pj.pageWidth;

                try {
                    pj.addPage(sheet1);
                    pagesToPrint++;
                }
                catch(e:Error) {
                    // do nothing
                }

                try {
                    pj.addPage(sheet2);
                    pagesToPrint++;
                }
                catch(e:Error) {
                    // do nothing
                }

                if(pagesToPrint > 0) {
                    pj.send();
                }
            }
        }

        private function printTwoPerPage():void {
            var pj:PrintJob = new PrintJob();
            var pagesToPrint:uint = 0;
            if(pj.start()) {
                if(pj.orientation == PrintJobOrientation.PORTRAIT) {
                    throw new Error("Without embedding fonts you must print two sheets per page with an orientation of landscape.");
                }

                sheet1.height = pj.pageHeight;
                sheet1.width = pj.pageWidth/2;
                sheet2.height = pj.pageHeight;
                sheet2.width = pj.pageWidth/2;

                var sheets:Sprite = new Sprite();
                sheets.addChild(sheet1);
                sheets.addChild(sheet2);
                sheets.getChildAt(1).x = sheets.getChildAt(0).width;
                try {
                    pj.addPage(sheets);
                    pagesToPrint++;
                }
                catch(e:Error) {
                    // do nothing
                }

                if(pagesToPrint > 0) {
                    pj.send();
                }
            }
        }

        private function printTopHalf():void {
            var pj:PrintJob = new PrintJob();
            var pagesToPrint:uint = 0;
            if(pj.start()) {
                if(pj.orientation == PrintJobOrientation.PORTRAIT) {
                    throw new Error("Without embedding fonts you must print the top half with an orientation of landscape.");
                }

                sheet1.height = pj.pageHeight;
                sheet1.width = pj.pageWidth/2;
                sheet2.height = pj.pageHeight;
                sheet2.width = pj.pageWidth/2;

                var sheets:Sprite = new Sprite();
                sheets.addChild(sheet1);
                sheets.addChild(sheet2);
                sheets.getChildAt(1).x = sheets.getChildAt(0).width;
                try {
                    pj.addPage(sheets, new Rectangle(0, 0, sheets.width, sheets.height/2));
                    pagesToPrint++;
                }
                catch(e:Error) {
                    // do nothing
                }

                if(pagesToPrint > 0) {
                    pj.send();
                }
            }
        }

        private function draw():void {
            var sheetWidth:Number = this.stage.stageWidth/2;
            var sheetHeight:Number = this.stage.stageHeight;

            addChild(sheet1);
            sheet1.width = sheetWidth;
            sheet1.height = sheetHeight;

            addChild(sheet2);
            sheet2.width = sheetWidth;
            sheet2.height = sheetHeight;
            sheet2.x = sheet1.width;
        }
    }
}


flash.printing.PrintJobOptions (Flex™ 2 Language Reference)

Class PrintJobOptions | Properties | Methods
Package | flash.printing
Class | public class PrintJobOptions
Inheritance | PrintJobOptions Inheritance Object

The PrintJobOptions class contains properties to use with the options parameter of the PrintJob.addPage() method. For more information about addPage(), see the PrintJob class.

See also

PrintJob
PrintJob.addPage()
Flash Player tasks and system printing

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | printAsBitmap : Boolean = false Specifies whether the content in the print job is printed as a bitmap or as a vector. | PrintJobOptions
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | PrintJobOptions(printAsBitmap:Boolean = false) Creates a new PrintJobOptions object. | PrintJobOptions
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
printAsBitmap property
public var printAsBitmap:Boolean = false

Specifies whether the content in the print job is printed as a bitmap or as a vector. The default value is false, for vector printing.

If the content that you're printing includes a bitmap image, set printAsBitmap to true to include any alpha transparency and color effects. If the content does not include bitmap images, you should print the content in higher quality vector format (the default option).

For example, to print your content as a bitmap, use the following syntax:

         var options:PrintJobOptions = new PrintJobOptions();
         myOption.printAsBitmap = true;
         myPrintJob.addPage(mySprite, null, myOption);
Constructor detail
PrintJobOptions () constructor
public function PrintJobOptions(printAsBitmap:Boolean = false)

Creates a new PrintJobOptions object. You pass this object to the options parameter of the PrintJob.addPage() method.

Parameters
printAsBitmap:Boolean (default = false) — If true, this object is printed as a bitmap. If false, this object is printed as a vector.

If the content that you're printing includes a bitmap image, set the printAsBitmap property to true to include any alpha transparency and color effects. If the content does not include bitmap images, omit this parameter to print the content in higher quality vector format (the default option).

See also

PrintJob.addPage()


flash.printing.PrintJobOrientation (Flex™ 2 Language Reference)

Class PrintJobOrientation | Properties | Methods | Constants
Package | flash.printing
Class | public final class PrintJobOrientation
Inheritance | PrintJobOrientation Inheritance Object

This class provides values that are used by the PrintJob.orientation property for the image position of a printed page.

See also

PrintJob.orientation
Setting size, scale, and orientation

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | LANDSCAPE : String = "landscape" [static] The landscape (horizontal) image orientation for printing. | PrintJobOrientation
 | PORTRAIT : String = "portrait" [static] The portrait (vertical) image orientation for printing. | PrintJobOrientation
Constant detail
LANDSCAPE constant
public static const LANDSCAPE:String = "landscape"

The landscape (horizontal) image orientation for printing. This constant is used with the PrintJob.orientation property. Use the syntax PrintJobOrientation.LANDSCAPE.

See also

PrintJob.orientation
PORTRAIT
PORTRAIT constant
public static const PORTRAIT:String = "portrait"

The portrait (vertical) image orientation for printing. This constant is used with the PrintJob.orientation property. Use the syntax PrintJobOrientation.PORTRAIT.

See also

PrintJob.orientation
LANDSCAPE


flash.profiler Summary (Flex™ 2 Language Reference)

Package flash.profiler | Functions

The flash.profiler package contains functions used for debugging and profiling ActionScript code.

Functions
Function | Description
showRedrawRegions | Shows or hides redraw regions.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.profiler Details (Flex™ 2 Language Reference)

Package flash.profiler | Functions

These functions can be used for debugging and profiling ActionScript code.
Public Functions
Function |  | Defined by
 | showRedrawRegions(on:Boolean, color:uint = 0xFF0000):void Shows or hides redraw regions. | flash.profiler
Function detail
showRedrawRegions () function
public function showRedrawRegions(on:Boolean, color:uint = 0xFF0000):void

Shows or hides redraw regions. Enables the debugger version of Flash® Player to outline the regions of the screen that are being redrawn (that is regions that are being updated).

Parameters
on:Boolean — Specifies whether to show or hide redraw regions. When set to true, the redraw rectangles are shown. When set to false, the redraw rectangles are hidden.
color:uint (default = 0xFF0000) — Sets the color of the rectangles. If you do not specify this parameter, 0xFF0000 is used.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.system Summary (Flex™ 2 Language Reference)

Package flash.system | Functions | Classes

The flash.system package contains classes for accessing system-level functionality, such as security, garbage collection, etc.

Functions
Function | Description
fscommand | Lets the SWF file communicate with either Flash Player or the program hosting Flash Player, such as a web browser.
Classes
Class | Description
ApplicationDomain | The ApplicationDomain class is a container for discrete groups of class definitions.
Capabilities | The Capabilities class provides properties that describe the system and player that are hosting a SWF file.
IME | The IME class lets you directly manipulate the operating system's input method editor (IME) in the Flash Player application that is running on a client computer.
IMEConversionMode | This class contains constants for use with the IME.conversionMode property.
LoaderContext | The LoaderContext class provides options for loading SWF files and other media by using the Loader class.
Security | The Security class lets you specify how SWF files in different domains can communicate with each other.
SecurityDomain | The SecurityDomain class represents the current security "sandbox," also known as a security domain.
SecurityPanel | The SecurityPanel class provides values for specifying which Security Settings panel you want to display.
System | The System class contains properties related to certain operations that take place on the user's computer, such as operations with shared objects, local settings for cameras and microphones, and use of the Clipboard.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.system Details (Flex™ 2 Language Reference)

Package flash.system | Functions

The flash.system package contains one package-level function, fscommand(), which facilitates communication between a SWF file and its container.
Public Functions
Function |  | Defined by
 | fscommand(command:String, args:String = ""):void Lets the SWF file communicate with either Flash Player or the program hosting Flash Player, such as a web browser. | flash.system
Function detail
fscommand () function
public function fscommand(command:String, args:String = ""):void

Lets the SWF file communicate with either Flash Player or the program hosting Flash Player, such as a web browser. You can also use the fscommand() function to pass messages to Director or to Visual Basic, Visual C++, and other programs that can host ActiveX controls.

The fscommand() function lets a SWF file communicate with a script in a web page. However, script access is controlled by the web page's allowScriptAccess setting. (You set this attribute in the HTML code that embeds the SWF file—for example, in the PARAM tag for Internet Explorer or the EMBED tag for Netscape.) When allowScriptAccess is set to "never", a SWF file cannot access web page scripts. With Flash Player 7 and later, when allowScriptAccess is set to "always", a SWF file can always access web page scripts. When allowScriptAccess is set to "sameDomain", scripting is allowed only from SWF files that are in the same domain as the web page; scripting is always allowed with previous versions of Flash Player. If allowScriptAccess is not specified in an HTML page, the attribute is set by default to "sameDomain" for SWF files of version 8 and later, and to "always" for SWF files of version 7 and earlier.

Usage 1: To use fscommand() to send a message to Flash Player, you must use predefined commands and parameters. The following table shows the values that you can specify for the fscommand() function's command and args parameters. These values control SWF files that are playing in Flash Player, including projectors. (A projector is a SWF file saved in a format that can run as a stand-alone application—that is, without Flash Player.)

Command | Parameter (args) | Purpose
quit | None | Closes the projector.
fullscreen | true or false | Specifying true sets Flash Player to full-screen mode. Specifying false returns the player to normal menu view.
allowscale | true or false | Specifying false sets the player so that the SWF file is always drawn at its original size and never scaled. Specifying true forces the SWF file to scale to 100% of the player.
showmenu | true or false | Specifying true enables the full set of context menu items. Specifying false hides all of the context menu items except About Flash Player and Settings.
exec | Path to application | Executes an application from within the projector.
trapallkeys | true or false | Specifying true sends all key events, including accelerator keys, to the onClipEvent(keyDown/keyUp) handler in Flash Player.

Not all of the commands listed in the table are available in all applications:

  • None of the commands are available in web players.
  • All of the commands are available in stand-alone applications, such as projectors.
  • Only allowscale and exec are available in test-movie players.

The exec command can contain only the characters A-Z, a-z, 0-9, period (.), and underscore (_). The exec command runs in the subdirectory fscommand only. In other words, if you use the exec command to call an application, the application must reside in a subdirectory named fscommand. The exec command works only from within a Flash projector file.

Usage 2: To use fscommand() to send a message to a scripting language such as JavaScript in a web browser, you can pass any two parameters in the command and args parameters. These parameters can be strings or expressions, and they are used in a JavaScript function that handles, or catches, the fscommand() function.

In a web browser, fscommand() calls the JavaScript function moviename_DoFScommand, which resides in the web page that contains the SWF file. For moviename, supply the name of the Flash object that you used for the NAME attribute of the EMBED tag or the ID property of the OBJECT tag. If you assign the SWF file the name "myMovie", the JavaScript function myMovie_DoFScommand is called.

In the web page that contains the SWF file, set the allowScriptAccess attribute to allow or deny the SWF file's ability to access the web page. (You set this attribute in the HTML code that embeds the SWF file—for example, in the PARAM tag for Internet Explorer or the EMBED tag for Netscape.) When allowScriptAccess is set to "never", outbound scripting always fails. When allowScriptAccess is set to "always", outbound scripting always succeeds. When it is set to "sameDomain", scripting is allowed only from SWF files that are in the same domain as the web page. If allowScriptAccess is not specified in a web page, it is set by default to "sameDomain" for Flash Player 8, and to "always" for previous versions of Flash Player.

When using this function, consider the Flash Player security model. For Flash Player 9, the fscommand() function is not allowed if the calling SWF file is in the local-with-file-system or local-with-network sandbox and the containing HTML page is in an untrusted sandbox. For more information, see the Flash Player 9 Security white paper at http://www.adobe.com/go/fp9_0_security.

Usage 3: The fscommand() function can send messages to Director (Macromedia Director from Adobe). These messages are interpreted by Lingo (the Director scripting language) as strings, events, or executable Lingo code. If a message is a string or an event, you must write the Lingo code to receive the message from the fscommand() function and carry out an action in Director. For more information, see the Director Support Center at www.adobe.com/support/director/.

Usage 4: In VisualBasic, Visual C++, and other programs that can host ActiveX controls, fscommand() sends a VB event with two strings that can be handled in the environment's programming language. For more information, use the keywords "Flash method" to search the Flash Support Center at www.adobe.com/support/flash/.

Note: If you are publishing for Flash Player 8 or later, the ExternalInterface class provides better functionality for communication between JavaScript and ActionScript (Usage 2) and between ActionScript and VisualBasic, Visual C++, or other programs that can host ActiveX controls (Usage 4). You should continue to use fscommand() for sending messages to Flash Player (Usage 1) and Director (Usage 3).

Parameters
command:String — A string passed to the host application for any use, or a command passed to Flash Player.
args:String (default = "") — A string passed to the host application for any use, or a value passed to Flash Player.

Example
The following example shows how fscommand() can be used to direct Flash Player to go into full screen mode and not allow scaling. An orange box is then added to the stage using draw(). In draw(), a click event listener is added named clickHandler(), which responds to click events by directing Flash Player to exit using another call to fscommand().

Note: this example should be executed in the standalone Flash Player and not within a web browser.

package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.system.fscommand;
    import flash.events.MouseEvent;

    public class FSCommandExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint = 100;

        public function FSCommandExample() {
            fscommand("fullscreen", "true");
            fscommand("allowscale", "false");
            draw();
        }

        private function clickHandler(event:MouseEvent):void {
            fscommand("quit");
            trace("clickHandler");
        }

        private function draw():void {
            var child:Sprite = new Sprite();
            child.graphics.beginFill(bgColor);
            child.graphics.drawRect(0, 0, size, size);
            child.graphics.endFill();
            child.buttonMode = true;
            addEventListener(MouseEvent.CLICK, clickHandler);

            var label:TextField = new TextField();
            label.text = "quit";
            label.selectable = false;
            label.mouseEnabled = false;
            child.addChild(label);

            addChild(child);
        }
    }
}

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.system.ApplicationDomain (Flex™ 2 Language Reference)

Class ApplicationDomain | Properties | Methods | Examples
Package | flash.system
Class | public final class ApplicationDomain
Inheritance | ApplicationDomain Inheritance Object

The ApplicationDomain class is a container for discrete groups of class definitions. Application domains are used to partition classes that are in the same security domain. They allow multiple definitions of the same class to exist and allow children to reuse parent definitions.

Application domains are used when an external SWF file is loaded through the Loader class. All ActionScript 3.0 definitions in the loaded SWF file are stored in the application domain, which is specified by the applicationDomain property of the LoaderContext object that you pass as a context parameter of the Loader object's load() or loadBytes() method. The LoaderInfo object also contains an applicationDomain property, which is read-only.

All code in a SWF file is defined to exist in an application domain. The current application domain is where your main application runs. The system domain contains all application domains, including the current domain, which means that it contains all Flash Player classes.

Every application domain, except the system domain, has an associated parent domain. The parent domain of your main application's application domain is the system domain. Loaded classes are defined only when their parent doesn't already define them. You cannot override a loaded class definition with a newer definition.

For usage examples of application domains, see Programming ActionScript 3.0.

The ApplicationDomain() constructor function allows you to create an ApplicationDomain object.

View the examples.

See also

flash.display.Loader.load()
flash.display.Loader.loadBytes()
flash.display.LoaderInfo
flash.net.URLRequest
flash.system.LoaderContext
ApplicationDomain class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentDomain : ApplicationDomain [static][read-only] Gets the current application domain in which your code is executing. | ApplicationDomain
 | parentDomain : ApplicationDomain [read-only] Gets the parent domain of this application domain. | ApplicationDomain
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ApplicationDomain(parentDomain:ApplicationDomain = null) Creates a new application domain. | ApplicationDomain
 | getDefinition(name:String):Object Gets a public definition from the specified application domain. | ApplicationDomain
 | hasDefinition(name:String):Boolean Checks to see if a public definition exists within the specified application domain. | ApplicationDomain
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
currentDomain property
currentDomain:ApplicationDomain [read-only]

Gets the current application domain in which your code is executing.

Implementation
    public static function get currentDomain():ApplicationDomain

See also

ApplicationDomain class
parentDomain property
parentDomain:ApplicationDomain [read-only]

Gets the parent domain of this application domain.

Implementation
    public function get parentDomain():ApplicationDomain

See also

ApplicationDomain class
Constructor detail
ApplicationDomain () constructor
public function ApplicationDomain(parentDomain:ApplicationDomain = null)

Creates a new application domain.

Parameters
parentDomain:ApplicationDomain (default = null) — If no parent domain is passed in, this application domain takes the system domain as its parent.
Method detail
getDefinition () method
public function getDefinition(name:String):Object

Gets a public definition from the specified application domain. The definition can be that of a class, a namespace, or a function.

Parameters
name:String — The name of the definition.

Returns
Object — The object associated with the definition.

Throws
ReferenceError — No public definition exists with the specified name.
hasDefinition () method
public function hasDefinition(name:String):Boolean

Checks to see if a public definition exists within the specified application domain. The definition can be that of a class, a namespace, or a function.

Parameters
name:String — The name of the definition.

Returns
Boolean — A value of true if the specified definition exists; otherwise, false.
Examples

The following example demonstrates runtime class loading.

Notes:

  • Since the ClassLoader class loads a SWF file, local security needs to be at the file system level.
  • To run this example, you must have a swf file called RuntimeClasses.swf existing in the same folder as the ApplicationDomainExample.swf file.

Begin by creating the RuntimeClasses.swf file from the following code:

   package {
       import flash.display.Sprite;

       public class RuntimeClasses extends Sprite {
           public function RuntimeClasses() {
           }
       }
   }

   import flash.display.Sprite;
   import flash.text.TextField;

   class Greeter {
       private var greeting:String;

       public function Greeter() {
           greeting = "Hello World";
       }

       public function greet():String {
           return greeting;
       }
   }

   class VisualGreeter extends Sprite {
       private var greeting:String;
       private var txt:TextField;

       public function VisualGreeter() {
           greeting = "Hello World";
           txt = new TextField();
           txt.text = greeting;
           txt.background = true;
           txt.backgroundColor = 0xFF0000;
       }

       public function greet():String {
           addChild(txt);
           return txt.text
       }
  }

Then implement the following code:

package {
    import flash.display.DisplayObject;
    import flash.display.Sprite;
    import flash.errors.IllegalOperationError;
    import flash.events.Event;

    public class ApplicationDomainExample extends Sprite {
        private var loader:ClassLoader;

        public function ApplicationDomainExample() {
            loader = new ClassLoader();
            loader.addEventListener(ClassLoader.LOAD_ERROR, loadErrorHandler);
            loader.addEventListener(ClassLoader.CLASS_LOADED, classLoadedHandler);
            loader.load("RuntimeClasses.swf");
        }

        private function loadErrorHandler(e:Event):void {
            throw new IllegalOperationError("Cannot load the specified file.");
        }

        private function classLoadedHandler(e:Event):void {
            var greeterClassRef:Class = loader.getClass("Greeter");
            var greeter:Object = new greeterClassRef();
            trace(greeter.greet()); // Hello World

            greeterClassRef = loader.getClass("VisualGreeter");
            greeter = new greeterClassRef();
            addChild(DisplayObject(greeter));
            greeter.greet();
        }
    }
}

import flash.display.Loader;
import flash.errors.IllegalOperationError;
import flash.events.Event;
import flash.events.EventDispatcher;
import flash.events.IOErrorEvent;
import flash.events.SecurityErrorEvent;
import flash.net.URLRequest;
import flash.system.ApplicationDomain;
import flash.system.LoaderContext;

class ClassLoader extends EventDispatcher {
    public static var CLASS_LOADED:String = "classLoaded";
    public static var LOAD_ERROR:String = "loadError";
    private var loader:Loader;
    private var swfLib:String;
    private var request:URLRequest;
    private var loadedClass:Class;

    public function ClassLoader() {
        loader = new Loader();
        loader.contentLoaderInfo.addEventListener(Event.COMPLETE, completeHandler);
        loader.contentLoaderInfo.addEventListener(IOErrorEvent.IO_ERROR, ioErrorHandler);
        loader.contentLoaderInfo.addEventListener(SecurityErrorEvent.SECURITY_ERROR, securityErrorHandler);
    }

    public function load(lib:String):void {
        swfLib = lib;
        request = new URLRequest(swfLib);
        var context:LoaderContext = new LoaderContext();
        context.applicationDomain = ApplicationDomain.currentDomain;
        loader.load(request, context);
    }

    public function getClass(className:String):Class {
        try {
            return loader.contentLoaderInfo.applicationDomain.getDefinition(className) as Class;
        }
        catch(e:Error) {
            throw new IllegalOperationError(className + " definition not found in " + swfLib);
        }
        return null;
    }

    private function completeHandler(e:Event):void {
        dispatchEvent(new Event(ClassLoader.CLASS_LOADED));
    }

    private function ioErrorHandler(e:Event):void {
        dispatchEvent(new Event(ClassLoader.LOAD_ERROR));
    }

    private function securityErrorHandler(e:Event):void {
        dispatchEvent(new Event(ClassLoader.LOAD_ERROR));
    }
}


flash.system.Capabilities (Flex™ 2 Language Reference)

Class Capabilities | Properties | Methods | Examples
Package | flash.system
Class | public final class Capabilities
Inheritance | Capabilities Inheritance Object

The Capabilities class provides properties that describe the system and player that are hosting a SWF file. For example, a mobile phone's screen might be 100 square pixels, black and white, whereas a PC screen might be 1000 square pixels, color. By using the Capabilities object to determine what type of device a user has, you can provide appropriate content to as many users as possible. When you know the device's capabilities, you can tell the server to send the appropriate SWF files or tell the SWF file to alter its presentation.

You can send a player's capabilities information, which is stored in the Capabilities.serverString property as a URL-encoded string, using the GET or POST HTTP method. The following example shows a server string for a computer that has MP3 support and 1600 x 1200 pixel resolution and that is running Windows XP with an input method editor (IME) installed:

A=t&SA=t&SV=t&EV=t&MP3=t&AE=t&VE=t&ACC=f&PR=t&SP=t&
     SB=f&DEB=t&V=WIN%209%2C0%2C0%2C0&M=Adobe%20Windows&
     R=1600x1200&DP=72&COL=color&AR=1.0&OS=Windows%20XP&
     L=en&PT=External&AVD=f&LFD=f&WD=f&IME=t

The following table lists the possible ActionScript properties and corresponding server strings:

ActionScript property | Server string
avHardwareDisable | AVD
hasAccessibility | ACC
hasAudio | A
hasAudioEncoder | AE
hasEmbeddedVideo | EV
hasIME | IME
hasMP3 | MP3
hasPrinting | PR
hasScreenBroadcast | SB
hasScreenPlayback | SP
hasStreamingAudio | SA
hasStreamingVideo | SV
hasTLS | TLS
hasVideoEncoder | VE
isDebugger | DEB
language | L
localFileReadDisable | LFD
manufacturer | M
os | OS
pixelAspectRatio | AR
playerType | PT
screenColor | COL
screenDPI | DP
screenResolutionX | R
screenResolutionY | R
version | V

All properties of the Capabilities class are read-only.

View the examples.

See also

Determining Flash Player version in Flex
Capabilities class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | avHardwareDisable : Boolean [static][read-only] Specifies whether access to the user's camera and microphone has been administratively prohibited (true) or allowed (false). | Capabilities
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | hasAccessibility : Boolean [static][read-only] Specifies whether the player is running in an environment that supports (true) or does not support (false) communication with accessibility aids. | Capabilities
 | hasAudio : Boolean [static][read-only] Specifies whether the player is running on a system that has audio capabilities. | Capabilities
 | hasAudioEncoder : Boolean [static][read-only] Specifies whether the player can (true) or cannot (false) encode an audio stream, such as that coming from a microphone. | Capabilities
 | hasEmbeddedVideo : Boolean [static][read-only] Specifies whether the player is running on a system that supports (true) or does not support (false) embedded video. | Capabilities
 | hasIME : Boolean [static][read-only] Specifies whether the player is running on a system that does (true) or does not (false) have an input method editor (IME) installed. | Capabilities
 | hasMP3 : Boolean [static][read-only] Specifies whether the player is running on a system that does (true) or does not (false) have an MP3 decoder. | Capabilities
 | hasPrinting : Boolean [static][read-only] Specifies whether the player is running on a system that does (true) or does not (false) support printing. | Capabilities
 | hasScreenBroadcast : Boolean [static][read-only] Specifies whether the player does (true) or does not (false) support the development of screen broadcast applications to be run through Flash Media Server. | Capabilities
 | hasScreenPlayback : Boolean [static][read-only] Specifies whether the player does (true) or does not (false) support the playback of screen broadcast applications that are being run through Flash Media Server. | Capabilities
 | hasStreamingAudio : Boolean [static][read-only] Specifies whether the player can (true) or cannot (false) play streaming audio. | Capabilities
 | hasStreamingVideo : Boolean [static][read-only] Specifies whether the player can (true) or cannot (false) play streaming video. | Capabilities
 | hasTLS : Boolean [static][read-only] Specifies whether the player is on a system that supports native SSL sockets through NetConnection (true) or does not (false). | Capabilities
 | hasVideoEncoder : Boolean [static][read-only] Specifies whether the player can (true) or cannot (false) encode a video stream, such as that coming from a web camera. | Capabilities
 | isDebugger : Boolean [static][read-only] Specifies whether the player is a special debugging version (true), or an officially released version (false). | Capabilities
 | language : String [static][read-only] Specifies the language code of the system on which the player is running. | Capabilities
 | localFileReadDisable : Boolean [static][read-only] Specifies whether read access to the user's hard disk has been administratively prohibited (true) or allowed (false). | Capabilities
 | manufacturer : String [static][read-only] Specifies the manufacturer of Flash Player, in the format "Adobe OSName". | Capabilities
 | os : String [static][read-only] Specifies the current operating system. | Capabilities
 | pixelAspectRatio : Number [static][read-only] Specifies the pixel aspect ratio of the screen. | Capabilities
 | playerType : String [static][read-only] Specifies the type of player. | Capabilities
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | screenColor : String [static][read-only] Specifies the screen color. | Capabilities
 | screenDPI : Number [static][read-only] Specifies the dots-per-inch (dpi) resolution of the screen, in pixels. | Capabilities
 | screenResolutionX : Number [static][read-only] Specifies the maximum horizontal resolution of the screen. | Capabilities
 | screenResolutionY : Number [static][read-only] Specifies the maximum vertical resolution of the screen. | Capabilities
 | serverString : String [static][read-only] A URL-encoded string that specifies values for each Capabilities property. | Capabilities
 | version : String [static][read-only] Specifies the Flash Player platform and version information. | Capabilities
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
avHardwareDisable property
avHardwareDisable:Boolean [read-only]

Specifies whether access to the user's camera and microphone has been administratively prohibited (true) or allowed (false). The server string is AVD.

Implementation
    public static function get avHardwareDisable():Boolean

See also

flash.media.Camera.getCamera()
flash.media.Microphone.getMicrophone()
Security.showSettings()
Flash Player Security
hasAccessibility property
hasAccessibility:Boolean [read-only]

Specifies whether the player is running in an environment that supports (true) or does not support (false) communication with accessibility aids. The server string is ACC.

Implementation
    public static function get hasAccessibility():Boolean

See also

flash.accessibility.Accessibility.active
flash.accessibility.Accessibility.updateProperties()
hasAudio property
hasAudio:Boolean [read-only]

Specifies whether the player is running on a system that has audio capabilities. This property is always true. The server string is A.

Implementation
    public static function get hasAudio():Boolean
hasAudioEncoder property
hasAudioEncoder:Boolean [read-only]

Specifies whether the player can (true) or cannot (false) encode an audio stream, such as that coming from a microphone. The server string is AE.

Implementation
    public static function get hasAudioEncoder():Boolean
hasEmbeddedVideo property
hasEmbeddedVideo:Boolean [read-only]

Specifies whether the player is running on a system that supports (true) or does not support (false) embedded video. The server string is EV.

Implementation
    public static function get hasEmbeddedVideo():Boolean
hasIME property
hasIME:Boolean [read-only]

Specifies whether the player is running on a system that does (true) or does not (false) have an input method editor (IME) installed. The server string is IME.

Implementation
    public static function get hasIME():Boolean

See also

flash.system.IME
flash.system.System.ime
IME class
hasMP3 property
hasMP3:Boolean [read-only]

Specifies whether the player is running on a system that does (true) or does not (false) have an MP3 decoder. The server string is MP3.

Implementation
    public static function get hasMP3():Boolean

See also

Capabilities class
hasPrinting property
hasPrinting:Boolean [read-only]

Specifies whether the player is running on a system that does (true) or does not (false) support printing. The server string is PR.

Implementation
    public static function get hasPrinting():Boolean
hasScreenBroadcast property
hasScreenBroadcast:Boolean [read-only]

Specifies whether the player does (true) or does not (false) support the development of screen broadcast applications to be run through Flash Media Server. The server string is SB.

Implementation
    public static function get hasScreenBroadcast():Boolean
hasScreenPlayback property
hasScreenPlayback:Boolean [read-only]

Specifies whether the player does (true) or does not (false) support the playback of screen broadcast applications that are being run through Flash Media Server. The server string is SP.

Implementation
    public static function get hasScreenPlayback():Boolean
hasStreamingAudio property
hasStreamingAudio:Boolean [read-only]

Specifies whether the player can (true) or cannot (false) play streaming audio. The server string is SA.

Implementation
    public static function get hasStreamingAudio():Boolean
hasStreamingVideo property
hasStreamingVideo:Boolean [read-only]

Specifies whether the player can (true) or cannot (false) play streaming video. The server string is SV.

Implementation
    public static function get hasStreamingVideo():Boolean
hasTLS property
hasTLS:Boolean [read-only]

Specifies whether the player is on a system that supports native SSL sockets through NetConnection (true) or does not (false). The server string is TLS.

Implementation
    public static function get hasTLS():Boolean

See also

flash.net.NetConnection.connectedProxyType
flash.net.NetConnection.proxyType
flash.net.NetConnection.usingTLS
hasVideoEncoder property
hasVideoEncoder:Boolean [read-only]

Specifies whether the player can (true) or cannot (false) encode a video stream, such as that coming from a web camera. The server string is VE.

Implementation
    public static function get hasVideoEncoder():Boolean
isDebugger property
isDebugger:Boolean [read-only]

Specifies whether the player is a special debugging version (true), or an officially released version (false). The server string is DEB.

Implementation
    public static function get isDebugger():Boolean
language property
language:String [read-only]

Specifies the language code of the system on which the player is running. The language is specified as a lowercase two-letter language code from ISO 639-1. For Chinese, an additional uppercase two-letter country code from ISO 3166 distinguishes between Simplified and Traditional Chinese. The languages codes are based on the English names of the language: for example, hu specifies Hungarian.

On English systems, this property returns only the language code (en), not the country code. On Microsoft Windows systems, this property returns the user interface (UI) language, which refers to the language used for all menus, dialog boxes, error messages, and help files. The following table lists the possible values:

Language | Value
Czech | cs
Danish | da
Dutch | nl
English | en
Finnish | fi
French | fr
German | de
Hungarian | hu
Italian | it
Japanese | ja
Korean | ko
Norwegian | no
Other/unknown | xu
Polish | pl
Portuguese | pt
Russian | ru
Simplified Chinese | zh-CN
Spanish | es
Swedish | sv
Traditional Chinese | zh-TW
Turkish | tr

The server string is L.

Implementation
    public static function get language():String
localFileReadDisable property
localFileReadDisable:Boolean [read-only]

Specifies whether read access to the user's hard disk has been administratively prohibited (true) or allowed (false). If this property is true, Flash Player cannot read files (including the first SWF file that Flash Player launches with) from the user's hard disk. For example, attempts to read a file on the user's hard disk using load methods will fail if this property is set to true.

Reading runtime shared libraries is also blocked if this property is set to true, but reading local shared objects is allowed without regard to the value of this property. The server string is LFD.

Implementation
    public static function get localFileReadDisable():Boolean

See also

flash.display.Loader
Flash Player Security
manufacturer property
manufacturer:String [read-only]

Specifies the manufacturer of Flash Player, in the format "Adobe OSName". The value for OSName could be "Windows", "Macintosh", "Linux", or another operating system name. The server string is M.

Implementation
    public static function get manufacturer():String
os property
os:String [read-only]

Specifies the current operating system. The os property can return the following strings: "Windows XP", "Windows 2000", "Windows NT", "Windows 98/ME", "Windows 95", "Windows CE" (available only in Flash Player SDK, not in the desktop version), "Linux", and "MacOS". The server string is OS.

Implementation
    public static function get os():String
pixelAspectRatio property
pixelAspectRatio:Number [read-only]

Specifies the pixel aspect ratio of the screen. The server string is AR.

Implementation
    public static function get pixelAspectRatio():Number
playerType property
playerType:String [read-only]

Specifies the type of player. This property can have one of the following values:

  • "StandAlone" for the stand-alone Flash Player
  • "External" for the external Flash Player or in test mode
  • "PlugIn" for the Flash Player browser plug-in
  • "ActiveX" for the Flash Player ActiveX control used by Microsoft Internet Explorer

The server string is PT.

Implementation
    public static function get playerType():String
screenColor property
screenColor:String [read-only]

Specifies the screen color. This property can have the value "color", "gray" (for grayscale), or "bw" (for black and white). The server string is COL.

Implementation
    public static function get screenColor():String
screenDPI property
screenDPI:Number [read-only]

Specifies the dots-per-inch (dpi) resolution of the screen, in pixels. The server string is DP.

Implementation
    public static function get screenDPI():Number
screenResolutionX property
screenResolutionX:Number [read-only]

Specifies the maximum horizontal resolution of the screen. The server string is R (which returns both the width and height of the screen).

Implementation
    public static function get screenResolutionX():Number

See also

Capabilities class
screenResolutionY property
screenResolutionY:Number [read-only]

Specifies the maximum vertical resolution of the screen. The server string is R (which returns both the width and height of the screen).

Implementation
    public static function get screenResolutionY():Number

See also

Capabilities class
serverString property
serverString:String [read-only]

A URL-encoded string that specifies values for each Capabilities property.

The following example shows a URL-encoded string:

A=t&SA=t&SV=t&EV=t&MP3=t&AE=t&VE=t&ACC=f&PR=t&SP=t&
  SB=f&DEB=t&V=WIN%208%2C5%2C0%2C208&M=Adobe%20Windows&
  R=1600x1200&DP=72&COL=color&AR=1.0&OS=Windows%20XP&
  L=en&PT=External&AVD=f&LFD=f&WD=f

Implementation
    public static function get serverString():String

See also

Capabilities class
version property
version:String [read-only]

Specifies the Flash Player platform and version information. The format of the version number is: platform majorVersion, minorVersion, buildNumber, internalBuildNumber. Possible values for platform are "WIN", "MAC", and "UNIX". Here are some examples of version information:

  WIN 9,0,0,0  // Flash Player 9 for Windows
  MAC 7,0,25,0   // Flash Player 7 for Macintosh
  UNIX 5,0,55,0  // Flash Player 5 for UNIX

The server string is V.

Implementation
    public static function get version():String

See also

Capabilities class
Examples

The following example simply outputs the values found in the flash.system.Capabilities object using several calls to trace().

package {
    import flash.display.Sprite;
    import flash.system.Capabilities;

    public class CapabilitiesExample extends Sprite {
        public function CapabilitiesExample() {
            showCapabilities();
        }

        private function showCapabilities():void {
            trace("avHardwareDisable: " + Capabilities.avHardwareDisable);
            trace("hasAccessibility: " + Capabilities.hasAccessibility);
            trace("hasAudio: " + Capabilities.hasAudio);
            trace("hasAudioEncoder: " + Capabilities.hasAudioEncoder);
            trace("hasEmbeddedVideo: " + Capabilities.hasEmbeddedVideo);
            trace("hasMP3: " + Capabilities.hasMP3);
            trace("hasPrinting: " + Capabilities.hasPrinting);
            trace("hasScreenBroadcast: " + Capabilities.hasScreenBroadcast);
            trace("hasScreenPlayback: " + Capabilities.hasScreenPlayback);
            trace("hasStreamingAudio: " + Capabilities.hasStreamingAudio);
            trace("hasVideoEncoder: " + Capabilities.hasVideoEncoder);
            trace("isDebugger: " + Capabilities.isDebugger);
            trace("language: " + Capabilities.language);
            trace("localFileReadDisable: " + Capabilities.localFileReadDisable);
            trace("manufacturer: " + Capabilities.manufacturer);
            trace("os: " + Capabilities.os);
            trace("pixelAspectRatio: " + Capabilities.pixelAspectRatio);
            trace("playerType: " + Capabilities.playerType);
            trace("screenColor: " + Capabilities.screenColor);
            trace("screenDPI: " + Capabilities.screenDPI);
            trace("screenResolutionX: " + Capabilities.screenResolutionX);
            trace("screenResolutionY: " + Capabilities.screenResolutionY);
            trace("serverString: " + Capabilities.serverString);
            trace("version: " + Capabilities.version);
        }
    }
}


flash.system.IME (Flex™ 2 Language Reference)

Class IME | Properties | Methods | Events
Package | flash.system
Class | public final class IME
Inheritance | IME Inheritance EventDispatcher Inheritance Object

The IME class lets you directly manipulate the operating system's input method editor (IME) in the Flash Player application that is running on a client computer. You can determine whether an IME is installed, whether or not the IME is currently enabled, and which IME is enabled. You can disable or enable the IME in the Flash Player application, and you can perform other limited functions, depending on the operating system.

IMEs let users type non-ASCII text characters in multibyte languages such as Chinese, Japanese, and Korean. For more information on working with IMEs, see the documentation for the operating system for which you are developing applications. For additional resources, see the following websites:

  • http://www.microsoft.com/globaldev/default.mspx
  • http://developer.apple.com/documentation/
  • http://java.sun.com

If an IME is not active on the user's computer, calls to IME methods or properties, other than Capabilities.hasIME, will fail. Once you manually activate an IME, subsequent ActionScript calls to IME methods and properties will work as expected. For example, if you are using a Japanese IME, it must be activated before any IME method or property is called.

The following table shows the platform coverage of this class:

Capability Windows Mac OSX Mac Classic
Determine whether the IME is installed
   flash.system.Capabilities.hasIME 		Yes Yes Yes
Set IME on or off
   flash.system.IME.enabled 		Yes Yes Yes
Find out whether IME is on or off
   flash.system.IME.enabled 		Yes Yes Yes
Get or set IME conversion mode
   flash.system.IME.conversionMode 		Yes Yes ** No
Send IME the string to be converted
   flash.system.IME.setCompositionString() 		Yes * No No
Get from IME the original string before conversion
   flash.system.System.ime.addEventListener(flash.events.IMEEvent.IME_COMPOSITION, myHandler)
   flash.system.System.ime.removeEventListener(flash.events.IMEEvent.IME_COMPOSITION, myHandler) 		Yes * No No
Send request to convert to IME
   flash.system.IME.doConversion() 		Yes * No No

* Not all Windows IMEs support all of these operations. The only IME that supports them all is the Japanese IME.

** On the Macintosh, only the Japanese IME supports these methods, and third-party IMEs do not support them.

See also

IME class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | conversionMode : String [static] The conversion mode of the current IME. | IME
 | enabled : Boolean [static] Indicates whether the system IME is enabled (true) or disabled (false). | IME
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
doConversion():void
[static] Instructs the IME to select the first candidate for the current composition string.
IME
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setCompositionString(composition:String):void
[static] Sets the IME composition string.
IME
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | imeComposition | Dispatched when a user has completed an input method editor (IME) composition and the reading string is available. | IME
Property detail
conversionMode property
conversionMode:String [read-write]

The conversion mode of the current IME. Possible values are IME mode string constants that indicate the conversion mode:

  • ALPHANUMERIC_FULL
  • ALPHANUMERIC_HALF
  • CHINESE
  • JAPANESE_HIRAGANA
  • JAPANESE_KATAKANA_FULL
  • JAPANESE_KATAKANA_HALF
  • KOREAN
  • UNKNOWN (read-only value; this value cannot be set)

Implementation
    public static function get conversionMode():String
    public function set conversionMode(value:String):void

Throws
Error — A set attempt was not successful.

See also

flash.system.IMEConversionMode.ALPHANUMERIC_FULL
flash.system.IMEConversionMode.ALPHANUMERIC_HALF
flash.system.IMEConversionMode.CHINESE
flash.system.IMEConversionMode.JAPANESE_HIRAGANA
flash.system.IMEConversionMode.JAPANESE_KATAKANA_FULL
flash.system.IMEConversionMode.JAPANESE_KATAKANA_HALF
flash.system.IMEConversionMode.KOREAN
flash.system.IMEConversionMode.UNKNOWN
IME class
enabled property
enabled:Boolean [read-write]

Indicates whether the system IME is enabled (true) or disabled (false). An enabled IME performs multibyte input; a disabled IME performs alphanumeric input.

Implementation
    public static function get enabled():Boolean
    public function set enabled(value:Boolean):void

Throws
Error — A set attempt was not successful.

See also

IME class
Method detail
doConversion () method
public static function doConversion():void

Instructs the IME to select the first candidate for the current composition string.

Throws
Error — The call was not successful.
setCompositionString () method
public static function setCompositionString(composition:String):void

Sets the IME composition string. When this string is set, the user can select IME candidates before committing the result to the text field that currently has focus.

If no text field has focus, this method fails and throws an error.

Parameters
composition:String — The string to send to the IME.

Throws
Error — The call is not successful.
Event detail
imeComposition event
Event object type: flash.events.IMEEvent
IMEEvent.type property = flash.events.IMEEvent.IME_COMPOSITION

Dispatched when a user has completed an input method editor (IME) composition and the reading string is available. IMEs are generally used to enter text from languages that have ideographs instead of letters, such as Japanese, Chinese and Korean.

Defines the value of the type property of an imeComposition event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The IME object.

See also

IME class


flash.system.IMEConversionMode (Flex™ 2 Language Reference)

Class IMEConversionMode | Properties | Methods | Constants
Package | flash.system
Class | public final class IMEConversionMode
Inheritance | IMEConversionMode Inheritance Object

This class contains constants for use with the IME.conversionMode property. Setting conversionMode to either ALPHANUMERIC_FULL or JAPANESE_KATAKANA_FULL causes the player to use a full width font, whereas using ALPHANUMERIC_HALF or JAPANESE_KATAKANA_HALF uses a half width font.

See also

flash.system.IME.conversionMode

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ALPHANUMERIC_FULL : String = "ALPHANUMERIC_FULL" [static] The string "ALPHANUMERIC_FULL", for use with the IME.conversionMode property. | IMEConversionMode
 | ALPHANUMERIC_HALF : String = "ALPHANUMERIC_HALF" [static] The string "ALPHANUMERIC_HALF", for use with the IME.conversionMode property. | IMEConversionMode
 | CHINESE : String = "CHINESE" [static] The string "CHINESE", for use with the IME.conversionMode property. | IMEConversionMode
 | JAPANESE_HIRAGANA : String = "JAPANESE_HIRAGANA" [static] The string "JAPANESE_HIRAGANA", for use with the IME.conversionMode property. | IMEConversionMode
 | JAPANESE_KATAKANA_FULL : String = "JAPANESE_KATAKANA_FULL" [static] The string "JAPANESE_KATAKANA_FULL", for use with the IME.conversionMode property. | IMEConversionMode
 | JAPANESE_KATAKANA_HALF : String = "JAPANESE_KATAKANA_HALF" [static] The string "JAPANESE_KATAKANA_HALF", for use with the IME.conversionMode property. | IMEConversionMode
 | KOREAN : String = "KOREAN" [static] The string "KOREAN", for use with the IME.conversionMode property. | IMEConversionMode
 | UNKNOWN : String = "UNKNOWN" [static] The string "UNKNOWN", which can be returned by a call to the IME.conversionMode property. | IMEConversionMode
Constant detail
ALPHANUMERIC_FULL constant
public static const ALPHANUMERIC_FULL:String = "ALPHANUMERIC_FULL"

The string "ALPHANUMERIC_FULL", for use with the IME.conversionMode property. This constant is used with all IMEs. Use the syntax IMEConversionMode.ALPHANUMERIC_FULL.

See also

flash.system.IME.conversionMode
IME class
ALPHANUMERIC_HALF constant
public static const ALPHANUMERIC_HALF:String = "ALPHANUMERIC_HALF"

The string "ALPHANUMERIC_HALF", for use with the IME.conversionMode property. This constant is used with all IMEs. Use the syntax IMEConversionMode.ALPHANUMERIC_HALF.

See also

flash.system.IME.conversionMode
IME class
CHINESE constant
public static const CHINESE:String = "CHINESE"

The string "CHINESE", for use with the IME.conversionMode property. This constant is used with simplified and traditional Chinese IMEs. Use the syntax IMEConversionMode.CHINESE.

See also

flash.system.IME.conversionMode
IME class
JAPANESE_HIRAGANA constant
public static const JAPANESE_HIRAGANA:String = "JAPANESE_HIRAGANA"

The string "JAPANESE_HIRAGANA", for use with the IME.conversionMode property. This constant is used with Japanese IMEs. Use the syntax IMEConversionMode.JAPANESE_HIRAGANA.

See also

flash.system.IME.conversionMode
IME class
JAPANESE_KATAKANA_FULL constant
public static const JAPANESE_KATAKANA_FULL:String = "JAPANESE_KATAKANA_FULL"

The string "JAPANESE_KATAKANA_FULL", for use with the IME.conversionMode property. This constant is used with Japanese IMEs. Use the syntax IMEConversionMode.JAPANESE_KATAKANA_FULL.

See also

flash.system.IME.conversionMode
IME class
JAPANESE_KATAKANA_HALF constant
public static const JAPANESE_KATAKANA_HALF:String = "JAPANESE_KATAKANA_HALF"

The string "JAPANESE_KATAKANA_HALF", for use with the IME.conversionMode property. This constant is used with Japanese IMEs. Use the syntax IMEConversionMode.JAPANESE_KATAKANA_HALF.

See also

flash.system.IME.conversionMode
IME class
KOREAN constant
public static const KOREAN:String = "KOREAN"

The string "KOREAN", for use with the IME.conversionMode property. This constant is used with Korean IMEs. Use the syntax IMEConversionMode.KOREAN.

See also

flash.system.IME.conversionMode
IME class
UNKNOWN constant
public static const UNKNOWN:String = "UNKNOWN"

The string "UNKNOWN", which can be returned by a call to the IME.conversionMode property. This value cannot be set, and is returned only if the player is unable to identify the currently active IME. Use the syntax IMEConversionMode.UNKNOWN.

See also

flash.system.IME.conversionMode


flash.system.LoaderContext (Flex™ 2 Language Reference)

Class LoaderContext | Properties | Methods
Package | flash.system
Class | public class LoaderContext
Inheritance | LoaderContext Inheritance Object

The LoaderContext class provides options for loading SWF files and other media by using the Loader class. The LoaderContext class is used as the context parameter in the load() and loadBytes() methods of the Loader class.

When loading SWF files with the Loader.load() method, you have two decisions to make: into which security domain the loaded SWF file should be placed, and into which application domain within that security domain? For more details on these choices, see the applicationDomain and securityDomain properties.

When loading a SWF file with the Loader.loadBytes() method, you have the same application domain choice to make as for Loader.load(), but it's not necessary to specify a security domain, because Loader.loadBytes() always places its loaded SWF file into the security domain of the loading SWF file.

When loading images (JPEG, GIF, or PNG) instead of SWF files, there is no need to specify a SecurityDomain or an application domain, because those concepts are meaningful only for SWF files. Instead, you have only one decision to make: do you need programmatic access to the pixels of the loaded image? If so, see the checkPolicyFile property.

See also

flash.display.Loader.load()
flash.display.Loader.loadBytes()
flash.system.ApplicationDomain
flash.system.LoaderContext.applicationDomain
flash.system.LoaderContext.checkPolicyFile
flash.system.LoaderContext.securityDomain
flash.system.SecurityDomain
Loading content dynamically

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | applicationDomain : ApplicationDomain = null Specifies the application domain to use for the Loader.load() or Loader.loadBytes() method. | LoaderContext
 | checkPolicyFile : Boolean = false Specifies whether Flash Player should attempt to download a cross-domain policy file from the loaded object's server before beginning to load the object itself. | LoaderContext
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | securityDomain : SecurityDomain = null Specifies the security domain to use for a Loader.load() operation. | LoaderContext
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LoaderContext(checkPolicyFile:Boolean = false, applicationDomain:ApplicationDomain = null, securityDomain:SecurityDomain = null) Creates a new LoaderContext object, with the specified settings. | LoaderContext
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
applicationDomain property
public var applicationDomain:ApplicationDomain = null

Specifies the application domain to use for the Loader.load() or Loader.loadBytes() method. Use this property only when loading a SWF file written in ActionScript 3.0 (not an image or a SWF file written in ActionScript 1.0 or ActionScript 2.0).

Every security domain is divided into one or more application domains, represented by ApplicationDomain objects. Application domains are not for security purposes; they are for managing cooperating units of ActionScript code. If you are loading a SWF file from another domain, and allowing it to be placed in a separate security domain, then you cannot control the choice of application domain into which the loaded SWF file is placed; and if you have specified a choice of application domain, it will be ignored. However, if you are loading a SWF file into your own security domain — either because the SWF file comes from your own domain, or because you are importing it into your security domain — then you can control the choice of application domain for the loaded SWF file.

You can pass an application domain only from your own security domain in LoaderContext.applicationDomain. Attempting to pass an application domain from any other security domain results in a SecurityError exception.

You have four choices for what kind of ApplicationDomain property to use:

  • Child of loader's ApplicationDomain. The default. You can explicitly represent this choice with the syntax new ApplicationDomain(ApplicationDomain.currentDomain). This allows the loaded SWF file to use the parent's classes directly, for example by writing new MyClassDefinedInParent(). The parent, however, cannot use this syntax; if the parent wishes to use the child's classes, it must call ApplicationDomain.getDefinition() to retrieve them. The advantage of this choice is that, if the child defines a class with the same name as a class already defined by the parent, no error results; the child simply inherits the parent's definition of that class, and the child's conflicting definition goes unused unless either child or parent calls the ApplicationDomain.getDefinition() method to retrieve it.
  • Loader's own ApplicationDomain. You use this application domain when using ApplicationDomain.currentDomain. When the load is complete, parent and child can use each other's classes directly. If the child attempts to define a class with the same name as a class already defined by the parent, an error results and the load is abandoned.
  • Child of the system ApplicationDomain. You use this application domain when using new ApplicationDomain(null). This separates loader and loadee entirely, allowing them to define separate versions of classes with the same name without conflict or overshadowing. The only way either side sees the other's classes is by calling the ApplicationDomain.getDefinition() method.
  • Child of some other ApplicationDomain. Occasionally you may have a more complex ApplicationDomain hierarchy. You can load a SWF file into any ApplicationDomain from your own SecurityDomain. For example, new ApplicationDomain(ApplicationDomain.currentDomain.parentDomain.parentDomain) loads a SWF file into a new child of the current domain's parent's parent.

When a load is complete, either side (loading or loaded) may need to find its own ApplicationDomain, or the other side's ApplicationDomain, for the purpose of calling ApplicationDomain.getDefinition(). Either side can retrieve a reference to its own application domain by using ApplicationDomain.currentDomain. The loading SWF file can retrieve a reference to the loaded SWF file's ApplicationDomain via Loader.contentLoaderInfo.applicationDomain. If the loaded SWF file knows how it was loaded, it can find its way to the loading SWF file's ApplicationDomain object. For example, if the child was loaded in the default way, it can find the loading SWF file's application domain by using ApplicationDomain.currentDomain.parentDomain.

For more information, see the "ApplicationDomain class" section of the "Client System Environment" chapter of Programming ActionScript 3.0.

See also

flash.display.Loader.load()
flash.display.Loader.loadBytes()
flash.system.ApplicationDomain
checkPolicyFile property
public var checkPolicyFile:Boolean = false

Specifies whether Flash Player should attempt to download a cross-domain policy file from the loaded object's server before beginning to load the object itself. This flag is applicable to the Loader.load() method, but not to the Loader.loadBytes() method.

Set this flag to true when you are loading an image (JPEG, GIF, or PNG) from outside the calling SWF file's own domain, and you expect to need access to the content of that image from ActionScript. Examples of accessing image content include referencing the Loader.content property to obtain a Bitmap object, and calling the BitmapData.draw() method to obtain a copy of the loaded image's pixels. If you attempt one of these operations without having specified checkPolicyFile at loading time, you may get a SecurityError exception because the needed policy file has not been downloaded yet.

When you call the Loader.load() method with LoaderContext.checkPolicyFile set to true, Flash Player does not begin downloading the specified object in URLRequest.url until it has either successfully downloaded a relevant cross-domain policy file or discovered that no such policy file exists. Flash Player first considers policy files that have already been downloaded, then attempts to download any pending policy files specified in calls to the Security.loadPolicyFile() method, then attempts to download a policy file from the default location that corresponds to URLRequest.url, which is /crossdomain.xml on the same server as URLRequest.url. In all cases, Flash Player requires that the given policy file exist on its server, that it provide access to the object at URLRequest.url by virtue of the policy file's location, and that it permit access by the domain of the calling SWF file by virtue of one or more <allow-access-from> tags.

If you set checkPolicyFile to true, Flash Player waits until policy file completion to begin the main download that you specify in the Loader.load() method. Therefore, as long as the policy file that you need exists, as soon as you have received any ProgressEvent.PROGRESS or Event.COMPLETE events from the contentLoaderInfo property of your Loader object, the policy file download is complete, and you can safely begin performing operations that require the policy file.

If you set checkPolicyFile to true, and no relevant policy file is found, you will not receive any error indication until you attempt an operation that throws a SecurityError exception. However, once the LoaderInfo object dispatches a ProgressEvent.PROGRESS or Event.COMPLETE event, you can test whether a relevant policy file was found by checking the value of the LoaderInfo.childAllowsParent property.

If you will not need pixel-level access to the image that you are loading, you should not set the checkPolicyFile property to true. Checking for a policy file in this case is wasteful, because it may delay the start of your download, and it may consume network bandwidth unnecessarily.

Also try to avoid setting checkPolicyFile to true if you are using the Loader.load() method to download a SWF file. This is because SWF-to-SWF permissions are not controlled by policy files, but rather by the Security.allowDomain() method, and thus checkPolicyFile has no effect when you load a SWF file. Checking for a policy file in this case is wasteful, because it may delay the download of the SWF file, and it may consume network bandwidth unnecessarily. (Flash Player cannot tell whether your main download will be a SWF file or an image, because the policy file download occurs before the main download.)

Be careful with checkPolicyFile if you are downloading an object from a URL that may use server-side HTTP redirects. Flash Player always attempts to retrieve policy files that correspond to the initial URL that you specify in URLRequest.url. If the final object comes from a different URL because of HTTP redirects, then the initially downloaded policy files might not be applicable to the object's final URL, which is the URL that matters in security decisions. If you find yourself in this situation, you can examine the value of LoaderInfo.url after you have received a ProgressEvent.PROGRESS or Event.COMPLETE event, which tells you the object's final URL. Then call the Security.loadPolicyFile() method with a policy file URL based on the object's final URL. Then poll the value of LoaderInfo.childAllowsParent until it becomes true.

See also

flash.display.BitmapData.draw()
flash.display.Loader.content
flash.display.Loader.load()
flash.display.LoaderInfo.childAllowsParent
flash.display.LoaderInfo.url
flash.system.Security.allowDomain()
flash.system.Security.loadPolicyFile()
Loading content dynamically
securityDomain property
public var securityDomain:SecurityDomain = null

Specifies the security domain to use for a Loader.load() operation. Use this property only when loading a SWF file (not an image).

The choice of security domain is meaningful only if you are loading a SWF file that might come from a different domain (a different server) than the loading SWF file. When you load a SWF file from your own domain, it is always placed into your security domain. But when you load a SWF file from a different domain, you have two options. You can allow the loaded SWF file to be placed in its "natural" security domain, which is different from that of the loading SWF file; this is the default. The other option is to specify that you want to place the loaded SWF file placed into the same security domain as the loading SWF file, by setting myLoaderContext.securityDomain to be equal to SecurityDomain.currentDomain. This is called import loading, and it is equivalent, for security purposes, to copying the loaded SWF file to your own server and loading it from there. In order for import loading to succeed, the loaded SWF file's server must have a policy file trusting the domain of the loading SWF file.

You can pass your own security domain only in LoaderContext.securityDomain. Attempting to pass any other security domain results in a SecurityError exception.

For more information, see the "Security" chapter in Programming ActionScript 3.0.

See also

flash.display.Loader.load()
flash.system.SecurityDomain
Loading content dynamically
Flash Player Security
Constructor detail
LoaderContext () constructor
public function LoaderContext(checkPolicyFile:Boolean = false, applicationDomain:ApplicationDomain = null, securityDomain:SecurityDomain = null)

Creates a new LoaderContext object, with the specified settings. For complete details on these settings, see the descriptions of the properties of this class.

Parameters
checkPolicyFile:Boolean (default = false) — Specifies whether Flash Player should check for the existence of a cross-domain policy file before loading the object.
applicationDomain:ApplicationDomain (default = null) — Specifies the ApplicationDomain object to use for a Loader object.
securityDomain:SecurityDomain (default = null) — Specifies the SecurityDomain object to use for a Loader object.

See also

flash.display.Loader.load()
flash.display.Loader.loadBytes()
flash.system.ApplicationDomain
flash.system.SecurityDomain


flash.system.Security (Flex™ 2 Language Reference)

View comments | RSS feed
Class Security | Properties | Methods | Constants | Examples
Package | flash.system
Class | public final class Security
Inheritance | Security Inheritance Object

The Security class lets you specify how SWF files in different domains can communicate with each other.

View the examples.

See also

Flash Player Security

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | exactSettings : Boolean [static] Determines how Flash Player chooses the domain to use for certain Flash Player settings, including settings for camera and microphone permissions, storage quotas, and storage of persistent shared objects. | Security
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | sandboxType : String [static][read-only] Indicates the type of security sandbox in which the calling SWF file is operating. | Security
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | allowDomain(... domains):void [static] Lets SWF files and HTML files in the identified domains access objects and variables in the SWF file that contains the allowDomain() call. | Security
 | allowInsecureDomain(... domains):void [static] Lets SWF files and HTML files in the identified domains access objects and variables in the calling SWF file, which is hosted by means of the HTTPS protocol. | Security
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | loadPolicyFile(url:String):void [static] Loads a cross-domain policy file from a location specified by the url parameter. | Security
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | showSettings(panel:String = "default"):void [static] Displays the Security Settings panel in Flash Player. | Security
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | LOCAL_TRUSTED : String = "localTrusted" [static] The SWF file is a local file and has been trusted by the user, using either the Settings Manager or a FlashPlayerTrust configuration file. | Security
 | LOCAL_WITH_FILE : String = "localWithFile" [static] The SWF file is a local file, has not been trusted by the user, and was not published with a networking designation. | Security
 | LOCAL_WITH_NETWORK : String = "localWithNetwork" [static] The SWF file is a local file, has not been trusted by the user, and was published with a networking designation. | Security
 | REMOTE : String = "remote" [static] The SWF file is from an Internet URL and operates under domain-based sandbox rules. | Security
Property detail
exactSettings property
exactSettings:Boolean [read-write]

Determines how Flash Player chooses the domain to use for certain Flash Player settings, including settings for camera and microphone permissions, storage quotas, and storage of persistent shared objects. You may set exactSettings to false in order to have the SWF file use the same settings that were used in Flash Player 6.

In Flash Player 6, the domain used for these player settings was based on the trailing portion of the domain of the SWF file. If the domain of a SWF file includes more than two segments, such as www.example.com, the first segment of the domain ("www") is removed, and the remaining portion of the domain is used: example.com. So, in Flash Player 6, www.example.com and store.example.com both use example.com as the domain for these settings. Similarly, www.example.co.uk and store.example.co.uk both use example.co.uk as the domain for these settings. In Flash Player 7 and later, player settings are chosen by default according to a SWF file's exact domain; for example, a SWF file from www.example.com would use the player settings for www.example.com, and a SWF file from store.example.com would use the separate player settings for store.example.com.

When Security.exactSettings is set to true, Flash Player uses exact domains for player settings. When it is set to false, the Flash Player uses domain settings used in Flash Player 6. The default value for exactSettings is false. If you change exactSettings from its default value, you must do so before any events occur that require Flash Player to choose player settings — for example, using a camera or microphone, or retrieving a persistent shared object.

If you previously published a version 6 SWF file and created persistent shared objects from it, and you now need to retrieve those persistent shared objects from that SWF file after porting it to version 7 or later, or from a different SWF file of version 7 or later, you must set Security.exactSettings to false before calling SharedObject.getLocal().

Implementation
    public static function get exactSettings():Boolean
    public function set exactSettings(value:Boolean):void

Throws
SecurityError — Flash Player already used the value of exactSettings at least once in a decision about player settings.

See also

Flash Player Security
sandboxType property
sandboxType:String [read-only]

Indicates the type of security sandbox in which the calling SWF file is operating.

Security.sandboxType has one of the following values:

  • remote (Security.REMOTE): This SWF file is from an Internet URL and operates under domain-based sandbox rules.
  • localWithFile (Security.LOCAL_WITH_FILE): This SWF file is a local file, has not been trusted by the user, and was not published with a networking designation. The SWF file may read from local data sources but may not communicate with the Internet.
  • localWithNetwork (Security.LOCAL_WITH_NETWORK): This SWF file is a local file, has not been trusted by the user, and was published with a networking designation. The SWF file can communicate with the Internet but cannot read from local data sources.
  • localTrusted (Security.LOCAL_TRUSTED): This SWF file is a local file and has been trusted by the user, using either the Settings Manager or a FlashPlayerTrust configuration file. The SWF file can read from local data sources and communicate with the Internet.

A SWF file of any version may use this property, but is only supported in Flash Player 8 or later. Thus you can examine this property, for example, from a version 7 SWF file playing in Flash Player 8. This all-versions support means that, if you publish for a version earlier than 8, you will not know at publish time whether this property will be supported at playback time. Thus, in a SWF file of version 7 or earlier, this property has an undefined value; that should happen only when the player version (indicated by flash.system.Capabilities.version) is earlier than 8. In that situation, you can determine the sandbox type according to whether your SWF file's URL is a local file or not. In that situation, you can determine the sandbox type according to whether your SWF file's URL is a local file. If it is a local file, Flash Player will classify your SWF file as localTrusted. (Before Flash Player 8, this was how all local content was treated.) If it is not a local file, Flash Player will classify your SWF file as remote.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Implementation
    public static function get sandboxType():String

See also

REMOTE
LOCAL_WITH_FILE
LOCAL_WITH_NETWORK
LOCAL_TRUSTED
Flash Player Security
Method detail
allowDomain () method
public static function allowDomain(... domains):void

Lets SWF files and HTML files in the identified domains access objects and variables in the SWF file that contains the allowDomain() call.

If two SWF files are served from the same domain — for example, http://mysite.com/swfA.swf and http://mysite.com/swfB.swf — then swfA.swf can examine and modify variables, objects, properties, methods, and so on in swfB.swf, and swfB.swf can do the same for swfA.swf. This is called cross-movie scripting or cross-scripting.

If two SWF files are served from different domains — for example, http://siteA.com/swfA.swf and http://siteB.com/siteB.swf — then, by default, Flash Player does not allow swfA.swf to script swfB.swf, nor swfB.swf to script swfA.swf. A SWF file gives SWF files from other domains by calling Security.allowDomain(). This is called cross-domain scripting. By calling Security.allowDomain("siteA.com"), siteB.swf gives siteA.swf permission to script it.

In any cross-domain situation, it is important to be clear about the two parties involved. For the purposes of this discussion, the side performing the cross-scripting is called the accessing party (usually the accessing SWF), and the other side is called the party being accessed (usually the SWF being accessed). When siteA.swf scripts siteB.swf, siteA.swf is the accessing party, and siteB.swf is the party being accessed.

Cross-domain permissions that are established with allowDomain() are asymmetrical. In the previous example, siteA.swf can script siteB.swf, but siteB.swf cannot script siteA.swf, because siteA.swf has not called allowDomain() to give SWF files at siteB.com permission to script it. You can set up symmetrical permissions by having both SWF files call allowDomain().

In addition to protecting SWF files from cross-domain scripting originated by other SWF files, Flash Player protects SWF files from cross-domain scripting originated by HTML files. HTML-to-SWF scripting can occur with older Flash browser functions such as SetVariable or callbacks established through ExternalInterface.addCallback(). When HTML-to-SWF scripting crosses domains, the SWF file being accessed must call allowDomain(), just as when the accessing party is a SWF file, or the operation will fail.

Specifying an IP address as a parameter to allowDomain() does not permit access by all parties that originate at the specified IP address. Instead, it permits access only by a party that contains the specified IP address it its URL, rather than a domain name that maps to that IP address.

Version-specific differences
Flash Player's cross-domain security rules have evolved from version to version. The following table summarizes the differences.

Latest SWF version involved in cross-scripting allowDomain() needed? allowInsecureDomain() needed? Which SWF must call allowDomain() or allowInsecureDomain()? What can be specified in allowDomain() or allowInsecureDomain()?
5 or earlier
 No
No
N/A
6
 Yes, if superdomains don't match The SWF file being accessed, or any SWF file with the same superdomain as the SWF file being accessed
  • Text-based domain (mysite.com)
  • IP address (192.168.1.1)
7
 Yes, if domains don't match exactly Yes, if performing HTTP-to-HTTPS access (even if domains match exactly) The SWF file being accessed, or any SWF file with exactly the same domain as the SWF file being accessed
8 or later
 SWF being accessed
  • Text-based domain (mysite.com)
  • IP address (192.168.1.1)
  • Wildcard (*)

The versions that control the behavior of Flash Player are SWF versions (the published version of a SWF file), not the version of Flash Player itself. For example, when Flash Player 8 is playing a SWF file published for version 7, it applies behavior that is consistent with version 7. This practice ensures that player upgrades do not change the behavior of Security.allowDomain() in deployed SWF files.

The version column in the previous table shows the latest SWF version involved in a cross-scripting operation. Flash Player determines its behavior according to either the accessing SWF file's version or the version of the SWF file that is being accessed, whichever is later.

The following paragraphs provide more detail about Flash Player security changes involving Security.allowDomain().

Version 5. There are no cross-domain scripting restrictions.

Version 6. Cross-domain scripting security is introduced. By default, Flash Player forbids cross-domain scripting; Security.allowDomain() can permit it. To determine whether two files are in the same domain, Flash Player uses each file's superdomain, which is the exact host name from the file's URL, minus the first segment, down to a minimum of two segments. For example, the superdomain of www.mysite.com is mysite.com. SWF files from www.mysite.com and store.mysite.com to script each other without a call to Security.allowDomain().

Version 7. Superdomain matching is changed to exact domain matching. Two files are permitted to script each other only if the host names in their URLs are identical; otherwise, a call to Security.allowDomain() is required. By default, files loaded from non-HTTPS URLs are no longer permitted to script files loaded from HTTPS URLs, even if the files are loaded from exactly the same domain. This restriction helps protect HTTPS files, because a non-HTTPS file is vulnerable to modification during download, and a maliciously modified non-HTTPS file could corrupt an HTTPS file, which is otherwise immune to such tampering. Security.allowInsecureDomain() is introduced to allow HTTPS SWF files that are being accessed to voluntarily disable this restriction, but the use of Security.allowInsecureDomain() is discouraged.

Version 8. There are two major areas of change:

  • Calling Security.allowDomain() now permits cross-scripting operations only if the SWF file being accessed is the SWF file that called Security.allowDomain(). In other words, a SWF file that calls Security.allowDomain() now permits access only to itself. In previous versions, calling Security.allowDomain() permitted cross-scripting operations where the SWF file being accessed could be any SWF file in the same domain as the SWF file that called Security.allowDomain(). Calling Security.allowDomain() previously opened up the entire domain of the calling SWF file.
  • Support has been added for wildcard values with Security.allowDomain("*") and Security.allowInsecureDomain("*"). The wildcard (*) value permits cross-scripting operations where the accessing file is any file at all, loaded from anywhere. Think of the wildcard as a global permission. Wildcard permissions are required to enable certain kinds of operations under the local file security rules. Specifically, for a local SWF file with network-access permissions to script a SWF file on the Internet, the Internet SWF file being accessed must call Security.allowDomain("*"), reflecting that the origin of a local SWF file is unknown. (If the Internet SWF file is loaded from an HTTPS URL, the Internet SWF file must instead call Security.allowInsecureDomain("*").)

Occasionally, you may encounter the following situation: You load a child SWF file from a different domain and want to allow the child SWF file to script the parent SWF file, but you don't know the final domain of the child SWF file. This can happen, for example, when you use load-balancing redirects or third-party servers.

In this situation, you can use the url property of the URLRequest object that you pass to Loader.load(). For example, if you load a child SWF file into a parent SWF, you can access the contentLoaderInfo property of the Loader object for the parent SWF:
Security.allowDomain(loader.contentLoaderInfo.url)

Make sure that you wait until the child SWF file begins loading to get the correct value of the url property. To determine when the child SWF has begun loading, use the progress event.

The opposite situation can also occur; that is, you might create a child SWF file that wants to allow its parent to script it, but doesn't know what the domain of its parent will be. In this situation, you can access the loaderInfo property of the display object that is the SWF's root object. In the child SWF, call Security.allowDomain( this.root.loaderInfo.loaderURL). You don't have to wait for the parent SWF file to load; the parent will already be loaded by the time the child loads.

If you are publishing for Flash Player 8 or later, you can also handle these situations by calling Security.allowDomain("*"). However, this can sometimes be a dangerous shortcut, because it allows the calling SWF file to be accessed by any other SWF file from any domain. It is usually safer to use the _url property.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
... domains — One or more strings or URLRequest objects that name the domains from which you want to allow access. You can specify the special domain "*" to allow access from all domains.

Specifying "*" is the only way to allow access to nonlocal SWF files from local SWF files that have been published using Access Network Only for the Local Playback Security option in the Flash authoring tool.

See also

ExternalInterface.addCallback()
flash.events.Event.COMPLETE
flash.display.DisplayObject.parent
flash.net.URLRequest.url
allowInsecureDomain()
Function parameters
Flash Player Security
allowInsecureDomain () method
public static function allowInsecureDomain(... domains):void

Lets SWF files and HTML files in the identified domains access objects and variables in the calling SWF file, which is hosted by means of the HTTPS protocol. This method is not recommended; see "Security considerations," later in this entry.

This method works in the same way as Security.allowDomain(), but it also permits operations in which the accessing party is loaded with a non-HTTPS protocol, and the party being accessed is loaded with HTTPS. In Flash Player 7 and later, non-HTTPS files are not allowed to script HTTPS files. The allowInsecureDomain() method lifts this restriction when the HTTPS SWF file being accessed uses it.

Use allowInsecureDomain() only to enable scripting from non-HTTPS files to HTTPS files. Use it to enable scripting when the accessing non-HTTPS file and the HTTPS file being accessed are served from the same domain, for example, if a SWF file at http://mysite.com wants to script a SWF file at https://mysite.com. Do not use this method to enable scripting between non-HTTPS files, between HTTPS files, or from HTTPS files to non-HTTPS files. For those situations, use allowDomain() instead.

Security considerations: Flash Player provides allowInsecureDomain() to maximize flexibility, but calling this method is not recommended. Serving a file over HTTPS provides several protections for you and your users, and calling allowInsecureDomain weakens one of those protections. The following scenario illustrates how allowInsecureDomain() can compromise security, if it is not used with careful consideration.

Note that the following information is only one possible scenario, designed to help you understand allowInsecureDomain() through a real-world example of cross-scripting. It does not cover all issues with security architecture and should be used for background information only. The Flash Player Developer Center contains extensive information on Flash Player and security. For more information, see http://www.adobe.com/devnet/security/.

Suppose you are building an e-commerce site that consists of two components: a catalog, which does not need to be secure, because it contains only public information; and a shopping cart/checkout component, which must be secure to protect users' financial and personal information. Suppose you are considering serving the catalog from http://mysite.com/catalog.swf and the cart from https://mysite.com/cart.swf. One requirement for your site is that a third party should not be able to steal your users' credit card numbers by taking advantage of a weakness in your security architecture.

Suppose that a middle-party attacker intervenes between your server and your users, attempting to steal the credit card numbers that your users enter into your shopping cart application. A middle party might, for example, be an unscrupulous ISP used by some of your users, or a malicious administrator at a user's workplace — anyone who has the ability to view or alter network packets transmitted over the public Internet between your users and your servers. This situation is not uncommon.

If cart.swf uses HTTPS to transmit credit card information to your servers, then the middle-party attacker can't directly steal this information from network packets, because the HTTPS transmission is encrypted. However, the attacker can use a different technique: altering the contents of one of your SWF files as it is delivered to the user, replacing your SWF file with an altered version that transmits the user's information to a different server, owned by the attacker.

The HTTPS protocol, among other things, prevents this "modification" attack from working, because, in addition to being encrypted, HTTPS transmissions are tamper-resistant. If a middle-party attacker alters a packet, the receiving side detects the alteration and discards the packet. So the attacker in this situation can't alter cart.swf, because it is delivered over HTTPS.

However, suppose that you want to allow buttons in catalog.swf, served over HTTP, to add items to the shopping cart in cart.swf, served over HTTPS. To accomplish this, cart.swf calls allowInsecureDomain(), which allows catalog.swf to script cart.swf. This action has an unintended consequence: Now the attacker can alter catalog.swf as it is initially being downloaded by the user, because catalog.swf is delivered with HTTP and is not tamper-resistant. The attacker's altered catalog.swf can now script cart.swf, because cart.swf contains a call to allowInsecureDomain(). The altered catalog.swf file can use ActionScript to access the variables in cart.swf, thus reading the user's credit card information and other sensitive data. The altered catalog.swf can then send this data to an attacker's server.

Obviously, this implementation is not desired, but you still want to allow cross-scripting between the two SWF files on your site. Here are two possible ways to redesign this hypothetical e-commerce site to avoid allowInsecureDomain():

  • Serve all SWF files in the application over HTTPS. This is by far the simplest and most reliable solution. In the scenario described, you would serve both catalog.swf and cart.swf over HTTPS. You might experience slightly higher bandwidth consumption and server CPU load when switching a file such as catalog.swf from HTTP to HTTPS, and your users might experience slightly longer application load times. You need to experiment with real servers to determine the severity of these effects; usually they are no worse than 10-20% each, and sometimes they are not present at all. You can usually improve results by using HTTPS-accelerating hardware or software on your servers. A major benefit of serving all cooperating SWF files over HTTPS is that you can use an HTTPS URL as the main URL in the user's browser without generating any mixed-content warnings from the browser. Also, the browser's padlock icon becomes visible, providing your users with a common and trusted indicator of security.
  • Use HTTPS-to-HTTP scripting, rather than HTTP-to-HTTPS scripting. In the scenario described, you could store the contents of the user's shopping cart in catalog.swf, and have cart.swf manage only the checkout process. At checkout time, cart.swf could retrieve the cart contents from ActionScript variables in catalog.swf. The restriction on HTTP-to-HTTPS scripting is asymmetrical; although an HTTP-delivered catalog.swf file cannot safely be allowed to script an HTTPS-delivered cart.swf file, an HTTPS cart.swf file can script the HTTP catalog.swf file. This approach is more delicate than the all-HTTPS approach; you must be careful not to trust any SWF file delivered over HTTP, because of its vulnerability to tampering. For example, when cart.swf retrieves the ActionScript variable that describes the cart contents, the ActionScript code in cart.swf cannot trust that the value of this variable is in the format that you expect. You must verify that the cart contents do not contain invalid data that might lead cart.swf to take an undesired action. You must also accept the risk that a middle party, by altering catalog.swf, could supply valid but inaccurate data to cart.swf; for example, by placing items in the user's cart. The usual checkout process mitigates this risk somewhat by displaying the cart contents and total cost for final approval by the user, but the risk remains present.

Web browsers have enforced separation between HTTPS and non-HTTPS files for years, and the scenario described illustrates one good reason for this restriction. Flash Player gives you the ability to work around this security restriction when you absolutely must, but be sure to consider the consequences carefully before doing so.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
... domains — One or more strings or URLRequest objects that name the domains from which you want to allow access. You can specify the special domain "*" to allow access from all domains.

Specifying "*" is the only way to allow access to nonlocal SWF files from local SWF files that have been published using the Access Network Only option for the Local Playback Security setting (File > Publish Settings > Flash tab) in the Flash authoring tool.

See also

allowDomain()
Function parameters
Flash Player Security
loadPolicyFile () method
public static function loadPolicyFile(url:String):void

Loads a cross-domain policy file from a location specified by the url parameter. Flash Player uses policy files to determine whether to permit Flash movies to load data from servers other than their own.

By default, Flash Player looks for policy files in only one location: /crossdomain.xml on the server to which a data-loading request is being made. By default, for an XMLSocket connection attempt, Flash Player looks for /crossdomain.xml on an HTTP server on port 80 in the subdomain to which the XMLSocket connection attempt is being made.

With Security.loadPolicyFile(), Flash Player can load policy files from arbitrary locations, as shown in the following example:

  Security.loadPolicyFile("http://www.example.com/sub/dir/pf.xml");

This causes Flash Player to retrieve a policy file from the specified URL. Any permissions granted by the policy file at that location will apply to all content at the same level or lower in the virtual directory hierarchy of the server. For example, following the previous code, these lines do not throw an exception:

 import flash.net.*;
  var request:URLRequest = new URLRequest("http://www.example.com/sub/dir/vars.txt");
  var loader:URLLoader = new URLLoader();
  loader.load(request);

  var loader2:URLLoader = new URLLoader();
  var request2:URLRequest = new URLRequest("http://www.example.com/sub/dir/deep/vars2.txt");
  loader2.load(request2);

However, the following code does throw a security exception:

 import flash.net.*;
  var request3:URLRequest = new URLRequest("http://www.example.com/elsewhere/vars3.txt");
  var loader3:URLLoader = new URLLoader();
  loader3.load(request3);

You can use loadPolicyFile() to load any number of policy files. When considering a request that requires a policy file, Flash Player always waits for the completion of any policy file downloads before denying a request. As a final fallback, if no policy file specified with loadPolicyFile() authorizes a request, Flash Player consults the original default location, /crossdomain.xml.

Using the xmlsocket protocol along with a specific port number, lets you retrieve policy files directly from an XMLSocket server, as shown in the following example:

  Security.loadPolicyFile("xmlsocket://foo.com:414");

This causes Flash Player to attempt to retrieve a policy file from the specified host and port. Any port can be used, not only ports 1024 and higher. Upon establishing a connection with the specified port, Flash Player transmits <policy-file-request />, terminated by a null byte. An XMLSocket server can be configured to serve both policy files and normal XMLSocket connections over the same port, in which case the server should wait for <policy-file-request /> before transmitting a policy file. A server can also be set up to serve policy files over a separate port from standard connections, in which case it can send a policy file as soon as a connection is established on the dedicated policy file port. The server must send a null byte to terminate a policy file, and may thereafter close the connection; if the server does not close the connection, Flash Player does so upon receiving the terminating null byte.

A policy file served by an XMLSocket server has the same syntax as any other policy file, except that it must also specify the ports to which access is granted. When a policy file comes from a port lower than 1024, it can grant access to any ports; when a policy file comes from port 1024 or higher, it can grant access only to other ports 1024 and higher. The allowed ports are specified in a "to-ports" attribute in the <allow-access-from> tag. Single port numbers, port ranges, and wildcards are all allowed. The following example shows an XMLSocket policy file:

  <cross-domain-policy>
    <allow-access-from domain="*" to-ports="507" />
    <allow-access-from domain="*.foo.com" to-ports="507,516" />
    <allow-access-from domain="*.bar.com" to-ports="516-523" />
    <allow-access-from domain="www.foo.com" to-ports="507,516-523" />
    <allow-access-from domain="www.bar.com" to-ports="*" />
  </cross-domain-policy>

A policy file obtained from the old default location—/crossdomain.xml on an HTTP server on port 80—implicitly authorizes access to all ports 1024 and above. There is no way to retrieve a policy file to authorize XMLSocket operations from any other location on an HTTP server; any custom locations for XMLSocket policy files must be on an XMLSocket server.

Because the ability to connect to ports lower than 1024 is new, a policy file loaded with loadPolicyFile() must always authorize this connection, even when a movie clip is connecting to its own subdomain.

For more information, see the following:

  • The security chapter in the Programming ActionScript 3.0 book and the latest comments on LiveDocs
    •
  • The Flash Player 9 Security white paper
Parameters
url:String — The URL location of the cross-domain policy file to be loaded.

See also

Flash Player Security
showSettings () method
public static function showSettings(panel:String = "default"):void

Displays the Security Settings panel in Flash Player.

Parameters
panel:String (default = "default") — A value from the SecurityPanel class that specifies which Security Settings panel you want to display. If you omit this parameter, SecurityPanel.DEFAULT is used.

See also

SecurityPanel
Flash Player Security
Constant detail
LOCAL_TRUSTED constant
public static const LOCAL_TRUSTED:String = "localTrusted"

The SWF file is a local file and has been trusted by the user, using either the Settings Manager or a FlashPlayerTrust configuration file. The SWF file can read from local data sources and communicate with the Internet.

See also

sandboxType
REMOTE
LOCAL_WITH_FILE
LOCAL_WITH_NETWORK
Flash Player Security
LOCAL_WITH_FILE constant
public static const LOCAL_WITH_FILE:String = "localWithFile"

The SWF file is a local file, has not been trusted by the user, and was not published with a networking designation. The SWF file may read from local data sources but may not communicate with the Internet.

See also

sandboxType
REMOTE
LOCAL_WITH_NETWORK
LOCAL_TRUSTED
Flash Player Security
LOCAL_WITH_NETWORK constant
public static const LOCAL_WITH_NETWORK:String = "localWithNetwork"

The SWF file is a local file, has not been trusted by the user, and was published with a networking designation. The SWF file can communicate with the Internet but cannot read from local data sources.

See also

sandboxType
REMOTE
LOCAL_WITH_FILE
LOCAL_TRUSTED
Flash Player Security
REMOTE constant
public static const REMOTE:String = "remote"

The SWF file is from an Internet URL and operates under domain-based sandbox rules.

See also

sandboxType
LOCAL_WITH_FILE
LOCAL_WITH_NETWORK
LOCAL_TRUSTED
Flash Player Security
Examples

The following example shows how a click event on a Sprite object can be used to show the Local Storage Settings panel of the Flash Player Settings. An orange box is added to the stage using draw(). In draw(), a click event listener is added named clickHandler(), which responds to click events by directing Flash Player to open its Local Storage Settings panel.
package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.events.*;
    import flash.system.Security;
    import flash.system.SecurityPanel;

    public class SecurityExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint = 100;

        public function SecurityExample() {
            draw();
        }

        private function draw():void {
            var child:Sprite = new Sprite();
            child.graphics.beginFill(bgColor);
            child.graphics.drawRect(0, 0, size, size);
            child.graphics.endFill();
            child.buttonMode = true;

            var label:TextField = new TextField();
            label.text = "settings";
            label.selectable = false;
            label.mouseEnabled = false;
            child.addChild(label);

            child.addEventListener(MouseEvent.CLICK, clickHandler);
            addChild(child);
        }

        private function clickHandler(event:MouseEvent):void {
            Security.showSettings(SecurityPanel.LOCAL_STORAGE);
        }
    }
}

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

djtechwriter said on Jun 29, 2006 at 4:48 PM :
The description for loadPolicyFile(), incorrectly states:
"By default, for an XMLSocket connection attempt, Flash Player looks for /crossdomain.xml on an HTTP server on port 80 in the subdomain to which the XMLSocket connection attempt is being made."

Actually, Flash Player 9 does not do this by default (although Flash Player 7.0.14.0 did).

And, for clarification, note that the ability to connect to ports lower than 1024 is granted by a policy file loaded with loadPolicyFile() only.

- Dave Jacowitz, Flash Team

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/flash/system/Security.html


flash.system.SecurityDomain (Flex™ 2 Language Reference)

Class SecurityDomain | Properties | Methods
Package | flash.system
Class | public class SecurityDomain
Inheritance | SecurityDomain Inheritance Object

The SecurityDomain class represents the current security "sandbox," also known as a security domain. By passing an instance of this class to Loader.load(), you can request that loaded media be placed in a particular sandbox.

See also

Flash Player Security

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentDomain : SecurityDomain [static][read-only] Gets the current security domain. | SecurityDomain
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
currentDomain property
currentDomain:SecurityDomain [read-only]

Gets the current security domain.

Implementation
    public static function get currentDomain():SecurityDomain

See also

flash.display.Loader.load()
flash.display.Loader.loadBytes()
flash.system.LoaderContext
Flash Player Security


flash.system.SecurityPanel (Flex™ 2 Language Reference)

Class SecurityPanel | Properties | Methods | Constants | Examples
Package | flash.system
Class | public final class SecurityPanel
Inheritance | SecurityPanel Inheritance Object

The SecurityPanel class provides values for specifying which Security Settings panel you want to display.

This class contains static constants that are used with the Security.showSettings() method. You cannot create new instances of the SecurityPanel class.

View the examples.

See also

Flash Player Security

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CAMERA : String = "camera" [static] When passed to Security.showSettings(), displays the Camera panel in Flash Player Settings. | SecurityPanel
 | DEFAULT : String = "default" [static] When passed to Security.showSettings(), displays the panel that was open the last time the user closed the Flash Player Settings. | SecurityPanel
 | LOCAL_STORAGE : String = "localStorage" [static] When passed to Security.showSettings(), displays the Local Storage Settings panel in Flash Player Settings. | SecurityPanel
 | MICROPHONE : String = "microphone" [static] When passed to Security.showSettings(), displays the Microphone panel in Flash Player Settings. | SecurityPanel
 | PRIVACY : String = "privacy" [static] When passed to Security.showSettings(), displays the Privacy Settings panel in Flash Player Settings. | SecurityPanel
 | SETTINGS_MANAGER : String = "settingsManager" [static] When passed to Security.showSettings(), displays the Settings Manager (in a separate browser window). | SecurityPanel
Constant detail
CAMERA constant
public static const CAMERA:String = "camera"

When passed to Security.showSettings(), displays the Camera panel in Flash Player Settings.

See also

Security.showSettings()
Flash Player Security
DEFAULT constant
public static const DEFAULT:String = "default"

When passed to Security.showSettings(), displays the panel that was open the last time the user closed the Flash Player Settings.

See also

Security.showSettings()
Flash Player Security
LOCAL_STORAGE constant
public static const LOCAL_STORAGE:String = "localStorage"

When passed to Security.showSettings(), displays the Local Storage Settings panel in Flash Player Settings.

See also

Security.showSettings()
Flash Player Security
MICROPHONE constant
public static const MICROPHONE:String = "microphone"

When passed to Security.showSettings(), displays the Microphone panel in Flash Player Settings.

See also

Security.showSettings()
Flash Player Security
PRIVACY constant
public static const PRIVACY:String = "privacy"

When passed to Security.showSettings(), displays the Privacy Settings panel in Flash Player Settings.

See also

Security.showSettings()
Flash Player Security
Flash Player Security
SETTINGS_MANAGER constant
public static const SETTINGS_MANAGER:String = "settingsManager"

When passed to Security.showSettings(), displays the Settings Manager (in a separate browser window).

See also

Security.showSettings()
Flash Player Security
Examples

The following example shows how a click event on a Sprite object can be used to show the Local Storage Settings panel of the Flash Player Settings. An orange box is added to the stage using draw(). In draw(), a click event listener is added named clickHandler(), which responds to click events by directing Flash Player to open its Local Storage Settings panel.
package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.events.*;
    import flash.system.Security;
    import flash.system.SecurityPanel;

    public class SecurityExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint = 100;

        public function SecurityExample() {
            draw();
        }

        private function draw():void {
            var child:Sprite = new Sprite();
            child.graphics.beginFill(bgColor);
            child.graphics.drawRect(0, 0, size, size);
            child.graphics.endFill();
            child.buttonMode = true;

            var label:TextField = new TextField();
            label.text = "settings";
            label.selectable = false;
            label.mouseEnabled = false;
            child.addChild(label);

            child.addEventListener(MouseEvent.CLICK, clickHandler);
            addChild(child);
        }

        private function clickHandler(event:MouseEvent):void {
            Security.showSettings(SecurityPanel.LOCAL_STORAGE);
        }
    }
}


flash.system.System (Flex™ 2 Language Reference)

Class System | Properties | Methods | Examples
Package | flash.system
Class | public final class System
Inheritance | System Inheritance Object

The System class contains properties related to certain operations that take place on the user's computer, such as operations with shared objects, local settings for cameras and microphones, and use of the Clipboard.

Additional properties and methods are in other classes within the flash.system package: the Capabilities class, the Security class, and the IME class.

This class contains only static methods and properties. You cannot create new instances of the System class.

View the examples.

See also

flash.system.Security
flash.events.IMEEvent
System class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | ime : IME [static][read-only] The currently installed system IME. | System
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | totalMemory : uint [static][read-only] The amount of memory (in bytes) currently in use by Adobe® Flash® Player. | System
 | useCodePage : Boolean [static] A Boolean value that tells Flash Player which code page to use to interpret external text files. | System
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | setClipboard(string:String):void [static] Replaces the contents of the Clipboard with a specified text string. | System
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
ime property
ime:IME [read-only]

The currently installed system IME. To register for imeComposition events, call addEventListener() on this instance.

Implementation
    public static function get ime():IME

See also

IMEConversionMode
System class
totalMemory property
totalMemory:uint [read-only]

The amount of memory (in bytes) currently in use by Adobe® Flash® Player.

Implementation
    public static function get totalMemory():uint

See also

System class
useCodePage property
useCodePage:Boolean [read-write]

A Boolean value that tells Flash Player which code page to use to interpret external text files. When the property is set to false, Flash Player interprets external text files as Unicode. (These files must be encoded as Unicode when you save them.) When the property is set to true, Flash Player interprets external text files using the traditional code page of the operating system running the player. The default value of useCodePage is false.

Text that you load as an external file (using flash.display.Loader.load() or the flash.net.URLLoader, flash.net.URLStream, or XML class) must have been saved as Unicode in order for Flash Player to recognize it as Unicode. To encode external files as Unicode, save the files in an application that supports Unicode, such as Notepad on Windows 2000.

If you load external text files that are not Unicode-encoded, set useCodePage to true. Add the following as the first line of code in the first frame of the SWF file that is loading the data:

System.useCodePage = true;

When this code is present, Flash Player interprets external text using the traditional code page of the operating system running Flash Player. This is generally CP1252 for an English Windows operating system and Shift-JIS for a Japanese operating system. If you set useCodePage to true, Flash Player 6 and later treat text as Flash Player 5 does. (Flash Player 5 treated all text as if it were in the traditional code page of the operating system running the player.)

If you set useCodePage to true, remember that the traditional code page of the operating system running the player must include the characters used in your external text file in order to display your text. For example, if you load an external text file that contains Chinese characters, those characters cannot display on a system that uses the CP1252 code page because that code page does not include Chinese characters.

To ensure that users on all platforms can view external text files used in your SWF files, you should encode all external text files as Unicode and leave useCodePage set to false. This way, Flash Player 6 and later interprets the text as Unicode.

Implementation
    public static function get useCodePage():Boolean
    public function set useCodePage(value:Boolean):void

See also

flash.display.Loader.load()
System class
Method detail
setClipboard () method
public static function setClipboard(string:String):void

Replaces the contents of the Clipboard with a specified text string.

Note: Because of security concerns, it is not possible to read the contents of the system Clipboard. In other words, there is no corresponding System.getClipboard() method.

Parameters
string:String — A plain-text string of characters to put on the system Clipboard, replacing its current contents (if any).

See also

System class
Examples

The following example shows how to copy information about your system's total memory to the system Clipboard using a call to System.totalMemory within a call to the System.setClipboard() method.
package {
    import flash.display.Sprite;
    import flash.system.System;

    public class SystemExample extends Sprite {
        public function SystemExample() {
            System.setClipboard("System.totalMemory: " + System.totalMemory);
        }
    }
}


flash.text Summary (Flex™ 2 Language Reference)

Package flash.text | Classes

The flash.text package contains classes for working with text fields, text formatting, text metrics, style sheets, and layout. Advanced anti-aliasing is available in Flash Player 8 and later through the flash.text.TextFormat and flash.text.TextRenderer classes.

Classes
Class | Description
AntiAliasType | The AntiAliasType class provides values for anti-aliasing in the flash.text.TextField class.
CSMSettings | The CSMSettings class contains properties for use with the TextRenderer.setAdvancedAntiAliasingTable() method to provide continuous stroke modulation (CSM).
Font | The Font class is used to manage embedded fonts in SWF files.
FontStyle | The FontStyle class provides values for the TextRenderer class.
FontType | The FontType class contains the enumerated constants "embedded" and "device" for the fontType property of the Font class.
GridFitType | The GridFitType class defines values for grid fitting in the TextField class.
StaticText | This class represents StaticText objects on the display list.
StyleSheet | The StyleSheet class lets you create a StyleSheet object that contains text formatting rules for font size, color, and other styles.
TextColorType | The TextColorType class provides color values for the flash.text.TextRenderer class.
TextDisplayMode | The TextDisplayMode class contains values that control the subpixel anti-aliasing of the FlashType system.
TextField | The TextField class is used to create display objects for text display and input.
TextFieldAutoSize | The TextFieldAutoSize class is an enumeration of constant values used in setting the autoSize property of the TextField class.
TextFieldType | The TextFieldType class is an enumeration of constant values used in setting the type property of the TextField class.
TextFormat | The TextFormat class represents character formatting information.
TextFormatAlign | The TextFormatAlign class provides values for text alignment in the TextFormat class.
TextLineMetrics | The TextLineMetrics class contains information about the text position and measurements of a line of text within a text field.
TextRenderer | The TextRenderer class provides functionality for the advanced anti-aliasing capability of embedded fonts.
TextSnapshot | TextSnapshot objects let you work with static text in a movie clip.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.text.AntiAliasType (Flex™ 2 Language Reference)

Class AntiAliasType | Properties | Methods | Constants
Package | flash.text
Class | public final class AntiAliasType
Inheritance | AntiAliasType Inheritance Object

The AntiAliasType class provides values for anti-aliasing in the flash.text.TextField class.

See also

flash.text.TextField

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ADVANCED : String = "advanced" [static] Sets anti-aliasing to advanced anti-aliasing. | AntiAliasType
 | NORMAL : String = "normal" [static] Sets anti-aliasing to the anti-aliasing that is used in Flash Player 7 and earlier. | AntiAliasType
Constant detail
ADVANCED constant
public static const ADVANCED:String = "advanced"

Sets anti-aliasing to advanced anti-aliasing. Advanced anti-aliasing allows font faces to be rendered at very high quality at small sizes. It is best used with applications that have a lot of small text. Advanced anti-aliasing is not recommended for very large fonts (larger than 48 points). This constant is used for the antiAliasType property in the TextField class. Use the syntax AntiAliasType.ADVANCED.

See also

flash.text.TextField.antiAliasType
NORMAL constant
public static const NORMAL:String = "normal"

Sets anti-aliasing to the anti-aliasing that is used in Flash Player 7 and earlier. This setting is recommended for applications that do not have a lot of text. This constant is used for the antiAliasType property in the TextField class. Use the syntax AntiAliasType.NORMAL.

See also

flash.text.TextField.antiAliasType


flash.text.CSMSettings (Flex™ 2 Language Reference)

Class CSMSettings | Properties | Methods
Package | flash.text
Class | public final class CSMSettings
Inheritance | CSMSettings Inheritance Object

The CSMSettings class contains properties for use with the TextRenderer.setAdvancedAntiAliasingTable() method to provide continuous stroke modulation (CSM). CSM is the continuous modulation of both stroke weight and edge sharpness.

See also

TextRenderer.setAdvancedAntiAliasingTable()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | fontSize : Number The size, in pixels, for which the settings apply. | CSMSettings
 | insideCutoff : Number The inside cutoff value, above which densities are set to a maximum density value (such as 255). | CSMSettings
 | outsideCutoff : Number The outside cutoff value, below which densities are set to zero. | CSMSettings
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CSMSettings(fontSize:Number, insideCutoff:Number, outsideCutoff:Number) Creates a new CSMSettings object which stores stroke values for custom anti-aliasing settings. | CSMSettings
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
fontSize property
public var fontSize:Number

The size, in pixels, for which the settings apply.

The advancedAntiAliasingTable array passed to the setAdvancedAntiAliasingTable() method can contain multiple entries that specify CSM settings for different font sizes. Using this property, you can specify the font size to which the other settings apply.

See also

TextRenderer.setAdvancedAntiAliasingTable()
insideCutoff property
public var insideCutoff:Number

The inside cutoff value, above which densities are set to a maximum density value (such as 255).

See also

TextRenderer.setAdvancedAntiAliasingTable()
outsideCutoff property
public var outsideCutoff:Number

The outside cutoff value, below which densities are set to zero.

See also

TextRenderer.setAdvancedAntiAliasingTable()
Constructor detail
CSMSettings () constructor
public function CSMSettings(fontSize:Number, insideCutoff:Number, outsideCutoff:Number)

Creates a new CSMSettings object which stores stroke values for custom anti-aliasing settings.

Parameters
fontSize:Number — The size, in pixels, for which the settings apply.
insideCutoff:Number — The inside cutoff value, above which densities are set to a maximum density value (such as 255).
outsideCutoff:Number — The outside cutoff value, below which densities are set to zero.


flash.text.Font (Flex™ 2 Language Reference)

Class Font | Properties | Methods
Package | flash.text
Class | public class Font
Inheritance | Font Inheritance Object

The Font class is used to manage embedded fonts in SWF files. Embedded fonts are represented as a subclass of the Font class. The Font class is currently useful only to find out information about embedded fonts; you cannot alter a font by using this class. You cannot use the Font class to load external fonts, or to create an instance of a Font object by itself. Use the Font class as an abstract base class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | fontName : String [read-only] The name of an embedded font. | Font
 | fontStyle : String [read-only] The style of the font. | Font
 | fontType : String [read-only] The type of the font. | Font
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | enumerateFonts(enumerateDeviceFonts:Boolean = false):Array [static] Specifies whether to provide a list of the currently available embedded fonts. | Font
 | hasGlyphs(str:String):Boolean Specifies whether a provided string can be displayed using the currently assigned font. | Font
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | registerFont(font:Class):void [static] Registers a font class in the global font list. | Font
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
fontName property
fontName:String [read-only]

The name of an embedded font.

Implementation
    public function get fontName():String
fontStyle property
fontStyle:String [read-only]

The style of the font. This value can be any of the values defined in the FontStyle class.

Implementation
    public function get fontStyle():String

See also

flash.text.FontStyle
fontType property
fontType:String [read-only]

The type of the font. This value can be any of the constants defined in the FontType class.

Implementation
    public function get fontType():String

See also

flash.text.FontType
Method detail
enumerateFonts () method
public static function enumerateFonts(enumerateDeviceFonts:Boolean = false):Array

Specifies whether to provide a list of the currently available embedded fonts.

Parameters
enumerateDeviceFonts:Boolean (default = false) — Indicates whether you want to limit the list to only the currently available embedded fonts. If this is set to false then a list of all fonts, both device fonts and embedded fonts, is returned. If this is set to true then only a list of embedded fonts is returned.

Returns
Array — A list of available fonts as an array of Font objects.

Example
This example first calls the static method Font.enumerateFonts() to get a list of all device and embedded fonts. Then it sorts the resulting Array of Font objects by the fontName property.

Next the example shows how to call the Font.enumerateFonts() method with the enumerateDeviceFonts parameter set to false. The resulting Array only includes embedded Font objects. (If you run this code within an application that does not contain any embedded fonts, the embeddedFonts array will be empty.)

import flash.text.Font;

var allFonts:Array = Font.enumerateFonts(true);
allFonts.sortOn("fontName", Array.CASEINSENSITIVE);

var embeddedFonts:Array = Font.enumerateFonts(false);
embeddedFonts.sortOn("fontName", Array.CASEINSENSITIVE);

hasGlyphs () method
public function hasGlyphs(str:String):Boolean

Specifies whether a provided string can be displayed using the currently assigned font.

Parameters
str:String — The string to test against the current font.

Returns
Boolean — A value of true if the specified string can be fully displayed using this font.
registerFont () method
public static function registerFont(font:Class):void

Registers a font class in the global font list.

Parameters
font:Class — The class you want to add to the global font list.


flash.text.FontStyle (Flex™ 2 Language Reference)

Class FontStyle | Properties | Methods | Constants
Package | flash.text
Class | public final class FontStyle
Inheritance | FontStyle Inheritance Object

The FontStyle class provides values for the TextRenderer class.

See also

flash.text.TextRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BOLD : String = "bold" [static] Defines the bold style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. | FontStyle
 | BOLD_ITALIC : String = "boldItalic" [static] Defines the combined bold and italic style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. | FontStyle
 | ITALIC : String = "italic" [static] Defines the italic style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. | FontStyle
 | REGULAR : String = "regular" [static] Defines the plain style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. | FontStyle
Constant detail
BOLD constant
public static const BOLD:String = "bold"

Defines the bold style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. Use the syntax FontStyle.BOLD.

See also

flash.text.TextRenderer.setAdvancedAntiAliasingTable()
BOLD_ITALIC constant
public static const BOLD_ITALIC:String = "boldItalic"

Defines the combined bold and italic style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. Use the syntax FontStyle.BOLD_ITALIC.

See also

flash.text.TextRenderer.setAdvancedAntiAliasingTable()
ITALIC constant
public static const ITALIC:String = "italic"

Defines the italic style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. Use the syntax FontStyle.ITALIC.

See also

flash.text.TextRenderer.setAdvancedAntiAliasingTable()
REGULAR constant
public static const REGULAR:String = "regular"

Defines the plain style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method. Use the syntax FontStyle.NONE.

See also

flash.text.TextRenderer.setAdvancedAntiAliasingTable()


flash.text.FontType (Flex™ 2 Language Reference)

Class FontType | Properties | Methods | Constants
Package | flash.text
Class | public final class FontType
Inheritance | FontType Inheritance Object

The FontType class contains the enumerated constants "embedded" and "device" for the fontType property of the Font class.

See also

flash.text.Font.fontType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DEVICE : String = "device" [static] Indicates that this is a device font. | FontType
 | EMBEDDED : String = "embedded" [static] Indicates that this is an embedded font. | FontType
Constant detail
DEVICE constant
public static const DEVICE:String = "device"

Indicates that this is a device font. Flash Player uses the fonts installed on the system that is running the SWF file.

Using device fonts results in a smaller movie size, because font data is not included in the file. Device fonts are often a good choice for displaying text at small point sizes, because anti-aliased text can be blurry at small sizes. Device fonts are also a good choice for large blocks of text, such as scrolling text.

Text fields that use device fonts may not be displayed the same across different systems and platforms, because Flash Player uses the fonts that are installed on the system. For the same reason, device fonts are not anti-aliased and may appear jagged at large point sizes.

See also

TextField.embedFonts
EMBEDDED constant
public static const EMBEDDED:String = "embedded"

Indicates that this is an embedded font. Font outlines are embedded in the published SWF file.

Text fields that use embedded fonts are always displayed in the chosen font, whether or not that font is installed on the playback system. Also, text fields that use embedded fonts are always anti-aliased (smoothed) by Flash Player. You can select the amount of anti-aliasing you want by using the TextField.antiAliasType property.

One drawback to embedded fonts is that they increase the size of the SWF file.

See also

TextField.embedFonts


flash.text.GridFitType (Flex™ 2 Language Reference)

Class GridFitType | Properties | Methods | Constants
Package | flash.text
Class | public final class GridFitType
Inheritance | GridFitType Inheritance Object

The GridFitType class defines values for grid fitting in the TextField class.

See also

flash.text.TextField

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | NONE : String = "none" [static] Doesn't set grid fitting. | GridFitType
 | PIXEL : String = "pixel" [static] Fits strong horizontal and vertical lines to the pixel grid. | GridFitType
 | SUBPIXEL : String = "subpixel" [static] Fits strong horizontal and vertical lines to the sub-pixel grid on LCD monitors. | GridFitType
Constant detail
NONE constant
public static const NONE:String = "none"

Doesn't set grid fitting. Horizontal and vertical lines in the glyphs are not forced to the pixel grid. This constant is used in setting the gridFitType property of the TextField class. This is often a good setting for animation or for large font sizes. Use the syntax GridFitType.NONE.

See also

flash.text.TextField.gridFitType
PIXEL constant
public static const PIXEL:String = "pixel"

Fits strong horizontal and vertical lines to the pixel grid. This constant is used in setting the gridFitType property of the TextField class. This setting only works for left-justified text fields and acts like the GridFitType.SUBPIXEL constant in static text. This setting generally provides the best readability for left-aligned text. Use the syntax GridFitType.PIXEL.

See also

flash.text.TextField.gridFitType
SUBPIXEL constant
public static const SUBPIXEL:String = "subpixel"

Fits strong horizontal and vertical lines to the sub-pixel grid on LCD monitors. (Red, green, and blue are actual pixels on an LCD screen.) This is often a good setting for right-aligned or center-aligned dynamic text, and it is sometimes a useful tradeoff for animation vs. text quality. This constant is used in setting the gridFitType property of the TextField class. Use the syntax GridFitType.SUBPIXEL.

See also

flash.text.TextField.gridFitType


flash.text.StaticText (Flex™ 2 Language Reference)

Class StaticText | Properties | Methods | Events
Package | flash.text
Class | public final class StaticText
Inheritance | StaticText Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

This class represents StaticText objects on the display list. You cannot create a StaticText object using ActionScript. Only the authoring tool can create a StaticText object. An attempt to create a new StaticText object generates an ArgumentError.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | text : String [read-only] Returns the current text of the static text field. | StaticText
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
text property
text:String [read-only]

Returns the current text of the static text field. The authoring tool may export multiple text field objects comprising the complete text. For example, for vertical text, the authoring tool will create one text field per character.

Implementation
    public function get text():String


flash.text.StyleSheet (Flex™ 2 Language Reference)

Class StyleSheet | Properties | Methods | Examples
Package | flash.text
Class | public dynamic class StyleSheet
Inheritance | StyleSheet Inheritance EventDispatcher Inheritance Object

The StyleSheet class lets you create a StyleSheet object that contains text formatting rules for font size, color, and other styles. You can then apply styles defined by a style sheet to a TextField object that contains HTML- or XML-formatted text. The text in the TextField object is automatically formatted according to the tag styles defined by the StyleSheet object. You can use text styles to define new formatting tags, redefine built-in HTML tags, or create style classes that you can apply to certain HTML tags.

To apply styles to a TextField object, assign the StyleSheet object to a TextField object's styleSheet property.

Flash Player supports a subset of properties in the original CSS1 specification (www.w3.org/TR/REC-CSS1). The following table shows the supported Cascading Style Sheet (CSS) properties and values, as well as their corresponding ActionScript property names. (Each ActionScript property name is derived from the corresponding CSS property name; if the name contains a hyphen, the hyphen is omitted and the subsequent character is capitalized.)

CSS property | ActionScript property | Usage and supported values
color | color | Only hexadecimal color values are supported. Named colors (such as blue) are not supported. Colors are written in the following format: #FF0000.
display | display | Supported values are inline, block, and none.
font-family | fontFamily | A comma-separated list of fonts to use, in descending order of desirability. Any font family name can be used. If you specify a generic font name, it is converted to an appropriate device font. The following font conversions are available: mono is converted to _typewriter, sans-serif is converted to _sans, and serif is converted to _serif.
font-size | fontSize | Only the numeric part of the value is used. Units (px, pt) are not parsed; pixels and points are equivalent.
font-style | fontStyle | Recognized values are normal and italic.
font-weight | fontWeight | Recognized values are normal and bold.
kerning | kerning | Recognized values are true and false. Kerning is supported for embedded fonts only. Certain fonts, such as Courier New, do not support kerning. The kerning property is only supported in SWF files created in Windows, not in SWF files created on the Macintosh. However, these SWF files can be played in non-Windows versions of Flash Player and the kerning still applies.
letter-spacing | letterSpacing | The amount of space that is uniformly distributed between characters. The value specifies the number of pixels that are added to the advance after each character. A negative value condenses the space between characters. Only the numeric part of the value is used. Units (px, pt) are not parsed; pixels and points are equivalent.
margin-left | marginLeft | Only the numeric part of the value is used. Units (px, pt) are not parsed; pixels and points are equivalent.
margin-right | marginRight | Only the numeric part of the value is used. Units (px, pt) are not parsed; pixels and points are equivalent.
text-align | textAlign | Recognized values are left, center, right, and justify.
text-decoration | textDecoration | Recognized values are none and underline.
text-indent | textIndent | Only the numeric part of the value is used. Units (px, pt) are not parsed; pixels and points are equivalent.

You can use the StyleSheet class to perform low-level text rendering. However, in Flex, you typically use the Label, Text, TextArea, and TextInput controls to process text.

For more information, see "Formatting text with Cascading Style Sheets" in Using ActionScript in Flash.

View the examples.

See also

flash.net.URLLoader

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | styleNames : Array [read-only] An array that contains the names (as strings) of all of the styles registered in this style sheet. | StyleSheet
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
StyleSheet()
Creates a new StyleSheet object.
StyleSheet
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
clear():void
Removes all styles from the style sheet object.
StyleSheet
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getStyle(styleName:String):Object
Returns a copy of the style object associated with the style named styleName.
StyleSheet
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
parseCSS(CSSText:String):void
Parses the CSS in CSSText and loads the style sheet with it.
StyleSheet
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setStyle(styleName:String, styleObject:Object):void
Adds a new style with the specified name to the style sheet object.
StyleSheet
Inherited
toString():String
Returns the string representation of the specified object.
Object
transform(formatObject:Object):TextFormat
Extends the CSS parsing capability.
StyleSheet
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
styleNames property
styleNames:Array [read-only]

An array that contains the names (as strings) of all of the styles registered in this style sheet.

Implementation
    public function get styleNames():Array
Constructor detail
StyleSheet () constructor
public function StyleSheet()

Creates a new StyleSheet object.

See also

flash.text.StyleSheet.getStyle()
Method detail
clear () method
public function clear():void

Removes all styles from the style sheet object.

getStyle () method
public function getStyle(styleName:String):Object

Returns a copy of the style object associated with the style named styleName. If there is no style object associated with styleName, null is returned.

Parameters
styleName:String — A string that specifies the name of the style to retrieve.

Returns
Object — An object.

See also

flash.text.StyleSheet.setStyle()
parseCSS () method
public function parseCSS(CSSText:String):void

Parses the CSS in CSSText and loads the style sheet with it. If a style in CSSText is already in styleSheet, the properties in styleSheet are retained, and only the ones in CSSText are added or changed in styleSheet.

To extend the native CSS parsing capability, you can override this method by creating a subclass of the StyleSheet class.

Parameters
CSSText:String — The CSS text to parse (a string).
setStyle () method
public function setStyle(styleName:String, styleObject:Object):void

Adds a new style with the specified name to the style sheet object. If the named style does not already exist in the style sheet, it is added. If the named style already exists in the style sheet, it is replaced. If the styleObject parameter is null, the named style is removed.

Flash Player creates a copy of the style object that you pass to this method.

For a list of supported styles, see the table in the description for the StyleSheet class.

Parameters
styleName:String — A string that specifies the name of the style to add to the style sheet.
styleObject:Object — An object that describes the style, or null.
transform () method
public function transform(formatObject:Object):TextFormat

Extends the CSS parsing capability. Advanced developers can override this method by extending the StyleSheet class.

Parameters
formatObject:Object — An object that describes the style, containing style rules as properties of the object, or null.

Returns
TextFormat — A TextFormat object containing the result of the mapping of CSS rules to text format properties.

See also

flash.text.TextFormat
Examples

The following example creates a new style sheet and assigns bold and red font treatments to the heading style.

package {
    import flash.display.Sprite;
    import flash.text.StyleSheet;
    import flash.text.TextField;
    import flash.text.TextFieldAutoSize;

    public class StyleSheetExample extends Sprite {

        public function StyleSheetExample() {
            var style:StyleSheet = new StyleSheet();

            var heading:Object = new Object();
            heading.fontWeight = "bold";
            heading.color = "#FF0000";

            var body:Object = new Object();
            body.fontStyle = "italic";

            style.setStyle(".heading", heading);
            style.setStyle("body", body);

            var label:TextField = new TextField();
            label.styleSheet = style;
            label.htmlText = "<body><span class='heading'>Hello </span>World...</body>";
            addChild(label);
        }
    }
}


flash.text.TextColorType (Flex™ 2 Language Reference)

Class TextColorType | Properties | Methods | Constants
Package | flash.text
Class | public final class TextColorType
Inheritance | TextColorType Inheritance Object

The TextColorType class provides color values for the flash.text.TextRenderer class.

See also

flash.text.TextRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DARK_COLOR : String = "dark" [static] Used in the colorType parameter in the setAdvancedAntiAliasingTable() method. | TextColorType
 | LIGHT_COLOR : String = "light" [static] Used in the colorType parameter in the setAdvancedAntiAliasingTable() method. | TextColorType
Constant detail
DARK_COLOR constant
public static const DARK_COLOR:String = "dark"

Used in the colorType parameter in the setAdvancedAntiAliasingTable() method. Use the syntax TextColorType.DARK_COLOR.

See also

flash.text.TextRenderer.setAdvancedAntiAliasingTable()
LIGHT_COLOR constant
public static const LIGHT_COLOR:String = "light"

Used in the colorType parameter in the setAdvancedAntiAliasingTable() method. Use the syntax TextColorType.LIGHT_COLOR.

See also

flash.text.TextRenderer.setAdvancedAntiAliasingTable()


flash.text.TextDisplayMode (Flex™ 2 Language Reference)

Class TextDisplayMode | Properties | Methods | Constants
Package | flash.text
Class | public final class TextDisplayMode
Inheritance | TextDisplayMode Inheritance Object

The TextDisplayMode class contains values that control the subpixel anti-aliasing of the FlashType system.

See also

flash.text.TextRenderer.displayMode

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CRT : String = "crt" [static] Forces Flash Player to display grayscale anti-aliasing. | TextDisplayMode
 | DEFAULT : String = "default" [static] Allows Flash Player to choose LCD or CRT mode. | TextDisplayMode
 | LCD : String = "lcd" [static] Forces Flash Player to use LCD subpixel anti-aliasing. | TextDisplayMode
Constant detail
CRT constant
public static const CRT:String = "crt"

Forces Flash Player to display grayscale anti-aliasing. While this setting avoids text coloring, some users may think it appears blurry.

DEFAULT constant
public static const DEFAULT:String = "default"

Allows Flash Player to choose LCD or CRT mode.

LCD constant
public static const LCD:String = "lcd"

Forces Flash Player to use LCD subpixel anti-aliasing. Depending on the font and the hardware, this setting can result in much higher resolution text or text coloring.


flash.text.TextField (Flex™ 2 Language Reference)

Class TextField | Properties | Methods | Events | Examples
Package | flash.text
Class | public class TextField
Inheritance | TextField Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | FlexTextField

The TextField class is used to create display objects for text display and input. All dynamic and input text fields in a SWF file are instances of the TextField class. You can use the TextField class to perform low-level text rendering. However, in Flex, you typically use the Label, Text, TextArea, and TextInput controls to process text. You can give a text field an instance name in the Property inspector and use the methods and properties of the TextField class to manipulate it with ActionScript. TextField instance names are displayed in the Movie Explorer and in the Insert Target Path dialog box in the Actions panel.

To create a text field dynamically, use the TextField() constructor.

The methods of the TextField class let you set, select, and manipulate text in a dynamic or input text field that you create during authoring or at runtime.

ActionScript provides several ways to format your text at runtime. The TextFormat class lets you set character and paragraph formatting for TextField objects. You can apply Cascading Style Sheets (CSS) styles to text fields by using the TextField.styleSheet property and the StyleSheet class. You can use CSS to style built-in HTML tags, define new formatting tags, or apply styles. You can assign HTML formatted text, which might optionally use CSS styles, directly to a text field. HTML text that you assign to a text field can contain embedded media (movie clips, SWF files, GIF files, PNG files, and JPEG files). The text wraps around the embedded media in the same way that a web browser wraps text around media embedded in an HTML document.

Flash Player supports a subset of HTML tags that you can use to format text. See the list of supported HTML tags in the description of the htmlText property.

View the examples.

See also

flash.text.TextFormat
flash.text.StyleSheet
Understanding the display architecture
Working with text

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | alwaysShowSelection : Boolean When set to true and the text field is not in focus, Flash Player highlights the selection in the text field in gray. | TextField
 | antiAliasType : String The type of anti-aliasing used for this text field. | TextField
 | autoSize : String Controls automatic sizing and alignment of text fields. | TextField
 | background : Boolean Specifies whether the text field has a background fill. | TextField
 | backgroundColor : uint The color of the text field background. | TextField
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
 | border : Boolean Specifies whether the text field has a border. | TextField
 | borderColor : uint The color of the text field border. | TextField
 | bottomScrollV : int [read-only] An integer (1-based index) that indicates the bottommost line that is currently visible in the specified text field. | TextField
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
 | caretIndex : int [read-only] The index of the insertion point (caret) position. | TextField
 | condenseWhite : Boolean A Boolean value that specifies whether extra white space (spaces, line breaks, and so on) in a text field with HTML text should be removed. | TextField
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | defaultTextFormat : TextFormat Specifies the format applied to newly inserted text, such as text inserted with the replaceSelectedText() method or text entered by a user. | TextField
 | displayAsPassword : Boolean Specifies whether the text field is a password text field. | TextField
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
 | embedFonts : Boolean Specifies whether to render by using embedded font outlines. | TextField
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
 | gridFitType : String The type of grid fitting used for this text field. | TextField
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
 | htmlText : String Contains the HTML representation of the text field's contents. | TextField
 | length : int [read-only] The number of characters in a text field. | TextField
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxChars : int The maximum number of characters that the text field can contain, as entered by a user. | TextField
 | maxScrollH : int [read-only] The maximum value of scrollH. | TextField
 | maxScrollV : int [read-only] The maximum value of scrollV. | TextField
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
 | mouseWheelEnabled : Boolean A Boolean value that indicates whether Flash Player should automatically scroll multiline text fields when the user clicks a text field and rolls the mouse wheel. | TextField
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
 | multiline : Boolean Indicates whether the text field is a multiline text field. | TextField
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | numLines : int [read-only] Defines the number of text lines in a multiline text field. | TextField
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | restrict : String Indicates the set of characters that a user can enter into the text field. | TextField
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
 | scrollH : int The current horizontal scrolling position. | TextField
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | scrollV : int The vertical position of text in a text field. | TextField
 | selectable : Boolean A Boolean value that indicates whether the text field is selectable. | TextField
 | selectionBeginIndex : int [read-only] The zero-based character index value of the first character in the current selection. | TextField
 | selectionEndIndex : int [read-only] The zero-based character index value of the last character in the current selection. | TextField
 | sharpness : Number The sharpness of the glyph edges in this text field. | TextField
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | styleSheet : StyleSheet Attaches a style sheet to the text field. | TextField
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String A string that is the current text in the text field. | TextField
 | textColor : uint The color of the text in a text field, in hexadecimal format. | TextField
 | textHeight : Number [read-only] The height of the text in pixels. | TextField
 | textWidth : Number [read-only] The width of the text in pixels. | TextField
 | thickness : Number The thickness of the glyph edges in this text field. | TextField
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | type : String The type of the text field. | TextField
 | useRichTextClipboard : Boolean Specifies whether to copy and paste the text formatting along with the text. | TextField
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
 | wordWrap : Boolean A Boolean value that indicates whether the text field has word wrap. | TextField
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TextField()
Creates a new TextField instance.
TextField
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
appendText(newText:String):void
Appends the string specified by the newText parameter to the end of the text of the TextField.
TextField
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
getCharBoundaries(charIndex:int):Rectangle
Returns a rectangle that is the bounding box of the character.
TextField
getCharIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the character at the point specified by the x and y parameters.
TextField
getFirstCharInParagraph(charIndex:int):int
Given a character index, returns the index of the first character in the same paragraph.
TextField
getImageReference(id:String):DisplayObject
Returns a DisplayObject reference for the given id, for an image or SWF file that has been added to an HTML-formatted text field by using an <img> tag.
TextField
getLineIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the line at the point specified by the x and y parameters.
TextField
getLineIndexOfChar(charIndex:int):int
Returns the zero-based index value of the line containing the character specified by the charIndex parameter.
TextField
getLineLength(lineIndex:int):int
Returns the number of characters in a specific text line.
TextField
getLineMetrics(lineIndex:int):TextLineMetrics
Returns metrics information about a given text line.
TextField
getLineOffset(lineIndex:int):int
Returns the character index of the first character in the line that the lineIndex parameter specifies.
TextField
getLineText(lineIndex:int):String
Returns the text of the line specified by the lineIndex parameter.
TextField
getParagraphLength(charIndex:int):int
Given a character index, returns the length of the paragraph containing the given character.
TextField
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
getTextFormat(beginIndex:int = -1, endIndex:int = -1):TextFormat
Returns a TextFormat object that contains formatting information for the range of text that the beginIndex and endIndex parameters specify.
TextField
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
replaceSelectedText(value:String):void
Replaces the current selection with the contents of the value parameter.
TextField
replaceText(beginIndex:int, endIndex:int, newText:String):void
Replaces the range of characters that the beginIndex and endIndex parameters specify with the contents of the newText parameter.
TextField
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setSelection(beginIndex:int, endIndex:int):void
Sets as selected the text designated by the index values of the first and last characters, which are specified with the beginIndex and endIndex parameters.
TextField
setTextFormat(format:TextFormat, beginIndex:int = -1, endIndex:int = -1):void
Applies the text formatting that the format parameter specifies to the specified text in a text field.
TextField
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched after a control's value is modified. | TextField
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
 | link | Dispatched when a user clicks a hyperlink in an HTML-enabled text field, where the URL begins with "event:". | TextField
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | scroll | Dispatched by a TextField object after the user scrolls. | TextField
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
 | textInput | Flash Player dispatches the textInput event when a user enters one or more characters of text. | TextField
Property detail
alwaysShowSelection property
alwaysShowSelection:Boolean [read-write]

When set to true and the text field is not in focus, Flash Player highlights the selection in the text field in gray. When set to false and the text field is not in focus, Flash Player does not highlight the selection in the text field.

The default value is false.

Implementation
    public function get alwaysShowSelection():Boolean
    public function set alwaysShowSelection(value:Boolean):void

See also

flash.display.Stage.focus

Example
Compile and run the following file. When you run the file, drag to select text in each of the two text fields, and notice the difference in selection highlighting when you select text in the two text fields (changing focus):

    package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.text.TextFieldType;

    public class TextField_alwaysShowSelection extends Sprite {
        public function TextField_alwaysShowSelection() {
            var label1:TextField = createTextField(0, 20, 200, 20);
            label1.text = "This text is selected.";
            label1.setSelection(0, 9);
            label1.alwaysShowSelection = true;

            var label2:TextField = createTextField(0, 50, 200, 20);
            label2.text = "Drag to select some of this text.";
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x; result.y = y;
            result.width = width; result.height = height;
            addChild(result);
            return result;
        }
    }
}

antiAliasType property
antiAliasType:String [read-write]

The type of anti-aliasing used for this text field. Use flash.text.AntiAliasType constants for this property. You can control this setting only if the font is embedded (with the embedFonts property set to true). The default setting is flash.text.AntiAliasType.ADVANCED.

To set values for this property, use the following string values:

String value | Description
flash.text.AntiAliasType.NORMAL | Applies the regular text anti-aliasing. This matches the type of anti-aliasing that Flash Player 7 and earlier versions used.
flash.text.AntiAliasType.ADVANCED | Applies advanced anti-aliasing, which makes text more legible. (This feature became available in Flash Player 8.) Advanced anti-aliasing allows for high-quality rendering of font faces at small sizes. It is best used with applications that have a lot of small text. Advanced anti-aliasing is not recommended for fonts that are larger than 48 points.
Implementation
    public function get antiAliasType():String
    public function set antiAliasType(value:String):void

See also

flash.text.AntiAliasType
flash.text.TextField.embedFonts
autoSize property
autoSize:String [read-write]

Controls automatic sizing and alignment of text fields. Acceptable values for the TextFieldAutoSize constants: TextFieldAutoSize.NONE (the default), TextFieldAutoSize.LEFT, TextFieldAutoSize.RIGHT, and TextFieldAutoSize.CENTER.

If autoSize is set to TextFieldAutoSize.NONE (the default) no resizing occurs.

If autoSize is set to TextFieldAutoSize.LEFT, the text is treated as left-justified text, meaning that the left margin of the text field remains fixed and any resizing of a single line of the text field is on the right margin. If the text includes a line break (for example, "\n" or "\r"), the bottom is also resized to fit the next line of text. If wordWrap is also set to true, only the bottom of the text field is resized and the right side remains fixed.

If autoSize is set to TextFieldAutoSize.RIGHT, the text is treated as right-justified text, meaning that the right margin of the text field remains fixed and any resizing of a single line of the text field is on the left margin. If the text includes a line break (for example, "\n" or "\r"), the bottom is also resized to fit the next line of text. If wordWrap is also set to true, only the bottom of the text field is resized and the left side remains fixed.

If autoSize is set to TextFieldAutoSize.CENTER, the text is treated as center-justified text, meaning that any resizing of a single line of the text field is equally distributed to both the right and left margins. If the text includes a line break (for example, "\n" or "\r"), the bottom is also resized to fit the next line of text. If wordWrap is also set to true, only the bottom of the text field is resized and the left and right sides remain fixed.

Implementation
    public function get autoSize():String
    public function set autoSize(value:String):void

Throws
ArgumentError — The autoSize specified is not a member of flash.text.TextFieldAutoSize.

See also

flash.text.TextFieldAutoSize
flash.text.TextField.autoSize
flash.text.TextField.wordWrap
background property
background:Boolean [read-write]

Specifies whether the text field has a background fill. If true, the text field has a background fill. If false, the text field has no background fill. Use the backgroundColor property to set the background color of a text field.

The default value is false.

Implementation
    public function get background():Boolean
    public function set background(value:Boolean):void

See also

flash.text.TextField.backgroundColor
backgroundColor property
backgroundColor:uint [read-write]

The color of the text field background. The default value is 0xFFFFFF (white). This property can be retrieved or set, even if there currently is no background, but the color is visible only if the text field has the background property set to true.

Implementation
    public function get backgroundColor():uint
    public function set backgroundColor(value:uint):void

See also

flash.text.TextField.background
border property
border:Boolean [read-write]

Specifies whether the text field has a border. If true, the text field has a border. If false, the text field has no border. Use the borderColor property to set the border color.

The default value is false.

Implementation
    public function get border():Boolean
    public function set border(value:Boolean):void

See also

flash.text.TextField.borderColor
borderColor property
borderColor:uint [read-write]

The color of the text field border. The default value is 0x000000 (black). This property can be retrieved or set, even if there currently is no border, but the color is visible only if the text field has the border property set to true.

Implementation
    public function get borderColor():uint
    public function set borderColor(value:uint):void

See also

flash.text.TextField.border
bottomScrollV property
bottomScrollV:int [read-only]

An integer (1-based index) that indicates the bottommost line that is currently visible in the specified text field. Think of the text field as a window onto a block of text. The scrollV property is the 1-based index of the topmost visible line in the window.

All the text between the lines indicated by scrollV and bottomScrollV is currently visible in the text field.

Implementation
    public function get bottomScrollV():int

See also

flash.text.TextField.scrollV
caretIndex property
caretIndex:int [read-only]

The index of the insertion point (caret) position. If no insertion point is displayed, the value is the position the insertion point would be if you restored focus to the field (typically where the insertion point last was, or 0 if the field has not had focus).

Selection span indexes are zero-based (for example, the first position is 0, the second position is 1, and so on).

Implementation
    public function get caretIndex():int

See also

selectable
selectionBeginIndex
selectionEndIndex

Example
In this example, a TextField instance is created and populated with text. An event listener is assigned so that when the user clicks on the TextField, the printCursorPosition method is called. In that case, the values of the caretIndex, selectionBeginIndex, and selectionEndIndex properties are output.

Run this example and try clicking in the TextField to select text. Then click in the field without selecting text. When you click in the text without making a selection, the caretIndex property indicates where the insertion point occurs, and the selectionBeginIndex and selectionEndIndex properties equal the caretIndex property value.

package {
    import flash.display.Sprite;
    import flash.events.MouseEvent;
    import flash.text.TextField;
    import flash.text.TextFieldType;

    public class TextField_caretIndex extends Sprite {
        public function TextField_caretIndex() {
            var tf:TextField = createTextField(10, 10, 100, 100);
            tf.wordWrap = true;
            tf.type = TextFieldType.INPUT;
            tf.text = "Click in this text field. Compare the difference between clicking without selecting versus clicking and selecting text.";
            tf.addEventListener(MouseEvent.CLICK, printCursorPosition);
        }

        private function printCursorPosition(event:MouseEvent):void {
            var tf:TextField = TextField(event.target);
            trace("caretIndex:", tf.caretIndex);
            trace("selectionBeginIndex:", tf.selectionBeginIndex);
            trace("selectionEndIndex:", tf.selectionEndIndex);
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            addChild(result);
            return result;
        }
    }
}

condenseWhite property
condenseWhite:Boolean [read-write]

A Boolean value that specifies whether extra white space (spaces, line breaks, and so on) in a text field with HTML text should be removed. The default value is false. The condenseWhite property only affects text set with the htmlText property, not the text property. If you set text with the text property, condenseWhite is ignored.

If you set condenseWhite to true, you must use standard HTML commands such as <BR> and <P> to place line breaks in the text field.

Set the condenseWhite property before setting the htmlText property.

Implementation
    public function get condenseWhite():Boolean
    public function set condenseWhite(value:Boolean):void

See also

flash.text.TextField.htmlText

Example
The following shows the difference between setting the condenseWhite setting to false and setting it to true:

package {
    import flash.display.Sprite;
    import flash.text.TextField;

    public class TextField_condenseWhite extends Sprite {
        public function TextField_condenseWhite() {
            var tf1:TextField = createTextField(0, 0, 200, 50);
            tf1.condenseWhite = false;
            tf1.htmlText = "keep    on\n\ttruckin'";

            var tf2:TextField = createTextField(0, 120, 200, 50);
            tf2.condenseWhite = true;
            tf2.htmlText = "keep    on\n\ttruckin'";
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            result.border = true;
            addChild(result);
            return result;
        }
    }
}

defaultTextFormat property
defaultTextFormat:TextFormat [read-write]

Specifies the format applied to newly inserted text, such as text inserted with the replaceSelectedText() method or text entered by a user.

When you access the defaultTextFormat property, the returned TextFormat object has all of its properties defined. No property is null.

Implementation
    public function get defaultTextFormat():TextFormat
    public function set defaultTextFormat(value:TextFormat):void

Throws
Error — This method cannot be used on a text field with a style sheet.

See also

flash.text.TextField.replaceSelectedText()
flash.text.TextField.getTextFormat()
flash.text.TextField.setTextFormat()
displayAsPassword property
displayAsPassword:Boolean [read-write]

Specifies whether the text field is a password text field. If the value of this property is true, the text field is treated as a password text field and hides the input characters using asterisks instead of the actual characters. If false, the text field is not treated as a password text field. When password mode is enabled, the Cut and Copy commands and their corresponding keyboard shortcuts will not function. This security mechanism prevents an unscrupulous user from using the shortcuts to discover a password on an unattended computer.

The default value is false.

Implementation
    public function get displayAsPassword():Boolean
    public function set displayAsPassword(value:Boolean):void
embedFonts property
embedFonts:Boolean [read-write]

Specifies whether to render by using embedded font outlines. If false, Flash Player renders the text field by using device fonts.

If you set the embedFonts property to true for a text field, you must specify a font for that text by using the font property of a TextFormat object applied to the text field. If the specified font is not embedded in the SWF file, the text is not displayed.

The default value is false.

Implementation
    public function get embedFonts():Boolean
    public function set embedFonts(value:Boolean):void

See also

Font.enumerateFonts()
gridFitType property
gridFitType:String [read-write]

The type of grid fitting used for this text field. This property applies only if the flash.text.AntiAliasType property of the text field is set to flash.text.AntiAliasType.ADVANCED.

The type of grid fitting used determines whether Flash Player forces strong horizontal and vertical lines to fit to a pixel or subpixel grid, or not at all.

For the flash.text.GridFitType property, you can use the following string values:

String value | Description
flash.text.GridFitType.NONE | Specifies no grid fitting. Horizontal and vertical lines in the glyphs are not forced to the pixel grid. This setting is usually good for animation or for large font sizes.
flash.text.GridFitType.PIXEL | Specifies that strong horizontal and vertical lines are fit to the pixel grid. This setting works only for left-aligned text fields. To use this setting, the flash.dispaly.AntiAliasType property of the text field must be set to flash.text.AntiAliasType.ADVANCED. This setting generally provides the best legibility for left-aligned text.
flash.text.GridFitType.SUBPIXEL | Specifies that strong horizontal and vertical lines are fit to the subpixel grid on an LCD monitor. To use this setting, the flash.text.AntiAliasType property of the text field must be set to flash.text.AntiAliasType.ADVANCED. The flash.text.GridFitType.SUBPIXEL setting is often good for right-aligned or centered dynamic text, and it is sometimes a useful trade-off for animation versus text quality.

The default value is pixel.

Implementation
    public function get gridFitType():String
    public function set gridFitType(value:String):void

See also

flash.text.GridFitType
flash.text.TextField.antiAliasType
flash.text.AntiAliasType
htmlText property
htmlText:String [read-write]

Contains the HTML representation of the text field's contents.

Flash Player supports the following HTML tags:

Tag | Description
Anchor tag The <a> tag creates a hypertext link and supports the following attributes:
  • href—The URL can be either absolute or relative to the location of the SWF file that is loading the page. An example of an absolute reference to a URL is http://www.adobe.com; an example of a relative reference is /index.html. Absolute URLs must be prefixed with http://; otherwise, Flash treats them as relative URLs.
  • event—Use the event attribute to specify the text property of the link TextEvent that is dispatched when the user clicks the hypertext link. An example is event:myEvent; when the user clicks this hypertext link, the text field dispatches a link TextEvent with its text property set to "myEvent".
  • target—Specifies the name of the target window where you load the page. Options include _self, _blank, _parent, and _top. The _self option specifies the current frame in the current window, _blank specifies a new window, _parent specifies the parent of the current frame, and _top specifies the top-level frame in the current window.

You can use the link event to cause the link to execute an ActionScript function in a SWF file instead of opening a URL.

You can also define a:link, a:hover, and a:active styles for anchor tags by using style sheets.

Bold tag | The <b> tag renders text as bold. A bold typeface must be available for the font used.
Break tag | The <br> tag creates a line break in the text field. You must set the text field to be a multiline text field to use this tag.
Font tag The <font> tag specifies a font or list of fonts to display the text.The font tag supports the following attributes:
  • color—Only hexadecimal color (#FFFFFF) values are supported.
  • face—Specifies the name of the font to use. As shown in the following example, you can specify a list of comma-delimited font names, in which case Flash Player selects the first available font. If the specified font is not installed on the user's computer system or isn't embedded in the SWF file, Flash Player selects a substitute font.
  • size—Specifies the size of the font. You can use absolute pixel sizes, such as 16 or 18, or relative point sizes, such as +2 or -4.
Image tag The <img> tag lets you embed external image files (JPEG, GIF, PNG), SWF files, and movie clips inside text fields. Text automatically flows around images you embed in text fields. To use this tag, you must set the text field to be multiline and to wrap text.

The <img> tag supports the following attributes:

  • src—Specifies the URL to an image or SWF file, or the linkage identifier for a movie clip symbol in the library. This attribute is required; all other attributes are optional. External files (JPEG, GIF, PNG, and SWF files) do not show until they are downloaded completely.
  • width—The width of the image, SWF file, or movie clip being inserted, in pixels.
  • height—The height of the image, SWF file, or movie clip being inserted, in pixels.
  • align—Specifies the horizontal alignment of the embedded image within the text field. Valid values are left and right. The default value is left.
  • hspace—Specifies the amount of horizontal space that surrounds the image where no text appears. The default value is 8.
  • vspace—Specifies the amount of vertical space that surrounds the image where no text appears. The default value is 8.
  • id—Specifies the name for the movie clip instance (created by Flash Player) that contains the embedded image file, SWF file, or movie clip. This is useful if you want to control the embedded content with ActionScript.
  • checkPolicyFile—Specifies that Flash Player will check for a cross-domain policy file on the server associated with the image's domain. If a cross-domain policy file exists, SWF files in the domains listed in the file can access the data of the loaded image, for instance by calling the BitmapData.draw() method with this image as the source parameter. For more information, see the "Flash Player Security" chapter in Programming ActionScript 3.0.

Flash displays media embedded in a text field at full size. To specify the dimensions of the media you are embedding, use the <img> tag's height and width attributes.

In general, an image embedded in a text field appears on the line following the <img> tag. However, when the <img> tag is the first character in the text field, the image appears on the first line of the text field.

Italic tag | The <i> tag displays the tagged text in italics. An italic typeface must be available for the font used.
List item tag | The <li> tag places a bullet in front of the text that it encloses. Note: Because Flash Player does not recognize ordered and unordered list tags (<ol> and <ul>, they do not modify how your list is rendered. All lists are unordered and all list items use bullets.
Paragraph tag The <p> tag creates a new paragraph. You must set the text field to be a multiline text field to use this tag. The <p> tag supports the following attributes:
  • align—Specifies alignment of text within the paragraph; valid values are left, right, justify, and center.
  • class—Specifies a CSS style class defined by a flash.text.StyleSheet object.
Span tag The <span> tag is available only for use with CSS text styles. It supports the following attribute:
  • class—Specifies a CSS style class defined by a flash.text.StyleSheet object.
Text format tag

The <textformat> tag lets you use a subset of paragraph formatting properties of the TextFormat class within text fields, including line leading, indentation, margins, and tab stops. You can combine <textformat> tags with the built-in HTML tags.

The <textformat> tag has the following attributes:

  • blockindent—Specifies the block indentation in points; corresponds to TextFormat.blockIndent.
  • indent—Specifies the indentation from the left margin to the first character in the paragraph; corresponds to TextFormat.indent. Both positive and negative numbers are acceptable.
  • leading—Specifies the amount of leading (vertical space) between lines; corresponds to TextFormat.leading. Both positive and negative numbers are acceptable.
  • leftmargin—Specifies the left margin of the paragraph, in points; corresponds to TextFormat.leftMargin.
  • rightmargin—Specifies the right margin of the paragraph, in points; corresponds to TextFormat.rightMargin.
  • tabstops—Specifies custom tab stops as an array of non-negative integers; corresponds to TextFormat.tabStops.
Underline tag | The <u> tag underlines the tagged text.

Flash Player supports the following HTML entities:

Entity | Description
&lt; | < (less than)
&gt; | > (greater than)
&amp; | & (ampersand)
&quot; | " (double quotes)
&apos; | ' (apostrophe, single quote)

Flash also supports explicit character codes, such as &#38; (ASCII ampersand) and &#x20AC; (Unicode € symbol).

Implementation
    public function get htmlText():String
    public function set htmlText(value:String):void

See also

flash.text.TextField.text
flash.text.StyleSheet
flash.events.TextEvent

Example
The following example creates a TextField called tf1, and assigns an HTML-formatted String to its text property. When its htmlText property is traced, the output is the HTML-formatted String, with additional tags (such as <P> and <FONT>) automatically added by Flash Player. When the value of the text property is traced, the unformatted string without HTML tags is displayed.

By way of comparison, the same steps are performed on another TextField object named tf2, with the addition that a StyleSheet object is assigned to tf2's styleSheet property before its htmlText property is set. In that case, when the htmlText property is traced, it only includes the exact HTML text that was originally assigned to the htmlText property, showing that no additional tags were added by Flash Player.

package {
    import flash.display.Sprite;
    import flash.text.StyleSheet;
    import flash.text.TextField;

    public class TextField_text extends Sprite {
        public function TextField_text() {
            var tf1:TextField = createTextField(10, 10, 400, 22);
            tf1.htmlText = "<b>Lorem ipsum dolor sit amet.</b>";

            // htmlText: <P ALIGN="LEFT"><FONT FACE="Times New Roman" SIZE="12" COLOR="#000000" LETTERSPACING="0" KERNING="0">&lt;b&gt;Lorem ipsum dolor sit amet.&lt;/b&gt;</FONT></P>
            trace("htmlText: " + tf1.htmlText);
            // text: Lorem ipsum dolor sit amet.
            trace("text: " + tf1.text);

            var tf2:TextField = createTextField(10, 50, 400, 22);
            tf2.styleSheet = new StyleSheet();
            tf2.htmlText = "<b>Lorem ipsum dolor sit amet.</b>";
            // htmlText: <b>Lorem ipsum dolor sit amet.</b>
            trace("htmlText: " + tf2.htmlText);
            // text: Lorem ipsum dolor sit amet.
            trace("text: " + tf2.text);
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            addChild(result);
            return result;
        }
    }
}

length property
length:int [read-only]

The number of characters in a text field. A character such as tab (\t) counts as one character.

Implementation
    public function get length():int
maxChars property
maxChars:int [read-write]

The maximum number of characters that the text field can contain, as entered by a user. A script can insert more text than maxChars allows; the maxChars property indicates only how much text a user can enter. If the value of this property is null, a user can enter an unlimited amount of text.

Implementation
    public function get maxChars():int
    public function set maxChars(value:int):void
maxScrollH property
maxScrollH:int [read-only]

The maximum value of scrollH.

Implementation
    public function get maxScrollH():int

See also

flash.text.TextField.scrollH
maxScrollV property
maxScrollV:int [read-only]

The maximum value of scrollV.

Implementation
    public function get maxScrollV():int

See also

flash.text.TextField.scrollV
mouseWheelEnabled property
mouseWheelEnabled:Boolean [read-write]

A Boolean value that indicates whether Flash Player should automatically scroll multiline text fields when the user clicks a text field and rolls the mouse wheel. By default, this value is true. This property is useful if you want to prevent mouse wheel scrolling of text fields, or implement your own text field scrolling.

Implementation
    public function get mouseWheelEnabled():Boolean
    public function set mouseWheelEnabled(value:Boolean):void
multiline property
multiline:Boolean [read-write]

Indicates whether the text field is a multiline text field. If the value is true, the text field is multiline; if the value is false, the text field is a single-line text field.

The default value is false.

Implementation
    public function get multiline():Boolean
    public function set multiline(value:Boolean):void

See also

numLines
numLines property
numLines:int [read-only]

Defines the number of text lines in a multiline text field. If wordWrap property is set to true, the number of lines increases when text wraps.

Implementation
    public function get numLines():int

See also

multiline
wordWrap
restrict property
restrict:String [read-write]

Indicates the set of characters that a user can enter into the text field. If the value of the restrict property is null, you can enter any character. If the value of the restrict property is an empty string, you cannot enter any character. If the value of the restrict property is a string of characters, you can enter only characters in the string into the text field. The string is scanned from left to right. You can specify a range by using the hyphen (-) character. This only restricts user interaction; a script may put any text into the text field. This property does not synchronize with the Embed font options in the Property inspector.

If the string begins with a caret (^) character, all characters are initially accepted and succeeding characters in the string are excluded from the set of accepted characters. If the string does not begin with a caret (^) character, no characters are initially accepted and succeeding characters in the string are included in the set of accepted characters.

The following example allows only uppercase characters, spaces, and numbers to be entered into a text field:

  my_txt.restrict = "A-Z 0-9";

The following example includes all characters, but excludes lowercase letters:

  my_txt.restrict = "^a-z";

You can use a backslash to enter a ^ or - verbatim. The accepted backslash sequences are \-, \^ or \\. The backslash must be an actual character in the string, so when specified in ActionScript, a double backslash must be used. For example, the following code includes only the dash (-) and caret (^):

  my_txt.restrict = "\\-\\^";

The ^ may be used anywhere in the string to toggle between including characters and excluding characters. The following code includes only uppercase letters, but excludes the uppercase letter Q:

  my_txt.restrict = "A-Z^Q";

You can use the u escape sequence to construct restrict strings. The following code includes only the characters from ASCII 32 (space) to ASCII 126 (tilde).

  my_txt.restrict = " -~";

The default value is null.

Implementation
    public function get restrict():String
    public function set restrict(value:String):void
scrollH property
scrollH:int [read-write]

The current horizontal scrolling position. If the scrollH property is 0, the text is not horizontally scrolled. This property value is an integer that represents the horizontal position in pixels.

For more information on scrolling text, see the Programming ActionScript 3.0 book.

The units of horizontal scrolling are pixels, whereas the units of vertical scrolling are lines. Horizontal scrolling is measured in pixels because most fonts you typically use are proportionally spaced; that is, the characters can have different widths. Flash Player performs vertical scrolling by line because users usually want to see a complete line of text rather than a partial line. Even if a line uses multiple fonts, the height of the line adjusts to fit the largest font in use.

Note: The scrollH property is zero-based, not 1-based like the scrollV vertical scrolling property.

Implementation
    public function get scrollH():int
    public function set scrollH(value:int):void

See also

flash.text.TextField.maxScrollH
flash.text.TextField.scrollV
scrollV property
scrollV:int [read-write]

The vertical position of text in a text field. The scrollV property is useful for directing users to a specific paragraph in a long passage, or creating scrolling text fields.

The units of vertical scrolling are lines, whereas the units of horizontal scrolling are pixels. If the first line displayed is the first line in the text field, scrollV is set to 1 (not 0). Horizontal scrolling is measured in pixels because most fonts are proportionally spaced; that is, the characters can have different widths. Flash performs vertical scrolling by line because users usually want to see a complete line of text rather than a partial line. Even if there are multiple fonts on a line, the height of the line adjusts to fit the largest font in use.

For more information on scrolling text, see "Creating scrolling text" in Using Flash.

 Implementation
    public function get scrollV():int
    public function set scrollV(value:int):void

See also

flash.text.TextField.scrollH
flash.text.TextField.maxScrollV
selectable property
selectable:Boolean [read-write]

A Boolean value that indicates whether the text field is selectable. The value true indicates that the text is selectable. The selectable property controls whether a text field is selectable, not whether a text field is editable. A dynamic text field can be selectable even if it is not editable. If a dynamic text field is not selectable, the user cannot select its text.

If selectable is set to false, the text in the text field does not respond to selection commands from the mouse or keyboard, and the text cannot be copied with the Copy command. If selectable is set to true, the text in the text field can be selected with the mouse or keyboard, and the text can be copied with the Copy command. You can select text this way even if the text field is a dynamic text field instead of an input text field.

The default value is true.

Implementation
    public function get selectable():Boolean
    public function set selectable(value:Boolean):void

See also

setSelection()
selectionBeginIndex
selectionEndIndex
setSelection()
caretIndex
selectionBeginIndex property
selectionBeginIndex:int [read-only]

The zero-based character index value of the first character in the current selection. For example, the first character is 0, the second character is 1, and so on. If no text is selected, this property is the value of caretIndex.

Implementation
    public function get selectionBeginIndex():int

See also

selectable
selectionEndIndex
setSelection()
caretIndex

Example
In this example, a TextField instance is created and populated with text. An event listener is assigned so that when the user clicks on the TextField, the printCursorPosition method is called. In that case, the values of the caretIndex, selectionBeginIndex, and selectionEndIndex properties are output.

Run this example and try clicking in the TextField to select text. Then click in the field without selecting text. When you click in the text without making a selection, the caretIndex property indicates where the insertion point occurs, and the selectionBeginIndex and selectionEndIndex properties equal the caretIndex property value.

package {
    import flash.display.Sprite;
    import flash.events.MouseEvent;
    import flash.text.TextField;
    import flash.text.TextFieldType;

    public class TextField_caretIndex extends Sprite {
        public function TextField_caretIndex() {
            var tf:TextField = createTextField(10, 10, 100, 100);
            tf.wordWrap = true;
            tf.type = TextFieldType.INPUT;
            tf.text = "Click in this text field. Compare the difference between clicking without selecting versus clicking and selecting text.";
            tf.addEventListener(MouseEvent.CLICK, printCursorPosition);
        }

        private function printCursorPosition(event:MouseEvent):void {
            var tf:TextField = TextField(event.target);
            trace("caretIndex:", tf.caretIndex);
            trace("selectionBeginIndex:", tf.selectionBeginIndex);
            trace("selectionEndIndex:", tf.selectionEndIndex);
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            addChild(result);
            return result;
        }
    }
}

selectionEndIndex property
selectionEndIndex:int [read-only]

The zero-based character index value of the last character in the current selection. For example, the first character is 0, the second character is 1, and so on. If no text is selected, this property is the value of caretIndex.

Implementation
    public function get selectionEndIndex():int

See also

selectable
selectionBeginIndex
setSelection()
caretIndex

Example
In this example, a TextField instance is created and populated with text. An event listener is assigned so that when the user clicks on the TextField, the printCursorPosition method is called. In that case, the values of the caretIndex, selectionBeginIndex, and selectionEndIndex properties are output.

Run this example and try clicking in the TextField to select text. Then click in the field without selecting text. When you click in the text without making a selection, the caretIndex property indicates where the insertion point occurs, and the selectionBeginIndex and selectionEndIndex properties equal the caretIndex property value.

package {
    import flash.display.Sprite;
    import flash.events.MouseEvent;
    import flash.text.TextField;
    import flash.text.TextFieldType;

    public class TextField_caretIndex extends Sprite {
        public function TextField_caretIndex() {
            var tf:TextField = createTextField(10, 10, 100, 100);
            tf.wordWrap = true;
            tf.type = TextFieldType.INPUT;
            tf.text = "Click in this text field. Compare the difference between clicking without selecting versus clicking and selecting text.";
            tf.addEventListener(MouseEvent.CLICK, printCursorPosition);
        }

        private function printCursorPosition(event:MouseEvent):void {
            var tf:TextField = TextField(event.target);
            trace("caretIndex:", tf.caretIndex);
            trace("selectionBeginIndex:", tf.selectionBeginIndex);
            trace("selectionEndIndex:", tf.selectionEndIndex);
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            addChild(result);
            return result;
        }
    }
}

sharpness property
sharpness:Number [read-write]

The sharpness of the glyph edges in this text field. This property applies only if the flash.text.AntiAliasType property of the text field is set to flash.text.AntiAliasType.ADVANCED. The range for sharpness is a number from -400 to 400. If you attempt to set sharpness to a value outside that range, Flash sets the property to the nearest value in the range (either -400 or 400).

The default value is 0.

Implementation
    public function get sharpness():Number
    public function set sharpness(value:Number):void

See also

flash.text.TextField.antiAliasType
flash.text.AntiAliasType
styleSheet property
styleSheet:StyleSheet [read-write]

Attaches a style sheet to the text field. For information on creating style sheets, see the StyleSheet class and Programming ActionScript 3.0.

You can change the style sheet associated with a text field at any time. If you change the style sheet in use, the text field is redrawn with the new style sheet. You can set the style sheet to null or undefined to remove the style sheet. If you remove the style sheet, the text field is redrawn without a style sheet. The formatting a style sheet applies is not retained if the style sheet is removed.

Implementation
    public function get styleSheet():StyleSheet
    public function set styleSheet(value:StyleSheet):void

See also

flash.text.StyleSheet
text property
text:String [read-write]

A string that is the current text in the text field. Lines are separated by the carriage return character ('\r', ASCII 13). This property contains unformatted text in the text field, without HTML tags.

To get the text in HTML form, use the htmlText property.

Implementation
    public function get text():String
    public function set text(value:String):void

See also

flash.text.TextField.htmlText

Example
The following example creates a TextField called tf1, and assigns an HTML-formatted String to its text property. When its htmlText property is traced, the output is the HTML-formatted String, with additional tags (such as <P> and <FONT>) automatically added by Flash Player. When the value of the text property is traced, the unformatted string without HTML tags is displayed.

By way of comparison, the same steps are performed on another TextField object named tf2, with the addition that a StyleSheet object is assigned to tf2's styleSheet property before its htmlText property is set. In that case, when the htmlText property is traced, it only includes the exact HTML text that was originally assigned to the htmlText property, showing that no additional tags were added by Flash Player.

package {
    import flash.display.Sprite;
    import flash.text.StyleSheet;
    import flash.text.TextField;

    public class TextField_text extends Sprite {
        public function TextField_text() {
            var tf1:TextField = createTextField(10, 10, 400, 22);
            tf1.htmlText = "<b>Lorem ipsum dolor sit amet.</b>";

            // htmlText: <P ALIGN="LEFT"><FONT FACE="Times New Roman" SIZE="12" COLOR="#000000" LETTERSPACING="0" KERNING="0">&lt;b&gt;Lorem ipsum dolor sit amet.&lt;/b&gt;</FONT></P>
            trace("htmlText: " + tf1.htmlText);
            // text: Lorem ipsum dolor sit amet.
            trace("text: " + tf1.text);

            var tf2:TextField = createTextField(10, 50, 400, 22);
            tf2.styleSheet = new StyleSheet();
            tf2.htmlText = "<b>Lorem ipsum dolor sit amet.</b>";
            // htmlText: <b>Lorem ipsum dolor sit amet.</b>
            trace("htmlText: " + tf2.htmlText);
            // text: Lorem ipsum dolor sit amet.
            trace("text: " + tf2.text);
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            addChild(result);
            return result;
        }
    }
}

textColor property
textColor:uint [read-write]

The color of the text in a text field, in hexadecimal format. The hexadecimal color system uses six digits to represent color values. Each digit has sixteen possible values or characters. The characters range from 0 to 9 and then A to F. For example, black is 0x000000; white is 0xFFFFFF.

Implementation
    public function get textColor():uint
    public function set textColor(value:uint):void

Example
The following ActionScript creates a TextField object and changes its textColor property to red (0xFF0000).

package {
    import flash.display.Sprite;
    import flash.text.TextField;

    public class TextField_textColor extends Sprite {
        public function TextField_textColor() {
            var tf:TextField = createTextField(10, 10, 100, 300);
            tf.text = "This will be red text";
            tf.textColor = 0xFF0000;
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            addChild(result);
            return result;
        }
    }
}

textHeight property
textHeight:Number [read-only]

The height of the text in pixels.

Implementation
    public function get textHeight():Number

See also

flash.text.TextField.textWidth

Example
The following example creates a TextField object and assigns text to it. The trace statements display the values of the textWidth and textHeight properties. For comparison, the width and height properties are also displayed. (Note that the values you see for textHeight and textWidth might vary depending on the font that is used on your machine).

package {
    import flash.display.Sprite;
    import flash.text.TextField;

    public class TextField_textHeight extends Sprite {
        public function TextField_textHeight() {
            var tf:TextField = createTextField(10, 10, 100, 150);
            tf.text = "Sample text";

            trace("textWidth: " + tf.textWidth); // textWidth: 55.75
            trace("textHeight: " + tf.textHeight); // textHeight: 13.450000000000001
            trace("width: " + tf.width); // width: 100
            trace("height: " + tf.height); // height: 150
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            result.border = true;
            result.background = true;
            addChild(result);
            return result;
        }
    }
}

textWidth property
textWidth:Number [read-only]

The width of the text in pixels.

Implementation
    public function get textWidth():Number

See also

flash.text.TextField.textHeight

Example
The following example creates a TextField object and assigns text to it. The trace statements display the values of the textWidth and textHeight properties. For comparison, the width and height properties are also displayed. (Note that the values you see for textHeight and textWidth might vary depending on the font that is used on your machine).

package {
    import flash.display.Sprite;
    import flash.text.TextField;

    public class TextField_textHeight extends Sprite {
        public function TextField_textHeight() {
            var tf:TextField = createTextField(10, 10, 100, 150);
            tf.text = "Sample text";

            trace("textWidth: " + tf.textWidth); // textWidth: 55.75
            trace("textHeight: " + tf.textHeight); // textHeight: 13.450000000000001
            trace("width: " + tf.width); // width: 100
            trace("height: " + tf.height); // height: 150
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            result.border = true;
            result.background = true;
            addChild(result);
            return result;
        }
    }
}

thickness property
thickness:Number [read-write]

The thickness of the glyph edges in this text field. This property applies only when flash.text.AntiAliasType is set to flash.text.AntiAliasType.ADVANCED.

The range for thickness is a number from -200 to 200. If you attempt to set thickness to a value outside that range, the property is set to the nearest value in the range (either -200 or 200).

The default value is 0.

Implementation
    public function get thickness():Number
    public function set thickness(value:Number):void

See also

flash.text.TextField.antiAliasType
flash.text.AntiAliasType
type property
type:String [read-write]

The type of the text field. Either one of the following TextFieldType constants: TextFieldType.DYNAMIC, which specifies a dynamic text field, which a user cannot edit, or TextFieldType.INPUT, which specifies an input text field, which a user can edit.

The default value is dynamic.

Implementation
    public function get type():String
    public function set type(value:String):void

Throws
ArgumentError — The type specified is not a member of flash.text.TextFieldType.

See also

flash.text.TextFieldType

Example

package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.text.TextFieldType;

    public class TextField_type extends Sprite {
        public function TextField_type() {
            var tfDynamic:TextField = createTextField(10, 10, 100, 20);
            tfDynamic.type = TextFieldType.DYNAMIC;
            tfDynamic.text = "hello";

            var tfInput:TextField = createTextField(10, 45, 100, 20);
            tfInput.type = TextFieldType.INPUT;
            tfInput.text = "world";
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            result.background = true;
            result.border = true;
            addChild(result);
            return result;
        }
    }
}

useRichTextClipboard property
useRichTextClipboard:Boolean [read-write]

Specifies whether to copy and paste the text formatting along with the text. When set to true, Flash Player will also copy and paste formatting (such as alignment, bold, and italics) when you copy and paste between text fields. Both the origin and destination text fields for the copy and paste procedure must have useRichTextClipboard set to true. The default value is false.

Implementation
    public function get useRichTextClipboard():Boolean
    public function set useRichTextClipboard(value:Boolean):void
wordWrap property
wordWrap:Boolean [read-write]

A Boolean value that indicates whether the text field has word wrap. If the value of wordWrap is true, the text field has word wrap; if the value is false, the text field does not have word wrap. The default value is false.

Implementation
    public function get wordWrap():Boolean
    public function set wordWrap(value:Boolean):void

Example
This example demonstrates the difference between setting the wordWrap property to true and setting it to false. Two TextField instances are created whose contents are too large for their widths. The wordWrap property of the first (named tfWrap) is set to true; it is set to false for the second (tfNoWrap).

package {
    import flash.display.Sprite;
    import flash.text.TextField;

    public class TextField_wordWrap extends Sprite {
        public function TextField_wordWrap() {
            var tfWrap:TextField = createTextField(10, 10, 100, 100);
            tfWrap.wordWrap = true;
            tfWrap.text = "(wordWrap = true):\nThis is very long text that will certainly extend beyond the width of this text field";

            var tfNoWrap:TextField = createTextField(10, 150, 100, 100);
            tfNoWrap.wordWrap = false;
            tfNoWrap.text = "(wordWrap = false):\nThis is very long text that will certainly extend beyond the width of this text field";
        }

        private function createTextField(x:Number, y:Number, width:Number, height:Number):TextField {
            var result:TextField = new TextField();
            result.x = x;
            result.y = y;
            result.width = width;
            result.height = height;
            result.background = true;
            result.border = true;
            addChild(result);
            return result;
        }
    }
}

Constructor detail
TextField () constructor
public function TextField()

Creates a new TextField instance. After you create the TextField instance, call the addChild() or addChildAt() method of the parent DisplayObjectContainer object to add the TextField instance to the display list.

Method detail
appendText () method
public function appendText(newText:String):void

Appends the string specified by the newText parameter to the end of the text of the TextField.

Parameters
newText:String — The string to append to the existing text.
getCharBoundaries () method
public function getCharBoundaries(charIndex:int):Rectangle

Returns a rectangle that is the bounding box of the character.

Parameters
charIndex:int — The zero-based index value for the character (for example, the first position is 0, the second position is 1, and so on).

Returns
Rectangle — A rectangle with x and y minimum and maximum values defining the bounding box of the character.

See also

flash.geom.Rectangle
getCharIndexAtPoint () method
public function getCharIndexAtPoint(x:Number, y:Number):int

Returns the zero-based index value of the character at the point specified by the x and y parameters.

Parameters
x:Number — The x coordinate of the character.
y:Number — The y coordinate of the character.

Returns
int — The zero-based index value of the character (for example, the first position is 0, the second position is 1, and so on). Returns -1 if the point is not over any character.
getFirstCharInParagraph () method
public function getFirstCharInParagraph(charIndex:int):int

Given a character index, returns the index of the first character in the same paragraph.

Parameters
charIndex:int — The zero-based index value of the character (for example, the first character is 0, the second character is 1, and so on).

Returns
int — The zero-based index value of the first character in the same paragraph.

Throws
RangeError — The character index specified is out of range.
getImageReference () method
public function getImageReference(id:String):DisplayObject

Returns a DisplayObject reference for the given id, for an image or SWF file that has been added to an HTML-formatted text field by using an <img> tag. The <img> tag is in the following format:

 <img src = 'filename.jpg' id = 'instanceName' >

Parameters
id:String — The id to match (in the id attribute of the <img> tag).

Returns
DisplayObject — The display object corresponding to the image or SWF file with the matching id attribute in the <img> tag of the text field. For media loaded from an external source, this object is a Loader object, and, once loaded, the media object is a child of that Loader object. For media embedded in the SWF file, this is the loaded object. If there is no <img> tag with the matching id, the method returns null.

See also

htmlText
getLineIndexAtPoint () method
public function getLineIndexAtPoint(x:Number, y:Number):int

Returns the zero-based index value of the line at the point specified by the x and y parameters.

Parameters
x:Number — The x coordinate of the line.
y:Number — The y coordinate of the line.

Returns
int — The zero-based index value of the line (for example, the first line is 0, the second line is 1, and so on). Returns -1 if the point is not over any line.
getLineIndexOfChar () method
public function getLineIndexOfChar(charIndex:int):int

Returns the zero-based index value of the line containing the character specified by the charIndex parameter.

Parameters
charIndex:int — The zero-based index value of the character (for example, the first character is 0, the second character is 1, and so on).

Returns
int — The zero-based index value of the line.

Throws
RangeError — The character index specified is out of range.
getLineLength () method
public function getLineLength(lineIndex:int):int

Returns the number of characters in a specific text line.

Parameters
lineIndex:int — The line number for which you want the length.

Returns
int — The number of characters in the line.

Throws
RangeError — The line number specified is out of range.
getLineMetrics () method
public function getLineMetrics(lineIndex:int):TextLineMetrics

Returns metrics information about a given text line.

Parameters
lineIndex:int — The line number for which you want metrics information.

Returns
TextLineMetrics — A TextLineMetrics object.

Throws
RangeError — The line number specified is out of range.

See also

flash.text.TextLineMetrics
flash.text.TextLineMetrics
getLineOffset () method
public function getLineOffset(lineIndex:int):int

Returns the character index of the first character in the line that the lineIndex parameter specifies.

Parameters
lineIndex:int — The zero-based index value of the line (for example, the first line is 0, the second line is 1, and so on).

Returns
int — The zero-based index value of the first character in the line.

Throws
RangeError — The line number specified is out of range.
getLineText () method
public function getLineText(lineIndex:int):String

Returns the text of the line specified by the lineIndex parameter.

Parameters
lineIndex:int — The zero-based index value of the line (for example, the first line is 0, the second line is 1, and so on).

Returns
String — The text string contained in the specified line.

Throws
RangeError — The line number specified is out of range.
getParagraphLength () method
public function getParagraphLength(charIndex:int):int

Given a character index, returns the length of the paragraph containing the given character. The length is relative to the first character in the paragraph (as returned by getFirstCharInParagraph()), not to the character index passed in.

Parameters
charIndex:int — The zero-based index value of the character (for example, the first character is 0, the second character is 1, and so on).

Returns
int — Returns the number of characters in the paragraph.

Throws
RangeError — The character index specified is out of range.

See also

flash.text.TextField.getFirstCharInParagraph()
getTextFormat () method
public function getTextFormat(beginIndex:int = -1, endIndex:int = -1):TextFormat

Returns a TextFormat object that contains formatting information for the range of text that the beginIndex and endIndex parameters specify. Only properties that are common to the entire text specified are set in the resulting TextFormat object. Any property that is mixed, meaning that it has different values at different points in the text, has a value of null.

If you do not specify values for these parameters, this method is applied to all the text in the text field.

The following table describes three possible usages:

Usage | Description
my_textField.getTextFormat() | Returns a TextFormat object containing formatting information for all text in a text field. Only properties that are common to all text in the text field are set in the resulting TextFormat object. Any property that is mixed, meaning that it has different values at different points in the text, has a value of null.
my_textField.getTextFormat(beginIndex:Number) | Returns a TextFormat object containing a copy of the text format of the character at the beginIndex position.
my_textField.getTextFormat(beginIndex:Number,endIndex:Number) | Returns a TextFormat object containing formatting information for the span of text from beginIndex to endIndex. Only properties that are common to all of the text in the specified range are set in the resulting TextFormat object. Any property that is mixed (that is, has different values at different points in the range) has its value set to null.
Parameters
beginIndex:int (default = -1) — Optional; an integer that specifies the starting location of a range of text within the text field.
endIndex:int (default = -1) — Optional; an integer that specifies the ending location of a range of text within the text field.

Returns
TextFormat — The TextFormat object that represents the formatting properties for the specified text.

Throws
RangeError — The beginIndex or endIndex specified is out of range.

See also

flash.text.TextFormat
flash.text.TextField.defaultTextFormat
flash.text.TextField.setTextFormat()
replaceSelectedText () method
public function replaceSelectedText(value:String):void

Replaces the current selection with the contents of the value parameter. The text is inserted at the position of the current selection, using the current default character format and default paragraph format. The text is not treated as HTML.

You can use the replaceSelectedText() method to insert and delete text without disrupting the character and paragraph formatting of the rest of the text.

Parameters
value:String — The string to replace the currently selected text.

Throws
Error — This method cannot be used on a text field with a style sheet.

See also

flash.display.Stage.focus
replaceText () method
public function replaceText(beginIndex:int, endIndex:int, newText:String):void

Replaces the range of characters that the beginIndex and endIndex parameters specify with the contents of the newText parameter.

Parameters
beginIndex:int — The zero-based index value for the start position of the replacement range.
endIndex:int — The zero-based index value for end position of the replacement range.
newText:String — The text to use to replace the specified range of characters.

Throws
Error — This method cannot be used on a text field with a style sheet.
setSelection () method
public function setSelection(beginIndex:int, endIndex:int):void

Sets as selected the text designated by the index values of the first and last characters, which are specified with the beginIndex and endIndex parameters. If the two parameter values are the same, this method sets the insertion point, just as if you set the caretIndex property.

Parameters
beginIndex:int — The zero-based index value of the first character in the selection (for example, the first character is 0, the second character is 1, and so on).
endIndex:int — The zero-based index value of the last character in the selection.

See also

selectable
selectionBeginIndex
selectionEndIndex
caretIndex
setTextFormat () method
public function setTextFormat(format:TextFormat, beginIndex:int = -1, endIndex:int = -1):void

Applies the text formatting that the format parameter specifies to the specified text in a text field. The value of format must be a TextFormat object that specifies the desired text formatting changes. Only the non-null properties of format are applied to the text field. Any property of format that is set to null is not applied. By default, all of the properties of a newly created TextFormat object are set to null.

The setTextFormat() method changes the text formatting applied to a range of characters or to the entire body of text in a text field. To apply the properties of format to all text in the text field, do not specify values for beginIndex and endIndex. To apply the properties of the format to a range of text, specify values for the beginIndex and the endIndex parameters. You can use the length property to determine the index values.

The two types of formatting information in a TextFormat object are character level formatting and paragraph level formatting. Each character in a text field might have its own character formatting settings, such as font name, font size, bold, and italic.

For paragraphs, the first character of the paragraph is examined for the paragraph formatting settings for the entire paragraph. Examples of paragraph formatting settings are left margin, right margin, and indentation.

Any text inserted manually by the user, or replaced by means of the replaceSelectedText() method, receives the text field's default formatting for new text, and not the formatting specified for the text insertion point. To set a text field's default formatting for new text, use defaultTextFormat.

Parameters
format:TextFormat — A TextFormat object that contains character and paragraph formatting information.
beginIndex:int (default = -1) — The zero-based index position specifying the first character of the desired range of text.
endIndex:int (default = -1) — The zero-based index position specifying the last character of the desired range of text.

Usage | Description
my_textField.setTextFormat(textFormat:TextFormat) | Applies the properties of textFormat to all text in the text field.
my_textField.setTextFormat(textFormat:TextFormat, beginIndex:int) | Applies the properties of textFormat to the text starting with the beginIndex position.
my_textField.setTextFormat(textFormat:TextFormat, beginIndex:int, endIndex:int) | Applies the properties of the textFormat parameter to the span of text from the beginIndex position to the endIndex position.

Notice that any text inserted manually by the user, or replaced by means of the replaceSelectedText() method, receives the text field's default formatting for new text, and not the formatting specified for the text insertion point. To set a text field's default formatting for new text, use the defaultTextFormat property.

Throws
Error — This method cannot be used on a text field with a style sheet.
RangeError — The beginIndex or endIndex specified is out of range.

See also

flash.text.TextFormat
flash.text.TextField.defaultTextFormat
Event detail
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched after a control's value is modified. Contrast this with the textInput event, which is dispatched before the value is modified. Unlike the W3C DOM Event Model version of the change event, which dispatches the event only after the control loses focus, the ActionScript 3.0 version of the change event is dispatched any time the control changes. For example, if a user types text into a text field, a change event is dispatched after every keystroke.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
link event
Event object type: flash.events.TextEvent
TextEvent.type property = flash.events.TextEvent.LINK

Dispatched when a user clicks a hyperlink in an HTML-enabled text field, where the URL begins with "event:". The remainder of the URL after "event:" will be placed in the text property of the LINK event.

Note: The default behavior, adding the text to the text field, occurs only when Flash Player generates the event, which in this case happens when a user attempts to input text. You cannot put text into a text field by sending it textInput events.

Defines the value of the type property of a link event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The text field containing the hyperlink that has been clicked. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
text | The remainder of the URL after "event:"

Example
In the following example, the playMP3() function is defined. A TextField object named list is created and populated with HTML text. The text "Track 1" and "Track 2" are links inside the text field. The playMP3() function is called when the user clicks either link. The name of the MP3 file, which follows the string "event:" in the href attribute of the HTML tag, is passed to the linkHandler() method as the text property of the link event object.

package {
    import flash.display.Sprite;
    import flash.errors.IOError;
    import flash.events.IOErrorEvent;
    import flash.events.TextEvent;
    import flash.media.Sound;
    import flash.media.SoundChannel;
    import flash.net.URLRequest;
    import flash.text.TextField;
    import flash.text.TextFieldAutoSize;

    public class TextField_event_link extends Sprite
    {
        private var myMP3:Sound;
        public function TextField_event_link() {
            myMP3 = new Sound();
            var list:TextField = new TextField();
            list.autoSize = TextFieldAutoSize.LEFT;
            list.multiline = true;
            list.htmlText = "<a href=\"event:track1.mp3\">Track 1</a><br>";
            list.htmlText += "<a href=\"event:track2.mp3\">Track 2</a><br>";
            addEventListener(TextEvent.LINK, linkHandler);
            addChild(list);
        }

        private function playMP3(mp3:String):void {
            try {
                myMP3.load(new URLRequest(mp3));
                myMP3.play();
            }
            catch(err:Error) {
                trace(err.message);
            }
            myMP3.addEventListener(IOErrorEvent.IO_ERROR, errorHandler);
        }

        private function linkHandler(linkEvent:TextEvent):void {
            playMP3(linkEvent.text);
        }

        private function errorHandler(errorEvent:IOErrorEvent):void {
            trace(errorEvent.text);
        }
    }
}

scroll event
Event object type: flash.events.Event
Event.type property = flash.events.Event.SCROLL

Dispatched by a TextField object after the user scrolls.

Defines the value of the type property of a scroll event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The TextField object that has been scrolled. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
textInput event
Event object type: flash.events.TextEvent
TextEvent.type property = flash.events.TextEvent.TEXT_INPUT

Flash Player dispatches the textInput event when a user enters one or more characters of text. A number of different text input methods can generate this event, including standard keyboards, input method editors (IMEs), voice or speech recognition systems, and even the act of pasting plain text with no formatting or style information.

Defines the value of the type property of a textInput event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The text field into which characters are being entered. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
text | The character or sequence of characters entered by the user.
Examples

The following example uses the TextFieldExample class to display a text message. This is accomplished by using the following steps:
  1. A label property of type TextField is created.
  2. The class constructor calls the configureLabel() function.
  3. The configureLabel() method first creates a new TextField object and assigns it to the label property, and then sets its parameters to the following:
    • Left-justify the text field.
    • Enable the background fill.
    • Enable the border.
  4. The configureLabel() method creates the format variable and assigns it to a new TextFormat instance with its parameters set to the following:
    • Font type = Veranda
    • Font color = solid red
    • Font size = 10
    • Font underline = true
  5. The defaultTextFormat property of the label text field is set to format, and the label instance is added to the display list, which initially displays a text field with no text on the stage.
  6. The constructor sets the text of the label text field to "Hello world and welcome to the show." by calling the setLabel() method.
package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.text.TextFieldAutoSize;
    import flash.text.TextFormat;

    public class TextFieldExample extends Sprite {
        private var label:TextField;
        private var labelText:String = "Hello world and welcome to the show.";

        public function TextFieldExample() {
            configureLabel();
            setLabel(labelText);
        }

        public function setLabel(str:String):void {
            label.text = str;
        }

        private function configureLabel():void {
            label = new TextField();
            label.autoSize = TextFieldAutoSize.LEFT;
            label.background = true;
            label.border = true;

            var format:TextFormat = new TextFormat();
            format.font = "Verdana";
            format.color = 0xFF0000;
            format.size = 10;
            format.underline = true;

            label.defaultTextFormat = format;
            addChild(label);
        }
    }
}


flash.text.TextFieldAutoSize (Flex™ 2 Language Reference)

Class TextFieldAutoSize | Properties | Methods | Constants
Package | flash.text
Class | public final class TextFieldAutoSize
Inheritance | TextFieldAutoSize Inheritance Object

The TextFieldAutoSize class is an enumeration of constant values used in setting the autoSize property of the TextField class.

See also

flash.text.TextField.autoSize

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CENTER : String = "center" [static] Specifies that the text is to be treated as center-justified text. | TextFieldAutoSize
 | LEFT : String = "left" [static] Specifies that the text is to be treated as left-justified text, meaning that the left side of the text field remains fixed and any resizing of a single line is on the right side. | TextFieldAutoSize
 | NONE : String = "none" [static] Specifies that no resizing is to occur. | TextFieldAutoSize
 | RIGHT : String = "right" [static] Specifies that the text is to be treated as right-justified text, meaning that the right side of the text field remains fixed and any resizing of a single line is on the left side. | TextFieldAutoSize
Constant detail
CENTER constant
public static const CENTER:String = "center"

Specifies that the text is to be treated as center-justified text. Any resizing of a single line of a text field is equally distributed to both the right and left sides.

LEFT constant
public static const LEFT:String = "left"

Specifies that the text is to be treated as left-justified text, meaning that the left side of the text field remains fixed and any resizing of a single line is on the right side.

NONE constant
public static const NONE:String = "none"

Specifies that no resizing is to occur.

RIGHT constant
public static const RIGHT:String = "right"

Specifies that the text is to be treated as right-justified text, meaning that the right side of the text field remains fixed and any resizing of a single line is on the left side.


flash.text.TextFieldType (Flex™ 2 Language Reference)

Class TextFieldType | Properties | Methods | Constants
Package | flash.text
Class | public final class TextFieldType
Inheritance | TextFieldType Inheritance Object

The TextFieldType class is an enumeration of constant values used in setting the type property of the TextField class.

See also

flash.text.TextField.type

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DYNAMIC : String = "dynamic" [static] Used to specify a dynamic TextField. | TextFieldType
 | INPUT : String = "input" [static] Used to specify an input TextField. | TextFieldType
Constant detail
DYNAMIC constant
public static const DYNAMIC:String = "dynamic"

Used to specify a dynamic TextField.

INPUT constant
public static const INPUT:String = "input"

Used to specify an input TextField.


flash.text.TextFormat (Flex™ 2 Language Reference)

Class TextFormat | Properties | Methods | Examples
Package | flash.text
Class | public class TextFormat
Inheritance | TextFormat Inheritance Object
Subclasses | UITextFormat

The TextFormat class represents character formatting information. Use the TextFormat class to create specific text formatting for text fields. You can apply text formatting to both static and dynamic text fields. The properties of the TextFormat class apply to device and embedded fonts. However, for embedded fonts, bold and italic text actually require specific fonts. If you want to display bold or italic text with an embedded font, you need to embed the bold and italic variations of that font.

You must use the constructor new TextFormat() to create a TextFormat object before setting its properties. The TextFormat properties are null by default because if you don't provide values for the properties, Flash Player uses its own default formatting. The default formatting that Flash Player uses for each property is as follows:

Default property formatting in Flash Player
(if property's value is null)
align = "left"
blockIndent = 0
bold = false
bullet = false
color = 0x000000
font = "Times New Roman" (default font is Times on Mac OS X)
indent = 0
italic = false
kerning = false
leading = 0
leftMargin = 0
letterSpacing = 0
rightMargin = 0
size = 12
tabStops = [] (empty array)
target = "" (empty string)
underline = false
url = "" (empty string)

The default formatting for each property is also described in each property description.

View the examples.

See also

flash.text.TextField.setTextFormat()
flash.text.TextField.getTextFormat()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | align : String Indicates the alignment of the paragraph. | TextFormat
 | blockIndent : Object Indicates the block indentation in pixels. | TextFormat
 | bold : Object Specifies whether the text is boldface. | TextFormat
 | bullet : Object Indicates that the text is part of a bulleted list. | TextFormat
 | color : Object Indicates the color of the text. | TextFormat
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | font : String The name of the font for text in this text format, as a string. | TextFormat
 | indent : Object Indicates the indentation from the left margin to the first character in the paragraph. | TextFormat
 | italic : Object Indicates whether text in this text format is italicized. | TextFormat
 | kerning : Object A Boolean value that indicates whether kerning is enabled (true) or disabled (false). | TextFormat
 | leading : Object An integer representing the amount of vertical space (called leading) between lines. | TextFormat
 | leftMargin : Object The left margin of the paragraph, in pixels. | TextFormat
 | letterSpacing : Object An integer representing the amount of space that is uniformly distributed between all characters. | TextFormat
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rightMargin : Object The right margin of the paragraph, in pixels. | TextFormat
 | size : Object The point size of text in this text format. | TextFormat
 | tabStops : Array Specifies custom tab stops as an array of non-negative integers. | TextFormat
 | target : String Indicates the target window where the hyperlink is displayed. | TextFormat
 | underline : Object Indicates whether the text that uses this text format is underlined (true) or not (false). | TextFormat
 | url : String Indicates the target URL for the text in this text format. | TextFormat
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TextFormat(font:String = null, size:Object = null, color:Object = null, bold:Object = null, italic:Object = null, underline:Object = null, url:String = null, target:String = null, align:String = null, leftMargin:Object = null, rightMargin:Object = null, indent:Object = null, leading:Object = null) Creates a TextFormat object with the specified properties. | TextFormat
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
align property
align:String [read-write]

Indicates the alignment of the paragraph. Valid values are TextFormatAlign constants.

The default value is TextFormatAlign.LEFT.

Implementation
    public function get align():String
    public function set align(value:String):void

Throws
ArgumentError — The align specified is not a member of flash.text.TextFormatAlign.

See also

flash.text.TextFormatAlign
blockIndent property
blockIndent:Object [read-write]

Indicates the block indentation in pixels. Block indentation is applied to an entire block of text; that is, to all lines of the text. In contrast, normal indentation (TextFormat.indent) affects only the first line of each paragraph. If this property is null, the TextFormat object does not specify block indentation (block indentation is 0).

Implementation
    public function get blockIndent():Object
    public function set blockIndent(value:Object):void
bold property
bold:Object [read-write]

Specifies whether the text is boldface. The default value is null, which means no boldface is used. If the value is true, then the text is boldface.

Implementation
    public function get bold():Object
    public function set bold(value:Object):void
bullet property
bullet:Object [read-write]

Indicates that the text is part of a bulleted list. In a bulleted list, each paragraph of text is indented. To the left of the first line of each paragraph, a bullet symbol is displayed. The default value is null, which means no bulleted list is used.

Implementation
    public function get bullet():Object
    public function set bullet(value:Object):void
color property
color:Object [read-write]

Indicates the color of the text. A number containing three 8-bit RGB components; for example, 0xFF0000 is red, and 0x00FF00 is green. The default value is null, which means that Flash Player uses the color black (0x000000).

Implementation
    public function get color():Object
    public function set color(value:Object):void
font property
font:String [read-write]

The name of the font for text in this text format, as a string. The default value is null, which means that Flash Player uses Times New Roman font for the text.

Implementation
    public function get font():String
    public function set font(value:String):void
indent property
indent:Object [read-write]

Indicates the indentation from the left margin to the first character in the paragraph. The default value is null, which indicates that no indentation is used.

Implementation
    public function get indent():Object
    public function set indent(value:Object):void

See also

flash.text.TextFormat.blockIndent
italic property
italic:Object [read-write]

Indicates whether text in this text format is italicized. The default value is null, which means no italics are used.

Implementation
    public function get italic():Object
    public function set italic(value:Object):void
kerning property
kerning:Object [read-write]

A Boolean value that indicates whether kerning is enabled (true) or disabled (false). Kerning adjusts the pixels between certain character pairs to improve readability, and should be used only when necessary, such as with headings in large fonts. Kerning is supported for embedded fonts only.

Certain fonts such as Verdana and monospaced fonts, such as Courier New, do not support kerning.

The default value is null, which means that kerning is not enabled. Implementation
    public function get kerning():Object
    public function set kerning(value:Object):void
leading property
leading:Object [read-write]

An integer representing the amount of vertical space (called leading) between lines. The default value is null, which indicates that the amount of leading used is 0.

Implementation
    public function get leading():Object
    public function set leading(value:Object):void
leftMargin property
leftMargin:Object [read-write]

The left margin of the paragraph, in pixels. The default value is null, which indicates that the left margin is 0 pixels.

Implementation
    public function get leftMargin():Object
    public function set leftMargin(value:Object):void
letterSpacing property
letterSpacing:Object [read-write]

An integer representing the amount of space that is uniformly distributed between all characters. The value specifies the number of pixels that are added to the advance after each character. The default value is null, which means that 0 pixels of letter spacing is used.

Implementation
    public function get letterSpacing():Object
    public function set letterSpacing(value:Object):void
rightMargin property
rightMargin:Object [read-write]

The right margin of the paragraph, in pixels. The default value is null, which indicates that the right margin is 0 pixels.

Implementation
    public function get rightMargin():Object
    public function set rightMargin(value:Object):void
size property
size:Object [read-write]

The point size of text in this text format. The default value is null, which means that a point size of 12 is used.

Implementation
    public function get size():Object
    public function set size(value:Object):void
tabStops property
tabStops:Array [read-write]

Specifies custom tab stops as an array of non-negative integers. Each tab stop is specified in pixels. If custom tab stops are not specified (null), the default tab stop is 4 (average character width).

Implementation
    public function get tabStops():Array
    public function set tabStops(value:Array):void
target property
target:String [read-write]

Indicates the target window where the hyperlink is displayed. If the target window is an empty string, the text is displayed in the default target window _self. You can choose a custom name or one of the following four names: _self specifies the current frame in the current window, _blank specifies a new window, _parent specifies the parent of the current frame, and _top specifies the top-level frame in the current window. If the TextFormat.url property is an empty string or null, you can get or set this property, but the property will have no effect.

Implementation
    public function get target():String
    public function set target(value:String):void

See also

flash.text.TextFormat.url
underline property
underline:Object [read-write]

Indicates whether the text that uses this text format is underlined (true) or not (false). This underlining is similar to that produced by the <U> tag, but the latter is not true underlining, because it does not skip descenders correctly. The default value is null, which indicates that underlining is not used.

Implementation
    public function get underline():Object
    public function set underline(value:Object):void
url property
url:String [read-write]

Indicates the target URL for the text in this text format. If the url property is an empty string, the text does not have a hyperlink. The default value is null, which indicates that the text does not have a hyperlink.

Note: The text with the assigned text format must be set with the htmlText property for the hyperlink to work.

Implementation
    public function get url():String
    public function set url(value:String):void

See also

flash.text.TextField.htmlText
Constructor detail
TextFormat () constructor
public function TextFormat(font:String = null, size:Object = null, color:Object = null, bold:Object = null, italic:Object = null, underline:Object = null, url:String = null, target:String = null, align:String = null, leftMargin:Object = null, rightMargin:Object = null, indent:Object = null, leading:Object = null)

Creates a TextFormat object with the specified properties. You can then change the properties of the TextFormat object to change the formatting of text fields.

Any parameter may be set to null to indicate that it is not defined. All of the parameters are optional; any omitted parameters are treated as null.

Parameters
font:String (default = null) — The name of a font for text as a string.
size:Object (default = null) — An integer that indicates the point size.
color:Object (default = null) — The color of text using this text format. A number containing three 8-bit RGB components; for example, 0xFF0000 is red, and 0x00FF00 is green.
bold:Object (default = null) — A Boolean value that indicates whether the text is boldface.
italic:Object (default = null) — A Boolean value that indicates whether the text is italicized.
underline:Object (default = null) — A Boolean value that indicates whether the text is underlined.
url:String (default = null) — The URL to which the text in this text format hyperlinks. If url is an empty string, the text does not have a hyperlink.
target:String (default = null) — The target window where the hyperlink is displayed. If the target window is an empty string, the text is displayed in the default target window _self. If the url parameter is set to an empty string or to the value null, you can get or set this property, but the property will have no effect.
align:String (default = null) — The alignment of the paragraph, as a TextFormatAlign value.
leftMargin:Object (default = null) — Indicates the left margin of the paragraph, in pixels.
rightMargin:Object (default = null) — Indicates the right margin of the paragraph, in pixels.
indent:Object (default = null) — An integer that indicates the indentation from the left margin to the first character in the paragraph.
leading:Object (default = null) — A number that indicates the amount of leading vertical space between lines.
Examples

The following example creates the TextFieldExample class to display a text message with the default location (x = 0, y = 0). This is accomplished using the following steps:
  1. A property label of type TextField is created.
  2. The class constructor calls the function configureLabel()
  3. The configureLabel() function first creates a new TextField object and assigns it to label then sets its parameters to
    • Left-justify the text field
    • Enable the background fill
    • Enable the border.
  4. Next, configureLable() creates the local variable, format, and assigns it to a new TextFormat instance with its parameters set to
    • Font type = Veranda
    • Font Color = solid red
    • Font size = 10
    • Font underline = true.
  5. The label's defaultTextFormat property is set to format, and the label instance is added to the display list, which initially displays a text field with no text (as tiny box with a white background) on the stage.
  6. Finally (back in the constructor), the label's text is then set to display "Hello World and welcome to the show", at coordinates x = 0, y = 0 by calling setLabel().
 package {
    import flash.display.Sprite;
    import flash.text.TextField;
    import flash.text.TextFieldAutoSize;
    import flash.text.TextFormat;

    public class TextFormatExample extends Sprite {
        private var label:TextField;

        public function TextFormatExample() {
            configureLabel();
            setLabel("Hello World and welcome to the show");
        }

        public function setLabel(str:String):void {
            label.text = str;
        }

        private function configureLabel():void {
            label = new TextField();
            label.autoSize = TextFieldAutoSize.LEFT;
            label.background = true;
            label.border = true;

            var format:TextFormat = new TextFormat();
            format.font = "Verdana";
            format.color = 0xFF0000;
            format.size = 10;
            format.underline = true;

            label.defaultTextFormat = format;
            addChild(label);
        }
    }
}


flash.text.TextFormatAlign (Flex™ 2 Language Reference)

Class TextFormatAlign | Properties | Methods | Constants
Package | flash.text
Class | public final class TextFormatAlign
Inheritance | TextFormatAlign Inheritance Object

The TextFormatAlign class provides values for text alignment in the TextFormat class.

See also

flash.text.TextFormat

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CENTER : String = "center" [static] Constant; centers the text in the text field. | TextFormatAlign
 | JUSTIFY : String = "justify" [static] Constant; justifies text within the text field. | TextFormatAlign
 | LEFT : String = "left" [static] Constant; aligns text to the left within the text field. | TextFormatAlign
 | RIGHT : String = "right" [static] Constant; aligns text to the right within the text field. | TextFormatAlign
Constant detail
CENTER constant
public static const CENTER:String = "center"

Constant; centers the text in the text field. Use the syntax TextFormatAlign.CENTER.

See also

flash.text.TextFormat.align
JUSTIFY constant
public static const JUSTIFY:String = "justify"

Constant; justifies text within the text field. Use the syntax TextFormatAlign.JUSTIFY.

See also

flash.text.TextFormat.align
LEFT constant
public static const LEFT:String = "left"

Constant; aligns text to the left within the text field. Use the syntax TextFormatAlign.LEFT.

See also

flash.text.TextFormat.align
RIGHT constant
public static const RIGHT:String = "right"

Constant; aligns text to the right within the text field. Use the syntax TextFormatAlign.RIGHT.

See also

flash.text.TextFormat.align


flash.text.TextLineMetrics (Flex™ 2 Language Reference)

View comments | RSS feed
Class TextLineMetrics | Properties | Methods | Examples
Package | flash.text
Class | public class TextLineMetrics
Inheritance | TextLineMetrics Inheritance Object

The TextLineMetrics class contains information about the text position and measurements of a line of text within a text field. All measurements are in pixels. Objects of this class are returned by the flash.text.TextField.getLineMetrics() method.

For measurements related to the text field containing the line of text (for example, the "Text Field height" measurement in the diagram), see flash.text.TextField.

The following diagram indicates the points and measurements of a text field and the line of text the field contains:

An image illustrating text metrics

View the examples.

See also

flash.text.TextField

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | ascent : Number The ascent value of the text is the length from the baseline to the top of the line height in pixels. | TextLineMetrics
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | descent : Number The descent value of the text is the length from the baseline to the bottom depth of the line in pixels. | TextLineMetrics
 | height : Number The height value of the text of the selected lines (not necessarily the complete text) in pixels. | TextLineMetrics
 | leading : Number The leading value is the measurement of the vertical distance between the lines of text. | TextLineMetrics
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | width : Number The width value is the width of the text of the selected lines (not necessarily the complete text) in pixels. | TextLineMetrics
 | x : Number The x value is the left position of the first character in pixels. | TextLineMetrics
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TextLineMetrics(x:Number, width:Number, height:Number, ascent:Number, descent:Number, leading:Number) Creates a TextLineMetrics object. | TextLineMetrics
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
ascent property
public var ascent:Number

The ascent value of the text is the length from the baseline to the top of the line height in pixels. See the "Ascent" measurement in the overview diagram for this class.

See also

TextLineMetrics class overview
descent property
public var descent:Number

The descent value of the text is the length from the baseline to the bottom depth of the line in pixels. See the "Descent" measurement in the overview diagram for this class.

See also

TextLineMetrics class overview
height property
public var height:Number

The height value of the text of the selected lines (not necessarily the complete text) in pixels. The height of the text line does not include the gutter height. See the "Line height" measurement in the overview diagram for this class.

See also

TextLineMetrics class overview
leading property
public var leading:Number

The leading value is the measurement of the vertical distance between the lines of text. See the "Leading" measurement in the overview diagram for this class.

See also

TextLineMetrics class overview
width property
public var width:Number

The width value is the width of the text of the selected lines (not necessarily the complete text) in pixels. The width of the text line is not the same as the width of the text field. The width of the text line is relative to the text field width, minus the gutter width of 4 pixels (2 pixels on each side). See the "Text Line width" measurement in the overview diagram for this class.

See also

TextLineMetrics class overview
x property
public var x:Number

The x value is the left position of the first character in pixels. This value includes the margin, indent (if any), and gutter widths. See the "Text Line x-position" in the overview diagram for this class.

See also

TextLineMetrics class overview
Constructor detail
TextLineMetrics () constructor
public function TextLineMetrics(x:Number, width:Number, height:Number, ascent:Number, descent:Number, leading:Number)

Creates a TextLineMetrics object. The TextLineMetrics object contains information about the text metrics of a line of text in a text field. Objects of this class are returned by the flash.text.TextField.getLineMetrics() method.

See the diagram in the overview for this class for the properties in context.

Parameters
x:Number — The left position of the first character in pixels.
width:Number — The width of the text of the selected lines (not necessarily the complete text) in pixels.
height:Number — The height of the text of the selected lines (not necessarily the complete text) in pixels.
ascent:Number — The length from the baseline to the top of the line height in pixels.
descent:Number — The length from the baseline to the bottom depth of the line in pixels.
leading:Number — The measurement of the vertical distance between the lines of text.

See also

TextLineMetrics class overview
flash.text.TextField.getLineMetrics()
Examples

The following example creates the classes TextLineMetricsExample and LineMetricsReader to print out a message in the Flash Player via an XML object. This is accomplished using the following steps:
  1. Create a property called label of type TextField.
  2. The constructor calls configureAssets(), which does the following:
    • Sets the stage's alignment to top-left and no scale.
    • Creates a new TextField object named label.
    • Enables label's background and sets the color to white.
    • Allows label's text to span multiple lines with automatic word wrapping.
    • Assigns the result of a call to getLabelText() to the text property of label. The getLabelText() method creates a variable of type XML and assigns it to an XML node named body, which is populated with a long sentence.
    • Adds label to the display list using addChild().
  3. A method that listens for resize events performed on the stage is then added called resizeHandler(). Every time the Flash Player window size is changed, a RESIZE event is dispatched and the following happens:
    • draw() is called to ensure that label appears in the center of the stage and surrounded by a 10-pixel buffer.
    • setTimeout() then executes showMetrics() after a short delay. The delay is added because the line metrics are not updated until after the RESIZE event has completed and the stage has fully re-drawn.
    • showMetrics() assigns a TextLineMetrics variable named metrics to the result of a call to getLineMetrics() and this variable is then passed to a new instance of a LineMetricsReader instance named reader. The two variables are then used within calls to trace() to print out the first (and only) line of label and information provided by the LineMetricsReader instance through its toString() method.
  4. The constructor forces a single dispatch of the resize event to force label to be drawn correctly when the SWF file is first loaded.
package {
    import flash.display.Sprite;
    import flash.display.StageAlign;
    import flash.display.StageScaleMode;
    import flash.events.*;
    import flash.text.TextField;
    import flash.text.TextLineMetrics;
    import flash.utils.setTimeout;

    public class TextLineMetricsExample extends Sprite {
        private var gutter:int = 10;
        private var label:TextField;

        public function TextLineMetricsExample() {
            configureAssets();
            configureListeners();
            resizeHandler(new Event(Event.RESIZE));
        }

        private function showMetrics():void {
            var metrics:TextLineMetrics = label.getLineMetrics(0);
            var reader:LineMetricsReader = new LineMetricsReader(metrics);
            trace("lineText: " + label.getLineText(0));
            trace("metrics: " + reader);
        }

        private function configureAssets():void {
            stage.align = StageAlign.TOP_LEFT;
            stage.scaleMode = StageScaleMode.NO_SCALE;

            label = new TextField();
            label.background = true;
            label.backgroundColor = 0xFFFFFF;
            label.multiline = true;
            label.wordWrap = true;
            label.text = getLabelText();
            addChild(label);
        }

        private function configureListeners():void {
            stage.addEventListener(Event.RESIZE, resizeHandler);
        }

        private function resizeHandler(event:Event):void {
            draw();
            setTimeout(showMetrics, 100);
        }

        private function draw():void {
            label.x = gutter;
            label.y = gutter;
            label.width = stage.stageWidth - (gutter * 2);
            label.height = stage.stageHeight - (gutter * 2);
        }

        private function getLabelText():String {
            var text:XML = <body>The Flex product line enables developers to build rich Internet applications that blend the responsiveness of desktop software, the cross-platform reach of the web, and the expressiveness of the Flash Platform.</body>
            return text.toString();
        }
    }
}

import flash.text.TextLineMetrics;

class LineMetricsReader {
    private var metrics:TextLineMetrics;

    public function LineMetricsReader(metrics:TextLineMetrics) {
        this.metrics = metrics;
    }

    public function toString():String {
        return "[TextLineMetrics ascent:" + metrics.ascent
            + ", descent:" + metrics.descent
            + ", leading:" + metrics.leading
            + ", width:" + metrics.width
            + ", height:" + metrics.height
            + ", x:" + metrics.x
            + "]";
    }
}

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

pemekscreen said on Jul 2, 2006 at 4:27 PM :
I tried this example in "Flash Professional 9 ActionScript 3.0 Preview"
and is showing the following mistake for me:

"TypeError: Error #1085: The element type "</body" must be terminated
by the matching end-tag "</</body>".
at TextLineMetricsExample/TextLineMetricsExample::getLabelText
()
at TextLineMetricsExample/
TextLineMetricsExample::configureAssets()
at TextLineMetricsExample$iinit()"
djtechwriter said on Jul 3, 2006 at 9:57 AM :
I just tested it and it works for me. Be sure you're copying and pasting the entire code sample into your file.
Also, make sure you're following the instructions in the "Help" section of the release notes here:
http://labs.adobe.com/technologies/flash9as3preview/releasenotes.html

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/flash/text/TextLineMetrics.html


flash.text.TextRenderer (Flex™ 2 Language Reference)

Class TextRenderer | Properties | Methods | Examples
Package | flash.text
Class | public final class TextRenderer
Inheritance | TextRenderer Inheritance Object

The TextRenderer class provides functionality for the advanced anti-aliasing capability of embedded fonts. Advanced anti-aliasing allows font faces to render at very high quality at small sizes. Use advanced anti-aliasing with applications that have a lot of small text. Adobe does not recommend using advanced anti-aliasing for very large fonts (larger than 48 points). Advanced anti-aliasing is available in Flash Player 8 and later only.

To set advanced anti-aliasing on a text field, set the antiAliasType property of the TextField instance.

Advanced anti-aliasing provides continuous stroke modulation (CSM), which is continuous modulation of both stroke weight and edge sharpness. As an advanced feature, you can use the setAdvancedAntiAliasingTable() method to define settings for specific typefaces and font sizes.

View the examples.

See also

flash.text.TextField.antiAliasType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | displayMode : String [static] Controls the rendering of FlashType text. | TextRenderer
 | maxLevel : int [static] The adaptively sampled distance fields (ADFs) quality level for advanced anti-aliasing. | TextRenderer
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | setAdvancedAntiAliasingTable(fontName:String, fontStyle:String, colorType:String, advancedAntiAliasingTable:Array):void [static] Sets a custom continuous stroke modulation (CSM) lookup table for a font. | TextRenderer
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
displayMode property
displayMode:String [read-write]

Controls the rendering of FlashType text. The visual quality of text is very subjective, and while Flash Player tries to use the best settings for various conditions, designers may choose a different look or feel for their text. Also, using displayMode allows a designer to override Flash Player's subpixel choice and create visual consistency independent of the user's hardware. Use the values in the TextDisplayMode class to set this property.

The default value is "default".

Implementation
    public static function get displayMode():String
    public function set displayMode(value:String):void

See also

TextDisplayMode class
maxLevel property
maxLevel:int [read-write]

The adaptively sampled distance fields (ADFs) quality level for advanced anti-aliasing. The only acceptable values are 3, 4, and 7.

Advanced anti-aliasing uses ADFs to represent the outlines that determine a glyph. The higher the quality, the more cache space is required for ADF structures. A value of 3 takes the least amount of memory and provides the lowest quality. Larger fonts require more cache space; at a font size of 64 pixels, the quality level increases from 3 to 4 or from 4 to 7 unless, the level is already set to 7.

The default value is 4.

Implementation
    public static function get maxLevel():int
    public function set maxLevel(value:int):void
Method detail
setAdvancedAntiAliasingTable () method
public static function setAdvancedAntiAliasingTable(fontName:String, fontStyle:String, colorType:String, advancedAntiAliasingTable:Array):void

Sets a custom continuous stroke modulation (CSM) lookup table for a font. Flash Player attempts to detect the best CSM for your font. If you are not satisfied with the CSM that the Flash Player provides, you can customize your own CSM by using the setAdvancedAntiAliasingTable() method.

Parameters
fontName:String — The name of the font for which you are applying settings.
fontStyle:String — The font style indicated by using one of the values from the flash.text.FontStyle class.
colorType:String — This value determines whether the stroke is dark or whether it is light. Use one of the values from the flash.text.TextColorType class.
advancedAntiAliasingTable:Array — An array of one or more CSMSettings objects for the specified font. Each object contains the following properties:
  • fontSize
  • insideCutOff
  • outsideCutOff

The advancedAntiAliasingTable array can contain multiple entries that specify CSM settings for different font sizes.

The fontSize is the size, in pixels, for which the settings apply.

Advanced anti-aliasing uses adaptively sampled distance fields (ADFs) to represent the outlines that determine a glyph. Flash Player uses an outside cutoff value (outsideCutOff), below which densities are set to zero, and an inside cutoff value (insideCutOff), above which densities are set to a maximum density value (such as 255). Between these two cutoff values, the mapping function is a linear curve ranging from zero at the outside cutoff to the maximum density at the inside cutoff.

Adjusting the outside and inside cutoff values affects stroke weight and edge sharpness. The spacing between these two parameters is comparable to twice the filter radius of classic anti-aliasing methods; a narrow spacing provides a sharper edge, while a wider spacing provides a softer, more filtered edge. When the spacing is zero, the resulting density image is a bi-level bitmap. When the spacing is very wide, the resulting density image has a watercolor-like edge.

Typically, users prefer sharp, high-contrast edges at small point sizes, and softer edges for animated text and larger point sizes.

The outside cutoff typically has a negative value, and the inside cutoff typically has a positive value, and their midpoint typically lies near zero. Adjusting these parameters to shift the midpoint toward negative infinity increases the stroke weight; shifting the midpoint toward positive infinity decreases the stroke weight. Make sure that the outside cutoff value is always less than or equal to the inside cutoff value.

See also

flash.text.FontStyle
flash.text.TextColorType
CSMSettings
Examples

The following example creates the TextRendererExample class to remove the normal right-click menu items from the stage and add a new menu item. This is accomplished using the following steps:
  1. A font is embedded that is used later in the example.
  2. The constructor creates two populated TextField objects using two calls to createLabel() and passing it font sizes of 24 and 48.
  3. The clickHandler() event listener is attached to both of the TextField objects that listen for click events. If either of the TextField objects is clicked, clickHandler() displays information about the event and an antiAliasEntry variable is set and later passed to a new Array named veradanaTable. The setAdvancedAntialiasingTable() method of TextRenderer is called and passed the verdanaTable Array instance.

Notes:

  • You will need to compile the SWF file with "Local playback security" set to "Access local files only".
  • This example requires that a font file named verdana.ttf be placed in the same directory as your SWF file.

package {
    import flash.display.DisplayObject;
    import flash.display.Sprite;
    import flash.events.*;
    import flash.text.*;

    public class TextRendererExample extends Sprite {
        [Embed(source="verdana.ttf", fontFamily="Verdana")]
        private var verdana:String;
        private var fontFamily:String = "Verdana";
        private var gutter:int = 10;

        public function TextRendererExample() {

            var label1:TextField = createLabel(24);
            label1.name = "label-24";
            var label2:TextField = createLabel(48);
            label2.name = "label-48";
            label1.addEventListener(MouseEvent.CLICK, clickHandler);
            label2.addEventListener(MouseEvent.CLICK, clickHandler);
        }

        public function clickHandler(event:Event):void {
            trace("clickHandler target: " + event.target.name);
            var antiAliasEntry:CSMSettings;
            if(event.target.name == "label-24") {
                 antiAliasEntry = {fontSize:24, insideCutOff:1.61, outsideCutOff:-3.43};
            } else if(event.target.name == "label-48") {
                antiAliasEntry = {fontSize:48, insideCutOff:0.8, outsideCutOff:-0.8};
            }
            var verdanaTable:Array = new Array(antiAliasEntry);
            TextRenderer.setAdvancedAntiAliasingTable(fontFamily, FontStyle.NONE, TextColorType.DARK_COLOR, verdanaTable);
        }

        private function createLabel(fontSize:Number):TextField {
            var label:TextField = new TextField();
            label.embedFonts = true;
            label.border = true;
            label.autoSize = TextFieldAutoSize.LEFT;
            label.antiAliasType = AntiAliasType.ADVANCED;
            label.defaultTextFormat = getTextFormat(fontSize);
            label.selectable = false;
            label.mouseEnabled = true;
            label.text = "Hello World";
            if(numChildren > 0) {
                var sibling:DisplayObject = getChildAt(numChildren - 1);
                label.y = sibling.y + sibling.height + gutter;
            }
            addChild(label);
            return label;
        }

        private function getTextFormat(fontSize:Number):TextFormat {
            var format:TextFormat = new TextFormat();
            format.color = 0xFFFFFF;
            format.align = TextFormatAlign.CENTER;
            format.size = fontSize;
            format.font = fontFamily;
            return format;
        }
    }
}


flash.text.TextSnapshot (Flex™ 2 Language Reference)

Class TextSnapshot | Properties | Methods
Package | flash.text
Class | public class TextSnapshot
Inheritance | TextSnapshot Inheritance Object

TextSnapshot objects let you work with static text in a movie clip. You can use them, for example, to lay out text with greater precision than that allowed by dynamic text, but still access the text in a read-only way.

You don't use a constructor to create a TextSnapshot object; it is returned by flash.display.DisplayObjectContainer.textSnapshot property.

See also

flash.display.DisplayObjectContainer.textSnapshot

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | charCount : int [read-only] The number of characters in a TextSnapshot object. | TextSnapshot
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | findText(beginIndex:int, textToFind:String, caseSensitive:Boolean):int Searches the specified TextSnapshot object and returns the position of the first occurrence of textToFind found at or after beginIndex. | TextSnapshot
 | getSelected(beginIndex:int, endIndex:int):Boolean Returns a Boolean value that specifies whether a TextSnapshot object contains selected text in the specified range. | TextSnapshot
 | getSelectedText(includeLineEndings:Boolean = false):String Returns a string that contains all the characters specified by the corresponding setSelected() method. | TextSnapshot
 | getText(beginIndex:int, endIndex:int, includeLineEndings:Boolean = false):String Returns a string that contains all the characters specified by the beginIndex and endIndex parameters. | TextSnapshot
 | getTextRunInfo(beginIndex:int, endIndex:int):Array Returns an array of objects that contains information about a run of text. | TextSnapshot
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | hitTestTextNearPos(x:Number, y:Number, maxDistance:Number = 0):Number Lets you determine which character within a TextSnapshot object is on or near the specified x, y coordinates of the movie clip containing the text in the TextSnapshot object. | TextSnapshot
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setSelectColor(hexColor:uint = 0xFFFF00):void Specifies the color to use when highlighting characters that have been selected with the setSelected() method. | TextSnapshot
 | setSelected(beginIndex:int, endIndex:int, select:Boolean):void Specifies a range of characters in a TextSnapshot object to be selected or deselected. | TextSnapshot
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
charCount property
charCount:int [read-only]

The number of characters in a TextSnapshot object.

Implementation
    public function get charCount():int

See also

flash.text.TextSnapshot.getText()
Method detail
findText () method
public function findText(beginIndex:int, textToFind:String, caseSensitive:Boolean):int

Searches the specified TextSnapshot object and returns the position of the first occurrence of textToFind found at or after beginIndex. If textToFind is not found, the method returns -1.

Parameters
beginIndex:int — Specifies the starting point to search for the specified text.
textToFind:String — Specifies the text to search for. If you specify a string literal instead of a variable of type String, enclose the string in quotation marks.
caseSensitive:Boolean — Specifies whether the text must match the case of the string in textToFind.

Returns
int — The zero-based index position of the first occurrence of the specified text, or -1.

See also

flash.text.TextSnapshot.getText()
getSelected () method
public function getSelected(beginIndex:int, endIndex:int):Boolean

Returns a Boolean value that specifies whether a TextSnapshot object contains selected text in the specified range.

To search all characters, pass a value of 0 for start, and charCount (or any very large number) for end. To search a single character, pass the end parameter a value that is one greater than the start parameter.

Parameters
beginIndex:int — Indicates the position of the first character to be examined. Valid values for beginIndex are 0 through TextSnapshot.charCount - 1. If beginIndex is a negative value, 0 is used.
endIndex:int — A value that is one greater than the index of the last character to be examined. Valid values for endIndex are 0 through charCount. The character indexed by the endIndex parameter is not included in the extracted string. If this parameter is omitted, charCount is used. If this value is less than or equal to the value of beginIndex, beginIndex + 1 is used.

Returns
Boolean — A Boolean value that indicates whether at least one character in the given range has been selected by the corresponding setSelected() method (true); otherwise, false.

See also

flash.text.TextSnapshot.charCount
flash.text.TextSnapshot.getText()
flash.text.TextSnapshot.getSelectedText()
flash.text.TextSnapshot.setSelected()
getSelectedText () method
public function getSelectedText(includeLineEndings:Boolean = false):String

Returns a string that contains all the characters specified by the corresponding setSelected() method. If no characters are specified (by the setSelected() method), an empty string is returned.

If you pass true for includeLineEndings, newline characters are inserted in the return string, and the return string might be longer than the input range. If includeLineEndings is false or omitted, the method returns the selected text without adding any characters.

Parameters
includeLineEndings:Boolean (default = false) — An optional Boolean value that specifies whether newline characters are inserted into the returned string where appropriate. The default value is false.

Returns
String — A string that contains all the characters specified by the corresponding setSelected() command.

See also

flash.text.TextSnapshot.getSelected()
flash.text.TextSnapshot.setSelected()
getText () method
public function getText(beginIndex:int, endIndex:int, includeLineEndings:Boolean = false):String

Returns a string that contains all the characters specified by the beginIndex and endIndex parameters. If no characters are selected, an empty string is returned.

To return all characters, pass a value of 0 for beginIndex and charCount (or any very large number) for endIndex. To return a single character, pass a value of beginIndex + 1 for endIndex.

If you pass a value of true for includeLineEndings, newline characters are inserted in the string returned where deemed appropriate. In this case, the return string might be longer than the input range. If includeLineEndings is false or omitted, the selected text is returned without any characters added.

Parameters
beginIndex:int — Indicates the position of the first character to be included in the returned string. Valid values for beginIndex are0 through charCount - 1. If beginIndex is a negative value, 0 is used.
endIndex:int — A value that is one greater than the index of the last character to be examined. Valid values for endIndex are 0 through charCount. The character indexed by the endIndex parameter is not included in the extracted string. If this parameter is omitted, charCount is used. If this value is less than or equal to the value of beginIndex, beginIndex + 1 is used.
includeLineEndings:Boolean (default = false) — An optional Boolean value that specifies whether newline characters are inserted (true) or are not inserted (false) into the returned string. The default value is false.

Returns
String — A string containing the characters in the specified range, or an empty string if no characters are found in the specified range.

See also

flash.text.TextSnapshot.charCount
flash.text.TextSnapshot.getSelectedText()
getTextRunInfo () method
public function getTextRunInfo(beginIndex:int, endIndex:int):Array

Returns an array of objects that contains information about a run of text. Each object corresponds to one character in the range of characters specified by the two method parameters.

Note: Using the getTextRunInfo() method for a large range of text can return a large object. Adobe recommends limiting the text range defined by the beginIndex and endIndex parameters.

Parameters
beginIndex:int — The index value of the first character in a range of characters in a TextSnapshot object.
endIndex:int — The index value of the last character in a range of characters in a TextSnapshot object.

Returns
Array — An array of objects in which each object contains information about a specific character in the range of characters specified by the beginIndex and endIndex parameters. Each object contains the following eleven properties:
  • indexInRun—A zero-based integer index of the character (relative to the entire string rather than the selected run of text).
  • selected—A Boolean value that indicates whether the character is selected true; false otherwise.
  • font—The name of the character's font.
  • color—The combined alpha and color value of the character. The first two hexadecimal digits represent the alpha value, and the remaining digits represent the color value.
  • height—The height of the character, in pixels.
  • matrix_a, matrix_b, matrix_c, matrix_d, matrix_tx, and matrix_ty— The values of a matrix that define the geometric transformation on the character. Normal, upright text always has a matrix of the form [1 0 0 1 x y], where x and y are the position of the character within the parent movie clip, regardless of the height of the text. The matrix is in the parent movie clip coordinate system, and does not include any transformations that may be on that movie clip itself (or its parent).
  • corner0x, corner0y, corner1x, corner1y, corner2x, corner2y, corner3x, and corner3y—The corners of the bounding box of the character, based on the coordinate system of the parent movie clip. These values are only available if the font used by the character is embedded in the SWF file.

See also

Matrix class
hitTestTextNearPos () method
public function hitTestTextNearPos(x:Number, y:Number, maxDistance:Number = 0):Number

Lets you determine which character within a TextSnapshot object is on or near the specified x, y coordinates of the movie clip containing the text in the TextSnapshot object.

If you omit or pass a value of 0 for maxDistance, the location specified by the x, y coordinates must lie inside the bounding box of the TextSnapshot object.

This method works correctly only with fonts that include character metric information; however, by default, the Flash authoring tool does not include this information for static text fields. Therefore, the method might return -1 instead of an index value. To ensure that an index value is returned, you can force the Flash authoring tool to include the character metric information for a font. To do this, add a dynamic text field that uses that font, select Character Options for that dynamic text field, and then specify that font outlines should be embedded for at least one character. (It doesn't matter which characters you specify, nor whether they are the characters used in the static text fields.)

Parameters
x:Number — A number that represents the x coordinate of the movie clip containing the text.
y:Number — A number that represents the y coordinate of the movie clip containing the text.
maxDistance:Number (default = 0) — An optional number that represents the maximum distance from x, y that can be searched for text. The distance is measured from the center point of each character. The default value is 0.

Returns
Number — A number representing the index value of the character that is nearest to the specified x, y coordinate. Returns -1 if no character is found, or if the font doesn't contain character metric information.

See also

flash.display.DisplayObject.x
flash.display.DisplayObject.y
setSelectColor () method
public function setSelectColor(hexColor:uint = 0xFFFF00):void

Specifies the color to use when highlighting characters that have been selected with the setSelected() method. The color is always opaque; you can't specify a transparency value.

This method works correctly only with fonts that include character metric information; however, by default, the Flash authoring tool does not include this information for static text fields. Therefore, the method might return -1 instead of an index value. To ensure that an index value is returned, you can force the Flash authoring tool to include the character metric information for a font. To do this, add a dynamic text field that uses that font, select Character Options for that dynamic text field, and then specify that font outlines should be embedded for at least one character. (It doesn't matter which characters you specify, nor if they are the characters used in the static text fields.)

Parameters
hexColor:uint (default = 0xFFFF00) — The color used for the border placed around characters that have been selected by the corresponding setSelected() command, expressed in hexadecimal format (0xRRGGBB).

See also

flash.text.TextSnapshot.setSelected()
setSelected () method
public function setSelected(beginIndex:int, endIndex:int, select:Boolean):void

Specifies a range of characters in a TextSnapshot object to be selected or deselected. Characters that are selected are drawn with a colored rectangle behind them, matching the bounding box of the character. The color of the bounding box is defined by setSelectColor().

To select or deselect all characters, pass a value of 0 for beginIndex and charCount (or any very large number) for endIndex. To specify a single character, pass a value of start + 1 for endIndex.

Because characters are individually marked as selected, you can call this method multiple times to select multiple characters; that is, using this method does not deselect other characters that have been set by this method.

The colored rectangle that indicates a selection is displayed only for fonts that include character metric information; by default, Flash does not include this information for static text fields. In some cases, this behavior means that text that is selected won't appear to be selected onscreen. To ensure that all selected text appears to be selected, you can force the Flash authoring tool to include the character metric information for a font. To do this, add a dynamic text field that uses that font, select Character Options for that dynamic text field, and then specify that font outlines should be embedded for at least one character. It doesn't matter which characters you specify, nor even if they are the characters used in the static text fields in question.

Parameters
beginIndex:int — Indicates the position of the first character to select. Valid values for beginIndex are 0 through charCount - 1. If beginIndex is a negative value, 0 is used.
endIndex:int — An integer that is 1+ the index of the last character to be examined. Valid values for end are 0 through charCount. The character indexed by the end parameter is not included in the extracted string. If you omit this parameter, TextSnapshot.charCount is used. If the value of beginIndex is less than or equal to the value of endIndex, beginIndex + 1 is used.
select:Boolean — A Boolean value that specifies whether the text should be selected (true) or deselected (false).

See also

flash.text.TextSnapshot.charCount
flash.text.TextSnapshot.setSelectColor()


flash.ui Summary (Flex™ 2 Language Reference)

Package flash.ui | Classes

The flash.ui package contains user interface classes, such as classes for interacting with the mouse and keyboard.

Classes
Class | Description
ContextMenu | The ContextMenu class provides control over the items in the Flash Player context menu.
ContextMenuBuiltInItems | The ContextMenuBuiltInItems class describes the items that are built in to a context menu.
ContextMenuItem | Use the ContextMenuItem class to create custom menu items to display in the Flash Player context menu.
Keyboard | The Keyboard class is used to build an interface that can be controlled by a user with a standard keyboard.
KeyLocation | The KeyLocation class contains constants that indicate the location of a key pressed on the keyboard.
Mouse | The methods of the Mouse class are used to hide and show the mouse pointer.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.ui.ContextMenu (Flex™ 2 Language Reference)

Class ContextMenu | Properties | Methods | Events | Examples
Package | flash.ui
Class | public final class ContextMenu
Inheritance | ContextMenu Inheritance EventDispatcher Inheritance Object

The ContextMenu class provides control over the items in the Flash Player context menu. Users open the context menu by right-clicking (Windows) or Control-clicking (Macintosh) Flash Player. You can use the methods and properties of the ContextMenu class to add custom menu items, control the display of the built-in context menu items (for example, Zoom In and Print), or create copies of menus.

You can attach a ContextMenu object to a specific button, movie clip, or text field object, or to an entire movie level. You use the menu property of the Button, MovieClip, or TextField class to do this. For more information about the menu property, see Button.menu, MovieClip.menu, and TextField.menu.

In Flex, only top-level components in the application can have context menus. For example, if a DataGrid control is a child of a TabNavigator or VBox container, the DataGrid control cannot have its own context menu.

To add new items to a ContextMenu object, you create a ContextMenuItem object, and then add that object to the ContextMenu.customItems array. For more information about creating context menu items, see the ContextMenuItem class entry.

Flash Player has three types of context menus: the standard menu (which appears when you right-click in Flash Player), the edit menu (which appears when you right-click a selectable or editable text field), and an error menu (which appears when a SWF file has failed to load into Flash Player). Only the standard and edit menus can be modified with the ContextMenu class.

Custom menu items always appear at the top of the Flash Player context menu, above any visible built-in menu items; a separator bar distinguishes built-in and custom menu items. You can add no more than 15 custom items to a context menu. You cannot remove the Settings menu item from the context menu. The Settings menu item is required in Flash so that users can access the settings that affect privacy and storage on their computers. You also cannot remove the About menu item, which is required so that users can find out what version of Flash Player they are using.

You must use the ContextMenu() constructor to create a ContextMenu object before calling its methods.

View the examples.

See also

ContextMenuItem class
flash.display.InteractiveObject.contextMenu

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | builtInItems : ContextMenuBuiltInItems An object that has the following properties of the ContextMenuBuiltInItems class: forwardAndBack, loop, play, print, quality, rewind, save, and zoom. | ContextMenu
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | customItems : Array An array of ContextMenuItem objects. | ContextMenu
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ContextMenu()
Creates a ContextMenu object.
ContextMenu
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
clone():ContextMenu
Creates a copy of the specified ContextMenu object.
ContextMenu
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
hideBuiltInItems():void
Hides all built-in menu items (except Settings) in the specified ContextMenu object.
ContextMenu
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | menuSelect | Dispatched when a user first generates a context menu but before the contents of the context menu are displayed. | ContextMenu
Property detail
builtInItems property
builtInItems:ContextMenuBuiltInItems [read-write]

An object that has the following properties of the ContextMenuBuiltInItems class: forwardAndBack, loop, play, print, quality, rewind, save, and zoom. Setting these properties to false removes the corresponding menu items from the specified ContextMenu object. These properties are enumerable and are set to true by default.

Implementation
    public function get builtInItems():ContextMenuBuiltInItems
    public function set builtInItems(value:ContextMenuBuiltInItems):void

See also

ContextMenuBuiltInItems class
ContextMenu.hideBuiltInItems()
customItems property
customItems:Array [read-write]

An array of ContextMenuItem objects. Each object in the array represents a context menu item that you have defined. Use this property to add, remove, or modify these custom menu items.

To add new menu items, you create a ContextMenuItem object and then add it to the customItems array (for example, by using Array.push()). For more information about creating menu items, see the ContextMenuItem class entry.

Implementation
    public function get customItems():Array
    public function set customItems(value:Array):void

See also

flash.display.InteractiveObject.contextMenu
Constructor detail
ContextMenu () constructor
public function ContextMenu()

Creates a ContextMenu object.

See also

ContextMenu.customItems
ContextMenu.hideBuiltInItems()
Method detail
clone () method
public function clone():ContextMenu

Creates a copy of the specified ContextMenu object. The copy inherits all the properties of the original menu object.

Returns
ContextMenu — A ContextMenu object with all the properties of the original menu object.
hideBuiltInItems () method
public function hideBuiltInItems():void

Hides all built-in menu items (except Settings) in the specified ContextMenu object. If the debugger version of Flash Player is running, the Debugging menu item appears, although it is dimmed for SWF files that do not have remote debugging enabled.

This method hides only menu items that appear in the standard context menu; it does not affect items that appear in the edit and error menus.

This method works by setting all the Boolean members of my_cm.builtInItems to false. You can selectively make a built-in item visible by setting its corresponding member in my_cm.builtInItems to true.

See also

ContextMenuBuiltInItems class
ContextMenu.builtInItems
Event detail
menuSelect event
Event object type: flash.events.ContextMenuEvent
ContextMenuEvent.type property = flash.events.ContextMenuEvent.MENU_SELECT

Dispatched when a user first generates a context menu but before the contents of the context menu are displayed. This allows your program to modify the set of context menu items before displaying the menu. The user generates the context menu by right-clicking the pointing device.

Defines the value of the type property of a menuSelect event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
contextMenuOwner | The display list object to which the menu is attached.
currentTarget | The object that is actively processing the Event object with an event listener.
mouseTarget | The display list object on which the user right-clicked to display the context menu.
target | The ContextMenu object that is about to be displayed. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
Examples

The following example uses the class ContextMenuExample to remove the default context menu items from the Stage and add a new menu item, which, if clicked, changes the color of a square on the Stage. This is accomplished with the following steps:
  1. A property myContextMenu is declared and then assigned to a new ContextMenu object and a property redRectangle of type Sprite is declared.
  2. The method removeDefaultItems() is called, which removes all built-in context menu items except Print.
  3. The method addCustomMenuItems() is called, which places a menu item called Red to Black menu selection into the defaultItems array by using the push() method of Array. A menuItemSelect event listener is added to the ContextMenuItem object and the associated method is called menuItemSelectHandler(). This method prints out some statements using trace() whenever the context menu is accessed and Red to Black is selected. Also the red square is removed and replaced with a black one.
  4. An event listener of type menuSelect is added, along with the associated method menuSelectHandler, which simply prints out three statements using trace() every time an item in the context menu is opened.
  5. Then addChildren() draws a red square and adds it to the display list, where it is immediately displayed.
  6. Finally, myContextMenu is assigned to the context menu of the redRectangle sprite so that the custom context menu is displayed only when the mouse pointer is over the square.
package {
    import flash.ui.ContextMenu;
    import flash.ui.ContextMenuItem;
    import flash.ui.ContextMenuBuiltInItems;
    import flash.events.ContextMenuEvent;
    import flash.events.ContextMenuEvent;
    import flash.display.Sprite;
    import flash.display.Shape;
    import flash.text.TextField;

    public class ContextMenuExample extends Sprite {
        private var myContextMenu:ContextMenu;
        private var menuLabel:String = "Reverse Colors";
        private var textLabel:String = "Right Click";
        private var redRectangle:Sprite;
        private var label:TextField;
        private var size:uint = 100;
        private var black:uint = 0x000000;
        private var red:uint = 0xFF0000;

        public function ContextMenuExample() {
            myContextMenu = new ContextMenu();
            removeDefaultItems();
            addCustomMenuItems();
            myContextMenu.addEventListener(ContextMenuEvent.MENU_SELECT, menuSelectHandler);

            addChildren();
            redRectangle.contextMenu = myContextMenu;
        }

        private function addChildren():void {
            redRectangle = new Sprite();
            redRectangle.graphics.beginFill(red);
            redRectangle.graphics.drawRect(0, 0, size, size);
            addChild(redRectangle);
            redRectangle.x = size;
            redRectangle.y = size;
            label = createLabel();
            redRectangle.addChild(label);
        }

        private function removeDefaultItems():void {
            myContextMenu.hideBuiltInItems();
            var defaultItems:ContextMenuBuiltInItems = myContextMenu.builtInItems;
            defaultItems.print = true;
        }

        private function addCustomMenuItems():void {
            var item:ContextMenuItem = new ContextMenuItem(menuLabel);
            myContextMenu.customItems.push(item);
            item.addEventListener(ContextMenuEvent.MENU_ITEM_SELECT, menuItemSelectHandler);
        }

        private function menuSelectHandler(event:ContextMenuEvent):void {
            trace("menuSelectHandler: " + event);
        }

        private function menuItemSelectHandler(event:ContextMenuEvent):void {
            trace("menuItemSelectHandler: " + event);
            var textColor:uint = (label.textColor == black) ? red : black;
            var bgColor:uint = (label.textColor == black) ? black : red;
            redRectangle.graphics.clear();
            redRectangle.graphics.beginFill(bgColor);
            redRectangle.graphics.drawRect(0, 0, size, size);
            label.textColor = textColor;
        }

        private function createLabel():TextField {
            var txtField:TextField = new TextField();
            txtField.text = textLabel;
            return txtField;
        }
    }
}


flash.ui.ContextMenuBuiltInItems (Flex™ 2 Language Reference)

Class ContextMenuBuiltInItems | Properties | Methods | Examples
Package | flash.ui
Class | public final class ContextMenuBuiltInItems
Inheritance | ContextMenuBuiltInItems Inheritance Object

The ContextMenuBuiltInItems class describes the items that are built in to a context menu. You can hide these items by using the ContextMenu.hideBuiltInItems() method.

View the examples.

See also

ContextMenu.hideBuiltInItems()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | forwardAndBack : Boolean = true Lets the user move forward or backward one frame in a SWF file at run time (does not appear for a single-frame SWF file). | ContextMenuBuiltInItems
 | loop : Boolean = true Lets the user set a SWF file to start over automatically when it reaches the final frame (does not appear for a single-frame SWF file). | ContextMenuBuiltInItems
 | play : Boolean = true Lets the user start a paused SWF file (does not appear for a single-frame SWF file). | ContextMenuBuiltInItems
 | print : Boolean = true Lets the user send the displayed frame image to a printer. | ContextMenuBuiltInItems
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | quality : Boolean = true Lets the user set the resolution of the SWF file at run time. | ContextMenuBuiltInItems
 | rewind : Boolean = true Lets the user set a SWF file to play from the first frame when selected, at any time (does not appear for a single-frame SWF file). | ContextMenuBuiltInItems
 | save : Boolean = true Lets the user with Shockmachine installed save a SWF file. | ContextMenuBuiltInItems
 | zoom : Boolean = true Lets the user zoom in and out on a SWF file at run time. | ContextMenuBuiltInItems
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ContextMenuBuiltInItems() Creates a new ContextMenuBuiltInItems object so that you can set the properties for Flash Player to display or hide each menu item. | ContextMenuBuiltInItems
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
forwardAndBack property
public var forwardAndBack:Boolean = true

Lets the user move forward or backward one frame in a SWF file at run time (does not appear for a single-frame SWF file).

loop property
public var loop:Boolean = true

Lets the user set a SWF file to start over automatically when it reaches the final frame (does not appear for a single-frame SWF file).

play property
public var play:Boolean = true

Lets the user start a paused SWF file (does not appear for a single-frame SWF file).

print property
public var print:Boolean = true

Lets the user send the displayed frame image to a printer.

quality property
public var quality:Boolean = true

Lets the user set the resolution of the SWF file at run time.

rewind property
public var rewind:Boolean = true

Lets the user set a SWF file to play from the first frame when selected, at any time (does not appear for a single-frame SWF file).

save property
public var save:Boolean = true

Lets the user with Shockmachine installed save a SWF file.

zoom property
public var zoom:Boolean = true

Lets the user zoom in and out on a SWF file at run time.

Constructor detail
ContextMenuBuiltInItems () constructor
public function ContextMenuBuiltInItems()

Creates a new ContextMenuBuiltInItems object so that you can set the properties for Flash Player to display or hide each menu item.

Examples

The following example uses the class ContextMenuBuiltInItemsExample to remove the normal context menu items from the stage and add a new menu item. This is accomplished with the following steps:
  1. A property myContextMenu is declared and then assigned to a new ContextMenu object.
  2. The method removeDefaultItems() is called, which removes all built-in context menu items except Print.
  3. The method addCustomMenuItems() is called, which places a menu item called Hello World into the customItems array using the push() method of Array.
  4. The Hello World menu item is then added to the Stage's context menu item list.
  5. A TextField object with the text "Right Click" is added to the center of the Stage by using addChild() via createLabel().
package {
    import flash.ui.ContextMenu;
    import flash.ui.ContextMenuItem;
    import flash.ui.ContextMenuBuiltInItems;
    import flash.display.Sprite;
    import flash.text.TextField;

    public class ContextMenuBuiltInItemsExample extends Sprite {
        private var myContextMenu:ContextMenu;

        public function ContextMenuBuiltInItemsExample() {
            myContextMenu = new ContextMenu();
            removeDefaultItems();
            addCustomMenuItems();
            this.contextMenu = myContextMenu;
            addChild(createLabel());
        }

        private function removeDefaultItems():void {
            myContextMenu.hideBuiltInItems();

            var defaultItems:ContextMenuBuiltInItems = myContextMenu.builtInItems;
            defaultItems.print = true;
        }

        private function addCustomMenuItems():void {
            var item:ContextMenuItem = new ContextMenuItem("Hello World");
            myContextMenu.customItems.push(item);
        }

        private function createLabel():TextField {
            var txtField:TextField = new TextField();
            txtField.text = "Right Click";
            txtField.x = this.stage.stageWidth/2 - txtField.width/2;
            txtField.y = this.stage.stageHeight/2 - txtField.height/2;
            return txtField;
        }
    }
}


flash.ui.ContextMenuItem (Flex™ 2 Language Reference)

Class ContextMenuItem | Properties | Methods | Events | Examples
Package | flash.ui
Class | public final class ContextMenuItem
Inheritance | ContextMenuItem Inheritance EventDispatcher Inheritance Object

Use the ContextMenuItem class to create custom menu items to display in the Flash Player context menu. Each ContextMenuItem object has a caption (text) that is displayed in the context menu. To add a new item to a context menu, you add it to the customItems array of a ContextMenu object.

With the properties of the ContextMenuItem class you can enable or disable specific menu items, and you can make items visible or invisible.

You write an event handler for the menuItemSelect event to add functionality to the menu item when the user selects it.

Custom menu items appear at the top of the context menu, above any built-in items. A separator bar always divides custom menu items from built-in items.

Restrictions:

  • You can add no more than 15 custom items to a context menu.
  • Each caption must contain at least one visible character.
  • Control characters, newlines, and other white space characters are ignored.
  • No caption can be more than 100 characters long.
  • Captions that are identical to any built-in menu item, or to another custom item, are ignored, whether the matching item is visible or not. Menu captions are compared to built-in captions or existing custom captions without regard to case, punctuation, or white space.
  • The following captions are not allowed, but the words may be used in conjunction with other words to form a custom caption (for example, although "Paste" is not allowed, "Paste tastes great" is allowed):
    •  Save
 Zoom In
 Zoom Out
 100%
 Show All
 Quality
 Play
 Loop
 Rewind
 Forward
 Back
 Movie not loaded
 About
 Print
 Show Redraw Regions
 Debugger
 Undo
 Cut
 Copy
 Paste
 Delete
 Select All
 Open
 Open in new window
 Copy link
  • None of the following words can appear in a custom caption on their own or in conjunction with other words:
    •  Adobe
 Macromedia
 Flash Player
 Settings

Note: When the player is running on a non-English system, the caption strings are compared to both the English list and the localized equivalents.

View the examples.

See also

ContextMenu class
ContextMenuBuiltInItems class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | caption : String Specifies the menu item caption (text) displayed in the context menu. | ContextMenuItem
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | enabled : Boolean Indicates whether the specified menu item is enabled or disabled. | ContextMenuItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | separatorBefore : Boolean Indicates whether a separator bar should appear above the specified menu item. | ContextMenuItem
 | visible : Boolean Indicates whether the specified menu item is visible when the Flash Player context menu is displayed. | ContextMenuItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ContextMenuItem(caption:String, separatorBefore:Boolean = false, enabled:Boolean = true, visible:Boolean = true)
Creates a new ContextMenuItem object that can be added to the ContextMenu.customItems array.
ContextMenuItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
clone():ContextMenuItem
Creates and returns a copy of the specified ContextMenuItem object.
ContextMenuItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | menuItemSelect | Dispatched when a user selects an item from a context menu. | ContextMenuItem
Property detail
caption property
caption:String [read-write]

Specifies the menu item caption (text) displayed in the context menu. See the ContextMenuItem class overview for caption value restrictions.

Implementation
    public function get caption():String
    public function set caption(value:String):void
enabled property
enabled:Boolean [read-write]

Indicates whether the specified menu item is enabled or disabled.

The default value is true.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void
separatorBefore property
separatorBefore:Boolean [read-write]

Indicates whether a separator bar should appear above the specified menu item.

Note: A separator bar always appears between any custom menu items and the built-in menu items.

The default value is false.

Implementation
    public function get separatorBefore():Boolean
    public function set separatorBefore(value:Boolean):void
visible property
visible:Boolean [read-write]

Indicates whether the specified menu item is visible when the Flash Player context menu is displayed.

The default value is true.

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
Constructor detail
ContextMenuItem () constructor
public function ContextMenuItem(caption:String, separatorBefore:Boolean = false, enabled:Boolean = true, visible:Boolean = true)

Creates a new ContextMenuItem object that can be added to the ContextMenu.customItems array.

Parameters
caption:String — Specifies the text associated with the menu item. See the ContextMenuItem class overview for caption value restrictions.
separatorBefore:Boolean (default = false) — Specifies whether a separator bar appears above the menu item in the context menu. The default value is false.
enabled:Boolean (default = true) — Specifies whether the menu item is enabled or disabled in the context menu. The default value is true (enabled). This parameter is optional.
visible:Boolean (default = true) — Specifies whether the menu item is visible or invisible. The default value is true (visible).
Method detail
clone () method
public function clone():ContextMenuItem

Creates and returns a copy of the specified ContextMenuItem object. The copy includes all properties of the original object.

Returns
ContextMenuItem — A ContextMenuItem object that contains all the properties of the original object.
Event detail
menuItemSelect event
Event object type: flash.events.ContextMenuEvent
ContextMenuEvent.type property = flash.events.ContextMenuEvent.MENU_ITEM_SELECT

Dispatched when a user selects an item from a context menu. The user generates the context menu by clicking the secondary button of the user's pointing device.

Defines the value of the type property of a menuItemSelect event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
contextMenuOwner | The display list object to which the menu is attached.
currentTarget | The object that is actively processing the Event object with an event listener.
mouseTarget | The display list object on which the user right-clicked to display the context menu.
target | The ContextMenuItem object that has been selected. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
Examples

The following example uses the class ContextMenuBuiltInItemsExample to remove the default context menu items from the Stage and add a new menu item. This is accomplished with the following steps:
  1. A property myContextMenu is declared and then assigned to a new ContextMenu object.
  2. The method removeDefaultItems() is called, which removes all built-in context menu items except Print.
  3. The method addCustomMenuItems() is called, which places a menu item called Hello World into the customItems array by using the push() method of Array.
  4. The Hello World context menu item is added to the Stage's context menu item list.
  5. A TextField object with the text "Right Click Here" is added to the stage.
package {
    import flash.ui.ContextMenu;
    import flash.ui.ContextMenuItem;
    import flash.ui.ContextMenuBuiltInItems;
    import flash.display.Sprite;
    import flash.text.TextField;

    public class ContextMenuItemExample extends Sprite {
        private var myContextMenu:ContextMenu;

        public function ContextMenuItemExample() {
            myContextMenu = new ContextMenu();
            removeDefaultItems();
            addCustomMenuItems();
            this.contextMenu = myContextMenu;
            addChild(createLabel());
        }

        private function removeDefaultItems():void {
            myContextMenu.hideBuiltInItems();

            var defaultItems:ContextMenuBuiltInItems = myContextMenu.builtInItems;
            defaultItems.print = true;
        }

        private function addCustomMenuItems():void {
            var item:ContextMenuItem = new ContextMenuItem("Hello World");
            myContextMenu.customItems.push(item);
        }

        private function createLabel():TextField {
            var txtField:TextField = new TextField();
            txtField.text = "Right Click Here";
            return txtField;
        }
    }
}


flash.ui.Keyboard (Flex™ 2 Language Reference)

Class Keyboard | Properties | Methods | Constants
Package | flash.ui
Class | public final class Keyboard
Inheritance | Keyboard Inheritance Object

The Keyboard class is used to build an interface that can be controlled by a user with a standard keyboard. You can use the methods and properties of the Keyboard class without using a constructor. The properties of the Keyboard class are constants representing the keys that are most commonly used to control games.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | capsLock : Boolean [static][read-only] Specifies whether the Caps Lock key is activated (true) or not (false). | Keyboard
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | numLock : Boolean [static][read-only] Specifies whether the Num Lock key is activated (true) or not (false). | Keyboard
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isAccessible():Boolean [static] Specifies whether the last key pressed is accessible by other SWF files. | Keyboard
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BACKSPACE : uint = 8 [static] Constant associated with the key code value for the Backspace key (8). | Keyboard
 | CAPS_LOCK : uint = 20 [static] Constant associated with the key code value for the Caps Lock key (20). | Keyboard
 | CONTROL : uint = 17 [static] Constant associated with the key code value for the Control key (17). | Keyboard
 | DELETE : uint = 46 [static] Constant associated with the key code value for the Delete key (46). | Keyboard
 | DOWN : uint = 40 [static] Constant associated with the key code value for the Down Arrow key (40). | Keyboard
 | END : uint = 35 [static] Constant associated with the key code value for the End key (35). | Keyboard
 | ENTER : uint = 13 [static] Constant associated with the key code value for the Enter key (13). | Keyboard
 | ESCAPE : uint = 27 [static] Constant associated with the key code value for the Escape key (27). | Keyboard
 | F1 : uint = 112 [static] Constant associated with the key code value for the F1 key (112). | Keyboard
 | F10 : uint = 121 [static] Constant associated with the key code value for the F10 key (121). | Keyboard
 | F11 : uint = 122 [static] Constant associated with the key code value for the F11 key (122). | Keyboard
 | F12 : uint = 123 [static] Constant associated with the key code value for the F12 key (123). | Keyboard
 | F13 : uint = 124 [static] Constant associated with the key code value for the F13 key (124). | Keyboard
 | F14 : uint = 125 [static] Constant associated with the key code value for the F14 key (125). | Keyboard
 | F15 : uint = 126 [static] Constant associated with the key code value for the F15 key (126). | Keyboard
 | F2 : uint = 113 [static] Constant associated with the key code value for the F2 key (113). | Keyboard
 | F3 : uint = 114 [static] Constant associated with the key code value for the F3 key (114). | Keyboard
 | F4 : uint = 115 [static] Constant associated with the key code value for the F4 key (115). | Keyboard
 | F5 : uint = 116 [static] Constant associated with the key code value for the F5 key (116). | Keyboard
 | F6 : uint = 117 [static] Constant associated with the key code value for the F6 key (117). | Keyboard
 | F7 : uint = 118 [static] Constant associated with the key code value for the F7 key (118). | Keyboard
 | F8 : uint = 119 [static] Constant associated with the key code value for the F8 key (119). | Keyboard
 | F9 : uint = 120 [static] Constant associated with the key code value for the F9 key (120). | Keyboard
 | HOME : uint = 36 [static] Constant associated with the key code value for the Home key (36). | Keyboard
 | INSERT : uint = 45 [static] Constant associated with the key code value for the Insert key (45). | Keyboard
 | LEFT : uint = 37 [static] Constant associated with the key code value for the Left Arrow key (37). | Keyboard
 | NUMPAD_0 : uint = 96 [static] Constant associated with the key code value for the number 0 key on the number pad (96). | Keyboard
 | NUMPAD_1 : uint = 97 [static] Constant associated with the key code value for the number 1 key on the number pad (97). | Keyboard
 | NUMPAD_2 : uint = 98 [static] Constant associated with the key code value for the number 2 key on the number pad (98). | Keyboard
 | NUMPAD_3 : uint = 99 [static] Constant associated with the key code value for the number 3 key on the number pad (99). | Keyboard
 | NUMPAD_4 : uint = 100 [static] Constant associated with the key code value for the number 4 key on the number pad (100). | Keyboard
 | NUMPAD_5 : uint = 101 [static] Constant associated with the key code value for the number 5 key on the number pad (101). | Keyboard
 | NUMPAD_6 : uint = 102 [static] Constant associated with the key code value for the number 6 key on the number pad (102). | Keyboard
 | NUMPAD_7 : uint = 103 [static] Constant associated with the key code value for the number 7 key on the number pad (103). | Keyboard
 | NUMPAD_8 : uint = 104 [static] Constant associated with the key code value for the number 8 key on the number pad (104). | Keyboard
 | NUMPAD_9 : uint = 105 [static] Constant associated with the key code value for the number 9 key on the number pad (105). | Keyboard
 | NUMPAD_ADD : uint = 107 [static] Constant associated with the key code value for the addition key on the number pad (107). | Keyboard
 | NUMPAD_DECIMAL : uint = 110 [static] Constant associated with the key code value for the decimal key on the number pad (110). | Keyboard
 | NUMPAD_DIVIDE : uint = 111 [static] Constant associated with the key code value for the division key on the number pad (111). | Keyboard
 | NUMPAD_ENTER : uint = 108 [static] Constant associated with the key code value for the Enter key on the number pad (108). | Keyboard
 | NUMPAD_MULTIPLY : uint = 106 [static] Constant associated with the key code value for the multiplication key on the number pad (106). | Keyboard
 | NUMPAD_SUBTRACT : uint = 109 [static] Constant associated with the key code value for the subtraction key on the number pad (109). | Keyboard
 | PAGE_DOWN : uint = 34 [static] Constant associated with the key code value for the Page Down key (34). | Keyboard
 | PAGE_UP : uint = 33 [static] Constant associated with the key code value for the Page Up key (33). | Keyboard
 | RIGHT : uint = 39 [static] Constant associated with the key code value for the Right Arrow key (39). | Keyboard
 | SHIFT : uint = 16 [static] Constant associated with the key code value for the Shift key (16). | Keyboard
 | SPACE : uint = 32 [static] Constant associated with the key code value for the Spacebar (32). | Keyboard
 | TAB : uint = 9 [static] Constant associated with the key code value for the Tab key (9). | Keyboard
 | UP : uint = 38 [static] Constant associated with the key code value for the Up Arrow key (38). | Keyboard
Property detail
capsLock property
capsLock:Boolean [read-only]

Specifies whether the Caps Lock key is activated (true) or not (false).

Implementation
    public static function get capsLock():Boolean
numLock property
numLock:Boolean [read-only]

Specifies whether the Num Lock key is activated (true) or not (false).

Implementation
    public static function get numLock():Boolean
Method detail
isAccessible () method
public static function isAccessible():Boolean

Specifies whether the last key pressed is accessible by other SWF files. By default, security restrictions prevent code from a SWF file in one domain from accessing a keystroke generated from a SWF file in another domain.

Returns
Boolean — The value true if the last key pressed can be accessed. If access is not permitted, this method returns false.
Constant detail
BACKSPACE constant
public static const BACKSPACE:uint = 8

Constant associated with the key code value for the Backspace key (8).

CAPS_LOCK constant
public static const CAPS_LOCK:uint = 20

Constant associated with the key code value for the Caps Lock key (20).

CONTROL constant
public static const CONTROL:uint = 17

Constant associated with the key code value for the Control key (17).

DELETE constant
public static const DELETE:uint = 46

Constant associated with the key code value for the Delete key (46).

DOWN constant
public static const DOWN:uint = 40

Constant associated with the key code value for the Down Arrow key (40).

END constant
public static const END:uint = 35

Constant associated with the key code value for the End key (35).

ENTER constant
public static const ENTER:uint = 13

Constant associated with the key code value for the Enter key (13).

ESCAPE constant
public static const ESCAPE:uint = 27

Constant associated with the key code value for the Escape key (27).

F1 constant
public static const F1:uint = 112

Constant associated with the key code value for the F1 key (112).

F10 constant
public static const F10:uint = 121

Constant associated with the key code value for the F10 key (121).

F11 constant
public static const F11:uint = 122

Constant associated with the key code value for the F11 key (122).

F12 constant
public static const F12:uint = 123

Constant associated with the key code value for the F12 key (123).

F13 constant
public static const F13:uint = 124

Constant associated with the key code value for the F13 key (124).

F14 constant
public static const F14:uint = 125

Constant associated with the key code value for the F14 key (125).

F15 constant
public static const F15:uint = 126

Constant associated with the key code value for the F15 key (126).

F2 constant
public static const F2:uint = 113

Constant associated with the key code value for the F2 key (113).

F3 constant
public static const F3:uint = 114

Constant associated with the key code value for the F3 key (114).

F4 constant
public static const F4:uint = 115

Constant associated with the key code value for the F4 key (115).

F5 constant
public static const F5:uint = 116

Constant associated with the key code value for the F5 key (116).

F6 constant
public static const F6:uint = 117

Constant associated with the key code value for the F6 key (117).

F7 constant
public static const F7:uint = 118

Constant associated with the key code value for the F7 key (118).

F8 constant
public static const F8:uint = 119

Constant associated with the key code value for the F8 key (119).

F9 constant
public static const F9:uint = 120

Constant associated with the key code value for the F9 key (120).

HOME constant
public static const HOME:uint = 36

Constant associated with the key code value for the Home key (36).

INSERT constant
public static const INSERT:uint = 45

Constant associated with the key code value for the Insert key (45).

LEFT constant
public static const LEFT:uint = 37

Constant associated with the key code value for the Left Arrow key (37).

NUMPAD_0 constant
public static const NUMPAD_0:uint = 96

Constant associated with the key code value for the number 0 key on the number pad (96).

NUMPAD_1 constant
public static const NUMPAD_1:uint = 97

Constant associated with the key code value for the number 1 key on the number pad (97).

NUMPAD_2 constant
public static const NUMPAD_2:uint = 98

Constant associated with the key code value for the number 2 key on the number pad (98).

NUMPAD_3 constant
public static const NUMPAD_3:uint = 99

Constant associated with the key code value for the number 3 key on the number pad (99).

NUMPAD_4 constant
public static const NUMPAD_4:uint = 100

Constant associated with the key code value for the number 4 key on the number pad (100).

NUMPAD_5 constant
public static const NUMPAD_5:uint = 101

Constant associated with the key code value for the number 5 key on the number pad (101).

NUMPAD_6 constant
public static const NUMPAD_6:uint = 102

Constant associated with the key code value for the number 6 key on the number pad (102).

NUMPAD_7 constant
public static const NUMPAD_7:uint = 103

Constant associated with the key code value for the number 7 key on the number pad (103).

NUMPAD_8 constant
public static const NUMPAD_8:uint = 104

Constant associated with the key code value for the number 8 key on the number pad (104).

NUMPAD_9 constant
public static const NUMPAD_9:uint = 105

Constant associated with the key code value for the number 9 key on the number pad (105).

NUMPAD_ADD constant
public static const NUMPAD_ADD:uint = 107

Constant associated with the key code value for the addition key on the number pad (107).

NUMPAD_DECIMAL constant
public static const NUMPAD_DECIMAL:uint = 110

Constant associated with the key code value for the decimal key on the number pad (110).

NUMPAD_DIVIDE constant
public static const NUMPAD_DIVIDE:uint = 111

Constant associated with the key code value for the division key on the number pad (111).

NUMPAD_ENTER constant
public static const NUMPAD_ENTER:uint = 108

Constant associated with the key code value for the Enter key on the number pad (108).

NUMPAD_MULTIPLY constant
public static const NUMPAD_MULTIPLY:uint = 106

Constant associated with the key code value for the multiplication key on the number pad (106).

NUMPAD_SUBTRACT constant
public static const NUMPAD_SUBTRACT:uint = 109

Constant associated with the key code value for the subtraction key on the number pad (109).

PAGE_DOWN constant
public static const PAGE_DOWN:uint = 34

Constant associated with the key code value for the Page Down key (34).

PAGE_UP constant
public static const PAGE_UP:uint = 33

Constant associated with the key code value for the Page Up key (33).

RIGHT constant
public static const RIGHT:uint = 39

Constant associated with the key code value for the Right Arrow key (39).

SHIFT constant
public static const SHIFT:uint = 16

Constant associated with the key code value for the Shift key (16).

SPACE constant
public static const SPACE:uint = 32

Constant associated with the key code value for the Spacebar (32).

TAB constant
public static const TAB:uint = 9

Constant associated with the key code value for the Tab key (9).

UP constant
public static const UP:uint = 38

Constant associated with the key code value for the Up Arrow key (38).


flash.ui.KeyLocation (Flex™ 2 Language Reference)

Class KeyLocation | Properties | Methods | Constants
Package | flash.ui
Class | public final class KeyLocation
Inheritance | KeyLocation Inheritance Object

The KeyLocation class contains constants that indicate the location of a key pressed on the keyboard. The KeyLocation constants are used in the KeyboardEvent.keyLocation property.

See also

flash.events.KeyboardEvent.keyLocation

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | LEFT : uint = 1 [static] Indicates the key activated is in the left key location (there is more than one possible location for this key). | KeyLocation
 | NUM_PAD : uint = 3 [static] Indicates the key activation originated on the numeric keypad or with a virtual key corresponding to the numeric keypad. | KeyLocation
 | RIGHT : uint = 2 [static] Indicates the key activated is in the right key location (there is more than one possible location for this key). | KeyLocation
 | STANDARD : uint = 0 [static] Indicates the key activation is not distinguished as the left or right version of the key, and did not originate on the numeric keypad (or did not originate with a virtual key corresponding to the numeric keypad). | KeyLocation
Constant detail
LEFT constant
public static const LEFT:uint = 1

Indicates the key activated is in the left key location (there is more than one possible location for this key). Example: The left Shift key on a PC 101 Key US keyboard.

NUM_PAD constant
public static const NUM_PAD:uint = 3

Indicates the key activation originated on the numeric keypad or with a virtual key corresponding to the numeric keypad. Example: The 1 key on a PC 101 Key US keyboard located on the numeric pad.

RIGHT constant
public static const RIGHT:uint = 2

Indicates the key activated is in the right key location (there is more than one possible location for this key). Example: The right Shift key on a PC 101 Key US keyboard.

STANDARD constant
public static const STANDARD:uint = 0

Indicates the key activation is not distinguished as the left or right version of the key, and did not originate on the numeric keypad (or did not originate with a virtual key corresponding to the numeric keypad). Example: The Q key on a PC 101 Key US keyboard.


flash.ui.Mouse (Flex™ 2 Language Reference)

Class Mouse | Properties | Methods | Examples
Package | flash.ui
Class | public final class Mouse
Inheritance | Mouse Inheritance Object

The methods of the Mouse class are used to hide and show the mouse pointer. The Mouse class is a top-level class whose properties and methods you can access without using a constructor. The pointer is visible by default, but you can hide it and implement a custom pointer.

View the examples.

See also

flash.events.MouseEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | hide():void [static] Hides the pointer. | Mouse
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | show():void [static] Displays the pointer. | Mouse
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
hide () method
public static function hide():void

Hides the pointer. The pointer is visible by default.

See also

flash.display.DisplayObject.mouseX
flash.display.DisplayObject.mouseY
show () method
public static function show():void

Displays the pointer. The pointer is visible by default.

See also

flash.display.DisplayObject.mouseX
flash.display.DisplayObject.mouseY
Examples

The following example uses the MouseExample, SimpleButton, ButtonDisplayState, and CustomCursor classes to place a simple button on the Stage. The button has a custom pointer and the button changes when clicked. This is accomplished with the following steps:
  1. Declare the following instance properties: cursor of type CustomCursor, child of type CustomButton, and gutter of type uint.
  2. Assign child to a new CustomButton instance, set its x and y coordinates to 10 pixels each, and then add the instance to the display list. The CustomButton class overrides the downState, upState, overState, and hitTestState properties in SimpleButton. Each of these properties instantiates a ButtonDisplayState object, which draws a different square, depending on the state of the child instance.
  3. The child instance is then used to add a MOUSE_OVER event listener and mouseOverHandler() listener method, along with a MOUSE_OUT event listener and associated mouseOutHandler() method.
  4. The event listeners work as follows:
    • mouseOverHandler: Hides the "normal" pointer and adds a MOUSE_MOVE listener, which processes the mouse moves using mouseMoveHandler(), described below.
    • mouseOutHandler: When the mouse moves outside the custom button, the "normal" pointer is shown, the MOUSE_MOVE event listener is removed, and the custom cursor's visibility is set to false.
    • mouseMoveHandler: Moves the custom cursor around wherever the pointer is moved and sets the custom cursor's visibility to true.
  5. Back in the MouseExample constructor, the cursor property is assigned to a new CustomCursor object and then added to the display list using addChild(). The CustomCursor class draws a small nearly black square in place of the "normal" pointer whenever the mouse is over child.
  6. A fourth event listener of type MOUSE_LEAVE is added, with the associated mouseLeaveHandler() method. In this method (called if the mouse leaves the Stage), mouseOutHandler() is passed a new mouseMove listener object, which essentially removes the pointer so it is not left on the Stage.
package {
    import flash.display.Sprite;
    import flash.display.DisplayObject;
    import flash.ui.Mouse;
    import flash.events.*;

    public class MouseExample extends Sprite {
         private var cursor:CustomCursor;
         private var child:CustomButton;
         private var gutter:uint = 10;

        public function MouseExample() {
            child = new CustomButton();
            child.x = gutter;
            child.y = gutter;
            addChild(child);

            child.addEventListener(MouseEvent.MOUSE_OVER, mouseOverHandler);
            child.addEventListener(MouseEvent.MOUSE_OUT, mouseOutHandler);

            cursor = new CustomCursor();
            addChild(cursor);

            stage.addEventListener(Event.MOUSE_LEAVE, mouseLeaveHandler);
        }

        private function mouseOverHandler(event:MouseEvent):void {
            trace("mouseOverHandler");
            Mouse.hide();
            child.addEventListener(MouseEvent.MOUSE_MOVE, mouseMoveHandler);
        }

        private function mouseOutHandler(event:MouseEvent):void {
            trace("mouseOutHandler");
            Mouse.show();
            child.removeEventListener(MouseEvent.MOUSE_MOVE, mouseMoveHandler);
            cursor.visible = false;
        }

        private function mouseMoveHandler(event:MouseEvent):void {
            trace("mouseMoveHandler");
            cursor.x = event.localX;
            cursor.y = event.localY;
            event.updateAfterEvent();
            cursor.visible = true;
        }

        private function mouseLeaveHandler(event:Event):void {
            trace("mouseLeaveHandler");
            mouseOutHandler(new MouseEvent(MouseEvent.MOUSE_MOVE));
        }
    }
}

import flash.display.Shape;
import flash.display.SimpleButton;

class CustomButton extends SimpleButton {
    var upColor:uint = 0xFFCC00;
    var overColor:uint = 0xCCFF00;
    var downColor:uint = 0x00CCFF;
    var size:uint = 80;

    public function CustomButton() {
        downState = new ButtonDisplayState(downColor, size+10);
        overState = new ButtonDisplayState(overColor, size);
        upState = new ButtonDisplayState(upColor, size);
        hitTestState = new ButtonDisplayState(upColor, size);
    }
}

class ButtonDisplayState extends Shape {
    var bgColor:uint;
    var size:uint;

    public function ButtonDisplayState(bgColor:uint, size:uint) {
        this.bgColor = bgColor;
        this.size = size;
        draw();
    }

    private function draw():void {
        graphics.clear();
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, size, size);
        graphics.endFill();
    }
}

class CustomCursor extends Shape {
    var bgColor:uint = 0x333333;
    var size:uint = 10;

    public function CustomCursor() {
        visible = false;
        draw();
    }

    private function draw():void {
        graphics.clear();
        graphics.beginFill(bgColor);
        graphics.drawRect(0, 0, size, size);
        graphics.endFill();
    }
}


flash.utils Summary (Flex™ 2 Language Reference)

Package flash.utils | Functions | Interfaces | Classes

The flash.utils package contains utility classes, such as data structures like ByteArray.

Functions
Function | Description
clearInterval | Cancels a specified setInterval() call.
clearTimeout | Cancels a specified setTimeout() call.
describeType | Produces an XML object that describes the ActionScript object named as the parameter of the method.
escapeMultiByte | Returns an escaped copy of the input string encoded as either UTF-8 or system code page, depending on the value of System.useCodePage.
getDefinitionByName | Returns a reference to the class object of the class specified by the name parameter.
getQualifiedClassName | Returns the fully qualified class name of an object.
getQualifiedSuperclassName | Returns the fully qualified class name of the base class of the object specified by the value parameter.
getTimer | Returns the number of milliseconds that have elapsed since Flash Player was initialized, and is used to compute relative time.
setInterval | Runs a function at a specified interval (in milliseconds).
setTimeout | Runs a specified function after a specified delay (in milliseconds).
unescapeMultiByte | Returns an unescaped copy of the input string, which is decoded from either system code page page or UTF-8 depending on the value of System.useCodePage.
Interfaces
Interface | Description
IDataInput | The IDataInput interface provides a set of methods for reading binary data.
IDataOutput | The IDataOutput interface provides a set of methods for writing binary data.
IExternalizable | The IExternalizable interface provides control over serialization of a class as it is encoded into a data stream.
Classes
Class | Description
ByteArray | The ByteArray class provides methods and properties to optimize reading, writing, and working with binary data.
Dictionary | The Dictionary class lets you create a dynamic collection of properties, which uses strict equality (===) for key comparison.
Endian | The Endian class contains values that denote the byte order used to represent multibyte numbers.
Proxy | The Proxy class lets you override the default behavior of ActionScript operations (such as retrieving and modifying properties) on an object.
Timer | The Timer class is the interface to Flash Player timers.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.utils Details (Flex™ 2 Language Reference)

Package flash.utils | Functions

The flash.utils package contains a variety of package-level functions for timing code execution, retrieving information about classes and objects, and converting escape characters.
Public Functions
Function |  | Defined by
 | clearInterval(id:uint):void Cancels a specified setInterval() call. | flash.utils
 | clearTimeout(id:uint):void Cancels a specified setTimeout() call. | flash.utils
 | describeType(value:*):XML Produces an XML object that describes the ActionScript object named as the parameter of the method. | flash.utils
 | escapeMultiByte(value:String):String Returns an escaped copy of the input string encoded as either UTF-8 or system code page, depending on the value of System.useCodePage. | flash.utils
 | getDefinitionByName(name:String):Object Returns a reference to the class object of the class specified by the name parameter. | flash.utils
 | getQualifiedClassName(value:*):String Returns the fully qualified class name of an object. | flash.utils
 | getQualifiedSuperclassName(value:*):String Returns the fully qualified class name of the base class of the object specified by the value parameter. | flash.utils
 | getTimer():int Returns the number of milliseconds that have elapsed since Flash Player was initialized, and is used to compute relative time. | flash.utils
 | setInterval(closure:Function, delay:Number, ... arguments):uint Runs a function at a specified interval (in milliseconds). | flash.utils
 | setTimeout(closure:Function, delay:Number, ... arguments):uint Runs a specified function after a specified delay (in milliseconds). | flash.utils
 | unescapeMultiByte(value:String):String Returns an unescaped copy of the input string, which is decoded from either system code page page or UTF-8 depending on the value of System.useCodePage. | flash.utils
Function detail
clearInterval () function
public function clearInterval(id:uint):void

Cancels a specified setInterval() call.

Parameters
id:uint — The ID of the setInterval() call, which you set to a variable, as in the following:
  var my_timedProcess:uint = setInterval(my_repeatedFunction, 1000);

  // ...

  clearInterval(my_timedProcess);

See also

setInterval()
clearTimeout () function
public function clearTimeout(id:uint):void

Cancels a specified setTimeout() call.

Parameters
id:uint — The ID of the setTimeout() call, which you set to a variable, as in the following:
  var my_timedProcess:uint = setTimeout(my_delayedFunction, 1000);

  // ...

  clearTimeout(my_timedProcess);

See also

setTimeout()
describeType () function
public function describeType(value:*):XML

Produces an XML object that describes the ActionScript object named as the parameter of the method. This method implements the programming concept of reflection for the ActionScript language.

If the value parameter is an instance of a type, the returned XML object includes all the instance properties of that type, but does not include any static properties. You can check for this condition when you parse the XML object by examining the value of the <type> tag's isStatic attribute, which is false when the value parameter is an instance of a type.

To obtain the static properties of a type, pass the type itself for the value parameter. The returned XML object includes not only the type's static properties, but also all of its instance properties. The instance properties are nested inside a tag named <factory> to distinguish them from the static properties. In this case, the isStatic attribute of the <type> tag is true.

Note: If you need only to traverse an object's inheritance hierarchy and do not need the other information provided by describeType(), use the getQualifiedClassName() and getQualifiedSuperclassName() functions instead.

The following table describes some of the tags and attributes of the XML object generated by describeType():

Tag | Attribute | Description
<type> |  | The root tag of the XML object.
 | name | The name of the ActionScript object's data type.
 | base | The immediate superclass of the ActionScript object's defining class. If the ActionScript object is a class object, the value is Class.
 | isDynamic | true if the ActionScript object's defining class is dynamic; false otherwise. If the ActionScript object is a class object, the value is true because the Class class is dynamic.
 | isFinal | true if the ActionScript object's defining class is final; false otherwise.
 | isStatic | true if the ActionScript object is a class object or constructor function; false otherwise. This attribute is named isStatic because if it is true, any tags that are not nested inside the factory tag are static.
<extendsClass> |  | There is a separate extendsClass tag for each superclass of the ActionScript object's defining class.
 | type | The name of a superclass that the ActionScript object's defining class extends.
<implementsInterface> |  | There is a separate implementsInterface tag for each interface implemented by the ActionScript object's defining class or any of its superclasses.
 | type | The name of an interface that the ActionScript object's defining class implements.
<accessor> |  | An accessor is a property defined by getter and setter functions.
 | name | The name of the accessor.
 | access | The access rights of the property. Possible values include readonly, writeonly, and readwrite.
 | type | The data type of the property.
 | declaredBy | The class that contains the associated getter or setter functions.
<constant> |  | A constant is a property defined with the const statement.
 | name | The name of the constant.
 | type | The data type of the constant.
<method> |  | A method is a function declared as part of a class definition.
 | name | The name of the method.
 | declaredBy | The class that contains the method definition.
 | returnType | The data type of the method's return value.
<parameter> |  | There is a separate parameter tag for each parameter that a method defines. This tag is always nested inside a <method> tag.
 | index | A number corresponding to the order in which the parameter appears in the method's parameter list. The first parameter has a value of 1.
 | type | The data type of the parameter.
 | optional | true if the parameter is optional; false otherwise.
<variable> |  | A variable is a property defined with the var statement.
 | name | The name of the variable.
 | type | The data type of the variable.
<factory> |  | If the ActionScript object is a class object or constructor function, all instance properties and methods are nested inside this tag. If the isStatic attribute of the <type> tag is true, all properties and methods that are not nested within the <factory> tag are static. This tag appears only if the ActionScript object is a class object or constructor function.
Parameters
value:* — The object for which a type description is desired. Any ActionScript value may be passed to this method including all available ActionScript types, object instances, primitive types such as uint, and class objects.

Returns
XML — An XML object containing details about the object that was passed in as a parameter. It provides the following information about the object:
  • The class of the object
  • The attributes of the class
  • The inheritance tree from the class to its base classes
  • The interfaces implemented by the class
  • The declared instance properties of the class
  • The declared static properties of the class
  • The instance methods of the class
  • The static methods of the class
  • For each method of the class, the name, number of parameters, return type, and parameter types

Note: describeType() only shows public properties and methods, and will not show properties and methods that are private, package internal or in custom namespaces.

See also

getQualifiedClassName()
getQualifiedSuperclassName()

Example
package {
    import flash.display.Sprite;
    import flash.utils.describeType;

    public class DescribeTypeExample extends Sprite {
        public function DescribeTypeExample() {
            var child:Sprite = new Sprite();
            var description:XML = describeType(child);
            trace(description..accessor.@name.toXMLString());
        }
    }
}

escapeMultiByte () function
public function escapeMultiByte(value:String):String

Returns an escaped copy of the input string encoded as either UTF-8 or system code page, depending on the value of System.useCodePage. Use of System.useCodePage allows legacy content encoded in local coce pages to be accessed by the player, but only on systems using that legacy code page. For example, Japanese data encoded as Shift-JIS will only be escaped and unescaped properly on an OS using a Japanese default code page.

Parameters
value:String — The string to be escaped.

Returns
String — An escaped copy of the input string. If System.useCodePage is true, the escaped string is encoded in the system code page. If System.useCodePage is false, the escaped string is encoded in UTF-8. For example, the input string "Crüe" will be escaped as "Cr%C3%BCe" on all systems if System.useCodePage is false. If system.useCodePage is true, and the system uses a Latin code page, "Crüe" will be escaped as "Cr%FCe". If the system uses a non Latin code page that does not contain the letter 'ü' the result will probably be "Cr?e".
getDefinitionByName () function
public function getDefinitionByName(name:String):Object

Returns a reference to the class object of the class specified by the name parameter.

Parameters
name:String — The name of a class.

Returns
Object — Returns a reference to the class object of the class specified by the name parameter.

Throws
ReferenceError — No public definition exists with the specified name.

Example
The following example uses the class GetDefinitionByNameExample to create an orange square on the stage. This is accomplished using the following steps:
  1. Variables for the background color of orange and size of 80 pixels are declared, which will later be used in drawing the square.
  2. Within the constructor, a variable ClassReference of type Class is assigned to Sprite.
  3. An instance of ClassReference called instance is instantiated.
  4. Since instance is, by reference, a Sprite object, a square can be drawn and added to the display list using the methods available to Sprite.
package {
    import flash.display.DisplayObject;
    import flash.display.Sprite;
    import flash.utils.getDefinitionByName;

    public class GetDefinitionByNameExample extends Sprite {
        private var bgColor:uint = 0xFFCC00;
        private var size:uint = 80;

        public function GetDefinitionByNameExample() {
            var ClassReference:Class = getDefinitionByName("flash.display.Sprite") as Class;
            var instance:Object = new ClassReference();
            instance.graphics.beginFill(bgColor);
            instance.graphics.drawRect(0, 0, size, size);
            instance.graphics.endFill();
            addChild(DisplayObject(instance));
        }
    }
}

getQualifiedClassName () function
public function getQualifiedClassName(value:*):String

Returns the fully qualified class name of an object.

Parameters
value:* — The object for which a fully qualified class name is desired. Any ActionScript value may be passed to this method including all available ActionScript types, object instances, primitive types such as uint, and class objects.

Returns
String — A string containing the fully qualified class name.

See also

describeType()
getQualifiedSuperclassName()
getQualifiedSuperclassName () function
public function getQualifiedSuperclassName(value:*):String

Returns the fully qualified class name of the base class of the object specified by the value parameter. This function provides a quicker way of retrieving the base class name than describeType(), but also doesn't provide all the information describeType() does.

After you retrieve the name of a class with this function, you can convert the class name to a class reference with the getDefinitionByName() function.

Note: This function restricts itself to instance hierarchies, whereas the describeType() function uses class object hierarchies if the value parameter is a data type. Calling describeType() on a data type returns the superclass based on the class object hierarchy, in which all class objects inherit from Class. The getQualifiedSuperclassName() function, however, ignores the class object hierarchy and returns the superclass based on the more familiar instance hierarchy. For example, calling getQualifiedSuperclassName(String) returns Object although technically the String class object inherits from Class. In other words, the results are the same whether you use an instance of a type or the type itself.

Parameters
value:* — Any value.

Returns
String — A fully qualified base class name, or null if none exists.

See also

describeType()
getDefinitionByName()
getQualifiedClassName()
getTimer () function
public function getTimer():int

Returns the number of milliseconds that have elapsed since Flash Player was initialized, and is used to compute relative time. For a calendar date (timestamp), see the Date object.

Returns
int — The number of milliseconds since Flash Player was initialized. If the player starts playing one SWF file, and another SWF file is loaded later, the return value is relative to when the first SWF file was loaded.

See also

Date class

Example
The following example uses the class GetTimerExample to get and print the number of milliseconds since the Flash Player started playing.
package {
    import flash.utils.getTimer;
    import flash.display.Sprite;

    public class GetTimerExample extends Sprite {
        public function GetTimerExample() {
            var duration:uint = getTimer();
            trace("duration: " + duration);
        }
    }
}

setInterval () function
public function setInterval(closure:Function, delay:Number, ... arguments):uint

Runs a function at a specified interval (in milliseconds).

Although you can use this method, it will generate a compiler warning. Instead of using the setInterval() method, consider creating a Timer object, with the specified interval, using 0 as the repeatCount parameter (which sets the timer to repeat indefinitely).

If you intend to use the clearInterval() method to cancel the setInterval() call, be sure to assign the setInterval() call to a variable (which the setInterval() method will later reference), as in the following:

  var my_timedProcess:uint = setInterval(my_repeatedFunction, 1000);

  // ...

  clearInterval(my_timedProcess);
Parameters
closure:Function — The name of the function to execute. Do not include quotation marks or parentheses, and do not specify parameters of the function to call. For example, use functionName, not functionName() or functionName(param).
delay:Number — The interval, in milliseconds.
... arguments — An optional list of arguments that are passed to the closure function.

Returns
uint — Unique numeric identifier for the timed process.

See also

clearInterval()
setTimeout () function
public function setTimeout(closure:Function, delay:Number, ... arguments):uint

Runs a specified function after a specified delay (in milliseconds).

Instead of using this method, consider creating a Timer object, with the specified interval, using 1 as the repeatCount parameter (which sets the timer to run only once).

If you intend to use the clearTimeout() method to cancel the setTimeout() call, be sure to assign the setTimeout() call to a variable (which the clearTimeout() method will later reference), as in the following:

  var my_timedProcess:uint = setTimeout(my_delayedFunction, 1000);

  // ...

  clearTimeout(my_timedProcess);
Parameters
closure:Function — The name of the function to execute. Do not include quotation marks or parentheses, and do not specify parameters of the function to call. For example, use functionName, not functionName() or functionName(param).
delay:Number — The delay, in milliseconds, until the function is executed.
... arguments — An optional list of arguments that are passed to the closure function.

Returns
uint — Unique numeric identifier for the timed process.

See also

clearTimeout()
unescapeMultiByte () function
public function unescapeMultiByte(value:String):String

Returns an unescaped copy of the input string, which is decoded from either system code page page or UTF-8 depending on the value of System.useCodePage. Use of System.useCodePage allows legacy content encoded in local coce pages to be accessed by the player, but only on systems using that legacy code page. For example, Japanese data encoded as Shift-JIS will only be escaped and unescaped properly on an OS using a Japanese default code page.

Parameters
value:String — The escaped string to be unescaped.

Returns
String — An unescaped copy of the input string. If System.useCodePage is true, the escaped string is decoded from the system code page. If System.useCodePage is false, the escaped string is decoded from UTF-8. For example, if the input string is "Cr%C3%BCe" and System.useCodePage is false, the result will be "Crüe" on all systems. If System.useCodePage is true and the input string is "Cr%FCe", and the system uses a Latin code page, the result will also be "Crüe". Unescaping "Cr%C3%BCe" with System.useCodePage set to true will produce different bad results on different systems, such as "Crüe" on a Latin system. Similarly, unescaping "Cr%FCe" with System.useCodePage set to false could procude "Cre" or "Cr?e" or other variations depending on the code page of the system.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.utils.ByteArray (Flex™ 2 Language Reference)

Class ByteArray | Properties | Methods | Examples
Package | flash.utils
Class | public class ByteArray
Inheritance | ByteArray Inheritance Object
Implements | IDataInput, IDataOutput

The ByteArray class provides methods and properties to optimize reading, writing, and working with binary data.

Note: The ByteArray class is for advanced ActionScript developers who need to access data on the byte level.

In-memory data is a packed array (the most compact representation for the data type) of bytes, but an instance of the ByteArray class can be manipulated with the standard ActionScript [] (array access) operators. It also can be read and written to as an in-memory file, using methods similar to those in the URLStream and Socket classes.

In addition, zlib compression and decompression are supported, as well as Action Message Format (AMF) object serialization.

Possible uses of the ByteArray class include the following:

  • Creating a custom protocol to connect to a server.
  • Writing your own URLEncoder/URLDecoder.
  • Writing your own AMF/Remoting packet.
  • Optimizing the size of your data by using data types.

View the examples.

See also

[] (array access)
Socket class
URLStream class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bytesAvailable : uint [read-only] The number of bytes of data available for reading from the current position in the byte array to the end of the array. | ByteArray
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | defaultObjectEncoding : uint [static] Denotes the default object encoding for the ByteArray class to use for a new ByteArray instance. | ByteArray
 | endian : String Changes or reads the byte order for the data; either "bigEndian" or "littleEndian". | ByteArray
 | length : uint The length of the ByteArray object, in bytes. | ByteArray
 | objectEncoding : uint Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading from, a ByteArray instance. | ByteArray
 | position : uint Moves, or returns the current position, in bytes, of the file pointer into the ByteArray object. | ByteArray
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ByteArray() Creates a ByteArray instance representing a packed array of bytes, so that you can use the methods and properties in this class to optimize your data storage and stream. | ByteArray
 | compress():void Compresses the byte array using zlib compression. | ByteArray
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | readBoolean():Boolean Reads a Boolean value from the byte stream. | ByteArray
 | readByte():int Reads a signed byte from the byte stream. | ByteArray
 | readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void Reads the number of data bytes, specified by the length parameter, from the byte stream. | ByteArray
 | readDouble():Number Reads an IEEE 754 double-precision (64-bit) floating-point number from the byte stream. | ByteArray
 | readFloat():Number Reads an IEEE 754 single-precision (32-bit) floating-point number from the byte stream. | ByteArray
 | readInt():int Reads a signed 32-bit integer from the byte stream. | ByteArray
 | readMultiByte(length:uint, charSet:String):String Reads a multibyte string of specified length from the byte stream using the specified character set. | ByteArray
 | readObject():* Reads an object from the byte array, encoded in AMF serialized format. | ByteArray
 | readShort():int Reads a signed 16-bit integer from the byte stream. | ByteArray
 | readUnsignedByte():uint Reads an unsigned byte from the byte stream. | ByteArray
 | readUnsignedInt():uint Reads an unsigned 32-bit integer from the byte stream. | ByteArray
 | readUnsignedShort():uint Reads an unsigned 16-bit integer from the byte stream. | ByteArray
 | readUTF():String Reads a UTF-8 string from the byte stream. | ByteArray
 | readUTFBytes(length:uint):String Reads a sequence of UTF-8 bytes specified by the length parameter from the byte stream and returns a string. | ByteArray
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Converts the byte array to a string. | ByteArray
 | uncompress():void Decompresses the byte array. | ByteArray
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
 | writeBoolean(value:Boolean):void Writes a Boolean value. | ByteArray
 | writeByte(value:int):void Writes a byte to the byte stream. | ByteArray
 | writeBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void Writes a sequence of length bytes from the specified byte array, bytes, starting offset (zero-based index) bytes into the byte stream. | ByteArray
 | writeDouble(value:Number):void Writes an IEEE 754 double-precision (64-bit) floating-point number to the byte stream. | ByteArray
 | writeFloat(value:Number):void Writes an IEEE 754 single-precision (32-bit) floating-point number to the byte stream. | ByteArray
 | writeInt(value:int):void Writes a 32-bit signed integer to the byte stream. | ByteArray
 | writeMultiByte(value:String, charSet:String):void Writes a multibyte string to the byte stream using the specified character set. | ByteArray
 | writeObject(object:*):void Writes an object into the byte array in AMF serialized format. | ByteArray
 | writeShort(value:int):void Writes a 16-bit integer to the byte stream. | ByteArray
 | writeUnsignedInt(value:uint):void Writes a 32-bit unsigned integer to the byte stream. | ByteArray
 | writeUTF(value:String):void Writes a UTF-8 string to the byte stream. | ByteArray
 | writeUTFBytes(value:String):void Writes a UTF-8 string to the byte stream. | ByteArray
Property detail
bytesAvailable property
bytesAvailable:uint [read-only]

The number of bytes of data available for reading from the current position in the byte array to the end of the array.

Use the bytesAvailable property in conjunction with the read methods each time you access a ByteArray object to ensure that you are reading valid data.

Implementation
    public function get bytesAvailable():uint
defaultObjectEncoding property
defaultObjectEncoding:uint [read-write]

Denotes the default object encoding for the ByteArray class to use for a new ByteArray instance. When you create a new ByteArray instance, the encoding on that instance starts with the value of defaultObjectEncoding. The defaultObjectEncoding property is initialized to ObjectEncoding.AMF3.

When an object is written to or read from binary data, the objectEncoding value is used to determine whether the ActionScript 3.0, ActionScript2.0, or ActionScript 1.0 format should be used. The value is a constant from the ObjectEncoding class.

Implementation
    public static function get defaultObjectEncoding():uint
    public function set defaultObjectEncoding(value:uint):void

See also

ObjectEncoding class
flash.utils.ByteArray.objectEncoding
endian property
endian:String [read-write]

Changes or reads the byte order for the data; either "bigEndian" or "littleEndian". The values are constants from the Endian class.

Implementation
    public function get endian():String
    public function set endian(value:String):void

See also

Endian class
length property
length:uint [read-write]

The length of the ByteArray object, in bytes.

If the length is set to a value that is larger than the current length, Flash Player fills the right side with zeros.

If the length is set to a value that is smaller than the current length, the array is truncated.

Implementation
    public function get length():uint
    public function set length(value:uint):void
objectEncoding property
objectEncoding:uint [read-write]

Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading from, a ByteArray instance. The value is a constant from the ObjectEncoding class.

Implementation
    public function get objectEncoding():uint
    public function set objectEncoding(value:uint):void

See also

ObjectEncoding class
flash.utils.ByteArray.defaultObjectEncoding
position property
position:uint [read-write]

Moves, or returns the current position, in bytes, of the file pointer into the ByteArray object. This is the point at which the next call to a read method starts reading or a write method starts writing.

Implementation
    public function get position():uint
    public function set position(value:uint):void
Constructor detail
ByteArray () constructor
public function ByteArray()

Creates a ByteArray instance representing a packed array of bytes, so that you can use the methods and properties in this class to optimize your data storage and stream.

Method detail
compress () method
public function compress():void

Compresses the byte array using zlib compression. The entire byte array is compressed.

See also

flash.utils.ByteArray.uncompress()
readBoolean () method
public function readBoolean():Boolean

Reads a Boolean value from the byte stream. A single byte is read, and true is returned if the byte is nonzero, false otherwise.

Returns
Boolean — Returns true if the byte is nonzero, false otherwise.

Throws
EOFError — There is not sufficient data available to read.
readByte () method
public function readByte():int

Reads a signed byte from the byte stream.

The returned value is in the range -128 to 127.

Returns
int — An integer between -128 and 127.

Throws
EOFError — There is not sufficient data available to read.
readBytes () method
public function readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void

Reads the number of data bytes, specified by the length parameter, from the byte stream. The bytes are read into the ByteArray object specified by the bytes parameter, starting at the position specified by offset.

Parameters
bytes:ByteArray — The ByteArray object to read data into.
offset:uint (default = 0) — The offset into bytes at which the data read should begin.
length:uint (default = 0) — The number of bytes to read. The default value of 0 causes all available data to be read.

Throws
EOFError — There is not sufficient data available to read.
readDouble () method
public function readDouble():Number

Reads an IEEE 754 double-precision (64-bit) floating-point number from the byte stream.

Returns
Number — A double-precision (64-bit) floating-point number.

Throws
EOFError — There is not sufficient data available to read.
readFloat () method
public function readFloat():Number

Reads an IEEE 754 single-precision (32-bit) floating-point number from the byte stream.

Returns
Number — A single-precision (32-bit) floating-point number.

Throws
EOFError — There is not sufficient data available to read.
readInt () method
public function readInt():int

Reads a signed 32-bit integer from the byte stream.

The returned value is in the range -2147483648 to 2147483647.

Returns
int — A 32-bit signed integer between -2147483648 and 2147483647.

Throws
EOFError — There is not sufficient data available to read.
readMultiByte () method
public function readMultiByte(length:uint, charSet:String):String

Reads a multibyte string of specified length from the byte stream using the specified character set.

Parameters
length:uint — The number of bytes from the byte stream to read.
charSet:String — The string denoting the character set to use to interpret the bytes. Possible character set strings include "shift-jis", "cn-gb", "iso-8859-1", and others. For a complete list, see Supported Character Sets.

Returns
String — UTF-8 encoded string.

Throws
EOFError — There is not sufficient data available to read.
readObject () method
public function readObject():*

Reads an object from the byte array, encoded in AMF serialized format.

Returns
* — The deserialized object.

Throws
EOFError — There is not sufficient data available to read.
readShort () method
public function readShort():int

Reads a signed 16-bit integer from the byte stream.

The returned value is in the range -32768 to 32767.

Returns
int — A 16-bit signed integer between -32768 and 32767.

Throws
EOFError — There is not sufficient data available to read.
readUnsignedByte () method
public function readUnsignedByte():uint

Reads an unsigned byte from the byte stream.

The returned value is in the range 0 to 255.

Returns
uint — A 32-bit unsigned integer between 0 and 255.

Throws
EOFError — There is not sufficient data available to read.
readUnsignedInt () method
public function readUnsignedInt():uint

Reads an unsigned 32-bit integer from the byte stream.

The returned value is in the range 0 to 4294967295.

Returns
uint — A 32-bit unsigned integer between 0 and 4294967295.

Throws
EOFError — There is not sufficient data available to read.
readUnsignedShort () method
public function readUnsignedShort():uint

Reads an unsigned 16-bit integer from the byte stream.

The returned value is in the range 0 to 65535.

Returns
uint — A 16-bit unsigned integer between 0 and 65535.

Throws
EOFError — There is not sufficient data available to read.
readUTF () method
public function readUTF():String

Reads a UTF-8 string from the byte stream. The string is assumed to be prefixed with an unsigned short indicating the length in bytes.

Returns
String — UTF-8 encoded string.

Throws
EOFError — There is not sufficient data available to read.

See also

flash.utils.IDataInput.readUTF()
readUTFBytes () method
public function readUTFBytes(length:uint):String

Reads a sequence of UTF-8 bytes specified by the length parameter from the byte stream and returns a string.

Parameters
length:uint — An unsigned short indicating the length of the UTF-8 bytes.

Returns
String — A string composed of the UTF-8 bytes of the specified length.

Throws
EOFError — There is not sufficient data available to read.
toString () method
public function toString():String

Converts the byte array to a string. If the data in the array begins with a Unicode byte order mark, Flash will honor that mark when converting to a string. If System.useCodePage is set to true, the player will treat the data in the array as being in the current system code page when converting.

Returns
String — The string representation of the byte array.
uncompress () method
public function uncompress():void

Decompresses the byte array. The byte array must have been previously compressed with the compress() method.

See also

flash.utils.ByteArray.compress()
writeBoolean () method
public function writeBoolean(value:Boolean):void

Writes a Boolean value. A single byte is written according to the value parameter, either 1 if true or 0 if false.

Parameters
value:Boolean — A Boolean value determining which byte is written. If the parameter is true, Flash Player writes a 1; if false, Flash Player writes a 0.
writeByte () method
public function writeByte(value:int):void

Writes a byte to the byte stream.

The low 8 bits of the parameter are used. The high 24 bits are ignored.

Parameters
value:int — A 32-bit integer. The low 8 bits are written to the byte stream.
writeBytes () method
public function writeBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void

Writes a sequence of length bytes from the specified byte array, bytes, starting offset (zero-based index) bytes into the byte stream.

If the length parameter is omitted, the default length of 0 is used; Flash Player writes the entire buffer starting at offset. If the offset parameter is also omitted, the entire buffer is written.

If offset or length is out of range, they are clamped to the beginning and end of the bytes array.

Parameters
bytes:ByteArray — The ByteArray object.
offset:uint (default = 0) — A zero-based index indicating the position into the array to begin writing.
length:uint (default = 0) — An unsigned integer indicating how far into the buffer to write.
writeDouble () method
public function writeDouble(value:Number):void

Writes an IEEE 754 double-precision (64-bit) floating-point number to the byte stream.

Parameters
value:Number — A double-precision (64-bit) floating-point number.
writeFloat () method
public function writeFloat(value:Number):void

Writes an IEEE 754 single-precision (32-bit) floating-point number to the byte stream.

Parameters
value:Number — A single-precision (32-bit) floating-point number.
writeInt () method
public function writeInt(value:int):void

Writes a 32-bit signed integer to the byte stream.

Parameters
value:int — An integer to write to the byte stream.
writeMultiByte () method
public function writeMultiByte(value:String, charSet:String):void

Writes a multibyte string to the byte stream using the specified character set.

Parameters
value:String — The string value to be written.
charSet:String — The string denoting the character set to use. Possible character set strings include "shift-jis", "cn-gb", "iso-8859-1", and others. For a complete list, see Supported Character Sets.
writeObject () method
public function writeObject(object:*):void

Writes an object into the byte array in AMF serialized format.

Parameters
object:* — The object to serialize.
writeShort () method
public function writeShort(value:int):void

Writes a 16-bit integer to the byte stream. The low 16 bits of the parameter are used. The high 16 bits are ignored.

Parameters
value:int — 32-bit integer, whose low 16 bits are written to the byte stream.
writeUnsignedInt () method
public function writeUnsignedInt(value:uint):void

Writes a 32-bit unsigned integer to the byte stream.

Parameters
value:uint — An unsigned integer to write to the byte stream.
writeUTF () method
public function writeUTF(value:String):void

Writes a UTF-8 string to the byte stream. The length of the UTF-8 string in bytes is written first, as a 16-bit integer, followed by the bytes representing the characters of the string.

Parameters
value:String — The string value to be written.

Throws
RangeError — If the length is larger than 65535.
writeUTFBytes () method
public function writeUTFBytes(value:String):void

Writes a UTF-8 string to the byte stream. Similar to the writeUTF() method, but writeUTFBytes() does not prefix the string with a 16-bit length word.

Parameters
value:String — The string value to be written.
Examples

The following example uses the class ByteArrayExample to write a Boolean and the double-precision floating-point representation of pi to a byte array. This is accomplished using the following steps:
  1. Declare a new ByteArray object instance byteArr.
  2. Write the byte-equivalent value of the Boolean false and then check the length and read it back.
  3. Write the double-precision floating-point equivalent of the mathematical value of pi.
  4. Read back each of the nine bytes written into the byte array.

Note: when trace() is called on a byte, it prints the decimal equivalent of the bytes stored in the byte array.

Notice how a code segment is added at the end to check for end of file errors to ensure that the byte stream is not read past its end.

package {
    import flash.display.Sprite;
    import flash.utils.ByteArray;
    import flash.errors.EOFError;

    public class ByteArrayExample extends Sprite {
        public function ByteArrayExample() {
            var byteArr:ByteArray = new ByteArray();

            byteArr.writeBoolean(false);
            trace(byteArr.length);            // 1
            trace(byteArr[0]);            // 0

            byteArr.writeDouble(Math.PI);
            trace(byteArr.length);            // 9
            trace(byteArr[0]);            // 0
            trace(byteArr[1]);            // 64
            trace(byteArr[2]);            // 9
            trace(byteArr[3]);            // 33
            trace(byteArr[4]);            // 251
            trace(byteArr[5]);            // 84
            trace(byteArr[6]);            // 68
            trace(byteArr[7]);            // 45
            trace(byteArr[8]);            // 24

            byteArr.position = 0;

            try {
                trace(byteArr.readBoolean() == false); // true
            }
            catch(e:EOFError) {
                trace(e);           // EOFError: Error #2030: End of file was encountered.
            }

            try {
                trace(byteArr.readDouble());        // 3.141592653589793
            }
            catch(e:EOFError) {
                trace(e);           // EOFError: Error #2030: End of file was encountered.
            }

            try {
                trace(byteArr.readDouble());
            }
            catch(e:EOFError) {
                trace(e);            // EOFError: Error #2030: End of file was encountered.
            }
        }
    }
}


flash.utils.Dictionary (Flex™ 2 Language Reference)

Class Dictionary | Properties | Methods
Package | flash.utils
Class | public dynamic class Dictionary
Inheritance | Dictionary Inheritance Object

The Dictionary class lets you create a dynamic collection of properties, which uses strict equality (===) for key comparison. When an object is used as a key, the object's identity is used to look up the object, and not the value returned from calling toString() on it.

The following statements show the relationship between a Dictionary object and a key object:

 var dict = new Dictionary();
 var obj = new Object();
 var key:Object = new Object();
 key.toString = function() { return "key" }

 dict[key] = "Letters";
 obj["key"] = "Letters";

 dict[key] == "Letters"; // true
 obj["key"] == "Letters"; // true
 obj[key] == "Letters"; // true because key == "key" is true b/c key.toString == "key"
 dict["key"] == "Letters"; // false because "key" === key is false
 delete dict[key]; //removes the key

See also

=== (strict equality)

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Dictionary(weakKeys:Boolean = false) Creates a new Dictionary object. | Dictionary
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
Dictionary () constructor
public function Dictionary(weakKeys:Boolean = false)

Creates a new Dictionary object. To remove a key from a Dictionary object, use the delete operator.

Parameters
weakKeys:Boolean (default = false) — Instructs the Dictionary object to use "weak" references on object keys. If the only reference to an object is in the specified Dictionary object, the key is eligible for garbage collection and is removed from the table when the object is collected.


flash.utils.Endian (Flex™ 2 Language Reference)

Class Endian | Properties | Methods | Constants
Package | flash.utils
Class | public final class Endian
Inheritance | Endian Inheritance Object

The Endian class contains values that denote the byte order used to represent multibyte numbers. The byte order is either bigEndian (most significant byte first) or littleEndian (least significant byte first).

Flash Player can interface with a server by using the binary protocol of that server, directly. Some servers use the bigEndian byte order and some servers use the littleEndian byte order. Most servers on the Internet use the bigEndian byte order because "network byte order" is bigEndian. The littleEndian byte order is popular because the Intel x86 architecture uses it. Use the endian byte order that matches the protocol of the server that is sending or receiving data.

See also

flash.utils.ByteArray.endian
flash.utils.IDataInput.endian
flash.utils.IDataOutput.endian
flash.net.Socket.endian
flash.net.URLStream.endian

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BIG_ENDIAN : String = "bigEndian" [static] Indicates the most significant byte of the multibyte number appears first in the sequence of bytes. | Endian
 | LITTLE_ENDIAN : String = "littleEndian" [static] Indicates the least significant byte of the multibyte number appears first in the sequence of bytes. | Endian
Constant detail
BIG_ENDIAN constant
public static const BIG_ENDIAN:String = "bigEndian"

Indicates the most significant byte of the multibyte number appears first in the sequence of bytes.

The hexadecimal number 0x12345678 has 4 bytes (2 hexadecimal digits per byte). The most significant byte is 0x12. The least significant byte is 0x78. (For the equivalent decimal number, 305419896, the most significant digit is 3, and the least significant digit is 6).

A stream using the bigEndian byte order (the most significant byte first) writes:

  12 34 56 78

See also

Socket connections
LITTLE_ENDIAN constant
public static const LITTLE_ENDIAN:String = "littleEndian"

Indicates the least significant byte of the multibyte number appears first in the sequence of bytes.

The hexadecimal number 0x12345678 has 4 bytes (2 hexadecimal digits per byte). The most significant byte is 0x12. The least significant byte is 0x78. (For the equivalent decimal number, 305419896, the most significant digit is 3, and the least significant digit is 6).

A stream using the littleEndian byte order (the least significant byte first) writes:

  78 56 34 12

See also

Socket connections


flash.utils.IDataInput (Flex™ 2 Language Reference)

Interface IDataInput | Properties | Methods | Examples
Package | flash.utils
Interface | public interface IDataInput
Implementors | ByteArray, Socket, URLStream

The IDataInput interface provides a set of methods for reading binary data. This interface is the I/O counterpart to the IDataOutput interface, which writes binary data.

All IDataInput and IDataOutput operations are "bigEndian" by default (the most significant byte in the sequence is stored at the lowest or first storage address), and are nonblocking. If insufficient data is available, an EOFError exception is thrown. Use the IDataInput.bytesAvailable property to determine how much data is available to read.

Sign extension matters only when you read data, not when you write it. Therefore you do not need separate write methods to work with IDataInput.readUnsignedByte() and IDataInput.readUnsignedShort(). In other words:

  • Use IDataOutput.writeByte() with IDataInput.readUnsignedByte() and IDataInput.readByte().
  • Use IDataOutput.writeShort() with IDataInput.readUnsignedShort() and IDataInput.readShort().

View the examples.

See also

IDataOutput interface
endian
Socket class
URLStream class
ByteArray class
EOFError class

Public Properties
Property |  | Defined by
 | bytesAvailable : uint [read-only] Returns the number of bytes of data available for reading in the input buffer. | IDataInput
 | endian : String The byte order for the data, either the "bigEndian" or "littleEndian" constant from the Endian class. | IDataInput
 | objectEncoding : uint Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading binary data. | IDataInput
Public Methods
Method |  | Defined by
 | readBoolean():Boolean Reads a Boolean value from the byte stream or byte array. | IDataInput
 | readByte():int Reads a signed byte from the byte stream or byte array. | IDataInput
 | readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void Reads the number of data bytes, specified by the length parameter, from the byte stream or byte array. | IDataInput
 | readDouble():Number Reads an IEEE 754 double-precision floating point number from the byte stream or byte array. | IDataInput
 | readFloat():Number Reads an IEEE 754 single-precision floating point number from the byte stream or byte array. | IDataInput
 | readInt():int Reads a signed 32-bit integer from the byte stream or byte array. | IDataInput
 | readMultiByte(length:uint, charSet:String):String Reads a multibyte string of specified length from the byte stream using the specified character set. | IDataInput
 | readObject():* Reads an object from the byte stream or byte array, encoded in AMF serialized format. | IDataInput
 | readShort():int Reads a signed 16-bit integer from the byte stream or byte array. | IDataInput
 | readUnsignedByte():uint Reads an unsigned byte from the byte stream or byte array. | IDataInput
 | readUnsignedInt():uint Reads an unsigned 32-bit integer from the byte stream or byte array. | IDataInput
 | readUnsignedShort():uint Reads an unsigned 16-bit integer from the byte stream or byte array. | IDataInput
 | readUTF():String Reads a UTF-8 string from the byte stream or byte array. | IDataInput
 | readUTFBytes(length:uint):String Reads a sequence of length UTF-8 bytes from the byte stream or byte array and returns a string. | IDataInput
Property detail
bytesAvailable property
bytesAvailable:uint [read-only]

Returns the number of bytes of data available for reading in the input buffer. User code must call bytesAvailable to ensure that sufficient data is available before trying to read it with one of the read methods.

Implementation
    public function get bytesAvailable():uint
endian property
endian:String [read-write]

The byte order for the data, either the "bigEndian" or "littleEndian" constant from the Endian class.

Implementation
    public function get endian():String
    public function set endian(value:String):void

See also

Endian class
objectEncoding property
objectEncoding:uint [read-write]

Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading binary data. The value is a constant from the ObjectEncoding class.

Implementation
    public function get objectEncoding():uint
    public function set objectEncoding(value:uint):void

See also

readObject()
IDataOutput.writeObject()
ObjectEncoding class
Method detail
readBoolean () method
public function readBoolean():Boolean

Reads a Boolean value from the byte stream or byte array. A single byte is read, and true is returned if the byte is nonzero, false otherwise.

Returns
Boolean — A Boolean value, true if the byte is nonzero, false otherwise.

Throws
EOFError — There is not sufficient data available to read.
readByte () method
public function readByte():int

Reads a signed byte from the byte stream or byte array.

Returns
int — The returned value is in the range -128 to 127.

Throws
EOFError — There is not sufficient data available to read.
readBytes () method
public function readBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void

Reads the number of data bytes, specified by the length parameter, from the byte stream or byte array. The bytes are read into the ByteArray objected specified by the bytes parameter, starting at the position specified by offset.

Parameters
bytes:ByteArray — The ByteArray object to read data into.
offset:uint (default = 0) — The offset into the bytes parameter at which data read should begin.
length:uint (default = 0) — The number of bytes to read. The default value of 0 causes all available data to be read.

Throws
EOFError — There is not sufficient data available to read.
readDouble () method
public function readDouble():Number

Reads an IEEE 754 double-precision floating point number from the byte stream or byte array.

Returns
Number — An IEEE 754 double-precision floating point number.

Throws
EOFError — There is not sufficient data available to read.
readFloat () method
public function readFloat():Number

Reads an IEEE 754 single-precision floating point number from the byte stream or byte array.

Returns
Number — An IEEE 754 single-precision floating point number.

Throws
EOFError — There is not sufficient data available to read.
readInt () method
public function readInt():int

Reads a signed 32-bit integer from the byte stream or byte array.

Returns
int — The returned value is in the range -2147483648 to 2147483647.

Throws
EOFError — There is not sufficient data available to read.
readMultiByte () method
public function readMultiByte(length:uint, charSet:String):String

Reads a multibyte string of specified length from the byte stream using the specified character set.

Parameters
length:uint — The number of bytes from the byte stream to read.
charSet:String — The string denoting the character set to use to interpret the bytes. Possible character set strings include "shift-jis", "cn-gb", "iso-8859-1", and others. For a complete list, see Supported Character Sets.

Returns
String — UTF-8 encoded string.

Throws
EOFError — There is not sufficient data available to read.
readObject () method
public function readObject():*

Reads an object from the byte stream or byte array, encoded in AMF serialized format.

Returns
* — The deserialized object

Throws
EOFError — There is not sufficient data available to read.

See also

objectEncoding
readShort () method
public function readShort():int

Reads a signed 16-bit integer from the byte stream or byte array.

Returns
int — The returned value is in the range -32768 to 32767.

Throws
EOFError — There is not sufficient data available to read.
readUnsignedByte () method
public function readUnsignedByte():uint

Reads an unsigned byte from the byte stream or byte array.

Returns
uint — The returned value is in the range 0 to 255.

Throws
EOFError — There is not sufficient data available to read.
readUnsignedInt () method
public function readUnsignedInt():uint

Reads an unsigned 32-bit integer from the byte stream or byte array.

Returns
uint — The returned value is in the range 0 to 4294967295.

Throws
EOFError — There is not sufficient data available to read.
readUnsignedShort () method
public function readUnsignedShort():uint

Reads an unsigned 16-bit integer from the byte stream or byte array.

Returns
uint — The returned value is in the range 0 to 65535.

Throws
EOFError — There is not sufficient data available to read.
readUTF () method
public function readUTF():String

Reads a UTF-8 string from the byte stream or byte array. The string is assumed to be prefixed with an unsigned short indicating the length in bytes.

This method is similar to the readUTF() method in the Java IDataInput interface.

Returns
String — A UTF-8 string produced by the byte representation of characters.

Throws
EOFError — There is not sufficient data available to read.
readUTFBytes () method
public function readUTFBytes(length:uint):String

Reads a sequence of length UTF-8 bytes from the byte stream or byte array and returns a string.

Parameters
length:uint

Returns
String — A UTF-8 string produced by the byte representation of characters of specified length.

Throws
EOFError — There is not sufficient data available to read.
Examples

The following example uses the class DataInputExample to write a boolean and the double-precision floating-point representation of pi to a byte array. This is accomplished using the following steps:
  1. Declare a new ByteArray object instance byteArr.
  2. Write the byte-equivalent value of the Boolean false and the double-precision floating-point equivalent of the mathematical value of pi.
  3. Read back the boolean and double-precision floating-point number.

Notice how a code segment is added at the end to check for end of file errors to ensure that the byte stream is not read past its end.

package {
    import flash.display.Sprite;
    import flash.utils.ByteArray;
    import flash.errors.EOFError;

    public class DataInputExample extends Sprite {
        public function DataInputExample() {
            var byteArr:ByteArray = new ByteArray();

            byteArr.writeBoolean(false);
            byteArr.writeDouble(Math.PI);

            byteArr.position = 0;

            try {
                trace(byteArr.readBoolean()); // false
            }
            catch(e:EOFError) {
                trace(e);           // EOFError: Error #2030: End of file was encountered.
            }

            try {
                trace(byteArr.readDouble());    // 3.141592653589793
            }
            catch(e:EOFError) {
                trace(e);           // EOFError: Error #2030: End of file was encountered.
            }

            try {
                trace(byteArr.readDouble());
            }
            catch(e:EOFError) {
                trace(e);        // EOFError: Error #2030: End of file was encountered.
            }
        }
    }
}


flash.utils.IDataOutput (Flex™ 2 Language Reference)

Interface IDataOutput | Properties | Methods | Examples
Package | flash.utils
Interface | public interface IDataOutput
Implementors | ByteArray, Socket

The IDataOutput interface provides a set of methods for writing binary data. This interface is the I/O counterpart to the IDataInput interface, which reads binary data. The IDataOutput interface is implemented by the Socket and ByteArray classes.

All IDataInput and IDataOutput operations are "bigEndian" by default (the most significant byte in the sequence is stored at the lowest or first storage address), and are nonblocking.

Sign extension matters only when you read data, not when you write it. Therefore, you do not need separate write methods to work with IDataInput.readUnsignedByte() and IDataInput.readUnsignedShort(). In other words:

  • Use IDataOutput.writeByte() with IDataInput.readUnsignedByte() and IDataInput.readByte().
  • Use IDataOutput.writeShort() with IDataInput.readUnsignedShort() and IDataInput.readShort().

View the examples.

See also

IDataInput interface
endian
Socket class
URLStream class
ByteArray class

Public Properties
Property |  | Defined by
 | endian : String The byte order for the data, either the "bigEndian" or "littleEndian" constant from the Endian class. | IDataOutput
 | objectEncoding : uint Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading binary data. | IDataOutput
Public Methods
Method |  | Defined by
 | writeBoolean(value:Boolean):void Writes a Boolean value. | IDataOutput
 | writeByte(value:int):void Writes a byte. | IDataOutput
 | writeBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void Writes a sequence of length bytes from the specified byte array, bytes, starting offset(zero-based index) bytes into the byte stream. | IDataOutput
 | writeDouble(value:Number):void Writes an IEEE 754 double-precision (64-bit) floating point number. | IDataOutput
 | writeFloat(value:Number):void Writes an IEEE 754 single-precision (32-bit) floating point number. | IDataOutput
 | writeInt(value:int):void Writes a 32-bit signed integer. | IDataOutput
 | writeMultiByte(value:String, charSet:String):void Writes a multibyte string to the byte stream using the specified character set. | IDataOutput
 | writeObject(object:*):void Writes an object to the byte stream or byte array in AMF serialized format. | IDataOutput
 | writeShort(value:int):void Writes a 16-bit integer. | IDataOutput
 | writeUnsignedInt(value:uint):void Writes a 32-bit unsigned integer. | IDataOutput
 | writeUTF(value:String):void Writes a UTF-8 string to the byte stream. | IDataOutput
 | writeUTFBytes(value:String):void Writes a UTF-8 string. | IDataOutput
Property detail
endian property
endian:String [read-write]

The byte order for the data, either the "bigEndian" or "littleEndian" constant from the Endian class.

Implementation
    public function get endian():String
    public function set endian(value:String):void

See also

Endian class
objectEncoding property
objectEncoding:uint [read-write]

Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading binary data. The value is a constant from the ObjectEncoding class.

Implementation
    public function get objectEncoding():uint
    public function set objectEncoding(value:uint):void

See also

IDataInput.readObject()
writeObject()
ObjectEncoding class
Method detail
writeBoolean () method
public function writeBoolean(value:Boolean):void

Writes a Boolean value. A single byte is written according to the value parameter, either 1 if true or 0 if false.

Parameters
value:Boolean — A Boolean value determining which byte is written. If the parameter is true Flash Player writes a 1; if false, Flash Player writes a 0.
writeByte () method
public function writeByte(value:int):void

Writes a byte. The low 8 bits of the parameter are used. The high 24 bits are ignored.

Parameters
value:int — A byte value as an integer.
writeBytes () method
public function writeBytes(bytes:ByteArray, offset:uint = 0, length:uint = 0):void

Writes a sequence of length bytes from the specified byte array, bytes, starting offset(zero-based index) bytes into the byte stream.

If the length parameter is omitted, the default length of 0 is used; Flash Player writes the entire buffer starting at offset. If the offset parameter is also omitted, the entire buffer is written.

If the offset or length parameter is out of range, they are clamped to the beginning and end of the bytes array.

Parameters
bytes:ByteArray — The byte array to write.
offset:uint (default = 0) — A zero-based index indicating the position into the array to begin writing.
length:uint (default = 0) — An unsigned integer indicating how far into the buffer to write.
writeDouble () method
public function writeDouble(value:Number):void

Writes an IEEE 754 double-precision (64-bit) floating point number.

Parameters
value:Number — A double-precision (64-bit) floating point number.
writeFloat () method
public function writeFloat(value:Number):void

Writes an IEEE 754 single-precision (32-bit) floating point number.

Parameters
value:Number — A single-precision (32-bit) floating point number.
writeInt () method
public function writeInt(value:int):void

Writes a 32-bit signed integer.

Parameters
value:int — A byte value as a signed integer.
writeMultiByte () method
public function writeMultiByte(value:String, charSet:String):void

Writes a multibyte string to the byte stream using the specified character set.

Parameters
value:String — The string value to be written.
charSet:String — The string denoting the character set to use. Possible character set strings include "shift-jis", "cn-gb", "iso-8859-1" and others. For a complete list, see Supported Character Sets.
writeObject () method
public function writeObject(object:*):void

Writes an object to the byte stream or byte array in AMF serialized format.

Parameters
object:* — the object to be serialized

See also

objectEncoding
writeShort () method
public function writeShort(value:int):void

Writes a 16-bit integer. The low 16 bits of the parameter are used. The high 16 bits are ignored.

Parameters
value:int — A byte value as an integer.
writeUnsignedInt () method
public function writeUnsignedInt(value:uint):void

Writes a 32-bit unsigned integer.

Parameters
value:uint — A byte value as an unsigned integer.
writeUTF () method
public function writeUTF(value:String):void

Writes a UTF-8 string to the byte stream. The length of the UTF-8 string in bytes is written first, as a 16-bit integer, followed by the bytes representing the characters of the string.

Parameters
value:String — The string value to be written.

Throws
RangeError — If the length is larger than 65535.
writeUTFBytes () method
public function writeUTFBytes(value:String):void

Writes a UTF-8 string. Similar to writeUTF(), but does not prefix the string with a 16-bit length word.

Parameters
value:String — The string value to be written.
Examples

The following example uses the class DataOutputExample to write a boolean and the double-precision floating-point representation of pi to a byte array. This is accomplished using the following steps:
  1. Declare a new ByteArray object instance byteArr.
  2. Write the byte-equivalent value of the Boolean false and the double-precision floating-point equivalent of the mathematical value of pi.
  3. Read back the boolean and double-precision floating-point number.

Notice how a code segment is added at the end to check for end of file errors to ensure that the byte stream is not read past its end.

package {
    import flash.display.Sprite;
    import flash.utils.ByteArray;
    import flash.errors.EOFError;

    public class DataOutputExample extends Sprite {
        public function DataOutputExample() {
            var byteArr:ByteArray = new ByteArray();

            byteArr.writeBoolean(false);
            byteArr.writeDouble(Math.PI);

            byteArr.position = 0;

            try {
                trace(byteArr.readBoolean()); // false
            }
            catch(e:EOFError) {
                trace(e);           // EOFError: Error #2030: End of file was encountered.
            }

            try {
                trace(byteArr.readDouble());    // 3.141592653589793
            }
            catch(e:EOFError) {
                trace(e);           // EOFError: Error #2030: End of file was encountered.
            }

            try {
                trace(byteArr.readDouble());
            }
            catch(e:EOFError) {
                trace(e);        // EOFError: Error #2030: End of file was encountered.
            }
        }
    }
}


flash.utils.IExternalizable (Flex™ 2 Language Reference)

Interface IExternalizable | Methods
Package | flash.utils
Interface | public interface IExternalizable
Implementors | ArrayCollection, ObjectProxy

The IExternalizable interface provides control over serialization of a class as it is encoded into a data stream. The writeExternal() and readExternal() methods of the IExternalizable interface are implemented by a class to allow customization of the contents and format of the data stream (but not the classname or type) for an object and its supertypes. Each individual class must serialize and reconstruct the state of its instances. These methods must be symmetrical with the supertype to save its state. These methods supercede the native Action Message Format (AMF) serialization behavior.

If a class does not implement, nor inherits from a class which implements, the IExternalizable interface, then an instance of the class will be serialized using the default mechanism of public members only. As a result, private, internal, and protected members of a class will not be available.

To serialize private members, a class must use the IExternalizable interface. For example, the following class will not serialize any of its members because they are private:

 class Example {

       private var one:int;
       private var two:int;
 }

However, if you implement the IExternalizable interface, you can write to, and read from, the data stream the private members of the class as follows:

 class Example implement IExternalizable {

       private var one:int;
       private var two:int;
        public function writeExternal(output:IDataOutput) {
             output.writeInt(one);
            output.writeInt(two);
       }
        public function readExternal(input:IDataInput) {
             one = input.readInt();
            two = input.readInt();
       }
 }

Note: If a class implements IExternalizable the default serialization no longer applies to instances of that class. If that class inherits public members from a super class, you must carefully manage those members as well.

When a subclass of a class implementing IExternalizable has private members of its own, the subclass must override the methods of IExternalizable, as follows:

 public class Base implements IExternalizable {

      private var one:Boolean;

      public function writeExternal(output:IDataOutput):void {

          output.writeBoolean(one);
      }

      public function readExternal(input:IDataInput):void {

          one = input.readBoolean();
      }
 }

 public class Example extends Base {

      private var one:String;

      public override function writeExternal(output:IDataOutput):void {

          super.writeExternal(output);
          output.writeUTF(one);
      }

      public override function readExternal(input:IDataInput):void {

          super.readExternal(input);
          one = input.readUTF();
      }
 }

The IExternalizable interface can also be used to compress data before writing it to a data stream. For example:

 class Example implements IExternalizable {

      public var one:Boolean;
      public var two:Boolean;
      public var three:Boolean;
      public var four:Boolean;
      public var five:Boolean;
      public var six:Boolean;
      public var seven:Boolean;
      public var eight:Boolean;
       public function writeExternal(output:IDataOutput) {
           var flag:int = 0;
           if (one) flag |= 1;
          if (two) flag |= 2;
          if (three) flag |= 4;
          if (four) flag |= 8;
          if (five) flag |= 16;
          if (six) flag |= 32;
          if (seven) flag |= 64;
          if (eight) flag |= 128;
           output.writeByte(flag);
      }
       public function readExternal(input:IDataInput) {
           var flag:int = input.readByte();
           one = (flag & 1) != 0;
          two = (flag & 2) != 0;
          three = (flag & 4) != 0;
          four = (flag & 8) != 0;
          five = (flag & 16) != 0;
          six = (flag & 32) != 0;
          seven = (flag & 64) != 0;
          eight = (flag & 128) != 0;
      }
 }

See also

flash.net.ObjectEncoding
Using custom serialization

Public Methods
Method |  | Defined by
 | readExternal(input:IDataInput):void A class implements this method to decode itself from a data stream by calling the methods of the IDataInput interface. | IExternalizable
 | writeExternal(output:IDataOutput):void A class implements this method to encode itself for a data stream by calling the methods of the IDataOutput interface. | IExternalizable
Method detail
readExternal () method
public function readExternal(input:IDataInput):void

A class implements this method to decode itself from a data stream by calling the methods of the IDataInput interface. This method must read the values in the same sequence and with the same types as were written by the writeExternal() method.

Parameters
input:IDataInput — The name of the class that implements the IDataInput interface.
writeExternal () method
public function writeExternal(output:IDataOutput):void

A class implements this method to encode itself for a data stream by calling the methods of the IDataOutput interface.

Parameters
output:IDataOutput — The name of the class that implements the IDataOutput interface.


flash.utils.Proxy (Flex™ 2 Language Reference)

Class Proxy | Properties | Methods | Examples
Package | flash.utils
Class | public class Proxy
Inheritance | Proxy Inheritance Object
Subclasses | AbstractService, DescribeTypeCacheRecord, ListCollectionView, ObjectProxy

The Proxy class lets you override the default behavior of ActionScript operations (such as retrieving and modifying properties) on an object.

The Proxy class has no constructor, and you should not attempt to instantiate Proxy. Instead, subclass the Proxy class to override methods such as getProperty and provide custom behavior. If you try to use a method of the Proxy class without overriding the method, an exception is thrown.

And, keep in mind, your own code overriding the methods of the Proxy class can throw exceptions unintentionally. Throwing exceptions when using these methods causes problems because the calling code (using operators like in, is, delete and others) does not expect exceptions. Unless you're already sure your overriding method does not throw exceptions, Adobe recommends using try..catch statements around your implementation of the Proxy class to avoid fatal errors when operators call your methods. For example:

 dynamic class MyProxy extends Proxy {
     flash_proxy override function callProperty(name:*, ...rest):* {
       try {
         // custom code here
       }
       catch (e:Error) {
         // respond to error here
       }
 }

The Proxy class is a replacement for the Object.__resolve and Object.addProperty features of ActionScript 2.0, which are no longer available in ActionScript 3.0. The Object.addProperty() feature allowed you to dynamically create get and set methods in ActionScript 2.0. Although ActionScript 3.0 provides get and set methods at compile time, you cannot dynamically assign one to an object unless you use the Proxy class.

To avoid collisions with the public namespace, the methods of the Proxy class are in the flash_proxy namespace.

Where methods of the Proxy class take a name argument, name can be either a String or a QName object (if namespaces are being used).

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Method |  | Defined by
 | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
 | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
 | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
 | getProperty(name:*):* Overrides any request for a property's value. | Proxy
 | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
 | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
 | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
 | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
 | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
 | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Method detail
callProperty () method
flash_proxy function callProperty(name:*, ... rest):*

Overrides the behavior of an object property that can be called as a function. When a method of the object is invoked, this method is called. While some objects can be called as functions, some object properties can also be called as functions.

Parameters
name:* — The name of the method being invoked.
... rest — An array specifying the arguments to the called method.

Returns
* — The return value of the called method.

See also

Function.call()
ECMA-262 Language Specification, 3rd Edition, section 15
deleteProperty () method
flash_proxy function deleteProperty(name:*):Boolean

Overrides the request to delete a property. When a property is deleted with the delete operator, this method is called to perform the deletion.

Parameters
name:* — The name of the property to delete.

Returns
Boolean — If the property was deleted, true; otherwise false.

See also

delete operator
ECMA-262 Language Specification, 3rd Edition, 8.6.2.5
getDescendants () method
flash_proxy function getDescendants(name:*):*

Overrides the use of the descendant operator. When the descendant operator is used, this method is invoked.

Parameters
name:* — The name of the property to descend into the object and search for.

Returns
* — The results of the descendant operator.

See also

descendant operator
E4X Specification
getProperty () method
flash_proxy function getProperty(name:*):*

Overrides any request for a property's value. If the property can't be found, the method returns undefined. For more information on this behavior, see the ECMA-262 Language Specification, 3rd Edition, section 8.6.2.1.

Parameters
name:* — The name of the property to retrieve.

Returns
* — The specified property or undefined if the property is not found.

See also

get statement
ECMA-262 Language Specification, 3rd Edition, section 8.6.2.1
hasProperty () method
flash_proxy function hasProperty(name:*):Boolean

Overrides a request to check whether an object has a particular property by name.

Parameters
name:* — The name of the property to check for.

Returns
Boolean — If the property exists, true; otherwise false.

See also

Object.hasOwnProperty()
ECMA-262 Language Specification, 3rd Edition, section 8.6.2.4
isAttribute () method
flash_proxy function isAttribute(name:*):Boolean

Checks whether a supplied QName is also marked as an attribute.

Parameters
name:* — The name of the property to check.

Returns
Boolean — Returns true if the argument for name is a QName that is also marked as an attribute.

See also

QName class
nextName () method
flash_proxy function nextName(index:int):String

Allows enumeration of the proxied object's properties by index number to retrieve property names. However, you cannot enumerate the properties of the Proxy class themselves. This function supports implementing for...in and for each..in loops on the object to retrieve the desired names.

For example (with code from Proxy.nextNameIndex()):

     protected var _item:Array; // array of object's properties
     override flash_proxy function nextNameIndex (index:int):int {
         // initial call
         if (index == 0) {
             _item = new Array();
             for (var x:* in _target) {
                _item.push(x);
             }
         }

         if (index < _item.length) {
             return index + 1;
         } else {
             return 0;
         }
     }
     override flash_proxy function nextName(index:int):String {
         return _item[index - 1];
     }
Parameters
index:int — The zero-based index value of the object's property.

Returns
String — String The property's name.

See also

Proxy.nextNameIndex()
Proxy.nextValue()
nextNameIndex () method
flash_proxy function nextNameIndex(index:int):int

Allows enumeration of the proxied object's properties by index number. Hhowever, you cannot enumerate the properties of the Proxy class themselves. This function supports implementing for...in and for each..in loops on the object to retrieve property index values.

For example:

     protected var _item:Array; // array of object's properties
     override flash_proxy function nextNameIndex (index:int):int {
         // initial call
         if (index == 0) {
             _item = new Array();
             for (var x:* in _target) {
                _item.push(x);
             }
         }

         if (index < _item.length) {
             return index + 1;
         } else {
             return 0;
         }
     }
     override flash_proxy function nextName(index:int):String {
         return _item[index - 1];
     }
Parameters
index:int — The zero-based index value where the enumeration begins.

Returns
int — The property's index value.

See also

Proxy.nextName()
Proxy.nextValue()
nextValue () method
flash_proxy function nextValue(index:int):*

Allows enumeration of the proxied object's properties by index number to retrieve property values. However, you cannot enumerate the properties of the Proxy class themselves. This function supports implementing for...in and for each..in loops on the object to retrieve the desired values.

For example (with code from Proxy.nextNameIndex()):

     protected var _item:Array; // array of object's properties
     override flash_proxy function nextNameIndex (index:int):int {
         // initial call
         if (index == 0) {
             _item = new Array();
             for (var x:* in _target) {
                _item.push(x);
             }
         }

         if (index < _item.length) {
             return index + 1;
         } else {
             return 0;
         }
     }
     override flash_proxy function nextName(index:int):String {
         return _item[index - 1];
     }
Parameters
index:int — The zero-based index value of the object's property.

Returns
* — The property's value.

See also

Proxy.nextNameIndex()
Proxy.nextName()
setProperty () method
flash_proxy function setProperty(name:*, value:*):void

Overrides a call to change a property's value. If the property can't be found, this method creates a property with the specified name and value.

Parameters
name:* — The name of the property to modify.
value:* — The value to set the property to.

See also

set statement
ECMA-262 Language Specification, 3rd Edition, section 8.6.2.2
Examples

package {
    import flash.display.Sprite;

    public class ProxyExample extends Sprite {
        public function ProxyExample() {
            var arr:ProxyArray = new ProxyArray();
            arr.push(1);
            arr.push(-2);
            arr.push(3);
            arr.push(4);
            arr.push("five");

            trace(arr.length); // 5
            trace(arr[0]);     // 1
            trace(arr[1]);     // -2
            trace(arr[2]);     // 3
            trace(arr[3]);     // 4

            trace(arr.sum());  // 6

            arr.clear();
            trace(arr); // (empty string)

            arr[0] = "zero";
            trace(arr); // zero
        }
    }
}

import flash.utils.Proxy;
import flash.utils.flash_proxy;

dynamic class ProxyArray extends Proxy {
    private var _item:Array;

    public function ProxyArray() {
        _item = new Array();
    }

    override flash_proxy function callProperty(methodName:*, ... args):* {
        var res:*;
        switch (methodName.toString()) {
            case 'clear':
                _item = new Array();
                break;
            case 'sum':
                var sum:Number = 0;
                for each (var i:* in _item) {
                    // ignore non-numeric values
                    if (!isNaN(i)) {
                        sum += i;
                    }
                }
                res = sum;
                break;
            default:
                res = _item[methodName].apply(_item, args);
                break;
        }
        return res;
    }

    override flash_proxy function getProperty(name:*):* {
        return _item[name];
    }

    override flash_proxy function setProperty(name:*, value:*):void {
        _item[name] = value;
    }
}


flash.utils.Timer (Flex™ 2 Language Reference)

Class Timer | Properties | Methods | Events | Examples
Package | flash.utils
Class | public class Timer
Inheritance | Timer Inheritance EventDispatcher Inheritance Object

The Timer class is the interface to Flash Player timers. You can create new Timer objects to run code on a specified time sequence. Use the start() method to start a timer. Add an event listener for the timer event to set up code to be run on the timer interval.

You can create Timer objects to run once or repeat at specified intervals to execute code on a schedule. Depending on the SWF file's framerate or Flash Player's environment (available memory and other factors), Flash Player may dispatch events at slightly offset intervals. For example, if a SWF file is set to play at 10 frames per second [fps], which is 100 millisecond intervals, but your timer is set to fire an event at 80 milliseconds, Flash Player will fire the event close to the 100 millisecond interval. Memory-intensive scripts may also offset the events.

View the examples.

See also

Working with Dates and Times
Controlling time intervals

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentCount : int [read-only] The total number of times the timer has fired since it started at zero. | Timer
 | delay : Number The delay, in milliseconds, between timer events. | Timer
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | repeatCount : int The total number of times the timer is set to run. | Timer
 | running : Boolean [read-only] The timer's current state; true if the timer is running, otherwise false. | Timer
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Timer(delay:Number, repeatCount:int = 0)
Constructs a new Timer object with the specified delay and repeatCount states.
Timer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
reset():void
Stops the timer, if it is running, and sets the currentCount property back to 0, like the reset button of a stopwatch.
Timer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
start():void
Starts the timer, if it is not already running.
Timer
stop():void
Stops the timer.
Timer
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | timer | Dispatched whenever a Timer object reaches an interval specified according to the Timer.delay property. | Timer
 | timerComplete | Dispatched whenever it has completed the number of requests set by Timer.repeatCount. | Timer
Property detail
currentCount property
currentCount:int [read-only]

The total number of times the timer has fired since it started at zero. If the timer has been reset, only the fires since the reset are counted.

Implementation
    public function get currentCount():int
delay property
delay:Number [read-write]

The delay, in milliseconds, between timer events. If you set the delay interval while the timer is running, the timer will restart at the same repeatCount iteration.

Implementation
    public function get delay():Number
    public function set delay(value:Number):void

Throws
Error — Throws an exception if the delay specified is negative or not a finite number.
repeatCount property
repeatCount:int [read-write]

The total number of times the timer is set to run. If the repeat count is set to 0, the timer continues forever or until the stop() method is invoked or the program stops. If the repeat count is nonzero, the timer runs the specified number of times. If repeatCount is set to a total that is the same or less then currentCount the timer stops and will not fire again.

Implementation
    public function get repeatCount():int
    public function set repeatCount(value:int):void
running property
running:Boolean [read-only]

The timer's current state; true if the timer is running, otherwise false.

Implementation
    public function get running():Boolean
Constructor detail
Timer () constructor
public function Timer(delay:Number, repeatCount:int = 0)

Constructs a new Timer object with the specified delay and repeatCount states.

The timer does not start automatically; you must call the start() method to start it.

Parameters
delay:Number — The delay between timer events, in milliseconds.
repeatCount:int (default = 0) — Specifies the number of repetitions. If zero, the timer repeats infinitely. If nonzero, the timer runs the specified number of times and then stops.

Throws
Error — if the delay specified is negative or not a finite number
Method detail
reset () method
public function reset():void

Stops the timer, if it is running, and sets the currentCount property back to 0, like the reset button of a stopwatch. Then, when start() is called, the timer instance runs for the specified number of repetitions, as set by the repeatCount value.

See also

Timer.stop()
start () method
public function start():void

Starts the timer, if it is not already running.

stop () method
public function stop():void

Stops the timer. When start() is called after stop(), the timer instance runs for the remaining number of repetitions, as set by the repeatCount property.

See also

Timer.reset()
Event detail
timer event
Event object type: flash.events.TimerEvent
TimerEvent.type property = flash.events.TimerEvent.TIMER

Dispatched whenever a Timer object reaches an interval specified according to the Timer.delay property.

Defines the value of the type property of a timer event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Timer object that has reached its interval.
timerComplete event
Event object type: flash.events.TimerEvent
TimerEvent.type property = flash.events.TimerEvent.TIMER_COMPLETE

Dispatched whenever it has completed the number of requests set by Timer.repeatCount.

Defines the value of the type property of a timerComplete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Timer object that has completed its requests.
Examples

The following example uses the class TimerExample to show how a listener method timerHandler() can be set to listen for a new TimerEvent to be dispatched. The timer is started when start() is called, and after that point, the timer events are dispatched.
package {
    import flash.utils.Timer;
    import flash.events.TimerEvent;
    import flash.display.Sprite;

    public class TimerExample extends Sprite {

        public function TimerExample() {
            var myTimer:Timer = new Timer(1000, 2);
            myTimer.addEventListener("timer", timerHandler);
            myTimer.start();
        }

        public function timerHandler(event:TimerEvent):void {
            trace("timerHandler: " + event);
        }
    }
}


flash.xml Summary (Flex™ 2 Language Reference)

Package flash.xml | Classes

The flash.xml package contains Flash Player's legacy XML support, and other Flash Player-specific XML functionality.

Classes
Class | Description
XMLDocument | The XMLDocument class represents the legacy XML object that was present in ActionScript 2.0.
XMLNode | The XMLNode class represents the legacy XML object that was present in ActionScript 2.0 and that was renamed in ActionScript 3.0.
XMLNodeType | The XMLNodeType class contains constants used with XMLNode.nodeType.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


flash.xml.XMLDocument (Flex™ 2 Language Reference)

Class XMLDocument | Properties | Methods | Examples
Package | flash.xml
Class | public class XMLDocument
Inheritance | XMLDocument Inheritance XMLNode Inheritance Object

The XMLDocument class represents the legacy XML object that was present in ActionScript 2.0. It was renamed in ActionScript 3.0 to XMLDocument to avoid name conflicts with the new XML class in ActionScript 3.0. In ActionScript 3.0, it is recommended that you use the new XML class and related classes, which support E4X (ECMAScript for XML).

The XMLDocument class, as well as XMLNode and XMLNodeType, are present for backward compatibility. The functionality for loading XML documents can now be found in the URLLoader class.

View the examples.

See also

flash.net.URLLoader
XML class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | attributes : Object An object containing all of the attributes of the specified XMLNode instance. | XMLNode
Inherited | childNodes : Array An array of the specified XMLNode object's children. | XMLNode
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | docTypeDecl : Object = null Specifies information about the XML document's DOCTYPE declaration. | XMLDocument
Inherited | firstChild : XMLNode Evaluates the specified XMLDocument object and references the first child in the parent node's child list. | XMLNode
 | idMap : Object An Object containing the nodes of the XML that have an id attribute assigned. | XMLDocument
 | ignoreWhite : Boolean = false When set to true, text nodes that contain only white space are discarded during the parsing process. | XMLDocument
Inherited | lastChild : XMLNode An XMLNode value that references the last child in the node's child list. | XMLNode
Inherited | localName : String The local name portion of the XML node's name. | XMLNode
Inherited | namespaceURI : String If the XML node has a prefix, namespaceURI is the value of the xmlns declaration for that prefix (the URI), which is typically called the namespace URI. | XMLNode
Inherited | nextSibling : XMLNode An XMLNode value that references the next sibling in the parent node's child list. | XMLNode
Inherited | nodeName : String A string representing the node name of the XMLNode object. | XMLNode
Inherited | nodeType : uint A nodeType constant value, either XMLNodeType.ELEMENT_NODE for an XML element or XMLNodeType.TEXT_NODE for a text node. | XMLNode
Inherited | nodeValue : String The node value of the XMLDocument object. | XMLNode
Inherited | parentNode : XMLNode An XMLNode value that references the parent node of the specified XML object, or returns null if the node has no parent. | XMLNode
Inherited | prefix : String The prefix portion of the XML node name. | XMLNode
Inherited | previousSibling : XMLNode An XMLNode value that references the previous sibling in the parent node's child list. | XMLNode
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | xmlDecl : Object = null A string that specifies information about a document's XML declaration. | XMLDocument
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | XMLDocument(source:String = null) Creates a new XMLDocument object. | XMLDocument
Inherited | appendChild(node:XMLNode):void Appends the specified node to the XML object's child list. | XMLNode
Inherited | cloneNode(deep:Boolean):XMLNode Constructs and returns a new XML node of the same type, name, value, and attributes as the specified XML object. | XMLNode
 | createElement(name:String):XMLNode Creates a new XMLNode object with the name specified in the parameter. | XMLDocument
 | createTextNode(text:String):XMLNode Creates a new XML text node with the specified text. | XMLDocument
Inherited | getNamespaceForPrefix(prefix:String):String Returns the namespace URI that is associated with the specified prefix for the node. | XMLNode
Inherited | getPrefixForNamespace(ns:String):String Returns the prefix that is associated with the specified namespace URI for the node. | XMLNode
Inherited | hasChildNodes():Boolean Indicates whether the specified XMLNode object has child nodes. | XMLNode
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | insertBefore(node:XMLNode, before:XMLNode):void Inserts a new child node into the XML object's child list, before the beforeNode node. | XMLNode
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | parseXML(source:String):void Parses the XML text specified in the value parameter and populates the specified XMLDocument object with the resulting XML tree. | XMLDocument
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | removeNode():void Removes the specified XML object from its parent. | XMLNode
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string representation of the XML object. | XMLDocument
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
docTypeDecl property
public var docTypeDecl:Object = null

Specifies information about the XML document's DOCTYPE declaration. After the XML text has been parsed into an XMLDocument object, the XMLDocument.docTypeDecl property of the XMLDocument object is set to the text of the XML document's DOCTYPE declaration (for example, <!DOCTYPE greeting SYSTEM "hello.dtd">). This property is set using a string representation of the DOCTYPE declaration, not an XMLNode object.

The legacy ActionScript XML parser is not a validating parser. The DOCTYPE declaration is read by the parser and stored in the XMLDocument.docTypeDecl property, but no DTD validation is performed.

If no DOCTYPE declaration was encountered during a parse operation, the XMLDocument.docTypeDecl property is set to null. The XML.toString() method outputs the contents of XML.docTypeDecl immediately after the XML declaration stored in XML.xmlDecl, and before any other text in the XML object. If XMLDocument.docTypeDecl is null, no DOCTYPE declaration is output.

idMap property
public var idMap:Object

An Object containing the nodes of the XML that have an id attribute assigned. The names of the properties of the object (each containing a node) match the values of the id attributes.

Consider the following XMLDocument object:

  <employee id='41'>
   <name>
    John Doe
   </name>
   <address>
    601 Townsend St.
   </address>
  </employee>

  <employee id='42'>
   <name>
    Jane Q. Public
   </name>
  </employee>
  <department id="IT">
   Information Technology
  </department>

In this example, the idMap property for this XMLDocument object is an Object with three properties: 41, 42, and IT. Each of these properties is an XMLNode that has the matching id value. For example, the IT property of the idMap object is this node:

  <department id="IT">
   Information Technology
  </department>

You must use the parseXML() method on the XMLDocument object for the idMap property to be instantiated.

If there is more than one XMLNode with the same id value, the matching property of the idNode object is that of the last node parsed. For example:

  var x1:XML = new XMLDocument("<a id='1'><b id='2' /><c id='1' /></a>");
  x2 = new XMLDocument();
  x2.parseXML(x1);
  trace (x2.idMap['1']);
This will output the <c> node:
  <c id='1' />
ignoreWhite property
public var ignoreWhite:Boolean = false

When set to true, text nodes that contain only white space are discarded during the parsing process. Text nodes with leading or trailing white space are unaffected. The default setting is false.

You can set the ignoreWhite property for individual XMLDocument objects, as the following code shows:

  my_xml.ignoreWhite = true;
xmlDecl property
public var xmlDecl:Object = null

A string that specifies information about a document's XML declaration. After the XML document is parsed into an XMLDocument object, this property is set to the text of the document's XML declaration. This property is set using a string representation of the XML declaration, not an XMLNode object. If no XML declaration is encountered during a parse operation, the property is set to null. The XMLDocument.toString() method outputs the contents of the XML.xmlDecl property before any other text in the XML object. If the XML.xmlDecl property contains null, no XML declaration is output.

Constructor detail
XMLDocument () constructor
public function XMLDocument(source:String = null)

Creates a new XMLDocument object. You must use the constructor to create an XMLDocument object before you call any of the methods of the XMLDocument class.

Note: Use the createElement() and createTextNode() methods to add elements and text nodes to an XML document tree.

Parameters
source:String (default = null) — The XML text parsed to create the new XMLDocument object.

See also

XMLDocument.createElement()
XMLDocument.createTextNode()
Method detail
createElement () method
public function createElement(name:String):XMLNode

Creates a new XMLNode object with the name specified in the parameter. The new node initially has no parent, no children, and no siblings. The method returns a reference to the newly created XMLNode object that represents the element. This method and the XMLDocument.createTextNode() method are the constructor methods for creating nodes for an XMLDocument object.

Parameters
name:String — The tag name of the XMLDocument element being created.

Returns
XMLNode — An XMLNode object.

See also

XMLDocument.createTextNode()
createTextNode () method
public function createTextNode(text:String):XMLNode

Creates a new XML text node with the specified text. The new node initially has no parent, and text nodes cannot have children or siblings. This method returns a reference to the XMLDocument object that represents the new text node. This method and the XMLDocument.createElement() method are the constructor methods for creating nodes for an XMLDocument object.

Parameters
text:String — The text used to create the new text node.

Returns
XMLNode — An XMLNode object.

See also

XMLDocument.createElement()
parseXML () method
public function parseXML(source:String):void

Parses the XML text specified in the value parameter and populates the specified XMLDocument object with the resulting XML tree. Any existing trees in the XMLDocument object are discarded.

Parameters
source:String — The XML text to be parsed and passed to the specified XMLDocument object.
toString () method
public override function toString():String

Returns a string representation of the XML object.

Returns
String
Examples

The following example uses the XMLDocument and XMLNode classes to parse and format an XML document. Rather than loading an external XML file, the example uses the top-level XML class to create an XML document, then parses it.
package {
    import flash.display.Sprite;
    import flash.xml.XMLDocument;
    import flash.xml.XMLNode;
    import flash.xml.XMLNodeType;

    public class XMLDocumentExample extends Sprite {
        public function XMLDocumentExample() {
            var result:XMLDocument = new XMLDocument();
            result.ignoreWhite = true;
            result.parseXML(getXMLString());

            var books:Array = parseBooks(result.firstChild);
            trace("books: \n" + books);
        }

        private function parseBooks(node:XMLNode):Array {
            var books:Array = new Array();

            var kids:Array = node.childNodes;
            for each(var item:XMLNode in kids) {
                parseBook(item, books);
            }

            return books;
        }

        private function parseBook(node:XMLNode, books:Array):void {
            var item:Book = new Book();
            item.setPublisher(node.attributes.publisher);
            item.setName(node.attributes.name);
            books.push(item);
        }

        private function getXMLString():String {
            var list:XML = <books>
                                <book publisher="Addison-Wesley" name="Design Patterns" />
                                <book publisher="Addison-Wesley" name="The Pragmatic Programmer" />
                                <book publisher="Addison-Wesley" name="Test Driven Development" />
                                <book publisher="Addison-Wesley" name="Refactoring to Patterns" />
                                <book publisher="O'Reilly Media" name="The Cathedral & the Bazaar" />
                                <book publisher="O'Reilly Media" name="Unit Test Frameworks" />
                            </books>;
            return list.toXMLString();
        }
    }

}
class Book {
    private var publisher:String;
    private var name:String;

    public function setPublisher(publisher:String):void {
        this.publisher = publisher;
    }

    public function setName(name:String):void {
        this.name = name;
    }

    public function toString():String {
        return "[Book name: " + name + " publisher: " + publisher + "]\n";
    }
}


flash.xml.XMLNode (Flex™ 2 Language Reference)

Class XMLNode | Properties | Methods | Examples
Package | flash.xml
Class | public class XMLNode
Inheritance | XMLNode Inheritance Object
Subclasses | XMLDocument

The XMLNode class represents the legacy XML object that was present in ActionScript 2.0 and that was renamed in ActionScript 3.0. In ActionScript 3.0, consider using the new top-level XML class and related classes instead, which support E4X (ECMAScript for XML). The XMLNode class is present for backward compatibility.

View the examples.

See also

XML
flash.xml.XMLDocument

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | attributes : Object An object containing all of the attributes of the specified XMLNode instance. | XMLNode
 | childNodes : Array [read-only] An array of the specified XMLNode object's children. | XMLNode
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | firstChild : XMLNode Evaluates the specified XMLDocument object and references the first child in the parent node's child list. | XMLNode
 | lastChild : XMLNode An XMLNode value that references the last child in the node's child list. | XMLNode
 | localName : String [read-only] The local name portion of the XML node's name. | XMLNode
 | namespaceURI : String [read-only] If the XML node has a prefix, namespaceURI is the value of the xmlns declaration for that prefix (the URI), which is typically called the namespace URI. | XMLNode
 | nextSibling : XMLNode An XMLNode value that references the next sibling in the parent node's child list. | XMLNode
 | nodeName : String A string representing the node name of the XMLNode object. | XMLNode
 | nodeType : uint A nodeType constant value, either XMLNodeType.ELEMENT_NODE for an XML element or XMLNodeType.TEXT_NODE for a text node. | XMLNode
 | nodeValue : String The node value of the XMLDocument object. | XMLNode
 | parentNode : XMLNode An XMLNode value that references the parent node of the specified XML object, or returns null if the node has no parent. | XMLNode
 | prefix : String [read-only] The prefix portion of the XML node name. | XMLNode
 | previousSibling : XMLNode An XMLNode value that references the previous sibling in the parent node's child list. | XMLNode
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | XMLNode(type:uint, value:String) Creates a new XMLNode object. | XMLNode
 | appendChild(node:XMLNode):void Appends the specified node to the XML object's child list. | XMLNode
 | cloneNode(deep:Boolean):XMLNode Constructs and returns a new XML node of the same type, name, value, and attributes as the specified XML object. | XMLNode
 | getNamespaceForPrefix(prefix:String):String Returns the namespace URI that is associated with the specified prefix for the node. | XMLNode
 | getPrefixForNamespace(ns:String):String Returns the prefix that is associated with the specified namespace URI for the node. | XMLNode
 | hasChildNodes():Boolean Indicates whether the specified XMLNode object has child nodes. | XMLNode
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | insertBefore(node:XMLNode, before:XMLNode):void Inserts a new child node into the XML object's child list, before the beforeNode node. | XMLNode
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removeNode():void Removes the specified XML object from its parent. | XMLNode
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Evaluates the specified XMLNode object, constructs a textual representation of the XML structure, including the node, children, and attributes, and returns the result as a string. | XMLNode
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
attributes property
attributes:Object [read-write]

An object containing all of the attributes of the specified XMLNode instance. The XMLNode.attributes object contains one variable for each attribute of the XMLNode instance. Because these variables are defined as part of the object, they are generally referred to as properties of the object. The value of each attribute is stored in the corresponding property as a string. For example, if you have an attribute named color, you would retrieve that attribute's value by specifying color as the property name, as the following code shows:

  var myColor:String = doc.firstChild.attributes.color

Implementation
    public function get attributes():Object
    public function set attributes(value:Object):void
childNodes property
childNodes:Array [read-only]

An array of the specified XMLNode object's children. Each element in the array is a reference to an XMLNode object that represents a child node. This is a read-only property and cannot be used to manipulate child nodes. Use the appendChild(), insertBefore(), and removeNode() methods to manipulate child nodes.

This property is undefined for text nodes (nodeType == 3).

Implementation
    public function get childNodes():Array

See also

XMLNode.nodeType
XMLNode.appendChild()
XMLNode.insertBefore()
XMLNode.removeNode()
firstChild property
public var firstChild:XMLNode

Evaluates the specified XMLDocument object and references the first child in the parent node's child list. This property is null if the node does not have children. This property is undefined if the node is a text node. This is a read-only property and cannot be used to manipulate child nodes; use the appendChild(), insertBefore(), and removeNode() methods to manipulate child nodes.

See also

XMLNode.appendChild()
XMLNode.insertBefore()
XMLNode.removeNode()
lastChild property
public var lastChild:XMLNode

An XMLNode value that references the last child in the node's child list. The XMLNode.lastChild property is null if the node does not have children. This property cannot be used to manipulate child nodes; use the appendChild(), insertBefore(), and removeNode() methods to manipulate child nodes.

See also

XMLNode.appendChild()
XMLNode.insertBefore()
XMLNode.removeNode()
localName property
localName:String [read-only]

The local name portion of the XML node's name. This is the element name without the namespace prefix. For example, the node <contact:mailbox/>bob@example.com</contact:mailbox> has the local name "mailbox", and the prefix "contact", which comprise the full element name "contact.mailbox".

You can access the namespace prefix through the prefix property of the XML node object. The nodeName property returns the full name (including the prefix and the local name).

Implementation
    public function get localName():String
namespaceURI property
namespaceURI:String [read-only]

If the XML node has a prefix, namespaceURI is the value of the xmlns declaration for that prefix (the URI), which is typically called the namespace URI. The xmlns declaration is in the current node or in a node higher in the XML hierarchy.

If the XML node does not have a prefix, the value of the namespaceURI property depends on whether there is a default namespace defined (as in xmlns="http://www.example.com/"). If there is a default namespace, the value of the namespaceURI property is the value of the default namespace. If there is no default namespace, the namespaceURI property for that node is an empty string ("").

You can use the getNamespaceForPrefix() method to identify the namespace associated with a specific prefix. The namespaceURI property returns the prefix associated with the node name.

Implementation
    public function get namespaceURI():String

See also

getNamespaceForPrefix()
getPrefixForNamespace()
nextSibling property
public var nextSibling:XMLNode

An XMLNode value that references the next sibling in the parent node's child list. This property is null if the node does not have a next sibling node. This property cannot be used to manipulate child nodes; use the appendChild(), insertBefore(), and removeNode() methods to manipulate child nodes.

See also

XMLNode.firstChild
XMLNode.appendChild()
XMLNode.insertBefore()
XMLNode.removeNode()
nodeName property
public var nodeName:String

A string representing the node name of the XMLNode object. If the XMLNode object is an XML element (nodeType == 1), nodeName is the name of the tag that represents the node in the XML file. For example, TITLE is the nodeName of an HTML TITLE tag. If the XMLNode object is a text node (nodeType == 3), nodeName is null.

See also

XMLNode.nodeType
nodeType property
public var nodeType:uint

A nodeType constant value, either XMLNodeType.ELEMENT_NODE for an XML element or XMLNodeType.TEXT_NODE for a text node.

The nodeType is a numeric value from the NodeType enumeration in the W3C DOM Level 1 recommendation: http://www.w3.org/tr/1998/REC-DOM-Level-1-19981001/level-one-core.html. The following table lists the values:

Integer value | Defined constant
1 | ELEMENT_NODE
2 | ATTRIBUTE_NODE
3 | TEXT_NODE
4 | CDATA_SECTION_NODE
5 | ENTITY_REFERENCE_NODE
6 | ENTITY_NODE
7 | PROCESSING_INSTRUCTION_NODE
8 | COMMENT_NODE
9 | DOCUMENT_NODE
10 | DOCUMENT_TYPE_NODE
11 | DOCUMENT_FRAGMENT_NODE
12 | NOTATION_NODE

In Flash Player, the built-in XMLNode class only supports XMLNodeType.ELEMENT_NODE and XMLNodeTypeTEXT_NODE.

See also

XMLNodeType.TEXT_NODE
XMLNodeType.ELEMENT_NODE
nodeValue property
public var nodeValue:String

The node value of the XMLDocument object. If the XMLDocument object is a text node, the nodeType is 3, and the nodeValue is the text of the node. If the XMLDocument object is an XML element (nodeType is 1), nodeValue is null and read-only.

See also

XMLNode.nodeType
parentNode property
public var parentNode:XMLNode

An XMLNode value that references the parent node of the specified XML object, or returns null if the node has no parent. This is a read-only property and cannot be used to manipulate child nodes; use the appendChild(), insertBefore(), and removeNode() methods to manipulate child nodes.

See also

XMLNode.appendChild()
XMLNode.insertBefore()
XMLNode.removeNode()
prefix property
prefix:String [read-only]

The prefix portion of the XML node name. For example, the node <contact:mailbox/>bob@example.com</contact:mailbox> prefix "contact" and the local name "mailbox", which comprise the full element name "contact.mailbox".

The nodeName property of an XML node object returns the full name (including the prefix and the local name). You can access the local name portion of the element's name via the localName property.

Implementation
    public function get prefix():String
previousSibling property
public var previousSibling:XMLNode

An XMLNode value that references the previous sibling in the parent node's child list. The property has a value of null if the node does not have a previous sibling node. This property cannot be used to manipulate child nodes; use the appendChild(), insertBefore(), and removeNode() methods to manipulate child nodes.

See also

XMLNode.lastChild
XMLNode.appendChild()
XMLNode.insertBefore()
XMLNode.removeNode()
Constructor detail
XMLNode () constructor
public function XMLNode(type:uint, value:String)

Creates a new XMLNode object. You must use the constructor to create an XMLNode object before you call any of the methods of the XMLNode class.

Note: Use the createElement() and createTextNode() methods to add elements and text nodes to an XML document tree.

Parameters
type:uint — The node type: either 1 for an XML element or 3 for a text node.
value:String — The XML text parsed to create the new XMLNode object.

See also

XMLDocument.createElement()
XMLDocument.createTextNode()
Method detail
appendChild () method
public function appendChild(node:XMLNode):void

Appends the specified node to the XML object's child list. This method operates directly on the node referenced by the childNode parameter; it does not append a copy of the node. If the node to be appended already exists in another tree structure, appending the node to the new location will remove it from its current location. If the childNode parameter refers to a node that already exists in another XML tree structure, the appended child node is placed in the new tree structure after it is removed from its existing parent node.

Parameters
node:XMLNode — An XMLNode that represents the node to be moved from its current location to the child list of the my_xml object.

See also

E4X: A new approach to XML processing
cloneNode () method
public function cloneNode(deep:Boolean):XMLNode

Constructs and returns a new XML node of the same type, name, value, and attributes as the specified XML object. If deep is set to true, all child nodes are recursively cloned, resulting in an exact copy of the original object's document tree.

The clone of the node that is returned is no longer associated with the tree of the cloned item. Consequently, nextSibling, parentNode, and previousSibling all have a value of null. If the deep parameter is set to false, or the my_xml node has no child nodes, firstChild and lastChild are also null.

Parameters
deep:Boolean — A Boolean value; if set to true, the children of the specified XML object will be recursively cloned.

Returns
XMLNode — An XMLNode Object.
getNamespaceForPrefix () method
public function getNamespaceForPrefix(prefix:String):String

Returns the namespace URI that is associated with the specified prefix for the node. To determine the URI, getPrefixForNamespace() searches up the XML hierarchy from the node, as necessary, and returns the namespace URI of the first xmlns declaration for the given prefix.

If no namespace is defined for the specified prefix, the method returns null.

If you specify an empty string ("") as the prefix and there is a default namespace defined for the node (as in xmlns="http://www.example.com/"), the method returns that default namespace URI.

Parameters
prefix:String — The prefix for which the method returns the associated namespace.

Returns
String — The namespace that is associated with the specified prefix.

See also

XMLNode.getPrefixForNamespace()
XMLNode.namespaceURI
getPrefixForNamespace () method
public function getPrefixForNamespace(ns:String):String

Returns the prefix that is associated with the specified namespace URI for the node. To determine the prefix, getPrefixForNamespace() searches up the XML hierarchy from the node, as necessary, and returns the prefix of the first xmlns declaration with a namespace URI that matches ns.

If there is no xmlns assignment for the given URI, the method returns null. If there is an xmlns assignment for the given URI but no prefix is associated with the assignment, the method returns an empty string ("").

Parameters
ns:String — The namespace URI for which the method returns the associated prefix.

Returns
String — The prefix associated with the specified namespace.

See also

XMLNode.getNamespaceForPrefix()
XMLNode.namespaceURI
hasChildNodes () method
public function hasChildNodes():Boolean

Indicates whether the specified XMLNode object has child nodes. This property is true if the specified XMLNode object has child nodes; otherwise, it is false.

Returns
Boolean — Returns true if the specified XMLNode object has child nodes; otherwise, false.
insertBefore () method
public function insertBefore(node:XMLNode, before:XMLNode):void

Inserts a new child node into the XML object's child list, before the beforeNode node. If the beforeNode parameter is undefined or null, the node is added using the appendChild() method. If beforeNode is not a child of my_xml, the insertion fails.

Parameters
node:XMLNode — The XMLNode object to be inserted.
before:XMLNode — The XMLNode object before the insertion point for the childNode.

See also

XMLNode.cloneNode()
removeNode () method
public function removeNode():void

Removes the specified XML object from its parent. Also deletes all descendants of the node.

toString () method
public function toString():String

Evaluates the specified XMLNode object, constructs a textual representation of the XML structure, including the node, children, and attributes, and returns the result as a string.

For top-level XMLDocument objects (those created with the constructor), the XMLDocument.toString() method outputs the document's XML declaration (stored in the XMLDocument.xmlDecl property), followed by the document's DOCTYPE declaration (stored in the XMLDocument.docTypeDecl property), followed by the text representation of all XML nodes in the object. The XML declaration is not output if the XMLDocument.xmlDecl property is null. The DOCTYPE declaration is not output if the XMLDocument.docTypeDecl property is null.

Returns
String — The string representing the XMLNode object.

See also

XMLDocument.docTypeDecl
XMLDocument.xmlDecl
Examples

The following example uses the XMLDocument and XMLNode classes to parse and format an XML document. Rather than loading an external XML file, the example uses the top-level XML class to create an XML document, then parses it.
package {
    import flash.display.Sprite;
    import flash.xml.XMLDocument;
    import flash.xml.XMLNode;
    import flash.xml.XMLNodeType;

    public class XMLDocumentExample extends Sprite {
        public function XMLDocumentExample() {
            var result:XMLDocument = new XMLDocument();
            result.ignoreWhite = true;
            result.parseXML(getXMLString());

            var books:Array = parseBooks(result.firstChild);
            trace("books: \n" + books);
        }

        private function parseBooks(node:XMLNode):Array {
            var books:Array = new Array();

            var kids:Array = node.childNodes;
            for each(var item:XMLNode in kids) {
                parseBook(item, books);
            }

            return books;
        }

        private function parseBook(node:XMLNode, books:Array):void {
            var item:Book = new Book();
            item.setPublisher(node.attributes.publisher);
            item.setName(node.attributes.name);
            books.push(item);
        }

        private function getXMLString():String {
            var list:XML = <books>
                                <book publisher="Addison-Wesley" name="Design Patterns" />
                                <book publisher="Addison-Wesley" name="The Pragmatic Programmer" />
                                <book publisher="Addison-Wesley" name="Test Driven Development" />
                                <book publisher="Addison-Wesley" name="Refactoring to Patterns" />
                                <book publisher="O'Reilly Media" name="The Cathedral & the Bazaar" />
                                <book publisher="O'Reilly Media" name="Unit Test Frameworks" />
                            </books>;
            return list.toXMLString();
        }
    }

}
class Book {
    private var publisher:String;
    private var name:String;

    public function setPublisher(publisher:String):void {
        this.publisher = publisher;
    }

    public function setName(name:String):void {
        this.name = name;
    }

    public function toString():String {
        return "[Book name: " + name + " publisher: " + publisher + "]\n";
    }
}


flash.xml.XMLNodeType (Flex™ 2 Language Reference)

Class XMLNodeType | Properties | Methods | Constants
Package | flash.xml
Class | public final class XMLNodeType
Inheritance | XMLNodeType Inheritance Object

The XMLNodeType class contains constants used with XMLNode.nodeType. The values are defined by the NodeType enumeration in the W3C DOM Level 1 recommendation: http://www.w3.org/tr/1998/REC-DOM-Level-1-19981001/level-one-core.html

See also

XMLNode.nodeType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ELEMENT_NODE : uint = 1 [static] Specifies that the node is an element. | XMLNodeType
 | TEXT_NODE : uint = 3 [static] Specifies that the node is a text node. | XMLNodeType
Constant detail
ELEMENT_NODE constant
public static const ELEMENT_NODE:uint = 1

Specifies that the node is an element. This constant is used with XMLNode.nodeType. The value is defined by the NodeType enumeration in the W3C DOM Level 1 recommendation: http://www.w3.org/tr/1998/REC-DOM-Level-1-19981001/level-one-core.html

See also

XMLNode.nodeType
TEXT_NODE constant
public static const TEXT_NODE:uint = 3

Specifies that the node is a text node. This constant is used with XMLNode.nodeType. The value is defined by the NodeType enumeration in the W3C DOM Level 1 recommendation: http://www.w3.org/tr/1998/REC-DOM-Level-1-19981001/level-one-core.html

See also

XMLNode.nodeType


mx.binding.utils Summary (Flex™ 2 Language Reference)

Package mx.binding.utils | Classes

The mx.binding.utils package contains the classes for creating binding watchers and for defining bindings in ActionScript.

Classes
Class | Description
BindingUtils | The BindingUtils class defines utility methods for performing data binding from ActionScript.
ChangeWatcher | The ChangeWatcher class defines utility methods that you can use with bindable Flex properties.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.binding.utils.BindingUtils (Flex™ 2 Language Reference)

View comments | RSS feed
Class BindingUtils | Properties | Methods
Package | mx.binding.utils
Class | public class BindingUtils
Inheritance | BindingUtils Inheritance Object

The BindingUtils class defines utility methods for performing data binding from ActionScript. You can use the methods defined in this class to configure data bindings.

See also

About data binding

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | bindProperty(site:Object, prop:String, host:Object, chain:Object, commitOnly:Boolean = false):ChangeWatcher [static] Binds a public property, prop on the site Object, to a bindable property or property chain. | BindingUtils
 | bindSetter(setter:Function, host:Object, chain:Object, commitOnly:Boolean = false):ChangeWatcher [static] Binds a setter function, setter, to a bindable property or property chain. | BindingUtils
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
bindProperty () method
public static function bindProperty(site:Object, prop:String, host:Object, chain:Object, commitOnly:Boolean = false):ChangeWatcher

Binds a public property, prop on the site Object, to a bindable property or property chain. If a ChangeWatcher instance is successfully created, prop is initialized to the current value of chain.

Parameters
site:Object — The Object defining the property to be bound to chain.
prop:String — The name of the public property defined in the site Object to be bound. The property will receive the current value of chain, when the value of chain changes.
host:Object — The object that hosts the property or property chain to be watched.
chain:Object — A value specifying the property or chain to be watched. Legal values are:
  • String containing the name of a public bindable property of the host object.
  • An Object in the form: { name: property name, access: function(host) { return host[name] } }. This Object must contain the name of, and an accessor function for, a non-public bindable property of the host object.
  • A non-empty Array containing a combination of the first two options that represents a chain of bindable properties accessible from the host. For example, to watch the property host.a.b.c, call the method as: watch(host, ["a","b","c"], ...).
commitOnly:Boolean (default = false) — Set to true if the handler should be called only on committing change events; set to false if the handler should be called on both committing and non-committing change events. Note: the presence of non-committing change events for a property is indicated by the [NonCommittingChangeEvent(<event-name>)] metadata tag. Typically these tags are used to indicate fine-grained value changes, such as modifications in a text field prior to confirmation.

Returns
ChangeWatcher — A ChangeWatcher instance, if at least one property name has been specified to the chain argument; null otherwise.
bindSetter () method
public static function bindSetter(setter:Function, host:Object, chain:Object, commitOnly:Boolean = false):ChangeWatcher

Binds a setter function, setter, to a bindable property or property chain. If a ChangeWatcher instance is successfully created, the setter function is invoked with current value of chain.

Parameters
setter:Function — Setter method to invoke with an argument of the current value of chain when that value changes.
host:Object — The host of the property. See the bindProperty() method for more information.
chain:Object — The name of the property, or property chain. See the bindProperty() method for more information.
commitOnly:Boolean (default = false) — Set to true if the handler should be called only on committing change events. See the bindProperty() method for more information.

Returns
ChangeWatcher — A ChangeWatcher instance, if at least one property name has been specified to the chain argument; null otherwise.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

TankMan89 said on Jul 2, 2006 at 9:51 AM :
An example would be good here. An example of how to make something bindable, and bind to it, entirely in actionscript, not mxml.
smgilson said on Jul 3, 2006 at 5:18 AM :
There are examples in the doc here:

http://livedocs.macromedia.com/flex/2/docs/00001043.html

http://livedocs.macromedia.com/flex/2/docs/00001044.html

Stephen

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/mx/binding/utils/BindingUtils.html


mx.binding.utils.ChangeWatcher (Flex™ 2 Language Reference)

Class ChangeWatcher | Properties | Methods
Package | mx.binding.utils
Class | public class ChangeWatcher
Inheritance | ChangeWatcher Inheritance Object

The ChangeWatcher class defines utility methods that you can use with bindable Flex properties. These methods let you define an event handler that is executed whenever a bindable property is updated.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ChangeWatcher(access:Object, handler:Function, commitOnly:Boolean = false, next:ChangeWatcher = null) Constructor. | ChangeWatcher
 | canWatch(host:Object, name:String, commitOnly:Boolean = false):Boolean [static] Lets you determine if the host exposes a data-binding event on the property. | ChangeWatcher
 | getEvents(host:Object, name:String, commitOnly:Boolean = false):Object [static] Returns all the binding events for all bindable properties in the host object. | ChangeWatcher
 | getValue():Object Retrieves the current value of the watched property or property chain, or null if the host object is null. | ChangeWatcher
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | isWatching():Boolean Returns true if each watcher in the chain is attached to at least one change event. | ChangeWatcher
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | reset(newHost:Object):void Resets this ChangeWatcher instance to use a new host object. | ChangeWatcher
 | setHandler(handler:Function):void Sets the handler function. | ChangeWatcher
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
 | unwatch():void Detaches this ChangeWatcher instance, and its handler function, from the current host. | ChangeWatcher
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
 | watch(host:Object, chain:Object, handler:Function, commitOnly:Boolean = false):ChangeWatcher [static] Creates and starts a ChangeWatcher instance. | ChangeWatcher
Constructor detail
ChangeWatcher () constructor
public function ChangeWatcher(access:Object, handler:Function, commitOnly:Boolean = false, next:ChangeWatcher = null)

Constructor. Not for public use. This method is called only from the watch() method. See the watch() method for parameter usage.

Parameters
access:Object
handler:Function
commitOnly:Boolean (default = false)
next:ChangeWatcher (default = null)
Method detail
canWatch () method
public static function canWatch(host:Object, name:String, commitOnly:Boolean = false):Boolean

Lets you determine if the host exposes a data-binding event on the property.

Parameters
host:Object — The host of the property. See the watch() method for more information.
name:String — The name of the property, or property chain. See the watch() method for more information.
commitOnly:Boolean (default = false) — Set to true if the handler should be called only on committing change events. See the watch() method for more information.

Returns
Boolean — true if host exposes any change events on name.
getEvents () method
public static function getEvents(host:Object, name:String, commitOnly:Boolean = false):Object

Returns all the binding events for all bindable properties in the host object.

Parameters
host:Object — The host of the property. See the watch() method for more information.
name:String — The name of the property, or property chain. See the watch() method for more information.
commitOnly:Boolean (default = false) — Controls inclusion of non-committing change events in the returned value.

Returns
Object — Object of the form { eventName: isCommitting, ... } containing all change events for the property.
getValue () method
public function getValue():Object

Retrieves the current value of the watched property or property chain, or null if the host object is null. For example:

   watch(obj, ["a","b","c"], ...).getValue() === obj.a.b.c

Returns
Object — The current value of the watched property or property chain.
isWatching () method
public function isWatching():Boolean

Returns true if each watcher in the chain is attached to at least one change event. Note that the isWatching() method varies with host, since different hosts may expose different change events for the watcher's chosen property.

Returns
Boolean — true if each watcher in the chain is attached to at least one change event.
reset () method
public function reset(newHost:Object):void

Resets this ChangeWatcher instance to use a new host object. You can call this method to reuse a watcher instance on a different host.

Parameters
newHost:Object — The new host of the property. See the watch() method for more information.
setHandler () method
public function setHandler(handler:Function):void

Sets the handler function.

Parameters
handler:Function — The handler function. This argument must not be null.
unwatch () method
public function unwatch():void

Detaches this ChangeWatcher instance, and its handler function, from the current host. You can use the reset() method to reattach the ChangeWatcher instance, or watch the same property or chain on a different host object.

watch () method
public static function watch(host:Object, chain:Object, handler:Function, commitOnly:Boolean = false):ChangeWatcher

Creates and starts a ChangeWatcher instance. A single ChangeWatcher instance can watch one property, or a property chain. A property chain is a sequence of properties accessible from a host object. For example, the expression obj.a.b.c contains the property chain (a, b, c).

Parameters
host:Object — The object that hosts the property or property chain to be watched. You can use the use the reset() method to change the value of the host argument after creating the ChangeWatcher instance.
chain:Object — A value specifying the property or chain to be watched. Legal values are:
  • A String containing the name of a public bindable property of the host object.
  • An Object in the form: { name: property name, access: function(host) { return host[name] } }. The Object contains the name of a public bindable property, and a function which serves as a getter for that property.
  • A non-empty Array containing any combination of the first two options. This represents a chain of bindable properties accessible from the host. For example, to watch the property host.a.b.c, call the method as: watch(host, ["a","b","c"], ...).

Note: The property or properties named in the chain argument must be public, because the describeType() method suppresses all information about non-public properties, including the bindability metadata that ChangeWatcher scans to find the change events that are exposed for a given property. However, the getter function supplied when using the { name, getter } argument form described above can be used to associate an arbitrary computed value with the named (public) property.
handler:Function — An event handler function called when the value of the watched property (or any property in a watched chain) is modified. The modification is signaled when any host object in the watcher chain dispatches the event that has been specified in that host object's [Bindable] metadata tag for the corresponding watched property. The default event is named propertyChange.

The event object dispatched by the bindable property is passed to this handler function without modification. By default, FLex dispatches an event object of type PropertyChangeEvent. However, you can define your own event type when you use the [Bindable] metadata tag to define a bindable property.
commitOnly:Boolean (default = false) — Set to true if the handler should be called only on committing change events; set to false if the handler should be called on both committing and non-committing change events. Note: the presence of non-committing change events for a property is indicated by the [NonCommittingChangeEvent(<event-name>)] metadata tag. Typically these tags are used to indicate fine-grained value changes, such as modifications in a text field prior to confirmation.

Returns
ChangeWatcher — The ChangeWatcher instance, if at least one property name has been specified to the chain argument; null otherwise. Note that the returned watcher is not guaranteed to have successfully discovered and attached itself to change events, since none may have been exposed on the given property or chain by the host. You can use the isWatching() method to determine the watcher's state.


mx.charts Summary (Flex™ 2 Language Reference)

Package mx.charts | Classes
(Adobe® Flex™ Charting components only)

The mx.charts package contains the Flex charting classes.

Classes
Class | Description
AreaChart | The AreaChart control represents data as an area bounded by a line connecting the values in the data.
AxisLabel | An AxisLabel object represents a single label on the chart axis.
AxisRenderer | You use the AxisRenderer class to describe the horizontal and vertical axes of a chart.
BarChart | The BarChart control represents data as a series of horizontal bars whose length is determined by values in the data.
BubbleChart | The BubbleChart control represents data with three values for each data point.
CandlestickChart | The CandlestickChart control represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
CategoryAxis | The CategoryAxis class lets charts represent data grouped by a set of discrete values along an axis.
ChartItem | A ChartItem represents a single item in a ChartSeries.
ColumnChart | The ColumnChart control represents data as a series of vertical columns whose height is determined by values in the data.
DateTimeAxis | The DateTimeAxis class maps time values evenly between a minimum and maximum value along a chart axis.
GridLines | The GridLines class draws grid lines inside the data area of the chart.
HitData | The HitData class represents information about the data item at a specific location on the screen.
HLOCChart | The HLOCChart (High Low Open Close) control represents financial data as a series of elements representing the high, low, closing, and optionally opening values of a data series.
Legend | The Legend control adds a legend to your charts, where the legend displays the label for each data series in the chart and a key showing the chart element for the series.
LegendItem | Controls the individual legend elements in a chart legend.
LinearAxis | The LinearAxis class maps numeric values evenly between a minimum and maximum value along a chart axis.
LineChart | The LineChart control represents a data series as points connected by a continuous line.
LogAxis | The LogAxis class maps numeric values logarithmically between a minimum and maximum value along a chart axis.
PieChart | The PieChart control represents a data series as a standard pie chart.
PlotChart | The PlotChart control represents data with two values for each data point.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.AreaChart (Flex™ 2 Language Reference)

Class AreaChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class AreaChart
Inheritance | AreaChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The AreaChart control represents data as an area bounded by a line connecting the values in the data. The AreaChart control can be used to represent different variations, including simple areas, stacked, 100% stacked, and high/low.

The AreaChart control expects its series property to contain an Array of AreaSeries objects.

Stacked and 100% area charts override the minField property of their AreaSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:AreaChart> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:AreaChart
    Properties
    type="overlaid|stacked|100%"
  />

View the examples.

See also

mx.charts.series.AreaSeries
Using the charting controls
Using area charts
Applying chart styles
Stacking charts
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
 | type : String Type of area chart to render. | AreaChart
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AreaChart()
Constructor.
AreaChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
type property
type:String [read-write]

Type of area chart to render.

Possible values are:

  • "overlaid": Multiple areas are rendered on top of each other, with the last series specified on top. This is the default value.
  • "stacked": Areas are stacked on top of each other and grouped by category. Each area represents the cumulative value of the areas beneath it.
  • "100%": Areas are stacked on top of each other, adding up to 100%. Each area represents the percent that series contributes to the sum of the whole.
Implementation
    public function get type():String
    public function set type(value:String):void
Constructor detail
AreaChart () constructor
public function AreaChart()

Constructor.

Examples
Line_AreaChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the LineChart and AreaChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="LineChart and AreaChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:LineChart id="linechart" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:LineSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:LineSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:LineSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:LineChart>

        <mx:Legend dataProvider="{linechart}"/>

        <mx:AreaChart id="Areachart" height="100%" width="45%"
             paddingLeft="5" paddingRight="5"
             showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:AreaSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:AreaSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:AreaSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:AreaChart>

        <mx:Legend dataProvider="{Areachart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.AxisLabel (Flex™ 2 Language Reference)

Class AxisLabel | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class AxisLabel
Inheritance | AxisLabel Inheritance Object

An AxisLabel object represents a single label on the chart axis. AxisLabel objects are generated by IAxis objects. The AxisLabel object is also passed as the data to custom AxisLabel objects that implement the IDataRenderer interface.

See also

mx.charts.AxisRenderer
mx.charts.chartClasses.IAxis

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | position : Number The position, specified as a value between 0 and 1, of the label along the axis. | AxisLabel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | text : String The text label that is actually rendered along the axis. | AxisLabel
 | value : Object The value that the label represents. | AxisLabel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AxisLabel(position:Number = 0, value:Object = null, text:String = null) Constructor. | AxisLabel
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
position property
public var position:Number

The position, specified as a value between 0 and 1, of the label along the axis. An AxisLabel with a position of 0 is placed at the minimum value of the axis, while an AxisLabel with a position of 1 is placed at the maximum value of the axis.

text property
public var text:String

The text label that is actually rendered along the axis.

value property
public var value:Object

The value that the label represents. The particular type of the value property is specific to the axis that generated the label. For example, a LinearAxis might generate numeric values, while a DateTimeAxis might generate Date instance values.

Constructor detail
AxisLabel () constructor
public function AxisLabel(position:Number = 0, value:Object = null, text:String = null)

Constructor.

Parameters
position:Number (default = 0) — The position, specified as a value between 0 and 1, of the label along the axis.
value:Object (default = null) — The value the label represents.
text:String (default = null) — The text label that is actually rendered along the axis.


mx.charts.AxisRenderer (Flex™ 2 Language Reference)

Class AxisRenderer | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class AxisRenderer
Inheritance | AxisRenderer Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IAxisRenderer

You use the AxisRenderer class to describe the horizontal and vertical axes of a chart. An axis is responsible for rendering the labels, tick marks, and title along its length.

AxisRenderer objects inherit some of their visual properties from the enclosing chart object. The text format of the labels and title defaults to the CSS text properties of the renderer. You can control the formatting of the axis title separately by specifying a axisTitleStyleName, either on the AxisRenderer or on the enclosing chart.

When positioning and sizing labels, the AxisRenderer takes a minimum amount of the chart's available space. If labels take too much space, then the AxisRenderer scales them. However, the AxisRenderer does not scale the labels to too small of a point size. To increase readability, the AxisRenderer chooses one of the following layout methods based on the one that requires the least scaling:

  • Render the labels horizontally end to end.
  • Stagger the labels horizontally in two rows.
  • Rotate the labels to fit them in the space provided. The AxisRenderer rotates the labels to the minimum angle needed to prevent them from overlapping. The maximum angle is 90 degrees.

The AxisRenderer adjusts the boundaries of the chart's data area to ensure that it can draw the labels without pushing outside of the boundaries.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:AxisRenderer> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:AxisRenderer
    Properties
    axis="IAxis"
    chart="ChartBase"
    gutters="Rectangle"
    heightLimit="Number"
    labelRenderer="IFactory"
    length="Number"
    otherAxes="Array"
    placement="right|left|bottom|top"
    ticks="Array"

    Styles
    axisStroke="No default"
    axisTitleStyleName="No default"
    canDropLabels="true|false"
    canStagger="true|false"
    labelGap="3"
    labelRotation="No default"
    minorTickLength="Default depends on axis"
    minorTickPlacement="none|inside|outside|cross"
    minorTickStroke="No default"
    showLabels="true|false"
    showLine="true|false"
    tickLength="Default depends on axis"
    tickPlacement="inside|outside|cross|none"
    tickStroke="No default"
  />

View the examples.

See also

Using strokes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | axis : IAxis The axis object associated with this renderer. | AxisRenderer
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | gutters : Rectangle The distance between the axisRenderer and the sides of the surrounding chart. | AxisRenderer
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
 | heightLimit : Number The maximum amount of space, in pixels, that an axis renderer will take from a chart. | AxisRenderer
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | horizontal : Boolean true if the axis renderer is being used as a horizontal axis. | AxisRenderer
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | labelRenderer : IFactory A reference to the factory used to render the axis labels. | AxisRenderer
 | length : Number [read-only] Specifies the length of the axis, in screen coordinates. | AxisRenderer
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
 | minorTicks : Array [read-only] Contains an array that specifies where Flex draws the minor tick marks along the axis. | AxisRenderer
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | otherAxes : Array [write-only] An Array of axes. | AxisRenderer
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | placement : String The side of the chart the axisRenderer will appear on. | AxisRenderer
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | ticks : Array [read-only] Contains an array that specifies where Flex draws the tick marks along the axis. | AxisRenderer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | chart : ChartBase [read-only] The base chart for this AxisRenderer. | AxisRenderer
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AxisRenderer()
Constructor.
AxisRenderer
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
adjustGutters(workingGutters:Rectangle, adjustable:Object):Rectangle
Adjusts its layout to accomodate the gutters passed in.
AxisRenderer
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
chartStateChanged(oldState:uint, newState:uint):void
Called by the chart to indicate when its current transition state has changed.
AxisRenderer
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
AxisRenderer
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
AxisRenderer
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
AxisRenderer
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
AxisRenderer
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Calculates the default size, and optionally the default minimum size, of the component. | AxisRenderer
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | AxisRenderer
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
axisStroke
Type: mx.graphics.IStroke CSS Inheritance: no
Specifies the characteristics of the line for the axis. This style must be an instance of the Stroke class. 		AxisRenderer
axisTitleStyleName
Type: String CSS Inheritance: yes
The name of the CSS class selector to use when formatting the axis title. 		AxisRenderer
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
canDropLabels
Type: Boolean CSS Inheritance: no
Specifies whether the AxisRenderer should drop labels as necessary to lay out correctly.

Set to true to cause the AxisRenderer to drop overlapping labels when rendering. Labels are always rendered at regular intervals. If necessary, the AxisRenderer will render every other label, or every third label, but never drop two or more consecutive labels.

Set to false to cause the AxisRenderer to use other schemes (rotation, scaling) to lay out the labels.

If you do not explicitly set this style, the AxisRenderer defaults to an appropriate value based on the type of axis being rendered.

AxisRenderer
canStagger
Type: Boolean CSS Inheritance: no
Specifies whether to stagger labels on two label rows. Use this setting to minimize the space required for the labels. The default value is true, which staggers the labels. 		AxisRenderer
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		AxisRenderer
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		AxisRenderer
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text in pixels. The default value is 10. 		AxisRenderer
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text uses an italic font face. Recognized values are "normal" and "italic". The default value is "normal". 		AxisRenderer
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text uses a bold face. Recognized values are "normal" and "bold". The default value is "normal". 		AxisRenderer
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
labelGap
Type: Number Format: Length CSS Inheritance: no
Specifies the gap between the end of the tick marks and the top of the labels, in pixels. The default value is 3. 		AxisRenderer
labelRotation
Type: Number CSS Inheritance: no
Specifies the label rotation. If the labels are rendered with device fonts, the labels are always drawn horizontally. If this style is any negative value, the AxisRenderer determines an optimal angle to render the labels in the smallest area without overlapping. 		AxisRenderer
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
minorTickLength
Type: Number Format: Length CSS Inheritance: no
Specifies the length of the minor tick marks on the axis, in pixels. The default value is 0. 		AxisRenderer
minorTickPlacement
Type: String CSS Inheritance: no
Specifies where to draw the minor tick marks. Options are:
  • "inside" - Draw minor tick marks inside the data area.
  • "outside" - Draw minor tick marks in the label area.
  • "cross" - Draw minor tick marks across the axis.
  • "none" - Draw no minor tick marks.
AxisRenderer
minorTickStroke
Type: mx.graphics.IStroke CSS Inheritance: no
Specifies the characteristics of the minor tick marks on the axis. This style must be an instance of the Stroke class. 		AxisRenderer
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
showLabels
Type: Boolean CSS Inheritance: no
Specifies whether labels should appear along the axis. The default value is true. 		AxisRenderer
showLine
Type: Boolean CSS Inheritance: no
Specifies whether to display the axis. The default value is true. 		AxisRenderer
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		AxisRenderer
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
tickLength
Type: Number Format: Length CSS Inheritance: no
Specifies the length of the tick marks on the axis, in pixels. The default value is 3. 		AxisRenderer
tickPlacement
Type: String CSS Inheritance: no
Specifies where to draw the tick marks. Options are:
  • "inside" - Draw tick marks inside the data area.
  • "outside" - Draw tick marks in the label area.
  • "cross" - Draw tick marks across the axis.
  • "none" - Draw no tick marks.
AxisRenderer
tickStroke
Type: mx.graphics.IStroke CSS Inheritance: no
Specifies the characteristics of the tick marks on the axis. This style must be an instance of the Stroke class. 		AxisRenderer
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
axis property
axis:IAxis [read-write]

The axis object associated with this renderer. This property is managed by the enclosing chart, and should not be explicitly set

Implementation
    public function get axis():IAxis
    public function set axis(value:IAxis):void
chart property
chart:ChartBase [read-only]

The base chart for this AxisRenderer.

Implementation
    protected function get chart():ChartBase
gutters property
gutters:Rectangle [read-write]

The distance between the axisRenderer and the sides of the surrounding chart. This property is assigned automatically by the chart, and should not be assigned directly.

Implementation
    public function get gutters():Rectangle
    public function set gutters(value:Rectangle):void
heightLimit property
heightLimit:Number [read-write]

The maximum amount of space, in pixels, that an axis renderer will take from a chart. Axis Renderers by default will take up as much space in the chart as necessary to render all of their labels at full size. If heightLimit is set, an AxisRenderer will resort to reducing the labels in size in order to guarantee the total size of the axis is less than heightLimit.

Implementation
    public function get heightLimit():Number
    public function set heightLimit(value:Number):void
horizontal property
horizontal:Boolean [read-write]

true if the axis renderer is being used as a horizontal axis. This property is managed by the enclosing CartesianChart, and should not be set directly.

Implementation
    public function get horizontal():Boolean
    public function set horizontal(value:Boolean):void
labelRenderer property
labelRenderer:IFactory [read-write]

A reference to the factory used to render the axis labels. This type must implement the IDataRenderer and IFlexDisplayObject interfaces.

The AxisRenderer will create one instance of this class for each label on the axis. The labelRenderer's data property is assigned an AxisLabel object containing the value and label to be rendered.

Implementation
    public function get labelRenderer():IFactory
    public function set labelRenderer(value:IFactory):void
length property
length:Number [read-only]

Specifies the length of the axis, in screen coordinates. The default length depends on a number of factors, including the size of the chart, the size of the labels, how the AxisRenderer chooses to lay out labels, and any requirements imposed by other portions of the chart.

Implementation
    public function get length():Number
minorTicks property
minorTicks:Array [read-only]

Contains an array that specifies where Flex draws the minor tick marks along the axis. Each array element contains a value between 0 and 1.

Implementation
    public function get minorTicks():Array
otherAxes property
otherAxes:Array [write-only]

An Array of axes.

Implementation
    public function set otherAxes(value:Array):void
placement property
placement:String [read-write]

The side of the chart the axisRenderer will appear on. Legal values are "left" and "right" for vertical axis renderers and "top" and "bottom" for horizontal axis renderers. By default, primary axes are placed on the left and top, and secondary axes are placed on the right and bottom. CartesianCharts automatically guarantee that secondary axes are placed opposite primary axes; if you explicitly place a primary vertical axis on the right, for example, the secondary vertical axis is swapped to the left.

Implementation
    public function get placement():String
    public function set placement(value:String):void
ticks property
ticks:Array [read-only]

Contains an array that specifies where Flex draws the tick marks along the axis. Each array element contains a value between 0 and 1.

Implementation
    public function get ticks():Array
Constructor detail
AxisRenderer () constructor
public function AxisRenderer()

Constructor.

Method detail
adjustGutters () method
public function adjustGutters(workingGutters:Rectangle, adjustable:Object):Rectangle

Adjusts its layout to accomodate the gutters passed in. This method is called by the enclosing chart to determine the size of the gutters and the corresponding data area. This method provides the AxisRenderer with an opportunity to calculate layout based on the new gutters, and to adjust them if necessary. If a given gutter is adjustable, an axis renderer can optionally adjust the gutters inward (i.e., larger) but not outward (smaller). The renderer should return the gutters plus any adjustments made.

Parameters
workingGutters:Rectangle — Defines the gutters to adjust.
adjustable:Object — Consists of four Boolean properties (left=true/false, top=true/false, right=true/false, and bottom=true/false) that indicate whether the axis renderer can optionally adjust each of the gutters further.

Returns
Rectangle
chartStateChanged () method
public function chartStateChanged(oldState:uint, newState:uint):void

Called by the chart to indicate when its current transition state has changed.

Parameters
oldState:uint — A number representing the old state.
newState:uint — A number representing the new state.
invalidateDisplayList () method
public override function invalidateDisplayList():void

Marks a component so that its updateDisplayList() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the width and height, it would be wasteful to update the component immediately after you change the width and then update again with the new height. It is more efficient to change both properties and then render the component with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

invalidateSize () method
public override function invalidateSize():void

Marks a component so that its measure() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the text and font size, it would be wasteful to update the text immediately after you change it and then update the size when it gets set. It is more efficient to change both properties and then render the text with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

measure () method
protected override function measure():void

Calculates the default size, and optionally the default minimum size, of the component. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the measure() method when the component is added to a container using the addChild() method, and when the component's invalidateSize() method is called.

When you set a specific height and width of a component, Flex does not call the measure() method, even if you explicitly call the invalidateSize() method. That is, Flex only calls the measure() method if the explicitWidth property or the explicitHeight property of the component is NaN.

In your override of this method, you must set the measuredWidth and measuredHeight properties to define the default size. You may optionally set the measuredMinWidth and measuredMinHeight properties to define the default minimum size.

Most components calculate these values based on the content they are displaying, and from the properties that affect content display. A few components simply have hard-coded default values.

The conceptual point of measure() is for the component to provide its own natural or intrinsic size as a default. Therefore, the measuredWidth and measuredHeight properties should be determined by factors such as:

  • The amount of text the component needs to display.
  • The styles, such as fontSize, for that text.
  • The size of a JPEG image that the component displays.
  • The measured or explicit sizes of the component's children.
  • Any borders, margins, and gaps.

In some cases, there is no intrinsic way to determine default values. For example, a simple GreenCircle component might simply set measuredWidth = 100 and measuredHeight = 100 in its measure() method to provide a reasonable default size. In other cases, such as a TextArea, an appropriate computation (such as finding the right width and height that would just display all the text and have the aspect ratio of a Golden Rectangle) might be too time-consuming to be worthwhile.

The default implementation of measure() is to set the default size to the current size of the component.

move () method
public override function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The new x-position for this object.
y:Number — The new y-position for this object.
setActualSize () method
public override function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
HLOCChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HLOCChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var stockDataAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.55,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 40.15,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
        ]]>
    </mx:Script>

    <mx:Panel title="HLOCChart Control Example" height="100%" width="100%">

        <mx:HLOCChart id="hlocchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{stockDataAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:HLOCSeries openField="Open" highField="High"
                    lowField="Low" closeField="Close"/>
            </mx:series>
        </mx:HLOCChart>

    </mx:Panel>
</mx:Application>


mx.charts.BarChart (Flex™ 2 Language Reference)

Class BarChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class BarChart
Inheritance | BarChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The BarChart control represents data as a series of horizontal bars whose length is determined by values in the data. A BarChart control can represent different chart variations, including simple bars, clustered bars, stacked, 100% stacked, and high/low.

The BarChart control expects its series property to contain an array of BarSeries objects.

Stacked and 100% bar charts override the minField property of their BarSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:BarChart> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:BarChart
    Properties
    type="clustered|overlaid|stacked|100%"

    Styles
    barWidthRatio=".65"
    maxBarWidth="No default"
  />

View the examples.

See also

mx.charts.series.BarSeries
Using the charting controls
Using bar charts
Applying chart styles
Stacking charts
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
 | type : String The type of bar chart to render. | BarChart
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BarChart()
Constructor.
BarChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
 | barWidthRatio | Type: Number CSS Inheritance: no Specifies how wide to draw the bars relative to the category width, as a percentage in the range of 0 to 1. A value of 1 uses the entire space, while a value of 0.6 uses 60% of the bar's available space. The actual bar width used is the smaller of the barWidthRatio property and the maxbarWidth property Clustered bars divide this space proportionally among the bars in each cluster. The default value is 0.65. | BarChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | maxBarWidth | Type: Number Format: Length CSS Inheritance: no Specifies how wide to draw the bars, in pixels. The actual bar width used is the smaller of this property and the barWidthRatio property. Clustered bars divide this space proportionally among the bars in each cluster. | BarChart
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
type property
type:String [read-write]

The type of bar chart to render. Possible values are:

  • "clustered": Bars are grouped by category. This is the default value.
  • "overlaid": Multiple bars are rendered on top of each other by category, with the last series specified on top.
  • "stacked": Bars are stacked end to end and grouped by category. Each bar represents the cumulative value of the values beneath it.
  • "100%": Bars are stacked end to end, adding up to 100%. Each bar represents the percent that it contributes to the sum of the values for that category.

Implementation
    public function get type():String
    public function set type(value:String):void
Constructor detail
BarChart () constructor
public function BarChart()

Constructor.

Examples
Column_BarChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ColumnChart and BarChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var medalsAC:ArrayCollection = new ArrayCollection( [
            { Country: "USA", Gold: 35, Silver:39, Bronze: 29 },
            { Country: "China", Gold: 32, Silver:17, Bronze: 14 },
            { Country: "Russia", Gold: 27, Silver:27, Bronze: 38 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="ColumnChart and BarChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:ColumnChart id="column" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:ColumnSeries xField="Country" yField="Gold" displayName="Gold"/>
                <mx:ColumnSeries xField="Country" yField="Silver" displayName="Silver"/>
                <mx:ColumnSeries xField="Country" yField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:ColumnChart>

        <mx:Legend dataProvider="{column}"/>

         <mx:BarChart id="bar" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:verticalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:verticalAxis>

            <mx:series>
                <mx:BarSeries yField="Country" xField="Gold" displayName="Gold"/>
                <mx:BarSeries yField="Country" xField="Silver" displayName="Silver"/>
                <mx:BarSeries yField="Country" xField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:BarChart>

        <mx:Legend dataProvider="{bar}"/>

    </mx:Panel>
</mx:Application>


mx.charts.BubbleChart (Flex™ 2 Language Reference)

Class BubbleChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class BubbleChart
Inheritance | BubbleChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The BubbleChart control represents data with three values for each data point. Each data point is defined by a value determining its position along the horizontal axis, a value determining its position along the vertical axis, and a value determining the size of the chart element, relative to the other data points on the chart.

The BubbleChart control expects its series property to contain an array of BubbleSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax
The <mx:BubbleChart> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:BubbleChart
    Properties
    radiusAxis="LinearAxis"
    secondRadiusAxis="LinearAxis"

    Styles
    maxRadius="30"
  />

View the examples.

See also

mx.charts.series.BubbleSeries
Using the charting controls
Using bubble charts
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radiusAxis : IAxis The axis the bubble radius is mapped against Bubble charts treat the size of the individual bubbles as a third dimension of data which is transformed in a similar manner to how x and y position is transformed. | BubbleChart
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
 | secondRadiusAxis : IAxis The axis the bubble radius of secondary series is mapped against. | BubbleChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BubbleChart()
Constructor.
BubbleChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
 | maxRadius | Type: Number Format: Length CSS Inheritance: no The maximum radius of the largest chart element, in pixels Flex assigns this radius to the data point with the largest value; all other data points are assigned a smaller radius based on their value relative to the largest value. The default value is 30 pixels. | BubbleChart
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
radiusAxis property
radiusAxis:IAxis [read-write]

The axis the bubble radius is mapped against Bubble charts treat the size of the individual bubbles as a third dimension of data which is transformed in a similar manner to how x and y position is transformed. By default, the radiusAxis is a LinearAxis with the autoAdjust property set to false.

Implementation
    public function get radiusAxis():IAxis
    public function set radiusAxis(value:IAxis):void
secondRadiusAxis property
secondRadiusAxis:IAxis [read-write]

The axis the bubble radius of secondary series is mapped against. Bubble charts treat the size of the individual bubbles as a third dimension of data which is transformed in a similar manner to how x and y position is transformed. By default, the secondRadisAxis is a LinearAxis with the autoAdjust property set to false.

Implementation
    public function get secondRadiusAxis():IAxis
    public function set secondRadiusAxis(value:IAxis):void
Constructor detail
BubbleChart () constructor
public function BubbleChart()

Constructor.

Examples
BubbleChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the BubbleChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Style>
        BubbleChart { color:#000099; }
    </mx:Style>

    <mx:Panel title="BubbleChart Control Example" height="100%" width="100%">

        <mx:BubbleChart id="bubblechart"
            height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" maxRadius="20"
            dataProvider="{expensesAC}">

            <mx:series>
                <mx:BubbleSeries displayName="Profit/Expenses/Amount"
                    xField="Profit" yField="Expenses" radiusField="Amount"/>
            </mx:series>
        </mx:BubbleChart>

        <mx:Legend dataProvider="{bubblechart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.CandlestickChart (Flex™ 2 Language Reference)

Class CandlestickChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class CandlestickChart
Inheritance | CandlestickChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The CandlestickChart control represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series. The top and bottom of the vertical line in each candlestick represent the high and low values for the datapoint, while the top and bottom of the filled box represents the opening and closing values. Each candlestick is filled differently depending on whether the closing value for the datapoint is higher or lower than the opening value.

A CandlestickChart control expects its series property to contain an array of CandlestickSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax
The <mx:CandlestickChart> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:CandlestickChart
    Styles
    columnWidthRatio=".65"
    maxColumnWidth="No default"
  />

View the examples.

See also

mx.charts.series.CandlestickSeries
Using the charting controls
Using candlestick charts
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CandlestickChart()
Constructor.
CandlestickChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
 | columnWidthRatio | Type: Number CSS Inheritance: no Specifies a ratio of how wide to draw the candlesticks relative to the horizontal axis's category widths, as a percentage in the range of 0 to 1. A value of 1 uses the entire space, while a value of 0.6 uses 60% of the column's available space. The actual candlestick width used is the smaller of the columnWidthRatio property and the maxColumnWidth property. Multiple candlestick series divide this space proportionally. The default value is 0.65. | CandlestickChart
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | maxColumnWidth | Type: Number Format: Length CSS Inheritance: no Specifies how wide to draw the candlesticks, in pixels. The actual column width used is the smaller of this property and the columnWidthRatio property. Multiple candlestick series divide this space proportionally. | CandlestickChart
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
CandlestickChart () constructor
public function CandlestickChart()

Constructor.

Examples
CandlestickChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the CandlestickChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.75,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 39.98,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
        ]]>
    </mx:Script>

    <mx:Panel title="CandlestickChart Control Example" height="100%" width="100%">

        <mx:CandlestickChart id="candlestickchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true"
            dataProvider="{expensesAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:CandlestickSeries openField="Open" highField="High"
                    lowField="Low" closeField="Close"/>
            </mx:series>

        </mx:CandlestickChart>
    </mx:Panel>
</mx:Application>


mx.charts.CategoryAxis (Flex™ 2 Language Reference)

Class CategoryAxis | Properties | Methods | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class CategoryAxis
Inheritance | CategoryAxis Inheritance AxisBase Inheritance EventDispatcher Inheritance Object
Implements | IAxis

The CategoryAxis class lets charts represent data grouped by a set of discrete values along an axis. You typically use the CategoryAxis class to define a set of labels that appear along an axis of a chart. For example, charts that render data according to City, Year, Business unit, and so on.

A CategoryAxis used in a chart does not inherit its dataProvider property from the containing chart. You must explicitly set the dataProvider property on a CategoryAxis.

While you can use the same dataProvider to provide data to the chart and categories to the CategoryAxis, a CategoryAxis can optimize rendering if its dataProvider is relatively static. If possible, ensure that the categories are relatively static and that changing data is stored in separate dataProviders.

The dataProvider property can accept either an array of strings or an array of records (objects) with a property specifying the category name. If you specify a categoryField property, the CategoryAxis assumes the dataProvider is an array of Objects. If categoryField is null, the CategoryAxis assumes dataProvider is an array of Strings.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:CategoryAxis> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:CategoryAxis
    Properties
    categoryField="null"
    dataProvider="No default"
    labelFunction="No default"
    padding="Default depends on chart type"
    ticksBetweenLabels="true"
  />

View the examples.

See also

Working with axes
About the CategoryAxis class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | baseline : Number [read-only] The baseline position for the axis. | CategoryAxis
 | categoryField : String Specifies the field of the data provider containing the text for the labels. | CategoryAxis
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | AxisBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dataProvider : Object Specifies the data source containing the label names. | CategoryAxis
Inherited | displayName : String The name of the axis. | AxisBase
 | labelFunction : Function Specifies a function that defines the labels that are generated for each item in the categoryAxis dataProvider. | CategoryAxis
 | padding : Number Specifies the padding added to either side of the axis when rendering data on the screen. | CategoryAxis
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | ticksBetweenLabels : Boolean Specifies the location of major tick marks on the axis, relative to the category labels. | CategoryAxis
Inherited | title : String The text for the title displayed along the axis. | AxisBase
Inherited | unitSize : Number The size of one unit of data as represented by this axis. | AxisBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CategoryAxis()
Constructor.
CategoryAxis
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dataChanged():void
Triggers events that inform the range object when the chart data has changed.
AxisBase
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
filterCache(cache:Array, field:String, filteredString:String):void
Filters a set of values of arbitrary type to a set of numbers that can be mapped.
CategoryAxis
formatForScreen(value:Object):String
Formats values for display in DataTips.
CategoryAxis
getLabelEstimate():AxisLabelSet
Determines the range to estimate what the axis labels should be.
CategoryAxis
getLabels(minimumAxisLength:Number):AxisLabelSet
Gets the labels text that is rendered.
CategoryAxis
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
invertTransform(value:Number):Object
Maps a position along the axis back to a numeric data value.
CategoryAxis
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void
Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
CategoryAxis
preferDropLabels():Boolean
Determines how the axis handles overlapping labels.
CategoryAxis
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet
Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
CategoryAxis
Inherited
registerDataTransform(transform:DataTransform, dimensionName:String):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
transformCache(cache:Array, field:String, convertedField:String):void
Maps a set of values from data space to screen space.
CategoryAxis
Inherited
unregisterDataTransform(transform:DataTransform):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
update():void
Updates the chart.
CategoryAxis
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | describeData(dimension:String, requiredFields:uint):Array Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. | AxisBase
Property detail
baseline property
baseline:Number [read-only]

The baseline position for the axis. Some series, such as ColumnSeries or AreaSeries, use this value to define the base of a filled region when no minimum value is specified.

Implementation
    public function get baseline():Number
categoryField property
categoryField:String [read-write]

Specifies the field of the data provider containing the text for the labels. If this property is null, CategoryAxis assumes that the dataProvider contains an array of Strings.

The default value is null.

Implementation
    public function get categoryField():String
    public function set categoryField(value:String):void
dataProvider property
dataProvider:Object [read-write]

Specifies the data source containing the label names. The dataProvider can be an Array of Strings, an Array of Objects, or any object that implements the IList or ICollectionView interface. If the dataProvider is an Array of Strings, ensure that the categoryField property is set to null. If the dataProvider is an Array of Objects, set the categoryField property to the name of the field that contains the label text.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
labelFunction property
labelFunction:Function [read-write]

Specifies a function that defines the labels that are generated for each item in the categoryAxis dataProvider. If no labelFunction is provided, the axis labels default to the value of the category itself.

The labelFunction for a CategoryAxis must have the following signature:

labelFunction(categoryValue:Object, previousCategoryValue:Object, axis:CategoryAxis, categoryItem:Object);

where:

categoryValue is the value of the category to be represented.

previousCategoryValue is the value of the previous category on the axis.

axis is the CategoryAxis being rendered.

categoryItem is the item from the dataProvider that is being represented.

If the CategoryAxis.categoryField is not set, the value will be the same as the categoryValue property.

Implementation
    public function get labelFunction():Function
    public function set labelFunction(value:Function):void
padding property
padding:Number [read-write]

Specifies the padding added to either side of the axis when rendering data on the screen. Set to 0 to map the first category to the very beginning of the axis and the last category to the end. Set to 0.5 to leave padding of half the width of a category on the axis between the beginning of the axis and the first category and between the last category and the end of the axis.

This is useful for chart types that render beyond the bounds of the category, such as columns and bars. However, when used as the horizontalAxis in a LineChart or AreaChart, it is reset to 0.

The default value is 0.5.

Implementation
    public function get padding():Number
    public function set padding(value:Number):void
ticksBetweenLabels property
ticksBetweenLabels:Boolean [read-write]

Specifies the location of major tick marks on the axis, relative to the category labels. If true, tick marks (and any associated grid lines) appear between the categories. If false, tick marks appear in the middle of the category, aligned with the label.

Implementation
    public function get ticksBetweenLabels():Boolean
    public function set ticksBetweenLabels(value:Boolean):void
Constructor detail
CategoryAxis () constructor
public function CategoryAxis()

Constructor.

Method detail
filterCache () method
public function filterCache(cache:Array, field:String, filteredString:String):void

Filters a set of values of arbitrary type to a set of numbers that can be mapped.

Parameters
cache:Array — An Array of objects where converted values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-filtered values.
filteredString:String — The field of the objects in the cache Array where filtered values should be stored.
formatForScreen () method
public function formatForScreen(value:Object):String

Formats values for display in DataTips. Returns a user-readable string.

Parameters
value:Object — The value to convert to a String.

Returns
String — The text of the DataTip.
getLabelEstimate () method
public function getLabelEstimate():AxisLabelSet

Determines the range to estimate what the axis labels should be. The axis almost immediately calls the getLabels() method to get the real values. The axis uses the estimated values to adjust chart margins, so any difference between the estimated labels and actual labels (returned from the getLabels() method) results in scaling the labels to fit.

An axis need only return the minimum and maximum labels when returning an estimate. If the label set is fairly static, without depending on the size of the axis being rendered on screen, an axis can return the entire label set from this function, and mark the estimate as accurate.

Returns
AxisLabelSet — An Array of AxisLabel objects.
getLabels () method
public function getLabels(minimumAxisLength:Number):AxisLabelSet

Gets the labels text that is rendered. When Flex calls this method, the axis has already determined the minimum length of the label.

Parameters
minimumAxisLength:Number — The minimum length of the axis, in pixels. The axis can be longer than this value, but not shorter.

Returns
AxisLabelSet — An array of AxisLabel objects.
invertTransform () method
public function invertTransform(value:Number):Object

Maps a position along the axis back to a numeric data value.

Parameters
value:Number — The bound of the axis. This parameter should be between 0 and 1, with 0 representing the minimum bound of the axis, and 1 the maximum.

Returns
Object
mapCache () method
public function mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void

Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.

Parameters
cache:Array — An Array of objects where converted values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-converted values.
convertedField:String — The field of the objects in the cache Array where converted values should be stored.
indexValues:Boolean (default = false) — This parameter is true if the values being mapped are index values, and false if they are natural data values.
preferDropLabels () method
public function preferDropLabels():Boolean

Determines how the axis handles overlapping labels. Typically, numeric ranges return true, while discrete value-based ranges do not. You can can override this property by setting it directly on the axis.

Returns
Boolean — true if labels can be dropped without loss of data; otherwise, false.
reduceLabels () method
public function reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet

Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels. The method is passed the two labels that are overlapping.

Parameters
intervalStart:AxisLabel — The start of the interval where labels overlap.
intervalEnd:AxisLabel — The end of the interval where labels overlap.

Returns
AxisLabelSet — A new label set that resolves the overlap by reducing the number of labels.
transformCache () method
public function transformCache(cache:Array, field:String, convertedField:String):void

Maps a set of values from data space to screen space.

Parameters
cache:Array — An Array of objects where mapped values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-mapped values.
convertedField:String — The field of the objects in the cache Array where mapped values should be stored.
update () method
public function update():void

Updates the chart. This can be called multiple times per frame.

Examples
HLOCChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HLOCChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var stockDataAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.55,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 40.15,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
        ]]>
    </mx:Script>

    <mx:Panel title="HLOCChart Control Example" height="100%" width="100%">

        <mx:HLOCChart id="hlocchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{stockDataAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:HLOCSeries openField="Open" highField="High"
                    lowField="Low" closeField="Close"/>
            </mx:series>
        </mx:HLOCChart>

    </mx:Panel>
</mx:Application>


mx.charts.ChartItem (Flex™ 2 Language Reference)

Class ChartItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class ChartItem
Inheritance | ChartItem Inheritance EventDispatcher Inheritance Object
Subclasses | AreaSeriesItem, BarSeriesItem, BubbleSeriesItem, ColumnSeriesItem, HLOCSeriesItem, LineSeriesItem, PieSeriesItem, PlotSeriesItem

A ChartItem represents a single item in a ChartSeries. In most standard series, there is one ChartItem created for each item in the series' dataProvider collection. ChartItems are passed to the instances of a series' itemRenderer for rendering. Most Series types extend ChartItem to contain additional information specific to the chart type.

See also

Skinning ChartItem objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | element : IChartElement The series or element that owns the ChartItem. | ChartItem
 | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
 | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
 | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ChartItem(element:IChartElement = null, item:Object = null, index:uint = 0)
Constructor.
ChartItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
element property
public var element:IChartElement

The series or element that owns the ChartItem.

index property
public var index:int

The index of the data from the series' dataProvider that the ChartItem represents.

item property
public var item:Object

The item from the series' dataProvider that the ChartItem represents.

itemRenderer property
public var itemRenderer:IFlexDisplayObject

The instance of the chart's itemRenderer that represents this ChartItem.

Constructor detail
ChartItem () constructor
public function ChartItem(element:IChartElement = null, item:Object = null, index:uint = 0)

Constructor.

Parameters
element:IChartElement (default = null) — The series or element that owns the ChartItem.
item:Object (default = null) — The item from the series' dataProvider that the ChartItem represents.
index:uint (default = 0) — The index of the data from the series' dataProvider that the ChartItem represents.
Method detail
clone () method
public function clone():ChartItem

Returns a copy of this ChartItem.

Returns
ChartItem


mx.charts.ColumnChart (Flex™ 2 Language Reference)

Class ColumnChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class ColumnChart
Inheritance | ColumnChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The ColumnChart control represents data as a series of vertical columns whose height is determined by values in the data. You can use the ColumnChart to represent a variety of different charts including simple columns, clustered columns, stacked, 100% stacked, and high/low.

A ColumnChart control expects its series property to contain an array of ColumnSeries objects.

Stacked and 100% column charts override the minField property of their ColumnSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ColumnChart> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:ColumnChart
    Properties
    type="clustered|overlaid|stacked|100%"

    Styles
    columnWidthRatio=".65"
    maxColumnWidth="No default"
  />

View the examples.

See also

mx.charts.series.ColumnSeries
Using the charting controls
Using column charts
Applying chart styles
Stacking charts
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
 | type : String The type of the column chart. | ColumnChart
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ColumnChart()
Constructor.
ColumnChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
 | columnWidthRatio | Type: Number CSS Inheritance: no Specifies a ratio of wide to draw the columns relative to the category width, as a percentage in the range of 0 to 1. A value of 1 uses the entire space, while a value of 0.6 uses 60% of the column's available space. The actual column width used is the smaller of the columnWidthRatio property and the maxColumnWidth property. Clustered columns divide this space proportionally among the columns in each cluster. The default value is 0.65. | ColumnChart
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | maxColumnWidth | Type: Number Format: Length CSS Inheritance: no Specifies how wide to draw the columns, in pixels. The actual column width used is the smaller of this property and the columnWidthRatio property. Clustered columns divide this space proportionally among the columns in each cluster. | ColumnChart
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
type property
type:String [read-write]

The type of the column chart.

Possible values are:

  • "clustered": Values from different series are grouped by category. This is the default type.
  • "overlaid": Multiple values are rendered on top of one another by category, with the last series on top.
  • "stacked": Columns are stacked on top of each other and grouped by category. Each column represents the cumulative value of the columns beneath it.
  • "100%": Columns are stacked on top of each other, adding up to 100%. Each column represents the percent that it contributes to the sum of the values for that category.
Implementation
    public function get type():String
    public function set type(value:String):void
Constructor detail
ColumnChart () constructor
public function ColumnChart()

Constructor.

Examples
Column_BarChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ColumnChart and BarChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var medalsAC:ArrayCollection = new ArrayCollection( [
            { Country: "USA", Gold: 35, Silver:39, Bronze: 29 },
            { Country: "China", Gold: 32, Silver:17, Bronze: 14 },
            { Country: "Russia", Gold: 27, Silver:27, Bronze: 38 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="ColumnChart and BarChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:ColumnChart id="column" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:ColumnSeries xField="Country" yField="Gold" displayName="Gold"/>
                <mx:ColumnSeries xField="Country" yField="Silver" displayName="Silver"/>
                <mx:ColumnSeries xField="Country" yField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:ColumnChart>

        <mx:Legend dataProvider="{column}"/>

         <mx:BarChart id="bar" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:verticalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:verticalAxis>

            <mx:series>
                <mx:BarSeries yField="Country" xField="Gold" displayName="Gold"/>
                <mx:BarSeries yField="Country" xField="Silver" displayName="Silver"/>
                <mx:BarSeries yField="Country" xField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:BarChart>

        <mx:Legend dataProvider="{bar}"/>

    </mx:Panel>
</mx:Application>


mx.charts.DateTimeAxis (Flex™ 2 Language Reference)

Class DateTimeAxis | Properties | Methods | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class DateTimeAxis
Inheritance | DateTimeAxis Inheritance NumericAxis Inheritance AxisBase Inheritance EventDispatcher Inheritance Object

The DateTimeAxis class maps time values evenly between a minimum and maximum value along a chart axis. It can plot values represented either as instances of the Date class, as numeric values representing the number of milliseconds since the epoch (midnight on January 1, 1970, GMT), or as String values when you provide a custom parsing function.

The DateTimeAxis chooses the most reasonable units to mark the axis by examining the range between the minimum and maximum values of the axis. The Axis chooses the largest unit that generates a reasonable number of labels for the given range. You can restrict the set of units the chart considers, or specify exactly which units it should use, by setting the labelUnits property.

You can specifiy the minimum and maximum values explicitly, or let the axis automatically determine them by examining the values being renderered in the chart. By default, the DateTimeAxis chooses the smallest possible range to contain all the values represented in the chart. Optionally, you can request that the minimum and maximum values be rounded to whole units (milliseconds, seconds, minutes, hours, days, weeks, months, years) by setting the autoAdjust property to true.

View the examples.

See also

mx.charts.chartClasses.IAxis
Working with axes
About the NumericAxis class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alignLabelsToUnits : Boolean Determines the placement of labels along the axis. | DateTimeAxis
Inherited | autoAdjust : Boolean Specifies whether Flex rounds values. | NumericAxis
Inherited | baseAtZero : Boolean = true Specifies whether Flex tries to keep the minimum and maximum values rooted at zero. | NumericAxis
Inherited | baseline : Number The computed minimum value for the axis as long as this value is greater than 0. | NumericAxis
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | AxisBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dataInterval : Number [write-only] Specifies the interval between data in your chart, specified in dataUnits. | DateTimeAxis
 | dataUnits : String Specifies the units that you expect the data in your chart to represent. | DateTimeAxis
 | displayLocalTime : Boolean When set to true, a DateTimeAxis considers all date values to be in the time zone of the client machine running the application. | DateTimeAxis
Inherited | displayName : String The name of the axis. | AxisBase
 | interval : Number Specifies the number of labelUnits between label values along the axis. | DateTimeAxis
Inherited | labelFunction : Function Called to format axis values for display as labels. | NumericAxis
 | labelUnits : String The units that the axis uses to generate labels. | DateTimeAxis
 | maximum : Date Specifies the maximum value for an axis label. | DateTimeAxis
 | minimum : Date Specifies the minimum value for an axis label. | DateTimeAxis
 | minorTickInterval : Number Specifies the number of minorTickUnits between minor tick marks along the axis. | DateTimeAxis
Inherited | minorTicks : Array An Array of minor tick marks generated to represent this axis. | NumericAxis
 | minorTickUnits : String The units that the Axis considers when generating minor tick marks. | DateTimeAxis
Inherited | padding : Number Specifies padding that Flex adds to the calculated minimum and maximum values for the axis when rendering the values on the screen. | NumericAxis
 | parseFunction : Function [write-only] Specifies a method that customizes the value of the data points. | DateTimeAxis
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | title : String The text for the title displayed along the axis. | AxisBase
 | unitSize : Number [read-only] The width, in pixels, of a single data unit. | DateTimeAxis
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | assignedMaximum : Number The explicitly assigned maximum value. | NumericAxis
Inherited | assignedMinimum : Number The explicitly assigned minimum value. | NumericAxis
Inherited | computedInterval : Number The computed interval represented by this axis. | NumericAxis
Inherited | computedMaximum : Number The computed maximum value represented by this axis. | NumericAxis
Inherited | computedMinimum : Number The computed minimum value represented by this axis. | NumericAxis
Inherited | dataDescriptions : Array An Array of DataDescription structures describing the data being represented by the chart. | NumericAxis
Inherited | labelCache : Array The most recent set of AxisLabel objects generated to represent this axis. | NumericAxis
Inherited | labelMaximum : Number The maximum value where a label should be placed. | NumericAxis
Inherited | labelMinimum : Number The minimum value where a label should be placed. | NumericAxis
Inherited | minorTickCache : Array The most recent set of minor tick marks generated to represent this axis. | NumericAxis
 | requiredDescribedFields : uint [read-only] The fields of the DescribeData structure that this axis is interested in. | DateTimeAxis
Inherited | ticks : Array An Array of tick marks for this axis. | NumericAxis
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DateTimeAxis()
Constructor.
DateTimeAxis
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dataChanged():void
Triggers events that inform the range object when the chart data has changed.
AxisBase
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
filterCache(cache:Array, field:String, filteredString:String):void
Filters a set of values of arbitrary type to a set of numbers that can be mapped.
NumericAxis
Inherited
formatForScreen(value:Object):String
Formats values for display in DataTips.
NumericAxis
Inherited
getLabelEstimate():AxisLabelSet
Determines the range to estimate what the axis labels should be.
NumericAxis
Inherited
getLabels(minimumAxisLength:Number):AxisLabelSet
Gets the labels text that is rendered.
NumericAxis
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
invertTransform(value:Number):Object
Maps a position along the axis back to a numeric data value.
NumericAxis
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void
Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
NumericAxis
Inherited
preferDropLabels():Boolean
Determines how the axis handles overlapping labels.
NumericAxis
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet
Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
DateTimeAxis
Inherited
registerDataTransform(transform:DataTransform, dimensionName:String):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
transformCache(cache:Array, field:String, convertedField:String):void
Maps a set of values from data space to screen space.
NumericAxis
Inherited
unregisterDataTransform(transform:DataTransform):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
update():void
Updates the chart.
NumericAxis
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustMinMax(minValue:Number, maxValue:Number):void Adjusts the generated or assigned range of the axis's labels. | NumericAxis
Inherited | buildLabelCache():Boolean Populates the labelCache property with labels representing the current values of the axis. | NumericAxis
 | buildMinorTickCache():Array Builds an Array of positions for the minor tick marks Array that is generated by this axis. | DateTimeAxis
Inherited | describeData(dimension:String, requiredFields:uint):Array Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. | AxisBase
 | formatDays(d:Date, previousValue:Date, axis:DateTimeAxis):String The default formatting function used when the axis renders with day-based labelUnits. | DateTimeAxis
 | formatMilliseconds(d:Date, previousValue:Date, axis:DateTimeAxis):String The default formatting function used when the axis renders with millisecond-based labelUnits. | DateTimeAxis
 | formatMinutes(d:Date, previousValue:Date, axis:DateTimeAxis):String The default formatting function used when the axis renders with minute-based labelUnits. | DateTimeAxis
 | formatMonths(d:Date, previousValue:Date, axis:DateTimeAxis):String The default formatting function used when the axis renders with month-based labelUnits. | DateTimeAxis
 | formatSeconds(d:Date, previousValue:Date, axis:DateTimeAxis):String The default formatting function used when the axis renders with second-based labelUnits. | DateTimeAxis
 | formatYears(d:Date, previousValue:Date, axis:DateTimeAxis):String The default formatting function used when the axis renders with year-based labelUnits. | DateTimeAxis
Inherited | guardMinMax(min:Number, max:Number):Array Protects the range against invalid values for this axis type. | NumericAxis
Inherited | invalidateCache():void Invalidates the cached labels and tick marks that represent this axis's values. | NumericAxis
Property detail
alignLabelsToUnits property
alignLabelsToUnits:Boolean [read-write]

Determines the placement of labels along the axis.

When false, the chart always puts a label at the beginning of the axis. For example, if your labels are every month and your first datapoint is July 14th, your first label will be on July 14th. When true, Flex first calculates the label units, then labels the first whole interval of those units. For example, if your first data point was July 14th, and your label units was months (set explicitly or dynamically calculated), the first label will be on August 1st.

The default value is true.

Implementation
    public function get alignLabelsToUnits():Boolean
    public function set alignLabelsToUnits(value:Boolean):void
dataInterval property
dataInterval:Number [write-only]

Specifies the interval between data in your chart, specified in dataUnits.

If, for example, the dataUnits property is set to "hours", and dataInterval property is set to 4, the chart assumes your data occurs every four hours. This affects how some series (such as ColumnSeries and CandlestickSeries) render their data. It also affects how labels are automatically chosen.

Implementation
    public function set dataInterval(value:Number):void

See also

dataUnits
dataUnits property
dataUnits:String [read-write]

Specifies the units that you expect the data in your chart to represent. The value can be one of the following:

  • milliseconds
  • seconds
  • minutes
  • hours
  • days
  • weeks
  • months
  • years

This value is used in two ways. First, when choosing appropriate label units, a DateTimeAxis does not choose any unit smaller than the units represented by the data. If the value of the dataUnits property is days, the chart would not render labels for every hour, no matter what the minmium/maximum range is.

Secondly, the value of the dataUnits property is used by some series to affect their rendering. Specifically, most columnar series (such as ColumnSeries, BarSeries, CandlestickSeries, and HLOCSeries) use the value of the dataUnits property to determine how wide to render their columns.

If, for example, your ColumnChart control's horizontal axis had its labelUnits property set to weeks and its dataUnits property set to days, the ColumnChart renders each column at 1/7th the distance between labels.

When the dataUnits property is set to null, columnar series render their columns as days, but the DateTimeAxis chooses an appropriate unit when it generates the labels.

The default value is null.

Implementation
    public function get dataUnits():String
    public function set dataUnits(value:String):void
displayLocalTime property
displayLocalTime:Boolean [read-write]

When set to true, a DateTimeAxis considers all date values to be in the time zone of the client machine running the application. If false, all values are in Universal Time (Greenwich Mean Time).

Implementation
    public function get displayLocalTime():Boolean
    public function set displayLocalTime(value:Boolean):void
interval property
interval:Number [read-write]

Specifies the number of labelUnits between label values along the axis. Flex calculates the interval if this property is set to null.

The default value is null.

Implementation
    public function get interval():Number
    public function set interval(value:Number):void
labelUnits property
labelUnits:String [read-write]

The units that the axis uses to generate labels. By default, a DateTimeAxis considers all valid units (milliseconds, seconds, minutes, hours, days, weeks, months, or years).

If the labelUnits property is not set, the chart does not use any unit smaller than the value of the dataUnits property to render labels.

Implementation
    public function get labelUnits():String
    public function set labelUnits(value:String):void
maximum property
maximum:Date [read-write]

Specifies the maximum value for an axis label. If null, Flex determines the minimum value from the data in the chart.

The default value is null.

Implementation
    public function get maximum():Date
    public function set maximum(value:Date):void
minimum property
minimum:Date [read-write]

Specifies the minimum value for an axis label. If null, Flex determines the minimum value from the data in the chart.

The default value is null.

Implementation
    public function get minimum():Date
    public function set minimum(value:Date):void
minorTickInterval property
minorTickInterval:Number [read-write]

Specifies the number of minorTickUnits between minor tick marks along the axis. If this is set to NaN, the DateTimeAxis calculates it automatically.

Normally the minorTickInterval property is automatically set to 1. If, however, the minorTickUnits property is the same units as the dataUnits property (either set explicitly or implicitly calculated), then the minorTickInterval property is the maximum of 1, or dataInterval.

Implementation
    public function get minorTickInterval():Number
    public function set minorTickInterval(value:Number):void
minorTickUnits property
minorTickUnits:String [read-write]

The units that the Axis considers when generating minor tick marks. By default, a DateTimeAxis considers all valid units (milliseconds, seconds, minutes, hours, days, weeks, months, or years).

If this property is not set, the chart determines the value of the minorTickUnits property. If the label interval is greater than 1, the minorTickUnits property is set to the value of the labelUnits property, and the minorTickInterval property is set to 1. If the label interval is 1, the minorTickUnits property is set to the next smaller unit from the labelUnits property. If set, the minorTickUnits property can never be smaller than the value of the dataUnits property.

Implementation
    public function get minorTickUnits():String
    public function set minorTickUnits(value:String):void
parseFunction property
parseFunction:Function [write-only]

Specifies a method that customizes the value of the data points. With this property, you specify a method that accepts a value and returns a Date object. The Date object is then used in the DateTimeAxis object of the chart. This lets you provide customizable date input strings and convert them to Date objects, which Flex can then interpret for use in the DateTimeAxis.

Flex passes only one parameter to the parsing method. This parameter is the value of the data point you specified for the series. Typically, it is a String that represents some form of a date. You cannot override this parameter or add additional parameters.

This Date object is immediately converted to a numeric value, so custom parseFunctions can reuse the same Date object for performance reasons. By default, the DateTimeAxis uses the string parsing functionality in the ECMA standard Date.parse() method.

The following example uses a data provider that defines a data object in the format { yyyy, mm, dd }. The method specified by the parseFunction uses these values to create a Date object that the axis can use.
   <mx:Script>
    import mx.collections.ArrayCollection;
    [Bindable]
    public var aapl:ArrayCollection = new ArrayCollection([
     {date: "2005, 8, 1", close: 42.71},
     {date: "2005, 8, 2", close: 42.99},
     {date: "2005, 8, 3", close: 44}
    ]);

    public function myParseFunction(s:String):Date {
     // Get an array of Strings from the comma-separated String passed in.
     var a:Array = s.split(",");

     // Create the new Date object. Note that the month argument is 0-based (with 0 being January).
     var newDate:Date = new Date(a[0],a[1]-1,a[2]);
     return newDate;
    }
   </mx:Script>
   <mx:LineChart id="mychart" dataProvider="{aapl}" showDataTips="true">
    <mx:horizontalAxis>
     <mx:DateTimeAxis dataUnits="days" parseFunction="myParseFunction"/>
    </mx:horizontalAxis>
    <mx:series>
     <mx:LineSeries yField="close" xField="date" displayName="AAPL"/>
    </mx:series>
   </mx:LineChart>
Implementation
    public function set parseFunction(value:Function):void
requiredDescribedFields property
requiredDescribedFields:uint [read-only]

The fields of the DescribeData structure that this axis is interested in.

Implementation
    protected function get requiredDescribedFields():uint
unitSize property
unitSize:Number [read-only]

The width, in pixels, of a single data unit. The type of a data unit is determined by the value of the dataUnits property.

Implementation
    public function get unitSize():Number
Constructor detail
DateTimeAxis () constructor
public function DateTimeAxis()

Constructor.

Method detail
buildMinorTickCache () method
protected override function buildMinorTickCache():Array

Builds an Array of positions for the minor tick marks Array that is generated by this axis. Subclasses must implement this function. This function is called automatically by the NumericAxis. You should access the minorTicks property instead of calling this function directly.

Returns
Array — An Array of positions from 0 to 1 that represent points between the axis minimum and maximum values where minor tick marks are rendered.
formatDays () method
protected function formatDays(d:Date, previousValue:Date, axis:DateTimeAxis):String

The default formatting function used when the axis renders with day-based labelUnits. If you write a custom DateTimeAxis class, you can override this method to provide alternate default formatting.

You do not call this method directly. Instead, Flex calls this method before it renders the label to get the appropriate String to display.

Parameters
d:Date — The Date object that contains the unit to format.
previousValue:Date — The Date object that contains the data point that occurs prior to the current data point.
axis:DateTimeAxis — The DateTimeAxis on which the label is rendered.

Returns
String — The formatted label.
formatMilliseconds () method
protected function formatMilliseconds(d:Date, previousValue:Date, axis:DateTimeAxis):String

The default formatting function used when the axis renders with millisecond-based labelUnits. If you write a custom DateTimeAxis class, you can override this method to provide alternate default formatting.

You do not call this method directly. Instead, Flex calls this method before it renders the label to get the appropriate String to display.

Parameters
d:Date — The Date object that contains the unit to format.
previousValue:Date — The Date object that contains the data point that occurs prior to the current data point.
axis:DateTimeAxis — The DateTimeAxis on which the label is rendered.

Returns
String — The formatted label.
formatMinutes () method
protected function formatMinutes(d:Date, previousValue:Date, axis:DateTimeAxis):String

The default formatting function used when the axis renders with minute-based labelUnits. If you write a custom DateTimeAxis class, you can override this method to provide alternate default formatting.

You do not call this method directly. Instead, Flex calls this method before it renders the label to get the appropriate String to display.

Parameters
d:Date — The Date object that contains the unit to format.
previousValue:Date — The Date object that contains the data point that occurs prior to the current data point.
axis:DateTimeAxis — The DateTimeAxis on which the label is rendered.

Returns
String — The formatted label.
formatMonths () method
protected function formatMonths(d:Date, previousValue:Date, axis:DateTimeAxis):String

The default formatting function used when the axis renders with month-based labelUnits. If you write a custom DateTimeAxis class, you can override this method to provide alternate default formatting.

You do not call this method directly. Instead, Flex calls this method before it renders the label to get the appropriate String to display.

Parameters
d:Date — The Date object that contains the unit to format.
previousValue:Date — The Date object that contains the data point that occurs prior to the current data point.
axis:DateTimeAxis — The DateTimeAxis on which the label is rendered.

Returns
String — The formatted label.
formatSeconds () method
protected function formatSeconds(d:Date, previousValue:Date, axis:DateTimeAxis):String

The default formatting function used when the axis renders with second-based labelUnits. If you write a custom DateTimeAxis class, you can override this method to provide alternate default formatting.

You do not call this method directly. Instead, Flex calls this method before it renders the label to get the appropriate String to display.

Parameters
d:Date — The Date object that contains the unit to format.
previousValue:Date — The Date object that contains the data point that occurs prior to the current data point.
axis:DateTimeAxis — The DateTimeAxis on which the label is rendered.

Returns
String — The formatted label.
formatYears () method
protected function formatYears(d:Date, previousValue:Date, axis:DateTimeAxis):String

The default formatting function used when the axis renders with year-based labelUnits. If you write a custom DateTimeAxis class, you can override this method to provide alternate default formatting.

You do not call this method directly. Instead, Flex calls this method before it renders the label to get the appropriate String to display.

Parameters
d:Date — The Date object that contains the unit to format.
previousValue:Date — The Date object that contains the data point that occurs prior to the current data point.
axis:DateTimeAxis — The DateTimeAxis on which the label is rendered.

Returns
String — The formatted label.
reduceLabels () method
public override function reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet

Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels. The method is passed the two labels that are overlapping.

Parameters
intervalStart:AxisLabel — The start of the interval where labels overlap.
intervalEnd:AxisLabel — The end of the interval where labels overlap.

Returns
AxisLabelSet — A new label set that resolves the overlap by reducing the number of labels.
Examples
DateTimeAxisExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the DateTimeAxis class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.collections.ArrayCollection;

            [Bindable]
            public var stockDataAC:ArrayCollection = new ArrayCollection( [
                {date: "2005, 7, 27", close: 41.71},
                {date: "2005, 7, 28", close: 42.21},
                {date: "2005, 7, 29", close: 42.11},
                {date: "2005, 8, 1", close: 42.71},
                {date: "2005, 8, 2", close: 42.99},
                {date: "2005, 8, 3", close: 44} ]);

            public function myParseFunction(s:String):Date {
                // Get an array of Strings from the comma-separated String passed in.
                var a:Array = s.split(",");
                // Create the new Date object.
                var newDate:Date = new Date(a[0],a[1],a[2]);
                return newDate;
            }
        ]]>
    </mx:Script>

    <mx:Panel title="DateTimeAxis Example" height="100%" width="100%">

        <mx:LineChart id="mychart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{stockDataAC}">

            <mx:horizontalAxis>
                <mx:DateTimeAxis dataUnits="days" parseFunction="myParseFunction"/>
            </mx:horizontalAxis>

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:series>
                <mx:LineSeries yField="close" xField="date" displayName="AAPL"/>
            </mx:series>
        </mx:LineChart>

    </mx:Panel>
</mx:Application>


mx.charts.GridLines (Flex™ 2 Language Reference)

Class GridLines | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class GridLines
Inheritance | GridLines Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The GridLines class draws grid lines inside the data area of the chart. Flex can draw lines horizontally, vertically, or both.

Flex draws grid lines aligned to the tick marks of the parent chart. By default, Flex draws one line for every tick mark along the appropriate axis.

You typically use the GridLines class as a child tag of a chart control's backgroundElements property or annotationElements property.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:GridLines> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:GridLines
    Styles
     direction="horizontal|vertical|both"
     horizontalAlternateFill="null"
     horizontalChangeCount="1"
     horizontalFill="null"
     horizontalOriginStroke="IStroke; No default"
     horizontalShowOrigin="Default depends on type of chart"
     horizontalStroke="IStroke; No default"
     horizontalTickAligned="true|false"
     verticalAlternateFill="null"
     verticalChangeCount="1"
     verticalFill="null"
     verticalOriginStroke="IStroke; No default"
     verticalShowOrigin="Default depends on type of chart"
     verticalStroke="IStroke; No default"
     verticalTickAligned="true|false"
  />

View the examples.

See also

Adding grid lines

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | ChartElement
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
GridLines()
Constructor.
GridLines
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
ChartElement
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | createDataID(dataPointID:Number):Number Creates a unique id to represent the a dataPoint for comparison purposes. | ChartElement
Inherited | dataChanged():void Indicates the underlying data represented by the element has changed. | ChartElement
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | processNewDataProvider(value:Object):void Called when a new dataProvider is assigned to the element. | ChartElement
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | direction | Type: String CSS Inheritance: no Specifies the direction of the grid lines. Allowable values are horizontal, vertical, or both. The default value is horizontal. | GridLines
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
 | horizontalAlternateFill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill pattern for alternating horizontal bands not defined by the fill property. Use the IFill class to define the properties of the fill as a child tag in MXML, or create an IFill object in ActionScript. Set to null to not fill the bands. The default value is null. | GridLines
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalChangeCount | Type: int CSS Inheritance: no Specifies the number of tick marks between horizontal grid lines. Set the horizontalChangeCount property to 3 to draw a grid line at every third tick mark along the axis. The fill style alternates at each grid line, so a larger horizontalChangeCount value results in large alternating bands. The defaults value is 1. | GridLines
 | horizontalFill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill pattern for every other horizontal band created by the grid lines. Use the IFill class to define the properties of the fill as a child tag in MXML, or create a IFill object in ActionScript. Set to null to not fill the bands. The default value is null. | GridLines
 | horizontalOriginStroke | Type: mx.graphics.IStroke CSS Inheritance: no Specifies the line style for the horizontal origin. Use the Stroke class to define the properties as a child tag in MXML, or create a Stroke object in ActionScript. | GridLines
 | horizontalShowOrigin | Type: Boolean CSS Inheritance: no Determines whether to draw the horizontal origin. If true, and the origin falls within the chart bounds, the grid lines draw it using the originStroke style. For ColumnChart, LineChart, PlotChart, BubbleChart, and AreaChart controls, the default value is true. For BarChart controls, the default value is false. This property does not apply to PieChart controls. | GridLines
 | horizontalStroke | Type: mx.graphics.IStroke CSS Inheritance: no Specifies the line style for horizontal grid lines. Use the Stroke class to define the properties as a child tag in MXML, or create a Stroke object in ActionScript. | GridLines
 | horizontalTickAligned | Type: Boolean CSS Inheritance: no Determines whether to align horizontal grid lines with tick marks. If true, horizontal grid lines are drawn aligned with the tick marks. If false, Flex draws them between tick marks. The default value is true. | GridLines
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlternateFill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill pattern for alternating vertical bands not defined by the fill property. Use the IFill class to define the properties of the fill as a child tag in MXML, or create an IFill object in ActionScript. Set to null to not fill the bands. The default value is null. | GridLines
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalChangeCount | Type: int CSS Inheritance: no Specifies the number of tick marks between vertical grid lines. Set verticalChangeCount to 3 to draw a grid line at every third tick mark along the axis. The fill style alternates at each grid line, so a larger verticalChangeCount value results in large alternating bands. The default value is 1. | GridLines
 | verticalFill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill pattern for alternating vertical bands created by the grid lines. Use the IFill class to define the properties of the fill as a child tag in MXML, or create a IFill object in ActionScript. Set to null to not fill the bands. The default value is null. | GridLines
 | verticalOriginStroke | Type: mx.graphics.IStroke CSS Inheritance: no Specifies the line style for the vertical origin. Use the Stroke class to define the properties as a child tag in MXML, or create a Stroke object in ActionScript. | GridLines
 | verticalShowOrigin | Type: Boolean CSS Inheritance: no Determines whether to draw the vertical Origin. If true, and the origin falls within the chart bounds, Flex draws it using the originStroke style. For ColumnChart, LineChart, and AreaChart controls, the default value is false. For PlotChart, BubbleChart, and BarChart controls, the default value is true. This property does not apply to PieChart controls. | GridLines
 | verticalStroke | Type: mx.graphics.IStroke CSS Inheritance: no Specifies the line style for vertical grid lines. Use the Stroke class to define the properties as a child tag in MXML, or create a Stroke object in ActionScript. | GridLines
 | verticalTickAligned | Type: Boolean CSS Inheritance: no Determines whether to align vertical grid lines with tick marks. If true, Flex draws vertical grid lines aligned with the tick marks. If false, Flex draws them between tick marks. The default value is true. | GridLines
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
GridLines () constructor
public function GridLines()

Constructor.

Examples
GridLinesExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the GridLines class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="GridLines Example" height="100%" width="100%">

        <mx:LineChart id="linechart" height="100%" width="100%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:backgroundElements>
               <mx:GridLines direction="horizontal">
                    <mx:horizontalStroke>
                        <mx:Stroke weight="1"/>
                    </mx:horizontalStroke>
                    <mx:horizontalFill>
                        <mx:SolidColor color="0xCCCCCC" alpha=".66"/>
                    </mx:horizontalFill>
                </mx:GridLines>
            </mx:backgroundElements>

            <mx:series>
                <mx:LineSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:LineSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:LineSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:LineChart>

        <mx:Legend dataProvider="{linechart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.HitData (Flex™ 2 Language Reference)

Class HitData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class HitData
Inheritance | HitData Inheritance Object

The HitData class represents information about the data item at a specific location on the screen. Flex returns the HitData structure for mouse events on chart data points. It describes what data points are under the current mouse position.

You can also get a HitData structure describing the data point at a specific location in the chart using the chart control's findDataPoints() method.

See also

mx.charts.ChartItem
Using the HitData object
Getting data with coordinates
Changing mouse sensitivity

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | chartItem : ChartItem The chart item described by the hit data. | HitData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contextColor : uint = 0 An RGB value that can be used to associate an on-screen representation of the associated chartItem. | HitData
 | dataTipFunction : Function A function provided by the HitData creator to generate a user-suitable String for display on screen that describes the referenced item. | HitData
 | displayText : String [read-only] A description of the associated item for display on screen. | HitData
 | distance : Number Specifies the distance between the data item on the screen and the location of the mouse pointer, in pixels. | HitData
 | element : IChartElement [read-only] Specifies the chart element rendering this data item that generated the HitData structure. | HitData
 | id : Number Specifies a unique identifier representing the data point. | HitData
 | item : Object Specifies the data item that the HitData structure describes. | HitData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number Specifies the X coordinate of the data item on the screen. | HitData
 | y : Number Specifies the Y coordinate of the data item on the screen. | HitData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | HitData(id:Number, distance:Number, x:Number, y:Number, chartItem:ChartItem) Constructor. | HitData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
chartItem property
public var chartItem:ChartItem

The chart item described by the hit data. A chart item represents the data a series uses to describe an individual item from its dataProvider.

contextColor property
public var contextColor:uint = 0

An RGB value that can be used to associate an on-screen representation of the associated chartItem. DataTips use this field to help render their data.

dataTipFunction property
public var dataTipFunction:Function

A function provided by the HitData creator to generate a user-suitable String for display on screen that describes the referenced item.

displayText property
displayText:String [read-only]

A description of the associated item for display on screen.

Implementation
    public function get displayText():String
distance property
public var distance:Number

Specifies the distance between the data item on the screen and the location of the mouse pointer, in pixels.

element property
element:IChartElement [read-only]

Specifies the chart element rendering this data item that generated the HitData structure.

Implementation
    public function get element():IChartElement
id property
public var id:Number

Specifies a unique identifier representing the data point. You can use this identifier to test for equality between two HitData objects. If two different chart elements represent the same dataProvider entry, they will have two different identifiers.

item property
public var item:Object

Specifies the data item that the HitData structure describes.

x property
public var x:Number

Specifies the X coordinate of the data item on the screen.

y property
public var y:Number

Specifies the Y coordinate of the data item on the screen.

Constructor detail
HitData () constructor
public function HitData(id:Number, distance:Number, x:Number, y:Number, chartItem:ChartItem)

Constructor.

Parameters
id:Number — Specifies a unique identifier representing the data point.
distance:Number — Specifies the distance between the data item on the screen and the location of the mouse pointer, in pixels.
x:Number — Specifies the x coordinate of the data item on the screen.
y:Number — Specifies the y coordinate of the data item on the screen.
chartItem:ChartItem — The chart item described by the hit data.


mx.charts.HLOCChart (Flex™ 2 Language Reference)

Class HLOCChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class HLOCChart
Inheritance | HLOCChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The HLOCChart (High Low Open Close) control represents financial data as a series of elements representing the high, low, closing, and optionally opening values of a data series. The top and bottom of the vertical line in each element represent the high and low values for the datapoint. The right-facing tick represents the closing values, and the left tick represents the opening value if one was specified.

An HLOCChart control expects its series property to contain an Array of HLOCSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax
The <mx:HLOCChart> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:HLOCChart
    Styles
    columnWidthRatio=".65"
    maxColumnWidth="No default"
  />

View the examples.

See also

mx.charts.series.HLOCSeries
Using the charting controls
Using HighLowOpenClose charts
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HLOCChart()
Constructor.
HLOCChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
 | columnWidthRatio | Type: Number CSS Inheritance: no Specifies a ratio of how wide to draw the HLOC lines relative to the horizontal axis's category widths, as a percentage in the range of 0 to 1. A value of 1 uses the entire space, while a value of 0.6 uses 60% of the category's available space. The actual element width used is the smaller of the columnWidthRatio property and the maxColumnWidth property. Multiple element series divide this space proportionally. The default value is 0.65. | HLOCChart
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | maxColumnWidth | Type: Number Format: Length CSS Inheritance: no Specifies how wide to draw the HLOC lines, in pixels. The actual width used is the smaller of this property and the columnWidthRatio property. Multiple HLOC series divide this space proportionally. | HLOCChart
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
HLOCChart () constructor
public function HLOCChart()

Constructor.

Examples
HLOCChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HLOCChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var stockDataAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.55,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 40.15,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
        ]]>
    </mx:Script>

    <mx:Panel title="HLOCChart Control Example" height="100%" width="100%">

        <mx:HLOCChart id="hlocchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{stockDataAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:HLOCSeries openField="Open" highField="High"
                    lowField="Low" closeField="Close"/>
            </mx:series>
        </mx:HLOCChart>

    </mx:Panel>
</mx:Application>


mx.charts.Legend (Flex™ 2 Language Reference)

Class Legend | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class Legend
Inheritance | Legend Inheritance Tile Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Legend control adds a legend to your charts, where the legend displays the label for each data series in the chart and a key showing the chart element for the series.

You can initialize a Legend control by binding a chart control identifier to the Legend control's dataProvider property, or you can define an Array of LegendItem objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Legend> tag inherits all the propertie of its parent classes and adds the following properties:

  <mx:Legend
    Properties
    dataProvider="No default"
    legendItemClass="No default"

    Styles
    backgroundColor="undefined"
    borderStyle="inset|none|solid|outset"
    horizontalGap="8"
    labelPlacement="right|left|top|bottom"
    markerHeight="15"
    markerWidth="10"
    paddingLeft="0"
    paddingRight="0"
    stroke="IStroke; no default"
    verticalGap="6"

    Events
    itemClick="Event; no default"
    itemMouseDown="Event; no default"
    itemMouseOut="Event; no default"
    itemMouseOver="Event; no default"
    itemMouseUp="Event; no default"
  />

View the examples.

See also

mx.charts.LegendItem
Using Legend controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
 | dataProvider : Object Set of data to be used in the Legend. | Legend
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String Determines how children are placed in the container. | Tile
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | legendItemClass : Class The class used to instantiate LegendItem objects. | Legend
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Legend()
Constructor.
Legend
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
 | commitProperties():void Processes the properties set on the component. | Legend
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the preferred, minimum, and maximum sizes of the Legend. | Legend
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Legend. | Legend
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when the user clicks on a LegendItem in the Legend control. | Legend
 | itemMouseDown | Dispatched when the user presses the mouse button while over a LegendItem in the Legend control. | Legend
 | itemMouseOut | Dispatched when the user moves the mouse off of a LegendItem in the Legend. | Legend
 | itemMouseOver | Dispatched when the user moves the mouse over a LegendItem in the Legend control. | Legend
 | itemMouseUp | Dispatched when the user releases the mouse button while over a LegendItem in the Legend. | Legend
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
 | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of the component. You can either have a backgroundColor or a backgroundImage, but not both. Note that some components, like a Button, do not have a background because they are completely filled with the button face or other graphics. The DataGrid control also ignores this style. The default value is undefined. If both this style and the backgroundImage style are undefined, the control has a transparent background. | Legend
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
 | borderStyle | Type: String CSS Inheritance: no Bounding box style. The possible values are "none", "solid", "inset" and "outset". The default value is "inset" <p>Note: The <code>borderStyle</code> style is not supported by the Button control or the Panel container. To make solid border Panels, set the <code>borderThickness</code> property, and set the <code>dropShadow</code> property to <code>false</code> if desired.</p>. | Legend
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of each child inside its tile cell. | Tile
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | Legend
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
 | labelPlacement | Type: String CSS Inheritance: yes Specifies the label placement of the legend element. Valid values are "top", "bottom", "right", and "left". | Legend
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | markerHeight | Type: Number Format: Length CSS Inheritance: yes Specifies the height of the legend element. | Legend
 | markerWidth | Type: Number Format: Length CSS Inheritance: yes Specifies the width of the legend element. | Legend
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and its content area. | Tile
 | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. The default value for the Tree control is 2. | Legend
 | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. | Legend
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. | Tile
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
 | stroke | Type: Object CSS Inheritance: no Specifies the line stroke for the legend element. | Legend
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of each child inside its tile cell. | Tile
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | Legend
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dataProvider property
dataProvider:Object [read-write]

Set of data to be used in the Legend.

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
legendItemClass property
public var legendItemClass:Class

The class used to instantiate LegendItem objects. When a legend's content is derived from the chart or data, it instantiates one instance of legendItemClass for each item described by the dataProvider. If you want custom behavior in your legend items, you can assign a subclass of LegendItem to this property to have the Legend create instances of their derived type instead.

Constructor detail
Legend () constructor
public function Legend()

Constructor.

Method detail
commitProperties () method
protected override function commitProperties():void

Processes the properties set on the component.

measure () method
protected override function measure():void

Calculates the preferred, minimum, and maximum sizes of the Legend.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Sets the size and position of each child of the Legend. This is an advanced method for use in subclassing. If you override this method, your implementation should call the super.updateDisplayList() method.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Event detail
itemClick event
Event object type: mx.charts.events.LegendMouseEvent

Dispatched when the user clicks on a LegendItem in the Legend control.

itemMouseDown event
Event object type: mx.charts.events.LegendMouseEvent

Dispatched when the user presses the mouse button while over a LegendItem in the Legend control.

itemMouseOut event
Event object type: mx.charts.events.LegendMouseEvent

Dispatched when the user moves the mouse off of a LegendItem in the Legend.

itemMouseOver event
Event object type: mx.charts.events.LegendMouseEvent

Dispatched when the user moves the mouse over a LegendItem in the Legend control.

itemMouseUp event
Event object type: mx.charts.events.LegendMouseEvent

Dispatched when the user releases the mouse button while over a LegendItem in the Legend.

Examples
PlotChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the PlotChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="PlotChart Control Example" height="100%" width="100%">

        <mx:PlotChart id="plot" height="100%" width="100%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:series>
                <mx:PlotSeries xField="Expenses" yField="Profit" displayName="Expenses/Profit"/>
                <mx:PlotSeries xField="Amount" yField="Expenses" displayName="Amount/Expenses"/>
                <mx:PlotSeries xField="Profit" yField="Amount" displayName="Profit/Amount"/>
            </mx:series>
        </mx:PlotChart>

        <mx:Legend dataProvider="{plot}"/>

    </mx:Panel>
</mx:Application>


mx.charts.LegendItem (Flex™ 2 Language Reference)

Class LegendItem | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class LegendItem
Inheritance | LegendItem Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Controls the individual legend elements in a chart legend.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:LegendItem> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:LegendItem
    Properties
    element="No default"
    label="No default"
    source="No default"
    legendData="No default"
    marker="No default"
    markerAspectRatio="No default"

    Styles
    fill="IFill; no default."
    fontWeight="normal|bold"
    horizontalGap="8"
    labelPlacement="right|left|top|bottom"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    markerHeight="15"
    markerWidth="10"
    paddingLeft="0"
    paddingRight="0"
    stroke="IStroke; no default"
    verticalGap="6"
  />

See also

mx.charts.Legend
mx.charts.chartClasses.LegendData
Using Legend controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | element : IChartElement The chart element that is responsible for generating this legend item. | LegendItem
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | label : String Specifies the text that Flex displays alongside the legend element. | LegendItem
 | legendData : Object [write-only] The LegendData instance that this LegendItem object represents. | LegendItem
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
 | marker : IFlexDisplayObject The marker displayed by this legend item. | LegendItem
 | markerAspectRatio : Number The aspect ratio for the marker associated with this legend item. | LegendItem
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
 | source : Object [read-only] Contains a reference to the data series that the LegendItem was generated from if you bind the dataProvider property of the parent Legend control to a chart control. | LegendItem
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LegendItem()
Constructor.
LegendItem
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fill | Type: Object CSS Inheritance: no Specifies an IFill object that defines the fill for the legend element. | LegendItem
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
 | fontWeight | Type: String CSS Inheritance: yes Whether the text is bold or not. Recognized values are "normal" and "bold". The default value is "normal". | LegendItem
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | LegendItem
 | labelPlacement | Type: String CSS Inheritance: yes Specifies the label placement of the legend element. Recognized values are "top", "bottom", "left", and "right". | LegendItem
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no Specifies the class that renders the marker portion of the legend item. Typically the marker is provided by the chart element that generates the legend item. When you create a legend manually, however, this style specifies what class is used to render the marker. | LegendItem
 | markerHeight | Type: Number Format: Length CSS Inheritance: yes Specifies the height of the legend element. | LegendItem
 | markerWidth | Type: Number Format: Length CSS Inheritance: yes Specifies the width of the legend element. | LegendItem
 | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. The default value for the Tree control is 2. | LegendItem
 | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. | LegendItem
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | stroke | Type: Object CSS Inheritance: no Specifies the line stroke for the legend element. | LegendItem
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | LegendItem
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
element property
public var element:IChartElement

The chart element that is responsible for generating this legend item. When a Legend control's contents are automatically generated by a chart, this field refers to the element (usually a series) that this item represents. In some cases, multiple items refer to the same element.

label property
label:String [read-write]

Specifies the text that Flex displays alongside the legend element.

Implementation
    public function get label():String
    public function set label(value:String):void
legendData property
legendData:Object [write-only]

The LegendData instance that this LegendItem object represents. When a chart generates the contents of a Legend control, the elements of the chart generate one or more LegendData structures for display in the Legend. Each LegendData structure generates one LegendItem object.

Implementation
    public function set legendData(value:Object):void
marker property
marker:IFlexDisplayObject [read-write]

The marker displayed by this legend item. Markers are typically assigned by the chart element that generated the LegendData associated with this item.

Implementation
    public function get marker():IFlexDisplayObject
    public function set marker(value:IFlexDisplayObject):void
markerAspectRatio property
public var markerAspectRatio:Number

The aspect ratio for the marker associated with this legend item. Some markers provided by chart series are intended for display at a particular aspect ratio. If this property is set, the legend item guarantees the aspect ratio of the marker during layout.

source property
source:Object [read-only]

Contains a reference to the data series that the LegendItem was generated from if you bind the dataProvider property of the parent Legend control to a chart control. Otherwise, this property contains a reference to the object associated with the LegendItem.

Implementation
    public function get source():Object
Constructor detail
LegendItem () constructor
public function LegendItem()

Constructor.


mx.charts.LinearAxis (Flex™ 2 Language Reference)

Class LinearAxis | Properties | Methods | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class LinearAxis
Inheritance | LinearAxis Inheritance NumericAxis Inheritance AxisBase Inheritance EventDispatcher Inheritance Object

The LinearAxis class maps numeric values evenly between a minimum and maximum value along a chart axis. By default, it determines minimum, maximum, and interval values from the charting data to fit all of the chart elements on the screen. You can also explicitly set specific values for these properties.

The auto-determination of range values works as follows:

  1. Flex determines a minimum and maximum value that accomodates all the data being displayed in the chart.
  2. If the autoAdjust and baseAtZero properties are set to true, Flex makes the following adjustments:
    • If all values are positive, Flex sets the minimum property to zero.
    • If all values are negative, Flex sets the maximum property to zero.
  3. If the autoAdjust property is set to true, Flex adjusts values of the minimum and maximum properties by rounding them up or down.
  4. Flex checks if any of the elements displayed in the chart require extra padding to display properly (for example, for labels). It adjusts the values of the minimum and maximum properties accordingly.
  5. Flex determines if you have explicitly specified any padding around the minimum and maximum values, and adjusts their values accordingly.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:LinearAxis> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:LinearAxis
    Properties
    interval="null"
    maximum="null"
    maximumLabelPrecision="null"
    minimum="null"
    minorInterval="null"
  />

View the examples.

See also

mx.charts.chartClasses.IAxis
Working with axes
About the NumericAxis class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | autoAdjust : Boolean Specifies whether Flex rounds values. | NumericAxis
Inherited | baseAtZero : Boolean = true Specifies whether Flex tries to keep the minimum and maximum values rooted at zero. | NumericAxis
Inherited | baseline : Number The computed minimum value for the axis as long as this value is greater than 0. | NumericAxis
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | AxisBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | displayName : String The name of the axis. | AxisBase
 | interval : Number Specifies the numeric difference between label values along the axis. | LinearAxis
Inherited | labelFunction : Function Called to format axis values for display as labels. | NumericAxis
 | maximum : Number Specifies the maximum value for an axis label. | LinearAxis
 | maximumLabelPrecision : Number Specifies the maximum number of decimal places for representing fractional values on the labels generated by this axis. | LinearAxis
 | minimum : Number Specifies the minimum value for an axis label. | LinearAxis
 | minorInterval : Number Specifies the numeric difference between minor tick marks along the axis. | LinearAxis
Inherited | minorTicks : Array An Array of minor tick marks generated to represent this axis. | NumericAxis
Inherited | padding : Number Specifies padding that Flex adds to the calculated minimum and maximum values for the axis when rendering the values on the screen. | NumericAxis
Inherited | parseFunction : Function Specify a parseFunction to customize how the values rendered by your chart are converted into numeric values. | NumericAxis
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | title : String The text for the title displayed along the axis. | AxisBase
Inherited | unitSize : Number The size of one unit of data as represented by this axis. | AxisBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | assignedMaximum : Number The explicitly assigned maximum value. | NumericAxis
Inherited | assignedMinimum : Number The explicitly assigned minimum value. | NumericAxis
Inherited | computedInterval : Number The computed interval represented by this axis. | NumericAxis
Inherited | computedMaximum : Number The computed maximum value represented by this axis. | NumericAxis
Inherited | computedMinimum : Number The computed minimum value represented by this axis. | NumericAxis
Inherited | dataDescriptions : Array An Array of DataDescription structures describing the data being represented by the chart. | NumericAxis
Inherited | labelCache : Array The most recent set of AxisLabel objects generated to represent this axis. | NumericAxis
Inherited | labelMaximum : Number The maximum value where a label should be placed. | NumericAxis
Inherited | labelMinimum : Number The minimum value where a label should be placed. | NumericAxis
Inherited | minorTickCache : Array The most recent set of minor tick marks generated to represent this axis. | NumericAxis
Inherited | requiredDescribedFields : uint The fields of the DescribeData structure that this axis is interested in. | NumericAxis
Inherited | ticks : Array An Array of tick marks for this axis. | NumericAxis
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LinearAxis()
Constructor.
LinearAxis
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dataChanged():void
Triggers events that inform the range object when the chart data has changed.
AxisBase
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
filterCache(cache:Array, field:String, filteredString:String):void
Filters a set of values of arbitrary type to a set of numbers that can be mapped.
NumericAxis
Inherited
formatForScreen(value:Object):String
Formats values for display in DataTips.
NumericAxis
Inherited
getLabelEstimate():AxisLabelSet
Determines the range to estimate what the axis labels should be.
NumericAxis
Inherited
getLabels(minimumAxisLength:Number):AxisLabelSet
Gets the labels text that is rendered.
NumericAxis
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
invertTransform(value:Number):Object
Maps a position along the axis back to a numeric data value.
NumericAxis
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void
Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
NumericAxis
Inherited
preferDropLabels():Boolean
Determines how the axis handles overlapping labels.
NumericAxis
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet
Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
NumericAxis
Inherited
registerDataTransform(transform:DataTransform, dimensionName:String):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
transformCache(cache:Array, field:String, convertedField:String):void
Maps a set of values from data space to screen space.
NumericAxis
Inherited
unregisterDataTransform(transform:DataTransform):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
update():void
Updates the chart.
NumericAxis
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustMinMax(minValue:Number, maxValue:Number):void Adjusts the generated or assigned range of the axis's labels. | NumericAxis
Inherited | buildLabelCache():Boolean Populates the labelCache property with labels representing the current values of the axis. | NumericAxis
Inherited | buildMinorTickCache():Array Builds an Array of positions for the minor tick marks Array that is generated by this axis. | NumericAxis
Inherited | describeData(requiredFields:uint):Array Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. | AxisBase
Inherited | guardMinMax(min:Number, max:Number):Array Protects the range against invalid values for this axis type. | NumericAxis
Inherited | invalidateCache():void Invalidates the cached labels and tick marks that represent this axis's values. | NumericAxis
Property detail
interval property
interval:Number [read-write]

Specifies the numeric difference between label values along the axis. Flex calculates the interval if this property is set to NaN. The default value is NaN.

Implementation
    public function get interval():Number
    public function set interval(value:Number):void
maximum property
maximum:Number [read-write]

Specifies the maximum value for an axis label. If you set the autoAdjust property to true, Flex calculates this value. If NaN, Flex determines the maximum value from the data in the chart. The default value is NaN.

Implementation
    public function get maximum():Number
    public function set maximum(value:Number):void
maximumLabelPrecision property
maximumLabelPrecision:Number [read-write]

Specifies the maximum number of decimal places for representing fractional values on the labels generated by this axis. By default, the axis autogenerates this value from the labels themselves. A value of 0 rounds to the nearest integer value, while a value of 2 rounds to the nearest 1/100th of a value.

Implementation
    public function get maximumLabelPrecision():Number
    public function set maximumLabelPrecision(value:Number):void
minimum property
minimum:Number [read-write]

Specifies the minimum value for an axis label. If NaN, Flex determines the minimum value from the data in the chart. The default value is NaN.

Implementation
    public function get minimum():Number
    public function set minimum(value:Number):void
minorInterval property
minorInterval:Number [read-write]

Specifies the numeric difference between minor tick marks along the axis. Flex calculates the difference if this property is set to NaN.

Implementation
    public function get minorInterval():Number
    public function set minorInterval(value:Number):void
Constructor detail
LinearAxis () constructor
public function LinearAxis()

Constructor.

Examples
HLOCChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HLOCChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var stockDataAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.55,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 40.15,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
        ]]>
    </mx:Script>

    <mx:Panel title="HLOCChart Control Example" height="100%" width="100%">

        <mx:HLOCChart id="hlocchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{stockDataAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:HLOCSeries openField="Open" highField="High"
                    lowField="Low" closeField="Close"/>
            </mx:series>
        </mx:HLOCChart>

    </mx:Panel>
</mx:Application>


mx.charts.LineChart (Flex™ 2 Language Reference)

Class LineChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class LineChart
Inheritance | LineChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The LineChart control represents a data series as points connected by a continuous line. You can use an icon or symbol to represent each data point along the line, or show a simple line with no icons.

The LineChart control expects its series property to contain an Array of LineSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax
The <mx:LineChart> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:LineChart
  />

View the examples.

See also

mx.charts.series.LineSeries
Using the charting controls
Using line charts
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LineChart()
Constructor.
LineChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
LineChart () constructor
public function LineChart()

Constructor.

Examples
Line_AreaChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the LineChart and AreaChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="LineChart and AreaChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:LineChart id="linechart" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:LineSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:LineSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:LineSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:LineChart>

        <mx:Legend dataProvider="{linechart}"/>

        <mx:AreaChart id="Areachart" height="100%" width="45%"
             paddingLeft="5" paddingRight="5"
             showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:AreaSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:AreaSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:AreaSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:AreaChart>

        <mx:Legend dataProvider="{Areachart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.LogAxis (Flex™ 2 Language Reference)

Class LogAxis | Properties | Methods | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class LogAxis
Inheritance | LogAxis Inheritance NumericAxis Inheritance AxisBase Inheritance EventDispatcher Inheritance Object

The LogAxis class maps numeric values logarithmically between a minimum and maximum value along a chart axis. By default, it determines minimum, maximum, and interval values from the charting data to fit all of the chart elements on the screen. You can also explicitly set specific values for these properties. A LogAxis object cannot correctly render negative values, as Log10() of a negative number is undefined.

View the examples.

See also

mx.charts.chartClasses.IAxis
Working with axes
About the NumericAxis class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | autoAdjust : Boolean Specifies whether Flex rounds values. | NumericAxis
Inherited | baseAtZero : Boolean = true Specifies whether Flex tries to keep the minimum and maximum values rooted at zero. | NumericAxis
Inherited | baseline : Number The computed minimum value for the axis as long as this value is greater than 0. | NumericAxis
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | AxisBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | displayName : String The name of the axis. | AxisBase
 | interval : Number Specifies the multiplier label values along the axis. | LogAxis
Inherited | labelFunction : Function Called to format axis values for display as labels. | NumericAxis
 | maximum : Number Specifies the maximum value for an axis label. | LogAxis
 | maximumLabelPrecision : Number Specifies the maximum number of decimal places for representing fractional values on the labels generated by this axis. | LogAxis
 | minimum : Number Specifies the minimum value for an axis label. | LogAxis
Inherited | minorTicks : Array An Array of minor tick marks generated to represent this axis. | NumericAxis
Inherited | padding : Number Specifies padding that Flex adds to the calculated minimum and maximum values for the axis when rendering the values on the screen. | NumericAxis
Inherited | parseFunction : Function Specify a parseFunction to customize how the values rendered by your chart are converted into numeric values. | NumericAxis
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | title : String The text for the title displayed along the axis. | AxisBase
Inherited | unitSize : Number The size of one unit of data as represented by this axis. | AxisBase
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | assignedMaximum : Number The explicitly assigned maximum value. | NumericAxis
Inherited | assignedMinimum : Number The explicitly assigned minimum value. | NumericAxis
Inherited | computedInterval : Number The computed interval represented by this axis. | NumericAxis
Inherited | computedMaximum : Number The computed maximum value represented by this axis. | NumericAxis
Inherited | computedMinimum : Number The computed minimum value represented by this axis. | NumericAxis
Inherited | dataDescriptions : Array An Array of DataDescription structures describing the data being represented by the chart. | NumericAxis
Inherited | labelCache : Array The most recent set of AxisLabel objects generated to represent this axis. | NumericAxis
Inherited | labelMaximum : Number The maximum value where a label should be placed. | NumericAxis
Inherited | labelMinimum : Number The minimum value where a label should be placed. | NumericAxis
Inherited | minorTickCache : Array The most recent set of minor tick marks generated to represent this axis. | NumericAxis
Inherited | requiredDescribedFields : uint The fields of the DescribeData structure that this axis is interested in. | NumericAxis
Inherited | ticks : Array An Array of tick marks for this axis. | NumericAxis
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LogAxis()
Constructor.
LogAxis
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dataChanged():void
Triggers events that inform the range object when the chart data has changed.
AxisBase
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
filterCache(cache:Array, field:String, filteredString:String):void
Filters a set of values of arbitrary type to a set of numbers that can be mapped.
NumericAxis
Inherited
formatForScreen(value:Object):String
Formats values for display in DataTips.
NumericAxis
Inherited
getLabelEstimate():AxisLabelSet
Determines the range to estimate what the axis labels should be.
NumericAxis
Inherited
getLabels(minimumAxisLength:Number):AxisLabelSet
Gets the labels text that is rendered.
NumericAxis
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
invertTransform(value:Number):Object
Maps a position along the axis back to a numeric data value.
NumericAxis
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void
Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
NumericAxis
Inherited
preferDropLabels():Boolean
Determines how the axis handles overlapping labels.
NumericAxis
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet
Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
NumericAxis
Inherited
registerDataTransform(transform:DataTransform, dimensionName:String):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
transformCache(cache:Array, field:String, convertedField:String):void
Maps a set of values from data space to screen space.
NumericAxis
Inherited
unregisterDataTransform(transform:DataTransform):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
update():void
Updates the chart.
NumericAxis
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustMinMax(minValue:Number, maxValue:Number):void Adjusts the generated or assigned range of the axis's labels. | NumericAxis
Inherited | buildLabelCache():Boolean Populates the labelCache property with labels representing the current values of the axis. | NumericAxis
Inherited | buildMinorTickCache():Array Builds an Array of positions for the minor tick marks Array that is generated by this axis. | NumericAxis
Inherited | describeData(requiredFields:uint):Array Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. | AxisBase
Inherited | guardMinMax(min:Number, max:Number):Array Protects the range against invalid values for this axis type. | NumericAxis
Inherited | invalidateCache():void Invalidates the cached labels and tick marks that represent this axis's values. | NumericAxis
Property detail
interval property
interval:Number [read-write]

Specifies the multiplier label values along the axis. A value of 10 generates labels at 1, 10, 100, 1000, etc., while a value of 100 generates labels at 1, 100, 10000, etc. Flex calculates the interval if this property is set to NaN. Intervals must be even powers of 10, and must be greater than or equal to 10. The LogAxis rounds the interval down to an even power of 10, if necessary.

The default value is 10.

Implementation
    public function get interval():Number
    public function set interval(value:Number):void
maximum property
maximum:Number [read-write]

Specifies the maximum value for an axis label. If NaN, Flex determines the maximum value from the data in the chart. The maximum value must be an even power of 10. The LogAxis rounds an explicit maximum value up to an even power of 10, if necessary.

The default value is NaN.

Implementation
    public function get maximum():Number
    public function set maximum(value:Number):void
maximumLabelPrecision property
maximumLabelPrecision:Number [read-write]

Specifies the maximum number of decimal places for representing fractional values on the labels generated by this axis. By default, the Axis autogenerates this value from the labels themselves. A value of 0 round to the nearest integer value, while a value of 2 rounds to the nearest 1/100th of a value.

Implementation
    public function get maximumLabelPrecision():Number
    public function set maximumLabelPrecision(value:Number):void
minimum property
minimum:Number [read-write]

Specifies the minimum value for an axis label. If NaN, Flex determines the minimum value from the data in the chart. The minimum value must be an even power of 10. The LogAxis will round an explicit minimum value downward to an even power of 10 if necessary.

The default value is NaN.

Implementation
    public function get minimum():Number
    public function set minimum(value:Number):void
Constructor detail
LogAxis () constructor
public function LogAxis()

Constructor.

Examples
LogAxisExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the LogAxis class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 20000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 15000, Amount: 600 },
            { Month: "Mar", Profit: 15000, Expenses: 5000, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="LogAxis Example" height="100%" width="100%">

        <mx:LineChart id="linechart" height="100%" width="100%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:verticalAxis>
                <mx:LogAxis interval="10"/>
            </mx:verticalAxis>

            <mx:series>
                <mx:LineSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:LineSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:LineSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:LineChart>

        <mx:Legend dataProvider="{linechart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.PieChart (Flex™ 2 Language Reference)

Class PieChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class PieChart
Inheritance | PieChart Inheritance PolarChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The PieChart control represents a data series as a standard pie chart. The data for the data provider determines the size of each wedge in the pie chart relative to the other wedges. You can use the PieSeries class to create standard pie charts, doughnut charts, or stacked pie charts.

The PieChart control expects its series property to contain an Array of PieSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PieChart> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:PieChart
    Styles
    innerRadius="0"
    textAlign="left"
  />

View the examples.

See also

mx.charts.series.PieSeries
Using the charting controls
Using pie charts
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | angularAxis : IAxis The axis object used to map data values to an angle between 0 and 2 PI. | PolarChart
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | radialAxis : IAxis The axis object used to map data values to a radial distance between the center and the outer edge of the chart. | PolarChart
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | PolarChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PieChart()
Constructor.
PieChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
PolarChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
PolarChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | PolarChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | innerRadius | Type: Number CSS Inheritance: no Determines the size of the hole in the center of the pie chart. This property is a percentage value of the center circle's radius compared to the entire pie's radius. The default value is 0 percent. Use this property to create a doughnut-shaped chart. | PieChart
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
 | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. Recognized values are "left", "right", or "center". The default value is "left". | PieChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
PieChart () constructor
public function PieChart()

Constructor.

Examples
PieChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the PieChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var medalsAC:ArrayCollection = new ArrayCollection( [
            { Country: "USA", Gold: 35, Silver:39, Bronze: 29 },
            { Country: "China", Gold: 32, Silver:17, Bronze: 14 },
            { Country: "Russia", Gold: 27, Silver:27, Bronze: 38 } ]);

        private function displayGold(data:Object, field:String, index:Number, percentValue:Number):String {
            var temp:String= (" " + percentValue).substr(0,6);
            return data.Country + ": " + '\n' + "Total Gold: " + data.Gold + '\n' + temp + "%";
        }
        ]]>
    </mx:Script>

    <mx:Panel title="Olympics 2004 Medals Tally Panel" height="100%" width="100%">

        <mx:PieChart id="chart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{medalsAC}" >

            <mx:series>
                <mx:PieSeries labelPosition="callout" field="Gold" labelFunction="displayGold">
                    <mx:calloutStroke>
                        <mx:Stroke weight="0" color="0x888888" alpha="100"/>
                    </mx:calloutStroke>
                    <mx:radialStroke>
                        <mx:Stroke weight="0" color="#FFFFFF" alpha="20"/>
                    </mx:radialStroke>
                    <mx:stroke>
                        <mx:Stroke color="0" alpha="20" weight="2"/>
                    </mx:stroke>
                </mx:PieSeries>
            </mx:series>
        </mx:PieChart>

    </mx:Panel>
</mx:Application>


mx.charts.PlotChart (Flex™ 2 Language Reference)

Class PlotChart | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts
Class | public class PlotChart
Inheritance | PlotChart Inheritance CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The PlotChart control represents data with two values for each data point. One value determines the position of the data point along the horizontal axis, and one value determines its position along the vertical axis.

The PlotChart control expects its series property to contain an Array of PlotSeries objects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax
The <mx:PlotChart> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:PlotChart
  />

View the examples.

See also

mx.charts.series.PlotSeries
Using the charting controls
Using plot charts
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | computedGutters : Rectangle The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
Inherited | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
Inherited | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
Inherited | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
Inherited | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
Inherited | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
Inherited | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
Inherited | dataRegion : Rectangle The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PlotChart()
Constructor.
PlotChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToData(v:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. | CartesianChart
Inherited | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
Inherited | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
Inherited | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
Inherited | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
Inherited | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
Inherited | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
PlotChart () constructor
public function PlotChart()

Constructor.

Examples
PlotChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the PlotChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="PlotChart Control Example" height="100%" width="100%">

        <mx:PlotChart id="plot" height="100%" width="100%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:series>
                <mx:PlotSeries xField="Expenses" yField="Profit" displayName="Expenses/Profit"/>
                <mx:PlotSeries xField="Amount" yField="Expenses" displayName="Amount/Expenses"/>
                <mx:PlotSeries xField="Profit" yField="Amount" displayName="Profit/Amount"/>
            </mx:series>
        </mx:PlotChart>

        <mx:Legend dataProvider="{plot}"/>

    </mx:Panel>
</mx:Application>


mx.charts.chartClasses Summary (Flex™ 2 Language Reference)

Package mx.charts.chartClasses | Interfaces | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.chartClasses package contains the base classes for the Flex charting components.

Interfaces
Interface | Description
IAxis | The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IAxisRenderer | The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IBar | The IBar interface is implemented by any any series that can be clustered vertically, such as a BarSeries.
IChartElement | IChartElement defines the base set of properties and methods required by a UIComponent to be representable in the data space of a chart.
IColumn | ChartElements that can be clustered along the vertical axis should implement this interface.
IStackable | The IStackable interface is implemented by any series that can be stacked.
Classes
Class | Description
AxisBase | The AxisBase class serves as a base class for the various axis types supported in Flex.
AxisLabelSet | An AxisLAbelSet represents the label and tick data generated by an implementation of IAxis.
BoundedValue | A bounded value is used to represent a datapoint that a chart element intends to render on screen.
CartesianChart | The CartesianChart class is a base class for the common chart types.
CartesianTransform | The CartesianTransform object represents a set of axes sed to map data values to x/y Cartesian screen coordinates and vice versa.
ChartBase | The ChartBase class is the link between the Flex component architecture and the DualStyleObject architecture.
ChartElement | The ChartElement class is the base class for visual chart elements.
ChartLabel | Draws data labels on chart controls.
ChartState | Describes the current state of a chart.
DataDescription | The DataDescription structure is used by ChartElements to describe the characteristics of the data they represent to Axis objects that auto-generate values from the data represented in the chart.
DataTip | The DataTip control provides information about a data point to chart users.
DataTransform | The DataTransform object represents a portion of a chart that contains glyphs and can transform values to screen coordinates and vice versa.
DualStyleObject | The DualStyleObject class serves as a base class for components that have a need to assign class selectors outside of the client developer's control.
HLOCSeriesBase | HLOCSeriesBase is the base class for the two financial series types, HLOCSeries and CandlestickSeries.
InstanceCache | InstanceCache is a utilty that governs the task of creating and managing a set of n object instances, where n changes frequently.
LegendData | The LegendData structure is used by charts to describe the items that should be displayed in an auto-generated legend.
NumericAxis | The NumericAxis class acts as a common base class for axis types representing a continuous range of values between a defined minimum and maximum.
PolarChart | The PolarChart control serves as base class for circular charts based in polar coordinates.
PolarTransform | The PolarTransform object represents a set of axes used to map data values to angle/distance polar coordinates and vice versa.
RenderData | RenderData structures are used by chart elements to store all of the relevant values and data needed to fully render the chart.
Series | The Series class is the base class for the classes that let you specify a data series for a chart control.
StackedSeries | Stacked Series serves as the common base class for all of the stacking set series (BarSet, ColumnSet, and AreaSet).

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.chartClasses.AxisBase (Flex™ 2 Language Reference)

Class AxisBase | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class AxisBase
Inheritance | AxisBase Inheritance EventDispatcher Inheritance Object
Subclasses | CategoryAxis, NumericAxis

The AxisBase class serves as a base class for the various axis types supported in Flex.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

Flex components inherit the following properties from the AxisBase class:

  <mx:tagname
    name="No default"
  >

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | chartDataProvider : Object [write-only] The data provider assigned to the enclosing chart. | AxisBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | displayName : String The name of the axis. | AxisBase
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | title : String The text for the title displayed along the axis. | AxisBase
 | unitSize : Number [read-only] The size of one unit of data as represented by this axis. | AxisBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AxisBase()
Constructor.
AxisBase
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
dataChanged():void
Triggers events that inform the range object when the chart data has changed.
AxisBase
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
registerDataTransform(transform:DataTransform, dimensionName:String):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
unregisterDataTransform(transform:DataTransform):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | describeData(dimension:String, requiredFields:uint):Array Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. | AxisBase
Property detail
chartDataProvider property
chartDataProvider:Object [write-only]

The data provider assigned to the enclosing chart. Axis types that are data provider-based can choose to inherit the data provider associated with the enclosing chart. If an axis is shared among multiple charts, the value of this property is undefined (most likely it will be the last data provider assigned to one of the associated charts).

Implementation
    public function set chartDataProvider(value:Object):void
displayName property
displayName:String [read-write]

The name of the axis. If set, Flex uses this name to format DataTip controls.

Implementation
    public function get displayName():String
    public function set displayName(value:String):void
title property
title:String [read-write]

The text for the title displayed along the axis.

Implementation
    public function get title():String
    public function set title(value:String):void
unitSize property
unitSize:Number [read-only]

The size of one unit of data as represented by this axis. This value is used by various series types to help in rendering. The ColumnSeries class, for example, uses this value to determine how wide columns should be rendered. Different axis types return different values, sometimes dependent on the data being represented. The DateTimeAxis class, for example, might return the number of milliseconds in a day, or a year, depending on the data that is rendered in the chart. Because this value is dependant on collecting the represented data, custom series cannot assume this value is accurate in their updateData() or updateMapping() methods.

Implementation
    public function get unitSize():Number
Constructor detail
AxisBase () constructor
public function AxisBase()

Constructor.

Method detail
dataChanged () method
public function dataChanged():void

Triggers events that inform the range object when the chart data has changed.

describeData () method
protected function describeData(dimension:String, requiredFields:uint):Array

Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. Implementors fill out and return an Array of mx.charts.chartClasses.DataDescription objects to guarantee that their data is correctly accounted for by any axes that are autogenerating values from the displayed data (such as minimum, maximum, interval, and unitSize). Most element types return an Array containing a single DataDescription. Aggregate elements, such as BarSet and ColumnSet, might return mutiple DataDescription instances that describe the data displayed by their subelements. When called, the implementor describes the data along the axis indicated by the dimension argument. This function might be called for each axis supported by the containing chart.

Parameters
dimension:String — Determines the axis to get data descriptions of.
requiredFields:uint — A bitfield that indicates which values of the DataDescription object the particular axis cares about. Implementors can optimize by only calculating the necessary fields.

Returns
Array
registerDataTransform () method
public function registerDataTransform(transform:DataTransform, dimensionName:String):void

Each DataTransform that makes use of an axis registers itself with that axis. The axis is responsible for informing the transform when its relevant values have changed. It should also request values from the transform when it wants to autogenerate minimum and maximum values.

Parameters
transform:DataTransform — The DataTransform to register.
dimensionName:String — The name of the dimension.
unregisterDataTransform () method
public function unregisterDataTransform(transform:DataTransform):void

Each DataTransform that makes use of an axis registers itself with that axis. The axis is responsible for informing the transform when its relevant values have changed. It should also request values from the transform when it wants to autogenerate minimum and maximum values.

Parameters
transform:DataTransform — The DataTransform to unregister.


mx.charts.chartClasses.AxisLabelSet (Flex™ 2 Language Reference)

Class AxisLabelSet | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class AxisLabelSet
Inheritance | AxisLabelSet Inheritance Object

An AxisLAbelSet represents the label and tick data generated by an implementation of IAxis.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | accurate : Boolean When returned from the getLabelEsimate() function, set to true if the estimate accurately represents the final labels to be rendered. | AxisLabelSet
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | labels : Array An array of AxisLabel objects representing the values of the generating axis. | AxisLabelSet
 | minorTicks : Array An array of values from 0 to 1 representing where to place minor tick marks along the axis. | AxisLabelSet
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | ticks : Array An array of values from 0 to 1 representing where to place tick marks along the axis. | AxisLabelSet
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AxisLabelSet() Constructor. | AxisLabelSet
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
accurate property
public var accurate:Boolean

When returned from the getLabelEsimate() function, set to true if the estimate accurately represents the final labels to be rendered. Irrelevant in other contexts

labels property
public var labels:Array

An array of AxisLabel objects representing the values of the generating axis.

minorTicks property
public var minorTicks:Array

An array of values from 0 to 1 representing where to place minor tick marks along the axis.

ticks property
public var ticks:Array

An array of values from 0 to 1 representing where to place tick marks along the axis.

Constructor detail
AxisLabelSet () constructor
public function AxisLabelSet()

Constructor.


mx.charts.chartClasses.BoundedValue (Flex™ 2 Language Reference)

Class BoundedValue | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class BoundedValue
Inheritance | BoundedValue Inheritance Object

A bounded value is used to represent a datapoint that a chart element intends to render on screen. ChartElements report BoundedValues describing their data to an Axis object that the axis computes autogenerated ranges. A BoundedValue encapsulates both the value of the datapoint in a particualr dimension, as well as a margin, in pixels, that a ChartElement needs above or below the value in order to render it. Plots on a plot chart, for example, report their data with margins to accomodate the size of the plots. A column chart might report a margin in the Y axis to accomodate a label rendered above the chart.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | lowerMargin : Number The margin, in pixels, required below the value in order to render properly. | BoundedValue
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | upperMargin : Number The margin, in pixels, required above the value in order to render properly. | BoundedValue
 | value : Number The value to be rendered. | BoundedValue
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | BoundedValue(value:Number, lowerMargin:Number = 0, upperMargin:Number = 0) Constructor. | BoundedValue
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
lowerMargin property
public var lowerMargin:Number

The margin, in pixels, required below the value in order to render properly.

upperMargin property
public var upperMargin:Number

The margin, in pixels, required above the value in order to render properly.

value property
public var value:Number

The value to be rendered.

Constructor detail
BoundedValue () constructor
public function BoundedValue(value:Number, lowerMargin:Number = 0, upperMargin:Number = 0)

Constructor.

Parameters
value:Number — The value to be rendered.
lowerMargin:Number (default = 0) — The lower margin.
upperMargin:Number (default = 0) — The upper margin.


mx.charts.chartClasses.CartesianChart (Flex™ 2 Language Reference)

Class CartesianChart | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class CartesianChart
Inheritance | CartesianChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | AreaChart, BarChart, BubbleChart, CandlestickChart, ColumnChart, HLOCChart, LineChart, PlotChart

The CartesianChart class is a base class for the common chart types. CartesianChart defines the basic layout behavior of the standard rectangular, two-dimensional charts.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:CartesianChart> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:CartesianChart
    Properties
    computedGutters="No default"
    dataRegion="Rectangle; no default"
    horizontalAxis="Axis; no default"
    horizontalAxisRatio=".33"
    horizontalAxisRenderer="AxisRenderer; no default"
    secondDataProvider="No default"
    secondHorizontalAxis="Axis; no default"
    secondHorizontalAxisRenderer="AxisRenderer; no default"
    secondSeries="Series; no default"
    secondVerticalAxis="Axis; no default"
    secondVerticalAxisRenderer="AxisRenderer; no default"
    verticalAxis="Axis; no default"
    verticalAxisRenderer="AxisRenderer; no default"

    Styles
    axisTitleStyleName="Style; no default"
    gridLinesStyleName="Style; no default"
    gutterBottom="No default"
    gutterLeft="No default"
    gutterRight="No default"
    gutterTop="No default"
    horizontalAxixStyle="Style; no default"
    secondHorizontalAxixStyle="Style; no default"
    secondVerticalAxisStyleName="Style; no default"
    textAlign="left|right|center"
    verticalAxisStyleName="Style; no default"
  />

See also

mx.charts.CategoryAxis
mx.charts.LinearAxis
mx.charts.chartClasses.ChartBase
Using the charting controls
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
 | computedGutters : Rectangle [read-only] The current computed size of the gutters of the CartesianChart. | CartesianChart
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | horizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
 | horizontalAxisRatio : Number = 0.33 Determines the height limit of the horiztonal axis. | CartesianChart
 | horizontalAxisRenderer : IAxisRenderer Specifies how data appears along the x-axis of a chart. | CartesianChart
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | secondDataProvider : Object The second dataProvider for this chart. | CartesianChart
 | secondHorizontalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
 | secondHorizontalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
 | secondSeries : Array An array of Series objects that define the secondary chart data. | CartesianChart
 | secondVerticalAxis : IAxis The second vertical axis definition for this chart. | CartesianChart
 | secondVerticalAxisRenderer : IAxisRenderer Defines the labels, tick marks, and data position for items on the x-axis. | CartesianChart
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | verticalAxis : IAxis Defines the labels, tick marks, and data position for items on the y-axis. | CartesianChart
 | verticalAxisRatio : Number = 0.33 Determines the width limit of the vertical axis. | CartesianChart
 | verticalAxisRenderer : IAxisRenderer Specifies how data appears along the y-axis of a chart. | CartesianChart
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
 | dataRegion : Rectangle [read-only] The area of the chart used to display data. | CartesianChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CartesianChart()
Constructor.
CartesianChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
CartesianChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
getSecondAxis(dimension:String):IAxis
Retrieves axis instance for a particular secondary dimension of the chart.
CartesianChart
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
localToData(pt:Point):Array
Converts a coordinate on screen to a tuple of data values.
CartesianChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setSecondAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular secondary dimension of the chart.
CartesianChart
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
styleChanged(styleProp:String):void
Detects changes to style properties.
CartesianChart
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
 | commitProperties():void Processes the properties set on the component. | CartesianChart
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
 | initSecondaryMode():void Initializes the chart for displaying a second series. | CartesianChart
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void | CartesianChart
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | CartesianChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
 | axisTitleStyleName | Type: String CSS Inheritance: yes The name of the CSS class selector to use when formatting titles on the axes. | CartesianChart
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
 | gridLinesStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the default grid lines. If you explicitly set the backgroundElements property on your chart, this value is ignored. | CartesianChart
 | gutterBottom | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control. | CartesianChart
 | gutterLeft | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the left of the chart data area and the left of the chart control. | CartesianChart
 | gutterRight | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control. | CartesianChart
 | gutterTop | Type: Number Format: Length CSS Inheritance: no The size of the region, in pixels, between the top of the chart data area and the top of the chart control. | CartesianChart
 | horizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the horizontal axis. | CartesianChart
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | secondHorizontalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second horizontal axis. | CartesianChart
 | secondVerticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the second vertical axis. | CartesianChart
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
 | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. Valid values are "left", "right", and "center". The default value is "left". | CartesianChart
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAxisStyleName | Type: String CSS Inheritance: no The class selector that defines the style properties for the vertical axis. | CartesianChart
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
computedGutters property
computedGutters:Rectangle [read-only]

The current computed size of the gutters of the CartesianChart. The gutters represent the area between the padding and the data area of the chart, where the titles and axes render. By default, the gutters are computed dynamically. You can set explicit values through the gutter styles. The gutters are computed to match any changes to the chart when it is validated by the LayoutManager.

Implementation
    public function get computedGutters():Rectangle
dataRegion property
dataRegion:Rectangle [read-only]

The area of the chart used to display data. This rectangle excludes the area used for gutters, axis lines and labels, and padding.

Implementation
    protected function get dataRegion():Rectangle
horizontalAxis property
horizontalAxis:IAxis [read-write]

Defines the labels, tick marks, and data position for items on the x-axis. Use either the LinearAxis class or the CategoryAxis class to set the properties of the horizontalAxis as a child tag in MXML or create a LinearAxis or CategoryAxis object in ActionScript.

Implementation
    public function get horizontalAxis():IAxis
    public function set horizontalAxis(value:IAxis):void
horizontalAxisRatio property
public var horizontalAxisRatio:Number = 0.33

Determines the height limit of the horiztonal axis. The limit is the width of the axis times this ratio.

The default value is 0.33..

horizontalAxisRenderer property
horizontalAxisRenderer:IAxisRenderer [read-write]

Specifies how data appears along the x-axis of a chart. Use the AxisRenderer class to define the properties for horizontalAxisRenderer as a child tag in MXML or create an AxisRenderer object in ActionScript.

Implementation
    public function get horizontalAxisRenderer():IAxisRenderer
    public function set horizontalAxisRenderer(value:IAxisRenderer):void
secondDataProvider property
secondDataProvider:Object [read-write]

The second dataProvider for this chart. The second dataProvider is typically rendered by a secondSeries.

Implementation
    public function get secondDataProvider():Object
    public function set secondDataProvider(value:Object):void
secondHorizontalAxis property
secondHorizontalAxis:IAxis [read-write]

Defines the labels, tick marks, and data position for items on the y-axis. Use either the LinearAxis class or the CategoryAxis class to set the properties of the horizontalAxis as a child tag in MXML or create a LinearAxis or CategoryAxis object in ActionScript.

Implementation
    public function get secondHorizontalAxis():IAxis
    public function set secondHorizontalAxis(value:IAxis):void
secondHorizontalAxisRenderer property
secondHorizontalAxisRenderer:IAxisRenderer [read-write]

Specifies how data appears along the y-axis of a chart. Use the AxisRenderer class to set the properties for verticalAxisRenderer as a child tag in MXML or create an AxisRenderer object in ActionScript.

Implementation
    public function get secondHorizontalAxisRenderer():IAxisRenderer
    public function set secondHorizontalAxisRenderer(value:IAxisRenderer):void
secondSeries property
secondSeries:Array [read-write]

An array of Series objects that define the secondary chart data. Secondary Series are displayed in the same data area as the primary chart series, but are typically rendered with different scales and axes.

Implementation
    public function get secondSeries():Array
    public function set secondSeries(value:Array):void
secondVerticalAxis property
secondVerticalAxis:IAxis [read-write]

The second vertical axis definition for this chart. This class is typically used to render the axis for a secondSeries.

Implementation
    public function get secondVerticalAxis():IAxis
    public function set secondVerticalAxis(value:IAxis):void
secondVerticalAxisRenderer property
secondVerticalAxisRenderer:IAxisRenderer [read-write]

Defines the labels, tick marks, and data position for items on the x-axis. Use either the LinearAxis class or the CategoryAxis class to set the properties of the horizontalAxis as a child tag in MXML or create a LinearAxis or CategoryAxis object in ActionScript.

Implementation
    public function get secondVerticalAxisRenderer():IAxisRenderer
    public function set secondVerticalAxisRenderer(value:IAxisRenderer):void
verticalAxis property
verticalAxis:IAxis [read-write]

Defines the labels, tick marks, and data position for items on the y-axis. Use either the LinearAxis class or the CategoryAxis class to set the properties of the horizontalAxis as a child tag in MXML or create a LinearAxis or CategoryAxis object in ActionScript.

Implementation
    public function get verticalAxis():IAxis
    public function set verticalAxis(value:IAxis):void
verticalAxisRatio property
public var verticalAxisRatio:Number = 0.33

Determines the width limit of the vertical axis. The limit is the width of the axis times this ratio.

The default value is 0.33..

verticalAxisRenderer property
verticalAxisRenderer:IAxisRenderer [read-write]

Specifies how data appears along the y-axis of a chart. Use the AxisRenderer class to set the properties for verticalAxisRenderer as a child tag in MXM or create an AxisRenderer object in ActionScript.

Implementation
    public function get verticalAxisRenderer():IAxisRenderer
    public function set verticalAxisRenderer(value:IAxisRenderer):void
Constructor detail
CartesianChart () constructor
public function CartesianChart()

Constructor.

Method detail
commitProperties () method
protected override function commitProperties():void

Processes the properties set on the component. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the commitProperties() method when you use the addChild() method to add a component to a container, or when you call the invalidateProperties() method of the component. Calls to the commitProperties() method occur before calls to the measure() method. This lets you set property values that might be used by the measure() method.

Some components have properties that affect the number or kinds of child objects that they need to create, or have properties that interact with each other, such as the horizontalScrollPolicy and horizontalScrollPosition properties. It is often best at startup time to process all of these properties at one time to avoid duplicating work.

dataToLocal () method
public override function dataToLocal(... dataValues):Point

Converts a tuple of data values to an x-y coordinate on screen. Call this function to transform data on to the screen using the same transform that the individual elements go through. For example, to create a custom highlight for a data region of a chart, you might use this function to determine the on-screen coordinates of the range of interest.

For Cartesian charts, you typically pass two values. The first value maps to the horizontal axis, and the second value maps to the vertical axis.

For polar charts, the first value maps to the angular axis, and the second maps to the radial axis.

Parameters
... dataValues

Returns
Point — Coordinates that are relative to the chart.
getSecondAxis () method
public function getSecondAxis(dimension:String):IAxis

Retrieves axis instance for a particular secondary dimension of the chart. This is a low level accessor. You typically retrieve the axis directly through a named property (such as the secondHorizontalAxis or secondVerticalAxis property).

Parameters
dimension:String

Returns
IAxis
initSecondaryMode () method
protected function initSecondaryMode():void

Initializes the chart for displaying a second series. This function is called automatically whenever any of the secondary properties, such as secondSeries or secondHorizontalAxis, are set. Specific chart subtypes override this method to initialize default secondary values. Column charts, for example, initialize a separate secondary vertical axis, but leave the primary and secondary horizontal axes linked.

localToData () method
public override function localToData(pt:Point):Array

Converts a coordinate on screen to a tuple of data values. Call this function to determine what data values a particular point on-screen represents.

Individual chart types determine how this transformation occurs. The point should be relative to the chart's coordinate space.

Parameters
pt:Point — The Point to convert.

Returns
Array — The tuple of data values.
measure () method
protected override function measure():void
setSecondAxis () method
public function setSecondAxis(dimension:String, value:IAxis):void

Assigns an axis instance to a particular secondary dimension of the chart. This is a low level accessor. You typically set the axis directly through a named property (such as the secondHorizontalAxis or secondVerticalAxis property).

Parameters
dimension:String
value:IAxis
styleChanged () method
public override function styleChanged(styleProp:String):void

Detects changes to style properties. When any style property is set, Flex calls the styleChanged() method, passing to it the name of the style being set.

This is an advanced method that you might override when creating a subclass of UIComponent. When you create a custom component, you can override the styleChanged() method to check the style name passed to it, and handle the change accordingly. This lets you override the default behavior of an existing style, or add your own custom style properties.

If you handle the style property, your override of the styleChanged() method should call the invalidateDisplayList() method to cause Flex to execute the component's updateDisplayList() method at the next screen update.

Parameters
styleProp:String — The name of the style property, or null if all styles for this component have changed.
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.


mx.charts.chartClasses.CartesianTransform (Flex™ 2 Language Reference)

Class CartesianTransform | Properties | Methods | Events | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class CartesianTransform
Inheritance | CartesianTransform Inheritance DataTransform Inheritance EventDispatcher Inheritance Object

The CartesianTransform object represents a set of axes sed to map data values to x/y Cartesian screen coordinates and vice versa.

When using charts in your applications, you typically will not need to interact with the CartesianTransform object. Transforms are created automatically by the built-in chart types and used by the series contained within so that they can transform data into rendering coordinates.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | axes : Object The set of axes associated with this transform. | DataTransform
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elements : Array The elements that are associated with this transform. | DataTransform
 | pixelHeight : Number [write-only] The height of the data area that the CartesianTransform represents, in pixels. | CartesianTransform
 | pixelWidth : Number [write-only] The width of the data area that the CartesianTransform represents, in pixels. | CartesianTransform
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CartesianTransform()
Constructor.
CartesianTransform
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dataChanged():void
Informs the DataTransform that some of the underlying data being represented on the chart has changed.
DataTransform
Inherited
describeData(dimension:String, requiredFields:uint):Array
Collects important displayed values for all elements associated with this data transform.
DataTransform
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getAxis(dimension:String):IAxis
Retrieves the axis instance responsible for transforming the data dimension specified by the dimension parameter.
DataTransform
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
invertTransform(... values):Array
Transforms x and y coordinates relative to the DataTransform coordinate system into a 2-dimensional value in data space.
CartesianTransform
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setAxis(dimension:String, v:IAxis):void
Assigns an axis instance to a particular dimension of the transform.
DataTransform
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String):void
Maps a set of numeric values representing data to screen coordinates.
CartesianTransform
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | transformChange | Dispatched when the transformation from data space to screen space has changed, typically either because the axes that make up the transformation have changed in some way, or the data transform itself has size. | DataTransform
Public Constants
Constant |  | Defined by
 | HORIZONTAL_AXIS : String = "h" [static] A String representing the horizontal axis. | CartesianTransform
 | VERTICAL_AXIS : String = "v" [static] A String representing the vertical axis. | CartesianTransform
Property detail
pixelHeight property
pixelHeight:Number [write-only]

The height of the data area that the CartesianTransform represents, in pixels. The containing chart sets this property explicitly during layout. The CartesianTransform uses this property to map data values to screen coordinates.

Implementation
    public function set pixelHeight(value:Number):void
pixelWidth property
pixelWidth:Number [write-only]

The width of the data area that the CartesianTransform represents, in pixels. The containing chart sets this property explicitly during layout. The CartesianTransform uses this property to map data values to screen coordinates.

Implementation
    public function set pixelWidth(value:Number):void
Constructor detail
CartesianTransform () constructor
public function CartesianTransform()

Constructor.

Method detail
invertTransform () method
public override function invertTransform(... values):Array

Transforms x and y coordinates relative to the DataTransform coordinate system into a 2-dimensional value in data space.

Parameters
... values

Returns
Array — An Array containing the transformed values.
transformCache () method
public override function transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String):void

Maps a set of numeric values representing data to screen coordinates. This method assumes the values are all numbers, so any non-numeric values must have been previously converted with the mapCache() method.

Parameters
cache:Array — An array of objects containing the data values in their fields. This is also where this function stores the converted numeric values.
xField:String — The field where the data values for the x axis are stored.
xConvertedField:String — The field where the mapped x screen coordinate is stored.
yField:String — The field where the data values for the y axis are stored.
yConvertedField:String — The field where the mapped y screen coordinate is stored.
Constant detail
HORIZONTAL_AXIS constant
public static const HORIZONTAL_AXIS:String = "h"

A String representing the horizontal axis.

VERTICAL_AXIS constant
public static const VERTICAL_AXIS:String = "v"

A String representing the vertical axis.


mx.charts.chartClasses.ChartBase (Flex™ 2 Language Reference)

Class ChartBase | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class ChartBase
Inheritance | ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerComponent
Subclasses | CartesianChart, PolarChart

The ChartBase class is the link between the Flex component architecture and the DualStyleObject architecture. It extends the Flex base class UIComponent, but contains DualStyleObject classes.

You typically do not use the ChartBase class directly. Instead you use one of its subclasses such as PlotChart or BubbleChart. It acts as the base class for the common chart types provided in the mx.charts package.

This class defines a number of CSS styles and properties that provide easy access to the more common features of the framework.

A chart's minimum size is 20 x 20 pixels. A chart's maximum size is unbounded. A chart's preferred size is 400 x 400 pixels.

ChartBase objects, and its subclasses, augment the normal mouse event objects with additional data describing the nearest chart data point under the mouse. The event object for mouse events contains an additional property, hitData, which contains a HitData object describing the nearest data point. See mx.charts.HitData for more information on the contents of the HitData object.

ChartBase objects only consider data points within a certain radius of the mouse pointer. You can set this radius using the mouseSensitivity property. If there is no data point within the mouseSensitivity radius, event.hitData is null.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

Flex components inherit the following properties from the ChartBase class:

  <mx:tagname
    Properties
    allElements="Array; No default"
    annotationElements="Array; No default"
    backgroundElements="Array; No default"
    chartState=""
    clipContent="false|true"
    dataProvider="No default"
    dataRegion"No default"
    dataTipFunction="No default"
    dataTipLayerIndex"No default"
    dataTipMode"No default"
    description"No default"
    labelElements"No default"
    legendData"No default"
    mouseSensitivity="5"
    series="No default"
    seriesFilters"No default"
    showDataTips="true|false"
    transforms"No default"

    Styles
    chartSeriesStyles="Style; No default"
    dataTipCalloutStroke="Stroke; No default"
    dataTipRenderer="Renderer; No default"
    fill="IFill; No default"
    fontFamily="Verdana"
    fontSize="10"
    maximumDataTipCount="NaN"
    paddingBottom="No default"
    paddingTop="No default"
    paddingLeft="0"
    paddingRight="0"
    showDataTipTargets="true|false"

   Events
    itemClick="Event; No default"
    itemDoubleClick="Event; No default"
    itemMouseDown="Event; No default"
    itemMouseMove="Event; No default"
    itemMouseUp="Event; No default"
    itemRollOut="Event; No default"
    itemRollOver="Event; No default"
  >

Default MXML Property dataProvider

See also

mx.charts.HitData
mx.charts.CategoryAxis
mx.charts.LinearAxis
Using the charting controls
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
 | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
 | chartState : uint [read-only] The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | dataProvider : Object Specifies the data provider for the chart. | ChartBase
 | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
 | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
 | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | legendData : Array [read-only] An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
 | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | series : Array An Array of Series objects that define the chart data. | ChartBase
 | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
 | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
 | dataRegion : Rectangle [read-only] The area of the chart used to display data. | ChartBase
 | dataTipLayerIndex : int [read-only] The index of the child that is responsible for rendering DataTips. | ChartBase
 | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
 | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ChartBase()
Constructor.
ChartBase
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
ChartBase
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
localToData(pt:Point):Array
Converts a coordinate on screen to a tuple of data values.
ChartBase
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
 | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
 | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
 | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
 | invalidateData():void This method triggers a redraw of the chart. | ChartBase
 | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
 | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
 | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
 | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
 | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
 | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
 | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. Each series in the chart draws a CSS type selector from the list contained in the chartSeriesStyles style. The first series uses the first selector, the second uses the second, and so on. Style properties in this type selector can be overridden by specifying a styleName property for the series. | ChartBase
 | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. The default value is 0x0B333C. | ChartBase
 | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. If set to null, no Stroke is drawn | ChartBase
 | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. This class must implement the IFlexDisplayObject and IDataRenderer interfaces. The chart assigns the custom data tip's data property to be the HitData structure describing the data point being described. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. The fill can be either a simple color value or an object that implements the mx.graphics.IFill interface. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
 | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". | ChartBase
 | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. The default value is 10. | ChartBase
 | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". | ChartBase
 | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". | ChartBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. If more datapoints are in range of the chart than allowed by this style, they will be prioritized by distance, with the closest showing first. The default value is NaN, which shows whatever datatips are within range. | ChartBase
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
 | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. The default value for the Tree control is 2. | ChartBase
 | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. | ChartBase
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
 | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
allElements property
protected var allElements:Array

The set of all chart elements displayed in the chart. This includes series, second series, background elements, annotation elements, etc.

annotationElements property
annotationElements:Array [read-write]

Sets an Array of ChartElements that appears on top of any data series rendered by the chart. Each item in the Array must subclass the mx.charts.DualStyleObject class and implement the IChartElement interface.

Implementation
    public function get annotationElements():Array
    public function set annotationElements(value:Array):void
backgroundElements property
backgroundElements:Array [read-write]

Sets an Array of background chart elements that appear below any data series rendered by the chart. Each item in the Array must subclass the mx.charts.DualStyleObject class and implement the IChartElement interface.

Implementation
    public function get backgroundElements():Array
    public function set backgroundElements(value:Array):void
chartState property
chartState:uint [read-only]

The current transition state of the chart. This property can be used to determine whether the chart is currently transitioning out its old data, transitioning in its new data, or has completed all transitions and is showing its current data set. See the mx.charts.chartClasses.ChartState enumeration for possible values.

Implementation
    public function get chartState():uint
clipContent property
clipContent:Boolean [read-write]

Determines if Flex clips the chart to the area bounded by the axes. Set to false to clip the chart. Set to true to avoid clipping when the data is rendered.

Implementation
    public function get clipContent():Boolean
    public function set clipContent(value:Boolean):void
dataProvider property
dataProvider:Object [read-write]

Specifies the data provider for the chart. Data series rendered by the chart are assigned this data provider. To render disparate data series in the same chart, use the dataProvider property on the individual series.

This property can accept an Array or any other object that implements the IList or ICollectionView interfaces.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
dataRegion property
dataRegion:Rectangle [read-only]

The area of the chart used to display data. This rectangle excludes the area used for gutters, axis lines and labels, and padding.

Implementation
    protected function get dataRegion():Rectangle
dataTipFunction property
public var dataTipFunction:Function

Specifies a callback method used to generate DataTips from values. This method should use the following signature:

   function dataTipFunction(hitData:Hit):String

This method returns a String that is displayed for each data point. The text can include HTML formatting. The single parameter is a HitData object that describes the data point.

dataTipLayerIndex property
dataTipLayerIndex:int [read-only]

The index of the child that is responsible for rendering DataTips. Derived classes that add additional visual elements to the chart should add it below this layer.

Implementation
    protected function get dataTipLayerIndex():int
dataTipMode property
dataTipMode:String [read-write]

Specifies how Flex displays DataTip controls for the chart. DataTip controls are similar to ToolTips, except that they display an appropriate value representing the nearest chart data point under the mouse pointer.

Different chart elements might show different styles of DataTip controls. For example, a stacked chart element might show both the values of the column and the percentage it contributes to the whole.

You can customize DataTip controls with the dataTipFunction property. Possible values are:

  • "single" - dataTips are shown for the closest dataPoint to the mouse cursor.
  • multiple - dataTips are shown for any dataTip within range of the mouse cursor. You can control the sensitivity with the mouseSensitivity property.

Implementation
    public function get dataTipMode():String
    public function set dataTipMode(value:String):void
description property
description:String [read-write]

A short description of the data described by the chart. Screen Readers use this property to describe the chart when accessibility is enabled.

This string defaults to the empty string, and must be explicitly assigned by the developer to have meaning.

Implementation
    public function get description():String
    public function set description(value:String):void
labelElements property
protected var labelElements:Array

The set of DisplayObjects representing the labels for the chart elements. Some series, annotation, and background types include overlays like elements, callouts, etc. If an element wants to display these overlays on top of all elements in the chart, they can pass a DisplayObject to the chart containing the overlays to be placed on top of all other chart elememnts. Chart implementors can access these overlay objects in the labelElements Array.

legendData property
legendData:Array [read-only]

An Array of Legend items.

This property can be used as the source for data binding.

Implementation
    public function get legendData():Array
mouseSensitivity property
public var mouseSensitivity:Number = 5

Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. Flex considers any data point less than mouseSensitivity pixels away to be under the mouse pointer. This value is also used by the findDataPoints method.

The default value is 5.

series property
series:Array [read-write]

An Array of Series objects that define the chart data. Each chart defines the type of Series objects that you use to populate this array. For example, a ColumnChart expects ColumnSeries objects as part of this Array. Some charts accept any object of type IChartElement as part of the Array, but in general each chart expects a specific type.

Implementation
    public function get series():Array
    public function set series(value:Array):void
seriesFilters property
seriesFilters:Array [read-write]

An Array of filters that are applied to all series in the chart. Assign an Array of Bitmap Filters to this property to apply them to all the series at once. Set the seriesFilter property to an empty Array to clear the default filters on the chart's series. Assigning filters to the seriesFilters property, which applies to all series, is more efficient than assigning them on individual series.

Implementation
    public function get seriesFilters():Array
    public function set seriesFilters(value:Array):void
showDataTips property
showDataTips:Boolean [read-write]

Specifies whether Flex shows DataTip controls for the chart. DataTip controls are similar to ToolTips, except that they display an appropriate value representing the nearest chart data point under the mouse pointer.

Different chart elements might show different styles of DataTip controls. For example, a stacked chart element might show both the values of the column and the percentage it contributes to the whole.

You can customize DataTip controls with the dataTipFunction property.

Implementation
    public function get showDataTips():Boolean
    public function set showDataTips(value:Boolean):void
transforms property
transforms:Array [read-write]

The DataTransforms managed by this chart. Each chart contains one or more data transform, representing a set of axes used to map from tuples from data space to screen space and vice-versa. Most charts only have a single DataTransform, but CartesianCharts that support second axes may manage a second DataTransform as needed.

Implementation
    protected function get transforms():Array
    protected function set transforms(value:Array):void
Constructor detail
ChartBase () constructor
public function ChartBase()

Constructor.

Method detail
applySeriesSet () method
protected function applySeriesSet(seriesSet:Array, transform:DataTransform):Array

Preprocesses the series and transform for display. You typically don't call this method directly. Instead, this function is called automatically during the chart's commitProperties() cycle when the series have been invalidated by a call to invalidateSeries().

By default, this method calls the customizeSeries() method once for each series in the set. Chart subclasses can override this function to add customization logic global to the whole series set.

Parameters
seriesSet:Array — An Array of series to preprocess.
transform:DataTransform — The transform used by the series.

Returns
Array — An Array of series with the series set applied.
customizeSeries () method
protected function customizeSeries(seriesGlyph:Series, i:uint):void

Applies per-series customization and formatting to the series of the chart. This method is called once for each series when the series have been changed by a call to the invalidateSeries() method.

Parameters
seriesGlyph:Series — The series to customize.
i:uint — The series' index in the series Array.
dataToLocal () method
public function dataToLocal(... dataValues):Point

Converts a tuple of data values to an x-y coordinate on screen. Call this function to transform data on to the screen using the same transform that the individual elements go through. For example, to create a custom highlight for a data region of a chart, you might use this function to determine the on-screen coordinates of the range of interest.

For Cartesian charts, you typically pass two values. The first value maps to the horizontal axis, and the second value maps to the vertical axis.

For polar charts, the first value maps to the angular axis, and the second maps to the radial axis.

Parameters
... dataValues

Returns
Point — Coordinates that are relative to the chart.
findDataPoints () method
public function findDataPoints(x:Number, y:Number):Array

Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method. The x and y arguments should be values in the ChartBase's coordinate system.

This method adheres to the limits specified by the mouseSensitivity property of the ChartBase object when looking for nearby data points.

Parameters
x:Number — The x coordinate relative to the ChartBase object.
y:Number — The y coordinate relative to the ChartBase object.

Returns
Array — An Array of HitData objects.

See also

mx.charts.HitData
getAxis () method
public function getAxis(dimension:String):IAxis

Retrieves the Axis instance for a particular dimension of the chart. This is a low level accessor. You typically retrieve the Axis directly through a named property (such as horizontalAxis, verticalAxis, or radiusAxis).

Parameters
dimension:String

Returns
IAxis
hideData () method
public function hideData():void

Informs the chart that the underlying data being displayed in the chart has been changed. Chart series and elements call this function when their rendering has changed in order to trigger a coordinated execution of show and hide data effects. You typically do not call this method on the chart directly.

invalidateChildOrder () method
protected function invalidateChildOrder():void

Informs the chart that its child list has been modified and should be re-ordererd. Derived chart classes can call this method to trigger a call to its updateChildOrder() method on the next commitProperties() cycle.

invalidateData () method
protected function invalidateData():void

This method triggers a redraw of the chart. Call this method when you add or change the chart's series or data providers.

invalidateSeries () method
protected function invalidateSeries():void

Informs the chart that its series Array has been modified and should be re-processed. Derived chart classes can call this method to trigger a call to its updateSeries() method on the next commitProperties cycle.

invalidateSeriesStyles () method
public function invalidateSeriesStyles():void

Triggers a redraw of the chart. Call this method when you change the style properties of the chart's series.

legendDataChanged () method
public function legendDataChanged():void

Dispatches a new LegendDataChanged event.

localToData () method
public function localToData(pt:Point):Array

Converts a coordinate on screen to a tuple of data values. Call this function to determine what data values a particular point on-screen represents.

Individual chart types determine how this transformation occurs. The point should be relative to the chart's coordinate space.

Parameters
pt:Point — The Point to convert.

Returns
Array — The tuple of data values.
positionDataTips () method
protected function positionDataTips():void

Defines the locations of DataTips on the chart. This method ensures that DataTips do not overlap each other (if multiple DataTips are visible) or their target data items.

setActualSize () method
public override function setActualSize(w:Number, h:Number):void

Sizes the object. Unlike directly setting the width and height properties, calling the setActualSize() method does not set the explictWidth and explicitHeight properties, so a future layout calculation may result in the object returning to its previous size. This method is used primarily by component developers implementing the updateDisplayList() method, by Effects, and by the LayoutManager.

Parameters
w:Number — Width of the object.
h:Number — Height of the object.
setAxis () method
public function setAxis(dimension:String, value:IAxis):void

Assigns an axis instance to a particular dimension of the chart. This is a low level accessor. You typically set the Axis directly through a named property (such as horizontalAxis, verticalAxis, or radiusAxis).

Parameters
dimension:String
value:IAxis
Event detail
itemClick event
Event object type: mx.charts.events.ChartItemEvent

Dispatched when a data point is found under the mouse pointer when it is clicked. Flex considers only data points within the radius determined by the mouseSensitivity property.

itemDoubleClick event
Event object type: mx.charts.events.ChartItemEvent

Dispatched when a data point is found under the mouse pointer when it is double clicked. Flex considers only data points within the radius determined by the mouseSensitivity property.

itemMouseDown event
Event object type: mx.charts.events.ChartItemEvent

Dispatched when a data point is found under the mouse pointer when it is pressed down. Flex considers only data points within the radius determined by the mouseSensitivity property.

itemMouseMove event
Event object type: mx.charts.events.ChartItemEvent

Dispatched when the mouse pointer moves while over a data point. Flex considers only data points within the radius determined by the mouseSensitivity property.

itemMouseUp event
Event object type: mx.charts.events.ChartItemEvent

Dispatched when a data point is found under the mouse pointer when it is released. Flex considers only data points within the radius determined by the mouseSensitivity property.

itemRollOut event
Event object type: mx.charts.events.ChartItemEvent

Dispatched when the closest data point under the mouse pointer changes. Flex considers only data points within the radius determined by the mouseSensitivity property.

itemRollOver event
Event object type: mx.charts.events.ChartItemEvent

Dispatched when a new data point is found under the mouse pointer. Flex only considers data points within the radius determined by the mouseSensitivity property.


mx.charts.chartClasses.ChartElement (Flex™ 2 Language Reference)

Class ChartElement | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class ChartElement
Inheritance | ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IChartElement
Subclasses | GridLines, Series

The ChartElement class is the base class for visual chart elements.

See also

Adding ChartElement objects

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
 | chartDataProvider : Object [write-only] The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
 | dataTransform : DataTransform The data dataTransform the element is associated with. | ChartElement
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | labelContainer : Sprite [read-only] The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | chart : ChartBase [read-only] Refers to the chart component containing this element. | ChartElement
 | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ChartElement()
Constructor.
ChartElement
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
ChartElement
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
 | createDataID(dataPointID:Number):Number Creates a unique id to represent the a dataPoint for comparison purposes. | ChartElement
 | dataChanged():void Indicates the underlying data represented by the element has changed. | ChartElement
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | processNewDataProvider(value:Object):void Called when a new dataProvider is assigned to the element. | ChartElement
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
chart property
chart:ChartBase [read-only]

Refers to the chart component containing this element.

Implementation
    protected function get chart():ChartBase
chartDataProvider property
chartDataProvider:Object [write-only]

The data provider assigned to the enclosing chart. Element types can choose to inherit the data provider from the enclosing chart if necessary, or allow developers to assign data providers specifically to the element. Not all elements are necessarily driven by a data provider.

Implementation
    public function set chartDataProvider(value:Object):void
cursor property
protected var cursor:IViewCursor

Each ChartElement carries a cursor associated with their dataProvider for their own internal use. ChartElements have sole ownership of this cursor; they can assume no other code will modify its position.

dataProvider property
dataProvider:Object [read-write]

A data provider assigned to the this specific element. In general, elements inherit the dataProvider from the enclosing chart. But individual elements can override with a specific dataProvider of their own.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
dataTransform property
dataTransform:DataTransform [read-write]

The data dataTransform the element is associated with. A data dataTransform represents an association between a set of elements and a set of axis objects used to dataTransform those elements from data space to screen coordinates and back. A chart element uses its associated dataTransform to calculate how to render its data.

Implementation
    public function get dataTransform():DataTransform
    public function set dataTransform(value:DataTransform):void
labelContainer property
labelContainer:Sprite [read-only]

The DisplayObject that displays labels rendered by this element. In most cases, labels displayed in the data area of a chart are rendered on top of all elements rather than interleaved with the data. If an implementing Element has labels to display, it can place them in a Sprite object and return it as the value of the labelContainer property. Enclosing charts will labelContainers from all enclosed elements and place them in the data area above all other elements.

Implementation
    public function get labelContainer():Sprite
Constructor detail
ChartElement () constructor
public function ChartElement()

Constructor.

Method detail
addChild () method
public override function addChild(child:DisplayObject):DisplayObject

Adds a child DisplayObject after the end of this child list.

Calling childList.addChild(child) is the same as calling childList.addChild(child, childList.numChildren) After it has been added, its index of the new child will be (child.numChildren - 1)

Parameters
child:DisplayObject — The DisplayObject to add as a child.

Returns
DisplayObject — The child that was added; this is the same as the argument passed in.
addChildAt () method
public override function addChildAt(child:DisplayObject, index:int):DisplayObject

Adds a child DisplayObject instance to this DisplayObjectContainer instance. The child is added at the index position specified. An index of 0 represents the back (bottom) of the display list for this DisplayObjectContainer object.

If you add a child object that already has a different display object container as a parent, the object is removed from the child list of the other display object container.

Parameters
child:DisplayObject — The DisplayObject instance to add as a child of this DisplayObjectContainer instance.
index:int — The index position to which the child is added. If you specify a currently occupied index position, the child object that exists at that position and all higher positions are moved up one position in the child list.

Returns
DisplayObject — The DisplayObject instance that you pass in the child parameter.
chartStateChanged () method
public function chartStateChanged(oldState:uint, v:uint):void

Called by the enclosing chart to indicate that the current state of the chart has changed. Implementing elements should respond to this method in order to synchronize changes to the data displayed by the element.

Parameters
oldState:uint — An integer representing the previous state.
v:uint — An integer representing the new state.
claimStyles () method
public function claimStyles(styles:Array, firstAvailable:uint):uint

Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array. Each chart has an associated set of selectors that are implicitly assigned to contained elements that require them. Implementing this function gives an element a chance to 'claim' elements out of that set, as necessary. An element that requires N style selectors claims the values from styles[firstAvailable] to styles[firstAvailable + N - 1]. Elements return the new value for firstAvailable after claiming any styles (for example, firstAvailable + N).

Parameters
styles:Array — An Array of styles to claim.
firstAvailable:uint — The first style selector in the Array to claim.

Returns
uint
collectTransitions () method
public function collectTransitions(chartState:Number, transitions:Array):void

Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state. The chart collects transitions from all elements and ensures that they play in parallel. It waits until all transitions have completed before advancing to another state. Implementors should append any necessary transitions to the transitions Array parameter.

Parameters
chartState:Number — The state at which the chart plays the new transitions.
transitions:Array — An Array of transition to add to the chart's list of transitions to play.
createDataID () method
protected function createDataID(dataPointID:Number):Number

Creates a unique id to represent the a dataPoint for comparison purposes. Derived classes can call this function with a locally unique data point ID to generate an ID that is unique across the application.

Parameters
dataPointID:Number

Returns
Number
dataChanged () method
protected function dataChanged():void

Indicates the underlying data represented by the element has changed. You should call this method whenever the data your series or element is displaying changes. It gives any associated axes a chance to update their ranges if appropriate.

describeData () method
public function describeData(dimension:String, requiredFields:uint):Array

Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. Implementors fill out and return an Array of mx.charts.chartClasses.DataDescription objects to guarantee that their data is correctly accounted for by any axes that are autogenerating values from the displayed data (such as minimum, maximum, interval, and unitSize). Most element types return an Array containing a single DataDescription. Aggregate elements, such as BarSet and ColumnSet, might return mutiple DataDescription instances that describe the data displayed by their subelements. When called, the implementor describes the data along the axis indicated by the dimension argument. This function might be called for each axis supported by the containing chart.

Parameters
dimension:String — Determines the axis to get data descriptions of.
requiredFields:uint — A bitfield that indicates which values of the DataDescription object the particular axis cares about. Implementors can optimize by only calculating the necessary fields.

Returns
Array
findDataPoints () method
public function findDataPoints(x:Number, y:Number, sensitivity2:Number):Array

Finds the closest data point represented by the element under the given coordinates.

This method returns either an array of HitData structures describing the datapoints within range. Individual ChartElements may choose to only return a single dataPoint if their dataPoints are guaranteed not to overlap.

Parameters
x:Number — The X coordinate.
y:Number — The Y coordinate.
sensitivity2:Number — How close, in pixels, the pointer must be to the exact coordinates to be considered "under". This property is similar to the value of the mouseSensitivity property of the chart control.

Returns
Array
mappingChanged () method
public function mappingChanged():void

Called when the mapping of one or more associated axes changes. The DataTransform assigned to this ChartElement will call this method when any of the axes it represents is modified in some way.

processNewDataProvider () method
protected function processNewDataProvider(value:Object):void

Called when a new dataProvider is assigned to the element. Subclassers can override and define custom behavior when a new dataProvider is assigned. This method will be called when either the dataProvider property is set, or when the chartDataProvider property is set if no specific dataProvider has been assigned directly.

Parameters
value:Object


mx.charts.chartClasses.ChartLabel (Flex™ 2 Language Reference)

Class ChartLabel | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class ChartLabel
Inheritance | ChartLabel Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

Draws data labels on chart controls.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object Defines the contents of the label. | ChartLabel
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ChartLabel()
Constructor.
ChartLabel
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
ChartLabel
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
 | createChildren():void Create child objects of the component. | ChartLabel
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Calculates the default size, and optionally the default minimum size, of the component. | ChartLabel
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | ChartLabel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

Defines the contents of the label.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
ChartLabel () constructor
public function ChartLabel()

Constructor.

Method detail
createChildren () method
protected override function createChildren():void

Create child objects of the component. This is an advanced method that you might override when creating a subclass of UIComponent.

A component that creates other components or objects within it is called a composite component. For example, the Flex ComboBox control is actually made up of a TextInput control to define the text area of the ComboBox, and a Button control to define the ComboBox arrow. Components implement the createChildren() method to create child objects (such as other components) within the component.

From within an override of the createChildren() method, you call the addChild() method to add each child object.

You do not call this method directly. Flex calls the createChildren() method in response to the call to the addChild() method to add the component to its parent.

invalidateSize () method
public override function invalidateSize():void

Marks a component so that its measure() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the text and font size, it would be wasteful to update the text immediately after you change it and then update the size when it gets set. It is more efficient to change both properties and then render the text with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

measure () method
protected override function measure():void

Calculates the default size, and optionally the default minimum size, of the component. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the measure() method when the component is added to a container using the addChild() method, and when the component's invalidateSize() method is called.

When you set a specific height and width of a component, Flex does not call the measure() method, even if you explicitly call the invalidateSize() method. That is, Flex only calls the measure() method if the explicitWidth property or the explicitHeight property of the component is NaN.

In your override of this method, you must set the measuredWidth and measuredHeight properties to define the default size. You may optionally set the measuredMinWidth and measuredMinHeight properties to define the default minimum size.

Most components calculate these values based on the content they are displaying, and from the properties that affect content display. A few components simply have hard-coded default values.

The conceptual point of measure() is for the component to provide its own natural or intrinsic size as a default. Therefore, the measuredWidth and measuredHeight properties should be determined by factors such as:

  • The amount of text the component needs to display.
  • The styles, such as fontSize, for that text.
  • The size of a JPEG image that the component displays.
  • The measured or explicit sizes of the component's children.
  • Any borders, margins, and gaps.

In some cases, there is no intrinsic way to determine default values. For example, a simple GreenCircle component might simply set measuredWidth = 100 and measuredHeight = 100 in its measure() method to provide a reasonable default size. In other cases, such as a TextArea, an appropriate computation (such as finding the right width and height that would just display all the text and have the aspect ratio of a Golden Rectangle) might be too time-consuming to be worthwhile.

The default implementation of measure() is to set the default size to the current size of the component.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.


mx.charts.chartClasses.ChartState (Flex™ 2 Language Reference)

Class ChartState | Properties | Methods | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public final class ChartState
Inheritance | ChartState Inheritance Object

Describes the current state of a chart. Series implementations can examine the Chart.state value to determine whether the chart is showing or hiding data, and how to render in response.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HIDING_DATA : uint = 2 [static] The chart is currently running transitions to hide the old chart data. | ChartState
 | NONE : uint = 0 [static] No state. | ChartState
 | PREPARING_TO_HIDE_DATA : uint = 1 [static] The display of data has changed in the chart, and it is about to begin a transition to hide the current data. | ChartState
 | PREPARING_TO_SHOW_DATA : uint = 3 [static] The chart has finished any transitions to hide the old data, and is preparing to run transitions to display the new data | ChartState
 | SHOWING_DATA : uint = 4 [static] The chart is currently running transitions to show the new chart data. | ChartState
Constant detail
HIDING_DATA constant
public static const HIDING_DATA:uint = 2

The chart is currently running transitions to hide the old chart data.

NONE constant
public static const NONE:uint = 0

No state. The chart is simply showing its data.

PREPARING_TO_HIDE_DATA constant
public static const PREPARING_TO_HIDE_DATA:uint = 1

The display of data has changed in the chart, and it is about to begin a transition to hide the current data.

PREPARING_TO_SHOW_DATA constant
public static const PREPARING_TO_SHOW_DATA:uint = 3

The chart has finished any transitions to hide the old data, and is preparing to run transitions to display the new data

SHOWING_DATA constant
public static const SHOWING_DATA:uint = 4

The chart is currently running transitions to show the new chart data.


mx.charts.chartClasses.DataDescription (Flex™ 2 Language Reference)

Class DataDescription | Properties | Methods | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class DataDescription
Inheritance | DataDescription Inheritance Object

The DataDescription structure is used by ChartElements to describe the characteristics of the data they represent to Axis objects that auto-generate values from the data represented in the chart. ChartElements displaying data should construct and return DataDescriptions from their describeData() method when invoked.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | boundedValues : Array An Array of BoundedValue objects describing the data in the element. | DataDescription
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | max : Number The maximum data value displayed by the element. | DataDescription
 | min : Number The minimum data value displayed by the element. | DataDescription
 | minInterval : Number The minimum interval, in data units, between any two values displayed by the element. | DataDescription
 | padding : Number The amount of padding, in data units, that the element requires beyond its min/max values to display its full values correctly . | DataDescription
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataDescription() Constructor. | DataDescription
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | REQUIRED_BOUNDED_VALUES : uint = 0x2 [static] A bitflag passed by the axis to an element's describeData() method. | DataDescription
 | REQUIRED_MIN_INTERVAL : uint = 0x1 [static] A bitflag passed by the axis to an element's describeData() method. | DataDescription
 | REQUIRED_MIN_MAX : uint = 0x4 [static] A bitflag passed by the axis to an element's describeData() method. | DataDescription
 | REQUIRED_PADDING : uint = 0x8 [static] A bitflag passed by the axis to an element's describeData() method. | DataDescription
Property detail
boundedValues property
public var boundedValues:Array

An Array of BoundedValue objects describing the data in the element. BoundedValues are data points that have extra space reserved around the datapoint in the chart's data area. If requested, a chart element fills this property with whatever BoundedValues are necessary to ensure enough space is visible in the chart data area. For example, a ColumnSeries that needs 20 pixels above each column to display a data label.

max property
public var max:Number

The maximum data value displayed by the element.

min property
public var min:Number

The minimum data value displayed by the element.

minInterval property
public var minInterval:Number

The minimum interval, in data units, between any two values displayed by the element.

padding property
public var padding:Number

The amount of padding, in data units, that the element requires beyond its min/max values to display its full values correctly .

Constructor detail
DataDescription () constructor
public function DataDescription()

Constructor.

Constant detail
REQUIRED_BOUNDED_VALUES constant
public static const REQUIRED_BOUNDED_VALUES:uint = 0x2

A bitflag passed by the axis to an element's describeData() method. If this flag is set, the element sets the boundedValues property.

REQUIRED_MIN_INTERVAL constant
public static const REQUIRED_MIN_INTERVAL:uint = 0x1

A bitflag passed by the axis to an element's describeData() method. If this flag is set, the element sets the minInterval property.

REQUIRED_MIN_MAX constant
public static const REQUIRED_MIN_MAX:uint = 0x4

A bitflag passed by the axis to an element's describeData() method. If this flag is set, the element sets the DescribeData.min and DescribeData.max properties.

REQUIRED_PADDING constant
public static const REQUIRED_PADDING:uint = 0x8

A bitflag passed by the axis to an element's describeData() method. If this flag is set, the element sets the DescribeData.padding property.


mx.charts.chartClasses.DataTip (Flex™ 2 Language Reference)

Class DataTip | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class DataTip
Inheritance | DataTip Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

The DataTip control provides information about a data point to chart users. When a user moves their mouse over a graphical element, the DataTip control displays text that provides information about the element. You can use DataTip controls to guide users as they work with your application or customize the DataTips to provide additional functionality.

To enable DataTips on a chart, set its showDataTips property to true.

See also

Using DataTips

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The HitData structure describing the data point that the DataTip is rendering. | DataTip
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxTipWidth : Number = 300 [static] Specifies the maximum width of the bounding box, in pixels, for new DataTip controls. | DataTip
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataTip()
Constructor.
DataTip
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
 | createChildren():void Create child objects of the component. | DataTip
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Calculates the default size, and optionally the default minimum size, of the component. | DataTip
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | DataTip
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
 | hide | Dispatched when an object's state changes from visible to invisible. | DataTip
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | show | Dispatched when the component becomes visible. | DataTip
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of the component. You can either have a backgroundColor or a backgroundImage, but not both. Note that some components, like a Button, do not have a background because they are completely filled with the button face or other graphics. The DataGrid control also ignores this style. The default value is undefined. If both this style and the backgroundImage style are undefined, the control has a transparent background. 		DataTip
borderColor
Type: uint Format: Color CSS Inheritance: no
Black section of a three-dimensional border, or the color section of a two-dimensional border. The following components support this style: Button, CheckBox, ComboBox, MenuBar, NumericStepper, ProgressBar, RadioButton, ScrollBar, Slider, and all components that support the borderStyle style. The default value depends on the component class; if not overriden for the class, it is 0xAAB3B3. 		DataTip
borderStyle
Type: String CSS Inheritance: no
Bounding box style. The possible values are "none", "solid", "inset" and "outset". The default value is "inset".

Note: The borderStyle style is not supported by the Button control or the Panel container. To make solid border Panels, set the borderThickness property, and set the dropShadow property to false if desired.

DataTip
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Text color of a component label. The default value is 0x0B333C. 		DataTip
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		DataTip
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		DataTip
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		DataTip
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		DataTip
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		DataTip
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DataTip
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		DataTip
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		DataTip
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DataTip
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		DataTip
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

DataTip
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingBottom
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the datatip's bottom border and its content area. The default value is 0. 		DataTip
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

DataTip
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

DataTip
paddingTop
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the datatip's top border and its content area. The default value is 0. 		DataTip
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowColor
Type: uint Format: Color CSS Inheritance: yes
Bottom inside color of a button's skin. A section of the three-dimensional border. The default value is 0xEEEEEE (light gray). 		DataTip
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

DataTip
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		DataTip
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		DataTip
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The HitData structure describing the data point that the DataTip is rendering.

Implementation
    public function get data():Object
    public function set data(value:Object):void
maxTipWidth property
public static var maxTipWidth:Number = 300

Specifies the maximum width of the bounding box, in pixels, for new DataTip controls.

The default value is 300.

Constructor detail
DataTip () constructor
public function DataTip()

Constructor.

Method detail
createChildren () method
protected override function createChildren():void

Create child objects of the component. This is an advanced method that you might override when creating a subclass of UIComponent.

A component that creates other components or objects within it is called a composite component. For example, the Flex ComboBox control is actually made up of a TextInput control to define the text area of the ComboBox, and a Button control to define the ComboBox arrow. Components implement the createChildren() method to create child objects (such as other components) within the component.

From within an override of the createChildren() method, you call the addChild() method to add each child object.

You do not call this method directly. Flex calls the createChildren() method in response to the call to the addChild() method to add the component to its parent.

measure () method
protected override function measure():void

Calculates the default size, and optionally the default minimum size, of the component. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the measure() method when the component is added to a container using the addChild() method, and when the component's invalidateSize() method is called.

When you set a specific height and width of a component, Flex does not call the measure() method, even if you explicitly call the invalidateSize() method. That is, Flex only calls the measure() method if the explicitWidth property or the explicitHeight property of the component is NaN.

In your override of this method, you must set the measuredWidth and measuredHeight properties to define the default size. You may optionally set the measuredMinWidth and measuredMinHeight properties to define the default minimum size.

Most components calculate these values based on the content they are displaying, and from the properties that affect content display. A few components simply have hard-coded default values.

The conceptual point of measure() is for the component to provide its own natural or intrinsic size as a default. Therefore, the measuredWidth and measuredHeight properties should be determined by factors such as:

  • The amount of text the component needs to display.
  • The styles, such as fontSize, for that text.
  • The size of a JPEG image that the component displays.
  • The measured or explicit sizes of the component's children.
  • Any borders, margins, and gaps.

In some cases, there is no intrinsic way to determine default values. For example, a simple GreenCircle component might simply set measuredWidth = 100 and measuredHeight = 100 in its measure() method to provide a reasonable default size. In other cases, such as a TextArea, an appropriate computation (such as finding the right width and height that would just display all the text and have the aspect ratio of a Golden Rectangle) might be too time-consuming to be worthwhile.

The default implementation of measure() is to set the default size to the current size of the component.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Event detail
hide event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.HIDE

Dispatched when an object's state changes from visible to invisible.

The FlexEvent.HIDE constant defines the value of the type property of the event object for a hide event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
show event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.SHOW

Dispatched when the component becomes visible.

The FlexEvent.SHOW constant defines the value of the type property of the event object for a show event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.charts.chartClasses.DataTransform (Flex™ 2 Language Reference)

Class DataTransform | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class DataTransform
Inheritance | DataTransform Inheritance EventDispatcher Inheritance Object
Subclasses | CartesianTransform, PolarTransform

The DataTransform object represents a portion of a chart that contains glyphs and can transform values to screen coordinates and vice versa. Each DataTransform object has a horizontal axis, a vertical axis, and a set of glyphs (background, data, and overlay) to render.

In theory, a chart can contain multiple overlaid DataTransform objects. This allows you to display a chart with multiple data sets rendered in the same area but with different ranges. For example, you might want to show monthly revenues compared to the number of units sold. If revenue was typically in millions while units was typically in the thousands, it would be difficult to render these effectively along the same range. Overlaying them in different DataTransform objects allows the end user to compare trends in the values when they are rendered with different ranges.

Charts can only contain one set of DataTransform.

Most of the time, you will use the ChartBase object, which hides the existance of the DataTransform object between the chart and its contained glyphs and axis objects. If you create your own ChartElement objects, you must understand the methods of the DataTransform class to correctly implement their element.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | axes : Object [read-only] The set of axes associated with this transform. | DataTransform
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | elements : Array The elements that are associated with this transform. | DataTransform
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataTransform()
Constructor.
DataTransform
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
dataChanged():void
Informs the DataTransform that some of the underlying data being represented on the chart has changed.
DataTransform
describeData(dimension:String, requiredFields:uint):Array
Collects important displayed values for all elements associated with this data transform.
DataTransform
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getAxis(dimension:String):IAxis
Retrieves the axis instance responsible for transforming the data dimension specified by the dimension parameter.
DataTransform
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
invertTransform(... values):Array
Transforms x and y coordinates relative to the DataTransform coordinate system into a two-dimensional value in data space.
DataTransform
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setAxis(dimension:String, v:IAxis):void
Assigns an axis instance to a particular dimension of the transform.
DataTransform
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String):void
Maps a set of numeric values representing data to screen coordinates.
DataTransform
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | transformChange | Dispatched when the transformation from data space to screen space has changed, typically either because the axes that make up the transformation have changed in some way, or the data transform itself has size. | DataTransform
Property detail
axes property
axes:Object [read-only]

The set of axes associated with this transform.

Implementation
    public function get axes():Object
elements property
elements:Array [read-write]

The elements that are associated with this transform. This Array includes background, series, and overlay elements associated with the transform. This value is assigned by the enclosing chart object.

Implementation
    public function get elements():Array
    public function set elements(value:Array):void
Constructor detail
DataTransform () constructor
public function DataTransform()

Constructor.

Method detail
dataChanged () method
public function dataChanged():void

Informs the DataTransform that some of the underlying data being represented on the chart has changed. The DataTransform generally has no knowledge of the source of the underlying data being represented by the chart, so glyphs should call this when their data changes so that the DataTransform can recalculate range scales based on their data. This does not invalidate the DataTransform, because there is no guarantee the data has changed. The axis objects (or range objects) must trigger an invalidate event.

describeData () method
public function describeData(dimension:String, requiredFields:uint):Array

Collects important displayed values for all elements associated with this data transform. Axis instances call this method to collect the values they need to consider when auto-generating appropriate ranges. This method returns an Array of BoundedValue objects.

To collect important values for the horizontal axis of a CartesianTransform, pass 0. To collect values for the vertical axis, pass 1.

Parameters
dimension:String — The dimension to collect values for.
requiredFields:uint — Defines the data that are required by this transform.

Returns
Array — A Array of BoundedValue objects.
getAxis () method
public function getAxis(dimension:String):IAxis

Retrieves the axis instance responsible for transforming the data dimension specified by the dimension parameter. If no axis has been previously assigned, a default axis is created. The default axis for all dimensions is a LinearAxis with the autoAdjust property set to false.

Parameters
dimension:String — The dimension whose axis is responsible for transforming the data.

Returns
IAxis — The axis instance.

See also

mx.charts.LinearAxis
invertTransform () method
public function invertTransform(... values):Array

Transforms x and y coordinates relative to the DataTransform coordinate system into a two-dimensional value in data space.

Parameters
... values

Returns
Array
setAxis () method
public function setAxis(dimension:String, v:IAxis):void

Assigns an axis instance to a particular dimension of the transform. Axis objects are assigned by the enclosing chart object.

Parameters
dimension:String — The dimension of the transform.
v:IAxis — The target axis instance.
transformCache () method
public function transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String):void

Maps a set of numeric values representing data to screen coordinates. This method assumes the values are all numbers, so any non-numeric values must have been previously converted with the mapCache() method.

Parameters
cache:Array — An array of objects containing the data values in their fields. This is also where this function will store the converted numeric values.
xField:String — The field where the data values for the x axis can be found.
xConvertedField:String — The field where the mapped x screen coordinate will be stored.
yField:String — The field where the data values for the y axis can be found.
yConvertedField:String — The field where the mapped y screen coordinate will be stored.
Event detail
transformChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.TRANSFORM_CHANGE

Dispatched when the transformation from data space to screen space has changed, typically either because the axes that make up the transformation have changed in some way, or the data transform itself has size.

The FlexEvent.TRANSFORM_CHANGE constant defines the value of the type property of the event object for a transformChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.charts.chartClasses.DualStyleObject (Flex™ 2 Language Reference)

Class DualStyleObject | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class DualStyleObject
Inheritance | DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | AxisRenderer, ChartElement

The DualStyleObject class serves as a base class for components that have a need to assign class selectors outside of the client developer's control. DualStyleObject instances have two styleName properties...the standard styleName, and the additional internalStyleName. A component can assign the internalStyleName property as necessary and leave the styleName property for the client developer to assign.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

Common MXML Syntax Inherited from DualStyleObject

Flex components inherit the following properties from the DualStyleObject class:

  <mx:tagname

    internalStyleName="Style; No default"

  >

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
 | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DualStyleObject()
Constructor.
DualStyleObject
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
internalStyleName property
internalStyleName:Object [read-write]

The name of a class selector this instance inherits values from. The internalStyleName property has lower priority than the styleName selector.

Implementation
    public function get internalStyleName():Object
    public function set internalStyleName(value:Object):void
Constructor detail
DualStyleObject () constructor
public function DualStyleObject()

Constructor.


mx.charts.chartClasses.HLOCSeriesBase (Flex™ 2 Language Reference)

Class HLOCSeriesBase | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class HLOCSeriesBase
Inheritance | HLOCSeriesBase Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IColumn
Subclasses | CandlestickSeries, HLOCSeries

HLOCSeriesBase is the base class for the two financial series types, HLOCSeries and CandlestickSeries. Most of the behavior related to charting open, close, high and low values resides in this class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | closeField : String Specifies the field of the data provider that determines the y-axis location of the closing value of the element. | HLOCSeriesBase
 | columnWidthRatio : Number Specifies the width of elements relative to the category width. | HLOCSeriesBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
 | highField : String Specifies the field of the data provider that determines the y-axis location of the high value of the element. | HLOCSeriesBase
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
 | legendData : Array [read-only] An Array of LegendData instances that describe the items that should show up in a legend representing this series. | HLOCSeriesBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
 | lowField : String Specifies the field of the data provider that determines the y-axis location of the low value of the element. | HLOCSeriesBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxColumnWidth : Number Specifies the width of the elements, in pixels. | HLOCSeriesBase
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
 | offset : Number Specifies how far to offset the center of the elements from the center of the available space, relative to the category width. | HLOCSeriesBase
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | openField : String Specifies the field of the data provider that determines the y-axis location of the opening value of the element. | HLOCSeriesBase
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xField : String Specifies the field of the data provider that determines the x-axis location of the element. | HLOCSeriesBase
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | HLOCSeriesBase
 | renderData : Object [read-only] Stores the information necessary to render this series. | HLOCSeriesBase
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | HLOCSeriesBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HLOCSeriesBase()
Constructor.
HLOCSeriesBase
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
HLOCSeriesBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
HLOCSeriesBase
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
HLOCSeriesBase
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
styleChanged(styleProp:String):void
Detects changes to style properties.
HLOCSeriesBase
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
formatDataTip(hd:HitData):String
Generates a text description of a ChartItem suitable for display as a DataTip.
HLOCSeriesBase
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
HLOCSeriesBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
HLOCSeriesBase
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
HLOCSeriesBase
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
HLOCSeriesBase
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
HLOCSeriesBase
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
HLOCSeriesBase
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | itemRenderer | Type: mx.core.IFactory CSS Inheritance: no A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. | HLOCSeriesBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. | HLOCSeriesBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
closeField property
closeField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of the closing value of the element.

The default value is "".

Implementation
    public function get closeField():String
    public function set closeField(value:String):void
columnWidthRatio property
columnWidthRatio:Number [read-write]

Specifies the width of elements relative to the category width. A value of 1 uses the entire space, while a value of 0.6 uses 60% of the element's available space. You typically do not set this property directly. The actual element width used is the smaller of the columnWidthRatio and maxColumnWidth properties.

The default value is 0.65..

Implementation
    public function get columnWidthRatio():Number
    public function set columnWidthRatio(value:Number):void
highField property
highField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of the high value of the element.

The default value is "".

Implementation
    public function get highField():String
    public function set highField(value:String):void
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items.

Implementation
    protected function get itemType():Class
legendData property
legendData:Array [read-only]

An Array of LegendData instances that describe the items that should show up in a legend representing this series. Derived series classes override this getter and return LegendData specific to their styles and data representation method. While most series types return only a single LegendData instance, some series types, such as PieSeries and StackedSeries, return multiple instances representing individual items in the array, or multiple ways of rendering data.

Implementation
    public function get legendData():Array
lowField property
lowField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of the low value of the element.

The default value is "".

Implementation
    public function get lowField():String
    public function set lowField(value:String):void
maxColumnWidth property
maxColumnWidth:Number [read-write]

Specifies the width of the elements, in pixels. The actual element width used is the smaller of this style and the columnWidthRatio property. You typically do not set this value directly; it is assigned by the enclosing chart.

Implementation
    public function get maxColumnWidth():Number
    public function set maxColumnWidth(value:Number):void
offset property
offset:Number [read-write]

Specifies how far to offset the center of the elements from the center of the available space, relative to the category width. At the value of default 0, the elements are centered on the space. Set to -50 to center the element at the beginning of the available space. You typically do not set this property directly. The enclosing chart control manages this value based on the value of its columnWidthRatio property.

Implementation
    public function get offset():Number
    public function set offset(value:Number):void
openField property
openField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of the opening value of the element.

The default value is "".

Implementation
    public function get openField():String
    public function set openField(value:String):void
renderData property
renderData:Object [read-only]

Stores the information necessary to render this series.

Implementation
    protected function get renderData():Object
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
xField property
xField:String [read-write]

Specifies the field of the data provider that determines the x-axis location of the element. If set to the empty string (""), Flex renders the columns in the order they appear in the dataProvider.

The default value is "".

Implementation
    public function get xField():String
    public function set xField(value:String):void
Constructor detail
HLOCSeriesBase () constructor
public function HLOCSeriesBase()

Constructor.

Method detail
beginInterpolation () method
public override function beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object

Called by the SeriesInterpolate effect to initiate an interpolation. The effect passes in the source and destination data for the series to interpolate between. The effect passes the return value of this method repeatedly to the series's interpolate() method to advance the animation of the duration of the effect. The series calculates the data it needs to perform the interpolation and returns it in this method.

Parameters
sourceRenderData:Object — The source data for the series to interpolate between.
destRenderData:Object — The destination data for the series to interpolate between.

Returns
Object — The data the series needs to perform the interpolation.
describeData () method
public override function describeData(dimension:String, requiredFields:uint):Array

Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. Implementors fill out and return an Array of mx.charts.chartClasses.DataDescription objects to guarantee that their data is correctly accounted for by any axes that are autogenerating values from the displayed data (such as minimum, maximum, interval, and unitSize). Most element types return an Array containing a single DataDescription. Aggregate elements, such as BarSet and ColumnSet, might return mutiple DataDescription instances that describe the data displayed by their subelements. When called, the implementor describes the data along the axis indicated by the dimension argument. This function might be called for each axis supported by the containing chart.

Parameters
dimension:String — Determines the axis to get data descriptions of.
requiredFields:uint — A bitfield that indicates which values of the DataDescription object the particular axis cares about. Implementors can optimize by only calculating the necessary fields.

Returns
Array
formatDataTip () method
protected function formatDataTip(hd:HitData):String

Generates a text description of a ChartItem suitable for display as a DataTip.

Parameters
hd:HitData

Returns
String
getElementBounds () method
public override function getElementBounds(renderData:Object):void

Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series. Effect classes call this function to fill in these fields for use in implementing various effect types. Derived classes should implement this function to generate the bounds of the series's items only when requested.

Parameters
renderData:Object
getMissingInterpolationValues () method
protected override function getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void

Fills in missing values in an interpolation structure. When a series calls the initializeInterpolationData() method, it passes in an Array of source and destination values for the interpolation. If either of those two Arrays are incomplete, the series needs to provide "appropriate" placeholder values for the interpolation. How those placeholder values are determined is specific to the series type. Series extenders should override this method to provide those placeholder values.

Parameters
sourceProps:Object — An object containing the source values being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
srcCache:Array — The Array of source chart items that are being interpolated.
destProps:Object — An Object containing the destination values that are being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
destCache:Array — The Array of destination chart items that are being interpolated.
index:Number — The index of the item that is being populated in the cache.
customData:Object — The data that was passed by the series into the initializeInterpolationData() method.
styleChanged () method
public override function styleChanged(styleProp:String):void

Detects changes to style properties. When any style property is set, Flex calls the styleChanged() method, passing to it the name of the style being set.

This is an advanced method that you might override when creating a subclass of UIComponent. When you create a custom component, you can override the styleChanged() method to check the style name passed to it, and handle the change accordingly. This lets you override the default behavior of an existing style, or add your own custom style properties.

If you handle the style property, your override of the styleChanged() method should call the invalidateDisplayList() method to cause Flex to execute the component's updateDisplayList() method at the next screen update.

Parameters
styleProp:String — The name of the style property, or null if all styles for this component have changed.
updateData () method
protected override function updateData():void

This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider. If you implement custom series types, you should override this method and load all data necessary to render the series out of the backing data provider. You must also be sure to call the super.updateData() method in your subclass. You do not generally call this method directly. Instead, to guarantee that your data has been updated at a given point, call the validateData() method of the Series class.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
updateFilter () method
protected override function updateFilter():void

This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform. This can happen either because the underlying data has changed, or because the range of the associated axes have changed. If you implement a custom series type, you should override this method and filter out any outlying data using the filterCache() method of the axes managed by its associated DataTransform. The filterCache() method converts any values out of range to NaN. You must be sure to call the super.updateFilter() method in your subclass. You should not generally call this method directly. Instead, if you need to guarantee that your data has been filtered at a given point, call the validateTransform() method of the Series class. You can generally assume that your updateData() and updateMapping() methods have been called prior to this method, if necessary.

updateMapping () method
protected override function updateMapping():void

This method is called when the underlying data the series represents needs to be mapped to numeric representations. This can happen either because the underlying data has changed, or because the axes used to render the series have changed in some relevant way. If you implement a custom series, you should override this method and convert the data represented into numeric values using the mapCache() method of the axes managed by its associated DataTransform. You must also be sure to call the super.updateMapping() method in your subclass. You should not generally call this method directly. Instead, to guarantee that your data has been mapped at a given point, call the validateData() method of the Series class. You can generally assume that your updateData() method has been called prior to this method, if necessary.

updateTransform () method
protected override function updateTransform():void

This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform. This can happen either because the underlying data has changed, because the range of the associated axes have changed, or because the size of the area on screen has changed. If you implement a custom series type, you should override this method and transform the data using the transformCache() method of the associated DataTransform. You must be sure to call the super.updateTransform() method in your subclass. You should not generally call this method directly. Instead, if you need to guarantee that your data has been filtered at a given point, call the valiateTransform() method of the Series class. You can generally assume that your updateData(), updateMapping(), and updateFilter() methods have been called prior to this method, if necessary.


mx.charts.chartClasses.IAxis (Flex™ 2 Language Reference)

Interface IAxis | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Interface | public interface IAxis extends IEventDispatcher
Implementors | AxisRenderer, CategoryAxis, NumericAxis

The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.

Classes implement this interface to provide range definition functionality.

See also

mx.charts.CategoryAxis
mx.charts.LinearAxis

Public Properties
Property |  | Defined by
 | baseline : Number [read-only] The baseline position for the axis. | IAxis
 | chartDataProvider : Object [write-only] The data provider assigned to the enclosing chart. | IAxis
 | displayName : String [read-only] The name of the axis. | IAxis
 | title : String [read-only] The text for the title displayed along the axis. | IAxis
 | unitSize : Number [read-only] The size of one unit of data as represented by this axis. | IAxis
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
dataChanged():void
Triggers events that inform the range object when the chart data has changed.
IAxis
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
filterCache(cache:Array, field:String, filteredString:String):void
Filters a set of values of arbitrary type to a set of numbers that can be mapped.
IAxis
formatForScreen(value:Object):String
Formats values for display in DataTips.
IAxis
getLabelEstimate():AxisLabelSet
Determines the range to estimate what the axis labels should be.
IAxis
getLabels(minimumAxisLength:Number):AxisLabelSet
Gets the labels text that is rendered.
IAxis
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
invertTransform(value:Number):Object
Maps a position along the axis back to a numeric data value.
IAxis
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void
Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
IAxis
preferDropLabels():Boolean
Determines how the axis handles overlapping labels.
IAxis
reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet
Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
IAxis
registerDataTransform(transform:DataTransform, dimensionName:String):void
Each DataTransform that makes use of an axis registers itself with that axis.
IAxis
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
transformCache(cache:Array, field:String, convertedField:String):void
Maps a set of values from data space to screen space.
IAxis
unregisterDataTransform(transform:DataTransform):void
Each DataTransform that makes use of an axis registers itself with that axis.
IAxis
update():void
Updates the chart.
IAxis
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
baseline property
baseline:Number [read-only]

The baseline position for the axis. Some series, such as ColumnSeries or AreaSeries, use this value to define the base of a filled region when no minimum value is specified.

Implementation
    public function get baseline():Number
chartDataProvider property
chartDataProvider:Object [write-only]

The data provider assigned to the enclosing chart. Axis types that are data provider-based can choose to inherit the data provider associated with the enclosing chart. If an axis is shared among multiple charts, the value of this property is undefined (most likely it will be the last data provider assigned to one of the associated charts).

Implementation
    public function set chartDataProvider(value:Object):void
displayName property
displayName:String [read-only]

The name of the axis. If set, Flex uses this name to format DataTip controls.

Implementation
    public function get displayName():String
title property
title:String [read-only]

The text for the title displayed along the axis.

Implementation
    public function get title():String
unitSize property
unitSize:Number [read-only]

The size of one unit of data as represented by this axis. This value is used by various series types to help in rendering. The ColumnSeries class, for example, uses this value to determine how wide columns should be rendered. Different axis types return different values, sometimes dependent on the data being represented. The DateTimeAxis class, for example, might return the number of milliseconds in a day, or a year, depending on the data that is rendered in the chart. Because this value is dependant on collecting the represented data, custom series cannot assume this value is accurate in their updateData() or updateMapping() methods.

Implementation
    public function get unitSize():Number
Method detail
dataChanged () method
public function dataChanged():void

Triggers events that inform the range object when the chart data has changed.

filterCache () method
public function filterCache(cache:Array, field:String, filteredString:String):void

Filters a set of values of arbitrary type to a set of numbers that can be mapped.

Parameters
cache:Array — An Array of objects where converted values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-filtered values.
filteredString:String — The field of the objects in the cache Array where filtered values should be stored.
formatForScreen () method
public function formatForScreen(value:Object):String

Formats values for display in DataTips. Returns a user-readable string.

Parameters
value:Object — The value to convert to a String.

Returns
String — The text of the DataTip.
getLabelEstimate () method
public function getLabelEstimate():AxisLabelSet

Determines the range to estimate what the axis labels should be. The axis almost immediately calls the getLabels() method to get the real values. The axis uses the estimated values to adjust chart margins, so any difference between the estimated labels and actual labels (returned from the getLabels() method) results in scaling the labels to fit.

An axis need only return the minimum and maximum labels when returning an estimate. If the label set is fairly static, without depending on the size of the axis being rendered on screen, an axis can return the entire label set from this function, and mark the estimate as accurate.

Returns
AxisLabelSet — An Array of AxisLabel objects.
getLabels () method
public function getLabels(minimumAxisLength:Number):AxisLabelSet

Gets the labels text that is rendered. When Flex calls this method, the axis has already determined the minimum length of the label.

Parameters
minimumAxisLength:Number — The minimum length of the axis, in pixels. The axis can be longer than this value, but not shorter.

Returns
AxisLabelSet — An array of AxisLabel objects.
invertTransform () method
public function invertTransform(value:Number):Object

Maps a position along the axis back to a numeric data value.

Parameters
value:Number — The bound of the axis. This parameter should be between 0 and 1, with 0 representing the minimum bound of the axis, and 1 the maximum.

Returns
Object
mapCache () method
public function mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void

Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.

Parameters
cache:Array — An Array of objects where converted values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-converted values.
convertedField:String — The field of the objects in the cache Array where converted values should be stored.
indexValues:Boolean (default = false) — This parameter is true if the values being mapped are index values, and false if they are natural data values.
preferDropLabels () method
public function preferDropLabels():Boolean

Determines how the axis handles overlapping labels. Typically, numeric ranges return true, while discrete value-based ranges do not. You can can override this property by setting it directly on the axis.

Returns
Boolean — true if labels can be dropped without loss of data; otherwise, false.
reduceLabels () method
public function reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet

Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels. The method is passed the two labels that are overlapping.

Parameters
intervalStart:AxisLabel — The start of the interval where labels overlap.
intervalEnd:AxisLabel — The end of the interval where labels overlap.

Returns
AxisLabelSet — A new label set that resolves the overlap by reducing the number of labels.
registerDataTransform () method
public function registerDataTransform(transform:DataTransform, dimensionName:String):void

Each DataTransform that makes use of an axis registers itself with that axis. The axis is responsible for informing the transform when its relevant values have changed. It should also request values from the transform when it wants to autogenerate minimum and maximum values.

Parameters
transform:DataTransform — The DataTransform to register.
dimensionName:String — The name of the dimension.
transformCache () method
public function transformCache(cache:Array, field:String, convertedField:String):void

Maps a set of values from data space to screen space.

Parameters
cache:Array — An Array of objects where mapped values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-mapped values.
convertedField:String — The field of the objects in the cache Array where mapped values should be stored.
unregisterDataTransform () method
public function unregisterDataTransform(transform:DataTransform):void

Each DataTransform that makes use of an axis registers itself with that axis. The axis is responsible for informing the transform when its relevant values have changed. It should also request values from the transform when it wants to autogenerate minimum and maximum values.

Parameters
transform:DataTransform — The DataTransform to unregister.
update () method
public function update():void

Updates the chart. This can be called multiple times per frame.


mx.charts.chartClasses.IAxisRenderer (Flex™ 2 Language Reference)

Interface IAxisRenderer | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Interface | public interface IAxisRenderer extends IUIComponent, IFlexDisplayObject, IBitmapDrawable, IEventDispatcher
Implementors | AxisRenderer

The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.

Classes implement this interface to provide range definition functionality.

See also

mx.charts.CategoryAxis
mx.charts.LinearAxis

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | alpha : Number The transparency of this object. | IFlexDisplayObject
 | axis : IAxis The axis object associated with this renderer. | IAxisRenderer
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | IUIComponent
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the object. | IUIComponent
Inherited | document : Object A reference to the document object associated with this component. | IUIComponent
Inherited | enabled : Boolean Whether the component can accept user interaction. | IUIComponent
Inherited | explicitHeight : Number The explicitly specified height for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitWidth : Number The explicitly specified width for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | focusPane : Sprite A single Sprite object that is shared among components and used as an overlay for drawing focus. | IUIComponent
 | gutters : Rectangle The distance between the axisRenderer and the sides of the surrounding chart. | IAxisRenderer
Inherited | height : Number The height of this object, in pixels. | IFlexDisplayObject
 | heightLimit : Number The maximum amount of space, in pixels, that an axis renderer will take from a chart. | IAxisRenderer
 | horizontal : Boolean true if the axis renderer is being used as a horizontal axis. | IAxisRenderer
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | IUIComponent
Inherited | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | measuredHeight : Number The measured height of this object. | IFlexDisplayObject
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | IUIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | IUIComponent
Inherited | measuredWidth : Number The measured width of this object. | IFlexDisplayObject
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
 | minorTicks : Array [read-only] Contains an array that specifies where Flex draws the minor tick marks along the axis. | IAxisRenderer
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | name : String The instance name of this object. | IFlexDisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | IUIComponent
 | otherAxes : Array [write-only] An Array of axes. | IAxisRenderer
Inherited | owner : DisplayObjectContainer Your owner is usually your parent, however If you are a popup subcomponent, your owner will be the component that popped you up. | IUIComponent
Inherited | parent : DisplayObjectContainer The parent of this object. | IFlexDisplayObject
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | IUIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | IUIComponent
 | placement : String The side of the chart the axisRenderer will appear on. | IAxisRenderer
Inherited | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
Inherited | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the surface of the component. | IUIComponent
Inherited | systemManager : ISystemManager A reference to the SystemManager object for this component. | IUIComponent
 | ticks : Array [read-only] Contains an array that specifies where Flex draws the tick marks along the axis. | IAxisRenderer
Inherited | tweeningProperties : Array Used by EffectManager. | IUIComponent
Inherited | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
Inherited | width : Number The width of this object, in pixels. | IFlexDisplayObject
Inherited | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Inherited | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
adjustGutters(workingGutters:Rectangle, adjustable:Object):Rectangle
Adjusts its layout to accomodate the gutters passed in.
IAxisRenderer
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
IAxisRenderer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
IUIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
IUIComponent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
initialize():void
Initialize the object.
IUIComponent
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
IUIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
IUIComponent
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
IUIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
axis property
axis:IAxis [read-write]

The axis object associated with this renderer. This property is managed by the enclosing chart, and should not be explicitly set.

Implementation
    public function get axis():IAxis
    public function set axis(value:IAxis):void
gutters property
gutters:Rectangle [read-write]

The distance between the axisRenderer and the sides of the surrounding chart. This property is assigned automatically by the chart, and should not be assigned directly.

Implementation
    public function get gutters():Rectangle
    public function set gutters(value:Rectangle):void
heightLimit property
heightLimit:Number [read-write]

The maximum amount of space, in pixels, that an axis renderer will take from a chart. Axis Renderers by default will take up as much space in the chart as necessary to render all of their labels at full size. If heightLimit is set, an AxisRenderer will resort to reducing the labels in size in order to guarantee the total size of the axis is less than heightLimit.

Implementation
    public function get heightLimit():Number
    public function set heightLimit(value:Number):void
horizontal property
horizontal:Boolean [read-write]

true if the axis renderer is being used as a horizontal axis. This property is managed by the enclosing CartesianChart, and should not be set directly.

Implementation
    public function get horizontal():Boolean
    public function set horizontal(value:Boolean):void
minorTicks property
minorTicks:Array [read-only]

Contains an array that specifies where Flex draws the minor tick marks along the axis. Each array element contains a value between 0 and 1.

Implementation
    public function get minorTicks():Array
otherAxes property
otherAxes:Array [write-only]

An Array of axes.

Implementation
    public function set otherAxes(value:Array):void
placement property
placement:String [read-write]

The side of the chart the axisRenderer will appear on. Legal values are "left" and "right" for vertical axis renderers and "top" and "bottom" for horizontal axis renderers. By default, primary axes are placed on the left and top, and secondary axes are placed on the right and bottom. CartesianCharts automatically guarantee that secondary axes are placed opposite primary axes; if you explicitly place a primary vertical axis on the right, for example, the secondary vertical axis is swapped to the left.

Implementation
    public function get placement():String
    public function set placement(value:String):void
ticks property
ticks:Array [read-only]

Contains an array that specifies where Flex draws the tick marks along the axis. Each array element contains a value between 0 and 1.

Implementation
    public function get ticks():Array
Method detail
adjustGutters () method
public function adjustGutters(workingGutters:Rectangle, adjustable:Object):Rectangle

Adjusts its layout to accomodate the gutters passed in. This method is called by the enclosing chart to determine the size of the gutters and the corresponding data area. This method provides the AxisRenderer with an opportunity to calculate layout based on the new gutters, and to adjust them if necessary. If a given gutter is adjustable, an axis renderer can optionally adjust the gutters inward (i.e., larger) but not outward (smaller). The renderer should return the gutters plus any adjustments made.

Parameters
workingGutters:Rectangle — Defines the gutters to adjust.
adjustable:Object — Consists of four Boolean properties (left=true/false, top=true/false, right=true/false, and bottom=true/false) that indicate whether the axis renderer can optionally adjust each of the gutters further.

Returns
Rectangle
chartStateChanged () method
public function chartStateChanged(oldState:uint, v:uint):void

Called by the enclosing chart to indicate that the current state of the chart has changed. Implementing elements should respond to this method in order to synchronize changes to the data displayed by the element.

Parameters
oldState:uint — An integer representing the previous state.
v:uint — An integer representing the new state.


mx.charts.chartClasses.IBar (Flex™ 2 Language Reference)

Interface IBar | Properties
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Interface | public interface IBar
Implementors | BarSeries, BarSet

The IBar interface is implemented by any any series that can be clustered vertically, such as a BarSeries. The BarSet series type requires that any sub-series assigned to it implement this interface.

Public Properties
Property |  | Defined by
 | barWidthRatio : Number [write-only] Specifies how wide to render the items relative to the category. | IBar
 | maxBarWidth : Number [write-only] Specifies how wide to draw the items, in pixels. | IBar
 | offset : Number [write-only] Specifies how far to offset the center of the items from the center of the available space, relative the category size. | IBar
Property detail
barWidthRatio property
barWidthRatio:Number [write-only]

Specifies how wide to render the items relative to the category. A value of 1 uses the entire space, while a value of 0.6 uses 60% of the category's available space. You typically do not set this property directly. A governing BarSet or BarChart would implicitly assign this value. The actual size used is the smaller of barWidthRatio and the maxbarWidth property

Implementation
    public function set barWidthRatio(value:Number):void
maxBarWidth property
maxBarWidth:Number [write-only]

Specifies how wide to draw the items, in pixels. The actual item width used is the smaller of this style and the barWidthRatio property. You typically do not set this property directly. The BarSet or BarChart objects assign this value.

Implementation
    public function set maxBarWidth(value:Number):void
offset property
offset:Number [write-only]

Specifies how far to offset the center of the items from the center of the available space, relative the category size. The range of values is a percentage in the range -100 to 100. Set to 0 to center the items in the space. Set to -50 to center the item at the beginning of the available space. You typically do not set this property directly. The BarSet or BarChart objects assign this value.

The default value is 0.

Implementation
    public function set offset(value:Number):void


mx.charts.chartClasses.IChartElement (Flex™ 2 Language Reference)

Interface IChartElement | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Interface | public interface IChartElement extends IFlexDisplayObject, IBitmapDrawable, IEventDispatcher
Implementors | ChartElement

IChartElement defines the base set of properties and methods required by a UIComponent to be representable in the data space of a chart. Any component assigned to the series, backgroundElements, or annotationElements Arrays of a chart must implement this interface.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | alpha : Number The transparency of this object. | IFlexDisplayObject
 | chartDataProvider : Object [write-only] The data provider assigned to the enclosing chart. | IChartElement
 | dataTransform : DataTransform [write-only] The DataTransform object that the element uses to map between data and screen coordinates. | IChartElement
Inherited | height : Number The height of this object, in pixels. | IFlexDisplayObject
 | labelContainer : Sprite [read-only] The DisplayObject that displays labels rendered by this element. | IChartElement
Inherited | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
Inherited | measuredHeight : Number The measured height of this object. | IFlexDisplayObject
Inherited | measuredWidth : Number The measured width of this object. | IFlexDisplayObject
Inherited | name : String The instance name of this object. | IFlexDisplayObject
Inherited | parent : DisplayObjectContainer The parent of this object. | IFlexDisplayObject
Inherited | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
Inherited | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
Inherited | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
Inherited | width : Number The width of this object, in pixels. | IFlexDisplayObject
Inherited | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Inherited | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
IChartElement
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
IChartElement
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
IChartElement
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
IChartElement
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Returns a HitData object describing the nearest data point to the coordinates passed to the method.
IChartElement
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
mappingChanged():void
Indicates to the element that the data mapping of the associated axes has changed.
IChartElement
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
chartDataProvider property
chartDataProvider:Object [write-only]

The data provider assigned to the enclosing chart. Element types can choose to inherit the data provider from the enclosing chart if necessary, or allow developers to assign data providers specifically to the element. Not all elements are necessarily driven by a data provider.

Implementation
    public function set chartDataProvider(value:Object):void
dataTransform property
dataTransform:DataTransform [write-only]

The DataTransform object that the element uses to map between data and screen coordinates. This property is assigned by the enclosing chart.

Implementation
    public function set dataTransform(value:DataTransform):void
labelContainer property
labelContainer:Sprite [read-only]

The DisplayObject that displays labels rendered by this element. In most cases, labels displayed in the data area of a chart are rendered on top of all elements rather than interleaved with the data. If an implementing Element has labels to display, it can place them in a Sprite object and return it as the value of the labelContainer property. Enclosing charts will labelContainers from all enclosed elements and place them in the data area above all other elements.

Implementation
    public function get labelContainer():Sprite
Method detail
chartStateChanged () method
public function chartStateChanged(oldState:uint, v:uint):void

Called by the enclosing chart to indicate that the current state of the chart has changed. Implementing elements should respond to this method in order to synchronize changes to the data displayed by the element.

Parameters
oldState:uint — An integer representing the previous state.
v:uint — An integer representing the new state.
claimStyles () method
public function claimStyles(styles:Array, firstAvailable:uint):uint

Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array. Each chart has an associated set of selectors that are implicitly assigned to contained elements that require them. Implementing this function gives an element a chance to 'claim' elements out of that set, as necessary. An element that requires N style selectors claims the values from styles[firstAvailable] to styles[firstAvailable + N - 1]. Elements return the new value for firstAvailable after claiming any styles (for example, firstAvailable + N).

Parameters
styles:Array — An Array of styles to claim.
firstAvailable:uint — The first style selector in the Array to claim.

Returns
uint
collectTransitions () method
public function collectTransitions(chartState:Number, transitions:Array):void

Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state. The chart collects transitions from all elements and ensures that they play in parallel. It waits until all transitions have completed before advancing to another state. Implementors should append any necessary transitions to the transitions Array parameter.

Parameters
chartState:Number — The state at which the chart plays the new transitions.
transitions:Array — An Array of transition to add to the chart's list of transitions to play.
describeData () method
public function describeData(dimension:String, requiredFields:uint):Array

Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. Implementors fill out and return an Array of mx.charts.chartClasses.DataDescription objects to guarantee that their data is correctly accounted for by any axes that are autogenerating values from the displayed data (such as minimum, maximum, interval, and unitSize). Most element types return an Array containing a single DataDescription. Aggregate elements, such as BarSet and ColumnSet, might return mutiple DataDescription instances that describe the data displayed by their subelements. When called, the implementor describes the data along the axis indicated by the dimension argument. This function might be called for each axis supported by the containing chart.

Parameters
dimension:String — Determines the axis to get data descriptions of.
requiredFields:uint — A bitfield that indicates which values of the DataDescription object the particular axis cares about. Implementors can optimize by only calculating the necessary fields.

Returns
Array
findDataPoints () method
public function findDataPoints(x:Number, y:Number, sensitivity2:Number):Array

Returns a HitData object describing the nearest data point to the coordinates passed to the method. The x and y arguments should be values in the Element's coordinate system. This method aheres to the limits specifies by the sensitivity2 parameter when looking for nearby data points.

Parameters
x:Number — The x coordinate relative to the ChartBase object.
y:Number — The y coordinate relative to the ChartBase object.
sensitivity2:Number

Returns
Array — A HitData object describing the nearest data point within sensitivity2 pixels.

See also

mx.charts.HitData
mappingChanged () method
public function mappingChanged():void

Indicates to the element that the data mapping of the associated axes has changed. Implementors should dispose of cached data and re-render appropriately. This function is called automatically by the associated DataTransform when necessary.


mx.charts.chartClasses.IColumn (Flex™ 2 Language Reference)

Interface IColumn | Properties
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Interface | public interface IColumn
Implementors | ColumnSeries, ColumnSet, HLOCSeriesBase

ChartElements that can be clustered along the vertical axis should implement this interface. Any element implementing this interface can be used as a child series of a ColumnSet element with its type property set to "clustered". The ColumnSeries, HLOCSeries, CandleStickSeries, and ColumnSet classes all implement this interface.

Public Properties
Property |  | Defined by
 | columnWidthRatio : Number [write-only] Specifies the width of items relative to the category size. | IColumn
 | maxColumnWidth : Number [write-only] Specifies how wide to draw the items, in pixels. | IColumn
 | offset : Number [write-only] Specifies how far to offset the center of the items from the center of the available space, relative the category size. | IColumn
Property detail
columnWidthRatio property
columnWidthRatio:Number [write-only]

Specifies the width of items relative to the category size. A value of 1 uses the entire space, while a value of 0.6 uses 60% of the item's available space. You typically do not set this property directly. A governing ColumSet or ColumnChart would implicitly assign this value. The actual item width used is the smaller of the columnWidthRatio and the maxColumnWidth properties.

Implementation
    public function set columnWidthRatio(value:Number):void
maxColumnWidth property
maxColumnWidth:Number [write-only]

Specifies how wide to draw the items, in pixels. The actual item width used is the smaller of this property and the columnWidthRatio property. You typically do not set this property directly. The ColumSet or ColumnChart object assigns this value. The actual item width used is the smaller of the columnWidthRatio and maxColumnWidth properties.

Implementation
    public function set maxColumnWidth(value:Number):void
offset property
offset:Number [write-only]

Specifies how far to offset the center of the items from the center of the available space, relative the category size. The range of values is a percentage in the range -100 to 100. Set to 0 to center the items in the space. Set to -50 to center the item at the beginning of the available space. You typically do not set this property directly. The ColumSet or ColumnChart object assigns this value.

The default value is 0.

Implementation
    public function set offset(value:Number):void


mx.charts.chartClasses.InstanceCache (Flex™ 2 Language Reference)

Class InstanceCache | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class InstanceCache
Inheritance | InstanceCache Inheritance Object

InstanceCache is a utilty that governs the task of creating and managing a set of n object instances, where n changes frequently.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | count : int The number of items currently required in the cache. | InstanceCache
 | creationCallback : Function A callback invoked when new instances are created. | InstanceCache
 | discard : Boolean = false Determines if unneeded instances are discarded. | InstanceCache
 | factory : IFactory A factory that generates the type of object to cache. | InstanceCache
 | format : TextFormat A TextFormat to apply to any instances created. | InstanceCache
 | hide : Boolean = true Determines if unneeded instances should be hidden. | InstanceCache
 | insertPosition : int [write-only] The position of the instance in the parent's child list. | InstanceCache
 | instances : Array [read-only] The Array of cached instances. | InstanceCache
 | properties : Object A hashmap of properties to assign to new instances. | InstanceCache
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | remove : Boolean = false Determines if unneeded instances should be removed from their parent. | InstanceCache
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | InstanceCache(type:Object, parent:Object = null, insertPosition:int = -1) Constructor. | InstanceCache
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
count property
count:int [read-write]

The number of items currently required in the cache.

Implementation
    public function get count():int
    public function set count(value:int):void
creationCallback property
public var creationCallback:Function

A callback invoked when new instances are created. This callback has the following signature:

   function creationCallback(newInstance:Object, cache:InstanceCache):void;

discard property
public var discard:Boolean = false

Determines if unneeded instances are discarded. If set to true, extra elements are discarded when the cache count is reduced. Otherwise, extra elements are kept in a separate cache and reused when the count is increased.

factory property
factory:IFactory [read-write]

A factory that generates the type of object to cache. Assigning to this discards all current instances and recreate new instances of the correct type.

Implementation
    public function get factory():IFactory
    public function set factory(value:IFactory):void
format property
format:TextFormat [read-write]

A TextFormat to apply to any instances created. If set, this format is applied as the current and default format for the contents of any instances created. This property is only relevant if the factory generates TextField instances.

Implementation
    public function get format():TextFormat
    public function set format(value:TextFormat):void
hide property
public var hide:Boolean = true

Determines if unneeded instances should be hidden. If true, the visible property is set to false on each extra element when the cache count is reduced, and set to true when the count is increased.

This property is only relevant when the factory generates DisplayObjects. Setting this property to true for other factory types generates a run-time error.

insertPosition property
insertPosition:int [write-only]

The position of the instance in the parent's child list.

Implementation
    public function set insertPosition(value:int):void
instances property
instances:Array [read-only]

The Array of cached instances. There may be more instances in this Array than currently requested. You should rely on the count property of the instance cache rather than the length of this Array.

Implementation
    public function get instances():Array
properties property
properties:Object [read-write]

A hashmap of properties to assign to new instances. Each key/value pair in this hashmap is assigned to each new instance created. The property hashmap is assigned to any existing instances when set.

The values in the hashmap are not cloned; object values are shared by all instances.

Implementation
    public function get properties():Object
    public function set properties(value:Object):void
remove property
public var remove:Boolean = false

Determines if unneeded instances should be removed from their parent. If true, the removeChild() method is called on the parent for each extra element when the cache count is reduced.

This property is only relevant when the factory generates DisplayObjects. Setting this property to true for other factory types generates a run-time error.

Constructor detail
InstanceCache () constructor
public function InstanceCache(type:Object, parent:Object = null, insertPosition:int = -1)

Constructor.

Parameters
type:Object — The type of object to construct. This can be either a Class or an IFactory.
parent:Object (default = null) — An optional DisplayObject to add new instances to.
insertPosition:int (default = -1) — Where in the parent's child list to insert instances. Set to -1 to add the children to the end of the child list.


mx.charts.chartClasses.IStackable (Flex™ 2 Language Reference)

Interface IStackable | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Interface | public interface IStackable
Implementors | AreaSeries, BarSeries, ColumnSeries

The IStackable interface is implemented by any series that can be stacked. Stacking sets (ColumnSet, BarSet, AreaSet) require that any sub-series assigned to it when stacking implement this interface.

Public Properties
Property |  | Defined by
 | stacker : StackedSeries The StackedSeries associated with this series. | IStackable
 | stackTotals : Dictionary [write-only] The stack totals for the series. | IStackable
Public Methods
Method |  | Defined by
 | stack(stackedXValueDictionary:Dictionary, previousElement:IStackable):Number Stacks the series. | IStackable
Property detail
stacker property
stacker:StackedSeries [read-write]

The StackedSeries associated with this series. The stacker manages the series's stacking behavior.

Implementation
    public function get stacker():StackedSeries
    public function set stacker(value:StackedSeries):void
stackTotals property
stackTotals:Dictionary [write-only]

The stack totals for the series.

Implementation
    public function set stackTotals(value:Dictionary):void
Method detail
stack () method
public function stack(stackedXValueDictionary:Dictionary, previousElement:IStackable):Number

Stacks the series. Normally, a series implements the updateData() method to load its data out of the data provider. But a stacking series performs special operations because its values are not necessarily stored in its data provider. Its values are whatever is stored in its data provider, summed with the values that are loaded by the object it stacks on top of.

A custom stacking series should implement the stack() method by loading its data out of its data provider, adding it to the base values stored in the dictionary to get the real values it should render with, and replacing the values in the dictionary with its new, summed values.

Parameters
stackedXValueDictionary:Dictionary — Contains the base values that the series should stack on top of. The keys in the dictionary are the y values, and the values are the x values.
previousElement:IStackable — The previous element in the stack. If, for example, the element is of the same type, you can use access to this property to avoid duplicate effort when rendering.

Returns
Number — The maximum value in the newly stacked series.


mx.charts.chartClasses.LegendData (Flex™ 2 Language Reference)

Class LegendData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class LegendData
Inheritance | LegendData Inheritance Object

The LegendData structure is used by charts to describe the items that should be displayed in an auto-generated legend. A chart's legendData property contains an Array of LegendData objects, one for each item in the Legend.

See also

Using Legend controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | aspectRatio : Number Determines the size and placement of the legend marker. | LegendData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | element : IChartElement The chart item that generated this legend item. | LegendData
 | label : String = "" The text identifying the series or item displayed in the legend item. | LegendData
 | marker : IFlexDisplayObject A visual indicator associating the legend item with the series or item being represented. | LegendData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LegendData() Constructor. | LegendData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
aspectRatio property
public var aspectRatio:Number

Determines the size and placement of the legend marker. If set, the LegendItem ensures that the marker's width and height match this value. If unset (NaN), the legend item chooses an appropriate default width and height.

element property
public var element:IChartElement

The chart item that generated this legend item.

label property
public var label:String = ""

The text identifying the series or item displayed in the legend item.

marker property
public var marker:IFlexDisplayObject

A visual indicator associating the legend item with the series or item being represented. This DisplayObject is added as a child to the LegendItem.

Constructor detail
LegendData () constructor
public function LegendData()

Constructor.


mx.charts.chartClasses.NumericAxis (Flex™ 2 Language Reference)

Class NumericAxis | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class NumericAxis
Inheritance | NumericAxis Inheritance AxisBase Inheritance EventDispatcher Inheritance Object
Implements | IAxis
Subclasses | DateTimeAxis, LinearAxis, LogAxis

The NumericAxis class acts as a common base class for axis types representing a continuous range of values between a defined minimum and maximum. The built-in LinearAxis, LogAxis, and DateTimeAxis classes all extend this base class.

See also

mx.charts.DateTimeAxis
mx.charts.LinearAxis
mx.charts.LogAxis
Working with axes
About the NumericAxis class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | autoAdjust : Boolean Specifies whether Flex rounds values. | NumericAxis
 | baseAtZero : Boolean = true Specifies whether Flex tries to keep the minimum and maximum values rooted at zero. | NumericAxis
 | baseline : Number [read-only] The computed minimum value for the axis as long as this value is greater than 0. | NumericAxis
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | AxisBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | displayName : String The name of the axis. | AxisBase
 | labelFunction : Function Called to format axis values for display as labels. | NumericAxis
 | minorTicks : Array [read-only] An Array of minor tick marks generated to represent this axis. | NumericAxis
 | padding : Number Specifies padding that Flex adds to the calculated minimum and maximum values for the axis when rendering the values on the screen. | NumericAxis
 | parseFunction : Function Specify a parseFunction to customize how the values rendered by your chart are converted into numeric values. | NumericAxis
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | title : String The text for the title displayed along the axis. | AxisBase
Inherited | unitSize : Number The size of one unit of data as represented by this axis. | AxisBase
Protected Properties
Property |  | Defined by
 | assignedMaximum : Number The explicitly assigned maximum value. | NumericAxis
 | assignedMinimum : Number The explicitly assigned minimum value. | NumericAxis
 | computedInterval : Number The computed interval represented by this axis. | NumericAxis
 | computedMaximum : Number The computed maximum value represented by this axis. | NumericAxis
 | computedMinimum : Number The computed minimum value represented by this axis. | NumericAxis
 | dataDescriptions : Array [read-only] An Array of DataDescription structures describing the data being represented by the chart. | NumericAxis
 | labelCache : Array The most recent set of AxisLabel objects generated to represent this axis. | NumericAxis
 | labelMaximum : Number The maximum value where a label should be placed. | NumericAxis
 | labelMinimum : Number The minimum value where a label should be placed. | NumericAxis
 | minorTickCache : Array The most recent set of minor tick marks generated to represent this axis. | NumericAxis
 | requiredDescribedFields : uint [read-only] The fields of the DescribeData structure that this axis is interested in. | NumericAxis
 | ticks : Array [read-only] An Array of tick marks for this axis. | NumericAxis
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NumericAxis()
Constructor.
NumericAxis
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dataChanged():void
Triggers events that inform the range object when the chart data has changed.
AxisBase
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
filterCache(cache:Array, field:String, filteredString:String):void
Filters a set of values of arbitrary type to a set of numbers that can be mapped.
NumericAxis
formatForScreen(value:Object):String
Formats values for display in DataTips.
NumericAxis
getLabelEstimate():AxisLabelSet
Determines the range to estimate what the axis labels should be.
NumericAxis
getLabels(minimumAxisLength:Number):AxisLabelSet
Gets the labels text that is rendered.
NumericAxis
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
invertTransform(value:Number):Object
Maps a position along the axis back to a numeric data value.
NumericAxis
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void
Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
NumericAxis
preferDropLabels():Boolean
Determines how the axis handles overlapping labels.
NumericAxis
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet
Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
NumericAxis
Inherited
registerDataTransform(transform:DataTransform, dimensionName:String):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
transformCache(cache:Array, field:String, convertedField:String):void
Maps a set of values from data space to screen space.
NumericAxis
Inherited
unregisterDataTransform(transform:DataTransform):void
Each DataTransform that makes use of an axis registers itself with that axis.
AxisBase
update():void
Updates the chart.
NumericAxis
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
 | adjustMinMax(minValue:Number, maxValue:Number):void Adjusts the generated or assigned range of the axis's labels. | NumericAxis
 | buildLabelCache():Boolean Populates the labelCache property with labels representing the current values of the axis. | NumericAxis
 | buildMinorTickCache():Array Builds an Array of positions for the minor tick marks Array that is generated by this axis. | NumericAxis
Inherited | describeData(requiredFields:uint):Array Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. | AxisBase
 | guardMinMax(min:Number, max:Number):Array Protects the range against invalid values for this axis type. | NumericAxis
 | invalidateCache():void Invalidates the cached labels and tick marks that represent this axis's values. | NumericAxis
Property detail
assignedMaximum property
protected var assignedMaximum:Number

The explicitly assigned maximum value. If no value has been assigned, this will be NaN. Typically, calculations should be performed with the computedMaximum field.

assignedMinimum property
protected var assignedMinimum:Number

The explicitly assigned minimum value. If no value has been assigned, this will be NaN. Typically calculations should be performed with the computedMinimum field.

autoAdjust property
autoAdjust:Boolean [read-write]

Specifies whether Flex rounds values. If false, Flex does not round the values set by the minimum and maximum properties, or modify the default minimum and maximum values.

The default value is true.

Implementation
    public function get autoAdjust():Boolean
    public function set autoAdjust(value:Boolean):void
baseAtZero property
public var baseAtZero:Boolean = true

Specifies whether Flex tries to keep the minimum and maximum values rooted at zero. If all axis values are positive, the minimum axis value is zero. If all axis values are negative, the maximum axis value is zero.

The default value is true.

baseline property
baseline:Number [read-only]

The computed minimum value for the axis as long as this value is greater than 0. If the maximum value is less than or equal to 0, then the baseline property is the computed maximum. If neither value is greater than 0, then the baseline property is 0.

Implementation
    public function get baseline():Number
computedInterval property
protected var computedInterval:Number

The computed interval represented by this axis. The computedInterval is used by the AxisRenderer and Gridlines classes to determine where to render tick marks and grid lines. The NumericAxis base class watches this field for changes to determine if the chart needs to be re-rendered. Derived classes are responsible for computing the value of this field.

computedMaximum property
protected var computedMaximum:Number

The computed maximum value represented by this axis. If the user has explicitly assigned a maximum value, the computedMaximum and assignedMaximum properties are usually the same. Otherwise, the computedMaximum is generated from the values represented in the chart.

computedMinimum property
protected var computedMinimum:Number

The computed minimum value represented by this axis. If the user has explicitly assigned a minimum value, the computedMinimum and assignedMinimum properties are usually be the same. Otherwise, the computedMinimum is generated from the values represented in the chart.

dataDescriptions property
dataDescriptions:Array [read-only]

An Array of DataDescription structures describing the data being represented by the chart. An axis can use this property to generate values for properties, such as its range.

Implementation
    protected function get dataDescriptions():Array
labelCache property
protected var labelCache:Array

The most recent set of AxisLabel objects generated to represent this axis. This property is null if the axis has been modified and requires new labels. To guarantee that the value of the labelCache property is correct, call the buildLabelCache() method before accessing the labelCache property.

labelFunction property
labelFunction:Function [read-write]

Called to format axis values for display as labels. A labelFunction has the following signature:

   function labelFunction(labelValue:Object, previousValue:Object, axis:IAxis):String

If you know the types of the data your function will be formatting, you can specify an explicit type for the labelValue and previousValue parameters.

Implementation
    public function get labelFunction():Function
    public function set labelFunction(value:Function):void
labelMaximum property
protected var labelMaximum:Number

The maximum value where a label should be placed. After computing an adjusted minimum value, many axis types expand the range of the axis further to make room for additional rendering artifacts in the chart, such as labels and borders. This value represents the maximum value in the chart before it is adjusted for these artifacts. Typically axes generate labels to make sure this value is labeled, rather than the adjusted maximum of the axis.

labelMinimum property
protected var labelMinimum:Number

The minimum value where a label should be placed. After computing an adjusted minimum value, many axis types expand the range of the axis further to make room for additional rendering artifacts in the chart, such as labels and borders. This value represents the minimum value in the chart before it is adjusted for these artifacts. Typically axes will generate labels to make sure this value is labeled, rather than the adjusted minimum of the axis.

minorTickCache property
protected var minorTickCache:Array

The most recent set of minor tick marks generated to represent this axis. This property may be null if the axis has been modified and requires new labels and tick marks. Use the public accessor minorTicks to build the minor tick marks on demand.

minorTicks property
minorTicks:Array [read-only]

An Array of minor tick marks generated to represent this axis.

Implementation
    public function get minorTicks():Array
padding property
padding:Number [read-write]

Specifies padding that Flex adds to the calculated minimum and maximum values for the axis when rendering the values on the screen.

Implementation
    public function get padding():Number
    public function set padding(value:Number):void
parseFunction property
parseFunction:Function [read-write]

Specify a parseFunction to customize how the values rendered by your chart are converted into numeric values. A custom parseFunction is passed a data value and should return a corresponding number representing the same value. By default, this axis uses the ECMA function parseFloat().

Implementation
    public function get parseFunction():Function
    public function set parseFunction(value:Function):void
requiredDescribedFields property
requiredDescribedFields:uint [read-only]

The fields of the DescribeData structure that this axis is interested in.

Implementation
    protected function get requiredDescribedFields():uint
ticks property
ticks:Array [read-only]

An Array of tick marks for this axis.

Implementation
    protected function get ticks():Array
Constructor detail
NumericAxis () constructor
public function NumericAxis()

Constructor.

Method detail
adjustMinMax () method
protected function adjustMinMax(minValue:Number, maxValue:Number):void

Adjusts the generated or assigned range of the axis's labels. This method is called during the update cycle of the axis. Subclasses can override this method to do special processing on the values. By default, no adjustments are made to the range.

Parameters
minValue:Number — The computed minimum value.
maxValue:Number — The computed maximum value.
buildLabelCache () method
protected function buildLabelCache():Boolean

Populates the labelCache property with labels representing the current values of the axis. Subclasses must implement this function. This function is called many times, so you should check to see if the labelCache property is null before performing any calculations.

Returns
Boolean — true if the labels were regenerated.
buildMinorTickCache () method
protected function buildMinorTickCache():Array

Builds an Array of positions for the minor tick marks Array that is generated by this axis. Subclasses must implement this function. This function is called automatically by the NumericAxis. You should access the minorTicks property instead of calling this function directly.

Returns
Array — An Array of positions from 0 to 1 that represent points between the axis minimum and maximum values where minor tick marks are rendered.
filterCache () method
public function filterCache(cache:Array, field:String, filteredString:String):void

Filters a set of values of arbitrary type to a set of numbers that can be mapped.

Parameters
cache:Array — An Array of objects where converted values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-filtered values.
filteredString:String — The field of the objects in the cache Array where filtered values should be stored.
formatForScreen () method
public function formatForScreen(value:Object):String

Formats values for display in DataTips. Returns a user-readable string.

Parameters
value:Object — The value to convert to a String.

Returns
String — The text of the DataTip.
getLabelEstimate () method
public function getLabelEstimate():AxisLabelSet

Determines the range to estimate what the axis labels should be. The axis almost immediately calls the getLabels() method to get the real values. The axis uses the estimated values to adjust chart margins, so any difference between the estimated labels and actual labels (returned from the getLabels() method) results in scaling the labels to fit.

An axis need only return the minimum and maximum labels when returning an estimate. If the label set is fairly static, without depending on the size of the axis being rendered on screen, an axis can return the entire label set from this function, and mark the estimate as accurate.

Returns
AxisLabelSet — An Array of AxisLabel objects.
getLabels () method
public function getLabels(minimumAxisLength:Number):AxisLabelSet

Gets the labels text that is rendered. When Flex calls this method, the axis has already determined the minimum length of the label.

Parameters
minimumAxisLength:Number — The minimum length of the axis, in pixels. The axis can be longer than this value, but not shorter.

Returns
AxisLabelSet — An array of AxisLabel objects.
guardMinMax () method
protected function guardMinMax(min:Number, max:Number):Array

Protects the range against invalid values for this axis type. This function is called during the update cycle of the axis to guarantee that invalid ranges are not generated. Subclasses can override this class and define logic that is appropriate to their axis type.

Parameters
min:Number — The computed minimum value.
max:Number — The computed maximum value.

Returns
Array — null if no adjustment is necessary, or an Array containing the adjusted values of the form [min,max].
invalidateCache () method
protected function invalidateCache():void

Invalidates the cached labels and tick marks that represent this axis's values. Derived classes should call this function whenever values used in the calculation of labels and tick marks change.

invertTransform () method
public function invertTransform(value:Number):Object

Maps a position along the axis back to a numeric data value.

Parameters
value:Number — The bound of the axis. This parameter should be between 0 and 1, with 0 representing the minimum bound of the axis, and 1 the maximum.

Returns
Object
mapCache () method
public function mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean = false):void

Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.

Parameters
cache:Array — An Array of objects where converted values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-converted values.
convertedField:String — The field of the objects in the cache Array where converted values should be stored.
indexValues:Boolean (default = false) — This parameter is true if the values being mapped are index values, and false if they are natural data values.
preferDropLabels () method
public function preferDropLabels():Boolean

Determines how the axis handles overlapping labels. Typically, numeric ranges return true, while discrete value-based ranges do not. You can can override this property by setting it directly on the axis.

Returns
Boolean — true if labels can be dropped without loss of data; otherwise, false.
reduceLabels () method
public function reduceLabels(intervalStart:AxisLabel, intervalEnd:AxisLabel):AxisLabelSet

Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels. The method is passed the two labels that are overlapping.

Parameters
intervalStart:AxisLabel — The start of the interval where labels overlap.
intervalEnd:AxisLabel — The end of the interval where labels overlap.

Returns
AxisLabelSet — A new label set that resolves the overlap by reducing the number of labels.
transformCache () method
public function transformCache(cache:Array, field:String, convertedField:String):void

Maps a set of values from data space to screen space.

Parameters
cache:Array — An Array of objects where mapped values are read from and stored.
field:String — The field of the objects in the cache Array containing the pre-mapped values.
convertedField:String — The field of the objects in the cache Array where mapped values should be stored.
update () method
public function update():void

Updates the chart. This can be called multiple times per frame.


mx.charts.chartClasses.PolarChart (Flex™ 2 Language Reference)

Class PolarChart | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class PolarChart
Inheritance | PolarChart Inheritance ChartBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | PieChart

The PolarChart control serves as base class for circular charts based in polar coordinates. A chart's minimum size is 20,20 pixels.
A chart's maximum size is unbounded.
A chart's preferred size is 400,400 pixels.

See also

mx.charts.CategoryAxis
mx.charts.LinearAxis
mx.charts.chartClasses.ChartBase
Using the charting controls
Applying chart styles
Improving Flex Charting component performance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | angularAxis : IAxis The axis object used to map data values to an angle between 0 and 2 PI. | PolarChart
Inherited | annotationElements : Array Sets an Array of ChartElements that appears on top of any data series rendered by the chart. | ChartBase
Inherited | backgroundElements : Array Sets an Array of background chart elements that appear below any data series rendered by the chart. | ChartBase
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartState : uint The current transition state of the chart. | ChartBase
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Determines if Flex clips the chart to the area bounded by the axes. | ChartBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object Specifies the data provider for the chart. | ChartBase
Inherited | dataTipFunction : Function Specifies a callback method used to generate DataTips from values. | ChartBase
Inherited | dataTipMode : String Specifies how Flex displays DataTip controls for the chart. | ChartBase
Inherited | description : String A short description of the data described by the chart. | ChartBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | legendData : Array An Array of Legend items. | ChartBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseSensitivity : Number = 5 Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart. | ChartBase
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radialAxis : IAxis The axis object used to map data values to a radial distance between the center and the outer edge of the chart. | PolarChart
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | series : Array An Array of Series objects that define the chart data. | ChartBase
Inherited | seriesFilters : Array An Array of filters that are applied to all series in the chart. | ChartBase
Inherited | showDataTips : Boolean Specifies whether Flex shows DataTip controls for the chart. | ChartBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | allElements : Array The set of all chart elements displayed in the chart. | ChartBase
 | dataRegion : Rectangle [read-only] The area of the chart used to display data. | PolarChart
Inherited | dataTipLayerIndex : int The index of the child that is responsible for rendering DataTips. | ChartBase
Inherited | labelElements : Array The set of DisplayObjects representing the labels for the chart elements. | ChartBase
Inherited | transforms : Array The DataTransforms managed by this chart. | ChartBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PolarChart()
Constructor.
PolarChart
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
dataToLocal(... dataValues):Point
Converts a tuple of data values to an x-y coordinate on screen.
PolarChart
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number):Array
Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
ChartBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getAxis(dimension:String):IAxis
Retrieves the Axis instance for a particular dimension of the chart.
ChartBase
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideData():void
Informs the chart that the underlying data being displayed in the chart has been changed.
ChartBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSeriesStyles():void
Triggers a redraw of the chart.
ChartBase
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
legendDataChanged():void
Dispatches a new LegendDataChanged event.
ChartBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
localToData(pt:Point):Array
Converts a coordinate on screen to a tuple of data values.
PolarChart
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
ChartBase
Inherited
setAxis(dimension:String, value:IAxis):void
Assigns an axis instance to a particular dimension of the chart.
ChartBase
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySeriesSet(seriesSet:Array, transform:DataTransform):Array Preprocesses the series and transform for display. | ChartBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | customizeSeries(seriesGlyph:Series, i:uint):void Applies per-series customization and formatting to the series of the chart. | ChartBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | invalidateChildOrder():void Informs the chart that its child list has been modified and should be re-ordererd. | ChartBase
Inherited | invalidateData():void This method triggers a redraw of the chart. | ChartBase
Inherited | invalidateSeries():void Informs the chart that its series Array has been modified and should be re-processed. | ChartBase
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | positionDataTips():void Defines the locations of DataTips on the chart. | ChartBase
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | PolarChart
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a data point is found under the mouse pointer when it is clicked. | ChartBase
Inherited | itemDoubleClick | Dispatched when a data point is found under the mouse pointer when it is double clicked. | ChartBase
Inherited | itemMouseDown | Dispatched when a data point is found under the mouse pointer when it is pressed down. | ChartBase
Inherited | itemMouseMove | Dispatched when the mouse pointer moves while over a data point. | ChartBase
Inherited | itemMouseUp | Dispatched when a data point is found under the mouse pointer when it is released. | ChartBase
Inherited | itemRollOut | Dispatched when the closest data point under the mouse pointer changes. | ChartBase
Inherited | itemRollOver | Dispatched when a new data point is found under the mouse pointer. | ChartBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | chartSeriesStyles | Type: Array CSS Inheritance: no Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series. | ChartBase
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ChartBase
Inherited | dataTipCalloutStroke | Type: mx.graphics.IStroke CSS Inheritance: no The Stroke to use to render the callout line from the data tip target to the tip. | ChartBase
Inherited | dataTipRenderer | Type: Class CSS Inheritance: no Specifies the class to use to render data tips. | ChartBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fill | Type: mx.graphics.IFill CSS Inheritance: no Specifies the fill style used for the chart background. | ChartBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ChartBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text in pixels. | ChartBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ChartBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ChartBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | maximumDataTipCount | Type: int CSS Inheritance: no Specifies the maximum number of datatips a chart will show. | ChartBase
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's bottom border and its content area. | ChartBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ChartBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ChartBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Specifies the number of pixels between the chart's top border and its content area. | ChartBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | showDataTipTargets | Type: Boolean CSS Inheritance: no Specifies whether to show targets over the datapoints when showDataTips is set to true. | ChartBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ChartBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
angularAxis property
angularAxis:IAxis [read-write]

The axis object used to map data values to an angle between 0 and 2 PI. By default, this is a linear axis with the autoAdjust property set to false. So, data values are mapped uniformly around the chart.

Implementation
    public function get angularAxis():IAxis
    public function set angularAxis(value:IAxis):void
dataRegion property
dataRegion:Rectangle [read-only]

The area of the chart used to display data. This rectangle excludes the area used for gutters, axis lines and labels, and padding.

Implementation
    protected function get dataRegion():Rectangle
radialAxis property
radialAxis:IAxis [read-write]

The axis object used to map data values to a radial distance between the center and the outer edge of the chart. By default, this is a linear axis with the autoAdjust property set to false. So, data values are mapped uniformly from the inside to the outside of the chart

Implementation
    public function get radialAxis():IAxis
    public function set radialAxis(value:IAxis):void
Constructor detail
PolarChart () constructor
public function PolarChart()

Constructor.

Method detail
dataToLocal () method
public override function dataToLocal(... dataValues):Point

Converts a tuple of data values to an x-y coordinate on screen. Call this function to transform data on to the screen using the same transform that the individual elements go through. For example, to create a custom highlight for a data region of a chart, you might use this function to determine the on-screen coordinates of the range of interest.

For Cartesian charts, you typically pass two values. The first value maps to the horizontal axis, and the second value maps to the vertical axis.

For polar charts, the first value maps to the angular axis, and the second maps to the radial axis.

Parameters
... dataValues

Returns
Point — Coordinates that are relative to the chart.
localToData () method
public override function localToData(pt:Point):Array

Converts a coordinate on screen to a tuple of data values. Call this function to determine what data values a particular point on-screen represents.

Individual chart types determine how this transformation occurs. The point should be relative to the chart's coordinate space.

Parameters
pt:Point — The Point to convert.

Returns
Array — The tuple of data values.
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.


mx.charts.chartClasses.PolarTransform (Flex™ 2 Language Reference)

Class PolarTransform | Properties | Methods | Events | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class PolarTransform
Inheritance | PolarTransform Inheritance DataTransform Inheritance EventDispatcher Inheritance Object

The PolarTransform object represents a set of axes used to map data values to angle/distance polar coordinates and vice versa.

You typically do not need to interact with the PolarTransform object. Transforms are created automatically by the built-in chart types and are used by the series contained within to transform data into rendering coordinates.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | axes : Object The set of axes associated with this transform. | DataTransform
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elements : Array The elements that are associated with this transform. | DataTransform
 | origin : Point [read-only] The origin of the polar transform. | PolarTransform
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radius : Number [read-only] The radius used by the transform to convert data units to polar coordinates. | PolarTransform
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PolarTransform()
Constructor.
PolarTransform
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dataChanged():void
Informs the DataTransform that some of the underlying data being represented on the chart has changed.
DataTransform
Inherited
describeData(dimension:String, requiredFields:uint):Array
Collects important displayed values for all elements associated with this data transform.
DataTransform
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getAxis(dimension:String):IAxis
Retrieves the axis instance responsible for transforming the data dimension specified by the dimension parameter.
DataTransform
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
invertTransform(... values):Array
Transforms x and y coordinates relative to the DataTransform coordinate system into a two-dimensional value in data space.
DataTransform
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setAxis(dimension:String, v:IAxis):void
Assigns an axis instance to a particular dimension of the transform.
DataTransform
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setSize(width:Number, height:Number):void
Sets the width and height that the PolarTransfor uses when calculating origin and radius.
PolarTransform
Inherited
toString():String
Returns the string representation of the specified object.
Object
transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String):void
Maps a set of numeric values representing data to screen coordinates.
PolarTransform
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | transformChange | Dispatched when the transformation from data space to screen space has changed, typically either because the axes that make up the transformation have changed in some way, or the data transform itself has size. | DataTransform
Public Constants
Constant |  | Defined by
 | ANGULAR_AXIS : String = "a" [static] A string representing the angular axis. | PolarTransform
 | RADIAL_AXIS : String = "r" [static] A string representing the radial axis. | PolarTransform
Property detail
origin property
origin:Point [read-only]

The origin of the polar transform. This point is used by associated series to convert data units to screen coordinates.

Implementation
    public function get origin():Point
radius property
radius:Number [read-only]

The radius used by the transform to convert data units to polar coordinates.

Implementation
    public function get radius():Number
Constructor detail
PolarTransform () constructor
public function PolarTransform()

Constructor.

Method detail
setSize () method
public function setSize(width:Number, height:Number):void

Sets the width and height that the PolarTransfor uses when calculating origin and radius. The containing chart calls this method. It should not generally be called directly.

Parameters
width:Number
height:Number
transformCache () method
public override function transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String):void

Maps a set of numeric values representing data to screen coordinates. This method assumes the values are all numbers, so any non-numeric values must have been previously converted with the mapCache() method.

Parameters
cache:Array — An array of objects containing the data values in their fields. This is also where this function will store the converted numeric values.
xField:String — The field where the data values for the x axis can be found.
xConvertedField:String — The field where the mapped x screen coordinate will be stored.
yField:String — The field where the data values for the y axis can be found.
yConvertedField:String — The field where the mapped y screen coordinate will be stored.
Constant detail
ANGULAR_AXIS constant
public static const ANGULAR_AXIS:String = "a"

A string representing the angular axis.

RADIAL_AXIS constant
public static const RADIAL_AXIS:String = "r"

A string representing the radial axis.


mx.charts.chartClasses.RenderData (Flex™ 2 Language Reference)

Class RenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class RenderData
Inheritance | RenderData Inheritance Object
Subclasses | AreaSeriesRenderData, BarSeriesRenderData, BubbleSeriesRenderData, ColumnSeriesRenderData, HLOCSeriesRenderData, LineSeriesRenderData, PieSeriesRenderData, PlotSeriesRenderData

RenderData structures are used by chart elements to store all of the relevant values and data needed to fully render the chart. Storing these values in a separate structure lets chart elements decouple their rendering from their assigned properties and data as necessary. This ability is used by the chart effects: effects such as SeriesInterpolate substitute temporary values calculated from previous and future renderData structures. Effects such as SeriesSlide and SeriesZoom substitute temporary RenderData structures with values calculated to render the effect correctly.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
 | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
 | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
 | length : uint [read-only] The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RenderData(cache:Array = null, filteredCache:Array = null) Constructor. | RenderData
 | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
bounds property
public var bounds:Rectangle

The bounds of all of the items a series displays on screen, relative to the series's coordinate system. This value is used by the various effects during rendering. A series fills in this value when the effect calls the getElementBounds() method. A series does not need to fill in this field unless specifically requested.

cache property
public var cache:Array

The list of ChartItems representing the items in the series's dataProvider.

elementBounds property
public var elementBounds:Array

An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. Effects use this Array to generate the effect rendering. An effect calls the getElementBounds() method, which causes the series to fill in this value. A series does not need to fill in this field unless specifically requested. Effects modify this Array to relect current positions of the items during the effect duration. If this value is filled in on the series's renderData, the series renders itself based on these rectangles rather than from the series's data.

filteredCache property
public var filteredCache:Array

The list of ChartItems representing the items in the series's dataProvider that remain after filtering.

length property
length:uint [read-only]

The number of items represented in this render data.

Implementation
    public function get length():uint
visibleRegion property
public var visibleRegion:Rectangle

The rectangle describing the possible coordinate range that a series can display on screen. This value is used by the various effects during rendering. An effect calls the getElementBounds() method to fill in this value. A series does not need to fill in this field unless specifically requested. If left null, effects assume the visible region of an element is the bounding box of the element itself (0, 0, width, height), expressed relative to the element.

Constructor detail
RenderData () constructor
public function RenderData(cache:Array = null, filteredCache:Array = null)

Constructor.

Parameters
cache:Array (default = null) — The list of ChartItems representing the items in the series's dataProvider.
filteredCache:Array (default = null) — The list of ChartItems representing the items in the series's dataProvider that remain after filtering.
Method detail
clone () method
public function clone():RenderData

Creates a copy of the render data. In the new copy, properties that point to other objects continue to point to the same objects as the original.

If you subclass this class, you must override this method.

Returns
RenderData


mx.charts.chartClasses.Series (Flex™ 2 Language Reference)

Class Series | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class Series
Inheritance | Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | AreaSeries, BarSeries, BubbleSeries, ColumnSeries, HLOCSeriesBase, LineSeries, PieSeries, PlotSeries, StackedSeries

The Series class is the base class for the classes that let you specify a data series for a chart control. You use the subclasses of the Series class with the associated chart control. You can use a Series class to specify the fill pattern and stroke characteristics for the chart elements associated with the data series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
 | dataTransform : DataTransform [write-only] The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
 | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
 | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
 | legendData : Array [read-only] An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | renderData : Object [read-only] Stores the information necessary to render this series. | Series
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Series()
Constructor.
Series
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
 | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
 | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dataTransform property
dataTransform:DataTransform [write-only]

The data dataTransform the element is associated with. A data dataTransform represents an association between a set of elements and a set of axis objects used to dataTransform those elements from data space to screen coordinates and back. A chart element uses its associated dataTransform to calculate how to render its data.

Implementation
    public function set dataTransform(value:DataTransform):void
displayName property
displayName:String [read-write]

The name of the series, for display to the user. This property is used to represent the series in user-visible labels, such as DataTips.

Implementation
    public function get displayName():String
    public function set displayName(value:String):void
filterData property
filterData:Boolean [read-write]

This property is true if the series filters its data before displaying. If a series renders data that contains missing values (such as null, undefined, or NaN), or renders values outside the range of the chart axes, this property should be set to true (the default). If you know that all of the data in the series is valid, you can set this to false to improve performance

Implementation
    public function get filterData():Boolean
    public function set filterData(value:Boolean):void
interactive property
interactive:Boolean [read-write]

Determines whether DataTips appear when users interact with chart data on the screen. Set to false to prevent the series from showing DataTips or generating hitData.

The default value is true.

Implementation
    public function get interactive():Boolean
    public function set interactive(value:Boolean):void
legendData property
legendData:Array [read-only]

An Array of LegendData instances that describe the items that should show up in a legend representing this series. Derived series classes override this getter and return LegendData specific to their styles and data representation method. While most series types return only a single LegendData instance, some series types, such as PieSeries and StackedSeries, return multiple instances representing individual items in the array, or multiple ways of rendering data.

Implementation
    public function get legendData():Array
renderData property
renderData:Object [read-only]

Stores the information necessary to render this series.

Implementation
    protected function get renderData():Object
transitionRenderData property
transitionRenderData:Object [read-write]

A render data structure passed in by a running transtion. When a series effect is set to play on a series, it first captures the current state of the series by asking for its render data. The transition modifies the render data to create the desired effect, and passes the structure back to the series for display. If the transitionRenderData property is non-null, a series uses its contents to update its display.

Implementation
    public function get transitionRenderData():Object
    public function set transitionRenderData(value:Object):void
Constructor detail
Series () constructor
public function Series()

Constructor.

Method detail
beginInterpolation () method
public function beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object

Called by the SeriesInterpolate effect to initiate an interpolation. The effect passes in the source and destination data for the series to interpolate between. The effect passes the return value of this method repeatedly to the series's interpolate() method to advance the animation of the duration of the effect. The series calculates the data it needs to perform the interpolation and returns it in this method.

Parameters
sourceRenderData:Object — The source data for the series to interpolate between.
destRenderData:Object — The destination data for the series to interpolate between.

Returns
Object — The data the series needs to perform the interpolation.
cacheDefaultValues () method
protected function cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean

Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property. If the measureName property is null or the empty string, it assumes the original dataProvider items are raw values and caches them instead.

Parameters
measureName:String
cache:Array
fieldName:String

Returns
Boolean
cacheIndexValues () method
protected function cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean

Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property. If the measureName property is null or the empty string, it stores the index of the items in the fieldName property instead.

Parameters
measureName:String
cache:Array
fieldName:String

Returns
Boolean
cacheNamedValues () method
protected function cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean

Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.

Parameters
measureName:String
cache:Array
fieldName:String

Returns
Boolean
claimStyles () method
public override function claimStyles(styles:Array, firstAvailable:uint):uint

Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array. Each chart has an associated set of selectors that are implicitly assigned to contained elements that require them. Implementing this function gives an element a chance to 'claim' elements out of that set, as necessary. An element that requires N style selectors claims the values from styles[firstAvailable] to styles[firstAvailable + N - 1]. Elements return the new value for firstAvailable after claiming any styles (for example, firstAvailable + N).

Parameters
styles:Array — An Array of styles to claim.
firstAvailable:uint — The first style selector in the Array to claim.

Returns
uint
endInterpolation () method
public function endInterpolation(interpolationData:Object):void

Called by the SeriesInterpolate effect to end an interpolation. The effect uses this method to complete the interpolation and clean up any temporary state associated with the effect.

Parameters
interpolationData:Object
extractMinInterval () method
protected function extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void

Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems. Derived classes can call this method from their DescribeData implementations to fill in the details of the DataDescription structure.

Parameters
cache:Array
measureName:String
desc:DataDescription
extractMinMax () method
protected function extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void

Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems. Derived classes can call this method from their DescribeData implementations to fill in the details of the DataDescription structure.

Parameters
cache:Array
measureName:String
desc:DataDescription
calculateInterval:Boolean (default = false)
getElementBounds () method
public function getElementBounds(renderData:Object):void

Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series. Effect classes call this function to fill in these fields for use in implementing various effect types. Derived classes should implement this function to generate the bounds of the series's items only when requested.

Parameters
renderData:Object
getMissingInterpolationValues () method
protected function getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void

Fills in missing values in an interpolation structure. When a series calls the initializeInterpolationData() method, it passes in an Array of source and destination values for the interpolation. If either of those two Arrays are incomplete, the series needs to provide "appropriate" placeholder values for the interpolation. How those placeholder values are determined is specific to the series type. Series extenders should override this method to provide those placeholder values.

Parameters
sourceProps:Object — An object containing the source values being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
srcCache:Array — The Array of source chart items that are being interpolated.
destProps:Object — An Object containing the destination values that are being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
destCache:Array — The Array of destination chart items that are being interpolated.
index:Number — The index of the item that is being populated in the cache.
customData:Object — The data that was passed by the series into the initializeInterpolationData() method.
getRenderDataForTransition () method
public function getRenderDataForTransition(type:String):Object

Returns a copy of the data needed to represent this series's data. This method is called by SeriesEffects to capture the before and after state of the series for animation.

If you implement a custom series type, you generally do not override this method. Instead, you should override the renderData() accessor.

Parameters
type:String — Indicates whether the effect is requesting a description of the data being hidden, or the new data being shown.

Returns
Object
initializeInterpolationData () method
protected function initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object

Helper function for Series to implement the interpolation effect. A custom series can call this function from its beginInterpolation() method to initialize a data structure to interpolate an arbitrary set of numeric properties over the life of the effect. You can pass that data structure to the applyInterpolation() utility method to actually modify the values when your interpolate() method is called.

Parameters
srcCache:Array — An array of objects whose fields contain the beginning values for the interpolation.
dstCache:Array — An array of objects whose fields contain the ending values for the interpolation.
iProps:Object — A hashtable whose keys identify the names of the properties from the cache to be interpolated.
cacheType:Class (default = null) — The class to instantiate that holds the delta values computed for the interpolation. Typically this is null, in which case a generic Object is used.
customData:Object (default = null) — An object containing series-specific data. When the initialization process encounters a missing value, it calls the series's getMissingInterpolationValues() method to fill in the missing value. This custom data is passed to that method, and can be used to pass through arbitrary parameters.

Returns
Object
interpolate () method
public function interpolate(interpolationValues:Array, interpolationData:Object):void

Called by the SeriesInterpolate effect to advance an interpolation. The effect calls this once per frame until the interpolation is complete. The series is responsible for using the parameters to render the interpolated values. By default, the series assumes that interpolationData is a data structure returned by the initializeInterpolationData() method, and passes it through to the applyInterpolation() method.

Parameters
interpolationValues:Array — An Array of Numbers, each ranging from 0 to 1, where the nth number indicates the percentage of the way the nth value in the data series should be interpolated between the start and end values.
interpolationData:Object — The data returned from the beginInterpolation() method.
invalidateData () method
protected function invalidateData(invalid:Boolean = true):void

Informs the series that the underlying data in the dataProvider has changed. This function triggers calls to the updateData(), updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
invalidateFilter () method
protected function invalidateFilter(invalid:Boolean = true):void

Informs the series that the filter of the data against the axes has changed and must be recalculated. Calling this method triggers calls to the updateFilter() and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
invalidateMapping () method
protected function invalidateMapping(invalid:Boolean = true):void

Informs the series that the mapping of the data into numeric values has changed and must be recalculated. Calling this function triggers calls to the updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
invalidateTransform () method
protected function invalidateTransform(invalid:Boolean = true):void

Informs the series that the transform the data to screen coordinates has changed and must be recalculated. Calling this function triggers a call to the updateTransform() method on the next call to the commitProperties() method.

Parameters
invalid:Boolean (default = true)
invalidateTransitions () method
protected function invalidateTransitions():void

Informs the series that a significant change has occured in the display of data. This triggers any showData and hideData effects.

legendDataChanged () method
protected function legendDataChanged():void

Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.

setActualSize () method
public override function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.
stripNaNs () method
protected function stripNaNs(cache:Array, field:String):void

Removes any item from the provided cache whose field property is NaN. Derived classes can call this method from their updateFilter() implementation to remove any ChartItems filtered out by the axes.

Parameters
cache:Array
field:String
stylesInitialized () method
public override function stylesInitialized():void

Calls the legendDataChanged() method.

updateData () method
protected function updateData():void

This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider. If you implement custom series types, you should override this method and load all data necessary to render the series out of the backing data provider. You must also be sure to call the super.updateData() method in your subclass. You do not generally call this method directly. Instead, to guarantee that your data has been updated at a given point, call the validateData() method of the Series class.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
updateFilter () method
protected function updateFilter():void

This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform. This can happen either because the underlying data has changed, or because the range of the associated axes have changed. If you implement a custom series type, you should override this method and filter out any outlying data using the filterCache() method of the axes managed by its associated DataTransform. The filterCache() method converts any values out of range to NaN. You must be sure to call the super.updateFilter() method in your subclass. You should not generally call this method directly. Instead, if you need to guarantee that your data has been filtered at a given point, call the validateTransform() method of the Series class. You can generally assume that your updateData() and updateMapping() methods have been called prior to this method, if necessary.

updateMapping () method
protected function updateMapping():void

This method is called when the underlying data the series represents needs to be mapped to numeric representations. This can happen either because the underlying data has changed, or because the axes used to render the series have changed in some relevant way. If you implement a custom series, you should override this method and convert the data represented into numeric values using the mapCache() method of the axes managed by its associated DataTransform. You must also be sure to call the super.updateMapping() method in your subclass. You should not generally call this method directly. Instead, to guarantee that your data has been mapped at a given point, call the validateData() method of the Series class. You can generally assume that your updateData() method has been called prior to this method, if necessary.

updateTransform () method
protected function updateTransform():void

This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform. This can happen either because the underlying data has changed, because the range of the associated axes have changed, or because the size of the area on screen has changed. If you implement a custom series type, you should override this method and transform the data using the transformCache() method of the associated DataTransform. You must be sure to call the super.updateTransform() method in your subclass. You should not generally call this method directly. Instead, if you need to guarantee that your data has been filtered at a given point, call the valiateTransform() method of the Series class. You can generally assume that your updateData(), updateMapping(), and updateFilter() methods have been called prior to this method, if necessary.

validateData () method
protected function validateData():void

Calls the series's updateData() and updateMapping() functions, if necessary. This function is called automatically by the series during commitProperties, as necessary, but a derived series might call it explicitly if the generated values are needed at an explicit time. Loading and mapping of data against the axes is defined to be acceptable at any point by the axes; this function is safe to call explicitly at any point.

validateTransform () method
protected function validateTransform():void

Calls the series's updateFilter() and updateTransform() functions, if necessary. This function is called automatically by the series during commitProperties(), as necessary, but a derived series might call it explicitly, if the generated values are needed at an explicit time. Filtering and transforming of data relies on specific values calculated by the axes, which can, in turn, depend on the data displayed in the chart. Calling this function at the wrong time might result in extra work being done if those values are updated.


mx.charts.chartClasses.StackedSeries (Flex™ 2 Language Reference)

Class StackedSeries | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.chartClasses
Class | public class StackedSeries
Inheritance | StackedSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | AreaSet, BarSet, ColumnSet

Stacked Series serves as the common base class for all of the stacking set series (BarSet, ColumnSet, and AreaSet). A StackedSeries accepts an Array of sub-series elements and does the appropriate calculations to stack them vertically so that each series renders the sum of the previous series's data plus its own value. This class is not intended for direct use.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | series : Array An array of sub-series managed by this stacking set. | StackedSeries
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
 | type : String The grouping behavior of this series. | StackedSeries
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | renderData : Object Stores the information necessary to render this series. | Series
 | stackedMaximum : Number The maximum sum represented by this stacked series. | StackedSeries
 | totalsByPrimaryAxis : Dictionary The summed totals of the stacked values. | StackedSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
StackedSeries()
Constructor.
StackedSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
invalidateStacking():void
Call this method to trigger a regeneration of the stacked values on the next call to the commitProperties() method.
StackedSeries
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
stack():void
Updates the series data, and uses the values of the series data it is stacking on top of so it can stack correctly.
StackedSeries
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
buildSubSeries():void
Processes the Array of sub-series for display, when necessary.
StackedSeries
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
customizeSeries(g:IChartElement, i:uint):void
Applies any customization to a sub-series when building the stacking behavior.
StackedSeries
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
formatDataTip(hitData:HitData):String
Provides custom text for DataTips.
StackedSeries
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
invalidateSeries():void
Call this method to trigger a call to the buildSubSeries() method on the next call to the commitProperties() method.
StackedSeries
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
updateStacking():void
Iterates over the individual sub-series to build the stacked values.
StackedSeries
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
series property
series:Array [read-write]

An array of sub-series managed by this stacking set. These series are rendered according to the stacking behavior of this stacking set as defined by the value of the type property.

Implementation
    public function get series():Array
    public function set series(value:Array):void
stackedMaximum property
protected var stackedMaximum:Number

The maximum sum represented by this stacked series.

totalsByPrimaryAxis property
protected var totalsByPrimaryAxis:Dictionary

The summed totals of the stacked values. This property contains a Dictionary whose keys are the values represented by the child series along the primary axis (for example, x axis values for a ColumnSeries, y axis values for a BarSeries), and whose values are the summed total of all the child series values at that key.

type property
type:String [read-write]

The grouping behavior of this series. All stacking series support "overlaid", "stacked", and "100%". When the type property is "overlaid", all sub-series are rendererd normally, with no special behavior applied. When the type property is "stacked", each sub-series is rendered as the sum of its data plus the values of all previous series. When the type property is "100%", each sub-series is rendered as its portion of the total sum of all series.

Implementation
    public function get type():String
    public function set type(value:String):void
Constructor detail
StackedSeries () constructor
public function StackedSeries()

Constructor.

Method detail
buildSubSeries () method
protected function buildSubSeries():void

Processes the Array of sub-series for display, when necessary. This method ensures that all sub-series are added as children of this stacking set, and applies any per-series customization that is necessary (for example, assigning inherited data providers or clustering properties).

This method is also responsible for informing the chart that series have changed and, as a result, implicit series styles must be reassigned. This method is called automatically by the stacking set, when necessary. Instead of calling this method directly, you should consider calling the invalidateSeries() method.

customizeSeries () method
protected function customizeSeries(g:IChartElement, i:uint):void

Applies any customization to a sub-series when building the stacking behavior. By default, this method assigns the inherited data providers to the sub-series. Derived classes can override this method to apply further customization.

Parameters
g:IChartElement
i:uint
formatDataTip () method
protected function formatDataTip(hitData:HitData):String

Provides custom text for DataTips. Stacking sets override the DataTip text of their contained sub-series to display additional information related to the stacking behavior. Derived classes must override this method to define custom DataTip text.

Parameters
hitData:HitData

Returns
String
invalidateSeries () method
protected function invalidateSeries():void

Call this method to trigger a call to the buildSubSeries() method on the next call to the commitProperties() method.

invalidateStacking () method
public function invalidateStacking():void

Call this method to trigger a regeneration of the stacked values on the next call to the commitProperties() method.

stack () method
public function stack():void

Updates the series data, and uses the values of the series data it is stacking on top of so it can stack correctly.

updateStacking () method
protected function updateStacking():void

Iterates over the individual sub-series to build the stacked values.


mx.charts.effects Summary (Flex™ 2 Language Reference)

Package mx.charts.effects | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.effects package contains the effect classes for the Flex charting components.

Classes
Class | Description
SeriesEffect | The base class for chart effects.
SeriesInterpolate | The SeriesInterpolate effect moves the graphics that represent the existing data in a series to the new points.
SeriesSlide | The SeriesSlide effect slides a data series into and out of the chart's boundaries.
SeriesZoom | The SeriesZoom effect implodes and explodes chart data into and out of the focal point that you specify.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.effects.SeriesEffect (Flex™ 2 Language Reference)

Class SeriesEffect | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects
Class | public class SeriesEffect
Inheritance | SeriesEffect Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object
Subclasses | SeriesInterpolate, SeriesSlide, SeriesZoom

The base class for chart effects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SeriesEffect> tag inherits the tag attributes of its superclass, and adds the following tag attributes:

  <mx:tagname

    Properties
    elementOffset="20"

    minimumElementDuration="0"

    offset="0"

    type="show|hide (Default value is set by chart)"

  >

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
 | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffect
 | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | type : String = "show" The type of transition this effect is being used for. | SeriesEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesEffect(target:Object)
Constructor.
SeriesEffect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
elementOffset property
public var elementOffset:Number = 20

Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series.

Set elementOffset to 0 to affect all elements of the series at the same time. They start the effect at the same time and end it at the same time.

Set elementOffset to a positive integer (such as 30) to stagger the effect on each element by that amount of time. For example, with a slide effect, the first element slides in immediately, then the next element begins 30 milliseconds later, and so on. The amount of time for the effect to execute is the same for each element, but the overall duration of the effect is longer.

Set elementOffset to a negative value to have the effect begin from the last element and move backwards through the list.

The default is 20.

minimumElementDuration property
public var minimumElementDuration:Number = 0

Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect.

Charts with a variable number of data points in the series cannot reliably create smooth effects with only the duration property. For example, an effect with a duration of 1000 and an elementOffset of 100 takes 900 milliseconds per element to complete an effect if you have two elements in the series. This is because the start of each effect is offset by 100 and each effect finishes in 1000 milliseconds.

If there are four elements in the series, each element takes 700 milliseconds to complete (the last effect starts 300 milliseconds after the first and must be completed within 1000 milliseconds). With 10 elements, each element has only 100 milliseconds

to complete the effect.

The minimumElementDuration value sets a minimal duration for each element. No element of the series takes less than this amount of time (in milliseconds) to execute the effect, regardless of the number of elements in the series and the value of the duration property. As a result, it is possible for an effect to take longer than a specified duration if at least two of the following three properties are specified: duration, offset, and minimumElementDuration.

The default is 0.

offset property
public var offset:Number = 0

Specifies the amount of time, in milliseconds, that Flex delays the effect.

Use this property to stagger effects on multiple series.

The default is 0.

type property
public var type:String = "show"

The type of transition this effect is being used for. Some series effects define different behavior based on whether they are being used during the show or hide portion of a chart transition. The SeriesSlide effect, for example, slides elements from their position off screen when this property is set to hide, and on screen when this property is set to show. This property is set by the chart, based on whether the effect as assigned to the ShowDataEffect or HideDataEffect style.

Constructor detail
SeriesEffect () constructor
public function SeriesEffect(target:Object)

Constructor.

Parameters
target:Object — The target of the effect.


mx.charts.effects.SeriesInterpolate (Flex™ 2 Language Reference)

Class SeriesInterpolate | Properties | Methods | Events | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects
Class | public class SeriesInterpolate
Inheritance | SeriesInterpolate Inheritance SeriesEffect Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The SeriesInterpolate effect moves the graphics that represent the existing data in a series to the new points. Instead of clearing the chart and then repopulating it as with SeriesZoom and SeriesSlide, this effect keeps the data on the screen at all times.

You only use the SeriesInterpolate effect with a showDataEffect effect trigger. It has no effect if set with a hideDataEffect.

View the examples.

See also

Using effects with charts
Using the SeriesInterpolate effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffect
Inherited | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | type : String = "show" The type of transition this effect is being used for. | SeriesEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesInterpolate(target:Object = null)
Constructor.
SeriesInterpolate
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Constructor detail
SeriesInterpolate () constructor
public function SeriesInterpolate(target:Object = null)

Constructor.

Parameters
target:Object (default = null)
Examples
SeriesInterpolateExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the CandlestickChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var companyAAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.75,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 39.98,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);

        [Bindable]
        private var companyBAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 18.50,  High: 19, Low: 18.48, Close:18.86},
            { Date: "26-Jul", Open: 19.56,  High: 19.98, Low: 18.6, Close:18.69},
            { Date: "27-Jul", Open: 20.81,  High: 20.99, Low: 20.03, Close:20.12},
            { Date: "28-Jul", Open: 20.70,  High: 21.00, Low: 19.5, Close:20.84},
            { Date: "29-Jul", Open: 21.7,  High: 21.79, Low: 20.45, Close:20.6},
            { Date: "1-Aug", Open: 22.45,  High: 22.65, Low: 21.65, Close:21.95},
            { Date: "2-Aug", Open: 22.56,  High: 22.6, Low: 22.05, Close:22.98},
            { Date: "3-Aug", Open: 22.42,  High: 22.70, Low: 22.1, Close:22.63},
            { Date: "4-Aug", Open: 21.67,  High: 22.82, Low: 21.67, Close:22.34},
            { Date: "5-Aug", Open: 22.44,  High: 22.85, Low: 22.12, Close:22.31} ]);
        ]]>
    </mx:Script>

    <mx:SeriesInterpolate id="interpolateIn" duration="1000"/>

    <mx:Panel title="CandlestickChart Control Example" height="100%" width="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:CandlestickChart id="candlestickchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{companyAAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:CandlestickSeries
                    openField="Open" highField="High"
                    lowField="Low" closeField="Close"
                    showDataEffect="{interpolateIn}"/>
            </mx:series>
        </mx:CandlestickChart>

        <mx:Label width="100%" color="blue"
            text="Choose a company to view recent stock data."/>

        <mx:HBox>
            <mx:RadioButton groupName="stocks" label="View Company A"
                selected="true" click="candlestickchart.dataProvider=companyAAC;"/>
            <mx:RadioButton groupName="stocks" label="View Company B"
                click="candlestickchart.dataProvider=companyBAC;"/>
        </mx:HBox>
    </mx:Panel>
</mx:Application>


mx.charts.effects.SeriesSlide (Flex™ 2 Language Reference)

Class SeriesSlide | Properties | Methods | Events | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects
Class | public class SeriesSlide
Inheritance | SeriesSlide Inheritance SeriesEffect Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The SeriesSlide effect slides a data series into and out of the chart's boundaries. You use the direction property to specify the location from which the series slides.

If you use SeriesSlide with a hideDataEffect effect trigger, the series slides from the current position onscreen to a position off of the screen, in the indicated direction. If you use SeriesSlide as a showDataEffect, the series slides from offscreen to a position onto the screen, in the indicated direction.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SeriesSlide> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:SeriesSlide
    Properties
    direction="left|right|up|down"
  />

View the examples.

See also

Using effects with charts
Using the SeriesSlide effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
 | direction : String = "left" Defines the location from which the series slides. | SeriesSlide
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffect
Inherited | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | type : String = "show" The type of transition this effect is being used for. | SeriesEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesSlide(target:Object = null)
Constructor.
SeriesSlide
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
 | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | SeriesSlide
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
direction property
public var direction:String = "left"

Defines the location from which the series slides. Valid values are "left", "right", "up", and "down". The default value is "left".

Constructor detail
SeriesSlide () constructor
public function SeriesSlide(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The target of the effect.
Method detail
initInstance () method
protected override function initInstance(instance:EffectInstance):void

Copies properties of the effect to the effect instance.

Flex calls this method from the Effect.createInstance() method; you do not have to call it yourself.

When you create a custom effect, override this method to copy properties from the Effect class to the effect instance class. In your override, you must call super.initInstance().

Parameters
instance:EffectInstance — The effect instance to initialize.
Examples
SeriesSlideExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the CandlestickChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var companyAAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.75,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 39.98,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);

        [Bindable]
        private var companyBAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 18.50,  High: 19, Low: 18.48, Close:18.86},
            { Date: "26-Jul", Open: 19.56,  High: 19.98, Low: 18.6, Close:18.69},
            { Date: "27-Jul", Open: 20.81,  High: 20.99, Low: 20.03, Close:20.12},
            { Date: "28-Jul", Open: 20.70,  High: 21.00, Low: 19.5, Close:20.84},
            { Date: "29-Jul", Open: 21.7,  High: 21.79, Low: 20.45, Close:20.6},
            { Date: "1-Aug", Open: 22.45,  High: 22.65, Low: 21.65, Close:21.95},
            { Date: "2-Aug", Open: 22.56,  High: 22.6, Low: 22.05, Close:22.98},
            { Date: "3-Aug", Open: 22.42,  High: 22.70, Low: 22.1, Close:22.63},
            { Date: "4-Aug", Open: 21.67,  High: 22.82, Low: 21.67, Close:22.34},
            { Date: "5-Aug", Open: 22.44,  High: 22.85, Low: 22.12, Close:22.31} ]);
        ]]>
    </mx:Script>

    <mx:SeriesSlide id="slideIn" duration="1000" direction="up"/>
    <mx:SeriesSlide id="slideOut" duration="1000" direction="down"/>

    <mx:Panel title="CandlestickChart Control Example" height="100%" width="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:CandlestickChart id="candlestickchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{companyAAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:CandlestickSeries
                    openField="Open" highField="High"
                    lowField="Low" closeField="Close"
                    showDataEffect="{slideIn}"
                    hideDataEffect="{slideOut}"/>
            </mx:series>
        </mx:CandlestickChart>

        <mx:Label width="100%" color="blue"
            text="Choose a company to view recent stock data."/>

        <mx:HBox>
            <mx:RadioButton groupName="stocks" label="View Company A"
                selected="true" click="candlestickchart.dataProvider=companyAAC;"/>
            <mx:RadioButton groupName="stocks" label="View Company B"
                click="candlestickchart.dataProvider=companyBAC;"/>
        </mx:HBox>
    </mx:Panel>
</mx:Application>


mx.charts.effects.SeriesZoom (Flex™ 2 Language Reference)

Class SeriesZoom | Properties | Methods | Events | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects
Class | public class SeriesZoom
Inheritance | SeriesZoom Inheritance SeriesEffect Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The SeriesZoom effect implodes and explodes chart data into and out of the focal point that you specify. As with the SeriesSlide effect, whether the effect is zooming to or from this point depends on whether it is assigned to the showDataEffect or hideDataEffect effect trigger.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SeriesZoom> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:SeriesZoom
    Properties
    horizontalFocus="center|left|right|null"
    relativeTo="series|chart"
    verticalFocus="top|center|bottom|null"
  />

View the examples.

See also

Using effects with charts
Using the SeriesZoom effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
 | horizontalFocus : String Defines the location of the focul point of the zoom. | SeriesZoom
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffect
Inherited | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relativeTo : String = "series" Controls the bounding box that Flex uses to calculate the focal point of the zooms. | SeriesZoom
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | type : String = "show" The type of transition this effect is being used for. | SeriesEffect
 | verticalFocus : String Defines the location of the focal point of the zoom. | SeriesZoom
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesZoom(target:Object = null)
Constructor.
SeriesZoom
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
horizontalFocus property
public var horizontalFocus:String

Defines the location of the focul point of the zoom.

Valid values of the horizontalFocus property are "left", "center", "right", and null.

You combine the horizontalFocus and verticalFocus properties to define where the data series zooms in and out from. For example, set the horizontalFocus property to "left" and the verticalFocus property to "top" to zoom the series data to and from the top left corner of either the element or the chart (depending on the setting of the relativeTo property).

If you specify only one of these two properties, then the focus is a horizontal or vertical line rather than a point. For example, when you set horizontalFocus to "left" but verticalFocus to null, the element zooms to and from a vertical line along the left edge of its bounding box. Set the verticalFocus property to "center" to zoom chart elements to and from a horizontal line along the middle of the chart's bounding box.

The default value is "center".

relativeTo property
public var relativeTo:String = "series"

Controls the bounding box that Flex uses to calculate the focal point of the zooms.

Valid values for the relativeTo property are "series" and "chart".

Set to "series" to zoom each element relative to itself. For example, each column of a ColumnChart zooms from the top left of the column, the center of the column, and so on.

Set to "chart" to zoom each element relative to the chart area. For example, each column zooms from the top left of the axes, the center of the axes, and so on.

The default value is "series".

verticalFocus property
public var verticalFocus:String

Defines the location of the focal point of the zoom. For more information, see the description of the horizontalFocus property.

Valid values of verticalFocus are "top", "center", "bottom", and null.

The default value is "center".

Constructor detail
SeriesZoom () constructor
public function SeriesZoom(target:Object = null)

Constructor.

Parameters
target:Object (default = null)
Examples
SeriesZoomExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the CandlestickChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var companyAAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.75,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 39.98,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);

        [Bindable]
        private var companyBAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 18.50,  High: 19, Low: 18.48, Close:18.86},
            { Date: "26-Jul", Open: 19.56,  High: 19.98, Low: 18.6, Close:18.69},
            { Date: "27-Jul", Open: 20.81,  High: 20.99, Low: 20.03, Close:20.12},
            { Date: "28-Jul", Open: 20.70,  High: 21.00, Low: 19.5, Close:20.84},
            { Date: "29-Jul", Open: 21.7,  High: 21.79, Low: 20.45, Close:20.6},
            { Date: "1-Aug", Open: 22.45,  High: 22.65, Low: 21.65, Close:21.95},
            { Date: "2-Aug", Open: 22.56,  High: 22.6, Low: 22.05, Close:22.98},
            { Date: "3-Aug", Open: 22.42,  High: 22.70, Low: 22.1, Close:22.63},
            { Date: "4-Aug", Open: 21.67,  High: 22.82, Low: 21.67, Close:22.34},
            { Date: "5-Aug", Open: 22.44,  High: 22.85, Low: 22.12, Close:22.31} ]);
        ]]>
    </mx:Script>

    <mx:SeriesZoom id="zoomIn" duration="1000"/>
    <mx:SeriesZoom id="zoomOut" duration="1000"/>

    <mx:Panel title="CandlestickChart Control Example" height="100%" width="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:CandlestickChart id="candlestickchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{companyAAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:CandlestickSeries
                    openField="Open" highField="High"
                    lowField="Low" closeField="Close"
                    showDataEffect="{zoomIn}"
                    hideDataEffect="{zoomOut}"/>
            </mx:series>
        </mx:CandlestickChart>

           <mx:Label width="100%" color="blue"
               text="Choose a company to view recent stock data."/>

           <mx:HBox>
               <mx:RadioButton groupName="stocks" label="View Company A"
                   selected="true" click="candlestickchart.dataProvider=companyAAC;"/>
               <mx:RadioButton groupName="stocks" label="View Company B"
                   click="candlestickchart.dataProvider=companyBAC;"/>
           </mx:HBox>
    </mx:Panel>
</mx:Application>


mx.charts.effects.effectClasses Summary (Flex™ 2 Language Reference)

Package mx.charts.effects.effectClasses | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.effects.effectClasses package contains the effect instance classes for the Flex charting components.

Classes
Class | Description
SeriesEffectInstance | The SeriesEffectInstance class implements the base instance class for the chart series effects.
SeriesInterpolateInstance | The SeriesInterpolateInstance class implements the instance class for the SeriesInterpolate effect.
SeriesSlideInstance | The SeriesSlideInstance class implements the instance class for the SeriesSlide effect.
SeriesZoomInstance | The SeriesZoomInstance class implements the instance class for the SeriesZoom effect.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.effects.effectClasses.SeriesEffectInstance (Flex™ 2 Language Reference)

Class SeriesEffectInstance | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects.effectClasses
Class | public class SeriesEffectInstance
Inheritance | SeriesEffectInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object
Subclasses | SeriesInterpolateInstance, SeriesSlideInstance, SeriesZoomInstance

The SeriesEffectInstance class implements the base instance class for the chart series effects.

See also

mx.charts.effects.SeriesEffect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffectInstance
 | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffectInstance
 | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
 | type : String = "show" The type of transition this effect is being used for. | SeriesEffectInstance
Protected Properties
Property |  | Defined by
 | interpolationValues : Array The current position of each chart item being managed by this effect. | SeriesEffectInstance
 | targetSeries : Series The series targeted by this instance. | SeriesEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesEffectInstance(target:Object = null)
Constructor.
SeriesEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
 | beginTween(elementCount:int):void Initializes the tweening calculations and sets up the interpolationValues Array for the number of items equal to the elementCount property. | SeriesEffectInstance
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
elementOffset property
public var elementOffset:Number = 20

Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series.

Set elementOffset to 0 to affect all elements of the series at the same time. They start the effect at the same time and end it at the same time.

Set elementOffset to a positive integer (such as 30) to stagger the effect on each element by that amount of time. For example, with a slide effect, the first element slides in immediately, then the next element begins 30 milliseconds later, and so on. The amount of time for the effect to execute is the same for each element, but the overall duration of the effect is longer.

Set elementOffset to a negative value to have the effect begin from the last element and move backwards through the list.

The default is 20.

interpolationValues property
protected var interpolationValues:Array

The current position of each chart item being managed by this effect. This is an array of values between 0 and 1 indicating how far the effect should render each item in the series between its starting and ending values. These values are calculated based on the duration, number of elements, element offset, minimum element duration, and easing function.

minimumElementDuration property
public var minimumElementDuration:Number = 0

Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect.

Charts with a variable number of data points in the series cannot reliably create smooth effects with only the duration property. For example, an effect with a duration of 1000 and an elementOffset of 100 takes 900 milliseconds per element to complete an effect if you have two elements in the series. This is because the start of each effect is offset by 100 and each effect finishes in 1000 milliseconds.

If there are four elements in the series, each element takes 700 milliseconds to complete (the last effect starts 300 milliseconds after the first and must be completed within 1000 milliseconds). With 10 elements, each element has only 100 milliseconds

to complete the effect.

The minimumElementDuration value sets a minimal duration for each element. No element of the series takes less than this amount of time (in milliseconds) to execute the effect, regardless of the number of elements in the series and the value of the duration property. As a result, it is possible for an effect to take longer than a specified duration if at least two of the following three properties are specified: duration, offset, and minimumElementDuration.

The default is 0.

offset property
public var offset:Number = 0

Specifies the amount of time, in milliseconds, that Flex delays the effect.

Use this property to stagger effects on multiple series.

The default is 0.

targetSeries property
protected var targetSeries:Series

The series targeted by this instance.

type property
public var type:String = "show"

The type of transition this effect is being used for. Some series effects define different behavior based on whether they are being used during the show or hide portion of a chart transition. The SeriesSlide effect, for example, slides elements from their position off screen when type is set to hide, and on screen when set to show. This property is set automatically by the chart, based on whether the effect is assigned to the ShowDataEffect or HideDataEffect style.

Constructor detail
SeriesEffectInstance () constructor
public function SeriesEffectInstance(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The target of the effect.
Method detail
beginTween () method
protected function beginTween(elementCount:int):void

Initializes the tweening calculations and sets up the interpolationValues Array for the number of items equal to the elementCount property. Derived classes should call this function in their play() method.

Parameters
elementCount:int — The number of elements to generate interpolation values for.


mx.charts.effects.effectClasses.SeriesInterpolateInstance (Flex™ 2 Language Reference)

Class SeriesInterpolateInstance | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects.effectClasses
Class | public class SeriesInterpolateInstance
Inheritance | SeriesInterpolateInstance Inheritance SeriesEffectInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The SeriesInterpolateInstance class implements the instance class for the SeriesInterpolate effect. Flex creates an instance of this class when it plays a SeriesInterpolate effect; you do not create one yourself.

See also

mx.charts.effects.SeriesInterpolate

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffectInstance
Inherited | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffectInstance
Inherited | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Inherited | type : String = "show" The type of transition this effect is being used for. | SeriesEffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | interpolationValues : Array The current position of each chart item being managed by this effect. | SeriesEffectInstance
Inherited | targetSeries : Series The series targeted by this instance. | SeriesEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesInterpolateInstance(target:Object)
Constructor.
SeriesInterpolateInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | beginTween(elementCount:int):void Initializes the tweening calculations and sets up the interpolationValues Array for the number of items equal to the elementCount property. | SeriesEffectInstance
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Constructor detail
SeriesInterpolateInstance () constructor
public function SeriesInterpolateInstance(target:Object)

Constructor.

Parameters
target:Object


mx.charts.effects.effectClasses.SeriesSlideInstance (Flex™ 2 Language Reference)

Class SeriesSlideInstance | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects.effectClasses
Class | public class SeriesSlideInstance
Inheritance | SeriesSlideInstance Inheritance SeriesEffectInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The SeriesSlideInstance class implements the instance class for the SeriesSlide effect. Flex creates an instance of this class when it plays a SeriesSlide effect; you do not create one yourself.

See also

mx.charts.effects.SeriesSlide

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | direction : String = "left" Defines the location from which the series slides. | SeriesSlideInstance
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffectInstance
Inherited | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffectInstance
Inherited | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Inherited | type : String = "show" The type of transition this effect is being used for. | SeriesEffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | interpolationValues : Array The current position of each chart item being managed by this effect. | SeriesEffectInstance
Inherited | targetSeries : Series The series targeted by this instance. | SeriesEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesSlideInstance(target:Object)
Constructor.
SeriesSlideInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | beginTween(elementCount:int):void Initializes the tweening calculations and sets up the interpolationValues Array for the number of items equal to the elementCount property. | SeriesEffectInstance
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
direction property
public var direction:String = "left"

Defines the location from which the series slides. Valid values are "left", "right", "up", and "down". The default value is "left".

Constructor detail
SeriesSlideInstance () constructor
public function SeriesSlideInstance(target:Object)

Constructor.

Parameters
target:Object


mx.charts.effects.effectClasses.SeriesZoomInstance (Flex™ 2 Language Reference)

Class SeriesZoomInstance | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.effects.effectClasses
Class | public class SeriesZoomInstance
Inheritance | SeriesZoomInstance Inheritance SeriesEffectInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The SeriesZoomInstance class implements the instance class for the SeriesZoom effect. Flex creates an instance of this class when it plays a SeriesZoom effect; you do not create one yourself.

See also

mx.charts.effects.SeriesZoom

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | elementOffset : Number = 20 Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series. | SeriesEffectInstance
 | horizontalFocus : String Defines the location of the focul point of the zoom. | SeriesZoomInstance
Inherited | minimumElementDuration : Number = 0 Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect. | SeriesEffectInstance
Inherited | offset : Number = 0 Specifies the amount of time, in milliseconds, that Flex delays the effect. | SeriesEffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relativeTo : String = "series" Controls the bounding box that Flex uses to calculate the focal point of the zooms. | SeriesZoomInstance
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Inherited | type : String = "show" The type of transition this effect is being used for. | SeriesEffectInstance
 | verticalFocus : String Defines the location of the focul point of the zoom. | SeriesZoomInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | interpolationValues : Array The current position of each chart item being managed by this effect. | SeriesEffectInstance
Inherited | targetSeries : Series The series targeted by this instance. | SeriesEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SeriesZoomInstance(target:Object)
Constructor.
SeriesZoomInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | beginTween(elementCount:int):void Initializes the tweening calculations and sets up the interpolationValues Array for the number of items equal to the elementCount property. | SeriesEffectInstance
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
horizontalFocus property
public var horizontalFocus:String

Defines the location of the focul point of the zoom.

Valid values of horizontalFocus are "left", "center", "right", and null.

The default value is "center".

You combine the horizontalFocus and verticalFocus properties to define where the data series zooms in and out from. For example, set horizontalFocus to "left" and verticalFocus to "top" to zoom the series data to and from the top left corner of either the element or the chart (depending on the setting of the relativeTo property).

If you specify only one of these two properties, then the focus is a horizontal or vertical line rather than a point. For example, when you set horizontalFocus to "left" but verticalFocus to null, the element zooms to and from a vertical line along the left edge of its bounding box. Set verticalFocus to "center" to zoom chart elements to and from a horizontal line along the middle of the chart's bounding box.

relativeTo property
public var relativeTo:String = "series"

Controls the bounding box that Flex uses to calculate the focal point of the zooms.

Valid values for relativeTo are "series" and "chart". The default value is "series".

Set to "series" to zoom each element relative to itself. For example, each column of a ColumnChart zooms from the top left of the column, the center of the column, and so on.

Set to "chart" to zoom each element relative to the chart area. For example, each column zooms from the top left of the axes, the center of the axes, and so on.

verticalFocus property
public var verticalFocus:String

Defines the location of the focul point of the zoom.

Valid values of verticalFocus are "top", "center", "bottom", and null. The default value is "center".

For more information, see the description of the horizontalFocus property.

Constructor detail
SeriesZoomInstance () constructor
public function SeriesZoomInstance(target:Object)

Constructor.

Parameters
target:Object


mx.charts.events Summary (Flex™ 2 Language Reference)

Package mx.charts.events | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.events package contains the classes that define chart event objects.

Classes
Class | Description
ChartItemEvent | The ChartItemEvent class represents events that are specific to the chart components, such as when a chart item is clicked.
LegendMouseEvent | The LegendMouseEvent class represents event objects that are specific to the chart legend components.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.events.ChartItemEvent (Flex™ 2 Language Reference)

Class ChartItemEvent | Properties | Methods | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.events
Class | public class ChartItemEvent
Inheritance | ChartItemEvent Inheritance MouseEvent Inheritance Event Inheritance Object

The ChartItemEvent class represents events that are specific to the chart components, such as when a chart item is clicked.

See also

Handling user interactions with charts
Using the HitData object

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | altKey : Boolean Reserved for future use. | MouseEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | buttonDown : Boolean Indicates whether the primary mouse button is pressed (true) or not (false). | MouseEvent
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | ctrlKey : Boolean Indicates whether the Control key is active (true) or inactive (false). | MouseEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | delta : int Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. | MouseEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | hitData : HitData [read-only] The first item in the hitSet array. | ChartItemEvent
 | hitSet : Array A set of HitData structures describing the chart items that triggered the event. | ChartItemEvent
Inherited | localX : Number The horizontal coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | localY : Number The vertical coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relatedObject : InteractiveObject A reference to a display list object that is related to the event. | MouseEvent
Inherited | shiftKey : Boolean Indicates whether the Shift key is active (true) or inactive (false). | MouseEvent
Inherited | stageX : Number The horizontal coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | stageY : Number The vertical coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ChartItemEvent(type:String, hitSet:Array, triggerEvent:MouseEvent, target:ChartBase) Constructor. | ChartItemEvent
Inherited | clone():Event Creates a copy of the MouseEvent object and sets the value of each property to match that of the original. | MouseEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string that contains all the properties of the MouseEvent object. | MouseEvent
Inherited | updateAfterEvent():void Instructs Flash Player to render after processing of this event completes, if the display list has been modified. | MouseEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLICK : String = "click" [static] Defines the value of the type property of a click event object. | MouseEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | DOUBLE_CLICK : String = "doubleClick" [static] Defines the value of the type property of a doubleClick event object. | MouseEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_CLICK : String = "itemClick" [static] Event type constant; indicates that the user clicked the mouse button over a chart item representing data in the chart. | ChartItemEvent
 | ITEM_DOUBLE_CLICK : String = "itemDoubleClick" [static] Event type constant; indicates that the user double-clicked the mouse button over a chart item representing data in the chart. | ChartItemEvent
 | ITEM_MOUSE_DOWN : String = "itemMouseDown" [static] Event type constant; indicates that the user pressed the mouse button over a chart item representing data in the chart. | ChartItemEvent
 | ITEM_MOUSE_MOVE : String = "itemMouseMove" [static] Event type constant; indicates that the user moved the mouse pointer while hovering over a chart item representing data in the chart. | ChartItemEvent
 | ITEM_MOUSE_UP : String = "itemMouseUp" [static] Event type constant; indicates that the user released the mouse button while over a chart item representing data in the chart. | ChartItemEvent
 | ITEM_ROLL_OUT : String = "itemRollOut" [static] Event type constant; indicates that the user rolled the mouse pointer away from a chart item representing data in the chart. | ChartItemEvent
 | ITEM_ROLL_OVER : String = "itemRollOver" [static] Event type constant; indicates that the user rolled the mouse pointer over a chart item representing data in the chart. | ChartItemEvent
Inherited | MOUSE_DOWN : String = "mouseDown" [static] Defines the value of the type property of a mouseDown event object. | MouseEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | MOUSE_MOVE : String = "mouseMove" [static] Defines the value of the type property of a mouseMove event object. | MouseEvent
Inherited | MOUSE_OUT : String = "mouseOut" [static] Defines the value of the type property of a mouseOut event object. | MouseEvent
Inherited | MOUSE_OVER : String = "mouseOver" [static] Defines the value of the type property of a mouseOver event object. | MouseEvent
Inherited | MOUSE_UP : String = "mouseUp" [static] Defines the value of the type property of a mouseUp event object. | MouseEvent
Inherited | MOUSE_WHEEL : String = "mouseWheel" [static] Defines the value of the type property of a mouseWheel event object. | MouseEvent
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | ROLL_OUT : String = "rollOut" [static] Defines the value of the type property of a rollOut event object. | MouseEvent
Inherited | ROLL_OVER : String = "rollOver" [static] Defines the value of the type property of a rollOver event object. | MouseEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
hitData property
hitData:HitData [read-only]

The first item in the hitSet array. This is a convenience function for developers who don't care about events corresponding to multiple items.

Implementation
    public function get hitData():HitData
hitSet property
public var hitSet:Array

A set of HitData structures describing the chart items that triggered the event. This array is in depth order; the first item in the array is the top-most item, and the last is the deepest.

Constructor detail
ChartItemEvent () constructor
public function ChartItemEvent(type:String, hitSet:Array, triggerEvent:MouseEvent, target:ChartBase)

Constructor.

Parameters
type:String — The type of the event.
hitSet:Array — An array of HitData structures describing the ChartItems that triggered the event.
triggerEvent:MouseEvent — The MouseEvent that triggered this ChartItemEvent.
target:ChartBase — The chart on which the event was triggered.
Constant detail
ITEM_CLICK constant
public static const ITEM_CLICK:String = "itemClick"

Event type constant; indicates that the user clicked the mouse button over a chart item representing data in the chart.

ITEM_DOUBLE_CLICK constant
public static const ITEM_DOUBLE_CLICK:String = "itemDoubleClick"

Event type constant; indicates that the user double-clicked the mouse button over a chart item representing data in the chart.

ITEM_MOUSE_DOWN constant
public static const ITEM_MOUSE_DOWN:String = "itemMouseDown"

Event type constant; indicates that the user pressed the mouse button over a chart item representing data in the chart.

ITEM_MOUSE_MOVE constant
public static const ITEM_MOUSE_MOVE:String = "itemMouseMove"

Event type constant; indicates that the user moved the mouse pointer while hovering over a chart item representing data in the chart.

ITEM_MOUSE_UP constant
public static const ITEM_MOUSE_UP:String = "itemMouseUp"

Event type constant; indicates that the user released the mouse button while over a chart item representing data in the chart.

ITEM_ROLL_OUT constant
public static const ITEM_ROLL_OUT:String = "itemRollOut"

Event type constant; indicates that the user rolled the mouse pointer away from a chart item representing data in the chart.

ITEM_ROLL_OVER constant
public static const ITEM_ROLL_OVER:String = "itemRollOver"

Event type constant; indicates that the user rolled the mouse pointer over a chart item representing data in the chart.


mx.charts.events.LegendMouseEvent (Flex™ 2 Language Reference)

Class LegendMouseEvent | Properties | Methods | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.events
Class | public class LegendMouseEvent
Inheritance | LegendMouseEvent Inheritance MouseEvent Inheritance Event Inheritance Object

The LegendMouseEvent class represents event objects that are specific to the chart legend components. such as when a legend item is clicked on.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | altKey : Boolean Reserved for future use. | MouseEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | buttonDown : Boolean Indicates whether the primary mouse button is pressed (true) or not (false). | MouseEvent
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | ctrlKey : Boolean Indicates whether the Control key is active (true) or inactive (false). | MouseEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | delta : int Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. | MouseEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | item : LegendItem The item in the Legend on which this event was triggered. | LegendMouseEvent
Inherited | localX : Number The horizontal coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | localY : Number The vertical coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relatedObject : InteractiveObject A reference to a display list object that is related to the event. | MouseEvent
Inherited | shiftKey : Boolean Indicates whether the Shift key is active (true) or inactive (false). | MouseEvent
Inherited | stageX : Number The horizontal coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | stageY : Number The vertical coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LegendMouseEvent(triggerEvent:MouseEvent, item:LegendItem) Constructor. | LegendMouseEvent
Inherited | clone():Event Creates a copy of the MouseEvent object and sets the value of each property to match that of the original. | MouseEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string that contains all the properties of the MouseEvent object. | MouseEvent
Inherited | updateAfterEvent():void Instructs Flash Player to render after processing of this event completes, if the display list has been modified. | MouseEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLICK : String = "click" [static] Defines the value of the type property of a click event object. | MouseEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | DOUBLE_CLICK : String = "doubleClick" [static] Defines the value of the type property of a doubleClick event object. | MouseEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_CLICK : String = "itemClick" [static] Event type constant; indicates that the user clicked the mouse button over a legend item. | LegendMouseEvent
 | ITEM_MOUSE_DOWN : String = "itemMouseDown" [static] Event type constant; indicates that the user clicked the mouse button over a legend item. | LegendMouseEvent
 | ITEM_MOUSE_OUT : String = "itemMouseOut" [static] Event type constant; indicates that the user rolled the mouse pointer away from a legend item. | LegendMouseEvent
 | ITEM_MOUSE_OVER : String = "itemMouseOver" [static] Event type constant; indicates that the user rolled the mouse pointer over a legend item. | LegendMouseEvent
 | ITEM_MOUSE_UP : String = "itemMouseUp" [static] Event type constant; indicates that the user released the mouse button while over a legend item. | LegendMouseEvent
Inherited | MOUSE_DOWN : String = "mouseDown" [static] Defines the value of the type property of a mouseDown event object. | MouseEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | MOUSE_MOVE : String = "mouseMove" [static] Defines the value of the type property of a mouseMove event object. | MouseEvent
Inherited | MOUSE_OUT : String = "mouseOut" [static] Defines the value of the type property of a mouseOut event object. | MouseEvent
Inherited | MOUSE_OVER : String = "mouseOver" [static] Defines the value of the type property of a mouseOver event object. | MouseEvent
Inherited | MOUSE_UP : String = "mouseUp" [static] Defines the value of the type property of a mouseUp event object. | MouseEvent
Inherited | MOUSE_WHEEL : String = "mouseWheel" [static] Defines the value of the type property of a mouseWheel event object. | MouseEvent
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | ROLL_OUT : String = "rollOut" [static] Defines the value of the type property of a rollOut event object. | MouseEvent
Inherited | ROLL_OVER : String = "rollOver" [static] Defines the value of the type property of a rollOver event object. | MouseEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
item property
public var item:LegendItem

The item in the Legend on which this event was triggered.

Constructor detail
LegendMouseEvent () constructor
public function LegendMouseEvent(triggerEvent:MouseEvent, item:LegendItem)

Constructor.

Parameters
triggerEvent:MouseEvent — The MouseEvent that triggered this LegentMouseEvent.
item:LegendItem — The item in the Legend on which this event was triggered.
Constant detail
ITEM_CLICK constant
public static const ITEM_CLICK:String = "itemClick"

Event type constant; indicates that the user clicked the mouse button over a legend item.

ITEM_MOUSE_DOWN constant
public static const ITEM_MOUSE_DOWN:String = "itemMouseDown"

Event type constant; indicates that the user clicked the mouse button over a legend item.

ITEM_MOUSE_OUT constant
public static const ITEM_MOUSE_OUT:String = "itemMouseOut"

Event type constant; indicates that the user rolled the mouse pointer away from a legend item.

ITEM_MOUSE_OVER constant
public static const ITEM_MOUSE_OVER:String = "itemMouseOver"

Event type constant; indicates that the user rolled the mouse pointer over a legend item.

ITEM_MOUSE_UP constant
public static const ITEM_MOUSE_UP:String = "itemMouseUp"

Event type constant; indicates that the user released the mouse button while over a legend item.


mx.charts.renderers Summary (Flex™ 2 Language Reference)

Package mx.charts.renderers | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.renderers package contains the item renderer classes for the Flex charting components.

Classes
Class | Description
AreaRenderer | The default class used to render the area beneath the dataPoints of an AreaSeries object.
BoxItemRenderer | A simple chart itemRenderer implementation that fills a rectangular area.
CandlestickItemRenderer | The default itemRenderer for a CandlestickSeries object.
CircleItemRenderer | A simple chart itemRenderer implementation that fills an elliptical area.
CrossItemRenderer | A simple chart itemRenderer implementation that fills a cross in its assigned area.
DiamondItemRenderer | A simple chart itemRenderer implementation that fills a diamond in its assigned area.
HLOCItemRenderer | The default item Rnderer for an HLOCSeries object.
LineRenderer | A simple implementation of a line segment renderer that is used by LineSeries objects.
ShadowBoxItemRenderer | A simple chart itemRenderer implementation that fills a rectangular area and surrounds it with a drop shadow.
ShadowLineRenderer | An implementation of a line segment renderer that is used by LineSeries objects.
TriangleItemRenderer | A simple chart itemRenderer implementation that fills an upright triangle in its assigned area.
WedgeItemRenderer | The default itemRenderer for a PieSeries object.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.renderers.AreaRenderer (Flex™ 2 Language Reference)

Class AreaRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class AreaRenderer
Inheritance | AreaRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

The default class used to render the area beneath the dataPoints of an AreaSeries object. This class renders the area using the fill, stroke, and line type as specified by the AreaSeries object's areaFill, areaStroke, and type styles, respectively.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The data that the AreaRenderer renders. | AreaRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AreaRenderer()
Constructor.
AreaRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The data that the AreaRenderer renders. The AreaRenderer expects this property to be assigned an instance of mx.charts.series.renderData.AreaRenderData.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
AreaRenderer () constructor
public function AreaRenderer()

Constructor.


mx.charts.renderers.BoxItemRenderer (Flex™ 2 Language Reference)

Class BoxItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class BoxItemRenderer
Inheritance | BoxItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

A simple chart itemRenderer implementation that fills a rectangular area. This class is the default itemRenderer for ColumnSeries and BarSeries objects. It can be used as an itemRenderer for ColumnSeries, BarSeries, AreaSeries, LineSeries, PlotSeries, and BubbleSeries objects. This class renders its area on screen using the fill and stroke styles of its associated series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The chartItem that this itemRenderer is displaying. | BoxItemRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BoxItemRenderer()
Constructor.
BoxItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The chartItem that this itemRenderer is displaying. The BoxRenderer does not depend on any properties of the chart item.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
BoxItemRenderer () constructor
public function BoxItemRenderer()

Constructor.


mx.charts.renderers.CandlestickItemRenderer (Flex™ 2 Language Reference)

Class CandlestickItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class CandlestickItemRenderer
Inheritance | CandlestickItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

The default itemRenderer for a CandlestickSeries object. This class renders a standard CandlestickChart item by using the stroke, boxStroke, fill, and declineFill styles of its associated series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The chart item that this renderer represents. | CandlestickItemRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CandlestickItemRenderer()
Constructor.
CandlestickItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The chart item that this renderer represents. CandlestickItemRenderers assume that this value is an instance of HLOCSeriesItem. This value is assigned by the owning series.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
CandlestickItemRenderer () constructor
public function CandlestickItemRenderer()

Constructor.


mx.charts.renderers.CircleItemRenderer (Flex™ 2 Language Reference)

Class CircleItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class CircleItemRenderer
Inheritance | CircleItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

A simple chart itemRenderer implementation that fills an elliptical area. This class can be used as an itemRenderer for ColumnSeries, BarSeries, AreaSeries, LineSeries, PlotSeries, and BubbleSeries objects. It renders its area on screen using the fill and stroke styles of its associated series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The chartItem that this itemRenderer displays. | CircleItemRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CircleItemRenderer()
Constructor.
CircleItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The chartItem that this itemRenderer displays. The BoxRenderer does not depend on any properties of the chart item.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
CircleItemRenderer () constructor
public function CircleItemRenderer()

Constructor.


mx.charts.renderers.CrossItemRenderer (Flex™ 2 Language Reference)

Class CrossItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class CrossItemRenderer
Inheritance | CrossItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A simple chart itemRenderer implementation that fills a cross in its assigned area. This class can be used as an itemRenderer for ColumnSeries, BarSeries, AreaSeries, LineSeries, PlotSeries, and BubbleSeries objects. It renders its area on screen using the fill and stroke styles of its associated series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
 | thickness : Number = 3 The thickness of the cross rendered, in pixels. | CrossItemRenderer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CrossItemRenderer()
Constructor
CrossItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
thickness property
public var thickness:Number = 3

The thickness of the cross rendered, in pixels. To create cross renderers of other widths, developers should extend this class and change this value in the derived class' constructor.

Constructor detail
CrossItemRenderer () constructor
public function CrossItemRenderer()

Constructor


mx.charts.renderers.DiamondItemRenderer (Flex™ 2 Language Reference)

Class DiamondItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class DiamondItemRenderer
Inheritance | DiamondItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A simple chart itemRenderer implementation that fills a diamond in its assigned area. This class can be used as an itemRenderer for ColumnSeries, BarSeries, AreaSeries, LineSeries, PlotSeries, and BubbleSeries objects. It renders its area on screen using the fill and stroke styles of its associated series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DiamondItemRenderer()
Constructor.
DiamondItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
DiamondItemRenderer () constructor
public function DiamondItemRenderer()

Constructor.


mx.charts.renderers.HLOCItemRenderer (Flex™ 2 Language Reference)

Class HLOCItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class HLOCItemRenderer
Inheritance | HLOCItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

The default item Rnderer for an HLOCSeries object. This class renders a vertical line from high to low with tick marks at the open and close points of the chart item.

The vertical line is rendered by using the value of the owning series's stroke style. The open and close tick marks are rendered by using the owning series's openTickStroke and closeTickStroke styles, respectively. The lengths of the open and close tick marks are determined by the owning series's openTickLength and closeTickLengthstyles, respectively.

Both the open tick and close tick values are optional; an HLOCItemRenderer only renders the tick marks if the open and close values on the associated chart item are non-NaN values.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The chart item that this renderer represents. | HLOCItemRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HLOCItemRenderer()
Constructor.
HLOCItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The chart item that this renderer represents. HLOCItemRenderers assume this value is an instance of HLOCSeriesItem. This value is assigned by the owning series.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
HLOCItemRenderer () constructor
public function HLOCItemRenderer()

Constructor.


mx.charts.renderers.LineRenderer (Flex™ 2 Language Reference)

Class LineRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class LineRenderer
Inheritance | LineRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

A simple implementation of a line segment renderer that is used by LineSeries objects. This class renders a line on screen using the stroke and form defined by the owning series's lineStroke and form styles, respectively.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The chart item that this renderer represents. | LineRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LineRenderer()
Constructor.
LineRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The chart item that this renderer represents. LineRenderers assume that this value is an instance of LineSeriesItem. This value is assigned by the owning series.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
LineRenderer () constructor
public function LineRenderer()

Constructor.


mx.charts.renderers.ShadowBoxItemRenderer (Flex™ 2 Language Reference)

Class ShadowBoxItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class ShadowBoxItemRenderer
Inheritance | ShadowBoxItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A simple chart itemRenderer implementation that fills a rectangular area and surrounds it with a drop shadow. This class can be used as an itemRenderer for ColumnSeries, BarSeries, AreaSeries, LineSeries, PlotSeries, and BubbleSeries objects. It renders its area on screen using the fill and stroke styles of its associated series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ShadowBoxItemRenderer()
Constructor.
ShadowBoxItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ShadowBoxItemRenderer () constructor
public function ShadowBoxItemRenderer()

Constructor.


mx.charts.renderers.ShadowLineRenderer (Flex™ 2 Language Reference)

Class ShadowLineRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class ShadowLineRenderer
Inheritance | ShadowLineRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

An implementation of a line segment renderer that is used by LineSeries objects. This class renders a line on screen with a dropshadow by using the stroke and form defined by the owning series's lineStroke and form styles, respectively.

ShadowLineRenderer is the default lineSegmentRenderer for the LineSeries class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The chart item that this renderer represents. | ShadowLineRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ShadowLineRenderer()
Constructor.
ShadowLineRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The chart item that this renderer represents. ShadowLineRenderers assume that this value is an instance of LineSeriesItem. This value is assigned by the owning series.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
ShadowLineRenderer () constructor
public function ShadowLineRenderer()

Constructor.


mx.charts.renderers.TriangleItemRenderer (Flex™ 2 Language Reference)

Class TriangleItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class TriangleItemRenderer
Inheritance | TriangleItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A simple chart itemRenderer implementation that fills an upright triangle in its assigned area. This class can be used as an itemRenderer for ColumnSeries, BarSeries, AreaSeries, LineSeries, PlotSeries, and BubbleSeries objects. It renders its area on screen using the fill and stroke styles of its associated series.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TriangleItemRenderer()
Constructor.
TriangleItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
TriangleItemRenderer () constructor
public function TriangleItemRenderer()

Constructor.


mx.charts.renderers.WedgeItemRenderer (Flex™ 2 Language Reference)

Class WedgeItemRenderer | Properties | Methods | Events
(Adobe® Flex™ Charting components only)
Package | mx.charts.renderers
Class | public class WedgeItemRenderer
Inheritance | WedgeItemRenderer Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

The default itemRenderer for a PieSeries object. This class renders a wedge using the stroke and radialStroke styles of the owning series to draw the inner and outer edges and side edges of the wedge, respectively. The wedge is filled using the value of the fill property of the associated chart item.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The chart item that this renderer represents. | WedgeItemRenderer
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WedgeItemRenderer()
Constructor.
WedgeItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
data property
data:Object [read-write]

The chart item that this renderer represents. WedgeItemRenderers assume that this value is an instance of PieSeriesItem. This value is assigned by the owning series.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
WedgeItemRenderer () constructor
public function WedgeItemRenderer()

Constructor.


mx.charts.series Summary (Flex™ 2 Language Reference)

Package mx.charts.series | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.renderers package contains the series classes for the Flex charting components.

Classes
Class | Description
AreaSeries | Defines a data series for an AreaChart control.
AreaSet | A grouping set that can be used to stack AreaSeries objects in any chart.
BarSeries | Defines a data series for a BarChart control.
BarSet | A grouping set that can be used to stack or cluster BarSeries objects in any chart.
BubbleSeries | Defines a data series for a BubbleChart control.
CandlestickSeries | Represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
ColumnSeries | Defines a data series for a ColumnChart control.
ColumnSet | ColumnSet is a grouping set that can be used to stack or cluster column series in any arbitrary chart.
HLOCSeries | Represents financial data as a series of elements representing the high, low, closing, and, optionally, opening values of a data series.
LineSeries | Defines a data series for a LineChart control.
PieSeries | The PieSeries class defines the data series for a PieChart control.
PlotSeries | Defines a data series for a PlotChart control.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.series.AreaSeries (Flex™ 2 Language Reference)

Class AreaSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class AreaSeries
Inheritance | AreaSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IStackable

Defines a data series for an AreaChart control. By default, this class uses the AreaRenderer itemRenderer. Optionally, you can define a different itemRenderer for the data series. The itemRenderer must implement the IDataRenderer interface.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:AreaSeries> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:AreaSeries
    Properties
    minField="null"
    stacker="No default"
    stackTotals="No default"
    xField="null"
    yField="null"

    Styles
    areaFill="IFill"
    areaRenderer="areaRenderer"
    areaStroke="Stroke"
    fill="IFill; no default"
    form="segment|curve|horizontal|reverseStep|step|vertical"
    itemRenderer="itemRenderer"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    radius="4"
    stroke="IStroke; no default"
  />

View the examples.

See also

mx.charts.AreaChart
Using the charting controls
Using area charts
Using strokes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | minField : String Specifies the field of the dataProvider that determines the bottom boundary of the area. | AreaSeries
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | sortOnXField : Boolean Requests the line datapoints be sorted from left to right before rendering. | AreaSeries
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
 | stacker : StackedSeries The StackedSeries associated with this AreaSeries. | AreaSeries
 | stackTotals : Dictionary [write-only] The stack totals for the series. | AreaSeries
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xField : String Specifies the field of the data provider that determines the position of the data points on the horizontal axis. | AreaSeries
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yField : String Specifies the field of the data provider that determines the position of the data point on the vertical axis. | AreaSeries
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | AreaSeries
Inherited | renderData : Object Stores the information necessary to render this series. | Series
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | AreaSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AreaSeries()
Constructor.
AreaSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
stack(stackedXValueDictionary:Dictionary, previousElement:IStackable):Number
Stacks the series.
AreaSeries
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void
Customizes the item renderer instances used to represent the chart.
AreaSeries
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
AreaSeries
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
AreaSeries
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
areaFill
Type: mx.graphics.IFill CSS Inheritance: no
Sets the fill for the area. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. 		AreaSeries
areaRenderer
Type: mx.core.IFactory CSS Inheritance: no
The class that the series uses to represent the filled area on the chart. This class is instantiated once per series. Classes used as areaRenderers should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the AreaSeriesRenderData that describes the area data. 		AreaSeries
areaStroke
Type: mx.graphics.IStroke CSS Inheritance: no
Sets the line style for the area. You use a Stroke object to define the stroke. You can specify the itemRenderer in MXML or using styles. 		AreaSeries
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fill
Type: mx.graphics.IFill CSS Inheritance: no
Sets the fill for this data series. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. 		AreaSeries
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
form
Type: String CSS Inheritance: no
Specifies the boundary type for the area. Possible values are:
  • "curve" - Draws curves for the boundary between data points.
  • "horizontal" - Draws only the boundary from the x-coordinate of the first point to the x-coordinate of the second point at the y-coordinate of the second point. Repeats this for each data point.
  • "reverseStep" - Draws boundaries of the area as horizontal segments. At the first data point, draws a vertical boundary line and then a horizontal boundary line to the second point, and repeats for each data point.
  • "segment" - Draws boundaries of the area as connected segments that are angled to connect at each data point in the series.
  • "step" - Draws boundaries of the area as horizontal segments. At the first data point, draws a horizontal boundary line and then a vertical boundary line to the second point, and repeats for each data point.
  • "vertical" - Draws only the boundary from the y-coordinate of the first point to the y-coordinate of the second point at the x-coordinate of the second point. Repeats this for each data point.
The default value is segment. 		AreaSeries
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
itemRenderer
Type: mx.core.IFactory CSS Inheritance: no
A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. 		AreaSeries
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
legendMarkerRenderer
Type: mx.core.IFactory CSS Inheritance: no
The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. 		AreaSeries
radius
Type: Number Format: Length CSS Inheritance: no
Specifies the radius, in pixels, of the chart elements for the data points. This property only applies if you specify an itemRenderer property. You can specify the itemRenderer in MXML or using styles. The default value is 4. 		AreaSeries
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
stroke
Type: mx.graphics.IStroke CSS Inheritance: no
Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. 		AreaSeries
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items

Implementation
    protected function get itemType():Class
minField property
minField:String [read-write]

Specifies the field of the dataProvider that determines the bottom boundary of the area. If null, the area is based at the range minimum (or maximum, if the field value is negative).

The default value is null.

Implementation
    public function get minField():String
    public function set minField(value:String):void
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
sortOnXField property
public var sortOnXField:Boolean

Requests the line datapoints be sorted from left to right before rendering.

By default, the LineSeries renders points from left to right. Set this property to false to render the items in the order they appear in the data provider.

The default value is true.

stacker property
stacker:StackedSeries [read-write]

The StackedSeries associated with this AreaSeries. The stacker manages the series's stacking behavior.

Implementation
    public function get stacker():StackedSeries
    public function set stacker(value:StackedSeries):void
stackTotals property
stackTotals:Dictionary [write-only]

The stack totals for the series.

Implementation
    public function set stackTotals(value:Dictionary):void
xField property
xField:String [read-write]

Specifies the field of the data provider that determines the position of the data points on the horizontal axis. If null, the data points are rendered in the order they appear in the data provider.

The default value is null.

Implementation
    public function get xField():String
    public function set xField(value:String):void
yField property
yField:String [read-write]

Specifies the field of the data provider that determines the position of the data point on the vertical axis. If null, the AreaSeries assumes the dataProvider is an Array of numbers, and uses the numbers as values for the data points.

The default value is null.

Implementation
    public function get yField():String
    public function set yField(value:String):void
Constructor detail
AreaSeries () constructor
public function AreaSeries()

Constructor.

Method detail
applyItemRendererProperties () method
protected function applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void

Customizes the item renderer instances used to represent the chart. This method is called automatically whenever a new item renderer is needed while the chart is being rendered. You can override this method to add your own customization as necessary.

Parameters
instance:DisplayObject — The new item renderer instance that is being created.
cache:InstanceCache — The InstanceCache that is used to manage the item renderer instances.
invalidateData () method
protected override function invalidateData(invalid:Boolean = true):void

Informs the series that the underlying data in the dataProvider has changed. This function triggers calls to the updateData(), updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
invalidateMapping () method
protected override function invalidateMapping(invalid:Boolean = true):void

Informs the series that the mapping of the data into numeric values has changed and must be recalculated. Calling this function triggers calls to the updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
stack () method
public function stack(stackedXValueDictionary:Dictionary, previousElement:IStackable):Number

Stacks the series. Normally, a series implements the updateData() method to load its data out of the data provider. But a stacking series performs special operations because its values are not necessarily stored in its data provider. Its values are whatever is stored in its data provider, summed with the values that are loaded by the object it stacks on top of.

A custom stacking series should implement the stack() method by loading its data out of its data provider, adding it to the base values stored in the dictionary to get the real values it should render with, and replacing the values in the dictionary with its new, summed values.

Parameters
stackedXValueDictionary:Dictionary — Contains the base values that the series should stack on top of. The keys in the dictionary are the y values, and the values are the x values.
previousElement:IStackable — The previous element in the stack. If, for example, the element is of the same type, you can use access to this property to avoid duplicate effort when rendering.

Returns
Number — The maximum value in the newly stacked series.
Examples
Line_AreaChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the LineChart and AreaChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="LineChart and AreaChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:LineChart id="linechart" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:LineSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:LineSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:LineSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:LineChart>

        <mx:Legend dataProvider="{linechart}"/>

        <mx:AreaChart id="Areachart" height="100%" width="45%"
             paddingLeft="5" paddingRight="5"
             showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:AreaSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:AreaSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:AreaSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:AreaChart>

        <mx:Legend dataProvider="{Areachart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.series.AreaSet (Flex™ 2 Language Reference)

Class AreaSet | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class AreaSet
Inheritance | AreaSet Inheritance StackedSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A grouping set that can be used to stack AreaSeries objects in any chart. An AreaSet encapsulates the same stacking behavior that is used in an AreaChart control, but can be used to assemble custom charts that are based on the CartesianChart class.

Default MXML Property series

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | series : Array An array of sub-series managed by this stacking set. | StackedSeries
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | type : String The grouping behavior of this series. | StackedSeries
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | renderData : Object Stores the information necessary to render this series. | Series
Inherited | stackedMaximum : Number The maximum sum represented by this stacked series. | StackedSeries
Inherited | totalsByPrimaryAxis : Dictionary The summed totals of the stacked values. | StackedSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AreaSet()
Constructor.
AreaSet
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
invalidateStacking():void
Call this method to trigger a regeneration of the stacked values on the next call to the commitProperties() method.
StackedSeries
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
stack():void
Updates the series data, and uses the values of the series data it is stacking on top of so it can stack correctly.
StackedSeries
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
buildSubSeries():void
Processes the Array of sub-series for display, when necessary.
StackedSeries
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
customizeSeries(g:IChartElement, i:uint):void
Applies any customization to a sub-series when building the stacking behavior.
StackedSeries
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
formatDataTip(hitData:HitData):String
Provides custom text for DataTips.
StackedSeries
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateSeries():void
Call this method to trigger a call to the buildSubSeries() method on the next call to the commitProperties() method.
StackedSeries
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateStacking():void
Iterates over the individual sub-series to build the stacked values.
StackedSeries
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
AreaSet () constructor
public function AreaSet()

Constructor.


mx.charts.series.BarSeries (Flex™ 2 Language Reference)

Class BarSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class BarSeries
Inheritance | BarSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IBar, IStackable

Defines a data series for a BarChart control. By default, this class uses the BoxItemRenderer class. Optionally, you can define an itemRenderer for the data series. The itemRenderer must implement the IDataRenderer interface.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:BarSeries> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:BarSeries
    Properties
    barWidthRatio=".65"
    maxBarWidth="No default"
    minField="null"
    offset="No default"
    stacker="No default"
    stackTotals="No default"
    xField="null"
    yField="null"

    Styles
    fill="IFill; no default"
    itemRenderer="itemRenderer"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    stroke="IStroke; no default"
  />

View the examples.

See also

mx.charts.BarChart
Using the charting controls
Using bar charts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | barWidthRatio : Number Specifies how wide to render the bars relative to the category width. | BarSeries
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxBarWidth : Number Specifies the width of the bars, in pixels. | BarSeries
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | minField : String Specifies the field of the data provider that determines the bottom of each bar. | BarSeries
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
 | offset : Number Specifies how far to offset the center of the bars from the center of the available space, relative the category width. | BarSeries
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
 | stacker : StackedSeries The StackedSeries associated with this BarSeries. | BarSeries
 | stackTotals : Dictionary [write-only] The stack totals for the series. | BarSeries
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xField : String Specifies the field of the data provider that determines the x-axis location of the top of each bar. | BarSeries
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yField : String Specifies the field of the data provider that determines the y-axis location of the bottom of each bar in the chart. | BarSeries
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | BarSeries
Inherited | renderData : Object Stores the information necessary to render this series. | Series
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | BarSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BarSeries()
Constructor.
BarSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
stack(stackedYValueDictionary:Dictionary, previousElement:IStackable):Number
Stacks the series.
BarSeries
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void
Customizes the item renderer instances that are used to represent the chart.
BarSeries
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
BarSeries
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
BarSeries
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fill | Type: mx.graphics.IFill CSS Inheritance: no Sets the fill for this data series. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. | BarSeries
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | itemRenderer | Type: mx.core.IFactory CSS Inheritance: no A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. | BarSeries
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. | BarSeries
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | stroke | Type: mx.graphics.IStroke CSS Inheritance: no Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. | BarSeries
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
barWidthRatio property
barWidthRatio:Number [read-write]

Specifies how wide to render the bars relative to the category width. A value of 1 uses the entire space, while a value of .6 uses 60% of the bar's available space. You typically do not set this property directly. The actual bar width used is the smaller of barWidthRatio and the maxbarWidth property

The default value is .65.

Implementation
    public function get barWidthRatio():Number
    public function set barWidthRatio(value:Number):void
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items.

Implementation
    protected function get itemType():Class
maxBarWidth property
maxBarWidth:Number [read-write]

Specifies the width of the bars, in pixels. The actual bar width used is the smaller of this style and the barWidthRatio property. Clustered bars divide this space proportionally among the bars in each cluster.

Implementation
    public function get maxBarWidth():Number
    public function set maxBarWidth(value:Number):void
minField property
minField:String [read-write]

Specifies the field of the data provider that determines the bottom of each bar. If null, the columns are based at the range minimum (or maximum, if the field value is negative).

The default value is null.

Implementation
    public function get minField():String
    public function set minField(value:String):void
offset property
offset:Number [read-write]

Specifies how far to offset the center of the bars from the center of the available space, relative the category width. The range of values is a percentage in the range -100 to 100. Set to 0 to center the bars in the space. Set to -50 to center the column at the beginning of the available space. You typically do not set this property directly.

The default value is 0.

Implementation
    public function get offset():Number
    public function set offset(value:Number):void
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
stacker property
stacker:StackedSeries [read-write]

The StackedSeries associated with this BarSeries. The stacker manages the series's stacking behavior.

Implementation
    public function get stacker():StackedSeries
    public function set stacker(value:StackedSeries):void
stackTotals property
stackTotals:Dictionary [write-only]

The stack totals for the series.

Implementation
    public function set stackTotals(value:Dictionary):void
xField property
xField:String [read-write]

Specifies the field of the data provider that determines the x-axis location of the top of each bar. If null, the BarSeries assumes that the data provider is an Array of numbers, and uses the numbers as values.

The default value is null.

Implementation
    public function get xField():String
    public function set xField(value:String):void
yField property
yField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of the bottom of each bar in the chart. If null, Flex arranges the bars in the order of the data in the data provider.

The default value is null.

Implementation
    public function get yField():String
    public function set yField(value:String):void
Constructor detail
BarSeries () constructor
public function BarSeries()

Constructor.

Method detail
applyItemRendererProperties () method
protected function applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void

Customizes the item renderer instances that are used to represent the chart. This method is called automatically whenever a new item renderer is needed while the chart is being rendered. You can override this method to add your own customization as necessary.

Parameters
instance:DisplayObject — The new item renderer instance that is being created.
cache:InstanceCache — The InstanceCache that is being used to manage the item renderer instances.
invalidateData () method
protected override function invalidateData(invalid:Boolean = true):void

Informs the series that the underlying data in the dataProvider has changed. This function triggers calls to the updateData(), updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
invalidateMapping () method
protected override function invalidateMapping(invalid:Boolean = true):void

Informs the series that the mapping of the data into numeric values has changed and must be recalculated. Calling this function triggers calls to the updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
stack () method
public function stack(stackedYValueDictionary:Dictionary, previousElement:IStackable):Number

Stacks the series. Normally, a series implements the updateData() method to load its data out of the data provider. But a stacking series performs special operations because its values are not necessarily stored in its data provider. Its values are whatever is stored in its data provider, summed with the values that are loaded by the object it stacks on top of.

A custom stacking series should implement the stack() method by loading its data out of its data provider, adding it to the base values stored in the dictionary to get the real values it should render with, and replacing the values in the dictionary with its new, summed values.

Parameters
stackedYValueDictionary:Dictionary — Contains the base values that the series should stack on top of. The keys in the dictionary are the x values, and the values are the y values.
previousElement:IStackable — The previous element in the stack. If, for example, the element is of the same type, you can use access to this property to avoid duplicate effort when rendering.

Returns
Number — The maximum value in the newly stacked series.
Examples
Column_BarChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ColumnChart and BarChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var medalsAC:ArrayCollection = new ArrayCollection( [
            { Country: "USA", Gold: 35, Silver:39, Bronze: 29 },
            { Country: "China", Gold: 32, Silver:17, Bronze: 14 },
            { Country: "Russia", Gold: 27, Silver:27, Bronze: 38 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="ColumnChart and BarChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:ColumnChart id="column" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:ColumnSeries xField="Country" yField="Gold" displayName="Gold"/>
                <mx:ColumnSeries xField="Country" yField="Silver" displayName="Silver"/>
                <mx:ColumnSeries xField="Country" yField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:ColumnChart>

        <mx:Legend dataProvider="{column}"/>

         <mx:BarChart id="bar" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:verticalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:verticalAxis>

            <mx:series>
                <mx:BarSeries yField="Country" xField="Gold" displayName="Gold"/>
                <mx:BarSeries yField="Country" xField="Silver" displayName="Silver"/>
                <mx:BarSeries yField="Country" xField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:BarChart>

        <mx:Legend dataProvider="{bar}"/>

    </mx:Panel>
</mx:Application>


mx.charts.series.BarSet (Flex™ 2 Language Reference)

Class BarSet | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class BarSet
Inheritance | BarSet Inheritance StackedSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IBar

A grouping set that can be used to stack or cluster BarSeries objects in any chart. A BarSet encapsulates the same grouping behavior that is used in a BarChart control, but it can be used to assemble custom charts that are based on the CartesianChart class. BarSets can be used to cluster any chart element type that implements the IBar interface. It can stack any chart element type that implements the IBar and IStackable interfaces. Because the BarSet class implements the IBar interface, you can use BarSets to cluster other BarSets to build more advanced custom charts.

Default MXML Property series

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | barWidthRatio : Number Specifies how wide to render the bars relative to the category width. | BarSet
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxBarWidth : Number Specifies how wide to draw the bars, in pixels. | BarSet
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
 | offset : Number Specifies how far to offset the center of the bars from the center of the available space, relative the category width. | BarSet
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | series : Array An array of sub-series managed by this stacking set. | StackedSeries
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | type : String The grouping behavior of this series. | StackedSeries
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | renderData : Object Stores the information necessary to render this series. | Series
Inherited | stackedMaximum : Number The maximum sum represented by this stacked series. | StackedSeries
Inherited | totalsByPrimaryAxis : Dictionary The summed totals of the stacked values. | StackedSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BarSet()
Constructor.
BarSet
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
invalidateStacking():void
Call this method to trigger a regeneration of the stacked values on the next call to the commitProperties() method.
StackedSeries
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
stack():void
Updates the series data, and uses the values of the series data it is stacking on top of so it can stack correctly.
StackedSeries
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
buildSubSeries():void
Processes the Array of sub-series for display, when necessary.
StackedSeries
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
customizeSeries(g:IChartElement, i:uint):void
Applies any customization to a sub-series when building the stacking behavior.
StackedSeries
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
formatDataTip(hitData:HitData):String
Provides custom text for DataTips.
StackedSeries
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateSeries():void
Call this method to trigger a call to the buildSubSeries() method on the next call to the commitProperties() method.
StackedSeries
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateStacking():void
Iterates over the individual sub-series to build the stacked values.
StackedSeries
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
barWidthRatio property
barWidthRatio:Number [read-write]

Specifies how wide to render the bars relative to the category width. A value of 1 uses the entire space, while a value of .6 uses 60% of the bar's available space. You typically do not set this property directly. The actual bar width used is the smaller of barWidthRatio and the maxbarWidth property

The default value is 0.65.

Implementation
    public function get barWidthRatio():Number
    public function set barWidthRatio(value:Number):void
maxBarWidth property
maxBarWidth:Number [read-write]

Specifies how wide to draw the bars, in pixels. The actual bar width used is the smaller of this style and the barWidthRatio property. Clustered bars divide this space proportionally among the bars in each cluster.

Implementation
    public function get maxBarWidth():Number
    public function set maxBarWidth(value:Number):void
offset property
offset:Number [read-write]

Specifies how far to offset the center of the bars from the center of the available space, relative the category width. The range of values is a percentage in the range -100 to 100. Set to 0 to center the bars in the space. Set to -50 to center the column at the beginning of the available space. You typically do not set this property directly.

The default value is 0.

Implementation
    public function get offset():Number
    public function set offset(value:Number):void
Constructor detail
BarSet () constructor
public function BarSet()

Constructor.


mx.charts.series.BubbleSeries (Flex™ 2 Language Reference)

Class BubbleSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class BubbleSeries
Inheritance | BubbleSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Defines a data series for a BubbleChart control. The default itemRenderer is the CircleRenderer class. Optionally, you can define an itemRenderer for the data series. The itemRenderer must implement the IDataRenderer interface.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:BubbleSeries> tag inherits all the properties of its parent classes, and the following properties:

  <mx:BubbleSeries
    Properties
    itemType=""
    legendData=""
    maxRadius=""
    radiusField="No default"
    renderData=""
    renderDataType=""
    xField="null"
    yField="null"

    Styles
    fill="IFill; no default"
    itemRenderer="itemRenderer"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    stroke="IStroke; no default"
  />

View the examples.

See also

mx.charts.BubbleChart
Using the charting controls
Using bubble charts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
 | legendData : Array [read-only] An Array of LegendData instances that describe the items that should show up in a legend representing this series. | BubbleSeries
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxRadius : Number = 50 The radius of the largest item rendererd in this series. | BubbleSeries
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radiusField : String Specifies the field of the data provider that determines the radius of each symbol, relative to the other data points in the chart. | BubbleSeries
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xField : String Specifies the field of the data provider that determines the x-axis location of each data point. | BubbleSeries
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yField : String Specifies the field of the data provider that determines the y-axis location of each data point. | BubbleSeries
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | BubbleSeries
 | renderData : Object [read-only] Stores the information necessary to render this series. | BubbleSeries
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | BubbleSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BubbleSeries()
Constructor.
BubbleSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
BubbleSeries
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
BubbleSeries
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
BubbleSeries
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
BubbleSeries
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
styleChanged(styleProp:String):void
Detects changes to style properties.
BubbleSeries
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void
Applies style properties to the specified DisplayObject.
BubbleSeries
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
BubbleSeries
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
BubbleSeries
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
BubbleSeries
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
BubbleSeries
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
BubbleSeries
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
BubbleSeries
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fill | Type: mx.graphics.IFill CSS Inheritance: no Sets the fill for this data series. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. | BubbleSeries
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | itemRenderer | Type: mx.core.IFactory CSS Inheritance: no A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. | BubbleSeries
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. | BubbleSeries
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | stroke | Type: mx.graphics.IStroke CSS Inheritance: no Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. | BubbleSeries
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
 | RADIUS_AXIS : String = "bubbleRadius" [static] The type of radius axis. | BubbleSeries
Property detail
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items.

Implementation
    protected function get itemType():Class
legendData property
legendData:Array [read-only]

An Array of LegendData instances that describe the items that should show up in a legend representing this series. Derived series classes override this getter and return LegendData specific to their styles and data representation method. While most series types return only a single LegendData instance, some series types, such as PieSeries and StackedSeries, return multiple instances representing individual items in the array, or multiple ways of rendering data.

Implementation
    public function get legendData():Array
maxRadius property
public var maxRadius:Number = 50

The radius of the largest item rendererd in this series. When you use a BubbleSeries object in a BubbleChart, the chart automatically assigns its maxRadius style value to this property on all series in the chart. When you use BubbleSeries objects in CartesianChart controls, you manage this property manually.

radiusField property
radiusField:String [read-write]

Specifies the field of the data provider that determines the radius of each symbol, relative to the other data points in the chart.

Implementation
    public function get radiusField():String
    public function set radiusField(value:String):void
renderData property
renderData:Object [read-only]

Stores the information necessary to render this series.

Implementation
    protected function get renderData():Object
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
xField property
xField:String [read-write]

Specifies the field of the data provider that determines the x-axis location of each data point. If null, Flex renders the data points in the order that they appear in the data provider.

The default value is null.

Implementation
    public function get xField():String
    public function set xField(value:String):void
yField property
yField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of each data point. If null, the BubbleSeries assumes that the data provider is an Array of numbers, and uses the numbers as values for the data points.

The default value is null.

Implementation
    public function get yField():String
    public function set yField(value:String):void
Constructor detail
BubbleSeries () constructor
public function BubbleSeries()

Constructor.

Method detail
applyItemRendererProperties () method
protected function applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void

Applies style properties to the specified DisplayObject. This method is the callback that the InstanceCache calls when it creates a new renderer.

Parameters
instance:DisplayObject — The instance being created.
cache:InstanceCache — A reference to the instance cache itself.
beginInterpolation () method
public override function beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object

Called by the SeriesInterpolate effect to initiate an interpolation. The effect passes in the source and destination data for the series to interpolate between. The effect passes the return value of this method repeatedly to the series's interpolate() method to advance the animation of the duration of the effect. The series calculates the data it needs to perform the interpolation and returns it in this method.

Parameters
sourceRenderData:Object — The source data for the series to interpolate between.
destRenderData:Object — The destination data for the series to interpolate between.

Returns
Object — The data the series needs to perform the interpolation.
describeData () method
public override function describeData(dimension:String, requiredFields:uint):Array

Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. Implementors fill out and return an Array of mx.charts.chartClasses.DataDescription objects to guarantee that their data is correctly accounted for by any axes that are autogenerating values from the displayed data (such as minimum, maximum, interval, and unitSize). Most element types return an Array containing a single DataDescription. Aggregate elements, such as BarSet and ColumnSet, might return mutiple DataDescription instances that describe the data displayed by their subelements. When called, the implementor describes the data along the axis indicated by the dimension argument. This function might be called for each axis supported by the containing chart.

Parameters
dimension:String — Determines the axis to get data descriptions of.
requiredFields:uint — A bitfield that indicates which values of the DataDescription object the particular axis cares about. Implementors can optimize by only calculating the necessary fields.

Returns
Array
findDataPoints () method
public override function findDataPoints(x:Number, y:Number, sensitivity2:Number):Array

Finds the closest data point represented by the element under the given coordinates.

This method returns either an array of HitData structures describing the datapoints within range. Individual ChartElements may choose to only return a single dataPoint if their dataPoints are guaranteed not to overlap.

Parameters
x:Number — The X coordinate.
y:Number — The Y coordinate.
sensitivity2:Number — How close, in pixels, the pointer must be to the exact coordinates to be considered "under". This property is similar to the value of the mouseSensitivity property of the chart control.

Returns
Array
getElementBounds () method
public override function getElementBounds(renderData:Object):void

Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series. Effect classes call this function to fill in these fields for use in implementing various effect types. Derived classes should implement this function to generate the bounds of the series's items only when requested.

Parameters
renderData:Object
getMissingInterpolationValues () method
protected override function getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void

Fills in missing values in an interpolation structure. When a series calls the initializeInterpolationData() method, it passes in an Array of source and destination values for the interpolation. If either of those two Arrays are incomplete, the series needs to provide "appropriate" placeholder values for the interpolation. How those placeholder values are determined is specific to the series type. Series extenders should override this method to provide those placeholder values.

Parameters
sourceProps:Object — An object containing the source values being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
srcCache:Array — The Array of source chart items that are being interpolated.
destProps:Object — An Object containing the destination values that are being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
destCache:Array — The Array of destination chart items that are being interpolated.
index:Number — The index of the item that is being populated in the cache.
customData:Object — The data that was passed by the series into the initializeInterpolationData() method.
styleChanged () method
public override function styleChanged(styleProp:String):void

Detects changes to style properties. When any style property is set, Flex calls the styleChanged() method, passing to it the name of the style being set.

This is an advanced method that you might override when creating a subclass of UIComponent. When you create a custom component, you can override the styleChanged() method to check the style name passed to it, and handle the change accordingly. This lets you override the default behavior of an existing style, or add your own custom style properties.

If you handle the style property, your override of the styleChanged() method should call the invalidateDisplayList() method to cause Flex to execute the component's updateDisplayList() method at the next screen update.

Parameters
styleProp:String — The name of the style property, or null if all styles for this component have changed.
updateData () method
protected override function updateData():void

This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider. If you implement custom series types, you should override this method and load all data necessary to render the series out of the backing data provider. You must also be sure to call the super.updateData() method in your subclass. You do not generally call this method directly. Instead, to guarantee that your data has been updated at a given point, call the validateData() method of the Series class.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
updateFilter () method
protected override function updateFilter():void

This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform. This can happen either because the underlying data has changed, or because the range of the associated axes have changed. If you implement a custom series type, you should override this method and filter out any outlying data using the filterCache() method of the axes managed by its associated DataTransform. The filterCache() method converts any values out of range to NaN. You must be sure to call the super.updateFilter() method in your subclass. You should not generally call this method directly. Instead, if you need to guarantee that your data has been filtered at a given point, call the validateTransform() method of the Series class. You can generally assume that your updateData() and updateMapping() methods have been called prior to this method, if necessary.

updateMapping () method
protected override function updateMapping():void

This method is called when the underlying data the series represents needs to be mapped to numeric representations. This can happen either because the underlying data has changed, or because the axes used to render the series have changed in some relevant way. If you implement a custom series, you should override this method and convert the data represented into numeric values using the mapCache() method of the axes managed by its associated DataTransform. You must also be sure to call the super.updateMapping() method in your subclass. You should not generally call this method directly. Instead, to guarantee that your data has been mapped at a given point, call the validateData() method of the Series class. You can generally assume that your updateData() method has been called prior to this method, if necessary.

updateTransform () method
protected override function updateTransform():void

This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform. This can happen either because the underlying data has changed, because the range of the associated axes have changed, or because the size of the area on screen has changed. If you implement a custom series type, you should override this method and transform the data using the transformCache() method of the associated DataTransform. You must be sure to call the super.updateTransform() method in your subclass. You should not generally call this method directly. Instead, if you need to guarantee that your data has been filtered at a given point, call the valiateTransform() method of the Series class. You can generally assume that your updateData(), updateMapping(), and updateFilter() methods have been called prior to this method, if necessary.

Constant detail
RADIUS_AXIS constant
public static const RADIUS_AXIS:String = "bubbleRadius"

The type of radius axis.

Examples
BubbleChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the BubbleChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Style>
        BubbleChart { color:#000099; }
    </mx:Style>

    <mx:Panel title="BubbleChart Control Example" height="100%" width="100%">

        <mx:BubbleChart id="bubblechart"
            height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" maxRadius="20"
            dataProvider="{expensesAC}">

            <mx:series>
                <mx:BubbleSeries displayName="Profit/Expenses/Amount"
                    xField="Profit" yField="Expenses" radiusField="Amount"/>
            </mx:series>
        </mx:BubbleChart>

        <mx:Legend dataProvider="{bubblechart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.series.CandlestickSeries (Flex™ 2 Language Reference)

Class CandlestickSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class CandlestickSeries
Inheritance | CandlestickSeries Inheritance HLOCSeriesBase Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series. The top and bottom of the vertical line in each candlestick represent the high and low values for the datapoint, while the top and bottom of the filled box represent the opening and closing values. Each candlestick is filled differently depending on whether the closing value for the datapoint is higher or lower than the opening value.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:CandlestickSeries> tag inherits all the properties of its parent classes, and the following properties:

  <mx:CandlestickSeries
    Styles
    boxStroke="IStroke; no default"
    declineFill="IFill; no default"
    fill="IFill; no default"
    stroke="IStroke; no default"
  />

View the examples.

See also

mx.charts.CandlestickChart
Using the charting controls
Using candlestick charts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | closeField : String Specifies the field of the data provider that determines the y-axis location of the closing value of the element. | HLOCSeriesBase
Inherited | columnWidthRatio : Number Specifies the width of elements relative to the category width. | HLOCSeriesBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | highField : String Specifies the field of the data provider that determines the y-axis location of the high value of the element. | HLOCSeriesBase
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | HLOCSeriesBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lowField : String Specifies the field of the data provider that determines the y-axis location of the low value of the element. | HLOCSeriesBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxColumnWidth : Number Specifies the width of the elements, in pixels. | HLOCSeriesBase
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | offset : Number Specifies how far to offset the center of the elements from the center of the available space, relative to the category width. | HLOCSeriesBase
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | openField : String Specifies the field of the data provider that determines the y-axis location of the opening value of the element. | HLOCSeriesBase
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | xField : String Specifies the field of the data provider that determines the x-axis location of the element. | HLOCSeriesBase
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | itemType : Class The subtype of ChartItem used by this series to represent individual items. | HLOCSeriesBase
Inherited | renderData : Object Stores the information necessary to render this series. | HLOCSeriesBase
Inherited | renderDataType : Class The subtype of ChartRenderData used by this series to store all data necessary to render. | HLOCSeriesBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CandlestickSeries()
Constructor.
CandlestickSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
HLOCSeriesBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
HLOCSeriesBase
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
findDataPoints(x:Number, y:Number, sensitivity:Number):Array
CandlestickSeries
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
HLOCSeriesBase
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
HLOCSeriesBase
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
formatDataTip(hd:HitData):String
Generates a text description of a ChartItem suitable for display as a DataTip.
HLOCSeriesBase
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
HLOCSeriesBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
HLOCSeriesBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
HLOCSeriesBase
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
HLOCSeriesBase
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
HLOCSeriesBase
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
HLOCSeriesBase
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | boxStroke | Type: mx.graphics.IStroke CSS Inheritance: no Sets the stroke style used to outline the box defining the open-close region of the series. | CandlestickSeries
 | declineFill | Type: mx.graphics.IFill CSS Inheritance: no Sets the declining fill for this data series, used when the closing value of an element is less than the opening value. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. | CandlestickSeries
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fill | Type: mx.graphics.IFill CSS Inheritance: no Sets the fill for this data series. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. | CandlestickSeries
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | itemRenderer | Type: mx.core.IFactory CSS Inheritance: no A factory that represents the class the series will use to represent individual items on the chart. | HLOCSeriesBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no The class that the series uses to render the series's marker in any associated legends. | HLOCSeriesBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | stroke | Type: mx.graphics.IStroke CSS Inheritance: no Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. | CandlestickSeries
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
CandlestickSeries () constructor
public function CandlestickSeries()

Constructor.

Method detail
findDataPoints () method
public override function findDataPoints(x:Number, y:Number, sensitivity:Number):Array Parameters
x:Number
y:Number
sensitivity:Number

Returns
Array
Examples
CandlestickChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the CandlestickChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.75,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 39.98,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
        ]]>
    </mx:Script>

    <mx:Panel title="CandlestickChart Control Example" height="100%" width="100%">

        <mx:CandlestickChart id="candlestickchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true"
            dataProvider="{expensesAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:CandlestickSeries openField="Open" highField="High"
                    lowField="Low" closeField="Close"/>
            </mx:series>

        </mx:CandlestickChart>
    </mx:Panel>
</mx:Application>


mx.charts.series.ColumnSeries (Flex™ 2 Language Reference)

Class ColumnSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class ColumnSeries
Inheritance | ColumnSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IColumn, IStackable

Defines a data series for a ColumnChart control. By default, this class uses the IBoxRenderer class. Optionally, you can define an itemRenderer for the data series. The itemRenderer must implement the IBoxRenderer interface.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ColumnSeries> tag inherits all the properties of its parent classes, and the following properties:

  <mx:ColumnSeries
    Properties
    columnWidthRatio=".65"
    legendData="No default"
    maxColumnWidth="No default"
    minField="null"
    offset="No default"
    sortOnXField="false|true"
    stacker="No default"
    stackTotals="No default"
    xField="null"
    yField="null"

    Styles
    fill="IFill; no default"
    itemRenderer="BoxItemRenderer"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    stroke="Stroke; no default"
  />

View the examples.

See also

mx.charts.ColumnChart
Using the charting controls
Using column charts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | columnWidthRatio : Number Specifies the width of columns relative to the category width. | ColumnSeries
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxColumnWidth : Number Specifies the width of the columns, in pixels. | ColumnSeries
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | minField : String Specifies the field of the data provider that determines the y-axis location of the bottom of a column. | ColumnSeries
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
 | offset : Number Specifies how far to offset the center of the columns from the center of the available space, relative to the category width. | ColumnSeries
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | sortOnXField : Boolean Requests the columns be sorted from left to right before rendering. | ColumnSeries
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
 | stacker : StackedSeries The StackedSeries associated with this BarSeries. | ColumnSeries
 | stackTotals : Dictionary [write-only] The stack totals for the series. | ColumnSeries
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xField : String Specifies the field of the data provider that determines the x-axis location of the column. | ColumnSeries
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yField : String Specifies the field of the data provider that determines the y-axis location of the top of a column. | ColumnSeries
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | ColumnSeries
Inherited | renderData : Object Stores the information necessary to render this series. | Series
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | ColumnSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ColumnSeries()
Constructor.
ColumnSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
stack(stackedXValueDictionary:Dictionary, previousElement:IStackable):Number
Stacks the series.
ColumnSeries
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void
Customizes the item renderer instances that are used to represent the chart.
ColumnSeries
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
ColumnSeries
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
ColumnSeries
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fill | Type: mx.graphics.IFill CSS Inheritance: no Sets the fill for this data series. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. | ColumnSeries
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | itemRenderer | Type: mx.core.IFactory CSS Inheritance: no A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. | ColumnSeries
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. | ColumnSeries
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | stroke | Type: mx.graphics.IStroke CSS Inheritance: no Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. | ColumnSeries
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
columnWidthRatio property
columnWidthRatio:Number [read-write]

Specifies the width of columns relative to the category width. A value of 1 uses the entire space, while a value of .6 uses 60% of the column's available space. You typically do not set this property directly. The actual column width used is the smaller of columnWidthRatio and the maxColumnWidth property.

The default value is 0.65.

Implementation
    public function get columnWidthRatio():Number
    public function set columnWidthRatio(value:Number):void
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items

Implementation
    protected function get itemType():Class
maxColumnWidth property
maxColumnWidth:Number [read-write]

Specifies the width of the columns, in pixels. The actual column width used is the smaller of this style and the columnWidthRatio property. Clustered columns divide this space proportionally among the columns in each cluster.

Implementation
    public function get maxColumnWidth():Number
    public function set maxColumnWidth(value:Number):void
minField property
minField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of the bottom of a column. If null, the columns are based at the range minimum (or maximum, if the field value is negative). The default value is null.

Implementation
    public function get minField():String
    public function set minField(value:String):void
offset property
offset:Number [read-write]

Specifies how far to offset the center of the columns from the center of the available space, relative to the category width. At the value of default 0, the columns are centered on the space. Set to -50 to center the column at the beginning of the available space. You typically do not set this property directly. The ColumnChart control manages this value based on its columnWidthRatio property.

Implementation
    public function get offset():Number
    public function set offset(value:Number):void
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
sortOnXField property
sortOnXField:Boolean [read-write]

Requests the columns be sorted from left to right before rendering. By default, the ColumnSeries renders columns in the order they appear in the data provider.

If you use the xField property to determine the position of each column, columns can appear in a different order on the screen. Columns can be rendered in any order. However, some custom columns might rely on the columns being rendered from left to right.

The default value is false.

Implementation
    public function get sortOnXField():Boolean
    public function set sortOnXField(value:Boolean):void
stacker property
stacker:StackedSeries [read-write]

The StackedSeries associated with this BarSeries. The stacker manages the series's stacking behavior.

Implementation
    public function get stacker():StackedSeries
    public function set stacker(value:StackedSeries):void
stackTotals property
stackTotals:Dictionary [write-only]

The stack totals for the series.

Implementation
    public function set stackTotals(value:Dictionary):void
xField property
xField:String [read-write]

Specifies the field of the data provider that determines the x-axis location of the column. If null, Flex renders the columns in the order they appear in the data provider. The default value is null.

Implementation
    public function get xField():String
    public function set xField(value:String):void
yField property
yField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of the top of a column. If null, the ColumnSeries assumes the data provider is an Array of numbers and uses the numbers as values. The default value is null.

Implementation
    public function get yField():String
    public function set yField(value:String):void
Constructor detail
ColumnSeries () constructor
public function ColumnSeries()

Constructor.

Method detail
applyItemRendererProperties () method
protected function applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void

Customizes the item renderer instances that are used to represent the chart. This method is called automatically whenever a new item renderer is needed while the chart is being rendered. You can override this method to add your own customization as necessary.

Parameters
instance:DisplayObject — The new item renderer instance that is being created.
cache:InstanceCache — The InstanceCache that is used to manage the item renderer instances.
invalidateData () method
protected override function invalidateData(invalid:Boolean = true):void

Informs the series that the underlying data in the dataProvider has changed. This function triggers calls to the updateData(), updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
invalidateMapping () method
protected override function invalidateMapping(invalid:Boolean = true):void

Informs the series that the mapping of the data into numeric values has changed and must be recalculated. Calling this function triggers calls to the updateMapping(), updateFilter(), and updateTransform() methods on the next call to the commitProperties() method. If any data effects are assigned to any elements of the chart, this method also triggers the show and hide effects.

Parameters
invalid:Boolean (default = true)
stack () method
public function stack(stackedXValueDictionary:Dictionary, previousElement:IStackable):Number

Stacks the series. Normally, a series implements the updateData() method to load its data out of the data provider. But a stacking series performs special operations because its values are not necessarily stored in its data provider. Its values are whatever is stored in its data provider, summed with the values that are loaded by the object it stacks on top of.

A custom stacking series should implement the stack() method by loading its data out of its data provider, adding it to the base values stored in the dictionary to get the real values it should render with, and replacing the values in the dictionary with its new, summed values.

Parameters
stackedXValueDictionary:Dictionary — Contains the base values that the series should stack on top of. The keys in the dictionary are the y values, and the values are the x values.
previousElement:IStackable — The previous element in the stack. If, for example, the element is of the same type, you can use access to this property to avoid duplicate effort when rendering.

Returns
Number — The maximum value in the newly stacked series.
Examples
Column_BarChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ColumnChart and BarChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var medalsAC:ArrayCollection = new ArrayCollection( [
            { Country: "USA", Gold: 35, Silver:39, Bronze: 29 },
            { Country: "China", Gold: 32, Silver:17, Bronze: 14 },
            { Country: "Russia", Gold: 27, Silver:27, Bronze: 38 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="ColumnChart and BarChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:ColumnChart id="column" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:ColumnSeries xField="Country" yField="Gold" displayName="Gold"/>
                <mx:ColumnSeries xField="Country" yField="Silver" displayName="Silver"/>
                <mx:ColumnSeries xField="Country" yField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:ColumnChart>

        <mx:Legend dataProvider="{column}"/>

         <mx:BarChart id="bar" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{medalsAC}">

            <mx:verticalAxis>
                <mx:CategoryAxis categoryField="Country"/>
            </mx:verticalAxis>

            <mx:series>
                <mx:BarSeries yField="Country" xField="Gold" displayName="Gold"/>
                <mx:BarSeries yField="Country" xField="Silver" displayName="Silver"/>
                <mx:BarSeries yField="Country" xField="Bronze" displayName="Bronze"/>
            </mx:series>
        </mx:BarChart>

        <mx:Legend dataProvider="{bar}"/>

    </mx:Panel>
</mx:Application>


mx.charts.series.ColumnSet (Flex™ 2 Language Reference)

Class ColumnSet | Properties | Methods | Events | Styles | Effects | Constants
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class ColumnSet
Inheritance | ColumnSet Inheritance StackedSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IColumn

ColumnSet is a grouping set that can be used to stack or cluster column series in any arbitrary chart. A ColumnSet encapsulates the same grouping behavior used in a ColumnChart, but can be used to assemble custom charts based on CartesianChart. ColumnSets can be used to cluster any chart element type that implements the IColumn interface. It can stack any chart element type that implements the IColumn and IStackable interfaces. Since ColumnSet itself implements the IColumn interface, you can use ColumnSets to cluster other ColumnSets to build more advanced custom charts.

Default MXML Property series

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | columnWidthRatio : Number Specifies the width of columns relative to the category width. | ColumnSet
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxColumnWidth : Number Specifies the width of the columns, in pixels. | ColumnSet
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
 | offset : Number Specifies how far to offset the center of the columns from the center of the available space, relative to the category width. | ColumnSet
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | series : Array An array of sub-series managed by this stacking set. | StackedSeries
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | type : String The grouping behavior of this series. | StackedSeries
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | renderData : Object Stores the information necessary to render this series. | Series
Inherited | stackedMaximum : Number The maximum sum represented by this stacked series. | StackedSeries
Inherited | totalsByPrimaryAxis : Dictionary The summed totals of the stacked values. | StackedSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ColumnSet()
Constructor.
ColumnSet
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ColumnSet
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
invalidateStacking():void
Call this method to trigger a regeneration of the stacked values on the next call to the commitProperties() method.
StackedSeries
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
stack():void
Updates the series data, and uses the values of the series data it is stacking on top of so it can stack correctly.
StackedSeries
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
buildSubSeries():void
Processes the Array of sub-series for display, when necessary.
ColumnSet
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
customizeSeries(g:IChartElement, i:uint):void
Applies any customization to a sub-series when building the stacking behavior.
ColumnSet
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
formatDataTip(hitData:HitData):String
Provides custom text for DataTips.
ColumnSet
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateSeries():void
Call this method to trigger a call to the buildSubSeries() method on the next call to the commitProperties() method.
StackedSeries
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateStacking():void
Iterates over the individual sub-series to build the stacked values.
StackedSeries
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
columnWidthRatio property
columnWidthRatio:Number [read-write]

Specifies the width of columns relative to the category width. A value of 1 uses the entire space, while a value of .6 uses 60% of the column's available space. You typically do not set this property directly. The actual column width used is the smaller of columnWidthRatio and the maxColumnWidth property

The default value is 0.65.

Implementation
    public function get columnWidthRatio():Number
    public function set columnWidthRatio(value:Number):void
maxColumnWidth property
maxColumnWidth:Number [read-write]

Specifies the width of the columns, in pixels. The actual column width used is the smaller of this style and the columnWidthRatio property. Clustered columns divide this space proportionally among the columns in each cluster.

Implementation
    public function get maxColumnWidth():Number
    public function set maxColumnWidth(value:Number):void
offset property
offset:Number [read-write]

Specifies how far to offset the center of the columns from the center of the available space, relative to the category width. At the value of default 0, the columns are centered on the space. Set to -50 to center the column at the beginning of the available space. You typically do not set this property directly. The ColumnChart control manages this value based on its columnWidthRatio property.

Implementation
    public function get offset():Number
    public function set offset(value:Number):void
Constructor detail
ColumnSet () constructor
public function ColumnSet()

Constructor.

Method detail
buildSubSeries () method
protected override function buildSubSeries():void

Processes the Array of sub-series for display, when necessary. This method ensures that all sub-series are added as children of this stacking set, and applies any per-series customization that is necessary (for example, assigning inherited data providers or clustering properties).

This method is also responsible for informing the chart that series have changed and, as a result, implicit series styles must be reassigned. This method is called automatically by the stacking set, when necessary. Instead of calling this method directly, you should consider calling the invalidateSeries() method.

customizeSeries () method
protected override function customizeSeries(g:IChartElement, i:uint):void

Applies any customization to a sub-series when building the stacking behavior. By default, this method assigns the inherited data providers to the sub-series. Derived classes can override this method to apply further customization.

Parameters
g:IChartElement
i:uint
describeData () method
public override function describeData(dimension:String, requiredFields:uint):Array

Called by the governing DataTransform to obtain a description of the data represented by this IChartElement. Implementors fill out and return an Array of mx.charts.chartClasses.DataDescription objects to guarantee that their data is correctly accounted for by any axes that are autogenerating values from the displayed data (such as minimum, maximum, interval, and unitSize). Most element types return an Array containing a single DataDescription. Aggregate elements, such as BarSet and ColumnSet, might return mutiple DataDescription instances that describe the data displayed by their subelements. When called, the implementor describes the data along the axis indicated by the dimension argument. This function might be called for each axis supported by the containing chart.

Parameters
dimension:String — Determines the axis to get data descriptions of.
requiredFields:uint — A bitfield that indicates which values of the DataDescription object the particular axis cares about. Implementors can optimize by only calculating the necessary fields.

Returns
Array
formatDataTip () method
protected override function formatDataTip(hitData:HitData):String

Provides custom text for DataTips. Stacking sets override the DataTip text of their contained sub-series to display additional information related to the stacking behavior. Derived classes must override this method to define custom DataTip text.

Parameters
hitData:HitData

Returns
String


mx.charts.series.HLOCSeries (Flex™ 2 Language Reference)

Class HLOCSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class HLOCSeries
Inheritance | HLOCSeries Inheritance HLOCSeriesBase Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Represents financial data as a series of elements representing the high, low, closing, and, optionally, opening values of a data series. The top and bottom of the vertical line in each element represent the high and low values for the datapoint. The right-facing tick mark represents the closing value, and the left tick mark represents the opening value, if one was specified.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HLOCSeries> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:HLOCSeries
    Styles
    closeTickLength="No default"
    closeTickStroke="No default"
    openTickLength="No default"
    openTickStroke="No default"
    stroke="No default"
  />

View the examples.

See also

mx.charts.HLOCChart
Using the charting controls
Using HighLowOpenClose charts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | closeField : String Specifies the field of the data provider that determines the y-axis location of the closing value of the element. | HLOCSeriesBase
Inherited | columnWidthRatio : Number Specifies the width of elements relative to the category width. | HLOCSeriesBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | highField : String Specifies the field of the data provider that determines the y-axis location of the high value of the element. | HLOCSeriesBase
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | HLOCSeriesBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lowField : String Specifies the field of the data provider that determines the y-axis location of the low value of the element. | HLOCSeriesBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxColumnWidth : Number Specifies the width of the elements, in pixels. | HLOCSeriesBase
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | offset : Number Specifies how far to offset the center of the elements from the center of the available space, relative to the category width. | HLOCSeriesBase
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | openField : String Specifies the field of the data provider that determines the y-axis location of the opening value of the element. | HLOCSeriesBase
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | xField : String Specifies the field of the data provider that determines the x-axis location of the element. | HLOCSeriesBase
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
Inherited | itemType : Class The subtype of ChartItem used by this series to represent individual items. | HLOCSeriesBase
Inherited | renderData : Object Stores the information necessary to render this series. | HLOCSeriesBase
Inherited | renderDataType : Class The subtype of ChartRenderData used by this series to store all data necessary to render. | HLOCSeriesBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HLOCSeries()
Constructor.
HLOCSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
HLOCSeriesBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
HLOCSeriesBase
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
HLOCSeriesBase
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
HLOCSeriesBase
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
formatDataTip(hd:HitData):String
Generates a text description of a ChartItem suitable for display as a DataTip.
HLOCSeriesBase
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
HLOCSeriesBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
HLOCSeriesBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
HLOCSeriesBase
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
HLOCSeriesBase
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
HLOCSeriesBase
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
HLOCSeriesBase
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | closeTickLength | Type: Number Format: Length CSS Inheritance: no Specifies the length, in pixels, for the close tick mark. Regardless of this value, an HLOCSeries will not render the close tick mark outside of the area assigned to the individual element. | HLOCSeries
 | closeTickStroke | Type: mx.graphics.IStroke CSS Inheritance: no Specifies the stroke to use for the close tick mark if an opening value is specified. | HLOCSeries
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | itemRenderer | Type: mx.core.IFactory CSS Inheritance: no A factory that represents the class the series will use to represent individual items on the chart. | HLOCSeriesBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no The class that the series uses to render the series's marker in any associated legends. | HLOCSeriesBase
 | openTickLength | Type: Number Format: Length CSS Inheritance: no Specifies the length, in pixels, for the open tick mark if an opening value is specified. Regardless of this value, an HLOCSeries will not render the open tick mark outside of the area assigned to the individual element. | HLOCSeries
 | openTickStroke | Type: mx.graphics.IStroke CSS Inheritance: no Specifies the stroke to use for the open tick mark if an opening value is specified. | HLOCSeries
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | stroke | Type: mx.graphics.IStroke CSS Inheritance: no Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. | HLOCSeries
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
HLOCSeries () constructor
public function HLOCSeries()

Constructor.

Examples
HLOCChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HLOCChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var stockDataAC:ArrayCollection = new ArrayCollection( [
            { Date: "25-Jul", Open: 40.55,  High: 40.75, Low: 40.24, Close:40.31},
            { Date: "26-Jul", Open: 40.15,  High: 40.78, Low: 39.97, Close:40.34},
            { Date: "27-Jul", Open: 40.38,  High: 40.66, Low: 40, Close:40.63},
            { Date: "28-Jul", Open: 40.49,  High: 40.99, Low: 40.3, Close:40.98},
            { Date: "29-Jul", Open: 40.13,  High: 40.4, Low: 39.65, Close:39.95},
            { Date: "1-Aug", Open: 39.00,  High: 39.50, Low: 38.7, Close:38.6},
            { Date: "2-Aug", Open: 38.68,  High: 39.34, Low: 37.75, Close:38.84},
            { Date: "3-Aug", Open: 38.76,  High: 38.76, Low: 38.03, Close:38.12},
            { Date: "4-Aug", Open: 37.98,  High: 37.98, Low: 36.56, Close:36.69},
            { Date: "5-Aug", Open: 36.61,  High: 37, Low: 36.48, Close:36.86} ]);
        ]]>
    </mx:Script>

    <mx:Panel title="HLOCChart Control Example" height="100%" width="100%">

        <mx:HLOCChart id="hlocchart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{stockDataAC}">

            <mx:verticalAxis>
                <mx:LinearAxis baseAtZero="false" />
            </mx:verticalAxis>

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Date" title="Date"/>
            </mx:horizontalAxis>

            <mx:horizontalAxisRenderer>
                <mx:AxisRenderer canDropLabels="true"/>
            </mx:horizontalAxisRenderer>

            <mx:series>
                <mx:HLOCSeries openField="Open" highField="High"
                    lowField="Low" closeField="Close"/>
            </mx:series>
        </mx:HLOCChart>

    </mx:Panel>
</mx:Application>


mx.charts.series.LineSeries (Flex™ 2 Language Reference)

Class LineSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class LineSeries
Inheritance | LineSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Defines a data series for a LineChart control. By default, this class uses the ShadowLineRenderer class. Optionally, you can define an itemRenderer for the data series. The itemRenderer must implement the ILineRenderer interface.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:LineSeries> tag inherits all the properties of its parent classes and adds the following properties:

  <mx:LineSeries
    Properties
    form="segment|curve|horizontal|reverseStep|step|vertical"
    interpolateValues="false|true"
    sortOnXField="false|true"
    xField="null"
    yField="null"

    Styles
    fill="0xFFFFFF"
    form="segment|curve|horizontal|reverseStep|step|vertical"
    itemRenderer="itemRenderer"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    lineSegmentRenderer="ShadowLineRenderer"
    lineStroke="Stroke(0xE47801,3)"
    radius="0"
    stroke="IStroke; no default"
  />

View the examples.

See also

mx.charts.LineChart
Using the charting controls
Using line charts
Using strokes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
 | form : String Specifies the line type for the chart. | LineSeries
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
 | interpolateValues : Boolean Specifies how to represent missing data. | LineSeries
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radius : Number Specifies the radius, in pixels, of the chart elements for the data points. | LineSeries
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | sortOnXField : Boolean Requests the line datapoints be sorted from left to right before rendering. | LineSeries
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xField : String Specifies the field of the data provider that determines the x-axis location of each data point. | LineSeries
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yField : String Specifies the field of the data provider that determines the y-axis location of each data point. | LineSeries
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | LineSeries
 | lineSegmentType : Class [read-only] The class used by this series to store all data necessary to represent a line segment. | LineSeries
Inherited | renderData : Object Stores the information necessary to render this series. | Series
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | LineSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LineSeries()
Constructor.
LineSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void
Customizes the item renderer instances that are used to represent the chart.
LineSeries
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fill
Type: mx.graphics.IFill CSS Inheritance: no
Sets the fill for this data series. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. 		LineSeries
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
form
Type: String CSS Inheritance: no
Specifies the line type for the chart. Possible values are:
  • "curve": Draws curves between data points.
  • "horizontal": Draws only the vertical line from the x-coordinate of the first point to the x-coordinate of the second point at the y-coordinate of the second point. Repeats this for each data point.
  • "vertical": Draws only the vertical line from the y-coordinate of the first point to the y-coordinate of the second point at the x-coordinate of the second point. Repeats this for each data point.
  • "segment": Draws lines as connected segments that are angled to connect at each data point in the series.
  • "step": Draws lines as horizontal segments. At the first data point, draws a horizontal line and then a vertical line to the second point, and repeats for each data point.
  • "reverseStep":L Draws lines as horizontal segments. At the first data point, draws a vertical line and then a horizontal line to the second point, and repeats for each data point.
The default is "segment". 		LineSeries
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
itemRenderer
Type: mx.core.IFactory CSS Inheritance: no
A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. 		LineSeries
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
legendMarkerRenderer
Type: mx.core.IFactory CSS Inheritance: no
The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. 		LineSeries
lineSegmentRenderer
Type: mx.core.IFactory CSS Inheritance: no
A factory that represents the class the series uses to represent the individual line segments in the series. This class is instantiated once for each distinct segment of the series. Classes used as lineSegmentRenderers should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned an instance of mx.charts.series.items.LineSeriesSegment that describes the segment to render. 		LineSeries
lineStroke
Type: mx.graphics.IStroke CSS Inheritance: no
Sets the stroke for the actual line segments. The default value for a LineChart control is orange (0xE47801). The default color for a LineSeries used in a CartesianChart control is black (0x000000). The default value for the width is 3. 		LineSeries
radius
Type: Number Format: Length CSS Inheritance: no
Specifies the radius, in pixels, of the chart elements for the data points. This property applies only if you specify an item renderer using the itemRenderer property. You can specify the itemRenderer in MXML or using styles. The default value is 0. 		LineSeries
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
stroke
Type: mx.graphics.IStroke CSS Inheritance: no
Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. 		LineSeries
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
form property
form:String [read-write]

Specifies the line type for the chart. Possible values are:

  • "curve": Draws curves between data points.
  • "horizontal": Draws only the vertical line from the x-coordinate of the first point to the x-coordinate of the second point at the y-coordinate of the second point. Repeats this for each data point.
  • "vertical": Draws only the vertical line from the y-coordinate of the first point to the y-coordinate of the second point at the x-coordinate of the second point. Repeats this for each data point.
  • "segment": Draws lines as connected segments that are angled to connect at each data point in the series.
  • "step": Draws lines as horizontal segments. At the first data point, draws a horizontal line and then a vertical line to the second point, and repeats for each data point.
  • "reverseStep": Draws lines as horizontal segments. At the first data point, draws a vertical line and then a horizontal line to the second point, and repeats for each data point.
The default is "segment".

Implementation
    public function get form():String
    public function set form(value:String):void
interpolateValues property
interpolateValues:Boolean [read-write]

Specifies how to represent missing data.

Set to false to break the line at the missing value. Set to true to draw a continuous line by interpolating the missing value.

The default value is false.

Implementation
    public function get interpolateValues():Boolean
    public function set interpolateValues(value:Boolean):void
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items.

Implementation
    protected function get itemType():Class
lineSegmentType property
lineSegmentType:Class [read-only]

The class used by this series to store all data necessary to represent a line segment. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get lineSegmentType():Class
radius property
radius:Number [read-write]

Specifies the radius, in pixels, of the chart elements for the data points. This property applies only if you specify an item renderer using the itemRenderer property. You can specify the itemRenderer in MXML or using styles.

The default value is 0.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
sortOnXField property
sortOnXField:Boolean [read-write]

Requests the line datapoints be sorted from left to right before rendering.

By default, the LineSeries renders points from left to right. Set this property to false to render the items in the order they appear in the data provider.

The default value is true.

Implementation
    public function get sortOnXField():Boolean
    public function set sortOnXField(value:Boolean):void
xField property
xField:String [read-write]

Specifies the field of the data provider that determines the x-axis location of each data point. If null, the data points are rendered in the order they appear in the data provider.

The default value is null.

Implementation
    public function get xField():String
    public function set xField(value:String):void
yField property
yField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of each data point. If null, the LineSeries assumes the data provider is an Array of numbers, and uses the numbers as values.

The default value is null.

Implementation
    public function get yField():String
    public function set yField(value:String):void
Constructor detail
LineSeries () constructor
public function LineSeries()

Constructor.

Method detail
applyItemRendererProperties () method
protected function applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void

Customizes the item renderer instances that are used to represent the chart. This method is called automatically whenever a new item renderer is needed while the chart is being rendered. You can override this method to add your own customization as necessary.

Parameters
instance:DisplayObject — The new item renderer instance that is being created.
cache:InstanceCache — The InstanceCache that is used to manage the item renderer instances.
Examples
Line_AreaChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the LineChart and AreaChart controls. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 },
            { Month: "Apr", Profit: 1800, Expenses: 1200, Amount: 900 },
            { Month: "May", Profit: 2400, Expenses: 575, Amount: 500 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="LineChart and AreaChart Controls Example"
        height="100%" width="100%" layout="horizontal">

        <mx:LineChart id="linechart" height="100%" width="45%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:LineSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:LineSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:LineSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:LineChart>

        <mx:Legend dataProvider="{linechart}"/>

        <mx:AreaChart id="Areachart" height="100%" width="45%"
             paddingLeft="5" paddingRight="5"
             showDataTips="true" dataProvider="{expensesAC}">

            <mx:horizontalAxis>
                <mx:CategoryAxis categoryField="Month"/>
            </mx:horizontalAxis>

            <mx:series>
                <mx:AreaSeries yField="Profit" form="curve" displayName="Profit"/>
                <mx:AreaSeries yField="Expenses" form="curve" displayName="Expenses"/>
                <mx:AreaSeries yField="Amount" form="curve" displayName="Amount"/>
            </mx:series>
        </mx:AreaChart>

        <mx:Legend dataProvider="{Areachart}"/>

    </mx:Panel>
</mx:Application>


mx.charts.series.PieSeries (Flex™ 2 Language Reference)

Class PieSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class PieSeries
Inheritance | PieSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The PieSeries class defines the data series for a PieChart control. The default item renderer is the WedgeItemRenderer class. Optionally, you can define an itemRenderer for the data series. The itemRenderer must implement the IDataRenderer interface.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PieSeries> tag inherits all the properties of its parent classes, and the following properties:

  <mx:PieSeries
    Properties
    explodeRadius="0"
    field="null"
    itemType="No default"
    labelFunction="No default"
    maxLabelRadius="0.6"
    nameField="null"
    outerRadius="1"
    perWedgeExplodeRadius="Array, no default"
    renderDataType="No default"
    reserveExplodeRadius="0"
    startAngle="0"

    Styles
    calloutGap="10"
    calloutStroke="IStroke; no default"
    fills="IFill; no default"
    fontSize="10"
    innerRadius="0"
    insideLabelSizeLimit="9"
    itemRenderer="No default"
    labelPosition="none|callout|inside|insideWithCallout|outside"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    radialStroke="IStroke; no default"
    stroke="IStroke; no default"
  />

View the examples.

See also

mx.charts.PieChart
Using the charting controls
Using pie charts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
 | explodeRadius : Number A number from 0 to 1, specifying how far all wedges of the pie series should be exploded from the center of the chart as a percentage of the total radius. | PieSeries
 | field : String Specifies the field of the data provider that determines the data for each wedge of the PieChart control. | PieSeries
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
 | labelFunction : Function Specifies a callback function used to render each label of the PieSeries. | PieSeries
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxLabelRadius : Number = 0.6 The maximum amount of the PieSeries's radius that can be allocated to labels. | PieSeries
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | nameField : String Specifies the field of the data provider that determines the name of each wedge of the PieChart control. | PieSeries
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | outerRadius : Number The percentage of the total space available to the PieSeries to use when rendering the contents of the series. | PieSeries
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | perWedgeExplodeRadius : Array An Array of numbers from 0 to 1, specifying how far each wedge of the pie series should be exploded from the center of the chart as a percentage of the total radius. | PieSeries
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | reserveExplodeRadius : Number A number from 0 to 1, specifying how much of the total radius of the pie series should be reserved to explode wedges at runtime. | PieSeries
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | startAngle : Number Specifies the starting angle for the first slice of the PieChart control. | PieSeries
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | PieSeries
Inherited | renderData : Object Stores the information necessary to render this series. | Series
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | PieSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PieSeries()
Constructor.
PieSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
PieSeries
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
PieSeries
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
PieSeries
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
createChildren():void
PieSeries
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
PieSeries
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
PieSeries
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
calloutGap
Type: Number Format: Length CSS Inheritance: no
Specifies how much space, in pixels, to insert between the edge of the pie and the labels when rendering callouts. The default value is 10. 		PieSeries
calloutStroke
Type: mx.graphics.IStroke CSS Inheritance: no
Specifies the line style used to draw the lines to callouts. 		PieSeries
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		PieSeries
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fills
Type: Array CSS Inheritance: no
Specifies an array of fill objects used to render each wedge of the PieChart control. If you do not provide enough Array elements for every slice, Flex repeats the fill from the beginning of the Array. 		PieSeries
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		PieSeries
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text in pixels. The default value is 10. 		PieSeries
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		PieSeries
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		PieSeries
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
innerRadius
Type: Number CSS Inheritance: no
A number from 0 to 1 specifying the distance from the center of the series to the inner edge of the rendered wedges, as a percentage of the total radius assigned to the series. This property is assigned directly to the series. 		PieSeries
insideLabelSizeLimit
Type: Number CSS Inheritance: no
Specifies the font size threshold, in points, below which inside labels are considered illegible. Below this threshold, Flex either removes labels entirely or renders them as callouts based on the setting of the labelPosition property. 		PieSeries
itemRenderer
Type: mx.core.IFactory CSS Inheritance: no
A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. 		PieSeries
labelPosition
Type: String CSS Inheritance: no
Specifies how to render value labels. You can set this property in MXML or using styles. Valid values are:
  • "none" - Do not draw labels.
  • "outside" - Draw labels around the boundary of the pie.
  • "callout" - Draw labels in two vertical stacks on either side of the pie. The pie is shrunk if necessary to make room for the labels (see maxLabelRadius). Draw key lines from each label to the associated wedge. Shrink labels as necessary to fit the space provided.
  • "inside" - Draw labels inside the chart, centered approximately seven tenths of the way along each wedge. Shrink labels to ensure that they do not interfere with each other. If labels are shrunk below the calloutPointSize property, remove them. When two labels overlap, Flex gives priority to labels for larger slices.
  • "insideWithCallout" - Draw labels inside the pie, but if labels are shrunk below a legible size, Flex converts them to callouts.
PieSeries
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
legendMarkerRenderer
Type: mx.core.IFactory CSS Inheritance: no
The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. 		PieSeries
radialStroke
Type: mx.graphics.IStroke CSS Inheritance: no
Specifies the line style used to draw the border between the wedges of the pie. 		PieSeries
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
stroke
Type: mx.graphics.IStroke CSS Inheritance: no
Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. 		PieSeries
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		PieSeries
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
explodeRadius property
explodeRadius:Number [read-write]

A number from 0 to 1, specifying how far all wedges of the pie series should be exploded from the center of the chart as a percentage of the total radius.

This value explodes all wedges in the pie series uniformly. You can set the value for individual wedges via the perWedgeExplodeRadius property.

The explode radius for any individual wedge is the value of the explodeRadius property plus its value in the perWedgeExplodeRadius Array.

To guarantee that the pie series stays within its containing chart's bounds while pulling out wedges, the pie series might shrink the total radius of the pie. If you dynamically pull out wedges at run time, the total pie radius shrinks. To avoid this effect, you can "reserve" the space and shrink the total radius initially by setting the reserveExplodeRadius property to the maximum explode radius you intend to set at run time.

Implementation
    public function get explodeRadius():Number
    public function set explodeRadius(value:Number):void
field property
field:String [read-write]

Specifies the field of the data provider that determines the data for each wedge of the PieChart control.

The default value is null.

Implementation
    public function get field():String
    public function set field(value:String):void
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items.

Implementation
    protected function get itemType():Class
labelFunction property
labelFunction:Function [read-write]

Specifies a callback function used to render each label of the PieSeries. The callback function has the following format:

   function_name(data:Object, field:String, index:Number, percentValue:Number):String { ... }
The data Object is the dataProvider item being rendered. The field String is the name of the field in the data that is being rendered. The index Number is the index in the original dataProvider of the item being rendered. The percent Number is the percentage of the total this item represents. This function returns a String that is the label for this item.

Implementation
    public function get labelFunction():Function
    public function set labelFunction(value:Function):void
maxLabelRadius property
public var maxLabelRadius:Number = 0.6

The maximum amount of the PieSeries's radius that can be allocated to labels. This value is only applicable when the series is rendering callout labels.

When rendering callout labels, the PieSeries reduces the radius of the wedges to allow space for the labels along the sides. Once the amount of space allocated to the labels reaches this limit, the series begins reducing the size of the labels to stay within this size.

nameField property
nameField:String [read-write]

Specifies the field of the data provider that determines the name of each wedge of the PieChart control.

The default value is null.

Implementation
    public function get nameField():String
    public function set nameField(value:String):void
outerRadius property
outerRadius:Number [read-write]

The percentage of the total space available to the PieSeries to use when rendering the contents of the series. This value is managed by the containing chart, and should not be assigned to directly.

This value ranges from 0 to 1.

Implementation
    public function get outerRadius():Number
    public function set outerRadius(value:Number):void
perWedgeExplodeRadius property
perWedgeExplodeRadius:Array [read-write]

An Array of numbers from 0 to 1, specifying how far each wedge of the pie series should be exploded from the center of the chart as a percentage of the total radius.

The nth value in this Array corresponds to the nth pie wedge. For example, to pull the third wedge half way out, you assign perWedgeExplodeRadius = [ 0, 0, 50];.

null or missing values in the Array are treated as 0.

To guarantee that the pie series stays within its containing chart's bounds while pulling out wedges, the pie series might shrink the total radius of the pie.

If you dynamically pull out wedges at run time, the total pie radius shrinks. To avoid this effect, you can "reserve" the space and shrink the total radius initially by setting the reserveExplodeRadius property to the maximum explode radius you intend to set at run time.

The value for an individual wedge in the perWedgeExplodeRadius Array is added to the value of the series's explodeRadius property to calculate the total explode radius for any given wedge.

Implementation
    public function get perWedgeExplodeRadius():Array
    public function set perWedgeExplodeRadius(value:Array):void
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
reserveExplodeRadius property
reserveExplodeRadius:Number [read-write]

A number from 0 to 1, specifying how much of the total radius of the pie series should be reserved to explode wedges at runtime. When a pie wedge is exploded, the series must shrink the total radius of the pie to make sure it doesn't exceed the bounds of its containing chart. Thus if a developer changes the explode value of a wedge at runtime, it can effectively shrink all the wedges rather than the desired effect of pulling out a single wedge. To avoid this, set reserveExplodeRadius to the maximum value you intend to explode any wedge at runtime.

Implementation
    public function get reserveExplodeRadius():Number
    public function set reserveExplodeRadius(value:Number):void
startAngle property
startAngle:Number [read-write]

Specifies the starting angle for the first slice of the PieChart control. The default value is 0, which is horizontal on the right side of the PieChart control.

Implementation
    public function get startAngle():Number
    public function set startAngle(value:Number):void
Constructor detail
PieSeries () constructor
public function PieSeries()

Constructor.

Method detail
beginInterpolation () method
public override function beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object

Called by the SeriesInterpolate effect to initiate an interpolation. The effect passes in the source and destination data for the series to interpolate between. The effect passes the return value of this method repeatedly to the series's interpolate() method to advance the animation of the duration of the effect. The series calculates the data it needs to perform the interpolation and returns it in this method.

Parameters
sourceRenderData:Object — The source data for the series to interpolate between.
destRenderData:Object — The destination data for the series to interpolate between.

Returns
Object — The data the series needs to perform the interpolation.
createChildren () method
protected override function createChildren():void
getElementBounds () method
public override function getElementBounds(renderData:Object):void

Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series. Effect classes call this function to fill in these fields for use in implementing various effect types. Derived classes should implement this function to generate the bounds of the series's items only when requested.

Parameters
renderData:Object
getMissingInterpolationValues () method
protected override function getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void

Fills in missing values in an interpolation structure. When a series calls the initializeInterpolationData() method, it passes in an Array of source and destination values for the interpolation. If either of those two Arrays are incomplete, the series needs to provide "appropriate" placeholder values for the interpolation. How those placeholder values are determined is specific to the series type. Series extenders should override this method to provide those placeholder values.

Parameters
sourceProps:Object — An object containing the source values being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
srcCache:Array — The Array of source chart items that are being interpolated.
destProps:Object — An Object containing the destination values that are being interpolated for a particular item. When this method exits, all properties in this Object should have non-NaN values.
destCache:Array — The Array of destination chart items that are being interpolated.
index:Number — The index of the item that is being populated in the cache.
customData:Object — The data that was passed by the series into the initializeInterpolationData() method.
interpolate () method
public override function interpolate(interpolationValues:Array, interpolationData:Object):void

Called by the SeriesInterpolate effect to advance an interpolation. The effect calls this once per frame until the interpolation is complete. The series is responsible for using the parameters to render the interpolated values. By default, the series assumes that interpolationData is a data structure returned by the initializeInterpolationData() method, and passes it through to the applyInterpolation() method.

Parameters
interpolationValues:Array — An Array of Numbers, each ranging from 0 to 1, where the nth number indicates the percentage of the way the nth value in the data series should be interpolated between the start and end values.
interpolationData:Object — The data returned from the beginInterpolation() method.
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
PieChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the PieChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var medalsAC:ArrayCollection = new ArrayCollection( [
            { Country: "USA", Gold: 35, Silver:39, Bronze: 29 },
            { Country: "China", Gold: 32, Silver:17, Bronze: 14 },
            { Country: "Russia", Gold: 27, Silver:27, Bronze: 38 } ]);

        private function displayGold(data:Object, field:String, index:Number, percentValue:Number):String {
            var temp:String= (" " + percentValue).substr(0,6);
            return data.Country + ": " + '\n' + "Total Gold: " + data.Gold + '\n' + temp + "%";
        }
        ]]>
    </mx:Script>

    <mx:Panel title="Olympics 2004 Medals Tally Panel" height="100%" width="100%">

        <mx:PieChart id="chart" height="100%" width="100%"
            paddingRight="5" paddingLeft="5"
            showDataTips="true" dataProvider="{medalsAC}" >

            <mx:series>
                <mx:PieSeries labelPosition="callout" field="Gold" labelFunction="displayGold">
                    <mx:calloutStroke>
                        <mx:Stroke weight="0" color="0x888888" alpha="100"/>
                    </mx:calloutStroke>
                    <mx:radialStroke>
                        <mx:Stroke weight="0" color="#FFFFFF" alpha="20"/>
                    </mx:radialStroke>
                    <mx:stroke>
                        <mx:Stroke color="0" alpha="20" weight="2"/>
                    </mx:stroke>
                </mx:PieSeries>
            </mx:series>
        </mx:PieChart>

    </mx:Panel>
</mx:Application>


mx.charts.series.PlotSeries (Flex™ 2 Language Reference)

Class PlotSeries | Properties | Methods | Events | Styles | Effects | Constants | Examples
(Adobe® Flex™ Charting components only)
Package | mx.charts.series
Class | public class PlotSeries
Inheritance | PlotSeries Inheritance Series Inheritance ChartElement Inheritance DualStyleObject Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Defines a data series for a PlotChart control. The default itemRenderer for a PlotChart control is the DiamondRenderer class. Optionally, you can define an itemRenderer for the data series. The itemRenderer must implement the IDataRenderer interface.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PlotSeries> tag inherits all the properties of its parent classes, and adds the following properties:

  <mx:PlotSeries
    Properties
    radius="4"
    xField="null"
    yField="null"

    Styles
    fill="0xFFFFFF"
    itemRenderer="itemRenderer"
    legendMarkerRenderer="Defaults to series's itemRenderer"
    radius="4"
    stroke="IStroke; no default"
  />

View the examples.

See also

mx.charts.PlotChart
Using the charting controls
Using plot charts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | chartDataProvider : Object The data provider assigned to the enclosing chart. | ChartElement
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object A data provider assigned to the this specific element. | ChartElement
Inherited | dataTransform : DataTransform The data dataTransform the element is associated with. | Series
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | displayName : String The name of the series, for display to the user. | Series
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filterData : Boolean This property is true if the series filters its data before displaying. | Series
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | interactive : Boolean Determines whether DataTips appear when users interact with chart data on the screen. | Series
Inherited | internalStyleName : Object The name of a class selector this instance inherits values from. | DualStyleObject
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelContainer : Sprite The DisplayObject that displays labels rendered by this element. | ChartElement
Inherited | legendData : Array An Array of LegendData instances that describe the items that should show up in a legend representing this series. | Series
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radius : Number Specifies the radius, in pixels, of the chart element at each data point. | PlotSeries
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitionRenderData : Object A render data structure passed in by a running transtion. | Series
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xField : String Specifies the field of the data provider that determines the x-axis location of each data point. | PlotSeries
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yField : String Specifies the field of the data provider that determines the y-axis location of each data point. | PlotSeries
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | chart : ChartBase Refers to the chart component containing this element. | ChartElement
Inherited | cursor : IViewCursor Each ChartElement carries a cursor associated with their dataProvider for their own internal use. | ChartElement
 | itemType : Class [read-only] The subtype of ChartItem used by this series to represent individual items. | PlotSeries
 | renderData : Object [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | PlotSeries
 | renderDataType : Class [read-only] The subtype of ChartRenderData used by this series to store all data necessary to render. | PlotSeries
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PlotSeries()
Constructor
PlotSeries
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
ChartElement
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
ChartElement
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
beginInterpolation(sourceRenderData:Object, destRenderData:Object):Object
Called by the SeriesInterpolate effect to initiate an interpolation.
Series
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
chartStateChanged(oldState:uint, v:uint):void
Called by the enclosing chart to indicate that the current state of the chart has changed.
ChartElement
Inherited
claimStyles(styles:Array, firstAvailable:uint):uint
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
Series
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
collectTransitions(chartState:Number, transitions:Array):void
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
ChartElement
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
describeData(dimension:String, requiredFields:uint):Array
Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
ChartElement
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
endInterpolation(interpolationData:Object):void
Called by the SeriesInterpolate effect to end an interpolation.
Series
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findDataPoints(x:Number, y:Number, sensitivity2:Number):Array
Finds the closest data point represented by the element under the given coordinates.
ChartElement
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getElementBounds(renderData:Object):void
Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
Series
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRenderDataForTransition(type:String):Object
Returns a copy of the data needed to represent this series's data.
Series
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
interpolate(interpolationValues:Array, interpolationData:Object):void
Called by the SeriesInterpolate effect to advance an interpolation.
Series
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
mappingChanged():void
Called when the mapping of one or more associated axes changes.
ChartElement
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sets the actual size of this object.
Series
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Calls the legendDataChanged() method.
Series
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void
Customizes the item renderer instances that are used to represent the chart.
PlotSeries
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
cacheDefaultValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheIndexValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
cacheNamedValues(measureName:String, cache:Array, fieldName:String):Boolean
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
Series
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
commitProperties():void
Processes the properties set on the component.
UIComponent
Inherited
createChildren():void
Create child objects of the component.
UIComponent
Inherited
createDataID(dataPointID:Number):Number
Creates a unique id to represent the a dataPoint for comparison purposes.
ChartElement
Inherited
dataChanged():void
Indicates the underlying data represented by the element has changed.
ChartElement
Inherited
extractMinInterval(cache:Array, measureName:String, desc:DataDescription):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
extractMinMax(cache:Array, measureName:String, desc:DataDescription, calculateInterval:Boolean = false):void
Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Series
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object):void
Fills in missing values in an interpolation structure.
Series
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class = null, customData:Object = null):Object
Helper function for Series to implement the interpolation effect.
Series
Inherited
invalidateData(invalid:Boolean = true):void
Informs the series that the underlying data in the dataProvider has changed.
Series
Inherited
invalidateFilter(invalid:Boolean = true):void
Informs the series that the filter of the data against the axes has changed and must be recalculated.
Series
Inherited
invalidateMapping(invalid:Boolean = true):void
Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
Series
Inherited
invalidateTransform(invalid:Boolean = true):void
Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
Series
Inherited
invalidateTransitions():void
Informs the series that a significant change has occured in the display of data.
Series
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
legendDataChanged():void
Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
Series
Inherited
measure():void
Calculates the default size, and optionally the default minimum size, of the component.
UIComponent
Inherited
processNewDataProvider(value:Object):void
Called when a new dataProvider is assigned to the element.
ChartElement
Inherited
stripNaNs(cache:Array, field:String):void
Removes any item from the provided cache whose field property is NaN.
Series
Inherited
updateData():void
This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
Series
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Draws the object and/or sizes and positions its children.
Series
Inherited
updateFilter():void
This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
Series
Inherited
updateMapping():void
This method is called when the underlying data the series represents needs to be mapped to numeric representations.
Series
Inherited
updateTransform():void
This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
Series
Inherited
validateData():void
Calls the series's updateData() and updateMapping() functions, if necessary.
Series
Inherited
validateTransform():void
Calls the series's updateFilter() and updateTransform() functions, if necessary.
Series
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fill | Type: mx.graphics.IFill CSS Inheritance: no Sets the fill for this data series. You can specify either an object implementing the IFill interface, or a number representing a solid color value. You can also specify a solid fill using CSS. | PlotSeries
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | itemRenderer | Type: mx.core.IFactory CSS Inheritance: no A factory that represents the class the series will use to represent individual items on the chart. This class is instantiated once for each element in the chart. Classes used as an itemRenderer should implement the IFlexDisplayObject, ISimpleStyleClient, and IDataRenderer interfaces. The data property is assigned the chartItem that the skin instance renders. | PlotSeries
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | legendMarkerRenderer | Type: mx.core.IFactory CSS Inheritance: no The class that the series uses to render the series's marker in any associated legends. If this style is null, most series default to using their itemRenderer as a legend marker skin instead. Classes used as legend markers should implement the IFlexDisplayObject interface, and optionally the ISimpleStyleClient and IDataRenderer interfaces. If the class used as a legend marker implements the IDataRenderer interface, the data property is assigned a LegendData instance. | PlotSeries
 | radius | Type: Number Format: Length CSS Inheritance: no Specifies the radius, in pixels, of the chart element at each data point. By default, the PlotChart control draws a circle at each data point. You can set this property in MXML or using styles. The default value is 4 pixels. | PlotSeries
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | stroke | Type: mx.graphics.IStroke CSS Inheritance: no Sets the stroke style for this data series. You must specify a Stroke object to define the stroke. | PlotSeries
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideDataEffect | Triggering event: hideData Defines the effect that Flex uses as it hides the current data from view. | Series
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showDataEffect | Triggering event: showData Defines the effect that Flex uses as it moves the current data into its final position on the screen. | Series
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
itemType property
itemType:Class [read-only]

The subtype of ChartItem used by this series to represent individual items. Subclasses can override and return a more specialized class if they need to store additional information in the items.

Implementation
    protected function get itemType():Class
radius property
radius:Number [read-write]

Specifies the radius, in pixels, of the chart element at each data point. By default, the PlotChart control draws a circle at each data point. You can set this property in MXML or using styles.

The default value is 4.

Implementation
    public function get radius():Number
    public function set radius(value:Number):void
renderData property
renderData:Object [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderData():Object
renderDataType property
renderDataType:Class [read-only]

The subtype of ChartRenderData used by this series to store all data necessary to render. Subclasses can override and return a more specialized class if they need to store additional information for rendering.

Implementation
    protected function get renderDataType():Class
xField property
xField:String [read-write]

Specifies the field of the data provider that determines the x-axis location of each data point. If null, Flex renders the data points in the order they appear in the dataProvider.

The default value is null.

Implementation
    public function get xField():String
    public function set xField(value:String):void
yField property
yField:String [read-write]

Specifies the field of the data provider that determines the y-axis location of each data point. If null, the PlotSeries assumes the data provider is an Array of numbers, and uses the numbers as values.

The default value is null.

Implementation
    public function get yField():String
    public function set yField(value:String):void
Constructor detail
PlotSeries () constructor
public function PlotSeries()

Constructor

Method detail
applyItemRendererProperties () method
protected function applyItemRendererProperties(instance:DisplayObject, cache:InstanceCache):void

Customizes the item renderer instances that are used to represent the chart. This method is called automatically whenever a new item renderer is needed while the chart is being rendered. You can override this method to add your own customization as necessary.

Parameters
instance:DisplayObject — The new item renderer instance that is being created.
cache:InstanceCache — The InstanceCache that is used to manage the item renderer instances.
Examples
PlotChartExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the PlotChart control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.collections.ArrayCollection;

        [Bindable]
        private var expensesAC:ArrayCollection = new ArrayCollection( [
            { Month: "Jan", Profit: 2000, Expenses: 1500, Amount: 450 },
            { Month: "Feb", Profit: 1000, Expenses: 200, Amount: 600 },
            { Month: "Mar", Profit: 1500, Expenses: 500, Amount: 300 } ]);
        ]]>
    </mx:Script>

    <mx:Panel title="PlotChart Control Example" height="100%" width="100%">

        <mx:PlotChart id="plot" height="100%" width="100%"
            paddingLeft="5" paddingRight="5"
            showDataTips="true" dataProvider="{expensesAC}">

            <mx:series>
                <mx:PlotSeries xField="Expenses" yField="Profit" displayName="Expenses/Profit"/>
                <mx:PlotSeries xField="Amount" yField="Expenses" displayName="Amount/Expenses"/>
                <mx:PlotSeries xField="Profit" yField="Amount" displayName="Profit/Amount"/>
            </mx:series>
        </mx:PlotChart>

        <mx:Legend dataProvider="{plot}"/>

    </mx:Panel>
</mx:Application>


mx.charts.series.items Summary (Flex™ 2 Language Reference)

Package mx.charts.series.items | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.renderers.items package contains the item series classes for the Flex charting components.

Classes
Class | Description
AreaSeriesItem | Represents the information required to render an item as part of an AreaSeries.
BarSeriesItem | Represents the information required to render an item as part of a BarSeries.
BubbleSeriesItem | Represents the information required to render an item as part of a BubbleSeries.
ColumnSeriesItem | Represents the information required to render an item as part of a ColumnSeries.
HLOCSeriesItem | Represents the information required to render an item as part of a HLOCSeries.
LineSeriesItem | Represents the information required to render an item as part of a LineSeries.
LineSeriesSegment | Represents the information required to render a segment in a LineSeries.
PieSeriesItem | Represents the information required to render a single wedge as part of a PieSeries.
PlotSeriesItem | Represents the information required to render an item as part of a PlotSeries.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.series.items.AreaSeriesItem (Flex™ 2 Language Reference)

Class AreaSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class AreaSeriesItem
Inheritance | AreaSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render an item as part of an AreaSeries. The AreaSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
 | min : Number The minimum value of this item converted into screen coordinates. | AreaSeriesItem
 | minFilter : Number The minimum value of this item, filtered against the vertical axis of the containing chart. | AreaSeriesItem
 | minNumber : Number The minimum value of this item, converted to a number by the vertical axis of the containing chart. | AreaSeriesItem
 | minValue : Object The minimum value of this item. | AreaSeriesItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number The x value of this item converted into screen coordinates. | AreaSeriesItem
 | xFilter : Number The x value of this item, filtered against the horizontal axis of the containing chart. | AreaSeriesItem
 | xNumber : Number The x value of this item, converted to a numeric representation by the horizontal axis of the containing chart. | AreaSeriesItem
 | xValue : Object The x value of this item. | AreaSeriesItem
 | y : Number The y value of this item converted into screen coordinates. | AreaSeriesItem
 | yFilter : Number The y value of this item, filtered against the vertical axis of the containing chart. | AreaSeriesItem
 | yNumber : Number The y value of this item, converted to a numeric representation by the vertical axis of the containing chart. | AreaSeriesItem
 | yValue : Object The y value of this item. | AreaSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AreaSeriesItem(element:AreaSeries = null, item:Object = null, index:uint = 0)
Constructor.
AreaSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
min property
public var min:Number

The minimum value of this item converted into screen coordinates. The value of this field is undefined if the AreaSeries is not stacked and its minField property is not set.

minFilter property
public var minFilter:Number

The minimum value of this item, filtered against the vertical axis of the containing chart. This value is set to NaN if the value lies outside the axis's range. The value of this field is undefined if the AreaSeries is not stacked and its minField property is not set.

minNumber property
public var minNumber:Number

The minimum value of this item, converted to a number by the vertical axis of the containing chart. The value of this field is undefined if the AreaSeries is not stacked and its minField property is not set.

minValue property
public var minValue:Object

The minimum value of this item. The value of this field is undefined if the AreaSeries is not stacked and its minField property is not set.

x property
public var x:Number

The x value of this item converted into screen coordinates.

xFilter property
public var xFilter:Number

The x value of this item, filtered against the horizontal axis of the containing chart. This value is set to NaN if the value lies outside the axis's range.

xNumber property
public var xNumber:Number

The x value of this item, converted to a numeric representation by the horizontal axis of the containing chart.

xValue property
public var xValue:Object

The x value of this item.

y property
public var y:Number

The y value of this item converted into screen coordinates.

yFilter property
public var yFilter:Number

The y value of this item, filtered against the vertical axis of the containing chart. This value is set to NaN if the value lies outside the axis's range.

yNumber property
public var yNumber:Number

The y value of this item, converted to a numeric representation by the vertical axis of the containing chart.

yValue property
public var yValue:Object

The y value of this item.

Constructor detail
AreaSeriesItem () constructor
public function AreaSeriesItem(element:AreaSeries = null, item:Object = null, index:uint = 0)

Constructor.

Parameters
element:AreaSeries (default = null) — The owning series.
item:Object (default = null) — The item from the dataProvider this ChartItem represents.
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.items.BarSeriesItem (Flex™ 2 Language Reference)

Class BarSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class BarSeriesItem
Inheritance | BarSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render an item as part of a BarSeries. The BarSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
 | min : Number The minimum value of this item converted into screen coordinates. | BarSeriesItem
 | minFilter : Number The minimum value of this item, filtered against the horizontal axis of the containing chart. | BarSeriesItem
 | minNumber : Number The minimum value of this item, converted to a number by the horizontal axis of the containing chart. | BarSeriesItem
 | minValue : Object The minimum value of this item. | BarSeriesItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number The x value of this item converted into screen coordinates. | BarSeriesItem
 | xFilter : Number The x value of this item, filtered against the horizontal axis of the containing chart. | BarSeriesItem
 | xNumber : Number The x value of this item, converted to a number by the horizontal axis of the containing chart. | BarSeriesItem
 | xValue : Object The x value of this item. | BarSeriesItem
 | y : Number The y value of this item converted into screen coordinates. | BarSeriesItem
 | yFilter : Number The y value of this item, filtered against the vertical axis of the containing chart. | BarSeriesItem
 | yNumber : Number The y value of this item, converted to a number by the vertical axis of the containing chart. | BarSeriesItem
 | yValue : Object The y value of this item. | BarSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BarSeriesItem(element:BarSeries = null, data:Object = null, index:uint = 0)
Constructor.
BarSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
min property
public var min:Number

The minimum value of this item converted into screen coordinates. The value of this field is undefined if the BarSeries is not stacked and its minField property is not set.

minFilter property
public var minFilter:Number

The minimum value of this item, filtered against the horizontal axis of the containing chart. This value NaN if the value lies outside the axis's range. The value of this field is undefined if the BarSeries is not stacked and its minField property is not set.

minNumber property
public var minNumber:Number

The minimum value of this item, converted to a number by the horizontal axis of the containing chart. The value of this field is undefined if the BarSeries is not stacked and its minField property is not set.

minValue property
public var minValue:Object

The minimum value of this item. The value of this field is undefined if the BarSeries is not stacked and its minField property is not set.

x property
public var x:Number

The x value of this item converted into screen coordinates.

xFilter property
public var xFilter:Number

The x value of this item, filtered against the horizontal axis of the containing chart. This value is NaN if the value lies outside the axis's range.

xNumber property
public var xNumber:Number

The x value of this item, converted to a number by the horizontal axis of the containing chart.

xValue property
public var xValue:Object

The x value of this item.

y property
public var y:Number

The y value of this item converted into screen coordinates.

yFilter property
public var yFilter:Number

The y value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

yNumber property
public var yNumber:Number

The y value of this item, converted to a number by the vertical axis of the containing chart.

yValue property
public var yValue:Object

The y value of this item.

Constructor detail
BarSeriesItem () constructor
public function BarSeriesItem(element:BarSeries = null, data:Object = null, index:uint = 0)

Constructor.

Parameters
element:BarSeries (default = null) — The owning series.
data:Object (default = null) — The item from the dataProvider that this ChartItem represents.
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.items.BubbleSeriesItem (Flex™ 2 Language Reference)

Class BubbleSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class BubbleSeriesItem
Inheritance | BubbleSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render an item as part of a BubbleSeries. The BubbleSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number The x value of this item converted into screen coordinates. | BubbleSeriesItem
 | xFilter : Number The x value of this item, filtered against the horizontal axis of the containing chart. | BubbleSeriesItem
 | xNumber : Number The x value of this item, converted to a number by the horizontal axis of the containing chart. | BubbleSeriesItem
 | xValue : Object The x value of this item. | BubbleSeriesItem
 | y : Number The y value of this item converted into screen coordinates. | BubbleSeriesItem
 | yFilter : Number The y value of this item, filtered against the vertical axis of the containing chart. | BubbleSeriesItem
 | yNumber : Number The y value of this item, converted to a number by the vertical axis of the containing chart. | BubbleSeriesItem
 | yValue : Object The y value of this item. | BubbleSeriesItem
 | z : Number The z value of this item converted into a pixel-based radius. | BubbleSeriesItem
 | zFilter : Number The z value of this item, filtered against the radius axis of the containing chart. | BubbleSeriesItem
 | zNumber : Number The z value of this item, converted to a number by the radius axis of the containing chart. | BubbleSeriesItem
 | zValue : Object The z value of this item. | BubbleSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BubbleSeriesItem(element:BubbleSeries = null, data:Object = null, index:uint = 0)
Constructor.
BubbleSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
x property
public var x:Number

The x value of this item converted into screen coordinates.

xFilter property
public var xFilter:Number

The x value of this item, filtered against the horizontal axis of the containing chart. This value is NaN if the value lies outside the axis' range.

xNumber property
public var xNumber:Number

The x value of this item, converted to a number by the horizontal axis of the containing chart.

xValue property
public var xValue:Object

The x value of this item.

y property
public var y:Number

The y value of this item converted into screen coordinates.

yFilter property
public var yFilter:Number

The y value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

yNumber property
public var yNumber:Number

The y value of this item, converted to a number by the vertical axis of the containing chart.

yValue property
public var yValue:Object

The y value of this item.

z property
public var z:Number

The z value of this item converted into a pixel-based radius.

zFilter property
public var zFilter:Number

The z value of this item, filtered against the radius axis of the containing chart. This value is NaN if the value lies outside the axis' range.

zNumber property
public var zNumber:Number

The z value of this item, converted to a number by the radius axis of the containing chart.

zValue property
public var zValue:Object

The z value of this item.

Constructor detail
BubbleSeriesItem () constructor
public function BubbleSeriesItem(element:BubbleSeries = null, data:Object = null, index:uint = 0)

Constructor.

Parameters
element:BubbleSeries (default = null) — The owning series.
data:Object (default = null) — The item from the dataProvider that this ChartItem represents.
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.items.ColumnSeriesItem (Flex™ 2 Language Reference)

Class ColumnSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class ColumnSeriesItem
Inheritance | ColumnSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render an item as part of a ColumnSeries. The ColumnSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
 | min : Number The minimum value of this item converted into screen coordinates. | ColumnSeriesItem
 | minFilter : Number The minimum value of this item, filtered against the vertical axis of the containing chart. | ColumnSeriesItem
 | minNumber : Number The minimum value of this item, converted to a number by the vertical axis of the containing chart. | ColumnSeriesItem
 | minValue : Object The miniumum value of this item. | ColumnSeriesItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number The x value of this item converted into screen coordinates. | ColumnSeriesItem
 | xFilter : Number The x value of this item, filtered against the horizontal axis of the containing chart. | ColumnSeriesItem
 | xNumber : Number The x value of this item, converted to a number by the horizontal axis of the containing chart. | ColumnSeriesItem
 | xValue : Object The x value of this item. | ColumnSeriesItem
 | y : Number The y value of this item converted into screen coordinates | ColumnSeriesItem
 | yFilter : Number The y value of this item, filtered against the vertical axis of the containing chart. | ColumnSeriesItem
 | yNumber : Number The y value of this item, converted to a number by the vertical axis of the containing chart. | ColumnSeriesItem
 | yValue : Object The y value of this item. | ColumnSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ColumnSeriesItem(element:ColumnSeries = null, data:Object = null, index:uint = 0)
Constructor.
ColumnSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
min property
public var min:Number

The minimum value of this item converted into screen coordinates. The value of this field is undefined if the ColumnSeries is not stacked and its minField property is not set.

minFilter property
public var minFilter:Number

The minimum value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis' range. The value of this field is undefined if the ColumnSeries is not stacked and its minField property is not set.

minNumber property
public var minNumber:Number

The minimum value of this item, converted to a number by the vertical axis of the containing chart. The value of this field is undefined if the ColumnSeries is not stacked and its minField property is not set.

minValue property
public var minValue:Object

The miniumum value of this item. The value of this field is undefined if the ColumnSeries is not stacked and its minField property is not set.

x property
public var x:Number

The x value of this item converted into screen coordinates.

xFilter property
public var xFilter:Number

The x value of this item, filtered against the horizontal axis of the containing chart. This value is NaN if the value lies outside the axis's range.

xNumber property
public var xNumber:Number

The x value of this item, converted to a number by the horizontal axis of the containing chart.

xValue property
public var xValue:Object

The x value of this item.

y property
public var y:Number

The y value of this item converted into screen coordinates

yFilter property
public var yFilter:Number

The y value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

yNumber property
public var yNumber:Number

The y value of this item, converted to a number by the vertical axis of the containing chart.

yValue property
public var yValue:Object

The y value of this item.

Constructor detail
ColumnSeriesItem () constructor
public function ColumnSeriesItem(element:ColumnSeries = null, data:Object = null, index:uint = 0)

Constructor.

Parameters
element:ColumnSeries (default = null) — The owning series.
data:Object (default = null) — The item from the dataProvider that this ChartItem represents.
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.items.HLOCSeriesItem (Flex™ 2 Language Reference)

Class HLOCSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class HLOCSeriesItem
Inheritance | HLOCSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render an item as part of a HLOCSeries. The HLOCSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | close : Number The close value of this item converted into screen coordinates. | HLOCSeriesItem
 | closeFilter : Number The close value of this item, filtered against the vertical axis of the containing chart. | HLOCSeriesItem
 | closeNumber : Number The close value of this item, converted to a number by the vertical axis of the containing chart. | HLOCSeriesItem
 | closeValue : Object The close value of this item. | HLOCSeriesItem
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
 | high : Number The high value of this item converted into screen coordinates. | HLOCSeriesItem
 | highFilter : Number The high value of this item, filtered against the vertical axis of the containing chart. | HLOCSeriesItem
 | highNumber : Number The high value of this item, converted to a number by the vertical axis of the containing chart. | HLOCSeriesItem
 | highValue : Object The high value of this item. | HLOCSeriesItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
 | low : Number The low value of this item converted into screen coordinates. | HLOCSeriesItem
 | lowFilter : Number The low value of this item, filtered against the vertical axis of the containing chart. | HLOCSeriesItem
 | lowNumber : Number The low value of this item, converted to a number by the vertical axis of the containing chart. | HLOCSeriesItem
 | lowValue : Object The low value of this item. | HLOCSeriesItem
 | open : Number The open value of this item converted into screen coordinates. | HLOCSeriesItem
 | openFilter : Number The open value of this item, filtered against the vertical axis of the containing chart. | HLOCSeriesItem
 | openNumber : Number The open value of this item, converted to a number by the vertical axis of the containing chart. | HLOCSeriesItem
 | openValue : Object The open value of this item. | HLOCSeriesItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number The x value of this item converted into screen coordinates. | HLOCSeriesItem
 | xFilter : Number The x value of this item, filtered against the horizontal axis of the containing chart. | HLOCSeriesItem
 | xNumber : Number The x value of this item, converted to a number by the horizontal axis of the containing chart. | HLOCSeriesItem
 | xValue : Object The x value of this item. | HLOCSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HLOCSeriesItem(element:HLOCSeriesBase = null, data:Object = null, index:uint = 0)
Constructor.
HLOCSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
close property
public var close:Number

The close value of this item converted into screen coordinates.

closeFilter property
public var closeFilter:Number

The close value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

closeNumber property
public var closeNumber:Number

The close value of this item, converted to a number by the vertical axis of the containing chart.

closeValue property
public var closeValue:Object

The close value of this item.

high property
public var high:Number

The high value of this item converted into screen coordinates.

highFilter property
public var highFilter:Number

The high value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

highNumber property
public var highNumber:Number

The high value of this item, converted to a number by the vertical axis of the containing chart.

highValue property
public var highValue:Object

The high value of this item.

low property
public var low:Number

The low value of this item converted into screen coordinates.

lowFilter property
public var lowFilter:Number

The low value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

lowNumber property
public var lowNumber:Number

The low value of this item, converted to a number by the vertical axis of the containing chart.

lowValue property
public var lowValue:Object

The low value of this item.

open property
public var open:Number

The open value of this item converted into screen coordinates.

openFilter property
public var openFilter:Number

The open value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

openNumber property
public var openNumber:Number

The open value of this item, converted to a number by the vertical axis of the containing chart.

openValue property
public var openValue:Object

The open value of this item.

x property
public var x:Number

The x value of this item converted into screen coordinates.

xFilter property
public var xFilter:Number

The x value of this item, filtered against the horizontal axis of the containing chart. This value is NaN if the value lies outside the axis's range.

xNumber property
public var xNumber:Number

The x value of this item, converted to a number by the horizontal axis of the containing chart.

xValue property
public var xValue:Object

The x value of this item.

Constructor detail
HLOCSeriesItem () constructor
public function HLOCSeriesItem(element:HLOCSeriesBase = null, data:Object = null, index:uint = 0)

Constructor.

Parameters
element:HLOCSeriesBase (default = null) — The owning series.
data:Object (default = null) — The item from the dataProvider that this ChartItem represents.
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.items.LineSeriesItem (Flex™ 2 Language Reference)

Class LineSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class LineSeriesItem
Inheritance | LineSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render an item as part of a LineSeries. The LineSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | x : Number The x value of this item converted into screen coordinates. | LineSeriesItem
 | xFilter : Number The x value of this item, filtered against the horizontal axis of the containing chart. | LineSeriesItem
 | xNumber : Number The x value of this item, converted to a number by the horizontal axis of the containing chart. | LineSeriesItem
 | xValue : Object The x value of this item. | LineSeriesItem
 | y : Number The y value of this item converted into screen coordinates. | LineSeriesItem
 | yFilter : Number The y value of this item, filtered against the vertical axis of the containing chart. | LineSeriesItem
 | yNumber : Number The y value of this item, converted to a number by the vertical axis of the containing chart. | LineSeriesItem
 | yValue : Object The y value of this item. | LineSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LineSeriesItem(element:LineSeries = null, data:Object = null, index:uint = 0)
Constructor.
LineSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
x property
public var x:Number

The x value of this item converted into screen coordinates.

xFilter property
public var xFilter:Number

The x value of this item, filtered against the horizontal axis of the containing chart. This value is NaN if the value lies outside the axis's range.

xNumber property
public var xNumber:Number

The x value of this item, converted to a number by the horizontal axis of the containing chart.

xValue property
public var xValue:Object

The x value of this item.

y property
public var y:Number

The y value of this item converted into screen coordinates.

yFilter property
public var yFilter:Number

The y value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

yNumber property
public var yNumber:Number

The y value of this item, converted to a number by the vertical axis of the containing chart.

yValue property
public var yValue:Object

The y value of this item.

Constructor detail
LineSeriesItem () constructor
public function LineSeriesItem(element:LineSeries = null, data:Object = null, index:uint = 0)

Constructor.

Parameters
element:LineSeries (default = null) — The owning series.
data:Object (default = null) — The item from the dataProvider that this ChartItem represents.
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.items.LineSeriesSegment (Flex™ 2 Language Reference)

Class LineSeriesSegment | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class LineSeriesSegment
Inheritance | LineSeriesSegment Inheritance Object

Represents the information required to render a segment in a LineSeries. The LineSeries class passes a LineSeriesSegment to its lineRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | element : LineSeries The series or element that owns this segment. | LineSeriesSegment
 | end : uint The index into the items array of the last item in this segment, inclusive. | LineSeriesSegment
 | index : uint The index of this segment in the array of segments representing the line series. | LineSeriesSegment
 | items : Array The array of chartItems representing the full line series that owns this segment. | LineSeriesSegment
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | start : uint The index into the items array of the first item in this segment. | LineSeriesSegment
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LineSeriesSegment(element:LineSeries, index:uint, items:Array, start:uint, end:uint) Constructor. | LineSeriesSegment
 | clone():LineSeriesSegment Returns a copy of this segment. | LineSeriesSegment
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
element property
public var element:LineSeries

The series or element that owns this segment.

end property
public var end:uint

The index into the items array of the last item in this segment, inclusive.

index property
public var index:uint

The index of this segment in the array of segments representing the line series.

items property
public var items:Array

The array of chartItems representing the full line series that owns this segment.

start property
public var start:uint

The index into the items array of the first item in this segment.

Constructor detail
LineSeriesSegment () constructor
public function LineSeriesSegment(element:LineSeries, index:uint, items:Array, start:uint, end:uint)

Constructor.

Parameters
element:LineSeries — The owning series.
index:uint — The index of the segment in the Array of segments representing the line series.
items:Array — The Array of LineSeriesItems representing the full line series.
start:uint — The index in the items Array of the first item in this segment.
end:uint — The index in the items Array of the last item in this segment, inclusive.
Method detail
clone () method
public function clone():LineSeriesSegment

Returns a copy of this segment.

Returns
LineSeriesSegment


mx.charts.series.items.PieSeriesItem (Flex™ 2 Language Reference)

Class PieSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class PieSeriesItem
Inheritance | PieSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render a single wedge as part of a PieSeries. The PieSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | angle : Number The angle, in radians, that this wedge subtends. | PieSeriesItem
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
 | fill : IFill The fill value associated with this wedge of the PieChart control. | PieSeriesItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
 | innerRadius : Number The distance of the inner edge of this wedge from its origin, measured in pixels. | PieSeriesItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
 | labelAngle : Number The angle of the label, in radians, for this wedge. | PieSeriesItem
 | number : Number The value this wedge represents converted into screen coordinates | PieSeriesItem
 | origin : Point The origin, relative to the PieSeries's coordinate system, of this wedge. | PieSeriesItem
 | outerRadius : Number The distance of the outer edge of this wedge from its origin, measured in pixels. | PieSeriesItem
 | percentValue : Number The percentage this value represents of the total pie. | PieSeriesItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | startAngle : Number The start angle, in radians, of this wedge. | PieSeriesItem
 | value : Object The value this wedge represents from the PieSeries' dataProvider. | PieSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PieSeriesItem(element:PieSeries = null, data:Object = null, index:uint = 0)
Constructor.
PieSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
angle property
public var angle:Number

The angle, in radians, that this wedge subtends.

fill property
public var fill:IFill

The fill value associated with this wedge of the PieChart control.

innerRadius property
public var innerRadius:Number

The distance of the inner edge of this wedge from its origin, measured in pixels. If 0, the wedge should come to a point at the origin.

labelAngle property
public var labelAngle:Number

The angle of the label, in radians, for this wedge.

number property
public var number:Number

The value this wedge represents converted into screen coordinates

origin property
public var origin:Point

The origin, relative to the PieSeries's coordinate system, of this wedge.

outerRadius property
public var outerRadius:Number

The distance of the outer edge of this wedge from its origin, measured in pixels.

percentValue property
public var percentValue:Number

The percentage this value represents of the total pie.

startAngle property
public var startAngle:Number

The start angle, in radians, of this wedge.

value property
public var value:Object

The value this wedge represents from the PieSeries' dataProvider.

Constructor detail
PieSeriesItem () constructor
public function PieSeriesItem(element:PieSeries = null, data:Object = null, index:uint = 0)

Constructor.

Parameters
element:PieSeries (default = null) — The owning series.
data:Object (default = null) — The item from the dataProvider that this ChartItem represents .
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.items.PlotSeriesItem (Flex™ 2 Language Reference)

Class PlotSeriesItem | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.items
Class | public class PlotSeriesItem
Inheritance | PlotSeriesItem Inheritance ChartItem Inheritance EventDispatcher Inheritance Object

Represents the information required to render an item as part of a PlotSeries. The PlotSeries class passes these items to its itemRenderer when rendering.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | element : IChartElement The series or element that owns the ChartItem. | ChartItem
Inherited | index : int The index of the data from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | item : Object The item from the series' dataProvider that the ChartItem represents. | ChartItem
Inherited | itemRenderer : IFlexDisplayObject The instance of the chart's itemRenderer that represents this ChartItem. | ChartItem
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radius : Number The radius of this item, in pixels. | PlotSeriesItem
 | x : Number The x value of this item converted into screen coordinates. | PlotSeriesItem
 | xFilter : Number The x value of this item, filtered against the horizontal axis of the containing chart. | PlotSeriesItem
 | xNumber : Number The x value of this item, converted to a number by the horizontal axis of the containing chart. | PlotSeriesItem
 | xValue : Object The x value of this item. | PlotSeriesItem
 | y : Number The y value of this item converted into screen coordinates | PlotSeriesItem
 | yFilter : Number The y value of this item, filtered against the vertical axis of the containing chart. | PlotSeriesItem
 | yNumber : Number The y value of this item, converted to a number by the vertical axis of the containing chart. | PlotSeriesItem
 | yValue : Object The y value of this item. | PlotSeriesItem
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PlotSeriesItem(element:PlotSeries = null, data:Object = null, index:uint = 0)
Constructor.
PlotSeriesItem
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clone():ChartItem
Returns a copy of this ChartItem.
ChartItem
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
radius property
public var radius:Number

The radius of this item, in pixels.

x property
public var x:Number

The x value of this item converted into screen coordinates.

xFilter property
public var xFilter:Number

The x value of this item, filtered against the horizontal axis of the containing chart. This value is NaN if the value lies outside the axis's range.

xNumber property
public var xNumber:Number

The x value of this item, converted to a number by the horizontal axis of the containing chart.

xValue property
public var xValue:Object

The x value of this item.

y property
public var y:Number

The y value of this item converted into screen coordinates

yFilter property
public var yFilter:Number

The y value of this item, filtered against the vertical axis of the containing chart. This value is NaN if the value lies outside the axis's range.

yNumber property
public var yNumber:Number

The y value of this item, converted to a number by the vertical axis of the containing chart.

yValue property
public var yValue:Object

The y value of this item.

Constructor detail
PlotSeriesItem () constructor
public function PlotSeriesItem(element:PlotSeries = null, data:Object = null, index:uint = 0)

Constructor.

Parameters
element:PlotSeries (default = null) — The owning series.
data:Object (default = null) — The item from the dataProvider this ChartItem represents .
index:uint (default = 0) — The index of the item from the series's dataProvider.


mx.charts.series.renderData Summary (Flex™ 2 Language Reference)

Package mx.charts.series.renderData | Classes
(Adobe® Flex™ Charting components only)

The mx.charts.renderers.renderData package contains the data classes for the Flex charting components.

Classes
Class | Description
AreaSeriesRenderData | Represents all the information needed by the AreaSeries to render.
BarSeriesRenderData | Represents all the information needed by the BarSeries to render.
BubbleSeriesRenderData | Represents all the information needed by the BubbleSeries to render.
ColumnSeriesRenderData | Represents all the information needed by the ColumnSeries to render.
HLOCSeriesRenderData | Represents all the information needed by the HLOCSeries and CandlestickSeries objects to render.
LineSeriesRenderData | Represents all the information needed by the LineSeries to render.
PieSeriesRenderData | Represents all the information needed by the PieSeries to render.
PlotSeriesRenderData | Represents all the information needed by the PlotSeries to render.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.charts.series.renderData.AreaSeriesRenderData (Flex™ 2 Language Reference)

Class AreaSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class AreaSeriesRenderData
Inheritance | AreaSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the AreaSeries to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | element : AreaSeries The AreaSeries that this structure is associated with. | AreaSeriesRenderData
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radius : Number The radius of the items of the AreaSeries. | AreaSeriesRenderData
 | renderedBase : Number The vertical position of the base of the area series, in pixels. | AreaSeriesRenderData
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AreaSeriesRenderData(element:AreaSeries, cache:Array = null, filteredCache:Array = null, renderedBase:Number = 0, radius:Number = 0) Constructor. | AreaSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
element property
public var element:AreaSeries

The AreaSeries that this structure is associated with.

radius property
public var radius:Number

The radius of the items of the AreaSeries.

renderedBase property
public var renderedBase:Number

The vertical position of the base of the area series, in pixels.

Constructor detail
AreaSeriesRenderData () constructor
public function AreaSeriesRenderData(element:AreaSeries, cache:Array = null, filteredCache:Array = null, renderedBase:Number = 0, radius:Number = 0)

Constructor.

Parameters
element:AreaSeries — The AreaSeries object that this structure is associated with.
cache:Array (default = null) — The list of AreaSeriesItem objects representing the items in the dataProvider.
filteredCache:Array (default = null) — The list of AreaSeriesItem objects representing the items in the dataProvider that remain after filtering.
renderedBase:Number (default = 0) — The vertical position of the base of the area series, in pixels.
radius:Number (default = 0)


mx.charts.series.renderData.BarSeriesRenderData (Flex™ 2 Language Reference)

Class BarSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class BarSeriesRenderData
Inheritance | BarSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the BarSeries to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | renderedBase : Number The horizontal position of the base of the bars, in pixels. | BarSeriesRenderData
 | renderedHalfWidth : Number Half the width of a bar, in pixels. | BarSeriesRenderData
 | renderedYOffset : Number The offset of each bar from its y value, in pixels. | BarSeriesRenderData
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | BarSeriesRenderData(cache:Array = null, filteredCache:Array = null, renderedBase:Number = 0, renderedHalfWidth:Number = 0, renderedYOffset:Number = 0) Constructor. | BarSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
renderedBase property
public var renderedBase:Number

The horizontal position of the base of the bars, in pixels.

renderedHalfWidth property
public var renderedHalfWidth:Number

Half the width of a bar, in pixels.

renderedYOffset property
public var renderedYOffset:Number

The offset of each bar from its y value, in pixels.

Constructor detail
BarSeriesRenderData () constructor
public function BarSeriesRenderData(cache:Array = null, filteredCache:Array = null, renderedBase:Number = 0, renderedHalfWidth:Number = 0, renderedYOffset:Number = 0)

Constructor.

Parameters
cache:Array (default = null) — The list of BarSeriesItem objects representing the items in the dataProvider
filteredCache:Array (default = null) — The list of BarSeriesItem objects representing the items in the dataProvider that remain after filtering.
renderedBase:Number (default = 0) — The horizontal position of the base of the bars, in pixels.
renderedHalfWidth:Number (default = 0) — Half the width of a bar, in pixels.
renderedYOffset:Number (default = 0) — The offset of each bar from its y value, in pixels.


mx.charts.series.renderData.BubbleSeriesRenderData (Flex™ 2 Language Reference)

Class BubbleSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class BubbleSeriesRenderData
Inheritance | BubbleSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the BubbleSeries to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | BubbleSeriesRenderData(cache:Array = null, filteredCache:Array = null) Constructor | BubbleSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
BubbleSeriesRenderData () constructor
public function BubbleSeriesRenderData(cache:Array = null, filteredCache:Array = null)

Constructor

Parameters
cache:Array (default = null) — The list of BubbleSeriesItem objects representing the items in the dataProvider.
filteredCache:Array (default = null) — The list of BubbleSeriesItem objects representing the items in the dataProvider that remain after filtering.


mx.charts.series.renderData.ColumnSeriesRenderData (Flex™ 2 Language Reference)

Class ColumnSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class ColumnSeriesRenderData
Inheritance | ColumnSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the ColumnSeries to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | renderedBase : Number The vertical position of the base of the columns, in pixels. | ColumnSeriesRenderData
 | renderedHalfWidth : Number Half the width of a column, in pixels. | ColumnSeriesRenderData
 | renderedXOffset : Number The offset of each column from its x value, in pixels. | ColumnSeriesRenderData
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ColumnSeriesRenderData(cache:Array = null, filteredCache:Array = null, renderedBase:Number = 0, renderedHalfWidth:Number = 0, renderedXOffset:Number = 0) Constructor. | ColumnSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
renderedBase property
public var renderedBase:Number

The vertical position of the base of the columns, in pixels.

renderedHalfWidth property
public var renderedHalfWidth:Number

Half the width of a column, in pixels.

renderedXOffset property
public var renderedXOffset:Number

The offset of each column from its x value, in pixels.

Constructor detail
ColumnSeriesRenderData () constructor
public function ColumnSeriesRenderData(cache:Array = null, filteredCache:Array = null, renderedBase:Number = 0, renderedHalfWidth:Number = 0, renderedXOffset:Number = 0)

Constructor.

Parameters
cache:Array (default = null) — The list of ColumnSeriesItem objects representing the items in the dataProvider.
filteredCache:Array (default = null) — The list of ColumnSeriesItem objects representing the items in the dataProvider that remain after filtering.
renderedBase:Number (default = 0) — The vertical position of the base of the columns, in pixels.
renderedHalfWidth:Number (default = 0) — Half the width of a column, in pixels.
renderedXOffset:Number (default = 0) — The offset of each column from its x value, in pixels.


mx.charts.series.renderData.HLOCSeriesRenderData (Flex™ 2 Language Reference)

Class HLOCSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class HLOCSeriesRenderData
Inheritance | HLOCSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the HLOCSeries and CandlestickSeries objects to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | renderedHalfWidth : Number Half the width of an item, in pixels. | HLOCSeriesRenderData
 | renderedXOffset : Number The offset of each item from its x value, in pixels. | HLOCSeriesRenderData
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | HLOCSeriesRenderData(cache:Array = null, filteredCache:Array = null, renderedHalfWidth:Number = 0, renderedXOffset:Number = 0) Constructor. | HLOCSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
renderedHalfWidth property
public var renderedHalfWidth:Number

Half the width of an item, in pixels.

renderedXOffset property
public var renderedXOffset:Number

The offset of each item from its x value, in pixels.

Constructor detail
HLOCSeriesRenderData () constructor
public function HLOCSeriesRenderData(cache:Array = null, filteredCache:Array = null, renderedHalfWidth:Number = 0, renderedXOffset:Number = 0)

Constructor.

Parameters
cache:Array (default = null) — The list of HLOCSeriesItem objects representing the items in the data provider.
filteredCache:Array (default = null) — The list of HLOCSeriesItem objects representing the items in the data provider that remain after filtering.
renderedHalfWidth:Number (default = 0) — Half the width of an item, in pixels.
renderedXOffset:Number (default = 0) — The offset of each item from its x value, in pixels.


mx.charts.series.renderData.LineSeriesRenderData (Flex™ 2 Language Reference)

Class LineSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class LineSeriesRenderData
Inheritance | LineSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the LineSeries to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radius : Number The radius of the individual items in the line series. | LineSeriesRenderData
 | segments : Array An Array of LineSeriesSegment instances representing each discontiguous segment of the line series. | LineSeriesRenderData
 | validPoints : Number The number of points in the cache that were not filtered out by the axes. | LineSeriesRenderData
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LineSeriesRenderData(cache:Array = null, filteredCache:Array = null, validPoints:Number = 0, segments:Array = null, radius:Number = 0) Constructor. | LineSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
radius property
public var radius:Number

The radius of the individual items in the line series.

segments property
public var segments:Array

An Array of LineSeriesSegment instances representing each discontiguous segment of the line series.

validPoints property
public var validPoints:Number

The number of points in the cache that were not filtered out by the axes.

Constructor detail
LineSeriesRenderData () constructor
public function LineSeriesRenderData(cache:Array = null, filteredCache:Array = null, validPoints:Number = 0, segments:Array = null, radius:Number = 0)

Constructor.

Parameters
cache:Array (default = null) — The list of LineSeriesItem objects representing the items in the dataProvider.
filteredCache:Array (default = null) — The list of LineSeriesItem objects representing the items in the dataProvider that remain after filtering.
validPoints:Number (default = 0) — The number of points in the cache that are valid.
segments:Array (default = null) — An Array of LineSeriesSegment objects representing each discontiguous segment of the LineSeries.
radius:Number (default = 0) — The radius of the individual items in the LineSeries.


mx.charts.series.renderData.PieSeriesRenderData (Flex™ 2 Language Reference)

Class PieSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class PieSeriesRenderData
Inheritance | PieSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the PieSeries to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
 | labelData : Object a structure of data associated with the layout of the labels rendered by the pie series. | PieSeriesRenderData
 | labelScale : Number the scale factor of the labels rendered by the pie series. | PieSeriesRenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | PieSeriesRenderData(cache:Array = null, filteredCache:Array = null, labelScale:Number = 1, labelData:Object = null) Constructor. | PieSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
labelData property
public var labelData:Object

a structure of data associated with the layout of the labels rendered by the pie series.

labelScale property
public var labelScale:Number

the scale factor of the labels rendered by the pie series.

Constructor detail
PieSeriesRenderData () constructor
public function PieSeriesRenderData(cache:Array = null, filteredCache:Array = null, labelScale:Number = 1, labelData:Object = null)

Constructor.

Parameters
cache:Array (default = null) — The list of PieSeriesItem objects representing the items in the dataProvider.
filteredCache:Array (default = null) — The list of PieSeriesItem objects representing the items in the dataProvider that remain after filtering.
labelScale:Number (default = 1) — The scale factor of the labels rendered by the PieSeries.
labelData:Object (default = null) — A structure of data associated with the layout of the labels rendered by the PieSeries.


mx.charts.series.renderData.PlotSeriesRenderData (Flex™ 2 Language Reference)

Class PlotSeriesRenderData | Properties | Methods
(Adobe® Flex™ Charting components only)
Package | mx.charts.series.renderData
Class | public class PlotSeriesRenderData
Inheritance | PlotSeriesRenderData Inheritance RenderData Inheritance Object

Represents all the information needed by the PlotSeries to render.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bounds : Rectangle The bounds of all of the items a series displays on screen, relative to the series's coordinate system. | RenderData
Inherited | cache : Array The list of ChartItems representing the items in the series's dataProvider. | RenderData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | elementBounds : Array An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system. | RenderData
Inherited | filteredCache : Array The list of ChartItems representing the items in the series's dataProvider that remain after filtering. | RenderData
Inherited | length : uint The number of items represented in this render data. | RenderData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | radius : Number The radius of the individual PlotSeriesItem objects. | PlotSeriesRenderData
Inherited | visibleRegion : Rectangle The rectangle describing the possible coordinate range that a series can display on screen. | RenderData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | PlotSeriesRenderData(cache:Array = null, filteredCache:Array = null, radius:Number = 0) Constructor. | PlotSeriesRenderData
Inherited | clone():RenderData Creates a copy of the render data. | RenderData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
radius property
public var radius:Number

The radius of the individual PlotSeriesItem objects.

Constructor detail
PlotSeriesRenderData () constructor
public function PlotSeriesRenderData(cache:Array = null, filteredCache:Array = null, radius:Number = 0)

Constructor.

Parameters
cache:Array (default = null) — The list of PlotSeriesItem objects representing the items in the dataProvider.
filteredCache:Array (default = null) — The list of PlotSeriesItem objects representing the items in the dataProvider that remain after filtering.
radius:Number (default = 0) — The radius of the individual PlotSeriesItem objects.


mx.collections Summary (Flex™ 2 Language Reference)

Package mx.collections | Interfaces | Classes

The mx.collections package contains the classes for the Flex collection components.

Interfaces
Interface | Description
ICollectionView | An ICollectionView is a view onto a collection of data.
IList | A collection of items organized in an ordinal fashion.
IViewCursor | Defines the interface for enumerating a collection view bi-directionally.
Classes
Class | Description
ArrayCollection | The ArrayCollection class is a wrapper class that exposes an Array as a collection that can be accessed and manipulated using the methods and properties of the ICollectionView or IList interfaces.
CursorBookmark | Encapsulates the positional aspects of a cursor in an ICollectionView.
ItemResponder | The ItemResponder class provides a default implementation of the mx.rpc.IResponder interface.
ListCollectionView | The ListCollectionView class adds the properties and methods of the ICollectionView interface to an object that conforms to the IList interface.
Sort | Provides the sorting information required to establish a sort on an existing view (ICollectionView interface or class that implements the interface).
SortField | Provides the sorting information required to establish a sort on a field or property in an existing view.
XMLListCollection | The XMLListCollection class provides collection functionality to an XMLList object and makes available some of the methods of the native XMLList class.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.collections.ArrayCollection (Flex™ 2 Language Reference)

Class ArrayCollection | Properties | Methods | Events
Package | mx.collections
Class | public class ArrayCollection
Inheritance | ArrayCollection Inheritance ListCollectionView Inheritance Proxy Inheritance Object
Implements | IExternalizable

The ArrayCollection class is a wrapper class that exposes an Array as a collection that can be accessed and manipulated using the methods and properties of the ICollectionView or IList interfaces. Operations on a ArrayCollection instance modify the data source; for example, if you use the removeItemAt() method on an ArrayCollection, you remove the item from the underlying Array.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ArrayCollection> tag inherits all the attributes of its superclass, and adds the following attributes:

  <mx:ArrayCollection
  Properties
  source="null"
  />

Default MXML Property source

Example
The following code creates a simple ArrayCollection object that accesses and manipulates an array with a single Object element. It retrieves the element using the IList interface getItemAt method and an IViewCursor object that it obtains using the ICollectionView createCursor method.
  var myCollection:ArrayCollection = new ArrayCollection([{first: 'Matt', last: 'Matthews'}]);
  var myCursor:IViewCursor = myCollection.createCursor();
  var firstItem:Object = myCollection.getItemAt(z0);
  var firstItemFromCursor:Object = myCursor.current;
  if (firstItem == firstItemFromCursor) {
     //doCelebration();
  }

See also

Using Data Providers and Collections

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filterFunction : Function A function that the view will use to eliminate items that do not match the function's criteria. | ListCollectionView
Inherited | length : int The number of items in this view. | ListCollectionView
Inherited | list : IList The IList that this collection view wraps. | ListCollectionView
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | sort : Sort The Sort that will be applied to the ICollectionView. | ListCollectionView
 | source : Array The source of data in the ArrayCollection. | ArrayCollection
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | localIndex : Array When the view is sorted or filtered the localIndex property contains an array of items in the sorted or filtered (ordered, reduced) view, in the sorted ordder. | ListCollectionView
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ArrayCollection(source:Array = null)
Constructor.
ArrayCollection
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
ListCollectionView
Inherited
addItem(item:Object):void
Adds the specified item to the end of the list.
ListCollectionView
Inherited
addItemAt(item:Object, index:int):void
Adds the item at the specified index.
ListCollectionView
Inherited
contains(item:Object):Boolean
Returns whether the view contains the specified object.
ListCollectionView
Inherited
createCursor():IViewCursor
Creates a new IViewCursor that works with this view.
ListCollectionView
Inherited
disableAutoUpdate():void
Prevents changes to the collection itself and items within the collection from being dispatched by the view.
ListCollectionView
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
ListCollectionView
Inherited
enableAutoUpdate():void
Enables auto-updating.
ListCollectionView
Inherited
getItemAt(index:int, prefetch:int = 0):Object
Gets the item at the specified index.
ListCollectionView
Inherited
getItemIndex(item:Object):int
Returns the index of the item if it is in the list such that getItemAt(index) == item.
ListCollectionView
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
ListCollectionView
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the ListCollectionView is created using an MXML tag.
ListCollectionView
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void
Notifies the view that an item has been updated.
ListCollectionView
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
refresh():Boolean
Applies the sort and filter to the view.
ListCollectionView
Inherited
removeAll():void
Remove all items from the list.
ListCollectionView
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
ListCollectionView
Inherited
removeItemAt(index:int):Object
Removes the item at the specified index and returns it.
ListCollectionView
Inherited
setItemAt(item:Object, index:int):Object
Places the item at the specified index.
ListCollectionView
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toArray():Array
Returns an Array that is populated in the same order as the IList implementation.
ListCollectionView
Inherited
toString():String
Pretty prints the contents of this view to a string and returns it.
ListCollectionView
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
ListCollectionView
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | collectionChange | Dispatched when the ICollectionView has been updated in some way. | ListCollectionView
Property detail
source property
source:Array [read-write]

The source of data in the ArrayCollection. The ArrayCollection object does not represent any changes that you make directly to the source array. Always use the ICollectionView or IList methods to modify the collection.

This property can be used as the source for data binding.

Implementation
    public function get source():Array
    public function set source(value:Array):void
Constructor detail
ArrayCollection () constructor
public function ArrayCollection(source:Array = null)

Constructor.

Creates a new ArrayCollection using the specified source array. If no array is specified an empty array will be used.

Parameters
source:Array (default = null)


mx.collections.CursorBookmark (Flex™ 2 Language Reference)

Class CursorBookmark | Properties | Methods
Package | mx.collections
Class | public class CursorBookmark
Inheritance | CursorBookmark Inheritance Object

Encapsulates the positional aspects of a cursor in an ICollectionView. Bookmarks are used to return a cursor to an absolute position within the ICollectionView.

See also

mx.collections.IViewCursor.bookmark
mx.collections.IViewCursor.seek()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | CURRENT : CursorBookmark [static][read-only] A bookmark representing the current item for the IViewCursor in an ICollectionView. | CursorBookmark
 | FIRST : CursorBookmark [static][read-only] A bookmark for the first item in an ICollectionView. | CursorBookmark
 | LAST : CursorBookmark [static][read-only] A bookmark for the last item in an ICollectionView. | CursorBookmark
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | value : Object [read-only] The underlying marker representation of the bookmark. | CursorBookmark
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CursorBookmark(value:Object) Creates a new instance of a bookmark with the specified value. | CursorBookmark
 | getViewIndex():int Get the approximate index of the item represented by this bookmark in its view. | CursorBookmark
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
CURRENT property
CURRENT:CursorBookmark [read-only]

A bookmark representing the current item for the IViewCursor in an ICollectionView.

Implementation
    public static function get CURRENT():CursorBookmark
FIRST property
FIRST:CursorBookmark [read-only]

A bookmark for the first item in an ICollectionView.

Implementation
    public static function get FIRST():CursorBookmark
LAST property
LAST:CursorBookmark [read-only]

A bookmark for the last item in an ICollectionView. If the view has no items, the cursor is at this bookmark.

Implementation
    public static function get LAST():CursorBookmark
value property
value:Object [read-only]

The underlying marker representation of the bookmark. This value is generally understood only by the IViewCursor or ICollectionView implementation.

Implementation
    public function get value():Object
Constructor detail
CursorBookmark () constructor
public function CursorBookmark(value:Object)

Creates a new instance of a bookmark with the specified value.

Parameters
value:Object — The value of this bookmark.
Method detail
getViewIndex () method
public function getViewIndex():int

Get the approximate index of the item represented by this bookmark in its view. If the item has been paged out this method could throw an ItemPendingError. If the item is not in the current view -1 is returned. This method also returns -1 if index-based location is not possible.

Returns
int


mx.collections.ICollectionView (Flex™ 2 Language Reference)

Interface ICollectionView | Properties | Methods | Events
Package | mx.collections
Interface | public interface ICollectionView extends IEventDispatcher
Implementors | ListCollectionView

An ICollectionView is a view onto a collection of data. The view can be modified to show the data sorted according to various criteria or reduced by filters without modifying the underlying data. An IViewCursor provides to access items within a collection. You can modify the collection by using the IViewCursor interface insert() and remove() methods.

An ICollectionView may be a view onto data that has been retrieved from a remote location. When Implementing this interface for data that may be remote it is important to handle the case where data may not yet be available, which is indicated by the ItemPendingError.

The IList interface is an alternative to the ICollectionView interface.

See also

mx.collections.IViewCursor
mx.collections.errors.ItemPendingError
mx.collections.IList
Using Data Providers and Collections

Public Properties
Property |  | Defined by
 | filterFunction : Function A function that the view will use to eliminate items that do not match the function's criteria. | ICollectionView
 | length : int [read-only] The number of items in this view. | ICollectionView
 | sort : Sort The Sort that will be applied to the ICollectionView. | ICollectionView
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
contains(item:Object):Boolean
Returns whether the view contains the specified object.
ICollectionView
createCursor():IViewCursor
Creates a new IViewCursor that works with this view.
ICollectionView
disableAutoUpdate():void
Prevents changes to the collection itself and items within the collection from being dispatched by the view.
ICollectionView
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
enableAutoUpdate():void
Enables auto-updating.
ICollectionView
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void
Notifies the view that an item has been updated.
ICollectionView
refresh():Boolean
Applies the sort and filter to the view.
ICollectionView
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Events
Event |  | Summary | Defined by
 | collectionChange | Dispatched when the ICollectionView has been updated in some way. | ICollectionView
Property detail
filterFunction property
filterFunction:Function [read-write]

A function that the view will use to eliminate items that do not match the function's criteria. A filterFunction is expected to have the following signature:

f(item:Object):Boolean
where the return value is true if the specified item should remain in the view.

If a filter is unsupported, Flex throws an error when accessing this property. You must call refresh() after setting the filterFunction property for the view to update.

Note: The Flex implementations of ICollectionView retrieve all items from a remote location before executing the filter function. If you use paging, apply the filter to the remote collection before you retrieve the data.

Implementation
    public function get filterFunction():Function
    public function set filterFunction(value:Function):void

See also

refresh()
length property
length:int [read-only]

The number of items in this view. 0 means no items, while -1 means that the length is unknown.

Implementation
    public function get length():int
sort property
sort:Sort [read-write]

The Sort that will be applied to the ICollectionView. Setting the sort does not automatically refresh the view, so you must call the refresh() method after setting this property. If sort is unsupported an error will be thrown when accessing this property.

Note: The Flex implementations of ICollectionView retrieve all items from a remote location before executing a sort. If you use paging with a sorted list, apply the sort to the remote collection before you retrieve the data.

Implementation
    public function get sort():Sort
    public function set sort(value:Sort):void

See also

refresh()
Method detail
contains () method
public function contains(item:Object):Boolean

Returns whether the view contains the specified object. Unlike the IViewCursor.findxxx methods, this search is succesful only if it finds an item that exactly matches the parameter. If the view has a filter applied to it this method may return false even if the underlying collection does contain the item.

Parameters
item:Object — The object to look for.

Returns
Boolean — true if the ICollectionView, after applying any filter, contains the item; false otherwise.
createCursor () method
public function createCursor():IViewCursor

Creates a new IViewCursor that works with this view.

Returns
IViewCursor — A new IViewCursor implementation.
disableAutoUpdate () method
public function disableAutoUpdate():void

Prevents changes to the collection itself and items within the collection from being dispatched by the view. Also prevents the view from updating the positions of items if the positions change in the collection. The changes will be queued and dispatched appropriately after enableAutoUpdate is called. If more events than updates to a single item occur, the view may end up resetting. The disableAutoUpdate method acts cumulatively; the same number of calls to enableAutoUpdate are required for the view to dispatch events and refresh. Note that disableAutoUpdate only affects the individual view; edits may be detected on an individual basis by other views.

enableAutoUpdate () method
public function enableAutoUpdate():void

Enables auto-updating. See disableAutoUpdate for more information.

See also

disableAutoUpdate()
itemUpdated () method
public function itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void

Notifies the view that an item has been updated. This method is useful if the contents of the view do not implement IPropertyChangeNotifier. If the call to this method includes a property parameter, the view may be able to optimize its notification mechanism. Otherwise it may choose to simply refresh the whole view.

Parameters
item:Object — The item within the view that was updated.
property:Object (default = null) — The name of the property that was updated.
oldValue:Object (default = null) — The old value of that property. (If property was null, this can be the old value of the item.).
newValue:Object (default = null) — The new value of that property. (If property was null, there's no need to specify this as the item is assumed to be the new value.)

See also

mx.events.CollectionEvent
mx.core.IPropertyChangeNotifier
mx.events.PropertyChangeEvent
refresh () method
public function refresh():Boolean

Applies the sort and filter to the view. The ICollectionView does not detect changes to a sort or filter automatically, so you must call the refresh() method to update the view after setting the sort or filterFunction property. If your ICollectionView implementation also implements the IMXMLObject interface, you should to call the refresh() method from your initialized() method.

Returns true if the refresh was successful and false if the sort is not yet complete (e.g., items are still pending). A client of the view should wait for a CollectionEvent event with the CollectionEventKind.REFRESH kind property to ensure that the refresh() operation is complete.

Returns
Boolean — true if the refresh() was complete, false if the refresh() is incomplete.
Event detail
collectionChange event
Event object type: mx.events.CollectionEvent
CollectionEvent.type property = mx.events.CollectionEvent.COLLECTION_CHANGE

Dispatched when the ICollectionView has been updated in some way.

The CollectionEvent.COLLECTION_CHANGE constant defines the value of the type property of the event object for an event that is dispatched when a collection has changed.

The properties of the event object have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
items | An Array of objects with information about the items affected by the event. The contents of this field depend on the event kind; for details see the items property
kind | The kind of event. The valid values are defined in the CollectionEventKind class as constants.
location | Location within the target collection of the item(s) specified in the items property.
oldLocation | the previous location in the collection of the item specified in the items property.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | CollectionEvent.COLLECTION_CHANGE


mx.collections.IList (Flex™ 2 Language Reference)

Interface IList | Properties | Methods | Events
Package | mx.collections
Interface | public interface IList extends IEventDispatcher
Implementors | ListCollectionView

A collection of items organized in an ordinal fashion. Provides access and manipulation methods based on index.

An IList may be a view onto data that has been retrieved from a remote location. When writing for a collection that may be remote, it is important to handle the case where data may not yet be available, which is indicated by the ItemPendingError.

The ICollectionView is an alternative to the IList.

See also

mx.collections.errors.ItemPendingError
mx.collections.ICollectionView
mx.collections.ListCollectionView
Using Data Providers and Collections

Public Properties
Property |  | Defined by
 | length : int [read-only] The number of items in this collection. | IList
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
addItem(item:Object):void
Adds the specified item to the end of the list.
IList
addItemAt(item:Object, index:int):void
Adds the item at the specified index.
IList
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
getItemAt(index:int, prefetch:int = 0):Object
Gets the item at the specified index.
IList
getItemIndex(item:Object):int
Returns the index of the item if it is in the list such that getItemAt(index) == item.
IList
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void
Notifies the view that an item has been updated.
IList
removeAll():void
Removes all items from the list.
IList
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
removeItemAt(index:int):Object
Removes the item at the specified index and returns it.
IList
setItemAt(item:Object, index:int):Object
Places the item at the specified index.
IList
toArray():Array
Returns an Array that is populated in the same order as the IList implementation.
IList
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Events
Event |  | Summary | Defined by
 | collectionChange | Dispatched when the IList has been updated in some way. | IList
Property detail
length property
length:int [read-only]

The number of items in this collection. 0 means no items while -1 means the length is unknown.

Implementation
    public function get length():int
Method detail
addItem () method
public function addItem(item:Object):void

Adds the specified item to the end of the list. Equivalent to addItemAt(item, length).

Parameters
item:Object — The item to add.
addItemAt () method
public function addItemAt(item:Object, index:int):void

Adds the item at the specified index. Any item that was after this index is moved out by one. If the list is shorter than the specified index, it will grow to accomodate the new item.

Parameters
item:Object — The item to place at the index.
index:int — The index at which to place the item.

Throws
RangeError — if index is less than 0.
getItemAt () method
public function getItemAt(index:int, prefetch:int = 0):Object

Gets the item at the specified index.

Parameters
index:int — The index in the list from which to retrieve the item.
prefetch:int (default = 0) — An int indicating both the direction and number of items to fetch during the request if the item is not local.

Returns
Object — The item at that index, or null if there is none.

Throws
ItemPendingError — if the data for that index needs to be loaded from a remote location.
RangeError — if index < 0 or index >= length.
getItemIndex () method
public function getItemIndex(item:Object):int

Returns the index of the item if it is in the list such that getItemAt(index) == item.

Note: unlike IViewCursor.findxxx() methods, The getItemIndex() method cannot take a parameter with only a subset of the fields in the item being serched for; this method always searches for an item that exactly matches the input parameter.

Parameters
item:Object — The item to find.

Returns
int — The index of the item, or -1 if the item is not in the list.
itemUpdated () method
public function itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void

Notifies the view that an item has been updated. This is useful if the contents of the view do not implement IEventDispatcher and dispatches a PropertyChangeEvent. If a property is specified the view may be able to optimize its notification mechanism. Otherwise it may choose to simply refresh the whole view.

Parameters
item:Object — The item within the view that was updated.
property:Object (default = null) — The name of the property that was updated.
oldValue:Object (default = null) — The old value of that property. (If property was null, this can be the old value of the item.)
newValue:Object (default = null) — The new value of that property. (If property was null, there's no need to specify this as the item is assumed to be the new value.)

See also

mx.events.CollectionEvent
mx.events.PropertyChangeEvent
removeAll () method
public function removeAll():void

Removes all items from the list.

If any item is not local and an asynchronous operation must be performed, an ItemPendingError will be thrown.

See the ItemPendingError documentation as well as the collections documentation for more information on using the ItemPendingError.

removeItemAt () method
public function removeItemAt(index:int):Object

Removes the item at the specified index and returns it. Any items that were after this index are now one index earlier.

Parameters
index:int — The index from which to remove the item.

Returns
Object — The item that was removed.

Throws
RangeError — is index is less than 0 or greater than length.
setItemAt () method
public function setItemAt(item:Object, index:int):Object

Places the item at the specified index. If an item was already at that index the new item will replace it and it will be returned.

Parameters
item:Object — The new item to be placed at the specified index.
index:int — index The index at which to place the item.

Returns
Object — The item that was replaced, or null if none.

Throws
RangeError — if index is less than 0 or greater than length.
toArray () method
public function toArray():Array

Returns an Array that is populated in the same order as the IList implementation. This method may throw an ItemPendingError.

Returns
Array

Throws
ItemPendingError — if the data is not yet completely loaded from a remote location.
Event detail
collectionChange event
Event object type: mx.events.CollectionEvent
CollectionEvent.type property = mx.events.CollectionEvent.COLLECTION_CHANGE

Dispatched when the IList has been updated in some way.

The CollectionEvent.COLLECTION_CHANGE constant defines the value of the type property of the event object for an event that is dispatched when a collection has changed.

The properties of the event object have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
items | An Array of objects with information about the items affected by the event. The contents of this field depend on the event kind; for details see the items property
kind | The kind of event. The valid values are defined in the CollectionEventKind class as constants.
location | Location within the target collection of the item(s) specified in the items property.
oldLocation | the previous location in the collection of the item specified in the items property.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | CollectionEvent.COLLECTION_CHANGE


mx.collections.ItemResponder (Flex™ 2 Language Reference)

Class ItemResponder | Properties | Methods
Package | mx.collections
Class | public class ItemResponder
Inheritance | ItemResponder Inheritance Object
Implements | IResponder

The ItemResponder class provides a default implementation of the mx.rpc.IResponder interface. It represents a responder that lets you specify methods to be called when a request is completed, either successfully or with an error. The class object can also lets you provide data (a token) to be used by the responder methods.

You use an ItemResponder object in the catch statement of a try block that might result in getting remote data, as shown in the following code:

     import mx.collections.ItemResponder;
     //...
      try
     {
        //...
        cursor.moveNext();
     }
    catch(e:ItemPendingError)
     {
        e.addResponder(new ItemResponder(myResultFunction, myFaultFunction, {info:"..."}));
     }

The result method specified must have the following signature:

     public function myResultFunction(result:Object, token:Object=null):void;

The fault method specified must have the following signature:

     public function myFaultFunction(error:Object, token:Object=null):void;

Any other signature will result in a runtime error.

See also

mx.collections.errors.ItemPendingError

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ItemResponder(result:Function, fault:Function, token:Object = null) Constructs an instance of the responder with the specified data and handlers. | ItemResponder
 | fault(info:Object):void This method is called by a service when an error has been received. | ItemResponder
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | result(data:Object):void This method is called by a service when the return value has been received. | ItemResponder
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
ItemResponder () constructor
public function ItemResponder(result:Function, fault:Function, token:Object = null)

Constructs an instance of the responder with the specified data and handlers.

Parameters
result:Function — Function that should be called when the request has completed successfully. Must have the following signature:
            public function (result:Object, token:Object=null):void;
fault:Function — Function that should be called when the request has completed with errors. Must have the following signature:
            public function (error:ErrorMessage, token:Object=null):void;
token:Object (default = null) — Object [optional] additional information to associate with this request. This object is passed to the result and fault functions as their second parameter.
Method detail
fault () method
public function fault(info:Object):void

This method is called by a service when an error has been received.

Parameters
info:Object — Object containing the information about the error that occured.
result () method
public function result(data:Object):void

This method is called by a service when the return value has been received.

Parameters
data:Object — Object containing the information returned from the request.


mx.collections.IViewCursor (Flex™ 2 Language Reference)

Interface IViewCursor | Properties | Methods | Events
Package | mx.collections
Interface | public interface IViewCursor extends IEventDispatcher

Defines the interface for enumerating a collection view bi-directionally. This cursor provides find, seek, and bookmarking capabilities along with the modification methods insert and remove. When a cursor is first retrieved from a view, (typically by the ICollectionView createCursor() method) the value of the current property should be the first item in the view, unless the view is empty.

See also

Using Data Providers and Collections

Public Properties
Property |  | Defined by
 | afterLast : Boolean [read-only] If the cursor is located after the last item in the view, this property is true . | IViewCursor
 | beforeFirst : Boolean [read-only] If the current is locatedbefore the first item in the view. | IViewCursor
 | bookmark : CursorBookmark [read-only] Provides access to a bookmark that corresponds to the item returned by the current property. | IViewCursor
 | current : Object [read-only] Provides access the object at the location in the source collection referenced by this cursor. | IViewCursor
 | view : ICollectionView [read-only] A reference to the ICollectionView with which this cursor is associated. | IViewCursor
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
findAny(values:Object):Boolean
Finds an item with the specified properties within the collection and positions the cursor to that item.
IViewCursor
findFirst(values:Object):Boolean
Finds the first item with the specified properties within the collection and positions the cursor to that item.
IViewCursor
findLast(values:Object):Boolean
Finds the last item with the specified properties within the collection and positions the cursor on that item.
IViewCursor
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
insert(item:Object):void
Inserts the specified item before the cursor's current position.
IViewCursor
moveNext():Boolean
Moves the cursor to the next item within the collection.
IViewCursor
movePrevious():Boolean
Moves the cursor to the previous item within the collection.
IViewCursor
remove():Object
Removes the current item and returns it.
IViewCursor
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
seek(bookmark:CursorBookmark, offset:int = 0, prefetch:int = 0):void
Moves the cursor to a location at an offset from the specified bookmark.
IViewCursor
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Events
Event |  | Summary | Defined by
 | cursorUpdate | Dispatched whenever the cursor position is updated. | IViewCursor
Property detail
afterLast property
afterLast:Boolean [read-only]

If the cursor is located after the last item in the view, this property is true . If the ICollectionView is empty (length == 0), this property is true.

This property can be used as the source for data binding.

Implementation
    public function get afterLast():Boolean
beforeFirst property
beforeFirst:Boolean [read-only]

If the current is locatedbefore the first item in the view. this property is true . If the ICollectionView is empty (length == 0), this property is true.

This property can be used as the source for data binding.

Implementation
    public function get beforeFirst():Boolean
bookmark property
bookmark:CursorBookmark [read-only]

Provides access to a bookmark that corresponds to the item returned by the current property. The bookmark can be used to move the cursor to a previously visited item, or to a position relative to that item. (See the seek() method for more information.)

This property can be used as the source for data binding.

Implementation
    public function get bookmark():CursorBookmark

See also

current
seek()
current property
current:Object [read-only]

Provides access the object at the location in the source collection referenced by this cursor. If the cursor is beyond the ends of the collection (beforeFirst, afterLast) this will return null.

This property can be used as the source for data binding.

Implementation
    public function get current():Object

See also

moveNext()
movePrevious()
seek()
beforeFirst
afterLast
view property
view:ICollectionView [read-only]

A reference to the ICollectionView with which this cursor is associated.

Implementation
    public function get view():ICollectionView
Method detail
findAny () method
public function findAny(values:Object):Boolean

Finds an item with the specified properties within the collection and positions the cursor to that item. If the item can not be found, the cursor location does not change.

The findAny() method can only be called on sorted views; if the view isn't sorted, a CursorError is thrown.

If the associated collection is remote, and not all of the items have been cached locally, this method begins an asynchronous fetch from the remote collection. If one is already in progress, this method waits for it to complete before making another fetch request.

If multiple items can match the search criteria then the item found is non-deterministic. If it is important to find the first or last occurrence of an item in a non-unique index, use the findFirst() or findLast() method.

The values in the parameter must be configured as name-value pairs, as in an associative array (or be the actual object to search for). The values of the names specified must match properties specified in the sort. For example, if properties x, y, and z are in the current sort, the values specified should be {x: x-value, y: y-value, z: z-value}.

When all of the data is local this method returns true if the item can be found and false otherwise. If the data is not local and an asynchronous operation must be performed, an ItemPendingError is thrown.

Parameters
values:Object

Returns
Boolean

See also

findFirst()
findLast()
mx.collections.errors.ItemPendingError
findFirst () method
public function findFirst(values:Object):Boolean

Finds the first item with the specified properties within the collection and positions the cursor to that item. If the item can not be found, no cursor location does not change.

The findFirst() method can only be called on sorted views; if the view isn't sorted, a CursorError is thrown.

If the associated collection is remote, and not all of the items have been cached locally, this method begins an asynchronous fetch from the remote collection. If one is already in progress, this method waits for it to complete before making another fetch request.

If it is not important to find the first occurrence of an item in a non-unique index, use findAny(), which may be a little faster than the findFirst() method.

The values specified must be configured as name-value pairs, as in an associative array (or be the actual object to search for). The values of the names specified must match properties specified in the sort. For example, if properties x, y, and z are in the current sort, the values specified should be {x: x-value, y: y-value, z: z-value}.

When all of the data is local this method returns true if the item can be found and false otherwise. If the data is not local and an asynchronous operation must be performed, an ItemPendingError is thrown.

Parameters
values:Object

Returns
Boolean

See also

findAny()
findLast()
mx.collections.errors.ItemPendingError
findLast () method
public function findLast(values:Object):Boolean

Finds the last item with the specified properties within the collection and positions the cursor on that item. If the item can not be found, the cursor location does not chanage.

The findLast() method can only be called on sorted views; if the view isn't sorted, a CursorError is thrown.

If the associated collection is remote, and not all of the items have been cached locally, this method begins an asynchronous fetch from the remote collection. If one is already in progress, this method waits for it to complete before making another fetch request.

If it is not important to find the last occurrence of an item in a non-unique index, use the findAny() method, which may be a little faster.

The values specified must be configured as name-value pairs, as in an associative array (or be the actual object to search for). The values of the names specified must match properties specified in the sort. For example, if properties x, y, and z are in the current sort, the values specified should be {x: x-value, y: y-value, z: z-value}.

When all of the data is local this method returns true if the item can be found and false otherwise. If the data is not local and an asynchronous operation must be performed, an ItemPendingError is thrown.

Parameters
values:Object

Returns
Boolean

See also

findAny()
findFirst()
mx.collections.errors.ItemPendingError
insert () method
public function insert(item:Object):void

Inserts the specified item before the cursor's current position. If the cursor is afterLast, the insertion occurs at the end of the view. If the cursor is beforeFirst on a non-empty view, an error is thrown.

Parameters
item:Object
moveNext () method
public function moveNext():Boolean

Moves the cursor to the next item within the collection. On success the current property is updated to reference the object at this new location. Returns true if the resulting current property is valid, or false if not (the property value is afterLast).

If the data is not local and an asynchronous operation must be performed, an ItemPendingError is thrown. See the ItemPendingError documentation and the collections documentation for more information on using the ItemPendingError.

Returns
Boolean — true if still in the list, false if the current value initially was or now is afterLast.

See also

current
movePrevious()
mx.collections.errors.ItemPendingError

Example
      var myArrayCollection:ICollectionView = new ArrayCollection([ "Bobby", "Mark", "Trevor", "Jacey", "Tyler" ]);
      var cursor:IViewCursor = myArrayCollection.createCursor();
      while (!cursor.afterLast)
      {
          trace(cursor.current);
          cursor.moveNext();
      }

movePrevious () method
public function movePrevious():Boolean

Moves the cursor to the previous item within the collection. On success the current property is updated to reference the object at this new location. Returns true if the resulting current property is valid, or false if not (the property value is beforeFirst).

If the data is not local and an asynchronous operation must be performed, an ItemPendingError is thrown. See the ItemPendingError documentation and the collections documentation for more information on using the ItemPendingError.

Returns
Boolean — true if still in the list, false if the current value initially was or now is beforeFirst.

See also

current
moveNext()
mx.collections.errors.ItemPendingError

Example
      var myArrayCollection:ICollectionView = new ArrayCollection([ "Bobby", "Mark", "Trevor", "Jacey", "Tyler" ]);
      var cursor:ICursor = myArrayCollection.createCursor();
      cursor.seek(CursorBookmark.last);
      while (!cursor.beforeFirst)
      {
          trace(current);
          cursor.movePrevious();
      }

remove () method
public function remove():Object

Removes the current item and returns it. If the cursor location is beforeFirst or afterLast, throws a CursorError. If you remove any item other than the last item, the cursor moves to the next item. If you remove the last item, the cursor is at the AFTER_LAST bookmark.

If the item after the removed item is not local and an asynchronous operation must be performed, an ItemPendingError is thrown. See the ItemPendingError documentation and the collections documentation for more information on using the ItemPendingError.

Returns
Object

See also

mx.collections.errors.ItemPendingError
seek () method
public function seek(bookmark:CursorBookmark, offset:int = 0, prefetch:int = 0):void

Moves the cursor to a location at an offset from the specified bookmark. The offset can be negative, in which case the cursor is positioned an offset number of items prior to the specified bookmark.

If the associated collection is remote, and not all of the items have been cached locally, this method begins an asynchronous fetch from the remote collection.

If the data is not local and an asynchronous operation must be performed, an ItemPendingError is thrown. See the ItemPendingError documentation and the collections documentation for more information on using the ItemPendingError.

Parameters
bookmark:CursorBookmark — CursorBookmark reference to marker information that allows repositioning to a specific location. You can set this parameter to value returned from the bookmark property, or to one of the following constant bookmark values:
  • CursorBookmark.FIRST - Seek from the start (first element) of the collection
  • CursorBookmark.CURRENT - Seek from the current position in the collection
  • CursorBookmark.LAST - Seek from the end (last element) of the collection
offset:int (default = 0) — Indicates how far from the specified bookmark to seek. If the specified number is negative, the cursor attempts to move prior to the specified bookmark. If the offset specified is beyond the end of the collection, the cursor is be positioned off the end, to the beforeFirst or afterLast location.
prefetch:int (default = 0) — Used for remote data. Indicates an intent to iterate in a specific direction once the seek operation completes. This reduces the number of required network round trips during a seek. If the iteration direction is known at the time of the request, the appropriate amount of data can be returned ahead of the request to iterate it.

See also

mx.collections.errors.ItemPendingError
Event detail
cursorUpdate event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.CURSOR_UPDATE

Dispatched whenever the cursor position is updated.

The FlexEvent.CURSOR_UPDATE constant defines the value of the type property of the event object for a cursorUpdate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.collections.ListCollectionView (Flex™ 2 Language Reference)

Class ListCollectionView | Properties | Methods | Events
Package | mx.collections
Class | public class ListCollectionView
Inheritance | ListCollectionView Inheritance Proxy Inheritance Object
Implements | ICollectionView, IList, IMXMLObject
Subclasses | ArrayCollection, XMLListCollection

The ListCollectionView class adds the properties and methods of the ICollectionView interface to an object that conforms to the IList interface. As a result, you can pass an object of this class to anything that requires an IList or ICollectionView.

This class also lets you use [ ] array notation to access the getItemAt() and setItemAt() methods. If you use code such as myListCollectionView[index] Flex calls the myListCollectionView object's getItemAt() or setItemAt() method.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ListCollectionView> has the following attributes, which all of its subclasses inherit:

  <mx:ListCollectionView
  Properties
  filterFunction="null"
  list="null"
  sort="null"

  Events
  collectionChange="No default"
  />

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | filterFunction : Function A function that the view will use to eliminate items that do not match the function's criteria. | ListCollectionView
 | length : int [read-only] The number of items in this view. | ListCollectionView
 | list : IList The IList that this collection view wraps. | ListCollectionView
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | sort : Sort The Sort that will be applied to the ICollectionView. | ListCollectionView
Protected Properties
Property |  | Defined by
 | localIndex : Array When the view is sorted or filtered the localIndex property contains an array of items in the sorted or filtered (ordered, reduced) view, in the sorted ordder. | ListCollectionView
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ListCollectionView(list:IList = null)
The ListCollectionView constructor.
ListCollectionView
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
ListCollectionView
addItem(item:Object):void
Adds the specified item to the end of the list.
ListCollectionView
addItemAt(item:Object, index:int):void
Adds the item at the specified index.
ListCollectionView
contains(item:Object):Boolean
Returns whether the view contains the specified object.
ListCollectionView
createCursor():IViewCursor
Creates a new IViewCursor that works with this view.
ListCollectionView
disableAutoUpdate():void
Prevents changes to the collection itself and items within the collection from being dispatched by the view.
ListCollectionView
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
ListCollectionView
enableAutoUpdate():void
Enables auto-updating.
ListCollectionView
getItemAt(index:int, prefetch:int = 0):Object
Gets the item at the specified index.
ListCollectionView
getItemIndex(item:Object):int
Returns the index of the item if it is in the list such that getItemAt(index) == item.
ListCollectionView
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
ListCollectionView
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the ListCollectionView is created using an MXML tag.
ListCollectionView
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void
Notifies the view that an item has been updated.
ListCollectionView
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
refresh():Boolean
Applies the sort and filter to the view.
ListCollectionView
removeAll():void
Remove all items from the list.
ListCollectionView
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
ListCollectionView
removeItemAt(index:int):Object
Removes the item at the specified index and returns it.
ListCollectionView
setItemAt(item:Object, index:int):Object
Places the item at the specified index.
ListCollectionView
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
toArray():Array
Returns an Array that is populated in the same order as the IList implementation.
ListCollectionView
toString():String
Pretty prints the contents of this view to a string and returns it.
ListCollectionView
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
ListCollectionView
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Event |  | Summary | Defined by
 | collectionChange | Dispatched when the ICollectionView has been updated in some way. | ListCollectionView
Property detail
filterFunction property
filterFunction:Function [read-write]

A function that the view will use to eliminate items that do not match the function's criteria. A filterFunction is expected to have the following signature:

f(item:Object):Boolean
where the return value is true if the specified item should remain in the view.

If a filter is unsupported, Flex throws an error when accessing this property. You must call refresh() after setting the filterFunction property for the view to update.

Note: The Flex implementations of ICollectionView retrieve all items from a remote location before executing the filter function. If you use paging, apply the filter to the remote collection before you retrieve the data.

This property can be used as the source for data binding.

Implementation
    public function get filterFunction():Function
    public function set filterFunction(value:Function):void

See also

refresh()
length property
length:int [read-only]

The number of items in this view. 0 means no items, while -1 means that the length is unknown.

This property can be used as the source for data binding.

Implementation
    public function get length():int
list property
list:IList [read-write]

The IList that this collection view wraps.

This property can be used as the source for data binding.

Implementation
    public function get list():IList
    public function set list(value:IList):void
localIndex property
protected var localIndex:Array

When the view is sorted or filtered the localIndex property contains an array of items in the sorted or filtered (ordered, reduced) view, in the sorted ordder. The ListCollectionView class uses this property to access the items in the view. The localIndex property should never contain anything that is not in the source, but may not have everything in the source. This property is null when there is no sort.

sort property
sort:Sort [read-write]

The Sort that will be applied to the ICollectionView. Setting the sort does not automatically refresh the view, so you must call the refresh() method after setting this property. If sort is unsupported an error will be thrown when accessing this property.

Note: The Flex implementations of ICollectionView retrieve all items from a remote location before executing a sort. If you use paging with a sorted list, apply the sort to the remote collection before you retrieve the data.

This property can be used as the source for data binding.

Implementation
    public function get sort():Sort
    public function set sort(value:Sort):void

See also

refresh()
Constructor detail
ListCollectionView () constructor
public function ListCollectionView(list:IList = null)

The ListCollectionView constructor.

Parameters
list:IList (default = null) — the IList this ListCollectionView is meant to wrap.
Method detail
addEventListener () method
public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event. You can register event listeners on all nodes in the display list for a specific type of event, phase, and priority.

After you successfully register an event listener, you cannot change its priority through additional calls to addEventListener(). To change a listener's priority, you must first call removeListener(). Then you can register the listener again with the new priority level.

After the listener is registered, subsequent calls to addEventListener() with a different value for either type or useCapture result in the creation of a separate listener registration. For example, if you first register a listener with useCapture set to true, it listens only during the capture phase. If you call addEventListener() again using the same listener object, but with useCapture set to false, you have two separate listeners: one that listens during the capture phase, and another that listens during the target and bubbling phases.

You cannot register an event listener for only the target phase or the bubbling phase. Those phases are coupled during registration because bubbling applies only to the ancestors of the target node.

When you no longer need an event listener, remove it by calling EventDispatcher.removeEventListener(); otherwise, memory problems might result. Objects with registered event listeners are not automatically removed from memory because the garbage collector does not remove objects that still have references.

Copying an EventDispatcher instance does not copy the event listeners attached to it. (If your newly created node needs an event listener, you must attach the listener after creating the node.) However, if you move an EventDispatcher instance, the event listeners attached to it move along with it.

If the event listener is being registered on a node while an event is also being processed on this node, the event listener is not triggered during the current phase but may be triggered during a later phase in the event flow, such as the bubbling phase.

If an event listener is removed from a node while an event is being processed on the node, it is still triggered by the current actions. After it is removed, the event listener is never invoked again (unless it is registered again for future processing).

Parameters
type:String — The type of event.
listener:Function — The listener function that processes the event. This function must accept an Event object as its only parameter and must return nothing, as this example shows:

function(evt:Event):void

The function can have any name.
useCapture:Boolean (default = false) — Determines whether the listener works in the capture phase or the target and bubbling phases. If useCapture is set to true, the listener processes the event only during the capture phase and not in the target or bubbling phase. If useCapture is false, the listener processes the event only during the target or bubbling phase. To listen for the event in all three phases, call addEventListener() twice, once with useCapture set to true, then again with useCapture set to false.
priority:int (default = 0) — The priority level of the event listener. Priorities are designated by a 32-bit integer. The higher the number, the higher the priority. All listeners with priority n are processed before listeners of priority n-1. If two or more listeners share the same priority, they are processed in the order in which they were added. The default priority is 0.
useWeakReference:Boolean (default = false) — Determines whether the reference to the listener is strong or weak. A strong reference (the default) prevents your listener from being garbage-collected. A weak reference does not.
addItem () method
public function addItem(item:Object):void

Adds the specified item to the end of the list. Equivalent to addItemAt(item, length).

Parameters
item:Object — The item to add.
addItemAt () method
public function addItemAt(item:Object, index:int):void

Adds the item at the specified index. Any item that was after this index is moved out by one. If the list is shorter than the specified index, it will grow to accomodate the new item.

Parameters
item:Object — The item to place at the index.
index:int — The index at which to place the item.
contains () method
public function contains(item:Object):Boolean

Returns whether the view contains the specified object. Unlike the IViewCursor.findxxx methods, this search is succesful only if it finds an item that exactly matches the parameter. If the view has a filter applied to it this method may return false even if the underlying collection does contain the item.

Parameters
item:Object — The object to look for.

Returns
Boolean — true if the ICollectionView, after applying any filter, contains the item; false otherwise.

See also

enableAutoUpdate()
mx.events.CollectionEvent
createCursor () method
public function createCursor():IViewCursor

Creates a new IViewCursor that works with this view.

Returns
IViewCursor — A new IViewCursor implementation.
disableAutoUpdate () method
public function disableAutoUpdate():void

Prevents changes to the collection itself and items within the collection from being dispatched by the view. Also prevents the view from updating the positions of items if the positions change in the collection. The changes will be queued and dispatched appropriately after enableAutoUpdate is called. If more events than updates to a single item occur, the view may end up resetting. The disableAutoUpdate method acts cumulatively; the same number of calls to enableAutoUpdate are required for the view to dispatch events and refresh. Note that disableAutoUpdate only affects the individual view; edits may be detected on an individual basis by other views.

See also

mx.collections.ICollectionView.enableAutoUpdate()
mx.events.CollectionEvent
dispatchEvent () method
public function dispatchEvent(event:Event):Boolean

Dispatches an event into the event flow. The event target is the EventDispatcher object upon which dispatchEvent() is called.

Parameters
event:Event — The Event object dispatched into the event flow.

Returns
Boolean — A value of true unless preventDefault() is called on the event, in which case it returns false.
enableAutoUpdate () method
public function enableAutoUpdate():void

Enables auto-updating. See disableAutoUpdate for more information.

See also

mx.collections.ICollectionView.disableAutoUpdate()
getItemAt () method
public function getItemAt(index:int, prefetch:int = 0):Object

Gets the item at the specified index.

Parameters
index:int — The index in the list from which to retrieve the item.
prefetch:int (default = 0) — An int indicating both the direction and number of items to fetch during the request if the item is not local.

Returns
Object — The item at that index, or null if there is none.
getItemIndex () method
public function getItemIndex(item:Object):int

Returns the index of the item if it is in the list such that getItemAt(index) == item.

Note: unlike IViewCursor.findxxx() methods, The getItemIndex() method cannot take a parameter with only a subset of the fields in the item being serched for; this method always searches for an item that exactly matches the input parameter.

Parameters
item:Object — The item to find.

Returns
int — The index of the item, or -1 if the item is not in the list.
hasEventListener () method
public function hasEventListener(type:String):Boolean

Checks whether the EventDispatcher object has any listeners registered for a specific type of event. This allows you to determine where an EventDispatcher object has altered handling of an event type in the event flow hierarchy. To determine whether a specific event type will actually trigger an event listener, use IEventDispatcher.willTrigger().

The difference between hasEventListener() and willTrigger() is that hasEventListener() examines only the object to which it belongs, whereas willTrigger() examines the entire event flow for the event specified by the type parameter.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type is registered; false otherwise.
initialized () method
public function initialized(document:Object, id:String):void

Called automatically by the MXML compiler when the ListCollectionView is created using an MXML tag. If you create the ListCollectionView through ActionScript, you must call this method passing in the MXML document and null for the id.

Parameters
document:Object — The MXML document containing this ListCollectionView.
id:String — Ignored.
itemUpdated () method
public function itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void

Notifies the view that an item has been updated. This method is useful if the contents of the view do not implement IPropertyChangeNotifier. If the call to this method includes a property parameter, the view may be able to optimize its notification mechanism. Otherwise it may choose to simply refresh the whole view.

Parameters
item:Object — The item within the view that was updated.
property:Object (default = null) — The name of the property that was updated.
oldValue:Object (default = null) — The old value of that property. (If property was null, this can be the old value of the item.).
newValue:Object (default = null) — The new value of that property. (If property was null, there's no need to specify this as the item is assumed to be the new value.)

See also

mx.events.CollectionEvent
mx.core.IPropertyChangeNotifier
mx.events.PropertyChangeEvent
refresh () method
public function refresh():Boolean

Applies the sort and filter to the view. The ICollectionView does not detect changes to a sort or filter automatically, so you must call the refresh() method to update the view after setting the sort or filterFunction property. If your ICollectionView implementation also implements the IMXMLObject interface, you should to call the refresh() method from your initialized() method.

Returns true if the refresh was successful and false if the sort is not yet complete (e.g., items are still pending). A client of the view should wait for a CollectionEvent event with the CollectionEventKind.REFRESH kind property to ensure that the refresh() operation is complete.

Returns
Boolean — true if the refresh() was complete, false if the refresh() is incomplete.
removeAll () method
public function removeAll():void

Remove all items from the list.

removeEventListener () method
public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Removes a listener from the EventDispatcher object. If there is no matching listener registered with the EventDispatcher object, a call to this method has no effect.

Parameters
type:String — The type of event.
listener:Function — The listener object to remove.
useCapture:Boolean (default = false) — Specifies whether the listener was registered for the capture phase or the target and bubbling phases. If the listener was registered for both the capture phase and the target and bubbling phases, two calls to removeEventListener() are required to remove both: one call with useCapture set to true, and another call with useCapture set to false.
removeItemAt () method
public function removeItemAt(index:int):Object

Removes the item at the specified index and returns it. Any items that were after this index are now one index earlier.

Parameters
index:int — The index from which to remove the item.

Returns
Object — The item that was removed.
setItemAt () method
public function setItemAt(item:Object, index:int):Object

Places the item at the specified index. If an item was already at that index the new item will replace it and it will be returned.

Parameters
item:Object — The new item to be placed at the specified index.
index:int — index The index at which to place the item.

Returns
Object — The item that was replaced, or null if none.
toArray () method
public function toArray():Array

Returns an Array that is populated in the same order as the IList implementation. This method may throw an ItemPendingError.

Returns
Array
toString () method
public function toString():String

Pretty prints the contents of this view to a string and returns it.

Returns
String
willTrigger () method
public function willTrigger(type:String):Boolean

Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type. This method returns true if an event listener is triggered during any phase of the event flow when an event of the specified type is dispatched to this EventDispatcher object or any of its descendants.

The difference between hasEventListener() and willTrigger() is that hasEventListener() examines only the object to which it belongs, whereas willTrigger() examines the entire event flow for the event specified by the type parameter.

Parameters
type:String — The type of event.

Returns
Boolean — A value of true if a listener of the specified type will be triggered; false otherwise.
Event detail
collectionChange event
Event object type: mx.events.CollectionEvent
CollectionEvent.type property = mx.events.CollectionEvent.COLLECTION_CHANGE

Dispatched when the ICollectionView has been updated in some way.

The CollectionEvent.COLLECTION_CHANGE constant defines the value of the type property of the event object for an event that is dispatched when a collection has changed.

The properties of the event object have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
items | An Array of objects with information about the items affected by the event. The contents of this field depend on the event kind; for details see the items property
kind | The kind of event. The valid values are defined in the CollectionEventKind class as constants.
location | Location within the target collection of the item(s) specified in the items property.
oldLocation | the previous location in the collection of the item specified in the items property.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | CollectionEvent.COLLECTION_CHANGE


mx.collections.Sort (Flex™ 2 Language Reference)

Class Sort | Properties | Methods | Constants
Package | mx.collections
Class | public class Sort
Inheritance | Sort Inheritance EventDispatcher Inheritance Object

Provides the sorting information required to establish a sort on an existing view (ICollectionView interface or class that implements the interface). After you assign a Sort instance to the view's sort property, you must call the view's refresh() method to apply the sort criteria. Typically the sort is defined for collections of complex items, that is collections in which the sort is performed on one or more properties of the objects in the collection. The following example shows this use:

     var col:ICollectionView = new ArrayCollection();
     // In the real world, the collection would have more than one item.
     col.addItem({first:"Anders", last:"Dickerson"});
     // Create the Sort instance.
     var sort:Sort = new Sort();
     // Set the sort field; sort on the last name first, first name second.
     // Both fields are case-insensitive.
     sort.fields = [new SortField("last", true), new SortField("first", true];
       // Assign the Sort object to the view.
     col.sort = sort;
     // Apply the sort to the collection.
       col.refresh();

There are situations in which the collection contains simple items, like String, Date, Boolean, etc. In this case, apply the sort to the simple type directly. When constructing a sort for simple items, use a single sort field, and specify a null name (first) parameter in the SortField object constructor. For example:

     var col:ICollectionView = new ArrayCollection();
     col.addItem("California");
     col.addItem("Arizona");
     var sort:Sort = new Sort();
     // There is only one sort field, so use a null first parameter.
     sort.fields = [new SortField(null, true)];
     col.sort = sort;
       col.refresh();

The Flex implementations of the ICollectionView interface retrieve all items from a remote location before executing a sort. If you use paging with a sorted list, apply the sort to the remote collection before you retrieve the data.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Sort> tag has the following attributes:

  <mx:Sort
  Properties
  compareFunction="Internal compare function"
  fields="null"
  unique="flase"
  />

Default MXML Property fields

See also

mx.collections.ICollectionView
Using Data Providers and Collections

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | compareFunction : Function The method used to compare items when sorting. | Sort
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | fields : Array An Array of SortField objects that specifies the fields to compare. | Sort
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | unique : Boolean Indicates if the sort should be unique. | Sort
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Sort()
Constructor.
Sort
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
findItem(items:Array, values:Object, mode:String, returnInsertionIndex:Boolean = false, compareFunction:Function = null):int
Finds the specified object within the specified array (or the insertion point if asked for), returning the index if found or -1 if not.
Sort
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
propertyAffectsSort(property:String):Boolean
Return whether the specified property is used to control the sort.
Sort
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
reverse():void
Goes through all SortFields and calls reverse() on them.
Sort
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
sort(items:Array):void
Apply the current sort to the specified array (not a copy).
Sort
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Public Constants
Constant |  | Defined by
 | ANY_INDEX_MODE : String = "any" [static] When executing a find return the index any matching item. | Sort
 | FIRST_INDEX_MODE : String = "first" [static] When executing a find return the index for the first matching item. | Sort
 | LAST_INDEX_MODE : String = "last" [static] When executing a find return the index for the last matching item. | Sort
Property detail
compareFunction property
compareFunction:Function [read-write]

The method used to compare items when sorting. If you specify this property, Flex ignores any compareFunction properties that you specify in the SortField objects that you use in this class.

The compare function must have the following signature:

              function [name](a:Object, b:Object, fields:Array=null):int

This function must return the following

  • -1, if a should appear before b in the sorted sequence
  • 0, if a equals b
  • 1, if a should appear after b in the sorted sequence

To return to the internal comparision function set this value to null.

The fields array specified specifies the object fields to compare. Typically the algorithm will compare properties until the field list is exhausted or a non zero value can be returned. For example:

        function myCompare(a:Object, b:Object, fields:Array=null):int
        {
            var result:int = 0;
            var i:int = 0;
            var propList:Array = fields ? fields : internalPropList;
            var len:int = propList.length;
            var propName:String;
            while (result == 0 && (i < len))
            {
                propName = propList[i];
                result = compareValues(a[propName], b[propName]);
                i++;
            }
            return result;
        }
             function compareValues(a:Object, b:Object):int
        {
            if (a == null && b == null)
                return 0;
                 if (a == null)
              return 1;
                 if (b == null)
               return -1;
                 if (a < b)
                return -1;
                 if (a > b)
                return 1;
                 return 0;
        }

The default value is an internal compare function that can perform a string, numeric, or date comparison in ascending or descending order, with case-sensitive or case-insensitive string comparisons. Specify your own function only if you need a need a custom comparison algorithm. This is normally only the case if a calculated field is used in a display.

Alternatively you can specify separate compare functions for each sort field by using the SortField class compare property; This way you can use the default comparison for some fields and a custom comparison for others.

Implementation
    public function get compareFunction():Function
    public function set compareFunction(value:Function):void
fields property
fields:Array [read-write]

An Array of SortField objects that specifies the fields to compare. The order of the SortField objects in the array determines field priority order when sorting. The default sort comparator checks the sort fields in array order until it determinines a sort order for the two fields being compared.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get fields():Array
    public function set fields(value:Array):void

See also

SortField
unique property
unique:Boolean [read-write]

Indicates if the sort should be unique. Unique sorts fail if any value or combined value specified by the fields listed in the fields property result in an indeterminate or non-unique sort order; that is, if two or more items have identical sort field values.

The default value is false.

Implementation
    public function get unique():Boolean
    public function set unique(value:Boolean):void
Constructor detail
Sort () constructor
public function Sort()

Constructor.

Creates a new Sort with no fields set and no custom comparator.

Method detail
findItem () method
public function findItem(items:Array, values:Object, mode:String, returnInsertionIndex:Boolean = false, compareFunction:Function = null):int

Finds the specified object within the specified array (or the insertion point if asked for), returning the index if found or -1 if not. The ListCollectionView class findxxx() methods use this method to find the requested item; as a general rule, it is easier to use these functions, and not findItem() to find data in ListCollectionView-based objects. You call the findItem() method directly when writing a class that supports sorting, such as a new ICollectionView implementation.

Parameters
items:Array — the Array within which to search.
values:Object — Object containing the properties to look for (or the object to search for, itself). The object must consist of field name/value pairs, where the field names are names of fields specified by the SortFields property, in the same order they are used in that property. You do not have to specify all of the fields from the SortFields property, but you cannot skip any in the order. Therefore, if the SortFields properity lists three fields, you can specify its first and second fields in this parameter, but you cannot specify only the first and third fields.
mode:String — String containing the type of find to perform. Valid values are
  • ANY_INDEX_MODE
    • Return any position that is valid for the values.
  • FIRST_INDEX_MODE
    • Return the position where the first occurrance of the values is found.
  • LAST_INDEX_MODE
    • Return the position where the last ocurrance of the specified values is found.
returnInsertionIndex:Boolean (default = false) — If the method does not find an item identified by the values parameter, and this parameter is true the findItem() method returns the insertion point for the values, that is the point in the sorted order where you should insert the item.
compareFunction:Function (default = null) — a comparator function to use to find the item. If you do not specify this parameter, the function uses the function determined by the Sort instance's compareFunction property, passing in the array of fields determined by the values object and the current SortFields.

Returns
int — int The index in the array of the found item. If the returnInsertionIndex parameter is false and the item is not found, returns -1. If the returnInsertionIndex parameter is true and the item is not found, returns the index of the point in the sorted array where the values would be inserted.
propertyAffectsSort () method
public function propertyAffectsSort(property:String):Boolean

Return whether the specified property is used to control the sort. The function cannot determine a definitive answer if the sort uses a custom comparitor; it always returns true in this case.

Parameters
property:String — The name of the field that to test.

Returns
Boolean — Whether the property value might affect the sort outcome. If the sort uses the default compareFunction, returns true if the property parameter specifies a sort field. If the sort or any SortField uses a custom comparator, there's no way to know, so return true.
reverse () method
public function reverse():void

Goes through all SortFields and calls reverse() on them. If the field was descending now it is ascending, and vice versa.

Note: an ICollectionView does not automatically update when the SortFields are modified; call its refresh() method to update the view.

sort () method
public function sort(items:Array):void

Apply the current sort to the specified array (not a copy). To prevent the array from being modified, create a copy use the copy in the items parameter.

Flex ICollectionView implementations call the sort method automatically and ensure that the sort is performed on a copy of the underlying data.

Parameters
items:Array — Array of items to sort.
Constant detail
ANY_INDEX_MODE constant
public static const ANY_INDEX_MODE:String = "any"

When executing a find return the index any matching item.

FIRST_INDEX_MODE constant
public static const FIRST_INDEX_MODE:String = "first"

When executing a find return the index for the first matching item.

LAST_INDEX_MODE constant
public static const LAST_INDEX_MODE:String = "last"

When executing a find return the index for the last matching item.


mx.collections.SortField (Flex™ 2 Language Reference)

Class SortField | Properties | Methods
Package | mx.collections
Class | public class SortField
Inheritance | SortField Inheritance EventDispatcher Inheritance Object

Provides the sorting information required to establish a sort on a field or property in an existing view. Typically the sort is defined for collections of complex items, that is items in which the sort is performed on properties of those objects. As in the following example:

     var col:ICollectionView = new ArrayCollection();
     col.addItem({first:"Anders", last:"Dickerson"});
     var sort:Sort = new Sort();
     sort.fields = [new SortField("first", true)];
     col.sort = sort;
There are situations in which the collection contains simple items, like String, Date, Boolean, etc. In this case, sorting should be applied to the simple type directly. When constructing a sort for this situation only a single sort field is required and should not have a name specified. For example:

     var col:ICollectionView = new ArrayCollection();
     col.addItem("California");
     col.addItem("Arizona");
     var sort:Sort = new Sort();
     sort.fields = [new SortField(null, true)];
     col.sort = sort;

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SortField> tag has the following attributes:

  <mx:SortField
  Properties
  caseInsensitive="false"
  compareFunction="Internal compare function"
  descending="false"
  name="null"
  numeric="false"
  />

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | caseInsensitive : Boolean Specifies whether the sort for this field should be case insensitive. | SortField
 | compareFunction : Function The function that compares two items during a sort of items for the associated collection. | SortField
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | descending : Boolean Specifies whether the this field should be sorted in descending order. | SortField
 | name : String The name of the field to be sorted. | SortField
 | numeric : Boolean Specifies that if the field being sorted contains numeric (number/int/uint) values, or string representations of numeric values, the comparitor use a numeric comparison. | SortField
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SortField(name:String = null, caseInsensitive:Boolean = false, descending:Boolean = false, numeric:Boolean = false)
Constructor.
SortField
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
reverse():void
Reverse the criteria for this sort field.
SortField
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
caseInsensitive property
caseInsensitive:Boolean [read-write]

Specifies whether the sort for this field should be case insensitive.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get caseInsensitive():Boolean
    public function set caseInsensitive(value:Boolean):void
compareFunction property
compareFunction:Function [read-write]

The function that compares two items during a sort of items for the associated collection. If you specify a compareFunction property in a Sort object, Flex ignores any compareFunction properties of the Sort's SortField objects.

The compare function must have the following signature:

function myCompare(a:Object, b:Object):int

This function must return the following values:

  • -1, if a should appear before b in the sorted sequence
  • 0, if a equals b
  • 1, if a should appear after b in the sorted sequence

The default value is an internal compare function that can perform a string, numeric, or date comparison in ascending or descending order, with case-sensitive or case-insensitive string comparisons. Specify your own function only if you need a need a custom comparison algorithm. This is normally only the case if a calculated field is used in a display.

Implementation
    public function get compareFunction():Function
    public function set compareFunction(value:Function):void
descending property
descending:Boolean [read-write]

Specifies whether the this field should be sorted in descending order.

The default value is false (ascending).

This property can be used as the source for data binding.

Implementation
    public function get descending():Boolean
    public function set descending(value:Boolean):void
name property
name:String [read-write]

The name of the field to be sorted.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get name():String
    public function set name(value:String):void
numeric property
numeric:Boolean [read-write]

Specifies that if the field being sorted contains numeric (number/int/uint) values, or string representations of numeric values, the comparitor use a numeric comparison. If this property is false, fields with string representations of numbers are sorted using strings comparison, so 100 precedes 99, because "1" is a lower string value than "9".

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get numeric():Boolean
    public function set numeric(value:Boolean):void
Constructor detail
SortField () constructor
public function SortField(name:String = null, caseInsensitive:Boolean = false, descending:Boolean = false, numeric:Boolean = false)

Constructor.

Parameters
name:String (default = null) — The name of the property that this field uses for comparison. If the object is a simple type, pass null.
caseInsensitive:Boolean (default = false) — When sorting strings, tells the comparitor whether to ignore the case of the values.
descending:Boolean (default = false) — Tells the comparator whether to arrange items in descending order.
numeric:Boolean (default = false) — Tells the comparitor whether to compare sort items as numbers, instead of alphabetically.
Method detail
reverse () method
public function reverse():void

Reverse the criteria for this sort field. If the field was sorted in descending order, for example, sort it in ascending order.

Note: an ICollectionView does not automatically update when the SortFields are modified; call its refresh() method to update the view.


mx.collections.XMLListCollection (Flex™ 2 Language Reference)

Class XMLListCollection | Properties | Methods | Events
Package | mx.collections
Class | public class XMLListCollection
Inheritance | XMLListCollection Inheritance ListCollectionView Inheritance Proxy Inheritance Object

The XMLListCollection class provides collection functionality to an XMLList object and makes available some of the methods of the native XMLList class.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:XMLListCollection> tag inherits all the attributes of its superclass, and adds the following attributes:

  <mx:XMLListCollection
  Properties
  source="null"
  />

Default MXML Property source

See also

XMLList
XML
Using Data Providers and Collections

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filterFunction : Function A function that the view will use to eliminate items that do not match the function's criteria. | ListCollectionView
Inherited | length : int The number of items in this view. | ListCollectionView
Inherited | list : IList The IList that this collection view wraps. | ListCollectionView
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | sort : Sort The Sort that will be applied to the ICollectionView. | ListCollectionView
 | source : XMLList The underlying XMLList for this collection. | XMLListCollection
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | localIndex : Array When the view is sorted or filtered the localIndex property contains an array of items in the sorted or filtered (ordered, reduced) view, in the sorted ordder. | ListCollectionView
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
XMLListCollection(source:XMLList = null)
Constructor.
XMLListCollection
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
ListCollectionView
Inherited
addItem(item:Object):void
Adds the specified item to the end of the list.
ListCollectionView
Inherited
addItemAt(item:Object, index:int):void
Adds the item at the specified index.
ListCollectionView
attribute(attributeName:Object):XMLList
Calls the attribute() method of each XML object in the XMLList and returns an XMLList of the results, which match the given attributeName.
XMLListCollection
attributes():XMLList
Calls the attributes() method of each XML object in the XMLList object and returns an XMList of attributes for each XML object.
XMLListCollection
child(propertyName:Object):XMLList
Calls the child() method of each XML object in the XMLList and returns an XMLList containing the children of with the specified property name, in order.
XMLListCollection
children():XMLList
Calls the children() method of each XML object in the XMLList and returns an XMLList containing the results.
XMLListCollection
Inherited
contains(item:Object):Boolean
Returns whether the view contains the specified object.
ListCollectionView
copy():XMLList
Returns a deep copy of the XMLList object.
XMLListCollection
Inherited
createCursor():IViewCursor
Creates a new IViewCursor that works with this view.
ListCollectionView
descendants(name:Object = *):XMLList
Calls the descendants() method of each XML object in the XMLList and returns an XMLList containing the results.
XMLListCollection
Inherited
disableAutoUpdate():void
Prevents changes to the collection itself and items within the collection from being dispatched by the view.
ListCollectionView
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
ListCollectionView
elements(name:String = "*"):XMLList
Calls the elements() method of each XML object in the XMLList.
XMLListCollection
Inherited
enableAutoUpdate():void
Enables auto-updating.
ListCollectionView
Inherited
getItemAt(index:int, prefetch:int = 0):Object
Gets the item at the specified index.
ListCollectionView
Inherited
getItemIndex(item:Object):int
Returns the index of the item if it is in the list such that getItemAt(index) == item.
ListCollectionView
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
ListCollectionView
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the ListCollectionView is created using an MXML tag.
ListCollectionView
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemUpdated(item:Object, property:Object = null, oldValue:Object = null, newValue:Object = null):void
Notifies the view that an item has been updated.
ListCollectionView
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
refresh():Boolean
Applies the sort and filter to the view.
ListCollectionView
Inherited
removeAll():void
Remove all items from the list.
ListCollectionView
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
ListCollectionView
Inherited
removeItemAt(index:int):Object
Removes the item at the specified index and returns it.
ListCollectionView
Inherited
setItemAt(item:Object, index:int):Object
Places the item at the specified index.
ListCollectionView
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
text():XMLList
Calls the text() method of each XML object in the XMLList and returns an XMLList containing the results.
XMLListCollection
Inherited
toArray():Array
Returns an Array that is populated in the same order as the IList implementation.
ListCollectionView
toString():String
Returns a string representation of the XMLList by calling the toString() method for each XML object in the XMLList.
XMLListCollection
toXMLString():String
Returns a string representation of the XMLList by calling the toXMLString() method for each XML object in the XMLList.
XMLListCollection
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
ListCollectionView
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | collectionChange | Dispatched when the ICollectionView has been updated in some way. | ListCollectionView
Property detail
source property
source:XMLList [read-write]

The underlying XMLList for this collection. The XMLListCollection object does not represent any changes that you make directly to the source XMLList object. Always use the XMLListCollection methods to modify the collection.

This property can be used as the source for data binding.

Implementation
    public function get source():XMLList
    public function set source(value:XMLList):void
Constructor detail
XMLListCollection () constructor
public function XMLListCollection(source:XMLList = null)

Constructor.

Creates a new XMLListCollection object using the specified XMLList object.

Parameters
source:XMLList (default = null) — The XMLList object containing the data to be represented by the XMLListCollection object.
Method detail
attribute () method
public function attribute(attributeName:Object):XMLList

Calls the attribute() method of each XML object in the XMLList and returns an XMLList of the results, which match the given attributeName.

Parameters
attributeName:Object — The attribute that you want to match in the XML objects of the XMLList.

Returns
XMLList — The XMLList of matching XML objects.

See also

XML.attribute()
attributes () method
public function attributes():XMLList

Calls the attributes() method of each XML object in the XMLList object and returns an XMList of attributes for each XML object.

Returns
XMLList — The XMLList containing the resulting XML objects, listing the attributes.

See also

XML.attributes()
child () method
public function child(propertyName:Object):XMLList

Calls the child() method of each XML object in the XMLList and returns an XMLList containing the children of with the specified property name, in order.

Parameters
propertyName:Object — The propery to match.

Returns
XMLList — An XMLList of matching children of the XML objects in the original XMLList.

See also

XML.child()
children () method
public function children():XMLList

Calls the children() method of each XML object in the XMLList and returns an XMLList containing the results.

Returns
XMLList — An XMLList of children of the XML objects in the original XMLList.

See also

XML.children()
copy () method
public function copy():XMLList

Returns a deep copy of the XMLList object.

Returns
XMLList — The copy of the XMLList object.
descendants () method
public function descendants(name:Object = *):XMLList

Calls the descendants() method of each XML object in the XMLList and returns an XMLList containing the results. The name parameter is passed to the XML object's descendants() method. If you do not specify a parameter, the string " is passed to the descendants() method.

Parameters
name:Object (default = *) — The name of the elements to match.

Returns
XMLList — XMLList of the matching descendents (children, grandchildren, etc.) of the XML objects in the original XMLList.

See also

XML.descendants()
elements () method
public function elements(name:String = "*"):XMLList

Calls the elements() method of each XML object in the XMLList. The name parameter is passed to the XML object's elements() method. If you do not specify a parameter, the string " is passed to the elements() method.

Parameters
name:String (default = "*") — The name of the elements to match.

Returns
XMLList — XMLList of the matching child elements of the XML objects in the original XMLList.

See also

XML.elements()
text () method
public function text():XMLList

Calls the text() method of each XML object in the XMLList and returns an XMLList containing the results.

Returns
XMLList

See also

XML.text()
toString () method
public override function toString():String

Returns a string representation of the XMLList by calling the toString() method for each XML object in the XMLList. If the prettyPrinting property of the XML class is set to true, then the results for each XML object in the XMLList are separated by the return character. Otherwise, if prettyPrinting is set to false, then the results are simply concatenated, without separating return characters.

The toString() method strips out the following in the returned string for an XML object that has simple content: the start tag, attributes, namespace declarations, and the end tag. Use the toXMLString() method if you want to preserve these in the returned string for XML objects with simple content.

Returns
String

See also

XML.prettyPrinting
toXMLString () method
public function toXMLString():String

Returns a string representation of the XMLList by calling the toXMLString() method for each XML object in the XMLList. If the prettyPrinting property of the XML class is set to true, then the results for each XML object in the XMLList are separated by the return character. Otherwise, if prettyPrinting is set to false, then the results are concatenated, without separating return characters.

The toXMLString() method preserves the following in the returned string for an XML object that has simple content: the start tag, attributes, namespace declarations, and the end tag. Use the toString() method if you want to strip these from the returned string for XML objects with simple content.

Returns
String — The string representation of the XMLList.

See also

XML.prettyPrinting


mx.collections.errors Summary (Flex™ 2 Language Reference)

Package mx.collections.errors | Classes

The mx.collections.errors package contains the error classes for the Flex collection components.

Classes
Class | Description
CollectionViewError | The CollectionViewError class represents general errors within a collection that are not related to specific activities such as Cursor seeking.
CursorError | This error is thrown by a collection Cursor.
ItemPendingError | This error is thrown when retrieving an item from a collection view requires an asynchronous call.
SortError | This error is thrown when a Sort class is not configured properly; for example, if the find criteria are invalid.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.collections.errors.CollectionViewError (Flex™ 2 Language Reference)

Class CollectionViewError | Properties | Methods
Package | mx.collections.errors
Class | public class CollectionViewError
Inheritance | CollectionViewError Inheritance Error Inheritance Object

The CollectionViewError class represents general errors within a collection that are not related to specific activities such as Cursor seeking. Errors of this class are thrown by the ListCollectionView class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CollectionViewError(message:String) Constructor. | CollectionViewError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
CollectionViewError () constructor
public function CollectionViewError(message:String)

Constructor.

Parameters
message:String — A message providing information about the error cause.


mx.collections.errors.CursorError (Flex™ 2 Language Reference)

Class CursorError | Properties | Methods
Package | mx.collections.errors
Class | public class CursorError
Inheritance | CursorError Inheritance Error Inheritance Object

This error is thrown by a collection Cursor. Errors of this class are thrown by classes that implement the IViewCursor interface.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CursorError(message:String) Constructor. | CursorError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
CursorError () constructor
public function CursorError(message:String)

Constructor.

Parameters
message:String — A message providing information about the error cause.


mx.collections.errors.ItemPendingError (Flex™ 2 Language Reference)

Class ItemPendingError | Properties | Methods
Package | mx.collections.errors
Class | public class ItemPendingError
Inheritance | ItemPendingError Inheritance Error Inheritance Object

This error is thrown when retrieving an item from a collection view requires an asynchronous call. This error occurs when the backing data is provided from a remote source and the data is not yet available locally.

If the receiver of this error needs notification when the requested item becomes available (that is, when the asynchronous call completes), it must use the addResponder() method and specify an object that supports the mx.rpc.IResponder interface to respond when the item is available. The mx.collections.ItemResponder class implements the IResponder interface and supports a data property.

See also

mx.collections.ItemResponder
mx.rpc.IResponder

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | responders : Array [read-only] An array of IResponder handlers that will be called when the asynchronous request completes. | ItemPendingError
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ItemPendingError(message:String) Constructor. | ItemPendingError
 | addResponder(responder:IResponder):void addResponder adds a responder to an Array of responders. | ItemPendingError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
responders property
responders:Array [read-only]

An array of IResponder handlers that will be called when the asynchronous request completes.

Implementation
    public function get responders():Array
Constructor detail
ItemPendingError () constructor
public function ItemPendingError(message:String)

Constructor.

Called by the Flex Framework when a request is made for an item that isn't local.

Parameters
message:String — A message providing information about the error cause.
Method detail
addResponder () method
public function addResponder(responder:IResponder):void

addResponder adds a responder to an Array of responders. The object assigned to the responder parameter must implement the mx.rpc.IResponder interface.

Parameters
responder:IResponder — A handler which will be called when the asynchronous request completes.

See also

mx.rpc.IResponder
mx.collections.ItemResponder


mx.collections.errors.SortError (Flex™ 2 Language Reference)

Class SortError | Properties | Methods
Package | mx.collections.errors
Class | public class SortError
Inheritance | SortError Inheritance Error Inheritance Object

This error is thrown when a Sort class is not configured properly; for example, if the find criteria are invalid.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SortError(message:String) Constructor. | SortError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
SortError () constructor
public function SortError(message:String)

Constructor.

Parameters
message:String — A message providing information about the error cause.


mx.containers Summary (Flex™ 2 Language Reference)

Package mx.containers | Classes

The mx.containers package contains the container classes.

Classes
Class | Description
Accordion | An Accordion navigator container has a collection of child containers, but only one of them at a time is visible.
ApplicationControlBar | The ApplicationControlBar container holds components that provide global navigation and application commands.
Box | A Box container lays out its children in a single vertical column or a single horizontal row.
BoxDirection | The BoxDirection class specifies constant values for the direction property of the Box container.
Canvas | A Canvas layout container defines a rectangular region in which you place child containers and controls.
ControlBar | The ControlBar container lets you place controls at the bottom of a Panel or TitleWindow container.
DividedBox | A DividedBox container measures and lays out its children horizontally or vertically in exactly the same way as a Box container, but it inserts draggable dividers in the gaps between the children.
Form | The Form container lets you control the layout of a form, mark form fields as required or optional, handle error messages, and bind your form data to the Flex data model to perform data checking and validation.
FormHeading | The FormHeading container is used to display a heading for a group of controls inside a Form container.
FormItem | The FormItem container defines a label and one or more children arranged horizontally or vertically.
FormItemDirection | The FormItem container defines the constant values for the direction property of the FormItem class.
Grid | A Grid container lets you arrange children as rows and columns of cells, similar to an HTML table.
GridItem | The GridItem container defines a grid cell in GridRow container.
GridRow | The GridRow container defines a row in a Grid container, and contains GridCell containers.
HBox | The HBox container lays out its children in a single horizontal row.
HDividedBox | The HDividedBox container lays out its children horizontally in the same way as HBox container, but it inserts a draggable divider in the gap between each child.
Panel | A Panel container consists of a title bar, a caption, a border, and a content area for its children.
TabNavigator | The TabNavigator container extends the ViewStack container by including a TabBar container for navigating between its child containers.
Tile | A Tile container lays out its children in a grid of equal-sized cells.
TileDirection | The TileDirection class defines the constant values for the direction property of the Tile container.
TitleWindow | A TitleWindow navigator container contains a title bar, a caption, a border, and a content area for its child.
VBox | The VBox container lays out its children in a single vertical column.
VDividedBox | The VDividedBox container lays out its children vertically in the same way as the VBox container, but it inserts a draggable divider in the gap between each child.
ViewStack | A ViewStack navigator container consists of a collection of child containers stacked on top of each other, where only one child at a time is visible.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.containers.Accordion (Flex™ 2 Language Reference)

Class Accordion | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class Accordion
Inheritance | Accordion Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerComponent, IHistoryManagerClient

An Accordion navigator container has a collection of child containers, but only one of them at a time is visible. It creates and manages navigator buttons (accordion headers), which you use to navigate between the children. There is one navigator button associated with each child container, and each navigator button belongs to the Accordion container, not to the child. When the user clicks a navigator button, the associated child container is displayed. The transition to the new child uses an animation to make it clear to the user that one child is disappearing and a different one is appearing.

The Accordion container does not extend the ViewStack container, but it implements all the properties, methods, styles, and events of the ViewStack container, such as selectedIndex and selectedChild.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Accordion> tag inherits all of the tag attributes of its superclass, with the exception of scrolling-related attributes, and adds the following tag attributes:

  <mx:Accordion

    Properties
    headerRenderer="IFactory"
    historyManagementEnabled="true|false"
    resizeToContent="false|true"
    selectedIndex="undefined"

    Styles
    fillAlphas="[0.60, 0.40, 0.75, 0.65]"
    fillColors="[0xFFFFFF, 0xCCCCCC, 0xFFFFFF, 0xEEEEEE]"
    focusAlpha="0.5"
    focusRoundedCorners="tl tr bl br"
    headerHeight="depends on header font styles"
    headerStyleName="No default"
    horizontalGap="8"
    openDuration="250"
    openEasingFunction="undefined"
    paddingBottom="-1"
    paddingTop="-1"
    selectedFillColors="undefined"
    textRollOverColor="0xB333C"
    textSelectedColor="0xB333C"
    verticalGap="-1"

    Events
    change="No default"
    >
      ...
      child tags
      ...
  </mx:Accordion>

View the examples.

See also

mx.containers.accordionClasses.AccordionHeader
Accordion navigator container
Multiple-view containers
Creating deferred components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | headerRenderer : IFactory A factory used to create the navigation buttons for each child. | Accordion
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
 | historyManagementEnabled : Boolean If set to true, this property enables history management within this Accordion container. | Accordion
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | resizeToContent : Boolean If set to true, this Accordion automatically resizes to the size of its current child. | Accordion
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedChild : Container A reference to the currently visible child container. | Accordion
 | selectedIndex : int The zero-based index of the currently visible child container. | Accordion
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
 | contentHeight : Number [read-only] The height of the area, in pixels, in which content is displayed. | Accordion
 | contentWidth : Number [read-only] The width of the area, in pixels, in which content is displayed. | Accordion
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Accordion()
Constructor.
Accordion
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
getHeaderAt(index:int):Button
Returns a reference to the navigator button for a child container.
Accordion
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
loadState(state:Object):void
Loads the state of this object.
Accordion
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
saveState():Object
Saves the state of this object.
Accordion
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's children. | Container
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the selected child container changes. | Accordion
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fillAlphas | Type: Array CSS Inheritance: no Specifies the alpha transparency values used for the background fill of components. You should set this to an Array of either two or four numbers. Elements 0 and 1 specify the start and end values for an alpha gradient. If elements 2 and 3 exist, they are used instead of elements 0 and 1 when the component is in a mouse-over state. The global default value is [ 0.60, 0.40, 0.75, 0.65 ]. Some components, such as the ApplicationControlBar container, have a different default value. For the ApplicationControlBar container, the default value is [ 0.0, 0.0 ]. | Accordion
 | fillColors | Type: Array Format: Color CSS Inheritance: no Specifies the colors used to tint the background fill of the component. You should set this to an Array of either two or four uint values that specify RGB colors. Elements 0 and 1 specify the start and end values for a color gradient. If elements 2 and 3 exist, they are used instead of elements 0 and 1 when the component is in a mouse-over state. For a flat-looking control, set the same color for elements 0 and 1 and for elements 2 and 3, The default value is [ 0xFFFFFF, 0xCCCCCC, 0xFFFFFF, 0xEEEEEE ]. Some components, such as the ApplicationControlBar container, have a different default value. For the ApplicationControlBar container, the default value is [ 0xFFFFFF, 0xFFFFFF ]. | Accordion
 | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. The default value is 0.4. | Accordion
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
 | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". | Accordion
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | headerHeight | Type: Number Format: Length CSS Inheritance: no Height of each accordion header, in pixels. The default value is automatically calculated based on the font styles for the header. | Accordion
 | headerStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the accordion headers (tabs). | Accordion
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value is 8. | Accordion
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | openDuration | Type: Number Format: Time CSS Inheritance: no Duration, in milliseconds, of the animation from one child to another. The default value is 250. | Accordion
 | openEasingFunction | Type: Function CSS Inheritance: no Tweening function used by the animation from one child to another. | Accordion
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and its content area. The default value is -1, so the bottom border of the last header overlaps the Accordion container's bottom border. | Accordion
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. The default value is -1, so the top border of the first header overlaps the Accordion container's top border. | Accordion
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | selectedFillColors | Type: Array Format: Color CSS Inheritance: no The two colors used to tint the background of the component when in its selected state. Pass the same color for both values for "flat" looking control. The default value is undefined, which means the colors are derived from themeColor. | Accordion
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
 | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Color of header text when rolled over. The default value is 0x2B333C. | Accordion
 | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Color of selected text. The default value is 0x2B333C. | Accordion
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value is -1, so the top and bottom borders of adjacent headers overlap. | Accordion
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
contentHeight property
contentHeight:Number [read-only]

The height of the area, in pixels, in which content is displayed. You can override this getter if your content does not occupy the entire area of the container.

Implementation
    protected function get contentHeight():Number
contentWidth property
contentWidth:Number [read-only]

The width of the area, in pixels, in which content is displayed. You can override this getter if your content does not occupy the entire area of the container.

Implementation
    protected function get contentWidth():Number
headerRenderer property
headerRenderer:IFactory [read-write]

A factory used to create the navigation buttons for each child. The default value is a factory which creates a mx.containers.accordionClasses.AccordionHeader. The created object must be a subclass of Button and implement the mx.core.IDataRenderer interface. The data property is set to the content associated with the header.

This property can be used as the source for data binding.

Implementation
    public function get headerRenderer():IFactory
    public function set headerRenderer(value:IFactory):void

See also

mx.containers.accordionClasses.AccordionHeader
historyManagementEnabled property
historyManagementEnabled:Boolean [read-write]

If set to true, this property enables history management within this Accordion container. As the user navigates from one child to another, the browser remembers which children were visited. The user can then click the browser's Back and Forward buttons to move through this navigation history.

The default value is true.

Implementation
    public function get historyManagementEnabled():Boolean
    public function set historyManagementEnabled(value:Boolean):void

See also

mx.managers.HistoryManager
resizeToContent property
resizeToContent:Boolean [read-write]

If set to true, this Accordion automatically resizes to the size of its current child.

The default value is false.

Implementation
    public function get resizeToContent():Boolean
    public function set resizeToContent(value:Boolean):void
selectedChild property
selectedChild:Container [read-write]

A reference to the currently visible child container. The default value is a reference to the first child. If there are no children, this property is null.

Note: You can only set this property in an ActionScript statement, not in MXML.

This property can be used as the source for data binding.

Implementation
    public function get selectedChild():Container
    public function set selectedChild(value:Container):void
selectedIndex property
selectedIndex:int [read-write]

The zero-based index of the currently visible child container. Child indexes are in the range 0, 1, 2, ... , n - 1, where n is the number of children. The default value is 0, corresponding to the first child. If there are no children, this property is -1.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
Constructor detail
Accordion () constructor
public function Accordion()

Constructor.

Method detail
getHeaderAt () method
public function getHeaderAt(index:int):Button

Returns a reference to the navigator button for a child container.

Parameters
index:int — Zero-based index of the child.

Returns
Button — Button object representing the navigator button.
loadState () method
public function loadState(state:Object):void

Loads the state of this object.

Parameters
state:Object — State of this object to load. This will be null when loading the initial state of the application.
saveState () method
public function saveState():Object

Saves the state of this object. The object contains name:value pairs for each property to be saved with the state.

The History Manager collects the state information from all components and encodes the information in a URL format. Most browsers have a length limitation on URLs, so the state information returned should be as minimal as possible.

Returns
Object — The state of this object.
Event detail
change event
Event object type: mx.events.IndexChangedEvent
IndexChangedEvent.type property = mx.events.IndexChangedEvent.CHANGE

Dispatched when the selected child container changes.

The IndexChangedEvent.CHANGE constant defines the value of the type property of the event object for a change event, which indicates that an index has changed, such as when and Accordion control changes the displayed panel or a ViewStack changes views.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
inputType | Indicates whether this event was caused by a mouse or keyboard interaction.
newIndex | The zero-based index after the change.
oldIndex | The zero-based index before the change.
relatedObject | Contains a reference to the child object that corresponds to the new index.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TriggerEvent | The event that triggered this event.
Type | IndexChangedEvent.CHANGE
Examples
AccordionExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Accordion layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Accordion Container Example" height="90%" width="90%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="Select an Accordion navigator button to change the panel."/>

        <mx:Accordion id="accordion" width="100%" height="100%">
            <!-- Define each panel using a VBox container. -->
            <mx:VBox label="Accordion Button for Panel 1">
                <mx:Label text="Accordion container panel 1"/>
            </mx:VBox>

            <mx:VBox label="Accordion Button for Panel 2">
                <mx:Label text="Accordion container panel 2"/>
            </mx:VBox>

            <mx:VBox label="Accordion Button for Panel 3">
                <mx:Label text="Accordion container panel 3"/>
            </mx:VBox>
        </mx:Accordion>

        <mx:Label width="100%" color="blue"
            text="Programmatically select the panel using a Button control."/>

        <mx:HBox>
            <mx:Button label="Select Panel 1" click="accordion.selectedIndex=0;"/>
            <mx:Button label="Select Panel 2" click="accordion.selectedIndex=1;"/>
            <mx:Button label="Select Panel 3" click="accordion.selectedIndex=2;"/>
        </mx:HBox>

    </mx:Panel>
</mx:Application>


mx.containers.ApplicationControlBar (Flex™ 2 Language Reference)

Class ApplicationControlBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class ApplicationControlBar
Inheritance | ApplicationControlBar Inheritance ControlBar Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The ApplicationControlBar container holds components that provide global navigation and application commands. An ApplicationControlBar for an editor, for example, could include Button controls for setting the font weight, a ComboBox control to select the font, and a MenuBar control to select the edit mode. Typically, you place an ApplicationControlBar container at the top of the application.

The ApplicationControlBar container can be in either of the following modes:

  • Docked mode: The bar is always at the top of the application's drawing area and becomes part of the application chrome. Any application-level scroll bars don't apply to the component, so that it always remains at the top of the visible area, and the bar expands to fill the width of the application. To create a docked bar, set the value of the dock property to true.
  • Normal mode: The bar can be placed anywhere in the application, gets sized and positioned just like any other component, and scrolls with the application. To create a normal bar, set the value of the dock property to false (default).

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ApplicationControlBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes. Unlike the ControlBar container, it is possible to set the backgroundColor style for an ApplicationControlBar container.

  <mx:ApplicationControlBar
    Properties
    dock="false|true"

    Styles
    fillAlphas="[0, 0]"
    fillColors="[0xFFFFFF, 0xFFFFFF]"
    >
    ...
      child tags
    ...
  </mx:ApplicationControlBar>

View the examples.

See also

ApplicationControlBar layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | dock : Boolean If true, specifies that the ApplicationControlBar should be docked to the top of the application. | ApplicationControlBar
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ApplicationControlBar()
Constructor.
ApplicationControlBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fillAlphas | Type: Array CSS Inheritance: no Alpha values used for the background fill of the container. The default value is [0,0]. | ApplicationControlBar
 | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the container. Pass the same color for both values for a "flat" looking control. The default value is [0xFFFFFF,0xFFFFFF]. You should also set the fillAlphas property to a nondefault value because its default value of [0,0] makes the colors invisible. | ApplicationControlBar
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dock property
dock:Boolean [read-write]

If true, specifies that the ApplicationControlBar should be docked to the top of the application. If false, specifies that the ApplicationControlBar gets sized and positioned just like any other component.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get dock():Boolean
    public function set dock(value:Boolean):void
Constructor detail
ApplicationControlBar () constructor
public function ApplicationControlBar()

Constructor.

Examples
SimpleApplicationControlBarExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ApplicationControlBar container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
    paddingLeft="10" paddingRight="10" paddingBottom="10"
    backgroundColor="0xCCCCCC">

    <mx:ApplicationControlBar dock="true" paddingTop="0" paddingBottom="0">
        <mx:Label text="Docked" color="blue"/>

        <mx:MenuBar id="myMenuBar" labelField="@label">
            <mx:XMLList>
                <menuitem label="MenuItem A" >
                    <menuitem label="SubMenuItem A-1" type="check"/>
                    <menuitem label="SubMenuItem A-2" type="check"/>
                </menuitem>
                <menuitem label="MenuItem B"/>
                <menuitem label="MenuItem C"/>
                <menuitem label="MenuItem D" >
                    <menuitem label="SubMenuItem D-1" type="radio" groupName="one"/>
                    <menuitem label="SubMenuItem D-2" type="radio" groupName="one"/>
                    <menuitem label="SubMenuItem D-3" type="radio" groupName="one"/>
                </menuitem>
            </mx:XMLList>
        </mx:MenuBar>
    </mx:ApplicationControlBar>

    <mx:Label text="A docked ApplicationControlBar appears at the top of the application window."/>
    <mx:Spacer height="100%" />

    <mx:ApplicationControlBar width="80%">
        <mx:Label text="Normal" color="blue"/>
        <mx:Label text="Search:" />
        <mx:TextInput width="100%" maxWidth="200" />
        <mx:Spacer width="100%" />
        <mx:Button label="Go adobe.com" />
    </mx:ApplicationControlBar>

    <mx:Label text="A normal ApplicationControlBar can appear anywhere in the application."/>

</mx:Application>


mx.containers.Box (Flex™ 2 Language Reference)

Class Box | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class Box
Inheritance | Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | ControlBar, DividedBox, Grid, HBox, NavBar, VBox

A Box container lays out its children in a single vertical column or a single horizontal row. The direction property determines whether to use vertical (default) or horizontal layout.

The Box class is the base class for the VBox and HBox classes. You use the <mx:Box>, <mx:VBox>, and <mx:HBox> tags to define Box containers.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Box> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Box
    Properties
    direction="vertical|horizontal"

    Styles
    horizontalAlign="left|center|right"
    horizontalGap="8"
    paddingBottom="0"
    paddingTop="0"
    verticalAlign="top|middle|bottom"
    verticalGap="6"
    >
    ...
      child tags
    ...
  </mx:Box>

View the examples.

See also

mx.containers.HBox
mx.containers.VBox
Box, HBox, and VBox layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | direction : String The direction in which this Box container lays out its children. | Box
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Box()
Constructor.
Box
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. Possible values are "left", "center", and "right". The default value is "left", but some containers, such as ButtonBar and ToggleButtonBar, have different default values. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. The default value is 0. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. The default value is 0. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. Possible values are "top", "middle", and "bottom". The default value is "top", but some containers, such as ButtonBar, ControlBar, LinkBar, and ToggleButtonBar, have different default values. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
direction property
direction:String [read-write]

The direction in which this Box container lays out its children. Possible MXML values are "horizontal" and "vertical". Possible values in ActionScript are BoxDirection.HORIZONTAL and BoxDirection.VERTICAL.

The default value is BoxDirection.VERTICAL.

This property can be used as the source for data binding.

Implementation
    public function get direction():String
    public function set direction(value:String):void
Constructor detail
Box () constructor
public function Box()

Constructor.

Method detail
measure () method
protected override function measure():void

Calculates the default sizes and minimum and maximum values of the Box container.

If the Box container's direction property is set to BoxDirection.HORIZONTAL, its measuredWidth property is equal to the sum of default widths of all of its children, plus the thickness of the borders, plus the left and right padding, plus the horizontal gap between each child. The value of the measuredHeight property is the maximum of all the children's default heights, plus room for the borders and padding. If the Box container's direction property is set to BoxDirection.VERTICAL, these two values are reversed.

The Box container's minWidth and minHeight properties are calculated similarly, by combining the minimum widths and minimum heights of the children. If the child's width property is a percentage value, the Box container's minimum width is equal to the value of the child's minWidth property. If the child's width is unset or set to a fixed value, the child refuses to grow or shrink, so the Box container's minimum width is equal to the value of the child's explicitWidth property. The child's minimum height is calculated similarly.

The Box container's maxWidth and maxHeight properties are not calculated. The Box container is assumed to have an infinite maximum width and height.

All of the values described previously are the measured widths and heights of the Box container. The user can override the measured values by explicitly supplying a value for the following properties:

  • width
  • height
  • minWidth
  • minHeight
  • maxWidth
  • maxHeight

You should not call the measure() method directly. The Flex LayoutManager calls it at the appropriate time. At application startup, the Flex LayoutManager attempts to measure all components from the children to the parents before setting them to their final sizes.

This is an advanced method for use in subclassing. If you override this method, your implementation must call the super.measure() method, or set the measuredHeight and measuredWidth properties. You may also optionally set the following properties:

  • measuredMinWidth
  • measuredMinHeight

These properties correspond to the layout properties listed previously and, therefore, are not separately documented.

pixelsToPercent () method
public function pixelsToPercent(pxl:Number):Number

Method used to convert number of pixels to a percentage relative to the contents of this container.

The percentage value is relevant only while the container does not change size or layout. After a resize and/or new layout has occurred, the value returned from this method may be stale.

An example of how this method could be used would be to restore a component's size to a specific number of pixels after hiding it.

Parameters
pxl:Number — The number of pixels for which a percentage value is desired.

Returns
Number — The percentage value that would be equivalent to pxl under the current layout conditions of this container. A negative value indicates that the container must grow in order to accommodate the requested size.
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Sets the size and position of each child of the Box container.

To understand the layout algorithm for the Box container, assume that the Box container's direction is horizontal.

All of the Box container's children are positioned side-by-side in a single horizontal row, with horizontalGap pixels between each pair of adjacent children. Initially, the widths of children without an explicit width value are set equal to the values of their measuredWidth properties.

If the sum of the values of the measuredWidth properties of the children is greater than or less than the width of the Box container, and if some of the children have a percentage value for the width property, the sizes of those children are grown or shrunk until all children exactly fit in the Box. However, no child is shrunk to less than the value of its minWidth property or increased greater than the value of its maxWidth property. Among the growing (or shrinking) children, extra space is added (or removed) in proportion to the child's percentWidth. For example, a child with a percentWidth of 40 percent will grow twice as much as a child with a percentWidth of 20 percent until all of the available space is filled or the prescribed sizes are reached.

After all flexible children have grown or shrunk, Flex checks to see if the sum of the children's widths match the width of the Box container. If not, the group of children are all shifted according to the value of the Box container's horizontalAlign property, so the children are aligned with the left edge of the Box, aligned with the right edge of the Box, or centered in the middle of the Box.

To determine the height of each child, Flex examines the value of the child's height property. If the height is unset, the child's height is set to its measuredHeight. If the height is set to a pixel value, that value is used. If the height is set to a percentage value, the child's height is grown or shrunk to match the specified percentage of the height of the Box, as long as the child's height is not shrunk to less than the value of its minHeight property or grown to be larger than the value of its maxHeight property.

The vertical position of each child is determined by the Box container's verticalAlign property. Each child is shifted so that it is aligned with the top edge of the box, aligned with the bottom edge of the box, or centered in the Box.

If the Box container's direction is vertical, the same rules apply, except that the widths and heights are swapped. The children are arranged in a single vertical column.

You should not call this method directly. The Flex LayoutManager calls it at the appropriate time. At application startup, the Flex LayoutManager calls the updateDisplayList() method on every component, starting with the Application object and working downward.

This is an advanced method for use in subclassing. If you override this method, your implementation should call the super.updateDisplayList() method and call the move() and setActualSize() methods on each of the children. For the purposes of performing layout, you should get the size of this container from the unscaledWidth and unscaledHeight properties, not the width and height properties. The width and height properties do not take into account the values of the scaleX and scaleY properties for this container.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
SimpleBoxExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Box layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Box Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="A Box container with vertically aligned children."/>
        <mx:Box direction="vertical" borderStyle="solid"
                paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">
            <mx:Button label="Button 1"/>
            <mx:Button label="Button 2"/>
            <mx:Button label="Button 3"/>
            <mx:ComboBox/>
        </mx:Box>

        <mx:Label width="100%" color="blue"
            text="A Box container with horizontally aligned children."/>
        <mx:Box direction="horizontal" borderStyle="solid"
                paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">
            <mx:Button label="Button 1"/>
            <mx:Button label="Button 2"/>
            <mx:Button label="Button 3"/>
            <mx:ComboBox/>
        </mx:Box>

    </mx:Panel>
</mx:Application>


mx.containers.BoxDirection (Flex™ 2 Language Reference)

Class BoxDirection | Properties | Methods | Constants
Package | mx.containers
Class | public final class BoxDirection
Inheritance | BoxDirection Inheritance Object

The BoxDirection class specifies constant values for the direction property of the Box container.

See also

mx.containers.Box

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] Specifies that children of the Box container are laid out horizontally. | BoxDirection
 | VERTICAL : String = "vertical" [static] Specifies that children of the Box container are laid out vertically. | BoxDirection
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

Specifies that children of the Box container are laid out horizontally.

VERTICAL constant
public static const VERTICAL:String = "vertical"

Specifies that children of the Box container are laid out vertically.


mx.containers.Canvas (Flex™ 2 Language Reference)

Class Canvas | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class Canvas
Inheritance | Canvas Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A Canvas layout container defines a rectangular region in which you place child containers and controls. It is the only container that lets you explicitly specify the location of its children within the container by using the x and y properties of each child.

Flex sets the children of a Canvas layout container to their preferred width and preferred height. You may override the value for a child's preferred width by setting its width property to either a fixed pixel value or a percentage of the container size. You can set the preferred height in a similar manner.

If you use percentage sizing inside a Canvas container, some of your components may overlap. If this is not the effect you want, plan your component positions and sizes carefully.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Canvas> tag inherits all the tag attributes of its superclass. Use the following syntax:

  <mx:Canvas>
    ...
      child tags
    ...
  </mx:Canvas>

View the examples.

See also

Maintaining aspect ratio when sizing
Canvas layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Canvas()
Constructor.
Canvas
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the preferred minimum and preferred maximum sizes of the Canvas. | Canvas
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size of each child of the container. | Canvas
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
Canvas () constructor
public function Canvas()

Constructor.

Method detail
measure () method
protected override function measure():void

Calculates the preferred minimum and preferred maximum sizes of the Canvas.

The measuredWidth of the Canvas is just large enough to display all of its children at their preferred widths without clipping them. This measure() method calculates the position of the right-most child, calculates the position of that child's right edge, and then adds room for the thickness of the Canvas container's border and the right padding. The measuredHeight is calculated similarly.

The Canvas container's minWidth and minHeight properties are not calculated, so Flex uses a default value of 0.

The Canvas container's maxWidth and maxHeight properties are not calculated. The container is assumed to have an infinite maximum width and height.

All of the values described previously are the measured widths and heights of Canvas. The user can override the measured values by calling the explicitly supplying a value for the following properties:

  • width
  • height
  • minWidth
  • minHeight
  • maxWidth
  • maxHeight

You should not call this method directly. The Flex LayoutManager calls it at the appropriate time. At application startup, the Flex LayoutManager attempts to measure all components from the children to the parents before setting them to their final sizes.

This is an advanced method for use in subclassing. If you override this method, your implementation must either call the super.measure() method or set the measuredHeight and measuredWidth properties. You may also optionally set the following properties:

  • measuredMinWidth
  • measuredMinHeight
These properties correspond to the layout properties listed previously and, therefore, are not documented separately.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Sets the size of each child of the container.

Canvas does not change the positions of its children. Each child is positioned according to the values of its x and y properties.

Canvas does set each child's width and height to be equal to that child's measuredWidth and measuredHeight if no width and height values are supplied. The child can also be made resizable by setting width and/or height to a percent value. Resizable children are bound by the right and bottom edges of the Canvas container. In this case, the child's minWidth, minHeight, maxWidth, and maxHeight values are honored.

You should not call this method directly. The Flex LayoutManager calls it at the appropriate time. At application startup, the Flex LayoutManager calls updateDisplayList() method on every component, starting with the Application object and working downward.

This is an advanced method for use in subclassing. If you override this method, your implementation should call the super.updateDisplayList() method and call the move() and setActualSize() methods on each of the children. For the purposes of performing layout, you should get the size of this container from the unscaledWidth and unscaledHeight properties, not the width and height properties. The width and height properties do not take into account the value of the scaleX and scaleY properties for this container.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
SimpleCanvasExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Canvas layout container.-->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Canvas Container Example" height="95%" width="95%"
        paddingTop="5" paddingLeft="5" paddingRight="5" paddingBottom="5">

        <mx:Label width="100%" color="blue"
            text="Use absolute positioning to place the children of a Canvas container."/>

        <mx:Canvas borderStyle="solid" height="200" width="100%">

            <!-- Stagger the position of the TextInput controls using absolute positioning.-->
            <mx:TextInput width="100" x="50" y="5"/>
            <mx:TextInput width="100" x="100" y="30"/>
            <mx:TextInput width="100" x="150" y="55"/>

            <!-- Overlap the VBox containers using layout constraints.-->
            <mx:VBox right="115" bottom="50" width="75" height="75" backgroundColor="#0080C0"/>
            <mx:VBox right="70" bottom="30" width="75" height="75" backgroundColor="#FFFF80"/>
            <mx:VBox right="25" bottom="10" width="75" height="75" backgroundColor="#8080C0" alpha="0.8"/>

            <mx:Text right="25" y="110"
                text="The Canvas container lets you place components on top of each other."/>
        </mx:Canvas>

    </mx:Panel>
</mx:Application>


mx.containers.ControlBar (Flex™ 2 Language Reference)

Class ControlBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class ControlBar
Inheritance | ControlBar Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | ApplicationControlBar

The ControlBar container lets you place controls at the bottom of a Panel or TitleWindow container. The <mx:ControlBar> tag must be the last child tag of the enclosing tag for the Panel or TitleWindow container.

The ControlBar is a Box with a background and default style properties.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ControlBar> tag inherits all the tag attributes but adds no additional attributes:

  <mx:ControlBar>
    ...
      child tags
    ...
  </mx:ControlBar>

View the examples.

See also

ControlBar layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ControlBar()
Constructor.
ControlBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
ControlBar () constructor
public function ControlBar()

Constructor.

Examples
SimpleControlBarExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ControlBar container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="ControlBar Container Example"  width="75%" height="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:HBox width="100%" height="100%">
            <!-- Area for your catalog. -->
            <mx:Image source="@Embed(source='assets/Nokia_6630.png')" width="50%" height="100%"/>
            <mx:Text width="50%" color="blue"
                text="The ControlBar container in this example adds a Label, NumericStepper, Spacer, and Button control to the bottom of the Panel container."/>
        </mx:HBox>

        <mx:ControlBar>
            <mx:Label text="Quantity"/>
            <mx:NumericStepper/>
            <!-- Use Spacer to push Button control to the right. -->
            <mx:Spacer width="100%"/>
            <mx:Button label="Add to Cart"/>
        </mx:ControlBar>

    </mx:Panel>
</mx:Application>


mx.containers.DividedBox (Flex™ 2 Language Reference)

Class DividedBox | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class DividedBox
Inheritance | DividedBox Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | HDividedBox, VDividedBox

A DividedBox container measures and lays out its children horizontally or vertically in exactly the same way as a Box container, but it inserts draggable dividers in the gaps between the children. Users can drag any divider to resize the children on each side.

The DividedBox class is the base class for the more commonly used HDividedBox and VDividedBox classes.

The direction property of a DividedBox container, inherited from Box container, determines whether it has horizontal or vertical layout.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:DividedBox> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:DividedBox
    Properties
    liveDragging="false|true"
    resizeToContent="false|true"

    Styles
    dividerAffordance="6"
    dividerAlpha="0.75"
    dividerColor="0x6F7777"
    dividerSkin="BoxDividerSkin"
    dividerThickness="3"
    horizontalDividerCursor="mx.skins.cursor.HBoxDivider"
    verticalDividerCursor="mx.skins.cursor.VBoxDivider"

    Events
    dividerPress="No default"
    dividerDrag="No default"
    dividerRelease="No default"
    >
      ...
      child tags
      ...
  </mx:DividedBox>

View the examples.

See also

mx.containers.HDividedBox
mx.containers.VDividedBox
DividedBox, HDividedBox, and VDividedBox layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String The direction in which this Box container lays out its children. | Box
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
 | liveDragging : Boolean = false If true, the children adjacent to a divider are continuously resized while the user drags it. | DividedBox
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
 | numDividers : int [read-only] The number of dividers. | DividedBox
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | resizeToContent : Boolean If true, the DividedBox automatically resizes to the size of its children. | DividedBox
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
 | dividerClass : Class The class for the divider between the children. | DividedBox
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DividedBox()
Constructor.
DividedBox
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
getDividerAt(i:int):BoxDivider
Returns a reference to the specified BoxDivider object in this DividedBox container.
DividedBox
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
moveDivider(i:int, amt:Number):void
Move a specific divider a given number of pixels.
DividedBox
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
 | dividerDrag | Dispatched multiple times as the user drags any divider. | DividedBox
 | dividerPress | Dispatched when the user presses any divider in this container. | DividedBox
 | dividerRelease | Dispatched when the user releases a divider. | DividedBox
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
 | dividerAffordance | Type: Number Format: Length CSS Inheritance: no Thickness in pixels of the area where the user can click to drag a divider. This area is centered in the gaps between the container's children, which are determined by the horizontalGap or verticalGap style property. The affordance cannot be set to a value larger than the gap size. A resize cursor appears when the mouse is over this area. The default value is 6. | DividedBox
 | dividerAlpha | Type: Number CSS Inheritance: no The alpha value that determines the transparency of the dividers. A value of 0.0 means completely transparent and a value of 1.0 means completely opaque. The default value is 0.75. | DividedBox
 | dividerColor | Type: uint Format: Color CSS Inheritance: yes Color of the dividers when the user presses or drags the dividers if the liveDragging property is set to false. If the liveDragging property is set to true, only the divider's knob is shown. The default value is 0x6F7777. | DividedBox
 | dividerSkin | Type: Class CSS Inheritance: no The divider skin. The default value is mx.skin.BoxDividerSkin. | DividedBox
 | dividerThickness | Type: Number Format: Length CSS Inheritance: no Thickness in pixels of the dividers when the user presses or drags the dividers, if the liveDragging property is set to false. (If the liveDragging property is set to true, only the divider's knob is shown.) The visible thickness cannot be set to a value larger than the affordance. The default value is 3. | DividedBox
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalDividerCursor | Type: Class CSS Inheritance: no The cursor skin for a horizontal DividedBox. The default value is mx.skins.cursor.HBoxDivider. | DividedBox
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalDividerCursor | Type: Class CSS Inheritance: no The cursor skin for a vertical DividedBox. The default value is mx.skins.cursor.VBoxDivider. | DividedBox
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dividerClass property
protected var dividerClass:Class

The class for the divider between the children.

The default value is mx.containers.dividedBoxClasses.BoxDivider.

liveDragging property
public var liveDragging:Boolean = false

If true, the children adjacent to a divider are continuously resized while the user drags it. If false, they are not resized until the user releases the divider.

The default value is false.

numDividers property
numDividers:int [read-only]

The number of dividers. The count is always numChildren - 1.

Implementation
    public function get numDividers():int
resizeToContent property
resizeToContent:Boolean [read-write]

If true, the DividedBox automatically resizes to the size of its children.

The default value is false.

Implementation
    public function get resizeToContent():Boolean
    public function set resizeToContent(value:Boolean):void
Constructor detail
DividedBox () constructor
public function DividedBox()

Constructor.

Method detail
getDividerAt () method
public function getDividerAt(i:int):BoxDivider

Returns a reference to the specified BoxDivider object in this DividedBox container.

Parameters
i:int — Zero-based index of a divider, counting from the left for a horizontal DividedBox, or from the top for a vertical DividedBox.

Returns
BoxDivider — A BoxDivider object.
moveDivider () method
public function moveDivider(i:int, amt:Number):void

Move a specific divider a given number of pixels.

Parameters
i:int — Zero-based index of a divider, counting from the left for a horizontal DividedBox, or from the top for a vertical DividedBox.
amt:Number — The number of pixels to move the divider. A negative number can be specified in order to move a divider up or left. The divider movement is constrained in the same manner as if a user had moved it.
Event detail
dividerDrag event
Event object type: mx.events.DividerEvent
DividerEvent.type property = mx.events.DividerEvent.DIVIDER_DRAG

Dispatched multiple times as the user drags any divider. The dividerDrag event is dispatched after the dividerPress event and before the dividerRelease event.

The DividerEvent.DIVIDER_DRAG constant defines the value of the type property of the event object for a dividerDrag event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the number of pixels that the divider has been dragged. Positive numbers represent a drag toward the right or bottom, negative numbers toward the left or top.
dividerIndex | Contains the zero-based index of the divider being dragged. The leftmost or topmost divider has a dividerIndex of 0.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
dividerPress event
Event object type: mx.events.DividerEvent
DividerEvent.type property = mx.events.DividerEvent.DIVIDER_PRESS

Dispatched when the user presses any divider in this container. The dividerPress event is dispatched before any dividerDrag events are dispatched.

The DividerEvent.DIVIDER_PRESS constant defines the value of the type property of the event object for a dividerPress event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the number of pixels that the divider has been dragged. Positive numbers represent a drag toward the right or bottom, negative numbers toward the left or top.
dividerIndex | Contains the zero-based index of the divider being dragged. The leftmost or topmost divider has a dividerIndex of 0.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
dividerRelease event
Event object type: mx.events.DividerEvent
DividerEvent.type property = mx.events.DividerEvent.DIVIDER_RELEASE

Dispatched when the user releases a divider. The dividerRelease event is dispatched after the dividerDrag events, but before the container's children are resized.

The DividerEvent.DIVIDER_RELEASE constant defines the value of the type property of the event object for a dividerRelease event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the number of pixels that the divider has been dragged. Positive numbers represent a drag toward the right or bottom, negative numbers toward the left or top.
dividerIndex | Contains the zero-based index of the divider being dragged. The leftmost or topmost divider has a dividerIndex of 0.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
DividedBoxExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the DividedBox layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="DividedBox Container Example" height="95%" width="95%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="A horizontal DividedBox container. Drag the divider side to side to resize the children."/>

        <mx:DividedBox direction="horizontal" width="100%" height="100%">

            <mx:Panel title="Panel 1" width="25%" height="100%" backgroundColor="0xCCCCCC">
            </mx:Panel>

            <mx:Panel title="Panel 2" width="25%" height="100%" backgroundColor="0xCCCCCC">
            </mx:Panel>

        </mx:DividedBox>

    </mx:Panel>
</mx:Application>


mx.containers.Form (Flex™ 2 Language Reference)

Class Form | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class Form
Inheritance | Form Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Form container lets you control the layout of a form, mark form fields as required or optional, handle error messages, and bind your form data to the Flex data model to perform data checking and validation. It also lets you use style sheets to configure the appearance of your forms.

The <mx:Form> tag defines the container for the entire form. Use the <mx:FormHeading> tag and the <mx:FormItem> tag to define its content. You can also insert other types of components in a Form container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Form> tag inherits all the tag attributes of its superclass and adds the following tag attributes:

  <mx:Form
    Styles
    horizontalGap="8"
    indicatorGap="14"
    labelWidth="Calculated"
    paddingBottom="16"
    paddingTop="16"
    verticalGap="6"
    >
    ...
      child tags
    ...
  </mx:Form>

View the examples.

See also

mx.containers.FormHeading
mx.containers.FormItem
Form, FormHeading, and FormItem layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Form()
Constructor.
Form
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the preferred, minimum and maximum sizes of the Form. | Form
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this container's children. | Form
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | Form
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
 | indicatorGap | Type: Number Format: Length CSS Inheritance: yes Number of pixels between the label and child components. The default value is 14. | Form
 | labelWidth | Type: Number Format: Length CSS Inheritance: yes Width of the form labels. The default is the length of the longest label in the form. | Form
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom edge of its content area. The default value is 16. | Form
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top edge of its content area. The default value is 16. | Form
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | Form
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
Form () constructor
public function Form()

Constructor.

Method detail
measure () method
protected override function measure():void

Calculates the preferred, minimum and maximum sizes of the Form. For more information about the measure method, see the UIComponent.measure() method.

The Form.measure() method sets the measuredWidth property to the width of the largest child, plus the values of the paddingLeft and paddingRight style properties and the width of the border.

The measuredHeight property is set to the sum of the measuredHeightS of all children, plus verticalGap space between each child. The paddingTop and paddingBottom style properties and the height of the border are also added.

The measuredMinWidth property is set to the largest minimum width of the children. If the child has a percentage value for width, the minWidth property is used, otherwise the measuredWidth property is used. The values of the paddingLeft and paddingRight style properties and the width of the border are also added.

The measuredMinHeight property is set to the same value as that of the measuredHeight property.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Responds to size changes by setting the positions and sizes of this container's children. For more information about the updateDisplayList() method, see the UIComponent.updateDisplayList() method.

The Form.updateDisplayList() method positions the children in a vertical column, spaced by the verticalGap style property. The paddingLeft, paddingRight, paddingTop and paddingBottom style properties are applied.

If a child has a percentage width, it is stretched horizontally to the specified percentage of the Form container; otherwise, it is set to its measuredWidth property. Each child is set to its measuredHeight property.

This method calls the super.updateDisplayList() method before doing anything else.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
FormExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate Form layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Model id="checkModel">
        <User>
            <FirstName>{fname.text}</FirstName>
            <DOB>{dob.text}</DOB>
            <Email>{email.text}</Email>
            <Age>{age.text}</Age>
            <SSN>{ssn.text}</SSN>
            <Zip>{zip.text}</Zip>
            <Phone>{phone.text}</Phone>
        </User>
    </mx:Model>

    <mx:Panel title="Form Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Moving from one form field to another triggers the validator."/>

        <mx:Form width="100%" height="100%">
            <mx:FormHeading label="Enter values into the form."/>

            <mx:FormItem label="First name">
                <mx:TextInput id="fname" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Date of birth (mm/dd/yyyy)">
                <mx:TextInput id="dob" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="E-mail address">
                <mx:TextInput id="email" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Age">
                <mx:TextInput id="age" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="SSN">
                <mx:TextInput id="ssn" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Zip">
                <mx:TextInput id="zip" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Phone">
                <mx:TextInput id="phone" width="200"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>

    <mx:StringValidator source="{fname}" property="text" minLength="4" maxLength="12"/>
    <mx:PhoneNumberValidator source="{phone}" property="text"/>
    <mx:DateValidator source="{dob}" property="text"/>
    <mx:EmailValidator source="{email}" property="text"/>
    <mx:NumberValidator source="{age}" property="text" integerError="Enter Integer value"
        minValue="18" maxValue="100" domain="int"/>
    <mx:SocialSecurityValidator source="{ssn}" property="text"/>
    <mx:ZipCodeValidator source="{zip}" property="text"/>

</mx:Application>


mx.containers.FormHeading (Flex™ 2 Language Reference)

Class FormHeading | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class FormHeading
Inheritance | FormHeading Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The FormHeading container is used to display a heading for a group of controls inside a Form container. The left side of the heading is aligned with the left side of the controls inside the form. You can include multiple FormHeading containers within a single Form container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:FormHeading> tag inherits all of the tag attributes of its superclass and adds the following tag attributes:

  <mx:FormHeading
    Properties
    label=""

    Styles
    color="0x0B333C"
    disabledColor="0xAAB3B3"
    fontAntiAliasType="advanced|normal"
    fontFamily="Verdana"
    fontGridFitType="pixel|subpixel|none"
    fontSharpness="0"
    fontSize="12"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    indicatorGap="14"
    labelWidth="Calculated"
    leading="2"
    paddingLeft="0"
    paddingRight="0"
    paddingTop="0"
    textAlign="Calculated"
    textDecoration="none|underline"
    textIndent="0"
  />

View the examples.

See also

mx.containers.Form
mx.containers.FormItem
Form, FormHeading, and FormItem layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | label : String Form heading text. | FormHeading
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FormHeading()
Constructor.
FormHeading
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		FormHeading
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		FormHeading
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		FormHeading
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		FormHeading
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		FormHeading
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		FormHeading
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		FormHeading
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		FormHeading
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		FormHeading
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		FormHeading
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
indicatorGap
Type: Number Format: Length CSS Inheritance: yes
Number of pixels between the label area and the heading text. The default value is 14. 		FormHeading
labelWidth
Type: Number Format: Length CSS Inheritance: yes
Width of the form labels. The default value is the length of the longest label in the form. For FormHeading, the labelWidth is space to the left of the heading text. 		FormHeading
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

FormHeading
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

FormHeading
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

FormHeading
paddingTop
Type: Number Format: Length CSS Inheritance: no
Number of pixels above the heading text. The default value is 0. 		FormHeading
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

FormHeading
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		FormHeading
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		FormHeading
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
label property
label:String [read-write]

Form heading text.

This property can be used as the source for data binding.

Implementation
    public function get label():String
    public function set label(value:String):void
Constructor detail
FormHeading () constructor
public function FormHeading()

Constructor.

Examples
FormExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate Form layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Model id="checkModel">
        <User>
            <FirstName>{fname.text}</FirstName>
            <DOB>{dob.text}</DOB>
            <Email>{email.text}</Email>
            <Age>{age.text}</Age>
            <SSN>{ssn.text}</SSN>
            <Zip>{zip.text}</Zip>
            <Phone>{phone.text}</Phone>
        </User>
    </mx:Model>

    <mx:Panel title="Form Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Moving from one form field to another triggers the validator."/>

        <mx:Form width="100%" height="100%">
            <mx:FormHeading label="Enter values into the form."/>

            <mx:FormItem label="First name">
                <mx:TextInput id="fname" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Date of birth (mm/dd/yyyy)">
                <mx:TextInput id="dob" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="E-mail address">
                <mx:TextInput id="email" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Age">
                <mx:TextInput id="age" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="SSN">
                <mx:TextInput id="ssn" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Zip">
                <mx:TextInput id="zip" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Phone">
                <mx:TextInput id="phone" width="200"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>

    <mx:StringValidator source="{fname}" property="text" minLength="4" maxLength="12"/>
    <mx:PhoneNumberValidator source="{phone}" property="text"/>
    <mx:DateValidator source="{dob}" property="text"/>
    <mx:EmailValidator source="{email}" property="text"/>
    <mx:NumberValidator source="{age}" property="text" integerError="Enter Integer value"
        minValue="18" maxValue="100" domain="int"/>
    <mx:SocialSecurityValidator source="{ssn}" property="text"/>
    <mx:ZipCodeValidator source="{zip}" property="text"/>

</mx:Application>


mx.containers.FormItem (Flex™ 2 Language Reference)

Class FormItem | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class FormItem
Inheritance | FormItem Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The FormItem container defines a label and one or more children arranged horizontally or vertically. Children can be controls or other containers. A single Form container can hold multiple FormItem containers.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:FormItem> tag inherits all of the tag attributes of its superclass, except paddingLeft, and adds the following tag attributes:

  <mx:FormItem
    Properties
    direction="vertical|horizontal"
    label=""
    required="false|true"

    Styles
    horizontalAlign="left|center|right"
    horizontalGap="8"
    indicatorGap="14"
    indicatorSkin="Class; mx.container.FormItem.Required"
    labelWidth="Calculated"
    paddingBottom="0"
    paddingRight="0"
    paddingTop="0"
    verticalGap="6"
    >
    ...
      child tags
    ...
  </mx:FormItem>

View the examples.

See also

mx.containers.Form
mx.containers.FormHeading
mx.controls.FormItemLabel
Form, FormHeading, and FormItem layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | direction : String Direction of the FormItem subcomponents. | FormItem
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | label : String Text label for the FormItem. | FormItem
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | required : Boolean If true, display an indicator that the FormItem children require user input. | FormItem
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FormItem()
Constructor.
FormItem
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the preferred, minimum and maximum sizes of the FormItem. | FormItem
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this container's children. | FormItem
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. Possible values are "left", "center", and "right". The default value is "left". | FormItem
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | FormItem
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
 | indicatorGap | Type: Number Format: Length CSS Inheritance: yes Number of pixels between the label and child components of the form item. The default value is 14. | FormItem
 | indicatorSkin | Type: Class CSS Inheritance: no Specifies the skin to use for the required field indicator. The default value is mx.containers.FormItem.Required. | FormItem
 | labelWidth | Type: Number Format: Length CSS Inheritance: yes Width of the form labels. The default is the length of the longest label in the form. | FormItem
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom edge of its content area. The default value is 0. | FormItem
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
 | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. The default value is 0. | FormItem
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top edge of its content area. The default value is 0. | FormItem
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | FormItem
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
direction property
direction:String [read-write]

Direction of the FormItem subcomponents. Possible MXML values are "vertical" or "horizontal". The default MXML value is "vertical". Possible ActionScript values are FormItemDirection.VERTICAL or FormItemDirection.HORIZONTAL. The default value is FormItemDirection.VERTICAL.

When direction is "vertical", the children of the FormItem are stacked vertically to the right of the FormItem label. When direction is "horizontal", the children are placed in a single row (if they fit), or in two equally-sized columns.

If you need more control over the layout of FormItem children, you can use a container such as Grid or Tile as the direct child of the FormItem and put the desired controls inside it.

The default value is FormItemDirection.VERTICAL.

This property can be used as the source for data binding.

Implementation
    public function get direction():String
    public function set direction(value:String):void
label property
label:String [read-write]

Text label for the FormItem. This label appears to the left of the child components of the form item. The default value is the empty String ("").

This property can be used as the source for data binding.

Implementation
    public function get label():String
    public function set label(value:String):void
required property
required:Boolean [read-write]

If true, display an indicator that the FormItem children require user input. If false, indicator is not displayed.

This property controls the indicator display only. You must attach a validator to the children if you require input validation.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get required():Boolean
    public function set required(value:Boolean):void
Constructor detail
FormItem () constructor
public function FormItem()

Constructor.

Method detail
measure () method
protected override function measure():void

Calculates the preferred, minimum and maximum sizes of the FormItem. See the UIComponent.measure() method for more information about the measure() method.

The FormItem.measure() method first determines the number of columns to use. If the direction property is FormItemDirection.HORIZONTAL, all controls will be placed in a single row if possible. If the controls cannot fit in a single row, they are split into two columns. If direction is FormItemDirection.VERTICAL, the controls are placed in a single column.

A FormItem contains two areas: the label area and the controls area. The size of the label is the same regardless of the direction of the controls. The size of the control area depends on how many rows and columns are used.

The width of the label area is determined by the labelWidth style property. If this property is undefined (which is the default), the width of the largest label in the parent Form container is used.

If all children are on a single row, the width of the control area is the sum of the widths of all the children plus horizontalGap space between the children.

If the children are on a single column, the width of the control area is the width of the widest child.

If the children are on multiple rows and columns, the width of the widest child is the column width, and the width of the control area is the column width multiplied by the number of columns plus the horizontalGap space between each column.

measuredWidth is set to the width of the label area plus the width of the control area plus the value of the indicatorGap style property. The values of the paddingLeft and paddingRight style properties and the width of the border are also added.

measuredHeight is set to the sum of the preferred heights of all rows of children, plus verticalGap space between each child. The paddingTop and paddingBottom style properties and the height of the border are also added.

measuredMinWidth is set to the width of the label area plus the minimum width of the control area plus the value of the indicatorGap style property. The values of the paddingLeft and paddingRight style properties and the width of the border are also added.

measuredMinHeight is set to the sum of the minimum heights of all rows of children, plus verticalGap space between each child. The paddingTop and paddingBottom style properties and the height of the border are also added.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Responds to size changes by setting the positions and sizes of this container's children. See the UIComponent.updateDisplayList() method for more information about the updateDisplayList() method.

See the FormItem.measure() method for more information on how the FormItem controls are positioned.

The label is right-aligned in the label area. All labels in a form are aligned with each other.

If the required property is true, a symbol indicating the field is required is placed between the label and the controls.

The controls are positioned in columns, as described in the documentation for the measure() method. The horizontalAlign style property determines where the controls are placed horizontally.

When the direction property is "vertical", any child that has no width specified uses the measuredWidth rounded up to the nearest 1/4 width of the control area. This is done to avoid jagged right edges of controls.

This method calls the super.updateDisplayList() method before doing anything else.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
FormExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate Form layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Model id="checkModel">
        <User>
            <FirstName>{fname.text}</FirstName>
            <DOB>{dob.text}</DOB>
            <Email>{email.text}</Email>
            <Age>{age.text}</Age>
            <SSN>{ssn.text}</SSN>
            <Zip>{zip.text}</Zip>
            <Phone>{phone.text}</Phone>
        </User>
    </mx:Model>

    <mx:Panel title="Form Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Moving from one form field to another triggers the validator."/>

        <mx:Form width="100%" height="100%">
            <mx:FormHeading label="Enter values into the form."/>

            <mx:FormItem label="First name">
                <mx:TextInput id="fname" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Date of birth (mm/dd/yyyy)">
                <mx:TextInput id="dob" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="E-mail address">
                <mx:TextInput id="email" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Age">
                <mx:TextInput id="age" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="SSN">
                <mx:TextInput id="ssn" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Zip">
                <mx:TextInput id="zip" width="200"/>
            </mx:FormItem>

            <mx:FormItem label="Phone">
                <mx:TextInput id="phone" width="200"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>

    <mx:StringValidator source="{fname}" property="text" minLength="4" maxLength="12"/>
    <mx:PhoneNumberValidator source="{phone}" property="text"/>
    <mx:DateValidator source="{dob}" property="text"/>
    <mx:EmailValidator source="{email}" property="text"/>
    <mx:NumberValidator source="{age}" property="text" integerError="Enter Integer value"
        minValue="18" maxValue="100" domain="int"/>
    <mx:SocialSecurityValidator source="{ssn}" property="text"/>
    <mx:ZipCodeValidator source="{zip}" property="text"/>

</mx:Application>


mx.containers.FormItemDirection (Flex™ 2 Language Reference)

Class FormItemDirection | Properties | Methods | Constants
Package | mx.containers
Class | public final class FormItemDirection
Inheritance | FormItemDirection Inheritance Object

The FormItem container defines the constant values for the direction property of the FormItem class.

See also

mx.containers.FormItem

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] Specifies that the children of the FormItem container are laid out horizontally. | FormItemDirection
 | VERTICAL : String = "vertical" [static] Specifies that the children of the FormItem container are laid out vertically. | FormItemDirection
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

Specifies that the children of the FormItem container are laid out horizontally.

VERTICAL constant
public static const VERTICAL:String = "vertical"

Specifies that the children of the FormItem container are laid out vertically.


mx.containers.Grid (Flex™ 2 Language Reference)

Class Grid | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class Grid
Inheritance | Grid Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A Grid container lets you arrange children as rows and columns of cells, similar to an HTML table. The Grid container contains one or more rows, and each row can contain one or more cells, or items. You use the following tags to define a Grid control:
  • The <mx:Grid> tag defines a Grid container.
  • The <mx:GridRow> tag defines a grid row, which has one or more cells. The grid row must be a child of the <Grid> tag.
  • The <mx:GridItem> tag defines a grid cell, and must be a child of the <GridRow> tag. The <mx:GridItem> tag can contain any number of children.

The height of all the cells in a single row is the same, but each row can have a different height. The width of all cells in a single column is the same, but each column can have a different width. You can define a different number of cells for each row or each column of the Grid container. In addition, a cell can span multiple columns or multiple rows of the container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Grid> tag inherits all of the tag attributes of its superclass, except the Box.direction property, and adds the following tag attributes:

  <mx:Grid
    Styles
    horizontalGap="8"
    verticalGap="6"
    >
      ...

    These child tags are examples only:
       <mx:GridRow id="row1">
        <mx:GridItem
          rowSpan="1"
          colSpan="1">
            <mx:Button label="Button 1"/>
        </mx:GridItem>
        ...
       </mx:GridRow>
    ...
  </mx:Grid>

View the examples.

See also

mx.containers.GridRow
mx.containers.GridItem
Grid layout container
Tile layout container
TitleWindow layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Grid()
Constructor.
Grid
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the preferred, minimum, and maximum sizes of the Grid. | Grid
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Grid. | Grid
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value is 8. | Grid
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value is 6. | Grid
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
Grid () constructor
public function Grid()

Constructor.

Method detail
measure () method
protected override function measure():void

Calculates the preferred, minimum, and maximum sizes of the Grid.

You should not call this method directly; it is an advanced method for use in subclassing. The Flex LayoutManger calls the measure() method at the appropriate time. At application startup, the Flex LayoutManager attempts to measure all components from the children to the parents before setting them to their final sizes.

To understand how the Grid container calculates its measurements, assume that every GridItem container has its rowSpan property and colSpan property set to 1. The measured width of the first column of the Grid container is equal to the maximum among of the measured widths of all GridItem containers in the first column. Similarly, the measured width of the second column is the maximum of all measured widths among the GridItem containers in the second column, and so on. The measuredWidth of the entire Grid container is the sum of all columns' measured widths, plus the thickness of the border, plus the left and right padding, plus room for the horizontal gap between adjacent grid cells.

The measuredHeight, minWidth, minHeight, maxWidth, and maxHeight properties' values are all calculated in a similar manner, by adding together the values of the GridItem containers' measuredHeight properties, minWidth properties, and so on.

If a GridItem container's colSpan property is 3, that GridItem container's measuredWidth is divided among 3 columns. If the measuredWidth is divided equally, each of the three columns calculates its measured width as if the GridItem container were only in that column and the GridItem container's measuredWidth were one-third of its actual value.

However, the GridItem container's measuredWidth property is not always divided equally among all the columns it spans. If some of the columns have a property with a percentage value of width, the GridItem container's measuredWidth property is divided accordingly, attempting to give each column the requested percentage of the Grid container.

All of the values described previously are the measured widths and heights of Grid. The user can override the measured values by explicitly supplying a value for the following properties:

  • minHeight
  • minWidth
  • maxHeight
  • maxWidth
  • height
  • width

If you override this method, your implementation must call the super.measure() method or set the measuredHeight and measuredWidth properties. You may also optionally set the following properties:

  • measuredMinWidth
  • measuredMinHeight

These properties correspond to the layout properties listed previously and, therefore, are not documented separately.

updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Sets the size and position of each child of the Grid.

You should not call this method directly; it is an advanced method for use in subclassing. The Flex LayoutManager calls the updateDisplayList method at the appropriate time. At application startup, the Flex LayoutManager calls the updateDisplayList() method on every component, starting with the root and working downward.

The Grid container follows the same layout rules as the VBox container. The positions and sizes of the GridRow containers are calculated the same way that a VBox container determines the positions and sizes of its children. Similarly, a GridRow container positions its GridItem containers using a similar layout algorithm of an HBox container.

The only difference is that the GridRow containers all coordinate with one another, so they all choose the same positions and sizes for their children (so that the columns of the Grid container align).

If you override this method, your implementation should call the super.updateDisplayList() method and call the move() and the setActualSize() methods on each of the children. For the purposes of performing layout, you should get the size of this container from the unscaledWidth and unscaledHeight properties, not the width and height properties. The width and height properties do not take into account the values of the scaleX and scaleY properties for this container.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
GridLayoutExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Grid layout container.-->
<mx:Application borderStyle="none" xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Grid Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="A 3 by 3 Grid container of Button controls."/>

        <mx:Grid>
            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>

            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>

            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>
        </mx:Grid>

    </mx:Panel>
</mx:Application>


mx.containers.GridItem (Flex™ 2 Language Reference)

Class GridItem | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class GridItem
Inheritance | GridItem Inheritance HBox Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The GridItem container defines a grid cell in GridRow container. (The GridRow container, in turn, defines a row in a Grid container.) The GridItem container can contain any number of children, which are laid out as in an HBox container. If you do not want HBox layout, create a container, such as a VBox container, as a child of the GridItem control and put other components in this child container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:GridItem> tag must be a child of the <GridRow> tag, which defines a grid row. The <mx:GridItem> container inherits the tag attributes of its superclass, and adds the following tag attributes.

  <mx:Grid>
    <mx:GridRow>
      <mx:GridItem
        rowSpan="1"
        colSpan="1">
          child components
      </mx:GridItem>
      ...
    </mx:GridRow>
    ...
  </mx:Grid>

View the examples.

See also

mx.containers.Grid
mx.containers.GridRow
Grid layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
 | colSpan : int Number of columns of the Grid container spanned by the cell. | GridItem
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
 | rowSpan : int Number of rows of the Grid container spanned by the cell. | GridItem
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
GridItem()
Constructor.
GridItem
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
colSpan property
colSpan:int [read-write]

Number of columns of the Grid container spanned by the cell.

The default value is 1.

Implementation
    public function get colSpan():int
    public function set colSpan(value:int):void
rowSpan property
rowSpan:int [read-write]

Number of rows of the Grid container spanned by the cell. You cannot extend a cell past the number of rows in the Grid.

The default value is 1.

Implementation
    public function get rowSpan():int
    public function set rowSpan(value:int):void
Constructor detail
GridItem () constructor
public function GridItem()

Constructor.

Examples
GridLayoutExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Grid layout container.-->
<mx:Application borderStyle="none" xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Grid Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="A 3 by 3 Grid container of Button controls."/>

        <mx:Grid>
            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>

            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>

            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>
        </mx:Grid>

    </mx:Panel>
</mx:Application>


mx.containers.GridRow (Flex™ 2 Language Reference)

Class GridRow | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class GridRow
Inheritance | GridRow Inheritance HBox Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The GridRow container defines a row in a Grid container, and contains GridCell containers.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:GridRow> must be a child of the <mx:Grid> tag, and has one or more child <mx:GridItem> tags that define the grid cells.

The <mx:GridRow> container inherits the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Grid>
    <mx:GridRow
    Styles
      horizontalAlign="left|center|right"
      verticalAlign="top|middle|bottom"
    >
      <mx:GridItem
        child components
      </mx:GridItem>
      ...
    </mx:GridRow>
    ...
  </mx:Grid>

View the examples.

See also

mx.containers.Grid
mx.containers.GridItem
Grid layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
GridRow()
Constructor.
GridRow
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the GridRow container. | GridRow
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. Possible values are "left", "center", and "right". The default value is "left". | GridRow
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. Possible values are "top", "middle", and "bottom". The default value is "top". | GridRow
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
GridRow () constructor
public function GridRow()

Constructor.

Method detail
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Sets the size and position of each child of the GridRow container. For more information about the Grid layout algorithm, see the Grid.updateDisplayList() method.

You should not call this method directly. The Flex LayoutManager calls it at the appropriate time. At application startup, the Flex LayoutManager calls the updateDisplayList() method on every component, starting with the root and working downward.

This is an advanced method for use in subclassing. If you override this method, your implementation should call the super.updateDisplayList() method and call the move() and setActualSize() methods on each of the children. For the purposes of performing layout, you should get the size of this container from the unscaledWidth and unscaledHeight properties, not the width and height properties. The width and height properties do not take into account the value of the scaleX and scaleY properties for this container.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Examples
GridLayoutExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Grid layout container.-->
<mx:Application borderStyle="none" xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Grid Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="A 3 by 3 Grid container of Button controls."/>

        <mx:Grid>
            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 1 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>

            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 2 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>

            <mx:GridRow>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 1" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 2" width="100"/>
                </mx:GridItem>
                <mx:GridItem>
                    <mx:Button label="Row 3 Col 3" width="100"/>
                </mx:GridItem>
            </mx:GridRow>
        </mx:Grid>

    </mx:Panel>
</mx:Application>


mx.containers.HBox (Flex™ 2 Language Reference)

Class HBox | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class HBox
Inheritance | HBox Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | GridItem, GridRow

The HBox container lays out its children in a single horizontal row. You use the <mx:HBox> tag instead of the <mx:Box> tag as a shortcut to avoid having to set the direction property to "horizontal".

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HBox> tag inherits all of the tag attributes of its superclass, except direction, and adds no new tag attributes.

View the examples.

See also

mx.containers.Box
mx.containers.VBox
Box, HBox, and VBox layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HBox()
Constructor.
HBox
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
HBox () constructor
public function HBox()

Constructor.

Examples
HBoxExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HBox layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="HBox Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

       <mx:Label width="100%" color="blue"
           text="An HBox container with horizontally aligned children."/>

       <mx:HBox borderStyle="solid" paddingTop="10" paddingBottom="10"
               paddingLeft="10" paddingRight="10">

            <mx:Button label="Button 1"/>
            <mx:Button label="Button 2"/>
            <mx:Button label="Button 3"/>
            <mx:ComboBox/>

        </mx:HBox>

    </mx:Panel>
</mx:Application>


mx.containers.HDividedBox (Flex™ 2 Language Reference)

Class HDividedBox | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class HDividedBox
Inheritance | HDividedBox Inheritance DividedBox Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The HDividedBox container lays out its children horizontally in the same way as HBox container, but it inserts a draggable divider in the gap between each child. A user can drag the divider to resize the area allotted to each child. The <mx:HDividedBox/> tag is the same as <mx:DividedBox direction="horizontal"/>.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HDividedBox> tag inherits all of the tag attributes of its superclass except direction and adds no new tag attributes.

View the examples.

See also

mx.containers.DividedBox
mx.containers.VDividedBox
DividedBox, HDividedBox, and VDividedBox layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | liveDragging : Boolean = false If true, the children adjacent to a divider are continuously resized while the user drags it. | DividedBox
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | numDividers : int The number of dividers. | DividedBox
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | resizeToContent : Boolean If true, the DividedBox automatically resizes to the size of its children. | DividedBox
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | dividerClass : Class The class for the divider between the children. | DividedBox
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HDividedBox()
Constructor.
HDividedBox
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getDividerAt(i:int):BoxDivider
Returns a reference to the specified BoxDivider object in this DividedBox container.
DividedBox
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
moveDivider(i:int, amt:Number):void
Move a specific divider a given number of pixels.
DividedBox
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | dividerDrag | Dispatched multiple times as the user drags any divider. | DividedBox
Inherited | dividerPress | Dispatched when the user presses any divider in this container. | DividedBox
Inherited | dividerRelease | Dispatched when the user releases a divider. | DividedBox
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dividerAffordance | Type: Number Format: Length CSS Inheritance: no Thickness in pixels of the area where the user can click to drag a divider. | DividedBox
Inherited | dividerAlpha | Type: Number CSS Inheritance: no The alpha value that determines the transparency of the dividers. | DividedBox
Inherited | dividerColor | Type: uint Format: Color CSS Inheritance: yes Color of the dividers when the user presses or drags the dividers if the liveDragging property is set to false. | DividedBox
Inherited | dividerSkin | Type: Class CSS Inheritance: no The divider skin. | DividedBox
Inherited | dividerThickness | Type: Number Format: Length CSS Inheritance: no Thickness in pixels of the dividers when the user presses or drags the dividers, if the liveDragging property is set to false. | DividedBox
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalDividerCursor | Type: Class CSS Inheritance: no The cursor skin for a horizontal DividedBox. | DividedBox
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalDividerCursor | Type: Class CSS Inheritance: no The cursor skin for a vertical DividedBox. | DividedBox
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
HDividedBox () constructor
public function HDividedBox()

Constructor.

Examples
HDividedBoxExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HDividedBox layout -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="HDividedBox Container Example" width="90%" height="90%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Drag the divider side to side to resize the children."/>

        <mx:HDividedBox width="100%" height="100%">

            <mx:Canvas label="Canvas 1" width="100%" height="100%" backgroundColor="#FFFFCC">
                <mx:Label text="Add components here" fontWeight="bold"/>
            </mx:Canvas>

            <mx:Canvas label="Canvas 2" width="100%" height="100%" backgroundColor="#99CCFF">
                <mx:Label text="Add components here" fontWeight="bold"/>
            </mx:Canvas>

        </mx:HDividedBox>

    </mx:Panel>
</mx:Application>


mx.containers.Panel (Flex™ 2 Language Reference)

Class Panel | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class Panel
Inheritance | Panel Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | Alert, RichTextEditor, TitleWindow

A Panel container consists of a title bar, a caption, a border, and a content area for its children. Typically, you use Panel containers to wrap top-level application modules. For example, you could include a shopping cart in a Panel container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Panel> tag inherits all of the tag attributes of its superclass and adds the following tag attributes:

  <mx:Panel
   Properties
   layout="vertical|horizontal|absolute"
   status=""
   title=""
   titleIcon="null"

   Styles
   borderAlpha="0.4"
   borderThicknessBottom="NaN"
   borderThicknessLeft="10"
   borderThicknessRight="10"
   borderThicknessTop="2"
   closeButtonDisabledSkin="CloseButtonDisabled"
   closeButtonDownSkin="CloseButtonDown"
   closeButtonOverSkin="CloseButtonOver"
   closeButtonUpSkin="CloseButtonUp"
   controlBarStyleName="null"
   cornerRadius="4"
   dropShadowEnabled="true|false"
   footerColors="null"
   headerColors="null"
   headerHeight="Based on style of title"
   highlightAlphas="[0.3,0]"
   horizontalAlign="left|center|right"
   horizontalGap="8"
   modalTransparency="0.5"
   modalTransparencyBlur="3"
   modalTransparencyColor="#DDDDDD"
   modalTransparencyDuration="100"
   paddingBottom="0"
   paddingTop="0"
   roundedBottomCorners="false|true"
   shadowDirection="center|left|right"
   shadowDistance="2"
   statusStyleName="windowStatus"
   titleBackgroundSkin="TitleBackground"
   titleStyleName="windowStyles"
   verticalAlign="top|middle|bottom"
   verticalGap="6"

   Effects
   resizeEndEffect="Dissolve"
   resizeStartEffect="Dissolve"

   Events
   close="No default"
   >
      ...
      child tags
      ...
  </mx:Panel>

View the examples.

See also

mx.containers.ControlBar
mx.containers.VBox
Panel layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
 | layout : String Specifies the layout mechanism used for this container. | Panel
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
 | status : String Text in the status area of the title bar. | Panel
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | title : String Title or caption displayed in the title bar. | Panel
 | titleIcon : Class The icon displayed in the title bar. | Panel
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
 | controlBar : IUIComponent A reference to this Panel container's control bar, if any. | Panel
 | statusTextField : UITextField The UITextField sub-control that displays the status. | Panel
 | titleBar : UIComponent The TitleBar sub-control that displays the Panel container's title bar. | Panel
 | titleTextField : UITextField The UITextField sub-control that displays the title. | Panel
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Panel()
Constructor.
Panel
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the default mininum and maximum sizes of the Panel container. | Panel
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | startDragging(event:MouseEvent):void Called when the user starts dragging a Panel that has been popped up by the PopUpManager. | Panel
 | stopDragging():void Called when the user stops dragging a Panel that has been popped up by the PopUpManager. | Panel
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's children. | Container
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | close | Dispatched when the user selects the close button. | Panel
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
 | borderAlpha | Type: Number CSS Inheritance: no Alpha of the title bar, control bar and sides of the Panel. The default value is 0.4. | Panel
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
 | borderThicknessBottom | Type: Number Format: Length CSS Inheritance: no Thickness of the bottom border of the Panel control. If this style is not set and the Panel control contains a ControlBar control, the bottom border thickness equals the thickness of the top border of the panel; otherwise the bottom border thickness equals the thickness of the left border. The default value is NaN. | Panel
 | borderThicknessLeft | Type: Number Format: Length CSS Inheritance: no Thickness of the left border of the Panel. The default value is 10. | Panel
 | borderThicknessRight | Type: Number Format: Length CSS Inheritance: no Thickness of the right border of the Panel. The default value is 10. | Panel
 | borderThicknessTop | Type: Number Format: Length CSS Inheritance: no Thickness of the top border of the Panel. The default value is 2. | Panel
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | closeButtonDisabledSkin | Type: Class CSS Inheritance: no The close button disabled skin. The default value is CloseButtonDisabled. | Panel
 | closeButtonDownSkin | Type: Class CSS Inheritance: no The close button down skin. The default value is CloseButtonDown. | Panel
 | closeButtonOverSkin | Type: Class CSS Inheritance: no The close button over skin. The default value is CloseButtonOver. | Panel
 | closeButtonUpSkin | Type: Class CSS Inheritance: no The close button up skin. The default value is CloseButtonUp. | Panel
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
 | controlBarStyleName | Type: String CSS Inheritance: no Name of the CSS style declaration that specifies styles to apply to any control bar child subcontrol. The default value is null. | Panel
 | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of corners of the window frame. The default value is 4. | Panel
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
 | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that controls the visibility of the Panel container's drop shadow. The default value is true. | Panel
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | footerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the footer (area for the ControlBar container) background. The first color is the top color. The second color is the bottom color. The default values are null, which makes the control bar background the same as the panel background. The default value is null. | Panel
 | headerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the header. The first color is the top color. The second color is the bottom color. The default values are null, which makes the header background the same as the panel background. The default value is null. | Panel
 | headerHeight | Type: Number Format: Length CSS Inheritance: no Height of the header. The default value is based on the style of the title text. | Panel
 | highlightAlphas | Type: Array CSS Inheritance: no Alphas used for the highlight fill of the header. The default value is [0.3,0]. | Panel
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. Possible values are "left", "center", and "right". The default value is "left", but some containers, such as ButtonBar and ToggleButtonBar, have different default values. | Panel
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | Panel
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | modalTransparency | Type: Number CSS Inheritance: yes Modality of components launched by the PopUp Manager is simulated by creating a large translucent overlay underneath the component. Because of the way translucent objects are rendered, you may notice a slight dimming of the objects under the overlay. The effective transparency can be set by changing the modalTransparency value from 0.0 (fully transparent) to 1.0 (fully opaque). You can also set the color of the overlay by changing the modalTransparencyColor style. The default value is 0.5. | Panel
 | modalTransparencyBlur | Type: Number CSS Inheritance: yes The blur applied to the application while a modal window is open. A Blur effect softens the details of an image. The default value is 3. | Panel
 | modalTransparencyColor | Type: uint Format: Color CSS Inheritance: yes Color of the modal overlay layer. This style is used in conjunction with the modalTransparency style to determine the colorization applied to the application when a modal window is open. The default value is #DDDDDD. | Panel
 | modalTransparencyDuration | Type: Number Format: Time CSS Inheritance: yes Duration, in milliseconds, of the modal transparency effect that plays when a modal window opens or closes. The default value is 100. | Panel
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's lower border and its content area. The default value is 0. | Panel
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. The default value is 0. | Panel
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | roundedBottomCorners | Type: Boolean CSS Inheritance: no Flag to enable rounding for the bottom two corners of the container. Does not affect the upper two corners, which are normally round. To configure the upper corners to be square, set cornerRadius to 0. The default value is false. | Panel
 | shadowDirection | Type: String CSS Inheritance: no Direction of drop shadow. Possible values are "left", "center", and "right". The default value is "center". | Panel
 | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of drop shadow. Negative values move the shadow above the panel. The default value is 2. | Panel
 | statusStyleName | Type: String CSS Inheritance: no Style declaration name for the status in the title bar. The default value is "windowStatus". | Panel
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
 | titleBackgroundSkin | Type: Class CSS Inheritance: no The title background skin. The default value is mx.skins.halo.TitleBackground. | Panel
 | titleStyleName | Type: String CSS Inheritance: no Style declaration name for the text in the title bar. The default value is "windowStyles", which causes the title to have boldface text. The default value is "windowStyles". | Panel
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. Possible values are "top", "middle", and "bottom". The default value is "top", but some containers, such as ButtonBar, ControlBar, LinkBar, and ToggleButtonBar, have different default values. | Panel
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | Panel
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
 | resizeEndEffect | Triggering event: resizeEnd Specifies the effect to play after a Resize effect finishes playing. To disable the default Dissolve effect, so that the children are hidden instantaneously, set the value of the resizeEndEffect property to "none". | Panel
 | resizeStartEffect | Triggering event: resizeStart Specifies the effect to play before a Resize effect begins playing. To disable the default Dissolve effect, so that the children are hidden instantaneously, set the value of the resizeStartEffect property to "none". | Panel
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
controlBar property
protected var controlBar:IUIComponent

A reference to this Panel container's control bar, if any.

layout property
layout:String [read-write]

Specifies the layout mechanism used for this container. Panel containers can use "vertical", "horizontal", or "absolute" positioning. Vertical positioning lays out the child components vertically from the top of the container to the bottom in the specified order. Horizontal positioning lays out the child components horizontally from the left of the container to the right in the specified order. Absolute positioning does no automatic layout and requires you to explicitly define the location of each child component.

The default value is "vertical".

This property can be used as the source for data binding.

Implementation
    public function get layout():String
    public function set layout(value:String):void
status property
status:String [read-write]

Text in the status area of the title bar.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get status():String
    public function set status(value:String):void
statusTextField property
protected var statusTextField:UITextField

The UITextField sub-control that displays the status. The status field is a child of the titleBar sub-control.

See also

titleBar
title property
title:String [read-write]

Title or caption displayed in the title bar.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get title():String
    public function set title(value:String):void
titleBar property
protected var titleBar:UIComponent

The TitleBar sub-control that displays the Panel container's title bar.

titleIcon property
titleIcon:Class [read-write]

The icon displayed in the title bar.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get titleIcon():Class
    public function set titleIcon(value:Class):void
titleTextField property
protected var titleTextField:UITextField

The UITextField sub-control that displays the title. The title field is a child of the titleBar sub-control.

See also

titleBar
Constructor detail
Panel () constructor
public function Panel()

Constructor.

Method detail
measure () method
protected override function measure():void

Calculates the default mininum and maximum sizes of the Panel container. For more information about the measure() method, see the UIComponent.measure() method.

The measure() method first calls VBox.measure() method, and then ensures that the measuredWidth and measuredMinWidth properties are wide enough to display the title and the ControlBar.

See also

mx.core.UIComponent.measure()
startDragging () method
protected function startDragging(event:MouseEvent):void

Called when the user starts dragging a Panel that has been popped up by the PopUpManager.

Parameters
event:MouseEvent
stopDragging () method
protected function stopDragging():void

Called when the user stops dragging a Panel that has been popped up by the PopUpManager.

Event detail
close event
Event object type: mx.events.CloseEvent
CloseEvent.type property = mx.events.CloseEvent.CLOSE

Dispatched when the user selects the close button.

The CloseEvent.CHANGE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
detail | For controls with multiple buttons, detail identifies the button in the popped up control that was clicked.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
SimplePanelExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate Panel layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            private function showProperties():void  {
                panelPropertyArea.text= "Status: " + panel.status + '\n' +
                  "Title: " + panel.title + '\n' +
                  "Width: " + panel.width + '\n' +
                  "Height: " + panel.height ;
            }
        ]]>
    </mx:Script>

    <mx:Panel id="panel" title="Panel Container Example" status="Active"
            height="75%" width="75%"
            paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="Click the Button control to see panel properties."/>

        <mx:TextArea id="panelPropertyArea" width="100%" height="100%"/>
        <mx:Button label="Click to view Panel properties" click="showProperties();"/>

    </mx:Panel>
</mx:Application>


mx.containers.TabNavigator (Flex™ 2 Language Reference)

Class TabNavigator | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class TabNavigator
Inheritance | TabNavigator Inheritance ViewStack Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerComponent

The TabNavigator container extends the ViewStack container by including a TabBar container for navigating between its child containers.

Like a ViewStack container, a TabNavigator container has a collection of child containers, in which only one child at a time is visible. Flex automatically creates a TabBar container at the top of the TabNavigator container, with a tab corresponding to each child container. Each tab can have its own label and icon. When the user clicks a tab, the corresponding child container becomes visible as the selected child of the TabNavigator container.

When you change the currently visible child container, you can use the hideEffect property of the container being hidden and the showEffect property of the newly visible child container to apply an effect to the child containers. The TabNavigator container waits for the hideEffect of the child container being hidden to complete before it reveals the new child container. You can interrupt a currently playing effect if you change the selectedIndex property of the TabNavigator container while an effect is playing.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:TabNavigator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:TabNavigator
    Styles
    fillAlphas="[0.60, 0.40, 0.75, 0.65]"
    fillColors="[0xFFFFFF, 0xCCCCCC, 0xFFFFFF, 0xEEEEEE]"
    firstTabStyleName="Value of the tabStyleName property"
    focusAlpha="0.4"
    focusRoundedCorners="tl tr bl br"
    horizontalAlign="left|center|right"
    horizontalGap="-1"
    lastTabStyleName="Value of the tabStyleName property"
    selectedTabTextStyleName="undefined"
    tabHeight="undefined"
    tabStyleName="Name of CSS style declaration that specifies styles for the tabs"
    tabWidth="undefined"
    >
      ...
      child tags
      ...
  </mx:TabNavigator>

View the examples.

See also

mx.containers.ViewStack
mx.controls.TabBar
TabNavigator container
Multiple-view containers
Creating deferred components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | historyManagementEnabled : Boolean If true, enables history management within this ViewStack container. | ViewStack
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | resizeToContent : Boolean If true, the ViewStack container automatically resizes to the size of its current child. | ViewStack
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selectedChild : Container A reference to the currently visible child container. | ViewStack
Inherited | selectedIndex : int The zero-based index of the currently visible child container. | ViewStack
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | contentHeight : Number The height of the area, in pixels, in which content is displayed. | ViewStack
Inherited | contentWidth : Number The width of the area, in pixels, in which content is displayed. | ViewStack
Inherited | contentX : Number The x coordinate of the area of the ViewStack container in which content is displayed, in pixels. | ViewStack
Inherited | contentY : Number The y coordinate of the area of the ViewStack container in which content is displayed, in pixels. | ViewStack
 | tabBar : TabBar A reference to the TabBar inside this TabNavigator. | TabNavigator
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TabNavigator()
Constructor.
TabNavigator
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
getTabAt(index:int):Button
Returns the tab of the navigator's TabBar control at the specified index.
TabNavigator
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
loadState(state:Object):void
Loads the state of this object.
ViewStack
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
saveState():Object
Saves the state of this object.
ViewStack
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the default sizes and mininum and maximum values of this TabNavigator container. | TabNavigator
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this container's tabs and children. | TabNavigator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selected child container changes. | ViewStack
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. 		Container
Inherited
backgroundAttachment
Type: String CSS Inheritance: no
If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). 		Container
Inherited
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. 		Container
Inherited
backgroundDisabledColor
Type: uint Format: Color CSS Inheritance: yes
Background color of the component when it is disabled. 		Container
Inherited
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. 		Container
Inherited
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. 		Container
Inherited
barColor
Type: uint Format: Color CSS Inheritance: yes
Determines the color of a ProgressBar. 		Container
Inherited
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. 		Container
Inherited
borderSides
Type: String CSS Inheritance: no
Bounding box sides. 		Container
Inherited
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. 		Container
Inherited
borderStyle
Type: String CSS Inheritance: no
Bounding box style. 		Container
Inherited
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. 		Container
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
Inherited
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. 		Container
Inherited
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. 		Container
Inherited
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. 		Container
Inherited
disabledOverlayAlpha
Type: Number CSS Inheritance: no
The alpha value for the overlay that is placed on top of the container when it is disabled. 		Container
Inherited
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. 		Container
Inherited
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. 		Container
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fillAlphas
Type: Array CSS Inheritance: no
Specifies the alpha transparency values used for the background fill of components. You should set this to an Array of either two or four numbers. Elements 0 and 1 specify the start and end values for an alpha gradient. If elements 2 and 3 exist, they are used instead of elements 0 and 1 when the component is in a mouse-over state. The global default value is [ 0.60, 0.40, 0.75, 0.65 ]. Some components, such as the ApplicationControlBar container, have a different default value. For the ApplicationControlBar container, the default value is [ 0.0, 0.0 ]. 		TabNavigator
fillColors
Type: Array Format: Color CSS Inheritance: no
Specifies the colors used to tint the background fill of the component. You should set this to an Array of either two or four uint values that specify RGB colors. Elements 0 and 1 specify the start and end values for a color gradient. If elements 2 and 3 exist, they are used instead of elements 0 and 1 when the component is in a mouse-over state. For a flat-looking control, set the same color for elements 0 and 1 and for elements 2 and 3, The default value is [ 0xFFFFFF, 0xCCCCCC, 0xFFFFFF, 0xEEEEEE ].

Some components, such as the ApplicationControlBar container, have a different default value. For the ApplicationControlBar container, the default value is [ 0xFFFFFF, 0xFFFFFF ].

TabNavigator
firstTabStyleName
Type: String CSS Inheritance: no
Name of CSS style declaration that specifies styles for the first tab. If this is unspecified, the default value of the tabStyleName style property is used. 		TabNavigator
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		TabNavigator
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		TabNavigator
Inherited
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. 		Container
Inherited
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. 		Container
Inherited
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. 		Container
Inherited
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. 		Container
Inherited
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. 		Container
Inherited
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. 		Container
Inherited
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. 		Container
Inherited
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. 		Container
horizontalAlign
Type: String CSS Inheritance: no
Horizontal positioning of tabs at the top of this TabNavigator container. The possible values are "left", "center", and "right". The default value is "left".

If the value is "left", the left edge of the first tab is aligned with the left edge of the TabNavigator container. If the value is "right", the right edge of the last tab is aligned with the right edge of the TabNavigator container. If the value is "center", the tabs are centered on the top of the TabNavigator container.

To see a difference between the alignments, the total width of all the tabs must be less than the width of the TabNavigator container.

TabNavigator
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
horizontalGap
Type: Number Format: Length CSS Inheritance: no
Separation between tabs, in pixels. The default value is -1, so that the borders of adjacent tabs overlap. 		TabNavigator
lastTabStyleName
Type: String CSS Inheritance: no
Name of CSS style declaration that specifies styles for the last tab. If this is unspecified, the default value of the tabStyleName style property is used. 		TabNavigator
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
Inherited
paddingBottom
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's bottom border and its content area. 		ViewStack
Inherited
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area. 		Container
Inherited
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area. 		Container
Inherited
paddingTop
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's top border and its content area. 		ViewStack
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
selectedTabTextStyleName
Type: String CSS Inheritance: no
Name of CSS style declaration that specifies styles for the text of the selected tab. 		TabNavigator
Inherited
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. 		Container
Inherited
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. 		Container
tabHeight
Type: Number Format: Length CSS Inheritance: no
Height of each tab, in pixels. The default value is undefined. When this property is undefined, the height of each tab is determined by the font styles applied to this TabNavigator container. If you set this property, the specified value overrides this calculation. 		TabNavigator
tabStyleName
Type: String CSS Inheritance: no
Name of CSS style declaration that specifies styles for the tabs. The default value is undefined. 		TabNavigator
tabWidth
Type: Number Format: Length CSS Inheritance: no
Width of each tab, in pixels. The default value is undefined. When this property is undefined, the width of each tab is determined by the width of its label text, using the font styles applied to this TabNavigator container. If the total width of the tabs would be greater than the width of the TabNavigator container, the calculated tab width is decreased, but only to a minimum of 30 pixels. If you set this property, the specified value overrides this calculation.

The label text on a tab is truncated if it does not fit in the tab. If a tab label is truncated, a tooltip with the full label text is displayed when a user rolls the mouse over the tab.

TabNavigator
Inherited
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. 		Container
Inherited
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. 		Container
Inherited
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. 		Container
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
verticalGap
Type: Number Format: Length CSS Inheritance: no
Number of pixels between children in the vertical direction. 		ViewStack
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
tabBar property
protected var tabBar:TabBar

A reference to the TabBar inside this TabNavigator.

Constructor detail
TabNavigator () constructor
public function TabNavigator()

Constructor.

Method detail
getTabAt () method
public function getTabAt(index:int):Button

Returns the tab of the navigator's TabBar control at the specified index.

Parameters
index:int — Index in the navigator's TabBar control.

Returns
Button — The tab at the specified index.
measure () method
protected override function measure():void

Calculates the default sizes and mininum and maximum values of this TabNavigator container. See the UIComponent.measure() method for more information about the measure() method.

The TabNavigator container uses the same measurement logic as the ViewStack container, with two modifications: First, it increases the value of the measuredHeight and measuredMinHeight properties to accomodate the tabs. Second, it increases the value of the measuredWidth property if necessary to ensure that each tab can be at least 30 pixels wide.

See also

mx.core.UIComponent.measure()
mx.containers.ViewStack.measure()
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Responds to size changes by setting the positions and sizes of this container's tabs and children. For more information about the updateDisplayList() method, see the UIComponent.updateDisplayList() method.

A TabNavigator container positions its TabBar container at the top. The width of the TabBar is set to the width of the TabNavigator, and the height of the TabBar is set based on the tabHeight property.

A TabNavigator container positions and sizes its child containers underneath the TabBar, using the same logic as in ViewStack container.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

mx.core.UIComponent.updateDisplayList()
Examples
TabNavigatorExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the TabNavigator layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="TabNavigator Container Example" height="90%" width="90%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="Select the tabs to change the panel."/>

        <mx:TabNavigator id="tn"  width="100%" height="100%">
            <!-- Define each panel using a VBox container. -->

            <mx:VBox label="Panel 1">
                <mx:Label text="TabNavigator container panel 1"/>
            </mx:VBox>

            <mx:VBox label="Panel 2">
                <mx:Label text="TabNavigator container panel 2"/>
            </mx:VBox>

            <mx:VBox label="Panel 3">
                <mx:Label text="TabNavigator container panel 3"/>
            </mx:VBox>
        </mx:TabNavigator>

        <mx:Label width="100%" color="blue"
            text="Programmatically select the panel using a Button control."/>

        <mx:HBox>
            <mx:Button label="Select Tab 1" click="tn.selectedIndex=0"/>
            <mx:Button label="Select Tab 2" click="tn.selectedIndex=1"/>
            <mx:Button label="Select Tab 3" click="tn.selectedIndex=2"/>
        </mx:HBox>

    </mx:Panel>
</mx:Application>


mx.containers.Tile (Flex™ 2 Language Reference)

Class Tile | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class Tile
Inheritance | Tile Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | Legend

A Tile container lays out its children in a grid of equal-sized cells. You can specify the size of the cells by using the tileWidth and tileHeight properties, or let the Tile container determine the cell size based on the largest child. A Tile container's direction property determines whether its cells are laid out horizontally or vertically, beginning from the upper-left corner of the Tile container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Tile> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Tile
    Properties
    direction="horizontal|vertical"
    tileHeight="NaN"
    tileWidth="NaN"

    Events
    horizontalAlign="left|center|right"
    horizontalGap="8"
    paddingBottom="0"
    paddingTop="0"
    verticalAlign="top|middle|bottom"
    verticalGap="6"
    >
      ...
      child tags
     ...
  </mx:Tile>

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | direction : String Determines how children are placed in the container. | Tile
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | tileHeight : Number Height of each tile cell, in pixels. | Tile
 | tileWidth : Number Width of each tile cell, in pixels. | Tile
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Tile()
Constructor.
Tile
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the default minimum and maximum sizes of the Tile container. | Tile
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the positions and sizes of this container's children. | Tile
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of each child inside its tile cell. Possible values are "left", "center", and "right". If the value is "left", the left edge of each child is at the left edge of its cell. If the value is "center", each child is centered horizontally within its cell. If the value is "right", the right edge of each child is at the right edge of its cell. The default value is "left". | Tile
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value is 8. | Tile
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and its content area. The default value is 0. | Tile
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. The default value is 0. | Tile
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of each child inside its tile cell. Possible values are "top", "middle", and "bottom". If the value is "top", the top edge of each child is at the top edge of its cell. If the value is "middle", each child is centered vertically within its cell. If the value is "bottom", the bottom edge of each child is at the bottom edge of its cell. The default value is "top". | Tile
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value is 6. | Tile
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
direction property
direction:String [read-write]

Determines how children are placed in the container. Possible MXML values are "horizontal" and "vertical". In ActionScript, you can set the direction using the values TileDirection.HORIZONTAL or TileDirection.VERTICAL. The default value is "horizontal". (If the container is a Legend container, which is a subclass of Tile, the default value is "vertical".)

The first child is always placed at the upper-left of the Tile container. If the direction is "horizontal", the children are placed left-to-right in the topmost row, and then left-to-right in the second row, and so on. If the value is "vertical", the children are placed top-to-bottom in the leftmost column, and then top-to-bottom in the second column, and so on.

The default value is "horizontal".

This property can be used as the source for data binding.

Implementation
    public function get direction():String
    public function set direction(value:String):void

See also

TileDirection
tileHeight property
tileHeight:Number [read-write]

Height of each tile cell, in pixels. If this property is NaN, the default, the height of each cell is determined by the height of the tallest child. If you set this property, the specified value overrides this calculation.

The default value is NaN.

This property can be used as the source for data binding.

Implementation
    public function get tileHeight():Number
    public function set tileHeight(value:Number):void
tileWidth property
tileWidth:Number [read-write]

Width of each tile cell, in pixels. If this property is NaN, the defualt, the width of each cell is determined by the width of the widest child. If you set this property, the specified value overrides this calculation.

The default value is NaN.

This property can be used as the source for data binding.

Implementation
    public function get tileWidth():Number
    public function set tileWidth(value:Number):void
Constructor detail
Tile () constructor
public function Tile()

Constructor.

Method detail
measure () method
protected override function measure():void

Calculates the default minimum and maximum sizes of the Tile container. For more information about the measure() method, see the UIComponent.measure() method.

This method first calculates the size of each tile cell. For a description of how the cell size is determined, see the tileWidth and tileHeight properties.

The measured size of a Tile container with children is sufficient to display the cells in an N-by-N grid with an equal number of rows and columns, plus room for the Tile container's padding and borders. However, there are various special cases, as in the following examples:

  • If a horizontal Tile container has an explicit width set, that value determines how many cells will fit horizontally, and the height required to fit all the children is calculated, producing an M-by-N grid.
  • If a vertical Tile container has an explicit height set, that value determines how many cells will fit vertically, and the height required to fit all the children is calculated, producing an N-by-M grid.

If there are no children, the measured size is just large enough for its padding and borders.

The minimum measured size of a Tile container with children is just large enough for a single tile cell, plus padding and borders. If there are no children, the minimum measured size is just large enough for its padding and borders.

See also

mx.core.UIComponent.measure()
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Sets the positions and sizes of this container's children. For more information about the updateDisplayList() method, see the UIComponent.updateDisplayList() method.

This method positions the children in a checkboard-style grid of equal-sized cells within the content area of the Tile container (i.e., the area inside its padding). For a description of how the cell size is determined, see the tileWidth and tileHeightproperties.

The separation between the cells is determined by the horizontalGap and verticalGap styles. The placement of each child within its cell is determined by the horizontalAlign and verticalAlign styles.

The flow of the children is determined by the direction property. The first cell is always placed at the upper left of the content area. If direction is set to "horizontal", the cells are placed left-to-right in the topmost row, and then left-to-right in the second row, and so on. If direction is set to "vertical", the cells are placed top-to-bottom in the leftmost column, and then top-to-bottom in the second column, and so on.

If a child has a percentWidth or percentHeight value, it is resized in that direction to fill the specified percentage of its tile cell.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

mx.core.UIComponent.updateDisplayList()
Examples
TileLayoutExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Tile layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Tile Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="A Tile container lays out its children in a grid of equal-sized cells."/>

        <mx:Tile direction="horizontal" borderStyle="inset"
                horizontalGap="10" verticalGap="15"
                paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

            <mx:Button label="1" height="50" width="75"/>
            <mx:Button label="2" height="50" width="75"/>
            <mx:Button label="3" height="50" width="75"/>
            <mx:Button label="4" height="50" width="75"/>
            <mx:Button label="5" height="50" width="75"/>
            <mx:Button label="6" height="50" width="75"/>

        </mx:Tile>

    </mx:Panel>
</mx:Application>


mx.containers.TileDirection (Flex™ 2 Language Reference)

Class TileDirection | Properties | Methods | Constants
Package | mx.containers
Class | public final class TileDirection
Inheritance | TileDirection Inheritance Object

The TileDirection class defines the constant values for the direction property of the Tile container.

See also

mx.containers.Tile

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] Specifies that the children of the Tile container are laid out horizontally; that is, starting with the first row. | TileDirection
 | VERTICAL : String = "vertical" [static] Specifies that the children of the Tile container are laid out vertically; that is, starting with the first column. | TileDirection
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

Specifies that the children of the Tile container are laid out horizontally; that is, starting with the first row.

VERTICAL constant
public static const VERTICAL:String = "vertical"

Specifies that the children of the Tile container are laid out vertically; that is, starting with the first column.


mx.containers.TitleWindow (Flex™ 2 Language Reference)

Class TitleWindow | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class TitleWindow
Inheritance | TitleWindow Inheritance Panel Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A TitleWindow navigator container contains a title bar, a caption, a border, and a content area for its child. Typically, you use TitleWindow containers to wrap self-contained application modules. For example, you could include a form in a TitleWindow container. When the user completes the form, you can close the TitleWindow container programmatically, or let the user close it by using the Close button.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:TitleWindow> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:TitleWindow

    Properties
    showCloseButton="false|true"
    >
    ...
      child tags
    ...
  />

View the examples.

See also

mx.core.Application
mx.managers.PopUpManager
mx.containers.Panel

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | layout : String Specifies the layout mechanism used for this container. | Panel
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | showCloseButton : Boolean Whether to display a Close button in the TitleWindow container. | TitleWindow
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | status : String Text in the status area of the title bar. | Panel
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | title : String Title or caption displayed in the title bar. | Panel
Inherited | titleIcon : Class The icon displayed in the title bar. | Panel
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | controlBar : IUIComponent A reference to this Panel container's control bar, if any. | Panel
Inherited | statusTextField : UITextField The UITextField sub-control that displays the status. | Panel
Inherited | titleBar : UIComponent The TitleBar sub-control that displays the Panel container's title bar. | Panel
Inherited | titleTextField : UITextField The UITextField sub-control that displays the title. | Panel
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TitleWindow()
Constructor.
TitleWindow
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default mininum and maximum sizes of the Panel container. | Panel
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | startDragging(event:MouseEvent):void Called when the user starts dragging a Panel that has been popped up by the PopUpManager. | Panel
Inherited | stopDragging():void Called when the user stops dragging a Panel that has been popped up by the PopUpManager. | Panel
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's children. | Container
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | close | Dispatched when the user selects the close button. | Panel
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderAlpha | Type: Number CSS Inheritance: no Alpha of the title bar, control bar and sides of the Panel. | Panel
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | borderThicknessBottom | Type: Number Format: Length CSS Inheritance: no Thickness of the bottom border of the Panel control. | Panel
Inherited | borderThicknessLeft | Type: Number Format: Length CSS Inheritance: no Thickness of the left border of the Panel. | Panel
Inherited | borderThicknessRight | Type: Number Format: Length CSS Inheritance: no Thickness of the right border of the Panel. | Panel
Inherited | borderThicknessTop | Type: Number Format: Length CSS Inheritance: no Thickness of the top border of the Panel. | Panel
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | closeButtonDisabledSkin | Type: Class CSS Inheritance: no The close button disabled skin. | Panel
Inherited | closeButtonDownSkin | Type: Class CSS Inheritance: no The close button down skin. | Panel
Inherited | closeButtonOverSkin | Type: Class CSS Inheritance: no The close button over skin. | Panel
Inherited | closeButtonUpSkin | Type: Class CSS Inheritance: no The close button up skin. | Panel
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | controlBarStyleName | Type: String CSS Inheritance: no Name of the CSS style declaration that specifies styles to apply to any control bar child subcontrol. | Panel
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of corners of the window frame. | Panel
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that controls the visibility of the Panel container's drop shadow. | Panel
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | footerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the footer (area for the ControlBar container) background. | Panel
Inherited | headerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the header. | Panel
Inherited | headerHeight | Type: Number Format: Length CSS Inheritance: no Height of the header. | Panel
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alphas used for the highlight fill of the header. | Panel
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Panel
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Panel
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | modalTransparency | Type: Number CSS Inheritance: yes Modality of components launched by the PopUp Manager is simulated by creating a large translucent overlay underneath the component. | Panel
Inherited | modalTransparencyBlur | Type: Number CSS Inheritance: yes The blur applied to the application while a modal window is open. | Panel
Inherited | modalTransparencyColor | Type: uint Format: Color CSS Inheritance: yes Color of the modal overlay layer. | Panel
Inherited | modalTransparencyDuration | Type: Number Format: Time CSS Inheritance: yes Duration, in milliseconds, of the modal transparency effect that plays when a modal window opens or closes. | Panel
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's lower border and its content area. | Panel
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. | Panel
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | roundedBottomCorners | Type: Boolean CSS Inheritance: no Flag to enable rounding for the bottom two corners of the container. | Panel
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of drop shadow. | Panel
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of drop shadow. | Panel
Inherited | statusStyleName | Type: String CSS Inheritance: no Style declaration name for the status in the title bar. | Panel
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | titleBackgroundSkin | Type: Class CSS Inheritance: no The title background skin. | Panel
Inherited | titleStyleName | Type: String CSS Inheritance: no Style declaration name for the text in the title bar. | Panel
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Panel
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Panel
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | resizeEndEffect | Triggering event: resizeEnd Specifies the effect to play after a Resize effect finishes playing. | Panel
Inherited | resizeStartEffect | Triggering event: resizeStart Specifies the effect to play before a Resize effect begins playing. | Panel
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
showCloseButton property
showCloseButton:Boolean [read-write]

Whether to display a Close button in the TitleWindow container. The default value is false. Set it to true to display the Close button. Selecting the Close button generates a close event, but does not close the TitleWindow container. You must write a handler for the close event and close the TitleWindow from within it.

The default value is false.

Implementation
    public function get showCloseButton():Boolean
    public function set showCloseButton(value:Boolean):void
Constructor detail
TitleWindow () constructor
public function TitleWindow()

Constructor.

Examples
SimpleTitleWindowExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple custom MXML TitleWindow component.
     The TitleWindowApp application displays this component.
     You cannot run it independently. -->

<mx:TitleWindow xmlns:mx="http://www.adobe.com/2006/mxml"
    title="Title Window" x="168" y="86">

    <mx:Script>
        <![CDATA[
            import mx.managers.PopUpManager;
            import mx.controls.Text;

            // A reference to the TextInput control in which to put the result.
            public var loginName:Text;

            // Event handler for the OK button.
            private function returnName():void {
                loginName.text="Name entered: " + userName.text;
                PopUpManager.removePopUp(this);
            }
        ]]>
    </mx:Script>

    <mx:HBox>
        <mx:Label text="Enter Name: "/>
        <mx:TextInput id="userName" width="100%"/>
    </mx:HBox>

    <mx:HBox>
        <mx:Button label="OK" click="returnName();"/>
        <mx:Button label="Cancel" click="PopUpManager.removePopUp(this);"/>
    </mx:HBox>

</mx:TitleWindow>
TitleWindowApp
<?xml version="1.0" encoding="utf-8"?>
<!-- Main application to demonstrate TitleWindow layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.managers.PopUpManager;
            import mx.containers.TitleWindow;
             import flash.geom.Point;

            private var point1:Point = new Point();

            // Open the TitleWindow container.
            // Cast the return value of the createPopUp() method
            // to SimpleTitleWindowExample, the name of the
            // component containing the TitleWindow container.
            private function showWindow():void {
                var login:SimpleTitleWindowExample=SimpleTitleWindowExample(PopUpManager.createPopUp( this, SimpleTitleWindowExample , true));

                // Calculate position of TitleWindow in Application's coordinates.
                point1.x=myButton.x;
                point1.y=myButton.y;
                point1=myButton.localToGlobal(point1);
                login.x=point1.x+25;
                login.y=point1.y+25;

                // Pass a reference to the TextInput control
                // to the TitleWindow container so that the
                // TitleWindow container can return data to the main application.
                login.loginName=returnedName;
            }
        ]]>
    </mx:Script>

    <mx:Panel title="TitleWindow Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Button id="myButton" label="Click to open the TitleWindow container"
            click="showWindow();"/>

        <mx:Text id="returnedName" text="" width="100%"/>

    </mx:Panel>
</mx:Application>


mx.containers.VBox (Flex™ 2 Language Reference)

Class VBox | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class VBox
Inheritance | VBox Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The VBox container lays out its children in a single vertical column. You use the <mx:VBox> tag instead of the <mx:Box> tag as a shortcut to avoid having to set the direction property to "vertical".

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:VBox> tag inherits all of the tag attributes of its superclass, except direction, and adds no new tag attributes.

View the examples.

See also

mx.containers.Box
mx.containers.HBox
Box, HBox, and VBox layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
VBox()
Constructor.
VBox
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
VBox () constructor
public function VBox()

Constructor.

Examples
VBoxExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the VBox layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="VBox Container Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

       <mx:Label width="100%" color="blue"
           text="A VBox container with vertically aligned children."/>

       <mx:VBox borderStyle="solid" paddingTop="10" paddingBottom="10"
               paddingLeft="10" paddingRight="10">

            <mx:Button label="Button 1"/>
            <mx:Button label="Button 2"/>
            <mx:Button label="Button 3"/>
            <mx:ComboBox/>

        </mx:VBox>

    </mx:Panel>
</mx:Application>


mx.containers.VDividedBox (Flex™ 2 Language Reference)

Class VDividedBox | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class VDividedBox
Inheritance | VDividedBox Inheritance DividedBox Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The VDividedBox container lays out its children vertically in the same way as the VBox container, but it inserts a draggable divider in the gap between each child. A user can drag the divider to resize the area allotted to each child. The <mx:VDividedBox/> tag is the same as <mx:DividedBox direction="vertical"/>.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:VDividedBox> tag inherits all of the tag attributes of its superclass, except direction, and adds no new tag attributes.

View the examples.

See also

mx.containers.DividedBox
mx.containers.HDividedBox
DividedBox, HDividedBox, and VDividedBox layout containers

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | liveDragging : Boolean = false If true, the children adjacent to a divider are continuously resized while the user drags it. | DividedBox
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | numDividers : int The number of dividers. | DividedBox
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | resizeToContent : Boolean If true, the DividedBox automatically resizes to the size of its children. | DividedBox
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | dividerClass : Class The class for the divider between the children. | DividedBox
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
VDividedBox()
Constructor.
VDividedBox
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getDividerAt(i:int):BoxDivider
Returns a reference to the specified BoxDivider object in this DividedBox container.
DividedBox
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
moveDivider(i:int, amt:Number):void
Move a specific divider a given number of pixels.
DividedBox
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | dividerDrag | Dispatched multiple times as the user drags any divider. | DividedBox
Inherited | dividerPress | Dispatched when the user presses any divider in this container. | DividedBox
Inherited | dividerRelease | Dispatched when the user releases a divider. | DividedBox
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dividerAffordance | Type: Number Format: Length CSS Inheritance: no Thickness in pixels of the area where the user can click to drag a divider. | DividedBox
Inherited | dividerAlpha | Type: Number CSS Inheritance: no The alpha value that determines the transparency of the dividers. | DividedBox
Inherited | dividerColor | Type: uint Format: Color CSS Inheritance: yes Color of the dividers when the user presses or drags the dividers if the liveDragging property is set to false. | DividedBox
Inherited | dividerSkin | Type: Class CSS Inheritance: no The divider skin. | DividedBox
Inherited | dividerThickness | Type: Number Format: Length CSS Inheritance: no Thickness in pixels of the dividers when the user presses or drags the dividers, if the liveDragging property is set to false. | DividedBox
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalDividerCursor | Type: Class CSS Inheritance: no The cursor skin for a horizontal DividedBox. | DividedBox
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalDividerCursor | Type: Class CSS Inheritance: no The cursor skin for a vertical DividedBox. | DividedBox
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
VDividedBox () constructor
public function VDividedBox()

Constructor.

Examples
VDividedBoxExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the VDividedBox layout -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="VDividedBox Container Example" width="90%" height="90%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Drag the divider up and down to resize the children."/>

        <mx:VDividedBox width="100%" height="100%">

            <mx:Canvas label="Canvas 1" width="100%" height="100%" backgroundColor="#FFFFCC">
                <mx:Label text="Add components here" fontWeight="bold"/>
            </mx:Canvas>

            <mx:Canvas label="Canvas 2" width="100%" height="100%" backgroundColor="#99CCFF">
                <mx:Label text="Add components here" fontWeight="bold"/>
            </mx:Canvas>

        </mx:VDividedBox>

    </mx:Panel>
</mx:Application>


mx.containers.ViewStack (Flex™ 2 Language Reference)

Class ViewStack | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.containers
Class | public class ViewStack
Inheritance | ViewStack Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IHistoryManagerClient
Subclasses | TabNavigator

A ViewStack navigator container consists of a collection of child containers stacked on top of each other, where only one child at a time is visible. When a different child container is selected, it seems to replace the old one because it appears in the same location. However, the old child container still exists; it is just invisible.

A ViewStack container does not provide a user interface for selecting which child container is currently visible. Typically, you set its selectedIndex or selectedChild property in ActionScript in response to some user action. Alternately, you can associate a LinkBar, TabBar or ToggleButtonBar container with a ViewStack container to provide a navigation interface. To do so, specify the ViewStack container as the value of the dataProvider property of the LinkBar, TabBar or ToggleButtonBar container.

You might decide to use a more complex navigator container than the ViewStack container, such as a TabNavigator container or Accordion container. In addition to having a collection of child containers, these containers provide their own user interface controls for navigating between their children.

When you change the currently visible child container, you can use the hideEffect property of the container being hidden and the showEffect property of the newly visible child container to apply an effect to the child containers. The ViewStack container waits for the hideEffect of the child container being hidden to complete before it reveals the new child container. You can interrupt a currently playing effect if you change the selectedIndex property of the ViewStack container while an effect is playing.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ViewStack> tag inherits the tag attributes of its superclass, with the exception of scrolling-related attributes, and adds the following tag attributes:

  <mx:ViewStack
    Properties
    historyManagementEnabled="false|true"
    resizeToContent="false|true"
    selectedIndex="0"

    Styles
    horizontalGap="8"
    paddingBottom="0"
    paddingTop="0"
    verticalGap="6"

    Events
    change="No default"
    >
      ...
      child tags
      ...
  </mx:ViewStack>

View the examples.

See also

mx.controls.LinkBar
mx.managers.HistoryManager
mx.managers.LayoutManager
ViewStack navigator container
Multiple-view containers
Creating deferred components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
 | historyManagementEnabled : Boolean If true, enables history management within this ViewStack container. | ViewStack
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | resizeToContent : Boolean If true, the ViewStack container automatically resizes to the size of its current child. | ViewStack
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedChild : Container A reference to the currently visible child container. | ViewStack
 | selectedIndex : int The zero-based index of the currently visible child container. | ViewStack
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
 | contentHeight : Number [read-only] The height of the area, in pixels, in which content is displayed. | ViewStack
 | contentWidth : Number [read-only] The width of the area, in pixels, in which content is displayed. | ViewStack
 | contentX : Number [read-only] The x coordinate of the area of the ViewStack container in which content is displayed, in pixels. | ViewStack
 | contentY : Number [read-only] The y coordinate of the area of the ViewStack container in which content is displayed, in pixels. | ViewStack
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ViewStack()
Constructor.
ViewStack
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
loadState(state:Object):void
Loads the state of this object.
ViewStack
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
saveState():Object
Saves the state of this object.
ViewStack
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
 | measure():void Calculates the default sizes and minimum and maximum values of the ViewStack container. | ViewStack
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this container's children. | ViewStack
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the selected child container changes. | ViewStack
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | ViewStack
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and its content area. The default value is 0. | ViewStack
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. The default value is 0. | ViewStack
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | ViewStack
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
contentHeight property
contentHeight:Number [read-only]

The height of the area, in pixels, in which content is displayed. You can override this getter if your content does not occupy the entire area of the ViewStack container.

Implementation
    protected function get contentHeight():Number
contentWidth property
contentWidth:Number [read-only]

The width of the area, in pixels, in which content is displayed. You can override this getter if your content does not occupy the entire area of the ViewStack container.

Implementation
    protected function get contentWidth():Number
contentX property
contentX:Number [read-only]

The x coordinate of the area of the ViewStack container in which content is displayed, in pixels. The default value is equal to the value of the paddingLeft style property, which has a default value of 0. Override the get() method if you do not want your content to start layout at x = 0.

Implementation
    protected function get contentX():Number
contentY property
contentY:Number [read-only]

The y coordinate of the area of the ViewStack container in which content is displayed, in pixels. The default value is equal to the value of the paddingTop style property, which has a default value of 0. Override the get() method if you do not want your content to start layout at y = 0.

Implementation
    protected function get contentY():Number
historyManagementEnabled property
historyManagementEnabled:Boolean [read-write]

If true, enables history management within this ViewStack container. As the user navigates from one child to another, the browser remembers which children were visited. The user can then click the browser's Back and Forward buttons to move through this navigation history.

The default value is false.

Implementation
    public function get historyManagementEnabled():Boolean
    public function set historyManagementEnabled(value:Boolean):void

See also

mx.managers.HistoryManager
resizeToContent property
resizeToContent:Boolean [read-write]

If true, the ViewStack container automatically resizes to the size of its current child.

The default value is false.

Implementation
    public function get resizeToContent():Boolean
    public function set resizeToContent(value:Boolean):void
selectedChild property
selectedChild:Container [read-write]

A reference to the currently visible child container. The default is a reference to the first child. If there are no children, this property is null.

Note: You can only set this property in an ActionScript statement, not in MXML.

This property can be used as the source for data binding.

Implementation
    public function get selectedChild():Container
    public function set selectedChild(value:Container):void
selectedIndex property
selectedIndex:int [read-write]

The zero-based index of the currently visible child container. Child indexes are in the range 0, 1, 2, ... , n - 1, where n is the number of children. The default value is 0, corresponding to the first child. If there are no children, the value of this property is -1.

Note: When you add a new child to a ViewStack container, the selectedIndex property is automatically adjusted, if necessary, so that the selected child remains selected.

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
Constructor detail
ViewStack () constructor
public function ViewStack()

Constructor.

Method detail
loadState () method
public function loadState(state:Object):void

Loads the state of this object.

Parameters
state:Object — State of this object to load. This will be null when loading the initial state of the application.
measure () method
protected override function measure():void

Calculates the default sizes and minimum and maximum values of the ViewStack container. For more information about the measure() method, see the UIComponent.measure() method.

The default size of a ViewStack container is the default size of its currently selected child, plus the padding and borders. If the ViewStack container has no children, its default size is just large enough for its padding and borders.

The minimum size of a ViewStack container is the minimum size of its currently selected child, plus the padding and borders. If the ViewStack container has no children, its minimum size is just large enough for its padding and borders.

This method does not change the maximum size of a ViewStack container - it remains unbounded.

See also

mx.core.UIComponent.measure()
saveState () method
public function saveState():Object

Saves the state of this object. The object contains name:value pairs for each property to be saved with the state.

The History Manager collects the state information from all components and encodes the information in a URL format. Most browsers have a length limitation on URLs, so the state information returned should be as minimal as possible.

Returns
Object — The state of this object.
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Responds to size changes by setting the positions and sizes of this container's children. For more information about the updateDisplayList() method, see the UIComponent.updateDisplayList() method.

Only one of its children is visible at a time, therefore, a ViewStack container positions and sizes only that child.

The selected child is positioned in the ViewStack container's upper-left corner, and allows for the ViewStack container's padding and borders.

If the selected child has a percentage width or height value, it is resized in that direction to fill the specified percentage of the ViewStack container's content area (i.e., the region inside its padding).

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

mx.core.UIComponent.updateDisplayList()
Event detail
change event
Event object type: mx.events.IndexChangedEvent
IndexChangedEvent.type property = mx.events.IndexChangedEvent.CHANGE

Dispatched when the selected child container changes.

The IndexChangedEvent.CHANGE constant defines the value of the type property of the event object for a change event, which indicates that an index has changed, such as when and Accordion control changes the displayed panel or a ViewStack changes views.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
inputType | Indicates whether this event was caused by a mouse or keyboard interaction.
newIndex | The zero-based index after the change.
oldIndex | The zero-based index before the change.
relatedObject | Contains a reference to the child object that corresponds to the new index.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TriggerEvent | The event that triggered this event.
Type | IndexChangedEvent.CHANGE
Examples
ViewStackExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ViewStack layout container. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

     <mx:Panel title="ViewStack Container Example" height="95%" width="95%"
         paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Use the Button controls to change panels of the ViewStack container."/>

        <mx:HBox borderStyle="solid" width="100%"
            paddingTop="5" paddingLeft="5" paddingRight="5" paddingBottom="5">

            <mx:Button id="searchButton" label="Search Panel"
                click="myViewStack.selectedChild=search;"/>
            <mx:Button id="cInfoButton" label="Customer Info Panel"
                click="myViewStack.selectedChild=custInfo;"/>
            <mx:Button id="aInfoButton" label="Account Panel"
                click="myViewStack.selectedChild=accountInfo;"/>
        </mx:HBox>

        <!-- Define the ViewStack and the three child containers and have it
        resize up to the size of the container for the buttons. -->
        <mx:ViewStack id="myViewStack" borderStyle="solid" width="100%" height="80%">

            <mx:Canvas id="search" backgroundColor="#FFFFCC" label="Search" width="100%" height="100%">
                <mx:Label text="Search Screen" color="#000000"/>
            </mx:Canvas>

            <mx:Canvas id="custInfo" backgroundColor="#CCFFFF" label="Customer Info" width="100%" height="100%">
                <mx:Label text="Customer Info" color="#000000"/>
            </mx:Canvas>

            <mx:Canvas id="accountInfo" backgroundColor="#FFCCFF" label="Account Info" width="100%" height="100%">
                <mx:Label text="Account Info" color="#000000"/>
            </mx:Canvas>
        </mx:ViewStack>

    </mx:Panel>
</mx:Application>


mx.containers.accordionClasses Summary (Flex™ 2 Language Reference)

Package mx.containers.accordionClasses | Classes

The mx.containers.accordionClasses package contains the classes used by the Accordion container.

Classes
Class | Description
AccordionHeader | The AccordionHeader class defines the appearance of the navigation buttons of an Accordion.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.containers.accordionClasses.AccordionHeader (Flex™ 2 Language Reference)

Class AccordionHeader | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.containers.accordionClasses
Class | public class AccordionHeader
Inheritance | AccordionHeader Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer

The AccordionHeader class defines the appearance of the navigation buttons of an Accordion. You use the getHeaderAt() method of the Accordion class to get a reference to an individual AccordionHeader object.

See also

mx.containers.Accordion

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object Stores a reference to the content associated with the header. | AccordionHeader
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | emphasized : Boolean Draws a thick border around the Button control when the control is in its up state if emphasized is set to true. | Button
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
Inherited | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toggle : Boolean Controls whether a Button is in a toggle state or not. | Button
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AccordionHeader()
Constructor.
AccordionHeader
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Button
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Button
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | Button
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | Button
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | selectedDisabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and disabled. | Button
Inherited | selectedDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and disabled. | Button
Inherited | selectedDownIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is down. | Button
Inherited | selectedDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down. | Button
Inherited | selectedOverIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse is over the control. | Button
Inherited | selectedOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control. | Button
Inherited | selectedUpIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is up. | Button
Inherited | selectedUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control. | Button
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user moves the mouse pointer over the button. | Button
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user presses it. | Button
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

Stores a reference to the content associated with the header.

Implementation
    public function get data():Object
    public function set data(value:Object):void
Constructor detail
AccordionHeader () constructor
public function AccordionHeader()

Constructor.


mx.controls Summary (Flex™ 2 Language Reference)

Package mx.controls | Classes

The mx.controls package contains the Flex user-interface controls.

Classes
Class | Description
Alert | The Alert control is a pop-up dialog box that can contain a message, a title, buttons (any combination of OK, Cancel, Yes, and No) and an icon.
Button | The Button control is a commonly used rectangular button.
ButtonBar | The ButtonBar control defines a horizontal or vertical group of logically related push buttons with a common look and navigation.
ButtonLabelPlacement | The ButtonLabelPlacement class defines the constants for the allowed values of the labelPlacement property of a Button, CheckBox, LinkButton, or RadioButton control.
CheckBox | The CheckBox control consists of an optional label and a small box that can contain a check mark or not.
ColorPicker | The ColorPicker control provides a way for a user to choose a color from a swatch list.
ComboBase | The ComboBase class is the base class for controls that display text in a text field and have a button that causes a drop-down list to appear where the user can choose which text to display.
ComboBox | The ComboBox control contains a drop-down list from which the user can select a single value.
DataGrid | The DataGrid control is a like a List except that it can show more than one column of data making it suited for showing objects with multiple properties.
DateChooser | The DateChooser control displays the name of a month, the year, and a grid of the days of the month, with columns labeled for the day of the week.
DateField | The DateField control is a text field that shows the date with a calendar icon on its right side.
FormItemLabel | The FormItem container uses a FormItemLabel object to display the label portion of the FormItem container.
HorizontalList | The HorizontalList control displays a horizontal list of items.
HRule | The HRule control creates a single horizontal line.
HScrollBar | The HScrollBar (horizontal ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
HSlider | The HSlider control lets users select a value by moving a slider thumb between the end points of the slider track.
Image | The Image control lets you import JPEG, PNG, GIF, and SWF files at runtime.
Label | The Label control displays a single line of noneditable text.
LinkBar | A LinkBar control defines a horizontal or vertical row of LinkButton controls that designate a series of link destinations.
LinkButton | The LinkButton control is a borderless Button control whose contents are highlighted when a user moves the mouse over it.
List | The List control displays a vertical list of items.
Menu | The Menu control creates a pop-up menu of individually selectable choices, similar to the File or Edit menu found in most software applications.
MenuBar | A MenuBar control defines a horizontal menu bar that contains one or more child menus.
NavBar | The NavBar control is the superclass for navigator controls, such as the LinkBar and TabBar controls, and cannot be instantiated directly.
NumericStepper | The NumericStepper control lets the user select a number from an ordered set.
PopUpButton | The PopUpButton control adds a flexible pop-up control interface to a Button control.
PopUpMenuButton | The PopUpMenuButton control creates a PopUpButton control with a main sub-button and a secondary sub-button.
ProgressBar | The ProgressBar control provides a visual representation of the progress of a task over time.
ProgressBarDirection | The ProgressBarDirection class defines the values for the direction property of the ProgressBar class.
ProgressBarLabelPlacement | The ProgressBarLabelPlacement class defines the values for the labelPlacement property of the ProgressBar class.
ProgressBarMode | The ProgressBarMode class defines the values for the mode property of the ProgressBar class.
RadioButton | The RadioButton control lets the user make a single choice within a set of mutually exclusive choices.
RadioButtonGroup | The RadioButtonGroup control defines a group of RadioButton controls that act as a single mutually exclusive control; therefore, a user can select only one RadioButton control at a time.
RichTextEditor | The RichTextEditor control lets users enter and format text.
Spacer | The Spacer control helps you lay out children within a parent container.
SWFLoader | The SWFLoader control loads and displays a specified SWF file.
TabBar | The TabBar control lets you create a horizontal or vertical group of tab navigation items by defining the labels and data associated with each tab.
Text | The Text control displays multiline, noneditable text.
TextArea | The TextArea control is a multiline text field with a border and optional scroll bars.
TextInput | The TextInput control is a single-line text field that is optionally editable.
TileList | The TileList control displays a number of items laid out in tiles.
ToggleButtonBar | The ToggleButtonBar control defines a horizontal or vertical group of buttons that maintain their selected or deselected state.
ToolTip | The ToolTip control lets you provide helpful information to your users.
Tree | The Tree control lets a user view hierarchical data arranged as an expandable tree.
VideoDisplay | The VideoDisplay control lets you play an FLV file in a Flex application.
VRule | The VRule control creates a single vertical line.
VScrollBar | The VScrollBar (vertical ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
VSlider | The VSlider control lets users select a value by moving a slider thumb between the end points of the slider track.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.Alert (Flex™ 2 Language Reference)

Class Alert | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Alert
Inheritance | Alert Inheritance Panel Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Alert control is a pop-up dialog box that can contain a message, a title, buttons (any combination of OK, Cancel, Yes, and No) and an icon. The Alert control is modal, which means it will retain focus until the user closes it.

Import the mx.controls.Alert class into your application, and then call the static show() method in ActionScript to display an Alert control. You cannot create an Alert control in MXML.

The Alert control closes when you select a button in the control, or press the Escape key.

View the examples.

See also

mx.managers.SystemManager
mx.managers.PopUpManager
Alert control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
 | buttonFlags : uint = 0x0004 A bitmask that contains Alert.OK, Alert.CANCEL, Alert.YES, and/or Alert.NO indicating the buttons available in the Alert control. | Alert
 | buttonHeight : Number = 22 [static] Height of each Alert button, in pixels. | Alert
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
 | buttonWidth : Number = 60 [static] Width of each Alert button, in pixels. | Alert
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
 | cancelLabel : String = "" [static] The label for the Cancel button. | Alert
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
 | defaultButtonFlag : uint = 0x0004 A bitflag that contains either Alert.OK, Alert.CANCEL, Alert.YES, or Alert.NO to specify the default button. | Alert
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
 | iconClass : Class The class of the icon to display. | Alert
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | layout : String Specifies the layout mechanism used for this container. | Panel
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
 | noLabel : String = "" [static] The label for the No button. | Alert
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
 | okLabel : String = "" [static] The label for the OK button. | Alert
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | status : String Text in the status area of the title bar. | Panel
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String = "" The text to display in this alert dialog box. | Alert
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | title : String Title or caption displayed in the title bar. | Panel
Inherited | titleIcon : Class The icon displayed in the title bar. | Panel
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yesLabel : String = "" [static] The label for the Yes button. | Alert
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | controlBar : IUIComponent A reference to this Panel container's control bar, if any. | Panel
Inherited | statusTextField : UITextField The UITextField sub-control that displays the status. | Panel
Inherited | titleBar : UIComponent The TitleBar sub-control that displays the Panel container's title bar. | Panel
Inherited | titleTextField : UITextField The UITextField sub-control that displays the title. | Panel
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Alert()
Constructor.
Alert
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
show(text:String = "", title:String = "", flags:uint = 0x4, parent:Sprite = null, closeHandler:Function = null, iconClass:Class = null, defaultButtonFlag:uint = 0x4):Alert
[static] Static method that pops up the Alert control.
Alert
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default mininum and maximum sizes of the Panel container. | Panel
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | startDragging(event:MouseEvent):void Called when the user starts dragging a Panel that has been popped up by the PopUpManager. | Panel
Inherited | stopDragging():void Called when the user stops dragging a Panel that has been popped up by the PopUpManager. | Panel
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's children. | Container
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | close | Dispatched when the user selects the close button. | Panel
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderAlpha | Type: Number CSS Inheritance: no Alpha of the title bar, control bar and sides of the Panel. | Panel
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | borderThicknessBottom | Type: Number Format: Length CSS Inheritance: no Thickness of the bottom border of the Panel control. | Panel
Inherited | borderThicknessLeft | Type: Number Format: Length CSS Inheritance: no Thickness of the left border of the Panel. | Panel
Inherited | borderThicknessRight | Type: Number Format: Length CSS Inheritance: no Thickness of the right border of the Panel. | Panel
Inherited | borderThicknessTop | Type: Number Format: Length CSS Inheritance: no Thickness of the top border of the Panel. | Panel
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | buttonStyleName | Type: String CSS Inheritance: no Name of the CSS style declaration that specifies styles for the Alert buttons. The default value is "alertButtonStyle". | Alert
Inherited | closeButtonDisabledSkin | Type: Class CSS Inheritance: no The close button disabled skin. | Panel
Inherited | closeButtonDownSkin | Type: Class CSS Inheritance: no The close button down skin. | Panel
Inherited | closeButtonOverSkin | Type: Class CSS Inheritance: no The close button over skin. | Panel
Inherited | closeButtonUpSkin | Type: Class CSS Inheritance: no The close button up skin. | Panel
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | controlBarStyleName | Type: String CSS Inheritance: no Name of the CSS style declaration that specifies styles to apply to any control bar child subcontrol. | Panel
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of corners of the window frame. | Panel
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that controls the visibility of the Panel container's drop shadow. | Panel
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | footerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the footer (area for the ControlBar container) background. | Panel
Inherited | headerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the header. | Panel
Inherited | headerHeight | Type: Number Format: Length CSS Inheritance: no Height of the header. | Panel
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alphas used for the highlight fill of the header. | Panel
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Panel
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Panel
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | messageStyleName | Type: String CSS Inheritance: no Name of the CSS style declaration that specifies styles for the Alert message text. The default value is undefined. | Alert
Inherited | modalTransparency | Type: Number CSS Inheritance: yes Modality of components launched by the PopUp Manager is simulated by creating a large translucent overlay underneath the component. | Panel
Inherited | modalTransparencyBlur | Type: Number CSS Inheritance: yes The blur applied to the application while a modal window is open. | Panel
Inherited | modalTransparencyColor | Type: uint Format: Color CSS Inheritance: yes Color of the modal overlay layer. | Panel
Inherited | modalTransparencyDuration | Type: Number Format: Time CSS Inheritance: yes Duration, in milliseconds, of the modal transparency effect that plays when a modal window opens or closes. | Panel
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's lower border and its content area. | Panel
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. | Panel
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | roundedBottomCorners | Type: Boolean CSS Inheritance: no Flag to enable rounding for the bottom two corners of the container. | Panel
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of drop shadow. | Panel
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of drop shadow. | Panel
Inherited | statusStyleName | Type: String CSS Inheritance: no Style declaration name for the status in the title bar. | Panel
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | titleBackgroundSkin | Type: Class CSS Inheritance: no The title background skin. | Panel
 | titleStyleName | Type: String CSS Inheritance: no Name of the CSS style declaration that specifies styles for the Alert title text. The default value is "windowStyles". | Alert
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Panel
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Panel
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | resizeEndEffect | Triggering event: resizeEnd Specifies the effect to play after a Resize effect finishes playing. | Panel
Inherited | resizeStartEffect | Triggering event: resizeStart Specifies the effect to play before a Resize effect begins playing. | Panel
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
 | CANCEL : uint = 0x0008 [static] Value that enables a Cancel button on the Alert control when passed as the flags parameter of the show() method. | Alert
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
 | NO : uint = 0x0002 [static] Value that enables a No button on the Alert control when passed as the flags parameter of the show() method. | Alert
 | NONMODAL : uint = 0x8000 [static] Value that makes an Alert nonmodal when passed as the flags parameter of the show() method. | Alert
 | OK : uint = 0x0004 [static] Value that enables an OK button on the Alert control when passed as the flags parameter of the show() method. | Alert
 | YES : uint = 0x0001 [static] Value that enables a Yes button on the Alert control when passed as the flags parameter of the show() method. | Alert
Property detail
buttonFlags property
public var buttonFlags:uint = 0x0004

A bitmask that contains Alert.OK, Alert.CANCEL, Alert.YES, and/or Alert.NO indicating the buttons available in the Alert control.

The default value is Alert.OK.

buttonHeight property
public static var buttonHeight:Number = 22

Height of each Alert button, in pixels. All buttons must be the same height.

The default value is 22.

buttonWidth property
public static var buttonWidth:Number = 60

Width of each Alert button, in pixels. All buttons must be the same width.

The default value is 60.

cancelLabel property
public static var cancelLabel:String = ""

The label for the Cancel button.

If you use a different label, you may need to adjust the buttonWidth property to fully display it.

The English resource bundle sets this property to "CANCEL".
defaultButtonFlag property
public var defaultButtonFlag:uint = 0x0004

A bitflag that contains either Alert.OK, Alert.CANCEL, Alert.YES, or Alert.NO to specify the default button.

The default value is Alert.OK.

iconClass property
public var iconClass:Class

The class of the icon to display. You typically embed an asset, such as a JPEG or GIF file, and then use the variable associated with the embedded asset to specify the value of this property.

The default value is null.

noLabel property
public static var noLabel:String = ""

The label for the No button.

If you use a different label, you may need to adjust the buttonWidth property to fully display it.

The English resource bundle sets this property to "NO".
okLabel property
public static var okLabel:String = ""

The label for the OK button.

If you use a different label, you may need to adjust the buttonWidth property to fully display the label.

The English resource bundle sets this property to "OK".
text property
public var text:String = ""

The text to display in this alert dialog box.

The default value is "".

yesLabel property
public static var yesLabel:String = ""

The label for the Yes button.

If you use a different label, you may need to adjust the buttonWidth property to fully display the label.

The English resource bundle sets this property to "YES".
Constructor detail
Alert () constructor
public function Alert()

Constructor.

Method detail
show () method
public static function show(text:String = "", title:String = "", flags:uint = 0x4, parent:Sprite = null, closeHandler:Function = null, iconClass:Class = null, defaultButtonFlag:uint = 0x4):Alert

Static method that pops up the Alert control. The Alert control closes when you select a button in the control, or press the Escape key.

Parameters
text:String (default = "") — Text string that appears in the Alert control. This text is centered in the alert dialog box.
title:String (default = "") — Text string that appears in the title bar. This text is left justified.
flags:uint (default = 0x4) — Which buttons to place in the Alert control. Valid values are Alert.OK, Alert.CANCEL, Alert.YES, and Alert.NO. The default value is Alert.OK. Use the bitwise OR operator to display more than one button. For example, passing (Alert.YES | Alert.NO) displays Yes and No buttons. Regardless of the order that you specify buttons, they always appear in the following order from left to right: OK, Yes, No, Cancel.
parent:Sprite (default = null) — Object upon which the Alert control centers itself.
closeHandler:Function (default = null) — Event handler that is called when any button on the Alert control is pressed. The event object passed to this handler is an instance of CloseEvent; the detail property of this object contains the value Alert.OK, Alert.CANCEL, Alert.YES, or Alert.NO.
iconClass:Class (default = null) — Class of the icon that is placed to the left of the text in the Alert control.
defaultButtonFlag:uint (default = 0x4) — A bitflag that specifies the default button. You can specify one and only one of Alert.OK, Alert.CANCEL, Alert.YES, or Alert.NO. The default value is Alert.OK. Pressing the Enter key triggers the default button just as if you clicked it. Pressing Escape triggers the Cancel or No button just as if you selected it.

Returns
Alert — A reference to the Alert control.

See also

mx.events.CloseEvent
Constant detail
CANCEL constant
public static const CANCEL:uint = 0x0008

Value that enables a Cancel button on the Alert control when passed as the flags parameter of the show() method. You can use the | operator to combine this bitflag with the OK, YES, NO, and NONMODAL flags.

NO constant
public static const NO:uint = 0x0002

Value that enables a No button on the Alert control when passed as the flags parameter of the show() method. You can use the | operator to combine this bitflag with the OK, CANCEL, YES, and NONMODAL flags.

NONMODAL constant
public static const NONMODAL:uint = 0x8000

Value that makes an Alert nonmodal when passed as the flags parameter of the show() method. You can use the | operator to combine this bitflag with the OK, CANCEL, YES, and NO flags.

OK constant
public static const OK:uint = 0x0004

Value that enables an OK button on the Alert control when passed as the flags parameter of the show() method. You can use the | operator to combine this bitflag with the CANCEL, YES, NO, and NONMODAL flags.

YES constant
public static const YES:uint = 0x0001

Value that enables a Yes button on the Alert control when passed as the flags parameter of the show() method. You can use the | operator to combine this bitflag with the OK, CANCEL, NO, and NONMODAL flags.

Examples
SimpleAlert
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Alert control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.controls.Alert;
            import mx.events.CloseEvent;

            // Event handler function uses a static method to show
            // a pop-up window with the title, message, and requested buttons.
            private function clickHandler(event:Event):void {
                Alert.show("Do you want to save your changes?", "Save Changes", 3, this, alertClickHandler);
            }

            // Event handler function for displaying the selected Alert button.
            private function alertClickHandler(event:CloseEvent):void {
                if (event.detail==Alert.YES)
                    status.text="You answered Yes";
                else
                    status.text="You answered No";
            }

        ]]>
    </mx:Script>

    <mx:Panel title="Alert Control Example" width="75%" horizontalAlign="center" paddingTop="10">
      <mx:Text width="100%" color="blue" textAlign="center"
          text="Click the button below to display a simple Alert window."/>
      <mx:Button label="Click Me" click="Alert.show('Hello World!', 'Message');"/>

      <mx:Text width="100%" color="blue" textAlign="center"
          text="Click the button below to display an Alert window and capture the button pressed by the user."/>
      <mx:Button label="Click Me" click="clickHandler(event);"/>
      <mx:Label id="status" fontWeight="bold"/>
    </mx:Panel>

</mx:Application>


mx.controls.Button (Flex™ 2 Language Reference)

Class Button | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Button
Inheritance | Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IFocusManagerComponent, IListItemRenderer
Subclasses | AccordionHeader, CheckBox, LinkButton, PopUpButton, RadioButton, ScrollThumb, SliderThumb

The Button control is a commonly used rectangular button. Button controls look like they can be pressed. They can have a text label, an icon, or both on their face.

Buttons typically use event listeners to perform an action when the user selects the control. When a user clicks the mouse on a Button control, and the Button control is enabled, it dispatches a click event and a buttonDown event. A button always dispatches events such as the mouseMove, mouseOver, mouseOut, rollOver, rollOut, mouseDown, and mouseUp events whether enabled or disabled.

You can customize the look of a Button control and change its functionality from a push button to a toggle button. You can change the button appearance by using a skin for each of the button's states.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Button> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Button
    Properties
    autoRepeat="false|true"
    emphasized="false|true"
    label=""
    labelPlacement="right|left|bottom|top"
    selected="false|true"
    selectedField="null"
    stickyHighlighting="false|true"
    toggle="false|true"

    Styles
    borderColor="0xAAB3B3"
    color="0x0B333C"
    cornerRadius="4"
    disabledColor="0xAAB3B3"
    disabledIcon="null"
    disabledSkin="mx.skins.halo.ButtonSkin"
    downIcon="null"
    downSkin="mx.skins.halo.ButtonSkin"
    fillAlphas="[0.6, 0.4]"
    fillColors="[0xE6EEEE, 0xFFFFFF]"
    focusAlpha="0.5"
    focusRoundedCorners"tl tr bl br"
    fontAntiAliasType="advanced"
    fontFamily="Verdana"
    fontGridFitType="pixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    highlightAlphas="[0.3, 0.0]"
    horizontalGap="2"
    icon="null"
    leading="2"
    overIcon="No default"
    overSkin="mx.skins.halo.ButtonSkin"
    paddingBottom="0"
    paddingLeft="0"
    paddingRight="0"
    paddingTop="0"
    repeatDelay="500"
    repeatInterval="35"
    selectedDisabledIcon="null"
    selectedDisabledSkin="mx.skins.halo.ButtonSkin"
    selectedDownIcon="No default"
    selectedDownSkin="mx.skins.halo.ButtonSkin"
    selectedOverIcon="null"
    selectedOverSkin="mx.skins.halo.ButtonSkin"
    selectedUpIcon="null"
    selectedUpSkin="mx.skins.halo.ButtonSkin"
    textAlign="center|left|right"
    textDecoration="none|underline"
    textIndent="0"
    textRollOverColor="0x2B333C"
    textSelectedColor="0x000000"
    upIcon="null"
    upSkin="mx.skins.halo.ButtonSkin"
    verticalGap="2"

    Events
    buttonDown="No default"
    change="No default"
    dataChange="No default"
  />

View the examples.

See also

Button control
Creating ActionScript components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | emphasized : Boolean Draws a thick border around the Button control when the control is in its up state if emphasized is set to true. | Button
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | label : String Text to appear on the Button control. | Button
 | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
 | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
 | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | toggle : Boolean Controls whether a Button is in a toggle state or not. | Button
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Button()
Constructor.
Button
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
 | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
 | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
 | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
 | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | buttonDown | Dispatched when the user presses the Button control. | Button
 | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The following controls support this style: Button, CheckBox, ComboBox, MenuBar, NumericStepper, ProgressBar, RadioButton, ScrollBar, Slider, and any components that support the borderStyle style. The default value depends on the component class; if not overriden for the class, the default value is 0xB7BABC. 		Button
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		Button
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The following components support this style: Alert, Button, ComboBox, LinkButton, MenuBar, NumericStepper, Panel, ScrollBar, Tab, TitleWindow, and any component that supports a borderStyle property set to "solid". The default value depends on the component class; if not overriden for the class, the default value is 0. 		Button
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		Button
disabledIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when the button is not disabled. The default value is null. 		Button
disabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the button is not selected and is disabled. The default value is "mx.skins.halo.ButtonSkin". 		Button
downIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when the button is not selected and the mouse button is down. The default value is null. 		Button
downSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. The default value is "mx.skins.halo.ButtonSkin". 		Button
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fillAlphas
Type: Array CSS Inheritance: no
Alphas used for the background fill of controls. Use [1, 1] to make the control background opaque. The default value is [ 0.6, 0.4 ]. 		Button
fillColors
Type: Array Format: Color CSS Inheritance: no
Colors used to tint the background of the control. Pass the same color for both values for a flat-looking control. The default value is [ 0xFFFFFF, 0xCCCCCC ]. 		Button
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		Button
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		Button
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		Button
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		Button
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		Button
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		Button
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		Button
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		Button
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		Button
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		Button
highlightAlphas
Type: Array CSS Inheritance: no
Alpha transparencies used for the highlight fill of controls. The first value specifies the transparency of the top of the highlight and the second value specifies the transparency of the bottom of the highlight. The highlight covers the top half of the skin. The default value is [ 0.3, 0.0 ]. 		Button
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
horizontalGap
Type: Number Format: Length CSS Inheritance: no
Gap between the label and icon, when the labelPlacement property is set to left or right. The default value is 2. 		Button
icon
Type: Class CSS Inheritance: no
Name of the class to use as the default icon. Setting any other icon style overrides this setting. The default value is null. 		Button
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

Button
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
overIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when the button is not selected and the mouse is over the control. The default value is null. 		Button
overSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. The default value is "mx.skins.halo.ButtonSkin". 		Button
paddingBottom
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's bottom border and the bottom of its content area. The default value is 0. 		Button
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

Button
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

Button
paddingTop
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's top border and the top of its content area. The default value is 0. 		Button
repeatDelay
Type: Number Format: Time CSS Inheritance: no
Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. The default value is 500. 		Button
repeatInterval
Type: Number Format: Time CSS Inheritance: no
Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. The default value is 35. 		Button
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
selectedDisabledIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when the button is selected and disabled. The default value is null. 		Button
selectedDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when a toggle button is selected and disabled. The default value is "mx.skins.halo.ButtonSkin". 		Button
selectedDownIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when the button is selected and the mouse button is down. The default value is null. 		Button
selectedDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down. The default value is "mx.skins.halo.ButtonSkin". 		Button
selectedOverIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when the button is selected and the mouse is over the control. The default value is null. 		Button
selectedOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control. The default value is "mx.skins.halo.ButtonSkin". 		Button
selectedUpIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when the button is selected and the mouse button is up. The default value is null. 		Button
selectedUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control. The default value is "mx.skins.halo.ButtonSkin". 		Button
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

Button
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		Button
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		Button
textRollOverColor
Type: uint Format: Color CSS Inheritance: yes
Text color of the label as the user moves the mouse pointer over the button. The default value is 0x2B333C. 		Button
textSelectedColor
Type: uint Format: Color CSS Inheritance: yes
Text color of the label as the user presses it. The default value is 0x000000. 		Button
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
upIcon
Type: Class CSS Inheritance: no
Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. The default value is null. 		Button
upSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. The default value is "mx.skins.halo.ButtonSkin". 		Button
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
verticalGap
Type: Number Format: Length CSS Inheritance: no
Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". The default value is 2. 		Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
autoRepeat property
autoRepeat:Boolean [read-write]

Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button.

The default value is false.

Implementation
    public function get autoRepeat():Boolean
    public function set autoRepeat(value:Boolean):void
data property
data:Object [read-write]

The data property lets you pass a value to the component when you use it as an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

When you use the control as a drop-in item renderer or drop-in item editor, Flex automatically writes the current value of the item to the selected property of this control.

You do not set this property in MXML.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
emphasized property
emphasized:Boolean [read-write]

Draws a thick border around the Button control when the control is in its up state if emphasized is set to true.

The default value is false.

Implementation
    public function get emphasized():Boolean
    public function set emphasized(value:Boolean):void
label property
label:String [read-write]

Text to appear on the Button control.

If the label is wider than the Button control, the label is truncated and terminated by an ellipsis (...). The full label displays as a tooltip when the user moves the mouse over the Button control. If you have also set a tooltip by using the tooltip property, the tooltip is displayed rather than the label text.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get label():String
    public function set label(value:String):void
labelPlacement property
labelPlacement:String [read-write]

Orientation of the label in relation to a specified icon. Valid MXML values are right, left, bottom, and top.

In ActionScript, you can use the following constants to set this property: ButtonLabelPlacement.RIGHT, ButtonLabelPlacement.LEFT, ButtonLabelPlacement.BOTTOM, and ButtonLabelPlacement.TOP.

The default value is ButtonLabelPlacement.RIGHT.

This property can be used as the source for data binding.

Implementation
    public function get labelPlacement():String
    public function set labelPlacement(value:String):void
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. The component can then use the listData property to initialize the data property of the drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
selected property
selected:Boolean [read-write]

Indicates whether a toggle button is toggled on (true) or off (false). This property can be set only if the toggle property is set to true.

For a CheckBox control, indicates whether the box is displaying a check mark. For a RadioButton control, indicates whether the control is selected.

The user can change this property by clicking the control, but you can also set the property programmatically.

If the toggle property is set to true, changing this property also dispatches a change event.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get selected():Boolean
    public function set selected(value:Boolean):void
selectedField property
public var selectedField:String = "null"

The name of the field in the data property which specifies the value of the Button control's selected property. You can set this property when you use the Button control in an item renderer. The default value is null, which means that the Button control does not set its selected state based on a property in the data property.

The default value is null.

stickyHighlighting property
public var stickyHighlighting:Boolean = false

If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. If true, the Button displays its down skin when the user presses it, and continues to display this skin when the user drags the mouse off of it.

Button subclasses, such as the SliderThumb and ScrollThumb classes or the up and down arrows of a ScrollBar, set this property to true.

The default value is false.

textField property
protected var textField:UITextField

The internal UITextField object that renders the label of this Button.

The default value is null.

toggle property
toggle:Boolean [read-write]

Controls whether a Button is in a toggle state or not. If true, clicking the button toggles it between a selected and an unselected state. You can get or set this state programmatically by using the selected property. If false, the button does not stay pressed after the user releases it. In this case, its selected property is always false. Buttons like this are used for performing actions. When toggle is set to false, selected is forced to false because only toggle buttons can be selected.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get toggle():Boolean
    public function set toggle(value:Boolean):void
Constructor detail
Button () constructor
public function Button()

Constructor.

Method detail
clickHandler () method
protected function clickHandler(event:MouseEvent):void

The default handler for the MouseEvent.CLICK event.

Parameters
event:MouseEvent — event object.
mouseDownHandler () method
protected function mouseDownHandler(event:MouseEvent):void

The default handler for the MouseEvent.MOUSE_DOWN event.

Parameters
event:MouseEvent — event object.
mouseUpHandler () method
protected function mouseUpHandler(event:MouseEvent):void

The default handler for the MouseEvent.MOUSE_UP event.

Parameters
event:MouseEvent — event object.
rollOutHandler () method
protected function rollOutHandler(event:MouseEvent):void

The default handler for the MouseEvent.ROLL_OUT event.

Parameters
event:MouseEvent — event object.
rollOverHandler () method
protected function rollOverHandler(event:MouseEvent):void

The default handler for the MouseEvent.ROLL_OVER event.

Parameters
event:MouseEvent — event object.
Event detail
buttonDown event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.BUTTON_DOWN

Dispatched when the user presses the Button control. If the autoRepeat property is true, this event is dispatched repeatedly as long as the button stays down.

The FlexEvent.BUTTON_DOWN constant defines the value of the type property of the event object for a buttonDown event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched when the selected property changes for a toggle Button control. A toggle Button control means that the toggle property is set to true. For the CheckBox and RadioButton controls, this event is dispatched when the selected property changes.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
ButtonExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Button control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import flash.events.Event;

            // Event handler function to print a message
            // describing the selected Button control.
            private function printMessage(event:Event):void  {
              message.text += event.target.label + " pressed" + "\n";
            }

      ]]>
    </mx:Script>

    <mx:Panel title="Button Control Example"
        height="75%" width="75%" layout="horizontal"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:VBox>
            <mx:Label width="100%" color="blue"
                text="Select a Button control."/>

             <!-- The button can contain an image, as in the "Button with Icon" button -->
             <mx:Button id="iconButton" icon="@Embed('assets/mm-icon.png')" label="Button with Icon"
                 labelPlacement="right" color="#993300" click="printMessage(event);"/>

             <!-- The size of the button and the label attributes can be customized -->
             <mx:Button label="Customized Button" color="#993300" toggle="true" selected="true"
                 textAlign="left" fontStyle="italic" fontSize="13" width="{iconButton.width}"
                 click="printMessage(event);"/>

             <!-- By default, the look and feel of the customized button is
                 similar to the Default Button.  -->
             <mx:Button label="Default Button" click="printMessage(event);"/>
        </mx:VBox>

         <mx:TextArea id="message" text="" editable="false" height="100%" width="100%"
             color="#0000FF"/>

    </mx:Panel>
</mx:Application>


mx.controls.ButtonBar (Flex™ 2 Language Reference)

Class ButtonBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class ButtonBar
Inheritance | ButtonBar Inheritance NavBar Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerComponent
Subclasses | ToggleButtonBar

The ButtonBar control defines a horizontal or vertical group of logically related push buttons with a common look and navigation.

A push button is one that does not remember its selected state when selected. The typical use for a push button in a button bar is for grouping a set of related buttons together, which gives them a common look and navigation, and handling the logic for the click event in a single place.

You can use the ToggleButtonBar control to define a group of toggle buttons.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ButtonBar> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:ButtonBar
    Styles
    buttonHeight="undefined"
    buttonStyleName="Name of CSS style declaration, which specifies
    styles for the buttons"
    buttonWidth="undefined"
    firstButtonStyleName="The value of buttonStyleName"
    focusAlpha="0.5"
    focusRoundedCorners="tl tr bl br"
    horizontalAlign="center|left|right"
    horizontalGap="0"
    lastButtonStyleName="The value of buttonStyleName"
    verticalAlign="middle|top|bottom"
    verticalGap="0"

    Events
    itemClick="No default"
    >
    ...
       child tags
    ...
  </mx:ButtonBar>

Default MXML Property dataProvider

View the examples.

See also

mx.controls.ToggleButtonBar
ButtonBar and ToggleButtonBar controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | dataProvider : Object Data used to populate the navigator control. | NavBar
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String The direction in which this Box container lays out its children. | Box
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | iconField : String Name of the field in the dataProvider object to display as the icon for each navigation item. | NavBar
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelField : String Name of the field in the dataProvider object to display as the label for each navigation item. | NavBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selectedIndex : int Index of the active navigation item, where the first item is at an index of 0. | NavBar
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | toolTipField : String Name of the the field in the dataProvider object to display as the tooltip label. | NavBar
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ButtonBar()
Constructor.
ButtonBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void Handles the MouseEvent.CLICK event for the items in the NavBar control. | NavBar
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | createNavItem(label:String, icon:Class = null):IFlexDisplayObject Creates the individual navigator items. | NavBar
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | hiliteSelectedNavItem(index:int):void Highlights the selected navigator item. | NavBar
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | resetNavItems():void Resets the navigator bar to its default state. | NavBar
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Inherited | updateNavItemIcon(index:int, icon:Class):void Resets the icon of a navigator item in the NavBar control. | NavBar
Inherited | updateNavItemLabel(index:int, label:String):void Sets the label property of a navigator item in the NavBar control. | NavBar
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when a user clicks a button. | ButtonBar
Inherited | itemClick | Dispatched when a navigation item is selected. | NavBar
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | buttonHeight | Type: Number Format: Length CSS Inheritance: no Height of each button, in pixels. If undefined, the height of each button is determined by the font styles applied to the container. If you set this property, the specified value overrides this calculation. | ButtonBar
 | buttonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the buttons. | ButtonBar
 | buttonWidth | Type: Number Format: Length CSS Inheritance: no Width of each button, in pixels. If undefined, the default width of each button is calculated from its label text. | ButtonBar
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | firstButtonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the first button. If this is unspecified, the default value of the buttonStyleName style property is used. | ButtonBar
 | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. The default value is 0.4. | ButtonBar
 | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". | ButtonBar
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of the tabs. Possible values are "left", "center", and "right". The default value is "center". | ButtonBar
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value is 0. | ButtonBar
 | lastButtonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the last button. If this is unspecified, the default value of the buttonStyleName style property is used. | ButtonBar
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of the tabs. Possible values are "top", "middle", and "bottom". The default value is "middle". | ButtonBar
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value is 0. | ButtonBar
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
ButtonBar () constructor
public function ButtonBar()

Constructor.

Event detail
itemClick event
Event object type: mx.events.ItemClickEvent
ItemClickEvent.type property = mx.events.ItemClickEvent.ITEM_CLICK

Dispatched when a user clicks a button. This event is only dispatched if the dataProvider property does not refer to a ViewStack container.

The ItemClickEvent.ITEM_CLICK constant defines the value of the type property of the event object for an itemClick event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index of the navigation item that was clicked.
item | The item in the data provider of the navigation item that was clicked.
label | The label of the navigation item that was clicked.
relatedObject | The child object that generated the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
ButtonBarExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ButtonBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.events.ItemClickEvent;

            // Event handler function to print a message
            // describing the selected Button control.
            private function clickHandler(event:ItemClickEvent):void {
                myTA.text="Selected button index: " + String(event.index) +
                    "\n" + "Selected button label: " + event.label;
            }
        ]]>
    </mx:Script>

    <mx:Panel title="ButtonBar Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

       <mx:Label width="100%" color="blue"
           text="Select a button in the ButtonBar control."/>

        <mx:TextArea id="myTA" width="100%" height="100%"/>

        <mx:ButtonBar horizontalGap="5" itemClick="clickHandler(event);">
            <mx:dataProvider>
                <mx:Array>
                    <mx:String>Flash</mx:String>
                    <mx:String>Director</mx:String>
                    <mx:String>Dreamweaver</mx:String>
                    <mx:String>ColdFusion</mx:String>
                </mx:Array>
            </mx:dataProvider>
        </mx:ButtonBar>
    </mx:Panel>
</mx:Application>


mx.controls.ButtonLabelPlacement (Flex™ 2 Language Reference)

Class ButtonLabelPlacement | Properties | Methods | Constants
Package | mx.controls
Class | public final class ButtonLabelPlacement
Inheritance | ButtonLabelPlacement Inheritance Object

The ButtonLabelPlacement class defines the constants for the allowed values of the labelPlacement property of a Button, CheckBox, LinkButton, or RadioButton control.

See also

mx.controls.Button
mx.controls.CheckBox
mx.controls.LinkButton
mx.controls.RadioButton

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BOTTOM : String = "bottom" [static] Specifies that the label appears below the icon. | ButtonLabelPlacement
 | LEFT : String = "left" [static] Specifies that the label appears to the left of the icon. | ButtonLabelPlacement
 | RIGHT : String = "right" [static] Specifies that the label appears to the right of the icon. | ButtonLabelPlacement
 | TOP : String = "top" [static] Specifies that the label appears above the icon. | ButtonLabelPlacement
Constant detail
BOTTOM constant
public static const BOTTOM:String = "bottom"

Specifies that the label appears below the icon.

LEFT constant
public static const LEFT:String = "left"

Specifies that the label appears to the left of the icon.

RIGHT constant
public static const RIGHT:String = "right"

Specifies that the label appears to the right of the icon.

TOP constant
public static const TOP:String = "top"

Specifies that the label appears above the icon.


mx.controls.CheckBox (Flex™ 2 Language Reference)

Class CheckBox | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class CheckBox
Inheritance | CheckBox Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The CheckBox control consists of an optional label and a small box that can contain a check mark or not. You can place the optional text label to the left, right, top, or bottom of the CheckBox. When a user clicks a CheckBox control or its associated text, the CheckBox control changes its state from checked to unchecked or from unchecked to checked. CheckBox controls gather a set of true or false values that are not mutually exclusive.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:CheckBox> tag inherits all of the tag attributes of its superclass and adds no new tag attributes.

View the examples.

See also

CheckBox control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
Inherited | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CheckBox()
Constructor.
CheckBox
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Button
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Button
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | Button
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | Button
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | selectedDisabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and disabled. | Button
Inherited | selectedDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and disabled. | Button
Inherited | selectedDownIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is down. | Button
Inherited | selectedDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down. | Button
Inherited | selectedOverIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse is over the control. | Button
Inherited | selectedOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control. | Button
Inherited | selectedUpIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is up. | Button
Inherited | selectedUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control. | Button
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user moves the mouse pointer over the button. | Button
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user presses it. | Button
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
CheckBox () constructor
public function CheckBox()

Constructor.

Examples
CheckBoxExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the CheckBox control -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

           import mx.controls.Alert;

           // This event handler adds and deletes items from the shopping cart.
           private function modifyCart():void
           {
                cartItems.text = "";

                if(milkCB.selected == true) {
                    cartItems.text += "milk" + '\n' ;
                }

                   if(eggsCB.selected == true) {
                    cartItems.text += "eggs" + '\n';
                }

                if(breadCB.selected == true) {
                    cartItems.text +="bread" + '\n';
                }
              }

           // This event handler opens the Alert control.
           private function sendMessage():void
           {
                if(couponCB.selected == true) {
                  Alert.show('You will receive coupons.');
                }
                else {
                    Alert.show('You will not receive any coupons.');
                }
           }
        ]]>
    </mx:Script>

    <mx:Panel title="CheckBox Control Example"
        height="75%" width="75%" layout="horizontal"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:VBox>
            <mx:CheckBox id="milkCB" label="milk" click="modifyCart()"/>
            <mx:CheckBox id="eggsCB" label="eggs" click="modifyCart()"/>
            <mx:CheckBox id="breadCB" label="bread" click="modifyCart()"/>
        </mx:VBox>

        <mx:VBox>
            <mx:Label text="Items in my cart "/>
            <mx:TextArea id="cartItems" width="300" height="50" verticalScrollPolicy="off"/>
            <!-- Event handler sendMessages() is used to handle event click -->
            <mx:CheckBox id="couponCB" label="Send me coupons for items in my cart"
                click="sendMessage()" selected="true" color="blue"/>
        </mx:VBox>
    </mx:Panel>
</mx:Application>


mx.controls.ColorPicker (Flex™ 2 Language Reference)

Class ColorPicker | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class ColorPicker
Inheritance | ColorPicker Inheritance ComboBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The ColorPicker control provides a way for a user to choose a color from a swatch list. The default mode of the component shows a single swatch in a square button. When the user clicks the swatch button, the swatch panel appears and displays the entire swatch list.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ColorPicker> tag inherits all of the properties of its superclass, and the following properties:

  <mx:ColorPicker
    Properties
    colorField="color"
    labelField="label"
    selectedColor="0x000000"
    selectedIndex="0"
    showTextField="true|false"

    Styles
    backgroundColor="0xE5E6E7"
    borderColor="0xA5A9AE"
    closeDuration="250"
    closeEasingFunction="undefined"
    color="0x0B333C"
    columnCount="20"
    fillAlphas="[0.6,0.4]"
    fillColors="[0xFFFFFF, 0xCCCCCC]"
    focusAlpha="0.5"
    FocusRoundedCorners="tl tr bl br"
    fontAntiAliasType="advanced"
    fontfamily="Verdana"
    fontGridFitType="pixel"
    fontSharpness="0""
    fontSize="10"
    fontStyle="normal"
    fontThickness="0"
    fontWeight="normal"
    highlightAlphas="[0.3,0.0]"
    horizontalGap="0"
    leading="2"
    openDuration="250"
    openEaingFunctin="undefined"
    paddingBottom="5"
    paddingLeft="5"
    paddingRight="5"
    paddingTop="4"
    previewHeight="22"
    previewWidth="45"
    swatchBorderColor="0x000000"
    swatchBorderSize="1"
    swatchGridBackgroundColor="0x000000"
    swatchGridBorderSize="0"
    swatchHeight="12"
    swatchHighlightColor="0xFFFFFF"
    swatchHighlightSize="1"
    swatchPanelStyleName="undefined"
    swatchWidth="12"
    textAlign="left"
    textDecoration="none"
    textFieldWidth="72"
    textIndent="0"
    verticalGap="0"

    Events
    change="No default"
    close="No default"
    enter="No default"
    itemRollOut="No default"
    itemRollOver="No default"
    open="No default"
    />

View the examples.

See also

mx.controls.List
mx.effects.Tween
mx.managers.PopUpManager
ColorPicker control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | colorField : String Name of the field in the objects of the dataProvider Array that specifies the hexadecimal values of the colors that the swatch panel displays. | ColorPicker
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataProvider : Object The set of items this component displays. | ComboBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | editable : Boolean A flag that indicates whether the control is editable, which lets the user directly type entries that are not specified in the dataProvider, or not editable, which requires the user select from the items in the dataProvider. | ComboBase
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | imeMode : String Specifies the IME (input method editor) mode. | ComboBase
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | labelField : String Name of the field in the objects of the dataProvider Array that contain text to display as the label in the SwatchPanel object text box. | ColorPicker
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | restrict : String Set of characters that a user can or cannot enter into the text field. | ComboBase
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedColor : uint The value of the currently selected color in the SwatchPanel object. | ColorPicker
 | selectedIndex : int [write-only] Index in the dataProvider of the selected item in the SwatchPanel object. | ColorPicker
Inherited | selectedItem : Object The item in the data provider at the selectedIndex. | ComboBase
 | showTextField : Boolean Specifies whether to show the text box that displays the color label or hexadecimal color value. | ColorPicker
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The value of the selected item. | ComboBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ComboBase
Inherited | collection : ICollectionView The ICollectionView of items this component displays. | ComboBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the dataProvider and pass the items to the renderers. | ComboBase
Inherited | textInput : TextInput The internal TextInput subcomponent that displays the current selection. | ComboBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ColorPicker()
Constructor.
ColorPicker
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
close(trigger:Event = null):void
Hides the drop-down SwatchPanel object.
ColorPicker
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
open():void
Displays the drop-down SwatchPanel object that shows colors that users can select.
ColorPicker
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | calculatePreferredSizeFromData(numItems:int):Object Determines default values of the height and width to use for the entries in the drop-down list. | ComboBase
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | collectionChangeHandler(event:Event):void Responds to changes to the data provider. | ComboBase
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | downArrowButton_buttonDownHandler(event:FlexEvent):void Performs some action when the drop-down button is pressed. | ComboBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | itemToUID(data:Object):String Determines the UID for a dataProvider item. | ComboBase
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Determines the measuredWidth and measuredHeight properties of the control. | ComboBase
Inherited | textInput_changeHandler(event:Event):void Handles changes to the TextInput that serves as the editable text field in the component. | ComboBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sizes and positions the internal components in the given width and height. | ComboBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the selected color changes as a result of user interaction. | ColorPicker
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | close | Dispatched when the swatch panel closes. | ColorPicker
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
 | enter | Dispatched if the ColorPicker editable property is set to true and the user presses Enter after typing in a hexadecimal color value. | ColorPicker
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemRollOut | Dispatched when the user rolls the mouse out of a swatch in the SwatchPanel object. | ColorPicker
 | itemRollOver | Dispatched when the user rolls the mouse over a swatch in the SwatchPanel object. | ColorPicker
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
 | open | Dispatched when the color swatch panel opens. | ColorPicker
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Color of the SwatchPanel object's background. The default value is 0xE5E6E7. 		ColorPicker
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the outer border on the SwatchPanel object. The default value is 0xA5A9AE. 		ColorPicker
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
closeDuration
Type: Number Format: Time CSS Inheritance: no
Length of a close transition, in milliseconds. The default value is 250. 		ColorPicker
closeEasingFunction
Type: Function CSS Inheritance: no
Easing function to control component tweening. The default value is undefined. 		ColorPicker
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		ColorPicker
columnCount
Type: int CSS Inheritance: no
Number of columns in the swatch grid. The default value is 20. 		ColorPicker
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		ColorPicker
Inherited
disabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the control is disabled. 		ComboBase
Inherited
downSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the user holds down the mouse button. 		ComboBase
Inherited
editableDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the control is disabled, and the editable property is true. 		ComboBase
Inherited
editableDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the user holds down the mouse button, and the editable property is true. 		ComboBase
Inherited
editableOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is over the control, and the editable property is true. 		ComboBase
Inherited
editableUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is not over the control, and the editable property is true. 		ComboBase
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fillAlphas
Type: Array CSS Inheritance: no
Alphas used for the background fill of controls. The default value is [ 0.6, 0.4 ]. 		ColorPicker
fillColors
Type: Array Format: Color CSS Inheritance: no
Colors used to tint the background of the control. Pass the same color for both values for a flat-looking control. The default value is [ 0xFFFFFF, 0xCCCCCC ]. 		ColorPicker
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		ColorPicker
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		ColorPicker
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		ColorPicker
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		ColorPicker
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		ColorPicker
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ColorPicker
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		ColorPicker
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		ColorPicker
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ColorPicker
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		ColorPicker
highlightAlphas
Type: Array CSS Inheritance: no
Alphas used for the highlight fill of controls. The default value is [ 0.3, 0.0 ]. 		ColorPicker
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
horizontalGap
Type: Number Format: Length CSS Inheritance: no
Horizontal gap between swatches in the swatch grid. The default value is 0. 		ColorPicker
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

ColorPicker
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
openDuration
Type: Number Format: Time CSS Inheritance: no
Length of an open transition, in milliseconds. The default value is 250. 		ColorPicker
openEasingFunction
Type: Function CSS Inheritance: no
Easing function to control component tweening. The default value is undefined. 		ColorPicker
Inherited
overSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is over the control. 		ComboBase
paddingBottom
Type: Number Format: Length CSS Inheritance: no
Bottom padding of SwatchPanel object below the swatch grid. The default value is 5. 		ColorPicker
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Left padding of SwatchPanel object to the side of the swatch grid. The default value is 5. 		ColorPicker
paddingRight
Type: Number Format: Length CSS Inheritance: no
Right padding of SwatchPanel object to the side of the swatch grid. The default value is 5. 		ColorPicker
paddingTop
Type: Number Format: Length CSS Inheritance: no
Top padding of SwatchPanel object above the swatch grid. The default value is 4. 		ColorPicker
previewHeight
Type: Number Format: Length CSS Inheritance: no
Height of the larger preview swatch that appears above the swatch grid on the upper left of the SwatchPanel object. The default value is 22. 		ColorPicker
previewWidth
Type: Number Format: Length CSS Inheritance: no
Width of the larger preview swatch. The default value is 45. 		ColorPicker
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
swatchBorderColor
Type: uint Format: Color CSS Inheritance: no
Color of the swatches' borders. The default value is 0x000000. 		ColorPicker
swatchBorderSize
Type: Number Format: Length CSS Inheritance: no
Size of the outlines of the swatches' borders. The default value is 1. 		ColorPicker
swatchGridBackgroundColor
Type: uint Format: Color CSS Inheritance: no
Color of the background rectangle behind the swatch grid. The default value is 0x000000. 		ColorPicker
swatchGridBorderSize
Type: Number Format: Length CSS Inheritance: no
Size of the single border around the grid of swatches. The default value is 0. 		ColorPicker
swatchHeight
Type: Number Format: Length CSS Inheritance: no
Height of each swatch. The default value is 12. 		ColorPicker
swatchHighlightColor
Type: uint Format: Color CSS Inheritance: no
Color of the highlight that appears around the swatch when the user rolls over a swatch. The default value is 0xFFFFFF. 		ColorPicker
swatchHighlightSize
Type: Number Format: Length CSS Inheritance: no
Size of the highlight that appears around the swatch when the user rolls over a swatch. The default value is 1. 		ColorPicker
swatchPanelStyleName
Type: String CSS Inheritance: no
Name of the style for the SwatchPanel object. The default value is undefined 		ColorPicker
swatchWidth
Type: Number Format: Length CSS Inheritance: no
Width of each swatch. The default value is 12. 		ColorPicker
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

ColorPicker
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		ColorPicker
textFieldWidth
Type: Number Format: Length CSS Inheritance: no
Width of the text box that appears above the swatch grid. The default value is 72. 		ColorPicker
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		ColorPicker
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
upSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is not over the control. 		ComboBase
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
verticalGap
Type: Number Format: Length CSS Inheritance: no
Vertical gap between swatches in the grid. The default value is 0. 		ColorPicker
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
colorField property
colorField:String [read-write]

Name of the field in the objects of the dataProvider Array that specifies the hexadecimal values of the colors that the swatch panel displays.

If the dataProvider objects do not contain a color field, set the colorField property to use the correct field name. This property is available, but not meaningful, if the dataProvider is an Array of hexadecimal color values.

The default value is "color".

This property can be used as the source for data binding.

Implementation
    public function get colorField():String
    public function set colorField(value:String):void
labelField property
labelField:String [read-write]

Name of the field in the objects of the dataProvider Array that contain text to display as the label in the SwatchPanel object text box.

If the dataProvider objects do not contain a label field, set the labelField property to use the correct field name. This property is available, but not meaningful, if the dataProvider is an Array of hexadecimal color values.

The default value is "label".

This property can be used as the source for data binding.

Implementation
    public function get labelField():String
    public function set labelField(value:String):void
selectedColor property
selectedColor:uint [read-write]

The value of the currently selected color in the SwatchPanel object. In the <mx:ColorPicker> tag only, you can set this property to a standard string color name, such as "blue". If the dataProvider contains an entry for black (0x000000), the default value is 0; otherwise, the default value is the color of the item at index 0 of the data provider.

This property can be used as the source for data binding.

Implementation
    public function get selectedColor():uint
    public function set selectedColor(value:uint):void
selectedIndex property
selectedIndex:int [write-only]

Index in the dataProvider of the selected item in the SwatchPanel object. Setting this property sets the selected color to the color that corresponds to the index, sets the selected index in the drop-down swatch to the selectedIndex property value, and displays the associated label in the text box. The default value is the index corresponding to black(0x000000) color if found, else it is 0.

This property can be used as the source for data binding.

Implementation
    public function set selectedIndex(value:int):void
showTextField property
showTextField:Boolean [read-write]

Specifies whether to show the text box that displays the color label or hexadecimal color value.

The default value is true.

Implementation
    public function get showTextField():Boolean
    public function set showTextField(value:Boolean):void
Constructor detail
ColorPicker () constructor
public function ColorPicker()

Constructor.

Method detail
close () method
public function close(trigger:Event = null):void

Hides the drop-down SwatchPanel object.

Parameters
trigger:Event (default = null)
open () method
public function open():void

Displays the drop-down SwatchPanel object that shows colors that users can select.

Event detail
change event
Event object type: mx.events.ColorPickerEvent
ColorPickerEvent.type property = mx.events.ColorPickerEvent.CHANGE

Dispatched when the selected color changes as a result of user interaction.

The ColorPickerEvent.CHANGE constant defines the value of the type property of the event that is dispatched when the user selects a color from the ColorPicker control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color that was selected.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The zero-based index in the Color's data provider that corresponds to the color that was selected.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
close event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.CLOSE

Dispatched when the swatch panel closes.

The DropdownEvent.CLOSE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
enter event
Event object type: mx.events.ColorPickerEvent
ColorPickerEvent.type property = mx.events.ColorPickerEvent.ENTER

Dispatched if the ColorPicker editable property is set to true and the user presses Enter after typing in a hexadecimal color value.

The ColorPickerEvent.ENTER constant defines the value of the type property of the event that is dispatched when the user presses the Enter key after typing in the color selector box.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color that was entered.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | Always -1.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
itemRollOut event
Event object type: mx.events.ColorPickerEvent
ColorPickerEvent.type property = mx.events.ColorPickerEvent.ITEM_ROLL_OUT

Dispatched when the user rolls the mouse out of a swatch in the SwatchPanel object.

The ColorPickerEvent.ITEM_ROLL_OUT constant defines the value of the type property of the event that is dispatched when the user rolls the mouse out of a swatch in the swatch panel.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color of the color that was rolled over.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The zero-based index in the Color's data provider that corresponds to the color that was rolled over.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
itemRollOver event
Event object type: mx.events.ColorPickerEvent
ColorPickerEvent.type property = mx.events.ColorPickerEvent.ITEM_ROLL_OVER

Dispatched when the user rolls the mouse over a swatch in the SwatchPanel object.

The ColorPickerEvent.ITEM_ROLL_OVER constant defines the value of the type property of the event that is dispatched when the user rolls the mouse over of a swatch in the swatch panel.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color of the color that the user rolled out of.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The zero-based index in the Color's data provider that corresponds to the color that the user rolled out of.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
open event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.OPEN

Dispatched when the color swatch panel opens.

The DropdownEvent.OPEN constant defines the value of the type property of the event object for a open event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
Examples
ColorPickerExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ColorPicker control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="ColorPicker Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
           text="Select the background color of the VBox container."/>
        <mx:ColorPicker id="cp" showTextField="true" selectedColor="0xFFFFFF"/>

        <mx:VBox width="100%" height="100%" backgroundColor="{cp.selectedColor}" borderStyle="solid"/>
        <mx:Label color="blue" text="selectedColor: 0x{cp.selectedColor.toString(16)}"/>
    </mx:Panel>
</mx:Application>


mx.controls.ComboBase (Flex™ 2 Language Reference)

Class ComboBase | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls
Class | public class ComboBase
Inheritance | ComboBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerComponent, IIMESupport
Subclasses | ColorPicker, ComboBox, DateField

The ComboBase class is the base class for controls that display text in a text field and have a button that causes a drop-down list to appear where the user can choose which text to display. The ComboBase class is not used directly as an MXML tag.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ComboBase> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:tagname
    Properties
    dataProvider="null"
    editable="false|true"
    imeMode="null"
    restrict="null"
    selectedIndex="-1"
    selectedItem="null"
    text=""

    Styles
    disabledSkin="Depends on class"
    downSkin="Depends on class"
    editableDisabledSkin="Depends on class"
    editableDownSkin="Depends on class"
    editableOverSkin="Depends on class"
    editableUpSkin="Depends on class"
    overSkin="Depends on class"
    upSkin="Depends on class"
   />

See also

mx.controls.Button
mx.controls.TextInput
mx.collections.ICollectionView

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | dataProvider : Object The set of items this component displays. | ComboBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | editable : Boolean A flag that indicates whether the control is editable, which lets the user directly type entries that are not specified in the dataProvider, or not editable, which requires the user select from the items in the dataProvider. | ComboBase
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
 | imeMode : String Specifies the IME (input method editor) mode. | ComboBase
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | restrict : String Set of characters that a user can or cannot enter into the text field. | ComboBase
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedIndex : int The index in the data provider of the selected item. | ComboBase
 | selectedItem : Object The item in the data provider at the selectedIndex. | ComboBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String Contents of the text field. | ComboBase
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | value : Object [read-only] The value of the selected item. | ComboBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | borderMetrics : EdgeMetrics [read-only] Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ComboBase
 | collection : ICollectionView The ICollectionView of items this component displays. | ComboBase
 | iterator : IViewCursor The main IViewCursor used to fetch items from the dataProvider and pass the items to the renderers. | ComboBase
 | textInput : TextInput The internal TextInput subcomponent that displays the current selection. | ComboBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ComboBase()
Constructor.
ComboBase
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
 | calculatePreferredSizeFromData(numItems:int):Object Determines default values of the height and width to use for the entries in the drop-down list. | ComboBase
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
 | collectionChangeHandler(event:Event):void Responds to changes to the data provider. | ComboBase
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
 | downArrowButton_buttonDownHandler(event:FlexEvent):void Performs some action when the drop-down button is pressed. | ComboBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
 | itemToUID(data:Object):String Determines the UID for a dataProvider item. | ComboBase
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Determines the measuredWidth and measuredHeight properties of the control. | ComboBase
 | textInput_changeHandler(event:Event):void Handles changes to the TextInput that serves as the editable text field in the component. | ComboBase
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sizes and positions the internal components in the given width and height. | ComboBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the control is disabled. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. For the ColorPicker class, the default value is the ColorPickerSkin class. For the DateField class, the default value is the ScrollArrowDownSkin class. | ComboBase
 | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the user holds down the mouse button. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. For the ColorPicker class, the default value is the ColorPickerSkin class. For the DateField class, the default value is the ScrollArrowDownSkin class. | ComboBase
 | editableDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the control is disabled, and the editable property is true. This skin is only used by the ComboBox class. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. | ComboBase
 | editableDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the user holds down the mouse button, and the editable property is true. This skin is only used by the ComboBox class. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. | ComboBase
 | editableOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the mouse is over the control, and the editable property is true. This skin is only used by the ComboBox class. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. | ComboBase
 | editableUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the mouse is not over the control, and the editable property is true. This skin is only used by the ComboBox class. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. | ComboBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the mouse is over the control. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. For the ColorPicker class, the default value is the ColorPickerSkin class. For the DateField class, the default value is the ScrollArrowDownSkin class. | ComboBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the mouse is not over the control. For the ComboBase class, there is no default value. For the ComboBox class, the default value is the ComboBoxArrowSkin class. | ComboBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
borderMetrics property
borderMetrics:EdgeMetrics [read-only]

Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. The value of each property is equal to the thickness of the corresponding side of the border, expressed in pixels.

Implementation
    protected function get borderMetrics():EdgeMetrics
collection property
protected var collection:ICollectionView

The ICollectionView of items this component displays.

dataProvider property
dataProvider:Object [read-write]

The set of items this component displays. This property is of type Object because the derived classes can handle a variety of data types such as Arrays, XML, ICollectionViews, and other classes. All are converted into an ICollectionView and that ICollectionView is returned if you get the value of this property; you will not get the value you set if it was not an ICollectionView.

Setting this property will adjust the selectedIndex property (and therefore the selectedItem property) if the selectedIndex property has not otherwise been set. If there is no prompt property, the selectedIndex property will be set to 0; otherwise it will remain at -1, the index used for the prompt string. If the selectedIndex property has been set and it is out of range of the new data provider, unexpected behavior is likely to occur.

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
editable property
editable:Boolean [read-write]

A flag that indicates whether the control is editable, which lets the user directly type entries that are not specified in the dataProvider, or not editable, which requires the user select from the items in the dataProvider.

If true keyboard input will be entered in the editable text field; otherwise it will be used as shortcuts to select items in the dataProvider.

The default value is false. This property is ignored by the DateField control..

This property can be used as the source for data binding.

Implementation
    public function get editable():Boolean
    public function set editable(value:Boolean):void
imeMode property
imeMode:String [read-write]

Specifies the IME (input method editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the specified IME mode when the control gets the focus, and sets it back to the previous value when the control loses the focus.

The flash.system.IMEConversionMode class defines constants for the valid values for this property. You can also specify null to specify no IME.

The default value is null.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void
iterator property
protected var iterator:IViewCursor

The main IViewCursor used to fetch items from the dataProvider and pass the items to the renderers. At the end of any sequence of code, it must always be positioned at the topmost visible item on screen.

restrict property
restrict:String [read-write]

Set of characters that a user can or cannot enter into the text field.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get restrict():String
    public function set restrict(value:String):void

See also

flash.text.TextField.restrict
selectedIndex property
selectedIndex:int [read-write]

The index in the data provider of the selected item. If there is a prompt property, the selectedIndex value can be set to -1 to show the prompt. If there is no prompt, property then selectedIndex will be set to 0 once a dataProvider is set.

If the ComboBox control is editable, the selectedIndex property is -1 if the user types any text into the text field.

Unlike many other Flex properties that are invalidating (setting them does not have an immediate effect), the selectedIndex and selectedItem properties are synchronous; setting one immediately affects the other.

The default value is -1.

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
selectedItem property
selectedItem:Object [read-write]

The item in the data provider at the selectedIndex.

If the data is an object or class instance, modifying properties in the object or instance modifies the dataProvider object but may not update the views unless the instance is Bindable or implements IPropertyChangeNotifier or a call to dataProvider.itemUpdated() occurs.

Setting the selectedItem property causes the ComboBox control to select that item (display it in the text field and set the selectedIndex) if it exists in the data provider. If the ComboBox control is editable, the selectedItem property is null if the user types any text into the text field.

Unlike many other Flex properties that are invalidating (setting them does not have an immediate effect), selectedIndex and selectedItem are synchronous; setting one immediately affects the other.

The default value is null;.

This property can be used as the source for data binding.

Implementation
    public function get selectedItem():Object
    public function set selectedItem(value:Object):void
text property
text:String [read-write]

Contents of the text field. If the control is non-editable setting this property has no effect. If the control is not editable, setting this property sets the contents of the text field.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get text():String
    public function set text(value:String):void
textInput property
protected var textInput:TextInput

The internal TextInput subcomponent that displays the current selection.

value property
value:Object [read-only]

The value of the selected item. If the item is a Number or String, the value is the item. If the item is an object, the value is the data property, if it exists, or the label property, if it exists.

Note: Using the selectedItem property is often preferable to using this property. The value property exists for backward compatibility with older applications

This property can be used as the source for data binding.

Implementation
    public function get value():Object
Constructor detail
ComboBase () constructor
public function ComboBase()

Constructor.

Method detail
calculatePreferredSizeFromData () method
protected function calculatePreferredSizeFromData(numItems:int):Object

Determines default values of the height and width to use for the entries in the drop-down list. Each subclass of ComboBase must implement this method and return an Object containing two properties: width and height.

Parameters
numItems:int — The number of items to check to determine the size

Returns
Object — An Object with width and height properties
collectionChangeHandler () method
protected function collectionChangeHandler(event:Event):void

Responds to changes to the data provider. The component will adjust the selectedIndex property if items are added or removed before the component's selected item.

Parameters
event:Event — The CollectionEvent dispatched from the collection

See also

mx.events.CollectionEvent
downArrowButton_buttonDownHandler () method
protected function downArrowButton_buttonDownHandler(event:FlexEvent):void

Performs some action when the drop-down button is pressed. This is an abstract base class implementation, so it has no effect and is overridden by the subclasses.

Parameters
event:FlexEvent
itemToUID () method
protected function itemToUID(data:Object):String

Determines the UID for a dataProvider item. Every dataProvider item must have or will be assigned a unique identifier (UID).

Parameters
data:Object — A dataProvider item

Returns
String — A unique identifier.
measure () method
protected override function measure():void

Determines the measuredWidth and measuredHeight properties of the control. The measured width is the width of the widest text in the dataProvider plus the width of the drop-down button. The measured height is the larger of either the button or the text. If no data provider has been set or there are no items in the data provider, the measuredWidth property is set to UIComponent.DEFAULT_MEASURED_WIDTH and the measuredHeight property is set to UIComponent.DEFAULT_MEASURED_HEIGHT.

See also

mx.core.UIComponent.measure()
textInput_changeHandler () method
protected function textInput_changeHandler(event:Event):void

Handles changes to the TextInput that serves as the editable text field in the component. The method sets selectedIndex to -1 (and therefore selectedItem to null).

Parameters
event:Event
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Sizes and positions the internal components in the given width and height. The drop-down button is placed all the way to the right and the text field fills the remaining area.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

mx.core.UIComponent.updateDisplayList()


mx.controls.ComboBox (Flex™ 2 Language Reference)

Class ComboBox | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class ComboBox
Inheritance | ComboBox Inheritance ComboBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IListItemRenderer

The ComboBox control contains a drop-down list from which the user can select a single value. Its functionality is very similar to that of the SELECT form element in HTML. The ComboBox can be editable, in which case the user can type entries into the TextInput portion of the ComboBox that are not in the list.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ComboBox> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:ComboBox
    Properties
    dataProvider="null"
    dropdownFactory="ClassFactory that creates an mx.controls.List"
    dropdownWidth="100 or width of the longest text in the dataProvider"
    itemRenderer="null"
    labelField="label"
    labelFunction="null"
    prompt="null"
    rowCount="5"
    selectedIndex="-1"
    selectedItem="null"

    Styles
    alternatingItemColors="undefined"
    arrowButtonWidth="22"
    borderColor="0xB7BAABC"
    borderThickness="1"
    closeDuration="250"
    closeEasingFunction="undefined"
    color="0x0B333C"
    cornerRadius="0"
    disabledColor="0xAAB3B3"
    dropDownBorderColor="undefined"
    dropDownStyleName="comboDropDown"
    fillAlphas="[0.6,0.4]"
    fillColors="[0xFFFFFF, 0xCCCCCC]"
    focusAlpha="0.4"
    focusRoundedCorners="tl tr bl br"
    fontAntiAliasType="advanced|normal"
    fontFamily="Verdana"
    fontGridFitType="pixel|none|subpixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    highlightAlphas="[0.3,0.0]"
    leading="0"
    openDuration="250"
    openEasingFunction="undefined"
    paddingLeft="5"
    paddingRight="5"
    rollOverColor="Depends on theme color"
    selectionColor="Depends on theme color"
    selectionDuration="250"
    selectionEasingFunction="undefined"
    textAlign="left|center|right"
    textDecoration="none|underline"
    textIndent="0"
    textRollOverColor="0x2B333C"
    textSelectedColor="0x2B333C"

    Events
    change="No default"
    close="No default"
    dataChange="No default"
    enter="No default"
    itemRollOut="No default"
    itemRollOver="No default"
    open="No default"
    scroll="No default"
  />

Default MXML Property dataProvider

View the examples.

See also

mx.controls.List
mx.effects.Tween
mx.managers.PopUpManager
Using Data-Driven Controls
Creating MXML components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | ComboBox
 | dataProvider : Object [write-only] The set of items this component displays. | ComboBox
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
 | dropdown : ListBase [read-only] A reference to the List control that acts as the drop-down in the ComboBox. | ComboBox
 | dropdownFactory : IFactory The IFactory that creates a ListBase-derived instance to use as the drop-down. | ComboBox
 | dropdownWidth : Number Width of the drop-down list, in pixels. | ComboBox
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | editable : Boolean A flag that indicates whether the control is editable, which lets the user directly type entries that are not specified in the dataProvider, or not editable, which requires the user select from the items in the dataProvider. | ComboBase
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | imeMode : String Specifies the IME (input method editor) mode. | ComboBase
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | itemRenderer : IFactory IFactory that generates the instances that displays the data for the drop-down list of the control. | ComboBox
 | labelField : String Name of the field in the items in the dataProvider Array to display as the label in the TextInput portion and drop-down list. | ComboBox
 | labelFunction : Function User-supplied function to run on each item to determine its label. | ComboBox
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | ComboBox
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
 | prompt : String The prompt for the ComboBox control. | ComboBox
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | restrict : String Set of characters that a user can or cannot enter into the text field. | ComboBase
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
 | rowCount : int Maximum number of rows visible in the ComboBox control list. | ComboBox
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedIndex : int [write-only] Index of the selected item in the drop-down list. | ComboBox
 | selectedItem : Object [write-only] Contains a reference to the selected item in the dataProvider. | ComboBox
 | selectedLabel : String [read-only] The String displayed in the TextInput portion of the ComboBox. | ComboBox
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String Contents of the text field. | ComboBase
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The value of the selected item. | ComboBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ComboBase
Inherited | collection : ICollectionView The ICollectionView of items this component displays. | ComboBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the dataProvider and pass the items to the renderers. | ComboBase
Inherited | textInput : TextInput The internal TextInput subcomponent that displays the current selection. | ComboBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ComboBox()
Constructor.
ComboBox
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
close():void
Hides the drop-down list.
ComboBox
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
itemToLabel(item:Object):String
Returns a string representing the item parameter.
ComboBox
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
open():void
Displays the drop-down list.
ComboBox
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
 | calculatePreferredSizeFromData(count:int):Object Determines default values of the height and width to use for each entry in the drop-down list, based on the maximum size of the label text in the first numItems items in the data provider. | ComboBox
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | collectionChangeHandler(event:Event):void Responds to changes to the data provider. | ComboBase
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | downArrowButton_buttonDownHandler(event:FlexEvent):void Performs some action when the drop-down button is pressed. | ComboBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | itemToUID(data:Object):String Determines the UID for a dataProvider item. | ComboBase
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Makes sure the control is at least 40 pixels wide, and tall enough to fit one line of text in the TextInput portion of the control but at least 22 pixels high. | ComboBox
Inherited | textInput_changeHandler(event:Event):void Handles changes to the TextInput that serves as the editable text field in the component. | ComboBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sizes and positions the internal components in the given width and height. | ComboBase
Events
Hide Inherited Events
Show Inherited Events
Event Summary Defined by
Inherited
activate
Dispatched when Flash Player gains operating system focus and becomes active. DisplayObject
Inherited
add
Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. UIComponent
Inherited
added
Dispatched when a display object is added to the display list. DisplayObject
change
Dispatched when the ComboBox contents changes as a result of user interaction: when the selectedIndex or selectedItem property changes, and, if the ComboBox control is editable, each time a keystroke is entered in the box. ComboBox
Inherited
click
Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. InteractiveObject
close
Dispatched when the drop-down list is dismissed for any reason such when the user:
  • selects an item in the drop-down list
  • clicks outside of the drop-down list
  • clicks the drop-down button while the drop-down list is displayed
  • presses the ESC key while the drop-down list is displayed
ComboBox
Inherited
creationComplete
Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. UIComponent
Inherited
currentStateChange
Dispatched after the view state has changed. UIComponent
Inherited
currentStateChanging
Dispatched after the currentState property changes, but before the view state changes. UIComponent
dataChange
Dispatched when the data property changes. ComboBox
Inherited
deactivate
Dispatched when Flash Player loses operating system focus and is becoming inactive. DisplayObject
Inherited
doubleClick
Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. InteractiveObject
Inherited
dragComplete
Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. UIComponent
Inherited
dragDrop
Dispatched by the drop target when the user releases the mouse over it. UIComponent
Inherited
dragEnter
Dispatched by a component when the user moves the mouse over the component during a drag operation. UIComponent
Inherited
dragExit
Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. UIComponent
Inherited
dragOver
Dispatched by a component when the user moves the mouse while over the component during a drag operation. UIComponent
Inherited
effectEnd
Dispatched after an effect ends. UIComponent
Inherited
effectStart
Dispatched just before an effect starts. UIComponent
enter
Dispatched if the editable property is set to true and the user presses the Enter key while typing in the editable text field. ComboBox
Inherited
enterFrame
Dispatched when the playhead is entering a new frame. DisplayObject
Inherited
enterState
Dispatched after the component has returned to the root view state. UIComponent
Inherited
exitState
Dispatched before the component exits from the root view state. UIComponent
Inherited
focusIn
Dispatched after a display object gains focus. InteractiveObject
Inherited
focusOut
Dispatched after a display object loses focus. InteractiveObject
Inherited
hide
Dispatched when an object's state changes from visible to invisible. UIComponent
Inherited
initialize
Dispatched when the component has finished its construction and has all initialization properties set. UIComponent
Inherited
invalid
Dispatched when a component is monitored by a Validator and the validation failed. UIComponent
itemRollOut
Dispatched when user rolls the mouse out of a drop-down list item. ComboBox
itemRollOver
Dispatched when the user rolls the mouse over a drop-down list item. ComboBox
Inherited
keyDown
Dispatched when the user presses a key. InteractiveObject
Inherited
keyFocusChange
Dispatched when the user attempts to change focus by using keyboard navigation. InteractiveObject
Inherited
keyUp
Dispatched when the user releases a key. InteractiveObject
Inherited
mouseDown
Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. InteractiveObject
Inherited
mouseDownOutside
Dispatched from a component opened using the PopUpManager when the user clicks outside it. UIComponent
Inherited
mouseFocusChange
Dispatched when the user attempts to change focus by using a pointer device. InteractiveObject
Inherited
mouseMove
Dispatched when a user moves the pointing device while it is over an InteractiveObject. InteractiveObject
Inherited
mouseOut
Dispatched when the user moves a pointing device away from an InteractiveObject instance. InteractiveObject
Inherited
mouseOver
Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. InteractiveObject
Inherited
mouseUp
Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. InteractiveObject
Inherited
mouseWheel
Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. InteractiveObject
Inherited
mouseWheelOutside
Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. UIComponent
Inherited
move
Dispatched when the object has moved. UIComponent
open
Dispatched when the user clicks the drop-down button to display the drop-down list. ComboBox
Inherited
preinitialize
Dispatched at the beginning of the component initialization sequence. UIComponent
Inherited
remove
Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. UIComponent
Inherited
removed
Dispatched when a display object is about to be removed from the display list. DisplayObject
Inherited
render
Dispatched when the display list is about to be updated and rendered. DisplayObject
Inherited
resize
Dispatched when the component is resized. UIComponent
Inherited
rollOut
Dispatched when the user moves a pointing device away from an InteractiveObject instance. InteractiveObject
Inherited
rollOver
Dispatched when the user moves a pointing device over an InteractiveObject instance. InteractiveObject
scroll
Dispatched when the user scrolls the ComboBox control's drop-down list. ComboBox
Inherited
show
Dispatched when an object's state changes from invisible to visible. UIComponent
Inherited
tabChildrenChange
Dispatched when the value of the object's tabChildren flag changes. InteractiveObject
Inherited
tabEnabledChange
Dispatched when the object's tabEnabled flag changes. InteractiveObject
Inherited
tabIndexChange
Dispatched when the value of the object's tabIndex property changes. InteractiveObject
Inherited
toolTipCreate
Dispatched by the component when it is time to create a ToolTip. UIComponent
Inherited
toolTipEnd
Dispatched by the component when its ToolTip has been hidden and will be discarded soon. UIComponent
Inherited
toolTipHide
Dispatched by the component when its ToolTip is about to be hidden. UIComponent
Inherited
toolTipShow
Dispatched by the component when its ToolTip is about to be shown. UIComponent
Inherited
toolTipShown
Dispatched by the component when its ToolTip has been shown. UIComponent
Inherited
toolTipStart
Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. UIComponent
Inherited
updateComplete
Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). UIComponent
Inherited
valid
Dispatched when a component is monitored by a Validator and the validation succeeded. UIComponent
Inherited
valueCommit
Dispatched when values are changed programmatically or by user interaction. UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
alternatingItemColors
Type: Array Format: Color CSS Inheritance: yes
The set of BackgroundColors for drop-down list rows in an alternating pattern. Value can be an Array of two of more colors. If undefined then the rows will use the drop-down list's backgroundColor style. The default value is undefined. 		ComboBox
arrowButtonWidth
Type: Number Format: Length CSS Inheritance: no
Width of the arrow button in pixels. The default value is 22. 		ComboBox
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The following controls support this style: Button, CheckBox, ComboBox, MenuBar, NumericStepper, ProgressBar, RadioButton, ScrollBar, Slider, and any components that support the borderStyle style. The default value depends on the component class; if not overriden for the class, the default value is 0xB7BABC. 		ComboBox
borderThickness
Type: Number Format: Length CSS Inheritance: no
The thickness of the border of the drop-down list. The default value is 1. 		ComboBox
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
closeDuration
Type: Number Format: Time CSS Inheritance: no
The length of the transition when the drop-down list closes, in milliseconds. The default transition has the drop-down slide up into the ComboBox. The default value is 250. 		ComboBox
closeEasingFunction
Type: Function CSS Inheritance: no
An easing function to control the close transition. Easing functions can be used to control the acceleration and deceleration of the transition. The default value is undefined. 		ComboBox
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		ComboBox
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The following components support this style: Alert, Button, ComboBox, LinkButton, MenuBar, NumericStepper, Panel, ScrollBar, Tab, TitleWindow, and any component that supports a borderStyle property set to "solid". The default value depends on the component class; if not overriden for the class, the default value is 0. 		ComboBox
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		ComboBox
Inherited
disabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the control is disabled. 		ComboBase
Inherited
downSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the user holds down the mouse button. 		ComboBase
dropdownBorderColor
Type: uint Format: Color CSS Inheritance: yes
The color of the border of the ComboBox. If undefined the drop-down list will use its normal borderColor style. This style is used by the validators to show the ComboBox in an error state. The default value is undefined. 		ComboBox
dropDownStyleName
Type: String CSS Inheritance: no
The name of a CSSStyleDeclaration to be used by the drop-down list. This allows you to control the appearance of the drop-down list or its item renderers. The default value is "comboDropDown". 		ComboBox
Inherited
editableDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the control is disabled, and the editable property is true. 		ComboBase
Inherited
editableDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the user holds down the mouse button, and the editable property is true. 		ComboBase
Inherited
editableOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is over the control, and the editable property is true. 		ComboBase
Inherited
editableUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is not over the control, and the editable property is true. 		ComboBase
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fillAlphas
Type: Array CSS Inheritance: no
Alphas used for the background fill of controls. Use [1, 1] to make the control background opaque. The default value is [ 0.6, 0.4 ]. 		ComboBox
fillColors
Type: Array Format: Color CSS Inheritance: no
Colors used to tint the background of the control. Pass the same color for both values for a flat-looking control. The default value is [ 0xFFFFFF, 0xCCCCCC ]. 		ComboBox
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		ComboBox
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		ComboBox
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		ComboBox
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		ComboBox
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		ComboBox
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ComboBox
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		ComboBox
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		ComboBox
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ComboBox
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		ComboBox
highlightAlphas
Type: Array CSS Inheritance: no
Alpha transparencies used for the highlight fill of controls. The first value specifies the transparency of the top of the highlight and the second value specifies the transparency of the bottom of the highlight. The highlight covers the top half of the skin. The default value is [ 0.3, 0.0 ]. 		ComboBox
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

ComboBox
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
openDuration
Type: Number Format: Time CSS Inheritance: no
Length of the transition when the drop-down list opens, in milliseconds. The default transition has the drop-down slide down from the ComboBox. The default value is 250. 		ComboBox
openEasingFunction
Type: Function CSS Inheritance: no
An easing function to control the open transition. Easing functions can be used to control the acceleration and deceleration of the transition. The default value is undefined. 		ComboBox
Inherited
overSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is over the control. 		ComboBase
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

ComboBox
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

ComboBox
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
rollOverColor
Type: uint Format: Color CSS Inheritance: yes
The rollOverColor of the drop-down list. 		ComboBox
selectionColor
Type: uint Format: Color CSS Inheritance: yes
The selectionColor of the drop-down list. 		ComboBox
selectionDuration
Type: uint Format: Time CSS Inheritance: no
The selectionDuration of the drop-down list. The default value is 250. 		ComboBox
selectionEasingFunction
Type: Function CSS Inheritance: no
The selectionEasingFunction of the drop-down list. The default value is undefined. 		ComboBox
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

ComboBox
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		ComboBox
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		ComboBox
textRollOverColor
Type: uint Format: Color CSS Inheritance: yes
The textRollOverColor of the drop-down list. The default value is #2B333C. 		ComboBox
textSelectedColor
Type: uint Format: Color CSS Inheritance: yes
The textSelectedColor of the drop-down list. The default value is #2B333C. 		ComboBox
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
upSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is not over the control. 		ComboBase
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The data property lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

The ComboBox control uses the listData property and the data property as follows. If the ComboBox is in a DataGrid control, it expects the dataField property of the column to map to a property in the data and sets selectedItem to that property. If the ComboBox control is in a List control, it expects the labelField of the list to map to a property in the data and sets selectedItem to that property. Otherwise, it sets selectedItem to the data itself.

You do not set this property in MXML.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
dataProvider property
dataProvider:Object [write-only]

The set of items this component displays. This property is of type Object because the derived classes can handle a variety of data types such as Arrays, XML, ICollectionViews, and other classes. All are converted into an ICollectionView and that ICollectionView is returned if you get the value of this property; you will not get the value you set if it was not an ICollectionView.

Setting this property will adjust the selectedIndex property (and therefore the selectedItem property) if the selectedIndex property has not otherwise been set. If there is no prompt property, the selectedIndex property will be set to 0; otherwise it will remain at -1, the index used for the prompt string. If the selectedIndex property has been set and it is out of range of the new data provider, unexpected behavior is likely to occur.

This property can be used as the source for data binding.

Implementation
    public function set dataProvider(value:Object):void
dropdown property
dropdown:ListBase [read-only]

A reference to the List control that acts as the drop-down in the ComboBox.

Implementation
    public function get dropdown():ListBase
dropdownFactory property
dropdownFactory:IFactory [read-write]

The IFactory that creates a ListBase-derived instance to use as the drop-down. The default value is an IFactory for List

This property can be used as the source for data binding.

Implementation
    public function get dropdownFactory():IFactory
    public function set dropdownFactory(value:IFactory):void
dropdownWidth property
dropdownWidth:Number [read-write]

Width of the drop-down list, in pixels.

The default value is 100 or the width of the longest text in the dataProvider, whichever is greater.

This property can be used as the source for data binding.

Implementation
    public function get dropdownWidth():Number
    public function set dropdownWidth(value:Number):void
itemRenderer property
itemRenderer:IFactory [read-write]

IFactory that generates the instances that displays the data for the drop-down list of the control. You can use this property to specify a custom item renderer for the drop-down list.

The control uses a List control internally to create the drop-down list. The default item renderer for the List control is the ListItemRenderer class, which draws the text associated with each item in the list, and an optional icon.

Implementation
    public function get itemRenderer():IFactory
    public function set itemRenderer(value:IFactory):void

See also

mx.controls.List
mx.controls.listClasses.ListItemRenderer
labelField property
labelField:String [read-write]

Name of the field in the items in the dataProvider Array to display as the label in the TextInput portion and drop-down list. By default, the control uses a property named label on each Array object and displays it.

However, if the dataProvider items do not contain a label property, you can set the labelField property to use a different property.

This property can be used as the source for data binding.

Implementation
    public function get labelField():String
    public function set labelField(value:String):void
labelFunction property
labelFunction:Function [read-write]

User-supplied function to run on each item to determine its label. By default the control uses a property named label on each dataProvider item to determine its label. However, some data sets do not have a label property, or do not have another property that can be used for displaying as a label.

An example is a data set that has lastName and firstName fields but you want to display full names. You use labelFunction to specify a callback function that uses the appropriate fields and return a displayable String.

The labelFunction takes a single argument which is the item in the dataProvider and returns a String:

   myLabelFunction(item:Object):String

This property can be used as the source for data binding.

Implementation
    public function get labelFunction():Function
    public function set labelFunction(value:Function):void
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. The component can then use the listData property and the data property to display the appropriate information as a drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
prompt property
prompt:String [read-write]

The prompt for the ComboBox control. A prompt is a String that is displayed in the TextInput portion of the ComboBox when selectedIndex = -1. It is usually a String like "Select one...". If there is no prompt, the ComboBox control sets selectedIndex to 0 and displays the first item in the dataProvider.

Implementation
    public function get prompt():String
    public function set prompt(value:String):void
rowCount property
rowCount:int [read-write]

Maximum number of rows visible in the ComboBox control list. If there are fewer items in the dataProvider, the ComboBox shows only as many items as there are in the dataProvider.

The default value is 5.

This property can be used as the source for data binding.

Implementation
    public function get rowCount():int
    public function set rowCount(value:int):void
selectedIndex property
selectedIndex:int [write-only]

Index of the selected item in the drop-down list. Setting this property sets the current index and displays the associated label in the TextInput portion.

The default value is -1, but it set to 0 when a dataProvider is assigned, unless there is a prompt. If the control is editable, and the user types in the TextInput portion, the value of the selectedIndex property becomes -1. If the value of the selectedIndex property is out of range, the selectedIndex property is set to the last item in the dataProvider.

This property can be used as the source for data binding.

Implementation
    public function set selectedIndex(value:int):void
selectedItem property
selectedItem:Object [write-only]

Contains a reference to the selected item in the dataProvider. If the data is an object or class instance, modifying properties in the object or instance modifies the dataProvider and thus its views. Setting the selectedItem itself causes the ComboBox to select that item (display it in the TextInput portion and set the selectedIndex) if it exists in the dataProvider.

If the ComboBox control is editable, the selectedItem property is null if the user types any text into the TextInput. It has a value only if the user selects an item from the drop-down list, or if it is set programmatically.

This property can be used as the source for data binding.

Implementation
    public function set selectedItem(value:Object):void
selectedLabel property
selectedLabel:String [read-only]

The String displayed in the TextInput portion of the ComboBox. It is calculated from the data by using the labelField or labelFunction.

Implementation
    public function get selectedLabel():String
Constructor detail
ComboBox () constructor
public function ComboBox()

Constructor.

Method detail
calculatePreferredSizeFromData () method
protected override function calculatePreferredSizeFromData(count:int):Object

Determines default values of the height and width to use for each entry in the drop-down list, based on the maximum size of the label text in the first numItems items in the data provider.

Parameters
count:int — The number of items to check to determine the value.

Returns
Object — An Object containing two properties: width and height.
close () method
public function close():void

Hides the drop-down list.

itemToLabel () method
public function itemToLabel(item:Object):String

Returns a string representing the item parameter.

This method checks in the following order to find a value to return:

  1. If you have specified a labelFunction property, returns the result of passing the item to the function.
  2. If the item is a String, Number, Boolean, or Function, returns the item.
  3. If the item has a property with the name specified by the control's labelField property, returns the contents of the property.
  4. If the item has a label property, returns its value.
Parameters
item:Object

Returns
String
measure () method
protected override function measure():void

Makes sure the control is at least 40 pixels wide, and tall enough to fit one line of text in the TextInput portion of the control but at least 22 pixels high.

open () method
public function open():void

Displays the drop-down list.

Event detail
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched when the ComboBox contents changes as a result of user interaction: when the selectedIndex or selectedItem property changes, and, if the ComboBox control is editable, each time a keystroke is entered in the box.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
close event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.CLOSE

Dispatched when the drop-down list is dismissed for any reason such when the user:

  • selects an item in the drop-down list
  • clicks outside of the drop-down list
  • clicks the drop-down button while the drop-down list is displayed
  • presses the ESC key while the drop-down list is displayed

The DropdownEvent.CLOSE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains an item from the dataProvider. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
enter event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.ENTER

Dispatched if the editable property is set to true and the user presses the Enter key while typing in the editable text field.

The FlexEvent.ENTER constant defines the value of the type property of the event object for a enter event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
itemRollOut event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_ROLL_OUT

Dispatched when user rolls the mouse out of a drop-down list item. The event object's target property contains a reference to the ComboBox and not the drop-down list.

The ListEvent.ITEM_ROLL_OUT constant defines the value of the type property of the ListEvent object for an itemRollOut event, which indicates that the user rolled the mouse pointer out of a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was rolled out.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_ROLL_OUT
itemRollOver event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_ROLL_OVER

Dispatched when the user rolls the mouse over a drop-down list item. The event object's target property contains a reference to the ComboBox and not the drop-down list.

The ListEvent.ITEM_ROLL_OVER constant defines the value of the type property of the ListEvent object for an itemRollOver event, which indicates that the user rolled the mouse pointer over a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was rolled over.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_ROLL_OVER
open event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.OPEN

Dispatched when the user clicks the drop-down button to display the drop-down list. It is also dispatched if the user uses the keyboard and types Ctrl-Down to open the drop-down.

The DropdownEvent.OPEN constant defines the value of the type property of the event object for a open event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
scroll event
Event object type: mx.events.ScrollEvent
ScrollEvent.type property = mx.events.ScrollEvent.SCROLL

Dispatched when the user scrolls the ComboBox control's drop-down list.

The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the change in scroll position, expressed in pixels. A positive value indicates the scroll was down or to the right. A negative value indicates the scroll was up or to the left.
direction | Contains the scroll direction, either ScrollEventDirection.HORIZONTAL or ScrollEventDirection.VERTICAL.
position | Contains the new scroll position.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
SimpleComboBox
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ComboBox control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            [Bindable]
            public var cards: Array = [ {label:"Visa", data:1},
                {label:"MasterCard", data:2}, {label:"American Express", data:3} ];

            [Bindable]
            public var selectedItem:Object;
        ]]>
    </mx:Script>

    <mx:Panel title="ComboBox Control Example"
        height="75%" width="75%" layout="horizontal"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:ComboBox dataProvider="{cards}" width="150"
            close="selectedItem=ComboBox(event.target).selectedItem"/>

        <mx:VBox width="250">
            <mx:Text  width="200" color="blue" text="Select a type of credit card."/>
            <mx:Label text="You selected: {selectedItem.label}"/>
            <mx:Label text="Data: {selectedItem.data}"/>
        </mx:VBox>

    </mx:Panel>
</mx:Application>


mx.controls.DataGrid (Flex™ 2 Language Reference)

Class DataGrid | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class DataGrid
Inheritance | DataGrid Inheritance DataGridBase Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IIMESupport
Subclasses | PrintDataGrid

The DataGrid control is a like a List except that it can show more than one column of data making it suited for showing objects with multiple properties.

The DataGrid control provides the following features:

  • Columns of different widths or identical fixed widths
  • Columns that the user can resize at runtime
  • Columns that the user can reorder at runtime
  • Optional customizable column headers
  • Ability to use a custom item renderer for any column to display data other than text
  • Support for sorting the data by clicking on a column

The DataGrid control is intended for viewing data, and not as a layout tool like an HTML table. The mx.containers package provides those layout tools.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:DataGrid> tag inherits all of the tag attributes of its superclass, except for labelField, iconField, and iconFunction, and adds the following tag attributes:

  <mx:DataGrid
    Properties
    columns="From dataProvider"
    draggableColumns="true|false"
    editable="false|true"
    editedItemPosition="null"
    horizontalScrollPosition="null"
    imeMode="null"
    itemEditorInstance="null"
    minColumnWidth="NaN"
    resizableColumns="true|false"
    sortableColumns="true|false"

    Styles
    backgroundDisabledColor="0xEFEEEF"
    columnDropIndicatorSkin="DataGridColumnDropIndicator"
    columnResizeSkin="DataGridColumnResizeSkin"
    headerColors="[#FFFFFF, #E6E6E6]"
    headerDragProxyStyleName="headerDragProxyStyle"
    headerSeparatorSkin="DataGridHeaderSeparator"
    headerStyleName="No default"
    horizontalGridLineColor="#666666"
    horizontalGridLines="false|true"
    rollOverColor="#E3FFD6"
    selectionColor="#CDFFC1"
    sortArrowSkin="DataGridSortArrow"
    stretchCursor="DataGridStretchCursor"
    verticalGridLineColor="#666666"
    verticalGridLines="false|true"

    Events
    columnStretch="No default"
    headerRelease="No default"
    headerShift="No default"
    itemEditBegin="No default"
    itemEditEnd="No default"
    itemFocusIn="No default"
    itemFocusOut="No default"
  />

  The following DataGrid code sample specifies the column order:
  <mx:DataGrid>
    <mx:dataProvider>
        <mx:Object Artist="Pavement" Price="11.99"
          Album="Slanted and Enchanted"/>
        <mx:Object Artist="Pavement"
          Album="Brighten the Corners" Price="11.99"/>
    </mx:dataProvider>
    <mx:columns>
        <mx:DataGridColumn dataField="Album"/>
        <mx:DataGridColumn dataField="Price"/>
    </mx:columns>
  </mx:DataGrid>

Default MXML Property dataProvider

View the examples.

See also

mx.controls.dataGridClasses.DataGridItemRenderer
mx.controls.dataGridClasses.DataGridColumn
mx.controls.dataGridClasses.DataGridDragProxy
mx.events.DataGridEvent
Using Data-Driven Controls
Example: Using an item renderer with a DataGrid control
Example: Using an item editor with a DataGrid control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | columns : Array An array of DataGridColumn objects, one for each column that can be displayed. | DataGrid
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
 | draggableColumns : Boolean A flag that indicates whether the user is allowed to reorder columns. | DataGrid
Inherited | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | editable : Boolean = false A flag that indicates whether or not the user can edit items in the data provider. | DataGrid
 | editedItemPosition : Object The column and row index of the item renderer for the data provider item being edited, if any. | DataGrid
 | editedItemRenderer : IListItemRenderer [read-only] A reference to the item renderer in the DataGrid control whose item is currently being edited. | DataGrid
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | headerHeight : Number The height of the header cell of the column, in pixels. | DataGridBase
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
 | horizontalScrollPosition : Number The offset into the content from the left edge. | DataGrid
Inherited | id : String ID of the component. | UIComponent
 | imeMode : String Specifies the IME (input method editor) mode. | DataGrid
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | itemEditorInstance : IListItemRenderer A reference to the currently active instance of the item editor, if it exists. | DataGrid
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
 | minColumnWidth : Number The minimum width of the columns, in pixels. | DataGrid
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | resizableColumns : Boolean = true A flag that indicates whether the user can change the size of the columns. | DataGrid
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showHeaders : Boolean A flag that indicates whether the control should show column headers. | DataGridBase
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
 | sortableColumns : Boolean = true A flag that indicates whether the user can sort the data provider items by clicking on a column header cell. | DataGrid
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | columnMap : Object A map of item renderes to columns. | DataGridBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | freeItemRenderersTable : Dictionary A per-column table of unused item renderers. | DataGridBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGrid()
Constructor.
DataGrid
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
createItemEditor(colIndex:int, rowIndex:int):void
Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.
DataGrid
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
destroyItemEditor():void
This method closes an item editor currently open on an item renderer.
DataGrid
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
calculateRowHeight(data:Object, hh:Number, skipVisible:Boolean = false):Number
Calculates the row height of columns in a row.
DataGridBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
clearSeparators():void
Removes column header separators that the user normally uses to resize columns.
DataGrid
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
drawColumnBackground(s:Sprite, columnIndex:int, color:uint, column:DataGridColumn):void
Draws a column background for a column with the suggested color.
DataGrid
drawHeaderBackground(headerBG:UIComponent):void
Draws the background of the headers into the given UIComponent.
DataGrid
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
drawHorizontalLine(s:Sprite, rowIndex:int, color:uint, y:Number):void
Draws a line between rows.
DataGrid
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
drawLinesAndColumnBackgrounds():void
Draw lines between columns, and column backgrounds.
DataGrid
drawRowBackground(s:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int):void
Draws a row background at the position and height specified using the color specified.
DataGrid
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
drawSeparators():void
Creates and displays the column header separators that the user normally uses to resize columns.
DataGrid
drawVerticalLine(s:Sprite, colIndex:int, color:uint, x:Number):void
Draw lines between columns.
DataGrid
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
Inherited
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
placeSortArrow():void
Draws the sort arrow graphic on the column that is the current sort key.
DataGrid
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | columnStretch | Dispatched when a user changes the width of a column, indicating that the amount of data displayed in that column may have changed. | DataGrid
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
 | headerRelease | Dispatched when the user releases the mouse button on a column header to request the control to sort the grid contents based on the contents of the column. | DataGrid
 | headerShift | Dispatched when the user releases the mouse button on a column header after having dragged the column to a new location resulting in shifting the column to a new index. | DataGrid
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
 | itemEditBegin | Dispatched when the editedItemPosition property has been set and the item can be edited. | DataGrid
 | itemEditBeginning | Dispatched when the user releases the mouse button while over an item renderer, tabs to the DataGrid control or within the DataGrid control, or in any other way attempts to edit an item. | DataGrid
 | itemEditEnd | Dispatched when an item editing session ends for any reason. | DataGrid
 | itemFocusIn | Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the DataGrid control or navigates to the item using a keyboard. | DataGrid
 | itemFocusOut | Dispatched when an item renderer loses focus, which can occur if the user clicks another item in the DataGrid control or clicks outside the control, or uses the keyboard to navigate to another item in the DataGrid control or outside the control. | DataGrid
Inherited | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
Inherited | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors to use for the backgrounds of the items in the list. | ListBase
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
 | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes The background color of the DataGrid when disabled. The default value is 0xEFEEEF. | DataGrid
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
 | columnDropIndicatorSkin | Type: Class CSS Inheritance: no The class to use as the skin that indicates that a column can be dropped in the current location. The default value is mx.skins.halo.DataGridColumnDropIndicator. | DataGrid
 | columnResizeSkin | Type: Class CSS Inheritance: no The class to use as the skin for a column that is being resized. The default value is mx.skins.halo.DataGridColumnResizeSkin. | DataGrid
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
 | headerColors | Type: Array Format: Color CSS Inheritance: yes An array of two colors used to draw the header background gradient. The first color is the top color. The second color is the bottom color. The default value is [0xFFFFFF, 0xE6E6E6]. | DataGrid
 | headerDragProxyStyleName | Type: String CSS Inheritance: no The name of a CSS style declaration for controlling aspects of the appearance of column when the user is dragging it to another location. The default value is "headerDragProxyStyle". | DataGrid
 | headerSeparatorSkin | Type: Class CSS Inheritance: no The class to use as the skin for the separator between the DataGrid header and the rest of the rows. The default value is mx.skins.halo.DataGridHeaderSeparator. | DataGrid
 | headerStyleName | Type: String CSS Inheritance: no The name of a CSS style declaration for controlling other aspects of the appearance of the column headers. The default value is "dataGridStyles". | DataGrid
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGridLineColor | Type: uint Format: Color CSS Inheritance: yes The color of the horizontal grid lines. The default value is 0x666666. | DataGrid
 | horizontalGridLines | Type: Boolean CSS Inheritance: no A flag that indicates whether to show horizontal grid lines between the rows. If true, shows horizontal grid lines. If false, hides horizontal grid lines. The default value is false. | DataGrid
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | rollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the row background when the user rolls over the row. The default value is 0xE3FFD6. | DataGrid
 | selectionColor | Type: uint Format: Color CSS Inheritance: yes The color of the background for the row when the user selects an item renderer in the row. The default value is 0xCDFFC1. | DataGrid
Inherited | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the component is disabled. | ListBase
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
Inherited | selectionEasingFunction | Type: Function CSS Inheritance: no The easingFunction for the selection effect. | ListBase
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
 | sortArrowSkin | Type: Class CSS Inheritance: no The class to use as the skin for the arrow that indicates the column sort direction. The default value is mx.skins.halo.DataGridSortArrow. | DataGrid
 | stretchCursor | Type: Class CSS Inheritance: no The class to use as the skin for the cursor that indicates that a column can be resized. The default value is mx.skins.halo.DataGridStretchCursor. | DataGrid
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user rolls over a it. | ListBase
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user selects it. | ListBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGridLineColor | Type: uint Format: Color CSS Inheritance: yes The color of the vertical grid lines. The default value is 0x666666. | DataGrid
 | verticalGridLines | Type: Boolean CSS Inheritance: no A flag that indicates whether to show vertical grid lines between the columns. If true, shows vertical grid lines. If false, hides vertical grid lines. The default value is false. | DataGrid
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
columns property
columns:Array [read-write]

An array of DataGridColumn objects, one for each column that can be displayed. If not explicitly set, the DataGrid control attempts to examine the first data provider item to determine the set of properties and display those properties in alphabetic order.

If you want to change the set of columns, you must get this array, make modifications to the columns and order of columns in the array, and then assign the new array to the columns property. This is because the DataGrid control returned a new copy of the array of columns and therefore did not notice the changes.

This property can be used as the source for data binding.

Implementation
    public function get columns():Array
    public function set columns(value:Array):void
draggableColumns property
draggableColumns:Boolean [read-write]

A flag that indicates whether the user is allowed to reorder columns. If true, the user can reorder the columns of the DataGrid control by dragging the header cells.

The default value is true.

Implementation
    public function get draggableColumns():Boolean
    public function set draggableColumns(value:Boolean):void
editable property
public var editable:Boolean = false

A flag that indicates whether or not the user can edit items in the data provider. If true, the item renderers in the control are editable. The user can click on an item renderer to open an editor.

You can turn off editing for individual columns of the DataGrid control using the DataGridColumn.editable property, or by handling the itemEditBeginning and itemEditBegin events

The default value is false.

editedItemPosition property
editedItemPosition:Object [read-write]

The column and row index of the item renderer for the data provider item being edited, if any.

This Object has two fields, columnIndex and rowIndex, the zero-based column and row indexes of the item. For example: {columnIndex:2, rowIndex:3}

Setting this property scrolls the item into view and dispatches the itemEditBegin event to open an item editor on the specified item renderer.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get editedItemPosition():Object
    public function set editedItemPosition(value:Object):void
editedItemRenderer property
editedItemRenderer:IListItemRenderer [read-only]

A reference to the item renderer in the DataGrid control whose item is currently being edited.

From within an event listener for the itemEditBegin and itemEditEnd events, you can access the current value of the item being edited using the editedItemRenderer.data property.

Implementation
    public function get editedItemRenderer():IListItemRenderer
horizontalScrollPosition property
horizontalScrollPosition:Number [read-write]

The offset into the content from the left edge. This can be a pixel offset in some subclasses or some other metric like the number of columns in a DataGrid control. The DataGrid scrolls by columns so the value of the horizontalScrollPosition property is always in the range of 0 to the index of the columns that will make the last column visible. This is different from the List control that scrolls by pixels. The DataGrid control always aligns the left edge of a column with the left edge of the DataGrid control.

Implementation
    public function get horizontalScrollPosition():Number
    public function set horizontalScrollPosition(value:Number):void
imeMode property
imeMode:String [read-write]

Specifies the IME (input method editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the specified IME mode when the control gets the focus, and sets it back to the previous value when the control loses the focus.

The flash.system.IMEConversionMode class defines constants for the valid values for this property. You can also specify null to specify no IME.

The default value is null.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void

See also

flash.system.IMEConversionMode
itemEditorInstance property
public var itemEditorInstance:IListItemRenderer

A reference to the currently active instance of the item editor, if it exists.

To access the item editor instance and the new item value when an item is being edited, you use the itemEditorInstance property. The itemEditorInstance property is not valid until after the event listener for the itemEditBegin event executes. Therefore, you typically only access the itemEditorInstance property from within the event listener for the itemEditEnd event.

The DataGridColumn.itemEditor property defines the class of the item editor and, therefore, the data type of the item editor instance.

You do not set this property in MXML.

minColumnWidth property
minColumnWidth:Number [read-write]

The minimum width of the columns, in pixels. If not NaN, the DataGrid control applies this value as the minimum width for all columns. Otherwise, individual columns can have their own minimum widths.

The default value is NaN.

Implementation
    public function get minColumnWidth():Number
    public function set minColumnWidth(value:Number):void
resizableColumns property
public var resizableColumns:Boolean = true

A flag that indicates whether the user can change the size of the columns. If true, the user can stretch or shrink the columns of the DataGrid control by dragging the grid lines between the header cells. If true, individual columns must also have their resizeable properties set to false to prevent the user from resizing a particular column.

The default value is true.

sortableColumns property
public var sortableColumns:Boolean = true

A flag that indicates whether the user can sort the data provider items by clicking on a column header cell. If true, the user can sort the data provider items by clicking on a column header cell. The DataGridColumn.dataField property of the column or the DataGridColumn.sortCompareFunction property of the column is used as the sort field. If a column is clicked more than once the sort alternates between ascending and descending order. If true, individual columns can be made to not respond to a click on a header by setting the column's sortable property to false.

When a user releases the mouse button over a header cell, the DataGrid control dispatches a headerRelease event if both this property and the column's sortable property are true. If no handler calls the preventDefault() method on the event, the DataGrid sorts using that column's DataGridColumn.dataField or DataGridColumn.sortCompareFunction properties.

The default value is true.

See also

mx.controls.dataGridClasses.DataGridColumn.dataField
mx.controls.dataGridClasses.DataGridColumn.sortCompareFunction
Constructor detail
DataGrid () constructor
public function DataGrid()

Constructor.

Method detail
clearSeparators () method
protected function clearSeparators():void

Removes column header separators that the user normally uses to resize columns.

createItemEditor () method
public function createItemEditor(colIndex:int, rowIndex:int):void

Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.

This method sets the editor instance as the itemEditorInstance property.

You may only call this method from within the event listener for the itemEditBegin event. To create an editor at other times, set the editedItemPosition property to generate the itemEditBegin event.

Parameters
colIndex:int — The column index in the data provider of the item to be edited.
rowIndex:int — The row index in the data provider of the item to be edited.
destroyItemEditor () method
public function destroyItemEditor():void

This method closes an item editor currently open on an item renderer. You typically only call this method from within the event listener for the itemEditEnd event, after you have already called the preventDefault() method to prevent the default event listener from executing.

drawColumnBackground () method
protected function drawColumnBackground(s:Sprite, columnIndex:int, color:uint, column:DataGridColumn):void

Draws a column background for a column with the suggested color. This implementation creates a Shape as a child of the input Sprite and fills it with the appropriate color.

Parameters
s:Sprite — A Sprite that will contain a display object that contains the graphics for that column.
columnIndex:int — The column's index in the set of displayed columns. The left most visible column has a column index of 0. This is used to keep track of the objects used for drawing backgrounds so a particular column can re-use the same display object even though the index of the DataGridColumn for that column has changed.
color:uint — The suggested color for the indicator
column:DataGridColumn — The column of the DataGrid control that you are drawing the background for.
drawHeaderBackground () method
protected function drawHeaderBackground(headerBG:UIComponent):void

Draws the background of the headers into the given UIComponent. The graphics drawn may be scaled horizontally if the component's width changes or this method will be called again to redraw at a different width and/or height

Parameters
headerBG:UIComponent — A UIComponent that will contain the header background graphics.
drawHorizontalLine () method
protected function drawHorizontalLine(s:Sprite, rowIndex:int, color:uint, y:Number):void

Draws a line between rows. This implementation draws a line directly into the given Sprite. The Sprite has been cleared before lines are drawn into it.

Parameters
s:Sprite — A Sprite that will contain a display object that contains the graphics for that row.
rowIndex:int — The row's index in the set of displayed rows. The header does not count, the top most visible row has a row index of 0. This is used to keep track of the objects used for drawing backgrounds so a particular row can re-use the same display object even though the index of the item that row is rendering has changed.
color:uint — The suggested color for the indicator
y:Number — The suggested y position for the background
drawLinesAndColumnBackgrounds () method
protected function drawLinesAndColumnBackgrounds():void

Draw lines between columns, and column backgrounds. This implementation calls the drawHorizontalLine(), drawVerticalLine(), and drawColumnBackground() methods as needed. It creates a Sprite that contains all of these graphics and adds it as a child of the listContent at the front of the z-order.

drawRowBackground () method
protected function drawRowBackground(s:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int):void

Draws a row background at the position and height specified using the color specified. This implementation creates a Shape as a child of the input Sprite and fills it with the appropriate color. This method also uses the backgroundAlpha style property setting to determine the transparency of the background color.

Parameters
s:Sprite — A Sprite that will contain a display object that contains the graphics for that row.
rowIndex:int — The row's index in the set of displayed rows. The header does not count, the top most visible row has a row index of 0. This is used to keep track of the objects used for drawing backgrounds so a particular row can re-use the same display object even though the index of the item that row is rendering has changed.
y:Number — The suggested y position for the background
height:Number — The suggested height for the indicator
color:uint — The suggested color for the indicator
dataIndex:int — The index of the item for that row in the data provider. This can be used to color the 10th item differently for example.
drawSeparators () method
protected function drawSeparators():void

Creates and displays the column header separators that the user normally uses to resize columns. This implementation uses the same Sprite as the lines and column backgrounds and adds instances of the headerSeparatorSkin and attaches mouse listeners to them in order to know when the user wants to resize a column.

drawVerticalLine () method
protected function drawVerticalLine(s:Sprite, colIndex:int, color:uint, x:Number):void

Draw lines between columns. This implementation draws a line directly into the given Sprite. The Sprite has been cleared before lines are drawn into it.

Parameters
s:Sprite — A Sprite that will contain a display object that contains the graphics for that row.
colIndex:int — The column's index in the set of displayed columns. The left most visible column has a column index of 0.
color:uint — The suggested color for the indicator
x:Number — The suggested x position for the background
placeSortArrow () method
protected function placeSortArrow():void

Draws the sort arrow graphic on the column that is the current sort key. This implementation creates or reuses an instance of the skin specified by sortArrowSkin style property and places it in the appropriate column header. It also shrinks the size of the column header if the text in the header would be obscured by the sort arrow.

Event detail
columnStretch event
Event object type: mx.events.DataGridEvent
DataGridEvent.type property = mx.events.DataGridEvent.COLUMN_STRETCH

Dispatched when a user changes the width of a column, indicating that the amount of data displayed in that column may have changed. If horizontalScrollPolicy is "none", other columns shrink or expand to compensate for the columns' resizing, and they also dispatch this event.

The DataGridEvent.COLUMN_STRETCH constant defines the value of the type property of the event object for a columnStretch event, which indicates that a user expanded a column horizontally.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the column.
itemRenderer | null
localX | the x position of the mouse
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.COLUMN_STRETCH
headerRelease event
Event object type: mx.events.DataGridEvent
DataGridEvent.type property = mx.events.DataGridEvent.HEADER_RELEASE

Dispatched when the user releases the mouse button on a column header to request the control to sort the grid contents based on the contents of the column. Only dispatched if the column is sortable and the data provider supports sorting. The DataGrid control has a default handler for this event that implements a single-column sort. Multiple-column sort can be implemented by calling the preventDefault() method to prevent the single column sort and setting the sort property of the data provider.

The DataGridEvent.HEADER_RELEASE constant defines the value of the type property of the event object for a headerRelease event, which indicates that the user pressed and released the mouse on a column header.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the column.
itemRenderer | The header renderer that is being released.
localX | NaN
reason | null
rowIndex | null
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.HEADER_RELEASE
headerShift event
Event object type: mx.events.IndexChangedEvent
IndexChangedEvent.type property = mx.events.IndexChangedEvent.HEADER_SHIFT

Dispatched when the user releases the mouse button on a column header after having dragged the column to a new location resulting in shifting the column to a new index.

The IndexChangedEvent.HEADER_SHIFT constant defines the value of the type property of the event object for a headerShift event, which indicates that a header has changed its index, as when a user drags a DataGrid column to a new position.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
inputType | Indicates whether this event was caused by a mouse or keyboard interaction.
newIndex | The zero-based index of the header after the change.
oldIndex | The zero-based index of the header before the change.
relatedObject | null
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TriggerEvent | The event that triggered this event.
Type | IndexChangedEvent.HEADER_SHIFT
itemEditBegin event
Event object type: mx.events.DataGridEvent
DataGridEvent.type property = mx.events.DataGridEvent.ITEM_EDIT_BEGIN

Dispatched when the editedItemPosition property has been set and the item can be edited.

The DataGridEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited.

The default listener for this event performs the following actions:

  • Creates an item editor object by using a call to the createItemEditor() method.
  • Copies the data property from the item to the editor. By default, the item editor object is an instance of the TextInput control. You use the itemEditor property of the list control to specify a custom item editor class.
  • Set the itemEditorInstance property of the list control to reference the item editor instance.

You can write an event listener for this event to modify the data passed to the item editor. For example, you might modify the data, its format, or other information used by the item editor.

You can also create an event listener to specify the item editor used to edit the item. For example, you might have two different item editors. Within the event listener you can examine the data to be edited or other information, and open the appropriate item editor by doing the following:

  1. Call preventDefault() to stop Flex from calling the createItemEditor() method as part of the default event listener.
  2. Set the itemEditor property to the appropriate editor.
  3. Call the createItemEditor() method.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | null
itemRenderer | The item renderer for the item that is being edited.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_EDIT_BEGIN
itemEditBeginning event
Event object type: mx.events.DataGridEvent
DataGridEvent.type property = mx.events.DataGridEvent.ITEM_EDIT_BEGINNING

Dispatched when the user releases the mouse button while over an item renderer, tabs to the DataGrid control or within the DataGrid control, or in any other way attempts to edit an item.

The DataGridEvent.ITEM__EDIT_BEGINNING constant defines the value of the type property of the event object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item.

The default listener for this event sets the DataGrid.editedItemPosition property to the item that has focus, which starts the item editing session.

You typically write your own event listener for this event to disallow editing of a specific item or items. Calling the preventDefault() method from within your own event listener for this event prevents the default listener from executing.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the item's column.
itemRenderer | The item renderer for the item that will be edited. This property is null if this event is generated by keyboard, as the item to be edited may be off-screen.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_EDIT_BEGINNING
itemEditEnd event
Event object type: mx.events.DataGridEvent
DataGridEvent.type property = mx.events.DataGridEvent.ITEM_EDIT_END

Dispatched when an item editing session ends for any reason.

The DataGridEvent.ITEM_EDIT_END constant defines the value of the type property of the event object for a itemEditEnd event, which indicates that an edit session is ending.

The list components have a default handler for this event that copies the data from the item editor to the data provider of the list control. The default event listener performs the following actions:

  • Uses the editorDataField property of the DataGridColumn associated with this event to determine the property of the item editor containing the new data and updates the data provider item with that new data. Since the default item editor is the TextInput control, the default value of the editorDataField property is "text", to specify that the text property of the TextInput contains the new item data.
  • Calls the destroyItemEditor() method to close the item editor.

You typically write an event listener for this event to perform the following actions:

  • In your event listener, you can modify the data returned by the editor to the list component. For example, you can reformat the data before returning it to the list control. By default, an item editor can only return a single value. You must write an event listener for the itemEditEnd event if you want to return multiple values.
  • In your event listener, you can examine the data entered into the item editor. If the data is incorrect, you can call the preventDefault() method to stop Flex from passing the new data back to the list control and from closing the editor.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the item's column.
itemRenderer | The item renderer for the item that is being edited.
localX | NaN
reason | A constant defining the reason for the event. The value must be a member of the DataGridEventReason class.
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_EDIT_END
itemFocusIn event
Event object type: mx.events.DataGridEvent
DataGridEvent.type property = mx.events.DataGridEvent.ITEM_FOCUS_IN

Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the DataGrid control or navigates to the item using a keyboard. Only dispatched if the item is editable.

The DataGridEvent.ITEM_FOCUS_IN constant defines the value of the type property of the event object for a itemFocusIn event, which indicates that an item has received the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | null
itemRenderer | The item editor instance for the item that is being edited.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_FOCUS_IN
itemFocusOut event
Event object type: mx.events.DataGridEvent
DataGridEvent.type property = mx.events.DataGridEvent.ITEM_FOCUS_OUT

Dispatched when an item renderer loses focus, which can occur if the user clicks another item in the DataGrid control or clicks outside the control, or uses the keyboard to navigate to another item in the DataGrid control or outside the control. Only dispatched if the item is editable.

The DataGridEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the event object for a itemFocusOut event, which indicates that an item has lost the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | null
itemRenderer | The item editor instance for the item that is being edited.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_FOCUS_OUT
Examples
SimpleDataGrid
<?xml version="1.0"?>
<!-- DataGrid control example. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:XMLList id="employees">
        <employee>
            <name>Christina Coenraets</name>
            <phone>555-219-2270</phone>
            <email>ccoenraets@fictitious.com</email>
            <active>true</active>
        </employee>
        <employee>
            <name>Joanne Wall</name>
            <phone>555-219-2012</phone>
            <email>jwall@fictitious.com</email>
            <active>true</active>
        </employee>
        <employee>
            <name>Maurice Smith</name>
            <phone>555-219-2012</phone>
            <email>maurice@fictitious.com</email>
            <active>false</active>
        </employee>
        <employee>
            <name>Mary Jones</name>
            <phone>555-219-2000</phone>
            <email>mjones@fictitious.com</email>
            <active>true</active>
        </employee>
    </mx:XMLList>

    <mx:Panel title="DataGrid Control Example" height="100%" width="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
            text="Select a row in the DataGrid control."/>

        <mx:DataGrid id="dg" width="100%" height="100%" rowCount="5" dataProvider="{employees}">
            <mx:columns>
                <mx:DataGridColumn dataField="name" headerText="Name"/>
                <mx:DataGridColumn dataField="phone" headerText="Phone"/>
                <mx:DataGridColumn dataField="email" headerText="Email"/>
            </mx:columns>
        </mx:DataGrid>

        <mx:Form width="100%" height="100%">
            <mx:FormItem label="Name">
                <mx:Label text="{dg.selectedItem.name}"/>
            </mx:FormItem>
            <mx:FormItem label="Email">
                <mx:Label text="{dg.selectedItem.email}"/>
            </mx:FormItem>
            <mx:FormItem label="Phone">
                <mx:Label text="{dg.selectedItem.phone}"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.controls.DateChooser (Flex™ 2 Language Reference)

Class DateChooser | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class DateChooser
Inheritance | DateChooser Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerComponent

The DateChooser control displays the name of a month, the year, and a grid of the days of the month, with columns labeled for the day of the week. The user can select a date, a range of dates, or multiple dates. The control contains forward and back arrow buttons for changing the month and year. You can let users select multiple dates, disable the selection of certain dates, and limit the display to a range of dates.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:DateChooser> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:DateChooser
    Properties
    allowDisjointSelection="true|false"
    allowMultipleSelection="false|true"
    dayNames="["S", "M", "T", "W", "T", "F", "S"]"
    disabledDays="No default"
    disabledRanges="No default"
    displayedMonth="Current month"
    displayedYear="Current year"
    firstDayOfWeek="0"
    maxYear="2100"
    minYear="1900"
    monthNames="["January", "February", "March", "April", "May",
      "June", "July", "August", "September", "October", "November",
      "December"]"
    monthSymbol=""
    selectableRange="No default"
    selectedDate="No default"
    selectedRanges="No default"
    showToday="true|false"
    yearNavigationEnabled="false|true"
    yearSymbol=""

    Styles
    backgroundColor="0xFFFFFF"
    backgroundAlpha=1.0
    borderColor="0xAAB3B3"
    borderThickness="1"
    color="0x0B333C"
    cornerRadius="0"
    disabledColor="0xAAB3B3"
    fillAlphas="[0.6, 0.4]"
    fillColors="[0xFFFFFF, 0xCCCCCC]"
    focusAlpha="0.5"
    focusRoundedCorners"tl tr bl br"
    fontAntiAliasType="advanced"
    fontFamily="Verdana"
    fontGridFitType="pixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    headerColors="[0xE1E5EB, 0xF4F5F7]"
    headerStyleName="No default"
    highlightAlphas="[0.3, 0.0]"
    horizontalGap="8"
    leading="2"
    nextMonthDisabledSkin="DateChooserMonthArrowSkin"
    nextMonthDownSkin="DateChooserMonthArrowSkin"
    nextMonthOverSkin="DateChooserMonthArrowSkin"
    nextMonthUpSkin="DateChooserMonthArrowSkin"
    nextYearDisabledSkin="DateChooserYearArrowSkin"
    nextYearDownSkin="DateChooserYearArrowSkin"
    nextYearOverSkin="DateChooserYearArrowSkin"
    nextYearUpSkin="DateChooserYearArrowSkin"
    prevMonthDisabledSkin="DateChooserMonthArrowSkin"
    prevMonthDownSkin="DateChooserMonthArrowSkin"
    prevMonthOverSkin="DateChooserMonthArrowSkin"
    prevMonthUpSkin="DateChooserMonthArrowSkin"
    prevYearDisabledSkin="DateChooserYearArrowSkin"
    prevYearDownSkin="DateChooserYearArrowSkin"
    prevYearOverSkin="DateChooserYearArrowSkin"
    prevYearUpSkin="DateChooserYearArrowSkin"
    rollOverColor="0xEEFEE6"
    rollOverIndicatorSkin="DateChooserIndicator"
    selectionColor="0xB7F39B"
    selectionIndicatorSkin="DateChooserIndicator"
    textAlign="left|right|center"
    textDecoration="none|underline"
    textIndent="0"
    todayColor="0x2B333C"
    todayIndicatorSkin="DateChooserIndicator"
    todayStyleName="White"
    verticalGap="6"
    weekDayStyleName="Bold"

    Events
    change="No default"
    scroll="No default"
  />

View the examples.

See also

mx.controls.DateField
DateChooser and DateField controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
 | allowDisjointSelection : Boolean If true, specifies that non-contiguous(disjoint) selection is allowed in the DateChooser control. | DateChooser
 | allowMultipleSelection : Boolean If true, specifies that multiple selection is allowed in the DateChooser control. | DateChooser
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | dayNames : Array The weekday names for DateChooser control. | DateChooser
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | disabledDays : Array The days to disable in a week. | DateChooser
 | disabledRanges : Array Disables single and multiple days. | DateChooser
 | displayedMonth : int Used together with the displayedYear property, the displayedMonth property specifies the month displayed in the DateChooser control. | DateChooser
 | displayedYear : int Used together with the displayedMonth property, the displayedYear property specifies the month displayed in the DateChooser control. | DateChooser
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | firstDayOfWeek : int Number representing the day of the week to display in the first column of the DateChooser control. | DateChooser
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
 | maxYear : int The last year selectable in the control. | DateChooser
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
 | minYear : int The first year selectable in the control. | DateChooser
 | monthNames : Array Names of the months displayed at the top of the DateChooser control. | DateChooser
 | monthSymbol : String This property is appended to the end of the value specified by the monthNames property to define the names of the months displayed at the top of the DateChooser control. | DateChooser
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectableRange : Object Range of dates between which dates are selectable. | DateChooser
 | selectedDate : Date Date selected in the DateChooser control. | DateChooser
 | selectedRanges : Array Selected date ranges. | DateChooser
 | showToday : Boolean If true, specifies that today is highlighted in the DateChooser control. | DateChooser
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yearNavigationEnabled : Boolean Enables year navigation. | DateChooser
 | yearSymbol : String This property is appended to the end of the year displayed at the top of the DateChooser control. | DateChooser
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DateChooser()
Constructor.
DateChooser
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when a date is selected or changed. | DateChooser
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | scroll | Dispatched when the month changes due to user interaction. | DateChooser
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property. Valid values range from 0.0 to 1.0. The default value is 1.0. 		DateChooser
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of the DateChooser control. The default value is 0xFFFFF. 		DateChooser
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The following controls support this style: Button, CheckBox, ComboBox, MenuBar, NumericStepper, ProgressBar, RadioButton, ScrollBar, Slider, and any components that support the borderStyle style. The default value depends on the component class; if not overriden for the class, the default value is 0xB7BABC. 		DateChooser
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. Only used when borderStyle is set to "solid". The default value is 1. 		DateChooser
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		DateChooser
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The following components support this style: Alert, Button, ComboBox, LinkButton, MenuBar, NumericStepper, Panel, ScrollBar, Tab, TitleWindow, and any component that supports a borderStyle property set to "solid". The default value depends on the component class; if not overriden for the class, the default value is 0. 		DateChooser
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		DateChooser
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fillAlphas
Type: Array CSS Inheritance: no
Alphas used for the background fill of controls. Use [1, 1] to make the control background opaque. The default value is [ 0.6, 0.4 ]. 		DateChooser
fillColors
Type: Array Format: Color CSS Inheritance: no
Colors used to tint the background of the control. Pass the same color for both values for a flat-looking control. The default value is [ 0xFFFFFF, 0xCCCCCC ]. 		DateChooser
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		DateChooser
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		DateChooser
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		DateChooser
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		DateChooser
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		DateChooser
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DateChooser
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		DateChooser
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		DateChooser
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DateChooser
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		DateChooser
headerColors
Type: Array Format: Color CSS Inheritance: yes
Colors of the band at the top of the DateChooser control. The default value is [ 0xE1E5EB, 0xF4F5F7 ]. 		DateChooser
headerStyleName
Type: String CSS Inheritance: no
Name of the style sheet definition to configure the text (month name and year) and appearance of the header area of the control. 		DateChooser
highlightAlphas
Type: Array CSS Inheritance: no
Alpha transparencies used for the highlight fill of controls. The first value specifies the transparency of the top of the highlight and the second value specifies the transparency of the bottom of the highlight. The highlight covers the top half of the skin. The default value is [ 0.3, 0.0 ]. 		DateChooser
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
horizontalGap
Type: Number Format: Length CSS Inheritance: no
Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. 		DateChooser
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

DateChooser
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
nextMonthDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next month arrow when the arrow is disabled. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
nextMonthDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next month arrow when the user presses the mouse button down on the arrow. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
nextMonthOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next month arrow when the user moves the mouse pointer over the arrow. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
nextMonthUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next month arrow when the mouse pointer is not over the arrow. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
nextYearDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next year arrow when the arrow is disabled. The default value is the DateChooserYearArrowSkin class. 		DateChooser
nextYearDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next Year arrow when the user presses the mouse button down on the arrow. The default value is the DateChooserYearArrowSkin class. 		DateChooser
nextYearOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next Year arrow when the user moves the mouse pointer over the arrow. The default value is the DateChooserYearArrowSkin class. 		DateChooser
nextYearUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the next Year arrow when the mouse pointer is not over the arrow. The default value is the DateChooserYearArrowSkin class. 		DateChooser
prevMonthDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous month arrow when the arrow is disabled. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
prevMonthDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous month arrow when the user presses the mouse button down over the arrow. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
prevMonthOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous month arrow when the user holds the mouse pointer over the arrow. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
prevMonthUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous month arrow when the mouse pointer is not over the arrow. The default value is the DateChooserMonthArrowSkin class. 		DateChooser
prevYearDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous Year arrow when the arrow is disabled. The default value is the DateChooserYearArrowSkin class. 		DateChooser
prevYearDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous Year arrow when the user presses the mouse button down over the arrow. The default value is the DateChooserYearArrowSkin class. 		DateChooser
prevYearOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous Year arrow when the user holds the mouse pointer over the arrow. The default value is the DateChooserYearArrowSkin class. 		DateChooser
prevYearUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the previous Year arrow when the mouse button not over the arrow. The default value is the DateChooserYearArrowSkin class. 		DateChooser
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
rollOverColor
Type: uint Format: Color CSS Inheritance: yes
Color of the highlight area of the date when the user holds the mouse pointer over a date in the DateChooser control. The default value is 0xE3FFD6. 		DateChooser
rollOverIndicatorSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the highlight area of the date when the user holds the mouse pointer over a date in the DateChooser control. The default value is mx.skins.halo.DateChooserIndicator. 		DateChooser
selectionColor
Type: uint Format: Color CSS Inheritance: yes
Color of the highlight area of the currently selected date in the DateChooser control. The default value is 0xCDFFC1. 		DateChooser
selectionIndicatorSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the highlight area of the currently selected date in the DateChooser control. The default value is mx.skins.halo.DateChooserIndicator. 		DateChooser
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

DateChooser
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		DateChooser
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		DateChooser
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
todayColor
Type: uint Format: Color CSS Inheritance: yes
Color of the background of today's date. The default value is 0x2B333C. 		DateChooser
todayIndicatorSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the highlight area of today's date in the DateChooser control. The default value is mx.skins.halo.DateChooserIndicator. 		DateChooser
todayStyleName
Type: String CSS Inheritance: no
Name of the style sheet definition to configure the appearance of the current day's numeric text, which is highlighted in the control when the showToday property is true. Specify a "color" style to change the font color. If omitted, the current day text inherits the text styles of the control. 		DateChooser
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
verticalGap
Type: Number Format: Length CSS Inheritance: no
Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. 		DateChooser
weekDayStyleName
Type: String CSS Inheritance: no
Name of the style sheet definition to configure the weekday names of the control. If omitted, the weekday names inherit the text styles of the control. 		DateChooser
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
allowDisjointSelection property
allowDisjointSelection:Boolean [read-write]

If true, specifies that non-contiguous(disjoint) selection is allowed in the DateChooser control. This property has an effect only if the allowMultipleSelection property is true. Setting this property changes the appearance of the DateChooser control.

The default value is true;.

This property can be used as the source for data binding.

Implementation
    public function get allowDisjointSelection():Boolean
    public function set allowDisjointSelection(value:Boolean):void
allowMultipleSelection property
allowMultipleSelection:Boolean [read-write]

If true, specifies that multiple selection is allowed in the DateChooser control. Setting this property changes the appearance of the DateChooser control.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get allowMultipleSelection():Boolean
    public function set allowMultipleSelection(value:Boolean):void
dayNames property
dayNames:Array [read-write]

The weekday names for DateChooser control. Changing this property changes the day labels of the DateChooser control. Sunday is the first day (at index 0). The rest of the week names follow in the normal order.

The default value is [ "S", "M", "T", "W", "T", "F", "S" ]..

This property can be used as the source for data binding.

Implementation
    public function get dayNames():Array
    public function set dayNames(value:Array):void
disabledDays property
disabledDays:Array [read-write]

The days to disable in a week. All the dates in a month, for the specified day, are disabled. This property changes the appearance of the DateChooser control. The elements of this array can have values from 0 (Sunday) to 6 (Saturday). For example, a value of [ 0, 6 ] disables Sunday and Saturday.

The default value is [].

This property can be used as the source for data binding.

Implementation
    public function get disabledDays():Array
    public function set disabledDays(value:Array):void
disabledRanges property
disabledRanges:Array [read-write]

Disables single and multiple days.

This property accepts an Array of objects as a parameter. Each object in this array is a Date object, specifying a single day to disable; or an object containing either or both of the rangeStart and rangeEnd properties, each of whose values is a Date object. The value of these properties describes the boundaries of the date range. If either is omitted, the range is considered unbounded in that direction. If you specify only rangeStart, all the dates after the specified date are disabled, including the rangeStart date. If you specify only rangeEnd, all the dates before the specified date are disabled, including the rangeEnd date. To disable a single day, use a single Date object specifying a date in the Array.

The following example, disables the following dates: January 11 2006, the range January 23 - February 10 2006, and March 1 2006 and all following dates.

disabledRanges="{[ new Date(2006,0,11), {rangeStart:
      new Date(2006,0,23), rangeEnd: new Date(2006,1,10)},
      {rangeStart: new Date(2006,2,1)} ]}"

The default value is [].

This property can be used as the source for data binding.

Implementation
    public function get disabledRanges():Array
    public function set disabledRanges(value:Array):void
displayedMonth property
displayedMonth:int [read-write]

Used together with the displayedYear property, the displayedMonth property specifies the month displayed in the DateChooser control. Month numbers are zero-based, so January is 0 and December is 11. Setting this property changes the appearance of the DateChooser control.

The default value is the current month.

This property can be used as the source for data binding.

Implementation
    public function get displayedMonth():int
    public function set displayedMonth(value:int):void
displayedYear property
displayedYear:int [read-write]

Used together with the displayedMonth property, the displayedYear property specifies the month displayed in the DateChooser control. Setting this property changes the appearance of the DateChooser control.

The default value is the current year.

This property can be used as the source for data binding.

Implementation
    public function get displayedYear():int
    public function set displayedYear(value:int):void
firstDayOfWeek property
firstDayOfWeek:int [read-write]

Number representing the day of the week to display in the first column of the DateChooser control. The value must be in the range 0 to 6, where 0 corresponds to Sunday, the first element of the dayNames Array.

Setting this property changes the order of the day columns. For example, setting it to 1 makes Monday the first column in the control.

The default value is 0 (Sunday).

This property can be used as the source for data binding.

Implementation
    public function get firstDayOfWeek():int
    public function set firstDayOfWeek(value:int):void
maxYear property
maxYear:int [read-write]

The last year selectable in the control.

The default value is 2100.

Implementation
    public function get maxYear():int
    public function set maxYear(value:int):void
minYear property
minYear:int [read-write]

The first year selectable in the control.

The default value is 1900.

Implementation
    public function get minYear():int
    public function set minYear(value:int):void
monthNames property
monthNames:Array [read-write]

Names of the months displayed at the top of the DateChooser control. The monthSymbol property is appended to the end of the value specified by the monthNames property, which is useful in languages such as Japanese.

The default value is [ "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December" ].

This property can be used as the source for data binding.

Implementation
    public function get monthNames():Array
    public function set monthNames(value:Array):void
monthSymbol property
monthSymbol:String [read-write]

This property is appended to the end of the value specified by the monthNames property to define the names of the months displayed at the top of the DateChooser control. Some languages, such as Japanese, use an extra symbol after the month name.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get monthSymbol():String
    public function set monthSymbol(value:String):void
selectableRange property
selectableRange:Object [read-write]

Range of dates between which dates are selectable. For example, a date between 04-12-2006 and 04-12-2007 is selectable, but dates out of this range are disabled.

This property accepts an Object as a parameter. The Object contains two properties, rangeStart and rangeEnd, of type Date. If you specify only rangeStart, all the dates after the specified date are enabled. If you only specify rangeEnd, all the dates before the specified date are enabled. To enable only a single day in a DateChooser control, you can pass a Date object directly.

The following example enables only the range January 1, 2006 through June 30, 2006. Months before January and after June do not appear in the DateChooser.

selectableRange="{{rangeStart : new Date(2006,0,1), rangeEnd : new Date(2006,5,30)}}"

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get selectableRange():Object
    public function set selectableRange(value:Object):void
selectedDate property
selectedDate:Date [read-write]

Date selected in the DateChooser control.

Selecting the currently selected date in the control deselects it, sets the selectedDate property to null, and then dispatches the change event.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get selectedDate():Date
    public function set selectedDate(value:Date):void
selectedRanges property
selectedRanges:Array [read-write]

Selected date ranges.

This property accepts an Array of objects as a parameter. Each object in this array has two date Objects, rangeStart and rangeEnd. The range of dates between each set of rangeStart and rangeEnd (inclusive) are selected. To select a single day, set both rangeStart and rangeEnd to the same date.

The following example, selects the following dates: January 11 2006, the range January 23 - February 10 2006.

selectedRanges="{[ {rangeStart: new Date(2006,0,11),
   rangeEnd: new Date(2006,0,11)}, {rangeStart:new Date(2006,0,23),
   rangeEnd: new Date(2006,1,10)} ]}"

The default value is [].

This property can be used as the source for data binding.

Implementation
    public function get selectedRanges():Array
    public function set selectedRanges(value:Array):void
showToday property
showToday:Boolean [read-write]

If true, specifies that today is highlighted in the DateChooser control. Setting this property changes the appearance of the DateChooser control.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get showToday():Boolean
    public function set showToday(value:Boolean):void
yearNavigationEnabled property
yearNavigationEnabled:Boolean [read-write]

Enables year navigation. When true an up and down button appear to the right of the displayed year. You can use these buttons to change the current year. These button appear to the left of the year in locales where year comes before the month in the date format.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get yearNavigationEnabled():Boolean
    public function set yearNavigationEnabled(value:Boolean):void
yearSymbol property
yearSymbol:String [read-write]

This property is appended to the end of the year displayed at the top of the DateChooser control. Some languages, such as Japanese, add a symbol after the year.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get yearSymbol():String
    public function set yearSymbol(value:String):void
Constructor detail
DateChooser () constructor
public function DateChooser()

Constructor.

Event detail
change event
Event object type: mx.events.CalendarLayoutChangeEvent
CalendarLayoutChangeEvent.type property = mx.events.CalendarLayoutChangeEvent.CHANGE

Dispatched when a date is selected or changed.

The CalendarLayoutChangeEvent.CHANGE constant defines the value of the type property of the event object for a change event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
newDate | The date selected in the control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | The event that triggered this change event; usually a change event.
scroll event
Event object type: mx.events.DateChooserEvent
DateChooserEvent.type property = mx.events.DateChooserEvent.SCROLL

Dispatched when the month changes due to user interaction.

The DateChooserEvent.SCROLL constant defines the value of the type property of the event object for a scrollevent.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
detail | The scroll direction.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | The event that triggered this change event; usually a scroll.
Examples
DateChooserExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate DateChooser control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            // Event handler function to write the selected
            // date to the Label control.
            private function displayDate(date:Date):void {
                if (date == null)
                    selection.text = "Date selected: ";
                else
                    selection.text = "Date selected: " + date.getFullYear().toString() +
                        '/' + (date.getMonth()+1).toString() + '/' + date.getDate();
            }
        ]]>
    </mx:Script>

    <mx:DateFormatter id="df"/>

    <mx:Panel title="DateChooser Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
            text="Select a date in the DateChooser control. Select it again to clear it."/>

        <mx:HBox horizontalGap="25">
          <mx:VBox>
              <mx:Label text="Simple DateChooser control."/>
              <mx:DateChooser id="dateChooser1" yearNavigationEnabled="true"
                  change="displayDate(DateChooser(event.target).selectedDate)"/>
              <mx:Label id="selection"  color="blue" text="Date selected:"/>
          </mx:VBox>

          <mx:VBox>
              <mx:Label text="Disable dates before June 1, 2006."/>
              <mx:DateChooser id="dateChooser2" yearNavigationEnabled="true"
                  disabledRanges="{[ {rangeEnd: new Date(2006, 5, 1)} ]}"/>
              <mx:Label  color="blue" text="Date selected: {df.format(dateChooser2.selectedDate)}"/>
          </mx:VBox>
        </mx:HBox>

    </mx:Panel>
</mx:Application>


mx.controls.DateField (Flex™ 2 Language Reference)

Class DateField | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class DateField
Inheritance | DateField Inheritance ComboBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IFocusManagerComponent, IListItemRenderer

The DateField control is a text field that shows the date with a calendar icon on its right side. When the user clicks anywhere inside the bounding box of the control, a DateChooser control pops up and shows the dates in the month of the current date. If no date is selected, the text field is blank and the month of the current date is displayed in the DateChooser control.

When the DateChooser control is open, the user can scroll through months and years, and select a date. When a date is selected, the DateChooser control closes, and the text field shows the selected date.

The user can also type the date in the text field if the editable property of the DateField control is set to true.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:DateField> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:DateField
    Properties
    dayNames="["S", "M", "T", "W", "T", "F", "S"]"
    disabledDays="No default"
    disabledRanges="No default"
    displayedMonth="Current month"
    displayedYear="Current year"
    firstDayOfWeek="0"
    formatString="MM/DD/YYYY"
    labelFunction="Internal formatter"
    maxYeay="2100"
    minYear="1900"
    monthNames="["January", "February", "March", "April", "May",
    "June", "July", "August", "September", "October", "November",
    "December"]"
    monthSymbol=""
    parseFunction="Internal parser"
    selectableRange="No default"
    selectedDate="No default"
    showToday="true|false"
    yearNavigationEnabled="false|true"
    yearSymbol=""

   Styles
    borderColor="0xAAB3B3"
    borderThickness="1"
    color="0x0xB333C"
    cornerRadius="0"
    dateChooserStyleName="No default"
    disabledColor="0xAAB3B3"
    fillAlphas="[0.6, 0.4]"
    fillColors="[0xFFFFFF, 0xCCCCCC]"
    focusAlpha="0.5"
    focusRoundedCorners="tl tr bl br"
    fontAntiAliasType="advanced"
    fontFamily="Verdana"
    fontGridFitType="pixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    headerColors="[0xE1E5EB, 0xF4F5F7]"
    headerStyleName="No default"
    highlightAlphas="[0.3, 0.0]"
    leading="2"
    paddingLeft="0"
    paddingRight="0"
    rollOverColor="0xE3FFD6"
    selectionColor="0xB7F39B"
    textAlign="left|right|center"
    textDecoration="none|underline"
    textIndent="0"
    todayColor="0x2B333C"
    todayStyleName="No default"
    weekDayStyleName="No default"

    Events
    change="No default"
    close="No default"
    dataChange="No default"
    open="No default"
    scroll="No default"
  />

View the examples.

See also

mx.controls.DateChooser
DateChooser and DateField controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | DateField
Inherited | dataProvider : Object The set of items this component displays. | ComboBase
 | dayNames : Array Weekday names for DateChooser control. | DateField
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | disabledDays : Array Days to disable in a week. | DateField
 | disabledRanges : Array Disables single and multiple days. | DateField
 | displayedMonth : int Used with the displayedYear property, the displayedMonth property specifies the month displayed in the DateChooser control. | DateField
 | displayedYear : int Used with the displayedMonth property, the displayedYear property determines which year is displayed in the DateChooser control. | DateField
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | editable : Boolean A flag that indicates whether the control is editable, which lets the user directly type entries that are not specified in the dataProvider, or not editable, which requires the user select from the items in the dataProvider. | ComboBase
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | firstDayOfWeek : int Day of the week (0-6, where 0 is the first element of the dayNames Array) to display in the first column of the DateChooser control. | DateField
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
 | formatString : String The format of the displayed date in the text field. | DateField
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | imeMode : String Specifies the IME (input method editor) mode. | ComboBase
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | labelFunction : Function Function used to format the date displayed in the text field of the DateField control. | DateField
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | DateField
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
 | maxYear : int The last year selectable in the control. | DateField
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
 | minYear : int The first year selectable in the control. | DateField
 | monthNames : Array Names of the months displayed at the top of the control. | DateField
 | monthSymbol : String This property is appended to the end of the value specified by the monthNames property to define the names of the months displayed at the top of the control. | DateField
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
 | parseFunction : Function Function used to parse the date entered as text in the text field area of the DateField control and return a Date object to the control. | DateField
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | restrict : String Set of characters that a user can or cannot enter into the text field. | ComboBase
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectableRange : Object Range of dates between which dates are selectable. | DateField
 | selectedDate : Date Date as selected in the DateChooser control. | DateField
 | showToday : Boolean If true, specifies that today is highlighted in the DateChooser control. | DateField
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String Contents of the text field. | ComboBase
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The value of the selected item. | ComboBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
 | yearNavigationEnabled : Boolean Enables year navigation. | DateField
 | yearSymbol : String This property is appended to the end of the year displayed at the top of the control. | DateField
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ComboBase
Inherited | collection : ICollectionView The ICollectionView of items this component displays. | ComboBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the dataProvider and pass the items to the renderers. | ComboBase
Inherited | textInput : TextInput The internal TextInput subcomponent that displays the current selection. | ComboBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DateField()
Constructor
DateField
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
close():void
Closes the DateChooser control.
DateField
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
dateToString(value:Date, outputFormat:String):String
[static] Formats a Date into a String according to the outputFormat argument.
DateField
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
open():void
Opens the DateChooser control.
DateField
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
stringToDate(valueString:String, inputFormat:String):Date
[static] Parses a String object that contains a date, and returns a Date object corresponding to the String.
DateField
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | calculatePreferredSizeFromData(numItems:int):Object Determines default values of the height and width to use for the entries in the drop-down list. | ComboBase
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | collectionChangeHandler(event:Event):void Responds to changes to the data provider. | ComboBase
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | downArrowButton_buttonDownHandler(event:FlexEvent):void Performs some action when the drop-down button is pressed. | ComboBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | itemToUID(data:Object):String Determines the UID for a dataProvider item. | ComboBase
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Determines the measuredWidth and measuredHeight properties of the control. | ComboBase
Inherited | textInput_changeHandler(event:Event):void Handles changes to the TextInput that serves as the editable text field in the component. | ComboBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sizes and positions the internal components in the given width and height. | ComboBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when a date is selected or changed, and the DateChooser control closes. | DateField
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | close | Dispatched when a date is selected or the user clicks outside the drop-down list. | DateField
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | DateField
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
 | open | Dispatched when a user selects the field to open the drop-down list. | DateField
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | scroll | Dispatched when the month changes due to user interaction. | DateField
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The following controls support this style: Button, CheckBox, ComboBox, MenuBar, NumericStepper, ProgressBar, RadioButton, ScrollBar, Slider, and any components that support the borderStyle style. The default value depends on the component class; if not overriden for the class, the default value is 0xB7BABC. 		DateField
borderThickness
Type: Number Format: Length CSS Inheritance: no
The bounding box thickness of the DateChooser control. The default value is 1. 		DateField
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		DateField
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The following components support this style: Alert, Button, ComboBox, LinkButton, MenuBar, NumericStepper, Panel, ScrollBar, Tab, TitleWindow, and any component that supports a borderStyle property set to "solid". The default value depends on the component class; if not overriden for the class, the default value is 0. 		DateField
dateChooserStyleName
Type: String CSS Inheritance: no
Name of the CSS Style declaration to use for the styles for the DateChooser control's drop-down list. By default, the DateChooser control uses the DateField control's inheritable styles. 		DateField
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		DateField
Inherited
disabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the control is disabled. 		ComboBase
Inherited
downSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the user holds down the mouse button. 		ComboBase
Inherited
editableDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the control is disabled, and the editable property is true. 		ComboBase
Inherited
editableDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the user holds down the mouse button, and the editable property is true. 		ComboBase
Inherited
editableOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is over the control, and the editable property is true. 		ComboBase
Inherited
editableUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is not over the control, and the editable property is true. 		ComboBase
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fillAlphas
Type: Array CSS Inheritance: no
Alphas used for the background fill of controls. Use [1, 1] to make the control background opaque. The default value is [ 0.6, 0.4 ]. 		DateField
fillColors
Type: Array Format: Color CSS Inheritance: no
Colors used to tint the background of the control. Pass the same color for both values for a flat-looking control. The default value is [ 0xFFFFFF, 0xCCCCCC ]. 		DateField
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		DateField
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		DateField
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		DateField
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		DateField
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		DateField
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DateField
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		DateField
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		DateField
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DateField
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		DateField
headerColors
Type: Array Format: Color CSS Inheritance: yes
Colors of the band at the top of the DateChooser control. The default value is [ 0xE6EEEE, 0xFFFFFF ]. 		DateField
headerStyleName
Type: String CSS Inheritance: no
Name of the style sheet definition to configure the text (month name and year) and appearance of the header area of the control. 		DateField
highlightAlphas
Type: Array CSS Inheritance: no
Alpha transparencies used for the highlight fill of controls. The first value specifies the transparency of the top of the highlight and the second value specifies the transparency of the bottom of the highlight. The highlight covers the top half of the skin. The default value is [ 0.3, 0.0 ]. 		DateField
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

DateField
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
Inherited
overSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is over the control. 		ComboBase
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

DateField
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

DateField
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
rollOverColor
Type: uint Format: Color CSS Inheritance: yes
Color of the highlight area of the date when the user holds the mouse pointer over a date in the DateChooser control. The default value is 0xE3FFD6. 		DateField
selectionColor
Type: uint Format: Color CSS Inheritance: yes
Color of the highlight area of the currently selected date in the DateChooser control. The default value is 0xCDFFC1. 		DateField
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

DateField
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		DateField
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		DateField
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
todayColor
Type: uint Format: Color CSS Inheritance: yes
Color of the highlight of today's date in the DateChooser control. The default value is 0x2B333. 		DateField
todayStyleName
Type: String CSS Inheritance: no
Name of the style sheet definition to configure the appearance of the current day's numeric text, which is highlighted in the control when the showToday property is true. Specify a color style property to change the font color. If omitted, the current day text inherits the text styles of the control. 		DateField
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
upSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the background and border when the mouse is not over the control. 		ComboBase
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
weekDayStyleName
Type: String CSS Inheritance: no
Name of the style sheet definition to configure the weekday names of the control. If omitted, the weekday names inherit the text styles of the control. 		DateField
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The data property lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

When you use the control as a drop-in item renderer or drop-in item editor, Flex automatically writes the current value of the item to the selectedDate property of this control.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
dayNames property
dayNames:Array [read-write]

Weekday names for DateChooser control. Setting this property changes the day labels of the DateChooser control. Sunday is the first day (at index 0). The rest of the week names follow in the normal order.

The default value is [ "S", "M", "T", "W", "T", "F", "S" ].

This property can be used as the source for data binding.

Implementation
    public function get dayNames():Array
    public function set dayNames(value:Array):void
disabledDays property
disabledDays:Array [read-write]

Days to disable in a week. All the dates in a month, for the specified day, are disabled. This property immediately changes the user interface of the DateChooser control. The elements of this Array can have values from 0 (Sunday) to 6 (Saturday). For example, a value of [0, 6] disables Sunday and Saturday.

The default value is [].

This property can be used as the source for data binding.

Implementation
    public function get disabledDays():Array
    public function set disabledDays(value:Array):void
disabledRanges property
disabledRanges:Array [read-write]

Disables single and multiple days.

This property accepts an Array of objects as a parameter. Each object in this Array is a Date object that specifies a single day to disable; or an object containing one or both of the rangeStart and rangeEnd properties, each of whose values is a Date object. The value of these properties describes the boundaries of the date range. If either is omitted, the range is considered unbounded in that direction. If you specify only rangeStart, all the dates after the specified date are disabled, including the rangeStart date. If you specify only rangeEnd, all the dates before the specified date are disabled, including the rangeEnd date. To disable a single day, use a single Date object that specifies a date in the Array.

The following example, disables the following dates: January 11 2006, the range January 23 - February 10 2006, and March 1 2006 and all following dates.

disabledRanges="{[new Date(2006,0,11), {rangeStart:
   new Date(2006,0,23), rangeEnd: new Date(2006,1,10)},
   {rangeStart: new Date(2006,2,1)}]}"

Setting this property immediately changes the appearance of the DateChooser control, if the disabled dates are included in the displayedMonth and displayedYear properties.

The default value is [].

This property can be used as the source for data binding.

Implementation
    public function get disabledRanges():Array
    public function set disabledRanges(value:Array):void
displayedMonth property
displayedMonth:int [read-write]

Used with the displayedYear property, the displayedMonth property specifies the month displayed in the DateChooser control. Month numbers are zero-based, so January is 0 and December is 11. Setting this property immediately changes the appearance of the DateChooser control. The default value is the month number of today's date.

The default value is the current month.

This property can be used as the source for data binding.

Implementation
    public function get displayedMonth():int
    public function set displayedMonth(value:int):void
displayedYear property
displayedYear:int [read-write]

Used with the displayedMonth property, the displayedYear property determines which year is displayed in the DateChooser control. Setting this property immediately changes the appearance of the DateChooser control.

The default value is the current year.

This property can be used as the source for data binding.

Implementation
    public function get displayedYear():int
    public function set displayedYear(value:int):void
firstDayOfWeek property
firstDayOfWeek:int [read-write]

Day of the week (0-6, where 0 is the first element of the dayNames Array) to display in the first column of the DateChooser control. Setting this property changes the order of the day columns.

The default value is 0 (Sunday).

This property can be used as the source for data binding.

Implementation
    public function get firstDayOfWeek():int
    public function set firstDayOfWeek(value:int):void
formatString property
formatString:String [read-write]

The format of the displayed date in the text field. This property can contain "M", "D", "Y", delimiter, and punctuation characters. This String is case-sensitive, and uses the same options as the DateFormatter.formatString property.

The default value is "MM/DD/YYYY".

This property can be used as the source for data binding.

Implementation
    public function get formatString():String
    public function set formatString(value:String):void

See also

mx.formatters.DateFormatter.formatString
labelFunction property
labelFunction:Function [read-write]

Function used to format the date displayed in the text field of the DateField control. If no function is specified, the default format is used.

The function takes a Date object as an argument, and returns a String in the format to be displayed, as the following example shows:

   public function formatDate(currentDate:Date):String {
       ...
       return dateString;
   }

If you allow the user to enter a date in the text field of the DateField control, and you define a formatting function using the labelFunction property, you should specify a function to the parseFunction property that converts the input text string to a Date object for use by the DateField control, or set the parseFunction property to null.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get labelFunction():Function
    public function set labelFunction(value:Function):void

See also

mx.controls.DateField.parseFunction
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. The component can then use the listData property to initialize the data property of the drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
maxYear property
maxYear:int [read-write]

The last year selectable in the control.

The default value is 2100.

Implementation
    public function get maxYear():int
    public function set maxYear(value:int):void
minYear property
minYear:int [read-write]

The first year selectable in the control.

The default value is 1900.

Implementation
    public function get minYear():int
    public function set minYear(value:int):void
monthNames property
monthNames:Array [read-write]

Names of the months displayed at the top of the control. The monthSymbol property is appended to the end of the value specified by the monthNames property, which is useful in languages such as Japanese.

The default value is [ "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December" ].

This property can be used as the source for data binding.

Implementation
    public function get monthNames():Array
    public function set monthNames(value:Array):void
monthSymbol property
monthSymbol:String [read-write]

This property is appended to the end of the value specified by the monthNames property to define the names of the months displayed at the top of the control. Some languages, such as Japanese, use an extra symbol after the month name.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get monthSymbol():String
    public function set monthSymbol(value:String):void
parseFunction property
parseFunction:Function [read-write]

Function used to parse the date entered as text in the text field area of the DateField control and return a Date object to the control. If no function is specified, Flex uses the default function. If you set the parseFunction property, it should typically perform the reverse of the function specified to the labelFunction property.

The function takes two arguments and returns a Date object to the DateField control, as the following example shows:

   public function parseDate(valueString:String, inputFormat:String):Date {
       ...
       return newDate
   }

Where the valueString argument contains the text string entered by the user in the text field, and the inputFormat argument contains the format of the string. For example, if you only allow the user to enter a text sting using two characters for month, day, and year, then pass "MM/DD/YY" to the inputFormat argument.

This property can be used as the source for data binding.

Implementation
    public function get parseFunction():Function
    public function set parseFunction(value:Function):void

See also

mx.controls.DateField.labelFunction
selectableRange property
selectableRange:Object [read-write]

Range of dates between which dates are selectable. For example, a date between 04-12-2006 and 04-12-2007 is selectable, but dates out of this range are disabled.

This property accepts an Object as a parameter. The Object contains two properties, rangeStart and rangeEnd, of type Date. If you specify only rangeStart, all the dates after the specified date are enabled. If you only specify rangeEnd, all the dates before the specified date are enabled. To enable only a single day in a DateChooser control, you can pass a Date object directly.

The following example enables only the range January 1, 2006 through June 30, 2006. Months before January and after June do not appear in the DateChooser.

selectableRange="{{rangeStart : new Date(2006,0,1),
   rangeEnd : new Date(2006,5,30)}}"

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get selectableRange():Object
    public function set selectableRange(value:Object):void
selectedDate property
selectedDate:Date [read-write]

Date as selected in the DateChooser control. Accepts a Date object as a parameter.

Selecting the currently selected date in the control deselects it, sets the selectedDate property to null, and then dispatches the change event.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get selectedDate():Date
    public function set selectedDate(value:Date):void
showToday property
showToday:Boolean [read-write]

If true, specifies that today is highlighted in the DateChooser control. Setting this property immediately changes the appearance of the DateChooser control.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get showToday():Boolean
    public function set showToday(value:Boolean):void
yearNavigationEnabled property
yearNavigationEnabled:Boolean [read-write]

Enables year navigation. When true an up and down button appear to the right of the displayed year. You can use these buttons to change the current year. These button appear to the left of the year in locales where year comes before the month in the date format.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get yearNavigationEnabled():Boolean
    public function set yearNavigationEnabled(value:Boolean):void
yearSymbol property
yearSymbol:String [read-write]

This property is appended to the end of the year displayed at the top of the control. Some languages, such as Japanese, add a symbol after the year.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get yearSymbol():String
    public function set yearSymbol(value:String):void
Constructor detail
DateField () constructor
public function DateField()

Constructor

Method detail
close () method
public function close():void

Closes the DateChooser control.

dateToString () method
public static function dateToString(value:Date, outputFormat:String):String

Formats a Date into a String according to the outputFormat argument. The outputFormat argument contains a pattern in which the value String is formatted. It can contain "M","D","Y", and delimiter and punctuation characters.

Parameters
value:Date — Date value to format.
outputFormat:String — String defining the date format.

Returns
String — The formatted date as a String.

Example
var todaysDate:String = DateField.dateToString(new Date(), "MM/DD/YYYY");

open () method
public function open():void

Opens the DateChooser control.

stringToDate () method
public static function stringToDate(valueString:String, inputFormat:String):Date

Parses a String object that contains a date, and returns a Date object corresponding to the String. The inputFormat argument contains the pattern in which the valueString String is formatted. It can contain "M","D","Y", and delimiter and punctuation characters. The function does not check for the validity of the Date object. If the value of the date, month, or year is NaN, this method returns null.

Parameters
valueString:String — Date value to format.
inputFormat:String — String defining the date format.

Returns
Date — The formatted date as a Date object.

Example
var dob:Date = DateField.stringToDate("06/30/2005", "MM/DD/YYYY");

Event detail
change event
Event object type: mx.events.CalendarLayoutChangeEvent
CalendarLayoutChangeEvent.type property = mx.events.CalendarLayoutChangeEvent.CHANGE

Dispatched when a date is selected or changed, and the DateChooser control closes.

The CalendarLayoutChangeEvent.CHANGE constant defines the value of the type property of the event object for a change event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
newDate | The date selected in the control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | The event that triggered this change event; usually a change event.
close event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.CLOSE

Dispatched when a date is selected or the user clicks outside the drop-down list.

The DropdownEvent.CLOSE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
open event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.OPEN

Dispatched when a user selects the field to open the drop-down list.

The DropdownEvent.OPEN constant defines the value of the type property of the event object for a open event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
scroll event
Event object type: mx.events.DateChooserEvent
DateChooserEvent.type property = mx.events.DateChooserEvent.SCROLL

Dispatched when the month changes due to user interaction.

The DateChooserEvent.SCROLL constant defines the value of the type property of the event object for a scrollevent.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
detail | The scroll direction.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | The event that triggered this change event; usually a scroll.
Examples
DateFieldExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the DateField control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
      <![CDATA[

         // Event handler for the DateField change event.
         private function dateChanged(date:Date):void {
            if (date == null)
                selection.text = "Date selected: ";
            else
                selection.text = "Date selected: " + date.getFullYear().toString() +
                    '/' + (date.getMonth()+1).toString() + '/' + date.getDate();
         }
      ]]>
    </mx:Script>

 <mx:DateFormatter id="df"/>

    <mx:Panel title="DateField Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%"  color="blue"
            text="Select a date in the DateField control. Select it again to clear it."/>

        <mx:Label text="Basic DateField:"/>
        <mx:DateField id="dateField1" yearNavigationEnabled="true"
            change="dateChanged(DateField(event.target).selectedDate)" />
        <mx:Label id="selection"  color="blue" text="Date selected:" />

        <mx:Label text="Disable dates before June 1, 2006."/>
        <mx:DateField id="dateField2" yearNavigationEnabled="true"
            disabledRanges="{[ {rangeEnd: new Date(2006, 5, 1)} ]}" />
        <mx:Label  color="blue" text="Date selected: {df.format(dateField2.selectedDate)}"/>

    </mx:Panel>
</mx:Application>


mx.controls.FormItemLabel (Flex™ 2 Language Reference)

Class FormItemLabel | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls
Class | public class FormItemLabel
Inheritance | FormItemLabel Inheritance Label Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The FormItem container uses a FormItemLabel object to display the label portion of the FormItem container. The FormItemLabel class does not add any functionality to its superclass, Label. Instead, its purpose is to let you set styles in a FormItemLabel type selector and set styles that affect the labels in all FormItem containers.

See also

mx.containers.FormItem

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | condenseWhite : Boolean Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a Label control with HTML text. | Label
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object Lets you pass a value to the component when you use it in an item renderer or item editor. | Label
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | htmlText : String Specifies the text displayed by the Label control, including HTML markup that expresses the styles of that text. | Label
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | Label
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selectable : Boolean Specifies whether the text can be selected. | Label
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String Specifies the plain text displayed by this control. | Label
Inherited | textHeight : Number The height of the text. | Label
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | textWidth : Number The width of the text. | Label
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | truncateToFit : Boolean = true If this propery is true, and the Label control size is smaller than its text, the text of the Label control is truncated using a localizable string, such as "...". | Label
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField that renders the text of this Label. | Label
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FormItemLabel()
Constructor.
FormItemLabel
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getLineMetrics(lineIndex:int):TextLineMetrics
Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
Label
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Label
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Label
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Label
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Label
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Label
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Label
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Label
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Label
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Label
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Label
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Label
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Label
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Label
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
FormItemLabel () constructor
public function FormItemLabel()

Constructor.


mx.controls.HorizontalList (Flex™ 2 Language Reference)

Class HorizontalList | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class HorizontalList
Inheritance | HorizontalList Inheritance TileBase Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The HorizontalList control displays a horizontal list of items. If there are more items than can be displayed at once, it can display a horizontal scroll bar so the user can access all items in the list.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HorizontalList> tag inherits all of the tag attributes of its superclass and it adds no new tag attributes.

  <mx:HorizontalList/>

Default MXML Property dataProvider

View the examples.

See also

Example: Using an item renderer with the TileList and HorizontalList controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
Inherited | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
Inherited | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
Inherited | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelField : String The name of the field in the data provider items to display as the label. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HorizontalList()
Constructor.
HorizontalList
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawTileBackground(s:Sprite, rowIndex:int, columnIndex:int, width:Number, height:Number, color:uint, item:IListItemRenderer):DisplayObject
Draws the background for an individual tile.
TileBase
Inherited
drawTileBackgrounds():void
Draws the backgrounds, if any, behind all of the tiles.
TileBase
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
Inherited
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
Inherited | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
Inherited | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors to use for the backgrounds of the items in the list. | ListBase
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | rollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user rolls over it. | ListBase
Inherited | selectionColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user selects it. | ListBase
Inherited | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the component is disabled. | ListBase
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
Inherited | selectionEasingFunction | Type: Function CSS Inheritance: no The easingFunction for the selection effect. | ListBase
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user rolls over a it. | ListBase
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user selects it. | ListBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
HorizontalList () constructor
public function HorizontalList()

Constructor.

Examples
HorizontalListExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HorizontalList Control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

             [Bindable]
             [Embed(source="assets/Nokia_6630.png")]
             public var phone1:Class;

             [Bindable]
             [Embed(source="assets/Nokia_6680.png")]
             public var phone2:Class;

             [Bindable]
             [Embed(source="assets/Nokia_7610.png")]
             public var phone3:Class;

             [Bindable]
             [Embed(source="assets/Nokia_lg_v_keypad.png")]
             public var phone4:Class;

             [Bindable]
             [Embed(source="assets/Nokia_sm_v_keypad.png")]
             public var phone5:Class;
        ]]>
    </mx:Script>

    <mx:Panel title="HorizontalList Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
           text="A HorizontalList control displays items in a single row."/>

        <mx:HorizontalList id="CameraSelection" height="250" columnCount="3" columnWidth="125">
            <mx:dataProvider>
                <mx:Array>
                    <mx:Object label="Nokia 6630" icon="{phone1}"/>
                    <mx:Object label="Nokia 6680" icon="{phone2}"/>
                    <mx:Object label="Nokia 7610" icon="{phone3}"/>
                    <mx:Object label="Nokia LGV" icon="{phone4}"/>
                    <mx:Object label="Nokia LMV" icon="{phone5}"/>
                </mx:Array>
            </mx:dataProvider>
        </mx:HorizontalList>

    </mx:Panel>
</mx:Application>


mx.controls.HRule (Flex™ 2 Language Reference)

Class HRule | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class HRule
Inheritance | HRule Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The HRule control creates a single horizontal line. You typically use this control to create a dividing line within a container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HRule> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:HRule
    Styles
    strokeColor="0xC4CCCC"
    shadowColor="0xEEEEEE"
    strokeWidth="2"
  />

View the examples.

See also

mx.controls.VRule
HRule and VRule controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HRule()
Constructor
HRule
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowColor
Type: uint Format: Color CSS Inheritance: yes
The shadow color of the line.
  • If strokeWidth is 1, shadowColor does nothing.
  • If strokeWidth is 2, shadowColor is the color of the bottom line.
  • If strokeWidth is greater than 2, shadowColor is the color of the bottom and right edges of the rectangle.
The default value is 0xEEEEEE. 		HRule
strokeColor
Type: uint Format: Color CSS Inheritance: yes
The color of the line.
  • If strokeWidth is 1, strokeColor is the color of the entire line.
  • If strokeWidth is 2, strokeColor is the color of the top line.
  • If strokeWidth is greater than 2, strokeColor is the color of the top and left edges of the rectangle.
The default value is 0xC4CCCC. 		HRule
strokeWidth
Type: Number Format: Length CSS Inheritance: yes
The thickness of the rule in pixels.
  • If strokeWidth is 1, the rule is a 1-pixel-wide line.
  • If strokeWidth is 2, the rule is two adjacent 1-pixel-wide horizontal lines.
  • If strokeWidth is greater than 2, the rule is a hollow rectangle with 1-pixel-wide edges.
The default value is 2. 		HRule
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
HRule () constructor
public function HRule()

Constructor

Examples
SimpleHRule
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HRule control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:WipeLeft id="myWL"/>

    <mx:Panel title="HRule Control Example" id="myPanel"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:HRule rollOverEffect="{myWL}" width="100%" strokeWidth="1" strokeColor="red"/>
        <mx:Label width="100%" color="blue"
            text="Move mouse over HorizontalRule control to redraw it."/>

    </mx:Panel>
</mx:Application>


mx.controls.HScrollBar (Flex™ 2 Language Reference)

Class HScrollBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class HScrollBar
Inheritance | HScrollBar Inheritance ScrollBar Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The HScrollBar (horizontal ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area. This control extends the base ScrollBar control.

Although you can use the HScrollBar control as a stand-alone control, you usually combine it as part of another group of components to provide scrolling functionality.

A ScrollBar control consist of four parts: two arrow buttons, a track, and a thumb. The position of the thumb and the display of the buttons depend on the current state of the control. The ScrollBar control uses four parameters to calculate its display state:

  • Minimum range value
  • Maximum range value
  • Current position - must be within the minimum and maximum range values
  • Viewport size - represents the number of items in the range that you can display at one time. The number of items must be less than or equal to the range, where the range is the set of values between the minimum range value and the maximum range value.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HScrollBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:HScrollBar

    Styles
    repeatDelay="500"
    repeatInterval="35"

    Events
    scroll="No default"
  />

View the examples.

See also

mx.controls.scrollClasses.ScrollBar
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | lineScrollSize : Number Amount to scroll when an arrow button is pressed, in pixels. | ScrollBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxScrollPosition : Number Number which represents the maximum scroll position. | ScrollBar
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minScrollPosition : Number Number that represents the minimum scroll position. | ScrollBar
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | pageScrollSize : Number Amount to move the scroll thumb when the scroll bar track is pressed, in pixels. | ScrollBar
Inherited | pageSize : Number The number of lines equivalent to one page. | ScrollBar
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollPosition : Number Number that represents the current scroll position. | ScrollBar
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HScrollBar()
Constructor.
HScrollBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setScrollProperties(pageSize:Number, minScrollPosition:Number, maxScrollPosition:Number, pageScrollSize:Number = 0):void
Sets the range and viewport size of the ScrollBar control.
ScrollBar
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | scroll | Dispatched when the ScrollBar control scrolls through user initiated action or programmatically. | HScrollBar
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollBar
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollBar
Inherited | downArrowDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when it is disabled. | ScrollBar
Inherited | downArrowDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when you click the arrow button . | ScrollBar
Inherited | downArrowOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when the mouse pointer is over the arrow button. | ScrollBar
Inherited | downArrowUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar. | ScrollBar
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | ScrollBar
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | ScrollBar
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | ScrollBar
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the repeatInterval. The default value is 500. | HScrollBar
 | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. The default value is 35. | HScrollBar
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | thumbDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar when you click the thumb. | ScrollBar
Inherited | thumbIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon for the thumb of the scroll bar. | ScrollBar
Inherited | thumbOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar when the mouse pointer is over the thumb. | ScrollBar
Inherited | thumbUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar. | ScrollBar
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | trackColors | Type: Array Format: Color CSS Inheritance: no The colors of the track, as an array of two colors. | ScrollBar
Inherited | trackSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the track of the scroll bar. | ScrollBar
Inherited | upArrowDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when it is disabled. | ScrollBar
Inherited | upArrowDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when you click the arrow button. | ScrollBar
Inherited | upArrowOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when the mouse pointer is over the arrow button. | ScrollBar
Inherited | upArrowUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar. | ScrollBar
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Inherited | THICKNESS : Number = 16 [static] The width of a vertical scrollbar, or the height of a horizontal scrollbar, in pixels. | ScrollBar
Constructor detail
HScrollBar () constructor
public function HScrollBar()

Constructor.

Event detail
scroll event
Event object type: mx.events.ScrollEvent
ScrollEvent.type property = mx.events.ScrollEvent.SCROLL

Dispatched when the ScrollBar control scrolls through user initiated action or programmatically.

The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the change in scroll position, expressed in pixels. A positive value indicates the scroll was down or to the right. A negative value indicates the scroll was up or to the left.
direction | Contains the scroll direction, either ScrollEventDirection.HORIZONTAL or ScrollEventDirection.VERTICAL.
position | Contains the new scroll position.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
HScrollBarExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the HScrollBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

     <mx:Script>
        <![CDATA[

            import mx.events.ScrollEvent;

            // Event handler function to display the scroll location
            // as you move the scroll thumb.
            private function myScroll(event:ScrollEvent):void
            {
                showPosition.text = "HScrollBar properties summary:" + '\n' +
                    "------------------------------------" + '\n' +
                    "Current scroll position: " + event.currentTarget.scrollPosition  + '\n' +
                    "The maximum scroll position: " + event.currentTarget.maxScrollPosition + '\n' +
                    "The minimum scroll position: " + event.currentTarget.minScrollPosition ;
            }
        ]]>
    </mx:Script>

    <mx:Panel id="panel" title="HScrollBar Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
           text="Click on the scroll bar to view its properties."/>

        <mx:HScrollBar id="bar" width="100%"
            minScrollPosition="0" maxScrollPosition="{panel.width - 20}"
            lineScrollSize="50" pageScrollSize="100"
            scroll="myScroll(event);"
            repeatDelay="1000" repeatInterval="500" />

        <mx:TextArea height="100%" width="100%" id="showPosition" color="blue" />

    </mx:Panel>
</mx:Application>


mx.controls.HSlider (Flex™ 2 Language Reference)

Class HSlider | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class HSlider
Inheritance | HSlider Inheritance Slider Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The HSlider control lets users select a value by moving a slider thumb between the end points of the slider track. The current value of the slider is determined by the relative location of the thumb between the end points of the slider, corresponding to the slider's minimum and maximum values.

The slider may allow a continuous range of values between its minimum and maximum values or it may be restricted to values at specific intervals between the minimum and maximum value. It may show tick marks at specified intervals along the track. These tick marks are independent of the allowed values of the slider. The slider may also use a data tip to display its current value.

The HSlider control has a horizontal direction. The slider track stretches from left to right, and the labels and tick marks are placed at the top or bottom of the track.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HSlider> tag inherits all of the tag attributes of its superclass, and adds the following tag attribute:

  <mx:HSlider
    Styles
    dataTipPlacement="top"
  />

View the examples.

See also

mx.controls.VSlider
mx.controls.sliderClasses.Slider
mx.controls.sliderClasses.SliderThumb
mx.controls.sliderClasses.SliderDataTip
mx.controls.sliderClasses.SliderLabel
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowThumbOverlap : Boolean = false If set to false, then each thumb can only be moved to the edge of the adjacent thumb. | Slider
Inherited | allowTrackClick : Boolean = true Specifies whether clicking on the track will move the slider thumb. | Slider
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataTipFormatFunction : Function Callback function that formats the data tip text. | Slider
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labels : Array An array of strings used for the slider labels. | Slider
Inherited | liveDragging : Boolean = false Specifies whether live dragging is enabled for the slider. | Slider
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maximum : Number The maximum allowed value on the slider. | Slider
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minimum : Number The minimum allowed value on the slider control. | Slider
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | showDataTip : Boolean = true If set to true, show a data tip during user interaction containing the current value of the slider. | Slider
Inherited | sliderDataTipClass : Class A reference to the class to use for the data tip. | Slider
Inherited | sliderThumbClass : Class A reference to the class to use for each thumb. | Slider
Inherited | snapInterval : Number Specifies the increment value of the slider thumb as the user moves the thumb. | Slider
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | thumbCount : int The number of thumbs allowed on the slider. | Slider
Inherited | tickInterval : Number The spacing of the tick marks relative to the maximum value of the control. | Slider
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Number Contains the position of the thumb, and is a number between the minimum and maximum properties. | Slider
Inherited | values : Array An array of values for each thumb when thumbCount is greater than 1. | Slider
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HSlider()
Constructor.
HSlider
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
getThumbAt(index:int):SliderThumb
Returns the thumb object at the given index.
Slider
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setThumbValueAt(index:int, value:Number):void
This method sets the value of a slider thumb, and updates the display.
Slider
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the amount of space that the component takes up. | Slider
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Positions the elements of the control. | Slider
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the slider changes value due to mouse or keyboard interaction. | Slider
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | thumbDrag | Dispatched when the slider's thumb is pressed and then moved by the mouse. | Slider
Inherited | thumbPress | Dispatched when the slider's thumb is pressed, meaning the user presses the mouse button over the thumb. | Slider
Inherited | thumbRelease | Dispatched when the slider's thumb is released, meaning the user releases the mouse button after a thumbPress event. | Slider
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no The color of the black section of the border. | Slider
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | dataTipOffset | Type: Number Format: Length CSS Inheritance: no The offset, in pixels, of the data tip relative to the thumb. | Slider
 | dataTipPlacement | Type: String CSS Inheritance: no The location of the data tip relative to the thumb. Possible values are "left", "right", "top", and "bottom". The default value is "top". | HSlider
Inherited | dataTipPrecision | Type: int CSS Inheritance: no Number of decimal places to use for the data tip text. | Slider
Inherited | dataTipStyleName | Type: String CSS Inheritance: no The name of the style declaration to use for the data tip. | Slider
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Specifies the alpha transparency values used for the background fill of components. | Slider
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the slider thumb. | Slider
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Specifies the colors used to tint the background fill of the component. | Slider
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | labelOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the labels relative to the track. | Slider
Inherited | labelStyleName | Type: String CSS Inheritance: no The name of the style to use for the slider label. | Slider
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | showTrackHighlight | Type: Boolean CSS Inheritance: no Specifies whether to enable track highlighting between thumbs (or a single thumb and the beginning of the track). | Slider
Inherited | slideDuration | Type: Number Format: Time CSS Inheritance: no Duration in milliseconds for the sliding animation when you click on the track to move a thumb. | Slider
Inherited | slideEasingFunction | Type: Function CSS Inheritance: no Tweening function used by the sliding animation when you click on the track to move a thumb. | Slider
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | thumbDisabledSkin | Type: Class CSS Inheritance: no The skin for the slider thumb disabled state. | Slider
Inherited | thumbDownSkin | Type: Class CSS Inheritance: no The skin for the slider thumb down state. | Slider
Inherited | thumbOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the thumb relative to the track. | Slider
Inherited | thumbOverSkin | Type: Class CSS Inheritance: no The skin for the slider thumb over state. | Slider
Inherited | thumbUpSkin | Type: Class CSS Inheritance: no The skin for the slider thumb up state. | Slider
Inherited | tickColor | Type: uint Format: Color CSS Inheritance: no The color of the tick marks. | Slider
Inherited | tickLength | Type: Number Format: Length CSS Inheritance: no The length in pixels of the tick marks. | Slider
Inherited | tickOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the tick marks relative to the track. | Slider
Inherited | tickThickness | Type: Number Format: Length CSS Inheritance: no The thickness in pixels of the tick marks. | Slider
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | trackColors | Type: Array Format: Color CSS Inheritance: no The colors of the track, as an array of two colors. | Slider
Inherited | trackHighlightSkin | Type: Class CSS Inheritance: no The skin for the slider track when it is selected. | Slider
Inherited | trackMargin | Type: Number Format: Length CSS Inheritance: no The size of the track margins, in pixels. | Slider
Inherited | trackSkin | Type: Class CSS Inheritance: no The skin for the slider track. | Slider
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
HSlider () constructor
public function HSlider()

Constructor.

Examples
SimpleImageHSlider
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HSlider control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

          private var imageWidth:Number=0;
          private var imageHeight:Number=0;

          // Event handler function to change the image size.
          private function changeSize():void
          {
             phoneImage.width=uint(imageWidth*hSlider.value/100);
             phoneImage.height=uint(imageHeight*hSlider.value/100);
          }
        ]]>
    </mx:Script>

    <mx:Panel id="panel" title="HSlider Control Example" height="100%" width="95%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:HBox height="100%" width="100%">
            <mx:Image id="phoneImage" source="@Embed('assets/Nokia_6630.png')"
                creationComplete="imageWidth=phoneImage.width; imageHeight=phoneImage.height;" />
        </mx:HBox>

        <mx:Label color="blue" text="Drag the slider to resize the image."/>

        <mx:HSlider id="hSlider" minimum="0" maximum="100" value="100"
            dataTipPlacement="top"
            tickColor="black"
            snapInterval="1" tickInterval="10"
            labels="['0%','100%']"
            allowTrackClick="true"
            liveDragging="true"
            change="changeSize();"/>
    </mx:Panel>
</mx:Application>


mx.controls.Image (Flex™ 2 Language Reference)

Class Image | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Image
Inheritance | Image Inheritance SWFLoader Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IListItemRenderer

The Image control lets you import JPEG, PNG, GIF, and SWF files at runtime. You can also embed any of these files and SVG files at compile time by using @Embed(source='filename').

Note: Flex also includes the SWFLoader control for loading Flex applications. You typically use the Image control for loading static graphic files and SWF files, and use the SWFLoader control for loading Flex applications. The Image control is also designed to be used in custom item renderers and item editors.

Embedded images load immediately, because they are already part of the Flex SWF file. However, they add to the size of your application and slow down the application initialization process. Embedded images also require you to recompile your applications whenever your image files change.

The alternative to embedding a resource is to load the resource at runtime. You can load a resource from the local file system in which the SWF file runs, or you can access a remote resource, typically though an HTTP request over a network. These images are independent of your Flex application, so you can change them without causing a recompile operation as long as the names of the modified images remain the same. The referenced images add no additional overhead to an application's initial loading time. However, you might experience a delay when you use the images and load them into Flash Player.

A SWF file can access one type of external resource only, either local or over a network; it cannot access both types. You determine the type of access allowed by the SWF file using the use-network flag when you compile your application. When the use-network flag is set to false, you can access resources in the local file system, but not over the network. The default value is true, which allows you to access resources over the network, but not in the local file system.

When you load images at runtime, you should be aware of the security restrictions of Flash Player. For example, you can load an image from any domain by using a URL, but the default security settings won't allow your code to access the bitmap data of the image unless it came from the same domain as the application. To access bitmap data from images on other servers, you must use a crossdomain.xml file.

The PNG and GIF formats also support the use of an alpha channel for creating transparent images.

When you use the Image control as a drop-in item renderer in a List control, either set an explicit row height of the List control, by using the rowHeight property, or set the variableRowHeight property of the List control to true to size the row correctly.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Image> tag inherits the tag attributes of its superclass, and adds the following tag attribute:

  <mx:Image
    Events
    dataChange="No default"
  />

View the examples.

See also

mx.controls.SWFLoader
Image control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLoad : Boolean If true, the content loads automatically. | SWFLoader
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | bytesLoaded : Number Number of bytes of the SWF or image file already loaded. | SWFLoader
Inherited | bytesTotal : Number Total size of the SWF or image file. | SWFLoader
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | content : DisplayObject This property contains the object that represents the content that was loaded in the SWFLoader control. | SWFLoader
Inherited | contentHeight : Number Height of the scaled content loaded by the control, in pixels. | SWFLoader
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentWidth : Number Width of the scaled content loaded by the control, in pixels. | SWFLoader
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Image
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | Image
Inherited | loaderContext : LoaderContext A LoaderContext object to use to load the content. | SWFLoader
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | maintainAspectRatio : Boolean If true, specifies to display the image with the same ratio of height to width as the original image. | SWFLoader
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentLoaded : Number Percentage of the image or SWF file already loaded. | SWFLoader
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleContent : Boolean If true, the content scales to fit the SWFLoader control. | SWFLoader
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | showBusyCursor : Boolean If true, shows a busy cursor while the content loads. | SWFLoader
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | source : Object Specifies the content to load. | SWFLoader
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | trustContent : Boolean If true, the content is loaded into your security domain. | SWFLoader
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Image()
Constructor.
Image
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
load(url:Object = null):void
Loads an image or SWF file.
SWFLoader
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | complete | Dispatched when content loading is complete. | SWFLoader
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | Image
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | httpStatus | Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code. | SWFLoader
Inherited | init | Dispatched when the properties and methods of a loaded SWF file are accessible. | SWFLoader
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | ioError | Dispatched when an input/output error occurs. | SWFLoader
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | open | Dispatched when a network operation starts. | SWFLoader
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | progress | Dispatched when content is loading. | SWFLoader
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | securityError | Dispatched when a security error occurs while content is loading. | SWFLoader
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | unload | Dispatched when a loaded object is removed, or when a second load is performed by the same SWFLoader control and the original content is removed prior to the new load beginning. | SWFLoader
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | brokenImageBorderSkin | Type: Class CSS Inheritance: no Name of class to use as the SWFLoader border skin if the control cannot load the content. | SWFLoader
Inherited | brokenImageSkin | Type: Class CSS Inheritance: no Name of the class to use as the SWFLoader skin if the control cannot load the content. | SWFLoader
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of the content when it does not have a one-to-one aspect ratio. | SWFLoader
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of the content when it does not have a one-to-one aspect ratio. | SWFLoader
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | completeEffect | Triggering event: complete Effect called when the complete event is dispatched. | SWFLoader
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The data property lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

When you use the control as a drop-in item renderer, Flex will use the listData.label property, if it exists, as the value of the source property of this control, or use the data property as the source property.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. The component can then use the listData property to initialize the other properties of the drop-in item renderer

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
Constructor detail
Image () constructor
public function Image()

Constructor.

Event detail
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
SimpleImage
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Image control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel id="myPanel" title="Image Control Example"
        height="75%" width="75%" horizontalAlign="center"
        paddingTop="10" paddingLeft="10">

        <mx:Label color="blue" text="Image embedded in the application."/>
        <mx:Image source="@Embed('assets/Nokia_6630.png')"/>

    </mx:Panel>
</mx:Application>


mx.controls.Label (Flex™ 2 Language Reference)

Class Label | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Label
Inheritance | Label Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IListItemRenderer
Subclasses | FormItemLabel, SliderLabel, Text

The Label control displays a single line of noneditable text. Use the Text control to create blocks of multiline noneditable text.

You can format Label text by using HTML tags, which are applied after the Label control's CSS styles are applied. You can also put padding around the four sides of the text. The text of a Label is nonselectable by default, but you can make it selectable.

If a Label is sized to be smaller than its text, you can control whether the text is simply clipped or whether it is truncated with a localizable string such as "...". (Note: Plain text can be truncated, but HTML text cannot.) If the entire text of the Label — either plain or HTML — is not completely visible, and you haven't assigned a tooltip to the Label, an automatic "truncation tip" displays the complete plain text when a user holds the mouse over the Label control.

Label controls do not have backgrounds or borders and cannot take focus.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Label> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Label
    Properties
    condenseWhite="true|false"
    data="null"
    htmlText=""
    listData="null"
    selectable="true|false"
    text=""
    truncateToFit="true|false"

    Styles
    color="0x0B333C"
    disabledColor="0xAAB3B3"
    fontAntiAliasType="advanced|normal"
    fontFamily="Verdana"
    fontGridFitType="pixel|none|subpixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    paddingLeft="0"
    paddingRight="0"
    textAlign="left|right|center"
    textDecoration="none|underline"
    textIndent="0"

    Events
    dataChange="No default"
  />

View the examples.

See also

mx.controls.Text
mx.controls.TextInput
mx.controls.TextArea
mx.controls.RichTextEditor
Using Text Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | condenseWhite : Boolean Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a Label control with HTML text. | Label
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object Lets you pass a value to the component when you use it in an item renderer or item editor. | Label
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | htmlText : String Specifies the text displayed by the Label control, including HTML markup that expresses the styles of that text. | Label
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | Label
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectable : Boolean Specifies whether the text can be selected. | Label
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String Specifies the plain text displayed by this control. | Label
 | textHeight : Number [read-only] The height of the text. | Label
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | textWidth : Number [read-only] The width of the text. | Label
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
 | truncateToFit : Boolean = true If this propery is true, and the Label control size is smaller than its text, the text of the Label control is truncated using a localizable string, such as "...". | Label
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | textField : UITextField The internal UITextField that renders the text of this Label. | Label
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Label()
Constructor.
Label
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
getLineMetrics(lineIndex:int):TextLineMetrics
Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
Label
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | Label
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		Label
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		Label
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		Label
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		Label
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		Label
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		Label
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		Label
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		Label
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		Label
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		Label
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

Label
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

Label
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

Label
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		Label
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		Label
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
condenseWhite property
condenseWhite:Boolean [read-write]

Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a Label control with HTML text.

The condenseWhite property affects only text set with the htmlText property, not the text property. If you set text with the text property, condenseWhite is ignored.

If you set the condenseWhite property to true, you must use standard HTML commands, such as <br> and <p>, to place line breaks in the text field.

The default value is false;.

This property can be used as the source for data binding.

Implementation
    public function get condenseWhite():Boolean
    public function set condenseWhite(value:Boolean):void
data property
data:Object [read-write]

Lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

When you use the control as a drop-in item renderer or drop-in item editor, Flex automatically writes the current value of the item to the text property of this control.

You do not set this property in MXML.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
htmlText property
htmlText:String [read-write]

Specifies the text displayed by the Label control, including HTML markup that expresses the styles of that text. When you specify HTML text in this property, you can use the subset of HTML tags that is supported by the Flash TextField control.

When you set this property, the HTML markup is applied after the CSS styles for the Label instance are applied. When you get this property, the HTML markup includes the CSS styles.

For example, if you set this to be a string such as, "This is an example of <b>bold</b> markup", the text "This is an example of bold markup" appears in the Label with whatever CSS styles normally apply. Also, the word "bold" appears in boldface font because of the <b> markup.

HTML markup uses characters such as < and >, which have special meaning in XML (and therefore in MXML). So, code such as the following does not compile:

   <mx:Label htmlText="This is an example of <b>bold</b> markup"/>

There are three ways around this problem.

  • Set the htmlText property in an ActionScript method called as an initialize handler:

       <mx:Label id="myLabel" initialize="myLabel_initialize()"/>

    where the myLabel_initialize method is in a script CDATA section:

       <mx:Script>
   <![CDATA[
   private function myLabel_initialize():void {
       myLabel.htmlText = "This is an example of <b>bold</b> markup";
   }
   ]]>
   </mx:Script>

    This is the simplest approach because the HTML markup remains easily readable. Notice that you must assign an id to the label so you can refer to it in the initialize handler.

  • Specify the htmlText property by using a child tag with a CDATA section. A CDATA section in XML contains character data where characters like < and > aren't given a special meaning.

       <mx:Label>
       <mx:htmlText><![CDATA[This is an example of <b>bold</b> markup]]></mx:htmlText>
   <mx:Label/>

    You must write the htmlText property as a child tag rather than as an attribute on the <mx:Label> tag because XML doesn't allow CDATA for the value of an attribute. Notice that the markup is readable, but the CDATA section makes this approach more complicated.

  • Use an hmtlText attribute where any occurences of the HTML markup characters < and > in the attribute value are written instead as the XML "entities" &lt; and &gt;:

       <mx:Label htmlText="This is an example of &lt;b&gt;bold&lt;/b&gt; markup"/&gt;
    Adobe does not recommend this approach because the HTML markup becomes nearly impossible to read.

If the condenseWhite property is true when you set the htmlText property, multiple white-space characters are condensed, as in HTML-based browsers; for example, three consecutive spaces are displayed as a single space. The default value for condenseWhite is false, so you must set condenseWhite to true to collapse the white space.

If you read back the htmlText property quickly after setting it, you get the same string that you set. However, after the LayoutManager runs, the value changes to include additional markup that includes the CSS styles.

Setting the htmlText property affects the text property in several ways. If you read the text property quickly after setting the htmlText property, you get null, which indicates that the text corresponding to the new htmlText has not yet been determined. However, after the LayoutManager runs, the text property value changes to the htmlText string with all the HTML markup removed; that is, the value is the characters that the Label actually displays.

Conversely, if you set the text property, any previously set htmlText is irrelevant. If you read the htmlText property quickly after setting the text property, you get null, which indicates that the htmlText that corresponds to the new text has not yet been determined. However, after the LayoutManager runs, the htmlText property value changes to the new text plus the HTML markup for the CSS styles.

To make the LayoutManager run immediately, you can call the validateNow() method on the Label. For example, you could set some htmlText, call the validateNow() method, and immediately obtain the corresponding text that doesn't have the HTML markup.

If you set both text and htmlText properties in ActionScript, whichever is set last takes effect. Do not set both in MXML, because MXML does not guarantee that the properties of an instance get set in any particular order.

Setting either text or htmlText property inside a loop is a fast operation, because the underlying TextField that actually renders the text is not updated until the LayoutManager runs.

If you try to set this property to null, it is set, instead, to the empty string. If the property temporarily has the value null, it indicates that the text has been recently set and the corresponding htmlText has not yet been determined.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get htmlText():String
    public function set htmlText(value:String):void

See also

flash.text.TextField.htmlText
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. The component can then use the listData property to initialize the data property of the drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
selectable property
selectable:Boolean [read-write]

Specifies whether the text can be selected. Making the text selectable lets you copy text from the control.

The default value is false;.

Implementation
    public function get selectable():Boolean
    public function set selectable(value:Boolean):void
text property
text:String [read-write]

Specifies the plain text displayed by this control. Its appearance is determined by the CSS styles of this Label control.

When you set this property, any characters that might look like HTML markup in the string have no special meaning and appear as entered.

To display text formatted by using HTML tags, use the htmlText property instead. If you set the htmlText property, the HTML replaces any text that you set using this property, and the text property returns a plain-text version of the HTML text, with all HTML tags stripped out.

To include the special characters left angle bracket (<), right angle bracket (>), or ampersand (&) in the text, wrap the text string in the CDATA tag. Alternatively, you can use HTML character entities for the special characters, for example, &lt;.

If the text is wider than the Label control, the text is truncated and terminated by an ellipsis (...). The full text displays as a tooltip when you move the mouse over the Label control. If you also set a tooltip by using the tooltip property, the tooltip is displayed rather than the text.

If you try to set this property to null, it is set, instead, to the empty string. The text property can temporarily have the value null, which indicates that the htmlText has been recently set and the corresponding text value has not yet been determined.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get text():String
    public function set text(value:String):void
textField property
protected var textField:UITextField

The internal UITextField that renders the text of this Label.

textHeight property
textHeight:Number [read-only]

The height of the text.

The value of the textHeight property is correct only after the component has been validated. If you set text and then immediately ask for the textHeight, you might receive an incorrect value. You should wait for the component to validate or call the validateNow() method before you get the value. This behavior differs from that of the flash.text.TextField control, which updates the value immediately.

Implementation
    public function get textHeight():Number

See also

flash.text.TextField
textWidth property
textWidth:Number [read-only]

The width of the text.

The value of the textWidth property is correct only after the component has been validated. If you set text and then immediately ask for the textWidth, you might receive an incorrect value. You should wait for the component to validate or call the validateNow() method before you get the value. This behavior differs from that of the flash.text.TextField control, which updates the value immediately.

Implementation
    public function get textWidth():Number

See also

flash.text.TextField
truncateToFit property
public var truncateToFit:Boolean = true

If this propery is true, and the Label control size is smaller than its text, the text of the Label control is truncated using a localizable string, such as "...". If this property is false, text that does not fit is clipped.

The default value is true.

Constructor detail
Label () constructor
public function Label()

Constructor.

Method detail
getLineMetrics () method
public function getLineMetrics(lineIndex:int):TextLineMetrics

Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control. The component must be validated to get a correct number. If you set text and then immediately call getLineMetrics() you may receive an incorrect value. You should either wait for the component to validate or call validateNow(). This is behavior differs from that of the flash.text.TextField class, which updates the value immediately.

Parameters
lineIndex:int — The zero-based index of the line for which to get the metrics. For the Label control, which has only a single line, must be 0.

Returns
TextLineMetrics

See also

flash.text.TextField
flash.text.TextLineMetrics
Event detail
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
LabelExample
<?xml version="1.0" encoding="utf-8"?>
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">
<!-- Simple example to demonstrate the Label control -->

    <mx:Script>
        <![CDATA[

            private var htmlData:String="<br>This label displays <b>bold</b> and <i>italic</i> HTML-formatted text.";

            // Event handler function to change the image size.
            private function displayHTML():void {
                simpleLabel.htmlText= htmlData;
            }

            // Event handler function to change the image size.
            private function displayText():void {
                simpleLabel.text="This Label displays plain text.";
            }
        ]]>
    </mx:Script>

  <mx:Panel title="Label Control Example" height="75%" width="75%"
      paddingTop="10" paddingLeft="10">

      <mx:Label id="simpleLabel" text="This Label displays plain text."/>
      <mx:Button id="Display" label="Click to diplay HTML Text" click="displayHTML();"/>
      <mx:Button id="Clear" label="Click to display plain text" click="displayText();"/>

  </mx:Panel>
</mx:Application>


mx.controls.LinkBar (Flex™ 2 Language Reference)

Class LinkBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class LinkBar
Inheritance | LinkBar Inheritance NavBar Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

A LinkBar control defines a horizontal or vertical row of LinkButton controls that designate a series of link destinations. You typically use a LinkBar control to control the active child container of a ViewStack container, or to create a stand-alone set of links.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:LinkBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:LinkBar
    Properties
    selectedIndex="-1"

    Styles
    horizontalGap="8"
    paddingBottom="2"
    paddingTop="2"
    rollOverColor="0xEEFEE6"
    selectionColor="0xCDFFC1"
    separatorColor="No default"
    separatorSkin="0x000000"
    separatorWidth="1"
    textRollOverColor="0x2B333C"
    textSelectedColor="0x000000"
    verticalGap="8"
    >
    ...
      child tags
    ...
  </mx:LinkBar>

Default MXML Property dataProvider

View the examples.

See also

mx.controls.NavBar
mx.containers.ViewStack
mx.controls.LinkButton
LinkBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | dataProvider : Object Data used to populate the navigator control. | NavBar
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String The direction in which this Box container lays out its children. | Box
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | iconField : String Name of the field in the dataProvider object to display as the icon for each navigation item. | NavBar
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelField : String Name of the field in the dataProvider object to display as the label for each navigation item. | NavBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedIndex : int The index of the last selected LinkButton control if the LinkBar control uses a ViewStack container as its data provider. | LinkBar
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | toolTipField : String Name of the the field in the dataProvider object to display as the tooltip label. | NavBar
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LinkBar()
Constructor
LinkBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void Handles the MouseEvent.CLICK event for the items in the NavBar control. | NavBar
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | createNavItem(label:String, icon:Class = null):IFlexDisplayObject Creates the individual navigator items. | NavBar
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | hiliteSelectedNavItem(index:int):void Highlights the selected navigator item. | NavBar
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | resetNavItems():void Resets the navigator bar to its default state. | NavBar
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this LinkBar control's children. | LinkBar
Inherited | updateNavItemIcon(index:int, icon:Class):void Resets the icon of a navigator item in the NavBar control. | NavBar
Inherited | updateNavItemLabel(index:int, label:String):void Sets the label property of a navigator item in the NavBar control. | NavBar
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a navigation item is selected. | NavBar
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between the LinkButton controls in the horizontal direction. The default value is 8. | LinkBar
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the bottom border and the LinkButton controls. The default value is 2. | LinkBar
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the top border and the LinkButton controls. The default value is 2. | LinkBar
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | rollOverColor | Type: uint Format: Color CSS Inheritance: yes Color of links as you roll the mouse pointer over them. The default value is based on the current themeColor. The default value is 0xEEFEE6 (light green). | LinkBar
 | selectionColor | Type: uint Format: Color CSS Inheritance: yes Background color of the LinkButton control as you press it. The default value is 0xCDFFC1. | LinkBar
 | separatorColor | Type: uint Format: Color CSS Inheritance: yes Separator color used by the default separator skin. The default value is 0xC4CCCC. | LinkBar
 | separatorSkin | Type: Class CSS Inheritance: no Seperator symbol between LinkButton controls in the LinkBar. The default value is mx.skins.halo.LinkSeparator. | LinkBar
 | separatorWidth | Type: Number Format: Length CSS Inheritance: yes Separator pixel width, in pixels. The default value is 1. | LinkBar
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
 | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the link as you move the mouse pointer over it. The default value is 0x2B333C. | LinkBar
 | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the link as you press it. The default value is 0x000000. | LinkBar
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value is 8. | LinkBar
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
selectedIndex property
selectedIndex:int [read-write]

The index of the last selected LinkButton control if the LinkBar control uses a ViewStack container as its data provider.

The default value is -1.

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
Constructor detail
LinkBar () constructor
public function LinkBar()

Constructor

Method detail
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Responds to size changes by setting the positions and sizes of this LinkBar control's children. For more information about the updateDisplayList() method, see the UIComponent.updateDisplayList() method.

The LinkBar.updateDisplayList() method first calls the Box.updateDisplayList() method to position the LinkButton controls. For more details, see the Box.updateDisplayList() method. After laying out the LinkButton controls, the separators are positioned between them.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, of the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

mx.core.UIComponent
mx.containers.Box
Examples
LinkBarExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the LinkBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="LinkBar Control Example"
        height="75%" width="75%" horizontalAlign="center"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Text width="100%"
            text="Select a link in the LinkBar control to set the active child of the ViewStack container."/>

        <mx:LinkBar color="#0000FF" fontWeight="bold" dataProvider="{myViewStack}"/>

        <!-- Define the ViewStack and the three child containers. -->
        <mx:ViewStack id="myViewStack" borderStyle="solid" width="100%" height="80%">

            <mx:Canvas id="search" backgroundColor="#FFFFCC" label="Search" width="100%" height="100%">
                <mx:Label text="Search Screen" color="#000000"/>
            </mx:Canvas>

            <mx:Canvas id="custInfo" backgroundColor="#CCFFFF" label="Customer Info" width="100%" height="100%">
                <mx:Label text="Customer Info" color="#000000"/>
            </mx:Canvas>

            <mx:Canvas id="accountInfo" backgroundColor="#FFCCFF" label="Account Info" width="100%" height="100%">
                <mx:Label text="Account Info" color="#000000"/>
            </mx:Canvas>
        </mx:ViewStack>

    </mx:Panel>
</mx:Application>


mx.controls.LinkButton (Flex™ 2 Language Reference)

Class LinkButton | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class LinkButton
Inheritance | LinkButton Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The LinkButton control is a borderless Button control whose contents are highlighted when a user moves the mouse over it. These traits are often exhibited by HTML links contained within a browser page. In order for the LinkButton control to perform some action, you must specify a click event handler, as you do with a Button control.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:LinkButton> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:LinkButton
    Styles
    cornerRadius="4""
    rollOverColor="0xEEFEE6"
    selectionColor="0xB7F39B"
    textRollOverColor="0x2B333C"
    textSelectedColor="0x2B333C"
  />

View the examples.

See also

mx.controls.LinkBar
LinkButton control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
Inherited | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toggle : Boolean Controls whether a Button is in a toggle state or not. | Button
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LinkButton()
Constructor.
LinkButton
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
 | cornerRadius | Type: Number Format: Length CSS Inheritance: no Corner radius of the highlighted rectangle around a LinkButton. The default value is 4. | LinkButton
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | rollOverColor | Type: uint Format: Color CSS Inheritance: yes Color of a LinkButton as a user moves the mouse pointer over it. The default value is 0xEEFEE6. | LinkButton
Inherited | selectedDisabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and disabled. | Button
Inherited | selectedDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and disabled. | Button
Inherited | selectedDownIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is down. | Button
Inherited | selectedDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down. | Button
Inherited | selectedOverIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse is over the control. | Button
Inherited | selectedOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control. | Button
Inherited | selectedUpIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is up. | Button
Inherited | selectedUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control. | Button
 | selectionColor | Type: uint Format: Color CSS Inheritance: yes Background color of a LinkButton as a user presses it. The default value is 0xB7F39B. | LinkButton
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
 | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of a LinkButton as a user moves the mouse pointer over it. The default value is 0x2B333C. | LinkButton
 | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of a LinkButton as a user presses it. The default value is 0x2B333C. | LinkButton
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
LinkButton () constructor
public function LinkButton()

Constructor.

Examples
LinkButtonExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the LinkButton control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:Panel title="LinkButton Control Example"
        height="75%" width="75%" horizontalAlign="center"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%"
            text="Select the LinkButton control to open the Alert control."/>

        <mx:LinkButton label="LinkButton control" color="#0000FF" fontWeight="bold"
            click="Alert.show('LinkButton selected!');"/>

    </mx:Panel>
</mx:Application>


mx.controls.List (Flex™ 2 Language Reference)

Class List | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class List
Inheritance | List Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IIMESupport
Subclasses | Menu, Tree

The List control displays a vertical list of items. Its functionality is very similar to that of the SELECT form element in HTML. If there are more items than can be displayed at once, it can display a vertical scroll bar so the user can access all items in the list. An optional horizontal scroll bar lets the user view items when the full width of the list items is unlikely to fit. The user can select one or more items from the list, depending on the value of the allowMultipleSelection property.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:List> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:List
    Properties
    editable="false|true"
    editedItemPosition="No default"
    editorDataField="text"
    editorHeightOffset="0"
    editorUsesEnterKey="false|true"
    editorWidthOffset="0"
    editorXOffset="0"
    editorYOffset="0"
    imeMode="null"
    itemEditor="TextInput"
    itemEditorInstance="Current item editor"
    rendererIsEditor="false|true"

    Styles
    backgroundDisabledColor="0xDDDDDD"

    Events
    itemEditBegin="No default"
    itemEditEnd="No default"
    itemEditBeginning="No default"
    itemFocusIn="No default"
    itemFocusOut="No default"
  />

Default MXML Property dataProvider

View the examples.

See also

mx.events.ListEvent
Using Data-Driven Controls
Example: Using an item renderer with a List control
Example: Using a custom item editor with a List control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | baselinePosition : Number [read-only] The baseline position for the control. | List
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
Inherited | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | editable : Boolean = false A flag that indicates whether or not the user can edit items in the data provider. | List
 | editedItemPosition : Object The column and row index of the item renderer for the data provider item being edited, if any. | List
 | editedItemRenderer : IListItemRenderer [read-only] A reference to the item renderer in the DataGrid control whose item is currently being edited. | List
 | editorDataField : String = "text" The name of the property of the item editor that contains the new data for the list item. | List
 | editorHeightOffset : Number = 0 The height of the item editor, in pixels, relative to the size of the item renderer. | List
 | editorUsesEnterKey : Boolean = false A flag that indicates whether the item editor uses Enter key. | List
 | editorWidthOffset : Number = 0 The width of the item editor, in pixels, relative to the size of the item renderer. | List
 | editorXOffset : Number = 0 The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | List
 | editorYOffset : Number = 0 The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | List
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
Inherited | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
Inherited | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
 | imeMode : String Specifies the IME (input method editor) mode. | List
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | itemEditor : IFactory The class factory for the item editor to use for the control, if the editable property is set to true. | List
 | itemEditorInstance : IListItemRenderer A reference to the currently active instance of the item editor, if it exists. | List
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelField : String The name of the field in the data provider items to display as the label. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The maximum value for the horizontalScrollPosition property. | ScrollControlBase
Inherited | maxVerticalScrollPosition : Number The maximum value for the verticalScrollPosition property. | ScrollControlBase
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rendererIsEditor : Boolean = false Specifies whether the item renderer is also an item editor. | List
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
List()
Constructor.
List
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
createItemEditor(colIndex:int, rowIndex:int):void
Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.
List
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
destroyItemEditor():void
Closes an item editor that is currently open on an item.
List
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
drawRowBackground(s:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int):void
Draws a row background at the position and height specified.
List
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
endEdit(reason:String):Boolean
Stops the editing of an item in the data provider.
List
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
layoutEditor(x:int, y:int, w:int, h:int):void
Positions the item editor instance at the suggested position with the suggested dimensions.
List
makeListData(data:Object, uid:String, rowNum:int):BaseListData
Creates a new ListData instance and populates the fields based on the input data provider item.
List
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
Inherited
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
 | itemEditBegin | Dispatched when the editedItemPosition property is set and the item can be edited. | List
 | itemEditBeginning | Dispatched when the user releases the mouse button while over an item, tabs to the List or within the List, or in any other way attempts to edit an item. | List
 | itemEditEnd | Dispatched when an item editing session is ending for any reason. | List
 | itemFocusIn | Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the List control or navigates to the item using a keyboard. | List
 | itemFocusOut | Dispatched when an item renderer loses the focus, which can occur if the user clicks another item in the List control or outside the list, or uses the keyboard to navigate to another item in the List control or outside the List control. | List
Inherited | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
Inherited | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors to use for the backgrounds of the items in the list. | ListBase
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
 | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. The global default value is undefined. The default value for List controls is 0xDDDDDD (light gray). If a Container is disabled, the background is dimmed, and the degree of dimming is controlled by the disabledOverlayAlpha style. | List
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | rollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user rolls over it. | ListBase
Inherited | selectionColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user selects it. | ListBase
Inherited | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the component is disabled. | ListBase
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
Inherited | selectionEasingFunction | Type: Function CSS Inheritance: no The easingFunction for the selection effect. | ListBase
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user rolls over a it. | ListBase
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user selects it. | ListBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
baselinePosition property
baselinePosition:Number [read-only]

The baseline position for the control. If there are any items in the list, the baseline position is computed based on the baseline position of item renderer. The baseline position is the y-coordinate of the first line of text of the component.

Implementation
    public function get baselinePosition():Number
editable property
public var editable:Boolean = false

A flag that indicates whether or not the user can edit items in the data provider. If true, the item renderers in the control are editable. The user can click on an item renderer to open an editor.

The default value is false.

editedItemPosition property
editedItemPosition:Object [read-write]

The column and row index of the item renderer for the data provider item being edited, if any.

This Object has two fields, columnIndex and rowIndex, the zero-based column and item indexes of the item. For a List control, the columnIndex property is always 0; for example: {columnIndex:0, rowIndex:3}.

Setting this property scrolls the item into view and dispatches the itemEditBegin event to open an item editor on the specified item,

This property can be used as the source for data binding.

Implementation
    public function get editedItemPosition():Object
    public function set editedItemPosition(value:Object):void
editedItemRenderer property
editedItemRenderer:IListItemRenderer [read-only]

A reference to the item renderer in the DataGrid control whose item is currently being edited.

From within an event listener for the itemEditBegin and itemEditEnd events, you can access the current value of the item being edited using the editedItemRenderer.data property.

Implementation
    public function get editedItemRenderer():IListItemRenderer
editorDataField property
public var editorDataField:String = "text"

The name of the property of the item editor that contains the new data for the list item. For example, the default itemEditor is TextInput, so the default value of the editorDataField property is "text", which specifies the text property of the the TextInput control.

editorHeightOffset property
public var editorHeightOffset:Number = 0

The height of the item editor, in pixels, relative to the size of the item renderer. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor.

Changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

editorUsesEnterKey property
public var editorUsesEnterKey:Boolean = false

A flag that indicates whether the item editor uses Enter key. If this property is set to true, the item editor uses the Enter key and the List will not look for the Enter key and move the editor in response.

Changing this value while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is false.

editorWidthOffset property
public var editorWidthOffset:Number = 0

The width of the item editor, in pixels, relative to the size of the item renderer. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor.

Changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

editorXOffset property
public var editorXOffset:Number = 0

The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor.

Changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

editorYOffset property
public var editorYOffset:Number = 0

The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor.

Changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

imeMode property
imeMode:String [read-write]

Specifies the IME (input method editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the specified IME mode when the control gets focus, and sets it back to the previous value when the control loses focus.

The flash.system.IMEConversionMode class defines constants for the valid values for this property. You can also specify null to specify no IME.

The default value is null.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void

See also

flash.system.IME
flash.system.IMEConversionMode
itemEditor property
public var itemEditor:IFactory

The class factory for the item editor to use for the control, if the editable property is set to true.

The default value is new ClassFactory(mx.controls.TextInput).

itemEditorInstance property
public var itemEditorInstance:IListItemRenderer

A reference to the currently active instance of the item editor, if it exists.

To access the item editor instance and the new item value when an item is being edited, you use the itemEditorInstance property. The itemEditorInstance property is not valid until after the event listener for the itemEditBegin event executes. Therefore, you typically only access the itemEditorInstance property from within the event listener for the itemEditEnd event.

The itemEditor property defines the class of the item editor and, therefore, the data type of the item editor instance.

You do not set this property in MXML.

rendererIsEditor property
public var rendererIsEditor:Boolean = false

Specifies whether the item renderer is also an item editor. If this property is true, Flex ignores the itemEditor property.

The default value is false.

Constructor detail
List () constructor
public function List()

Constructor.

Method detail
createItemEditor () method
public function createItemEditor(colIndex:int, rowIndex:int):void

Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.

This method sets the editor instance as the itemEditorInstance property.

You can call this method only from within the event listener for the itemEditBegin event. To create an editor at other times, set the editedItemPosition property to generate the itemEditBegin event.

Parameters
colIndex:int — The column index. Flex sets the value of this property to 0 for a List control.
rowIndex:int — The index in the data provider of the item to be edited.
destroyItemEditor () method
public function destroyItemEditor():void

Closes an item editor that is currently open on an item. You typically call this method only from within the event listener for the itemEditEnd event, after you call the preventDefault() method to prevent the default event listener from executing.

drawRowBackground () method
protected function drawRowBackground(s:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int):void

Draws a row background at the position and height specified. This creates a Shape as a child of the input Sprite and fills it with the appropriate color. This method also uses the backgroundAlpha style property setting to determine the transparency of the background color.

Parameters
s:Sprite — A Sprite that will contain a display object that contains the graphics for that row.
rowIndex:int — The row's index in the set of displayed rows. The header does not count; the top most visible row has a row index of 0. This is used to keep track of the objects used for drawing backgrounds so that a particular row can reuse the same display object even though the index of the item that the row is rendering has changed.
y:Number — The suggested y position for the background.
height:Number — The suggested height for the indicator.
color:uint — The suggested color for the indicator.
dataIndex:int — The index of the item for that row in the data provider. For example, this can be used to color the 10th item differently.
endEdit () method
protected function endEdit(reason:String):Boolean

Stops the editing of an item in the data provider. When the user finished editing an item, the control calls this method. It dispatches the itemEditEnd event to start the process of copying the edited data from the itemEditorInstance to the data provider and hiding the itemEditorInstance.

Parameters
reason:String — A constant defining the reason for the event (such as "CANCELLED", "NEW_ROW", or "OTHER"). The value must be a member of the ListEventReason class.

Returns
Boolean — Returns true if preventDefault() is not called. Otherwise, false.

See also

mx.events.ListEventReason
layoutEditor () method
protected function layoutEditor(x:int, y:int, w:int, h:int):void

Positions the item editor instance at the suggested position with the suggested dimensions. The Tree control overrides this method and adjusts the position to compensate for indentation of the renderer.

Parameters
x:int — The suggested x position for the indicator.
y:int — The suggested y position for the indicator.
w:int — The suggested width for the indicator.
h:int — The suggested height for the indicator.
makeListData () method
protected function makeListData(data:Object, uid:String, rowNum:int):BaseListData

Creates a new ListData instance and populates the fields based on the input data provider item. The Tree control overrides this method to add additional Tree-related fields.

Parameters
data:Object — The data provider item used to populate the ListData.
uid:String — The UID for the item.
rowNum:int — The index of the item in the data provider.

Returns
BaseListData — A newly constructed ListData object.
Event detail
itemEditBegin event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_EDIT_BEGIN

Dispatched when the editedItemPosition property is set and the item can be edited.

The ListEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited.

The default listener for this event performs the following actions:

  • Creates an item editor object via a call to the createItemEditor() method.
  • Copies the data property from the item to the editor. By default, the item editor object is an instance of the TextInput control. You use the itemEditor property of the list control to specify a custom item editor class.
  • Set the itemEditorInstance property of the list control to reference the item editor instance.

You can write an event listener for this event to modify the data passed to the item editor. For example, you might modify the data, its format, or other information used by the item editor.

You can also create an event listener to specify the item editor used to edit the item. For example, you might have two different item editors. Within the event listener you can examine the data to be edited or other information, and open the appropriate item editor by doing the following:

  1. Call preventDefault() to stop Flex from calling the createItemEditor() method as part of the default event listener.
  2. Set the itemEditor property to the appropriate editor.
  3. Call the createItemEditor() method.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer for the item that is being edited.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_EDIT_BEGIN
itemEditBeginning event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_EDIT_BEGINNING

Dispatched when the user releases the mouse button while over an item, tabs to the List or within the List, or in any other way attempts to edit an item.

The ListEvent.ITEM_EDIT_BEGINNING constant defines the value of the type property of the ListEvent object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item.

The default listener for this event sets the List.editedItemPosition property to the item that has focus, which starts the item editing session.

You typically write your own event listener for this event to disallow editing of a specific item or items. Calling the preventDefault() method from within your own event listener for this event prevents the default listener from executing.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer for the item that will be edited. This property is null if this event is generated by keyboard, as the item to be edited may be off-screen.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_EDIT_BEGIN
itemEditEnd event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_EDIT_END

Dispatched when an item editing session is ending for any reason.

The ListEvent.ITEM_EDIT_END constant defines the value of the type property of the ListEvent object for a itemEditEnd event, which indicates that an edit session is ending.

The list components have a default handler for this event that copies the data from the item editor to the data provider of the list control. The default event listener performs the following actions:

  • Uses the editorDataField property of the list control to determine the property of the item editor containing the new data and updates the data provider item with that new data. Since the default item editor is the TextInput control, the default value of the editorDataField property is "text", to specify that the text property of the TextInput contains the new item data.
  • Calls the destroyItemEditor() method to close the item editor.

You typically write an event listener for this event to perform the following actions:

  • In your event listener, you can modify the data returned by the editor to the list component. For example, you can reformat the data before returning it to the list control. By default, an item editor can only return a single value. You must write an event listener for the itemEditEnd event if you want to return multiple values.
  • In your event listener, you can examine the data entered into the item editor. If the data is incorrect, you can call the preventDefault() method to stop Flex from passing the new data back to the list control and from closing the editor.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer for the item that was edited.
reason | A constant defining the reason for the event. The value must be a member of the ListEventReson class.
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_EDIT_BEGIN
itemFocusIn event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_FOCUS_IN

Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the List control or navigates to the item using a keyboard. Only dispatched if the list item is editable.

The ListEvent.ITEM_FOCUS_IN constant defines the value of the type property of the ListEvent object for an itemFocusIn event, which indicates that an item has received the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item editor instance for the item that is being edited.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_FOCUS_IN
itemFocusOut event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_FOCUS_OUT

Dispatched when an item renderer loses the focus, which can occur if the user clicks another item in the List control or outside the list, or uses the keyboard to navigate to another item in the List control or outside the List control. Only dispatched if the list item is editable.

The ListEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the ListEvent object for an itemFocusOut event, which indicates that an item has lost the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item editor instance for the item that was being edited.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_FOCUS_OUT
Examples
SimpleList
<?xml version="1.0"?>
<!-- Simple example to demonstrate the List Control -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[
            [Bindable]
            public var selectedItem:Object;
       ]]>
    </mx:Script>

    <mx:Model id="mystates">
      <states>
        <state label="Alabama" data="AL"/>
        <state label="Alaska" data="AK"/>
        <state label="Arizona" data="AZ"/>
        <state label="Arkansas" data="AR"/>
        <state label="California" data="CA"/>
        <state label="Colorado" data="CO"/>
        <state label="Connecticut" data="CT"/>
      </states>
    </mx:Model>

    <mx:Panel title="List Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label text="Select a state to see its abbreviation."/>

        <mx:List id="source" width="100%" color="blue"
            dataProvider="{mystates.state}"
            change="this.selectedItem=List(event.target).selectedItem"/>

        <mx:VBox width="100%">
            <mx:Label text="Selected State: {selectedItem.label}"/>
            <mx:Label text="State abbreviation: {selectedItem.data}"/>
        </mx:VBox>

    </mx:Panel>
</mx:Application>


mx.controls.Menu (Flex™ 2 Language Reference)

Class Menu | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Menu
Inheritance | Menu Inheritance List Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerContainer

The Menu control creates a pop-up menu of individually selectable choices, similar to the File or Edit menu found in most software applications. The popped up menu can have as many levels of submenus as needed. After a Menu control has opened, it remains visible until it is closed by any of the following actions:
  • A call to the Menu.hide() method.
  • When a user selects an enabled menu item.
  • When a user clicks outside of the Menu control.
  • When a user selects another component in the application.
The Menu class has no corresponding MXML tag. You must create it using ActionScript.

View the examples.

See also

mx.controls.MenuBar
mx.controls.PopUpMenuButton
mx.controls.menuClasses.MenuBarItem
mx.controls.menuClasses.IMenuDataDescriptor
mx.controls.treeClasses.DefaultDataDescriptor
mx.effects.Tween
mx.managers.PopUpManager
Using Menu-Based Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number The baseline position for the control. | List
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
 | dataDescriptor : IMenuDataDescriptor The object that accesses and manipulates data in the data provider. | Menu
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
Inherited | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | editable : Boolean = false A flag that indicates whether or not the user can edit items in the data provider. | List
Inherited | editedItemPosition : Object The column and row index of the item renderer for the data provider item being edited, if any. | List
Inherited | editedItemRenderer : IListItemRenderer A reference to the item renderer in the DataGrid control whose item is currently being edited. | List
Inherited | editorDataField : String = "text" The name of the property of the item editor that contains the new data for the list item. | List
Inherited | editorHeightOffset : Number = 0 The height of the item editor, in pixels, relative to the size of the item renderer. | List
Inherited | editorUsesEnterKey : Boolean = false A flag that indicates whether the item editor uses Enter key. | List
Inherited | editorWidthOffset : Number = 0 The width of the item editor, in pixels, relative to the size of the item renderer. | List
Inherited | editorXOffset : Number = 0 The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | List
Inherited | editorYOffset : Number = 0 The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | List
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | hasRoot : Boolean [read-only] A flag that indicates that the current data provider has a root node; for example, a single top node in a hierarchical structure. | Menu
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
Inherited | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
Inherited | imeMode : String Specifies the IME (input method editor) mode. | List
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | itemEditor : IFactory The class factory for the item editor to use for the control, if the editable property is set to true. | List
Inherited | itemEditorInstance : IListItemRenderer A reference to the currently active instance of the item editor, if it exists. | List
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelField : String The name of the field in the data provider items to display as the label. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
 | parentMenu : Menu The parent menu in a hierarchical chain of menus, where the current menu is a submenu of the parent. | Menu
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rendererIsEditor : Boolean = false Specifies whether the item renderer is also an item editor. | List
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
 | showRoot : Boolean / A Boolean flag that specifies whether to display the data provider's root node. | Menu
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Menu()
Constructor.
Menu
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createItemEditor(colIndex:int, rowIndex:int):void
Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.
List
createMenu(parent:DisplayObjectContainer, mdp:Object, showRoot:Boolean = true):Menu
[static] Creates and returns an instance of the Menu class.
Menu
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
destroyItemEditor():void
Closes an item editor that is currently open on an item.
List
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
hide():void
Hides the Menu control and any of its submenus if the Menu control is visible.
Menu
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
popUpMenu(menu:Menu, parent:DisplayObjectContainer, mdp:Object):void
[static] Sets the dataProvider of an existing Menu control and places the Menu control in the specified parent container.
Menu
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
show(xShow:Object = null, yShow:Object = null):void
Shows the Menu control.
Menu
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
Inherited
drawRowBackground(s:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int):void
Draws a row background at the position and height specified.
List
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
endEdit(reason:String):Boolean
Stops the editing of an item in the data provider.
List
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
Inherited
layoutEditor(x:int, y:int, w:int, h:int):void
Positions the item editor instance at the suggested position with the suggested dimensions.
List
Inherited
makeListData(data:Object, uid:String, rowNum:int):BaseListData
Creates a new ListData instance and populates the fields based on the input data provider item.
List
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
measure():void
Calculates the preferred width and height of the Menu based on the widths and heights of its menu items.
Menu
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
setMenuItemToggled(item:Object, toggle:Boolean):void
Toggles the menu item.
Menu
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when a menu item is selected. | Menu
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
Inherited | itemEditBegin | Dispatched when the editedItemPosition property is set and the item can be edited. | List
Inherited | itemEditBeginning | Dispatched when the user releases the mouse button while over an item, tabs to the List or within the List, or in any other way attempts to edit an item. | List
Inherited | itemEditEnd | Dispatched when an item editing session is ending for any reason. | List
Inherited | itemFocusIn | Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the List control or navigates to the item using a keyboard. | List
Inherited | itemFocusOut | Dispatched when an item renderer loses the focus, which can occur if the user clicks another item in the List control or outside the list, or uses the keyboard to navigate to another item in the List control or outside the List control. | List
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
 | menuHide | Dispatched when a menu or submenu is dismissed. | Menu
 | menuShow | Dispatched when a menu or submenu opens. | Menu
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
 | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors used for menu or submenu menu items in an alternating pattern. The value can be an Array of two or more colors. This style is only used if backgroundColor is not specified. The default value is "undefined". | Menu
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | List
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | branchDisabledIcon | Type: Class CSS Inheritance: no The icon for all disabled menu items that have submenus. The default value is "MenuBranchDisabled". | Menu
 | branchIcon | Type: Class CSS Inheritance: no The icon for all enabled menu items that have submenus. The default value is "MenuBranchIcon". | Menu
 | checkDisabledIcon | Type: Class CSS Inheritance: no The icon for all dsiabled menu items whose type identifier is a check box. The default value is "MenuCheckDisabled". | Menu
 | checkIcon | Type: Class CSS Inheritance: no The icon for all enabled menu items whose type identifier is a check box. The default value is "MenuCheckEnabled". | Menu
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | openDuration | Type: Number Format: Time CSS Inheritance: no The duration of the menu or submenu opening transition, in milliseconds. The value 0 specifies no transition. The default value is 250. | Menu
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
 | radioDisabledIcon | Type: Class CSS Inheritance: no The icon for all disabled menu items whose type identifier is a radio button. The default value is "MenuRadioDisabled". | Menu
 | radioIcon | Type: Class CSS Inheritance: no The icon for all enabled menu items whose type identifier is a radio button. The default value is "MenuRadioEnabled". | Menu
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | rollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the menu item background when a user rolls the mouse over it. The default value is 0xB2E1FF. | Menu
 | selectionColor | Type: uint Format: Color CSS Inheritance: yes The color of the menu item background when a menu item is selected. The default value is 0x7FCEFF. | Menu
Inherited | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the component is disabled. | ListBase
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
 | selectionEasingFunction | Type: Function CSS Inheritance: no The reference to an easingFunction equation which is used to control programmatic tweening. The default value is "undefined". | Menu
 | separatorSkin | Type: Class CSS Inheritance: no The skin for all menu items which are identified as separators. The default value is "MenuSeparator". | Menu
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
 | textIndent | Type: Number Format: Length CSS Inheritance: yes The offset of the first line of text from the left side of the menu or submenu menu item. The default value is 0. | Menu
 | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the menu item text when a user rolls the mouse over the menu item. The default value is 0x2B333C. | Menu
 | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes The color of the menu item text when the menu item is selected. The default value is 0x2B333C. | Menu
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dataDescriptor property
dataDescriptor:IMenuDataDescriptor [read-write]

The object that accesses and manipulates data in the data provider. The Menu control delegates to the data descriptor for information about its data. This data is then used to parse and move about the data source. The default value is an internal instance of the DefaultDataDescriptor class.

Implementation
    public function get dataDescriptor():IMenuDataDescriptor
    public function set dataDescriptor(value:IMenuDataDescriptor):void
hasRoot property
hasRoot:Boolean [read-only]

A flag that indicates that the current data provider has a root node; for example, a single top node in a hierarchical structure. XML and Object are examples of types that have a root node, while Lists and Arrays do not.

The default value is false.

Implementation
    public function get hasRoot():Boolean

See also

showRoot
parentMenu property
parentMenu:Menu [read-write]

The parent menu in a hierarchical chain of menus, where the current menu is a submenu of the parent.

Implementation
    public function get parentMenu():Menu
    public function set parentMenu(value:Menu):void
showRoot property
showRoot:Boolean [read-write]

/ A Boolean flag that specifies whether to display the data provider's root node. If the dataProvider object has a root node, and showRoot is set to false, the Menu control does not display the root node; only the descendants of the root node will be displayed. This flag has no effect on data providers without root nodes, like Lists and Arrays.

The default value is true.

Implementation
    public function get showRoot():Boolean
    public function set showRoot(value:Boolean):void

See also

hasRoot
Constructor detail
Menu () constructor
public function Menu()

Constructor.

Applications do not normally call the Menu constructor directly. Instead, Applications will call the Menu.createMenu() method.

Method detail
createMenu () method
public static function createMenu(parent:DisplayObjectContainer, mdp:Object, showRoot:Boolean = true):Menu

Creates and returns an instance of the Menu class. The Menu control's content is determined by the method's mdp argument. The Menu control is placed in the parent container specified by the method's parent argument. This method does not show the Menu control. Instead, this method just creates the Menu control and allows for modifications to be made to the Menu instance before the Menu is shown. To show the Menu, call the Menu.show() method.

Parameters
parent:DisplayObjectContainer — A container that the PopUpManager uses to place the Menu control in. The Menu control may not actually be parented by this object.
mdp:Object — The data provider for the Menu control.
showRoot:Boolean (default = true) — A Boolean flag that specifies whether to display the root node of the data provider.

Returns
Menu — An instance of the Menu class.

See also

mx.controls.Menu
mx.controls.Menu
mx.controls.Menu.popUpMenu()
hide () method
public function hide():void

Hides the Menu control and any of its submenus if the Menu control is visible.

measure () method
protected override function measure():void

Calculates the preferred width and height of the Menu based on the widths and heights of its menu items. This method does not take into account the position and size of submenus.

popUpMenu () method
public static function popUpMenu(menu:Menu, parent:DisplayObjectContainer, mdp:Object):void

Sets the dataProvider of an existing Menu control and places the Menu control in the specified parent container. This method does not show the Menu control; you must use the Menu.show() method to display the Menu control. The Menu.createMenu() method uses this method.

Parameters
menu:Menu — Menu control to popup.
parent:DisplayObjectContainer — A container that the PopUpManager uses to place the Menu control in. The Menu control may not actually be parented by this object. If you omit this property, the method sets the Menu control's parent to the application.
mdp:Object — dataProvider object set on the popped up Menu. If you omit this property, the method sets the Menu data provider to a new, empty XML object.
setMenuItemToggled () method
protected function setMenuItemToggled(item:Object, toggle:Boolean):void

Toggles the menu item. The menu item type identifier must be a check box or radio button, otherwise this method has no effect.

Parameters
item:Object — The menu item to toggle
toggle:Boolean — Boolean value that indicates whether the item is toggled.
show () method
public function show(xShow:Object = null, yShow:Object = null):void

Shows the Menu control. If the Menu control is not visible, this method places the Menu in the upper-left corner of the parent application at the given coordinates, resizes the Menu control as needed, and makes the Menu control visible. The x and y arguments of the show() method specify the coordinates of the upper-left corner of the Menu control relative to the parent application, which is not necessarily the direct parent of the Menu control. For example, if the Menu control is in an HBox container which is nested within a Panel container, the x and y coordinates are relative to the Application container, not to the HBox container.

Parameters
xShow:Object (default = null) — Horizontal location of the Menu control's upper-left corner (optional).
yShow:Object (default = null) — Vertical location of the Menu control's upper-left corner (optional).
Event detail
itemClick event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.ITEM_CLICK

Dispatched when a menu item is selected.

The MenuEvent.ITEM_CLICK event type constant indicates that the user selected a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the selected menu item.
item | The item in the dataProvider that was selected.
itemRenderer | The ListItemRenderer of the selected menu item.
label | The label text of the selected menu item.
menu | The specific Menu instance associated with this event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_CLICK
menuHide event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.MENU_HIDE

Dispatched when a menu or submenu is dismissed.

The MenuEvent.MENU_HIDE event type constant indicates that a menu or submenu closed.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | -1. This property is not set for this type of event.
item | null. This property is not set for this type of event.
itemRenderer | null. This property is not set for this type of event.
label | null. This property is not set for this type of event.
menu | The specific Menu instance that was hidden.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.MENU_HIDE
menuShow event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.MENU_SHOW

Dispatched when a menu or submenu opens.

The MenuEvent.MENU_SHOW type constant indicates that the mouse pointer rolled a menu or submenu opened.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | -1. This property is not set for this type of event.
item | null. This property is not set for this type of event.
itemRenderer | null. This property is not set for this type of event.
label | null. This property is not set for this type of event.
menu | The specific Menu instance associated with the event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.MENU_SHOW
Examples
SimpleMenuExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Menu control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.controls.Menu;
            import mx.events.MenuEvent;
            import mx.controls.Alert;
            import flash.geom.Point;

            private var point1:Point = new Point();
            private var myMenu:Menu;

            // Create and display the Menu control.
            private function showMenu():void {
                myMenu= Menu.createMenu(panel, myMenuData, false);
                myMenu.labelField="@label"
                myMenu.addEventListener("itemClick", menuHandler);

                // Calculate position of Menu in Application's coordinates.
                point1.x=mybutton.x;
                point1.y=mybutton.y;
                point1=mybutton.localToGlobal(point1);

                myMenu.show(point1.x + 25, point1.y + 25);
            }

            // Event handler for the Menu control's change event.
            private function menuHandler(event:MenuEvent):void  {
                Alert.show("Label: " + event.item.@label, "Clicked menu item");
            }
        ]]>
    </mx:Script>

    <mx:XML id="myMenuData">
        <root>
            <menuitem label="MenuItem 1" eventName="copy"/>
            <menuitem label="MenuItem 2" eventName="paste"/>
        </root>
    </mx:XML>

    <mx:Panel id="panel" title="Menu Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10">

        <mx:Label width="100%" color="blue"
           text="Click the button to open the Menu control."/>

        <mx:Button id="mybutton" label="Open Menu" click="showMenu();"/>

    </mx:Panel>
</mx:Application>


mx.controls.MenuBar (Flex™ 2 Language Reference)

Class MenuBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class MenuBar
Inheritance | MenuBar Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerComponent

A MenuBar control defines a horizontal menu bar that contains one or more child menus. The MenuBar control is generally always visible. It is not intended for use as a pop-up menu. The individual child menus pop up as the user selects them with the mouse or keyboard. Open menus disappear when a menu item is selected, or if the menu is dismissed by the user clicking outside the menu.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:MenuBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:MenuBar
    Properties
    dataDescriptor="instance of DefaultDataDescriptor"
    dataProvider="undefined"
    iconField="icon"
    labelField="label"
    labelFunction="undefined"
    menubarItems="[]"
    menus="[]"
    selectedIndex="-1"
    showRoot="true"

    Styles
    backgroundAlpha="1.0"
    backgroundColor="undefined"
    backgroundSkin="mx.skins.halo.MenuBarBackgroundSkin"
    borderColor="0xAAB3B3"
    color="0x0B333C"
    cornerRadius="0"
    disabledColor="0xAAB3B3"
    fillAlphas="[0.6,0.4]"
    fillColors="[0xFFFFFF, 0xCCCCCC]"
    focusAlpha="0.5"
    focusRoundedCorners="tl tr bl br"
    fontAntiAliasType="advanced|normal"
    fontFamily="Verdana"
    fontGridFitType="pixel|none|subpixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    highlightAlphas="[0.3,0.0]"
    itemDownSkin="mx.skins.halo.ActivatorSkin"
    itemOverSkin="mx.skins.halo.ActivatorSkin"
    itemUpSkin="mx.skins.halo.ActivatorSkin"
    leading="2""
    rollOverColor="0xB2E1FF"
    selectionColor="0x7FCEFF"
    textAlign="left"
    textDecoration="none"
    textIndent="0"

    Events
    itemClick="No default"
    itemRollOut="No default"
    itemRollOver="No default"
    menuHide="No default"
    menuShow="No default"
  />

Default MXML Property dataProvider

View the examples.

See also

mx.controls.Menu
mx.controls.PopUpMenuButton
mx.controls.menuClasses.MenuBarItem
mx.controls.menuClasses.IMenuDataDescriptor
mx.controls.treeClasses.DefaultDataDescriptor
Using Menu-Based Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | dataDescriptor : IMenuDataDescriptor The object that accesses and manipulates data in the data provider. | MenuBar
 | dataProvider : Object The hierarchy of objects that are displayed as MenuBar items and menus. | MenuBar
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | hasRoot : Boolean [read-only] A flag that indicates that the current data provider has a root node; for example, a single top node in a hierarchical structure. | MenuBar
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | iconField : String The name of the field in the data provider object that determines the icon to display for each menu item. | MenuBar
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | labelField : String The name of the field in the data provider object that determines the text to display for each menu item. | MenuBar
 | labelFunction : Function The function that determines the text to display for each menu item. | MenuBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | menuBarItems : Array An Array of MenuBarItem objects that populate this MenuBar. | MenuBar
 | menus : Array An Array containing the Menu objects for this MenuBar. | MenuBar
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedIndex : int The index in the MenuBar control of the currently open Menu or the last opened Menu if none are currently open. | MenuBar
 | showRoot : Boolean A Boolean flag that specifies whether to display the data provider's root node. | MenuBar
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MenuBar()
Constructor
MenuBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
getMenuAt(index:int):Menu
Returns a reference to the Menu at the specified MenuBar item index.
MenuBar
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Calculates the preferred width and height of the MenuBar based on the default widths of the MenuBar items. | MenuBar
 | updateBackground():void Updates the MenuBar background skin. | MenuBar
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when the user selects a menu item. | MenuBar
 | itemRollOut | Dispatched when the mouse pointer rolls out of a menu item. | MenuBar
 | itemRollOver | Dispatched when the mouse pointer rolls over a menu item. | MenuBar
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
 | menuHide | Dispatched when a menu or submenu closes. | MenuBar
 | menuShow | Dispatched when a menu or submenu opens, or the mouse pointer rolls over an item with no drop-down menu. | MenuBar
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property. Valid values range from 0.0 to 1.0. The default value is 1.0. 		MenuBar
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of the component. The default value is undefined, which means it is not set and the component has a transparent background.

The default skins of most Flex controls are partially transparent. As a result, the background color of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>
MenuBar
backgroundSkin
Type: Class CSS Inheritance: no
The background skin of the MenuBar control. The default value is mx.skins.halo.MenuBarBackgroundSkin. 		MenuBar
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The following controls support this style: Button, CheckBox, ComboBox, MenuBar, NumericStepper, ProgressBar, RadioButton, ScrollBar, Slider, and any components that support the borderStyle style. The default value depends on the component class; if not overriden for the class, the default value is 0xB7BABC. 		MenuBar
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		MenuBar
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The following components support this style: Alert, Button, ComboBox, LinkButton, MenuBar, NumericStepper, Panel, ScrollBar, Tab, TitleWindow, and any component that supports a borderStyle property set to "solid". The default value depends on the component class; if not overriden for the class, the default value is 0. 		MenuBar
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		MenuBar
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
fillAlphas
Type: Array CSS Inheritance: no
Alphas used for the background fill of controls. Use [1, 1] to make the control background opaque. The default value is [ 0.6, 0.4 ]. 		MenuBar
fillColors
Type: Array Format: Color CSS Inheritance: no
Colors used to tint the background of the control. Pass the same color for both values for a flat-looking control. The default value is [ 0xFFFFFF, 0xCCCCCC ]. 		MenuBar
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		MenuBar
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		MenuBar
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		MenuBar
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		MenuBar
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		MenuBar
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		MenuBar
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		MenuBar
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		MenuBar
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		MenuBar
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		MenuBar
highlightAlphas
Type: Array CSS Inheritance: no
Alpha transparencies used for the highlight fill of controls. The first value specifies the transparency of the top of the highlight and the second value specifies the transparency of the bottom of the highlight. The highlight covers the top half of the skin. The default value is [ 0.3, 0.0 ]. 		MenuBar
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
itemDownSkin
Type: Class CSS Inheritance: no
The skin when a MenuBar item is selected. The default value is mx.skins.halo.ActivatorSkin. 		MenuBar
itemOverSkin
Type: Class CSS Inheritance: no
The skin when focus is over a MenuBar item either. The default value is mx.skins.halo.ActivatorSkin. 		MenuBar
itemUpSkin
Type: Class CSS Inheritance: no
The skin when a MenuBar item is not selected. The default value is mx.skins.halo.ActivatorSkin. 		MenuBar
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

MenuBar
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
rollOverColor
Type: uint Format: Color CSS Inheritance: yes
The color of the menu item background when a user rolls the mouse over it. 		MenuBar
selectionColor
Type: uint Format: Color CSS Inheritance: yes
The color of the menu item background when a menu item is selected. 		MenuBar
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

MenuBar
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		MenuBar
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		MenuBar
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dataDescriptor property
dataDescriptor:IMenuDataDescriptor [read-write]

The object that accesses and manipulates data in the data provider. The MenuBar control delegates to the data descriptor for information about its data. This data is then used to parse and move about the data source.

When you specify this property as an attribute in MXML, you must use a reference to the data descriptor, not the string name of the descriptor. Use the following format for setting the property:

<mx:MenuBar id="menubar" dataDescriptor="{new MyCustomDataDescriptor()}"/>>

Alternatively, you can specify the property in MXML as a nested subtag, as the following example shows:

<mx:MenuBst>
   <mx:dataDescriptor>
      <myCustomDataDescriptor>
   </mx:dataDescriptor>
   ...

The default value is an internal instance of the DefaultDataDescriptor class.

Implementation
    public function get dataDescriptor():IMenuDataDescriptor
    public function set dataDescriptor(value:IMenuDataDescriptor):void
dataProvider property
dataProvider:Object [read-write]

The hierarchy of objects that are displayed as MenuBar items and menus. The top-level children all become MenuBar items, and their children become the items in the menus and submenus. The MenuBar control handles the source data object as follows:

  • A String containing valid XML text is converted to an XML object.
  • An XMLNode is converted to an XML object.
  • An XMLList is converted to an XMLListCollection.
  • Any object that implements the ICollectionView interface is cast to an ICollectionView.
  • An Array is converted to an ArrayCollection.
  • Any other type object is wrapped in an Array with the object as its sole entry.

The default value is "undefined".

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
hasRoot property
hasRoot:Boolean [read-only]

A flag that indicates that the current data provider has a root node; for example, a single top node in a hierarchical structure. XML and Object are examples of types that have a root node, while Lists and Arrays do not.

Implementation
    public function get hasRoot():Boolean
iconField property
iconField:String [read-write]

The name of the field in the data provider object that determines the icon to display for each menu item. By default, the MenuBar does not try to display icons along with the text in a menu item. By specifying an icon field, you can define a graphic that is created and displayed as an icon for a menu item. The MenuItemRenderer will look in the data provider object for a property of the name supplied as the iconField. If the value of the property is a Class, it will instantiate that class and expect it to be an instance of an IFlexDisplayObject. If the value of the property is a String, it will look to see if a Class exists with that name in the application, and if it can't find one, it will also look for a property on the document with that name and expect that property to map to a Class.

The default value is "icon".

This property can be used as the source for data binding.

Implementation
    public function get iconField():String
    public function set iconField(value:String):void
labelField property
labelField:String [read-write]

The name of the field in the data provider object that determines the text to display for each menu item. If the data provider is an Array of Strings, Flex uses each string value as the label. If the data provider is an E4X XML object, you must set this property explicitly. For example, use

The default value is "label".

This property can be used as the source for data binding.

Implementation
    public function get labelField():String
    public function set labelField(value:String):void
labelFunction property
public var labelFunction:Function

The function that determines the text to display for each menu item. The label function must find the appropriate field or fields in the data provider object and return a displayable string. If you omit this property, Flex uses the contents of the field or attribute specified by the labelField property. If you specify this property, Flex ignores any labelField property value. The labelFunction property is good for handling formatting and localization.

The label function must take a single argument which is the item in the dataProvider and return a String.

labelFunction(item:Object):String

The default value is "undefined".

menuBarItems property
public var menuBarItems:Array

An Array of MenuBarItem objects that populate this MenuBar. Each item in the array defines an item displayed in a MenuBar control.

The default value is [ ].

See also

mx.controls.menuClasses.MenuBarItem
menus property
public var menus:Array

An Array containing the Menu objects for this MenuBar. Each MenuBar item can have a corresponding Menu object in the array, even if the item does not have a drop-down menu. Flex does not initially populate the menus array; instead, it creates the menus dynamically, as needed.

The default value is [ ].

selectedIndex property
selectedIndex:int [read-write]

The index in the MenuBar control of the currently open Menu or the last opened Menu if none are currently open.

The default value is -1.

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
showRoot property
showRoot:Boolean [read-write]

A Boolean flag that specifies whether to display the data provider's root node. If the dataProvider object has a root node, and showRoot is set to false, the items on the MenuBar control correspond to the immediate descendants of the root node. This flag has no effect on data providers without root nodes, like Lists and Arrays.

The default value is true.

Implementation
    public function get showRoot():Boolean
    public function set showRoot(value:Boolean):void

See also

hasRoot
Constructor detail
MenuBar () constructor
public function MenuBar()

Constructor

Method detail
getMenuAt () method
public function getMenuAt(index:int):Menu

Returns a reference to the Menu at the specified MenuBar item index. 0 is the Menu contained at the leftmost MenuBar item index.

Parameters
index:int — Index of the Menu instance to return.

Returns
Menu — Reference to the Menu contained at the specified index.
measure () method
protected override function measure():void

Calculates the preferred width and height of the MenuBar based on the default widths of the MenuBar items.

updateBackground () method
protected function updateBackground():void

Updates the MenuBar background skin. This method is called when MenuBar children are created or when any styles on the MenuBar changes.

Event detail
itemClick event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.ITEM_CLICK

Dispatched when the user selects a menu item.

The MenuEvent.ITEM_CLICK event type constant indicates that the user selected a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the selected menu item.
item | The item in the dataProvider that was selected.
itemRenderer | The ListItemRenderer of the selected menu item.
label | The label text of the selected menu item.
menu | The specific Menu instance associated with this event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_CLICK
itemRollOut event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.ITEM_ROLL_OUT

Dispatched when the mouse pointer rolls out of a menu item.

The MenuEvent.ITEM_ROLL_OUT type constant indicates that the mouse pointer rolled out of a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the menu item that was rolled out of.
item | The item in the dataProvider corresponding to the menu item that was rolled out of.
itemRenderer | The ListItemRenderer of the menu item that was rolled out of.
label | The label text of the menu item that was rolled out of.
menu | The specific Menu instance associated with the event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_ROLL_OUT
itemRollOver event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.ITEM_ROLL_OVER

Dispatched when the mouse pointer rolls over a menu item.

The MenuEvent.ITEM_ROLL_OVER type constant indicates that the mouse pointer rolled over a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the menu item that was rolled over.
item | The item in the dataProvider associated with the rolled over menu item.
itemRenderer | The ListItemRenderer of the menu item that was rolled over.
label | The label text of the menu item that was rolled over.
menu | The specific Menu instance associated with the event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_ROLL_OVER
menuHide event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.MENU_HIDE

Dispatched when a menu or submenu closes.

The MenuEvent.MENU_HIDE event type constant indicates that a menu or submenu closed.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | -1. This property is not set for this type of event.
item | null. This property is not set for this type of event.
itemRenderer | null. This property is not set for this type of event.
label | null. This property is not set for this type of event.
menu | The specific Menu instance that was hidden.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.MENU_HIDE
menuShow event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.MENU_SHOW

Dispatched when a menu or submenu opens, or the mouse pointer rolls over an item with no drop-down menu.

The MenuEvent.MENU_SHOW type constant indicates that the mouse pointer rolled a menu or submenu opened.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | -1. This property is not set for this type of event.
item | null. This property is not set for this type of event.
itemRenderer | null. This property is not set for this type of event.
label | null. This property is not set for this type of event.
menu | The specific Menu instance associated with the event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.MENU_SHOW
Examples
MenuBarExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the MenuBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" creationComplete="initCollections();" >

    <mx:Script>
        <![CDATA[

            import mx.events.MenuEvent;
            import mx.controls.Alert;
            import mx.collections.*;

            [Bindable]
            public var menuBarCollection:XMLListCollection;

            private var menubarXML:XMLList =
                <>
                    <menuitem label="Menu1">
                        <menuitem label="MenuItem 1-A" data="1A"/>
                        <menuitem label="MenuItem 1-B" data="1B"/>
                    </menuitem>
                    <menuitem label="Menu2">
                        <menuitem label="MenuItem 2-A" type="check"  data="2A"/>
                        <menuitem type="separator" />
                        <menuitem label="MenuItem 2-B" >
                            <menuitem label="SubMenuItem 3-A" type="radio"
                                groupName="one" data="3A"/>
                            <menuitem label="SubMenuItem 3-B" type="radio"
                                groupName="one" data="3B"/>
                        </menuitem>
                    </menuitem>
                </>;

            // Event handler for the MenuBar control's itemClick event.
            private function menuHandler(event:MenuEvent):void  {
                Alert.show("Label: " + event.item.@label + "\n" +
                    "Data: " + event.item.@data, "Clicked menu item");
            }

            // Event handler to initialize the MenuBar control.
            private function initCollections():void {
                menuBarCollection = new XMLListCollection(menubarXML);
            }
         ]]>
    </mx:Script>

    <mx:Panel title="MenuBar Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10">

        <mx:Label width="100%" color="blue"
           text="Select a menu item."/>

        <mx:MenuBar labelField="@label" itemClick="menuHandler(event);"
            dataProvider="{menuBarCollection}" />

    </mx:Panel>
</mx:Application>


mx.controls.NavBar (Flex™ 2 Language Reference)

Class NavBar | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls
Class | public class NavBar
Inheritance | NavBar Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | ButtonBar, LinkBar

The NavBar control is the superclass for navigator controls, such as the LinkBar and TabBar controls, and cannot be instantiated directly.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The tag inherits all of the tag attributes of its superclass, with the exception of scrolling-related attributes, and adds the following tag attributes:

  <mx:tagname
    Properties
    dataProvider="No default"
    iconField="icon"
    labeField="label"
    selectedIndex="-1"
    toolTipField="tooltip"

    Events
    itemClick="No default"
    >
     ...
       child tags
     ...
    </mx:tagname>

See also

mx.collections.IList
mx.containers.ViewStack
mx.controls.LinkBar
mx.controls.TabBar
mx.controls.ButtonBar
Using ToolTips with NavBar controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
 | dataProvider : Object Data used to populate the navigator control. | NavBar
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String The direction in which this Box container lays out its children. | Box
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | iconField : String Name of the field in the dataProvider object to display as the icon for each navigation item. | NavBar
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | labelField : String Name of the field in the dataProvider object to display as the label for each navigation item. | NavBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedIndex : int Index of the active navigation item, where the first item is at an index of 0. | NavBar
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
 | toolTipField : String Name of the the field in the dataProvider object to display as the tooltip label. | NavBar
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NavBar()
Constructor.
NavBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
 | clickHandler(event:MouseEvent):void Handles the MouseEvent.CLICK event for the items in the NavBar control. | NavBar
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
 | createNavItem(label:String, icon:Class = null):IFlexDisplayObject Creates the individual navigator items. | NavBar
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
 | hiliteSelectedNavItem(index:int):void Highlights the selected navigator item. | NavBar
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
 | resetNavItems():void Resets the navigator bar to its default state. | NavBar
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
 | updateNavItemIcon(index:int, icon:Class):void Resets the icon of a navigator item in the NavBar control. | NavBar
 | updateNavItemLabel(index:int, label:String):void Sets the label property of a navigator item in the NavBar control. | NavBar
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when a navigation item is selected. | NavBar
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Box
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Box
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Box
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Box
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dataProvider property
dataProvider:Object [read-write]

Data used to populate the navigator control. The type of data can either be a ViewStack container or an Array.

When you use a ViewStack container, the label and icon properties of the ViewStack container's children are used to populate the navigation items, as in the following example:

      <mx:LinkBar dataProvider="{vs}"/>
      <mx:ViewStack id="vs">
        <mx:VBox label="Accounts" icon="account_icon"/>
        <mx:VBox label="Leads" icon="leads_icon"/>
      </mx:ViewStack>

The LinkBar control contains two links: "Accounts" and "Leads," each with its own icon as specified on the VBox tags. When you click a link, the ViewStack container navigates to the corresponding view.

When you use an Array, the labelField property determines the name of the dataProvider field to use as the label for each navigation item; the iconField property determines the name of the dataProvider field to use as the icon for each navigation item. If you use an Array of Strings, the labelField property is ignored.

The default value is "undefined".

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
iconField property
iconField:String [read-write]

Name of the field in the dataProvider object to display as the icon for each navigation item.

The default value is "icon".

This property can be used as the source for data binding.

Implementation
    public function get iconField():String
    public function set iconField(value:String):void
labelField property
labelField:String [read-write]

Name of the field in the dataProvider object to display as the label for each navigation item.

The default value is "label".

This property can be used as the source for data binding.

Implementation
    public function get labelField():String
    public function set labelField(value:String):void
selectedIndex property
selectedIndex:int [read-write]

Index of the active navigation item, where the first item is at an index of 0.

The default value is -1.

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
toolTipField property
toolTipField:String [read-write]

Name of the the field in the dataProvider object to display as the tooltip label.

The default value is "toolTip".

This property can be used as the source for data binding.

Implementation
    public function get toolTipField():String
    public function set toolTipField(value:String):void
Constructor detail
NavBar () constructor
public function NavBar()

Constructor.

Method detail
clickHandler () method
protected function clickHandler(event:MouseEvent):void

Handles the MouseEvent.CLICK event for the items in the NavBar control. This handler dispatches the itemClick event for the NavBar control.

Parameters
event:MouseEvent — The event object.
createNavItem () method
protected function createNavItem(label:String, icon:Class = null):IFlexDisplayObject

Creates the individual navigator items. By default, this method performs no action. You can override this method in a subclass to create a navigator item based on the type of navigator items in your subclass.

Parameters
label:String — The label for the created navigator item.
icon:Class (default = null) — The icon for the created navigator item. Typically, this is an icon that you have embedded in the application.

Returns
IFlexDisplayObject — The created navigator item.
hiliteSelectedNavItem () method
protected function hiliteSelectedNavItem(index:int):void

Highlights the selected navigator item. By default, this method performs no action. You can override this method in a subclass to highlight the selected navigator item.

Parameters
index:int — The index of the selected item in the NavBar control. The first item is at an index of 0.
resetNavItems () method
protected function resetNavItems():void

Resets the navigator bar to its default state. By default, this method performs no action. You can override this method in a subclass to reset the navigator bar to a default state.

updateNavItemIcon () method
protected function updateNavItemIcon(index:int, icon:Class):void

Resets the icon of a navigator item in the NavBar control. You can override this method in a subclass to set the icon of a navigator item based on the type of navigator items in your subclass.

Parameters
index:int — The index of the navigator item in the NavBar control. The first navigator item is at an index of 0.
icon:Class — The new icon for the navigator item. Typically, this is an icon that you have embedded in the application.
updateNavItemLabel () method
protected function updateNavItemLabel(index:int, label:String):void

Sets the label property of a navigator item in the NavBar control. You can override this method in a subclass to set the label of a navigator item based on the type of navigator items in your subclass.

Parameters
index:int — The index of the navigator item in the NavBar control. The first navigator item is at an index of 0.
label:String — The new label text for the navigator item.
Event detail
itemClick event
Event object type: mx.events.ItemClickEvent
ItemClickEvent.type property = mx.events.ItemClickEvent.ITEM_CLICK

Dispatched when a navigation item is selected.

The ItemClickEvent.ITEM_CLICK constant defines the value of the type property of the event object for an itemClick event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index of the navigation item that was clicked.
item | The item in the data provider of the navigation item that was clicked.
label | The label of the navigation item that was clicked.
relatedObject | The child object that generated the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.controls.NumericStepper (Flex™ 2 Language Reference)

Class NumericStepper | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class NumericStepper
Inheritance | NumericStepper Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IFocusManagerComponent, IIMESupport, IListItemRenderer

The NumericStepper control lets the user select a number from an ordered set. The NumericStepper control consists of a single-line input text field and a pair of arrow buttons for stepping through the possible values. The Up Arrow and Down Arrow keys also cycle through the values.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax
The <mx:NumericStepper> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:
  <mx:NumericStepper
    Properties
    imeMode="null"
    maxChars="10"
    maximum="10"
    minimum="0"
    stepSize="1"
    value="0"

    Styles
    backgroundAlpha="1.0"
    backgroundColor="undefined"
    backgroundImage="undefined"
    backgroundSize="auto"
    borderCapColor="0x919999"
    borderColor="0xAAB3B3"
    borderSides="left top right bottom"
    borderSkin="HaloBorder"
    borderStyle="inset"
    borderThickness="1"
    color="0x0B333C"
    cornerRadius="0"
    disabledColor="0xAAB3B3"
    downArrowDisabledSkin="NumericStepperDownSkin"
    downArrowDownSkin="NumericStepperDownSkin"
    downArrowOverSkin="NumericStepperDownSkin"
    downArrowUpSkin="NumericStepperDownSkin"
    dropShadowEnabled="false"
    dropShadowColor="0x000000"
    focusAlpha="0.5"
    focusRoundedCorners="tl tr bl br"
    fontAntiAliasType="advanced"
    fontFamily="Verdana"
    fontGridFitType="pixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    highlightAlphas="[0.3,0.0]"
    leading="2"
    paddingLeft="0"
    paddingRight="0"
    shadowDirection="center"
    shadowDistance="2"
    textAlign="left|center|right"
    textDecoration="none|underline"
    textIndent="0"
    upArrowDisabledSkin="NumericStepperUpSkin"
    upArrowDownSkin="NumericStepperUpSkin"
    upArrowOverSkin="NumericStepperUpSkin"
    upArrowUpSkin="NumericStepperUpSkin"

    Events
    change="No default"
    dataChange="No default"
  />

View the examples.

See also

NumericStepper control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | NumericStepper
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
 | imeMode : String Specifies the IME (Input Method Editor) mode. | NumericStepper
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | NumericStepper
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxChars : int The maximum number of characters that can be entered in the field. | NumericStepper
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maximum : Number Maximum value of the NumericStepper. | NumericStepper
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
 | minimum : Number Minimum value of the NumericStepper. | NumericStepper
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
 | nextValue : Number [read-only] The value that is one step larger than the current value property and not greater than the maximum property value. | NumericStepper
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | previousValue : Number [read-only] The value that is one step smaller than the current value property and not smaller than the maximum property value. | NumericStepper
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
 | stepSize : Number Non-zero unit of change between values. | NumericStepper
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | value : Number Current value displayed in the text area of the NumericStepper control. | NumericStepper
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NumericStepper()
Constructor.
NumericStepper
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the value of the NumericStepper control changes as a result of user interaction. | NumericStepper
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | NumericStepper
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. Valid values range from 0.0 to 1.0. The default value is 1.0. 		NumericStepper
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. You can have both a backgroundColor and a backgroundImage set. Some components do not have a background. The DataGrid control ignores this style. The default value is undefined, which means it is not set. If both this style and the backgroundImage style are undefined, the component has a transparent background.

For the Application container, this style specifies the background color while the application loads, and a background gradient while it is running. Flex calculates the gradient pattern between a color slightly darker than the specified color, and a color slightly lighter than the specified color.

The default skins of most Flex controls are partially transparent. As a result, the background color of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

NumericStepper
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. This can be an absolute or relative URL or class. You can either have both a backgroundColor and a backgroundImage set at the same time. The background image is displayed on top of the background color. The default value is undefined, meaning "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The default skins of most Flex controls are partially transparent. As a result, the background image of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

NumericStepper
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). The default value is "auto", which maintains the original size of the image. 		NumericStepper
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The default value depends on the component class; if not overridden for the class, the default value is 0xB7BABC. 		NumericStepper
borderSides
Type: String CSS Inheritance: no
Bounding box sides. A space-delimited String that specifies the sides of the border to show. The String can contain "left", "top", "right", and "bottom" in any order. The default value is "left top right bottom", which shows all four sides. This style is only used when borderStyle is "solid". 		NumericStepper
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. The default value is mx.skins.halo.HaloBorder. 		NumericStepper
borderStyle
Type: String CSS Inheritance: no
Bounding box style. The possible values are "none", "solid", "inset", and "outset". The default value depends on the component class; if not overridden for the class, the default value is "inset". The default value for most Containers is "none". 		NumericStepper
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. Only used when borderStyle is set to "solid". The default value is 1. 		NumericStepper
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		NumericStepper
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The default value depends on the component class; if not overriden for the class, the default value is 0. The default value for ApplicationControlBar is 5. 		NumericStepper
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		NumericStepper
downArrowDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the Up arrow when the arrow is disabled. The default value is NumericStepperDownSkin. 		NumericStepper
downArrowDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the up arrow when the arrow is enabled and a user presses the mouse button over the arrow. The default value is NumericStepperDownSkin. 		NumericStepper
downArrowOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is over the arrow. The default value is NumericStepperDownSkin. 		NumericStepper
downArrowUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is not on the arrow. There is no default. 		NumericStepper
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. The default value is 0x000000. 		NumericStepper
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. This style is used with borderStyle="solid". The default value is false.

Note: For drop shadows to appear on containers, set backgroundColor or backgroundImage properties. Otherwise, the shadow appears behind the container because the default background of a container is transparent.

NumericStepper
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		NumericStepper
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		NumericStepper
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		NumericStepper
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		NumericStepper
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		NumericStepper
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		NumericStepper
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		NumericStepper
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		NumericStepper
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		NumericStepper
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		NumericStepper
highlightAlphas
Type: Array CSS Inheritance: no
Alphas used for the highlight fill of controls. The default value is [ 0.3, 0.0 ]. 		NumericStepper
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

NumericStepper
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

NumericStepper
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

NumericStepper
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. Possible values are "left", "center", and "right". The default value is "center". 		NumericStepper
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. If the property is set to a negative value, the shadow appears above the component. The default value is 2. 		NumericStepper
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

NumericStepper
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		NumericStepper
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		NumericStepper
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
upArrowDisabledSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the Up arrow when the arrow is disabled. The default value is NumericStepperUpSkin. 		NumericStepper
upArrowDownSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the Up arrow when the arrow is enabled and a user presses the mouse button over the arrow. The default value is NumericStepperUpSkin. 		NumericStepper
upArrowOverSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is over the arrow. The default value is NumericStepperUpSkin. 		NumericStepper
upArrowUpSkin
Type: Class CSS Inheritance: no
Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is not on the arrow. The default value is NumericStepperUpSkin. 		NumericStepper
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The data property lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

When you use the control as a drop-in item renderer or drop-in item editor, Flex automatically writes the current value of the item to the value property of this control.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
imeMode property
imeMode:String [read-write]

Specifies the IME (Input Method Editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the specified IME mode when the control gets the focus and sets it back to previous value when the control loses the focus.

The flash.system.IMEConversionMode class defines constants for the valid values for this property. You can also specify null to specify no IME.

The default value is null.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void

See also

flash.system.IMEConversionMode
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. The component can then use the listData property to initialize the data property of the drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
maxChars property
maxChars:int [read-write]

The maximum number of characters that can be entered in the field. A value of 0 means that any number of characters can be entered.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get maxChars():int
    public function set maxChars(value:int):void
maximum property
maximum:Number [read-write]

Maximum value of the NumericStepper. The maximum can be any number, including a fractional value.

The default value is 10.

This property can be used as the source for data binding.

Implementation
    public function get maximum():Number
    public function set maximum(value:Number):void
minimum property
minimum:Number [read-write]

Minimum value of the NumericStepper. The minimum can be any number, including a fractional value.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get minimum():Number
    public function set minimum(value:Number):void
nextValue property
nextValue:Number [read-only]

The value that is one step larger than the current value property and not greater than the maximum property value.

Implementation
    public function get nextValue():Number
previousValue property
previousValue:Number [read-only]

The value that is one step smaller than the current value property and not smaller than the maximum property value.

Implementation
    public function get previousValue():Number
stepSize property
stepSize:Number [read-write]

Non-zero unit of change between values. The value property must be a multiple of this number.

The default value is 1.

This property can be used as the source for data binding.

Implementation
    public function get stepSize():Number
    public function set stepSize(value:Number):void
value property
value:Number [read-write]

Current value displayed in the text area of the NumericStepper control. If a user enters number that is not a multiple of the stepSize property or is not in the range between the maximum and minimum properties, this property is set to the closest valid value.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get value():Number
    public function set value(value:Number):void
Constructor detail
NumericStepper () constructor
public function NumericStepper()

Constructor.

Event detail
change event
Event object type: mx.events.NumericStepperEvent
NumericStepperEvent.type property = mx.events.NumericStepperEvent.CHANGE

Dispatched when the value of the NumericStepper control changes as a result of user interaction.

The NumericStepperEvent.CHANGE constant defines the value of the type property of the event object for a change event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value of the NumericStepper control when the event was dispatched.
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
NumericStepperExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the NumericStepper control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="NumericStepper Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10">

        <mx:Text width="100%" color="blue"
            text="Default NumericStepper control with a minimum=0, maximum=10, and stepSize=1."/>
        <mx:NumericStepper/>

        <mx:Text width="100%"  color="blue"
            text="NumericStepper control with a minimum=10, maximum=40, stepSize=0.01, and starting value of 20."/>

        <mx:NumericStepper id="ns"
            minimum="10.00" maximum="40.00"
            stepSize="0.01"
            value="20.00"
            width="65"/>

        <mx:Label  color="blue" text="You selected {ns.value}"/>

    </mx:Panel>
</mx:Application>


mx.controls.PopUpButton (Flex™ 2 Language Reference)

Class PopUpButton | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class PopUpButton
Inheritance | PopUpButton Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | PopUpMenuButton

The PopUpButton control adds a flexible pop-up control interface to a Button control. It contains a main button and a secondary button, called the pop-up button, which pops up any UIComponent object when a user clicks the pop-up button.

A PopUpButton control can have a text label, an icon, or both on its face. When a user clicks the main part of the PopUpButton control, it dispatches a click event.

One common use for the PopUpButton control is to have the pop-up button open a List control or a Menu control that changes the function and label of the main button.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PopUpButton> tag inherits all of the tag attributes of its superclass and adds the following tag attributes:

  <mx:PopUpButton

    Properties
    openAlways="false|true
    popUp="No default"

    Styles
    arrowButtonWidth="16"
    closeDuration="250"
    closeEasingFunction="No default"
    openDuration="250"
    openEasingFunction="No default"
    popUpDownSkin="popUpDownSkin"
    popUpGap="0"
    popUpIcon="PopUpIcon"
    popUpOverSkin="popUpOverSkin"

    Events
    close="No default"
    open="No default"
  />

View the examples.

See also

PopUpButton control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | emphasized : Boolean Draws a thick border around the Button control when the control is in its up state if emphasized is set to true. | Button
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
Inherited | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | openAlways : Boolean If true, specifies to pop up the popUp when you click the main button. | PopUpButton
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | popUp : IUIComponent Specifies the UIComponent object, or object defined by a subclass of UIComponent, to pop up. | PopUpButton
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PopUpButton()
Constructor.
PopUpButton
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
close():void
Closes the UIComponent object opened by the PopUpButton control.
PopUpButton
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
open():void
Opens the UIComponent object specified by the popUp property.
PopUpButton
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | close | Dispatched when the specified UIComponent closes. | PopUpButton
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
 | open | Dispatched when the specified UIComponent opens. | PopUpButton
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
 | arrowButtonWidth | Type: Number Format: Length CSS Inheritance: no Number of pixels between the divider line and the right edge of the component. The default value is 16. | PopUpButton
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Button
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | closeDuration | Type: Number Format: Time CSS Inheritance: no Length of a close transition, in milliseconds. The default value is 250. | PopUpButton
 | closeEasingFunction | Type: Function CSS Inheritance: no Easing function to control component closing tween. | PopUpButton
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Button
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | Button
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | Button
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | openDuration | Type: Number Format: Time CSS Inheritance: no Length of an open transition, in milliseconds. The default value is 250. | PopUpButton
 | openEasingFunction | Type: Function CSS Inheritance: no Easing function to control component opening tween. | PopUpButton
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
 | popUpDownSkin | Type: Class CSS Inheritance: no Skin class for the popUpDown state (when arrowButton is in down state) of the background and border. The default value is mx.skins.halo.PopUpButtonSkin. | PopUpButton
 | popUpGap | Type: Number Format: Length CSS Inheritance: no Number of vertical pixels between the PopUpButton and the specified popup UIComponent. The default value is 0. | PopUpButton
 | popUpIcon | Type: Class CSS Inheritance: no The icon used for the right button of PopUpButton. Supported classes are mx.skins.halo.PopUpIcon and mx.skins.halo.PopUpMenuIcon. The default value is mx.skins.halo.PopUpIcon. | PopUpButton
 | popUpOverSkin | Type: Class CSS Inheritance: no Skin class for the popUpOver state (over arrowButton) of the background and border. The default value is mx.skins.halo.PopUpButtonSkin. | PopUpButton
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user moves the mouse pointer over the button. | Button
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user presses it. | Button
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
openAlways property
openAlways:Boolean [read-write]

If true, specifies to pop up the popUp when you click the main button. The popUp always appears when you press the Spacebar, or when you click the pop-up button, regardless of the setting of the openAlways property.

The default value is false.

Implementation
    public function get openAlways():Boolean
    public function set openAlways(value:Boolean):void
popUp property
popUp:IUIComponent [read-write]

Specifies the UIComponent object, or object defined by a subclass of UIComponent, to pop up. For example, you can specify a Menu, TileList, or Tree control.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get popUp():IUIComponent
    public function set popUp(value:IUIComponent):void
Constructor detail
PopUpButton () constructor
public function PopUpButton()

Constructor.

Method detail
close () method
public function close():void

Closes the UIComponent object opened by the PopUpButton control.

open () method
public function open():void

Opens the UIComponent object specified by the popUp property.

Event detail
close event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.CLOSE

Dispatched when the specified UIComponent closes.

The DropdownEvent.CLOSE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
open event
Event object type: mx.events.DropdownEvent
DropdownEvent.type property = mx.events.DropdownEvent.OPEN

Dispatched when the specified UIComponent opens.

The DropdownEvent.OPEN constant defines the value of the type property of the event object for a open event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
Examples
PopUpButtonExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the PopUpButton control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.controls.*;
            import mx.events.*;

            private var myMenu:Menu;

            // Initialize the Menu control, and specify it as the pop up object
            // of the PopUpButton control.
            private function initMenu():void {
                myMenu = new Menu();
                var dp:Object = [{label: "New Folder"}, {label: "Sent Items"}, {label: "Inbox"}];
                myMenu.dataProvider = dp;
                myMenu.selectedIndex = 0;
                myMenu.addEventListener("itemClick", itemClickHandler);
                popB.popUp = myMenu;
                popB.label = "Put in: " + myMenu.dataProvider[myMenu.selectedIndex].label;
            }

            // Define the event listener for the Menu control's itemClick event.
            private function itemClickHandler(event:MenuEvent):void {
                var label:String = event.item.label;
                popTypeB.text=String("Moved to " + label);
                popB.label = "Put in: " + label;
                popB.close();
                myMenu.selectedIndex = event.index;
            }

        ]]>
    </mx:Script>

    <mx:Panel title="PopUpButton Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingRight="10" paddingLeft="10">

        <mx:Label width="100%" color="blue"
            text="Button label contains the name of the last selected menu item." />
        <mx:PopUpButton id="popB" label="Edit" creationComplete="initMenu();" width="135" />

        <mx:Spacer height="50" />
        <mx:TextInput id="popTypeB" />

    </mx:Panel>
</mx:Application>


mx.controls.PopUpMenuButton (Flex™ 2 Language Reference)

Class PopUpMenuButton | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class PopUpMenuButton
Inheritance | PopUpMenuButton Inheritance PopUpButton Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The PopUpMenuButton control creates a PopUpButton control with a main sub-button and a secondary sub-button. Clicking on the secondary (right) sub-button drops down a menu that can be popluated through a dataProvider property. The main sub-button of the PopUpMenuButton control can have a text label, an icon, or both on its face. When a user selects an item from the drop-down menu or clicks the main button of the PopUpMenuButton control, the control dispatches an itemClick event. When a user clicks the main button of the control, the control also dispatches a click event. You can customize the look of a PopUpMenuButton control.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PopUpMenuButton> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:PopUpMenuButton
    Properties
    dataDescriptor="instance of DefaultDataDescriptor"
    dataProvider="undefined"
    labelField="null"
    labelFunction="undefined"
    showRoot="false|true"

    Event
    change=No default
  />

View the examples.

See also

mx.controls.Menu
mx.controls.MenuBar
Using Menu-Based Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
 | dataDescriptor : IMenuDataDescriptor The data descriptor accesses and manipulates data in the data provider. | PopUpMenuButton
 | dataProvider : Object DataProvider for popUpMenu. | PopUpMenuButton
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | emphasized : Boolean Draws a thick border around the Button control when the control is in its up state if emphasized is set to true. | Button
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
 | labelField : String Name of the field in the dataProvider Array that contains the text to show for each menu item. | PopUpMenuButton
 | labelFunction : Function A function that determines the text to display for each menu item. | PopUpMenuButton
Inherited | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | openAlways : Boolean If true, specifies to pop up the popUp when you click the main button. | PopUpButton
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | popUp : IUIComponent [write-only] A reference to the pop-up Menu object. | PopUpMenuButton
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
 | showRoot : Boolean Specifies whether to display the top-level node or nodes of the data provider. | PopUpMenuButton
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PopUpMenuButton()
Constructor.
PopUpMenuButton
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
close():void
Closes the UIComponent object opened by the PopUpButton control.
PopUpButton
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
open():void
Opens the UIComponent object specified by the popUp property.
PopUpButton
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | close | Dispatched when the specified UIComponent closes. | PopUpButton
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when a user selects an item from the pop-up menu. | PopUpMenuButton
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | open | Dispatched when the specified UIComponent opens. | PopUpButton
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | arrowButtonWidth | Type: Number Format: Length CSS Inheritance: no Number of pixels between the divider line and the right edge of the component. | PopUpButton
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Button
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | closeDuration | Type: Number Format: Time CSS Inheritance: no Length of a close transition, in milliseconds. | PopUpButton
Inherited | closeEasingFunction | Type: Function CSS Inheritance: no Easing function to control component closing tween. | PopUpButton
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Button
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | Button
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | Button
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | openDuration | Type: Number Format: Time CSS Inheritance: no Length of an open transition, in milliseconds. | PopUpButton
Inherited | openEasingFunction | Type: Function CSS Inheritance: no Easing function to control component opening tween. | PopUpButton
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
Inherited | popUpDownSkin | Type: Class CSS Inheritance: no Skin class for the popUpDown state (when arrowButton is in down state) of the background and border. | PopUpButton
Inherited | popUpGap | Type: Number Format: Length CSS Inheritance: no Number of vertical pixels between the PopUpButton and the specified popup UIComponent. | PopUpButton
Inherited | popUpIcon | Type: Class CSS Inheritance: no The icon used for the right button of PopUpButton. | PopUpButton
Inherited | popUpOverSkin | Type: Class CSS Inheritance: no Skin class for the popUpOver state (over arrowButton) of the background and border. | PopUpButton
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user moves the mouse pointer over the button. | Button
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user presses it. | Button
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dataDescriptor property
dataDescriptor:IMenuDataDescriptor [read-write]

The data descriptor accesses and manipulates data in the data provider.

When you specify this property as an attribute in MXML, you must use a reference to the data descriptor, not the string name of the descriptor. Use the following format for the property:

<mx:PopUpMenuButton id="menubar" dataDescriptor="{new MyCustomDataDescriptor()}"/>

Alternatively, you can specify the property in MXML as a nested subtag, as the following example shows:

<mx:PopUpMenuButton>
   <mx:dataDescriptor>
      <myCustomDataDescriptor>
   </mx:dataDescriptor>
   ...

The default value is an internal instance of the DefaultDataDescriptor class.

Implementation
    public function get dataDescriptor():IMenuDataDescriptor
    public function set dataDescriptor(value:IMenuDataDescriptor):void
dataProvider property
dataProvider:Object [read-write]

DataProvider for popUpMenu.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
labelField property
labelField:String [read-write]

Name of the field in the dataProvider Array that contains the text to show for each menu item. The labelFunction property, if set, overrides this property. If the data provider is an Array of Strings, Flex uses each String value as the label. If the data provider is an E4X XML object, you must set this property explicitly; for example, use @label to specify the label attribute.

The default value is "label".

This property can be used as the source for data binding.

Implementation
    public function get labelField():String
    public function set labelField(value:String):void
labelFunction property
public var labelFunction:Function

A function that determines the text to display for each menu item. If you omit this property, Flex uses the contents of the field or attribute determined by the labelField property. If you specify this property, Flex ignores any labelField property value.

If you specify this property, the label function must find the appropriate field or fields and return a displayable string. The labelFunction property is good for handling formatting and localization.

The label function must take a single argument which is the item in the dataProvider and return a String.

labelFunction(item:Object):String

The default value is null.

popUp property
popUp:IUIComponent [write-only]

A reference to the pop-up Menu object.

This property is read-only, and setting it has no effect. Set the dataProvider property, instead. (The write-only indicator appears in the syntax summary because the property in the superclass is read-write and this class overrides the setter with an empty implementation.)

Implementation
    public function set popUp(value:IUIComponent):void
showRoot property
showRoot:Boolean [read-write]

Specifies whether to display the top-level node or nodes of the data provider. If this is set to false, the control displays only descendants of the first top-level node. Any other top-level nodes are ignored. You normally set this property to false for E4X format XML data providers, where the top-level node is the document object.

The default value is true.

Implementation
    public function get showRoot():Boolean
    public function set showRoot(value:Boolean):void
Constructor detail
PopUpMenuButton () constructor
public function PopUpMenuButton()

Constructor.

Event detail
itemClick event
Event object type: mx.events.MenuEvent
MenuEvent.type property = mx.events.MenuEvent.ITEM_CLICK

Dispatched when a user selects an item from the pop-up menu.

The MenuEvent.ITEM_CLICK event type constant indicates that the user selected a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the selected menu item.
item | The item in the dataProvider that was selected.
itemRenderer | The ListItemRenderer of the selected menu item.
label | The label text of the selected menu item.
menu | The specific Menu instance associated with this event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_CLICK
Examples
PopUpButtonMenuExample
<?xml version="1.0" encoding="utf-8"?>
<!-- PopUpMenuButton control example. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[
            import mx.events.*;
            import mx.controls.*;

            //Event handler, invoked when you select from the menu.
            public function itemClickHandler(event:MenuEvent):void {
                Alert.show("Menu label: " + event.label
                    + "  \n menu item index within parent menu: " + event.index);
            }
        ]]>
    </mx:Script>

    <!-- A an data provider in E4X format. -->
    <mx:XMLList id="treeDP2">
        <node label="Inbox">
            <node label="Personal">
                <node label="Family"/>
                <node label="Friends"/>
            </node>
            <node label="Marketing"/>
            <node label="To Do"/>
        </node>
        <node label="Calendar">
            <node label="Appointments" data="6"/>
            <node label="Meetings"/>
        </node>
        <node label="Deleted Items"/>
    </mx:XMLList>

    <mx:Panel title="PopUpMenuButton Control Example" height="100%" width="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
            text="Click the down arrow to open the menu."/>

        <mx:PopUpMenuButton id="p2"
            dataProvider="{treeDP2}"
            labelField="@label"
            itemClick="itemClickHandler(event);"/>

    </mx:Panel>
</mx:Application>


mx.controls.ProgressBar (Flex™ 2 Language Reference)

Class ProgressBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class ProgressBar
Inheritance | ProgressBar Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The ProgressBar control provides a visual representation of the progress of a task over time. There are two types of ProgressBar controls: determinate and indeterminate.

A determinate ProgressBar control is a linear representation of the progress of a task over time. You use a determinate ProgressBar when the scope of the task is known. It displays when the user has to wait for an extended amount of time.

An indeterminate ProgressBar control represents time-based processes for which the scope is not yet known. As soon as you can determine the scope, you should use a determinate ProgressBar control.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ProgressBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:ProgressBar
    Properties
    conversion="1"
    direction="right|left"
    indeterminate="false|true"
    label="No default"
    labelPlacement="bottom|top|left|right|center"
    maximum="0"
    minimum="0"
    mode="event|polled|manual"
    source="No default"

    Styles
    barColor="undefined"
    barSkin="ProgressBarSkin"
    borderColor="0xAAB3B3"
    color="0x0B333C"
    disabledColor="0xAAB3B3"
    fontAntiAliasType="advanced"
    fontFamily="Verdana"
    fontGridFitType="pixel"
    fontSharpness="0"
    fontSize="10"
    fontThickness="0"
    fontStyle="normal|italic"
    fontWeight="normal|bold"
    horizontalGap="8"
    indeterminateSkin="ProgressIndeterminateSkin"
    labelWidth="Computed"
    leading="0"
    paddingLeft="0"
    paddingRight="0"
    textAlign="left|right|center"
    textDecoration="none|underline"
    textIndent="0"
    themeColor="haloGreen|haloBlue|haloOrange"
    trackColors="[0xE6EEEE,0xE6EEEE]"
    trackHeight="Calculated"
    trackSkin="ProgressTrackSkin"
    verticalGap="6"

    Events
    complete="No default"
    hide="No default"
    progress="No default"
    show="No default"

    Effects
    completeEffect="No default"
  />

View the examples.

See also

mx.controls.ProgressBarDirection
mx.controls.ProgressBarLabelPlacement
mx.controls.ProgressBarMode
ProgressBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | conversion : Number Number used to convert incoming current bytes loaded value and the total bytes loaded values. | ProgressBar
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | direction : String Direction in which the fill of the ProgressBar expands toward completion. | ProgressBar
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
 | indeterminate : Boolean Whether the ProgressBar control has a determinate or indeterminate appearance. | ProgressBar
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | label : String Text that accompanies the progress bar. | ProgressBar
 | labelPlacement : String Placement of the label. | ProgressBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maximum : Number Largest progress value for the ProgressBar. | ProgressBar
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
 | minimum : Number Smallest progress value for the ProgressBar. | ProgressBar
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
 | mode : String Specifies the method used to update the bar. | ProgressBar
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
 | percentComplete : Number [read-only] Percentage of process that is completed.The range is 0 to 100. | ProgressBar
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
 | source : Object Refers to the control that the ProgressBar is measuring the progress of. | ProgressBar
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | value : Number [read-only] Read-only property that contains the amount of progress that has been made - between the minimum and maximum values. | ProgressBar
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ProgressBar()
Constructor.
ProgressBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
setProgress(value:Number, total:Number):void
Sets the state of the bar to reflect the amount of progress made when using manual mode.
ProgressBar
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | complete | Dispatched when the load completes. | ProgressBar
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
 | hide | Dispatched when an object's state changes from visible to invisible. | ProgressBar
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
 | progress | Dispatched as content loads in event or polled mode. | ProgressBar
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | show | Dispatched when the component becomes visible. | ProgressBar
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
barColor
Type: uint Format: Color CSS Inheritance: yes
Determines the color of a ProgressBar. A ProgressBar is filled with a vertical gradient between this color and a brighter color computed from it. This style has no effect on other components, but can be set on a container to control the appearance of all progress bars found within. The default value is undefined, which means it is not set. In this case, the themeColor style property is used. 		ProgressBar
barSkin
Type: Class CSS Inheritance: no
Skin style for a determinate progress bar. The default value is ProgressBarSkin. 		ProgressBar
borderColor
Type: uint Format: Color CSS Inheritance: no
Black section of a three-dimensional border, or the color section of a two-dimensional border. The default value is 0xB7BABC. 		ProgressBar
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		ProgressBar
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		ProgressBar
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		ProgressBar
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		ProgressBar
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		ProgressBar
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ProgressBar
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		ProgressBar
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		ProgressBar
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ProgressBar
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		ProgressBar
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
horizontalGap
Type: Number Format: Length CSS Inheritance: no
Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. 		ProgressBar
indeterminateSkin
Type: Class CSS Inheritance: no
Skin style for an indeterminate progress bar. The default value is ProgressIndeterminateSkin. 		ProgressBar
labelWidth
Type: Number Format: Length CSS Inheritance: yes
The width of the label in pixels. If the value is NaN, the ProgressBar control sets it to the width of the control. The default value is NaN. 		ProgressBar
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

ProgressBar
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

ProgressBar
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

ProgressBar
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

ProgressBar
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		ProgressBar
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		ProgressBar
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of the ProgressBar control. Possible values are haloGreen, haloBlue, and haloOrange. Adobe recommends setting the themeColor style in the <mx:Application> tag, instead of in individual controls. The default value is "haloBlue". 		ProgressBar
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
trackColors
Type: Array Format: Color CSS Inheritance: no
The colors of the track, as an array of two colors. You can use the same color twice for a solid track color. The default value is [ 0xE6EEEE, 0xE6EEEE ]. 		ProgressBar
trackHeight
Type: Number Format: Length CSS Inheritance: no
The height of the track in pixels. If the value is NaN, then use the height of the skin specified by the trackSkin property. The default value is NaN. 		ProgressBar
trackSkin
Type: Class CSS Inheritance: no
Skin style for the progress indicator track. The default value is ProgressTrackSkin. 		ProgressBar
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
verticalGap
Type: Number Format: Length CSS Inheritance: no
Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. 		ProgressBar
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
 | completeEffect | Triggering event: complete Effect called when Flex dispatches the complete event, which occurs when the load completes. | ProgressBar
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
conversion property
conversion:Number [read-write]

Number used to convert incoming current bytes loaded value and the total bytes loaded values. Flex divides the current and total values by this property and uses the closest integer that is less than or equal to each value in the label string. A value of 1 does no conversion.

The default value is 1.

This property can be used as the source for data binding.

Implementation
    public function get conversion():Number
    public function set conversion(value:Number):void
direction property
direction:String [read-write]

Direction in which the fill of the ProgressBar expands toward completion. Valid values in MXML are "right" and "left".

In ActionScript, you use use the following constants to set this property: ProgressBarDirection.RIGHT and ProgressBarDirection.LEFT.

The default value is ProgressBarDirection.RIGHT.

This property can be used as the source for data binding.

Implementation
    public function get direction():String
    public function set direction(value:String):void

See also

mx.controls.ProgressBarDirection
indeterminate property
indeterminate:Boolean [read-write]

Whether the ProgressBar control has a determinate or indeterminate appearance. Use an inteterminate appearance when the progress status cannot be determined. If true, the appearance is indeterminate.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get indeterminate():Boolean
    public function set indeterminate(value:Boolean):void
label property
label:String [read-write]

Text that accompanies the progress bar. You can include the following special characters in the text string:

  • %1 = current loaded bytes
  • %2 = total bytes
  • %3 = percent loaded
  • %% = "%" character

If a field is unknown, it is replaced by "??". If undefined, the label is not displayed.

The default value is "LOADING %3%%".

This property can be used as the source for data binding.

Implementation
    public function get label():String
    public function set label(value:String):void
labelPlacement property
labelPlacement:String [read-write]

Placement of the label. Valid values in MXML are "right", "left", "bottom", "center", and "top".

In ActionScript, you can use use the following constants to set this property: ProgressBarLabelPlacement.RIGHT, ProgressBarLabelPlacement.LEFT, ProgressBarLabelPlacement.BOTTOM, ProgressBarLabelPlacement.CENTER, and ProgressBarLabelPlacement.TOP.

The default value is ProgressBarLabelPlacement.BOTTOM.

This property can be used as the source for data binding.

Implementation
    public function get labelPlacement():String
    public function set labelPlacement(value:String):void

See also

mx.controls.ProgressBarLabelPlacement
maximum property
maximum:Number [read-write]

Largest progress value for the ProgressBar. You can only use this property in manual mode.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get maximum():Number
    public function set maximum(value:Number):void
minimum property
minimum:Number [read-write]

Smallest progress value for the ProgressBar. This property is set by the developer only in manual mode.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get minimum():Number
    public function set minimum(value:Number):void
mode property
mode:String [read-write]

Specifies the method used to update the bar. Use one of the following values in MXML:

  • event The control specified by the source property must dispatch progress and completed events. The ProgressBar uses these events to update its status.
  • polled The source property must specify an object that exposes getBytesLoaded() and getBytesTotal() methods. The ProgressBar control calls these methods to update its status.
  • manual You manually update the ProgressBar status. In this mode you specify the maximum and minimum properties and use the setProgress() property method to specify the status. This mode is often used when the indeterminate property is true.

In ActionScript, you can use use the following constants to set this property: ProgressBarMode.EVENT, ProgressBarMode.POLLED, and ProgressBarMode.MANUAL.

The default value is ProgressBarMode.EVENT.

This property can be used as the source for data binding.

Implementation
    public function get mode():String
    public function set mode(value:String):void

See also

mx.controls.ProgressBarMode
percentComplete property
percentComplete:Number [read-only]

Percentage of process that is completed.The range is 0 to 100. Use the setProgress() method to change the percentage.

This property can be used as the source for data binding.

Implementation
    public function get percentComplete():Number
source property
source:Object [read-write]

Refers to the control that the ProgressBar is measuring the progress of. Use this property only in event and polled mode. A typical usage is to set this property to a Loader control.

This property can be used as the source for data binding.

Implementation
    public function get source():Object
    public function set source(value:Object):void
value property
value:Number [read-only]

Read-only property that contains the amount of progress that has been made - between the minimum and maximum values.

This property can be used as the source for data binding.

Implementation
    public function get value():Number
Constructor detail
ProgressBar () constructor
public function ProgressBar()

Constructor.

Method detail
setProgress () method
public function setProgress(value:Number, total:Number):void

Sets the state of the bar to reflect the amount of progress made when using manual mode. The value argument is assigned to the value property and the maximum argument is assigned to the maximum property. The minimum property is not altered.

Parameters
value:Number — Current value.
total:Number — Total or target value.
Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched when the load completes.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
hide event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.HIDE

Dispatched when an object's state changes from visible to invisible.

The FlexEvent.HIDE constant defines the value of the type property of the event object for a hide event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched as content loads in event or polled mode.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.
show event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.SHOW

Dispatched when the component becomes visible.

The FlexEvent.SHOW constant defines the value of the type property of the event object for a show event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
SimpleProgressBar
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ProgressBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

          private var j:uint=10;

          // Event handler function to set the value of the
          // ProgressBar control.
          private function runit():void
          {
              if(j<=100)
              {
                 bar.setProgress(j,100);
                 bar.label= "CurrentProgress" + " " + j + "%";
                 j+=10;
              }
              if(j>100)
              {
                 j=0;
              }
          }
        ]]>
    </mx:Script>

    <mx:Panel title="ProgressBar Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
            text="Click the button to increment the progress bar." />
        <mx:Button id="Speed" label="Run" click="runit();"/>

        <mx:ProgressBar id="bar" labelPlacement="bottom" themeColor="#F20D7A"
            minimum="0" visible="true" maximum="100" label="CurrentProgress 0%"
            direction="right" mode="manual" width="100%"/>

    </mx:Panel>
</mx:Application>


mx.controls.ProgressBarDirection (Flex™ 2 Language Reference)

Class ProgressBarDirection | Properties | Methods | Constants
Package | mx.controls
Class | public final class ProgressBarDirection
Inheritance | ProgressBarDirection Inheritance Object

The ProgressBarDirection class defines the values for the direction property of the ProgressBar class.

See also

mx.controls.ProgressBar
ProgressBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | LEFT : String = "left" [static] Specifies to fill the progress bar from the right to the left. | ProgressBarDirection
 | RIGHT : String = "right" [static] Specifies to fill the progress bar from the left to the right. | ProgressBarDirection
Constant detail
LEFT constant
public static const LEFT:String = "left"

Specifies to fill the progress bar from the right to the left.

RIGHT constant
public static const RIGHT:String = "right"

Specifies to fill the progress bar from the left to the right.


mx.controls.ProgressBarLabelPlacement (Flex™ 2 Language Reference)

Class ProgressBarLabelPlacement | Properties | Methods | Constants
Package | mx.controls
Class | public final class ProgressBarLabelPlacement
Inheritance | ProgressBarLabelPlacement Inheritance Object

The ProgressBarLabelPlacement class defines the values for the labelPlacement property of the ProgressBar class.

See also

mx.controls.ProgressBar
ProgressBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BOTTOM : String = "bottom" [static] Specifies to place the label below the progress bar. | ProgressBarLabelPlacement
 | CENTER : String = "center" [static] Specifies to place at the center inside the progress bar. | ProgressBarLabelPlacement
 | LEFT : String = "left" [static] Specifies to place the label to the left of the progress bar. | ProgressBarLabelPlacement
 | RIGHT : String = "right" [static] Specifies to place the label to the right of the progress bar. | ProgressBarLabelPlacement
 | TOP : String = "top" [static] Specifies to place the label above the progress bar. | ProgressBarLabelPlacement
Constant detail
BOTTOM constant
public static const BOTTOM:String = "bottom"

Specifies to place the label below the progress bar.

CENTER constant
public static const CENTER:String = "center"

Specifies to place at the center inside the progress bar.

LEFT constant
public static const LEFT:String = "left"

Specifies to place the label to the left of the progress bar.

RIGHT constant
public static const RIGHT:String = "right"

Specifies to place the label to the right of the progress bar.

TOP constant
public static const TOP:String = "top"

Specifies to place the label above the progress bar.


mx.controls.ProgressBarMode (Flex™ 2 Language Reference)

Class ProgressBarMode | Properties | Methods | Constants
Package | mx.controls
Class | public final class ProgressBarMode
Inheritance | ProgressBarMode Inheritance Object

The ProgressBarMode class defines the values for the mode property of the ProgressBar class.

See also

mx.controls.ProgressBar
ProgressBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | EVENT : String = "event" [static] The control specified by the source property must dispatch progress and completed events. | ProgressBarMode
 | MANUAL : String = "manual" [static] You manually update the ProgressBar status. | ProgressBarMode
 | POLLED : String = "polled" [static] The source property must specify an object that exposes the getBytesLoaded() and getBytesTotal() methods. | ProgressBarMode
Constant detail
EVENT constant
public static const EVENT:String = "event"

The control specified by the source property must dispatch progress and completed events. The ProgressBar uses these events to update its status.

MANUAL constant
public static const MANUAL:String = "manual"

You manually update the ProgressBar status. In this mode, you specify the maximum and minimum properties and use the setProgress() method to specify the status. This mode is often used when the indeterminate property is true.

POLLED constant
public static const POLLED:String = "polled"

The source property must specify an object that exposes the getBytesLoaded() and getBytesTotal() methods. The ProgressBar control calls these methods to update its status.


mx.controls.RadioButton (Flex™ 2 Language Reference)

Class RadioButton | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class RadioButton
Inheritance | RadioButton Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFocusManagerGroup

The RadioButton control lets the user make a single choice within a set of mutually exclusive choices. A RadioButton group is composed of two or more RadioButton controls with the same groupName property. The RadioButton group can refer to a group created by the <mx:RadioButtonGroup> tag. The user selects only one member of the group at a time. Selecting an unselected group member deselects the currently selected RadioButton control within that group.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:RadioButton> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:RadioButton
    Properties
    groupName=""
    labelPlacement="right|left|top|bottom"
  />

View the examples.

See also

mx.controls.RadioButtonGroup
RadioButton control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | group : RadioButtonGroup The RadioButtonGroup object to which this RadioButton belongs. | RadioButton
 | groupName : String Specifies the name of the group to which this RadioButton control belongs, or specifies the value of the id property of a RadioButtonGroup control if this RadioButton is part of a group defined by a RadioButtonGroup control. | RadioButton
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
 | labelPlacement : String Position of the label relative to the RadioButton icon. | RadioButton
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | value : Object Optional user-defined value that is associated with a RadioButton control. | RadioButton
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RadioButton()
Constructor.
RadioButton
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Button
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Button
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | Button
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | Button
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | selectedDisabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and disabled. | Button
Inherited | selectedDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and disabled. | Button
Inherited | selectedDownIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is down. | Button
Inherited | selectedDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down. | Button
Inherited | selectedOverIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse is over the control. | Button
Inherited | selectedOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control. | Button
Inherited | selectedUpIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is up. | Button
Inherited | selectedUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control. | Button
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user moves the mouse pointer over the button. | Button
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user presses it. | Button
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
group property
group:RadioButtonGroup [read-write]

The RadioButtonGroup object to which this RadioButton belongs.

The default value is "undefined".

Implementation
    public function get group():RadioButtonGroup
    public function set group(value:RadioButtonGroup):void
groupName property
groupName:String [read-write]

Specifies the name of the group to which this RadioButton control belongs, or specifies the value of the id property of a RadioButtonGroup control if this RadioButton is part of a group defined by a RadioButtonGroup control.

The default value is "undefined".

This property can be used as the source for data binding.

Implementation
    public function get groupName():String
    public function set groupName(value:String):void
labelPlacement property
labelPlacement:String [read-write]

Position of the label relative to the RadioButton icon. Valid values in MXML are "right", "left", "bottom", and "top".

In ActionScript, you use the following constants to set this property: ButtonLabelPlacement.RIGHT, ButtonLabelPlacement.LEFT, ButtonLabelPlacement.BOTTOM, and ButtonLabelPlacement.TOP.

The default value is ButtonLabelPlacement.RIGHT.

This property can be used as the source for data binding.

Implementation
    public function get labelPlacement():String
    public function set labelPlacement(value:String):void
value property
value:Object [read-write]

Optional user-defined value that is associated with a RadioButton control.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get value():Object
    public function set value(value:Object):void
Constructor detail
RadioButton () constructor
public function RadioButton()

Constructor.

Examples
RadioButtonExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate RadioButton control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:Panel title="RadioButton Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10">

       <mx:Label width="100%" color="blue"
           text="What year were women first allowed to compete in the Boston Marathon?"/>

        <mx:RadioButton groupName="year" id="option1" label="1942"/>
        <mx:RadioButton groupName="year" id="option2" label="1952"/>
        <mx:RadioButton groupName="year" id="option3" label="1962"/>
        <mx:RadioButton groupName="year" id="option4" label="1972"/>

        <mx:Button label="Check Answer"
            click="Alert.show(option4.selected?'Correct Answer!':'Wrong Answer', 'Result')"/>

    </mx:Panel>
</mx:Application>


href="../../Object.html">Object, id:String):void
Implementation of the IMXMLObject.initialized() method to support deferred instantiation.
RadioButtonGroup Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object Inherited
toString():String
Returns the string representation of the specified object.
Object Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | change | Dispatched when the value of the selected RadioButton control in this group changes. | RadioButtonGroup
 | itemClick | Dispatched when a user selects a RadioButton control in the group. | RadioButtonGroup
Property detail
enabled property
enabled:Boolean [read-write]

Determines whether selection is allowed.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void
labelPlacement property
labelPlacement:String [read-write]

Position of the RadioButton label relative to the RadioButton icon for each control in the group. You can override this setting for the individual controls.

Valid values in MXML are "right", "left", "bottom", and "top".

In ActionScript, you use the following constants to set this property: ButtonLabelPlacement.RIGHT, ButtonLabelPlacement.LEFT, ButtonLabelPlacement.BOTTOM, and ButtonLabelPlacement.TOP.

The default value is "right".

This property can be used as the source for data binding.

Implementation
    public function get labelPlacement():String
    public function set labelPlacement(value:String):void
numRadioButtons property
numRadioButtons:int [read-only]

The number of RadioButtons that belong to this RadioButtonGroup.

The default value is "undefined".

Implementation
    public function get numRadioButtons():int
selectedValue property
selectedValue:Object [read-write]

The value of the value property of the selected RadioButton control in the group, if this has been set to be something other than null (the default value). Otherwise, selectedValue is the value of the label property of the selected RadioButton. If no RadioButton is selected, this property is null.

If you set selectedValue, Flex selects the RadioButton control whose value or label property matches this value.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get selectedValue():Object
    public function set selectedValue(value:Object):void
selection property
selection:RadioButton [read-write]

Contains a reference to the currently selected RadioButton control in the group. You can access the property in ActionScript only; it is not settable in MXML.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get selection():RadioButton
    public function set selection(value:RadioButton):void
Constructor detail
RadioButtonGroup () constructor
public function RadioButtonGroup(document:IFlexDisplayObject = null)

Constructor.

Parameters
document:IFlexDisplayObject (default = null) — In simple cases where a class extends EventDispatcher, the document parameter should not be used.

See also

flash.events.EventDispatcher
Method detail
getRadioButtonAt () method
public function getRadioButtonAt(index:int):RadioButton

Returns the RadioButton control at the specified index.

Parameters
index:int — The index of the RadioButton control in the RadioButtonGroup control, where the index of the first control is 0.

Returns
RadioButton — The specified RadioButton control.
initialized () method
public function initialized(document:Object, id:String):void

Implementation of the IMXMLObject.initialized() method to support deferred instantiation.

Parameters
document:Object — The MXML document that created this object.
id:String — The identifier used by document to refer to this object. If the object is a deep property on document, id is null.

See also

mx.core.IMXMLObject
Event detail
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched when the value of the selected RadioButton control in this group changes.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
itemClick event
Event object type: mx.events.ItemClickEvent
ItemClickEvent.type property = mx.events.ItemClickEvent.ITEM_CLICK

Dispatched when a user selects a RadioButton control in the group. You can also set a handler for individual RadioButton controls.

The ItemClickEvent.ITEM_CLICK constant defines the value of the type property of the event object for an itemClick event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index of the navigation item that was clicked.
item | The item in the data provider of the navigation item that was clicked.
label | The label of the navigation item that was clicked.
relatedObject | The child object that generated the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
RadioButtonGroupExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate RadioButtonGroup control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

        import mx.controls.Alert;
        import  mx.events.ItemClickEvent;

        // Event handler function to display the selected button
        // in an Alert control.
        private function handleCard(event:ItemClickEvent):void {
            if (event.currentTarget.selectedValue == "AmEx") {
                    Alert.show("You selected American Express")
            }
            else {
                if (event.currentTarget.selectedValue == "MC") {
                    Alert.show("You selected MasterCard")
                }
                else {
                    Alert.show("You selected Visa")
                }
            }
        }
        ]]>
    </mx:Script>

    <mx:Panel title="RadioButtonGroup Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10">

        <mx:Label width="100%" color="blue"
            text="Select a type of credit card."/>

        <mx:RadioButtonGroup id="cardtype" itemClick="handleCard(event);"/>
        <mx:RadioButton groupName="cardtype" id="americanExpress" value="AmEx"
            label="American Express" width="150" />
        <mx:RadioButton groupName="cardtype" id="masterCard" value="MC"
            label="MasterCard" width="150" />
        <mx:RadioButton groupName="cardtype" id="visa" value="Visa"
            label="Visa" width="150" />

    </mx:Panel>
</mx:Application>


mx.controls.RichTextEditor (Flex™ 2 Language Reference)

Class RichTextEditor | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class RichTextEditor
Inheritance | RichTextEditor Inheritance Panel Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The RichTextEditor control lets users enter and format text. The text characteristics that users can vary include the font family, color, size, and style, and other properties such as text alignment, bullets and URL links. The control consists of a Panel control with two direct children:
  • A Text Area control where users can enter text.
  • A Container with format controls that let a user specify the text characteristics. The format controls affect text being typed or selected text.

The RichTextEditor has a default height and width of 300 by 325 pixels and a default minimum height and width of 200 by 220 pixels. If you put a RichTextEditor control in a DividedBox control, make sure that the DividedBox control is large enough to contain the RichTextEditor control at its minimum dimensions. Also, you can explicitly set the RichTextEditor control's minHeight or minWidth property to NaN to let the DividedBox container reduce the control's dimensions to 0.

The following table describes the subcontrols that you can access and modify:

Control Type | ID | Description
TextArea | textArea | Area where the user can enter text.
container | toolbar | Contains the formatting controls; puts the controls in a single horizontal row, if they fit, or multiple rows, otherwise.
ComboBox fontFamilyCombo Specifies the text font family. The ComboBox dataProvider is an Array of Strings with the following values:
  • _sans
  • _serif
  • _typewriter
  • Arial
  • Courier
  • Courier New
  • Geneva
  • Georgia
  • Helvetica
  • Times New Roman
  • Times
  • Verdana (default)
ComboBox | fontSizeCombo | Specifies the font size. The ComboBox dataProvider is an Array of Strings with the following values: 8, 9, 10 (default), 11, 12, 14, 16, 18, 20, 24, 26, 28, 36, 48, 72.
HBox | toolbar2 | Contains the font characteristic buttons.
Button | boldButton | When toggled to selected="true", sets the font to bold.
Button | italicButton | When toggled to selected="true", sets the font to italic.
Button | underlineButton | When toggled to selected="true", sets the font to underlined.
ColorPicker | colorPicker | Specifies the color of the text.
ToggleButtonBar alignButtons Specifies the text alignment. The control's data provider consists of an Array Of objects, with the object action field specifying the justification type. The available actions are as follows:
  • left (default)
  • center
  • right
  • justify
Button | bulletButton | When toggled to selected="true", sets the current line, or the selected line, to a list item, preceded by a bullet.
TextInput linkTextInput This field is enabled only when text is selected. When the user enters a URL in this field and presses the Enter key, Flex inserts the equivalent of an HTML <a href="user_text" target="blank"></a> tag in the TextArea subcontrol at around the currently selected text.

Flex initially fills this control with the text specified by the defaultLinProtocol property; users can append the rest of the link to this text, or replace it.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:RichTextEditor> tag inherits all the members of its parent and adds the following members:

   <RichTextEditor
     Properties
     defaultLinkProtocol="http://"
     htmlText=""
     showControlBar="true | false"
     showToolTips="false | true"
     text=""

     Events
     change
   />

View the examples.

See also

mx.containers.ControlBar
mx.containers.Panel
mx.controls.ToggleButtonBar
mx.controls.Button
mx.controls.ColorPicker
mx.controls.ComboBox
mx.controls.TextArea
mx.controls.TextInput
Using Text Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
 | defaultLinkProtocol : String The default protocol string to use at the start of link text. | RichTextEditor
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
 | htmlText : String Text containing HTML markup that displays in the RichTextEditor control's TextArea subcontrol. | RichTextEditor
Inherited | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | layout : String Specifies the layout mechanism used for this container. | Panel
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selection : TextRange [read-only] A TextRange object containing the selected text in the TextArea subcontrol. | RichTextEditor
 | showControlBar : Boolean Specifies whether to display the control bar that contains the text formatting controls. | RichTextEditor
 | showToolTips : Boolean Specifies whether to display tooltips for the text formatting controls. | RichTextEditor
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | status : String Text in the status area of the title bar. | Panel
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String Plain text without markup that displays in the RichTextEditor control's TextArea subcontrol. | RichTextEditor
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | title : String Title or caption displayed in the title bar. | Panel
Inherited | titleIcon : Class The icon displayed in the title bar. | Panel
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | controlBar : IUIComponent A reference to this Panel container's control bar, if any. | Panel
Inherited | statusTextField : UITextField The UITextField sub-control that displays the status. | Panel
Inherited | titleBar : UIComponent The TitleBar sub-control that displays the Panel container's title bar. | Panel
Inherited | titleTextField : UITextField The UITextField sub-control that displays the title. | Panel
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default mininum and maximum sizes of the Panel container. | Panel
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | startDragging(event:MouseEvent):void Called when the user starts dragging a Panel that has been popped up by the PopUpManager. | Panel
Inherited | stopDragging():void Called when the user stops dragging a Panel that has been popped up by the PopUpManager. | Panel
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's children. | Container
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the user changes the contents or format of the text in the TextArea control. | RichTextEditor
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | close | Dispatched when the user selects the close button. | Panel
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderAlpha | Type: Number CSS Inheritance: no Alpha of the title bar, control bar and sides of the Panel. | Panel
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | borderThicknessBottom | Type: Number Format: Length CSS Inheritance: no Thickness of the bottom border of the Panel control. | Panel
Inherited | borderThicknessLeft | Type: Number Format: Length CSS Inheritance: no Thickness of the left border of the Panel. | Panel
Inherited | borderThicknessRight | Type: Number Format: Length CSS Inheritance: no Thickness of the right border of the Panel. | Panel
Inherited | borderThicknessTop | Type: Number Format: Length CSS Inheritance: no Thickness of the top border of the Panel. | Panel
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | closeButtonDisabledSkin | Type: Class CSS Inheritance: no The close button disabled skin. | Panel
Inherited | closeButtonDownSkin | Type: Class CSS Inheritance: no The close button down skin. | Panel
Inherited | closeButtonOverSkin | Type: Class CSS Inheritance: no The close button over skin. | Panel
Inherited | closeButtonUpSkin | Type: Class CSS Inheritance: no The close button up skin. | Panel
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | controlBarStyleName | Type: String CSS Inheritance: no Name of the CSS style declaration that specifies styles to apply to any control bar child subcontrol. | Panel
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of corners of the window frame. | Panel
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that controls the visibility of the Panel container's drop shadow. | Panel
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | footerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the footer (area for the ControlBar container) background. | Panel
Inherited | headerColors | Type: Array Format: Color CSS Inheritance: yes Array of two colors used to draw the header. | Panel
Inherited | headerHeight | Type: Number Format: Length CSS Inheritance: no Height of the header. | Panel
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alphas used for the highlight fill of the header. | Panel
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. | Panel
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | Panel
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | modalTransparency | Type: Number CSS Inheritance: yes Modality of components launched by the PopUp Manager is simulated by creating a large translucent overlay underneath the component. | Panel
Inherited | modalTransparencyBlur | Type: Number CSS Inheritance: yes The blur applied to the application while a modal window is open. | Panel
Inherited | modalTransparencyColor | Type: uint Format: Color CSS Inheritance: yes Color of the modal overlay layer. | Panel
Inherited | modalTransparencyDuration | Type: Number Format: Time CSS Inheritance: yes Duration, in milliseconds, of the modal transparency effect that plays when a modal window opens or closes. | Panel
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's lower border and its content area. | Panel
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and its content area. | Panel
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | roundedBottomCorners | Type: Boolean CSS Inheritance: no Flag to enable rounding for the bottom two corners of the container. | Panel
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of drop shadow. | Panel
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of drop shadow. | Panel
Inherited | statusStyleName | Type: String CSS Inheritance: no Style declaration name for the status in the title bar. | Panel
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
 | textAreaStyleName | Type: String CSS Inheritance: no Name of the CSS Style declaration to use for the styles for the TextArea. By default, the TextArea uses the the RichTextEditor's inheritable styles. | RichTextEditor
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | titleBackgroundSkin | Type: Class CSS Inheritance: no The title background skin. | Panel
Inherited | titleStyleName | Type: String CSS Inheritance: no Style declaration name for the text in the title bar. | Panel
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. | Panel
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | Panel
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | resizeEndEffect | Triggering event: resizeEnd Specifies the effect to play after a Resize effect finishes playing. | Panel
Inherited | resizeStartEffect | Triggering event: resizeStart Specifies the effect to play before a Resize effect begins playing. | Panel
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
defaultLinkProtocol property
public var defaultLinkProtocol:String

The default protocol string to use at the start of link text. This string appears in the LinkTextInput subcontrol, so users do not have to type the protocol identifier when entering link text.

The default value is "http://".

htmlText property
public var htmlText:String

Text containing HTML markup that displays in the RichTextEditor control's TextArea subcontrol. You cannot set this property and the text property simultaneously. If you set one property, it replaces any value set using the other property. You can get both properties; the htmlText property always returns a String containing HTML markup that represents the current text formatting. For more information on using this property, see the TextArea documentation.

The default value is "".

See also

mx.controls.TextArea
selection property
selection:TextRange [read-only]

A TextRange object containing the selected text in the TextArea subcontrol.

Implementation
    public function get selection():TextRange

See also

mx.controls.textClasses.TextRange
showControlBar property
public var showControlBar:Boolean

Specifies whether to display the control bar that contains the text formatting controls.

The default value is true.

showToolTips property
public var showToolTips:Boolean

Specifies whether to display tooltips for the text formatting controls.

The default value is false.

text property
public var text:String

Plain text without markup that displays in the RichTextEditor control's TextArea subcontrol. You cannot set this property and the htmlText property simultaneously. If you set one property, it replaces any value set using the other property. You can get both properties; the text property always returns a plain text String with no formatting information. For more information on using this property, see the TextArea documentation.

The default value is "".

See also

mx.controls.TextArea
Event detail
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched when the user changes the contents or format of the text in the TextArea control. This event is not dispatched if you change the TextArea contents by resetting the text or htmlText property.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
Examples
RichTextEditorExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the RichTextEditor control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
    horizontalAlign="center" verticalAlign="middle">

    <mx:RichTextEditor id="rte" title="RichTextEditor" height="75%" text="Enter text into the RichTextEditor control, then click a button to display your text as plain text, or as HTML-formatted text."/>

    <mx:TextArea id="rteText" width="80%" height="25%"/>

    <mx:HBox>
        <mx:Button label="Show Plain Text" click="rteText.text=rte.text;"/>
        <mx:Button label="Show HTML Markup" click="rteText.text=rte.htmlText;"/>
    </mx:HBox>

</mx:Application>


mx.controls.Spacer (Flex™ 2 Language Reference)

Class Spacer | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Spacer
Inheritance | Spacer Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Spacer control helps you lay out children within a parent container. Although the Spacer control does not draw anything, it does allocate space for itself within its parent container.

In the following example, a flexible Spacer control is used to push the Button control to the right, so that the Button control is aligned with the right edge of the HBox container:

  <mx:HBox>
   <mx:Image source="Logo.jpg"/>
   <mx:Label text="Company XYZ"/>
   <mx:Spacer width="100%"/>
   <mx:Button label="Close"/>
  </mx:HBox>

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Spacer> tag inherits all of the tag attributes of its superclass, and adds no new tag attributes.

  <mx:Spacer/>

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Spacer()
Constructor
Spacer
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
Spacer () constructor
public function Spacer()

Constructor

Examples
SpacerExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Spacer control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel id="panel" title="Spacer Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Text width="100%" color="blue"
            text="The Spacer control pushes the second image to the right edge of the HBox container."/>

        <mx:HBox width="100%">
            <mx:Image source="@Embed('assets/Nokia_6630.png')"/>
            <mx:Spacer width="100%"/>
            <mx:Image source="@Embed('assets/Nokia_6680.png')"/>
        </mx:HBox>

    </mx:Panel>
</mx:Application>


mx.controls.SWFLoader (Flex™ 2 Language Reference)

Class SWFLoader | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class SWFLoader
Inheritance | SWFLoader Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | Image

The SWFLoader control loads and displays a specified SWF file. You typically use SWFLoader for loading a Flex 2 application into a host Flex 2 application.

Note: You can also use the SWFLoader control to load a GIF, JPEG, or PNG image file at runtime, or embed any of these files and SVG files at compile time by using @Embed(source='filename'). However, the Image control is better suited for this capability and should be used for most image loading. The Image control is also designed to be used in custom item renderers and item editors. When using either SWFLoader or Image with an SVG file, you can only load the SVG if it has been embedded in your application using an Embed statement; you cannot load an SVG from the network at runtime.

The SWFLoader control lets you scale its content and set its size. It can also resize itself to fit the size of its content. By default, content is scaled to fit the size of the SWFLoader control. It can also load content on demand programmatically, and monitor the progress of a load.

A SWFLoader control cannot receive focus. However, the contents of a SWFLoader control can accept focus and have its own focus interactions.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SWFLoader> tag inherits all of the tag attributes of its superclass and adds the following tag attributes:

  <mx:SWFLoader
    Properties
    autoLoad="true|false"
    loaderContext="null"
    maintainAspectRatio="true|false"
    scaleContent="true|false"
    showBusyCursor="false|true"
    source="No default"
    trustContent="false|true"

    Styles
    brokenImageBorderSkin="BrokenImageBorderSkin"
    brokenImageSkin="BrokenImageSkin"
    horizontalAlign="left|center|right"
    verticalAlign="top|middle|bottom"

    Effects
    completeEffect="No default"

    Events
    complete="No default"
    httpStatus="No default"
    init="No default"
    ioError="No default"
    open="No default"
    progress="No default"
    securityError="No default"
    unload="No default"
  />

View the examples.

See also

mx.controls.Image
SWFLoader control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | autoLoad : Boolean If true, the content loads automatically. | SWFLoader
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
 | bytesLoaded : Number [read-only] Number of bytes of the SWF or image file already loaded. | SWFLoader
 | bytesTotal : Number [read-only] Total size of the SWF or image file. | SWFLoader
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | content : DisplayObject [read-only] This property contains the object that represents the content that was loaded in the SWFLoader control. | SWFLoader
 | contentHeight : Number [read-only] Height of the scaled content loaded by the control, in pixels. | SWFLoader
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
 | contentWidth : Number [read-only] Width of the scaled content loaded by the control, in pixels. | SWFLoader
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | loaderContext : LoaderContext A LoaderContext object to use to load the content. | SWFLoader
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
 | maintainAspectRatio : Boolean If true, specifies to display the image with the same ratio of height to width as the original image. | SWFLoader
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
 | percentLoaded : Number [read-only] Percentage of the image or SWF file already loaded. | SWFLoader
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
 | scaleContent : Boolean If true, the content scales to fit the SWFLoader control. | SWFLoader
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | showBusyCursor : Boolean If true, shows a busy cursor while the content loads. | SWFLoader
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
 | source : Object Specifies the content to load. | SWFLoader
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
 | trustContent : Boolean If true, the content is loaded into your security domain. | SWFLoader
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SWFLoader()
Constructor.
SWFLoader
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
load(url:Object = null):void
Loads an image or SWF file.
SWFLoader
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | complete | Dispatched when content loading is complete. | SWFLoader
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
 | httpStatus | Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code. | SWFLoader
 | init | Dispatched when the properties and methods of a loaded SWF file are accessible. | SWFLoader
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | ioError | Dispatched when an input/output error occurs. | SWFLoader
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
 | open | Dispatched when a network operation starts. | SWFLoader
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
 | progress | Dispatched when content is loading. | SWFLoader
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | securityError | Dispatched when a security error occurs while content is loading. | SWFLoader
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
 | unload | Dispatched when a loaded object is removed, or when a second load is performed by the same SWFLoader control and the original content is removed prior to the new load beginning. | SWFLoader
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | brokenImageBorderSkin | Type: Class CSS Inheritance: no Name of class to use as the SWFLoader border skin if the control cannot load the content. The default value is BrokenImageBorderSkin. | SWFLoader
 | brokenImageSkin | Type: Class CSS Inheritance: no Name of the class to use as the SWFLoader skin if the control cannot load the content. The default value is BrokenImageSkin. | SWFLoader
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of the content when it does not have a one-to-one aspect ratio. Possible values are "left", "center", and "right". The default value is "left". | SWFLoader
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of the content when it does not have a one-to-one aspect ratio. Possible values are "top", "middle", and "bottom". The default value is "top". | SWFLoader
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
 | completeEffect | Triggering event: complete Effect called when the complete event is dispatched. | SWFLoader
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
autoLoad property
autoLoad:Boolean [read-write]

If true, the content loads automatically. If false, you must call the load() method.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get autoLoad():Boolean
    public function set autoLoad(value:Boolean):void
bytesLoaded property
bytesLoaded:Number [read-only]

Number of bytes of the SWF or image file already loaded.

This property can be used as the source for data binding.

Implementation
    public function get bytesLoaded():Number
bytesTotal property
bytesTotal:Number [read-only]

Total size of the SWF or image file.

This property can be used as the source for data binding.

Implementation
    public function get bytesTotal():Number
content property
content:DisplayObject [read-only]

This property contains the object that represents the content that was loaded in the SWFLoader control.

Implementation
    public function get content():DisplayObject
contentHeight property
contentHeight:Number [read-only]

Height of the scaled content loaded by the control, in pixels. Note that this is not the height of the control itself, but of the loaded content. Use the height property of the control to obtain its height.

The value of this property is not final when the complete event is triggered. You can get the value after the updateComplete event is triggered.

The default value is NaN.

Implementation
    public function get contentHeight():Number
contentWidth property
contentWidth:Number [read-only]

Width of the scaled content loaded by the control, in pixels. Note that this is not the width of the control itself, but of the loaded content. Use the width property of the control to obtain its width.

The value of this property is not final when the complete event is triggered. You can get the value after the updateComplete event is triggered.

The default value is NaN.

Implementation
    public function get contentWidth():Number
loaderContext property
loaderContext:LoaderContext [read-write]

A LoaderContext object to use to load the content. This is an advanced property. Most of the time you can use the trustContent property.

The default value is null, which causes the control to use the trustContent property to create a LoaderContext object, which you can read back after the load starts.

To use a custom LoaderContext object, you must understand the SecurityDomain and ApplicationDomain classes. Setting this property will not start a load; you must set this before the load starts. This does not mean that you have to set autoLoad property to false, because the load does not actually start immediately, but waiting for the creationComplete event to set it is too late.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get loaderContext():LoaderContext
    public function set loaderContext(value:LoaderContext):void

See also

flash.system.LoaderContext
flash.system.ApplicationDomain
flash.system.SecurityDomain
maintainAspectRatio property
maintainAspectRatio:Boolean [read-write]

If true, specifies to display the image with the same ratio of height to width as the original image.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get maintainAspectRatio():Boolean
    public function set maintainAspectRatio(value:Boolean):void
percentLoaded property
percentLoaded:Number [read-only]

Percentage of the image or SWF file already loaded.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get percentLoaded():Number
scaleContent property
scaleContent:Boolean [read-write]

If true, the content scales to fit the SWFLoader control. If false, the SWFLoader scales to fit the content.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get scaleContent():Boolean
    public function set scaleContent(value:Boolean):void
showBusyCursor property
showBusyCursor:Boolean [read-write]

If true, shows a busy cursor while the content loads. The default busy cursor is the mx.skins.halo.BusyCursor as defined by the busyCursor property of the CursorManager class.

The default value is false.

Implementation
    public function get showBusyCursor():Boolean
    public function set showBusyCursor(value:Boolean):void

See also

mx.managers.CursorManager
source property
source:Object [read-write]

Specifies the content to load. The source property takes the following form:

   source="URLOrPathOrClass"

   source="@Embed(source='PathOrClass')"

The value of the source property represents a relative or absolute URL, an object that implements IFlexDisplayObject, a class whose type implements IFlexDisplayObject, or a String that represents a class.

When you specify a path to a SWF, GIF, JPEG, PNG, or SVG file, Flex automatically converts the file to the correct data type for use with the SWFLoader control.

If you omit the Embed statement, Flex loads the referenced file at runtime; it is not packaged as part of the generated SWF file. At runtime, the source property only supports the loading of GIF, JPEG, PNG images, and SWF files.

Flex Data Services users can use the SWFLoader control to load a Flex application by using the following form:

   source="MXMLPath.mxml.swf"

Flex Data Services compiles the MXML file, and returns the SWF file to the main application. This technique works well with SWF files that add graphics or animations to an application, but are not intended to have a large amount of user interaction. If you import SWF files that require a large amount of user interaction, you should build them as custom components.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get source():Object
    public function set source(value:Object):void
trustContent property
trustContent:Boolean [read-write]

If true, the content is loaded into your security domain. This means that the load fails if the content is in another domain and that domain does not have a crossdomain.xml file allowing your domain to access it. This property only has an affect on the next load, it will not start a new load on already loaded content.

The default value is false, which means load any content without failing, but you cannot access the content. Most importantly, the loaded content cannot access your objects and code, which is the safest scenario. Do not set this property to true unless you are absolutely sure of the safety of the loaded content, especially active content like SWF files.

You can also use the loaderContext property to exactly determine how content gets loaded, if setting trustContent does not exactly meet your needs. The loaderContext property causes the SWFLoader to ignore the value of the trustContent property. But, you should be familiar with the SecurityDomain and ApplicationDomain classes to use the loaderContext property.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get trustContent():Boolean
    public function set trustContent(value:Boolean):void

See also

flash.system.SecurityDomain
flash.system.ApplicationDomain
Constructor detail
SWFLoader () constructor
public function SWFLoader()

Constructor.

Method detail
load () method
public function load(url:Object = null):void

Loads an image or SWF file. The url argument can reference a GIF, JPEG, PNG, or SWF file; you cannot use this method to load an SVG file. Instead, you must load it using an Embed statement with the source property.

Parameters
url:Object (default = null) — Absolute or relative URL of the GIF, JPEG, PNG, or SWF file to load.
Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched when content loading is complete.

This event is dispatched regardless of whether the load was triggered by an autoload or an explicit call to the load() method.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
httpStatus event
Event object type: flash.events.HTTPStatusEvent
HTTPStatusEvent.type property = flash.events.HTTPStatusEvent.HTTP_STATUS

Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code.

Defines the value of the type property of a httpStatus event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
status | The HTTP status code returned by the server.
target | The network object receiving an HTTP status code.
init event
Event object type: flash.events.Event
Event.type property = flash.events.Event.INIT

Dispatched when the properties and methods of a loaded SWF file are accessible. The following two conditions must exist for this event to be dispatched:

  • All properties and methods associated with the loaded object and those associated with the control are accessible.
  • The constructors for all child objects have completed.

Defines the value of the type property of an init event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The LoaderInfo object associated with the SWF file being loaded.
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an input/output error occurs.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.

See also

flash.events.IOErrorEvent
open event
Event object type: flash.events.Event
Event.type property = flash.events.Event.OPEN

Dispatched when a network operation starts.

Defines the value of the type property of an open event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has opened a connection.
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched when content is loading.

This event is dispatched regardless of whether the load was triggered by an autoload or an explicit call to the load() method.

Note: The progress event is not guaranteed to be dispatched. The complete event may be received, without any progress events being dispatched. This can happen when the loaded content is a local file.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.
securityError event
Event object type: flash.events.SecurityErrorEvent
SecurityErrorEvent.type property = flash.events.SecurityErrorEvent.SECURITY_ERROR

Dispatched when a security error occurs while content is loading. For more information, see the Flash Player SecurityErrorEvent class.

The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting the security error.
text | Text to be displayed as an error message.
unload event
Event object type: flash.events.Event
Event.type property = flash.events.Event.UNLOAD

Dispatched when a loaded object is removed, or when a second load is performed by the same SWFLoader control and the original content is removed prior to the new load beginning.

Defines the value of the type property of an unload event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The LoaderInfo object associated with the SWF file being unloaded or replaced.
Examples
local
<?xml version="1.0"?>
<!-- Flex application loaded by the SWFLoader control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" height="75" width="350">

    <mx:Label color="blue" text="The Label control of the embedded application."/>

</mx:Application>
SimpleLoader
<?xml version="1.0"?>
<!-- Simple example to demonstrate the SWFLoader control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="SWFLoader Control Example"  height="90%" width="90%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label text="The Label control of the outer application."/>

        <mx:SWFLoader id="Load" source="@Embed(source='Local.swf')" height="100" width="350"/>

    </mx:Panel>
</mx:Application>


mx.controls.TabBar (Flex™ 2 Language Reference)

Class TabBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class TabBar
Inheritance | TabBar Inheritance ToggleButtonBar Inheritance ButtonBar Inheritance NavBar Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The TabBar control lets you create a horizontal or vertical group of tab navigation items by defining the labels and data associated with each tab. Use the TabBar control instead of the TabNavigator container to create tabs that, by default, are not associated with multiple views.

Using the TabBar control lets the tabs be directly determined by the data so that you can change the view or views in any way.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:TabBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:TabBar
    Styles
    firstTabStyleName="Value of the tabStyleName property"
    horizontalAlign="left|center|right"
    horizontalGap="-1"
    lastTabStyleName="Value of the tabStyleName property"
    selectedTabTextStyleName="activeTabStyle"
    tabHeight="undefined"
    tabStyleName="Tab"
    tabWidth="undefined"
    verticalAlign="top|middle|bottom"
    verticalGap="-1"

    Events
    itemClick="No default"
    >
    ...
       child tags
    ...
  </mx:TabBar>

Default MXML Property dataProvider

View the examples.

See also

TabBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | dataProvider : Object Data used to populate the navigator control. | NavBar
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String The direction in which this Box container lays out its children. | Box
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | iconField : String Name of the field in the dataProvider object to display as the icon for each navigation item. | NavBar
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelField : String Name of the field in the dataProvider object to display as the label for each navigation item. | NavBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selectedIndex : int Index of the selected button. | ToggleButtonBar
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toggleOnClick : Boolean Specifies whether the currently selected button can be deselected by the user. | ToggleButtonBar
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | toolTipField : String Name of the the field in the dataProvider object to display as the tooltip label. | NavBar
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TabBar()
Constructor.
TabBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void Handles the MouseEvent.CLICK event for the items in the NavBar control. | NavBar
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | createNavItem(label:String, icon:Class = null):IFlexDisplayObject Creates the individual navigator items. | NavBar
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | hiliteSelectedNavItem(index:int):void Highlights the selected navigator item. | NavBar
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | resetNavItems():void Resets the navigator bar to its default state. | NavBar
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Inherited | updateNavItemIcon(index:int, icon:Class):void Resets the icon of a navigator item in the NavBar control. | NavBar
Inherited | updateNavItemLabel(index:int, label:String):void Sets the label property of a navigator item in the NavBar control. | NavBar
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when a tab navigation item is selected. | TabBar
Inherited | itemClick | Dispatched when a user clicks a button. | ButtonBar
Inherited | itemClick | Dispatched when a navigation item is selected. | NavBar
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | buttonHeight | Type: Number Format: Length CSS Inheritance: no Height of each button, in pixels. | ButtonBar
Inherited | buttonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the buttons. | ButtonBar
Inherited | buttonWidth | Type: Number Format: Length CSS Inheritance: no Width of each button, in pixels. | ButtonBar
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | firstButtonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the first button. | ButtonBar
 | firstTabStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies the styles to use for the first tab navigation item. The default value is "tabStyleName". | TabBar
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ButtonBar
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ButtonBar
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of the tab navigation items. Possible values are "left", "center", and "right". The default value is "left". | TabBar
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between tab navigation items in the horizontal direction. The default value is -1. | TabBar
Inherited | lastButtonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the last button. | ButtonBar
 | lastTabStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies the styles to use for the last tab navigation item. The default value is "tabStyleName". | TabBar
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | selectedButtonTextStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the text of the selected button. | ToggleButtonBar
 | selectedTabTextStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies the styles to use for the text of the selected tab navigation item. The default value is "activeTabStyle". | TabBar
 | tabHeight | Type: Number Format: Length CSS Inheritance: no Height of each tab navigation item, in pixels. When this property is undefined, the height of each tab is determined by the font styles applied to the container. If you set this property, the specified value overrides this calculation. The default value is undefined. | TabBar
 | tabStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies the styles to use for the tab navigation items. The default value is "Tab". | TabBar
 | tabWidth | Type: Number Format: Length CSS Inheritance: no Width of the tab navigation item, in pixels. If undefined, the default tab widths are calculated from the label text. The default value is undefined. | TabBar
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of the tab navigation items. Possible values are "top", "middle", and "bottom". The default value is "top". | TabBar
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between tab navigation items in the vertical direction. The default value is -1. | TabBar
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
TabBar () constructor
public function TabBar()

Constructor.

Event detail
itemClick event
Event object type: mx.events.ItemClickEvent
ItemClickEvent.type property = mx.events.ItemClickEvent.ITEM_CLICK

Dispatched when a tab navigation item is selected. This event is sent only if the data provider is not a ViewStack container.

The ItemClickEvent.ITEM_CLICK constant defines the value of the type property of the event object for an itemClick event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index of the navigation item that was clicked.
item | The item in the data provider of the navigation item that was clicked.
label | The label of the navigation item that was clicked.
relatedObject | The child object that generated the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
TabBarExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the TabBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.events.ItemClickEvent;
            import mx.controls.TabBar;

            [Bindable]
            public var STATE_ARRAY:Array = [{label:"Alabama", data:"Montgomery"},
                {label:"Alaska", data:"Juneau"},
                {label:"Arkansas", data:"LittleRock"}
            ];

            private function clickEvt(event:ItemClickEvent):void {
                // Access target TabBar control.
                var targetComp:TabBar = TabBar(event.currentTarget);
                forClick.text="label is: " + event.label + ", index is: " +
                    event.index + ", capital is: " +
                    targetComp.dataProvider[event.index].data;
            }
       ]]>
    </mx:Script>

    <mx:Panel title="TabBar Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
            text="Select a tab to change the current panel."/>

        <mx:TabBar itemClick="clickEvt(event);">
            <mx:dataProvider>{STATE_ARRAY}</mx:dataProvider>
        </mx:TabBar>

        <mx:TextArea id="forClick" height="100%" width="100%"/>

    </mx:Panel>
</mx:Application>


mx.controls.Text (Flex™ 2 Language Reference)

Class Text | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Text
Inheritance | Text Inheritance Label Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Text control displays multiline, noneditable text. Use the Label control if you need only a single line of text.

The Text control does not support scroll bars. If you need scrolling, you should use a non-editable TextArea control.

You can format the text in a Text control using HTML tags, which are applied after the control's CSS styles are applied. You can also put padding around the four sides of the text.

The text in a Text control is selectable by default, but you can make it unselectable. When using a Text control in an item renderer, always set its selectable property to false.

If the control is not as wide as the text, the text will wordwrap. The text is always aligned top-left in the control.

To size a Text component, it's common to specify an explicit width and let Flex determine the height as required to display all the text. If you specify an explicit height, some of the text may get clipped; unlike Label, Text does not truncate its text with "...". It's also common to use percentage widths and heights with Text.

If you leave both the width and the height unspecified, Flex calculates them based on any explicit line breaks in the text, with no wordwrapping within lines. For example, if you set the text property, the newline character "\n" causes a line break. If you set the htmlText property, the HTML markup <br> causes a line break. If your text or htmlText is lengthy and doesn't contain line breaks, you can get a very wide Text component; you can set the maxWidth to limit how wide the component is allowed to grow.

Text controls do not have backgrounds or borders and cannot take focus.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Text> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Text
  />

View the examples.

See also

mx.controls.Label
mx.controls.TextInput
mx.controls.TextArea
mx.controls.RichTextEditor
Using Text Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | condenseWhite : Boolean Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a Label control with HTML text. | Label
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object Lets you pass a value to the component when you use it in an item renderer or item editor. | Label
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | htmlText : String Specifies the text displayed by the Label control, including HTML markup that expresses the styles of that text. | Label
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | Label
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selectable : Boolean Specifies whether the text can be selected. | Label
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String Specifies the plain text displayed by this control. | Label
Inherited | textHeight : Number The height of the text. | Label
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | textWidth : Number The width of the text. | Label
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | truncateToFit : Boolean = true If this propery is true, and the Label control size is smaller than its text, the text of the Label control is truncated using a localizable string, such as "...". | Label
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField that renders the text of this Label. | Label
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Text()
Constructor.
Text
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getLineMetrics(lineIndex:int):TextLineMetrics
Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
Label
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Label
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Label
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Label
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Label
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Label
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Label
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Label
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Label
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Label
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Label
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Label
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Label
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Label
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
Text () constructor
public function Text()

Constructor.

Examples
TextExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Text control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="Text Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10">

        <mx:Text width="100%">
            <mx:text>
                This is a multiline, non-editable text component.
                If you need an editable multiline component, use TextArea.
            </mx:text>
        </mx:Text>

        <mx:Text width="100%">
            <mx:htmlText>
                <![CDATA[This is <font color="#FF0000">HTML text</font> in a <b>Text component</b>. Using the <u>htmlText attribute</u> of the <font color="#008800">Text component</font> you can use basic HTML markup.]]>
            </mx:htmlText>
        </mx:Text>

   </mx:Panel>
</mx:Application>


mx.controls.TextArea (Flex™ 2 Language Reference)

Class TextArea | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class TextArea
Inheritance | TextArea Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IFocusManagerComponent, IIMESupport, IListItemRenderer

The TextArea control is a multiline text field with a border and optional scroll bars. The TextArea control supports the HTML rendering capabilities of the Adobe Flash Player.

If you disable a TextArea control, it displays its contents in the color specified by the disabledColor style. You can also set a TextArea control to read-only to disallow editing of the text. To conceal input text by displaying characters as asterisks, set the TextArea's displayAsPassword property.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:TextArea> tag inherits the attributes of its superclass and adds the following attributes:

  <mx:TextArea
    Properties
    condenseWhite="false|true"
    data="undefined"
    displayAsPassword="false|true"
    editable="true|false"
    horizontalScrollPolicy="auto|on|off"
    horizontalScrollPosition="0"
    htmlText="null"
    imeMode="null"
    length="0"
    listData=null
    maxChars="0"
    restrict="null"
    selectionBeginIndex="0"
    selectionEndIndex="0"
    styleSheet="null"
    text=""
    textHeight="height of text""
    textWidth="width of text"
    verticalScrollPolicy="auto|on|off"
    verticalScrollPosition="0"
    wordWrap="true|false"

    Styles
    disabledColor="0xAAB3B3"
    focusAlpha="0.5"
    focusRoundedCorners"tl tr bl br"
    paddingLeft="0""
    paddingRight="0""

    Events
    change="No default"
  />

View the examples.

See also

mx.controls.Label
mx.controls.Text
mx.controls.TextInput
mx.controls.RichTextEditor
mx.controls.textClasses.TextRange
Using Text Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | condenseWhite : Boolean Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a TextArea control with HTML text. | TextArea
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object Lets you pass a value to the component when you use it in an item renderer or item editor. | TextArea
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | displayAsPassword : Boolean Indicates whether this control is used for entering passwords. | TextArea
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | editable : Boolean Indicates whether the user is allowed to edit the text in this control. | TextArea
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always on (ScrollPolicy.ON), always off (ScrollPolicy.OFF), or turns on when needed (ScrollPolicy.AUTO). | TextArea
 | horizontalScrollPosition : Number [write-only] Pixel position in the content area of the leftmost pixel that is currently displayed. | TextArea
 | htmlText : String Specifies the text displayed by the TextArea control, including HTML markup that expresses the styles of that text. | TextArea
Inherited | id : String ID of the component. | UIComponent
 | imeMode : String Specifies the IME (input method editor) mode. | TextArea
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | length : int [read-only] The number of characters of text displayed in the TextArea. | TextArea
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | TextArea
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxChars : int Maximum number of characters that users can enter in the text field. | TextArea
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | restrict : String Indicates the set of characters that a user can enter into the control. | TextArea
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
 | selectionBeginIndex : int The zero-based character index value of the first character in the current selection. | TextArea
 | selectionEndIndex : int The zero-based index of the position afterthe last character in the current selection (equivalent to the one-based index of the last character). | TextArea
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
 | styleSheet : StyleSheet A flash.text.StyleSheet object that can perform rendering on the TextArea control's text. | TextArea
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String Plain text that appears in the control. | TextArea
 | textHeight : Number [read-only] The height of the text. | TextArea
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | textWidth : Number [read-only] The width of the text. | TextArea
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | verticalScrollPolicy : String Whether the vertical scroll bar is always on (ScrollPolicy.ON), always off (ScrollPolicy.OFF), or turns on when needed (ScrollPolicy.AUTO). | TextArea
 | verticalScrollPosition : Number [write-only] Line number of the top row of characters that is currently displayed. | TextArea
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
 | wordWrap : Boolean Indicates whether the text automatically wraps at the end of a line. | TextArea
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
 | textField : UITextField The internal UITextField that renders the text of this TextArea. | TextArea
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TextArea()
Constructor.
TextArea
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
getLineMetrics(lineIndex:int):TextLineMetrics
Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
TextArea
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setSelection(beginIndex:int, endIndex:int):void
Selects the text in the range specified by the parameters.
TextArea
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the border for this component. | ScrollControlBase
Inherited | createChildren():void Creates objects that are children of this ScrollControlBase, which in this case are the border and mask. | ScrollControlBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this control's borders. | ScrollControlBase
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseWheelHandler(event:MouseEvent):void Event handler for the mouse wheel scroll event. | ScrollControlBase
Inherited | scrollHandler(event:Event):void Default event handler for the scroll event. | ScrollControlBase
Inherited | setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in. | ScrollControlBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when text in the TextArea control changes through user input or data binding. | TextArea
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | TextArea
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
 | textInput | Dispatched when the user types, deletes, or pastes text into the control. | TextArea
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
 | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of the component if it is disabled. The default value is 0xAAB3B3. | TextArea
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. The default value is 0.4. | TextArea
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
 | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". | TextArea
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. The default value for the Tree control is 2. | TextArea
 | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. | TextArea
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
condenseWhite property
condenseWhite:Boolean [read-write]

Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a TextArea control with HTML text.

The condenseWhite property only affects text set with the htmlText property, not the text property. If you set text with the text property, condenseWhite is ignored.

If you set the condenseWhite property to true, you must use standard HTML commands such as <br> and <p> to place line breaks in the text field.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get condenseWhite():Boolean
    public function set condenseWhite(value:Boolean):void
data property
data:Object [read-write]

Lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

When you use the control as a drop-in item renderer or drop-in item editor, Flex automatically writes the current value of the item to the text property of this control.

You do not set this property in MXML.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
displayAsPassword property
displayAsPassword:Boolean [read-write]

Indicates whether this control is used for entering passwords. If true, the field does not display entered text, instead, each text character entered into the control appears as the character "*".

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get displayAsPassword():Boolean
    public function set displayAsPassword(value:Boolean):void
editable property
editable:Boolean [read-write]

Indicates whether the user is allowed to edit the text in this control. If true, the user can edit the text.

The default value is true;.

This property can be used as the source for data binding.

Implementation
    public function get editable():Boolean
    public function set editable(value:Boolean):void
horizontalScrollPolicy property
horizontalScrollPolicy:String [read-write]

Specifies whether the horizontal scroll bar is always on (ScrollPolicy.ON), always off (ScrollPolicy.OFF), or turns on when needed (ScrollPolicy.AUTO).

The default value is ScrollPolicy.AUTO.

Implementation
    public function get horizontalScrollPolicy():String
    public function set horizontalScrollPolicy(value:String):void
horizontalScrollPosition property
horizontalScrollPosition:Number [write-only]

Pixel position in the content area of the leftmost pixel that is currently displayed. (The content area includes all contents of a control, not just the portion that is currently displayed.) This property is always set to 0, and ignores changes, if wordWrap is set to true.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function set horizontalScrollPosition(value:Number):void
htmlText property
htmlText:String [read-write]

Specifies the text displayed by the TextArea control, including HTML markup that expresses the styles of that text. When you specify HTML text in this property, you can use the subset of HTML tags that is supported by the Flash TextField control.

When you set this property, the HTML markup is applied after the CSS styles for the TextArea instance are applied. When you get this property, the HTML markup includes the CSS styles.

For example, if you set this to be a string such as, "This is an example of <b>bold</b> markup", the text "This is an example of bold markup" appears in the TextArea with whatever CSS styles normally apply. Also, the word "bold" appears in boldface font because of the <b> markup.

HTML markup uses characters such as < and >, which have special meaning in XML (and therefore in MXML). So, code such as the following does not compile:

   <mx:TextArea htmlText="This is an example of <b>bold</b> markup"/>

There are three ways around this problem.

  • Set the htmlText property in an ActionScript method called as an initialize handler:

       <mx:TextArea id="myTextArea" initialize="myTextArea_initialize()"/>

    where the myTextArea_initialize method is in a script CDATA section:

       <mx:Script>
   <![CDATA[
   private function myTextArea_initialize():void {
       myTextArea.htmlText = "This is an example of <b>bold</b> markup";
   }
   ]]>
   </mx:Script>

    This is the simplest approach because the HTML markup remains easily readable. Notice that you must assign an id to the TextArea so you can refer to it in the initialize handler.

  • Specify the htmlText property by using a child tag with a CDATA section. A CDATA section in XML contains character data where characters like < and > aren't given a special meaning.

       <mx:TextArea>
       <mx:htmlText><![CDATA[This is an example of <b>bold</b> markup]]></mx:htmlText>
   <mx:TextArea/>

    You must write the htmlText property as a child tag rather than as an attribute on the <mx:TextArea> tag because XML doesn't allow CDATA for the value of an attribute. Notice that the markup is readable, but the CDATA section makes this approach more complicated.

  • Use an hmtlText attribute where any occurences of the HTML markup characters < and > in the attribute value are written instead as the XML "entities" &lt; and &gt;:

       <mx:TextArea htmlText="This is an example of &lt;b&gt;bold&lt;/b&gt; markup"/&gt;
    Adobe does not recommend this approach because the HTML markup becomes nearly impossible to read.

If the condenseWhite property is true when you set the htmlText property, multiple white-space characters are condensed, as in HTML-based browsers; for example, three consecutive spaces are displayed as a single space. The default value for condenseWhite is false, so you must set condenseWhite to true to collapse the white space.

If you read back the htmlText property quickly after setting it, you get the same string that you set. However, after the LayoutManager runs, the value changes to include additional markup that includes the CSS styles.

Setting the htmlText property affects the text property in several ways. If you read the text property quickly after setting the htmlText property, you get null, which indicates that the text corresponding to the new htmlText has not yet been determined. However, after the LayoutManager runs, the text property value changes to the htmlText string with all the HTML markup removed; that is, the value is the characters that the TextArea actually displays.

Conversely, if you set the text property, any previously set htmlText is irrelevant. If you read the htmlText property quickly after setting the text property, you get null, which indicates that the htmlText that corresponds to the new text has not yet been determined. However, after the LayoutManager runs, the htmlText property value changes to the new text plus the HTML markup for the CSS styles.

To make the LayoutManager run immediately, you can call the validateNow() method on the TextArea. For example, you could set some htmlText, call the validateNow() method, and immediately obtain the corresponding text that doesn't have the HTML markup.

If you set both text and htmlText properties in ActionScript, whichever is set last takes effect. Do not set both in MXML, because MXML does not guarantee that the properties of an instance get set in any particular order.

Setting either text or htmlText property inside a loop is a fast operation, because the underlying TextField that actually renders the text is not updated until the LayoutManager runs.

If you try to set this property to null, it is set, instead, to the empty string. If the property temporarily has the value null, it indicates that the text has been recently set and the corresponding htmlText has not yet been determined.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get htmlText():String
    public function set htmlText(value:String):void

See also

flash.text.TextField.htmlText
imeMode property
imeMode:String [read-write]

Specifies the IME (input method editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the specified IME mode when the control gets the focus, and sets it back to the previous value when the control loses the focus.

The flash.system.IMEConversionMode class defines constants for the valid values for this property. You can also specify null to specify no IME.

The default value is null.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void

See also

flash.system.IMEConversionMode
length property
length:int [read-only]

The number of characters of text displayed in the TextArea.

The default value is 0.

Implementation
    public function get length():int
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. The component can then use the listData property to initialize the data property of the drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
maxChars property
maxChars:int [read-write]

Maximum number of characters that users can enter in the text field. This property does not limit the length of text specified by the setting the control's text or htmlTextproperty.

The default value of 0, which indicates no limit.

This property can be used as the source for data binding.

Implementation
    public function get maxChars():int
    public function set maxChars(value:int):void
restrict property
restrict:String [read-write]

Indicates the set of characters that a user can enter into the control. If the value of the restrict property is null, you can enter any character. If the value of the restrict property is an empty string, you cannot enter any character. This property only restricts user interaction; a script can put any text into the text field. If the value of the restrict property is a string of characters, you may enter only characters in that string into the text field.

Flex scans the string from left to right. You can specify a range by using the hyphen (-) character. If the string begins with a caret (^) character, all characters are initially accepted and succeeding characters in the string are excluded from the set of accepted characters. If the string does not begin with a caret (^) character, no characters are initially accepted and succeeding characters in the string are included in the set of accepted characters.

Because some characters have a special meaning when used in the restrict property, you must use backslash characters to specify the literal characters -, ^, and \. When you use the restrict property as an attribute in an MXML tag, use single backslashes, as in the following example: \^\-\\. When you set the restrict In and ActionScript expression, use double backslashes, as in the following example: \\^\\-\\\.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get restrict():String
    public function set restrict(value:String):void

See also

flash.text.TextField.restrict
selectionBeginIndex property
selectionBeginIndex:int [read-write]

The zero-based character index value of the first character in the current selection. For example, the first character is 0, the second character is 1, and so on. When the control gets the focus, the selection is visible if the selectionBeginIndex and selectionEndIndex properties are both set.

The default value is 0.

Implementation
    public function get selectionBeginIndex():int
    public function set selectionBeginIndex(value:int):void
selectionEndIndex property
selectionEndIndex:int [read-write]

The zero-based index of the position afterthe last character in the current selection (equivalent to the one-based index of the last character). If the last character in the selection, for example, is the fifth character, this property has the value 5. When the control gets the focus, the selection is visible if the selectionBeginIndex and selectionEndIndex properties are both set.

The default value is 0.

Implementation
    public function get selectionEndIndex():int
    public function set selectionEndIndex(value:int):void
styleSheet property
styleSheet:StyleSheet [read-write]

A flash.text.StyleSheet object that can perform rendering on the TextArea control's text. Used for detailed control of HTML styles for the text. For more information, see the flash.text.StyleSheet class documentation.

The default value is null.

Implementation
    public function get styleSheet():StyleSheet
    public function set styleSheet(value:StyleSheet):void

See also

flash.text.StyleSheet
text property
text:String [read-write]

Plain text that appears in the control. Its appearance is determined by the CSS styles of this Label control.

Any HTML tags in the text string are ignored, and appear as entered in the string. To display text formatted using HTML tags, use the htmlText property instead. If you set the htmlText property, the HTML replaces any text you had set using this propety, and the text property returns a plain-text version of the HTML text, with all HTML tags stripped out. For more information see the htmlText property.

To include the special characters left angle bracket (<), right angle bracket (>), or ampersand (&) in the text, wrap the text string in the CDATA tag. Alternatively, you can use HTML character entities for the special characters, for example, &lt;.

If you try to set this property to null, it is set, instead, to the empty string. The text property can temporarily have the value null, which indicates that the htmlText has been recently set and the corresponding text value has not yet been determined.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get text():String
    public function set text(value:String):void
textField property
protected var textField:UITextField

The internal UITextField that renders the text of this TextArea.

textHeight property
textHeight:Number [read-only]

The height of the text.

The value of the textHeight property is correct only after the component has been validated. If you set text and then immediately ask for the textHeight, you might receive an incorrect value. You should wait for the component to validate or call the validateNow() method before you get the value. This behavior differs from that of the flash.text.TextField control, which updates the value immediately.

Implementation
    public function get textHeight():Number

See also

flash.text.TextField
textWidth property
textWidth:Number [read-only]

The width of the text.

The value of the textWidth property is correct only after the component has been validated. If you set text and then immediately ask for the textWidth, you might receive an incorrect value. You should wait for the component to validate or call the validateNow() method before you get the value. This behavior differs from that of the flash.text.TextField control, which updates the value immediately.

Implementation
    public function get textWidth():Number

See also

flash.text.TextField
verticalScrollPolicy property
verticalScrollPolicy:String [read-write]

Whether the vertical scroll bar is always on (ScrollPolicy.ON), always off (ScrollPolicy.OFF), or turns on when needed (ScrollPolicy.AUTO).

The default value is ScrollPolicy.AUTO.

Implementation
    public function get verticalScrollPolicy():String
    public function set verticalScrollPolicy(value:String):void
verticalScrollPosition property
verticalScrollPosition:Number [write-only]

Line number of the top row of characters that is currently displayed. The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function set verticalScrollPosition(value:Number):void
wordWrap property
wordWrap:Boolean [read-write]

Indicates whether the text automatically wraps at the end of a line. If true, the text wraps to occupy multiple lines, if necessary.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get wordWrap():Boolean
    public function set wordWrap(value:Boolean):void
Constructor detail
TextArea () constructor
public function TextArea()

Constructor.

Method detail
getLineMetrics () method
public function getLineMetrics(lineIndex:int):TextLineMetrics

Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control. The component must be validated to get a correct number. If you set the text or htmlText property and then immediately call getLineMetrics() you may receive an incorrect value. You should either wait for the component to validate or call validateNow(). This is behavior differs from that of the flash.text.TextField class, which updates the value immediately.

Parameters
lineIndex:int — The zero-based index of the line for which to get the metrics.

Returns
TextLineMetrics

See also

flash.text.TextField
flash.text.TextLineMetrics
setSelection () method
public function setSelection(beginIndex:int, endIndex:int):void

Selects the text in the range specified by the parameters. If the control is not in focus, the selection highlight will not show until the control gains focus. Also, if the focus is gained by clicking on the control, any previous selection would be lost. If the two parameter values are the same, the new selection is an insertion point.

Parameters
beginIndex:int — The zero-based index of the first character in the selection; that is, the first character is 0, the second character is 1, and so on.
endIndex:int — The zero-based index of the position after the last character in the selection (equivalent to the one-based index of the last character). If the parameter is 5, the last character in the selection, for example, is the fifth character. When the TextArea control gets the focus, the selection is visible if the selectionBeginIndex and selectionEndIndex properties are both set.
Event detail
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched when text in the TextArea control changes through user input or data binding. This event does not occur if you use ActionScript code to change the text.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
textInput event
Event object type: flash.events.TextEvent
TextEvent.type property = flash.events.TextEvent.TEXT_INPUT

Dispatched when the user types, deletes, or pastes text into the control.

Defines the value of the type property of a textInput event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The text field into which characters are being entered. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
text | The character or sequence of characters entered by the user.
Examples
TextAreaExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the TextArea control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="TextArea Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:TextArea width="400" height="100">
            <mx:text>
                This is a multiline, editable TextArea control. If you need
                a non-editable multiline control, use the Text control.
            </mx:text>
        </mx:TextArea>

        <mx:TextArea width="400" height="100">
            <mx:htmlText><![CDATA[This is <font color="#FF0000">HTML text</font> in a <b>TextArea control</b>. Use the <u>htmlText property</u> of the <font color="#008800">TextArea control</font> to include basic HTML markup in your text.]]></mx:htmlText>
        </mx:TextArea>

    </mx:Panel>
</mx:Application>


mx.controls.TextInput (Flex™ 2 Language Reference)

Class TextInput | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class TextInput
Inheritance | TextInput Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IFocusManagerComponent, IIMESupport, IListItemRenderer

The TextInput control is a single-line text field that is optionally editable. All text in this control must use the same styling unless it is HTML text. The TextInput control supports the HTML rendering capabilities of the Adobe Flash Player.

TextInput controls do not include a label, although you can add one by using a Label control or by nesting the TextInput control in a FormItem control in a Form container. When used in a FormItem control, a TextInput control indicates whether a value is required. TextInput controls have a number of states, including filled, selected, disabled, and error. TextInput controls support formatting, validation, and keyboard equivalents; they also dispatch change and enter events.

If you disable a TextInput control, it displays its contents in the color specified by the disabledColor style. To disallow editing the text, you set the editable property to false. To conceal the input text by displaying asterisks instead of the characters entered, you set the displayAsPassword property to true.

The TextInput control is used as a subcomponent in several other controls, such as the RichTextEditor, NumericStepper, and ComboBox controls. As a result, if you assign style properties to a TextInput control by using a CSS type selector, Flex applies those styles to the TextInput when it appears in the other controls unless you explicitly override them.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:TextInput> tag inherits the attributes of its superclass and adds the following attributes:

  <mx:TextInput
    Properties
    condenseWhite="false|true"
    data="undefined"
    displayAsPassword="false|true"
    editable="true|false"
    horizontalScrollPosition="0"
    htmlText=""
    imeMode="null"
    length="0"
    listData=null
    maxChars="0"
    maxHorizontalScrollPosition="0"
    restrict="null"
    selectionBeginIndex="0"
    selectionEndIndex="0"
    text=""
    textField="internal subcontrol"
    textHeight="0"
    textWidth="0"

    Styles
    backgroundAlpha="1.0"
    backgroundColor="undefined"
    backgroundImage="undefined"
    backgroundSize="auto"
    borderColor="0xAAB3B3"
    borderSides="left top right bottom"
    borderSkin="mx.skins.halo.HaloBorder"
    borderStyle="inset"
    borderThickness="1"
    color="0x0B333C"
    cornerRadius="0"
    disabledColor="0xAAB3B3"
    dropShadowColor="0x000000"
    dropShadowEnabled="false"
    focusAlpha="0.5"
    focusRoundedCorners"tl tr bl br"
    fontAntiAliasType="advanced|normal"
    fontFamily="Verdana"
    fontGridFitType="pixel|none|subpixel"
    fontSharpness="0"
    fontSize="10"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    paddingLeft="0"
    paddingRight="0"
    shadowDirection="center"
    shadowDistance="2"
    textAlign="lift|right|center"
    textDecoration="none|underline"
    textIndent="0"

    Events
    change="No default"
    dataChange="No default"
    enter="No default"
    textInput="No default"
  />

View the examples.

See also

mx.controls.Label
mx.controls.Text
mx.controls.TextArea
mx.controls.RichTextEditor
mx.controls.textClasses.TextRange
Using Text Controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | condenseWhite : Boolean Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a TextInput control with HTML text. | TextInput
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object Lets you pass a value to the component when you use it in an item renderer or item editor. | TextInput
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | displayAsPassword : Boolean Indicates whether this control is used for entering passwords. | TextInput
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | editable : Boolean Indicates whether the user is allowed to edit the text in this control. | TextInput
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | horizontalScrollPosition : Number / Pixel position in the content area of the leftmost pixel that is currently displayed. | TextInput
 | htmlText : String Specifies the text displayed by the TextInput control, including HTML markup that expresses the styles of that text. | TextInput
Inherited | id : String ID of the component. | UIComponent
 | imeMode : String Specifies the IME (input method editor) mode. | TextInput
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | length : int [read-only] The number of characters of text displayed in the TextArea. | TextInput
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | TextInput
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxChars : int Maximum number of characters that users can enter in the text field. | TextInput
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxHorizontalScrollPosition : Number [read-only] Maximum value of horizontalScrollPosition. | TextInput
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | restrict : String Indicates the set of characters that a user can enter into the control. | TextInput
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectionBeginIndex : int The zero-based character index value of the first character in the current selection. | TextInput
 | selectionEndIndex : int The zero-based index of the position afterthe last character in the current selection (equivalent to the one-based index of the last character). | TextInput
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String Plain text that appears in the control. | TextInput
 | textHeight : Number [read-only] The height of the text. | TextInput
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | textWidth : Number [read-only] The width of the text. | TextInput
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | textField : UITextField The internal UITextField that renders the text of this TextInput. | TextInput
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TextInput()
Constructor.
TextInput
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
getLineMetrics(lineIndex:int):TextLineMetrics
Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
TextInput
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setSelection(beginIndex:int, endIndex:int):void
Selects the text in the range specified by the parameters.
TextInput
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when text in the TextInput control changes through user input or data binding. | TextInput
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | TextInput
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
 | enter | Dispatched when the user presses the Enter key. | TextInput
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
 | textInput | Dispatched when the user types, deletes, or pastes text into the control. | TextInput
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. Valid values range from 0.0 to 1.0. The default value is 1.0. 		TextInput
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. You can have both a backgroundColor and a backgroundImage set. Some components do not have a background. The DataGrid control ignores this style. The default value is undefined, which means it is not set. If both this style and the backgroundImage style are undefined, the component has a transparent background.

For the Application container, this style specifies the background color while the application loads, and a background gradient while it is running. Flex calculates the gradient pattern between a color slightly darker than the specified color, and a color slightly lighter than the specified color.

The default skins of most Flex controls are partially transparent. As a result, the background color of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

TextInput
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. This can be an absolute or relative URL or class. You can either have both a backgroundColor and a backgroundImage set at the same time. The background image is displayed on top of the background color. The default value is undefined, meaning "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The default skins of most Flex controls are partially transparent. As a result, the background image of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

TextInput
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). The default value is "auto", which maintains the original size of the image. 		TextInput
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The default value depends on the component class; if not overridden for the class, the default value is 0xB7BABC. 		TextInput
borderSides
Type: String CSS Inheritance: no
Bounding box sides. A space-delimited String that specifies the sides of the border to show. The String can contain "left", "top", "right", and "bottom" in any order. The default value is "left top right bottom", which shows all four sides. This style is only used when borderStyle is "solid". 		TextInput
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. The default value is mx.skins.halo.HaloBorder. 		TextInput
borderStyle
Type: String CSS Inheritance: no
Bounding box style. The possible values are "none", "solid", "inset", and "outset". The default value depends on the component class; if not overridden for the class, the default value is "inset". The default value for most Containers is "none". 		TextInput
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. Only used when borderStyle is set to "solid". The default value is 1. 		TextInput
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		TextInput
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The default value depends on the component class; if not overriden for the class, the default value is 0. The default value for ApplicationControlBar is 5. 		TextInput
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		TextInput
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. The default value is 0x000000. 		TextInput
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. This style is used with borderStyle="solid". The default value is false.

Note: For drop shadows to appear on containers, set backgroundColor or backgroundImage properties. Otherwise, the shadow appears behind the container because the default background of a container is transparent.

TextInput
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		TextInput
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		TextInput
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		TextInput
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		TextInput
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		TextInput
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		TextInput
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		TextInput
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		TextInput
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		TextInput
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		TextInput
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

TextInput
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

TextInput
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. Possible values are "left", "center", and "right". The default value is "center". 		TextInput
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. If the property is set to a negative value, the shadow appears above the component. The default value is 2. 		TextInput
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

TextInput
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		TextInput
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		TextInput
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
condenseWhite property
condenseWhite:Boolean [read-write]

Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a TextInput control with HTML text.

The condenseWhite property affects only text set with the htmlText property, not the text property. If you set text with the text property, condenseWhite is ignored.

If you set the condenseWhite property to true, you must use standard HTML commands, such as <br> and <p>, to place line breaks in the text field.

The default value is false;.

This property can be used as the source for data binding.

Implementation
    public function get condenseWhite():Boolean
    public function set condenseWhite(value:Boolean):void
data property
data:Object [read-write]

Lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

When you use the control as a drop-in item renderer or drop-in item editor, Flex automatically writes the current value of the item to the text property of this control.

You do not set this property in MXML.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
displayAsPassword property
displayAsPassword:Boolean [read-write]

Indicates whether this control is used for entering passwords. If true, the field does not display entered text, instead, each text character entered into the control appears as the character "*".

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get displayAsPassword():Boolean
    public function set displayAsPassword(value:Boolean):void
editable property
editable:Boolean [read-write]

Indicates whether the user is allowed to edit the text in this control. If true, the user can edit the text.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get editable():Boolean
    public function set editable(value:Boolean):void
horizontalScrollPosition property
horizontalScrollPosition:Number [read-write]

/ Pixel position in the content area of the leftmost pixel that is currently displayed. (The content area includes all contents of a control, not just the portion that is currently displayed.) This property is always set to 0, and ignores changes, if wordWrap is set to true.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get horizontalScrollPosition():Number
    public function set horizontalScrollPosition(value:Number):void
htmlText property
htmlText:String [read-write]

Specifies the text displayed by the TextInput control, including HTML markup that expresses the styles of that text. When you specify HTML text in this property, you can use the subset of HTML tags that is supported by the Flash TextField control.

When you set this property, the HTML markup is applied after the CSS styles for the TextInput instance are applied. When you get this property, the HTML markup includes the CSS styles.

For example, if you set this to be a string such as, "This is an example of <b>bold</b> markup", the text "This is an example of bold markup" appears in the TextInput with whatever CSS styles normally apply. Also, the word "bold" appears in boldface font because of the <b> markup.

HTML markup uses characters such as < and >, which have special meaning in XML (and therefore in MXML). So, code such as the following does not compile:

   <mx:TextInput htmlText="This is an example of <b>bold</b> markup"/>

There are three ways around this problem.

  • Set the htmlText property in an ActionScript method called as an initialize handler:

       <mx:TextInput id="myTextInput" initialize="myTextInput_initialize()"/>

    where the myTextInput_initialize method is in a script CDATA section:

       <mx:Script>
   <![CDATA[
   private function myTextInput_initialize():void {
       myTextInput.htmlText = "This is an example of <b>bold</b> markup";
   }
   ]]>
   </mx:Script>

    This is the simplest approach because the HTML markup remains easily readable. Notice that you must assign an id to the TextInput so you can refer to it in the initialize handler.

  • Specify the htmlText property by using a child tag with a CDATA section. A CDATA section in XML contains character data where characters like < and > aren't given a special meaning.

       <mx:TextInput>
       <mx:htmlText><![CDATA[This is an example of <b>bold</b> markup]]></mx:htmlText>
   <mx:TextInput/>

    You must write the htmlText property as a child tag rather than as an attribute on the <mx:TextInput> tag because XML doesn't allow CDATA for the value of an attribute. Notice that the markup is readable, but the CDATA section makes this approach more complicated.

  • Use an hmtlText attribute where any occurences of the HTML markup characters < and > in the attribute value are written instead as the XML "entities" &lt; and &gt;:

       <mx:TextInput htmlText="This is an example of &lt;b&gt;bold&lt;/b&gt; markup"/&gt;
    Adobe does not recommend this approach because the HTML markup becomes nearly impossible to read.

If the condenseWhite property is true when you set the htmlText property, multiple white-space characters are condensed, as in HTML-based browsers; for example, three consecutive spaces are displayed as a single space. The default value for condenseWhite is false, so you must set condenseWhite to true to collapse the white space.

If you read back the htmlText property quickly after setting it, you get the same string that you set. However, after the LayoutManager runs, the value changes to include additional markup that includes the CSS styles.

Setting the htmlText property affects the text property in several ways. If you read the text property quickly after setting the htmlText property, you get null, which indicates that the text corresponding to the new htmlText has not yet been determined. However, after the LayoutManager runs, the text property value changes to the htmlText string with all the HTML markup removed; that is, the value is the characters that the TextInput actually displays.

Conversely, if you set the text property, any previously set htmlText is irrelevant. If you read the htmlText property quickly after setting the text property, you get null, which indicates that the htmlText that corresponds to the new text has not yet been determined. However, after the LayoutManager runs, the htmlText property value changes to the new text plus the HTML markup for the CSS styles.

To make the LayoutManager run immediately, you can call the validateNow() method on the TextInput. For example, you could set some htmlText, call the validateNow() method, and immediately obtain the corresponding text that doesn't have the HTML markup.

If you set both text and htmlText properties in ActionScript, whichever is set last takes effect. Do not set both in MXML, because MXML does not guarantee that the properties of an instance get set in any particular order.

Setting either text or htmlText property inside a loop is a fast operation, because the underlying TextField that actually renders the text is not updated until the LayoutManager runs.

If you try to set this property to null, it is set, instead, to the empty string. If the property temporarily has the value null, it indicates that the text has been recently set and the corresponding htmlText has not yet been determined.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get htmlText():String
    public function set htmlText(value:String):void

See also

flash.text.TextField.htmlText
imeMode property
imeMode:String [read-write]

Specifies the IME (input method editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the specified IME mode when the control gets the focus, and sets it back to the previous value when the control loses the focus.

The flash.system.IMEConversionMode class defines constants for the valid values for this property. You can also specify null to specify no IME.

The default value is null.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void

See also

flash.system.IMEConversionMode
length property
length:int [read-only]

The number of characters of text displayed in the TextArea.

The default value is 0.

Implementation
    public function get length():int
listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. The component can then use the listData property to initialize the data property of the drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
maxChars property
maxChars:int [read-write]

Maximum number of characters that users can enter in the text field. This property does not limit the length of text specified by the setting the control's text or htmlText property.

The default value is 0, which is a special case meaning an unlimited number.

This property can be used as the source for data binding.

Implementation
    public function get maxChars():int
    public function set maxChars(value:int):void
maxHorizontalScrollPosition property
maxHorizontalScrollPosition:Number [read-only]

Maximum value of horizontalScrollPosition.

The default value is 0, which means that horizontal scrolling is not required.

The value of the maxHorizontalScrollPosition property is computed from the data and size of component, and must not be set by the application code.

Implementation
    public function get maxHorizontalScrollPosition():Number
restrict property
restrict:String [read-write]

Indicates the set of characters that a user can enter into the control. If the value of the restrict property is null, you can enter any character. If the value of the restrict property is an empty string, you cannot enter any character. This property only restricts user interaction; a script can put any text into the text field. If the value of the restrict property is a string of characters, you may enter only characters in that string into the text field.

Flex scans the string from left to right. You can specify a range by using the hyphen (-) character. If the string begins with a caret (^) character, all characters are initially accepted and succeeding characters in the string are excluded from the set of accepted characters. If the string does not begin with a caret (^) character, no characters are initially accepted and succeeding characters in the string are included in the set of accepted characters.

Because some characters have a special meaning when used in the restrict property, you must use backslash characters to specify the literal characters -, ^, and \. When you use the restrict property as an attribute in an MXML tag, use single backslashes, as in the following example: \^\-\\. When you set the restrict In and ActionScript expression, use double backslashes, as in the following example: \\^\\-\\\.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get restrict():String
    public function set restrict(value:String):void

See also

flash.text.TextField.restrict
selectionBeginIndex property
selectionBeginIndex:int [read-write]

The zero-based character index value of the first character in the current selection. For example, the first character is 0, the second character is 1, and so on. When the control gets the focus, the selection is visible if the selectionBeginIndex and selectionEndIndex properties are both set.

The default value is 0.

Implementation
    public function get selectionBeginIndex():int
    public function set selectionBeginIndex(value:int):void
selectionEndIndex property
selectionEndIndex:int [read-write]

The zero-based index of the position afterthe last character in the current selection (equivalent to the one-based index of the last character). If the last character in the selection, for example, is the fifth character, this property has the value 5. When the control gets the focus, the selection is visible if the selectionBeginIndex and selectionEndIndex properties are both set.

The default value is 0.

Implementation
    public function get selectionEndIndex():int
    public function set selectionEndIndex(value:int):void
text property
text:String [read-write]

Plain text that appears in the control. Its appearance is determined by the CSS styles of this Label control.

Any HTML tags in the text string are ignored, and appear as entered in the string. To display text formatted using HTML tags, use the htmlText property instead. If you set the htmlText property, the HTML replaces any text you had set using this propety, and the text property returns a plain-text version of the HTML text, with all HTML tags stripped out. For more information see the htmlText property.

To include the special characters left angle bracket (<), right angle bracket (>), or ampersand (&) in the text, wrap the text string in the CDATA tag. Alternatively, you can use HTML character entities for the special characters, for example, &lt;.

If you try to set this property to null, it is set, instead, to the empty string. The text property can temporarily have the value null, which indicates that the htmlText has been recently set and the corresponding text value has not yet been determined.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get text():String
    public function set text(value:String):void
textField property
protected var textField:UITextField

The internal UITextField that renders the text of this TextInput.

textHeight property
textHeight:Number [read-only]

The height of the text.

The value of the textHeight property is correct only after the component has been validated. If you set text and then immediately ask for the textHeight, you might receive an incorrect value. You should wait for the component to validate or call the validateNow() method before you get the value. This behavior differs from that of the flash.text.TextField control, which updates the value immediately.

Implementation
    public function get textHeight():Number

See also

flash.text.TextField
textWidth property
textWidth:Number [read-only]

The width of the text.

The value of the textWidth property is correct only after the component has been validated. If you set text and then immediately ask for the textWidth, you might receive an incorrect value. You should wait for the component to validate or call the validateNow() method before you get the value. This behavior differs from that of the flash.text.TextField control, which updates the value immediately.

Implementation
    public function get textWidth():Number

See also

flash.text.TextField
Constructor detail
TextInput () constructor
public function TextInput()

Constructor.

Method detail
getLineMetrics () method
public function getLineMetrics(lineIndex:int):TextLineMetrics

Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control. The component must be validated to get a correct number. If you set the text or htmlText property and then immediately call getLineMetrics() you may receive an incorrect value. You should either wait for the component to validate or call validateNow(). This is behavior differs from that of the flash.text.TextField class, which updates the value immediately.

Parameters
lineIndex:int — The zero-based index of the line for which to get the metrics.

Returns
TextLineMetrics

See also

flash.text.TextField
flash.text.TextLineMetrics
setSelection () method
public function setSelection(beginIndex:int, endIndex:int):void

Selects the text in the range specified by the parameters. If the control is not in focus, the selection highlight will not show until the control gains focus. Also, if the focus is gained by clicking on the control, any previous selection would be lost. If the two parameter values are the same, the new selection is an insertion point.

Parameters
beginIndex:int — The zero-based index of the first character in the selection; that is, the first character is 0, the second character is 1, and so on.
endIndex:int — The zero-based index of the position after the last character in the selection (equivalent to the one-based index of the last character). If the parameter is 5, the last character in the selection, for example, is the fifth character. When the TextInput control gets the focus, the selection is visible if the selectionBeginIndex and selectionEndIndex properties are both set.
Event detail
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched when text in the TextInput control changes through user input or data binding. This event does not occur if you use ActionScript code to change the text.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
enter event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.ENTER

Dispatched when the user presses the Enter key.

The FlexEvent.ENTER constant defines the value of the type property of the event object for a enter event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
textInput event
Event object type: flash.events.TextEvent
TextEvent.type property = flash.events.TextEvent.TEXT_INPUT

Dispatched when the user types, deletes, or pastes text into the control.

Defines the value of the type property of a textInput event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | true; call the preventDefault() method to cancel default behavior.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The text field into which characters are being entered. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
text | The character or sequence of characters entered by the user.
Examples
TextInputExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the TextInput control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="TextInput Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10">

        <mx:TextInput id="src" text="Hello World!"/>

        <mx:Button label="Copy Text" click="dest.text = src.text"/>

        <mx:TextInput id="dest"/>

    </mx:Panel>
</mx:Application>


mx.controls.TileList (Flex™ 2 Language Reference)

Class TileList | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class TileList
Inheritance | TileList Inheritance TileBase Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The TileList control displays a number of items laid out in tiles. It displays a scroll bar on one of its axes to access all items in the list, depending on the direction property. You can set the size of the tiles by using the rowHeight or columnWidth properties. Alternatively, Flex measures the item renderer for the first item in the dataProvider and uses that size for all tiles.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:TileList> tag inherits all of the tag attributes of its superclass, but ignores the variableRowHeight and wordWrap tag attributes. It adds no additional tag attributes.

  <mx:TileList/>

Default MXML Property dataProvider

View the examples.

See also

Using Data-Driven Controls
Example: Using an item renderer with the TileList and HorizontalList controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String The direction in which this control lays out its children. | TileBase
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
Inherited | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
Inherited | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
Inherited | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelField : String The name of the field in the data provider items to display as the label. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxColumns : int The maximum number of columns that the control can have. | TileBase
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxRows : int The maximum number of rows that the control can have. | TileBase
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TileList()
Constructor.
TileList
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawTileBackground(s:Sprite, rowIndex:int, columnIndex:int, width:Number, height:Number, color:uint, item:IListItemRenderer):DisplayObject
Draws the background for an individual tile.
TileBase
Inherited
drawTileBackgrounds():void
Draws the backgrounds, if any, behind all of the tiles.
TileBase
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
Inherited
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
Inherited | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
Inherited | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors to use for the backgrounds of the items in the list. | ListBase
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | rollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user rolls over it. | ListBase
Inherited | selectionColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user selects it. | ListBase
Inherited | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the component is disabled. | ListBase
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
Inherited | selectionEasingFunction | Type: Function CSS Inheritance: no The easingFunction for the selection effect. | ListBase
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user rolls over a it. | ListBase
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user selects it. | ListBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
TileList () constructor
public function TileList()

Constructor.

Examples
TileListExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the TileList Control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

             [Bindable]
             [Embed(source="assets/Nokia_6630.png")]
             public var phone1:Class;

             [Bindable]
             [Embed(source="assets/Nokia_6680.png")]
             public var phone2:Class;

             [Bindable]
             [Embed(source="assets/Nokia_7610.png")]
             public var phone3:Class;

             [Bindable]
             [Embed(source="assets/Nokia_lg_v_keypad.png")]
             public var phone4:Class;

             [Bindable]
             [Embed(source="assets/Nokia_sm_v_keypad.png")]
             public var phone5:Class;
        ]]>
    </mx:Script>

    <mx:Panel title="TileList Control Example" height="100%" width="100%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%" color="blue"
            text="A TileList control displays items in rows and columns."/>

        <mx:TileList id="CameraSelection" height="250" width="300"
            maxColumns="2" rowHeight="225" columnWidth="125">
            <mx:dataProvider>
                <mx:Array>
                    <mx:Object label="Nokia 6630" icon="{phone1}"/>
                    <mx:Object label="Nokia 6680" icon="{phone2}"/>
                    <mx:Object label="Nokia 7610" icon="{phone3}"/>
                    <mx:Object label="Nokia LGV" icon="{phone4}"/>
                    <mx:Object label="Nokia LMV" icon="{phone5}"/>
                </mx:Array>
            </mx:dataProvider>
        </mx:TileList>

    </mx:Panel>
</mx:Application>


mx.controls.ToggleButtonBar (Flex™ 2 Language Reference)

Class ToggleButtonBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class ToggleButtonBar
Inheritance | ToggleButtonBar Inheritance ButtonBar Inheritance NavBar Inheritance Box Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | TabBar

The ToggleButtonBar control defines a horizontal or vertical group of buttons that maintain their selected or deselected state. Only one button in the ToggleButtonBar control can be in the selected state. This means that when a user selects a button in a ToggleButtonBar control, the button stays in the selected state until the user selects a different button.

If you set the toggleOnClick property of the ToggleButtonBar container to true, selecting the currently selected button deselects it. By default the toggleOnClick property is set to false.

You can use the ButtonBar control to define a group of push buttons.

The typical use for a toggle button is for maintaining selection among a set of options, such as switching between views in a ViewStack container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ToggleButtonBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:ToggleButtonBar
    Properties
    selectedIndex="0"
    toggleOnClick="false|true"

    Styles
    selectedButtonTextStyleName="Name of CSS style declaration that specifies styles for the text of the selected button.">
    ...
       child tags
    ...
  </mx:ToggleButtonBar>

View the examples.

See also

ButtonBar and ToggleButtonBar controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | dataProvider : Object Data used to populate the navigator control. | NavBar
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | direction : String The direction in which this Box container lays out its children. | Box
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | iconField : String Name of the field in the dataProvider object to display as the icon for each navigation item. | NavBar
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labelField : String Name of the field in the dataProvider object to display as the label for each navigation item. | NavBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | selectedIndex : int Index of the selected button. | ToggleButtonBar
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | toggleOnClick : Boolean Specifies whether the currently selected button can be deselected by the user. | ToggleButtonBar
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | toolTipField : String Name of the the field in the dataProvider object to display as the tooltip label. | NavBar
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ToggleButtonBar()
Constructor.
ToggleButtonBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
pixelsToPercent(pxl:Number):Number
Method used to convert number of pixels to a percentage relative to the contents of this container.
Box
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void Handles the MouseEvent.CLICK event for the items in the NavBar control. | NavBar
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | createNavItem(label:String, icon:Class = null):IFlexDisplayObject Creates the individual navigator items. | NavBar
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | hiliteSelectedNavItem(index:int):void Highlights the selected navigator item. | NavBar
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default sizes and minimum and maximum values of the Box container. | Box
Inherited | resetNavItems():void Resets the navigator bar to its default state. | NavBar
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Sets the size and position of each child of the Box container. | Box
Inherited | updateNavItemIcon(index:int, icon:Class):void Resets the icon of a navigator item in the NavBar control. | NavBar
Inherited | updateNavItemLabel(index:int, label:String):void Sets the label property of a navigator item in the NavBar control. | NavBar
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when a user clicks a button. | ButtonBar
Inherited | itemClick | Dispatched when a navigation item is selected. | NavBar
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | buttonHeight | Type: Number Format: Length CSS Inheritance: no Height of each button, in pixels. | ButtonBar
Inherited | buttonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the buttons. | ButtonBar
Inherited | buttonWidth | Type: Number Format: Length CSS Inheritance: no Width of each button, in pixels. | ButtonBar
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | firstButtonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the first button. | ButtonBar
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ButtonBar
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ButtonBar
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
Inherited | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of the tabs. | ButtonBar
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. | ButtonBar
Inherited | lastButtonStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the last button. | ButtonBar
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Box
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Box
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | selectedButtonTextStyleName | Type: String CSS Inheritance: no Name of CSS style declaration that specifies styles for the text of the selected button. | ToggleButtonBar
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of the tabs. | ButtonBar
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. | ButtonBar
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
selectedIndex property
selectedIndex:int [read-write]

Index of the selected button. Indexes are in the range of 0, 1, 2, ... , n - 1, where n is the number of buttons.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
toggleOnClick property
toggleOnClick:Boolean [read-write]

Specifies whether the currently selected button can be deselected by the user. By default, the currently selected button gets deselected automatically only when another button in the group is selected. Setting this property to true lets the user deselect it. When the currently selected button is deselected, the selectedIndex property is set to -1.

The default value is false.

Implementation
    public function get toggleOnClick():Boolean
    public function set toggleOnClick(value:Boolean):void
Constructor detail
ToggleButtonBar () constructor
public function ToggleButtonBar()

Constructor.

Examples
ToggleButtonBarExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the ToggleButtonBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.events.ItemClickEvent;

            // Event handler function to print a message
            // describing the selected Button control.
            private function clickHandler(event:ItemClickEvent):void {
                myTA.text="Selected button index: " + String(event.index) +
                    "\n" + "Selected button label: " + event.label;
            }
        ]]>
    </mx:Script>

    <mx:Panel title="ToggleButtonBar Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="Select a button in the ToggleButtonBar control."/>

        <mx:TextArea id="myTA" width="100%" height="100%"/>

        <mx:ToggleButtonBar horizontalGap="5" itemClick="clickHandler(event);">
            <mx:dataProvider>
                <mx:Array>
                    <mx:String>Flash</mx:String>
                    <mx:String>Director</mx:String>
                    <mx:String>Dreamweaver</mx:String>
                    <mx:String>ColdFusion</mx:String>
                </mx:Array>
            </mx:dataProvider>
        </mx:ToggleButtonBar>
    </mx:Panel>
</mx:Application>


mx.controls.ToolTip (Flex™ 2 Language Reference)

Class ToolTip | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls
Class | public class ToolTip
Inheritance | ToolTip Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IToolTip
Subclasses | SliderDataTip

The ToolTip control lets you provide helpful information to your users. When a user moves the mouse pointer over a graphical component, the ToolTip control pops up and displays text that provides information about the component. You can use ToolTips to guide users as they work with your application or customize the ToolTip controls to provide additional functionality.

See also

mx.managers.ToolTipManager
mx.styles.CSSStyleDeclaration
About ToolTips
Creating ToolTips
Using the ToolTip Manager
Using dynamic ToolTip text
Using error tips

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxWidth : Number = 300 [static] Maximum width in pixels for new ToolTip controls. | ToolTip
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
 | text : String The text displayed by the ToolTip. | ToolTip
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | textField : UITextField The internal UITextField that renders the text of this ToolTip. | ToolTip
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ToolTip()
Constructor.
ToolTip
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. Valid values range from 0.0 to 1.0. The default value is 0.95. 		ToolTip
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. Valid values range from 0.0 to 1.0. The default value is 1.0. 		ToolTip
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. You can have both a backgroundColor and a backgroundImage set. Some components do not have a background. The DataGrid control ignores this style. The default value is undefined, which means it is not set. If both this style and the backgroundImage style are undefined, the component has a transparent background.

For the Application container, this style specifies the background color while the application loads, and a background gradient while it is running. Flex calculates the gradient pattern between a color slightly darker than the specified color, and a color slightly lighter than the specified color.

The default skins of most Flex controls are partially transparent. As a result, the background color of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

ToolTip
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. This can be an absolute or relative URL or class. You can either have both a backgroundColor and a backgroundImage set at the same time. The background image is displayed on top of the background color. The default value is undefined, meaning "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The default skins of most Flex controls are partially transparent. As a result, the background image of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

ToolTip
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). The default value is "auto", which maintains the original size of the image. 		ToolTip
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The default value depends on the component class; if not overridden for the class, the default value is 0xB7BABC. 		ToolTip
borderSides
Type: String CSS Inheritance: no
Bounding box sides. A space-delimited String that specifies the sides of the border to show. The String can contain "left", "top", "right", and "bottom" in any order. The default value is "left top right bottom", which shows all four sides. This style is only used when borderStyle is "solid". 		ToolTip
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. The default value is mx.skins.halo.HaloBorder. 		ToolTip
borderStyle
Type: String CSS Inheritance: no
Bounding box style. The possible values are "none", "solid", "inset", and "outset". The default value depends on the component class; if not overridden for the class, the default value is "inset". The default value for most Containers is "none". 		ToolTip
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. Only used when borderStyle is set to "solid". The default value is 1. 		ToolTip
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		ToolTip
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The default value depends on the component class; if not overriden for the class, the default value is 0. The default value for ApplicationControlBar is 5. 		ToolTip
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		ToolTip
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. The default value is 0x000000. 		ToolTip
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. This style is used with borderStyle="solid". The default value is false.

Note: For drop shadows to appear on containers, set backgroundColor or backgroundImage properties. Otherwise, the shadow appears behind the container because the default background of a container is transparent.

ToolTip
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		ToolTip
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		ToolTip
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		ToolTip
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ToolTip
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		ToolTip
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		ToolTip
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ToolTip
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		ToolTip
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

ToolTip
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

ToolTip
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

ToolTip
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. Possible values are "left", "center", and "right". The default value is "center". 		ToolTip
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. If the property is set to a negative value, the shadow appears above the component. The default value is 2. 		ToolTip
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

ToolTip
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		ToolTip
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		ToolTip
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
maxWidth property
public static var maxWidth:Number = 300

Maximum width in pixels for new ToolTip controls.

text property
text:String [read-write]

The text displayed by the ToolTip.

The default value is null.

Implementation
    public function get text():String
    public function set text(value:String):void
textField property
protected var textField:UITextField

The internal UITextField that renders the text of this ToolTip.

Constructor detail
ToolTip () constructor
public function ToolTip()

Constructor.


mx.controls.Tree (Flex™ 2 Language Reference)

Class Tree | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class Tree
Inheritance | Tree Inheritance List Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IIMESupport

The Tree control lets a user view hierarchical data arranged as an expandable tree. Each item in a tree can be a leaf or a branch. A leaf item is an end point in the tree. A branch item can contain leaf or branch items, or it can be empty.

By default, a leaf is represented by a text label next to a file icon. A branch is represented by a text label next to a folder icon, with a disclosure triangle that a user can open to expose children.

The Tree class uses an ITreeDataDescriptor object to parse and manipulate the data provider. The default tree data descriptor, an object of the DefaultDataDescriptor class, supports XML and Object classes; an Object class data provider must have all children in children fields.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Tree> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Tree
    Properties
    dataDescriptor="Instance of DefaultDataDescriptor"
    dataProvider="null"
    dragMoveEnabled="true|false"
    firstVisibleItem="First item in the control"
    hasRoot="false|true"
    itemIcons="null"
    maxHorizontalScrollPosition="0"
    openItems="null"
    showRoot="true|false"

    Styles
    alternatingItemColors="undefined"
    backgroundDisabledColor="0xDDDDDD"
    defaultLeafIcon="TreeNodeIcon in assets.swf"
    depthColors="undefined"
    disclosureClosedIcon="TreeDisclosureClosed in assets.swf"
    disclosureOpenIcon="TreeDisclosureOpen in assets.swf"
    folderClosedIcon="TreeFolderClosed in assets.swf"
    folderOpenIcon="TreeFolderOpen in assets.swf"
    indentation="17"
    openDuration="250"
    openEasingFunction="undefined"
    paddingLeft="2"
    paddingRight="0"
    rollOverColor="0xAADEFF"
    selectionColor="0x7FCDFE"
    selectionDisabledColor="0xDDDDDD"
    selectionEasingFunction="undefined"
    textRollOverColor="0x2B333C"
    textSelectedColor="0x2B333C"

    Events
    change="No default"
    itemClose="No default"
    itemOpen="No default"
    itemOpening="No default"
  />

Default MXML Property dataProvider

View the examples.

See also

mx.controls.treeClasses.ITreeDataDescriptor
mx.controls.treeClasses.DefaultDataDescriptor
Using Data-Driven Controls
Example: Using an item renderer with a Tree control
Example: Using a custom item editor with a Tree control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number The baseline position for the control. | List
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
 | dataDescriptor : ITreeDataDescriptor Tree delegates to the data descriptor for information about the data. | Tree
 | dataProvider : Object An object that contains the data to be displayed. | Tree
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
 | dragMoveEnabled : Boolean Indicates that items can be moved instead of just copied from the Tree control as part of a drag-and-drop operation. | Tree
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | editable : Boolean = false A flag that indicates whether or not the user can edit items in the data provider. | List
Inherited | editedItemPosition : Object The column and row index of the item renderer for the data provider item being edited, if any. | List
Inherited | editedItemRenderer : IListItemRenderer A reference to the item renderer in the DataGrid control whose item is currently being edited. | List
Inherited | editorDataField : String = "text" The name of the property of the item editor that contains the new data for the list item. | List
Inherited | editorHeightOffset : Number = 0 The height of the item editor, in pixels, relative to the size of the item renderer. | List
Inherited | editorUsesEnterKey : Boolean = false A flag that indicates whether the item editor uses Enter key. | List
Inherited | editorWidthOffset : Number = 0 The width of the item editor, in pixels, relative to the size of the item renderer. | List
Inherited | editorXOffset : Number = 0 The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | List
Inherited | editorYOffset : Number = 0 The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | List
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | firstVisibleItem : Object The item that is currently displayed in the top row of the tree. | Tree
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | hasRoot : Boolean [read-only] Indicates that the current dataProvider has a root item; for example, a single top node in a hierarchical structure. | Tree
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
Inherited | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
Inherited | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
Inherited | imeMode : String Specifies the IME (input method editor) mode. | List
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | itemEditor : IFactory The class factory for the item editor to use for the control, if the editable property is set to true. | List
Inherited | itemEditorInstance : IListItemRenderer A reference to the currently active instance of the item editor, if it exists. | List
 | itemIcons : Object An object that specifies the icons for the items. | Tree
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelField : String The name of the field in the data provider items to display as the label. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxHorizontalScrollPosition : Number The maximum value for the maxHorizontalScrollPosition property for the Tree control. | Tree
Inherited | maxVerticalScrollPosition : Number The maximum value for the verticalScrollPosition property. | ScrollControlBase
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | openItems : Object The items that have been opened or set opened. | Tree
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rendererIsEditor : Boolean = false Specifies whether the item renderer is also an item editor. | List
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
 | showRoot : Boolean Sets the visibility of the root item. | Tree
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Tree()
Constructor.
Tree
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createItemEditor(colIndex:int, rowIndex:int):void
Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.
List
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
destroyItemEditor():void
Closes an item editor that is currently open on an item.
List
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
expandChildrenOf(item:Object, open:Boolean):void
Opens or closes all the tree items below the specified item.
Tree
expandItem(item:Object, open:Boolean, animate:Boolean = false, dispatchEvent:Boolean = false, cause:Event = null):void
Opens or closes a branch item.
Tree
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
getParentItem(item:Object):*
Returns the known parent of a child item.
Tree
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
isItemOpen(item:Object):Boolean
Returns true if the specified item branch is open (is showing its children).
Tree
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
setItemIcon(item:Object, iconID:Class, iconID2:Class):void
Sets the associated icon for the item.
Tree
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
Inherited
drawRowBackground(s:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int):void
Draws a row background at the position and height specified.
List
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
endEdit(reason:String):Boolean
Stops the editing of an item in the data provider.
List
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
initListData(item:Object, treeListData:TreeListData):void
Initializes a TreeListData object that is used by the tree item renderer.
Tree
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
Inherited
layoutEditor(x:int, y:int, w:int, h:int):void
Positions the item editor instance at the suggested position with the suggested dimensions.
List
Inherited
makeListData(data:Object, uid:String, rowNum:int):BaseListData
Creates a new ListData instance and populates the fields based on the input data provider item.
List
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
Inherited
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the user selects a tree item. | Tree
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
 | itemClose | Dispatched when a branch is closed or collapsed. | Tree
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
Inherited | itemEditBegin | Dispatched when the editedItemPosition property is set and the item can be edited. | List
Inherited | itemEditBeginning | Dispatched when the user releases the mouse button while over an item, tabs to the List or within the List, or in any other way attempts to edit an item. | List
Inherited | itemEditEnd | Dispatched when an item editing session is ending for any reason. | List
Inherited | itemFocusIn | Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the List control or navigates to the item using a keyboard. | List
Inherited | itemFocusOut | Dispatched when an item renderer loses the focus, which can occur if the user clicks another item in the List control or outside the list, or uses the keyboard to navigate to another item in the List control or outside the List control. | List
 | itemOpen | Dispatched when a branch is opened or expanded. | Tree
 | itemOpening | Dispatched when a branch open or close is initiated. | Tree
Inherited | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
Inherited | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
 | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes Colors for rows in an alternating pattern. Value can be an Array of two of more colors. Used only if the backgroundColor property is not specified. The default value is undefined. | Tree
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
 | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. The global default value is undefined. The default value for List controls is 0xDDDDDD (light gray). If a Container is disabled, the background is dimmed, and the degree of dimming is controlled by the disabledOverlayAlpha style. | Tree
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
 | defaultLeafIcon | Type: Class Format: EmbeddedFile CSS Inheritance: no Specifies the default icon for a leaf item. In MXML, you can use the following syntax to set this property: defaultLeafIcon="@Embed(source='c.jpg');" The default value is TreeNodeIcon in assets.swf. | Tree
 | depthColors | Type: Array Format: Color CSS Inheritance: yes Array of colors used in the Tree control, in descending order. The default value is undefined. | Tree
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
 | disclosureClosedIcon | Type: Class Format: EmbeddedFile CSS Inheritance: no Specifies the icon that is displayed next to a parent item that is closed so that its children are not displayed (the subtree is collapsed). The default value is TreeDisclosureClosed in assets.swf. | Tree
 | disclosureOpenIcon | Type: Class Format: EmbeddedFile CSS Inheritance: no Specifies the icon that is displayed next to a parent item that is open so that its children are displayed. The default value is TreeDisclosureOpen in assets.swf. | Tree
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
 | folderClosedIcon | Type: Class Format: EmbeddedFile CSS Inheritance: no Specifies the folder closed icon for a branch item of the tree. In MXML, you can use the following syntax to set this property: folderClosedIcon="@Embed(source='b.jpg');" The default value is TreeFolderClosed in assets.swf. | Tree
 | folderOpenIcon | Type: Class Format: EmbeddedFile CSS Inheritance: no Specifies the folder open icon for a branch item of the tree. In MXML, you can use the following syntax to set this property: folderOpenIcon="@Embed(source='a.jpg');" The default value is TreeFolderOpen in assets.swf. | Tree
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
 | indentation | Type: Number CSS Inheritance: no Indentation for each tree level, in pixels. The default value is 17. | Tree
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | openDuration | Type: Number Format: Time CSS Inheritance: no Length of an open or close transition, in milliseconds. The default value is 250. | Tree
 | openEasingFunction | Type: Function CSS Inheritance: no Easing function to control component tweening. The default value is undefined. | Tree
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
 | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. The default value for the Tree control is 2. | Tree
 | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. The default value is 0. The default value for a Button and CheckBox control is 3. The default value for the ComboBox control is 5. The default value for the Form container is 16. | Tree
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | rollOverColor | Type: uint Format: Color CSS Inheritance: yes Color of the background when the user rolls over the link. The default value is undefined. | Tree
 | selectionColor | Type: uint Format: Color CSS Inheritance: yes Color of the background when the user selects the link. The default value is undefined. | Tree
 | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes Specifies the disabled color of a list item. The default value is 0xDDDDDD. | Tree
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
 | selectionEasingFunction | Type: Function CSS Inheritance: no Reference to an easingFunction function used for controlling programmatic tweening. The default value is undefined. | Tree
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
 | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Color of the text when the user rolls over a row. The default value is 0x2B333C. | Tree
 | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Color of the text when the user selects a row. The default value is 0x2B333C. | Tree
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
dataDescriptor property
dataDescriptor:ITreeDataDescriptor [read-write]

Tree delegates to the data descriptor for information about the data. This data is then used to parse and move about the data source.

When you specify this property as an attribute in MXML you must use a reference to the data descriptor, not the string name of the descriptor. Use the following format for the property:

<mx:Tree id="tree" dataDescriptor="{new MyCustomTreeDataDescriptor()}"/>>

Alternatively, you can specify the property in MXML as a nested subtag, as the following example shows:

<mx:Tree>
  <mx:dataDescriptor>
  <myCustomTreeDataDescriptor>

The default value is an internal instance of the DefaultDataDescriptor class.

Implementation
    public function get dataDescriptor():ITreeDataDescriptor
    public function set dataDescriptor(value:ITreeDataDescriptor):void
dataProvider property
dataProvider:Object [read-write]

An object that contains the data to be displayed. When you assign a value to this property, the Tree class handles the source data object as follows:

  • A String containing valid XML text is converted to an XMLListCollection.
  • An XMLNode is converted to an XMLListCollection.
  • An XMLList is converted to an XMLListCollection.
  • Any object that implements the ICollectionView interface is cast to an ICollectionView.
  • An Array is converted to an ArrayCollection.
  • Any other type object is wrapped in an Array with the object as its sole entry.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
dragMoveEnabled property
dragMoveEnabled:Boolean [read-write]

Indicates that items can be moved instead of just copied from the Tree control as part of a drag-and-drop operation.

The default value is true.

Implementation
    public function get dragMoveEnabled():Boolean
    public function set dragMoveEnabled(value:Boolean):void
firstVisibleItem property
firstVisibleItem:Object [read-write]

The item that is currently displayed in the top row of the tree. Based on how the branches have been opened and closed and scrolled, the top row might hold, for example, the ninth item in the list of currently viewable items which in turn represents some great-grandchild of the root. Setting this property is analogous to setting the verticalScrollPosition of the List control. If the item isn't currently viewable, for example, because it is under a nonexpanded item, setting this property has no effect.

NOTE: In Flex 1.0 this property was typed as XMLNode although it really was either an XMLNode or TreeNode. In 2.0, it is now the generic type Object and will return an object of the same type as the data contained in the dataProvider.

The default value is the first item in the Tree control.

This property can be used as the source for data binding.

Implementation
    public function get firstVisibleItem():Object
    public function set firstVisibleItem(value:Object):void
hasRoot property
hasRoot:Boolean [read-only]

Indicates that the current dataProvider has a root item; for example, a single top node in a hierarchical structure. XML and Object are examples of types that have a root. Lists and arrays do not.

Implementation
    public function get hasRoot():Boolean

See also

showRoot
itemIcons property
public var itemIcons:Object

An object that specifies the icons for the items. Each entry in the object has a field name that is the item UID and a value that is an an object with the following format:

   {iconID: Class, iconID2: Class}
The iconID field value is the class of the icon for a closed or leaf item and the iconID2 is the class of the icon for an open item.

This property is intended to allow initialization of item icons. Changes to this array after initialization are not detected automatically. Use the setItemIcon() method to change icons dynamically.

The default value is undefined.

See also

setItemIcon()
maxHorizontalScrollPosition property
maxHorizontalScrollPosition:Number [read-write]

The maximum value for the maxHorizontalScrollPosition property for the Tree control. Unlike the maxHorizontalScrollPosition property in the List control, this property is modified by the Tree control as items open and close and as items in the tree otherwise become visible or are hidden (for example, by scrolling).

If you set this property to the widest known item in the dataProvider, the Tree control modifies it so that even if that widest item is four levels down in the tree, the user can scroll to see it. As a result, although you read back the same value for the maxHorizontalScrollPosition property that you set, it isn't necessarily the actual value used by the Tree control.

The default value is 0.

Implementation
    public function get maxHorizontalScrollPosition():Number
    public function set maxHorizontalScrollPosition(value:Number):void
openItems property
openItems:Object [read-write]

The items that have been opened or set opened.

The default value is null.

Implementation
    public function get openItems():Object
    public function set openItems(value:Object):void
showRoot property
showRoot:Boolean [read-write]

Sets the visibility of the root item. If the dataProvider data has a root node, and this is set to false, the Tree control does not display the root item. Only the decendants of the root item are displayed. This flag has no effect on non-rooted dataProviders, such as List and Array.

The default value is true.

Implementation
    public function get showRoot():Boolean
    public function set showRoot(value:Boolean):void

See also

hasRoot
Constructor detail
Tree () constructor
public function Tree()

Constructor.

Method detail
expandChildrenOf () method
public function expandChildrenOf(item:Object, open:Boolean):void

Opens or closes all the tree items below the specified item.

Parameters
item:Object — the starting item
open:Boolean — toggles an open or close operation
expandItem () method
public function expandItem(item:Object, open:Boolean, animate:Boolean = false, dispatchEvent:Boolean = false, cause:Event = null):void

Opens or closes a branch item. When a branch item opens, it restores the open and closed states of its child branches if they were already opened.

Parameters
item:Object — Item to affect.
open:Boolean — Specify true to open, false to close.
animate:Boolean (default = false) — Specify true to animate the transition. (Note: If a branch has over 20 children, it does not animate the first time it opens, for performance reasons.)
dispatchEvent:Boolean (default = false) — Controls whether the tree fires an open event after the open animation is complete.
cause:Event (default = null) — The event, if any, that initiated the item open action.
getParentItem () method
public function getParentItem(item:Object):*

Returns the known parent of a child item. This method returns a value only if the item was or is currently visible. Top level items have a parent with the value null.

Parameters
item:Object — item for which to get the parent

Returns
* — The parent of the item
initListData () method
protected function initListData(item:Object, treeListData:TreeListData):void

Initializes a TreeListData object that is used by the tree item renderer.

Parameters
item:Object — The item to be rendered.
treeListData:TreeListData — The TreeListDataItem to use in rendering the item.
isItemOpen () method
public function isItemOpen(item:Object):Boolean

Returns true if the specified item branch is open (is showing its children).

Parameters
item:Object — Item to inspect.

Returns
Boolean — True if open, false if not.
setItemIcon () method
public function setItemIcon(item:Object, iconID:Class, iconID2:Class):void

Sets the associated icon for the item. Calling this method overrides the iconField and iconFunction properties for this item if it is a leaf item. Branch items don't use the iconField and iconFunction properties. They use the folderOpenIcon and folderClosedIcon properties.

Parameters
item:Object — Item to affect.
iconID:Class — Linkage ID for the closed (or leaf) icon.
iconID2:Class — Linkage ID for the open icon.
Event detail
change event
Event object type: flash.events.Event
Event.type property = flash.events.Event.CHANGE

Dispatched when the user selects a tree item.

Defines the value of the type property of a change event object.

This event has the following properties:

Property | Value
bubbles | true
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object that has had its value modified. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
itemClose event
Event object type: mx.events.TreeEvent
TreeEvent.type property = mx.events.TreeEvent.ITEM_CLOSE

Dispatched when a branch is closed or collapsed.

The TreeEvent.ITEM_CLOSE event type constant indicates that a tree branch closed or collapsed.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
itemRenderer | The ListItemRenderer for the node that closed
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
triggerEvent | If the node closed in response to a user action, identifies it as a keyboard action or a mouse action.
node | the Tree node that closed
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | TreeEvent.ITEM_CLOSE
itemOpen event
Event object type: mx.events.TreeEvent
TreeEvent.type property = mx.events.TreeEvent.ITEM_OPEN

Dispatched when a branch is opened or expanded.

The TreeEvent.ITEM_OPEN event type constant indicates that a tree branch opened or expaneded.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
itemRenderer | The ListItemRenderer for the node that opened
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
triggerEvent | If the node opened in response to a user action, identifies it as a keyboard action or a mouse action.
node | the Tree node that opened
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | TreeEvent.ITEM_OPEN
itemOpening event
Event object type: mx.events.TreeEvent
TreeEvent.type property = mx.events.TreeEvent.ITEM_OPENING

Dispatched when a branch open or close is initiated.

The TreeEvent.ITEM_OPENING event type constant is dispatched immediately before a tree opens or closes.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
animate | Whether to animate the opening or closing operation.
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dispatchEvent | Whether to dispatch an ITEM_OPEN or ITEM_CLOSE event after the open or close animation is complete. true
itemRenderer | The ListItemRenderer for the node that opened
node | the Tree node that opened
opening | true if the item is opening, false if it is closing.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | If the node opened in response to a user action, identifies it as a keyboard action or a mouse action.
type | TreeEvent.ITEM_OPENING
Examples
TreeExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Tree control example. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            [Bindable]
            public var selectedNode:Object;

            // Event handler for the Tree control change event.
            public function treeChanged(event:Event):void {
                selectedNode=Tree(event.target).selectedItem;
            }
        ]]>
    </mx:Script>

    <mx:XMLList id="treeData">
        <node label="Mail Box">
            <node label="Inbox">
                <node label="Marketing"/>
                <node label="Product Management"/>
                <node label="Personal"/>
            </node>
            <node label="Outbox">
                <node label="Professional"/>
                <node label="Personal"/>
            </node>
            <node label="Spam"/>
            <node label="Sent"/>
        </node>
    </mx:XMLList>

    <mx:Panel title="Tree Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="Select a node in the Tree control."/>

        <mx:HDividedBox width="100%" height="100%">
            <mx:Tree id="myTree" width="50%" height="100%" labelField="@label"
                showRoot="false" dataProvider="{treeData}" change="treeChanged(event)"/>
            <mx:TextArea height="100%" width="50%"
                text="Selected Item: {selectedNode.@label}"/>
        </mx:HDividedBox>

    </mx:Panel>
</mx:Application>


mx.controls.VideoDisplay (Flex™ 2 Language Reference)

Class VideoDisplay | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class VideoDisplay
Inheritance | VideoDisplay Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The VideoDisplay control lets you play an FLV file in a Flex application. It supports progressive download over HTTP, streaming from the Flash Media Server, and streaming from a Camera object.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:VideoDisplay> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:VideoDisplay
    Properties
    autoBandWidthDetection="false|true"
    autoPlay="true|false"
    autoRewind="true|false"
    bufferTime="0.1"
    cuePointManagerClass=""
    cuePoints=""
    idleTimeout="300000"
    live="false|true"
    maintainAspectRatio="true|false"
    playheadTime=""
    playheadUpdateInterval="250"
    progressInterval="250"
    source=""
    totalTime=""
    volume="0.75"

    Styles
    backgroundAlpha="1.0"
    backgroundColor="0x000000"
    backgroundImage="undefined"
    backgroundSize="undefined"
    borderColor="undefined"
    borderSides="left top right bottom"
    borderSkin="ClassReference('mx.skins.halo.HaloBorder')"
    borderStyle="none"
    borderThickness="1"
    cornerRadius="0"
    dropShadowColor="0x000000"
    dropShadowEnabled="false|true"
    shadowDirection="center"
    shadowDistance="2"

    Events
    close="No default"
    complete="No default"
    cuePoint="No default"
    playheadUpdate="No default"
    progress="No default"
    ready="No default"
    rewind="No default"
    stateChange="No default"
   />

View the examples.

See also

VideoDisplay control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | autoBandWidthDetection : Boolean Specifies whether the VideoDisplay control should use the built-in automatic bandwidth detection feature. | VideoDisplay
 | autoPlay : Boolean Specifies whether the video should start playing immediately when the source property is set. | VideoDisplay
 | autoRewind : Boolean Specifies whether the FLV file should be rewound to the first frame when play stops, either by calling the stop() method or by reaching the end of the stream. | VideoDisplay
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
 | borderMetrics : EdgeMetrics [read-only] Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | VideoDisplay
 | bufferTime : Number Number of seconds of video to buffer in memory before starting to play the video file. | VideoDisplay
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
 | bytesLoaded : int [read-only] Number of bytes already loaded that are available for playing. | VideoDisplay
 | bytesTotal : int [read-only] Total number of bytes to load. | VideoDisplay
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | cuePointManager : Object [read-only] The instance of the CuePointManager class associated with the VideoPlayer control. | VideoDisplay
 | cuePointManagerClass : Class Cue point manager to use. | VideoDisplay
 | cuePoints : Array The Array of cue points associated with the control. | VideoDisplay
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
 | idleTimeout : int Specifies the amount of time, in milliseconds, that the connection is idle (playing is paused or stopped) before the connection to the Flash Media Server is stopped. | VideoDisplay
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | live : Boolean Specifies whether the control is streaming a live feed. | VideoDisplay
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
 | maintainAspectRatio : Boolean Specifies whether the control should maintain the original aspect ratio while resizing the video. | VideoDisplay
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | playheadTime : Number Playhead position, measured in seconds, since the video starting playing. | VideoDisplay
 | playheadUpdateInterval : int Specifies the amount of time, in milliseconds, between each playheadUpdate event. | VideoDisplay
 | playing : Boolean [read-only] If true, the media is currently playing. | VideoDisplay
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
 | progressInterval : int Specifies the amount of time, in milliseconds, between each progress event. | VideoDisplay
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
 | source : String Relative path and filename of the FLV file to stream. | VideoDisplay
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | state : String [read-only] The current state of the VideoDisplay control. | VideoDisplay
 | stateResponsive : Boolean [read-only] Specifies whether the VideoDisplay control is in a responsive state, true, or in the unresponsive state, false. | VideoDisplay
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
 | totalTime : Number Total length of the media, in seconds. | VideoDisplay
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | videoHeight : int [read-only] Height of the loaded FLV file. | VideoDisplay
 | videoWidth : int [read-only] Width of the loaded FLV file. | VideoDisplay
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
 | volume : Number The volume level, specified as an value between 0 and 1. | VideoDisplay
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | border : IFlexDisplayObject The border object for the control. | VideoDisplay
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
VideoDisplay()
Constructor.
VideoDisplay
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
attachCamera(camera:Camera):void
Specifies whether to play a video stream from a camera.
VideoDisplay
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
close():void
Forces the close of an input stream and connection to Flash Media Server.
VideoDisplay
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
load():void
Loads the media file without playing it.
VideoDisplay
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
pause():void
Pauses playback without moving the playhead.
VideoDisplay
play():void
Plays the media file.
VideoDisplay
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
stop():void
Stops playback.
VideoDisplay
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
 | createBorder():void Creates the border for this component. | VideoDisplay
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of the borders. | VideoDisplay
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | close | Dispatched when the NetConnection object is closed, whether by timing out or by calling the close() method. | VideoDisplay
 | complete | Dispatched when the playhead reaches the end of the FLV file. | VideoDisplay
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
 | cuePoint | Dispatched when the value of a cue point's time property is equal to the current playhead location. | VideoDisplay
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
 | playheadUpdate | Dispatched every 0.25 seconds while the video is playing. | VideoDisplay
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
 | progress | Dispatched continuously until the FLV file has downloaded completely. | VideoDisplay
 | ready | Dispatched when the FLV file is loaded and ready to play. | VideoDisplay
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
 | rewind | Dispatched when the control autorewinds. | VideoDisplay
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
 | stateChange | Dispatched when the state of the control changes. | VideoDisplay
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. Valid values range from 0.0 to 1.0. The default value is 1.0. 		VideoDisplay
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. You can have both a backgroundColor and a backgroundImage set. Some components do not have a background. The DataGrid control ignores this style. The default value is undefined, which means it is not set. If both this style and the backgroundImage style are undefined, the component has a transparent background.

For the Application container, this style specifies the background color while the application loads, and a background gradient while it is running. Flex calculates the gradient pattern between a color slightly darker than the specified color, and a color slightly lighter than the specified color.

The default skins of most Flex controls are partially transparent. As a result, the background color of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

VideoDisplay
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. This can be an absolute or relative URL or class. You can either have both a backgroundColor and a backgroundImage set at the same time. The background image is displayed on top of the background color. The default value is undefined, meaning "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The default skins of most Flex controls are partially transparent. As a result, the background image of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

VideoDisplay
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). The default value is "auto", which maintains the original size of the image. 		VideoDisplay
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The default value depends on the component class; if not overridden for the class, the default value is 0xB7BABC. 		VideoDisplay
borderSides
Type: String CSS Inheritance: no
Bounding box sides. A space-delimited String that specifies the sides of the border to show. The String can contain "left", "top", "right", and "bottom" in any order. The default value is "left top right bottom", which shows all four sides. This style is only used when borderStyle is "solid". 		VideoDisplay
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. The default value is mx.skins.halo.HaloBorder. 		VideoDisplay
borderStyle
Type: String CSS Inheritance: no
Bounding box style. The possible values are "none", "solid", "inset", and "outset". The default value depends on the component class; if not overridden for the class, the default value is "inset". The default value for most Containers is "none". 		VideoDisplay
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. Only used when borderStyle is set to "solid". The default value is 1. 		VideoDisplay
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The default value depends on the component class; if not overriden for the class, the default value is 0. The default value for ApplicationControlBar is 5. 		VideoDisplay
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. The default value is 0x000000. 		VideoDisplay
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. This style is used with borderStyle="solid". The default value is false.

Note: For drop shadows to appear on containers, set backgroundColor or backgroundImage properties. Otherwise, the shadow appears behind the container because the default background of a container is transparent.

VideoDisplay
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. Possible values are "left", "center", and "right". The default value is "center". 		VideoDisplay
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. If the property is set to a negative value, the shadow appears above the component. The default value is 2. 		VideoDisplay
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
autoBandWidthDetection property
autoBandWidthDetection:Boolean [read-write]

Specifies whether the VideoDisplay control should use the built-in automatic bandwidth detection feature. When false, you do not require a main.asc file on Flash Media Server (FMS) 2 to connect to FMS. When true, you need to implement a main.asc and store it in the directory structure of FMS. The main.asc file must define the following functions:

  •    application.onConnect = function(p_client, p_autoSenseBW)
   {
     //Add security code here.
     this.acceptConnection(p_client);
     if (p_autoSenseBW)
       this.calculateClientBw(p_client);
     else
       p_client.call("onBWDone");
   }
  •    application.calculateClientBw = function(p_client)
   {
     // Add code to set the clients BandWidth.
     // Use p_client.getStats() which returns bytes_in
     // and bytes_Out and check your bandWidth using
     // p_client.call("onBWCheck", result, p_client.payload).
     p_client.call("onBWDone");
   }

  •    Client.prototype.getStreamLength = function(p_streamName)
   {
     return Stream.length(p_streamName);
   }
For more information on writing main.asc, see the FMS documentation.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get autoBandWidthDetection():Boolean
    public function set autoBandWidthDetection(value:Boolean):void
autoPlay property
autoPlay:Boolean [read-write]

Specifies whether the video should start playing immediately when the source property is set. If true, the video file immediately begins to buffer and play.

Even if autoPlay is set to false, Flex starts loading the video after the initialize() method is called. For Flash Media Server, this means creating the stream and loading the first frame to display (and loading more if autoSize or aspectRatio is set to true). In the case of an HTTP download, Flex starts downloading the stream and shows the first frame.

The default value is true.

Implementation
    public function get autoPlay():Boolean
    public function set autoPlay(value:Boolean):void
autoRewind property
autoRewind:Boolean [read-write]

Specifies whether the FLV file should be rewound to the first frame when play stops, either by calling the stop() method or by reaching the end of the stream. This property has no effect for live streaming video.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get autoRewind():Boolean
    public function set autoRewind(value:Boolean):void
border property
protected var border:IFlexDisplayObject

The border object for the control.

borderMetrics property
borderMetrics:EdgeMetrics [read-only]

Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. The value of each property is equal to the thickness of one side of the border around the control, in pixels.

Implementation
    public function get borderMetrics():EdgeMetrics
bufferTime property
bufferTime:Number [read-write]

Number of seconds of video to buffer in memory before starting to play the video file. For slow connections streaming over RTMP, it is important to increase this property from the default.

The default value is 0.1.

This property can be used as the source for data binding.

Implementation
    public function get bufferTime():Number
    public function set bufferTime(value:Number):void
bytesLoaded property
bytesLoaded:int [read-only]

Number of bytes already loaded that are available for playing. The value is only useful for media loaded using HTTP.

Contains -1 when there is no input stream, when the stream is from Flash Media Server, or if the information is not yet available.

This property can be used as the source for data binding.

Implementation
    public function get bytesLoaded():int
bytesTotal property
bytesTotal:int [read-only]

Total number of bytes to load. The value is only useful for media loaded using HTTP.

Contains -1 when there is no input stream, when the stream is from Flash Media Server, or if the information is not yet available.

This property can be used as the source for data binding.

Implementation
    public function get bytesTotal():int
cuePointManager property
cuePointManager:Object [read-only]

The instance of the CuePointManager class associated with the VideoPlayer control. You can use this object to control cue points, or use the cuePoints property.

You use cue points to trigger cuePoint events when the playback of your video reaches a specified location. To set cue points, you use methods of the CuePointManager class.

Implementation
    public function get cuePointManager():Object

See also

mx.controls.videoClasses.CuePointManager
cuePointManagerClass property
cuePointManagerClass:Class [read-write]

Cue point manager to use. Set this to mx.controls.videoClasses.CuePointManager to enable cue point management.

Implementation
    public function get cuePointManagerClass():Class
    public function set cuePointManagerClass(value:Class):void

See also

mx.controls.videoClasses.CuePointManager
cuePoints property
cuePoints:Array [read-write]

The Array of cue points associated with the control. You can use this property to control cue points, or use the cuePointManager property.

You use cue points to trigger cuePoint events when the playback of your video reaches a specified location. To set cue points, you pass an Array to the cuePoints property.

Each element of the Array contains two fields:

  • The name field contains an arbitrary name of the cue point.
  • The time field contains the playhead location, in seconds, of the VideoDisplay control with which the cue point is associated.

This property can be used as the source for data binding.

Implementation
    public function get cuePoints():Array
    public function set cuePoints(value:Array):void
idleTimeout property
idleTimeout:int [read-write]

Specifies the amount of time, in milliseconds, that the connection is idle (playing is paused or stopped) before the connection to the Flash Media Server is stopped. This property has no effect on the HTTP download of FLV files. If this property is set when the stream is already idle, it restarts the idle timeout with a new value.

The default value is 300000 (five minutes).

Implementation
    public function get idleTimeout():int
    public function set idleTimeout(value:int):void
live property
live:Boolean [read-write]

Specifies whether the control is streaming a live feed. Set this property to true when streaming a live feed from Flash Media Server.

The default value is false.

Implementation
    public function get live():Boolean
    public function set live(value:Boolean):void
maintainAspectRatio property
maintainAspectRatio:Boolean [read-write]

Specifies whether the control should maintain the original aspect ratio while resizing the video.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get maintainAspectRatio():Boolean
    public function set maintainAspectRatio(value:Boolean):void
playheadTime property
playheadTime:Number [read-write]

Playhead position, measured in seconds, since the video starting playing. The event object for many of the VideoPlay events include the playhead position so that you can determine the location in the video file where the event occurred.

Setting this property to a value in seconds performs a seek operation. If the video is currently playing, it continues playing from the new playhead position. If the video is paused, it seeks to the new playhead position and remains paused. If the video is stopped, it seeks to the new playhead position and enters the paused state. Setting this property has no effect with live video streams.

If the new playhead position is less than 0 or NaN, the control throws an exception. If the new playhead position is past the end of the video, or past the amount of the video file downloaded so far, then the control still attempts the seek.

If player is in an unresponsive state, it queues the request.

This property throws an exception if set when no stream is connected. Use the stateChange event and the connected property to determine when it is safe to set this property.

The default value is NaN.

This property can be used as the source for data binding.

Implementation
    public function get playheadTime():Number
    public function set playheadTime(value:Number):void
playheadUpdateInterval property
playheadUpdateInterval:int [read-write]

Specifies the amount of time, in milliseconds, between each playheadUpdate event.

If you set this property when the video is playing, the timer restarts at 0, and the next playheadUpdate event occurs after the new time interval.

The default value is 250.

Implementation
    public function get playheadUpdateInterval():int
    public function set playheadUpdateInterval(value:int):void
playing property
playing:Boolean [read-only]

If true, the media is currently playing.

This property can be used as the source for data binding.

Implementation
    public function get playing():Boolean
progressInterval property
progressInterval:int [read-write]

Specifies the amount of time, in milliseconds, between each progress event. The progress event occurs continuously until the video file downloads completely.

If you set this property when the video is downloading, the timer restarts at 0, and the next progress event occurs after the new time interval.

The default value is 250.

Implementation
    public function get progressInterval():int
    public function set progressInterval(value:int):void
source property
source:String [read-write]

Relative path and filename of the FLV file to stream.

This property can be used as the source for data binding.

Implementation
    public function get source():String
    public function set source(value:String):void
state property
state:String [read-only]

The current state of the VideoDisplay control. You set this property by calls to the load(), play(), stop(), and pause() methods, and setting the playHeadTime property.

This property can have the following values defined in the VideoEvent class: VideoEvent.BUFFERING, VideoEvent.CONNECTION_ERROR, VideoEvent.DISCONNECTED, VideoEvent.EXEC_QUEUED_CMD, VideoEvent.LOADING, VideoEvent.PAUSED, VideoEvent.PLAYING, VideoEvent.RESIZING, VideoEvent.REWINDING, VideoEvent.SEEKING, and VideoEvent.STOPPED.

The default value is VideoEvent.DISCONNECTED.

This property can be used as the source for data binding.

Implementation
    public function get state():String

See also

mx.events.VideoEvent
stateResponsive property
stateResponsive:Boolean [read-only]

Specifies whether the VideoDisplay control is in a responsive state, true, or in the unresponsive state, false. The control enters the unresponsive state when video is being loaded or is rewinding.

The control is also in a responsive state when the state property is: VideoEvent.CONNECTION_ERROR, VideoEvent.EXEC_QUEUED_CMD, VideoEvent.RESIZING, or VideoEvent.SEEKING.

If the control is unresponsive, calls to the play(), load(), stop(), and pause() methods are queued, and then executed when the control changes to the responsive state.

This property can be used as the source for data binding.

Implementation
    public function get stateResponsive():Boolean
totalTime property
totalTime:Number [read-write]

Total length of the media, in seconds. For FLV 1.0 video files, you manually set this property. For FLV 1.1 and later, the control calculates this value automatically.

This property can be used as the source for data binding.

Implementation
    public function get totalTime():Number
    public function set totalTime(value:Number):void
videoHeight property
videoHeight:int [read-only]

Height of the loaded FLV file. -1 if no FLV file loaded yet.

This property can be used as the source for data binding.

Implementation
    public function get videoHeight():int
videoWidth property
videoWidth:int [read-only]

Width of the loaded FLV file. -1 if no FLV file loaded yet.

This property can be used as the source for data binding.

Implementation
    public function get videoWidth():int
volume property
volume:Number [read-write]

The volume level, specified as an value between 0 and 1.

The default value is 0.75.

This property can be used as the source for data binding.

Implementation
    public function get volume():Number
    public function set volume(value:Number):void
Constructor detail
VideoDisplay () constructor
public function VideoDisplay()

Constructor.

Method detail
attachCamera () method
public function attachCamera(camera:Camera):void

Specifies whether to play a video stream from a camera. The video is displayed within the boundaries of the control in the application window.

Parameters
camera:Camera — A Camera object that is capturing video data.
close () method
public function close():void

Forces the close of an input stream and connection to Flash Media Server. Calling this method dispatches the close event. Typically calling this method directly is not necessary because the connection is automatically closed when the idle period times out, as defined by the idleTimeout property.

createBorder () method
protected function createBorder():void

Creates the border for this component. Normally the border is determined by the borderStyle and borderSkin styles. It must set the border property to the instance of the border.

layoutChrome () method
protected function layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void

Responds to size changes by setting the positions and sizes of the borders.

The VideoDisplay.layoutChrome() method sets the position and size of the VideoDisplay's border. In every subclass of VideoDisplay, the subclass's layoutChrome() method should call the super.layoutChrome() method, so that the border is positioned properly.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
load () method
public function load():void

Loads the media file without playing it.

This method is similar to the play() method, but it causes the file to be loaded without playing. Autoresizing will occur if appropriate. After the load and autoresize, the state of the control is set to VideoEvent.PAUSED.

pause () method
public function pause():void

Pauses playback without moving the playhead. If playback is already is paused or is stopped, this method has no effect.

To start playback again, call the play() method.

If the control is in an unresponsive state, the request is queued.

play () method
public function play():void

Plays the media file. If the file has not been loaded, it loads it. You can call this method while playback is paused, stopped, or while the control is playing.

If the control is in an unresponsive state, the request is queued.

stop () method
public function stop():void

Stops playback. If the autoRewind property is set to true, rewind to the first frame.

To start playback again, call the play() method.

If playback is already stopped, this method has no effect. If the control is in an unresponsive state, the request is queued.

Event detail
close event
Event object type: mx.events.VideoEvent
VideoEvent.type property = mx.events.VideoEvent.CLOSE

Dispatched when the NetConnection object is closed, whether by timing out or by calling the close() method. You use this event when working with Flash Media Server.

The VideoEvent.CLOSE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
complete event
Event object type: mx.events.VideoEvent
VideoEvent.type property = mx.events.VideoEvent.COMPLETE

Dispatched when the playhead reaches the end of the FLV file.

The VideoEvent.COMPLETE constant defines the value of the type property of the event object for a complete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
cuePoint event
Event object type: mx.events.CuePointEvent
CuePointEvent.type property = mx.events.CuePointEvent.CUE_POINT

Dispatched when the value of a cue point's time property is equal to the current playhead location.

The CuePointEvent.CUE_POINT constant defines the value of the type property of the event object for a cuePoint event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
cuePointName | The name of the cue point.
cuePointTime | The time of the cue point, in seconds.
cuePointType | The string "actionscript".
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
playheadUpdate event
Event object type: mx.events.VideoEvent
VideoEvent.type property = mx.events.VideoEvent.PLAYHEAD_UPDATE

Dispatched every 0.25 seconds while the video is playing. This event is not dispatched when the video is in a paused or stopped state.

The VideoEvent.PLAYHEAD_UPDATE constant defines the value of the type property of the event object for a playheadUpdate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
progress event
Event object type: flash.events.ProgressEvent

Dispatched continuously until the FLV file has downloaded completely.

You can use this event to check the number of bytes loaded or the number of bytes in the buffer. This event starts getting dispatched when the load() or play() method is called first and ends when all bytes are loaded or if there is a network error.

ready event
Event object type: mx.events.VideoEvent
VideoEvent.type property = mx.events.VideoEvent.READY

Dispatched when the FLV file is loaded and ready to play.

This event is dispatched the first time the VideoDisplay control enters a responsive state after a new FLV file is loaded by the load() or play() method. It is dispatched only once for each FLV file loaded.

The VideoEvent.READY constant defines the value of the type property of the event object for a ready event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
rewind event
Event object type: mx.events.VideoEvent
VideoEvent.type property = mx.events.VideoEvent.REWIND

Dispatched when the control autorewinds.

The VideoEvent.REWIND constant defines the value of the type property of the event object for a rewind event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

autoRewind
stateChange event
Event object type: mx.events.VideoEvent
VideoEvent.type property = mx.events.VideoEvent.STATE_CHANGE

Dispatched when the state of the control changes.

You can use this event to track when playback enters and leaves the unresponsive state (for example, in the middle of connecting, resizing, or rewinding), during which time calls to the play(), pause(), and stop() methods and writes to the playHeadTime property are queued, and then executed when the player enters the responsive state.

The VideoEvent.STATE_CHANGE constant defines the value of the type property of the event object for a stateChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
VideoDisplayExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the VideoDisplay control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Panel title="VideoDisplay Control Example" height="75%" width="75%"
        horizontalAlign="center"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

       <mx:Text width="75%" color="blue"
           text="Use the buttons to control the video. The Stop button resets the video to the beginning."/>

        <mx:VideoDisplay id="myVid" height="158" width="211" source="assets/phone.flv" autoPlay="false"/>

        <mx:HBox>
            <mx:Button label="Play" click="myVid.play();"/>
            <mx:Button label="Pause" click="myVid.pause();"/>
            <mx:Button label="Stop" click="myVid.stop();"/>
        </mx:HBox>

    </mx:Panel>
</mx:Application>


mx.controls.VRule (Flex™ 2 Language Reference)

Class VRule | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class VRule
Inheritance | VRule Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The VRule control creates a single vertical line. You typically use this control to create a dividing line within a container.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:VRule> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:VRule
    Styles
    strokeColor="0xC4CCCC"
    shadowColor="0xEEEEEE"
    strokeWidth="2"
  />

View the examples.

See also

mx.controls.HRule
HRule and VRule controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
VRule()
Constructor
VRule
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowColor
Type: uint Format: Color CSS Inheritance: yes
The shadow color of the line.
  • If strokeWidth is 1, shadowColor does nothing.
  • If strokeWidth is 2 shadowColor is the color of the right line.
  • If strokeWidth is greater than 2, shadowColor is the color of the bottom and right edges of the rectangle.
The default value is 0xEEEEEE. 		VRule
strokeColor
Type: uint Format: Color CSS Inheritance: yes
The color of the line.
  • If strokeWidth is 1, strokeColor is the color of the entire line.
  • If strokeWidth is 2, strokeColor is the color of the left line.
  • If strokeWidth is greater than 2, strokeColor is the color of the top and left edges of the rectangle.
The default value is 0xC4CCCC. 		VRule
strokeWidth
Type: Number Format: Length CSS Inheritance: yes
The thickness of the rule in pixels.
  • If strokeWidth is 1, the rule is a 1-pixel-wide line.
  • If strokeWidth is 2, the rule is two adjacent 1-pixel-wide vertical lines.
  • If strokeWidth is greater than 2, the rule is a hollow rectangle with 1-pixel-wide edges.
The default value is 2. 		VRule
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
VRule () constructor
public function VRule()

Constructor

Examples
SimpleVRule
<?xml version="1.0"?>
<!-- Simple example to demonstrate the VRule control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

   <mx:Panel title="VRule Control Example" id="myPanel" horizontalAlign="center"
       paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

      <mx:VRule rollOverEffect="WipeUp" strokeWidth="1" strokeColor="red"/>
      <mx:Label width="100%" color="blue"
          text="Move mouse over VRule control to redraw it."/>

   </mx:Panel>
</mx:Application>


mx.controls.VScrollBar (Flex™ 2 Language Reference)

Class VScrollBar | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class VScrollBar
Inheritance | VScrollBar Inheritance ScrollBar Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The VScrollBar (vertical ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area. This control extends the base ScrollBar control.

Although you can use the VScrollBar control as a stand-alone control, you usually combine it as part of another group of components to provide scrolling functionality.

A ScrollBar control consist of four parts: two arrow buttons, a track, and a thumb. The position of the thumb and the display of the arrow buttons depend on the current state of the ScrollBar control. The ScrollBar control uses four parameters to calculate its display state:

  • Minimum range value
  • Maximum range value
  • Current position - must be within the minimum and maximum range values
  • Viewport size - represents the number of items in the range that you can display at one time. The number of items must be less than or equal to the range, where the range is the set of values between the minimum range value and the maximum range value.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:VScrollBar> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:VScrollBar

    Styles
    repeatDelay="500"
    repeatInterval="35"

    Events
    scroll="No default"
  />

View the examples.

See also

mx.controls.scrollClasses.ScrollBar
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | lineScrollSize : Number Amount to scroll when an arrow button is pressed, in pixels. | ScrollBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxScrollPosition : Number Number which represents the maximum scroll position. | ScrollBar
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minScrollPosition : Number Number that represents the minimum scroll position. | ScrollBar
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | pageScrollSize : Number Amount to move the scroll thumb when the scroll bar track is pressed, in pixels. | ScrollBar
Inherited | pageSize : Number The number of lines equivalent to one page. | ScrollBar
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollPosition : Number Number that represents the current scroll position. | ScrollBar
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
VScrollBar()
Constructor.
VScrollBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setScrollProperties(pageSize:Number, minScrollPosition:Number, maxScrollPosition:Number, pageScrollSize:Number = 0):void
Sets the range and viewport size of the ScrollBar control.
ScrollBar
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | scroll | Dispatched when the ScrollBar control scrolls through user initiated action or programmatically. | VScrollBar
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollBar
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollBar
Inherited | downArrowDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when it is disabled. | ScrollBar
Inherited | downArrowDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when you click the arrow button . | ScrollBar
Inherited | downArrowOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when the mouse pointer is over the arrow button. | ScrollBar
Inherited | downArrowUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar. | ScrollBar
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | ScrollBar
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | ScrollBar
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | ScrollBar
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the repeatInterval. The default value is 500. | VScrollBar
 | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. The default value is 35. | VScrollBar
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | thumbDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar when you click the thumb. | ScrollBar
Inherited | thumbIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon for the thumb of the scroll bar. | ScrollBar
Inherited | thumbOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar when the mouse pointer is over the thumb. | ScrollBar
Inherited | thumbUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar. | ScrollBar
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | trackColors | Type: Array Format: Color CSS Inheritance: no The colors of the track, as an array of two colors. | ScrollBar
Inherited | trackSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the track of the scroll bar. | ScrollBar
Inherited | upArrowDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when it is disabled. | ScrollBar
Inherited | upArrowDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when you click the arrow button. | ScrollBar
Inherited | upArrowOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when the mouse pointer is over the arrow button. | ScrollBar
Inherited | upArrowUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar. | ScrollBar
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Inherited | THICKNESS : Number = 16 [static] The width of a vertical scrollbar, or the height of a horizontal scrollbar, in pixels. | ScrollBar
Constructor detail
VScrollBar () constructor
public function VScrollBar()

Constructor.

Event detail
scroll event
Event object type: mx.events.ScrollEvent
ScrollEvent.type property = mx.events.ScrollEvent.SCROLL

Dispatched when the ScrollBar control scrolls through user initiated action or programmatically.

The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the change in scroll position, expressed in pixels. A positive value indicates the scroll was down or to the right. A negative value indicates the scroll was up or to the left.
direction | Contains the scroll direction, either ScrollEventDirection.HORIZONTAL or ScrollEventDirection.VERTICAL.
position | Contains the new scroll position.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
VScrollBarExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the VScrollBar control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

     <mx:Script>
        <![CDATA[

            import mx.events.ScrollEvent;

            // Event handler function to display the scroll location
            // as you move the scroll thumb.
            private function myScroll(event:ScrollEvent):void
            {
                showPosition.text = "VScrollBar properties summary:" + '\n' +
                    "------------------------------------" + '\n' +
                    "Current scroll position: " + event.currentTarget.scrollPosition  + '\n' +
                    "The maximum scroll position: " + event.currentTarget.maxScrollPosition + '\n' +
                    "The minimum scroll position: " + event.currentTarget.minScrollPosition ;
            }
        ]]>
    </mx:Script>

    <mx:Panel id="panel" title="VScrollBar Control Example" height="75%" width="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="Click on the scroll bar to view its properties."/>

        <mx:VScrollBar id="bar" height="100%"
            minScrollPosition="0" maxScrollPosition="{panel.width - 20}"
            lineScrollSize="50" pageScrollSize="100"
            repeatDelay="1000" repeatInterval="500"
            scroll="myScroll(event);"/>

        <mx:TextArea height="100%" width="100%" id="showPosition" color="blue"/>

    </mx:Panel>
</mx:Application>


mx.controls.VSlider (Flex™ 2 Language Reference)

Class VSlider | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.controls
Class | public class VSlider
Inheritance | VSlider Inheritance Slider Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The VSlider control lets users select a value by moving a slider thumb between the end points of the slider track. The current value of the slider is determined by the relative location of the thumb between the end points of the slider, corresponding to the slider's minimum and maximum values.

The slider may allow a continuous range of values between its minimum and maximum values, or it may be restricted to values at concrete intervals between the minimum and maximum value. It may show tick marks at specified intervals along the track. These tick marks are independent of the allowed values of the slider. It may also use a data tip to display its current value.

The VSlider has a vertical orientation. The slider track stretches from bottom to top, and the labels and tick marks are placed to the left or right of the track.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:VSlider> tag inherits all of the tag attributes of its superclass, and adds the following tag attribute:

  <mx:VSlider
    Styles
    dataTipPlacement="top"
  />

View the examples.

See also

mx.controls.HSlider
mx.controls.sliderClasses.Slider
mx.controls.sliderClasses.SliderThumb
mx.controls.sliderClasses.SliderDataTip
mx.controls.sliderClasses.SliderLabel
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowThumbOverlap : Boolean = false If set to false, then each thumb can only be moved to the edge of the adjacent thumb. | Slider
Inherited | allowTrackClick : Boolean = true Specifies whether clicking on the track will move the slider thumb. | Slider
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | dataTipFormatFunction : Function Callback function that formats the data tip text. | Slider
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | labels : Array An array of strings used for the slider labels. | Slider
Inherited | liveDragging : Boolean = false Specifies whether live dragging is enabled for the slider. | Slider
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maximum : Number The maximum allowed value on the slider. | Slider
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minimum : Number The minimum allowed value on the slider control. | Slider
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | showDataTip : Boolean = true If set to true, show a data tip during user interaction containing the current value of the slider. | Slider
Inherited | sliderDataTipClass : Class A reference to the class to use for the data tip. | Slider
Inherited | sliderThumbClass : Class A reference to the class to use for each thumb. | Slider
Inherited | snapInterval : Number Specifies the increment value of the slider thumb as the user moves the thumb. | Slider
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | thumbCount : int The number of thumbs allowed on the slider. | Slider
Inherited | tickInterval : Number The spacing of the tick marks relative to the maximum value of the control. | Slider
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Number Contains the position of the thumb, and is a number between the minimum and maximum properties. | Slider
Inherited | values : Array An array of values for each thumb when thumbCount is greater than 1. | Slider
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
VSlider()
Constructor.
VSlider
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
getThumbAt(index:int):SliderThumb
Returns the thumb object at the given index.
Slider
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setThumbValueAt(index:int, value:Number):void
This method sets the value of a slider thumb, and updates the display.
Slider
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the amount of space that the component takes up. | Slider
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Positions the elements of the control. | Slider
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the slider changes value due to mouse or keyboard interaction. | Slider
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | thumbDrag | Dispatched when the slider's thumb is pressed and then moved by the mouse. | Slider
Inherited | thumbPress | Dispatched when the slider's thumb is pressed, meaning the user presses the mouse button over the thumb. | Slider
Inherited | thumbRelease | Dispatched when the slider's thumb is released, meaning the user releases the mouse button after a thumbPress event. | Slider
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no The color of the black section of the border. | Slider
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | dataTipOffset | Type: Number Format: Length CSS Inheritance: no The offset, in pixels, of the data tip relative to the thumb. | Slider
 | dataTipPlacement | Type: String CSS Inheritance: no The location of the data tip relative to the thumb. Possible values are "left", "right", "top", and "bottom". The default value is "left". | VSlider
Inherited | dataTipPrecision | Type: int CSS Inheritance: no Number of decimal places to use for the data tip text. | Slider
Inherited | dataTipStyleName | Type: String CSS Inheritance: no The name of the style declaration to use for the data tip. | Slider
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Specifies the alpha transparency values used for the background fill of components. | Slider
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the slider thumb. | Slider
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Specifies the colors used to tint the background fill of the component. | Slider
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | labelOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the labels relative to the track. | Slider
Inherited | labelStyleName | Type: String CSS Inheritance: no The name of the style to use for the slider label. | Slider
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | showTrackHighlight | Type: Boolean CSS Inheritance: no Specifies whether to enable track highlighting between thumbs (or a single thumb and the beginning of the track). | Slider
Inherited | slideDuration | Type: Number Format: Time CSS Inheritance: no Duration in milliseconds for the sliding animation when you click on the track to move a thumb. | Slider
Inherited | slideEasingFunction | Type: Function CSS Inheritance: no Tweening function used by the sliding animation when you click on the track to move a thumb. | Slider
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | thumbDisabledSkin | Type: Class CSS Inheritance: no The skin for the slider thumb disabled state. | Slider
Inherited | thumbDownSkin | Type: Class CSS Inheritance: no The skin for the slider thumb down state. | Slider
Inherited | thumbOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the thumb relative to the track. | Slider
Inherited | thumbOverSkin | Type: Class CSS Inheritance: no The skin for the slider thumb over state. | Slider
Inherited | thumbUpSkin | Type: Class CSS Inheritance: no The skin for the slider thumb up state. | Slider
Inherited | tickColor | Type: uint Format: Color CSS Inheritance: no The color of the tick marks. | Slider
Inherited | tickLength | Type: Number Format: Length CSS Inheritance: no The length in pixels of the tick marks. | Slider
Inherited | tickOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the tick marks relative to the track. | Slider
Inherited | tickThickness | Type: Number Format: Length CSS Inheritance: no The thickness in pixels of the tick marks. | Slider
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | trackColors | Type: Array Format: Color CSS Inheritance: no The colors of the track, as an array of two colors. | Slider
Inherited | trackHighlightSkin | Type: Class CSS Inheritance: no The skin for the slider track when it is selected. | Slider
Inherited | trackMargin | Type: Number Format: Length CSS Inheritance: no The size of the track margins, in pixels. | Slider
Inherited | trackSkin | Type: Class CSS Inheritance: no The skin for the slider track. | Slider
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
VSlider () constructor
public function VSlider()

Constructor.

Examples
SimpleImageVSlider
<?xml version="1.0"?>
<!-- Simple example to demonstrate the VSlider control. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

          private var imageWidth:Number=0;
          private var imageHeight:Number=0;

          // Event handler function to change the image size.
          private function changeSize():void
          {
             phoneImage.width=uint(imageWidth*hSlider.value/100);
             phoneImage.height=uint(imageHeight*hSlider.value/100);
          }
        ]]>
    </mx:Script>

        <mx:Panel id="panel" title="VSlider Control Example"
            height="100%" width="100%"
            layout="horizontal"
            paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

            <mx:HBox width="50%">
                <mx:Image id="phoneImage" source="@Embed('assets/Nokia_6630.png')"
                    creationComplete="imageWidth=phoneImage.width; imageHeight=phoneImage.height;" />
            </mx:HBox>

            <mx:VBox horizontalAlign="center">
                <mx:Label color="blue" text="Drag the slider to resize the image."/>

                <mx:VSlider id="hSlider"
                    dataTipPlacement="top"
                    minimum="0" maximum="100" value="100"
                    tickColor="black"
                    snapInterval="1" tickInterval="10"
                    labels="['0%','100%']"
                    allowTrackClick="true"
                    liveDragging="true"
                    change="changeSize();"/>
            </mx:VBox>

        </mx:Panel>
</mx:Application>


mx.controls.dataGridClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.dataGridClasses | Classes

The mx.controls.dataGridClasses package contains the classes used by the DataGrid control.

Classes
Class | Description
DataGridBase | The DataGridBase class is the base class for controls that display lists of items in multiple columns.
DataGridColumn | The DataGridColumn class describes a column in a DataGrid control.
DataGridDragProxy | The DataGridDragProxy class defines the default drag proxy used when dragging data from a DataGrid control.
DataGridItemRenderer | The DataGridItemRenderer class defines the default item renderer for a DataGrid control.
DataGridListData | The DataGridListData class defines the data type of the listData property that is implemented by drop-in item renderers or drop-in item editors for the DataGrid control.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.dataGridClasses.DataGridBase (Flex™ 2 Language Reference)

Class DataGridBase | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.dataGridClasses
Class | public class DataGridBase
Inheritance | DataGridBase Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | DataGrid

The DataGridBase class is the base class for controls that display lists of items in multiple columns. It is not used directly in applications.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The DataGridBase class inherits all the properties of its parent classes and adds the following properties:

  <mx:tagname
    headerHeight="depends on styles and header renderer"
    showHeaders="true|false"
  />

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
Inherited | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | headerHeight : Number The height of the header cell of the column, in pixels. | DataGridBase
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
Inherited | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
Inherited | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelField : String The name of the field in the data provider items to display as the label. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
 | showHeaders : Boolean A flag that indicates whether the control should show column headers. | DataGridBase
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
 | columnMap : Object A map of item renderes to columns. | DataGridBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
 | freeItemRenderersTable : Dictionary A per-column table of unused item renderers. | DataGridBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridBase()
Constructor.
DataGridBase
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
calculateRowHeight(data:Object, hh:Number, skipVisible:Boolean = false):Number
Calculates the row height of columns in a row.
DataGridBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
Inherited
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
Inherited | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
Inherited | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors to use for the backgrounds of the items in the list. | ListBase
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | rollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user rolls over it. | ListBase
Inherited | selectionColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user selects it. | ListBase
Inherited | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the component is disabled. | ListBase
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
Inherited | selectionEasingFunction | Type: Function CSS Inheritance: no The easingFunction for the selection effect. | ListBase
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user rolls over a it. | ListBase
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user selects it. | ListBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
columnMap property
protected var columnMap:Object

A map of item renderes to columns. Like ListBase.rowMap, this property contains a hash map of item renderers and the columns they belong to. Item renderers are indexed by their DisplayObject name

See also

mx.controls.listClasses.ListBase.rowMap
freeItemRenderersTable property
protected var freeItemRenderersTable:Dictionary

A per-column table of unused item renderers. Most list classes recycle item renderers that they have already created as they scroll off screen. The recycled renderers are stored here. The table is a Dictionary where the entries are Arrays indexed by the actual DataGridColumn (not the column's dataField or other properties), and each array is a stack of currently unused renderers

headerHeight property
headerHeight:Number [read-write]

The height of the header cell of the column, in pixels. If set explicitly, that height will be used for all of the headers. If not set explicitly, the height will based on style settings and the header renderer.

This property can be used as the source for data binding.

Implementation
    public function get headerHeight():Number
    public function set headerHeight(value:Number):void
showHeaders property
showHeaders:Boolean [read-write]

A flag that indicates whether the control should show column headers. If true, the control shows column headers.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get showHeaders():Boolean
    public function set showHeaders(value:Boolean):void
Constructor detail
DataGridBase () constructor
public function DataGridBase()

Constructor.

Method detail
calculateRowHeight () method
protected function calculateRowHeight(data:Object, hh:Number, skipVisible:Boolean = false):Number

Calculates the row height of columns in a row. If skipVisible is true> the DataGridBase already knows the height of the renderers for the column that do fit in the display area so this method only needs to calculate for the item renderers that would exist if other columns in that row were in the display area. This is needed so that if the user scrolls horizontally, the height of the row does not adjust as different columns appear and disappear.

Parameters
data:Object — The data provider item for the row.
hh:Number — The current height of the row.
skipVisible:Boolean (default = false) — If true, no need to measure item renderers in visible columns

Returns
Number — The row height, in pixels.


mx.controls.dataGridClasses.DataGridColumn (Flex™ 2 Language Reference)

Class DataGridColumn | Properties | Methods | Styles
Package | mx.controls.dataGridClasses
Class | public class DataGridColumn
Inheritance | DataGridColumn Inheritance CSSStyleDeclaration Inheritance EventDispatcher Inheritance Object
Implements | IIMESupport

The DataGridColumn class describes a column in a DataGrid control. There is one DataGridColumn per displayable column, even if a column is hidden or off-screen. The data provider items of a DataGrid control can contain properties that are not displayed and, therefore, do not need a DataGridColumn. A DataGridColumn allows specification of the color and font of the text in a column; what kind of component displays the data for the column; whether the column is editable, sortable, or resizeable; and the text for the column header.

Notes:

  • A DataGridColumn only holds information about a column; it is not the parent of the item renderers in the column.
  • If you specify a DataGridColumn class without a dataField property, you must specify a sortCompareFunction property. Otherwise, sort operations may cause run-time errors.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

You use the <mx.DataGridcolumn> tag to configure a column of a DataGrid control. You specify the <mx.DataGridcolumn> tag as a child of the columns property in MXML. The <mx.DataGridcolumn> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:DataGridColumn
  Properties
    dataField="No default"
    dataTipField="No default"
    dataTipFunction="No default"
    editable="true|false"
    editorDataField="text"
    editorHeightOffset="0"
    editorUsesEnterKey="false|true"
    editorWidthOffset="0"
    editorXOffset="0"
    editorYOffset="0"
    headerRenderer="DataGridItemRenderer"
    headerText="No default"
    headerWordWrap="undefined"
    imeMode="null"
    itemEditor="TextInput"
    itemRenderer="DataGridItemRenderer"
    labelFunction="No default"
    minWidth="20"
    rendererIsEditor="false|true"
    resizable="true|false"
    showDataTips="false|true"
    sortable="true|false"
    sortCompareFunction="No default"
    sortDescending="false|true"
    visible="true|false"
    width="100"
    wordWrap="false|true"

   Styles
    backgroundColor="0xFFFFFF"
    color="No default."
    disabledColor="0xAAB3B3"
    fontAntiAliasType="advanced"
    fontFamily="No default"
    fontGridFitType="pixel"
    fontSharpness="0"
    fontSize="No default"
    fontStyle="normal|italic"
    fontThickness="0"
    fontWeight="normal|bold"
    headerStyleName="No default"
    paddingLeft="0"
    paddingRight="0"
    textAlign="right|center|left"
    textDecoration="none|underline"
    textIndent="0"
  />

See also

mx.controls.DataGrid
mx.styles.CSSStyleDeclaration

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dataField : String The name of the field or property in the data provider item associated with the column. | DataGridColumn
 | dataTipField : String The name of the field in the data provider to display as the datatip. | DataGridColumn
 | dataTipFunction : Function Specifies a callback function to run on each item of the data provider to determine its dataTip. | DataGridColumn
Inherited | defaultFactory : Function This function, if it isn't null, is usually autogenerated by the MXML compiler. | CSSStyleDeclaration
 | editable : Boolean = true A flag that indicates whether the items in the column are editable. | DataGridColumn
 | editorDataField : String = "text" The name of the property of the item editor that contains the new data for the list item. | DataGridColumn
 | editorHeightOffset : Number = 0 The height of the item editor, in pixels, relative to the size of the item renderer. | DataGridColumn
 | editorUsesEnterKey : Boolean = false A flag that indicates whether the item editor uses Enter key. | DataGridColumn
 | editorWidthOffset : Number = 0 The width of the item editor, in pixels, relative to the size of the item renderer. | DataGridColumn
 | editorXOffset : Number = 0 The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | DataGridColumn
 | editorYOffset : Number = 0 The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. | DataGridColumn
Inherited | factory : Function This function, if it isn't null, is usually autogenerated by the MXML compiler. | CSSStyleDeclaration
 | headerRenderer : IFactory The class factory for item renderer instances that display the column header for the column. | DataGridColumn
 | headerText : String Text for the header of this column. | DataGridColumn
 | headerWordWrap : * A flag that indicates whether text in the header will be word wrapped if it doesn't fit on one line. | DataGridColumn
 | imeMode : String Specifies the IME (input method editor) mode. | DataGridColumn
 | itemEditor : IFactory A class factory for the instances of the item editor to use for the column, when it is editable. | DataGridColumn
 | itemRenderer : IFactory The class factory for item renderer instances that display the data for each item in the column. | DataGridColumn
 | labelFunction : Function A function that determines the text to display in this column. | DataGridColumn
 | minWidth : Number The minimum width of the column. | DataGridColumn
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rendererIsEditor : Boolean = false A flag that indicates that the item renderer is also an item editor. | DataGridColumn
 | resizable : Boolean = true A flag that indicates whether the user is allowed to resize the width of the column. | DataGridColumn
 | showDataTips : * A flag that indicates whether the datatips are shown in the column. | DataGridColumn
 | sortable : Boolean = true A flag that indicates whether the user can click on the header of this column to sort the data provider. | DataGridColumn
 | sortCompareFunction : Function A callback function that gets called when sorting the data in the column. | DataGridColumn
 | sortDescending : Boolean = true A flag that indicates, if the column is the field used the sort the dataprovider, whether the sort is in descending order. | DataGridColumn
 | visible : Boolean A flag that indicates whethe the column is visible. | DataGridColumn
 | width : Number The width of the column, in pixels. | DataGridColumn
 | wordWrap : * A flag that indicates whether the text in a row of this column is word wrapped if it doesn't fit on one line If undefined, the DataGrid control's wordWrap property is used. | DataGridColumn
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | overrides : Object If the setStyle() method is called on a UIComponent or CSSStyleDeclaration at run time, this object stores the name/value pairs that were set; they override the name/value pairs in the objects produced by the methods specified by the defaultFactory and factory properties. | CSSStyleDeclaration
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridColumn(columnName:String = null)
Constructor.
DataGridColumn
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
clearStyle(styleProp:String):void
Clears a style property on this CSSStyleDeclaration.
CSSStyleDeclaration
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getStyle(styleProp:String):*
Gets the value for a specified style property, as determined solely by this CSSStyleDeclaration.
CSSStyleDeclaration
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
itemToDataTip(data:Object):String
Returns a String that the item renderer displays as the datatip for the given data object, based on the dataTipField and dataTipFunction properties.
DataGridColumn
itemToLabel(data:Object):String
Returns the String that the item renderer displays for the given data object.
DataGridColumn
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this CSSStyleDeclaration.
CSSStyleDeclaration
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Styles
Style Description Defined by
backgroundColor
Type: uint Format: Color CSS Inheritance: no
The Background color of the column. The default value is undefined, which means it uses the value of the backgroundColor style of the associated DataGrid control. The default value for the DataGrid control is 0xFFFFFF. 		DataGridColumn
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		DataGridColumn
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		DataGridColumn
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		DataGridColumn
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		DataGridColumn
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		DataGridColumn
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DataGridColumn
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		DataGridColumn
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		DataGridColumn
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		DataGridColumn
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		DataGridColumn
headerStyleName
Type: String CSS Inheritance: no
The name of a CSS style declaration for controlling other aspects of the appearance of the column headers. The default value is undefined, which means it uses the value of the headerStyleName style of the associated DataGrid control. The default value for the DataGrid control is ".dataGridStyles". 		DataGridColumn
paddingLeft
Type: Number Format: Length CSS Inheritance: no
The number of pixels between the container's left border and its content area. The default value is 0. 		DataGridColumn
paddingRight
Type: Number Format: Length CSS Inheritance: no
The number of pixels between the container's right border and its content area. The default value is 0. 		DataGridColumn
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

DataGridColumn
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		DataGridColumn
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		DataGridColumn
Property detail
dataField property
public var dataField:String

The name of the field or property in the data provider item associated with the column. Each DataGridColumn control requires this property and/or the labelFunction property to be set in order to calculate the displayable text for the item renderer. If the dataField and labelFunction properties are set, the data is displayed using the labelFunction and sorted using the dataField. If the property named in the dataField does not exist, the sortCompareFunction must be set for the sort to work correctly.

This value of this property is not necessarily the String that is displayed in the column header. This property is used only to access the data in the data provider. For more information, see the headerText property.

See also

headerText
dataTipField property
dataTipField:String [read-write]

The name of the field in the data provider to display as the datatip. By default, the DataGrid control looks for a property named label on each data provider item and displays it. However, if the data provider does not contain a label property, you can set the dataTipField property to specify a different property. For example, you could set the value to "FullName" when a user views a set of people's names included from a database.

This property can be used as the source for data binding.

Implementation
    public function get dataTipField():String
    public function set dataTipField(value:String):void
dataTipFunction property
dataTipFunction:Function [read-write]

Specifies a callback function to run on each item of the data provider to determine its dataTip. This property is used by the itemToDataTip method.

By default the control looks for a property named label on each data provider item and displays it as its dataTip. However, some data providers do not have a label property nor do they have another property that you can use for displaying data in the rows. For example, you might have a data provider that contains a lastName and firstName fields, but you want to display full names as the dataTip. You can specify a function to the dataTipFunction property that returns a single String containing the value of both fields. You can also use the dataTipFunction property for handling formatting and localization.

The function must take a single Object parameter, containing the data provider element, and return a String.

This property can be used as the source for data binding.

Implementation
    public function get dataTipFunction():Function
    public function set dataTipFunction(value:Function):void
editable property
public var editable:Boolean = true

A flag that indicates whether the items in the column are editable. If true, and the DataGrid's editable property is also true, the items in a column are editable and can be individually edited by clicking on an item or by navigating to the item by using the Tab and Arrow keys.

The default value is true.

editorDataField property
public var editorDataField:String = "text"

The name of the property of the item editor that contains the new data for the list item. For example, the default itemEditor is TextInput, so the default value of the editorDataField property is "text", which specifies the text property of the TextInput control.

The default value is "text".

editorHeightOffset property
public var editorHeightOffset:Number = 0

The height of the item editor, in pixels, relative to the size of the item renderer. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor. Note that changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

editorUsesEnterKey property
public var editorUsesEnterKey:Boolean = false

A flag that indicates whether the item editor uses Enter key. If true the item editor uses the Enter key and the DataGrid will not look for the Enter key and move the editor in response. Note that changing this value while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is false..

editorWidthOffset property
public var editorWidthOffset:Number = 0

The width of the item editor, in pixels, relative to the size of the item renderer. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor. Note that changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

editorXOffset property
public var editorXOffset:Number = 0

The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor. Note that changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

editorYOffset property
public var editorYOffset:Number = 0

The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item. This property can be used to make the editor overlap the item renderer by a few pixels to compensate for a border around the editor. Note that changing these values while the editor is displayed will have no effect on the current editor, but will affect the next item renderer that opens an editor.

The default value is 0.

headerRenderer property
headerRenderer:IFactory [read-write]

The class factory for item renderer instances that display the column header for the column. You can specify a drop-in item renderer, an inline item renderer, or a custom item renderer component as the value of this property.

The default item renderer is the DataGridItemRenderer class, which displays the item data as text.

This property can be used as the source for data binding.

Implementation
    public function get headerRenderer():IFactory
    public function set headerRenderer(value:IFactory):void
headerText property
headerText:String [read-write]

Text for the header of this column. By default, the DataGrid control uses the value of the dataField property as the header text.

This property can be used as the source for data binding.

Implementation
    public function get headerText():String
    public function set headerText(value:String):void
headerWordWrap property
headerWordWrap:* [read-write]

A flag that indicates whether text in the header will be word wrapped if it doesn't fit on one line. If undefined, the DataGrid control's wordWrap property is used.

The default value is undefined.

Implementation
    public function get headerWordWrap():*
    public function set headerWordWrap(value:*):void
imeMode property
imeMode:String [read-write]

Specifies the IME (input method editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the IME mode when the itemFocusIn event occurs, and sets it back to the previous value when the itemFocusOut event occurs. The flash.system.IMEConversionMode class defines constants for the valid values for this property.

The default value is null, in which case it uses the value of the DataGrid control's imeMode property.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void

See also

flash.system.IMEConversionMode
itemEditor property
public var itemEditor:IFactory

A class factory for the instances of the item editor to use for the column, when it is editable.

The default value is new ClassFactory(mx.controls.TextInput).

itemRenderer property
itemRenderer:IFactory [read-write]

The class factory for item renderer instances that display the data for each item in the column. You can specify a drop-in item renderer, an inline item renderer, or a custom item renderer component as the value of this property.

The default item renderer is the DataGridItemRenderer class, which displays the item data as text.

This property can be used as the source for data binding.

Implementation
    public function get itemRenderer():IFactory
    public function set itemRenderer(value:IFactory):void
labelFunction property
labelFunction:Function [read-write]

A function that determines the text to display in this column. By default the column displays the text for the field in the data that matches the column name. However, sometimes you want to display text based on more than one field in the data, or display something that does not have the format that you want. In such a case you specify a callback function using labelFunction.

For the DataGrid control, the method signature has the following form:

labelFunction(item:Object, column:DataGridColumn):String

Where item contains the DataGrid item object, and column specifies the DataGrid column.

A callback function might concatenate the firstName and lastName fields in the data, or do some custom formatting on a Date, or convert a number for the month into the string for the month.

This property can be used as the source for data binding.

Implementation
    public function get labelFunction():Function
    public function set labelFunction(value:Function):void
minWidth property
minWidth:Number [read-write]

The minimum width of the column.

The default value is 20..

This property can be used as the source for data binding.

Implementation
    public function get minWidth():Number
    public function set minWidth(value:Number):void
rendererIsEditor property
public var rendererIsEditor:Boolean = false

A flag that indicates that the item renderer is also an item editor. If this property is true, Flex ignores the itemEditor property and uses the item renderer for that item as the editor.

The default value is false.

resizable property
public var resizable:Boolean = true

A flag that indicates whether the user is allowed to resize the width of the column. If true, the user can drag the grid lines between the column headers to resize the column.

The default value is true.

showDataTips property
showDataTips:* [read-write]

A flag that indicates whether the datatips are shown in the column. If true, datatips are displayed for text in the rows. Datatips are tooltips designed to show the text that is too long for the row.

The default value is false.

Implementation
    public function get showDataTips():*
    public function set showDataTips(value:*):void
sortable property
public var sortable:Boolean = true

A flag that indicates whether the user can click on the header of this column to sort the data provider. If this property and the DataGrid sortableColumns property are both true, the DataGrid control dispatches a headerRelease event when a user releases the mouse button on this column's header. If no other handler calls the preventDefault() method on the headerRelease event, the dataField property or sortCompareFunction in the column is used to reorder the items in the dataProvider.

The default value is true.

sortCompareFunction property
sortCompareFunction:Function [read-write]

A callback function that gets called when sorting the data in the column. If this property is not specified, the sort tries to use a basic string or number sort on the data. If the data is not a string or number or if the dataField property is not a valid property of the data provider, the sort does not work or will generate an exception. If you specify a value of the labelFunction property, you must also provide a function to the sortCompareFunction property, unless sorting is not allowed on this column.

The DataGrid control uses this function to sort the elements of the data provider collection. The function signature of the callback function takes two parameters and have the following form:

mySortCompareFunction(obj1:Object, obj2:Object):int

obj1 — A data element to compare.

obj2 — Another data element to compare with obj1.

The function should return a value based on the comparison of the objects:

  • -1 if obj1 should appear before obj2 in ascending order.
  • 0 if obj1 = obj2.
  • 1 if obj1 should appear after obj2 in ascending order.

Note: The obj1 and obj2 parameters are entire data provider elements and not just the data for the item.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get sortCompareFunction():Function
    public function set sortCompareFunction(value:Function):void
sortDescending property
public var sortDescending:Boolean = true

A flag that indicates, if the column is the field used the sort the dataprovider, whether the sort is in descending order.

The default value is true;.

visible property
visible:Boolean [read-write]

A flag that indicates whethe the column is visible. If true, the column is visible.

The default value is true.

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
width property
width:Number [read-write]

The width of the column, in pixels. If horizontalScrollPolicy is false all visible columns must fit in the displayable area and the DataGrid will not always honor the width of the columns if the total width of the columns is too small or too large.

The default value is 100.

This property can be used as the source for data binding.

Implementation
    public function get width():Number
    public function set width(value:Number):void
wordWrap property
wordWrap:* [read-write]

A flag that indicates whether the text in a row of this column is word wrapped if it doesn't fit on one line If undefined, the DataGrid control's wordWrap property is used.

The default value is undefined.

Implementation
    public function get wordWrap():*
    public function set wordWrap(value:*):void
Constructor detail
DataGridColumn () constructor
public function DataGridColumn(columnName:String = null)

Constructor.

Parameters
columnName:String (default = null) — The name of the field in the data provider associated with the column, and the text for the header cell of this column. This is equivalent to setting the dataField and headerText properties.
Method detail
itemToDataTip () method
public function itemToDataTip(data:Object):String

Returns a String that the item renderer displays as the datatip for the given data object, based on the dataTipField and dataTipFunction properties. If the method cannot convert the parameter to a String, it returns a single space.

This method is for use by developers who are creating subclasses of the DataGridColumn class. It is not for use by application developers.

Parameters
data:Object — Object to be rendered.

Returns
String — Displayable String based on the data.
itemToLabel () method
public function itemToLabel(data:Object):String

Returns the String that the item renderer displays for the given data object. If the DataGridColumn or its DataGrid control has a non-null labelFunction property, it applies the function to the data object. Otherwise, the method extracts the contents of the field specified by the dataField property, or gets the string value of the data object. If the method cannot convert the parameter to a String, it returns a single space.

Parameters
data:Object — Object to be rendered.

Returns
String — Displayable String based on the data.


mx.controls.dataGridClasses.DataGridDragProxy (Flex™ 2 Language Reference)

Class DataGridDragProxy | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.dataGridClasses
Class | public class DataGridDragProxy
Inheritance | DataGridDragProxy Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The DataGridDragProxy class defines the default drag proxy used when dragging data from a DataGrid control.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridDragProxy()
Constructor.
DataGridDragProxy
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
DataGridDragProxy () constructor
public function DataGridDragProxy()

Constructor.


mx.controls.dataGridClasses.DataGridItemRenderer (Flex™ 2 Language Reference)

Class DataGridItemRenderer | Properties | Methods | Events | Styles
Package | mx.controls.dataGridClasses
Class | public class DataGridItemRenderer
Inheritance | DataGridItemRenderer Inheritance UITextField Inheritance FlexTextField Inheritance TextField Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, ILayoutManagerClient, IListItemRenderer, IStyleClient

The DataGridItemRenderer class defines the default item renderer for a DataGrid control. By default, the item renderer draws the text associated with each item in the grid.

You can override the default item renderer by creating a custom item renderer.

See also

mx.controls.DataGrid
mx.core.IDataRenderer
mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | alwaysShowSelection : Boolean When set to true and the text field is not in focus, Flash Player highlights the selection in the text field in gray. | TextField
Inherited | antiAliasType : String The type of anti-aliasing used for this text field. | TextField
Inherited | autoSize : String Controls automatic sizing and alignment of text fields. | TextField
Inherited | background : Boolean Specifies whether the text field has a background fill. | TextField
Inherited | backgroundColor : uint The color of the text field background. | TextField
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UITextField
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | border : Boolean Specifies whether the text field has a border. | TextField
Inherited | borderColor : uint The color of the text field border. | TextField
Inherited | bottomScrollV : int An integer (1-based index) that indicates the bottommost line that is currently visible in the specified text field. | TextField
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | caretIndex : int The index of the insertion point (caret) position. | TextField
Inherited | className : String The name of this instance's class, such as "DataGridItemRenderer". | UITextField
Inherited | condenseWhite : Boolean A Boolean value that specifies whether extra white space (spaces, line breaks, and so on) in a text field with HTML text should be removed. | TextField
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | data : Object The implementation of the data property as defined by the IDataRenderer interface. | DataGridItemRenderer
Inherited | defaultTextFormat : TextFormat Specifies the format applied to newly inserted text, such as text inserted with the replaceSelectedText() method or text entered by a user. | TextField
Inherited | displayAsPassword : Boolean Specifies whether the text field is a password text field. | TextField
Inherited | document : Object A reference to the document object associated with this UITextField object. | UITextField
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | embedFonts : Boolean Specifies whether to render by using embedded font outlines. | TextField
Inherited | enabled : Boolean A Boolean value that indicates whether the component is enabled. | UITextField
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UITextField
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UITextField
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UITextField
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UITextField
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UITextField
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UITextField
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusPane : Sprite A single Sprite object that is shared among components and used as an overlay for drawing focus. | UITextField
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | gridFitType : String The type of grid fitting used for this text field. | TextField
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | htmlText : String Contains the HTML representation of the text field's contents. | TextField
Inherited | ignorePadding : Boolean If true, the paddingLeft and paddingRight styles will not add space around the text of the component. | UITextField
Inherited | imeMode : String Specifies the IME (input method editor) mode. | UITextField
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UITextField
Inherited | inheritingStyles : Object The beginning of this UITextField's chain of inheriting styles. | UITextField
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required) | UITextField
Inherited | length : int The number of characters in a text field. | TextField
 | listData : BaseListData The implementation of the listData property as defined by the IDropInListItemRenderer interface. | DataGridItemRenderer
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxChars : int The maximum number of characters that the text field can contain, as entered by a user. | TextField
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UITextField
Inherited | maxScrollH : int The maximum value of scrollH. | TextField
Inherited | maxScrollV : int The maximum value of scrollV. | TextField
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UITextField
Inherited | measuredHeight : Number The default height of the component, in pixels. | UITextField
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UITextField
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UITextField
Inherited | measuredWidth : Number The default width of the component, in pixels. | UITextField
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UITextField
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UITextField
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseWheelEnabled : Boolean A Boolean value that indicates whether Flash Player should automatically scroll multiline text fields when the user clicks a text field and rolls the mouse wheel. | TextField
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | multiline : Boolean Indicates whether the text field is a multiline text field. | TextField
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UITextField
Inherited | nonInheritingStyles : Object The beginning of this UITextField's chain of non-inheriting styles. | UITextField
Inherited | numLines : int Defines the number of text lines in a multiline text field. | TextField
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer By default, set to the parent container of this object. | UITextField
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UITextField
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UITextField
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UITextField
Inherited | processedDescriptors : Boolean Set to true after the createChildren() method creates any internal component children. | UITextField
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | restrict : String Indicates the set of characters that a user can enter into the text field. | TextField
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollH : int The current horizontal scrolling position. | TextField
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollV : int The vertical position of text in a text field. | TextField
Inherited | selectable : Boolean A Boolean value that indicates whether the text field is selectable. | TextField
Inherited | selectionBeginIndex : int The zero-based character index value of the first character in the current selection. | TextField
Inherited | selectionEndIndex : int The zero-based character index value of the last character in the current selection. | TextField
Inherited | sharpness : Number The sharpness of the glyph edges in this text field. | TextField
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | DataGridItemRenderer
Inherited | styleName : Object The class style used by this component. | UITextField
Inherited | styleSheet : StyleSheet Attaches a style sheet to the text field. | TextField
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UITextField
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String A string that is the current text in the text field. | TextField
Inherited | textColor : uint The color of the text in a text field, in hexadecimal format. | TextField
Inherited | textHeight : Number The height of the text in pixels. | TextField
Inherited | textWidth : Number The width of the text in pixels. | TextField
Inherited | thickness : Number The thickness of the glyph edges in this text field. | TextField
Inherited | toolTip : String Text to display in the ToolTip. | UITextField
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UITextField
Inherited | type : String The type of the text field. | TextField
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required) | UITextField
Inherited | useRichTextClipboard : Boolean Specifies whether to copy and paste the text formatting along with the text. | TextField
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | wordWrap : Boolean A Boolean value that indicates whether the text field has word wrap. | TextField
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridItemRenderer()
Constructor.
DataGridItemRenderer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
appendText(newText:String):void
Appends the string specified by the newText parameter to the end of the text of the TextField.
TextField
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
DataGridItemRenderer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getCharBoundaries(charIndex:int):Rectangle
Returns a rectangle that is the bounding box of the character.
TextField
Inherited
getCharIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the character at the point specified by the x and y parameters.
TextField
getClassStyleDeclarations():Array
Returns an Array of CSSStyleDeclaration objects for the type selector that applies to this component, or null if none exist.
DataGridItemRenderer
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UITextField
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UITextField
Inherited
getFirstCharInParagraph(charIndex:int):int
Given a character index, returns the index of the first character in the same paragraph.
TextField
Inherited
getImageReference(id:String):DisplayObject
Returns a DisplayObject reference for the given id, for an image or SWF file that has been added to an HTML-formatted text field by using an <img> tag.
TextField
Inherited
getLineIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the line at the point specified by the x and y parameters.
TextField
Inherited
getLineIndexOfChar(charIndex:int):int
Returns the zero-based index value of the line containing the character specified by the charIndex parameter.
TextField
Inherited
getLineLength(lineIndex:int):int
Returns the number of characters in a specific text line.
TextField
Inherited
getLineMetrics(lineIndex:int):TextLineMetrics
Returns metrics information about a given text line.
TextField
Inherited
getLineOffset(lineIndex:int):int
Returns the character index of the first character in the line that the lineIndex parameter specifies.
TextField
Inherited
getLineText(lineIndex:int):String
Returns the text of the line specified by the lineIndex parameter.
TextField
Inherited
getParagraphLength(charIndex:int):int
Given a character index, returns the length of the paragraph containing the given character.
TextField
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
DataGridItemRenderer
Inherited
getTextFormat(beginIndex:int = -1, endIndex:int = -1):TextFormat
Returns a TextFormat object that contains formatting information for the range of text that the beginIndex and endIndex parameters specify.
TextField
Inherited
getTextStyles():TextFormat
Returns the TextFormat object that represents character formatting information for this UITextField object.
UITextField
Inherited
getUITextFormat():UITextFormat
Returns a UITextFormat object that contains formatting information for this component.
UITextField
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
initialize():void
Initializes this component.
UITextField
initProtoChain():void
Sets up the inheritingStyles and nonInheritingStyles objects and their proto chains so that the getStyle() method can work.
DataGridItemRenderer
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UITextField
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UITextField
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UITextField
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UITextField
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagates style changes to the children of this component.
DataGridItemRenderer
Inherited
owns(child:DisplayObject):Boolean
Returns true if the child is parented or owned by this object.
UITextField
Inherited
parentChanged(p:DisplayObjectContainer):void
This function is called when a UITextField object is assigned a parent.
UITextField
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
regenerateStyleCache(recursive:Boolean):void
Sets up the internal style cache values so that the getStyle() method functions.
DataGridItemRenderer
registerEffects(effects:Array):void
For each effect event, registers the EffectManager as one of the event listeners.
DataGridItemRenderer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
replaceSelectedText(value:String):void
Replaces the current selection with the contents of the value parameter.
TextField
Inherited
replaceText(beginIndex:int, endIndex:int, newText:String):void
Replaces the range of characters that the beginIndex and endIndex parameters specify with the contents of the newText parameter.
TextField
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UITextField
Inherited
setColor(color:uint):void
Sets the font color of the text.
UITextField
Inherited
setFocus():void
Sets the focus to this component.
UITextField
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSelection(beginIndex:int, endIndex:int):void
Sets as selected the text designated by the index values of the first and last characters, which are specified with the beginIndex and endIndex parameters.
TextField
setStyle(styleProp:String, newValue:):void
Sets a style property on this component instance.
DataGridItemRenderer
Inherited
setTextFormat(format:TextFormat, beginIndex:int = -1, endIndex:int = -1):void
Applies the text formatting that the format parameter specifies to the specified text in a text field.
TextField
Inherited
setVisible(visible:Boolean, noEvent:Boolean = false):void
Sets the visible property of this UITextField object.
UITextField
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UITextField
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexTextField
Inherited
truncateToFit(truncationIndicator:String = null):Boolean
Truncate text to make it fit horizontally in the area defined for the control, and append an ellipsis, three periods (...), to the text.
UITextField
validateDisplayList():void
If Flex calls LayoutManager.invalidateDisplayList() method on this ILayoutManagerClient, then this function is called when it's time to update the display list.
DataGridItemRenderer
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UITextField
validateProperties():void
If Flex calls the LayoutManager.invalidateProperties() method on this ILayoutManagerClient, then this function is called when it's time to commit property values.
DataGridItemRenderer
validateSize(recursive:Boolean = false):void
If Flex calls the LayoutManager.invalidateSize() method on this ILayoutManagerClient, then this function is called when it's time to do measurements.
DataGridItemRenderer
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | toolTipShowHandler(event:ToolTipEvent):void The event handler to position the tooltip. | DataGridItemRenderer
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched after a control's value is modified. | TextField
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | dataChange | Dispatched when the data property changes. | DataGridItemRenderer
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | link | Dispatched when a user clicks a hyperlink in an HTML-enabled text field, where the URL begins with "event:". | TextField
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched by a TextField object after the user scrolls. | TextField
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | textInput | Flash Player dispatches the textInput event when a user enters one or more characters of text. | TextField
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | UITextField
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | UITextField
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | UITextField
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | UITextField
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | UITextField
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | UITextField
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | UITextField
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | UITextField
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | UITextField
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | UITextField
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | UITextField
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | UITextField
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | UITextField
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | UITextField
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | UITextField
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | UITextField
Property detail
data property
data:Object [read-write]

The implementation of the data property as defined by the IDataRenderer interface. The value is ignored. Only the listData property is used.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
listData property
listData:BaseListData [read-write]

The implementation of the listData property as defined by the IDropInListItemRenderer interface. The text of the renderer is set to the label property of the listData.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
styleDeclaration property
styleDeclaration:CSSStyleDeclaration [read-write]

Storage for the inline inheriting styles on this object. This CSSStyleDeclaration is created the first time that setStyle() is called on this component to set an inheriting style.

Implementation
    public function get styleDeclaration():CSSStyleDeclaration
    public function set styleDeclaration(value:CSSStyleDeclaration):void
Constructor detail
DataGridItemRenderer () constructor
public function DataGridItemRenderer()

Constructor.

Method detail
clearStyle () method
public function clearStyle(styleProp:String):void

Deletes a style property from this component instance.

This does not necessarily cause the getStyle() method to return undefined.

Parameters
styleProp:String — The name of the style property.
getClassStyleDeclarations () method
public function getClassStyleDeclarations():Array

Returns an Array of CSSStyleDeclaration objects for the type selector that applies to this component, or null if none exist.

For example, suppose that component MyButton extends Button. This method first looks for a MyButton selector; then, it looks for a Button type selector; finally, it looks for a UIComponent type selector.

Returns
Array — Array of CSSStyleDeclaration objects.
getStyle () method
public override function getStyle(styleProp:String):*

Gets a style property that has been set anywhere in this component's style lookup chain.

This same method is used to get any kind of style property, so the value returned may be a Boolean, String, Number, int, uint (for an RGB color), Class (for a skin), or any kind of object. Therefore the return type is simply specified as

If you are getting a particular style property, you will know its type and will often want to store the result in a variable of that type. No casting from to that type is necessary:

var backgroundColor:uint = getStyle("backgroundColor");

If the style property has not been set anywhere in the style lookup chain, the value returned by getStyle() will be undefined. Note that undefined is a special value that is not the same as false, "", NaN, 0, or null. No valid style value is ever undefined. You can use the static method StyleManager.isValidStyleValue() to test whether the value was set.

Parameters
styleProp:String — Name of the style property.

Returns
* — Style value.
initProtoChain () method
public function initProtoChain():void

Sets up the inheritingStyles and nonInheritingStyles objects and their proto chains so that the getStyle() method can work.

notifyStyleChangeInChildren () method
public function notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void

Propagates style changes to the children of this component.

Parameters
styleProp:String — Name of the style property.
recursive:Boolean — Propagates style changes to the children's children.
regenerateStyleCache () method
public function regenerateStyleCache(recursive:Boolean):void

Sets up the internal style cache values so that the getStyle() method functions. If this object already has children, then reinitialize the children's style caches.

Parameters
recursive:Boolean — Regenerate children's proto chains.
registerEffects () method
public function registerEffects(effects:Array):void

For each effect event, registers the EffectManager as one of the event listeners.

Parameters
effects:Array — An Array of Strings of effect names.
setStyle () method
public override function setStyle(styleProp:String, newValue:):void

Sets a style property on this component instance.

This may override a style that was set globally.

Calling the setStyle() method can result in decreased performance. Use it only when necessary.

Parameters
styleProp:String — Name of the style property.
newValue: — New value for the style.
toolTipShowHandler () method
protected function toolTipShowHandler(event:ToolTipEvent):void

The event handler to position the tooltip.

Parameters
event:ToolTipEvent — The event object.
validateDisplayList () method
public function validateDisplayList():void

If Flex calls LayoutManager.invalidateDisplayList() method on this ILayoutManagerClient, then this function is called when it's time to update the display list.

validateProperties () method
public function validateProperties():void

If Flex calls the LayoutManager.invalidateProperties() method on this ILayoutManagerClient, then this function is called when it's time to commit property values.

validateSize () method
public function validateSize(recursive:Boolean = false):void

If Flex calls the LayoutManager.invalidateSize() method on this ILayoutManagerClient, then this function is called when it's time to do measurements.

Parameters
recursive:Boolean (default = false) — If true, call this method on the object's children.
Event detail
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.controls.dataGridClasses.DataGridListData (Flex™ 2 Language Reference)

Class DataGridListData | Properties | Methods
Package | mx.controls.dataGridClasses
Class | public class DataGridListData
Inheritance | DataGridListData Inheritance BaseListData Inheritance Object

The DataGridListData class defines the data type of the listData property that is implemented by drop-in item renderers or drop-in item editors for the DataGrid control. All drop-in item renderers and drop-in item editors must implement the IDropInListItemRenderer interface, which defines the listData property.

Although the properties of this class are writable, you should consider them to be read-only. They are initialized by the DataGrid class, and read by an item renderer or item editor. Changing these values can lead to unexpected results.

See also

mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | columnIndex : int The column index of the item in columns for the DataGrid control. | DataGridListData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dataField : String Name of the field or property in the data provider associated with the column. | DataGridListData
Inherited | label : String The textual representation of the item data, based on the list class's itemToLabel() method. | BaseListData
Inherited | owner : IUIComponent A reference to the list object that owns this item. | BaseListData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rowIndex : int The index of the item in the data provider. | BaseListData
Inherited | uid : String The unique identifier for this item. | BaseListData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataGridListData(text:String, dataField:String, columnIndex:int, uid:String, owner:IUIComponent, rowIndex:int = 0) Constructor. | DataGridListData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
columnIndex property
public var columnIndex:int

The column index of the item in columns for the DataGrid control.

dataField property
public var dataField:String

Name of the field or property in the data provider associated with the column.

Constructor detail
DataGridListData () constructor
public function DataGridListData(text:String, dataField:String, columnIndex:int, uid:String, owner:IUIComponent, rowIndex:int = 0)

Constructor.

Parameters
text:String — Text representation of the item data.
dataField:String — Name of the field or property in the data provider associated with the column.
columnIndex:int — The column index of the item in the columns for the DataGrid control.
uid:String — A unique identifier for the item.
owner:IUIComponent — A reference to the DataGrid control.
rowIndex:int (default = 0) — The index of the item in the data provider for the DataGrid control.


mx.controls.listClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.listClasses | Interfaces | Classes

The mx.controls.listClasses package contains the classes used by the list-based controls.

Interfaces
Interface | Description
IDropInListItemRenderer | The interface for "drop-in" item renderers.
IListItemRenderer | Item renderers and item editors for list components must implement the IListItemRenderer interface.
Classes
Class | Description
BaseListData | The BaseListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors.
ListBase | The ListBase class is the base class for controls that represent lists of items that can have one or more selected and can scroll through the items.
ListBaseSeekPending | An object that stores data about a seek operation that was interrupted by an ItemPendingError error.
ListBaseSelectionData | Records used by list classes to keep track of what is selected.
ListData | The ListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the List control.
ListItemDragProxy | The default drag proxy used when dragging from a list-based control (except for the DataGrid class).
ListItemRenderer | The ListItemRenderer class defines the default item renderer for a List control.
ListRowInfo | Used by the list-based classes to store information about their IListItemRenderers.
TileBase | The TileBase class is the base class for controls that display data items in a sequence of rows and columns.
TileBaseDirection | Values for the direction property of the TileList component.
TileListItemRenderer | The TileListItemRenderer class defines the default item renderer for the HorizontalList and TileList controls.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.listClasses.BaseListData (Flex™ 2 Language Reference)

Class BaseListData | Properties | Methods
Package | mx.controls.listClasses
Class | public class BaseListData
Inheritance | BaseListData Inheritance Object
Subclasses | DataGridListData, ListData, TreeListData

The BaseListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors. All drop-in item renderers and drop-in item editors must implement the IDropInListItemRenderer interface, which defines the listData property.

The listData property is of type BaseListData, where the BaseListData class has three subclasses: DataGridListData, ListData, and TreeListData. The actual data type of the value of the listData property depends on the control using the drop-in item renderer or item editor. For a DataGrid control, the value is of type DataGridListData, for a List control the value is of type ListData, and for a Tree control, the value is of type TreeListData.

When used as a drop-in item renderer or drop-in item editor, Flex sets the listData property to a BaseListData-derived class containing information computed about the item in the data provider containing the data for the item.

While the properties of this class are writable, you should consider them to be read only. They are initialized by the list class, and read by an item renderer or item editor. Changing these values can lead to unexpected results.

See also

mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | label : String The textual representation of the item data, based on the list class's itemToLabel() method. | BaseListData
 | owner : IUIComponent A reference to the list object that owns this item. | BaseListData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rowIndex : int The index of the item in the data provider. | BaseListData
 | uid : String The unique identifier for this item. | BaseListData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | BaseListData(label:String, uid:String, owner:IUIComponent, rowIndex:int = 0) Constructor. | BaseListData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
label property
public var label:String

The textual representation of the item data, based on the list class's itemToLabel() method.

owner property
public var owner:IUIComponent

A reference to the list object that owns this item. This should be a ListBase-derived class. This property is typed as IUIComponent so that drop-ins like Label and TextInput don't have to have dependencies on List and all of its dependencies.

rowIndex property
public var rowIndex:int

The index of the item in the data provider.

uid property
uid:String [read-write]

The unique identifier for this item.

Implementation
    public function get uid():String
    public function set uid(value:String):void
Constructor detail
BaseListData () constructor
public function BaseListData(label:String, uid:String, owner:IUIComponent, rowIndex:int = 0)

Constructor.

Parameters
label:String — The textual representation of the item data.
uid:String — A unique identifier.
owner:IUIComponent — A reference to the list control.
rowIndex:int (default = 0) — The index of the item in the data provider for the list control.


mx.controls.listClasses.IDropInListItemRenderer (Flex™ 2 Language Reference)

Interface IDropInListItemRenderer | Properties
Package | mx.controls.listClasses
Interface | public interface IDropInListItemRenderer
Implementors | Button, ComboBox, DataGridItemRenderer, DateField, Image, Label, ListBase, ListItemRenderer, MenuItemRenderer, NumericStepper, TextArea, TextInput, TileListItemRenderer, TreeItemRenderer

The interface for "drop-in" item renderers. Most IListItemRenderers are not "drop-ins". They are expecting to use a particular field of the data provider item. For example, they may assign the "lastName" property of the item to a Label's text property. This is easy to write using data-binding, but has the negative consequence that the renderer cannot be re-used in another column of a DataGrid or another List with different fields. IDropInListItemRenderer allows a renderer to be re-used. The list classes will pass more information to the renderer so that it can determine which field to use at run-time.

Components that you want to use as drop-in item renderers or drop-in item editors must implement the IDropInListItemRenderer interface. Many Flex component implement this interface, and therefore are usable as drop-in item renderers and drop-in item editors in any column or list.

Drop-in item renderers or drop-in item editors also must implement the IDataRenderer interface to define the data property.

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. The component can then use the listData property to initialize the data property of the drop-in item renderer or drop-in item editor.

The listData property is of type BaseListData, where the BaseListData class has three subclasses: DataGridListData, ListData, and TreeListData. The actual data type of the value of the listData property depends on the control using the drop-in item renderer or item editor. For a DataGrid control, the value is of type DataGridListData, for a List control the value is of type ListData, and for a Tree control, the value is of type TreeListData.

The following example shows the setter method for the data property for the NumericStepper control that initializes NumericStepper's value property based on the value of the listData property:

    public function set data(value:Object):void
    {
      _data = value;

      this.value = _listData ? parseFloat(_listData.label) : Number(_data);

      dispatchEvent(new FlexEvent(FlexEvent.DATA_CHANGE));
    }

In the example above, the NumericStepper control ignores the data property when setting NumericStepper's value property, and uses the listData property instead.

To implement the IDropInListItemRenderer interface, you define a setter and getter method to implement the listData property. Typically, the setter method writes the value of the listData property to an internal variable. The list class always assigns this property then sets the data provider item in the data property. Most implementations apply the listData either in the data setter, or in commitProperties() method because the data setter called the invalidateProperties() method or in response to the dataChange event because the data setter dispatched the event. The getter method returns the current value of the internal variable, as the following example shows:

    // Internal variable for the property value.
    private var _listData:BaseListData;

    // Make the listData property bindable.
    [Bindable("dataChange")]

    // Define the getter method.
    public function get listData():BaseListData
    {
      return _listData;
    }

    // Define the setter method,
    public function set listData(value:BaseListData):void
    {
      _listData = value;
    }

See also

mx.controls.listClasses.BaseListData
mx.core.IDataRenderer

Public Properties
Property |  | Defined by
 | listData : BaseListData Implements the listData property using setter and getter methods. | IDropInListItemRenderer
Property detail
listData property
listData:BaseListData [read-write]

Implements the listData property using setter and getter methods.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void


mx.controls.listClasses.IListItemRenderer (Flex™ 2 Language Reference)

Interface IListItemRenderer | Properties | Methods
Package | mx.controls.listClasses
Interface | public interface IListItemRenderer extends IDataRenderer, IEventDispatcher, IFlexDisplayObject, IBitmapDrawable, ILayoutManagerClient, ISimpleStyleClient, IUIComponent
Implementors | Button, ComboBox, Container, DataGridItemRenderer, DateField, Image, Label, ListBase, ListItemRenderer, MenuBarItem, MenuItemRenderer, NumericStepper, TextArea, TextInput, TileListItemRenderer, TreeItemRenderer

Item renderers and item editors for list components must implement the IListItemRenderer interface. The IListItemRenderer interface is a set of several other interfaces. It does not define any new class methods or properties.

The set of interfaces includes the following: IDataRenderer, IFlexDisplayObject, ILayoutManagerClient, ISimpleStyleClient, IUIComponent. The UIComponent class implements all of these interfaces, except the IDataRenderer interface. Therefore, if you create a custom item renderer or item editor as a subclass of the UIComponent class, you only have to implement the IDataRenderer interface and then you can add to the class definition that the class implements IDataRenderer and IListItemRenderer.

IListItemRenderers are generally dedicated to displaying a particular field from the data provider item and cannot be re-used in other DataGrid columns or in other lists with different fields. If you want to create a renderer that can be re-used you can also implement IDropInListItemRenderer, and the list will pass more data to the renderer that allows the renderer to be re-used with different data fields.

Item renderers and item editors are passed data from a list class' data provider using the IDataRenderer interface. Renderers and editors that implement the IDropInListItemRenderer interface get other information from the list class. The item renderer or item editor uses one or both pieces of information to display the data.

The renderers and editors are often recycled. Once they are created, they may be used again simply by being given a new data and optional listData property. Therefore in your implementation you must make sure that component properties are not assumed to contain their initial, or default values.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | alpha : Number The transparency of this object. | IFlexDisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | IUIComponent
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the object. | IUIComponent
Inherited | data : Object The data to render or edit. | IDataRenderer
Inherited | document : Object A reference to the document object associated with this component. | IUIComponent
Inherited | enabled : Boolean Whether the component can accept user interaction. | IUIComponent
Inherited | explicitHeight : Number The explicitly specified height for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitWidth : Number The explicitly specified width for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | focusPane : Sprite A single Sprite object that is shared among components and used as an overlay for drawing focus. | IUIComponent
Inherited | height : Number The height of this object, in pixels. | IFlexDisplayObject
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | IUIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required) This flag should only be modified by the LayoutManager. | ILayoutManagerClient
Inherited | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | measuredHeight : Number The measured height of this object. | IFlexDisplayObject
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | IUIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | IUIComponent
Inherited | measuredWidth : Number The measured width of this object. | IFlexDisplayObject
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | name : String The instance name of this object. | IFlexDisplayObject
Inherited | nestLevel : int The top-level SystemManager has a nestLevel of 1. | ILayoutManagerClient
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | IUIComponent
Inherited | owner : DisplayObjectContainer Your owner is usually your parent, however If you are a popup subcomponent, your owner will be the component that popped you up. | IUIComponent
Inherited | parent : DisplayObjectContainer The parent of this object. | IFlexDisplayObject
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | IUIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | IUIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ILayoutManagerClient
Inherited | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
Inherited | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the surface of the component. | IUIComponent
Inherited | styleName : Object The source of this object's style values. | ISimpleStyleClient
Inherited | systemManager : ISystemManager A reference to the SystemManager object for this component. | IUIComponent
Inherited | tweeningProperties : Array Used by EffectManager. | IUIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object is waiting to have its updateComplete event dispatched. | ILayoutManagerClient
Inherited | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
Inherited | width : Number The width of this object, in pixels. | IFlexDisplayObject
Inherited | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Inherited | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
IUIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
IUIComponent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
initialize():void
Initialize the object.
IUIComponent
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
Inherited
owns(displayObject:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
IUIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
IUIComponent
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
IUIComponent
Inherited
styleChanged(styleProp:String):void
Called when the value of a style property is changed.
ISimpleStyleClient
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
ILayoutManagerClient
Inherited
validateProperties():void
Validates the properties of a component.
ILayoutManagerClient
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
ILayoutManagerClient
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher


mx.controls.listClasses.ListBase (Flex™ 2 Language Reference)

Class ListBase | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.listClasses
Class | public class ListBase
Inheritance | ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IFocusManagerComponent, IListItemRenderer
Subclasses | DataGridBase, List, TileBase

The ListBase class is the base class for controls that represent lists of items that can have one or more selected and can scroll through the items. Items are supplied using the dataProvider property and displayed via item renderers.

In a model/view architecture, the ListBase-derived class represents the view, and the dataProvider object represents the model.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The ListBase class inherits all of the tag properties of its superclasses, and adds the following tag properties:

  <mx:tagname
    Properties
    allowDragSelection="false|true"
    allowMultipleSelection="false|true"
    columnCount="4"
    columnWidth="NaN"
    dataProvider="null"
    dataTipField="label"
    dataTipFunction="null"
    dragEnabled="false|true"
    dragMoveEnabled="false|true"
    dropEnabled="false|true"
    iconField="null"
    iconFunction="null"
    itemRenderer="null"
    labelField="label"
    labelFunction="null"
    lockedColumnCount=0
    lockedRowCount=0
    menuSelectionMode="false|true"
    rowCount="-1"
    rowHeight="NaN"
    selectable="true|false"
    selectedIndex="-1"
    selectedIndices="null"
    selectedItem="null"
    selectedItems="null"
    showDataTips="false|true"
    variableRowHeight="false|true"
    wordWrap="false|true"

    Styles
    alternatingItemColors="undefined"
    dropIndicatorSkin="ListDropIndicator"
    focusAlpha="0.5"
    focusRoundedCorners="tl tr bl br"
    paddingBottom="2"
    paddingLeft="2"
    paddingRight="0"
    paddingTop="2"
    rollOverColor="0xEEFEE6"
    selectionColor="0x7FCEFF"
    selectionDisabledColor="0xDDDDDD"
    selectionDuration="250"
    selectionEasingFunction="undefined"
    textRollOverColor="0x2B333C"
    textSelectedColor="0x2B333C"
    useRollOver="true|false"
    verticalAlign="top|middle|bottom"

    Events
    change="No default"
    dataChange="No default"
    itemClick="No default"
    itemDoubleClick="No default"
    itemRollOut="No default"
    itemRollOver="No default"
    itemClick="No default"
   />

See also

mx.collections.ICollectionView

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
 | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
 | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
 | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
 | dataProvider : Object Set of data to be viewed. | ListBase
 | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
 | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
 | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
 | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
 | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
 | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
 | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | itemRenderer : IFactory The custom item renderer for the control. | ListBase
 | labelField : String The name of the field in the data provider items to display as the label. | ListBase
 | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
 | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
 | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
 | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The maximum value for the horizontalScrollPosition property. | ScrollControlBase
Inherited | maxVerticalScrollPosition : Number The maximum value for the verticalScrollPosition property. | ScrollControlBase
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
 | rowCount : int Number of rows to be displayed. | ListBase
 | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
 | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
 | selectedIndex : int The index in the data provider of the selected item. | ListBase
 | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
 | selectedItem : Object A reference to the selected item in the data provider. | ListBase
 | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
 | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | value : Object [read-only] The selected item, or the data or label field of the selected item. | ListBase
 | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
 | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
 | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
 | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
 | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
 | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
 | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
 | caretUID : String The UID of the item under the caret. | ListBase
 | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
 | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
 | defaultRowCount : int = 4 The default number of rows to display. | ListBase
 | dragImage : IUIComponent [read-only] Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
 | dragImageOffsets : Point [read-only] Gets the offset of the drag image for drag and drop. | ListBase
 | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
 | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
 | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
 | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
 | freeItemRenderers : Array A stack of unused item renderers. | ListBase
 | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
 | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
 | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
 | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
 | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
 | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
 | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
 | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
 | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
 | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
 | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
 | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
 | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
 | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
 | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
 | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
 | selectionIndicators : Object A hash table of selection indicators. | ListBase
 | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
 | selectionTweens : Object A hash table of selection tweens. | ListBase
 | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
 | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
 | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ListBase()
Constructor.
ListBase
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
 | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
 | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
 | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
 | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
alternatingItemColors
Type: Array Format: Color CSS Inheritance: yes
The colors to use for the backgrounds of the items in the list. The value is an array of two or more colors. The backgrounds of the list items alternate among the colors in the array.

For DataGrid controls, all items in a row have the same background color, and each row's background color is determined from the array of colors.

For the TileList control, which uses a single list to populate a two-dimensional display, the style can result in a checkerboard appearance, stripes, or other patterns based on the number of columns and rows and the number of colors specified. TileList cycles through the colors, placing the individual item background colors according to the layout direction. If you have an even number of colors and an even number of columns for a TileList layed out horizontally, you will get striping. If the number of columns is an odd number, you will get a checkerboard pattern.

Only takes effect if no backgroundColor is specified.

The default value is undefined. 		ListBase
Inherited
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. 		ScrollControlBase
Inherited
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. 		ScrollControlBase
Inherited
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. 		ScrollControlBase
Inherited
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. 		ScrollControlBase
Inherited
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. 		ScrollControlBase
Inherited
borderSides
Type: String CSS Inheritance: no
Bounding box sides. 		ScrollControlBase
Inherited
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. 		ScrollControlBase
Inherited
borderStyle
Type: String CSS Inheritance: no
Bounding box style. 		ScrollControlBase
Inherited
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. 		ScrollControlBase
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
Inherited
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. 		ScrollControlBase
Inherited
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. 		ScrollControlBase
Inherited
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. 		ScrollControlBase
dropIndicatorSkin
Type: Class CSS Inheritance: no
The skin to use to indicate where a dragged item can be dropped. When a ListBase-derived component is a potential drop target in a drag-and-drop operation, a call to the showDropFeedback() method makes an instance of this class and positions it one pixel above the itemRenderer for the item where, if the drop occurs, is the item after the dropped item. The default value is mx.controls.listClasses.ListDropIndicator. 		ListBase
Inherited
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. 		ScrollControlBase
Inherited
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. 		ScrollControlBase
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
focusAlpha
Type: Number CSS Inheritance: no
Specifies the alpha transparency value of the focus skin. The default value is 0.4. 		ListBase
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
focusRoundedCorners
Type: String CSS Inheritance: no
Specifies which corners of the focus rectangle should be rounded. This value is a space-separated String that can contain any combination of "tl", "tr", "bl" and "br". For example, to specify that the right side corners should be rounded, but the left side corners should be square, use "tr br". The cornerRadius style property specifies the radius of the rounded corners. The default value depends on the component class; if not overridden for the class, default value is "tl tr bl br". 		ListBase
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
Inherited
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. 		ScrollControlBase
Inherited
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. 		ScrollControlBase
Inherited
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. 		ScrollControlBase
Inherited
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. 		ScrollControlBase
Inherited
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. 		ScrollControlBase
Inherited
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. 		ScrollControlBase
Inherited
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. 		ScrollControlBase
Inherited
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. 		ScrollControlBase
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
horizontalScrollBarStyleName
Type: String CSS Inheritance: no
Style name for horizontal scrollbar. 		ScrollControlBase
Inherited
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text. 		ScrollControlBase
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingBottom
Type: Number Format: Length CSS Inheritance: no
The number of pixels between the bottom of the row and the bottom of the renderer in the row. The default value is 2. 		ListBase
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

ListBase
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

ListBase
paddingTop
Type: Number Format: Length CSS Inheritance: no
The number of pixels between the top of the row and the top of the renderer in the row. The default value is 2. 		ListBase
Inherited
repeatDelay
Type: Number Format: Time CSS Inheritance: no
Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. 		ScrollControlBase
Inherited
repeatInterval
Type: Number Format: Time CSS Inheritance: no
Number of milliseconds between buttonDown events if the user presses and holds on a button. 		ScrollControlBase
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
rollOverColor
Type: uint Format: Color CSS Inheritance: yes
The color of the background of a renderer when the user rolls over it. The default value is 0xEEFEE6. 		ListBase
selectionColor
Type: uint Format: Color CSS Inheritance: yes
The color of the background of a renderer when the user selects it. The default value is 0x7FCEFF. 		ListBase
selectionDisabledColor
Type: uint Format: Color CSS Inheritance: yes
The color of the background of a renderer when the component is disabled. The default value is 0xDDDDDD. 		ListBase
selectionDuration
Type: Number Format: Time CSS Inheritance: no
The duration of the selection effect. When an item is selected an effect plays as the background is colored. Set to 0 to disable the effect. The default value is 250. 		ListBase
selectionEasingFunction
Type: Function CSS Inheritance: no
The easingFunction for the selection effect. When an item is selected an effect plays as the background is colored. The default is a linear fade in of the color. An easingFunction can be used for controlling the selection effect. The default value is undefined. 		ListBase
Inherited
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. 		ScrollControlBase
Inherited
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. 		ScrollControlBase
Inherited
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. 		ScrollControlBase
Inherited
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. 		ScrollControlBase
Inherited
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. 		ScrollControlBase
textRollOverColor
Type: uint Format: Color CSS Inheritance: yes
The color of the text of a renderer when the user rolls over a it. The default value is 0x2B333C. 		ListBase
textSelectedColor
Type: uint Format: Color CSS Inheritance: yes
The color of the text of a renderer when the user selects it. The default value is 0x2B333C. 		ListBase
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
useRollOver
Type: Boolean CSS Inheritance: no
A flag that controls whether items are highlighted as the mouse rolls over them. If true, rows are highlighted as the mouse rolls over them. If false, rows are highlighted only when selected. The default value is true. 		ListBase
verticalAlign
Type: String CSS Inheritance: no
The vertical alignment of a renderer in a row. Possible values are "top", "middle", and "bottom". The DataGrid positions the renderers in a row based on this style and the paddingTop and paddingBottom styles. if the item in the columns for a row have different heights Other list classes do not use verticalAlign but the item renderers can examine this style property and adjust their layout based on it. The default value is "top". 		ListBase
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Inherited
verticalScrollBarStyleName
Type: String CSS Inheritance: no
Style name for vertical scrollbar. 		ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
allowDragSelection property
public var allowDragSelection:Boolean = false

A flag that indicates whether drag-selection is enabled. Drag-Selection is the ability to select an item by dragging into it as opposed to normal selection where you can't have the mouse button down when you mouse over the item you want to select. This feature is used in ComboBox dropdowns to support pressing the mouse button when the mouse is over the dropdown button then dragging the mouse into the dropdown to select an item.

The default value is false.

allowMultipleSelection property
allowMultipleSelection:Boolean [read-write]

A flag that indicates whether you can allow more than one item to be selected at the same time. If true, users can select multiple items. There is no option to disallow discontiguous selection. Standard complex selection options are always in effect (shift-click, control-click).

The default value is false.

Implementation
    public function get allowMultipleSelection():Boolean
    public function set allowMultipleSelection(value:Boolean):void
anchorBookmark property
protected var anchorBookmark:CursorBookmark

A bookmark to the item that is the anchor. A bookmark allows the component to quickly seek to a position in the collection of items. This property is used when selecting a set of items between the anchor and the caret or highlighted item, and when finding the selected item after a Sort or Filter is applied.

anchorIndex property
protected var anchorIndex:int = -1

The offset of the item in the data provider that is the selection anchor point.

See also

mx.controls.listClasses.ListBase.caretItemRenderer
caretBookmark property
protected var caretBookmark:CursorBookmark

A bookmark to the item under the caret. A bookmark allows the component to quickly seek to a position in the collection of items.

caretIndex property
protected var caretIndex:int = -1

The offset of the item in the data provider that is the selection caret point.

See also

mx.controls.listClasses.ListBase.caretItemRenderer
caretIndicator property
protected var caretIndicator:Sprite

The DisplayObject that contains the graphics that indicate which renderer is the caret.

caretItemRenderer property
protected var caretItemRenderer:IListItemRenderer

The renderer for the item under the caret. In the selection model, there is an anchor, a caret and a highlighted item. When the mouse is being used for selection, the item under the mouse is highlighted as the mouse rolls over the item. When the mouse is clicked with no modifier keys (SHIFT or CTRL), the set of selected items is cleared and the item under the highlight is selected and becomes the anchor. The caret is unused in mouse selection. If there is an anchor and another item is selected while using the SHIFT key, the old set of selected items is cleared, and all items between the item and the anchor are selected. Clicking items while using the CTRL key toggles the selection of individual items and does not move the anchor.

When selecting items using the keyboard, if the arrow keys are used with no modifier keys, the old selection is cleared and the new item is selected and becomes the anchor and the caret, and a caret indicator is shown around the selection highlight. If the user uses arrow keys with the SHIFT key, the old selection is cleared and the items between the anchor and the new item are selected. The caret moves to the new item. If arrow keys are used with the CTRL key, just the caret moves. The user can use the SPACE key to toggle selection of the item under the caret.

caretUID property
protected var caretUID:String

The UID of the item under the caret.

collection property
protected var collection:ICollectionView

An ICollectionView that represents the data provider. When you set the dataProvider property, Flex wraps the data provider as necessary to support the ICollectionView interface and sets this property to the result. The ListBase class then uses this property to access data in the provider. When you get the dataProvider property, Flex returns this value.

columnCount property
columnCount:int [read-write]

The number of columns to be displayed in a TileList control or items in a HorizontalList control. For the DataGrid it is the number of visible columns. Note: Setting this property has no effect on a DataGrid control, which bases the number of columns on the control width and the individual column widths.

The default value is 4.

Implementation
    public function get columnCount():int
    public function set columnCount(value:int):void
columnWidth property
columnWidth:Number [read-write]

The width of the control's columns. This property is used by TileList and HorizontalList controls; It has no effect on DataGrid controls, where you set the individual DataGridColumn widths.

The default value is 50.

Implementation
    public function get columnWidth():Number
    public function set columnWidth(value:Number):void
data property
data:Object [read-write]

The item in the data provider this component should render when this component is used as an item renderer or item editor. The list class sets this property on each renderer or editor and the component displays the data. ListBase-derived classes support this property for complex situations like having a List of DataGrids or a DataGrid where one column is a List.

The list classes use the listData property in addition to the data property to determine what to display. If the list class is in a DataGrid it expects the dataField property of the column to map to a property in the data and sets selectedItem value to that property. If it is in a List or TileList control, it expects the labelField property of the list to map to a property in the data, and sets selectedItem value to that property. Otherwise it sets the selectedItem to the data itself.

This property uses the data provider but does not set it. In all cases, you must set the data provider in some other way.

You do not set this property in MXML.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
dataProvider property
dataProvider:Object [read-write]

Set of data to be viewed. This property lets you use most types of objects as data providers. If you set the dataProvider property to an Array, it will be converted to an ArrayCollection. If you set the property to an XML object, it will be converted into an XMLListCollection with only one item. If you set the property to an XMLList, it will be converted to an XMLListCollection. If you set the property to an object that implements the IList or ICollectionView interface, the object will be used directly.

As a consequence of the conversions, when you get the dataProvider property, it will always be an ICollectionView, and therefore not necessarily be the type of object you used to you set the property. This behavor is important to understand if you want to modify the data in the data provider: changes to the original data may not be detected, but changes to the ICollectionView object that you get back from the dataProvider property will be detected.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void

See also

mx.collections.ICollectionView
dataTipField property
dataTipField:String [read-write]

Name of the field in the data provider items to display as the data tip. By default, the list looks for a property named label on each item and displays it. However, if the data objects do not contain a label property, you can set the dataTipField property to use a different property in the data object. An example would be "FullName" when viewing a set of people's names retrieved from a database.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get dataTipField():String
    public function set dataTipField(value:String):void
dataTipFunction property
dataTipFunction:Function [read-write]

User-supplied function to run on each item to determine its dataTip. By default, the list looks for a property named label on each data provider item and displays it. However, some items do not have a label property nor do they have another property that can be used for displaying in the rows. An example is a data set that has lastName and firstName fields, but you want to display full names. You can supply a dataTipFunction that finds the appropriate fields and return a displayable string. The dataTipFunction is also good for handling formatting and localization.

The dataTipFunction takes a single argument which is the item in the data provider and returns a String:

myDataTipFunction(item:Object):String

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get dataTipFunction():Function
    public function set dataTipFunction(value:Function):void
defaultColumnCount property
protected var defaultColumnCount:int = 4

The default number of columns to display. This value is used if the calculation for the number of columns results in a value less than 1 when trying to calculate the columnCount based on size or content.

The default value is 4.

defaultRowCount property
protected var defaultRowCount:int = 4

The default number of rows to display. This value is used if the calculation for the number of columns results in a value less than 1 when trying to calculate the rowCount based on size or content.

The default value is 4.

dragEnabled property
dragEnabled:Boolean [read-write]

A flag that indicates whether you can drag items out of this control and drop them on other controls. If true, dragging is enabled for the control. If the dropEnabled property is also true, you can drag items and drop them within this control to reorder the items.

The default value is false.

Implementation
    public function get dragEnabled():Boolean
    public function set dragEnabled(value:Boolean):void
dragImage property
dragImage:IUIComponent [read-only]

Gets an instance of a class that displays the visuals during a drag and drop operation.

The default value is mx.controls.listClasses.ListItemDragProxy.

Implementation
    protected function get dragImage():IUIComponent
dragImageOffsets property
dragImageOffsets:Point [read-only]

Gets the offset of the drag image for drag and drop.

Implementation
    protected function get dragImageOffsets():Point
dragMoveEnabled property
dragMoveEnabled:Boolean [read-write]

A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. If true, and the dragEnabled property is true, items can be moved. Often the data provider cannot or should not have items removed from it, so a MOVE operation should not be allowed during drag-and-drop.

The default value is false.

Implementation
    public function get dragMoveEnabled():Boolean
    public function set dragMoveEnabled(value:Boolean):void
dropEnabled property
dropEnabled:Boolean [read-write]

A flag that indicates whether dragged items can be dropped onto the control.

If you set this property to true, the control accepts all data formats, and assumes that the dragged data matches the format of the data in the data provider. If you want to explicitly check the data format of the data being dragged, you must handle one or more of the drag events, such as dragOver, and call the DragEvent's preventDefault() method to customize the way the list class accepts dropped data.

The default value is false.

Implementation
    public function get dropEnabled():Boolean
    public function set dropEnabled(value:Boolean):void
explicitColumnCount property
protected var explicitColumnCount:int = -1

The column count requested by explicitly setting the columnCount property.

explicitColumnWidth property
protected var explicitColumnWidth:Number

The column width requested by explicitly setting the columnWidth.

explicitRowCount property
protected var explicitRowCount:int = -1

The row count requested by explicitly setting rowCount.

explicitRowHeight property
protected var explicitRowHeight:Number

The row height requested by explicitly setting rowHeight.

freeItemRenderers property
protected var freeItemRenderers:Array

A stack of unused item renderers. Most list classes recycle renderers they've already created as they scroll out of the displayable area; doing so saves time during scrolling. The recycled renderers are stored here.

highlightIndicator property
protected var highlightIndicator:Sprite

The DisplayObject that contains the graphics that indicates which renderer is highlighted.

highlightItemRenderer property
protected var highlightItemRenderer:IListItemRenderer

The renderer that is currently rolled over or under the caret.

highlightUID property
protected var highlightUID:String

The UID of the item that is current rolled over or under the caret.

iconField property
iconField:String [read-write]

The name of the field in the data provider object that determines what to display as the icon. By default, the list class does not try to display icons with the text in the rows. However, by specifying an icon field, you can specify a graphic that is created and displayed as an icon in the row. This property is ignored by DataGrid.

The renderers will look in the data provider object for a property of the name supplied as the iconField. If the value of the property is a Class, it will instantiate that class and expect it to be an instance of an IFlexDisplayObject. If the value of the property is a String, it will look to see if a Class exists with that name in the application, and if it can't find one, it will also look for a property on the document with that name and expect that property to map to a Class.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get iconField():String
    public function set iconField(value:String):void
iconFunction property
iconFunction:Function [read-write]

A user-supplied function to run on each item to determine its icon. By default the list does not try to display icons with the text in the rows. However, by specifying an icon function, you can specify a Class for a graphic that will be created and displayed as an icon in the row. This property is ignored by DataGrid.

The iconFunction takes a single argument which is the item in the data provider and returns a Class.

iconFunction(item:Object):Class

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get iconFunction():Function
    public function set iconFunction(value:Function):void
itemRenderer property
itemRenderer:IFactory [read-write]

The custom item renderer for the control. You can specify a drop-in, inline, or custom item renderer.

The default item renderer depends on the component class. The TileList and HorizontalList class use TileListItemRenderer, The List class uses ListItemRenderer. The DataGrid class uses DataGridItemRenderer from DataGridColumn.

Implementation
    public function get itemRenderer():IFactory
    public function set itemRenderer(value:IFactory):void
itemsNeedMeasurement property
protected var itemsNeedMeasurement:Boolean = true

A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. This property is set if a style changes that can affect the measurements of the renderer, or if the data provider is changed.

itemsSizeChanged property
protected var itemsSizeChanged:Boolean = false

A flag that indicates that the size of the renderers may have changed. The component usually responds by re-applying the data items to all of the renderers on the next updateDisplayList() call. There is an assumption that re-applying the items will invalidate the item renderers and cause them to re-measure.

iterator property
protected var iterator:IViewCursor

The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. At the end of any sequence of code, it must always be positioned at the topmost visible item being displayed.

iteratorValid property
protected var iteratorValid:Boolean = true

A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). If the component gets a page fault (an ItemPending error), it sets iteratorValid to false. Code that normally handles the rendering of items checks this flag and does not run until the page of data comes in from the server.

keySelectionPending property
protected var keySelectionPending:Boolean = false

A flag that indicates if keyboard selection was interrupted by a page fault. The component responds by suspending the rendering of items until the page of data arrives. The finishKeySelection() method will be called when the paged data arrives

labelField property
labelField:String [read-write]

The name of the field in the data provider items to display as the label. By default the list looks for a property named label on each item and displays it. However, if the data objects do not contain a label property, you can set the labelField property to use a different property in the data object. An example would be "FullName" when viewing a set of people names fetched from a database.

The default value is "label".

This property can be used as the source for data binding.

Implementation
    public function get labelField():String
    public function set labelField(value:String):void
labelFunction property
labelFunction:Function [read-write]

A user-supplied function to run on each item to determine its label. By default, the list looks for a property named label on each data provider item and displays it. However, some data sets do not have a label property nor do they have another property that can be used for displaying. An example is a data set that has lastName and firstName fields but you want to display full names.

You can supply a labelFunction that finds the appropriate fields and returns a displayable string. The labelFunction is also good for handling formatting and localization.

For most components, the label function takes a single argument which is the item in the data provider and returns a String.

labelFunction(item:Object):String

The method signature for the DataGrid and DataGridColumn classes is:

labelFunction(item:Object, column:DataGridColumn):String
where item contains the DataGrid item object, and column specifies the DataGrid column.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get labelFunction():Function
    public function set labelFunction(value:Function):void
lastDropIndex property
protected var lastDropIndex:int

The most recently calculated index where the drag item should be added to the drop target.

lastSeekPending property
protected var lastSeekPending:ListBaseSeekPending

The most recent seek that caused a page fault. If there are multiple page faults, only the most recent one is of interest, as that is where to position the iterator and start rendering rows again.

listContent property
protected var listContent:ListBaseContentHolder

An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. This is roughly equivalent to the contentPane in the Container class, and is used for managing scrolling.

listData property
listData:BaseListData [read-write]

When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. The component can then use the listData property and the data property to display the appropriate information as a drop-in item renderer or drop-in item editor.

You do not set this property in MXML or ActionScript; Flex sets it when the component is used as a drop-in item renderer or drop-in item editor.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
listItems property
protected var listItems:Array

An Array of Arrays that contains the itemRenderer instances that render each data provider item. This is a two-dimensional row major array (array of rows that are arrays of columns).

lockedColumnCount property
lockedColumnCount:int [read-write]

The index of the first column in the control that scrolls. Columns with indexes that are lower than this value remain fixed in view. Not supported by all list classes.

The default value is 0.

Implementation
    public function get lockedColumnCount():int
    public function set lockedColumnCount(value:int):void
lockedRowCount property
lockedRowCount:int [read-write]

The index of the first row in the control that scrolls. Rows above this one remain fixed in view.

The default value is 0.

Implementation
    public function get lockedRowCount():int
    public function set lockedRowCount(value:int):void
menuSelectionMode property
public var menuSelectionMode:Boolean = false

A flag that indicates whether menu-style selection should be used. In a Menu, dragging from one renderer into another selects the new one and un-selects the old.

rendererChanged property
protected var rendererChanged:Boolean = false

A flag that indicates that the renderer changed. The component usually responds by destroying all existing renderers and redrawing all of the renderers on the next updateDisplayList() call.

rowCount property
rowCount:int [read-write]

Number of rows to be displayed. If the height of the component has been explicitly set, this property might not have any effect.

The default value is 4.

Implementation
    public function get rowCount():int
    public function set rowCount(value:int):void
rowHeight property
rowHeight:Number [read-write]

The height of the rows in pixels. Unless the variableRowHeight property is true, all rows are the same height. If not specified, the row height is based on the font size and other properties of the renderer.

Implementation
    public function get rowHeight():Number
    public function set rowHeight(value:Number):void
rowInfo property
protected var rowInfo:Array

An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems.

rowMap property
protected var rowMap:Object

A hash map of item renderers to their respective ListRowInfo object. The ListRowInfo object is indexed by the DisplayObject name of the item renderer.

selectable property
selectable:Boolean [read-write]

A flag that indicates whether the list shows selected items as selected. If true, the control supports selection. The Menu class, which subclasses ListBase, sets this property to false by default, because it doesn't show the chosen menu item as selected.

The default value is true.

Implementation
    public function get selectable():Boolean
    public function set selectable(value:Boolean):void
selectedData property
protected var selectedData:Object

A hash table of ListBaseSelectionData objects that track which items are currently selected. The table is indexed by the UID of the items.

See also

mx.controls.listClasses.ListBaseSelectionData
selectedIndex property
selectedIndex:int [read-write]

The index in the data provider of the selected item.

The default value is -1 (no selected item).

This property can be used as the source for data binding.

Implementation
    public function get selectedIndex():int
    public function set selectedIndex(value:int):void
selectedIndices property
selectedIndices:Array [read-write]

An array of indices in the data provider of the selected items. The items are in the order that the user selected the items.

The default value is [ ].

This property can be used as the source for data binding.

Implementation
    public function get selectedIndices():Array
    public function set selectedIndices(value:Array):void
selectedItem property
selectedItem:Object [read-write]

A reference to the selected item in the data provider.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get selectedItem():Object
    public function set selectedItem(value:Object):void
selectedItems property
selectedItems:Array [read-write]

An array of references to the selected items in the data provider. The items are in the order that the user selected the items.

The default value is [ ].

This property can be used as the source for data binding.

Implementation
    public function get selectedItems():Array
    public function set selectedItems(value:Array):void
selectionIndicators property
protected var selectionIndicators:Object

A hash table of selection indicators. This table allows the component to quickly find and remove the indicators when the set of selected items is cleared. The table is indexed by the item's UID.

selectionLayer property
protected var selectionLayer:Sprite

The layer in listContent where all selection and highlight indicators are drawn.

selectionTweens property
protected var selectionTweens:Object

A hash table of selection tweens. This allows the component to quickly find and clean up any tweens in progress if the set of selected items is cleared. The table is indexed by the item's UID.

showCaret property
protected var showCaret:Boolean

A flag that indicates whether to show caret. This property is usually set to false when mouse activity is detected and set back to true when the keyboard is used for selection.

showDataTips property
showDataTips:Boolean [read-write]

A flag that indicates whether dataTips are displayed for text in the rows. If true, dataTips are displayed. DataTips are tooltips designed to show the text that is too long for the row. If you set a dataTipFunction, dataTips are shown regardless of whether the text is too long for the row.

The default value is false.

This property can be used as the source for data binding.

Implementation
    public function get showDataTips():Boolean
    public function set showDataTips(value:Boolean):void
value property
value:Object [read-only]

The selected item, or the data or label field of the selected item. If the selected item is a Number or String the value is the item. If the item is an object, the value is the data property if it exists, or the label property if it exists.

Note: Using selectedItem is often preferable. This property exists for backward compatibility with older applications

This property can be used as the source for data binding.

Implementation
    public function get value():Object
variableRowHeight property
variableRowHeight:Boolean [read-write]

A flag that indicates whether the individual rows can have different height. This property is ignored by TileList and HorizontalList. If true, individual rows can have different height values.

The default value is false.

Implementation
    public function get variableRowHeight():Boolean
    public function set variableRowHeight(value:Boolean):void
visibleData property
protected var visibleData:Object

A hash table of data provider item renderers currently in view. The table is indexed by the data provider item's UID and is used to quickly get the renderer used to display a partuclar item.

wordWrap property
wordWrap:Boolean [read-write]

A flag that indicates whether text in the row should be word wrapped. If true, enables word wrapping for text in the rows. Only takes effect if variableRowHeight is also true

The default value is false.

Implementation
    public function get wordWrap():Boolean
    public function set wordWrap(value:Boolean):void
wordWrapChanged property
protected var wordWrapChanged:Boolean = false

A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. This property is set when you change the wordWrap property value, and is reset to false by the updateDisplayList() method. The component usually responds by re-applying the data items to all of the renderers on the next updateDisplayList() call. This is different from itemsSizeChanged because it further indicates that re-applying the data items to the renderers may not invalidate them since the only thing that changed was whether or not the renderer should factor in wordWrap into its size calculations

Constructor detail
ListBase () constructor
public function ListBase()

Constructor.

Method detail
addDragData () method
protected function addDragData(ds:Object):void

Adds the selected items to the DragSource object as part of a drag-and-drop operation. Override this method to add other data to the drag source.

Parameters
ds:Object — The DragSource object to which to add the data.
addToFreeItemRenderers () method
protected function addToFreeItemRenderers(item:IListItemRenderer):void

Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.

Parameters
item:IListItemRenderer — IListItemRenderer
applySelectionEffect () method
protected function applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void

Sets up the effect for applying the selection indicator. The default is a basic alpha tween.

Parameters
indicator:Sprite — A Sprite that contains the graphics depicting selection
uid:String — The UID of the item being selected which can be used to index into a table and track more than one selection effect
itemRenderer:IListItemRenderer — The item renderer that is being shown as selected
calculateDropIndex () method
public function calculateDropIndex(event:DragEvent = null):int

Returns the index where the dropped items should be added to the drop target.

Parameters
event:DragEvent (default = null) — A DragEvent that contains information about the position of the mouse. If null the method should return the dropIndex value from the last valid event.

Returns
int — Index where the dropped items should be added.
calculateDropIndicatorY () method
protected function calculateDropIndicatorY(rowCount:Number, rowNum:int):Number

Calculates the y position of the drop indicator when performing a drag-and-drop operation.

Parameters
rowCount:Number — The number of visible rows in the control.
rowNum:int — The row number in the control where the drop indicator should appear.

Returns
Number — The y axis coordinate of the drop indicator.
clearIndicators () method
protected function clearIndicators():void

Removes all selection and highlight and caret indicators.

clearSelected () method
protected function clearSelected(transition:Boolean = false):void

Clears the set of selected items and removes all graphics depicting the selected state of those items.

Parameters
transition:Boolean (default = false) — true if the graphics should have a fadeout effect.
collectionChangeHandler () method
protected function collectionChangeHandler(event:Event):void

Handles CollectionEvents dispatched from the data provider as the data changes. Updates the renderers, selected indices and scrollbars as needed.

Parameters
event:Event — The CollectionEvent.
commitProperties () method
protected override function commitProperties():void

Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.

See also

mx.core.ScrollControlBase
configureScrollBars () method
protected function configureScrollBars():void

Configures the ScrollBars based on the number of rows and columns and viewable rows and columns. This method is called from the updateDisplayList() method after the rows and columns have been updated. The method should figures out what parameters to pass into the setScrollBarProperties() to properly set the ScrollBars up.

copySelectedItems () method
protected function copySelectedItems(useDataField:Boolean = true):Array

Makes a copy of the selected items in the order they were selected.

Parameters
useDataField:Boolean (default = true) — true if the array should be filled with the actual items or false if the array should be filled with the indexes of the items

Returns
Array — array of selected items
createChildren () method
protected override function createChildren():void

Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers. Note that the item renderers are not created immediately, but later when Flex calls the updateDisplayList() method.

dragCompleteHandler () method
protected function dragCompleteHandler(event:DragEvent):void

Handles DragEvent.DRAG_COMPLETE events. This method removes the item from the data provider.

Parameters
event:DragEvent — The DragEvent
dragDropHandler () method
protected function dragDropHandler(event:DragEvent):void

Handles DragEvent.DRAG_DROP events. This method hides the UI feeback by calling the hideDropFeedback() method.

Parameters
event:DragEvent — The DragEvent
dragEnterHandler () method
protected function dragEnterHandler(event:DragEvent):void

Handles DragEvent.DRAG_ENTER events. This method determines if the DragSource object contains valid elements and uses the showDropFeedback() method to set up the UI feeback.

Parameters
event:DragEvent — The DragEvent
dragExitHandler () method
protected function dragExitHandler(event:DragEvent):void

Handles DragEvent.DRAG_EXIT events. This method hides the UI feeback by calling the hideDropFeedback() method.

Parameters
event:DragEvent — The DragEvent
dragOverHandler () method
protected function dragOverHandler(event:DragEvent):void

Handles DragEvent.DRAG_OVER events. This method determines if the DragSource object contains valid elements and uses the showDropFeedback() method to set up the UI feeback.

Parameters
event:DragEvent — The DragEvent
dragScroll () method
protected function dragScroll():void

Interval function that scrolls the list up or down if the mouse goes above or below the list.

drawCaretIndicator () method
protected function drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void

Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.

Parameters
indicator:Sprite — A Sprite that should contain the graphics for that make a renderer look highlighted
x:Number — The suggested x position for the indicator
y:Number — The suggested y position for the indicator
width:Number — The suggested width for the indicator
height:Number — The suggested height for the indicator
color:uint — The suggested color for the indicator
itemRenderer:IListItemRenderer — The item renderer that is being highlighted
drawHighlightIndicator () method
protected function drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void

Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.

Parameters
indicator:Sprite — A Sprite that should contain the graphics for that make a renderer look highlighted
x:Number — The suggested x position for the indicator
y:Number — The suggested y position for the indicator
width:Number — The suggested width for the indicator
height:Number — The suggested height for the indicator
color:uint — The suggested color for the indicator
itemRenderer:IListItemRenderer — The item renderer that is being highlighted
drawItem () method
protected function drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void

Draws the renderer with indicators that it is highlighted, selected, or the caret.

Parameters
item:IListItemRenderer — The renderer.
selected:Boolean (default = false) — true if the renderer should be drawn in its selected state.
highlighted:Boolean (default = false) — true if the renderer should be drawn in its highlighted state.
caret:Boolean (default = false) — true if the renderer should be drawn as if it is the selection caret.
transition:Boolean (default = false) — true if the selection state should fade in via an effect.
drawRowBackgrounds () method
protected function drawRowBackgrounds():void

Draws any alternating row colors, borders and backgrounds for the rows.

drawSelectionIndicator () method
protected function drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void

Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.

Parameters
indicator:Sprite — A Sprite that should contain the graphics for that make a renderer look highlighted
x:Number — The suggested x position for the indicator
y:Number — The suggested y position for the indicator
width:Number — The suggested width for the indicator
height:Number — The suggested height for the indicator
color:uint — The suggested color for the indicator
itemRenderer:IListItemRenderer — The item renderer that is being highlighted
findKey () method
protected function findKey(eventCode:int):Boolean

Tries to find the next item in the data provider that starts with the character in the eventCode parameter. You can override this to do fancier typeahead lookups. The search starts at the selectedIndex location; if it reaches the end of the data provider it starts over from the beginning.

Parameters
eventCode:int — The key that was pressed on the keyboard

Returns
Boolean — true if a match was found
findString () method
public function findString(str:String):Boolean

Finds an item in the list based on a string and moves the selection to it. The search starts at the selectedIndex location; if it reaches the end of the data provider it starts over from the beginning.

Parameters
str:String — The string to match

Returns
Boolean — true if a match was found
finishKeySelection () method
protected function finishKeySelection():void

Sets selected items based on the caretIndex and anchorIndex properties. Called by the keyboard selection handlers and by the updateDisplayList method in case the keyboard selection handler got a page fault while scrolling to get more items.

hideDropFeedback () method
public function hideDropFeedback(event:DragEvent):void

Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.

Parameters
event:DragEvent — A DragEvent object that contains information about the mouse location.
indexToColumn () method
protected function indexToColumn(index:int):int

The column for the data provider item at the given index.

Parameters
index:int — The offset into the data provider

Returns
int — The column the item would be displayed at in the component.
indexToItemRenderer () method
public function indexToItemRenderer(index:int):IListItemRenderer

Get an item renderer for the index of an item in the data provider, if one exists. Since item renderers only exist for items within the set of viewable rows items, you cannot use this method for items that are not visible.

Parameters
index:int — The offset into the data provider for an item

Returns
IListItemRenderer — The item renderer that is displaying the item, or null if the item is not currently displayed.
indexToRow () method
protected function indexToRow(index:int):int

The row for the data provider item at the given index.

Parameters
index:int — The offset into the data provider.

Returns
int — The row the item would be displayed at in the component.
indicesToIndex () method
public function indicesToIndex(rowIndex:int, colIndex:int):int

Computes the offset into the data provider of the item at colIndex, rowIndex. The 9th row 3rd column in a TileList could be different items in the data provider based on the direction the tiles are laid out and the number of rows and columns in the TileList.

Parameters
rowIndex:int — The 0-based index of the row, including rows scrolled off the top. Thus, if verticalScrollPosition is 2 then the first visible row has a rowIndex of 2.
colIndex:int — The 0-based index of the column, including columns scrolled off the left. If horizontalScrollPosition is 2 then the first column on the left has a columnIndex of 2.

Returns
int — The offset into the data provider.
invalidateList () method
public function invalidateList():void

Refresh all rows on next update.

isItemHighlighted () method
public function isItemHighlighted(data:Object):Boolean

Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).

Parameters
data:Object — The data provider item

Returns
Boolean — true if the item is highlighted
isItemSelected () method
public function isItemSelected(data:Object):Boolean

Determines if the item renderer for a data provider item is selected.

Parameters
data:Object — The data provider item

Returns
Boolean — true if the item is highlighted
isItemVisible () method
public function isItemVisible(item:Object):Boolean

Determines if an item is being displayed by a renderer.

Parameters
item:Object — A data provider item.

Returns
Boolean — true if the item is being displayed.
itemRendererContains () method
public function itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean

Determines whether a renderer contains (or owns) a display object. Ownership means that the display object isn't actually parented by the renderer but is associated with it in some way. Popups should be owned by the renderers so that activity in the popup is associated with the renderer and not seen as activity in another component.

Parameters
renderer:IListItemRenderer — The renderer that might contain or own the display object.
object:DisplayObject — The display object that might be associated with the renderer.

Returns
Boolean — true if the display object is contained or owned by the renderer.
itemRendererToIndex () method
public function itemRendererToIndex(itemRenderer:IListItemRenderer):int

Returns the index of the item in the data provider of the item being rendered by this item renderer. Since item renderers only exist for items that are within the set of viewable rows, you cannot use this method for items that are not visible.

Parameters
itemRenderer:IListItemRenderer — The item renderer that is displaying the item for which you want to know the data provider index.

Returns
int — The index of the item in the data provider
itemRendererToIndices () method
protected function itemRendererToIndices(item:IListItemRenderer):Point

Returns a Point containing the columnIndex and rowIndex of an item renderer. Since item renderers are only created for items within the set of viewable rows you cannot use this method to get the indices for items that are not visible. Also note that item renderers are recycled so the indices you get for an item may change if that item renderer is reused to display a different item. Usually, this method is called during mouse and keyboard handling when the set of data displayed by the item renderers hasn't yet changed.

Parameters
item:IListItemRenderer — An item renderer

Returns
Point — A Point. The x property is the columnIndex and the y property is the rowIndex.
itemToDataTip () method
public function itemToDataTip(data:Object):String

Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties. If the method cannot convert the parameter to a string, it returns a single space.

For use by developers creating subclasses of ListBase or its children. Not used by application developers.

Parameters
data:Object — Object to be rendered.

Returns
String — String displayable string based on the data.
itemToIcon () method
public function itemToIcon(data:Object):Class

Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties. The field in the item can return a string as long as that string represents the name of a class in the application. The field in the item can also be a string that is the name of a variable in the document that holds the class for the icon.

Parameters
data:Object — The item from which to extract the icon class

Returns
Class — The icon for the item, as a class reference or null if none.
itemToItemRenderer () method
public function itemToItemRenderer(item:Object):IListItemRenderer

Returns the item renderer for a given item in the data provider, if there is one. Since item renderers only exist for items that are within the set of viewable rows, this method returns null if the item is not visible. For DataGrid, this will return the first column's renderer.

Parameters
item:Object — The data provider item

Returns
IListItemRenderer — The item renderer or null if the item is not currently displayed.
itemToLabel () method
public function itemToLabel(data:Object):String

Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties. If the method cannot convert the parameter to a string, it returns a single space.

Parameters
data:Object — Object to be rendered.

Returns
String — The string to be displayed based on the data.
itemToUID () method
protected function itemToUID(data:Object):String

Determines the UID for a data provider item. All items in a data provider must either have a unique ID (UID) or one will be generated and associated with it. This means that you cannot have an object or scalar value appear twice in a data provider. For example, the following data provider is not supported because the value "foo" appears twice and the UID for a string is the string itself

var sampleDP:Array = ["foo", "bar", "foo"]
Simple dynamic objects can appear twice if they are two separate instances. The following is supported because each of the instances will be given a different UID because they are different objects.
var sampleDP:Array = [{label: "foo"}, {label: "foo"}]
Note that the following is not supported because the same instance appears twice.
var foo:Object = {label: "foo"}; sampleDP:Array = [foo, foo];

Parameters
data:Object — The data provider item

Returns
String — The UID as a string
makeRowsAndColumns () method
protected function makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point

Make enough rows and columns to fill the area described by left, top, right, bottom. Renderers are created and inserted into the listItems array starting at (firstColumn, firstRow)( and moving downwards.

If byCount and rowsNeeded are specified, then just make that many rows and ignore the bottom and right parameters.

Parameters
left:Number — Horizontal pixel offset of area to fill.
top:Number — Vertical pixel offset of area to fill.
right:Number — Horizontal pixel offset of area to fill (from left side of component).
bottom:Number — Vertical pixel offset of area to fill (from top of component).
firstColumn:int — Offset into listItems to store the first renderer to be created.
firstRow:int — Offset into listItems to store the first renderer to be created.
byCount:Boolean (default = false) — If true, make rowsNeeded number of rows and ignore bottom parameter
rowsNeeded:uint (default = 0) — Number of rows to create if byCount is true;

Returns
Point — A Point containing the number of rows and columns created.
measure () method
protected override function measure():void

Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.

See also

mx.core.ScrollControlBase
measureHeightOfItems () method
public function measureHeightOfItems(index:int = -1, count:int = 0):Number

Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.

This method is not implemented in the ListBase class and must be implemented in the child class.

A negative index value can be used to specify that the height calculation includes any headers.

Parameters
index:int (default = -1) — The data provider item at which to start calculating the height.
count:int (default = 0) — The number of items to use in calculating the height.

Returns
Number — the sum of the height of the measured items.
measureWidthOfItems () method
public function measureWidthOfItems(index:int = -1, count:int = 0):Number

Measures a set of items from the data provider using the current item renderer and returns the maximum width found. This method is used to calculate the width of the component. The various ListBase-derived classes have slightly different implementations. DataGrid measures its columns instead of data provider items, and TileList just measures the first item and assumes all items are the same size.

This method is not implemented in the ListBase class and must be implemented in the child class.

A negative index value can be used to specify that the width calculation includes any headers.

Parameters
index:int (default = -1) — The data provider item at which to start measuring the width.
count:int (default = 0) — The number of items to measure in calculating the width.

Returns
Number — The widest of the measured items.
mouseClickHandler () method
protected function mouseClickHandler(event:MouseEvent):void

Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers. This method determines which renderer was clicked and dispatches a ListEvent.ITEM_CLICK event.

Parameters
event:MouseEvent
mouseDoubleClickHandler () method
protected function mouseDoubleClickHandler(event:MouseEvent):void

Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers. This method determines which renderer was clicked and dispatches a ListEvent.ITEM_DOUBLE_CLICK event.

Parameters
event:MouseEvent
mouseDownHandler () method
protected function mouseDownHandler(event:MouseEvent):void

Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers. This method finds the renderer that was pressed and prepares to receive a MouseEvent.MOUSE_UP event.

Parameters
event:MouseEvent — The mouse event
mouseEventToItemRenderer () method
protected function mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer

Determines which item renderer is under the mouse. Item renderers can be made of multiple mouse targets, or have visible areas that are not mouse targets. This method checks both targets and position to determine which item renderer the mouse is over from the user's perspective, which can differ from the information provied by the mouse event.

Parameters
event:MouseEvent — A MouseEvent that contains the position of the mouse and the object it is over

Returns
IListItemRenderer — The item renderer the mouse is over or null if none.
mouseMoveHandler () method
protected function mouseMoveHandler(event:MouseEvent):void

Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers. This method watches for a gesture that constitutes the beginning of a drag drop and send a DragEvent.DRAG_START event. It also checks to see if the mouse is over a non-target area of a renderer so that Flex can try to make it look like that renderer was the target.

Parameters
event:MouseEvent — The mouse event
mouseOutHandler () method
protected function mouseOutHandler(event:MouseEvent):void

Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers. This method finds out which renderer the mouse has left and removes the highlights.

Parameters
event:MouseEvent — The mouse event
mouseOverHandler () method
protected function mouseOverHandler(event:MouseEvent):void

Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers. This method finds out which renderer the mouse is over and shows it as highlighted.

The list classes also call this from a MouseEvent.MOUSE_MOVE event. This event is used to detect movement in non-target areas of the renderers and in padded areas around the renderers.

Parameters
event:MouseEvent — The mouse event
mouseUpHandler () method
protected function mouseUpHandler(event:MouseEvent):void

Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers. This method finds the renderer that was pressed and prepares to receive a MouseEvent.MOUSE_UP event.

Parameters
event:MouseEvent — The mouse event
mouseWheelHandler () method
protected override function mouseWheelHandler(event:MouseEvent):void

Handles mouseWheel events by changing scroll positions. This is a copy of the version in ScrollControlBase, modified to change the horizontalScrollPosition if the target is runs horizontally

Parameters
event:MouseEvent

See also

mx.core.ScrollControlBase.mouseWheelHandler()
moveSelectionHorizontally () method
protected function moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void

Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys. This method might change the horizontalScrollPosition, verticalScrollPosition, and caretIndex properties, and call the finishKeySelection()method to update the selection.

Not implemented in ListBase because the default list is single column and therefore doesn't scroll horizontally.

Parameters
code:uint — The key that was pressed (e.g. Keyboard.LEFT)
shiftKey:Boolean — true if the shift key was held down when the keyboard key was pressed.
ctrlKey:Boolean — true if the ctrl key was held down when the keyboard key was pressed
moveSelectionVertically () method
protected function moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void

Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys. This method might change the horizontalScrollPosition, verticalScrollPosition, and caretIndex properties, and call the finishKeySelection()method to update the selection

Parameters
code:uint — The key that was pressed (e.g. Keyboard.DOWN)
shiftKey:Boolean — true if the shift key was held down when the keyboard key was pressed.
ctrlKey:Boolean — true if the ctrl key was held down when the keyboard key was pressed
removeIndicators () method
protected function removeIndicators(uid:String):void

Cleans up selection highlights and other associated graphics for a given item in the data provider.

Parameters
uid:String — The UID of the data provider item
scrollHorizontally () method
protected function scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void

Adjusts the renderers in response to a change in scroll position.

The list classes attempt to optimize scrolling when the scroll position has changed by less than the number of visible rows. In that situation some rows are unchanged and just need to be moved, other rows are removed and then new rows are added. If the scroll position changes too much, all old rows are removed and new rows are added by calling the makeRowsAndColumns() method for the entire viewable area.

Not implemented in ListBase because the default list is single column and therefore doesn't scroll horizontally.

Parameters
pos:int — The new scroll position.
deltaPos:int — The change in position. It is always a positive number.
scrollUp:Boolean — true if scroll position is getting smaller.
scrollPositionToIndex () method
protected function scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int

Returns the data provider index for the item at the first visible row and column for the given scroll positions.

Parameters
horizontalScrollPosition:int — The horizontalScrollPosition property value corresponding to the scroll position.
verticalScrollPosition:int — The verticalScrollPosition property value corresponding to the scroll position.

Returns
int — The data provider index
scrollToIndex () method
public function scrollToIndex(index:int):Boolean

Ensures that the data provider item at the given index is visible. If the item is visible, the verticalScrollPosition property is left unchanged even if the item is not the first visible item. If the item is not currently visible, the verticalScrollPosition property is changed make the item the first visible item, unless there aren't enough rows to do so because the verticalScrollPosition value is limited by the maxVerticalScrollPosition property.

Parameters
index:int

Returns
Boolean — true if verticalScrollPosition changed
scrollVertically () method
protected function scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void

Adjusts the renderers in response to a change in scroll position.

The list classes attempt to optimize scrolling when the scroll position has changed by less than the number of visible rows. In that situation some rows are unchanged and just need to be moved, other rows are removed and then new rows are added. If the scroll position changes too much, all old rows are removed and new rows are added by calling the makeRowsAndColumns() method for the entire viewable area.

Parameters
pos:int — The new scroll position.
deltaPos:int — The change in position. It is always a positive number.
scrollUp:Boolean — true if scroll position is getting smaller.
seekPendingFailureHandler () method
protected function seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void

The default failure handler when a seek fails due to a page fault.

Parameters
data:Object
info:ListBaseSeekPending
seekPendingResultHandler () method
protected function seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void

The default result handler when a seek fails due to a page fault. This method checks to see if it has the most recent page fault result: if not it simply exits; if it does, it sets the iterator to the correct position.

Parameters
data:Object
info:ListBaseSeekPending
selectItem () method
protected function selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean

Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state. This method also updates the display of the item renderers based on their updated selected state.

Parameters
item:IListItemRenderer — The item renderer that was clicked
shiftKey:Boolean — true if the shift key was held down when the mouse was clicked.
ctrlKey:Boolean — true if the ctrl key was held down when the mouse was clicked.
transition:Boolean (default = true) — true if the graphics for the selected state should be faded in using an effect.

Returns
Boolean — true if the set of selected items changed. Clicking on an already-selected item doesn't always change the set of selected items.
setRowCount () method
protected function setRowCount(v:int):void

Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.

Parameters
v:int
setRowHeight () method
protected function setRowHeight(v:Number):void

Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows

Parameters
v:Number
showDropFeedback () method
public function showDropFeedback(event:DragEvent):void

Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.

Parameters
event:DragEvent — A DragEvent object that contains information as to where the mouse is.
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Adds or removes item renderers if the number of displayable items changed. Refreshes the item renderers if they might have changed. Applies the selection if it was changed programmatically.

Parameters
unscaledWidth:Number
unscaledHeight:Number

See also

mx.core.ScrollControlBase
updateList () method
protected function updateList():void

Refreshes all rows now. Calling this method can require substantial processing, because can be expensive at it completely redraws all renderers in the list and won't return until complete.

Event detail
change event
Event object type: flash.events.Event

Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction.

dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
itemClick event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_CLICK

Dispatched when the user clicks on an item in the control.

The ListEvent.ITEM_CLICK constant defines the value of the type property of the ListEvent object for an itemClick event, which indicates that the user clicked the mouse over a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was clicked.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_CLICK
itemDoubleClick event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_DOUBLE_CLICK

Dispatched when the user double-clicks on an item in the control.

The ListEvent.ITEM_DOUBLE_CLICK constant defines the value of the type property of the ListEvent object for an itemDoubleClick event, which indicates that the user double clicked the mouse over a visual item in the control.

To receive itemDoubleClick events, you must set the component's doubleClickEnabled property to true.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was double clicked.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_DOUBLE_CLICK
itemRollOut event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_ROLL_OUT

Dispatched when the user rolls the mouse pointer out of an item in the control.

The ListEvent.ITEM_ROLL_OUT constant defines the value of the type property of the ListEvent object for an itemRollOut event, which indicates that the user rolled the mouse pointer out of a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was rolled out.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_ROLL_OUT
itemRollOver event
Event object type: mx.events.ListEvent
ListEvent.type property = mx.events.ListEvent.ITEM_ROLL_OVER

Dispatched when the user rolls the mouse pointer over an item in the control.

The ListEvent.ITEM_ROLL_OVER constant defines the value of the type property of the ListEvent object for an itemRollOver event, which indicates that the user rolled the mouse pointer over a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was rolled over.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_ROLL_OVER


mx.controls.listClasses.ListBaseSeekPending (Flex™ 2 Language Reference)

Class ListBaseSeekPending | Properties | Methods
Package | mx.controls.listClasses
Class | public class ListBaseSeekPending
Inheritance | ListBaseSeekPending Inheritance Object

An object that stores data about a seek operation that was interrupted by an ItemPendingError error.

See also

mx.collections.errors.ItemPendingError
mx.controls.listClasses.ListBase.lastSeekPending

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bookmark : CursorBookmark The bookmark that was being used in the seek operation. | ListBaseSeekPending
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | offset : int The offset from the bookmark that was the target of the seek operation. | ListBaseSeekPending
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ListBaseSeekPending(bookmark:CursorBookmark, offset:int) Constructor. | ListBaseSeekPending
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
bookmark property
public var bookmark:CursorBookmark

The bookmark that was being used in the seek operation.

offset property
public var offset:int

The offset from the bookmark that was the target of the seek operation.

Constructor detail
ListBaseSeekPending () constructor
public function ListBaseSeekPending(bookmark:CursorBookmark, offset:int)

Constructor.

Parameters
bookmark:CursorBookmark — The bookmark that was being used in the seek operation.
offset:int — The offset from the bookmark that was the target of the seek operation.


mx.controls.listClasses.ListBaseSelectionData (Flex™ 2 Language Reference)

Class ListBaseSelectionData | Properties | Methods
Package | mx.controls.listClasses
Class | public class ListBaseSelectionData
Inheritance | ListBaseSelectionData Inheritance Object

Records used by list classes to keep track of what is selected. Each selected item is represented by an instance of this class.

See also

mx.controls.listClasses.ListBase.selectedData

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | approximate : Boolean If true, then the index property is an approximate value and not the exact value. | ListBaseSelectionData
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The data Object that is selected (selectedItem) | ListBaseSelectionData
 | index : int The index in the data provider of the selected item. | ListBaseSelectionData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ListBaseSelectionData(data:Object, index:int, approximate:Boolean) Constructor. | ListBaseSelectionData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
approximate property
public var approximate:Boolean

If true, then the index property is an approximate value and not the exact value.

data property
public var data:Object

The data Object that is selected (selectedItem)

index property
public var index:int

The index in the data provider of the selected item. (may be approximate)

Constructor detail
ListBaseSelectionData () constructor
public function ListBaseSelectionData(data:Object, index:int, approximate:Boolean)

Constructor.

Parameters
data:Object — The data Object that is selected
index:int — The index in the data provider of the selected item. (may be approximate)
approximate:Boolean — If true, then the index property is an approximate value and not the exact value.


mx.controls.listClasses.ListData (Flex™ 2 Language Reference)

Class ListData | Properties | Methods
Package | mx.controls.listClasses
Class | public class ListData
Inheritance | ListData Inheritance BaseListData Inheritance Object

The ListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the List control. All drop-in item renderers and drop-in item editors must implement the IDropInListItemRenderer interface, which defines the listData property.

While the properties of this class are writable, you should consider them to be read only. They are initialized by the List class, and read by an item renderer or item editor. Changing these values can lead to unexpected results.

See also

mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | icon : Class A Class representing the icon for the item in the List control computed from the list class's itemToIcon() method | ListData
Inherited | label : String The textual representation of the item data, based on the list class's itemToLabel() method. | BaseListData
 | labelField : String The value of the labelField property in the list class. | ListData
Inherited | owner : IUIComponent A reference to the list object that owns this item. | BaseListData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rowIndex : int The index of the item in the data provider. | BaseListData
Inherited | uid : String The unique identifier for this item. | BaseListData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ListData(text:String, icon:Class, labelField:String, uid:String, owner:IUIComponent, rowIndex:int = 0) Constructor. | ListData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
icon property
public var icon:Class

A Class representing the icon for the item in the List control computed from the list class's itemToIcon() method

labelField property
public var labelField:String

The value of the labelField property in the list class. This is the value normally used to calculate which property should be taken from the item in the data provider for the text displayed in the item renderer, but is also used by DateField and other components to indicate which field to take from the data provider item that contains a Date or other non-text property.

For example, if a data provider item contains a "hiredDate" property, the labelField property can be set to "hiredDate" and the itemRenderer property can be set to DateField. The DateField control then uses the hiredDate property.

Constructor detail
ListData () constructor
public function ListData(text:String, icon:Class, labelField:String, uid:String, owner:IUIComponent, rowIndex:int = 0)

Constructor.

Parameters
text:String — Text representation of the item data.
icon:Class — A Class or String object representing the icon for the item in the List control.
labelField:String — The name of the field of the data provider containing the label data of the List component.
uid:String — A unique identifier for the item.
owner:IUIComponent — A reference to the List control.
rowIndex:int (default = 0) — The index of the item in the data provider for the List control.


mx.controls.listClasses.ListItemDragProxy (Flex™ 2 Language Reference)

Class ListItemDragProxy | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.listClasses
Class | public class ListItemDragProxy
Inheritance | ListItemDragProxy Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The default drag proxy used when dragging from a list-based control (except for the DataGrid class). A drag proxy is a component that parents the objects or copies of the objects being dragged

See also

mx.controls.dataGridClasses.DataGridDragProxy

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ListItemDragProxy()
Constructor.
ListItemDragProxy
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
ListItemDragProxy () constructor
public function ListItemDragProxy()

Constructor.


mx.controls.listClasses.ListItemRenderer (Flex™ 2 Language Reference)

Class ListItemRenderer | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.listClasses
Class | public class ListItemRenderer
Inheritance | ListItemRenderer Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IListItemRenderer

The ListItemRenderer class defines the default item renderer for a List control. By default, the item renderer draws the text associated with each item in the list, and an optional icon.

You can override the default item renderer by creating a custom item renderer.

See also

mx.controls.List
mx.core.IDataRenderer
mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The implementation of the data property as defined by the IDataRenderer interface. | ListItemRenderer
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | listData : BaseListData The implementation of the listData property as defined by the IDropInListItemRenderer interface. | ListItemRenderer
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | icon : IFlexDisplayObject The internal IFlexDisplayObject that displays the icon in this renderer. | ListItemRenderer
 | label : UITextField The internal UITextField that displays the text in this renderer. | ListItemRenderer
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ListItemRenderer()
Constructor.
ListItemRenderer
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | toolTipShowHandler(event:ToolTipEvent):void Positions the tooltip. | ListItemRenderer
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | ListItemRenderer
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | color | Type: uint Format: Color CSS Inheritance: yes Text color of a component label. The default value is 0x0B333C. | ListItemRenderer
 | disabledColor | Type: uint Format: Color CSS Inheritance: yes Text color of the component if it is disabled. The default value is 0xAAB3B3. | ListItemRenderer
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The implementation of the data property as defined by the IDataRenderer interface. When set, it stores the value and invalidates the component to trigger a relayout of the component.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
icon property
protected var icon:IFlexDisplayObject

The internal IFlexDisplayObject that displays the icon in this renderer.

label property
protected var label:UITextField

The internal UITextField that displays the text in this renderer.

listData property
listData:BaseListData [read-write]

The implementation of the listData property as defined by the IDropInListItemRenderer interface.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
Constructor detail
ListItemRenderer () constructor
public function ListItemRenderer()

Constructor.

Method detail
toolTipShowHandler () method
protected function toolTipShowHandler(event:ToolTipEvent):void

Positions the tooltip.

Parameters
event:ToolTipEvent — Event object.
Event detail
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.controls.listClasses.ListRowInfo (Flex™ 2 Language Reference)

Class ListRowInfo | Properties | Methods
Package | mx.controls.listClasses
Class | public class ListRowInfo
Inheritance | ListRowInfo Inheritance Object

Used by the list-based classes to store information about their IListItemRenderers.

See also

mx.controls.listClasses.ListBase.rowInfo

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | data : Object The item in the dataprovider. | ListRowInfo
 | height : Number The height of the row including margins. | ListRowInfo
 | itemOldY : Number The last Y value for the renderer. | ListRowInfo
 | oldY : Number The last Y value for the row. | ListRowInfo
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | uid : String The unique identifier of the item in the dataProvider | ListRowInfo
 | y : Number The y-position value for the row. | ListRowInfo
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ListRowInfo(y:Number, height:Number, uid:String, data:Object = null) Constructor. | ListRowInfo
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
data property
public var data:Object

The item in the dataprovider.

height property
public var height:Number

The height of the row including margins.

itemOldY property
public var itemOldY:Number

The last Y value for the renderer. Used in Tree's open/close effects.

oldY property
public var oldY:Number

The last Y value for the row. Used in Tree's open/close effects.

uid property
public var uid:String

The unique identifier of the item in the dataProvider

y property
public var y:Number

The y-position value for the row.

Constructor detail
ListRowInfo () constructor
public function ListRowInfo(y:Number, height:Number, uid:String, data:Object = null)

Constructor.

Parameters
y:Number — The y-position value for the row.
height:Number — The height of the row including margins.
uid:String — The unique identifier of the item in the dataProvider
data:Object (default = null) — The item in the dataprovider.


mx.controls.listClasses.TileBase (Flex™ 2 Language Reference)

Class TileBase | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.listClasses
Class | public class TileBase
Inheritance | TileBase Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | HorizontalList, TileList

The TileBase class is the base class for controls that display data items in a sequence of rows and columns. TileBase-derived classes ignore the variableRowHeight and wordWrap properties inherited from their parent class. All items in a TileList are the same width and height.

This class is not used directly in applications.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | allowDragSelection : Boolean = false A flag that indicates whether drag-selection is enabled. | ListBase
Inherited | allowMultipleSelection : Boolean A flag that indicates whether you can allow more than one item to be selected at the same time. | ListBase
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columnCount : int The number of columns to be displayed in a TileList control or items in a HorizontalList control. | ListBase
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | dataTipField : String Name of the field in the data provider items to display as the data tip. | ListBase
Inherited | dataTipFunction : Function User-supplied function to run on each item to determine its dataTip. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | direction : String The direction in which this control lays out its children. | TileBase
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dragEnabled : Boolean A flag that indicates whether you can drag items out of this control and drop them on other controls. | ListBase
Inherited | dragMoveEnabled : Boolean A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation. | ListBase
Inherited | dropEnabled : Boolean A flag that indicates whether dragged items can be dropped onto the control. | ListBase
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
Inherited | iconField : String The name of the field in the data provider object that determines what to display as the icon. | ListBase
Inherited | iconFunction : Function A user-supplied function to run on each item to determine its icon. | ListBase
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelField : String The name of the field in the data provider items to display as the label. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxColumns : int The maximum number of columns that the control can have. | TileBase
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxRows : int The maximum number of rows that the control can have. | TileBase
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
Inherited | selectable : Boolean A flag that indicates whether the list shows selected items as selected. | ListBase
Inherited | selectedIndex : int The index in the data provider of the selected item. | ListBase
Inherited | selectedIndices : Array An array of indices in the data provider of the selected items. | ListBase
Inherited | selectedItem : Object A reference to the selected item in the data provider. | ListBase
Inherited | selectedItems : Array An array of references to the selected items in the data provider. | ListBase
Inherited | showDataTips : Boolean A flag that indicates whether dataTips are displayed for text in the rows. | ListBase
Inherited | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | anchorBookmark : CursorBookmark A bookmark to the item that is the anchor. | ListBase
Inherited | anchorIndex : int = -1 The offset of the item in the data provider that is the selection anchor point. | ListBase
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | caretBookmark : CursorBookmark A bookmark to the item under the caret. | ListBase
Inherited | caretIndex : int = -1 The offset of the item in the data provider that is the selection caret point. | ListBase
Inherited | caretIndicator : Sprite The DisplayObject that contains the graphics that indicate which renderer is the caret. | ListBase
Inherited | caretItemRenderer : IListItemRenderer The renderer for the item under the caret. | ListBase
Inherited | caretUID : String The UID of the item under the caret. | ListBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | dragImage : IUIComponent Gets an instance of a class that displays the visuals during a drag and drop operation. | ListBase
Inherited | dragImageOffsets : Point Gets the offset of the drag image for drag and drop. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | highlightIndicator : Sprite The DisplayObject that contains the graphics that indicates which renderer is highlighted. | ListBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | highlightUID : String The UID of the item that is current rolled over or under the caret. | ListBase
Inherited | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | keySelectionPending : Boolean = false A flag that indicates if keyboard selection was interrupted by a page fault. | ListBase
Inherited | lastDropIndex : int The most recently calculated index where the drag item should be added to the drop target. | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | selectionLayer : Sprite The layer in listContent where all selection and highlight indicators are drawn. | ListBase
Inherited | selectionTweens : Object A hash table of selection tweens. | ListBase
Inherited | showCaret : Boolean A flag that indicates whether to show caret. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TileBase()
Constructor.
TileBase
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
calculateDropIndex(event:DragEvent = null):int
Returns the index where the dropped items should be added to the drop target.
ListBase
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hideDropFeedback(event:DragEvent):void
Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
ListBase
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemHighlighted(data:Object):Boolean
Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
ListBase
Inherited
isItemSelected(data:Object):Boolean
Determines if the item renderer for a data provider item is selected.
ListBase
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
showDropFeedback(event:DragEvent):void
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
ListBase
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method Defined by
Inherited
addDragData(ds:Object):void
Adds the selected items to the DragSource object as part of a drag-and-drop operation.
ListBase
Inherited
addToFreeItemRenderers(item:IListItemRenderer):void
Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
ListBase
Inherited
adjustFocusRect(obj:DisplayObject = null):void
Adjust the focus rectangle.
UIComponent
Inherited
applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void
Sets up the effect for applying the selection indicator.
ListBase
Inherited
attachOverlay():void
This is an internal method used by the Flex framework to support the Dissolve effect.
UIComponent
Inherited
calculateDropIndicatorY(rowCount:Number, rowNum:int):Number
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
ListBase
Inherited
childrenCreated():void
Performs any final processing after child objects are created.
UIComponent
Inherited
clearIndicators():void
Removes all selection and highlight and caret indicators.
ListBase
Inherited
clearSelected(transition:Boolean = false):void
Clears the set of selected items and removes all graphics depicting the selected state of those items.
ListBase
Inherited
collectionChangeHandler(event:Event):void
Handles CollectionEvents dispatched from the data provider as the data changes.
ListBase
Inherited
commitProperties():void
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
ListBase
Inherited
configureScrollBars():void
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
ListBase
Inherited
copySelectedItems(useDataField:Boolean = true):Array
Makes a copy of the selected items in the order they were selected.
ListBase
Inherited
createBorder():void
Creates the border for this component.
ScrollControlBase
Inherited
createChildren():void
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
ListBase
Inherited
dragCompleteHandler(event:DragEvent):void
Handles DragEvent.DRAG_COMPLETE events.
ListBase
Inherited
dragDropHandler(event:DragEvent):void
Handles DragEvent.DRAG_DROP events.
ListBase
Inherited
dragEnterHandler(event:DragEvent):void
Handles DragEvent.DRAG_ENTER events.
ListBase
Inherited
dragExitHandler(event:DragEvent):void
Handles DragEvent.DRAG_EXIT events.
ListBase
Inherited
dragOverHandler(event:DragEvent):void
Handles DragEvent.DRAG_OVER events.
ListBase
Inherited
dragScroll():void
Interval function that scrolls the list up or down if the mouse goes above or below the list.
ListBase
Inherited
drawCaretIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawHighlightIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
Inherited
drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void
Draws the renderer with indicators that it is highlighted, selected, or the caret.
ListBase
Inherited
drawRowBackgrounds():void
Draws any alternating row colors, borders and backgrounds for the rows.
ListBase
Inherited
drawSelectionIndicator(indicator:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:IListItemRenderer):void
Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
ListBase
drawTileBackground(s:Sprite, rowIndex:int, columnIndex:int, width:Number, height:Number, color:uint, item:IListItemRenderer):DisplayObject
Draws the background for an individual tile.
TileBase
drawTileBackgrounds():void
Draws the backgrounds, if any, behind all of the tiles.
TileBase
Inherited
findKey(eventCode:int):Boolean
Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
ListBase
Inherited
finishKeySelection():void
Sets selected items based on the caretIndex and anchorIndex properties.
ListBase
Inherited
focusInHandler(event:FocusEvent):void
The event handler called when a UIComponent object gets focus.
UIComponent
Inherited
focusOutHandler(event:FocusEvent):void
The event handler called when a UIComponent object loses focus.
UIComponent
Inherited
indexToColumn(index:int):int
The column for the data provider item at the given index.
ListBase
Inherited
indexToRow(index:int):int
The row for the data provider item at the given index.
ListBase
Inherited
initializationComplete():void
Finalizes the initialization of this component.
UIComponent
Inherited
initializeAccessibility():void
Initializes this component's accessibility code.
UIComponent
Inherited
isOurFocus(target:DisplayObject):Boolean
Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
UIComponent
Inherited
itemRendererToIndices(item:IListItemRenderer):Point
Returns a Point containing the columnIndex and rowIndex of an item renderer.
ListBase
Inherited
itemToUID(data:Object):String
Determines the UID for a data provider item.
ListBase
Inherited
keyDownHandler(event:KeyboardEvent):void
The event handler called for a keyDown event.
UIComponent
Inherited
keyUpHandler(event:KeyboardEvent):void
The event handler called for a keyUp event.
UIComponent
Inherited
layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void
Responds to size changes by setting the positions and sizes of this control's borders.
ScrollControlBase
Inherited
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point
Make enough rows and columns to fill the area described by left, top, right, bottom.
ListBase
Inherited
measure():void
Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
ListBase
Inherited
mouseClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDoubleClickHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseDownHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseEventToItemRenderer(event:MouseEvent):IListItemRenderer
Determines which item renderer is under the mouse.
ListBase
Inherited
mouseMoveHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOutHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseOverHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
ListBase
Inherited
mouseUpHandler(event:MouseEvent):void
Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
ListBase
Inherited
mouseWheelHandler(event:MouseEvent):void
Handles mouseWheel events by changing scroll positions.
ListBase
Inherited
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean):void
Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
ListBase
Inherited
removeIndicators(uid:String):void
Cleans up selection highlights and other associated graphics for a given item in the data provider.
ListBase
Inherited
scrollHandler(event:Event):void
Default event handler for the scroll event.
ScrollControlBase
Inherited
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
ListBase
Inherited
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void
Adjusts the renderers in response to a change in scroll position.
ListBase
Inherited
seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void
The default failure handler when a seek fails due to a page fault.
ListBase
Inherited
seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void
The default result handler when a seek fails due to a page fault.
ListBase
Inherited
selectItem(item:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean = true):Boolean
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
ListBase
Inherited
setRowCount(v:int):void
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
ListBase
Inherited
setRowHeight(v:Number):void
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
ListBase
Inherited
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
ScrollControlBase
Inherited
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void
Adds or removes item renderers if the number of displayable items changed.
ListBase
Inherited
updateList():void
Refreshes all rows now.
ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | itemClick | Dispatched when the user clicks on an item in the control. | ListBase
Inherited | itemDoubleClick | Dispatched when the user double-clicks on an item in the control. | ListBase
Inherited | itemRollOut | Dispatched when the user rolls the mouse pointer out of an item in the control. | ListBase
Inherited | itemRollOver | Dispatched when the user rolls the mouse pointer over an item in the control. | ListBase
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors to use for the backgrounds of the items in the list. | ListBase
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropIndicatorSkin | Type: Class CSS Inheritance: no The skin to use to indicate where a dragged item can be dropped. | ListBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no Style name for horizontal scrollbar. | ScrollControlBase
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | rollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user rolls over it. | ListBase
Inherited | selectionColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the user selects it. | ListBase
Inherited | selectionDisabledColor | Type: uint Format: Color CSS Inheritance: yes The color of the background of a renderer when the component is disabled. | ListBase
Inherited | selectionDuration | Type: Number Format: Time CSS Inheritance: no The duration of the selection effect. | ListBase
Inherited | selectionEasingFunction | Type: Function CSS Inheritance: no The easingFunction for the selection effect. | ListBase
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user rolls over a it. | ListBase
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes The color of the text of a renderer when the user selects it. | ListBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | useRollOver | Type: Boolean CSS Inheritance: no A flag that controls whether items are highlighted as the mouse rolls over them. | ListBase
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no Style name for vertical scrollbar. | ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
direction property
direction:String [read-write]

The direction in which this control lays out its children. Possible values are TileBaseDirection.HORIZONTAL and TileBaseDirection.VERTICAL. The default value is TileBaseDirection.HORIZONTAL.

If the value is TileBaseDirection.HORIZONTAL, the tiles are laid out along the first row until the number of visible columns or maxColumns is reached and then a new row is started. If more rows are created than can be displayed at once, the control will display a vertical scrollbar. The opposite is true if the value is TileBaseDirection.VERTICAL.

This property can be used as the source for data binding.

Implementation
    public function get direction():String
    public function set direction(value:String):void
maxColumns property
maxColumns:int [read-write]

The maximum number of columns that the control can have. If 0, then there are no limits to the number of columns. This value is ignored if the direction is TileBaseDirection.VERTICAL because the control will have as many columns as it needs to to display all the data.

The default value is 0 (no limit).

Implementation
    public function get maxColumns():int
    public function set maxColumns(value:int):void
maxRows property
maxRows:int [read-write]

The maximum number of rows that the control can have. If 0, then there is no limit to the number of rows. This value is ignored if the direction is TileBaseDirection.HORIZONTAL because the control will have as many rows as it needs to to display all the data.

The default value is 0 (no limit).

Implementation
    public function get maxRows():int
    public function set maxRows(value:int):void
Constructor detail
TileBase () constructor
public function TileBase()

Constructor.

Method detail
drawTileBackground () method
protected function drawTileBackground(s:Sprite, rowIndex:int, columnIndex:int, width:Number, height:Number, color:uint, item:IListItemRenderer):DisplayObject

Draws the background for an individual tile. Takes a Sprite object, applies the background dimensions and color, and returns the sprite with the values applied.

Parameters
s:Sprite — The Sprite that contains the individual tile backgrounds.
rowIndex:int — The index of the row that contains the tile.
columnIndex:int — The index of the column that contains the tile.
width:Number — The width of the background.
height:Number — The height of the background.
color:uint — The fill color for the background.
item:IListItemRenderer — The item renderer for the tile.

Returns
DisplayObject — The background Sprite.
drawTileBackgrounds () method
protected function drawTileBackgrounds():void

Draws the backgrounds, if any, behind all of the tiles. This implementation makes a Sprite names "tileBGs" if it doesn't exist, adds it to the back of the z-order in the listContent, and calls drawTileBackground() for each visible tile.


mx.controls.listClasses.TileBaseDirection (Flex™ 2 Language Reference)

Class TileBaseDirection | Properties | Methods | Constants
Package | mx.controls.listClasses
Class | public final class TileBaseDirection
Inheritance | TileBaseDirection Inheritance Object

Values for the direction property of the TileList component.

See also

mx.controls.listClasses.TileBase.direction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] Arrange children horizontally. | TileBaseDirection
 | VERTICAL : String = "vertical" [static] Arrange chidren vertically. | TileBaseDirection
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

Arrange children horizontally. For controls, such as TileList, that arrange children in two dimensions, arrange the children by filling up a row before going on to the next row.

VERTICAL constant
public static const VERTICAL:String = "vertical"

Arrange chidren vertically. For controls, such as TileList, that arrange children in two dimensions, arrange the children by filling up a column before going on to the next column.


mx.controls.listClasses.TileListItemRenderer (Flex™ 2 Language Reference)

Class TileListItemRenderer | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.listClasses
Class | public class TileListItemRenderer
Inheritance | TileListItemRenderer Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IListItemRenderer

The TileListItemRenderer class defines the default item renderer for the HorizontalList and TileList controls. By default, the item renderer draws the text associated with each item in the list, and an optional icon.

You can override the default item renderer by creating a custom item renderer.

See also

mx.controls.HorizontalList
mx.controls.TileList
mx.core.IDataRenderer
mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The implementation of the data property as defined by the IDataRenderer interface. | TileListItemRenderer
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | listData : BaseListData The implementation of the listData property as defined by the IDropInListItemRenderer interface. | TileListItemRenderer
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | icon : IFlexDisplayObject The internal IFlexDisplayObject that displays the icon in this renderer. | TileListItemRenderer
 | label : UITextField The internal UITextField that displays the text in this renderer. | TileListItemRenderer
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TileListItemRenderer()
Constructor.
TileListItemRenderer
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | toolTipShowHandler(event:ToolTipEvent):void Positions the tooltip. | TileListItemRenderer
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | TileListItemRenderer
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | color | Type: uint Format: Color CSS Inheritance: yes Text color of a component label. The default value is 0x0B333C. | TileListItemRenderer
 | disabledColor | Type: uint Format: Color CSS Inheritance: yes Text color of the component if it is disabled. The default value is 0xAAB3B3. | TileListItemRenderer
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value is 6. | TileListItemRenderer
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The implementation of the data property as defined by the IDataRenderer interface. It simply stores the value and invalidates the component to trigger a relayout of the component.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
icon property
protected var icon:IFlexDisplayObject

The internal IFlexDisplayObject that displays the icon in this renderer.

label property
protected var label:UITextField

The internal UITextField that displays the text in this renderer.

listData property
listData:BaseListData [read-write]

The implementation of the listData property as defined by the IDropInListItemRenderer interface.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
Constructor detail
TileListItemRenderer () constructor
public function TileListItemRenderer()

Constructor.

Method detail
toolTipShowHandler () method
protected function toolTipShowHandler(event:ToolTipEvent):void

Positions the tooltip.

Parameters
event:ToolTipEvent — Event object.
Event detail
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.controls.menuClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.menuClasses | Interfaces | Classes

The mx.controls.menuClasses package contains the classes used by the menu-based controls.

Interfaces
Interface | Description
IMenuDataDescriptor | The IMenuDataDescriptor interface defines the interface that a dataDescriptor for a Menu or MenuBar control must implement.
IMenuItemRenderer | The IMenuItemRenderer interface defines the interface that a menu item renderer for a Menu control must implement.
Classes
Class | Description
MenuBarItem | The MenuBarItem class defines an item displayed in a MenuBar control.
MenuItemRenderer | The MenuItemRenderer class defines the default item renderer for menu items in any menu control.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.menuClasses.IMenuDataDescriptor (Flex™ 2 Language Reference)

Interface IMenuDataDescriptor | Methods
Package | mx.controls.menuClasses
Interface | public interface IMenuDataDescriptor
Implementors | DefaultDataDescriptor

The IMenuDataDescriptor interface defines the interface that a dataDescriptor for a Menu or MenuBar control must implement. The interface provides methods for parsing and modifyng a collection of data that is displayed by a Menu or MenuBar control.

See also

mx.collections.ICollectionView
Using Menu-Based Controls

Public Methods
Method |  | Defined by
 | addChildAt(parent:Object, newChild:Object, index:int, model:Object = null):Boolean Add a child node to a node at the specified index. | IMenuDataDescriptor
 | getChildren(node:Object, model:Object = null):ICollectionView Provides access to a node's children. | IMenuDataDescriptor
 | getData(node:Object, model:Object = null):Object Returns a node's data. | IMenuDataDescriptor
 | getGroupName(node:Object):String Returns the name of the radio button group to which the node belongs, if any. | IMenuDataDescriptor
 | getType(node:Object):String Returns the type identifier of a node. | IMenuDataDescriptor
 | hasChildren(node:Object, model:Object = null):Boolean Returns true if the node actually has children. | IMenuDataDescriptor
 | isBranch(node:Object, model:Object = null):Boolean Tests a node for termination. | IMenuDataDescriptor
 | isEnabled(node:Object):Boolean Returns whether the node is enabled. | IMenuDataDescriptor
 | isToggled(node:Object):Boolean Returns whether the node is toggled. | IMenuDataDescriptor
 | removeChildAt(parent:Object, child:Object, index:int, model:Object = null):Boolean Removes the child node from a node at the specified index. | IMenuDataDescriptor
 | setEnabled(node:Object, value:Boolean):void Sets the value of the field or attribute in the data provider that identifies whether the node is enabled. | IMenuDataDescriptor
 | setToggled(node:Object, value:Boolean):void Sets the value of the field or attribute in the data provider that identifies whether the node is toggled. | IMenuDataDescriptor
Method detail
addChildAt () method
public function addChildAt(parent:Object, newChild:Object, index:int, model:Object = null):Boolean

Add a child node to a node at the specified index. This implementation does the following:

  • If the parent parameter is null or undefined, inserts the child parameter at the specified index in the collection specified by model parameter.
  • If the parent parameter has a children field or property, the method adds the child parameter to it at the index parameter location. In this case, the model parameter is not required.
  • If the index value is greater than the collection length or number of children in the parent, adds the object as the last child.

Parameters
parent:Object — The node object that will parent the child
newChild:Object — The node object that will be parented by the node
index:int — The 0-based index of where to put the child node relative to the parent
model:Object (default = null) — The entire collection that this node is a part of

Returns
Boolean — true if successful
getChildren () method
public function getChildren(node:Object, model:Object = null):ICollectionView

Provides access to a node's children. Returns a collection of children if they exist. If the node is an Object, the method returns the contents of the object's children field as an ArrayCollection. If the node is XML, the method returns an XMLListCollection containing the child elements.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
ICollectionView — An object containing the children nodes.
getData () method
public function getData(node:Object, model:Object = null):Object

Returns a node's data. Currently returns the entire node.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
Object — The node.
getGroupName () method
public function getGroupName(node:Object):String

Returns the name of the radio button group to which the node belongs, if any. This method is used by menu-based controls.

Parameters
node:Object — The node for which to get the group name.

Returns
String — The value of the node's groupName attribute or field, or an empty string if there is no such entry.
getType () method
public function getType(node:Object):String

Returns the type identifier of a node. This method is used by menu-based controls to determine if the node represents a separator, radio button, a check box, or normal item.

Parameters
node:Object — The node object for which to get the type.

Returns
String — the value of the type attribute or field, or the empty string if there is no such field.
hasChildren () method
public function hasChildren(node:Object, model:Object = null):Boolean

Returns true if the node actually has children.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
Boolean — boolean indicating if this node currently has children
isBranch () method
public function isBranch(node:Object, model:Object = null):Boolean

Tests a node for termination. Branches are non-terminating but are not required to have any leaf nodes. If the node is XML, returns true if the node has children or a true isBranch attribute. If the node is an object, returns true if the node has a (possibly empty) children field.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
Boolean — boolean indicating if this node is non-terminating
isEnabled () method
public function isEnabled(node:Object):Boolean

Returns whether the node is enabled. This method is used by menu-based controls.

Parameters
node:Object — The node for which to get the status.

Returns
Boolean — the value of the node's enabled attribute or field, or true if there is no such entry or the value is not false.
isToggled () method
public function isToggled(node:Object):Boolean

Returns whether the node is toggled. This method is used by menu-based controls.

Parameters
node:Object — The node for which to get the status.

Returns
Boolean — The value of the node's toggled attribute or field, or false if there is no such entry.
removeChildAt () method
public function removeChildAt(parent:Object, child:Object, index:int, model:Object = null):Boolean

Removes the child node from a node at the specified index. If the parent parameter is null or undefined, the method uses the model parameter to access the child; otherwise, it uses the parent parameter and ignores the model parameter.

Parameters
parent:Object — The node object that currently parents the child node
child:Object — The node that is being removed
index:int — The 0-based index of the child node to remove relative to the parent
model:Object (default = null) — The entire collection that this node is a part of

Returns
Boolean — true if successful
setEnabled () method
public function setEnabled(node:Object, value:Boolean):void

Sets the value of the field or attribute in the data provider that identifies whether the node is enabled. This method sets the value of the node's enabled attribute or field. This method is used by menu-based controls.

Parameters
node:Object — The node for which to set the status.
value:Boolean — Whether the node is enabled.
setToggled () method
public function setToggled(node:Object, value:Boolean):void

Sets the value of the field or attribute in the data provider that identifies whether the node is toggled. This method sets the value of the node's toggled attribute or field. This method is used by menu-based controls.

Parameters
node:Object — The node for which to set the status.
value:Boolean — Whether the node is toggled.


mx.controls.menuClasses.IMenuItemRenderer (Flex™ 2 Language Reference)

Interface IMenuItemRenderer | Properties
Package | mx.controls.menuClasses
Interface | public interface IMenuItemRenderer
Implementors | MenuItemRenderer

The IMenuItemRenderer interface defines the interface that a menu item renderer for a Menu control must implement. The menu item renderers are often recycled. Once they are created, they may be used again simply by being given new data. Therefore, in individual implementations, component developers must make sure that component properties are not assumed to contain specific initial, or default values. To implement this interface, a component developer must define a setter and getter method that implements the menu property. Typically, the setter method writes the value of the data property to an internal variable, and the getter method returns the current value of the internal variable, as the following example shows:
     // Internal variable for the property value.
     private var _menu:Menu;

     // Define the getter method.
     public function get menu():Menu
     {
         return _menu;
     }

     // Define the setter method.
     public function set menu(value:Menu):void
     {
         _menu = value;
     }

Public Properties
Property |  | Defined by
 | menu : Menu A reference to this menu item renderer's Menu control, if it contains one. | IMenuItemRenderer
Property detail
menu property
menu:Menu [read-write]

A reference to this menu item renderer's Menu control, if it contains one. This would indicate that this menu item renderer is a branch node, capable of popping up a sub menu.

Implementation
    public function get menu():Menu
    public function set menu(value:Menu):void


mx.controls.menuClasses.MenuBarItem (Flex™ 2 Language Reference)

Class MenuBarItem | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.menuClasses
Class | public class MenuBarItem
Inheritance | MenuBarItem Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IListItemRenderer

The MenuBarItem class defines an item displayed in a MenuBar control. A MenuBarItem instance displays the text for the item and passes mouse and keyboard interactions to the MenuBar so that it can correctly show and hide menus. In general, this class is not explictly used. Most customization are done to the Menu instances contained in the MenuBar or to the MenuBar itself.

See also

mx.controls.Menu
mx.controls.MenuBar

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The data property of the IListItemRenderer interface has no purpose in the MenuBarItem class. | MenuBarItem
 | dataProvider : Object The object that provides the data for the Menu that is popped up when this MenuBarItem is selected. | MenuBarItem
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | menuBarIndex : int The index of this MenuBarItem relative to other MenuBarItems in the MenuBar. | MenuBarItem
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MenuBarItem()
Constructor
MenuBarItem
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		MenuBarItem
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		MenuBarItem
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		MenuBarItem
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		MenuBarItem
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		MenuBarItem
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		MenuBarItem
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		MenuBarItem
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		MenuBarItem
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		MenuBarItem
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		MenuBarItem
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

MenuBarItem
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

MenuBarItem
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		MenuBarItem
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		MenuBarItem
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The data property of the IListItemRenderer interface has no purpose in the MenuBarItem class. The property always has a value of null, and setting it has no effect.

The default value is null.

Implementation
    public function get data():Object
    public function set data(value:Object):void
dataProvider property
dataProvider:Object [read-write]

The object that provides the data for the Menu that is popped up when this MenuBarItem is selected.

The default value is "undefined".

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
menuBarIndex property
public var menuBarIndex:int

The index of this MenuBarItem relative to other MenuBarItems in the MenuBar. The index of the first, ie: left most, MenuBarItem is 0 and increases as you move to the right.

The default value is "undefined".

Constructor detail
MenuBarItem () constructor
public function MenuBarItem()

Constructor


mx.controls.menuClasses.MenuItemRenderer (Flex™ 2 Language Reference)

Class MenuItemRenderer | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.menuClasses
Class | public class MenuItemRenderer
Inheritance | MenuItemRenderer Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IListItemRenderer, IMenuItemRenderer

The MenuItemRenderer class defines the default item renderer for menu items in any menu control. By default, the item renderer draws the text associated with each menu item, the separator characters, and icons.

You can override the default item renderer by creating a custom item renderer.

See also

mx.controls.Menu
mx.controls.MenuBar
mx.core.IDataRenderer
mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The implementation of the data property as defined by the IDataRenderer interface. | MenuItemRenderer
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | listData : BaseListData The implementation of the listData property as defined by the IDropInListItemRenderer interface. | MenuItemRenderer
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | menu : Menu Contains a reference to the associated Menu control. | MenuItemRenderer
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | branchIcon : IFlexDisplayObject The internal IFlexDisplayObject that displays the branch icon in this renderer. | MenuItemRenderer
 | icon : IFlexDisplayObject The internal IFlexDisplayObject that displays the icon in this renderer. | MenuItemRenderer
 | label : UITextField The internal UITextField that displays the text in this renderer. | MenuItemRenderer
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MenuItemRenderer()
Constructor.
MenuItemRenderer
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | MenuItemRenderer
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | color | Type: uint Format: Color CSS Inheritance: yes Text color of the menu item label. The default value is 0x0B333C. | MenuItemRenderer
 | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of the menu item if it is disabled. The default value is 0xAAB3B3. | MenuItemRenderer
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
branchIcon property
protected var branchIcon:IFlexDisplayObject

The internal IFlexDisplayObject that displays the branch icon in this renderer.

The default value is null.

data property
data:Object [read-write]

The implementation of the data property as defined by the IDataRenderer interface.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
icon property
protected var icon:IFlexDisplayObject

The internal IFlexDisplayObject that displays the icon in this renderer.

The default value is null.

label property
protected var label:UITextField

The internal UITextField that displays the text in this renderer.

The default value is null.

listData property
listData:BaseListData [read-write]

The implementation of the listData property as defined by the IDropInListItemRenderer interface.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
menu property
menu:Menu [read-write]

Contains a reference to the associated Menu control.

The default value is null.

Implementation
    public function get menu():Menu
    public function set menu(value:Menu):void
Constructor detail
MenuItemRenderer () constructor
public function MenuItemRenderer()

Constructor.

Event detail
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.controls.scrollClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.scrollClasses | Classes

The mx.controls.scrollClasses package contains the classes used by controls that support scroll bars.

Classes
Class | Description
ScrollBar | The ScrollBar class is the base class for the HScrollBar and VScrollBar controls.
ScrollBarDirection | The ScrollBarDirection class defines the values for the direction property of the ScrollBar control.
ScrollThumb | The ScrollThumb class defines the thumb of a ScrollBar control.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.scrollClasses.ScrollBar (Flex™ 2 Language Reference)

Class ScrollBar | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.scrollClasses
Class | public class ScrollBar
Inheritance | ScrollBar Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | HScrollBar, VScrollBar

The ScrollBar class is the base class for the HScrollBar and VScrollBar controls. A ScrollBar consists of two arrow buttons, a track between them, and a variable-size scroll thumb. The scroll thumb can move by clicking on either of the two arrow buttons, dragging the scroll thumb along the track, or clicking on the track.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ScrollBar> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:ScrollBar
    Properties
    direction="vertical|horizontal"
    lineScrollSize="1"
    maxScrollPosition="0"
    minScrollPosition="0"
    pageScrollSize="Reset to the pageSize parameter of setScrollProperties"
    pageSize="0"
    scrollPosition="0"

    Styles
    borderColor="0xB7BABC"
    cornerRadius="0"
    downArrowDisabledSkin="mx.skins.halo.ScrollArrowSkin"
    downArrowDownSkin="mx.skins.halo.ScrollArrowSkin"
    downArrowOverSkin="mx.skins.halo.ScrollArrowSkin"
    downArrowUpSkin="mx.skins.halo.ScrollArrowSkin"
    fillAlphas="[0.6, 0.4]"
    fillColors="[0xFFFFFF, 0xCCCCCC]"
    highlightAlphas="[0.3, 0.0]"
    thumbDownSkin="mx.skins.halo.ScrollThumbSkin"
    thumbIcon="undefined"
    thumbOverSkin="mx.skins.halo.ScrollThumbSkin"
    thumbUpSkin="mx.skins.halo.ScrollThumbSkin"
    trackColors="[0x94999b, 0xe7e7e7]"
    trackSkin="mx.skins.halo.ScrollTrackSkin"
    upArrowDisabledSkin="mx.skins.halo.ScrollArrowSkin"
    upArrowDownSkin="mx.skins.halo.ScrollArrowSkin"
    upArrowOverSkin="mx.skins.halo.ScrollArrowSkin"
    upArrowUpSkin="mx.skins.halo.ScrollArrowSkin"
  />

See also

mx.controls.HScrollBar
mx.controls.VScrollBar
mx.controls.Button
mx.controls.scrollClasses.ScrollThumb
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | direction : String Specifies whether the ScrollBar is for horizontal or vertical scrolling. | ScrollBar
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | lineScrollSize : Number Amount to scroll when an arrow button is pressed, in pixels. | ScrollBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxScrollPosition : Number Number which represents the maximum scroll position. | ScrollBar
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
 | minScrollPosition : Number Number that represents the minimum scroll position. | ScrollBar
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
 | pageScrollSize : Number Amount to move the scroll thumb when the scroll bar track is pressed, in pixels. | ScrollBar
 | pageSize : Number The number of lines equivalent to one page. | ScrollBar
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
 | scrollPosition : Number Number that represents the current scroll position. | ScrollBar
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ScrollBar()
Constructor.
ScrollBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setScrollProperties(pageSize:Number, minScrollPosition:Number, maxScrollPosition:Number, pageScrollSize:Number = 0):void
Sets the range and viewport size of the ScrollBar control.
ScrollBar
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
 | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. The following controls support this style: Button, CheckBox, ComboBox, MenuBar, NumericStepper, ProgressBar, RadioButton, ScrollBar, Slider, and any components that support the borderStyle style. The default value depends on the component class; if not overriden for the class, the default value is 0xB7BABC. | ScrollBar
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. The following components support this style: Alert, Button, ComboBox, LinkButton, MenuBar, NumericStepper, Panel, ScrollBar, Tab, TitleWindow, and any component that supports a borderStyle property set to "solid". The default value depends on the component class; if not overriden for the class, the default value is 0. | ScrollBar
 | downArrowDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when it is disabled. If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
 | downArrowDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when you click the arrow button . If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
 | downArrowOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar when the mouse pointer is over the arrow button. If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
 | downArrowUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the down arrow button of the scroll bar. If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
 | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. Use [1, 1] to make the control background opaque. The default value is [ 0.6, 0.4 ]. | ScrollBar
 | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. Pass the same color for both values for a flat-looking control. The default value is [ 0xFFFFFF, 0xCCCCCC ]. | ScrollBar
 | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. The first value specifies the transparency of the top of the highlight and the second value specifies the transparency of the bottom of the highlight. The highlight covers the top half of the skin. The default value is [ 0.3, 0.0 ]. | ScrollBar
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
 | thumbDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar when you click the thumb. The default value is mx.skins.halo.ScrollThumbSkin. | ScrollBar
 | thumbIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon for the thumb of the scroll bar. The default value is "undefined". | ScrollBar
 | thumbOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar when the mouse pointer is over the thumb. The default value is mx.skins.halo.ScrollThumbSkin. | ScrollBar
 | thumbUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the thumb of the scroll bar. The default value is mx.skins.halo.ScrollThumbSkin. | ScrollBar
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | trackColors | Type: Array Format: Color CSS Inheritance: no The colors of the track, as an array of two colors. You can use the same color twice for a solid track color. The default value is [0x94999b, 0xe7e7e7]. | ScrollBar
 | trackSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the track of the scroll bar. The default value is mx.skins.halo.ScrollTrackSkin. | ScrollBar
 | upArrowDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when it is disabled. If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
 | upArrowDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when you click the arrow button. If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
 | upArrowOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar when the mouse pointer is over the arrow button. If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
 | upArrowUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the up arrow button of the scroll bar. If you change the skin, either graphically or programmatically, you should ensure that the new skin is the same height (for horizontal ScrollBars) or width (for vertical ScrollBars) as the track. The default value is mx.skins.halo.ScrollArrowSkin. | ScrollBar
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
 | THICKNESS : Number = 16 [static] The width of a vertical scrollbar, or the height of a horizontal scrollbar, in pixels. | ScrollBar
Property detail
direction property
direction:String [read-write]

Specifies whether the ScrollBar is for horizontal or vertical scrolling. Valid values in MXML are "vertical" and "horizontal".

In ActionScript, you use the following constants to set this property: ScrollBarDirection.VERTICAL and ScrollBarDirection.HORIZONTAL.

The default value is ScrollBarDirection.VERTICAL.

This property can be used as the source for data binding.

Implementation
    public function get direction():String
    public function set direction(value:String):void

See also

mx.controls.scrollClasses.ScrollBarDirection
lineScrollSize property
lineScrollSize:Number [read-write]

Amount to scroll when an arrow button is pressed, in pixels.

The default value is 1.

Implementation
    public function get lineScrollSize():Number
    public function set lineScrollSize(value:Number):void
maxScrollPosition property
maxScrollPosition:Number [read-write]

Number which represents the maximum scroll position.

The default value is 0.

Implementation
    public function get maxScrollPosition():Number
    public function set maxScrollPosition(value:Number):void
minScrollPosition property
minScrollPosition:Number [read-write]

Number that represents the minimum scroll position.

The default value is 0.

Implementation
    public function get minScrollPosition():Number
    public function set minScrollPosition(value:Number):void
pageScrollSize property
pageScrollSize:Number [read-write]

Amount to move the scroll thumb when the scroll bar track is pressed, in pixels.

The default value is 0.

Implementation
    public function get pageScrollSize():Number
    public function set pageScrollSize(value:Number):void
pageSize property
pageSize:Number [read-write]

The number of lines equivalent to one page.

The default value is 0.

Implementation
    public function get pageSize():Number
    public function set pageSize(value:Number):void
scrollPosition property
scrollPosition:Number [read-write]

Number that represents the current scroll position. The value is between minScrollPosition and maxScrollPosition inclusively.

The default value is 0.

Implementation
    public function get scrollPosition():Number
    public function set scrollPosition(value:Number):void
Constructor detail
ScrollBar () constructor
public function ScrollBar()

Constructor.

Method detail
setScrollProperties () method
public function setScrollProperties(pageSize:Number, minScrollPosition:Number, maxScrollPosition:Number, pageScrollSize:Number = 0):void

Sets the range and viewport size of the ScrollBar control. The ScrollBar control updates the state of the arrow buttons and size of the scroll thumb accordingly.

Parameters
pageSize:Number — Number which represents the size of one page.
minScrollPosition:Number — Number which represents the bottom of the scrolling range.
maxScrollPosition:Number — Number which represetns the top of the scrolling range.
pageScrollSize:Number (default = 0) — Number which represents the increment to move when the scroll track is pressed.
Constant detail
THICKNESS constant
public static const THICKNESS:Number = 16

The width of a vertical scrollbar, or the height of a horizontal scrollbar, in pixels.


mx.controls.scrollClasses.ScrollBarDirection (Flex™ 2 Language Reference)

Class ScrollBarDirection | Properties | Methods | Constants
Package | mx.controls.scrollClasses
Class | public final class ScrollBarDirection
Inheritance | ScrollBarDirection Inheritance Object

The ScrollBarDirection class defines the values for the direction property of the ScrollBar control.

See also

mx.controls.scrollClasses.ScrollBar
mx.controls.HScrollBar
mx.controls.VScrollBar
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] Specifies that a ScrollBar control is for horizontal scrolling. | ScrollBarDirection
 | VERTICAL : String = "vertical" [static] Specifies that a ScrollBar control is for vertical scrolling. | ScrollBarDirection
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

Specifies that a ScrollBar control is for horizontal scrolling.

VERTICAL constant
public static const VERTICAL:String = "vertical"

Specifies that a ScrollBar control is for vertical scrolling.


mx.controls.scrollClasses.ScrollThumb (Flex™ 2 Language Reference)

Class ScrollThumb | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.scrollClasses
Class | public class ScrollThumb
Inheritance | ScrollThumb Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The ScrollThumb class defines the thumb of a ScrollBar control.

See also

mx.controls.scrollClasses.ScrollBar
mx.controls.HScrollBar
mx.controls.VScrollBar
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | emphasized : Boolean Draws a thick border around the Button control when the control is in its up state if emphasized is set to true. | Button
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
Inherited | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toggle : Boolean Controls whether a Button is in a toggle state or not. | Button
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ScrollThumb()
Constructor.
ScrollThumb
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Button
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Button
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | Button
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | Button
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | selectedDisabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and disabled. | Button
Inherited | selectedDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and disabled. | Button
Inherited | selectedDownIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is down. | Button
Inherited | selectedDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down. | Button
Inherited | selectedOverIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse is over the control. | Button
Inherited | selectedOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control. | Button
Inherited | selectedUpIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is up. | Button
Inherited | selectedUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control. | Button
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user moves the mouse pointer over the button. | Button
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user presses it. | Button
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
ScrollThumb () constructor
public function ScrollThumb()

Constructor.


mx.controls.sliderClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.sliderClasses | Classes

The mx.controls.sliderClasses package contains the classes used by the Slider control.

Classes
Class | Description
Slider | The Slider class is the base class for the Flex slider controls.
SliderDataTip | The SliderDataTip class defines the tooltip used in the mx.controls.Slider control.
SliderDirection | The SliderDirection class defines the constant values for the direction property of the Slider class.
SliderLabel | The SliderLabel class defines the label used in the mx.controls.Slider component.
SliderThumb | The SliderThumb class represents a thumb of a Slider control.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.sliderClasses.Slider (Flex™ 2 Language Reference)

Class Slider | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.sliderClasses
Class | public class Slider
Inheritance | Slider Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | HSlider, VSlider

The Slider class is the base class for the Flex slider controls. The slider controls let users select a value by moving a slider thumb between the end points of the slider track. The current value of the slider is determined by the relative location of the thumb between the end points of the slider, corresponding to the slider's minimum and maximum values. The Slider class is subclassed by HSlider and VSlider.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The Slider class cannot be used as an MXML tag. Use the <mx:HSlider> and <mx:VSlider> tags instead. However, the Slider class does define tag attributes used by the <mx:HSlider> and <mx:VSlider> tags.

The Slider class inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:tagname
    Properties
    allowThumbOverlap="false|true"
    allowTrackClick="true|false"
    dataTipFormatFunction="undefined"
    direction="horizontal|vertical"
    labels="undefined"
    liveDragging="false|true"
    maximum="10"
    minimum="0"
    showDataTip="true|false"
    sliderDataTipClass="sliderDataTip"
    sliderThumbClass="SliderThumb"
    snapInterval="0"
    thumbCount="1"
    tickInterval="0"
    value="The value of the minimum property."

    Styles
    borderColor="0x919999"
    dataTipOffset="16"
    dataTipPrecision="2"
    dataTipStyleName="undefined"
    fillAlphas="[0.6, 0.4, 0.75, 0.65]"
    fillColors="[0xFFFFFF, 0xCCCCCC, 0xFFFFFF, 0xEEEEEE;]"
    labelOffset="-10"
    labelStyleName="undefined"
    showTrackHighlight="false"
    slideDuration="300"
    slideEasingFunction="undefined"
    thumbDisabledSkin="SliderThumbSkin"
    thumbDownSkin="SliderThumbSkin"
    thumbOffset="0"
    thumbOverSkin="SliderThumbSkin"
    thumbUpSkin="SliderThumbSkin"
    tickColor="0x6F7777"
    tickLength="3"
    tickOffset="-6"
    tickThickness="1"
    trackColors="[ 0xEEEEEE, 0xFFFFFF ]"
    tracHighlightSkin="SliderHighlightSkin"
    trackMargin="undefined"
    trackSkin="SliderTrackSkin"

    Events
    change="No default"
    thumbDrag="No default"
    thumbPress="No default"
    thumbRelease="No default"
  />

See also

HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
 | allowThumbOverlap : Boolean = false If set to false, then each thumb can only be moved to the edge of the adjacent thumb. | Slider
 | allowTrackClick : Boolean = true Specifies whether clicking on the track will move the slider thumb. | Slider
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | dataTipFormatFunction : Function Callback function that formats the data tip text. | Slider
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | direction : String The orientation of the slider control. | Slider
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | labels : Array An array of strings used for the slider labels. | Slider
 | liveDragging : Boolean = false Specifies whether live dragging is enabled for the slider. | Slider
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maximum : Number The maximum allowed value on the slider. | Slider
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
 | minimum : Number The minimum allowed value on the slider control. | Slider
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | showDataTip : Boolean = true If set to true, show a data tip during user interaction containing the current value of the slider. | Slider
 | sliderDataTipClass : Class A reference to the class to use for the data tip. | Slider
 | sliderThumbClass : Class A reference to the class to use for each thumb. | Slider
 | snapInterval : Number Specifies the increment value of the slider thumb as the user moves the thumb. | Slider
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | thumbCount : int The number of thumbs allowed on the slider. | Slider
 | tickInterval : Number The spacing of the tick marks relative to the maximum value of the control. | Slider
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | value : Number Contains the position of the thumb, and is a number between the minimum and maximum properties. | Slider
 | values : Array An array of values for each thumb when thumbCount is greater than 1. | Slider
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Slider()
Constructor.
Slider
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
getThumbAt(index:int):SliderThumb
Returns the thumb object at the given index.
Slider
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
setThumbValueAt(index:int, value:Number):void
This method sets the value of a slider thumb, and updates the display.
Slider
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Calculates the amount of space that the component takes up. | Slider
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Positions the elements of the control. | Slider
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | change | Dispatched when the slider changes value due to mouse or keyboard interaction. | Slider
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
 | thumbDrag | Dispatched when the slider's thumb is pressed and then moved by the mouse. | Slider
 | thumbPress | Dispatched when the slider's thumb is pressed, meaning the user presses the mouse button over the thumb. | Slider
 | thumbRelease | Dispatched when the slider's thumb is released, meaning the user releases the mouse button after a thumbPress event. | Slider
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
 | borderColor | Type: uint Format: Color CSS Inheritance: no The color of the black section of the border. The default value is 0x919999. | Slider
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | dataTipOffset | Type: Number Format: Length CSS Inheritance: no The offset, in pixels, of the data tip relative to the thumb. Used in combination with the dataTipPlacement style property of the HSlider and VSlider controls. The default value is 16. | Slider
 | dataTipPrecision | Type: int CSS Inheritance: no Number of decimal places to use for the data tip text. A value of 0 means to round all values to an integer. The default value is 2. | Slider
 | dataTipStyleName | Type: String CSS Inheritance: no The name of the style declaration to use for the data tip. The default value is undefined. | Slider
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
 | fillAlphas | Type: Array CSS Inheritance: no Specifies the alpha transparency values used for the background fill of components. You should set this to an Array of either two or four numbers. Elements 0 and 1 specify the start and end values for an alpha gradient. If elements 2 and 3 exist, they are used instead of elements 0 and 1 when the component is in a mouse-over state. The global default value is [ 0.60, 0.40, 0.75, 0.65 ]. Some components, such as the ApplicationControlBar container, have a different default value. For the ApplicationControlBar container, the default value is [ 0.0, 0.0 ]. | Slider
 | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the slider thumb. Pass the same color for both values for a "flat" looking control. The default value is [ 0xFFFFFF, 0xCCCCCC, 0xFFFFFF, 0xEEEEEE; ]. | Slider
 | fillColors | Type: Array Format: Color CSS Inheritance: no Specifies the colors used to tint the background fill of the component. You should set this to an Array of either two or four uint values that specify RGB colors. Elements 0 and 1 specify the start and end values for a color gradient. If elements 2 and 3 exist, they are used instead of elements 0 and 1 when the component is in a mouse-over state. For a flat-looking control, set the same color for elements 0 and 1 and for elements 2 and 3, The default value is [ 0xFFFFFF, 0xCCCCCC, 0xFFFFFF, 0xEEEEEE ]. Some components, such as the ApplicationControlBar container, have a different default value. For the ApplicationControlBar container, the default value is [ 0xFFFFFF, 0xFFFFFF ]. | Slider
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | labelOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the labels relative to the track. The default value is -10. | Slider
 | labelStyleName | Type: String CSS Inheritance: no The name of the style to use for the slider label. The default value is undefined. | Slider
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
 | showTrackHighlight | Type: Boolean CSS Inheritance: no Specifies whether to enable track highlighting between thumbs (or a single thumb and the beginning of the track). The default value is false. | Slider
 | slideDuration | Type: Number Format: Time CSS Inheritance: no Duration in milliseconds for the sliding animation when you click on the track to move a thumb. The default value is 300. | Slider
 | slideEasingFunction | Type: Function CSS Inheritance: no Tweening function used by the sliding animation when you click on the track to move a thumb. The default value is undefined. | Slider
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
 | thumbDisabledSkin | Type: Class CSS Inheritance: no The skin for the slider thumb disabled state. The default value is SliderThumbSkin. | Slider
 | thumbDownSkin | Type: Class CSS Inheritance: no The skin for the slider thumb down state. The default value is SliderThumbSkin. | Slider
 | thumbOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the thumb relative to the track. The default value is 0. | Slider
 | thumbOverSkin | Type: Class CSS Inheritance: no The skin for the slider thumb over state. The default value is SliderThumbSkin. | Slider
 | thumbUpSkin | Type: Class CSS Inheritance: no The skin for the slider thumb up state. The default value is SliderThumbSkin. | Slider
 | tickColor | Type: uint Format: Color CSS Inheritance: no The color of the tick marks. Can be a hex color value or the string name of a known color. The default value is 0x6F7777.. | Slider
 | tickLength | Type: Number Format: Length CSS Inheritance: no The length in pixels of the tick marks. If direction is Direction.HORIZONTAL, then adjust the height of the tick marks. If direction is Direction.VERTICAL, then adjust the width. The default value is 3. | Slider
 | tickOffset | Type: Number Format: Length CSS Inheritance: no The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the tick marks relative to the track. The default value is -6. | Slider
 | tickThickness | Type: Number Format: Length CSS Inheritance: no The thickness in pixels of the tick marks. If direction is horizontal, then adjust the width of the tick marks. If direction is vertical, then adjust the height. The default value is 1. | Slider
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | trackColors | Type: Array Format: Color CSS Inheritance: no The colors of the track, as an array of two colors. You can use the same color twice for a solid track color. You use this property along with the fillAlphas property. Typically you set fillAlphas to [ 1.0, 1.0 ] when setting trackColors. The default value is [ 0xE7E7E7, 0xE7E7E7 ]. | Slider
 | trackHighlightSkin | Type: Class CSS Inheritance: no The skin for the slider track when it is selected. | Slider
 | trackMargin | Type: Number Format: Length CSS Inheritance: no The size of the track margins, in pixels. If undefined, then the track margins will be determined by the length of the first and last labels. If given a value, Flex attempts to fit the labels in the available space. The default value is undefined. | Slider
 | trackSkin | Type: Class CSS Inheritance: no The skin for the slider track. | Slider
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
allowThumbOverlap property
public var allowThumbOverlap:Boolean = false

If set to false, then each thumb can only be moved to the edge of the adjacent thumb. If true, then each thumb can be moved to any position on the track.

The default value is false.

allowTrackClick property
public var allowTrackClick:Boolean = true

Specifies whether clicking on the track will move the slider thumb.

The default value is true.

dataTipFormatFunction property
dataTipFormatFunction:Function [read-write]

Callback function that formats the data tip text. The function takes a single Number as an argument and returns a formatted String.

The function has the following signature:

   funcName(value:Number):String

The following example prefixes the data tip text with a dollar sign and formats the text using the dataTipPrecision of a Slider Control named 'slide':

  import mx.formatters.NumberBase;
  function myDataTipFormatter(value:Number):String {
   var dataFormatter:NumberBase = new NumberBase(".", ",", ".", "");
    return   "$ " + dataFormatter.formatPrecision(String(value), slide.getStyle("dataTipPrecision"));
  }

The default value is undefined.

Implementation
    public function get dataTipFormatFunction():Function
    public function set dataTipFormatFunction(value:Function):void
direction property
direction:String [read-write]

The orientation of the slider control. Valid values in MXML are "horizontal" or "vertical".

In ActionScript, you use the following constants to set this property: SliderDirection.VERTICAL and SliderDirection.HORIZONTAL.

The HSlider and VSlider controls set this property for you; do not set it when using those controls.

The default value is SliderDirection.HORIZONTAL.

Implementation
    public function get direction():String
    public function set direction(value:String):void

See also

mx.controls.sliderClasses.SliderDirection
labels property
labels:Array [read-write]

An array of strings used for the slider labels. Flex positions the labels at the beginning of the track, and spaces them evenly between the beginning of the track and the end of the track.

For example, if the array contains three items, the first item is placed at the beginning of the track, the second item in the middle, and the last item at the end of the track.

If only one label is specified, it is placed at the beginning of the track. By default, labels are placed above the tick marks (if present) or above the track. To align the labels with the tick marks, make sure that the number of tick marks is equal to the number of labels.

The default value is undefined.

Implementation
    public function get labels():Array
    public function set labels(value:Array):void
liveDragging property
public var liveDragging:Boolean = false

Specifies whether live dragging is enabled for the slider. If false, Flex sets the value and values properties and dispatches the change event when the user stops dragging the slider thumb. If true, Flex sets the value and values properties and dispatches the change event continuously as the user moves the thumb.

The default value is false.

maximum property
maximum:Number [read-write]

The maximum allowed value on the slider.

The default value is 10.

Implementation
    public function get maximum():Number
    public function set maximum(value:Number):void
minimum property
minimum:Number [read-write]

The minimum allowed value on the slider control.

The default value is 0.

Implementation
    public function get minimum():Number
    public function set minimum(value:Number):void
showDataTip property
public var showDataTip:Boolean = true

If set to true, show a data tip during user interaction containing the current value of the slider.

The default value is true.

sliderDataTipClass property
sliderDataTipClass:Class [read-write]

A reference to the class to use for the data tip.

The default value is SliderDataTip.

Implementation
    public function get sliderDataTipClass():Class
    public function set sliderDataTipClass(value:Class):void
sliderThumbClass property
sliderThumbClass:Class [read-write]

A reference to the class to use for each thumb.

The default value is SliderThumb.

Implementation
    public function get sliderThumbClass():Class
    public function set sliderThumbClass(value:Class):void
snapInterval property
snapInterval:Number [read-write]

Specifies the increment value of the slider thumb as the user moves the thumb. For example, if snapInterval is 2, the minimum value is 0, and the maximum value is 10, the thumb snaps to the values 0, 2, 4, 6, 8, and 10 as the user move the thumb. A value of 0, means that the slider moves continuously between the minimum and maximum values.

The default value is 0.

Implementation
    public function get snapInterval():Number
    public function set snapInterval(value:Number):void
thumbCount property
thumbCount:int [read-write]

The number of thumbs allowed on the slider. Possible values are 1 or 2. If set to 1, then the value property contains the current value of the slider. If set to 2, then the values property contains an array of values representing the value for each thumb.

The default value is 1.

Implementation
    public function get thumbCount():int
    public function set thumbCount(value:int):void
tickInterval property
tickInterval:Number [read-write]

The spacing of the tick marks relative to the maximum value of the control. Flex displays tick marks whenever you set the tickInterval property to a nonzero value.

For example, if tickInterval is 1 and maximum is 10, then a tick mark is placed at each 1/10th interval along the slider. A value of 0 shows no tick marks.

The default value is 0.

Implementation
    public function get tickInterval():Number
    public function set tickInterval(value:Number):void
value property
value:Number [read-write]

Contains the position of the thumb, and is a number between the minimum and maximum properties. Use the value property when thumbCount is 1. When thumbCount is greater than 1, use the values property instead. The default value is equal to the minimum property.

This property can be used as the source for data binding.

Implementation
    public function get value():Number
    public function set value(value:Number):void
values property
values:Array [read-write]

An array of values for each thumb when thumbCount is greater than 1.

This property can be used as the source for data binding.

Implementation
    public function get values():Array
    public function set values(value:Array):void
Constructor detail
Slider () constructor
public function Slider()

Constructor.

Method detail
getThumbAt () method
public function getThumbAt(index:int):SliderThumb

Returns the thumb object at the given index. Use this method to style and customize individual thumbs in a slider control.

Parameters
index:int — The zero-based index number of the thumb.

Returns
SliderThumb — A reference to the SliderThumb object.
measure () method
protected override function measure():void

Calculates the amount of space that the component takes up. A horizontal slider control calculates its height by examining the position of its labels, tick marks, and thumbs relative to the track. The height of the control is equivalent to the position of the bottom of the lowest element subtracted from the position of the top of the highest element. The width of a horizontal slider control defaults to 250 pixels. For a vertical slider control, the width and the length measurements are reversed.

setThumbValueAt () method
public function setThumbValueAt(index:int, value:Number):void

This method sets the value of a slider thumb, and updates the display.

Parameters
index:int — The zero-based index number of the thumb to set the value of, where a value of 0 corresponds to the first thumb.
value:Number — The value to set the thumb to
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Positions the elements of the control. The track, thumbs, labels, and tick marks are all positioned and sized by this method. The track is sized based on the length of the labels and on the track margin. If you specify a trackMargin, then the size of the track is equal to the available width minus the trackMargin times 2.

Tick marks are spaced at even intervals along the track starting from the beginning of the track. An additional tick mark is placed at the end of the track if one doesn't already exist (if the tick interval isn't a multiple of the maximum value). The tick mark y-position is based on the tickOffset. An offset of 0 places the bottom of the tick at the top of the track. Negative offsets move the ticks upwards while positive offsets move them downward through the track.

Labels are positioned at even intervals along the track. The labels are always horizontally centered above their interval position unless the trackMargin setting is too small. If you specify a trackMargin, then the first and last labels will position themselves at the left and right borders of the control. Labels will not crop or resize themselves if they overlap, so be sure to allow enough space for them to fit on the track. The y-position is based on the labelOffset property. An offset of 0 places the bottom of the label at the top of the track. Unlike tick marks, the labels can not be positioned to overlap the track. If the offset is a positive number, then the top of the label will be positioned below the bottom of the track.

The thumbs are positioned to overlap the track. Their x-position is determined by their value. The y-position is controlled by the thumbOffset property. An offset of 0 places the center of the thumb at the center of the track. A negative offset moves the thumbs upwards while a positive offset moves the thumbs downwards.

The placement of the tick marks, labels and thumbs are all independent from each other. They will not attempt to reposition themselves if they overlap.

For a vertical slider control, the same rules apply. In the above description, substitute width for height, height for width, left for up or top, right for down or bottom, x-position for y-position, and y-position for x-position.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
Event detail
change event
Event object type: mx.events.SliderEvent
SliderEvent.type property = mx.events.SliderEvent.CHANGE

Dispatched when the slider changes value due to mouse or keyboard interaction.

If the liveDragging property is true, the event is dispatched continuously as the user moves the thumb. If liveDragging is false, the event is dispatched when the user releases the slider thumb.

The SliderEvent.CHANGE constant defines the value of the type property of the event object for a change event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.
thumbDrag event
Event object type: mx.events.SliderEvent
SliderEvent.type property = mx.events.SliderEvent.THUMB_DRAG

Dispatched when the slider's thumb is pressed and then moved by the mouse. This event is always preceded by a thumbPress event.

The SliderEvent.THUMB_DRAG constant defines the value of the type property of the event object for a thumbDrag event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.
thumbPress event
Event object type: mx.events.SliderEvent
SliderEvent.type property = mx.events.SliderEvent.THUMB_PRESS

Dispatched when the slider's thumb is pressed, meaning the user presses the mouse button over the thumb.

The SliderEvent.THUMB_PRESS constant defines the value of the type property of the event object for a thumbPress event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.
thumbRelease event
Event object type: mx.events.SliderEvent
SliderEvent.type property = mx.events.SliderEvent.THUMB_RELEASE

Dispatched when the slider's thumb is released, meaning the user releases the mouse button after a thumbPress event.

The SliderEvent.THUMB_RELEASE constant defines the value of the type property of the event object for a thumbRelease event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.


mx.controls.sliderClasses.SliderDataTip (Flex™ 2 Language Reference)

Class SliderDataTip | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.sliderClasses
Class | public class SliderDataTip
Inheritance | SliderDataTip Inheritance ToolTip Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The SliderDataTip class defines the tooltip used in the mx.controls.Slider control. The class adds no additional functionality to mx.controls.ToolTip. It is used only to apply a type selector style.

See also

mx.controls.HSlider
mx.controls.VSlider
mx.controls.sliderClasses.Slider
mx.controls.sliderClasses.SliderLabel
mx.controls.sliderClasses.SliderThumb
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number = 300 [static] Maximum width in pixels for new ToolTip controls. | ToolTip
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String The text displayed by the ToolTip. | ToolTip
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField that renders the text of this ToolTip. | ToolTip
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SliderDataTip()
Constructor.
SliderDataTip
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ToolTip
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ToolTip
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ToolTip
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ToolTip
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ToolTip
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ToolTip
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ToolTip
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ToolTip
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ToolTip
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ToolTip
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ToolTip
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ToolTip
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ToolTip
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ToolTip
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ToolTip
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ToolTip
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ToolTip
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ToolTip
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ToolTip
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ToolTip
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ToolTip
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ToolTip
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ToolTip
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ToolTip
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ToolTip
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ToolTip
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ToolTip
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ToolTip
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ToolTip
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ToolTip
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ToolTip
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
SliderDataTip () constructor
public function SliderDataTip()

Constructor.


mx.controls.sliderClasses.SliderDirection (Flex™ 2 Language Reference)

Class SliderDirection | Properties | Methods | Constants
Package | mx.controls.sliderClasses
Class | public final class SliderDirection
Inheritance | SliderDirection Inheritance Object

The SliderDirection class defines the constant values for the direction property of the Slider class.

See also

mx.controls.sliderClasses.Slider
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] Specifies to display a horizontal slider. | SliderDirection
 | VERTICAL : String = "vertical" [static] Specifies to display a vertical slider. | SliderDirection
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

Specifies to display a horizontal slider. The HSlider control uses this constant.

VERTICAL constant
public static const VERTICAL:String = "vertical"

Specifies to display a vertical slider. The VSlider control uses this constant.


mx.controls.sliderClasses.SliderLabel (Flex™ 2 Language Reference)

Class SliderLabel | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.sliderClasses
Class | public class SliderLabel
Inheritance | SliderLabel Inheritance Label Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The SliderLabel class defines the label used in the mx.controls.Slider component. The class adds no additional functionality to mx.controls.Label. It is used to apply a type selector style.

See also

mx.controls.HSlider
mx.controls.VSlider
mx.controls.sliderClasses.Slider
mx.controls.sliderClasses.SliderDataTip
mx.controls.sliderClasses.SliderThumb
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | condenseWhite : Boolean Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a Label control with HTML text. | Label
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object Lets you pass a value to the component when you use it in an item renderer or item editor. | Label
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | htmlText : String Specifies the text displayed by the Label control, including HTML markup that expresses the styles of that text. | Label
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control. | Label
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selectable : Boolean Specifies whether the text can be selected. | Label
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String Specifies the plain text displayed by this control. | Label
Inherited | textHeight : Number The height of the text. | Label
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | textWidth : Number The width of the text. | Label
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | truncateToFit : Boolean = true If this propery is true, and the Label control size is smaller than its text, the text of the Label control is truncated using a localizable string, such as "...". | Label
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField that renders the text of this Label. | Label
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SliderLabel()
Constructor.
SliderLabel
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getLineMetrics(lineIndex:int):TextLineMetrics
Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
Label
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Label
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Label
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Label
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Label
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Label
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Label
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Label
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Label
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Label
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Label
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Label
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Label
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Label
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Label
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
SliderLabel () constructor
public function SliderLabel()

Constructor.


mx.controls.sliderClasses.SliderThumb (Flex™ 2 Language Reference)

Class SliderThumb | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.sliderClasses
Class | public class SliderThumb
Inheritance | SliderThumb Inheritance Button Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The SliderThumb class represents a thumb of a Slider control. The SliderThumb class can only be used within the context of a Slider control. You can create a subclass of the SliderThumb class, and use it with a Slider control by setting the thumbClass property of the Slider control to your subclass.

See also

mx.controls.HSlider
mx.controls.VSlider
mx.controls.sliderClasses.Slider
mx.controls.sliderClasses.SliderDataTip
mx.controls.sliderClasses.SliderLabel
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | autoRepeat : Boolean Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button. | Button
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it as an item renderer or item editor. | Button
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | emphasized : Boolean Draws a thick border around the Button control when the control is in its up state if emphasized is set to true. | Button
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | label : String Text to appear on the Button control. | Button
Inherited | labelPlacement : String Orientation of the label in relation to a specified icon. | Button
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control. | Button
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | selected : Boolean Indicates whether a toggle button is toggled on (true) or off (false). | Button
Inherited | selectedField : String = "null" The name of the field in the data property which specifies the value of the Button control's selected property. | Button
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | stickyHighlighting : Boolean = false If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it. | Button
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toggle : Boolean Controls whether a Button is in a toggle state or not. | Button
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | xPosition : Number Specifies the position of the center of the thumb on the x-axis. | SliderThumb
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | textField : UITextField The internal UITextField object that renders the label of this Button. | Button
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SliderThumb()
Constructor.
SliderThumb
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clickHandler(event:MouseEvent):void The default handler for the MouseEvent.CLICK event. | Button
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | mouseDownHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_DOWN event. | Button
Inherited | mouseUpHandler(event:MouseEvent):void The default handler for the MouseEvent.MOUSE_UP event. | Button
Inherited | rollOutHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OUT event. | Button
Inherited | rollOverHandler(event:MouseEvent):void The default handler for the MouseEvent.ROLL_OVER event. | Button
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | buttonDown | Dispatched when the user presses the Button control. | Button
Inherited | change | Dispatched when the selected property changes for a toggle Button control. | Button
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Button
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Button
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Button
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Button
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Button
Inherited | disabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not disabled. | Button
Inherited | disabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and is disabled. | Button
Inherited | downIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse button is down. | Button
Inherited | downSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down. | Button
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | fillAlphas | Type: Array CSS Inheritance: no Alphas used for the background fill of controls. | Button
Inherited | fillColors | Type: Array Format: Color CSS Inheritance: no Colors used to tint the background of the control. | Button
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | Button
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | Button
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Button
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Button
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Button
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Button
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Button
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Button
Inherited | highlightAlphas | Type: Array CSS Inheritance: no Alpha transparencies used for the highlight fill of controls. | Button
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGap | Type: Number Format: Length CSS Inheritance: no Gap between the label and icon, when the labelPlacement property is set to left or right. | Button
Inherited | icon | Type: Class CSS Inheritance: no Name of the class to use as the default icon. | Button
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | Button
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | overIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is not selected and the mouse is over the control. | Button
Inherited | overSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control. | Button
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's bottom border and the bottom of its content area. | Button
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Button
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Button
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's top border and the top of its content area. | Button
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval. | Button
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button. | Button
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | selectedDisabledIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and disabled. | Button
Inherited | selectedDisabledSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and disabled. | Button
Inherited | selectedDownIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is down. | Button
Inherited | selectedDownSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down. | Button
Inherited | selectedOverIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse is over the control. | Button
Inherited | selectedOverSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control. | Button
Inherited | selectedUpIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when the button is selected and the mouse button is up. | Button
Inherited | selectedUpSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control. | Button
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Button
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Button
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Button
Inherited | textRollOverColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user moves the mouse pointer over the button. | Button
Inherited | textSelectedColor | Type: uint Format: Color CSS Inheritance: yes Text color of the label as the user presses it. | Button
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | upIcon | Type: Class CSS Inheritance: no Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button. | Button
Inherited | upSkin | Type: Class CSS Inheritance: no Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control. | Button
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGap | Type: Number Format: Length CSS Inheritance: no Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom". | Button
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
xPosition property
xPosition:Number [read-write]

Specifies the position of the center of the thumb on the x-axis.

Implementation
    public function get xPosition():Number
    public function set xPosition(value:Number):void
Constructor detail
SliderThumb () constructor
public function SliderThumb()

Constructor.


mx.controls.textClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.textClasses | Classes

The mx.controls.textClasses package contains the classes used by the text-based controls.

Classes
Class | Description
TextRange | The TextRange class provides properties that select and format a range of text in the Label, Text, TextArea, TextEditor, and RichTextEditor controls.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.textClasses.TextRange (Flex™ 2 Language Reference)

Class TextRange | Properties | Methods
Package | mx.controls.textClasses
Class | public class TextRange
Inheritance | TextRange Inheritance Object

The TextRange class provides properties that select and format a range of text in the Label, Text, TextArea, TextEditor, and RichTextEditor controls.

See also

mx.controls.Label
mx.controls.RichTextEditor
mx.controls.Text
mx.controls.TextArea
mx.controls.TextInput
flash.text.TextFormatAlign

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | beginIndex : int Zero-based index in the control's text field of the first character in the range. | TextRange
 | bullet : Boolean Whether the text in the range is in a bulleted list. | TextRange
 | color : Object Color of the text in the range. | TextRange
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | endIndex : int Zero-based index in the control's text field of the point immediately after the last character in the range; equivalent to the One-based index of the last character. | TextRange
 | fontFamily : String Name of the font for text in the range. | TextRange
 | fontSize : int Point size of the text in the range. | TextRange
 | fontStyle : String Style of the font in the range, as "italic" or "normal". | TextRange
 | fontWeight : String Weight of the font in the range, as "bold" or "normal". | TextRange
 | htmlText : String Contents of the range in the form of HTML text. | TextRange
 | modifiesSelection : Boolean [read-only] Whether the TextRange modifies the currenly selected text. | TextRange
 | owner : UIComponent The control that contains the text. | TextRange
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | text : String Plain-text contents of the range. | TextRange
 | textAlign : String Alignment of the text in the range. | TextRange
 | textDecoration : String Decoration of the font in the range, as "underline" or "normal". | TextRange
 | url : String URL for a hypertext link in the range. | TextRange
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TextRange(owner:UIComponent, modifiesSelection:Boolean = false, beginIndex:int = -1, endIndex:int = -1) Create a new TextRange Object that represents a subset of the contents of a text control, including the formatting information. | TextRange
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
beginIndex property
beginIndex:int [read-write]

Zero-based index in the control's text field of the first character in the range. If the fifth character in the text is the first character in the range, this property has a value of 4.

Implementation
    public function get beginIndex():int
    public function set beginIndex(value:int):void
bullet property
bullet:Boolean [read-write]

Whether the text in the range is in a bulleted list. If only part of the range is in a bulleted list, this value is false.

Implementation
    public function get bullet():Boolean
    public function set bullet(value:Boolean):void
color property
color:Object [read-write]

Color of the text in the range. You can set this value using any valid color identifier. The property returns the value as a numeric value. If the range has multiple colors, this value is null.

Implementation
    public function get color():Object
    public function set color(value:Object):void
endIndex property
endIndex:int [read-write]

Zero-based index in the control's text field of the point immediately after the last character in the range; equivalent to the One-based index of the last character. If the fifth character in the text is the last character in the range, this property has a value of 5.

Implementation
    public function get endIndex():int
    public function set endIndex(value:int):void
fontFamily property
fontFamily:String [read-write]

Name of the font for text in the range. If the range has multiple fonts, this value is null.

Implementation
    public function get fontFamily():String
    public function set fontFamily(value:String):void
fontSize property
fontSize:int [read-write]

Point size of the text in the range. If the range has multiple sizes, this value is 0.

Implementation
    public function get fontSize():int
    public function set fontSize(value:int):void
fontStyle property
fontStyle:String [read-write]

Style of the font in the range, as "italic" or "normal". Setting the property to any other string results in normal style. If the range has multiple styles, this value is null.

Implementation
    public function get fontStyle():String
    public function set fontStyle(value:String):void
fontWeight property
fontWeight:String [read-write]

Weight of the font in the range, as "bold" or "normal". Setting the property to any other string results in normal weight. If the range has multiple weights, this value is null.

Implementation
    public function get fontWeight():String
    public function set fontWeight(value:String):void
htmlText property
htmlText:String [read-write]

Contents of the range in the form of HTML text. This property returns all HTML markup for the range, including markup for formatting that is applied by Flex, not just HTML that you specify in using an htmlText property. This property is, therefore, a full HTML representation of the text as it appears in the control.

Implementation
    public function get htmlText():String
    public function set htmlText(value:String):void
modifiesSelection property
modifiesSelection:Boolean [read-only]

Whether the TextRange modifies the currenly selected text. Set by the constructor.

Implementation
    public function get modifiesSelection():Boolean
owner property
owner:UIComponent [read-write]

The control that contains the text. The owner control must have a textField property, or, as is the case of the RichTextEditor control, a textArea property. The owner of the text in a RichTextEditor control is the RichTextEditor control, not its TextArea subcontrol. Initially set by the constructor.

Implementation
    public function get owner():UIComponent
    public function set owner(value:UIComponent):void
text property
text:String [read-write]

Plain-text contents of the range.

Implementation
    public function get text():String
    public function set text(value:String):void
textAlign property
textAlign:String [read-write]

Alignment of the text in the range. The flash.text.TextFormatAlign constants specify the valid values. Setting this property to any other value has no effect. If the range has multiple alignments, this value is null.

Implementation
    public function get textAlign():String
    public function set textAlign(value:String):void

See also

flash.text.TextFormatAlign
textDecoration property
textDecoration:String [read-write]

Decoration of the font in the range, as "underline" or "normal". Setting the property to any other string results in normal text. If the range has multiple decoration settings, this value is null.

Implementation
    public function get textDecoration():String
    public function set textDecoration(value:String):void
url property
url:String [read-write]

URL for a hypertext link in the range. If the range does not include a link, the value is the empty string. If the range includes multiple links, the value is null.

Implementation
    public function get url():String
    public function set url(value:String):void
Constructor detail
TextRange () constructor
public function TextRange(owner:UIComponent, modifiesSelection:Boolean = false, beginIndex:int = -1, endIndex:int = -1)

Create a new TextRange Object that represents a subset of the contents of a text control, including the formatting information.

Parameters
owner:UIComponent — The control that contains the text. The control must have a textField property, or, as is the case of the RichTextEditor control, a textArea property.
modifiesSelection:Boolean (default = false) — Whether to select the text in the range. If you set this parameter to true and do not specify a begin or end index that corresponds to text in the control, Flex uses the begin or end index of the current text selection. If this parameter is true, you omit the beginIndex and endIndex parameters, and there is no selection, the TextRange object is empty.
beginIndex:int (default = -1) — Zero-based index of the first character in the range. If the modifiesSelection parameter is false and you omit this parameter or specify a negative value, the range starts with the first text character.
endIndex:int (default = -1) — Zero-based index of the position after the last character in the range. If the modifiesSelection parameter is false and you omit this parameter, specify a negative value, or specify a value past the end of the text, the range ends with the last text character.


mx.controls.treeClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.treeClasses | Interfaces | Classes

The mx.controls.treeClasses package contains the classes used by the Tree control.

Interfaces
Interface | Description
ITreeDataDescriptor | Interface providing methods for parsing and adding nodes to a collection of data that is displayed by a Tree control.
Classes
Class | Description
DefaultDataDescriptor | The DefaultDataDescriptor class provides a default implementation for accessing and manipulating data for use in controls such as Tree and Menu.
TreeItemRenderer | The TreeItemRenderer class defines the default item renderer for a Tree control.
TreeListData | The TreeListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the Tree control.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.treeClasses.DefaultDataDescriptor (Flex™ 2 Language Reference)

Class DefaultDataDescriptor | Properties | Methods
Package | mx.controls.treeClasses
Class | public class DefaultDataDescriptor
Inheritance | DefaultDataDescriptor Inheritance Object
Implements | IMenuDataDescriptor, ITreeDataDescriptor

The DefaultDataDescriptor class provides a default implementation for accessing and manipulating data for use in controls such as Tree and Menu. This implementation handles e4x XML and object nodes in similar but different ways. See each method description for details on how the method accesses values in nodes of various types. This class is the default value of the Tree, Menu, MenuBar, and PopUpMenuButton control dataDescriptor properties.

See also

mx.controls.treeClasses.ITreeDataDescriptor
mx.controls.menuClasses.IMenuDataDescriptor
mx.controls.Menu
Bar
mx.controls.PopUpMenuButton
mx.controls.Tree

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DefaultDataDescriptor() Constructor | DefaultDataDescriptor
 | addChildAt(parent:Object, newChild:Object, index:int, model:Object = null):Boolean Add a child node to a node at the specified index. | DefaultDataDescriptor
 | getChildren(node:Object, model:Object = null):ICollectionView Provides access to a node's children. | DefaultDataDescriptor
 | getData(node:Object, model:Object = null):Object Returns a node's data. | DefaultDataDescriptor
 | getGroupName(node:Object):String Returns the name of the radio button group to which the node belongs, if any. | DefaultDataDescriptor
 | getType(node:Object):String Returns the type identifier of a node. | DefaultDataDescriptor
 | hasChildren(node:Object, model:Object = null):Boolean Returns true if the node actually has children. | DefaultDataDescriptor
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isBranch(node:Object, model:Object = null):Boolean Tests a node for termination. | DefaultDataDescriptor
 | isEnabled(node:Object):Boolean Returns whether the node is enabled. | DefaultDataDescriptor
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | isToggled(node:Object):Boolean Returns whether the node is toggled. | DefaultDataDescriptor
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removeChildAt(parent:Object, child:Object, index:int, model:Object = null):Boolean Removes the child node from a node at the specified index. | DefaultDataDescriptor
 | setEnabled(node:Object, value:Boolean):void Sets the value of the field or attribute in the data provider that identifies whether the node is enabled. | DefaultDataDescriptor
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setToggled(node:Object, value:Boolean):void Sets the value of the field or attribute in the data provider that identifies whether the node is toggled. | DefaultDataDescriptor
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
DefaultDataDescriptor () constructor
public function DefaultDataDescriptor()

Constructor

Method detail
addChildAt () method
public function addChildAt(parent:Object, newChild:Object, index:int, model:Object = null):Boolean

Add a child node to a node at the specified index. This implementation does the following:

  • If the parent parameter is null or undefined, inserts the child parameter at the specified index in the collection specified by model parameter.
  • If the parent parameter has a children field or property, the method adds the child parameter to it at the index parameter location. In this case, the model parameter is not required.
  • If the index value is greater than the collection length or number of children in the parent, adds the object as the last child.

Parameters
parent:Object — The node object that will parent the child
newChild:Object — The node object that will be parented by the node
index:int — The 0-based index of where to put the child node relative to the parent
model:Object (default = null) — The entire collection that this node is a part of

Returns
Boolean — true if successful
getChildren () method
public function getChildren(node:Object, model:Object = null):ICollectionView

Provides access to a node's children. Returns a collection of children if they exist. If the node is an Object, the method returns the contents of the object's children field as an ArrayCollection. If the node is XML, the method returns an XMLListCollection containing the child elements.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
ICollectionView — An object containing the children nodes.
getData () method
public function getData(node:Object, model:Object = null):Object

Returns a node's data. Currently returns the entire node.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
Object — The node.
getGroupName () method
public function getGroupName(node:Object):String

Returns the name of the radio button group to which the node belongs, if any. This method is used by menu-based controls.

Parameters
node:Object — The node for which to get the group name.

Returns
String — The value of the node's groupName attribute or field, or an empty string if there is no such entry.
getType () method
public function getType(node:Object):String

Returns the type identifier of a node. This method is used by menu-based controls to determine if the node represents a separator, radio button, a check box, or normal item.

Parameters
node:Object — The node object for which to get the type.

Returns
String — the value of the type attribute or field, or the empty string if there is no such field.
hasChildren () method
public function hasChildren(node:Object, model:Object = null):Boolean

Returns true if the node actually has children.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
Boolean — boolean indicating if this node currently has children
isBranch () method
public function isBranch(node:Object, model:Object = null):Boolean

Tests a node for termination. Branches are non-terminating but are not required to have any leaf nodes. If the node is XML, returns true if the node has children or a true isBranch attribute. If the node is an object, returns true if the node has a (possibly empty) children field.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The collection that contains the node; ignored by this class.

Returns
Boolean — boolean indicating if this node is non-terminating
isEnabled () method
public function isEnabled(node:Object):Boolean

Returns whether the node is enabled. This method is used by menu-based controls.

Parameters
node:Object — The node for which to get the status.

Returns
Boolean — the value of the node's enabled attribute or field, or true if there is no such entry or the value is not false.
isToggled () method
public function isToggled(node:Object):Boolean

Returns whether the node is toggled. This method is used by menu-based controls.

Parameters
node:Object — The node for which to get the status.

Returns
Boolean — The value of the node's toggled attribute or field, or false if there is no such entry.
removeChildAt () method
public function removeChildAt(parent:Object, child:Object, index:int, model:Object = null):Boolean

Removes the child node from a node at the specified index. If the parent parameter is null or undefined, the method uses the model parameter to access the child; otherwise, it uses the parent parameter and ignores the model parameter.

Parameters
parent:Object — The node object that currently parents the child node
child:Object — The node that is being removed
index:int — The 0-based index of the child node to remove relative to the parent
model:Object (default = null) — The entire collection that this node is a part of

Returns
Boolean — true if successful
setEnabled () method
public function setEnabled(node:Object, value:Boolean):void

Sets the value of the field or attribute in the data provider that identifies whether the node is enabled. This method sets the value of the node's enabled attribute or field. This method is used by menu-based controls.

Parameters
node:Object — The node for which to set the status.
value:Boolean — Whether the node is enabled.
setToggled () method
public function setToggled(node:Object, value:Boolean):void

Sets the value of the field or attribute in the data provider that identifies whether the node is toggled. This method sets the value of the node's toggled attribute or field. This method is used by menu-based controls.

Parameters
node:Object — The node for which to set the status.
value:Boolean — Whether the node is toggled.


mx.controls.treeClasses.ITreeDataDescriptor (Flex™ 2 Language Reference)

Interface ITreeDataDescriptor | Methods
Package | mx.controls.treeClasses
Interface | public interface ITreeDataDescriptor
Implementors | DefaultDataDescriptor

Interface providing methods for parsing and adding nodes to a collection of data that is displayed by a Tree control.

See also

mx.collections.ICollectionView

Public Methods
Method |  | Defined by
 | addChildAt(parent:Object, newChild:Object, index:int, model:Object = null):Boolean Adds a child node to a node at the specified index. | ITreeDataDescriptor
 | getChildren(node:Object, model:Object = null):ICollectionView Provides access to a node's children, returning a collection view of children if they exist. | ITreeDataDescriptor
 | getData(node:Object, model:Object = null):Object Gets the data from a node. | ITreeDataDescriptor
 | hasChildren(node:Object, model:Object = null):Boolean Tests for the existence of children in a non-terminating node. | ITreeDataDescriptor
 | isBranch(node:Object, model:Object = null):Boolean Tests a node for termination. | ITreeDataDescriptor
 | removeChildAt(parent:Object, child:Object, index:int, model:Object = null):Boolean Removes a child node to a node at the specified index. | ITreeDataDescriptor
Method detail
addChildAt () method
public function addChildAt(parent:Object, newChild:Object, index:int, model:Object = null):Boolean

Adds a child node to a node at the specified index.

Parameters
parent:Object — The node object that will parent the child.
newChild:Object — The node object that will be parented by the node.
index:int — The 0-based index of where to put the child node.
model:Object (default = null) — The entire collection that this node is a part of

Returns
Boolean — true if successful.
getChildren () method
public function getChildren(node:Object, model:Object = null):ICollectionView

Provides access to a node's children, returning a collection view of children if they exist. A node can return any object in the collection as its children; children need not be nested. It is best-practice to return the same collection view for a given node.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The entire collection that this node is a part of.

Returns
ICollectionView — An collection view containing the child nodes.
getData () method
public function getData(node:Object, model:Object = null):Object

Gets the data from a node.

Parameters
node:Object — The node object from which to get the data.
model:Object (default = null) — The collection that contains the node.

Returns
Object — Object The requested data.
hasChildren () method
public function hasChildren(node:Object, model:Object = null):Boolean

Tests for the existence of children in a non-terminating node.

Parameters
node:Object
model:Object (default = null)

Returns
Boolean
isBranch () method
public function isBranch(node:Object, model:Object = null):Boolean

Tests a node for termination. Branches are non-terminating but are not required to have any leaf nodes.

Parameters
node:Object — The node object currently being evaluated.
model:Object (default = null) — The entire collection that this node is a part of.

Returns
Boolean — A Boolean indicating if this node is non-terminating.
removeChildAt () method
public function removeChildAt(parent:Object, child:Object, index:int, model:Object = null):Boolean

Removes a child node to a node at the specified index.

Parameters
parent:Object — The node object that is the parent of the child.
child:Object — The node object that will be removed.
index:int — The 0-based index of the soon to be deleted node.
model:Object (default = null) — The entire collection that this node is a part of

Returns
Boolean — true if successful.


mx.controls.treeClasses.TreeItemRenderer (Flex™ 2 Language Reference)

Class TreeItemRenderer | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.controls.treeClasses
Class | public class TreeItemRenderer
Inheritance | TreeItemRenderer Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IDataRenderer, IDropInListItemRenderer, IListItemRenderer

The TreeItemRenderer class defines the default item renderer for a Tree control. By default, the item renderer draws the text associated with each item in the tree, an optional icon, and an optional disclosure icon.

You can override the default item renderer by creating a custom item renderer.

See also

mx.controls.Tree
mx.core.IDataRenderer
mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The implementation of the data property as defined by the IDataRenderer interface. | TreeItemRenderer
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | listData : BaseListData The implementation of the listData property as defined by the IDropInListItemRenderer interface. | TreeItemRenderer
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | disclosureIcon : IFlexDisplayObject The internal IFlexDisplayObject that displays the disclosure icon in this renderer. | TreeItemRenderer
 | icon : IFlexDisplayObject The internal IFlexDisplayObject that displays the icon in this renderer. | TreeItemRenderer
 | label : UITextField The internal UITextField that displays the text in this renderer. | TreeItemRenderer
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TreeItemRenderer()
Constructor.
TreeItemRenderer
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | TreeItemRenderer
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
 | color | Type: uint Format: Color CSS Inheritance: yes Text color of a component label. The default value is 0x0B333C. | TreeItemRenderer
 | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of the component if it is disabled. The default value is 0xAAB3B3. | TreeItemRenderer
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
data property
data:Object [read-write]

The implementation of the data property as defined by the IDataRenderer interface.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
disclosureIcon property
protected var disclosureIcon:IFlexDisplayObject

The internal IFlexDisplayObject that displays the disclosure icon in this renderer.

icon property
protected var icon:IFlexDisplayObject

The internal IFlexDisplayObject that displays the icon in this renderer.

label property
protected var label:UITextField

The internal UITextField that displays the text in this renderer.

listData property
listData:BaseListData [read-write]

The implementation of the listData property as defined by the IDropInListItemRenderer interface.

This property can be used as the source for data binding.

Implementation
    public function get listData():BaseListData
    public function set listData(value:BaseListData):void

See also

mx.controls.listClasses.IDropInListItemRenderer
Constructor detail
TreeItemRenderer () constructor
public function TreeItemRenderer()

Constructor.

Event detail
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When you use a component as an item renderer, the data property contains the data to display. You can listen for this event and update the component when the data property changes.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.controls.treeClasses.TreeListData (Flex™ 2 Language Reference)

Class TreeListData | Properties | Methods
Package | mx.controls.treeClasses
Class | public class TreeListData
Inheritance | TreeListData Inheritance BaseListData Inheritance Object

The TreeListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the Tree control. All drop-in item renderers and drop-in item editors must implement the IDropInListItemRenderer interface, which defines the listData property.

While the properties of this class are writable, you should considered them to be read only. They are initialized by the Tree class, and read by an item renderer or item editor. Changing these values can lead to unexpected results.

See also

mx.controls.listClasses.IDropInListItemRenderer

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | depth : int The level of the item in the tree. | TreeListData
 | disclosureIcon : Class A Class representing the disclosure icon for the item in the Tree control. | TreeListData
 | hasChildren : Boolean Contains true if the node has children. | TreeListData
 | icon : Class A Class representing the icon for the item in the Tree control. | TreeListData
 | indent : int The default indentation for this row of the Tree control. | TreeListData
 | item : Object The data for this item in the Tree control. | TreeListData
Inherited | label : String The textual representation of the item data, based on the list class's itemToLabel() method. | BaseListData
 | open : Boolean Contains true if the node is open. | TreeListData
Inherited | owner : IUIComponent A reference to the list object that owns this item. | BaseListData
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rowIndex : int The index of the item in the data provider. | BaseListData
Inherited | uid : String The unique identifier for this item. | BaseListData
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TreeListData(text:String, uid:String, owner:ListBase, rowIndex:int = 0) Constructor. | TreeListData
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
depth property
public var depth:int

The level of the item in the tree. The top level is 1.

disclosureIcon property
public var disclosureIcon:Class

A Class representing the disclosure icon for the item in the Tree control.

hasChildren property
public var hasChildren:Boolean

Contains true if the node has children.

icon property
public var icon:Class

A Class representing the icon for the item in the Tree control.

indent property
public var indent:int

The default indentation for this row of the Tree control.

item property
public var item:Object

The data for this item in the Tree control.

open property
public var open:Boolean

Contains true if the node is open.

Constructor detail
TreeListData () constructor
public function TreeListData(text:String, uid:String, owner:ListBase, rowIndex:int = 0)

Constructor.

Parameters
text:String — Text representation of the item data.
uid:String — A unique identifier for the item.
owner:ListBase — A reference to the Tree control.
rowIndex:int (default = 0) — The index of the item in the data provider for the Tree control.


mx.controls.videoClasses Summary (Flex™ 2 Language Reference)

Package mx.controls.videoClasses | Classes

The mx.controls.videoClasses package contains the classes used by the VideoDisplay control.

Classes
Class | Description
CuePointManager | The CuePointManager class lets you use ActionScript code to manage the cue points associated with the VideoDisplay control.
VideoError | The VideoError class represents the error codes for errors thrown by the VideoDisplay control.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.controls.videoClasses.CuePointManager (Flex™ 2 Language Reference)

Class CuePointManager | Properties | Methods
Package | mx.controls.videoClasses
Class | public class CuePointManager
Inheritance | CuePointManager Inheritance Object

The CuePointManager class lets you use ActionScript code to manage the cue points associated with the VideoDisplay control.

See also

mx.controls.VideoDisplay

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CuePointManager(owner:VideoPlayer, id:uint = 0) Constructor. | CuePointManager
 | addCuePoint(cuePoint:Object):Object Adds a cue point. | CuePointManager
 | getCuePointByName(name:String):Object Search for a cue point with specified name. | CuePointManager
 | getCuePoints():Array Returns an Array of all cue points. | CuePointManager
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removeAllCuePoints():void Removes all cue points. | CuePointManager
 | removeCuePoint(cuePoint:Object):Object Removes a cue point from the currently loaded FLV file. | CuePointManager
 | setCuePoints(cuePointArray:Array):void Set the array of cue points. | CuePointManager
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
CuePointManager () constructor
public function CuePointManager(owner:VideoPlayer, id:uint = 0)

Constructor.

Parameters
owner:VideoPlayer
id:uint (default = 0)
Method detail
addCuePoint () method
public function addCuePoint(cuePoint:Object):Object

Adds a cue point.

You can add multiple cue points with the same name and time. When you call the removeCuePoint() method with the name and time, it removes the first matching cue point. To remove all matching cue points, you have to make additional calls to the removeCuePoint() method.

Parameters
cuePoint:Object — The Object describes the cue point. It must contain the properties name:String and time:Number (in seconds). If the Object does not conform to these conventions, it throws a VideoError error.

Returns
Object — A copy of the cue point Object added. The copy has the following additional properties:
  • array - the Array of all cue points. Treat this Array as read only because adding, removing or editing objects within it can cause cue points to malfunction.
  • index - the index into the Array for the returned cue point.

Throws
VideoError — If the arguments are invalid.
getCuePointByName () method
public function getCuePointByName(name:String):Object

Search for a cue point with specified name.

Parameters
name:String — The name of the cue point.

Returns
Object — null if no match was found, or a copy of the matching cue point Object with additional properties:
  • array - the Array of cue points searched. Treat this array as read only because adding, removing or editing objects within it can cause cue points to malfunction.
  • index - the index into the Array for the returned cue point.
getCuePoints () method
public function getCuePoints():Array

Returns an Array of all cue points.

Returns
Array — An Array of cue point objects. Each cue point object describes the cue point, and contains the properties name:String and time:Number (in seconds).
removeAllCuePoints () method
public function removeAllCuePoints():void

Removes all cue points.

removeCuePoint () method
public function removeCuePoint(cuePoint:Object):Object

Removes a cue point from the currently loaded FLV file. Only the name and time properties are used from the cuePoint argument to determine the cue point to be removed.

If multiple cue points match the search criteria, only one will be removed. To remove all cue points, call this function repeatedly in a loop with the same arguments until it returns null.

Parameters
cuePoint:Object — The Object must contain at least one of name:String and time:Number properties, and removes the cue point that matches the specified properties.

Returns
Object — An object representing the cue point removed. If there was no matching cue point, then it returns null.
setCuePoints () method
public function setCuePoints(cuePointArray:Array):void

Set the array of cue points.

You can add multiple cue points with the same name and time. When you call the removeCuePoint() method with this name, only the first one is removed.

Parameters
cuePointArray:Array — An Array of cue point objects. Each cue point object describes the cue point. It must contain the properties name:String and time:Number (in seconds).


mx.controls.videoClasses.VideoError (Flex™ 2 Language Reference)

Class VideoError | Properties | Methods | Constants
Package | mx.controls.videoClasses
Class | public class VideoError
Inheritance | VideoError Inheritance Error Inheritance Object

The VideoError class represents the error codes for errors thrown by the VideoDisplay control.

See also

mx.controls.VideoDisplay

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | code : uint [read-only] Contains the error code. | VideoError
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | VideoError(errCode:uint, msg:String = null) Constructor | VideoError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DELETE_DEFAULT_PLAYER : uint = 1007 [static] Cannot delete default VideoPlayer | VideoError
 | ILLEGAL_CUE_POINT : uint = 1002 [static] Illegal cue point. | VideoError
 | INVALID_CONTENT_PATH : uint = 1004 [static] Invalid content path. | VideoError
 | INVALID_SEEK : uint = 1003 [static] Invalid seek. | VideoError
 | INVALID_XML : uint = 1005 [static] Invalid XML. | VideoError
 | NO_BITRATE_MATCH : uint = 1006 [static] No bitrate match. | VideoError
 | NO_CONNECTION : uint = 1000 [static] Unable to make connection to server or to find FLV on server. | VideoError
 | NO_CUE_POINT_MATCH : uint = 1001 [static] No matching cue point found. | VideoError
Property detail
code property
code:uint [read-only]

Contains the error code.

Implementation
    public function get code():uint
Constructor detail
VideoError () constructor
public function VideoError(errCode:uint, msg:String = null)

Constructor

Parameters
errCode:uint — error code.
msg:String (default = null) — The error message.
Constant detail
DELETE_DEFAULT_PLAYER constant
public static const DELETE_DEFAULT_PLAYER:uint = 1007

Cannot delete default VideoPlayer

ILLEGAL_CUE_POINT constant
public static const ILLEGAL_CUE_POINT:uint = 1002

Illegal cue point.

INVALID_CONTENT_PATH constant
public static const INVALID_CONTENT_PATH:uint = 1004

Invalid content path.

INVALID_SEEK constant
public static const INVALID_SEEK:uint = 1003

Invalid seek.

INVALID_XML constant
public static const INVALID_XML:uint = 1005

Invalid XML.

NO_BITRATE_MATCH constant
public static const NO_BITRATE_MATCH:uint = 1006

No bitrate match.

NO_CONNECTION constant
public static const NO_CONNECTION:uint = 1000

Unable to make connection to server or to find FLV on server.

NO_CUE_POINT_MATCH constant
public static const NO_CUE_POINT_MATCH:uint = 1001

No matching cue point found.


mx.core Summary (Flex™ 2 Language Reference)

Package mx.core | Interfaces | Classes

The mx.core package contains the base classes and interfaces, such as UIComponent, used by Flex.

Interfaces
Interface | Description
IChildList | The IChildList interface defines the properties and methods for accessing and manipulating child lists, which are subsets of a DisplayObjectContainer's children.
IContainer | IContainer is a marker interface that indicates a component acts as a container for other components.
IDataRenderer | The IDataRenderer interface defines the interface for components that have a data property.
IDeferredInstance | The IDeferredInstance interface defines the Flex deferred instance factory interface.
IDeferredInstantiationUIComponent | The IDeferredInstantiationUIComponent interface defines the interface for a component or object that defers instantiation.
IFactory | The IFactory interface defines the interface that factory classes such as ClassFactory must implement.
IFlexAsset | IFlexAsset is a marker interface with the following meaning: if a class declares that it implements IFlexAsset, then that class represents an asset -- such as a bitmap, a font, or a sound -- that has been embedded in a Flex application.
IFlexDisplayObject | The IFlexDisplayObject interface defines the interface for skin elements.
IIMESupport | The IIMESupport interface defines the interface for any component that supports IME (input method editor).
IInvalidating | The IInvalidating interface defines the interface for components that use invalidation to do delayed -- rather than immediate -- property commitment, measurement, drawing, and layout.
IMXMLObject | The IMXMLObject interface defines the APIs that a non-visual component must implement in order to work properly with the MXML compiler.
IPropertyChangeNotifier | The IPropertyChangeNotifier interface defines a marker interface.
IRawChildrenContainer | The IRawChildrenContainer interface defines the APIs for containers that can return an IChildList that represents all their children.
IRepeater | The IRepeater interface defines the APIs for Repeater public APIs of the Repeater object.
IRepeaterClient | The IRepeaterClient interface defines the APIs for components that can have multiple instances created by a Repeater.
IToolTip | The IToolTip interface defines the API that tooltip-like components must implement in order to work with the ToolTipManager.
IUIComponent | The IUIComponent interface defines the basic set of APIs that you must implement to create a child of a Flex container or list.
IUID | The IUID interface defines the interface for objects that must have Unique Identifiers (UIDs) to uniquely identify the object.
Classes
Class | Description
Application | Flex defines a default, or Application, container that lets you start adding content to your application without explicitly defining another container.
BitmapAsset | BitmapAsset is a subclass of the Flash Player's Bitmap class which represents bitmap images that you embed in a Flex application.
ButtonAsset | ButtonAsset is a subclass of the Flash Player's SimpleButton class which represents button symbols that you embed in a Flex application from a SWF file produced by Flash.
ClassFactory | A ClassFactory instance is a "factory object" which Flex uses to generate instances of another class, each with identical properties.
ComponentDescriptor | ComponentDescriptor is the base class for the UIComponentDescriptor class, which encapsulates the information that you specified in an MXML tag for an instance of a visual component.
Container | The Container class is an abstract base class for components that controls the layout characteristics of child components.
ContainerCreationPolicy | The ContainerCreationPolicy class defines the constant values for the creationPolicy property of the Container class.
ContainerLayout | The ContainerLayout class defines the constant values for the layout property of container classes.
DeferredInstanceFromClass | A deferred instance factory that creates and returns an instance of a specified class.
DeferredInstanceFromFunction | A deferred instance factory that uses a generator function to create an instance of the required object.
DragSource | The DragSource class contains the data being dragged.
EdgeMetrics | The EdgeMetrics class specifies the thickness, in pixels, of the four edge regions around a visual component.
EventPriority | The EventPriority class defines constant values for the priority argument of the addEventListener() method of EventDispatcher.
FlexBitmap | FlexBitmap is a subclass of the Player's Bitmap class.
FlexMovieClip | FlexMovieClip is a subclass of the Player's MovieClip class.
FlexShape | FlexShape is a subclass of the Player's Shape class.
FlexSimpleButton | FlexSimpleButton is a subclass of the Player's SimpleButton class.
FlexSprite | FlexSprite is a subclass of the Player's Sprite class and the superclass of UIComponent.
FlexTextField | FlexTextField is a subclass of the Player's TextField class and the superclass of UITextField.
MovieClipAsset | MovieClipAsset is a subclass of the Flash Player's MovieClip class which represents movieclip symbols that you embed in a Flex application from a SWF file produced by Flash.
MovieClipLoaderAsset | MovieClipLoaderAsset is a subclass of the MovieClipAsset class which represents SWF files that you embed in a Flex application.
Repeater | The Repeater class is the runtime object that corresponds to the <mx:Repeater> tag.
ScrollControlBase | The ScrollControlBase class is the base class for controls with scroll bars.
ScrollPolicy | Values for the horizontalScrollPolicy and verticalScrollPolicy properties of the Container and ScrollControlBase classes.
SoundAsset | SoundAsset is a subclass of the Flash Player's Sound class which represents sounds that you embed in a Flex application.
SpriteAsset | SpriteAsset is a subclass of the Flash Player's Sprite class which represents vector graphic images that you embed in a Flex application.
TextFieldAsset | TextFieldAsset is a subclass of the Flash Player's TextField class which represents TextField symbols that you embed in a Flex application from a SWF file produced by Flash.
UIComponent | The UIComponent class is the base class for all visual components, both interactive and noninteractive.
UIComponentCachePolicy | The ContainerCreationPolicy class defines the constant values for the cachePolicy property of the UIComponent class.
UIComponentDescriptor | A UIComponentDescriptor instance encapsulates the information that you specified in an MXML tag for an instance of a visual component.
UITextField | The UITextField class defines the component used by many Flex components to display text.
UITextFormat | The UITextFormat class represents character formatting information for the UITextField class.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.core.Application (Flex™ 2 Language Reference)

Class Application | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.core
Class | public class Application
Inheritance | Application Inheritance Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Flex defines a default, or Application, container that lets you start adding content to your application without explicitly defining another container. Flex creates this container from the <mx:Application> tag, the first tag in an MXML application file. While you might find it convenient to use the Application container as the only container in your application, in most cases you explicitly define at least one more container before you add any controls to your application.

Applications support a predefined plain style that sets a white background, left alignment, and removes all margins. To use this style, do the following:

    <mx:Application styleName="plain" />

This is equivalent to setting the following style attributes:

    backgroundColor="0xFFFFFF"
    horizontalAlign="left"
    paddingLeft="0"
    paddingTop="0"
    paddingBottom="0"
    paddingRight="0"

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Application> tag inherits all of the tag attributes of its superclass and adds the following tag attributes:

  <mx:Application
    Properties
    application="No default"
    controlBar="null"
    frameRate="24"
    layout="vertical|horizontal|absolute"
    pageTitle"No default"
    preloader="No default"
    resetHistory="false|true"
    scriptRecursionLimit="1000"
    scriptTimeLimit="60"
    usePreloader="true|false"
    viewSourceURL=""
    xmlns:No default="No default"

    Styles
    backgroundGradientAlphas="[ 1.0, 1.0 ]"
    backgroundGradientColors="undefined"
    horizontalAlign="center|left|right"
    horizontalGap="8"
    modalTransparency="0.5"
    modalTransparencyBlur="3"
    modalTransparencyColor="#DDDDDD"
    modalTransparencyDuration="100"
    paddingBottom="24"
    paddingTop="24"
    verticalAlign="top|bottom|middle"
    verticalGap="6"

    Events
    applicationComplete="No default"
    error="No default"
  />

View the examples.

See also

mx.managers.CursorManager
mx.managers.LayoutManager
mx.managers.SystemManager
flash.events.EventDispatcher
Using the Application container
Dynamically adding containers to the queue

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | application : Object [static][read-only] A reference to the top-level application. | Application
Inherited | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
Inherited | baselinePosition : Number The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | childDescriptors : Array Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | Container
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | controlBar : IUIComponent The ApplicationControlBar for this Application. | Application
Inherited | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
Inherited | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
Inherited | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
 | frameRate : Number Specifies the frame rate of the application. | Application
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
Inherited | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
Inherited | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
Inherited | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | layout : String Specifies the layout mechanism used for this application. | Application
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxHorizontalScrollPosition : Number The largest possible value for the horizontalScrollPosition property. | Container
Inherited | maxVerticalScrollPosition : Number The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
 | pageTitle : String Specifies a string that appears in the title bar of the browser. | Application
 | parameters : Object [read-only] The parameters property returns an Object containing name-value pairs representing the parameters provided to this Application. | Application
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | preloader : Object Specifies the path of a SWC component class or ActionScript component class that defines a custom progress bar. | Application
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rawChildren : IChildList A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
 | resetHistory : Boolean = true If true, the application's history state is reset to its initial state whenever the application is reloaded. | Application
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
 | scriptRecursionLimit : int Specifies the maximum depth of the Adobe Flash Player call stack before Flash Player stops. | Application
 | scriptTimeLimit : Number Specifies the maximum duration, in seconds, that an ActionScript event handler can execute before the Flash Player assumes that it is hung, and aborts it. | Application
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
 | url : String [read-only] The URL from which this Application's SWF file was loaded. | Application
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
 | usePreloader : Boolean If true, specifies to display the application preloader. | Application
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
Inherited | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
Inherited | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
Inherited | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
Inherited | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
Inherited | viewMetrics : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | viewMetricsAndPadding : EdgeMetrics Returns an object that has four properties: left, top, right, and bottom. | Container
 | viewSourceURL : String URL where the application's source can be viewed. | Application
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Application()
Constructor.
Application
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
addToCreationQueue(id:Object, preferredIndex:int = -1, callbackFunc:Function = null, parent:IFlexDisplayObject = null):void
Add a container to the Application's creation queue.
Application
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
Inherited
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
Inherited
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
Inherited
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
Inherited
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
Inherited
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
Inherited
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeAllChildren():void
Removes all children from the child list of this container.
Container
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's children. | Container
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | applicationComplete | Dispatched after the Application has been initialized, processed by the LayoutManager, and attached to the display list. | Application
Inherited | childAdd | Dispatched after a child has been added to a container. | Container
Inherited | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
Inherited | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
 | error | Dispatched when an error occurs anywhere in the application, such as an HTTPService, WebService, or RemoteObject fails. | Application
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | Container
Inherited | backgroundAttachment | Type: String CSS Inheritance: no If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). | Container
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | Container
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes Background color of the component when it is disabled. | Container
 | backgroundGradientAlphas | Type: Array CSS Inheritance: no Specifies the alpha transparency values used for the background gradient fill of the application. You should set this to an Array of two numbers. Elements 0 and 1 specify the start and end values for an alpha gradient. The default value is [ 1.0, 1.0 ]. | Application
 | backgroundGradientColors | Type: Array Format: Color CSS Inheritance: no Specifies the colors used to tint the background gradient fill of the application. You should set this to an Array of two uint values that specify RGB colors. Elements 0 and 1 specify the start and end values for a color gradient. For a solid-color background, set the same color value for elements 0 and 1. A value of undefined means background gradient is generated based on the backgroundColor property. The default value is undefined. | Application
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | Container
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | Container
Inherited | barColor | Type: uint Format: Color CSS Inheritance: yes Determines the color of a ProgressBar. | Container
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | Container
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | Container
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | Container
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | Container
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | Container
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | Container
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | Container
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | Container
Inherited | disabledOverlayAlpha | Type: Number CSS Inheritance: no The alpha value for the overlay that is placed on top of the container when it is disabled. | Container
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | Container
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | Container
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | Container
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | Container
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | Container
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | Container
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | Container
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | Container
 | horizontalAlign | Type: String CSS Inheritance: no Horizontal alignment of children in the container. Possible values are "left", "center", and "right". The default value is "left", but some containers, such as ButtonBar and ToggleButtonBar, have different default values. | Application
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | horizontalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the horizontal direction. The default value depends on the component class; if not overriden for the class, the default value is 8. | Application
Inherited | horizontalScrollBarStyleName | Type: String CSS Inheritance: no The name of the horizontal scrollbar style. | Container
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
 | modalTransparency | Type: Number CSS Inheritance: yes Modality of components launched by the PopUp Manager is simulated by creating a large translucent overlay underneath the component. Because of the way translucent objects are rendered, you may notice a slight dimming of the objects under the overlay. The effective transparency can be set by changing the modalTransparency value from 0.0 (fully transparent) to 1.0 (fully opaque). You can also set the color of the overlay by changing the modalTransparencyColor style. The default value is 0.5. | Application
 | modalTransparencyBlur | Type: Number CSS Inheritance: yes The blur applied to the application while a modal window is open. A Blur effect softens the details of an image. The default value is 3. | Application
 | modalTransparencyColor | Type: uint Format: Color CSS Inheritance: yes Color of the modal overlay layer. This style is used in conjunction with the modalTransparency style to determine the colorization applied to the application when a modal window is open. The default value is #DDDDDD. | Application
 | modalTransparencyDuration | Type: Number Format: Time CSS Inheritance: yes Duration, in milliseconds, of the modal transparency effect that plays when a modal window opens or closes. The default value is 100. | Application
 | paddingBottom | Type: Number Format: Length CSS Inheritance: no Number of pixels between the application's bottom border and its content area. The default value is 24. | Application
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | Container
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | Container
 | paddingTop | Type: Number Format: Length CSS Inheritance: no Number of pixels between the application's top border and its content area. The default value is 24. | Application
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | Container
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | Container
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | Container
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | Container
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | Container
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
 | verticalAlign | Type: String CSS Inheritance: no Vertical alignment of children in the container. Possible values are "top", "middle", and "bottom". The default value is "top", but some containers, such as ButtonBar, ControlBar, LinkBar, and ToggleButtonBar, have different default values. | Application
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
 | verticalGap | Type: Number Format: Length CSS Inheritance: no Number of pixels between children in the vertical direction. The default value depends on the component class; if not overriden for the class, the default value is 6. | Application
Inherited | verticalScrollBarStyleName | Type: String CSS Inheritance: no The name of the vertical scrollbar style. | Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
application property
application:Object [read-only]

A reference to the top-level application.

In general, there can be a hierarchy of Application objects, because an Application can use a SWFLoader control to dynamically load another Application. The parentApplication property of a UIComponent can be used to access the sub-Application in which that UIComponent lives, and to walk up the hierarchy to the top-level Application.

Implementation
    public static function get application():Object

See also

Using the Application.application.parameters object
controlBar property
public var controlBar:IUIComponent

The ApplicationControlBar for this Application.

The default value is null.

See also

mx.containers.ApplicationControlBar
frameRate property
public var frameRate:Number

Specifies the frame rate of the application.

The default value is 24.

layout property
layout:String [read-write]

Specifies the layout mechanism used for this application. Applications can use "vertical", "horizontal", or "absolute" positioning. Vertical positioning lays out each child component vertically from the top of the application to the bottom in the specified order. Horizontal positioning lays out each child component horizontally from the left of the application to the right in the specified order. Absolute positioning does no automatic layout and requires you to explicitly define the location of each child component.

The default value is "vertical".

This property can be used as the source for data binding.

Implementation
    public function get layout():String
    public function set layout(value:String):void
pageTitle property
public var pageTitle:String

Specifies a string that appears in the title bar of the browser. This property provides the same functionality as the HTML <title> tag.

The default value is "".

parameters property
parameters:Object [read-only]

The parameters property returns an Object containing name-value pairs representing the parameters provided to this Application.

You can use a for-in loop to extract all the names and values from the parameters Object.

There are two sources of parameters: the query string of the Application's URL, and the value of the FlashVars HTML parameter (this affects only the main Application).

Implementation
    public function get parameters():Object
preloader property
public var preloader:Object

Specifies the path of a SWC component class or ActionScript component class that defines a custom progress bar. A SWC component must be in the same directory as the MXML file or in the WEB-INF/flex/user_classes directory of your Flex web application.

resetHistory property
public var resetHistory:Boolean = true

If true, the application's history state is reset to its initial state whenever the application is reloaded. Applications are reloaded when any of the following occurs:

  • The user clicks the browser's Refresh button.
  • The user navigates to another web page, and then clicks the browser's Back button to return to the Flex application.
  • The user loads a Flex application from the browser's Favorites or Bookmarks menu.

The default value is true.

scriptRecursionLimit property
public var scriptRecursionLimit:int

Specifies the maximum depth of the Adobe Flash Player call stack before Flash Player stops. This is essentially the stack overflow limit.

The default value is 1000.

scriptTimeLimit property
public var scriptTimeLimit:Number

Specifies the maximum duration, in seconds, that an ActionScript event handler can execute before the Flash Player assumes that it is hung, and aborts it. The maximum allowable value that you can set is 60 seconds.

The default value is 60.

url property
url:String [read-only]

The URL from which this Application's SWF file was loaded.

Implementation
    public function get url():String
usePreloader property
public var usePreloader:Boolean

If true, specifies to display the application preloader.

The default value is true.

viewSourceURL property
viewSourceURL:String [read-write]

URL where the application's source can be viewed. Setting this property inserts a "View Source" menu item into the application's default context menu. Selecting the menu item opens the viewSourceURL in a new window.

You must set the viewSourceURL property using MXML, not using ActionScript, as the following example shows:

     <mx:Application viewSourceURL="http://path/to/source">
       ...
     </mx:Application>
Implementation
    public function get viewSourceURL():String
    public function set viewSourceURL(value:String):void
Constructor detail
Application () constructor
public function Application()

Constructor.

Method detail
addToCreationQueue () method
public function addToCreationQueue(id:Object, preferredIndex:int = -1, callbackFunc:Function = null, parent:IFlexDisplayObject = null):void

Add a container to the Application's creation queue.

Use this mechanism to instantiate and draw the contents of a container in an ordered manner. The container should have the creationPolicy property set to "none" prior to calling this function.

Parameters
id:Object — The id of the container to add to the queue or a pointer to the container itself
preferredIndex:int (default = -1) — (optional) A positive integer that determines the container's position in the queue relative to the other containers presently in the queue.
callbackFunc:Function (default = null) — This parameter is ignored.
parent:IFlexDisplayObject (default = null) — This parameter is ignored.
Event detail
applicationComplete event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.APPLICATION_COMPLETE

Dispatched after the Application has been initialized, processed by the LayoutManager, and attached to the display list.

The FlexEvent.APPLICATION_COMPLETE constant defines the value of the type property of the event object for a applicationComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
error event
Event object type: flash.events.ErrorEvent
ErrorEvent.type property = flash.events.ErrorEvent.ERROR

Dispatched when an error occurs anywhere in the application, such as an HTTPService, WebService, or RemoteObject fails.

Defines the value of the type property of an error event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The object experiencing a network operation failure.
text | Text to be displayed as an error message.
Examples
SimpleApplicationExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Application container. -->

<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
    backgroundGradientColors="[0xCCCCCC, 0x66CCFF]"
    backgroundColor="0xCCCCCC"
    horizontalAlign="center" verticalAlign="center"
    applicationComplete="appComplete();">

    <mx:Script>
        <![CDATA[

            // Event handlers for the components.
            private function appComplete():void {
                myTA.text+="Application creation complete" + "\n";
            }

            private function panelCreationComplete():void {
                myTA.text+="Panel creation complete" + "\n";
            }

            private function textAreaCreationComplete():void {
                myTA.text+="\n" + "TextArea creation complete" + "\n";
            }
        ]]>
    </mx:Script>

    <mx:ApplicationControlBar dock="true">
        <mx:Button label="Set Solid Fill"
            click="this.setStyle('backgroundGradientColors', [0xCCCCCC, 0xCCCCCC]);"/>
        <mx:Button label="Set Gradient Fill"
            click="this.setStyle('backgroundGradientColors', [0xCCCCCC, 0x66CCFF]);"/>
    </mx:ApplicationControlBar>

    <mx:Panel title="Application Container Example" backgroundColor="0x9CB0BA"
        width="75%" height="75%"
        creationComplete="panelCreationComplete();">

        <mx:TextArea id="myTA" height="100%" width="100%"
            text="Event order: "
            creationComplete="textAreaCreationComplete();"/>

    </mx:Panel>
</mx:Application>


mx.core.BitmapAsset (Flex™ 2 Language Reference)

Class BitmapAsset | Properties | Methods | Events
Package | mx.core
Class | public class BitmapAsset
Inheritance | BitmapAsset Inheritance FlexBitmap Inheritance Bitmap Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFlexAsset, IFlexDisplayObject

BitmapAsset is a subclass of the Flash Player's Bitmap class which represents bitmap images that you embed in a Flex application. It implements the IFlexDisplayObject interface, which makes it possible for an embedded bitmap image to be displayed in an Image control, or to be used as a container background or a component skin.

The bitmap image that you're embedding can be in a JPEG, GIF, or PNG file. You can also embed a bitmap symbol that is in a SWF file produced by Flash. In each of these cases, the MXML compiler autogenerates a class that extends BitmapAsset to represent the embedded bitmap image.

You don't generally have to use the BitmapAsset class directly when you write a Flex application. For example, you can embed a GIF file and display the image in an Image control by writing the gollowing:

  <mx:Image id="logo" source="@Embed(source='Logo.gif')"/>

or use it as the application's background image in CSS syntax by writing

  <mx:Style>
      Application
      {
          backgroundImage: Embed(source="Logo.gif")
      }
  <mx:Style/>

without having to understand that the MXML compiler has created a subclass of BitmapAsset for you.

However, it may be useful to understand what is happening at the ActionScript level. To embed a bitmap image in ActionScript, you declare a variable of type Class, and put [Embed] metadata on it. For example, you embed a GIF file like this:

  [Bindable]
  [Embed(source="Logo.gif")]
  private var logoClass:Class;

The MXML compiler sees the .gif extension, transcodes the GIF data into the bitmap format that the Flash Player uses, autogenerates a subclass of the BitmapAsset class, and sets your variable to be a reference to this autogenerated class. You can then use this class reference to create instances of the BitmapAsset using the new operator, and you can use APIs of the Bitmap class on them:

  var logo:BitmapAsset = BitmapAsset(new logoClass());
  addChild(logo);

However, you rarely need to create BitmapAsset instances yourself because image-related properties and styles can simply be set to an image-producing class, and components will create image instances as necessary. For example, to display this image in an Image control, you can set the Image's source property to logoClass. In MXML you could do this as follows:

  <mx:Image id="logo" source="{logoClass}"/>

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | bitmapData : BitmapData The BitmapData object being referenced. | Bitmap
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | measuredHeight : Number [read-only] The measured height of this object. | BitmapAsset
 | measuredWidth : Number [read-only] The measured width of this object. | BitmapAsset
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | pixelSnapping : String Controls whether or not the Bitmap object is snapped to the nearest pixel. | Bitmap
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | smoothing : Boolean Controls whether or not the bitmap is smoothed when scaled. | Bitmap
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BitmapAsset(bitmapData:BitmapData = null, pixelSnapping:String = "auto", smoothing:Boolean = false)
Constructor.
BitmapAsset
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
BitmapAsset
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
BitmapAsset
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexBitmap
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
measuredHeight property
measuredHeight:Number [read-only]

The measured height of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measured width of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredWidth():Number
Constructor detail
BitmapAsset () constructor
public function BitmapAsset(bitmapData:BitmapData = null, pixelSnapping:String = "auto", smoothing:Boolean = false)

Constructor.

Parameters
bitmapData:BitmapData (default = null) — The data for the bitmap image.
pixelSnapping:String (default = "auto") — Whether or not the bitmap is snapped to the nearest pixel.
smoothing:Boolean (default = false) — Whether or not the bitmap is smoothed when scaled.
Method detail
move () method
public function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The new x-position for this object.
y:Number — The new y-position for this object.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.


mx.core.ButtonAsset (Flex™ 2 Language Reference)

Class ButtonAsset | Properties | Methods | Events
Package | mx.core
Class | public class ButtonAsset
Inheritance | ButtonAsset Inheritance FlexSimpleButton Inheritance SimpleButton Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFlexAsset, IFlexDisplayObject

ButtonAsset is a subclass of the Flash Player's SimpleButton class which represents button symbols that you embed in a Flex application from a SWF file produced by Flash. It implements the IFlexDisplayObject interface, which makes it possible for a SimpleButtonAsset to be displayed in an Image control, or to be used as a container background or a component skin.

This class is included in Flex for completeness, so that any kind of symbol in a SWF file produced by Flash can be embedded in a Flex application. However, Flex applications do not typically use embedded SimpleButtons. Refer to more commonly-used asset classes such as BitmapAsset for more information about how embedded assets work in Flex.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | downState : DisplayObject Specifies a display object that is used as the visual object for the button "Down" state —the state that the button is in when the user clicks the hitTestState object. | SimpleButton
Inherited | enabled : Boolean A Boolean value that specifies whether a button is enabled. | SimpleButton
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitTestState : DisplayObject Specifies a display object that is used as the hit testing object for the button. | SimpleButton
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | measuredHeight : Number [read-only] The measured height of this object. | ButtonAsset
 | measuredWidth : Number [read-only] The measured width of this object. | ButtonAsset
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | overState : DisplayObject Specifies a display object that is used as the visual object for the button over state — the state that the button is in when the mouse is positioned over the button. | SimpleButton
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform The SoundTransform object assigned to this button. | SimpleButton
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | SimpleButton
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | upState : DisplayObject Specifies a display object that is used as the visual object for the button up state — the state that the button is in when the mouse is not positioned over the button. | SimpleButton
Inherited | useHandCursor : Boolean A Boolean value that, when set to true, indicates whether Flash Player displays the hand cursor when the mouse rolls over a button. | SimpleButton
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ButtonAsset()
Constructor.
ButtonAsset
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ButtonAsset
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
ButtonAsset
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSimpleButton
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
measuredHeight property
measuredHeight:Number [read-only]

The measured height of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measured width of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredWidth():Number
Constructor detail
ButtonAsset () constructor
public function ButtonAsset()

Constructor.

Method detail
move () method
public function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The new x-position for this object.
y:Number — The new y-position for this object.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.


mx.core.ClassFactory (Flex™ 2 Language Reference)

Class ClassFactory | Properties | Methods
Package | mx.core
Class | public class ClassFactory
Inheritance | ClassFactory Inheritance Object
Implements | IFactory

A ClassFactory instance is a "factory object" which Flex uses to generate instances of another class, each with identical properties.

You specify a generator class when you construct the factory object. Then you set the properties property on the factory object. Flex uses the factory object to generate instances by calling the factory object's newInstance() method.

The newInstance() method creates a new instance of the generator class, and sets the properties specified by properties in the new instance. If you need to further customize the generated instances, you can override the newInstance() method.

The ClassFactory class implements the IFactory interface. Therefore it lets you create objects that can be assigned to properties of type IFactory, such as the itemRenderer property of a List control or the itemEditor property of a DataGrid control.

For example, suppose you write an item renderer class named ProductRenderer containing a showProductImage property which can be true or false. If you want to make a List control use this renderer, and have each renderer instance display a product image, you would write the following code:

  var productRenderer:ClassFactory = new ClassFactory(ProductRenderer);
  productRenderer.properties = { showProductImage: true };
  myList.itemRenderer = productRenderer;

The List control calls the newInstance() method on the itemRenderer to create individual instances of ProductRenderer, each with showProductImage property set to true. If you want a different List control to omit the product images, you use the ProductRenderer class to create another ClassFactory with the properties property set to { showProductImage: false }.

Using the properties property to configure the instances can be powerful, since it allows a single generator class to be used in different ways. However, it is very common to create non-configurable generator classes which require no properties to be set. For this reason, MXML lets you use the following syntax:

  <mx:List id="myList" itemRenderer="ProductRenderer">

The MXML compiler automatically creates the ClassFactory instance for you.

See also

mx.core.IFactory
mx.controls.List

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | generator : Class The Class that the newInstance() method uses to generate objects from this factory object. | ClassFactory
 | properties : Object = null An Object whose name/value pairs specify the properties to be set on each object generated by the newInstance() method. | ClassFactory
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ClassFactory(generator:Class = null) Constructor. | ClassFactory
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | newInstance():* Creates a new instance of the generator class, with the properties specified by properties. | ClassFactory
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
generator property
public var generator:Class

The Class that the newInstance() method uses to generate objects from this factory object.

properties property
public var properties:Object = null

An Object whose name/value pairs specify the properties to be set on each object generated by the newInstance() method.

For example, if you set properties to { text: "Hello", width: 100 }, then every instance of the generator class that is generated by calling newInstance() will have its text set to "Hello" and its width set to 100.

The default value is null.

Constructor detail
ClassFactory () constructor
public function ClassFactory(generator:Class = null)

Constructor.

Parameters
generator:Class (default = null) — The Class that the newInstance() method uses to generate objects from this factory object.
Method detail
newInstance () method
public function newInstance():*

Creates a new instance of the generator class, with the properties specified by properties.

This method implements the newInstance() method of the IFactory interface.

Returns
* — The new instance that was created.


mx.core.ComponentDescriptor (Flex™ 2 Language Reference)

Class ComponentDescriptor | Properties | Methods
Package | mx.core
Class | public class ComponentDescriptor
Inheritance | ComponentDescriptor Inheritance Object
Subclasses | UIComponentDescriptor

ComponentDescriptor is the base class for the UIComponentDescriptor class, which encapsulates the information that you specified in an MXML tag for an instance of a visual component. In Flex 2, non-visual components are treated differently and do not have descriptors, but in a future version the ComponentDescriptor base class may be used for them as well.

Most of the tags in an MXML file describe a tree of UIComponent objects. For example, the <mx:Application> tag represents a UIComponent object, and its child containers and controls are all UIComponent objects.

The MXML compiler compiles each of these MXML tags into a UIComponentDescriptor instance. To be precise, the MXML compiler autogenerates an ActionScript data structure which is a tree of UIComponentDescriptor objects.

At runtime, the createComponentsFromDescriptors() method of the Container class uses the information in the UIComponentDescriptor objects in the container's childDescriptors array to create the actual UIComponent objects that are the container's children, plus deeper descendants as well. Depending on the value of the container's creationPolicy, property, the descendants might be created at application startup, when some part of the component is about to become visible, or when the application developer manually calls the createComponentsFromDescriptors() method.

You do not typically create ComponentDescriptor or UIComponentDescriptor instances yourself; you can access the ones that the MXML compiler autogenerates, via the childDescriptors array of the Container class.

See also

mx.core.UIComponentDescriptor
mx.core.Container.childDescriptors
mx.core.Container.creationPolicy
mx.core.Container.createComponentsFromDescriptors()
Creating deferred components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | document : Object A reference to the document Object in which the component is to be created. | ComponentDescriptor
 | events : Object An Object containing name/value pairs for the component's event handlers, as specified in MXML. | ComponentDescriptor
 | id : String The identifier for the component, as specified in MXML. | ComponentDescriptor
 | properties : Object [read-only] An Object containing name/value pairs for the component's properties, as specified in MXML. | ComponentDescriptor
 | propertiesFactory : Function A Function that returns an Object containing name/value pairs for the component's properties, as specified in MXML. | ComponentDescriptor
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | type : Class The Class of the component, as specified in MXML. | ComponentDescriptor
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ComponentDescriptor(descriptorProperties:Object) Constructor | ComponentDescriptor
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | invalidateProperties():void Invalidates the cached properties property. | ComponentDescriptor
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns the string "ComponentDescriptor_" plus the value of the id property. | ComponentDescriptor
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
document property
public var document:Object

A reference to the document Object in which the component is to be created.

See also

mx.core.IUIComponent.document
events property
public var events:Object

An Object containing name/value pairs for the component's event handlers, as specified in MXML.

For example, if you write

   <mx:DataGrid id="dg" initialize="fetchData(); initDataGrid();"  change="changeHandler(event);"/>

then the descriptor's events property is the Object

   { initialize: "__dg_initialize", change: "__dg_change" }

The eventproperty is null if no MXML event handlers were specified for the component

The strings "__dg_initialize" and "__dg_change" are the names of event handler methods that the MXML compiler autogenerates. The body of these methods contain the ActionScript statements that you specified as the values of the event attributes. For example, the autogenerated initialize handler is

   public function __dg_initialize(event:mx.events.FlexEvent):void
   {
       fetchData();
       initDataGrid();
   }

You should not assume that the autogenerated event handlers will always be specified by name; this may change in a future version of Flex.

This property is used by the Container method createComponentsFromDescriptors() to register the autogenerated event handlers using the addEventListener() method.

id property
public var id:String

The identifier for the component, as specified in MXML.

For example, if you write

   <mx:TextInput id="firstName" text="Enter your first name here"/>

then the descriptor's id property is the String "firstName".

The id property is null if no MXML id was specified for the component.

The value of the id property becomes the name of a public variable in the MXML document object, autogenerated by the MXML compiler. The value of this variable is a reference to the UIComponent object created from this descriptor. This is why you can, for example, reference the TextInput control's text property as firstName.text from anywhere within the document containing this TextInput instance.

If an id is specified, and it isn't the empty string, it also becomes the name of the DisplayObject object. If an id is not specified or is empty, the DisplayObject object's name remains an autogenerated string, such as "Button3", as returned by the NameUtil.createUniqueName() method. The name is used in generating the string returned by the toString() method. It can also be used to find the component from its parent by calling getChildByName().

See also

flash.display.DisplayObject.name
properties property
properties:Object [read-only]

An Object containing name/value pairs for the component's properties, as specified in MXML.

For example, if you write

   <mx:TextInput width="150" text="Hello"/>

then the descriptor's properties property is the Object

   { width: 150, text: "Hello" }

The properties property is null if no MXML properties were specified for the component. In this case, the component will use default property values.

This Object is produced by calling the function specified by the propertiesFactory property, and then cached for subsequent access. However, when a Repeater produces multiple instances of a component from the same descriptor, a fresh copy of the properties Object should be produced for each component instance so that they don't share property values which are Arrays or Object references. The Repeater accomplishes this by calling the invalidateProperties() method on the descriptor.

Implementation
    public function get properties():Object

See also

propertiesFactory
invalidateProperties()
propertiesFactory property
public var propertiesFactory:Function

A Function that returns an Object containing name/value pairs for the component's properties, as specified in MXML.

For example, if you write

   <mx:TextInput width="150" text="Hello">

then the descriptor's propertiesFactory property is the Function:

   function():Object { return { width: 150, text: "Hello" }; }

The propertiesFactoryproperty is null if no MXML properties were specified for the component. In this case, the component will use default property values.

The reason that propertyFactory is a Function returning an Object rather than an actual Object is to allow the tree of ComponentDescriptor objects to "unfold" incrementally. If all the descriptors in the descriptor tree for the document were created at launch time, the time to launch would be greater.

The properties property returns a cached Object that was produced by this factory function.

Note: Event handlers such as click="doSomething();" appear in the events Object, not in the properties Object.

See also

properties
type property
public var type:Class

The Class of the component, as specified in MXML.

For example, if you write

   <mx:TextInput/>

then the descriptor's type property the Class mx.controls.TextInput.

The property is never null for the ComponentDescriptor objects created by the MXML compiler, because every MXML tag has a tag name such as mx:TextInput.

The mapping between an MXML tag and its corresponding class is determined by the XML namespace and the "manifest" file, if any, that is associated with that namespace. For example, the standard Flex namespace http://www.adobe.com/2006/mxml represented by the mx: prefix is associated (in the flex-config.xml file) with the manifest file mxml-manifest.xml, and this file has the tag

   <component id="TextInput" class="mx.controls.TextInput"/>

which maps the tag name mx:TextInput to the Class mx.controls.TextInput. Note that the use of a manifest file allows components in single XML namespace to map to classes in multiple ActionScript packages.

Constructor detail
ComponentDescriptor () constructor
public function ComponentDescriptor(descriptorProperties:Object)

Constructor

Parameters
descriptorProperties:Object — An Object containing name/value pairs for the properties of the ComponentDescriptor object, such as its type, id, propertiesFactory and events
Method detail
invalidateProperties () method
public function invalidateProperties():void

Invalidates the cached properties property. The next time you read the properties property, the properties are regenerated from the function specified by the value of the propertiesFactory property.

toString () method
public function toString():String

Returns the string "ComponentDescriptor_" plus the value of the id property.

Returns
String — The string "ComponentDescriptor_" plus the value of the id property.


mx.core.Container (Flex™ 2 Language Reference)

Class Container | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.core
Class | public class Container
Inheritance | Container Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IContainer, IDataRenderer, IFocusManagerContainer, IListItemRenderer, IRawChildrenContainer
Subclasses | Accordion, Application, Box, Canvas, Form, FormItem, Panel, Tile, ViewStack

The Container class is an abstract base class for components that controls the layout characteristics of child components. You do not create an instance of Container in an application. Instead, you create an instance of one of Container's subclasses, such as Canvas or HBox.

The Container class contains the logic for scrolling, clipping, and dynamic instantiation. It contains methods for adding and removing children. It also contains the getChildAt() method, and the logic for drawing the background and borders of containers.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax
Flex Framework containers inherit the following attributes from the Container class:

  <mx:tagname

    Properties
    autoLayout="true|false"
    clipContent="true|false"
    creationIndex="undefined"
    creationPolicy="auto|all|queued|none"
    defaultButton="No default"
    horizontalLineScrollSize="5"
    horizontalPageScrollSize="0"
    horizontalScrollBar="null"
    horizontalScrollPolicy="auto|on|off"
    horizontalScrollPosition="0"
    icon="undefined"
    label=""
    verticalLineScrollSize="5"
    verticalPageScrollSize="0"
    verticalScrollBar="null"
    verticalScrollPolicy="auto|on|off"
    verticalScrollPosition="0"

    Styles
    backgroundAlpha="1.0"
    backgroundAttachment="scroll"
    backgroundColor="undefined"
    backgroundDisabledColor="undefined"
    backgroundImage="undefined"
    backgroundSize="auto"
    barColor="undefined"
    borderColor="0xAAB3B3"
    borderSides="left top right bottom"
    borderSkin="mx.skins.halo.HaloBorder"
    borderStyle="inset"
    borderThickness="1"
    color="0x0B333C"
    cornerRadius="0"
    disabledColor="0xAAB3B3"
    disbledOverlayAlpha="undefined"
    dropShadowColor="0x000000"
    dropShadowEnabled="false"
    fontAntiAliasType="advanced"
    fontfamily="Verdana"
    fontGridFitType="pixel"
    fontSharpness="0""
    fontSize="10"
    fontStyle="normal"
    fontThickness="0"
    fontWeight="normal"
    horizontalScrollBarStyleName="undefined"
    paddingBottom="0"
    paddingLeft="0"
    paddingRight="0"
    paddingTop="0"
    shadowDirection="center"
    shadowDistance="2"
    textAlign="left"
    textDecoration="none|underline"
    textIndent="0"
    verticalScrollBarStyleName="undefined"

    Events
    childAdd="No default"
    childIndexChange="No default"
    childRemove="No default"
    dataChange="No default"
    scroll="No default"
    >
      ...
      child tags
      ...
  </mx:tagname>

See also

Using deferred creation
About the creationPolicy property
Creating deferred components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | autoLayout : Boolean If true, measurement and layout are done when the position or size of a child is changed. | Container
 | baselinePosition : Number [read-only] The vertical distance (in pixels) between the top of the container and the baseline of the first line of text. | Container
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
 | borderMetrics : EdgeMetrics [read-only] Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | Container
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
 | childDescriptors : Array [read-only] Array of UIComponentDescriptor objects produced by the MXML compiler. | Container
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
 | clipContent : Boolean Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. | Container
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contentMouseX : Number [read-only] Returns the x position of the mouse, in the content coordinate system. | Container
 | contentMouseY : Number [read-only] Returns the y position of the mouse, in the content coordinate system. | Container
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | creationIndex : int Specifies the order to instantiate and draw the children of the container. | Container
 | creationPolicy : String The child creation policy for this Container. | Container
Inherited | currentState : String The current view state of the component. | UIComponent
 | data : Object The data property lets you pass a value to the component when you use it in an item renderer or item editor. | Container
 | defaultButton : IFlexDisplayObject The Button control designated as the default button for the container. | Container
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | horizontalLineScrollSize : Number Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed. | Container
 | horizontalPageScrollSize : Number Number of pixels to move when the track in the horizontal scroll bar is pressed. | Container
 | horizontalScrollBar : ScrollBar The horizontal scrollbar used in this container. | Container
 | horizontalScrollPolicy : String Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. | Container
 | horizontalScrollPosition : Number The current position of the horizontal scroll bar. | Container
 | icon : Class The Class of the icon displayed by some navigator containers to represent this Container. | Container
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | label : String The text displayed by some navigator containers to represent this Container. | Container
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxHorizontalScrollPosition : Number [read-only] The largest possible value for the horizontalScrollPosition property. | Container
 | maxVerticalScrollPosition : Number [read-only] The largest possible value for the verticalScrollPosition property. | Container
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
 | numChildren : int [read-only] Number of child components in this container. | Container
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rawChildren : IChildList [read-only] A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. | Container
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | verticalLineScrollSize : Number Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed. | Container
 | verticalPageScrollSize : Number Number of pixels to scroll when the track in the vertical scroll bar is pressed. | Container
 | verticalScrollBar : ScrollBar The vertical scrollbar used in this container. | Container
 | verticalScrollPolicy : String Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. | Container
 | verticalScrollPosition : Number The current position of the vertical scroll bar. | Container
 | viewMetrics : EdgeMetrics [read-only] Returns an object that has four properties: left, top, right, and bottom. | Container
 | viewMetricsAndPadding : EdgeMetrics [read-only] Returns an object that has four properties: left, top, right, and bottom. | Container
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | actualCreationPolicy : String The creation policy of this container. | Container
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Container()
Constructor.
Container
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject to this Container.
Container
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this Container.
Container
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
Container
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
Container
createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
Container
createComponentsFromDescriptors(recurse:Boolean = true):void
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
Container
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
executeBindings(recurse:Boolean = false):void
Executes all the data bindings on this Container.
Container
executeChildBindings(recurse:Boolean):void
Executes the bindings into this Container's child UIComponent objects.
Container
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
getChildAt(index:int):DisplayObject
Gets the nth child component object.
Container
getChildByName(name:String):DisplayObject
Returns the child whose name property is the specified String.
Container
getChildIndex(child:DisplayObject):int
Gets the zero-based index of a specific child.
Container
getChildren():Array
Returns an Array of DisplayObject objects consisting of the content children of the container.
Container
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
Container
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
Container
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
removeAllChildren():void
Removes all children from the child list of this container.
Container
removeChild(child:DisplayObject):DisplayObject
Removes a child DisplayObject from the child list of this Container.
Container
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the child list of this Container at the specified index.
Container
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
setChildIndex(child:DisplayObject, newIndex:int):void
Sets the index of a particular child.
Container
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
 | attachOverlay():void Used internally by the Dissolve Effect to add the overlay to the chrome of a container. | Container
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
 | createBorder():void Creates the container's border skin if it is needed and does not already exist. | Container
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's borders. | Container
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | scrollChildren():void Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. | Container
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Respond to size changes by setting the positions and sizes of this container's children. | Container
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | childAdd | Dispatched after a child has been added to a container. | Container
 | childIndexChange | Dispatched after the index (among the container children) of a container child changes. | Container
 | childRemove | Dispatched before a child of a container is removed. | Container
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
 | dataChange | Dispatched when the data property changes. | Container
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | scroll | Dispatched when the user manually scrolls the container. | Container
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. Valid values range from 0.0 to 1.0. The default value is 1.0. 		Container
backgroundAttachment
Type: String CSS Inheritance: no
If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll"). The default value is "scroll". 		Container
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. You can have both a backgroundColor and a backgroundImage set. Some components do not have a background. The DataGrid control ignores this style. The default value is undefined, which means it is not set. If both this style and the backgroundImage style are undefined, the component has a transparent background.

For the Application container, this style specifies the background color while the application loads, and a background gradient while it is running. Flex calculates the gradient pattern between a color slightly darker than the specified color, and a color slightly lighter than the specified color.

The default skins of most Flex controls are partially transparent. As a result, the background color of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

Container
backgroundDisabledColor
Type: uint Format: Color CSS Inheritance: yes
Background color of the component when it is disabled. The global default value is undefined. The default value for List controls is 0xDDDDDD (light gray). If a Container is disabled, the background is dimmed, and the degree of dimming is controlled by the disabledOverlayAlpha style. 		Container
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. This can be an absolute or relative URL or class. You can either have both a backgroundColor and a backgroundImage set at the same time. The background image is displayed on top of the background color. The default value is undefined, meaning "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The default skins of most Flex controls are partially transparent. As a result, the background image of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

Container
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). The default value is "auto", which maintains the original size of the image. 		Container
barColor
Type: uint Format: Color CSS Inheritance: yes
Determines the color of a ProgressBar. A ProgressBar is filled with a vertical gradient between this color and a brighter color computed from it. This style has no effect on other components, but can be set on a container to control the appearance of all progress bars found within. The default value is undefined, which means it is not set. In this case, the themeColor style property is used. 		Container
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The default value depends on the component class; if not overridden for the class, the default value is 0xB7BABC. 		Container
borderSides
Type: String CSS Inheritance: no
Bounding box sides. A space-delimited String that specifies the sides of the border to show. The String can contain "left", "top", "right", and "bottom" in any order. The default value is "left top right bottom", which shows all four sides. This style is only used when borderStyle is "solid". 		Container
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. The default value is mx.skins.halo.HaloBorder. 		Container
borderStyle
Type: String CSS Inheritance: no
Bounding box style. The possible values are "none", "solid", "inset", and "outset". The default value depends on the component class; if not overridden for the class, the default value is "inset". The default value for most Containers is "none". 		Container
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. Only used when borderStyle is set to "solid". The default value is 1. 		Container
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		Container
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The default value depends on the component class; if not overriden for the class, the default value is 0. The default value for ApplicationControlBar is 5. 		Container
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		Container
disabledOverlayAlpha
Type: Number CSS Inheritance: no
The alpha value for the overlay that is placed on top of the container when it is disabled. 		Container
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. The default value is 0x000000. 		Container
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. This style is used with borderStyle="solid". The default value is false.

Note: For drop shadows to appear on containers, set backgroundColor or backgroundImage properties. Otherwise, the shadow appears behind the container because the default background of a container is transparent.

Container
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		Container
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		Container
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		Container
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		Container
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		Container
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		Container
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		Container
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		Container
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
horizontalScrollBarStyleName
Type: String CSS Inheritance: no
The name of the horizontal scrollbar style. The default value is undefined. 		Container
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
paddingBottom
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's bottom border and the bottom of its content area. The default value is 0. 		Container
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

Container
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

Container
paddingTop
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's top border and the top of its content area. The default value is 0. 		Container
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. Possible values are "left", "center", and "right". The default value is "center". 		Container
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. If the property is set to a negative value, the shadow appears above the component. The default value is 2. 		Container
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

Container
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		Container
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		Container
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
verticalScrollBarStyleName
Type: String CSS Inheritance: no
The name of the vertical scrollbar style. The default value is undefined. 		Container
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
actualCreationPolicy property
protected var actualCreationPolicy:String

The creation policy of this container. This property is useful when the container inherits its creation policy from its parent container.

autoLayout property
autoLayout:Boolean [read-write]

If true, measurement and layout are done when the position or size of a child is changed. If false, measurement and layout are done only once, when children are added to or removed from the container.

When using the Move effect, the layout around the component that is moving does not readjust to fit that the Move effect animates. Setting a container's autoLayout property to true has no effect on this behavior.

The Zoom effect does not work when the autoLayout property is false.

The autoLayout property does not apply to Accordion or ViewStack containers.

The default value is true.

Implementation
    public function get autoLayout():Boolean
    public function set autoLayout(value:Boolean):void
baselinePosition property
baselinePosition:Number [read-only]

The vertical distance (in pixels) between the top of the container and the baseline of the first line of text.

If the verticalAlign style is set to "top", then this property is equal to child.y + child.baselinePosition, where child is the View container's first child. If the verticalAlign style is set to "middle" or "bottom", then this property is equal to super.baselinePosition.

Implementation
    public function get baselinePosition():Number
borderMetrics property
borderMetrics:EdgeMetrics [read-only]

Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. The value of each property is equal to the thickness of one side of the border, expressed in pixels.

Unlike viewMetrics, this property is not overriden by subclasses of Container.

Implementation
    public function get borderMetrics():EdgeMetrics
childDescriptors property
childDescriptors:Array [read-only]

Array of UIComponentDescriptor objects produced by the MXML compiler.

Each UIComponentDescriptor object contains the information specified in one child MXML tag of the container's MXML tag. The order of the UIComponentDescriptor objects in the Array is the same as the order of the child tags. During initialization, the child descriptors are used to create the container's child UIComponent objects and its Repeater objects, and to give them the initial property values, event handlers, effects, and so on, that were specified in MXML.

Implementation
    public function get childDescriptors():Array

See also

mx.core.UIComponentDescriptor
clipContent property
clipContent:Boolean [read-write]

Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container. If false, the children of this container remain visible when they are moved or sized outside the borders of this container. If true, the children of this container are clipped.

If clipContent is false, then scrolling is disabled for this container and scrollbars will not appear. If clipContent is true, then scrollbars will usually appear when the container's children extend outside the border of the container. For additional control over the appearance of scrollbars, see horizontalScrollPolicy and verticalScrollPolicy.

The default value is true.

Implementation
    public function get clipContent():Boolean
    public function set clipContent(value:Boolean):void
contentMouseX property
contentMouseX:Number [read-only]

Returns the x position of the mouse, in the content coordinate system. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component.

Implementation
    public function get contentMouseX():Number
contentMouseY property
contentMouseY:Number [read-only]

Returns the y position of the mouse, in the content coordinate system. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component.

Implementation
    public function get contentMouseY():Number
creationIndex property
creationIndex:int [read-write]

Specifies the order to instantiate and draw the children of the container.

This property can only be used when the creationPolicy property is set to ContainerCreationPolicy.QUEUED. Otherwise, it is ignored.

The default value is -1.

Implementation
    public function get creationIndex():int
    public function set creationIndex(value:int):void
creationPolicy property
creationPolicy:String [read-write]

The child creation policy for this Container. ActionScript values can be ContainerCreationPolicy.AUTO, ContainerCreationPolicy.ALL, ContainerCreationPolicy.NONE, or ContainerCreationPolicy.QUEUED. MXML values can be "auto", "all", "none", or "queued".

If no creationPolicy is specified for a container, that container inherits its parent's creationPolicy. If no creationPolicy is specified for the Application, it defaults to ContainerCreationPolicy.AUTO.

A creationPolicy of ContainerCreationPolicy.AUTO means that the container delays creating some or all descendants until they are needed, a process which is known as deferred instantiation. This policy produces the best startup time because fewer UIComponents are created initially. However, this introduces navigation delays when a user navigates to other parts of the application for the first time. Navigator containers such as Accordion, TabNavigator, and ViewStack implement the ContainerCreationPolicy.AUTO policy by creating all their children immediately, but wait to create the deeper descendants of a child until it becomes the selected child of the navigator container.

A creationPolicy of ContainerCreationPolicy.ALL means that the navigator containers immediately create deeper descendants for each child, rather than waiting until that child is selected. For single-view containers such as a VBox container, there is no difference between the ContainerCreationPolicy.AUTO and ContainerCreationPolicy.ALL policies.

A creationPolicy of ContainerCreationPolicy.QUEUED means that the container is added to a creation queue rather than being immediately instantiated and drawn. When the application processes the queued container, it creates the children of the container and then waits until the children have been created before advancing to the next container in the creation queue.

A creationPolicy of ContainerCreationPolicy.NONE means that the container creates none of its children. In that case, it is the responsibility of the MXML author to create the children by calling the createComponentsFromDescriptors() method.

Implementation
    public function get creationPolicy():String
    public function set creationPolicy(value:String):void
data property
data:Object [read-write]

The data property lets you pass a value to the component when you use it in an item renderer or item editor. You typically use data binding to bind a field of the data property to a property of this component.

You do not set this property in MXML.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get data():Object
    public function set data(value:Object):void

See also

mx.core.IDataRenderer
defaultButton property
defaultButton:IFlexDisplayObject [read-write]

The Button control designated as the default button for the container. When controls in the container have focus, pressing the Enter key is the same as clicking this Button control.

The default value is null.

Implementation
    public function get defaultButton():IFlexDisplayObject
    public function set defaultButton(value:IFlexDisplayObject):void
horizontalLineScrollSize property
horizontalLineScrollSize:Number [read-write]

Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed.

The default value is 5.

This property can be used as the source for data binding.

Implementation
    public function get horizontalLineScrollSize():Number
    public function set horizontalLineScrollSize(value:Number):void
horizontalPageScrollSize property
horizontalPageScrollSize:Number [read-write]

Number of pixels to move when the track in the horizontal scroll bar is pressed. A value of 0 means that the page size will be calculated to be a full screen.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get horizontalPageScrollSize():Number
    public function set horizontalPageScrollSize(value:Number):void
horizontalScrollBar property
horizontalScrollBar:ScrollBar [read-write]

The horizontal scrollbar used in this container. This property is null if no horizontal scroll bar is currently displayed. In general you do not access this property directly. Manipulation of the horizontalScrollPolicy and horizontalScrollPosition properties should provide sufficient control over the scroll bar.

Implementation
    public function get horizontalScrollBar():ScrollBar
    public function set horizontalScrollBar(value:ScrollBar):void
horizontalScrollPolicy property
horizontalScrollPolicy:String [read-write]

Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed. ActionScript values can be ScrollPolicy.ON, ScrollPolicy.OFF, and ScrollPolicy.AUTO. MXML values can be "on", "off", and "auto".

Setting this property to ScrollPolicy.OFF also prevents the horizontalScrollPosition property from having an effect.

Note: This property does not apply to the ControlBar container.

If the horizontalScrollPolicy is ScrollPolicy.AUTO, the horizontal scroll bar appears when all of the following are true:

  • One of the container's children extends beyond the left edge or right edge of the container.
  • The clipContent property is true.
  • The width and height of the container are large enough to reasonably accommodate a scroll bar.

The default value is ScrollPolicy.AUTO.

This property can be used as the source for data binding.

Implementation
    public function get horizontalScrollPolicy():String
    public function set horizontalScrollPolicy(value:String):void
horizontalScrollPosition property
horizontalScrollPosition:Number [read-write]

The current position of the horizontal scroll bar. This is equal to the distance in pixels between the left edge of the scrollable surface and the leftmost piece of the surface that is currently visible.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get horizontalScrollPosition():Number
    public function set horizontalScrollPosition(value:Number):void
icon property
icon:Class [read-write]

The Class of the icon displayed by some navigator containers to represent this Container.

For example, if this Container is a child of a TabNavigator, this icon appears in the corresponding tab. If this Container is a child of an Accordion, this icon appears in the corresponding header.

To embed the icon in the SWF file, use the @Embed() MXML compiler directive:

     icon="@Embed('filepath')"

The image can be a JPEG, GIF, PNG, SVG, or SWF file.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get icon():Class
    public function set icon(value:Class):void
label property
label:String [read-write]

The text displayed by some navigator containers to represent this Container.

For example, if this Container is a child of a TabNavigator, this string appears in the corresponding tab. If this Container is a child of an Accordion, this string appears in the corresponding header.

The default value is "".

This property can be used as the source for data binding.

Implementation
    public function get label():String
    public function set label(value:String):void
maxHorizontalScrollPosition property
maxHorizontalScrollPosition:Number [read-only]

The largest possible value for the horizontalScrollPosition property. Defaults to 0 if the horizontal scrollbar is not present.

Implementation
    public function get maxHorizontalScrollPosition():Number
maxVerticalScrollPosition property
maxVerticalScrollPosition:Number [read-only]

The largest possible value for the verticalScrollPosition property. Defaults to 0 if the vertical scrollbar is not present.

Implementation
    public function get maxVerticalScrollPosition():Number
numChildren property
numChildren:int [read-only]

Number of child components in this container.

The number of children is initially equal to the number of children declared in MXML. At runtime, new children may be added by calling addChild() or addChildAt(), and existing children may be removed by calling removeChild(), removeChildAt(), or removeAllChildren().

Implementation
    public function get numChildren():int
rawChildren property
rawChildren:IChildList [read-only]

A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property. In addition, the container may contain style elements and skins, such as the border and background. The Flash Player does not draw any distinction between child components and skins. They are all accessible using the Player's getChildAt() method and numChildren property. However, the Container class overrides the getChildAt() method and numChildren property (and several other methods) to create the illusion that the container's children are the only child components.

If you need to access all of the children of the container (both the content children and the skins), then use the methods and properties on the rawChildren property instead of the regular Container methods. For example, use the Container.rawChildren.getChildAt()) method. However, if a container creates a ContentPane Sprite object for its children, the rawChildren property value only counts the ContentPane, not the container's children. It is not always possible to determine when a container will have a ContentPane.

Note:If you call the addChild or addChildAtmethod of the rawChildren object, set tabEnabled=false on the component that you have added. Doing so prevents users from tabbing to the visual-only component that you have added.

Implementation
    public function get rawChildren():IChildList
verticalLineScrollSize property
verticalLineScrollSize:Number [read-write]

Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed.

The default value is 5.

This property can be used as the source for data binding.

Implementation
    public function get verticalLineScrollSize():Number
    public function set verticalLineScrollSize(value:Number):void
verticalPageScrollSize property
verticalPageScrollSize:Number [read-write]

Number of pixels to scroll when the track in the vertical scroll bar is pressed. A value of 0 means that the page size will be calculated to be a full screen.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get verticalPageScrollSize():Number
    public function set verticalPageScrollSize(value:Number):void
verticalScrollBar property
verticalScrollBar:ScrollBar [read-write]

The vertical scrollbar used in this container. This property is null if no vertical scroll bar is currently displayed. In general you do not access this property directly. Manipulation of the verticalScrollPolicy and verticalScrollPosition properties should provide sufficient control over the scroll bar.

Implementation
    public function get verticalScrollBar():ScrollBar
    public function set verticalScrollBar(value:ScrollBar):void
verticalScrollPolicy property
verticalScrollPolicy:String [read-write]

Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed. Possible values are ScrollPolicy.ON, ScrollPolicy.OFF, and ScrollPolicy.AUTO. MXML values can be "on", "off", and "auto".

Setting this property to ScrollPolicy.OFF also prevents the verticalScrollPosition property from having an effect.

Note: This property does not apply to the ControlBar container.

If the verticalScrollPolicy is ScrollPolicy.AUTO, the vertical scroll bar appears when all of the following are true:

  • One of the container's children extends beyond the top edge or bottom edge of the container.
  • The clipContent property is true.
  • The width and height of the container are large enough to reasonably accommodate a scroll bar.

The default value is ScrollPolicy.AUTO.

This property can be used as the source for data binding.

Implementation
    public function get verticalScrollPolicy():String
    public function set verticalScrollPolicy(value:String):void
verticalScrollPosition property
verticalScrollPosition:Number [read-write]

The current position of the vertical scroll bar. This is equal to the distance in pixels between the top edge of the scrollable surface and the topmost piece of the surface that is currently visible.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get verticalScrollPosition():Number
    public function set verticalScrollPosition(value:Number):void
viewMetrics property
viewMetrics:EdgeMetrics [read-only]

Returns an object that has four properties: left, top, right, and bottom. The value of each property equals the thickness of the chrome (visual elements) around the edge of the container.

The chrome includes the border thickness. If the horizontalScrollPolicy or verticalScrollPolicy property value is ScrollPolicy.ON, the chrome also includes the thickness of the corresponding scroll bar. If a scroll policy is ScrollPolicy.AUTO, the chrome measurement does not include the scroll bar thickness, even if a scroll bar is displayed.

Subclasses of Container should override this method, so that they include other chrome to be taken into account when positioning the Container's children. For example, the viewMetrics property for the Panel class should return an object whose top property includes the thickness of the Panel container's title bar.

Implementation
    public function get viewMetrics():EdgeMetrics
viewMetricsAndPadding property
viewMetricsAndPadding:EdgeMetrics [read-only]

Returns an object that has four properties: left, top, right, and bottom. The value of each property is equal to the thickness of the chrome (visual elements) around the edge of the container plus the thickness of the object's margins.

The chrome includes the border thickness. If the horizontalScrollPolicy or verticalScrollPolicy property value is ScrollPolicy.ON, the chrome also includes the thickness of the corresponding scroll bar. If a scroll policy is ScrollPolicy.AUTO, the chrome measurement does not include the scroll bar thickness, even if a scroll bar is displayed.

Implementation
    public function get viewMetricsAndPadding():EdgeMetrics
Constructor detail
Container () constructor
public function Container()

Constructor.

Method detail
addChild () method
public override function addChild(child:DisplayObject):DisplayObject

Adds a child DisplayObject to this Container. The child is added after other existing children, so that the first child added has index 0, the next has index 1, an so on.

Note: While the child argument to the method is specified as of type DisplayObject, the argument must implement the IUIComponent interface to be added as a child of a container. All Flex components implement this interface.

Children are layered from back to front. In other words, if children overlap, the one with index 0 is farthest to the back, and the one with index numChildren - 1 is frontmost. This means the newly added children are layered in front of existing children.

Parameters
child:DisplayObject — The DisplayObject to add as a child of this Container. It must implement the IUIComponent interface.

Returns
DisplayObject — The added child as an object of type DisplayObject. You typically cast the return value to UIComponent, or to the type of the added component.

See also

mx.core.IUIComponent
Defining a method override
addChildAt () method
public override function addChildAt(child:DisplayObject, index:int):DisplayObject

Adds a child DisplayObject to this Container. The child is added at the index specified.

Note: While the child argument to the method is specified as of type DisplayObject, the argument must implement the IUIComponent interface to be added as a child of a container. All Flex components implement this interface.

Children are layered from back to front. In other words, if children overlap, the one with index 0 is farthest to the back, and the one with index numChildren - 1 is frontmost. This means the newly added children are layered in front of existing children.

When you add a new child at an index that is already occupied by an old child, it doesn't replace the old child; instead the old child and the ones after it "slide over" and have their index incremented by one. For example, suppose a Container contains the children (A, B, C) and you add D at index 1. Then the container will contain (A, D, B, C). If you want to replace an old child, you must first remove it before adding the new one.

Parameters
child:DisplayObject — The DisplayObject to add as a child of this Container. It must implement the IUIComponent interface.
index:int — The index to add the child at.

Returns
DisplayObject — The added child as an object of type DisplayObject. You typically cast the return value to UIComponent, or to the type of the added component.

See also

mx.core.IUIComponent
attachOverlay () method
protected override function attachOverlay():void

Used internally by the Dissolve Effect to add the overlay to the chrome of a container.

contentToGlobal () method
public override function contentToGlobal(point:Point):Point

Converts a Point object from content coordinates to global coordinates. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning. Global coordinates specify a pixel position relative to the upper-left corner of the Stage in Flash Player, that is, the outermost edge of the application.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the content coordinate system as properties.

Returns
Point — A Point object with coordinates relative to the Stage.
contentToLocal () method
public override function contentToLocal(point:Point):Point

Converts a Point object from content to local coordinates. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning. Local coordinates specify a pixel position relative to the upper left corner of the component.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the content coordinate system as properties.

Returns
Point — Point A Point object with coordinates relative to the local coordinate system.
createBorder () method
protected function createBorder():void

Creates the container's border skin if it is needed and does not already exist.

createComponentFromDescriptor () method
public function createComponentFromDescriptor(descriptor:ComponentDescriptor, recurse:Boolean):IFlexDisplayObject

Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.

This method instantiates the new object but does not add it to the display list, so the object does not appear on the screen by default. To add the new object to the display list, call the validateNow() method on the container after calling the createComponentFromDescriptor() method, as the following example shows:

      myVBox.createComponentFromDescriptor(myVBox.childDescriptors[0],false);
      myVBox.validateNow();

Alternatively, you can call the createComponentsFromDescriptors() method on the container to create all components at one time. You are not required to call the validateNow() method after calling the createComponentsFromDescriptors() method.

Parameters
descriptor:ComponentDescriptor — The UIComponentDescriptor for the component to be created. This argument is either a UIComponentDescriptor object or the index of one of the container's children (an integer between 0 and n-1, where n is the total number of children of this container).
recurse:Boolean — If false, create this component but none of its children. If true, after creating the component, Flex calls the createComponentsFromDescriptors() method to create all or some of its children, based on the value of the component's creationPolicy property.

Returns
IFlexDisplayObject

See also

mx.core.UIComponentDescriptor
createComponentsFromDescriptors () method
public function createComponentsFromDescriptors(recurse:Boolean = true):void

Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.

If the value of the container's creationPolicy property is ContainerCreationPolicy.ALL, then this method is called automatically during the initialization sequence.

If the value of the container's creationPolicy is ContainerCreationPolicy.AUTO, then this method is called automatically when the container's children are about to become visible.

If the value of the container's creationPolicy property is ContainerCreationPolicy.NONE, then you should call this function when you want to create this container's children.

Parameters
recurse:Boolean (default = true) — If true, recursively create components.
executeBindings () method
public override function executeBindings(recurse:Boolean = false):void

Executes all the data bindings on this Container. Flex calls this method automatically once a Container has been created to cause any data bindings that have destinations inside of it to execute.

Parameters
recurse:Boolean (default = false)
executeChildBindings () method
public function executeChildBindings(recurse:Boolean):void

Executes the bindings into this Container's child UIComponent objects. Flex calls this method automatically once a Container has been created.

Parameters
recurse:Boolean — If false, then only execute the bindings on the immediate children of this Container. If true, then also execute the bindings on this container's grandchildren, great-grandchildren, and so on.
getChildAt () method
public override function getChildAt(index:int):DisplayObject

Gets the nth child component object.

The children returned from this method include children that are declared in MXML and children that are added using the addChild() or addChildAt() method.

Parameters
index:int — Number from 0 to (numChildren - 1).

Returns
DisplayObject — Reference to the child as an object of type DisplayObject. You typically cast the return value to UIComponent, or to the type of a specific Flex control, such as ComboBox or TextArea.
getChildByName () method
public override function getChildByName(name:String):DisplayObject

Returns the child whose name property is the specified String.

Parameters
name:String — The identifier of the child.

Returns
DisplayObject — The DisplayObject representing the child as an object of type DisplayObject. You typically cast the return value to UIComponent, or to the type of a specific Flex control, such as ComboBox or TextArea.
getChildIndex () method
public override function getChildIndex(child:DisplayObject):int

Gets the zero-based index of a specific child.

The first child of the container (i.e.: the first child tag that appears in the MXML declaration) has an index of 0, the second child has an index of 1, and so on. The indexes of a container's children determine the order in which they get laid out. For example, in a VBox the child with index 0 is at the top, the child with index 1 is below it, etc.

If you add a child by calling the addChild() method, the new child's index is equal to the largest index among existing children plus one. You can insert a child at a specified index by using the addChildAt() method; in that case the indices of the child previously at that index, and the children at higher indices, all have their index increased by 1 so that all indices fall in the range from 0 to (numChildren - 1).

If you remove a child by calling removeChild() or removeChildAt() method, then the indices of the remaining children are adjusted so that all indices fall in the range from 0 to (numChildren - 1).

If myView.getChildIndex(myChild) returns 5, then myView.getChildAt(5) returns myChild.

The index of a child may be changed by calling the setChildIndex() method.

Parameters
child:DisplayObject — Reference to child whose index to get.

Returns
int — Number between 0 and (numChildren - 1).
getChildren () method
public function getChildren():Array

Returns an Array of DisplayObject objects consisting of the content children of the container. This array does not include the DisplayObjects that implement the container's display elements, such as its border and the background image.

Returns
Array — Array of DisplayObject objects consisting of the content children of the container.

See also

rawChildren
globalToContent () method
public override function globalToContent(point:Point):Point

Converts a Point object from global to content coordinates. Global coordinates specify a pixel position relative to the upper-left corner of the Stage in Flash Player, that is, the outermost edge of the application. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the global (Stage) coordinate system as properties.

Returns
Point — Point A Point object with coordinates relative to the component.
layoutChrome () method
protected function layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void

Respond to size changes by setting the positions and sizes of this container's borders. This is an advanced method that you might override when creating a subclass of Container.

Flex calls the layoutChrome() method when the container is added to a parent container using the addChild() method, and when the container's invalidateDisplayList() method is called.

The Container.layoutChrome() method is called regardless of the value of the autoLayout property.

The Container.layoutChrome() method sets the position and size of the Container container's border. In every subclass of Container, the subclass's layoutChrome() method should call the super.layoutChrome() method, so that the border is positioned properly.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

Implementing the layoutChrome() method
localToContent () method
public override function localToContent(point:Point):Point

Converts a Point object from local to content coordinates. Local coordinates specify a pixel position relative to the upper left corner of the component. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the local coordinate system as properties.

Returns
Point — Point A Point object with coordinates relative to the content coordinate system.
removeAllChildren () method
public function removeAllChildren():void

Removes all children from the child list of this container.

removeChild () method
public override function removeChild(child:DisplayObject):DisplayObject

Removes a child DisplayObject from the child list of this Container. The removed child will have its parent property set to null. The child will still exist unless explicitly destroyed. If you add it to another container, it will retain its last known state.

Parameters
child:DisplayObject — The DisplayObject to remove.

Returns
DisplayObject — The removed child as an object of type DisplayObject. You typically cast the return value to UIComponent, or to the type of the removed component.
removeChildAt () method
public override function removeChildAt(index:int):DisplayObject

Removes a child DisplayObject from the child list of this Container at the specified index. The removed child will have its parent property set to null. The child will still exist unless explicitly destroyed. If you add it to another container, it will retain its last known state.

Parameters
index:int — The child index of the DisplayObject to remove.

Returns
DisplayObject — The removed child as an object of type DisplayObject. You typically cast the return value to UIComponent, or to the type of the removed component.
scrollChildren () method
protected function scrollChildren():void

Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties. Content that doesn't appear in the viewable area gets clipped. This method should be overridden by subclasses that have scrollable chrome in the content area.

setChildIndex () method
public override function setChildIndex(child:DisplayObject, newIndex:int):void

Sets the index of a particular child. See the getChildIndex() method for a description of the child's index.

Parameters
child:DisplayObject — Reference to child whose index to set.
newIndex:int — Number that indicates the new index. Must be an integer between 0 and (numChildren - 1).
updateDisplayList () method
protected override function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Respond to size changes by setting the positions and sizes of this container's children.

See the UIComponent.updateDisplayList() method for more information about the updateDisplayList() method.

The Container.updateDisplayList() method sets the position and size of the Container container's border. In every subclass of Container, the subclass's updateDisplayList() method should call the super.updateDisplayList() method, so that the border is positioned properly.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

mx.core.UIComponent
Event detail
childAdd event
Event object type: mx.events.ChildExistenceChangedEvent
ChildExistenceChangedEvent.type property = mx.events.ChildExistenceChangedEvent.CHILD_ADD

Dispatched after a child has been added to a container.

The childAdd event is dispatched when the addChild() or addChildAt() method is called. When a container is first created, the addChild() method is automatically called for each child component declared in the MXML file. The addChildAt() method is automatically called whenever a Repeater object adds or removes child objects. The application developer may also manually call these methods to add new children.

At the time when this event is sent, the child object has been initialized, but its width and height have not yet been calculated, and the child has not been drawn on the screen. If you want to be notified when the child has been fully initialized and rendered, then register as a listener for the child's creationComplete event.

The ChildExistenceChangedEvent.CHILD_ADD constant defines the value of the type property of the event object for a childAdd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
relatedObject | Contains a reference to the child object that was created.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
childIndexChange event
Event object type: mx.events.IndexChangedEvent
IndexChangedEvent.type property = mx.events.IndexChangedEvent.CHILD_INDEX_CHANGE

Dispatched after the index (among the container children) of a container child changes. This event is only dispatched for the child specified as the argument to the setChildIndex() method; it is not dispatched for any other child whose index changes as a side effect of the call to the setChildIndex() method.

The child's index is changed when the setChildIndex() method is called.

The IndexChangedEvent.CHILD_INDEX_CHANGE constant defines the value of the type property of the event object for a childIndexChange event, which indicates that a component's index among a container's children has changed.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
inputType | Indicates whether this event was caused by a mouse or keyboard interaction.
newIndex | The zero-based index of the child after the change.
oldIndex | The zero-based index of the child before the change.
relatedObject | Contains a reference to the child object whose index changed.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TriggerEvent | null
Type | IndexChangedEvent.CHILD_INDEX_CHANGE
childRemove event
Event object type: mx.events.ChildExistenceChangedEvent
ChildExistenceChangedEvent.type property = mx.events.ChildExistenceChangedEvent.CHILD_REMOVE

Dispatched before a child of a container is removed.

This event is delivered when any of the following methods is called: removeChild(), removeChildAt(), or removeAllChildren().

The ChildExistenceChangedEvent.CHILD_REMOVE constant defines the value of the type property of the event object for a childRemove event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
relatedObject | Contains a reference to the child object that is about to be removed.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
dataChange event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.DATA_CHANGE

Dispatched when the data property changes.

When a container is used as a renderer in a List or other components, the data property is used pass to the container the data to display.

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
scroll event
Event object type: mx.events.ScrollEvent
ScrollEvent.type property = mx.events.ScrollEvent.SCROLL

Dispatched when the user manually scrolls the container.

The event is dispatched when the scroll position is changed using either the mouse (e.g. clicking on the scrollbar's "down" button) or the keyboard (e.g., clicking on the down-arrow key). However, this event is not dispatched if the scroll position is changed programatically (e.g., setting the value of the horizontalScrollPosition property). The viewChanged event is delivered whenever the scroll position is changed, either manually or programatically.

At the time when this event is dispatched, the scrollbar has been updated to the new position, but the container's child objects have not been shifted to reflect the new scroll position.

The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the change in scroll position, expressed in pixels. A positive value indicates the scroll was down or to the right. A negative value indicates the scroll was up or to the left.
direction | Contains the scroll direction, either ScrollEventDirection.HORIZONTAL or ScrollEventDirection.VERTICAL.
position | Contains the new scroll position.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.core.ContainerCreationPolicy (Flex™ 2 Language Reference)

Class ContainerCreationPolicy | Properties | Methods | Constants
Package | mx.core
Class | public final class ContainerCreationPolicy
Inheritance | ContainerCreationPolicy Inheritance Object

The ContainerCreationPolicy class defines the constant values for the creationPolicy property of the Container class.

See also

mx.core.Container.creationPolicy

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ALL : String = "all" [static] Immediately create all descendants. | ContainerCreationPolicy
 | AUTO : String = "auto" [static] Delay creating some or all descendants until they are needed. | ContainerCreationPolicy
 | NONE : String = "none" [static] Do not create any children. | ContainerCreationPolicy
 | QUEUED : String = "queued" [static] Add the container to a creation queue. | ContainerCreationPolicy
Constant detail
ALL constant
public static const ALL:String = "all"

Immediately create all descendants.

Avoid using this creationPolicy because it increases the startup time of your application. There is usually no good reason to create components at startup which the user cannot see. If you are using this policy so that you can "push" data into hidden components at startup, you should instead design your application so that the data is stored in data variables and components which are created later "pull" in this data, via databinding or an initialize handler.

AUTO constant
public static const AUTO:String = "auto"

Delay creating some or all descendants until they are needed.

For example, if a navigator container such as a TabNavigator has this creationPolicy, it will immediately create all of its children, plus the descendants of the initially selected child. However, it will wait to create the descendants of the other children until the user navigates to them.

NONE constant
public static const NONE:String = "none"

Do not create any children.

With this creationPolicy, it is the developer's responsibility to programmatically create the children from the UIComponentDescriptors by calling createComponentsFromDescriptors() on the parent container.

QUEUED constant
public static const QUEUED:String = "queued"

Add the container to a creation queue.


mx.core.ContainerLayout (Flex™ 2 Language Reference)

Class ContainerLayout | Properties | Methods | Constants
Package | mx.core
Class | public final class ContainerLayout
Inheritance | ContainerLayout Inheritance Object

The ContainerLayout class defines the constant values for the layout property of container classes.

See also

mx.containers.Panel.layout
mx.core.Application.layout

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ABSOLUTE : String = "absolute" [static] Use absolute layout for the contents of this container. | ContainerLayout
 | HORIZONTAL : String = "horizontal" [static] Use horizontal layout for the contents of this container. | ContainerLayout
 | VERTICAL : String = "vertical" [static] Use vertical layout for the contents of this container. | ContainerLayout
Constant detail
ABSOLUTE constant
public static const ABSOLUTE:String = "absolute"

Use absolute layout for the contents of this container. You are responsible for explicitly specifying the position of each child.

The easiest way to do this is to specify the x, y, width, and height of each child.

The width and height can be specified as a percentage value in MXML. (In ActionScript you have to set the percentWidth and percentHeight properties.)

If you don't specify the width or percentWidth for a child, then its measuredWidth, as automatically determined by its measure() method, will be used. The same applies for its height.

As an alternative way of doing layout, you can use the anchor styles left, top, right , bottom, horizontalCenter, and verticalCenter on children to anchor them to the sides or the center of a container.

When you use absolute layout, the container's paddingLeft, paddingTop, paddingRight, paddingBottom, horizontalGap, verticalGap, horizontalAlign, andverticalAlign styles are ignored.

HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

Use horizontal layout for the contents of this container. The container will automatically place its children in a single row.

If you don't specify the width or percentWidth for a child, then its measuredWidth, as automatically determined by its measure() method, is used. The same applies for its height.

You can control the spacing between children with the horizontalGap style, and the alignment of the children with the verticalAlign style. The paddingLeft, paddingTop, paddingRight, and paddingBottom styles control the space between the border of the container and the children.

VERTICAL constant
public static const VERTICAL:String = "vertical"

Use vertical layout for the contents of this container. The container will automatically place its children in a single column.

If you don't specify the width or percentWidth for a child, then its measuredWidth, as automatically determined by its measure() method, is used. The same applies for its height.

You can control the spacing between children with the verticalGap style, and the alignment of the children with the horizontalAlign style. The paddingLeft, paddingTop, paddingRight, and paddingBottom styles control the space between the border of the container and the children.


mx.core.DeferredInstanceFromClass (Flex™ 2 Language Reference)

Class DeferredInstanceFromClass | Properties | Methods
Package | mx.core
Class | public class DeferredInstanceFromClass
Inheritance | DeferredInstanceFromClass Inheritance Object
Implements | IDeferredInstance

A deferred instance factory that creates and returns an instance of a specified class. An application can use the getInstance() method to create an instance of the class when it is first needed and get a reference to the instance thereafter.

See also

DeferredInstanceFromFunction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DeferredInstanceFromClass(generator:Class) Constructor. | DeferredInstanceFromClass
 | getInstance():Object Creates and returns an instance of the class specified in the DeferredInstanceFromClass constructor, if it does not yet exist; otherwise, returns the already-created class instance. | DeferredInstanceFromClass
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
DeferredInstanceFromClass () constructor
public function DeferredInstanceFromClass(generator:Class)

Constructor.

Parameters
generator:Class — The class whose instance the getInstance() method creates and returns.
Method detail
getInstance () method
public function getInstance():Object

Creates and returns an instance of the class specified in the DeferredInstanceFromClass constructor, if it does not yet exist; otherwise, returns the already-created class instance.

Returns
Object — An instance of the class specified in the DeferredInstanceFromClass constructor.


mx.core.DeferredInstanceFromFunction (Flex™ 2 Language Reference)

Class DeferredInstanceFromFunction | Properties | Methods
Package | mx.core
Class | public class DeferredInstanceFromFunction
Inheritance | DeferredInstanceFromFunction Inheritance Object
Implements | IDeferredInstance

A deferred instance factory that uses a generator function to create an instance of the required object. An application uses the getInstance() method to create an instance of an object when it is first needed and get a reference to the object thereafter.

See also

DeferredInstanceFromClass

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DeferredInstanceFromFunction(generator:Function) Constructor. | DeferredInstanceFromFunction
 | getInstance():Object Returns a reference to an instance of the desired object. | DeferredInstanceFromFunction
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
DeferredInstanceFromFunction () constructor
public function DeferredInstanceFromFunction(generator:Function)

Constructor.

Parameters
generator:Function — A function that creates and returns an instance of the required object.
Method detail
getInstance () method
public function getInstance():Object

Returns a reference to an instance of the desired object. If no instance of the required object exists, calls the function specified in this class' generator constructor parameter.

Returns
Object — An instance of the object.


mx.core.DragSource (Flex™ 2 Language Reference)

Class DragSource | Properties | Methods
Package | mx.core
Class | public class DragSource
Inheritance | DragSource Inheritance Object

The DragSource class contains the data being dragged. The data can be in multiple formats. For example, a Text component may have plain text, rich text and HTML data.

Each format of data is identified with a string. The hasFormat() method is used to determine if the object has data in that format. The dataForFormat() method is used to retrieve the data in the specified format.

Data can be added directly using the addData() method, or indirectly using the addHandler() method. The addHandler() method registers a callback that will be called if the data is requested. This is useful for adding data in a non-native format that may require large computations or conversions. For example, if you have raw sound data you can add an MP3 format handler. The MP3 conversion will only be done if the MP3 data is requested.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | formats : Array [read-only] Contains the formats of the drag data, as an Array of Strings. | DragSource
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DragSource() Constructor. | DragSource
 | addData(data:Object, format:String):void Adds data and a corresponding format String to the drag source. | DragSource
 | addHandler(handler:Function, format:String):void Adds a handler that is called when data for the specified format is requested. | DragSource
 | dataForFormat(format:String):Object Retrieves the data for the specified format. | DragSource
 | hasFormat(format:String):Boolean Returns true if the data source contains the requested format; otherwise, it returns false. | DragSource
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
formats property
formats:Array [read-only]

Contains the formats of the drag data, as an Array of Strings. Set this property using the addData() or addHandler() methods. The default value depends on data added to the DragSource object.

Implementation
    public function get formats():Array
Constructor detail
DragSource () constructor
public function DragSource()

Constructor.

Method detail
addData () method
public function addData(data:Object, format:String):void

Adds data and a corresponding format String to the drag source. This method does not return a value.

Parameters
data:Object — Object that specifies the drag data. This can be any object, such as a String, a DataProvider, and so on.
format:String — String that specifies a label that describes the format for this data.
addHandler () method
public function addHandler(handler:Function, format:String):void

Adds a handler that is called when data for the specified format is requested. This is useful when dragging large amounts of data. The handler is only called if the data is requested. This method does not return a value.

Parameters
handler:Function — Function that specifies the handler called to request the data. This function must return the data in the specified format.
format:String — String that specifies the format for this data.
dataForFormat () method
public function dataForFormat(format:String):Object

Retrieves the data for the specified format. If the data was added with the addData() method, it is returned directly. If the data was added with the addHandler() method, the handler function is called to return the data.

Parameters
format:String — String that specifies a label that describes the format for the data to return.

Returns
Object — An Object containing the data in the requested format. If you drag multiple items, the returned value is an Array. For a list control, the returned value is always an Array, even if it contains a single item.
hasFormat () method
public function hasFormat(format:String):Boolean

Returns true if the data source contains the requested format; otherwise, it returns false.

Parameters
format:String — String that specifies a label that describes the format for the data.

Returns
Boolean — true if the data source contains the requested format.


mx.core.EdgeMetrics (Flex™ 2 Language Reference)

Class EdgeMetrics | Properties | Methods
Package | mx.core
Class | public class EdgeMetrics
Inheritance | EdgeMetrics Inheritance Object

The EdgeMetrics class specifies the thickness, in pixels, of the four edge regions around a visual component.

The following Flex properties have values that are EdgeMetrics objects:

  • The borderMetrics property of the mx.core.Container and mx.skins.Border classes includes only the border in the calculations of the property values of the EdgeMetrics object.
  • The viewMetrics property of the mx.core.Container class, and of subclasses of the Container class, includes possible scrollbars and non-content elements -- such as a Panel container's header area and the area for a ControlBar component -- in the calculations of the property values of the EdgeMetrics object.
  • The viewMetricsAndPadding property of the mx.core.Container class includes the items listed for the viewMetrics property, plus the any areas defined by the margins of the container in the calculations of the property values of the EdgeMetrics object.

These three properites all return a reference to the same EdgeMetrics object that the Container is using for its measurement and layout; they do not return a copy of this object. If you need a copy, call the clone() method.

See also

mx.core.Container
mx.skins.Border
mx.containers.Panel

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bottom : Number The height, in pixels, of the bottom edge region. | EdgeMetrics
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | EMPTY : EdgeMetrics [static] An EdgeMetrics object with a value of zero for its left, top, right, and bottom properties. | EdgeMetrics
 | left : Number The width, in pixels, of the left edge region. | EdgeMetrics
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | right : Number The width, in pixels, of the right edge region. | EdgeMetrics
 | top : Number The height, in pixels, of the top edge region. | EdgeMetrics
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | EdgeMetrics(left:Number = 0, top:Number = 0, right:Number = 0, bottom:Number = 0) Constructor. | EdgeMetrics
 | clone():EdgeMetrics Returns a copy of this EdgeMetrics object. | EdgeMetrics
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
bottom property
public var bottom:Number

The height, in pixels, of the bottom edge region.

EMPTY property
public static var EMPTY:EdgeMetrics

An EdgeMetrics object with a value of zero for its left, top, right, and bottom properties.

left property
public var left:Number

The width, in pixels, of the left edge region.

right property
public var right:Number

The width, in pixels, of the right edge region.

top property
public var top:Number

The height, in pixels, of the top edge region.

Constructor detail
EdgeMetrics () constructor
public function EdgeMetrics(left:Number = 0, top:Number = 0, right:Number = 0, bottom:Number = 0)

Constructor.

Parameters
left:Number (default = 0) — The width, in pixels, of the left edge region.
top:Number (default = 0) — The height, in pixels, of the top edge region.
right:Number (default = 0) — The width, in pixels, of the right edge region.
bottom:Number (default = 0) — The height, in pixels, of the bottom edge region.
Method detail
clone () method
public function clone():EdgeMetrics

Returns a copy of this EdgeMetrics object.

Returns
EdgeMetrics


mx.core.EventPriority (Flex™ 2 Language Reference)

Class EventPriority | Properties | Methods | Constants
Package | mx.core
Class | public final class EventPriority
Inheritance | EventPriority Inheritance Object

The EventPriority class defines constant values for the priority argument of the addEventListener() method of EventDispatcher.

The higher the number, the higher the priority of the event listener. All listeners with priority N will be processed before listeners of priority N - 1. If two or more listeners share the same priority, they are processed in the order in which they were added.

Priorities can be positive, 0, or negative. The default priority is 0.

You should not write code that depends on the numeric values of these constants. They are subject to change in future versions of Flex.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | BINDING : int = 100 [static] Autogenerated event handlers that evaluate data-binding expressions need to be executed before any others, so they have a higher priority than the default. | EventPriority
 | CURSOR_MANAGEMENT : int = 200 [static] The CursorManager has handlers for mouse events which must be executed before other mouse event handlers, so they have a high priority. | EventPriority
 | DEFAULT : int = 0 [static] Event handlers on component instances are executed with the default priority, 0. | EventPriority
 | DEFAULT_HANDLER : int = -50 [static] Some components listen to events that they dispatch on themselves and let other listeners call the preventDefault() method to tell the component not to perform a default action. | EventPriority
 | EFFECT : int = -100 [static] Autogenerated event handlers that trigger effects are executed after other event handlers on component instances, so they have a lower priority than the default. | EventPriority
Constant detail
BINDING constant
public static const BINDING:int = 100

Autogenerated event handlers that evaluate data-binding expressions need to be executed before any others, so they have a higher priority than the default.

CURSOR_MANAGEMENT constant
public static const CURSOR_MANAGEMENT:int = 200

The CursorManager has handlers for mouse events which must be executed before other mouse event handlers, so they have a high priority.

DEFAULT constant
public static const DEFAULT:int = 0

Event handlers on component instances are executed with the default priority, 0.

DEFAULT_HANDLER constant
public static const DEFAULT_HANDLER:int = -50

Some components listen to events that they dispatch on themselves and let other listeners call the preventDefault() method to tell the component not to perform a default action. Those components must listen with a lower priority than the default priority, so that the other handlers are executed first and have a chance to call preventDefault().

EFFECT constant
public static const EFFECT:int = -100

Autogenerated event handlers that trigger effects are executed after other event handlers on component instances, so they have a lower priority than the default.


mx.core.FlexBitmap (Flex™ 2 Language Reference)

Class FlexBitmap | Properties | Methods | Events
Package | mx.core
Class | public class FlexBitmap
Inheritance | FlexBitmap Inheritance Bitmap Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | BitmapAsset

FlexBitmap is a subclass of the Player's Bitmap class. It overrides the toString() method to return a string indicating the location of the object within the hierarchy of DisplayObjects in the application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | bitmapData : BitmapData The BitmapData object being referenced. | Bitmap
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | pixelSnapping : String Controls whether or not the Bitmap object is snapped to the nearest pixel. | Bitmap
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | smoothing : Boolean Controls whether or not the bitmap is smoothed when scaled. | Bitmap
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FlexBitmap(bitmapData:BitmapData = null, pixelSnapping:String = "auto", smoothing:Boolean = false)
Constructor.
FlexBitmap
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexBitmap
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
FlexBitmap () constructor
public function FlexBitmap(bitmapData:BitmapData = null, pixelSnapping:String = "auto", smoothing:Boolean = false)

Constructor.

Sets the name property to a string returned by the createUniqueName() method of the mx.utils.NameUtils class. This string is the name of the object's class concatenated with an integer that is unique within the application, such as "FlexBitmap12".

Parameters
bitmapData:BitmapData (default = null) — The data for the bitmap.
pixelSnapping:String (default = "auto") — Whether or not the bitmap is snapped to the nearest pixel.
smoothing:Boolean (default = false) — Whether or not the bitmap is smoothed when scaled.

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.createUniqueName()
Method detail
toString () method
public override function toString():String

Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application. This string, such as "MyApp0.HBox5.FlexBitmap12", is built by the displayObjectToString() method of the mx.utils.NameUtils class from the name property of the object and its ancestors.

Returns
String — A String indicating the location of this object within the DisplayObject hierarchy.

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.displayObjectToString()


mx.core.FlexMovieClip (Flex™ 2 Language Reference)

Class FlexMovieClip | Properties | Methods | Events
Package | mx.core
Class | public class FlexMovieClip
Inheritance | FlexMovieClip Inheritance MovieClip Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | MovieClipAsset

FlexMovieClip is a subclass of the Player's MovieClip class. It overrides the toString() method to return a string indicating the location of the object within the hierarchy of DisplayObjects in the application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentFrame : int Specifies the number of the frame in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabel : String The current label in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabels : Array Returns an array of FrameLabel objects from the current scene. | MovieClip
Inherited | currentScene : Scene The current scene in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean A Boolean value that indicates whether a movie clip is enabled. | MovieClip
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | framesLoaded : int The number of frames that are loaded from a streaming SWF file. | MovieClip
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scenes : Array An array of Scene objects, each listing the name, the number of frames, and the frame labels for a scene in the MovieClip instance. | MovieClip
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | totalFrames : int The total number of frames in the MovieClip instance. | MovieClip
Inherited | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | MovieClip
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FlexMovieClip()
Constructor.
FlexMovieClip
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
gotoAndPlay(frame:Object, scene:String = null):void
Starts playing the SWF file at the specified frame.
MovieClip
Inherited
gotoAndStop(frame:Object, scene:String = null):void
Brings the playhead to the specified frame of the movie clip and stops it there.
MovieClip
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
nextFrame():void
Sends the playhead to the next frame and stops it.
MovieClip
Inherited
nextScene():void
Moves the playhead to the next scene of the MovieClip instance.
MovieClip
Inherited
play():void
Moves the playhead in the timeline of the movie clip.
MovieClip
Inherited
prevFrame():void
Sends the playhead to the previous frame and stops it.
MovieClip
Inherited
prevScene():void
Moves the playhead to the previous scene of the MovieClip instance.
MovieClip
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stop():void
Stops the playhead in the movie clip.
MovieClip
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexMovieClip
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Constructor detail
FlexMovieClip () constructor
public function FlexMovieClip()

Constructor.

Sets the name property to a string returned by the createUniqueName() method of the mx.utils.NameUtils class.

This string is the name of the object's class concatenated with an integer that is unique within the application, such as "FlexMovieClip14".

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.createUniqueName()
Method detail
toString () method
public override function toString():String

Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application. This string, such as "MyApp0.HBox5.FlexMovieClip14", is built by the displayObjectToString() method of the mx.utils.NameUtils class from the name property of the object and its ancestors.

Returns
String — A String indicating the location of this object within the DisplayObject hierarchy.

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.displayObjectToString()


mx.core.FlexShape (Flex™ 2 Language Reference)

Class FlexShape | Properties | Methods | Events
Package | mx.core
Class | public class FlexShape
Inheritance | FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | ProgrammaticSkin

FlexShape is a subclass of the Player's Shape class. It overrides the toString() method to return a string indicating the location of the object within the hierarchy of DisplayObjects in the application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FlexShape()
Constructor.
FlexShape
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
FlexShape () constructor
public function FlexShape()

Constructor.

Sets the name property to a string which is returned by the createUniqueName() method of the mx.utils.NameUtils class.

This string is the name of the object's class concatenated with an integer that is unique within the application, such as "FlexShape15".

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.createUniqueName()
Method detail
toString () method
public override function toString():String

Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application. This string, such as "MyApp0.HBox5.FlexShape15", is built by the displayObjectToString() method of the mx.utils.NameUtils class from the name property of the object and its ancestors.

Returns
String — A String indicating the location of this object within the DisplayObject hierarchy.

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.displayObjectToString()


mx.core.FlexSimpleButton (Flex™ 2 Language Reference)

Class FlexSimpleButton | Properties | Methods | Events
Package | mx.core
Class | public class FlexSimpleButton
Inheritance | FlexSimpleButton Inheritance SimpleButton Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | ButtonAsset

FlexSimpleButton is a subclass of the Player's SimpleButton class. It overrides the toString() method to return a string indicating the location of the object within the hierarchy of DisplayObjects in the application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | downState : DisplayObject Specifies a display object that is used as the visual object for the button "Down" state —the state that the button is in when the user clicks the hitTestState object. | SimpleButton
Inherited | enabled : Boolean A Boolean value that specifies whether a button is enabled. | SimpleButton
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitTestState : DisplayObject Specifies a display object that is used as the hit testing object for the button. | SimpleButton
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | overState : DisplayObject Specifies a display object that is used as the visual object for the button over state — the state that the button is in when the mouse is positioned over the button. | SimpleButton
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform The SoundTransform object assigned to this button. | SimpleButton
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | SimpleButton
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | upState : DisplayObject Specifies a display object that is used as the visual object for the button up state — the state that the button is in when the mouse is not positioned over the button. | SimpleButton
Inherited | useHandCursor : Boolean A Boolean value that, when set to true, indicates whether Flash Player displays the hand cursor when the mouse rolls over a button. | SimpleButton
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FlexSimpleButton()
Constructor.
FlexSimpleButton
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSimpleButton
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Constructor detail
FlexSimpleButton () constructor
public function FlexSimpleButton()

Constructor.

Sets the name property to a string returned by the createUniqueName() method of the mx.utils.NameUtils class.

This string is the name of the object's class concatenated with an integer that is unique within the application, such as "FlexSimpleButton16".

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.createUniqueName()
Method detail
toString () method
public override function toString():String

Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application. This string, such as "MyApp0.HBox5.FlexSimpleButton16", is built by the displayObjectToString() method of the mx.utils.NameUtils class from the name property of the object and its ancestors.

Returns
String — A String indicating the location of this object within the DisplayObject hierarchy.

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.displayObjectToString()


mx.core.FlexSprite (Flex™ 2 Language Reference)

Class FlexSprite | Properties | Methods | Events
Package | mx.core
Class | public class FlexSprite
Inheritance | FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | SpriteAsset, UIComponent

FlexSprite is a subclass of the Player's Sprite class and the superclass of UIComponent. It overrides the toString() method to return a string indicating the location of the object within the hierarchy of DisplayObjects in the application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FlexSprite()
Constructor.
FlexSprite
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Constructor detail
FlexSprite () constructor
public function FlexSprite()

Constructor.

Sets the name property to a string returned by the createUniqueName() method of the mx.utils.NameUtils class.

This string is the name of the object's class concatenated with an integer that is unique within the application, such as "Button17".

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.createUniqueName()
Method detail
toString () method
public override function toString():String

Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application. This string, such as "MyApp0.HBox5.Button17", is built by the displayObjectToString() method of the mx.utils.NameUtils class from the name property of the object and its ancestors.

Returns
String — A String indicating the location of this object within the DisplayObject hierarchy.

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.displayObjectToString()


mx.core.FlexTextField (Flex™ 2 Language Reference)

Class FlexTextField | Properties | Methods | Events
Package | mx.core
Class | public class FlexTextField
Inheritance | FlexTextField Inheritance TextField Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | TextFieldAsset, UITextField

FlexTextField is a subclass of the Player's TextField class and the superclass of UITextField. It overrides the toString() method to return a string indicating the location of the object within the hierarchy of DisplayObjects in the application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | alwaysShowSelection : Boolean When set to true and the text field is not in focus, Flash Player highlights the selection in the text field in gray. | TextField
Inherited | antiAliasType : String The type of anti-aliasing used for this text field. | TextField
Inherited | autoSize : String Controls automatic sizing and alignment of text fields. | TextField
Inherited | background : Boolean Specifies whether the text field has a background fill. | TextField
Inherited | backgroundColor : uint The color of the text field background. | TextField
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | border : Boolean Specifies whether the text field has a border. | TextField
Inherited | borderColor : uint The color of the text field border. | TextField
Inherited | bottomScrollV : int An integer (1-based index) that indicates the bottommost line that is currently visible in the specified text field. | TextField
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | caretIndex : int The index of the insertion point (caret) position. | TextField
Inherited | condenseWhite : Boolean A Boolean value that specifies whether extra white space (spaces, line breaks, and so on) in a text field with HTML text should be removed. | TextField
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | defaultTextFormat : TextFormat Specifies the format applied to newly inserted text, such as text inserted with the replaceSelectedText() method or text entered by a user. | TextField
Inherited | displayAsPassword : Boolean Specifies whether the text field is a password text field. | TextField
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | embedFonts : Boolean Specifies whether to render by using embedded font outlines. | TextField
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | gridFitType : String The type of grid fitting used for this text field. | TextField
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | htmlText : String Contains the HTML representation of the text field's contents. | TextField
Inherited | length : int The number of characters in a text field. | TextField
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxChars : int The maximum number of characters that the text field can contain, as entered by a user. | TextField
Inherited | maxScrollH : int The maximum value of scrollH. | TextField
Inherited | maxScrollV : int The maximum value of scrollV. | TextField
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseWheelEnabled : Boolean A Boolean value that indicates whether Flash Player should automatically scroll multiline text fields when the user clicks a text field and rolls the mouse wheel. | TextField
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | multiline : Boolean Indicates whether the text field is a multiline text field. | TextField
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numLines : int Defines the number of text lines in a multiline text field. | TextField
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | restrict : String Indicates the set of characters that a user can enter into the text field. | TextField
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollH : int The current horizontal scrolling position. | TextField
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollV : int The vertical position of text in a text field. | TextField
Inherited | selectable : Boolean A Boolean value that indicates whether the text field is selectable. | TextField
Inherited | selectionBeginIndex : int The zero-based character index value of the first character in the current selection. | TextField
Inherited | selectionEndIndex : int The zero-based character index value of the last character in the current selection. | TextField
Inherited | sharpness : Number The sharpness of the glyph edges in this text field. | TextField
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleSheet : StyleSheet Attaches a style sheet to the text field. | TextField
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String A string that is the current text in the text field. | TextField
Inherited | textColor : uint The color of the text in a text field, in hexadecimal format. | TextField
Inherited | textHeight : Number The height of the text in pixels. | TextField
Inherited | textWidth : Number The width of the text in pixels. | TextField
Inherited | thickness : Number The thickness of the glyph edges in this text field. | TextField
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | type : String The type of the text field. | TextField
Inherited | useRichTextClipboard : Boolean Specifies whether to copy and paste the text formatting along with the text. | TextField
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | wordWrap : Boolean A Boolean value that indicates whether the text field has word wrap. | TextField
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FlexTextField()
Constructor.
FlexTextField
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
appendText(newText:String):void
Appends the string specified by the newText parameter to the end of the text of the TextField.
TextField
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getCharBoundaries(charIndex:int):Rectangle
Returns a rectangle that is the bounding box of the character.
TextField
Inherited
getCharIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the character at the point specified by the x and y parameters.
TextField
Inherited
getFirstCharInParagraph(charIndex:int):int
Given a character index, returns the index of the first character in the same paragraph.
TextField
Inherited
getImageReference(id:String):DisplayObject
Returns a DisplayObject reference for the given id, for an image or SWF file that has been added to an HTML-formatted text field by using an <img> tag.
TextField
Inherited
getLineIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the line at the point specified by the x and y parameters.
TextField
Inherited
getLineIndexOfChar(charIndex:int):int
Returns the zero-based index value of the line containing the character specified by the charIndex parameter.
TextField
Inherited
getLineLength(lineIndex:int):int
Returns the number of characters in a specific text line.
TextField
Inherited
getLineMetrics(lineIndex:int):TextLineMetrics
Returns metrics information about a given text line.
TextField
Inherited
getLineOffset(lineIndex:int):int
Returns the character index of the first character in the line that the lineIndex parameter specifies.
TextField
Inherited
getLineText(lineIndex:int):String
Returns the text of the line specified by the lineIndex parameter.
TextField
Inherited
getParagraphLength(charIndex:int):int
Given a character index, returns the length of the paragraph containing the given character.
TextField
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getTextFormat(beginIndex:int = -1, endIndex:int = -1):TextFormat
Returns a TextFormat object that contains formatting information for the range of text that the beginIndex and endIndex parameters specify.
TextField
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
replaceSelectedText(value:String):void
Replaces the current selection with the contents of the value parameter.
TextField
Inherited
replaceText(beginIndex:int, endIndex:int, newText:String):void
Replaces the range of characters that the beginIndex and endIndex parameters specify with the contents of the newText parameter.
TextField
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSelection(beginIndex:int, endIndex:int):void
Sets as selected the text designated by the index values of the first and last characters, which are specified with the beginIndex and endIndex parameters.
TextField
Inherited
setTextFormat(format:TextFormat, beginIndex:int = -1, endIndex:int = -1):void
Applies the text formatting that the format parameter specifies to the specified text in a text field.
TextField
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexTextField
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched after a control's value is modified. | TextField
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | link | Dispatched when a user clicks a hyperlink in an HTML-enabled text field, where the URL begins with "event:". | TextField
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched by a TextField object after the user scrolls. | TextField
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | textInput | Flash Player dispatches the textInput event when a user enters one or more characters of text. | TextField
Constructor detail
FlexTextField () constructor
public function FlexTextField()

Constructor.

Sets the name property to a string returned by the createUniqueName() method of the mx.utils.NameUtils class.

This string is the name of the object's class concatenated with an integer that is unique within the application, such as "UITextField18".

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.createUniqueName()
Method detail
toString () method
public override function toString():String

Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application. This string, such as "MyApp0.HBox5.UITextField18", is built by the displayObjectToString() method of the mx.utils.NameUtils class from the name property of the object and its ancestors.

Returns
String — A String indicating the location of this object within the DisplayObject hierarchy.

See also

flash.display.DisplayObject.name
mx.utils.NameUtil.displayObjectToString()


mx.core.IChildList (Flex™ 2 Language Reference)

Interface IChildList | Properties | Methods
Package | mx.core
Interface | public interface IChildList
Subinterfaces | ISystemManager
Implementors | SystemManager, UIComponent

The IChildList interface defines the properties and methods for accessing and manipulating child lists, which are subsets of a DisplayObjectContainer's children.

As an example, consider the Container class. It overrides DisplayObjectContainer APIs such as the numChildren and getChildAt() methods to access only "content" children, which are the controls and other containers that you put inside it. But a Container can also have additional children created automatically by the framework, such as a background or border skin and scrollbars. So Container exposes a property called rawChildren of type IChildList, which lets you access all its children, not just the content children.

As another example, the SystemManager class is a DisplayObjectContainer whose children are partitioned into various layers: normal children like the Application are on the bottom, popups above them, tooltips above them, and cursors on the top. The SystemManager class has properties named popUpChildren, toolTipChildren, and cursorChildren which let you access these layers, and the type of each of these properties is IChildList. Therefore, you can count the number of popups using the systemManager.popUpChildren.numChildren property, insert another DisplayObject into the tooltip layer using the systemManager.toolTipChildren.addChild() method, and so on.

See also

mx.core.Container.rawChildren
mx.managers.SystemManager.rawChildren
mx.managers.SystemManager.popUpChildren
mx.managers.SystemManager.toolTipChildren
mx.managers.SystemManager.cursorChildren

Public Properties
Property |  | Defined by
 | numChildren : int [read-only] The number of children in this child list. | IChildList
Public Methods
Method |  | Defined by
 | addChild(child:DisplayObject):DisplayObject Adds a child DisplayObject after the end of this child list. | IChildList
 | addChildAt(child:DisplayObject, index:int):DisplayObject Adds a child DisplayObject to this child list at the index specified. | IChildList
 | contains(child:DisplayObject):Boolean Determines if a DisplayObject is in this child list, or is a descendant of an child in this child list. | IChildList
 | getChildAt(index:int):DisplayObject Gets the child DisplayObject at the specified index in this child list. | IChildList
 | getChildByName(name:String):DisplayObject Gets the child DisplayObject with the specified name in this child list. | IChildList
 | getChildIndex(child:DisplayObject):int Gets the index of a specific child in this child list. | IChildList
 | getObjectsUnderPoint(point:Point):Array Returns an array of DisplayObjects that lie under the specified point and are in this child list. | IChildList
 | removeChild(child:DisplayObject):DisplayObject Removes the specified child DisplayObject from this child list. | IChildList
 | removeChildAt(index:int):DisplayObject Removes the child DisplayObject at the specified index from this child list. | IChildList
 | setChildIndex(child:DisplayObject, newIndex:int):void Changes the index of a particular child in this child list. | IChildList
Property detail
numChildren property
numChildren:int [read-only]

The number of children in this child list.

Implementation
    public function get numChildren():int
Method detail
addChild () method
public function addChild(child:DisplayObject):DisplayObject

Adds a child DisplayObject after the end of this child list.

Calling childList.addChild(child) is the same as calling childList.addChild(child, childList.numChildren) After it has been added, its index of the new child will be (child.numChildren - 1)

Parameters
child:DisplayObject — The DisplayObject to add as a child.

Returns
DisplayObject — The child that was added; this is the same as the argument passed in.
addChildAt () method
public function addChildAt(child:DisplayObject, index:int):DisplayObject

Adds a child DisplayObject to this child list at the index specified. An index of 0 represents the beginning of the DisplayList, and an index of numChildren represents the end.

Adding a child anywhere except at the end of a child list will increment the indexes of children that were previously at that index or at higher indices.

Parameters
child:DisplayObject — The DisplayObject to add as a child.
index:int — The index to add the child at.

Returns
DisplayObject — The child that was added; this is the same as the child argument passed in.
contains () method
public function contains(child:DisplayObject):Boolean

Determines if a DisplayObject is in this child list, or is a descendant of an child in this child list.

Parameters
child:DisplayObject — The DisplayObject to test.

Returns
Boolean — true if the DisplayObject is in this child list or is a descendant of an child in this child list; false otherwise.
getChildAt () method
public function getChildAt(index:int):DisplayObject

Gets the child DisplayObject at the specified index in this child list.

Parameters
index:int — An integer from 0 to (numChildren - 1) that specifies the index of a child in this child list.

Returns
DisplayObject — The child at the specified index.
getChildByName () method
public function getChildByName(name:String):DisplayObject

Gets the child DisplayObject with the specified name in this child list.

Parameters
name:String — The name of the child to return.

Returns
DisplayObject — The child with the specified name.
getChildIndex () method
public function getChildIndex(child:DisplayObject):int

Gets the index of a specific child in this child list.

The first child in the child list has an index of 0, the second child has an index of 1, and the last child has an index of (numChildren - 1).

If getChildIndex(myChild) returns 5, then myView.getChildAt(5) returns myChild.

If you add a child by calling the addChild() method, the new child's index is equal to the largest index among the existing children plus one.

You can insert a child at a specified index by using the addChildAt() method In that case the children previously at that index and higher indices have their index increased by 1 so that all children are indexed from 0 to (numChildren - 1).

If you remove a child by calling the removeChild() or removeChildAt() method, then the children at higher indices have their index decreased by 1 so that all children are indexed from 0 to (numChildren - 1).

If you change a child's index by calling the setChildIndex() method, then the children between the old index and the new index, inclusive, have their indexes adjusted so that all children are indexed from 0 to (numChildren - 1).

Parameters
child:DisplayObject — The child whose index to get.

Returns
int — The index of the child, which is an integer between 0 and (numChildren - 1).
getObjectsUnderPoint () method
public function getObjectsUnderPoint(point:Point):Array

Returns an array of DisplayObjects that lie under the specified point and are in this child list.

Parameters
point:Point — The point under which to look.

Returns
Array — An array of object that lie under the specified point that are children of this Container.
removeChild () method
public function removeChild(child:DisplayObject):DisplayObject

Removes the specified child DisplayObject from this child list.

Removing a child anywhere except from the end of a child list will decrement the indexes of children that were at higher indices.

The removed child will have its parent set to null and will be garbage collected if no other references to it exist.

Parameters
child:DisplayObject — The DisplayObject to remove.

Returns
DisplayObject — The child that was removed; this is the same as the argument passed in.
removeChildAt () method
public function removeChildAt(index:int):DisplayObject

Removes the child DisplayObject at the specified index from this child list.

Removing a child anywhere except from the end of a child list will decrement the indexes of children that were at higher indices.

The removed child will have its parent set to null and will be garbage collected if no other references to it exist.

Parameters
index:int — The child index of the DisplayObject to remove.

Returns
DisplayObject — The child that was removed.
setChildIndex () method
public function setChildIndex(child:DisplayObject, newIndex:int):void

Changes the index of a particular child in this child list. See the getChildIndex() method for a description of the child's index.

Parameters
child:DisplayObject — The child whose index to set.
newIndex:int — The new index for the specified child. This must be an integer between zero and (numChildren - 1).


mx.core.IContainer (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Interface IContainer
Package | mx.core
Interface | public interface IContainer
Implementors | Container

IContainer is a marker interface that indicates a component acts as a container for other components. It is used only by the MXML compiler, not by the Flex framework. This interface does not define any properties or methods that the implementing class must actually implement.


mx.core.IDataRenderer (Flex™ 2 Language Reference)

Interface IDataRenderer | Properties
Package | mx.core
Interface | public interface IDataRenderer
Subinterfaces | IListItemRenderer
Implementors | AccordionHeader, AreaRenderer, BoxItemRenderer, Button, CandlestickItemRenderer, ChartLabel, CircleItemRenderer, ComboBox, Container, DataGridItemRenderer, DataTip, DateField, HLOCItemRenderer, Image, Label, LineRenderer, ListBase, ListItemRenderer, MenuItemRenderer, NumericStepper, ShadowLineRenderer, TextArea, TextInput, TileListItemRenderer, TreeItemRenderer, WedgeItemRenderer

The IDataRenderer interface defines the interface for components that have a data property.

Components that are used in an item renderer or item editor in a list control (such as the List, HorizontalList, TileList, DataGrid, and Tree controls), or as renderers in a chart are passed the data to render or edit by using the data property. The component must implement IDataRenderer so that the host components can pass this information. All Flex containers and many Flex components implement IDataRenderer and the data property.

In a list control, Flex sets the data property of an item renderer or item editor to the element in the data provider that corresponds to the item being rendered or edited. For a DataGrid control, the data property contains the data provider element for the entire row of the DataGrid control, not just for the item.

To implement this interface, you define a setter and getter method to implement the data property. Typically, the setter method writes the value of the data property to an internal variable and dispatches a dataChange event, and the getter method returns the current value of the internal variable, as the following example shows:

    // Internal variable for the property value.
    private var _data:Object;

    // Make the data property bindable.
    [Bindable("dataChange")]

    // Define the getter method.
    public function get data():Object {
        return _data;
    }

    // Define the setter method, and dispatch an event when the property
    // changes to support data binding.
    public function set data(value:Object):void {
        _data = value;

        dispatchEvent(new FlexEvent(FlexEvent.DATA_CHANGE));
    }

Public Properties
Property |  | Defined by
 | data : Object The data to render or edit. | IDataRenderer
Property detail
data property
data:Object [read-write]

The data to render or edit.

Implementation
    public function get data():Object
    public function set data(value:Object):void


mx.core.IDeferredInstance (Flex™ 2 Language Reference)

Interface IDeferredInstance | Methods
Package | mx.core
Interface | public interface IDeferredInstance
Implementors | DeferredInstanceFromClass, DeferredInstanceFromFunction

The IDeferredInstance interface defines the Flex deferred instance factory interface. An implementation of IDeferredInstance creates a particular instance value when the getInstance() method is first called, and returns a reference to that value when the getInstance() method is called subsequently.

The Flex compiler performs the following automatic coercions when it encounters MXML that assigns a value to a property with the IDeferredInstance type:

  1. If you assign a property of type IDeferredInstance a value that is an MXML child tag representing a class, such as a component tag, the compiler creates an IDeferredInstance implementation whose getInstance() method returns an instance of the class, configured as specified in the MXML code. The following example shows this format; in this example, the compiler generates an IDeferredInstance1 implementation whose getInstance() method returns an instance of the Label class, with its text property set to "This is a deferred label":
        <MyComp>
    <MyDeferredInstanceProperty>
      <Label text="This is a deferred label"/>
     </myDeferredInstanceProperty>
    </MyComp>
  2. If you assign a text string to a property of type IDeferredInstance, the compiler interprets the string as a fully qualified class name, and creates an IDeferredInstance implementation whose getInstance() method returns a new instance of the specified class. The specified class must have a constructor with no arguments. The following example shows this format; in this example, the compiler generates an IDeferredInstance1 implementation whose getInstance() method returns an instance of the MyClass class:
        <MyComp myDeferredInstanceProperty="myPackage.MyClass/>

Use the IDeferredInstance interface when an ActionScript class defers the instantiation of a property value. You cannot use IDeferredInstance if an ActionScript class requires multiple instances of the same value. In those situations, use the IFactory interface.

The states.AddChild class includes a childFactory property that is of type IDeferredInstance.

See also

mx.states.AddChild
Using IDeferredInstance in a template component

Public Methods
Method |  | Defined by
 | getInstance():Object Creates an instance Object from a class or function, if the instance does not yet exist. | IDeferredInstance
Method detail
getInstance () method
public function getInstance():Object

Creates an instance Object from a class or function, if the instance does not yet exist.

Returns
Object — The instance Object.


mx.core.IDeferredInstantiationUIComponent (Flex™ 2 Language Reference)

Interface IDeferredInstantiationUIComponent | Properties | Methods
Package | mx.core
Interface | public interface IDeferredInstantiationUIComponent extends IUIComponent, IFlexDisplayObject, IBitmapDrawable, IEventDispatcher
Implementors | UIComponent

The IDeferredInstantiationUIComponent interface defines the interface for a component or object that defers instantiation.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | alpha : Number The transparency of this object. | IFlexDisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | IUIComponent
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the object. | IUIComponent
 | cacheHeuristic : Boolean [write-only] Used by Flex to suggest bitmap caching for the object. | IDeferredInstantiationUIComponent
 | cachePolicy : String [read-only] Specifies the bitmap caching policy for this object. | IDeferredInstantiationUIComponent
 | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | IDeferredInstantiationUIComponent
Inherited | document : Object A reference to the document object associated with this component. | IUIComponent
Inherited | enabled : Boolean Whether the component can accept user interaction. | IUIComponent
Inherited | explicitHeight : Number The explicitly specified height for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitWidth : Number The explicitly specified width for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | focusPane : Sprite A single Sprite object that is shared among components and used as an overlay for drawing focus. | IUIComponent
Inherited | height : Number The height of this object, in pixels. | IFlexDisplayObject
 | id : String ID of the component. | IDeferredInstantiationUIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | IUIComponent
Inherited | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | measuredHeight : Number The measured height of this object. | IFlexDisplayObject
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | IUIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | IUIComponent
Inherited | measuredWidth : Number The measured width of this object. | IFlexDisplayObject
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | name : String The instance name of this object. | IFlexDisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | IUIComponent
Inherited | owner : DisplayObjectContainer Your owner is usually your parent, however If you are a popup subcomponent, your owner will be the component that popped you up. | IUIComponent
Inherited | parent : DisplayObjectContainer The parent of this object. | IFlexDisplayObject
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | IUIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | IUIComponent
Inherited | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
Inherited | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the surface of the component. | IUIComponent
Inherited | systemManager : ISystemManager A reference to the SystemManager object for this component. | IUIComponent
Inherited | tweeningProperties : Array Used by EffectManager. | IUIComponent
Inherited | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
Inherited | width : Number The width of this object, in pixels. | IFlexDisplayObject
Inherited | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Inherited | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
IDeferredInstantiationUIComponent
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
IDeferredInstantiationUIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
IDeferredInstantiationUIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
IUIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
IUIComponent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
initialize():void
Initialize the object.
IUIComponent
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
IUIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
IUIComponent
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
IDeferredInstantiationUIComponent
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
IUIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
cacheHeuristic property
cacheHeuristic:Boolean [write-only]

Used by Flex to suggest bitmap caching for the object. If cachePolicy is UIComponentCachePolicy.AUTO, then cacheHeuristic is used to control the object's cacheAsBitmap property.

Implementation
    public function set cacheHeuristic(value:Boolean):void
cachePolicy property
cachePolicy:String [read-only]

Specifies the bitmap caching policy for this object. Possible values in MXML are "on", "off" and "auto" (default).

Possible values in ActionScript are UIComponentCachePolicy.ON, UIComponentCachePolicy.OFF and UIComponentCachePolicy.AUTO (default).

  • A value of UIComponentCachePolicy.ON means that the object is always cached as a bitmap.
  • A value of UIComponentCachePolicy.OFF means that the object is never cached as a bitmap.
  • A value of UIComponentCachePolicy.AUTO means that the framework uses heuristics to decide whether the object should be cached as a bitmap.

Implementation
    public function get cachePolicy():String
descriptor property
descriptor:UIComponentDescriptor [read-write]

Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. If this UIComponent instance was not created from a descriptor, this property is null.

Implementation
    public function get descriptor():UIComponentDescriptor
    public function set descriptor(value:UIComponentDescriptor):void
id property
id:String [read-write]

ID of the component. This value becomes the instance name of the object and should not contain any white space or special characters. Each component throughout an application should have a unique id.

If your application is going to be tested by third party tools, give each component a meaningful id. Testing tools use ids to represent the control in their scripts and having a meaningful name can make scripts more readable. For example, set the value of a button to submit_button rather than b1 or button1.

Implementation
    public function get id():String
    public function set id(value:String):void
Method detail
createReferenceOnParentDocument () method
public function createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void

Creates an id reference to this IUIComponent object on its parent document object. This function can create multidimensional references such as b[2][4] for objects inside one or more repeaters. If the indices are null, it creates a simple non-Array reference.

Parameters
parentDocument:IFlexDisplayObject — The parent of this IUIComponent object.
deleteReferenceOnParentDocument () method
public function deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void

Deletes the id reference to this IUIComponent object on its parent document object. This function can delete from multidimensional references such as b[2][4] for objects inside one or more Repeaters. If the indices are null, it deletes the simple non-Array reference.

Parameters
parentDocument:IFlexDisplayObject — The parent of this IUIComponent object.
executeBindings () method
public function executeBindings(recurse:Boolean = false):void

Executes the data bindings into this UIComponent object.

Parameters
recurse:Boolean (default = false) — Recursively execute bindings for children of this component.
registerEffects () method
public function registerEffects(effects:Array):void

For each effect event, register the EffectManager as one of the event listeners.

Parameters
effects:Array — An Array of strings of effect names.


mx.core.IFactory (Flex™ 2 Language Reference)

Interface IFactory | Methods
Package | mx.core
Interface | public interface IFactory
Implementors | ClassFactory

The IFactory interface defines the interface that factory classes such as ClassFactory must implement. An object of type IFactory is a "factory object" which Flex uses to generate multiple instances of another class, each with identical properties.

For example, a DataGridColumn has an itemRenderer of type IFactory; it calls itemRenderer.newInstance() to create the cells for a particular column of the DataGrid.

See also

mx.core.ClassFactory

Public Methods
Method |  | Defined by
 | newInstance():* Creates an instance of some class (determined by the class that implements IFactory). | IFactory
Method detail
newInstance () method
public function newInstance():*

Creates an instance of some class (determined by the class that implements IFactory).

Returns
* — The newly created instance.


mx.core.IFlexAsset (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Interface IFlexAsset
Package | mx.core
Interface | public interface IFlexAsset
Implementors | BitmapAsset, ButtonAsset, MovieClipAsset, MovieClipLoaderAsset, SoundAsset, SpriteAsset, TextFieldAsset

IFlexAsset is a marker interface with the following meaning: if a class declares that it implements IFlexAsset, then that class represents an asset -- such as a bitmap, a font, or a sound -- that has been embedded in a Flex application. This interface does not define any properties or methods that the class must actually implement.

The Flash Player uses ActionScript classes to represent embedded assets as well as executable ActionScript code. When you embed an asset in a Flex application, the MXML compiler autogenerates a class to represent it, and all such classes declare that they implement IFlexAsset so that they can be distinguished from the code classes.


mx.core.IFlexDisplayObject (Flex™ 2 Language Reference)

Interface IFlexDisplayObject | Properties | Methods
Package | mx.core
Interface | public interface IFlexDisplayObject extends IBitmapDrawable, IEventDispatcher
Subinterfaces | IChartElement, IListItemRenderer, IToolTipManagerClient, IUIComponent
Implementors | BitmapAsset, ButtonAsset, MovieClipAsset, MovieClipLoaderAsset, ProgrammaticSkin, SpriteAsset, SystemManager, TextFieldAsset, UIComponent

The IFlexDisplayObject interface defines the interface for skin elements. At a minimum, a skin must be a DisplayObject and implement this interface.

Public Properties
Property |  | Defined by
 | alpha : Number The transparency of this object. | IFlexDisplayObject
 | height : Number The height of this object, in pixels. | IFlexDisplayObject
 | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
 | measuredHeight : Number [read-only] The measured height of this object. | IFlexDisplayObject
 | measuredWidth : Number [read-only] The measured width of this object. | IFlexDisplayObject
 | name : String The instance name of this object. | IFlexDisplayObject
 | parent : DisplayObjectContainer [read-only] The parent of this object. | IFlexDisplayObject
 | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
 | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
 | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
 | width : Number The width of this object, in pixels. | IFlexDisplayObject
 | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
 | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
alpha property
alpha:Number [read-write]

The transparency of this object. The value is a Number from 0.0 to 1.0, where 0.0 means transparent and 1.0 means fully opaque.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void

See also

flash.display.DisplayObject.alpha
height property
height:Number [read-write]

The height of this object, in pixels.

Implementation
    public function get height():Number
    public function set height(value:Number):void
mask property
mask:DisplayObject [read-write]

The DisplayObject used to mask this object so that only part of it is actually drawn. The mask object itself is not drawn.

Set mask to null to remove the mask.

To ensure that masking works when the stage is scaled, the mask display object must be in an active part of the display list.

Implementation
    public function get mask():DisplayObject
    public function set mask(value:DisplayObject):void

See also

flash.display.DisplayObject.mask
measuredHeight property
measuredHeight:Number [read-only]

The measured height of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measured width of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredWidth():Number
name property
name:String [read-write]

The instance name of this object.

Flash classes such as Sprite, TextField, etc. initialize the instance name to "instanceN", where N is a unique integer. Flex classes such as FlexSprite, FlexTextField, etc. initialize it to a string that combines the class name with a unique integer, such as "Button5". (This name is produced by the NameUtil.createUniqueName() method.) The Flex framework assigns instance names to some objects that it creates, such as "upSkin" for the "up"-state skin of a Button. If you have assigned an MXML id to this object, then the instance name is set to that id.

You can use the DisplayObjectContainer method getChildByName() to get an object by name from its parent container.

Implementation
    public function get name():String
    public function set name(value:String):void
parent property
parent:DisplayObjectContainer [read-only]

The parent of this object.

This property can be null if the object has not yet ben added to a DisplayObjectContainer with addChild() or addChildAt(), or if it has been removed from a DisplayObjectContainer with removeChild() or removeChildAt().

Implementation
    public function get parent():DisplayObjectContainer
scaleX property
scaleX:Number [read-write]

The horizontal scaling factor for this object. The value is a Number where 1.0 means the object isn't scaled horziontally, 2.0 means that it is stretched to twice its normal width, and 0.5 means that it is compressed to half its normal width.

Implementation
    public function get scaleX():Number
    public function set scaleX(value:Number):void
scaleY property
scaleY:Number [read-write]

The vertical scaling factor for this object. The value is a Number where 1.0 means the object isn't scaled vertically, 2.0 means that it is stretched to twice its normal height, and 0.5 means that it is compressed to half its normal height.

Implementation
    public function get scaleY():Number
    public function set scaleY(value:Number):void
visible property
visible:Boolean [read-write]

A flag that indicates whether this object is visible.

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
width property
width:Number [read-write]

The width of this object, in pixels.

Implementation
    public function get width():Number
    public function set width(value:Number):void
x property
x:Number [read-write]

The horizontal position of this object relative to its parent, in pixel coordinates.

Implementation
    public function get x():Number
    public function set x(value:Number):void
y property
y:Number [read-write]

The vertical position of this object relative to its parent, in pixel coordinates.

Implementation
    public function get y():Number
    public function set y(value:Number):void
Method detail
move () method
public function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The new x-position for this object.
y:Number — The new y-position for this object.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.


mx.core.IIMESupport (Flex™ 2 Language Reference)

Interface IIMESupport | Properties
Package | mx.core
Interface | public interface IIMESupport
Implementors | ComboBase, DataGrid, DataGridColumn, List, NumericStepper, TextArea, TextInput, Tree, UITextField

The IIMESupport interface defines the interface for any component that supports IME (input method editor). IME is used for entering characters in Chinese, Japanese, and Korean.

See also

flash.system.IME

Public Properties
Property |  | Defined by
 | imeMode : String The IME mode of the component. | IIMESupport
Property detail
imeMode property
imeMode:String [read-write]

The IME mode of the component.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void


mx.core.IInvalidating (Flex™ 2 Language Reference)

Interface IInvalidating | Methods
Package | mx.core
Interface | public interface IInvalidating
Implementors | ProgrammaticSkin, UIComponent, UITextField

The IInvalidating interface defines the interface for components that use invalidation to do delayed -- rather than immediate -- property commitment, measurement, drawing, and layout.

Public Methods
Method |  | Defined by
 | invalidateDisplayList():void Calling this method results in a call to the component's validateDisplayList() method before the display list is rendered. | IInvalidating
 | invalidateProperties():void Calling this method results in a call to the component's validateProperties() method before the display list is rendered. | IInvalidating
 | invalidateSize():void Calling this method results in a call to the component's validateSize() method before the display list is rendered. | IInvalidating
 | validateNow():void Validates and updates the properties and layout of this object by immediately calling validateProperties(), validateSize(), and validateDisplayList(), if necessary. | IInvalidating
Method detail
invalidateDisplayList () method
public function invalidateDisplayList():void

Calling this method results in a call to the component's validateDisplayList() method before the display list is rendered.

For components that extend UIComponent, this implies that updateDisplayList() is called.

invalidateProperties () method
public function invalidateProperties():void

Calling this method results in a call to the component's validateProperties() method before the display list is rendered.

For components that extend UIComponent, this implies that commitProperties() is called.

invalidateSize () method
public function invalidateSize():void

Calling this method results in a call to the component's validateSize() method before the display list is rendered.

For components that extend UIComponent, this implies that measure() is called, unless the component has both explicitWidth and explicitHeight set.

validateNow () method
public function validateNow():void

Validates and updates the properties and layout of this object by immediately calling validateProperties(), validateSize(), and validateDisplayList(), if necessary.

When properties are changed, the new values do not usually have an immediate effect on the component. Usually, all of the application code that needs to be run at that time is executed. Then the LayoutManager starts calling the validateProperties(), validateSize(), and validateDisplayList() methods on components, based on their need to be validated and their depth in the hierarchy of display list objects.

For example, setting the width property is delayed, because it may require recalculating the widths of the object's children or its parent. Delaying the processing also prevents it from being repeated multiple times if the application code sets the width property more than once. This method lets you manually override this behavior.


mx.core.IMXMLObject (Flex™ 2 Language Reference)

Interface IMXMLObject | Methods
Package | mx.core
Interface | public interface IMXMLObject
Implementors | AbstractTarget, DataService, HTTPService, ListCollectionView, MessageAgent, RadioButtonGroup, RemoteObject, Validator, WebService

The IMXMLObject interface defines the APIs that a non-visual component must implement in order to work properly with the MXML compiler. Currently, the only supported method is the initialized() method.

Public Methods
Method |  | Defined by
 | initialized(document:Object, id:String):void Called after the implementing object has been created and all component properties specified on the MXML tag have been initialized. | IMXMLObject
Method detail
initialized () method
public function initialized(document:Object, id:String):void

Called after the implementing object has been created and all component properties specified on the MXML tag have been initialized.

Parameters
document:Object — The MXML document that created this object.
id:String — The identifier used by document to refer to this object. If the object is a deep property on document, id is null.


mx.core.IPropertyChangeNotifier (Flex™ 2 Language Reference)

Interface IPropertyChangeNotifier | Properties | Methods
Package | mx.core
Interface | public interface IPropertyChangeNotifier extends IEventDispatcher, IUID
Subinterfaces | IManaged
Implementors | ObjectProxy, UIComponent

The IPropertyChangeNotifier interface defines a marker interface. Classes that support this interface declare support for event propagation in a specialized manner. Classes that implement this interface must dispatch events for each property of this class and any nested classes publicly exposed as properties. For those properties that are anonymous (complex and not strongly typed), implementing classes provide custom support or directly use the ObjectProxy class. Implementors of this interface should use the PropertyChangeEvent.createUpdateEvent() method to construct an appropriate update event for dispatch.

Example

 function set myProperty(value:Object):void
 {
    var oldValue:IPropertyChangeNotifier = _myProperty;
    var newValue:IPropertyChangeNotifier = value;

    // Need to ensure to dispatch changes on the new property.
    // Listeners use the source property to determine which object
    // actually originated the event.
    // In their event handler code, they can tell if an event has been
    // propagated from deep within the object graph by comparing
    // event.target and event.source. If they are equal, then the property
    // change is at the surface of the object. If they are not equal, the
    // property change is somewhere deeper in the object graph.
    newValue.addEventListener(
                PropertyChangeEvent.PROPERTY_CHANGE,
                dispatchEvent);

    // need to stop listening for events from the old property
    oldValue.removeEventListener(
                PropertyChangeEvent.PROPERTY_CHANGE,
                dispatchEvent);

    _myProperty = newValue;

    // now notify anyone that is listening
    if (dispatcher.hasEventListener(PropertyChangeEvent.PROPERTY_CHANGE))
    {
         var event:PropertyChangeEvent =
                         PropertyChangeEvent.createUpdateEvent(
                                                       this,
                                                       "myProperty",
                                                       newValue,
                                                       oldValue);
        dispatchEvent(event);
     }
  }

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | uid : String The unique identifier for this object. | IUID
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher


mx.core.IRawChildrenContainer (Flex™ 2 Language Reference)

Interface IRawChildrenContainer | Properties
Package | mx.core
Interface | public interface IRawChildrenContainer
Implementors | Container

The IRawChildrenContainer interface defines the APIs for containers that can return an IChildList that represents all their children. This interface should be implemented by any container that has overridden IChildList APIs such as numChildren and addChild() method to manage only a subset of its actual children. The mx.core.Container class, for example, has a set of content children separate from the non-content children, such as borders, title bars, and dividers.

See also

mx.core.Container

Public Properties
Property |  | Defined by
 | rawChildren : IChildList [read-only] Returns an IChildList representing all children. | IRawChildrenContainer
Property detail
rawChildren property
rawChildren:IChildList [read-only]

Returns an IChildList representing all children. This is used by FocusManager to find non-content children that may still receive focus (for example, components in ControlBars).

Implementation
    public function get rawChildren():IChildList


mx.core.IRepeater (Flex™ 2 Language Reference)

Interface IRepeater | Properties | Methods
Package | mx.core
Interface | public interface IRepeater
Implementors | Repeater, UIComponent

The IRepeater interface defines the APIs for Repeater public APIs of the Repeater object.

Public Properties
Property |  | Defined by
 | container : Container [read-only] The container that contains this Repeater, and in which it will create its children. | IRepeater
 | count : int The number of times this Repeater should execute. | IRepeater
 | currentIndex : int [read-only] The index of the item in the dataProvider currently being processed while this Repeater is executing. | IRepeater
 | currentItem : Object [read-only] The item in the dataProvider currently being processed while this Repeater is executing. | IRepeater
 | dataProvider : Object The data provider used by this Repeater to create repeated instances of its children. | IRepeater
 | recycleChildren : Boolean A Boolean flag indicating whether this Repeater should re-use previously created children, or create new ones. | IRepeater
 | startingIndex : int The index into the dataProvider at which this Repeater starts creating children. | IRepeater
Public Methods
Method |  | Defined by
 | executeChildBindings():void Executes the bindings into all the UIComponents created by this Repeater. | IRepeater
 | initializeRepeater(container:Container, recurse:Boolean):void Initializes a new Repeater object. | IRepeater
Property detail
container property
container:Container [read-only]

The container that contains this Repeater, and in which it will create its children.

Implementation
    public function get container():Container
count property
count:int [read-write]

The number of times this Repeater should execute.

If the Repeater reaches the end of the data provider while executing, the number of times it actually executes will be less that the requested count.

Implementation
    public function get count():int
    public function set count(value:int):void
currentIndex property
currentIndex:int [read-only]

The index of the item in the dataProvider currently being processed while this Repeater is executing.

After the Repeater has finished executing, this property is -1. However, the repeaterIndex property of a repeated component instance remembers the index of the dataProvider item from which it was created. In the case of nested Repeaters, you can use the repeaterIndices array.

Implementation
    public function get currentIndex():int

See also

mx.core.UIComponent.repeaterIndex
mx.core.UIComponent.repeaterIndices
mx.core.UIComponent.instanceIndex
mx.core.UIComponent.instanceIndices
currentItem property
currentItem:Object [read-only]

The item in the dataProvider currently being processed while this Repeater is executing.

After the Repeater has finished executing, this property is null. However, in this case you can call the getRepeaterItem() method of the repeated component instance to get the dataProvider item from which it was created.

Implementation
    public function get currentItem():Object

See also

mx.core.UIComponent.getRepeaterItem()
dataProvider property
dataProvider:Object [read-write]

The data provider used by this Repeater to create repeated instances of its children.

If you read the dataProvider property, you always get an ICollectionView object or null. If you set the dataProvider property to anything other than null, it is converted into an ICollectionView object, according the following rules:

  • If you set it to an Array, it is converted into an ArrayCollection.
  • If you set it to an ICollectionView, no conversion is performed.
  • If you set it to an IList, it is converted into a ListCollectionView.
  • If you set it to an XML or XMLList, it is converted into an XMLListCollection.
  • Otherwise, it is converted to a single-element ArrayCollection.

You must specify a value for the dataProvider property or the Repeater component will not execute.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
recycleChildren property
recycleChildren:Boolean [read-write]

A Boolean flag indicating whether this Repeater should re-use previously created children, or create new ones.

If true, when this Repeater's dataProvider, startingIndex, or count changes, it will recycle the existing children by binding the new data into them. If more children are required, they are created and added. If fewer children are required, the extra ones are removed and garbage collected.

If false, when this Repeater's dataProvider, startingIndex, or count changes, it will remove any previous children that it created and then create and add new children from the new data items.

This property is false by default. Setting it to true can increase performance, but is not appropriate in all situations. For example, if the previously created children have state information such as text typed in by a user, then this state will not get reset when the children are recycled.

Implementation
    public function get recycleChildren():Boolean
    public function set recycleChildren(value:Boolean):void
startingIndex property
startingIndex:int [read-write]

The index into the dataProvider at which this Repeater starts creating children.

Implementation
    public function get startingIndex():int
    public function set startingIndex(value:int):void
Method detail
executeChildBindings () method
public function executeChildBindings():void

Executes the bindings into all the UIComponents created by this Repeater.

This method is called by the Flex framework. Developers should not need to call it.

initializeRepeater () method
public function initializeRepeater(container:Container, recurse:Boolean):void

Initializes a new Repeater object.

This method is called by the Flex framework. Developers should not need to call it.

Parameters
container:Container — The Container that contains this Repeater, and in which this Repeater will create its children.
recurse:Boolean — A Boolean flag indicating whether this Repeater should create all descendants of its children.


mx.core.IRepeaterClient (Flex™ 2 Language Reference)

Interface IRepeaterClient | Properties | Methods
Package | mx.core
Interface | public interface IRepeaterClient
Implementors | UIComponent

The IRepeaterClient interface defines the APIs for components that can have multiple instances created by a Repeater. The IRepeaterClient interface is implemented by the UIComponent class and so is inherited by all Flex framework controls and containers.

Public Properties
Property |  | Defined by
 | instanceIndices : Array An Array that contains the indices required to reference the repeated component instance from its document. | IRepeaterClient
 | isDocument : Boolean [read-only] Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | IRepeaterClient
 | repeaterIndices : Array An Array that contains the indices of the items in the data providers of the Repeaters that produced the component. | IRepeaterClient
 | repeaters : Array An Array that contains any enclosing Repeaters of the component. | IRepeaterClient
Public Methods
Method |  | Defined by
 | initializeRepeaterArrays(parent:IRepeaterClient):void Initializes the instanceIndices, repeaterIndices, and repeaters properties. | IRepeaterClient
Property detail
instanceIndices property
instanceIndices:Array [read-write]

An Array that contains the indices required to reference the repeated component instance from its document. This Array is empty unless the component is within one or more Repeaters. The first element corresponds to the outermost Repeater. For example, if the id is "b" and instanceIndices is [ 2, 4 ], you would reference it on the document as b[2][4].

Implementation
    public function get instanceIndices():Array
    public function set instanceIndices(value:Array):void
isDocument property
isDocument:Boolean [read-only]

Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component.

Implementation
    public function get isDocument():Boolean
repeaterIndices property
repeaterIndices:Array [read-write]

An Array that contains the indices of the items in the data providers of the Repeaters that produced the component. The Array is empty unless the component is within one or more Repeaters. The first element corresponds to the outermost Repeater component. For example, if repeaterIndices is [ 2, 4 ], the outer Repeater component used its dataProvider[2] data item and the inner Repeater component used its dataProvider[4] data item.

This property differs from instanceIndices if the startingIndex of any of the Repeater components is non-zero. For example, even if a Repeater component starts at dataProvider item 4, the document reference of the first repeated component is b[0], not b[4].

Implementation
    public function get repeaterIndices():Array
    public function set repeaterIndices(value:Array):void
repeaters property
repeaters:Array [read-write]

An Array that contains any enclosing Repeaters of the component. The Array is empty unless the component is within one or more Repeaters. The first element corresponds to the outermost Repeater.

Implementation
    public function get repeaters():Array
    public function set repeaters(value:Array):void
Method detail
initializeRepeaterArrays () method
public function initializeRepeaterArrays(parent:IRepeaterClient):void

Initializes the instanceIndices, repeaterIndices, and repeaters properties.

This method is called by the Flex framework. Developers should not need to call it.

Parameters
parent:IRepeaterClient


mx.core.IToolTip (Flex™ 2 Language Reference)

Interface IToolTip | Properties | Methods
Package | mx.core
Interface | public interface IToolTip extends IUIComponent, IFlexDisplayObject, IBitmapDrawable, IEventDispatcher
Implementors | ToolTip

The IToolTip interface defines the API that tooltip-like components must implement in order to work with the ToolTipManager. The ToolTip class implements this interface.

See also

mx.controls.ToolTip
mx.managers.ToolTipManager

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | alpha : Number The transparency of this object. | IFlexDisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | IUIComponent
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the object. | IUIComponent
Inherited | document : Object A reference to the document object associated with this component. | IUIComponent
Inherited | enabled : Boolean Whether the component can accept user interaction. | IUIComponent
Inherited | explicitHeight : Number The explicitly specified height for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | explicitWidth : Number The explicitly specified width for the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | focusPane : Sprite A single Sprite object that is shared among components and used as an overlay for drawing focus. | IUIComponent
Inherited | height : Number The height of this object, in pixels. | IFlexDisplayObject
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | IUIComponent
Inherited | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | measuredHeight : Number The measured height of this object. | IFlexDisplayObject
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | IUIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | IUIComponent
Inherited | measuredWidth : Number The measured width of this object. | IFlexDisplayObject
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | name : String The instance name of this object. | IFlexDisplayObject
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | IUIComponent
Inherited | owner : DisplayObjectContainer Your owner is usually your parent, however If you are a popup subcomponent, your owner will be the component that popped you up. | IUIComponent
Inherited | parent : DisplayObjectContainer The parent of this object. | IFlexDisplayObject
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | IUIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | IUIComponent
Inherited | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
Inherited | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
 | screen : Rectangle [read-only] A Rectangle that specifies the size and position of the base drawing surface for this tooltip. | IToolTip
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the surface of the component. | IUIComponent
Inherited | systemManager : ISystemManager A reference to the SystemManager object for this component. | IUIComponent
 | text : String The text that appears in the tooltip. | IToolTip
Inherited | tweeningProperties : Array Used by EffectManager. | IUIComponent
Inherited | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
Inherited | width : Number The width of this object, in pixels. | IFlexDisplayObject
Inherited | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Inherited | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
IUIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
IUIComponent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
initialize():void
Initialize the object.
IUIComponent
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
Inherited
owns(displayObject:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
IUIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
IUIComponent
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
IUIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
screen property
screen:Rectangle [read-only]

A Rectangle that specifies the size and position of the base drawing surface for this tooltip.

Implementation
    public function get screen():Rectangle
text property
text:String [read-write]

The text that appears in the tooltip.

Implementation
    public function get text():String
    public function set text(value:String):void


mx.core.IUIComponent (Flex™ 2 Language Reference)

Interface IUIComponent | Properties | Methods
Package | mx.core
Interface | public interface IUIComponent extends IFlexDisplayObject, IBitmapDrawable, IEventDispatcher
Subinterfaces | IAxisRenderer, IDeferredInstantiationUIComponent, IListItemRenderer, IToolTip
Implementors | UIComponent, UITextField

The IUIComponent interface defines the basic set of APIs that you must implement to create a child of a Flex container or list.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | alpha : Number The transparency of this object. | IFlexDisplayObject
 | baselinePosition : Number [read-only] Determines the baseline y-coordinate of the first line of text of the component. | IUIComponent
 | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the object. | IUIComponent
 | document : Object A reference to the document object associated with this component. | IUIComponent
 | enabled : Boolean Whether the component can accept user interaction. | IUIComponent
 | explicitHeight : Number The explicitly specified height for the component, in pixels, as the component's coordinates. | IUIComponent
 | explicitMaxHeight : Number [read-only] Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
 | explicitMaxWidth : Number [read-only] Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
 | explicitMinHeight : Number [read-only] Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
 | explicitMinWidth : Number [read-only] Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
 | explicitWidth : Number The explicitly specified width for the component, in pixels, as the component's coordinates. | IUIComponent
 | focusPane : Sprite A single Sprite object that is shared among components and used as an overlay for drawing focus. | IUIComponent
Inherited | height : Number The height of this object, in pixels. | IFlexDisplayObject
 | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | IUIComponent
Inherited | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
 | maxHeight : Number [read-only] Number that specifies the maximum height of the component, in pixels, as the component's coordinates. | IUIComponent
 | maxWidth : Number [read-only] Number that specifies the maximum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | measuredHeight : Number The measured height of this object. | IFlexDisplayObject
 | measuredMinHeight : Number The default minimum height of the component, in pixels. | IUIComponent
 | measuredMinWidth : Number The default minimum width of the component, in pixels. | IUIComponent
Inherited | measuredWidth : Number The measured width of this object. | IFlexDisplayObject
 | minHeight : Number [read-only] Number that specifies the minimum height of the component, in pixels, as the component's coordinates. | IUIComponent
 | minWidth : Number [read-only] Number that specifies the minimum width of the component, in pixels, as the component's coordinates. | IUIComponent
Inherited | name : String The instance name of this object. | IFlexDisplayObject
 | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | IUIComponent
 | owner : DisplayObjectContainer Your owner is usually your parent, however If you are a popup subcomponent, your owner will be the component that popped you up. | IUIComponent
Inherited | parent : DisplayObjectContainer The parent of this object. | IFlexDisplayObject
 | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | IUIComponent
 | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | IUIComponent
Inherited | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
Inherited | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
 | scrollRect : Rectangle The scroll rectangle bounds of the surface of the component. | IUIComponent
 | systemManager : ISystemManager A reference to the SystemManager object for this component. | IUIComponent
 | tweeningProperties : Array Used by EffectManager. | IUIComponent
Inherited | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
Inherited | width : Number The width of this object, in pixels. | IFlexDisplayObject
Inherited | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Inherited | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
IUIComponent
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
IUIComponent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
initialize():void
Initialize the object.
IUIComponent
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
IUIComponent
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
IUIComponent
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
IUIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
baselinePosition property
baselinePosition:Number [read-only]

Determines the baseline y-coordinate of the first line of text of the component.

Implementation
    public function get baselinePosition():Number
cacheAsBitmap property
cacheAsBitmap:Boolean [read-write]

If set to true, Flash Player caches an internal bitmap representation of the object. This can increase performance for display objects that contain complex vector content.

Implementation
    public function get cacheAsBitmap():Boolean
    public function set cacheAsBitmap(value:Boolean):void

See also

flash.display.DisplayObject.cacheAsBitmap
document property
document:Object [read-write]

A reference to the document object associated with this component. A document object is an Object at the top of the hierarchy of a Flex application, MXML component, or ActionScript component.

Implementation
    public function get document():Object
    public function set document(value:Object):void
enabled property
enabled:Boolean [read-write]

Whether the component can accept user interaction. If you set the enabled property to false for a container, Flex dims the color of the container and of all of its children, and blocks user input to the container and to all of its children.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void
explicitHeight property
explicitHeight:Number [read-write]

The explicitly specified height for the component, in pixels, as the component's coordinates. If no height is explicitly specified, the value is NaN.

Implementation
    public function get explicitHeight():Number
    public function set explicitHeight(value:Number):void

See also

mx.core.UIComponent.explicitHeight
explicitMaxHeight property
explicitMaxHeight:Number [read-only]

Number that specifies the maximum height of the component, in pixels, as the component's coordinates.

Implementation
    public function get explicitMaxHeight():Number

See also

mx.core.UIComponent.explicitMaxHeight
explicitMaxWidth property
explicitMaxWidth:Number [read-only]

Number that specifies the maximum width of the component, in pixels, as the component's coordinates.

Implementation
    public function get explicitMaxWidth():Number

See also

mx.core.UIComponent.explicitMaxWidth
explicitMinHeight property
explicitMinHeight:Number [read-only]

Number that specifies the minimum height of the component, in pixels, as the component's coordinates.

Implementation
    public function get explicitMinHeight():Number

See also

mx.core.UIComponent.explicitMinHeight
explicitMinWidth property
explicitMinWidth:Number [read-only]

Number that specifies the minimum width of the component, in pixels, as the component's coordinates.

Implementation
    public function get explicitMinWidth():Number

See also

mx.core.UIComponent.explicitMinWidth
explicitWidth property
explicitWidth:Number [read-write]

The explicitly specified width for the component, in pixels, as the component's coordinates. If no width is explicitly specified, the value is NaN.

Implementation
    public function get explicitWidth():Number
    public function set explicitWidth(value:Number):void

See also

mx.core.UIComponent.explicitWidth
focusPane property
focusPane:Sprite [read-write]

A single Sprite object that is shared among components and used as an overlay for drawing focus. Components share this object if their parent is a focused component, not if the component implements the IFocusManagerComponent interface.

Implementation
    public function get focusPane():Sprite
    public function set focusPane(value:Sprite):void

See also

mx.core.UIComponent.focusPane
includeInLayout property
includeInLayout:Boolean [read-write]

Specifies whether this component is included in the layout of the parent container. If true, the object is included in its parent container's layout. If false, the object is positioned by its parent container as per its layout rules, but it is ignored for the purpose of computing the position of the next child.

Implementation
    public function get includeInLayout():Boolean
    public function set includeInLayout(value:Boolean):void
maxHeight property
maxHeight:Number [read-only]

Number that specifies the maximum height of the component, in pixels, as the component's coordinates.

Implementation
    public function get maxHeight():Number

See also

mx.core.UIComponent.maxHeight
maxWidth property
maxWidth:Number [read-only]

Number that specifies the maximum width of the component, in pixels, as the component's coordinates.

Implementation
    public function get maxWidth():Number

See also

mx.core.UIComponent.maxWidth
measuredMinHeight property
measuredMinHeight:Number [read-write]

The default minimum height of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredMinHeight():Number
    public function set measuredMinHeight(value:Number):void
measuredMinWidth property
measuredMinWidth:Number [read-write]

The default minimum width of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredMinWidth():Number
    public function set measuredMinWidth(value:Number):void
minHeight property
minHeight:Number [read-only]

Number that specifies the minimum height of the component, in pixels, as the component's coordinates.

Implementation
    public function get minHeight():Number

See also

mx.core.UIComponent.minHeight
minWidth property
minWidth:Number [read-only]

Number that specifies the minimum width of the component, in pixels, as the component's coordinates.

Implementation
    public function get minWidth():Number

See also

mx.core.UIComponent.minWidth
opaqueBackground property
opaqueBackground:Object [read-write]

Specifies whether the display object is opaque with a certain background color. A transparent bitmap contains alpha channel data and is drawn transparently. An opaque bitmap has no alpha channel (and renders faster than a transparent bitmap). If the bitmap is opaque, you specify its own background color to use.

Implementation
    public function get opaqueBackground():Object
    public function set opaqueBackground(value:Object):void

See also

flash.display.DisplayObject.opaqueBackground
owner property
owner:DisplayObjectContainer [read-write]

Your owner is usually your parent, however If you are a popup subcomponent, your owner will be the component that popped you up. For example, a combobox dropdown's owner is the combobox. This property is not managed by the framework, but rather, by each component so if you popup sub-components you should set this property on them

Implementation
    public function get owner():DisplayObjectContainer
    public function set owner(value:DisplayObjectContainer):void
percentHeight property
percentHeight:Number [read-write]

Number that specifies the height of a component as a percentage of its parent's size. Allowed values are 0 to 100.

Implementation
    public function get percentHeight():Number
    public function set percentHeight(value:Number):void
percentWidth property
percentWidth:Number [read-write]

Number that specifies the width of a component as a percentage of its parent's size. Allowed values are 0 to 100.

Implementation
    public function get percentWidth():Number
    public function set percentWidth(value:Number):void
scrollRect property
scrollRect:Rectangle [read-write]

The scroll rectangle bounds of the surface of the component.

Implementation
    public function get scrollRect():Rectangle
    public function set scrollRect(value:Rectangle):void

See also

flash.display.DisplayObject.scrollRect
systemManager property
systemManager:ISystemManager [read-write]

A reference to the SystemManager object for this component.

Implementation
    public function get systemManager():ISystemManager
    public function set systemManager(value:ISystemManager):void
tweeningProperties property
tweeningProperties:Array [read-write]

Used by EffectManager. Returns non-null if a component is not using the EffectManager to execute a Tween.

Implementation
    public function get tweeningProperties():Array
    public function set tweeningProperties(value:Array):void
Method detail
getExplicitOrMeasuredHeight () method
public function getExplicitOrMeasuredHeight():Number

A convenience method for determining whether to use the explicit or measured height

Returns
Number — A Number which is explicitHeight if defined or measuredHeight if not.
getExplicitOrMeasuredWidth () method
public function getExplicitOrMeasuredWidth():Number

A convenience method for determining whether to use the explicit or measured width

Returns
Number — A Number which is explicitWidth if defined or measuredWidth if not.
initialize () method
public function initialize():void

Initialize the object.

See also

mx.core.UIComponent.initialize()
owns () method
public function owns(child:DisplayObject):Boolean

Returns true if the chain of owner properties points from child to this UIComponent.

Parameters
child:DisplayObject — A UIComponent.

Returns
Boolean — true if the child is parented or owned by this UIComponent.
parentChanged () method
public function parentChanged(p:DisplayObjectContainer):void

Called by Flex when a UIComponent object is added to or removed from a parent. Developers typically never need to call this method.

Parameters
p:DisplayObjectContainer — The parent of this UIComponent object.
setVisible () method
public function setVisible(value:Boolean, noEvent:Boolean = false):void

Called when the visible property changes. You should set the visible property to show or hide a component instead of calling this method directly.

Parameters
value:Boolean — The new value of the visible property. Specify true to show the component, and false to hide it.
noEvent:Boolean (default = false) — If true, do not dispatch an event. If false, dispatch a show event when the component becomes visible, and a hide event when the component becomes invisible.


mx.core.IUID (Flex™ 2 Language Reference)

Interface IUID | Properties
Package | mx.core
Interface | public interface IUID
Subinterfaces | IPropertyChangeNotifier

The IUID interface defines the interface for objects that must have Unique Identifiers (UIDs) to uniquely identify the object. UIDs do not need to be universally unique for most uses in Flex. One exception is for messages send by data services.

Public Properties
Property |  | Defined by
 | uid : String The unique identifier for this object. | IUID
Property detail
uid property
uid:String [read-write]

The unique identifier for this object.

Implementation
    public function get uid():String
    public function set uid(value:String):void


mx.core.MovieClipAsset (Flex™ 2 Language Reference)

Class MovieClipAsset | Properties | Methods | Events
Package | mx.core
Class | public class MovieClipAsset
Inheritance | MovieClipAsset Inheritance FlexMovieClip Inheritance MovieClip Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFlexAsset, IFlexDisplayObject
Subclasses | MovieClipLoaderAsset

MovieClipAsset is a subclass of the Flash Player's MovieClip class which represents movieclip symbols that you embed in a Flex application from a SWF file produced by Flash. It implements the IFlexDisplayObject interface, which makes it possible for the MovieClip to be displayed in an Image control, or to be used as a container background or a component skin.

The MovieClip that you're embedding must be a movieclip symbol that is in a SWF file. A common reason for using an embedded movieclip is that you have created a frame-based animation in Flash and want to use it in a Flex application. The MXML compiler autogenerates a class that extends MovieClipAsset to represent the embedded animation.

You don't generally have to use the MovieClipAsset class directly when you write a Flex application. For example, you can use a movieclip animation as an application's background image by writing the following:

  <mx:Application backgroundImage="@Embed(source='Assets.swf', symbol='BackgroundAnimation')"/>

or

  <mx:Style>
      Application
      {
          backgroundImage: Embed(source="Assets.swf", symbol="BackgroundAnimation")
      }
  <mx:Style/>

without having to understand that the MXML compiler has created a subclass of MovieClipAsset for you.

However, it may be useful to understand what is happening at the ActionScript level. To embed a movieclip in ActionScript, you declare a variable of type Class, and put [Embed] metadata on it. For example:

  [Bindable]
  [Embed(source="Assets.swf", symbol="BackgroundAnimation")]
  private var backgroundAnimationClass:Class;

The MXML compiler notices that the BackgroundAnimation symbol in Assets.swf is a movie clip, autogenerates a subclass of the MovieClipAsset class to represent it, and sets your variable to be a reference to this autogenerated class. You can then use this class reference to create instances of the MovieClipAsset using the new operator, and you can use APIs of the MovieClip class on them:

  var backgroundAnimation:MovieClipAsset =
      MovieClipAsset(new backgroundAnimationClass());
  var n:int = backgroundAnimation.totalFrames;

However, you rarely need to create MovieClipAsset instances yourself because image-related properties and styles can be set to an image-producing class, and components will create instances as necessary. For example, to set the application background to this animation, you can simply write the following:

  <mx:Application backgroundImage="{backgroundAnimationClass}"/>

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentFrame : int Specifies the number of the frame in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabel : String The current label in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabels : Array Returns an array of FrameLabel objects from the current scene. | MovieClip
Inherited | currentScene : Scene The current scene in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean A Boolean value that indicates whether a movie clip is enabled. | MovieClip
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | framesLoaded : int The number of frames that are loaded from a streaming SWF file. | MovieClip
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | measuredHeight : Number [read-only] The measured height of this object. | MovieClipAsset
 | measuredWidth : Number [read-only] The measured width of this object. | MovieClipAsset
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scenes : Array An array of Scene objects, each listing the name, the number of frames, and the frame labels for a scene in the MovieClip instance. | MovieClip
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | totalFrames : int The total number of frames in the MovieClip instance. | MovieClip
Inherited | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | MovieClip
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MovieClipAsset()
Constructor.
MovieClipAsset
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
gotoAndPlay(frame:Object, scene:String = null):void
Starts playing the SWF file at the specified frame.
MovieClip
Inherited
gotoAndStop(frame:Object, scene:String = null):void
Brings the playhead to the specified frame of the movie clip and stops it there.
MovieClip
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
MovieClipAsset
Inherited
nextFrame():void
Sends the playhead to the next frame and stops it.
MovieClip
Inherited
nextScene():void
Moves the playhead to the next scene of the MovieClip instance.
MovieClip
Inherited
play():void
Moves the playhead in the timeline of the movie clip.
MovieClip
Inherited
prevFrame():void
Sends the playhead to the previous frame and stops it.
MovieClip
Inherited
prevScene():void
Moves the playhead to the previous scene of the MovieClip instance.
MovieClip
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
MovieClipAsset
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stop():void
Stops the playhead in the movie clip.
MovieClip
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexMovieClip
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
measuredHeight property
measuredHeight:Number [read-only]

The measured height of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measured width of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredWidth():Number
Constructor detail
MovieClipAsset () constructor
public function MovieClipAsset()

Constructor.

Method detail
move () method
public function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The new x-position for this object.
y:Number — The new y-position for this object.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.


mx.core.MovieClipLoaderAsset (Flex™ 2 Language Reference)

Class MovieClipLoaderAsset | Properties | Methods | Events
Package | mx.core
Class | public class MovieClipLoaderAsset
Inheritance | MovieClipLoaderAsset Inheritance MovieClipAsset Inheritance FlexMovieClip Inheritance MovieClip Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFlexAsset, IFlexDisplayObject

MovieClipLoaderAsset is a subclass of the MovieClipAsset class which represents SWF files that you embed in a Flex application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentFrame : int Specifies the number of the frame in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabel : String The current label in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabels : Array Returns an array of FrameLabel objects from the current scene. | MovieClip
Inherited | currentScene : Scene The current scene in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean A Boolean value that indicates whether a movie clip is enabled. | MovieClip
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | framesLoaded : int The number of frames that are loaded from a streaming SWF file. | MovieClip
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | MovieClipAsset
Inherited | measuredWidth : Number The measured width of this object. | MovieClipAsset
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
 | movieClipData : ByteArray [read-only] A ByteArray containing the inner content. | MovieClipLoaderAsset
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scenes : Array An array of Scene objects, each listing the name, the number of frames, and the frame labels for a scene in the MovieClip instance. | MovieClip
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | totalFrames : int The total number of frames in the MovieClip instance. | MovieClip
Inherited | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | MovieClip
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Protected Properties
Property |  | Defined by
 | initialHeight : Number = 0 Backing storage for the measuredHeight property. | MovieClipLoaderAsset
 | initialWidth : Number = 0 Backing storage for the measuredWidth property. | MovieClipLoaderAsset
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MovieClipLoaderAsset()
Constructor.
MovieClipLoaderAsset
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
gotoAndPlay(frame:Object, scene:String = null):void
Starts playing the SWF file at the specified frame.
MovieClip
Inherited
gotoAndStop(frame:Object, scene:String = null):void
Brings the playhead to the specified frame of the movie clip and stops it there.
MovieClip
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
MovieClipAsset
Inherited
nextFrame():void
Sends the playhead to the next frame and stops it.
MovieClip
Inherited
nextScene():void
Moves the playhead to the next scene of the MovieClip instance.
MovieClip
Inherited
play():void
Moves the playhead in the timeline of the movie clip.
MovieClip
Inherited
prevFrame():void
Sends the playhead to the previous frame and stops it.
MovieClip
Inherited
prevScene():void
Moves the playhead to the previous scene of the MovieClip instance.
MovieClip
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
MovieClipAsset
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stop():void
Stops the playhead in the movie clip.
MovieClip
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexMovieClip
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | complete | Dispatched after the SWF asset has been fully loaded. | MovieClipLoaderAsset
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
initialHeight property
protected var initialHeight:Number = 0

Backing storage for the measuredHeight property. Subclasses should set this value in the constructor.

initialWidth property
protected var initialWidth:Number = 0

Backing storage for the measuredWidth property. Subclasses should set this value in the constructor.

movieClipData property
movieClipData:ByteArray [read-only]

A ByteArray containing the inner content. Overridden in subclasses.

Implementation
    public function get movieClipData():ByteArray
Constructor detail
MovieClipLoaderAsset () constructor
public function MovieClipLoaderAsset()

Constructor.

Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched after the SWF asset has been fully loaded.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.


mx.core.Repeater (Flex™ 2 Language Reference)

Class Repeater | Properties | Methods | Events | Styles | Effects | Constants | Examples
Package | mx.core
Class | public class Repeater
Inheritance | Repeater Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IRepeater

The Repeater class is the runtime object that corresponds to the <mx:Repeater> tag. It creates multiple instances of its subcomponents based on its dataProvider. The repeated components can be any standard or custom controls or containers.

You can use the <mx:Repeater> tag anywhere a control or container tag is allowed, with the exception of the <mx:Application> container tag. To repeat a user interface component, you place its tag in the <mx:Repeater> tag. You can use more than one <mx:Repeater> tag in an MXML document. You can also nest <mx:Repeater> tags.

You cannot use the <mx:Repeater> tag for objects that do not extend the UIComponent class.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <Repeater> class has the following properties:

  <mx:Repeater

    Properties
    id="No default"
    childDescriptors="No default"
    count="No default"
    dataProvider="No default"
    recycleChildren="false|true"
    startingIndex="0"
     Events
    repeat="No default"
    repeatEnd="No default"
    repeatStart="No default"
  >

View the examples.

See also

mx.core.Container
mx.core.UIComponent
mx.core.UIComponentDescriptor
flash.events.EventDispatcher
Dynamically repeating components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
 | childDescriptors : Array An Array of UIComponentDescriptor objects for this Repeater's children. | Repeater
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | container : Container [read-only] The container that contains this Repeater. | Repeater
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | count : int The number of times this Repeater should execute. | Repeater
 | currentIndex : int [read-only] The index of the item in the dataProvider currently being processed while this Repeater is executing. | Repeater
 | currentItem : Object [read-only] The item in the dataProvider currently being processed while this Repeater is executing. | Repeater
Inherited | currentState : String The current view state of the component. | UIComponent
 | dataProvider : Object The data provider used by this Repeater to create repeated instances of its children. | Repeater
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | recycleChildren : Boolean A Boolean flag indicating whether this Repeater should re-use previously created children, or create new ones. | Repeater
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | startingIndex : int The index into the dataProvider at which this Repeater starts creating children. | Repeater
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Repeater()
Constructor.
Repeater
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
executeChildBindings():void
Executes the bindings into all the UIComponents created by this Repeater.
Repeater
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
initializeRepeater(container:Container, recurse:Boolean):void
Initializes a new Repeater object.
Repeater
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
 | repeat | Dispatched each time an item is processed and the currentIndex and currentItem properties are updated. | Repeater
 | repeatEnd | Dispatched after all the subcomponents of a repeater are created. | Repeater
 | repeatStart | Dispatched when Flex begins processing the dataProvider property and begins creating the specified subcomponents. | Repeater
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
childDescriptors property
public var childDescriptors:Array

An Array of UIComponentDescriptor objects for this Repeater's children.

container property
container:Container [read-only]

The container that contains this Repeater.

Implementation
    public function get container():Container
count property
count:int [read-write]

The number of times this Repeater should execute.

If the Repeater reaches the end of the data provider while executing, the number of times it actually executes will be less that the requested count.

This property can be used as the source for data binding.

Implementation
    public function get count():int
    public function set count(value:int):void
currentIndex property
currentIndex:int [read-only]

The index of the item in the dataProvider currently being processed while this Repeater is executing.

After the Repeater has finished executing, this property is -1. However, the repeaterIndex property of a repeated component instance remembers the index of the dataProvider item from which it was created. In the case of nested Repeaters, you can use the repeaterIndices array.

This property can be used as the source for data binding.

Implementation
    public function get currentIndex():int
currentItem property
currentItem:Object [read-only]

The item in the dataProvider currently being processed while this Repeater is executing.

After the Repeater has finished executing, this property is null. However, in this case you can call the getRepeaterItem() method of the repeated component instance to get the dataProvider item from which it was created.

This property can be used as the source for data binding.

Implementation
    public function get currentItem():Object
dataProvider property
dataProvider:Object [read-write]

The data provider used by this Repeater to create repeated instances of its children.

If you read the dataProvider property, you always get an ICollectionView object or null. If you set the dataProvider property to anything other than null, it is converted into an ICollectionView object, according the following rules:

  • If you set it to an Array, it is converted into an ArrayCollection.
  • If you set it to an ICollectionView, no conversion is performed.
  • If you set it to an IList, it is converted into a ListCollectionView.
  • If you set it to an XML or XMLList, it is converted into an XMLListCollection.
  • Otherwise, it is converted to a single-element ArrayCollection.

You must specify a value for the dataProvider property or the Repeater component will not execute.

This property can be used as the source for data binding.

Implementation
    public function get dataProvider():Object
    public function set dataProvider(value:Object):void
recycleChildren property
recycleChildren:Boolean [read-write]

A Boolean flag indicating whether this Repeater should re-use previously created children, or create new ones.

If true, when this Repeater's dataProvider, startingIndex, or count changes, it will recycle the existing children by binding the new data into them. If more children are required, they are created and added. If fewer children are required, the extra ones are removed and garbage collected.

If false, when this Repeater's dataProvider, startingIndex, or count changes, it will remove any previous children that it created and then create and add new children from the new data items.

This property is false by default. Setting it to true can increase performance, but is not appropriate in all situations. For example, if the previously created children have state information such as text typed in by a user, then this state will not get reset when the children are recycled.

Implementation
    public function get recycleChildren():Boolean
    public function set recycleChildren(value:Boolean):void
startingIndex property
startingIndex:int [read-write]

The index into the dataProvider at which this Repeater starts creating children.

This property can be used as the source for data binding.

Implementation
    public function get startingIndex():int
    public function set startingIndex(value:int):void
Constructor detail
Repeater () constructor
public function Repeater()

Constructor.

Method detail
executeChildBindings () method
public function executeChildBindings():void

Executes the bindings into all the UIComponents created by this Repeater.

This method is called by the Flex framework. Developers should not need to call it.

initializeRepeater () method
public function initializeRepeater(container:Container, recurse:Boolean):void

Initializes a new Repeater object.

This method is called by the Flex framework. Developers should not need to call it.

Parameters
container:Container — The Container that contains this Repeater, and in which this Repeater will create its children.
recurse:Boolean — A Boolean flag indicating whether this Repeater should create all descendants of its children.
Event detail
repeat event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.REPEAT

Dispatched each time an item is processed and the currentIndex and currentItem properties are updated.

The FlexEvent.REPEAT constant defines the value of the type property of the event object for a repeat event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
repeatEnd event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.REPEAT_END

Dispatched after all the subcomponents of a repeater are created. This event is triggered even if the dataProvider property is empty or null.

The FlexEvent.REPEAT_END constant defines the value of the type property of the event object for a repeatEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
repeatStart event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.REPEAT_START

Dispatched when Flex begins processing the dataProvider property and begins creating the specified subcomponents. This event is triggered even if the dataProvider property is empty or null.

The FlexEvent.REPEAT_START constant defines the value of the type property of the event object for a repeatStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
RepeaterExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Repeater class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.controls.Alert;

            [Bindable]
            private var dp:Array = [1, 2, 3, 4, 5, 6, 7, 8, 9];

        ]]>
    </mx:Script>

    <mx:Panel title="Repeater Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Use the Repeater class to create 9 Button controls in a 3 by 3 Tile container."/>

        <mx:Tile direction="horizontal" borderStyle="inset"
            horizontalGap="10" verticalGap="15"
            paddingLeft="10" paddingTop="10" paddingBottom="10" paddingRight="10">

            <mx:Repeater id="rp" dataProvider="{dp}">
                <mx:Button height="49" width="50"
                    label="{String(rp.currentItem)}"
                    click="Alert.show(String(event.currentTarget.getRepeaterItem()) + ' pressed')"/>
            </mx:Repeater>
        </mx:Tile>

    </mx:Panel>
</mx:Application>


mx.core.ScrollControlBase (Flex™ 2 Language Reference)

Class ScrollControlBase | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.core
Class | public class ScrollControlBase
Inheritance | ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | ListBase, TextArea

The ScrollControlBase class is the base class for controls with scroll bars. The user interacts with the scroll bar or the developer accesses methods and properties that alter the viewable area. The ScrollControlBase takes a single child object and positions and masks or sizes that object to display the viewable content. All items to be scrolled must be children of that content object

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <ScrollControlBase> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:tagname
 Properties
  border="object of border skin style"
  horizontalScrollPolicy="off|on|auto"
  horizontalScrollPosition="0"
  liveScrolling="true|false"
  maxHorizontalScrollPosition="NaN"
  maxVerticalScrollPosition="NaN"
  scrollTipFunction="undefined"
  showScrollTips="false|true"
  verticalScrollPolicy="auto|off|on"
  verticalScrollPosition="0"

  Styles
  backgroundAlpha="1.0"
  backgroundColor="undefined"
  backgroundImage="undefined"
  backgroundSize="auto"
  borderColor="0xAAB3B3"
  borderSides="left top right bottom"
  borderSkin="ClassReference('mx.skins.halo.HaloBorder')"
  borderStyle="inset"
  borderThickness="1"
  color="0x0B333C"
  cornerRadius="0"
  disabledColor="0xAAB3B3"
  dropShadowColor="0x000000"
  dropShadowEnabled="false"
  fontFamily="Verdana"
  fontSize="10"
  fontStyle="normal|italic"
  fontWeight="normal|bold"
  horizontalScrollBarStyleName=""
  leading="2"
  repeatDelay"500"
  repeatInterval"35"
  shadowDirection="center"
  shadowDistance="2"
  textAlign="value; see detail."
  textDecoration="none|underline"
  textIndent="0"
  verticalScrollBarStyleName=""

  Events
  scroll="No default"
  />

See also

ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
 | borderMetrics : EdgeMetrics [read-only] Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | horizontalScrollPolicy : String A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
 | horizontalScrollPosition : Number The offset into the content from the left edge. | ScrollControlBase
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
 | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxHorizontalScrollPosition : Number The maximum value for the horizontalScrollPosition property. | ScrollControlBase
 | maxVerticalScrollPosition : Number The maximum value for the verticalScrollPosition property. | ScrollControlBase
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
 | scrollTipFunction : Function A function that computes the string to be displayed as the ScrollTip. | ScrollControlBase
 | showScrollTips : Boolean = false A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. | ScrollControlBase
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | verticalScrollPolicy : String A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. | ScrollControlBase
 | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
 | viewMetrics : EdgeMetrics [read-only] An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
 | border : IFlexDisplayObject The border object. | ScrollControlBase
 | horizontalScrollBar : ScrollBar The horizontal scroll bar. | ScrollControlBase
 | maskShape : Shape The mask. | ScrollControlBase
 | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
 | verticalScrollBar : ScrollBar The vertical scroll bar. | ScrollControlBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ScrollControlBase()
Constructor.
ScrollControlBase
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
 | createBorder():void Creates the border for this component. | ScrollControlBase
 | createChildren():void Creates objects that are children of this ScrollControlBase, which in this case are the border and mask. | ScrollControlBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this control's borders. | ScrollControlBase
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | mouseWheelHandler(event:MouseEvent):void Event handler for the mouse wheel scroll event. | ScrollControlBase
 | scrollHandler(event:Event):void Default event handler for the scroll event. | ScrollControlBase
 | setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in. | ScrollControlBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style Description Defined by
backgroundAlpha
Type: Number CSS Inheritance: no
Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. Valid values range from 0.0 to 1.0. The default value is 1.0. 		ScrollControlBase
backgroundColor
Type: uint Format: Color CSS Inheritance: no
Background color of a component. You can have both a backgroundColor and a backgroundImage set. Some components do not have a background. The DataGrid control ignores this style. The default value is undefined, which means it is not set. If both this style and the backgroundImage style are undefined, the component has a transparent background.

For the Application container, this style specifies the background color while the application loads, and a background gradient while it is running. Flex calculates the gradient pattern between a color slightly darker than the specified color, and a color slightly lighter than the specified color.

The default skins of most Flex controls are partially transparent. As a result, the background color of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

ScrollControlBase
backgroundImage
Type: Object Format: File CSS Inheritance: no
Background image of a component. This can be an absolute or relative URL or class. You can either have both a backgroundColor and a backgroundImage set at the same time. The background image is displayed on top of the background color. The default value is undefined, meaning "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The default skins of most Flex controls are partially transparent. As a result, the background image of a container partially "bleeds through" to controls that are in that container. You can avoid this by setting the alpha values of the control's fillAlphas property to 1, as the following example shows:

  <mx:Container backgroundColor="0x66CC66"/>
   <mx:ControlName ... fillAlphas="[1,1]"/>
  </mx:Container>

ScrollControlBase
backgroundSize
Type: String CSS Inheritance: no
Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). The default value is "auto", which maintains the original size of the image. 		ScrollControlBase
borderColor
Type: uint Format: Color CSS Inheritance: no
Color of the border. The default value depends on the component class; if not overridden for the class, the default value is 0xB7BABC. 		ScrollControlBase
borderSides
Type: String CSS Inheritance: no
Bounding box sides. A space-delimited String that specifies the sides of the border to show. The String can contain "left", "top", "right", and "bottom" in any order. The default value is "left top right bottom", which shows all four sides. This style is only used when borderStyle is "solid". 		ScrollControlBase
borderSkin
Type: Class CSS Inheritance: no
The border skin of the component. The default value is mx.skins.halo.HaloBorder. 		ScrollControlBase
borderStyle
Type: String CSS Inheritance: no
Bounding box style. The possible values are "none", "solid", "inset", and "outset". The default value depends on the component class; if not overridden for the class, the default value is "inset". The default value for most Containers is "none". 		ScrollControlBase
borderThickness
Type: Number Format: Length CSS Inheritance: no
Bounding box thickness. Only used when borderStyle is set to "solid". The default value is 1. 		ScrollControlBase
Inherited
bottom
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. 		UIComponent
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		ScrollControlBase
cornerRadius
Type: Number Format: Length CSS Inheritance: no
Radius of component corners. The default value depends on the component class; if not overriden for the class, the default value is 0. The default value for ApplicationControlBar is 5. 		ScrollControlBase
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		ScrollControlBase
dropShadowColor
Type: uint Format: Color CSS Inheritance: yes
Color of the drop shadow. The default value is 0x000000. 		ScrollControlBase
dropShadowEnabled
Type: Boolean CSS Inheritance: no
Boolean property that specifies whether the component has a visible drop shadow. This style is used with borderStyle="solid". The default value is false.

Note: For drop shadows to appear on containers, set backgroundColor or backgroundImage properties. Otherwise, the shadow appears behind the container because the default background of a container is transparent.

ScrollControlBase
Inherited
errorColor
Type: uint Format: Color CSS Inheritance: yes
Color of the component highlight when validation fails.. 		UIComponent
Inherited
focusBlendMode
Type: String CSS Inheritance: no
Blend mode used by the focus rectangle. 		UIComponent
Inherited
focusSkin
Type: Class CSS Inheritance: no
Skin used to draw the focus rectangle. 		UIComponent
Inherited
focusThickness
Type: Number Format: Length CSS Inheritance: no
Thickness, in pixels, of the focus rectangle outline. 		UIComponent
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		ScrollControlBase
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		ScrollControlBase
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		ScrollControlBase
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ScrollControlBase
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		ScrollControlBase
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		ScrollControlBase
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		ScrollControlBase
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		ScrollControlBase
Inherited
horizontalCenter
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
horizontalScrollBarStyleName
Type: String CSS Inheritance: no
Style name for horizontal scrollbar. This allows more control over the appearance of the scrollbar. The default value is undefined. 		ScrollControlBase
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

ScrollControlBase
Inherited
left
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. 		UIComponent
repeatDelay
Type: Number Format: Time CSS Inheritance: no
Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. This value affects the delay before the control starts scrolling repeatedly if the user holds down the mouse button on a scrollbar arrow. The default value is 500. 		ScrollControlBase
repeatInterval
Type: Number Format: Time CSS Inheritance: no
Number of milliseconds between buttonDown events if the user presses and holds on a button. This value affects how fast the control scrolls if the user holds down the mouse button on a scrollbar arrow. The default value is 35. 		ScrollControlBase
Inherited
right
Type: Number Format: Length CSS Inheritance: no
The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. 		UIComponent
shadowDirection
Type: String CSS Inheritance: no
Direction of the drop shadow. Possible values are "left", "center", and "right". The default value is "center". 		ScrollControlBase
shadowDistance
Type: Number Format: Length CSS Inheritance: no
Distance of the drop shadow. If the property is set to a negative value, the shadow appears above the component. The default value is 2. 		ScrollControlBase
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

ScrollControlBase
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		ScrollControlBase
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		ScrollControlBase
Inherited
themeColor
Type: uint Format: Color CSS Inheritance: yes
Theme color of a component. 		UIComponent
Inherited
top
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. 		UIComponent
Inherited
verticalCenter
Type: Number Format: Length CSS Inheritance: no
The vertical distance in pixels from the center of the component's parent container to the center of the component. 		UIComponent
verticalScrollBarStyleName
Type: String CSS Inheritance: no
Style name for vertical scrollbar. This allows more control over the appearance of the scrollbar. The default value is undefined. 		ScrollControlBase
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
border property
protected var border:IFlexDisplayObject

The border object.

borderMetrics property
borderMetrics:EdgeMetrics [read-only]

Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. The value of each property is equal to the thickness of one side of the border, expressed in pixels.

Implementation
    public function get borderMetrics():EdgeMetrics
horizontalScrollBar property
protected var horizontalScrollBar:ScrollBar

The horizontal scroll bar. This property is null if no horizontal scroll bar is currently displayed. In general you do not access this property directly. Manipulation of the horizontalScrollPolicy and horizontalScrollPosition properties should provide sufficient control over the scroll bar.

horizontalScrollPolicy property
horizontalScrollPolicy:String [read-write]

A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. Allowed values are ScrollPolicy.ON, ScrollPolicy.OFF, and ScrollPolicy.AUTO. MXML values can be "on", "off", and "auto".

Setting this property to ScrollPolicy.OFF for ListBase subclasses does not affect the horizontalScrollPosition property; you can still scroll the contents programmatically.

Note that the policy can affect the measured size of the component If the policy is ScrollPolicy.AUTO the scrollbar is not factored in the measured size. This is done to keep the layout from recalculating when the scrollbar appears. If you know that you will have enough data for scrollbars you should set the policy to ScrollPolicy.ON. If you don't know, you may need to set an explicit width or height on the component to allow for scrollbars to appear later.

The default value is ScrollPolicy.OFF.

This property can be used as the source for data binding.

Implementation
    public function get horizontalScrollPolicy():String
    public function set horizontalScrollPolicy(value:String):void
horizontalScrollPosition property
horizontalScrollPosition:Number [read-write]

The offset into the content from the left edge. This can be a pixel offset in some subclasses or some other metric like the number of columns in a DataGrid or number of items in a HorizontalList or TileList.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get horizontalScrollPosition():Number
    public function set horizontalScrollPosition(value:Number):void
liveScrolling property
public var liveScrolling:Boolean = true

A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. The default value is true.

maskShape property
protected var maskShape:Shape

The mask. This property may be undefined if no scroll bars are currently displayed or in some subclasses which have a different masking mechanism. A mask defined the viewable area of a displayable object. Thus this mask is used to hide the portions of the content that are not currently viewable. In general you do not access this property directly. Manipulation of the horizontalScrollPolicy, verticalScrollPolicy, horizontalScrollPosition, and verticalScrollPosition properties should provide sufficient control over the mask.

maxHorizontalScrollPosition property
maxHorizontalScrollPosition:Number [read-write]

The maximum value for the horizontalScrollPosition property. Note that this is not the width of the content because the maxHorizontalScrollPosition property contains the width of the content minus the width of the displayable area.

In most components, the value of the maxHorizontalScrollPosition property is computed from the data and size of component, and must not be set by the application code.

This property can be used as the source for data binding.

Implementation
    public function get maxHorizontalScrollPosition():Number
    public function set maxHorizontalScrollPosition(value:Number):void
maxVerticalScrollPosition property
maxVerticalScrollPosition:Number [read-write]

The maximum value for the verticalScrollPosition property. Note that this is not the height of the content because the maxVerticalScrollPosition property contains the height of the content minus the height of the displayable area.

The value of the maxVerticalScrollPosition property is computed from the data and size of component, and must not be set by the application code.

This property can be used as the source for data binding.

Implementation
    public function get maxVerticalScrollPosition():Number
    public function set maxVerticalScrollPosition(value:Number):void
scrollAreaChanged property
protected var scrollAreaChanged:Boolean

A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. Used by most layout methods to re-adjust the scrolling properties again.

scrollTipFunction property
scrollTipFunction:Function [read-write]

A function that computes the string to be displayed as the ScrollTip. This function is called if the showScrollTips property is set to true and the scroll thumb is being dragged. The function should return a String that used as a ScrollTip. The function is passed two parameters. The first is the direction of the scroll bar. The second is its scrollPosition, as the following example shows:

   function scrollTipFunction(direction:String, position:Number):String
   {
     if (direction == "vertical") return myToolTips[position];
     else return "";
   }

This property can be used as the source for data binding.

Implementation
    public function get scrollTipFunction():Function
    public function set scrollTipFunction(value:Function):void
showScrollTips property
public var showScrollTips:Boolean = false

A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged. The default value is false to disable the tooltip.

verticalScrollBar property
protected var verticalScrollBar:ScrollBar

The vertical scroll bar. This property is null if no vertical scroll bar is currently displayed. In general you do not access this property directly. Manipulation of the verticalScrollPolicy and verticalScrollPosition properties should provide sufficient control over the scroll bar.

verticalScrollPolicy property
verticalScrollPolicy:String [read-write]

A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method. Allowed values are ScrollPolicy.ON, ScrollPolicy.OFF, and ScrollPolicy.AUTO. MXML values can be "on", "off", and "auto".

Setting this property to ScrollPolicy.OFF for ListBase subclasses does not affect the verticalScrollPosition property; you can still scroll the contents programmatically.

Note that the policy can affect the measured size of the component If the policy is ScrollPolicy.AUTO the scrollbar is not factored in the measured size. This is done to keep the layout from recalculating when the scrollbar appears. If you know that you will have enough data for scrollbars you should set the policy to ScrollPolicy.ON. If you don't know, you may need to set an explicit width or height on the component to allow for scrollbars to appear later.

The default value is ScrollPolicy.AUTO.

This property can be used as the source for data binding.

Implementation
    public function get verticalScrollPolicy():String
    public function set verticalScrollPolicy(value:String):void
verticalScrollPosition property
verticalScrollPosition:Number [read-write]

The offset into the content from the top edge. This can be a pixel offset in some subclasses or some other metric like number of lines in a List or number of tiles in a TileList.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get verticalScrollPosition():Number
    public function set verticalScrollPosition(value:Number):void
viewMetrics property
viewMetrics:EdgeMetrics [read-only]

An EdgeMetrics object taking into account the scroll bars, if visible.

Implementation
    public function get viewMetrics():EdgeMetrics
Constructor detail
ScrollControlBase () constructor
public function ScrollControlBase()

Constructor.

Method detail
createBorder () method
protected function createBorder():void

Creates the border for this component. Normally the border is determined by the borderStyle and borderSkin styles. It must set the border property to the instance of the border.

createChildren () method
protected override function createChildren():void

Creates objects that are children of this ScrollControlBase, which in this case are the border and mask. Flex calls this method when the ScrollControlBase is first created. If a subclass overrides this method, the subclass should call the super.createChildren() method so that the logic in the ScrollControlBase.createChildren() method is executed.

layoutChrome () method
protected function layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void

Responds to size changes by setting the positions and sizes of this control's borders.

The ScrollControlBase.layoutChrome() method sets the position and size of the ScrollControlBase's border. In every subclass of ScrollControlBase, the subclass's layoutChrome() method should call the super.layoutChrome() method, so that the border is positioned properly.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.
mouseWheelHandler () method
protected function mouseWheelHandler(event:MouseEvent):void

Event handler for the mouse wheel scroll event.

Parameters
event:MouseEvent — The event object.
scrollHandler () method
protected function scrollHandler(event:Event):void

Default event handler for the scroll event.

Parameters
event:Event — The event object.
setScrollBarProperties () method
protected function setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int):void

Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in. If a TextArea can only show 100 pixels across and 5 lines of text, but the actual text to display is 200 pixels wide and 30 lines of text, then the setScrollBarProperties() method is called as setScrollBarProperties(200, 100, 30, 5).

Parameters
totalColumns:int — The number of horizontal units that need to be displayed.
visibleColumns:int — The number of horizontal units that can be displayed at one time.
totalRows:int — The number of vertical units that need to be displayed.
visibleRows:int — The number of vertical units that can be displayed at one time
Event detail
scroll event
Event object type: mx.events.ScrollEvent
ScrollEvent.type property = mx.events.ScrollEvent.SCROLL

Dispatched when the content is scrolled.

The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the change in scroll position, expressed in pixels. A positive value indicates the scroll was down or to the right. A negative value indicates the scroll was up or to the left.
direction | Contains the scroll direction, either ScrollEventDirection.HORIZONTAL or ScrollEventDirection.VERTICAL.
position | Contains the new scroll position.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.core.ScrollPolicy (Flex™ 2 Language Reference)

Class ScrollPolicy | Properties | Methods | Constants
Package | mx.core
Class | public final class ScrollPolicy
Inheritance | ScrollPolicy Inheritance Object

Values for the horizontalScrollPolicy and verticalScrollPolicy properties of the Container and ScrollControlBase classes.

See also

mx.core.Container
mx.core.ScrollControlBase
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | AUTO : String = "auto" [static] Show the scrollbar if the children exceed the owner's dimension. | ScrollPolicy
 | OFF : String = "off" [static] Never show the scrollbar. | ScrollPolicy
 | ON : String = "on" [static] Always show the scrollbar. | ScrollPolicy
Constant detail
AUTO constant
public static const AUTO:String = "auto"

Show the scrollbar if the children exceed the owner's dimension. The size of the owner is not adjusted to account for the scrollbars when they appear, so this may cause the scrollbar to obscure the contents of the control or container.

OFF constant
public static const OFF:String = "off"

Never show the scrollbar.

ON constant
public static const ON:String = "on"

Always show the scrollbar. The size of the scrollbar is automatically added to the size of the owner's contents to determine the size of the owner if explicit sizes are not specified.


mx.core.SoundAsset (Flex™ 2 Language Reference)

Class SoundAsset | Properties | Methods | Events
Package | mx.core
Class | public class SoundAsset
Inheritance | SoundAsset Inheritance Sound Inheritance EventDispatcher Inheritance Object
Implements | IFlexAsset

SoundAsset is a subclass of the Flash Player's Sound class which represents sounds that you embed in a Flex application.

The sound that you're embedding can be in an MP3 file. You can also embed a sound symbol that is in a SWF file produced by Flash. In both cases, the MXML compiler autogenerates a class that extends SoundAsset to represent the embedded sound data.

You don't generally have to use the SoundAsset class directly when you write a Flex application. For example, you can embed an MP3 file and use it in a SoundEffect simply by writing the following:

  <mx:SoundEffect id="beep" source="@Embed(source='Beep.mp3')"/>

without having to understand that the MXML compiler has created a subclass of SoundAsset for you.

However, it may be useful to understand what is happening at the ActionScript level. To embed a bitmap in ActionScript, you declare a variable of type Class, and put [Embed] metadata on it. For example, you embed an MP3 file like this:

  [Bindable]
  [Embed(source="Beep.mp3")]
  private var beepClass:Class;

The MXML compiler sees the .mp3 extension, transcodes the MP3 data into the sound format that the Flash Player uses, autogenerates a subclass of the SoundAsset class, and sets your variable to be a reference to this autogenerated class. You can then use this class reference to create instances of the SoundAsset using the new operator, and you can use APIs of the Sound class on them:

    var beepSound:SoundAsset = SoundAsset(new beepClass());
    beepSound.play();

However, you rarely need to create SoundAsset instances yourself because sound-related properties and styles can simply be set to a sound-producing class, and components will create sound instances as necessary. For example, to play this sound with a SoundEffect, you can set the SoundEffect's source property to beepClass. In MXML you could do this as follows:

  <mx:SoundEffect id="beepEffect" source="{beepClass}"/>

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bytesLoaded : uint Returns the currently available number of bytes in this sound object. | Sound
Inherited | bytesTotal : int Returns the total number of bytes in this sound object. | Sound
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | id3 : ID3Info Provides access to the metadata that is part of an MP3 file. | Sound
Inherited | isBuffering : Boolean Returns the buffering state of external MP3 files. | Sound
Inherited | length : Number The length of the current sound in milliseconds. | Sound
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | url : String The URL from which this sound was loaded. | Sound
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SoundAsset()
Constructor.
SoundAsset
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
close():void
Closes the stream, causing any download of data to cease.
Sound
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
load(stream:URLRequest, context:SoundLoaderContext = null):void
Initiates loading of an external MP3 file from the specified URL.
Sound
Inherited
play(startTime:Number = 0, loops:int = 0, sndTransform:SoundTransform = null):SoundChannel
Generates a new SoundChannel object to play back the sound.
Sound
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | complete | Dispatched when data has loaded successfully. | Sound
Inherited | id3 | Dispatched by a Sound object when ID3 data is available for an MP3 sound. | Sound
Inherited | ioError | Dispatched when an input/output error occurs that causes a load operation to fail. | Sound
Inherited | open | Dispatched when a load operation starts. | Sound
Inherited | progress | Dispatched when data is received as a load operation progresses. | Sound
Constructor detail
SoundAsset () constructor
public function SoundAsset()

Constructor.


mx.core.SpriteAsset (Flex™ 2 Language Reference)

Class SpriteAsset | Properties | Methods | Events
Package | mx.core
Class | public class SpriteAsset
Inheritance | SpriteAsset Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFlexAsset, IFlexDisplayObject
Subclasses | DataGridHeaderSeparator

SpriteAsset is a subclass of the Flash Player's Sprite class which represents vector graphic images that you embed in a Flex application. It implements the IFlexDisplayObject interface, which makes it possible for an embedded vector graphic image to be displayed in an Image control, or to be used as a container background or a component skin.

The vector graphic image that you're embedding can be in an SVG file. You can also embed a sprite symbol that is in a SWF file produced by Flash. In both cases, the MXML compiler autogenerates a class that extends SpriteAsset to represent the embedded vector graphic image.

You don't generally have to use the SpriteAsset class directly when you write a Flex application. For example, you can embed a sprite symbol from a SWF file and display it in an Image control by writing the following:

  <mx:Image id="logo" source="@Embed(source='Assets.swf', symbol='Logo')"/>

Or use it as the application's background image in CSS syntax by writing the following:

  <mx:Style>
      Application
      {
          backgroundImage: Embed(source="Assets.swf", symbol='Logo')
      }
  <mx:Style/>

without having to understand that the MXML compiler has created a subclass of BitmapAsset for you.

However, it may be useful to understand what is happening at the ActionScript level. To embed a vector graphic image in ActionScript, you declare a variable of type Class, and put [Embed] metadata on it. For example, you embed a sprite symbol from a SWF file like this:

  [Bindable]
  [Embed(source="Assets.swf", symbol="Logo")]
  private var logoClass:Class;

The MXML compiler notices that the Logo symbol in Assets.swf is a sprite, autogenerates a subclass of the SpriteAsset class to represent it, and sets your variable to be a reference to this autogenerated class. You can then use this class reference to create instances of the SpriteAsset using the new operator, and use APIs of the Sprite class on them:

  var logo:SpriteAsset = SpriteAsset(new logoClass());
  addChild(logo);

However, you rarely need to create SpriteAsset instances yourself because image-related properties and styles can simply be set to an image-producing class, and components will create image instances as necessary. For example, to display this vector graphic image in an Image control, you can set the Image's source property to logoClass. In MXML you could do this as follows:

  <mx:Image id="logo" source="{logoClass}"/>

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | measuredHeight : Number [read-only] The measured height of this object. | SpriteAsset
 | measuredWidth : Number [read-only] The measured width of this object. | SpriteAsset
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SpriteAsset()
Constructor.
SpriteAsset
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
SpriteAsset
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
SpriteAsset
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
measuredHeight property
measuredHeight:Number [read-only]

The measured height of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measured width of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredWidth():Number
Constructor detail
SpriteAsset () constructor
public function SpriteAsset()

Constructor.

Method detail
move () method
public function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The new x-position for this object.
y:Number — The new y-position for this object.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.


mx.core.TextFieldAsset (Flex™ 2 Language Reference)

Class TextFieldAsset | Properties | Methods | Events
Package | mx.core
Class | public class TextFieldAsset
Inheritance | TextFieldAsset Inheritance FlexTextField Inheritance TextField Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFlexAsset, IFlexDisplayObject

TextFieldAsset is a subclass of the Flash Player's TextField class which represents TextField symbols that you embed in a Flex application from a SWF file produced by Flash. It implements the IFlexDisplayObject interface, which makes it possible for a TextFieldAsset to be displayed in an Image control, or to be used as a container background or a component skin.

This class is included in Flex for completeness, so that any kind of symbol in a SWF file produced by Flash can be embedded in a Flex application. However, Flex applications do not typically use embedded TextFields. Refer to more commonly-used asset classes such as BitmapAsset for more information about how embedded assets work in Flex.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | alwaysShowSelection : Boolean When set to true and the text field is not in focus, Flash Player highlights the selection in the text field in gray. | TextField
Inherited | antiAliasType : String The type of anti-aliasing used for this text field. | TextField
Inherited | autoSize : String Controls automatic sizing and alignment of text fields. | TextField
Inherited | background : Boolean Specifies whether the text field has a background fill. | TextField
Inherited | backgroundColor : uint The color of the text field background. | TextField
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | border : Boolean Specifies whether the text field has a border. | TextField
Inherited | borderColor : uint The color of the text field border. | TextField
Inherited | bottomScrollV : int An integer (1-based index) that indicates the bottommost line that is currently visible in the specified text field. | TextField
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | caretIndex : int The index of the insertion point (caret) position. | TextField
Inherited | condenseWhite : Boolean A Boolean value that specifies whether extra white space (spaces, line breaks, and so on) in a text field with HTML text should be removed. | TextField
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | defaultTextFormat : TextFormat Specifies the format applied to newly inserted text, such as text inserted with the replaceSelectedText() method or text entered by a user. | TextField
Inherited | displayAsPassword : Boolean Specifies whether the text field is a password text field. | TextField
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | embedFonts : Boolean Specifies whether to render by using embedded font outlines. | TextField
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | gridFitType : String The type of grid fitting used for this text field. | TextField
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | htmlText : String Contains the HTML representation of the text field's contents. | TextField
Inherited | length : int The number of characters in a text field. | TextField
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxChars : int The maximum number of characters that the text field can contain, as entered by a user. | TextField
Inherited | maxScrollH : int The maximum value of scrollH. | TextField
Inherited | maxScrollV : int The maximum value of scrollV. | TextField
 | measuredHeight : Number [read-only] The measured height of this object. | TextFieldAsset
 | measuredWidth : Number [read-only] The measured width of this object. | TextFieldAsset
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseWheelEnabled : Boolean A Boolean value that indicates whether Flash Player should automatically scroll multiline text fields when the user clicks a text field and rolls the mouse wheel. | TextField
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | multiline : Boolean Indicates whether the text field is a multiline text field. | TextField
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numLines : int Defines the number of text lines in a multiline text field. | TextField
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | restrict : String Indicates the set of characters that a user can enter into the text field. | TextField
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollH : int The current horizontal scrolling position. | TextField
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollV : int The vertical position of text in a text field. | TextField
Inherited | selectable : Boolean A Boolean value that indicates whether the text field is selectable. | TextField
Inherited | selectionBeginIndex : int The zero-based character index value of the first character in the current selection. | TextField
Inherited | selectionEndIndex : int The zero-based character index value of the last character in the current selection. | TextField
Inherited | sharpness : Number The sharpness of the glyph edges in this text field. | TextField
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleSheet : StyleSheet Attaches a style sheet to the text field. | TextField
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String A string that is the current text in the text field. | TextField
Inherited | textColor : uint The color of the text in a text field, in hexadecimal format. | TextField
Inherited | textHeight : Number The height of the text in pixels. | TextField
Inherited | textWidth : Number The width of the text in pixels. | TextField
Inherited | thickness : Number The thickness of the glyph edges in this text field. | TextField
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | type : String The type of the text field. | TextField
Inherited | useRichTextClipboard : Boolean Specifies whether to copy and paste the text formatting along with the text. | TextField
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | wordWrap : Boolean A Boolean value that indicates whether the text field has word wrap. | TextField
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TextFieldAsset()
Constructor.
TextFieldAsset
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
appendText(newText:String):void
Appends the string specified by the newText parameter to the end of the text of the TextField.
TextField
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getCharBoundaries(charIndex:int):Rectangle
Returns a rectangle that is the bounding box of the character.
TextField
Inherited
getCharIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the character at the point specified by the x and y parameters.
TextField
Inherited
getFirstCharInParagraph(charIndex:int):int
Given a character index, returns the index of the first character in the same paragraph.
TextField
Inherited
getImageReference(id:String):DisplayObject
Returns a DisplayObject reference for the given id, for an image or SWF file that has been added to an HTML-formatted text field by using an <img> tag.
TextField
Inherited
getLineIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the line at the point specified by the x and y parameters.
TextField
Inherited
getLineIndexOfChar(charIndex:int):int
Returns the zero-based index value of the line containing the character specified by the charIndex parameter.
TextField
Inherited
getLineLength(lineIndex:int):int
Returns the number of characters in a specific text line.
TextField
Inherited
getLineMetrics(lineIndex:int):TextLineMetrics
Returns metrics information about a given text line.
TextField
Inherited
getLineOffset(lineIndex:int):int
Returns the character index of the first character in the line that the lineIndex parameter specifies.
TextField
Inherited
getLineText(lineIndex:int):String
Returns the text of the line specified by the lineIndex parameter.
TextField
Inherited
getParagraphLength(charIndex:int):int
Given a character index, returns the length of the paragraph containing the given character.
TextField
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getTextFormat(beginIndex:int = -1, endIndex:int = -1):TextFormat
Returns a TextFormat object that contains formatting information for the range of text that the beginIndex and endIndex parameters specify.
TextField
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
TextFieldAsset
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
replaceSelectedText(value:String):void
Replaces the current selection with the contents of the value parameter.
TextField
Inherited
replaceText(beginIndex:int, endIndex:int, newText:String):void
Replaces the range of characters that the beginIndex and endIndex parameters specify with the contents of the newText parameter.
TextField
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
TextFieldAsset
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSelection(beginIndex:int, endIndex:int):void
Sets as selected the text designated by the index values of the first and last characters, which are specified with the beginIndex and endIndex parameters.
TextField
Inherited
setTextFormat(format:TextFormat, beginIndex:int = -1, endIndex:int = -1):void
Applies the text formatting that the format parameter specifies to the specified text in a text field.
TextField
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexTextField
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched after a control's value is modified. | TextField
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | link | Dispatched when a user clicks a hyperlink in an HTML-enabled text field, where the URL begins with "event:". | TextField
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched by a TextField object after the user scrolls. | TextField
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | textInput | Flash Player dispatches the textInput event when a user enters one or more characters of text. | TextField
Property detail
measuredHeight property
measuredHeight:Number [read-only]

The measured height of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measured width of this object.

This is typically hard-coded for graphical skins because this number is simply the number of pixels in the graphic. For code skins, it can also be hard-coded if you expect to be drawn at a certain size. If your size can change based on properties, you may want to also be an ILayoutManagerClient so a measure() method will be called at an appropriate time, giving you an opportunity to compute a measuredHeight.

Implementation
    public function get measuredWidth():Number
Constructor detail
TextFieldAsset () constructor
public function TextFieldAsset()

Constructor.

Method detail
move () method
public function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The new x-position for this object.
y:Number — The new y-position for this object.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Sets the actual size of this object.

This method is mainly for use in implementing the updateDisplayList() method, which is where you compute this object's actual size based on its explicit size, parent-relative (percent) size, and measured size. You then apply this actual size to the object by calling setActualSize().

In other situations, you should be setting properties such as width, height, percentWidth, or percentHeight rather than calling this method.

Parameters
newWidth:Number — The new width for this object.
newHeight:Number — The new height for this object.


mx.core.UIComponent (Flex™ 2 Language Reference)

Class UIComponent | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.core
Class | public class UIComponent
Inheritance | UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IChildList, IDeferredInstantiationUIComponent, IFlexDisplayObject, IInvalidating, ILayoutManagerClient, IPropertyChangeNotifier, IRepeaterClient, ISimpleStyleClient, IStyleClient, IToolTipManagerClient, IUIComponent, IValidatorListener
Subclasses | Button, ChartBase, ChartLabel, ComboBase, Container, DataGridDragProxy, DataTip, DateChooser, DualStyleObject, FormHeading, HRule, Label, LegendItem, ListItemDragProxy, ListItemRenderer, MenuBar, MenuBarItem, MenuItemRenderer, NumericStepper, PopUpButtonSkin, ProgressBar, Repeater, ScrollBar, ScrollControlBase, Slider, Spacer, SwatchSkin, SWFLoader, TextInput, TileListItemRenderer, ToolTip, TreeItemRenderer, VideoDisplay, VRule

The UIComponent class is the base class for all visual components, both interactive and noninteractive.

An interactive component can participate in tabbing and other kinds of keyboard focus manipulation, accept low-level events like keyboard and mouse input, and be disabled so that it does not receive keyboard and mouse input. This is in contrast to noninteractive components, like Label and ProgressBar, which simply display contents and are not manipulated by the user.

The UIComponent class is not used as an MXML tag, but is used as a base class for other classes.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

All user interface components in Flex extend the UIComponent class. Flex components inherit the following properties from the UIComponent class:

  <mx:tagname
   Properties
    cachePolicy="auto|on|off"
    currentState="null"
    doubleClickEnabled="true|false"
    enabled="true|false"
    explicitHeight="NaN"
    explicitMaxHeight="NaN"
    explicitMaxWidth="NaN"
    explicitMinHeight="NaN"
    explicitMinWidth="NaN"
    explicitWidth="NaN"
    focusEnabled="true|false"
    height="0"
    id=""
    includeInLayout="true|false"
    maxHeight="10000"
    maxWidth="10000"
    measuredHeight=
    measuredMinHeight=
    measuredMinWidth=
    measuredWidth=
    minHeight="0"
    minWidth="0"
    mouseFocusEnabled="true|false"
    percentHeight="NaN"
    percentWidth="NaN"
    scaleX="1.0"
    scaleY="1.0"
    states="null"
    styleName="undefined"
    toolTip="null"
    transitions=""
    validationSubField
    width="0"
    x="0"
    y="0"

  Styles
    bottom="undefined"
    errorColor="0xFFFFFF"
    focusBlendMode="normal"
    focusSkin="HaloFocusRect""
    focusThickness="2"
    horizontalCenter="undefined"
    left="undefined"
    right="undefined"
    themeColor="haloGreen"
    top="undefined"
    verticalCenter="undefined"

  Effects
    addedEffect="No default"
    creationCompleteEffect="No default"
    focusInEffect="No default"
    focusOutEffect="No default"

    hideEffect="No default"
    mouseDownEffect="No default"
    mouseUpEffect="No default"
    moveEffect="No default"
    removedEffect="No default"
    resizeEffect="No default"
    rollOutEffect="No default"
    rollOverEffect="No default"
    showEffect="No default"

  Events
    add="No default"
    creationComplete="No default"
    currentStateChange="No default"
    currentStateChanging="No default"
    dragComplete="No default"
    dragDrop="No default"
    dragEnter="No default"
    dragExit="No default"
    dragOver="No default"
    effectEnd="No default"
    effectStart="No default"
    enterState="No default"
    exitState="No default"
    hide="No default"
    initialize="No default"
    invalid="No default"
    mouseDownOutside="No default"
    mouseWheelOutside="No default"
    move="No default"
    preinitialize="No default"
    record="No default"
    remove="No default"
    resize="No default"
    show="No default"
    toolTipCreate="No default"
    toolTipEnd="No default"
    toolTipHide="No default"
    toolTipShow="No default"
    toolTipShown="No default"
    toolTipStart="No default"
    updateComplete="No default"
    valid="No default"
    valueCommit="No default"
  >

See also

mx.core.UIComponent
Using the setStyle() method
About overriding protected UIComponent methods
Example: Creating a composite component

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | baselinePosition : Number [read-only] Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
 | cacheHeuristic : Boolean [write-only] Used by Flex to suggest bitmap caching for the object. | UIComponent
 | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
 | className : String [read-only] The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contentMouseX : Number [read-only] Returns the x position of the mouse, in the content coordinate system. | UIComponent
 | contentMouseY : Number [read-only] Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | currentState : String The current view state of the component. | UIComponent
 | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
 | document : Object A reference to the document object associated with this UIComponent. | UIComponent
 | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | enabled : Boolean Whether the component can accept user interaction. | UIComponent
 | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
 | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
 | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
 | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
 | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
 | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
 | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
 | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | id : String ID of the component. | UIComponent
 | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
 | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
 | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
 | instanceIndex : int [read-only] The index of a repeated component. | UIComponent
 | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
 | isDocument : Boolean [read-only] Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
 | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
 | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
 | measuredHeight : Number The default height of the component, in pixels. | UIComponent
 | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
 | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
 | measuredWidth : Number The default width of the component, in pixels. | UIComponent
 | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
 | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
 | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
 | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
 | parent : DisplayObjectContainer [read-only] The parent container or component for this component. | UIComponent
 | parentApplication : Object [read-only] A reference to the Application object that contains this UIComponent instance. | UIComponent
 | parentDocument : Object [read-only] A reference to the parent document object for this UIComponent. | UIComponent
 | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
 | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
 | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | repeater : IRepeater [read-only] A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
 | repeaterIndex : int [read-only] The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
 | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
 | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
 | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
 | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
 | screen : Rectangle [read-only] Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | states : Array The view states that are defined for this component. | UIComponent
 | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
 | styleName : Object The class style used by this component. | UIComponent
 | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
 | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
 | uid : String A unique identifier for the object. | UIComponent
 | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
 | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
 | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
 | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
 | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Property |  | Defined by
 | unscaledHeight : Number [read-only] A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
 | unscaledWidth : Number [read-only] A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
UIComponent()
Constructor.
UIComponent
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
initialize():void
Initializes the internal structure of this component.
UIComponent
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
 | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
 | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
 | commitProperties():void Processes the properties set on the component. | UIComponent
 | createChildren():void Create child objects of the component. | UIComponent
 | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
 | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
 | initializationComplete():void Finalizes the initialization of this component. | UIComponent
 | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
 | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
 | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
 | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
 | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
 | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
 | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
 | currentStateChange | Dispatched after the view state has changed. | UIComponent
 | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
 | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
 | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
 | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
 | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
 | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
 | effectEnd | Dispatched after an effect ends. | UIComponent
 | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
 | enterState | Dispatched after the component has returned to the root view state. | UIComponent
 | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
 | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
 | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
 | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
 | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
 | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
 | move | Dispatched when the object has moved. | UIComponent
 | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
 | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
 | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
 | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
 | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
 | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
 | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
 | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
 | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
 | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
 | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
 | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
 | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Style |  | Description | Defined by
 | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. If this style is set, the lower edge of the component is anchored to the bottom edge of its container; when its container is resized, the two edges maintain their separation. The default value is undefined, which means it is not set. | UIComponent
 | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. The default value is 0xFF0000. | UIComponent
 | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. For more information, see the blendMode property of the flash.display.DisplayObject class. The default value is "normal". | UIComponent
 | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. The default value is mx.skins.halo.HaloFocusRect. | UIComponent
 | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. The default value is 2. | UIComponent
 | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. If this style is set, the center of the component will be anchored to the center of its container; when its container is resized, the two centers maintain their horizontal separation. The default value is undefined, which means it is not set. | UIComponent
 | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. If this style is set, the left edge of the component is anchored to the left edge of its container; when its container is resized, the two edges maintain their separation. The default value is undefined, which means it is not set. | UIComponent
 | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. If this style is set, the right edge of the component is anchored to the right edge of its container; when its container is resized, the two edges maintain their separation. The default value is undefined, which means it is not set. | UIComponent
 | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. This property controls the appearance of highlights, appearance when a component is selected, and other similar visual cues, but it does not have any effect on the regular borders or background colors of the component. The preferred values are haloGreen, haloBlue, haloOrange, and haloSilver, although any valid color value can be used. The default values of the rollOverColor and selectionColor styles are based on the themeColor value. The default value is "haloBlue". | UIComponent
 | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. If this style is set, the top edge of the component is anchored to the top edge of its container; when its container is resized, the two edges maintain their separation. The default value is undefined, which means it is not set. | UIComponent
 | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. If this style is set, the center of the component is anchored to the center of its container; when its container is resized, the two centers maintain their vertical separation. The default value is undefined, which means it is not set. | UIComponent
Effects
Effect |  | Description | Defined by
 | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
 | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
 | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
 | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
 | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
 | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
 | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
 | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
 | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
 | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
 | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
 | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
 | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Constant |  | Defined by
 | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
 | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
 | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
 | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
 | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
 | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
baselinePosition property
baselinePosition:Number [read-only]

Determines the baseline y-coordinate of the first line of text of the component. Each component should override this property.

Implementation
    public function get baselinePosition():Number
cacheHeuristic property
cacheHeuristic:Boolean [write-only]

Used by Flex to suggest bitmap caching for the object. If cachePolicy is UIComponentCachePolicy.AUTO, then cacheHeuristic is used to control the object's cacheAsBitmap property.

Implementation
    public function set cacheHeuristic(value:Boolean):void
cachePolicy property
cachePolicy:String [read-write]

Specifies the bitmap caching policy for this object. Possible values in MXML are "on", "off" and "auto" (default).

Possible values in ActionScript are UIComponentCachePolicy.ON, UIComponentCachePolicy.OFF and UIComponentCachePolicy.AUTO (default).

  • A value of UIComponentCachePolicy.ON means that the object is always cached as a bitmap.
  • A value of UIComponentCachePolicy.OFF means that the object is never cached as a bitmap.
  • A value of UIComponentCachePolicy.AUTO means that the framework uses heuristics to decide whether the object should be cached as a bitmap.

The default value is UIComponentCachePolicy.AUTO.

Implementation
    public function get cachePolicy():String
    public function set cachePolicy(value:String):void
className property
className:String [read-only]

The name of this instance's class, such as "Button".

This string does not include the package name. If you need the package name as well, call the getQualifiedClassName() method in the flash.utils package. It will return a string such as "mx.controls::Button".

Implementation
    public function get className():String
contentMouseX property
contentMouseX:Number [read-only]

Returns the x position of the mouse, in the content coordinate system. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component.

Implementation
    public function get contentMouseX():Number
contentMouseY property
contentMouseY:Number [read-only]

Returns the y position of the mouse, in the content coordinate system. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component.

Implementation
    public function get contentMouseY():Number
currentState property
currentState:String [read-write]

The current view state of the component. Set to "" or null to reset the component back to its base state.

When you use this property to set a component's state, Flex applies any transition you have defined. You can also use the setCurrentState() method to set the current state; this method can optionally change states without applying a transition.

This property can be used as the source for data binding.

Implementation
    public function get currentState():String
    public function set currentState(value:String):void

See also

setCurrentState()
descriptor property
descriptor:UIComponentDescriptor [read-write]

Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. If this UIComponent instance was not created from a descriptor, this property is null.

Implementation
    public function get descriptor():UIComponentDescriptor
    public function set descriptor(value:UIComponentDescriptor):void

See also

mx.core.UIComponentDescriptor
document property
document:Object [read-write]

A reference to the document object associated with this UIComponent. A document object is an Object at the top of the hierarchy of a Flex application, MXML component, or AS component.

Implementation
    public function get document():Object
    public function set document(value:Object):void
doubleClickEnabled property
doubleClickEnabled:Boolean [read-write]

Specifies whether the UIComponent object receives doubleClick events. The default value is true, which means that the UIComponent object receives doubleClick events.

The mouseEnabled property must also be set to true, its default value, for the object to receive doubleClick events.

The default value is true.

Implementation
    public function get doubleClickEnabled():Boolean
    public function set doubleClickEnabled(value:Boolean):void
enabled property
enabled:Boolean [read-write]

Whether the component can accept user interaction. If you set the enabled property to false for a container, Flex dims the color of the container and of all of its children, and blocks user input to the container and to all of its children.

This property can be used as the source for data binding.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void
errorString property
errorString:String [read-write]

The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails.

You can use the errorString property to show a validation error for a component, without actually using a validator class. When you write a String value to the errorString property, Flex draws a red border around the component to indicate the validation error, and the String appears in a tooltip as the validation error message when you move the mouse over the component, just as if a validator detected a validation error.

To clear the validation error, write an empty String, "", to the errorString property.

Note that writing a value to the errorString property does not trigger the valid or invalid events; it only changes the border color and displays the validation error message.

This property can be used as the source for data binding.

Implementation
    public function get errorString():String
    public function set errorString(value:String):void
explicitHeight property
explicitHeight:Number [read-write]

Number that specifies the explicit height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true explicitHeight with respect to its parent is affected by the scaleY property.

Setting the height property also sets this property to the specified height value.

This property can be used as the source for data binding.

Implementation
    public function get explicitHeight():Number
    public function set explicitHeight(value:Number):void
explicitMaxHeight property
explicitMaxHeight:Number [read-write]

Number that specifies the maximum height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxHeight with respect to its parent is affected by the scaleY property. Some components have no theoretical limit to their height. In those cases their maxHeight will be set to UIComponent.DEFAULT_MAX_HEIGHT.

The default value is NaN.

This property can be used as the source for data binding.

Implementation
    public function get explicitMaxHeight():Number
    public function set explicitMaxHeight(value:Number):void
explicitMaxWidth property
explicitMaxWidth:Number [read-write]

Number that specifies the maximum width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxWidth with respect to its parent is affected by the scaleX property. Some components have no theoretical limit to their width. In those cases their maxWidth will be set to UIComponent.DEFAULT_MAX_WIDTH.

The default value is NaN.

This property can be used as the source for data binding.

Implementation
    public function get explicitMaxWidth():Number
    public function set explicitMaxWidth(value:Number):void
explicitMinHeight property
explicitMinHeight:Number [read-write]

Number that specifies the minimum height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minHeight with respect to its parent is affected by the scaleY property.

The default value is NaN.

This property can be used as the source for data binding.

Implementation
    public function get explicitMinHeight():Number
    public function set explicitMinHeight(value:Number):void
explicitMinWidth property
explicitMinWidth:Number [read-write]

Number that specifies the minimum width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minWidth with respect to its parent is affected by the scaleX property.

The default value is NaN.

This property can be used as the source for data binding.

Implementation
    public function get explicitMinWidth():Number
    public function set explicitMinWidth(value:Number):void
explicitWidth property
explicitWidth:Number [read-write]

Number that specifies the explicit width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true explicitWidth with respect to its parent is affected by the scaleX property.

Setting the width property also sets this property to the specified width value.

This property can be used as the source for data binding.

Implementation
    public function get explicitWidth():Number
    public function set explicitWidth(value:Number):void
focusEnabled property
focusEnabled:Boolean [read-write]

Indicates whether the component can receive focus when clicked on. If this property is false, focus will be transferred to the first parent that is mouseFocusEnable set to true.

The default value is true.

Implementation
    public function get focusEnabled():Boolean
    public function set focusEnabled(value:Boolean):void
focusManager property
focusManager:IFocusManager [read-write]

Gets the FocusManager that controls focus for this component and its peers. Each popup has its own focus loop and therefore its own instance of a FocusManager. To make sure you're talking to the right one, use this method.

Implementation
    public function get focusManager():IFocusManager
    public function set focusManager(value:IFocusManager):void
focusPane property
focusPane:Sprite [read-write]

The focus pane associated with this object. An object has a focus pane when one of its children has focus.

Implementation
    public function get focusPane():Sprite
    public function set focusPane(value:Sprite):void
height property
height:Number [read-write]

Number that specifies the height of the component, in pixels, in the parent's coordinates. The default value is 0, not the actual height of the control.

Note: You can specify a percentage value in the MXML height attribute, such as height="100%", but you cannot use a percentage value for the height property in ActionScript; use the percentHeight property instead.

Setting this property causes a resize event to be dispatched. See the resize event for details on when this event is dispatched. If the component's scaleY property is not 100, the height of the component from its internal coordinates will not match. Thus a 100 pixel high component with a scaleY of 200 will take 100 pixels in the parent, but will internally think it is 50 pixels high.

This property can be used as the source for data binding.

Implementation
    public function get height():Number
    public function set height(value:Number):void
id property
id:String [read-write]

ID of the component. This value becomes the instance name of the object and should not contain any white space or special characters. Each component throughout an application should have a unique id.

If your application is going to be tested by third party tools, give each component a meaningful id. Testing tools use ids to represent the control in their scripts and having a meaningful name can make scripts more readable. For example, set the value of a button to submit_button rather than b1 or button1.

Implementation
    public function get id():String
    public function set id(value:String):void
includeInLayout property
includeInLayout:Boolean [read-write]

Specifies whether this component is included in the layout of the parent container. If true, the object is included in its parent container's layout. If false, the object is positioned by its parent container as per its layout rules, but it is ignored for the purpose of computing the position of the next child.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get includeInLayout():Boolean
    public function set includeInLayout(value:Boolean):void
inheritingStyles property
inheritingStyles:Object [read-write]

The beginning of this component's chain of inheriting styles. The getStyle() method simply accesses inheritingStyles[styleName] to search the entire prototype-linked chain. This object is set up by initProtoChain(). Developers typically never need to access this property directly.

Implementation
    public function get inheritingStyles():Object
    public function set inheritingStyles(value:Object):void
initialized property
initialized:Boolean [read-write]

A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required).

Implementation
    public function get initialized():Boolean
    public function set initialized(value:Boolean):void
instanceIndex property
instanceIndex:int [read-only]

The index of a repeated component. If the component is not within a Repeater, the value is -1.

Implementation
    public function get instanceIndex():int
instanceIndices property
instanceIndices:Array [read-write]

An Array containing the indices required to reference this UIComponent object from its parent document. The Array is empty unless this UIComponent object is within one or more Repeaters. The first element corresponds to the outermost Repeater. For example, if the id is "b" and instanceIndices is [2,4], you would reference it on the parent document as b[2][4].

Implementation
    public function get instanceIndices():Array
    public function set instanceIndices(value:Array):void
isDocument property
isDocument:Boolean [read-only]

Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component.

Implementation
    public function get isDocument():Boolean
isPopUp property
public var isPopUp:Boolean

Set to true by the PopUpManager to indicate that component has been popped up.

maxHeight property
maxHeight:Number [read-write]

Number that specifies the maximum height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxHeight with respect to its parent is affected by the scaleY property. Some components have no theoretical limit to their height. In those cases their maxHeight will be set to UIComponent.DEFAULT_MAX_HEIGHT.

The default value is 10000.

This property can be used as the source for data binding.

Implementation
    public function get maxHeight():Number
    public function set maxHeight(value:Number):void
maxWidth property
maxWidth:Number [read-write]

Number that specifies the maximum width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxWidth with respect to its parent is affected by the scaleX property. Some components have no theoretical limit to their width. In those cases their maxWidth will be set to UIComponent.DEFAULT_MAX_WIDTH.

The default value is 10000.

This property can be used as the source for data binding.

Implementation
    public function get maxWidth():Number
    public function set maxWidth(value:Number):void
measuredHeight property
measuredHeight:Number [read-write]

The default height of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredHeight():Number
    public function set measuredHeight(value:Number):void
measuredMinHeight property
measuredMinHeight:Number [read-write]

The default minimum height of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredMinHeight():Number
    public function set measuredMinHeight(value:Number):void
measuredMinWidth property
measuredMinWidth:Number [read-write]

The default minimum width of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredMinWidth():Number
    public function set measuredMinWidth(value:Number):void
measuredWidth property
measuredWidth:Number [read-write]

The default width of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredWidth():Number
    public function set measuredWidth(value:Number):void
minHeight property
minHeight:Number [read-write]

Number that specifies the minimum height of the component, in pixels, in the component's coordinates. The default value depends on the component implementation.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minHeight with respect to its parent is affected by the scaleY property.

This property can be used as the source for data binding.

Implementation
    public function get minHeight():Number
    public function set minHeight(value:Number):void
minWidth property
minWidth:Number [read-write]

Number that specifies the minimum width of the component, in pixels, in the component's coordinates. The default value depends on the component implementation.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minWidth with respect to its parent is affected by the scaleX property.

This property can be used as the source for data binding.

Implementation
    public function get minWidth():Number
    public function set minWidth(value:Number):void
mouseFocusEnabled property
mouseFocusEnabled:Boolean [read-write]

Whether you can receive focus when clicked on. If false, focus will be transferred to the first parent that is mouseFocusEnable set to true.

The default value is true.

Implementation
    public function get mouseFocusEnabled():Boolean
    public function set mouseFocusEnabled(value:Boolean):void
nestLevel property
nestLevel:int [read-write]

Depth of this object in the containment hierarchy. This number is used by the measurement and layout code. The value is 0 if this component is not on the DisplayList.

Implementation
    public function get nestLevel():int
    public function set nestLevel(value:int):void
nonInheritingStyles property
nonInheritingStyles:Object [read-write]

The beginning of this component's chain of non-inheriting styles. The getStyle() method simply accesses nonInheritingStyles[styleName] to search the entire prototype-linked chain. This object is set up by initProtoChain(). Developers typically never need to access this property directly.

Implementation
    public function get nonInheritingStyles():Object
    public function set nonInheritingStyles(value:Object):void
owner property
owner:DisplayObjectContainer [read-write]

The owner of this UIComponent. By default, it is the parent of this UIComponent. However, if this UIComponent object is a child component that is popped up by its parent, such as the dropdown list of a ComboBox control, the owner is the component that popped up this UIComponent object.

This property is not managed by Flex, but by each component. Therefore, if you use the PopUpManger.createPopUp() or PopUpManger.addPopUp() method to pop up a child component, you should set the owner property of the child component to the component that popped it up.

The default value is the value of the parent property.

Implementation
    public function get owner():DisplayObjectContainer
    public function set owner(value:DisplayObjectContainer):void
parent property
parent:DisplayObjectContainer [read-only]

The parent container or component for this component. Only UIComponent objects should have a parent property. Non-UIComponent objects should use another property to reference the object to which they belong. By convention, non-UIComponent objects use an owner property to reference the object to which they belong.

Implementation
    public function get parent():DisplayObjectContainer
parentApplication property
parentApplication:Object [read-only]

A reference to the Application object that contains this UIComponent instance. This Application object might exist in a SWFLoader control in another Application, and so on, creating a chain of Application objects that can be walked using parentApplication. The parentApplication property of an Application is never itself; it is either the Application into which it was loaded or null (for the top-level Application). Walking the application chain using the parentApplication property is similar to walking the document chain using the parentDocument property. You can access the top-level application using the application property of the Application class.

This property can be used as the source for data binding.

Implementation
    public function get parentApplication():Object
parentDocument property
parentDocument:Object [read-only]

A reference to the parent document object for this UIComponent. A document object is a UIComponent at the top of the hierarchy of a Flex application, MXML component, or AS component. For the Application object, the parentDocument property is null. This property is useful in MXML scripts to go up a level in the chain of document objects. It can be used to walk this chain using parentDocument.parentDocument, and so on. It is typed as Object so that authors can access properties and methods on ancestor document objects without casting.

This property can be used as the source for data binding.

Implementation
    public function get parentDocument():Object
percentHeight property
percentHeight:Number [read-write]

Number that specifies the height of a component as a percentage of its parent's size. Allowed values are 0-100. The default value is NaN. Setting the height or explicitHeight properties resets this property to NaN.

This property returns a numeric value only if the property was previously set; it does not reflect the exact size of the component in percent.

This property can be used as the source for data binding.

Implementation
    public function get percentHeight():Number
    public function set percentHeight(value:Number):void
percentWidth property
percentWidth:Number [read-write]

Number that specifies the width of a component as a percentage of its parent's size. Allowed values are 0-100. The default value is NaN. Setting the width or explicitWidth properties resets this property to NaN.

This property returns a numeric value only if the property was previously set; it does not reflect the exact size of the component in percent.

This property can be used as the source for data binding.

Implementation
    public function get percentWidth():Number
    public function set percentWidth(value:Number):void
processedDescriptors property
processedDescriptors:Boolean [read-write]

Set to true after immediate or deferred child creation, depending on which one happens. For a Container object, it is set to true at the end of the createComponentsFromDescriptors() method, meaning after the Container object creates its children from its child descriptors.

For example, if an Accordion container uses deferred instantiation, the processedDescriptors property for the second pane of the Accordion container does not become true until after the user navigates to that pane and the pane creates its children. But, if the Accordion had set the creationPolicy property to "all", the processedDescriptors property for its second pane is set to true during application startup.

For classes that are not containers, which do not have descriptors, it is set to true after the createChildren() method creates any internal component children.

Implementation
    public function get processedDescriptors():Boolean
    public function set processedDescriptors(value:Boolean):void
repeater property
repeater:IRepeater [read-only]

A reference to the Repeater object in the parent document that produced this UIComponent. Use this property, rather than the repeaters property, when the UIComponent is created by a single Repeater object. Use the repeaters property when this UIComponent is created by nested Repeater objects.

The property is set to null when this UIComponent is not created by a Repeater.

Implementation
    public function get repeater():IRepeater
repeaterIndex property
repeaterIndex:int [read-only]

The index of the item in the data provider of the Repeater that produced this UIComponent. Use this property, rather than the repeaterIndices property, when the UIComponent is created by a single Repeater object. Use the repeaterIndices property when this UIComponent is created by nested Repeater objects.

This property is set to -1 when this UIComponent is not created by a Repeater.

Implementation
    public function get repeaterIndex():int
repeaterIndices property
repeaterIndices:Array [read-write]

An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. The Array is empty unless this UIComponent is within one or more Repeaters.

The first element in the Array corresponds to the outermost Repeater. For example, if repeaterIndices is [2,4] it means that the outer repeater used item dataProvider[2] and the inner repeater used item dataProvider[4].

Note that this property differs from the instanceIndices property if the startingIndex property of any of the Repeaters is not 0. For example, even if a Repeater starts at dataProvider[4], the document reference of the first repeated object is b[0], not b[4].

Implementation
    public function get repeaterIndices():Array
    public function set repeaterIndices(value:Array):void
repeaters property
repeaters:Array [read-write]

An Array containing references to the Repeater objects in the parent document that produced this UIComponent. The Array is empty unless this UIComponent is within one or more Repeaters. The first element corresponds to the outermost Repeater object.

Implementation
    public function get repeaters():Array
    public function set repeaters(value:Array):void
scaleX property
scaleX:Number [read-write]

Number that specifies the horizontal scaling factor.

The default value is 1.0, which means that the object is not scaled. A scaleX of 2.0 means the object has been magnified by a factor of 2, and a scaleX of 0.5 means the object has been reduced by a factor of 2.

A value of 0.0 is an invalid value. Rather than setting it to 0.0, set it to a small value, or set the visible property to false to hide the component.

The default value is 1.0.

This property can be used as the source for data binding.

Implementation
    public function get scaleX():Number
    public function set scaleX(value:Number):void
scaleY property
scaleY:Number [read-write]

Number that specifies the vertical scaling percentage.

The default value is 1.0, which means that the object is not scaled. A scaleY of 2.0 means the object has been magnified by a factor of 2, and a scaleY of 0.5 means the object has been reduced by a factor of 2.

A value of 0.0 is an invalid value. Rather than setting it to 0.0, set it to a small value, or set the visible property to false to hide the component.

The default value is 1.0.

This property can be used as the source for data binding.

Implementation
    public function get scaleY():Number
    public function set scaleY(value:Number):void
screen property
screen:Rectangle [read-only]

Returns an object that contains the size and position of the base drawing surface for this object.

Implementation
    public function get screen():Rectangle
states property
public var states:Array

The view states that are defined for this component. You can specify the states property only on the root of the application or on the root tag of an MXML component. The compiler generates an error if you specify it on any other control.

styleDeclaration property
styleDeclaration:CSSStyleDeclaration [read-write]

Storage for the inline inheriting styles on this object. This CSSStyleDeclaration is created the first time that the setStyle() method is called on this component to set an inheriting style. Developers typically never need to access this property directly.

Implementation
    public function get styleDeclaration():CSSStyleDeclaration
    public function set styleDeclaration(value:CSSStyleDeclaration):void
styleName property
styleName:Object [read-write]

The class style used by this component. This can be a String, CSSStyleDeclaration or an IStyleClient.

If this is a String, it is the name of a class declaration in an mx:Style tag or CSS file. You do not include the period in the styleName. For example, if you have a class style named ".bigText", set the styleName property to "bigText" (no period).

If this is an IStyleClient (typically a UIComponent), all styles in the styleName ojbect are used by this component.

The default value is null.

Implementation
    public function get styleName():Object
    public function set styleName(value:Object):void
systemManager property
systemManager:ISystemManager [read-write]

Returns the SystemManager object used by this component.

Implementation
    public function get systemManager():ISystemManager
    public function set systemManager(value:ISystemManager):void
toolTip property
toolTip:String [read-write]

Text to display in the ToolTip.

The default value is null.

This property can be used as the source for data binding.

Implementation
    public function get toolTip():String
    public function set toolTip(value:String):void
transitions property
public var transitions:Array

An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs.

See also

mx.states.Transition
tweeningProperties property
tweeningProperties:Array [read-write]

Array of properties that are currently being tweened on this object.

Used to alert the EffectManager that certain properties of this object are being tweened, so that the EffectManger doesn't attempt to animate the same properties.

Implementation
    public function get tweeningProperties():Array
    public function set tweeningProperties(value:Array):void
uid property
uid:String [read-write]

A unique identifier for the object. Flex data-driven controls, including all controls that are subclasses of List class, use a UID to track data provider items.

Flex can automatically create and manage UIDs. However, there are circumstances when you must supply your own uid property by implementing the IUID interface, or when supplying your own uid property improves processing efficiency. UIDs do not need to be universally unique for most uses in Flex. One exception is for messages sent by data services.

Implementation
    public function get uid():String
    public function set uid(value:String):void

See also

IUID
mx.utils.UIDUtil
unscaledHeight property
unscaledHeight:Number [read-only]

A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList().

Implementation
    protected function get unscaledHeight():Number
unscaledWidth property
unscaledWidth:Number [read-only]

A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList().

Implementation
    protected function get unscaledWidth():Number
updateCompletePendingFlag property
updateCompletePendingFlag:Boolean [read-write]

A flag that determines if an object has been through all three phases of layout validation (provided that any were required).

Implementation
    public function get updateCompletePendingFlag():Boolean
    public function set updateCompletePendingFlag(value:Boolean):void
validationSubField property
validationSubField:String [read-write]

Used by a validator to associate a subfield with this component.

Implementation
    public function get validationSubField():String
    public function set validationSubField(value:String):void
visible property
visible:Boolean [read-write]

Controls the visibility of this UIComponent. If true, the object is visible.

When setting to true, the object will dispatch a show event. When setting to false, the object will dispatch a hide event. In either case the children of the object will not emit a show or hide event unless the object has specifically written an implementation to do so.

The default value is true.

This property can be used as the source for data binding.

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
width property
width:Number [read-write]

Number that specifies the width of the component, in pixels, in the parent's coordinates. The default value is 0, not the actual width of the control.

Note: You can specify a percentage value in the MXML width attribute, such as width="100%", but you cannot use a percentage value in the width property in ActionScript. Use the percentWidth property instead.

Setting this property causes a resize event to be dispatched. See the resize event for details on when this event is dispatched. If the component's scaleX property is not 1.0, the width of the component from its internal coordinates will not match. Thus a 100 pixel wide component with a scaleX of 2 will take 100 pixels in the parent, but will internally think it is 50 pixels wide.

This property can be used as the source for data binding.

Implementation
    public function get width():Number
    public function set width(value:Number):void
x property
x:Number [read-write]

Number that specifies the component's horizontal position, in pixels, within its parent container.

Setting this property directly or calling move() will have no effect -- or only a temporary effect -- if the component is parented by a layout container such as HBox, Grid, or Form, because the layout calculations of those containers set the x position to the results of the calculation. However, the x property must almost always be set when the parent is a Canvas or other absolute-positioning container because the default value is 0.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get x():Number
    public function set x(value:Number):void
y property
y:Number [read-write]

Number that specifies the component's vertical position, in pixels, within its parent container.

Setting this property directly or calling move() will have no effect -- or only a temporary effect -- if the component is parented by a layout container such as HBox, Grid, or Form, because the layout calculations of those containers set the x position to the results of the calculation. However, the x property must almost always be set when the parent is a Canvas or other absolute-positioning container because the default value is 0.

The default value is 0.

This property can be used as the source for data binding.

Implementation
    public function get y():Number
    public function set y(value:Number):void
Constructor detail
UIComponent () constructor
public function UIComponent()

Constructor.

Method detail
adjustFocusRect () method
protected function adjustFocusRect(obj:DisplayObject = null):void

Adjust the focus rectangle.

Parameters
obj:DisplayObject (default = null) — component whose focus rectangle to modify. If omitted, the default value is this UIComponent object.
attachOverlay () method
protected function attachOverlay():void

This is an internal method used by the Flex framework to support the Dissolve effect. You should not need to call it or override it.

callLater () method
public function callLater(method:Function, args:Array = null):void

Queues a function to be called later.

Before each update of the screen, the Flash Player calls the set of functions that are scheduled for the update. Sometimes, a function should be called in the next update to allow the rest of the code scheduled for the current update to be executed. Some features, like effects, can cause queued functions to be delayed until the feature completes.

Parameters
method:Function — Reference to a method to be executed later.
args:Array (default = null) — Array of arguments to pass to the method. specified by the fn parameter.
childrenCreated () method
protected function childrenCreated():void

Performs any final processing after child objects are created. This is an advanced method that you might override when creating a subclass of UIComponent.

clearStyle () method
public function clearStyle(styleProp:String):void

Deletes a style property from this component instance.

This does not necessarily cause the getStyle() method to return undefined.

Parameters
styleProp:String — The name of the style property.
commitProperties () method
protected function commitProperties():void

Processes the properties set on the component. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the commitProperties() method when you use the addChild() method to add a component to a container, or when you call the invalidateProperties() method of the component. Calls to the commitProperties() method occur before calls to the measure() method. This lets you set property values that might be used by the measure() method.

Some components have properties that affect the number or kinds of child objects that they need to create, or have properties that interact with each other, such as the horizontalScrollPolicy and horizontalScrollPosition properties. It is often best at startup time to process all of these properties at one time to avoid duplicating work.

See also

Implementing the commitProperties() method
contentToGlobal () method
public function contentToGlobal(point:Point):Point

Converts a Point object from content coordinates to global coordinates. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning. Global coordinates specify a pixel position relative to the upper-left corner of the Stage in Flash Player, that is, the outermost edge of the application.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the content coordinate system as properties.

Returns
Point — A Point object with coordinates relative to the Stage.

See also

globalToContent()
contentToLocal () method
public function contentToLocal(point:Point):Point

Converts a Point object from content to local coordinates. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning. Local coordinates specify a pixel position relative to the upper left corner of the component.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the content coordinate system as properties.

Returns
Point — Point A Point object with coordinates relative to the local coordinate system.

See also

contentToGlobal()
createChildren () method
protected function createChildren():void

Create child objects of the component. This is an advanced method that you might override when creating a subclass of UIComponent.

A component that creates other components or objects within it is called a composite component. For example, the Flex ComboBox control is actually made up of a TextInput control to define the text area of the ComboBox, and a Button control to define the ComboBox arrow. Components implement the createChildren() method to create child objects (such as other components) within the component.

From within an override of the createChildren() method, you call the addChild() method to add each child object.

You do not call this method directly. Flex calls the createChildren() method in response to the call to the addChild() method to add the component to its parent.

See also

Implementing the createChildren() method
createReferenceOnParentDocument () method
public function createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void

Creates an id reference to this IUIComponent object on its parent document object. This function can create multidimensional references such as b[2][4] for objects inside one or more repeaters. If the indices are null, it creates a simple non-Array reference.

Parameters
parentDocument:IFlexDisplayObject — The parent of this IUIComponent object.
deleteReferenceOnParentDocument () method
public function deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void

Deletes the id reference to this IUIComponent object on its parent document object. This function can delete from multidimensional references such as b[2][4] for objects inside one or more Repeaters. If the indices are null, it deletes the simple non-Array reference.

Parameters
parentDocument:IFlexDisplayObject — The parent of this IUIComponent object.
determineTextFormatFromStyles () method
public function determineTextFormatFromStyles():UITextFormat

Returns a UITextFormat object corresponding to the text styles for this UIComponent.

Returns
UITextFormat — UITextFormat object corresponding to the text styles for this UIComponent.
drawFocus () method
public function drawFocus(focused:Boolean):void

Shows or hides the focus indicator around this component.

UIComponent implements this by creating an instance of the class specified by the focusSkin style and positioning it appropriately.

Parameters
focused:Boolean
drawRoundRect () method
public function drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void

Programatically draws a rectangle into this skin's Graphics object.

The rectangle can have rounded corners. Its edges are stroked with the current line style of the Graphics object. It can have a solid color fill, a gradient fill, or no fill. A solid fill can have an alpha transparency. A gradient fill can be linear or radial. You can specify up to 15 colors and alpha values at specified points along the gradient, and you can specify a rotation angle or transformation matrix for the gradient. Finally, the rectangle can have a rounded rectangular hole carved out of it.

This versatile rectangle-drawing routine is used by many skins. It calls the drawRect() or drawRoundRect() methods (in the flash.display.Graphics class) to draw into this skin's Graphics object.

Parameters
x:Number — Horizontal position of upper-left corner of rectangle within this skin.
y:Number — Vertical position of upper-left corner of rectangle within this skin.
width:Number — Width of rectangle, in pixels.
height:Number — Height of rectangle, in pixels.
cornerRadius:Object (default = null) — Corner radius/radii of rectangle. Can be null, a Number, or an Object. If it is null, it specifies that the corners should be square rather than rounded. If it is a Number, it specifies the same radius, in pixels, for all four corners. If it is an Object, it should have properties named tl, tr, bl, and br, whose values are Numbers specifying the radius, in pixels, for the top left, top right, bottom left, and bottom right corners. For example, you can pass a plain Object such as { tl: 5, tr: 5, bl: 0, br: 0 }. The default value is null (square corners).
color:Object (default = null) — The RGB color(s) for the fill. Can be null, a uint, or an Array. If it is null, the rectangle not filled. If it is a uint, it specifies an RGB fill color. For example, pass 0xFF0000 to fill with red. If it is an Array, it should contain uints specifying the gradient colors. For example, pass [ 0xFF0000, 0xFFFF00, 0x0000FF ] to fill with a red-to-yellow-to-blue gradient. You can specify up to 15 colors in the gradient. The default value is null (no fill).
alpha:Object (default = null) — Alpha value(s) for the fill. Can be null, a Number, or an Array. This argument is ignored if color is null. If color is a uint specifying an RGB fill color, then alpha should be a Number specifying the transparency of the fill, where 0.0 is completely transparent and 1.0 is completely opaque. You can also pass null instead of 1.0 in this case to specify complete opaqueness. If color is an Array specifying gradient colors, then alpha should be an Array of Numbers, of the same length, that specifies the corresponding alpha values for the gradient. In this case, the default value is null (completely opaque).
gradientMatrix:Matrix (default = null) — Matrix object used for the gradient fill. The utility methods horizontalGradientMatrix(), verticalGradientMatrix(), and rotatedGradientMatrix() can be used to create the value for this parameter.
gradientType:String (default = "linear") — Type of gradient fill. The possible values are GradientType.LINEAR or GradientType.RADIAL. (The GradientType class is in the package flash.display.)
gradientRatios:Array (default = null) — (optional default [0,255]) Specifies the distribution of colors. The number of entries must match the number of colors defined in the color parameter. Each value defines the percentage of the width where the color is sampled at 100%. The value 0 represents the left-hand position in the gradient box, and 255 represents the right-hand position in the gradient box.
hole:Object (default = null) — (optional) A rounded rectangular hole that should be carved out of the middle of the otherwise solid rounded rectangle { x: #, y: #, w: #, h: #, r: # or { br: #, bl: #, tl: #, tr: # } }
effectFinished () method
public function effectFinished(effectInst:EffectInstance):void

Called by the effect instance when it stops playing on the component. You can use this method to restore a modification to the component made by the effectStarted() method when the effect started, or perform some other action when the effect ends.

Parameters
effectInst:EffectInstance — The effect instance object playing on the component.
effectStarted () method
public function effectStarted(effectInst:EffectInstance):void

Called by the effect instance when it starts playing on the component. You can use this method to perform a modification to the component as part of an effect. You can use the effectFinished() method to restore the modification when the effect ends.

Parameters
effectInst:EffectInstance — The effect instance object playing on the component.
endEffectsStarted () method
public function endEffectsStarted():void

Ends all currently playing effects on the component.

executeBindings () method
public function executeBindings(recurse:Boolean = false):void

Executes the data bindings into this UIComponent object.

Parameters
recurse:Boolean (default = false) — Recursively execute bindings for children of this component.
finishPrint () method
public function finishPrint(obj:Object, target:IFlexDisplayObject):void

Called after printing is complete. For the UIComponent class, the method performs no action. Flex containers override the method to restore the container after printing.

This method is normally not used by application developers.

Parameters
obj:Object — Contains the properties of the component that restore it to its state before printing.
target:IFlexDisplayObject — The component that just finished printing. It may be the current component or one of its children.

See also

mx.printing.FlexPrintJob
focusInHandler () method
protected function focusInHandler(event:FocusEvent):void

The event handler called when a UIComponent object gets focus. If you override this method, make sure to call the base class version.

Parameters
event:FocusEvent — The event object.
focusOutHandler () method
protected function focusOutHandler(event:FocusEvent):void

The event handler called when a UIComponent object loses focus. If you override this method, make sure to call the base class version.

Parameters
event:FocusEvent — The event object.
getClassStyleDeclarations () method
public function getClassStyleDeclarations():Array

Finds the type selectors for this UIComponent instance. The algorithm walks up the superclass chain. For example, suppose that class MyButton extends Button. A MyButton instance will first look for a MyButton type selector then, it will look for a Button type selector. then, it will look for a UIComponent type selector. (The superclass chain is considered to stop at UIComponent, not Object.)

Returns
Array — An Array of type selectors for this UIComponent instance.
getExplicitOrMeasuredHeight () method
public function getExplicitOrMeasuredHeight():Number

A convenience method for determining whether to use the explicit or measured height

Returns
Number — A Number which is explicitHeight if defined or measuredHeight if not.
getExplicitOrMeasuredWidth () method
public function getExplicitOrMeasuredWidth():Number

A convenience method for determining whether to use the explicit or measured width

Returns
Number — A Number which is explicitWidth if defined or measuredWidth if not.
getFocus () method
public function getFocus():InteractiveObject

Gets the object that currently has focus. It might not be this object. Note that this method does not necessarily return the component that has focus. It may return the internal subcomponent of the component that has focus. To get the component that has focus, use the focusManager.focus property.

Returns
InteractiveObject — Object that has focus.
getRepeaterItem () method
public function getRepeaterItem(whichRepeater:int = -1):Object

Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated. The argument whichRepeater is 0 for the outermost Repeater, 1 for the next inner Repeater, and so on. If whichRepeater is not specified, the innermost Repeater is used.

Parameters
whichRepeater:int (default = -1) — Number of the Repeater, counting from the outermost one, starting at 0.

Returns
Object — The requested repeater item.
getStyle () method
public function getStyle(styleProp:String):*

Gets a style property that has been set anywhere in this component's style lookup chain.

This same method is used to get any kind of style property, so the value returned may be a Boolean, String, Number, int, uint (for an RGB color), Class (for a skin), or any kind of object. Therefore the return type is simply specified as

If you are getting a particular style property, you will know its type and will often want to store the result in a variable of that type. No casting from to that type is necessary:

var backgroundColor:uint = getStyle("backgroundColor");

If the style property has not been set anywhere in the style lookup chain, the value returned by getStyle() will be undefined. Note that undefined is a special value that is not the same as false, "", NaN, 0, or null. No valid style value is ever undefined. You can use the static method StyleManager.isValidStyleValue() to test whether the value was set.

Parameters
styleProp:String — Name of the style property.

Returns
* — Style value.

See also

Using the setStyle() and getStyle() methods
globalToContent () method
public function globalToContent(point:Point):Point

Converts a Point object from global to content coordinates. Global coordinates specify a pixel position relative to the upper-left corner of the Stage in Flash Player, that is, the outermost edge of the application. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the global (Stage) coordinate system as properties.

Returns
Point — Point A Point object with coordinates relative to the component.

See also

contentToGlobal()
horizontalGradientMatrix () method
public function horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix

Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.

For performance reasons, the Matrix is stored in a static variable which is reused by all calls to horizontalGradientMatrix() and verticalGradientMatrix(). Therefore, you should pass the resulting Matrix to drawRoundRect() before calling horizontalGradientMatrix() or verticalGradientMatrix() again.

Parameters
x:Number — The left coordinate of the gradient, in pixels.
y:Number — The top coordinate of the gradient, in pixels.
width:Number — The width of the gradient, in pixels.
height:Number — The height of the gradient, in pixels.

Returns
Matrix — The Matrix for the horizontal gradient.
initializationComplete () method
protected function initializationComplete():void

Finalizes the initialization of this component.

This method is the last code that executes when you add a component to a parent for the first time using addChild() or addChildAt(). It handles some housekeeping related to dispatching the initialize event. If you are writing a component, you should not need to override this method.

initialize () method
public function initialize():void

Initializes the internal structure of this component.

Initializing a UIComponent is the fourth step in the creation of a visual component instance, and happens automatically the first time that the instance is added to a parent. Therefore, you do not generally need to call initialize(); the Flex framework calls it for you from UIComponent's override of the addChild() and addChildAt() methods.

The first step in the creation of a visual component instance is construction, with the new operator:

   var okButton:Button = new Button();

After construction, the new Button instance is a solitary DisplayObject; it does not yet have a UITextField as a child to display its label, and it doesn't have a parent.

The second step is configuring the newly-constructed instance with the appropriate properties, styles, and event handlers:

   okButton.label = "OK";
   okButton.setStyle("cornerRadius", 0);
   okButton.addEventListener(MouseEvent.CLICK, clickHandler);

The third step is adding the instance to a parent:

   someContainer.addChild(okButton);

A side effect of calling addChild() or addChildAt(), when adding a component to a parent for the first time, is that initialize gets automatically called.

This method first dispatches a preinitialize event, giving developers using this component a chance to affect it before its internal structure has been created. Next it calls the createChildren() method to create the component's internal structure; for a Button, this method creates and adds the UITextField for the label. Then it dispatches an initialize event, giving developers a chance to affect the component after its internal structure has been created.

Note that it is the act of attaching a component to a parent for the first time that triggers the creation of its internal structure. If its internal structure includes other UIComponents, then this is a recursive process in which the tree of DisplayObjects grows by one leaf node at a time.

If you are writing a component, you should not need to override this method.

initializeAccessibility () method
protected function initializeAccessibility():void

Initializes this component's accessibility code.

This method is called by the initialize() method to hook in the component's accessibility code, which resides in a separate class in the mx.accessibility package. Each subclass that supports accessibility must override this method because the hook-in process uses a different static variable in each subclass.

initializeRepeaterArrays () method
public function initializeRepeaterArrays(parent:IRepeaterClient):void

Initializes various properties which keep track of repeated instances of this component.

An MXML <mx:Repeater/> tag can cause repeated instances of a component to be created, one instance for each item in the Repeater's data provider. The instanceIndices, repeaters, and repeaterIndices properties of UIComponent keep track of which instance came from which data item and which Repeater.

This method is an internal method which is automatically called by the Flex framework. You should not have to call it or override it.

Parameters
parent:IRepeaterClient — The parent object containing the Repeater that created this component.
invalidateDisplayList () method
public function invalidateDisplayList():void

Marks a component so that its updateDisplayList() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the width and height, it would be wasteful to update the component immediately after you change the width and then update again with the new height. It is more efficient to change both properties and then render the component with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

invalidateProperties () method
public function invalidateProperties():void

Marks a component so that its commitProperties() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the text color and size, it would be wasteful to update the color immediately after you change it and then update the size when it gets set. It is more efficient to change both properties and then render the text with its new size and color once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

invalidateSize () method
public function invalidateSize():void

Marks a component so that its measure() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the text and font size, it would be wasteful to update the text immediately after you change it and then update the size when it gets set. It is more efficient to change both properties and then render the text with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

isOurFocus () method
protected function isOurFocus(target:DisplayObject):Boolean

Typically overridden by components containing UITextField objects, where the UITextField object gets focus.

Parameters
target:DisplayObject — A UIComponent object containing a UITextField object that can receive focus.

Returns
Boolean — Returns true if the UITextField object has focus.
keyDownHandler () method
protected function keyDownHandler(event:KeyboardEvent):void

The event handler called for a keyDown event. If you override this method, make sure to call the base class version.

Parameters
event:KeyboardEvent — The event object.
keyUpHandler () method
protected function keyUpHandler(event:KeyboardEvent):void

The event handler called for a keyUp event. If you override this method, make sure to call the base class version.

Parameters
event:KeyboardEvent — The event object.
localToContent () method
public function localToContent(point:Point):Point

Converts a Point object from local to content coordinates. Local coordinates specify a pixel position relative to the upper left corner of the component. Content coordinates specify a pixel position relative to the upper left corner of the component's content, and include all of the component's content area, including any regions that are currently clipped and must be accessed by scrolling the component. You use the content coordinate system to set and get the positions of children of a container that uses absolute positioning.

Parameters
point:Point — A Point object that specifies the x and y coordinates in the local coordinate system as properties.

Returns
Point — Point A Point object with coordinates relative to the content coordinate system.

See also

contentToLocal()
measure () method
protected function measure():void

Calculates the default size, and optionally the default minimum size, of the component. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the measure() method when the component is added to a container using the addChild() method, and when the component's invalidateSize() method is called.

When you set a specific height and width of a component, Flex does not call the measure() method, even if you explicitly call the invalidateSize() method. That is, Flex only calls the measure() method if the explicitWidth property or the explicitHeight property of the component is NaN.

In your override of this method, you must set the measuredWidth and measuredHeight properties to define the default size. You may optionally set the measuredMinWidth and measuredMinHeight properties to define the default minimum size.

Most components calculate these values based on the content they are displaying, and from the properties that affect content display. A few components simply have hard-coded default values.

The conceptual point of measure() is for the component to provide its own natural or intrinsic size as a default. Therefore, the measuredWidth and measuredHeight properties should be determined by factors such as:

  • The amount of text the component needs to display.
  • The styles, such as fontSize, for that text.
  • The size of a JPEG image that the component displays.
  • The measured or explicit sizes of the component's children.
  • Any borders, margins, and gaps.

In some cases, there is no intrinsic way to determine default values. For example, a simple GreenCircle component might simply set measuredWidth = 100 and measuredHeight = 100 in its measure() method to provide a reasonable default size. In other cases, such as a TextArea, an appropriate computation (such as finding the right width and height that would just display all the text and have the aspect ratio of a Golden Rectangle) might be too time-consuming to be worthwhile.

The default implementation of measure() is to set the default size to the current size of the component.

See also

Implementing the measure() method
measureHTMLText () method
public function measureHTMLText(htmlText:String):TextLineMetrics

Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.

Parameters
htmlText:String — A String specifying the HTML text to measure.

Returns
TextLineMetrics — A TextLineMetrics object containing the text measurements.
measureText () method
public function measureText(text:String):TextLineMetrics

Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.

Parameters
text:String — A String specifying the text to measure.

Returns
TextLineMetrics — A TextLineMetrics object containing the text measurements.
move () method
public function move(x:Number, y:Number):void

Moves the component to a specified position within its parent. Calling this method is exactly the same as setting the component's x and y properties.

If you are overriding the updateDisplayList() method in a custom component, you should call the move() method rather than setting the x and y properties. The difference is that the move() method changes the location of the component and then dispatches a move event when you call the method, while setting the x and y properties changes the location of the component and dispatches the event on the next screen refresh.

Parameters
x:Number — Left position of the component within its parent.
y:Number — Top position of the component within its parent.
notifyStyleChangeInChildren () method
public function notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void

Propagate style changes to the children. You typically never need to call this method.

Parameters
styleProp:String — String specifying the name of the style property.
recursive:Boolean — Recursivly notify all children of this component.
owns () method
public function owns(child:DisplayObject):Boolean

Returns true if the chain of owner properties points from child to this UIComponent.

Parameters
child:DisplayObject — A UIComponent.

Returns
Boolean — true if the child is parented or owned by this UIComponent.
parentChanged () method
public function parentChanged(p:DisplayObjectContainer):void

Called by Flex when a UIComponent object is added to or removed from a parent. Developers typically never need to call this method.

Parameters
p:DisplayObjectContainer — The parent of this UIComponent object.
prepareToPrint () method
public function prepareToPrint(target:IFlexDisplayObject):Object

Prepares an IFlexDisplayObject for printing. For the UIComponent class, the method performs no action. Flex containers override the method to prepare for printing; for example, by removing scroll bars from the printed output.

This method is normally not used by application developers.

Parameters
target:IFlexDisplayObject — The component to be printed. It may be the current component or one of its children.

Returns
Object — Object containing the properties of the current component required by the finishPrint() method to restore it to its previous state.

See also

mx.printing.FlexPrintJob
regenerateStyleCache () method
public function regenerateStyleCache(recursive:Boolean):void

Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.

The Flex framework calls this method in the following situations:

  • When you add a UIComponent to a parent using the addChild() or addChildAt( methods.
  • When you change the styleName property of a UIComponent.
  • When you set a style in a CSS selector using the setStyle() method of CSSStyleDeclaration.

Building the style cache is a computation-intensive operation, so you should avoid changing styleName or or setting selector styles unnecessarily.

This method is not called when you set an instance style by calling the setStyle() method of UIComponent. Setting an instance style is a relatively fast operation compared with setting a selector style.

You should not need to call or override this method.

Parameters
recursive:Boolean — Recursivly regenerates the style cache for all children of this component.
registerEffects () method
public function registerEffects(effects:Array):void

For each effect event, register the EffectManager as one of the event listeners. You typically never need to call this method.

Parameters
effects:Array — The names of the effect events.
resumeBackgroundProcessing () method
public static function resumeBackgroundProcessing():void

Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().

Refer to the description of suspendBackgroundProcessing() for more information.

setActualSize () method
public function setActualSize(w:Number, h:Number):void

Sizes the object. Unlike directly setting the width and height properties, calling the setActualSize() method does not set the explictWidth and explicitHeight properties, so a future layout calculation may result in the object returning to its previous size. This method is used primarily by component developers implementing the updateDisplayList() method, by Effects, and by the LayoutManager.

Parameters
w:Number — Width of the object.
h:Number — Height of the object.
setCurrentState () method
public function setCurrentState(stateName:String, playTransition:Boolean = true):void

Set the current state.

Parameters
stateName:String — The name of the new view state.
playTransition:Boolean (default = true) — If true, play the appropriate transition when the view state changes.

See also

currentState
setFocus () method
public function setFocus():void

Sets the focus to this component. The component may in turn pass focus to a subcomponent.

Note: Only the TextInput and TextArea controls show a highlight when this method sets the focus. All controls show a highlight when the user tabs to the control.

setStyle () method
public function setStyle(styleProp:String, newValue:*):void

Sets a style property on this component instance.

This may override a style that was set globally.

Calling the setStyle() method can result in decreased performance. Use it only when necessary.

Parameters
styleProp:String — Name of the style property.
newValue:* — New value for the style.

See also

Using the setStyle() and getStyle() methods
Applying styles to custom components
About overriding the styleChanged() method
setVisible () method
public function setVisible(value:Boolean, noEvent:Boolean = false):void

Called when the visible property changes. You should set the visible property to show or hide a component instead of calling this method directly.

Parameters
value:Boolean — The new value of the visible property. Specify true to show the component, and false to hide it.
noEvent:Boolean (default = false) — If true, do not dispatch an event. If false, dispatch a show event when the component becomes visible, and a hide event when the component becomes invisible.
styleChanged () method
public function styleChanged(styleProp:String):void

Detects changes to style properties. When any style property is set, Flex calls the styleChanged() method, passing to it the name of the style being set.

This is an advanced method that you might override when creating a subclass of UIComponent. When you create a custom component, you can override the styleChanged() method to check the style name passed to it, and handle the change accordingly. This lets you override the default behavior of an existing style, or add your own custom style properties.

If you handle the style property, your override of the styleChanged() method should call the invalidateDisplayList() method to cause Flex to execute the component's updateDisplayList() method at the next screen update.

Parameters
styleProp:String — The name of the style property, or null if all styles for this component have changed.
stylesInitialized () method
public function stylesInitialized():void

Flex calls the stylesInitialized() method when the styles for a component are first initialized.

This is an advanced method that you might override when creating a subclass of UIComponent. Flex guarantees that your component's styles will be fully initialized before the first time your component's measure and updateDisplayList methods are called. For most components, that is sufficient. But if you need early access to your style values, you can override the stylesInitialized() function to access style properties as soon as they are initialized the first time.

suspendBackgroundProcessing () method
public static function suspendBackgroundProcessing():void

Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.

These methods can be useful when you have time-critical code which needs to execute without interruption. For example, when you set the suspendBackgroundProcessing property of an Effect to true, suspendBackgroundProcessing() is automatically called when it starts playing, and resumeBackgroundProcessing is called when it stops, in order to ensure that the animation is smooth.

Since the LayoutManager uses callLater(),
   this means that commitProperties(),
   measure(), and updateDisplayList()
   will not get called in between calls to
   suspendBackgroundProcessing() and
   resumeBackgroundProcessing().

It is safe for both an outer method and an inner method (i.e., one that the outer methods calls) to call suspendBackgroundProcessing() and resumeBackgroundProcessing(), because these methods actually increment and decrement a counter which determines whether background processing occurs.

updateDisplayList () method
protected function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Draws the object and/or sizes and positions its children. This is an advanced method that you might override when creating a subclass of UIComponent.

You do not call this method directly. Flex calls the updateDisplayList() method when the component is added to a container using the addChild() method, and when the component's invalidateDisplayList() method is called.

If the component has no children, this method is where you would do programmatic drawing using methods on the component's Graphics object such as graphics.drawRect().

If the component has children, this method is where you would call the move() and setActualSize() methods on its children.

Components may do programmatic drawing even if they have children. In doing either, you should use the component's unscaledWidth and unscaledHeight as its bounds.

It is important to use unscaledWidth and unscaledHeight instead of the width and height properties.

Parameters
unscaledWidth:Number — Specifies the width of the component, in pixels, in the component's coordinates, regardless of the value of the scaleX property of the component.
unscaledHeight:Number — Specifies the height of the component, in pixels, in the component's coordinates, regardless of the value of the scaleY property of the component.

See also

Implementing the updateDisplayList() method
validateDisplayList () method
public function validateDisplayList():void

Validates the position and size of children and draws other visuals. If the LayoutManager.invalidateDisplayList() method is called with this ILayoutManagerClient, then the validateDisplayList() method is called when it's time to update the display list.

validateNow () method
public function validateNow():void

Validate and update the properties and layout of this object and redraw it, if necessary. Processing properties that require substantial computation are normally not processed until the script finishes executing. For example setting the width property is delayed, because it may require recalculating the widths of the objects children or its parent. Delaying the processing prevents it from being repeated multiple times if the script sets the width property more than once. This method lets you manually override this behavior.

validateProperties () method
public function validateProperties():void

Used by layout logic to validate the properties of a component by calling the commitProperties() method. In general, subclassers should override the commitProperties() method and not this method.

validateSize () method
public function validateSize(recursive:Boolean = false):void

Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.

Parameters
recursive:Boolean (default = false) — If true, call this method on the objects children.
validationResultHandler () method
public function validationResultHandler(event:ValidationResultEvent):void

Handles both the valid and invalid events from a validator assigned to this component.

You typically handle the valid and invalid events dispatched by a validator by assigning event listeners to the validators. If you want to handle validation events directly in the component that is being validated, you can override this method to handle the valid and invalid events. You typically call super.validationResultHandler(event) in your override.

Parameters
event:ValidationResultEvent — The event object for the validation.

See also

mx.events.ValidationResultEvent
verticalGradientMatrix () method
public function verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix

Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.

For performance reasons, the Matrix is stored in a static variable which is reused by all calls to horizontalGradientMatrix() and verticalGradientMatrix(). Therefore, you should pass the resulting Matrix to drawRoundRect() before calling horizontalGradientMatrix() or verticalGradientMatrix() again.

Parameters
x:Number — The left coordinate of the gradient, in pixels.
y:Number — The top coordinate of the gradient, in pixels.
width:Number — The width of the gradient, in pixels.
height:Number — The height of the gradient, in pixels.

Returns
Matrix — The Matrix for the vertical gradient.
Event detail
add event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.ADD

Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. If the component is added to the container as a noncontent child by using the rawChildren.addChild() or rawChildren.addChildAt() method, the event is not dispatched.

The FlexEvent.ADD constant defines the value of the type property of the event object for an add event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
creationComplete event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.CREATION_COMPLETE

Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing.

At this point, depending on its visible property, the component may not be visible even though it has been drawn.

The FlexEvent.CREATION_COMPLETE constant defines the value of the type property of the event object for a creationComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
currentStateChange event
Event object type: mx.events.StateChangeEvent
StateChangeEvent.type property = mx.events.StateChangeEvent.CURRENT_STATE_CHANGE

Dispatched after the view state has changed.

The StateChangeEvent.CURRENT_STATE_CHANGE constant defines the value of the type property of the event that is dispatched when the view state has changed. The value of this constant is "currentStateChange".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
newState | The name of the view state that was entered.
oldState | The name of the view state that was exited.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | StateChangeEvent.CURRENT_STATE_CHANGE
currentStateChanging event
Event object type: mx.events.StateChangeEvent
StateChangeEvent.type property = mx.events.StateChangeEvent.CURRENT_STATE_CHANGING

Dispatched after the currentState property changes, but before the view state changes.

The StateChangeEvent.CURRENT_STATE_CHANGING constant defines the value of the type property of the event that is dispatched when the view state is about to change. The value of this constant is "currentStateChanging".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
newState | The name of the view state that is being entered.
oldState | The name of the view state that is being exited.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | StateChangeEvent.CURRENT_STATE_CHANGING
dragComplete event
Event object type: mx.events.DragEvent
DragEvent.type property = mx.events.DragEvent.DRAG_COMPLETE

Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop.

You can use this event to perform any final cleanup of the drag-and-drop operation. For example, if you drag a List control item from one list to another, you can delete the List control item from the source if you no longer need it.

The DragEvent.DRAG_COMPLETE constant defines the value of the type property of the event object for a dragComplete event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
dragDrop event
Event object type: mx.events.DragEvent
DragEvent.type property = mx.events.DragEvent.DRAG_DROP

Dispatched by the drop target when the user releases the mouse over it.

You use this event handler to add the drag data to the drop target.

The DragEvent.DRAG_DROP constant defines the value of the type property of the event object for a dragDrop event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
dragEnter event
Event object type: mx.events.DragEvent
DragEvent.type property = mx.events.DragEvent.DRAG_ENTER

Dispatched by a component when the user moves the mouse over the component during a drag operation.

In order to be a valid drop target, you must define a handler for this event. In the handler, you can change the appearance of the drop target to provide visual feedback to the user that the component can accept the drag. For example, you could draw a border around the drop target, or give focus to the drop target.

If you want to accept the drag, you must call the DragManager.acceptDragDrop() method. If you don't call acceptDragDrop(), you will not get any of the other drag events.

The value of the action property is always DragManager.MOVE, even if you are doing a copy. This is because the dragEnter event occurs before the control recognizes that the Control key is pressed to signal a copy. The action property of the event object for the dragOver event does contain a value that signifies the type of drag operation.

You may change the type of drag action by calling the DragManager.showFeedback() method.

The DragEvent.DRAG_ENTER constant defines the value of the type property of the event object for a dragEnter event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event, which is always DragManager.MOVE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

mx.managers.DragManager
dragExit event
Event object type: mx.events.DragEvent
DragEvent.type property = mx.events.DragEvent.DRAG_EXIT

Dispatched by the component when the user drags outside the component, but does not drop the data onto the target.

You use this event to restore the drop target to its normal appearance if you modified its appearance as part of handling the dragEnter or dragOver event.

The DragEvent.DRAG_EXIT constant defines the value of the type property of the event object for a dragExit event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
dragOver event
Event object type: mx.events.DragEvent
DragEvent.type property = mx.events.DragEvent.DRAG_OVER

Dispatched by a component when the user moves the mouse while over the component during a drag operation.

In the handler, you can change the appearance of the drop target to provide visual feedback to the user that the component can accept the drag. For example, you could draw a border around the drop target, or give focus to the drop target.

You should handle this event to perform additional logic before allowing the drop, such as dropping data to various locations in the drop target, reading keyboard input to determine if the drag-and-drop action is a move or copy of the drag data, or providing different types of visual feedback based on the type of drag-and-drop action.

You may also change the type of drag action by changing the DragManager.showFeedback() method. The default value of the action property is DragManager.MOVE.

The DragEvent.DRAG_OVER constant defines the value of the type property of the event object for a dragOver event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

mx.managers.DragManager
effectEnd event
Event object type: mx.events.EffectEvent
EffectEvent.type property = mx.events.EffectEvent.EFFECT_END

Dispatched after an effect ends.

The effect will have made the last set of visual changes before this event is fired, but those changes will not have been rendered on the screen. Thus, you might have to use the callLater() method to delay any other changes that you want to make until after the changes have been rendered onscreen.

The EffectEvent.EFFECT_END constant defines the value of the type property of the event object for an effectEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
effectInstance | The effect instance object for the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
effectStart event
Event object type: mx.events.EffectEvent
EffectEvent.type property = mx.events.EffectEvent.EFFECT_START

Dispatched just before an effect starts.

The effect does not start changing any visuals until after this event is fired.

The EffectEvent.EFFECT_START constant defines the value of the type property of the event object for an effectStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
effectInstance | The effect instance object for the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
enterState event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.ENTER_STATE

Dispatched after the component has returned to the root view state.

The FlexEvent.ENTER_STATE constant defines the value of the type property of the event object for a enterState event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
exitState event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.EXIT_STATE

Dispatched before the component exits from the root view state.

The FlexEvent.EXIT_STATE constant defines the value of the type property of the event object for a exitState event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
hide event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.HIDE

Dispatched when an object's state changes from visible to invisible.

The FlexEvent.HIDE constant defines the value of the type property of the event object for a hide event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
initialize event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.INITIALIZE

Dispatched when the component has finished its construction and has all initialization properties set.

After the initialization phase, properties are processed, the component is measured, laid out, and drawn, after which the creationComplete event is dispatched.

The FlexEvent.INITIALIZE constant defines the value of the type property of the event object for a initialize event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
invalid event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.INVALID

Dispatched when a component is monitored by a Validator and the validation failed.

The FlexEvent.INVALID constant defines the value of the type property of the event object for a invalid event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
mouseDownOutside event
Event object type: mx.events.FlexMouseEvent
FlexMouseEvent.type property = mx.events.FlexMouseEvent.MOUSE_DOWN_OUTSIDE

Dispatched from a component opened using the PopUpManager when the user clicks outside it.

The FlexMouseEvent.MOUSE_DOWN_OUTSIDE constant defines the value of the type property of the event object for a mouseDownOutside event.

The properties of the event object have the following values:

Property | Value
altKey | Indicates whether the Alt key is down (true) or not (false).
bubbles | false
buttonDown | Indicates whether the main mouse button is down (true) or not (false).
cancelable | false
ctrlKey | Indicates whether the Control key is down (true) or not (false).
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget. For PopUpManager events, the object is the pop-up window.
delta | Indicates how many lines should be scrolled for each notch the user scrolls the mouse wheel. For PopUpManager events this value is 0.
localX | The horizontal position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
localY | The vertical position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
relatedObject | A reference to a display list object that is related to the event. For PopUpManager events, the object is the container over which the mouse pointer is located.
shiftKey | Indicates whether the Shift key is down (true) or not (false).
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event. For PopUpManager events, the object is the pop-up window.
mouseWheelOutside event
Event object type: mx.events.FlexMouseEvent
FlexMouseEvent.type property = mx.events.FlexMouseEvent.MOUSE_WHEEL_OUTSIDE

Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it.

The FlexMouseEvent.MOUSE_WHEEL_OUTSIDE constant defines the value of the type property of the event object for a mouseWheelOutside event.

The properties of the event object have the following values:

Property | Value
altKey | Indicates whether the Alt key is down (true) or not (false).
bubbles | false
buttonDown | Indicates whether the main mouse button is down (true) or not (false).
cancelable | false
ctrlKey | Indicates whether the Control key is down (true) or not (false).
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget. For PopUpManager events, the object is the pop-up window.
delta | Indicates how many lines should be scrolled for each notch the user scrolls the mouse wheel. For PopUpManager events this value is 0.
localX | The horizontal position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
localY | The vertical position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
relatedObject | A reference to a display list object that is related to the event. For PopUpManager events, the object is the container over which the mouse pointer is located.
shiftKey | Indicates whether the Shift key is down (true) or not (false).
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event. For PopUpManager events, the object is the pop-up window.
move event
Event object type: mx.events.MoveEvent
MoveEvent.type property = mx.events.MoveEvent.MOVE

Dispatched when the object has moved.

You can move the component by setting the x or y properties, by calling the move() method, by setting one of the following properties either on the component or on other components such that the LayoutManager needs to change the x or y properties of the component:

  • minWidth
  • minHeight
  • maxWidth
  • maxHeight
  • explicitWidth
  • explicitHeight

When you call the move() method, the move event is dispatched before the method returns. In all other situations, the move event is not dispatched until after the property changes.

The MoveEvent.MOVE constant defines the value of the type property of the event object for a move event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
oldX | The previous x coordinate of the object, in pixels.
oldY | The previous y coordinate of the object, in pixels.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
preinitialize event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.PREINITIALIZE

Dispatched at the beginning of the component initialization sequence. The component is in a very raw state when this event is dispatched. Many components, such as the Button control, create internal child components to implement functionality; for example, the Button control creates an internal UITextField component to represent its label text. When Flex dispatches the preinitialize event, the children, including the internal children, of a component have not yet been created.

The FlexEvent.PREINITIALIZE constant defines the value of the type property of the event object for a preinitialize event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
remove event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.REMOVE

Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. If the component is removed from the container as a noncontent child by using the rawChildren.removeChild() or rawChildren.removeChildAt() method, the event is not dispatched.

The FlexEvent.REMOVE constant defines the value of the type property of the event object for an remove event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
resize event
Event object type: mx.events.ResizeEvent
ResizeEvent.type property = mx.events.ResizeEvent.RESIZE

Dispatched when the component is resized.

You can resize the component by setting the width or height property, by calling the setActualSize() method, or by setting one of the following properties either on the component or on other components such that the LayoutManager needs to change the width or height properties of the component:

  • minWidth
  • minHeight
  • maxWidth
  • maxHeight
  • explicitWidth
  • explicitHeight

The resize event is not dispatched until after the property changes.

The ResizeEvent.RESIZE constant defines the value of the type property of the event object for a resize event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
oldHeight | The previous height of the object, in pixels.
oldWidth | The previous width of the object, in pixels.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
show event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.SHOW

Dispatched when an object's state changes from invisible to visible.

The FlexEvent.SHOW constant defines the value of the type property of the event object for a show event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
toolTipCreate event
Event object type: mx.events.ToolTipEvent
ToolTipEvent.type property = mx.events.ToolTipEvent.TOOL_TIP_CREATE

Dispatched by the component when it is time to create a ToolTip.

If you create your own IToolTip object and place a reference to it in the toolTip property of the event object that is passed to your toolTipCreate handler, the ToolTipManager displays your custom ToolTip. Otherwise, the ToolTipManager creates an instance of ToolTipManager.toolTipClass to display.

The sequence of ToolTip events is toolTipStart, toolTipCreate, toolTipShow, toolTipShown, toolTipHide, and toolTipEnd.

The ToolTipEvent.TOOL_TIP_CREATE constant defines the value of the type property of the event object for a toolTipCreate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
toolTipEnd event
Event object type: mx.events.ToolTipEvent
ToolTipEvent.type property = mx.events.ToolTipEvent.TOOL_TIP_END

Dispatched by the component when its ToolTip has been hidden and will be discarded soon.

If you specify an effect using the ToolTipManager.hideEffect property, this event is dispatched after the effect stops playing.

The sequence of ToolTip events is toolTipStart, toolTipCreate, toolTipShow, toolTipShown, toolTipHide, and toolTipEnd.

The ToolTipEvent.TOOL_TIP_END constant defines the value of the type property of the event object for a toolTipEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
toolTipHide event
Event object type: mx.events.ToolTipEvent
ToolTipEvent.type property = mx.events.ToolTipEvent.TOOL_TIP_HIDE

Dispatched by the component when its ToolTip is about to be hidden.

If you specify an effect using the ToolTipManager.hideEffect property, this event is dispatched before the effect starts playing.

The sequence of ToolTip events is toolTipStart, toolTipCreate, toolTipShow, toolTipShown, toolTipHide, and toolTipEnd.

The ToolTipEvent.TOOL_TIP_HIDE constant defines the value of the type property of the event object for a toolTipHide event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
toolTipShow event
Event object type: mx.events.ToolTipEvent
ToolTipEvent.type property = mx.events.ToolTipEvent.TOOL_TIP_SHOW

Dispatched by the component when its ToolTip is about to be shown.

If you specify an effect using the ToolTipManager.showEffect property, this event is dispatched before the effect starts playing. You can use this event to modify the ToolTip before it appears.

The sequence of ToolTip events is toolTipStart, toolTipCreate, toolTipShow, toolTipShown, toolTipHide, and toolTipEnd.

The ToolTipEvent.TOOL_TIP_SHOW constant defines the value of the type property of the event object for a toolTipShow event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
toolTipShown event
Event object type: mx.events.ToolTipEvent
ToolTipEvent.type property = mx.events.ToolTipEvent.TOOL_TIP_SHOWN

Dispatched by the component when its ToolTip has been shown.

If you specify an effect using the ToolTipManager.showEffect property, this event is dispatched after the effect stops playing.

The sequence of ToolTip events is toolTipStart, toolTipCreate, toolTipShow, toolTipShown, toolTipHide, and toolTipEnd.

The ToolTipEvent.TOOL_TIP_SHOWN constant defines the value of the type property of the event object for a toolTipShown event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
toolTipStart event
Event object type: mx.events.ToolTipEvent
ToolTipEvent.type property = mx.events.ToolTipEvent.TOOL_TIP_START

Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it.

The sequence of ToolTip events is toolTipStart, toolTipCreate, toolTipShow, toolTipShown, toolTipHide, and toolTipEnd.

The ToolTipEvent.TOOL_TIP_START constant defines the value of the type property of the event object for a toolTipStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
updateComplete event
Event object type: flash.events.Event
Event.type property = mx.events.FlexEvent.UPDATE_COMPLETE

Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed).

This is the last opportunity to alter the component before it is displayed. All properties have been committed and the component has been measured and layed out.

The FlexEvent.UPDATE_COMPLETE constant defines the value of the type property of the event object for a updateComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
valid event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.VALID

Dispatched when a component is monitored by a Validator and the validation succeeded.

The FlexEvent.VALID constant defines the value of the type property of the event object for a valid event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
valueCommit event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.VALUE_COMMIT

Dispatched when values are changed programmatically or by user interaction.

Because a programmatic change triggers this event, make sure that any valueCommit event handler does not change a value that causes another valueCommit event. For example, do not change a control's dataProvider property in a valueCommit event handler.

The FlexEvent.VALUE_COMMIT constant defines the value of the type property of the event object for a valueCommit event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Constant detail
DEFAULT_MAX_HEIGHT constant
public static const DEFAULT_MAX_HEIGHT:Number = 10000

The default value for the maxHeight property.

The default value is 10000.

DEFAULT_MAX_WIDTH constant
public static const DEFAULT_MAX_WIDTH:Number = 10000

The default value for the maxWidth property.

The default value is 10000.

DEFAULT_MEASURED_HEIGHT constant
public static const DEFAULT_MEASURED_HEIGHT:Number = 22

The default value for the measuredHeight property. Most components calculate a measuredHeight but some are flow-based and have to pick a number that looks reasonable.

The default value is 22.

DEFAULT_MEASURED_MIN_HEIGHT constant
public static const DEFAULT_MEASURED_MIN_HEIGHT:Number = 22

The default value for the measuredMinHeight property. Most components calculate a measuredMinHeight but some are flow-based and have to pick a number that looks reasonable.

The default value is 22.

DEFAULT_MEASURED_MIN_WIDTH constant
public static const DEFAULT_MEASURED_MIN_WIDTH:Number = 40

The default value for the measuredMinWidth property. Most components calculate a measuredMinWidth but some are flow-based and have to pick a number that looks reasonable.

The default value is 40.

DEFAULT_MEASURED_WIDTH constant
public static const DEFAULT_MEASURED_WIDTH:Number = 160

The default value for the measuredWidth property. Most components calculate a measuredWidth but some are flow-based and have to pick a number that looks reasonable.

The default value is 160.


mx.core.UIComponentCachePolicy (Flex™ 2 Language Reference)

Class UIComponentCachePolicy | Properties | Methods | Constants
Package | mx.core
Class | public final class UIComponentCachePolicy
Inheritance | UIComponentCachePolicy Inheritance Object

The ContainerCreationPolicy class defines the constant values for the cachePolicy property of the UIComponent class.

See also

mx.core.UIComponent.cachePolicy

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | AUTO : String = "auto" [static] Specifies that the Flex framework should use heuristics to decide whether to cache the object as a bitmap. | UIComponentCachePolicy
 | OFF : String = "off" [static] Specifies that the Flex framework should never attempt to cache the object as a bitmap. | UIComponentCachePolicy
 | ON : String = "on" [static] Specifies that the Flex framework should always cache the object as a bitmap. | UIComponentCachePolicy
Constant detail
AUTO constant
public static const AUTO:String = "auto"

Specifies that the Flex framework should use heuristics to decide whether to cache the object as a bitmap.

OFF constant
public static const OFF:String = "off"

Specifies that the Flex framework should never attempt to cache the object as a bitmap.

ON constant
public static const ON:String = "on"

Specifies that the Flex framework should always cache the object as a bitmap.


mx.core.UIComponentDescriptor (Flex™ 2 Language Reference)

Class UIComponentDescriptor | Properties | Methods
Package | mx.core
Class | public class UIComponentDescriptor
Inheritance | UIComponentDescriptor Inheritance ComponentDescriptor Inheritance Object

A UIComponentDescriptor instance encapsulates the information that you specified in an MXML tag for an instance of a visual component.

Most of the tags in an MXML file describe a tree of UIComponent objects. For example, the <mx:Application> tag represents a UIComponent object, and its child containers and controls are all UIComponent objects.

The MXML compiler compiles each of these MXML tags into a UIComponentDescriptor instance. To be precise, the MXML compiler autogenerates an ActionScript data structure which is a tree of UIComponentDescriptor objects.

At runtime, the createComponentsFromDescriptors() method of the Container class uses the information in the UIComponentDescriptor objects in the container's childDescriptors array to create the actual UIComponent objects that are the container's children, plus deeper descendants as well. Depending on the value of the container's creationPolicy, property, the descendants might be created at application startup, when some part of the component is about to become visible, or when the application developer manually calls the createComponentsFromDescriptors() method.

You do not typically create UIComponentDescriptor instances yourself; you can access the ones that the MXML compiler autogenerates via the childDescriptors array of the Container class.

See also

mx.core.Container.childDescriptors
mx.core.Container.creationPolicy
mx.core.Container.createComponentsFromDescriptors()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | document : Object A reference to the document Object in which the component is to be created. | ComponentDescriptor
 | effects : Array An Array containing the effects for the component, as specified in MXML. | UIComponentDescriptor
Inherited | events : Object An Object containing name/value pairs for the component's event handlers, as specified in MXML. | ComponentDescriptor
Inherited | id : String The identifier for the component, as specified in MXML. | ComponentDescriptor
Inherited | properties : Object An Object containing name/value pairs for the component's properties, as specified in MXML. | ComponentDescriptor
Inherited | propertiesFactory : Function A Function that returns an Object containing name/value pairs for the component's properties, as specified in MXML. | ComponentDescriptor
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | stylesFactory : Function A Function that constructs an Object containing name/value pairs for the instance styles for the component, as specified in MXML. | UIComponentDescriptor
Inherited | type : Class The Class of the component, as specified in MXML. | ComponentDescriptor
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | UIComponentDescriptor(descriptorProperties:Object) Constructor. | UIComponentDescriptor
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | invalidateProperties():void Invalidates the cached properties property. | ComponentDescriptor
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "ComponentDescriptor_" plus the value of the id property. | ComponentDescriptor
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
effects property
public var effects:Array

An Array containing the effects for the component, as specified in MXML.

For example, if you write the following code:

   <mx:TextInput showEffect="Fade" hideEffect="Fade"/>

The descriptor's effects property is the Array [ "showEffect", "hideEffect" ].

The effectsproperty is null if no MXML effects were specified for the component.

Note that the values of the effect attributes are not specified in this property. Instead, effects are treated like styles and therefore are include in the stylesFactory property. The effect Array simply keeps track of which styles in the stylesFactory are actually effects.

This property is used by the Container method createComponentsFromDescriptors() to register the effects with the EffectManager.

stylesFactory property
public var stylesFactory:Function

A Function that constructs an Object containing name/value pairs for the instance styles for the component, as specified in MXML.

For example, if you write the following code:

   <mx:TextInput borderColor="0x888888" color="0xDDDDDD"/>

Then the descriptors' stylesFactory property is the Function:

   function():void { this.borderColor = 0x888888; this.color = 0xDDDDDD };

The stylesFactory property is null if no MXML styles were specified for the component instance.

Constructor detail
UIComponentDescriptor () constructor
public function UIComponentDescriptor(descriptorProperties:Object)

Constructor.

Parameters
descriptorProperties:Object — An Object containing name/value pairs for the properties of the UIComponentDescriptor object, such as its type, id, propertiesFactory, events, stylesFactory, and effects.


mx.core.UITextField (Flex™ 2 Language Reference)

Class UITextField | Properties | Methods | Events | Styles
Package | mx.core
Class | public class UITextField
Inheritance | UITextField Inheritance FlexTextField Inheritance TextField Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IIMESupport, IInvalidating, ISimpleStyleClient, IToolTipManagerClient, IUIComponent
Subclasses | DataGridItemRenderer

The UITextField class defines the component used by many Flex components to display text. For example, the mx.controls.Button control uses a UITextField component to define the label area of the Button control.

The UITextField class extends the flash.text.TextField class to support additional functionality required by Flex, such as CSS styles, invalidation/measurement/layout, enabling/disabling, tooltips, and IME (Input Method Editor) support for entering Chinese, Japanese, and Korean text.

See also

flash.text.TextField
mx.core.UITextFormat

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | alwaysShowSelection : Boolean When set to true and the text field is not in focus, Flash Player highlights the selection in the text field in gray. | TextField
Inherited | antiAliasType : String The type of anti-aliasing used for this text field. | TextField
Inherited | autoSize : String Controls automatic sizing and alignment of text fields. | TextField
Inherited | background : Boolean Specifies whether the text field has a background fill. | TextField
Inherited | backgroundColor : uint The color of the text field background. | TextField
 | baselinePosition : Number [read-only] Determines the baseline y-coordinate of the first line of text of the component. | UITextField
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | border : Boolean Specifies whether the text field has a border. | TextField
Inherited | borderColor : uint The color of the text field border. | TextField
Inherited | bottomScrollV : int An integer (1-based index) that indicates the bottommost line that is currently visible in the specified text field. | TextField
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | caretIndex : int The index of the insertion point (caret) position. | TextField
 | className : String [read-only] The name of this instance's class, such as "DataGridItemRenderer". | UITextField
Inherited | condenseWhite : Boolean A Boolean value that specifies whether extra white space (spaces, line breaks, and so on) in a text field with HTML text should be removed. | TextField
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | defaultTextFormat : TextFormat Specifies the format applied to newly inserted text, such as text inserted with the replaceSelectedText() method or text entered by a user. | TextField
Inherited | displayAsPassword : Boolean Specifies whether the text field is a password text field. | TextField
 | document : Object A reference to the document object associated with this UITextField object. | UITextField
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | embedFonts : Boolean Specifies whether to render by using embedded font outlines. | TextField
 | enabled : Boolean A Boolean value that indicates whether the component is enabled. | UITextField
 | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UITextField
 | explicitMaxHeight : Number [read-only] Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UITextField
 | explicitMaxWidth : Number [read-only] Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UITextField
 | explicitMinHeight : Number [read-only] Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UITextField
 | explicitMinWidth : Number [read-only] Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UITextField
 | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UITextField
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | focusPane : Sprite A single Sprite object that is shared among components and used as an overlay for drawing focus. | UITextField
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | gridFitType : String The type of grid fitting used for this text field. | TextField
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | htmlText : String Contains the HTML representation of the text field's contents. | TextField
 | ignorePadding : Boolean If true, the paddingLeft and paddingRight styles will not add space around the text of the component. | UITextField
 | imeMode : String Specifies the IME (input method editor) mode. | UITextField
 | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UITextField
 | inheritingStyles : Object The beginning of this UITextField's chain of inheriting styles. | UITextField
 | initialized : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required) | UITextField
Inherited | length : int The number of characters in a text field. | TextField
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxChars : int The maximum number of characters that the text field can contain, as entered by a user. | TextField
 | maxHeight : Number [read-only] Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UITextField
Inherited | maxScrollH : int The maximum value of scrollH. | TextField
Inherited | maxScrollV : int The maximum value of scrollV. | TextField
 | maxWidth : Number [read-only] Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UITextField
 | measuredHeight : Number [read-only] The default height of the component, in pixels. | UITextField
 | measuredMinHeight : Number The default minimum height of the component, in pixels. | UITextField
 | measuredMinWidth : Number The default minimum width of the component, in pixels. | UITextField
 | measuredWidth : Number [read-only] The default width of the component, in pixels. | UITextField
 | minHeight : Number [read-only] Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UITextField
 | minWidth : Number [read-only] Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UITextField
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseWheelEnabled : Boolean A Boolean value that indicates whether Flash Player should automatically scroll multiline text fields when the user clicks a text field and rolls the mouse wheel. | TextField
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | multiline : Boolean Indicates whether the text field is a multiline text field. | TextField
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | nestLevel : int Depth of this object in the containment hierarchy. | UITextField
 | nonInheritingStyles : Object The beginning of this UITextField's chain of non-inheriting styles. | UITextField
Inherited | numLines : int Defines the number of text lines in a multiline text field. | TextField
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | owner : DisplayObjectContainer By default, set to the parent container of this object. | UITextField
 | parent : DisplayObjectContainer [read-only] The parent container or component for this component. | UITextField
 | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UITextField
 | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UITextField
 | processedDescriptors : Boolean Set to true after the createChildren() method creates any internal component children. | UITextField
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | restrict : String Indicates the set of characters that a user can enter into the text field. | TextField
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollH : int The current horizontal scrolling position. | TextField
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | scrollV : int The vertical position of text in a text field. | TextField
Inherited | selectable : Boolean A Boolean value that indicates whether the text field is selectable. | TextField
Inherited | selectionBeginIndex : int The zero-based character index value of the first character in the current selection. | TextField
Inherited | selectionEndIndex : int The zero-based character index value of the last character in the current selection. | TextField
Inherited | sharpness : Number The sharpness of the glyph edges in this text field. | TextField
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | styleName : Object The class style used by this component. | UITextField
Inherited | styleSheet : StyleSheet Attaches a style sheet to the text field. | TextField
 | systemManager : ISystemManager Returns the SystemManager object used by this component. | UITextField
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | text : String A string that is the current text in the text field. | TextField
Inherited | textColor : uint The color of the text in a text field, in hexadecimal format. | TextField
Inherited | textHeight : Number The height of the text in pixels. | TextField
Inherited | textWidth : Number The width of the text in pixels. | TextField
Inherited | thickness : Number The thickness of the glyph edges in this text field. | TextField
 | toolTip : String Text to display in the ToolTip. | UITextField
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UITextField
Inherited | type : String The type of the text field. | TextField
 | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required) | UITextField
Inherited | useRichTextClipboard : Boolean Specifies whether to copy and paste the text formatting along with the text. | TextField
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | wordWrap : Boolean A Boolean value that indicates whether the text field has word wrap. | TextField
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
UITextField()
Constructor.
UITextField
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
appendText(newText:String):void
Appends the string specified by the newText parameter to the end of the text of the TextField.
TextField
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getCharBoundaries(charIndex:int):Rectangle
Returns a rectangle that is the bounding box of the character.
TextField
Inherited
getCharIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the character at the point specified by the x and y parameters.
TextField
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UITextField
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UITextField
Inherited
getFirstCharInParagraph(charIndex:int):int
Given a character index, returns the index of the first character in the same paragraph.
TextField
Inherited
getImageReference(id:String):DisplayObject
Returns a DisplayObject reference for the given id, for an image or SWF file that has been added to an HTML-formatted text field by using an <img> tag.
TextField
Inherited
getLineIndexAtPoint(x:Number, y:Number):int
Returns the zero-based index value of the line at the point specified by the x and y parameters.
TextField
Inherited
getLineIndexOfChar(charIndex:int):int
Returns the zero-based index value of the line containing the character specified by the charIndex parameter.
TextField
Inherited
getLineLength(lineIndex:int):int
Returns the number of characters in a specific text line.
TextField
Inherited
getLineMetrics(lineIndex:int):TextLineMetrics
Returns metrics information about a given text line.
TextField
Inherited
getLineOffset(lineIndex:int):int
Returns the character index of the first character in the line that the lineIndex parameter specifies.
TextField
Inherited
getLineText(lineIndex:int):String
Returns the text of the line specified by the lineIndex parameter.
TextField
Inherited
getParagraphLength(charIndex:int):int
Given a character index, returns the length of the paragraph containing the given character.
TextField
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UITextField
Inherited
getTextFormat(beginIndex:int = -1, endIndex:int = -1):TextFormat
Returns a TextFormat object that contains formatting information for the range of text that the beginIndex and endIndex parameters specify.
TextField
getTextStyles():TextFormat
Returns the TextFormat object that represents character formatting information for this UITextField object.
UITextField
getUITextFormat():UITextFormat
Returns a UITextFormat object that contains formatting information for this component.
UITextField
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
initialize():void
Initializes this component.
UITextField
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UITextField
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UITextField
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UITextField
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UITextField
owns(child:DisplayObject):Boolean
Returns true if the child is parented or owned by this object.
UITextField
parentChanged(p:DisplayObjectContainer):void
This function is called when a UITextField object is assigned a parent.
UITextField
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
replaceSelectedText(value:String):void
Replaces the current selection with the contents of the value parameter.
TextField
Inherited
replaceText(beginIndex:int, endIndex:int, newText:String):void
Replaces the range of characters that the beginIndex and endIndex parameters specify with the contents of the newText parameter.
TextField
setActualSize(w:Number, h:Number):void
Sizes the object.
UITextField
setColor(color:uint):void
Sets the font color of the text.
UITextField
setFocus():void
Sets the focus to this component.
UITextField
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setSelection(beginIndex:int, endIndex:int):void
Sets as selected the text designated by the index values of the first and last characters, which are specified with the beginIndex and endIndex parameters.
TextField
setStyle(styleProp:String, value:*):void
Does nothing.
UITextField
Inherited
setTextFormat(format:TextFormat, beginIndex:int = -1, endIndex:int = -1):void
Applies the text formatting that the format parameter specifies to the specified text in a text field.
TextField
setVisible(visible:Boolean, noEvent:Boolean = false):void
Sets the visible property of this UITextField object.
UITextField
styleChanged(styleProp:String):void
Detects changes to style properties.
UITextField
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexTextField
truncateToFit(truncationIndicator:String = null):Boolean
Truncate text to make it fit horizontally in the area defined for the control, and append an ellipsis, three periods (...), to the text.
UITextField
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UITextField
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched after a control's value is modified. | TextField
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | link | Dispatched when a user clicks a hyperlink in an HTML-enabled text field, where the URL begins with "event:". | TextField
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | scroll | Dispatched by a TextField object after the user scrolls. | TextField
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | textInput | Flash Player dispatches the textInput event when a user enters one or more characters of text. | TextField
Styles
Style Description Defined by
color
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component, including the component label. The default value is 0x0B333C. 		UITextField
disabledColor
Type: uint Format: Color CSS Inheritance: yes
Color of text in the component if it is disabled. The default value is 0xAAB3B3. 		UITextField
fontAntiAliasType
Type: String CSS Inheritance: yes
Sets the antiAliasType property of internal TextFields. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set to "normal" to disable the FlashType renderer.

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "advanced". 		UITextField
fontFamily
Type: String CSS Inheritance: yes
Name of the font to use. Unlike in a full CSS implementation, comma-separated lists are not supported. You can use any font family name. If you specify a generic font name, it is converted to an appropriate device font. The default value is "Verdana". 		UITextField
fontGridFitType
Type: String CSS Inheritance: yes
Sets the gridFitType property of internal TextFields that represent text in Flex controls. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is "pixel". 		UITextField
fontSharpness
Type: Number CSS Inheritance: yes
Sets the sharpness property of internal TextFields that represent text in Flex controls. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect for system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		UITextField
fontSize
Type: Number Format: Length CSS Inheritance: yes
Height of the text, in pixels. The default value is 10. 		UITextField
fontStyle
Type: String CSS Inheritance: yes
Determines whether the text is italic font. Recognized values are "normal" and "italic". The default value is "normal". 		UITextField
fontThickness
Type: Number CSS Inheritance: yes
Sets the thickness property of internal TextFields that represent text in Flex controls. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This style has no effect on system fonts.

This style applies to all the text in a TextField subcontrol; you can't apply it to some characters and not others.

The default value is 0. 		UITextField
fontWeight
Type: String CSS Inheritance: yes
Determines whether the text is boldface. Recognized values are "normal" and "bold". The default value is "normal". 		UITextField
leading
Type: Number Format: Length CSS Inheritance: no
Additional vertical space between lines of text.

The default value is 2.
The default value for the ComboBox control is 0.

UITextField
paddingLeft
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's left border and the left edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.
The default value for the Tree control is 2.

UITextField
paddingRight
Type: Number Format: Length CSS Inheritance: no
Number of pixels between the container's right border and the right edge of its content area.

The default value is 0.
The default value for a Button and CheckBox control is 3.
The default value for the ComboBox control is 5.
The default value for the Form container is 16.

UITextField
textAlign
Type: String CSS Inheritance: yes
Alignment of text within a container. Possible values are "left", "right", or "center".

The default value for most controls is left. For the Button, LinkButton, and AccordionHeader components, the default value is "center". For these components, this property is only recognized when the labelPlacement property is set to "left" or "right". If labelPlacement is set to "top" or "bottom", the text and any icon are centered.

UITextField
textDecoration
Type: String CSS Inheritance: no
Determines whether the text is underlined. Possible values are "none" and "underline". The default value is "none". 		UITextField
textIndent
Type: Number Format: Length CSS Inheritance: yes
Offset of first line of text from the left side of the container, in pixels. The default value is 0. 		UITextField
Property detail
baselinePosition property
baselinePosition:Number [read-only]

Determines the baseline y-coordinate of the first line of text of the component. Any subclass of UITextField should override this property.

Implementation
    public function get baselinePosition():Number
className property
className:String [read-only]

The name of this instance's class, such as "DataGridItemRenderer".

This string does not include the package name. If you need the package name as well, call the getQualifiedClassName() method in the flash.utils package. It will return a string such as "mx.controls.dataGridClasses::DataGridItemRenderer".

Implementation
    public function get className():String
document property
document:Object [read-write]

A reference to the document object associated with this UITextField object. A document object is an Object at the top of the hierarchy of a Flex application, MXML component, or AS component.

Implementation
    public function get document():Object
    public function set document(value:Object):void
enabled property
enabled:Boolean [read-write]

A Boolean value that indicates whether the component is enabled. This property only affects the color of the text and not whether the UITextField is editable. To control editability, use the flash.text.TextField.type property.

The default value is true.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void

See also

flash.text.TextField
explicitHeight property
explicitHeight:Number [read-write]

Number that specifies the explicit height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true explicitHeight with respect to its parent is affected by the scaleY property.

Setting the height property also sets this property to the specified height value.

Implementation
    public function get explicitHeight():Number
    public function set explicitHeight(value:Number):void
explicitMaxHeight property
explicitMaxHeight:Number [read-only]

Number that specifies the maximum height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxHeight with respect to its parent is affected by the scaleY property.

The default value is NaN.

Implementation
    public function get explicitMaxHeight():Number
explicitMaxWidth property
explicitMaxWidth:Number [read-only]

Number that specifies the maximum width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxWidth with respect to its parent is affected by the scaleX property.

The default value is NaN.

Implementation
    public function get explicitMaxWidth():Number
explicitMinHeight property
explicitMinHeight:Number [read-only]

Number that specifies the minimum height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minHeight with respect to its parent is affected by the scaleY property.

Implementation
    public function get explicitMinHeight():Number
explicitMinWidth property
explicitMinWidth:Number [read-only]

Number that specifies the minimum width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minWidth with respect to its parent is affected by the scaleX property.

Implementation
    public function get explicitMinWidth():Number
explicitWidth property
explicitWidth:Number [read-write]

Number that specifies the explicit width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true explicitWidth with respect to its parent is affected by the scaleX property.

Setting the width property also sets this property to the specified width value.

Implementation
    public function get explicitWidth():Number
    public function set explicitWidth(value:Number):void
focusPane property
focusPane:Sprite [read-write]

A single Sprite object that is shared among components and used as an overlay for drawing focus. Components share this object if their parent is a focused component, not if the component implements the IFocusManagerComponent interface.

Implementation
    public function get focusPane():Sprite
    public function set focusPane(value:Sprite):void
ignorePadding property
ignorePadding:Boolean [read-write]

If true, the paddingLeft and paddingRight styles will not add space around the text of the component.

The default value is true.

Implementation
    public function get ignorePadding():Boolean
    public function set ignorePadding(value:Boolean):void
imeMode property
imeMode:String [read-write]

Specifies the IME (input method editor) mode. The IME enables users to enter text in Chinese, Japanese, and Korean. Flex sets the specified IME mode when the control gets the focus, and sets it back to the previous value when the control loses the focus.

The flash.system.IMEConversionMode class defines constants for the valid values for this property. You can also specify null to specify no IME.

The default value is null.

Implementation
    public function get imeMode():String
    public function set imeMode(value:String):void

See also

flash.system.IMEConversionMode
includeInLayout property
includeInLayout:Boolean [read-write]

Specifies whether this component is included in the layout of the parent container. If true, the object is included in its parent container's layout. If false, the object is positioned by its parent container as per its layout rules, but it is ignored for the purpose of computing the position of the next child.

Implementation
    public function get includeInLayout():Boolean
    public function set includeInLayout(value:Boolean):void
inheritingStyles property
inheritingStyles:Object [read-write]

The beginning of this UITextField's chain of inheriting styles. The getStyle() method accesses inheritingStyles[styleName] to search the entire prototype-linked chain. This object is set up by the initProtoChain() method. You typically never need to access this property directly.

Implementation
    public function get inheritingStyles():Object
    public function set inheritingStyles(value:Object):void
initialized property
initialized:Boolean [read-write]

A flag that determines if an object has been through all three phases of layout validation (provided that any were required)

Implementation
    public function get initialized():Boolean
    public function set initialized(value:Boolean):void
maxHeight property
maxHeight:Number [read-only]

Number that specifies the maximum height of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxHeight with respect to its parent is affected by the scaleY property. Some components have no theoretical limit to their height. In those cases their maxHeight will be set to UIComponent.DEFAULT_MAX_HEIGHT.

Implementation
    public function get maxHeight():Number
maxWidth property
maxWidth:Number [read-only]

Number that specifies the maximum width of the component, in pixels, in the component's coordinates.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true maxWidth with respect to its parent is affected by the scaleX property. Some components have no theoretical limit to their width. In those cases their maxWidth will be set to UIComponent.DEFAULT_MAX_WIDTH.

Implementation
    public function get maxWidth():Number
measuredHeight property
measuredHeight:Number [read-only]

The default height of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredHeight():Number
measuredMinHeight property
measuredMinHeight:Number [read-write]

The default minimum height of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredMinHeight():Number
    public function set measuredMinHeight(value:Number):void
measuredMinWidth property
measuredMinWidth:Number [read-write]

The default minimum width of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredMinWidth():Number
    public function set measuredMinWidth(value:Number):void
measuredWidth property
measuredWidth:Number [read-only]

The default width of the component, in pixels. This value is set by the measure() method.

Implementation
    public function get measuredWidth():Number
minHeight property
minHeight:Number [read-only]

Number that specifies the minimum height of the component, in pixels, in the component's coordinates. The default value depends on the component implementation.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minHeight with respect to its parent is affected by the scaleY property.

Implementation
    public function get minHeight():Number
minWidth property
minWidth:Number [read-only]

Number that specifies the minimum width of the component, in pixels, in the component's coordinates. The default value depends on the component implementation.

This value is used by the container in calculating the size and position of the component. It is not used by the component itself in determining its default size. Thus this property may not have any effect if parented by Container, or containers that don't factor in this property. Because the value is in component coordinates, the true minWidth with respect to its parent is affected by the scaleX property.

Implementation
    public function get minWidth():Number
nestLevel property
nestLevel:int [read-write]

Depth of this object in the containment hierarchy. This number is used by the measurement and layout code. The value is 0 if this component is not on the DisplayList.

Implementation
    public function get nestLevel():int
    public function set nestLevel(value:int):void
nonInheritingStyles property
nonInheritingStyles:Object [read-write]

The beginning of this UITextField's chain of non-inheriting styles. The getStyle() method accesses nonInheritingStyles[styleName] method to search the entire prototype-linked chain. This object is set up by the initProtoChain() method. You typically never need to access this property directly.

Implementation
    public function get nonInheritingStyles():Object
    public function set nonInheritingStyles(value:Object):void
owner property
owner:DisplayObjectContainer [read-write]

By default, set to the parent container of this object. However, if this object is a child component that is popped up by its parent, such as the dropdown list of a ComboBox control, the owner is the component that popped up this object.

This property is not managed by Flex, but by each component. Therefore, if you use the PopUpManger.createPopUp() or PopUpManger.addPopUp() method to pop up a child component, you should set the owner property of the child component to the component that popped it up.

The default value is the value of the parent property.

Implementation
    public function get owner():DisplayObjectContainer
    public function set owner(value:DisplayObjectContainer):void
parent property
parent:DisplayObjectContainer [read-only]

The parent container or component for this component.

Implementation
    public function get parent():DisplayObjectContainer
percentHeight property
percentHeight:Number [read-write]

Number that specifies the height of a component as a percentage of its parent's size. Allowed values are 0-100. The default value is NaN. Setting the height or explicitHeight properties resets this property to NaN.

This property returns a numeric value only if the property was previously set; it does not reflect the exact size of the component in percent.

Implementation
    public function get percentHeight():Number
    public function set percentHeight(value:Number):void
percentWidth property
percentWidth:Number [read-write]

Number that specifies the width of a component as a percentage of its parent's size. Allowed values are 0-100. The default value is NaN. Setting the width or explicitWidth properties resets this property to NaN.

This property returns a numeric value only if the property was previously set; it does not reflect the exact size of the component in percent.

Implementation
    public function get percentWidth():Number
    public function set percentWidth(value:Number):void
processedDescriptors property
processedDescriptors:Boolean [read-write]

Set to true after the createChildren() method creates any internal component children.

Implementation
    public function get processedDescriptors():Boolean
    public function set processedDescriptors(value:Boolean):void
styleName property
styleName:Object [read-write]

The class style used by this component. This can be a String, CSSStyleDeclaration or an IStyleClient.

If this is a String, it is the name of a class declaration in an mx:Style tag or CSS file. You do not include the period in the styleName. For example, if you have a class style named ".bigText", set the styleName property to "bigText" (no period).

If this is an IStyleClient (typically a UIComponent), all styles in the styleName ojbect are used by this component.

Implementation
    public function get styleName():Object
    public function set styleName(value:Object):void
systemManager property
systemManager:ISystemManager [read-write]

Returns the SystemManager object used by this component.

Implementation
    public function get systemManager():ISystemManager
    public function set systemManager(value:ISystemManager):void
toolTip property
toolTip:String [read-write]

Text to display in the ToolTip.

Implementation
    public function get toolTip():String
    public function set toolTip(value:String):void
tweeningProperties property
tweeningProperties:Array [read-write]

Array of properties that are currently being tweened on this object.

Used to alert the EffectManager that certain properties of this object are being tweened, so that the EffectManger doesn't attempt to animate the same properties.

Implementation
    public function get tweeningProperties():Array
    public function set tweeningProperties(value:Array):void
updateCompletePendingFlag property
updateCompletePendingFlag:Boolean [read-write]

A flag that determines if an object has been through all three phases of layout validation (provided that any were required)

Implementation
    public function get updateCompletePendingFlag():Boolean
    public function set updateCompletePendingFlag(value:Boolean):void
Constructor detail
UITextField () constructor
public function UITextField()

Constructor.

Method detail
getExplicitOrMeasuredHeight () method
public function getExplicitOrMeasuredHeight():Number

A convenience method for determining whether to use the explicit or measured height

Returns
Number — A Number which is explicitHeight if defined or measuredHeight if not.
getExplicitOrMeasuredWidth () method
public function getExplicitOrMeasuredWidth():Number

A convenience method for determining whether to use the explicit or measured width

Returns
Number — A Number which is explicitWidth if defined or measuredWidth if not.
getStyle () method
public function getStyle(styleProp:String):*

Gets a style property that has been set anywhere in this component's style lookup chain.

This same method is used to get any kind of style property, so the value returned may be a Boolean, String, Number, int, uint (for an RGB color), Class (for a skin), or any kind of object. Therefore the return type is simply specified as

If you are getting a particular style property, you will know its type and will often want to store the result in a variable of that type. No casting from to that type is necessary:

var backgroundColor:uint = getStyle("backgroundColor");

If the style property has not been set anywhere in the style lookup chain, the value returned by getStyle() will be undefined. Note that undefined is a special value that is not the same as false, "", NaN, 0, or null. No valid style value is ever undefined. You can use the static method StyleManager.isValidStyleValue() to test whether the value was set.

Parameters
styleProp:String — Name of the style property.

Returns
* — Style value.
getTextStyles () method
public function getTextStyles():TextFormat

Returns the TextFormat object that represents character formatting information for this UITextField object.

Returns
TextFormat — A TextFormat object.

See also

flash.text.TextFormat
getUITextFormat () method
public function getUITextFormat():UITextFormat

Returns a UITextFormat object that contains formatting information for this component. This method is similar to the getTextFormat() method of the flash.text.TextField class, but it returns a UITextFormat object instead of a TextFormat object.

The UITextFormat class extends the TextFormat class to add the text measurement methods measureText() and measureHTMLText().

Returns
UITextFormat — An object that contains formatting information for this component.

See also

mx.core.UITextFormat
flash.text.TextField
initialize () method
public function initialize():void

Initializes this component.

This method is required by the IUIComponent interface, but it actually does nothing for a UITextField.

invalidateDisplayList () method
public function invalidateDisplayList():void

Marks a component so that its updateDisplayList() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the width and height, it would be wasteful to update the component immediately after you change the width and then update again with the new height. It is more efficient to change both properties and then render the component with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

invalidateProperties () method
public function invalidateProperties():void

Marks a component so that its commitProperties() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the text color and size, it would be wasteful to update the color immediately after you change it and then update the size when it gets set. It is more efficient to change both properties and then render the text with its new size and color once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

invalidateSize () method
public function invalidateSize():void

Marks a component so that its measure() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the text and font size, it would be wasteful to update the text immediately after you change it and then update the size when it gets set. It is more efficient to change both properties and then render the text with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

move () method
public function move(x:Number, y:Number):void

Moves the component to a specified position within its parent. Calling this method is exactly the same as setting the component's x and y properties.

If you are overriding the updateDisplayList() method in a custom component, you should call the move() method rather than setting the x and y properties. The difference is that the move() method changes the location of the component and then dispatches a move event when you call the method, while setting the x and y properties changes the location of the component and dispatches the event on the next screen refresh.

Parameters
x:Number — Left position of the component within its parent.
y:Number — Top position of the component within its parent.
owns () method
public function owns(child:DisplayObject):Boolean

Returns true if the child is parented or owned by this object.

Parameters
child:DisplayObject — The child DisplayObject.

Returns
Boolean — true if the child is parented or owned by this UITextField object.

See also

owner
parentChanged () method
public function parentChanged(p:DisplayObjectContainer):void

This function is called when a UITextField object is assigned a parent. You typically never need to call this method.

Parameters
p:DisplayObjectContainer — The parent of this UITextField object.
setActualSize () method
public function setActualSize(w:Number, h:Number):void

Sizes the object. Unlike directly setting the width and height properties, calling the setActualSize() method does not set the explictWidth and explicitHeight properties, so a future layout calculation may result in the object returning to its previous size. This method is used primarily by component developers implementing the updateDisplayList() method, by Effects, and by the LayoutManager.

Parameters
w:Number — Width of the object.
h:Number — Height of the object.
setColor () method
public function setColor(color:uint):void

Sets the font color of the text.

Parameters
color:uint — The new font color.
setFocus () method
public function setFocus():void

Sets the focus to this component. The component may in turn pass focus to a subcomponent.

Note: Only the TextInput and TextArea controls show a highlight when this method sets the focus. All controls show a highlight when the user tabs to the control.

setStyle () method
public function setStyle(styleProp:String, value:*):void

Does nothing. A UITextField cannot have inline styles.

Parameters
styleProp:String — Name of the style property.
value:* — New value for the style.
setVisible () method
public function setVisible(visible:Boolean, noEvent:Boolean = false):void

Sets the visible property of this UITextField object.

Parameters
visible:Boolean — true to make this UITextField visible, and false to make it invisible.
noEvent:Boolean (default = false) — true to suppress generating an event when you change visibility.
styleChanged () method
public function styleChanged(styleProp:String):void

Detects changes to style properties. When any style property is set, Flex calls the styleChanged() method, passing to it the name of the style being set.

This is an advanced method that you might override when creating a subclass of UIComponent. When you create a custom component, you can override the styleChanged() method to check the style name passed to it, and handle the change accordingly. This lets you override the default behavior of an existing style, or add your own custom style properties.

If you handle the style property, your override of the styleChanged() method should call the invalidateDisplayList() method to cause Flex to execute the component's updateDisplayList() method at the next screen update.

Parameters
styleProp:String — The name of the style property, or null if all styles for this component have changed.
truncateToFit () method
public function truncateToFit(truncationIndicator:String = null):Boolean

Truncate text to make it fit horizontally in the area defined for the control, and append an ellipsis, three periods (...), to the text.

Parameters
truncationIndicator:String (default = null) — The text to be appended after truncation. If you pass null, a localizable string such as "..." will be used.

Returns
Boolean — true if the text needed truncation.
validateNow () method
public function validateNow():void

Validate and update the properties and layout of this object and redraw it, if necessary. Processing properties that require substantial computation are normally not processed until the script finishes executing. For example setting the width property is delayed, because it may require recalculating the widths of the objects children or its parent. Delaying the processing prevents it from being repeated multiple times if the script sets the width property more than once. This method lets you manually override this behavior.


mx.core.UITextFormat (Flex™ 2 Language Reference)

Class UITextFormat | Properties | Methods
Package | mx.core
Class | public class UITextFormat
Inheritance | UITextFormat Inheritance TextFormat Inheritance Object

The UITextFormat class represents character formatting information for the UITextField class. The UITextField class defines the component used by many Flex composite components to display text.

The UITextFormat class extends the Flash Player's TextFormat class to add the text measurement methods measureText() and measureHTMLText() and to add properties for controlling the FlashType font renderer.

See also

mx.core.UITextField

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | align : String Indicates the alignment of the paragraph. | TextFormat
 | antiAliasType : String Defines the anti-aliasing setting for the UITextField class. | UITextFormat
Inherited | blockIndent : Object Indicates the block indentation in pixels. | TextFormat
Inherited | bold : Object Specifies whether the text is boldface. | TextFormat
Inherited | bullet : Object Indicates that the text is part of a bulleted list. | TextFormat
Inherited | color : Object Indicates the color of the text. | TextFormat
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | font : String The name of the font for text in this text format, as a string. | TextFormat
 | gridFitType : String Defines the grid-fitting setting for the UITextField class. | UITextFormat
Inherited | indent : Object Indicates the indentation from the left margin to the first character in the paragraph. | TextFormat
Inherited | italic : Object Indicates whether text in this text format is italicized. | TextFormat
Inherited | kerning : Object A Boolean value that indicates whether kerning is enabled (true) or disabled (false). | TextFormat
Inherited | leading : Object An integer representing the amount of vertical space (called leading) between lines. | TextFormat
Inherited | leftMargin : Object The left margin of the paragraph, in pixels. | TextFormat
Inherited | letterSpacing : Object An integer representing the amount of space that is uniformly distributed between all characters. | TextFormat
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rightMargin : Object The right margin of the paragraph, in pixels. | TextFormat
 | sharpness : Number Defines the sharpness setting for the UITextField class. | UITextFormat
Inherited | size : Object The point size of text in this text format. | TextFormat
Inherited | tabStops : Array Specifies custom tab stops as an array of non-negative integers. | TextFormat
Inherited | target : String Indicates the target window where the hyperlink is displayed. | TextFormat
 | thickness : Number Defines the thickness setting for the UITextField class. | UITextFormat
Inherited | underline : Object Indicates whether the text that uses this text format is underlined (true) or not (false). | TextFormat
Inherited | url : String Indicates the target URL for the text in this text format. | TextFormat
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | UITextFormat(systemManager:ISystemManager, font:String = null, size:Object = null, color:Object = null, bold:Object = null, italic:Object = null, underline:Object = null, url:String = null, target:String = null, align:String = null, leftMargin:Object = null, rightMargin:Object = null, indent:Object = null, leading:Object = null) Constructor. | UITextFormat
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | measureHTMLText(htmlText:String):TextLineMetrics Returns measurement information for the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField, and using this UITextFormat object to define the text format. | UITextFormat
 | measureText(text:String):TextLineMetrics Returns measurement information for the specified text, assuming that it is displayed in a single-line UITextField component, and using this UITextFormat object to define the text format. | UITextFormat
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
antiAliasType property
public var antiAliasType:String

Defines the anti-aliasing setting for the UITextField class. The possible values are "normal" (flash.text.AntiAliasType.NORMAL) and "advanced" (flash.text.AntiAliasType.ADVANCED).

The default value is "advanced", which enables the FlashType renderer if you are using an embedded FlashType font. Set this property to "normal" to disable the FlashType renderer.

This property has no effect for system fonts.

This property applies to all the text in a UITextField object; you cannot apply it to some characters and not others.

The default value is "advanced".

See also

flash.text.AntiAliasType
gridFitType property
public var gridFitType:String

Defines the grid-fitting setting for the UITextField class. The possible values are "none" (flash.text.GridFitType.NONE), "pixel" (flash.text.GridFitType.PIXEL), and "subpixel" (flash.text.GridFitType.SUBPIXEL).

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This property has no effect for system fonts.

This property applies to all the text in a UITextField object; you cannot apply it to some characters and not others.

The default value is "pixel".

See also

flash.text.GridFitType
sharpness property
public var sharpness:Number

Defines the sharpness setting for the UITextField class. This property specifies the sharpness of the glyph edges. The possible values are Numbers from -400 through 400.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This property has no effect for system fonts.

This property applies to all the text in a UITextField object; you cannot apply it to some characters and not others.

The default value is 0.

See also

flash.text.TextField
thickness property
public var thickness:Number

Defines the thickness setting for the UITextField class. This property specifies the thickness of the glyph edges. The possible values are Numbers from -200 to 200.

This property only applies when you are using an embedded FlashType font and the fontAntiAliasType property is set to "advanced".

This property has no effect for system fonts.

This property applies to all the text in a UITextField object; you cannot apply it to some characters and not others.

The default value is 0.

See also

flash.text.TextField
Constructor detail
UITextFormat () constructor
public function UITextFormat(systemManager:ISystemManager, font:String = null, size:Object = null, color:Object = null, bold:Object = null, italic:Object = null, underline:Object = null, url:String = null, target:String = null, align:String = null, leftMargin:Object = null, rightMargin:Object = null, indent:Object = null, leading:Object = null)

Constructor.

Parameters
systemManager:ISystemManager — A SystemManager object. The SystemManager keeps track of which fonts are embedded. Typically this is the SystemManager obtained from the systemManager property of UIComponent.
font:String (default = null) — A String specifying the name of a font, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
size:Object (default = null) — A Number specifying a font size in pixels, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
color:Object (default = null) — An unsigned integer specifying the RGB color of the text, such as 0xFF0000 for red, or null to indicate that is UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
bold:Object (default = null) — A Boolean flag specifying whether the text is bold, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
italic:Object (default = null) — A Boolean flag specifying whether the text is italic, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
underline:Object (default = null) — A Boolean flag specifying whether the text is underlined, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
url:String (default = null) — A String specifying the URL to which the text is hyperlinked, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
target:String (default = null) — A String specifying the target window where the hyperlinked URL is displayed. If the target window is null or an empty string, the hyperlinked page is displayed in the same browser window. If the urlString parameter is null or an empty string, this property has no effect. This parameter is optional, with a default value of null.
align:String (default = null) — A String specifying the alignment of the paragraph, as a flash.text.TextFormatAlign value, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
leftMargin:Object (default = null) — A Number specifying the left margin of the paragraph, in pixels, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
rightMargin:Object (default = null) — A Number specifying the right margin of the paragraph, in pixels, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
indent:Object (default = null) — A Number specifying the indentation from the left margin to the first character in the paragraph, in pixels, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.
leading:Object (default = null) — A Number specifying the amount of additional vertical space between lines, or null to indicate that this UITextFormat doesn't specify this property. This parameter is optional, with a default value of null.

See also

flash.text.TextFormatAlign
Method detail
measureHTMLText () method
public function measureHTMLText(htmlText:String):TextLineMetrics

Returns measurement information for the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField, and using this UITextFormat object to define the text format.

Parameters
htmlText:String — A String specifying the HTML text to measure.

Returns
TextLineMetrics — A TextLineMetrics object containing the text measurements.

See also

flash.text.TextLineMetrics
measureText () method
public function measureText(text:String):TextLineMetrics

Returns measurement information for the specified text, assuming that it is displayed in a single-line UITextField component, and using this UITextFormat object to define the text format.

Parameters
text:String — A String specifying the text to measure.

Returns
TextLineMetrics — A TextLineMetrics object containing the text measurements.

See also

flash.text.TextLineMetrics


mx.data Summary (Flex™ 2 Language Reference)

Package mx.data | Interfaces | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.data package contains for working with the Flex Data Management Service.

Interfaces
Interface | Description
IAccessPrivileges | Objects that must restrict access must implement the IAccessPrivileges interface.
IChangeObject | The IChangeObject interface provides the methods and properties needed when decting local conflicts.
IManaged | The IPropertyChangeNotifier interface provides the contract for a managed object.
Classes
Class | Description
Conflict | The Conflict class is used to represent error that has occurred due to an update operation.
ConflictDetector | A DataService instance uses a ConflictDetector instance to determine when a conflict occurs for an operation pushed from a remote destination.
Conflicts | The Conflicts class represents a list of conflicts.
DataService | The DataService class provides the top-level functionality for Data Management Services in Flex 2.
DataStore | A DataStore batches transactions for one or more DataService instances.
ItemReference | An ItemReference instance is returned from the DataService.getItem() and DataService.createItem() methods to provide you with a way to manage your reference to the remote object.
PageInformation | The PageInformation object provides detailed data about what pages of a collection have been loaded, how many there are, and what the current page size is.
UpdateCollectionRange | The UpdateCollectionRange class provides specific information about a range of add and remove operations made to a collection.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.data.Conflict (Flex™ 2 Language Reference)

Class Conflict | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public class Conflict
Inheritance | Conflict Inheritance Object

The Conflict class is used to represent error that has occurred due to an update operation. Conflicts are generated for many reasons. For example, another client has updated the same property of an item. Conflicts are determined by both the remote destination and the local DataService. A conflict detected by the DataService is considered a local conflict. A conflict detected by the remote destination is a remote conflict. Custom assemblers can generate a remote conflict for any operation when processing an update. Local conflicts are determined by the ConflictDetector object. To customize local conflict detection the ConflictDetector can be extended and assigned to the DataService.conflictDetector property. All conflicts must be resolved before changes can be committed.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | cause : DataMessage [read-only] Returns the DataMessage that caused the conflict. | Conflict
 | clientObject : Object [read-only] Returns the state of the client object (whose property was changed) at the time of the conflict. | Conflict
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | destination : String [read-only] Returns the destination for the data service of the item involved in this conflict. | Conflict
 | originalObject : Object [read-only] Returns the state of the original client object before its properties were changed, as known at the time of the conflict. | Conflict
 | propertyNames : Array [read-only] Returns an Array of the names of the properties that were in conflict between the client change and the remote item state. | Conflict
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | resolved : Boolean [read-only] Indicates whether this Conflict has been resolved (acceptClient() or acceptServer() has been called). | Conflict
 | serverObject : Object [read-only] Returns the value of server object whose property was to be changed. | Conflict
 | serverObjectReferencedIds : Object [read-only] If the serverObject has any properties with lazy="true", returns an Object that stores the referencedId Arrays for each lazily loaded property, using the property name as the lookup key value. | Conflict
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Conflict(dataService:ConcreteDataService, errMsg:DataErrorMessage, resolver:ConflictResolver) Constructs an instance of a Conflict based on the specified error message | Conflict
 | acceptClient():void Requeues the current local changes and updates the property values such that a subsequent call to DataService.commit() should succeed, causing these changes to override the previous ones. | Conflict
 | acceptServer():void Removes the conflicting local change and applies the property values found on Conflict.serverObject to the local item. | Conflict
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String | Conflict
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
cause property
cause:DataMessage [read-only]

Returns the DataMessage that caused the conflict.

Implementation
    public function get cause():DataMessage
clientObject property
clientObject:Object [read-only]

Returns the state of the client object (whose property was changed) at the time of the conflict.

Implementation
    public function get clientObject():Object
destination property
destination:String [read-only]

Returns the destination for the data service of the item involved in this conflict.

Implementation
    public function get destination():String
originalObject property
originalObject:Object [read-only]

Returns the state of the original client object before its properties were changed, as known at the time of the conflict.

Implementation
    public function get originalObject():Object
propertyNames property
propertyNames:Array [read-only]

Returns an Array of the names of the properties that were in conflict between the client change and the remote item state. All property names are String values and exist in the public namespace.

Implementation
    public function get propertyNames():Array
resolved property
resolved:Boolean [read-only]

Indicates whether this Conflict has been resolved (acceptClient() or acceptServer() has been called).

Implementation
    public function get resolved():Boolean

See also

mx.data.Conflict.acceptServer()
mx.data.Conflict.acceptClient()
serverObject property
serverObject:Object [read-only]

Returns the value of server object whose property was to be changed.

Implementation
    public function get serverObject():Object
serverObjectReferencedIds property
serverObjectReferencedIds:Object [read-only]

If the serverObject has any properties with lazy="true", returns an Object that stores the referencedId Arrays for each lazily loaded property, using the property name as the lookup key value.

Implementation
    public function get serverObjectReferencedIds():Object
Constructor detail
Conflict () constructor
public function Conflict(dataService:ConcreteDataService, errMsg:DataErrorMessage, resolver:ConflictResolver)

Constructs an instance of a Conflict based on the specified error message

Parameters
dataService:ConcreteDataService
errMsg:DataErrorMessage
resolver:ConflictResolver
Method detail
acceptClient () method
public function acceptClient():void

Requeues the current local changes and updates the property values such that a subsequent call to DataService.commit() should succeed, causing these changes to override the previous ones.

Example
         private function conflictHandler(event:DataConflictEvent):void
         {
             if (acceptClientCheck.selected)
             {
                  event.conflict.acceptClient();
             }
             else
             {
                  event.conflict.acceptServer();
             }
         }

acceptServer () method
public function acceptServer():void

Removes the conflicting local change and applies the property values found on Conflict.serverObject to the local item.

Example
         private function conflictHandler(event:DataConflictEvent):void
         {
             if (acceptClientCheck.selected)
             {
                  event.conflict.acceptClient();
             }
             else
             {
                  event.conflict.acceptServer();
             }
         }

toString () method
public function toString():String

Returns
String


mx.data.ConflictDetector (Flex™ 2 Language Reference)

Class ConflictDetector | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public class ConflictDetector
Inheritance | ConflictDetector Inheritance Object

A DataService instance uses a ConflictDetector instance to determine when a conflict occurs for an operation pushed from a remote destination.

It has three methods that are used to determine if a conflict exists when processing a pushed operation, checkCreate(), checkDelete(), and checkUpdate(). Each of these methods is called for the corresponding operation with two parameters, the local and the remote change. Returning true from these methods indicates to the DataService that no conflict has occurred.

If you want to customize how conflicts are detected on the client, you can extend this class and augment the behavior as needed to match remote assembler logic.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ConflictDetector(dataService:ConcreteDataService) Constructs an instance of the default conflict detection mechanism. | ConflictDetector
 | checkCreate(remoteChange:IChangeObject, localChange:IChangeObject):void Called by the DataService when a create operation is pushed/processed from the remote destination. | ConflictDetector
 | checkDelete(remoteChange:IChangeObject, localChange:IChangeObject):void Called by the DataService when a delete operation is pushed/processed from the remote destination. | ConflictDetector
 | checkUpdate(remoteChange:IChangeObject, localChange:IChangeObject):void Called by the DataService when an update operation is pushed/processed from the remote destination. | ConflictDetector
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
ConflictDetector () constructor
public function ConflictDetector(dataService:ConcreteDataService)

Constructs an instance of the default conflict detection mechanism.

Parameters
dataService:ConcreteDataService — ConcreteDataService reference to the data service that will use this conflict detector.
Method detail
checkCreate () method
public function checkCreate(remoteChange:IChangeObject, localChange:IChangeObject):void

Called by the DataService when a create operation is pushed/processed from the remote destination.

Parameters
remoteChange:IChangeObject — IChangeObject representing the remote change being processed.
localChange:IChangeObject — IChangeObject representing any local changes made to the same object referenced by the remoteChange parameter. This value can be null if no local changes have been made to the item represented by the remoteChange parameter.
checkDelete () method
public function checkDelete(remoteChange:IChangeObject, localChange:IChangeObject):void

Called by the DataService when a delete operation is pushed/processed from the remote destination.

Parameters
remoteChange:IChangeObject — IChangeObject representing the remote change being processed.
localChange:IChangeObject — IChangeObject representing any local changes made to the same object referenced by the remoteChange parameter. This value can be null if no local changes have been made to the item represented by the remoteChange parameter.
checkUpdate () method
public function checkUpdate(remoteChange:IChangeObject, localChange:IChangeObject):void

Called by the DataService when an update operation is pushed/processed from the remote destination.

Parameters
remoteChange:IChangeObject — IChangeObject representing the remote change being processed.
localChange:IChangeObject — IChangeObject representing any local changes made to the same object referenced by the remoteChange parameter. This value can be null if no local changes have been made to the item represented by the remoteChange parameter.


mx.data.Conflicts (Flex™ 2 Language Reference)

Class Conflicts | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public class Conflicts

The Conflicts class represents a list of conflicts. When conflicts are detected between changes made by a client and those made on the server, a Conflict object is created for each item which contains both the client and server versions of the data involved in that item at any given time. You cannot commit any changes until all conflicts are resolved. At that point, the DataService.commit() method will call remove all of these conflicts. If you attempt to resolve a Conflict which was already resolved, an error is thrown. An instance of this class can be accessed from the DataService.conflicts property. Because this class implements IList it can be used with an ArrayCollection.list property. Allowing it to participate as a data source for UI controls and data binding.

Public Properties
Property |  | Defined by
 | resolved : Boolean [write-only] Indicates if there are any unresolved conflicts in the list. | Conflicts
Public Methods
Method |  | Defined by
 | Conflicts() | Conflicts
 | acceptAllClient():void This is a convience method that iterates all of the conflicts within this list and invokes the Conflict.acceptClient() method. | Conflicts
 | acceptAllServer():void This is a convience method that iterates all of the conflicts within this list and invokes the Conflict.acceptClient() method. | Conflicts
Property detail
resolved property
resolved:Boolean [write-only]

Indicates if there are any unresolved conflicts in the list. When this returns true all conflicts have been resolved and DataService.commit() can be called without an error.

This property can be used as the source for data binding.

Implementation
    public function set resolved(value:Boolean):void
Constructor detail
Conflicts () constructor
public function Conflicts()
Method detail
acceptAllClient () method
public function acceptAllClient():void

This is a convience method that iterates all of the conflicts within this list and invokes the Conflict.acceptClient() method. Once completed this method will clear all of the conflicts in the list. Calling this method will requeue each local change and update all property values such that a subsequent call to DataService.commit() should succeed, allowing these changes to override the current ones.

See also

mx.data.Conflict.acceptClient()
acceptAllServer () method
public function acceptAllServer():void

This is a convience method that iterates all of the conflicts within this list and invokes the Conflict.acceptClient() method. Once completed this method will clear all of the conflicts in the list. Calling this method removes the conflicting local change and applies the property values found on each Conflict.serverObject within the list to each related local item.

See also

mx.data.Conflict.acceptServer()


mx.data.DataService (Flex™ 2 Language Reference)

Class DataService | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public class DataService
Inheritance | DataService Inheritance Object
Implements | IEventDispatcher
Subclasses | DataService

The DataService class provides the top-level functionality for Data Management Services in Flex 2. The DataService provides synchronization, replication, and occasionally connected services.

A DataService is constructed specifying the desired destination. These destinations are configured from the services-config.xml file.

There are two different sets of methods that retreive data from the specified remote destination. The first are for collection managed objects. The second are for Single Managed Objects or SMO.

For the collection managed objects the DataService.fill() method is used. This method populates an ArrayCollection with objects that this services will manage.

To get Single Managed Objects the DataService.getItem() and DataService.createItem() methods are used.

When a previously filled ArrayCollection is no longer needed, or the items within that collection should no longer receive or create updates, the DataService.releaseCollection() method is called.

When an item previously retreived using DataService.getItem() or DataService.createItem() is no longer needed or should not receive or create updates, the DataService.releaseItem() method is be called. The DataService.createItem() and DataService.getItem() methods return an ItemReference. This object can be used to release a specific instance of a single managed object. Unlike the DataService.releaseItem() method, calling ItemReference.releaseItem() will release a specific instance of an SMO. DataService.releaseItem() will release the first SMO that it finds with a matching identity to that specified. This is normally okay as long as the number of calls to DataService.getItem() and DataService.createItem() matches the number of calls to DataService.releaseItem().

A connection to the remote destination is created automatically the first time any methods that require a connection are called. For example, calling the DataService.fill() method or DataService.commit() operation when there are uncommited updates will attempt to establish a connection to the remote destination. To force a DataService to become disconnected use the DataService.disconnect() method. This method can be used to clean up remote destination resources when no longer needed. Because other services may be using the same physical connection calling DataService.disconnect() may terminate the connection.

The bindable property connected indicates the current state of the associated DataService connection.

If a remote destination has declared any security constraints for an operation, credentials must be provided. Credentials are set via the DataService.setCredentials() call. This turns into a login command at the remote destination. To change credentials or invalidate the current session DataService.logout() can be called. When called the DataService.logout() method will release all local managed data. It is equivalent to calling DataService.release().

Each DataService has a dataStore property that returns an object of type mx.data.DataStore. This object stores the uncommitted changes for one or more DataService objects. By default, a DataServiceshares the same DataService with other data services if they have managed association properties and share the same set of channels. When sharing DataStores, a commit() method call on one DataService commits changes for all DataService using the shared data store. This preserves the order of operations in the event there are dependencies between the changes in the associated DataService objects.

DataService and DataService dispatch result and fault events for all operations that require a remote call.

Data binding can be used on properties of any managed instances for a DataService. DataService will also dispatch a "message" event when a remote operation occurs for any managed object. For example when a locally managed item is updated by a remote process a message will be pushed to all DataService instances that are still managing that item. This message is dispatched as a MessageEvent.MESSAGE event.

When a conflict is detected either at the remote destination in response to a change committed by the DataService, or due to a pushed change which conflicts with a local uncommitted change, a conflict event is dispatched. These events can be handled by listening for the DataConflictEvent.CONFLICT. Data binding can be employed to update UI controls by binding to the DataService.conflicts.resolved property.

DataService supports the following data synchronization configuration modes:

  • autoCommit - when true each change is immediately sent to the remote destination once detected. When this is false, an explicit call to commit must be made. The bindable DataService.commitRequiredproperty can be used to determine whether or not there are uncommitted changes.
  • autoSyncEnabled - This affects any fill, getItem or createItem calls made and determines whether managed instances listen for changes made to these objects by other clients or using the server push api at the remote destination.
  • autoMerge property controls whether or not changes received from a remote destination are applied immediately or queued up until a call to DataService.merge() is made.

The DataService.revertChanges() method is used to revert changes for a specific item or for all items. When an error occurs for a remote destination operation, the committed changes are put back into the uncommitted queue so the data stays in sync with the remote destination data. If the changes are in error, typically a call to DataService.revertChanges() is made to undo the changes as part of a fault handler.

The mx.data.mxml.DataService class is an MXML-specific subclass of mx.data.DataService that allows binding to the properties of a DataService.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:DataService> tag accepts the following tag attributes:

  <mx:DataService
   Properties
   autoCommit="true"
   autoSyncEnabled="true"
   autoMerge="true"
   conflictDetector="No default."
   dataStore="No default."
   destination="No default."
   pageSize="No default."
   id="No default."

   Events
   conflict="No default."
   fault="No default."
   message="No default."
   propertyChange="No default."
   result="No default."
 />

See also

mx.data.mxml.DataService
mx.data.Conflicts
mx.data.Conflict
mx.data.ItemReference
mx.data.IManaged
mx.data.utils.Managed
mx.data.IChangeObject
Creating a distributed data application

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | autoCommit : Boolean Indicates if changes to the buffer are automatically committed. | DataService
 | autoMerge : Boolean If set to false, when changes are pushed from the remote destination to the client they are not immediately applied. | DataService
 | autoSyncEnabled : Boolean When true, fill(), createItem() and getItem() requests return items which listen for updates made to these items from the remote destination. | DataService
 | commitRequired : Boolean [read-only] Indicates if there are changes that have not been committed and the commit() method should be called. | DataService
 | conflictDetector : ConflictDetector Provides access to the current implementation being used to detect conflicts for remote operations pushed to this DataService. | DataService
 | conflicts : Conflicts [read-only] Returns the Conflicts object, an ArrayList of Conflict instances. | DataService
 | connected : Boolean [read-only] Indicates if the DataService is connected to the remote destination. | DataService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dataStore : DataStore Returns an object of type mx.data.DataStore. | DataService
 | destination : String [read-only] Indicates which remote destination this service is associated with. | DataService
 | mergeRequired : Boolean [read-only] Indicates if there are any pending changes that must be merged. | DataService
 | pageSize : int Provides access to the current page size setting for all collections. | DataService
 | pagingEnabled : Boolean [read-only] Indicates if the remote desintation is configured to allow paged requests. | DataService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | requestTimeout : int Provides access to the request timeout in seconds for an operation. | DataService
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataService(destination:String) Constructs an instance of the DataService with the specified destination. | DataService
 | commit():AsyncToken Commits any pending changes for all collections currently managed by this service. | DataService
 | count(... args):AsyncToken Calls a count method on the remote destination. | DataService
 | createItem(item:Object):ItemReference Requests that the specified item be created in the remote store. | DataService
 | deleteItem(item:Object):AsyncToken Requests that the specified item be deleted from the remote store. | DataService
 | disconnect():void Disconnects the DataService's network connection. | DataService
 | fill(value:ListCollectionView, ... args):AsyncToken Fills the specified ListCollectionView based on the associated <fill-method> elements. | DataService
 | getItem(identity:Object, defaultValue:Object = null):ItemReference Makes an asynchronous request for an item matching the specified identity. | DataService
 | getPendingOperation(item:IManaged):uint Returns the pending operation in the message cache for the specified item. | DataService
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | logout():void Logs the user out of the destination for the DataService. | DataService
 | merge():void Merges any pending updates into the managed set of objects. | DataService
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | release():void Releases all managed collections and items for the DataService. | DataService
 | releaseCollection(view:ListCollectionView, clear:Boolean = false):void Releases any item within the specified collection from management by this service. | DataService
 | releaseItem(item:IManaged, allowCopy:Boolean = true):IManaged Releases the specified item from management by this service. | DataService
 | revertChanges(item:IManaged = null):Boolean Reverts any uncommitted changes to the specified item. | DataService
 | setCredentials(username:String, password:String):void Sets the credentials for this DataService destination. | DataService
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setRemoteCredentials(username:String, password:String):void Sets the credentials for the third party of this DataService destination. | DataService
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Events
Event |  | Summary | Defined by
 | conflict | The DataConflictEvent.CONFLICT event is dispatched when a conflict is detected between either pending local changes and changes submitted by another client, or when changes submitted by this client are conflicting with those in the remote destination. | DataService
 | fault | The DataServiceFaultEvent.FAULT event is dispatched when a service call fails due to an error. | DataService
 | message | The MessageEvent.MESSAGE event is dispatched when the remote destination pushes a notification of a data operation. | DataService
 | propertyChange | The PropertyChangeEvent.PROPERTY_CHANGE event is dispatched when a property of this service changes. | DataService
 | result | The ResultEvent.RESULT event is dispatched when a service call successfully returns. | DataService
Property detail
autoCommit property
autoCommit:Boolean [read-write]

Indicates if changes to the buffer are automatically committed. Committed changes are sent to the remote service immediately.

Implementation
    public function get autoCommit():Boolean
    public function set autoCommit(value:Boolean):void
autoMerge property
autoMerge:Boolean [read-write]

If set to false, when changes are pushed from the remote destination to the client they are not immediately applied. Instead, the mergeRequired property is set to true. An event handler can be registered to listen for change events on this property to be notified of when a merge needs to be applied. To merge changes, call the merge() method and all changes are applied. Uncommited changes can not be committed when there are any changes that need to be merged. If paging is enabled all requests for non local items are cached until merge() is called. Once merge() is called, the cached requests are processed.

Implementation
    public function get autoMerge():Boolean
    public function set autoMerge(value:Boolean):void
autoSyncEnabled property
autoSyncEnabled:Boolean [read-write]

When true, fill(), createItem() and getItem() requests return items which listen for updates made to these items from the remote destination. When a change is made to this property value, it only affects future calls to these methods, not existing collections or items. Also note that when a mix of collections retrieved with autoSyncEnabled and those that were filled without autoSyncEnabled, any items appearing in both collections will still receive update events.

Implementation
    public function get autoSyncEnabled():Boolean
    public function set autoSyncEnabled(value:Boolean):void
commitRequired property
commitRequired:Boolean [read-only]

Indicates if there are changes that have not been committed and the commit() method should be called. When this property changes, an event is dispatched. This property can be used within an application to provide visual feedback.

This property can be used as the source for data binding.

Implementation
    public function get commitRequired():Boolean
conflictDetector property
conflictDetector:ConflictDetector [read-write]

Provides access to the current implementation being used to detect conflicts for remote operations pushed to this DataService.

Implementation
    public function get conflictDetector():ConflictDetector
    public function set conflictDetector(value:ConflictDetector):void
conflicts property
conflicts:Conflicts [read-only]

Returns the Conflicts object, an ArrayList of Conflict instances. Conflicts must be resolved before commit() can be called. Conflicts can be resolved by going through the conflicts, resolving each conflict individually or by calling the acceptAllClient() method or acceptAllServer() method on this property.

Implementation
    public function get conflicts():Conflicts
connected property
connected:Boolean [read-only]

Indicates if the DataService is connected to the remote destination.

This property can be used as the source for data binding.

Implementation
    public function get connected():Boolean
dataStore property
dataStore:DataStore [read-write]

Returns an object of type mx.data.DataStore. The DataStore manages the set of incoming and outgoing changes for one or more DataServices, which may have references between them. When you commit on a DataStore, all of the pending changes of each DataService using that DataStore are committed. By default, a DataService shares the same DataStore with other DataServices if they have managed association properties and share the same set of channels. If you are sharing DataStores, a commit call on one DataService commits changes for all DataServices using that data store. This preserves the order of operations in case there are dependencies between the changes in your uncommitted batches.

This property can be used as the source for data binding.

Implementation
    public function get dataStore():DataStore
    public function set dataStore(value:DataStore):void
destination property
destination:String [read-only]

Indicates which remote destination this service is associated with.

Implementation
    public function get destination():String
mergeRequired property
mergeRequired:Boolean [read-only]

Indicates if there are any pending changes that must be merged.

This property can be used as the source for data binding.

Implementation
    public function get mergeRequired():Boolean
pageSize property
pageSize:int [read-write]

Provides access to the current page size setting for all collections.

Implementation
    public function get pageSize():int
    public function set pageSize(value:int):void
pagingEnabled property
pagingEnabled:Boolean [read-only]

Indicates if the remote desintation is configured to allow paged requests.

Implementation
    public function get pagingEnabled():Boolean
requestTimeout property
requestTimeout:int [read-write]

Provides access to the request timeout in seconds for an operation. A value less than or equal to zero prevents request timeout. When a current operation times out due to the requestTimeout limit being reached a fault will be dispatched for that operation, indicating that the request was timed out.

Implementation
    public function get requestTimeout():int
    public function set requestTimeout(value:int):void
Constructor detail
DataService () constructor
public function DataService(destination:String)

Constructs an instance of the DataService with the specified destination. The destination must be a reference to a destination configured in the services-config.xml file.

Parameters
destination:String — that contains the name of the desired destination.
Method detail
commit () method
public function commit():AsyncToken

Commits any pending changes for all collections currently managed by this service. When autoCommit property is true, transactions are not be used. To use transactions, set the autoCommit property to false and call this method directly.

Returns
AsyncToken — AsyncToken that will be returned in the call property of either the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
count () method
public function count(... args):AsyncToken

Calls a count method on the remote destination. The count method called is based on the associated <count-method> tags and the parameters passed. For example, if the following count("firstName", "Bob") call was made and <count-method> tags exist or are referenced in the services-config.xml under the associated destination:

            <count-method>
                <name>getCount</name>
                <params>java.lang.String,java.lang.String</params>
                <security-run-as name="freddie" password="nightmare" />
            </count-method>

            <count-method>
                <name>getCount</name>
                <security-constraint ref="sample-users" />
            </count-method>
The first <count-method> with the run-as security setting is invoked because it contains two parameters, which matches the <params> tag types and count.

Parameters
... args — List of arguments that should be passed to the remote destination.

Returns
AsyncToken — Object returned in the call property of the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.

See also

mx.data.DataService.fill()
createItem () method
public function createItem(item:Object):ItemReference

Requests that the specified item be created in the remote store. If an error occurs a DataConflictEvent is dispatched.

Parameters
item:Object — that should be created in the remote store.

Returns
ItemReference — ItemReference (which extends AsyncToken). This reference is returned in the token property of either the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase. The result property of this object is bindable and can be used to bind the item returned. This result object is set to null if the item is removed from another client. If you hold on to ItemReference objects in your application, you should call the releaseItem() method in the ItemReference when you are finished with this reference to the item. If you do not hold onto the ItemReferences, you can use the releaseItem() method on the DataService, which takes the instance of the item itself to release.
deleteItem () method
public function deleteItem(item:Object):AsyncToken

Requests that the specified item be deleted from the remote store. If an error occurs a DataConflictEvent will be dispatched.

Parameters
item:Object — that should be deleted in the remote store.

Returns
AsyncToken — AsyncToken that will be returned in the token property of either the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
disconnect () method
public function disconnect():void

Disconnects the DataService's network connection. This method does not wait for outstanding network operations to complete.

fill () method
public function fill(value:ListCollectionView, ... args):AsyncToken

Fills the specified ListCollectionView based on the associated <fill-method> elements. For example, if the following <fill-method> elements exist or are referenced in the services-config.xml under the associated destination:

            <fill-method>
                <name>loadPersons</name>
                <params>java.lang.String,java.lang.String</params>
                <security-run-as name="freddie" password="nightmare" />
            </fill-method>

            <fill-method>
                <name>loadPersons</name>
                <security-constraint ref="sample-users" />
            </fill-method>
Then calling fill(myCollection, ["firstName", "Bob"]) invokes the first <fill-method> with the run-as security setting since it contains two parameters, matching the <params> tag types and count. Likewise, calling fill(myCollection) invokes the second <fill-method> tag as it contains no <params> tag. Any pending changes or data is cleared during a call to fill.

Parameters
value:ListCollectionView — to the collection that should be filled with the specified arguments.
... args — rest:Array variable list of arguments that should be passed to the remote destination.

Returns
AsyncToken — Object that is returned in the call property of the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
getItem () method
public function getItem(identity:Object, defaultValue:Object = null):ItemReference

Makes an asynchronous request for an item matching the specified identity. If you provide a defaultValue, and the item does not exist, the item is created instead using the information in the defaultValue. This method returns an ItemReference. If you receive a valid instance from the getItem() method call, you must call the releaseItem() method to release an instance of the item. If you hang onto the ItemReference, you should call the releaseItem() method on the reference to be sure you release the proper reference (in case your client has made more than one getItem() method call for the same item). If you do not hold onto the ItemReference, you can call the releaseItem() method on the DataService with the item itself.

Parameters
identity:Object — Object that contains the identity properties for the desired object.
defaultValue:Object (default = null) — An instance of the type with the default values that should be created if it doesn't exist.

Returns
ItemReference — ItemReference to the item you want to get. The ItemReference extends AsyncToken so you can use it to receive notification of when the item has been retrieved or when this call produces a fault. The ItemReference is returned as the token property in either the ResultEvent.RESULT or in the FaultEvent.FAULT if you are listening for events on the DataService object. Custom data can be attached to this object and inspected later during the event handling phase. You also can use data binding to bind to the result property of the ItemReference. This property is set to a valid value when the item is populated from the remote destination and is bindable so you can simply bind your user interface controls to the properties of the ItemReference's result property. If the item is removed from the server or another client, this reference is set to null. The ItemReference also has an invalid property which is set to true if the are errors returning the item or if the server returns null for an item.
getPendingOperation () method
public function getPendingOperation(item:IManaged):uint

Returns the pending operation in the message cache for the specified item. Use this method to provide visual feedback to a user of what type of change, if any, has been made to an item.

Parameters
item:IManaged — that should be tested against.

Returns
uint — uint that indicates what pending operation has been performed. The following are valid operations for an item:
  • DataMessage.CREATE_OPERATION - indicates that a create is pending for the specified item.
  • DataMessage.DELETE_OPERATION - indicates that a delete is pending for the specified item.
  • DataMessage.UPDATE_OPERATION - indicates that updates are pending for the specified item.
  • DataMessage.UNKNOWN_OPERATION - indicates that no operations are pending for the specified item.
logout () method
public function logout():void

Logs the user out of the destination for the DataService. Logging out of a destination applies to everything connected using the same ChannelSet as specified in the server configuration. For example, if you are connected over the my-rtmp channel and you log out using one of your DataService instances, anything that was connected over the same ChannelSet is logged out.

merge () method
public function merge():void

Merges any pending updates into the managed set of objects. The process of merging changes detect conflicts and process any pending item requests. This merges all messages for any other DataService instances that share this same data store.

release () method
public function release():void

Releases all managed collections and items for the DataService.

See also

mx.data.DataService.releaseCollection()
mx.data.DataService.releaseItem()
releaseCollection () method
public function releaseCollection(view:ListCollectionView, clear:Boolean = false):void

Releases any item within the specified collection from management by this service. If the item exists in more than one collection, a copy of the item is made. Any uncommitted changes made to an item that exists only in this collection are released, including deletes, creates and updates.

Parameters
view:ListCollectionView — ListCollectionView reference that should no longer receive remote updates.
clear:Boolean (default = false) — Boolean indicating if the all items should be removed from the list. In addition no copies will be made of any item.
releaseItem () method
public function releaseItem(item:IManaged, allowCopy:Boolean = true):IManaged

Releases the specified item from management by this service. If you hold onto ItemReferences, you should call the releaseItem() method on the ItemReference to be sure you release the proper reference in the case where you might have made more than one getItem call which retrieves the same item from different parts of your client application.

This call releases any associated resources, including nested properties. The specified item no longer receives updates from the remote destination. In addition if there are any uncommited changes to this item and it does not appear in any other collection these changes will also be released. If the specified item exists in more than one collection then the value handed back will be a copy of the original unless the allowCopy parameter is set to false.

Parameters
item:IManaged — IManaged reference to the item to be released.
allowCopy:Boolean (default = true) — Optional parameter that defaults to true. If true, makes a copy of the item if it is still referenced by another managed reference. You can set this to false but it would mean that object might still get updates from the server if it is still managed through other references.

Returns
IManaged — the released item which will be a copy if allowCopy=false and the item is managed by another reference.
revertChanges () method
public function revertChanges(item:IManaged = null):Boolean

Reverts any uncommitted changes to the specified item. Or if no item is suppied, it will revert all uncommitted changes. If you revert a create operation, it removes the item. If you revert a delete, it adds the item back in. Reverting an update restores the original properties of the item that were in place before you started changing it.

One situation in which you would use this method is after a fault has occurred. In that case, any failed changes are put back into the uncommitted changes list. At that point you can either modify those changes to fix the problem or revert them using this method to keep those changes from being resubmitted again.

If an item is supplied and this item doesn't have any changes this method will return false. If no item is supplied and there are no changes this method returns false. Otherwise, it returns true.

Parameters
item:IManaged (default = null) — reference to revert changes for or null to revert all changes.

Returns
Boolean — Boolean indicating if any changes were reverted.
setCredentials () method
public function setCredentials(username:String, password:String):void

Sets the credentials for this DataService destination. The credentials are applied to all services connected over the same ChannelSet.

Parameters
username:String — username for the destination.
password:String — The password for the destination
setRemoteCredentials () method
public function setRemoteCredentials(username:String, password:String):void

Sets the credentials for the third party of this DataService destination.

Parameters
username:String — The username for the destination.
password:String — The password for the destination.
Event detail
conflict event
Event object type: mx.data.events.DataConflictEvent
DataConflictEvent.type property = mx.data.events.DataConflictEvent.CONFLICT

The DataConflictEvent.CONFLICT event is dispatched when a conflict is detected between either pending local changes and changes submitted by another client, or when changes submitted by this client are conflicting with those in the remote destination. Each DataService sends conflict events only for items of this particular destination. Use the conflict event on the DataService if you need to handle conflicts for a set of related destinations at the same time.

The CONFLICT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
conflict | The Conflict object that holds the conflict that occurred.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
fault event
Event object type: mx.data.events.DataServiceFaultEvent
DataServiceFaultEvent.type property = mx.data.events.DataServiceFaultEvent.FAULT

The DataServiceFaultEvent.FAULT event is dispatched when a service call fails due to an error. For example, a call to the fill() method dispatches this event if the call fails. You'll also get this event for each item which generates an error as part of a commit result. In this case, the DataServiceFaultEvent will contain the token returned by the commit, but the item and error message strings in the fault are specific to the item which caused the error.

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, calling preventDefault() from the associated token's responder.fault method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that holds the conflict that occurred.
item | The item that generated the fault.
item | The identity of of the item that generated the fault.
message | The Message associated with this event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
message event
Event object type: mx.messaging.events.MessageEvent
MessageEvent.type property = mx.messaging.events.MessageEvent.MESSAGE

The MessageEvent.MESSAGE event is dispatched when the remote destination pushes a notification of a data operation. For example, when data is updated in the remote destination an update operation is sent to all clients listening, this operation is converted to a message event on this DataService.

The MESSAGE event type; dispatched upon receipt of a message.

The value of this constant is "message".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
propertyChange event
Event object type: mx.events.PropertyChangeEvent
PropertyChangeEvent.type property = mx.events.PropertyChangeEvent.PROPERTY_CHANGE

The PropertyChangeEvent.PROPERTY_CHANGE event is dispatched when a property of this service changes. This happens for the following properties:

  • commitRequired
  • mergeRequired
  • connected

The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event.

The properties of the event object have the following values:

Property | Value
bubbles | Determined by the constructor; defaults to false.
cancelable | Determined by the constructor; defaults to false.
kind | The kind of change; PropertyChangeEventKind.UPDATE or PropertyChangeEventKind.DELETE.
oldValue | The original property value.
newValue | The new property value, if any.
property | The property that changed
source | The object that contains the property that changed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result event
Event object type: mx.rpc.events.ResultEvent
ResultEvent.type property = mx.rpc.events.ResultEvent.RESULT

The ResultEvent.RESULT event is dispatched when a service call successfully returns. For example a call to fill() will dispatch this event if the call is successful.

The RESULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, preventDefault() from the associated token's responder.result method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result | Result that the RPC call returns.
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.


mx.data.DataStore (Flex™ 2 Language Reference)

Class DataStore | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public class DataStore
Inheritance | DataStore Inheritance EventDispatcher Inheritance Object

A DataStore batches transactions for one or more DataService instances. It manages the set of pending changes destined for the server and also stores the set of conflicts received from the server. By default, if your DataService does not have managed associations, it automatically gets its own independent DataStore. Each call to the commit() method send only changes made to that DataService.

When you use managed associations, the default changes so that all DataService instances that share the same set of channels and have the same value of the use-transactions flag share the same DataStore. When you are sharing a DataStore, a single call to the commit() method applies to all changes made by all DataService instances sharing that DataStore. The default changes because with managed associations, it is possible that changes between destinations can have dependencies so it is important to preserve the order of operations on the client when sending messages to the server.

If you want to change the default, you can create your own DataStore and manually assign it to one or more dataStore properties of a DataService. Do this when you first initialize your DataService, before you have issued any other DataService api calls such as fill or getItem. Note that all DataServices which share the same DataStore should be using the same set of channels and should also have the same value of the use-transactions flag.

See also

Creating a distributed data application

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | autoCommit : Boolean If set to true, operations that modify the state managed by the DataService are committed immediately. | DataStore
 | autoMerge : Boolean If set to false, when changes are pushed from the server to the client they are not immediately applied. | DataStore
 | commitRequired : Boolean [read-only] Indicates if there are pending updates that must be committed. | DataStore
 | conflicts : Conflicts [read-only] Returns a list of conflicts for all managed items. | DataStore
 | connected : Boolean [read-only] Indicates whether the DataStore is connected. | DataStore
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | mergeRequired : Boolean [read-only] Indicates if there are any pending changes that must be merged. | DataStore
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | requestTimeout : int Provides access to the request timeout in seconds for an operation. | DataStore
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataStore(destination:String, useTransactions:Boolean)
Normally, a DataStore is created automatically for you but you can create your own DataStore and assign it to the dataStore property of a DataService.
DataStore
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
commit():AsyncToken
Commits any pending changes for all collections currently managed by this DataService.
DataStore
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
merge():void
Merges any pending updates into the managed set of objects.
DataStore
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
revertChanges():Boolean
Reverts all pending (uncommitted) changes for all DataServices managed by this DataStore.
DataStore
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | conflict | Dispatched when a conflict is detected between either pending changes on this client and changes submitted by another client, or when changes submitted by this client result detect a conflict error at the remote destination. | DataStore
 | fault | The FaultEvent.FAULT event is dispatched when the commit call returns an error. | DataStore
 | result | The ResultEvent.RESULT event is dispatched when the commit call successfully returns. | DataStore
Property detail
autoCommit property
autoCommit:Boolean [read-write]

If set to true, operations that modify the state managed by the DataService are committed immediately. If set to false, you must explicitly call the commit() method to send the changes to the server.

Implementation
    public function get autoCommit():Boolean
    public function set autoCommit(value:Boolean):void
autoMerge property
autoMerge:Boolean [read-write]

If set to false, when changes are pushed from the server to the client they are not immediately applied. Instead, the mergeRequired property is set to true. You can listen for change events on this property to be notified of when a merge needs to be applied. To merge changes, you call the merge() method and all changes are applied. You are not able to commit any changes when there are any changes that must be merged.

Implementation
    public function get autoMerge():Boolean
    public function set autoMerge(value:Boolean):void
commitRequired property
commitRequired:Boolean [read-only]

Indicates if there are pending updates that must be committed.

This property can be used as the source for data binding.

Implementation
    public function get commitRequired():Boolean
conflicts property
conflicts:Conflicts [read-only]

Returns a list of conflicts for all managed items.

This property can be used as the source for data binding.

Implementation
    public function get conflicts():Conflicts
connected property
connected:Boolean [read-only]

Indicates whether the DataStore is connected.

Implementation
    public function get connected():Boolean
mergeRequired property
mergeRequired:Boolean [read-only]

Indicates if there are any pending changes that must be merged.

This property can be used as the source for data binding.

Implementation
    public function get mergeRequired():Boolean
requestTimeout property
requestTimeout:int [read-write]

Provides access to the request timeout in seconds for an operation. A value less than or equal to zero prevents request timeout.

Implementation
    public function get requestTimeout():int
    public function set requestTimeout(value:int):void
Constructor detail
DataStore () constructor
public function DataStore(destination:String, useTransactions:Boolean)

Normally, a DataStore is created automatically for you but you can create your own DataStore and assign it to the dataStore property of a DataService. To do this, you must ensure all data services that share the same data store use the same channel set and have the same value of the use-transactions configuration setting. Use this constructor to create a DataStore where the destination parameter contains the destination of one of the DataServices using this data store. This is just used to look up the channel set. You also should provide the value for the use-transactions flag for this data store.

Parameters
destination:String
useTransactions:Boolean
Method detail
commit () method
public function commit():AsyncToken

Commits any pending changes for all collections currently managed by this DataService. When the autoCommit property is true, transactions are not be used. To use transactions, set the autoCommit property to false and call this method directly.

Returns
AsyncToken — Object that is returned in call property of either the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
merge () method
public function merge():void

Merges any pending updates into the managed set of objects. The process of merging changes can detect conflicts.

revertChanges () method
public function revertChanges():Boolean

Reverts all pending (uncommitted) changes for all DataServices managed by this DataStore.

Returns
Boolean — true if any changes were reverted.
Event detail
conflict event
Event object type: mx.data.events.DataConflictEvent
DataConflictEvent.type property = mx.data.events.DataConflictEvent.CONFLICT

Dispatched when a conflict is detected between either pending changes on this client and changes submitted by another client, or when changes submitted by this client result detect a conflict error at the remote destination. The DataStore dispatches conflict events for all destinations which share the DataStore, or you can listen for conflict events for a specific type on a DataService. Use the DataStore when you have an object with associations as in that case, you may need to resolve conflicts in a specific order to maintain integrity of those associations.

The CONFLICT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
conflict | The Conflict object that holds the conflict that occurred.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
fault event
Event object type: mx.rpc.events.FaultEvent
FaultEvent.type property = mx.rpc.events.FaultEvent.FAULT

The FaultEvent.FAULT event is dispatched when the commit call returns an error.

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, calling preventDefault() from the associated token's responder.fault method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that contains the details of what caused this event.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
result event
Event object type: mx.rpc.events.ResultEvent
ResultEvent.type property = mx.rpc.events.ResultEvent.RESULT

The ResultEvent.RESULT event is dispatched when the commit call successfully returns.

The RESULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, preventDefault() from the associated token's responder.result method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result | Result that the RPC call returns.
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.


mx.data.IAccessPrivileges (Flex™ 2 Language Reference)

Interface IAccessPrivileges | Properties
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Interface | public interface IAccessPrivileges

Objects that must restrict access must implement the IAccessPrivileges interface.

Public Properties
Property |  | Defined by
 | privileges : AccessPrivileges Returns the current privilege settings. | IAccessPrivileges
Property detail
privileges property
privileges:AccessPrivileges [read-write]

Returns the current privilege settings.

Implementation
    public function get privileges():AccessPrivileges
    public function set privileges(value:AccessPrivileges):void


mx.data.IChangeObject (Flex™ 2 Language Reference)

Interface IChangeObject | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Interface | public interface IChangeObject

The IChangeObject interface provides the methods and properties needed when decting local conflicts. Conflicts represent an error that has occurred due to an update operation. Conflicts are generated for many reasons. For example, another client has updated the same property of an item. Conflicts are determined by both the remote destination and the local DataService. A conflict detected by the DataService is considered a local conflict. A conflict detected by the remote destination is a remote conflict. This interface is used when detecting local conflicts. Local conflicts are determined by the ConflictDetector object. To customize local conflict detection the ConflictDetector can be extended and assigned to the DataService.conflictDetector property.

Public Properties
Property |  | Defined by
 | changedPropertyNames : Array [read-only] Returns the list of property names which changed as part of an update. | IChangeObject
 | currentVersion : Object [read-only] New version of the item. | IChangeObject
 | identity : Object [read-only] Identity of the item being changed. | IChangeObject
 | message : DataMessage [read-only] Provides access to the local DataMessage corresponding to the local changes. | IChangeObject
 | newVersion : Object [read-only] Remote destinations current version of the item. | IChangeObject
 | previousVersion : Object [read-only] Previous version of the item. | IChangeObject
Public Methods
Method |  | Defined by
 | conflict(description:String, properties:Array):void Declares that a conflict occurred while processing this change. | IChangeObject
 | getConflict():DataErrorMessage Returns the conflict created with a previous call to the conflict() method. | IChangeObject
 | isCreate():Boolean Indicates if the change is due to a new item. | IChangeObject
 | isDelete():Boolean Indicates if the item was deleted. | IChangeObject
 | isUpdate():Boolean Indicates if the change is due to an update. | IChangeObject
Property detail
changedPropertyNames property
changedPropertyNames:Array [read-only]

Returns the list of property names which changed as part of an update. If this method returns null, it is in indication that all properties may have changed.

Implementation
    public function get changedPropertyNames():Array
currentVersion property
currentVersion:Object [read-only]

New version of the item.

Implementation
    public function get currentVersion():Object
identity property
identity:Object [read-only]

Identity of the item being changed.

Implementation
    public function get identity():Object
message property
message:DataMessage [read-only]

Provides access to the local DataMessage corresponding to the local changes.

Implementation
    public function get message():DataMessage
newVersion property
newVersion:Object [read-only]

Remote destinations current version of the item.

Implementation
    public function get newVersion():Object
previousVersion property
previousVersion:Object [read-only]

Previous version of the item.

Implementation
    public function get previousVersion():Object
Method detail
conflict () method
public function conflict(description:String, properties:Array):void

Declares that a conflict occurred while processing this change. The conflict will be dispatched as a ConflictEvent on the DataService. The specified properites list will indicate which properites are in conflict. The specified description will be available on the faultString property of the event's message property.

Parameters
description:String
properties:Array
getConflict () method
public function getConflict():DataErrorMessage

Returns the conflict created with a previous call to the conflict() method.

Returns
DataErrorMessage
isCreate () method
public function isCreate():Boolean

Indicates if the change is due to a new item.

Returns
Boolean
isDelete () method
public function isDelete():Boolean

Indicates if the item was deleted.

Returns
Boolean
isUpdate () method
public function isUpdate():Boolean

Indicates if the change is due to an update.

Returns
Boolean


mx.data.IManaged (Flex™ 2 Language Reference)

Interface IManaged | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Interface | public interface IManaged extends IPropertyChangeNotifier, IEventDispatcher, IUID

The IPropertyChangeNotifier interface provides the contract for a managed object. When using the [Managed] tag this interface will be implemented on the specified class during compilation.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | uid : String The unique identifier for this object. | IUID
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher


mx.data.ItemReference (Flex™ 2 Language Reference)

Class ItemReference | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public dynamic class ItemReference
Inheritance | ItemReference Inheritance AsyncToken Inheritance EventDispatcher Inheritance Object

An ItemReference instance is returned from the DataService.getItem() and DataService.createItem() methods to provide you with a way to manage your reference to the remote object. The AsyncToken implementation that this class extends provides a list of responders to be notified of result and fault events that occur on the operation to retrieve the item (the get or the create). You can bind to the value of the result property that always maintains a reference to the managed instance. If the item is deleted in another client, the result property is set to null. If a fault occurs and the DatService instance cannot retrieve the item, the invalid property is set to true. Listen for the fault event to get more information about what caused the error.

When you want to release your reference to this managed item, you should call the ItemReference.releaseItem() method. This is similar to calling the DataService.releaseItem() method but if you are holding references to the ItemReference instance you should use this version of the releaseItem() method to ensure that you release the correct reference to the item in case you have made more than one getItem() method call to retrieve the same item from different parts of your application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | message : IMessage Provides access to the associated message. | AsyncToken
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | responders : Array An array of IResponder handlers that will be called when the asynchronous request completes. | AsyncToken
Inherited | result : Object The result that was returned by the associated RPC call. | AsyncToken
 | valid : Boolean = false Set to true if the ItemReference becomes invalid either because the server faulted when trying to retrieve the item or if the retrieved item was itself null. | ItemReference
 | valid : Boolean = false | ItemReference
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ItemReference(msg:IMessage)
ItemReference
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
addResponder(responder:IResponder):void
addResponder adds a responder to an Array of responders.
AsyncToken
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hasResponder():Boolean
Determines if this token has at least one mx.rpc.IResponder registered.
AsyncToken
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
releaseItem(clear:Boolean = true):void
Releases the managed item reference retrieved with the getItem() or createItem() method call that returned this ItemReference.
ItemReference
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | propertyChange | Dispatched when a property of the channel set changes. | AsyncToken
Property detail
valid property
public var valid:Boolean = false

Set to true if the ItemReference becomes invalid either because the server faulted when trying to retrieve the item or if the retrieved item was itself null. You can use this property to bind to your user interface controls to display status information for this item without having to listen for explicit fault events.

This property can be used as the source for data binding.

valid property
public var valid:Boolean = false
Constructor detail
ItemReference () constructor
public function ItemReference(msg:IMessage)Parameters
msg:IMessage
Method detail
releaseItem () method
public function releaseItem(clear:Boolean = true):void

Releases the managed item reference retrieved with the getItem() or createItem() method call that returned this ItemReference. Since it is possible to have more than one ItemReference that points to the same item on the same client, this method ensures you release the proper reference.

Parameters
clear:Boolean (default = true)


mx.data.PageInformation (Flex™ 2 Language Reference)

Class PageInformation | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public final class PageInformation
Inheritance | PageInformation Inheritance Object

The PageInformation object provides detailed data about what pages of a collection have been loaded, how many there are, and what the current page size is.

Example
    var pageInfo:PageInformation = myDataService.getPageInformation(myCollection);
    trace("current page size: "+pageInfo.pageSize);
    trace("current page count: "+pageInfo.pageCount);
    var pagesLoaded:Array = []
    for (var i:int in pageInfo.loadedPages)
         pagesLoaded.push(i);
    trace("pages loaded: "+pagesLoaded.join());

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | loadedPages : Object [read-only] Provides read-only access to the loaded page information for the collection. | PageInformation
 | pageCount : int [read-only] Provides read-only access to the current number of pages in the collection. | PageInformation
 | pageSize : int [read-only] Provides read-only access to the current page size for the collection | PageInformation
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | PageInformation(pageSize:int, pageCount:int, loadedPages:Object) | PageInformation
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
loadedPages property
loadedPages:Object [read-only]

Provides read-only access to the loaded page information for the collection. This is a sparse array that contains only entries for pages that are loaded.

Implementation
    public function get loadedPages():Object

Example
        var pagesLoaded:Array = []
        for (var i:int in pageInfo.loadedPages)
             pagesLoaded.push(i);
        trace("pages loaded: "+pagesLoaded.join());

pageCount property
pageCount:int [read-only]

Provides read-only access to the current number of pages in the collection.

Implementation
    public function get pageCount():int
pageSize property
pageSize:int [read-only]

Provides read-only access to the current page size for the collection

Implementation
    public function get pageSize():int
Constructor detail
PageInformation () constructor
public function PageInformation(pageSize:int, pageCount:int, loadedPages:Object)Parameters
pageSize:int
pageCount:int
loadedPages:Object


mx.data.UpdateCollectionRange (Flex™ 2 Language Reference)

Class UpdateCollectionRange | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data
Class | public class UpdateCollectionRange
Inheritance | UpdateCollectionRange Inheritance Object

The UpdateCollectionRange class provides specific information about a range of add and remove operations made to a collection. These objects are associated with a specific UpdateCollectionMessage and are carried in an Array on its body property.

Example
     var ucm:UpdateCollectionMessage = UpdateCollectionMessage(msg);
     var ucr:UpdateCollectionRange = UpdateCollectionRange(ucm.body[0]);
     trace("First change to the collection was "+ ucr.updateType +" at "+
            ucr.position);

See also

mx.data.messages.UpdateCollectionMessage

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | identities : Array An Array of identity objects that represent which items were either deleted or inserted in the associated collection starting at the position indicated by the position property. | UpdateCollectionRange
 | position : int Indicates the begining index for the range of updates made to the associated collection. | UpdateCollectionRange
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | updateType : int Indicates what operation this range represents. | UpdateCollectionRange
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | UpdateCollectionRange() Constructs an empty UpdateCollectionRange. | UpdateCollectionRange
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DELETE_FROM_COLLECTION : int = 1 [static] Indicates a range of items that have been deleted from the collection. | UpdateCollectionRange
 | INSERT_INTO_COLLECTION : int = 0 [static] Indicates a range of items have been inserted into the collection. | UpdateCollectionRange
Property detail
identities property
public var identities:Array

An Array of identity objects that represent which items were either deleted or inserted in the associated collection starting at the position indicated by the position property.

position property
public var position:int

Indicates the begining index for the range of updates made to the associated collection. The updateType indicates if the range was an insert or a remove operation.

updateType property
public var updateType:int

Indicates what operation this range represents. Valid values are:

  • UpdateCollectionRange.INSERT_INTO_COLLECTION
  • UpdateCollectionRange.DELETE_FROM_COLLECTION

Constructor detail
UpdateCollectionRange () constructor
public function UpdateCollectionRange()

Constructs an empty UpdateCollectionRange.

Constant detail
DELETE_FROM_COLLECTION constant
public static const DELETE_FROM_COLLECTION:int = 1

Indicates a range of items that have been deleted from the collection. The identities property will contain an Array of item identity objects for each item that was inserted into the collection. The position property indicates at what index the insertion operation began. Inspect the identityies.length to determine how many items were inserted.

INSERT_INTO_COLLECTION constant
public static const INSERT_INTO_COLLECTION:int = 0

Indicates a range of items have been inserted into the collection. The identities property will contain an Array of item identity objects for each item that was inserted into the collection. The position property indicates at what index the insertion operation began. Inspect the identityies.length to determine how many items were inserted.


mx.data.errors Summary (Flex™ 2 Language Reference)

Package mx.data.errors | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.data.errors package contains the error classes used with the Flex Data Management Service.

Classes
Class | Description
DataListError | This error is thrown when an unanticipated problem occurs in a DataList.
DataServiceError | This error is thrown when a an unanticipated problem occurs in a DataService component.
NoDataAvailableError | This error is thrown when data requested is not local.
UnresolvedConflictsError | This error is thrown when a commit request is made while there are still unresolved conflicts and no listener has been registered for UnresolvedConflictsEvent.FAULT.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.data.errors.DataListError (Flex™ 2 Language Reference)

Class DataListError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.errors
Class | public class DataListError
Inheritance | DataListError Inheritance Error Inheritance Object

This error is thrown when an unanticipated problem occurs in a DataList.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataListError(msg:String) Constructs a new instance of the error with the specified message. | DataListError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
DataListError () constructor
public function DataListError(msg:String)

Constructs a new instance of the error with the specified message.

Parameters
msg:String — that contains the message that describes this error.


mx.data.errors.DataServiceError (Flex™ 2 Language Reference)

Class DataServiceError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.errors
Class | public class DataServiceError
Inheritance | DataServiceError Inheritance Error Inheritance Object

This error is thrown when a an unanticipated problem occurs in a DataService component.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataServiceError(msg:String) Constructs a new instance of the error with the specified message. | DataServiceError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
DataServiceError () constructor
public function DataServiceError(msg:String)

Constructs a new instance of the error with the specified message.

Parameters
msg:String — String that contains the message that describes this error.


mx.data.errors.NoDataAvailableError (Flex™ 2 Language Reference)

Class NoDataAvailableError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.errors
Class | public class NoDataAvailableError
Inheritance | NoDataAvailableError Inheritance Error Inheritance Object

This error is thrown when data requested is not local. The receiver of this error may assign an object which implements the mx.rpc.IResponder inerface to the responder property to receive notification of when the data requested is available.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | responder : IResponder If the data is not local and an asynchronous operation must be performed, an NoDataAvailableError will be thrown. | NoDataAvailableError
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | NoDataAvailableError(msg:String = "Requested data not found.") Constructs a new instance of the error with the specified message. | NoDataAvailableError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
responder property
responder:IResponder [read-write]

If the data is not local and an asynchronous operation must be performed, an NoDataAvailableError will be thrown. The responder property references the handler that will be called when the asynchronous request completes. The object assigned to the responder property must implement mx.rpc.IResponder. On successful return of the remote data the result method will be invoked, on failure the fault method will be invoked.

Implementation
    public function get responder():IResponder
    public function set responder(value:IResponder):void
Constructor detail
NoDataAvailableError () constructor
public function NoDataAvailableError(msg:String = "Requested data not found.")

Constructs a new instance of the error with the specified message.

Parameters
msg:String (default = "Requested data not found.") — String that contains the message that describes this error.


mx.data.errors.UnresolvedConflictsError (Flex™ 2 Language Reference)

Class UnresolvedConflictsError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.errors
Class | public class UnresolvedConflictsError
Inheritance | UnresolvedConflictsError Inheritance Error Inheritance Object

This error is thrown when a commit request is made while there are still unresolved conflicts and no listener has been registered for UnresolvedConflictsEvent.FAULT.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | UnresolvedConflictsError(msg:String) Constructs a new instance of the error with the specified message. | UnresolvedConflictsError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "Error" by default or the value contained in Error.message property, if defined. | Error
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
UnresolvedConflictsError () constructor
public function UnresolvedConflictsError(msg:String)

Constructs a new instance of the error with the specified message.

Parameters
msg:String — String that contains the message that describes this error.


mx.data.events Summary (Flex™ 2 Language Reference)

Package mx.data.events | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.data.events package contains the event classes used with the Flex Data Management Service.

Classes
Class | Description
DataConflictEvent | This event informs users of a DataService instance that a conflict has occured.
DataServiceFaultEvent | This event is sent when a DataService or DataStore has generated a fault.
UnresolvedConflictsEvent | A DataList throws this event when the commit() method is called while conflicts remain unresolved.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.data.events.DataConflictEvent (Flex™ 2 Language Reference)

Class DataConflictEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.events
Class | public class DataConflictEvent
Inheritance | DataConflictEvent Inheritance Event Inheritance Object

This event informs users of a DataService instance that a conflict has occured. The user should access the conflicts Array from the DataService and resolve each one in turn.

See also

mx.data.DataService.conflicts

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | conflict : Conflict | DataConflictEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataConflictEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, c:Conflict = null) | DataConflictEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
 | createEvent(c:Conflict):DataConflictEvent [static] | DataConflictEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
 | CONFLICT : String = "conflict" [static] The CONFLICT event type. | DataConflictEvent
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
conflict property
public var conflict:Conflict
Constructor detail
DataConflictEvent () constructor
public function DataConflictEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, c:Conflict = null)Parameters
type:String
bubbles:Boolean (default = false)
cancelable:Boolean (default = false)
c:Conflict (default = null)
Method detail
createEvent () method
public static function createEvent(c:Conflict):DataConflictEvent Parameters
c:Conflict

Returns
DataConflictEvent
Constant detail
CONFLICT constant
public static const CONFLICT:String = "conflict"

The CONFLICT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
conflict | The Conflict object that holds the conflict that occurred.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.data.events.DataServiceFaultEvent (Flex™ 2 Language Reference)

Class DataServiceFaultEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.events
Class | public class DataServiceFaultEvent
Inheritance | DataServiceFaultEvent Inheritance FaultEvent Inheritance AbstractEvent Inheritance MessageEvent Inheritance Event Inheritance Object
Subclasses | UnresolvedConflictsEvent

This event is sent when a DataService or DataStore has generated a fault. If the fault was generated for a specific item, the item and/or its identity can be retrieved from this fault.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | fault : Fault The Fault object that contains the details of what caused this event. | FaultEvent
 | identity : Object The identity of the item that generated the fault. | DataServiceFaultEvent
 | item : Object Stores the item that generated the fault. | DataServiceFaultEvent
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | token : AsyncToken The token that represents the call to the method. | AbstractEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataServiceFaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, fault:Fault = null, token:AsyncToken = null, message:ErrorMessage = null, obj:Object = null, id:Object = null) | DataServiceFaultEvent
Inherited | clone():Event Clones the MessageEvent. | MessageEvent
 | createEvent(fault:Fault, token:AsyncToken, message:ErrorMessage, obj:Object, id:Object):DataServiceFaultEvent [static] | DataServiceFaultEvent
Inherited | createEventFromMessageFault(value:MessageFaultEvent, token:AsyncToken = null):FaultEvent [static] Given a MessageFaultEvent, this method constructs and returns a FaultEvent. | FaultEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string representation of the FaultEvent. | FaultEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | FAULT : String = "fault" [static] The FAULT event type. | DataServiceFaultEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
identity property
public var identity:Object

The identity of the item that generated the fault. This is null if there was no single item associated with the fault.

item property
public var item:Object

Stores the item that generated the fault. This is null if no item was available or this fault occurred due to the failure of a batch of items.

Constructor detail
DataServiceFaultEvent () constructor
public function DataServiceFaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, fault:Fault = null, token:AsyncToken = null, message:ErrorMessage = null, obj:Object = null, id:Object = null)Parameters
type:String
bubbles:Boolean (default = false)
cancelable:Boolean (default = true)
fault:Fault (default = null)
token:AsyncToken (default = null)
message:ErrorMessage (default = null)
obj:Object (default = null)
id:Object (default = null)
Method detail
createEvent () method
public static function createEvent(fault:Fault, token:AsyncToken, message:ErrorMessage, obj:Object, id:Object):DataServiceFaultEvent Parameters
fault:Fault
token:AsyncToken
message:ErrorMessage
obj:Object
id:Object

Returns
DataServiceFaultEvent
Constant detail
FAULT constant
public static const FAULT:String = "fault"

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, calling preventDefault() from the associated token's responder.fault method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that holds the conflict that occurred.
item | The item that generated the fault.
item | The identity of of the item that generated the fault.
message | The Message associated with this event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.data.events.UnresolvedConflictsEvent (Flex™ 2 Language Reference)

Class UnresolvedConflictsEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.events
Class | public class UnresolvedConflictsEvent
Inheritance | UnresolvedConflictsEvent Inheritance DataServiceFaultEvent Inheritance FaultEvent Inheritance AbstractEvent Inheritance MessageEvent Inheritance Event Inheritance Object

A DataList throws this event when the commit() method is called while conflicts remain unresolved.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | fault : Fault The Fault object that contains the details of what caused this event. | FaultEvent
Inherited | identity : Object The identity of the item that generated the fault. | DataServiceFaultEvent
Inherited | item : Object Stores the item that generated the fault. | DataServiceFaultEvent
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | token : AsyncToken The token that represents the call to the method. | AbstractEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | UnresolvedConflictsEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false) | UnresolvedConflictsEvent
Inherited | clone():Event Clones the MessageEvent. | MessageEvent
Inherited | createEvent(fault:Fault, token:AsyncToken, message:ErrorMessage, obj:Object, id:Object):DataServiceFaultEvent [static] | DataServiceFaultEvent
Inherited | createEventFromMessageFault(value:MessageFaultEvent, token:AsyncToken = null):FaultEvent [static] Given a MessageFaultEvent, this method constructs and returns a FaultEvent. | FaultEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string representation of the FaultEvent. | FaultEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | FAULT : String = "fault" [static] The FAULT event type. | UnresolvedConflictsEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
UnresolvedConflictsEvent () constructor
public function UnresolvedConflictsEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false)Parameters
type:String
bubbles:Boolean (default = false)
cancelable:Boolean (default = false)
Constant detail
FAULT constant
public static const FAULT:String = "fault"

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that holds the conflict that occurred.
item | The item that generated the fault.
item | The identity of of the item that generated the fault.
message | The Message associated with this event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.data.messages Summary (Flex™ 2 Language Reference)

Package mx.data.messages | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.data.messages package contains the messages used with the Flex Data Management Service.

Classes
Class | Description
DataAssociationMessage | This message is used to add and remove associations between objects managed by different data services.
DataErrorMessage | Special cases of ErrorMessage will be sent when a data conflict occurs.
DataMessage | This message is used to transport an operation that occured on a managed object or collection.
PagedMessage | This messsage provides information about a partial sequence result.
SequencedMessage | Clients receive this message in response to DataService.fill() request.
UpdateCollectionMessage | This message is used to establish consistency between the remote sequence and the corresponding local collection.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.data.messages.DataAssociationMessage (Flex™ 2 Language Reference)

Class DataAssociationMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.messages
Class | public class DataAssociationMessage
Inheritance | DataAssociationMessage Inheritance DataMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object

This message is used to add and remove associations between objects managed by different data services. Associations are configured using the <metadata> tag in the destination configuration xml file.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
 | childMessageId : String If the association involves a child that is being created in the same message batch, the server will use this message id to locate the child instead of relying on the identity provided by the client (the identity may be changed by the server). | DataAssociationMessage
 | childSequenceId : int The index of the child sequence on the server. | DataAssociationMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | identity : Object Provides access to the identity map which defines the unique identity of the item affected by this DataMessage (relevant for create/update/delete but not fill operations). | DataMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
Inherited | operation : uint Provides access to the operation/command of this DataMessage. | DataMessage
 | parentMessageId : String If the association involves a parent that is being created in the same message batch, the server will use this message id to locate the parent instead of relying on the identity provided by the client (the identity may be changed by the server) | DataAssociationMessage
 | parentPropertyName : String The property name by which the parent references the child. | DataAssociationMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | sequencePosition : int = -1 For one-to-many relationships, the position of the child instance in the sequence, optionally used for adding and removing child relationships to a specific location in the sequence. | DataAssociationMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataAssociationMessage() Creates a new instance of an empty association message. | DataAssociationMessage
Inherited | getOperationAsString(op:uint):String [static] Provides a description of the operation specified. | DataMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isCompensating(msg:DataAssociationMessage):Boolean Determines whether the passed message is compensating to the current message. | DataAssociationMessage
Inherited | isCreate():Boolean Returns true if this is a create operation. | DataMessage
Inherited | isEmptyUpdate():Boolean Returns true if this message is both an update and its list of property names has a length of zero. | DataMessage
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ASSOCIATION_ADD_OPERATION : uint = 13 [static] This operation requests the remote destination add a new association between the specified instances. | DataMessage
Inherited | ASSOCIATION_REMOVE_OPERATION : uint = 14 [static] This operation requests the remote destination remove an association between the specified instances. | DataMessage
Inherited | BATCHED_OPERATION : uint = 5 [static] This operation represents a set of batched operations to be performed as a single unit. | DataMessage
Inherited | COUNT_OPERATION : uint = 9 [static] This operation requests that a configured <count-method> be invoked on a remote destination. | DataMessage
Inherited | CREATE_AND_SEQUENCE_OPERATION : uint = 11 [static] This operation requests a create of the specified item from a remote destination. | DataMessage
Inherited | CREATE_OPERATION : uint = 0 [static] Indicates a create operation. | DataMessage
Inherited | DELETE_OPERATION : uint = 4 [static] This operation indicates that the specified item should be removed. | DataMessage
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | FILL_OPERATION : uint = 1 [static] This operation requests that the remote destination create a sequence using the remote destination's adapter. | DataMessage
Inherited | GET_OPERATION : uint = 2 [static] This operation requests that the remote destination get a specific managed object based on its unique ID. | DataMessage
Inherited | GET_OR_CREATE_OPERATION : uint = 10 [static] This operation requests an item with the specified identity from the remote destination. | DataMessage
Inherited | GET_SEQUENCE_ID_OPERATION : uint = 12 [static] This operation requests a sequence id for a set of fill parameters. | DataMessage
Inherited | MULTI_BATCH_OPERATION : uint = 6 [static] This operation represents a set of operations to be performed as a single unit but which may contain multiple batched, create, update or delete operations that involve more than one destination, that is, more than one remote adapter. | DataMessage
Inherited | PAGE_ITEMS_OPERATION : uint = 20 [static] This operation indicates a request for a page of items specified by identities. | DataMessage
Inherited | PAGE_OPERATION : uint = 8 [static] This operation is used to retrieve a page of sequenced content that is delivered across several messages instead of in a single message. | DataMessage
Inherited | RELEASE_COLLECTION_OPERATION : uint = 18 [static] This operation indicates that the client is no longer interested in receiving notificaion of operations performed on the specified collection. | DataMessage
Inherited | RELEASE_ITEM_OPERATION : uint = 19 [static] This operation indicates that the client is no longer interested in receiving notification of operations performed on the specified item. | DataMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Inherited | TRANSACTED_OPERATION : uint = 7 [static] This operation is similar to the MULTI_BATCH_OPERATION with the addition that the server should encapsulate the multiple batches of messages within a transacation. | DataMessage
Inherited | UNKNOWN_OPERATION : uint = 1000 [static] Code for an unknown operation type. | DataMessage
Inherited | UPDATE_BODY_CHANGES : uint = 0 [static] This constant is used to access the list of changed property names. | DataMessage
Inherited | UPDATE_BODY_NEW : uint = 2 [static] This constant is used to access the new value of a changed item. | DataMessage
Inherited | UPDATE_BODY_PREV : uint = 1 [static] This constant is used to access the previous value of the changed item. | DataMessage
Inherited | UPDATE_COLLECTION_OPERATION : uint = 17 [static] This operation is sent when a local or remote sequence has been modified by insert(s) or delete(s). | DataMessage
Inherited | UPDATE_OPERATION : uint = 3 [static] This operation indicates an update to data object has been performed. | DataMessage
Property detail
childMessageId property
public var childMessageId:String

If the association involves a child that is being created in the same message batch, the server will use this message id to locate the child instead of relying on the identity provided by the client (the identity may be changed by the server).

childSequenceId property
public var childSequenceId:int

The index of the child sequence on the server.

parentMessageId property
public var parentMessageId:String

If the association involves a parent that is being created in the same message batch, the server will use this message id to locate the parent instead of relying on the identity provided by the client (the identity may be changed by the server)

parentPropertyName property
public var parentPropertyName:String

The property name by which the parent references the child.

sequencePosition property
public var sequencePosition:int = -1

For one-to-many relationships, the position of the child instance in the sequence, optionally used for adding and removing child relationships to a specific location in the sequence.

Constructor detail
DataAssociationMessage () constructor
public function DataAssociationMessage()

Creates a new instance of an empty association message.

Method detail
isCompensating () method
public function isCompensating(msg:DataAssociationMessage):Boolean

Determines whether the passed message is compensating to the current message. An association add is compensating to a matching association remove, and vice versa.

Parameters
msg:DataAssociationMessage — The message to test against this message.

Returns
Boolean — true if the message is compensating; otherwise false.


mx.data.messages.DataErrorMessage (Flex™ 2 Language Reference)

Class DataErrorMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.messages
Class | public class DataErrorMessage
Inheritance | DataErrorMessage Inheritance ErrorMessage Inheritance AcknowledgeMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object

Special cases of ErrorMessage will be sent when a data conflict occurs. This message provides the conflict information in addition to the ErrorMessage information.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
 | cause : DataMessage The client oringinated message which caused the conflict. | DataErrorMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | extendedData : Object Extended data that the remote destination has chosen to associate with this error to facilitate custom error processing on the client. | ErrorMessage
Inherited | faultCode : String The fault code for the error. | ErrorMessage
Inherited | faultDetail : String Detailed description of what caused the error. | ErrorMessage
Inherited | faultString : String A simple description of the error. | ErrorMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
 | propertyNames : Array An array of properties that were found to be conflicting between the client and server objects. | DataErrorMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | rootCause : Object Should a root cause exist for the error, this property contains those details. | ErrorMessage
 | serverObject : Object The value that the server had for the object with the conflicting properties. | DataErrorMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataErrorMessage() Constructs an instance of a DataErrorMessage. | DataErrorMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | ERROR_HINT_HEADER : String = "DSErrorHint" [static] Header name for the error hint header. | AcknowledgeMessage
Inherited | MESSAGE_DELIVERY_IN_DOUBT : String = "Client.Error.DeliveryInDoubt" [static] If a message may not have been delivered, the faultCode will contain this constant. | ErrorMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Inherited | RETRYABLE_HINT_HEADER : String = "DSRetryableErrorHint" [static] Header name for the retryable hint header. | ErrorMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Property detail
cause property
public var cause:DataMessage

The client oringinated message which caused the conflict.

propertyNames property
public var propertyNames:Array

An array of properties that were found to be conflicting between the client and server objects.

serverObject property
public var serverObject:Object

The value that the server had for the object with the conflicting properties.

Constructor detail
DataErrorMessage () constructor
public function DataErrorMessage()

Constructs an instance of a DataErrorMessage.


mx.data.messages.DataMessage (Flex™ 2 Language Reference)

Class DataMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.messages
Class | public class DataMessage
Inheritance | DataMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object
Subclasses | DataAssociationMessage, UpdateCollectionMessage

This message is used to transport an operation that occured on a managed object or collection. This class of message is transmitted between clients subscribed to a remote destination as well as between server nodes within a cluster. The payload of this message describes all of the relevant details of the operation. This information is used to replicate updates and detect conflicts. The body of the message will contain different data based on the operation setting.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
 | identity : Object Provides access to the identity map which defines the unique identity of the item affected by this DataMessage (relevant for create/update/delete but not fill operations). | DataMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
 | operation : uint Provides access to the operation/command of this DataMessage. | DataMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataMessage() Creates a new instance of an empty DataMessage. | DataMessage
 | getOperationAsString(op:uint):String [static] Provides a description of the operation specified. | DataMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isCreate():Boolean Returns true if this is a create operation. | DataMessage
 | isEmptyUpdate():Boolean Returns true if this message is both an update and its list of property names has a length of zero. | DataMessage
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
 | ASSOCIATION_ADD_OPERATION : uint = 13 [static] This operation requests the remote destination add a new association between the specified instances. | DataMessage
 | ASSOCIATION_REMOVE_OPERATION : uint = 14 [static] This operation requests the remote destination remove an association between the specified instances. | DataMessage
 | BATCHED_OPERATION : uint = 5 [static] This operation represents a set of batched operations to be performed as a single unit. | DataMessage
 | COUNT_OPERATION : uint = 9 [static] This operation requests that a configured <count-method> be invoked on a remote destination. | DataMessage
 | CREATE_AND_SEQUENCE_OPERATION : uint = 11 [static] This operation requests a create of the specified item from a remote destination. | DataMessage
 | CREATE_OPERATION : uint = 0 [static] Indicates a create operation. | DataMessage
 | DELETE_OPERATION : uint = 4 [static] This operation indicates that the specified item should be removed. | DataMessage
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
 | FILL_OPERATION : uint = 1 [static] This operation requests that the remote destination create a sequence using the remote destination's adapter. | DataMessage
 | GET_OPERATION : uint = 2 [static] This operation requests that the remote destination get a specific managed object based on its unique ID. | DataMessage
 | GET_OR_CREATE_OPERATION : uint = 10 [static] This operation requests an item with the specified identity from the remote destination. | DataMessage
 | GET_SEQUENCE_ID_OPERATION : uint = 12 [static] This operation requests a sequence id for a set of fill parameters. | DataMessage
 | MULTI_BATCH_OPERATION : uint = 6 [static] This operation represents a set of operations to be performed as a single unit but which may contain multiple batched, create, update or delete operations that involve more than one destination, that is, more than one remote adapter. | DataMessage
 | PAGE_ITEMS_OPERATION : uint = 20 [static] This operation indicates a request for a page of items specified by identities. | DataMessage
 | PAGE_OPERATION : uint = 8 [static] This operation is used to retrieve a page of sequenced content that is delivered across several messages instead of in a single message. | DataMessage
 | RELEASE_COLLECTION_OPERATION : uint = 18 [static] This operation indicates that the client is no longer interested in receiving notificaion of operations performed on the specified collection. | DataMessage
 | RELEASE_ITEM_OPERATION : uint = 19 [static] This operation indicates that the client is no longer interested in receiving notification of operations performed on the specified item. | DataMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
 | TRANSACTED_OPERATION : uint = 7 [static] This operation is similar to the MULTI_BATCH_OPERATION with the addition that the server should encapsulate the multiple batches of messages within a transacation. | DataMessage
 | UNKNOWN_OPERATION : uint = 1000 [static] Code for an unknown operation type. | DataMessage
 | UPDATE_BODY_CHANGES : uint = 0 [static] This constant is used to access the list of changed property names. | DataMessage
 | UPDATE_BODY_NEW : uint = 2 [static] This constant is used to access the new value of a changed item. | DataMessage
 | UPDATE_BODY_PREV : uint = 1 [static] This constant is used to access the previous value of the changed item. | DataMessage
 | UPDATE_COLLECTION_OPERATION : uint = 17 [static] This operation is sent when a local or remote sequence has been modified by insert(s) or delete(s). | DataMessage
 | UPDATE_OPERATION : uint = 3 [static] This operation indicates an update to data object has been performed. | DataMessage
Property detail
identity property
public var identity:Object

Provides access to the identity map which defines the unique identity of the item affected by this DataMessage (relevant for create/update/delete but not fill operations).

operation property
public var operation:uint

Provides access to the operation/command of this DataMessage. Operations indicate how the remote destination should process this message. To display a description of operation type use the getOperationAsString method.

See also

getOperationAsString()
Constructor detail
DataMessage () constructor
public function DataMessage()

Creates a new instance of an empty DataMessage.

Method detail
getOperationAsString () method
public static function getOperationAsString(op:uint):String

Provides a description of the operation specified. This method is used in toString() operations on this message.

Parameters
op:uint

Returns
String

Example
         var msg:DataMessage = DataMessage(event.message);
         trace("Current operation -'"+
                DataMessage.getOperationAsString(msg.operation)+ "'.");

isCreate () method
public function isCreate():Boolean

Returns true if this is a create operation.

Returns
Boolean — Boolean indicating if this is a create operation.

See also

CREATE_OPERATION
CREATE_AND_SEQUENCE_OPERATION
isEmptyUpdate () method
public function isEmptyUpdate():Boolean

Returns true if this message is both an update and its list of property names has a length of zero.

Returns
Boolean
Constant detail
ASSOCIATION_ADD_OPERATION constant
public static const ASSOCIATION_ADD_OPERATION:uint = 13

This operation requests the remote destination add a new association between the specified instances. The body property will contain a reference to the item that will be added. Clients send this operation when a one-to-many or many-to-many association's many side has an item added to it. The many side of the association is represented by a collection under managemenet of a DataService and calls to the IList.addItemAt(), IList.addItem() or IViewCursor.insert() methods will generate this operation.

See also

mx.collections.IList.addItemAt()
mx.collections.IList.addItem()
mx.collections.IViewCursor.insert()
ASSOCIATION_REMOVE_OPERATION constant
public static const ASSOCIATION_REMOVE_OPERATION:uint = 14

This operation requests the remote destination remove an association between the specified instances. The body property will contain a reference to the item that will be removed. Clients send this operation when a one-to-many or many-to-many association's many side has an item removed from it. The many side of the association is represented by a collection under managemenet of a DataService and calls to the IList.removeItemAt() or IViewCursor.remove() methods will generate this operation.

See also

mx.collections.IList.removeItemAt()
mx.collections.IViewCursor.remove()
BATCHED_OPERATION constant
public static const BATCHED_OPERATION:uint = 5

This operation represents a set of batched operations to be performed as a single unit. Clients send a batch when DataService.commit() is invoked. All messages in the batch are intended for the same destination. The body property contains all of the messages that belong within this batch.

COUNT_OPERATION constant
public static const COUNT_OPERATION:uint = 9

This operation requests that a configured <count-method> be invoked on a remote destination. The body property of the message will contain the arguments that should be passed to the remote destination when invoking the method. Clients send this operation when the DataService.count() method is invoked.

See also

mx.data.DataService.count()
CREATE_AND_SEQUENCE_OPERATION constant
public static const CREATE_AND_SEQUENCE_OPERATION:uint = 11

This operation requests a create of the specified item from a remote destination. Clients send this operation when the DataService.createItem() method is invoked. The body property contains the item that should be created.

See also

mx.data.DataService.createItem()
CREATE_OPERATION constant
public static const CREATE_OPERATION:uint = 0

Indicates a create operation. The body property will contain the new item to be created. When the operation is perfomed outside of an association a corresponding UpdateCollectionMessage will be delivered indicating the location/index the item should be added at. Clients will send this operation when a collection under managemenet of a DataService uses the IList.addItemAt(), IList.addItem() or IViewCursor.insert() methods.

See also

mx.data.messages.UpdateCollectionMessage
DELETE_OPERATION constant
public static const DELETE_OPERATION:uint = 4

This operation indicates that the specified item should be removed. Clients will receive and send this operation when the item is removed. Clients will send this operation when DataService.deleteItem() or when a collection under managemenet of a DataService uses the IList.removeItemAt() or IViewCursor.remove() method.

See also

mx.data.DataService.deleteItem()
mx.collections.IList.removeItemAt()
mx.collections.IViewCursor.remove()
FILL_OPERATION constant
public static const FILL_OPERATION:uint = 1

This operation requests that the remote destination create a sequence using the remote destination's adapter. The body property of the message will contain the fill arguments that should be used when creating the remote sequence.

GET_OPERATION constant
public static const GET_OPERATION:uint = 2

This operation requests that the remote destination get a specific managed object based on its unique ID. The identity property contain's the desired object's identity.

See also

mx.data.DataService.getItem()
GET_OR_CREATE_OPERATION constant
public static const GET_OR_CREATE_OPERATION:uint = 10

This operation requests an item with the specified identity from the remote destination. If no item exists with the identity, a create operation will be performed. Clients send this operation when the DataService.getItem() method is called with non-null default values for the item. The body property contains the default values of the item should it need to be created.

See also

mx.data.DataService.getItem()
GET_SEQUENCE_ID_OPERATION constant
public static const GET_SEQUENCE_ID_OPERATION:uint = 12

This operation requests a sequence id for a set of fill parameters. If the sequence exists, it will not be recreated. If it does not exist, it will be recreated remotely. Clients send this operation when reconnecting to a remote destination or when failing over to a new node within a cluster. This operation is only used if the fetch attribute of the <reconnect> tag in the remote destination's configuration xml file is set to IDENTITY.

See also

mx.data.DataService.disconnect()
MULTI_BATCH_OPERATION constant
public static const MULTI_BATCH_OPERATION:uint = 6

This operation represents a set of operations to be performed as a single unit but which may contain multiple batched, create, update or delete operations that involve more than one destination, that is, more than one remote adapter. Clients send a multi-batch when DataService.commit() is invoked and there are associations configured for that destination. Messages in this batch will be sent to multiple destinations.

PAGE_ITEMS_OPERATION constant
public static const PAGE_ITEMS_OPERATION:uint = 20

This operation indicates a request for a page of items specified by identities. This is operation is similar to a PAGE_OPERATION except the page index is not needed. Clients send this operation when fetching lazily loaded items for associations configured using one-to-many and many-to-many.

PAGE_OPERATION constant
public static const PAGE_OPERATION:uint = 8

This operation is used to retrieve a page of sequenced content that is delivered across several messages instead of in a single message. It represents a request for a portion of a remote sequence. Clients send this operation when an item or property is requested that is not resident locally. This operation is only performed if either the <paging> tag under <network> tag has its enabled attribute set to true with a non-zero pageSize attribute or if an association is configured with the lazy attribute set to true.

RELEASE_COLLECTION_OPERATION constant
public static const RELEASE_COLLECTION_OPERATION:uint = 18

This operation indicates that the client is no longer interested in receiving notificaion of operations performed on the specified collection. Clients send this operation when DataService.releaseCollection() is invoked or if DataService.fill() is invoked with an ArrayCollection which was previously filled with different parameters or if a one-to-many association's owning item is released.

See also

mx.data.DataService.releaseCollection()
mx.data.DataService.release()
mx.data.DataService.releaseItem()
RELEASE_ITEM_OPERATION constant
public static const RELEASE_ITEM_OPERATION:uint = 19

This operation indicates that the client is no longer interested in receiving notification of operations performed on the specified item. Clients send this operation when DataService.releaseItem() or ItemReference.releaseItem() is invoked.

See also

mx.data.DataService.releaseItem()
mx.data.ItemReference.releaseItem()
TRANSACTED_OPERATION constant
public static const TRANSACTED_OPERATION:uint = 7

This operation is similar to the MULTI_BATCH_OPERATION with the addition that the server should encapsulate the multiple batches of messages within a transacation. This operation is only performed when the remote destination has the <use-transactions> tag under the <properties> tag within the destination configuration xml set with a value of true

UNKNOWN_OPERATION constant
public static const UNKNOWN_OPERATION:uint = 1000

Code for an unknown operation type.

UPDATE_BODY_CHANGES constant
public static const UPDATE_BODY_CHANGES:uint = 0

This constant is used to access the list of changed property names. Use this property with bracket notation on the body property of a message with an operation of UPDATE_OPERATION.

See also

UPDATE_OPERATION

Example
         var msg:DataMessage = DataMessage(event.message);
         if (msg.operation == DataMessage.UPDATE_OPERATION)
         {
            // look at each change and display the old and new values
            var propertyNames:Array = msg.body[DataMessage.UPDATE_BODY_CHANGES];
            var newValues:Object = msg.body[DataMessage.UPDATE_BODY_NEW];
            var oldValues:Object = msg.body[DataMessage.UPDATE_BODY_PREV];
            var propertyName:String;
            for (var i:int=0; i<propertyNames.length; i++)
            {
                propertyName = propertyNames[i];
                trace("Property '"+ propertyName + "' was changed from '" +
                      oldValues[propertyName] + "' to '"+ newValues[propertyName] +
                      "'.");
            }
         }

UPDATE_BODY_NEW constant
public static const UPDATE_BODY_NEW:uint = 2

This constant is used to access the new value of a changed item. Use this property with bracket notation on the body property of a message with an operation of UPDATE_OPERATION.

See also

UPDATE_OPERATION

Example
         var msg:DataMessage = DataMessage(event.message);
         if (msg.operation == DataMessage.UPDATE_OPERATION)
         {
            // look at each change and display the old and new values
            var propertyNames:Array = msg.body[DataMessage.UPDATE_BODY_CHANGES];
            var newValues:Object = msg.body[DataMessage.UPDATE_BODY_NEW];
            var oldValues:Object = msg.body[DataMessage.UPDATE_BODY_PREV];
            var propertyName:String;
            for (var i:int=0; i<propertyNames.length; i++)
            {
                propertyName = propertyNames[i];
                trace("Property '"+ propertyName + "' was changed from '" +
                      oldValues[propertyName] + "' to '"+ newValues[propertyName] +
                      "'.");
            }
         }

UPDATE_BODY_PREV constant
public static const UPDATE_BODY_PREV:uint = 1

This constant is used to access the previous value of the changed item. Use this property with bracket notation on the body property of a message with an operation of UPDATE_OPERATION.

See also

UPDATE_OPERATION

Example
         var msg:DataMessage = DataMessage(event.message);
         if (msg.operation == DataMessage.UPDATE_OPERATION)
         {
            // look at each change and display the old and new values
            var propertyNames:Array = msg.body[DataMessage.UPDATE_BODY_CHANGES];
            var newValues:Object = msg.body[DataMessage.UPDATE_BODY_NEW];
            var oldValues:Object = msg.body[DataMessage.UPDATE_BODY_PREV];
            var propertyName:String;
            for (var i:int=0; i<propertyNames.length; i++)
            {
                propertyName = propertyNames[i];
                trace("Property '"+ propertyName + "' was changed from '" +
                      oldValues[propertyName] + "' to '"+ newValues[propertyName] +
                      "'.");
            }
         }

UPDATE_COLLECTION_OPERATION constant
public static const UPDATE_COLLECTION_OPERATION:uint = 17

This operation is sent when a local or remote sequence has been modified by insert(s) or delete(s). This operation provides information about the locations of all insert(s) and delete(s) such that the state of the collection order can be restored. The body contains an Array of UpdateCollectionRanges indicating what items have been removed and added. Applying the update collection ranges inorder will establish a consistent ordering of the items within the specified collection.

UPDATE_OPERATION constant
public static const UPDATE_OPERATION:uint = 3

This operation indicates an update to data object has been performed. Clients will receive and send this operation when an item has been updated. The body property of the message is an Array containing specific information about the update that occured. The DataMessage.UPDATE_BODY_CHANGES location within the array contains an array of property names that were changed during the update. The DataMessage.UPDATE_BODY_NEW location within the array contains the object in its new modified state. The DataMessage.UPDATE_BODY_PREV location within the array contains the object in its state prior to the updates.

Example
         var msg:DataMessage = DataMessage(event.message);
         if (msg.operation == DataMessage.UPDATE_OPERATION)
         {
            // look at each change and display the old and new values
            var propertyNames:Array = msg.body[DataMessage.UPDATE_BODY_CHANGES];
            var newValues:Object = msg.body[DataMessage.UPDATE_BODY_NEW];
            var oldValues:Object = msg.body[DataMessage.UPDATE_BODY_PREV];
            var propertyName:String;
            for (var i:int=0; i<propertyNames.length; i++)
            {
                propertyName = propertyNames[i];
                trace("Property '"+ propertyName + "' was changed from '" +
                      oldValues[propertyName] + "' to '"+ newValues[propertyName] +
                      "'.");
            }
         }


mx.data.messages.PagedMessage (Flex™ 2 Language Reference)

Class PagedMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.messages
Class | public class PagedMessage
Inheritance | PagedMessage Inheritance SequencedMessage Inheritance AcknowledgeMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object

This messsage provides information about a partial sequence result. When paging is enabled for a destination and DataService.fill() or a page request is made the remote destination will return this message as a response. The body property is an Array containing the items for the requested page with a length of the configured page size.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
 | pageCount : int Provides access to the number of total pages in a sequence based on the current page size. | PagedMessage
 | pageIndex : int Provides access to the index of the current page in a sequence. | PagedMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | sequenceId : int Provides access to the sequence id for this message. | SequencedMessage
Inherited | sequenceSize : int Provides access to the sequence size for this message. | SequencedMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | PagedMessage() Creates a new instance of an empty PagedMessage. | PagedMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | ERROR_HINT_HEADER : String = "DSErrorHint" [static] Header name for the error hint header. | AcknowledgeMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Property detail
pageCount property
public var pageCount:int

Provides access to the number of total pages in a sequence based on the current page size.

pageIndex property
public var pageIndex:int

Provides access to the index of the current page in a sequence.

Constructor detail
PagedMessage () constructor
public function PagedMessage()

Creates a new instance of an empty PagedMessage.


mx.data.messages.SequencedMessage (Flex™ 2 Language Reference)

Class SequencedMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.messages
Class | public class SequencedMessage
Inheritance | SequencedMessage Inheritance AcknowledgeMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object
Subclasses | PagedMessage

Clients receive this message in response to DataService.fill() request. The body of the message is an Array of items that were returned from the remote destination based on the fill parameters.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | sequenceId : int Provides access to the sequence id for this message. | SequencedMessage
 | sequenceSize : int Provides access to the sequence size for this message. | SequencedMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SequencedMessage() Creates a new instance of an empty SequencedMessage. | SequencedMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | ERROR_HINT_HEADER : String = "DSErrorHint" [static] Header name for the error hint header. | AcknowledgeMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Property detail
sequenceId property
public var sequenceId:int

Provides access to the sequence id for this message. The sequence id is a unique identifier for a sequence within a remote destination. This value is only unique for the endpoint and destination contacted.

sequenceSize property
public var sequenceSize:int

Provides access to the sequence size for this message. The sequence size indicates how many items reside in the remote sequence.

Constructor detail
SequencedMessage () constructor
public function SequencedMessage()

Creates a new instance of an empty SequencedMessage.


mx.data.messages.UpdateCollectionMessage (Flex™ 2 Language Reference)

Class UpdateCollectionMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.messages
Class | public class UpdateCollectionMessage
Inheritance | UpdateCollectionMessage Inheritance DataMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object

This message is used to establish consistency between the remote sequence and the corresponding local collection. It contains all insert and delete operations that were performed on a collection. Clients send this message when a local collection is updated using the collection API (IListView.removeItemAt(), etc) or the Single Managed Object API (DataService.createItem()). The remote destination sends this message when the remote sequence is updated and items are moved or removed and inserted. This body property contains a list of UpdateCollectionRange objects that indicate just how the collection was modified. Applying the update collection ranges inorder will establish a consistent ordering of the items within the specified collection.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
 | collectionId : Object The unique identifier for the collection that was updated. | UpdateCollectionMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | identity : Object Provides access to the identity map which defines the unique identity of the item affected by this DataMessage (relevant for create/update/delete but not fill operations). | DataMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
Inherited | operation : uint Provides access to the operation/command of this DataMessage. | DataMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | replace : Boolean Indicates if the entire collection should be replaced by the contents of this message. | UpdateCollectionMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
 | updateMode : int Indicates the state of this update. | UpdateCollectionMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | UpdateCollectionMessage() Creates a new instance of an empty UpdateCollectionMessage. | UpdateCollectionMessage
Inherited | getOperationAsString(op:uint):String [static] Provides a description of the operation specified. | DataMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isCreate():Boolean Returns true if this is a create operation. | DataMessage
Inherited | isEmptyUpdate():Boolean Returns true if this message is both an update and its list of property names has a length of zero. | DataMessage
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ASSOCIATION_ADD_OPERATION : uint = 13 [static] This operation requests the remote destination add a new association between the specified instances. | DataMessage
Inherited | ASSOCIATION_REMOVE_OPERATION : uint = 14 [static] This operation requests the remote destination remove an association between the specified instances. | DataMessage
Inherited | BATCHED_OPERATION : uint = 5 [static] This operation represents a set of batched operations to be performed as a single unit. | DataMessage
 | CLIENT_UPDATE : int = 0 [static] Indicates this update collection message was client generated. | UpdateCollectionMessage
Inherited | COUNT_OPERATION : uint = 9 [static] This operation requests that a configured <count-method> be invoked on a remote destination. | DataMessage
Inherited | CREATE_AND_SEQUENCE_OPERATION : uint = 11 [static] This operation requests a create of the specified item from a remote destination. | DataMessage
Inherited | CREATE_OPERATION : uint = 0 [static] Indicates a create operation. | DataMessage
Inherited | DELETE_OPERATION : uint = 4 [static] This operation indicates that the specified item should be removed. | DataMessage
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | FILL_OPERATION : uint = 1 [static] This operation requests that the remote destination create a sequence using the remote destination's adapter. | DataMessage
Inherited | GET_OPERATION : uint = 2 [static] This operation requests that the remote destination get a specific managed object based on its unique ID. | DataMessage
Inherited | GET_OR_CREATE_OPERATION : uint = 10 [static] This operation requests an item with the specified identity from the remote destination. | DataMessage
Inherited | GET_SEQUENCE_ID_OPERATION : uint = 12 [static] This operation requests a sequence id for a set of fill parameters. | DataMessage
Inherited | MULTI_BATCH_OPERATION : uint = 6 [static] This operation represents a set of operations to be performed as a single unit but which may contain multiple batched, create, update or delete operations that involve more than one destination, that is, more than one remote adapter. | DataMessage
Inherited | PAGE_ITEMS_OPERATION : uint = 20 [static] This operation indicates a request for a page of items specified by identities. | DataMessage
Inherited | PAGE_OPERATION : uint = 8 [static] This operation is used to retrieve a page of sequenced content that is delivered across several messages instead of in a single message. | DataMessage
Inherited | RELEASE_COLLECTION_OPERATION : uint = 18 [static] This operation indicates that the client is no longer interested in receiving notificaion of operations performed on the specified collection. | DataMessage
Inherited | RELEASE_ITEM_OPERATION : uint = 19 [static] This operation indicates that the client is no longer interested in receiving notification of operations performed on the specified item. | DataMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
 | SERVER_OVERRIDE : int = 2 [static] Indicates this update collection message was client generated and the remote destination determined that it should be reverted on that client. | UpdateCollectionMessage
 | SERVER_UPDATE : int = 1 [static] Indicates this update collection message was remotely generated and is based on the current state of the remote sequence. | UpdateCollectionMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Inherited | TRANSACTED_OPERATION : uint = 7 [static] This operation is similar to the MULTI_BATCH_OPERATION with the addition that the server should encapsulate the multiple batches of messages within a transacation. | DataMessage
Inherited | UNKNOWN_OPERATION : uint = 1000 [static] Code for an unknown operation type. | DataMessage
Inherited | UPDATE_BODY_CHANGES : uint = 0 [static] This constant is used to access the list of changed property names. | DataMessage
Inherited | UPDATE_BODY_NEW : uint = 2 [static] This constant is used to access the new value of a changed item. | DataMessage
Inherited | UPDATE_BODY_PREV : uint = 1 [static] This constant is used to access the previous value of the changed item. | DataMessage
Inherited | UPDATE_COLLECTION_OPERATION : uint = 17 [static] This operation is sent when a local or remote sequence has been modified by insert(s) or delete(s). | DataMessage
Inherited | UPDATE_OPERATION : uint = 3 [static] This operation indicates an update to data object has been performed. | DataMessage
Property detail
collectionId property
public var collectionId:Object

The unique identifier for the collection that was updated. For a collection filled with the DataService.fill() method this contains and Array of the parameters specified.

replace property
public var replace:Boolean

Indicates if the entire collection should be replaced by the contents of this message. When the number of changes to a remote sequence have reached a tipping point a replace message is generated as an optimization. When true the body property contains an Array of item identities that should replace any existing items.

updateMode property
public var updateMode:int

Indicates the state of this update. The remote destination sends update collection messages to clients with one of three update modes:

  • UpdateCollectionMessage.SERVER_UPDATE - client applies this update collection unconditionally
  • UpdateCollectionMessage.CLIENT_UPDATE - the committing client does not need to process this update collection.
  • UpdateCollectionMessage.SERVER_OVERRIDEN - the remote destination modified the update collection message sent by the client and the committing client must revert this update collection.

Constructor detail
UpdateCollectionMessage () constructor
public function UpdateCollectionMessage()

Creates a new instance of an empty UpdateCollectionMessage.

Constant detail
CLIENT_UPDATE constant
public static const CLIENT_UPDATE:int = 0

Indicates this update collection message was client generated.

See also

mx.data.messages.UpdateCollectionMessage.updateMode
SERVER_OVERRIDE constant
public static const SERVER_OVERRIDE:int = 2

Indicates this update collection message was client generated and the remote destination determined that it should be reverted on that client. A subsequent update collection message will follow containing the correct values to apply getting the client collection back to a consistent state with the remote one.

See also

mx.data.messages.UpdateCollectionMessage.updateMode
SERVER_UPDATE constant
public static const SERVER_UPDATE:int = 1

Indicates this update collection message was remotely generated and is based on the current state of the remote sequence.

See also

mx.data.messages.UpdateCollectionMessage.updateMode


mx.data.mxml Summary (Flex™ 2 Language Reference)

Package mx.data.mxml | Classes
(Adobe® Flex™ Data Services 2 only)

Classes
Class | Description
DataService | The DataService class provides the top-level functionality for distributed data in Flex 2.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.data.mxml.DataService (Flex™ 2 Language Reference)

Class DataService | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.mxml
Class | public class DataService
Inheritance | DataService Inheritance DataService Inheritance Object
Implements | IMXMLObject

The DataService class provides the top-level functionality for distributed data in Flex 2. This is an MXML-specific subclass of mx.data.DataService that allows binding to the properties of a DataService.

Note: The destination property must be set before using a DataService object.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:DataService> tag accepts the following tag attributes:

  <mx:DataService
   Properties
   autoCommit="true"
   autoSyncEnabled="true"
   autoMerge="true"
   conflictDetector="No default."
   dataStore="No default."
   destination="No default."
   pageSize="No default."
   id="No default."

   Events
   conflict="No default."
   fault="No default."
   message="No default."
   propertyChange="No default."
   result="No default."
 />

See also

mx.data.DataService
mx.data.Conflicts
mx.data.Conflict
mx.data.ItemReference
mx.data.IManaged
mx.data.utils.Managed
mx.data.IChangeObject

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | autoCommit : Boolean Indicates if changes to the buffer are automatically committed. | DataService
 | autoMerge : Boolean If set to false, when changes are pushed from the remote destination to the client they are not immediately applied. | DataService
Inherited | autoSyncEnabled : Boolean When true, fill(), createItem() and getItem() requests return items which listen for updates made to these items from the remote destination. | DataService
 | commitRequired : Boolean [read-only] Indicates if there are changes that have not been committed and the commit() method should be called. | DataService
 | conflictDetector : ConflictDetector [write-only] Provides access to the current implementation being used to detect conflicts for remote operations pushed to this DataService. | DataService
 | conflicts : Conflicts [read-only] Returns the Conflicts object, an ArrayList of Conflict instances. | DataService
Inherited | connected : Boolean Indicates if the DataService is connected to the remote destination. | DataService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dataStore : DataStore Returns an object of type mx.data.DataStore. | DataService
 | destination : String Indicates which remote destination this service is associated with. | DataService
 | mergeRequired : Boolean [read-only] Indicates if there are any pending changes that must be merged. | DataService
 | pageSize : int Provides access to the current page size setting for all collections. | DataService
 | pagingEnabled : Boolean [read-only] Indicates if the remote desintation is configured to allow paged requests. | DataService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | requestTimeout : int Provides access to the request timeout in seconds for an operation. | DataService
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataService(dest:String = null) Constructs an instance of the DataService with the specified destination. | DataService
 | commit():AsyncToken Commits any pending changes for all collections currently managed by this service. | DataService
 | count(... args):AsyncToken Calls a count method on the remote destination. | DataService
 | createItem(item:Object):ItemReference Requests that the specified item be created in the remote store. | DataService
 | deleteItem(item:Object):AsyncToken Requests that the specified item be deleted from the remote store. | DataService
 | disconnect():void Disconnects the DataService's network connection. | DataService
 | fill(value:ListCollectionView, ... args):AsyncToken Fills the specified ListCollectionView based on the associated <fill-method> elements. | DataService
 | getItem(identity:Object, defaultValue:Object = null):ItemReference Makes an asynchronous request for an item matching the specified identity. | DataService
 | getPendingOperation(item:IManaged):uint Returns the pending operation in the message cache for the specified item. | DataService
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | logout():void Logs the user out of the destination for the DataService. | DataService
 | merge():void Merges any pending updates into the managed set of objects. | DataService
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | release():void Releases all managed collections and items for the DataService. | DataService
 | releaseCollection(view:ListCollectionView, clear:Boolean = false):void Releases any item within the specified collection from management by this service. | DataService
 | releaseItem(item:IManaged, allowCopy:Boolean = true):IManaged Releases the specified item from management by this service. | DataService
 | revertChanges(item:IManaged = null):Boolean Reverts any uncommitted changes to the specified item. | DataService
 | setCredentials(username:String, password:String):void Sets the credentials for this DataService destination. | DataService
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setRemoteCredentials(username:String, password:String):void Sets the credentials for the third party of this DataService destination. | DataService
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | conflict | The DataConflictEvent.CONFLICT event is dispatched when a conflict is detected between either pending local changes and changes submitted by another client, or when changes submitted by this client are conflicting with those in the remote destination. | DataService
Inherited | fault | The DataServiceFaultEvent.FAULT event is dispatched when a service call fails due to an error. | DataService
Inherited | message | The MessageEvent.MESSAGE event is dispatched when the remote destination pushes a notification of a data operation. | DataService
Inherited | propertyChange | The PropertyChangeEvent.PROPERTY_CHANGE event is dispatched when a property of this service changes. | DataService
Inherited | result | The ResultEvent.RESULT event is dispatched when a service call successfully returns. | DataService
Property detail
autoCommit property
autoCommit:Boolean [read-write]

Indicates if changes to the buffer are automatically committed. Committed changes are sent to the remote service immediately.

Implementation
    public function get autoCommit():Boolean
    public function set autoCommit(value:Boolean):void
autoMerge property
autoMerge:Boolean [read-write]

If set to false, when changes are pushed from the remote destination to the client they are not immediately applied. Instead, the mergeRequired property is set to true. An event handler can be registered to listen for change events on this property to be notified of when a merge needs to be applied. To merge changes, call the merge() method and all changes are applied. Uncommited changes can not be committed when there are any changes that need to be merged. If paging is enabled all requests for non local items are cached until merge() is called. Once merge() is called, the cached requests are processed.

Implementation
    public function get autoMerge():Boolean
    public function set autoMerge(value:Boolean):void
commitRequired property
commitRequired:Boolean [read-only]

Indicates if there are changes that have not been committed and the commit() method should be called. When this property changes, an event is dispatched. This property can be used within an application to provide visual feedback.

This property can be used as the source for data binding.

Implementation
    public function get commitRequired():Boolean
conflictDetector property
conflictDetector:ConflictDetector [write-only]

Provides access to the current implementation being used to detect conflicts for remote operations pushed to this DataService.

Implementation
    public function set conflictDetector(value:ConflictDetector):void
conflicts property
conflicts:Conflicts [read-only]

Returns the Conflicts object, an ArrayList of Conflict instances. Conflicts must be resolved before commit() can be called. Conflicts can be resolved by going through the conflicts, resolving each conflict individually or by calling the acceptAllClient() method or acceptAllServer() method on this property.

Implementation
    public function get conflicts():Conflicts
dataStore property
dataStore:DataStore [read-write]

Returns an object of type mx.data.DataStore. The DataStore manages the set of incoming and outgoing changes for one or more DataServices, which may have references between them. When you commit on a DataStore, all of the pending changes of each DataService using that DataStore are committed. By default, a DataService shares the same DataStore with other DataServices if they have managed association properties and share the same set of channels. If you are sharing DataStores, a commit call on one DataService commits changes for all DataServices using that data store. This preserves the order of operations in case there are dependencies between the changes in your uncommitted batches.

This property can be used as the source for data binding.

Implementation
    public function get dataStore():DataStore
    public function set dataStore(value:DataStore):void
destination property
destination:String [read-write]

Indicates which remote destination this service is associated with.

Implementation
    public function get destination():String
    public function set destination(value:String):void
mergeRequired property
mergeRequired:Boolean [read-only]

Indicates if there are any pending changes that must be merged.

This property can be used as the source for data binding.

Implementation
    public function get mergeRequired():Boolean
pageSize property
pageSize:int [read-write]

Provides access to the current page size setting for all collections.

Implementation
    public function get pageSize():int
    public function set pageSize(value:int):void
pagingEnabled property
pagingEnabled:Boolean [read-only]

Indicates if the remote desintation is configured to allow paged requests.

Implementation
    public function get pagingEnabled():Boolean
requestTimeout property
requestTimeout:int [read-write]

Provides access to the request timeout in seconds for an operation. A value less than or equal to zero prevents request timeout. When a current operation times out due to the requestTimeout limit being reached a fault will be dispatched for that operation, indicating that the request was timed out.

Implementation
    public function get requestTimeout():int
    public function set requestTimeout(value:int):void
Constructor detail
DataService () constructor
public function DataService(dest:String = null)

Constructs an instance of the DataService with the specified destination. The destination must be a reference to a destination configured in the services-config.xml file.

Parameters
dest:String (default = null) — String that contains the name of the remote destination this service will connect to.
Method detail
commit () method
public override function commit():AsyncToken

Commits any pending changes for all collections currently managed by this service. When autoCommit property is true, transactions are not be used. To use transactions, set the autoCommit property to false and call this method directly.

Returns
AsyncToken — AsyncToken that will be returned in the call property of either the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
count () method
public override function count(... args):AsyncToken

Calls a count method on the remote destination. The count method called is based on the associated <count-method> tags and the parameters passed. For example, if the following count("firstName", "Bob") call was made and <count-method> tags exist or are referenced in the services-config.xml under the associated destination:

            <count-method>
                <name>getCount</name>
                <params>java.lang.String,java.lang.String</params>
                <security-run-as name="freddie" password="nightmare" />
            </count-method>

            <count-method>
                <name>getCount</name>
                <security-constraint ref="sample-users" />
            </count-method>
The first <count-method> with the run-as security setting is invoked because it contains two parameters, which matches the <params> tag types and count.

Parameters
... args — List of arguments that should be passed to the remote destination.

Returns
AsyncToken — Object returned in the call property of the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
createItem () method
public override function createItem(item:Object):ItemReference

Requests that the specified item be created in the remote store. If an error occurs a DataConflictEvent is dispatched.

Parameters
item:Object — that should be created in the remote store.

Returns
ItemReference — ItemReference (which extends AsyncToken). This reference is returned in the token property of either the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase. The result property of this object is bindable and can be used to bind the item returned. This result object is set to null if the item is removed from another client. If you hold on to ItemReference objects in your application, you should call the releaseItem() method in the ItemReference when you are finished with this reference to the item. If you do not hold onto the ItemReferences, you can use the releaseItem() method on the DataService, which takes the instance of the item itself to release.
deleteItem () method
public override function deleteItem(item:Object):AsyncToken

Requests that the specified item be deleted from the remote store. If an error occurs a DataConflictEvent will be dispatched.

Parameters
item:Object — that should be deleted in the remote store.

Returns
AsyncToken — AsyncToken that will be returned in the token property of either the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
disconnect () method
public override function disconnect():void

Disconnects the DataService's network connection. This method does not wait for outstanding network operations to complete.

fill () method
public override function fill(value:ListCollectionView, ... args):AsyncToken

Fills the specified ListCollectionView based on the associated <fill-method> elements. For example, if the following <fill-method> elements exist or are referenced in the services-config.xml under the associated destination:

            <fill-method>
                <name>loadPersons</name>
                <params>java.lang.String,java.lang.String</params>
                <security-run-as name="freddie" password="nightmare" />
            </fill-method>

            <fill-method>
                <name>loadPersons</name>
                <security-constraint ref="sample-users" />
            </fill-method>
Then calling fill(myCollection, ["firstName", "Bob"]) invokes the first <fill-method> with the run-as security setting since it contains two parameters, matching the <params> tag types and count. Likewise, calling fill(myCollection) invokes the second <fill-method> tag as it contains no <params> tag. Any pending changes or data is cleared during a call to fill.

Parameters
value:ListCollectionView — to the collection that should be filled with the specified arguments.
... args — rest:Array variable list of arguments that should be passed to the remote destination.

Returns
AsyncToken — Object that is returned in the call property of the ResultEvent.RESULT or in the FaultEvent.FAULT. Custom data can be attached to this object and inspected later during the event handling phase.
getItem () method
public override function getItem(identity:Object, defaultValue:Object = null):ItemReference

Makes an asynchronous request for an item matching the specified identity. If you provide a defaultValue, and the item does not exist, the item is created instead using the information in the defaultValue. This method returns an ItemReference. If you receive a valid instance from the getItem() method call, you must call the releaseItem() method to release an instance of the item. If you hang onto the ItemReference, you should call the releaseItem() method on the reference to be sure you release the proper reference (in case your client has made more than one getItem() method call for the same item). If you do not hold onto the ItemReference, you can call the releaseItem() method on the DataService with the item itself.

Parameters
identity:Object — Object that contains the identity properties for the desired object.
defaultValue:Object (default = null) — An instance of the type with the default values that should be created if it doesn't exist.

Returns
ItemReference — ItemReference to the item you want to get. The ItemReference extends AsyncToken so you can use it to receive notification of when the item has been retrieved or when this call produces a fault. The ItemReference is returned as the token property in either the ResultEvent.RESULT or in the FaultEvent.FAULT if you are listening for events on the DataService object. Custom data can be attached to this object and inspected later during the event handling phase. You also can use data binding to bind to the result property of the ItemReference. This property is set to a valid value when the item is populated from the remote destination and is bindable so you can simply bind your user interface controls to the properties of the ItemReference's result property. If the item is removed from the server or another client, this reference is set to null. The ItemReference also has an invalid property which is set to true if the are errors returning the item or if the server returns null for an item.
getPendingOperation () method
public override function getPendingOperation(item:IManaged):uint

Returns the pending operation in the message cache for the specified item. Use this method to provide visual feedback to a user of what type of change, if any, has been made to an item.

Parameters
item:IManaged — that should be tested against.

Returns
uint — uint that indicates what pending operation has been performed. The following are valid operations for an item:
  • DataMessage.CREATE_OPERATION - indicates that a create is pending for the specified item.
  • DataMessage.DELETE_OPERATION - indicates that a delete is pending for the specified item.
  • DataMessage.UPDATE_OPERATION - indicates that updates are pending for the specified item.
  • DataMessage.UNKNOWN_OPERATION - indicates that no operations are pending for the specified item.
logout () method
public override function logout():void

Logs the user out of the destination for the DataService. Logging out of a destination applies to everything connected using the same ChannelSet as specified in the server configuration. For example, if you are connected over the my-rtmp channel and you log out using one of your DataService instances, anything that was connected over the same ChannelSet is logged out.

merge () method
public override function merge():void

Merges any pending updates into the managed set of objects. The process of merging changes detect conflicts and process any pending item requests. This merges all messages for any other DataService instances that share this same data store.

release () method
public override function release():void

Releases all managed collections and items for the DataService.

releaseCollection () method
public override function releaseCollection(view:ListCollectionView, clear:Boolean = false):void

Releases any item within the specified collection from management by this service. If the item exists in more than one collection, a copy of the item is made. Any uncommitted changes made to an item that exists only in this collection are released, including deletes, creates and updates.

Parameters
view:ListCollectionView — ListCollectionView reference that should no longer receive remote updates.
clear:Boolean (default = false) — Boolean indicating if the all items should be removed from the list. In addition no copies will be made of any item.
releaseItem () method
public override function releaseItem(item:IManaged, allowCopy:Boolean = true):IManaged

Releases the specified item from management by this service. If you hold onto ItemReferences, you should call the releaseItem() method on the ItemReference to be sure you release the proper reference in the case where you might have made more than one getItem call which retrieves the same item from different parts of your client application.

This call releases any associated resources, including nested properties. The specified item no longer receives updates from the remote destination. In addition if there are any uncommited changes to this item and it does not appear in any other collection these changes will also be released. If the specified item exists in more than one collection then the value handed back will be a copy of the original unless the allowCopy parameter is set to false.

Parameters
item:IManaged — IManaged reference to the item to be released.
allowCopy:Boolean (default = true) — Optional parameter that defaults to true. If true, makes a copy of the item if it is still referenced by another managed reference. You can set this to false but it would mean that object might still get updates from the server if it is still managed through other references.

Returns
IManaged — the released item which will be a copy if allowCopy=false and the item is managed by another reference.
revertChanges () method
public override function revertChanges(item:IManaged = null):Boolean

Reverts any uncommitted changes to the specified item. Or if no item is suppied, it will revert all uncommitted changes. If you revert a create operation, it removes the item. If you revert a delete, it adds the item back in. Reverting an update restores the original properties of the item that were in place before you started changing it.

One situation in which you would use this method is after a fault has occurred. In that case, any failed changes are put back into the uncommitted changes list. At that point you can either modify those changes to fix the problem or revert them using this method to keep those changes from being resubmitted again.

If an item is supplied and this item doesn't have any changes this method will return false. If no item is supplied and there are no changes this method returns false. Otherwise, it returns true.

Parameters
item:IManaged (default = null) — reference to revert changes for or null to revert all changes.

Returns
Boolean — Boolean indicating if any changes were reverted.
setCredentials () method
public override function setCredentials(username:String, password:String):void

Sets the credentials for this DataService destination. The credentials are applied to all services connected over the same ChannelSet.

Parameters
username:String — username for the destination.
password:String — The password for the destination
setRemoteCredentials () method
public override function setRemoteCredentials(username:String, password:String):void

Sets the credentials for the third party of this DataService destination.

Parameters
username:String — The username for the destination.
password:String — The password for the destination.


mx.data.utils Summary (Flex™ 2 Language Reference)

Package mx.data.utils | Classes
(Adobe® Flex™ Data Services 2 only)

Classes
Class | Description
Managed | Provides utility methods for DataService managed objects.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.data.utils.Managed (Flex™ 2 Language Reference)

Class Managed | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.data.utils
Class | public class Managed
Inheritance | Managed Inheritance Object

Provides utility methods for DataService managed objects. These methods make developing compliant managed objects simpler. This class is also used by the code generated by the MXML compiler when using the [Managed] class metadata tag.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | createUpdateEvent(obj:IManaged, property:Object, event:PropertyChangeEvent):PropertyChangeEvent [static] | Managed
 | getDestination(obj:Object):String [static] Returns the destination the specified object is associated with. | Managed
 | getProperty(obj:IManaged, property:String, value:*):* [static] This method is used to retreive the a property from a managed object. | Managed
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | setProperty(obj:IManaged, property:Object, oldValue:*, newValue:*):void [static] This method is used to set the property of a managed object. | Managed
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
createUpdateEvent () method
public static function createUpdateEvent(obj:IManaged, property:Object, event:PropertyChangeEvent):PropertyChangeEvent Parameters
obj:IManaged
property:Object
event:PropertyChangeEvent

Returns
PropertyChangeEvent
getDestination () method
public static function getDestination(obj:Object):String

Returns the destination the specified object is associated with.

Parameters
obj:Object — Object reference to the item to get the destination from.

Returns
String
getProperty () method
public static function getProperty(obj:IManaged, property:String, value:*):*

This method is used to retreive the a property from a managed object. In addition to returning the vlaue of the property specified this method will handle keeping related artifacts in sync to support both deeply nested event dispatching and lazy loaded properties.

Parameters
obj:IManaged — IManaged reference to the object on which the desired property should be retreived from.
property:String — String containing the name of the desired property.
value:* — any reference to the current value of the property.

Returns
* — the new normalized value of the property. This value should be assigned to the original reference.

See also

setProperty()

Example
   public class Customer implements IManaged
   {
      private var _addresses:ArrayCollection;
      public function get addresses():ArrayCollection
      {
          _addresses = Managed.getProperty(this, "addresses", _addresses);
      }

      public function set addresses(value:ArrayCollection):void
      {
          Managed.setProperty(this, "addresses", _addresses, _addresses = value);
      }
   }

setProperty () method
public static function setProperty(obj:IManaged, property:Object, oldValue:*, newValue:*):void

This method is used to set the property of a managed object. In addition to setting the vlaue of the property specified, this method will handle keeping related artifacts in sync and clean up any deeply nested event dispatching and lazy loaded properties.

Parameters
obj:IManaged — IManaged reference to the managed object that the property will be set on
property:Object — Object containing the name of the property that will be set. Typically this is a String value but can be a QName.
oldValue:* — reference to the previous value of the property.
newValue:* — reference to the new value of the property

See also

getProperty()

Example
   public class Customer implements IManaged
   {
      private var _addresses:ArrayCollection;
      public function get addresses():ArrayCollection
      {
          _addresses = Managed.getProperty(this, "addresses", _addresses);
      }

      public function set addresses(value:ArrayCollection):void
      {
          Managed.setProperty(this, "addresses", _addresses, _addresses = value);
      }
   }


mx.effects Summary (Flex™ 2 Language Reference)

Package mx.effects | Classes

The mx.effects package contains the classes to support behaviors.

Classes
Class | Description
AddChildAction | The AddChildAction class defines an action effect that corresponds to the AddChild property of a view state definition.
AnimateProperty | The AnimateProperty effect animates a property or style of a component.
Blur | The Blur effect lets you apply a blur visual effect to a component.
CompositeEffect | The CompositeEffect class is the parent class for the Parallel and Sequence classes, which define the <mx:Parallel> and <mx:Sequence> MXML tags.
Dissolve | Animate the component from transparent to opaque, or from opaque to transparent.
Effect | The Effect class is an abstract base class that defines the basic functionality of all Flex effects.
EffectInstance | The EffectInstance class represents an instance of an effect playing on a target.
EffectManager | The EffectManager class listens for events, such as the show and move events, dispatched by objects in a Flex application.
EffectTargetFilter | The EffectTargetFilter class defines a custom filter that is executed by each transition effect on each target of the effect.
Fade | The Fade effect animates the alpha property of a component, either from transparent to opaque, or from opaque to transparent.
Glow | The Glow effect lets you apply a visual glow effect to a component.
Iris | The Iris effect animates the effect target by expanding or contracting a rectangular mask centered on the target.
MaskEffect | The MaskEffect class is an abstract base class for all effects that animate a mask, such as the wipe effects and the Iris effect.
Move | The Move effect changes the position of a component over a specified time interval.
Parallel | The Parallel effect plays multiple child effects at the same time.
Pause | The Pause effect is useful when sequencing effects.
RemoveChildAction | The RemoveChildAction class defines an action effect that corresponds to the RemoveChild property of a view state definition.
Resize | The Resize effect changes the width, height, or both dimensions of a component over a specified time interval.
Rotate | The Rotate effect rotates a component around a specified point.
Sequence | The Sequence effect plays multiple child effects one after the other, in the order in which they are added.
SetPropertyAction | The SetPropertyAction class defines an action effect that corresponds to the SetProperty property of a view state definition.
SetStyleAction | The SetStyleAction class defines an action effect that corresponds to the SetStyle property of a view state definition.
SoundEffect | The SoundEffect class plays an MP3 audio file.
Tween | The Tween class defines a tween, a property animation performed on a target object over a period of time.
TweenEffect | The TweenEffect class is the superclass for all effects that are based on the Tween object.
WipeDown | The WipeDown class defines a bar wipe down effect.
WipeLeft | The WipeLeft class defines a bar wipe left effect.
WipeRight | The WipeRight class defines a bar wipe right effect.
WipeUp | The WipeUp class defines a bar wipe up effect.
Zoom | The Zoom effect zooms the object in or out on a center point.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.effects.AddChildAction (Flex™ 2 Language Reference)

Class AddChildAction | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class AddChildAction
Inheritance | AddChildAction Inheritance Effect Inheritance EventDispatcher Inheritance Object

The AddChildAction class defines an action effect that corresponds to the AddChild property of a view state definition. You use an AddChildAction effect within a transition definition to control when the view state change defined by an AddChild property occurs during the transition.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:AddChildAction> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:AddChildAction
    Properties
    id="ID"
    index="-1"
    relativeTo=""
    position="index"
  />

View the examples.

See also

mx.effects.effectClasses.AddChildActionInstance
mx.states.AddChild

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
 | index : int = -1 The index of the child within the parent. | AddChildAction
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | position : String = "index" The position of the child in the display list, relative to the object specified by the relativeTo property. | AddChildAction
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relativeTo : DisplayObjectContainer The location where the child component is added. | AddChildAction
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AddChildAction(target:Object = null)
Constructor.
AddChildAction
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Property detail
index property
public var index:int = -1

The index of the child within the parent. A value of -1 means add the child as the last child of the parent.

The default value is -1.

position property
public var position:String = "index"

The position of the child in the display list, relative to the object specified by the relativeTo property. Valid values are "before", "after", "firstChild", "lastChild", and "index", where "index" specifies to use the index property to determine the position of the child.

The default value is "index".

relativeTo property
public var relativeTo:DisplayObjectContainer

The location where the child component is added. By default, Flex determines this value from the AddChild property definition in the view state definition.

Constructor detail
AddChildAction () constructor
public function AddChildAction(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
TransitionExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the Transition class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <mx:transitions>
        <!-- Define the transition from the base state to the Register state.-->
        <mx:Transition id="toRegister" fromState="*" toState="Register">
            <mx:Sequence targets="{[loginPanel, registerLink, confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>

        <!-- Define the transition from the Register state to the base state.-->
        <mx:Transition id="toDefault" fromState="Register" toState="*">
            <mx:Sequence targets="{[loginPanel, registerLink,
                    confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction  target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>
    </mx:transitions>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.effects.AnimateProperty (Flex™ 2 Language Reference)

Class AnimateProperty | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class AnimateProperty
Inheritance | AnimateProperty Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The AnimateProperty effect animates a property or style of a component. You specify the property name, start value, and end value of the property to animate. The effect sets the property to the start value, and then updates the property value over the duration of the effect until it reaches the end value.

For example, to change the width of a Button control, you can specify width as the property to animate, and starting and ending width values to the effect.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:AnimateProperty> tag inherits all the tag attributes of its superclass and adds the following tag attributes:

  <mx:AnimateProperty
    id="ID"
   fromValue="0"
    isStyle="false|true"
    property="required"
    roundValue="false|true"
    toValue="0"
  />

View the examples.

See also

mx.effects.effectClasses.AnimatePropertyInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
 | fromValue : Number The starting value of the property for the effect. | AnimateProperty
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | isStyle : Boolean = false If true, the property attribute is a style and you set it by using the setStyle() method. | AnimateProperty
 | property : String The name of the property on the target to animate. | AnimateProperty
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
 | roundValue : Boolean = false If true, round off the interpolated tweened value to the nearest integer. | AnimateProperty
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | toValue : Number The ending value for the effect. | AnimateProperty
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AnimateProperty(target:Object = null)
Constructor.
AnimateProperty
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
fromValue property
public var fromValue:Number

The starting value of the property for the effect. The default value is the target's current property value.

isStyle property
public var isStyle:Boolean = false

If true, the property attribute is a style and you set it by using the setStyle() method.

The default value is false.

property property
public var property:String

The name of the property on the target to animate. This attribute is required.

roundValue property
public var roundValue:Boolean = false

If true, round off the interpolated tweened value to the nearest integer. This property is useful if the property you are animating is an int or uint.

The default value is false.

toValue property
public var toValue:Number

The ending value for the effect. The default value is the target's current property value.

Constructor detail
AnimateProperty () constructor
public function AnimateProperty(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
AnimatePropertyEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the AnimateProperty effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Sequence id="animateScaleXUpDown" >
        <mx:AnimateProperty property="scaleX" fromValue="1" toValue="1.5" duration="1000" />
        <mx:AnimateProperty property="scaleX" fromValue="1.5" toValue="1" duration="1000" />
    </mx:Sequence>

    <mx:Panel title="AnimateProperty Effect Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click on the image to use the AnimateProperty effect with the scaleX property."/>

        <mx:Image id="flex" source="@Embed(source='assets/Nokia_6630.png')"
            mouseDownEffect="{animateScaleXUpDown}"/>

    </mx:Panel>
</mx:Application>


mx.effects.Blur (Flex™ 2 Language Reference)

Class Blur | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Blur
Inheritance | Blur Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Blur effect lets you apply a blur visual effect to a component. A Blur effect softens the details of an image. You can produce blurs that range from a softly unfocused look to a Gaussian blur, a hazy appearance like viewing an image through semi-opaque glass.

The Blur effect uses the Flash BlurFilter class as part of its implementation. For more information, see flash.filters.BlurFilter.

If you apply a Blur effect to a component, you cannot apply a BlurFilter or a second Blur effect to the component.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Blur> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Blur
    id="ID"
    blurXFrom="val"
    blurXTo="val"
    blurYFrom="val"
    blurYTo="val"
  />

View the examples.

See also

flash.filters.BlurFilter
mx.effects.effectClasses.BlurInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | blurXFrom : Number The starting amount of horizontal blur. | Blur
 | blurXTo : Number The ending amount of horizontal blur. | Blur
 | blurYFrom : Number The starting amount of vertical blur. | Blur
 | blurYTo : Number The ending amount of vertical blur. | Blur
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Blur(target:Object = null)
Constructor.
Blur
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
blurXFrom property
public var blurXFrom:Number

The starting amount of horizontal blur. Valid values are from 0.0 to 255.0.

blurXTo property
public var blurXTo:Number

The ending amount of horizontal blur. Valid values are from 0.0 to 255.0.

blurYFrom property
public var blurYFrom:Number

The starting amount of vertical blur. Valid values are from 0.0 to 255.0.

blurYTo property
public var blurYTo:Number

The ending amount of vertical blur. Valid values are from 0.0 to 255.0.

Constructor detail
Blur () constructor
public function Blur(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
BlurEffectExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Blur effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Blur id="blurImage" duration="1000"
        blurXFrom="0.0" blurXTo="10.0"
        blurYFrom="0.0" blurYTo="10.0"/>
    <mx:Blur id="unblurImage" duration="1000"
        blurXFrom="10.0" blurXTo="0.0"
        blurYFrom="10.0" blurYTo="0.0"/>

    <mx:Panel title="Blur Effect Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click and hold the mouse on the image to see blurImage effect. Release the mouse to see the unblurImage effect."/>

        <mx:Image id="flex" source="@Embed(source='assets/Nokia_6630.png')"
            mouseDownEffect="{blurImage}"
            mouseUpEffect="{unblurImage}"/>

    </mx:Panel>
</mx:Application>


mx.effects.CompositeEffect (Flex™ 2 Language Reference)

Class CompositeEffect | Properties | Methods | Events
Package | mx.effects
Class | public class CompositeEffect
Inheritance | CompositeEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object
Subclasses | Parallel, Sequence

The CompositeEffect class is the parent class for the Parallel and Sequence classes, which define the <mx:Parallel> and <mx:Sequence> MXML tags. Flex supports two methods to combine, or composite, effects: parallel and sequence. When you combine multiple effects in parallel, the effects play at the same time. When you combine multiple effects in sequence, one effect must complete before the next effect starts.

You can create a composite effect in MXML, as the following example shows:

  <mx:Parallel id="WipeRightUp">
    <mx:children>
      <mx:WipeRight duration="1000"/>
      <mx:WipeUp duration="1000"/>
    </mx:children>
  </mx:Parallel>

  <mx:VBox id="myBox" hideEffect="WipeRightUp">
    <mx:TextArea id="aTextArea" text="hello"/>
  </mx:VBox>

The <mx:children> tag is optional.

Starting a composite effect in ActionScript is usually a five-step process:

  1. Create instances of the effect objects to be composited together; for example:
    myFadeEffect = new mx.effects.Fade(target);
  2. Set properties, such as duration, on the individual effect objects.
  3. Create an instance of the Parallel or Sequence effect object; for example:
    mySequenceEffect = new mx.effects.Sequence();
  4. Call the addChild() method for each of the effect objects; for example:
    mySequenceEffect.addChild(myFadeEffect);
  5. Invoke the composite effect's play() method; for example:
    mySequenceEffect.play();

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The CompositeEffect class adds the following tag attributes, and all the subclasses of the CompositeEffect class inherit these tag attributes:

  <mx:tagname>
    <mx:children>
      <!-- Specify child effect tags -->
    </mx:children>
  </mx:tagname>

Default MXML Property children

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | children : Array An Array containing the child effects of this CompositeEffect. | CompositeEffect
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CompositeEffect(target:Object = null)
Constructor.
CompositeEffect
addChild(childEffect:Effect):void
Adds a new child effect to this composite effect.
CompositeEffect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Property detail
children property
public var children:Array

An Array containing the child effects of this CompositeEffect.

Constructor detail
CompositeEffect () constructor
public function CompositeEffect(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — This argument is ignored for composite effects. It is included only for consistency with other types of effects.
Method detail
addChild () method
public function addChild(childEffect:Effect):void

Adds a new child effect to this composite effect. A Sequence effect plays each child effect one at a time, in the order that they were added. A Parallel effect plays all child effects simultaneously; the order in which they are added does not matter.

Parameters
childEffect:Effect — Child effect to be added to the composite effect.


mx.effects.Dissolve (Flex™ 2 Language Reference)

Class Dissolve | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Dissolve
Inheritance | Dissolve Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

Animate the component from transparent to opaque, or from opaque to transparent. When the Dissolve effect is played, it does the following:
  1. When the effect begins, it creates an opaque rectangle. The rectangle floats above the target component, its color matches the Dissolve.color property, and its alpha property is initially set to (1.0 - Dissolve.alphaFrom).
  2. As the effect plays, the alpha property of the rectangle animates from (1.0 - alphaFrom) to (1.0 - alphaTo). As the rectangle becomes more and more opaque, the content underneath it gradually disappears.
  3. When the effect finishes, the rectangle is destroyed.

When the target object is a Container, the Dissolve effect applies to the content area inside the container. The content area is the region where the container's background color is visible.

Note: To use the Dissolve effect with the creationCompleteEffect trigger of a DataGrid control, you must define the data provider of the control inline using a child tag of the DataGrid control, or using data binding. This issue is a result of the data provider not being set until the creationComplete event is dispatched. Therefore, when the effect starts playing, Flex has not completed the sizing of the DataGrid control.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Dissolve> tag inherits the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Dissolve
    id="ID"
    alphaFrom="val"
    alphaTo="val"
    color="val"
  />

View the examples.

See also

mx.effects.effectClasses.DissolveInstance
mx.effects.Tween
mx.effects.TweenEffect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphaFrom : Number Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | Dissolve
 | alphaTo : Number Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | Dissolve
Inherited | className : String The name of the effect class, such as "Fade". | Effect
 | color : uint = 0xFFFFFFFF Hex value that represents the color of the floating rectangle that the effect displays over the target object. | Dissolve
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
 | targetArea : RoundedRectangle The area of the target to play the effect upon. | Dissolve
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Dissolve(target:Object = null)
Constructor.
Dissolve
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
alphaFrom property
public var alphaFrom:Number

Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

If the effect causes the target component to disappear, the default value is the current value of the target's alpha property. If the effect causes the target component to appear, the default value is 0.0.

alphaTo property
public var alphaTo:Number

Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

If the effect causes the target component to disappear, the default value is 0.0. If the effect causes the target component to appear, the default value is the current value of the target's alpha property.

color property
public var color:uint = 0xFFFFFFFF

Hex value that represents the color of the floating rectangle that the effect displays over the target object. The default value is the color specified by the target component's backgroundColor style property, or 0xFFFFFF, if backgroundColor is not set.

targetArea property
public var targetArea:RoundedRectangle

The area of the target to play the effect upon. The dissolve overlay is drawn using this property's dimensions. UIComponents create an overlay over the entire component. Containers create an overlay over their content area, but not their chrome.

The default value is null.

Constructor detail
Dissolve () constructor
public function Dissolve(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
DissolveEffectExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Dissolve effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Dissolve id="dissolveOut" duration="1000" alphaFrom="1.0" alphaTo="0.0"/>
    <mx:Dissolve id="dissolveIn" duration="1000" alphaFrom="0.0" alphaTo="1.0"/>

    <mx:Panel title="Dissolve Effect Example"
        width="95%" height="95%" layout="horizontal"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:VBox height="100%">
            <mx:Label text="Nokia 9930"
                fontSize="14"
                visible="{cb1.selected}"
                hideEffect="{dissolveOut}" showEffect="{dissolveIn}"/>

            <mx:Image source="@Embed(source='assets/Nokia_6630.png')"
                visible="{cb1.selected}"
                hideEffect="{dissolveOut}" showEffect="{dissolveIn}"/>
        </mx:VBox>

        <mx:VBox height="100%" width="100%">
            <mx:Text width="100%" color="blue"
                text="Use the Dissolve effect to show or hide the text, image, and button. The Dissolve effect works with system and embedded fonts, unlike the Fade effect which requires embedded fonts."/>

                <mx:Spacer height="100%"/>

                <mx:Button label="Purchase"
                    visible="{cb1.selected}"
                    hideEffect="{dissolveOut}" showEffect="{dissolveIn}"/>
        </mx:VBox>

        <mx:ControlBar>
            <mx:CheckBox id="cb1" label="visible" selected="true"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.effects.Effect (Flex™ 2 Language Reference)

Class Effect | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Effect
Inheritance | Effect Inheritance EventDispatcher Inheritance Object
Subclasses | AddChildAction, CompositeEffect, MaskEffect, RemoveChildAction, SetPropertyAction, SetStyleAction, SoundEffect, TweenEffect

The Effect class is an abstract base class that defines the basic functionality of all Flex effects. The Effect class defines the base factory class for all effects. The EffectInstance class defines the base class for all effect instance subclasses.

You do not create an instance of the Effect class itself in an application. Instead, you create an instance of one of the subclasses, such as Fade or WipeLeft.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The Effect class defines the following properties, which all of its subclasses inherit:

  <mx:tagname
    Properties
    customFilter=""
    duration="500"
    filter=""
    repeatCount="1"
    repeatDelay="0"
    startDelay="0"
    suspendBackgroundProcessing="false|true"
    target="effect target"
    targets="array of effect targets"

    Events
    effectEnd="No default"
    efectStart="No default"
  />

View the examples.

See also

mx.effects.EffectInstance
About applying behaviors
Using effects with charts
Improving effect performance
Using effects with queued containers
About creating a custom effect
Example: Defining a simple effect
Example: Passing parameters to effects
Writing an effect for a transition
Defining a custom effect trigger

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | className : String [read-only] The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
 | duration : Number Duration of the effect in milliseconds. | Effect
 | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
 | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
 | isPlaying : Boolean [read-only] A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
 | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
 | repeatCount : int = 1 Number of times to repeat the effect. | Effect
 | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
 | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
 | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
 | target : Object The UIComponent object to which this effect is applied. | Effect
 | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Effect(target:Object = null)
Constructor.
Effect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
pause():void
Pauses the effect until you call the resume() method.
Effect
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
 | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
 | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
 | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
 | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
 | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Event |  | Summary | Defined by
 | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
 | effectStart | Dispatched when the effect starts playing. | Effect
Property detail
className property
className:String [read-only]

The name of the effect class, such as "Fade".

This is a short, or unqualified, class name that does not include the package name. If you need the qualified name, use the getQualifiedClassName() method in the flash.utils package.

Implementation
    public function get className():String
customFilter property
customFilter:EffectTargetFilter [read-write]

Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect.

Target filtering is only performed if you call the captureStartValues() method before playing the effect. Flex automatically calls the captureStartValues() method when the effect is part of a transition.

Use the filter property for simple filtering. If the customFilter property is non-null, the filter property is ignored.

The default value is null.

Implementation
    public function get customFilter():EffectTargetFilter
    public function set customFilter(value:EffectTargetFilter):void

See also

mx.effects.EffectTargetFilter
duration property
duration:Number [read-write]

Duration of the effect in milliseconds.

In a Parallel or Sequence effect, the duration property sets the duration of each effect. For example, if a Sequence effect has its duration property set to 3000, each effect in the Sequence takes 3000 ms to play.

For a repeated effect, the duration property specifies the duration of a single instance of the effect. Therefore, if an effect has a duration property set to 2000, and a repeatCount property set to 3, the effect takes a total of 6000 ms (6 seconds) to play.

The default value is 500.

Implementation
    public function get duration():Number
    public function set duration(value:Number):void
filter property
filter:String [read-write]

Specifies an algorithm for filtering targets for an effect. A value of null specifies no filtering.

Target filtering is only performed if you call the captureStartValues() method before playing the effect. Flex automatically calls the captureStartValues() method when the effect is part of a transition.

Use this property for simple filtering. Use the customFilter property for more complex filtering. If the customFilter property has a non-null value, this property is ignored.

You can use the following values for the filter property:

  • A value of "add" plays the effect on any targets that are added as a child to a container.
  • A value of "hide" plays the effect on any targets whose visible property changed from true to false.
  • A value of "move" plays the effect on any targets that changed their x or y properties.
  • A value of "remove" plays the effect on any targets that are removed as a child of a container.
  • A value of "resize" plays the effect on any targets that changed their width or height properties.
  • A value of "show" plays the effect on any targets whose visible property changed from false to true.
  • A value of "" specifies no filtering.

The default value is null.

Implementation
    public function get filter():String
    public function set filter(value:String):void
instanceClass property
public var instanceClass:Class

An object of type Class that specifies the effect instance class class for this effect class.

All subclasses of the Effect class must set this property in their constructor.

isPlaying property
isPlaying:Boolean [read-only]

A read-only flag which is true if any instances of the effect are currently playing, and false if none are.

Implementation
    public function get isPlaying():Boolean
relevantProperties property
relevantProperties:Array [read-write]

An Array of property names to use when performing filtering. This property is used internally and should not be set by effect users.

The default value is equal to the Array returned by the getAffectedProperties() method.

Implementation
    public function get relevantProperties():Array
    public function set relevantProperties(value:Array):void
relevantStyles property
relevantStyles:Array [read-write]

An Array of style names to use when performing filtering. This property is used internally and should not be set by effect users.

The default value is equal to the Array returned by the getAffectedProperties() method.

Implementation
    public function get relevantStyles():Array
    public function set relevantStyles(value:Array):void
repeatCount property
public var repeatCount:int = 1

Number of times to repeat the effect. Possible values are any integer greater than or equal to 0. A value of 1 means to play the effect once. A value of 0 means to play the effect indefinitely until stopped by a call to the end() method.

The default value is 1.

repeatDelay property
public var repeatDelay:int = 0

Amount of time, in milliseconds, to wait before repeating the effect. Possible values are any integer greater than or equal to 0.

The default value is 0.

startDelay property
public var startDelay:int = 0

Amount of time, in milliseconds, to wait before starting the effect. Possible values are any int greater than or equal to 0. If the effect is repeated by using the repeatCount property, the startDelay is only applied to the first time the effect is played.

The default value is 0.

suspendBackgroundProcessing property
public var suspendBackgroundProcessing:Boolean = false

If true, blocks all background processing while the effect is playing. Background processing includes measurement, layout, and processing responses that have arrived from the server. The default value is false.

You are encouraged to set this property to true in most cases, because it improves the performance of the application. However, the property should be set to false if either of the following is true:

  • User input may arrive while the effect is playing, and the application must respond to the user input before the effect finishes playing.
  • A response may arrive from the server while the effect is playing, and the application must process the response while the effect is still playing.

The default value is false.

target property
target:Object [read-write]

The UIComponent object to which this effect is applied. When an effect is triggered by an effect trigger, the target property is automatically set to be the object that triggers the effect.

Implementation
    public function get target():Object
    public function set target(value:Object):void
targets property
targets:Array [read-write]

An Array of UIComponent objects that are targets for the effect. When the effect is playing, it performs the effect on each target in parallel. Setting the target property replaces all objects in this Array. When the targets property is set, the target property returns the first item in this Array.

Implementation
    public function get targets():Array
    public function set targets(value:Array):void
Constructor detail
Effect () constructor
public function Effect(target:Object = null)

Constructor.

Starting an effect is usually a three-step process:

  • Create an instance of the effect object with the new operator.
  • Set properties on the effect object, such as duration.
  • Call the play() method or assign the effect to a trigger.
Parameters
target:Object (default = null) — The Object to animate with this effect.
Method detail
applyValueToTarget () method
protected function applyValueToTarget(target:Object, property:String, value:*, props:Object):void

Used internally by the Effect infrastructure. If captureStartValues() has been called, then when Flex calls the play() method, it uses this function to set the targets back to the starting state. The default behavior is to take the value captured using the getValueFromTarget() method and set it directly on the target's property. For example:

   target[property] = value;

Only override this method if you need to apply the captured values in a different way. Note that style properties of a target are set using a different mechanism. Use the relevantStyles property to specify which style properties to capture and apply.

Parameters
target:Object — The effect target.
property:String — The target property.
value:* — The value of the property.
props:Object — Array of Objects, where each Array element contains a start and end Object for the properties that the effect is monitoring.
captureStartValues () method
public function captureStartValues():void

Captures the current values of the relevant properties on the effect's targets. Flex automatically calls the captureStartValues() method when the effect is part of a transition.

Use this function when you want the effect to figure out the start and end values of the effect. The proper usage of this function is to use it in the following steps:

  1. Call the captureStartValues() method. The effect captures the starting effect values.
  2. Make changes to your effect targets, like adding/removing children, altering properties, changing location, or changing dimensions.
  3. Call the play() method. The effect captures the end values. This function populates the EffectInstance.propertyChanges property for each effect instance created by this effect. Effect developers can use the propertyChanges property to retrieve the start and end values for their effect.
createInstance () method
public function createInstance(target:Object = null):EffectInstance

Creates a single effect instance and initializes it. Use this method instead of the play() method to manipulate the effect instance properties before the effect instance plays.

The effect instance is created with the type specified in the instanceClass property. It is then initialized using the initInstance() method. If the instance was created by the EffectManager (when the effect is triggered by an effect trigger), the effect is further initialized by a call to the EffectInstance.initEffect() method.

Calling the createInstance() method does not play the effect. You must call the startEffect() method on the returned effect instance.

This function is automatically called by the Effect.play() method.

Parameters
target:Object (default = null) — Object to animate with this effect.

Returns
EffectInstance — The effect instance object for the effect.
createInstances () method
public function createInstances(targets:Array = null):Array

Takes an Array of target objects and invokes the createInstance() method on each target.

Parameters
targets:Array (default = null) — Array of objects to animate with this effect.

Returns
Array — Array of effect instance objects, one per target, for the effect.
effectEndHandler () method
protected function effectEndHandler(event:EffectEvent):void

Called when an effect instance has finished playing. If you override this method, ensure that you call the super method.

Parameters
event:EffectEvent — An event object of type EffectEvent.
effectStartHandler () method
protected function effectStartHandler(event:EffectEvent):void

This method is called when the effect instance starts playing. If you override this method, ensure that you call the super method.

Parameters
event:EffectEvent — An event object of type EffectEvent.
end () method
public function end(effectInstance:EffectInstance = null):void

Interrupts an effect that is currently playing, and jumps immediately to the end of the effect. Calling this method invokes the EffectInstance.end() method.

The effect instance dispatches an effectEnd event when you call this method as part of ending the effect.

If you pass an effect instance as an argument, just that instance is interrupted. If no argument is passed in, all effect instances currently spawned from the effect are interrupted.

Parameters
effectInstance:EffectInstance (default = null) — EffectInstance to terminate.

See also

mx.effects.EffectInstance.end()
filterInstance () method
protected function filterInstance(propChanges:Array, targ:Object):Boolean

Determines the logic for filtering out an effect instance. The CompositeEffect class overrides this method.

Parameters
propChanges:Array — The properties modified by the effect.
targ:Object — The effect target.

Returns
Boolean — Returns true if the effect instance should play.
getAffectedProperties () method
public function getAffectedProperties():Array

Returns an Array of Strings, where each String is the name of a property that is changed by this effect. For example, the Move effect returns an Array that contains "x" and "y".

Every subclass of Effect must implement this method. The method is used by the EffectManager to ensure that no two effects are trying to animate the same property of the same object at the same time.

Returns
Array — An Array of Strings specifying the names of the properties modified by this effect.

See also

Example: Defining a simple effect
getValueFromTarget () method
protected function getValueFromTarget(target:Object, property:String):*

Called by the captureStartValues() method to get the value of a property from the target. This function should only be called internally by the effects framework. The default behavior is to simply return target[property]. Effect developers can override this function if you need a different behavior.

Parameters
target:Object — The effect target.
property:String — The target property.

Returns
* — The value of the target property.
initInstance () method
protected function initInstance(instance:EffectInstance):void

Copies properties of the effect to the effect instance.

Flex calls this method from the Effect.createInstance() method; you do not have to call it yourself.

When you create a custom effect, override this method to copy properties from the Effect class to the effect instance class. In your override, you must call super.initInstance().

Parameters
instance:EffectInstance — The effect instance to initialize.

See also

Example: Defining a simple effect
pause () method
public function pause():void

Pauses the effect until you call the resume() method.

play () method
public function play(targets:Array = null, playReversedFromEnd:Boolean = false):Array

Begins playing the effect. You typically call the end() method before you call the play() method to ensure that any previous instance of the effect has ended before you start a new one.

All subclasses must implement this method.

Parameters
targets:Array (default = null) — Array of target objects on which to play this effect. If this parameter is specified, then the effect's targets property is not used.
playReversedFromEnd:Boolean (default = false) — If true, play the effect backwards.

Returns
Array — Array of EffectInstance objects, one per target, for the effect.
resume () method
public function resume():void

Resumes the effect after it has been paused by a call to the pause() method.

reverse () method
public function reverse():void

Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.

Event detail
effectEnd event
Event object type: mx.events.EffectEvent
EffectEvent.type property = mx.events.EffectEvent.EFFECT_END

Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method.

The EffectEvent.EFFECT_END constant defines the value of the type property of the event object for an effectEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
effectInstance | The effect instance object for the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
effectStart event
Event object type: mx.events.EffectEvent
EffectEvent.type property = mx.events.EffectEvent.EFFECT_START

Dispatched when the effect starts playing.

The EffectEvent.EFFECT_START constant defines the value of the type property of the event object for an effectStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
effectInstance | The effect instance object for the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
SimpleEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Effect class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.controls.Alert;

            // Event handler for the effectEnd event.
            private function endEffectHandler():void {
                Alert.show("Effect Ended!");
            }

            // Event handler for the reset button.
            private function resetHandler():void {
                expand.end();
                img.width=30;
                img.height=60;
                button1.enabled=true;
            }
        ]]>
    </mx:Script>

    <mx:Resize id="expand" target="{img}" widthTo="100" heightTo="200"
        duration="10000" effectEnd="endEffectHandler();"/>

    <mx:Panel title="Resize Effect Example" width="100%" height="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Use the Button controls to control the Resize effect."/>

        <mx:Image id="img" width="30" height="60"
            source="@Embed(source='assets/Nokia_6630.png')"/>

        <mx:ControlBar>
            <mx:Button id="button1" label="Start" click="expand.play(); button1.enabled=false;"/>
            <mx:Button label="Pause" click="expand.pause();"/>
            <mx:Button label="Resume" click="expand.resume();"/>
            <mx:Button label="Reverse" click="expand.reverse();"/>
            <mx:Button label="End" click="expand.end();"/>
            <mx:Button label="Reset" click="resetHandler();"/>
        </mx:ControlBar>

    </mx:Panel>
</mx:Application>


mx.effects.EffectInstance (Flex™ 2 Language Reference)

Class EffectInstance | Properties | Methods
Package | mx.effects
Class | public class EffectInstance
Inheritance | EffectInstance Inheritance EventDispatcher Inheritance Object
Subclasses | ActionEffectInstance, CompositeEffectInstance, MaskEffectInstance, SoundEffectInstance, TweenEffectInstance

The EffectInstance class represents an instance of an effect playing on a target. Each target has a separate effect instance associated with it. An effect instance's lifetime is transitory. An instance is created when the effect is played on a target and is destroyed when the effect has finished playing. If there are multiple effects playing on a target at the same time (for example, a Parallel effect), there is a separate effect instance for each effect.

Effect developers must create an instance class for their custom effects.

See also

mx.effects.Effect
About creating a custom effect
Example: Defining a simple effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | className : String [read-only] The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | duration : Number Duration of the effect in milliseconds. | EffectInstance
 | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | playheadTime : Number [read-only] Current position in time of the effect. | EffectInstance
 | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
 | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
 | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
 | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
 | target : Object The UIComponent object to which this effect is applied. | EffectInstance
 | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
EffectInstance(target:Object)
Constructor.
EffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
className property
className:String [read-only]

The name of the effect class, such as "FadeInstance".

This is a short or "unqualified" class name that does not include the package name. If you need the qualified name, use the getQualifiedClassName() method in the flash.utils package.

Implementation
    public function get className():String
duration property
duration:Number [read-write]

Duration of the effect in milliseconds.

The default value is 500.

Implementation
    public function get duration():Number
    public function set duration(value:Number):void
effect property
public var effect:Effect

The Effect object that created this EffectInstance object.

playheadTime property
playheadTime:Number [read-only]

Current position in time of the effect. This property has a value between 0 and the actual duration (which includes the value of the startDelay, repeatCount, and repeatDelay properties).

Implementation
    public function get playheadTime():Number
propertyChanges property
public var propertyChanges:PropertyChanges

Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. This property is only set if the captureStartValues() method was called on the effect that created this effect instance.

You often use the propertyChanges property to create an effect that is used as part of a transition. Flex automatically calls the captureStartValues() method when it starts a transition. Within your override of the Effectinstance.play() method, you can examine the information within the propertyChanges() method to initialize the start and end values of the effect.

See also

mx.effects.effectClasses.PropertyChanges
Using the propertyChanges property
repeatCount property
public var repeatCount:int = 1

Number of times to repeat the effect. Possible values are any integer greater than or equal to 0.

The default value is 1.

See also

mx.effects.Effect.repeatCount
repeatDelay property
public var repeatDelay:int = 0

Amount of time, in milliseconds, to wait before repeating the effect.

The default value is 0.

See also

mx.effects.Effect.repeatDelay
startDelay property
public var startDelay:int = 0

Amount of time, in milliseconds, to wait before starting the effect. Possible values are any int greater than or equal to 0. If the effect is repeated by using the repeatCount property, the startDelay property is applied only the first time the effect is played.

The default value is 0.

suspendBackgroundProcessing property
public var suspendBackgroundProcessing:Boolean = false

If true, blocks all background processing while the effect is playing. Background processing includes measurement, layout, and processing responses that have arrived from the server.

The default value is false.

See also

mx.effects.Effect.suspendBackgroundProcessing
target property
public var target:Object

The UIComponent object to which this effect is applied.

See also

mx.effects.Effect.target
triggerEvent property
public var triggerEvent:Event

The event, if any, which triggered the playing of the effect. This property is useful when an effect is assigned to multiple triggering events.

If the effect was played programmatically by a call to the play() method, rather than being triggered by an event, this property is null.

Constructor detail
EffectInstance () constructor
public function EffectInstance(target:Object)

Constructor.

Parameters
target:Object — UIComponent object to animate with this effect.
Method detail
end () method
public function end():void

Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect. This method is invoked by a call to the Effect.end() method. As part of its implementation, it calls the finishEffect() method.

The effect instance dispatches an effectEnd event when you call this method as part of ending the effect.

In a subclass of EffectInstance, you can optionally override this method. As part of your override, you should call the super.end() method from the end of your override, after your logic.

See also

mx.effects.Effect.end()
Example: Defining a simple effect
finishEffect () method
public function finishEffect():void

Called by the end() method when the effect finishes playing. This function dispatches an endEffect event for the effect target.

You do not have to override this method in a subclass. You do not need to call this method when using effects, but you may need to call it if you create an effect subclass.

See also

mx.events.EffectEvent
finishRepeat () method
public function finishRepeat():void

Called after each iteration of a repeated effect finishes playing.

You do not have to override this method in a subclass. You do not need to call this method when using effects.

initEffect () method
public function initEffect(event:Event):void

This method is called if the effect was triggered by the EffectManager. This base class version saves the event that triggered the effect in the triggerEvent property. Each subclass should override this method.

Parameters
event:Event — The Event object that was dispatched to trigger the effect. For example, if the trigger was a mouseDownEffect, the event would be a MouseEvent with type equal to MouseEvent.MOUSEDOWN.
pause () method
public function pause():void

Pauses the effect until you call the resume() method.

play () method
public function play():void

Plays the effect instance on the target. Call the startEffect() method instead to make an effect start playing on an EffectInstance.

In a subclass of EffectInstance, you must override this method. The override must call the super.play() method so that an effectStart event is dispatched from the target.

See also

Example: Defining a simple effect
resume () method
public function resume():void

Resumes the effect after it has been paused by a call to the pause() method.

reverse () method
public function reverse():void

Plays the effect in reverse, starting from the current position of the effect.

startEffect () method
public function startEffect():void

Plays the effect instance on the target after the startDelay period has elapsed. Called by the Effect class. Use this function instead of the play() method when starting an EffectInstance.


mx.effects.EffectManager (Flex™ 2 Language Reference)

Class EffectManager | Properties | Methods
Package | mx.effects
Class | public class EffectManager
Inheritance | EffectManager Inheritance EventDispatcher Inheritance Object

The EffectManager class listens for events, such as the show and move events, dispatched by objects in a Flex application. For each event, corresponding to an event trigger, it determines if there is an effect assigned to the object. If an effect is defined, it plays the effect.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
endEffectsForTarget(target:IUIComponent):void
[static] Immediately ends any effects currently playing on a target.
EffectManager
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
resumeEventHandling():void
[static] Allows the EffectManager class to resume processing events after a call to the suspendEventHandling() method.
EffectManager
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
suspendEventHandling():void
[static] After this method is called, the EffectManager class ignores all events, and no effects are triggered, until a call to resumeEventHandling().
EffectManager
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Method detail
endEffectsForTarget () method
public static function endEffectsForTarget(target:IUIComponent):void

Immediately ends any effects currently playing on a target.

Parameters
target:IUIComponent — The target component on which to end all effects.
resumeEventHandling () method
public static function resumeEventHandling():void

Allows the EffectManager class to resume processing events after a call to the suspendEventHandling() method. Used internally in conjunction with the suspendEventHandling() method so that an effect that is updating the screen does not cause another effect to be triggered.

suspendEventHandling () method
public static function suspendEventHandling():void

After this method is called, the EffectManager class ignores all events, and no effects are triggered, until a call to resumeEventHandling(). Used internally so that an effect that is updating the screen does not cause another effect to be triggered.


mx.effects.EffectTargetFilter (Flex™ 2 Language Reference)

Class EffectTargetFilter | Properties | Methods
Package | mx.effects
Class | public class EffectTargetFilter
Inheritance | EffectTargetFilter Inheritance Object

The EffectTargetFilter class defines a custom filter that is executed by each transition effect on each target of the effect.

The EffectTargetFilter class defines a defaultFilterFunction() method that uses the filterProperties and filterStyles properties to determine whether to play the effect on each effect target.

You can also define a custom filter function to implement your own filtering logic. To do so, define your filter function, and then specify that function to an EffectTargetFilter object using the filterFunction property.

To configure an effect to use a custom filter, you pass an EffectTargetFilter object to the Effect.customFilter property of the effect.

See also

Defining a custom filter

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | filterFunction : Function A function that defines custom filter logic. | EffectTargetFilter
 | filterProperties : Array An Array of Strings specifying component properties. | EffectTargetFilter
 | filterStyles : Array An Array of Strings specifying style properties. | EffectTargetFilter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | EffectTargetFilter() Constructor. | EffectTargetFilter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Method |  | Defined by
 | defaultFilterFunction(propChanges:Array, instanceTarget:Object):Boolean The default filter function for the EffectTargetFilter class. | EffectTargetFilter
Property detail
filterFunction property
public var filterFunction:Function

A function that defines custom filter logic. Flex calls this method on every target of the effect. If the function returns true, the effect plays on the target; if it returns false, the target is skipped by the effect. A custom filter function gives you greater control over filtering than the Effect.filter property.

The filter function has the following signature:

   filterFunc(propChanges:Array, instanceTarget:Object):Boolean
   {
       // Return true to play the effect on instanceTarget,
       // or false to not play the effect.
      }

where:

propChanges - An Array of PropertyChanges objects, one object per target component of the effect. If a property of a target is not modified by the transition, it is not included in this Array.

instanceTarget - The specific target component of the effect that you want to filter. Within the custom filter function, you first search the propChanges Array for the PropertyChanges object that matches the instanceTarget argument by comparing the instanceTarget argument to the propChanges.target property.

See also

mx.effects.effectClasses.PropertyChanges
filterProperties property
public var filterProperties:Array

An Array of Strings specifying component properties. If any of the properties in the Array changed on the target component, play the effect on the target.

If you define a custom filter function, you can examine the filterProperties property from within your function.

filterStyles property
public var filterStyles:Array

An Array of Strings specifying style properties. If any of the style properties in the Array changed on the target component, play the effect on the target.

If you define a custom filter function, you can examine the filterStyles property from within your function.

Constructor detail
EffectTargetFilter () constructor
public function EffectTargetFilter()

Constructor.

Method detail
defaultFilterFunction () method
protected function defaultFilterFunction(propChanges:Array, instanceTarget:Object):Boolean

The default filter function for the EffectTargetFilter class. If the instanceTarget has different start and end values for any of the values specified by the filterProperties or filterStyles properties, play the effect on the target.

Parameters
propChanges:Array — An Array of PropertyChanges objects. The target property of each PropertyChanges object is equal to the effect's target. If no properties changed for an effect target, it is not included in this Array.
instanceTarget:Object — The target of the EffectInstance that calls this function. If an effect has multiple targets, this function is called once per target.

Returns
Boolean — Returns true to allow the effect instance to play.

See also

mx.effects.effectClasses.PropertyChanges


mx.effects.Fade (Flex™ 2 Language Reference)

Class Fade | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Fade
Inheritance | Fade Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Fade effect animates the alpha property of a component, either from transparent to opaque, or from opaque to transparent.

If you specify the Fade effect for the showEffect or hideEffect trigger, and if you omit values for the alphaFrom and alphaTo properties, the effect automatically transitions alpha from 0 to the target's current alpha value on a showEffect trigger, and from the target's current alpha value to 0 on a hideEffect trigger.

Note: To use the Fade effect with text, you must use an embedded font, not a device font.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Fade> tag inherits the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Fade
    id="ID"
    alphaFrom="val"
    alphaTo="val"
  />

View the examples.

See also

mx.effects.effectClasses.FadeInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphaFrom : Number Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | Fade
 | alphaTo : Number Final transparency level, where 0.0 means transparent and 1.0 means fully opaque. | Fade
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Fade(target:Object = null)
Constructor.
Fade
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
alphaFrom property
public var alphaFrom:Number

Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

If the effect causes the target component to disappear, the default value is the current value of the target's alpha property. If the effect causes the target component to appear, the default value is 0.0.

alphaTo property
public var alphaTo:Number

Final transparency level, where 0.0 means transparent and 1.0 means fully opaque.

If the effect causes the target component to disappear, the default value is 0.0. If the effect causes the target component to appear, the default value is the current value of the target's alpha property.

Constructor detail
Fade () constructor
public function Fade(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
FadeEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Fade effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
    initialize="Font.registerFont(arial_font);">

    <mx:Script>
        <![CDATA[

            import flash.text.Font;

            [Embed("assets/arial.ttf", fontName="MyArial")]
            public var arial_font:Class;
        ]]>
    </mx:Script>

    <mx:Fade id="fadeOut" duration="1000" alphaFrom="1.0" alphaTo="0.0"/>
    <mx:Fade id="fadeIn" duration="1000" alphaFrom="0.0" alphaTo="1.0"/>

    <mx:Panel title="Fade Effect Example" width="95%" height="95%"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:Text width="100%" color="blue"
            text="Use the Fade effect to show or hide the text and image. Use an embedded font when applying the Fade effect to text."/>

        <mx:Label text="Nokia 9930"
            fontFamily="MyArial" fontSize="14"
            visible="{cb1.selected}"
            hideEffect="{fadeOut}" showEffect="{fadeIn}"/>

        <mx:Image source="@Embed(source='assets/Nokia_6630.png')"
            visible="{cb1.selected}"
            hideEffect="{fadeOut}" showEffect="{fadeIn}"/>

        <mx:CheckBox id="cb1" label="visible" selected="true"/>

    </mx:Panel>
</mx:Application>


mx.effects.Glow (Flex™ 2 Language Reference)

Class Glow | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Glow
Inheritance | Glow Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Glow effect lets you apply a visual glow effect to a component.

The Glow effect uses the Flash GlowFilter class as part of its implementation. For more information, see the flash.filters.GlowFilter class. If you apply a Glow effect to a component, you cannot apply a GlowFilter or a second Glow effect to the component.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Glow> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Glow
    id="ID"
    alphaFrom="val"
    alphaTo="val"
    blurXFrom="val"
    blurXTo="val"
    blurYFrom="val"
    blurYTo="val"
    color="themeColor of the application"
    inner="false|true"
    knockout="false|true"
    strength="2"
  />

View the examples.

See also

flash.filters.GlowFilter
mx.effects.effectClasses.GlowInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphaFrom : Number Starting transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | Glow
 | alphaTo : Number Ending transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | Glow
 | blurXFrom : Number The starting amount of horizontal blur. | Glow
 | blurXTo : Number The ending amount of horizontal blur. | Glow
 | blurYFrom : Number The starting amount of vertical blur. | Glow
 | blurYTo : Number The ending amount of vertical blur. | Glow
Inherited | className : String The name of the effect class, such as "Fade". | Effect
 | color : uint = 0xFFFFFFFF The color of the glow. | Glow
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
 | inner : Boolean Specifies whether the glow is an inner glow. | Glow
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | knockout : Boolean Specifies whether the object has a knockout effect. | Glow
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
 | strength : Number The strength of the imprint or spread. | Glow
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Glow(target:Object = null)
Constructor.
Glow
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
alphaFrom property
public var alphaFrom:Number

Starting transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

alphaTo property
public var alphaTo:Number

Ending transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

blurXFrom property
public var blurXFrom:Number

The starting amount of horizontal blur. Valid values are from 0.0 to 255.0.

blurXTo property
public var blurXTo:Number

The ending amount of horizontal blur. Valid values are from 0.0 to 255.0.

blurYFrom property
public var blurYFrom:Number

The starting amount of vertical blur. Valid values are from 0.0 to 255.0.

blurYTo property
public var blurYTo:Number

The ending amount of vertical blur. Valid values are from 0.0 to 255.0.

color property
public var color:uint = 0xFFFFFFFF

The color of the glow. The default value is the value of the themeColor style property of the application.

inner property
public var inner:Boolean

Specifies whether the glow is an inner glow. A value of true indicates an inner glow within the outer edges of the object. The default value is false, to specify an outer glow around the outer edges of the object.

The default value is false.

knockout property
public var knockout:Boolean

Specifies whether the object has a knockout effect. A value of true makes the object's fill color transparent to reveal the background color of the underlying object. The default value is false to specify no knockout effect.

The default value is false.

strength property
public var strength:Number

The strength of the imprint or spread. The higher the value, the more color is imprinted and the stronger the contrast between the glow and the background. Valid values are from 0 to 255.

The default value is 2.

Constructor detail
Glow () constructor
public function Glow(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
GlowEffectExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Glow effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Glow id="glowImage" duration="1000"
        alphaFrom="1.0" alphaTo="0.3"
        blurXFrom="0.0" blurXTo="50.0"
        blurYFrom="0.0" blurYTo="50.0"
        color="0x00FF00"/>
    <mx:Glow id="unglowImage" duration="1000"
        alphaFrom="0.3" alphaTo="1.0"
        blurXFrom="50.0" blurXTo="0.0"
        blurYFrom="50.0" blurYTo="0.0"
        color="0x0000FF"/>

    <mx:Panel title="Glow Effect Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click and hold the mouse on the image to see glowImage effect. Release the mouse to see unglowImage effect."/>

        <mx:Image source="@Embed(source='assets/Nokia_6630.png')"
            mouseDownEffect="{glowImage}"
            mouseUpEffect="{unglowImage}"/>

    </mx:Panel>
</mx:Application>


mx.effects.Iris (Flex™ 2 Language Reference)

Class Iris | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Iris
Inheritance | Iris Inheritance MaskEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Iris effect animates the effect target by expanding or contracting a rectangular mask centered on the target. The effect can either enlarge the mask from the center of the target to expose the target, or contract the mask toward the center to obscure the target.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Iris> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Iris
    id="ID"
  />

View the examples.

See also

mx.effects.effectClasses.IrisInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffect
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffect
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffect
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffect
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffect
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffect
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, true, or invisible, false. | MaskEffect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffect
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffect
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffect
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Iris(target:Object = null)
Constructor.
Iris
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns the component properties modified by this effect.
MaskEffect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | MaskEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the effect ends. | MaskEffect
Inherited | tweenStart | Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods. | MaskEffect
Inherited | tweenUpdate | Dispatched every time the effect updates the target. | MaskEffect
Constructor detail
Iris () constructor
public function Iris(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
IrisEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Iris effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Iris id="irisOut" duration="1000" showTarget="true"/>
    <mx:Iris id="irisIn" duration="1000" showTarget="false"/>

    <mx:Panel title="Iris Effect Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Use the Iris effect to show or hide the phone image."/>

        <mx:Image id="flex" source="@Embed(source='assets/Nokia_6630.png')"
            visible="{cb1.selected}"
            showEffect="{irisIn}" hideEffect="{irisOut}"/>

        <mx:CheckBox id="cb1" label="visible" selected="true"/>

    </mx:Panel>
</mx:Application>


mx.effects.MaskEffect (Flex™ 2 Language Reference)

Class MaskEffect | Properties | Methods | Events
Package | mx.effects
Class | public class MaskEffect
Inheritance | MaskEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object
Subclasses | Iris, WipeDown, WipeLeft, WipeRight, WipeUp

The MaskEffect class is an abstract base class for all effects that animate a mask, such as the wipe effects and the Iris effect. This class encapsulates methods and properties that are common among all mask-based effects.

A mask effect uses an overlay, called a mask, to perform the effect. By default, the mask is a rectangle with the same size as the target component.

The before or after state of the target component of a mask effect must be invisible. That means a mask effect always makes a target component appear on the screen, or disappear from the screen.

You use the scaleXFrom, scaleYFrom, scaleXTo, and scaleX properties to specify the initial and final scale of the mask, where a value of 1.0 corresponds to scaling the mask to the size of the target component, 2.0 scales the mask to twice the size of the component, 0.5 scales the mask to half the size of the component, and so on. To use any one of these properties, you must specify all four.

You use the xFrom, yFrom, xTo, and yTo properties to specify the coordinates of the initial position and final position of the mask relative to the target component, where (0, 0) corresponds to the upper left corner of the target. To use any one of these properties, you must specify all four.

The coordinates of the initial and final position of the mask depend on the type of effect and whether the show property is true or false. For example, for the WipeLeft effect with a show value of false, the coordinates of the initial mask position are (0, 0),corresponding to the upper-left corner of the target, and the coordinates of the final position are the upper-right corner of the target (width, 0), where width is the width of the target.

For a show value of true for the WipeLeft effect, the coordinates of the initial mask position are (width, 0), and the coordinates of the final position are (0, 0).

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The MaskEffect class defines the following properties, which all of its subclasses inherit:

  <mx:tagname
    createMaskFunction=""
    moveEasingFunction=""
    scaleEasingFunction=""
    scaleXFrom=""
    scaleXTo=""
    scaleYFrom=""
    scaleYTo=""
    show="true|false"
    xFrom=""
    xTo=""
    yFrom=""
    yTo=""
  />

See also

mx.effects.effectClasses.MaskEffectInstance
mx.effects.TweenEffect
Creating a custom mask function

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffect
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
 | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffect
 | scaleXFrom : Number Initial scaleX for mask. | MaskEffect
 | scaleXTo : Number Ending scaleX for mask. | MaskEffect
 | scaleYFrom : Number Initial scaleY for mask. | MaskEffect
 | scaleYTo : Number Ending scaleY for mask. | MaskEffect
 | showTarget : Boolean Specifies that the target component is becoming visible, true, or invisible, false. | MaskEffect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | xFrom : Number Initial position's x coordinate for mask. | MaskEffect
 | xTo : Number Destination position's x coordinate for mask. | MaskEffect
 | yFrom : Number Initial position's y coordinate for mask. | MaskEffect
 | yTo : Number Destination position's y coordinate for mask. | MaskEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MaskEffect(target:Object = null)
Constructor.
MaskEffect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
getAffectedProperties():Array
Returns the component properties modified by this effect.
MaskEffect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
 | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | MaskEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
 | tweenEnd | Dispatched when the effect ends. | MaskEffect
 | tweenStart | Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods. | MaskEffect
 | tweenUpdate | Dispatched every time the effect updates the target. | MaskEffect
Property detail
createMaskFunction property
public var createMaskFunction:Function

Function called when the effect creates the mask. The default value is a function that returns a Rectangle with the same dimensions as the target.

The custom mask function has the following signature:

   public function createLargeMask(targ:Object, bounds:Rectangle):Shape
      {
       var myMask:Shape = new FlexShape();
         // Create mask.
            return myMask;
      }

Your custom mask function takes an argument corresponding to the target component of the effect, and a second argument that defines the dimensions of the target so that you can correctly size the mask. You use that argument to access properties of the target component, such as width and height, so that you can create a mask with the correct size.

The function returns a single Shape object that defines the mask.

moveEasingFunction property
public var moveEasingFunction:Function

Easing function to use for moving the mask.

The default value is null.

scaleEasingFunction property
public var scaleEasingFunction:Function

Easing function to use for scaling the mask.

The default value is null.

scaleXFrom property
public var scaleXFrom:Number

Initial scaleX for mask.

To specify this property, you must specify all four of these properties: scaleXFrom, scaleYFrom, scaleXTo, and scaleX.

scaleXTo property
public var scaleXTo:Number

Ending scaleX for mask.

To specify this property, you must specify all four of these properties: scaleXFrom, scaleYFrom, scaleXTo, and scaleX.

scaleYFrom property
public var scaleYFrom:Number

Initial scaleY for mask.

To specify this property, you must specify all four of these properties: scaleXFrom, scaleYFrom, scaleXTo, and scaleX.

scaleYTo property
public var scaleYTo:Number

Ending scaleY for mask.

To specify this property, you must specify all four of these properties: scaleXFrom, scaleYFrom, scaleXTo, and scaleX.

showTarget property
showTarget:Boolean [read-write]

Specifies that the target component is becoming visible, true, or invisible, false. If you specify this effect for a showEffect or hideEffect trigger, Flex sets the showTarget property for you, either to true if the component becomes visible, or false if the component becomes invisible. If you use this effect with a different effect trigger, you should set it yourself, often within the event listener for the startEffect event.

The default value is true.

Implementation
    public function get showTarget():Boolean
    public function set showTarget(value:Boolean):void
xFrom property
public var xFrom:Number

Initial position's x coordinate for mask.

To specify this property, you must specify all four of these properties: xFrom, yFrom, xTo, and yTo.

xTo property
public var xTo:Number

Destination position's x coordinate for mask.

To specify this property, you must specify all four of these properties: xFrom, yFrom, xTo, and yTo.

yFrom property
public var yFrom:Number

Initial position's y coordinate for mask.

To specify this property, you must specify all four of these properties: xFrom, yFrom, xTo, and yTo.

yTo property
public var yTo:Number

Destination position's y coordinate for mask.

To specify this property, you must specify all four of these properties: xFrom, yFrom, xTo, and yTo.

Constructor detail
MaskEffect () constructor
public function MaskEffect(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Method detail
getAffectedProperties () method
public override function getAffectedProperties():Array

Returns the component properties modified by this effect. This method returns an Array containing: [ "visible", "width", "height" ]. Since the WipeDown, WipeLeft, WipeRight, and WipeDown effect subclasses all modify these same properties, those classes do not implement this method.

If you subclass the MaskEffect class to create a custom effect, and it modifies a different set of properties on the target, you must override this method and return an Array containing a list of the properties modified by your subclass.

Returns
Array — An Array of Strings specifying the names of the properties modified by this effect.

See also

mx.effects.Effect.getAffectedProperties()
tweenEventHandler () method
protected function tweenEventHandler(event:TweenEvent):void

Called when the TweenEffect dispatches a TweenEvent. If you override this method, ensure that you call the super method.

Parameters
event:TweenEvent — An event object of type TweenEvent.
Event detail
tweenEnd event
Event object type: mx.events.TweenEvent
TweenEvent.type property = mx.events.TweenEvent.TWEEN_END

Dispatched when the effect ends.

When an effect plays a single time, this event occurs at the same time as an effectEnd event. If you configure the effect to repeat, it occurs at the end of every repetition of the effect, and the endEffect event occurs after the effect plays for the final time.

The TweenEvent.TWEEN_END constant defines the value of the event object's type property for a tweenEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenEnd() method.
tweenStart event
Event object type: mx.events.TweenEvent
TweenEvent.type property = mx.events.TweenEvent.TWEEN_START

Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods. Flex also dispatches the first tweenUpdate event for the effect at the same time.

The Effect.effectStart event is dispatched before the tweenStart event.

The TweenEvent.TWEEN_START constant defines the value of the event object's type property for a tweenStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenUpdate() method.
tweenUpdate event
Event object type: mx.events.TweenEvent
TweenEvent.type property = mx.events.TweenEvent.TWEEN_UPDATE

Dispatched every time the effect updates the target. The dispatching of this event corresponds to the calls to the onMoveTweenUpdate() and onScaleTweenUpdate() methods.

The TweenEvent.TWEEN_UPDATE constant defines the value of the event object's type property for a tweenUpdate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenUpdate() method.


mx.effects.Move (Flex™ 2 Language Reference)

Class Move | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Move
Inheritance | Move Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Move effect changes the position of a component over a specified time interval. You can specify the initial position with the xFrom and yFrom values, the destination position with xTo and yTo, or the number of pixels to move the component with xBy and yBy.

If you specify any two of the values (initial position, destination, or amount to move), Flex calculates the third. If you specify all three, Flex ignores the xBy and yBy values. If you specify only the xTo and yTo values or the xBy and yBy values, Flex sets xFrom and yFrom to be the object's current position.

If you specify a Move effect for a moveEffect trigger, and if you do not set the six From, To, and By properties, Flex sets them to create a smooth transition between the object's old position and its new position.

If the object's position was originally determined by its parent container (for example, the object is inside an HBox container), the object's position may be reset to its original position next time that the container's layout code runs. To avoid snapping back to the original position, place the object inside a Canvas container, or set the parent container's autoLayout property to false.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Move> tag inherits all of the tag attributes of its of its superclass, and adds the following tag attributes:

  <mx:Move
    id="ID"
    xFrom="val"
    yFrom="val"
    xTo="val"
    yTo="val"
    xBy="val"
    yBy="val"
   />

View the examples.

See also

mx.effects.effectClasses.MoveInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | xBy : Number Number of pixels to move the components along the x axis. | Move
 | xFrom : Number Initial position's x coordinate. | Move
 | xTo : Number Destination position's x coordinate. | Move
 | yBy : Number Number of pixels to move the components along the y axis. | Move
 | yFrom : Number Initial position's y coordinate. | Move
 | yTo : Number Destination position's y coordinate. | Move
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Move(target:Object = null)
Constructor.
Move
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
xBy property
public var xBy:Number

Number of pixels to move the components along the x axis. Values can be negative.

xFrom property
public var xFrom:Number

Initial position's x coordinate.

xTo property
public var xTo:Number

Destination position's x coordinate.

yBy property
public var yBy:Number

Number of pixels to move the components along the y axis. Values can be negative.

yFrom property
public var yFrom:Number

Initial position's y coordinate.

yTo property
public var yTo:Number

Destination position's y coordinate.

Constructor detail
Move () constructor
public function Move(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
MoveEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Move effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            private function moveImage():void {
                myMove.end();
                myMove.xTo=mouseX-60;
                myMove.play();
            }
      ]]>
    </mx:Script>

    <mx:Move id="myMove" target="{img}"/>

    <mx:Panel title="Move Effect Example" width="95%" height="95%"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

       <mx:Text width="100%" color="blue"
           text="Click anywhere on the canvas to move the phone horizontally to that position"/>

        <mx:Canvas id="canvas" width="100%" height="100%" mouseDown="moveImage();">

            <mx:Image id="img" source="@Embed(source='assets/Nokia_6630.png')"/>

        </mx:Canvas>

    </mx:Panel>
</mx:Application>


mx.effects.Parallel (Flex™ 2 Language Reference)

Class Parallel | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Parallel
Inheritance | Parallel Inheritance CompositeEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Parallel effect plays multiple child effects at the same time.

You can create a Paralell effect in MXML, as the following example shows:

  <mx:Parallel id="WipeRightUp">
    <mx:children>
      <mx:WipeRight duration="1000"/>
      <mx:WipeUp duration="1000"/>
    </mx:children>
  </mx:Parallel>

  <mx:VBox id="myBox" hideEffect="{WipeRightUp}" >
    <mx:TextArea id="aTextArea" text="hello"/>
  </mx:VBox>

Notice that the <mx:children> tag is optional.

Starting a Parallel effect in ActionScript is usually a five-step process:

  1. Create instances of the effect objects to be composited together; for example:
    myFadeEffect = new mx.effects.Fade(target);
  2. Set properties, such as duration, on the individual effect objects.
  3. Create an instance of the Parallel effect object; for example:
    myParallelEffect = new mx.effects.Parallel();
  4. Call the addChild() method for each of the effect objects; for example:
    myParallelEffect.addChild(myFadeEffect);
  5. Invoke the Parallel effect's play() method; for example:
    myParallelEffect.play();

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Parallel> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Parallel id="identifier">
    <mx:children>
      <!-- Specify child effect tags -->
    </mx:children>
  </mx:Parallel>

View the examples.

See also

mx.effects.effectClasses.ParallelInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | children : Array An Array containing the child effects of this CompositeEffect. | CompositeEffect
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Parallel(target:Object = null)
Constructor.
Parallel
Inherited
addChild(childEffect:Effect):void
Adds a new child effect to this composite effect.
CompositeEffect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Constructor detail
Parallel () constructor
public function Parallel(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — This argument is ignored for Parallel effects. It is included only for consistency with other types of effects.
Examples
ParallelEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Parallel effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

   <mx:Parallel id="expand" target="{img}">
        <mx:Move xTo="{canvas.width/2 - 50}" yTo="{canvas.height/2 - 100}"/>
        <mx:Resize widthTo="100" heightTo="200"/>
    </mx:Parallel>

    <mx:Parallel id="contract" target="{img}">
        <mx:Move xTo="20" yTo="20"/>
        <mx:Resize widthTo="30" heightTo="60"/>
    </mx:Parallel>

    <mx:Panel title="Parallel Effect Example" width="100%" height="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Use the Button controls to move and resize the phone image in parallel."/>

        <mx:Canvas id="canvas" width="100%" height="100%">
            <mx:Image id="img" x="20" y="20" width="30" height="60"
                source="@Embed(source='assets/Nokia_6630.png')"/>
        </mx:Canvas>

        <mx:ControlBar>
            <mx:Button label="Expand" click="expand.end(); expand.play();"/>
            <mx:Button label="Contract" click="contract.end(); contract.play();"/>
        </mx:ControlBar>

    </mx:Panel>
</mx:Application>


mx.effects.Pause (Flex™ 2 Language Reference)

Class Pause | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Pause
Inheritance | Pause Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Pause effect is useful when sequencing effects. It does nothing for a specified period of time. If you add a Pause effect as a child of a Sequence effect, you can create a pause between the two other effects.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Pause> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Pause
    id="ID"
  />

View the examples.

See also

mx.effects.effectClasses.PauseInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Pause(target:Object = null)
Constructor.
Pause
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Constructor detail
Pause () constructor
public function Pause(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — This argument is ignored by the Pause effect. It is included for consistency with other effects.
Examples
PauseEffectExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Pause effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[
            import mx.effects.easing.*;
        ]]>
    </mx:Script>

    <mx:Sequence id="movePauseMove">
        <mx:Move xBy="150" duration="2000" easingFunction="Bounce.easeOut"/>
        <mx:Pause duration="2000"/>
        <mx:Move xBy="-150" duration="2000" easingFunction="Bounce.easeIn"/>
    </mx:Sequence>

    <mx:Panel title="Pause Effect Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the phone image to start the Sequence effect. The effect pauses for 2 seconds between moves."/>

        <mx:Image
            source="@Embed(source='assets/Nokia_6630.png')"
            mouseDownEffect="{movePauseMove}"/>

    </mx:Panel>
</mx:Application>


mx.effects.RemoveChildAction (Flex™ 2 Language Reference)

Class RemoveChildAction | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class RemoveChildAction
Inheritance | RemoveChildAction Inheritance Effect Inheritance EventDispatcher Inheritance Object

The RemoveChildAction class defines an action effect that corresponds to the RemoveChild property of a view state definition. You use a RemoveChildAction effect within a transition definition to control when the view state change defined by a RemoveChild property occurs during the transition.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:RemoveChildAction> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:RemoveChildAction
    Properties
    id="ID"
  />

View the examples.

See also

mx.effects.effectClasses.RemoveChildActionInstance
mx.states.RemoveChild

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RemoveChildAction(target:Object = null)
Constructor.
RemoveChildAction
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Constructor detail
RemoveChildAction () constructor
public function RemoveChildAction(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
TransitionExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the Transition class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <mx:transitions>
        <!-- Define the transition from the base state to the Register state.-->
        <mx:Transition id="toRegister" fromState="*" toState="Register">
            <mx:Sequence targets="{[loginPanel, registerLink, confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>

        <!-- Define the transition from the Register state to the base state.-->
        <mx:Transition id="toDefault" fromState="Register" toState="*">
            <mx:Sequence targets="{[loginPanel, registerLink,
                    confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction  target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>
    </mx:transitions>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.effects.Resize (Flex™ 2 Language Reference)

Class Resize | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Resize
Inheritance | Resize Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Resize effect changes the width, height, or both dimensions of a component over a specified time interval.

If you specify only two of the three values of the widthFrom, widthTo, and widthBy properties, Flex calculates the third. If you specify all three, Flex ignores the widthBy value. If you specify only the widthBy or the widthTo value, the widthFrom property is set to be the object's current width. The same is true for heightFrom, heightTo, and heightBy property values.

If you specify a Resize effect for a resize trigger, and if you do not set the six From, To, and By properties, Flex sets them to create a smooth transition between the object's old size and its new size.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Resize> tag inherits all of the tag attributes of its superclass, and adds the following tab attributes:

  <mx:Resize
    id="ID"
    widthFrom="val"
    heightFrom="val"
    widthTo="val"
    heightTo="val"
    widthBy="val"
    heightBy="val"
    hideChildrenTargets=""
  />

View the examples.

See also

mx.effects.effectClasses.ResizeInstance
mx.effects.Tween

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
 | heightBy : Number Number of pixels by which to modify the height of the component. | Resize
 | heightFrom : Number Initial height, in pixels. | Resize
 | heightTo : Number Final height, in pixels. | Resize
 | hideChildrenTargets : Array An Array of Panel containers. | Resize
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | widthBy : Number Number of pixels by which to modify the width of the component. | Resize
 | widthFrom : Number Initial width, in pixels. | Resize
 | widthTo : Number Final width, in pixels. | Resize
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Resize(target:Object = null)
Constructor.
Resize
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
heightBy property
public var heightBy:Number

Number of pixels by which to modify the height of the component. Values may be negative.

heightFrom property
public var heightFrom:Number

Initial height, in pixels. If omitted, Flex uses the current height.

heightTo property
public var heightTo:Number

Final height, in pixels.

hideChildrenTargets property
public var hideChildrenTargets:Array

An Array of Panel containers. The children of these Panel containers are hidden while the Resize effect plays.

You use data binding syntax to set this property in MXML, as the following example shows, where panelOne and panelTwo are the names of two Panel containers in your application:

<mx:Resize id="e" heightFrom="100" heightTo="400"
  hideChildrenTargets="{[panelOne, panelTwo]}" />
widthBy property
public var widthBy:Number

Number of pixels by which to modify the width of the component. Values may be negative.

widthFrom property
public var widthFrom:Number

Initial width, in pixels. If omitted, Flex uses the current width.

widthTo property
public var widthTo:Number

Final width, in pixels.

Constructor detail
Resize () constructor
public function Resize(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
ResizeEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Resize effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Resize id="expand" target="{img}" widthTo="100" heightTo="200"/>
    <mx:Resize id="contract" target="{img}" widthTo="30" heightTo="60"/>

    <mx:Panel title="Resize Effect Example" width="100%" height="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Use the Button controls to resize the image."/>

        <mx:Image id="img" width="30" height="60"
            source="@Embed(source='assets/Nokia_6630.png')"/>

        <mx:ControlBar>
            <mx:Button label="Expand" click="expand.end(); expand.play();"/>
            <mx:Button label="Contract" click="contract.end(); contract.play();"/>
        </mx:ControlBar>

    </mx:Panel>
</mx:Application>


mx.effects.Rotate (Flex™ 2 Language Reference)

Class Rotate | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Rotate
Inheritance | Rotate Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Rotate effect rotates a component around a specified point. You can specify the coordinates of the center of the rotation, and the starting and ending angles of rotation. You can specify positive or negative values for the angles.

Note: To use the Rotate effect with text, you must use an embedded font, not a device font.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Rotate> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Rotate
    id="ID"
    angleFrom="0"
    angleTo="360"
    originX="0"
    originY="0"
  />

View the examples.

See also

mx.effects.effectClasses.RotateInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | angleFrom : Number = 0 The starting angle of rotation of the target object, expressed in degrees. | Rotate
 | angleTo : Number = 360 The ending angle of rotation of the target object, expressed in degrees. | Rotate
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | originX : Number The x-position of the center point of rotation. | Rotate
 | originY : Number The y-position of the center point of rotation. | Rotate
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Rotate(target:Object = null)
Constructor.
Rotate
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
angleFrom property
public var angleFrom:Number = 0

The starting angle of rotation of the target object, expressed in degrees. Valid values range from 0 to 360.

The default value is 0.

angleTo property
public var angleTo:Number = 360

The ending angle of rotation of the target object, expressed in degrees. Values can be either positive or negative.

If the value of angleTo is less than the value of angleFrom, the target rotates in a counterclockwise direction. Otherwise, it rotates in clockwise direction. If you want the target to rotate multiple times, set this value to a large positive or small negative number.

The default value is 360.

originX property
public var originX:Number

The x-position of the center point of rotation. The target rotates around this point. The valid values are between 0 and the width of the target.

The default value is 0.

originY property
public var originY:Number

The y-position of the center point of rotation. The target rotates around this point. The valid values are between 0 and the height of the target.

The default value is 0.

Constructor detail
Rotate () constructor
public function Rotate(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
RotateEffectExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Rotate effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
    initialize="Font.registerFont(arial_font);">

    <mx:Script>
        <![CDATA[

            import flash.text.Font;

            [Embed("assets/arial.ttf", fontName="MyArial")]
            public var arial_font:Class;

            [Bindable]
            public var angle:int=0;

            private function rotateImage():void {
                rotate.end();
                angle += 45;
                rotate.play();
            }
      ]]>
    </mx:Script>

    <mx:Rotate id="rotate" angleFrom="{angle-45}" angleTo="{angle}" target="{myVB}"/>

    <mx:Panel title="Rotate Effect Example" horizontalAlign="center"
        width="75%" height="75%" layout="horizontal"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:VBox id="myVB" width="50%" horizontalAlign="center">
            <mx:Label text="Nokia 9930"
                fontFamily="MyArial" fontSize="14"/>

            <mx:Image id="img"
                source="@Embed(source='assets/Nokia_6630.png')"/>
        </mx:VBox>

        <mx:Text width="50%" color="blue"
            text="Click the button to rotate the image 45 degrees. Use an embedded font when applying the Rotate effect to text."/>

        <mx:ControlBar>
            <mx:Button label="Rotate 45 Degrees" click="rotateImage();"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.effects.Sequence (Flex™ 2 Language Reference)

Class Sequence | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Sequence
Inheritance | Sequence Inheritance CompositeEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Sequence effect plays multiple child effects one after the other, in the order in which they are added.

You can create a Sequence effect in MXML, as the following example shows:

  <mx:Sequence id="WipeRightUp">
    <mx:children>
      <mx:WipeRight duration="1000"/>
      <mx:WipeUp duration="1000"/>
    </mx:children>
  </mx:Sequence>

  <mx:VBox id="myBox" hideEffect="{WipeRightUp}">
    <mx:TextArea id="aTextArea" text="hello"/>
  </mx:VBox>

Notice that the <mx:children> tag is optional.

Starting a composite effect in ActionScript is usually a five-step process:

  1. Create instances of the effect objects to be composited together; for example:
    myFadeEffect = new mx.effects.Fade(target);
  2. Set properties, such as duration, on the individual effect objects.
  3. Create an instance of the Sequence effect object; for example:
    mySequenceEffect = new mx.effects.Sequence();
  4. Call the addChild() method for each of the effect objects; for example:
    mySequenceEffect.addChild(myFadeEffect);
  5. Invoke the Sequence effect's play() method; for example:
    mySequenceEffect.play();

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Sequence> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Sequence id="identifier">
    <mx:children>
      <!-- Specify child effect tags -->
    </mx:children>
  </mx:Sequence>

View the examples.

See also

mx.effects.effectClasses.SequenceInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | children : Array An Array containing the child effects of this CompositeEffect. | CompositeEffect
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Sequence(target:Object = null)
Constructor.
Sequence
Inherited
addChild(childEffect:Effect):void
Adds a new child effect to this composite effect.
CompositeEffect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Constructor detail
Sequence () constructor
public function Sequence(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — This argument is ignored for Sequence effects. It is included only for consistency with other types of effects.
Examples
SequenceEffectExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Sequence effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[
            import mx.effects.easing.*;
        ]]>
    </mx:Script>

    <mx:Sequence id="movePauseMove">
        <mx:Move xBy="150" duration="2000" easingFunction="Bounce.easeOut"/>
        <mx:Pause duration="2000"/>
        <mx:Move xBy="-150" duration="2000" easingFunction="Bounce.easeIn"/>
    </mx:Sequence>

    <mx:Panel title="Sequence Effect Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the phone image to start the Sequence effect. The effect pauses for 2 seconds between moves."/>

        <mx:Image
            source="@Embed(source='assets/Nokia_6630.png')"
            mouseDownEffect="{movePauseMove}"/>

    </mx:Panel>
</mx:Application>


mx.effects.SetPropertyAction (Flex™ 2 Language Reference)

Class SetPropertyAction | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class SetPropertyAction
Inheritance | SetPropertyAction Inheritance Effect Inheritance EventDispatcher Inheritance Object

The SetPropertyAction class defines an action effect that corresponds to the SetProperty property of a view state definition. You use a SetPropertyAction effect within a transition definition to control when the view state change defined by a SetProperty property occurs during the transition.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SetPropertyAction> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:SetPropertyAction
    Properties
    id="ID"
    name=""
    value=""
  />

View the examples.

See also

mx.effects.effectClasses.SetPropertyActionInstance
mx.states.SetProperty

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | name : String The name of the property being changed. | SetPropertyAction
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | value : * The new value for the property. | SetPropertyAction
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SetPropertyAction(target:Object = null)
Constructor.
SetPropertyAction
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Property detail
name property
public var name:String

The name of the property being changed. By default, Flex determines this value from the SetProperty property definition in the view state definition.

value property
public var value:*

The new value for the property. By default, Flex determines this value from the SetProperty property definition in the view state definition.

Constructor detail
SetPropertyAction () constructor
public function SetPropertyAction(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
TransitionExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the Transition class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <mx:transitions>
        <!-- Define the transition from the base state to the Register state.-->
        <mx:Transition id="toRegister" fromState="*" toState="Register">
            <mx:Sequence targets="{[loginPanel, registerLink, confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>

        <!-- Define the transition from the Register state to the base state.-->
        <mx:Transition id="toDefault" fromState="Register" toState="*">
            <mx:Sequence targets="{[loginPanel, registerLink,
                    confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction  target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>
    </mx:transitions>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.effects.SetStyleAction (Flex™ 2 Language Reference)

Class SetStyleAction | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class SetStyleAction
Inheritance | SetStyleAction Inheritance Effect Inheritance EventDispatcher Inheritance Object

The SetStyleAction class defines an action effect that corresponds to the SetStyle property of a view state definition. You use an SetStyleAction effect within a transition definition to control when the view state change defined by a SetStyle property occurs during the transition.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SetStyleAction> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:SetStyleAction
    Properties
    id="ID"
    style=""
    value=""
  />

View the examples.

See also

mx.effects.effectClasses.SetStyleActionInstance
mx.states.SetStyle

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | name : String The name of the style property being changed. | SetStyleAction
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
 | relevantStyles : Array Contains the style properties modified by this effect. | SetStyleAction
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | value : * The new value for the style property. | SetStyleAction
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SetStyleAction(target:Object = null)
Constructor.
SetStyleAction
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Property detail
name property
public var name:String

The name of the style property being changed. By default, Flex determines this value from the SetStyle property definition in the view state definition.

relevantStyles property
relevantStyles:Array [read-write]

Contains the style properties modified by this effect. This getter method overrides the superclass method.

If you create a subclass of this class to create a custom effect, you must override this method and return an Array that contains a list of the style properties modified by your subclass.

Implementation
    public function get relevantStyles():Array
    public function set relevantStyles(value:Array):void

See also

mx.effects.Effect.getAffectedProperties()
value property
public var value:*

The new value for the style property. By default, Flex determines this value from the SetStyle property definition in the view state definition.

Constructor detail
SetStyleAction () constructor
public function SetStyleAction(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
TransitionExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the Transition class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <mx:transitions>
        <!-- Define the transition from the base state to the Register state.-->
        <mx:Transition id="toRegister" fromState="*" toState="Register">
            <mx:Sequence targets="{[loginPanel, registerLink, confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>

        <!-- Define the transition from the Register state to the base state.-->
        <mx:Transition id="toDefault" fromState="Register" toState="*">
            <mx:Sequence targets="{[loginPanel, registerLink,
                    confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction  target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>
    </mx:transitions>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.effects.SoundEffect (Flex™ 2 Language Reference)

Class SoundEffect | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class SoundEffect
Inheritance | SoundEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The SoundEffect class plays an MP3 audio file. For example, you could play a sound when a user clicks a Button control. This effect lets you repeat the sound, select the source file, and control the volume and pan.

You specify the MP3 file using the source property. If you have already embedded the MP3 file, using the Embed keyword, you can pass the Class object of the MP3 file to the source property. Otherwise, specify the full URL to the MP3 file.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SoundEffect> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:SoundEffect
    Properties
    id="ID"
    autoLoad="true|false"
    bufferTime="1000"
    loops="0"
    panEasingFunction=""
    panFrom="0"
    source=""
    startTime="0"
    useDuration="true|false"
    volumeEasingFunction="true|false"
    volumeTo="1"

    Events
    complete="No default"
    id3="No default"
    ioError="No default"
    progress="No default"
  />

View the examples.

See also

mx.effects.effectClasses.SoundEffectInstance
flash.media.Sound

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | autoLoad : Boolean If true, load the MP3 file when the source has been specified. | SoundEffect
 | bufferTime : Number = 1000 The SoundEffect class uses an internal Sound object to control the MP3 file. | SoundEffect
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
 | isLoading : Boolean [read-only] This property is true if the MP3 has been loaded. | SoundEffect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | loops : int = 0 The number of times to play the sound in a loop, where a value of 0 means play the effect once, a value of 1 means play the effect twice, and so on. | SoundEffect
 | panEasingFunction : Function The easing function for the pan effect. | SoundEffect
 | panFrom : Number Initial pan of the Sound object. | SoundEffect
 | panTo : Number Final pan of the Sound object. | SoundEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
 | sound : Sound [read-only] The Sound object that the MP3 file has been loaded into. | SoundEffect
 | source : Object The URL or class of the MP3 file to play. | SoundEffect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
 | startTime : Number = 0 The initial position in the MP3 file, in milliseconds, at which playback should start. | SoundEffect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | useDuration : Boolean = true If true, stop the effect after the time specified by the duration property has elapsed. | SoundEffect
 | volumeEasingFunction : Function The easing function for the volume effect. | SoundEffect
 | volumeFrom : Number Initial volume of the Sound object. | SoundEffect
 | volumeTo : Number Final volume of the Sound object. | SoundEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SoundEffect(target:Object = null)
Constructor.
SoundEffect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
load():void
Loads the MP3 if the source property points to a URL.
SoundEffect
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
 | complete | Dispatched when the sound file finishes loading. | SoundEffect
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
 | id3 | Dispatched when ID3 data is available for an MP3 sound file. | SoundEffect
 | ioError | Dispatched when an error occurs during the loading of the sound file. | SoundEffect
 | progress | Dispatched periodically as the sound file loads. | SoundEffect
Property detail
autoLoad property
autoLoad:Boolean [read-write]

If true, load the MP3 file when the source has been specified.

The default value is true.

Implementation
    public function get autoLoad():Boolean
    public function set autoLoad(value:Boolean):void
bufferTime property
public var bufferTime:Number = 1000

The SoundEffect class uses an internal Sound object to control the MP3 file. This property specifies the minimum number of milliseconds worth of sound data to hold in the Sound object's buffer. The Sound object waits until it has at least this much data before beginning playback, and before resuming playback after a network stall.

The default value is 1000.

isLoading property
isLoading:Boolean [read-only]

This property is true if the MP3 has been loaded.

Implementation
    public function get isLoading():Boolean
loops property
public var loops:int = 0

The number of times to play the sound in a loop, where a value of 0 means play the effect once, a value of 1 means play the effect twice, and so on. If you repeat the MP3 file, it still uses the setting of the useDuration property to determine the playback time.

The duration property takes precedence over this property. If the effect duration is not long enough to play the sound at least once, the sound does not loop.

The default value is 0.

panEasingFunction property
public var panEasingFunction:Function

The easing function for the pan effect. Use this function to interpolate between the values of panFrom and panTo.

panFrom property
public var panFrom:Number

Initial pan of the Sound object. The value can range from -1.0 to 1.0, where -1.0 uses only the left channel, 1.0 uses only the right channel, and 0.0 balances the sound evenly between the two channels.

The default value is 0.0.

panTo property
public var panTo:Number

Final pan of the Sound object. The value can range from -1.0 to 1.0, where -1.0 uses only the left channel, 1.0 uses only the right channel, and 0.0 balances the sound evenly between the two channels.

The default value is 0.0.

sound property
sound:Sound [read-only]

The Sound object that the MP3 file has been loaded into.

Implementation
    public function get sound():Sound
source property
source:Object [read-write]

The URL or class of the MP3 file to play. If you have already embedded the MP3 file, using the Embed keyword, you can pass the Class object of the MP3 file to the source property. Otherwise, specify the full URL to the MP3 file.

Implementation
    public function get source():Object
    public function set source(value:Object):void
startTime property
public var startTime:Number = 0

The initial position in the MP3 file, in milliseconds, at which playback should start.

The default value is 0.

useDuration property
public var useDuration:Boolean = true

If true, stop the effect after the time specified by the duration property has elapsed. If false, stop the effect after the MP3 finishes playing or looping.

The default value is true.

volumeEasingFunction property
public var volumeEasingFunction:Function

The easing function for the volume effect. This function is used to interpolate between the values of volumeFrom and volumeTo.

volumeFrom property
public var volumeFrom:Number

Initial volume of the Sound object. Value can range from 0.0 to 1.0.

The default value is 1.

volumeTo property
public var volumeTo:Number

Final volume of the Sound object. Value can range from 0.0 to 1.0.

The default value is 1.

Constructor detail
SoundEffect () constructor
public function SoundEffect(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Method detail
load () method
public function load():void

Loads the MP3 if the source property points to a URL.

Event detail
complete event
Event object type: flash.events.Event
Event.type property = flash.events.Event.COMPLETE

Dispatched when the sound file finishes loading.

Defines the value of the type property of a complete event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object that has completed loading. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
id3 event
Event object type: flash.events.Event
Event.type property = flash.events.Event.ID3

Dispatched when ID3 data is available for an MP3 sound file.

Defines the value of the type property of an id3 event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Sound object loading the MP3 for which ID3 data is now available. The target is not always the object in the display list that registered the event listener. Use the currentTarget property to access the object in the display list that is currently processing the event.
ioError event
Event object type: flash.events.IOErrorEvent
IOErrorEvent.type property = flash.events.IOErrorEvent.IO_ERROR

Dispatched when an error occurs during the loading of the sound file.

Defines the value of the type property of an ioError event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object experiencing the input/output error.
text | Text to be displayed as an error message.
progress event
Event object type: flash.events.ProgressEvent
ProgressEvent.type property = flash.events.ProgressEvent.PROGRESS

Dispatched periodically as the sound file loads.

Within the event object, you can access the number of bytes currently loaded and the total number of bytes to load. The event is not guaranteed to be dispatched, which means that the complete event might be dispatched without any progress events being dispatched.

Defines the value of the type property of a progress event object.

This event has the following properties:

Property | Value
bubbles | false
bytesLoaded | The number of items or bytes loaded at the time the listener processes the event.
bytesTotal | The total number of items or bytes that ultimately will be loaded if the loading process succeeds.
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The network object reporting progress.
Examples
SoundEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the SoundEffect effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:SoundEffect id="mySounds" source="@Embed(source='assets/jazz.mp3')"/>

    <mx:Panel title="Sound Effect Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label width="100%" color="blue"
            text="Click on the phone to hear the sound effect."/>

        <mx:Image id="flex" source="@Embed(source='assets/Nokia_6630.png')"
            mouseDownEffect="{mySounds}"/>

    </mx:Panel>
</mx:Application>


mx.effects.Tween (Flex™ 2 Language Reference)

Class Tween | Properties | Methods
Package | mx.effects
Class | public class Tween
Inheritance | Tween Inheritance EventDispatcher Inheritance Object

The Tween class defines a tween, a property animation performed on a target object over a period of time. That animation can be a change in position, such as performed by the Move effect; a change in size, as performed by the Resize or Zoom effects; a change in visibility, as performed by the Fade or Dissolve effects; or other types of animations.

When defining tween effects, you typically create an instance of the Tween class within your override of the EffectInstance.play() method. A Tween instance accepts the startValue, endValue, and duration properties, and an optional easing function to define the animation.

The Tween object invokes the mx.effects.effectClasses.TweenEffectInstance.onTweenUpdate() callback function on a regular interval on the effect instance for the duration of the effect, passing to the onTweenUpdate() method an interpolated value between the startValue and endValue. Typically, the callback function updates some property of the target object, causing that object to animate over the duration of the effect.

When the effect ends, the Tween objects invokes the mx.effects.effectClasses.TweenEffectInstance.onTweenEnd() callback function, if you defined one.

See also

mx.effects.TweenEffect
mx.effects.effectClasses.TweenEffectInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | duration : Number = 3000 Duration of the animation, in milliseconds. | Tween
 | easingFunction : Function [write-only] Sets the easing function for the animation. | Tween
 | listener : Object Object that is notified at each interval of the animation. | Tween
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Tween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1)
Constructor.
Tween
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
endTween():void
Interrupt the tween, jump immediately to the end of the tween, and invoke the onTweenEnd() callback function.
Tween
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
pause():void
Pauses the effect until you call the resume() method.
Tween
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Tween
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
Tween
seek(playheadTime:Number):void
Advances the tween effect to the specified position.
Tween
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setTweenHandlers(updateFunction:Function, endFunction:Function):void
By default, the Tween class invokes the mx.effects.effectClasses.TweenEffectInstance.onTweenUpdate() callback function on a regular interval on the effect instance for the duration of the effect, and the optional mx.effects.effectClasses.TweenEffectInstance.onTweenEnd() callback function at the end of the effect duration.
Tween
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
duration property
public var duration:Number = 3000

Duration of the animation, in milliseconds.

easingFunction property
easingFunction:Function [write-only]

Sets the easing function for the animation. The easing function is used to interpolate between the startValue value and the endValue. A trivial easing function does linear interpolation, but more sophisticated easing functions create the illusion of acceleration and deceleration, which makes the animation seem more natural.

If no easing function is specified, an easing function based on the Math.sin() method is used.

The easing function follows the function signature popularized by Robert Penner. The function accepts four arguments. The first argument is the "current time", where the animation start time is 0. The second argument is a the initial value at the beginning of the animation (a Number). The third argument is the ending value minus the initial value. The fourth argument is the duration of the animation. The return value is the interpolated value for the current time (usually a value between the initial value and the ending value).

Flex includes a set of easing functions in the mx.effects.easing package.

For more information, see http://www.ericd.net/chapter7.pdf.

Implementation
    public function set easingFunction(value:Function):void
listener property
public var listener:Object

Object that is notified at each interval of the animation.

Constructor detail
Tween () constructor
public function Tween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1)

Constructor.

When the constructor is called, the animation automatically starts playing.

Parameters
listener:Object — Object that is notified at each interval of the animation. You typically pass the this keyword as the value. The listener must define the onTweenUpdate() method and optionally the onTweenEnd() method. The former method is invoked for each interval of the animation, and the latter is invoked just after the animation finishes.
startValue:Object — Initial value(s) of the animation. Either a number or an array of numbers. If a number is passed, the Tween interpolates between this number and the number passed in the endValue parameter. If an array of numbers is passed, each number in the array is interpolated.
endValue:Object — Final value(s) of the animation. The type of this argument must match the startValue parameter.
duration:Number (default = -1) — Duration of the animation, expressed in milliseconds.
minFps:Number (default = -1) — Minimum number of times that the onTweenUpdate() method should be called every second. The tween code tries to call the onTweenUpdate() method as frequently as possible (up to 100 times per second). However, if the frequency falls below minFps, the duration of the animation automatically increases. As a result, an animation that temporarily freezes (because it is not getting any CPU cycles) begins again where it left off, instead of suddenly jumping ahead.
Method detail
endTween () method
public function endTween():void

Interrupt the tween, jump immediately to the end of the tween, and invoke the onTweenEnd() callback function.

pause () method
public function pause():void

Pauses the effect until you call the resume() method.

resume () method
public function resume():void

Resumes the effect after it has been paused by a call to the pause() method.

reverse () method
public function reverse():void

Plays the effect in reverse, starting from the current position of the effect.

seek () method
public function seek(playheadTime:Number):void

Advances the tween effect to the specified position.

Parameters
playheadTime:Number — The position, in milliseconds, between 0 and the value of the duration property.
setTweenHandlers () method
public function setTweenHandlers(updateFunction:Function, endFunction:Function):void

By default, the Tween class invokes the mx.effects.effectClasses.TweenEffectInstance.onTweenUpdate() callback function on a regular interval on the effect instance for the duration of the effect, and the optional mx.effects.effectClasses.TweenEffectInstance.onTweenEnd() callback function at the end of the effect duration.

This method lets you specify different methods as the update and the end callback functions.

Parameters
updateFunction:Function — Specifies the update callback function.
endFunction:Function — Specifies the end callback function.


mx.effects.TweenEffect (Flex™ 2 Language Reference)

Class TweenEffect | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class TweenEffect
Inheritance | TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object
Subclasses | AnimateProperty, Blur, Dissolve, Fade, Glow, Move, Pause, Resize, Rotate, SeriesEffect, Zoom

The TweenEffect class is the superclass for all effects that are based on the Tween object. This class encapsulates methods and properties that are common among all Tween-based effects, to avoid duplication of code elsewhere.

You create a subclass of the TweenEffect class to define an effect that plays an animation over a period of time. For example, the Resize effect modifies the size of its target over a specified duration.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:TweenEffect> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:TagName
    Properties
    easingFunction="easing function name; no default"

    Events
    tweenEnd="No default"
  />

View the examples.

See also

mx.effects.Tween
mx.effects.effectClasses.TweenEffectInstance
About creating a custom effect
Example: Creating a tween effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
 | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TweenEffect(target:Object = null)
Constructor.
TweenEffect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
 | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
 | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
 | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
 | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
easingFunction property
public var easingFunction:Function = null

The easing function for the animation. The easing function is used to interpolate between the initial value and the final value. A trivial easing function would simply do linear interpolation, but more sophisticated easing functions create the illusion of acceleration and deceleration, which makes the animation seem more natural.

If no easing function is specified, an easing function based on the Math.sin() method is used.

The easing function follows the function signature popularized by Robert Penner. The function accepts four arguments. The first argument is the "current time", where the animation start time is 0. The second argument is the initial value at the beginning of the animation (a Number). The third argument is the ending value minus the initial value. The fourth argument is the duration of the animation. The return value is the interpolated value for the current time. This is usually a value between the initial value and the ending value.

The value of this property must be a function object.

Flex includes a set of easing functions in the mx.effects.easing package.

For more information, see http://www.ericd.net/chapter7.pdf.

Constructor detail
TweenEffect () constructor
public function TweenEffect(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Method detail
tweenEventHandler () method
protected function tweenEventHandler(event:TweenEvent):void

Called when the TweenEffect dispatches a TweenEvent. If you override this method, ensure that you call the super method.

Parameters
event:TweenEvent — An event object of type TweenEvent.
Event detail
tweenEnd event
Event object type: mx.events.TweenEvent
TweenEvent.type property = mx.events.TweenEvent.TWEEN_END

Dispatched when the tween effect ends. This event corresponds to a call to the TweenEffectInstance.onTweenEnd() method.

When a tween effect plays a single time, this event occurs at the same time as an effectEnd event. If you configure the tween effect to repeat, it occurs at the end of every repetition of the effect, and the endEffect event occurs after the effect plays for the final time.

The TweenEvent.TWEEN_END constant defines the value of the event object's type property for a tweenEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenEnd() method.
tweenStart event
Event object type: mx.events.TweenEvent
TweenEvent.type property = mx.events.TweenEvent.TWEEN_START

Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. Flex also dispatches the first tweenUpdate event for the effect at the same time.

The Effect.effectStart event is dispatched before the tweenStart event.

The TweenEvent.TWEEN_START constant defines the value of the event object's type property for a tweenStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenUpdate() method.
tweenUpdate event
Event object type: mx.events.TweenEvent
TweenEvent.type property = mx.events.TweenEvent.TWEEN_UPDATE

Dispatched every time the tween effect updates the target. This event corresponds to a call to the TweenEffectInstance.onTweenUpdate() method.

The TweenEvent.TWEEN_UPDATE constant defines the value of the event object's type property for a tweenUpdate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenUpdate() method.
Examples
SimpleTweenEffectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the TweenEffect class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.events.TweenEvent;

            // Event handler for the tweenUpdate and tweenEnd effects.
            private function tweenUpdateHandler(event:TweenEvent):void {
                // Access current width of the image.
                currentWidth.text="Current width (in pixels): " + String(event.value[0]);
            }

            // Event handler for the reset button.
            private function resetHandler():void {
                expand.end();
                img.width=30;
                currentWidth.text="Current width (in pixels): 30";
                img.height=60;
                button1.enabled=true;
            }
        ]]>
    </mx:Script>

    <mx:Resize id="expand" target="{img}" widthTo="100" heightTo="200"
        duration="10000"
        tweenUpdate="tweenUpdateHandler(event);"
        tweenEnd="tweenUpdateHandler(event);"/>

    <mx:Panel title="Resize Effect Example" width="100%" height="100%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Use the Button controls to resize the image."/>

        <mx:HBox width="100%">
            <mx:Image id="img" width="30" height="60"
                source="@Embed(source='assets/Nokia_6630.png')"/>
            <mx:Text id="currentWidth" height="20" width="100%"/>
        </mx:HBox>

        <mx:ControlBar>
            <mx:Button id="button1" label="Start" click="expand.play(); button1.enabled=false;"/>
            <mx:Button label="Pause" click="expand.pause();"/>
            <mx:Button label="Resume" click="expand.resume();"/>
            <mx:Button label="Reverse" click="expand.reverse();"/>
            <mx:Button label="End" click="expand.end();"/>
            <mx:Button label="Reset" click="resetHandler();"/>
        </mx:ControlBar>

    </mx:Panel>
</mx:Application>


mx.effects.WipeDown (Flex™ 2 Language Reference)

Class WipeDown | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class WipeDown
Inheritance | WipeDown Inheritance MaskEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The WipeDown class defines a bar wipe down effect. The before or after state of the component must be invisible.

You often use this effect with the showEffect and hideEffect triggers. The showEffect trigger occurs when a component becomes visible by changing its visible property from false to true. The hideEffect trigger occurs when the component becomes invisible by changing its visible property from true to false.

This effect inherits the MaskEffect.show property. If you set the value to true, the component appears. If you set the value to false, the component disappears. The default value is true.

If you specify this effect for a showEffect or hideEffect trigger, Flex sets the show property for you, either to true if the component becomes invisible, or false if the component becomes visible.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:WipeDown> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:WipeDown
    id="ID"
  />

View the examples.

See also

mx.effects.effectClasses.WipeDownInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffect
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffect
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffect
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffect
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffect
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffect
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, true, or invisible, false. | MaskEffect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffect
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffect
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffect
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeDown(target:Object = null)
Constructor.
WipeDown
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns the component properties modified by this effect.
MaskEffect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | MaskEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the effect ends. | MaskEffect
Inherited | tweenStart | Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods. | MaskEffect
Inherited | tweenUpdate | Dispatched every time the effect updates the target. | MaskEffect
Constructor detail
WipeDown () constructor
public function WipeDown(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
WipeDownExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the WipeDown effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:WipeDown id="wipeOut" duration="1000"/>
    <mx:WipeDown id="wipeIn" duration="1000"/>

    <mx:Panel title="WipeDown Effect Example" width="95%" height="95%"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:Text width="100%" color="blue"
            text="Use the WipeDown effect to show or hide the text and image."/>

        <mx:Label text="Nokia 9930"
            fontSize="14"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:Image source="@Embed(source='assets/Nokia_6630.png')"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:CheckBox id="cb1" label="visible" selected="true"/>

    </mx:Panel>
</mx:Application>


mx.effects.WipeLeft (Flex™ 2 Language Reference)

Class WipeLeft | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class WipeLeft
Inheritance | WipeLeft Inheritance MaskEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The WipeLeft class defines a bar wipe left effect. The before or after state of the component must be invisible.

You often use this effect with the showEffect and hideEffect triggers. The showEffect trigger occurs when a component becomes visible by changing its visible property from false to true. The hideEffect trigger occurs when the component becomes invisible by changing its visible property from true to false.

This effect inherits the MaskEffect.show property. If you set the value to true, the component appears. If you set the value to false, the component disappears. The default value is true.

If you specify this effect for a showEffect or hideEffect trigger, Flex sets the show property for you, either to true if the component becomes invisible, or false if the component becomes visible.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:WipeLeft> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:WipeLeft
    id="ID"
  />

View the examples.

See also

mx.effects.effectClasses.WipeLeftInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffect
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffect
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffect
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffect
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffect
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffect
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, true, or invisible, false. | MaskEffect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffect
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffect
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffect
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeLeft(target:Object = null)
Constructor.
WipeLeft
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns the component properties modified by this effect.
MaskEffect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | MaskEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the effect ends. | MaskEffect
Inherited | tweenStart | Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods. | MaskEffect
Inherited | tweenUpdate | Dispatched every time the effect updates the target. | MaskEffect
Constructor detail
WipeLeft () constructor
public function WipeLeft(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
WipeLeftExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the WipeLeft effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:WipeLeft id="wipeOut" duration="1000"/>
    <mx:WipeLeft id="wipeIn" duration="1000"/>

    <mx:Panel title="WipeLeft Effect Example" width="95%" height="95%"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:Text width="100%" color="blue"
            text="Use the WipeLeft effect to show or hide the text and image."/>

        <mx:Label text="Nokia 9930"
            fontSize="14"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:Image source="@Embed(source='assets/Nokia_6630.png')"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:CheckBox id="cb1" label="visible" selected="true"/>

    </mx:Panel>
</mx:Application>


mx.effects.WipeRight (Flex™ 2 Language Reference)

Class WipeRight | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class WipeRight
Inheritance | WipeRight Inheritance MaskEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The WipeRight class defines a bar wipe right effect. The before or after state of the component must be invisible.

You often use this effect with the showEffect and hideEffect triggers. The showEffect trigger occurs when a component becomes visible by changing its visible property from false to true. The hideEffect trigger occurs when the component becomes invisible by changing its visible property from true to false.

This effect inherits the MaskEffect.show property. If you set the value to true, the component appears. If you set the value to false, the component disappears. The default value is true.

If you specify this effect for a showEffect or hideEffect trigger, Flex sets the show property for you, either to true if the component becomes invisible, or false if the component becomes visible.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:WipeRight> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:WipeRight
    id="ID"
  />

View the examples.

See also

mx.effects.effectClasses.WipeRightInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffect
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffect
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffect
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffect
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffect
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffect
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, true, or invisible, false. | MaskEffect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffect
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffect
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffect
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeRight(target:Object = null)
Constructor.
WipeRight
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns the component properties modified by this effect.
MaskEffect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | MaskEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the effect ends. | MaskEffect
Inherited | tweenStart | Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods. | MaskEffect
Inherited | tweenUpdate | Dispatched every time the effect updates the target. | MaskEffect
Constructor detail
WipeRight () constructor
public function WipeRight(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
WipeRightExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the WipeRight effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:WipeRight id="wipeOut" duration="1000"/>
    <mx:WipeRight id="wipeIn" duration="1000"/>

    <mx:Panel title="WipeRight Effect Example" width="95%" height="95%"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:Text width="100%" color="blue"
            text="Use the WipeRight effect to show or hide the text and image."/>

        <mx:Label text="Nokia 9930"
            fontSize="14"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:Image source="@Embed(source='assets/Nokia_6630.png')"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:CheckBox id="cb1" label="visible" selected="true"/>

    </mx:Panel>
</mx:Application>


mx.effects.WipeUp (Flex™ 2 Language Reference)

Class WipeUp | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class WipeUp
Inheritance | WipeUp Inheritance MaskEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The WipeUp class defines a bar wipe up effect. The before or after state of the component must be invisible.

You often use this effect with the showEffect and hideEffect triggers. The showEffect trigger occurs when a component becomes visible by changing its visible property from false to true. The hideEffect trigger occurs when the component becomes invisible by changing its visible property from true to false.

This effect inherits the MaskEffect.show property. If you set the value to true, the component appears. If you set the value to false, the component disappears. The default value is true.

If you specify this effect for a showEffect or hideEffect trigger, Flex sets the show property for you, either to true if the component becomes invisible, or false if the component becomes visible.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:WipeUp> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:WipeUp
    id="ID"
  />

View the examples.

See also

mx.effects.effectClasses.WipeUpInstance

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffect
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffect
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffect
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffect
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffect
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffect
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffect
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, true, or invisible, false. | MaskEffect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffect
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffect
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffect
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffect
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeUp(target:Object = null)
Constructor.
WipeUp
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns the component properties modified by this effect.
MaskEffect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | MaskEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the effect ends. | MaskEffect
Inherited | tweenStart | Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods. | MaskEffect
Inherited | tweenUpdate | Dispatched every time the effect updates the target. | MaskEffect
Constructor detail
WipeUp () constructor
public function WipeUp(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
WipeUpExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the WipeUp effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:WipeUp id="wipeOut" duration="1000"/>
    <mx:WipeUp id="wipeIn" duration="1000"/>

    <mx:Panel title="WipeUp Effect Example" width="95%" height="95%"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:Text width="100%" color="blue"
            text="Use the WipeUp effect to show or hide the text and image."/>

        <mx:Label text="Nokia 9930"
            fontSize="14"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:Image source="@Embed(source='assets/Nokia_6630.png')"
            visible="{cb1.selected}"
            hideEffect="{wipeOut}" showEffect="{wipeIn}"/>

        <mx:CheckBox id="cb1" label="visible" selected="true"/>

    </mx:Panel>
</mx:Application>


mx.effects.Zoom (Flex™ 2 Language Reference)

Class Zoom | Properties | Methods | Events | Examples
Package | mx.effects
Class | public class Zoom
Inheritance | Zoom Inheritance TweenEffect Inheritance Effect Inheritance EventDispatcher Inheritance Object

The Zoom effect zooms the object in or out on a center point.

When you apply a Zoom effect to text rendered using a system font, Flex scales the text between whole point sizes. While you do not have to use embedded fonts when you apply a Zoom effect to text, the Zoom will appear smoother when you apply it to embedded fonts.

Note: The Zoom effect does not work when the Container.autoLayout property is false.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Zoom> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Zoom
    id="ID"
    captureRollEvents="false|true"
    originX="Calculated"
    originY="Calculated"
    zoomWidthFrom="0.01"
    zoomWidthTo="1.0"
    zoomHeightFrom="0.01"
    zoomHeightTo="1.0"
  />

View the examples.

See also

mx.effects.effectClasses.ZoomInstance
mx.managers.LayoutManager

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | captureRollEvents : Boolean If true, prevents Flex from dispatching the rollOut and rollOver events if the mouse has not moved. | Zoom
Inherited | className : String The name of the effect class, such as "Fade". | Effect
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | customFilter : EffectTargetFilter Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect. | Effect
Inherited | duration : Number Duration of the effect in milliseconds. | Effect
Inherited | easingFunction : Function = null The easing function for the animation. | TweenEffect
Inherited | filter : String Specifies an algorithm for filtering targets for an effect. | Effect
Inherited | instanceClass : Class An object of type Class that specifies the effect instance class class for this effect class. | Effect
Inherited | isPlaying : Boolean A read-only flag which is true if any instances of the effect are currently playing, and false if none are. | Effect
 | originX : Number Number that represents the x-position of the zoom origin when the effect target is in a container that supports absolute positioning, such as the Canvas container. | Zoom
 | originY : Number Number that represents the y-position of the zoom origin when the effect target is in a container that supports absolute positioning, such as the Canvas container. | Zoom
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relevantProperties : Array An Array of property names to use when performing filtering. | Effect
Inherited | relevantStyles : Array An Array of style names to use when performing filtering. | Effect
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | Effect
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | Effect
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | Effect
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | Effect
Inherited | target : Object The UIComponent object to which this effect is applied. | Effect
Inherited | targets : Array An Array of UIComponent objects that are targets for the effect. | Effect
 | zoomHeightFrom : Number Number that represents the scale at which to start the height zoom, as a percent between 0.01 and 1.0. | Zoom
 | zoomHeightTo : Number Number that represents the scale at which to complete the height zoom, as a percent between 0.01 and 1.0. | Zoom
 | zoomWidthFrom : Number Number that represents the scale at which to start the width zoom, as a percent between 0.01 and 1.0. | Zoom
 | zoomWidthTo : Number Number that represents the scale at which to complete the width zoom, as a percent between 0.01 and 1.0. | Zoom
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Zoom(target:Object = null)
Constructor.
Zoom
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
captureStartValues():void
Captures the current values of the relevant properties on the effect's targets.
Effect
Inherited
createInstance(target:Object = null):EffectInstance
Creates a single effect instance and initializes it.
Effect
Inherited
createInstances(targets:Array = null):Array
Takes an Array of target objects and invokes the createInstance() method on each target.
Effect
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end(effectInstance:EffectInstance = null):void
Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
Effect
Inherited
getAffectedProperties():Array
Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
Effect
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
Effect
Inherited
play(targets:Array = null, playReversedFromEnd:Boolean = false):Array
Begins playing the effect.
Effect
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
Effect
Inherited
reverse():void
Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
Effect
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | applyValueToTarget(target:Object, property:String, value:*, props:Object):void Used internally by the Effect infrastructure. | Effect
Inherited | effectEndHandler(event:EffectEvent):void Called when an effect instance has finished playing. | Effect
Inherited | effectStartHandler(event:EffectEvent):void This method is called when the effect instance starts playing. | Effect
Inherited | filterInstance(propChanges:Array, targ:Object):Boolean Determines the logic for filtering out an effect instance. | Effect
Inherited | getValueFromTarget(target:Object, property:String):* Called by the captureStartValues() method to get the value of a property from the target. | Effect
Inherited | initInstance(instance:EffectInstance):void Copies properties of the effect to the effect instance. | Effect
Inherited | tweenEventHandler(event:TweenEvent):void Called when the TweenEffect dispatches a TweenEvent. | TweenEffect
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | effectEnd | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method. | Effect
Inherited | effectStart | Dispatched when the effect starts playing. | Effect
Inherited | tweenEnd | Dispatched when the tween effect ends. | TweenEffect
Inherited | tweenStart | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method. | TweenEffect
Inherited | tweenUpdate | Dispatched every time the tween effect updates the target. | TweenEffect
Property detail
captureRollEvents property
public var captureRollEvents:Boolean

If true, prevents Flex from dispatching the rollOut and rollOver events if the mouse has not moved. Set this property to true when you use the Zoom effect to toggle the effect target between a big and small size.

For example, you use the rollOverEffect to trigger the Zoom effect to reduce the size of the target. As the target shrinks, the mouse pointer is no longer over the target, triggering a rollOut event, and the corresponding rollOutEffect. By setting the captureRollEvents property to true, you prevent Flex from dispatching the rollOut event unless it occurs because you moved the mouse.

The default value is false.

originX property
public var originX:Number

Number that represents the x-position of the zoom origin when the effect target is in a container that supports absolute positioning, such as the Canvas container. The zoom origin is the position on the target around which the Zoom effect is centered.

The value must be between 0 and the width of the target component.

The default value is target.width / 2, which is the center of the target.
originY property
public var originY:Number

Number that represents the y-position of the zoom origin when the effect target is in a container that supports absolute positioning, such as the Canvas container. The zoom origin is the position on the target around which the Zoom effect is centered.

The value must be between 0 and the height of the target component.

The default value is target.height / 2, which is the center of the target.
zoomHeightFrom property
public var zoomHeightFrom:Number

Number that represents the scale at which to start the height zoom, as a percent between 0.01 and 1.0. The default value is 0.01, which is very small.

zoomHeightTo property
public var zoomHeightTo:Number

Number that represents the scale at which to complete the height zoom, as a percent between 0.01 and 1.0. The default value is 1.0, which is the object's normal size.

zoomWidthFrom property
public var zoomWidthFrom:Number

Number that represents the scale at which to start the width zoom, as a percent between 0.01 and 1.0. The default value is 0.01, which is very small.

zoomWidthTo property
public var zoomWidthTo:Number

Number that represents the scale at which to complete the width zoom, as a percent between 0.01 and 1.0. The default value is 1.0, which is the object's normal size.

Constructor detail
Zoom () constructor
public function Zoom(target:Object = null)

Constructor.

Parameters
target:Object (default = null) — The Object to animate with this effect.
Examples
ZoomEffectExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the Zoom effect. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[
            import flash.events.MouseEvent;

            public function doZoom(event:MouseEvent):void {
                if (zoomAll.isPlaying) {
                    zoomAll.reverse();
                }
                else {
                    // If this is a ROLL_OUT event, play the effect backwards.
                    // If this is a ROLL_OVER event, play the effect forwards.
                    zoomAll.play([event.target], event.type == MouseEvent.ROLL_OUT ? true : false);
                }
            }
        ]]>
    </mx:Script>

    <mx:Zoom id="zoomAll" zoomWidthTo="1" zoomHeightTo="1" zoomWidthFrom=".5" zoomHeightFrom=".5"  />

    <mx:Panel title="Zoom Effect Example" width="95%" height="95%" horizontalAlign="center"
        paddingTop="5" paddingLeft="10" paddingRight="10" paddingBottom="5">

        <mx:Text width="100%" color="blue"
            text="Move the mouse over the image to enlarge it. Move the mouse off of the image to shrink it."/>

        <mx:Image id="img"
            source="@Embed(source='assets/Nokia_6630.png')"
            scaleX=".5" scaleY=".5"
            rollOver="doZoom(event)"
            rollOut="doZoom(event)"/>

    </mx:Panel>
</mx:Application>


mx.effects.easing Summary (Flex™ 2 Language Reference)

Package mx.effects.easing | Classes

The mx.effects.easing package contains the easing classes used by effects.

Classes
Class | Description
Back | The Back class defines three easing functions to implement motion with Flex effect classes.
Bounce | The Bounce class defines three easing functions to implement bounce motion with Flex effect classes.
Circular | The Circular class defines three easing functions to implement circular motion with Flex effect classes.
Cubic | The Cubic class defines three easing functions to implement motion with Flex effect classes.
Elastic | The Elastc class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
Exponential | The Exponential class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
Linear | The Linear class defines easing functions to implement linear motion with Flex effect classes.
Quadratic | The Quadratic class defines three easing functions to implement quadratic motion with Flex effect classes.
Quartic | The Quartic class defines three easing functions to implement motion with Flex effect classes.
Quintic | The Quintic class defines three easing functions to implement motion with Flex effect classes.
Sine | The Sine class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by a sine wave.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.effects.easing.Back (Flex™ 2 Language Reference)

Class Back | Properties | Methods
Package | mx.effects.easing
Class | public class Back
Inheritance | Back Inheritance Object

The Back class defines three easing functions to implement motion with Flex effect classes. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number, s:Number = 0):Number [static] The easeIn() method starts the motion by backtracking, then reversing direction and moving toward the target. | Back
 | easeInOut(t:Number, b:Number, c:Number, d:Number, s:Number = 0):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion by backtracking, then reversing direction and moving toward target, overshooting target slightly, reversing direction again, and then moving back toward the target. | Back
 | easeOut(t:Number, b:Number, c:Number, d:Number, s:Number = 0):Number [static] The easeOut() method starts the motion by moving towards the target, overshooting it slightly, and then reversing direction back toward the target. | Back
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number, s:Number = 0):Number

The easeIn() method starts the motion by backtracking, then reversing direction and moving toward the target.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.
s:Number (default = 0) — Specifies the amount of overshoot, where the higher the value, the greater the overshoot.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number, s:Number = 0):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion by backtracking, then reversing direction and moving toward target, overshooting target slightly, reversing direction again, and then moving back toward the target.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.
s:Number (default = 0) — Specifies the amount of overshoot, where the higher the value, the greater the overshoot.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number, s:Number = 0):Number

The easeOut() method starts the motion by moving towards the target, overshooting it slightly, and then reversing direction back toward the target.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.
s:Number (default = 0) — Specifies the amount of overshoot, where the higher the value, the greater the overshoot.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Bounce (Flex™ 2 Language Reference)

Class Bounce | Properties | Methods
Package | mx.effects.easing
Class | public class Bounce
Inheritance | Bounce Inheritance Object

The Bounce class defines three easing functions to implement bounce motion with Flex effect classes. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts the bounce motion fast, and then decelerates motion as it executes. | Bounce
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the bounce motion slowly, accelerate motion, then decelerate. | Bounce
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts the bounce motion slowly, and then accelerates motion as it executes. | Bounce
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts the bounce motion fast, and then decelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the bounce motion slowly, accelerate motion, then decelerate.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts the bounce motion slowly, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Circular (Flex™ 2 Language Reference)

Class Circular | Properties | Methods
Package | mx.effects.easing
Class | public class Circular
Inheritance | Circular Inheritance Object

The Circular class defines three easing functions to implement circular motion with Flex effect classes. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion slowly, and then accelerates motion as it executes. | Circular
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate. | Circular
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion as it executes. | Circular
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion slowly, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Cubic (Flex™ 2 Language Reference)

Class Cubic | Properties | Methods
Package | mx.effects.easing
Class | public class Cubic
Inheritance | Cubic Inheritance Object

The Cubic class defines three easing functions to implement motion with Flex effect classes. The acceleration of motion for a Cubic easing equation is greater than for a Quadratic easing equation. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes. | Cubic
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from zero velocity, accelerates motion, then decelerates back to a zero velocity. | Cubic
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes. | Cubic
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from zero velocity, accelerates motion, then decelerates back to a zero velocity.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Elastic (Flex™ 2 Language Reference)

Class Elastic | Properties | Methods
Package | mx.effects.easing
Class | public class Elastic
Inheritance | Elastic Inheritance Object

The Elastc class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number, a:Number = 0, p:Number = 0):Number [static] The easeIn() method starts motion slowly, and then accelerates motion as it executes. | Elastic
 | easeInOut(t:Number, b:Number, c:Number, d:Number, a:Number = 0, p:Number = 0):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate. | Elastic
 | easeOut(t:Number, b:Number, c:Number, d:Number, a:Number = 0, p:Number = 0):Number [static] The easeOut() method starts motion fast, and then decelerates motion as it executes. | Elastic
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number, a:Number = 0, p:Number = 0):Number

The easeIn() method starts motion slowly, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.
a:Number (default = 0) — Specifies the amplitude of the sine wave.
p:Number (default = 0) — Specifies the period of the sine wave.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number, a:Number = 0, p:Number = 0):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.
a:Number (default = 0) — Specifies the amplitude of the sine wave.
p:Number (default = 0) — Specifies the period of the sine wave.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number, a:Number = 0, p:Number = 0):Number

The easeOut() method starts motion fast, and then decelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.
a:Number (default = 0) — Specifies the amplitude of the sine wave.
p:Number (default = 0) — Specifies the period of the sine wave.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Exponential (Flex™ 2 Language Reference)

Class Exponential | Properties | Methods
Package | mx.effects.easing
Class | public class Exponential
Inheritance | Exponential Inheritance Object

The Exponential class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion slowly, and then accelerates motion as it executes. | Exponential
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate. | Exponential
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion as it executes. | Exponential
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion slowly, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Linear (Flex™ 2 Language Reference)

Class Linear | Properties | Methods
Package | mx.effects.easing
Class | public class Linear
Inheritance | Linear Inheritance Object

The Linear class defines easing functions to implement linear motion with Flex effect classes. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes. | Linear
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from zero velocity, accelerate motion, then decelerate back to zero velocity. | Linear
 | easeNone(t:Number, b:Number, c:Number, d:Number):Number [static] The easeNone() method defines a constant motion, with no acceleration. | Linear
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes. | Linear
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from zero velocity, accelerate motion, then decelerate back to zero velocity.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeNone () method
public static function easeNone(t:Number, b:Number, c:Number, d:Number):Number

The easeNone() method defines a constant motion, with no acceleration.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Quadratic (Flex™ 2 Language Reference)

Class Quadratic | Properties | Methods
Package | mx.effects.easing
Class | public class Quadratic
Inheritance | Quadratic Inheritance Object

The Quadratic class defines three easing functions to implement quadratic motion with Flex effect classes. The acceleration of motion for a Quadratic easing equation is slower than for a Cubic or Quartic easing equation. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion from a zero velocity, and then accelerates motion as it executes. | Quadratic
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity. | Quadratic
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes. | Quadratic
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion from a zero velocity, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Quartic (Flex™ 2 Language Reference)

Class Quartic | Properties | Methods
Package | mx.effects.easing
Class | public class Quartic
Inheritance | Quartic Inheritance Object

The Quartic class defines three easing functions to implement motion with Flex effect classes. The acceleration of motion for a Quartic easing equation is greater than for a Quadratic or Cubic easing equation. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion from a zero velocity, and then accelerates motion as it executes. | Quartic
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity. | Quartic
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion to a zero velocity. | Quartic
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion from a zero velocity, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion to a zero velocity.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Quintic (Flex™ 2 Language Reference)

Class Quintic | Properties | Methods
Package | mx.effects.easing
Class | public class Quintic
Inheritance | Quintic Inheritance Object

The Quintic class defines three easing functions to implement motion with Flex effect classes. The acceleration of motion for a Quintic easing equation is greater than for a Quadratic, Cubic, or Quartic easing equation. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes. | Quintic
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity. | Quintic
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes. | Quintic
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.easing.Sine (Flex™ 2 Language Reference)

Class Sine | Properties | Methods
Package | mx.effects.easing
Class | public class Sine
Inheritance | Sine Inheritance Object

The Sine class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by a sine wave. For more information, see http://www.robertpenner.com/profmx.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | easeIn(t:Number, b:Number, c:Number, d:Number):Number [static] The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes. | Sine
 | easeInOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity. | Sine
 | easeOut(t:Number, b:Number, c:Number, d:Number):Number [static] The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes. | Sine
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
easeIn () method
public static function easeIn(t:Number, b:Number, c:Number, d:Number):Number

The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeInOut () method
public static function easeInOut(t:Number, b:Number, c:Number, d:Number):Number

The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.
easeOut () method
public static function easeOut(t:Number, b:Number, c:Number, d:Number):Number

The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.

Parameters
t:Number — Specifies time.
b:Number — Specifies the initial position of a component.
c:Number — Specifies the total change in position of the component.
d:Number — Specifies the duration of the effect, in milliseconds.

Returns
Number — Number corresponding to the position of the component.


mx.effects.effectClasses Summary (Flex™ 2 Language Reference)

Package mx.effects.effectClasses | Classes

The mx.effects.effectClasses package contains the effect implementation classes corresponding to the effect factory classes in the mx.effects package.

Classes
Class | Description
ActionEffectInstance | The ActionEffectInstance class is the superclass for all action effect instance classes.
AddChildActionInstance | The AddChildActionInstance class implements the instance class for the AddChildAction effect.
AnimatePropertyInstance | The AnimatePropertyInstance class implements the instance class for the AnimateProperty effect.
BlurInstance | The BlurInstance class implements the instance class for the Blur effect.
CompositeEffectInstance | The CompositeEffectInstance class implements the instance class for the CompositeEffect class.
DissolveInstance | The DissolveInstance class implements the instance class for the Dissolve effect.
FadeInstance | The FadeInstance class implements the instance class for the Fade effect.
GlowInstance | The GlowInstance class implements the instance class for the Glow effect.
IrisInstance | The IrisInstance class implements the instance class for the Iris effect.
MaskEffectInstance | The MaskEffectInstance class is an abstract base class that implements the instance class for the MaskEffect class.
MoveInstance | The MoveInstance class implements the instance class for the Move effect.
ParallelInstance | The ParallelInstance class implements the instance class for the Parallel effect.
PauseInstance | The PauseInstance class implements the instance class for the Pause effect.
PropertyChanges | The PropertyChanges class defines the start and end values for a set of properties of a target component of a transition.
RemoveChildActionInstance | The RemoveChildActionInstance class implements the instance class for the RemoveChildAction effect.
ResizeInstance | The ResizeInstance class implements the instance class for the Resize effect.
RotateInstance | The RotateInstance class implements the instance class for the Rotate effect.
SequenceInstance | The SequenceInstance class implements the instance class for the Sequence effect.
SetPropertyActionInstance | The SetPropertyActionInstance class implements the instance class for the SetPropertyAction effect.
SetStyleActionInstance | The SetStyleActionInstance class implements the instance class for the SetStyleAction effect.
SoundEffectInstance | The SoundEffectInstance class implements the instance class for the SoundEffect effect.
TweenEffectInstance | The TweenEffectInstance class implements the instance class for the TweenEffect.
WipeDownInstance | The WipeDownInstance class implements the instance class for the WipeDown effect.
WipeLeftInstance | The WipeLeftInstance class implements the instance class for the WipeLeft effect.
WipeRightInstance | The WipeRightInstance class implements the instance class for the WipeRight effect.
WipeUpInstance | The WipeUpInstance class implements the instance class for the WipeUp effect.
ZoomInstance | The ZoomInstance class implements the instance class for the Zoom effect.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.effects.effectClasses.ActionEffectInstance (Flex™ 2 Language Reference)

Class ActionEffectInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class ActionEffectInstance
Inheritance | ActionEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object
Subclasses | AddChildActionInstance, RemoveChildActionInstance, SetPropertyActionInstance, SetStyleActionInstance

The ActionEffectInstance class is the superclass for all action effect instance classes.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Protected Properties
Property |  | Defined by
 | playedAction : Boolean = false Indicates whether the effect has been played (true), or not (false). | ActionEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ActionEffectInstance(target:Object)
Constructor.
ActionEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | getStartValue():* Used internally to retrieve the values saved by the saveStartValue() method. | ActionEffectInstance
 | saveStartValue():* Subclasses implement this method to save the starting state before the effect plays. | ActionEffectInstance
Property detail
playedAction property
protected var playedAction:Boolean = false

Indicates whether the effect has been played (true), or not (false).

The play() method sets this property to true after the effect plays; you do not set it directly.

Constructor detail
ActionEffectInstance () constructor
public function ActionEffectInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.
Method detail
getStartValue () method
protected function getStartValue():*

Used internally to retrieve the values saved by the saveStartValue() method.

Returns
*
saveStartValue () method
protected function saveStartValue():*

Subclasses implement this method to save the starting state before the effect plays.

Returns
*


mx.effects.effectClasses.AddChildActionInstance (Flex™ 2 Language Reference)

Class AddChildActionInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class AddChildActionInstance
Inheritance | AddChildActionInstance Inheritance ActionEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The AddChildActionInstance class implements the instance class for the AddChildAction effect. Flex creates an instance of this class when it plays an AddChildAction effect; you do not create one yourself.

See also

mx.effects.AddChildAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | index : int = -1 The index of the child within the parent. | AddChildActionInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
 | position : String The position of the child component, relative to relativeTo, where it is added. | AddChildActionInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relativeTo : DisplayObjectContainer The location where the child component is added. | AddChildActionInstance
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | playedAction : Boolean = false Indicates whether the effect has been played (true), or not (false). | ActionEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AddChildActionInstance(target:Object)
Constructor.
AddChildActionInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | getStartValue():* Used internally to retrieve the values saved by the saveStartValue() method. | ActionEffectInstance
Inherited | saveStartValue():* Subclasses implement this method to save the starting state before the effect plays. | ActionEffectInstance
Property detail
index property
public var index:int = -1

The index of the child within the parent.

position property
public var position:String

The position of the child component, relative to relativeTo, where it is added.

relativeTo property
public var relativeTo:DisplayObjectContainer

The location where the child component is added.

Constructor detail
AddChildActionInstance () constructor
public function AddChildActionInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.AnimatePropertyInstance (Flex™ 2 Language Reference)

Class AnimatePropertyInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class AnimatePropertyInstance
Inheritance | AnimatePropertyInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The AnimatePropertyInstance class implements the instance class for the AnimateProperty effect. Flex creates an instance of this class when it plays an AnimateProperty effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the AnimateProperty effect, the TweenEvent.value property contains a Number between the values of the AnimateProperty.fromValue and AnimateProperty.toValue properties, for the target property specified by AnimateProperty.property.

See also

mx.effects.AnimateProperty
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | fromValue : Number The starting value of the property for the effect. | AnimatePropertyInstance
 | isStyle : Boolean = false If true, the property attribute is a style and you set it by using the setStyle() method. | AnimatePropertyInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
 | property : String The name of the property on the target to animate. | AnimatePropertyInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
 | roundValue : Boolean = false If true, round off the interpolated tweened value to the nearest integer. | AnimatePropertyInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
 | toValue : Number The ending value for the effect. | AnimatePropertyInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AnimatePropertyInstance(target:Object)
Constructor.
AnimatePropertyInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
fromValue property
public var fromValue:Number

The starting value of the property for the effect. The default value is the target's current property value.

isStyle property
public var isStyle:Boolean = false

If true, the property attribute is a style and you set it by using the setStyle() method.

The default value is false.

property property
public var property:String

The name of the property on the target to animate. This attribute is required.

roundValue property
public var roundValue:Boolean = false

If true, round off the interpolated tweened value to the nearest integer. This property is useful if the property you are animating is an int or uint.

The default value is false.

toValue property
public var toValue:Number

The ending value for the effect. The default value is the target's current property value.

Constructor detail
AnimatePropertyInstance () constructor
public function AnimatePropertyInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.BlurInstance (Flex™ 2 Language Reference)

Class BlurInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class BlurInstance
Inheritance | BlurInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The BlurInstance class implements the instance class for the Blur effect. Flex creates an instance of this class when it plays a Blur effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Blur effect, the TweenEvent.value property contains a 2-item Array, where:

  • value[0]:Number A value between the values of the Blur.blurXTo and Blur.blurXFrom property, applied to the target's BlurFilter.blurX property.
  • value[1]:Number A value between the values of the Blur.blurYTo and Blur.blurYFrom property, applied to the target's BlurFilter.blurY property.

See also

mx.effects.Blur
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | blurXFrom : Number The starting amount of horizontal blur. | BlurInstance
 | blurXTo : Number The ending amount of horizontal blur. | BlurInstance
 | blurYFrom : Number The starting amount of vertical blur. | BlurInstance
 | blurYTo : Number The ending amount of vertical blur. | BlurInstance
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BlurInstance(target:Object)
Constructor.
BlurInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
blurXFrom property
public var blurXFrom:Number

The starting amount of horizontal blur.

blurXTo property
public var blurXTo:Number

The ending amount of horizontal blur.

blurYFrom property
public var blurYFrom:Number

The starting amount of vertical blur.

blurYTo property
public var blurYTo:Number

The ending amount of vertical blur.

Constructor detail
BlurInstance () constructor
public function BlurInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.CompositeEffectInstance (Flex™ 2 Language Reference)

Class CompositeEffectInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class CompositeEffectInstance
Inheritance | CompositeEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object
Subclasses | ParallelInstance, SequenceInstance

The CompositeEffectInstance class implements the instance class for the CompositeEffect class. Flex creates an instance of this class when it plays a CompositeEffect; you do not create one yourself.

See also

mx.effects.CompositeEffect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CompositeEffectInstance(target:Object)
Constructor.
CompositeEffectInstance
addChildSet(childSet:Array):void
Adds a new set of child effects to this Composite effect.
CompositeEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
onTweenEnd(value:Object):void
Used internally to keep track of the value of the playheadTime property.
CompositeEffectInstance
onTweenUpdate(value:Object):void
Used internally to keep track of the value of the playheadTime property.
CompositeEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | onEffectEnd(childEffect:EffectInstance):void Called each time one of the child effects has finished playing. | CompositeEffectInstance
Constructor detail
CompositeEffectInstance () constructor
public function CompositeEffectInstance(target:Object)

Constructor.

Parameters
target:Object — This argument is ignored for Composite effects. It is included only for consistency with other types of effects.
Method detail
addChildSet () method
public function addChildSet(childSet:Array):void

Adds a new set of child effects to this Composite effect. A Sequence effect plays each child effect set one at a time, in the order that it is added. A Parallel effect plays all child effect sets simultaneously; the order in which they are added doesn't matter.

Parameters
childSet:Array — Array of child effects to be added to the CompositeEffect.
onEffectEnd () method
protected function onEffectEnd(childEffect:EffectInstance):void

Called each time one of the child effects has finished playing. Subclasses must implement this function.

Parameters
childEffect:EffectInstance — child effect.
onTweenEnd () method
public function onTweenEnd(value:Object):void

Used internally to keep track of the value of the playheadTime property.

Parameters
value:Object
onTweenUpdate () method
public function onTweenUpdate(value:Object):void

Used internally to keep track of the value of the playheadTime property.

Parameters
value:Object


mx.effects.effectClasses.DissolveInstance (Flex™ 2 Language Reference)

Class DissolveInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class DissolveInstance
Inheritance | DissolveInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The DissolveInstance class implements the instance class for the Dissolve effect. Flex creates an instance of this class when it plays a Dissolve effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Dissolve effect, the TweenEvent.value property contains a Number between the values of the Dissolve.alphaFrom and Dissolve.alphaTo properties.

See also

mx.effects.Dissolve
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphaFrom : Number Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | DissolveInstance
 | alphaTo : Number Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | DissolveInstance
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
 | color : uint = 0xFFFFFFFF Hex value that represents the color of the floating rectangle that the effect displays over the target object. | DissolveInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
 | targetArea : RoundedRectangle The area of the target to play the effect upon. | DissolveInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DissolveInstance(target:Object)
Constructor.
DissolveInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
alphaFrom property
public var alphaFrom:Number

Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

alphaTo property
public var alphaTo:Number

Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

color property
public var color:uint = 0xFFFFFFFF

Hex value that represents the color of the floating rectangle that the effect displays over the target object. The default value is the color specified by the target component's backgroundColor style property, or 0xFFFFFF, if backgroundColor is not set.

targetArea property
public var targetArea:RoundedRectangle

The area of the target to play the effect upon. The dissolve overlay is drawn using this property's dimensions. UIComponents create an overlay over the entire component. Containers create an overlay over their content area, but not their chrome.

Constructor detail
DissolveInstance () constructor
public function DissolveInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.FadeInstance (Flex™ 2 Language Reference)

Class FadeInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class FadeInstance
Inheritance | FadeInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The FadeInstance class implements the instance class for the Fade effect. Flex creates an instance of this class when it plays a Fade effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Fade effect, the TweenEvent.value property contains a Number between the values of the Fade.alphaFrom and Fade.alphaTo properties.

See also

mx.effects.Fade
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphaFrom : Number Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | FadeInstance
 | alphaTo : Number Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque. | FadeInstance
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
FadeInstance(target:Object)
Constructor.
FadeInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
alphaFrom property
public var alphaFrom:Number

Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

alphaTo property
public var alphaTo:Number

Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.

Constructor detail
FadeInstance () constructor
public function FadeInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.GlowInstance (Flex™ 2 Language Reference)

Class GlowInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class GlowInstance
Inheritance | GlowInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The GlowInstance class implements the instance class for the Glow effect. Flex creates an instance of this class when it plays a Glow effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Glow effect, the TweenEvent.value property contains a 4-item Array, where:

  • value[0]:uint The value of the target's GlowFilter.color property.
  • value[1]:Number A value between the values of the Glow.alphaFrom and Glow.alphaTo property.
  • value[2]:Number A value between the values of the Glow.blurXFrom and Glow.blurXTo property.
  • value[3]:Number A value between the values of the Glow.blurYFrom and Glow.blurYTo property.

See also

mx.effects.Glow
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alphaFrom : Number Starting transparency level. | GlowInstance
 | alphaTo : Number Ending transparency level. | GlowInstance
 | blurXFrom : Number The starting amount of horizontal blur. | GlowInstance
 | blurXTo : Number The ending amount of horizontal blur. | GlowInstance
 | blurYFrom : Number The starting amount of vertical blur. | GlowInstance
 | blurYTo : Number The ending amount of vertical blur. | GlowInstance
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
 | color : uint = 0xFFFFFFFF The color of the glow. | GlowInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | inner : Boolean The inner flag of the glow. | GlowInstance
 | knockout : Boolean The knockout flag of the glow. | GlowInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
 | strength : Number The strength of the glow. | GlowInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
GlowInstance(target:Object)
Constructor.
GlowInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
alphaFrom property
public var alphaFrom:Number

Starting transparency level.

alphaTo property
public var alphaTo:Number

Ending transparency level.

blurXFrom property
public var blurXFrom:Number

The starting amount of horizontal blur.

blurXTo property
public var blurXTo:Number

The ending amount of horizontal blur.

blurYFrom property
public var blurYFrom:Number

The starting amount of vertical blur.

blurYTo property
public var blurYTo:Number

The ending amount of vertical blur.

color property
public var color:uint = 0xFFFFFFFF

The color of the glow.

inner property
public var inner:Boolean

The inner flag of the glow.

knockout property
public var knockout:Boolean

The knockout flag of the glow.

strength property
public var strength:Number

The strength of the glow.

Constructor detail
GlowInstance () constructor
public function GlowInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.IrisInstance (Flex™ 2 Language Reference)

Class IrisInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class IrisInstance
Inheritance | IrisInstance Inheritance MaskEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The IrisInstance class implements the instance class for the Iris effect. Flex creates an instance of this class when it plays an Iris effect; you do not create one yourself.

See also

mx.effects.Iris

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffectInstance
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffectInstance
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffectInstance
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffectInstance
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffectInstance
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffectInstance
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, false, or invisible, true. | MaskEffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | targetArea : Rectangle The area where the mask is applied on the target. | MaskEffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffectInstance
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffectInstance
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffectInstance
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | effectMask : Shape Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property. | MaskEffectInstance
Inherited | targetVisualBounds : Rectangle The actual size of the effect target, including any drop shadows. | MaskEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
IrisInstance(target:Object)
Constructor.
IrisInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
MaskEffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
MaskEffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
MaskEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | defaultCreateMask(targ:Object, bounds:Rectangle):Shape Creates the default mask for the effect. | MaskEffectInstance
Inherited | initMaskEffect():void Initializes the move and scale properties of the effect. | MaskEffectInstance
Inherited | onMoveTweenEnd(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onMoveTweenUpdate(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect. | MaskEffectInstance
Inherited | onScaleTweenEnd(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onScaleTweenUpdate(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect. | MaskEffectInstance
Constructor detail
IrisInstance () constructor
public function IrisInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.MaskEffectInstance (Flex™ 2 Language Reference)

Class MaskEffectInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class MaskEffectInstance
Inheritance | MaskEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object
Subclasses | IrisInstance, WipeDownInstance, WipeLeftInstance, WipeRightInstance, WipeUpInstance

The MaskEffectInstance class is an abstract base class that implements the instance class for the MaskEffect class.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Mask effect, the TweenEvent.value property contains a 4-item Array, where:

  • value[0]:Number The value of the target's x property.
  • value[1]:Number The value of the target's y property.
  • value[2]:Number The value of the target's scaleX property.
  • value[3]:Number The value of the target's scaleY property.

See also

mx.effects.MaskEffect
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffectInstance
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
 | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffectInstance
 | scaleXFrom : Number Initial scaleX for mask. | MaskEffectInstance
 | scaleXTo : Number Ending scaleX for mask. | MaskEffectInstance
 | scaleYFrom : Number Initial scaleY for mask. | MaskEffectInstance
 | scaleYTo : Number Ending scaleY for mask. | MaskEffectInstance
 | showTarget : Boolean Specifies that the target component is becoming visible, false, or invisible, true. | MaskEffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
 | targetArea : Rectangle The area where the mask is applied on the target. | MaskEffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
 | xFrom : Number Initial position's x coordinate for mask. | MaskEffectInstance
 | xTo : Number Destination position's x coordinate for mask. | MaskEffectInstance
 | yFrom : Number Initial position's y coordinate for mask. | MaskEffectInstance
 | yTo : Number Destination position's y coordinate for mask. | MaskEffectInstance
Protected Properties
Property |  | Defined by
 | effectMask : Shape Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property. | MaskEffectInstance
 | targetVisualBounds : Rectangle The actual size of the effect target, including any drop shadows. | MaskEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MaskEffectInstance(target:Object)
Constructor.
MaskEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
pause():void
Pauses the effect until you call the resume() method.
MaskEffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
MaskEffectInstance
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
MaskEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | defaultCreateMask(targ:Object, bounds:Rectangle):Shape Creates the default mask for the effect. | MaskEffectInstance
 | initMaskEffect():void Initializes the move and scale properties of the effect. | MaskEffectInstance
 | onMoveTweenEnd(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect for the last time. | MaskEffectInstance
 | onMoveTweenUpdate(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect. | MaskEffectInstance
 | onScaleTweenEnd(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time. | MaskEffectInstance
 | onScaleTweenUpdate(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect. | MaskEffectInstance
Property detail
createMaskFunction property
createMaskFunction:Function [read-write]

Function called when the effect creates the mask. The default value is a function that returns a Rectangle with the same dimensions as the effect target.

You can use this property to specify your own callback function to draw the mask. The function must have the following signature:

   public function createLargeMask(targ:Object, bounds:Rectangle):Shape {
     var myMask:Shape = new Shape();
     // Create mask.

     return myMask;
   }

You set this property to the name of the function, as the following example shows for the WipeLeft effect:

     <mx:WipeLeft id="showWL" createMaskFunction="createLargeMask" showTarget="false"/>
Implementation
    public function get createMaskFunction():Function
    public function set createMaskFunction(value:Function):void
effectMask property
protected var effectMask:Shape

Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property.

moveEasingFunction property
public var moveEasingFunction:Function

Easing function to use for moving the mask.

scaleEasingFunction property
public var scaleEasingFunction:Function

Easing function to use for scaling the mask.

scaleXFrom property
public var scaleXFrom:Number

Initial scaleX for mask.

scaleXTo property
public var scaleXTo:Number

Ending scaleX for mask.

scaleYFrom property
public var scaleYFrom:Number

Initial scaleY for mask.

scaleYTo property
public var scaleYTo:Number

Ending scaleY for mask.

showTarget property
showTarget:Boolean [read-write]

Specifies that the target component is becoming visible, false, or invisible, true.

The default value is true.

Implementation
    public function get showTarget():Boolean
    public function set showTarget(value:Boolean):void
targetArea property
public var targetArea:Rectangle

The area where the mask is applied on the target. The dimensions are relative to the target itself. By default, the area is the entire target and is created like this: new Rectangle(0, 0, target.width, target.height);

targetVisualBounds property
protected var targetVisualBounds:Rectangle

The actual size of the effect target, including any drop shadows. Flex calculates the value of this property; you do not have to set it.

xFrom property
public var xFrom:Number

Initial position's x coordinate for mask.

xTo property
public var xTo:Number

Destination position's x coordinate for mask.

yFrom property
public var yFrom:Number

Initial position's y coordinate for mask.

yTo property
public var yTo:Number

Destination position's y coordinate for mask.

Constructor detail
MaskEffectInstance () constructor
public function MaskEffectInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.
Method detail
defaultCreateMask () method
protected function defaultCreateMask(targ:Object, bounds:Rectangle):Shape

Creates the default mask for the effect.

Parameters
targ:Object — The effect target.
bounds:Rectangle — The actual visual bounds of the target which includes drop shadows

Returns
Shape — A Shape object that defines the mask.
initMaskEffect () method
protected function initMaskEffect():void

Initializes the move and scale properties of the effect. All subclasses should override this function. Flex calls it after the mask has been created, but before the tweens are created.

onMoveTweenEnd () method
protected function onMoveTweenEnd(value:Object):void

Callback method that is called when the x and y position of the mask should be updated by the effect for the last time. You do not call this method directly. This method implements the method of the superclass.

Parameters
value:Object — Contains the final x and y value for the mask position, where value[0] contains the x position of the mask, and value[1] contains the y position.
onMoveTweenUpdate () method
protected function onMoveTweenUpdate(value:Object):void

Callback method that is called when the x and y position of the mask should be updated by the effect. You do not call this method directly. This method implements the method of the superclass.

Parameters
value:Object — Contains an interpolated x and y value for the mask position, where value[0] contains the new x position of the mask, and value[1] contains the new y position.
onScaleTweenEnd () method
protected function onScaleTweenEnd(value:Object):void

Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time. You do not call this method directly. This method implements the method of the superclass.

Parameters
value:Object — Contains the final scaleX and scaleY value for the mask, where value[0] contains the scaleX value of the mask, and value[1] contains the scaleY value.
onScaleTweenUpdate () method
protected function onScaleTweenUpdate(value:Object):void

Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect. You do not call this method directly. This method implements the method of the superclass.

Parameters
value:Object — Contains an interpolated scaleX and scaleY value for the mask, where value[0] contains the new scaleX value of the mask, and value[1] contains the new scaleY value.
pause () method
public override function pause():void

Pauses the effect until you call the resume() method.

resume () method
public override function resume():void

Resumes the effect after it has been paused by a call to the pause() method.

reverse () method
public override function reverse():void

Plays the effect in reverse, starting from the current position of the effect.


mx.effects.effectClasses.MoveInstance (Flex™ 2 Language Reference)

Class MoveInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class MoveInstance
Inheritance | MoveInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The MoveInstance class implements the instance class for the Move effect. Flex creates an instance of this class when it plays a Move effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Move effect, the TweenEvent.value property contains a 2-item Array, where:

  • value[0]:Number A value between the values of the Move.xFrom and Move.xTo property.
  • value[1]:Number A value between the values of the Move.yFrom and Move.yTo property.

See also

mx.effects.Move
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
 | xBy : Number Number of pixels to move the components along the x axis. | MoveInstance
 | xFrom : Number Initial position's x coordinate. | MoveInstance
 | xTo : Number Destination position's x coordinate. | MoveInstance
 | yBy : Number Number of pixels to move the components along the y axis. | MoveInstance
 | yFrom : Number Initial position's y coordinate. | MoveInstance
 | yTo : Number Destination position's y coordinate. | MoveInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MoveInstance(target:Object)
Constructor.
MoveInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
xBy property
public var xBy:Number

Number of pixels to move the components along the x axis. Values can be negative.

xFrom property
public var xFrom:Number

Initial position's x coordinate.

xTo property
public var xTo:Number

Destination position's x coordinate.

yBy property
public var yBy:Number

Number of pixels to move the components along the y axis. Values can be negative.

yFrom property
public var yFrom:Number

Initial position's y coordinate.

yTo property
public var yTo:Number

Destination position's y coordinate.

Constructor detail
MoveInstance () constructor
public function MoveInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.ParallelInstance (Flex™ 2 Language Reference)

Class ParallelInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class ParallelInstance
Inheritance | ParallelInstance Inheritance CompositeEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The ParallelInstance class implements the instance class for the Parallel effect. Flex creates an instance of this class when it plays a Parallel effect; you do not create one yourself.

See also

mx.effects.Parallel

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ParallelInstance(target:Object)
Constructor.
ParallelInstance
Inherited
addChildSet(childSet:Array):void
Adds a new set of child effects to this Composite effect.
CompositeEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
end():void
Interrupts any effects that are currently playing, skips over any effects that haven't started playing, and jumps immediately to the end of the composite effect.
ParallelInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Used internally to keep track of the value of the playheadTime property.
CompositeEffectInstance
Inherited
onTweenUpdate(value:Object):void
Used internally to keep track of the value of the playheadTime property.
CompositeEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | onEffectEnd(childEffect:EffectInstance):void Each time a child effect of SequenceInstance or ParallelInstance finishes, Flex calls the onEffectEnd() method. | ParallelInstance
Constructor detail
ParallelInstance () constructor
public function ParallelInstance(target:Object)

Constructor.

Parameters
target:Object — This argument is ignored for Parallel effects. It is included only for consistency with other types of effects.
Method detail
end () method
public override function end():void

Interrupts any effects that are currently playing, skips over any effects that haven't started playing, and jumps immediately to the end of the composite effect.

onEffectEnd () method
protected override function onEffectEnd(childEffect:EffectInstance):void

Each time a child effect of SequenceInstance or ParallelInstance finishes, Flex calls the onEffectEnd() method. For SequenceInstance, it plays the next effect. In ParallelInstance, it keeps track of all the effects until all of them have finished playing. If you create a subclass of CompositeEffect, you must implement this method.

Parameters
childEffect:EffectInstance


mx.effects.effectClasses.PauseInstance (Flex™ 2 Language Reference)

Class PauseInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class PauseInstance
Inheritance | PauseInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The PauseInstance class implements the instance class for the Pause effect. Flex creates an instance of this class when it plays a Pause effect; you do not create one yourself.

See also

mx.effects.Pause

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PauseInstance(target:Object)
Constructor.
PauseInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Constructor detail
PauseInstance () constructor
public function PauseInstance(target:Object)

Constructor.

Parameters
target:Object — This argument is ignored by the Pause effect. It is included for consistency with other effects.


mx.effects.effectClasses.PropertyChanges (Flex™ 2 Language Reference)

Class PropertyChanges | Properties | Methods
Package | mx.effects.effectClasses
Class | public class PropertyChanges
Inheritance | PropertyChanges Inheritance Object

The PropertyChanges class defines the start and end values for a set of properties of a target component of a transition. The start and end fields of the PropertyChanges class contain the same set of properties, but with different values.

Target properties that have the same start and end values are not included in the start and end fields.

See also

mx.states.Transition

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | end : Object An Object containing the ending properties of the target component modified by the change in view state. | PropertyChanges
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | start : Object An Object containing the starting properties of the target component modified by the change in view state. | PropertyChanges
 | target : IUIComponent A target component of a transition. | PropertyChanges
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | PropertyChanges(target:IUIComponent) The PropertyChanges constructor. | PropertyChanges
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
end property
public var end:Object

An Object containing the ending properties of the target component modified by the change in view state.

For example, for a target component that is both moved and resized by a change to the view state, end contains the ending position and size of the component, as the following example shows:

{ x: 100, y: 100, width: 200, height: 200 }

start property
public var start:Object

An Object containing the starting properties of the target component modified by the change in view state.

For example, for a target component that is both moved and resized by a change to the view state, start contains the starting position and size of the component, as the following example shows:

{ x: 0, y: 0, width: 100, height: 100}

target property
public var target:IUIComponent

A target component of a transition. The start and end fields of the PropertyChanges object define how the target component is modified by the change to the view state.

Constructor detail
PropertyChanges () constructor
public function PropertyChanges(target:IUIComponent)

The PropertyChanges constructor.

Parameters
target:IUIComponent — Object that is a target of an effect.


mx.effects.effectClasses.RemoveChildActionInstance (Flex™ 2 Language Reference)

Class RemoveChildActionInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class RemoveChildActionInstance
Inheritance | RemoveChildActionInstance Inheritance ActionEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The RemoveChildActionInstance class implements the instance class for the RemoveChildAction effect. Flex creates an instance of this class when it plays a RemoveChildAction effect; you do not create one yourself.

See also

mx.effects.RemoveChildAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | playedAction : Boolean = false Indicates whether the effect has been played (true), or not (false). | ActionEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RemoveChildActionInstance(target:Object)
Constructor.
RemoveChildActionInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | getStartValue():* Used internally to retrieve the values saved by the saveStartValue() method. | ActionEffectInstance
Inherited | saveStartValue():* Subclasses implement this method to save the starting state before the effect plays. | ActionEffectInstance
Constructor detail
RemoveChildActionInstance () constructor
public function RemoveChildActionInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.ResizeInstance (Flex™ 2 Language Reference)

Class ResizeInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class ResizeInstance
Inheritance | ResizeInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The ResizeInstance class implements the instance class for the Resize effect. Flex creates an instance of this class when it plays a Resize effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Resize effect, the TweenEvent.value property contains a 2-item Array, where:

  • value[0]:Number A value between the values of the Resize.widthFrom and Resize.widthTo property.
  • value[1]:Number A value between the values of the Resize.heightFrom and Resize.heightTo property.

See also

mx.effects.Resize
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | heightBy : Number Number of pixels by which to modify the height of the component. | ResizeInstance
 | heightFrom : Number Initial height. | ResizeInstance
 | heightTo : Number Final height, in pixels. | ResizeInstance
 | hideChildrenTargets : Array An Array of Panels. | ResizeInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
 | widthBy : Number Number of pixels by which to modify the width of the component. | ResizeInstance
 | widthFrom : Number Initial width. | ResizeInstance
 | widthTo : Number Final width, in pixels. | ResizeInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ResizeInstance(target:Object)
Constructor.
ResizeInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
heightBy property
heightBy:Number [read-write]

Number of pixels by which to modify the height of the component. Values may be negative.

Implementation
    public function get heightBy():Number
    public function set heightBy(value:Number):void
heightFrom property
public var heightFrom:Number

Initial height. If omitted, Flex uses the current size.

heightTo property
heightTo:Number [read-write]

Final height, in pixels.

Implementation
    public function get heightTo():Number
    public function set heightTo(value:Number):void
hideChildrenTargets property
public var hideChildrenTargets:Array

An Array of Panels. The children of these Panels are hidden while the Resize effect plays.

widthBy property
widthBy:Number [read-write]

Number of pixels by which to modify the width of the component. Values may be negative.

Implementation
    public function get widthBy():Number
    public function set widthBy(value:Number):void
widthFrom property
public var widthFrom:Number

Initial width. If omitted, Flex uses the current size.

widthTo property
widthTo:Number [read-write]

Final width, in pixels.

Implementation
    public function get widthTo():Number
    public function set widthTo(value:Number):void
Constructor detail
ResizeInstance () constructor
public function ResizeInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.RotateInstance (Flex™ 2 Language Reference)

Class RotateInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class RotateInstance
Inheritance | RotateInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The RotateInstance class implements the instance class for the Rotate effect. Flex creates an instance of this class when it plays a Rotate effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Rotate effect, the TweenEvent.value property contains a Number between the values of the Rotate.angleFrom and Rotate.angleTo properties.

See also

mx.effects.Rotate
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | angleFrom : Number = 0 The starting angle of rotation of the target object, expressed in degrees. | RotateInstance
 | angleTo : Number = 360 The ending angle of rotation of the target object, expressed in degrees. | RotateInstance
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | originX : Number The x-position of the center point of rotation. | RotateInstance
 | originY : Number The y-position of the center point of rotation. | RotateInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RotateInstance(target:Object)
Constructor.
RotateInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
angleFrom property
public var angleFrom:Number = 0

The starting angle of rotation of the target object, expressed in degrees. Valid values range from 0 to 360.

The default value is 0.

angleTo property
public var angleTo:Number = 360

The ending angle of rotation of the target object, expressed in degrees. Values can be either positive or negative.

If the value of angleTo is less than the value of angleFrom, then the target rotates in a counterclockwise direction. Otherwise, it rotates in clockwise direction. If you want the target to rotate multiple times, set this value to a large positive or small negative number.

The default value is 360.

originX property
public var originX:Number

The x-position of the center point of rotation. The target rotates around this point. The valid values are between 0 and the width of the target.

The default value is 0.

originY property
public var originY:Number

The y-position of the center point of rotation. The target rotates around this point. The valid values are between 0 and the height of the target.

The default value is 0.

Constructor detail
RotateInstance () constructor
public function RotateInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.SequenceInstance (Flex™ 2 Language Reference)

Class SequenceInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class SequenceInstance
Inheritance | SequenceInstance Inheritance CompositeEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The SequenceInstance class implements the instance class for the Sequence effect. Flex creates an instance of this class when it plays a Sequence effect; you do not create one yourself.

See also

mx.effects.Sequence

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SequenceInstance(target:Object)
Constructor.
SequenceInstance
Inherited
addChildSet(childSet:Array):void
Adds a new set of child effects to this Composite effect.
CompositeEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
end():void
Interrupts any effects that are currently playing, skips over any effects that haven't started playing, and jumps immediately to the end of the composite effect.
SequenceInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Used internally to keep track of the value of the playheadTime property.
CompositeEffectInstance
Inherited
onTweenUpdate(value:Object):void
Used internally to keep track of the value of the playheadTime property.
CompositeEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | onEffectEnd(childEffect:EffectInstance):void Each time a child effect of SequenceInstance finishes, Flex calls the onEffectEnd() method. | SequenceInstance
Constructor detail
SequenceInstance () constructor
public function SequenceInstance(target:Object)

Constructor.

Parameters
target:Object — This argument is ignored for Sequence effects. It is included only for consistency with other types of effects.
Method detail
end () method
public override function end():void

Interrupts any effects that are currently playing, skips over any effects that haven't started playing, and jumps immediately to the end of the composite effect.

onEffectEnd () method
protected override function onEffectEnd(childEffect:EffectInstance):void

Each time a child effect of SequenceInstance finishes, Flex calls the onEffectEnd() method. For SequenceInstance, it plays the next effect. This method implements the method of the superclass.

Parameters
childEffect:EffectInstance — The child effect.


mx.effects.effectClasses.SetPropertyActionInstance (Flex™ 2 Language Reference)

Class SetPropertyActionInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class SetPropertyActionInstance
Inheritance | SetPropertyActionInstance Inheritance ActionEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The SetPropertyActionInstance class implements the instance class for the SetPropertyAction effect. Flex creates an instance of this class when it plays a SetPropertyAction effect; you do not create one yourself.

See also

mx.effects.SetPropertyAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | name : String The name of the property being changed. | SetPropertyActionInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
 | value : * The new value for the property. | SetPropertyActionInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | playedAction : Boolean = false Indicates whether the effect has been played (true), or not (false). | ActionEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SetPropertyActionInstance(target:Object)
Constructor.
SetPropertyActionInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | getStartValue():* Used internally to retrieve the values saved by the saveStartValue() method. | ActionEffectInstance
Inherited | saveStartValue():* Subclasses implement this method to save the starting state before the effect plays. | ActionEffectInstance
Property detail
name property
public var name:String

The name of the property being changed.

value property
value:* [read-write]

The new value for the property.

Implementation
    public function get value():*
    public function set value(value:*):void
Constructor detail
SetPropertyActionInstance () constructor
public function SetPropertyActionInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.SetStyleActionInstance (Flex™ 2 Language Reference)

Class SetStyleActionInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class SetStyleActionInstance
Inheritance | SetStyleActionInstance Inheritance ActionEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The SetStyleActionInstance class implements the instance class for the SetStyleAction effect. Flex creates an instance of this class when it plays a SetStyleAction effect; you do not create one yourself.

See also

mx.effects.SetStyleAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | name : String The name of the style property being changed. | SetStyleActionInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
 | value : * The new value for the property. | SetStyleActionInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | playedAction : Boolean = false Indicates whether the effect has been played (true), or not (false). | ActionEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SetStyleActionInstance(target:Object)
Constructor.
SetStyleActionInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | getStartValue():* Used internally to retrieve the values saved by the saveStartValue() method. | ActionEffectInstance
Inherited | saveStartValue():* Subclasses implement this method to save the starting state before the effect plays. | ActionEffectInstance
Property detail
name property
public var name:String

The name of the style property being changed.

value property
value:* [read-write]

The new value for the property.

Implementation
    public function get value():*
    public function set value(value:*):void
Constructor detail
SetStyleActionInstance () constructor
public function SetStyleActionInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.SoundEffectInstance (Flex™ 2 Language Reference)

Class SoundEffectInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class SoundEffectInstance
Inheritance | SoundEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The SoundEffectInstance class implements the instance class for the SoundEffect effect. Flex creates an instance of this class when it plays a SoundEffect effect; you do not create one yourself.

See also

mx.effects.Fade

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | bufferTime : Number = 1000 The SoundEffect class uses an internal Sound object to control the MP3 file. | SoundEffectInstance
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | isLoading : Boolean [read-only] This property is true if the MP3 has been loaded. | SoundEffectInstance
 | loops : int = 0 The number of times to play the sound in a loop, where a value of 0 means play the effect once, a value of 1 means play the effect twice, and so on. | SoundEffectInstance
 | panEasingFunction : Function The easing function for the pan effect. | SoundEffectInstance
 | panFrom : Number Initial pan of the Sound object. | SoundEffectInstance
 | panTo : Number Final pan of the Sound object. | SoundEffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
 | sound : Sound Reference to the internal Sound object. | SoundEffectInstance
 | soundChannel : SoundChannel [read-only] The SoundChannel object that the MP3 file has been loaded into. | SoundEffectInstance
 | source : Object The URL or class of the MP3 file to play. | SoundEffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
 | startTime : Number = 0 The initial position in the MP3 file, in milliseconds, at which playback should start. | SoundEffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
 | useDuration : Boolean = true If true, stop the effect after the time specified by the duration property has elapsed. | SoundEffectInstance
 | volumeEasingFunction : Function The easing function for the volume effect. | SoundEffectInstance
 | volumeFrom : Number Initial volume of the Sound object. | SoundEffectInstance
 | volumeTo : Number Final volume of the Sound object. | SoundEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SoundEffectInstance(target:Object)
Constructor.
SoundEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
bufferTime property
public var bufferTime:Number = 1000

The SoundEffect class uses an internal Sound object to control the MP3 file. This property specifies the minimum number of milliseconds worth of sound data to hold in the Sound object's buffer. The Sound object waits until it has at least this much data before beginning playback, and before resuming playback after a network stall.

The default value is 1000.

isLoading property
isLoading:Boolean [read-only]

This property is true if the MP3 has been loaded.

Implementation
    public function get isLoading():Boolean
loops property
public var loops:int = 0

The number of times to play the sound in a loop, where a value of 0 means play the effect once, a value of 1 means play the effect twice, and so on. If you repeat the MP3 file, it still uses the setting of the useDuration property to determine the playback time.

The duration property takes precedence over this property. If the effect duration is not long enough to play the sound at least once, the sound does not loop.

The default value is 0.

panEasingFunction property
public var panEasingFunction:Function

The easing function for the pan effect. This function is used to interpolate between the values of panFrom and panTo.

panFrom property
public var panFrom:Number

Initial pan of the Sound object. The value can range from -1.0 to 1.0, where -1.0 uses only the left channel, 1.0 uses only the right channel, and 0.0 balances the sound evenly between the two channels.

The default value is 0.

panTo property
public var panTo:Number

Final pan of the Sound object. The value can range from -1.0 to 1.0, where -1.0 uses only the left channel, 1.0 uses only the right channel, and 0.0 balances the sound evenly between the two channels.

The default value is 0.

sound property
public var sound:Sound

Reference to the internal Sound object. The SoundEffect uses this instance to play the MP3 file.

soundChannel property
soundChannel:SoundChannel [read-only]

The SoundChannel object that the MP3 file has been loaded into.

Implementation
    public function get soundChannel():SoundChannel
source property
source:Object [read-write]

The URL or class of the MP3 file to play. If you have already embedded the MP3 file, using the Embed keyword, you can pass the Class object of the MP3 file to the source property. Otherwise, specify the full URL to the MP3 file.

Implementation
    public function get source():Object
    public function set source(value:Object):void
startTime property
public var startTime:Number = 0

The initial position in the MP3 file, in milliseconds, at which playback should start.

The default value is 0.

useDuration property
public var useDuration:Boolean = true

If true, stop the effect after the time specified by the duration property has elapsed. If false, stop the effect after the MP3 finishes playing or looping.

The default value is true.

volumeEasingFunction property
public var volumeEasingFunction:Function

The easing function for the volume effect. Use this function to interpolate between the values of volumeFrom and volumeTo.

volumeFrom property
public var volumeFrom:Number

Initial volume of the Sound object. Value can range from 0.0 to 1.0.

The default value is 1.0.

volumeTo property
public var volumeTo:Number

Final volume of the Sound object. Value can range from 0.0 to 1.0.

The default value is 1.0.

Constructor detail
SoundEffectInstance () constructor
public function SoundEffectInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.TweenEffectInstance (Flex™ 2 Language Reference)

Class TweenEffectInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class TweenEffectInstance
Inheritance | TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object
Subclasses | AnimatePropertyInstance, BlurInstance, DissolveInstance, FadeInstance, GlowInstance, MoveInstance, PauseInstance, ResizeInstance, RotateInstance, SeriesEffectInstance, ZoomInstance

The TweenEffectInstance class implements the instance class for the TweenEffect. Flex creates an instance of this class when it plays a TweenEffect; you do not create one yourself.

See also

mx.effects.Tween
mx.effects.TweenEffect
About creating a custom effect
Example: Creating a tween effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
 | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | playheadTime : Number [read-only] The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
 | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TweenEffectInstance(target:Object)
Constructor.
TweenEffectInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
easingFunction property
public var easingFunction:Function

The easing function for the animation. By default, effects use the same easing function as the TweenEffect class.

See also

mx.effects.TweenEffect.easingFunction
playheadTime property
playheadTime:Number [read-only]

The current position of the effect, in milliseconds. This value is between 0 and the value of the duration property. Use the seek() method to change the position of the effect.

Implementation
    public function get playheadTime():Number
tween property
public var tween:Tween

The Tween object, which determines the animation. To create an effect, you must create a Tween instance in the override of the EffectInstance.play() method and assign it to the tween property. Use the createTween() method to create your Tween object.

Constructor detail
TweenEffectInstance () constructor
public function TweenEffectInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.
Method detail
createTween () method
protected function createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween

Creates a Tween instance, assigns it the start, end, and duration values. If an easing function has been specified, then it is assigned to the Tween instance. The Tween instance is assigned event listeners for the TweenEvents: tweenStart, tweenUpdate, and tweenEnd. Typically, you call this method from your override of the EffectInstance.play() method which effectively starts the animation timer.

Parameters
listener:Object — Object that is notified at each interval of the animation. You typically pass the this keyword as the value. The listener must define the onTweenUpdate() method and optionally the onTweenEnd() method. The onTweenUpdate() method is invoked for each interval of the animation, and the onTweenEnd() method is invoked just after the animation finishes.
startValue:Object — Initial value(s) of the animation. Either a number or an Array of numbers. If a number is passed, the Tween interpolates between this number and the number passed in the endValue parameter. If an Array of numbers is passed, each number in the Array is interpolated.
endValue:Object — Final value(s) of the animation. The type of this argument must match the startValue parameter.
duration:Number (default = -1) — Duration of the animation, in milliseconds.
minFps:Number (default = -1) — Minimum number of times that the onTweenUpdate() method should be called every second. The tween code tries to call the onTweenUpdate() method as frequently as possible (up to 100 times per second). However, if the frequency falls below minFps, the duration of the animation automatically increases. As a result, an animation that temporarily freezes (because it is not getting any CPU cycles) begins again where it left off, instead of suddenly jumping ahead.

Returns
Tween — The newly created Tween instance.
end () method
public override function end():void

Interrupts an effect that is currently playing, and immediately jumps to the end of the effect. Calls the Tween.endTween() method on the tween property. This method implements the method of the superclass.

If you create a subclass of TweenEffectInstance, you can optionally override this method.

The effect dispatches the effectEnd event.

See also

mx.effects.EffectInstance.end()
onTweenEnd () method
public function onTweenEnd(value:Object):void

Callback method that is called when the target should be updated by the effect for the last time. The Tween class passes Tween.endValue as the value of the value argument. The value argument can be either a Number or an Array of Numbers.

Overriding this function is optional. You must also call the super version of this method from the end of your override, super.onTweenEnd(val), after your logic.

Parameters
value:Object — The value of the value argument is an interpolated value determined by the Tween.startValue property, Tween.endValue property, and interpolation function specified by the implementation of the effect in its play() method. The play() method uses these values to create a Tween object that plays the effect over a time period. The value argument can be either a Number or an Array of Numbers.
onTweenUpdate () method
public function onTweenUpdate(value:Object):void

Callback method that is called when the target should be updated by the effect. The Tween class uses the easing function and the Tween.startValue, Tween.endValue and Tween.duration properties to calculate the value of the value argument. The value argument can be either a Number or an Array of Numbers.

All subclasses must override this method. It is not necessary to call the super version of this function when overriding this method.

Parameters
value:Object — The value of the value argument is an interpolated value determined by the Tween.startValue property, Tween.endValue property, and interpolation function specified by the implementation of the effect in its play() method. The play() method uses these values to create a Tween object that plays the effect over a time period. The value argument can be either a Number or an Array of Numbers.
seek () method
public function seek(playheadTime:Number):void

Advances the effect to the specified position.

Parameters
playheadTime:Number — The position, in milliseconds, between 0 and the value of the duration property.


mx.effects.effectClasses.WipeDownInstance (Flex™ 2 Language Reference)

Class WipeDownInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class WipeDownInstance
Inheritance | WipeDownInstance Inheritance MaskEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The WipeDownInstance class implements the instance class for the WipeDown effect. Flex creates an instance of this class when it plays a WipeDown effect; you do not create one yourself.

See also

mx.effects.WipeDown

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffectInstance
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffectInstance
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffectInstance
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffectInstance
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffectInstance
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffectInstance
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, false, or invisible, true. | MaskEffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | targetArea : Rectangle The area where the mask is applied on the target. | MaskEffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffectInstance
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffectInstance
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffectInstance
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | effectMask : Shape Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property. | MaskEffectInstance
Inherited | targetVisualBounds : Rectangle The actual size of the effect target, including any drop shadows. | MaskEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeDownInstance(target:Object)
Constructor.
WipeDownInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
MaskEffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
MaskEffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
MaskEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | defaultCreateMask(targ:Object, bounds:Rectangle):Shape Creates the default mask for the effect. | MaskEffectInstance
Inherited | initMaskEffect():void Initializes the move and scale properties of the effect. | MaskEffectInstance
Inherited | onMoveTweenEnd(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onMoveTweenUpdate(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect. | MaskEffectInstance
Inherited | onScaleTweenEnd(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onScaleTweenUpdate(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect. | MaskEffectInstance
Constructor detail
WipeDownInstance () constructor
public function WipeDownInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.WipeLeftInstance (Flex™ 2 Language Reference)

Class WipeLeftInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class WipeLeftInstance
Inheritance | WipeLeftInstance Inheritance MaskEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The WipeLeftInstance class implements the instance class for the WipeLeft effect. Flex creates an instance of this class when it plays a WipeLeft effect; you do not create one yourself.

See also

mx.effects.WipeLeft

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffectInstance
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffectInstance
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffectInstance
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffectInstance
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffectInstance
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffectInstance
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, false, or invisible, true. | MaskEffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | targetArea : Rectangle The area where the mask is applied on the target. | MaskEffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffectInstance
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffectInstance
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffectInstance
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | effectMask : Shape Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property. | MaskEffectInstance
Inherited | targetVisualBounds : Rectangle The actual size of the effect target, including any drop shadows. | MaskEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeLeftInstance(target:Object)
Constructor.
WipeLeftInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
MaskEffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
MaskEffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
MaskEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | defaultCreateMask(targ:Object, bounds:Rectangle):Shape Creates the default mask for the effect. | MaskEffectInstance
Inherited | initMaskEffect():void Initializes the move and scale properties of the effect. | MaskEffectInstance
Inherited | onMoveTweenEnd(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onMoveTweenUpdate(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect. | MaskEffectInstance
Inherited | onScaleTweenEnd(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onScaleTweenUpdate(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect. | MaskEffectInstance
Constructor detail
WipeLeftInstance () constructor
public function WipeLeftInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.WipeRightInstance (Flex™ 2 Language Reference)

Class WipeRightInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class WipeRightInstance
Inheritance | WipeRightInstance Inheritance MaskEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The WipeRightInstance class implements the instance class for the WipeRight effect. Flex creates an instance of this class when it plays a WipeRight effect; you do not create one yourself.

See also

mx.effects.WipeRight

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffectInstance
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffectInstance
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffectInstance
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffectInstance
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffectInstance
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffectInstance
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, false, or invisible, true. | MaskEffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | targetArea : Rectangle The area where the mask is applied on the target. | MaskEffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffectInstance
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffectInstance
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffectInstance
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | effectMask : Shape Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property. | MaskEffectInstance
Inherited | targetVisualBounds : Rectangle The actual size of the effect target, including any drop shadows. | MaskEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeRightInstance(target:Object)
Constructor.
WipeRightInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
MaskEffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
MaskEffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
MaskEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | defaultCreateMask(targ:Object, bounds:Rectangle):Shape Creates the default mask for the effect. | MaskEffectInstance
Inherited | initMaskEffect():void Initializes the move and scale properties of the effect. | MaskEffectInstance
Inherited | onMoveTweenEnd(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onMoveTweenUpdate(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect. | MaskEffectInstance
Inherited | onScaleTweenEnd(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onScaleTweenUpdate(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect. | MaskEffectInstance
Constructor detail
WipeRightInstance () constructor
public function WipeRightInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.WipeUpInstance (Flex™ 2 Language Reference)

Class WipeUpInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class WipeUpInstance
Inheritance | WipeUpInstance Inheritance MaskEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The WipeUpInstance class implements the instance class for the WipeUp effect. Flex creates an instance of this class when it plays a WipeUp effect; you do not create one yourself.

See also

mx.effects.WipeUp

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | createMaskFunction : Function Function called when the effect creates the mask. | MaskEffectInstance
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
Inherited | moveEasingFunction : Function Easing function to use for moving the mask. | MaskEffectInstance
Inherited | playheadTime : Number Current position in time of the effect. | EffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | scaleEasingFunction : Function Easing function to use for scaling the mask. | MaskEffectInstance
Inherited | scaleXFrom : Number Initial scaleX for mask. | MaskEffectInstance
Inherited | scaleXTo : Number Ending scaleX for mask. | MaskEffectInstance
Inherited | scaleYFrom : Number Initial scaleY for mask. | MaskEffectInstance
Inherited | scaleYTo : Number Ending scaleY for mask. | MaskEffectInstance
Inherited | showTarget : Boolean Specifies that the target component is becoming visible, false, or invisible, true. | MaskEffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | targetArea : Rectangle The area where the mask is applied on the target. | MaskEffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | xFrom : Number Initial position's x coordinate for mask. | MaskEffectInstance
Inherited | xTo : Number Destination position's x coordinate for mask. | MaskEffectInstance
Inherited | yFrom : Number Initial position's y coordinate for mask. | MaskEffectInstance
Inherited | yTo : Number Destination position's y coordinate for mask. | MaskEffectInstance
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | effectMask : Shape Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property. | MaskEffectInstance
Inherited | targetVisualBounds : Rectangle The actual size of the effect target, including any drop shadows. | MaskEffectInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
WipeUpInstance(target:Object)
Constructor.
WipeUpInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
EffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
pause():void
Pauses the effect until you call the resume() method.
MaskEffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
MaskEffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
MaskEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | defaultCreateMask(targ:Object, bounds:Rectangle):Shape Creates the default mask for the effect. | MaskEffectInstance
Inherited | initMaskEffect():void Initializes the move and scale properties of the effect. | MaskEffectInstance
Inherited | onMoveTweenEnd(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onMoveTweenUpdate(value:Object):void Callback method that is called when the x and y position of the mask should be updated by the effect. | MaskEffectInstance
Inherited | onScaleTweenEnd(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time. | MaskEffectInstance
Inherited | onScaleTweenUpdate(value:Object):void Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect. | MaskEffectInstance
Constructor detail
WipeUpInstance () constructor
public function WipeUpInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.effects.effectClasses.ZoomInstance (Flex™ 2 Language Reference)

Class ZoomInstance | Properties | Methods
Package | mx.effects.effectClasses
Class | public class ZoomInstance
Inheritance | ZoomInstance Inheritance TweenEffectInstance Inheritance EffectInstance Inheritance EventDispatcher Inheritance Object

The ZoomInstance class implements the instance class for the Zoom effect. Flex creates an instance of this class when it plays a Zoom effect; you do not create one yourself.

Every effect class that is a subclass of the TweenEffect class supports the following events:

  • tweenEnd: Dispatched when the tween effect ends.
  • tweenUpdate: Dispatched every time a TweenEffect class calculates a new value.

The event object passed to the event listener for these events is of type TweenEvent. The TweenEvent class defines the property value, which contains the tween value calculated by the effect. For the Zoom effect, the TweenEvent.value property contains a 2-item Array, where:

  • value[0]:Number A value between the values of the Zoom.zoomWidthFrom and Zoom.zoomWidthTo property.
  • value[1]:Number A value between the values of the Zoom.zoomHeightFrom and Zoom.zoomHeightTo property.

See also

mx.effects.Zoom
mx.events.TweenEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | captureRollEvents : Boolean Prevents the rollOut and rollOver events from being dispatched if the mouse has not moved. | ZoomInstance
Inherited | className : String The name of the effect class, such as "FadeInstance". | EffectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | duration : Number Duration of the effect in milliseconds. | EffectInstance
Inherited | easingFunction : Function The easing function for the animation. | TweenEffectInstance
Inherited | effect : Effect The Effect object that created this EffectInstance object. | EffectInstance
 | originX : Number Number that represents the x-position of the zoom origin, or registration point. | ZoomInstance
 | originY : Number Number that represents the y-position of the zoom origin, or registration point. | ZoomInstance
Inherited | playheadTime : Number The current position of the effect, in milliseconds. | TweenEffectInstance
Inherited | propertyChanges : PropertyChanges Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets. | EffectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeatCount : int = 1 Number of times to repeat the effect. | EffectInstance
Inherited | repeatDelay : int = 0 Amount of time, in milliseconds, to wait before repeating the effect. | EffectInstance
Inherited | startDelay : int = 0 Amount of time, in milliseconds, to wait before starting the effect. | EffectInstance
Inherited | suspendBackgroundProcessing : Boolean = false If true, blocks all background processing while the effect is playing. | EffectInstance
Inherited | target : Object The UIComponent object to which this effect is applied. | EffectInstance
Inherited | triggerEvent : Event The event, if any, which triggered the playing of the effect. | EffectInstance
Inherited | tween : Tween The Tween object, which determines the animation. | TweenEffectInstance
 | zoomHeightFrom : Number Number that represents the scale at which to start the height zoom, as a percent between 0.01 and 1.0. | ZoomInstance
 | zoomHeightTo : Number Number that represents the scale at which to complete the height zoom, as a percent between 0.01 and 1.0. | ZoomInstance
 | zoomWidthFrom : Number Number that represents the scale at which to start the width zoom, as a percent between 0.01 and 1.0. | ZoomInstance
 | zoomWidthTo : Number Number that represents the scale at which to complete the width zoom, as a percent between 0.01 and 1.0. | ZoomInstance
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ZoomInstance(target:Object)
Constructor.
ZoomInstance
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
end():void
Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
TweenEffectInstance
Inherited
finishEffect():void
Called by the end() method when the effect finishes playing.
EffectInstance
Inherited
finishRepeat():void
Called after each iteration of a repeated effect finishes playing.
EffectInstance
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initEffect(event:Event):void
This method is called if the effect was triggered by the EffectManager.
EffectInstance
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
onTweenEnd(value:Object):void
Callback method that is called when the target should be updated by the effect for the last time.
TweenEffectInstance
Inherited
onTweenUpdate(value:Object):void
Callback method that is called when the target should be updated by the effect.
TweenEffectInstance
Inherited
pause():void
Pauses the effect until you call the resume() method.
EffectInstance
Inherited
play():void
Plays the effect instance on the target.
EffectInstance
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resume():void
Resumes the effect after it has been paused by a call to the pause() method.
EffectInstance
Inherited
reverse():void
Plays the effect in reverse, starting from the current position of the effect.
EffectInstance
Inherited
seek(playheadTime:Number):void
Advances the effect to the specified position.
TweenEffectInstance
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startEffect():void
Plays the effect instance on the target after the startDelay period has elapsed.
EffectInstance
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createTween(listener:Object, startValue:Object, endValue:Object, duration:Number = -1, minFps:Number = -1):Tween Creates a Tween instance, assigns it the start, end, and duration values. | TweenEffectInstance
Property detail
captureRollEvents property
public var captureRollEvents:Boolean

Prevents the rollOut and rollOver events from being dispatched if the mouse has not moved. Set this value to true in situations where the target toggles between a big and small state without moving the mouse.

The default value is false.

originX property
public var originX:Number

Number that represents the x-position of the zoom origin, or registration point. The default value is target.width / 2, which is the center of the target.

originY property
public var originY:Number

Number that represents the y-position of the zoom origin, or registration point. The default value is target.height / 2, which is the center of the target.

zoomHeightFrom property
public var zoomHeightFrom:Number

Number that represents the scale at which to start the height zoom, as a percent between 0.01 and 1.0. The default value is 0.01, which is very small.

zoomHeightTo property
public var zoomHeightTo:Number

Number that represents the scale at which to complete the height zoom, as a percent between 0.01 and 1.0. The default value is 1.0, which is the object's normal size.

zoomWidthFrom property
public var zoomWidthFrom:Number

Number that represents the scale at which to start the width zoom, as a percent between 0.01 and 1.0. The default value is 0.01, which is very small.

zoomWidthTo property
public var zoomWidthTo:Number

Number that represents the scale at which to complete the width zoom, as a percent between 0.01 and 1.0. The default value is 1.0, which is the object's normal size.

Constructor detail
ZoomInstance () constructor
public function ZoomInstance(target:Object)

Constructor.

Parameters
target:Object — The Object to animate with this effect.


mx.events Summary (Flex™ 2 Language Reference)

Package mx.events | Classes

The mx.events package contains the classes that define Flex event objects.

Classes
Class | Description
CalendarLayoutChangeEvent | The CalendarLayoutChangeEvent class represents the event object passed to the event listener for the change event for the DateChooser and DateField controls.
ChildExistenceChangedEvent | Represents events that are dispatched when a the child of a control is created or destroyed.
CloseEvent | The CloseEvent class represents event objects specific to popup windows, such as the Alert control.
CollectionEvent | The mx.events.CollectionEvent class represents an event that is dispatched when the associated collection changes.
CollectionEventKind | The CollectionEventKind class contains constants for the valid values of the mx.events.CollectionEvent class kind property.
ColorPickerEvent | Represents events that are specific to the ColorPicker control, such as when the user rolls the mouse over or out of a swatch in the swatch panel.
CuePointEvent | The CuePointEvent class represents the event object passed to the event listener for cue point events dispatched by the VideoDisplay control.
DataGridEvent | The DataGridEvent class represents event objects that are specific to the DataGrid control, such as the event that is dispatched when an editable grid item gets the focus.
DataGridEventReason | The DataGridEventReason class defines constants for the values of the reason property of a DataGridEvent object when the type property is itemEditEnd.
DateChooserEvent | The DateChooserEvent class represents the event object passed to the event listener for the scroll event for the DateChooser and DateField controls.
DateChooserEventDetail | Constants that define the values of the detail property of a DateChooserEvent object.
DividerEvent | Represents events that are dispatched when a divider has been pressed, dragged or released.
DragEvent | The DragEvent class represents event objects that are dispatched as part of a drag-and-drop operation.
DropdownEvent | The DropdownEvent class represents the event object passed to the event listener for the open and close events.
DynamicEvent | This subclass of Event is dynamic, meaning that you can set arbitrary event properties on its instances at runtime.
EffectEvent | Represents event objects that are specific to Flex effects.
FlexEvent | The FlexEvent class represents the event object passed to the event listener for many Flex events.
FlexMouseEvent | The FlexMouseEvent class represents the event object passed to the event listener for Flex-specific mouse activity.
IndexChangedEvent | The IndexChangedEvent class represents events that are dispatched when an index changes.
ItemClickEvent | Represents events that are dispatched when a navigation item on a navigator bar, such as a ButtonBar, LinkBar, or TabBar control, has been clicked.
ListEvent | The ListEvent class represents events associated with items in list-based controls such as List, Tree, Menu, and DataGrid.
ListEventReason | Constants for the values of the reason property of a ListEvent object where the value of the type property is ListEvent.ITEM_EDIT_END.
MenuEvent | The MenuEvent class represents events that are associated with menu activities in controls such as Menu, MenuBar, and PopUpMenuButton.
MoveEvent | Represents event objects that are dispatched when a Flex component moves.
NumericStepperEvent | Represents events that are specific to the NumericStepper control.
PropertyChangeEvent | The PropertyChangeEvent class represents the event object passed to the event listener when one of the properties of an object has changed, and provides information about the change.
PropertyChangeEventKind | The PropertyChangeEventKind class defines the constant values for the kind property of the PropertyChangeEvent class.
ResizeEvent | Represents event objects that are dispatched when the size of a Flex component changes.
RSLEvent | The RSLEvent class represents an event object used by the DownloadProgressBar class when an RSL is being downloaded by the Preloader class.
ScrollEvent | Represents events that are dispatched by the ScrollBar class.
ScrollEventDetail | Constants for the values of the detail property of a ScrollEvent.
ScrollEventDirection | Constants for the values of the direction property of a ScrollEvent.
SliderEvent | The SliderEvent class represents the event object passed to the event listener for the change, thumbDrag, thumbPress, and thumbRelease events of the HSlider and VSlider classes.
SliderEventClickTarget | The SliderEventClickTarget class defines the constants for the values of the clickTarget property of the SliderEvent class.
StateChangeEvent | The StateChangeEvent class represents an event that is dispatched when the currentState property of a component changes.
ToolTipEvent | The ToolTipEvent class represents ToolTip events, which are generated by the ToolTipManager class.
TreeEvent | The TreeEvent class represents the event object passed to the event listener for events that are associated with activities in tree, such as when a tree branch opens or closes.
TweenEvent | Represents event objects that are specific to Flex tween effects.
ValidationResultEvent | The ValidationResultEvent class represents the event object passed to the listener for the valid validator event or the invalid validator event.
VideoEvent | The VideoEvent class represents the event object passed to the event listener for events dispatched by the VideoDisplay control, and defines the values of the VideoDisplay.state property.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.events.CalendarLayoutChangeEvent (Flex™ 2 Language Reference)

Class CalendarLayoutChangeEvent | Properties | Methods | Constants
Package | mx.events
Class | public class CalendarLayoutChangeEvent
Inheritance | CalendarLayoutChangeEvent Inheritance Event Inheritance Object

The CalendarLayoutChangeEvent class represents the event object passed to the event listener for the change event for the DateChooser and DateField controls.

See also

mx.controls.DateChooser
mx.controls.DateField

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | newDate : Date The selected date of the control. | CalendarLayoutChangeEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | triggerEvent : Event The event that triggered the change of the date; usually a change event. | CalendarLayoutChangeEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CalendarLayoutChangeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, newDate:Date = null, triggerEvent:Event = null) Constructor. | CalendarLayoutChangeEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
 | CHANGE : String = "change" [static] The CalendarLayoutChangeEvent.CHANGE constant defines the value of the type property of the event object for a change event. | CalendarLayoutChangeEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
newDate property
public var newDate:Date

The selected date of the control.

triggerEvent property
public var triggerEvent:Event

The event that triggered the change of the date; usually a change event.

Constructor detail
CalendarLayoutChangeEvent () constructor
public function CalendarLayoutChangeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, newDate:Date = null, triggerEvent:Event = null)

Constructor.

Parameters
type:String — The event type; indicates the action that triggered the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
newDate:Date (default = null) — The date selected in the control.
triggerEvent:Event (default = null) — The event that triggered this change event; usually a change event.
Constant detail
CHANGE constant
public static const CHANGE:String = "change"

The CalendarLayoutChangeEvent.CHANGE constant defines the value of the type property of the event object for a change event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
newDate | The date selected in the control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | The event that triggered this change event; usually a change event.


mx.events.ChildExistenceChangedEvent (Flex™ 2 Language Reference)

Class ChildExistenceChangedEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ChildExistenceChangedEvent
Inheritance | ChildExistenceChangedEvent Inheritance Event Inheritance Object

Represents events that are dispatched when a the child of a control is created or destroyed.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relatedObject : DisplayObject Reference to the child object that was created or destroyed. | ChildExistenceChangedEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ChildExistenceChangedEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, relatedObject:DisplayObject = null) Constructor. | ChildExistenceChangedEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
 | CHILD_ADD : String = "childAdd" [static] The ChildExistenceChangedEvent.CHILD_ADD constant defines the value of the type property of the event object for a childAdd event. | ChildExistenceChangedEvent
 | CHILD_REMOVE : String = "childRemove" [static] The ChildExistenceChangedEvent.CHILD_REMOVE constant defines the value of the type property of the event object for a childRemove event. | ChildExistenceChangedEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
 | OVERLAY_CREATED : String = "overlayCreated" [static] The ChildExistenceChangedEvent.OVERLAY_CREATED constant defines the value of the type property of the event object for a overlayCreated event. | ChildExistenceChangedEvent
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
relatedObject property
public var relatedObject:DisplayObject

Reference to the child object that was created or destroyed.

Constructor detail
ChildExistenceChangedEvent () constructor
public function ChildExistenceChangedEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, relatedObject:DisplayObject = null)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
relatedObject:DisplayObject (default = null) — Reference to the child object that was created or destroyed.
Constant detail
CHILD_ADD constant
public static const CHILD_ADD:String = "childAdd"

The ChildExistenceChangedEvent.CHILD_ADD constant defines the value of the type property of the event object for a childAdd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
relatedObject | Contains a reference to the child object that was created.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
CHILD_REMOVE constant
public static const CHILD_REMOVE:String = "childRemove"

The ChildExistenceChangedEvent.CHILD_REMOVE constant defines the value of the type property of the event object for a childRemove event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
relatedObject | Contains a reference to the child object that is about to be removed.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
OVERLAY_CREATED constant
public static const OVERLAY_CREATED:String = "overlayCreated"

The ChildExistenceChangedEvent.OVERLAY_CREATED constant defines the value of the type property of the event object for a overlayCreated event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
relatedObject | Contains a reference to the child object whose overlay was created.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.CloseEvent (Flex™ 2 Language Reference)

Class CloseEvent | Properties | Methods | Constants
Package | mx.events
Class | public class CloseEvent
Inheritance | CloseEvent Inheritance Event Inheritance Object

The CloseEvent class represents event objects specific to popup windows, such as the Alert control.

See also

mx.controls.Alert

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | detail : int Identifies the button in the popped uo control that was clicked. | CloseEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CloseEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, detail:int = -1) Constructor. | CloseEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
 | CLOSE : String = "close" [static] The CloseEvent.CHANGE constant defines the value of the type property of the event object for a close event. | CloseEvent
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
detail property
public var detail:int

Identifies the button in the popped uo control that was clicked. This property is for controls with multiple buttons. The Alert control sets this property to one of the following constants:

  • Alert.YES
  • Alert.NO
  • Alert.OK
  • Alert.CANCEL

Constructor detail
CloseEvent () constructor
public function CloseEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, detail:int = -1)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
detail:int (default = -1) — Value of the detail property; identifies the button in the popped up control that was clicked.
Constant detail
CLOSE constant
public static const CLOSE:String = "close"

The CloseEvent.CHANGE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
detail | For controls with multiple buttons, detail identifies the button in the popped up control that was clicked.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.CollectionEvent (Flex™ 2 Language Reference)

Class CollectionEvent | Properties | Methods | Constants
Package | mx.events
Class | public class CollectionEvent
Inheritance | CollectionEvent Inheritance Event Inheritance Object

The mx.events.CollectionEvent class represents an event that is dispatched when the associated collection changes.

See also

FlexEvent.CURSOR_UPDATE

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | items : Array When the kind is CollectionEventKind.ADD or CollectionEventKind.REMOVE the items property is an Array of added/removed items. | CollectionEvent
 | kind : String Indicates the kind of event that occurred. | CollectionEvent
 | location : int When the kind value is CollectionEventKind.ADD, CollectionEventKind.MOVE, CollectionEventKind.REMOVE, or CollectionEventKind.REPLACE, this property is the zero-base index in the collection of the item(s) specified in the items property. | CollectionEvent
 | oldLocation : int When the kind value is CollectionEventKind.MOVE, this property is the zero-based index in the target collection of the previous location of the item(s) specified by the items property. | CollectionEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CollectionEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, kind:String = null, location:int = -1, oldLocation:int = -1, items:Array = null) Constructor. | CollectionEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
 | COLLECTION_CHANGE : String = "collectionChange" [static] The CollectionEvent.COLLECTION_CHANGE constant defines the value of the type property of the event object for an event that is dispatched when a collection has changed. | CollectionEvent
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
items property
public var items:Array

When the kind is CollectionEventKind.ADD or CollectionEventKind.REMOVE the items property is an Array of added/removed items. When the kind is CollectionEventKind.REPLACE or CollectionEventKind.UPDATE the items property is an Array of PropertyChangeEvent objects with information about the items affected by the event. When a value changes, query the newValue and oldValue fields of the PropertyChangeEvent objects to find out what the old and new values were. When the kind is CollectionEventKind.REFRESH or CollectionEventKind.RESET, this array has zero length.

The default value is [ ].

See also

PropertyChangeEvent
kind property
public var kind:String

Indicates the kind of event that occurred. The property value can be one of the values in the CollectionEventKind class, or null, which indicates that the kind is unknown.

The default value is null.

See also

CollectionEventKind
location property
public var location:int

When the kind value is CollectionEventKind.ADD, CollectionEventKind.MOVE, CollectionEventKind.REMOVE, or CollectionEventKind.REPLACE, this property is the zero-base index in the collection of the item(s) specified in the items property.

The default value is -1.

See also

CollectionEventKind
oldLocation property
public var oldLocation:int

When the kind value is CollectionEventKind.MOVE, this property is the zero-based index in the target collection of the previous location of the item(s) specified by the items property.

The default value is -1.

Constructor detail
CollectionEvent () constructor
public function CollectionEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, kind:String = null, location:int = -1, oldLocation:int = -1, items:Array = null)

Constructor.

Parameters
type:String — The event type; indicates the action that triggered the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
kind:String (default = null) — Indicates the kind of event that occured. The parameter value can be one of the values in the CollectionEventKind class, or null, which indicates that the kind is unknown.
location:int (default = -1) — When the kind is CollectionEventKind.ADD, CollectionEventKind.MOVE, CollectionEventKind.REMOVE, or CollectionEventKind.REPLACE, this value indicates at what location the item(s) specified in the items property can be found within the target collection.
oldLocation:int (default = -1) — When the kind is CollectionEventKind.MOVE, this value indicates the old location within the target collection of the item(s) specified in the items property.
items:Array (default = null) — Array of objects with information about the items affected by the event, as described in the items property. When the kind is CollectionEventKind.REFRESH or CollectionEventKind.RESET, this Array has zero length.
Constant detail
COLLECTION_CHANGE constant
public static const COLLECTION_CHANGE:String = "collectionChange"

The CollectionEvent.COLLECTION_CHANGE constant defines the value of the type property of the event object for an event that is dispatched when a collection has changed.

The properties of the event object have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
items | An Array of objects with information about the items affected by the event. The contents of this field depend on the event kind; for details see the items property
kind | The kind of event. The valid values are defined in the CollectionEventKind class as constants.
location | Location within the target collection of the item(s) specified in the items property.
oldLocation | the previous location in the collection of the item specified in the items property.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | CollectionEvent.COLLECTION_CHANGE


mx.events.CollectionEventKind (Flex™ 2 Language Reference)

Class CollectionEventKind | Properties | Methods | Constants
Package | mx.events
Class | public final class CollectionEventKind
Inheritance | CollectionEventKind Inheritance Object

The CollectionEventKind class contains constants for the valid values of the mx.events.CollectionEvent class kind property. These constants indicate the kind of change that was made to the collection.

See also

mx.events.CollectionEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ADD : String = "add" [static] Indicates that the collection added an item or items. | CollectionEventKind
 | MOVE : String = "move" [static] Indicates that the item has moved from the position identified by the CollectionEvent oldLocation property to the position identified by the location property. | CollectionEventKind
 | REFRESH : String = "refresh" [static] Indicates that the collection applied a sort, a filter, or both. | CollectionEventKind
 | REMOVE : String = "remove" [static] Indicates that the collection removed an item or items. | CollectionEventKind
 | REPLACE : String = "replace" [static] Indicates that the item at the position identified by the CollectionEvent location property has been replaced. | CollectionEventKind
 | RESET : String = "reset" [static] Indicates that the collection has changed so drastically that a reset is required. | CollectionEventKind
 | UPDATE : String = "update" [static] Indicates that one or more items were updated within the collection. | CollectionEventKind
Constant detail
ADD constant
public static const ADD:String = "add"

Indicates that the collection added an item or items.

MOVE constant
public static const MOVE:String = "move"

Indicates that the item has moved from the position identified by the CollectionEvent oldLocation property to the position identified by the location property.

REFRESH constant
public static const REFRESH:String = "refresh"

Indicates that the collection applied a sort, a filter, or both. This change can potentially be easier to handle than a RESET.

REMOVE constant
public static const REMOVE:String = "remove"

Indicates that the collection removed an item or items.

REPLACE constant
public static const REPLACE:String = "replace"

Indicates that the item at the position identified by the CollectionEvent location property has been replaced.

RESET constant
public static const RESET:String = "reset"

Indicates that the collection has changed so drastically that a reset is required.

UPDATE constant
public static const UPDATE:String = "update"

Indicates that one or more items were updated within the collection. The affected item(s) or their associated ObjectChangeEvent objects are stored in the items property.


mx.events.ColorPickerEvent (Flex™ 2 Language Reference)

Class ColorPickerEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ColorPickerEvent
Inheritance | ColorPickerEvent Inheritance Event Inheritance Object

Represents events that are specific to the ColorPicker control, such as when the user rolls the mouse over or out of a swatch in the swatch panel.

See also

ColorPicker control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | color : uint The RGB color that was rolled over, rolled out of, selected, or entered. | ColorPickerEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | index : int The zero-based index in the Color's data provider that corresponds to the color that was rolled over, rolled out of, or selected. | ColorPickerEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ColorPickerEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, index:int = -1, color:uint = 0xFFFFFFFF) Constructor. | ColorPickerEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
 | CHANGE : String = "change" [static] The ColorPickerEvent.CHANGE constant defines the value of the type property of the event that is dispatched when the user selects a color from the ColorPicker control. | ColorPickerEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | ENTER : String = "enter" [static] The ColorPickerEvent.ENTER constant defines the value of the type property of the event that is dispatched when the user presses the Enter key after typing in the color selector box. | ColorPickerEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_ROLL_OUT : String = "itemRollOut" [static] The ColorPickerEvent.ITEM_ROLL_OUT constant defines the value of the type property of the event that is dispatched when the user rolls the mouse out of a swatch in the swatch panel. | ColorPickerEvent
 | ITEM_ROLL_OVER : String = "itemRollOver" [static] The ColorPickerEvent.ITEM_ROLL_OVER constant defines the value of the type property of the event that is dispatched when the user rolls the mouse over of a swatch in the swatch panel. | ColorPickerEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
color property
public var color:uint

The RGB color that was rolled over, rolled out of, selected, or entered.

index property
public var index:int

The zero-based index in the Color's data provider that corresponds to the color that was rolled over, rolled out of, or selected. If the event type is ColorPickerEvent.ENTER, will have default value -1; it is not set in this case because the user can enter an RGB string that doesn't match any color in the data provider.

Constructor detail
ColorPickerEvent () constructor
public function ColorPickerEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, index:int = -1, color:uint = 0xFFFFFFFF)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
index:int (default = -1) — The zero-based index in the Color's data provider that corresponds to the color that was rolled over, rolled out of, or selected.
color:uint (default = 0xFFFFFFFF) — The RGB color that was rolled over, rolled out of, selected, or entered.
Constant detail
CHANGE constant
public static const CHANGE:String = "change"

The ColorPickerEvent.CHANGE constant defines the value of the type property of the event that is dispatched when the user selects a color from the ColorPicker control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color that was selected.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The zero-based index in the Color's data provider that corresponds to the color that was selected.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
ENTER constant
public static const ENTER:String = "enter"

The ColorPickerEvent.ENTER constant defines the value of the type property of the event that is dispatched when the user presses the Enter key after typing in the color selector box.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color that was entered.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | Always -1.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
ITEM_ROLL_OUT constant
public static const ITEM_ROLL_OUT:String = "itemRollOut"

The ColorPickerEvent.ITEM_ROLL_OUT constant defines the value of the type property of the event that is dispatched when the user rolls the mouse out of a swatch in the swatch panel.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color of the color that was rolled over.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The zero-based index in the Color's data provider that corresponds to the color that was rolled over.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
ITEM_ROLL_OVER constant
public static const ITEM_ROLL_OVER:String = "itemRollOver"

The ColorPickerEvent.ITEM_ROLL_OVER constant defines the value of the type property of the event that is dispatched when the user rolls the mouse over of a swatch in the swatch panel.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
color | The RGB color of the color that the user rolled out of.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The zero-based index in the Color's data provider that corresponds to the color that the user rolled out of.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.CuePointEvent (Flex™ 2 Language Reference)

Class CuePointEvent | Properties | Methods | Constants
Package | mx.events
Class | public class CuePointEvent
Inheritance | CuePointEvent Inheritance Event Inheritance Object

The CuePointEvent class represents the event object passed to the event listener for cue point events dispatched by the VideoDisplay control.

See also

mx.controls.VideoDisplay

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | cuePointName : String The name of the cue point that caused the event. | CuePointEvent
 | cuePointTime : Number The time of the cue point that caused the event, in seconds. | CuePointEvent
 | cuePointType : String The string "actionscript". | CuePointEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CuePointEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, cuePointName:String = null, cuePointTime:Number, cuePointType:String = null) Constructor. | CuePointEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
 | CUE_POINT : String = "cuePoint" [static] The CuePointEvent.CUE_POINT constant defines the value of the type property of the event object for a cuePoint event. | CuePointEvent
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
cuePointName property
public var cuePointName:String

The name of the cue point that caused the event.

cuePointTime property
public var cuePointTime:Number

The time of the cue point that caused the event, in seconds.

cuePointType property
public var cuePointType:String

The string "actionscript".

Constructor detail
CuePointEvent () constructor
public function CuePointEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, cuePointName:String = null, cuePointTime:Number, cuePointType:String = null)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
cuePointName:String (default = null) — The name of the cue point.
cuePointTime:Number — The time of the cue point, in seconds.
cuePointType:String (default = null) — The string "actionscript".
Constant detail
CUE_POINT constant
public static const CUE_POINT:String = "cuePoint"

The CuePointEvent.CUE_POINT constant defines the value of the type property of the event object for a cuePoint event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
cuePointName | The name of the cue point.
cuePointTime | The time of the cue point, in seconds.
cuePointType | The string "actionscript".
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.DataGridEvent (Flex™ 2 Language Reference)

Class DataGridEvent | Properties | Methods | Constants
Package | mx.events
Class | public class DataGridEvent
Inheritance | DataGridEvent Inheritance Event Inheritance Object

The DataGridEvent class represents event objects that are specific to the DataGrid control, such as the event that is dispatched when an editable grid item gets the focus.

See also

mx.controls.DataGrid

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | columnIndex : int The zero-based index in the DataGrid object's columns array of the column associated with the event. | DataGridEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | dataField : String The name of the field or property in the data associated with the column. | DataGridEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | itemRenderer : IListItemRenderer The item renderer for the item that is being edited or the header render that is being clicked or stretched. | DataGridEvent
 | localX : Number The column's x-position; used for replaying column stretch events. | DataGridEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | reason : String The reason the itemEditEnd event was dispatched. | DataGridEvent
 | rowIndex : int The zero-based index of the item in the data provider. | DataGridEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DataGridEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, columnIndex:int = -1, dataField:String = null, rowIndex:int = -1, reason:String = null, itemRenderer:IListItemRenderer = null, localX:Number) Constructor. | DataGridEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
 | COLUMN_STRETCH : String = "columnStretch" [static] The DataGridEvent.COLUMN_STRETCH constant defines the value of the type property of the event object for a columnStretch event, which indicates that a user expanded a column horizontally. | DataGridEvent
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | HEADER_RELEASE : String = "headerRelease" [static] The DataGridEvent.HEADER_RELEASE constant defines the value of the type property of the event object for a headerRelease event, which indicates that the user pressed and released the mouse on a column header. | DataGridEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_EDIT_BEGIN : String = "itemEditBegin" [static] The DataGridEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited. | DataGridEvent
 | ITEM_EDIT_BEGINNING : String = "itemEditBeginning" [static] The DataGridEvent.ITEM__EDIT_BEGINNING constant defines the value of the type property of the event object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item. | DataGridEvent
 | ITEM_EDIT_END : String = "itemEditEnd" [static] The DataGridEvent.ITEM_EDIT_END constant defines the value of the type property of the event object for a itemEditEnd event, which indicates that an edit session is ending. | DataGridEvent
 | ITEM_FOCUS_IN : String = "itemFocusIn" [static] The DataGridEvent.ITEM_FOCUS_IN constant defines the value of the type property of the event object for a itemFocusIn event, which indicates that an item has received the focus. | DataGridEvent
 | ITEM_FOCUS_OUT : String = "itemFocusOut" [static] The DataGridEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the event object for a itemFocusOut event, which indicates that an item has lost the focus. | DataGridEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
columnIndex property
public var columnIndex:int

The zero-based index in the DataGrid object's columns array of the column associated with the event.

dataField property
public var dataField:String

The name of the field or property in the data associated with the column.

itemRenderer property
public var itemRenderer:IListItemRenderer

The item renderer for the item that is being edited or the header render that is being clicked or stretched. You can access the data provider item using this property.

localX property
public var localX:Number

The column's x-position; used for replaying column stretch events.

reason property
public var reason:String

The reason the itemEditEnd event was dispatched. Valid only for events with type ITEM_EDIT_END. The possible values are defined in the DataGridEventReason class.

See also

DataGridEventReason
rowIndex property
public var rowIndex:int

The zero-based index of the item in the data provider.

Constructor detail
DataGridEvent () constructor
public function DataGridEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, columnIndex:int = -1, dataField:String = null, rowIndex:int = -1, reason:String = null, itemRenderer:IListItemRenderer = null, localX:Number)

Constructor. Normally called by the DataGrid object; not used in application code.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
columnIndex:int (default = -1) — The zero-based index of the column where the event occurred.
dataField:String (default = null) — The name of the field or property in the data associated with the column.
rowIndex:int (default = -1) — The zero-based index of the item in the in the data provider.
reason:String (default = null) — The reason for an itemEditEnd event.
itemRenderer:IListItemRenderer (default = null) — The item renderer that is being edited or the header renderer that was clicked..
localX:Number — Column x-position for replaying columnStretch events.
Constant detail
COLUMN_STRETCH constant
public static const COLUMN_STRETCH:String = "columnStretch"

The DataGridEvent.COLUMN_STRETCH constant defines the value of the type property of the event object for a columnStretch event, which indicates that a user expanded a column horizontally.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the column.
itemRenderer | null
localX | the x position of the mouse
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.COLUMN_STRETCH
HEADER_RELEASE constant
public static const HEADER_RELEASE:String = "headerRelease"

The DataGridEvent.HEADER_RELEASE constant defines the value of the type property of the event object for a headerRelease event, which indicates that the user pressed and released the mouse on a column header.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the column.
itemRenderer | The header renderer that is being released.
localX | NaN
reason | null
rowIndex | null
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.HEADER_RELEASE
ITEM_EDIT_BEGIN constant
public static const ITEM_EDIT_BEGIN:String = "itemEditBegin"

The DataGridEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited.

The default listener for this event performs the following actions:

  • Creates an item editor object by using a call to the createItemEditor() method.
  • Copies the data property from the item to the editor. By default, the item editor object is an instance of the TextInput control. You use the itemEditor property of the list control to specify a custom item editor class.
  • Set the itemEditorInstance property of the list control to reference the item editor instance.

You can write an event listener for this event to modify the data passed to the item editor. For example, you might modify the data, its format, or other information used by the item editor.

You can also create an event listener to specify the item editor used to edit the item. For example, you might have two different item editors. Within the event listener you can examine the data to be edited or other information, and open the appropriate item editor by doing the following:

  1. Call preventDefault() to stop Flex from calling the createItemEditor() method as part of the default event listener.
  2. Set the itemEditor property to the appropriate editor.
  3. Call the createItemEditor() method.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | null
itemRenderer | The item renderer for the item that is being edited.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_EDIT_BEGIN
ITEM_EDIT_BEGINNING constant
public static const ITEM_EDIT_BEGINNING:String = "itemEditBeginning"

The DataGridEvent.ITEM__EDIT_BEGINNING constant defines the value of the type property of the event object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item.

The default listener for this event sets the DataGrid.editedItemPosition property to the item that has focus, which starts the item editing session.

You typically write your own event listener for this event to disallow editing of a specific item or items. Calling the preventDefault() method from within your own event listener for this event prevents the default listener from executing.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the item's column.
itemRenderer | The item renderer for the item that will be edited. This property is null if this event is generated by keyboard, as the item to be edited may be off-screen.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_EDIT_BEGINNING
ITEM_EDIT_END constant
public static const ITEM_EDIT_END:String = "itemEditEnd"

The DataGridEvent.ITEM_EDIT_END constant defines the value of the type property of the event object for a itemEditEnd event, which indicates that an edit session is ending.

The list components have a default handler for this event that copies the data from the item editor to the data provider of the list control. The default event listener performs the following actions:

  • Uses the editorDataField property of the DataGridColumn associated with this event to determine the property of the item editor containing the new data and updates the data provider item with that new data. Since the default item editor is the TextInput control, the default value of the editorDataField property is "text", to specify that the text property of the TextInput contains the new item data.
  • Calls the destroyItemEditor() method to close the item editor.

You typically write an event listener for this event to perform the following actions:

  • In your event listener, you can modify the data returned by the editor to the list component. For example, you can reformat the data before returning it to the list control. By default, an item editor can only return a single value. You must write an event listener for the itemEditEnd event if you want to return multiple values.
  • In your event listener, you can examine the data entered into the item editor. If the data is incorrect, you can call the preventDefault() method to stop Flex from passing the new data back to the list control and from closing the editor.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | The name of the field or property in the data associated with the item's column.
itemRenderer | The item renderer for the item that is being edited.
localX | NaN
reason | A constant defining the reason for the event. The value must be a member of the DataGridEventReason class.
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_EDIT_END
ITEM_FOCUS_IN constant
public static const ITEM_FOCUS_IN:String = "itemFocusIn"

The DataGridEvent.ITEM_FOCUS_IN constant defines the value of the type property of the event object for a itemFocusIn event, which indicates that an item has received the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | null
itemRenderer | The item editor instance for the item that is being edited.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_FOCUS_IN
ITEM_FOCUS_OUT constant
public static const ITEM_FOCUS_OUT:String = "itemFocusOut"

The DataGridEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the event object for a itemFocusOut event, which indicates that an item has lost the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the item's column in the DataGrid object's columns array.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dataField | null
itemRenderer | The item editor instance for the item that is being edited.
localX | NaN
reason | null
rowIndex | The zero-based index of the item in the data provider.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | DataGridEvent.ITEM_FOCUS_OUT


mx.events.DataGridEventReason (Flex™ 2 Language Reference)

Class DataGridEventReason | Properties | Methods | Constants
Package | mx.events
Class | public final class DataGridEventReason
Inheritance | DataGridEventReason Inheritance Object

The DataGridEventReason class defines constants for the values of the reason property of a DataGridEvent object when the type property is itemEditEnd.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CANCELLED : String = "cancelled" [static] Specifies that the user cancelled editing and that they do not want to save the edited data. | DataGridEventReason
 | NEW_COLUMN : String = "newColumn" [static] Specifies that the user moved focus to a new column in the same row. | DataGridEventReason
 | NEW_ROW : String = "newRow" [static] Specifies that the user moved focus to a new row. | DataGridEventReason
 | OTHER : String = "other" [static] Specifies that the list control lost focus, was scrolled, or is somehow in a state where editing is not allowed. | DataGridEventReason
Constant detail
CANCELLED constant
public static const CANCELLED:String = "cancelled"

Specifies that the user cancelled editing and that they do not want to save the edited data. Even if you call the preventDefault() method from within your event listener for the itemEditEnd event, Flex still calls the destroyItemEditor() editor to close the editor.

NEW_COLUMN constant
public static const NEW_COLUMN:String = "newColumn"

Specifies that the user moved focus to a new column in the same row. Within an event listener, you can let the focus change occur, or prevent it. For example, your event listener might check that the user entered a valid value for the item currently being edited. If not, you can prevent the user from moving to a new item by calling the preventDefault() method. In this case, the item editor remains open, and the user continues to edit the current item. If you call the preventDefault() method and also call the destroyItemEditor() method, you block the move to the new item, but the item editor closes.

NEW_ROW constant
public static const NEW_ROW:String = "newRow"

Specifies that the user moved focus to a new row. You handle this reason much like you handle NEW_COLUMN.

OTHER constant
public static const OTHER:String = "other"

Specifies that the list control lost focus, was scrolled, or is somehow in a state where editing is not allowed. Even if you call the preventDefault() method from within your event listener for the itemEditEnd event, Flex still calls the destroyItemEditor() editor to close the editor.


mx.events.DateChooserEvent (Flex™ 2 Language Reference)

Class DateChooserEvent | Properties | Methods | Constants
Package | mx.events
Class | public class DateChooserEvent
Inheritance | DateChooserEvent Inheritance Event Inheritance Object

The DateChooserEvent class represents the event object passed to the event listener for the scroll event for the DateChooser and DateField controls.

See also

mx.controls.DateChooser
mx.controls.DateField
mx.events.DateChooserEventDetail
DateChooser and DateField controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | detail : String Indicates the direction of scrolling. | DateChooserEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | triggerEvent : Event The event that triggered this change; usually a scroll. | DateChooserEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DateChooserEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, detail:String = null, triggerEvent:Event = null) Constructor. | DateChooserEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | SCROLL : String = "scroll" [static] The DateChooserEvent.SCROLL constant defines the value of the type property of the event object for a scrollevent. | DateChooserEvent
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
detail property
public var detail:String

Indicates the direction of scrolling. The values are defined by the DateChooserEventDetail class. The possible values are DateChooserEventDetail.NEXT_MONTH, DateChooserEventDetail.NEXT_YEAR, DateChooserEventDetail.PREVIOUS_MONTH, or DateChooserEventDetail.PREVIOUS_YEAR.

See also

mx.events.DateChooserEventDetail
triggerEvent property
public var triggerEvent:Event

The event that triggered this change; usually a scroll.

Constructor detail
DateChooserEvent () constructor
public function DateChooserEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, detail:String = null, triggerEvent:Event = null)

Constructor. Normally called by the DateChooser object and not used in application code.

Parameters
type:String — The event type; indicates the action that triggered the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
detail:String (default = null) — Indicates the unit and direction of scrolling. The possible values are DateChooserEventDetail.NEXT_MONTH, DateChooserEventDetail.NEXT_YEAR, DateChooserEventDetail.PREVIOUS_MONTH, or DateChooserEventDetail.PREVIOUS_YEAR.
triggerEvent:Event (default = null) — The event that triggered this change event; usually a scroll.
Constant detail
SCROLL constant
public static const SCROLL:String = "scroll"

The DateChooserEvent.SCROLL constant defines the value of the type property of the event object for a scrollevent.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
detail | The scroll direction.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | The event that triggered this change event; usually a scroll.


mx.events.DateChooserEventDetail (Flex™ 2 Language Reference)

Class DateChooserEventDetail | Properties | Methods | Constants
Package | mx.events
Class | public final class DateChooserEventDetail
Inheritance | DateChooserEventDetail Inheritance Object

Constants that define the values of the detail property of a DateChooserEvent object.

See also

mx.events.DateChooserEvent
DateChooser and DateField controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | NEXT_MONTH : String = "nextMonth" [static] Indicates that the user scrolled the calendar to the next month. | DateChooserEventDetail
 | NEXT_YEAR : String = "nextYear" [static] Indicates that the user scrolled the calendar to the next year. | DateChooserEventDetail
 | PREVIOUS_MONTH : String = "previousMonth" [static] Indicates that the user scrolled the calendar to the previous month. | DateChooserEventDetail
 | PREVIOUS_YEAR : String = "previousYear" [static] Indicates that the user scrolled the calendar to the previous year. | DateChooserEventDetail
Constant detail
NEXT_MONTH constant
public static const NEXT_MONTH:String = "nextMonth"

Indicates that the user scrolled the calendar to the next month.

NEXT_YEAR constant
public static const NEXT_YEAR:String = "nextYear"

Indicates that the user scrolled the calendar to the next year.

PREVIOUS_MONTH constant
public static const PREVIOUS_MONTH:String = "previousMonth"

Indicates that the user scrolled the calendar to the previous month.

PREVIOUS_YEAR constant
public static const PREVIOUS_YEAR:String = "previousYear"

Indicates that the user scrolled the calendar to the previous year.


mx.events.DividerEvent (Flex™ 2 Language Reference)

Class DividerEvent | Properties | Methods | Constants
Package | mx.events
Class | public class DividerEvent
Inheritance | DividerEvent Inheritance Event Inheritance Object

Represents events that are dispatched when a divider has been pressed, dragged or released. These events are dispatched by the DividedBox control and its children.

See also

mx.containers.DividedBox

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | delta : Number The number of pixels that the divider has been dragged. | DividerEvent
 | dividerIndex : int The zero-based index of the divider being pressed or dragged. | DividerEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DividerEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, dividerIndex:int = -1, delta:Number) Constructor. | DividerEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | DIVIDER_DRAG : String = "dividerDrag" [static] The DividerEvent.DIVIDER_DRAG constant defines the value of the type property of the event object for a dividerDrag event. | DividerEvent
 | DIVIDER_PRESS : String = "dividerPress" [static] The DividerEvent.DIVIDER_PRESS constant defines the value of the type property of the event object for a dividerPress event. | DividerEvent
 | DIVIDER_RELEASE : String = "dividerRelease" [static] The DividerEvent.DIVIDER_RELEASE constant defines the value of the type property of the event object for a dividerRelease event. | DividerEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
delta property
public var delta:Number

The number of pixels that the divider has been dragged. Positive numbers represent a drag toward the right or bottom, negative numbers toward the left or top.

dividerIndex property
public var dividerIndex:int

The zero-based index of the divider being pressed or dragged. The leftmost or topmost divider has a dividerIndex of 0.

Constructor detail
DividerEvent () constructor
public function DividerEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, dividerIndex:int = -1, delta:Number)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
dividerIndex:int (default = -1) — Index of the divider that generated the event.
delta:Number — The number of pixels by which the divider has been dragged.
Constant detail
DIVIDER_DRAG constant
public static const DIVIDER_DRAG:String = "dividerDrag"

The DividerEvent.DIVIDER_DRAG constant defines the value of the type property of the event object for a dividerDrag event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the number of pixels that the divider has been dragged. Positive numbers represent a drag toward the right or bottom, negative numbers toward the left or top.
dividerIndex | Contains the zero-based index of the divider being dragged. The leftmost or topmost divider has a dividerIndex of 0.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DIVIDER_PRESS constant
public static const DIVIDER_PRESS:String = "dividerPress"

The DividerEvent.DIVIDER_PRESS constant defines the value of the type property of the event object for a dividerPress event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the number of pixels that the divider has been dragged. Positive numbers represent a drag toward the right or bottom, negative numbers toward the left or top.
dividerIndex | Contains the zero-based index of the divider being dragged. The leftmost or topmost divider has a dividerIndex of 0.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DIVIDER_RELEASE constant
public static const DIVIDER_RELEASE:String = "dividerRelease"

The DividerEvent.DIVIDER_RELEASE constant defines the value of the type property of the event object for a dividerRelease event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the number of pixels that the divider has been dragged. Positive numbers represent a drag toward the right or bottom, negative numbers toward the left or top.
dividerIndex | Contains the zero-based index of the divider being dragged. The leftmost or topmost divider has a dividerIndex of 0.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.DragEvent (Flex™ 2 Language Reference)

Class DragEvent | Properties | Methods | Constants
Package | mx.events
Class | public class DragEvent
Inheritance | DragEvent Inheritance MouseEvent Inheritance Event Inheritance Object

The DragEvent class represents event objects that are dispatched as part of a drag-and-drop operation.

See also

mx.managers.DragManager
mx.core.DragSource
mx.core.UIComponent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | action : String The requested action. | DragEvent
Inherited | altKey : Boolean Reserved for future use. | MouseEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | buttonDown : Boolean Indicates whether the primary mouse button is pressed (true) or not (false). | MouseEvent
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | ctrlKey : Boolean Indicates whether the Control key is active (true) or inactive (false). | MouseEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | delta : int Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. | MouseEvent
 | dragInitiator : IUIComponent The component that initiated the drag. | DragEvent
 | dragSource : DragSource The DragSource object containing the data being dragged. | DragEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | localX : Number The horizontal coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | localY : Number The vertical coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relatedObject : InteractiveObject A reference to a display list object that is related to the event. | MouseEvent
Inherited | shiftKey : Boolean Indicates whether the Shift key is active (true) or inactive (false). | MouseEvent
Inherited | stageX : Number The horizontal coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | stageY : Number The vertical coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DragEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, dragInitiator:IUIComponent = null, dragSource:DragSource = null, action:String = null, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false) Constructor. | DragEvent
Inherited | clone():Event Creates a copy of the MouseEvent object and sets the value of each property to match that of the original. | MouseEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string that contains all the properties of the MouseEvent object. | MouseEvent
Inherited | updateAfterEvent():void Instructs Flash Player to render after processing of this event completes, if the display list has been modified. | MouseEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLICK : String = "click" [static] Defines the value of the type property of a click event object. | MouseEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | DOUBLE_CLICK : String = "doubleClick" [static] Defines the value of the type property of a doubleClick event object. | MouseEvent
 | DRAG_COMPLETE : String = "dragComplete" [static] The DragEvent.DRAG_COMPLETE constant defines the value of the type property of the event object for a dragComplete event. | DragEvent
 | DRAG_DROP : String = "dragDrop" [static] The DragEvent.DRAG_DROP constant defines the value of the type property of the event object for a dragDrop event. | DragEvent
 | DRAG_ENTER : String = "dragEnter" [static] The DragEvent.DRAG_ENTER constant defines the value of the type property of the event object for a dragEnter event. | DragEvent
 | DRAG_EXIT : String = "dragExit" [static] The DragEvent.DRAG_EXIT constant defines the value of the type property of the event object for a dragExit event. | DragEvent
 | DRAG_OVER : String = "dragOver" [static] The DragEvent.DRAG_OVER constant defines the value of the type property of the event object for a dragOver event. | DragEvent
 | DRAG_START : String = "dragStart" [static] The DragEvent.DRAG_START constant defines the value of the type property of the event object for a dragStart event. | DragEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_DOWN : String = "mouseDown" [static] Defines the value of the type property of a mouseDown event object. | MouseEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | MOUSE_MOVE : String = "mouseMove" [static] Defines the value of the type property of a mouseMove event object. | MouseEvent
Inherited | MOUSE_OUT : String = "mouseOut" [static] Defines the value of the type property of a mouseOut event object. | MouseEvent
Inherited | MOUSE_OVER : String = "mouseOver" [static] Defines the value of the type property of a mouseOver event object. | MouseEvent
Inherited | MOUSE_UP : String = "mouseUp" [static] Defines the value of the type property of a mouseUp event object. | MouseEvent
Inherited | MOUSE_WHEEL : String = "mouseWheel" [static] Defines the value of the type property of a mouseWheel event object. | MouseEvent
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | ROLL_OUT : String = "rollOut" [static] Defines the value of the type property of a rollOut event object. | MouseEvent
Inherited | ROLL_OVER : String = "rollOver" [static] Defines the value of the type property of a rollOver event object. | MouseEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
action property
public var action:String

The requested action. One of DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.

dragInitiator property
public var dragInitiator:IUIComponent

The component that initiated the drag.

dragSource property
public var dragSource:DragSource

The DragSource object containing the data being dragged.

Constructor detail
DragEvent () constructor
public function DragEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, dragInitiator:IUIComponent = null, dragSource:DragSource = null, action:String = null, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false)

Constructor. Normally called by the Flex control and not used in application code.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = true) — Specifies whether the behavior associated with the event can be prevented.
dragInitiator:IUIComponent (default = null) — IUIComponent that specifies the component initiating the drag.
dragSource:DragSource (default = null) — A DragSource object containing the data being dragged.
action:String (default = null) — The specified drop action, such as DragManager.MOVE.
ctrlKey:Boolean (default = false) — Indicates whether the Ctrl key was pressed.
altKey:Boolean (default = false) — Indicates whether the Alt key was pressed.
shiftKey:Boolean (default = false) — Indicates whether the Shift key was pressed.
Constant detail
DRAG_COMPLETE constant
public static const DRAG_COMPLETE:String = "dragComplete"

The DragEvent.DRAG_COMPLETE constant defines the value of the type property of the event object for a dragComplete event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DRAG_DROP constant
public static const DRAG_DROP:String = "dragDrop"

The DragEvent.DRAG_DROP constant defines the value of the type property of the event object for a dragDrop event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DRAG_ENTER constant
public static const DRAG_ENTER:String = "dragEnter"

The DragEvent.DRAG_ENTER constant defines the value of the type property of the event object for a dragEnter event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event, which is always DragManager.MOVE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DRAG_EXIT constant
public static const DRAG_EXIT:String = "dragExit"

The DragEvent.DRAG_EXIT constant defines the value of the type property of the event object for a dragExit event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DRAG_OVER constant
public static const DRAG_OVER:String = "dragOver"

The DragEvent.DRAG_OVER constant defines the value of the type property of the event object for a dragOver event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DRAG_START constant
public static const DRAG_START:String = "dragStart"

The DragEvent.DRAG_START constant defines the value of the type property of the event object for a dragStart event.

The properties of the event object have the following values:

Property | Value
action | The action that caused the event: DragManager.COPY, DragManager.LINK, DragManager.MOVE, or DragManager.NONE.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dragInitiator | The component that initiated the drag.
dragSource | The DragSource object containing the data being dragged.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.DropdownEvent (Flex™ 2 Language Reference)

Class DropdownEvent | Properties | Methods | Constants
Package | mx.events
Class | public class DropdownEvent
Inheritance | DropdownEvent Inheritance Event Inheritance Object

The DropdownEvent class represents the event object passed to the event listener for the open and close events.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | triggerEvent : Event If the control is opened or closed in response to a user action, this property contains a value indicating the type of input action. | DropdownEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DropdownEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, triggerEvent:Event = null) Constructor. | DropdownEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
 | CLOSE : String = "close" [static] The DropdownEvent.CLOSE constant defines the value of the type property of the event object for a close event. | DropdownEvent
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
 | OPEN : String = "open" [static] The DropdownEvent.OPEN constant defines the value of the type property of the event object for a open event. | DropdownEvent
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
triggerEvent property
public var triggerEvent:Event

If the control is opened or closed in response to a user action, this property contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.

Constructor detail
DropdownEvent () constructor
public function DropdownEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, triggerEvent:Event = null)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
triggerEvent:Event (default = null) — A value indicating the type of input action that triggered the event
Constant detail
CLOSE constant
public static const CLOSE:String = "close"

The DropdownEvent.CLOSE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.
OPEN constant
public static const OPEN:String = "open"

The DropdownEvent.OPEN constant defines the value of the type property of the event object for a open event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | A value indicating the type of input action that triggered the event.


mx.events.DynamicEvent (Flex™ 2 Language Reference)

Class DynamicEvent | Properties | Methods | Constants
Package | mx.events
Class | public dynamic class DynamicEvent
Inheritance | DynamicEvent Inheritance Event Inheritance Object

This subclass of Event is dynamic, meaning that you can set arbitrary event properties on its instances at runtime.

By contrast, Event and its other subclasses are non-dynamic, meaning that you can only set properties that are declared in those classes. When prototyping an application, using a DynamicEvent can be easier because you don't have to write an Event subclass to declare the properties in advance. However, you should eventually eliminate your DynamicEvents and write Event subclasses because these are faster and safer. A DynamicEvent is so flexible that the compiler can't help you catch your error when you set the wrong property or assign it a value of an incorrect type.

Example:

  var event:DynamicEvent = new DynamicEvent("credentialsChanged");
  event.name = name;
  event.passsword = password; // misspelling won't be caught!
  dispatchEvent(event);

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DynamicEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false) Constructor. | DynamicEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
DynamicEvent () constructor
public function DynamicEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.


mx.events.EffectEvent (Flex™ 2 Language Reference)

Class EffectEvent | Properties | Methods | Constants
Package | mx.events
Class | public class EffectEvent
Inheritance | EffectEvent Inheritance Event Inheritance Object

Represents event objects that are specific to Flex effects. Flex effects dispatch the following types of events:
  • effectStart
  • effectEnd

See also

mx.effects.Effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | effectInstance : EffectInstance The effect instance object for the event. | EffectEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | EffectEvent(eventType:String, bubbles:Boolean = false, cancelable:Boolean = false, effectInstance:EffectInstance = null) Constructor. | EffectEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | EFFECT_END : String = "effectEnd" [static] The EffectEvent.EFFECT_END constant defines the value of the type property of the event object for an effectEnd event. | EffectEvent
 | EFFECT_START : String = "effectStart" [static] The EffectEvent.EFFECT_START constant defines the value of the type property of the event object for an effectStart event. | EffectEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
effectInstance property
public var effectInstance:EffectInstance

The effect instance object for the event. You can use this property to access the properties of the effect instance object from within your event listener.

Constructor detail
EffectEvent () constructor
public function EffectEvent(eventType:String, bubbles:Boolean = false, cancelable:Boolean = false, effectInstance:EffectInstance = null)

Constructor.

Parameters
eventType:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
effectInstance:EffectInstance (default = null) — The effect instance that triggered the event.
Constant detail
EFFECT_END constant
public static const EFFECT_END:String = "effectEnd"

The EffectEvent.EFFECT_END constant defines the value of the type property of the event object for an effectEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
effectInstance | The effect instance object for the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

mx.effects.Effect
EFFECT_START constant
public static const EFFECT_START:String = "effectStart"

The EffectEvent.EFFECT_START constant defines the value of the type property of the event object for an effectStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
effectInstance | The effect instance object for the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

mx.effects.Effect


mx.events.FlexEvent (Flex™ 2 Language Reference)

Class FlexEvent | Properties | Methods | Constants
Package | mx.events
Class | public class FlexEvent
Inheritance | FlexEvent Inheritance Event Inheritance Object

The FlexEvent class represents the event object passed to the event listener for many Flex events.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | FlexEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false) Constructor. | FlexEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
 | ADD : String = "add" [static] The FlexEvent.ADD constant defines the value of the type property of the event object for an add event. | FlexEvent
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
 | APPLICATION_COMPLETE : String = "applicationComplete" [static] The FlexEvent.APPLICATION_COMPLETE constant defines the value of the type property of the event object for a applicationComplete event. | FlexEvent
 | BUTTON_DOWN : String = "buttonDown" [static] The FlexEvent.BUTTON_DOWN constant defines the value of the type property of the event object for a buttonDown event. | FlexEvent
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
 | CREATION_COMPLETE : String = "creationComplete" [static] The FlexEvent.CREATION_COMPLETE constant defines the value of the type property of the event object for a creationComplete event. | FlexEvent
 | CURSOR_UPDATE : String = "cursorUpdate" [static] The FlexEvent.CURSOR_UPDATE constant defines the value of the type property of the event object for a cursorUpdate event. | FlexEvent
 | DATA_CHANGE : String = "dataChange" [static] The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event. | FlexEvent
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | ENTER : String = "enter" [static] The FlexEvent.ENTER constant defines the value of the type property of the event object for a enter event. | FlexEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | ENTER_STATE : String = "enterState" [static] The FlexEvent.ENTER_STATE constant defines the value of the type property of the event object for a enterState event. | FlexEvent
 | EXIT_STATE : String = "exitState" [static] The FlexEvent.EXIT_STATE constant defines the value of the type property of the event object for a exitState event. | FlexEvent
 | HIDE : String = "hide" [static] The FlexEvent.HIDE constant defines the value of the type property of the event object for a hide event. | FlexEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
 | IDLE : String = "idle" [static] The FlexEvent.IDLE constant defines the value of the type property of the event object for a idle event. | FlexEvent
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | INIT_COMPLETE : String = "initComplete" [static] Dispatched when a Flex application finishes initialization. | FlexEvent
 | INITIALIZE : String = "initialize" [static] The FlexEvent.INITIALIZE constant defines the value of the type property of the event object for a initialize event. | FlexEvent
 | INIT_PROGRESS : String = "initProgress" [static] Dispatched when the Flex application completes an initialization phase, as defined by calls to the measure(), commitProperties(), or updateDisplayList() methods. | FlexEvent
 | INVALID : String = "invalid" [static] The FlexEvent.INVALID constant defines the value of the type property of the event object for a invalid event. | FlexEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
 | PREINITIALIZE : String = "preinitialize" [static] The FlexEvent.PREINITIALIZE constant defines the value of the type property of the event object for a preinitialize event. | FlexEvent
 | REMOVE : String = "remove" [static] The FlexEvent.REMOVE constant defines the value of the type property of the event object for an remove event. | FlexEvent
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
 | REPEAT : String = "repeat" [static] The FlexEvent.REPEAT constant defines the value of the type property of the event object for a repeat event. | FlexEvent
 | REPEAT_END : String = "repeatEnd" [static] The FlexEvent.REPEAT_END constant defines the value of the type property of the event object for a repeatEnd event. | FlexEvent
 | REPEAT_START : String = "repeatStart" [static] The FlexEvent.REPEAT_START constant defines the value of the type property of the event object for a repeatStart event. | FlexEvent
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
 | SHOW : String = "show" [static] The FlexEvent.SHOW constant defines the value of the type property of the event object for a show event. | FlexEvent
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
 | TRANSFORM_CHANGE : String = "transformChange" [static] The FlexEvent.TRANSFORM_CHANGE constant defines the value of the type property of the event object for a transformChange event. | FlexEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
 | UPDATE_COMPLETE : String = "updateComplete" [static] The FlexEvent.UPDATE_COMPLETE constant defines the value of the type property of the event object for a updateComplete event. | FlexEvent
 | VALID : String = "valid" [static] The FlexEvent.VALID constant defines the value of the type property of the event object for a valid event. | FlexEvent
 | VALUE_COMMIT : String = "valueCommit" [static] The FlexEvent.VALUE_COMMIT constant defines the value of the type property of the event object for a valueCommit event. | FlexEvent
Constructor detail
FlexEvent () constructor
public function FlexEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
Constant detail
ADD constant
public static const ADD:String = "add"

The FlexEvent.ADD constant defines the value of the type property of the event object for an add event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
APPLICATION_COMPLETE constant
public static const APPLICATION_COMPLETE:String = "applicationComplete"

The FlexEvent.APPLICATION_COMPLETE constant defines the value of the type property of the event object for a applicationComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
BUTTON_DOWN constant
public static const BUTTON_DOWN:String = "buttonDown"

The FlexEvent.BUTTON_DOWN constant defines the value of the type property of the event object for a buttonDown event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
CREATION_COMPLETE constant
public static const CREATION_COMPLETE:String = "creationComplete"

The FlexEvent.CREATION_COMPLETE constant defines the value of the type property of the event object for a creationComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
CURSOR_UPDATE constant
public static const CURSOR_UPDATE:String = "cursorUpdate"

The FlexEvent.CURSOR_UPDATE constant defines the value of the type property of the event object for a cursorUpdate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
DATA_CHANGE constant
public static const DATA_CHANGE:String = "dataChange"

The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
ENTER constant
public static const ENTER:String = "enter"

The FlexEvent.ENTER constant defines the value of the type property of the event object for a enter event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
ENTER_STATE constant
public static const ENTER_STATE:String = "enterState"

The FlexEvent.ENTER_STATE constant defines the value of the type property of the event object for a enterState event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
EXIT_STATE constant
public static const EXIT_STATE:String = "exitState"

The FlexEvent.EXIT_STATE constant defines the value of the type property of the event object for a exitState event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
HIDE constant
public static const HIDE:String = "hide"

The FlexEvent.HIDE constant defines the value of the type property of the event object for a hide event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
IDLE constant
public static const IDLE:String = "idle"

The FlexEvent.IDLE constant defines the value of the type property of the event object for a idle event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
INIT_COMPLETE constant
public static const INIT_COMPLETE:String = "initComplete"

Dispatched when a Flex application finishes initialization. You use this event when creating a custom download progress bar.

This event is always dispatched once by the Preloader class, and is the last event that the Preloader dispatches. When this event is dispatched, the event listener should dispatch an Event.COMPLETE event.

A download progress bar must dispatch a complete event after it has received an init_complete event. The complete event informs the Preloader that the download progress bar has completed all operations and can be dismissed.

A download progress bar can perform additional tasks, such as playing an animation, after receiving an init_complete event, and before dispatching the complete event. Dispatching the complete event should be the last action of the download progress bar.

The FlexEvent.INIT_COMPLETE constant defines the value of the type property of the event object for a initComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

mx.preloaders.DownloadProgressBar
INITIALIZE constant
public static const INITIALIZE:String = "initialize"

The FlexEvent.INITIALIZE constant defines the value of the type property of the event object for a initialize event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
INIT_PROGRESS constant
public static const INIT_PROGRESS:String = "initProgress"

Dispatched when the Flex application completes an initialization phase, as defined by calls to the measure(), commitProperties(), or updateDisplayList() methods. This event describes the progress of the application in the initialization phase. You use this event when creating a custom download progress bar.

The FlexEvent.INIT_PROGRESS constant defines the value of the type property of the event object for a initProgress event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

mx.preloaders.DownloadProgressBar
INVALID constant
public static const INVALID:String = "invalid"

The FlexEvent.INVALID constant defines the value of the type property of the event object for a invalid event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
PREINITIALIZE constant
public static const PREINITIALIZE:String = "preinitialize"

The FlexEvent.PREINITIALIZE constant defines the value of the type property of the event object for a preinitialize event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
REMOVE constant
public static const REMOVE:String = "remove"

The FlexEvent.REMOVE constant defines the value of the type property of the event object for an remove event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
REPEAT constant
public static const REPEAT:String = "repeat"

The FlexEvent.REPEAT constant defines the value of the type property of the event object for a repeat event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
REPEAT_END constant
public static const REPEAT_END:String = "repeatEnd"

The FlexEvent.REPEAT_END constant defines the value of the type property of the event object for a repeatEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
REPEAT_START constant
public static const REPEAT_START:String = "repeatStart"

The FlexEvent.REPEAT_START constant defines the value of the type property of the event object for a repeatStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
SHOW constant
public static const SHOW:String = "show"

The FlexEvent.SHOW constant defines the value of the type property of the event object for a show event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TRANSFORM_CHANGE constant
public static const TRANSFORM_CHANGE:String = "transformChange"

The FlexEvent.TRANSFORM_CHANGE constant defines the value of the type property of the event object for a transformChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
UPDATE_COMPLETE constant
public static const UPDATE_COMPLETE:String = "updateComplete"

The FlexEvent.UPDATE_COMPLETE constant defines the value of the type property of the event object for a updateComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
VALID constant
public static const VALID:String = "valid"

The FlexEvent.VALID constant defines the value of the type property of the event object for a valid event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
VALUE_COMMIT constant
public static const VALUE_COMMIT:String = "valueCommit"

The FlexEvent.VALUE_COMMIT constant defines the value of the type property of the event object for a valueCommit event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.FlexMouseEvent (Flex™ 2 Language Reference)

Class FlexMouseEvent | Properties | Methods | Constants
Package | mx.events
Class | public class FlexMouseEvent
Inheritance | FlexMouseEvent Inheritance MouseEvent Inheritance Event Inheritance Object

The FlexMouseEvent class represents the event object passed to the event listener for Flex-specific mouse activity.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | altKey : Boolean Reserved for future use. | MouseEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | buttonDown : Boolean Indicates whether the primary mouse button is pressed (true) or not (false). | MouseEvent
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | ctrlKey : Boolean Indicates whether the Control key is active (true) or inactive (false). | MouseEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | delta : int Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel. | MouseEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | localX : Number The horizontal coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | localY : Number The vertical coordinate at which the event occurred relative to the containing sprite. | MouseEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | relatedObject : InteractiveObject A reference to a display list object that is related to the event. | MouseEvent
Inherited | shiftKey : Boolean Indicates whether the Shift key is active (true) or inactive (false). | MouseEvent
Inherited | stageX : Number The horizontal coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | stageY : Number The vertical coordinate at which the event occurred in global Stage coordinates. | MouseEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | FlexMouseEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, localX:Number = 0, localY:Number = 0, relatedObject:InteractiveObject = null, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false, buttonDown:Boolean = false, delta:int = 0) Constructor. | FlexMouseEvent
Inherited | clone():Event Creates a copy of the MouseEvent object and sets the value of each property to match that of the original. | MouseEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string that contains all the properties of the MouseEvent object. | MouseEvent
Inherited | updateAfterEvent():void Instructs Flash Player to render after processing of this event completes, if the display list has been modified. | MouseEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLICK : String = "click" [static] Defines the value of the type property of a click event object. | MouseEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | DOUBLE_CLICK : String = "doubleClick" [static] Defines the value of the type property of a doubleClick event object. | MouseEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_DOWN : String = "mouseDown" [static] Defines the value of the type property of a mouseDown event object. | MouseEvent
 | MOUSE_DOWN_OUTSIDE : String = "mouseDownOutside" [static] The FlexMouseEvent.MOUSE_DOWN_OUTSIDE constant defines the value of the type property of the event object for a mouseDownOutside event. | FlexMouseEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | MOUSE_MOVE : String = "mouseMove" [static] Defines the value of the type property of a mouseMove event object. | MouseEvent
Inherited | MOUSE_OUT : String = "mouseOut" [static] Defines the value of the type property of a mouseOut event object. | MouseEvent
Inherited | MOUSE_OVER : String = "mouseOver" [static] Defines the value of the type property of a mouseOver event object. | MouseEvent
Inherited | MOUSE_UP : String = "mouseUp" [static] Defines the value of the type property of a mouseUp event object. | MouseEvent
Inherited | MOUSE_WHEEL : String = "mouseWheel" [static] Defines the value of the type property of a mouseWheel event object. | MouseEvent
 | MOUSE_WHEEL_OUTSIDE : String = "mouseWheelOutside" [static] The FlexMouseEvent.MOUSE_WHEEL_OUTSIDE constant defines the value of the type property of the event object for a mouseWheelOutside event. | FlexMouseEvent
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | ROLL_OUT : String = "rollOut" [static] Defines the value of the type property of a rollOut event object. | MouseEvent
Inherited | ROLL_OVER : String = "rollOver" [static] Defines the value of the type property of a rollOver event object. | MouseEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
FlexMouseEvent () constructor
public function FlexMouseEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, localX:Number = 0, localY:Number = 0, relatedObject:InteractiveObject = null, ctrlKey:Boolean = false, altKey:Boolean = false, shiftKey:Boolean = false, buttonDown:Boolean = false, delta:int = 0)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
localX:Number (default = 0) — The horizontal position at which the event occurred.
localY:Number (default = 0) — The vertical position at which the event occurred.
relatedObject:InteractiveObject (default = null) — The display list object that is related to the event.
ctrlKey:Boolean (default = false) — Whether the Control key is down.
altKey:Boolean (default = false) — Whether the Alt key is down.
shiftKey:Boolean (default = false) — Whether the Shift key is down.
buttonDown:Boolean (default = false) — Whether the Control key is down.
delta:int (default = 0) — How many lines should be scrolled for each notch the user scrolls the mouse wheel.
Constant detail
MOUSE_DOWN_OUTSIDE constant
public static const MOUSE_DOWN_OUTSIDE:String = "mouseDownOutside"

The FlexMouseEvent.MOUSE_DOWN_OUTSIDE constant defines the value of the type property of the event object for a mouseDownOutside event.

The properties of the event object have the following values:

Property | Value
altKey | Indicates whether the Alt key is down (true) or not (false).
bubbles | false
buttonDown | Indicates whether the main mouse button is down (true) or not (false).
cancelable | false
ctrlKey | Indicates whether the Control key is down (true) or not (false).
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget. For PopUpManager events, the object is the pop-up window.
delta | Indicates how many lines should be scrolled for each notch the user scrolls the mouse wheel. For PopUpManager events this value is 0.
localX | The horizontal position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
localY | The vertical position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
relatedObject | A reference to a display list object that is related to the event. For PopUpManager events, the object is the container over which the mouse pointer is located.
shiftKey | Indicates whether the Shift key is down (true) or not (false).
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event. For PopUpManager events, the object is the pop-up window.
MOUSE_WHEEL_OUTSIDE constant
public static const MOUSE_WHEEL_OUTSIDE:String = "mouseWheelOutside"

The FlexMouseEvent.MOUSE_WHEEL_OUTSIDE constant defines the value of the type property of the event object for a mouseWheelOutside event.

The properties of the event object have the following values:

Property | Value
altKey | Indicates whether the Alt key is down (true) or not (false).
bubbles | false
buttonDown | Indicates whether the main mouse button is down (true) or not (false).
cancelable | false
ctrlKey | Indicates whether the Control key is down (true) or not (false).
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget. For PopUpManager events, the object is the pop-up window.
delta | Indicates how many lines should be scrolled for each notch the user scrolls the mouse wheel. For PopUpManager events this value is 0.
localX | The horizontal position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
localY | The vertical position at which the event occurred. For PopUpManager events, the value is relative to the pop-up control.
relatedObject | A reference to a display list object that is related to the event. For PopUpManager events, the object is the container over which the mouse pointer is located.
shiftKey | Indicates whether the Shift key is down (true) or not (false).
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event. For PopUpManager events, the object is the pop-up window.


mx.events.IndexChangedEvent (Flex™ 2 Language Reference)

Class IndexChangedEvent | Properties | Methods | Constants
Package | mx.events
Class | public class IndexChangedEvent
Inheritance | IndexChangedEvent Inheritance Event Inheritance Object

The IndexChangedEvent class represents events that are dispatched when an index changes. This event can indicate that the index value of a child of a container changed, the displayed child of a navigator container such as an Accordion or ViewStack changed, or the order of column headers in a DataGrid control changed.

See also

mx.core.Container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | newIndex : Number The zero-based index after the change. | IndexChangedEvent
 | oldIndex : Number The zero-based index before the change. | IndexChangedEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relatedObject : DisplayObject The child object whose index changed, or the object associated with the new index. | IndexChangedEvent
Inherited | target : Object The event target. | Event
 | triggerEvent : Event The event that triggered this event. | IndexChangedEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | IndexChangedEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, relatedObject:DisplayObject = null, oldIndex:Number = -1, newIndex:Number = -1, triggerEvent:Event = null) Constructor. | IndexChangedEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
 | CHANGE : String = "change" [static] The IndexChangedEvent.CHANGE constant defines the value of the type property of the event object for a change event, which indicates that an index has changed, such as when and Accordion control changes the displayed panel or a ViewStack changes views. | IndexChangedEvent
 | CHILD_INDEX_CHANGE : String = "childIndexChange" [static] The IndexChangedEvent.CHILD_INDEX_CHANGE constant defines the value of the type property of the event object for a childIndexChange event, which indicates that a component's index among a container's children has changed. | IndexChangedEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | HEADER_SHIFT : String = "headerShift" [static] The IndexChangedEvent.HEADER_SHIFT constant defines the value of the type property of the event object for a headerShift event, which indicates that a header has changed its index, as when a user drags a DataGrid column to a new position. | IndexChangedEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
newIndex property
public var newIndex:Number

The zero-based index after the change. For change events it is the index of the current child. For childIndexChange events, it is the new index of the child. For headerShift events, it is the new index of the header.

oldIndex property
public var oldIndex:Number

The zero-based index before the change. For change events it is the index of the previous child. For childIndexChange events, it is the previous index of the child. For headerShift events, it is the previous index of the header.

relatedObject property
public var relatedObject:DisplayObject

The child object whose index changed, or the object associated with the new index. This property is not set for header changes.

triggerEvent property
public var triggerEvent:Event

The event that triggered this event. Indicates whether this event was caused by a mouse or keyboard interaction. The value is null when a container dispatches a childIndexChanged event.

Constructor detail
IndexChangedEvent () constructor
public function IndexChangedEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, relatedObject:DisplayObject = null, oldIndex:Number = -1, newIndex:Number = -1, triggerEvent:Event = null)

Constructor. Normally called by a Flex control and not used in application code.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
relatedObject:DisplayObject (default = null) — The child object associated with the index change.
oldIndex:Number (default = -1) — The zero-based index before the change.
newIndex:Number (default = -1) — The zero-based index after the change.
triggerEvent:Event (default = null) — The event that triggered this event.
Constant detail
CHANGE constant
public static const CHANGE:String = "change"

The IndexChangedEvent.CHANGE constant defines the value of the type property of the event object for a change event, which indicates that an index has changed, such as when and Accordion control changes the displayed panel or a ViewStack changes views.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
inputType | Indicates whether this event was caused by a mouse or keyboard interaction.
newIndex | The zero-based index after the change.
oldIndex | The zero-based index before the change.
relatedObject | Contains a reference to the child object that corresponds to the new index.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TriggerEvent | The event that triggered this event.
Type | IndexChangedEvent.CHANGE
CHILD_INDEX_CHANGE constant
public static const CHILD_INDEX_CHANGE:String = "childIndexChange"

The IndexChangedEvent.CHILD_INDEX_CHANGE constant defines the value of the type property of the event object for a childIndexChange event, which indicates that a component's index among a container's children has changed.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
inputType | Indicates whether this event was caused by a mouse or keyboard interaction.
newIndex | The zero-based index of the child after the change.
oldIndex | The zero-based index of the child before the change.
relatedObject | Contains a reference to the child object whose index changed.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TriggerEvent | null
Type | IndexChangedEvent.CHILD_INDEX_CHANGE
HEADER_SHIFT constant
public static const HEADER_SHIFT:String = "headerShift"

The IndexChangedEvent.HEADER_SHIFT constant defines the value of the type property of the event object for a headerShift event, which indicates that a header has changed its index, as when a user drags a DataGrid column to a new position.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
inputType | Indicates whether this event was caused by a mouse or keyboard interaction.
newIndex | The zero-based index of the header after the change.
oldIndex | The zero-based index of the header before the change.
relatedObject | null
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
TriggerEvent | The event that triggered this event.
Type | IndexChangedEvent.HEADER_SHIFT


mx.events.ItemClickEvent (Flex™ 2 Language Reference)

Class ItemClickEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ItemClickEvent
Inheritance | ItemClickEvent Inheritance Event Inheritance Object

Represents events that are dispatched when a navigation item on a navigator bar, such as a ButtonBar, LinkBar, or TabBar control, has been clicked.

See also

mx.controls.NavBar
mx.controls.Button
mx.controls.List

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | index : int The index of the associated navigation item. | ItemClickEvent
 | item : Object The item in the data provider of the associated navigation item. | ItemClickEvent
 | label : String The label of the associated navigation item. | ItemClickEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relatedObject : InteractiveObject The child object that generated the event; for example, the button that a user clicked in a ButtonBar control. | ItemClickEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ItemClickEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, label:String = null, index:int = -1, relatedObject:InteractiveObject = null, item:Object = null) Constructor. | ItemClickEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_CLICK : String = "itemClick" [static] The ItemClickEvent.ITEM_CLICK constant defines the value of the type property of the event object for an itemClick event. | ItemClickEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
index property
public var index:int

The index of the associated navigation item.

item property
public var item:Object

The item in the data provider of the associated navigation item.

label property
public var label:String

The label of the associated navigation item.

relatedObject property
public var relatedObject:InteractiveObject

The child object that generated the event; for example, the button that a user clicked in a ButtonBar control.

Constructor detail
ItemClickEvent () constructor
public function ItemClickEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, label:String = null, index:int = -1, relatedObject:InteractiveObject = null, item:Object = null)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
label:String (default = null) — The label of the associated navigation item.
index:int (default = -1) — The index of the associated navigation item.
relatedObject:InteractiveObject (default = null) — The child object that generated the event.
item:Object (default = null) — The item in the data provider for the associated navigation item.
Constant detail
ITEM_CLICK constant
public static const ITEM_CLICK:String = "itemClick"

The ItemClickEvent.ITEM_CLICK constant defines the value of the type property of the event object for an itemClick event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index of the navigation item that was clicked.
item | The item in the data provider of the navigation item that was clicked.
label | The label of the navigation item that was clicked.
relatedObject | The child object that generated the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.ListEvent (Flex™ 2 Language Reference)

Class ListEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ListEvent
Inheritance | ListEvent Inheritance Event Inheritance Object
Subclasses | MenuEvent

The ListEvent class represents events associated with items in list-based controls such as List, Tree, Menu, and DataGrid.

See also

mx.controls.List
mx.controls.listClasses.ListBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | columnIndex : int The zero-based index of the column that contains the item renderer where the event occurred. | ListEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | itemRenderer : IListItemRenderer The item renderer where the event occurred. | ListEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | reason : String The reason the itemEditEnd event was dispatched. | ListEvent
 | rowIndex : int In the zero-based index of the row that contains the item renderer where the event occured, or for editing events, the index of the item in the data provider that is being edited. | ListEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ListEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, columnIndex:int = -1, rowIndex:int = -1, reason:String = null, itemRenderer:IListItemRenderer = null) Constructor. | ListEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_CLICK : String = "itemClick" [static] The ListEvent.ITEM_CLICK constant defines the value of the type property of the ListEvent object for an itemClick event, which indicates that the user clicked the mouse over a visual item in the control. | ListEvent
 | ITEM_DOUBLE_CLICK : String = "itemDoubleClick" [static] The ListEvent.ITEM_DOUBLE_CLICK constant defines the value of the type property of the ListEvent object for an itemDoubleClick event, which indicates that the user double clicked the mouse over a visual item in the control. | ListEvent
 | ITEM_EDIT_BEGIN : String = "itemEditBegin" [static] The ListEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited. | ListEvent
 | ITEM_EDIT_BEGINNING : String = "itemEditBeginning" [static] The ListEvent.ITEM_EDIT_BEGINNING constant defines the value of the type property of the ListEvent object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item. | ListEvent
 | ITEM_EDIT_END : String = "itemEditEnd" [static] The ListEvent.ITEM_EDIT_END constant defines the value of the type property of the ListEvent object for a itemEditEnd event, which indicates that an edit session is ending. | ListEvent
 | ITEM_FOCUS_IN : String = "itemFocusIn" [static] The ListEvent.ITEM_FOCUS_IN constant defines the value of the type property of the ListEvent object for an itemFocusIn event, which indicates that an item has received the focus. | ListEvent
 | ITEM_FOCUS_OUT : String = "itemFocusOut" [static] The ListEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the ListEvent object for an itemFocusOut event, which indicates that an item has lost the focus. | ListEvent
 | ITEM_ROLL_OUT : String = "itemRollOut" [static] The ListEvent.ITEM_ROLL_OUT constant defines the value of the type property of the ListEvent object for an itemRollOut event, which indicates that the user rolled the mouse pointer out of a visual item in the control. | ListEvent
 | ITEM_ROLL_OVER : String = "itemRollOver" [static] The ListEvent.ITEM_ROLL_OVER constant defines the value of the type property of the ListEvent object for an itemRollOver event, which indicates that the user rolled the mouse pointer over a visual item in the control. | ListEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
columnIndex property
public var columnIndex:int

The zero-based index of the column that contains the item renderer where the event occurred.

itemRenderer property
public var itemRenderer:IListItemRenderer

The item renderer where the event occurred. You can access the data provider item using this property.

reason property
public var reason:String

The reason the itemEditEnd event was dispatched. Valid only for events with type ITEM_EDIT_END. The possible values are defined in the ListEventReason class.

See also

ListEventReason
rowIndex property
public var rowIndex:int

In the zero-based index of the row that contains the item renderer where the event occured, or for editing events, the index of the item in the data provider that is being edited.

Constructor detail
ListEvent () constructor
public function ListEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, columnIndex:int = -1, rowIndex:int = -1, reason:String = null, itemRenderer:IListItemRenderer = null)

Constructor. Normally called by the Flex control and not used in application code.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
columnIndex:int (default = -1) — The zero-based index of the column that contains the renderer.
rowIndex:int (default = -1) — The zero-based index of the row that contains the renderer, or for editing events, the index of the item in the data provider that is being edited
reason:String (default = null) — The reason for an itemEditEnd event.
itemRenderer:IListItemRenderer (default = null) — The item renderer for the data provider item.
Constant detail
ITEM_CLICK constant
public static const ITEM_CLICK:String = "itemClick"

The ListEvent.ITEM_CLICK constant defines the value of the type property of the ListEvent object for an itemClick event, which indicates that the user clicked the mouse over a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was clicked.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_CLICK
ITEM_DOUBLE_CLICK constant
public static const ITEM_DOUBLE_CLICK:String = "itemDoubleClick"

The ListEvent.ITEM_DOUBLE_CLICK constant defines the value of the type property of the ListEvent object for an itemDoubleClick event, which indicates that the user double clicked the mouse over a visual item in the control.

To receive itemDoubleClick events, you must set the component's doubleClickEnabled property to true.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was double clicked.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_DOUBLE_CLICK
ITEM_EDIT_BEGIN constant
public static const ITEM_EDIT_BEGIN:String = "itemEditBegin"

The ListEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited.

The default listener for this event performs the following actions:

  • Creates an item editor object via a call to the createItemEditor() method.
  • Copies the data property from the item to the editor. By default, the item editor object is an instance of the TextInput control. You use the itemEditor property of the list control to specify a custom item editor class.
  • Set the itemEditorInstance property of the list control to reference the item editor instance.

You can write an event listener for this event to modify the data passed to the item editor. For example, you might modify the data, its format, or other information used by the item editor.

You can also create an event listener to specify the item editor used to edit the item. For example, you might have two different item editors. Within the event listener you can examine the data to be edited or other information, and open the appropriate item editor by doing the following:

  1. Call preventDefault() to stop Flex from calling the createItemEditor() method as part of the default event listener.
  2. Set the itemEditor property to the appropriate editor.
  3. Call the createItemEditor() method.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer for the item that is being edited.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_EDIT_BEGIN
ITEM_EDIT_BEGINNING constant
public static const ITEM_EDIT_BEGINNING:String = "itemEditBeginning"

The ListEvent.ITEM_EDIT_BEGINNING constant defines the value of the type property of the ListEvent object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item.

The default listener for this event sets the List.editedItemPosition property to the item that has focus, which starts the item editing session.

You typically write your own event listener for this event to disallow editing of a specific item or items. Calling the preventDefault() method from within your own event listener for this event prevents the default listener from executing.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer for the item that will be edited. This property is null if this event is generated by keyboard, as the item to be edited may be off-screen.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_EDIT_BEGIN
ITEM_EDIT_END constant
public static const ITEM_EDIT_END:String = "itemEditEnd"

The ListEvent.ITEM_EDIT_END constant defines the value of the type property of the ListEvent object for a itemEditEnd event, which indicates that an edit session is ending.

The list components have a default handler for this event that copies the data from the item editor to the data provider of the list control. The default event listener performs the following actions:

  • Uses the editorDataField property of the list control to determine the property of the item editor containing the new data and updates the data provider item with that new data. Since the default item editor is the TextInput control, the default value of the editorDataField property is "text", to specify that the text property of the TextInput contains the new item data.
  • Calls the destroyItemEditor() method to close the item editor.

You typically write an event listener for this event to perform the following actions:

  • In your event listener, you can modify the data returned by the editor to the list component. For example, you can reformat the data before returning it to the list control. By default, an item editor can only return a single value. You must write an event listener for the itemEditEnd event if you want to return multiple values.
  • In your event listener, you can examine the data entered into the item editor. If the data is incorrect, you can call the preventDefault() method to stop Flex from passing the new data back to the list control and from closing the editor.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer for the item that was edited.
reason | A constant defining the reason for the event. The value must be a member of the ListEventReson class.
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_EDIT_BEGIN
ITEM_FOCUS_IN constant
public static const ITEM_FOCUS_IN:String = "itemFocusIn"

The ListEvent.ITEM_FOCUS_IN constant defines the value of the type property of the ListEvent object for an itemFocusIn event, which indicates that an item has received the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item editor instance for the item that is being edited.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_FOCUS_IN
ITEM_FOCUS_OUT constant
public static const ITEM_FOCUS_OUT:String = "itemFocusOut"

The ListEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the ListEvent object for an itemFocusOut event, which indicates that an item has lost the focus.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item editor instance for the item that was being edited.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_FOCUS_OUT
ITEM_ROLL_OUT constant
public static const ITEM_ROLL_OUT:String = "itemRollOut"

The ListEvent.ITEM_ROLL_OUT constant defines the value of the type property of the ListEvent object for an itemRollOut event, which indicates that the user rolled the mouse pointer out of a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was rolled out.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_ROLL_OUT
ITEM_ROLL_OVER constant
public static const ITEM_ROLL_OVER:String = "itemRollOver"

The ListEvent.ITEM_ROLL_OVER constant defines the value of the type property of the ListEvent object for an itemRollOver event, which indicates that the user rolled the mouse pointer over a visual item in the control.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
columnIndex | The zero-based index of the column associated with the event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
itemRenderer | The item renderer that was rolled over.
reason | null
rowIndex | The zero-based index of the item associated with the event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Type | ListEvent.ITEM_ROLL_OVER


mx.events.ListEventReason (Flex™ 2 Language Reference)

Class ListEventReason | Properties | Methods | Constants
Package | mx.events
Class | public final class ListEventReason
Inheritance | ListEventReason Inheritance Object

Constants for the values of the reason property of a ListEvent object where the value of the type property is ListEvent.ITEM_EDIT_END.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | CANCELLED : String = "cancelled" [static] Specifies that the user cancelled editing and that they do not want to save the edited data. | ListEventReason
 | NEW_ROW : String = "newRow" [static] Specifies that the user moved focus to a new row in the control. | ListEventReason
 | OTHER : String = "other" [static] Specifies that the list control lost focus, was scrolled, or is somehow in a state where editing is not allowed. | ListEventReason
Constant detail
CANCELLED constant
public static const CANCELLED:String = "cancelled"

Specifies that the user cancelled editing and that they do not want to save the edited data. Even if you call the preventDefault() method from within your event listener for the itemEditEnd event, Flex still calls the destroyItemEditor() method to close the editor.

NEW_ROW constant
public static const NEW_ROW:String = "newRow"

Specifies that the user moved focus to a new row in the control. Within an event listener, you can let the focus change occur, or prevent it. For example, your event listener might check that the user entered a valid value for the item currently being edited. If not, you can prevent the user from moving to a new item by calling the preventDefault() method. In this case, the item editor remains open, and the user continues to edit the current item. If you call the preventDefault() method and also call the destroyItemEditor() method, you block the move to the new item, but the item editor closes.

OTHER constant
public static const OTHER:String = "other"

Specifies that the list control lost focus, was scrolled, or is somehow in a state where editing is not allowed. Even if you call the preventDefault() method from within your event listener for the itemEditEnd event, Flex still calls the destroyItemEditor() method to close the editor.


mx.events.MenuEvent (Flex™ 2 Language Reference)

Class MenuEvent | Properties | Methods | Constants
Package | mx.events
Class | public class MenuEvent
Inheritance | MenuEvent Inheritance ListEvent Inheritance Event Inheritance Object

The MenuEvent class represents events that are associated with menu activities in controls such as Menu, MenuBar, and PopUpMenuButton.

See also

mx.controls.Menu
mx.controls.MenuBar
mx.controls.PopUpMenuButton

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | columnIndex : int The zero-based index of the column that contains the item renderer where the event occurred. | ListEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | index : int The index of the associated menu item within its parent menu or submenu. | MenuEvent
 | item : Object The specific item in the dataProvider. | MenuEvent
Inherited | itemRenderer : IListItemRenderer The item renderer where the event occurred. | ListEvent
 | label : String The label text of the associated menu item. | MenuEvent
 | menu : Menu The specific Menu instance associated with the event, such as the menu or submenu that was hidden or opened. | MenuEvent
 | menuBar : MenuBar The MenuBar instance that is the parent of the selected Menu control, or null when the target Menu control is not parented by a MenuBar control. | MenuEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reason : String The reason the itemEditEnd event was dispatched. | ListEvent
Inherited | rowIndex : int In the zero-based index of the row that contains the item renderer where the event occured, or for editing events, the index of the item in the data provider that is being edited. | ListEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MenuEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, menuBar:MenuBar = null, menu:Menu = null, item:Object = null, itemRenderer:IListItemRenderer = null, label:String = null, index:int = -1) Constructor. | MenuEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_CLICK : String = "itemClick" [static] The MenuEvent.ITEM_CLICK event type constant indicates that the user selected a menu item. | MenuEvent
Inherited | ITEM_DOUBLE_CLICK : String = "itemDoubleClick" [static] The ListEvent.ITEM_DOUBLE_CLICK constant defines the value of the type property of the ListEvent object for an itemDoubleClick event, which indicates that the user double clicked the mouse over a visual item in the control. | ListEvent
Inherited | ITEM_EDIT_BEGIN : String = "itemEditBegin" [static] The ListEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited. | ListEvent
Inherited | ITEM_EDIT_BEGINNING : String = "itemEditBeginning" [static] The ListEvent.ITEM_EDIT_BEGINNING constant defines the value of the type property of the ListEvent object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item. | ListEvent
Inherited | ITEM_EDIT_END : String = "itemEditEnd" [static] The ListEvent.ITEM_EDIT_END constant defines the value of the type property of the ListEvent object for a itemEditEnd event, which indicates that an edit session is ending. | ListEvent
Inherited | ITEM_FOCUS_IN : String = "itemFocusIn" [static] The ListEvent.ITEM_FOCUS_IN constant defines the value of the type property of the ListEvent object for an itemFocusIn event, which indicates that an item has received the focus. | ListEvent
Inherited | ITEM_FOCUS_OUT : String = "itemFocusOut" [static] The ListEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the ListEvent object for an itemFocusOut event, which indicates that an item has lost the focus. | ListEvent
 | ITEM_ROLL_OUT : String = "itemRollOut" [static] The MenuEvent.ITEM_ROLL_OUT type constant indicates that the mouse pointer rolled out of a menu item. | MenuEvent
 | ITEM_ROLL_OVER : String = "itemRollOver" [static] The MenuEvent.ITEM_ROLL_OVER type constant indicates that the mouse pointer rolled over a menu item. | MenuEvent
 | MENU_HIDE : String = "menuHide" [static] The MenuEvent.MENU_HIDE event type constant indicates that a menu or submenu closed. | MenuEvent
 | MENU_SHOW : String = "menuShow" [static] The MenuEvent.MENU_SHOW type constant indicates that the mouse pointer rolled a menu or submenu opened. | MenuEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
index property
public var index:int

The index of the associated menu item within its parent menu or submenu. This is -1 for the menuShow and menuHide events.

item property
public var item:Object

The specific item in the dataProvider. This is null for the menuShow and menuHide events.

label property
public var label:String

The label text of the associated menu item. This is null for the menuShow and menuHide events.

menu property
public var menu:Menu

The specific Menu instance associated with the event, such as the menu or submenu that was hidden or opened.

menuBar property
public var menuBar:MenuBar

The MenuBar instance that is the parent of the selected Menu control, or null when the target Menu control is not parented by a MenuBar control.

Constructor detail
MenuEvent () constructor
public function MenuEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, menuBar:MenuBar = null, menu:Menu = null, item:Object = null, itemRenderer:IListItemRenderer = null, label:String = null, index:int = -1)

Constructor. Normally called by the Menu object.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = true) — Specifies whether the behavior associated with the event can be prevented.
menuBar:MenuBar (default = null) — The MenuBar instance that is the parent of the selected Menu control, or null when the target Menu control is not parented by a MenuBar control.
menu:Menu (default = null) — The specific Menu instance associated with the event, such as the menu or submenu that was hidden or opened.
item:Object (default = null) — The item in the dataProvider of the assicated menu item.
itemRenderer:IListItemRenderer (default = null) — The ListItemRenderer of the associated menu item.
label:String (default = null) — The label text of the associated menu item.
index:int (default = -1) — The index in the menu of the associated menu item.
Constant detail
ITEM_CLICK constant
public static const ITEM_CLICK:String = "itemClick"

The MenuEvent.ITEM_CLICK event type constant indicates that the user selected a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the selected menu item.
item | The item in the dataProvider that was selected.
itemRenderer | The ListItemRenderer of the selected menu item.
label | The label text of the selected menu item.
menu | The specific Menu instance associated with this event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_CLICK
ITEM_ROLL_OUT constant
public static const ITEM_ROLL_OUT:String = "itemRollOut"

The MenuEvent.ITEM_ROLL_OUT type constant indicates that the mouse pointer rolled out of a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the menu item that was rolled out of.
item | The item in the dataProvider corresponding to the menu item that was rolled out of.
itemRenderer | The ListItemRenderer of the menu item that was rolled out of.
label | The label text of the menu item that was rolled out of.
menu | The specific Menu instance associated with the event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_ROLL_OUT
ITEM_ROLL_OVER constant
public static const ITEM_ROLL_OVER:String = "itemRollOver"

The MenuEvent.ITEM_ROLL_OVER type constant indicates that the mouse pointer rolled over a menu item.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | The index in the menu of the menu item that was rolled over.
item | The item in the dataProvider associated with the rolled over menu item.
itemRenderer | The ListItemRenderer of the menu item that was rolled over.
label | The label text of the menu item that was rolled over.
menu | The specific Menu instance associated with the event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.ITEM_ROLL_OVER
MENU_HIDE constant
public static const MENU_HIDE:String = "menuHide"

The MenuEvent.MENU_HIDE event type constant indicates that a menu or submenu closed.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | -1. This property is not set for this type of event.
item | null. This property is not set for this type of event.
itemRenderer | null. This property is not set for this type of event.
label | null. This property is not set for this type of event.
menu | The specific Menu instance that was hidden.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.MENU_HIDE
MENU_SHOW constant
public static const MENU_SHOW:String = "menuShow"

The MenuEvent.MENU_SHOW type constant indicates that the mouse pointer rolled a menu or submenu opened.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
index | -1. This property is not set for this type of event.
item | null. This property is not set for this type of event.
itemRenderer | null. This property is not set for this type of event.
label | null. This property is not set for this type of event.
menu | The specific Menu instance associated with the event.
menuBar | The MenuBar instance that is the parent of the Menu control, or null if the Menu control is not parented by a MenuBar control.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | MenuEvent.MENU_SHOW


mx.events.MoveEvent (Flex™ 2 Language Reference)

Class MoveEvent | Properties | Methods | Constants
Package | mx.events
Class | public class MoveEvent
Inheritance | MoveEvent Inheritance Event Inheritance Object

Represents event objects that are dispatched when a Flex component moves.

See also

mx.core.UIComponent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | oldX : Number The previous x coordinate of the object, in pixels. | MoveEvent
 | oldY : Number The previous y coordinate of the object, in pixels. | MoveEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MoveEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, oldX:Number, oldY:Number) Constructor. | MoveEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
 | MOVE : String = "move" [static] The MoveEvent.MOVE constant defines the value of the type property of the event object for a move event. | MoveEvent
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
oldX property
public var oldX:Number

The previous x coordinate of the object, in pixels.

oldY property
public var oldY:Number

The previous y coordinate of the object, in pixels.

Constructor detail
MoveEvent () constructor
public function MoveEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, oldX:Number, oldY:Number)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
oldX:Number — The previous x coordinate of the object, in pixels.
oldY:Number — The previous y coordinate of the object, in pixels.
Constant detail
MOVE constant
public static const MOVE:String = "move"

The MoveEvent.MOVE constant defines the value of the type property of the event object for a move event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
oldX | The previous x coordinate of the object, in pixels.
oldY | The previous y coordinate of the object, in pixels.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.NumericStepperEvent (Flex™ 2 Language Reference)

Class NumericStepperEvent | Properties | Methods | Constants
Package | mx.events
Class | public class NumericStepperEvent
Inheritance | NumericStepperEvent Inheritance Event Inheritance Object

Represents events that are specific to the NumericStepper control.

See also

mx.controls.NumericStepper
NumericStepper control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
 | value : Number The value of the NumericStepper control when the event was dispatched. | NumericStepperEvent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | NumericStepperEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, value:Number) Constructor. | NumericStepperEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
 | CHANGE : String = "change" [static] The NumericStepperEvent.CHANGE constant defines the value of the type property of the event object for a change event. | NumericStepperEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
value property
public var value:Number

The value of the NumericStepper control when the event was dispatched.

Constructor detail
NumericStepperEvent () constructor
public function NumericStepperEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, value:Number)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
value:Number — The value of the NumericStepper control when the event was dispatched.
Constant detail
CHANGE constant
public static const CHANGE:String = "change"

The NumericStepperEvent.CHANGE constant defines the value of the type property of the event object for a change event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value of the NumericStepper control when the event was dispatched.


mx.events.PropertyChangeEvent (Flex™ 2 Language Reference)

Class PropertyChangeEvent | Properties | Methods | Constants
Package | mx.events
Class | public class PropertyChangeEvent
Inheritance | PropertyChangeEvent Inheritance Event Inheritance Object

The PropertyChangeEvent class represents the event object passed to the event listener when one of the properties of an object has changed, and provides information about the change. This event is used by collection classes, and is the only way for collections to know that the data they represent has changed. This event is also used by the Flex data binding mechanism.

See also

PropertyChangeEventKind

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | kind : String Specifies the kind of change. | PropertyChangeEvent
 | newValue : Object The value of the property after the change. | PropertyChangeEvent
 | oldValue : Object The value of the property before the change. | PropertyChangeEvent
 | property : Object A String, QName, or int specifying the property that changed. | PropertyChangeEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | source : Object The object that the change occured on. | PropertyChangeEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PropertyChangeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, kind:String = null, property:Object = null, oldValue:Object = null, newValue:Object = null, source:Object = null)
Constructor.
PropertyChangeEvent
Inherited
clone():Event
Duplicates an instance of an Event subclass.
Event
createUpdateEvent(source:Object, property:Object, oldValue:Object, newValue:Object):PropertyChangeEvent
[static] Returns a new PropertyChangeEvent of kind PropertyChangeEventKind.UPDATE with the specified properties.
PropertyChangeEvent
Inherited
formatToString(className:String, ... arguments):String
A utility function for implementing the toString() method in your custom Event class.
Event
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isDefaultPrevented():Boolean
Checks whether preventDefault() has been called on the event.
Event
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
preventDefault():void
Cancels an event's default behavior if that behavior can be canceled.
Event
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
stopImmediatePropagation():void
Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow.
Event
Inherited
stopPropagation():void
Prevents processing of any event listeners in nodes subsequent to the current node in the event flow.
Event
Inherited
toString():String
Returns a string containing all the properties of the Event object.
Event
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
 | PROPERTY_CHANGE : String = "propertyChange" [static] The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event. | PropertyChangeEvent
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
kind property
public var kind:String

Specifies the kind of change. The possible values are PropertyChangeEventKind.UPDATE, PropertyChangeEventKind.DELETE, and null.

newValue property
public var newValue:Object

The value of the property after the change.

oldValue property
public var oldValue:Object

The value of the property before the change.

property property
public var property:Object

A String, QName, or int specifying the property that changed.

source property
public var source:Object

The object that the change occured on.

Constructor detail
PropertyChangeEvent () constructor
public function PropertyChangeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, kind:String = null, property:Object = null, oldValue:Object = null, newValue:Object = null, source:Object = null)

Constructor.

Parameters
type:String — The event type; indicates the action that triggered the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
kind:String (default = null) — Specifies the kind of change. The possible values are PropertyChangeEventKind.UPDATE, PropertyChangeEventKind.DELETE, and null.
property:Object (default = null) — A String, QName, or int specifying the property that changed.
oldValue:Object (default = null) — The value of the property before the change.
newValue:Object (default = null) — The value of the property after the change.
source:Object (default = null) — The object that the change occured on.
Method detail
createUpdateEvent () method
public static function createUpdateEvent(source:Object, property:Object, oldValue:Object, newValue:Object):PropertyChangeEvent

Returns a new PropertyChangeEvent of kind PropertyChangeEventKind.UPDATE with the specified properties. This is a convenience method.

Parameters
source:Object — The object where the change occured.
property:Object — A String, QName, or int specifying the property that changed,
oldValue:Object — The value of the property before the change.
newValue:Object — The value of the property after the change.

Returns
PropertyChangeEvent — A newly constructed PropertyChangeEvent with the specified properties.
Constant detail
PROPERTY_CHANGE constant
public static const PROPERTY_CHANGE:String = "propertyChange"

The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event.

The properties of the event object have the following values:

Property | Value
bubbles | Determined by the constructor; defaults to false.
cancelable | Determined by the constructor; defaults to false.
kind | The kind of change; PropertyChangeEventKind.UPDATE or PropertyChangeEventKind.DELETE.
oldValue | The original property value.
newValue | The new property value, if any.
property | The property that changed
source | The object that contains the property that changed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.PropertyChangeEventKind (Flex™ 2 Language Reference)

Class PropertyChangeEventKind | Properties | Methods | Constants
Package | mx.events
Class | public final class PropertyChangeEventKind
Inheritance | PropertyChangeEventKind Inheritance Object

The PropertyChangeEventKind class defines the constant values for the kind property of the PropertyChangeEvent class.

See also

mx.events.PropertyChangeEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DELETE : String = "delete" [static] Indicates that the property was deleted from the object. | PropertyChangeEventKind
 | UPDATE : String = "update" [static] Indicates that the value of the property changed. | PropertyChangeEventKind
Constant detail
DELETE constant
public static const DELETE:String = "delete"

Indicates that the property was deleted from the object.

UPDATE constant
public static const UPDATE:String = "update"

Indicates that the value of the property changed.


mx.events.ResizeEvent (Flex™ 2 Language Reference)

Class ResizeEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ResizeEvent
Inheritance | ResizeEvent Inheritance Event Inheritance Object

Represents event objects that are dispatched when the size of a Flex component changes.

See also

mx.core.UIComponent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | oldHeight : Number The previous height of the object, in pixels. | ResizeEvent
 | oldWidth : Number The previous width of the object, in pixels. | ResizeEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ResizeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, oldWidth:Number, oldHeight:Number) Constructor. | ResizeEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
 | RESIZE : String = "resize" [static] The ResizeEvent.RESIZE constant defines the value of the type property of the event object for a resize event. | ResizeEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
oldHeight property
public var oldHeight:Number

The previous height of the object, in pixels.

oldWidth property
public var oldWidth:Number

The previous width of the object, in pixels.

Constructor detail
ResizeEvent () constructor
public function ResizeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, oldWidth:Number, oldHeight:Number)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
oldWidth:Number — The previous width of the object, in pixels.
oldHeight:Number — The previous height of the object, in pixels.
Constant detail
RESIZE constant
public static const RESIZE:String = "resize"

The ResizeEvent.RESIZE constant defines the value of the type property of the event object for a resize event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
oldHeight | The previous height of the object, in pixels.
oldWidth | The previous width of the object, in pixels.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.RSLEvent (Flex™ 2 Language Reference)

Class RSLEvent | Properties | Methods | Constants
Package | mx.events
Class | public class RSLEvent
Inheritance | RSLEvent Inheritance ProgressEvent Inheritance Event Inheritance Object

The RSLEvent class represents an event object used by the DownloadProgressBar class when an RSL is being downloaded by the Preloader class.

See also

mx.preloaders.DownloadProgressBar
mx.preloaders.Preloader

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | bytesLoaded : uint The number of items or bytes loaded when the listener processes the event. | ProgressEvent
Inherited | bytesTotal : uint The total number of items or bytes that will be loaded if the loading process succeeds. | ProgressEvent
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | errorText : String The error message if the type is RSL_ERROR; otherwise, it is null; | RSLEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rslIndex : int The index number of the RSL currently being downloaded. | RSLEvent
 | rslTotal : int The total number of RSLs being downloaded by the preloader | RSLEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
 | url : URLRequest The URLRequest object that represents the location of the RSL being downloaded. | RSLEvent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RSLEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, bytesLoaded:int = -1, bytesTotal:int = -1, rslIndex:int = -1, rslTotal:int = -1, url:URLRequest = null, errorText:String = null) Constructor. | RSLEvent
Inherited | clone():Event Creates a copy of the ProgressEvent object and sets each property's value to match that of the original. | ProgressEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string that contains all the properties of the ProgressEvent object. | ProgressEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | PROGRESS : String = "progress" [static] Defines the value of the type property of a progress event object. | ProgressEvent
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | RSL_COMPLETE : String = "rslComplete" [static] Dispatched when the RSL has finished downloading. | RSLEvent
 | RSL_ERROR : String = "rslError" [static] Dispatched when there is an error downloading the RSL. | RSLEvent
 | RSL_PROGRESS : String = "rslProgress" [static] Dispatched when the RSL is downloading. | RSLEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOCKET_DATA : String = "socketData" [static] Defines the value of the type property of a socketData event object. | ProgressEvent
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
errorText property
public var errorText:String

The error message if the type is RSL_ERROR; otherwise, it is null;

rslIndex property
public var rslIndex:int

The index number of the RSL currently being downloaded. This is a number between 0 and rslTotal - 1.

rslTotal property
public var rslTotal:int

The total number of RSLs being downloaded by the preloader

url property
public var url:URLRequest

The URLRequest object that represents the location of the RSL being downloaded.

Constructor detail
RSLEvent () constructor
public function RSLEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, bytesLoaded:int = -1, bytesTotal:int = -1, rslIndex:int = -1, rslTotal:int = -1, url:URLRequest = null, errorText:String = null)

Constructor.

Parameters
type:String — The type of the event. Possible values are:
  • "rslProgress" (RSLEvent.RSL_PROGRESS);
  • "rslComplete" (RSLEvent.RSL_COMPLETE);
  • "rslError" (RSLEvent.RSL_ERROR);
bubbles:Boolean (default = false) — Determines whether the Event object participates in the bubbling stage of the event flow.
cancelable:Boolean (default = false) — Determines whether the Event object can be cancelled.
bytesLoaded:int (default = -1) — The number of bytes loaded at the time the listener processes the event.
bytesTotal:int (default = -1) — The total number of bytes that will ultimately be loaded if the loading process succeeds.
rslIndex:int (default = -1) — The index number of the RSL relative to the total. This should be a value between 0 and total - 1.
rslTotal:int (default = -1) — The total number of RSLs being loaded.
url:URLRequest (default = null) — The location of the RSL.
errorText:String (default = null) — The error message of the error when type is RSLEvent.RSL_ERROR.
Constant detail
RSL_COMPLETE constant
public static const RSL_COMPLETE:String = "rslComplete"

Dispatched when the RSL has finished downloading. The RSLEvent.RSL_COMPLETE constant defines the value of the type property of the event object for a rslComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
bytesLoaded | The number of bytes loaded.
bytesTotal | The total number of bytes to load.
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
errorText | Empty
rslIndex | The index number of the RSL currently being downloaded.
rslTotal | The total number of RSLs being downloaded.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
url | The URLRequest object that represents the location of the RSL being downloaded.
RSL_ERROR constant
public static const RSL_ERROR:String = "rslError"

Dispatched when there is an error downloading the RSL. The RSLEvent.RSL_ERROR constant defines the value of the type property of the event object for a rslError event.

The properties of the event object have the following values:

An error message.
Property | Value
bubbles | false
bytesLoaded | Empty
bytesTotal | Empty
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
errorText |
rslIndex | The index number of the RSL currently being downloaded.
rslTotal | The total number of RSLs being downloaded.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
url | The URLRequest object that represents the location of the RSL being downloaded.
RSL_PROGRESS constant
public static const RSL_PROGRESS:String = "rslProgress"

Dispatched when the RSL is downloading. The RSLEvent.RSL_PROGRESS constant defines the value of the type property of the event object for a rslProgress event.

The properties of the event object have the following values:

Empty
Property | Value
bubbles | false
bytesLoaded | The number of bytes loaded.
bytesTotal | The total number of bytes to load.
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
errorText |
rslIndex | The index number of the RSL currently being downloaded.
rslTotal | The total number of RSLs being downloaded.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
url | The URLRequest object that represents the location of the RSL being downloaded.


mx.events.ScrollEvent (Flex™ 2 Language Reference)

Class ScrollEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ScrollEvent
Inheritance | ScrollEvent Inheritance Event Inheritance Object

Represents events that are dispatched by the ScrollBar class.

See also

mx.core.UIComponent
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | delta : Number The change in the scroll position value that resulted from the scroll. | ScrollEvent
 | detail : String Provides the details of the scroll activity. | ScrollEvent
 | direction : String The direction of motion. | ScrollEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | position : Number The new scroll position. | ScrollEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ScrollEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, detail:String = null, position:Number, direction:String = null, delta:Number) Constructor. | ScrollEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | SCROLL : String = "scroll" [static] The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event. | ScrollEvent
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
delta property
public var delta:Number

The change in the scroll position value that resulted from the scroll. The value is expressed in pixels. A positive value indicates the scroll was down or to the right. A negative value indicates the scroll was up or to the left.

detail property
public var detail:String

Provides the details of the scroll activity. Constants for the possible values are provided in the ScrollEventDetail class.

See also

mx.events.ScrollEventDetail
direction property
public var direction:String

The direction of motion. The possible values are ScrollEventDirection.VERTICAL or ScrollEventDirection.HORIZONTAL.

See also

mx.events.ScrollEventDirection
position property
public var position:Number

The new scroll position.

Constructor detail
ScrollEvent () constructor
public function ScrollEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, detail:String = null, position:Number, direction:String = null, delta:Number)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Provides the specifics of the type of scroll activity. Constants for the possible values are provided in the ScrollEventDetail class.
detail:String (default = null) — The new scroll position.
position:Number — The scroll direction, either ScrollEventDirection.HORIZONTAL or ScrollEventDirection.VERTICAL.
direction:String (default = null) — The change in scroll position, expressed in pixels.
delta:Number
Constant detail
SCROLL constant
public static const SCROLL:String = "scroll"

The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
delta | Contains the change in scroll position, expressed in pixels. A positive value indicates the scroll was down or to the right. A negative value indicates the scroll was up or to the left.
direction | Contains the scroll direction, either ScrollEventDirection.HORIZONTAL or ScrollEventDirection.VERTICAL.
position | Contains the new scroll position.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.ScrollEventDetail (Flex™ 2 Language Reference)

Class ScrollEventDetail | Properties | Methods | Constants
Package | mx.events
Class | public final class ScrollEventDetail
Inheritance | ScrollEventDetail Inheritance Object

Constants for the values of the detail property of a ScrollEvent.

See also

mx.events.ScrollEvent
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | AT_BOTTOM : String = "atBottom" [static] Indicates that the scroll bar is at the bottom of its scrolling range. | ScrollEventDetail
 | AT_LEFT : String = "atLeft" [static] Indicates that the scroll bar is at the left of its scrolling range. | ScrollEventDetail
 | AT_RIGHT : String = "atRight" [static] Indicates that the scroll bar is at the right of its scrolling range. | ScrollEventDetail
 | AT_TOP : String = "atTop" [static] Indicates that the scroll bar is at the top of its scrolling range. | ScrollEventDetail
 | LINE_DOWN : String = "lineDown" [static] Indicates that the scroll bar has moved down by one line. | ScrollEventDetail
 | LINE_LEFT : String = "lineLeft" [static] Indicates that the scroll bar has moved left by one line. | ScrollEventDetail
 | LINE_RIGHT : String = "lineRight" [static] Indicates that the scroll bar has moved right by one line. | ScrollEventDetail
 | LINE_UP : String = "lineUp" [static] Indicates that the scroll bar has moved up by one line. | ScrollEventDetail
 | PAGE_DOWN : String = "pageDown" [static] Indicates that the scroll bar has moved down by one page. | ScrollEventDetail
 | PAGE_LEFT : String = "pageLeft" [static] Indicates that the scroll bar has moved left by one page. | ScrollEventDetail
 | PAGE_RIGHT : String = "pageRight" [static] Indicates that the scroll bar has moved right by one page. | ScrollEventDetail
 | PAGE_UP : String = "pageUp" [static] Indicates that the scroll bar has moved up by one page. | ScrollEventDetail
 | THUMB_POSITION : String = "thumbPosition" [static] Indicates that the scroll bar thumb has stopped moving. | ScrollEventDetail
 | THUMB_TRACK : String = "thumbTrack" [static] Indicates that the scroll bar thumb is moving. | ScrollEventDetail
Constant detail
AT_BOTTOM constant
public static const AT_BOTTOM:String = "atBottom"

Indicates that the scroll bar is at the bottom of its scrolling range.

AT_LEFT constant
public static const AT_LEFT:String = "atLeft"

Indicates that the scroll bar is at the left of its scrolling range.

AT_RIGHT constant
public static const AT_RIGHT:String = "atRight"

Indicates that the scroll bar is at the right of its scrolling range.

AT_TOP constant
public static const AT_TOP:String = "atTop"

Indicates that the scroll bar is at the top of its scrolling range.

LINE_DOWN constant
public static const LINE_DOWN:String = "lineDown"

Indicates that the scroll bar has moved down by one line.

LINE_LEFT constant
public static const LINE_LEFT:String = "lineLeft"

Indicates that the scroll bar has moved left by one line.

LINE_RIGHT constant
public static const LINE_RIGHT:String = "lineRight"

Indicates that the scroll bar has moved right by one line.

LINE_UP constant
public static const LINE_UP:String = "lineUp"

Indicates that the scroll bar has moved up by one line.

PAGE_DOWN constant
public static const PAGE_DOWN:String = "pageDown"

Indicates that the scroll bar has moved down by one page.

PAGE_LEFT constant
public static const PAGE_LEFT:String = "pageLeft"

Indicates that the scroll bar has moved left by one page.

PAGE_RIGHT constant
public static const PAGE_RIGHT:String = "pageRight"

Indicates that the scroll bar has moved right by one page.

PAGE_UP constant
public static const PAGE_UP:String = "pageUp"

Indicates that the scroll bar has moved up by one page.

THUMB_POSITION constant
public static const THUMB_POSITION:String = "thumbPosition"

Indicates that the scroll bar thumb has stopped moving.

THUMB_TRACK constant
public static const THUMB_TRACK:String = "thumbTrack"

Indicates that the scroll bar thumb is moving.


mx.events.ScrollEventDirection (Flex™ 2 Language Reference)

Class ScrollEventDirection | Properties | Methods | Constants
Package | mx.events
Class | public final class ScrollEventDirection
Inheritance | ScrollEventDirection Inheritance Object

Constants for the values of the direction property of a ScrollEvent.

See also

mx.events.ScrollEvent
ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HORIZONTAL : String = "horizontal" [static] The user scrolled horizontally. | ScrollEventDirection
 | VERTICAL : String = "vertical" [static] The user scrolled vertically. | ScrollEventDirection
Constant detail
HORIZONTAL constant
public static const HORIZONTAL:String = "horizontal"

The user scrolled horizontally.

VERTICAL constant
public static const VERTICAL:String = "vertical"

The user scrolled vertically.


mx.events.SliderEvent (Flex™ 2 Language Reference)

Class SliderEvent | Properties | Methods | Constants
Package | mx.events
Class | public class SliderEvent
Inheritance | SliderEvent Inheritance Event Inheritance Object

The SliderEvent class represents the event object passed to the event listener for the change, thumbDrag, thumbPress, and thumbRelease events of the HSlider and VSlider classes.

See also

mx.controls.HSlider
mx.controls.VSlider
mx.controls.sliderClasses.Slider
mx.events.SliderEventClickTarget
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | clickTarget : String Specifies whether the slider track or a slider thumb was pressed. | SliderEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | keyCode : int If the event was triggered by a key press, the keycode for the key. | SliderEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | thumbIndex : int The zero-based index of the thumb whose position has changed. | SliderEvent
 | triggerEvent : Event Indicates the type of input action. | SliderEvent
Inherited | type : String The type of event. | Event
 | value : Number The new value of the slider. | SliderEvent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SliderEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, thumbIndex:int = -1, value:Number, triggerEvent:Event = null, clickTarget:String = null, keyCode:int = -1) Constructor. | SliderEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
 | CHANGE : String = "change" [static] The SliderEvent.CHANGE constant defines the value of the type property of the event object for a change event. | SliderEvent
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
 | THUMB_DRAG : String = "thumbDrag" [static] The SliderEvent.THUMB_DRAG constant defines the value of the type property of the event object for a thumbDrag event. | SliderEvent
 | THUMB_PRESS : String = "thumbPress" [static] The SliderEvent.THUMB_PRESS constant defines the value of the type property of the event object for a thumbPress event. | SliderEvent
 | THUMB_RELEASE : String = "thumbRelease" [static] The SliderEvent.THUMB_RELEASE constant defines the value of the type property of the event object for a thumbRelease event. | SliderEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
clickTarget property
public var clickTarget:String

Specifies whether the slider track or a slider thumb was pressed. This property can have one of two values: SliderEventClickTarget.THUMB or SliderEventClickTarget.TRACK.

See also

mx.events.SliderEventClickTarget
keyCode property
public var keyCode:int

If the event was triggered by a key press, the keycode for the key.

thumbIndex property
public var thumbIndex:int

The zero-based index of the thumb whose position has changed. If there is only a single thumb, the value is 0. If there are two thumbs, the value is 0 or 1.

triggerEvent property
public var triggerEvent:Event

Indicates the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.

value property
public var value:Number

The new value of the slider.

Constructor detail
SliderEvent () constructor
public function SliderEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, thumbIndex:int = -1, value:Number, triggerEvent:Event = null, clickTarget:String = null, keyCode:int = -1)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
thumbIndex:int (default = -1) — The zero-based index of the thumb whose position has changed.
value:Number — The type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
triggerEvent:Event (default = null) — Whether the slider track or a slider thumb was pressed.
clickTarget:String (default = null) — If the event was triggered by a key press, the keycode for the key.
keyCode:int (default = -1)
Constant detail
CHANGE constant
public static const CHANGE:String = "change"

The SliderEvent.CHANGE constant defines the value of the type property of the event object for a change event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.
THUMB_DRAG constant
public static const THUMB_DRAG:String = "thumbDrag"

The SliderEvent.THUMB_DRAG constant defines the value of the type property of the event object for a thumbDrag event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.
THUMB_PRESS constant
public static const THUMB_PRESS:String = "thumbPress"

The SliderEvent.THUMB_PRESS constant defines the value of the type property of the event object for a thumbPress event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.
THUMB_RELEASE constant
public static const THUMB_RELEASE:String = "thumbRelease"

The SliderEvent.THUMB_RELEASE constant defines the value of the type property of the event object for a thumbRelease event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
clickTarget | Specifies whether the slider track or a slider thumb was pressed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
keyCode | If the event was triggered by a key press, the keycode for the key.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
thumbIndex | The zero-based index of the thumb whose position has changed.
triggerEvent | Contains a value indicating the type of input action. The value is either InteractionInputType.MOUSE or InteractionInputType.KEYBOARD.
value | The new value of the slider.


mx.events.SliderEventClickTarget (Flex™ 2 Language Reference)

Class SliderEventClickTarget | Properties | Methods | Constants
Package | mx.events
Class | public final class SliderEventClickTarget
Inheritance | SliderEventClickTarget Inheritance Object

The SliderEventClickTarget class defines the constants for the values of the clickTarget property of the SliderEvent class.

See also

mx.events.SliderEvent
HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | THUMB : String = "thumb" [static] Specifies that the Slider's thumb was clicked. | SliderEventClickTarget
 | TRACK : String = "track" [static] Specifies that the Slider's track was clicked. | SliderEventClickTarget
Constant detail
THUMB constant
public static const THUMB:String = "thumb"

Specifies that the Slider's thumb was clicked.

TRACK constant
public static const TRACK:String = "track"

Specifies that the Slider's track was clicked.


mx.events.StateChangeEvent (Flex™ 2 Language Reference)

Class StateChangeEvent | Properties | Methods | Constants
Package | mx.events
Class | public class StateChangeEvent
Inheritance | StateChangeEvent Inheritance Event Inheritance Object

The StateChangeEvent class represents an event that is dispatched when the currentState property of a component changes.

See also

mx.core.UIComponent
mx.states.State

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | newState : String The name of the view state that the component is entering. | StateChangeEvent
 | oldState : String The name of the view state that the component is exiting. | StateChangeEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | StateChangeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, oldState:String = null, newState:String = null) Constructor. | StateChangeEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
 | CURRENT_STATE_CHANGE : String = "currentStateChange" [static] The StateChangeEvent.CURRENT_STATE_CHANGE constant defines the value of the type property of the event that is dispatched when the view state has changed. | StateChangeEvent
 | CURRENT_STATE_CHANGING : String = "currentStateChanging" [static] The StateChangeEvent.CURRENT_STATE_CHANGING constant defines the value of the type property of the event that is dispatched when the view state is about to change. | StateChangeEvent
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
newState property
public var newState:String

The name of the view state that the component is entering.

oldState property
public var oldState:String

The name of the view state that the component is exiting.

Constructor detail
StateChangeEvent () constructor
public function StateChangeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, oldState:String = null, newState:String = null)

Constructor. Normally called by a Flex control and not used in application code.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
oldState:String (default = null) — The name of the view state the component is exiting.
newState:String (default = null) — The name of the view state the component is entering.
Constant detail
CURRENT_STATE_CHANGE constant
public static const CURRENT_STATE_CHANGE:String = "currentStateChange"

The StateChangeEvent.CURRENT_STATE_CHANGE constant defines the value of the type property of the event that is dispatched when the view state has changed. The value of this constant is "currentStateChange".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
newState | The name of the view state that was entered.
oldState | The name of the view state that was exited.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | StateChangeEvent.CURRENT_STATE_CHANGE
CURRENT_STATE_CHANGING constant
public static const CURRENT_STATE_CHANGING:String = "currentStateChanging"

The StateChangeEvent.CURRENT_STATE_CHANGING constant defines the value of the type property of the event that is dispatched when the view state is about to change. The value of this constant is "currentStateChanging".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
newState | The name of the view state that is being entered.
oldState | The name of the view state that is being exited.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | StateChangeEvent.CURRENT_STATE_CHANGING


mx.events.ToolTipEvent (Flex™ 2 Language Reference)

Class ToolTipEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ToolTipEvent
Inheritance | ToolTipEvent Inheritance Event Inheritance Object

The ToolTipEvent class represents ToolTip events, which are generated by the ToolTipManager class. The ToolTipManager class calls the dispatchEvent() method of the object to which the tip applies to dispatch the event.

See also

mx.managers.ToolTipManager
mx.core.UIComponent
Using ToolTip events

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | toolTip : IToolTip The ToolTip object to which this event applies. | ToolTipEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ToolTipEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, toolTip:IToolTip = null) Constructor. | ToolTipEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
 | TOOL_TIP_CREATE : String = "toolTipCreate" [static] The ToolTipEvent.TOOL_TIP_CREATE constant defines the value of the type property of the event object for a toolTipCreate event. | ToolTipEvent
 | TOOL_TIP_END : String = "toolTipEnd" [static] The ToolTipEvent.TOOL_TIP_END constant defines the value of the type property of the event object for a toolTipEnd event. | ToolTipEvent
 | TOOL_TIP_HIDE : String = "toolTipHide" [static] The ToolTipEvent.TOOL_TIP_HIDE constant defines the value of the type property of the event object for a toolTipHide event. | ToolTipEvent
 | TOOL_TIP_SHOW : String = "toolTipShow" [static] The ToolTipEvent.TOOL_TIP_SHOW constant defines the value of the type property of the event object for a toolTipShow event. | ToolTipEvent
 | TOOL_TIP_SHOWN : String = "toolTipShown" [static] The ToolTipEvent.TOOL_TIP_SHOWN constant defines the value of the type property of the event object for a toolTipShown event. | ToolTipEvent
 | TOOL_TIP_START : String = "toolTipStart" [static] The ToolTipEvent.TOOL_TIP_START constant defines the value of the type property of the event object for a toolTipStart event. | ToolTipEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
toolTip property
public var toolTip:IToolTip

The ToolTip object to which this event applies. This object is normally an instance of ToolTip object, but can be any UIComponent object.

Constructor detail
ToolTipEvent () constructor
public function ToolTipEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, toolTip:IToolTip = null)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
toolTip:IToolTip (default = null) — The ToolTip object to which this event applies.
Constant detail
TOOL_TIP_CREATE constant
public static const TOOL_TIP_CREATE:String = "toolTipCreate"

The ToolTipEvent.TOOL_TIP_CREATE constant defines the value of the type property of the event object for a toolTipCreate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
TOOL_TIP_END constant
public static const TOOL_TIP_END:String = "toolTipEnd"

The ToolTipEvent.TOOL_TIP_END constant defines the value of the type property of the event object for a toolTipEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
TOOL_TIP_HIDE constant
public static const TOOL_TIP_HIDE:String = "toolTipHide"

The ToolTipEvent.TOOL_TIP_HIDE constant defines the value of the type property of the event object for a toolTipHide event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
TOOL_TIP_SHOW constant
public static const TOOL_TIP_SHOW:String = "toolTipShow"

The ToolTipEvent.TOOL_TIP_SHOW constant defines the value of the type property of the event object for a toolTipShow event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
TOOL_TIP_SHOWN constant
public static const TOOL_TIP_SHOWN:String = "toolTipShown"

The ToolTipEvent.TOOL_TIP_SHOWN constant defines the value of the type property of the event object for a toolTipShown event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.
TOOL_TIP_START constant
public static const TOOL_TIP_START:String = "toolTipStart"

The ToolTipEvent.TOOL_TIP_START constant defines the value of the type property of the event object for a toolTipStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
tooltip | The ToolTip object to which this event applies.


mx.events.TreeEvent (Flex™ 2 Language Reference)

Class TreeEvent | Properties | Methods | Constants
Package | mx.events
Class | public class TreeEvent
Inheritance | TreeEvent Inheritance Event Inheritance Object

The TreeEvent class represents the event object passed to the event listener for events that are associated with activities in tree, such as when a tree branch opens or closes.

See also

mx.controls.Tree

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | animate : Boolean Whether to animate an opening or closing operation; used for ITEM_OPENING type events only. | TreeEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | dispatchEvent : Boolean Whether to dispatch an event (ITEM_OPEN or ITEM_CLOSE) after the open or close animation is complete. | TreeEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | item : Object Storage for the node property. | TreeEvent
 | itemRenderer : IListItemRenderer The ListItemRenderer for the node that closed or opened. | TreeEvent
 | opening : Boolean Used for an ITEM_OPENING type events only. | TreeEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | triggerEvent : Event The low level MouseEvent or KeyboardEvent that triggered this event or null if this event was triggered programatically. | TreeEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TreeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, item:Object = null, itemRenderer:IListItemRenderer = null, triggerEvent:Event = null) Constructor. | TreeEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | ITEM_CLOSE : String = "itemClose" [static] The TreeEvent.ITEM_CLOSE event type constant indicates that a tree branch closed or collapsed. | TreeEvent
 | ITEM_OPEN : String = "itemOpen" [static] The TreeEvent.ITEM_OPEN event type constant indicates that a tree branch opened or expaneded. | TreeEvent
 | ITEM_OPENING : String = "itemOpening" [static] The TreeEvent.ITEM_OPENING event type constant is dispatched immediately before a tree opens or closes. | TreeEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
animate property
public var animate:Boolean

Whether to animate an opening or closing operation; used for ITEM_OPENING type events only.

dispatchEvent property
public var dispatchEvent:Boolean

Whether to dispatch an event (ITEM_OPEN or ITEM_CLOSE) after the open or close animation is complete. Used for ITEM_OPENING type events only.

item property
public var item:Object

Storage for the node property. If you populate the Tree from XML data, access the label and data properties for the node as event.node.attributes.label and event.node.attributes.data.

itemRenderer property
public var itemRenderer:IListItemRenderer

The ListItemRenderer for the node that closed or opened.

opening property
public var opening:Boolean

Used for an ITEM_OPENING type events only. Indicates whether the item is opening true, or closing false.

triggerEvent property
public var triggerEvent:Event

The low level MouseEvent or KeyboardEvent that triggered this event or null if this event was triggered programatically.

Constructor detail
TreeEvent () constructor
public function TreeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, item:Object = null, itemRenderer:IListItemRenderer = null, triggerEvent:Event = null)

Constructor. Normally called by the Flex Tree control; not used in application code.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
item:Object (default = null) — The Tree node (item) to which this event applies.
itemRenderer:IListItemRenderer (default = null) — The item renderer object for the cell.
triggerEvent:Event (default = null) — If the node opened or closed in response to a user action, indicates the type of input action.
Constant detail
ITEM_CLOSE constant
public static const ITEM_CLOSE:String = "itemClose"

The TreeEvent.ITEM_CLOSE event type constant indicates that a tree branch closed or collapsed.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
itemRenderer | The ListItemRenderer for the node that closed
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
triggerEvent | If the node closed in response to a user action, identifies it as a keyboard action or a mouse action.
node | the Tree node that closed
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | TreeEvent.ITEM_CLOSE
ITEM_OPEN constant
public static const ITEM_OPEN:String = "itemOpen"

The TreeEvent.ITEM_OPEN event type constant indicates that a tree branch opened or expaneded.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
itemRenderer | The ListItemRenderer for the node that opened
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
triggerEvent | If the node opened in response to a user action, identifies it as a keyboard action or a mouse action.
node | the Tree node that opened
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
type | TreeEvent.ITEM_OPEN
ITEM_OPENING constant
public static const ITEM_OPENING:String = "itemOpening"

The TreeEvent.ITEM_OPENING event type constant is dispatched immediately before a tree opens or closes.

The properties of the event object for this event type have the following values. Not all properties are meaningful for all kinds of events. See the detailed property descriptions for more information.

Property | Value
animate | Whether to animate the opening or closing operation.
bubbles | false
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
dispatchEvent | Whether to dispatch an ITEM_OPEN or ITEM_CLOSE event after the open or close animation is complete. true
itemRenderer | The ListItemRenderer for the node that opened
node | the Tree node that opened
opening | true if the item is opening, false if it is closing.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
triggerEvent | If the node opened in response to a user action, identifies it as a keyboard action or a mouse action.
type | TreeEvent.ITEM_OPENING


mx.events.TweenEvent (Flex™ 2 Language Reference)

Class TweenEvent | Properties | Methods | Constants
Package | mx.events
Class | public class TweenEvent
Inheritance | TweenEvent Inheritance Event Inheritance Object

Represents event objects that are specific to Flex tween effects. Flex effects dispatch two types of tween events:
  • tweenUpdate
  • tweenEnd

See also

mx.effects.TweenEffect
mx.effects.Tween

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
 | value : Object For a tweenStart or tweenUpdate event, the value passed to the onTweenUpdate() method; for a tweenEnd event, the value passed to the onTweenEnd() method. | TweenEvent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TweenEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, value:Object = null) Constructor. | TweenEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
 | TWEEN_END : String = "tweenEnd" [static] The TweenEvent.TWEEN_END constant defines the value of the event object's type property for a tweenEnd event. | TweenEvent
 | TWEEN_START : String = "tweenStart" [static] The TweenEvent.TWEEN_START constant defines the value of the event object's type property for a tweenStart event. | TweenEvent
 | TWEEN_UPDATE : String = "tweenUpdate" [static] The TweenEvent.TWEEN_UPDATE constant defines the value of the event object's type property for a tweenUpdate event. | TweenEvent
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
value property
public var value:Object

For a tweenStart or tweenUpdate event, the value passed to the onTweenUpdate() method; for a tweenEnd event, the value passed to the onTweenEnd() method.

For the exact value of this property, see the instance class for each tween effect.

See also

mx.effects.effectClasses.ActionEffectInstance
mx.effects.effectClasses.BlurInstance
mx.effects.effectClasses.DissolveInstance
mx.effects.effectClasses.FadeInstance
mx.effects.effectClasses.GlowInstance
mx.effects.effectClasses.MaskEffectInstance
mx.effects.effectClasses.MoveInstance
mx.effects.effectClasses.ResizeInstance
mx.effects.effectClasses.RotateInstance
mx.effects.effectClasses.ZoomInstance
Constructor detail
TweenEvent () constructor
public function TweenEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, value:Object = null)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
value:Object (default = null) — For a tweenStart or tweenUpdate event, the value passed to the onTweenUpdate() method; for a tweenEnd event, the value passed to the onTweenEnd() method.
Constant detail
TWEEN_END constant
public static const TWEEN_END:String = "tweenEnd"

The TweenEvent.TWEEN_END constant defines the value of the event object's type property for a tweenEnd event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenEnd() method.

See also

mx.effects.Effect
mx.effects.TweenEffect
mx.events.EffectEvent
TWEEN_START constant
public static const TWEEN_START:String = "tweenStart"

The TweenEvent.TWEEN_START constant defines the value of the event object's type property for a tweenStart event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenUpdate() method.
TWEEN_UPDATE constant
public static const TWEEN_UPDATE:String = "tweenUpdate"

The TweenEvent.TWEEN_UPDATE constant defines the value of the event object's type property for a tweenUpdate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
value | The value passed to the onTweenUpdate() method.


mx.events.ValidationResultEvent (Flex™ 2 Language Reference)

Class ValidationResultEvent | Properties | Methods | Constants
Package | mx.events
Class | public class ValidationResultEvent
Inheritance | ValidationResultEvent Inheritance Event Inheritance Object

The ValidationResultEvent class represents the event object passed to the listener for the valid validator event or the invalid validator event.

See also

mx.validators.Validator
mx.validators.ValidationResult
mx.validators.RegExpValidationResult

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | field : String The name of the field that failed validation and triggered the event. | ValidationResultEvent
 | message : String [read-only] A single string that contains every error message from all of the ValidationResult objects in the results Array. | ValidationResultEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | results : Array An array of ValidationResult objects, one per validated field. | ValidationResultEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ValidationResultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, field:String = null, results:Array = null) Constructor. | ValidationResultEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | INVALID : String = "invalid" [static] The ValidationResultEvent.INVALID constant defines the value of the type property of the event object for an invalid event. | ValidationResultEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
 | VALID : String = "valid" [static] The ValidationResultEvent.VALID constant defines the value of the type property of the event object for a validevent. | ValidationResultEvent
Property detail
field property
public var field:String

The name of the field that failed validation and triggered the event.

message property
message:String [read-only]

A single string that contains every error message from all of the ValidationResult objects in the results Array.

Implementation
    public function get message():String
results property
public var results:Array

An array of ValidationResult objects, one per validated field.

See also

mx.validators.ValidationResult
Constructor detail
ValidationResultEvent () constructor
public function ValidationResultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, field:String = null, results:Array = null)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
field:String (default = null) — The name of the field that failed validation and triggered the event.
results:Array (default = null) — An array of ValidationResult objects, one per validated field.
Constant detail
INVALID constant
public static const INVALID:String = "invalid"

The ValidationResultEvent.INVALID constant defines the value of the type property of the event object for an invalid event. The value of this constant is "invalid".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
field | The name of the field that failed validation.
message | A single string that contains every error message from all of the ValidationResult objects in the results Array.
results | An array of ValidationResult objects, one per validated field.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
VALID constant
public static const VALID:String = "valid"

The ValidationResultEvent.VALID constant defines the value of the type property of the event object for a validevent. The value of this constant is "valid".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
field | An empty String.
message | An empty String.
results | An empty Array.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.events.VideoEvent (Flex™ 2 Language Reference)

Class VideoEvent | Properties | Methods | Constants
Package | mx.events
Class | public class VideoEvent
Inheritance | VideoEvent Inheritance Event Inheritance Object

The VideoEvent class represents the event object passed to the event listener for events dispatched by the VideoDisplay control, and defines the values of the VideoDisplay.state property.

See also

mx.controls.VideoDisplay

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | playheadTime : Number The location of the playhead of the VideoDisplay control when the event occurs. | VideoEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | state : String The value of the VideoDisplay.state property when the event occurs. | VideoEvent
 | stateResponsive : Boolean [read-only] The value of the VideoDisplay.stateResponsive property when the event occurs. | VideoEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | VideoEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, state:String = null, playheadTime:Number) Constructor. | VideoEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
 | BUFFERING : String = "buffering" [static] The value of the VideoDisplay.state property immediately after a call to the play() or load() method. | VideoEvent
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
 | CLOSE : String = "close" [static] The VideoEvent.CLOSE constant defines the value of the type property of the event object for a close event. | VideoEvent
 | COMPLETE : String = "complete" [static] The VideoEvent.COMPLETE constant defines the value of the type property of the event object for a complete event. | VideoEvent
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
 | CONNECTION_ERROR : String = "connectionError" [static] The value of the VideoDisplay.state property when the VideoDisplay control was unable to load the video stream. | VideoEvent
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | DISCONNECTED : String = "disconnected" [static] The value of the VideoDisplay.state property when the video stream has timed out or is idle. | VideoEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | EXEC_QUEUED_CMD : String = "execQueuedCmd" [static] The value of the VideoDisplay.state property during execution of queued command. | VideoEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | LOADING : String = "loading" [static] The value of the VideoDisplay.state property immediately after a call to the play() or load() method. | VideoEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
 | PAUSED : String = "paused" [static] The value of the VideoDisplay.state property when an FLV file is loaded, but play is paused. | VideoEvent
 | PLAYHEAD_UPDATE : String = "playheadUpdate" [static] The VideoEvent.PLAYHEAD_UPDATE constant defines the value of the type property of the event object for a playheadUpdate event. | VideoEvent
 | PLAYING : String = "playing" [static] The value of the VideoDisplay.state property when an FLV file is loaded and is playing. | VideoEvent
 | READY : String = "ready" [static] The VideoEvent.READY constant defines the value of the type property of the event object for a ready event. | VideoEvent
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | RESIZING : String = "resizing" [static] The value of the VideoDisplay.state property when the VideoDisplay control is resizing. | VideoEvent
 | REWIND : String = "rewind" [static] The VideoEvent.REWIND constant defines the value of the type property of the event object for a rewind event. | VideoEvent
 | REWINDING : String = "rewinding" [static] The value of the VideoDisplay.state property during an autorewind triggered when play stops. | VideoEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
 | SEEKING : String = "seeking" [static] The value of the VideoDisplay.state property for a seek occurring due to the VideoDisplay.playHeadTime property being set. | VideoEvent
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
 | STATE_CHANGE : String = "stateChange" [static] The VideoEvent.STATE_CHANGE constant defines the value of the type property of the event object for a stateChange event. | VideoEvent
 | STOPPED : String = "stopped" [static] The value of the VideoDisplay.state property when an FLV file is loaded but play has stopped. | VideoEvent
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
playheadTime property
public var playheadTime:Number

The location of the playhead of the VideoDisplay control when the event occurs.

state property
public var state:String

The value of the VideoDisplay.state property when the event occurs.

See also

mx.controls.VideoDisplay.state
stateResponsive property
stateResponsive:Boolean [read-only]

The value of the VideoDisplay.stateResponsive property when the event occurs.

Implementation
    public function get stateResponsive():Boolean

See also

mx.controls.VideoDisplay.stateResponsive
Constructor detail
VideoEvent () constructor
public function VideoEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, state:String = null, playheadTime:Number)

Constructor.

Parameters
type:String — The event type; indicates the action that caused the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
state:String (default = null) — The value of the VideoDisplay.state property when the event occurs.
playheadTime:Number — The location of the playhead when the event occurs.
Constant detail
BUFFERING constant
public static const BUFFERING:String = "buffering"

The value of the VideoDisplay.state property immediately after a call to the play() or load() method.

This is a responsive state. In the responsive state, calls to the play(), load(), stop(), and pause() methods are executed immediately.

CLOSE constant
public static const CLOSE:String = "close"

The VideoEvent.CLOSE constant defines the value of the type property of the event object for a close event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
COMPLETE constant
public static const COMPLETE:String = "complete"

The VideoEvent.COMPLETE constant defines the value of the type property of the event object for a complete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
CONNECTION_ERROR constant
public static const CONNECTION_ERROR:String = "connectionError"

The value of the VideoDisplay.state property when the VideoDisplay control was unable to load the video stream. This state can occur when there is no connection to a server, the video stream is not found, or for other reasons.

This is a unresponsive state. If the control is unresponsive, calls to the play(), load(), stop(), and pause() methods are queued, and then executed when the control changes to the responsive state.

DISCONNECTED constant
public static const DISCONNECTED:String = "disconnected"

The value of the VideoDisplay.state property when the video stream has timed out or is idle.

This is a responsive state. In the responsive state, calls to the play(), load(), stop(), and pause() methods are executed immediately.

EXEC_QUEUED_CMD constant
public static const EXEC_QUEUED_CMD:String = "execQueuedCmd"

The value of the VideoDisplay.state property during execution of queued command. There will never be a stateChange event dispatched for this state; it is for internal use only.

This is a unresponsive state. If the control is unresponsive, calls to the play(), load(), stop(), and pause() methods are queued, and then executed when the control changes to the responsive state.

LOADING constant
public static const LOADING:String = "loading"

The value of the VideoDisplay.state property immediately after a call to the play() or load() method.

This is a unresponsive state. If the control is unresponsive, calls to the play(), load(), stop(), and pause() methods are queued, and then executed when the control changes to the responsive state.

PAUSED constant
public static const PAUSED:String = "paused"

The value of the VideoDisplay.state property when an FLV file is loaded, but play is paused. This state is entered when you call the pause() or load() method.

This is a responsive state. In the responsive state, calls to the play(), load(), stop(), and pause() methods are executed immediately.

PLAYHEAD_UPDATE constant
public static const PLAYHEAD_UPDATE:String = "playheadUpdate"

The VideoEvent.PLAYHEAD_UPDATE constant defines the value of the type property of the event object for a playheadUpdate event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
PLAYING constant
public static const PLAYING:String = "playing"

The value of the VideoDisplay.state property when an FLV file is loaded and is playing. This state is entered when you call the play() method.

This is a responsive state. In the responsive state, calls to the play(), load(), stop(), and pause() methods are executed immediately.

READY constant
public static const READY:String = "ready"

The VideoEvent.READY constant defines the value of the type property of the event object for a ready event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
RESIZING constant
public static const RESIZING:String = "resizing"

The value of the VideoDisplay.state property when the VideoDisplay control is resizing.

This is a unresponsive state. If the control is unresponsive, calls to the play(), load(), stop(), and pause() methods are queued, and then executed when the control changes to the responsive state.

REWIND constant
public static const REWIND:String = "rewind"

The VideoEvent.REWIND constant defines the value of the type property of the event object for a rewind event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
REWINDING constant
public static const REWINDING:String = "rewinding"

The value of the VideoDisplay.state property during an autorewind triggered when play stops. After the rewind completes, the state changes to STOPPED.

This is a unresponsive state. If the control is unresponsive, calls to the play(), load(), stop(), and pause() methods are queued, and then executed when the control changes to the responsive state.

SEEKING constant
public static const SEEKING:String = "seeking"

The value of the VideoDisplay.state property for a seek occurring due to the VideoDisplay.playHeadTime property being set.

This is a unresponsive state. If the control is unresponsive, calls to the play(), load(), stop(), and pause() methods are queued, and then executed when the control changes to the responsive state.

STATE_CHANGE constant
public static const STATE_CHANGE:String = "stateChange"

The VideoEvent.STATE_CHANGE constant defines the value of the type property of the event object for a stateChange event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
playheadTime | The location of the playhead when the event occurs.
state | The value of the VideoDisplay.state property when the event occurs.
stateResponsive | The value of the VideoDisplay.stateResponsive property when the event occurs.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
STOPPED constant
public static const STOPPED:String = "stopped"

The value of the VideoDisplay.state property when an FLV file is loaded but play has stopped. This state is entered when you call the stop() method or when the playhead reaches the end of the video stream.

This is a responsive state. In the responsive state, calls to the play(), load(), stop(), and pause() methods are executed immediately.


mx.formatters Summary (Flex™ 2 Language Reference)

Package mx.formatters | Classes

The mx.formatters package contains the classes to support data formatting.

Classes
Class | Description
CurrencyFormatter | The CurrencyFormatter class formats a valid number as a currency value.
DateBase | The DateBase class contains the localized string information used by the mx.formatters.DateFormatter class and the parsing function that renders the pattern.
DateFormatter | The DateFormatter class uses a format String to render date and time Strings from a String or a Date object.
Formatter | The Formatter class is the base class for all data formatters.
NumberBase | The NumberBase class is a utility class that contains general number formatting capabilities, including rounding, precision, thousands formatting, and negative sign formatting.
NumberBaseRoundType | The NumberBaseRoundType class defines the constant values for formatter properties that specify a type of rounding.
NumberFormatter | The NumberFormatter class formats a valid number by adjusting the decimal rounding and precision, the thousands separator, and the negative sign.
PhoneFormatter | The PhoneFormatter class formats a valid number into a phone number format, including international configurations.
SwitchSymbolFormatter | The SwitchSymbolFormatter class is a utility class that you can use when creating custom formatters.
ZipCodeFormatter | The ZipCodeFormatter class formats a valid number into one of the following formats, based on a user-supplied formatString property.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.formatters.CurrencyFormatter (Flex™ 2 Language Reference)

Class CurrencyFormatter | Properties | Methods | Examples
Package | mx.formatters
Class | public class CurrencyFormatter
Inheritance | CurrencyFormatter Inheritance Formatter Inheritance Object

The CurrencyFormatter class formats a valid number as a currency value. It adjusts the decimal rounding and precision, the thousands separator, and the negative sign; it also adds a currency symbol. You place the currency symbol on either the left or the right side of the value with the alignSymbol property. The currency symbol can contain multiple characters, including blank spaces.

If an error occurs, an empty String is returned and a String that describes the error is saved to the error property. The error property can have one of the following values:

  • "Invalid value" means an invalid numeric value is passed to the format() method. The value should be a valid number in the form of a Number or a String.
  • "Invalid format" means one of the parameters contains an unusable setting.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:CurrencyFormatter> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:CurrencyFormatter
    alignSymbol="left|right"
    currencySymbol="$"
    decimalSeparatorFrom="."
    decimalSeparatorTo="."
    precision="-1"
    rounding="none|up|down|nearest"
    thousandsSeparatorFrom=","
    thousandsSeparatorTo=","
    useNegativeSign="true|false"
    useThousandsSeparator="true|false"
 />

View the examples.

See also

mx.formatters.NumberBase
mx.formatters.NumberBaseRoundType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alignSymbol : String Aligns currency symbol to the left side or the right side of the formatted number. | CurrencyFormatter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currencySymbol : String Character to use as a currency symbol for a formatted number. | CurrencyFormatter
 | decimalSeparatorFrom : String Decimal separator character to use when parsing an input string. | CurrencyFormatter
 | decimalSeparatorTo : String Decimal separator character to use when outputting formatted decimal numbers. | CurrencyFormatter
Inherited | error : String Description saved by the formatter when an error occurs. | Formatter
 | precision : int Number of decimal places to include in the output String. | CurrencyFormatter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rounding : String How to round the number. | CurrencyFormatter
 | thousandsSeparatorFrom : String Character to use as the thousands separator in the input String. | CurrencyFormatter
 | thousandsSeparatorTo : String Character to use as the thousands separator in the output string. | CurrencyFormatter
 | useNegativeSign : Boolean If true, format a negative number by preceding it with a minus "-" sign. | CurrencyFormatter
 | useThousandsSeparator : Boolean If true, split the number into thousands increments by using a separator character. | CurrencyFormatter
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | defaultInvalidFormatError : String = "Invalid format" Error message for an invalid format string specified to the formatter. | Formatter
Inherited | defaultInvalidValueError : String = "Invalid value" Error message for an invalid value specified to the formatter. | Formatter
Inherited | packageResources : ResourceBundle [static] A ResourceBundle object containing all symbols from formatters.properties. | Formatter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CurrencyFormatter() Constructor. | CurrencyFormatter
 | format(value:Object):String Formats value as currency. | CurrencyFormatter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alignSymbol property
public var alignSymbol:String

Aligns currency symbol to the left side or the right side of the formatted number. Permitted values are "left" and "right".

The default value is "left".

currencySymbol property
public var currencySymbol:String

Character to use as a currency symbol for a formatted number. You can use one or more characters to represent the currency symbol; for example, "$" or "YEN". You can also use empty spaces to add space between the currency character and the formatted number. When the number is a negative value, the currency symbol appears between the number and the minus sign or parentheses.

The default value is "$".

decimalSeparatorFrom property
public var decimalSeparatorFrom:String

Decimal separator character to use when parsing an input string.

The default value is ".".

decimalSeparatorTo property
public var decimalSeparatorTo:String

Decimal separator character to use when outputting formatted decimal numbers.

The default value is ".".

precision property
public var precision:int

Number of decimal places to include in the output String. You can disable precision by setting it to -1. A value of -1 means do not change the precision. For example, if the input value is 1.453 and rounding is set to NumberBaseRoundType.NONE, return 1.453. If precision is -1 and you set some form of rounding, return a value based on that rounding type.

The default value is -1.

rounding property
public var rounding:String

How to round the number. In ActionScript, the value can be NumberBaseRoundType.NONE, NumberBaseRoundType.UP, NumberBaseRoundType.DOWN, or NumberBaseRoundType.NEAREST. In MXML, the value can be "none", "up", "down", or "nearest".

The default value is NumberBaseRoundType.NONE.

See also

mx.formatters.NumberBaseRoundType
thousandsSeparatorFrom property
public var thousandsSeparatorFrom:String

Character to use as the thousands separator in the input String.

The default value is ",".

thousandsSeparatorTo property
public var thousandsSeparatorTo:String

Character to use as the thousands separator in the output string.

The default value is ",".

useNegativeSign property
public var useNegativeSign:Boolean

If true, format a negative number by preceding it with a minus "-" sign. If false, format the number surrounded by parentheses, for example (400).

The default value is true.

useThousandsSeparator property
public var useThousandsSeparator:Boolean

If true, split the number into thousands increments by using a separator character.

The default value is true.

Constructor detail
CurrencyFormatter () constructor
public function CurrencyFormatter()

Constructor.

Method detail
format () method
public override function format(value:Object):String

Formats value as currency. If value cannot be formatted, return an empty String and write a description of the error to the error property.

Parameters
value:Object — Value to format.

Returns
String — Formatted string. Empty if an error occurs.
Examples
CurrencyFormatterExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the CurrencyFormatter. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

              import mx.events.ValidationResultEvent;
              private var vResult:ValidationResultEvent;

              // Event handler to validate and format input.
              private function Format():void {

                     vResult = numVal.validate();

                    if (vResult.type==ValidationResultEvent.VALID) {
                        var temp:Number=Number(priceUS.text);
                        formattedUSPrice.text= usdFormatter.format(temp);
                    }

                    else {
                       formattedUSPrice.text="";
                    }
              }
        ]]>
    </mx:Script>

    <mx:CurrencyFormatter id="usdFormatter" precision="2"
        currencySymbol="$" decimalSeparatorFrom="."
        decimalSeparatorTo="." useNegativeSign="true"
        useThousandsSeparator="true" alignSymbol="left"/>

    <mx:NumberValidator id="numVal" source="{priceUS}" property="text"
        allowNegative="true" domain="real"/>

    <mx:Panel title="CurrencyFormatter Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter U.S. dollar amount:">
                <mx:TextInput id="priceUS" text="" width="50%"/>
            </mx:FormItem>

            <mx:FormItem label="Formatted amount: ">
                <mx:TextInput id="formattedUSPrice" text="" width="50%" editable="false"/>
            </mx:FormItem>

            <mx:FormItem>
                <mx:Button label="Validate and Format" click="Format();"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.formatters.DateBase (Flex™ 2 Language Reference)

Class DateBase | Properties | Methods
Package | mx.formatters
Class | public class DateBase
Inheritance | DateBase Inheritance Object

The DateBase class contains the localized string information used by the mx.formatters.DateFormatter class and the parsing function that renders the pattern. This is a helper class for the DateFormatter class that is not usually used independently.

See also

mx.formatters.DateFormatter

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dayNamesLong : Array [static] Long format of day names. | DateBase
 | dayNamesShort : Array [static] Short format of day names. | DateBase
 | monthNamesLong : Array [static] Long format of month names. | DateBase
 | monthNamesShort : Array [static] Short format of month names. | DateBase
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | timeOfDay : Array [static] Time of day names. | DateBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
dayNamesLong property
public static var dayNamesLong:Array

Long format of day names.

The default value is [Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday", "Saturday"].

dayNamesShort property
public static var dayNamesShort:Array

Short format of day names.

The default value is ["Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"].

monthNamesLong property
public static var monthNamesLong:Array

Long format of month names.

The default value is ["January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December"]..

monthNamesShort property
public static var monthNamesShort:Array

Short format of month names.

The default value is ["Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct","Nov", "Dec"].

timeOfDay property
timeOfDay:Array [read-write]

Time of day names.

The default value is ["AM", "PM"].

Implementation
    public static function get timeOfDay():Array
    public function set timeOfDay(value:Array):void


mx.formatters.DateFormatter (Flex™ 2 Language Reference)

Class DateFormatter | Properties | Methods | Examples
Package | mx.formatters
Class | public class DateFormatter
Inheritance | DateFormatter Inheritance Formatter Inheritance Object

The DateFormatter class uses a format String to render date and time Strings from a String or a Date object. You can create many variations easily, including international formats.

If an error occurs, an empty String is returned and a String describing the error is saved to the error property. The error property can have one of the following values:

  • "Invalid value" means a value that is not a Date object or a is not a recognized String representation of a date is passed to the format() method. (An empty argument is allowed.)
  • "Invalid format" means either the formatString property is set to empty (""), or there is less than one pattern letter in the formatString property.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

You use the <mx:DateFormatter> tag to render date and time Strings from a Date object.

The <mx:DateFormatter> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:DateFormatter
    formatString="Y|M|D|A|E|H|J|K|L|N|S"
   />

View the examples.

See also

mx.formatters.DateBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | error : String Description saved by the formatter when an error occurs. | Formatter
 | formatString : String The mask pattern. | DateFormatter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | defaultInvalidFormatError : String = "Invalid format" Error message for an invalid format string specified to the formatter. | Formatter
Inherited | defaultInvalidValueError : String = "Invalid value" Error message for an invalid value specified to the formatter. | Formatter
Inherited | packageResources : ResourceBundle [static] A ResourceBundle object containing all symbols from formatters.properties. | Formatter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | DateFormatter() Constructor. | DateFormatter
 | format(value:Object):String Formats a String as a date. | DateFormatter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Method |  | Defined by
 | parseDateString(str:String):Date [static] Converts a date that is formatted as a String into a Date object. | DateFormatter
Property detail
formatString property
public var formatString:String

The mask pattern.

You compose a pattern String using specific uppercase letters, for example: YYYY/MM.

The DateFormatter pattern String can contain other text in addition to pattern letters. To form a valid pattern String, you only need one pattern letter.

The following table describes the valid pattern letters:

Pattern letter | Description
Y Year. If the number of pattern letters is two, the year is truncated to two digits; otherwise, it appears as four digits. The year can be zero-padded, as the third example shows in the following set of examples:

YY = 05

YYYY = 2005

YYYYY = 02005
M Month in year. The format depends on the following criteria:
  • If the number of pattern letters is one, the format is interpreted as numeric in one or two digits.
  • If the number of pattern letters is two, the format is interpreted as numeric in two digits.
  • If the number of pattern letters is three, the format is interpreted as short text.
  • If the number of pattern letters is four, the format is interpreted as full text.
Examples:

M = 7

MM= 07

MMM=Jul

MMMM= July
D Day in month. While a single-letter pattern string for day is valid, you typically use a two-letter pattern string.

Examples:

D=4

DD=04

DD=10
E Day in week. The format depends on the following criteria:
  • If the number of pattern letters is one, the format is interpreted as numeric in one or two digits.
  • If the number of pattern letters is two, the format is interpreted as numeric in two digits.
  • If the number of pattern letters is three, the format is interpreted as short text.
  • If the number of pattern letters is four, the format is interpreted as full text.
Examples:

E = 1

EE = 01

EEE = Mon

EEEE = Monday
A | am/pm indicator.
J | Hour in day (0-23).
H | Hour in day (1-24).
K | Hour in am/pm (0-11).
L | Hour in am/pm (1-12).
N Minute in hour.

Examples:

N = 3

NN = 03
S Second in minute.

Examples:

SS = 30
Other text You can add other text into the pattern string to further format the string. You can use punctuation, numbers, and all lowercase letters. You should avoid uppercase letters because they may be interpreted as pattern letters.

Example:

EEEE, MMM. D, YYYY at H:NN A = Tuesday, Sept. 8, 2005 at 1:26 PM

The default value is "MM/DD/YYYY".

Constructor detail
DateFormatter () constructor
public function DateFormatter()

Constructor.

Method detail
format () method
public override function format(value:Object):String

Formats a String as a date. The formatString property determines the format of the output String. If value cannot be formatted, return an empty String and write a description of the error to the error property.

Parameters
value:Object — Date to format. This can be a Date object, or a date String such as "Thursday, April 22, 2004".

Returns
String — Formatted String. Empty if an error occurs. A description of the error condition is written to the error property.
parseDateString () method
protected static function parseDateString(str:String):Date

Converts a date that is formatted as a String into a Date object. Month and day names must match the names in mx.formatters.DateBase.

Parameters
str:String — Date that is formatted as a String.

Returns
Date — Date object.

See also

mx.formatters.DateBase
Examples
DateFormatterExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the DateFormatter. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.events.ValidationResultEvent;
            private var vResult:ValidationResultEvent;

            // Event handler to validate and format input.
            private function Format():void
            {
                vResult = dateVal.validate();
                if (vResult.type==ValidationResultEvent.VALID) {
                    formattedDate.text=dateFormatter.format(dob.text);
                }

                else {
                    formattedDate.text= "";
                }
            }
        ]]>
    </mx:Script>

    <mx:DateFormatter id="dateFormatter" formatString="month: MM, day: DD, year: YYYY"/>

    <mx:DateValidator id="dateVal" source="{dob}" property="text" inputFormat="mm/dd/yyyy"/>

    <mx:Panel title="DateFormatter Example" width="95%" height="95%"
            paddingTop="10" paddingLeft="5" paddingRight="5" paddingBottom="10">

        <mx:Form width="100%">
            <mx:FormItem label="Enter date (mm/dd/yyyy):" width="100%">
                <mx:TextInput id="dob" text=""/>
            </mx:FormItem>

            <mx:FormItem label="Formatted date: " width="100%">
                <mx:TextInput id="formattedDate" text="" editable="false"/>
            </mx:FormItem>

            <mx:FormItem>
                <mx:Button label="Validate and Format" click="Format();"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.formatters.Formatter (Flex™ 2 Language Reference)

Class Formatter | Properties | Methods | Examples
Package | mx.formatters
Class | public class Formatter
Inheritance | Formatter Inheritance Object
Subclasses | CurrencyFormatter, DateFormatter, NumberFormatter, PhoneFormatter, ZipCodeFormatter

The Formatter class is the base class for all data formatters. Any subclass of Formatter must override the format() method.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The Formatter class defines the following tag attributes, which all of its subclasses inherit:

  <mx:tagname
    Properties
    error=""
  />

View the examples.

See also

Creating a custom formatter

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | error : String Description saved by the formatter when an error occurs. | Formatter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Protected Properties
Property |  | Defined by
 | defaultInvalidFormatError : String = "Invalid format" Error message for an invalid format string specified to the formatter. | Formatter
 | defaultInvalidValueError : String = "Invalid value" Error message for an invalid value specified to the formatter. | Formatter
 | packageResources : ResourceBundle [static] A ResourceBundle object containing all symbols from formatters.properties. | Formatter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Formatter() Constructor. | Formatter
 | format(value:Object):String Formats a value and returns a String containing the new, formatted, value. | Formatter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
defaultInvalidFormatError property
protected var defaultInvalidFormatError:String = "Invalid format"

Error message for an invalid format string specified to the formatter.

The default value is "Invalid format".

defaultInvalidValueError property
protected var defaultInvalidValueError:String = "Invalid value"

Error message for an invalid value specified to the formatter.

The default value is "Invalid value".

error property
public var error:String

Description saved by the formatter when an error occurs. For the possible values of this property, see the description of each formatter.

Subclasses must set this value in the format() method.

packageResources property
protected static var packageResources:ResourceBundle

A ResourceBundle object containing all symbols from formatters.properties.

Constructor detail
Formatter () constructor
public function Formatter()

Constructor.

Method detail
format () method
public function format(value:Object):String

Formats a value and returns a String containing the new, formatted, value. All subclasses must override this method to implement the formatter.

Parameters
value:Object — Value to be formatted.

Returns
String — The formatted string.
Examples
SimpleFormatterExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Formatter class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            // Event handler to format the input.
            private function Format():void
            {
                // The format() method returns the formatted String,
                // or an empty String if there is an error.
                var formattedVal:String = numberFormatter.format(inputVal.text);

                if (formattedVal.length==0) {
                    // If there is an error, the Format.error property
                    // contains the reason.
                    formattedNumber.text=numberFormatter.error;
                }

                else {
                    formattedNumber.text=formattedVal;
                }
            }
        ]]>
    </mx:Script>

    <mx:NumberFormatter id="numberFormatter"/>

    <mx:Panel title="NumberFormatter Example" width="75%" height="75%"
            paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter number - a letter is invalid:">
                <mx:TextInput id="inputVal" text="" width="75%"/>
            </mx:FormItem>

            <mx:FormItem label="Formatted number: ">
                <mx:TextInput id="formattedNumber" editable="false" width="75%"/>
            </mx:FormItem>

            <mx:FormItem>
                <mx:Button label="Validate and Format" click="Format();"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.formatters.NumberBase (Flex™ 2 Language Reference)

Class NumberBase | Properties | Methods
Package | mx.formatters
Class | public class NumberBase
Inheritance | NumberBase Inheritance Object

The NumberBase class is a utility class that contains general number formatting capabilities, including rounding, precision, thousands formatting, and negative sign formatting. The implementation of the formatter classes use this class.

See also

mx.formatters.NumberFormatter
mx.formatters.NumberBaseRoundType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | decimalSeparatorFrom : String Decimal separator character to use when parsing an input String. | NumberBase
 | decimalSeparatorTo : String Decimal separator character to use when outputting formatted decimal numbers. | NumberBase
 | isValid : Boolean = false If true, the format succeeded, otherwise it is false. | NumberBase
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | thousandsSeparatorFrom : String Character to use as the thousands separator in the input String. | NumberBase
 | thousandsSeparatorTo : String Character to use as the thousands separator in the output String. | NumberBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | NumberBase(decimalSeparatorFrom:String = ".", thousandsSeparatorFrom:String = ",", decimalSeparatorTo:String = ".", thousandsSeparatorTo:String = ",") Constructor. | NumberBase
 | formatDecimal(value:String):String Formats a number by replacing the default decimal separator, ".", with the decimal separator specified by decimalSeparatorTo. | NumberBase
 | formatNegative(value:String, useSign:Boolean):String Formats a negative number with either a minus sign (-) or parentheses (). | NumberBase
 | formatPrecision(value:String, precision:int):String Formats a number by setting its decimal precision by using the decimalSeparatorTo property as the decimal separator. | NumberBase
 | formatRounding(value:String, roundType:String):String Formats a number by rounding it. | NumberBase
 | formatRoundingWithPrecision(value:String, roundType:String, precision:int):String Formats a number by rounding it and setting the decimal precision. | NumberBase
 | formatThousands(value:String):String Formats a number by using the thousandsSeparatorTo property as the thousands separator and the decimalSeparatorTo property as the decimal separator. | NumberBase
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | parseNumberString(str:String):String Extracts a number from a formatted String. | NumberBase
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
decimalSeparatorFrom property
public var decimalSeparatorFrom:String

Decimal separator character to use when parsing an input String.

The default value is ".".

decimalSeparatorTo property
public var decimalSeparatorTo:String

Decimal separator character to use when outputting formatted decimal numbers.

The default value is ".".

isValid property
public var isValid:Boolean = false

If true, the format succeeded, otherwise it is false.

thousandsSeparatorFrom property
public var thousandsSeparatorFrom:String

Character to use as the thousands separator in the input String.

The default value is ",".

thousandsSeparatorTo property
public var thousandsSeparatorTo:String

Character to use as the thousands separator in the output String.

The default value is ",".

Constructor detail
NumberBase () constructor
public function NumberBase(decimalSeparatorFrom:String = ".", thousandsSeparatorFrom:String = ",", decimalSeparatorTo:String = ".", thousandsSeparatorTo:String = ",")

Constructor.

Parameters
decimalSeparatorFrom:String (default = ".") — Decimal separator to use when parsing an input String.
thousandsSeparatorFrom:String (default = ",") — Character to use as the thousands separator in the input String.
decimalSeparatorTo:String (default = ".") — Decimal separator character to use when outputting formatted decimal numbers.
thousandsSeparatorTo:String (default = ",") — Character to use as the thousands separator in the output String.
Method detail
formatDecimal () method
public function formatDecimal(value:String):String

Formats a number by replacing the default decimal separator, ".", with the decimal separator specified by decimalSeparatorTo.

Parameters
value:String — The String value of the Number (formatted American style ####.##).

Returns
String — String representation of the input where "." is replaced with the decimal formatting character.
formatNegative () method
public function formatNegative(value:String, useSign:Boolean):String

Formats a negative number with either a minus sign (-) or parentheses ().

Parameters
value:String — Value to be formatted.
useSign:Boolean — If true, use a minus sign (-). If false, use parentheses ().

Returns
String — Formatted number.
formatPrecision () method
public function formatPrecision(value:String, precision:int):String

Formats a number by setting its decimal precision by using the decimalSeparatorTo property as the decimal separator.

Parameters
value:String — Value to be formatted.
precision:int — Number of decimal points to use.

Returns
String — Formatted number.
formatRounding () method
public function formatRounding(value:String, roundType:String):String

Formats a number by rounding it. The possible rounding types are defined by mx.formatters.NumberBaseRoundType.

Parameters
value:String — Value to be rounded.
roundType:String — The type of rounding to perform: NumberBaseRoundType.NONE, NumberBaseRoundType.UP, NumberBaseRoundType.DOWN, or NumberBaseRoundType.NEAREST.

Returns
String — Formatted number.

See also

mx.formatters.NumberBaseRoundType
formatRoundingWithPrecision () method
public function formatRoundingWithPrecision(value:String, roundType:String, precision:int):String

Formats a number by rounding it and setting the decimal precision. The possible rounding types are defined by mx.formatters.NumberBaseRoundType.

Parameters
value:String — Value to be rounded.
roundType:String — The type of rounding to perform: NumberBaseRoundType.NONE, NumberBaseRoundType.UP, NumberBaseRoundType.DOWN, or NumberBaseRoundType.NEAREST.
precision:int — int of decimal places to use.

Returns
String — Formatted number.

See also

mx.formatters.NumberBaseRoundType
formatThousands () method
public function formatThousands(value:String):String

Formats a number by using the thousandsSeparatorTo property as the thousands separator and the decimalSeparatorTo property as the decimal separator.

Parameters
value:String — Value to be formatted.

Returns
String — Formatted number.
parseNumberString () method
public function parseNumberString(str:String):String

Extracts a number from a formatted String. Examines the String from left to right and returns the first number sequence. Ignores thousands separators and includes the decimal and numbers trailing the decimal.

Parameters
str:String — String to parse for the numeric value.

Returns
String — Value, which can be a decimal.


mx.formatters.NumberBaseRoundType (Flex™ 2 Language Reference)

Class NumberBaseRoundType | Properties | Methods | Constants
Package | mx.formatters
Class | public final class NumberBaseRoundType
Inheritance | NumberBaseRoundType Inheritance Object

The NumberBaseRoundType class defines the constant values for formatter properties that specify a type of rounding. For example, you can set the NumberFormatter.rounding property using these constants.

See also

mx.formatters.NumberFormatter
mx.formatters.NumberBase

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DOWN : String = "down" [static] Rounds a number down to an integer that is both closest to, and less than or equal to, the input number. | NumberBaseRoundType
 | NEAREST : String = "nearest" [static] Rounds a number up or down to the nearest integer. | NumberBaseRoundType
 | NONE : String = "none" [static] Perform no rounding. | NumberBaseRoundType
 | UP : String = "up" [static] Rounds a number up to an integer value that is both closest to, and greater than or equal to, the input number. | NumberBaseRoundType
Constant detail
DOWN constant
public static const DOWN:String = "down"

Rounds a number down to an integer that is both closest to, and less than or equal to, the input number.

NEAREST constant
public static const NEAREST:String = "nearest"

Rounds a number up or down to the nearest integer.

NONE constant
public static const NONE:String = "none"

Perform no rounding.

UP constant
public static const UP:String = "up"

Rounds a number up to an integer value that is both closest to, and greater than or equal to, the input number.


mx.formatters.NumberFormatter (Flex™ 2 Language Reference)

Class NumberFormatter | Properties | Methods | Examples
Package | mx.formatters
Class | public class NumberFormatter
Inheritance | NumberFormatter Inheritance Formatter Inheritance Object

The NumberFormatter class formats a valid number by adjusting the decimal rounding and precision, the thousands separator, and the negative sign.

If you use both the rounding and precision properties, rounding is applied first, and then you set the decimal length by using the specified precision value. This lets you round a number and still have a trailing decimal; for example, 303.99 = 304.00.

If an error occurs, an empty String is returned and a String describing the error is saved to the error property. The error property can have one of the following values:

  • "Invalid value" means an invalid numeric value is passed to the format() method. The value should be a valid number in the form of a Number or a String.
  • "Invalid format" means one of the parameters contain an unusable setting.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:NumberFormatter> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:NumberFormatter
    decimalSeparatorFrom="."
    decimalSeparatorTo="."
    precision="-1"
    rounding="none|up|down|nearest"
    thousandsSeparatorFrom=","
    thousandsSeparatorTo=","
    useNegativeSign="true|false"
    useThousandsSeparator="true|false"/>

View the examples.

See also

mx.formatters.NumberBase
mx.formatters.NumberBaseRoundType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | decimalSeparatorFrom : String Decimal separator character to use when parsing an input String. | NumberFormatter
 | decimalSeparatorTo : String Decimal separator character to use when outputting formatted decimal numbers. | NumberFormatter
Inherited | error : String Description saved by the formatter when an error occurs. | Formatter
 | precision : int Number of decimal places to include in the output String. | NumberFormatter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rounding : String Specifies how to round the number. | NumberFormatter
 | thousandsSeparatorFrom : String Character to use as the thousands separator in the input String. | NumberFormatter
 | thousandsSeparatorTo : String Character to use as the thousands separator in the output String. | NumberFormatter
 | useNegativeSign : Boolean If true, format a negative number by preceding it with a minus "-" sign. | NumberFormatter
 | useThousandsSeparator : Boolean If true, split the number into thousands increments by using a separator character. | NumberFormatter
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | defaultInvalidFormatError : String = "Invalid format" Error message for an invalid format string specified to the formatter. | Formatter
Inherited | defaultInvalidValueError : String = "Invalid value" Error message for an invalid value specified to the formatter. | Formatter
Inherited | packageResources : ResourceBundle [static] A ResourceBundle object containing all symbols from formatters.properties. | Formatter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | NumberFormatter() Constructor. | NumberFormatter
 | format(value:Object):String Formats the number as a String. | NumberFormatter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
decimalSeparatorFrom property
public var decimalSeparatorFrom:String

Decimal separator character to use when parsing an input String.

The default value is ".".

decimalSeparatorTo property
public var decimalSeparatorTo:String

Decimal separator character to use when outputting formatted decimal numbers.

The default value is ".".

precision property
public var precision:int

Number of decimal places to include in the output String. You can disable precision by setting it to -1. A value of -1 means do not change the precision. For example, if the input value is 1.453 and rounding is set to NumberBaseRoundType.NONE, return a value of 1.453. If precision is -1 and you have set some form of rounding, return a value based on that rounding type.

The default value is -1.

rounding property
public var rounding:String

Specifies how to round the number.

In ActionScript, you can use the following constants to set this property: NumberBaseRoundType.NONE, NumberBaseRoundType.UP, NumberBaseRoundType.DOWN, or NumberBaseRoundType.NEAREST. Valid MXML values are "down", "nearest", "up", and "none".

The default value is NumberBaseRoundType.NONE.

See also

mx.formatters.NumberBaseRoundType
thousandsSeparatorFrom property
public var thousandsSeparatorFrom:String

Character to use as the thousands separator in the input String.

The default value is ",".

thousandsSeparatorTo property
public var thousandsSeparatorTo:String

Character to use as the thousands separator in the output String.

The default value is ",".

useNegativeSign property
public var useNegativeSign:Boolean

If true, format a negative number by preceding it with a minus "-" sign. If false, format the number surrounded by parentheses, for example (400).

The default value is true.

useThousandsSeparator property
public var useThousandsSeparator:Boolean

If true, split the number into thousands increments by using a separator character.

The default value is true.

Constructor detail
NumberFormatter () constructor
public function NumberFormatter()

Constructor.

Method detail
format () method
public override function format(value:Object):String

Formats the number as a String. If value cannot be formatted, return an empty String and write a description of the error to the error property.

Parameters
value:Object — Value to format.

Returns
String — Formatted String. Empty if an error occurs.
Examples
NumberFormatterExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate NumberFormatter. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

          import mx.events.ValidationResultEvent;
          private var vResult:ValidationResultEvent;

          // Event handler to validate and format input.
          private function Format():void
          {
             vResult = numVal.validate();
             if (vResult.type==ValidationResultEvent.VALID) {

                formattedNumber.text= numberFormatter.format(inputVal.text);
             }

             else {
                formattedNumber.text= "";
             }
          }
      ]]>
    </mx:Script>

    <mx:NumberFormatter id="numberFormatter" precision="4"
        useThousandsSeparator="true" useNegativeSign="true"/>

    <mx:NumberValidator id="numVal" source="{inputVal}" property="text"
        allowNegative="true" domain="real"/>

    <mx:Panel title="NumberFormatter Example" width="75%" height="75%"
            paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter number:">
                <mx:TextInput id="inputVal" text="" width="50%"/>
            </mx:FormItem>

            <mx:FormItem label="Formatted number (precision=4): ">
                <mx:TextInput id="formattedNumber" editable="false" width="50%"/>
            </mx:FormItem>

            <mx:FormItem>
                <mx:Button label="Validate and Format" click="Format();"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.formatters.PhoneFormatter (Flex™ 2 Language Reference)

Class PhoneFormatter | Properties | Methods | Examples
Package | mx.formatters
Class | public class PhoneFormatter
Inheritance | PhoneFormatter Inheritance Formatter Inheritance Object

The PhoneFormatter class formats a valid number into a phone number format, including international configurations.

A shortcut is provided for the United States seven-digit format. If the areaCode property contains a value and you use the seven-digit format string, (###-####), a seven-digit value to format automatically adds the area code to the returned String. The default format for the area code is (###). You can change this using the areaCodeFormat property. You can format the area code any way you want as long as it contains three number placeholders.

If an error occurs, an empty String is returned and a String that describes the error is saved to the error property. The error property can have one of the following values:

  • "Invalid value" means an invalid numeric value is passed to the format() method. The value should be a valid number in the form of a Number or a String, or the value contains a different number of digits than what is specified in the format String.
  • "Invalid format" means any of the characters in the formatString property do not match the allowed characters specified in the validPatternChars property, or the areaCodeFormat property is specified but does not contain exactly three numeric placeholders.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PhoneFormatter> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:PhoneFormatter
    areaCode "-1"
    areaCodeFormat "(###)"
    formatString="(###) ###-####"
    validPatternChars "+()#-. "
  />

View the examples.

See also

mx.formatters.SwitchSymbolFormatter

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | areaCode : int Area code number added to a seven-digit United States format phone number to form a 10-digit phone number. | PhoneFormatter
 | areaCodeFormat : String Default format for the area code when the areacode property is rendered by a seven-digit format. | PhoneFormatter
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | error : String Description saved by the formatter when an error occurs. | Formatter
 | formatString : String String that contains mask characters that represent a specified phone number format. | PhoneFormatter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | validPatternChars : String List of valid characters that can be used in the formatString property. | PhoneFormatter
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | defaultInvalidFormatError : String = "Invalid format" Error message for an invalid format string specified to the formatter. | Formatter
Inherited | defaultInvalidValueError : String = "Invalid value" Error message for an invalid value specified to the formatter. | Formatter
Inherited | packageResources : ResourceBundle [static] A ResourceBundle object containing all symbols from formatters.properties. | Formatter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | PhoneFormatter() Constructor. | PhoneFormatter
 | format(value:Object):String Formats the String as a phone number. | PhoneFormatter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
areaCode property
public var areaCode:int

Area code number added to a seven-digit United States format phone number to form a 10-digit phone number. A value of -1 means do not prepend the area code.

The default value is -1.

areaCodeFormat property
public var areaCodeFormat:String

Default format for the area code when the areacode property is rendered by a seven-digit format.

The default value is "(###) ".

formatString property
public var formatString:String

String that contains mask characters that represent a specified phone number format.

The default value is "(###) ###-####".

validPatternChars property
public var validPatternChars:String

List of valid characters that can be used in the formatString property. This property is used during validation of the formatString property.

The default value is "+()#- .".

Constructor detail
PhoneFormatter () constructor
public function PhoneFormatter()

Constructor.

Method detail
format () method
public override function format(value:Object):String

Formats the String as a phone number. If the value cannot be formatted, return an empty String and write a description of the error to the error property.

Parameters
value:Object — Value to format.

Returns
String — Formatted String. Empty if an error occurs. A description of the error condition is written to the error property.
Examples
PhoneFormatterExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate PhoneFormatter. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.events.ValidationResultEvent;
            private var vResult:ValidationResultEvent;

            // Event handler to validate and format input.
            private function Format():void
            {
                vResult = pnVal.validate();
                if (vResult.type==ValidationResultEvent.VALID) {
                    formattedPhone.text= phoneFormatter.format(phone.text);
                }

                else {
                    formattedPhone.text= "";
                }
            }
        ]]>
    </mx:Script>

    <mx:PhoneFormatter id="phoneFormatter"
        formatString="(###) ###-####" validPatternChars="#-() "/>

    <mx:PhoneNumberValidator id="pnVal" source="{phone}" property="text"
            allowedFormatChars=""/>

    <mx:Panel title="PhoneFormatter Example" width="75%" height="75%"
            paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter a 10-digit phone number:">
                <mx:TextInput id="phone" text="" width="75%"/>
            </mx:FormItem>

            <mx:FormItem label="Formatted phone number: ">
                <mx:TextInput id="formattedPhone" text="" width="75%" editable="false"/>
            </mx:FormItem>

            <mx:FormItem>
                <mx:Button label="Validate and Format" click="Format();"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.formatters.SwitchSymbolFormatter (Flex™ 2 Language Reference)

Class SwitchSymbolFormatter | Properties | Methods | Examples
Package | mx.formatters
Class | public class SwitchSymbolFormatter
Inheritance | SwitchSymbolFormatter Inheritance Object

The SwitchSymbolFormatter class is a utility class that you can use when creating custom formatters. This class performs a substitution by replacing placeholder characters in one String with numbers from a second String.

For example, you specify the following information to the SwitchSymbolFormatter class:

Format String: "The SocialSecurity number is: ###-##-####"

Input String: "123456789"

The SwitchSymbolFormatter class parses the format String and replaces each placeholder character, by default the number character (#), with a number from the input String in the order in which the numbers are specified in the input String. You can define a different placeholder symbol by passing it to the constructor when you instantiate a SwitchSymbolFormatter object.

The output String created by the SwitchSymbolFormatter class from these two Strings is the following:

"The SocialSecurity number is: 123-45-6789"

The pattern can contain any characters as long as they are constant for all values of the numeric portion of the String. However, the value for formatting must be numeric.

The number of digits supplied in the source value must match the number of digits defined in the pattern String. This is the responsibility of the script calling the SwitchSymbolFormatter object.

View the examples.

See also

mx.formatters.PhoneFormatter
Using the SwitchSymbolFormatter class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SwitchSymbolFormatter(numberSymbol:String = "#") Constructor. | SwitchSymbolFormatter
 | formatValue(format:String, source:Object):String Creates a new String by formatting the source String using the format pattern. | SwitchSymbolFormatter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
SwitchSymbolFormatter () constructor
public function SwitchSymbolFormatter(numberSymbol:String = "#")

Constructor.

Parameters
numberSymbol:String (default = "#") — Character to use as the pattern character.
Method detail
formatValue () method
public function formatValue(format:String, source:Object):String

Creates a new String by formatting the source String using the format pattern.

Parameters
format:String — String that defines the user-requested pattern including.
source:Object — Valid number sequence (alpha characters are allowed if needed).

Returns
String
Examples
SwitchSymbolFormatterExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate SwitchSymbolFormatter. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.formatters.SwitchSymbolFormatter;
            import mx.events.ValidationResultEvent;

            private var vResult:ValidationResultEvent;

            // Event handler to validate and format input.
            private function Format():void
            {
                vResult = scVal.validate();

                if (vResult.type==ValidationResultEvent.VALID) {
                    var switcher:SwitchSymbolFormatter=new SwitchSymbolFormatter('#');

                    formattedSCNumber.text =
                        switcher.formatValue("Formatted Social Securty number: ###-##-#### ", scNum.text);
                }

                else {
                    formattedSCNumber.text= "";
                }
            }
        ]]>
    </mx:Script>

    <mx:SocialSecurityValidator id="scVal" source="{scNum}" property="text"/>

    <mx:Panel title="SwitchSymbolFormatter Example" width="75%" height="75%"
            paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Label text="Enter a 9 digit Social Security number with no separator characters:"/>
        <mx:TextInput id="scNum" text="" maxChars="9" width="50%"/>

        <mx:Button label="Validate and Format" click="Format();"/>
        <mx:TextInput id="formattedSCNumber" editable="false" width="75%"/>

    </mx:Panel>
</mx:Application>


mx.formatters.ZipCodeFormatter (Flex™ 2 Language Reference)

Class ZipCodeFormatter | Properties | Methods | Examples
Package | mx.formatters
Class | public class ZipCodeFormatter
Inheritance | ZipCodeFormatter Inheritance Formatter Inheritance Object

The ZipCodeFormatter class formats a valid number into one of the following formats, based on a user-supplied formatString property.
  • #####-####
  • ##### ####
  • #####
  • ### ### (Canadian)

A six-digit number must be supplied for a six-digit mask. If you use a five-digit or a nine-digit mask, you can use either a five-digit or a nine-digit number for formatting.

If an error occurs, an empty String is returned and a String that describes the error is saved to the error property. The error property can have one of the following values:

  • "Invalid value" means an invalid numeric value is passed to the format() method. The value should be a valid number in the form of a Number or a String, except for Canadian postal code, which allows alphanumeric values, or the number of digits does not match the allowed digits from the formatString property.
  • "Invalid format" means any of the characters in the formatString property do not match the allowed characters specified in the validFormatChars property, or the number of numeric placeholders does not equal 9, 5, or 6.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ZipCodeFormatter> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:ZipCodeFormatter
    formatString="#####|#####-####|### ###"
  />

View the examples.

See also

mx.formatters.SwitchSymbolFormatter

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | error : String Description saved by the formatter when an error occurs. | Formatter
 | formatString : String The mask pattern. | ZipCodeFormatter
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | defaultInvalidFormatError : String = "Invalid format" Error message for an invalid format string specified to the formatter. | Formatter
Inherited | defaultInvalidValueError : String = "Invalid value" Error message for an invalid value specified to the formatter. | Formatter
Inherited | packageResources : ResourceBundle [static] A ResourceBundle object containing all symbols from formatters.properties. | Formatter
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ZipCodeFormatter() Constructor. | ZipCodeFormatter
 | format(value:Object):String Formats the String by using the specified format. | ZipCodeFormatter
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
formatString property
formatString:String [read-write]

The mask pattern. Possible values are "#####-####", "##### ####", "#####", "###-###" and "### ###".

The default value is "#####".

Implementation
    public function get formatString():String
    public function set formatString(value:String):void
Constructor detail
ZipCodeFormatter () constructor
public function ZipCodeFormatter()

Constructor.

Method detail
format () method
public override function format(value:Object):String

Formats the String by using the specified format. If the value cannot be formatted, return an empty String and write a description of the error to the error property.

Parameters
value:Object — Value to format.

Returns
String — Formatted String. Empty if an error occurs. A description of the error condition is written to the error property.
Examples
ZipCodeFormatterExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate ZipCodeFormatter. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            import mx.events.ValidationResultEvent;
            private var vResult:ValidationResultEvent;

            // Event handler to validate and format input.
            private function Format():void
            {
                vResult = zcVal.validate();

                if (vResult.type==ValidationResultEvent.VALID) {
                    formattedZipcode.text= zipFormatter.format(zip.text);
                }

                else {
                    formattedZipcode.text= "";
                }
            }
        ]]>
    </mx:Script>

    <mx:ZipCodeFormatter id="zipFormatter" formatString="#####-####"/>

    <mx:ZipCodeValidator id="zcVal" source="{zip}" property="text" allowedFormatChars=""/>

    <mx:Panel title="ZipCodeFormatter Example" width="75%" height="75%"
            paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form width="100%">
            <mx:FormItem label="Enter a 5 or 9 digit U.S. ZIP code:" width="100%">
                <mx:TextInput id="zip" text=""/>
            </mx:FormItem>

            <mx:FormItem label="Formatted ZIP code: " width="100%">
                <mx:TextInput id="formattedZipcode" text="" editable="false"/>
            </mx:FormItem>

            <mx:FormItem>
                <mx:Button label="Validate and Format" click="Format();"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.graphics Summary (Flex™ 2 Language Reference)

Package mx.graphics | Interfaces | Classes

The mx.graphics package contains drawing classes.

Interfaces
Interface | Description
IFill | Defines the interface that classes that perform a fill must implement.
IStroke | Defines the interface that classes that define a line must implement.
Classes
Class | Description
BitmapFill | Defines a set of values used to fill an area on screen with a bitmap or other DisplayObject.
GradientEntry | The GradientEntry class defines the objects that control a transition as part of a gradient fill.
LinearGradient | The LinearGradient class lets you specify the fill of a graphical element, where a gradient specifies a gradual color transition in the fill color.
LinearGradientStroke | The LinearGradientStroke class lets you specify a gradient filled stroke.
RadialGradient | The RadialGradient class lets you specify a gradual color transition in the fill color.
RectangularDropShadow | Drop shadows are typically created using the DropShadowFilter class.
RoundedRectangle | RoundedRectangle represents a Rectangle with curved corners
SolidColor | Defines a representation for a color, including a color and an alpha value.
Stroke | The Stroke class defines the properties for a line.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.graphics.BitmapFill (Flex™ 2 Language Reference)

Class BitmapFill | Properties | Methods
Package | mx.graphics
Class | public class BitmapFill
Inheritance | BitmapFill Inheritance Object
Implements | IFill

Defines a set of values used to fill an area on screen with a bitmap or other DisplayObject.

See also

mx.graphics.IFill
flash.display.Bitmap
flash.display.BitmapData
flash.display.DisplayObject

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | offsetX : Number = 0 How far the bitmap is horizontally offset from the origin. | BitmapFill
 | offsetY : Number = 0 How far the bitmap is vertically offset from the origin. | BitmapFill
 | originX : Number = 0 The horizontal origin for the bitmap fill. | BitmapFill
 | originY : Number = 0 The vertical origin for the bitmap fill. | BitmapFill
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | repeat : Boolean = true Whether the bitmap is repeated to fill the area. | BitmapFill
 | rotation : Number = 0 The number of degrees to rotate the bitmap. | BitmapFill
 | scaleX : Number = 1 The percent to horizontally scale the bitmap when filling, from 0 to 1. | BitmapFill
 | scaleY : Number = 1 The percent to vertically scale the bitmap when filling, from 0 to 1. | BitmapFill
 | smooth : Boolean = false A flag indicating whether to smooth the bitmap data when filling with it. | BitmapFill
 | source : Object The source used for the bitmap fill. | BitmapFill
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | BitmapFill() Constructor. | BitmapFill
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
offsetX property
public var offsetX:Number = 0

How far the bitmap is horizontally offset from the origin. This adjustment is performed after rotation and scaling.

offsetY property
public var offsetY:Number = 0

How far the bitmap is vertically offset from the origin. This adjustment is performed after rotation and scaling.

originX property
public var originX:Number = 0

The horizontal origin for the bitmap fill. The bitmap fill is offset so that this point appears at the origin. Scaling and rotation of the bitmap are performed around this point.

originY property
public var originY:Number = 0

The vertical origin for the bitmap fill. The bitmap fill is offset so that this point appears at the origin. Scaling and rotation of the bitmap are performed around this point.

repeat property
public var repeat:Boolean = true

Whether the bitmap is repeated to fill the area. Set to true to cause the fill to tile outward to the edges of the filled region. Set to false to end the fill at the edge of the region.

rotation property
public var rotation:Number = 0

The number of degrees to rotate the bitmap. Valid values range from 0 to 360. The default value is 0.

scaleX property
public var scaleX:Number = 1

The percent to horizontally scale the bitmap when filling, from 0 to 1. If 1, the bitmap is filled at its natural size. The default value is 1.

scaleY property
public var scaleY:Number = 1

The percent to vertically scale the bitmap when filling, from 0 to 1. If 1, the bitmap is filled at its natural size. The default value is 1.

smooth property
public var smooth:Boolean = false

A flag indicating whether to smooth the bitmap data when filling with it.

source property
source:Object [read-write]

The source used for the bitmap fill. The fill can render from various graphical sources, including the following:

  • A Bitmap or BitmapData instance.
  • A class representing a subclass of DisplayObject. The BitmapFill instantiates the class and creates a bitmap rendering of it.
  • An instance of a DisplayObject. The BitmapFill copies it into a Bitmap for filling.
  • The name of a subclass of DisplayObject. The BitmapFill loads the class, instantiates it, and creates a bitmap rendering of it.

Implementation
    public function get source():Object
    public function set source(value:Object):void
Constructor detail
BitmapFill () constructor
public function BitmapFill()

Constructor.


mx.graphics.GradientEntry (Flex™ 2 Language Reference)

Class GradientEntry | Properties | Methods
Package | mx.graphics
Class | public class GradientEntry
Inheritance | GradientEntry Inheritance Object

The GradientEntry class defines the objects that control a transition as part of a gradient fill. You use this class with the LinearGradient and RadialGradient classes to define a gradient fill.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:GradientEntry> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:GradientEntry
    Properties
    alpha="1.0"
    color="0x000000"
    ratio="-1"
  />

See also

mx.graphics.LinearGradient
mx.graphics.RadialGradient
Using a gradient fill with chart controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number = 1 The transparency of a gradient fill. | GradientEntry
 | color : uint The color value for a gradient fill. | GradientEntry
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | ratio : Number Where in the graphical element, as a percentage from 0 to 1, Flex starts the transition to the associated color. | GradientEntry
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | GradientEntry(color:uint = 0, ratio:Number = -1, alpha:Number = 1) Constructor. | GradientEntry
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
public var alpha:Number = 1

The transparency of a gradient fill. Possible values are 0.0 (invisible) through 1.0 (opaque).

The default value is 1.

color property
public var color:uint

The color value for a gradient fill.

ratio property
public var ratio:Number

Where in the graphical element, as a percentage from 0 to 1, Flex starts the transition to the associated color. For example, a ratio of .33 means Flex begins the transition to that color 33% of the way through the graphical element.

Constructor detail
GradientEntry () constructor
public function GradientEntry(color:uint = 0, ratio:Number = -1, alpha:Number = 1)

Constructor.

Parameters
color:uint (default = 0) — The color for this gradient entry.
ratio:Number (default = -1) — Where in the graphical element to start the transition to the associated color. Flex uniformly spaces any GradientEntries with missing ratio values.
alpha:Number (default = 1) — The alpha value for this entry in the gradient. This parameter is optional. The default value is 1.


mx.graphics.IFill (Flex™ 2 Language Reference)

Interface IFill | Methods
Package | mx.graphics
Interface | public interface IFill
Implementors | BitmapFill, LinearGradient, RadialGradient, SolidColor

Defines the interface that classes that perform a fill must implement.

See also

mx.graphics.LinearGradient
mx.graphics.RadialGradient

Public Methods
Method |  | Defined by
 | begin(target:Graphics, rc:Rectangle):void Starts the fill. | IFill
 | end(target:Graphics):void Ends the fill. | IFill
Method detail
begin () method
public function begin(target:Graphics, rc:Rectangle):void

Starts the fill.

Parameters
target:Graphics — The target Graphics object that is being filled.
rc:Rectangle — The Rectangle object that defines the size of the fill inside the target. If the dimensions of the Rectangle are larger than the dimensions of the target, the fill is clipped. If the dimensions of the Rectangle are smaller than the dimensions of the target, the fill expands to fill the entire target.
end () method
public function end(target:Graphics):void

Ends the fill.

Parameters
target:Graphics — The Graphics object that is being filled.


mx.graphics.IStroke (Flex™ 2 Language Reference)

Interface IStroke | Properties | Methods
Package | mx.graphics
Interface | public interface IStroke
Implementors | LinearGradientStroke, Stroke

Defines the interface that classes that define a line must implement.

Public Properties
Property |  | Defined by
 | weight : Number The line weight, in pixels. | IStroke
Public Methods
Method |  | Defined by
 | apply(g:Graphics):void Applies the properties to the specified Graphics object. | IStroke
Property detail
weight property
weight:Number [read-write]

The line weight, in pixels. For many chart lines, the default value is 1 pixel.

Implementation
    public function get weight():Number
    public function set weight(value:Number):void
Method detail
apply () method
public function apply(g:Graphics):void

Applies the properties to the specified Graphics object.

Parameters
g:Graphics — The Graphics object to apply the properties to.


mx.graphics.LinearGradient (Flex™ 2 Language Reference)

Class LinearGradient | Properties | Methods
Package | mx.graphics
Class | public class LinearGradient
Implements | IFill

The LinearGradient class lets you specify the fill of a graphical element, where a gradient specifies a gradual color transition in the fill color. You add a series of GradientEntry classes to the LinearGradient object's entries Array to define the colors that make up the gradient fill.

In MXML, you define a LinearGradient by adding a series of GradientEntry objects, as the following example shows:

  <mx:fill>
   <mx:LinearGradient>
    <mx:entries>
     <mx:GradientEntry color="0xC5C551" ratio="0" alpha=".5"/>
     <mx:GradientEntry color="0xFEFE24" ratio=".33" alpha=".5"/>
     <mx:GradientEntry color="0xECEC21" ratio=".66" alpha=".5"/>
    </mx:entries>
   </mx:LinearGradient>
  </mx:fill>

You can also define a LinearGradient as a fill for any graphic element in ActionScript, as the following example shows:

  <?xml version="1.0"?>
  <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" creationComplete="init()">
   <mx:Script>
   import flash.display.Graphics;
   import flash.geom.Rectangle;
   import mx.graphics.GradientEntry;
   import mx.graphics.LinearGradient;

   private function init():void {
    var w:Number = 200;
    var h:Number = 200;

    var s:Sprite = new Sprite();
    // Add the new Sprite to the display list.
    rawChildren.addChild(s);

    var g:Graphics = s.graphics;
    g.lineStyle(1,0x33CCFF,1.0);

    var fill:LinearGradient = new LinearGradient();

    var g1:GradientEntry = new GradientEntry(0xFFCC66,0,.5);
    var g2:GradientEntry = new GradientEntry(0x000000,.33,.5);
    var g3:GradientEntry = new GradientEntry(0x99FF33,.66,.5);

     fill.entries = [g1,g2,g3];
    fill.angle = 240;

     // Draw a box and fill it with the LinearGradient.
    g.moveTo(0,0);
    fill.begin(g,new Rectangle(0,0,w,h));
    g.lineTo(w,0);
    g.lineTo(w,h);
    g.lineTo(0,h);
    g.lineTo(0,0);
    fill.end(g);
   }
   </mx:Script>
  </mx:Application>

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:LinearGradient> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:LinearGradient
    Properties
    angle="0"
  />

See also

mx.graphics.GradientEntry
mx.graphics.RadialGradient
mx.graphics.IFill
Using a gradient fill with chart controls

Public Properties
Property |  | Defined by
 | angle : Number Controls the transition direction. | LinearGradient
Public Methods
Method |  | Defined by
 | LinearGradient() Constructor. | LinearGradient
 | begin(target:Graphics, rc:Rectangle):void Starts the fill. | LinearGradient
 | end(target:Graphics):void Ends the fill. | LinearGradient
Property detail
angle property
angle:Number [read-write]

Controls the transition direction. By default, the LinearGradient class defines a transition from left to right across the graphical element. A value of 180 causes the transition to occur from right to left.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void
Constructor detail
LinearGradient () constructor
public function LinearGradient()

Constructor.

Method detail
begin () method
public function begin(target:Graphics, rc:Rectangle):void

Starts the fill.

Parameters
target:Graphics — The target Graphics object that is being filled.
rc:Rectangle — The Rectangle object that defines the size of the fill inside the target. If the dimensions of the Rectangle are larger than the dimensions of the target, the fill is clipped. If the dimensions of the Rectangle are smaller than the dimensions of the target, the fill expands to fill the entire target.
end () method
public function end(target:Graphics):void

Ends the fill.

Parameters
target:Graphics — The Graphics object that is being filled.


mx.graphics.LinearGradientStroke (Flex™ 2 Language Reference)

Class LinearGradientStroke | Properties | Methods
Package | mx.graphics
Class | public class LinearGradientStroke
Implements | IStroke

The LinearGradientStroke class lets you specify a gradient filled stroke. You use the LinearGradientStroke class, along with the GradientEntry class, to define a gradient stroke.

See also

mx.graphics.Stroke
mx.graphics.GradientEntry
mx.graphics.RadialGradient
flash.display.Graphics

Public Properties
Property |  | Defined by
 | angle : Number By default, the LinearGradientStroke defines a transition from left to right across the control. | LinearGradientStroke
 | caps : String = "null" A value from the CapsStyle class that specifies the type of caps at the end of lines. | LinearGradientStroke
 | interpolationMethod : String = "rgb" A value from the InterpolationMethod class that specifies which value to use. | LinearGradientStroke
 | joints : String = "null" A value from the JointStyle class that specifies the type of joint appearance used at angles. | LinearGradientStroke
 | miterLimit : Number = 0 A number that indicates the limit at which a miter is cut off. | LinearGradientStroke
 | pixelHinting : Boolean = false A Boolean value that specifies whether to hint strokes to full pixels. | LinearGradientStroke
 | scaleMode : String = "normal" A value from the LineScaleMode class that specifies which scale mode to use. | LinearGradientStroke
 | spreadMethod : String = "pad" A value from the SpreadMethod class that specifies which spread method to use. | LinearGradientStroke
 | weight : Number The line weight, in pixels. | LinearGradientStroke
Public Methods
Method |  | Defined by
 | LinearGradientStroke(weight:Number = 0, pixelHinting:Boolean = false, scaleMode:String = "normal", caps:String = null, joints:String = null, miterLimit:Number = 0) Constructor. | LinearGradientStroke
 | apply(g:Graphics):void Applies the properties to the specified Graphics object. | LinearGradientStroke
Property detail
angle property
angle:Number [read-write]

By default, the LinearGradientStroke defines a transition from left to right across the control. Use the angle property to control the transition direction. For example, a value of 180 causes the transition to occur from right to left, rather than from left to right.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void
caps property
public var caps:String = "null"

A value from the CapsStyle class that specifies the type of caps at the end of lines. Valid values are: CapsStyle.NONE, CapsStyle.ROUND, and CapsStyle.SQUARE.

The default value is CapsStyle.ROUND.

interpolationMethod property
public var interpolationMethod:String = "rgb"

A value from the InterpolationMethod class that specifies which value to use. Valid values are InterpolationMethod.LINEAR_RGB and InterpolationMethod.RGB.

The default value is InterpolationMethod.RGB.

joints property
public var joints:String = "null"

A value from the JointStyle class that specifies the type of joint appearance used at angles. Valid values are: JointStyle.BEVEL, JointStyle.MITER, and JointStyle.ROUND.

The default value is JointStyle.ROUND.

miterLimit property
public var miterLimit:Number = 0

A number that indicates the limit at which a miter is cut off. Valid values range from 0 to 255 (and values outside of that range are rounded to 0 or 255). This value is only used if the jointStyle is set to miter. The miterLimit value represents the length that a miter can extend beyond the point at which the lines meet to form a joint. The value expresses a factor of the line thickness. For example, with a miterLimit factor of 2.5 and a thickness of 10 pixels, the miter is cut off at 25 pixels.

The default value is 0.

pixelHinting property
public var pixelHinting:Boolean = false

A Boolean value that specifies whether to hint strokes to full pixels. This affects both the position of anchors of a curve and the line stroke size itself. With pixelHinting set to true, Flash Player hints line widths to full pixel widths. With pixelHinting set to false, disjoints can appear for curves and straight lines.

The default value is false.

scaleMode property
public var scaleMode:String = "normal"

A value from the LineScaleMode class that specifies which scale mode to use. Value valids are:

  • LineScaleMode.NORMAL—Always scale the line thickness when the object is scaled (the default).
  • LineScaleMode.NONE—Never scale the line thickness.
  • LineScaleMode.VERTICAL—Do not scale the line thickness if the object is scaled vertically only.
  • LineScaleMode.HORIZONTAL—Do not scale the line thickness if the object is scaled horizontally only.

spreadMethod property
public var spreadMethod:String = "pad"

A value from the SpreadMethod class that specifies which spread method to use. Value values are SpreadMethod.PAD, SpreadMethod.REFLECT, and SpreadMethod.REPEAT.

The default value is SpreadMethod.PAD.

weight property
weight:Number [read-write]

The line weight, in pixels. For many chart lines, the default value is 1 pixel.

Implementation
    public function get weight():Number
    public function set weight(value:Number):void
Constructor detail
LinearGradientStroke () constructor
public function LinearGradientStroke(weight:Number = 0, pixelHinting:Boolean = false, scaleMode:String = "normal", caps:String = null, joints:String = null, miterLimit:Number = 0)

Constructor.

Parameters
weight:Number (default = 0) — Specifies the line weight, in pixels.
pixelHinting:Boolean (default = false) — A Boolean value that specifies whether to hint strokes to full pixels. This affects both the position of anchors of a curve and the line stroke size itself. With pixelHinting set to true, Flash Player hints line widths to full pixel widths. With pixelHinting set to false, disjoints can appear for curves and straight lines.

If a value is not supplied, the line does not use pixel hinting.
scaleMode:String (default = "normal") — A value from the LineScaleMode class that specifies which scale mode to use. Possible values are horizontal, none, normal and vertical.
caps:String (default = null) — A value from the CapsStyle class that specifies the type of caps at the end of lines. Valid values are: CapsStyle.NONE, CapsStyle.ROUND, and CapsStyle.SQUARE. The default value is CapsStyle.ROUND.
joints:String (default = null) — A value from the JointStyle class that specifies the type of joint appearance used at angles. Valid values are: JointStyle.BEVEL, JointStyle.MITER, and JointStyle.ROUND. The default value is JoinStyle.ROUND.
miterLimit:Number (default = 0) — Optional. A number that indicates the limit at which a miter is cut off. Valid values range from 1 to 255 (and values outside of that range are rounded to 1 or 255). This value is only used if the jointStyle property is set to miter. The miterLimit value represents the length that a miter can extend beyond the point at which the lines meet to form a joint. The value expresses a factor of the line thickness. For example, with a miterLimit factor of 2.5 and a thickness of 10 pixels, the miter is cut off at 25 pixels.
Method detail
apply () method
public function apply(g:Graphics):void

Applies the properties to the specified Graphics object.

Parameters
g:Graphics — The Graphics object to which the LinearGradientStroke styles are applied.


mx.graphics.RadialGradient (Flex™ 2 Language Reference)

Class RadialGradient | Properties | Methods
Package | mx.graphics
Class | public class RadialGradient
Implements | IFill

The RadialGradient class lets you specify a gradual color transition in the fill color. A radial gradient defines a fill pattern that radiates out from the center of a graphical element. You add a series of GradientEntry classes to the RadialGradient object's entries Array to define the colors that make up the gradient fill.

In MXML, you define a LinearGradient by adding a series of GradientEntry objects, as the following example shows:

  <mx:fill>
   <mx:RadialGradient>
    <mx:entries>
     <mx:GradientEntry color="0xC5C551" ratio="0" alpha=".5"/>
     <mx:GradientEntry color="0xFEFE24" ratio=".33" alpha=".5"/>
     <mx:GradientEntry color="0xECEC21" ratio=".66" alpha=".5"/>
    </mx:entries>
   </mx:RadialGradient>
  </mx:fill>

You can also define a LinearGradient as a fill for any graphic element in ActionScript, as the following example shows:

  <?xml version="1.0"?>
  <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" creationComplete="init()">
   <mx:Script>
   import flash.display.Graphics;
   import flash.geom.Rectangle;
   import mx.graphics.GradientEntry;
   import mx.graphics.RadialGradient;

   private function init():void {
    var w:Number = 200;
    var h:Number = 200;

    var s:Sprite = new Sprite();
    // Add the new Sprite to the display list.
    rawChildren.addChild(s);

    var g:Graphics = s.graphics;
    g.lineStyle(1,0x33CCFF,1.0);

    var fill:RadialGradient = new RadialGradient();

    var g1:GradientEntry = new GradientEntry(0xFFCC66,0,.5);
    var g2:GradientEntry = new GradientEntry(0x000000,.33,.5);
    var g3:GradientEntry = new GradientEntry(0x99FF33,.66,.5);

     fill.entries = [g1,g2,g3];

    // Set focal point to upper left corner.
    fill.angle = 45;
    fill.focalPointRatio = -.8;

     // Draw a box and fill it with the LinearGradient.
    g.moveTo(0,0);
    fill.begin(g,new Rectangle(0,0,w,h));
    g.lineTo(w,0);
    g.lineTo(w,h);
    g.lineTo(0,h);
    g.lineTo(0,0);
    fill.end(g);
   }
   </mx:Script>
  </mx:Application>

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:RadialGradient> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:RadialGradient
    Properties
    angle="0"
    foculPointRatio="0"
  />

See also

mx.graphics.GradientEntry
mx.graphics.LinearGradient
mx.graphics.IFill
Using a gradient fill with chart controls

Public Properties
Property |  | Defined by
 | angle : Number Sets the location of the start of the radial fill. | RadialGradient
 | focalPointRatio : Number = 0 Sets the location of the start of the radial fill. | RadialGradient
Public Methods
Method |  | Defined by
 | RadialGradient() Constructor. | RadialGradient
 | begin(target:Graphics, rc:Rectangle):void Starts the fill. | RadialGradient
 | end(target:Graphics):void Ends the fill. | RadialGradient
Property detail
angle property
angle:Number [read-write]

Sets the location of the start of the radial fill. Use the focalPointRatio property in conjunction with this property to adjust the location and distance from the center point of the bounding Rectangle to the focal point. Valid values are from 0 to 360.

The default value is 0.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void
focalPointRatio property
public var focalPointRatio:Number = 0

Sets the location of the start of the radial fill. Valid values are from -1 to 1. A value of -1 sets the focal point (or, start of the gradient fill) on the left of the bounding Rectangle. A value of 1 sets the focal point on the right of the bounding Rectangle.

If you use this property in conjunction with the angle property, this value specifies the degree of distance from the center that the focal point occurs. For example, with an angle of 45 and focalPointRatio of .25, the focal point is slightly lower and to the right of center. If you set focalPointRatio to 1, the focal point is all the way to the bottom right corner of the bounding Rectangle.

The default value is 0, which sets the focal point in the middle of the bounding Rectangle.

Constructor detail
RadialGradient () constructor
public function RadialGradient()

Constructor.

Method detail
begin () method
public function begin(target:Graphics, rc:Rectangle):void

Starts the fill.

Parameters
target:Graphics — The target Graphics object that is being filled.
rc:Rectangle — The Rectangle object that defines the size of the fill inside the target. If the dimensions of the Rectangle are larger than the dimensions of the target, the fill is clipped. If the dimensions of the Rectangle are smaller than the dimensions of the target, the fill expands to fill the entire target.
end () method
public function end(target:Graphics):void

Ends the fill.

Parameters
target:Graphics — The Graphics object that is being filled.


mx.graphics.RectangularDropShadow (Flex™ 2 Language Reference)

Class RectangularDropShadow | Properties | Methods
Package | mx.graphics
Class | public class RectangularDropShadow
Inheritance | RectangularDropShadow Inheritance Object

Drop shadows are typically created using the DropShadowFilter class. However, the DropShadowFilter, like all bitmap filters, can be computationally expensive. If the DropShadowFilter is applied to a DisplayObject, then the drop shadow is recalculated whenever the appearance of the object changes. If the DisplayObject is animated (using a Resize effect, for example), then the presence of drop shadows hurts the animation refresh rate.

This class optimizes drop shadows for a common case. If you are applying a drop shadow to a rectangularly-shaped object whose edges fall on pixel boundaries, then this class should be used instead of using the DropShadowFilter directly.

This class accepts the first four parameters that are passed to DropShadowFilter: alpha, angle, color, and distance. In addition, this class accepts the corner radii for each of the four corners of the rectangularly-shaped object that is casting a shadow.

Once those 8 values have been set, this class pre-computes the drop shadow in an offscreen Bitmap. When the drawShadow() method is called, pieces of the precomputed drop shadow are copied onto the passed-in Graphics object.

See also

flash.filters.DropShadowFilter
flash.display.DisplayObject

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number The alpha transparency value for the shadow color. | RectangularDropShadow
 | angle : Number The angle of the shadow. | RectangularDropShadow
 | blRadius : Number The corner radius of the bottom left corner of the rounded rectangle that is casting the shadow. | RectangularDropShadow
 | brRadius : Number The corner radius of the bottom right corner of the rounded rectangle that is casting the shadow. | RectangularDropShadow
 | color : int The color of the shadow. | RectangularDropShadow
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | distance : Number The offset distance for the shadow, in pixels. | RectangularDropShadow
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | tlRadius : Number The corner radius of the top left corner of the rounded rectangle that is casting the shadow. | RectangularDropShadow
 | trRadius : Number The corner radius of the top right corner of the rounded rectangle that is casting the shadow. | RectangularDropShadow
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RectangularDropShadow() Constructor. | RectangularDropShadow
 | drawShadow(g:Graphics, x:Number, y:Number, width:Number, height:Number):void Renders the shadow on the screen. | RectangularDropShadow
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
alpha:Number [read-write]

The alpha transparency value for the shadow color. Valid values are 0.0 to 1.0. For example, .25 sets a transparency value of 25%. The default value is 1.0.

Implementation
    public function get alpha():Number
    public function set alpha(value:Number):void
angle property
angle:Number [read-write]

The angle of the shadow. Valid values are 0 to 360 degrees (floating point). The default value is 45.

Implementation
    public function get angle():Number
    public function set angle(value:Number):void
blRadius property
blRadius:Number [read-write]

The corner radius of the bottom left corner of the rounded rectangle that is casting the shadow. May be zero for non-rounded rectangles.

Implementation
    public function get blRadius():Number
    public function set blRadius(value:Number):void
brRadius property
brRadius:Number [read-write]

The corner radius of the bottom right corner of the rounded rectangle that is casting the shadow. May be zero for non-rounded rectangles.

Implementation
    public function get brRadius():Number
    public function set brRadius(value:Number):void
color property
color:int [read-write]

The color of the shadow. Valid values are in hexadecimal format 0xRRGGBB. The default value is 0x000000.

Implementation
    public function get color():int
    public function set color(value:int):void
distance property
distance:Number [read-write]

The offset distance for the shadow, in pixels. The default value is 4.0 (floating point).

Implementation
    public function get distance():Number
    public function set distance(value:Number):void
tlRadius property
tlRadius:Number [read-write]

The corner radius of the top left corner of the rounded rectangle that is casting the shadow. May be zero for non-rounded rectangles.

Implementation
    public function get tlRadius():Number
    public function set tlRadius(value:Number):void
trRadius property
trRadius:Number [read-write]

The corner radius of the top right corner of the rounded rectangle that is casting the shadow. May be zero for non-rounded rectangles.

Implementation
    public function get trRadius():Number
    public function set trRadius(value:Number):void
Constructor detail
RectangularDropShadow () constructor
public function RectangularDropShadow()

Constructor.

Method detail
drawShadow () method
public function drawShadow(g:Graphics, x:Number, y:Number, width:Number, height:Number):void

Renders the shadow on the screen.

Parameters
g:Graphics — The Graphics object on which to draw the shadow.
x:Number — The horizontal offset of the drop shadow, based on the Graphics object's position.
y:Number — The vertical offset of the drop shadow, based on the Graphics object's position.
width:Number — The width of the shadow, in pixels.
height:Number — The height of the shadow, in pixels.


mx.graphics.RoundedRectangle (Flex™ 2 Language Reference)

Class RoundedRectangle | Properties | Methods
Package | mx.graphics
Class | public class RoundedRectangle
Inheritance | RoundedRectangle Inheritance Rectangle Inheritance Object

RoundedRectangle represents a Rectangle with curved corners

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bottom : Number The sum of the y and height properties. | Rectangle
Inherited | bottomRight : Point The location of the Rectangle object's bottom-right corner, determined by the values of the right and bottom properties. | Rectangle
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | cornerRadius : Number = 0 The radius of each corner (in pixels). | RoundedRectangle
Inherited | height : Number The height of the rectangle, in pixels. | Rectangle
Inherited | left : Number The x coordinate of the top-left corner of the rectangle. | Rectangle
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | right : Number The sum of the x and width properties. | Rectangle
Inherited | size : Point The size of the Rectangle object, expressed as a Point object with the values of the width and height properties. | Rectangle
Inherited | top : Number The y coordinate of the top-left corner of the rectangle. | Rectangle
Inherited | topLeft : Point The location of the Rectangle object's top-left corner, determined by the x and y coordinates of the point. | Rectangle
Inherited | width : Number The width of the rectangle, in pixels. | Rectangle
Inherited | x : Number The x coordinate of the top-left corner of the rectangle. | Rectangle
Inherited | y : Number The y coordinate of the top-left corner of the rectangle. | Rectangle
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RoundedRectangle(x:Number = 0, y:Number = 0, width:Number = 0, height:Number = 0, cornerRadius:Number = 0) Constructor. | RoundedRectangle
Inherited | clone():Rectangle Returns a new Rectangle object with the same values for the x, y, width, and height properties as the original Rectangle object. | Rectangle
Inherited | contains(x:Number, y:Number):Boolean Determines whether the specified point is contained within the rectangular region defined by this Rectangle object. | Rectangle
Inherited | containsPoint(point:Point):Boolean Determines whether the specified point is contained within the rectangular region defined by this Rectangle object. | Rectangle
Inherited | containsRect(rect:Rectangle):Boolean Determines whether the Rectangle object specified by the rect parameter is contained within this Rectangle object. | Rectangle
Inherited | equals(toCompare:Rectangle):Boolean Determines whether the object specified in the toCompare parameter is equal to this Rectangle object. | Rectangle
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | inflate(dx:Number, dy:Number):void Increases the size of the Rectangle object by the specified amounts, in pixels. | Rectangle
Inherited | inflatePoint(point:Point):void Increases the size of the Rectangle object. | Rectangle
Inherited | intersection(toIntersect:Rectangle):Rectangle If the Rectangle object specified in the toIntersect parameter intersects with this Rectangle object, returns the area of intersection as a Rectangle object. | Rectangle
Inherited | intersects(toIntersect:Rectangle):Boolean Determines whether the object specified in the toIntersect parameter intersects with this Rectangle object. | Rectangle
Inherited | isEmpty():Boolean Determines whether or not this Rectangle object is empty. | Rectangle
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | offset(dx:Number, dy:Number):void Adjusts the location of the Rectangle object, as determined by its top-left corner, by the specified amounts. | Rectangle
Inherited | offsetPoint(point:Point):void Adjusts the location of the Rectangle object using a Point object as a parameter. | Rectangle
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setEmpty():void Sets all of the Rectangle object's properties to 0. | Rectangle
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Builds and returns a string that lists the horizontal and vertical positions and the width and height of the Rectangle object. | Rectangle
Inherited | union(toUnion:Rectangle):Rectangle Adds two rectangles together to create a new Rectangle object, by filling in the horizontal and vertical space between the two rectangles. | Rectangle
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
cornerRadius property
public var cornerRadius:Number = 0

The radius of each corner (in pixels). Default value is 0.

Constructor detail
RoundedRectangle () constructor
public function RoundedRectangle(x:Number = 0, y:Number = 0, width:Number = 0, height:Number = 0, cornerRadius:Number = 0)

Constructor.

Parameters
x:Number (default = 0)
y:Number (default = 0)
width:Number (default = 0)
height:Number (default = 0)
cornerRadius:Number (default = 0)


mx.graphics.SolidColor (Flex™ 2 Language Reference)

Class SolidColor | Properties | Methods
Package | mx.graphics
Class | public class SolidColor
Inheritance | SolidColor Inheritance Object
Implements | IFill

Defines a representation for a color, including a color and an alpha value.

Default MXML Property color

See also

mx.graphics.IFill

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number = 1.0 The transparency of a color. | SolidColor
 | color : uint = 0x000000 A color value. | SolidColor
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SolidColor(color:uint = 0x000000, alpha:Number = 1.0) Constructor. | SolidColor
 | begin(target:Graphics, rc:Rectangle):void Starts the fill. | SolidColor
 | end(target:Graphics):void Ends the fill. | SolidColor
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
public var alpha:Number = 1.0

The transparency of a color. Possible values are 0.0 (invisible) through 1.0 (opaque).

The default value is 1.0.

color property
public var color:uint = 0x000000

A color value.

Constructor detail
SolidColor () constructor
public function SolidColor(color:uint = 0x000000, alpha:Number = 1.0)

Constructor.

Parameters
color:uint (default = 0x000000) — Specifies the color. The default value is 0x000000 (black).
alpha:Number (default = 1.0) — Specifies the level of transparency. Valid values range from 0.0 (completely transparent) to 1.0 (completely opaque). The default value is 1.0.
Method detail
begin () method
public function begin(target:Graphics, rc:Rectangle):void

Starts the fill.

Parameters
target:Graphics — The target Graphics object that is being filled.
rc:Rectangle — The Rectangle object that defines the size of the fill inside the target. If the dimensions of the Rectangle are larger than the dimensions of the target, the fill is clipped. If the dimensions of the Rectangle are smaller than the dimensions of the target, the fill expands to fill the entire target.
end () method
public function end(target:Graphics):void

Ends the fill.

Parameters
target:Graphics — The Graphics object that is being filled.


mx.graphics.Stroke (Flex™ 2 Language Reference)

Class Stroke | Properties | Methods
Package | mx.graphics
Class | public class Stroke
Inheritance | Stroke Inheritance Object
Implements | IStroke

The Stroke class defines the properties for a line. You can define a Stroke object in MXML, but you must attach that Stroke to another object for it to appear in your application. The following example defines two Stroke objects and then uses them in the horizontalAxisRenderer of a LineChart control:
  ...
  <mx:Stroke id="ticks" color="0xFF0000" weight="1"/>
  <mx:Stroke id="mticks" color="0x0000FF" weight="1"/>

  <mx:LineChart id="mychart" dataProvider="{ndxa}">
   <mx:horizontalAxisRenderer>
    <mx:AxisRenderer placement="bottom" canDropLabels="true">
     <mx:tickStroke>{ticks}</mx:tickStroke>
     <mx:minorTickStroke>{mticks}</mx:minorTickStroke>
    </mx:AxisRenderer>
   </mx:horizontalAxisRenderer>
  </LineChart>
  ...

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Stroke> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

  <mx:Stroke
    Properties
    alpha="1.0"
    caps="null|none|round|square"
    color="0x000000"
    joints="null|bevel|miter|round"
    miterLimit="0"
    pixelHinting="false|true"
    scaleMode="normal|none|noScale|vertical"
    weight="1 (in most cases)"
  />

See also

flash.display.Graphics
Using strokes

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alpha : Number The transparency of a line. | Stroke
 | caps : String = "null" Specifies the type of caps at the end of lines. | Stroke
 | color : uint = 0 The line color. | Stroke
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | joints : String = "null" Specifies the type of joint appearance used at angles. | Stroke
 | miterLimit : Number = 0 Indicates the limit at which a miter is cut off. | Stroke
 | pixelHinting : Boolean = false Specifies whether to hint strokes to full pixels. | Stroke
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | scaleMode : String = "normal" Specifies how to scale a stroke. | Stroke
 | weight : Number The line weight, in pixels. | Stroke
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Stroke(color:uint = 0, weight:Number = 0, alpha:Number = 1.0, pixelHinting:Boolean = false, scaleMode:String = "normal", caps:String = null, joints:String = null, miterLimit:Number = 0) Constructor. | Stroke
 | apply(g:Graphics):void Applies the properties to the specified Graphics object. | Stroke
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
alpha property
public var alpha:Number

The transparency of a line. Possible values are 0.0 (invisible) through 1.0 (opaque).

The default value is 1.0..

caps property
public var caps:String = "null"

Specifies the type of caps at the end of lines. Valid values are: "round", "square", and "none".

color property
public var color:uint = 0

The line color.

The default value is 0x000000 (black)..

joints property
public var joints:String = "null"

Specifies the type of joint appearance used at angles. Valid values are "round", "miter", and "bevel".

miterLimit property
public var miterLimit:Number = 0

Indicates the limit at which a miter is cut off. Valid values range from 0 to 255.

The default value is 0.

pixelHinting property
public var pixelHinting:Boolean = false

Specifies whether to hint strokes to full pixels. This value affects both the position of anchors of a curve and the line stroke size itself.

The default value is false.

scaleMode property
public var scaleMode:String = "normal"

Specifies how to scale a stroke. Valid values are "normal", "none", "vertical", and "noScale".

The default value is "normal".

weight property
weight:Number [read-write]

The line weight, in pixels. For many charts, the default value is 1 pixel.

Implementation
    public function get weight():Number
    public function set weight(value:Number):void
Constructor detail
Stroke () constructor
public function Stroke(color:uint = 0, weight:Number = 0, alpha:Number = 1.0, pixelHinting:Boolean = false, scaleMode:String = "normal", caps:String = null, joints:String = null, miterLimit:Number = 0)

Constructor.

Parameters
color:uint (default = 0) — Specifies the line color.
weight:Number (default = 0) — Specifies the line weight, in pixels.
alpha:Number (default = 1.0) — Specifies the alpha value in the range 0.0 to 1.0.
pixelHinting:Boolean (default = false) — Specifies whether to hint strokes to full pixels. This value affects both the position of anchors of a curve and the line stroke size itself.
scaleMode:String (default = "normal") — Specifies how to scale a stroke. Valid values are "normal", "none", "vertical", and "noScale".
caps:String (default = null) — Specifies the type of caps at the end of lines. Valid values are "round", "square", and "none".
joints:String (default = null) — Specifies the type of joint appearance used at angles. Valid values are "round", "miter", and "bevel".
miterLimit:Number (default = 0) — Indicates the limit at which a miter is cut off. Valid values range from 0 to 255.
Method detail
apply () method
public function apply(g:Graphics):void

Applies the properties to the specified Graphics object.

Parameters
g:Graphics — The Graphics object to which the Stroke's styles are applied.


mx.logging Summary (Flex™ 2 Language Reference)

Package mx.logging | Interfaces | Classes

The mx.logging package contains the logging classes.

Interfaces
Interface | Description
ILogger | All loggers within the logging framework must implement this interface.
ILoggingTarget | All logger target implementations within the logging framework must implement this interface.
Classes
Class | Description
AbstractTarget | This class provides the basic functionality required by the logging framework for a target implementation.
Log | Provides psuedo-hierarchical logging capabilities with multiple format and output options.
LogEvent | Represents the log information for a single logging event.
LogEventLevel | Static class containing constants for use in the level property.
LogLogger | The logger that is used within the logging framework.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.logging.AbstractTarget (Flex™ 2 Language Reference)

Class AbstractTarget | Properties | Methods
Package | mx.logging
Class | public class AbstractTarget
Inheritance | AbstractTarget Inheritance Object
Implements | ILoggingTarget, IMXMLObject
Subclasses | LineFormattedTarget

This class provides the basic functionality required by the logging framework for a target implementation. It handles the validation of filter expressions and provides a default level property. No implementation of the logEvent() method is provided.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | filters : Array In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category. | AbstractTarget
 | id : String [read-only] Provides access to the id of this target. | AbstractTarget
 | level : int Provides access to the level this target is currently set at. | AbstractTarget
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AbstractTarget() Constructor. | AbstractTarget
 | addLogger(logger:ILogger):void Sets up this target with the specified logger. | AbstractTarget
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialized(document:Object, id:String):void Called after the implementing object has been created and all properties specified on the tag have been assigned. | AbstractTarget
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | logEvent(event:LogEvent):void This method handles a LogEvent from an associated logger. | AbstractTarget
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removeLogger(logger:ILogger):void Stops this target from receiving events from the specified logger. | AbstractTarget
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
filters property
filters:Array [read-write]

In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category.

Each logger belongs to a category. By convention these categories map to the fully-qualified class name in which the logger is used. For example, a logger that is logging messages for the mx.rpc.soap.WebService class, uses "mx.rpc.soap.WebService" as the parameter to the Log.getLogger() method call. When messages are sent under this category only those targets that have a filter which matches that category receive notification of those events. Filter expressions can include a wildcard match, indicated with an asterisk. The wildcard must be the right-most character in the expression. For example: rpc*, mx.*, or *. If an invalid expression is specified, a InvalidFilterError is thrown. If null or [] is specified, the filters are set to the default of ["*"].

Implementation
    public function get filters():Array
    public function set filters(value:Array):void

Example
               var traceLogger:ILoggingTarget = new TraceTarget();
               traceLogger.filters = ["mx.rpc.*", "mx.messaging.*"];
               Log.addTarget(traceLogger);

id property
id:String [read-only]

Provides access to the id of this target. The id is assigned at runtime by the mxml compiler if used as an mxml tag, or internally if used within a script block

Implementation
    public function get id():String
level property
level:int [read-write]

Provides access to the level this target is currently set at. Value values are:

  • LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure
  • LogEventLevel.ERROR designates error events that might still allow the application to continue running.
  • LogEventLevel.WARN designates events that could be harmful to the application operation
  • LogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.
  • LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.
  • LogEventLevel.ALL intended to force a target to process all messages.

Implementation
    public function get level():int
    public function set level(value:int):void
Constructor detail
AbstractTarget () constructor
public function AbstractTarget()

Constructor.

Method detail
addLogger () method
public function addLogger(logger:ILogger):void

Sets up this target with the specified logger. This allows this target to receive log events from the specified logger.

Parameters
logger:ILogger — The ILogger that this target should listen to.
initialized () method
public function initialized(document:Object, id:String):void

Called after the implementing object has been created and all properties specified on the tag have been assigned.

Parameters
document:Object — MXML document that created this object.
id:String — Used by the document to refer to this object. If the object is a deep property on the document, id is null.
logEvent () method
public function logEvent(event:LogEvent):void

This method handles a LogEvent from an associated logger. A target uses this method to translate the event into the appropriate format for transmission, storage, or display. This method will be called only if the event's level is in range of the target's level. Descendants need to override this method to make it useful.

Parameters
event:LogEvent
removeLogger () method
public function removeLogger(logger:ILogger):void

Stops this target from receiving events from the specified logger.

Parameters
logger:ILogger — The ILogger that this target should ignore.


mx.logging.ILogger (Flex™ 2 Language Reference)

Interface ILogger | Properties | Methods
Package | mx.logging
Interface | public interface ILogger extends IEventDispatcher
Implementors | LogLogger

All loggers within the logging framework must implement this interface.

See also

Using the Logging API

Public Properties
Property |  | Defined by
 | category : String [read-only] The category value for the logger. | ILogger
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
debug(message:String, ... rest):void
Logs the specified data using the LogEventLevel.DEBUG level.
ILogger
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
error(message:String, ... rest):void
Logs the specified data using the LogEventLevel.ERROR level.
ILogger
fatal(message:String, ... rest):void
Logs the specified data using the LogEventLevel.FATAL level.
ILogger
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
info(message:String, ... rest):void
Logs the specified data using the LogEvent.INFO level.
ILogger
log(level:int, message:String, ... rest):void
Logs the specified data at the given level.
ILogger
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
warn(message:String, ... rest):void
Logs the specified data using the LogEventLevel.WARN level.
ILogger
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
category property
category:String [read-only]

The category value for the logger.

Implementation
    public function get category():String
Method detail
debug () method
public function debug(message:String, ... rest):void

Logs the specified data using the LogEventLevel.DEBUG level. LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This string can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.

Example
      // Get the logger for the mx.messaging.Channel "category"
      // and send some data to it.
      var logger:ILogger = Log.getLogger("mx.messaging.Channel");
      logger.debug("here is some channel info {0} and {1}", 15.4, true);
        // This will log the following String:
      //   "here is some channel info 15.4 and true"

error () method
public function error(message:String, ... rest):void

Logs the specified data using the LogEventLevel.ERROR level. LogEventLevel.ERROR designates error events that might still allow the application to continue running.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.

Example
      // Get the logger for the mx.messaging.Channel "category"
      // and send some data to it.
      var logger:ILogger = Log.getLogger("mx.messaging.Channel");
      logger.error("here is some channel info {0} and {1}", 15.4, true);
        // This will log the following String:
      //   "here is some channel info 15.4 and true"

fatal () method
public function fatal(message:String, ... rest):void

Logs the specified data using the LogEventLevel.FATAL level. LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.

Example
      // Get the logger for the mx.messaging.Channel "category"
      // and send some data to it.
      var logger:ILogger = Log.getLogger("mx.messaging.Channel");
      logger.fatal("here is some channel info {0} and {1}", 15.4, true);
        // This will log the following String:
      //   "here is some channel info 15.4 and true"

info () method
public function info(message:String, ... rest):void

Logs the specified data using the LogEvent.INFO level. LogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.

Example
      // Get the logger for the mx.messaging.Channel "category"
      // and send some data to it.
      var logger:ILogger = Log.getLogger("mx.messaging.Channel");
      logger.info("here is some channel info {0} and {1}", 15.4, true);
        // This will log the following String:
      //   "here is some channel info 15.4 and true"

log () method
public function log(level:int, message:String, ... rest):void

Logs the specified data at the given level.

The String specified for logging can contain braces with an index indicating which additional parameter should be inserted into the String before it is logged. For example "the first additional parameter was {0} the second was {1}" is translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
level:int — The level this information should be logged at. Valid values are:
  • LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure
  • LogEventLevel.ERROR designates error events that might still allow the application to continue running.
  • LogEventLevel.WARN designates events that could be harmful to the application operation
  • LogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.
  • LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.
  • LogEventLevel.ALL intended to force a target to process all messages.
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.

Example
      // Get the logger for the mx.messaging.Channel "category"
      // and send some data to it.
      var logger:ILogger = Log.getLogger("mx.messaging.Channel");
      logger.log("here is some channel info {0} and {1}", LogEventLevel.DEBUG, 15.4, true);
        // this will log the following string:
      //   "here is some channel info 15.4 and true"

warn () method
public function warn(message:String, ... rest):void

Logs the specified data using the LogEventLevel.WARN level. LogEventLevel.WARN designates events that could be harmful to the application operation.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Aadditional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.

Example
      // Get the logger for the mx.messaging.Channel "category"
      // and send some data to it.
      var logger:ILogger = Log.getLogger("mx.messaging.Channel");
      logger.warn("here is some channel info {0} and {1}", 15.4, true);
        // This will log the following String:
      //   "here is some channel info 15.4 and true"


mx.logging.ILoggingTarget (Flex™ 2 Language Reference)

Interface ILoggingTarget | Properties | Methods
Package | mx.logging
Interface | public interface ILoggingTarget
Implementors | AbstractTarget

All logger target implementations within the logging framework must implement this interface.

Public Properties
Property |  | Defined by
 | filters : Array In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category. | ILoggingTarget
 | level : int Provides access to the level this target is currently set at. | ILoggingTarget
Public Methods
Method |  | Defined by
 | addLogger(logger:ILogger):void Sets up this target with the specified logger. | ILoggingTarget
 | removeLogger(logger:ILogger):void Stops this target from receiving events from the specified logger. | ILoggingTarget
Property detail
filters property
filters:Array [read-write]

In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category.

Each logger belongs to a category. By convention these categories map to the fully qualified class name in which the logger is used. For example, a logger that is logging messages for the mx.rpc.soap.WebService class would use "mx.rpc.soap.WebService" as the parameter to the Log.getLogger() call. When messages are sent under this category only those targets that have a filter which matches that category will receive notification of those events. Filter expressions may include a wildcard match, indicated with an asterisk. The wildcard must be the right most character in the expression. For example: rpc*, mx.*, or *. If an invalid expression is specified a InvalidFilterError will be thrown. No spaces or any of the following characters are valid within a filter expression: []~$^&\/(){}<>+=`!#%?,:;'"@.

Implementation
    public function get filters():Array
    public function set filters(value:Array):void

Example
      var traceLogger:ILoggingTarget = new TraceTarget();
      traceLogger.filters = [ "mx.rpc.*", "mx.messaging.*" ];
      Log.addTarget(traceLogger);

level property
level:int [read-write]

Provides access to the level this target is currently set at. Value values are:

  • LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure
  • LogEventLevel.ERROR designates error events that might still allow the application to continue running.
  • LogEventLevel.WARN designates events that could be harmful to the application operation
  • LogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.
  • LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.
  • LogEventLevel.ALL intended to force a target to process all messages.

Implementation
    public function get level():int
    public function set level(value:int):void
Method detail
addLogger () method
public function addLogger(logger:ILogger):void

Sets up this target with the specified logger. This allows this target to receive log events from the specified logger.

Note: This method is called by the framework and should not be called by you directly.

Parameters
logger:ILogger — The ILogger that this target listens to.
removeLogger () method
public function removeLogger(logger:ILogger):void

Stops this target from receiving events from the specified logger.

Note: This method is called by the framework and should not be called by you directly.

Parameters
logger:ILogger — The ILogger that this target ignores.


mx.logging.Log (Flex™ 2 Language Reference)

Class Log | Properties | Methods
Package | mx.logging
Class | public class Log
Inheritance | Log Inheritance Object

Provides psuedo-hierarchical logging capabilities with multiple format and output options. The log system consists of two major components, the logger and a target. You can use the logger to send information to a target. The target is responsible for formatting and general output of the log data.

Loggers are singleton instances created for a particular category of information. Typically, the category is the package name of the component that desires to log information. The category provides users the ability to specify what log information they are interested in. Multiple categories can be selected and combined with regular expressions. This allows for both broad and narrow logging information to be acquired. For example, you might be interested in all logging information under the "mx.messaging" and "mx.rpc" packages and want the output from these packages to be formatted as xml. To get the all of the logging information under the "mx.messaging" category including sub-packages and components a wildcard expression is required, such as "mx.messaging.*". See the code example below for more details.

Targets provide the output mechanism of the data being logged. This mechanism typically includes formatting, transmission, or storage, but, can be anything possible under the VM. There are several different targets provided: XMLLogTarget, MiniDebugTarget, DebugChannelTarget, TraceTarget, etc. Each of these writers take the current log information and "sends" it somewhere for display and/or storage. Targets also provide the specification of what log data to output.

Example
  ...
  import mx.logging.ILoggingTarget;
  import mx.logging.Log;
  import mx.logging.LogEvent;
  import mx.logging.targets.TraceTarget;
  // Set up writer:
  var traceTarget:ILoggingTarget = new TraceTarget();
  traceTarget.filters = ["mx.messaging.*", "mx.rpc.*"];
  traceTarget.level = LogEventLevel.DEBUG;
  // Start writing log data:
  Log.addTarget(traceTarget);
   // Get a logger for the mx.messaging.Channel "category"
  // and send some data to it:
  var logger:ILogger = Log.getLogger("mx.messaging.Channel");
  logger.log("Here is some channel info {0} and {1}", LogEventLevel.DEBUG, 15.4, true);
 // The output logged would look like this:
 // Here is some channel info 15.4 and true
  // because the xmlTarget is listening for anything under mx.messaging
  // with the level of DEBUG it will get data logged in this example.
  ...

See also

Using the Logging API

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | addTarget(target:ILoggingTarget):void [static] Allows the specified target to begin receiving notification of log events. | Log
 | flush():void [static] This method removes all of the current loggers from the cache. | Log
 | getLogger(category:String):ILogger [static] Returns the logger associated with the specified category. | Log
 | hasIllegalCharacters(value:String):Boolean [static] This method checks the specified string value for illegal characters. | Log
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isDebug():Boolean [static] Indicates whether a debug level log event will be processed by a log target. | Log
 | isError():Boolean [static] Indicates whether an error level log event will be processed by a log target. | Log
 | isFatal():Boolean [static] Indicates whether a fatal level log event will be processed by a log target. | Log
 | isInfo():Boolean [static] Indicates whether an info level log event will be processed by a log target. | Log
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | isWarn():Boolean [static] Indicates whether a warn level log event will be processed by a log target. | Log
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removeTarget(target:ILoggingTarget):void [static] Stops the specified target from receiving notification of log events. | Log
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
addTarget () method
public static function addTarget(target:ILoggingTarget):void

Allows the specified target to begin receiving notification of log events.

Parameters
target:ILoggingTarget — specific target that should capture log events.
flush () method
public static function flush():void

This method removes all of the current loggers from the cache. Subsquent calls to the getLogger() method return new instances of loggers rather than any previous instances with the same category. This method is intended for use in debugging only.

getLogger () method
public static function getLogger(category:String):ILogger

Returns the logger associated with the specified category. If the category given doesn't exist a new instance of a logger will be returned and associated with that category. Categories must be at least one character in length and may not contain any blanks or any of the following characters: []~$^&\/(){}<>+=`!#%?,:;'"@ This method will throw an InvalidCategoryError if the category specified is malformed.

Parameters
category:String — The category of the logger that should be returned.

Returns
ILogger — An instance of a logger object for the specified name. If the name doesn't exist, a new instance with the specified name is returned.
hasIllegalCharacters () method
public static function hasIllegalCharacters(value:String):Boolean

This method checks the specified string value for illegal characters.

Parameters
value:String — The String to check for illegal characters. The following characters are not valid: []~$^&\/(){}<>+=`!#%?,:;'"@

Returns
Boolean — true if there are any illegal characters found, false otherwise
isDebug () method
public static function isDebug():Boolean

Indicates whether a debug level log event will be processed by a log target.

Returns
Boolean — true if a debug level log event will be logged; otherwise false.
isError () method
public static function isError():Boolean

Indicates whether an error level log event will be processed by a log target.

Returns
Boolean — true if an error level log event will be logged; otherwise false.
isFatal () method
public static function isFatal():Boolean

Indicates whether a fatal level log event will be processed by a log target.

Returns
Boolean — true if a fatal level log event will be logged; otherwise false.
isInfo () method
public static function isInfo():Boolean

Indicates whether an info level log event will be processed by a log target.

Returns
Boolean — true if an info level log event will be logged; otherwise false.
isWarn () method
public static function isWarn():Boolean

Indicates whether a warn level log event will be processed by a log target.

Returns
Boolean — true if a warn level log event will be logged; otherwise false.
removeTarget () method
public static function removeTarget(target:ILoggingTarget):void

Stops the specified target from receiving notification of log events.

Parameters
target:ILoggingTarget — specific target that should capture log events.


mx.logging.LogEvent (Flex™ 2 Language Reference)

Class LogEvent | Properties | Methods | Constants
Package | mx.logging
Class | public class LogEvent
Inheritance | LogEvent Inheritance Event Inheritance Object

Represents the log information for a single logging event. The loging system dispatches a single event each time a process requests information be logged. This event can be captured by any object for storage or formatting.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | level : int Provides access to the level for this log event. | LogEvent
 | message : String Provides access to the message that was logged. | LogEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LogEvent(message:String = "", level:int = 0) Constructor. | LogEvent
Inherited | clone():Event Duplicates an instance of an Event subclass. | Event
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
 | getLevelString(value:uint):String [static] Returns a string value representing the level specified. | LogEvent
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string containing all the properties of the Event object. | Event
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | LOG : String = "log" [static] Event type constant; identifies a logging event. | LogEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
level property
public var level:int

Provides access to the level for this log event. Valid values are:

  • LogEventLogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.
  • LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.
  • LogEventLevel.ERROR designates error events that might still allow the application to continue running.
  • LogEventLevel.WARN designates events that could be harmful to the application operation.
  • LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure.

message property
public var message:String

Provides access to the message that was logged.

Constructor detail
LogEvent () constructor
public function LogEvent(message:String = "", level:int = 0)

Constructor.

Parameters
message:String (default = "") — String containing the log data.
level:int (default = 0) — The level for this log event. Valid values are:
  • LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure
  • LogEventLevel.ERROR designates error events that might still allow the application to continue running.
  • LogEventLevel.WARN designates events that could be harmful to the application operation
  • LogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.
  • LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.
  • LogEventLevel.ALL intended to force a target to process all messages.
Method detail
getLevelString () method
public static function getLevelString(value:uint):String

Returns a string value representing the level specified.

Parameters
value:uint — level a string is desired for.

Returns
String — The level specified in English.
Constant detail
LOG constant
public static const LOG:String = "log"

Event type constant; identifies a logging event.


mx.logging.LogEventLevel (Flex™ 2 Language Reference)

Class LogEventLevel | Properties | Methods | Constants
Package | mx.logging
Class | public final class LogEventLevel
Inheritance | LogEventLevel Inheritance Object

Static class containing constants for use in the level property.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ALL : int = 0 [static] Tells a target to process all messages. | LogEventLevel
 | DEBUG : int = 2 [static] Designates informational level messages that are fine grained and most helpful when debugging an application. | LogEventLevel
 | ERROR : int = 8 [static] Designates error events that might still allow the application to continue running. | LogEventLevel
 | FATAL : int = 1000 [static] Designates events that are very harmful and will eventually lead to application failure. | LogEventLevel
 | INFO : int = 4 [static] Designates informational messages that highlight the progress of the application at coarse-grained level. | LogEventLevel
 | WARN : int = 6 [static] Designates events that could be harmful to the application operation. | LogEventLevel
Constant detail
ALL constant
public static const ALL:int = 0

Tells a target to process all messages.

DEBUG constant
public static const DEBUG:int = 2

Designates informational level messages that are fine grained and most helpful when debugging an application.

ERROR constant
public static const ERROR:int = 8

Designates error events that might still allow the application to continue running.

FATAL constant
public static const FATAL:int = 1000

Designates events that are very harmful and will eventually lead to application failure.

INFO constant
public static const INFO:int = 4

Designates informational messages that highlight the progress of the application at coarse-grained level.

WARN constant
public static const WARN:int = 6

Designates events that could be harmful to the application operation.


mx.logging.LogLogger (Flex™ 2 Language Reference)

Class LogLogger | Properties | Methods
Package | mx.logging
Class | public class LogLogger
Inheritance | LogLogger Inheritance EventDispatcher Inheritance Object
Implements | ILogger

The logger that is used within the logging framework. This class dispatches events for each message logged using the log() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | category : String [read-only] The category this logger send messages for. | LogLogger
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LogLogger(category:String)
Constructor.
LogLogger
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
debug(message:String, ... rest):void
Logs the specified data using the LogEventLevel.DEBUG level.
LogLogger
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
error(message:String, ... rest):void
Logs the specified data using the LogEventLevel.ERROR level.
LogLogger
fatal(message:String, ... rest):void
Logs the specified data using the LogEventLevel.FATAL level.
LogLogger
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
info(message:String, ... rest):void
Logs the specified data using the LogEvent.INFO level.
LogLogger
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
log(level:int, message:String, ... rest):void
Logs the specified data at the given level.
LogLogger
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
warn(message:String, ... rest):void
Logs the specified data using the LogEventLevel.WARN level.
LogLogger
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
category property
category:String [read-only]

The category this logger send messages for.

Implementation
    public function get category():String
Constructor detail
LogLogger () constructor
public function LogLogger(category:String)

Constructor.

Parameters
category:String
Method detail
debug () method
public function debug(message:String, ... rest):void

Logs the specified data using the LogEventLevel.DEBUG level. LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This string can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.
error () method
public function error(message:String, ... rest):void

Logs the specified data using the LogEventLevel.ERROR level. LogEventLevel.ERROR designates error events that might still allow the application to continue running.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.
fatal () method
public function fatal(message:String, ... rest):void

Logs the specified data using the LogEventLevel.FATAL level. LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.
info () method
public function info(message:String, ... rest):void

Logs the specified data using the LogEvent.INFO level. LogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.
log () method
public function log(level:int, message:String, ... rest):void

Logs the specified data at the given level.

The String specified for logging can contain braces with an index indicating which additional parameter should be inserted into the String before it is logged. For example "the first additional parameter was {0} the second was {1}" is translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
level:int — The level this information should be logged at. Valid values are:
  • LogEventLevel.FATAL designates events that are very harmful and will eventually lead to application failure
  • LogEventLevel.ERROR designates error events that might still allow the application to continue running.
  • LogEventLevel.WARN designates events that could be harmful to the application operation
  • LogEventLevel.INFO designates informational messages that highlight the progress of the application at coarse-grained level.
  • LogEventLevel.DEBUG designates informational level messages that are fine grained and most helpful when debugging an application.
  • LogEventLevel.ALL intended to force a target to process all messages.
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.
warn () method
public function warn(message:String, ... rest):void

Logs the specified data using the LogEventLevel.WARN level. LogEventLevel.WARN designates events that could be harmful to the application operation.

The string specified for logging can contain braces with an index indicating which additional parameter should be inserted into the string before it is logged. For example "the first additional parameter was {0} the second was {1}" will be translated into "the first additional parameter was 10 the second was 15" when called with 10 and 15 as parameters.

Parameters
message:String — The information to log. This String can contain special marker characters of the form {x}, where x is a zero based index that will be replaced with the additional parameters found at that index if specified.
... rest — Aadditional parameters that can be subsituted in the str parameter at each "{x}" location, where x is an integer (zero based) index value into the Array of values specified.


mx.logging.errors Summary (Flex™ 2 Language Reference)

Package mx.logging.errors | Classes

The mx.logging.errors package contains the error classes used by the logging components.

Classes
Class | Description
InvalidCategoryError | This error is thrown when a category specified for a logger contains invalid characters or is malformed.
InvalidFilterError | This error is thrown when a filter specified for a target contains invalid characters or is malformed.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.logging.errors.InvalidCategoryError (Flex™ 2 Language Reference)

Class InvalidCategoryError | Properties | Methods
Package | mx.logging.errors
Class | public class InvalidCategoryError
Inheritance | InvalidCategoryError Inheritance Error Inheritance Object

This error is thrown when a category specified for a logger contains invalid characters or is malformed. This error is thrown by the following method:
  • Log.getLogger() if a category specified is malformed.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | InvalidCategoryError(message:String) Constructor. | InvalidCategoryError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns the messge as a String. | InvalidCategoryError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
InvalidCategoryError () constructor
public function InvalidCategoryError(message:String)

Constructor.

Parameters
message:String — The message that describes this error.
Method detail
toString () method
public function toString():String

Returns the messge as a String.

Returns
String — The message.


mx.logging.errors.InvalidFilterError (Flex™ 2 Language Reference)

Class InvalidFilterError | Properties | Methods
Package | mx.logging.errors
Class | public class InvalidFilterError
Inheritance | InvalidFilterError Inheritance Error Inheritance Object

This error is thrown when a filter specified for a target contains invalid characters or is malformed. This error is thrown by the following methods/properties:
  • ILoggerTarget.filters if a filter expression in this listis malformed.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | InvalidFilterError(message:String) Constructor. | InvalidFilterError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns the messge as a String. | InvalidFilterError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
InvalidFilterError () constructor
public function InvalidFilterError(message:String)

Constructor.

Parameters
message:String — The message that describes this error.
Method detail
toString () method
public function toString():String

Returns the messge as a String.

Returns
String — The message.


mx.logging.targets Summary (Flex™ 2 Language Reference)

Package mx.logging.targets | Classes

The mx.logging.errors package contains the target classes used by the logging components.

Classes
Class | Description
LineFormattedTarget | All logger target implementations that have a formatted line style output should extend this class.
MiniDebugTarget | Provides a logger target that outputs to a LocalConnection, connected to the MiniDebug application.
TraceTarget | Provides a logger target that uses the global trace() method to output log messages.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.logging.targets.LineFormattedTarget (Flex™ 2 Language Reference)

Class LineFormattedTarget | Properties | Methods
Package | mx.logging.targets
Class | public class LineFormattedTarget
Inheritance | LineFormattedTarget Inheritance AbstractTarget Inheritance Object
Subclasses | MiniDebugTarget, TraceTarget

All logger target implementations that have a formatted line style output should extend this class. It provides default behavior for including date, time, category, and level within the output.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | fieldSeparator : String = " " The separator string to use between fields (the default is " ") | LineFormattedTarget
Inherited | filters : Array In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category. | AbstractTarget
Inherited | id : String Provides access to the id of this target. | AbstractTarget
 | includeCategory : Boolean Indicates if the category for this target should added to the trace. | LineFormattedTarget
 | includeDate : Boolean Indicates if the date should be added to the trace. | LineFormattedTarget
 | includeLevel : Boolean Indicates if the level for the event should added to the trace. | LineFormattedTarget
 | includeTime : Boolean Indicates if the time should be added to the trace. | LineFormattedTarget
Inherited | level : int Provides access to the level this target is currently set at. | AbstractTarget
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LineFormattedTarget() Constructor. | LineFormattedTarget
Inherited | addLogger(logger:ILogger):void Sets up this target with the specified logger. | AbstractTarget
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | initialized(document:Object, id:String):void Called after the implementing object has been created and all properties specified on the tag have been assigned. | AbstractTarget
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | logEvent(event:LogEvent):void This method handles a LogEvent from an associated logger. | LineFormattedTarget
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | removeLogger(logger:ILogger):void Stops this target from receiving events from the specified logger. | AbstractTarget
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
fieldSeparator property
public var fieldSeparator:String = " "

The separator string to use between fields (the default is " ")

includeCategory property
public var includeCategory:Boolean

Indicates if the category for this target should added to the trace.

includeDate property
public var includeDate:Boolean

Indicates if the date should be added to the trace.

includeLevel property
public var includeLevel:Boolean

Indicates if the level for the event should added to the trace.

includeTime property
public var includeTime:Boolean

Indicates if the time should be added to the trace.

Constructor detail
LineFormattedTarget () constructor
public function LineFormattedTarget()

Constructor.

Constructs an instance of a logger target that will format the message data on a single line and pass that line to the internalLog() method.

Method detail
logEvent () method
public override function logEvent(event:LogEvent):void

This method handles a LogEvent from an associated logger. A target uses this method to translate the event into the appropriate format for transmission, storage, or display. This method will be called only if the event's level is in range of the target's level.

Parameters
event:LogEvent


mx.logging.targets.MiniDebugTarget (Flex™ 2 Language Reference)

Class MiniDebugTarget | Properties | Methods
Package | mx.logging.targets
Class | public class MiniDebugTarget
Inheritance | MiniDebugTarget Inheritance LineFormattedTarget Inheritance AbstractTarget Inheritance Object

Provides a logger target that outputs to a LocalConnection, connected to the MiniDebug application.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | fieldSeparator : String = " " The separator string to use between fields (the default is " ") | LineFormattedTarget
Inherited | filters : Array In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category. | AbstractTarget
Inherited | id : String Provides access to the id of this target. | AbstractTarget
Inherited | includeCategory : Boolean Indicates if the category for this target should added to the trace. | LineFormattedTarget
Inherited | includeDate : Boolean Indicates if the date should be added to the trace. | LineFormattedTarget
Inherited | includeLevel : Boolean Indicates if the level for the event should added to the trace. | LineFormattedTarget
Inherited | includeTime : Boolean Indicates if the time should be added to the trace. | LineFormattedTarget
Inherited | level : int Provides access to the level this target is currently set at. | AbstractTarget
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MiniDebugTarget(connection:String = "_mdbtrace", method:String = "trace") Constructor. | MiniDebugTarget
Inherited | addLogger(logger:ILogger):void Sets up this target with the specified logger. | AbstractTarget
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | initialized(document:Object, id:String):void Called after the implementing object has been created and all properties specified on the tag have been assigned. | AbstractTarget
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | logEvent(event:LogEvent):void This method handles a LogEvent from an associated logger. | LineFormattedTarget
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | removeLogger(logger:ILogger):void Stops this target from receiving events from the specified logger. | AbstractTarget
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
MiniDebugTarget () constructor
public function MiniDebugTarget(connection:String = "_mdbtrace", method:String = "trace")

Constructor.

Constructs an instance of a logger target that will send the log data to the MiniDebug application.

Parameters
connection:String (default = "_mdbtrace") — Specifies where to send the logging information. This value is the name of the connection specified in the LocalConnection.connect() method call in the remote SWF, that can receive calls to a log() method with the following signature:
        log(... args:Array)
Each value specified in the args Array is a String.
method:String (default = "trace") — Specifies what method to call on the remote connection.


mx.logging.targets.TraceTarget (Flex™ 2 Language Reference)

Class TraceTarget | Properties | Methods
Package | mx.logging.targets
Class | public class TraceTarget
Inheritance | TraceTarget Inheritance LineFormattedTarget Inheritance AbstractTarget Inheritance Object

Provides a logger target that uses the global trace() method to output log messages.

To view trace() method output, you must be running the debugger version of Flash Player.

The debugger version of Flash Player sends output from the trace() method to the flashlog.txt file. The default location of this file is the same directory as the mm.cfg file. You can customize the location of this file by using the TraceOutputFileName property in the mm.cfg file. You must also set TraceOutputFileEnable to 1 in your mm.cfg file.

See also

Using the Logging API

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | fieldSeparator : String = " " The separator string to use between fields (the default is " ") | LineFormattedTarget
Inherited | filters : Array In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category. | AbstractTarget
Inherited | id : String Provides access to the id of this target. | AbstractTarget
Inherited | includeCategory : Boolean Indicates if the category for this target should added to the trace. | LineFormattedTarget
Inherited | includeDate : Boolean Indicates if the date should be added to the trace. | LineFormattedTarget
Inherited | includeLevel : Boolean Indicates if the level for the event should added to the trace. | LineFormattedTarget
Inherited | includeTime : Boolean Indicates if the time should be added to the trace. | LineFormattedTarget
Inherited | level : int Provides access to the level this target is currently set at. | AbstractTarget
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | TraceTarget() Constructor. | TraceTarget
Inherited | addLogger(logger:ILogger):void Sets up this target with the specified logger. | AbstractTarget
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | initialized(document:Object, id:String):void Called after the implementing object has been created and all properties specified on the tag have been assigned. | AbstractTarget
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | logEvent(event:LogEvent):void This method handles a LogEvent from an associated logger. | LineFormattedTarget
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | removeLogger(logger:ILogger):void Stops this target from receiving events from the specified logger. | AbstractTarget
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
TraceTarget () constructor
public function TraceTarget()

Constructor.

Constructs an instance of a logger target that will send the log data to the global trace() method. All output will be directed to flashlog.txt by default.


mx.managers Summary (Flex™ 2 Language Reference)

Package mx.managers | Interfaces | Classes

The mx.managers package contains the Flax manager classes, such as DragManager and Historymanager.

Interfaces
Interface | Description
IFocusManager | The IFocusManager interface defines the interface that components must implement to manage the focus on components in response to mouse activity or keyboard activity (Tab key), and to support a default button.
IFocusManagerComponent | The IFocusManagerComponent interface defines the interface that focusable components must implement in order to receive focus from the FocusManager.
IFocusManagerContainer | The IFocusManagerContainer interface defines the interface that containers implement to host a FocusManager.
IFocusManagerGroup | The IFocusManagerGroup interface defines the interface that any component must implement if it is grouped in sets, where only one member of the set can be selected at any given time.
IHistoryManagerClient | Interface that must be implemented by objects registered with the History Manager.
ILayoutManagerClient | The ILayoutManagerClient interface defines the interface that a component must implement to participate in the LayoutManager's commit/measurement/layout sequence.
ISystemManager | An ISystemManager manages an "application window".
IToolTipManagerClient | Components that implement IToolTipManagerClient can have tooltips and must have a toolTip getter/setter.
Classes
Class | Description
CursorManager | The CursorManager class controls a prioritized list of cursors, where the cursor with the highest priority is currently visible.
CursorManagerPriority | The CursorManagerPriority class defines the constant values for the priority argument to the CursorManager.setCursor() method.
DragManager | The DragManager class manages drag and drop operations, which let you move data from one place to another in a Flex application.
FocusManager | The FocusManager class manages the focus on components in response to mouse activity or keyboard activity (Tab key).
HistoryManager | History management lets users navigate through a Flex application using the web browser's Back and Forward navigation commands.
LayoutManager | The LayoutManager is the engine behind Flex's measurement and layout strategy.
PopUpManager | The PopUpManager singleton class creates new top-level windows and places or removes those windows from the layer on top of all other visible windows.
PopUpManagerChildList | The PopUpManagerChildList class defines the constant values for the detail property of the PopUpManager addPopUp() and createPopUp() methods.
SystemManager | The SystemManager class manages an application window.
ToolTipManager | The ToolTipManager lets you set basic ToolTip and error tip functionality, such as display delay and the disabling of ToolTips.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.managers.CursorManager (Flex™ 2 Language Reference)

Class CursorManager | Properties | Methods | Styles | Constants
Package | mx.managers
Class | public class CursorManager
Inheritance | CursorManager Inheritance Object

The CursorManager class controls a prioritized list of cursors, where the cursor with the highest priority is currently visible. If the cursor list contains more than one cursor with the same priority, the Cursor Manager displays the most recently created cursor.

For example, if your application performs processing that requires the user to wait until the processing completes, you can change the cursor so that it reflects the waiting period. In this case, you can change the cursor to an hourglass or other image.

You also might want to change the cursor to provide feedback to the user to indicate the actions that the user can perform. For example, you can use one cursor image to indicate that user input is enabled, and another to indicate that input is disabled. You can use a JPEG, GIF, PNG, or SVG image, a Sprite object, or a SWF file as the cursor image.

All methods and properties of the CursorManager are static, so you do not need to create an instance of it.

See also

mx.managers.CursorManagerPriority

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentCursorID : int = 0 [static] ID of the current custom cursor, or NO_CURSOR if the system cursor is showing. | CursorManager
 | currentCursorXOffset : Number = 0 [static] The x offset of the custom cursor, in pixels, relative to the mouse pointer. | CursorManager
 | currentCursorYOffset : Number = 0 [static] The y offset of the custom cursor, in pixels, relative to the mouse pointer. | CursorManager
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | hideCursor():void [static] Makes the cursor invisible. | CursorManager
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removeAllCursors():void [static] Removes all of the cursors from the cursor list and restores the system cursor. | CursorManager
 | removeBusyCursor():void [static] Removes the busy cursor from the cursor list. | CursorManager
 | removeCursor(cursorID:int):void [static] Removes a cursor from the cursor list. | CursorManager
 | setBusyCursor():void [static] Displays the busy cursor. | CursorManager
 | setCursor(cursorClass:Class, priority:int = 2, xOffset:Number = 0, yOffset:Number = 0):int [static] Creates a new cursor and sets an optional priority for the cursor. | CursorManager
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | showCursor():void [static] Makes the cursor visible. | CursorManager
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Styles
Style |  | Description | Defined by
 | busyCursor | Type: Class CSS Inheritance: no The skin for the busy cursor The default value is mx.skins.halo.BusyCursor. | CursorManager
Public Constants
Constant |  | Defined by
 | NO_CURSOR : int = 0 [static] Constant that is the value of currentCursorID property when there is no cursor managed by the CursorManager and therefore the system cursor is being displayed. | CursorManager
Property detail
currentCursorID property
public static var currentCursorID:int = 0

ID of the current custom cursor, or NO_CURSOR if the system cursor is showing.

currentCursorXOffset property
public static var currentCursorXOffset:Number = 0

The x offset of the custom cursor, in pixels, relative to the mouse pointer.

The default value is 0.

currentCursorYOffset property
public static var currentCursorYOffset:Number = 0

The y offset of the custom cursor, in pixels, relative to the mouse pointer.

The default value is 0.

Method detail
hideCursor () method
public static function hideCursor():void

Makes the cursor invisible. Cursor visibility is not reference-counted. A single call to the hideCursor() method always hides the cursor regardless of how many calls to the showCursor() method were made.

removeAllCursors () method
public static function removeAllCursors():void

Removes all of the cursors from the cursor list and restores the system cursor.

removeBusyCursor () method
public static function removeBusyCursor():void

Removes the busy cursor from the cursor list. If other busy cursor requests are still active in the cursor list, which means you called the setBusyCursor() method more than once, a busy cursor does not disappear until you remove all busy cursors from the list.

removeCursor () method
public static function removeCursor(cursorID:int):void

Removes a cursor from the cursor list. If the cursor being removed is the currently displayed cursor, the CursorManager displays the next cursor in the list, if one exists. If the list becomes empty, the CursorManager displays the default system cursor.

Parameters
cursorID:int — ID of cursor to remove.
setBusyCursor () method
public static function setBusyCursor():void

Displays the busy cursor. The busy cursor has a priority of CursorManagerPriority.LOW. Therefore, if the cursor list contains a cursor with a higher priority, the busy cursor is not displayed until you remove the higher priority cursor. To create a busy cursor at a higher priority level, use the setCursor() method.

setCursor () method
public static function setCursor(cursorClass:Class, priority:int = 2, xOffset:Number = 0, yOffset:Number = 0):int

Creates a new cursor and sets an optional priority for the cursor. Adds the new cursor to the cursor list.

Parameters
cursorClass:Class — Class of the cursor to display.
priority:int (default = 2) — Integer that specifies the priority level of the cursor. Possible values are CursorManagerPriority.HIGH, CursorManagerPriority.MEDIUM, and CursorManagerPriority.LOW.
xOffset:Number (default = 0) — Number that specifies the x offset of the cursor, in pixels, relative to the mouse pointer.
yOffset:Number (default = 0) — Number that specifies the y offset of the cursor, in pixels, relative to the mouse pointer.

Returns
int — The ID of the cursor.

See also

mx.managers.CursorManagerPriority
showCursor () method
public static function showCursor():void

Makes the cursor visible. Cursor visibility is not reference-counted. A single call to the showCursor() method always shows the cursor regardless of how many calls to the hideCursor() method were made.

Constant detail
NO_CURSOR constant
public static const NO_CURSOR:int = 0

Constant that is the value of currentCursorID property when there is no cursor managed by the CursorManager and therefore the system cursor is being displayed.


mx.managers.CursorManagerPriority (Flex™ 2 Language Reference)

Class CursorManagerPriority | Properties | Methods | Constants
Package | mx.managers
Class | public final class CursorManagerPriority
Inheritance | CursorManagerPriority Inheritance Object

The CursorManagerPriority class defines the constant values for the priority argument to the CursorManager.setCursor() method.

See also

mx.managers.CursorManager

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | HIGH : int = 1 [static] Constant that specifies the highest cursor priority when passed as the priority argument to setCursor(). | CursorManagerPriority
 | LOW : int = 3 [static] Constant that specifies the lowest cursor priority when passed as the priority argument to setCursor(). | CursorManagerPriority
 | MEDIUM : int = 2 [static] Constant that specifies a medium cursor priority when passed as the priority argument to setCursor(). | CursorManagerPriority
Constant detail
HIGH constant
public static const HIGH:int = 1

Constant that specifies the highest cursor priority when passed as the priority argument to setCursor().

LOW constant
public static const LOW:int = 3

Constant that specifies the lowest cursor priority when passed as the priority argument to setCursor().

MEDIUM constant
public static const MEDIUM:int = 2

Constant that specifies a medium cursor priority when passed as the priority argument to setCursor().


mx.managers.DragManager (Flex™ 2 Language Reference)

Class DragManager | Properties | Methods | Styles | Constants
Package | mx.managers
Class | public class DragManager
Inheritance | DragManager Inheritance Object

The DragManager class manages drag and drop operations, which let you move data from one place to another in a Flex application. For example, you can select an object, such as an item in a List control or a Flex control, such as an Image control, and then drag it over another component to add it to that component.

All methods and properties of the DragManager are static, so you do not need to create an instance of it.

All Flex components support drag and drop operations. Flex provides additional support for drag and drop to the List, Tree, and DataGrid controls.

When the user selects an item with the mouse, the selected component is called the drag initiator. The image displayed during the drag operation is called the drag proxy.

When the user moves the drag proxy over another component, the dragEnter event is sent to that component. If the component accepts the drag, it becomes the drop target and receives dragOver, dragExit, and dragDrop events.

When the drag is complete, a dragComplete event is sent to the drag initiator.

See also

mx.core.DragSource
mx.events.DragEvent
mx.core.UIComponent
Manually adding drag-and-drop support
Drag-and-drop techniques and considerations

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | isDragging : Boolean [static][read-only] Read-only property that returns true if a drag is in progress. | DragManager
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | acceptDragDrop(target:IUIComponent):void [static] Call this method from your dragEnter event handler if you accept the drag/drop data. | DragManager
 | doDrag(dragInitiator:IUIComponent, dragSource:DragSource, mouseEvent:MouseEvent, dragImage:IFlexDisplayObject = null, xOffset:Number = 0, yOffset:Number = 0, imageAlpha:Number = 0.5, allowMove:Boolean = true):void [static] Initiates a drag and drop operation. | DragManager
 | getFeedback():String [static] Returns the current drag and drop feedback. | DragManager
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | showFeedback(feedback:String):void [static] Sets the feedback indicator for the drag and drop operation. | DragManager
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Styles
Style |  | Description | Defined by
 | copyCursor | Type: Class CSS Inheritance: no Cursor displayed during a copy operation. The default value is mx.skins.cursor.DragCopy. | DragManager
 | defaultDragImageSkin | Type: Class CSS Inheritance: no Skin used to draw the default drag image, which is also called the drag proxy. The default value is mx.skins.halo.DefaultDragImage. | DragManager
 | linkCursor | Type: Class CSS Inheritance: no Cursor displayed during a link operation. The default value is mx.skins.cursor.DragLink. | DragManager
 | moveCursor | Type: Class CSS Inheritance: no Cursor displayed during a move operation. The default value is mx.skins.cursor.DragMove. | DragManager
 | rejectCursor | Type: Class CSS Inheritance: no Cursor displayed for a reject operation. The default value is mx.skins.cursor.DragReject. | DragManager
Public Constants
Constant |  | Defined by
 | COPY : String = "copy" [static] Constant that specifies that the type of drag action is "copy". | DragManager
 | LINK : String = "link" [static] Constant that specifies that the type of drag action is "link". | DragManager
 | MOVE : String = "move" [static] Constant that specifies that the type of drag action is "move". | DragManager
 | NONE : String = "none" [static] Constant that specifies that the type of drag action is "none". | DragManager
Property detail
isDragging property
isDragging:Boolean [read-only]

Read-only property that returns true if a drag is in progress.

Implementation
    public static function get isDragging():Boolean
Method detail
acceptDragDrop () method
public static function acceptDragDrop(target:IUIComponent):void

Call this method from your dragEnter event handler if you accept the drag/drop data. For example:

DragManager.acceptDragDrop(event.target);

Parameters
target:IUIComponent — The drop target accepting the drag.
doDrag () method
public static function doDrag(dragInitiator:IUIComponent, dragSource:DragSource, mouseEvent:MouseEvent, dragImage:IFlexDisplayObject = null, xOffset:Number = 0, yOffset:Number = 0, imageAlpha:Number = 0.5, allowMove:Boolean = true):void

Initiates a drag and drop operation.

Parameters
dragInitiator:IUIComponent — IUIComponent that specifies the component initiating the drag.
dragSource:DragSource — DragSource object that contains the data being dragged.
mouseEvent:MouseEvent — The MouseEvent that contains the mouse information for the start of the drag.
dragImage:IFlexDisplayObject (default = null) — The image to drag. This argument is optional. If omitted, a standard drag rectangle is used during the drag and drop operation. If you specify an image, you must explicitly set a height and width of the image or else it will not appear.
xOffset:Number (default = 0) — Number that specifies the x offset, in pixels, for the dragImage. This argument is optional. If omitted, the drag proxy is shown at the upper-left corner of the drag initiator. The offset is expressed in pixels from the left edge of the drag proxy to the left edge of the drag initiator, and is usually a negative number.
yOffset:Number (default = 0) — Number that specifies the y offset, in pixels, for the dragImage. This argument is optional. If omitted, the drag proxy is shown at the upper-left corner of the drag initiator. The offset is expressed in pixels from the top edge of the drag proxy to the top edge of the drag initiator, and is usually a negative number.
imageAlpha:Number (default = 0.5) — Number that specifies the alpha value used for the drag image. This argument is optional. If omitted, the default alpha value is 0.5. A value of 0.0 indicates that the image is transparent; a value of 1.0 indicates it is fully opaque.
allowMove:Boolean (default = true)
getFeedback () method
public static function getFeedback():String

Returns the current drag and drop feedback.

Returns
String — Possible return values are DragManager.COPY, DragManager.MOVE, DragManager.LINK, or DragManager.NONE.
showFeedback () method
public static function showFeedback(feedback:String):void

Sets the feedback indicator for the drag and drop operation. Possible values are DragManager.COPY, DragManager.MOVE, DragManager.LINK, or DragManager.NONE.

Parameters
feedback:String — The type of feedback indicator to display.
Constant detail
COPY constant
public static const COPY:String = "copy"

Constant that specifies that the type of drag action is "copy".

LINK constant
public static const LINK:String = "link"

Constant that specifies that the type of drag action is "link".

MOVE constant
public static const MOVE:String = "move"

Constant that specifies that the type of drag action is "move".

NONE constant
public static const NONE:String = "none"

Constant that specifies that the type of drag action is "none".


mx.managers.FocusManager (Flex™ 2 Language Reference)

Class FocusManager | Properties | Methods
Package | mx.managers
Class | public class FocusManager
Inheritance | FocusManager Inheritance Object
Implements | IFocusManager

The FocusManager class manages the focus on components in response to mouse activity or keyboard activity (Tab key). There can be several FocusManager instances in an application. Each FocusManager instance is responsible for a set of components that comprise a "tab loop". If you hit Tab enough times, focus traverses through a set of components and eventually get back to the first component that had focus. That is a "tab loop" and a FocusManager instance manages that loop. If there are popup windows with their own set of components in a "tab loop" those popup windows will have their own FocusManager instances. The main application always has a FocusManager instance.

The FocusManager manages focus from the "component level". In Flex, a UITextField in a component is the only way to allow keyboard entry of text. To the Flash Player, that UITextField has focus. However, from the FocusManager's perspective the component that parents the UITextField has focus. Thus there is a distinction between component-level focus and player-level focus. Application developers generally only have to deal with component-level focus while component developers must understand player-level focus.

All components that can be managed by the FocusManager must implement mx.managers.IFocusManagerComponent, whereas objects managed by player-level focus do not.

The FocusManager also managers the concept of a defaultButton, which is the Button on a form that dispatches a click event when the Enter key is pressed depending on where focus is at that time.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | defaultButton : IUIComponent A reference to the original default Button control. | FocusManager
 | defaultButtonEnabled : Boolean A flag that indicates whether the FocusManager should check for the Enter key being pressed to activate the default button. | FocusManager
 | focusPane : Sprite A single Sprite that is moved from container to container as the focus moves to those containers. | FocusManager
 | nextTabIndex : int [read-only] The next unique tab index to use in this tab loop. | FocusManager
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | showFocusIndicator : Boolean A flag that indicates whether to display an indicator that a component has focus. | FocusManager
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | FocusManager(container:IFocusManagerContainer, popup:Boolean = false) Constructor. | FocusManager
 | activate():void The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. | FocusManager
 | deactivate():void The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. | FocusManager
 | findFocusManagerComponent(o:InteractiveObject):IFocusManagerComponent Returns the IFocusManagerComponent that contains the given object, if any. | FocusManager
 | getFocus():IFocusManagerComponent Gets the IFocusManagerComponent component that currently has the focus. | FocusManager
 | getNextFocusManagerComponent(backward:Boolean = false):IFocusManagerComponent Returns the IFocusManagerComponent that would receive focus if the user pressed the Tab key to navigate to another component. | FocusManager
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | hideFocus():void Sets showFocusIndicator to false and removes the visual focus indicator from the focused object, if any. | FocusManager
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | setFocus(o:IFocusManagerComponent):void Sets focus to an IFocusManagerComponent component. | FocusManager
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | showFocus():void Sets showFocusIndicator to true and draws the visual focus indicator on the focused object, if any. | FocusManager
 | toString():String Returns a String representation of the component hosting the FocusManager object, with the String ".focusManager" appended to the end of the String. | FocusManager
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
defaultButton property
defaultButton:IUIComponent [read-write]

A reference to the original default Button control. Pressing the Enter key while the focus is on any control activates the Button control by dispatching a click event on the Button control, just as if it was clicked with the mouse. The actual default Button control changes if focus is given to another Button control, but switches back to the original if focus is not on a button.

The defaultButton must be of class mx.controls.Button even though this property is of type IUIComponent.

Implementation
    public function get defaultButton():IUIComponent
    public function set defaultButton(value:IUIComponent):void
defaultButtonEnabled property
defaultButtonEnabled:Boolean [read-write]

A flag that indicates whether the FocusManager should check for the Enter key being pressed to activate the default button. TextArea and other components that want to recognize the Enter key set this property to false to disable the Enter key from dispatching a click event on the default button, if it exists.

Implementation
    public function get defaultButtonEnabled():Boolean
    public function set defaultButtonEnabled(value:Boolean):void
focusPane property
focusPane:Sprite [read-write]

A single Sprite that is moved from container to container as the focus moves to those containers. The Sprite is used as the parent of the visual indicator that a component has focus.

Implementation
    public function get focusPane():Sprite
    public function set focusPane(value:Sprite):void
nextTabIndex property
nextTabIndex:int [read-only]

The next unique tab index to use in this tab loop.

Implementation
    public function get nextTabIndex():int
showFocusIndicator property
showFocusIndicator:Boolean [read-write]

A flag that indicates whether to display an indicator that a component has focus. If true a component receiving focus draws a visible indicator that it has focus.

By default, this is false until the user uses the Tab key, then it is set to true.

In general it is better to use the showFocus() and hideFocus() methods to change this property as those methods also update the visual indicator that a component has focus.

Implementation
    public function get showFocusIndicator():Boolean
    public function set showFocusIndicator(value:Boolean):void
Constructor detail
FocusManager () constructor
public function FocusManager(container:IFocusManagerContainer, popup:Boolean = false)

Constructor.

A FocusManager manages the focus within the children of an IFocusManagerContainer. It installs itself in the IFocusManagerContainer during execution of the constructor.

Parameters
container:IFocusManagerContainer — An IFocusManagerContainer that hosts the FocusManager.
popup:Boolean (default = false) — If true, indicates that the container is a popup component and not the main application.
Method detail
activate () method
public function activate():void

The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. If the mouse is clicked in an IFocusManagerContainer with a deactivated FocusManager, the SystemManager will call the activate() method on that FocusManager. The FocusManager that was activated will have its deactivate() method called prior to the activation of another FocusManager.

The FocusManager adds event handlers that allow it to monitor focus related keyboard and mouse activity.

deactivate () method
public function deactivate():void

The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. If the mouse is clicked in an IFocusManagerContainer with a deactivated FocusManager, the SystemManager will call the activate() method on that FocusManager. The FocusManager that was activated will have its deactivate() method called prior to the activation of another FocusManager.

The FocusManager removes event handlers that allow it to monitor focus related keyboard and mouse activity.

findFocusManagerComponent () method
public function findFocusManagerComponent(o:InteractiveObject):IFocusManagerComponent

Returns the IFocusManagerComponent that contains the given object, if any. Because the player can set focus to a subcomponent of a Flex component this method determines which IFocusManagerComponent has focus from the component perspective.

Parameters
o:InteractiveObject — An object that can have player-level focus.

Returns
IFocusManagerComponent — The IFOcusManagerComponent containing o or null
getFocus () method
public function getFocus():IFocusManagerComponent

Gets the IFocusManagerComponent component that currently has the focus. Calling this method is recommended instead of using the Stage object because it indicates which component has focus. The Stage might return a subcomponent in that component.

Returns
IFocusManagerComponent — IFocusManagerComponent object that has focus.
getNextFocusManagerComponent () method
public function getNextFocusManagerComponent(backward:Boolean = false):IFocusManagerComponent

Returns the IFocusManagerComponent that would receive focus if the user pressed the Tab key to navigate to another component. It will return the same component as the current focused component if there are no other valid components in the application.

Parameters
backward:Boolean (default = false) — If true, return the object as if the Shift-Tab keys were pressed.

Returns
IFocusManagerComponent — The component that would receive focus.
hideFocus () method
public function hideFocus():void

Sets showFocusIndicator to false and removes the visual focus indicator from the focused object, if any.

setFocus () method
public function setFocus(o:IFocusManagerComponent):void

Sets focus to an IFocusManagerComponent component. Does not check for the components visibility, enabled state, or any other conditions.

Parameters
o:IFocusManagerComponent — A component that can receive focus.
showFocus () method
public function showFocus():void

Sets showFocusIndicator to true and draws the visual focus indicator on the focused object, if any.

toString () method
public function toString():String

Returns a String representation of the component hosting the FocusManager object, with the String ".focusManager" appended to the end of the String.

Returns
String


mx.managers.HistoryManager (Flex™ 2 Language Reference)

Class HistoryManager | Properties | Methods
Package | mx.managers
Class | public class HistoryManager
Inheritance | HistoryManager Inheritance Object

History management lets users navigate through a Flex application using the web browser's Back and Forward navigation commands.

History management is enabled by default for the Accordion and TabNavigator containers. This means that if the user selects one of the panes in an Accordion control, that user can return to the previous pane by using the browser?s Back button or back navigation command. History management is disabled by default for the ViewStack navigator container.

You can disable history management by setting the navigator container's historyManagementEnabled property to false.

You can also enable history management for other objects in an application by registering the objects with the HistoryManager. To register a component with the HistoryManager class, you call the HistoryManager class's register() method with a reference to a component instance that implements the IHistoryManagerClient interface. In the following example, the Application component (this) is registered with the HistoryManager class when the Application is initialized:

  <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
    implements="mx.managers.IHistoryManagerClient"
    initialize="mx.managers.HistoryManager.register(this);">
You must also implement the saveState() and loadState() methods of the IHistoryManagerClient interface to complete the registration of the component. Components that extend UIComponent automatically inherit the loadState() method.

All methods and properties of the HistoryManager are static, so you do not need to create an instance of it.

See also

mx.managers.IHistoryManagerClient
Using standard history management

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialize(sm:ISystemManager):void [static] Initializes the HistoryManager. | HistoryManager
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | register(obj:IHistoryManagerClient):void [static] Registers an object with the HistoryManager. | HistoryManager
 | save():void [static] Saves the application's current state so it can be restored later. | HistoryManager
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
 | unregister(obj:IHistoryManagerClient):void [static] Unregisters an object with the HistoryManager. | HistoryManager
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
initialize () method
public static function initialize(sm:ISystemManager):void

Initializes the HistoryManager. In general, this does not need to be called because any time you add a component with historyManagementEnabled, Flex calls this method. However, the HistoryManager will not work correctly if it is not initialized from the top-level application. So, if your application does not have any HistoryManager enabled components in it and loads other sub-applications that do, you must call the HistoryManager.initialize() method in the main application, usually from an initialize event handler on the application.

Parameters
sm:ISystemManager — SystemManager for this application.
register () method
public static function register(obj:IHistoryManagerClient):void

Registers an object with the HistoryManager. The object must implement the IHistoryManagerClient interface.

Parameters
obj:IHistoryManagerClient — Object to register.

See also

mx.managers.IHistoryManagerClient
save () method
public static function save():void

Saves the application's current state so it can be restored later. This method is automatically called by navigator containers whenever their navigation state changes. If you registered an interface with the HistoryManager, you are responsible for calling the save() method when the application state changes.

unregister () method
public static function unregister(obj:IHistoryManagerClient):void

Unregisters an object with the HistoryManager.

Parameters
obj:IHistoryManagerClient — Object to unregister.


mx.managers.IFocusManager (Flex™ 2 Language Reference)

Interface IFocusManager | Properties | Methods
Package | mx.managers
Interface | public interface IFocusManager
Implementors | Accordion, Button, ButtonBar, ChartBase, ComboBase, Container, DateChooser, DateField, FocusManager, ListBase, Menu, MenuBar, NumericStepper, RadioButton, TabNavigator, TextArea, TextInput

The IFocusManager interface defines the interface that components must implement to manage the focus on components in response to mouse activity or keyboard activity (Tab key), and to support a default button.

See also

mx.managers.FocusManager

Public Properties
Property |  | Defined by
 | defaultButton : IUIComponent A reference to the original default Button control. | IFocusManager
 | defaultButtonEnabled : Boolean A flag that indicates whether the FocusManager should check for the Enter key being pressed to activate the default button. | IFocusManager
 | focusPane : Sprite A single Sprite that is moved from container to container as the focus moves to those containers. | IFocusManager
 | nextTabIndex : int [read-only] The next unique tab index to use in this tab loop. | IFocusManager
 | showFocusIndicator : Boolean A flag that indicates whether to display an indicator that a component has focus. | IFocusManager
Public Methods
Method |  | Defined by
 | activate():void The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. | IFocusManager
 | deactivate():void The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. | IFocusManager
 | findFocusManagerComponent(o:InteractiveObject):IFocusManagerComponent Returns the IFocusManagerComponent that contains the given object, if any. | IFocusManager
 | getFocus():IFocusManagerComponent Gets the IFocusManagerComponent component that currently has the focus. | IFocusManager
 | getNextFocusManagerComponent(backward:Boolean = false):IFocusManagerComponent Returns the IFocusManagerComponent that would receive focus if the user pressed the Tab key to navigate to another component. | IFocusManager
 | hideFocus():void Sets showFocusIndicator to false and removes the visual focus indicator from the focused object, if any. | IFocusManager
 | setFocus(o:IFocusManagerComponent):void Sets focus to an IFocusManagerComponent component. | IFocusManager
 | showFocus():void Sets showFocusIndicator to true and draws the visual focus indicator on the focused object, if any. | IFocusManager
Property detail
defaultButton property
defaultButton:IUIComponent [read-write]

A reference to the original default Button control. Pressing the Enter key while the focus is on any control activates the Button control by dispatching a click event on the Button control, just as if it was clicked with the mouse. The actual default Button control changes if focus is given to another Button control, but switches back to the original if focus is not on a button.

The defaultButton must be of class mx.controls.Button even though this property is of type IUIComponent.

Implementation
    public function get defaultButton():IUIComponent
    public function set defaultButton(value:IUIComponent):void
defaultButtonEnabled property
defaultButtonEnabled:Boolean [read-write]

A flag that indicates whether the FocusManager should check for the Enter key being pressed to activate the default button. TextArea and other components that want to recognize the Enter key set this property to false to disable the Enter key from dispatching a click event on the default button, if it exists.

Implementation
    public function get defaultButtonEnabled():Boolean
    public function set defaultButtonEnabled(value:Boolean):void
focusPane property
focusPane:Sprite [read-write]

A single Sprite that is moved from container to container as the focus moves to those containers. The Sprite is used as the parent of the visual indicator that a component has focus.

Implementation
    public function get focusPane():Sprite
    public function set focusPane(value:Sprite):void
nextTabIndex property
nextTabIndex:int [read-only]

The next unique tab index to use in this tab loop.

Implementation
    public function get nextTabIndex():int
showFocusIndicator property
showFocusIndicator:Boolean [read-write]

A flag that indicates whether to display an indicator that a component has focus. If true a component receiving focus draws a visible indicator that it has focus.

By default, this is false until the user uses the Tab key, then it is set to true.

In general it is better to use the showFocus() and hideFocus() methods to change this property as those methods also update the visual indicator that a component has focus.

Implementation
    public function get showFocusIndicator():Boolean
    public function set showFocusIndicator(value:Boolean):void
Method detail
activate () method
public function activate():void

The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. If the mouse is clicked in an IFocusManagerContainer with a deactivated FocusManager, the SystemManager will call the activate() method on that FocusManager. The FocusManager that was activated will have its deactivate() method called prior to the activation of another FocusManager.

deactivate () method
public function deactivate():void

The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time. If the mouse is clicked in an IFocusManagerContainer with a deactivated FocusManager, the SystemManager will call the activate() method on that FocusManager. The FocusManager that was activated will have its deactivate() method called prior to the activation of another FocusManager.

findFocusManagerComponent () method
public function findFocusManagerComponent(o:InteractiveObject):IFocusManagerComponent

Returns the IFocusManagerComponent that contains the given object, if any. Because the player can set focus to a subcomponent of a Flex component this method determines which IFocusManagerComponent has focus from the component perspective.

Parameters
o:InteractiveObject — An object that can have player-level focus.

Returns
IFocusManagerComponent — The IFOcusManagerComponent containing o or null
getFocus () method
public function getFocus():IFocusManagerComponent

Gets the IFocusManagerComponent component that currently has the focus. Calling this method is recommended instead of using the Stage object because it indicates which component has focus. The Stage might return a subcomponent in that component.

Returns
IFocusManagerComponent — IFocusManagerComponent object that has focus.
getNextFocusManagerComponent () method
public function getNextFocusManagerComponent(backward:Boolean = false):IFocusManagerComponent

Returns the IFocusManagerComponent that would receive focus if the user pressed the Tab key to navigate to another component. It will return the same component as the current focused component if there are no other valid components in the application.

Parameters
backward:Boolean (default = false) — If true, return the object as if the Shift-Tab keys were pressed.

Returns
IFocusManagerComponent — The component that would receive focus.
hideFocus () method
public function hideFocus():void

Sets showFocusIndicator to false and removes the visual focus indicator from the focused object, if any.

setFocus () method
public function setFocus(o:IFocusManagerComponent):void

Sets focus to an IFocusManagerComponent component. Does not check for the components visibility, enabled state, or any other conditions.

Parameters
o:IFocusManagerComponent — A component that can receive focus.
showFocus () method
public function showFocus():void

Sets showFocusIndicator to true and draws the visual focus indicator on the focused object, if any.


mx.managers.IFocusManagerComponent (Flex™ 2 Language Reference)

Interface IFocusManagerComponent | Properties | Methods
Package | mx.managers
Interface | public interface IFocusManagerComponent
Implementors | Accordion, Button, ButtonBar, ChartBase, ComboBase, DateChooser, DateField, ListBase, MenuBar, NumericStepper, TabNavigator, TextArea, TextInput

The IFocusManagerComponent interface defines the interface that focusable components must implement in order to receive focus from the FocusManager. The base implementations of this interface are in the UIComponent class, but UIComponent does not implement the full IFocusManagerComponent interface since some UIComponents are not intended to receive focus. Therefore, to make a UIComponent-derived component be a valid focusable component, you simply add "implements IFocusManagerComponent" to the class definition.

Public Properties
Property |  | Defined by
 | focusEnabled : Boolean A flag that indicates whether the component can receive focus when selected. | IFocusManagerComponent
 | mouseFocusEnabled : Boolean [read-only] A flag that indicates whether the component can receive focus when selected with the mouse. | IFocusManagerComponent
 | tabEnabled : Boolean [read-only] A flag that indicates whether pressing the Tab key eventually moves focus to this component. | IFocusManagerComponent
 | tabIndex : int [read-only] If tabEnabled, the order in which the component receives focus. | IFocusManagerComponent
Public Methods
Method |  | Defined by
 | drawFocus(draw:Boolean):void Called by the FocusManager when the component receives focus. | IFocusManagerComponent
 | setFocus():void Called by the FocusManager when the component receives focus. | IFocusManagerComponent
Property detail
focusEnabled property
focusEnabled:Boolean [read-write]

A flag that indicates whether the component can receive focus when selected.

As an optimization, if a child component in your component implements the IFocusManagerComponent interface, and you never want it to receive focus, you can set focusEnabled to false before calling addChild() on the child component.

This will cause the FocusManager to ignore this component and not monitor it for changes to the tabEnabled, tabChildren, and mouseFocusEnabled properties. This also means you cannot change this value after addChild() and expect the FocusManager to notice.

Note: It does not mean that you cannot give this object focus programmatically in your setFocus() method; it just tells the FocusManager to ignore this IFocusManagerComponent component in the Tab and mouse searches.

Implementation
    public function get focusEnabled():Boolean
    public function set focusEnabled(value:Boolean):void
mouseFocusEnabled property
mouseFocusEnabled:Boolean [read-only]

A flag that indicates whether the component can receive focus when selected with the mouse. If false, focus will be transferred to the first parent that is mouseFocusEnabled.

Implementation
    public function get mouseFocusEnabled():Boolean
tabEnabled property
tabEnabled:Boolean [read-only]

A flag that indicates whether pressing the Tab key eventually moves focus to this component. Even if false, you can still be given focus by being selected with the mouse or via a call to setFocus()

Implementation
    public function get tabEnabled():Boolean
tabIndex property
tabIndex:int [read-only]

If tabEnabled, the order in which the component receives focus. If -1, then the component receives focus based on z-order.

Implementation
    public function get tabIndex():int
Method detail
drawFocus () method
public function drawFocus(draw:Boolean):void

Called by the FocusManager when the component receives focus. The component should draw or hide a graphic that indicates that the component has focus.

Parameters
draw:Boolean — If true, draw the focus indicator, otherwise hide it.
setFocus () method
public function setFocus():void

Called by the FocusManager when the component receives focus. The component may in turn set focus to an internal component.


mx.managers.IFocusManagerContainer (Flex™ 2 Language Reference)

Interface IFocusManagerContainer | Properties | Methods
Package | mx.managers
Interface | public interface IFocusManagerContainer extends IEventDispatcher
Implementors | Container, Menu

The IFocusManagerContainer interface defines the interface that containers implement to host a FocusManager. The PopUpManager automatically installs a FocusManager in any IFocusManagerContainer it pops up.

Public Properties
Property |  | Defined by
 | focusManager : IFocusManager The FocusManager for this component. | IFocusManagerContainer
 | systemManager : ISystemManager [read-only] Returns the SystemManager object used by this component. | IFocusManagerContainer
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the container instance or the instance itself.
IFocusManagerContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
focusManager property
focusManager:IFocusManager [read-write]

The FocusManager for this component. The FocusManager must be in a focusManager property.

Implementation
    public function get focusManager():IFocusManager
    public function set focusManager(value:IFocusManager):void
systemManager property
systemManager:ISystemManager [read-only]

Returns the SystemManager object used by this component.

Implementation
    public function get systemManager():ISystemManager
Method detail
contains () method
public function contains(child:DisplayObject):Boolean

Determines whether the specified display object is a child of the container instance or the instance itself. The search includes the entire display list including this container instance. Grandchildren, great-grandchildren, and so on each return true.

Parameters
child:DisplayObject — The child object to test.

Returns
Boolean — true if the child object is a child of the container or the container itself; otherwise false.


mx.managers.IFocusManagerGroup (Flex™ 2 Language Reference)

Interface IFocusManagerGroup | Properties
Package | mx.managers
Interface | public interface IFocusManagerGroup
Implementors | RadioButton

The IFocusManagerGroup interface defines the interface that any component must implement if it is grouped in sets, where only one member of the set can be selected at any given time. For example, a RadioButton implements IFocusManagerGroup because a set of RadioButtons in the same group can only have one RadioButton selected at any one time, and the FocusManager will make sure not to give focus to the RadioButtons that are not selected in response to moving focus via the Tab key.

Public Properties
Property |  | Defined by
 | groupName : String The name of the group of controls to which the control belongs. | IFocusManagerGroup
 | selected : Boolean A flag that indicates whether this control is selected. | IFocusManagerGroup
Property detail
groupName property
groupName:String [read-write]

The name of the group of controls to which the control belongs.

Implementation
    public function get groupName():String
    public function set groupName(value:String):void
selected property
selected:Boolean [read-write]

A flag that indicates whether this control is selected.

Implementation
    public function get selected():Boolean
    public function set selected(value:Boolean):void


mx.managers.IHistoryManagerClient (Flex™ 2 Language Reference)

Interface IHistoryManagerClient | Methods
Package | mx.managers
Interface | public interface IHistoryManagerClient
Implementors | Accordion, ViewStack

Interface that must be implemented by objects registered with the History Manager. The methods in this interface are called by the HistoryManager when saving and loading the history state of the application.

This interface is implemented by the Flex navigator containers TabNavigator, Accordion, and ViewStack. It must be implemented by any other component that is registered with the HistoryManager.

See also

mx.managers.HistoryManager
Using standard history management

Public Methods
Method |  | Defined by
 | loadState(state:Object):void Loads the state of this object. | IHistoryManagerClient
 | saveState():Object Saves the state of this object. | IHistoryManagerClient
 | toString():String Converts this object to a unique string. | IHistoryManagerClient
Method detail
loadState () method
public function loadState(state:Object):void

Loads the state of this object.

Parameters
state:Object — State of this object to load. This will be null when loading the initial state of the application.

Example
The following code loads the selected index and search string from the saved state.
   public function loadState(state:Object):void
   {
    // First, check to see if state is null. When the app is reset
    // back to its initial state, loadState() is passed null.
    if (state == null)
    {
    myList.selectedIndex = -1;
     mySearchInput.text = "";
    }
    else
    {
     myList.selectedIndex = state.selectedIndex;
     mySearchInput.text = state.searchString;
    }
   }

saveState () method
public function saveState():Object

Saves the state of this object. The object contains name:value pairs for each property to be saved with the state.

The History Manager collects the state information from all components and encodes the information in a URL format. Most browsers have a length limitation on URLs, so the state information returned should be as minimal as possible.

Returns
Object — The state of this object.

Example
The following code saves the selected index from a List, and a search string.
   public function saveState():Object
   {
    var state:Object = {};
      state.selectedIndex = myList.selectedIndex;
    state.searchString = mySearchInput.text;
      return state;
  }

toString () method
public function toString():String

Converts this object to a unique string. Implemented by UIComponent.

Returns
String — The unique identifier for this object.


mx.managers.ILayoutManagerClient (Flex™ 2 Language Reference)

Interface ILayoutManagerClient | Properties | Methods
Package | mx.managers
Interface | public interface ILayoutManagerClient extends IEventDispatcher
Subinterfaces | IListItemRenderer
Implementors | DataGridItemRenderer, ProgrammaticSkin, UIComponent

The ILayoutManagerClient interface defines the interface that a component must implement to participate in the LayoutManager's commit/measurement/layout sequence.

Objects that implement this interface can be passed to the LayoutManager's invalidateProperties() method. When the LayoutManager reaches the commit properties phase, the LayoutManager invokes this object's validateProperties() method.

Similarly, if an object is passed to the LayoutManager's invalidateSize() method, then the LayoutManager calls that object's validateSize() method during its measurement phase, and if an object is passed to LayoutManager's invalidateDisplayList() method, then the LayoutManager calls its validateDisplayList() method during the layout phase.

The ILayoutManagerClient interface is implemented by the UIComponent and ProgrammaticSkin classes.

Public Properties
Property |  | Defined by
 | initialized : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required) This flag should only be modified by the LayoutManager. | ILayoutManagerClient
 | nestLevel : int The top-level SystemManager has a nestLevel of 1. | ILayoutManagerClient
 | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ILayoutManagerClient
 | updateCompletePendingFlag : Boolean A flag that determines if an object is waiting to have its updateComplete event dispatched. | ILayoutManagerClient
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
validateDisplayList():void
Validates the position and size of children and draws other visuals.
ILayoutManagerClient
validateProperties():void
Validates the properties of a component.
ILayoutManagerClient
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
ILayoutManagerClient
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
initialized property
initialized:Boolean [read-write]

A flag that determines if an object has been through all three phases of layout validation (provided that any were required) This flag should only be modified by the LayoutManager.

Implementation
    public function get initialized():Boolean
    public function set initialized(value:Boolean):void
nestLevel property
nestLevel:int [read-write]

The top-level SystemManager has a nestLevel of 1. Its immediate children (the top-level Application and any pop-up windows) have a nestLevel of 2. Their children have a nestLevel of 3, and so on. The nestLevel is used to sort ILayoutManagerClients during the measurement and layout phases. During the commit phase, the LayoutManager commits properties on clients in order of decreasing nestLevel, so that an object's children have already had their properties committed before Flex commits properties on the object itself. During the measurement phase, the LayoutManager measures clients in order of decreasing nestLevel, so that an object's children have already been measured before Flex measures the object itself. During the layout phase, the LayoutManager lays out clients in order of increasing nestLevel, so that an object has a chance to set the sizes of its children before the child objects are asked to position and size their children.

Implementation
    public function get nestLevel():int
    public function set nestLevel(value:int):void
processedDescriptors property
processedDescriptors:Boolean [read-write]

Set to true after immediate or deferred child creation, depending on which one happens. For a Container object, it is set to true at the end of the createComponentsFromDescriptors() method, meaning after the Container object creates its children from its child descriptors.

For example, if an Accordion container uses deferred instantiation, the processedDescriptors property for the second pane of the Accordion container does not become true until after the user navigates to that pane and the pane creates its children. But, if the Accordion had set the creationPolicy property to "all", the processedDescriptors property for its second pane is set to true during application startup.

For classes that are not containers, which do not have descriptors, it is set to true after the createChildren() method creates any internal component children.

Implementation
    public function get processedDescriptors():Boolean
    public function set processedDescriptors(value:Boolean):void
updateCompletePendingFlag property
updateCompletePendingFlag:Boolean [read-write]

A flag that determines if an object is waiting to have its updateComplete event dispatched. This flag should only be modified by the LayoutManager.

Implementation
    public function get updateCompletePendingFlag():Boolean
    public function set updateCompletePendingFlag(value:Boolean):void
Method detail
validateDisplayList () method
public function validateDisplayList():void

Validates the position and size of children and draws other visuals. If the LayoutManager.invalidateDisplayList() method is called with this ILayoutManagerClient, then the validateDisplayList() method is called when it's time to update the display list.

validateProperties () method
public function validateProperties():void

Validates the properties of a component. If the LayoutManager.invalidateProperties() method is called with this ILayoutManagerClient, then the validateProperties() method is called when it's time to commit property values.

validateSize () method
public function validateSize(recursive:Boolean = false):void

Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.

Parameters
recursive:Boolean (default = false) — If true, call this method on the objects children.


mx.managers.ISystemManager (Flex™ 2 Language Reference)

Interface ISystemManager | Properties | Methods
Package | mx.managers
Interface | public interface ISystemManager extends IEventDispatcher, IChildList
Implementors | SystemManager

An ISystemManager manages an "application window". Every application that runs on the desktop or in a browser has an area where the visuals of the application will be displayed. It may be a window in the operating system or an area within the browser. That is an "application window" and different from an instance of mx.core.Application, which is the main "top-level" window within an application.

Every application has an ISystemManager. The ISystemManager sends an event if the size of the application window changes (you cannot change it from within the application, but only through interaction with the operating system window or browser). It parents all displayable items within the application, such as the main mx.core.Application instance and all popups, tooltips, cursors, an so on. Any object parented by the ISystemManager is considered to be a "top-level" window, even tooltips and cursors.

The ISystemManager also switches focus between top-level windows if there are more than one IFocusManagerContainer displayed and users are interacting with components within the IFocusManagerContainers.

All keyboard and mouse activity that is not expressly trapped is seen by the ISystemManager, making it a good place to monitor activity should you need to do so.

If an application is loaded into another application, an ISystemManager will still be created, but will not manage an "application window", depending on security and domain rules. Instead, it will be the content of the Loader that loaded it and simply serve as the parent of the sub-application

The ISystemManager maintains multiple lists of children, one each for tooltips, cursors, popup windows. This is how it ensures that popup windows "float" above the main application windows and that tooltips "float" above that and cursors above that. If you examine the numChildren property or getChildAt() method on the ISystemManager you are accessing the main application window and any other windows that aren't popped up. To get the list of all windows, including popups, tooltips and cursors, use the rawChildren property.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | cursorChildren : IChildList [read-only] An list of the custom cursors being parented by this ISystemManager. | ISystemManager
 | document : Object A reference to the document object. | ISystemManager
 | focusPane : Sprite A single Sprite shared among components used as an overlay for drawing focus. | ISystemManager
 | loaderInfo : LoaderInfo [read-only] The LoaderInfo object that represents information about the application. | ISystemManager
Inherited | numChildren : int The number of children in this child list. | IChildList
 | numModalWindows : int The number of modal windows. | ISystemManager
 | popUpChildren : IChildList [read-only] An list of the topMost (popup) windows being parented by this ISystemManager. | ISystemManager
 | rawChildren : IChildList [read-only] A list of all children being parented by this ISystemManager. | ISystemManager
 | screen : Rectangle [read-only] The size and position of the application window. | ISystemManager
 | stage : Stage [read-only] The flash.display.Stage that represents the application window mapped to this SystemManager | ISystemManager
 | toolTipChildren : IChildList [read-only] A list of the tooltips being parented by this ISystemManager. | ISystemManager
 | topLevelSystemManager : ISystemManager [read-only] The ISystemManager responsible for the application window. | ISystemManager
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
activate(f:IFocusManagerContainer):void
Activates the FocusManager in an IFocusManagerContainer.
ISystemManager
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject after the end of this child list.
IChildList
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject to this child list at the index specified.
IChildList
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
addFocusManager(f:IFocusManagerContainer):void
Registers a top-level window containing a FocusManager.
ISystemManager
Inherited
contains(child:DisplayObject):Boolean
Determines if a DisplayObject is in this child list, or is a descendant of an child in this child list.
IChildList
deactivate(f:IFocusManagerContainer):void
Deactivates the FocusManager in an IFocusManagerContainer, and activate the FocusManager of the next highest window that is an IFocusManagerContainer.
ISystemManager
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
getChildAt(index:int):DisplayObject
Gets the child DisplayObject at the specified index in this child list.
IChildList
Inherited
getChildByName(name:String):DisplayObject
Gets the child DisplayObject with the specified name in this child list.
IChildList
Inherited
getChildIndex(child:DisplayObject):int
Gets the index of a specific child in this child list.
IChildList
getDefinitionByName(name:String):Object
Converts the given String to a Class or package-level Function.
ISystemManager
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of DisplayObjects that lie under the specified point and are in this child list.
IChildList
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
isFontFaceEmbedded(tf:TextFormat):Boolean
Returns true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.
ISystemManager
isTopLevel():Boolean
Returns true if this ISystemManager is responsible for an application window, and false if this application has been loaded into another application.
ISystemManager
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject from this child list.
IChildList
Inherited
removeChildAt(index:int):DisplayObject
Removes the child DisplayObject at the specified index from this child list.
IChildList
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
removeFocusManager(f:IFocusManagerContainer):void
Unregisters a top-level window containing a FocusManager.
ISystemManager
Inherited
setChildIndex(child:DisplayObject, newIndex:int):void
Changes the index of a particular child in this child list.
IChildList
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
cursorChildren property
cursorChildren:IChildList [read-only]

An list of the custom cursors being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, top-most windows, tooltips, and custom cursors. You can access the custom cursors through the cursorChildren property.

The IChildList object has methods like getChildAt() and properties like numChildren. For example, cursorChildren.numChildren gives the number of custom cursors (which will be either 0 or 1) and, if a custom cursor exists, you can access it as cursorChildren.getChildAt(0).

Implementation
    public function get cursorChildren():IChildList
document property
document:Object [read-write]

A reference to the document object. A document object is an Object at the top of the hierarchy of a Flex application, MXML component, or AS component.

Implementation
    public function get document():Object
    public function set document(value:Object):void
focusPane property
focusPane:Sprite [read-write]

A single Sprite shared among components used as an overlay for drawing focus. You share it if you parent a focused component, not if you are IFocusManagerComponent.

Implementation
    public function get focusPane():Sprite
    public function set focusPane(value:Sprite):void
loaderInfo property
loaderInfo:LoaderInfo [read-only]

The LoaderInfo object that represents information about the application.

Implementation
    public function get loaderInfo():LoaderInfo
numModalWindows property
numModalWindows:int [read-write]

The number of modal windows.

Modal windows don't allow clicking in another windows which would normally activate the FocusManager in that window. The PopUpManager modifies this count as it creates and destroy modal windows.

Implementation
    public function get numModalWindows():int
    public function set numModalWindows(value:int):void
popUpChildren property
popUpChildren:IChildList [read-only]

An list of the topMost (popup) windows being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, tooltips, and custom cursors. You can access the top-most windows through the popUpChildren property.

The IChildList object has methods like getChildAt() and properties like numChildren. For example, popUpChildren.numChildren gives the number of topmost windows and you can access them as popUpChildren.getChildAt(i).

Implementation
    public function get popUpChildren():IChildList
rawChildren property
rawChildren:IChildList [read-only]

A list of all children being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, tooltips, and custom cursors.

The IChildList object has methods like getChildAt() and properties like numChildren.

Implementation
    public function get rawChildren():IChildList
screen property
screen:Rectangle [read-only]

The size and position of the application window. The Rectangle object contains x, y, width, and height properties.

Implementation
    public function get screen():Rectangle
stage property
stage:Stage [read-only]

The flash.display.Stage that represents the application window mapped to this SystemManager

Implementation
    public function get stage():Stage
toolTipChildren property
toolTipChildren:IChildList [read-only]

A list of the tooltips being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, topmost windows, tooltips, and custom cursors.

The IChildList object has methods like getChildAt() and properties like numChildren. For example, toolTipChildren.numChildren gives the number of tooltips (which will be either 0 or 1) and, if a tooltip exists, you can access it as toolTipChildren.getChildAt(0).

Implementation
    public function get toolTipChildren():IChildList
topLevelSystemManager property
topLevelSystemManager:ISystemManager [read-only]

The ISystemManager responsible for the application window. This will be the same ISystemManager unless this application has been loaded into another application.

Implementation
    public function get topLevelSystemManager():ISystemManager
Method detail
activate () method
public function activate(f:IFocusManagerContainer):void

Activates the FocusManager in an IFocusManagerContainer.

Parameters
f:IFocusManagerContainer — IFocusManagerContainer the top-level window whose FocusManager should be activated.
addFocusManager () method
public function addFocusManager(f:IFocusManagerContainer):void

Registers a top-level window containing a FocusManager. Called by the FocusManager, generally not called by application code.

Parameters
f:IFocusManagerContainer — The top-level window in the application.
deactivate () method
public function deactivate(f:IFocusManagerContainer):void

Deactivates the FocusManager in an IFocusManagerContainer, and activate the FocusManager of the next highest window that is an IFocusManagerContainer.

Parameters
f:IFocusManagerContainer — IFocusManagerContainer the top-level window whose FocusManager should be deactivated.
getDefinitionByName () method
public function getDefinitionByName(name:String):Object

Converts the given String to a Class or package-level Function. Calls the appropriate ApplicationDomain.getDefinition() method based on whether you are loaded into another application or not.

Parameters
name:String — Name of class, for example "mx.video.VideoManager".

Returns
Object — The Class represented by the name, or null.
isFontFaceEmbedded () method
public function isFontFaceEmbedded(tf:TextFormat):Boolean

Returns true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.

Parameters
tf:TextFormat — The TextFormat class representing character formatting information.

Returns
Boolean — true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.
isTopLevel () method
public function isTopLevel():Boolean

Returns true if this ISystemManager is responsible for an application window, and false if this application has been loaded into another application.

Returns
Boolean — true if this ISystemManager is responsible for an application window.
removeFocusManager () method
public function removeFocusManager(f:IFocusManagerContainer):void

Unregisters a top-level window containing a FocusManager. Called by the FocusManager, generally not called by application code.

Parameters
f:IFocusManagerContainer — The top-level window in the application.


mx.managers.IToolTipManagerClient (Flex™ 2 Language Reference)

Interface IToolTipManagerClient | Properties | Methods
Package | mx.managers
Interface | public interface IToolTipManagerClient extends IFlexDisplayObject, IBitmapDrawable, IEventDispatcher
Implementors | UIComponent, UITextField

Components that implement IToolTipManagerClient can have tooltips and must have a toolTip getter/setter. The ToolTipManager class manages showing and hiding the tooltip on behalf of any component which is an IToolTipManagerClient.

See also

mx.controls.ToolTip
mx.managers.ToolTipManager
mx.core.IToolTip

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | alpha : Number The transparency of this object. | IFlexDisplayObject
Inherited | height : Number The height of this object, in pixels. | IFlexDisplayObject
Inherited | mask : DisplayObject The DisplayObject used to mask this object so that only part of it is actually drawn. | IFlexDisplayObject
Inherited | measuredHeight : Number The measured height of this object. | IFlexDisplayObject
Inherited | measuredWidth : Number The measured width of this object. | IFlexDisplayObject
Inherited | name : String The instance name of this object. | IFlexDisplayObject
Inherited | parent : DisplayObjectContainer The parent of this object. | IFlexDisplayObject
Inherited | scaleX : Number The horizontal scaling factor for this object. | IFlexDisplayObject
Inherited | scaleY : Number The vertical scaling factor for this object. | IFlexDisplayObject
 | toolTip : String The text of this component's tooltip. | IToolTipManagerClient
Inherited | visible : Boolean A flag that indicates whether this object is visible. | IFlexDisplayObject
Inherited | width : Number The width of this object, in pixels. | IFlexDisplayObject
Inherited | x : Number The horizontal position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Inherited | y : Number The vertical position of this object relative to its parent, in pixel coordinates. | IFlexDisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
IFlexDisplayObject
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
IFlexDisplayObject
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
toolTip property
toolTip:String [read-write]

The text of this component's tooltip.

Implementation
    public function get toolTip():String
    public function set toolTip(value:String):void


mx.managers.LayoutManager (Flex™ 2 Language Reference)

Class LayoutManager | Properties | Methods
Package | mx.managers
Class | public class LayoutManager
Inheritance | LayoutManager Inheritance EventDispatcher Inheritance Object

The LayoutManager is the engine behind Flex's measurement and layout strategy. Layout is performed in three phases; commit, measurement, and layout.

Each phase is distinct from the others and all UIComponents of one phase are processed prior to moving on to the next phase. During the processing of UIComponents in a phase, requests for UIComponents to get re-processed by some phase may occur. These requests are queued and are only processed during the next run of the phase.

The commit phase begins with a call to validateProperties(), which walks through a list (sorted by nesting level) of objects calling each object's validateProperties()method.

The objects in the list are processed by nesting order, with the most deeply nested object accessed first. This can also be referred to as bottom-up inside-out ordering.

This phase allows components whose contents depend on property settings to configure themselves prior to the measurement and the layout phases. For the sake of performance, sometimes a component's property setter method does not do all the work to update to the new property value. Instead, the property setter calls the invalidateProperties() method, deferring the work until this phase runs. This prevents unnecessary work if the property is set multiple times.

The measurement phase begins with a call to validateSize(), which walks through a list (sorted by nesting level) of objects calling each object's validateSize() method to determine if the object has changed in size.

If an object's invalidateSize() method was previously called, then the validateSize() method is called. If the size or position of the object was changed as a result of the validateSize() call, then the object's invalidateDisplayList() method is called, thus adding the object to the processing queue for the next run of the layout phase. Additionally, the object's parent is marked for both measurement and layout phases, by calling invalidateSize() and invalidateDisplayList() respectively.

The objects in the list are processed by nesting order, with the most deeply nested object accessed first. This can also be referred to as bottom-up inside-out ordering.

The layout phase begins with a call to the validateDisplayList() method, which walks through a list (reverse sorted by nesting level) of objects calling each object's validateDisplayList() method to request the object to size and position all components contained within it (i.e. its children).

If an object's invalidateDisplayList() method was previously called, then validateDisplayList() method for the object is called.

The objects in the list are processed in reversed nesting order, with the least deeply nested object accessed first. This can also be referred to as top-down or outside-in ordering.

In general, components do not override the validateProperties(),
  validateSize(), or validateDisplayList() methods.
  In the case of UIComponents, most components override the
  commitProperties(), measure(), or
  updateDisplayList() methods, which are called
  by the validateProperties(),
  validateSize(), or
  validateDisplayList() methods, respectively.

At application startup, a single instance of the LayoutManager is created and stored in the UIComponent.layoutManager property. All components are expected to use that instance. If you do not have access to the UIComponent object, you can also access the LayoutManager using the static LayoutManager.getInstance() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | usePhasedInstantiation : Boolean A flag that indicates whether the LayoutManager allows screen updates between phases. | LayoutManager
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LayoutManager()
Constructor.
LayoutManager
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getInstance():LayoutManager
[static] Returns the sole instance of this singleton class, creating it if it does not already exist.
LayoutManager
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
invalidateDisplayList(obj:ILayoutManagerClient):void
Called when a component changes in some way that its layout and/or visuals need to be changed.
LayoutManager
invalidateProperties(obj:ILayoutManagerClient):void
Adds an object to the list of components that want their validateProperties() method called.
LayoutManager
invalidateSize(obj:ILayoutManagerClient):void
Adds an object to the list of components that want their validateSize() method called.
LayoutManager
isInvalid():Boolean
Returns true if there are components that need validating; false if all components have been validated.
LayoutManager
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
validateClient(target:ILayoutManagerClient, skipDisplayList:Boolean = false):void
When properties are changed, components generally do not apply those changes immediately.
LayoutManager
validateNow():void
When properties are changed, components generally do not apply those changes immediately.
LayoutManager
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
usePhasedInstantiation property
usePhasedInstantiation:Boolean [read-write]

A flag that indicates whether the LayoutManager allows screen updates between phases. If true, measurement and layout are done in phases, one phase per screen update. All components have their validateProperties() and commitProperties() methods called until all their properties are validated. The screen will then be updated.

Then all components will have their validateSize() and measure() methods called until all components have been measured, then the screen will be updated again.

Finally, all components will have their validateDisplayList() and updateDisplayList() methods called until all components have been validated, and the screen will be updated again. If in the validation of one phase, an earlier phase gets invalidated, the LayoutManager starts over. This is more efficient when large numbers of components are being created an initialized. The framework is responsible for setting this property.

If false, all three phases are completed before the screen is updated.

Implementation
    public function get usePhasedInstantiation():Boolean
    public function set usePhasedInstantiation(value:Boolean):void
Constructor detail
LayoutManager () constructor
public function LayoutManager()

Constructor.

Method detail
getInstance () method
public static function getInstance():LayoutManager

Returns the sole instance of this singleton class, creating it if it does not already exist.

Returns
LayoutManager
invalidateDisplayList () method
public function invalidateDisplayList(obj:ILayoutManagerClient):void

Called when a component changes in some way that its layout and/or visuals need to be changed. In that case, it is necessary to run the component's layout algorithm, even if the component's size hasn't changed. For example, when a new child component is added, or a style property changes or the component has been given a new size by its parent.

Parameters
obj:ILayoutManagerClient — The object that changed.
invalidateProperties () method
public function invalidateProperties(obj:ILayoutManagerClient):void

Adds an object to the list of components that want their validateProperties() method called. A component should call this method when a property changes. Typically, a property setter method stores a the new value in a temporary variable and calls the invalidateProperties() method so that its validateProperties() and commitProperties() methods are called later, when the new value will actually be applied to the component and/or its children. The advantage of this strategy is that often, more than one property is changed at a time and the properties may interact with each other, or repeat some code as they are applied, or need to be applied in a specific order. This strategy allows the most efficient method of applying new property values.

Parameters
obj:ILayoutManagerClient — The object whose property changed.
invalidateSize () method
public function invalidateSize(obj:ILayoutManagerClient):void

Adds an object to the list of components that want their validateSize() method called. Called when an object's size changes.

An object's size can change for two reasons:

  1. The content of the object changes. For example, the size of a button changes when its label is changed.
  2. A script explicitly changes one of the following properties: minWidth, minHeight, explicitWidth, explicitHeight, maxWidth, or maxHeight.

When the first condition occurs, it's necessary to recalculate the measurements for the object. When the second occurs, it's not necessary to recalculate the measurements because the new size of the object is known. However, it's necessary to remeasure and relayout the object's parent.

Parameters
obj:ILayoutManagerClient — The object whose size changed.
isInvalid () method
public function isInvalid():Boolean

Returns true if there are components that need validating; false if all components have been validated.

Returns
Boolean
validateClient () method
public function validateClient(target:ILayoutManagerClient, skipDisplayList:Boolean = false):void

When properties are changed, components generally do not apply those changes immediately. Instead the components usually call one of the LayoutManager's invalidate methods and apply the properties at a later time. The actual property you set can be read back immediately, but if the property affects other properties in the component or its children or parents, those other properties may not be immediately updated.

To guarantee that the values are updated, you can call the validateClient() method. It updates all properties in all components whose nest level is greater than or equal to the target component before returning. Call this method only when necessary as it is a computationally intensive call.

Parameters
target:ILayoutManagerClient — The component passed in is used to test which components should be validated. All components contained by this component will have their validateProperties(), commitProperties(), validateSize(), measure(), validateDisplayList(), and updateDisplayList() methods called.
skipDisplayList:Boolean (default = false) — If true, does not call the validateDisplayList() and updateDisplayList() methods.
validateNow () method
public function validateNow():void

When properties are changed, components generally do not apply those changes immediately. Instead the components usually call one of the LayoutManager's invalidate methods and apply the properties at a later time. The actual property you set can be read back immediately, but if the property affects other properties in the component or its children or parents, those other properties may not be immediately updated. To guarantee that the values are updated, you can call the validateNow() method. It updates all properties in all components before returning. Call this method only when necessary as it is a computationally intensive call.


mx.managers.PopUpManager (Flex™ 2 Language Reference)

Class PopUpManager | Properties | Methods
Package | mx.managers
Class | public class PopUpManager
Inheritance | PopUpManager Inheritance Object

The PopUpManager singleton class creates new top-level windows and places or removes those windows from the layer on top of all other visible windows. See the SystemManager for a description of the layering. It is used for popup dialogs, menus, and dropdowns in the ComboBox control and in similar components.

The PopUpManager also provides modality, so that windows below the popup cannot receive mouse events, and also provides an event if the user clicks the mouse outside the window so the developer can choose to dismiss the window or warn the user.

See also

PopUpManagerChildList
TitleWindow layout container

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | addPopUp(window:IFlexDisplayObject, parent:DisplayObject, modal:Boolean = false, childList:String = null):void [static] Pops up a top-level window. | PopUpManager
 | bringToFront(popUp:IFlexDisplayObject):void [static] Makes sure a popup window is higher than other objects in its child list The SystemManager does this automatically if the popup is a top level window and is moused on, but otherwise you have to take care of this yourself. | PopUpManager
 | centerPopUp(popUp:IFlexDisplayObject):void [static] Centers a popup window over whatever window was used in the call to the createPopUp() or addPopUp() method. | PopUpManager
 | createPopUp(parent:DisplayObject, className:Class, modal:Boolean = false, childList:String = null):IFlexDisplayObject [static] Creates a top-level window and places it above other windows in the z-order. | PopUpManager
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removePopUp(popUp:IFlexDisplayObject):void [static] Removes a popup window popped up by the createPopUp() or addPopUp() method. | PopUpManager
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
addPopUp () method
public static function addPopUp(window:IFlexDisplayObject, parent:DisplayObject, modal:Boolean = false, childList:String = null):void

Pops up a top-level window. It is good practice to call removePopUp() to remove popups created by using the createPopUp() method. If the class implements IFocusManagerContainer, the window will have its own FocusManager so that, if the user uses the TAB key to navigate between controls, only the controls in the window will be accessed.

Example

var tw = new TitleWindow();
tw.title = "My Title";
mx.managers.PopUpManager.addPopUp(tw, pnl, false);

Creates a popup window using the tw instance of the TitleWindow class and pnl as the Sprite for determining where to place the popup. It is defined to be a non-modal window.

Parameters
window:IFlexDisplayObject — The IFlexDisplayObject to be popped up.
parent:DisplayObject — DisplayObject to be used for determining which SystemManager's layers to use and optionally the reference point for centering the new top level window. It may not be the actual parent of the popup as all popups are parented by the SystemManager.
modal:Boolean (default = false) — If true, the window is modal which means that the user will not be able to interact with other popups until the window is removed.
childList:String (default = null) — The child list in which to add the pop-up. One of PopUpManagerChildList.APPLICATION, PopUpManagerChildList.POPUP, or PopUpManagerChildList.PARENT (default).

See also

PopUpManagerChildList
bringToFront () method
public static function bringToFront(popUp:IFlexDisplayObject):void

Makes sure a popup window is higher than other objects in its child list The SystemManager does this automatically if the popup is a top level window and is moused on, but otherwise you have to take care of this yourself.

Parameters
popUp:IFlexDisplayObject — IFlexDisplayObject representing the popup.
centerPopUp () method
public static function centerPopUp(popUp:IFlexDisplayObject):void

Centers a popup window over whatever window was used in the call to the createPopUp() or addPopUp() method.

Note that the position of the popup window may not change immediately after this call since Flex may wait to measure and layout the popup window before centering it.

Parameters
popUp:IFlexDisplayObject — IFlexDisplayObject representing the popup.
createPopUp () method
public static function createPopUp(parent:DisplayObject, className:Class, modal:Boolean = false, childList:String = null):IFlexDisplayObject

Creates a top-level window and places it above other windows in the z-order. It is good practice to call the removePopUp() method to remove popups created by using the createPopUp() method. If the class implements IFocusManagerContainer, the window will have its own FocusManager so that, if the user uses the TAB key to navigate between controls, only the controls in the window will be accessed.

Example

pop = mx.managers.PopUpManager.createPopUp(pnl, TitleWindow, false);

Creates a popup window based on the TitleWindow class, using pnl as the MovieClip for determining where to place the popup. It is defined to be a non-modal window meaning that other windows can receive mouse events

Parameters
parent:DisplayObject — DisplayObject to be used for determining which SystemManager's layers to use and optionally the reference point for centering the new top level window. It may not be the actual parent of the popup as all popups are parented by the SystemManager.
className:Class — Class of object that is to be created for the popup. The class must implement IFlexDisplayObject.
modal:Boolean (default = false) — If true, the window is modal which means that the user will not be able to interact with other popups until the window is removed.
childList:String (default = null) — The child list in which to add the popup. One of PopUpManagerChildList.APPLICATION, PopUpManagerChildList.POPUP, or PopUpManagerChildList.PARENT (default).

Returns
IFlexDisplayObject — Reference to new top-level window.

See also

PopUpManagerChildList
removePopUp () method
public static function removePopUp(popUp:IFlexDisplayObject):void

Removes a popup window popped up by the createPopUp() or addPopUp() method.

Parameters
popUp:IFlexDisplayObject — The IFlexDisplayObject representing the popup window.


mx.managers.PopUpManagerChildList (Flex™ 2 Language Reference)

Class PopUpManagerChildList | Properties | Methods | Constants
Package | mx.managers
Class | public final class PopUpManagerChildList
Inheritance | PopUpManagerChildList Inheritance Object

The PopUpManagerChildList class defines the constant values for the detail property of the PopUpManager addPopUp() and createPopUp() methods.

See also

PopUpManager

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | APPLICATION : String = "application" [static] Indicates that the popup is placed in the same child list as the application. | PopUpManagerChildList
 | PARENT : String = "parent" [static] Indicates that the popup is placed in whatever child list the parent component is in. | PopUpManagerChildList
 | POPUP : String = "popup" [static] Indicates that the popup is placed in the popup child list which will cause it to float over other popups in the application layer. | PopUpManagerChildList
Constant detail
APPLICATION constant
public static const APPLICATION:String = "application"

Indicates that the popup is placed in the same child list as the application.

PARENT constant
public static const PARENT:String = "parent"

Indicates that the popup is placed in whatever child list the parent component is in.

POPUP constant
public static const POPUP:String = "popup"

Indicates that the popup is placed in the popup child list which will cause it to float over other popups in the application layer.


mx.managers.SystemManager (Flex™ 2 Language Reference)

Class SystemManager | Properties | Methods | Events
Package | mx.managers
Class | public class SystemManager
Inheritance | SystemManager Inheritance MovieClip Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IChildList, IFlexDisplayObject, ISystemManager

The SystemManager class manages an application window. Every application that runs on the desktop or in a browser has an area where the visuals of the application are displayed. It may be a window in the operating system or an area within the browser. That area is an application window and different from an instance of mx.core.Application, which is the main, or top-level, window within an application.

Every application has a SystemManager. The SystemManager sends an event if the size of the application window changes (you cannot change it from within the application, but only through interaction with the operating system window or browser). It parents all displayable things within the application like the main mx.core.Application instance and all popups, tooltips, cursors, and so on. Any object parented by the SystemManager is considered to be a top-level window, even tooltips and cursors.

The SystemManager also switches focus between top-level windows if there are more than one IFocusManagerContainer displayed and users are interacting with components within the IFocusManagerContainers.

All keyboard and mouse activity that is not expressly trapped is seen by the SystemManager, making it a good place to monitor activity should you need to do so.

If an application is loaded into another application, a SystemManager will still be created, but will not manage an application window, depending on security and domain rules. Instead, it could manage the content of the Loader that loaded it.

The SystemManager maintains multiple lists of children, one each for tooltips, cursors, popup windows. This is how it ensures that popup windows "float" above the main application windows and that tooltips "float" above that and cursors above that. If you simply examine the numChildren property or call the getChildAt() method on the SystemManager, you are accessing the main application window and any other windows that aren't popped up. To get the list of all windows, including popups, tooltips and cursors, use the rawChildren property.

The SystemManager is the first display class created within an application. It is responsible for creating an mx.preloaders.Preloader that displays and mx.preloaders.DownloadProgressBar while the application finishes loading, then creates the mx.core.Application instance.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | application : IUIComponent [read-only] The application parented by this SystemManager. | SystemManager
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentFrame : int Specifies the number of the frame in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabel : String The current label in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
Inherited | currentLabels : Array Returns an array of FrameLabel objects from the current scene. | MovieClip
Inherited | currentScene : Scene The current scene in which the playhead is located in the timeline of the MovieClip instance. | MovieClip
 | cursorChildren : IChildList [read-only] An list of the custom cursors being parented by this ISystemManager. | SystemManager
 | document : Object A reference to the document object. | SystemManager
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
 | embeddedFontList : Object [read-only] The list of embedded fonts in this application. | SystemManager
Inherited | enabled : Boolean A Boolean value that indicates whether a movie clip is enabled. | MovieClip
 | explicitHeight : Number The explicit width of this object. | SystemManager
 | explicitWidth : Number The explicit width of this object. | SystemManager
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
 | focusPane : Sprite The focus pane associated with this object. | SystemManager
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | framesLoaded : int The number of frames that are loaded from a streaming SWF file. | MovieClip
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
 | height : Number The height of this object. | SystemManager
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | measuredHeight : Number [read-only] The measuredHeight is the explicit or measuredHeight of the main mx.core.Application window or the starting height of the SWF if the main window has not yet been created or does not exist. | SystemManager
 | measuredWidth : Number [read-only] The measuredWidth is the explicit or measuredWidth of the main mx.core.Application window, or the starting width of the SWF if the main window has not yet been created or does not exist. | SystemManager
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | numChildren : int [read-only] The number of non-floating windows. | SystemManager
 | numModalWindows : int Number of modal windows. | SystemManager
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
 | popUpChildren : IChildList [read-only] An list of the topMost (popup) windows being parented by this ISystemManager. | SystemManager
 | preloaderBackgroundAlpha : Number [read-only] The background alpha used by the child of the preloader. | SystemManager
 | preloaderBackgroundColor : uint [read-only] The background color used by the child of the preloader. | SystemManager
 | preloaderBackgroundImage : Object [read-only] The background color used by the child of the preloader. | SystemManager
 | preloaderBackgroundSize : String [read-only] The background size used by the child of the preloader. | SystemManager
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rawChildren : IChildList [read-only] A list of all children being parented by this ISystemManager. | SystemManager
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scenes : Array An array of Scene objects, each listing the name, the number of frames, and the frame labels for a scene in the MovieClip instance. | MovieClip
 | screen : Rectangle [read-only] The size and position of the application window. | SystemManager
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
 | toolTipChildren : IChildList [read-only] A list of the tooltips being parented by this ISystemManager. | SystemManager
 | topLevelSystemManager : ISystemManager [read-only] Returns the SystemManager responsible for the application window. | SystemManager
Inherited | totalFrames : int The total number of frames in the MovieClip instance. | MovieClip
Inherited | trackAsMenu : Boolean Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events. | MovieClip
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
 | width : Number The width of this object. | SystemManager
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SystemManager()
Constructor.
SystemManager
activate(f:IFocusManagerContainer):void
Activates the FocusManager in an IFocusManagerContainer.
SystemManager
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
addFocusManager(f:IFocusManagerContainer):void
Registers a top-level window containing a FocusManager.
SystemManager
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
create(params:Object = null):Object
Entry point for creating the application.
SystemManager
deactivate(f:IFocusManagerContainer):void
Deactivates the FocusManager in an IFocusManagerContainer, and activate the FocusManager of the next highest window that is an IFocusManagerContainer.
SystemManager
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
getDefinitionByName(name:String):Object
Converts the given String to a Class or package-level Function.
SystemManager
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height.
SystemManager
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width.
SystemManager
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
getSWFRoot(object:Object):DisplayObject
[static] Returns the root DisplayObject that loaded the application.
SystemManager
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
gotoAndPlay(frame:Object, scene:String = null):void
Starts playing the SWF file at the specified frame.
MovieClip
Inherited
gotoAndStop(frame:Object, scene:String = null):void
Brings the playhead to the specified frame of the movie clip and stops it there.
MovieClip
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
info():Object
Overridden by autogenerated code.
SystemManager
isFontFaceEmbedded(tf:TextFormat):Boolean
Returns true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.
SystemManager
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
isTopLevel():Boolean
Returns true if this ISystemManager is responsible for an application window, and false if this application has been loaded into another application.
SystemManager
isTopLevelWindow(object:DisplayObject):Boolean
Returns true if the DisplayObject is the top-level window.
SystemManager
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Calling the move() method has no effect as it is directly mapped to the application window or the loader.
SystemManager
Inherited
nextFrame():void
Sends the playhead to the next frame and stops it.
MovieClip
Inherited
nextScene():void
Moves the playhead to the next scene of the MovieClip instance.
MovieClip
Inherited
play():void
Moves the playhead in the timeline of the movie clip.
MovieClip
Inherited
prevFrame():void
Sends the playhead to the previous frame and stops it.
MovieClip
Inherited
prevScene():void
Moves the playhead to the previous scene of the MovieClip instance.
MovieClip
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
removeFocusManager(f:IFocusManagerContainer):void
Unregisters a top-level window containing a FocusManager.
SystemManager
setActualSize(newWidth:Number, newHeight:Number):void
Calling the setActualSize() method has no effect if it is directly mapped to the application window and if it is the top-level window.
SystemManager
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stop():void
Stops the playhead in the movie clip.
MovieClip
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
 | applicationComplete | Dispatched when the application has finished initializing | SystemManager
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
 | idle | Dispatched every 100 milliseconds when there has been no keyboard or mouse activity for 1 second. | SystemManager
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
 | resize | Dispatched when the Stage is resized. | SystemManager
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
application property
application:IUIComponent [read-only]

The application parented by this SystemManager. SystemManagers create an instance of an Application even if they are loaded into another Application. Thus, this may not match mx.core.Application.application if the SWF has been loaded into another application.

Note that this property is not typed as mx.core.Application because of load-time performance considerations but can be coerced into an mx.core.Application.

Implementation
    public function get application():IUIComponent
cursorChildren property
cursorChildren:IChildList [read-only]

An list of the custom cursors being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, top-most windows, tooltips, and custom cursors. You can access the custom cursors through the cursorChildren property.

The IChildList object has methods like getChildAt() and properties like numChildren. For example, cursorChildren.numChildren gives the number of custom cursors (which will be either 0 or 1) and, if a custom cursor exists, you can access it as cursorChildren.getChildAt(0).

Implementation
    public function get cursorChildren():IChildList
document property
document:Object [read-write]

A reference to the document object. A document object is an Object at the top of the hierarchy of a Flex application, MXML component, or AS component.

Implementation
    public function get document():Object
    public function set document(value:Object):void
embeddedFontList property
embeddedFontList:Object [read-only]

The list of embedded fonts in this application.

Implementation
    public function get embeddedFontList():Object
explicitHeight property
explicitHeight:Number [read-write]

The explicit width of this object. For the SystemManager this should always be NaN unless the application was loaded into another application. If the application was not loaded into another application, setting this value has no effect.

Implementation
    public function get explicitHeight():Number
    public function set explicitHeight(value:Number):void
explicitWidth property
explicitWidth:Number [read-write]

The explicit width of this object. For the SystemManager this should always be NaN unless the application was loaded into another application. If the application was not loaded into another application, setting this value has no effect.

Implementation
    public function get explicitWidth():Number
    public function set explicitWidth(value:Number):void
focusPane property
focusPane:Sprite [read-write]

The focus pane associated with this object. An object has a focus pane when one of its children has focus.

Implementation
    public function get focusPane():Sprite
    public function set focusPane(value:Sprite):void
height property
height:Number [read-write]

The height of this object. For the SystemManager this should always be the width of the stage unless the application was loaded into another application. If the application was not loaded into another application, setting this value has no effect.

Implementation
    public function get height():Number
    public function set height(value:Number):void
measuredHeight property
measuredHeight:Number [read-only]

The measuredHeight is the explicit or measuredHeight of the main mx.core.Application window or the starting height of the SWF if the main window has not yet been created or does not exist.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measuredWidth is the explicit or measuredWidth of the main mx.core.Application window, or the starting width of the SWF if the main window has not yet been created or does not exist.

Implementation
    public function get measuredWidth():Number
numChildren property
numChildren:int [read-only]

The number of non-floating windows. This is the main application window plus any other windows added to the SystemManager that are not popups, tooltips or cursors.

Implementation
    public function get numChildren():int
numModalWindows property
numModalWindows:int [read-write]

Number of modal windows. Modal windows don't allow clicking in another windows which would normally activate the FocusManager in that window. The PopUpManager modifies this count as it creates and destroy modal windows.

Implementation
    public function get numModalWindows():int
    public function set numModalWindows(value:int):void
popUpChildren property
popUpChildren:IChildList [read-only]

An list of the topMost (popup) windows being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, tooltips, and custom cursors. You can access the top-most windows through the popUpChildren property.

The IChildList object has methods like getChildAt() and properties like numChildren. For example, popUpChildren.numChildren gives the number of topmost windows and you can access them as popUpChildren.getChildAt(i).

Implementation
    public function get popUpChildren():IChildList
preloaderBackgroundAlpha property
preloaderBackgroundAlpha:Number [read-only]

The background alpha used by the child of the preloader.

Implementation
    public function get preloaderBackgroundAlpha():Number
preloaderBackgroundColor property
preloaderBackgroundColor:uint [read-only]

The background color used by the child of the preloader.

Implementation
    public function get preloaderBackgroundColor():uint
preloaderBackgroundImage property
preloaderBackgroundImage:Object [read-only]

The background color used by the child of the preloader.

Implementation
    public function get preloaderBackgroundImage():Object
preloaderBackgroundSize property
preloaderBackgroundSize:String [read-only]

The background size used by the child of the preloader.

Implementation
    public function get preloaderBackgroundSize():String
rawChildren property
rawChildren:IChildList [read-only]

A list of all children being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, tooltips, and custom cursors.

The IChildList object has methods like getChildAt() and properties like numChildren.

Implementation
    public function get rawChildren():IChildList
screen property
screen:Rectangle [read-only]

The size and position of the application window. The Rectangle object contains x, y, width, and height properties.

Implementation
    public function get screen():Rectangle
toolTipChildren property
toolTipChildren:IChildList [read-only]

A list of the tooltips being parented by this ISystemManager.

An ISystemManager has various types of children, such as the Application, popups, topmost windows, tooltips, and custom cursors.

The IChildList object has methods like getChildAt() and properties like numChildren. For example, toolTipChildren.numChildren gives the number of tooltips (which will be either 0 or 1) and, if a tooltip exists, you can access it as toolTipChildren.getChildAt(0).

Implementation
    public function get toolTipChildren():IChildList
topLevelSystemManager property
topLevelSystemManager:ISystemManager [read-only]

Returns the SystemManager responsible for the application window. This will be the same SystemManager unless this application has been loaded into another application.

Implementation
    public function get topLevelSystemManager():ISystemManager
width property
width:Number [read-write]

The width of this object. For the SystemManager this should always be the width of the stage unless the application was loaded into another application. If the application was not loaded into another application, setting this value will have no effect.

Implementation
    public function get width():Number
    public function set width(value:Number):void
Constructor detail
SystemManager () constructor
public function SystemManager()

Constructor.

This is the starting point for all Flex applications. This class is set to be the root class of a Flex SWF file. The Player instantiates an instance of this class, causing this constructor to be called.

Method detail
activate () method
public function activate(f:IFocusManagerContainer):void

Activates the FocusManager in an IFocusManagerContainer.

Parameters
f:IFocusManagerContainer — IFocusManagerContainer the top-level window whose FocusManager should be activated.
addFocusManager () method
public function addFocusManager(f:IFocusManagerContainer):void

Registers a top-level window containing a FocusManager. Called by the FocusManager, generally not called by application code.

Parameters
f:IFocusManagerContainer — The top-level window in the application.
create () method
public function create(params:Object = null):Object

Entry point for creating the application. Do not call this directly. It is called by Flex.

Parameters
params:Object (default = null)

Returns
Object
deactivate () method
public function deactivate(f:IFocusManagerContainer):void

Deactivates the FocusManager in an IFocusManagerContainer, and activate the FocusManager of the next highest window that is an IFocusManagerContainer.

Parameters
f:IFocusManagerContainer — IFocusManagerContainer the top-level window whose FocusManager should be deactivated.
getDefinitionByName () method
public function getDefinitionByName(name:String):Object

Converts the given String to a Class or package-level Function. Calls the appropriate ApplicationDomain.getDefinition() method based on whether you are loaded into another application or not.

Parameters
name:String — Name of class, for example "mx.video.VideoManager".

Returns
Object — The Class represented by the name, or null.
getExplicitOrMeasuredHeight () method
public function getExplicitOrMeasuredHeight():Number

A convenience method for determining whether to use the explicit or measured height.

Returns
Number — A Number which is the explicitHeight if defined, or the measuredHeight property if not.
getExplicitOrMeasuredWidth () method
public function getExplicitOrMeasuredWidth():Number

A convenience method for determining whether to use the explicit or measured width.

Returns
Number — A Number which is the explicitWidth if defined, or the measuredWidth property if not.
getSWFRoot () method
public static function getSWFRoot(object:Object):DisplayObject

Returns the root DisplayObject that loaded the application.

Parameters
object:Object — Any Object.

Returns
DisplayObject — The root DisplayObject for the SWF file that actually loaded the class.
info () method
public function info():Object

Overridden by autogenerated code.

Returns
Object
isFontFaceEmbedded () method
public function isFontFaceEmbedded(tf:TextFormat):Boolean

Returns true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.

Parameters
tf:TextFormat — The TextFormat class representing character formatting information.

Returns
Boolean — true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.
isTopLevel () method
public function isTopLevel():Boolean

Returns true if this ISystemManager is responsible for an application window, and false if this application has been loaded into another application.

Returns
Boolean — true if this ISystemManager is responsible for an application window.
isTopLevelWindow () method
public function isTopLevelWindow(object:DisplayObject):Boolean

Returns true if the DisplayObject is the top-level window.

Parameters
object:DisplayObject

Returns
Boolean — true if the DisplayObject is the top-level window.
move () method
public function move(x:Number, y:Number):void

Calling the move() method has no effect as it is directly mapped to the application window or the loader.

Parameters
x:Number — The new x coordinate.
y:Number — The new y coordinate.
removeFocusManager () method
public function removeFocusManager(f:IFocusManagerContainer):void

Unregisters a top-level window containing a FocusManager. Called by the FocusManager, generally not called by application code.

Parameters
f:IFocusManagerContainer — The top-level window in the application.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Calling the setActualSize() method has no effect if it is directly mapped to the application window and if it is the top-level window. Otherwise attempts to resize itself, clipping children if needed.

Parameters
newWidth:Number — The new width.
newHeight:Number — The new height.
Event detail
applicationComplete event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.APPLICATION_COMPLETE

Dispatched when the application has finished initializing

The FlexEvent.APPLICATION_COMPLETE constant defines the value of the type property of the event object for a applicationComplete event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
idle event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.IDLE

Dispatched every 100 milliseconds when there has been no keyboard or mouse activity for 1 second.

The FlexEvent.IDLE constant defines the value of the type property of the event object for a idle event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
resize event
Event object type: flash.events.Event
Event.type property = flash.events.Event.RESIZE

Dispatched when the Stage is resized.

Defines the value of the type property of a resize event object.

This event has the following properties:

Property | Value
bubbles | false
cancelable | false; there is no default behavior to cancel.
currentTarget | The object that is actively processing the Event object with an event listener.
target | The Stage object.


mx.managers.ToolTipManager (Flex™ 2 Language Reference)

Class ToolTipManager | Properties | Methods
Package | mx.managers
Class | public class ToolTipManager
Inheritance | ToolTipManager Inheritance EventDispatcher Inheritance Object

The ToolTipManager lets you set basic ToolTip and error tip functionality, such as display delay and the disabling of ToolTips.

See also

mx.controls.ToolTip
mx.validators.Validator
Using the ToolTip Manager
Using dynamic ToolTip text

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currentTarget : DisplayObject [static] The UIComponent that is currently displaying a ToolTip, or null if none is. | ToolTipManager
 | currentToolTip : IToolTip [static] The ToolTip object that is currently visible, or null if none is shown. | ToolTipManager
 | enabled : Boolean = true [static] If true, the ToolTipManager will automatically show ToolTips when the user moves the mouse pointer over components. | ToolTipManager
 | hideDelay : Number = 10000 [static] The amount of time, in milliseconds, that Flex waits to hide the ToolTip after it appears. | ToolTipManager
 | hideEffect : Effect [static] The effect that plays when a ToolTip is hidden, or null if the ToolTip should disappear with no effect. | ToolTipManager
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | scrubDelay : Number = 100 [static] The amount of time, in milliseconds, that a user can take when moving the mouse between controls before Flex again waits for the duration of showDelay to display a ToolTip. | ToolTipManager
 | showDelay : Number = 500 [static] The amount of time, in milliseconds, that Flex waits before displaying the ToolTip box once a user moves the mouse over a component that has a ToolTip. | ToolTipManager
 | showEffect : Effect [static] The effect that plays when a ToolTip is shown, or null if the ToolTip should appear with no effect. | ToolTipManager
 | toolTipClass : Class [static] The class to use for creating ToolTips. | ToolTipManager
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
createToolTip(text:String, x:Number, y:Number, errorTipBorderStyle:String = null, context:IUIComponent = null):ToolTip
[static] Creates an instance of the ToolTip class with the specified text and displays it at the specified location in stage coordinates.
ToolTipManager
destroyToolTip(toolTip:IToolTip):void
[static] Destroys a specified ToolTip that was created by the createToolTip() method.
ToolTipManager
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
currentTarget property
public static var currentTarget:DisplayObject

The UIComponent that is currently displaying a ToolTip, or null if none is.

currentToolTip property
public static var currentToolTip:IToolTip

The ToolTip object that is currently visible, or null if none is shown.

enabled property
public static var enabled:Boolean = true

If true, the ToolTipManager will automatically show ToolTips when the user moves the mouse pointer over components. If false, no ToolTips will be shown.

The default value is true.

hideDelay property
public static var hideDelay:Number = 10000

The amount of time, in milliseconds, that Flex waits to hide the ToolTip after it appears. Once Flex hides a ToolTip, the user must move the mouse off the component and then back onto it to see the ToolTip again. If you set hideDelay to Infinity, Flex does not hide the ToolTip until the user triggers an event, such as moving the mouse off of the component.

The default value is 10000.

hideEffect property
public static var hideEffect:Effect

The effect that plays when a ToolTip is hidden, or null if the ToolTip should disappear with no effect.

The default value is null.

scrubDelay property
public static var scrubDelay:Number = 100

The amount of time, in milliseconds, that a user can take when moving the mouse between controls before Flex again waits for the duration of showDelay to display a ToolTip.

This setting is useful if the user moves quickly from one control to another; after displaying the first ToolTip, Flex will display the others immediately rather than waiting. The shorter the setting for scrubDelay, the more likely that the user must wait for an amount of time specified by showDelay in order to see the next ToolTip. A good use of this property is if you have several buttons on a toolbar, and the user will quickly scan across them to see brief descriptions of their functionality.

The default value is 100.

showDelay property
public static var showDelay:Number = 500

The amount of time, in milliseconds, that Flex waits before displaying the ToolTip box once a user moves the mouse over a component that has a ToolTip. To make the ToolTip appear instantly, set showDelay to 0.

The default value is 500.

showEffect property
public static var showEffect:Effect

The effect that plays when a ToolTip is shown, or null if the ToolTip should appear with no effect.

The default value is null.

toolTipClass property
public static var toolTipClass:Class

The class to use for creating ToolTips.

The default value is mx.controls.ToolTip.

Method detail
createToolTip () method
public static function createToolTip(text:String, x:Number, y:Number, errorTipBorderStyle:String = null, context:IUIComponent = null):ToolTip

Creates an instance of the ToolTip class with the specified text and displays it at the specified location in stage coordinates.

ToolTips appear in their own layer, on top of everything except cursors.

The standard way of using ToolTips is to let the ToolTipManager automatically show and hide them as the user moves the mouse over the objects that have the toolTip property set. You can turn off this automatic ToolTip management by setting the ToolTipManager's enabled property to false.

By contrast, this method—along with hideToolTip()—gives you programmatic control over ToolTips. You can show them when and where you choose, and you can even show more than one at once if you need to. (The ToolTipManager never does this, because it is generally confusing to the user).

This method first creates a new instance of ToolTip and calls the addChild() method to put it into the SystemManager's toolTips layer. If you are showing an error tip, it sets the appropriate styles. Then it sets the text for the ToolTip, sizes the ToolTip based on its text, and positions it where you specified.

You must save the reference to the ToolTip that this method returns so that you can pass it to the hideToolTip() method.

Parameters
text:String — The text to display in the ToolTip instance.
x:Number — The horizontal coordinate of the ToolTip in stage coordinates. In case of multiple stages, the relevant stage is determined from the context argument.
y:Number — The vertical coordinate of the ToolTip in stage coordinates. In case of multiple stages, the relevant stage is determined from the context argument.
errorTipBorderStyle:String (default = null) — The border style of an error tip. This method argument can be null, "errorTipRight", "errorTipAbove", or "errorTipBelow". If it is null, then the createToolTip() method creates a normal ToolTip. If it is "errorTipRight", "errorTipAbove", or "errorTipBelow", then the createToolTip() method creates an error tip, and this parameter determines where the arrow of the error tip points to (the error's target). For example, if you pass "errorTipRight", Flex positions the error tip (via the x and y arguments) to the right of the error target; the arrow is on the left edge of the error tip.
context:IUIComponent (default = null) — This property is not currently used.

Returns
ToolTip — The newly created ToolTip.
destroyToolTip () method
public static function destroyToolTip(toolTip:IToolTip):void

Destroys a specified ToolTip that was created by the createToolTip() method.

This method calls the removeChild() method to remove the specified ToolTip from the SystemManager's ToolTips layer. It will then be garbage-collected unless you keep a reference to it.

You should not call this method on the ToolTipManager's currentToolTip.

Parameters
toolTip:IToolTip — The ToolTip instance to destroy.


mx.messaging Summary (Flex™ 2 Language Reference)

Package mx.messaging | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.messaging package contains the messaging classes used with Flex Data Services.

Classes
Class | Description
Channel | The Channel class is the base message channel class that all channels in the messaging system must extend.
ChannelSet | The ChannelSet is a set of Channels that are used to send messages to a target destination.
Consumer | A Consumer subscribes to a destination to receive messages.
MessageAgent | The MessageAgent class provides the basic low-level functionality common to message handling for a destination. Note: For advanced use only.
MessageResponder | The MessageResponder class handles a successful result or fault from a message destination.
Producer | A Producer sends messages to a destination.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.messaging.Channel (Flex™ 2 Language Reference)

Class Channel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging
Class | public class Channel
Inheritance | Channel Inheritance EventDispatcher Inheritance Object
Subclasses | PollingChannel

The Channel class is the base message channel class that all channels in the messaging system must extend.

Channels are specific protocol-based conduits for messages sent between MessageAgents and remote destinations. Preconfigured channels are obtained within the framework using the ServerConfig.getChannel() method. You can create a Channel directly using the new operator and add it to a ChannelSet directly.

Channels represent a physical connection to a remote endpoint. Channels are shared across destinations by default. This means that a client targetting different destinations may use the same Channel to communicate with these destinations.

Note: This class is for advanced use only. Use this class for creating custom channels like the existing RTMPChannel, AMFChannel, and HTTPChannel.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | channelSets : Array [read-only] Provides access to the ChannelSets connected to the Channel. | Channel
 | connected : Boolean [read-only] Indicates whether this channel has established a connection to the remote destination. | Channel
 | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | endpoint : String [read-only] Provides access to the endpoint for this channel. | Channel
 | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
 | id : String [read-only] Provides access to the id of this channel. | Channel
 | protocol : String [read-only] Provides access to the protocol that the channel uses. | Channel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | reconnecting : Boolean [read-only] Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
 | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
 | uri : String [read-only] Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Channel(id:String, uri:String)
Constructs an instance of a generic Channel that connects to the specified endpoint URI.
Channel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
 | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
 | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
 | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
 | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
 | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
 | internalConnect():void Connects the Channel to its endpoint. | Channel
 | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
 | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Event |  | Summary | Defined by
 | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
 | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
 | channelFault | Dispatched after the channel has faulted. | Channel
 | message | Dispatched when a channel receives a message from its endpoint. | Channel
 | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
channelSets property
channelSets:Array [read-only]

Provides access to the ChannelSets connected to the Channel.

Implementation
    public function get channelSets():Array
connected property
connected:Boolean [read-only]

Indicates whether this channel has established a connection to the remote destination.

This property can be used as the source for data binding.

Implementation
    public function get connected():Boolean
connectTimeout property
connectTimeout:int [read-write]

Provides access to the connect timeout in seconds for the channel. A value of 0 or below indicates that a connect attempt will never be timed out on the client. For channels that are configured to failover, this value is the total time to wait for a connection to be established. It is not reset for each failover URI that the channel may attempt to connect to.

Implementation
    public function get connectTimeout():int
    public function set connectTimeout(value:int):void
endpoint property
endpoint:String [read-only]

Provides access to the endpoint for this channel. This value is calculated based on the value of the uri property.

Implementation
    public function get endpoint():String
failoverURIs property
failoverURIs:Array [read-write]

Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered.

Implementation
    public function get failoverURIs():Array
    public function set failoverURIs(value:Array):void
id property
id:String [read-only]

Provides access to the id of this channel.

Implementation
    public function get id():String
protocol property
protocol:String [read-only]

Provides access to the protocol that the channel uses.

Note: Subclasses of Channel must override this method and return a string that represents their supported protocol. Examples of supported protocol strings are "rtmp", "http" or "https".

Implementation
    public function get protocol():String
reconnecting property
reconnecting:Boolean [read-only]

Indicates whether this channel is in the process of reconnecting to an alternate endpoint.

This property can be used as the source for data binding.

Implementation
    public function get reconnecting():Boolean
requestTimeout property
requestTimeout:int [read-write]

Provides access to the default request timeout in seconds for the channel. A value of 0 or below indicates that outbound requests will never be timed out on the client.

Request timeouts are most useful for RPC style messaging that requires a response from the remote destination.

Implementation
    public function get requestTimeout():int
    public function set requestTimeout(value:int):void
uri property
uri:String [read-only]

Provides access to the URI used to create the whole endpoint URI for this channel. The URI can be a partial path, in which case the full endpoint URI is computed as necessary.

Implementation
    public function get uri():String
Constructor detail
Channel () constructor
public function Channel(id:String, uri:String)

Constructs an instance of a generic Channel that connects to the specified endpoint URI. Note: The Channel type should not be constructed directly. Instead create instances of protocol specific subclasses such as RTMPChannel or AMFChannel.

Parameters
id:String — The id of this channel.
uri:String — The endpoint URI for this channel.
Method detail
applySettings () method
public function applySettings(settings:XML):void

Subclasses should override this method to apply any settings that may be necessary for an individual channel. Make sure to call super.applySettings() to apply common settings for the channel.

Parameters
settings:XML — XML fragment of the services-config.xml file for this channel. The following fragement includes the <channel> tag with all of its configuration settings:
      <channel id="my-amf" type="mx.messaging.channels.AMFChannel">
        <endpoint uri="/dev/messagebroker/amf" type="flex.messaging.endpoints.AmfEndpoint"/>
        <properties>
          <polling-enabled>false</polling-enabled>
        </properties>
      </channel>
connect () method
public final function connect(channelSet:ChannelSet):void

Connects the ChannelSet to the Channel. If the Channel has not yet connected to its endpoint, it attempts to do so. Channel subclasses must override the internalConnect() method, and call the connectSuccess() method once the underlying connection is established.

Parameters
channelSet:ChannelSet — The ChannelSet to connect to the Channel.
connectFailed () method
protected function connectFailed(event:ChannelFaultEvent):void

Processes a failed internal connect and dispatches the FAULT event for the channel. If the Channel has failoverURI values, it will attempt to reconnect automatically by trying these URI values in order until a connection is established or the available values are exhausted.

Parameters
event:ChannelFaultEvent — The ChannelFaultEvent for the failed connect.
connectSuccess () method
protected function connectSuccess():void

Processes a successful internal connect and dispatches the CONNECT event for the Channel.

connectTimeoutHandler () method
protected function connectTimeoutHandler(event:TimerEvent):void

Handles a connect timeout by dispatching a ChannelFaultEvent. Subtypes may overide this to shutdown the current connect attempt but must call super.connectTimeoutHandler(event).

Parameters
event:TimerEvent — The timer event indicating that the connect timeout has been reached.
disconnect () method
public final function disconnect(channelSet:ChannelSet):void

Disconnects the ChannelSet from the Channel. If the Channel is connected to its endpoint and it has no more connected ChannelSets it will internally disconnect.

Channel subclasses need to override the internalDisconnect() method, and call the disconnectSuccess() method when the underlying connection has been terminated.

Parameters
channelSet:ChannelSet — The ChannelSet to disconnect from the Channel.
disconnectFailed () method
protected function disconnectFailed(event:ChannelFaultEvent):void

Processes a failed internal disconnect and dispatches the FAULT event for the channel.

Parameters
event:ChannelFaultEvent — The ChannelFaultEvent for the failed disconnect.
disconnectSuccess () method
protected function disconnectSuccess(rejected:Boolean = false):void

Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. If the disconnect is due to a network failure and the Channel has failoverURI values, it will attempt to reconnect automatically by trying these URI values in order until a connection is established or the available values are exhausted.

Parameters
rejected:Boolean (default = false) — True if the disconnect should skip any failover processing that would otherwise be attempted; false if failover processing should be allowed to run.
getMessageResponder () method
protected function getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder

Returns the appropriate MessageResponder for the Channel's send() method. Must be overridden.

Parameters
agent:MessageAgent — The MessageAgent sending the message.
message:IMessage — The Message to send.

Returns
MessageResponder — The MessageResponder to handle the result or fault.

Throws
IllegalOperationError — If the Channel subclass does not override this method.
internalConnect () method
protected function internalConnect():void

Connects the Channel to its endpoint. Must be overridden.

internalDisconnect () method
protected function internalDisconnect(rejected:Boolean = false):void

Disconnects the Channel from its endpoint. Must be overridden.

Parameters
rejected:Boolean (default = false) — True if the disconnect was due to a connection rejection or timeout and reconnection should not be attempted automatically; otherwise false.
internalSend () method
protected function internalSend(messageResponder:MessageResponder):void

Sends the Message out over the Channel and routes the response to the responder. Must be overridden.

Parameters
messageResponder:MessageResponder — The MessageResponder to handle the response.
logout () method
public function logout(agent:MessageAgent):void

Sends a CommandMessage to the server to logout if the Channel is connected. Current credentials are cleared.

Parameters
agent:MessageAgent — The MessageAgent to logout.
send () method
public final function send(agent:MessageAgent, message:IMessage):void

Sends the specified message to its target destination. Subclasses must override the internalSend() method to perform the actual send.

Parameters
agent:MessageAgent — The MessageAgent that is sending the message.
message:IMessage — The Message to send.

Throws
InvalidDestinationError — If neither the MessageAgent nor the message specify a destination.
setCredentials () method
public function setCredentials(credentials:String, agent:MessageAgent = null):void

Sets the credentials to the specified value. If the credentials are non-null and the Channel is connected, this method also sends a CommandMessage to the server to login using the credentials.

Parameters
credentials:String — The credentials string.
agent:MessageAgent (default = null) — The MessageAgent to login, that will handle the login result.
Event detail
channelConnect event
Event object type: mx.messaging.events.ChannelEvent
ChannelEvent.type property = mx.messaging.events.ChannelEvent.CONNECT

Dispatched after the channel has connected to its endpoint.

The CONNECT event type; indicates that the Channel connected to its endpoint.

The value of this constant is "channelConnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.
channelDisconnect event
Event object type: mx.messaging.events.ChannelEvent
ChannelEvent.type property = mx.messaging.events.ChannelEvent.DISCONNECT

Dispatched after the channel has disconnected from its endpoint.

The DISCONNECT event type; indicates that the Channel disconnected from its endpoint.

The value of this constant is "channelDisconnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.
channelFault event
Event object type: mx.messaging.events.ChannelFaultEvent
ChannelFaultEvent.type property = mx.messaging.events.ChannelFaultEvent.FAULT

Dispatched after the channel has faulted.

The FAULT event type; indicates that the Channel faulted.

The value of this constant is "channelFault".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The Channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
faultCode | Provides destination-specific details of the failure.
faultDetail | Provides access to the destination-specific reason for the failure.
faultString | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rootCause | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
message event
Event object type: mx.messaging.events.MessageEvent
MessageEvent.type property = mx.messaging.events.MessageEvent.MESSAGE

Dispatched when a channel receives a message from its endpoint.

The MESSAGE event type; dispatched upon receipt of a message.

The value of this constant is "message".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
propertyChange event
Event object type: mx.events.PropertyChangeEvent
PropertyChangeEvent.type property = mx.events.PropertyChangeEvent.PROPERTY_CHANGE

Dispatched when a property of the channel changes.

The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event.

The properties of the event object have the following values:

Property | Value
bubbles | Determined by the constructor; defaults to false.
cancelable | Determined by the constructor; defaults to false.
kind | The kind of change; PropertyChangeEventKind.UPDATE or PropertyChangeEventKind.DELETE.
oldValue | The original property value.
newValue | The new property value, if any.
property | The property that changed
source | The object that contains the property that changed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.messaging.ChannelSet (Flex™ 2 Language Reference)

Class ChannelSet | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging
Class | public class ChannelSet
Inheritance | ChannelSet Inheritance EventDispatcher Inheritance Object

The ChannelSet is a set of Channels that are used to send messages to a target destination. The ChannelSet improves the quality of service on the client by hunting through its Channels to send messages in the face of network failures or individual Channel problems.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | channelIds : Array [read-only] The ids of the Channels used by the ChannelSet. | ChannelSet
 | clustered : Boolean [read-only] Indicates whether the ChannelSet targets a clustered destination. | ChannelSet
 | configured : Boolean [read-only] Indicates whether the ChannelSet is using automatically configured Channels or manually assigned Channels. | ChannelSet
 | connected : Boolean [read-only] Indicates whether the ChannelSet is connected. | ChannelSet
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | messageAgents : Array [read-only] Provides access to the set of MessageAgents that use this ChannelSet. | ChannelSet
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ChannelSet(channelIds:Array = null, clustered:Boolean = false)
Constructs a ChannelSet.
ChannelSet
addChannel(channel:Channel):void
Adds a Channel to the ChannelSet.
ChannelSet
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
channelConnectHandler(event:ChannelEvent):void
Handles a CONNECT ChannelEvent and redispatches the event.
ChannelSet
channelDisconnectHandler(event:ChannelEvent):void
Handles a DISCONNECT ChannelEvent and redispatches the event.
ChannelSet
channelFaultHandler(event:ChannelFaultEvent):void
Handles a ChannelFaultEvent and redispatches the event.
ChannelSet
connect(agent:MessageAgent):void
Connects a MessageAgent to the ChannelSet.
ChannelSet
disconnect(agent:MessageAgent):void
Disconnects a MessageAgent from the ChannelSet.
ChannelSet
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
logout(agent:MessageAgent):void
Clears the stored credentials and calls logout on every channel in the set.
ChannelSet
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
removeChannel(channel:Channel):void
Removes a Channel from the ChannelSet.
ChannelSet
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(agent:MessageAgent, message:IMessage):void
Sends a message from a MessageAgent over the currently connected Channel.
ChannelSet
setCredentials(credentials:String, agent:MessageAgent):void
Stores the credentials and passes them through to every connected channel.
ChannelSet
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
toString():String
Returns the ids of the Channels in the ChannelSet.
ChannelSet
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | channelConnect | Dispatched after a Channel in the ChannelSet has connected to its endpoint. | ChannelSet
 | channelDisconnect | Dispatched after a Channel in the ChannelSet has disconnected from its endpoint. | ChannelSet
 | channelFault | Dispatched after a Channel in the ChannelSet has faulted. | ChannelSet
 | propertyChange | Dispatched when a property of the channel set changes. | ChannelSet
Property detail
channelIds property
channelIds:Array [read-only]

The ids of the Channels used by the ChannelSet.

Implementation
    public function get channelIds():Array
clustered property
clustered:Boolean [read-only]

Indicates whether the ChannelSet targets a clustered destination. If true, upon a successful connection the ChannelSet queries the destination for all clustered endpoints for its Channels and assigns these failover URIs to them.

Implementation
    public function get clustered():Boolean
configured property
configured:Boolean [read-only]

Indicates whether the ChannelSet is using automatically configured Channels or manually assigned Channels.

Implementation
    public function get configured():Boolean
connected property
connected:Boolean [read-only]

Indicates whether the ChannelSet is connected.

This property can be used as the source for data binding.

Implementation
    public function get connected():Boolean
messageAgents property
messageAgents:Array [read-only]

Provides access to the set of MessageAgents that use this ChannelSet.

Implementation
    public function get messageAgents():Array
Constructor detail
ChannelSet () constructor
public function ChannelSet(channelIds:Array = null, clustered:Boolean = false)

Constructs a ChannelSet. If the channelIds argument is provided, the ChannelSet will the specified Channels obtained via ServerConfig.getChannel() to reach its destination. Attempting to manually assign Channels to a ChannelSet that targets a configured destination is not allowed.

If the channelIds argument is not provided or is null, Channels must be manually created and added to the ChannelSet in order to connect and send messages.

If the ChannelSet is clustered, after connecting over one of its channels the first time the ChannelSet will automatically request all of the endpoints across the cluster for each Channel in the set and assign these failover URIs to each respective Channel. This allows Channels in the ChannelSet to failover, and when failover is exhausted for a Channel the ChannelSet can advance to the next available Channel in the set.

Regardless of clustering, if a Channel cannot connect or looses connectivity, the ChannelSet will advance to its next available Channel and attempt to reconnect. This allows the ChannelSet to hunt through Channels that use different protocols, ports, etc., in search of one that can connect to its endpoint successfully.

Parameters
channelIds:Array (default = null) — The ids of configured Channels for this ChannelSet to use. If null, Channels must be manually added to the ChannelSet.
clustered:Boolean (default = false) — True if the Channels in the ChannelSet are clustered, otherwise false.
Method detail
addChannel () method
public function addChannel(channel:Channel):void

Adds a Channel to the ChannelSet.

Parameters
channel:Channel — The Channel to add.

Throws
IllegalOperationError — If the ChannelSet is configured, adding a Channel is not supported.
channelConnectHandler () method
public function channelConnectHandler(event:ChannelEvent):void

Handles a CONNECT ChannelEvent and redispatches the event.

Parameters
event:ChannelEvent — The ChannelEvent.
channelDisconnectHandler () method
public function channelDisconnectHandler(event:ChannelEvent):void

Handles a DISCONNECT ChannelEvent and redispatches the event.

Parameters
event:ChannelEvent — The ChannelEvent.
channelFaultHandler () method
public function channelFaultHandler(event:ChannelFaultEvent):void

Handles a ChannelFaultEvent and redispatches the event.

Parameters
event:ChannelFaultEvent — The ChannelFaultEvent.
connect () method
public function connect(agent:MessageAgent):void

Connects a MessageAgent to the ChannelSet. Once connected, the agent can use the ChannelSet to send messages.

Parameters
agent:MessageAgent — The MessageAgent to connect.
disconnect () method
public function disconnect(agent:MessageAgent):void

Disconnects a MessageAgent from the ChannelSet.

Parameters
agent:MessageAgent — The MessageAgent to disconnect.
logout () method
public function logout(agent:MessageAgent):void

Clears the stored credentials and calls logout on every channel in the set.

Parameters
agent:MessageAgent — The MessageAgent that is initiating the logout.
removeChannel () method
public function removeChannel(channel:Channel):void

Removes a Channel from the ChannelSet. If the Channel to remove is currently connected and being used by the ChannelSet, it is disconnected.

Parameters
channel:Channel — The Channel to remove.

Throws
IllegalOperationError — If the ChannelSet is configured, removing a Channel is not supported.
send () method
public function send(agent:MessageAgent, message:IMessage):void

Sends a message from a MessageAgent over the currently connected Channel.

Parameters
agent:MessageAgent — The MessageAgent sending the message.
message:IMessage — The Message to send.

Throws
NoChannelAvailableError — If the ChannelSet has no internal Channels to use.
setCredentials () method
public function setCredentials(credentials:String, agent:MessageAgent):void

Stores the credentials and passes them through to every connected channel.

Parameters
credentials:String — The credentials for the MessageAgent.
agent:MessageAgent — The MessageAgent that is setting the credentials.
toString () method
public override function toString():String

Returns the ids of the Channels in the ChannelSet.

Returns
String — String representation of the ChannelSet.
Event detail
channelConnect event
Event object type: mx.messaging.events.ChannelEvent
ChannelEvent.type property = mx.messaging.events.ChannelEvent.CONNECT

Dispatched after a Channel in the ChannelSet has connected to its endpoint.

The CONNECT event type; indicates that the Channel connected to its endpoint.

The value of this constant is "channelConnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.
channelDisconnect event
Event object type: mx.messaging.events.ChannelEvent
ChannelEvent.type property = mx.messaging.events.ChannelEvent.DISCONNECT

Dispatched after a Channel in the ChannelSet has disconnected from its endpoint.

The DISCONNECT event type; indicates that the Channel disconnected from its endpoint.

The value of this constant is "channelDisconnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.
channelFault event
Event object type: mx.messaging.events.ChannelFaultEvent
ChannelFaultEvent.type property = mx.messaging.events.ChannelFaultEvent.FAULT

Dispatched after a Channel in the ChannelSet has faulted.

The FAULT event type; indicates that the Channel faulted.

The value of this constant is "channelFault".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The Channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
faultCode | Provides destination-specific details of the failure.
faultDetail | Provides access to the destination-specific reason for the failure.
faultString | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rootCause | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
propertyChange event
Event object type: mx.events.PropertyChangeEvent
PropertyChangeEvent.type property = mx.events.PropertyChangeEvent.PROPERTY_CHANGE

Dispatched when a property of the channel set changes.

The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event.

The properties of the event object have the following values:

Property | Value
bubbles | Determined by the constructor; defaults to false.
cancelable | Determined by the constructor; defaults to false.
kind | The kind of change; PropertyChangeEventKind.UPDATE or PropertyChangeEventKind.DELETE.
oldValue | The original property value.
newValue | The new property value, if any.
property | The property that changed
source | The object that contains the property that changed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.messaging.Consumer (Flex™ 2 Language Reference)

Class Consumer | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging
Class | public class Consumer
Inheritance | Consumer Inheritance MessageAgent Inheritance EventDispatcher Inheritance Object

A Consumer subscribes to a destination to receive messages. Consumers send subscribe and unsubscribe messages which generate a MessageAckEvent or MessageFaultEvent depending upon whether the operation was successful or not. Once subscribed, a Consumer dispatches a MessageEvent for each message it receives. Consumers provide the ability to filter messages using a selector. These selectors must be understood by the destination.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Consumer> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

   <mx:Consumer
    Properties
    messageType="No default."
    resubscribeAttempts="5"
    resubscribeInterval="5000"
    selector="No default."
    timestamp="No default."
  />

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the MessageAgent. | MessageAgent
Inherited | clientId : String Provides access to the client id for the MessageAgent. | MessageAgent
Inherited | connected : Boolean Indicates whether this MessageAgent is currently connected to its destination via its ChannelSet. | MessageAgent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | destination : String Provides access to the destination for the MessageAgent. | MessageAgent
 | messageType : String [read-only] The server alias for the type of message the Consumer can process. | Consumer
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | MessageAgent
 | resubscribeAttempts : int The number of resubscribe attempts that the Consumer makes in the event that the connection to its destination fails. | Consumer
 | resubscribeInterval : int The number of milliseconds between resubscribe attempts. | Consumer
 | selector : String The selector for the Consumer. | Consumer
 | subscribed : Boolean [read-only] Indicates whether the Consumer is currently subscribed. | Consumer
 | subtopic : String [write-only] Setting the subtopic when the Consumer is connected and subscribed has the side effect of unsubscribing and resubscribing the Consumer. | Consumer
 | timestamp : Number Contains the timestamp of the most recent message this Consumer has received. | Consumer
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Consumer(messageType:String = "flex.messaging.messages.AsyncMessage")
Constructs a Consumer.
Consumer
Inherited
acknowledge(ackMsg:AcknowledgeMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a result for a sent message.
MessageAgent
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
channelConnectHandler(event:ChannelEvent):void
Handles a CONNECT ChannelEvent.
MessageAgent
Inherited
channelDisconnectHandler(event:ChannelEvent):void
Handles a DISCONNECT ChannelEvent.
MessageAgent
Inherited
channelFaultHandler(event:ChannelFaultEvent):void
Handles a ChannelFaultEvent.
MessageAgent
disconnect():void
Disconnects the Consumer from its remote destination.
Consumer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
fault(errMsg:ErrorMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a fault for a sent message.
MessageAgent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called after the implementing object has been created and all properties specified on the tag have been assigned.
MessageAgent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout():void
Logs the MessageAgent out from its remote destination.
MessageAgent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
receive(timestamp:Number = 0):void
Requests any messages that are pending from the server from the specified timestamp to the present.
Consumer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setCredentials(username:String, password:String):void
Sets the credentials that the MessageAgent uses to authenticate to destinations.
MessageAgent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setRemoteCredentials(username:String, password:String):void
Sets the remote credentials that will be passed through to the remote destination for authenticating to secondary systems.
MessageAgent
subscribe(clientId:String = null):void
Subscribes to the remote destination.
Consumer
Inherited
toString():String
Returns the string representation of the specified object.
Object
unsubscribe():void
Unsubscribes from the remote destination.
Consumer
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
 | getSubscribeMessage():CommandMessage Returns a subscribe message. | Consumer
 | getUnsubscribeMessage():CommandMessage Returns an unsubscribe message. | Consumer
 | initChannelSet(message:IMessage):void Consumer overrides this method and initializes its ChannelSet based upon the value of messageType. | Consumer
Inherited | internalSend(message:IMessage):void Sends a Message from the MessageAgent to its destination using the agent's ChannelSet. | MessageAgent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | acknowledge | Dispatched when an acknowledge message is received for a sent message. | MessageAgent
Inherited | channelConnect | Dispatched when the underlying Channel the MessageAgent is using connects. | MessageAgent
Inherited | channelDisconnect | Dispatched when the underlying Channel the MessageAgent is using disconnects. | MessageAgent
Inherited | channelFault | Dispatched when the underlying Channel the MessageAgent is using faults. | MessageAgent
Inherited | fault | Dispatched when a message fault occurs. | MessageAgent
 | message | Dispatched when a message is received by the Consumer. | Consumer
Inherited | propertyChange | Dispatched when the connected property of the MessageAgent changes. | MessageAgent
Property detail
messageType property
messageType:String [read-only]

The server alias for the type of message the Consumer can process.

Implementation
    public function get messageType():String
resubscribeAttempts property
resubscribeAttempts:int [read-write]

The number of resubscribe attempts that the Consumer makes in the event that the connection to its destination fails. A value of -1 enables infinite attempts.

Implementation
    public function get resubscribeAttempts():int
    public function set resubscribeAttempts(value:int):void
resubscribeInterval property
resubscribeInterval:int [read-write]

The number of milliseconds between resubscribe attempts. If a Consumer doesn't receive an acknowledgement for a subscription request, it will wait the specified number of milliseconds before attempting to resubscribe. Setting the value to zero disables resubscriptions.

Implementation
    public function get resubscribeInterval():int
    public function set resubscribeInterval(value:int):void

Throws
ArgumentError — If the assigned value is negative.
selector property
selector:String [read-write]

The selector for the Consumer. This is an expression that is passed to the destination which uses it to filter the messages delivered to the Consumer.

Before a call to the subscribe() method, this property can be set with no side effects. After the Consumer has subscribed to its destination, changing this value has the side effect of updating the Consumer's subscription to use the new selector expression immediately.

The remote destination must understand the value of the selector expression.

Implementation
    public function get selector():String
    public function set selector(value:String):void
subscribed property
subscribed:Boolean [read-only]

Indicates whether the Consumer is currently subscribed. The propertyChange event is dispatched when this property changes.

This property can be used as the source for data binding.

Implementation
    public function get subscribed():Boolean
subtopic property
subtopic:String [write-only]

Setting the subtopic when the Consumer is connected and subscribed has the side effect of unsubscribing and resubscribing the Consumer.

Implementation
    public function set subtopic(value:String):void
timestamp property
timestamp:Number [read-write]

Contains the timestamp of the most recent message this Consumer has received. This value is passed to the destination in a receive() call to request that it deliver messages for the Consumer from the timestamp forward. All messages with a timestamp value greater than the timestamp value will be returned during a poll operation. Setting this value to -1 will retrieve all cached messages from the destination.

Implementation
    public function get timestamp():Number
    public function set timestamp(value:Number):void
Constructor detail
Consumer () constructor
public function Consumer(messageType:String = "flex.messaging.messages.AsyncMessage")

Constructs a Consumer.

Parameters
messageType:String (default = "flex.messaging.messages.AsyncMessage") — The alias for the message type processed by the service hosting the remote destination the Consumer will subscribe to.

Example
       function initConsumer():void
       {
           var consumer:Consumer = new Consumer();
           consumer.destination = "NASDAQ";
           consumer.selector = "operation IN ('Bid','Ask')";
           consumer.addEventListener(MessageEvent.MESSAGE, messageHandler);
           consumer.subscribe();
       }
            function messageHandler(event:MessageEvent):void
       {
           var msg:IMessage = event.message;
           var info:Object = msg.body;
           trace("-App recieved message: " + msg.toString());
       }

Method detail
disconnect () method
public override function disconnect():void

Disconnects the Consumer from its remote destination. This method should be invoked on a Consumer that is no longer needed by an application after unsubscribing. This method does not wait for outstanding network operations to complete and does not send an unsubscribe message to the server. After invoking disconnect(), the Consumer will report that it is in an disconnected, unsubscribed state because it will not receive any more messages until it has reconnected and resubscribed.

getSubscribeMessage () method
protected function getSubscribeMessage():CommandMessage

Returns a subscribe message. This method should be overridden by subclasses if they need custom subscribe messages.

Returns
CommandMessage — The subscribe CommandMessage.
getUnsubscribeMessage () method
protected function getUnsubscribeMessage():CommandMessage

Returns an unsubscribe message. This method should be overridden by subclasses if they need custom unsubscribe messages.

Returns
CommandMessage — The unsubscribe CommandMessage.
initChannelSet () method
protected override function initChannelSet(message:IMessage):void

Consumer overrides this method and initializes its ChannelSet based upon the value of messageType.

Parameters
message:IMessage — The message that needs to be sent.
receive () method
public function receive(timestamp:Number = 0):void

Requests any messages that are pending from the server from the specified timestamp to the present.

Parameters
timestamp:Number (default = 0) — The timestamp to request messages from.
subscribe () method
public function subscribe(clientId:String = null):void

Subscribes to the remote destination.

Parameters
clientId:String (default = null) — The client id to subscribe with. Use null for non-durable Consumers. If the subscription is durable, a consistent value must be supplied every time the Consumer subscribes in order to reconnect to the correct durable subscription in the remote destination.

Throws
InvalidDestinationError — If no destination is set.
unsubscribe () method
public function unsubscribe():void

Unsubscribes from the remote destination. In the case of durable JMS subscriptions, this will destroy the durable subscription on the JMS server.

Event detail
message event
Event object type: mx.messaging.events.MessageEvent
MessageEvent.type property = mx.messaging.events.MessageEvent.MESSAGE

Dispatched when a message is received by the Consumer.

The MESSAGE event type; dispatched upon receipt of a message.

The value of this constant is "message".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.messaging.MessageAgent (Flex™ 2 Language Reference)

Class MessageAgent | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging
Class | public class MessageAgent
Inheritance | MessageAgent Inheritance EventDispatcher Inheritance Object
Implements | IMXMLObject
Subclasses | Consumer, Producer

The MessageAgent class provides the basic low-level functionality common to message handling for a destination.

Note: For advanced use only. Use this class for creating custom message agents like the existing Producer and Consumer classes.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

All message agent classes, including the Producer and Consumer classes, extend MessageAgent and inherit the following tag attributes:

   <mx:tagname

    Properties
    channelSet="No default."
    clientId="No default."
    connected="false"
    destination="No default."
    requestTimeout="-1"
    subtopic="No default."

    Events
    acknowledge="No default."
    channelConnect="No default."
    channelDisconnect="No default."
    channelFault="No default."
    fault="No default."
    propertyChange="No default."
  />

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | channelSet : ChannelSet Provides access to the ChannelSet used by the MessageAgent. | MessageAgent
 | clientId : String [read-only] Provides access to the client id for the MessageAgent. | MessageAgent
 | connected : Boolean [read-only] Indicates whether this MessageAgent is currently connected to its destination via its ChannelSet. | MessageAgent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | destination : String Provides access to the destination for the MessageAgent. | MessageAgent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | MessageAgent
 | subtopic : String Provides access to the subtopic for the remote destination that the MessageAgent uses. | MessageAgent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MessageAgent()
Constructor.
MessageAgent
acknowledge(ackMsg:AcknowledgeMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a result for a sent message.
MessageAgent
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
channelConnectHandler(event:ChannelEvent):void
Handles a CONNECT ChannelEvent.
MessageAgent
channelDisconnectHandler(event:ChannelEvent):void
Handles a DISCONNECT ChannelEvent.
MessageAgent
channelFaultHandler(event:ChannelFaultEvent):void
Handles a ChannelFaultEvent.
MessageAgent
disconnect():void
Disconnects the MessageAgent's network connection.
MessageAgent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
fault(errMsg:ErrorMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a fault for a sent message.
MessageAgent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
initialized(document:Object, id:String):void
Called after the implementing object has been created and all properties specified on the tag have been assigned.
MessageAgent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
logout():void
Logs the MessageAgent out from its remote destination.
MessageAgent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setCredentials(username:String, password:String):void
Sets the credentials that the MessageAgent uses to authenticate to destinations.
MessageAgent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setRemoteCredentials(username:String, password:String):void
Sets the remote credentials that will be passed through to the remote destination for authenticating to secondary systems.
MessageAgent
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | initChannelSet(message:IMessage):void Used to automatically initialize the channelSet property for the MessageAgent before it connects for the first time. | MessageAgent
 | internalSend(message:IMessage):void Sends a Message from the MessageAgent to its destination using the agent's ChannelSet. | MessageAgent
Events
Event |  | Summary | Defined by
 | acknowledge | Dispatched when an acknowledge message is received for a sent message. | MessageAgent
 | channelConnect | Dispatched when the underlying Channel the MessageAgent is using connects. | MessageAgent
 | channelDisconnect | Dispatched when the underlying Channel the MessageAgent is using disconnects. | MessageAgent
 | channelFault | Dispatched when the underlying Channel the MessageAgent is using faults. | MessageAgent
 | fault | Dispatched when a message fault occurs. | MessageAgent
 | propertyChange | Dispatched when the connected property of the MessageAgent changes. | MessageAgent
Property detail
channelSet property
channelSet:ChannelSet [read-write]

Provides access to the ChannelSet used by the MessageAgent. The ChannelSet can be manually constructed and assigned, or it will be dynamically initialized to use the configured Channels for the destination for this MessageAgent.

Implementation
    public function get channelSet():ChannelSet
    public function set channelSet(value:ChannelSet):void
clientId property
clientId:String [read-only]

Provides access to the client id for the MessageAgent. Agents are assigned their client id by the remote destination.

Implementation
    public function get clientId():String
connected property
connected:Boolean [read-only]

Indicates whether this MessageAgent is currently connected to its destination via its ChannelSet. The propertyChange event is dispatched when this property changes.

This property can be used as the source for data binding.

Implementation
    public function get connected():Boolean
destination property
destination:String [read-write]

Provides access to the destination for the MessageAgent. Changing the destination will disconnect the MessageAgent if it is currently connected.

This property can be used as the source for data binding.

Implementation
    public function get destination():String
    public function set destination(value:String):void

Throws
InvalidDestinationError — If the destination is null or zero-length.
requestTimeout property
requestTimeout:int [read-write]

Provides access to the request timeout in seconds for sent messages. If an acknowledgement, response or fault is not received from the remote destination before the timeout is reached the message is faulted. A value less than or equal to zero prevents request timeout.

Implementation
    public function get requestTimeout():int
    public function set requestTimeout(value:int):void
subtopic property
subtopic:String [read-write]

Provides access to the subtopic for the remote destination that the MessageAgent uses.

This property can be used as the source for data binding.

Implementation
    public function get subtopic():String
    public function set subtopic(value:String):void
Constructor detail
MessageAgent () constructor
public function MessageAgent()

Constructor.

Method detail
acknowledge () method
public function acknowledge(ackMsg:AcknowledgeMessage, msg:IMessage):void

Invoked by a MessageResponder upon receiving a result for a sent message. Subclasses may override this method if they need to perform custom acknowledgement processing, but must invoke super.acknowledge() as well. This method dispatches a MessageAckEvent.

Parameters
ackMsg:AcknowledgeMessage — The AcknowledgMessage returned.
msg:IMessage — The original sent message.
channelConnectHandler () method
public function channelConnectHandler(event:ChannelEvent):void

Handles a CONNECT ChannelEvent. Subclasses that need to perform custom processing should override this method, and invoke super.channelConnectHandler().

Parameters
event:ChannelEvent — The ChannelEvent.
channelDisconnectHandler () method
public function channelDisconnectHandler(event:ChannelEvent):void

Handles a DISCONNECT ChannelEvent. Subclasses that need to perform custom processing should override this method, and invoke super.channelDisconnectHandler().

Parameters
event:ChannelEvent — The ChannelEvent.
channelFaultHandler () method
public function channelFaultHandler(event:ChannelFaultEvent):void

Handles a ChannelFaultEvent. Subclasses that need to perform custom processing should override this method, and invoke super.channelFaultHandler().

Parameters
event:ChannelFaultEvent — ChannelFaultEvent
disconnect () method
public function disconnect():void

Disconnects the MessageAgent's network connection. This method does not wait for outstanding network operations to complete.

fault () method
public function fault(errMsg:ErrorMessage, msg:IMessage):void

Invoked by a MessageResponder upon receiving a fault for a sent message. Subclasses may override this method if they need to perform custom fault processing, but must invoke super.fault() as well. This method dispatchs a MessageFaultEvent.

Parameters
errMsg:ErrorMessage — The ErrorMessage.
msg:IMessage — The original sent message that caused this fault.
initChannelSet () method
protected function initChannelSet(message:IMessage):void

Used to automatically initialize the channelSet property for the MessageAgent before it connects for the first time. Subtypes may override to perform custom initialization.

Parameters
message:IMessage — The message that needs to be sent.
initialized () method
public function initialized(document:Object, id:String):void

Called after the implementing object has been created and all properties specified on the tag have been assigned.

Parameters
document:Object — MXML document that created this object.
id:String — id used by the document to refer to this object. If the object is a deep property on the document, id is null.
internalSend () method
protected final function internalSend(message:IMessage):void

Sends a Message from the MessageAgent to its destination using the agent's ChannelSet. MessageAgent subclasses must use this method to send their messages.

Parameters
message:IMessage — The message to send.

Throws
InvalidDestinationError — If no destination is set.
logout () method
public function logout():void

Logs the MessageAgent out from its remote destination. Logging out of a destination applies to everything connected using the same ChannelSet as specified in the server configuration. For example, if several DataService components are connected over an RTMP channel and logout() is invoked on one of them, all other client components that are connected using the same ChannelSet are also logged out.

setCredentials () method
public function setCredentials(username:String, password:String):void

Sets the credentials that the MessageAgent uses to authenticate to destinations. The credentials are applied to all services connected over the same ChannelSet.

Parameters
username:String — The username.
password:String — The password.
setRemoteCredentials () method
public function setRemoteCredentials(username:String, password:String):void

Sets the remote credentials that will be passed through to the remote destination for authenticating to secondary systems.

Parameters
username:String — The username.
password:String — The password.
Event detail
acknowledge event
Event object type: mx.messaging.events.MessageAckEvent
MessageAckEvent.type property = mx.messaging.events.MessageAckEvent.ACKNOWLEDGE

Dispatched when an acknowledge message is received for a sent message.

The ACKNOWLEDGE event type; dispatched upon receipt of an acknowledgement.

The value of this constant is "acknowledge".

The properties of the event object have the following values:

Property | Value
acknowledgeMessage | Utility property to get the message property from MessageEvent as an AcknowledgeMessage.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
correlate | The original Message correlated with this acknowledgement.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
channelConnect event
Event object type: mx.messaging.events.ChannelEvent
ChannelEvent.type property = mx.messaging.events.ChannelEvent.CONNECT

Dispatched when the underlying Channel the MessageAgent is using connects.

The CONNECT event type; indicates that the Channel connected to its endpoint.

The value of this constant is "channelConnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.
channelDisconnect event
Event object type: mx.messaging.events.ChannelEvent
ChannelEvent.type property = mx.messaging.events.ChannelEvent.DISCONNECT

Dispatched when the underlying Channel the MessageAgent is using disconnects.

The DISCONNECT event type; indicates that the Channel disconnected from its endpoint.

The value of this constant is "channelDisconnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.
channelFault event
Event object type: mx.messaging.events.ChannelFaultEvent
ChannelFaultEvent.type property = mx.messaging.events.ChannelFaultEvent.FAULT

Dispatched when the underlying Channel the MessageAgent is using faults.

The FAULT event type; indicates that the Channel faulted.

The value of this constant is "channelFault".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The Channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
faultCode | Provides destination-specific details of the failure.
faultDetail | Provides access to the destination-specific reason for the failure.
faultString | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rootCause | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
fault event
Event object type: mx.messaging.events.MessageFaultEvent
MessageFaultEvent.type property = mx.messaging.events.MessageFaultEvent.FAULT

Dispatched when a message fault occurs.

The FAULT event type; dispatched for a message fault.

The value of this constant is "fault".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
faultCode | Provides destination-specific details of the failure.
faultDetail | Provides access to the destination-specific reason for the failure.
faultString | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
message | The ErrorMessage for this event.
rootCause | Provides access to the underlying reason for the failure, if one exists.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
propertyChange event
Event object type: mx.events.PropertyChangeEvent
PropertyChangeEvent.type property = mx.events.PropertyChangeEvent.PROPERTY_CHANGE

Dispatched when the connected property of the MessageAgent changes. Also dispatched when the subscribed of a Consumer changes.

The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event.

The properties of the event object have the following values:

Property | Value
bubbles | Determined by the constructor; defaults to false.
cancelable | Determined by the constructor; defaults to false.
kind | The kind of change; PropertyChangeEventKind.UPDATE or PropertyChangeEventKind.DELETE.
oldValue | The original property value.
newValue | The new property value, if any.
property | The property that changed
source | The object that contains the property that changed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.

See also

mx.messaging.Consumer


mx.messaging.MessageResponder (Flex™ 2 Language Reference)

Class MessageResponder | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging
Class | public class MessageResponder
Inheritance | MessageResponder Inheritance Responder Inheritance Object

The MessageResponder class handles a successful result or fault from a message destination. For each message that a Channel sends, the Channel creates a MessageResponder to handle the result. Upon a response, the Channel will invoke either the result() or status() callback on the MessageResponder. MessageResponder subclasses should override these methods to perform any necessary processing. For every response, whether a successful result or an error, the MessageResponder should invoke acknowledge() on its agent. If the response was a fault, the MessageResponder should also invoke fault() on its agent.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | agent : MessageAgent [read-only] Provides access to the MessageAgent that sent the message. | MessageResponder
 | channel : Channel [read-only] Provides access to the Channel used to send the message. | MessageResponder
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | message : IMessage [read-only] Provides access to the sent Message. | MessageResponder
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MessageResponder(agent:MessageAgent, message:IMessage, channel:Channel = null) Constructs a MessageResponder to handle the response for the specified Message for the specified MessageAgent. | MessageResponder
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | result(message:IMessage):void Called by the channel that created this MessageResponder when a response returns from the destination. | MessageResponder
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | status(message:IMessage):void Called by the channel that created this MessageResponder when a fault response returns from the destination. | MessageResponder
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Method |  | Defined by
 | createRequestTimeoutErrorMessage():ErrorMessage Constructs an ErrorMessage that can be passed to the associated MessageAgent's callbacks upon a request timeout. | MessageResponder
 | requestTimedOut():void Subclasses must override this method to handle a request timeout and invoke the proper callbacks on the associated MessageAgent. | MessageResponder
 | resultHandler(message:IMessage):void Subclasses must override this method to perform custom processing of the result and invoke the proper callbacks on the associated MessageAgent. | MessageResponder
 | statusHandler(message:IMessage):void Subclasses must override this method to perform custom processing of the status and invoke the proper callbacks on the associated MessageAgent. | MessageResponder
Property detail
agent property
agent:MessageAgent [read-only]

Provides access to the MessageAgent that sent the message.

Implementation
    public function get agent():MessageAgent
channel property
channel:Channel [read-only]

Provides access to the Channel used to send the message.

Implementation
    public function get channel():Channel
message property
message:IMessage [read-only]

Provides access to the sent Message.

Implementation
    public function get message():IMessage
Constructor detail
MessageResponder () constructor
public function MessageResponder(agent:MessageAgent, message:IMessage, channel:Channel = null)

Constructs a MessageResponder to handle the response for the specified Message for the specified MessageAgent.

Parameters
agent:MessageAgent — agent The MessageAgent sending the Message.
message:IMessage — message The Message being sent.
channel:Channel (default = null) — The Channel used to send.
Method detail
createRequestTimeoutErrorMessage () method
protected function createRequestTimeoutErrorMessage():ErrorMessage

Constructs an ErrorMessage that can be passed to the associated MessageAgent's callbacks upon a request timeout.

Returns
ErrorMessage
requestTimedOut () method
protected function requestTimedOut():void

Subclasses must override this method to handle a request timeout and invoke the proper callbacks on the associated MessageAgent.

result () method
public final function result(message:IMessage):void

Called by the channel that created this MessageResponder when a response returns from the destination. This method performs core result processing and then invokes the resultHandler() method that subclasses may override to perform any necessary custom processing.

Parameters
message:IMessage — The result Message returned by the destination.
resultHandler () method
protected function resultHandler(message:IMessage):void

Subclasses must override this method to perform custom processing of the result and invoke the proper callbacks on the associated MessageAgent.

Parameters
message:IMessage — The result Message returned by the destination.
status () method
public final function status(message:IMessage):void

Called by the channel that created this MessageResponder when a fault response returns from the destination. This method performs core result processing and then invokes the statusHandler() method that subclasses may override to perform any necessary custom processing.

Parameters
message:IMessage — The fault Message returned by the destination.
statusHandler () method
protected function statusHandler(message:IMessage):void

Subclasses must override this method to perform custom processing of the status and invoke the proper callbacks on the associated MessageAgent.

Parameters
message:IMessage — The fault Message returned by the destination.


mx.messaging.Producer (Flex™ 2 Language Reference)

Class Producer | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging
Class | public class Producer
Inheritance | Producer Inheritance MessageAgent Inheritance EventDispatcher Inheritance Object
Subclasses | AsyncRequest

A Producer sends messages to a destination. Producers dispatch a MessageAckEvent or MessageFaultEvent for each message they send depending upon whether the outbound message was sent and processed successfully or not.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Producer> tag inherits all the tag attributes of its superclass, and adds the following tag attributes:

   <mx:Producer
    Properties
    defaultHeaders="No default."
  />

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the MessageAgent. | MessageAgent
Inherited | clientId : String Provides access to the client id for the MessageAgent. | MessageAgent
Inherited | connected : Boolean Indicates whether this MessageAgent is currently connected to its destination via its ChannelSet. | MessageAgent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | defaultHeaders : Object The default headers to apply to messages sent by the Producer. | Producer
Inherited | destination : String Provides access to the destination for the MessageAgent. | MessageAgent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | MessageAgent
Inherited | subtopic : String Provides access to the subtopic for the remote destination that the MessageAgent uses. | MessageAgent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Producer()
Constructs a Producer.
Producer
Inherited
acknowledge(ackMsg:AcknowledgeMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a result for a sent message.
MessageAgent
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
channelConnectHandler(event:ChannelEvent):void
Handles a CONNECT ChannelEvent.
MessageAgent
Inherited
channelDisconnectHandler(event:ChannelEvent):void
Handles a DISCONNECT ChannelEvent.
MessageAgent
Inherited
channelFaultHandler(event:ChannelFaultEvent):void
Handles a ChannelFaultEvent.
MessageAgent
Inherited
disconnect():void
Disconnects the MessageAgent's network connection.
MessageAgent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
fault(errMsg:ErrorMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a fault for a sent message.
MessageAgent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called after the implementing object has been created and all properties specified on the tag have been assigned.
MessageAgent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout():void
Logs the MessageAgent out from its remote destination.
MessageAgent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(message:IMessage):void
Sends the specified message to its destination.
Producer
Inherited
setCredentials(username:String, password:String):void
Sets the credentials that the MessageAgent uses to authenticate to destinations.
MessageAgent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setRemoteCredentials(username:String, password:String):void
Sets the remote credentials that will be passed through to the remote destination for authenticating to secondary systems.
MessageAgent
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | initChannelSet(message:IMessage):void Used to automatically initialize the channelSet property for the MessageAgent before it connects for the first time. | MessageAgent
Inherited | internalSend(message:IMessage):void Sends a Message from the MessageAgent to its destination using the agent's ChannelSet. | MessageAgent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | acknowledge | Dispatched when an acknowledge message is received for a sent message. | MessageAgent
Inherited | channelConnect | Dispatched when the underlying Channel the MessageAgent is using connects. | MessageAgent
Inherited | channelDisconnect | Dispatched when the underlying Channel the MessageAgent is using disconnects. | MessageAgent
Inherited | channelFault | Dispatched when the underlying Channel the MessageAgent is using faults. | MessageAgent
Inherited | fault | Dispatched when a message fault occurs. | MessageAgent
Inherited | propertyChange | Dispatched when the connected property of the MessageAgent changes. | MessageAgent
Property detail
defaultHeaders property
defaultHeaders:Object [read-write]

The default headers to apply to messages sent by the Producer. Any default headers that do not exist in the message will be created. If the message already contains a matching header, the value in the message takes precedence and the default header value is ignored.

Implementation
    public function get defaultHeaders():Object
    public function set defaultHeaders(value:Object):void
Constructor detail
Producer () constructor
public function Producer()

Constructs a Producer.

Example
       function sendMessage():void
       {
           var producer:Producer = new Producer();
           producer.destination = "NASDAQ";
           var msg:AsyncMessage = new AsyncMessage();
           msg.headers.operation = "UPDATE";
           msg.body = {"SYMBOL":50.00};
           producer.send(msg);
       }

Method detail
send () method
public function send(message:IMessage):void

Sends the specified message to its destination. If the producer is being used for publish/subscribe messaging, only messages of type AsyncMessage should be sent unless a custom message type is being used and the message destination on the server has been configured to process the custom message type.

Parameters
message:IMessage — The Message to send.

Throws
InvalidDestinationError — If no destination is set.

Example
         var producer:Producer = new Producer();
         producer.destination = "TestTopic";
         var msg:AsyncMessage = new AsyncMessage();
         msg.body = "test message";
         producer.send(msg);


mx.messaging.channels Summary (Flex™ 2 Language Reference)

Package mx.messaging.channels | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.messaging.channels package contains the channel messaging classes used with Flex Data Services.

Classes
Class | Description
AMFChannel | The AMFChannel class provides the AMF support for messaging.
HTTPChannel | The HTTPChannel class provides the HTTP support for messaging.
NetConnectionChannel | This NetConnectionChannel provides the basic NetConnection support for messaging.
PollingChannel | The PollingChannel class provides the polling behavior that all polling channels in the messaging system require.
RTMPChannel | The RTMPChannel class provides basic RTMP support for messaging.
SecureAMFChannel | The SecureAMFChannel class is identical to the AMFChannel class except that it uses a secure protocol, HTTPS, to send messages to an AMF endpoint.
SecureHTTPChannel | The SecureHTTPChannel class is identical to the HTTPChannel class except that it uses a secure protocol, HTTPS, to send messages to an HTTP endpoint.
SecureRTMPChannel | The SecureRTMPChannel class is identical to the RTMPChannel class except that it uses a secure protocol, RTMPS, to send messages to an RTMPS endpoint.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.messaging.channels.AMFChannel (Flex™ 2 Language Reference)

Class AMFChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class AMFChannel
Inheritance | AMFChannel Inheritance NetConnectionChannel Inheritance PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object
Subclasses | SecureAMFChannel

The AMFChannel class provides the AMF support for messaging. You can configure this Channel to poll the server at an interval to approximate server push. You can also use this Channel with polling disabled to send RPC messages to remote destinations to invoke their methods.

The AMFChannel relies on network services native to Flash Player, and exposed to ActionScript by the NetConnection class. This channel uses NetConnection exclusively, and creates a new NetConnection per instance.

Channels are created within the framework using the ServerConfig.getChannel() method. Channels can be constructed directly and assigned to a ChannelSet if desired.

Channels represent a physical connection to a remote endpoint. Channels are shared across destinations by default. This means that a client targetting different destinations may use the same Channel to communicate with these destinations.

When used in polling mode, this Channel polls the server for new messages based on the polling-interval-seconds property in the configuration file, and this can be changed by setting the pollingInterval property. The default value is 3 seconds. To enable polling, the channel must be connected and the polling-enabled property in the configuration file must be set to true, or the pollingEnabled property of the Channel must be set to true.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
Inherited | netConnection : NetConnection Provides access to the associated NetConnection for this Channel. | NetConnectionChannel
 | polling : Boolean [read-only] Reports whether the channel is actively polling. | AMFChannel
 | pollingEnabled : Boolean Indicates whether this channel is enabled to poll. | AMFChannel
 | pollingInterval : Number Provides access to the polling interval for this Channel. | AMFChannel
 | protocol : String [read-only] Returns the protocol for this channel (http). | AMFChannel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AMFChannel(id:String, uri:String)
Creates an new AMFChannel instance.
AMFChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
Inherited
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
polling property
polling:Boolean [read-only]

Reports whether the channel is actively polling.

Implementation
    public function get polling():Boolean
pollingEnabled property
pollingEnabled:Boolean [read-write]

Indicates whether this channel is enabled to poll.

Implementation
    public function get pollingEnabled():Boolean
    public function set pollingEnabled(value:Boolean):void
pollingInterval property
pollingInterval:Number [read-write]

Provides access to the polling interval for this Channel. The value is in milliseconds. This value determines how often this Channel requests messages from the server, to approximate server push.

Implementation
    public function get pollingInterval():Number
    public function set pollingInterval(value:Number):void

Throws
ArgumentError — If the pollingInterval is assigned a value of 0 or less.
protocol property
protocol:String [read-only]

Returns the protocol for this channel (http).

Implementation
    public function get protocol():String
Constructor detail
AMFChannel () constructor
public function AMFChannel(id:String, uri:String)

Creates an new AMFChannel instance.

Parameters
id:String — The id of this Channel.
uri:String — The uri for this Channel.


mx.messaging.channels.HTTPChannel (Flex™ 2 Language Reference)

Class HTTPChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class HTTPChannel
Inheritance | HTTPChannel Inheritance PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object
Subclasses | SecureHTTPChannel

The HTTPChannel class provides the HTTP support for messaging. You can configure this Channel to poll the server at an interval to approximate server push. You can also use this Channel with polling disabled to send RPC messages to remote destinations to invoke their methods.

The HTTPChannel relies on network services native to Flash Player, and exposed to ActionScript by the URLLoader class. This channel uses URLLoader exclusively, and creates a new URLLoader per request.

Channels are created within the framework using the ServerConfig.getChannel() method. Channels can be constructed directly and assigned to a ChannelSet if desired.

Channels represent a physical connection to a remote endpoint. Channels are shared across destinations by default. This means that a client targetting different destinations may use the same Channel to communicate with these destinations.

When used in polling mode, this Channel polls the server for new messages based on the polling-interval-seconds property in the configuration file, and this can be changed by setting the pollingInterval property. The default value is 3 seconds. To enable polling, the channel must be connected and the polling-enabled property in the configuration file must be set to true, or the pollingEnabled property of the Channel must be set to true.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
 | polling : Boolean [read-only] Reports whether the channel is actively polling. | HTTPChannel
 | pollingEnabled : Boolean Indicates whether this channel is enabled to poll. | HTTPChannel
 | pollingInterval : Number Provides access to the polling interval for this Channel. | HTTPChannel
 | protocol : String [read-only] Returns the protocol for this channel (http). | HTTPChannel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HTTPChannel(id:String, uri:String = "")
Creates an new HTTPChannel instance.
HTTPChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
Inherited
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
polling property
polling:Boolean [read-only]

Reports whether the channel is actively polling.

Implementation
    public function get polling():Boolean
pollingEnabled property
pollingEnabled:Boolean [read-write]

Indicates whether this channel is enabled to poll.

Implementation
    public function get pollingEnabled():Boolean
    public function set pollingEnabled(value:Boolean):void
pollingInterval property
pollingInterval:Number [read-write]

Provides access to the polling interval for this Channel. The value is in milliseconds. This value determines how often this Channel requests messages from the server, to approximate server push.

Implementation
    public function get pollingInterval():Number
    public function set pollingInterval(value:Number):void

Throws
ArgumentError — If the pollingInterval is assigned a value of 0 or less.
protocol property
protocol:String [read-only]

Returns the protocol for this channel (http).

Implementation
    public function get protocol():String
Constructor detail
HTTPChannel () constructor
public function HTTPChannel(id:String, uri:String = "")

Creates an new HTTPChannel instance.

Parameters
id:String — The id of this Channel.
uri:String (default = "") — The uri for this Channel.


mx.messaging.channels.NetConnectionChannel (Flex™ 2 Language Reference)

Class NetConnectionChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class NetConnectionChannel
Inheritance | NetConnectionChannel Inheritance PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object
Subclasses | AMFChannel, RTMPChannel

This NetConnectionChannel provides the basic NetConnection support for messaging. The AMFChannel and RTMPChannel both extend this class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
 | netConnection : NetConnection [read-only] Provides access to the associated NetConnection for this Channel. | NetConnectionChannel
Inherited | protocol : String Provides access to the protocol that the channel uses. | Channel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NetConnectionChannel(id:String, uri:String)
Creates a new NetConnectionChannel instance.
NetConnectionChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
Inherited
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
netConnection property
netConnection:NetConnection [read-only]

Provides access to the associated NetConnection for this Channel.

Implementation
    public function get netConnection():NetConnection
Constructor detail
NetConnectionChannel () constructor
public function NetConnectionChannel(id:String, uri:String)

Creates a new NetConnectionChannel instance.

The underlying NetConnection's objectEncoding is set to ObjectEncoding.AMF3 by default. It can be changed manually by accessing the channel's netConnection property. The global NetConnection.defaultObjectEncoding setting is not honored by this channel.

Parameters
id:String — The id of this Channel.
uri:String — The uri for this Channel.


mx.messaging.channels.PollingChannel (Flex™ 2 Language Reference)

Class PollingChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class PollingChannel
Inheritance | PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object
Subclasses | HTTPChannel, NetConnectionChannel

The PollingChannel class provides the polling behavior that all polling channels in the messaging system require.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
Inherited | protocol : String Provides access to the protocol that the channel uses. | Channel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PollingChannel(id:String, uri:String)
Creates a new PollingChannel instance with the specified id.
PollingChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Constructor detail
PollingChannel () constructor
public function PollingChannel(id:String, uri:String)

Creates a new PollingChannel instance with the specified id. Once a PollingChannel is connected and begins polling, it will issue a poll request once every three seconds by default. Note: The PollingChannel type should not be constructed directly. Instead create instances of protocol specific subclasses such as HTTPChannel or AMFChannel that extend it.

Parameters
id:String — The id of this Channel.
uri:String — The uri for this Channel.
Method detail
disablePolling () method
public function disablePolling():void

Disables polling based on the number of times enablePolling() and disablePolling() have been invoked. If the net result is to disable polling the channel stop polling.

Invoked automatically based upon subscribing or unsubscribing from a remote destination over a PollingChannel.

enablePolling () method
public function enablePolling():void

Enables polling based on the number of times enablePolling() and disablePolling() have been invoked. If the net result is to enable polling the channel will poll the server on behalf of connected MessageAgents.

Invoked automatically based upon subscribing or unsubscribing from a remote destination over a PollingChannel.


mx.messaging.channels.RTMPChannel (Flex™ 2 Language Reference)

Class RTMPChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class RTMPChannel
Inheritance | RTMPChannel Inheritance NetConnectionChannel Inheritance PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object
Subclasses | SecureRTMPChannel

The RTMPChannel class provides basic RTMP support for messaging.

The RTMPChannel relies on network services native to Flash Player, and exposed to ActionScript by the NetConnection class. This Channel uses NetConnection exclusively, and creates a new NetConnection per instance.

Channels are created within the framework using the ServerConfig.getChannel() method. Channels can be constructed directly and assigned to a ChannelSet if desired.

Channels represent a physical connection to a remote endpoint. Channels are shared across destinations by default. This means that a client targetting different destinations may use the same Channel to communicate with these destinations.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
Inherited | netConnection : NetConnection Provides access to the associated NetConnection for this Channel. | NetConnectionChannel
 | protocol : String [read-only] Returns the protocol for this channel (rtmp). | RTMPChannel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RTMPChannel(id:String, uri:String)
Creates an new RTMPChannel instance.
RTMPChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
Inherited
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
protocol property
protocol:String [read-only]

Returns the protocol for this channel (rtmp).

Implementation
    public function get protocol():String
Constructor detail
RTMPChannel () constructor
public function RTMPChannel(id:String, uri:String)

Creates an new RTMPChannel instance.

Parameters
id:String — The id of this channel
uri:String — The uri for this channel


mx.messaging.channels.SecureAMFChannel (Flex™ 2 Language Reference)

Class SecureAMFChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class SecureAMFChannel
Inheritance | SecureAMFChannel Inheritance AMFChannel Inheritance NetConnectionChannel Inheritance PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object

The SecureAMFChannel class is identical to the AMFChannel class except that it uses a secure protocol, HTTPS, to send messages to an AMF endpoint.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
Inherited | netConnection : NetConnection Provides access to the associated NetConnection for this Channel. | NetConnectionChannel
Inherited | polling : Boolean Reports whether the channel is actively polling. | AMFChannel
Inherited | pollingEnabled : Boolean Indicates whether this channel is enabled to poll. | AMFChannel
Inherited | pollingInterval : Number Provides access to the polling interval for this Channel. | AMFChannel
 | protocol : String [read-only] Returns the protocol for this channel (https). | SecureAMFChannel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SecureAMFChannel(id:String, uri:String)
Creates an new SecureAMFChannel instance.
SecureAMFChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
Inherited
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
protocol property
protocol:String [read-only]

Returns the protocol for this channel (https).

Implementation
    public function get protocol():String
Constructor detail
SecureAMFChannel () constructor
public function SecureAMFChannel(id:String, uri:String)

Creates an new SecureAMFChannel instance.

Parameters
id:String — The id of this Channel.
uri:String — The uri for this Channel.


mx.messaging.channels.SecureHTTPChannel (Flex™ 2 Language Reference)

Class SecureHTTPChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class SecureHTTPChannel
Inheritance | SecureHTTPChannel Inheritance HTTPChannel Inheritance PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object

The SecureHTTPChannel class is identical to the HTTPChannel class except that it uses a secure protocol, HTTPS, to send messages to an HTTP endpoint.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
Inherited | polling : Boolean Reports whether the channel is actively polling. | HTTPChannel
Inherited | pollingEnabled : Boolean Indicates whether this channel is enabled to poll. | HTTPChannel
Inherited | pollingInterval : Number Provides access to the polling interval for this Channel. | HTTPChannel
 | protocol : String [read-only] Returns the protocol for this channel (https). | SecureHTTPChannel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SecureHTTPChannel(id:String, uri:String)
Creates an new SecureHTTPChannel instance.
SecureHTTPChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
Inherited
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
protocol property
protocol:String [read-only]

Returns the protocol for this channel (https).

Implementation
    public function get protocol():String
Constructor detail
SecureHTTPChannel () constructor
public function SecureHTTPChannel(id:String, uri:String)

Creates an new SecureHTTPChannel instance.

Parameters
id:String — The id of this Channel.
uri:String — The uri for this Channel.


mx.messaging.channels.SecureRTMPChannel (Flex™ 2 Language Reference)

Class SecureRTMPChannel | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.channels
Class | public class SecureRTMPChannel
Inheritance | SecureRTMPChannel Inheritance RTMPChannel Inheritance NetConnectionChannel Inheritance PollingChannel Inheritance Channel Inheritance EventDispatcher Inheritance Object

The SecureRTMPChannel class is identical to the RTMPChannel class except that it uses a secure protocol, RTMPS, to send messages to an RTMPS endpoint.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSets : Array Provides access to the ChannelSets connected to the Channel. | Channel
Inherited | connected : Boolean Indicates whether this channel has established a connection to the remote destination. | Channel
Inherited | connectTimeout : int Provides access to the connect timeout in seconds for the channel. | Channel
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpoint : String Provides access to the endpoint for this channel. | Channel
Inherited | failoverURIs : Array Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered. | Channel
Inherited | id : String Provides access to the id of this channel. | Channel
Inherited | netConnection : NetConnection Provides access to the associated NetConnection for this Channel. | NetConnectionChannel
 | protocol : String [read-only] Returns the protocol for this channel (rtmps). | SecureRTMPChannel
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether this channel is in the process of reconnecting to an alternate endpoint. | Channel
Inherited | requestTimeout : int Provides access to the default request timeout in seconds for the channel. | Channel
Inherited | uri : String Provides access to the URI used to create the whole endpoint URI for this channel. | Channel
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SecureRTMPChannel(id:String, uri:String)
Creates an new SecureRTMPChannel instance.
SecureRTMPChannel
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
applySettings(settings:XML):void
Subclasses should override this method to apply any settings that may be necessary for an individual channel.
Channel
Inherited
connect(channelSet:ChannelSet):void
Connects the ChannelSet to the Channel.
Channel
Inherited
disablePolling():void
Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
disconnect(channelSet:ChannelSet):void
Disconnects the ChannelSet from the Channel.
Channel
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
enablePolling():void
Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
PollingChannel
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout(agent:MessageAgent):void
Sends a CommandMessage to the server to logout if the Channel is connected.
Channel
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(agent:MessageAgent, message:IMessage):void
Sends the specified message to its target destination.
Channel
Inherited
setCredentials(credentials:String, agent:MessageAgent = null):void
Sets the credentials to the specified value.
Channel
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | connectFailed(event:ChannelFaultEvent):void Processes a failed internal connect and dispatches the FAULT event for the channel. | Channel
Inherited | connectSuccess():void Processes a successful internal connect and dispatches the CONNECT event for the Channel. | Channel
Inherited | connectTimeoutHandler(event:TimerEvent):void Handles a connect timeout by dispatching a ChannelFaultEvent. | Channel
Inherited | disconnectFailed(event:ChannelFaultEvent):void Processes a failed internal disconnect and dispatches the FAULT event for the channel. | Channel
Inherited | disconnectSuccess(rejected:Boolean = false):void Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel. | Channel
Inherited | getMessageResponder(agent:MessageAgent, message:IMessage):MessageResponder Returns the appropriate MessageResponder for the Channel's send() method. | Channel
Inherited | internalConnect():void Connects the Channel to its endpoint. | Channel
Inherited | internalDisconnect(rejected:Boolean = false):void Disconnects the Channel from its endpoint. | Channel
Inherited | internalSend(messageResponder:MessageResponder):void Sends the Message out over the Channel and routes the response to the responder. | Channel
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | channelConnect | Dispatched after the channel has connected to its endpoint. | Channel
Inherited | channelDisconnect | Dispatched after the channel has disconnected from its endpoint. | Channel
Inherited | channelFault | Dispatched after the channel has faulted. | Channel
Inherited | message | Dispatched when a channel receives a message from its endpoint. | Channel
Inherited | propertyChange | Dispatched when a property of the channel changes. | Channel
Property detail
protocol property
protocol:String [read-only]

Returns the protocol for this channel (rtmps).

Implementation
    public function get protocol():String
Constructor detail
SecureRTMPChannel () constructor
public function SecureRTMPChannel(id:String, uri:String)

Creates an new SecureRTMPChannel instance.

Parameters
id:String — The id of this Channel.
uri:String — The uri for this Channel.


mx.messaging.config Summary (Flex™ 2 Language Reference)

Package mx.messaging.config | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.messaging.config package contains the messaging configuration classes used with Flex Data Services .

Classes
Class | Description
LoaderConfig | This class acts as a context for the messaging framework so that it has access the URL and arguments of the SWF without needing access to the root MovieClip's LoaderInfo or Flex's Application class.
ServerConfig | This class provides access to the server messaging configuration information.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.messaging.config.LoaderConfig (Flex™ 2 Language Reference)

Class LoaderConfig | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.config
Class | public class LoaderConfig
Inheritance | LoaderConfig Inheritance Object

This class acts as a context for the messaging framework so that it has access the URL and arguments of the SWF without needing access to the root MovieClip's LoaderInfo or Flex's Application class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | parameters : Object [static][read-only] If the LoaderConfig has been initialized, this should represent the top-level MovieClip's parameters. | LoaderConfig
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | url : String [static][read-only] If the LoaderConfig has been initialized, this should represent the top-level MovieClip's URL. | LoaderConfig
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LoaderConfig() Constructor. | LoaderConfig
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
parameters property
parameters:Object [read-only]

If the LoaderConfig has been initialized, this should represent the top-level MovieClip's parameters.

Implementation
    public static function get parameters():Object
url property
url:String [read-only]

If the LoaderConfig has been initialized, this should represent the top-level MovieClip's URL.

Implementation
    public static function get url():String
Constructor detail
LoaderConfig () constructor
public function LoaderConfig()

Constructor.

One instance of LoaderConfig is created by the SystemManager. You should not need to construct your own.


mx.messaging.config.ServerConfig (Flex™ 2 Language Reference)

Class ServerConfig | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.config
Class | public class ServerConfig
Inheritance | ServerConfig Inheritance Object

This class provides access to the server messaging configuration information. This class encapsulates information from the services-config.xml file on the client and is used by the messaging system to provide configured ChannelSets and Channels to the messaging framework.

The XML source is provided during the compilation process. However, there is currently no internal restriction preventing the acquisition of this XML data by other means, such as network, local file system, or shared object at runtime.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | xml : XML [static] The XML configuration; this value must contain the relevant portions of the <services> tag from the services-config.xml file. | ServerConfig
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | getChannel(id:String, clustered:Boolean = false):Channel [static] Returns a shared instance of the configured Channel. | ServerConfig
 | getChannelSet(destinationId:String, message:IMessage, serverMessageType:String = null):ChannelSet [static] Returns a shared ChannelSet for use with the specified destination belonging to the service that handles the specified message type. | ServerConfig
 | getProperties(destinationId:String, serviceId:String = null):XMLList [static] Returns the property information for the specified destination | ServerConfig
 | getServiceIdForMessage(message:IMessage):String [static] Returns the id for the first service found that will service the specified message. | ServerConfig
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
xml property
xml:XML [read-write]

The XML configuration; this value must contain the relevant portions of the <services> tag from the services-config.xml file.

Implementation
    public static function get xml():XML
    public function set xml(value:XML):void
Method detail
getChannel () method
public static function getChannel(id:String, clustered:Boolean = false):Channel

Returns a shared instance of the configured Channel.

Parameters
id:String — The id of the desired Channel.
clustered:Boolean (default = false) — True if the Channel will be used in a clustered fashion; otherwise false.

Returns
Channel — The Channel instance.

Throws
InvalidChannelError — If no Channel has the specified id.
getChannelSet () method
public static function getChannelSet(destinationId:String, message:IMessage, serverMessageType:String = null):ChannelSet

Returns a shared ChannelSet for use with the specified destination belonging to the service that handles the specified message type.

If identical destinations are defined for multiple services that handle this message type, the first match is used and the others are ignored.

Parameters
destinationId:String — The target destination id.
message:IMessage — A message to send. Services correlate to message types, so the message disambiguates identically named destinations belonging to different services.
serverMessageType:String (default = null) — If specified, this value is used to disambiguate identically named destinations belonging to different services, rather than using the registered server class alias of the message argument. When this argument is provided the message argument can be passed as null because it will not be used.

Returns
ChannelSet — The ChannelSet.

Throws
InvalidDestinationError — If the specified destination is not defined or does not service messages of this type.
getProperties () method
public static function getProperties(destinationId:String, serviceId:String = null):XMLList

Returns the property information for the specified destination

Parameters
destinationId:String — The id of the desired destination.
serviceId:String (default = null) — The id of the service the destination belongs to.

Returns
XMLList — XMLList containing the <property> tag information.

Throws
InvalidDestinationError — If the specified destination is not found.
getServiceIdForMessage () method
public static function getServiceIdForMessage(message:IMessage):String

Returns the id for the first service found that will service the specified message.

Parameters
message:IMessage — The message to locate the corresponding service for.

Returns
String — The service id.

Throws
MessagingError — If no service is found that will process the message.


mx.messaging.errors Summary (Flex™ 2 Language Reference)

Package mx.messaging.errors | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.messaging.errors package contains the messaging error classes used with Flex Data Services.

Classes
Class | Description
ChannelError | This is the base class for any channel related errors.
InvalidChannelError | This error is thrown when a Channel can't be accessed or is not valid for the current destination.
InvalidDestinationError | This error is thrown when a destination can't be accessed or is not valid.
MessageSerializationError | This error indicates a problem serializing a message within a channel.
MessagingError | This is the base class for any messaging related error.
NoChannelAvailableError | This error is thrown when no Channel is available to send messages.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.messaging.errors.ChannelError (Flex™ 2 Language Reference)

Class ChannelError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.errors
Class | public class ChannelError
Inheritance | ChannelError Inheritance MessagingError Inheritance Error Inheritance Object
Subclasses | InvalidChannelError, InvalidDestinationError

This is the base class for any channel related errors. It allows for less granular catch code.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ChannelError(msg:String) Constructs a new instance of a ChannelError with the specified message. | ChannelError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "[MessagingError]" by default, and includes the message property if defined. | MessagingError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
ChannelError () constructor
public function ChannelError(msg:String)

Constructs a new instance of a ChannelError with the specified message.

Parameters
msg:String — String that contains the message that describes the error.


mx.messaging.errors.InvalidChannelError (Flex™ 2 Language Reference)

Class InvalidChannelError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.errors
Class | public class InvalidChannelError
Inheritance | InvalidChannelError Inheritance ChannelError Inheritance MessagingError Inheritance Error Inheritance Object

This error is thrown when a Channel can't be accessed or is not valid for the current destination. This error is thrown by the following methods/properties within the framework:
  • ServerConfig.getChannel() if the channel can't be found based on channel id.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | InvalidChannelError(msg:String) Constructs a new instance of an InvalidChannelError with the specified message. | InvalidChannelError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "[MessagingError]" by default, and includes the message property if defined. | MessagingError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
InvalidChannelError () constructor
public function InvalidChannelError(msg:String)

Constructs a new instance of an InvalidChannelError with the specified message.

Parameters
msg:String — String that contains the message that describes this InvalidChannelError.


mx.messaging.errors.InvalidDestinationError (Flex™ 2 Language Reference)

Class InvalidDestinationError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.errors
Class | public class InvalidDestinationError
Inheritance | InvalidDestinationError Inheritance ChannelError Inheritance MessagingError Inheritance Error Inheritance Object

This error is thrown when a destination can't be accessed or is not valid. This error is thrown by the following methods/properties within the framework:
  • ServerConfig.getChannelSet() if an invalid destination is specified.
  • ServerConfig.getProperties() if an invalid destination is specified.
  • Channel.send() if no destination is specified for the message to send.
  • MessageAgent.destination setter if the destination value is null or zero length.
  • Producer.send() if no destination is specified for the Producer or message to send.
  • Consumer.subscribe() if no destination is specified for the Consumer.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | InvalidDestinationError(msg:String) Constructs a new instance of an InvalidDestinationError with the specified message. | InvalidDestinationError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "[MessagingError]" by default, and includes the message property if defined. | MessagingError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
InvalidDestinationError () constructor
public function InvalidDestinationError(msg:String)

Constructs a new instance of an InvalidDestinationError with the specified message.

Parameters
msg:String — String that contains the message that describes this InvalidDestinationError.


mx.messaging.errors.MessageSerializationError (Flex™ 2 Language Reference)

Class MessageSerializationError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.errors
Class | public class MessageSerializationError
Inheritance | MessageSerializationError Inheritance MessagingError Inheritance Error Inheritance Object

This error indicates a problem serializing a message within a channel. It provides a fault property which corresponds to an ErrorMessage generated when this error is thrown.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
 | fault : ErrorMessage Provides specific information about the fault that occurred and for which message. | MessageSerializationError
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MessageSerializationError(msg:String, fault:ErrorMessage) Constructs a new instance of the MessageSerializationError with the specified message. | MessageSerializationError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "[MessagingError]" by default, and includes the message property if defined. | MessagingError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
fault property
public var fault:ErrorMessage

Provides specific information about the fault that occurred and for which message.

Constructor detail
MessageSerializationError () constructor
public function MessageSerializationError(msg:String, fault:ErrorMessage)

Constructs a new instance of the MessageSerializationError with the specified message.

Parameters
msg:String — String that contains the message that describes the error.
fault:ErrorMessage


mx.messaging.errors.MessagingError (Flex™ 2 Language Reference)

Class MessagingError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.errors
Class | public class MessagingError
Inheritance | MessagingError Inheritance Error Inheritance Object
Subclasses | ChannelError, MessageSerializationError, NoChannelAvailableError

This is the base class for any messaging related error. It allows for less granular catch code.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MessagingError(msg:String) Constructs a new instance of a MessagingError with the specified message. | MessagingError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns the string "[MessagingError]" by default, and includes the message property if defined. | MessagingError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
MessagingError () constructor
public function MessagingError(msg:String)

Constructs a new instance of a MessagingError with the specified message.

Parameters
msg:String — String that contains the message that describes the error.
Method detail
toString () method
public function toString():String

Returns the string "[MessagingError]" by default, and includes the message property if defined.

Returns
String — String representation of the MessagingError.


mx.messaging.errors.NoChannelAvailableError (Flex™ 2 Language Reference)

Class NoChannelAvailableError | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.errors
Class | public class NoChannelAvailableError
Inheritance | NoChannelAvailableError Inheritance MessagingError Inheritance Error Inheritance Object

This error is thrown when no Channel is available to send messages. This error is thrown by the following methods within the framework:
  • ChannelSet.send() if the ChannelSet has no channels.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | NoChannelAvailableError(msg:String) Constructs a new instance of the NoChannelAvailableError with the specified message. | NoChannelAvailableError
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string "[MessagingError]" by default, and includes the message property if defined. | MessagingError
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
NoChannelAvailableError () constructor
public function NoChannelAvailableError(msg:String)

Constructs a new instance of the NoChannelAvailableError with the specified message.

Parameters
msg:String — String that contains the message that describes this NoChannelAvailableError.


mx.messaging.events Summary (Flex™ 2 Language Reference)

Package mx.messaging.events | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.messaging.events package contains the messaging event classes used with Flex Data Services.

Classes
Class | Description
ChannelEvent | The ChannelEvent is used to propagate channel events within the messaging system.
ChannelFaultEvent | The ChannelFaultEvent class is used to propagate channel fault events within the messaging system.
MessageAckEvent | The MessageAckEvent class is used to propagate acknowledge messages within the messaging system.
MessageEvent | The MessageEvent class is used to propagate messages within the messaging system.
MessageFaultEvent | The MessageFaultEvent class is used to propagate fault messages within the messaging system.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.messaging.events.ChannelEvent (Flex™ 2 Language Reference)

Class ChannelEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.events
Class | public class ChannelEvent
Inheritance | ChannelEvent Inheritance Event Inheritance Object
Subclasses | ChannelFaultEvent

The ChannelEvent is used to propagate channel events within the messaging system.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
 | channel : Channel The Channel that generated this event. | ChannelEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | reconnecting : Boolean Indicates whether the Channel that generated this event is reconnecting. | ChannelEvent
 | rejected : Boolean Indicates whether the Channel that generated this event was rejected. | ChannelEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ChannelEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, channel:Channel = null, reconnecting:Boolean = false, rejected:Boolean = false)
Constructs an instance of this event with the specified type and Channel instance.
ChannelEvent
clone():Event
Clones the ChannelEvent.
ChannelEvent
createEvent(type:String, channel:Channel = null, reconnecting:Boolean = false, rejected:Boolean = false):ChannelEvent
[static] Utility method to create a new ChannelEvent that doesn't bubble and is not cancelable.
ChannelEvent
Inherited
formatToString(className:String, ... arguments):String
A utility function for implementing the toString() method in your custom Event class.
Event
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isDefaultPrevented():Boolean
Checks whether preventDefault() has been called on the event.
Event
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
preventDefault():void
Cancels an event's default behavior if that behavior can be canceled.
Event
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
stopImmediatePropagation():void
Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow.
Event
Inherited
stopPropagation():void
Prevents processing of any event listeners in nodes subsequent to the current node in the event flow.
Event
toString():String
Returns a string representation of the ChannelEvent.
ChannelEvent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
 | CONNECT : String = "channelConnect" [static] The CONNECT event type; indicates that the Channel connected to its endpoint. | ChannelEvent
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
 | DISCONNECT : String = "channelDisconnect" [static] The DISCONNECT event type; indicates that the Channel disconnected from its endpoint. | ChannelEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
channel property
public var channel:Channel

The Channel that generated this event.

reconnecting property
public var reconnecting:Boolean

Indicates whether the Channel that generated this event is reconnecting.

rejected property
public var rejected:Boolean

Indicates whether the Channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.

Constructor detail
ChannelEvent () constructor
public function ChannelEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, channel:Channel = null, reconnecting:Boolean = false, rejected:Boolean = false)

Constructs an instance of this event with the specified type and Channel instance.

Parameters
type:String — The ChannelEvent type.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Indicates whether the behavior associated with the event can be prevented; used by the RPC subclasses.
channel:Channel (default = null) — The Channel generating the event.
reconnecting:Boolean (default = false) — Indicates whether the Channel is in the process of reconnecting or not.
rejected:Boolean (default = false) — Indicates whether the Channel's connection has been rejected, which suppresses automatic reconnection.
Method detail
clone () method
public override function clone():Event

Clones the ChannelEvent.

Returns
Event — Copy of this ChannelEvent.
createEvent () method
public static function createEvent(type:String, channel:Channel = null, reconnecting:Boolean = false, rejected:Boolean = false):ChannelEvent

Utility method to create a new ChannelEvent that doesn't bubble and is not cancelable.

Parameters
type:String — The ChannelEvent type.
channel:Channel (default = null) — The Channel generating the event.
reconnecting:Boolean (default = false) — Indicates whether the Channel is in the process of reconnecting or not.
rejected:Boolean (default = false) — Indicates whether the Channel's connection has been rejected, which suppresses automatic reconnection.

Returns
ChannelEvent — New ChannelEvent.
toString () method
public override function toString():String

Returns a string representation of the ChannelEvent.

Returns
String — String representation of the ChannelEvent.
Constant detail
CONNECT constant
public static const CONNECT:String = "channelConnect"

The CONNECT event type; indicates that the Channel connected to its endpoint.

The value of this constant is "channelConnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.
DISCONNECT constant
public static const DISCONNECT:String = "channelDisconnect"

The DISCONNECT event type; indicates that the Channel disconnected from its endpoint.

The value of this constant is "channelDisconnect".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rejected | Indicates whether the channel that generated this event was rejected. This would be true in the event that the channel has been disconnected due to inactivity and should not attempt to failover or connect on an alternate channel.


mx.messaging.events.ChannelFaultEvent (Flex™ 2 Language Reference)

Class ChannelFaultEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.events
Class | public class ChannelFaultEvent
Inheritance | ChannelFaultEvent Inheritance ChannelEvent Inheritance Event Inheritance Object

The ChannelFaultEvent class is used to propagate channel fault events within the messaging system.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | channel : Channel The Channel that generated this event. | ChannelEvent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | faultCode : String Provides access to the destination-specific failure code. | ChannelFaultEvent
 | faultDetail : String Provides destination-specific details of the failure. | ChannelFaultEvent
 | faultString : String Provides access to the destination-specific reason for the failure. | ChannelFaultEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | reconnecting : Boolean Indicates whether the Channel that generated this event is reconnecting. | ChannelEvent
Inherited | rejected : Boolean Indicates whether the Channel that generated this event was rejected. | ChannelEvent
 | rootCause : Object Provides access to the underlying reason for the failure if the channel did not raise the failure itself. | ChannelFaultEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ChannelFaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, channel:Channel = null, reconnecting:Boolean = false, code:String = null, level:String = null, description:String = null)
Constructs an instance of this event with the specified type.
ChannelFaultEvent
clone():Event
Clones the ChannelFaultEvent.
ChannelFaultEvent
createErrorMessage():ErrorMessage
Creates an ErrorMessage based on the ChannelFaultEvent by copying over the faultCode, faultString, faultDetail and rootCause to the new ErrorMessage.
ChannelFaultEvent
createEvent(channel:Channel, reconnecting:Boolean = false, code:String = null, level:String = null, description:String = null):ChannelFaultEvent
[static] Utility method to create a new ChannelFaultEvent that doesn't bubble and is not cancelable.
ChannelFaultEvent
Inherited
formatToString(className:String, ... arguments):String
A utility function for implementing the toString() method in your custom Event class.
Event
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isDefaultPrevented():Boolean
Checks whether preventDefault() has been called on the event.
Event
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
preventDefault():void
Cancels an event's default behavior if that behavior can be canceled.
Event
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
stopImmediatePropagation():void
Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow.
Event
Inherited
stopPropagation():void
Prevents processing of any event listeners in nodes subsequent to the current node in the event flow.
Event
toString():String
Returns a string representation of the ChannelFaultEvent.
ChannelFaultEvent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "channelConnect" [static] The CONNECT event type; indicates that the Channel connected to its endpoint. | ChannelEvent
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | DISCONNECT : String = "channelDisconnect" [static] The DISCONNECT event type; indicates that the Channel disconnected from its endpoint. | ChannelEvent
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | FAULT : String = "channelFault" [static] The FAULT event type; indicates that the Channel faulted. | ChannelFaultEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
faultCode property
public var faultCode:String

Provides access to the destination-specific failure code. For more specific details see the faultString and faultDetails properties.

The format of the fault codes are provided by the remote destination, but will typically have the following form: host.operation.error e.g. "Server.Connect.Failed"

See also

faultString
faultDetail
faultDetail property
public var faultDetail:String

Provides destination-specific details of the failure.

Typically fault details are a stack trace of an exception thrown at the remote destination.

See also

faultString
faultCode
faultString property
public var faultString:String

Provides access to the destination-specific reason for the failure.

See also

faultCode
faultDetail
rootCause property
public var rootCause:Object

Provides access to the underlying reason for the failure if the channel did not raise the failure itself.

Constructor detail
ChannelFaultEvent () constructor
public function ChannelFaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, channel:Channel = null, reconnecting:Boolean = false, code:String = null, level:String = null, description:String = null)

Constructs an instance of this event with the specified type.

Parameters
type:String — The Channel generating the event.
bubbles:Boolean (default = false) — Indicates whether the Channel is in the process of reconnecting or not.
cancelable:Boolean (default = false) — The fault code.
channel:Channel (default = null) — The fault level.
reconnecting:Boolean (default = false) — The fault description.
code:String (default = null)
level:String (default = null)
description:String (default = null)
Method detail
clone () method
public override function clone():Event

Clones the ChannelFaultEvent.

Returns
Event — Copy of this ChannelFaultEvent.
createErrorMessage () method
public function createErrorMessage():ErrorMessage

Creates an ErrorMessage based on the ChannelFaultEvent by copying over the faultCode, faultString, faultDetail and rootCause to the new ErrorMessage.

Returns
ErrorMessage — The ErrorMessage.
createEvent () method
public static function createEvent(channel:Channel, reconnecting:Boolean = false, code:String = null, level:String = null, description:String = null):ChannelFaultEvent

Utility method to create a new ChannelFaultEvent that doesn't bubble and is not cancelable.

Parameters
channel:Channel — The Channel generating the event.
reconnecting:Boolean (default = false) — Indicates whether the Channel is in the process of reconnecting or not.
code:String (default = null) — The fault code.
level:String (default = null) — The fault level.
description:String (default = null) — The fault description.

Returns
ChannelFaultEvent — New ChannelFaultEvent.
toString () method
public override function toString():String

Returns a string representation of the ChannelFaultEvent.

Returns
String — String representation of the ChannelFaultEvent.
Constant detail
FAULT constant
public static const FAULT:String = "channelFault"

The FAULT event type; indicates that the Channel faulted.

The value of this constant is "channelFault".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
channel | The Channel that generated this event.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
faultCode | Provides destination-specific details of the failure.
faultDetail | Provides access to the destination-specific reason for the failure.
faultString | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
reconnecting | Indicates whether the channel that generated this event is reconnecting.
rootCause | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.messaging.events.MessageAckEvent (Flex™ 2 Language Reference)

Class MessageAckEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.events
Class | public class MessageAckEvent
Inheritance | MessageAckEvent Inheritance MessageEvent Inheritance Event Inheritance Object

The MessageAckEvent class is used to propagate acknowledge messages within the messaging system.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | acknowledgeMessage : AcknowledgeMessage [read-only] Utility property to get the message property from the MessageEvent as an AcknowledgeMessage. | MessageAckEvent
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | correlation : IMessage The original Message correlated with this acknowledgement. | MessageAckEvent
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MessageAckEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, ack:AcknowledgeMessage = null, correlation:IMessage = null)
Constructs an instance of this event with the specified acknowledge message and original correlated message.
MessageAckEvent
clone():Event
Clones the MessageAckEvent.
MessageAckEvent
createEvent(ack:AcknowledgeMessage = null, correlation:IMessage = null):MessageAckEvent
[static] Utility method to create a new MessageAckEvent that doesn't bubble and is not cancelable.
MessageAckEvent
Inherited
formatToString(className:String, ... arguments):String
A utility function for implementing the toString() method in your custom Event class.
Event
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isDefaultPrevented():Boolean
Checks whether preventDefault() has been called on the event.
Event
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
preventDefault():void
Cancels an event's default behavior if that behavior can be canceled.
Event
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
stopImmediatePropagation():void
Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow.
Event
Inherited
stopPropagation():void
Prevents processing of any event listeners in nodes subsequent to the current node in the event flow.
Event
toString():String
Returns a string representation of the MessageAckEvent.
MessageAckEvent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
 | ACKNOWLEDGE : String = "acknowledge" [static] The ACKNOWLEDGE event type; dispatched upon receipt of an acknowledgement. | MessageAckEvent
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
acknowledgeMessage property
acknowledgeMessage:AcknowledgeMessage [read-only]

Utility property to get the message property from the MessageEvent as an AcknowledgeMessage.

Implementation
    public function get acknowledgeMessage():AcknowledgeMessage
correlation property
public var correlation:IMessage

The original Message correlated with this acknowledgement.

Constructor detail
MessageAckEvent () constructor
public function MessageAckEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, ack:AcknowledgeMessage = null, correlation:IMessage = null)

Constructs an instance of this event with the specified acknowledge message and original correlated message.

Parameters
type:String — The type for the MessageAckEvent.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Indicates whether the behavior associated with the event can be prevented.
ack:AcknowledgeMessage (default = null) — The AcknowledgeMessage this event should dispatch.
correlation:IMessage (default = null) — The message correlated with this acknowledgement.
Method detail
clone () method
public override function clone():Event

Clones the MessageAckEvent.

Returns
Event — Copy of this MessageAckEvent.
createEvent () method
public static function createEvent(ack:AcknowledgeMessage = null, correlation:IMessage = null):MessageAckEvent

Utility method to create a new MessageAckEvent that doesn't bubble and is not cancelable.

Parameters
ack:AcknowledgeMessage (default = null) — The AcknowledgeMessage this event should dispatch.
correlation:IMessage (default = null) — The Message correlated with this acknowledgement.

Returns
MessageAckEvent — New MessageAckEvent.
toString () method
public override function toString():String

Returns a string representation of the MessageAckEvent.

Returns
String — String representation of the MessageAckEvent.
Constant detail
ACKNOWLEDGE constant
public static const ACKNOWLEDGE:String = "acknowledge"

The ACKNOWLEDGE event type; dispatched upon receipt of an acknowledgement.

The value of this constant is "acknowledge".

The properties of the event object have the following values:

Property | Value
acknowledgeMessage | Utility property to get the message property from MessageEvent as an AcknowledgeMessage.
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
correlate | The original Message correlated with this acknowledgement.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.messaging.events.MessageEvent (Flex™ 2 Language Reference)

Class MessageEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.events
Class | public class MessageEvent
Inheritance | MessageEvent Inheritance Event Inheritance Object
Subclasses | AbstractEvent, MessageAckEvent

The MessageEvent class is used to propagate messages within the messaging system.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MessageEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, message:IMessage = null) Constructs an instance of this event with the specified type and message. | MessageEvent
 | clone():Event Clones the MessageEvent. | MessageEvent
 | createEvent(type:String, msg:IMessage):MessageEvent [static] Utility method to create a new MessageEvent that doesn't bubble and is not cancelable. | MessageEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string representation of the MessageEvent. | MessageEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
message property
public var message:IMessage

The Message associated with this event.

Constructor detail
MessageEvent () constructor
public function MessageEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, message:IMessage = null)

Constructs an instance of this event with the specified type and message.

Parameters
type:String — The type for the MessageEvent.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Indicates whether the behavior associated with the event can be prevented; used by the RPC subclasses.
message:IMessage (default = null) — The associated message.
Method detail
clone () method
public override function clone():Event

Clones the MessageEvent.

Returns
Event — Copy of this MessageEvent.
createEvent () method
public static function createEvent(type:String, msg:IMessage):MessageEvent

Utility method to create a new MessageEvent that doesn't bubble and is not cancelable.

Parameters
type:String — The type for the MessageEvent.
msg:IMessage — The associated message.

Returns
MessageEvent — New MessageEvent.
toString () method
public override function toString():String

Returns a string representation of the MessageEvent.

Returns
String — String representation of the MessageEvent.
Constant detail
MESSAGE constant
public static const MESSAGE:String = "message"

The MESSAGE event type; dispatched upon receipt of a message.

The value of this constant is "message".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
RESULT constant
public static const RESULT:String = "result"

The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination.

The value of this constant is "result".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.messaging.events.MessageFaultEvent (Flex™ 2 Language Reference)

Class MessageFaultEvent | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.events
Class | public class MessageFaultEvent
Inheritance | MessageFaultEvent Inheritance Event Inheritance Object

The MessageFaultEvent class is used to propagate fault messages within the messaging system.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | faultCode : String [read-only] Provides access to the destination specific failure code. | MessageFaultEvent
 | faultDetail : String [read-only] Provides destination specific details of the failure. | MessageFaultEvent
 | faultString : String [read-only] Provides access to the destination specific reason for the failure. | MessageFaultEvent
 | message : ErrorMessage The ErrorMessage for this event. | MessageFaultEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rootCause : Object [read-only] Provides access to the root cause of the failure, if one exists. | MessageFaultEvent
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MessageFaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, message:ErrorMessage = null)
Constructs an instance of a fault message event for the specified message and fault information.
MessageFaultEvent
clone():Event
Clones the MessageFaultEvent.
MessageFaultEvent
createEvent(msg:ErrorMessage):MessageFaultEvent
[static] Utility method to create a new MessageFaultEvent that doesn't bubble and is not cancelable.
MessageFaultEvent
Inherited
formatToString(className:String, ... arguments):String
A utility function for implementing the toString() method in your custom Event class.
Event
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isDefaultPrevented():Boolean
Checks whether preventDefault() has been called on the event.
Event
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
preventDefault():void
Cancels an event's default behavior if that behavior can be canceled.
Event
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
stopImmediatePropagation():void
Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow.
Event
Inherited
stopPropagation():void
Prevents processing of any event listeners in nodes subsequent to the current node in the event flow.
Event
toString():String
Returns a string representation of the MessageFaultEvent.
MessageFaultEvent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | FAULT : String = "fault" [static] The FAULT event type; dispatched for a message fault. | MessageFaultEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
faultCode property
faultCode:String [read-only]

Provides access to the destination specific failure code. For more specific details see faultString and faultDetails properties.

The format of the fault codes are provided by the remote destination, but, will typically have the following form: host.operation.error For example, "Server.Connect.Failed"

Implementation
    public function get faultCode():String

See also

faultString
faultDetail
faultDetail property
faultDetail:String [read-only]

Provides destination specific details of the failure.

Typically fault details are a stack trace of an exception thrown at the remote destination.

Implementation
    public function get faultDetail():String

See also

faultString
faultCode
faultString property
faultString:String [read-only]

Provides access to the destination specific reason for the failure.

Implementation
    public function get faultString():String

See also

faultCode
faultDetail
message property
public var message:ErrorMessage

The ErrorMessage for this event.

rootCause property
rootCause:Object [read-only]

Provides access to the root cause of the failure, if one exists. In the case of custom exceptions thrown by a destination, the root cause represents the top level failure that is merely transported by the ErrorMessage.

Implementation
    public function get rootCause():Object

See also

MessageFaultEvent.rootCause
Constructor detail
MessageFaultEvent () constructor
public function MessageFaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, message:ErrorMessage = null)

Constructs an instance of a fault message event for the specified message and fault information.

Parameters
type:String — The type for the MessageAckEvent.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Indicates whether the behavior associated with the event can be prevented.
message:ErrorMessage (default = null) — The ErrorMessage associated with the fault.
Method detail
clone () method
public override function clone():Event

Clones the MessageFaultEvent.

Returns
Event — Copy of this MessageFaultEvent.
createEvent () method
public static function createEvent(msg:ErrorMessage):MessageFaultEvent

Utility method to create a new MessageFaultEvent that doesn't bubble and is not cancelable.

Parameters
msg:ErrorMessage — The ErrorMessage associated with the fault.

Returns
MessageFaultEvent — New MessageFaultEvent.
toString () method
public override function toString():String

Returns a string representation of the MessageFaultEvent.

Returns
String — String representation of the MessageFaultEvent.
Constant detail
FAULT constant
public static const FAULT:String = "fault"

The FAULT event type; dispatched for a message fault.

The value of this constant is "fault".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
faultCode | Provides destination-specific details of the failure.
faultDetail | Provides access to the destination-specific reason for the failure.
faultString | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
message | The ErrorMessage for this event.
rootCause | Provides access to the underlying reason for the failure, if one exists.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.messaging.management Summary (Flex™ 2 Language Reference)

Package mx.messaging.management | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.messaging.management package contains the bean management classes used with Flex Data Services.

Classes
Class | Description
MBeanAttributeInfo | Client representation of metadata for a MBean attribute.
MBeanFeatureInfo | Client representation of metadata for a MBean feature.
MBeanInfo | Client representation of metadata for a MBean.
MBeanOperationInfo | Client representation of metadata for a MBean operation.
MBeanParameterInfo | Client representation of metadata for a MBean operation parameter.
ObjectInstance | Client representation of an object name instance for server-side management controls.
ObjectName | Client representation of the name for server-side management controls.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.messaging.management.MBeanAttributeInfo (Flex™ 2 Language Reference)

Class MBeanAttributeInfo | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.management
Class | public class MBeanAttributeInfo
Inheritance | MBeanAttributeInfo Inheritance MBeanFeatureInfo Inheritance Object

Client representation of metadata for a MBean attribute.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | description : String The description of the MBean feature. | MBeanFeatureInfo
 | isIs : Boolean Indicates if the server-side getter for the attribute has an 'is' prefix. | MBeanAttributeInfo
Inherited | name : String The name of the MBean feature. | MBeanFeatureInfo
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | readable : Boolean Indicates if the attribute is readable. | MBeanAttributeInfo
 | type : String The data type of the attribute. | MBeanAttributeInfo
 | writable : Boolean Indicates if the attribute is writable. | MBeanAttributeInfo
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MBeanAttributeInfo() Creates a new instance of an empty MBeanAttributeInfo. | MBeanAttributeInfo
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the feature info. | MBeanFeatureInfo
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
isIs property
public var isIs:Boolean

Indicates if the server-side getter for the attribute has an 'is' prefix.

readable property
public var readable:Boolean

Indicates if the attribute is readable.

type property
public var type:String

The data type of the attribute.

writable property
public var writable:Boolean

Indicates if the attribute is writable.

Constructor detail
MBeanAttributeInfo () constructor
public function MBeanAttributeInfo()

Creates a new instance of an empty MBeanAttributeInfo.


mx.messaging.management.MBeanFeatureInfo (Flex™ 2 Language Reference)

Class MBeanFeatureInfo | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.management
Class | public class MBeanFeatureInfo
Inheritance | MBeanFeatureInfo Inheritance Object
Subclasses | MBeanAttributeInfo, MBeanOperationInfo, MBeanParameterInfo

Client representation of metadata for a MBean feature.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | description : String The description of the MBean feature. | MBeanFeatureInfo
 | name : String The name of the MBean feature. | MBeanFeatureInfo
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MBeanFeatureInfo() Creates a new instance of an empty MBeanFeatureInfo. | MBeanFeatureInfo
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string representation of the feature info. | MBeanFeatureInfo
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
description property
public var description:String

The description of the MBean feature.

name property
public var name:String

The name of the MBean feature.

Constructor detail
MBeanFeatureInfo () constructor
public function MBeanFeatureInfo()

Creates a new instance of an empty MBeanFeatureInfo.

Method detail
toString () method
public function toString():String

Returns a string representation of the feature info.

Returns
String — String representation of the feature info.


mx.messaging.management.MBeanInfo (Flex™ 2 Language Reference)

Class MBeanInfo | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.management
Class | public class MBeanInfo
Inheritance | MBeanInfo Inheritance Object

Client representation of metadata for a MBean.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | attributes : Array The attributes exposed by the MBean. | MBeanInfo
 | className : String The class name for the MBean. | MBeanInfo
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | constructors : Array The constructors exposed by the MBean. | MBeanInfo
 | description : String The description for the MBean. | MBeanInfo
 | operations : Array The operations provided by the MBean. | MBeanInfo
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MBeanInfo() Creates a new instance of an empty MBeanInfo. | MBeanInfo
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string representation of the MBean info. | MBeanInfo
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
attributes property
public var attributes:Array

The attributes exposed by the MBean.

className property
public var className:String

The class name for the MBean.

constructors property
public var constructors:Array

The constructors exposed by the MBean.

description property
public var description:String

The description for the MBean.

operations property
public var operations:Array

The operations provided by the MBean.

Constructor detail
MBeanInfo () constructor
public function MBeanInfo()

Creates a new instance of an empty MBeanInfo.

Method detail
toString () method
public function toString():String

Returns a string representation of the MBean info.

Returns
String — String representation of the MBean info.


mx.messaging.management.MBeanOperationInfo (Flex™ 2 Language Reference)

Class MBeanOperationInfo | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.management
Class | public class MBeanOperationInfo
Inheritance | MBeanOperationInfo Inheritance MBeanFeatureInfo Inheritance Object

Client representation of metadata for a MBean operation.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | description : String The description of the MBean feature. | MBeanFeatureInfo
 | impact : int The impact of the operation. | MBeanOperationInfo
Inherited | name : String The name of the MBean feature. | MBeanFeatureInfo
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | returnType : String The return data type for the operation. | MBeanOperationInfo
 | signature : Array The parameter data types that make up the operation signature. | MBeanOperationInfo
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MBeanOperationInfo() Creates a new instance of an empty MBeanOperationInfo. | MBeanOperationInfo
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the feature info. | MBeanFeatureInfo
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ACTION : int = 1 The operation is write-like, updating the control in some way. | MBeanOperationInfo
 | ACTION_INFO : int = 2 The operation is both read-like and write-like, updating the control and returning information. | MBeanOperationInfo
 | INFO : int = 0 The operation is purely informational with no side-effects, read-only. | MBeanOperationInfo
 | UNKNOWN : int = 3 The side-effects for the operation are unknown. | MBeanOperationInfo
Property detail
impact property
public var impact:int

The impact of the operation. One of four possible values, defined as constants for this class.

See also

INFO
ACTION
ACTION_INFO
UNKNOWN
returnType property
public var returnType:String

The return data type for the operation.

signature property
public var signature:Array

The parameter data types that make up the operation signature.

Constructor detail
MBeanOperationInfo () constructor
public function MBeanOperationInfo()

Creates a new instance of an empty MBeanOperationInfo.

Constant detail
ACTION constant
public const ACTION:int = 1

The operation is write-like, updating the control in some way.

ACTION_INFO constant
public const ACTION_INFO:int = 2

The operation is both read-like and write-like, updating the control and returning information.

INFO constant
public const INFO:int = 0

The operation is purely informational with no side-effects, read-only.

UNKNOWN constant
public const UNKNOWN:int = 3

The side-effects for the operation are unknown.


mx.messaging.management.MBeanParameterInfo (Flex™ 2 Language Reference)

Class MBeanParameterInfo | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.management
Class | public class MBeanParameterInfo
Inheritance | MBeanParameterInfo Inheritance MBeanFeatureInfo Inheritance Object

Client representation of metadata for a MBean operation parameter.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | description : String The description of the MBean feature. | MBeanFeatureInfo
Inherited | name : String The name of the MBean feature. | MBeanFeatureInfo
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | type : String The data type of the operation parameter. | MBeanParameterInfo
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | MBeanParameterInfo() Creates a new instance of an empty MBeanParameterInfo. | MBeanParameterInfo
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the feature info. | MBeanFeatureInfo
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
type property
public var type:String

The data type of the operation parameter.

Constructor detail
MBeanParameterInfo () constructor
public function MBeanParameterInfo()

Creates a new instance of an empty MBeanParameterInfo.


mx.messaging.management.ObjectInstance (Flex™ 2 Language Reference)

Class ObjectInstance | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.management
Class | public class ObjectInstance
Inheritance | ObjectInstance Inheritance Object

Client representation of an object name instance for server-side management controls.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | className : String The class name. | ObjectInstance
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | objectName : ObjectName The object name. | ObjectInstance
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ObjectInstance() Creates a new instance of an empty ObjectInstance. | ObjectInstance
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string representation of the object name instance. | ObjectInstance
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
className property
public var className:String

The class name.

objectName property
public var objectName:ObjectName

The object name.

Constructor detail
ObjectInstance () constructor
public function ObjectInstance()

Creates a new instance of an empty ObjectInstance.

Method detail
toString () method
public function toString():String

Returns a string representation of the object name instance.

Returns
String — String representation of the object name instance.


mx.messaging.management.ObjectName (Flex™ 2 Language Reference)

Class ObjectName | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.management
Class | public class ObjectName
Inheritance | ObjectName Inheritance Object

Client representation of the name for server-side management controls.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | canonicalKeyPropertyListString : String A string representation of the list of key properties, with the key properties sorted in lexical order. | ObjectName
 | canonicalName : String The canonical form of the name; a string representation with the properties sorted in lexical order. | ObjectName
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | domain : String The domain part. | ObjectName
 | domainPattern : Boolean Indicates if the object name is a pattern on the domain part. | ObjectName
 | keyPropertyList : Object The key properties as an Object, keyed by property name. | ObjectName
 | keyPropertyListString : String A string representation of the list of key properties. | ObjectName
 | pattern : Boolean Indicates if the object name is a pattern. | ObjectName
 | propertyPattern : Boolean Indicates if the object name is a pattern on the key properties. | ObjectName
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ObjectName() Creates a new instance of an empty ObjectName. | ObjectName
 | getKeyProperty(property:String):Object Returns the value associated with the specified property key. | ObjectName
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String This method will return a string representation of the object name. | ObjectName
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
canonicalKeyPropertyListString property
public var canonicalKeyPropertyListString:String

A string representation of the list of key properties, with the key properties sorted in lexical order.

canonicalName property
public var canonicalName:String

The canonical form of the name; a string representation with the properties sorted in lexical order.

domain property
public var domain:String

The domain part.

domainPattern property
public var domainPattern:Boolean

Indicates if the object name is a pattern on the domain part.

keyPropertyList property
public var keyPropertyList:Object

The key properties as an Object, keyed by property name.

keyPropertyListString property
public var keyPropertyListString:String

A string representation of the list of key properties.

pattern property
public var pattern:Boolean

Indicates if the object name is a pattern.

propertyPattern property
public var propertyPattern:Boolean

Indicates if the object name is a pattern on the key properties.

Constructor detail
ObjectName () constructor
public function ObjectName()

Creates a new instance of an empty ObjectName.

Method detail
getKeyProperty () method
public function getKeyProperty(property:String):Object

Returns the value associated with the specified property key.

Parameters
property:String — property key.

Returns
Object
toString () method
public function toString():String

This method will return a string representation of the object name.

Returns
String — String representation of the object name.


mx.messaging.messages Summary (Flex™ 2 Language Reference)

Package mx.messaging.messages | Interfaces | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.messaging.messages package contains the message classes used with Flex Data Services.

Interfaces
Interface | Description
IMessage | This interface defines the contract for message objects.
Classes
Class | Description
AbstractMessage | Abstract base class for all messages.
AcknowledgeMessage | An AcknowledgeMessage acknowledges the receipt of a message that was sent previously.
AsyncMessage | AsyncMessage is the base class for all asynchronous messages.
CommandMessage | The CommandMessage class provides a mechanism for sending commands to the server infrastructure, such as commands related to publish/subscribe messaging scenarios, ping operations, and cluster operations.
ErrorMessage | The ErrorMessage class is used to report errors within the messaging system.
HTTPRequestMessage | HTTP requests are sent to the HTTP endpoint using this message type.
RemotingMessage | RemotingMessages are used to send RPC requests to a remote endpoint.
SOAPMessage | SOAPMessages are similar to HTTPRequestMessages.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.messaging.messages.AbstractMessage (Flex™ 2 Language Reference)

Class AbstractMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class AbstractMessage
Inheritance | AbstractMessage Inheritance Object
Implements | IMessage
Subclasses | AsyncMessage, HTTPRequestMessage, RemotingMessage

Abstract base class for all messages. Messages have two customizable sections; headers and body. The headers property provides access to specialized meta information for a specific message instance. The headers property is an associative array with the specific header name as the key.

The body of a message contains the instance specific data that needs to be delivered and processed by the remote destination. The body is an object and is the payload for a message.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
 | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | destination : String The message destination. | AbstractMessage
 | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
 | messageId : String The unique id for the message. | AbstractMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
 | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AbstractMessage() Constructs an instance of an AbstractMessage with an empty body and header. | AbstractMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
 | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
 | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
 | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Property detail
body property
body:Object [read-write]

The body of a message contains the specific data that needs to be delivered to the remote destination.

Implementation
    public function get body():Object
    public function set body(value:Object):void
clientId property
clientId:String [read-write]

The clientId indicates which MessageAgent sent the message.

Implementation
    public function get clientId():String
    public function set clientId(value:String):void
destination property
destination:String [read-write]

The message destination.

Implementation
    public function get destination():String
    public function set destination(value:String):void
headers property
headers:Object [read-write]

The headers of a message are an associative array where the key is the header name and the value is the header value. This property provides access to the specialized meta information for the specific message instance. Core header names begin with a 'DS' prefix. Custom header names should start with a unique prefix to avoid name collisions.

Implementation
    public function get headers():Object
    public function set headers(value:Object):void
messageId property
messageId:String [read-write]

The unique id for the message. The message id can be used to correlate a response to the original request message in request-response messaging scenarios.

Implementation
    public function get messageId():String
    public function set messageId(value:String):void
timestamp property
timestamp:Number [read-write]

Provides access to the time stamp for the message. A time stamp is the date and time that the message was sent. The time stamp is used for tracking the message through the system, ensuring quality of service levels and providing a mechanism for message expiration.

Implementation
    public function get timestamp():Number
    public function set timestamp(value:Number):void

See also

timeToLive
timeToLive property
timeToLive:Number [read-write]

The time to live value of a message indicates how long the message should be considered valid and deliverable. This value works in conjunction with the timestamp value. Time to live is the number of milliseconds that this message remains valid starting from the specified timestamp value. For example, if the timestamp value is 04/05/05 1:30:45 PST and the timeToLive value is 5000, then this message will expire at 04/05/05 1:30:50 PST. Once a message expires it will not be delivered to any other clients.

Implementation
    public function get timeToLive():Number
    public function set timeToLive(value:Number):void
Constructor detail
AbstractMessage () constructor
public function AbstractMessage()

Constructs an instance of an AbstractMessage with an empty body and header. This message type should not be instantiated or used directly.

Method detail
toString () method
public function toString():String

Returns a string representation of the message.

Returns
String — String representation of the message.
Constant detail
DESTINATION_CLIENT_ID_HEADER constant
public static const DESTINATION_CLIENT_ID_HEADER:String = "DSDstClientId"

Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. Each message will contain this header identifying the Consumer instance that will receive the message.

ENDPOINT_HEADER constant
public static const ENDPOINT_HEADER:String = "DSEndpoint"

Messages are tagged with the endpoint id for the Channel they are sent over. Channels set this value automatically when they send a message.

REMOTE_CREDENTIALS_HEADER constant
public static const REMOTE_CREDENTIALS_HEADER:String = "DSRemoteCredentials"

Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header.

REQUEST_TIMEOUT_HEADER constant
public static const REQUEST_TIMEOUT_HEADER:String = "DSRequestTimeout"

Messages sent with a defined request timeout use this header. The request timeout value is set on outbound messages by services or channels and the value controls how long the corresponding MessageResponder will wait for an acknowledgement, result or fault response for the message before timing out the request.


mx.messaging.messages.AcknowledgeMessage (Flex™ 2 Language Reference)

Class AcknowledgeMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class AcknowledgeMessage
Inheritance | AcknowledgeMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object
Subclasses | ErrorMessage, SequencedMessage

An AcknowledgeMessage acknowledges the receipt of a message that was sent previously. Every message sent within the messaging system must receive an acknowledgement.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AcknowledgeMessage() Constructs an instance of an AcknowledgeMessage with an empty body and header. | AcknowledgeMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
 | ERROR_HINT_HEADER : String = "DSErrorHint" [static] Header name for the error hint header. | AcknowledgeMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Constructor detail
AcknowledgeMessage () constructor
public function AcknowledgeMessage()

Constructs an instance of an AcknowledgeMessage with an empty body and header.

Constant detail
ERROR_HINT_HEADER constant
public static const ERROR_HINT_HEADER:String = "DSErrorHint"

Header name for the error hint header. Used to indicate that the acknowledgement is for a message that generated an error.


mx.messaging.messages.AsyncMessage (Flex™ 2 Language Reference)

Class AsyncMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class AsyncMessage
Inheritance | AsyncMessage Inheritance AbstractMessage Inheritance Object
Subclasses | AcknowledgeMessage, CommandMessage, DataMessage

AsyncMessage is the base class for all asynchronous messages.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AsyncMessage(body:Object = null, headers:Object = null) Constructs an instance of an AsyncMessage with an empty body and header. | AsyncMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
 | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Property detail
correlationId property
public var correlationId:String

Provides access to the correlation id of the message. Used for acknowledgement and for segmentation of messages. The correlationId contains the messageId of the previous message that this message refers to.

See also

mx.messaging.messages.AbstractMessage.messageId
Constructor detail
AsyncMessage () constructor
public function AsyncMessage(body:Object = null, headers:Object = null)

Constructs an instance of an AsyncMessage with an empty body and header. In addition to this default behavior, the body and the headers for the message may also be passed to the constructor as a convenience. An example of this invocation approach for the body is: var msg:AsyncMessage = new AsyncMessage("Body text"); An example that provides both the body and headers is: var msg:AsyncMessage = new AsyncMessage("Body text", {"customerHeader":"customValue"});

Parameters
body:Object (default = null) — The optional body to assign to the message.
headers:Object (default = null) — The optional headers to assign to the message.
Constant detail
SUBTOPIC_HEADER constant
public static const SUBTOPIC_HEADER:String = "DSSubtopic"

Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header.


mx.messaging.messages.CommandMessage (Flex™ 2 Language Reference)

Class CommandMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class CommandMessage
Inheritance | CommandMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object

The CommandMessage class provides a mechanism for sending commands to the server infrastructure, such as commands related to publish/subscribe messaging scenarios, ping operations, and cluster operations.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
 | messageRefType : String Targets the CommandMessage to a remote destination belonging to a specific service, based upon whether this server message type matches the message type the service handles. | CommandMessage
 | operation : uint Provides access to the operation/command for the CommandMessage. | CommandMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | CommandMessage() Constructs an instance of a CommandMessage with an empty body and header and a default operation of UNKNOWN_OPERATION. | CommandMessage
 | getOperationAsString(op:uint):String [static] Provides a description of the operation specified. | CommandMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns a string representation of the message. | CommandMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
 | AUTHENTICATION_MESSAGE_REF_TYPE : String = "flex.messaging.messages.AuthenticationMessage" [static] The server message type for authentication commands. | CommandMessage
 | CLIENT_PING_OPERATION : uint = 5 [static] This operation is used to test connectivity over the current channel to the remote endpoint. | CommandMessage
 | CLIENT_SYNC_OPERATION : uint = 4 [static] This operation is used by a remote destination to sync missed or cached messages back to a client as a result of a client issued poll command. | CommandMessage
 | CLUSTER_REQUEST_OPERATION : uint = 7 [static] This operation is used to request a list of failover endpoint URIs for the remote destination based on cluster membership. | CommandMessage
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
 | LOGIN_OPERATION : uint = 8 [static] This operation is used to send credentials to the endpoint so that the user can be logged in over the current channel. | CommandMessage
 | LOGOUT_OPERATION : uint = 9 [static] This operation is used to log the user out of the current channel, and will invalidate the server session if the channel is HTTP based. | CommandMessage
 | POLL_OPERATION : uint = 2 [static] This operation is used to poll a remote destination for pending, undelivered messages. | CommandMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
 | SELECTOR_HEADER : String = "DSSelector" [static] Subscribe commands issued by a Consumer pass the Consumer's selector expression in this header. | CommandMessage
 | SESSION_INVALIDATE_OPERATION : uint = 10 [static] This operation is used to indicate that the client's session with a remote destination has timed out. | CommandMessage
 | SUBSCRIBE_OPERATION : uint = 0 [static] This operation is used to subscribe to a remote destination. | CommandMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
 | UNKNOWN_OPERATION : uint = 10000 [static] This is the default operation for new CommandMessage instances. | CommandMessage
 | UNSUBSCRIBE_OPERATION : uint = 1 [static] This operation is used to unsubscribe from a remote destination. | CommandMessage
Property detail
messageRefType property
public var messageRefType:String

Targets the CommandMessage to a remote destination belonging to a specific service, based upon whether this server message type matches the message type the service handles.

operation property
public var operation:uint

Provides access to the operation/command for the CommandMessage. Operations indicate how this message should be processed by the remote destination.

Constructor detail
CommandMessage () constructor
public function CommandMessage()

Constructs an instance of a CommandMessage with an empty body and header and a default operation of UNKNOWN_OPERATION.

Method detail
getOperationAsString () method
public static function getOperationAsString(op:uint):String

Provides a description of the operation specified. This method is used in toString() operations on this message.

Parameters
op:uint — One of the CommandMessage operation constants.

Returns
String — Short name for the operation.

Example
         var msg:CommandMessage = CommandMessage(event.message);
         trace("Current operation -'"+
                CommandMessage.getOperationAsString(msg.operation)+ "'.");

toString () method
public override function toString():String

Returns a string representation of the message.

Returns
String — String representation of the message.
Constant detail
AUTHENTICATION_MESSAGE_REF_TYPE constant
public static const AUTHENTICATION_MESSAGE_REF_TYPE:String = "flex.messaging.messages.AuthenticationMessage"

The server message type for authentication commands.

CLIENT_PING_OPERATION constant
public static const CLIENT_PING_OPERATION:uint = 5

This operation is used to test connectivity over the current channel to the remote endpoint.

CLIENT_SYNC_OPERATION constant
public static const CLIENT_SYNC_OPERATION:uint = 4

This operation is used by a remote destination to sync missed or cached messages back to a client as a result of a client issued poll command.

CLUSTER_REQUEST_OPERATION constant
public static const CLUSTER_REQUEST_OPERATION:uint = 7

This operation is used to request a list of failover endpoint URIs for the remote destination based on cluster membership.

LOGIN_OPERATION constant
public static const LOGIN_OPERATION:uint = 8

This operation is used to send credentials to the endpoint so that the user can be logged in over the current channel. The credentials need to be Base64 encoded and stored in the body of the message.

LOGOUT_OPERATION constant
public static const LOGOUT_OPERATION:uint = 9

This operation is used to log the user out of the current channel, and will invalidate the server session if the channel is HTTP based.

POLL_OPERATION constant
public static const POLL_OPERATION:uint = 2

This operation is used to poll a remote destination for pending, undelivered messages.

SELECTOR_HEADER constant
public static const SELECTOR_HEADER:String = "DSSelector"

Subscribe commands issued by a Consumer pass the Consumer's selector expression in this header.

SESSION_INVALIDATE_OPERATION constant
public static const SESSION_INVALIDATE_OPERATION:uint = 10

This operation is used to indicate that the client's session with a remote destination has timed out.

SUBSCRIBE_OPERATION constant
public static const SUBSCRIBE_OPERATION:uint = 0

This operation is used to subscribe to a remote destination.

UNKNOWN_OPERATION constant
public static const UNKNOWN_OPERATION:uint = 10000

This is the default operation for new CommandMessage instances.

UNSUBSCRIBE_OPERATION constant
public static const UNSUBSCRIBE_OPERATION:uint = 1

This operation is used to unsubscribe from a remote destination.


mx.messaging.messages.ErrorMessage (Flex™ 2 Language Reference)

Class ErrorMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class ErrorMessage
Inheritance | ErrorMessage Inheritance AcknowledgeMessage Inheritance AsyncMessage Inheritance AbstractMessage Inheritance Object
Subclasses | DataErrorMessage

The ErrorMessage class is used to report errors within the messaging system. An error message only occurs in response to a message sent within the system.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | correlationId : String Provides access to the correlation id of the message. | AsyncMessage
Inherited | destination : String The message destination. | AbstractMessage
 | extendedData : Object Extended data that the remote destination has chosen to associate with this error to facilitate custom error processing on the client. | ErrorMessage
 | faultCode : String The fault code for the error. | ErrorMessage
 | faultDetail : String Detailed description of what caused the error. | ErrorMessage
 | faultString : String A simple description of the error. | ErrorMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rootCause : Object Should a root cause exist for the error, this property contains those details. | ErrorMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ErrorMessage() Constructs an ErrorMessage instance. | ErrorMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | ERROR_HINT_HEADER : String = "DSErrorHint" [static] Header name for the error hint header. | AcknowledgeMessage
 | MESSAGE_DELIVERY_IN_DOUBT : String = "Client.Error.DeliveryInDoubt" [static] If a message may not have been delivered, the faultCode will contain this constant. | ErrorMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
 | RETRYABLE_HINT_HEADER : String = "DSRetryableErrorHint" [static] Header name for the retryable hint header. | ErrorMessage
Inherited | SUBTOPIC_HEADER : String = "DSSubtopic" [static] Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header. | AsyncMessage
Property detail
extendedData property
public var extendedData:Object

Extended data that the remote destination has chosen to associate with this error to facilitate custom error processing on the client.

faultCode property
public var faultCode:String

The fault code for the error. This value typically follows the convention of "[outer_context].[inner_context].[issue]". For example: "Channel.Connect.Failed", "Server.Call.Failed", etc.

faultDetail property
public var faultDetail:String

Detailed description of what caused the error. This is typically a stack trace from the remote destination.

faultString property
public var faultString:String

A simple description of the error.

rootCause property
public var rootCause:Object

Should a root cause exist for the error, this property contains those details. This may be an ErrorMessage, a NetStatusEvent info Object, or an underlying Flash error event: ErrorEvent, IOErrorEvent, or SecurityErrorEvent.

Constructor detail
ErrorMessage () constructor
public function ErrorMessage()

Constructs an ErrorMessage instance.

Constant detail
MESSAGE_DELIVERY_IN_DOUBT constant
public static const MESSAGE_DELIVERY_IN_DOUBT:String = "Client.Error.DeliveryInDoubt"

If a message may not have been delivered, the faultCode will contain this constant.

RETRYABLE_HINT_HEADER constant
public static const RETRYABLE_HINT_HEADER:String = "DSRetryableErrorHint"

Header name for the retryable hint header. This is used to indicate that the operation that generated the error may be retryable rather than fatal.


mx.messaging.messages.HTTPRequestMessage (Flex™ 2 Language Reference)

Class HTTPRequestMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class HTTPRequestMessage
Inheritance | HTTPRequestMessage Inheritance AbstractMessage Inheritance Object
Subclasses | SOAPMessage

HTTP requests are sent to the HTTP endpoint using this message type. An HTTPRequestMessage encapsulates content and header information normally found in HTTP requests made by a browser.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contentType : String Indicates the content type of this message. | HTTPRequestMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
 | httpHeaders : Object Contains specific HTTP headers that should be placed on the request made to the destination. | HTTPRequestMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
 | method : String Indicates what method should be used for the request. | HTTPRequestMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | recordHeaders : Boolean Only used when going through the proxy, should the proxy send back the request and response headers it used. | HTTPRequestMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
 | url : String Contains the final destination for this request. | HTTPRequestMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | HTTPRequestMessage() Constructs an uninitialized HTTP request. | HTTPRequestMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
 | CONTENT_TYPE_FORM : String = "application/x-www-form-urlencoded" [static] Indicates that the content of this message is a form. | HTTPRequestMessage
 | CONTENT_TYPE_SOAP_XML : String = "text/xml; charset=utf-8" [static] Indicates that the content of this message is XML meant for a SOAP request. | HTTPRequestMessage
 | CONTENT_TYPE_XML : String = "application/xml" [static] Indicates that the content of this message is XML. | HTTPRequestMessage
 | DELETE_METHOD : String = "DELETE" [static] Indicates that the method used for this request should be "delete". | HTTPRequestMessage
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
 | GET_METHOD : String = "GET" [static] Indicates that the method used for this request should be "get". | HTTPRequestMessage
 | HEAD_METHOD : String = "HEAD" [static] Indicates that the method used for this request should be "head". | HTTPRequestMessage
 | OPTIONS_METHOD : String = "OPTIONS" [static] Indicates that the method used for this request should be "options". | HTTPRequestMessage
 | POST_METHOD : String = "POST" [static] Indicates that the method used for this request should be "post". | HTTPRequestMessage
 | PUT_METHOD : String = "PUT" [static] Indicates that the method used for this request should be "put". | HTTPRequestMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
 | TRACE_METHOD : String = "TRACE" [static] Indicates that the method used for this request should be "trace". | HTTPRequestMessage
Property detail
contentType property
public var contentType:String

Indicates the content type of this message. This value must be understood by the destination this request is sent to.

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.POST_METHOD;
          msg.url = "http://my.company.com/login";

httpHeaders property
public var httpHeaders:Object

Contains specific HTTP headers that should be placed on the request made to the destination.

method property
method:String [read-write]

Indicates what method should be used for the request. The only values allowed are:

  • HTTPRequestMessage.DELETE_METHOD
  • HTTPRequestMessage.GET_METHOD
  • HTTPRequestMessage.HEAD_METHOD
  • HTTPRequestMessage.POST_METHOD
  • HTTPRequestMessage.OPTIONS_METHOD
  • HTTPRequestMessage.PUT_METHOD
  • HTTPRequestMessage.TRACE_METHOD

Implementation
    public function get method():String
    public function set method(value:String):void

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.POST_METHOD;
          msg.url = "http://my.company.com/login";

recordHeaders property
public var recordHeaders:Boolean

Only used when going through the proxy, should the proxy send back the request and response headers it used. Defaults to false. Currently only set when using the NetworkMonitor.

url property
public var url:String

Contains the final destination for this request. This is the URL that the content of this message, found in the body property, will be sent to, using the method specified.

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.POST_METHOD;
          msg.url = "http://my.company.com/login";

Constructor detail
HTTPRequestMessage () constructor
public function HTTPRequestMessage()

Constructs an uninitialized HTTP request.

Constant detail
CONTENT_TYPE_FORM constant
public static const CONTENT_TYPE_FORM:String = "application/x-www-form-urlencoded"

Indicates that the content of this message is a form.

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.POST_METHOD;
          msg.url = "http://my.company.com/login";

CONTENT_TYPE_SOAP_XML constant
public static const CONTENT_TYPE_SOAP_XML:String = "text/xml; charset=utf-8"

Indicates that the content of this message is XML meant for a SOAP request.

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_SOAP_XML;
          msg.method = HTTPRequestMessage.POST_METHOD;
          msg.url = "http://my.company.com/login";

CONTENT_TYPE_XML constant
public static const CONTENT_TYPE_XML:String = "application/xml"

Indicates that the content of this message is XML.

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_XML;
          msg.method = HTTPRequestMessage.POST_METHOD;
          msg.url = "http://my.company.com/login";

DELETE_METHOD constant
public static const DELETE_METHOD:String = "DELETE"

Indicates that the method used for this request should be "delete".

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.DELETE_METHOD;
          msg.url = "http://my.company.com/login";

GET_METHOD constant
public static const GET_METHOD:String = "GET"

Indicates that the method used for this request should be "get".

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.GET_METHOD;
          msg.url = "http://my.company.com/login";

HEAD_METHOD constant
public static const HEAD_METHOD:String = "HEAD"

Indicates that the method used for this request should be "head".

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.HEAD_METHOD;
          msg.url = "http://my.company.com/login";

OPTIONS_METHOD constant
public static const OPTIONS_METHOD:String = "OPTIONS"

Indicates that the method used for this request should be "options".

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.OPTIONS_METHOD;
          msg.url = "http://my.company.com/login";

POST_METHOD constant
public static const POST_METHOD:String = "POST"

Indicates that the method used for this request should be "post".

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.POST_METHOD;
          msg.url = "http://my.company.com/login";

PUT_METHOD constant
public static const PUT_METHOD:String = "PUT"

Indicates that the method used for this request should be "put".

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.PUT_METHOD;
          msg.url = "http://my.company.com/login";

TRACE_METHOD constant
public static const TRACE_METHOD:String = "TRACE"

Indicates that the method used for this request should be "trace".

Example
          var msg:HTTPRequestMessage = new HTTPRequestMessage();
          msg.contentType = HTTPRequestMessage.CONTENT_TYPE_FORM;
          msg.method = HTTPRequestMessage.TRACE_METHOD;
          msg.url = "http://my.company.com/login";


mx.messaging.messages.IMessage (Flex™ 2 Language Reference)

Interface IMessage | Properties | Methods
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Interface | public interface IMessage
Implementors | AbstractMessage

This interface defines the contract for message objects.

Public Properties
Property |  | Defined by
 | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | IMessage
 | clientId : String The clientId indicates which client sent the message. | IMessage
 | destination : String The message destination. | IMessage
 | headers : Object Provides access to the headers of the message. | IMessage
 | messageId : String The unique id for the message. | IMessage
 | timestamp : Number Provides access to the time stamp for the message. | IMessage
 | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | IMessage
Public Methods
Method |  | Defined by
 | toString():String This method will return a string representation of the message. | IMessage
Property detail
body property
body:Object [read-write]

The body of a message contains the specific data that needs to be delivered to the remote destination.

Implementation
    public function get body():Object
    public function set body(value:Object):void
clientId property
clientId:String [read-write]

The clientId indicates which client sent the message.

Implementation
    public function get clientId():String
    public function set clientId(value:String):void
destination property
destination:String [read-write]

The message destination.

Implementation
    public function get destination():String
    public function set destination(value:String):void
headers property
headers:Object [read-write]

Provides access to the headers of the message. The headers of a message are an associative array where the key is the header name. This property provides access to specialized meta information for the specific message instance.

Implementation
    public function get headers():Object
    public function set headers(value:Object):void
messageId property
messageId:String [read-write]

The unique id for the message. The message id can be used to correlate a response to the original request message in request-response messaging scenarios.

Implementation
    public function get messageId():String
    public function set messageId(value:String):void
timestamp property
timestamp:Number [read-write]

Provides access to the time stamp for the message. A time stamp is the date and time that the message was sent. The time stamp is used for tracking the message through the system, ensuring quality of service levels and providing a mechanism for expiration.

Implementation
    public function get timestamp():Number
    public function set timestamp(value:Number):void

See also

timeToLive
timeToLive property
timeToLive:Number [read-write]

The time to live value of a message indicates how long the message should be considered valid and deliverable. This value works in conjunction with the timestamp value. Time to live is the number of milliseconds that this message remains valid starting from the specified timestamp value. For example, if the timestamp value is 04/05/05 1:30:45 PST and the timeToLive value is 5000, then this message will expire at 04/05/05 1:30:50 PST. Once a message expires it will not be delivered to any other clients.

Implementation
    public function get timeToLive():Number
    public function set timeToLive(value:Number):void
Method detail
toString () method
public function toString():String

This method will return a string representation of the message.

Returns
String — String representation of the message.


mx.messaging.messages.RemotingMessage (Flex™ 2 Language Reference)

Class RemotingMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class RemotingMessage
Inheritance | RemotingMessage Inheritance AbstractMessage Inheritance Object

RemotingMessages are used to send RPC requests to a remote endpoint. These messages use the operation property to specify which method to call on the remote object. The destination property indicates what object/service should be used.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
 | operation : String Provides access to the name of the remote method/operation that should be called. | RemotingMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | source : String This property is provided for backwards compatibility. | RemotingMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RemotingMessage() Constructs an uninitialized RemotingMessage. | RemotingMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Property detail
operation property
public var operation:String

Provides access to the name of the remote method/operation that should be called.

source property
public var source:String

This property is provided for backwards compatibility. The best practice, however, is to not expose the underlying source of a RemoteObject destination on the client and only one source to a destination. Some types of Remoting Services may even ignore this property for security reasons.

Constructor detail
RemotingMessage () constructor
public function RemotingMessage()

Constructs an uninitialized RemotingMessage.


mx.messaging.messages.SOAPMessage (Flex™ 2 Language Reference)

Class SOAPMessage | Properties | Methods | Constants
(Adobe® Flex™ Data Services 2 only)
Package | mx.messaging.messages
Class | public class SOAPMessage
Inheritance | SOAPMessage Inheritance HTTPRequestMessage Inheritance AbstractMessage Inheritance Object

SOAPMessages are similar to HTTPRequestMessages. However, they always contain a SOAP XML envelope request body that will always be sent using HTTP POST. They also allow a SOAP action to be specified.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | body : Object The body of a message contains the specific data that needs to be delivered to the remote destination. | AbstractMessage
Inherited | clientId : String The clientId indicates which MessageAgent sent the message. | AbstractMessage
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentType : String Indicates the content type of this message. | HTTPRequestMessage
Inherited | destination : String The message destination. | AbstractMessage
Inherited | headers : Object The headers of a message are an associative array where the key is the header name and the value is the header value. | AbstractMessage
Inherited | httpHeaders : Object Contains specific HTTP headers that should be placed on the request made to the destination. | HTTPRequestMessage
Inherited | messageId : String The unique id for the message. | AbstractMessage
Inherited | method : String Indicates what method should be used for the request. | HTTPRequestMessage
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | recordHeaders : Boolean Only used when going through the proxy, should the proxy send back the request and response headers it used. | HTTPRequestMessage
 | SOAP_ACTION_HEADER : String = "SOAPAction" [static] The HTTP header that stores the SOAP action for the SOAPMessage. | SOAPMessage
Inherited | timestamp : Number Provides access to the time stamp for the message. | AbstractMessage
Inherited | timeToLive : Number The time to live value of a message indicates how long the message should be considered valid and deliverable. | AbstractMessage
Inherited | url : String Contains the final destination for this request. | HTTPRequestMessage
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SOAPMessage() Constructs an uninitialized SOAPMessage. | SOAPMessage
 | getSOAPAction():String Provides access to the name of the remote method/operation that will be called. | SOAPMessage
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns a string representation of the message. | AbstractMessage
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | CONTENT_TYPE_FORM : String = "application/x-www-form-urlencoded" [static] Indicates that the content of this message is a form. | HTTPRequestMessage
Inherited | CONTENT_TYPE_SOAP_XML : String = "text/xml; charset=utf-8" [static] Indicates that the content of this message is XML meant for a SOAP request. | HTTPRequestMessage
Inherited | CONTENT_TYPE_XML : String = "application/xml" [static] Indicates that the content of this message is XML. | HTTPRequestMessage
Inherited | DELETE_METHOD : String = "DELETE" [static] Indicates that the method used for this request should be "delete". | HTTPRequestMessage
Inherited | DESTINATION_CLIENT_ID_HEADER : String = "DSDstClientId" [static] Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances. | AbstractMessage
Inherited | ENDPOINT_HEADER : String = "DSEndpoint" [static] Messages are tagged with the endpoint id for the Channel they are sent over. | AbstractMessage
Inherited | GET_METHOD : String = "GET" [static] Indicates that the method used for this request should be "get". | HTTPRequestMessage
Inherited | HEAD_METHOD : String = "HEAD" [static] Indicates that the method used for this request should be "head". | HTTPRequestMessage
Inherited | OPTIONS_METHOD : String = "OPTIONS" [static] Indicates that the method used for this request should be "options". | HTTPRequestMessage
Inherited | POST_METHOD : String = "POST" [static] Indicates that the method used for this request should be "post". | HTTPRequestMessage
Inherited | PUT_METHOD : String = "PUT" [static] Indicates that the method used for this request should be "put". | HTTPRequestMessage
Inherited | REMOTE_CREDENTIALS_HEADER : String = "DSRemoteCredentials" [static] Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header. | AbstractMessage
Inherited | REQUEST_TIMEOUT_HEADER : String = "DSRequestTimeout" [static] Messages sent with a defined request timeout use this header. | AbstractMessage
Inherited | TRACE_METHOD : String = "TRACE" [static] Indicates that the method used for this request should be "trace". | HTTPRequestMessage
Property detail
SOAP_ACTION_HEADER property
public static var SOAP_ACTION_HEADER:String = "SOAPAction"

The HTTP header that stores the SOAP action for the SOAPMessage.

Constructor detail
SOAPMessage () constructor
public function SOAPMessage()

Constructs an uninitialized SOAPMessage.

Method detail
getSOAPAction () method
public function getSOAPAction():String

Provides access to the name of the remote method/operation that will be called.

Returns
String


mx.preloaders Summary (Flex™ 2 Language Reference)

Package mx.preloaders | Interfaces | Classes

The mx.preloaders package contains the classes used by the download progress bar.

Interfaces
Interface | Description
IPreloaderDisplay | The IPreloaderDisplay interface defines the inteface that a class must implement to be used as a download progress bar.
Classes
Class | Description
DownloadProgressBar | The DownloadProgressBar class displays download progress.
Preloader | The Preloader class is used by the SystemManager to monitor the download and initialization status of a Flex application.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.preloaders.DownloadProgressBar (Flex™ 2 Language Reference)

Class DownloadProgressBar | Properties | Methods | Events
Package | mx.preloaders
Class | public class DownloadProgressBar
Inheritance | DownloadProgressBar Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IPreloaderDisplay

The DownloadProgressBar class displays download progress. It is used by the Preloader control to provide user feedback while the application is downloading and loading.

The download progress bar displays information about two different phases of the application: the download phase and the initialization phase.

In the <mx:Application> tag, use the the preloader property to specify the name of your subclass.

You can implement a custom download progress bar component by creating a subclass of the DownloadProgressBar class. Do not implement a download progress bar as an MXML component because it loads too slowly.

See also

mx.core.Application
mx.preloaders.IPreloaderDisplay
mx.preloaders.Preloader
Creating a custom progress bar

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
 | backgroundAlpha : Number Alpha level of the SWF file or image defined by the backgroundImage property, or the color defined by the backgroundColor property. | DownloadProgressBar
 | backgroundColor : uint Background color of a download progress bar. | DownloadProgressBar
 | backgroundImage : Object The background image of the application, which is passed in by the preloader. | DownloadProgressBar
 | backgroundSize : String Scales the image specified by backgroundImage to different percentage sizes. | DownloadProgressBar
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
 | initializingLabel : String [static] The string to display as the label while in the initializing phase. | DownloadProgressBar
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
 | preloader : Sprite [write-only] The Preloader class passes in a reference to itself to the display class so that it can listen for events from the preloader. | DownloadProgressBar
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | stageHeight : Number The height of the stage, which is passed in by the Preloader class. | DownloadProgressBar
 | stageWidth : Number The width of the stage, which is passed in by the Preloader class. | DownloadProgressBar
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
 | visible : Boolean Specifies whether the download progress bar is visible. | DownloadProgressBar
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Protected Properties
Property |  | Defined by
 | barFrameRect : RoundedRectangle [read-only] The dimensions of the progress bar border. | DownloadProgressBar
 | barRect : RoundedRectangle [read-only] The dimensions of the progress bar. | DownloadProgressBar
 | borderRect : RoundedRectangle [read-only] The dimensions of the border of the display. | DownloadProgressBar
 | downloadingLabel : String The string to display as the label while in the downloading phase. | DownloadProgressBar
 | DOWNLOAD_PERCENTAGE : uint = 60 The percentage of the progress bar that the downloading phase fills when the SWF file is fully downloaded. | DownloadProgressBar
 | label : String Text to display when the progress bar is active. | DownloadProgressBar
 | labelFormat : TextFormat [read-only] The TextFormat object of the TextField component of the label. | DownloadProgressBar
 | labelRect : Rectangle [read-only] The dimensions of the TextField component for the label. | DownloadProgressBar
 | MINIMUM_DISPLAY_TIME : uint = 0 The minimum number of milliseconds that the display should appear visible. | DownloadProgressBar
 | percentFormat : TextFormat [read-only] The TextFormat of the TextField component for displaying the percent. | DownloadProgressBar
 | percentRect : Rectangle [read-only] The dimensions of the TextField component for displaying the percent. | DownloadProgressBar
 | showLabel : Boolean Controls whether to display the label, true, or not, false. | DownloadProgressBar
 | showPercentage : Boolean Controls whether to display the percentage, true, or not, false. | DownloadProgressBar
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DownloadProgressBar()
Constructor
DownloadProgressBar
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
initialize():void
Called by the Preloader after the download progress bar has been added as a child of the Preloader.
DownloadProgressBar
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | center(width:Number, height:Number):void Centers the download progress bar based on the passed in dimensions. | DownloadProgressBar
 | completeHandler(event:Event):void Event listener for the Event.COMPLETE event. | DownloadProgressBar
 | createChildren():void Creates the subcomponents of the display. | DownloadProgressBar
 | getPercentLoaded(loaded:Number, total:Number):Number Returns the percentage value of the application loaded. | DownloadProgressBar
 | initProgressHandler(event:Event):void Event listener for the FlexEvent.INIT_PROGRESS event. | DownloadProgressBar
 | progressHandler(event:ProgressEvent):void Event listener for the ProgressEvent.PROGRESS event. | DownloadProgressBar
 | rslCompleteHandler(event:RSLEvent):void Event listener for the RSLEvent.RSL_COMPLETE event. | DownloadProgressBar
 | rslErrorHandler(event:RSLEvent):void Event listener for the RSLEvent.RSL_ERROR event. | DownloadProgressBar
 | rslProgressHandler(event:RSLEvent):void Event listener for the RSLEvent.RSL_PROGRESS event. | DownloadProgressBar
 | setProgress(completed:Number, total:Number):void Updates the display of the download progress bar with the current download information. | DownloadProgressBar
 | showDisplayForDownloading(elapsedTime:int, event:ProgressEvent):Boolean Defines the algorithm for determining whether to show the download progress bar while in the download phase. | DownloadProgressBar
 | showDisplayForInit(elapsedTime:int, count:int):Boolean Defines the algorithm for determining whether to show the download progress bar while in the initialization phase, assuming that the display is not currently visible. | DownloadProgressBar
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Property detail
backgroundAlpha property
backgroundAlpha:Number [read-write]

Alpha level of the SWF file or image defined by the backgroundImage property, or the color defined by the backgroundColor property. Valid values range from 0 to 1.0.

You can specify either a backgroundColor or a backgroundImage, but not both.

The default value is 1.0.

Implementation
    public function get backgroundAlpha():Number
    public function set backgroundAlpha(value:Number):void
backgroundColor property
backgroundColor:uint [read-write]

Background color of a download progress bar. You can have either a backgroundColor or a backgroundImage, but not both.

Implementation
    public function get backgroundColor():uint
    public function set backgroundColor(value:uint):void
backgroundImage property
backgroundImage:Object [read-write]

The background image of the application, which is passed in by the preloader. You can specify either a backgroundColor or a backgroundImage, but not both.

A value of null means "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The preloader does not display embedded images. You can only use images loaded at runtime.

The default value is null.

Implementation
    public function get backgroundImage():Object
    public function set backgroundImage(value:Object):void
backgroundSize property
backgroundSize:String [read-write]

Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). A value of "auto", maintains the original size of the image.

The default value is "auto".

Implementation
    public function get backgroundSize():String
    public function set backgroundSize(value:String):void
barFrameRect property
barFrameRect:RoundedRectangle [read-only]

The dimensions of the progress bar border. This is a read-only property which you must override if you need to change it.

Implementation
    protected function get barFrameRect():RoundedRectangle
barRect property
barRect:RoundedRectangle [read-only]

The dimensions of the progress bar. This is a read-only property which you must override if you need to change it.

Implementation
    protected function get barRect():RoundedRectangle
borderRect property
borderRect:RoundedRectangle [read-only]

The dimensions of the border of the display. This is a read-only property which you must override if you need to change it.

Implementation
    protected function get borderRect():RoundedRectangle
downloadingLabel property
downloadingLabel:String [read-write]

The string to display as the label while in the downloading phase.

The default value is "Loading".

Implementation
    protected function get downloadingLabel():String
    protected function set downloadingLabel(value:String):void
DOWNLOAD_PERCENTAGE property
protected var DOWNLOAD_PERCENTAGE:uint = 60

The percentage of the progress bar that the downloading phase fills when the SWF file is fully downloaded. The rest of the progress bar is filled during the initializing phase. This should be a value from 0 to 100.

The default value is 60.

initializingLabel property
initializingLabel:String [read-write]

The string to display as the label while in the initializing phase.

The default value is "Initializing".

Implementation
    public static function get initializingLabel():String
    public function set initializingLabel(value:String):void
label property
label:String [read-write]

Text to display when the progress bar is active. The Preloader class sets this value before displaying the progress bar. Implementing this property in a subclass is optional.

The default value is "".

Implementation
    protected function get label():String
    protected function set label(value:String):void
labelFormat property
labelFormat:TextFormat [read-only]

The TextFormat object of the TextField component of the label. This is a read-only property which you must override if you need to change it.

Implementation
    protected function get labelFormat():TextFormat
labelRect property
labelRect:Rectangle [read-only]

The dimensions of the TextField component for the label. This is a read-only property which you must override if you need to change it.

Implementation
    protected function get labelRect():Rectangle
MINIMUM_DISPLAY_TIME property
protected var MINIMUM_DISPLAY_TIME:uint = 0

The minimum number of milliseconds that the display should appear visible. If the downloading and initialization of the application takes less time than this value, then Flex pauses for this amount of time before dispatching the complete event.

The default value is 0.

percentFormat property
percentFormat:TextFormat [read-only]

The TextFormat of the TextField component for displaying the percent. This is a read-only property which you must override if you need to change it.

Implementation
    protected function get percentFormat():TextFormat
percentRect property
percentRect:Rectangle [read-only]

The dimensions of the TextField component for displaying the percent. This is a read-only property which you must override if you need to change it.

Implementation
    protected function get percentRect():Rectangle
preloader property
preloader:Sprite [write-only]

The Preloader class passes in a reference to itself to the display class so that it can listen for events from the preloader.

Implementation
    public function set preloader(value:Sprite):void
showLabel property
showLabel:Boolean [read-write]

Controls whether to display the label, true, or not, false.

The default value is true.

Implementation
    protected function get showLabel():Boolean
    protected function set showLabel(value:Boolean):void
showPercentage property
showPercentage:Boolean [read-write]

Controls whether to display the percentage, true, or not, false.

The default value is true.

Implementation
    protected function get showPercentage():Boolean
    protected function set showPercentage(value:Boolean):void
stageHeight property
stageHeight:Number [read-write]

The height of the stage, which is passed in by the Preloader class.

Implementation
    public function get stageHeight():Number
    public function set stageHeight(value:Number):void
stageWidth property
stageWidth:Number [read-write]

The width of the stage, which is passed in by the Preloader class.

Implementation
    public function get stageWidth():Number
    public function set stageWidth(value:Number):void
visible property
visible:Boolean [read-write]

Specifies whether the download progress bar is visible.

When the Preloader control determines that the progress bar should be displayed, it sets this value to true. When the Preloader control determines that the progress bar should be hidden, it sets the value to false.

A subclass of the DownloadProgressBar class should never modify this property. Instead, you can override the setter method to recognize when the Preloader control modifies it, and perform any necessary actions.

The default value is false.

Implementation
    public function get visible():Boolean
    public function set visible(value:Boolean):void
Constructor detail
DownloadProgressBar () constructor
public function DownloadProgressBar()

Constructor

Method detail
center () method
protected function center(width:Number, height:Number):void

Centers the download progress bar based on the passed in dimensions.

Parameters
width:Number — The width of the area in which to center the download progress bar.
height:Number — The height of the area in which to center the download progress bar.
completeHandler () method
protected function completeHandler(event:Event):void

Event listener for the Event.COMPLETE event. The default implementation does nothing.

Parameters
event:Event — The event object.
createChildren () method
protected function createChildren():void

Creates the subcomponents of the display.

getPercentLoaded () method
protected function getPercentLoaded(loaded:Number, total:Number):Number

Returns the percentage value of the application loaded.

Parameters
loaded:Number — Number of bytes of the application SWF file that have been downloaded.
total:Number — Size of the application SWF file in bytes.

Returns
Number — The percentage value of the loaded application.
initialize () method
public function initialize():void

Called by the Preloader after the download progress bar has been added as a child of the Preloader. This should be the starting point for configuring your download progress bar.

initProgressHandler () method
protected function initProgressHandler(event:Event):void

Event listener for the FlexEvent.INIT_PROGRESS event. This implementation updates the progress bar each time the event is dispatched, and changes the text of the label.

Parameters
event:Event — The event object.
progressHandler () method
protected function progressHandler(event:ProgressEvent):void

Event listener for the ProgressEvent.PROGRESS event. This implementation updates the progress bar with the percentage of bytes downloaded.

Parameters
event:ProgressEvent — The event object.
rslCompleteHandler () method
protected function rslCompleteHandler(event:RSLEvent):void

Event listener for the RSLEvent.RSL_COMPLETE event.

Parameters
event:RSLEvent — The event object.
rslErrorHandler () method
protected function rslErrorHandler(event:RSLEvent):void

Event listener for the RSLEvent.RSL_ERROR event. This event listner handles any errors detected when downloading an RSL.

Parameters
event:RSLEvent — The event object.
rslProgressHandler () method
protected function rslProgressHandler(event:RSLEvent):void

Event listener for the RSLEvent.RSL_PROGRESS event. The default implementation does nothing.

Parameters
event:RSLEvent — The event object.
setProgress () method
protected function setProgress(completed:Number, total:Number):void

Updates the display of the download progress bar with the current download information. A typical implementation divides the loaded value by the total value and displays a percentage. If you do not implement this method, you should create a progress bar that displays an animation to indicate to the user that a download is occurring.

The setProgress() method is only called if the application is being downloaded from a remote server and the application is not in the browser cache.

Parameters
completed:Number — Number of bytes of the application SWF file that have been downloaded.
total:Number — Size of the application SWF file in bytes.
showDisplayForDownloading () method
protected function showDisplayForDownloading(elapsedTime:int, event:ProgressEvent):Boolean

Defines the algorithm for determining whether to show the download progress bar while in the download phase.

Parameters
elapsedTime:int — number of milliseconds that have elapsed since the start of the download phase.
event:ProgressEvent — The ProgressEvent object that contains the bytesLoaded and bytesTotal properties.

Returns
Boolean — If the return value is true, then show the download progress bar. The default behavior is to show the download progress bar if more than 700 milliseconds have elapsed and if Flex has downloaded less than half of the bytes of the SWF file.
showDisplayForInit () method
protected function showDisplayForInit(elapsedTime:int, count:int):Boolean

Defines the algorithm for determining whether to show the download progress bar while in the initialization phase, assuming that the display is not currently visible.

Parameters
elapsedTime:int — number of milliseconds that have elapsed since the start of the download phase.
count:int — number of times that the initProgress event has been received from the application.

Returns
Boolean — If true, then show the download progress bar.


mx.preloaders.IPreloaderDisplay (Flex™ 2 Language Reference)

Interface IPreloaderDisplay | Properties | Methods
Package | mx.preloaders
Interface | public interface IPreloaderDisplay extends IEventDispatcher
Implementors | DownloadProgressBar

The IPreloaderDisplay interface defines the inteface that a class must implement to be used as a download progress bar. The IPreloaderDisplay receives events from the Preloader class and is responsible to visualizing that information to the user.

See also

mx.preloaders.DownloadProgressBar
mx.preloaders.Preloader

Public Properties
Property |  | Defined by
 | backgroundAlpha : Number Alpha level of the SWF file or image defined by the backgroundImage property, or the color defined by the backgroundColor property. | IPreloaderDisplay
 | backgroundColor : uint Background color of a download progress bar. | IPreloaderDisplay
 | backgroundImage : Object The background image of the application, which is passed in by the preloader. | IPreloaderDisplay
 | backgroundSize : String Scales the image specified by backgroundImage to different percentage sizes. | IPreloaderDisplay
 | preloader : Sprite [write-only] The Preloader class passes in a reference to itself to the display class so that it can listen for events from the preloader. | IPreloaderDisplay
 | stageHeight : Number The height of the stage, which is passed in by the Preloader class. | IPreloaderDisplay
 | stageWidth : Number The width of the stage, which is passed in by the Preloader class. | IPreloaderDisplay
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
IEventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
IEventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
IEventDispatcher
initialize():void
Called by the Preloader after the download progress bar has been added as a child of the Preloader.
IPreloaderDisplay
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
IEventDispatcher
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
IEventDispatcher
Property detail
backgroundAlpha property
backgroundAlpha:Number [read-write]

Alpha level of the SWF file or image defined by the backgroundImage property, or the color defined by the backgroundColor property. Valid values range from 0 to 1.0.

You can specify either a backgroundColor or a backgroundImage, but not both.

Implementation
    public function get backgroundAlpha():Number
    public function set backgroundAlpha(value:Number):void
backgroundColor property
backgroundColor:uint [read-write]

Background color of a download progress bar. You can have either a backgroundColor or a backgroundImage, but not both.

Implementation
    public function get backgroundColor():uint
    public function set backgroundColor(value:uint):void
backgroundImage property
backgroundImage:Object [read-write]

The background image of the application, which is passed in by the preloader. You can specify either a backgroundColor or a backgroundImage, but not both.

A value of null means "not set". If this style and the backgroundColor style are undefined, the component has a transparent background.

The preloader does not display embedded images. You can only use images loaded at runtime.

Implementation
    public function get backgroundImage():Object
    public function set backgroundImage(value:Object):void
backgroundSize property
backgroundSize:String [read-write]

Scales the image specified by backgroundImage to different percentage sizes. A value of "100%" stretches the image to fit the entire component. To specify a percentage value, you must include the percent sign (%). A value of "auto", maintains the original size of the image.

Implementation
    public function get backgroundSize():String
    public function set backgroundSize(value:String):void
preloader property
preloader:Sprite [write-only]

The Preloader class passes in a reference to itself to the display class so that it can listen for events from the preloader.

Implementation
    public function set preloader(value:Sprite):void
stageHeight property
stageHeight:Number [read-write]

The height of the stage, which is passed in by the Preloader class.

Implementation
    public function get stageHeight():Number
    public function set stageHeight(value:Number):void
stageWidth property
stageWidth:Number [read-write]

The width of the stage, which is passed in by the Preloader class.

Implementation
    public function get stageWidth():Number
    public function set stageWidth(value:Number):void
Method detail
initialize () method
public function initialize():void

Called by the Preloader after the download progress bar has been added as a child of the Preloader. This should be the starting point for configuring your download progress bar.


mx.preloaders.Preloader (Flex™ 2 Language Reference)

Class Preloader | Properties | Methods | Events
Package | mx.preloaders
Class | public class Preloader
Inheritance | Preloader Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The Preloader class is used by the SystemManager to monitor the download and initialization status of a Flex application. It is also responsible for downloading the runtime shared libraries (RSLs).

The Preloader class instantiates a download progress bar, which must implement the IPreloaderDisplay interface, and passes download and initialization events to the download progress bar.

See also

mx.preloaders.DownloadProgressBar
mx.preloaders.Preloader

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Preloader()
Constructor
Preloader
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
initialize(showDisplay:Boolean, displayClassName:Class, backgroundColor:uint, backgroundAlpha:Number, backgroundImage:Object, backgroundSize:String, displayWidth:Number, displayHeight:Number, libs:Array = null, sizes:Array = null):void
Called by the SystemManager to initialize a Preloader object.
Preloader
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
registerApplication(app:IEventDispatcher):void
Called by the SystemManager after it has finished instantiating an instance of the application class.
Preloader
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Constructor detail
Preloader () constructor
public function Preloader()

Constructor

Method detail
initialize () method
public function initialize(showDisplay:Boolean, displayClassName:Class, backgroundColor:uint, backgroundAlpha:Number, backgroundImage:Object, backgroundSize:String, displayWidth:Number, displayHeight:Number, libs:Array = null, sizes:Array = null):void

Called by the SystemManager to initialize a Preloader object.

Parameters
showDisplay:Boolean — Determines if the display class should be displayed.
displayClassName:Class — The IPreloaderDisplay class to use for displaying the preloader status.
backgroundColor:uint — Background color of the application.
backgroundAlpha:Number — Background alpha of the application.
backgroundImage:Object — Background image of the application.
backgroundSize:String — Background size of the application.
displayWidth:Number — Width of the application.
displayHeight:Number — Height of the application.
libs:Array (default = null) — Array of string URLs for the runtime shared libraries.
sizes:Array (default = null) — Array of uint values containing the byte size for each URL in the libs argument
registerApplication () method
public function registerApplication(app:IEventDispatcher):void

Called by the SystemManager after it has finished instantiating an instance of the application class. Flex calls this method; you do not call it yourself.

Parameters
app:IEventDispatcher — The application object.


mx.printing Summary (Flex™ 2 Language Reference)

Package mx.printing | Classes

The mx.printing package contains the printing classes.

Classes
Class | Description
FlexPrintJob | The FlexPrintJob class is a wrapper over the Flash Player's PrintJob API.
FlexPrintJobScaleType | Values for the scaleType property of the FlexPrintJob.addObject() method parameter.
PrintDataGrid | The PrintDataGrid control is a DataGrid subclass that is styled to show a table with line borders and is optimized for printing.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.printing.FlexPrintJob (Flex™ 2 Language Reference)

Class FlexPrintJob | Properties | Methods | Examples
Package | mx.printing
Class | public class FlexPrintJob
Inheritance | FlexPrintJob Inheritance Object

The FlexPrintJob class is a wrapper over the Flash Player's PrintJob API. It supports automatically slicing and paginating the output on multilple pages, and scaling the grod contents to fit the printer's page size.

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | pageHeight : Number [read-only] The height of the printable area on the printer page; it does not include any user-set margins. | FlexPrintJob
 | pageWidth : Number [read-only] The width of the printable area on the printer page; it does not include any user-set margins. | FlexPrintJob
 | printAsBitmap : Boolean Specifies whether to print the job content as a bitmap (true) or in vector format (false). | FlexPrintJob
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | FlexPrintJob() Constructor. | FlexPrintJob
 | addObject(obj:IUIComponent, scaleType:String = "matchWidth"):void Adds a UIComponent object to the list of objects being printed. | FlexPrintJob
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | send():void Sends the added objects to the printer to start printing. | FlexPrintJob
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | start():Boolean Initializes the PrintJob object. | FlexPrintJob
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
pageHeight property
pageHeight:Number [read-only]

The height of the printable area on the printer page; it does not include any user-set margins. It is set after start() method returns.

Implementation
    public function get pageHeight():Number
pageWidth property
pageWidth:Number [read-only]

The width of the printable area on the printer page; it does not include any user-set margins. This property is set after start() method returns.

Implementation
    public function get pageWidth():Number
printAsBitmap property
printAsBitmap:Boolean [read-write]

Specifies whether to print the job content as a bitmap (true) or in vector format (false). Printing as a bitmap supports output that includes a bitmap image with alpha transparency or color effects. If the content does not include any bitmap images with alpha transparency or color effects, you can print in higher quality vector format by setting the printAsBitmap property to false.

The default value is true.

Implementation
    public function get printAsBitmap():Boolean
    public function set printAsBitmap(value:Boolean):void
Constructor detail
FlexPrintJob () constructor
public function FlexPrintJob()

Constructor.

Method detail
addObject () method
public function addObject(obj:IUIComponent, scaleType:String = "matchWidth"):void

Adds a UIComponent object to the list of objects being printed. Call this method after the start() method returns. Each call to this method starts a new page, so you should format your objects in page-sized chunks. You can use the PrintDataGrid class to span a data grid across multiple pages.

Parameters
obj:IUIComponent — The Object to be printed.
scaleType:String (default = "matchWidth") — The scaling technique to use to control how the object fits on one or more printed pages. Must be one of the constant values defined in the FlexPrintJobScaleType class.

See also

PrintDataGrid
FlexPrintJobScaleType
send () method
public function send():void

Sends the added objects to the printer to start printing. Call this method after you have used the addObject() method to add the print pages.

start () method
public function start():Boolean

Initializes the PrintJob object. Displays the operating system printer dialog to the user. Flex sets the pageWidth and pageHeight properties after this call returns.

Returns
Boolean — true if the user clicks OK when the print dialog box appears, or false if the user clicks Cancel or if an error occurs.
Examples
FormPrintHeader
<?xml version="1.0"?>
<!-- Custom control for the header area of the printed page. -->

<mx:VBox xmlns:mx="http://www.adobe.com/2006/mxml" width="60%"
    horizontalAlign="right" >

    <mx:Label text="This is a placeholder for first page contents"/>
</mx:VBox>
FormPrintFooter
<?xml version="1.0"?>
<!-- Custom control for the footer area of the printed page. -->

<mx:VBox xmlns:mx="http://www.adobe.com/2006/mxml" width="60%"
    horizontalAlign="right" >
    <!-- Declare and initialize the product total variable. -->

    <mx:Script>
        <![CDATA[
            [Bindable]
            public var pTotal:Number = 0;
        ]]>
    </mx:Script>
    <mx:Label text="Product Total: {pTotal}"/>
</mx:VBox>
FormPrintView
<?xml version="1.0"?>
<!-- Custom control to print the DataGrid control on multiple pages. -->

<mx:VBox xmlns:mx="http://www.adobe.com/2006/mxml" xmlns="*" backgroundColor="#FFFFFF"
    paddingTop="50" paddingBottom="50" paddingLeft="50">

    <mx:Script>
        <![CDATA[
            import mx.core.*
            // Declare and initialize the variables used in the component.
            // The application sets the actual prodTotal value.
            [Bindable]
            public var pageNumber:Number = 1;
            [Bindable]
            public var prodTotal:Number = 0;

            // Control the page contents by selectively hiding the header and
            // footer based on the page type.
            public function showPage(pageType:String):void {
                if(pageType == "first" || pageType == "middle") {
                    // Hide the footer.
                    footer.includeInLayout=false;
                    footer.visible = false;
                }
                if(pageType == "middle" || pageType == "last") {
                    // The header won't be used again; hide it.
                    header.includeInLayout=false;
                    header.visible = false;
                }
                if(pageType == "last") {
                    // Show the footer.
                    footer.includeInLayout=true;
                    footer.visible = true;
                }
                //Update the DataGrid layout to reflect the results.
                validateNow();
            }
        ]]>
    </mx:Script>

    <!-- The template for the printed page, with the contents for all pages. -->
    <mx:VBox width="80%" horizontalAlign="left">
        <mx:Label text="Page {pageNumber}"/>
    </mx:VBox>

    <FormPrintHeader id="header" />
    <!-- The data grid. The sizeToPage property is true by default, so the last
        page has only as many grid rows as are needed for the data. -->
    <mx:PrintDataGrid id="myDataGrid" width="60%" height="100%">
    <!-- Specify the columns to ensure that their order is correct. -->
        <mx:columns>
            <mx:DataGridColumn dataField="Index" />
            <mx:DataGridColumn dataField="Qty" />
        </mx:columns>
    </mx:PrintDataGrid>

    <!-- Create a FormPrintFooter control and set its prodTotal variable. -->
    <FormPrintFooter id="footer" pTotal="{prodTotal}" />

</mx:VBox>
PrintDataGridExample
<?xml version="1.0"?>
<!-- Main application to print a DataGrid control on multiple pages. -->

<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" initialize="initData();">

    <mx:Script>
        <![CDATA[

        import mx.printing.*;
        import mx.collections.ArrayCollection;
        import FormPrintView;

        // Declare variables and initialize simple variables.
        [Bindable]
        public var dgProvider:ArrayCollection;
        public var footerHeight:Number = 20;
        public var prodIndex:Number;
        public var prodTotal:Number = 0;

        // Data initialization.
        public function initData():void {
            // Create the data provider for the DataGrid control.
            dgProvider = new ArrayCollection;
        }

        // Fill the dgProvider ArrayCollection with the specified items.
        public function setdgProvider(items:int):void {

            prodIndex=1;
            dgProvider.removeAll();
            for (var z:int=0; z<items; z++)
            {
                var prod1:Object = {};
                prod1.Qty = prodIndex * 7;
                prod1.Index = prodIndex++;
                prodTotal += prod1.Qty;
                dgProvider.addItem(prod1);
            }
        }

        // The function to print the output.
        public function doPrint():void {

            var printJob:FlexPrintJob = new FlexPrintJob();
            if (printJob.start()) {
                // Create a FormPrintView control as a child of the current view.
                var thePrintView:FormPrintView = new FormPrintView();
               Application.application.addChild(thePrintView);

                //Set the print view properties.
                thePrintView.width=printJob.pageWidth;
                thePrintView.height=printJob.pageHeight;
                thePrintView.prodTotal = prodTotal;
                // Set the data provider of the FormPrintView component's data grid
                // to be the data provider of the displayed data grid.
                thePrintView.myDataGrid.dataProvider = myDataGrid.dataProvider;
                // Create a single-page image.
                thePrintView.showPage("single");
                // If the print image's data grid can hold all the provider's rows,
                // add the page to the print job.
                if(!thePrintView.myDataGrid.validNextPage)
                {
                    printJob.addObject(thePrintView);
                }
                // Otherwise, the job requires multiple pages.
                else
                {
                    // Create the first page and add it to the print job.
                    thePrintView.showPage("first");
                    printJob.addObject(thePrintView);
                    thePrintView.pageNumber++;
                    // Loop through the following code until all pages are queued.
                    while(true)
                    {
                        // Move the next page of data to the top of the print grid.
                        thePrintView.myDataGrid.nextPage();
                        thePrintView.showPage("last");
                        // If the page holds the remaining data, or if the last page
                        // was completely filled by the last grid data, queue it for printing.
                        // Test if there is data for another PrintDataGrid page.
                        if(!thePrintView.myDataGrid.validNextPage)
                        {
                            // This is the last page; queue it and exit the print loop.
                            printJob.addObject(thePrintView);
                            break;
                        }
                        else
                        // This is not the last page. Queue a middle page.
                        {
                            thePrintView.showPage("middle");
                            printJob.addObject(thePrintView);
                            thePrintView.pageNumber++;
                        }
                    }
                }
                // All pages are queued; remove the FormPrintView control to free memory.
                Application.application.removeChild(thePrintView);
            }
            // Send the job to the printer.
            printJob.send();
        }
        ]]>
    </mx:Script>

    <mx:Panel title="CheckBox Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:DataGrid id="myDataGrid" dataProvider="{dgProvider}">
            <mx:columns>
                <mx:DataGridColumn dataField="Index"/>
                <mx:DataGridColumn dataField="Qty"/>
            </mx:columns>
        </mx:DataGrid>

        <mx:Text width="100%" color="blue"
            text="Specify the number of lines and click Fill Grid first. Then you can click Print."/>

        <mx:TextInput id="dataItems" text="35"/>

        <mx:HBox>
            <mx:Button id="setDP" label="Fill Grid" click="setdgProvider(int(dataItems.text));"/>
            <mx:Button id="printDG" label="Print" click="doPrint();"/>
        </mx:HBox>
    </mx:Panel>
</mx:Application>


mx.printing.FlexPrintJobScaleType (Flex™ 2 Language Reference)

Class FlexPrintJobScaleType | Properties | Methods | Constants
Package | mx.printing
Class | public final class FlexPrintJobScaleType
Inheritance | FlexPrintJobScaleType Inheritance Object

Values for the scaleType property of the FlexPrintJob.addObject() method parameter.

See also

FlexPrintJob.addObject()

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | FILL_PAGE : String = "fillPage" [static] Scales the object to fill at least one page completely; that is, it selects the larger of the MATCH_WIDTH or MATCH_HEIGHT scale types. | FlexPrintJobScaleType
 | MATCH_HEIGHT : String = "matchHeight" [static] Scales the object to fill the available page height. | FlexPrintJobScaleType
 | MATCH_WIDTH : String = "matchWidth" [static] Scales the object to fill the available page width. | FlexPrintJobScaleType
 | NONE : String = "none" [static] Does not scale the output. | FlexPrintJobScaleType
 | SHOW_ALL : String = "showAll" [static] Scales the object to fit on a single page, filling one dimension; that is, it selects the smaller of the MATCH_WIDTH or MATCH_HEIGHT scale types. | FlexPrintJobScaleType
Constant detail
FILL_PAGE constant
public static const FILL_PAGE:String = "fillPage"

Scales the object to fill at least one page completely; that is, it selects the larger of the MATCH_WIDTH or MATCH_HEIGHT scale types.

MATCH_HEIGHT constant
public static const MATCH_HEIGHT:String = "matchHeight"

Scales the object to fill the available page height. If the resulting object width exceeds the page width, the output spans multiple pages.

MATCH_WIDTH constant
public static const MATCH_WIDTH:String = "matchWidth"

Scales the object to fill the available page width. If the resulting object height exceeds the page height, the output spans multiple pages.

NONE constant
public static const NONE:String = "none"

Does not scale the output. The printed page has the same dimensions as the object on the screen. If the object height, width, or both dimensions exceed the page width or height, the output spans multiple pages.

SHOW_ALL constant
public static const SHOW_ALL:String = "showAll"

Scales the object to fit on a single page, filling one dimension; that is, it selects the smaller of the MATCH_WIDTH or MATCH_HEIGHT scale types.


mx.printing.PrintDataGrid (Flex™ 2 Language Reference)

Class PrintDataGrid | Properties | Methods | Events | Styles | Constants | Examples
Package | mx.printing
Class | public class PrintDataGrid
Inheritance | PrintDataGrid Inheritance DataGrid Inheritance DataGridBase Inheritance ListBase Inheritance ScrollControlBase Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The PrintDataGrid control is a DataGrid subclass that is styled to show a table with line borders and is optimized for printing. It can automatically size to properly fit its container, and removes any partially displayed rows.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PrintDataGrid> tag inherits the tag attributes of its superclass; however, you do not use the properties, styles, events, and effects (or methods) associated with user interaction. The <mx:PrintDataGrid> tag adds the following tag attribute:

  <mx:PrintDataGrid
    Properties
    sizeToPage="true|false"
  >
  ...
  </mx:PrintDataGrid>

View the examples.

See also

FlexPrintJob

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics Returns an EdgeMetrics object that has four properties: left, top, right, and bottom. | ScrollControlBase
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | columns : Array An array of DataGridColumn objects, one for each column that can be displayed. | DataGrid
Inherited | columnWidth : Number The width of the control's columns. | ListBase
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
 | currentPageHeight : Number [read-only] The height of PrintDataGrid that would be, if sizeToPage property is true and PrintDataGrid displays only completely viewable rows and no partial rows. | PrintDataGrid
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | data : Object The item in the data provider this component should render when this component is used as an item renderer or item editor. | ListBase
Inherited | dataProvider : Object Set of data to be viewed. | ListBase
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | headerHeight : Number The height of the header cell of the column, in pixels. | DataGridBase
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | horizontalScrollPosition : Number The offset into the content from the left edge. | DataGrid
Inherited | id : String ID of the component. | UIComponent
Inherited | imeMode : String Specifies the IME (input method editor) mode. | DataGrid
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | itemEditorInstance : IListItemRenderer A reference to the currently active instance of the item editor, if it exists. | DataGrid
Inherited | itemRenderer : IFactory The custom item renderer for the control. | ListBase
Inherited | labelFunction : Function A user-supplied function to run on each item to determine its label. | ListBase
Inherited | listData : BaseListData When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control. | ListBase
Inherited | liveScrolling : Boolean = true A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released. | ScrollControlBase
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | lockedColumnCount : int The index of the first column in the control that scrolls. | ListBase
Inherited | lockedRowCount : int The index of the first row in the control that scrolls. | ListBase
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | menuSelectionMode : Boolean = false A flag that indicates whether menu-style selection should be used. | ListBase
Inherited | minColumnWidth : Number The minimum width of the columns, in pixels. | DataGrid
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
 | originalHeight : Number [read-only] The height of PrintDataGrid as set by the user. | PrintDataGrid
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | resizableColumns : Boolean = true A flag that indicates whether the user can change the size of the columns. | DataGrid
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | rowCount : int Number of rows to be displayed. | ListBase
Inherited | rowHeight : Number The height of the rows in pixels. | ListBase
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | showHeaders : Boolean A flag that indicates whether the control should show column headers. | DataGridBase
 | sizeToPage : Boolean = true If true, the PrintDataGrid readjusts its height to display only completely viewable rows. | PrintDataGrid
Inherited | sortableColumns : Boolean = true A flag that indicates whether the user can sort the data provider items by clicking on a column header cell. | DataGrid
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
 | validNextPage : Boolean [read-only] Indicates the data provider contains additional data rows that follow the rows that the PrintDataGrid control currently displays. | PrintDataGrid
Inherited | value : Object The selected item, or the data or label field of the selected item. | ListBase
Inherited | variableRowHeight : Boolean A flag that indicates whether the individual rows can have different height. | ListBase
Inherited | verticalScrollPosition : Number The offset into the content from the top edge. | ScrollControlBase
Inherited | viewMetrics : EdgeMetrics An EdgeMetrics object taking into account the scroll bars, if visible. | ScrollControlBase
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | wordWrap : Boolean A flag that indicates whether text in the row should be word wrapped. | ListBase
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | border : IFlexDisplayObject The border object. | ScrollControlBase
Inherited | collection : ICollectionView An ICollectionView that represents the data provider. | ListBase
Inherited | columnMap : Object A map of item renderes to columns. | DataGridBase
Inherited | defaultColumnCount : int = 4 The default number of columns to display. | ListBase
Inherited | defaultRowCount : int = 4 The default number of rows to display. | ListBase
Inherited | explicitColumnCount : int = -1 The column count requested by explicitly setting the columnCount property. | ListBase
Inherited | explicitColumnWidth : Number The column width requested by explicitly setting the columnWidth. | ListBase
Inherited | explicitRowCount : int = -1 The row count requested by explicitly setting rowCount. | ListBase
Inherited | explicitRowHeight : Number The row height requested by explicitly setting rowHeight. | ListBase
Inherited | freeItemRenderers : Array A stack of unused item renderers. | ListBase
Inherited | freeItemRenderersTable : Dictionary A per-column table of unused item renderers. | DataGridBase
Inherited | highlightItemRenderer : IListItemRenderer The renderer that is currently rolled over or under the caret. | ListBase
Inherited | itemsNeedMeasurement : Boolean = true A flag that indicates whether the columnWidth and rowHeight properties need to be calculated. | ListBase
Inherited | itemsSizeChanged : Boolean = false A flag that indicates that the size of the renderers may have changed. | ListBase
Inherited | iterator : IViewCursor The main IViewCursor used to fetch items from the data provider and pass the items to the renderers. | ListBase
Inherited | iteratorValid : Boolean = true A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed). | ListBase
Inherited | lastSeekPending : ListBaseSeekPending The most recent seek that caused a page fault. | ListBase
Inherited | listContent : ListBaseContentHolder An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics. | ListBase
Inherited | listItems : Array An Array of Arrays that contains the itemRenderer instances that render each data provider item. | ListBase
Inherited | maskShape : Shape The mask. | ScrollControlBase
Inherited | rendererChanged : Boolean = false A flag that indicates that the renderer changed. | ListBase
Inherited | rowInfo : Array An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems. | ListBase
Inherited | rowMap : Object A hash map of item renderers to their respective ListRowInfo object. | ListBase
Inherited | scrollAreaChanged : Boolean A flag that the scrolling area changed due to the appearance or disappearance of scrollbars. | ScrollControlBase
Inherited | selectedData : Object A hash table of ListBaseSelectionData objects that track which items are currently selected. | ListBase
Inherited | selectionIndicators : Object A hash table of selection indicators. | ListBase
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | visibleData : Object A hash table of data provider item renderers currently in view. | ListBase
Inherited | wordWrapChanged : Boolean = false A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated. | ListBase
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PrintDataGrid()
Constructor.
PrintDataGrid
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
findString(str:String):Boolean
Finds an item in the list based on a string and moves the selection to it.
ListBase
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
indexToItemRenderer(index:int):IListItemRenderer
Get an item renderer for the index of an item in the data provider, if one exists.
ListBase
Inherited
indicesToIndex(rowIndex:int, colIndex:int):int
Computes the offset into the data provider of the item at colIndex, rowIndex.
ListBase
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateList():void
Refresh all rows on next update.
ListBase
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isItemVisible(item:Object):Boolean
Determines if an item is being displayed by a renderer.
ListBase
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
itemRendererContains(renderer:IListItemRenderer, object:DisplayObject):Boolean
Determines whether a renderer contains (or owns) a display object.
ListBase
Inherited
itemRendererToIndex(itemRenderer:IListItemRenderer):int
Returns the index of the item in the data provider of the item being rendered by this item renderer.
ListBase
Inherited
itemToDataTip(data:Object):String
Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
ListBase
Inherited
itemToIcon(data:Object):Class
Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
ListBase
Inherited
itemToItemRenderer(item:Object):IListItemRenderer
Returns the item renderer for a given item in the data provider, if there is one.
ListBase
Inherited
itemToLabel(data:Object):String
Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
ListBase
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHeightOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
ListBase
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureWidthOfItems(index:int = -1, count:int = 0):Number
Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
ListBase
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
nextPage():void
Puts the next set of data rows in view; that is, it sets the PrintDataGrid verticalScrollPosition property to equal verticalScrollPosition + (number of scrollable rows).
PrintDataGrid
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
scrollToIndex(index:int):Boolean
Ensures that the data provider item at the given index is visible.
ListBase
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addDragData(ds:Object):void Adds the selected items to the DragSource object as part of a drag-and-drop operation. | ListBase
Inherited | addToFreeItemRenderers(item:IListItemRenderer):void Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it. | ListBase
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | applySelectionEffect(indicator:Sprite, uid:String, itemRenderer:IListItemRenderer):void Sets up the effect for applying the selection indicator. | ListBase
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | calculateDropIndicatorY(rowCount:Number, rowNum:int):Number Calculates the y position of the drop indicator when performing a drag-and-drop operation. | ListBase
Inherited | calculateRowHeight(data:Object, hh:Number, skipVisible:Boolean = false):Number Calculates the row height of columns in a row. | DataGridBase
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | clearIndicators():void Removes all selection and highlight and caret indicators. | ListBase
Inherited | clearSelected(transition:Boolean = false):void Clears the set of selected items and removes all graphics depicting the selected state of those items. | ListBase
Inherited | clearSeparators():void Removes column header separators that the user normally uses to resize columns. | DataGrid
Inherited | collectionChangeHandler(event:Event):void Handles CollectionEvents dispatched from the data provider as the data changes. | ListBase
Inherited | commitProperties():void Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set. | ListBase
Inherited | configureScrollBars():void Configures the ScrollBars based on the number of rows and columns and viewable rows and columns. | ListBase
Inherited | copySelectedItems(useDataField:Boolean = true):Array Makes a copy of the selected items in the order they were selected. | ListBase
Inherited | createBorder():void Creates the border for this component. | ScrollControlBase
Inherited | createChildren():void Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers. | ListBase
Inherited | drawColumnBackground(s:Sprite, columnIndex:int, color:uint, column:DataGridColumn):void Draws a column background for a column with the suggested color. | DataGrid
Inherited | drawHeaderBackground(headerBG:UIComponent):void Draws the background of the headers into the given UIComponent. | DataGrid
Inherited | drawHorizontalLine(s:Sprite, rowIndex:int, color:uint, y:Number):void Draws a line between rows. | DataGrid
Inherited | drawItem(item:IListItemRenderer, selected:Boolean = false, highlighted:Boolean = false, caret:Boolean = false, transition:Boolean = false):void Draws the renderer with indicators that it is highlighted, selected, or the caret. | ListBase
Inherited | drawLinesAndColumnBackgrounds():void Draw lines between columns, and column backgrounds. | DataGrid
Inherited | drawRowBackground(s:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int):void Draws a row background at the position and height specified using the color specified. | DataGrid
Inherited | drawRowBackgrounds():void Draws any alternating row colors, borders and backgrounds for the rows. | ListBase
Inherited | drawSeparators():void Creates and displays the column header separators that the user normally uses to resize columns. | DataGrid
Inherited | drawVerticalLine(s:Sprite, colIndex:int, color:uint, x:Number):void Draw lines between columns. | DataGrid
Inherited | findKey(eventCode:int):Boolean Tries to find the next item in the data provider that starts with the character in the eventCode parameter. | ListBase
Inherited | finishKeySelection():void Sets selected items based on the caretIndex and anchorIndex properties. | ListBase
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | indexToColumn(index:int):int The column for the data provider item at the given index. | ListBase
Inherited | indexToRow(index:int):int The row for the data provider item at the given index. | ListBase
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | itemRendererToIndices(item:IListItemRenderer):Point Returns a Point containing the columnIndex and rowIndex of an item renderer. | ListBase
Inherited | itemToUID(data:Object):String Determines the UID for a data provider item. | ListBase
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | layoutChrome(unscaledWidth:Number, unscaledHeight:Number):void Responds to size changes by setting the positions and sizes of this control's borders. | ScrollControlBase
Inherited | makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean = false, rowsNeeded:uint = 0):Point Make enough rows and columns to fill the area described by left, top, right, bottom. | ListBase
Inherited | measure():void Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties. | ListBase
Inherited | scrollHandler(event:Event):void Default event handler for the scroll event. | ScrollControlBase
Inherited | scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean):void Adjusts the renderers in response to a change in scroll position. | ListBase
Inherited | scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int):int Returns the data provider index for the item at the first visible row and column for the given scroll positions. | ListBase
Inherited | scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean):void Adjusts the renderers in response to a change in scroll position. | ListBase
Inherited | seekPendingFailureHandler(data:Object, info:ListBaseSeekPending):void The default failure handler when a seek fails due to a page fault. | ListBase
Inherited | seekPendingResultHandler(data:Object, info:ListBaseSeekPending):void The default result handler when a seek fails due to a page fault. | ListBase
Inherited | setRowCount(v:int):void Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows. | ListBase
Inherited | setRowHeight(v:Number):void Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows | ListBase
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Adds or removes item renderers if the number of displayable items changed. | ListBase
Inherited | updateList():void Refreshes all rows now. | ListBase
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | change | Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction. | ListBase
Inherited | columnStretch | Dispatched when a user changes the width of a column, indicating that the amount of data displayed in that column may have changed. | DataGrid
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | dataChange | Dispatched when the data property changes. | ListBase
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | headerShift | Dispatched when the user releases the mouse button on a column header after having dragged the column to a new location resulting in shifting the column to a new index. | DataGrid
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | scroll | Dispatched when the content is scrolled. | ScrollControlBase
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | alternatingItemColors | Type: Array Format: Color CSS Inheritance: yes The colors to use for the backgrounds of the items in the list. | ListBase
Inherited | backgroundAlpha | Type: Number CSS Inheritance: no Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style. | ScrollControlBase
Inherited | backgroundColor | Type: uint Format: Color CSS Inheritance: no Background color of a component. | ScrollControlBase
Inherited | backgroundDisabledColor | Type: uint Format: Color CSS Inheritance: yes The background color of the DataGrid when disabled. | DataGrid
Inherited | backgroundImage | Type: Object Format: File CSS Inheritance: no Background image of a component. | ScrollControlBase
Inherited | backgroundSize | Type: String CSS Inheritance: no Scales the image specified by backgroundImage to different percentage sizes. | ScrollControlBase
Inherited | borderColor | Type: uint Format: Color CSS Inheritance: no Color of the border. | ScrollControlBase
Inherited | borderSides | Type: String CSS Inheritance: no Bounding box sides. | ScrollControlBase
Inherited | borderSkin | Type: Class CSS Inheritance: no The border skin of the component. | ScrollControlBase
Inherited | borderStyle | Type: String CSS Inheritance: no Bounding box style. | ScrollControlBase
Inherited | borderThickness | Type: Number Format: Length CSS Inheritance: no Bounding box thickness. | ScrollControlBase
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | color | Type: uint Format: Color CSS Inheritance: yes Color of text in the component, including the component label. | ScrollControlBase
Inherited | cornerRadius | Type: Number Format: Length CSS Inheritance: no Radius of component corners. | ScrollControlBase
Inherited | disabledColor | Type: uint Format: Color CSS Inheritance: yes Color of text in the component if it is disabled. | ScrollControlBase
Inherited | dropShadowColor | Type: uint Format: Color CSS Inheritance: yes Color of the drop shadow. | ScrollControlBase
Inherited | dropShadowEnabled | Type: Boolean CSS Inheritance: no Boolean property that specifies whether the component has a visible drop shadow. | ScrollControlBase
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusAlpha | Type: Number CSS Inheritance: no Specifies the alpha transparency value of the focus skin. | ListBase
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusRoundedCorners | Type: String CSS Inheritance: no Specifies which corners of the focus rectangle should be rounded. | ListBase
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | fontAntiAliasType | Type: String CSS Inheritance: yes Sets the antiAliasType property of internal TextFields. | ScrollControlBase
Inherited | fontFamily | Type: String CSS Inheritance: yes Name of the font to use. | ScrollControlBase
Inherited | fontGridFitType | Type: String CSS Inheritance: yes Sets the gridFitType property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSharpness | Type: Number CSS Inheritance: yes Sets the sharpness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontSize | Type: Number Format: Length CSS Inheritance: yes Height of the text, in pixels. | ScrollControlBase
Inherited | fontStyle | Type: String CSS Inheritance: yes Determines whether the text is italic font. | ScrollControlBase
Inherited | fontThickness | Type: Number CSS Inheritance: yes Sets the thickness property of internal TextFields that represent text in Flex controls. | ScrollControlBase
Inherited | fontWeight | Type: String CSS Inheritance: yes Determines whether the text is boldface. | ScrollControlBase
Inherited | headerColors | Type: Array Format: Color CSS Inheritance: yes An array of two colors used to draw the header background gradient. | DataGrid
Inherited | headerSeparatorSkin | Type: Class CSS Inheritance: no The class to use as the skin for the separator between the DataGrid header and the rest of the rows. | DataGrid
Inherited | headerStyleName | Type: String CSS Inheritance: no The name of a CSS style declaration for controlling other aspects of the appearance of the column headers. | DataGrid
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | horizontalGridLineColor | Type: uint Format: Color CSS Inheritance: yes The color of the horizontal grid lines. | DataGrid
Inherited | horizontalGridLines | Type: Boolean CSS Inheritance: no A flag that indicates whether to show horizontal grid lines between the rows. | DataGrid
Inherited | leading | Type: Number Format: Length CSS Inheritance: no Additional vertical space between lines of text. | ScrollControlBase
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | paddingBottom | Type: Number Format: Length CSS Inheritance: no The number of pixels between the bottom of the row and the bottom of the renderer in the row. | ListBase
Inherited | paddingLeft | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's left border and the left edge of its content area. | ListBase
Inherited | paddingRight | Type: Number Format: Length CSS Inheritance: no Number of pixels between the container's right border and the right edge of its content area. | ListBase
Inherited | paddingTop | Type: Number Format: Length CSS Inheritance: no The number of pixels between the top of the row and the top of the renderer in the row. | ListBase
Inherited | repeatDelay | Type: Number Format: Time CSS Inheritance: no Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval. | ScrollControlBase
Inherited | repeatInterval | Type: Number Format: Time CSS Inheritance: no Number of milliseconds between buttonDown events if the user presses and holds on a button. | ScrollControlBase
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | shadowDirection | Type: String CSS Inheritance: no Direction of the drop shadow. | ScrollControlBase
Inherited | shadowDistance | Type: Number Format: Length CSS Inheritance: no Distance of the drop shadow. | ScrollControlBase
Inherited | sortArrowSkin | Type: Class CSS Inheritance: no The class to use as the skin for the arrow that indicates the column sort direction. | DataGrid
Inherited | stretchCursor | Type: Class CSS Inheritance: no The class to use as the skin for the cursor that indicates that a column can be resized. | DataGrid
Inherited | textAlign | Type: String CSS Inheritance: yes Alignment of text within a container. | ScrollControlBase
Inherited | textDecoration | Type: String CSS Inheritance: no Determines whether the text is underlined. | ScrollControlBase
Inherited | textIndent | Type: Number Format: Length CSS Inheritance: yes Offset of first line of text from the left side of the container, in pixels. | ScrollControlBase
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalAlign | Type: String CSS Inheritance: no The vertical alignment of a renderer in a row. | ListBase
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | verticalGridLineColor | Type: uint Format: Color CSS Inheritance: yes The color of the vertical grid lines. | DataGrid
Inherited | verticalGridLines | Type: Boolean CSS Inheritance: no A flag that indicates whether to show vertical grid lines between the columns. | DataGrid
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Property detail
currentPageHeight property
currentPageHeight:Number [read-only]

The height of PrintDataGrid that would be, if sizeToPage property is true and PrintDataGrid displays only completely viewable rows and no partial rows. If sizeToPage property is true, the value of this property equals the height property.

Implementation
    public function get currentPageHeight():Number
originalHeight property
originalHeight:Number [read-only]

The height of PrintDataGrid as set by the user. If the sizeToPage property is false, the value of this property equals the height property.

Implementation
    public function get originalHeight():Number
sizeToPage property
public var sizeToPage:Boolean = true

If true, the PrintDataGrid readjusts its height to display only completely viewable rows.

validNextPage property
validNextPage:Boolean [read-only]

Indicates the data provider contains additional data rows that follow the rows that the PrintDataGrid control currently displays.

Implementation
    public function get validNextPage():Boolean
Constructor detail
PrintDataGrid () constructor
public function PrintDataGrid()

Constructor.

Constructs a DataGrid without scrollbars or user interactivity: column sorting, resizing, drag scrolling, selection, or keyboard interaction. The default height is 100% of the container height, or the height required to display all the dataProvider rows, whichever is smaller.

Method detail
nextPage () method
public function nextPage():void

Puts the next set of data rows in view; that is, it sets the PrintDataGrid verticalScrollPosition property to equal verticalScrollPosition + (number of scrollable rows).

Examples
FormPrintHeader
<?xml version="1.0"?>
<!-- Custom control for the header area of the printed page. -->

<mx:VBox xmlns:mx="http://www.adobe.com/2006/mxml" width="60%"
    horizontalAlign="right" >

    <mx:Label text="This is a placeholder for first page contents"/>
</mx:VBox>
FormPrintFooter
<?xml version="1.0"?>
<!-- Custom control for the footer area of the printed page. -->

<mx:VBox xmlns:mx="http://www.adobe.com/2006/mxml" width="60%"
    horizontalAlign="right" >
    <!-- Declare and initialize the product total variable. -->

    <mx:Script>
        <![CDATA[
            [Bindable]
            public var pTotal:Number = 0;
        ]]>
    </mx:Script>
    <mx:Label text="Product Total: {pTotal}"/>
</mx:VBox>
FormPrintView
<?xml version="1.0"?>
<!-- Custom control to print the DataGrid control on multiple pages. -->

<mx:VBox xmlns:mx="http://www.adobe.com/2006/mxml" xmlns="*" backgroundColor="#FFFFFF"
    paddingTop="50" paddingBottom="50" paddingLeft="50">

    <mx:Script>
        <![CDATA[
            import mx.core.*
            // Declare and initialize the variables used in the component.
            // The application sets the actual prodTotal value.
            [Bindable]
            public var pageNumber:Number = 1;
            [Bindable]
            public var prodTotal:Number = 0;

            // Control the page contents by selectively hiding the header and
            // footer based on the page type.
            public function showPage(pageType:String):void {
                if(pageType == "first" || pageType == "middle") {
                    // Hide the footer.
                    footer.includeInLayout=false;
                    footer.visible = false;
                }
                if(pageType == "middle" || pageType == "last") {
                    // The header won't be used again; hide it.
                    header.includeInLayout=false;
                    header.visible = false;
                }
                if(pageType == "last") {
                    // Show the footer.
                    footer.includeInLayout=true;
                    footer.visible = true;
                }
                //Update the DataGrid layout to reflect the results.
                validateNow();
            }
        ]]>
    </mx:Script>

    <!-- The template for the printed page, with the contents for all pages. -->
    <mx:VBox width="80%" horizontalAlign="left">
        <mx:Label text="Page {pageNumber}"/>
    </mx:VBox>

    <FormPrintHeader id="header" />
    <!-- The data grid. The sizeToPage property is true by default, so the last
        page has only as many grid rows as are needed for the data. -->
    <mx:PrintDataGrid id="myDataGrid" width="60%" height="100%">
    <!-- Specify the columns to ensure that their order is correct. -->
        <mx:columns>
            <mx:DataGridColumn dataField="Index" />
            <mx:DataGridColumn dataField="Qty" />
        </mx:columns>
    </mx:PrintDataGrid>

    <!-- Create a FormPrintFooter control and set its prodTotal variable. -->
    <FormPrintFooter id="footer" pTotal="{prodTotal}" />

</mx:VBox>
PrintDataGridExample
<?xml version="1.0"?>
<!-- Main application to print a DataGrid control on multiple pages. -->

<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" initialize="initData();">

    <mx:Script>
        <![CDATA[

        import mx.printing.*;
        import mx.collections.ArrayCollection;
        import FormPrintView;

        // Declare variables and initialize simple variables.
        [Bindable]
        public var dgProvider:ArrayCollection;
        public var footerHeight:Number = 20;
        public var prodIndex:Number;
        public var prodTotal:Number = 0;

        // Data initialization.
        public function initData():void {
            // Create the data provider for the DataGrid control.
            dgProvider = new ArrayCollection;
        }

        // Fill the dgProvider ArrayCollection with the specified items.
        public function setdgProvider(items:int):void {

            prodIndex=1;
            dgProvider.removeAll();
            for (var z:int=0; z<items; z++)
            {
                var prod1:Object = {};
                prod1.Qty = prodIndex * 7;
                prod1.Index = prodIndex++;
                prodTotal += prod1.Qty;
                dgProvider.addItem(prod1);
            }
        }

        // The function to print the output.
        public function doPrint():void {

            var printJob:FlexPrintJob = new FlexPrintJob();
            if (printJob.start()) {
                // Create a FormPrintView control as a child of the current view.
                var thePrintView:FormPrintView = new FormPrintView();
               Application.application.addChild(thePrintView);

                //Set the print view properties.
                thePrintView.width=printJob.pageWidth;
                thePrintView.height=printJob.pageHeight;
                thePrintView.prodTotal = prodTotal;
                // Set the data provider of the FormPrintView component's data grid
                // to be the data provider of the displayed data grid.
                thePrintView.myDataGrid.dataProvider = myDataGrid.dataProvider;
                // Create a single-page image.
                thePrintView.showPage("single");
                // If the print image's data grid can hold all the provider's rows,
                // add the page to the print job.
                if(!thePrintView.myDataGrid.validNextPage)
                {
                    printJob.addObject(thePrintView);
                }
                // Otherwise, the job requires multiple pages.
                else
                {
                    // Create the first page and add it to the print job.
                    thePrintView.showPage("first");
                    printJob.addObject(thePrintView);
                    thePrintView.pageNumber++;
                    // Loop through the following code until all pages are queued.
                    while(true)
                    {
                        // Move the next page of data to the top of the print grid.
                        thePrintView.myDataGrid.nextPage();
                        thePrintView.showPage("last");
                        // If the page holds the remaining data, or if the last page
                        // was completely filled by the last grid data, queue it for printing.
                        // Test if there is data for another PrintDataGrid page.
                        if(!thePrintView.myDataGrid.validNextPage)
                        {
                            // This is the last page; queue it and exit the print loop.
                            printJob.addObject(thePrintView);
                            break;
                        }
                        else
                        // This is not the last page. Queue a middle page.
                        {
                            thePrintView.showPage("middle");
                            printJob.addObject(thePrintView);
                            thePrintView.pageNumber++;
                        }
                    }
                }
                // All pages are queued; remove the FormPrintView control to free memory.
                Application.application.removeChild(thePrintView);
            }
            // Send the job to the printer.
            printJob.send();
        }
        ]]>
    </mx:Script>

    <mx:Panel title="CheckBox Control Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:DataGrid id="myDataGrid" dataProvider="{dgProvider}">
            <mx:columns>
                <mx:DataGridColumn dataField="Index"/>
                <mx:DataGridColumn dataField="Qty"/>
            </mx:columns>
        </mx:DataGrid>

        <mx:Text width="100%" color="blue"
            text="Specify the number of lines and click Fill Grid first. Then you can click Print."/>

        <mx:TextInput id="dataItems" text="35"/>

        <mx:HBox>
            <mx:Button id="setDP" label="Fill Grid" click="setdgProvider(int(dataItems.text));"/>
            <mx:Button id="printDG" label="Print" click="doPrint();"/>
        </mx:HBox>
    </mx:Panel>
</mx:Application>


mx.resources Summary (Flex™ 2 Language Reference)

Package mx.resources | Classes

The mx.resources package contains the classes used to support localization.

Classes
Class | Description
Locale | You can use this class to query the current Locale.
ResourceBundle | This class can be used to internationalize the framework and applications.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.resources.Locale (Flex™ 2 Language Reference)

Class Locale | Properties | Methods
Package | mx.resources
Class | public class Locale
Inheritance | Locale Inheritance Object

You can use this class to query the current Locale. The locale is settlable through the XML configuration file,an mxmlc compiler argument or through Flex builder. However, locale is not settable through the Locale class at run time. The framework currently supports en_US and ja_JP only. However, you can create properties files for any language and keep them under a locale folder, such as fr_FR for French. eg: Locale.getCurrent(Application.application.systemManager).country returns the current country.

See also

mx.resources.ResourceBundle

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | country : String [read-only] The country of current locale [Read-Only]. | Locale
 | language : String [read-only] The language of current locale [Read-Only]. | Locale
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | variant : String [read-only] The variant of current locale [Read-Only]. | Locale
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Locale(localeStr:String) Constructor. | Locale
 | getCurrent(sm:ISystemManager):Locale [static] Gets the current locale. | Locale
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String Returns locale in the form language_country_variant if variant is present else language_country | Locale
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
country property
country:String [read-only]

The country of current locale [Read-Only].

The default value is "EN".

Implementation
    public function get country():String

Example
      Locale.getCurrent(Application.application.systemManager).country

language property
language:String [read-only]

The language of current locale [Read-Only].

The default value is "en".

Implementation
    public function get language():String

Example
      Locale.getCurrent(Application.application.systemManager).language

variant property
variant:String [read-only]

The variant of current locale [Read-Only].

The default value is "".

Implementation
    public function get variant():String

Example
      Locale.getCurrent(Application.application.systemManager).variant

Constructor detail
Locale () constructor
public function Locale(localeStr:String)

Constructor.

Parameters
localeStr:String
Method detail
getCurrent () method
public static function getCurrent(sm:ISystemManager):Locale

Gets the current locale.

Parameters
sm:ISystemManager

Returns
Locale

Example
      Locale.getCurrent(Application.application.systemManager).country

toString () method
public function toString():String

Returns locale in the form language_country_variant if variant is present else language_country

Returns
String

Example
      Locale.getCurrent(Application.application.systemManager).toString()


mx.resources.ResourceBundle (Flex™ 2 Language Reference)

Class ResourceBundle | Properties | Methods
Package | mx.resources
Class | public class ResourceBundle
Inheritance | ResourceBundle Inheritance Object

This class can be used to internationalize the framework and applications. To localize an application, you can create one properties file per class or per package or simply a single properties file. This properties file is exactly like a Java-based properties file which has name-value pairs. The properties file name can be the same as the class name, for example, MyAlert.properties corresponding to MyAlert.as, or it can have a different name. Exisiting framework properties files can be found in the frameworks/locale/en_US/ directory. The frameworks/locale/en_US/SharedResources.properties file contains all shared keys and error strings across the framework.

If you want to localize in a particular language, for example French, you would make a copy of frameworks/locale/en_US/ directory and call it fr_FR/ and make the necessary changes to the framework properties files. You can compile your application kept in MyApp using "..\bin\mxmlc.exe" -locale en_US -library-path=..\frameworks\libs -source-path="..\frameworks\locale\{locale}, ..\myLocale\{locale}" main.mxml

Note that the source-path mentions the source for both frmaework properties files as well as myApp's properties files. In this case, you would place MyAlert.properties in the myLocale/en_US and myLocale/fr_FR directories. The locale directory should be part of the compc ActionScript classpath but should not be a part of the ActionScript classpath that is used for mxmlc when building the main SWF file; for example, placing myLocale in the myApp directory would throw a compiler warning. The locale is settable through the xml config file, mxml compiler argument or through Flex builder. However, locale is not settable through the Locale class at runtime.

The framework currently supports en_US and ja_JP only. However, you can create properties files for any language and keep them under a locale folder, such as fr_FR for French.

While getting localizable text, you must specify the filename in the ResourceBundle metadata; for example:

 [ResourceBundle('MyAlert')]
 private static var rb:ResourceBundle;

and then access it in ActionScript using rb.getString('foo'); or in MXML using @Resource(bundle='MyAlert', key='foo').

See also

mx.resources.Locale

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ResourceBundle() Constructor. | ResourceBundle
 | getBoolean(key:String, defaultValue:Boolean = true):Boolean Gets a Boolean from a ResourceBundle. | ResourceBundle
 | getNumber(key:String):Number Gets a Number from a ResourceBundle. | ResourceBundle
 | getObject(key:String):Object Gets an object from a ResourceBundle. | ResourceBundle
 | getResourceBundle(baseName:String, currentDomain:ApplicationDomain = null):ResourceBundle [static] Gets a ResourceBundle when provided with a className. | ResourceBundle
 | getString(key:String):String Gets a string from a ResourceBundle. | ResourceBundle
 | getStringArray(key:String):Array Gets an array from a ResourceBundle. | ResourceBundle
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Method |  | Defined by
 | getContent():Object You can override this method to provide your own keys and values for a ResourceBundle or to add objects to your custom ResourceBundle. | ResourceBundle
Constructor detail
ResourceBundle () constructor
public function ResourceBundle()

Constructor.

Method detail
getBoolean () method
public function getBoolean(key:String, defaultValue:Boolean = true):Boolean

Gets a Boolean from a ResourceBundle.

Parameters
key:String
defaultValue:Boolean (default = true)

Returns
Boolean

Example
     [ResourceBundle("foo")]
     private static var packageResources:ResourceBundle;
     packageResources.getString("myBooleanKey");

getContent () method
protected function getContent():Object

You can override this method to provide your own keys and values for a ResourceBundle or to add objects to your custom ResourceBundle. The following example adds a jpg image to a custom ResourceBundle. First you create a class called myPic. You then make a custom ResourceBundle called myBundle.

Returns
Object

See also

getObject()

Example
     package {
     [Embed(source='picture.jpg')]
     public class myPic extends mx.core.SpriteAsset {}
     }
     package {
     import mx.resources.ResourceBundle;
     public class myBundle extends ResourceBundle {
     public function myBundle() { super(); }
     override protected static function getContent():Object {
     var contentObj:Object = new Object();
     content.push("myPic", myPic);
     return contentObj; }}}

getNumber () method
public function getNumber(key:String):Number

Gets a Number from a ResourceBundle.

Parameters
key:String

Returns
Number

Example
      [ResourceBundle("foo")]
      private static var packageResources:ResourceBundle;
      packageResources.getString("myNumericKey");

getObject () method
public function getObject(key:String):Object

Gets an object from a ResourceBundle. The folowing example shows how to get a jpg image with the getObject() method.

Parameters
key:String

Returns
Object

See also

getContent()

Example
   [ResourceBundle("MyBundle")]
   private static var rb:ResourceBundle;
   var sprite:SpriteAsset = SpriteAsset(rb.getObject("myPic"));

getResourceBundle () method
public static function getResourceBundle(baseName:String, currentDomain:ApplicationDomain = null):ResourceBundle

Gets a ResourceBundle when provided with a className.

Parameters
baseName:String
currentDomain:ApplicationDomain (default = null)

Returns
ResourceBundle

Example
     private static var rb:ResourceBundle;
     rb = getResourceBundle("fooBundle");

getString () method
public function getString(key:String):String

Gets a string from a ResourceBundle.

Parameters
key:String

Returns
String

Example
         [ResourceBundle("controls")]
  private static var packageResources:ResourceBundle;
  packageResources.getString("okLabel");

getStringArray () method
public function getStringArray(key:String):Array

Gets an array from a ResourceBundle.

Parameters
key:String

Returns
Array

Example
     [ResourceBundle("SharedResources")]
     private static var sharedResources:ResourceBundle;
     sharedResources.getStringArray("monthNames");


mx.rpc Summary (Flex™ 2 Language Reference)

Package mx.rpc | Interfaces | Classes

The mx.rpc package contains the RPC classes.

Interfaces
Interface | Description
IResponder | This interface provides the contract for any service that needs to respond to remote or asynchronous calls.
Classes
Class | Description
AbstractInvoker | An invoker is an object that actually executes an remote procedure call (RPC).
AbstractOperation | The AbstractOperation class represents an is an individual method on a service.
AbstractService | the AbstractService class is the base class for the WebService and RemoteObject classes.
AsyncRequest | The AsyncRequest class provides an abstraction of messaging for RPC call invocation.
AsyncToken | This class provides a place to set additional or token-level data for asynchronous rpc operations.
Fault | Object that represents a fault in an remote procedure call (RPC) service invocation.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.AbstractInvoker (Flex™ 2 Language Reference)

Class AbstractInvoker | Properties | Methods
Package | mx.rpc
Class | public class AbstractInvoker
Inheritance | AbstractInvoker Inheritance EventDispatcher Inheritance Object
Subclasses | AbstractOperation, HTTPService

An invoker is an object that actually executes an remote procedure call (RPC). For example, RemoteObject, HTTPService, and WebService objects are invokers.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | lastResult : Object [read-only] The result of the last invocation. | AbstractInvoker
 | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | AbstractInvoker
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
cancel():void
Cancels the last service invocation.
AbstractInvoker
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
lastResult property
lastResult:Object [read-only]

The result of the last invocation.

This property can be used as the source for data binding.

Implementation
    public function get lastResult():Object
makeObjectsBindable property
makeObjectsBindable:Boolean [read-write]

When this value is true, anonymous objects returned are forced to bindable objects.

Implementation
    public function get makeObjectsBindable():Boolean
    public function set makeObjectsBindable(value:Boolean):void
Method detail
cancel () method
public function cancel():void

Cancels the last service invocation. Even though the network operation may still continue, no result or fault event is dispatched.

clearResult () method
public function clearResult(fireBindingEvent:Boolean = true):void

Sets the result property of the invoker to null. This is useful when the result is a large object that is no longer being used.

Parameters
fireBindingEvent:Boolean (default = true) — fireBindingEvent Set to true if you want anything bound to the result to update. Otherwise, set to false. The default value is true


mx.rpc.AbstractOperation (Flex™ 2 Language Reference)

Class AbstractOperation | Properties | Methods | Events
Package | mx.rpc
Class | public class AbstractOperation
Inheritance | AbstractOperation Inheritance AbstractInvoker Inheritance EventDispatcher Inheritance Object
Subclasses | Operation, Operation

The AbstractOperation class represents an is an individual method on a service. An Operation can be called either by invoking the function of the same name on the service or by accessing the Operation as a property on the service and calling the send() method.

See also

mx.rpc.AbstractService
mx.rpc.remoting.RemoteObject
mx.rpc.soap.WebService

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | arguments : Object The arguments to pass to the Operation when it is invoked. | AbstractOperation
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | lastResult : Object The result of the last invocation. | AbstractInvoker
Inherited | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | AbstractInvoker
 | name : String The name of this Operation. | AbstractOperation
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | service : AbstractService [read-only] Provides convenient access to the service on which the Operation is being invoked. | AbstractOperation
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AbstractOperation(service:AbstractService = null, name:String = null)
Creates a new Operation.
AbstractOperation
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
cancel():void
Cancels the last service invocation.
AbstractInvoker
Inherited
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(... args):AsyncToken
Executes the method.
AbstractOperation
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | fault | Dispatched when an Operation call fails. | AbstractOperation
 | result | Dispatched when an Operation invocation successfully returns. | AbstractOperation
Property detail
arguments property
public var arguments:Object

The arguments to pass to the Operation when it is invoked. If you call the send() method with no parameters, an array based on this object is sent. If you call the send() method with parameters (or call the function directly on the service) those parameters are used instead of whatever is stored in this property. For RemoteObject Operations the associated argumentNames array determines the order of the arguments passed.

name property
name:String [read-write]

The name of this Operation. This is how the Operation is accessed off the service. It can only be set once.

Implementation
    public function get name():String
    public function set name(value:String):void
service property
service:AbstractService [read-only]

Provides convenient access to the service on which the Operation is being invoked. Note that the service cannot be changed after the Operation is constructed.

Implementation
    public function get service():AbstractService
Constructor detail
AbstractOperation () constructor
public function AbstractOperation(service:AbstractService = null, name:String = null)

Creates a new Operation. This is usually done directly by the MXML compiler or automatically by the service when an unknown Operation has been accessed. It is not recommended that a developer use this constructor directly.

Parameters
service:AbstractService (default = null)
name:String (default = null)
Method detail
send () method
public function send(... args):AsyncToken

Executes the method. Any arguments passed in are passed along as part of the method call. If there are no arguments passed, the arguments object is used as the source of parameters.

Parameters
... args

Returns
AsyncToken — AsyncToken Call using the asynchronous completion token pattern. The same object is available in the result and fault events from the token property.
Event detail
fault event
Event object type: mx.rpc.events.FaultEvent
FaultEvent.type property = mx.rpc.events.FaultEvent.FAULT

Dispatched when an Operation call fails.

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, calling preventDefault() from the associated token's responder.fault method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that contains the details of what caused this event.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
result event
Event object type: mx.rpc.events.ResultEvent
ResultEvent.type property = mx.rpc.events.ResultEvent.RESULT

Dispatched when an Operation invocation successfully returns.

The RESULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, preventDefault() from the associated token's responder.result method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result | Result that the RPC call returns.
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.


mx.rpc.AbstractService (Flex™ 2 Language Reference)

Class AbstractService | Properties | Methods | Events
Package | mx.rpc
Class | public dynamic class AbstractService
Inheritance | AbstractService Inheritance Proxy Inheritance Object
Implements | IEventDispatcher
Subclasses | RemoteObject, WebService

the AbstractService class is the base class for the WebService and RemoteObject classes. This class does the work of creating Operations which do the actual execution of remote procedure calls.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | channelSet : ChannelSet Provides access to the ChannelSet used by the service. | AbstractService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | destination : String The destination of the service. | AbstractService
 | operations : Object The Operations array is usually only set by the MXML compiler if you create a service using an MXML tag. | AbstractService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | AbstractService
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AbstractService(destination:String = null) | AbstractService
 | disconnect():void Disconnects the service's network connection and removes any pending request responders. | AbstractService
 | getOperation(name:String):AbstractOperation Returns an Operation of the given name. | AbstractService
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | logout():void Logs the user out of the destination. | AbstractService
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | setCredentials(username:String, password:String):void Set the credentials for the destination accessed by the service. | AbstractService
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setRemoteCredentials(remoteUsername:String, remotePassword:String):void The username and password to be used to authenticate a user when accessing a remote, third-party endpoint such as a webservice through a proxy or a remote object through a custom adapter. | AbstractService
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Event |  | Summary | Defined by
 | fault | The fault event is dispatched when a service call fails and isn't handled by the Operation itself. | AbstractService
 | invoke | The invoke event is dispatched when a service Operation is invoked so long as an Error is not thrown before the Channel attempts to send the message. | AbstractService
 | result | The result event is dispatched when a service call successfully returns and isn't handled by the Operation itself. | AbstractService
Property detail
channelSet property
channelSet:ChannelSet [read-write]

Provides access to the ChannelSet used by the service. The ChannelSet can be manually constructed and assigned, or it will be dynamically created to use the configured Channels for the destination for this service.

This property can be used as the source for data binding.

Implementation
    public function get channelSet():ChannelSet
    public function set channelSet(value:ChannelSet):void
destination property
destination:String [read-write]

The destination of the service. This value should match a destination entry in the services-config.xml file.

This property can be used as the source for data binding.

Implementation
    public function get destination():String
    public function set destination(value:String):void
operations property
operations:Object [read-write]

The Operations array is usually only set by the MXML compiler if you create a service using an MXML tag.

This property can be used as the source for data binding.

Implementation
    public function get operations():Object
    public function set operations(value:Object):void
requestTimeout property
requestTimeout:int [read-write]

Provides access to the request timeout in seconds for sent messages. A value less than or equal to zero prevents request timeout.

This property can be used as the source for data binding.

Implementation
    public function get requestTimeout():int
    public function set requestTimeout(value:int):void
Constructor detail
AbstractService () constructor
public function AbstractService(destination:String = null)Parameters
destination:String (default = null)
Method detail
disconnect () method
public function disconnect():void

Disconnects the service's network connection and removes any pending request responders. This method does not wait for outstanding network operations to complete.

getOperation () method
public final function getOperation(name:String):AbstractOperation

Returns an Operation of the given name. If the Operation wasn't been created beforehand, it is created during this call. Operations are usually accessible by simply naming them after the service variable (myService.someOperation), but if your Operation name happens to match a defined method on the service (like setCredentials), you can use this method to get the Operation instead.

Parameters
name:String — Name of the Operation.

Returns
AbstractOperation — Operation that executes for this name.
logout () method
public function logout():void

Logs the user out of the destination. Logging out of a destination applies to everything connected using the same ChannelSet as specified in the server configuration. For example, if you're connected over the my-rtmp channel and you log out using one of your RPC components, anything that was connected over the same ChannelSet is logged out.

setCredentials () method
public function setCredentials(username:String, password:String):void

Set the credentials for the destination accessed by the service. The credentials are applied to all services connected over the same ChannelSet. Note that services that use a proxy or a third-party adapter to a remote endpoint will need to setRemoteCredentials instead.

Parameters
username:String — The username for the destination.
password:String — The password for the destination.
setRemoteCredentials () method
public function setRemoteCredentials(remoteUsername:String, remotePassword:String):void

The username and password to be used to authenticate a user when accessing a remote, third-party endpoint such as a webservice through a proxy or a remote object through a custom adapter.

Parameters
remoteUsername:String — the username to pass to the remote endpoint
remotePassword:String — the password to pass to the remote endpoint
Event detail
fault event
Event object type: mx.rpc.events.FaultEvent
FaultEvent.type property = mx.rpc.events.FaultEvent.FAULT

The fault event is dispatched when a service call fails and isn't handled by the Operation itself.

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, calling preventDefault() from the associated token's responder.fault method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that contains the details of what caused this event.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
invoke event
Event object type: mx.rpc.events.InvokeEvent
InvokeEvent.type property = mx.rpc.events.InvokeEvent.INVOKE

The invoke event is dispatched when a service Operation is invoked so long as an Error is not thrown before the Channel attempts to send the message.

The INVOKE event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The request Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result event
Event object type: mx.rpc.events.ResultEvent
ResultEvent.type property = mx.rpc.events.ResultEvent.RESULT

The result event is dispatched when a service call successfully returns and isn't handled by the Operation itself.

The RESULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, preventDefault() from the associated token's responder.result method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result | Result that the RPC call returns.
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.


mx.rpc.AsyncRequest (Flex™ 2 Language Reference)

Class AsyncRequest | Properties | Methods | Events
Package | mx.rpc
Class | public class AsyncRequest
Inheritance | AsyncRequest Inheritance Producer Inheritance MessageAgent Inheritance EventDispatcher Inheritance Object

The AsyncRequest class provides an abstraction of messaging for RPC call invocation. An AsyncRequest allows multiple requests to be made on a remote destination and will call back to the responder specified within the request when the remote request is completed.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the MessageAgent. | MessageAgent
Inherited | clientId : String Provides access to the client id for the MessageAgent. | MessageAgent
Inherited | connected : Boolean Indicates whether this MessageAgent is currently connected to its destination via its ChannelSet. | MessageAgent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | defaultHeaders : Object The default headers to apply to messages sent by the Producer. | Producer
Inherited | destination : String Provides access to the destination for the MessageAgent. | MessageAgent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | MessageAgent
Inherited | subtopic : String Provides access to the subtopic for the remote destination that the MessageAgent uses. | MessageAgent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AsyncRequest()
Constructs a new asynchronous request.
AsyncRequest
Inherited
acknowledge(ackMsg:AcknowledgeMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a result for a sent message.
MessageAgent
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
channelConnectHandler(event:ChannelEvent):void
Handles a CONNECT ChannelEvent.
MessageAgent
Inherited
channelDisconnectHandler(event:ChannelEvent):void
Handles a DISCONNECT ChannelEvent.
MessageAgent
Inherited
channelFaultHandler(event:ChannelFaultEvent):void
Handles a ChannelFaultEvent.
MessageAgent
Inherited
disconnect():void
Disconnects the MessageAgent's network connection.
MessageAgent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
fault(errMsg:ErrorMessage, msg:IMessage):void
Invoked by a MessageResponder upon receiving a fault for a sent message.
MessageAgent
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called after the implementing object has been created and all properties specified on the tag have been assigned.
MessageAgent
invoke(msg:IMessage, responder:IResponder):void
Dispatches the asynchronous request and stores the responder to call later.
AsyncRequest
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout():void
Logs the MessageAgent out from its remote destination.
MessageAgent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
send(message:IMessage):void
Sends the specified message to its destination.
Producer
Inherited
setCredentials(username:String, password:String):void
Sets the credentials that the MessageAgent uses to authenticate to destinations.
MessageAgent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setRemoteCredentials(username:String, password:String):void
Sets the remote credentials that will be passed through to the remote destination for authenticating to secondary systems.
MessageAgent
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | initChannelSet(message:IMessage):void Used to automatically initialize the channelSet property for the MessageAgent before it connects for the first time. | MessageAgent
Inherited | internalSend(message:IMessage):void Sends a Message from the MessageAgent to its destination using the agent's ChannelSet. | MessageAgent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | acknowledge | Dispatched when an acknowledge message is received for a sent message. | MessageAgent
Inherited | channelConnect | Dispatched when the underlying Channel the MessageAgent is using connects. | MessageAgent
Inherited | channelDisconnect | Dispatched when the underlying Channel the MessageAgent is using disconnects. | MessageAgent
Inherited | channelFault | Dispatched when the underlying Channel the MessageAgent is using faults. | MessageAgent
Inherited | fault | Dispatched when a message fault occurs. | MessageAgent
Inherited | propertyChange | Dispatched when the connected property of the MessageAgent changes. | MessageAgent
Constructor detail
AsyncRequest () constructor
public function AsyncRequest()

Constructs a new asynchronous request.

Method detail
invoke () method
public function invoke(msg:IMessage, responder:IResponder):void

Dispatches the asynchronous request and stores the responder to call later.

Parameters
msg:IMessage
responder:IResponder


mx.rpc.AsyncToken (Flex™ 2 Language Reference)

Class AsyncToken | Properties | Methods | Events
Package | mx.rpc
Class | public dynamic class AsyncToken
Inheritance | AsyncToken Inheritance EventDispatcher Inheritance Object
Subclasses | ItemReference

This class provides a place to set additional or token-level data for asynchronous rpc operations. It also allows an IResponder to be attached for an individual call. The AsyncToken can be referenced in ResultEvent and FaultEvent from the token property.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | message : IMessage [read-only] Provides access to the associated message. | AsyncToken
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | responders : Array [read-only] An array of IResponder handlers that will be called when the asynchronous request completes. | AsyncToken
 | result : Object [read-only] The result that was returned by the associated RPC call. | AsyncToken
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AsyncToken(message:IMessage)
Constructs an instance of the token with the specified message.
AsyncToken
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
addResponder(responder:IResponder):void
addResponder adds a responder to an Array of responders.
AsyncToken
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
hasResponder():Boolean
Determines if this token has at least one mx.rpc.IResponder registered.
AsyncToken
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | propertyChange | Dispatched when a property of the channel set changes. | AsyncToken
Property detail
message property
message:IMessage [read-only]

Provides access to the associated message.

Implementation
    public function get message():IMessage
responders property
responders:Array [read-only]

An array of IResponder handlers that will be called when the asynchronous request completes. Eaxh responder assigned to the token will have its result or fault function called passing in the matching event before the operation or service dispatches the event itself. A developer can prevent the service from subsequently dispatching the event by calling event.preventDefault(). Note that this will not prevent the service or operation's result property from being assigned.

Implementation
    public function get responders():Array
result property
result:Object [read-only]

The result that was returned by the associated RPC call. Once the result property on the token has been assigned it will be strictly equal to the result property on the associated ResultEvent.

This property can be used as the source for data binding.

Implementation
    public function get result():Object
Constructor detail
AsyncToken () constructor
public function AsyncToken(message:IMessage)

Constructs an instance of the token with the specified message.

Parameters
message:IMessage
Method detail
addResponder () method
public function addResponder(responder:IResponder):void

addResponder adds a responder to an Array of responders. The object assigned to the responder parameter must implement mx.rpc.IResponder.

Parameters
responder:IResponder — A handler which will be called when the asynchronous request completes.

See also

mx.rpc.IResponder
hasResponder () method
public function hasResponder():Boolean

Determines if this token has at least one mx.rpc.IResponder registered.

Returns
Boolean — true if at least one responder has been added to this token.
Event detail
propertyChange event
Event object type: mx.events.PropertyChangeEvent
PropertyChangeEvent.type property = mx.events.PropertyChangeEvent.PROPERTY_CHANGE

Dispatched when a property of the channel set changes.

The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event.

The properties of the event object have the following values:

Property | Value
bubbles | Determined by the constructor; defaults to false.
cancelable | Determined by the constructor; defaults to false.
kind | The kind of change; PropertyChangeEventKind.UPDATE or PropertyChangeEventKind.DELETE.
oldValue | The original property value.
newValue | The new property value, if any.
property | The property that changed
source | The object that contains the property that changed.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.rpc.Fault (Flex™ 2 Language Reference)

Class Fault | Properties | Methods
Package | mx.rpc
Class | public class Fault
Inheritance | Fault Inheritance Error Inheritance Object

Object that represents a fault in an remote procedure call (RPC) service invocation.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorID : int Contains the reference number associated with the specific error message. | Error
 | faultCode : String [read-only] A simple code describing the fault. | Fault
 | faultDetail : String [read-only] Any extra details of the fault. | Fault
 | faultString : String [read-only] Text description of the fault. | Fault
Inherited | message : String Contains the message associated with the Error object. | Error
Inherited | name : String Contains the name of the Error object. | Error
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | rootCause : Object The cause of the fault. | Fault
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Fault(faultCode:String, faultString:String, faultDetail:String = null) Creates a new Fault object. | Fault
Inherited | getStackTrace():String Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only). | Error
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toString():String | Fault
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
faultCode property
faultCode:String [read-only]

A simple code describing the fault.

Implementation
    public function get faultCode():String
faultDetail property
faultDetail:String [read-only]

Any extra details of the fault.

Implementation
    public function get faultDetail():String
faultString property
faultString:String [read-only]

Text description of the fault.

Implementation
    public function get faultString():String
rootCause property
public var rootCause:Object

The cause of the fault. The value will be null if the cause is unknown or whether this fault represents the root itself.

Constructor detail
Fault () constructor
public function Fault(faultCode:String, faultString:String, faultDetail:String = null)

Creates a new Fault object.

Parameters
faultCode:String
faultString:String
faultDetail:String (default = null)
Method detail
toString () method
public function toString():String

Returns
String


mx.rpc.IResponder (Flex™ 2 Language Reference)

Interface IResponder | Methods
Package | mx.rpc
Interface | public interface IResponder
Implementors | ItemResponder

This interface provides the contract for any service that needs to respond to remote or asynchronous calls.

Public Methods
Method |  | Defined by
 | fault(info:Object):void This method is called by a service when an error has been received. | IResponder
 | result(data:Object):void This method is called by a service when the return value has been received. | IResponder
Method detail
fault () method
public function fault(info:Object):void

This method is called by a service when an error has been received. While info is typed as Object it is often (but not always) an mx.rpc.events.FaultEvent.

Parameters
info:Object
result () method
public function result(data:Object):void

This method is called by a service when the return value has been received. While data is typed as Object, it is often (but not always) an mx.rpc.events.ResultEvent.

Parameters
data:Object


mx.rpc.events Summary (Flex™ 2 Language Reference)

Package mx.rpc.events | Classes

The mx.rpc.events package contains the RPC event classes.

Classes
Class | Description
AbstractEvent | The base class for events that RPC services dispatch.
FaultEvent | This event is dispatched when an RPC call has a fault.
HeaderEvent | The event that indicates an RPC operation, such as a WebService SOAP request, returned a header in the response.
InvokeEvent | The event that indicates an RPC operation has been invoked.
ResultEvent | The event that indicates an RPC operation has successfully returned a result.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.events.AbstractEvent (Flex™ 2 Language Reference)

Class AbstractEvent | Properties | Methods | Constants
Package | mx.rpc.events
Class | public class AbstractEvent
Inheritance | AbstractEvent Inheritance MessageEvent Inheritance Event Inheritance Object
Subclasses | FaultEvent, HeaderEvent, InvokeEvent, ResultEvent

The base class for events that RPC services dispatch.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
 | token : AsyncToken [read-only] The token that represents the call to the method. | AbstractEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | clone():Event Clones the MessageEvent. | MessageEvent
Inherited | createEvent(type:String, msg:IMessage):MessageEvent [static] Utility method to create a new MessageEvent that doesn't bubble and is not cancelable. | MessageEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
Inherited | toString():String Returns a string representation of the MessageEvent. | MessageEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
token property
token:AsyncToken [read-only]

The token that represents the call to the method. Used in the asynchronous completion token pattern.

Implementation
    public function get token():AsyncToken


mx.rpc.events.FaultEvent (Flex™ 2 Language Reference)

Class FaultEvent | Properties | Methods | Constants
Package | mx.rpc.events
Class | public class FaultEvent
Inheritance | FaultEvent Inheritance AbstractEvent Inheritance MessageEvent Inheritance Event Inheritance Object
Subclasses | DataServiceFaultEvent

This event is dispatched when an RPC call has a fault.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | fault : Fault [read-only] The Fault object that contains the details of what caused this event. | FaultEvent
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | token : AsyncToken The token that represents the call to the method. | AbstractEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | FaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, fault:Fault = null, token:AsyncToken = null, message:IMessage = null) Create a new FaultEvent. | FaultEvent
Inherited | clone():Event Clones the MessageEvent. | MessageEvent
 | createEvent(fault:Fault, token:AsyncToken = null, msg:IMessage = null):FaultEvent [static] Given a Fault, this method constructs and returns a FaultEvent. | FaultEvent
 | createEventFromMessageFault(value:MessageFaultEvent, token:AsyncToken = null):FaultEvent [static] Given a MessageFaultEvent, this method constructs and returns a FaultEvent. | FaultEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string representation of the FaultEvent. | FaultEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | FAULT : String = "fault" [static] The FAULT event type. | FaultEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
fault property
fault:Fault [read-only]

The Fault object that contains the details of what caused this event.

Implementation
    public function get fault():Fault
Constructor detail
FaultEvent () constructor
public function FaultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, fault:Fault = null, token:AsyncToken = null, message:IMessage = null)

Create a new FaultEvent. The fault is a required parameter while the call and message are optional.

Parameters
type:String — The event type; indicates the action that triggered the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = true) — Specifies whether the behavior associated with the event can be prevented.
fault:Fault (default = null) — Object that holds details of the fault, including a faultCode and faultString
token:AsyncToken (default = null) — Token representing the call to the method. Used in the asynchronous completion token pattern.
message:IMessage (default = null) — Source Message of the fault.
Method detail
createEvent () method
public static function createEvent(fault:Fault, token:AsyncToken = null, msg:IMessage = null):FaultEvent

Given a Fault, this method constructs and returns a FaultEvent.

Parameters
fault:Fault — Fault that contains the details of the FaultEvent.
token:AsyncToken (default = null) — AsyncToken [optional] associated with this fault.
msg:IMessage (default = null) — Message [optional] associated with this fault.

Returns
FaultEvent
createEventFromMessageFault () method
public static function createEventFromMessageFault(value:MessageFaultEvent, token:AsyncToken = null):FaultEvent

Given a MessageFaultEvent, this method constructs and returns a FaultEvent.

Parameters
value:MessageFaultEvent — MessageFaultEvent reference to extract the appropriate fault information from.
token:AsyncToken (default = null) — AsyncToken [optional] associated with this fault.

Returns
FaultEvent
toString () method
public override function toString():String

Returns a string representation of the FaultEvent.

Returns
String — String representation of the FaultEvent.
Constant detail
FAULT constant
public static const FAULT:String = "fault"

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, calling preventDefault() from the associated token's responder.fault method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that contains the details of what caused this event.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.


mx.rpc.events.HeaderEvent (Flex™ 2 Language Reference)

Class HeaderEvent | Properties | Methods | Constants
Package | mx.rpc.events
Class | public class HeaderEvent
Inheritance | HeaderEvent Inheritance AbstractEvent Inheritance MessageEvent Inheritance Event Inheritance Object

The event that indicates an RPC operation, such as a WebService SOAP request, returned a header in the response. A new header event is dispatched for each service header.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
 | header : Object [read-only] Header that the RPC call returned in the response. | HeaderEvent
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | token : AsyncToken The token that represents the call to the method. | AbstractEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | HeaderEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, header:Object = null, token:AsyncToken = null, message:IMessage = null) Creates a new HeaderEvent. | HeaderEvent
Inherited | clone():Event Clones the MessageEvent. | MessageEvent
 | createEvent(header:Object, token:AsyncToken, message:IMessage):HeaderEvent [static] | HeaderEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string representation of the HeaderEvent. | HeaderEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
 | HEADER : String = "header" [static] The HEADER event type. | HeaderEvent
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
header property
header:Object [read-only]

Header that the RPC call returned in the response.

Implementation
    public function get header():Object
Constructor detail
HeaderEvent () constructor
public function HeaderEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, header:Object = null, token:AsyncToken = null, message:IMessage = null)

Creates a new HeaderEvent.

Parameters
type:String — Object that holds the header of the call.
bubbles:Boolean (default = false) — AsyncToken that represents the call to the method. Used in the asynchronous completion token pattern.
cancelable:Boolean (default = true) — Source Message of the header.
header:Object (default = null)
token:AsyncToken (default = null)
message:IMessage (default = null)
Method detail
createEvent () method
public static function createEvent(header:Object, token:AsyncToken, message:IMessage):HeaderEvent Parameters
header:Object
token:AsyncToken
message:IMessage

Returns
HeaderEvent
toString () method
public override function toString():String

Returns a string representation of the HeaderEvent.

Returns
String — String representation of the HeaderEvent.
Constant detail
HEADER constant
public static const HEADER:String = "header"

The HEADER event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
cancelable | true, but the preventDefault() method has no effect.
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
header | Header that the RPC call returns in the response.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.rpc.events.InvokeEvent (Flex™ 2 Language Reference)

Class InvokeEvent | Properties | Methods | Constants
Package | mx.rpc.events
Class | public class InvokeEvent
Inheritance | InvokeEvent Inheritance AbstractEvent Inheritance MessageEvent Inheritance Event Inheritance Object

The event that indicates an RPC operation has been invoked.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | token : AsyncToken The token that represents the call to the method. | AbstractEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | InvokeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, token:AsyncToken = null, message:IMessage = null) Create a new InvokeEvent. | InvokeEvent
Inherited | clone():Event Clones the MessageEvent. | MessageEvent
Inherited | createEvent(type:String, msg:IMessage):MessageEvent [static] Utility method to create a new MessageEvent that doesn't bubble and is not cancelable. | MessageEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string representation of the InvokeEvent. | InvokeEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | INVOKE : String = "invoke" [static] The INVOKE event type. | InvokeEvent
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | RESULT : String = "result" [static] The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination. | MessageEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Constructor detail
InvokeEvent () constructor
public function InvokeEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = false, token:AsyncToken = null, message:IMessage = null)

Create a new InvokeEvent.

Parameters
type:String — The event type; indicates the action that triggered the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = false) — Specifies whether the behavior associated with the event can be prevented.
token:AsyncToken (default = null) — Token that represents the call to the method. Used in the asynchronous completion token pattern.
message:IMessage (default = null) — Source Message of the request.
Method detail
toString () method
public override function toString():String

Returns a string representation of the InvokeEvent.

Returns
String — String representation of the InvokeEvent.
Constant detail
INVOKE constant
public static const INVOKE:String = "invoke"

The INVOKE event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The request Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.rpc.events.ResultEvent (Flex™ 2 Language Reference)

Class ResultEvent | Properties | Methods | Constants
Package | mx.rpc.events
Class | public class ResultEvent
Inheritance | ResultEvent Inheritance AbstractEvent Inheritance MessageEvent Inheritance Event Inheritance Object

The event that indicates an RPC operation has successfully returned a result.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | message : IMessage The Message associated with this event. | MessageEvent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | result : Object [read-only] Result that the RPC call returns. | ResultEvent
Inherited | target : Object The event target. | Event
Inherited | token : AsyncToken The token that represents the call to the method. | AbstractEvent
Inherited | type : String The type of event. | Event
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ResultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, result:Object = null, token:AsyncToken = null, message:IMessage = null) Create a new ResultEvent. | ResultEvent
Inherited | clone():Event Clones the MessageEvent. | MessageEvent
Inherited | createEvent(type:String, msg:IMessage):MessageEvent [static] Utility method to create a new MessageEvent that doesn't bubble and is not cancelable. | MessageEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String Returns a string representation of the ResultEvent. | ResultEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
Inherited | MESSAGE : String = "message" [static] The MESSAGE event type; dispatched upon receipt of a message. | MessageEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
 | RESULT : String = "result" [static] The RESULT event type. | ResultEvent
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
result property
result:Object [read-only]

Result that the RPC call returns.

Implementation
    public function get result():Object
Constructor detail
ResultEvent () constructor
public function ResultEvent(type:String, bubbles:Boolean = false, cancelable:Boolean = true, result:Object = null, token:AsyncToken = null, message:IMessage = null)

Create a new ResultEvent.

Parameters
type:String — The event type; indicates the action that triggered the event.
bubbles:Boolean (default = false) — Specifies whether the event can bubble up the display list hierarchy.
cancelable:Boolean (default = true) — Specifies whether the behavior associated with the event can be prevented.
result:Object (default = null) — Object that holds the actual result of the call.
token:AsyncToken (default = null) — Token that represents the call to the method. Used in the asynchronous completion token pattern.
message:IMessage (default = null) — Source Message of the result.
Method detail
toString () method
public override function toString():String

Returns a string representation of the ResultEvent.

Returns
String — String representation of the ResultEvent.
Constant detail
RESULT constant
public static const RESULT:String = "result"

The RESULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, preventDefault() from the associated token's responder.result method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result | Result that the RPC call returns.
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.


mx.rpc.http Summary (Flex™ 2 Language Reference)

Package mx.rpc.http | Classes

The mx.rpc.http package contains the HTTP classes.

Classes
Class | Description
HTTPService | When you call the HTTPService object's send() method, it makes an HTTP GET or POST request to the specified URL, and an HTTP response is returned.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.http.HTTPService (Flex™ 2 Language Reference)

Class HTTPService | Properties | Methods | Events | Constants
Package | mx.rpc.http
Class | public class HTTPService
Inheritance | HTTPService Inheritance AbstractInvoker Inheritance EventDispatcher Inheritance Object
Subclasses | HTTPService

When you call the HTTPService object's send() method, it makes an HTTP GET or POST request to the specified URL, and an HTTP response is returned. Optionally, you can pass parameters to the specified URL.

Note: Due to a software limitation, HTTPService does not generate user-friendly error messages when using GET.

See also

mx.rpc.http.mxml.HTTPService
Using RPC Components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | channelSet : ChannelSet Provides access to the ChannelSet used by the service. | HTTPService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | contentType : String = "application/x-www-form-urlencoded" Type of content for service requests. | HTTPService
 | destination : String An HTTPService destination name in the services-config.xml file. | HTTPService
 | headers : Object Custom HTTP headers to be sent to the third party endpoint. | HTTPService
Inherited | lastResult : Object The result of the last invocation. | AbstractInvoker
Inherited | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | AbstractInvoker
 | method : String = "GET" HTTP method for sending the request. | HTTPService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | request : Object Object of name-value pairs used as parameters to the URL. | HTTPService
 | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | HTTPService
 | resultFormat : String Value that indicates how you want to deserialize the result returned by the HTTP call. | HTTPService
 | rootURL : String The URL that the HTTPService object should use when computing relative URLs. | HTTPService
 | url : String Location of the service. | HTTPService
 | useProxy : Boolean Specifies whether to use the Flex proxy service. | HTTPService
 | xmlDecode : Function ActionScript function used to decode a service result from XML. | HTTPService
 | xmlEncode : Function ActionScript function used to encode a service request as XML. | HTTPService
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HTTPService(rootURL:String = null)
Creates a new HTTPService.
HTTPService
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
cancel():void
Cancels the last service invocation.
AbstractInvoker
Inherited
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
disconnect():void
Disconnects the service's network connection.
HTTPService
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
logout():void
Logs the user out of the destination.
HTTPService
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(parameters:Object = null):AsyncToken
Executes an HTTPService request.
HTTPService
setCredentials(username:String, password:String):void
Sets the credentials for the destination accessed by the service.
HTTPService
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setRemoteCredentials(remoteUsername:String, remotePassword:String):void
The username and password to authenticate a user when accessing the HTTP URL.
HTTPService
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | fault | Dispatched when an HTTPService call fails. | HTTPService
 | invoke | The invoke event is fired when an HTTPService call is invoked so long as an Error is not thrown before the Channel attempts to send the message. | HTTPService
 | result | Dispatched when an HTTPService call returns successfully. | HTTPService
Public Constants
Constant |  | Defined by
 | CONTENT_TYPE_FORM : String = "application/x-www-form-urlencoded" [static] Indicates that the data being sent by the HTTP service is encoded as application/x-www-form-urlencoded. | HTTPService
 | CONTENT_TYPE_XML : String = "application/xml" [static] Indicates that the data being sent by the HTTP service is encoded as application/xml. | HTTPService
 | DEFAULT_DESTINATION_HTTP : String = "DefaultHTTP" [static] Indicates that the HTTPService object uses the DefaultHTTP destination. | HTTPService
 | DEFAULT_DESTINATION_HTTPS : String = "DefaultHTTPS" [static] Indicates that the HTTPService object uses the DefaultHTTPS destination. | HTTPService
 | ERROR_DECODING : String = "Client.CouldNotDecode" [static] Indicates that an XML formatted result could not be parsed into an XML instance or decoded into an Object. | HTTPService
 | ERROR_ENCODING : String = "Client.CouldNotEncode" [static] Indicates that an input parameter could not be encoded as XML. | HTTPService
 | ERROR_URL_REQUIRED : String = "Client.URLRequired" [static] Indicates that the useProxy property was set to false but a url was not provided. | HTTPService
 | RESULT_FORMAT_ARRAY : String = "array" [static] The result format "array" is similar to "object" however the value returned is always an Array such that if the result returned from result format "object" is not an Array already the item will be added as the first item to a new Array. | HTTPService
 | RESULT_FORMAT_E4X : String = "e4x" [static] The result format "e4x" specifies that the value returned is an XML instance, which can be accessed using ECMAScript for XML (E4X) expressions. | HTTPService
 | RESULT_FORMAT_FLASHVARS : String = "flashvars" [static] The result format "flashvars" specifies that the value returned is text containing name=value pairs separated by ampersands, which is parsed into an ActionScript object. | HTTPService
 | RESULT_FORMAT_OBJECT : String = "object" [static] The result format "object" specifies that the value returned is XML but is parsed as a tree of ActionScript objects. | HTTPService
 | RESULT_FORMAT_TEXT : String = "text" [static] The result format "text" specifies that the HTTPService result text should be an unprocessed String. | HTTPService
 | RESULT_FORMAT_XML : String = "xml" [static] The result format "xml" specifies that results should be returned as an flash.xml.XMLNode instance pointing to the first child of the parent flash.xml.XMLDocument. | HTTPService
Property detail
channelSet property
channelSet:ChannelSet [read-write]

Provides access to the ChannelSet used by the service. The ChannelSet can be manually constructed and assigned, or it will be dynamically created to use the configured Channels for the destination for this service.

Implementation
    public function get channelSet():ChannelSet
    public function set channelSet(value:ChannelSet):void
contentType property
public var contentType:String = "application/x-www-form-urlencoded"

Type of content for service requests.
The default is application/x-www-form-urlencoded which sends requests like a normal HTTP POST with name-value pairs. application/xml send requests as XML.

destination property
destination:String [read-write]

An HTTPService destination name in the services-config.xml file. When unspecified, Flex uses the DefaultHTTP destination. If you are using the url property, but want requests to reach the proxy over HTTPS, specify DefaultHTTPS.

Implementation
    public function get destination():String
    public function set destination(value:String):void
headers property
public var headers:Object

Custom HTTP headers to be sent to the third party endpoint. If multiple headers need to be sent with the same name the value should be specified as an Array.

method property
public var method:String = "GET"

HTTP method for sending the request. Permitted values are GET, POST, HEAD, OPTIONS, PUT, TRACE and DELETE. Lowercase letters are converted to uppercase letters. The default value is GET.

request property
public var request:Object

Object of name-value pairs used as parameters to the URL. If the contentType property is set to application/xml, it should be an XML document.

requestTimeout property
requestTimeout:int [read-write]

Provides access to the request timeout in seconds for sent messages. A value less than or equal to zero prevents request timeout.

Implementation
    public function get requestTimeout():int
    public function set requestTimeout(value:int):void
resultFormat property
resultFormat:String [read-write]

Value that indicates how you want to deserialize the result returned by the HTTP call. The value for this is based on the following:

  • Whether you are returning XML or name/value pairs.
  • How you want to access the results; you can access results as an object, text, or XML.
The default value is object. The following values are permitted:
  • object The value returned is XML and is parsed as a tree of ActionScript objects. This is the default.
  • array The value returned is XML and is parsed as a tree of ActionScript objects however if the top level object is not an Array, a new Array is created and the result set as the first item. If makeObjectsBindable is true then the Array will be wrapped in an ArrayCollection.
  • xml The value returned is XML and is returned as literal XML in an ActionScript XMLnode object.
  • flashvars The value returned is text containing name=value pairs separated by ampersands, which is parsed into an ActionScript object.
  • text The value returned is text, and is left raw.
  • e4x The value returned is XML and is returned as literal XML in an ActionScript XML object, which can be accessed using ECMAScript for XML (E4X) expressions.

Implementation
    public function get resultFormat():String
    public function set resultFormat(value:String):void
rootURL property
rootURL:String [read-write]

The URL that the HTTPService object should use when computing relative URLs. This property is only used when going through the proxy. When the useProxy property is set to false, the relative URL is computed automatically based on the location of the SWF running this application. If not set explicitly rootURL is automatically set to the URL of mx.messaging.config.LoaderConfig.url.

Implementation
    public function get rootURL():String
    public function set rootURL(value:String):void
url property
url:String [read-write]

Location of the service. If you specify the url and a non-default destination, your destination in the services-config.xml file must allow the specified URL.

Implementation
    public function get url():String
    public function set url(value:String):void
useProxy property
useProxy:Boolean [read-write]

Specifies whether to use the Flex proxy service. The default value is false. If you do not specify true to proxy requests though the Flex server, you must ensure that Flash Player can reach the target URL. You also cannot use destinations defined in the services-config.xml file if the useProxy property is set to false.

The default value is false.

Implementation
    public function get useProxy():Boolean
    public function set useProxy(value:Boolean):void
xmlDecode property
public var xmlDecode:Function

ActionScript function used to decode a service result from XML. When the resultFormat is an object and the xmlDecode property is set, Flex uses the XML that the HTTPService returns to create an Object. If it is not defined the default XMLDecoder is used to do the work.

The function referenced by the xmlDecode property must take a flash.xml.XMLNode object as a parameter and should return an Object. It can return any type of object, but it must return something. Returning null or undefined causes a fault.

The following example shows an <mx:HTTPService> tag that specifies an xmlDecode function:
   <mx:HTTPService id="hs" xmlDecode="xmlDecoder" url="myURL" resultFormat="object" contentType="application/xml">
        <mx:request><source/>
            <obj>{RequestObject}</obj>
        </mx:request>
   </mx:HTTPService>
The following example shows an xmlDecoder function:
function xmlDecoder (myXML)
{
 // Simplified decoding logic.
 var myObj = {};
 myObj.name = myXML.firstChild.nodeValue;
 myObj.honorific = myXML.firstChild.attributes.honorific;
 return myObj;
}
xmlEncode property
public var xmlEncode:Function

ActionScript function used to encode a service request as XML. When the contentType of a request is application/xml and the request object passed in is an Object, Flex attempts to use the function specified in the xmlEncode property to turn it into a flash.xml.XMLNode object If the xmlEncode property is not set, Flex uses the default XMLEncoder to turn the object graph into a flash.xml.XMLNode object.

The xmlEncode property takes an Object and should return a flash.xml.XMLNode object. In this case, the XMLNode object can be a flash.xml.XML object, which is a subclass of XMLNode, or the first child of the flash.xml.XML object, which is what you get from an <mx:XML> tag. Returning the wrong type of object causes a fault. The following example shows an <mx:HTTPService> tag that specifies an xmlEncode function:

  <mx:HTTPService id="hs" xmlEncode="xmlEncoder" url="myURL" resultFormat="object" contentType="application/xml">
        <mx:request><source/>
            <obj>{RequestObject}</obj>
        </mx:request>
   </mx:HTTPService>
The following example shows an xmlEncoder function:
function xmlEncoder (myObj)
{
  return new XML("MyObj.test
  MyObj.anotherTest");
}
Constructor detail
HTTPService () constructor
public function HTTPService(rootURL:String = null)

Creates a new HTTPService. If you expect the service to send using relative URLs you may wish to specify the rootURL that will be the basis for determining the full URL (one example would be Application.application.url).

Parameters
rootURL:String (default = null)
Method detail
disconnect () method
public function disconnect():void

Disconnects the service's network connection. This method does not wait for outstanding network operations to complete.

logout () method
public function logout():void

Logs the user out of the destination. Logging out of a destination applies to everything connected using the same channel as specified in the server configuration. For example, if you're connected over the my-rtmp channel and you log out using one of your RPC components, anything that was connected over my-rtmp is logged out.

send () method
public function send(parameters:Object = null):AsyncToken

Executes an HTTPService request. The parameters are optional, but if specified should be an Object containing name-value pairs or an XML object depending on the contentType.

Parameters
parameters:Object (default = null)

Returns
AsyncToken — An object representing the asynchronous completion token. It is the same object available in the result or fault event's call property.
setCredentials () method
public function setCredentials(username:String, password:String):void

Sets the credentials for the destination accessed by the service. The credentials are applied to all services connected over the same ChannelSet. Note that services that use a proxy to a remote destination will need to call the setRemoteCredentials() method instead.

Parameters
username:String — the username for the destination
password:String — the password for the destination
setRemoteCredentials () method
public function setRemoteCredentials(remoteUsername:String, remotePassword:String):void

The username and password to authenticate a user when accessing the HTTP URL. These are passed as part of the HTTP Authorization header from the proxy to the endpoint. If the useProxy property is set to is false, this property is ignored.

Parameters
remoteUsername:String — the username to pass to the remote endpoint
remotePassword:String — the password to pass to the remote endpoint
Event detail
fault event
Event object type: mx.rpc.events.FaultEvent
FaultEvent.type property = mx.rpc.events.FaultEvent.FAULT

Dispatched when an HTTPService call fails.

The FAULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, calling preventDefault() from the associated token's responder.fault method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
fault | The Fault object that contains the details of what caused this event.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
token | The token that represents the call to the method. Used in the asynchronous completion token pattern.
invoke event
Event object type: mx.rpc.events.InvokeEvent
InvokeEvent.type property = mx.rpc.events.InvokeEvent.INVOKE

The invoke event is fired when an HTTPService call is invoked so long as an Error is not thrown before the Channel attempts to send the message.

The INVOKE event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.
cancelable | true
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The request Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result event
Event object type: mx.rpc.events.ResultEvent
ResultEvent.type property = mx.rpc.events.ResultEvent.RESULT

Dispatched when an HTTPService call returns successfully.

The RESULT event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | true, preventDefault() from the associated token's responder.result method will prevent the service or operation from dispatching this event
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
message | The Message associated with this event.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
result | Result that the RPC call returns.
token | The token that represents the indiviudal call to the method. Used in the asynchronous completion token pattern.
Constant detail
CONTENT_TYPE_FORM constant
public static const CONTENT_TYPE_FORM:String = "application/x-www-form-urlencoded"

Indicates that the data being sent by the HTTP service is encoded as application/x-www-form-urlencoded.

CONTENT_TYPE_XML constant
public static const CONTENT_TYPE_XML:String = "application/xml"

Indicates that the data being sent by the HTTP service is encoded as application/xml.

DEFAULT_DESTINATION_HTTP constant
public static const DEFAULT_DESTINATION_HTTP:String = "DefaultHTTP"

Indicates that the HTTPService object uses the DefaultHTTP destination.

DEFAULT_DESTINATION_HTTPS constant
public static const DEFAULT_DESTINATION_HTTPS:String = "DefaultHTTPS"

Indicates that the HTTPService object uses the DefaultHTTPS destination.

ERROR_DECODING constant
public static const ERROR_DECODING:String = "Client.CouldNotDecode"

Indicates that an XML formatted result could not be parsed into an XML instance or decoded into an Object.

ERROR_ENCODING constant
public static const ERROR_ENCODING:String = "Client.CouldNotEncode"

Indicates that an input parameter could not be encoded as XML.

ERROR_URL_REQUIRED constant
public static const ERROR_URL_REQUIRED:String = "Client.URLRequired"

Indicates that the useProxy property was set to false but a url was not provided.

RESULT_FORMAT_ARRAY constant
public static const RESULT_FORMAT_ARRAY:String = "array"

The result format "array" is similar to "object" however the value returned is always an Array such that if the result returned from result format "object" is not an Array already the item will be added as the first item to a new Array.

RESULT_FORMAT_E4X constant
public static const RESULT_FORMAT_E4X:String = "e4x"

The result format "e4x" specifies that the value returned is an XML instance, which can be accessed using ECMAScript for XML (E4X) expressions.

RESULT_FORMAT_FLASHVARS constant
public static const RESULT_FORMAT_FLASHVARS:String = "flashvars"

The result format "flashvars" specifies that the value returned is text containing name=value pairs separated by ampersands, which is parsed into an ActionScript object.

RESULT_FORMAT_OBJECT constant
public static const RESULT_FORMAT_OBJECT:String = "object"

The result format "object" specifies that the value returned is XML but is parsed as a tree of ActionScript objects. This is the default.

RESULT_FORMAT_TEXT constant
public static const RESULT_FORMAT_TEXT:String = "text"

The result format "text" specifies that the HTTPService result text should be an unprocessed String.

RESULT_FORMAT_XML constant
public static const RESULT_FORMAT_XML:String = "xml"

The result format "xml" specifies that results should be returned as an flash.xml.XMLNode instance pointing to the first child of the parent flash.xml.XMLDocument.


mx.rpc.http.mxml Summary (Flex™ 2 Language Reference)

Package mx.rpc.http.mxml | Classes

The mx.rpc.http.mxml package contains the HTTP MXML class.

Classes
Class | Description
HTTPService | You use the <mx:HTTPService> tag to represent an HTTPService object in an MXML file.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.http.mxml.HTTPService (Flex™ 2 Language Reference)

Class HTTPService | Properties | Methods | Events | Constants | Examples
Package | mx.rpc.http.mxml
Class | public class HTTPService
Inheritance | HTTPService Inheritance HTTPService Inheritance AbstractInvoker Inheritance EventDispatcher Inheritance Object
Implements | IMXMLObject, IMXMLSupport

You use the <mx:HTTPService> tag to represent an HTTPService object in an MXML file. When you call the HTTPService object's send() method, it makes an HTTP GET or POST request to the specified URL, and an HTTP response is returned. Optionally, you can pass parameters to the specified URL.

Note: Due to a software limitation, HTTPService does not generate user-friendly error messages when using GET.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:HTTPService> tag accepts the following tag attributes:

<mx:HTTPService
Properties
concurrency="multiple|single|last"
contentType="application/x-www-form-urlencoded|application/xml"
destination="DefaultHTTP"
id="No default."
method="GET|POST|HEAD|OPTIONS|PUT|TRACE|DELETE"
resultFormat="object|array|xml|e4x|flashvars|text"
showBusyCursor="false|true"
makeObjectsBindable="false|true"
url="No default."
useProxy="false|true"
xmlEncode="No default."
xmlDecode="No default."
Events
fault="No default."
result="No default."
/>
The <mx:HTTPService> tag can have a single <mx:request> tag under which the parameters can be specified.

View the examples.

See also

mx.rpc.http.HTTPService
mx.validators.Validator
mx.managers.CursorManager
Using RPC Components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the service. | HTTPService
 | concurrency : String Value that indicates how to handle multiple calls to the same service. | HTTPService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentType : String = "application/x-www-form-urlencoded" Type of content for service requests. | HTTPService
Inherited | destination : String An HTTPService destination name in the services-config.xml file. | HTTPService
Inherited | headers : Object Custom HTTP headers to be sent to the third party endpoint. | HTTPService
Inherited | lastResult : Object The result of the last invocation. | AbstractInvoker
Inherited | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | AbstractInvoker
Inherited | method : String = "GET" HTTP method for sending the request. | HTTPService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | request : Object Object of name-value pairs used as parameters to the URL. | HTTPService
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | HTTPService
Inherited | resultFormat : String Value that indicates how you want to deserialize the result returned by the HTTP call. | HTTPService
Inherited | rootURL : String The URL that the HTTPService object should use when computing relative URLs. | HTTPService
 | showBusyCursor : Boolean If true, a busy cursor is displayed while a service is executing. | HTTPService
Inherited | url : String Location of the service. | HTTPService
Inherited | useProxy : Boolean Specifies whether to use the Flex proxy service. | HTTPService
Inherited | xmlDecode : Function ActionScript function used to decode a service result from XML. | HTTPService
Inherited | xmlEncode : Function ActionScript function used to encode a service request as XML. | HTTPService
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HTTPService()
Creates a new HTTPService.
HTTPService
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
cancel():void
Cancels the most recent HTTPService request.
HTTPService
Inherited
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
Inherited
disconnect():void
Disconnects the service's network connection.
HTTPService
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
initialized(document:Object, id:String):void
If you create this class in ActionScript and want it to function with validation, you must call this method and pass in the MXML document and the HTTPService's id.
HTTPService
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
logout():void
Logs the user out of the destination.
HTTPService
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(parameters:Object = null):AsyncToken
Executes an HTTPService request.
HTTPService
Inherited
setCredentials(username:String, password:String):void
Sets the credentials for the destination accessed by the service.
HTTPService
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setRemoteCredentials(remoteUsername:String, remotePassword:String):void
The username and password to authenticate a user when accessing the HTTP URL.
HTTPService
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | Dispatched when an HTTPService call fails. | HTTPService
Inherited | invoke | The invoke event is fired when an HTTPService call is invoked so long as an Error is not thrown before the Channel attempts to send the message. | HTTPService
Inherited | result | Dispatched when an HTTPService call returns successfully. | HTTPService
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | CONTENT_TYPE_FORM : String = "application/x-www-form-urlencoded" [static] Indicates that the data being sent by the HTTP service is encoded as application/x-www-form-urlencoded. | HTTPService
Inherited | CONTENT_TYPE_XML : String = "application/xml" [static] Indicates that the data being sent by the HTTP service is encoded as application/xml. | HTTPService
Inherited | DEFAULT_DESTINATION_HTTP : String = "DefaultHTTP" [static] Indicates that the HTTPService object uses the DefaultHTTP destination. | HTTPService
Inherited | DEFAULT_DESTINATION_HTTPS : String = "DefaultHTTPS" [static] Indicates that the HTTPService object uses the DefaultHTTPS destination. | HTTPService
Inherited | ERROR_DECODING : String = "Client.CouldNotDecode" [static] Indicates that an XML formatted result could not be parsed into an XML instance or decoded into an Object. | HTTPService
Inherited | ERROR_ENCODING : String = "Client.CouldNotEncode" [static] Indicates that an input parameter could not be encoded as XML. | HTTPService
Inherited | ERROR_URL_REQUIRED : String = "Client.URLRequired" [static] Indicates that the useProxy property was set to false but a url was not provided. | HTTPService
Inherited | RESULT_FORMAT_ARRAY : String = "array" [static] The result format "array" is similar to "object" however the value returned is always an Array such that if the result returned from result format "object" is not an Array already the item will be added as the first item to a new Array. | HTTPService
Inherited | RESULT_FORMAT_E4X : String = "e4x" [static] The result format "e4x" specifies that the value returned is an XML instance, which can be accessed using ECMAScript for XML (E4X) expressions. | HTTPService
Inherited | RESULT_FORMAT_FLASHVARS : String = "flashvars" [static] The result format "flashvars" specifies that the value returned is text containing name=value pairs separated by ampersands, which is parsed into an ActionScript object. | HTTPService
Inherited | RESULT_FORMAT_OBJECT : String = "object" [static] The result format "object" specifies that the value returned is XML but is parsed as a tree of ActionScript objects. | HTTPService
Inherited | RESULT_FORMAT_TEXT : String = "text" [static] The result format "text" specifies that the HTTPService result text should be an unprocessed String. | HTTPService
Inherited | RESULT_FORMAT_XML : String = "xml" [static] The result format "xml" specifies that results should be returned as an flash.xml.XMLNode instance pointing to the first child of the parent flash.xml.XMLDocument. | HTTPService
Property detail
concurrency property
public var concurrency:String

Value that indicates how to handle multiple calls to the same service. The default value is multiple. The following values are permitted:

  • multiple Existing requests are not cancelled, and the developer is responsible for ensuring the consistency of returned data by carefully managing the event stream. This is the default value.
  • single Only a single request at a time is allowed on the operation; multiple requests generate a fault.
  • last Making a request cancels any existing request.

showBusyCursor property
showBusyCursor:Boolean [read-write]

If true, a busy cursor is displayed while a service is executing. The default value is false.

Implementation
    public function get showBusyCursor():Boolean
    public function set showBusyCursor(value:Boolean):void
Constructor detail
HTTPService () constructor
public function HTTPService()

Creates a new HTTPService. This constructor is usually called by the generated code of an MXML document. You usually use the mx.rpc.http.HTTPService class to create an HTTPService in ActionScript.

Method detail
cancel () method
public override function cancel():void

Cancels the most recent HTTPService request.

initialized () method
public function initialized(document:Object, id:String):void

If you create this class in ActionScript and want it to function with validation, you must call this method and pass in the MXML document and the HTTPService's id.

Parameters
document:Object
id:String
send () method
public override function send(parameters:Object = null):AsyncToken

Executes an HTTPService request. The parameters are optional, but if specified should be an Object containing name-value pairs or an XML object depending on the contentType.

Parameters
parameters:Object (default = null)

Returns
AsyncToken — an AsyncToken. It will be the same object available in the result or fault event's token property.
Examples
HTTPServiceExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the HTTPService tag. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
    creationComplete="feedRequest.send();">

    <!-- The url property specifies the location of the requested file,
    in this case the RSS 2.0 feed of Matt Chotin's blog.
    As of this writing, the URL was still valid, but you should
    check to make sure it hasn't changed.
    You should use the latest RSS 2.0 URL listed on the right side of
    the blog at http://www.adobe.com/go/mchotinblog. -->

    <mx:HTTPService
        id="feedRequest"
        url="http://weblogs.macromedia.com/mchotin/index.xml"
        useProxy="false" />

    <mx:Panel title="HTTPService Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:DataGrid id="dgPosts" height="50%" width="75%"
            dataProvider="{feedRequest.lastResult.rss.channel.item}">
            <mx:columns>
                <mx:DataGridColumn headerText="Posts" dataField="title"/>
                <mx:DataGridColumn headerText="Date" dataField="pubDate"/>
            </mx:columns>
        </mx:DataGrid>

        <mx:TextArea height="50%" width="75%" htmlText="{dgPosts.selectedItem.description}"/>

    </mx:Panel>
</mx:Application>


mx.rpc.mxml Summary (Flex™ 2 Language Reference)

Package mx.rpc.mxml | Interfaces

The mx.rpc.mxml package contains the RPC MXML interface.

Interfaces
Interface | Description
IMXMLSupport | Implementing this interface means that an RPC service can be used in an MXML document via tags since it supports the interfaces specified during Flex 1.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.mxml.IMXMLSupport (Flex™ 2 Language Reference)

Interface IMXMLSupport | Properties
Package | mx.rpc.mxml
Interface | public interface IMXMLSupport
Implementors | HTTPService, Operation, Operation, RemoteObject, WebService

Implementing this interface means that an RPC service can be used in an MXML document via tags since it supports the interfaces specified during Flex 1.

Public Properties
Property |  | Defined by
 | concurrency : String The concurrency setting of the RPC operation or HTTPService. | IMXMLSupport
 | showBusyCursor : Boolean Indicates whether the RPC operation or HTTPService should show the busy cursor while it is executing. | IMXMLSupport
Property detail
concurrency property
public var concurrency:String

The concurrency setting of the RPC operation or HTTPService. One of "multiple" "last" or "single."

showBusyCursor property
showBusyCursor:Boolean [read-write]

Indicates whether the RPC operation or HTTPService should show the busy cursor while it is executing.

Implementation
    public function get showBusyCursor():Boolean
    public function set showBusyCursor(value:Boolean):void


mx.rpc.remoting Summary (Flex™ 2 Language Reference)

Package mx.rpc.remoting | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.rpc.remoting package contains the remote object classes.

Classes
Class | Description
Operation | An Operation used specifically by RemoteObjects.
RemoteObject | The RemoteObject class gives you access to classes on a remote application server.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.remoting.Operation (Flex™ 2 Language Reference)

Class Operation | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.rpc.remoting
Class | public class Operation
Inheritance | Operation Inheritance AbstractOperation Inheritance AbstractInvoker Inheritance EventDispatcher Inheritance Object
Subclasses | Operation

An Operation used specifically by RemoteObjects. An Operation is an individual method on a service. An Operation can be called either by invoking the function of the same name on the service or by accessing the Operation as a property on the service and calling the send() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | argumentNames : Array An ordered list of the names of the arguments to pass to a method invocation. | Operation
Inherited | arguments : Object The arguments to pass to the Operation when it is invoked. | AbstractOperation
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | lastResult : Object The result of the last invocation. | AbstractInvoker
 | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | Operation
Inherited | name : String The name of this Operation. | AbstractOperation
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | service : AbstractService Provides convenient access to the service on which the Operation is being invoked. | AbstractOperation
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Operation(remoteObject:AbstractService = null, name:String = null)
Creates a new Operation.
Operation
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
cancel():void
Cancels the last service invocation.
AbstractInvoker
Inherited
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(... args):AsyncToken
Operation
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | Dispatched when an Operation call fails. | AbstractOperation
Inherited | result | Dispatched when an Operation invocation successfully returns. | AbstractOperation
Property detail
argumentNames property
public var argumentNames:Array

An ordered list of the names of the arguments to pass to a method invocation. Since the arguments object is a hashmap with no guaranteed ordering, this array helps put everything together correctly. It will be set automatically by the MXML compiler, if necessary, when the Operation is used in tag form.

makeObjectsBindable property
makeObjectsBindable:Boolean [read-write]

When this value is true, anonymous objects returned are forced to bindable objects.

Implementation
    public function get makeObjectsBindable():Boolean
    public function set makeObjectsBindable(value:Boolean):void
Constructor detail
Operation () constructor
public function Operation(remoteObject:AbstractService = null, name:String = null)

Creates a new Operation. This is usually done directly automatically by the RemoteObject when an unknown operation has been accessed. It is not recommended that a developer use this constructor directly.

Parameters
remoteObject:AbstractService (default = null)
name:String (default = null)
Method detail
send () method
public override function send(... args):AsyncToken Parameters
... args

Returns
AsyncToken


mx.rpc.remoting.RemoteObject (Flex™ 2 Language Reference)

Class RemoteObject | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.rpc.remoting
Class | public dynamic class RemoteObject
Inheritance | RemoteObject Inheritance AbstractService Inheritance Proxy Inheritance Object
Subclasses | RemoteObject

The RemoteObject class gives you access to classes on a remote application server.

See also

Using RPC Components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the service. | AbstractService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | destination : String The destination of the service. | AbstractService
 | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | RemoteObject
Inherited | operations : Object The Operations array is usually only set by the MXML compiler if you create a service using an MXML tag. | AbstractService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | AbstractService
 | source : String Lets you specify a source value on the client; not supported for destinations that use the JavaAdapter. | RemoteObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RemoteObject(destination:String = null) Creates a new RemoteObject. | RemoteObject
Inherited | disconnect():void Disconnects the service's network connection and removes any pending request responders. | AbstractService
Inherited | getOperation(name:String):AbstractOperation Returns an Operation of the given name. | AbstractService
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | logout():void Logs the user out of the destination. | AbstractService
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setCredentials(username:String, password:String):void Set the credentials for the destination accessed by the service. | AbstractService
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setRemoteCredentials(remoteUsername:String, remotePassword:String):void If a remote object is managed by an external service, such a ColdFusion Component (CFC), a username and password can be set for the authentication mechanism of that remote service. | RemoteObject
 | toString():String Represents an instance of RemoteObject as a String, describing important properties such as the destination id and the set of channels assigned. | RemoteObject
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | The fault event is dispatched when a service call fails and isn't handled by the Operation itself. | AbstractService
Inherited | invoke | The invoke event is dispatched when a service Operation is invoked so long as an Error is not thrown before the Channel attempts to send the message. | AbstractService
Inherited | result | The result event is dispatched when a service call successfully returns and isn't handled by the Operation itself. | AbstractService
Property detail
makeObjectsBindable property
makeObjectsBindable:Boolean [read-write]

When this value is true, anonymous objects returned are forced to bindable objects.

Implementation
    public function get makeObjectsBindable():Boolean
    public function set makeObjectsBindable(value:Boolean):void
source property
source:String [read-write]

Lets you specify a source value on the client; not supported for destinations that use the JavaAdapter. This allows you to provide more than one source that can be accessed from a single destination on the server.

Implementation
    public function get source():String
    public function set source(value:String):void
Constructor detail
RemoteObject () constructor
public function RemoteObject(destination:String = null)

Creates a new RemoteObject.

Parameters
destination:String (default = null) — [optional] Destination of the RemoteObject; should match a destination name in the services-config.xml file.
Method detail
setRemoteCredentials () method
public override function setRemoteCredentials(remoteUsername:String, remotePassword:String):void

If a remote object is managed by an external service, such a ColdFusion Component (CFC), a username and password can be set for the authentication mechanism of that remote service.

Parameters
remoteUsername:String — the username to pass to the remote endpoint
remotePassword:String — the password to pass to the remote endpoint
toString () method
public function toString():String

Represents an instance of RemoteObject as a String, describing important properties such as the destination id and the set of channels assigned.

Returns
String


mx.rpc.remoting.mxml Summary (Flex™ 2 Language Reference)

Package mx.rpc.remoting.mxml | Classes
(Adobe® Flex™ Data Services 2 only)

The mx.rpc.remoting.mxml package contains the RPC remote object MXML classes.

Classes
Class | Description
Operation | The Operation used for RemoteObject when created in an MXML document
RemoteObject | The <mx:RemoteObject> tag gives you access to the methods of Java objects using Action Message Format (AMF) encoding.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.remoting.mxml.Operation (Flex™ 2 Language Reference)

Class Operation | Properties | Methods | Events
(Adobe® Flex™ Data Services 2 only)
Package | mx.rpc.remoting.mxml
Class | public class Operation
Inheritance | Operation Inheritance Operation Inheritance AbstractOperation Inheritance AbstractInvoker Inheritance EventDispatcher Inheritance Object
Implements | IMXMLSupport

The Operation used for RemoteObject when created in an MXML document

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | argumentNames : Array An ordered list of the names of the arguments to pass to a method invocation. | Operation
Inherited | arguments : Object The arguments to pass to the Operation when it is invoked. | AbstractOperation
 | concurrency : String The concurrency for this Operation. | Operation
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | lastResult : Object The result of the last invocation. | AbstractInvoker
Inherited | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | Operation
Inherited | name : String The name of this Operation. | AbstractOperation
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | service : AbstractService Provides convenient access to the service on which the Operation is being invoked. | AbstractOperation
 | showBusyCursor : Boolean Whether this operation should show the busy cursor while it is executing. | Operation
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
cancel():void
Operation
Inherited
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
send(... args):AsyncToken
Operation
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | Dispatched when an Operation call fails. | AbstractOperation
Inherited | result | Dispatched when an Operation invocation successfully returns. | AbstractOperation
Property detail
concurrency property
public var concurrency:String

The concurrency for this Operation. If it has not been explicitly set the setting from the RemoteObject will be used.

showBusyCursor property
showBusyCursor:Boolean [read-write]

Whether this operation should show the busy cursor while it is executing. If it has not been explicitly set the setting from the RemoteObject will be used.

Implementation
    public function get showBusyCursor():Boolean
    public function set showBusyCursor(value:Boolean):void
Method detail
cancel () method
public override function cancel():void
send () method
public override function send(... args):AsyncToken Parameters
... args

Returns
AsyncToken


mx.rpc.remoting.mxml.RemoteObject (Flex™ 2 Language Reference)

View comments | RSS feed
Class RemoteObject | Properties | Methods | Events | Examples
(Adobe® Flex™ Data Services 2 only)
Package | mx.rpc.remoting.mxml
Class | public dynamic class RemoteObject
Inheritance | RemoteObject Inheritance RemoteObject Inheritance AbstractService Inheritance Proxy Inheritance Object
Implements | IMXMLObject, IMXMLSupport

The <mx:RemoteObject> tag gives you access to the methods of Java objects using Action Message Format (AMF) encoding.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:RemoteObject> tag accepts the following tag attributes:

 <mx:RemoteObject
  Properties
  concurrency="multiple|single|last"
  destination="No default."
  id="No default."
  endpoint="No default."
  showBusyCursor="false|true"
  source="No default." (currently, Macromedia ColdFusion only)
  makeObjectsBindable="false|true"

  Events
  fault="No default."
  result="No default."
 />

<mx:RemoteObject> can have multiple <mx:method> tags, which have the following tag attributes:

 <mx:method
  Properties
  concurrency="multiple|single|last"
  name="No default, required."
  makeObjectsBindable="false|true"

 Events
  fault="No default."
  result="No default."
 />

It then can have a single <mx:arguments> child tag which is an array of objects that is passed in order.

View the examples.

See also

Using RPC Components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the service. | AbstractService
 | concurrency : String Value that indicates how to handle multiple calls to the same service. | RemoteObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | destination : String The destination of the service. | AbstractService
 | endpoint : String This property allows the developer to quickly specify an endpoint for a RemoteObject destination without referring to a services configuration file at compile time or programmatically creating a ChannelSet. | RemoteObject
Inherited | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | RemoteObject
Inherited | operations : Object The Operations array is usually only set by the MXML compiler if you create a service using an MXML tag. | AbstractService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | AbstractService
 | showBusyCursor : Boolean If true, a busy cursor is displayed while a service is executing. | RemoteObject
Inherited | source : String Lets you specify a source value on the client; not supported for destinations that use the JavaAdapter. | RemoteObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RemoteObject(destination:String = null) Create a new RemoteObject. | RemoteObject
Inherited | disconnect():void Disconnects the service's network connection and removes any pending request responders. | AbstractService
Inherited | getOperation(name:String):AbstractOperation Returns an Operation of the given name. | AbstractService
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialized(document:Object, id:String):void Called automatically by the MXML compiler if the RemoteObject is set up using a tag. | RemoteObject
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | logout():void Logs the user out of the destination. | AbstractService
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setCredentials(username:String, password:String):void Set the credentials for the destination accessed by the service. | AbstractService
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | setRemoteCredentials(remoteUsername:String, remotePassword:String):void If a remote object is managed by an external service, such a ColdFusion Component (CFC), a username and password can be set for the authentication mechanism of that remote service. | RemoteObject
Inherited | toString():String Represents an instance of RemoteObject as a String, describing important properties such as the destination id and the set of channels assigned. | RemoteObject
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | The fault event is dispatched when a service call fails and isn't handled by the Operation itself. | AbstractService
Inherited | invoke | The invoke event is dispatched when a service Operation is invoked so long as an Error is not thrown before the Channel attempts to send the message. | AbstractService
Inherited | result | The result event is dispatched when a service call successfully returns and isn't handled by the Operation itself. | AbstractService
Property detail
concurrency property
public var concurrency:String

Value that indicates how to handle multiple calls to the same service. The default value is multiple. The following values are permitted:

  • multiple Existing requests are not cancelled, and the developer is responsible for ensuring the consistency of returned data by carefully managing the event stream. This is the default.
  • single Only a single request at a time is allowed on the operation; multiple requests generate a fault.
  • last Making a request cancels any existing request.

endpoint property
endpoint:String [read-write]

This property allows the developer to quickly specify an endpoint for a RemoteObject destination without referring to a services configuration file at compile time or programmatically creating a ChannelSet. It also overrides an existing ChannelSet if one has been set for the RemoteObject service.

If the endpoint url starts with "https" a SecureAMFChannel will be used, otherwise an AMFChannel will be used. Two special tokens, {server.name} and {server.port}, can be used in the endpoint url to specify that the channel should use the server name and port that was used to load the SWF.

Implementation
    public function get endpoint():String
    public function set endpoint(value:String):void
showBusyCursor property
showBusyCursor:Boolean [read-write]

If true, a busy cursor is displayed while a service is executing. The default value is false.

Implementation
    public function get showBusyCursor():Boolean
    public function set showBusyCursor(value:Boolean):void
Constructor detail
RemoteObject () constructor
public function RemoteObject(destination:String = null)

Create a new RemoteObject.

Parameters
destination:String (default = null) — the destination of the RemoteObject, should match a destination name in the services-config.xml file.
Method detail
initialized () method
public function initialized(document:Object, id:String):void

Called automatically by the MXML compiler if the RemoteObject is set up using a tag. If you create the RemoteObject through ActionScript you may want to call this method yourself as it is useful for validating any arguments.

Parameters
document:Object — the MXML document on which this RemoteObject lives
id:String — the id of this RemoteObject within the document
Examples
RemoteObjectExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the RemoteObject tag. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

<!--  Make sure the Flex Data Services proxy-config.xml file contains the following definition.
      The Java class mypackage.stockquote.MyTicker.class must be available on the
      web application's classpath.

    <destination id="MyRemoteObjectDest">
        <properties>
            <source>mypackage.stockquote.MyTicker</source>
            <scope>application</scope>
        </properties>
    </destination>
-->

    <mx:Script>
        <![CDATA[
            import mx.controls.Alert;
        ]]>
    </mx:Script>

    <mx:RemoteObject id="RO" destination="MyRemoteObjectDest"
        fault="Alert.show(event.fault.faultstring), 'Error'">

        <mx:method name="GetQuote">
            <mx:arguments>
                <symbol>{stockSymbol.text}</symbol>
            </mx:arguments>
        </mx:method>
    </mx:RemoteObject>

    <mx:Panel title="RemoteObject Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%"  color="blue"
            text="Enter a stock symbol to obtain a quote."/>

        <mx:TextInput id="stockSymbol" text="ADBE"/>
        <mx:Button label="Get Quote" click="RO.GetQuote.send()"/>

        <mx:Text htmlText="Company: {RO.GetQuote.lastResult.GetQuoteResult.StockQuote.Company}"/>
        <mx:Text htmlText="Current price: ${RO.GetQuote.lastResult.GetQuoteResult.StockQuote.Price}"/>

    </mx:Panel>
</mx:Application>

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

mpeterson said on Jun 30, 2006 at 11:00 AM :
In the MXML example at the bottom of this page, "faultstring" should be "faultString".
- Mike Peterson
Adobe Flex documentation team

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/mx/rpc/remoting/mxml/RemoteObject.html


mx.rpc.soap Summary (Flex™ 2 Language Reference)

Package mx.rpc.soap | Classes

The mx.rpc.soap package contains the web service classes.

Classes
Class | Description
LoadEvent | This event is dispatched when the WSDL document has loaded sucessfully.
Operation | An Operation used specifically by WebServices.
SOAPHeader | You use a SOAPHeader to specify the headers that need to be added to a SOAP envelope of a WebService Operation request.
WebService | The WebService class provides access to SOAP-based web services on remote servers.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.soap.LoadEvent (Flex™ 2 Language Reference)

Class LoadEvent | Properties | Methods | Constants
Package | mx.rpc.soap
Class | public class LoadEvent
Inheritance | LoadEvent Inheritance Event Inheritance Object

This event is dispatched when the WSDL document has loaded sucessfully.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | bubbles : Boolean Indicates whether an event is a bubbling event. | Event
Inherited | cancelable : Boolean Indicates whether the behavior associated with the event can be prevented. | Event
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | currentTarget : Object The object that is actively processing the Event object with an event listener. | Event
 | document : XMLDocument The raw XML for the WSDL document. | LoadEvent
Inherited | eventPhase : uint The current phase in the event flow. | Event
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | target : Object The event target. | Event
Inherited | type : String The type of event. | Event
 | wsdl : WSDL The parsed WSDL document. | LoadEvent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | LoadEvent(wsdl:WSDL, document:XMLDocument) Creates a new LoadEvent. | LoadEvent
 | clone():Event | LoadEvent
Inherited | formatToString(className:String, ... arguments):String A utility function for implementing the toString() method in your custom Event class. | Event
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isDefaultPrevented():Boolean Checks whether preventDefault() has been called on the event. | Event
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | preventDefault():void Cancels an event's default behavior if that behavior can be canceled. | Event
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | stopImmediatePropagation():void Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow. | Event
Inherited | stopPropagation():void Prevents processing of any event listeners in nodes subsequent to the current node in the event flow. | Event
 | toString():String | LoadEvent
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | ACTIVATE : String = "activate" [static] Defines the value of the type property of an activate event object. | Event
Inherited | ADDED : String = "added" [static] Defines the value of the type property of an added event object. | Event
Inherited | CANCEL : String = "cancel" [static] Defines the value of the type property of a cancel event object. | Event
Inherited | CHANGE : String = "change" [static] Defines the value of the type property of a change event object. | Event
Inherited | CLOSE : String = "close" [static] Defines the value of the type property of a close event object. | Event
Inherited | COMPLETE : String = "complete" [static] Defines the value of the type property of a complete event object. | Event
Inherited | CONNECT : String = "connect" [static] Defines the value of the type property of a connect event object. | Event
Inherited | DEACTIVATE : String = "deactivate" [static] Defines the value of the type property of a deactivate event object. | Event
Inherited | ENTER_FRAME : String = "enterFrame" [static] Defines the value of the type property of an enterFrame event object. | Event
Inherited | ID3 : String = "id3" [static] Defines the value of the type property of an id3 event object. | Event
Inherited | INIT : String = "init" [static] Defines the value of the type property of an init event object. | Event
 | LOAD : String = "load" [static] The LOAD event type. | LoadEvent
Inherited | MOUSE_LEAVE : String = "mouseLeave" [static] Defines the value of the type property of a mouseLeave event object. | Event
Inherited | OPEN : String = "open" [static] Defines the value of the type property of an open event object. | Event
Inherited | REMOVED : String = "removed" [static] Defines the value of the type property of a removed event object. | Event
Inherited | RENDER : String = "render" [static] Defines the value of the type property of a render event object. | Event
Inherited | RESIZE : String = "resize" [static] Defines the value of the type property of a resize event object. | Event
Inherited | SCROLL : String = "scroll" [static] Defines the value of the type property of a scroll event object. | Event
Inherited | SELECT : String = "select" [static] Defines the value of the type property of a select event object. | Event
Inherited | SOUND_COMPLETE : String = "soundComplete" [static] Defines the value of the type property of a soundComplete event object. | Event
Inherited | TAB_CHILDREN_CHANGE : String = "tabChildrenChange" [static] Defines the value of the type property of a tabChildrenChange event object. | Event
Inherited | TAB_ENABLED_CHANGE : String = "tabEnabledChange" [static] Defines the value of the type property of a tabEnabledChange event object. | Event
Inherited | TAB_INDEX_CHANGE : String = "tabIndexChange" [static] Defines the value of the type property of a tabIndexChange event object. | Event
Inherited | UNLOAD : String = "unload" [static] Defines the value of the type property of an unload event object. | Event
Property detail
document property
public var document:XMLDocument

The raw XML for the WSDL document.

wsdl property
public var wsdl:WSDL

The parsed WSDL document.

Constructor detail
LoadEvent () constructor
public function LoadEvent(wsdl:WSDL, document:XMLDocument)

Creates a new LoadEvent.

Parameters
wsdl:WSDL
document:XMLDocument
Method detail
clone () method
public override function clone():Event

Returns
Event
toString () method
public override function toString():String

Returns
String
Constant detail
LOAD constant
public static const LOAD:String = "load"

The LOAD event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.


mx.rpc.soap.Operation (Flex™ 2 Language Reference)

Class Operation | Properties | Methods | Events
Package | mx.rpc.soap
Class | public class Operation
Inheritance | Operation Inheritance AbstractOperation Inheritance AbstractInvoker Inheritance EventDispatcher Inheritance Object
Subclasses | Operation

An Operation used specifically by WebServices. An Operation is an individual method on a service. An Operation can be called either by invoking the function of the same name on the service or by accessing the Operation as a property on the service and calling the send() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | arguments : Object The arguments to pass to the Operation when it is invoked. | AbstractOperation
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | endpointURI : String The location of the WebService for this Operation. | Operation
 | headers : Array [read-only] Accessor to an Array of SOAPHeaders that are to be sent on each invocation of the operation. | Operation
Inherited | lastResult : Object The result of the last invocation. | AbstractInvoker
 | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | Operation
Inherited | name : String The name of this Operation. | AbstractOperation
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | request : Object The request of the Operation is an object structure or an XML structure. | Operation
 | resultFormat : String Determines how the Operation result is decoded. | Operation
 | resultHeaders : Array [read-only] The headers that were returned as part of the last execution of this operation. | Operation
Inherited | service : AbstractService Provides convenient access to the service on which the Operation is being invoked. | AbstractOperation
 | targetNamespace : String | Operation
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Operation(webService:AbstractService = null, name:String = null)
Creates a new Operation.
Operation
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
addHeader(header:SOAPHeader):void
Adds a header that is applied only to this Operation.
Operation
addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String):void
Adds a header that is applied only to this Operation.
Operation
Inherited
cancel():void
Cancels the last service invocation.
AbstractInvoker
clearHeaders():void
Clears the headers for this individual Operation.
Operation
Inherited
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getHeader(qname:QName, headerName:String = null):SOAPHeader
Returns a header if a match is found based on QName localName and URI.
Operation
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
removeHeader(qname:QName, headerName:String = null):void
Removes the header with the given QName from all operations.
Operation
Inherited
send(... args):AsyncToken
Executes the method.
AbstractOperation
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | createFaultEvent(faultCode:String = null, faultString:String = null, faultDetail:String = null):FaultEvent | Operation
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | Dispatched when an Operation call fails. | AbstractOperation
Inherited | result | Dispatched when an Operation invocation successfully returns. | AbstractOperation
Property detail
endpointURI property
endpointURI:String [read-write]

The location of the WebService for this Operation. Normally, the WSDL specifies the location of the services, but you can set this property to override that location for the individual Operation.

Implementation
    public function get endpointURI():String
    public function set endpointURI(value:String):void
headers property
headers:Array [read-only]

Accessor to an Array of SOAPHeaders that are to be sent on each invocation of the operation.

Implementation
    public function get headers():Array
makeObjectsBindable property
makeObjectsBindable:Boolean [read-write]

When this value is true, anonymous objects returned are forced to bindable objects.

Implementation
    public function get makeObjectsBindable():Boolean
    public function set makeObjectsBindable(value:Boolean):void
request property
request:Object [read-write]

The request of the Operation is an object structure or an XML structure. If you specify XML, the XML is sent as is. If you pass an object, it is encoded into a SOAP XML structure.

Implementation
    public function get request():Object
    public function set request(value:Object):void
resultFormat property
resultFormat:String [read-write]

Determines how the Operation result is decoded. A value of object specifies that the XML will be decoded into an object structure as specified in the WSDL document. A value of xml specifies that the XML will be left as XMLNodes. A value of e4x specifies that the XML will be accessible using EcmaScript for XML (E4X) expressions.

Implementation
    public function get resultFormat():String
    public function set resultFormat(value:String):void
resultHeaders property
resultHeaders:Array [read-only]

The headers that were returned as part of the last execution of this operation. They match up with the result property and are the same as the collection of headers that are dispatched individually as HeaderEvents.

This property can be used as the source for data binding.

Implementation
    public function get resultHeaders():Array
targetNamespace property
public var targetNamespace:String
Constructor detail
Operation () constructor
public function Operation(webService:AbstractService = null, name:String = null)

Creates a new Operation. This is usually done directly by the MXML compiler or automatically by the WebService when an unknown operation has been accessed. It is not recommended that a developer use this constructor directly.

Parameters
webService:AbstractService (default = null)
name:String (default = null)
Method detail
addHeader () method
public function addHeader(header:SOAPHeader):void

Adds a header that is applied only to this Operation.

Parameters
header:SOAPHeader — The actual header.
addSimpleHeader () method
public function addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String):void

Adds a header that is applied only to this Operation.

Parameters
qnameLocal:String — the localname for the header QName
qnameNamespace:String — the namespace for header QName
headerName:String — Name of the header.
headerValue:String — Value of the header.
clearHeaders () method
public function clearHeaders():void

Clears the headers for this individual Operation.

createFaultEvent () method
protected function createFaultEvent(faultCode:String = null, faultString:String = null, faultDetail:String = null):FaultEvent Parameters
faultCode:String (default = null)
faultString:String (default = null)
faultDetail:String (default = null)

Returns
FaultEvent
getHeader () method
public function getHeader(qname:QName, headerName:String = null):SOAPHeader

Returns a header if a match is found based on QName localName and URI.

Parameters
qname:QName — QName of the SOAPHeader.
headerName:String (default = null) — Name of a header in the SOAPHeader content (Optional)

Returns
SOAPHeader
removeHeader () method
public function removeHeader(qname:QName, headerName:String = null):void

Removes the header with the given QName from all operations.

Parameters
qname:QName — QName of the SOAPHeader.
headerName:String (default = null) — Name of a header in the SOAPHeader content (Optional)


mx.rpc.soap.SOAPHeader (Flex™ 2 Language Reference)

Class SOAPHeader | Properties | Methods
Package | mx.rpc.soap
Class | public class SOAPHeader
Inheritance | SOAPHeader Inheritance Object

You use a SOAPHeader to specify the headers that need to be added to a SOAP envelope of a WebService Operation request.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | content : Object The content to send for the header value; can be a String or flash.xml.XMLNode. | SOAPHeader
 | mustUnderstand : Boolean Specifies whether the header must be understood by the endpoint. | SOAPHeader
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | qname : QName The qualified name of the SOAP header. | SOAPHeader
 | role : String Specifies the URI for the role that this header is intended in a potential chain of endpoints processing a SOAP request. | SOAPHeader
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SOAPHeader(qname:QName, content:Object) Constructs a new SOAPHeader. | SOAPHeader
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
content property
public var content:Object

The content to send for the header value; can be a String or flash.xml.XMLNode.

mustUnderstand property
public var mustUnderstand:Boolean

Specifies whether the header must be understood by the endpoint. If the header is handled but must be understood the endpoint should return a SOAP fault.

qname property
public var qname:QName

The qualified name of the SOAP header.

role property
public var role:String

Specifies the URI for the role that this header is intended in a potential chain of endpoints processing a SOAP request. If defined, this value is used to specify the actor for the SOAP header.

Constructor detail
SOAPHeader () constructor
public function SOAPHeader(qname:QName, content:Object)

Constructs a new SOAPHeader. The qualified name and content for the SOAP header are required.

Parameters
qname:QName
content:Object


mx.rpc.soap.WebService (Flex™ 2 Language Reference)

Class WebService | Properties | Methods | Events | Constants
Package | mx.rpc.soap
Class | public dynamic class WebService
Inheritance | WebService Inheritance AbstractService Inheritance Proxy Inheritance Object
Subclasses | WebService

The WebService class provides access to SOAP-based web services on remote servers.

See also

Using RPC Components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the service. | AbstractService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | description : String The description of the service for the currently active port. | WebService
 | destination : String The destination of the service. | WebService
 | endpointURI : String The location of the WebService. | WebService
 | headers : Array [read-only] Returns the array of SOAPHeaders registered for the WebService. | WebService
 | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | WebService
Inherited | operations : Object The Operations array is usually only set by the MXML compiler if you create a service using an MXML tag. | AbstractService
 | port : String Specifies the port within the WSDL document that this WebService should use | WebService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | AbstractService
 | rootURL : String The URL that the WebService should use when computing relative URLs. | WebService
 | service : String Specifies the service within the WSDL document that this WebService should use. | WebService
 | useProxy : Boolean Specifies whether to use the Flex proxy service. | WebService
 | wsdl : String The location of the WSDL document for this WebService. | WebService
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | WebService(destination:String = null, rootURL:String = null) Creates a new WebService. | WebService
 | addHeader(header:SOAPHeader):void Adds a header that will be applied to all operations of this web service. | WebService
 | addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String):void Add a header that will be applied to all operations of this WebService. | WebService
 | canLoadWSDL():Boolean Returns a Boolean value that indicates whether the WebService ready to load a WSDL (does it have a valid destination or wsdl specified). | WebService
 | clearHeaders():void Clears the headers that applied to all operations. | WebService
Inherited | disconnect():void Disconnects the service's network connection and removes any pending request responders. | AbstractService
 | getHeader(qname:QName, headerName:String = null):SOAPHeader Returns a header if a match is found based on QName localName and URI. | WebService
Inherited | getOperation(name:String):AbstractOperation Returns an Operation of the given name. | AbstractService
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | loadWSDL(uri:String = null):void Instructs the WebService to download the WSDL document. | WebService
Inherited | logout():void Logs the user out of the destination. | AbstractService
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | removeHeader(qname:QName, headerName:String = null):void Removes the header with the given QName from all operations. | WebService
Inherited | setCredentials(username:String, password:String):void Set the credentials for the destination accessed by the service. | AbstractService
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setRemoteCredentials(remoteUsername:String, remotePassword:String):void The username and password to authenticate a user when accessing the webservice. | WebService
 | toString():String Represents an instance of WebService as a String, describing important properties such as the destination id and the set of channels assigned. | WebService
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | The fault event is dispatched when a service call fails and isn't handled by the Operation itself. | AbstractService
Inherited | invoke | The invoke event is dispatched when a service Operation is invoked so long as an Error is not thrown before the Channel attempts to send the message. | AbstractService
 | load | The LoadEvent.LOAD is dispatched when the WSDL document has loaded successfully. | WebService
Inherited | result | The result event is dispatched when a service call successfully returns and isn't handled by the Operation itself. | AbstractService
Public Constants
Constant |  | Defined by
 | DEFAULT_DESTINATION_HTTP : String = "DefaultHTTP" [static] | WebService
 | DEFAULT_DESTINATION_HTTPS : String = "DefaultHTTPS" [static] | WebService
Property detail
description property
description:String [read-write]

The description of the service for the currently active port.

Implementation
    public function get description():String
    public function set description(value:String):void
destination property
destination:String [read-write]

The destination of the service. This value should match a destination entry in the services-config.xml file.

Implementation
    public function get destination():String
    public function set destination(value:String):void
endpointURI property
endpointURI:String [read-write]

The location of the WebService. Normally, the WSDL document specifies the location of the services, but you can set this property to override that location.

Implementation
    public function get endpointURI():String
    public function set endpointURI(value:String):void
headers property
headers:Array [read-only]

Returns the array of SOAPHeaders registered for the WebService.

Implementation
    public function get headers():Array
makeObjectsBindable property
makeObjectsBindable:Boolean [read-write]

When this value is true, anonymous objects returned are forced to bindable objects.

Implementation
    public function get makeObjectsBindable():Boolean
    public function set makeObjectsBindable(value:Boolean):void
port property
port:String [read-write]

Specifies the port within the WSDL document that this WebService should use

Implementation
    public function get port():String
    public function set port(value:String):void
rootURL property
rootURL:String [read-write]

The URL that the WebService should use when computing relative URLs. This property is only used when going through the proxy. When the useProxy property is set to false the relative URL is computed automatically based on the location of the SWF running this application. If not set explicitly rootURL is automatically set to the URL of mx.messaging.config.LoaderConfig.url.

Implementation
    public function get rootURL():String
    public function set rootURL(value:String):void
service property
service:String [read-write]

Specifies the service within the WSDL document that this WebService should use.

Implementation
    public function get service():String
    public function set service(value:String):void
useProxy property
useProxy:Boolean [read-write]

Specifies whether to use the Flex proxy service. The default value is false. If you do not specify true to proxy requests though the Flex server, you must ensure that Flash Player can reach the target URL. You also cannot use destinations defined in the services-config.xml file if the useProxy property is set to false.

The default value is false.

Implementation
    public function get useProxy():Boolean
    public function set useProxy(value:Boolean):void
wsdl property
wsdl:String [read-write]

The location of the WSDL document for this WebService. If you use a relative URL, make sure that the rootURL has been specified or that you created the WebService in MXML.

Implementation
    public function get wsdl():String
    public function set wsdl(value:String):void
Constructor detail
WebService () constructor
public function WebService(destination:String = null, rootURL:String = null)

Creates a new WebService. The destination, if specified, should match an entry in services-config.xml. If unspecified, the WebService uses the DefaultHTTP destination. The rootURL is required if you intend to use a relative URL find the WSDL document for this WebService.

Parameters
destination:String (default = null)
rootURL:String (default = null)
Method detail
addHeader () method
public function addHeader(header:SOAPHeader):void

Adds a header that will be applied to all operations of this web service.

Parameters
header:SOAPHeader — Actual header.
addSimpleHeader () method
public function addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String):void

Add a header that will be applied to all operations of this WebService.

Parameters
qnameLocal:String — the localname for the header QName
qnameNamespace:String — the namespace for header QName
headerName:String — the name of the header
headerValue:String — the value of the header
canLoadWSDL () method
public function canLoadWSDL():Boolean

Returns a Boolean value that indicates whether the WebService ready to load a WSDL (does it have a valid destination or wsdl specified).

Returns
Boolean
clearHeaders () method
public function clearHeaders():void

Clears the headers that applied to all operations.

getHeader () method
public function getHeader(qname:QName, headerName:String = null):SOAPHeader

Returns a header if a match is found based on QName localName and URI.

Parameters
qname:QName — QName of the SOAPHeader.
headerName:String (default = null) — Name of a header in the SOAPHeader content (Optional)

Returns
SOAPHeader
loadWSDL () method
public function loadWSDL(uri:String = null):void

Instructs the WebService to download the WSDL document. The WebService calls this method automatically WebService when specified in the WebService MXML tag, but it must be called manually if you create the WebService object in ActionScript after you have specified the destination or wsdl property value.

Parameters
uri:String (default = null) — If the wsdl hasn't been specified previously, it may be specified here.
removeHeader () method
public function removeHeader(qname:QName, headerName:String = null):void

Removes the header with the given QName from all operations.

Parameters
qname:QName — QName of the SOAPHeader.
headerName:String (default = null) — Name of a header in the SOAPHeader content (Optional)
setRemoteCredentials () method
public override function setRemoteCredentials(remoteUsername:String, remotePassword:String):void

The username and password to authenticate a user when accessing the webservice. These will be passed as part of the HTTP Authorization header from the proxy to the endpoint. If useProxy is false this property will be ignored.

Parameters
remoteUsername:String — the username to pass to the remote endpoint
remotePassword:String — the password to pass to the remote endpoint
toString () method
public function toString():String

Represents an instance of WebService as a String, describing important properties such as the destination id and the set of channels assigned.

Returns
String
Event detail
load event
Event object type: mx.rpc.soap.LoadEvent
LoadEvent.type property = mx.rpc.soap.LoadEvent.LOAD

The LoadEvent.LOAD is dispatched when the WSDL document has loaded successfully.

The LOAD event type.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Constant detail
DEFAULT_DESTINATION_HTTP constant
public static const DEFAULT_DESTINATION_HTTP:String = "DefaultHTTP"
DEFAULT_DESTINATION_HTTPS constant
public static const DEFAULT_DESTINATION_HTTPS:String = "DefaultHTTPS"


mx.rpc.soap.mxml Summary (Flex™ 2 Language Reference)

Package mx.rpc.soap.mxml | Classes

The mx.rpc.soap.mxml package contains the web service MXML class.

Classes
Class | Description
Operation | An Operation used specifically by WebServices.
WebService | The <mx:WebService> tag gives you access to the operations of SOAP-compliant web services.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.soap.mxml.Operation (Flex™ 2 Language Reference)

Class Operation | Properties | Methods | Events
Package | mx.rpc.soap.mxml
Class | public class Operation
Inheritance | Operation Inheritance Operation Inheritance AbstractOperation Inheritance AbstractInvoker Inheritance EventDispatcher Inheritance Object
Implements | IMXMLSupport

An Operation used specifically by WebServices. An Operation is an individual method on a service. An Operation can be called either by invoking the function of the same name on the service or by accessing the Operation as a property on the service and calling the send() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | arguments : Object The arguments to pass to the Operation when it is invoked. | AbstractOperation
 | concurrency : String The concurrency for this Operation. | Operation
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | endpointURI : String The location of the WebService for this Operation. | Operation
Inherited | headers : Array Accessor to an Array of SOAPHeaders that are to be sent on each invocation of the operation. | Operation
Inherited | lastResult : Object The result of the last invocation. | AbstractInvoker
Inherited | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | Operation
Inherited | name : String The name of this Operation. | AbstractOperation
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | request : Object The request of the Operation is an object structure or an XML structure. | Operation
Inherited | resultFormat : String Determines how the Operation result is decoded. | Operation
Inherited | resultHeaders : Array The headers that were returned as part of the last execution of this operation. | Operation
Inherited | service : AbstractService Provides convenient access to the service on which the Operation is being invoked. | AbstractOperation
 | showBusyCursor : Boolean Whether this operation should show the busy cursor while it is executing. | Operation
Inherited | targetNamespace : String | Operation
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Operation(webService:WebService = null, name:String = null)
Operation
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
addHeader(header:SOAPHeader):void
Adds a header that is applied only to this Operation.
Operation
Inherited
addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String):void
Adds a header that is applied only to this Operation.
Operation
cancel():void
Use superclass description.
Operation
Inherited
clearHeaders():void
Clears the headers for this individual Operation.
Operation
Inherited
clearResult(fireBindingEvent:Boolean = true):void
Sets the result property of the invoker to null.
AbstractInvoker
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getHeader(qname:QName, headerName:String = null):SOAPHeader
Returns a header if a match is found based on QName localName and URI.
Operation
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
removeHeader(qname:QName, headerName:String = null):void
Removes the header with the given QName from all operations.
Operation
send(... args):AsyncToken
Execute the method.
Operation
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | createFaultEvent(faultCode:String = null, faultString:String = null, faultDetail:String = null):FaultEvent | Operation
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | Dispatched when an Operation call fails. | AbstractOperation
Inherited | result | Dispatched when an Operation invocation successfully returns. | AbstractOperation
Property detail
concurrency property
public var concurrency:String

The concurrency for this Operation. If it has not been explicitly set the setting from the WebService will be used.

showBusyCursor property
showBusyCursor:Boolean [read-write]

Whether this operation should show the busy cursor while it is executing. If it has not been explicitly set the setting from the WebService will be used.

Implementation
    public function get showBusyCursor():Boolean
    public function set showBusyCursor(value:Boolean):void
Constructor detail
Operation () constructor
public function Operation(webService:WebService = null, name:String = null)Parameters
webService:WebService (default = null)
name:String (default = null)
Method detail
cancel () method
public override function cancel():void

Use superclass description.

send () method
public override function send(... args):AsyncToken

Execute the method. Any arguments passed in will be passed along as part of the method call. If there are no arguments passed the arguments array will be used as the source of parameters.

Parameters
... args

Returns
AsyncToken — the call object that can be used as part of the asynchronous completion token pattern, the same object will be available in the result/fault events.


mx.rpc.soap.mxml.WebService (Flex™ 2 Language Reference)

View comments | RSS feed
Class WebService | Properties | Methods | Events | Constants | Examples
Package | mx.rpc.soap.mxml
Class | public dynamic class WebService
Inheritance | WebService Inheritance WebService Inheritance AbstractService Inheritance Proxy Inheritance Object
Implements | IMXMLObject, IMXMLSupport

The <mx:WebService> tag gives you access to the operations of SOAP-compliant web services.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:WebService> tag accepts the following tag attributes:

 <mx:WebService
   Properties
   concurrency="multiple|single|last"
   destination="No default."
   id="No default."
   serviceName="No default."
   showBusyCursor="false|true"
   makeObjectsBindable="false|true"
   useProxy="false|true"
   wsdl="No default."
    Events
   fault="No default."
   result="No default."
 />

An <mx:WebService> tag can have multiple <mx:operation> tags, which have the following tag attributes:

 <mx:operation
   Properties
   concurrency="multiple|single|last"
   name=No default, required.
   resultFormat="object|xml|e4x"
   makeObjectsBindable="false|true"

   Events
   fault=No default.
   result=No default.
 />
An <mx:Operation> tag contains an <mx:request> tag. To specify an XML structure in an <mx:request> tag, you must set the value of the tag's format attribute to "xml". Otherwise, the body is converted into Objects.

View the examples.

See also

Using RPC Components

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | channelSet : ChannelSet Provides access to the ChannelSet used by the service. | AbstractService
 | concurrency : String Value that indicates how to handle multiple calls to the same service. | WebService
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | description : String The description of the service for the currently active port. | WebService
Inherited | destination : String The destination of the service. | WebService
Inherited | endpointURI : String The location of the WebService. | WebService
Inherited | headers : Array Returns the array of SOAPHeaders registered for the WebService. | WebService
Inherited | makeObjectsBindable : Boolean When this value is true, anonymous objects returned are forced to bindable objects. | WebService
Inherited | operations : Object The Operations array is usually only set by the MXML compiler if you create a service using an MXML tag. | AbstractService
Inherited | port : String Specifies the port within the WSDL document that this WebService should use | WebService
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | requestTimeout : int Provides access to the request timeout in seconds for sent messages. | AbstractService
Inherited | rootURL : String The URL that the WebService should use when computing relative URLs. | WebService
Inherited | service : String Specifies the service within the WSDL document that this WebService should use. | WebService
 | serviceName : String | WebService
 | showBusyCursor : Boolean If true, a busy cursor is displayed while a service is executing. | WebService
Inherited | useProxy : Boolean Specifies whether to use the Flex proxy service. | WebService
Inherited | wsdl : String The location of the WSDL document for this WebService. | WebService
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | WebService(destination:String = null) Creates a new WebService component. | WebService
Inherited | addHeader(header:SOAPHeader):void Adds a header that will be applied to all operations of this web service. | WebService
Inherited | addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String):void Add a header that will be applied to all operations of this WebService. | WebService
Inherited | canLoadWSDL():Boolean Returns a Boolean value that indicates whether the WebService ready to load a WSDL (does it have a valid destination or wsdl specified). | WebService
Inherited | clearHeaders():void Clears the headers that applied to all operations. | WebService
Inherited | disconnect():void Disconnects the service's network connection and removes any pending request responders. | AbstractService
Inherited | getHeader(qname:QName, headerName:String = null):SOAPHeader Returns a header if a match is found based on QName localName and URI. | WebService
Inherited | getOperation(name:String):AbstractOperation Returns an Operation of the given name. | AbstractService
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialized(document:Object, id:String):void Called automatically by the MXML compiler if the WebService is setup using a tag. | WebService
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | loadWSDL(uri:String = null):void Instructs the WebService to download the WSDL document. | WebService
Inherited | logout():void Logs the user out of the destination. | AbstractService
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | removeHeader(qname:QName, headerName:String = null):void Removes the header with the given QName from all operations. | WebService
Inherited | setCredentials(username:String, password:String):void Set the credentials for the destination accessed by the service. | AbstractService
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | setRemoteCredentials(remoteUsername:String, remotePassword:String):void The username and password to authenticate a user when accessing the webservice. | WebService
Inherited | toString():String Represents an instance of WebService as a String, describing important properties such as the destination id and the set of channels assigned. | WebService
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | fault | The fault event is dispatched when a service call fails and isn't handled by the Operation itself. | AbstractService
Inherited | invoke | The invoke event is dispatched when a service Operation is invoked so long as an Error is not thrown before the Channel attempts to send the message. | AbstractService
Inherited | load | The LoadEvent.LOAD is dispatched when the WSDL document has loaded successfully. | WebService
Inherited | result | The result event is dispatched when a service call successfully returns and isn't handled by the Operation itself. | AbstractService
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_DESTINATION_HTTP : String = "DefaultHTTP" [static] | WebService
Inherited | DEFAULT_DESTINATION_HTTPS : String = "DefaultHTTPS" [static] | WebService
Property detail
concurrency property
public var concurrency:String

Value that indicates how to handle multiple calls to the same service. The default value is multiple. The following values are permitted:

  • multiple Existing requests are not cancelled, and the developer is responsible for ensuring the consistency of returned data by carefully managing the event stream. This is the default.
  • single Only a single request at a time is allowed on the operation; multiple requests generate a fault.
  • last Making a request cancels any existing request.

serviceName property
serviceName:String [read-write]Implementation
    public function get serviceName():String
    public function set serviceName(value:String):void
showBusyCursor property
showBusyCursor:Boolean [read-write]

If true, a busy cursor is displayed while a service is executing. The default value is false.

Implementation
    public function get showBusyCursor():Boolean
    public function set showBusyCursor(value:Boolean):void
Constructor detail
WebService () constructor
public function WebService(destination:String = null)

Creates a new WebService component.

Parameters
destination:String (default = null) — the destination of the WebService, should match a destination name in the services-config.xml file.
Method detail
initialized () method
public function initialized(document:Object, id:String):void

Called automatically by the MXML compiler if the WebService is setup using a tag. If you create the WebService through ActionScript you may want to call this method yourself as it is useful for validating any arguments.

Parameters
document:Object — the MXML document on which this WebService lives
id:String — the id of this WebService within the document
Examples
WebServiceExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the WebService tag. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

<!--  Make sure the Flex Data Services proxy-config.xml file contains the following definition:

    <destination id="DefaultHTTP">
        <properties>
            <dynamic-url>http://ws.invesbot.com/*</dynamic-url>
        </properties>
    </destination>
-->

    <mx:Script>
        <![CDATA[
            import mx.controls.Alert;
        ]]>
    </mx:Script>

    <mx:WebService id="WS" wsdl="http://ws.invesbot.com/stockquotes.asmx?WSDL"
        useProxy="true"
        fault="Alert.show(event.fault.faultstring), 'Error'">

        <mx:operation name="GetQuote" resultFormat="object">
            <mx:request>
                <symbol>{stockSymbol.text}</symbol>
            </mx:request>
        </mx:operation>
    </mx:WebService>

    <mx:Panel title="WebService Example" height="75%" width="75%"
        paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10">

        <mx:Label width="100%"  color="blue"
            text="Enter a stock symbol to obtain a quote."/>

        <mx:TextInput id="stockSymbol" text="ADBE"/>
        <mx:Button label="Get Quote" click="WS.GetQuote.send()"/>

        <mx:Text htmlText="Company: {WS.GetQuote.lastResult.GetQuoteResult.StockQuote.Company}"/>
        <mx:Text htmlText="Current price: ${WS.GetQuote.lastResult.GetQuoteResult.StockQuote.Price}"/>

    </mx:Panel>
</mx:Application>

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

mpeterson said on Jun 30, 2006 at 12:20 PM :
Instances of "faultstring" on this page should be "faultString".
- Mike Peterson
Adobe Flex documentation team

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/mx/rpc/soap/mxml/WebService.html


mx.rpc.xml Summary (Flex™ 2 Language Reference)

Package mx.rpc.xml | Classes

The mx.rpc.xml package contains the RPC XML-related classes.

Classes
Class | Description
SimpleXMLDecoder | The SimpleXMLDecoder class deserialize XML into a graph of ActionScript objects.
SimpleXMLEncoder | The SimpleXMLEncoder class take ActionScript Objects and encodes them to XML.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.rpc.xml.SimpleXMLDecoder (Flex™ 2 Language Reference)

Class SimpleXMLDecoder | Properties | Methods
Package | mx.rpc.xml
Class | public class SimpleXMLDecoder
Inheritance | SimpleXMLDecoder Inheritance Object

The SimpleXMLDecoder class deserialize XML into a graph of ActionScript objects. Use this class when no schema information is available.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | decodeXML(dataNode:XMLNode):Object Converts a tree of XMLNodes into a tree of ActionScript Objects. | SimpleXMLDecoder
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | simpleType(val:Object):Object [static] Converts an ActionScript object into a Number, Boolean, or String. | SimpleXMLDecoder
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
decodeXML () method
public function decodeXML(dataNode:XMLNode):Object

Converts a tree of XMLNodes into a tree of ActionScript Objects.

Parameters
dataNode:XMLNode

Returns
Object
simpleType () method
public static function simpleType(val:Object):Object

Converts an ActionScript object into a Number, Boolean, or String.

Parameters
val:Object

Returns
Object


mx.rpc.xml.SimpleXMLEncoder (Flex™ 2 Language Reference)

Class SimpleXMLEncoder | Properties | Methods
Package | mx.rpc.xml
Class | public class SimpleXMLEncoder
Inheritance | SimpleXMLEncoder Inheritance Object

The SimpleXMLEncoder class take ActionScript Objects and encodes them to XML. Use default serialization.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SimpleXMLEncoder(myXML:XMLDocument) | SimpleXMLEncoder
 | encodeDate(rawDate:Date, dateType:String):String [static] | SimpleXMLEncoder
 | encodeValue(obj:Object, qname:QName, parentNode:XMLNode):XMLNode parentNode - optional, an XMLNode under which to put the encoded value. | SimpleXMLEncoder
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Constructor detail
SimpleXMLEncoder () constructor
public function SimpleXMLEncoder(myXML:XMLDocument)Parameters
myXML:XMLDocument
Method detail
encodeDate () method
public static function encodeDate(rawDate:Date, dateType:String):String Parameters
rawDate:Date
dateType:String

Returns
String
encodeValue () method
public function encodeValue(obj:Object, qname:QName, parentNode:XMLNode):XMLNode

parentNode - optional, an XMLNode under which to put the encoded value. If this is present, we will be able to use namespace prefixes already defined above the encoded object - if not, a well-formed XML document including all NS declarations necessary is returned.

Parameters
obj:Object
qname:QName
parentNode:XMLNode

Returns
XMLNode


mx.skins Summary (Flex™ 2 Language Reference)

Package mx.skins | Classes

The mx.skins package contains the classes that define the skinning components.

Classes
Class | Description
Border | The Border class is an abstract base class for various classes that draw borders, either rectangular or non-rectangular, around UIComponents.
ProgrammaticSkin | This class is the base class for skin elements which draw themselves programmatically.
RectangularBorder | The RectangularBorder class is an abstract base class for various classes that draw rectangular borders around UIComponents.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.skins.Border (Flex™ 2 Language Reference)

Class Border | Properties | Methods | Events
Package | mx.skins
Class | public class Border
Inheritance | Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | AccordionHeaderSkin, ActivatorSkin, ButtonBarButtonSkin, ButtonSkin, CheckBoxIcon, ColorPickerSkin, ComboBoxArrowSkin, DateChooserMonthArrowSkin, DateChooserYearArrowSkin, LinkButtonSkin, MenuBarBackgroundSkin, NumericStepperDownSkin, NumericStepperUpSkin, ProgressBarSkin, ProgressIndeterminateSkin, ProgressTrackSkin, RadioButtonIcon, RectangularBorder, ScrollArrowSkin, ScrollThumbSkin, ScrollTrackSkin, SliderHighlightSkin, SliderThumbSkin, SliderTrackSkin, SwatchPanelSkin, TabSkin

The Border class is an abstract base class for various classes that draw borders, either rectangular or non-rectangular, around UIComponents. This class does not do any actual drawing itself.

If you create a new non-rectangular border class, you should extend this class. If you create a new rectangular border class, you should extend the abstract subclass RectangularBorder.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
 | borderMetrics : EdgeMetrics [read-only] The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Border()
Constructor.
Border
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
borderMetrics property
borderMetrics:EdgeMetrics [read-only]

The thickness of the border edges.

Implementation
    public function get borderMetrics():EdgeMetrics
Constructor detail
Border () constructor
public function Border()

Constructor.


mx.skins.ProgrammaticSkin (Flex™ 2 Language Reference)

Class ProgrammaticSkin | Properties | Methods | Events
Package | mx.skins
Class | public class ProgrammaticSkin
Inheritance | ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IFlexDisplayObject, IInvalidating, ILayoutManagerClient, ISimpleStyleClient
Subclasses | AreaRenderer, Border, BoxItemRenderer, BrokenImageBorderSkin, CandlestickItemRenderer, CircleItemRenderer, CrossItemRenderer, DataGridColumnDropIndicator, DataGridColumnResizeSkin, DataGridSortArrow, DateChooserIndicator, DiamondItemRenderer, HaloFocusRect, HLOCItemRenderer, LineRenderer, LinkSeparator, ListDropIndicator, PopUpIcon, ShadowBoxItemRenderer, ShadowLineRenderer, TitleBackground, TriangleItemRenderer, WedgeItemRenderer

This class is the base class for skin elements which draw themselves programmatically.

See also

Programmatic skinning
Programmatic skins recipe

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
 | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
 | measuredHeight : Number [read-only] The measured height of this object. | ProgrammaticSkin
 | measuredWidth : Number [read-only] The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
 | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
 | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
 | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
 | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ProgrammaticSkin()
Constructor.
ProgrammaticSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
 | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
 | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
 | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
 | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
initialized property
initialized:Boolean [read-write]

A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required).

Implementation
    public function get initialized():Boolean
    public function set initialized(value:Boolean):void
measuredHeight property
measuredHeight:Number [read-only]

The measured height of this object. This should be overridden by subclasses to return the preferred height for the skin.

Implementation
    public function get measuredHeight():Number
measuredWidth property
measuredWidth:Number [read-only]

The measured width of this object. This should be overridden by subclasses to return the preferred width for the skin.

Implementation
    public function get measuredWidth():Number
nestLevel property
nestLevel:int [read-write]

Depth of this object in the containment hierarchy. This number is used by the measurement and layout code. The value is 0 if this component is not on the DisplayList.

Implementation
    public function get nestLevel():int
    public function set nestLevel(value:int):void
processedDescriptors property
processedDescriptors:Boolean [read-write]

Set to true after immediate or deferred child creation, depending on which one happens. For a Container object, it is set to true at the end of the createComponentsFromDescriptors() method, meaning after the Container object creates its children from its child descriptors.

For example, if an Accordion container uses deferred instantiation, the processedDescriptors property for the second pane of the Accordion container does not become true until after the user navigates to that pane and the pane creates its children. But, if the Accordion had set the creationPolicy property to "all", the processedDescriptors property for its second pane is set to true during application startup.

For classes that are not containers, which do not have descriptors, it is set to true after the createChildren() method creates any internal component children.

Implementation
    public function get processedDescriptors():Boolean
    public function set processedDescriptors(value:Boolean):void
styleName property
styleName:Object [read-write]

A parent component used to obtain style values. This is typically set to the component that created this skin.

Implementation
    public function get styleName():Object
    public function set styleName(value:Object):void
updateCompletePendingFlag property
updateCompletePendingFlag:Boolean [read-write]

A flag that determines if an object has been through all three phases of layout validation (provided that any were required).

Implementation
    public function get updateCompletePendingFlag():Boolean
    public function set updateCompletePendingFlag(value:Boolean):void
Constructor detail
ProgrammaticSkin () constructor
public function ProgrammaticSkin()

Constructor.

Method detail
drawRoundRect () method
protected function drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void

Programatically draws a rectangle into this skin's Graphics object.

The rectangle can have rounded corners. Its edges are stroked with the current line style of the Graphics object. It can have a solid color fill, a gradient fill, or no fill. A solid fill can have an alpha transparency. A gradient fill can be linear or radial. You can specify up to 15 colors and alpha values at specified points along the gradient, and you can specify a rotation angle or transformation matrix for the gradient. Finally, the rectangle can have a rounded rectangular hole carved out of it.

This versatile rectangle-drawing routine is used by many skins. It calls the drawRect() or drawRoundRect() methods (in the flash.display.Graphics class) to draw into this skin's Graphics object.

Parameters
x:Number — Horizontal position of upper-left corner of rectangle within this skin.
y:Number — Vertical position of upper-left corner of rectangle within this skin.
width:Number — Width of rectangle, in pixels.
height:Number — Height of rectangle, in pixels.
cornerRadius:Object (default = null) — Corner radius/radii of rectangle. Can be null, a Number, or an Object. If it is null, it specifies that the corners should be square rather than rounded. If it is a Number, it specifies the same radius, in pixels, for all four corners. If it is an Object, it should have properties named tl, tr, bl, and br, whose values are Numbers specifying the radius, in pixels, for the top left, top right, bottom left, and bottom right corners. For example, you can pass a plain Object such as { tl: 5, tr: 5, bl: 0, br: 0 }. The default value is null (square corners).
color:Object (default = null) — The RGB color(s) for the fill. Can be null, a uint, or an Array. If it is null, the rectangle not filled. If it is a uint, it specifies an RGB fill color. For example, pass 0xFF0000 to fill with red. If it is an Array, it should contain uints specifying the gradient colors. For example, pass [ 0xFF0000, 0xFFFF00, 0x0000FF ] to fill with a red-to-yellow-to-blue gradient. You can specify up to 15 colors in the gradient. The default value is null (no fill).
alpha:Object (default = null) — Alpha value(s) for the fill. Can be null, a Number, or an Array. This argument is ignored if color is null. If color is a uint specifying an RGB fill color, then alpha should be a Number specifying the transparency of the fill, where 0.0 is completely transparent and 1.0 is completely opaque. You can also pass null instead of 1.0 in this case to specify complete opaqueness. If color is an Array specifying gradient colors, then alpha should be an Array of Numbers, of the same length, that specifies the corresponding alpha values for the gradient. In this case, the default value is null (completely opaque).
gradientMatrix:Matrix (default = null) — Matrix object used for the gradient fill. The utility methods horizontalGradientMatrix(), verticalGradientMatrix(), and rotatedGradientMatrix() can be used to create the value for this parameter.
gradientType:String (default = "linear") — Type of gradient fill. The possible values are GradientType.LINEAR or GradientType.RADIAL. (The GradientType class is in the package flash.display.)
gradientRatios:Array (default = null) — (optional default [0,255]) Specifies the distribution of colors. The number of entries must match the number of colors defined in the color parameter. Each value defines the percentage of the width where the color is sampled at 100%. The value 0 represents the left-hand position in the gradient box, and 255 represents the right-hand position in the gradient box.
hole:Object (default = null) — (optional) A rounded rectangular hole that should be carved out of the middle of the otherwise solid rounded rectangle { x: #, y: #, w: #, h: #, r: # or { br: #, bl: #, tl: #, tr: # } }

See also

flash.display.Graphics.beginGradientFill()
getStyle () method
public function getStyle(styleProp:String):*

Returns the value of the specified style property.

Parameters
styleProp:String — Name of the style property.

Returns
* — The style value. This can be any type of object that style properties can be, such as int, Number, String, etc.
horizontalGradientMatrix () method
protected function horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix

Utility function to create a horizontal gradient matrix.

Parameters
x:Number — The left edge of the gradient.
y:Number — The top edge of the gradient.
width:Number — The width of the gradient.
height:Number — The height of the gradient.

Returns
Matrix — The horizontal gradient matrix. This is a temporary object that should only be used for a single subsequent call to the drawRoundRect() method.
invalidateDisplayList () method
public function invalidateDisplayList():void

Marks a component so that its updateDisplayList() method gets called during a later screen update.

Invalidation is a useful mechanism for eliminating duplicate work by delaying processing of changes to a component until a later screen update. For example, if you want to change the width and height, it would be wasteful to update the component immediately after you change the width and then update again with the new height. It is more efficient to change both properties and then render the component with its new size once.

Invalidation methods rarely get called. In general, setting a property on a component automatically calls the appropriate invalidation method.

invalidateProperties () method
public function invalidateProperties():void

Calling this method results in a call to the component's validateProperties() method before the display list is rendered.

For components that extend UIComponent, this implies that commitProperties() is called.

invalidateSize () method
public function invalidateSize():void

Calling this method results in a call to the component's validateSize() method before the display list is rendered.

For components that extend UIComponent, this implies that measure() is called, unless the component has both explicitWidth and explicitHeight set.

move () method
public function move(x:Number, y:Number):void

Moves this object to the specified x and y coordinates.

Parameters
x:Number — The horizontal position, in pixels.
y:Number — The vertical position, in pixels.
rotatedGradientMatrix () method
protected function rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix

Utility function to create a rotated gradient matrix.

Parameters
x:Number — The left edge of the gradient.
y:Number — The top edge of the gradient.
width:Number — The width of the gradient.
height:Number — The height of the gradient.
rotation:Number — The amount to rotate, in degrees.

Returns
Matrix — The horizontal gradient matrix. This is a temporary object that should only be used for a single subsequent call to the drawRoundRect() method.
setActualSize () method
public function setActualSize(newWidth:Number, newHeight:Number):void

Sets the height and width of this object.

Parameters
newWidth:Number — The width, in pixels, of this object.
newHeight:Number — The height, in pixels, of this object.
styleChanged () method
public function styleChanged(styleProp:String):void

Whenever any style changes, redraw this skin. Subclasses can override this method and perform a more specific test before calling invalidateDisplayList().

Parameters
styleProp:String — The name of the style property that changed, or null if all styles have changed.
updateDisplayList () method
protected function updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void

Programmatically draws the graphics for this skin.

Subclasses should override this method and include calls to methods such as graphics.moveTo() and graphics.lineTo().

This occurs before any scaling from sources such as user code or zoom effects. The component is unaware of the scaling that takes place later.

Parameters
unscaledWidth:Number — The width, in pixels, of this object before any scaling.
unscaledHeight:Number — The height, in pixels, of this object before any scaling.

See also

Implementing the updateDisplayList() method
validateDisplayList () method
public function validateDisplayList():void

This function is called by the LayoutManager when it's time for this control to draw itself. The actual drawing happens in the updateDisplayList function, which is called by this function.

validateNow () method
public function validateNow():void

Validate and update the properties and layout of this object and redraw it, if necessary.

validateProperties () method
public function validateProperties():void

This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface. Skins do not call LayoutManager.invalidateProperties(), which would normally trigger a call to this method.

validateSize () method
public function validateSize(recursive:Boolean = false):void

This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface. Skins do not call LayoutManager.invalidateSize(), which would normally trigger a call to this method.

Parameters
recursive:Boolean (default = false) — Determines whether children of this skin are validated.
verticalGradientMatrix () method
protected function verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix

Utility function to create a vertical gradient matrix.

Parameters
x:Number — The left edge of the gradient.
y:Number — The top edge of the gradient.
width:Number — The width of the gradient.
height:Number — The height of the gradient.

Returns
Matrix — The horizontal gradient matrix. This is a temporary object that should only be used for a single subsequent call to the drawRoundRect() method.


mx.skins.RectangularBorder (Flex™ 2 Language Reference)

Class RectangularBorder | Properties | Methods | Events
Package | mx.skins
Class | public class RectangularBorder
Inheritance | RectangularBorder Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | HaloBorder, ToolTipBorder

The RectangularBorder class is an abstract base class for various classes that draw rectangular borders around UIComponents.

This class implements support for the backgroundImage, backgroundSize, and backgroundAttachment styles.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RectangularBorder()
Constructor.
RectangularBorder
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
RectangularBorder () constructor
public function RectangularBorder()

Constructor.


mx.skins.halo Summary (Flex™ 2 Language Reference)

Package mx.skins.halo | Classes

The mx.skins.halo package contains the classes used to skin Flex user-interface controls.

Classes
Class | Description
AccordionHeaderSkin | The skin for all the states of an AccordionHeader in an Accordion.
ActivatorSkin | Defines the up, down, and over states for MenuBarItem objects.
BrokenImageBorderSkin | The skin for the border of a SWFLoader or Image component when the content could not be loaded.
ButtonBarButtonSkin | The skin for all the states of the ButtonBarButtons in a ButtonBar.
ButtonSkin | The skin for all the states of a Button.
CheckBoxIcon | The skin for all the states of the icon in a CheckBox.
ColorPickerSkin | The skin for all the states of a ColorPicker.
ComboBoxArrowSkin | The skin for all the states of the button in a ComboBox.
DataGridColumnDropIndicator | The skin for the column drop indicator in a DataGrid.
DataGridColumnResizeSkin | The skin for the column resizer in a DataGrid.
DataGridHeaderSeparator | The skin for the separator between column headers in a DataGrid.
DataGridSortArrow | The skin for the sort arrow in a column header in a DataGrid.
DateChooserIndicator | The skins of the DateChooser's indicators for displaying today, rollover and selected dates.
DateChooserMonthArrowSkin | The skin for all the states of the next-month and previous-month buttons in a DateChooser.
DateChooserYearArrowSkin | The skin for all the states of the next-year and previous-year buttons in a DateChooser.
HaloBorder | Defines the appearance of the default border for the Halo theme.
HaloColors | Defines the colors used by components that support the Halo theme.
HaloFocusRect | Defines the skin for the focus indicator.
LinkButtonSkin | The skin for all the states of a LinkButton.
LinkSeparator | The skin for the separator between the Links in a LinkBar.
ListDropIndicator | The skin for the drop indicator of a list-based control.
MenuBarBackgroundSkin | The skin for the background of a MenuBar.
NumericStepperDownSkin | The skin for all the states of the down button in a NumericStepper.
NumericStepperUpSkin | The skin for all the states of the up button in a NumericStepper.
PopUpButtonSkin | The skin for all the states of a PopUpButton.
PopUpIcon | The skin for all the states of the icon in a PopUpButton.
PopUpMenuIcon | The skin for all the states of the icon in a PopUpMenuButton.
ProgressBarSkin | The skin for a ProgressBar.
ProgressIndeterminateSkin | The skin for the indeterminate state of a ProgressBar.
ProgressTrackSkin | The skin for the track in a ProgressBar.
RadioButtonIcon | The skin for all the states of the icon in a RadioButton.
ScrollArrowSkin | The skin for all the states of the up or down button in a ScrollBar.
ScrollThumbSkin | The skin for all the states of the thumb in a ScrollBar.
ScrollTrackSkin | The skin for the track in a ScrollBar.
SliderHighlightSkin | The skin for the highlighted state of the track of a Slider.
SliderThumbSkin | The skin for all the states of a thumb in a Slider.
SliderTrackSkin | The skin for the track in a Slider.
SwatchPanelSkin | The skin for the border of a SwatchPanel.
SwatchSkin | The skin used for all color swatches in a ColorPicker.
TabSkin | The skin for all the states of a Tab in a TabNavigator or TabBar.
TitleBackground | The skin for a title bar area of a Panel.
ToolTipBorder | The skin for a ToolTip.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.skins.halo.AccordionHeaderSkin (Flex™ 2 Language Reference)

Class AccordionHeaderSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class AccordionHeaderSkin
Inheritance | AccordionHeaderSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of an AccordionHeader in an Accordion.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
AccordionHeaderSkin()
Constructor.
AccordionHeaderSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
AccordionHeaderSkin () constructor
public function AccordionHeaderSkin()

Constructor.


mx.skins.halo.ActivatorSkin (Flex™ 2 Language Reference)

Class ActivatorSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ActivatorSkin
Inheritance | ActivatorSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Defines the up, down, and over states for MenuBarItem objects.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ActivatorSkin()
Constructor.
ActivatorSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ActivatorSkin () constructor
public function ActivatorSkin()

Constructor.


mx.skins.halo.BrokenImageBorderSkin (Flex™ 2 Language Reference)

Class BrokenImageBorderSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class BrokenImageBorderSkin
Inheritance | BrokenImageBorderSkin Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the border of a SWFLoader or Image component when the content could not be loaded.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
BrokenImageBorderSkin()
Constructor.
BrokenImageBorderSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
BrokenImageBorderSkin () constructor
public function BrokenImageBorderSkin()

Constructor.


mx.skins.halo.ButtonBarButtonSkin (Flex™ 2 Language Reference)

Class ButtonBarButtonSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ButtonBarButtonSkin
Inheritance | ButtonBarButtonSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the ButtonBarButtons in a ButtonBar.

See also

ButtonBar and ToggleButtonBar controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ButtonBarButtonSkin()
Constructor.
ButtonBarButtonSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ButtonBarButtonSkin () constructor
public function ButtonBarButtonSkin()

Constructor.


mx.skins.halo.ButtonSkin (Flex™ 2 Language Reference)

Class ButtonSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ButtonSkin
Inheritance | ButtonSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of a Button.

See also

Button control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ButtonSkin()
Constructor.
ButtonSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ButtonSkin () constructor
public function ButtonSkin()

Constructor.


mx.skins.halo.CheckBoxIcon (Flex™ 2 Language Reference)

Class CheckBoxIcon | Properties | Methods | Events
Package | mx.skins.halo
Class | public class CheckBoxIcon
Inheritance | CheckBoxIcon Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the icon in a CheckBox.

See also

CheckBox control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CheckBoxIcon()
Constructor.
CheckBoxIcon
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
CheckBoxIcon () constructor
public function CheckBoxIcon()

Constructor.


mx.skins.halo.ColorPickerSkin (Flex™ 2 Language Reference)

Class ColorPickerSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ColorPickerSkin
Inheritance | ColorPickerSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of a ColorPicker.

See also

ColorPicker control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ColorPickerSkin()
Constructor.
ColorPickerSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ColorPickerSkin () constructor
public function ColorPickerSkin()

Constructor.


mx.skins.halo.ComboBoxArrowSkin (Flex™ 2 Language Reference)

Class ComboBoxArrowSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ComboBoxArrowSkin
Inheritance | ComboBoxArrowSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the button in a ComboBox.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ComboBoxArrowSkin()
Constructor.
ComboBoxArrowSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ComboBoxArrowSkin () constructor
public function ComboBoxArrowSkin()

Constructor.


mx.skins.halo.DataGridColumnDropIndicator (Flex™ 2 Language Reference)

Class DataGridColumnDropIndicator | Properties | Methods | Events
Package | mx.skins.halo
Class | public class DataGridColumnDropIndicator
Inheritance | DataGridColumnDropIndicator Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the column drop indicator in a DataGrid.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridColumnDropIndicator()
Constructor.
DataGridColumnDropIndicator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
DataGridColumnDropIndicator () constructor
public function DataGridColumnDropIndicator()

Constructor.


mx.skins.halo.DataGridColumnResizeSkin (Flex™ 2 Language Reference)

Class DataGridColumnResizeSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class DataGridColumnResizeSkin
Inheritance | DataGridColumnResizeSkin Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the column resizer in a DataGrid.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridColumnResizeSkin()
Constructor.
DataGridColumnResizeSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
DataGridColumnResizeSkin () constructor
public function DataGridColumnResizeSkin()

Constructor.


mx.skins.halo.DataGridHeaderSeparator (Flex™ 2 Language Reference)

Class DataGridHeaderSeparator | Properties | Methods | Events
Package | mx.skins.halo
Class | public class DataGridHeaderSeparator
Inheritance | DataGridHeaderSeparator Inheritance SpriteAsset Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the separator between column headers in a DataGrid.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | doubleClickEnabled : Boolean Specifies whether the object receives doubleClick events. | InteractiveObject
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | SpriteAsset
Inherited | measuredWidth : Number The measured width of this object. | SpriteAsset
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridHeaderSeparator()
Constructor.
DataGridHeaderSeparator
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
SpriteAsset
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the actual size of this object.
SpriteAsset
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Constructor detail
DataGridHeaderSeparator () constructor
public function DataGridHeaderSeparator()

Constructor.


mx.skins.halo.DataGridSortArrow (Flex™ 2 Language Reference)

Class DataGridSortArrow | Properties | Methods | Events
Package | mx.skins.halo
Class | public class DataGridSortArrow
Inheritance | DataGridSortArrow Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the sort arrow in a column header in a DataGrid.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DataGridSortArrow()
Constructor.
DataGridSortArrow
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
DataGridSortArrow () constructor
public function DataGridSortArrow()

Constructor.


mx.skins.halo.DateChooserIndicator (Flex™ 2 Language Reference)

Class DateChooserIndicator | Properties | Methods | Events
Package | mx.skins.halo
Class | public class DateChooserIndicator
Inheritance | DateChooserIndicator Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skins of the DateChooser's indicators for displaying today, rollover and selected dates.

See also

DateChooser and DateField controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DateChooserIndicator()
Constructor
DateChooserIndicator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
DateChooserIndicator () constructor
public function DateChooserIndicator()

Constructor


mx.skins.halo.DateChooserMonthArrowSkin (Flex™ 2 Language Reference)

Class DateChooserMonthArrowSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class DateChooserMonthArrowSkin
Inheritance | DateChooserMonthArrowSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the next-month and previous-month buttons in a DateChooser.

See also

DateChooser and DateField controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DateChooserMonthArrowSkin()
Constructor.
DateChooserMonthArrowSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
DateChooserMonthArrowSkin () constructor
public function DateChooserMonthArrowSkin()

Constructor.


mx.skins.halo.DateChooserYearArrowSkin (Flex™ 2 Language Reference)

Class DateChooserYearArrowSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class DateChooserYearArrowSkin
Inheritance | DateChooserYearArrowSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the next-year and previous-year buttons in a DateChooser.

See also

DateChooser and DateField controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DateChooserYearArrowSkin()
Constructor.
DateChooserYearArrowSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
DateChooserYearArrowSkin () constructor
public function DateChooserYearArrowSkin()

Constructor.


mx.skins.halo.HaloBorder (Flex™ 2 Language Reference)

Class HaloBorder | Properties | Methods | Events
Package | mx.skins.halo
Class | public class HaloBorder
Inheritance | HaloBorder Inheritance RectangularBorder Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

Defines the appearance of the default border for the Halo theme.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HaloBorder()
Constructor.
HaloBorder
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
HaloBorder () constructor
public function HaloBorder()

Constructor.


mx.skins.halo.HaloColors (Flex™ 2 Language Reference)

Class HaloColors | Properties | Methods
Package | mx.skins.halo
Class | public class HaloColors
Inheritance | HaloColors Inheritance Object

Defines the colors used by components that support the Halo theme.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | addHaloColors(colors:Object, themeColor:uint, fillColor0:uint, fillColor1:uint):void [static] Calculates colors that are used by components that support the Halo theme, such as the colors of beveled edges. | HaloColors
 | getCacheKey(... colors):String [static] Returns a unique hash key based on the colors that are passed in. | HaloColors
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
addHaloColors () method
public static function addHaloColors(colors:Object, themeColor:uint, fillColor0:uint, fillColor1:uint):void

Calculates colors that are used by components that support the Halo theme, such as the colors of beveled edges. This method uses the themeColor and fillColors properties to calculate its colors.

Parameters
colors:Object
themeColor:uint — The value of the themeColor style property.
fillColor0:uint — The start color of a fill.
fillColor1:uint — The end color of a fill.
getCacheKey () method
public static function getCacheKey(... colors):String

Returns a unique hash key based on the colors that are passed in. This key is used to store the calculated colors so they only need to be calculated once.

Parameters
... colors

Returns
String


mx.skins.halo.HaloFocusRect (Flex™ 2 Language Reference)

Class HaloFocusRect | Properties | Methods | Events
Package | mx.skins.halo
Class | public class HaloFocusRect
Inheritance | HaloFocusRect Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Implements | IStyleClient

Defines the skin for the focus indicator. This is the rectangle that appears around a control when it has focus.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
HaloFocusRect()
Constructor.
HaloFocusRect
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
HaloFocusRect () constructor
public function HaloFocusRect()

Constructor.


mx.skins.halo.LinkButtonSkin (Flex™ 2 Language Reference)

Class LinkButtonSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class LinkButtonSkin
Inheritance | LinkButtonSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of a LinkButton.

See also

LinkButton control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LinkButtonSkin()
Constructor.
LinkButtonSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
LinkButtonSkin () constructor
public function LinkButtonSkin()

Constructor.


mx.skins.halo.LinkSeparator (Flex™ 2 Language Reference)

Class LinkSeparator | Properties | Methods | Events
Package | mx.skins.halo
Class | public class LinkSeparator
Inheritance | LinkSeparator Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the separator between the Links in a LinkBar.

See also

LinkBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
LinkSeparator()
Constructor.
LinkSeparator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
LinkSeparator () constructor
public function LinkSeparator()

Constructor.


mx.skins.halo.ListDropIndicator (Flex™ 2 Language Reference)

Class ListDropIndicator | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ListDropIndicator
Inheritance | ListDropIndicator Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the drop indicator of a list-based control.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | direction : String = "horizontal" Should the skin draw a horizontal line or vertical line. | ListDropIndicator
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ListDropIndicator()
Constructor.
ListDropIndicator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Property detail
direction property
public var direction:String = "horizontal"

Should the skin draw a horizontal line or vertical line. Default is horizontal.

Constructor detail
ListDropIndicator () constructor
public function ListDropIndicator()

Constructor.


mx.skins.halo.MenuBarBackgroundSkin (Flex™ 2 Language Reference)

Class MenuBarBackgroundSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class MenuBarBackgroundSkin
Inheritance | MenuBarBackgroundSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the background of a MenuBar.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
MenuBarBackgroundSkin()
Constructor.
MenuBarBackgroundSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
MenuBarBackgroundSkin () constructor
public function MenuBarBackgroundSkin()

Constructor.


mx.skins.halo.NumericStepperDownSkin (Flex™ 2 Language Reference)

Class NumericStepperDownSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class NumericStepperDownSkin
Inheritance | NumericStepperDownSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the down button in a NumericStepper.

See also

NumericStepper control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NumericStepperDownSkin()
Constructor.
NumericStepperDownSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
NumericStepperDownSkin () constructor
public function NumericStepperDownSkin()

Constructor.


mx.skins.halo.NumericStepperUpSkin (Flex™ 2 Language Reference)

Class NumericStepperUpSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class NumericStepperUpSkin
Inheritance | NumericStepperUpSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the up button in a NumericStepper.

See also

NumericStepper control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NumericStepperUpSkin()
Constructor.
NumericStepperUpSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
NumericStepperUpSkin () constructor
public function NumericStepperUpSkin()

Constructor.


mx.skins.halo.PopUpButtonSkin (Flex™ 2 Language Reference)

Class PopUpButtonSkin | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.skins.halo
Class | public class PopUpButtonSkin
Inheritance | PopUpButtonSkin Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of a PopUpButton.

See also

PopUpButton control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PopUpButtonSkin()
Constructor.
PopUpButtonSkin
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
PopUpButtonSkin () constructor
public function PopUpButtonSkin()

Constructor.


mx.skins.halo.PopUpIcon (Flex™ 2 Language Reference)

Class PopUpIcon | Properties | Methods | Events
Package | mx.skins.halo
Class | public class PopUpIcon
Inheritance | PopUpIcon Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object
Subclasses | PopUpMenuIcon

The skin for all the states of the icon in a PopUpButton.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PopUpIcon()
Constructor
PopUpIcon
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
PopUpIcon () constructor
public function PopUpIcon()

Constructor


mx.skins.halo.PopUpMenuIcon (Flex™ 2 Language Reference)

Class PopUpMenuIcon | Properties | Methods | Events
Package | mx.skins.halo
Class | public class PopUpMenuIcon
Inheritance | PopUpMenuIcon Inheritance PopUpIcon Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the icon in a PopUpMenuButton.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PopUpMenuIcon()
Constructor
PopUpMenuIcon
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
PopUpMenuIcon () constructor
public function PopUpMenuIcon()

Constructor


mx.skins.halo.ProgressBarSkin (Flex™ 2 Language Reference)

Class ProgressBarSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ProgressBarSkin
Inheritance | ProgressBarSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for a ProgressBar.

See also

ProgressBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ProgressBarSkin()
Constructor.
ProgressBarSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ProgressBarSkin () constructor
public function ProgressBarSkin()

Constructor.


mx.skins.halo.ProgressIndeterminateSkin (Flex™ 2 Language Reference)

Class ProgressIndeterminateSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ProgressIndeterminateSkin
Inheritance | ProgressIndeterminateSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the indeterminate state of a ProgressBar.

See also

ProgressBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ProgressIndeterminateSkin()
Constructor.
ProgressIndeterminateSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ProgressIndeterminateSkin () constructor
public function ProgressIndeterminateSkin()

Constructor.


mx.skins.halo.ProgressTrackSkin (Flex™ 2 Language Reference)

Class ProgressTrackSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ProgressTrackSkin
Inheritance | ProgressTrackSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the track in a ProgressBar.

See also

ProgressBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ProgressTrackSkin()
Constructor.
ProgressTrackSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ProgressTrackSkin () constructor
public function ProgressTrackSkin()

Constructor.


mx.skins.halo.RadioButtonIcon (Flex™ 2 Language Reference)

Class RadioButtonIcon | Properties | Methods | Events
Package | mx.skins.halo
Class | public class RadioButtonIcon
Inheritance | RadioButtonIcon Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the icon in a RadioButton.

See also

RadioButton control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RadioButtonIcon()
Constructor.
RadioButtonIcon
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
RadioButtonIcon () constructor
public function RadioButtonIcon()

Constructor.


mx.skins.halo.ScrollArrowSkin (Flex™ 2 Language Reference)

Class ScrollArrowSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ScrollArrowSkin
Inheritance | ScrollArrowSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the up or down button in a ScrollBar.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ScrollArrowSkin()
Constructor.
ScrollArrowSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ScrollArrowSkin () constructor
public function ScrollArrowSkin()

Constructor.


mx.skins.halo.ScrollThumbSkin (Flex™ 2 Language Reference)

Class ScrollThumbSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ScrollThumbSkin
Inheritance | ScrollThumbSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of the thumb in a ScrollBar.

See also

ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ScrollThumbSkin()
Constructor.
ScrollThumbSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ScrollThumbSkin () constructor
public function ScrollThumbSkin()

Constructor.


mx.skins.halo.ScrollTrackSkin (Flex™ 2 Language Reference)

Class ScrollTrackSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ScrollTrackSkin
Inheritance | ScrollTrackSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the track in a ScrollBar.

See also

ScrollBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ScrollTrackSkin()
Constructor.
ScrollTrackSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ScrollTrackSkin () constructor
public function ScrollTrackSkin()

Constructor.


mx.skins.halo.SliderHighlightSkin (Flex™ 2 Language Reference)

Class SliderHighlightSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class SliderHighlightSkin
Inheritance | SliderHighlightSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the highlighted state of the track of a Slider.

See also

HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SliderHighlightSkin()
Constructor.
SliderHighlightSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
SliderHighlightSkin () constructor
public function SliderHighlightSkin()

Constructor.


mx.skins.halo.SliderThumbSkin (Flex™ 2 Language Reference)

Class SliderThumbSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class SliderThumbSkin
Inheritance | SliderThumbSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of a thumb in a Slider.

See also

HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SliderThumbSkin()
Constructor.
SliderThumbSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
SliderThumbSkin () constructor
public function SliderThumbSkin()

Constructor.


mx.skins.halo.SliderTrackSkin (Flex™ 2 Language Reference)

Class SliderTrackSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class SliderTrackSkin
Inheritance | SliderTrackSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the track in a Slider.

See also

HSlider and VSlider controls

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SliderTrackSkin()
Constructor.
SliderTrackSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
SliderTrackSkin () constructor
public function SliderTrackSkin()

Constructor.


mx.skins.halo.SwatchPanelSkin (Flex™ 2 Language Reference)

Class SwatchPanelSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class SwatchPanelSkin
Inheritance | SwatchPanelSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for the border of a SwatchPanel.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SwatchPanelSkin()
Constructor.
SwatchPanelSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
SwatchPanelSkin () constructor
public function SwatchPanelSkin()

Constructor.


mx.skins.halo.SwatchSkin (Flex™ 2 Language Reference)

Class SwatchSkin | Properties | Methods | Events | Styles | Effects | Constants
Package | mx.skins.halo
Class | public class SwatchSkin
Inheritance | SwatchSkin Inheritance UIComponent Inheritance FlexSprite Inheritance Sprite Inheritance DisplayObjectContainer Inheritance InteractiveObject Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin used for all color swatches in a ColorPicker.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | baselinePosition : Number Determines the baseline y-coordinate of the first line of text of the component. | UIComponent
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | buttonMode : Boolean Specifies the button mode of this sprite. | Sprite
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | cacheHeuristic : Boolean Used by Flex to suggest bitmap caching for the object. | UIComponent
Inherited | cachePolicy : String Specifies the bitmap caching policy for this object. | UIComponent
Inherited | className : String The name of this instance's class, such as "Button". | UIComponent
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | contentMouseX : Number Returns the x position of the mouse, in the content coordinate system. | UIComponent
Inherited | contentMouseY : Number Returns the y position of the mouse, in the content coordinate system. | UIComponent
Inherited | contextMenu : ContextMenu Specifies the context menu associated with this object. | InteractiveObject
Inherited | currentState : String The current view state of the component. | UIComponent
Inherited | descriptor : UIComponentDescriptor Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance. | UIComponent
Inherited | document : Object A reference to the document object associated with this UIComponent. | UIComponent
Inherited | doubleClickEnabled : Boolean Specifies whether the UIComponent object receives doubleClick events. | UIComponent
Inherited | dropTarget : DisplayObject Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped. | Sprite
Inherited | enabled : Boolean Whether the component can accept user interaction. | UIComponent
Inherited | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | UIComponent
Inherited | explicitHeight : Number Number that specifies the explicit height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMaxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitMinWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | explicitWidth : Number Number that specifies the explicit width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | focusEnabled : Boolean Indicates whether the component can receive focus when clicked on. | UIComponent
Inherited | focusManager : IFocusManager Gets the FocusManager that controls focus for this component and its peers. | UIComponent
Inherited | focusPane : Sprite The focus pane associated with this object. | UIComponent
Inherited | focusRect : Object Specifies whether this object displays a focus rectangle. | InteractiveObject
Inherited | graphics : Graphics Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur. | Sprite
Inherited | height : Number Number that specifies the height of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | hitArea : Sprite Designates another sprite to serve as the hit area for a sprite. | Sprite
Inherited | id : String ID of the component. | UIComponent
Inherited | includeInLayout : Boolean Specifies whether this component is included in the layout of the parent container. | UIComponent
Inherited | inheritingStyles : Object The beginning of this component's chain of inheriting styles. | UIComponent
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | UIComponent
Inherited | instanceIndex : int The index of a repeated component. | UIComponent
Inherited | instanceIndices : Array An Array containing the indices required to reference this UIComponent object from its parent document. | UIComponent
Inherited | isDocument : Boolean Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component. | UIComponent
Inherited | isPopUp : Boolean Set to true by the PopUpManager to indicate that component has been popped up. | UIComponent
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | maxHeight : Number Number that specifies the maximum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | maxWidth : Number Number that specifies the maximum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | measuredHeight : Number The default height of the component, in pixels. | UIComponent
Inherited | measuredMinHeight : Number The default minimum height of the component, in pixels. | UIComponent
Inherited | measuredMinWidth : Number The default minimum width of the component, in pixels. | UIComponent
Inherited | measuredWidth : Number The default width of the component, in pixels. | UIComponent
Inherited | minHeight : Number Number that specifies the minimum height of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | minWidth : Number Number that specifies the minimum width of the component, in pixels, in the component's coordinates. | UIComponent
Inherited | mouseChildren : Boolean Determines whether or not the children of the object are mouse enabled. | DisplayObjectContainer
Inherited | mouseEnabled : Boolean Specifies whether this object receives mouse messages. | InteractiveObject
Inherited | mouseFocusEnabled : Boolean Whether you can receive focus when clicked on. | UIComponent
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | UIComponent
Inherited | nonInheritingStyles : Object The beginning of this component's chain of non-inheriting styles. | UIComponent
Inherited | numChildren : int Returns the number of children of this object. | DisplayObjectContainer
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | owner : DisplayObjectContainer The owner of this UIComponent. | UIComponent
Inherited | parent : DisplayObjectContainer The parent container or component for this component. | UIComponent
Inherited | parentApplication : Object A reference to the Application object that contains this UIComponent instance. | UIComponent
Inherited | parentDocument : Object A reference to the parent document object for this UIComponent. | UIComponent
Inherited | percentHeight : Number Number that specifies the height of a component as a percentage of its parent's size. | UIComponent
Inherited | percentWidth : Number Number that specifies the width of a component as a percentage of its parent's size. | UIComponent
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | UIComponent
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | repeater : IRepeater A reference to the Repeater object in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaterIndex : int The index of the item in the data provider of the Repeater that produced this UIComponent. | UIComponent
Inherited | repeaterIndices : Array An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent. | UIComponent
Inherited | repeaters : Array An Array containing references to the Repeater objects in the parent document that produced this UIComponent. | UIComponent
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Number that specifies the horizontal scaling factor. | UIComponent
Inherited | scaleY : Number Number that specifies the vertical scaling percentage. | UIComponent
Inherited | screen : Rectangle Returns an object that contains the size and position of the base drawing surface for this object. | UIComponent
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | soundTransform : SoundTransform Controls sound within this sprite. | Sprite
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | states : Array The view states that are defined for this component. | UIComponent
Inherited | styleDeclaration : CSSStyleDeclaration Storage for the inline inheriting styles on this object. | UIComponent
Inherited | styleName : Object The class style used by this component. | UIComponent
Inherited | systemManager : ISystemManager Returns the SystemManager object used by this component. | UIComponent
Inherited | tabChildren : Boolean Determines whether the children of the object are tab enabled. | DisplayObjectContainer
Inherited | tabEnabled : Boolean Specifies whether this object is in the tab order. | InteractiveObject
Inherited | tabIndex : int Specifies the tab ordering of objects in a SWF file. | InteractiveObject
Inherited | textSnapshot : TextSnapshot Returns a TextSnapshot object for this DisplayObjectContainer instance. | DisplayObjectContainer
Inherited | toolTip : String Text to display in the ToolTip. | UIComponent
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | transitions : Array An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs. | UIComponent
Inherited | tweeningProperties : Array Array of properties that are currently being tweened on this object. | UIComponent
Inherited | uid : String A unique identifier for the object. | UIComponent
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | UIComponent
Inherited | useHandCursor : Boolean A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true. | Sprite
Inherited | validationSubField : String Used by a validator to associate a subfield with this component. | UIComponent
Inherited | visible : Boolean Controls the visibility of this UIComponent. | UIComponent
Inherited | width : Number Number that specifies the width of the component, in pixels, in the parent's coordinates. | UIComponent
Inherited | x : Number Number that specifies the component's horizontal position, in pixels, within its parent container. | UIComponent
Inherited | y : Number Number that specifies the component's vertical position, in pixels, within its parent container. | UIComponent
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | unscaledHeight : Number A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList(). | UIComponent
Inherited | unscaledWidth : Number A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList(). | UIComponent
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SwatchSkin()
Constructor.
SwatchSkin
Inherited
addChild(child:DisplayObject):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addChildAt(child:DisplayObject, index:int):DisplayObject
Adds a child DisplayObject instance to this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
areInaccessibleObjectsUnderPoint(point:Point):Boolean
Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
DisplayObjectContainer
Inherited
callLater(method:Function, args:Array = null):void
Queues a function to be called later.
UIComponent
Inherited
clearStyle(styleProp:String):void
Deletes a style property from this component instance.
UIComponent
Inherited
contains(child:DisplayObject):Boolean
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
DisplayObjectContainer
Inherited
contentToGlobal(point:Point):Point
Converts a Point object from content coordinates to global coordinates.
UIComponent
Inherited
contentToLocal(point:Point):Point
Converts a Point object from content to local coordinates.
UIComponent
Inherited
createReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Creates an id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
deleteReferenceOnParentDocument(parentDocument:IFlexDisplayObject):void
Deletes the id reference to this IUIComponent object on its parent document object.
UIComponent
Inherited
determineTextFormatFromStyles():UITextFormat
Returns a UITextFormat object corresponding to the text styles for this UIComponent.
UIComponent
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
drawFocus(focused:Boolean):void
Shows or hides the focus indicator around this component.
UIComponent
Inherited
drawRoundRect(x:Number, y:Number, w:Number, h:Number, r:Object = null, c:Object = null, alpha:Object = null, rot:Object = null, gradient:String = null, ratios:Array = null, hole:Object = null):void
Programatically draws a rectangle into this skin's Graphics object.
UIComponent
Inherited
effectFinished(effectInst:EffectInstance):void
Called by the effect instance when it stops playing on the component.
UIComponent
Inherited
effectStarted(effectInst:EffectInstance):void
Called by the effect instance when it starts playing on the component.
UIComponent
Inherited
endEffectsStarted():void
Ends all currently playing effects on the component.
UIComponent
Inherited
executeBindings(recurse:Boolean = false):void
Executes the data bindings into this UIComponent object.
UIComponent
Inherited
finishPrint(obj:Object, target:IFlexDisplayObject):void
Called after printing is complete.
UIComponent
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getChildAt(index:int):DisplayObject
Returns the child display object instance that exists at the specified index.
DisplayObjectContainer
Inherited
getChildByName(name:String):DisplayObject
Returns the child display object that exists with the specified name.
DisplayObjectContainer
Inherited
getChildIndex(child:DisplayObject):int
Returns the index position of a child DisplayObject instance.
DisplayObjectContainer
Inherited
getClassStyleDeclarations():Array
Finds the type selectors for this UIComponent instance.
UIComponent
Inherited
getExplicitOrMeasuredHeight():Number
A convenience method for determining whether to use the explicit or measured height
UIComponent
Inherited
getExplicitOrMeasuredWidth():Number
A convenience method for determining whether to use the explicit or measured width
UIComponent
Inherited
getFocus():InteractiveObject
Gets the object that currently has focus.
UIComponent
Inherited
getObjectsUnderPoint(point:Point):Array
Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getRepeaterItem(whichRepeater:int = -1):Object
Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
UIComponent
Inherited
getStyle(styleProp:String):*
Gets a style property that has been set anywhere in this component's style lookup chain.
UIComponent
Inherited
globalToContent(point:Point):Point
Converts a Point object from global to content coordinates.
UIComponent
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
UIComponent
Inherited
initialize():void
Initializes the internal structure of this component.
UIComponent
Inherited
initializeRepeaterArrays(parent:IRepeaterClient):void
Initializes various properties which keep track of repeated instances of this component.
UIComponent
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
UIComponent
Inherited
invalidateProperties():void
Marks a component so that its commitProperties() method gets called during a later screen update.
UIComponent
Inherited
invalidateSize():void
Marks a component so that its measure() method gets called during a later screen update.
UIComponent
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToContent(point:Point):Point
Converts a Point object from local to content coordinates.
UIComponent
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
measureHTMLText(htmlText:String):TextLineMetrics
Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
measureText(text:String):TextLineMetrics
Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
UIComponent
Inherited
move(x:Number, y:Number):void
Moves the component to a specified position within its parent.
UIComponent
Inherited
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void
Propagate style changes to the children.
UIComponent
Inherited
owns(child:DisplayObject):Boolean
Returns true if the chain of owner properties points from child to this UIComponent.
UIComponent
Inherited
parentChanged(p:DisplayObjectContainer):void
Called by Flex when a UIComponent object is added to or removed from a parent.
UIComponent
Inherited
prepareToPrint(target:IFlexDisplayObject):Object
Prepares an IFlexDisplayObject for printing.
UIComponent
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
regenerateStyleCache(recursive:Boolean):void
Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
UIComponent
Inherited
registerEffects(effects:Array):void
For each effect event, register the EffectManager as one of the event listeners.
UIComponent
Inherited
removeChild(child:DisplayObject):DisplayObject
Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
DisplayObjectContainer
Inherited
removeChildAt(index:int):DisplayObject
Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
DisplayObjectContainer
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
resumeBackgroundProcessing():void
[static] Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
UIComponent
Inherited
setActualSize(w:Number, h:Number):void
Sizes the object.
UIComponent
Inherited
setChildIndex(child:DisplayObject, index:int):void
Changes the position of an existing child in the display object container.
DisplayObjectContainer
Inherited
setCurrentState(stateName:String, playTransition:Boolean = true):void
Set the current state.
UIComponent
Inherited
setFocus():void
Sets the focus to this component.
UIComponent
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
setStyle(styleProp:String, newValue:*):void
Sets a style property on this component instance.
UIComponent
Inherited
setVisible(value:Boolean, noEvent:Boolean = false):void
Called when the visible property changes.
UIComponent
Inherited
startDrag(lockCenter:Boolean = false, bounds:Rectangle = null):void
Lets the user drag the specified sprite.
Sprite
Inherited
stopDrag():void
Ends the startDrag() method.
Sprite
Inherited
styleChanged(styleProp:String):void
Detects changes to style properties.
UIComponent
Inherited
stylesInitialized():void
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
UIComponent
Inherited
suspendBackgroundProcessing():void
[static] Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
UIComponent
Inherited
swapChildren(child1:DisplayObject, child2:DisplayObject):void
Swaps the z-order (front-to-back order) of the two specified child objects.
DisplayObjectContainer
Inherited
swapChildrenAt(index1:int, index2:int):void
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
DisplayObjectContainer
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexSprite
Inherited
validateDisplayList():void
Validates the position and size of children and draws other visuals.
UIComponent
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
UIComponent
Inherited
validateProperties():void
Used by layout logic to validate the properties of a component by calling the commitProperties() method.
UIComponent
Inherited
validateSize(recursive:Boolean = false):void
Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
UIComponent
Inherited
validationResultHandler(event:ValidationResultEvent):void
Handles both the valid and invalid events from a validator assigned to this component.
UIComponent
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix
Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
UIComponent
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | adjustFocusRect(obj:DisplayObject = null):void Adjust the focus rectangle. | UIComponent
Inherited | attachOverlay():void This is an internal method used by the Flex framework to support the Dissolve effect. | UIComponent
Inherited | childrenCreated():void Performs any final processing after child objects are created. | UIComponent
Inherited | commitProperties():void Processes the properties set on the component. | UIComponent
Inherited | createChildren():void Create child objects of the component. | UIComponent
Inherited | focusInHandler(event:FocusEvent):void The event handler called when a UIComponent object gets focus. | UIComponent
Inherited | focusOutHandler(event:FocusEvent):void The event handler called when a UIComponent object loses focus. | UIComponent
Inherited | initializationComplete():void Finalizes the initialization of this component. | UIComponent
Inherited | initializeAccessibility():void Initializes this component's accessibility code. | UIComponent
Inherited | isOurFocus(target:DisplayObject):Boolean Typically overridden by components containing UITextField objects, where the UITextField object gets focus. | UIComponent
Inherited | keyDownHandler(event:KeyboardEvent):void The event handler called for a keyDown event. | UIComponent
Inherited | keyUpHandler(event:KeyboardEvent):void The event handler called for a keyUp event. | UIComponent
Inherited | measure():void Calculates the default size, and optionally the default minimum size, of the component. | UIComponent
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Draws the object and/or sizes and positions its children. | UIComponent
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | add | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method. | UIComponent
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | click | Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject. | InteractiveObject
Inherited | creationComplete | Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing. | UIComponent
Inherited | currentStateChange | Dispatched after the view state has changed. | UIComponent
Inherited | currentStateChanging | Dispatched after the currentState property changes, but before the view state changes. | UIComponent
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | doubleClick | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true. | InteractiveObject
Inherited | dragComplete | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop. | UIComponent
Inherited | dragDrop | Dispatched by the drop target when the user releases the mouse over it. | UIComponent
Inherited | dragEnter | Dispatched by a component when the user moves the mouse over the component during a drag operation. | UIComponent
Inherited | dragExit | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target. | UIComponent
Inherited | dragOver | Dispatched by a component when the user moves the mouse while over the component during a drag operation. | UIComponent
Inherited | effectEnd | Dispatched after an effect ends. | UIComponent
Inherited | effectStart | Dispatched just before an effect starts. | UIComponent
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | enterState | Dispatched after the component has returned to the root view state. | UIComponent
Inherited | exitState | Dispatched before the component exits from the root view state. | UIComponent
Inherited | focusIn | Dispatched after a display object gains focus. | InteractiveObject
Inherited | focusOut | Dispatched after a display object loses focus. | InteractiveObject
Inherited | hide | Dispatched when an object's state changes from visible to invisible. | UIComponent
Inherited | initialize | Dispatched when the component has finished its construction and has all initialization properties set. | UIComponent
Inherited | invalid | Dispatched when a component is monitored by a Validator and the validation failed. | UIComponent
Inherited | keyDown | Dispatched when the user presses a key. | InteractiveObject
Inherited | keyFocusChange | Dispatched when the user attempts to change focus by using keyboard navigation. | InteractiveObject
Inherited | keyUp | Dispatched when the user releases a key. | InteractiveObject
Inherited | mouseDown | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseDownOutside | Dispatched from a component opened using the PopUpManager when the user clicks outside it. | UIComponent
Inherited | mouseFocusChange | Dispatched when the user attempts to change focus by using a pointer device. | InteractiveObject
Inherited | mouseMove | Dispatched when a user moves the pointing device while it is over an InteractiveObject. | InteractiveObject
Inherited | mouseOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | mouseOver | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseUp | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheel | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window. | InteractiveObject
Inherited | mouseWheelOutside | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it. | UIComponent
Inherited | move | Dispatched when the object has moved. | UIComponent
Inherited | preinitialize | Dispatched at the beginning of the component initialization sequence. | UIComponent
Inherited | remove | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method. | UIComponent
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Inherited | resize | Dispatched when the component is resized. | UIComponent
Inherited | rollOut | Dispatched when the user moves a pointing device away from an InteractiveObject instance. | InteractiveObject
Inherited | rollOver | Dispatched when the user moves a pointing device over an InteractiveObject instance. | InteractiveObject
Inherited | show | Dispatched when an object's state changes from invisible to visible. | UIComponent
Inherited | tabChildrenChange | Dispatched when the value of the object's tabChildren flag changes. | InteractiveObject
Inherited | tabEnabledChange | Dispatched when the object's tabEnabled flag changes. | InteractiveObject
Inherited | tabIndexChange | Dispatched when the value of the object's tabIndex property changes. | InteractiveObject
Inherited | toolTipCreate | Dispatched by the component when it is time to create a ToolTip. | UIComponent
Inherited | toolTipEnd | Dispatched by the component when its ToolTip has been hidden and will be discarded soon. | UIComponent
Inherited | toolTipHide | Dispatched by the component when its ToolTip is about to be hidden. | UIComponent
Inherited | toolTipShow | Dispatched by the component when its ToolTip is about to be shown. | UIComponent
Inherited | toolTipShown | Dispatched by the component when its ToolTip has been shown. | UIComponent
Inherited | toolTipStart | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it. | UIComponent
Inherited | updateComplete | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed). | UIComponent
Inherited | valid | Dispatched when a component is monitored by a Validator and the validation succeeded. | UIComponent
Inherited | valueCommit | Dispatched when values are changed programmatically or by user interaction. | UIComponent
Styles
Hide Inherited Styles
Show Inherited Styles
Style |  | Description | Defined by
Inherited | bottom | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container. | UIComponent
Inherited | errorColor | Type: uint Format: Color CSS Inheritance: yes Color of the component highlight when validation fails.. | UIComponent
Inherited | focusBlendMode | Type: String CSS Inheritance: no Blend mode used by the focus rectangle. | UIComponent
Inherited | focusSkin | Type: Class CSS Inheritance: no Skin used to draw the focus rectangle. | UIComponent
Inherited | focusThickness | Type: Number Format: Length CSS Inheritance: no Thickness, in pixels, of the focus rectangle outline. | UIComponent
Inherited | horizontalCenter | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Inherited | left | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component. | UIComponent
Inherited | right | Type: Number Format: Length CSS Inheritance: no The horizontal distance in pixels from the right edge of the component to the right edge of its parent container. | UIComponent
Inherited | themeColor | Type: uint Format: Color CSS Inheritance: yes Theme color of a component. | UIComponent
Inherited | top | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component. | UIComponent
Inherited | verticalCenter | Type: Number Format: Length CSS Inheritance: no The vertical distance in pixels from the center of the component's parent container to the center of the component. | UIComponent
Effects
Hide Inherited Effects
Show Inherited Effects
Effect |  | Description | Defined by
Inherited | addedEffect | Triggering event: added Played when the component is added as a child to a Container. | UIComponent
Inherited | creationCompleteEffect | Triggering event: creationComplete Played when the omponent is created. | UIComponent
Inherited | focusInEffect | Triggering event: focusIn Played when the component gains keyboard focus. | UIComponent
Inherited | focusOutEffect | Triggering event: focusOut Played when the component loses keyboard focus. | UIComponent
Inherited | hideEffect | Triggering event: hide Played when the component becomes invisible. | UIComponent
Inherited | mouseDownEffect | Triggering event: mouseDown Played when the user presses the mouse button while over the component. | UIComponent
Inherited | mouseUpEffect | Triggering event: mouseUp Played when the user releases the mouse button while over the component. | UIComponent
Inherited | moveEffect | Triggering event: move Played when the component is moved. | UIComponent
Inherited | removedEffect | Triggering event: removed Played when the component is removed from a Container. | UIComponent
Inherited | resizeEffect | Triggering event: resize Played when the component is resized. | UIComponent
Inherited | rollOutEffect | Triggering event: rollOut Played when the user rolls the mouse so it is no longer over the component. | UIComponent
Inherited | rollOverEffect | Triggering event: rollOver Played when the user rolls the mouse over the component. | UIComponent
Inherited | showEffect | Triggering event: show Played when the component becomes visible. | UIComponent
Public Constants
Hide Inherited Public Constants
Show Inherited Public Constants
Constant |  | Defined by
Inherited | DEFAULT_MAX_HEIGHT : Number = 10000 [static] The default value for the maxHeight property. | UIComponent
Inherited | DEFAULT_MAX_WIDTH : Number = 10000 [static] The default value for the maxWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_HEIGHT : Number = 22 [static] The default value for the measuredHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_HEIGHT : Number = 22 [static] The default value for the measuredMinHeight property. | UIComponent
Inherited | DEFAULT_MEASURED_MIN_WIDTH : Number = 40 [static] The default value for the measuredMinWidth property. | UIComponent
Inherited | DEFAULT_MEASURED_WIDTH : Number = 160 [static] The default value for the measuredWidth property. | UIComponent
Constructor detail
SwatchSkin () constructor
public function SwatchSkin()

Constructor.


mx.skins.halo.TabSkin (Flex™ 2 Language Reference)

Class TabSkin | Properties | Methods | Events
Package | mx.skins.halo
Class | public class TabSkin
Inheritance | TabSkin Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for all the states of a Tab in a TabNavigator or TabBar.

See also

TabBar control

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TabSkin()
Constructor.
TabSkin
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
TabSkin () constructor
public function TabSkin()

Constructor.


mx.skins.halo.TitleBackground (Flex™ 2 Language Reference)

Class TitleBackground | Properties | Methods | Events
Package | mx.skins.halo
Class | public class TitleBackground
Inheritance | TitleBackground Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for a title bar area of a Panel.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
TitleBackground()
Constructor.
TitleBackground
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
TitleBackground () constructor
public function TitleBackground()

Constructor.


mx.skins.halo.ToolTipBorder (Flex™ 2 Language Reference)

Class ToolTipBorder | Properties | Methods | Events
Package | mx.skins.halo
Class | public class ToolTipBorder
Inheritance | ToolTipBorder Inheritance RectangularBorder Inheritance Border Inheritance ProgrammaticSkin Inheritance FlexShape Inheritance Shape Inheritance DisplayObject Inheritance EventDispatcher Inheritance Object

The skin for a ToolTip.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | accessibilityProperties : AccessibilityProperties The current accessibility options for this display object. | DisplayObject
Inherited | alpha : Number Indicates the alpha transparency value of the object specified. | DisplayObject
Inherited | blendMode : String A value from the BlendMode class that specifies which blend mode to use. | DisplayObject
Inherited | borderMetrics : EdgeMetrics The thickness of the border edges. | Border
Inherited | cacheAsBitmap : Boolean If set to true, Flash Player caches an internal bitmap representation of the display object. | DisplayObject
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | filters : Array An indexed array that contains each filter object currently associated with the display object. | DisplayObject
Inherited | graphics : Graphics Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur. | Shape
Inherited | height : Number Indicates the height of the display object, in pixels. | DisplayObject
Inherited | initialized : Boolean A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required). | ProgrammaticSkin
Inherited | loaderInfo : LoaderInfo Returns a LoaderInfo object containing information about loading the file to which this display object belongs. | DisplayObject
Inherited | mask : DisplayObject The calling display object is masked by the specified mask object. | DisplayObject
Inherited | measuredHeight : Number The measured height of this object. | ProgrammaticSkin
Inherited | measuredWidth : Number The measured width of this object. | ProgrammaticSkin
Inherited | mouseX : Number Indicates the x coordinate of the mouse position, in pixels. | DisplayObject
Inherited | mouseY : Number Indicates the y coordinate of the mouse position, in pixels. | DisplayObject
Inherited | name : String Indicates the instance name of the DisplayObject. | DisplayObject
Inherited | nestLevel : int Depth of this object in the containment hierarchy. | ProgrammaticSkin
Inherited | opaqueBackground : Object Specifies whether the display object is opaque with a certain background color. | DisplayObject
Inherited | parent : DisplayObjectContainer Indicates the DisplayObjectContainer object that contains this display object. | DisplayObject
Inherited | processedDescriptors : Boolean Set to true after immediate or deferred child creation, depending on which one happens. | ProgrammaticSkin
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | root : DisplayObject For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file. | DisplayObject
Inherited | rotation : Number Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation. | DisplayObject
Inherited | scale9Grid : Rectangle The current scaling grid that is in effect. | DisplayObject
Inherited | scaleX : Number Indicates the horizontal scale (percentage) of the object as applied from the registration point. | DisplayObject
Inherited | scaleY : Number Indicates the vertical scale (percentage) of an object as applied from the registration point of the object. | DisplayObject
Inherited | scrollRect : Rectangle The scroll rectangle bounds of the display object. | DisplayObject
Inherited | stage : Stage The Stage of the display object. | DisplayObject
Inherited | styleName : Object A parent component used to obtain style values. | ProgrammaticSkin
Inherited | transform : Transform An object with properties pertaining to a display object's matrix, color transform, and pixel bounds. | DisplayObject
Inherited | updateCompletePendingFlag : Boolean A flag that determines if an object has been through all three phases of layout validation (provided that any were required). | ProgrammaticSkin
Inherited | visible : Boolean Whether or not the display object is visible. | DisplayObject
Inherited | width : Number Indicates the width of the display object, in pixels. | DisplayObject
Inherited | x : Number Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Inherited | y : Number Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer. | DisplayObject
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ToolTipBorder()
Constructor.
ToolTipBorder
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
getBounds(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
DisplayObject
Inherited
getRect(targetCoordinateSpace:DisplayObject):Rectangle
Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
DisplayObject
Inherited
getStyle(styleProp:String):*
Returns the value of the specified style property.
ProgrammaticSkin
Inherited
globalToLocal(point:Point):Point
Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
DisplayObject
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
hitTestObject(obj:DisplayObject):Boolean
Evaluates the display object to see if it overlaps or intersects with the obj display object.
DisplayObject
Inherited
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean = false):Boolean
Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
DisplayObject
Inherited
invalidateDisplayList():void
Marks a component so that its updateDisplayList() method gets called during a later screen update.
ProgrammaticSkin
Inherited
invalidateProperties():void
Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
ProgrammaticSkin
Inherited
invalidateSize():void
Calling this method results in a call to the component's validateSize() method before the display list is rendered.
ProgrammaticSkin
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
localToGlobal(point:Point):Point
Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
DisplayObject
Inherited
move(x:Number, y:Number):void
Moves this object to the specified x and y coordinates.
ProgrammaticSkin
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setActualSize(newWidth:Number, newHeight:Number):void
Sets the height and width of this object.
ProgrammaticSkin
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
styleChanged(styleProp:String):void
Whenever any style changes, redraw this skin.
ProgrammaticSkin
Inherited
toString():String
Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
FlexShape
Inherited
validateDisplayList():void
This function is called by the LayoutManager when it's time for this control to draw itself.
ProgrammaticSkin
Inherited
validateNow():void
Validate and update the properties and layout of this object and redraw it, if necessary.
ProgrammaticSkin
Inherited
validateProperties():void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
validateSize(recursive:Boolean = false):void
This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
ProgrammaticSkin
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object = null, color:Object = null, alpha:Object = null, gradientMatrix:Matrix = null, gradientType:String = "linear", gradientRatios:Array = null, hole:Object = null):void Programatically draws a rectangle into this skin's Graphics object. | ProgrammaticSkin
Inherited | horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a horizontal gradient matrix. | ProgrammaticSkin
Inherited | rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number):Matrix Utility function to create a rotated gradient matrix. | ProgrammaticSkin
Inherited | updateDisplayList(unscaledWidth:Number, unscaledHeight:Number):void Programmatically draws the graphics for this skin. | ProgrammaticSkin
Inherited | verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number):Matrix Utility function to create a vertical gradient matrix. | ProgrammaticSkin
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | activate | Dispatched when Flash Player gains operating system focus and becomes active. | DisplayObject
Inherited | added | Dispatched when a display object is added to the display list. | DisplayObject
Inherited | deactivate | Dispatched when Flash Player loses operating system focus and is becoming inactive. | DisplayObject
Inherited | enterFrame | Dispatched when the playhead is entering a new frame. | DisplayObject
Inherited | removed | Dispatched when a display object is about to be removed from the display list. | DisplayObject
Inherited | render | Dispatched when the display list is about to be updated and rendered. | DisplayObject
Constructor detail
ToolTipBorder () constructor
public function ToolTipBorder()

Constructor.


mx.states Summary (Flex™ 2 Language Reference)

Package mx.states | Interfaces | Classes

The mx.states package contains the classes to support view states. Each view state, represented by a State object, can override the characteristics of the base (default) state. Flex can be in only one view state at a time, and you set the view state by using the UIObject currentState property or setCurrentState() method. The package includes classes to add or delete child display objects, and to set properties, styles, and event handlers on components.

Interfaces
Interface | Description
IOverride | The IOverride interface is used for view state overrides.
Classes
Class | Description
AddChild | The AddChild class adds a child display object, such as a component, to a container as part of a view state.
RemoveChild | The RemoveChild class removes a child display object, such as a component, from a container as part of a view state.
SetEventHandler | The SetEventHandler class specifies an event handler that is active only during a particular view state.
SetProperty | The SetProperty class specifies a property value that is in effect only during the parent view state.
SetStyle | The SetStyle class specifies a style that is in effect only during the parent view state.
State | The State class defines a view state, a particular view of a component.
Transition | The Transition class defines a set of effects that play in response to a change of view state.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.states.AddChild (Flex™ 2 Language Reference)

View comments | RSS feed
Class AddChild | Properties | Methods | Examples
Package | mx.states
Class | public class AddChild
Inheritance | AddChild Inheritance Object
Implements | IOverride

The AddChild class adds a child display object, such as a component, to a container as part of a view state. You use this class in the overrides property of the State class.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:AddChild> tag has the following attributes:

  <mx:AddChild
  Properties
  target="null"
  targetFactory="null"
  creationPolicy="auto"
  position="lastChild"
  relativeTo="parent of the State object"
  />

Default MXML Property targetFactory

View the examples.

See also

mx.states.State
mx.states.RemoveChild
mx.states.Transition
mx.effects.AddChildAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | creationPolicy : String The creation policy for this child. | AddChild
 | position : String The position of the child in the display list, relative to the object specified by the relativeTo property. | AddChild
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | relativeTo : UIComponent The object relative to which the child is added. | AddChild
 | target : DisplayObject The child to be added. | AddChild
 | targetFactory : IDeferredInstance The factory that creates the child. | AddChild
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | AddChild(relativeTo:UIComponent = null, target:DisplayObject = null, position:String = "lastChild") Constructor. | AddChild
 | apply(parent:UIComponent):void Applies the override. | AddChild
 | createInstance():void Creates the child instance from the factory. | AddChild
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialize():void Initializes the override. | AddChild
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | remove(parent:UIComponent):void Removes the override. | AddChild
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
creationPolicy property
creationPolicy:String [read-write]

The creation policy for this child. This property determines when the targetFactory will create the instance of the child. Flex uses this properthy only if you specify a targetFactory property. The following values are valid:

Value | Meaning
auto | (default)Create the instance the first time it is needed.
all | Create the instance when the application started up.
none | Do not automatically create the instance. You must call the createInstance() method to create the instance.

The default value is "auto".

Implementation
    public function get creationPolicy():String
    public function set creationPolicy(value:String):void
position property
public var position:String

The position of the child in the display list, relative to the object specified by the relativeTo property. Valid values are "before", "after", "firstChild", and "lastChild".

The default value is "lastChild".

relativeTo property
public var relativeTo:UIComponent

The object relative to which the child is added. This property is used in conjunction with the position property. This property is optional; if you omit it, Flex uses the immediate parent of the State object, that is, the component that has the states property, or <mx:states%gt;tag that specifies the State object.

target property
target:DisplayObject [read-write]

The child to be added. If you set this property, the child instance is created at app startup. Setting this property is equivalent to setting a targetFactory property with a creationPolicy of "all".

Do not set this property if you set the targetFactory property.

Implementation
    public function get target():DisplayObject
    public function set target(value:DisplayObject):void
targetFactory property
targetFactory:IDeferredInstance [read-write]

The factory that creates the child. You can specify either of the following items:

  • A factory class that implements the IDeferredInstance interface and creates the child instance or instances.
  • A Flex component, (that is, any class that is a subclass of the UIComponent class), such as the Button contol. If you use a Flex component, the Flex compiler automatically wraps the component in a factory class.

If you set this property, the child is instantiated at the time determined by the creationPolicy property.

Do not set this property if you set the target property. This propety is the AddChild class default property. Setting this property with a creationPolicy of "all" is equivalent to setting a target property.

Implementation
    public function get targetFactory():IDeferredInstance
    public function set targetFactory(value:IDeferredInstance):void
Constructor detail
AddChild () constructor
public function AddChild(relativeTo:UIComponent = null, target:DisplayObject = null, position:String = "lastChild")

Constructor.

Parameters
relativeTo:UIComponent (default = null) — The component relative to which child is added.
target:DisplayObject (default = null) — The child object. All Flex components are subclasses of the DisplayObject class.
position:String (default = "lastChild") — the location in the display list of the target relative to the relativeTo component. Must be one of the following: "firstChild", "lastChild", "before" or "after".
Method detail
apply () method
public function apply(parent:UIComponent):void

Applies the override. Flex retains the original value, so that it can restore the value later in the remove() method.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
createInstance () method
public function createInstance():void

Creates the child instance from the factory. You must use this method only if you specify a targetFactory property and a creationPolicy value of "none". Flex automatically calls this method if the creationPolicy property value is "auto" or "all". If you call this method multiple times, the child instance is created only on the first call.

initialize () method
public function initialize():void

Initializes the override. Flex calls this method before the first call to the apply() method, so you put one-time initialization code for the override in this method.

Flex calls this method automatically when the state is entered. It should not be called directly.

remove () method
public function remove(parent:UIComponent):void

Removes the override. The value remembered in the apply() method is restored.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
Examples
StatesExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the States class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

knallore_adobe said on Jun 30, 2006 at 7:03 AM :
typo in the relativeTo property description:

or <mx:states%gt;tag should be or <mx:states>tag

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/mx/states/AddChild.html


mx.states.IOverride (Flex™ 2 Language Reference)

Interface IOverride | Methods
Package | mx.states
Interface | public interface IOverride
Implementors | AddChild, RemoveChild, SetEventHandler, SetProperty, SetStyle

The IOverride interface is used for view state overrides. All entries in the State class overrides property array must implement this interface.

See also

mx.states.State

Public Methods
Method |  | Defined by
 | apply(parent:UIComponent):void Applies the override. | IOverride
 | initialize():void Initializes the override. | IOverride
 | remove(parent:UIComponent):void Removes the override. | IOverride
Method detail
apply () method
public function apply(parent:UIComponent):void

Applies the override. Flex retains the original value, so that it can restore the value later in the remove() method.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
initialize () method
public function initialize():void

Initializes the override. Flex calls this method before the first call to the apply() method, so you put one-time initialization code for the override in this method.

Flex calls this method automatically when the state is entered. It should not be called directly.

remove () method
public function remove(parent:UIComponent):void

Removes the override. The value remembered in the apply() method is restored.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.


mx.states.RemoveChild (Flex™ 2 Language Reference)

Class RemoveChild | Properties | Methods | Examples
Package | mx.states
Class | public class RemoveChild
Inheritance | RemoveChild Inheritance Object
Implements | IOverride

The RemoveChild class removes a child display object, such as a component, from a container as part of a view state. The child is only removed from the display list, it is not deleted. You use this class in the overrides property of the State class.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:RemoveChild> tag has the following attributes:

  <mx:RemoveChild
  Properties
  target="null"
  />

View the examples.

See also

mx.states.State
mx.states.AddChild
mx.states.Transition
mx.effects.RemoveChildAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | target : DisplayObject The child to remove from the view. | RemoveChild
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RemoveChild(target:DisplayObject = null) Constructor. | RemoveChild
 | apply(parent:UIComponent):void Applies the override. | RemoveChild
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialize():void IOverride interface method; this class implements it as an empty method. | RemoveChild
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | remove(parent:UIComponent):void Removes the override. | RemoveChild
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
target property
public var target:DisplayObject

The child to remove from the view.

Constructor detail
RemoveChild () constructor
public function RemoveChild(target:DisplayObject = null)

Constructor.

Parameters
target:DisplayObject (default = null) — The child to remove from the view.
Method detail
apply () method
public function apply(parent:UIComponent):void

Applies the override. Flex retains the original value, so that it can restore the value later in the remove() method.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
initialize () method
public function initialize():void

IOverride interface method; this class implements it as an empty method.

Initializes the override. Flex calls this method before the first call to the apply() method, so you put one-time initialization code for the override in this method.

Flex calls this method automatically when the state is entered. It should not be called directly.

remove () method
public function remove(parent:UIComponent):void

Removes the override. The value remembered in the apply() method is restored.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
Examples
StatesExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the States class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.states.SetEventHandler (Flex™ 2 Language Reference)

Class SetEventHandler | Properties | Methods | Events
Package | mx.states
Class | public class SetEventHandler
Inheritance | SetEventHandler Inheritance EventDispatcher Inheritance Object
Implements | IOverride

The SetEventHandler class specifies an event handler that is active only during a particular view state. For example, you might define a Button control that uses one event handler in the base view state, but uses a different event handler when you change view state.

You use this class in the overrides property of the State class.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SetEventHanlder> tag has the following attributes:

  <mx:SetEventHandler
  Properties
  name="null"
  handlerFunction="null"
  target="null"

  Events
  handler=No default
  />

See also

mx.states.State
mx.states.SetProperty
mx.states.SetStyle

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | handlerFunction : Function The handler function for the event. | SetEventHandler
 | name : String The name of the event whose handler is being set. | SetEventHandler
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | target : EventDispatcher The component that dispatches the event. | SetEventHandler
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SetEventHandler(target:EventDispatcher = null, name:String = null)
Constructor.
SetEventHandler
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
apply(parent:UIComponent):void
Applies the override.
SetEventHandler
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
initialize():void
IOverride interface method; this class implements it as an empty method.
SetEventHandler
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
remove(parent:UIComponent):void
Removes the override.
SetEventHandler
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | handler | The event handler function to execute in response to the event that is specified by the name property. | SetEventHandler
Property detail
handlerFunction property
public var handlerFunction:Function

The handler function for the event. This property is intended for developers who use ActionScript to create and access view states. In MXML, you can use the equivalent handler event attribute; do not use both in a single MXML tag.

The default value is null.

name property
public var name:String

The name of the event whose handler is being set. You must set this property, either in the SetEventHandler constructor or by setting the property value directly.

target property
public var target:EventDispatcher

The component that dispatches the event. If the property value is null, Flex uses the immediate parent of the <mx:states> tag.

The default value is null.

Constructor detail
SetEventHandler () constructor
public function SetEventHandler(target:EventDispatcher = null, name:String = null)

Constructor.

Parameters
target:EventDispatcher (default = null) — The object that dispatches the event to be handled. By default, Flex uses the immediate parent of the State object.
name:String (default = null) — The event type for which to set the handler.
Method detail
apply () method
public function apply(parent:UIComponent):void

Applies the override. Flex retains the original value, so that it can restore the value later in the remove() method.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
initialize () method
public function initialize():void

IOverride interface method; this class implements it as an empty method.

Initializes the override. Flex calls this method before the first call to the apply() method, so you put one-time initialization code for the override in this method.

Flex calls this method automatically when the state is entered. It should not be called directly.

remove () method
public function remove(parent:UIComponent):void

Removes the override. The value remembered in the apply() method is restored.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
Event detail
handler event
Event object type: Object

The event handler function to execute in response to the event that is specified by the name property.

Do not specify the handler property and the handlerFunction property in a single <mx:SetEventHandler> tag.

Flex does not dispatch a handler event. You use the handler key word only as an MXML attribte. When you use the handler handler attribute, you can specify a method that takes multiple parameters, not just the Event object; also, you can specify the handler code in-line in the MXML tag.


mx.states.SetProperty (Flex™ 2 Language Reference)

Class SetProperty | Properties | Methods | Examples
Package | mx.states
Class | public class SetProperty
Inheritance | SetProperty Inheritance Object
Implements | IOverride

The SetProperty class specifies a property value that is in effect only during the parent view state. You use this class in the overrides property of the State class.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SetProperty> tag has the following attributes:

  <mx:SetProperty
  Properties
  name="null"
  target="null"

  value="undefined"
  />

View the examples.

See also

mx.states.State
mx.states.SetEventHandler
mx.states.SetStyle
mx.effects.SetPropertyAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | name : String The name of the property to change. | SetProperty
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | target : Object The object containing the property to be changed. | SetProperty
 | value : * The new value for the property. | SetProperty
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SetProperty(target:Object = null, name:String = null, value:*) Constructor. | SetProperty
 | apply(parent:UIComponent):void Applies the override. | SetProperty
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialize():void IOverride interface method; this class implements it as an empty method. | SetProperty
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | remove(parent:UIComponent):void Removes the override. | SetProperty
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
name property
public var name:String

The name of the property to change. You must set this property, either in the SetProperty constructor or by setting the property value directly.

target property
public var target:Object

The object containing the property to be changed. If the property value is null, Flex uses the immediate parent of the State object.

The default value is null.

value property
public var value:*

The new value for the property.

The default value is undefined.

Constructor detail
SetProperty () constructor
public function SetProperty(target:Object = null, name:String = null, value:*)

Constructor.

Parameters
target:Object (default = null) — The object whose property is being set. By default, Flex uses the immediate parent of the State object.
name:String (default = null) — The property to set.
value:* — The value of the property in the view state.
Method detail
apply () method
public function apply(parent:UIComponent):void

Applies the override. Flex retains the original value, so that it can restore the value later in the remove() method.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
initialize () method
public function initialize():void

IOverride interface method; this class implements it as an empty method.

Initializes the override. Flex calls this method before the first call to the apply() method, so you put one-time initialization code for the override in this method.

Flex calls this method automatically when the state is entered. It should not be called directly.

remove () method
public function remove(parent:UIComponent):void

Removes the override. The value remembered in the apply() method is restored.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
Examples
StatesExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the States class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.states.SetStyle (Flex™ 2 Language Reference)

Class SetStyle | Properties | Methods | Examples
Package | mx.states
Class | public class SetStyle
Inheritance | SetStyle Inheritance Object
Implements | IOverride

The SetStyle class specifies a style that is in effect only during the parent view state. You use this class in the overrides property of the State class.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SetStyle> tag has the following attributes:

  <mx:SetStyle
  Properties
  name="null"
  target="null"

  value"null"
  />

View the examples.

See also

mx.states.State
mx.states.SetEventHandler
mx.states.SetProperty
mx.effects.SetStyleAction

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | name : String The name of the style to change. | SetStyle
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | target : IStyleClient The object whose style is being changed. | SetStyle
 | value : Object The new value for the style. | SetStyle
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | SetStyle(target:IStyleClient = null, name:String = null, value:Object = null) Constructor. | SetStyle
 | apply(parent:UIComponent):void Applies the override. | SetStyle
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | initialize():void IOverride interface method; this class implements it as an empty method. | SetStyle
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | remove(parent:UIComponent):void Removes the override. | SetStyle
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
name property
public var name:String

The name of the style to change. You must set this property, either in the SetStyle constructor or by setting the property value directly.

target property
public var target:IStyleClient

The object whose style is being changed. If the property value is null, Flex uses the immediate parent of the State object.

The default value is null.

value property
public var value:Object

The new value for the style.

The default value is null.

Constructor detail
SetStyle () constructor
public function SetStyle(target:IStyleClient = null, name:String = null, value:Object = null)

Constructor.

Parameters
target:IStyleClient (default = null) — The object whose style is being set. By default, Flex uses the immediate parent of the State object.
name:String (default = null) — The style to set.
value:Object (default = null) — The value of the style in the view state.
Method detail
apply () method
public function apply(parent:UIComponent):void

Applies the override. Flex retains the original value, so that it can restore the value later in the remove() method.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
initialize () method
public function initialize():void

IOverride interface method; this class implements it as an empty method.

Initializes the override. Flex calls this method before the first call to the apply() method, so you put one-time initialization code for the override in this method.

Flex calls this method automatically when the state is entered. It should not be called directly.

remove () method
public function remove(parent:UIComponent):void

Removes the override. The value remembered in the apply() method is restored.

This method is called automatically when the state is entered. It should not be called directly.

Parameters
parent:UIComponent — The parent of the state object containing this override. The override should use this as its target if an explicit target was not specified.
Examples
StatesExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the States class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.states.State (Flex™ 2 Language Reference)

Class State | Properties | Methods | Events | Examples
Package | mx.states
Class | public class State
Inheritance | State Inheritance EventDispatcher Inheritance Object

The State class defines a view state, a particular view of a component. For example, a product thumbnail could have two view states; a base view state with minimal information, and a rich view state with additional information. The overrides property specifies a set of child classes to add or remove from the base view state, and properties, styles, and event handlers to set when the view state is in effect.

You use the State class in the states property of Flex components. You can only specify a states property at the root of an application or a custom control, not on child controls.

You enable a view state by setting a component's currentState property.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:State> tag has the following attributes:

  <mx:State
  Properties
  basedOn="null"
  name="null"
  overrides="null"
  />

Default MXML Property overrides

View the examples.

See also

mx.states.AddChild
mx.states.RemoveChild
mx.states.SetEventHandler
mx.states.SetProperty
mx.states.SetStyle
mx.states.Transition

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | basedOn : String The name of the view state upon which this view state is based, or null if this view state is not based on a named view state. | State
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | name : String The name of the view state. | State
 | overrides : Array The overrides for this view state, as an Array of objects that implement the IOverride interface. | State
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
State()
Constructor.
State
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Events
Event |  | Summary | Defined by
 | enterState | Dispatched when the view state has been entered. | State
 | exitState | Dispatched before a view state is exited. | State
Property detail
basedOn property
public var basedOn:String

The name of the view state upon which this view state is based, or null if this view state is not based on a named view state. If this value is null, the view state is based on a root state that consists of the properties, styles, event handlers, and children that you define for a component without using a State class.

The default value is null.

name property
public var name:String

The name of the view state. State names must be unique for a given component. This property must be set.

overrides property
public var overrides:Array

The overrides for this view state, as an Array of objects that implement the IOverride interface. These overrides are applied in order when the state is entered, and removed in reverse order when the state is exited.

The following Flex classes implement the IOverride interface and let you define the view state characteristics:

  • AddChild
  • RemoveChild
  • SetEventHandler
  • SetProperty
  • SetStyle

The overrides property is the default property of the State class. You can omit the <mx:overrides> tag and its child <mx:Array>tag if you use MXML tag syntax to define the overrides.

Constructor detail
State () constructor
public function State()

Constructor.

Event detail
enterState event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.ENTER_STATE

Dispatched when the view state has been entered. This event is dispatched after the changes to the base view state have been applied.

The FlexEvent.ENTER_STATE constant defines the value of the type property of the event object for a enterState event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
exitState event
Event object type: mx.events.FlexEvent
FlexEvent.type property = mx.events.FlexEvent.EXIT_STATE

Dispatched before a view state is exited. This event is dispatched before the changes to the base view state have been removed.

The FlexEvent.EXIT_STATE constant defines the value of the type property of the event object for a exitState event.

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Examples
StatesExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the States class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.states.Transition (Flex™ 2 Language Reference)

Class Transition | Properties | Methods | Examples
Package | mx.states
Class | public class Transition
Inheritance | Transition Inheritance Object

The Transition class defines a set of effects that play in response to a change of view state. While a view state definition defines how to change states, a transition defines the order in which visual changes occur during the state change.

To define a transition, you set the transition property of an Application to an Array of Transition objects.

You use the toState and fromState properties of the Transition class to specify the state changes that trigger the transition. By default, both the fromState and toState properties are set to "*", meaning apply the transition to any changes to the view state.

You can use the fromState property to explicitly specify a view state that your are changing from, and the toState property to explicitly specify a view state that you are changing to. If a state change matches two transitions, the toState property takes precedence over the fromState property. If more than one transition match, Flex uses the first definition in the transition array.

You use the effect property to specify the Effect object to play when you apply the transition. Typically, this is a composite effect object, such as the Parallel or Sequence effect, that contains multiple effects, as the following example shows:

   <mx:Transition id="myTransition" fromState="*" toState="*">
    <mx:Parallel>
        ...
    </mx:Parallel>
  </mx:Transition>

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:Transition> tag defines the following attributes:

  <mx:Transition
    Properties
    id="ID"
    effect=""
    fromState="*"
    toState="*"
  />

Default MXML Property effect

View the examples.

See also

mx.effects.AddChildAction
mx.effects.RemoveChildAction
mx.effects.SetPropertyAction
mx.effects.SetStyleAction
Defining transitions
Transition tips and troubleshooting
Example: Creating a transition effect

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | effect : Effect The Effect object to play when you apply the transition. | Transition
 | fromState : String = "*" A String specifying the view state that your are changing from when you apply the transition. | Transition
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | toState : String = "*" A String specifying the view state that you are changing to when you apply the transition. | Transition
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | Transition() Constructor. | Transition
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
effect property
public var effect:Effect

The Effect object to play when you apply the transition. Typically, this is a composite effect object, such as the Parallel or Sequence effect, that contains multiple effects.

The effect property is the default property of the Transition class. You can omit the <mx:effect> tag if you use MXML tag syntax.

fromState property
public var fromState:String = "*"

A String specifying the view state that your are changing from when you apply the transition. The default value is "*", meaning any view state.

You can set this property to an empty string, "", which corresponds to the base view state.

The default value is "&#42;".

toState property
public var toState:String = "*"

A String specifying the view state that you are changing to when you apply the transition. The default value is "*", meaning any view state.

You can set this property to an empty string, "", which corresponds to the base view state.

The default value is "&#42;".

Constructor detail
Transition () constructor
public function Transition()

Constructor.

Examples
TransitionExample
<?xml version="1.0" ?>
<!-- Simple example to demonstrate the Transition class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <!-- Define one view state, in addition to the base state.-->
    <mx:states>
        <mx:State name="Register">
            <mx:AddChild relativeTo="{loginForm}" position="lastChild">
                <mx:target>
                    <mx:FormItem id="confirm" label="Confirm:">
                        <mx:TextInput/>
                    </mx:FormItem>
                </mx:target>
            </mx:AddChild>
            <mx:SetProperty target="{loginPanel}" name="title" value="Register"/>
            <mx:SetProperty target="{loginButton}" name="label" value="Register"/>
            <mx:SetStyle target="{loginButton}"
                name="color" value="blue"/>
            <mx:RemoveChild target="{registerLink}"/>
            <mx:AddChild relativeTo="{spacer1}" position="before">
                <mx:target>
                    <mx:LinkButton id="loginLink" label="Return to Login" click="currentState=''"/>
                </mx:target>
            </mx:AddChild>
        </mx:State>
    </mx:states>

    <mx:transitions>
        <!-- Define the transition from the base state to the Register state.-->
        <mx:Transition id="toRegister" fromState="*" toState="Register">
            <mx:Sequence targets="{[loginPanel, registerLink, confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>

        <!-- Define the transition from the Register state to the base state.-->
        <mx:Transition id="toDefault" fromState="Register" toState="*">
            <mx:Sequence targets="{[loginPanel, registerLink,
                    confirm, loginLink, spacer1]}">
                <mx:RemoveChildAction/>
                <mx:SetPropertyAction target="{loginPanel}" name="title"/>
                <mx:SetPropertyAction  target="{loginButton}" name="label"/>
                <mx:SetStyleAction target="{loginButton}" name="color"/>
                <mx:Resize target="{loginPanel}"/>
                <mx:AddChildAction/>
            </mx:Sequence>
        </mx:Transition>
    </mx:transitions>

    <!-- Define a Panel container that defines the login form.-->
    <mx:Panel title="Login" id="loginPanel"
        horizontalScrollPolicy="off" verticalScrollPolicy="off"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Text width="100%" color="blue"
            text="Click the 'Need to Register?' link to change state. Click the 'Return to Login' link to return to the base state."/>

        <mx:Form id="loginForm" >
            <mx:FormItem label="Username:">
                <mx:TextInput/>
            </mx:FormItem>
            <mx:FormItem label="Password:">
                <mx:TextInput/>
            </mx:FormItem>
        </mx:Form>
        <mx:ControlBar>
            <mx:LinkButton id="registerLink"  label="Need to Register?"
                click="currentState='Register'"/>
            <mx:Spacer width="100%" id="spacer1"/>
            <mx:Button label="Login" id="loginButton"/>
        </mx:ControlBar>
    </mx:Panel>
</mx:Application>


mx.styles Summary (Flex™ 2 Language Reference)

Package mx.styles | Interfaces | Classes

The mx.styles package contains the classes used by the Flex styles components.

Interfaces
Interface | Description
ISimpleStyleClient | This interface describes the properties and methods that an object must implement so that it can participate in the style subsystem.
IStyleClient | This interface describes the properties and methods that an object must implement so that it can fully participate in the style subsystem.
Classes
Class | Description
CSSStyleDeclaration | The CSSStyleDeclaration class represents a set of CSS style rules.
StyleManager The StyleManager class manages the following:
  • Which CSS style properties the class inherits
  • Which style properties are colors, and therefore get special handling
  • A list of strings that are aliases for color values

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.styles.CSSStyleDeclaration (Flex™ 2 Language Reference)

Class CSSStyleDeclaration | Properties | Methods
Package | mx.styles
Class | public class CSSStyleDeclaration
Inheritance | CSSStyleDeclaration Inheritance EventDispatcher Inheritance Object
Subclasses | DataGridColumn

The CSSStyleDeclaration class represents a set of CSS style rules. The MXML compiler automatically generates one CSSStyleDeclaration object for each selector in the CSS files associated with a Flex application.

A CSS rule such as

      Button { color: #FF0000 }
affects every instance of the Button class; a selector like Button is called a type selector and must not start with a dot.

A CSS rule such as

      .redButton { color: #FF0000 }
affects only components whose styleName property is set to ".redButton"; a selector like .redButton is called a class selector and must start with a dot.

You can access the autogenerated CSSStyleDeclaration objects using the StyleManager.getStyleDeclaration() method, passing it either a type selector

  var buttonDeclaration:CSSStyleDeclaration =
      StyleManager.getStyleDeclaration("Button");
or a class selector
  var redButtonStyleDeclaration:CSSStyleDeclaration =
      StyleManager.getStyleDeclaration(".redButton");
8

You can use the getStyle(), setStyle(), and clearStyle() methods to get, set, and clear style properties on a CSSStyleDeclaration.

You can also create and install a CSSStyleDeclaration at run time using the StyleManager.setStyleDeclaration() method:

  var newStyleDeclaration:CSSStyleDeclaration = new CSSStyleDeclaration();
  newStyleDeclaration.setStyle("leftMargin", 50);
  newStyleDeclaration.setStyle("rightMargin", 50);
  StyleManager.setStyleDeclaration(".bigMargins", newStyleDeclaration);

See also

mx.core.UIComponent
mx.styles.StyleManager
Using the StyleManager class

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | defaultFactory : Function This function, if it isn't null, is usually autogenerated by the MXML compiler. | CSSStyleDeclaration
 | factory : Function This function, if it isn't null, is usually autogenerated by the MXML compiler. | CSSStyleDeclaration
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Protected Properties
Property |  | Defined by
 | overrides : Object If the setStyle() method is called on a UIComponent or CSSStyleDeclaration at run time, this object stores the name/value pairs that were set; they override the name/value pairs in the objects produced by the methods specified by the defaultFactory and factory properties. | CSSStyleDeclaration
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CSSStyleDeclaration(selector:String = null)
Constructor.
CSSStyleDeclaration
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
clearStyle(styleProp:String):void
Clears a style property on this CSSStyleDeclaration.
CSSStyleDeclaration
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
getStyle(styleProp:String):*
Gets the value for a specified style property, as determined solely by this CSSStyleDeclaration.
CSSStyleDeclaration
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
setStyle(styleProp:String, newValue:*):void
Sets a style property on this CSSStyleDeclaration.
CSSStyleDeclaration
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Property detail
defaultFactory property
public var defaultFactory:Function

This function, if it isn't null, is usually autogenerated by the MXML compiler. It produce copies of a plain Object, such as { leftMargin: 10, rightMargin: 10 }, containing name/value pairs for style properties; the object is used to build a node of the prototype chain for looking up style properties.

If this CSSStyleDeclaration is owned by a UIComponent written in MXML, this function encodes the style attributes that were specified on the root tag of the component definition.

If the UIComponent was written in ActionScript, this property is null.

factory property
public var factory:Function

This function, if it isn't null, is usually autogenerated by the MXML compiler. It produce copies of a plain Object, such as { leftMargin: 10, rightMargin: 10 }, containing name/value pairs for style properties; the object is used to build a node of the prototype chain for looking up style properties.

If this CSSStyleDeclaration is owned by a UIComponent, this function encodes the style attributes that were specified in MXML for an instance of that component.

overrides property
protected var overrides:Object

If the setStyle() method is called on a UIComponent or CSSStyleDeclaration at run time, this object stores the name/value pairs that were set; they override the name/value pairs in the objects produced by the methods specified by the defaultFactory and factory properties.

Constructor detail
CSSStyleDeclaration () constructor
public function CSSStyleDeclaration(selector:String = null)

Constructor.

Parameters
selector:String (default = null) — If not null, this CSSStyleDeclaration will be registered with the StyleManager using the selector value.
Method detail
clearStyle () method
public function clearStyle(styleProp:String):void

Clears a style property on this CSSStyleDeclaration. This is the same as setting the style value to undefined.

Parameters
styleProp:String — The name of the style property.
getStyle () method
public function getStyle(styleProp:String):*

Gets the value for a specified style property, as determined solely by this CSSStyleDeclaration.

The returned value may be of any type.

The values null, "", false, NaN, and 0 are all valid style values, but the value undefined is not; it indicates that the specified style is not set on this CSSStyleDeclaration. You can use the method StyleManager.isValidStyleValue() to test the value that is returned.

Parameters
styleProp:String — The name of the style property.

Returns
* — The value of the specified style property if set, or undefined if not.
setStyle () method
public function setStyle(styleProp:String, newValue:*):void

Sets a style property on this CSSStyleDeclaration.

Parameters
styleProp:String — The name of the style property.
newValue:* — The value of the style property. The value may be of any type. The values null, "", false, NaN, and 0 are all valid style values, but the value undefined is not. Setting a style property to the value undefined is the same as calling the clearStyle() method.


mx.styles.ISimpleStyleClient (Flex™ 2 Language Reference)

Interface ISimpleStyleClient | Properties | Methods
Package | mx.styles
Interface | public interface ISimpleStyleClient
Subinterfaces | IListItemRenderer, IStyleClient
Implementors | ProgrammaticSkin, UIComponent, UITextField

This interface describes the properties and methods that an object must implement so that it can participate in the style subsystem. This interface is intended to be used by classes that obtain their style values from other objects rather than through locally set values and type selectors. This interface is implemented by ProgrammaticSkin.

See also

mx.styles.IStyleClient
mx.styles.CSSStyleDeclaration

Public Properties
Property |  | Defined by
 | styleName : Object The source of this object's style values. | ISimpleStyleClient
Public Methods
Method |  | Defined by
 | styleChanged(styleProp:String):void Called when the value of a style property is changed. | ISimpleStyleClient
Property detail
styleName property
styleName:Object [read-write]

The source of this object's style values. The value of styleName may be one of three possible types: - A String, such as "headerStyle". The string names a class selector defined in a CSS style sheet. - A CSSStyleDeclaration, such as StyleManager.getStyleDeclaration(".headerStyle"). - A UIComponent. The object implementing this interface inherits all the style values from the referenced UIComponent.

Implementation
    public function get styleName():Object
    public function set styleName(value:Object):void
Method detail
styleChanged () method
public function styleChanged(styleProp:String):void

Called when the value of a style property is changed.

Parameters
styleProp:String — The name of the style property that changed.


mx.styles.IStyleClient (Flex™ 2 Language Reference)

Interface IStyleClient | Properties | Methods
Package | mx.styles
Interface | public interface IStyleClient extends ISimpleStyleClient
Implementors | DataGridItemRenderer, HaloFocusRect, UIComponent

This interface describes the properties and methods that an object must implement so that it can fully participate in the style subsystem. This interface is implemented by UIComponent.

If the object does not need to store style values locally, it can implement the ISimpleStyleClient interface instead.

See also

mx.styles.ISimpleStyleClient
mx.styles.CSSStyleDeclaration

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | className : String [read-only] The name of component class. | IStyleClient
 | inheritingStyles : Object An object containing the inheritable styles for this component. | IStyleClient
 | nonInheritingStyles : Object An object containing the noninheritable styles for this component. | IStyleClient
 | styleDeclaration : CSSStyleDeclaration The style declaration used by this object. | IStyleClient
Inherited | styleName : Object The source of this object's style values. | ISimpleStyleClient
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | clearStyle(styleProp:String):void Deletes a style property from this component instance. | IStyleClient
 | getClassStyleDeclarations():Array Returns an Array of CSSStyleDeclaration objects for the type selector that applies to this component, or null if none exist. | IStyleClient
 | getStyle(styleProp:String):* Gets a style property that has been set anywhere in this component's style lookup chain. | IStyleClient
 | notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void Propagates style changes to the children of this component. | IStyleClient
 | regenerateStyleCache(recursive:Boolean):void Sets up the internal style cache values so that the getStyle() method functions. | IStyleClient
 | registerEffects(effects:Array):void For each effect event, registers the EffectManager as one of the event listeners. | IStyleClient
 | setStyle(styleProp:String, newValue:*):void Sets a style property on this component instance. | IStyleClient
Inherited | styleChanged(styleProp:String):void Called when the value of a style property is changed. | ISimpleStyleClient
Property detail
className property
className:String [read-only]

The name of component class.

Implementation
    public function get className():String
inheritingStyles property
inheritingStyles:Object [read-write]

An object containing the inheritable styles for this component.

Implementation
    public function get inheritingStyles():Object
    public function set inheritingStyles(value:Object):void
nonInheritingStyles property
nonInheritingStyles:Object [read-write]

An object containing the noninheritable styles for this component.

Implementation
    public function get nonInheritingStyles():Object
    public function set nonInheritingStyles(value:Object):void
styleDeclaration property
styleDeclaration:CSSStyleDeclaration [read-write]

The style declaration used by this object.

Implementation
    public function get styleDeclaration():CSSStyleDeclaration
    public function set styleDeclaration(value:CSSStyleDeclaration):void

See also

mx.styles.CSSStyleDeclaration
Method detail
clearStyle () method
public function clearStyle(styleProp:String):void

Deletes a style property from this component instance.

This does not necessarily cause the getStyle() method to return undefined.

Parameters
styleProp:String — Name of the style property.
getClassStyleDeclarations () method
public function getClassStyleDeclarations():Array

Returns an Array of CSSStyleDeclaration objects for the type selector that applies to this component, or null if none exist.

For example, suppose that component MyButton extends Button. This method first looks for a MyButton selector; then, it looks for a Button type selector; finally, it looks for a UIComponent type selector.

Returns
Array — Array of CSSStyleDeclaration objects.
getStyle () method
public function getStyle(styleProp:String):*

Gets a style property that has been set anywhere in this component's style lookup chain.

This same method is used to get any kind of style property, so the value returned may be a Boolean, String, Number, int, uint (for an RGB color), Class (for a skin), or any kind of object. Therefore the return type is specified as

If you are getting a particular style property, you will know its type and will often want to store the result in a variable of that type. You can use either the as operator or coercion to do this. For example:

   var backgroundColor:uint = getStyle("backgroundColor") as int;
   or
   var backgroundColor:uint = int(getStyle("backgroundColor"));

If the style property has not been set anywhere in the style lookup chain, the value returned by the getStyle() method is undefined. Note that undefined is a special value that is not the same as false, the empty String (""), NaN, 0, or null. No valid style value is ever undefined. You can use the static method StyleManager.isValidStyleValue() to test whether the value was set.

Parameters
styleProp:String — Name of the style property.

Returns
* — Style value.
notifyStyleChangeInChildren () method
public function notifyStyleChangeInChildren(styleProp:String, recursive:Boolean):void

Propagates style changes to the children of this component.

Parameters
styleProp:String — Name of the style property.
recursive:Boolean — Propagates style changes to the children's children.
regenerateStyleCache () method
public function regenerateStyleCache(recursive:Boolean):void

Sets up the internal style cache values so that the getStyle() method functions. If this object already has children, then reinitialize the children's style caches.

Parameters
recursive:Boolean — Regenerate children's proto chains.
registerEffects () method
public function registerEffects(effects:Array):void

For each effect event, registers the EffectManager as one of the event listeners.

Parameters
effects:Array — An Array of Strings of effect names.
setStyle () method
public function setStyle(styleProp:String, newValue:*):void

Sets a style property on this component instance.

This may override a style that was set globally.

Calling the setStyle() method can result in decreased performance. Use it only when necessary.

Parameters
styleProp:String — Name of the style property.
newValue:* — New value for the style.


mx.styles.StyleManager (Flex™ 2 Language Reference)

Class StyleManager | Properties | Methods | Constants
Package | mx.styles
Class | public class StyleManager
Inheritance | StyleManager Inheritance Object

The StyleManager class manages the following:
  • Which CSS style properties the class inherits
  • Which style properties are colors, and therefore get special handling
  • A list of strings that are aliases for color values

See also

mx.styles.CSSStyleDeclaration
External style sheets
Using the StyleManager class
Applying programmatic skins

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | clearStyleDeclaration(selector:String, update:Boolean):void [static] Clears the CSSStyleDeclaration object that stores the rules for the specified CSS selector. | StyleManager
 | getColorName(colorName:Object):uint [static] Returns the numeric RGB color value that corresponds to the specified color string. | StyleManager
 | getColorNames(colors:Array):void [static] Converts each element of the colors Array from a color name to a numeric RGB color value. | StyleManager
 | getStyleDeclaration(selector:String):CSSStyleDeclaration [static] Gets the CSSStyleDeclaration object that stores the rules for the specified CSS selector. | StyleManager
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isColorName(colorName:String):Boolean [static] Tests to see if the given String is an alias for a color value. | StyleManager
 | isInheritingStyle(styleName:String):Boolean [static] Tests to see if a style is inheriting. | StyleManager
 | isInheritingTextFormatStyle(styleName:String):Boolean [static] Test to see if a TextFormat style is inheriting. | StyleManager
 | isParentDisplayListInvalidatingStyle(styleName:String):Boolean [static] Tests to see if this style affects the component's parent container in such a way as to require that the parent container redraws itself when this style changes. | StyleManager
 | isParentSizeInvalidatingStyle(styleName:String):Boolean [static] Tests to see if the style changes the size of the component's parent container. | StyleManager
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | isSizeInvalidatingStyle(styleName:String):Boolean [static] Tests to see if a style changes the size of a component. | StyleManager
 | isValidStyleValue(value:*):Boolean [static] Determines if a specified parameter is a valid style property. | StyleManager
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | registerColorName(colorName:String, colorValue:uint):void [static] Adds a color name to the list of aliases for colors. | StyleManager
 | registerInheritingStyle(styleName:String):void [static] Adds to the list of styles that can inherit values from their parents. | StyleManager
 | registerParentDisplayListInvalidatingStyle(styleName:String):void [static] Adds to the list of styles which may affect the appearance or layout of the component's parent container. | StyleManager
 | registerParentSizeInvalidatingStyle(styleName:String):void [static] Adds to the list of styles which may affect the measured size of the component's parent container. | StyleManager
 | registerSizeInvalidatingStyle(styleName:String):void [static] Adds to the list of styles which may affect the measured size of the component. | StyleManager
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | setStyleDeclaration(selector:String, styleDeclaration:CSSStyleDeclaration, update:Boolean):void [static] Sets the CSSStyleDeclaration object that stores the rules for the specified CSS selector. | StyleManager
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | NOT_A_COLOR : uint = 0xFFFFFFFF [static] The getColorName() method returns this value if the passed-in String is not a legitimate color name. | StyleManager
Method detail
clearStyleDeclaration () method
public static function clearStyleDeclaration(selector:String, update:Boolean):void

Clears the CSSStyleDeclaration object that stores the rules for the specified CSS selector.

If the specified selector is a class selector (for example, ".bigMargins" or ".myStyle"), you must be sure to start the selector property with a period (.).

If the specified selector is a type selector (for example, "Button"), do not start the selector property with a period.

The global selector is similar to a type selector and does not start with a period.

Parameters
selector:String — The name of the CSS selector to clear.
update:Boolean — Set to true to force an immediate update of the styles. Set to false to avoid an immediate update of the styles in the application. The styles will be updated the next time this method or the setStyleDeclaration() method is called with the update property set to true.
getColorName () method
public static function getColorName(colorName:Object):uint

Returns the numeric RGB color value that corresponds to the specified color string. The color string can be either a case-insensitive color name such as "red", "Blue", or "haloGreen", a hexadecimal value such as 0xFF0000, or a #-hexadecimal String such as "#FF0000".

This method returns a uint, such as 4521830, that represents a color. You can convert this uint to a hexadecimal value by passing the numeric base (in this case, 16), to the uint class's toString() method, as the following example shows:

   import mx.styles.StyleManager;
   private function getNewColorName():void {
       StyleManager.registerColorName("soylentGreen",0x44FF66);
       trace(StyleManager.getColorName("soylentGreen").toString(16));
   }
Parameters
colorName:Object — The color name.

Returns
uint — Returns a uint that represents the color value or NOT_A_COLOR if the value of the colorName property is not an alias for a color.
getColorNames () method
public static function getColorNames(colors:Array):void

Converts each element of the colors Array from a color name to a numeric RGB color value. Each color String can be either a case-insensitive color name such as "red", "Blue", or "haloGreen", a hexadecimal value such as 0xFF0000, or a #-hexadecimal String such as "#FF0000"..

Parameters
colors:Array — An Array of color names.
getStyleDeclaration () method
public static function getStyleDeclaration(selector:String):CSSStyleDeclaration

Gets the CSSStyleDeclaration object that stores the rules for the specified CSS selector.

If the selector parameter starts with a period (.), the returned CSSStyleDeclaration is a class selector and applies only to those instances whose styleName property specifies that selector (not including the period). For example, the class selector ".bigMargins" applies to any UIComponent whose styleName is "bigMargins".

If the selector parameter does not start with a period, the returned CSSStyleDeclaration is a type selector and applies to all instances of that type. For example, the type selector "Button" applies to all instances of Button and its subclasses.

The global selector is similar to a type selector and does not start with a period.

Parameters
selector:String — The name of the CSS selector.

Returns
CSSStyleDeclaration — The style declaration whose name matches the selector property.
isColorName () method
public static function isColorName(colorName:String):Boolean

Tests to see if the given String is an alias for a color value. For example, by default, the String "blue" is an alias for 0x0000FF.

Parameters
colorName:String — The color name to test. This parameter is not case-sensitive.

Returns
Boolean — Returns true if colorName is an alias for a color.
isInheritingStyle () method
public static function isInheritingStyle(styleName:String):Boolean

Tests to see if a style is inheriting.

Parameters
styleName:String — The name of the style that you test to see if it is inheriting.

Returns
Boolean — Returns true if the specified style is inheriting.
isInheritingTextFormatStyle () method
public static function isInheritingTextFormatStyle(styleName:String):Boolean

Test to see if a TextFormat style is inheriting.

Parameters
styleName:String — The name of the style that you test to see if it is inheriting.

Returns
Boolean — Returns true if the specified TextFormat style is inheriting.
isParentDisplayListInvalidatingStyle () method
public static function isParentDisplayListInvalidatingStyle(styleName:String):Boolean

Tests to see if this style affects the component's parent container in such a way as to require that the parent container redraws itself when this style changes.

When one of these styles is set with setStyle(), the invalidateDisplayList() method is auomatically called on the component's parent container to make it redraw and/or relayout its children.

Parameters
styleName:String — The name of the style to test.

Returns
Boolean — Returns true if the specified style is one which may affect the appearance or layout of the component's parent container.
isParentSizeInvalidatingStyle () method
public static function isParentSizeInvalidatingStyle(styleName:String):Boolean

Tests to see if the style changes the size of the component's parent container.

When one of these styles is set with setStyle(), the invalidateSize() method is automatically called on the component's parent container to make its measured size get recalculated later.

Parameters
styleName:String — The name of the style to test.

Returns
Boolean — Returns true if the specified style is one which may affect the measured size of the component's parent container.
isSizeInvalidatingStyle () method
public static function isSizeInvalidatingStyle(styleName:String):Boolean

Tests to see if a style changes the size of a component.

When one of these styles is set with the setStyle() method, the invalidateSize() method is automatically called on the component to make its measured size get recalculated later.

Parameters
styleName:String — The name of the style to test.

Returns
Boolean — Returns true if the specified style is one which may affect the measured size of the component.
isValidStyleValue () method
public static function isValidStyleValue(value:*):Boolean

Determines if a specified parameter is a valid style property. For example:

   trace(StyleManager.isValidStyleValue(myButton.getStyle("color")).toString());

This can be useful because some styles can be set to values such as 0, NaN, the empty String (""), or null, which can cause an if (value) test to fail.

Parameters
value:* — The style property to test.

Returns
Boolean — If you pass the value returned by a getStyle() method call to this method, it returns true if the style was set and false if it was not set.
registerColorName () method
public static function registerColorName(colorName:String, colorValue:uint):void

Adds a color name to the list of aliases for colors.

Parameters
colorName:String — The name of the color to add to the list; for example, "blue". If you later access this color name, the value is not case-sensitive.
colorValue:uint — Color value, for example, 0x0000FF.
registerInheritingStyle () method
public static function registerInheritingStyle(styleName:String):void

Adds to the list of styles that can inherit values from their parents.

Note: Ensure that you avoid using duplicate style names, as name collisions can result in decreased performance if a style that is already used becomes inheriting.

Parameters
styleName:String — The name of the style that is added to the list of styles that can inherit values.
registerParentDisplayListInvalidatingStyle () method
public static function registerParentDisplayListInvalidatingStyle(styleName:String):void

Adds to the list of styles which may affect the appearance or layout of the component's parent container. When one of these styles is set with setStyle(), the invalidateDisplayList() method is auomatically called on the component's parent container to make it redraw and/or relayout its children.

Parameters
styleName:String — The name of the style to register.
registerParentSizeInvalidatingStyle () method
public static function registerParentSizeInvalidatingStyle(styleName:String):void

Adds to the list of styles which may affect the measured size of the component's parent container.

When one of these styles is set with setStyle(), the invalidateSize() method is automatically called on the component's parent container to make its measured size get recalculated later.

Parameters
styleName:String — The name of the style to register.
registerSizeInvalidatingStyle () method
public static function registerSizeInvalidatingStyle(styleName:String):void

Adds to the list of styles which may affect the measured size of the component. When one of these styles is set with setStyle(), the invalidateSize() method is automatically called on the component to make its measured size get recalculated later.

Parameters
styleName:String — The name of the style that you add to the list.
setStyleDeclaration () method
public static function setStyleDeclaration(selector:String, styleDeclaration:CSSStyleDeclaration, update:Boolean):void

Sets the CSSStyleDeclaration object that stores the rules for the specified CSS selector.

If the selector parameter starts with a period (.), the specified selector is a class selector and applies only to those instances whose styleName property specifies that selector (not including the period). For example, the class selector ".bigMargins" applies to any UIComponent whose styleName is "bigMargins".

If the selector parameter does not start with a period, the specified selector is a "type selector" and applies to all instances of that type. For example, the type selector "Button" applies to all instances of Button and its subclasses.

The global selector is similar to a type selector and does not start with a period.

Parameters
selector:String — The name of the CSS selector.
styleDeclaration:CSSStyleDeclaration — The new style declaration.
update:Boolean — Set to true to force an immediate update of the styles. Set to false to avoid an immediate update of the styles in the application. The styles will be updated the next time this method or the clearStyleDeclaration() method is called with the update property set to true.
Constant detail
NOT_A_COLOR constant
public static const NOT_A_COLOR:uint = 0xFFFFFFFF

The getColorName() method returns this value if the passed-in String is not a legitimate color name.


mx.utils Summary (Flex™ 2 Language Reference)

Package mx.utils | Classes

The mx.utils package contains Flex utility classes.

Classes
Class | Description
ArrayUtil | The ArrayUtil utility class is an all-static class with methods for working with arrays within Flex.
ColorUtil | The ColorUtil class is an all-static class with methods for working with RGB colors within Flex.
DescribeTypeCache | DescribeTypeCache is a convenience class that is used to cache the return values of flash.utils.describeType() so that calls made subsequent times return faster.
DescribeTypeCacheRecord | This class represents a single cache entry, this gets created as part of the describeType method call on the DescribeTypeCache class.
GraphicsUtil | The Graphics class is an all-static class with utility methods related to the Graphics class.
NameUtil | The NameUtil utility class defines static methods for creating names for Flex objects.
ObjectProxy | This class provides the ability to track changes to an item managed by this proxy.
ObjectUtil | The ObjectUtil class is an all-static class with methods for working with Objects within Flex.
StringUtil | The StringUtil utility class is an all-static class with methods for working with String objects within Flex.
UIDUtil | The UIDUtil class is an all-static class with methods for working with UIDs (unique identifiers) within Flex.
URLUtil | The URLUtil class is a static class with methods for working with full and relative URLs within Flex.
XMLUtil | The XMLUtil class is an all-static class with methods for working with XML within Flex.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.utils.ArrayUtil (Flex™ 2 Language Reference)

Class ArrayUtil | Properties | Methods
Package | mx.utils
Class | public class ArrayUtil
Inheritance | ArrayUtil Inheritance Object

The ArrayUtil utility class is an all-static class with methods for working with arrays within Flex. You do not create instances of ArrayUtil; instead you call static methods such as the ArrayUtil.toArray() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | getItemIndex(item:Object, source:Array):int [static] Returns the index of the item in the Array. | ArrayUtil
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | toArray(obj:Object):Array [static] Ensures that an Object can be used as an Array. | ArrayUtil
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
getItemIndex () method
public static function getItemIndex(item:Object, source:Array):int

Returns the index of the item in the Array. Note that in this implementation the search is linear and is therefore O(n).

Parameters
item:Object — The item to find in the Array.
source:Array — The Array to search for the item.

Returns
int — The index of the item, and -1 if the item is not in the list.
toArray () method
public static function toArray(obj:Object):Array

Ensures that an Object can be used as an Array.

If the Object is already an Array, it returns the object. If the object is not an Array, it returns an Array in which the only element is the Object. As a special case, if the Object is null, it returns an empty Array.

Parameters
obj:Object — Object that you want to ensure is an array.

Returns
Array — An Array. If the original Object is already an Array, the original Array is returned. Otherwise, a new Array whose only element is the Object is returned or an empty Array if the Object was null.


mx.utils.ColorUtil (Flex™ 2 Language Reference)

Class ColorUtil | Properties | Methods
Package | mx.utils
Class | public class ColorUtil
Inheritance | ColorUtil Inheritance Object

The ColorUtil class is an all-static class with methods for working with RGB colors within Flex. You do not create instances of ColorUtil; instead you simply call static methods such as the ColorUtil.adjustBrightness() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | adjustBrightness(rgb:uint, brite:Number):uint [static] Performs a linear brightness adjustment of an RGB color. | ColorUtil
 | adjustBrightness2(rgb:uint, brite:Number):uint [static] Performs a scaled brightness adjustment of an RGB color. | ColorUtil
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | rgbMultiply(rgb1:uint, rgb2:uint):uint [static] Performs an RGB multiplication of two RGB colors. | ColorUtil
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
adjustBrightness () method
public static function adjustBrightness(rgb:uint, brite:Number):uint

Performs a linear brightness adjustment of an RGB color.

The same amount is added to the red, green, and blue channels of an RGB color. Each color channel is limited to the range 0 through 255.

Parameters
rgb:uint — Original RGB color.
brite:Number — Amount to be added to each color channel. The range for this parameter is -255 to 255; -255 produces black while 255 produces white. If this parameter is 0, the RGB color returned is the same as the original color.

Returns
uint — New RGB color.
adjustBrightness2 () method
public static function adjustBrightness2(rgb:uint, brite:Number):uint

Performs a scaled brightness adjustment of an RGB color.

Parameters
rgb:uint — Original RGB color.
brite:Number — The percentage to brighten or darken the original color. If positive, the original color is brightened toward white by this percentage. If negative, it is darkened toward black by this percentage. The range for this parameter is -100 to 100; -100 produces black while 100 produces white. If this parameter is 0, the RGB color returned is the same as the original color.

Returns
uint — New RGB color.
rgbMultiply () method
public static function rgbMultiply(rgb1:uint, rgb2:uint):uint

Performs an RGB multiplication of two RGB colors.

This always results in a darker number than either original color unless one of them is white, in which case the other color is returned.

Parameters
rgb1:uint — First RGB color.
rgb2:uint — Second RGB color.

Returns
uint — RGB multiplication of the two colors.


mx.utils.DescribeTypeCache (Flex™ 2 Language Reference)

Class DescribeTypeCache | Properties | Methods
Package | mx.utils
Class | public class DescribeTypeCache
Inheritance | DescribeTypeCache Inheritance Object

DescribeTypeCache is a convenience class that is used to cache the return values of flash.utils.describeType() so that calls made subsequent times return faster. This class also lets you set handler functions for specific value types. These will get called when the user tries to access these values on the DescribeTypeCacheRecord class.

See also

mx.utils.DescribeTypeCacheRecord

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | describeType(o:*):DescribeTypeCacheRecord [static] Calls flash.utils.describeType() for the first time and caches the return value so that subsequent calls return faster. | DescribeTypeCache
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | registerCacheHandler(valueName:String, handler:Function):void [static] registerCacheHandler lets you add function handler for specific strings. | DescribeTypeCache
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
describeType () method
public static function describeType(o:*):DescribeTypeCacheRecord

Calls flash.utils.describeType() for the first time and caches the return value so that subsequent calls return faster.

Parameters
o:*

Returns
DescribeTypeCacheRecord

See also

flash.utils.describeType()
registerCacheHandler () method
public static function registerCacheHandler(valueName:String, handler:Function):void

registerCacheHandler lets you add function handler for specific strings. These functions get called when the user refers to these values on a instance of DescribeTypeCacheRecord.

Parameters
valueName:String — String that specifies the value for which the handler must be set.
handler:Function — Function that should be called when user references valueName.


mx.utils.DescribeTypeCacheRecord (Flex™ 2 Language Reference)

Class DescribeTypeCacheRecord | Properties | Methods
Package | mx.utils
Class | public dynamic class DescribeTypeCacheRecord
Inheritance | DescribeTypeCacheRecord Inheritance Proxy Inheritance Object

This class represents a single cache entry, this gets created as part of the describeType method call on the DescribeTypeCache class.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | callProperty(name:*, ... rest):* Overrides the behavior of an object property that can be called as a function. | Proxy
Inherited | deleteProperty(name:*):Boolean Overrides the request to delete a property. | Proxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
Inherited | getProperty(name:*):* Overrides any request for a property's value. | Proxy
Inherited | hasProperty(name:*):Boolean Overrides a request to check whether an object has a particular property by name. | Proxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
Inherited | nextName(index:int):String Allows enumeration of the proxied object's properties by index number to retrieve property names. | Proxy
Inherited | nextNameIndex(index:int):int Allows enumeration of the proxied object's properties by index number. | Proxy
Inherited | nextValue(index:int):* Allows enumeration of the proxied object's properties by index number to retrieve property values. | Proxy
Inherited | setProperty(name:*, value:*):void Overrides a call to change a property's value. | Proxy


mx.utils.GraphicsUtil (Flex™ 2 Language Reference)

Class GraphicsUtil | Properties | Methods
Package | mx.utils
Class | public class GraphicsUtil
Inheritance | GraphicsUtil Inheritance Object

The Graphics class is an all-static class with utility methods related to the Graphics class. You do not create instances of GraphicsUtil; instead you simply call methods such as the GraphicsUtil.drawRoundRectComplex() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | drawRoundRectComplex(graphics:Graphics, x:Number, y:Number, width:Number, height:Number, topLeftRadius:Number, topRightRadius:Number, bottomLeftRadius:Number, bottomRightRadius:Number):void [static] Draws a rounded rectangle using the size of a radius to draw the rounded corners. | GraphicsUtil
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
drawRoundRectComplex () method
public static function drawRoundRectComplex(graphics:Graphics, x:Number, y:Number, width:Number, height:Number, topLeftRadius:Number, topRightRadius:Number, bottomLeftRadius:Number, bottomRightRadius:Number):void

Draws a rounded rectangle using the size of a radius to draw the rounded corners.
You must set the line style, fill, or both
on the Graphics object before
you call the drawRoundRectComplex() method
by calling the linestyle(),
lineGradientStyle(), beginFill(),
beginGradientFill(), or
beginBitmapFill() method.

Parameters
graphics:Graphics — The Graphics object that draws the rounded rectangle.
x:Number — The horizontal position relative to the registration point of the parent display object, in pixels.
y:Number — The vertical position relative to the registration point of the parent display object, in pixels.
width:Number — The width of the round rectangle, in pixels.
height:Number — The height of the round rectangle, in pixels.
topLeftRadius:Number — The radius of the upper-left corner, in pixels.
topRightRadius:Number — The radius of the upper-right corner, in pixels.
bottomLeftRadius:Number — The radius of the bottom-left corner, in pixels.
bottomRightRadius:Number — The radius of the bottom-right corner, in pixels.


mx.utils.NameUtil (Flex™ 2 Language Reference)

Class NameUtil | Properties | Methods
Package | mx.utils
Class | public class NameUtil
Inheritance | NameUtil Inheritance Object

The NameUtil utility class defines static methods for creating names for Flex objects. You do not create instances of NameUtil; instead you call static methods of the class, such as the NameUtil.createName() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | createUniqueName(object:Object):String [static] Creates a unique name for any Object instance, such as "Button12", by combining the unqualified class name with an incrementing counter. | NameUtil
 | displayObjectToString(displayObject:DisplayObject):String [static] Returns a string, such as "MyApplication0.addressForm.lastName.TextField17", for a DisplayObject object that indicates its position in the hierarchy of DisplayObject objects in an application. | NameUtil
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
createUniqueName () method
public static function createUniqueName(object:Object):String

Creates a unique name for any Object instance, such as "Button12", by combining the unqualified class name with an incrementing counter.

Parameters
object:Object — Object requiring a name.

Returns
String — String containing the unique name.
displayObjectToString () method
public static function displayObjectToString(displayObject:DisplayObject):String

Returns a string, such as "MyApplication0.addressForm.lastName.TextField17", for a DisplayObject object that indicates its position in the hierarchy of DisplayObject objects in an application.

Parameters
displayObject:DisplayObject — A DisplayObject object whose hierarchy in the application is desired.

Returns
String — String containing the position of displayObject in the hierarchy of DisplayObject objects in an application.


mx.utils.ObjectProxy (Flex™ 2 Language Reference)

Class ObjectProxy | Properties | Methods
Package | mx.utils
Class | public dynamic class ObjectProxy
Inheritance | ObjectProxy Inheritance Proxy Inheritance Object
Implements | IExternalizable, IPropertyChangeNotifier

This class provides the ability to track changes to an item managed by this proxy. Any number of objects can "listen" for changes on this object, by using the addEventListener() method.

Example
  import mx.events.PropertyChangeEvent;
  import mx.utils.ObjectUtil;
  import mx.utils.ObjectProxy;
  import mx.utils.StringUtil;
   var a:Object = { name: "Tyler", age: 5, ssnum: "555-55-5555" };
  var p:ObjectProxy = new ObjectProxy(a);
  p.addEventListener(PropertyChangeEvent.PROPERTY_CHANGE, updateHandler);
  p.name = "Jacey";
  p.age = 2;
  delete p.ssnum;
   // handler function
  function updateHandler(event:ChangeEvent):void
  {
      trace(StringUtil.substitute("updateHandler('{0}', {1}, {2}, {3}, '{4}')",
                              event.kind,
                              event.property,
                              event.oldValue,
                                     event.newValue,
                              event.target.object_proxy::UUID));
  }
   // trace output
  updateHandler('opUpdate', name, Jacey, '698AF8CB-B3D9-21A3-1AFFDGHT89075CD2')
  updateHandler('opUpdate', age, 2, '698AF8CB-B3D9-21A3-1AFFDGHT89075CD2')
  updateHandler('opDelete', ssnum, null, '698AF8CB-B3D9-21A3-1AFFDGHT89075CD2')

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | uid : String The unique identifier for this object. | ObjectProxy
Protected Properties
Property |  | Defined by
 | dispatcher : EventDispatcher A reference to the EventDispatcher for this proxy. | ObjectProxy
 | notifiers : Object A hashmap of property change notifiers that this proxy is listening for changes from; the key of the map is the property name. | ObjectProxy
 | object : Object [read-only] The object being proxied. | ObjectProxy
 | propertyList : Array Contains a list of all of the property names for the proxied object. | ObjectProxy
 | proxyClass : Class Indicates what kind of proxy to create when proxying complex properties. | ObjectProxy
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ObjectProxy(item:Object = null, uid:String = null, proxyDepth:int = -1) Initializes this proxy with the specified object, id and proxy depth. | ObjectProxy
 | addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void Registers an event listener object so that the listener receives notification of an event. | ObjectProxy
 | dispatchEvent(event:Event):Boolean Dispatches an event into the event flow. | ObjectProxy
 | hasEventListener(type:String):Boolean Checks whether there are any event listeners registered for a specific type of event. | ObjectProxy
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | propertyChangeHandler(event:PropertyChangeEvent):void Called when a complex property is updated. | ObjectProxy
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | readExternal(input:IDataInput):void Since Flex only uses ObjectProxy to wrap anonymous objects, the server flex.messaging.io.ObjectProxy instance serializes itself as a Map that will be returned as a plain ActionScript object. | ObjectProxy
 | removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void Removes an event listener. | ObjectProxy
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
 | willTrigger(type:String):Boolean Checks whether an event listener is registered with this object or any of its ancestors for the specified event type. | ObjectProxy
 | writeExternal(output:IDataOutput):void Since Flex only serializes the inner ActionScript object that it wraps, the server flex.messaging.io.ObjectProxy populates itself with this anonymous object's contents and appears to the user as a Map. | ObjectProxy
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
 | callProperty(name:*, ... rest):* Returns the value of the proxied object's method with the specified name. | ObjectProxy
 | deleteProperty(name:*):Boolean Deletes the specified property on the proxied object and sends notification of the delete to the handler. | ObjectProxy
 | getComplexProperty(name:*, value:*):* Provides a place for subclasses to override how a complex property that needs to be either proxied or daisy chained for event bubbling is managed. | ObjectProxy
Inherited | getDescendants(name:*):* Overrides the use of the descendant operator. | Proxy
 | getProperty(name:*):* Returns the specified property value of the proxied object. | ObjectProxy
 | hasProperty(name:*):Boolean This is an internal function that must be implemented by a subclass of flash.utils.Proxy. | ObjectProxy
Inherited | isAttribute(name:*):Boolean Checks whether a supplied QName is also marked as an attribute. | Proxy
 | nextName(index:int):String This is an internal function that must be implemented by a subclass of flash.utils.Proxy. | ObjectProxy
 | nextNameIndex(index:int):int This is an internal function that must be implemented by a subclass of flash.utils.Proxy. | ObjectProxy
 | nextValue(index:int):* This is an internal function that must be implemented by a subclass of flash.utils.Proxy. | ObjectProxy
 | setProperty(name:*, value:*):void Updates the specified property on the proxied object and sends notification of the update to the handler. | ObjectProxy
 | setupPropertyList():void This method creates an array of all of the property names for the proxied object. | ObjectProxy
Property detail
dispatcher property
protected var dispatcher:EventDispatcher

A reference to the EventDispatcher for this proxy.

notifiers property
protected var notifiers:Object

A hashmap of property change notifiers that this proxy is listening for changes from; the key of the map is the property name.

object property
object:Object [read-only]

The object being proxied.

This property can be used as the source for data binding.

Implementation
    object_proxy function get object():Object
propertyList property
protected var propertyList:Array

Contains a list of all of the property names for the proxied object. Descendants need to fill this list by overriding the setupPropertyList() method.

proxyClass property
protected var proxyClass:Class

Indicates what kind of proxy to create when proxying complex properties. Subclasses should assign this value appropriately.

uid property
uid:String [read-write]

The unique identifier for this object.

This property can be used as the source for data binding.

Implementation
    public function get uid():String
    public function set uid(value:String):void
Constructor detail
ObjectProxy () constructor
public function ObjectProxy(item:Object = null, uid:String = null, proxyDepth:int = -1)

Initializes this proxy with the specified object, id and proxy depth.

Parameters
item:Object (default = null) — Object to proxy. If no item is specified, an anonymous object will be constructed and assigned.
uid:String (default = null) — String containing the unique id for this object instance. Required for IPropertyChangeNotifier compliance as every object must provide a unique way of identifying it. If no value is specified, a random id will be assigned.
proxyDepth:int (default = -1) — An integer indicating how many levels in a complex object graph should have a proxy created during property access. The default is -1, meaning "proxy to infinite depth".

Example
      import mx.events.PropertyChangeEvent;
      import mx.utils.ObjectUtil;
      import mx.utils.ObjectProxy;
      import mx.utils.StringUtil;
           var a:Object = { name: "Tyler", age: 5, ssnum: "555-55-5555" };
      var p:ObjectProxy = new ObjectProxy(a);
      p.addEventListener(PropertyChangeEvent.PROPERTY_CHANGE, updateHandler);
      p.name = "Jacey";
      p.age = 2;
      delete p.ssnum;
           // handler function
      function updateHandler(event:PropertyChangeEvent):void
      {
          trace(StringUtil.substitute("updateHandler('{0}', {1}, {2}, {3}, '{4}')",
                                  event.kind,
                                  event.property,
                                  event.oldValue,
                                         event.newValue,
                                  event.target.uid));
      }
           // trace output
      updateHandler('opUpdate', name, Jacey, '698AF8CB-B3D9-21A3-1AFFDGHT89075CD2')
      updateHandler('opUpdate', age, 2, '698AF8CB-B3D9-21A3-1AFFDGHT89075CD2')
      updateHandler('opDelete', ssnum, null, '698AF8CB-B3D9-21A3-1AFFDGHT89075CD2')

Method detail
addEventListener () method
public function addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void

Registers an event listener object so that the listener receives notification of an event. For more information, see the flash.events.EventDispatcher class.

Parameters
type:String
listener:Function
useCapture:Boolean (default = false)
priority:int (default = 0)
useWeakReference:Boolean (default = false)

See also

flash.events.EventDispatcher.addEventListener()
callProperty () method
flash_proxy override function callProperty(name:*, ... rest):*

Returns the value of the proxied object's method with the specified name.

Parameters
name:* — The name of the method being invoked.
... rest — An array specifying the arguments to the called method.

Returns
* — The return value of the called method.
deleteProperty () method
flash_proxy override function deleteProperty(name:*):Boolean

Deletes the specified property on the proxied object and sends notification of the delete to the handler.

Parameters
name:* — Typically a string containing the name of the property, or possibly a QName where the property name is found by inspecting the localName property.

Returns
Boolean — A Boolean indicating if the property was deleted.
dispatchEvent () method
public function dispatchEvent(event:Event):Boolean

Dispatches an event into the event flow. For more information, see the flash.events.EventDispatcher class.

Parameters
event:Event

Returns
Boolean

See also

flash.events.EventDispatcher.dispatchEvent()
getComplexProperty () method
object_proxy function getComplexProperty(name:*, value:*):*

Provides a place for subclasses to override how a complex property that needs to be either proxied or daisy chained for event bubbling is managed.

Parameters
name:* — Typically a string containing the name of the property, or possibly a QName where the property name is found by inspecting the localName property.
value:* — The property value.

Returns
* — The property value or an instance of ObjectProxy.
getProperty () method
flash_proxy override function getProperty(name:*):*

Returns the specified property value of the proxied object.

Parameters
name:* — Typically a string containing the name of the property, or possibly a QName where the property name is found by inspecting the localName property.

Returns
* — The value of the property. In some instances this value may be an instance of ObjectProxy.
hasEventListener () method
public function hasEventListener(type:String):Boolean

Checks whether there are any event listeners registered for a specific type of event. This allows you to determine where an object has altered handling of an event type in the event flow hierarchy. For more information, see the flash.events.EventDispatcher class.

Parameters
type:String

Returns
Boolean

See also

flash.events.EventDispatcher.hasEventListener()
hasProperty () method
flash_proxy override function hasProperty(name:*):Boolean

This is an internal function that must be implemented by a subclass of flash.utils.Proxy.

Parameters
name:* — The property name that should be tested for existence.

Returns
Boolean

See also

flash.utils.Proxy.hasProperty()
nextName () method
flash_proxy override function nextName(index:int):String

This is an internal function that must be implemented by a subclass of flash.utils.Proxy.

Parameters
index:int

Returns
String

See also

flash.utils.Proxy.nextName()
nextNameIndex () method
flash_proxy override function nextNameIndex(index:int):int

This is an internal function that must be implemented by a subclass of flash.utils.Proxy.

Parameters
index:int

Returns
int

See also

flash.utils.Proxy.nextNameIndex()
nextValue () method
flash_proxy override function nextValue(index:int):*

This is an internal function that must be implemented by a subclass of flash.utils.Proxy.

Parameters
index:int

Returns
*

See also

flash.utils.Proxy.nextValue()
propertyChangeHandler () method
public function propertyChangeHandler(event:PropertyChangeEvent):void

Called when a complex property is updated.

Parameters
event:PropertyChangeEvent
readExternal () method
public function readExternal(input:IDataInput):void

Since Flex only uses ObjectProxy to wrap anonymous objects, the server flex.messaging.io.ObjectProxy instance serializes itself as a Map that will be returned as a plain ActionScript object. Yo can then set the object_proxy object property to this value.

Parameters
input:IDataInput
removeEventListener () method
public function removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void

Removes an event listener. If there is no matching listener registered with the EventDispatcher object, a call to this method has no effect. For more information, see the flash.events.EventDispatcher class.

Parameters
type:String
listener:Function
useCapture:Boolean (default = false)

See also

flash.events.EventDispatcher.removeEventListener()
setProperty () method
flash_proxy override function setProperty(name:*, value:*):void

Updates the specified property on the proxied object and sends notification of the update to the handler.

Parameters
name:* — Object containing the name of the property that should be updated on the proxied object.
value:* — Value that should be set on the proxied object.
setupPropertyList () method
protected function setupPropertyList():void

This method creates an array of all of the property names for the proxied object. Descendants must override this method if they wish to add more properties to this list. Be sure to call super.setupPropertyList before making any changes to the propertyList property.

willTrigger () method
public function willTrigger(type:String):Boolean

Checks whether an event listener is registered with this object or any of its ancestors for the specified event type. This method returns true if an event listener is triggered during any phase of the event flow when an event of the specified type is dispatched to this object or any of its descendants. For more information, see the flash.events.EventDispatcher class.

Parameters
type:String

Returns
Boolean

See also

flash.events.EventDispatcher.willTrigger()
writeExternal () method
public function writeExternal(output:IDataOutput):void

Since Flex only serializes the inner ActionScript object that it wraps, the server flex.messaging.io.ObjectProxy populates itself with this anonymous object's contents and appears to the user as a Map.

Parameters
output:IDataOutput


mx.utils.ObjectUtil (Flex™ 2 Language Reference)

Class ObjectUtil | Properties | Methods
Package | mx.utils
Class | public class ObjectUtil
Inheritance | ObjectUtil Inheritance Object

The ObjectUtil class is an all-static class with methods for working with Objects within Flex. You do not create instances of ObjectUtil; instead you simply call static methods such as the ObjectUtil.isSimple() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
compare(a:Object, b:Object, depth:int = -1):int
[static] Compares the Objects and returns an integer value indicating if the first item is less than greater than or equal to the second item.
ObjectUtil
copy(value:Object):Object
[static] Copies the specified Object and returns a reference to the copy.
ObjectUtil
dateCompare(a:Date, b:Date):int
[static] Compares the two Date objects and returns an integer value indicating if the first Date object is before, equal to, or after the second item.
ObjectUtil
getClassInfo(obj:Object, excludes:Array = null, options:Object = null):Object
[static] Returns information about the class, and properties of the class, for the specified Object.
ObjectUtil
hasMetadata(obj:Object, propName:String, metadataName:String, excludes:Array = null, options:Object = null):Boolean
[static] Uses getClassInfo and examines the metadata information to determine whether a property on a given object has the specified metadata.
ObjectUtil
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
isSimple(value:Object):Boolean
[static] Returns true if the object reference specified is a simple data type.
ObjectUtil
numericCompare(a:Number, b:Number):int
[static] Compares two numberic values.
ObjectUtil
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
stringCompare(a:String, b:String, caseInsensitive:Boolean = false):int
[static] Compares two String values.
ObjectUtil
toString(value:Object, namespaceURIs:Array = null, exclude:Array = null):String
[static] Pretty-prints the specified Object into a String.
ObjectUtil
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Method detail
compare () method
public static function compare(a:Object, b:Object, depth:int = -1):int

Compares the Objects and returns an integer value indicating if the first item is less than greater than or equal to the second item. This method will recursively compare properties on nested objects and will return as soon as a non-zero result is found. By default this method will recurse to the deepest level of any property. To change the depth for comparison specify a non-negative value for the depth parameter.

Parameters
a:Object — Object.
b:Object — Object.
depth:int (default = -1) — Indicates how many levels should be recursed when performing the comparison. Set this value to 0 for a shallow comparison of only the primitive representation of each property. For example:
   var a:Object = {name:"Bob", info:[1,2,3]};
   var b:Object = {name:"Alice", info:[5,6,7]};
   var c:int = ObjectUtil.compare(a, b, 0);

In the above example the complex properties of a and b will be flattened by a call to toString() when doing the comparison. In this case the info property will be turned into a string when performing the comparison.

Returns
int — Return 0 if a and b are null, NaN, or equal. Return 1 if a is null or greater than b. Return -1 if b is null or greater than a.
copy () method
public static function copy(value:Object):Object

Copies the specified Object and returns a reference to the copy. The copy is made using a native serialization technique. This means that custom serialization will be respected during the copy.

This method is designed for copying data objects, such as elements of a collection. It is not intended for copying a UIComponent object, such as a TextInput control. If you want to create copies of specific UIComponent objects, you can create a subclass of the component and implement a clone() method, or other method to perform the copy.

Parameters
value:Object — Object that should be copied.

Returns
Object — Copy of the specified Object.
dateCompare () method
public static function dateCompare(a:Date, b:Date):int

Compares the two Date objects and returns an integer value indicating if the first Date object is before, equal to, or after the second item.

Parameters
a:Date — Date object.
b:Date — Date object.

Returns
int — 0 if a and b are null or equal; 1 if a is null or before b; -1 if b is null or before a.
getClassInfo () method
public static function getClassInfo(obj:Object, excludes:Array = null, options:Object = null):Object

Returns information about the class, and properties of the class, for the specified Object.

Parameters
obj:Object — The Object to inspect.
excludes:Array (default = null) — Array of Strings specifying the property names that should be excluded from the returned result. For example, you could specify ["currentTarget", "target"] for an Event object since these properties can cause the returned result to become large.
options:Object (default = null) — An Object containing one or more properties that control the information returned by this method. The properties include the following:
  • includeReadOnly: If false, exclude Object properties that are read-only. The default value is true.
  • includeTransient: If false, exclude Object properties and variables that have [Transient] metadata. The default value is true.
  • uris: Array of Strings of all namespaces that should be included in the output. It does allow for a wildcard of "*". By default, it is null, meaning no namespaces should be included. For example, you could specify ["mx_internal", "mx_object"] or ["*"].

Returns
Object — An Object containing the following properties:
  • name: String containing the name of the class;
  • properties: Sorted list of the property names of the specified object.
hasMetadata () method
public static function hasMetadata(obj:Object, propName:String, metadataName:String, excludes:Array = null, options:Object = null):Boolean

Uses getClassInfo and examines the metadata information to determine whether a property on a given object has the specified metadata.

Parameters
obj:Object — The object holding the property.
propName:String — The property to check for metadata.
metadataName:String — The name of the metadata to check on the property.
excludes:Array (default = null) — If any properties need to be excluded when generating class info. (Optional)
options:Object (default = null) — If any options flags need to changed when generating class info. (Optional)

Returns
Boolean — true if the property has the specified metadata.
isSimple () method
public static function isSimple(value:Object):Boolean

Returns true if the object reference specified is a simple data type. The simple data types include the following:

  • String
  • Number
  • uint
  • int
  • Boolean
  • Date
  • Array

Parameters
value:Object — Object inspected.

Returns
Boolean — true if the object specified is one of the types above; false otherwise.
numericCompare () method
public static function numericCompare(a:Number, b:Number):int

Compares two numberic values.

Parameters
a:Number — First number.
b:Number — Second number.

Returns
int — 0 is both numbers are NaN. 1 if only a is a NaN. -1 if only b is a NaN. -1 if a is less than b. 1 if a is greater than b.
stringCompare () method
public static function stringCompare(a:String, b:String, caseInsensitive:Boolean = false):int

Compares two String values.

Parameters
a:String — First String value.
b:String — Second String value.
caseInsensitive:Boolean (default = false) — Specifies to perform a case insensitive compare, true, or not, false.

Returns
int — 0 is both Strings are null. 1 if only a is null. -1 if only b is null. -1 if a precedes b. 1 if b precedes a.
toString () method
public static function toString(value:Object, namespaceURIs:Array = null, exclude:Array = null):String

Pretty-prints the specified Object into a String. All properties will be in alpha ordering. Each object will be assigned an id during printing; this value will be displayed next to the object type token preceded by a '#', for example:

      (mx.messaging.messages::AsyncMessage)#2.

This id is used to indicate when a circular reference occurs. Properties of an object that are of the Class type will appear only as the assigned type. For example a custom definition like the following:

        public class MyCustomClass {
          public var clazz:Class;
        }

With the clazz property assigned to Date will display as shown below:

       (somepackage::MyCustomClass)#0
          clazz = (Date)
Parameters
value:Object — Object to be pretty printed.
namespaceURIs:Array (default = null) — Array of namespace URIs for properties that should be included in the output. By default only properties in the public namespace will be included in the output. To get all properties regardless of namespace pass an array with a single element of ".
exclude:Array (default = null) — Array of the property names that should be excluded from the output. Use this to remove data from the formatted string.

Returns
String — String containing the formatted version of the specified object.

Example
      // example 1
      var obj:AsyncMessage = new AsyncMessage();
      obj.body = [];
      obj.body.push(new AsyncMessage());
      obj.headers["1"] = { name: "myName", num: 15.3};
      obj.headers["2"] = { name: "myName", num: 15.3};
      obj.headers["10"] = { name: "myName", num: 15.3};
      obj.headers["11"] = { name: "myName", num: 15.3};
      trace(ObjectUtil.toString(obj));
           // will output to flashlog.txt
      (mx.messaging.messages::AsyncMessage)#0
        body = (Array)#1
          [0] (mx.messaging.messages::AsyncMessage)#2
            body = (Object)#3
            clientId = (Null)
            correlationId = ""
            destination = ""
            headers = (Object)#4
            messageId = "378CE96A-68DB-BC1B-BCF7FFFFFFFFB525"
            sequenceId = (Null)
            sequencePosition = 0
            sequenceSize = 0
            timeToLive = 0
            timestamp = 0
        clientId = (Null)
        correlationId = ""
        destination = ""
        headers = (Object)#5
          1 = (Object)#6
            name = "myName"
            num = 15.3
          10 = (Object)#7
            name = "myName"
            num = 15.3
          11 = (Object)#8
            name = "myName"
            num = 15.3
          2 = (Object)#9
            name = "myName"
            num = 15.3
        messageId = "1D3E6E96-AC2D-BD11-6A39FFFFFFFF517E"
        sequenceId = (Null)
        sequencePosition = 0
        sequenceSize = 0
        timeToLive = 0
        timestamp = 0
           // example 2 with circular references
      obj = {};
      obj.prop1 = new Date();
      obj.prop2 = [];
      obj.prop2.push(15.2);
      obj.prop2.push("testing");
      obj.prop2.push(true);
      obj.prop3 = {};
      obj.prop3.circular = obj;
      obj.prop3.deeper = new ErrorMessage();
      obj.prop3.deeper.rootCause = obj.prop3.deeper;
      obj.prop3.deeper2 = {};
      obj.prop3.deeper2.deeperStill = {};
      obj.prop3.deeper2.deeperStill.yetDeeper = obj;
      trace(ObjectUtil.toString(obj));
           // will output to flashlog.txt
      (Object)#0
        prop1 = Tue Apr 26 13:59:17 GMT-0700 2005
        prop2 = (Array)#1
          [0] 15.2
          [1] "testing"
          [2] true
        prop3 = (Object)#2
          circular = (Object)#0
          deeper = (mx.messaging.messages::ErrorMessage)#3
            body = (Object)#4
            clientId = (Null)
            code = (Null)
            correlationId = ""
            destination = ""
            details = (Null)
            headers = (Object)#5
            level = (Null)
            message = (Null)
            messageId = "14039376-2BBA-0D0E-22A3FFFFFFFF140A"
            rootCause = (mx.messaging.messages::ErrorMessage)#3
            sequenceId = (Null)
            sequencePosition = 0
            sequenceSize = 0
            timeToLive = 0
            timestamp = 0
          deeper2 = (Object)#6
            deeperStill = (Object)#7
              yetDeeper = (Object)#0


mx.utils.StringUtil (Flex™ 2 Language Reference)

Class StringUtil | Properties | Methods
Package | mx.utils
Class | public class StringUtil
Inheritance | StringUtil Inheritance Object

The StringUtil utility class is an all-static class with methods for working with String objects within Flex. You do not create instances of StringUtil; instead you call methods such as the StringUtil.substitute() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
 | isWhitespace(character:String):Boolean [static] Returns true if the specified string is a single space, tab, carriage return, newline, or formfeed character. | StringUtil
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
 | substitute(str:String, ... rest):String [static] Substitutes "{n}" tokens within the specified string with the respective arguments passed in. | StringUtil
Inherited | toString():String Returns the string representation of the specified object. | Object
 | trim(str:String):String [static] Removes all whitespace characters from the beginning and end of the specified string. | StringUtil
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
isWhitespace () method
public static function isWhitespace(character:String):Boolean

Returns true if the specified string is a single space, tab, carriage return, newline, or formfeed character.

Parameters
character:String — The String that is is being queried.

Returns
Boolean — true if the specified string is a single space, tab, carriage return, newline, or formfeed character.
substitute () method
public static function substitute(str:String, ... rest):String

Substitutes "{n}" tokens within the specified string with the respective arguments passed in.

Parameters
str:String — The string to make substitutions in. This string can contain special tokens of the form {n}, where n is a zero based index, that will be replaced with the additional parameters found at that index if specified.
... rest — Additional parameters that can be substituted in the str parameter at each {n} location, where n is an integer (zero based) index value into the array of values specified. If the first parameter is an array this array will be used as a parameter list. This allows reuse of this routine in other methods that want to use the ... rest signature. For example
      public function myTracer(str:String, ... rest):void
      {
          label.text += StringUtil.substitute(str, rest) + "\n";
      }

Returns
String — New string with all of the {n} tokens replaced with the respective arguments specified.

Example
var str:String = "here is some info '{0}' and {1}"; trace(StringUtil.substitute(str, 15.4, true)); // this will output the following string: // "here is some info '15.4' and true"

trim () method
public static function trim(str:String):String

Removes all whitespace characters from the beginning and end of the specified string.

Parameters
str:String — The String whose whitespace should be trimmed.

Returns
String — Updated String where whitespace was removed from the beginning and end.


mx.utils.UIDUtil (Flex™ 2 Language Reference)

Class UIDUtil | Properties | Methods
Package | mx.utils
Class | public class UIDUtil
Inheritance | UIDUtil Inheritance Object

The UIDUtil class is an all-static class with methods for working with UIDs (unique identifiers) within Flex. You do not create instances of UIDUtil; instead you simply call static methods such as the UIDUtil.createUID() method.

Note: I you have a dynamic object that has no [Bindable] properties (which force the object to implement the IUID interface), Flex adds an mx_internal_uid property that contains a UID to the object. To avoid having this field in your dynamic object, make it [Bindable], implement the IUID interface in the object class, or set a uid property with a value.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | createUID():String [static] Generates a UID (unique identifier) based on ActionScript's pseudo-random number generator and the current time. | UIDUtil
 | getUID(item:Object):String [static] Returns the UID (unique identifier) for the specified object. | UIDUtil
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
createUID () method
public static function createUID():String

Generates a UID (unique identifier) based on ActionScript's pseudo-random number generator and the current time.

The UID has the form "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX" where X is a hexadecimal digit (0-9, A-F).

This UID will not be truly globally unique; but it is the best we can do without player support for UID generation.

Returns
String — The newly-generated UID.
getUID () method
public static function getUID(item:Object):String

Returns the UID (unique identifier) for the specified object. If the specified object doesn't have an UID then the method assings one to it. If a map is specified this method will use the map to construct the UID. As a special case, if the item passed in is null, this method returns a null UID.

Parameters
item:Object — Object that we need to find the UID for.

Returns
String — The UID that was either found or generated.


mx.utils.URLUtil (Flex™ 2 Language Reference)

Class URLUtil | Properties | Methods | Constants
Package | mx.utils
Class | public class URLUtil
Inheritance | URLUtil Inheritance Object

The URLUtil class is a static class with methods for working with full and relative URLs within Flex.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | getFullURL(rootURL:String, url:String):String [static] Converts a potentially relative URL to a full qualified URL. | URLUtil
 | getPort(url:String):uint [static] | URLUtil
 | getProtocol(url:String):String [static] Returns the protocol section of the specified url. | URLUtil
 | getServerName(url:String):String [static] | URLUtil
 | getServerNameWithPort(url:String):String [static] Pull the domain and port information out of a URL. | URLUtil
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
 | isHttpsURL(url:String):Boolean [static] | URLUtil
 | isHttpURL(url:String):Boolean [static] Determines if the URL starts with either http:, https:, or rtmp: followed by two slashes. | URLUtil
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | replacePort(uri:String, newPort:uint):String [static] Returns a new string with the port replaced with the specified port. | URLUtil
 | replaceProtocol(uri:String, newProtocol:String):String [static] This method will replace the protocol of the specified uri with the given protocol. | URLUtil
 | replaceTokens(url:String):String [static] | URLUtil
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | SERVER_NAME_TOKEN : String = "{server.name}" [static] | URLUtil
 | SERVER_PORT_TOKEN : String = "{server.port}" [static] | URLUtil
Method detail
getFullURL () method
public static function getFullURL(rootURL:String, url:String):String

Converts a potentially relative URL to a full qualified URL. If the URL is not relative, it is just returned as is. If the URL starts with a slash, the host and port from the root URL are prepended. Otherwise, the host, port, and path are prepended.

Parameters
rootURL:String — URL used to resolve url, if url is relative.
url:String — URL to convert.

Returns
String — Fully qualified URL.
getPort () method
public static function getPort(url:String):uint Parameters
url:String

Returns
uint
getProtocol () method
public static function getProtocol(url:String):String

Returns the protocol section of the specified url. Parameters

url:String — String containing the url to parse.

Returns
String — String containing the protocol or an empty string if no protocol is specified.

Example
getProtocol("https://localhost:2700/") returns "https" getProtocol("rtmp://www.myCompany.com/myMainDirectory/groupChatApp/HelpDesk") returns "rtmp" getProtocol("rtmpt:/sharedWhiteboardApp/June2002") returns "rtmpt" getProtocol("rtmp::1234/chatApp/room_name") returns "rtmp"

getServerName () method
public static function getServerName(url:String):String Parameters
url:String

Returns
String
getServerNameWithPort () method
public static function getServerNameWithPort(url:String):String

Pull the domain and port information out of a URL.

Parameters
url:String

Returns
String
isHttpsURL () method
public static function isHttpsURL(url:String):Boolean Parameters
url:String

Returns
Boolean
isHttpURL () method
public static function isHttpURL(url:String):Boolean

Determines if the URL starts with either http:, https:, or rtmp: followed by two slashes.

Parameters
url:String

Returns
Boolean — true> if the URL starts with http:, https:, or rtmp: followed by two slashes.
replacePort () method
public static function replacePort(uri:String, newPort:uint):String

Returns a new string with the port replaced with the specified port. If there is no port in the specified uri the port will be inserted. This method expects that a protocol has been specified within the uri.

Parameters
uri:String — String containing the uri in which the port should be replaced.
newPort:uint — uint containing the new port to subsitute.

Returns
String — String containing the uri with the port replaced.
replaceProtocol () method
public static function replaceProtocol(uri:String, newProtocol:String):String

This method will replace the protocol of the specified uri with the given protocol.

Parameters
uri:String — String containing the uri in which the protocol needs to be replaced.
newProtocol:String — String containing the new protocol to use.

Returns
String — String containing the uri with the protocol replaced, or empty string if the uri doesn't contain a protocol.
replaceTokens () method
public static function replaceTokens(url:String):String Parameters
url:String

Returns
String
Constant detail
SERVER_NAME_TOKEN constant
public static const SERVER_NAME_TOKEN:String = "{server.name}"
SERVER_PORT_TOKEN constant
public static const SERVER_PORT_TOKEN:String = "{server.port}"


mx.utils.XMLUtil (Flex™ 2 Language Reference)

Class XMLUtil | Properties | Methods
Package | mx.utils
Class | public class XMLUtil
Inheritance | XMLUtil Inheritance Object

The XMLUtil class is an all-static class with methods for working with XML within Flex. You do not create instances of XMLUtil; instead you simply call static methods such as the XMLUtil.qnamesEqual() method.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | createXMLDocument(str:String):XMLDocument [static] Creates XML out of the specified string, ignoring whitespace. | XMLUtil
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
 | qnamesEqual(qname1:QName, qname2:QName):Boolean [static] Returns true if the two QName parameters have identical uri and localName properties. | XMLUtil
 | qnameToString(qname:QName):String [static] Returns the concatenation of a Qname object's uri and localName properties, separated by a colon. | XMLUtil
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Method detail
createXMLDocument () method
public static function createXMLDocument(str:String):XMLDocument

Creates XML out of the specified string, ignoring whitespace. This method is used to create objects defined in <mx:XML> tags and WebService requests, although they, in turn, get the firstChild of the structure.

Parameters
str:String — XML string.

Returns
XMLDocument — New XML object that ignored whitespace.
qnamesEqual () method
public static function qnamesEqual(qname1:QName, qname2:QName):Boolean

Returns true if the two QName parameters have identical uri and localName properties.

Parameters
qname1:QName — First QName object.
qname2:QName — Second QName object.

Returns
Boolean — true if the two QName parameters have identical uri and localName properties.
qnameToString () method
public static function qnameToString(qname:QName):String

Returns the concatenation of a Qname object's uri and localName properties, separated by a colon. If the object does not have a uri property, or the value of uri is the empty string, returns the localName property.

Parameters
qname:QName — QName object.

Returns
String — Concatenation of a Qname object's uri and localName properties, separated by a colon.


mx.validators Summary (Flex™ 2 Language Reference)

Package mx.validators | Interfaces | Classes

The mx.validators package contains the classes to support data validation.

Interfaces
Interface | Description
IValidatorListener | The interface that components implement to support the Flex data validation mechanism.
Classes
Class | Description
CreditCardValidator | The CreditCardValidator class validates that a credit card number is the correct length, has the correct prefix, and passes the Luhn mod10 algorithm for the specified card type.
CreditCardValidatorCardType | The CreditCardValidatorCardType class defines value constants for specifying the type of credit card to validate.
CurrencyValidator | The CurrencyValidator class ensures that a String represents a valid currency expression.
CurrencyValidatorAlignSymbol | The CurrencyValidatorAlignSymbol class defines value constants for specifying currency symbol alignment.
DateValidator | The DateValidator class validates that a String or Object contains a proper date and matches a specified format.
EmailValidator | The EmailValidator class validates that a String has a single @ sign, a period in the domain name and that the top-level domain suffix has two, three, four, or six characters.
NumberValidator | The NumberValidator class ensures that a String represents a valid number.
PhoneNumberValidator | The PhoneNumberValidator class validates that a string is a valid phone number.
RegExpValidationResult | The RegExpValidator class dispatches the valid and invalid events.
RegExpValidator | The RegExpValidator class lets you use a regular expression to validate a field.
SocialSecurityValidator | The SocialSecurityValidator class validates that a String is a valid United States Social Security number.
StringValidator | The StringValidator class validates that the length of a String is within a specified range.
ValidationResult | The ValidationResult class contains the results of a validation.
Validator | The Validator class is the base class for all Flex validators.
ZipCodeValidator | The ZipCodeValidator class validates that a String has the correct length and format for a five-digit ZIP code, a five-digit+four-digit United States ZIP code, or Canadian postal code.
ZipCodeValidatorDomainType | The ZipCodeValidatorDomainType class defines the values for the domain property of the ZipCodeValidator class, which you use to specify the type of ZIP code to validate.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


mx.validators.CreditCardValidator (Flex™ 2 Language Reference)

Class CreditCardValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class CreditCardValidator
Inheritance | CreditCardValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The CreditCardValidator class validates that a credit card number is the correct length, has the correct prefix, and passes the Luhn mod10 algorithm for the specified card type. This validator does not check whether the credit card is an actual active credit card account.

You can specify the input to the CreditCardValidator in two ways:

  • Use the cardNumberSource and cardNumberProperty properties to specify the location of the credit card number, and the cardTypeSource and cardTypeProperty properties to specify the location of the credit card type to validate.
  • Use the source and property properties to specify a single Object. The Object should contain the following fields:
    • cardType - Specifies the type of credit card being validated.

      In MXML, use the values: "American Express", "Diners Club", "Discover", "MasterCard", or "Visa".

      In ActionScript, use the static constants CreditCardValidatorCardType.MASTER_CARD, CreditCardValidatorCardType.VISA, or CreditCardValidatorCardType.AMERICAN_EXPRESS CreditCardValidatorCardType.DISCOVER, or CreditCardValidatorCardType.DINERS_CLUB.

    • cardNumber - Specifies the number of the card being validated.

To perform the validation, it uses the following guidelines:

Length:

  1. Visa: 13 or 16 digits
  2. MasterCard: 16 digits
  3. Discover: 16 digits
  4. American Express: 15 digits
  5. Diners Club: 14 digits or 16 digits if it also functions as MasterCard
Prefix:
  1. Visa: 4
  2. MasterCard: 51 to 55
  3. Discover: 6011
  4. American Express: 34 or 37
  5. Diners Club: 300 to 305, 36 or 38, 51 to 55

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:CreditCardValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:CreditCardValidator
    allowedFormatChars=" -"
    cardNumberListener="Object specified by cardNumberSource"
    cardNumberProperty="No default"
    cardNumberSource="No default"
    cardTypeListener="Object specified by cardTypeSource"
    cardTypeProperty="No default"
    cardTypeSource="No default"
    invalidCharError= "Invalid characters in your credit card number. (Only enter numbers.)"
    invalidNumberError="The credit card number is invalid."
    noNumError="No credit card number specified."
    noTypeError="No credit card type specified or the type is not valid."
    wrongLengthError="Your credit card number contains the wrong number of digits."
    wrongTypeError="Incorrect card type specified."
  />

View the examples.

See also

mx.validators.CreditCardValidatorCardType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | allowedFormatChars : String The set of formatting characters allowed in the cardNumber field. | CreditCardValidator
 | cardNumberListener : IValidatorListener The component that listens for the validation result for the card number subfield. | CreditCardValidator
 | cardNumberProperty : String Name of the card number property to validate. | CreditCardValidator
 | cardNumberSource : Object Object that contains the value of the card number field. | CreditCardValidator
 | cardTypeListener : IValidatorListener The component that listens for the validation result for the card type subfield. | CreditCardValidator
 | cardTypeProperty : String Name of the card type property to validate. | CreditCardValidator
 | cardTypeSource : Object Object that contains the value of the card type field. | CreditCardValidator
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | invalidCharError : String Error message when the cardNumber field contains invalid characters. | CreditCardValidator
 | invalidNumberError : String Error message when the credit card number is invalid. | CreditCardValidator
Inherited | listener : Object Specifies the validation listener. | Validator
 | noNumError : String Error message when the cardNumber field is empty. | CreditCardValidator
 | noTypeError : String Error message when the cardType field is blank. | CreditCardValidator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
 | wrongLengthError : String Error message when the cardNumber field contains the wrong number of digits for the specified credit card type. | CreditCardValidator
 | wrongTypeError : String Error message the cardType field contains an invalid credit card type. | CreditCardValidator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CreditCardValidator()
Constructor.
CreditCardValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateCreditCard(validator:CreditCardValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator.
CreditCardValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a credit card number. | CreditCardValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
allowedFormatChars property
allowedFormatChars:String [read-write]

The set of formatting characters allowed in the cardNumber field.

The default value is " -" (space and dash).

Implementation
    public function get allowedFormatChars():String
    public function set allowedFormatChars(value:String):void
cardNumberListener property
cardNumberListener:IValidatorListener [read-write]

The component that listens for the validation result for the card number subfield. If none is specified, use the value specified to the cardNumberSource property.

Implementation
    public function get cardNumberListener():IValidatorListener
    public function set cardNumberListener(value:IValidatorListener):void
cardNumberProperty property
public var cardNumberProperty:String

Name of the card number property to validate. This attribute is optional, but if you specify the cardNumberSource property, you should also set this property.

cardNumberSource property
cardNumberSource:Object [read-write]

Object that contains the value of the card number field. If you specify a value for this property, you must also specify a value for the cardNumberProperty property. Do not use this property if you set the source and property properties.

Implementation
    public function get cardNumberSource():Object
    public function set cardNumberSource(value:Object):void
cardTypeListener property
cardTypeListener:IValidatorListener [read-write]

The component that listens for the validation result for the card type subfield. If none is specified, then use the value specified to the cardTypeSource property.

Implementation
    public function get cardTypeListener():IValidatorListener
    public function set cardTypeListener(value:IValidatorListener):void
cardTypeProperty property
public var cardTypeProperty:String

Name of the card type property to validate. This attribute is optional, but if you specify the cardTypeSource property, you should also set this property.

In MXML, valid values are:

  • "American Express"
  • "Diners Club"
  • "Discover"
  • "MasterCard"
  • "Visa"

In ActionScript, you can use the following constants to set this property:

CreditCardValidatorCardType.AMERICAN_EXPRESS, CreditCardValidatorCardType.DINERS_CLUB, CreditCardValidatorCardType.DISCOVER, CreditCardValidatorCardType.MASTER_CARD, and CreditCardValidatorCardType.VISA.

See also

mx.validators.CreditCardValidatorCardType
cardTypeSource property
cardTypeSource:Object [read-write]

Object that contains the value of the card type field. If you specify a value for this property, you must also specify a value for the cardTypeProperty property. Do not use this property if you set the source and property properties.

Implementation
    public function get cardTypeSource():Object
    public function set cardTypeSource(value:Object):void
invalidCharError property
public var invalidCharError:String

Error message when the cardNumber field contains invalid characters.

The default value is "Invalid characters in your credit card number. (Enter numbers only.)".

invalidNumberError property
public var invalidNumberError:String

Error message when the credit card number is invalid.

The default value is "The credit card number is invalid.".

noNumError property
public var noNumError:String

Error message when the cardNumber field is empty.

The default value is "No credit card number is specified.".

noTypeError property
public var noTypeError:String

Error message when the cardType field is blank.

The default value is "No credit card type is specified or the type is not valid.".

wrongLengthError property
public var wrongLengthError:String

Error message when the cardNumber field contains the wrong number of digits for the specified credit card type.

The default value is "Your credit card number contains the wrong number of digits.".

wrongTypeError property
public var wrongTypeError:String

Error message the cardType field contains an invalid credit card type. You should use the predefined constants for the cardType field: CreditCardValidatorCardType.MASTER_CARD, CreditCardValidatorCardType.VISA, CreditCardValidatorCardType.AMERICAN_EXPRESS, CreditCardValidatorCardType.DISCOVER, or CreditCardValidatorCardType.DINERS_CLUB.

The default value is "Incorrect card type is specified.".

Constructor detail
CreditCardValidator () constructor
public function CreditCardValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a credit card number.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — an Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validateCreditCard () method
public static function validateCreditCard(validator:CreditCardValidator, value:Object, baseField:String):Array

Convenience method for calling a validator. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:CreditCardValidator — The CreditCardValidator instance.
value:Object — A field to validate, which must contain the following fields:
  • cardType - Specifies the type of credit card being validated. Use the static constants CreditCardValidatorCardType.MASTER_CARD, CreditCardValidatorCardType.VISA, CreditCardValidatorCardType.AMERICAN_EXPRESS, CreditCardValidatorCardType.DISCOVER, or CreditCardValidatorCardType.DINERS_CLUB.
  • cardNumber - Specifies the number of the card being validated.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.date, the baseField value is "date".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
CreditCardValidatorExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the CreditCardValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <!-- Define model for the credit card data. -->
    <mx:Model id="creditcard">
        <card>
            <cardType>{cardTypeCombo.selectedItem.data}</cardType>
            <cardNumber>{cardNumberInput.text}</cardNumber>
        </card>
    </mx:Model>

    <mx:CreditCardValidator id="ccV"
        cardTypeSource="{creditcard}" cardTypeProperty="cardType"
        cardNumberSource="{creditcard}" cardNumberProperty="cardNumber"
        trigger="{myButton}" triggerEvent="click"
        cardTypeListener="{cardTypeCombo}"
        cardNumberListener="{cardNumberInput}"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="CreditCardValidator Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form id="creditCardForm">
            <mx:FormItem label="Card Type">
                <mx:ComboBox id="cardTypeCombo">
                    <mx:dataProvider>
                        <mx:Object label="American Express" data="American Express"/>
                        <mx:Object label="Diners Club" data="Diners Club"/>
                        <mx:Object label="Discover" data="Discover"/>
                        <mx:Object label="MasterCard" data="MasterCard"/>
                        <mx:Object label="Visa" data="Visa"/>
                    </mx:dataProvider>
                </mx:ComboBox>
            </mx:FormItem>
            <mx:FormItem label="Credit Card Number">
                <mx:TextInput id="cardNumberInput"/>
            </mx:FormItem>
            <mx:FormItem>
                <mx:Button id="myButton" label="Check Credit"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.validators.CreditCardValidatorCardType (Flex™ 2 Language Reference)

Class CreditCardValidatorCardType | Properties | Methods | Constants
Package | mx.validators
Class | public final class CreditCardValidatorCardType
Inheritance | CreditCardValidatorCardType Inheritance Object

The CreditCardValidatorCardType class defines value constants for specifying the type of credit card to validate. These values are used in the CreditCardValidator.cardType property.

See also

mx.validators.CreditCardValidator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | AMERICAN_EXPRESS : String = "American Express" [static] Specifies the card type as American Express. | CreditCardValidatorCardType
 | DINERS_CLUB : String = "Diners Club" [static] Specifies the card type as Diners Club. | CreditCardValidatorCardType
 | DISCOVER : String = "Discover" [static] Specifies the card type as Discover. | CreditCardValidatorCardType
 | MASTER_CARD : String = "MasterCard" [static] Specifies the card type as MasterCard. | CreditCardValidatorCardType
 | VISA : String = "Visa" [static] Specifies the card type as Visa. | CreditCardValidatorCardType
Constant detail
AMERICAN_EXPRESS constant
public static const AMERICAN_EXPRESS:String = "American Express"

Specifies the card type as American Express.

DINERS_CLUB constant
public static const DINERS_CLUB:String = "Diners Club"

Specifies the card type as Diners Club.

DISCOVER constant
public static const DISCOVER:String = "Discover"

Specifies the card type as Discover.

MASTER_CARD constant
public static const MASTER_CARD:String = "MasterCard"

Specifies the card type as MasterCard.

VISA constant
public static const VISA:String = "Visa"

Specifies the card type as Visa.


mx.validators.CurrencyValidator (Flex™ 2 Language Reference)

Class CurrencyValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class CurrencyValidator
Inheritance | CurrencyValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The CurrencyValidator class ensures that a String represents a valid currency expression. It can make sure the input falls within a given range (specified by minValue and maxValue), is non-negative (specified by allowNegative), and does not exceed the specified precision. The CurrencyValidator class correctly validates formatted and unformatted currency expressions, e.g., "$12,345.00" and "12345". You can customize the currencySymbol, alignSymbol, thousandsSeparator, and decimalSeparator properties for internationalization.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:CurrencyValidator> tag inherits all of the tag properties of its superclass, and adds the following tag properties:

  <mx:CurrencyValidator
    alignSymbol="left|right|any"
    allowNegative="true|false"
    currencySymbol="$"
    currencySymbolError="The currency symbol occurs in an invalid location."
    decimalPointCountError="The decimal separator can only occur once."
    decimalSeparator="."
    exceedsMaxError="The amount entered is too large."
    invalidCharError="The input contains invalid characters."
    invalidFormatCharsError="One of the formatting parameters is invalid."
    lowerThanMinError="The amount entered is too small."
    maxValue="NaN"
    minValue="NaN"
    negativeError="The amount may not be negative."
    precision="2"
    precisionError="The amount entered has too many digits beyond the decimal point."
    separationError="The thousands separator must be followed by three digits."
    thousandsSeparator=","
  />

View the examples.

See also

mx.validators.CurrencyValidatorAlignSymbol

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | alignSymbol : String Specifies the alignment of the currencySymbol relative to the rest of the expression. | CurrencyValidator
 | allowNegative : Boolean Specifies whether negative numbers are permitted. | CurrencyValidator
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | currencySymbol : String The single-character String used to specify the currency symbol, such as "$" or "£". | CurrencyValidator
 | currencySymbolError : String Error message when the currency symbol, defined by currencySymbol, is in the wrong location. | CurrencyValidator
 | decimalPointCountError : String Error message when the decimal separator character occurs more than once. | CurrencyValidator
 | decimalSeparator : String The character used to separate the whole from the fractional part of the number. | CurrencyValidator
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | exceedsMaxError : String Error message when the value is greater than maxValue. | CurrencyValidator
 | invalidCharError : String Error message when the currency contains invalid characters. | CurrencyValidator
 | invalidFormatCharsError : String Error message when the value contains an invalid formatting character. | CurrencyValidator
Inherited | listener : Object Specifies the validation listener. | Validator
 | lowerThanMinError : String Error message when the value is less than minValue. | CurrencyValidator
 | maxValue : Number Maximum value for a valid number. | CurrencyValidator
 | minValue : Number Minimum value for a valid number. | CurrencyValidator
 | negativeError : String Error message when the value is negative and the allowNegative property is false. | CurrencyValidator
 | precision : int The maximum number of digits allowed to follow the decimal point. | CurrencyValidator
 | precisionError : String Error message when the value has a precision that exceeds the value defined by the precision property. | CurrencyValidator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
 | separationError : String Error message when the thousands separator is incorrectly placed. | CurrencyValidator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
 | thousandsSeparator : String The character used to separate thousands. | CurrencyValidator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
CurrencyValidator()
Constructor.
CurrencyValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateCurrency(validator:CurrencyValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator.
CurrencyValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a currency expression. | CurrencyValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
alignSymbol property
public var alignSymbol:String

Specifies the alignment of the currencySymbol relative to the rest of the expression. Acceptable values in ActionScript are CurrencyValidatorAlignSymbol.LEFT, CurrencyValidatorAlignSymbol.RIGHT, and CurrencyValidatorAlignSymbol.ANY. Acceptable values in MXML are "left", "right", and "any".

The default value is CurrencyValidatorAlignSymbol.LEFT.

See also

mx.validators.CurrencyValidatorAlignSymbol
allowNegative property
public var allowNegative:Boolean

Specifies whether negative numbers are permitted. Can be true or false.

The default value is true.

currencySymbol property
public var currencySymbol:String

The single-character String used to specify the currency symbol, such as "$" or "£". Cannot be a digit and must be distinct from the thousandsSeparator and the decimalSeparator.

The default value is "$".

currencySymbolError property
public var currencySymbolError:String

Error message when the currency symbol, defined by currencySymbol, is in the wrong location.

The default value is "The currency symbol occurs in an invalid location.".

decimalPointCountError property
public var decimalPointCountError:String

Error message when the decimal separator character occurs more than once.

The default value is "The decimal separator can only occur once.".

decimalSeparator property
public var decimalSeparator:String

The character used to separate the whole from the fractional part of the number. Cannot be a digit and must be distinct from the currencySymbol and the thousandsSeparator.

The default value is ".".

exceedsMaxError property
public var exceedsMaxError:String

Error message when the value is greater than maxValue.

The default value is "The amount entered is too large.".

invalidCharError property
public var invalidCharError:String

Error message when the currency contains invalid characters.

The default value is "The input contains invalid characters.".

invalidFormatCharsError property
public var invalidFormatCharsError:String

Error message when the value contains an invalid formatting character.

The default value is "One of the formatting parameters is invalid.".

lowerThanMinError property
public var lowerThanMinError:String

Error message when the value is less than minValue.

The default value is "The amount entered is too small.".

maxValue property
public var maxValue:Number

Maximum value for a valid number. A value of NaN means it is ignored.

The default value is NaN.

minValue property
public var minValue:Number

Minimum value for a valid number. A value of NaN means it is ignored.

The default value is NaN.

negativeError property
public var negativeError:String

Error message when the value is negative and the allowNegative property is false.

The default value is "The amount may not be negative.".

precision property
public var precision:int

The maximum number of digits allowed to follow the decimal point. Can be any non-negative integer. Note: Setting to 0 has the same effect as setting NumberValidator.domain to int. Setting it to -1, means it is ignored.

The default value is 2.

precisionError property
public var precisionError:String

Error message when the value has a precision that exceeds the value defined by the precision property.

The default value is "The amount entered has too many digits beyond the decimal point.".

separationError property
public var separationError:String

Error message when the thousands separator is incorrectly placed.

The default value is "The thousands separator must be followed by three digits.".

thousandsSeparator property
public var thousandsSeparator:String

The character used to separate thousands. Cannot be a digit and must be distinct from the currencySymbol and the decimalSeparator.

The default value is ",".

Constructor detail
CurrencyValidator () constructor
public function CurrencyValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a currency expression.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validateCurrency () method
public static function validateCurrency(validator:CurrencyValidator, value:Object, baseField:String):Array

Convenience method for calling a validator. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:CurrencyValidator — The CurrencyValidator instance.
value:Object — The object to validate.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.currency, the baseField value is "currency".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
CurrencyValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the CurrencyValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:CurrencyValidator source="{priceUS}" property="text" precision="2"
        trigger="{myButton}" triggerEvent="click"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="CurrencyValidator Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter a U.S. dollar amount: ">
                 <mx:TextInput id="priceUS" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate"/>
            </mx:FormItem>
        </mx:Form>
    </mx:Panel>
</mx:Application>


mx.validators.CurrencyValidatorAlignSymbol (Flex™ 2 Language Reference)

Class CurrencyValidatorAlignSymbol | Properties | Methods | Constants
Package | mx.validators
Class | public final class CurrencyValidatorAlignSymbol
Inheritance | CurrencyValidatorAlignSymbol Inheritance Object

The CurrencyValidatorAlignSymbol class defines value constants for specifying currency symbol alignment. These values are used in the CurrencyValidator.alignSymbol property.

See also

mx.validators.CurrencyValidator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Public Constants
Constant |  | Defined by
 | ANY : String = "any" [static] Specifies "any" as the alignment of the currency symbol for the CurrencyValidator class. | CurrencyValidatorAlignSymbol
 | LEFT : String = "left" [static] Specifies "left" as the alignment of the currency symbol for the CurrencyValidator class. | CurrencyValidatorAlignSymbol
 | RIGHT : String = "right" [static] Specifies "right" as the alignment of the currency symbol for the CurrencyValidator class. | CurrencyValidatorAlignSymbol
Constant detail
ANY constant
public static const ANY:String = "any"

Specifies "any" as the alignment of the currency symbol for the CurrencyValidator class.

LEFT constant
public static const LEFT:String = "left"

Specifies "left" as the alignment of the currency symbol for the CurrencyValidator class.

RIGHT constant
public static const RIGHT:String = "right"

Specifies "right" as the alignment of the currency symbol for the CurrencyValidator class.


mx.validators.DateValidator (Flex™ 2 Language Reference)

Class DateValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class DateValidator
Inheritance | DateValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The DateValidator class validates that a String or Object contains a proper date and matches a specified format. Users can enter a single digit or two digits for month, day, and year. By default, the validator ensures the following formats:
  • The month is between 1 and 12
  • The day is between 1 and 31
  • The year is a number

You can specify the date in the DateValidator class in two ways:

  • Single String containing the date - Use the source and property properties to specify the String. The String can contain digits and the formatting characters specified by the allowedFormatChars property, which include the "/\-. " characters. By default, the input format of the date in a String field is "MM/DD/YYYY" where "MM" is the month, "DD" is the day, and "YYYY" is the year. You can use the inputFormat property to specify a different format.
  • Object or multiple fields containing the day, month, and year. Use all of the following properties to specify the day, month, and year inputs: daySource, dayProperty, monthSource, monthProperty, yearSource, and yearProperty.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:DateValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:DateValidator
    allowedFormatChars="/\-. "
    dayListener="Object specified by daySource"
    dayProperty="No default"
    daySource="No default"
    formatError= "Configuration error: Incorrect formatting string."
    inputFormat="MM/DD/YYYY"
    invalidCharError="Invalid characters in your date."
    monthListener="Object specified by monthSource"
    monthProperty="No default"
    monthSource="No default"
    validateAsString="true|false"
    wrongDayError="Please enter a valid day for the month."
    wrongLengthError="Please type the date in the format inputFormat."
    wrongMonthError="Please enter a month between 1 and 12."
    wrongYearError="Please enter a year between 0 and 9999."
    yearListener="Object specified by yearSource"
    yearProperty="No default"
    yearSource="No default"
  />

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | allowedFormatChars : String The set of formatting characters allowed for separating the month, day, and year values. | DateValidator
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | dayListener : IValidatorListener The component that listens for the validation result for the day subfield. | DateValidator
 | dayProperty : String Name of the day property to validate. | DateValidator
 | daySource : Object Object that contains the value of the day field. | DateValidator
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | formatError : String Error message when the inputFormat property is not in the correct format. | DateValidator
 | inputFormat : String The date format to validate the value against. | DateValidator
 | invalidCharError : String Error message when there are invalid characters in the date. | DateValidator
Inherited | listener : Object Specifies the validation listener. | Validator
 | monthListener : IValidatorListener The component that listens for the validation result for the month subfield. | DateValidator
 | monthProperty : String Name of the month property to validate. | DateValidator
 | monthSource : Object Object that contains the value of the month field. | DateValidator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
 | validateAsString : Boolean Determines how to validate the value. | DateValidator
 | wrongDayError : String Error message when the day is invalid. | DateValidator
 | wrongLengthError : String Error message when the length of the date doesn't match that of the inputFormat property. | DateValidator
 | wrongMonthError : String Error message when the month is invalid. | DateValidator
 | wrongYearError : String Error message when the year is invalid. | DateValidator
 | yearListener : IValidatorListener The component that listens for the validation result for the year subfield. | DateValidator
 | yearProperty : String Name of the year property to validate. | DateValidator
 | yearSource : Object Object that contains the value of the year field. | DateValidator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
DateValidator()
Constructor.
DateValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateDate(validator:DateValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator from within a custom validation function.
DateValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a date. | DateValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
allowedFormatChars property
allowedFormatChars:String [read-write]

The set of formatting characters allowed for separating the month, day, and year values.

The default value is "/\-. ".

Implementation
    public function get allowedFormatChars():String
    public function set allowedFormatChars(value:String):void
dayListener property
dayListener:IValidatorListener [read-write]

The component that listens for the validation result for the day subfield. If none is specified, use the value specified for the daySource property.

Implementation
    public function get dayListener():IValidatorListener
    public function set dayListener(value:IValidatorListener):void
dayProperty property
public var dayProperty:String

Name of the day property to validate. This property is optional, but if you specify the daySource property, you should also set this property.

daySource property
daySource:Object [read-write]

Object that contains the value of the day field. If you specify a value for this property, you must also specify a value for the dayProperty property. Do not use this property if you set the source and property properties.

Implementation
    public function get daySource():Object
    public function set daySource(value:Object):void
formatError property
public var formatError:String

Error message when the inputFormat property is not in the correct format.

The default value is "Configuration error: Incorrect formatting string.".

inputFormat property
public var inputFormat:String

The date format to validate the value against. "MM" is the month, "DD" is the day, and "YYYY" is the year. This String is case-sensitive.

The default value is "MM/DD/YYYY".

invalidCharError property
public var invalidCharError:String

Error message when there are invalid characters in the date.

The default value is "Invalid characters in your date.".

monthListener property
monthListener:IValidatorListener [read-write]

The component that listens for the validation result for the month subfield. If none is specified, use the value specified for the monthSource property.

Implementation
    public function get monthListener():IValidatorListener
    public function set monthListener(value:IValidatorListener):void
monthProperty property
public var monthProperty:String

Name of the month property to validate. This property is optional, but if you specify the monthSource property, you should also set this property.

monthSource property
monthSource:Object [read-write]

Object that contains the value of the month field. If you specify a value for this property, you must also specify a value for the monthProperty property. Do not use this property if you set the source and property properties.

Implementation
    public function get monthSource():Object
    public function set monthSource(value:Object):void
validateAsString property
public var validateAsString:Boolean

Determines how to validate the value. If set to true, the validator evaluates the value as a String, unless the value has a month, day, or year property. If false, the validator evaluates the value as a Date object.

The default value is true.

wrongDayError property
public var wrongDayError:String

Error message when the day is invalid.

The default value is "Please enter a valid day for the month.".

wrongLengthError property
public var wrongLengthError:String

Error message when the length of the date doesn't match that of the inputFormat property.

The default value is "Please type the date in the format <i>inputFormat</i>.".

wrongMonthError property
public var wrongMonthError:String

Error message when the month is invalid.

The default value is "Please enter a month between 1 and 12.".

wrongYearError property
public var wrongYearError:String

Error message when the year is invalid.

The default value is "Please enter a year between 0 and 9999.".

yearListener property
yearListener:IValidatorListener [read-write]

The component that listens for the validation result for the year subfield. If none is specified, use the value specified for the yearSource property.

Implementation
    public function get yearListener():IValidatorListener
    public function set yearListener(value:IValidatorListener):void
yearProperty property
public var yearProperty:String

Name of the year property to validate. This property is optional, but if you specify the yearSource property, you should also set this property.

yearSource property
yearSource:Object [read-write]

Object that contains the value of the year field. If you specify a value for this property, you must also specify a value for the yearProperty property. Do not use this property if you set the source and property properties.

Implementation
    public function get yearSource():Object
    public function set yearSource(value:Object):void
Constructor detail
DateValidator () constructor
public function DateValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a date.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom validator class, you must implement this method.

Parameters
value:Object — Either a String or an Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validateDate () method
public static function validateDate(validator:DateValidator, value:Object, baseField:String):Array

Convenience method for calling a validator from within a custom validation function. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:DateValidator — The DateValidator instance.
value:Object — A field to validate.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.date, the baseField value is "date".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
DateValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the DateValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:Model id="CheckModel">
        <dateInfo>
            <DOB>{dob.text}</DOB>
        </dateInfo>
    </mx:Model>

    <mx:DateValidator source="{dob}" property="text" allowedFormatChars="/"
        trigger="{myButton}" triggerEvent="click"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="DateValidator Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter date of birth (mm/dd/yyyy): ">
                <mx:TextInput id="dob" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate" />
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.validators.EmailValidator (Flex™ 2 Language Reference)

Class EmailValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class EmailValidator
Inheritance | EmailValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The EmailValidator class validates that a String has a single @ sign, a period in the domain name and that the top-level domain suffix has two, three, four, or six characters. IP domain names are valid if they are enclosed in square brackets. The validator does not check whether the domain and user name actually exist.

You can use IP domain names if they are enclosed in square brackets; for example, myname@[206.132.22.1]. You can use individual IP numbers from 0 to 255.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:EmailValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:EmailValidator
    invalidCharError="Invalid characters in your email address."
    invalidDomainError= "The domain in your email address is incorrectly formatted."
    invalidIPDomainError="The IP domain in your email address is incorrectly formatted."
    invalidPeriodsInDomainError="The domain in your email address has consecutive periods."
    missingAtSignError="Missing an at character in your email address."
    missingPeriodInDomainError="The domain in your email address is missing a period."
    missingUsernameError="The username in your email address is missing."
    tooManyAtSignsError="Too many at characters in your email address."
  />

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | invalidCharError : String Error message when there are invalid characters in the e-mail address. | EmailValidator
 | invalidDomainError : String Error message when the suffix (the top level domain) is not 2, 3, 4 or 6 characters long. | EmailValidator
 | invalidIPDomainError : String Error message when the IP domain is invalid. | EmailValidator
 | invalidPeriodsInDomainError : String Error message when there are continuous periods in the domain. | EmailValidator
Inherited | listener : Object Specifies the validation listener. | Validator
 | missingAtSignError : String Error message when there is no at sign in the email address. | EmailValidator
 | missingPeriodInDomainError : String Error message when there is no period in the domain. | EmailValidator
 | missingUsernameError : String Error message when there is no username. | EmailValidator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
 | tooManyAtSignsError : String Error message when there is more than one at sign in the e-mail address. | EmailValidator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
EmailValidator()
Constructor.
EmailValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateEmail(validator:EmailValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator from within a custom validation function.
EmailValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate an e-mail address. | EmailValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
invalidCharError property
public var invalidCharError:String

Error message when there are invalid characters in the e-mail address.

The default value is "Invalid characters in your email address.".

invalidDomainError property
public var invalidDomainError:String

Error message when the suffix (the top level domain) is not 2, 3, 4 or 6 characters long.

The default value is "The domain in your email address is incorrectly formatted.".

invalidIPDomainError property
public var invalidIPDomainError:String

Error message when the IP domain is invalid. The IP domain must be enclosed by square brackets.

The default value is "The IP domain in your email address is incorrectly formatted.".

invalidPeriodsInDomainError property
public var invalidPeriodsInDomainError:String

Error message when there are continuous periods in the domain.

The default value is "The domain in your email address has continous periods.".

missingAtSignError property
public var missingAtSignError:String

Error message when there is no at sign in the email address.

The default value is "Missing an at character in your email address.".

missingPeriodInDomainError property
public var missingPeriodInDomainError:String

Error message when there is no period in the domain.

The default value is "The domain in your email address is missing a period.".

missingUsernameError property
public var missingUsernameError:String

Error message when there is no username.

The default value is "The username in your email address is missing.".

tooManyAtSignsError property
public var tooManyAtSignsError:String

Error message when there is more than one at sign in the e-mail address. This property is optional.

The default value is "Too many at characters in your email address.".

Constructor detail
EmailValidator () constructor
public function EmailValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate an e-mail address.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Either a String or an Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validateEmail () method
public static function validateEmail(validator:EmailValidator, value:Object, baseField:String):Array

Convenience method for calling a validator from within a custom validation function. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:EmailValidator — The EmailValidator instance.
value:Object — A field to validate.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.email, the baseField value is "email".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
EmailValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the EmailValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

   <mx:EmailValidator source="{email}" property="text"
       trigger="{myButton}" triggerEvent="click"
       valid="Alert.show('Validation Succeeded!');"/>

   <mx:Panel title="EmailValidator Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter an e-mail address: ">
                <mx:TextInput id="email" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate" />
            </mx:FormItem>
        </mx:Form>
    </mx:Panel>
 </mx:Application>


mx.validators.IValidatorListener (Flex™ 2 Language Reference)

Interface IValidatorListener | Properties | Methods
Package | mx.validators
Interface | public interface IValidatorListener
Implementors | UIComponent

The interface that components implement to support the Flex data validation mechanism. The UIComponent class implements this interface. Therefore, any subclass of UIComponent also implements it.

Public Properties
Property |  | Defined by
 | errorString : String The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails. | IValidatorListener
 | validationSubField : String Used by a validator to assign a subfield. | IValidatorListener
Public Methods
Method |  | Defined by
 | validationResultHandler(event:ValidationResultEvent):void Handles both the valid and invalid events from a validator assigned to this component. | IValidatorListener
Property detail
errorString property
errorString:String [read-write]

The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails.

You can use the errorString property to show a validation error for a component, without actually using a validator class. When you write a String value to the errorString property, Flex draws a red border around the component to indicate the validation error, and the String appears in a tooltip as the validation error message when you move the mouse over the component, just as if a validator detected a validation error.

To clear the validation error, write an empty String, "", to the errorString property.

Note that writing a value to the errorString property does not trigger the valid or invalid events; it only changes the border color and displays the validation error message.

Implementation
    public function get errorString():String
    public function set errorString(value:String):void
validationSubField property
validationSubField:String [read-write]

Used by a validator to assign a subfield.

Implementation
    public function get validationSubField():String
    public function set validationSubField(value:String):void
Method detail
validationResultHandler () method
public function validationResultHandler(event:ValidationResultEvent):void

Handles both the valid and invalid events from a validator assigned to this component.

You typically handle the valid and invalid events dispatched by a validator by assigning event listeners to the validators. If you want to handle validation events directly in the component that is being validated, you can override this method to handle the valid and invalid events. From within your implementation, you can use the dispatchEvent() method to dispatch the valid and invalid events in the case where a validator is also listening for them.

Parameters
event:ValidationResultEvent — The event object for the validation.

See also

mx.events.ValidationResultEvent


mx.validators.NumberValidator (Flex™ 2 Language Reference)

Class NumberValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class NumberValidator
Inheritance | NumberValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The NumberValidator class ensures that a String represents a valid number. It can ensure that the input falls within a given range (specified by minValue and maxValue), is an integer (specified by domain), is non-negative (specified by allowNegative), and does not exceed the specified precision. The validator correctly validates formatted numbers (e.g., "12,345.67") and you can customize the thousandsSeparator and decimalSeparator properties for internationalization.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:NumberValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:NumberValidator
    allowNegative="true|false"
    decimalPointCountError="The decimal separator can only occur once."
    decimalSeparator="."
    domain="real|int"
    exceedsMaxError="The number entered is too large."
    integerError="The number must be an integer."
    invalidCharError="The input contains invalid characters."
    invalidFormatCharsError="One of the formatting parameters is invalid."
    lowerThanMinError="The number entered is too small."
    maxValue="NaN"
    minValue="NaN"
    negativeError="The number may not be negative."
    precision="-1"
    precisionError="The number entered has too many digits beyond the decimal point."
    separationError="The thousands separator must be followed by three digits."
    thousandsSeparator=","
  />

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | allowNegative : Boolean Specifies whether negative numbers are permitted. | NumberValidator
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | decimalPointCountError : String Error message when the decimal separator character occurs more than once. | NumberValidator
 | decimalSeparator : String The character used to separate the whole from the fractional part of the number. | NumberValidator
 | domain : String Type of number to be validated. | NumberValidator
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | exceedsMaxError : String Error message when the value exceeds the maxValue property. | NumberValidator
 | integerError : String Error message when the number must be an integer, as defined by the domain property. | NumberValidator
 | invalidCharError : String Error message when the value contains invalid characters. | NumberValidator
 | invalidFormatCharsError : String Error message when the value contains invalid format characters, which means that it contains a digit or minus sign (-) as a separator character, or it contains two or more consecutive separator characters. | NumberValidator
Inherited | listener : Object Specifies the validation listener. | Validator
 | lowerThanMinError : String Error message when the value is less than minValue. | NumberValidator
 | maxValue : Number Maximum value for a valid number. | NumberValidator
 | minValue : Number Minimum value for a valid number. | NumberValidator
 | negativeError : String Error message when the value is negative and the allowNegative property is false. | NumberValidator
 | precision : int The maximum number of digits allowed to follow the decimal point. | NumberValidator
 | precisionError : String Error message when the value has a precision that exceeds the value defined by the precision property. | NumberValidator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
 | separationError : String Error message when the thousands separator is in the wrong location. | NumberValidator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
 | thousandsSeparator : String The character used to separate thousands in the whole part of the number. | NumberValidator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
NumberValidator()
Constructor.
NumberValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateNumber(validator:NumberValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator from within a custom validation function.
NumberValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a number. | NumberValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
 | isRealValue(value:Object):Boolean Determines if the value is not null and not NaN value. | NumberValidator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
allowNegative property
public var allowNegative:Boolean

Specifies whether negative numbers are permitted. Valid values are true or false.

The default value is true.

decimalPointCountError property
public var decimalPointCountError:String

Error message when the decimal separator character occurs more than once.

The default value is "The decimal separator can only occur once.".

decimalSeparator property
public var decimalSeparator:String

The character used to separate the whole from the fractional part of the number. Cannot be a digit and must be distinct from the thousandsSeparator.

The default value is ".".

domain property
public var domain:String

Type of number to be validated. Permitted values are "real" and "int".

The default value is "real".

exceedsMaxError property
public var exceedsMaxError:String

Error message when the value exceeds the maxValue property.

The default value is "The number entered is too large.".

integerError property
public var integerError:String

Error message when the number must be an integer, as defined by the domain property.

The default value is "The number must be an integer.".

invalidCharError property
public var invalidCharError:String

Error message when the value contains invalid characters.

The default value is The input contains invalid characters.".

invalidFormatCharsError property
public var invalidFormatCharsError:String

Error message when the value contains invalid format characters, which means that it contains a digit or minus sign (-) as a separator character, or it contains two or more consecutive separator characters.

The default value is "One of the formatting parameters is invalid.".

lowerThanMinError property
public var lowerThanMinError:String

Error message when the value is less than minValue.

The default value is "The number entered is too small.".

maxValue property
public var maxValue:Number

Maximum value for a valid number. A value of NaN means there is no maximum.

The default value is NaN.

minValue property
public var minValue:Number

Minimum value for a valid number. A value of NaN means there is no minimum.

The default value is NaN.

negativeError property
public var negativeError:String

Error message when the value is negative and the allowNegative property is false.

The default value is "The number may not be negative.".

precision property
public var precision:int

The maximum number of digits allowed to follow the decimal point. Can be any nonnegative integer. Note: Setting to 0 has the same effect as setting domain to "int". A value of -1 means it is ignored.

The default value is -1.

precisionError property
public var precisionError:String

Error message when the value has a precision that exceeds the value defined by the precision property.

The default value is "The number entered has too many digits beyond the decimal point.".

separationError property
public var separationError:String

Error message when the thousands separator is in the wrong location.

The default value is "The thousands separator must be followed by three digits.".

thousandsSeparator property
public var thousandsSeparator:String

The character used to separate thousands in the whole part of the number. Cannot be a digit and must be distinct from the decimalSeparator.

The default value is ",".

Constructor detail
NumberValidator () constructor
public function NumberValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a number.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
isRealValue () method
protected override function isRealValue(value:Object):Boolean

Determines if the value is not null and not NaN value.

Parameters
value:Object

Returns
Boolean
validateNumber () method
public static function validateNumber(validator:NumberValidator, value:Object, baseField:String):Array

Convenience method for calling a validator from within a custom validation function. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:NumberValidator — The NumberValidator instance.
value:Object — A field to validate.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.number, the baseField value is "number".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
NumberValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the NumberValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:NumberValidator source="{age}" property="text" integerError="Enter Integer value"
        minValue="18" maxValue="50" domain="int"
        trigger="{myButton}" triggerEvent="click"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="NumberValidator Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter an age between 18 and 50: ">
                <mx:TextInput id="age" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate" />
            </mx:FormItem>
        </mx:Form>
    </mx:Panel>
</mx:Application>


mx.validators.PhoneNumberValidator (Flex™ 2 Language Reference)

Class PhoneNumberValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class PhoneNumberValidator
Inheritance | PhoneNumberValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The PhoneNumberValidator class validates that a string is a valid phone number. A valid phone number contains at least 10 digits, plus additional formatting characters. The validator does not check if the phone number is an actual active phone number.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:PhoneNumberValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:PhoneNumberValidator
    allowedFormatChars="()- .+"
    invalidCharError="Invalid characters in your phone number."
    wrongLengthError="Your telephone number must be at least 10 digits in length."
  />

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | allowedFormatChars : String The set of allowable formatting characters. | PhoneNumberValidator
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | invalidCharError : String Error message when the value contains invalid characters. | PhoneNumberValidator
Inherited | listener : Object Specifies the validation listener. | Validator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
 | wrongLengthError : String Error message when the value has fewer than 10 digits. | PhoneNumberValidator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
PhoneNumberValidator()
Constructor.
PhoneNumberValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validatePhoneNumber(validator:PhoneNumberValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator from within a custom validation function.
PhoneNumberValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a phone number. | PhoneNumberValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
allowedFormatChars property
allowedFormatChars:String [read-write]

The set of allowable formatting characters.

The default value is "()- .+".

Implementation
    public function get allowedFormatChars():String
    public function set allowedFormatChars(value:String):void
invalidCharError property
public var invalidCharError:String

Error message when the value contains invalid characters.

The default value is "Invalid characters in your phone number.".

wrongLengthError property
public var wrongLengthError:String

Error message when the value has fewer than 10 digits.

The default value is "Your telephone number must be at least 10 digits in length.".

Constructor detail
PhoneNumberValidator () constructor
public function PhoneNumberValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a phone number.

You do not typically call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validatePhoneNumber () method
public static function validatePhoneNumber(validator:PhoneNumberValidator, value:Object, baseField:String):Array

Convenience method for calling a validator from within a custom validation function. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:PhoneNumberValidator — The PhoneNumberValidator instance.
value:Object — A field to validate.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.phone, the baseField value is "phone".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
PhoneNumberValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the PhoneNumberValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:PhoneNumberValidator source="{phone}" property="text"
        trigger="{myButton}" triggerEvent="click"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="Phone Number Validator Panel" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter 10-digit phone number: ">
                <mx:TextInput id="phone" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate" />
            </mx:FormItem>
        </mx:Form>
     </mx:Panel>
</mx:Application>


mx.validators.RegExpValidationResult (Flex™ 2 Language Reference)

Class RegExpValidationResult | Properties | Methods
Package | mx.validators
Class | public class RegExpValidationResult
Inheritance | RegExpValidationResult Inheritance ValidationResult Inheritance Object

The RegExpValidator class dispatches the valid and invalid events. For an invalid event, the event object is an instance of the ValidationResultEvent class, and the ValidationResultEvent.results property contains an Array of ValidationResult objects.

However, for a valid event, the ValidationResultEvent.results property contains an Array of RegExpValidationResult objects. The RegExpValidationResult class is a child class of the ValidationResult class, and contains additional properties used with regular expressions.

See also

mx.events.ValidationResultEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | errorCode : String The validation error code if the value of the isError property is true. | ValidationResult
Inherited | errorMessage : String The validation error message if the value of the isError property is true. | ValidationResult
Inherited | isError : Boolean Contains true if the field generated a validation failure. | ValidationResult
 | matchedIndex : int An integer that contains the starting index in the input String of the match. | RegExpValidationResult
 | matchedString : String A String that contains the substring of the input String that matches the regular expression. | RegExpValidationResult
 | matchedSubstrings : Array An Array of Strings that contains parenthesized substring matches, if any. | RegExpValidationResult
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | subField : String The name of the subfield that the result is associated with. | ValidationResult
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | RegExpValidationResult(isError:Boolean, subField:String = "", errorCode:String = "", errorMessage:String = "", matchedString:String = "", matchedIndex:int = 0, matchedSubstrings:Array = null) Constructor | RegExpValidationResult
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
matchedIndex property
public var matchedIndex:int

An integer that contains the starting index in the input String of the match.

matchedString property
public var matchedString:String

A String that contains the substring of the input String that matches the regular expression.

matchedSubstrings property
public var matchedSubstrings:Array

An Array of Strings that contains parenthesized substring matches, if any. If no substring matches are found, this Array is of length 0. Use matchedSubStrings[0] to access the first substring match.

Constructor detail
RegExpValidationResult () constructor
public function RegExpValidationResult(isError:Boolean, subField:String = "", errorCode:String = "", errorMessage:String = "", matchedString:String = "", matchedIndex:int = 0, matchedSubstrings:Array = null)

Constructor

Parameters
isError:Boolean — Pass true if there was a validation error.
subField:String (default = "") — Name of the subfield of the validated Object.
errorCode:String (default = "") — Validation error code.
errorMessage:String (default = "") — Validation error message.
matchedString:String (default = "") — Matching substring.
matchedIndex:int (default = 0) — Index of the matching String.
matchedSubstrings:Array (default = null) — Array of substring matches.


mx.validators.RegExpValidator (Flex™ 2 Language Reference)

Class RegExpValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class RegExpValidator
Inheritance | RegExpValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The RegExpValidator class lets you use a regular expression to validate a field. You pass a regular expression to the validator using the expression property, and additional flags to control the regular expression pattern matching using the flags property.

The validation is successful if the validator can find a match of the regular expression in the field to validate. A validation error occurs when the validator finds no match.

The RegExpValidator class dispatches the valid and invalid events. For an invalid event, the event object is an instance of the ValidationResultEvent class, and it contains an Array of ValidationResult objects.

However, for a valid event, the ValidationResultEvent object contains an Array of RegExpValidationResult objects. The RegExpValidationResult class is a child class of the ValidationResult class, and contains additional properties used with regular expressions, including the following:

  • matchedIndex An integer that contains the starting index in the input String of the match.
  • matchedString A String that contains the substring of the input String that matches the regular expression.
  • matchedSubStrings An Array of Strings that contains parenthesized substring matches, if any. If no substring matches are found, this Array is of length 0. Use matchedSubStrings[0] to access the first substring match.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:RegExpValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:RegExpValidator
    expression="No default"
    flags="No default"
    noExpressionError="The expression is missing."
    noMatchError="The field is invalid."
  />

View the examples.

See also

mx.validators.RegExpValidationResult
mx.validators.ValidationResult
RegExp

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | expression : String The regular expression to use for validation. | RegExpValidator
 | flags : String The regular expression flags to use when matching. | RegExpValidator
Inherited | listener : Object Specifies the validation listener. | Validator
 | noExpressionError : String Error message when there is no regular expression specifed. | RegExpValidator
 | noMatchError : String Error message when there are no matches to the regular expression. | RegExpValidator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
RegExpValidator()
Constructor
RegExpValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a regular expression. | RegExpValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
expression property
expression:String [read-write]

The regular expression to use for validation.

Implementation
    public function get expression():String
    public function set expression(value:String):void
flags property
flags:String [read-write]

The regular expression flags to use when matching.

Implementation
    public function get flags():String
    public function set flags(value:String):void
noExpressionError property
public var noExpressionError:String

Error message when there is no regular expression specifed. The default value is "The expression is missing."

noMatchError property
public var noMatchError:String

Error message when there are no matches to the regular expression. The default value is "The field is invalid."

Constructor detail
RegExpValidator () constructor
public function RegExpValidator()

Constructor

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a regular expression.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Object to validate.

Returns
Array — For an invalid result, an Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
Examples
RegexValidatorExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the RegExpValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[
            import mx.events.ValidationResultEvent;
            import mx.validators.*;

            // Write the results to the
            private function handleResult(eventObj:ValidationResultEvent):void {
                if (eventObj.type == ValidationResultEvent.VALID)
                {
                    // For valid events, the results Array contains
                    // RegExpValidationResult objects.
                    var xResult:RegExpValidationResult;
                    reResults.text="";
                    for (var i:uint = 0; i < eventObj.results.length; i++)
                    {
                        xResult = eventObj.results[i];
                        reResults.text=reResults.text + xResult.matchedIndex + " " +
                            xResult.matchedString + "\n";
                    }
                }
                else
                {
                    reResults.text="";
                }
            }
        ]]>
    </mx:Script>

    <mx:RegExpValidator id="regExpV"
        source="{regex_text}" property="text"
        flags="g" expression="{regex.text}"
        valid="handleResult(event)" invalid="handleResult(event)"
        trigger="{myButton}" triggerEvent="click"/>

   <mx:Panel title="RegExpValidator Example" width="95%" height="95%"
        paddingTop="5" paddingLeft="5" paddingRight="5" paddingBottom="5">

        <mx:Text width="100%" text="Instructions:"/>
        <mx:Text width="100%" text="1. Enter text to search. By default, enter  a string containing the letters ABC in sequence followed by any digit."/>
        <mx:Text width="100%" text="2. Enter the regular expression. By default, enter ABC\d."/>
        <mx:Text width="100%" text="3. Click the Button control to trigger the validation."/>
        <mx:Text width="100%" text="4. The results show the index in the text where the matching pattern begins, and the matching pattern. "/>

        <mx:Form>
            <mx:FormItem label="Enter text: ">
                <mx:TextInput id="regex_text" text="xxxxABC4xxx" width="100%"/>
            </mx:FormItem>

            <mx:FormItem label="Enter regular expression: ">
                <mx:TextInput id="regex" text="ABC\d" width="100%"/>
            </mx:FormItem>

            <mx:FormItem label="Results: ">
                <mx:TextInput id="reResults" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate"/>
            </mx:FormItem>
        </mx:Form>
    </mx:Panel>
</mx:Application>


mx.validators.SocialSecurityValidator (Flex™ 2 Language Reference)

Class SocialSecurityValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class SocialSecurityValidator
Inheritance | SocialSecurityValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The SocialSecurityValidator class validates that a String is a valid United States Social Security number. It does not check whether it is an existing Social Security number.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:SocialSecurityValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:SocialSecurityValidator
    allowedFormatChars=" -"
    invalidCharError="You entered invalid characters in your Social Security number."
    wrongFormatError="The Social Security number must be 9 digits or in the form NNN-NN-NNNN."
    zeroStartError="Invalid Social Security number: the number cannot start with 000."
  />

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | allowedFormatChars : String Specifies the set of formatting characters allowed in the input. | SocialSecurityValidator
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | invalidCharError : String Error message when the value contains characters other than digits and formatting characters defined by the allowedFormatChars property. | SocialSecurityValidator
Inherited | listener : Object Specifies the validation listener. | Validator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
 | wrongFormatError : String Error message when the value is incorrectly formatted. | SocialSecurityValidator
 | zeroStartError : String Error message when the value contains an invalid Social Security number. | SocialSecurityValidator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
SocialSecurityValidator()
Constructor.
SocialSecurityValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateSocialSecurity(validator:SocialSecurityValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator.
SocialSecurityValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a Social Security number. | SocialSecurityValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
allowedFormatChars property
allowedFormatChars:String [read-write]

Specifies the set of formatting characters allowed in the input.

The default value is "()- .+".

Implementation
    public function get allowedFormatChars():String
    public function set allowedFormatChars(value:String):void
invalidCharError property
public var invalidCharError:String

Error message when the value contains characters other than digits and formatting characters defined by the allowedFormatChars property.

The default value is "You entered invalid characters in your Social Security number.".

wrongFormatError property
public var wrongFormatError:String

Error message when the value is incorrectly formatted.

The default value is "The Social Security number must be 9 digits or in the form NNN-NN-NNNN.".

zeroStartError property
public var zeroStartError:String

Error message when the value contains an invalid Social Security number.

The default value is "Invalid Social Security number: the number cannot start with 000.".

Constructor detail
SocialSecurityValidator () constructor
public function SocialSecurityValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a Social Security number.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validateSocialSecurity () method
public static function validateSocialSecurity(validator:SocialSecurityValidator, value:Object, baseField:String):Array

Convenience method for calling a validator. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:SocialSecurityValidator — The SocialSecurityValidator instance.
value:Object — A field to validate.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.social, the baseField value is social.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
SocialSecurityValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate SocialSecurityValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:SocialSecurityValidator source="{ssn}" property="text"
        trigger="{myButton}" triggerEvent="click"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="Social Security Validator Panel" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter Social Security number: ">
                <mx:TextInput id="ssn" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate" />
            </mx:FormItem>
        </mx:Form>
    </mx:Panel>
</mx:Application>


mx.validators.StringValidator (Flex™ 2 Language Reference)

Class StringValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class StringValidator
Inheritance | StringValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The StringValidator class validates that the length of a String is within a specified range.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:StringValidator> tag inherits all of the tag attributes of its superclass, and add the following tag attributes:

  <mx:StringValidator
    maxLength="NaN"
    minLength="NaN"
    tooLongError="This string is longer than the maximum allowed length."
    tooShortError="This string is shorter than the minimum allowed length."
  />

View the examples.

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
Inherited | listener : Object Specifies the validation listener. | Validator
 | maxLength : Number Maximum length for a valid String. | StringValidator
 | minLength : Number Minimum length for a valid String. | StringValidator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
 | tooLongError : String Error message when the String is longer than the maxLength property. | StringValidator
 | tooShortError : String Error message when the string is shorter than the minLength property. | StringValidator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
StringValidator()
Constructor.
StringValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateString(validator:StringValidator, value:Object, baseField:String = null):Array
[static] Convenience method for calling a validator.
StringValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a String. | StringValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
maxLength property
public var maxLength:Number

Maximum length for a valid String. A value of NaN means this property is ignored.

The default value is NaN.

minLength property
public var minLength:Number

Minimum length for a valid String. A value of NaN means this property is ignored.

The default value is NaN.

tooLongError property
tooLongError:String [read-write]

Error message when the String is longer than the maxLength property.

The default value is "This String is longer than the maximum allowed length.".

Implementation
    public function get tooLongError():String
    public function set tooLongError(value:String):void
tooShortError property
tooShortError:String [read-write]

Error message when the string is shorter than the minLength property.

The default value is "This String is shorter than the minimum allowed length.".

Implementation
    public function get tooShortError():String
    public function set tooShortError(value:String):void
Constructor detail
StringValidator () constructor
public function StringValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a String.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validateString () method
public static function validateString(validator:StringValidator, value:Object, baseField:String = null):Array

Convenience method for calling a validator. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:StringValidator — The StringValidator instance.
value:Object — A field to validate.
baseField:String (default = null) — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.mystring, the baseField value is "mystring".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
StringValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate StringValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:StringValidator source="{fname}" property="text"
        tooShortError="This string is shorter than the minimum allowed length of 4. "
        tooLongError="This string is longer than the maximum allowed length of 20."
        minLength="4" maxLength="20"
        trigger="{myButton}" triggerEvent="click"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="StringValidator Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

            <mx:Form>
                <mx:FormItem label="Enter a name between 4 and 20 characters: ">
                    <mx:TextInput id="fname" width="100%"/>
                </mx:FormItem>

                <mx:FormItem >
                    <mx:Button id="myButton" label="Validate" />
                </mx:FormItem>
            </mx:Form>
    </mx:Panel>
</mx:Application>


mx.validators.ValidationResult (Flex™ 2 Language Reference)

Class ValidationResult | Properties | Methods
Package | mx.validators
Class | public class ValidationResult
Inheritance | ValidationResult Inheritance Object
Subclasses | RegExpValidationResult

The ValidationResult class contains the results of a validation.

The ValidationResultEvent class defines the event object that is passed to event listeners for the valid and invalid validator events. The class also defines the results property, which contains an Array of ValidationResult objects, one for each field examined by the validator. This lets you access the ValidationResult objects from within an event listener.

See also

mx.events.ValidationResultEvent

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | errorCode : String The validation error code if the value of the isError property is true. | ValidationResult
 | errorMessage : String The validation error message if the value of the isError property is true. | ValidationResult
 | isError : Boolean Contains true if the field generated a validation failure. | ValidationResult
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | subField : String The name of the subfield that the result is associated with. | ValidationResult
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
 | ValidationResult(isError:Boolean, subField:String = "", errorCode:String = "", errorMessage:String = "") Constructor | ValidationResult
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
errorCode property
public var errorCode:String

The validation error code if the value of the isError property is true.

errorMessage property
public var errorMessage:String

The validation error message if the value of the isError property is true.

isError property
public var isError:Boolean

Contains true if the field generated a validation failure.

subField property
public var subField:String

The name of the subfield that the result is associated with. Some validators, such as CreditCardValidator and DateValidator, validate multiple subfields at the same time.

Constructor detail
ValidationResult () constructor
public function ValidationResult(isError:Boolean, subField:String = "", errorCode:String = "", errorMessage:String = "")

Constructor

Parameters
isError:Boolean — Pass true if there was a validation error.
subField:String (default = "") — Name of the subfield of the validated Object.
errorCode:String (default = "") — Validation error code.
errorMessage:String (default = "") — Validation error message.


mx.validators.Validator (Flex™ 2 Language Reference)

Class Validator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class Validator
Inheritance | Validator Inheritance EventDispatcher Inheritance Object
Implements | IMXMLObject
Subclasses | CreditCardValidator, CurrencyValidator, DateValidator, EmailValidator, NumberValidator, PhoneNumberValidator, RegExpValidator, SocialSecurityValidator, StringValidator, ZipCodeValidator

The Validator class is the base class for all Flex validators. This class implements the ability for a validator to make a field required, which means that the user must enter a value in the field or the validation fails.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The Validator class defines the following tag attributes, which all of its subclasses inherit:

  <mx:Validator
    enabled="true|false"
    listener="Value of the source property"
    property="No default"
    required="true|false"
    requiredFieldError="This field is required."
    source="No default"
    trigger="Value of the source property"
    triggerEvent="valueCommit"
  />

View the examples.

See also

mx.events.ValidationResultEvent
mx.validators.ValidationResult
mx.validators.RegExpValidationResult
Using error tips
Validating data by using custom validators
Example: Creating a simple validator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | listener : Object Specifies the validation listener. | Validator
 | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
 | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
 | source : Object Specifies the object containing the property to validate. | Validator
 | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
 | triggerEvent : String Specifies the event that triggers the validation. | Validator
Protected Properties
Property |  | Defined by
 | actualListeners : Array [read-only] Contains an Array of listener objects, if any, or the source object. | Validator
 | actualTrigger : IEventDispatcher [read-only] Contains the trigger object, if any, or the source object. | Validator
 | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
Validator()
Constructor.
Validator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Method |  | Defined by
 | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Executes the validation logic of this validator, including validating that a missing or empty value causes a validation error as defined by the value of the required property. | Validator
 | getValueFromSource():Object Returns the Object to validate. | Validator
 | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
 | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
 | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Event |  | Summary | Defined by
 | invalid | Dispatched when validation fails. | Validator
 | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Constant |  | Defined by
 | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
 | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
actualListeners property
actualListeners:Array [read-only]

Contains an Array of listener objects, if any, or the source object. Used to determine which object to notify about the validation result.

Implementation
    protected function get actualListeners():Array
actualTrigger property
actualTrigger:IEventDispatcher [read-only]

Contains the trigger object, if any, or the source object. Used to determine the listener object for the triggerEvent.

Implementation
    protected function get actualTrigger():IEventDispatcher
enabled property
enabled:Boolean [read-write]

Setting this value to false will stop the validator from performing validation. When a validator is disabled, it dispatch no events, and the validate() method returns null.

The default value is true.

Implementation
    public function get enabled():Boolean
    public function set enabled(value:Boolean):void
listener property
listener:Object [read-write]

Specifies the validation listener.

If you do not specify a listener, Flex uses the value of the source property. After Flex determines the source component, it changes the border color of the component, displays an error message for a failure, or hides any existing error message for a successful validation.

Implementation
    public function get listener():Object
    public function set listener(value:Object):void
property property
property:String [read-write]

A String specifying the name of the property of the source object that contains the value to validate. This property supports dot-delimited Strings for specifying nested properties. The property is optional, but if you specify source, you should set a value for this property as well.

The default value is null.

Implementation
    public function get property():String
    public function set property(value:String):void
required property
public var required:Boolean

If true, specifies that a missing or empty value causes a validation error.

The default value is true.

requiredFieldError property
public var requiredFieldError:String

Error message when a value is missing and the required property is true.

The default value is "This field is required.".

source property
source:Object [read-write]

Specifies the object containing the property to validate. Set this to an instance of a component or a data model. You use data binding syntax in MXML to specify the value. If you specify a value to the source property, then you should specify a value to the property property as well. The source property is optional.

The default value is null.

Implementation
    public function get source():Object
    public function set source(value:Object):void
subFields property
protected var subFields:Array

An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. For example, CreditCardValidator sets this property to [ "cardNumber", "cardType" ]. This value means that the value Object passed to the validate() method should contain a cardNumber and a cardType property.

Subclasses of the Validator class that validate multiple data fields (like CreditCardValidator and DateValidator) should assign this property in their constructor.

trigger property
trigger:IEventDispatcher [read-write]

Specifies the component generating the event that triggers the validator. If omitted, by default Flex uses the value of the source property. When the trigger dispatches a triggerEvent, validation executes.

Implementation
    public function get trigger():IEventDispatcher
    public function set trigger(value:IEventDispatcher):void
triggerEvent property
triggerEvent:String [read-write]

Specifies the event that triggers the validation. If omitted, Flex uses the valueCommit event. Flex dispatches the valueCommit event when a user completes data entry into a control. Usually this is when the user removes focus from the component, or when a property value is changed programmatically. If you want a validator to ignore all events, set triggerEvent to the empty string ("").

Implementation
    public function get triggerEvent():String
    public function set triggerEvent(value:String):void
Constructor detail
Validator () constructor
public function Validator()

Constructor.

Method detail
addListenerHandler () method
protected function addListenerHandler():void

Sets up all of the listeners for the valid and invalid events dispatched from the validator. Subclasses of the Validator class should first call the removeListenerHandler() method, and then the addListenerHandler() method if the value of one of their listeners or sources changes. The CreditCardValidator and DateValidator classes use this function internally.

doValidation () method
protected function doValidation(value:Object):Array

Executes the validation logic of this validator, including validating that a missing or empty value causes a validation error as defined by the value of the required property.

If you create a subclass of a validator class, you must override this method.

Parameters
value:Object — Value to validate.

Returns
Array — For an invalid result, an Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator that failed validation.

See also

mx.validators.ValidationResult
About overriding the doValidation() method
getValueFromSource () method
protected function getValueFromSource():Object

Returns the Object to validate. Subclasses, such as the CreditCardValidator and DateValidator classes, override this method because they need to access the values from multiple subfields.

Returns
Object — The Object to validate.
handleResults () method
protected function handleResults(errorResults:Array):ValidationResultEvent

Returns a ValidationResultEvent from the Array of error results. Internally, this function takes the results from the doValidation() method and puts it into a ValidationResultEvent object. Subclasses, such as the RegExpValidator class, should override this function if they output a subclass of ValidationResultEvent objects, such as the RegExpValidationResult objects, and needs to populate the object with additional information. You never call this function directly, and you should rarely override it.

Parameters
errorResults:Array — Array of ValidationResult objects.

Returns
ValidationResultEvent — The ValidationResultEvent returned by the validate() method.
initialized () method
public function initialized(document:Object, id:String):void

Called automatically by the MXML compiler when the Validator is created using an MXML tag.

Parameters
document:Object — The MXML document containing this Validator.
id:String — Ignored.
isRealValue () method
protected function isRealValue(value:Object):Boolean

Returns true if value is null.

Parameters
value:Object — The value to test.

Returns
Boolean — true if value is null.
removeListenerHandler () method
protected function removeListenerHandler():void

Disconnects all of the listeners for the valid and invalid events dispatched from the validator. Subclasses should first call the removeListenerHandler() method and then the addListenerHandler method if the value of one of their listeners or sources changes. The CreditCardValidator and DateValidator classes use this function internally.

validate () method
public function validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent

Performs validation and optionally notifies the listeners of the result.

Parameters
value:Object (default = null) — Optional value to validate. If null, then the validator uses the source and property properties to determine the value. If you specify this argument, you should also set the listener property to specify the target component for any validation error messages.
suppressEvents:Boolean (default = false) — If false, then after validation, the validator will notify the listener of the result.

Returns
ValidationResultEvent — A ValidationResultEvent object containing the results of the validation. For a successful validation, the ValidationResultEvent.results Array property is empty. For a validation failure, the ValidationResultEvent.results Array property contains one ValidationResult object for each field checked by the validator, both for fields that failed the validation and for fields that passed. Examine the ValidationResult.isError property to determine if the field passed or failed the validation.

See also

mx.events.ValidationResultEvent
mx.validators.ValidationResult
validateAll () method
public static function validateAll(validators:Array):Array

Invokes all the validators in the validators Array. Returns an Array containing one ValidationResultEvent object for each validator that failed. Returns an empty Array if all validators succeed.

Parameters
validators:Array — An Array containing the Validator objects to execute.

Returns
Array — Array of ValidationResultEvent objects, where the Array contains one ValidationResultEvent object for each validator that failed. The Array is empty if all validators succeed.
Event detail
invalid event
Event object type: mx.events.ValidationResultEvent
ValidationResultEvent.type property = mx.events.ValidationResultEvent.INVALID

Dispatched when validation fails.

The ValidationResultEvent.INVALID constant defines the value of the type property of the event object for an invalid event. The value of this constant is "invalid".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
field | The name of the field that failed validation.
message | A single string that contains every error message from all of the ValidationResult objects in the results Array.
results | An array of ValidationResult objects, one per validated field.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
valid event
Event object type: mx.events.ValidationResultEvent
ValidationResultEvent.type property = mx.events.ValidationResultEvent.VALID

Dispatched when validation succeeds.

The ValidationResultEvent.VALID constant defines the value of the type property of the event object for a validevent. The value of this constant is "valid".

The properties of the event object have the following values:

Property | Value
bubbles | false
cancelable | false
currentTarget | The Object that defines the event listener that handles the event. For example, if you use myButton.addEventListener() to register an event listener, myButton is the value of the currentTarget.
field | An empty String.
message | An empty String.
results | An empty Array.
target | The Object that dispatched the event; it is not always the Object listening for the event. Use the currentTarget property to always access the Object listening for the event.
Constant detail
DECIMAL_DIGITS constant
protected static const DECIMAL_DIGITS:String = "0123456789"

A String containing the decimal digits 0 through 9.

ROMAN_LETTERS constant
protected static const ROMAN_LETTERS:String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz"

A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z").

Examples
SimpleValidatorExample
<?xml version="1.0"?>
<!-- Simple example to demonstrate the Validator class. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        <![CDATA[

            // Import necessary classes.
            import mx.controls.Alert;
            import mx.events.ValidationResultEvent;

            // Event listener for the valid and invalid events.
            private function handleValid(eventObj:ValidationResultEvent):void {
                if(eventObj.type==ValidationResultEvent.VALID)
                    // Enable Submit button.
                    submitButton.enabled = true;
                else
                    submitButton.enabled = false;
            }

            // Submit form is everything is valid.
            private function submitForm():void {
                Alert.show("Form Submitted!");
            }

        ]]>
    </mx:Script>

    <!-- The Validator class defines the required property and the validator events
         used by all validator subclasses. -->
    <mx:Validator id="reqValid" required="true"
        source="{fname}" property="text"
        valid="handleValid(event)" invalid="handleValid(event)"/>

    <mx:Panel title="Validator Example" width="100%" height="100%"
            paddingTop="5" paddingLeft="5" paddingRight="5" paddingBottom="5">

        <mx:Form>
            <mx:Text width="100%" color="blue"
                text="Enter a value in the Name field before you can submit. The E-mail field is optional."/>

            <mx:FormItem label="Name: " required="true">
                <mx:TextInput id="fname" width="100%"/>
            </mx:FormItem>

            <mx:FormItem label="E-mail address: " required="false">
                <mx:TextInput id="email" width="100%"/>
            </mx:FormItem>

            <mx:FormItem>
                <mx:Button id="submitButton" enabled="false"
                    label="Submit" click="submitForm();"/>
            </mx:FormItem>
        </mx:Form>

    </mx:Panel>
</mx:Application>


mx.validators.ZipCodeValidator (Flex™ 2 Language Reference)

Class ZipCodeValidator | Properties | Methods | Events | Constants | Examples
Package | mx.validators
Class | public class ZipCodeValidator
Inheritance | ZipCodeValidator Inheritance Validator Inheritance EventDispatcher Inheritance Object

The ZipCodeValidator class validates that a String has the correct length and format for a five-digit ZIP code, a five-digit+four-digit United States ZIP code, or Canadian postal code.

MXML Syntax collapsed Show MXML Syntax
expanded Hide MXML Syntax

The <mx:ZipCodeValidator> tag inherits all of the tag attributes of its superclass, and adds the following tag attributes:

  <mx:ZipCodeValidator
    allowedFormatChars=" -"
    domain="US Only | US or Canada"
    invalidCharError="The ZIP code contains invalid characters."
    invalidDomainError="The domain parameter is invalid. It must be either 'US Only' or 'US or Canada'."
    wrongCAFormatError="The Canadian ZIP code must be formatted 'A1B 2C3'."
    wrongLengthError="The ZIP code must be 5 digits or 5+4 digits."
    wrongUSFormatError="The ZIP+4 extension must be formatted '12345-6789'."
  />

View the examples.

See also

mx.validators.ZipCodeValidatorDomainType

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
 | allowedFormatChars : String The set of formatting characters allowed in the ZIP code. | ZipCodeValidator
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
 | domain : String Type of ZIP code to check. | ZipCodeValidator
Inherited | enabled : Boolean Setting this value to false will stop the validator from performing validation. | Validator
 | invalidCharError : String Error message when the ZIP code contains invalid characters. | ZipCodeValidator
 | invalidDomainError : String Error message when the domain property contains an invalid value. | ZipCodeValidator
Inherited | listener : Object Specifies the validation listener. | Validator
Inherited | property : String A String specifying the name of the property of the source object that contains the value to validate. | Validator
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
Inherited | required : Boolean If true, specifies that a missing or empty value causes a validation error. | Validator
Inherited | requiredFieldError : String Error message when a value is missing and the required property is true. | Validator
Inherited | source : Object Specifies the object containing the property to validate. | Validator
Inherited | trigger : IEventDispatcher Specifies the component generating the event that triggers the validator. | Validator
Inherited | triggerEvent : String Specifies the event that triggers the validation. | Validator
 | wrongCAFormatError : String Error message for an invalid Canadian postal code. | ZipCodeValidator
 | wrongLengthError : String Error message for an invalid US ZIP code. | ZipCodeValidator
 | wrongUSFormatError : String Error message for an incorrectly formatted ZIP code. | ZipCodeValidator
Protected Properties
Hide Inherited Protected Properties
Show Inherited Protected Properties
Property |  | Defined by
Inherited | actualListeners : Array Contains an Array of listener objects, if any, or the source object. | Validator
Inherited | actualTrigger : IEventDispatcher Contains the trigger object, if any, or the source object. | Validator
Inherited | subFields : Array An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method. | Validator
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method Defined by
ZipCodeValidator()
Constructor.
ZipCodeValidator
Inherited
addEventListener(type:String, listener:Function, useCapture:Boolean = false, priority:int = 0, useWeakReference:Boolean = false):void
Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
EventDispatcher
Inherited
dispatchEvent(event:Event):Boolean
Dispatches an event into the event flow.
EventDispatcher
Inherited
hasEventListener(type:String):Boolean
Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
EventDispatcher
Inherited
hasOwnProperty(name:String):Boolean
Indicates whether an object has a specified property defined.
Object
Inherited
initialized(document:Object, id:String):void
Called automatically by the MXML compiler when the Validator is created using an MXML tag.
Validator
Inherited
isPrototypeOf(theClass:Object):Boolean
Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
Object
Inherited
propertyIsEnumerable(name:String):Boolean
Indicates whether the specified property exists and is enumerable.
Object
Inherited
removeEventListener(type:String, listener:Function, useCapture:Boolean = false):void
Removes a listener from the EventDispatcher object.
EventDispatcher
Inherited
setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void
Sets the availability of a dynamic property for loop operations.
Object
Inherited
toString():String
Returns the string representation of the specified object.
Object
Inherited
validate(value:Object = null, suppressEvents:Boolean = false):ValidationResultEvent
Performs validation and optionally notifies the listeners of the result.
Validator
Inherited
validateAll(validators:Array):Array
[static] Invokes all the validators in the validators Array.
Validator
validateZipCode(validator:ZipCodeValidator, value:Object, baseField:String):Array
[static] Convenience method for calling a validator.
ZipCodeValidator
Inherited
valueOf():Object
Returns the primitive value of the specified object.
Object
Inherited
willTrigger(type:String):Boolean
Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
EventDispatcher
Protected Methods
Hide Inherited Protected Methods
Show Inherited Protected Methods
Method |  | Defined by
Inherited | addListenerHandler():void Sets up all of the listeners for the valid and invalid events dispatched from the validator. | Validator
 | doValidation(value:Object):Array Override of the base class doValidation() method to validate a ZIP code. | ZipCodeValidator
Inherited | getValueFromSource():Object Returns the Object to validate. | Validator
Inherited | handleResults(errorResults:Array):ValidationResultEvent Returns a ValidationResultEvent from the Array of error results. | Validator
Inherited | isRealValue(value:Object):Boolean Returns true if value is null. | Validator
Inherited | removeListenerHandler():void Disconnects all of the listeners for the valid and invalid events dispatched from the validator. | Validator
Events
Hide Inherited Events
Show Inherited Events
Event |  | Summary | Defined by
Inherited | invalid | Dispatched when validation fails. | Validator
Inherited | valid | Dispatched when validation succeeds. | Validator
Protected Constants
Hide Inherited Protected Constants
Show Inherited Protected Constants
Constant |  | Defined by
Inherited | DECIMAL_DIGITS : String = "0123456789" [static] A String containing the decimal digits 0 through 9. | Validator
Inherited | ROMAN_LETTERS : String = "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz" [static] A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z"). | Validator
Property detail
allowedFormatChars property
allowedFormatChars:String [read-write]

The set of formatting characters allowed in the ZIP code. This can not have digits or alphabets [a-z A-Z].

The default value is " -"..

Implementation
    public function get allowedFormatChars():String
    public function set allowedFormatChars(value:String):void
domain property
public var domain:String

Type of ZIP code to check. In MXML, valid values are "US or Canada" and "US Only".

In ActionScript, you can use the following constants to set this property: ZipCodeValidatorDomainType.US_ONLY and ZipCodeValidatorDomainType.US_OR_CANADA.

The default value is ZipCodeValidatorDomainType.US_ONLY.

invalidCharError property
public var invalidCharError:String

Error message when the ZIP code contains invalid characters.

The default value is "The ZIP code contains invalid characters.".

invalidDomainError property
public var invalidDomainError:String

Error message when the domain property contains an invalid value.

The default value is "The domain parameter is invalid. It must be either 'US Only' or 'US or Canada'.".

wrongCAFormatError property
public var wrongCAFormatError:String

Error message for an invalid Canadian postal code.

The default value is "The Canadian postal code must be formatted 'A1B 2C3'.".

wrongLengthError property
public var wrongLengthError:String

Error message for an invalid US ZIP code.

The default value is "The ZIP code must be 5 digits or 5+4 digits.".

wrongUSFormatError property
public var wrongUSFormatError:String

Error message for an incorrectly formatted ZIP code.

The default value is "The ZIP+4 code extension must be formatted '12345-6789'.".

Constructor detail
ZipCodeValidator () constructor
public function ZipCodeValidator()

Constructor.

Method detail
doValidation () method
protected override function doValidation(value:Object):Array

Override of the base class doValidation() method to validate a ZIP code.

You do not call this method directly; Flex calls it as part of performing a validation. If you create a custom Validator class, you must implement this method.

Parameters
value:Object — Object to validate.

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.
validateZipCode () method
public static function validateZipCode(validator:ZipCodeValidator, value:Object, baseField:String):Array

Convenience method for calling a validator. Each of the standard Flex validators has a similar convenience method.

Parameters
validator:ZipCodeValidator — The ZipCodeValidator instance.
value:Object — A field to validate.
baseField:String — Text representation of the subfield specified in the value parameter. For example, if the value parameter specifies value.zipCode, the baseField value is "zipCode".

Returns
Array — An Array of ValidationResult objects, with one ValidationResult object for each field examined by the validator.

See also

mx.validators.ValidationResult
Examples
ZipCodeValidatorExample
<?xml version="1.0" encoding="utf-8"?>
<!-- Simple example to demonstrate the ZipCodeValidator. -->
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

    <mx:Script>
        import mx.controls.Alert;
    </mx:Script>

    <mx:ZipCodeValidator source="{zip}" property="text"
        trigger="{myButton}" triggerEvent="click"
        valid="Alert.show('Validation Succeeded!');"/>

    <mx:Panel title="ZipcodeValidator Example" width="75%" height="75%"
        paddingTop="10" paddingLeft="10" paddingRight="10" paddingBottom="10">

        <mx:Form>
            <mx:FormItem label="Enter a 5 or 9 digit U.S. Zip code: ">
                <mx:TextInput id="zip" width="100%"/>
            </mx:FormItem>

            <mx:FormItem >
                <mx:Button id="myButton" label="Validate" />
            </mx:FormItem>
        </mx:Form>
    </mx:Panel>
</mx:Application>


mx.validators.ZipCodeValidatorDomainType (Flex™ 2 Language Reference)

Class ZipCodeValidatorDomainType | Properties | Methods
Package | mx.validators
Class | public final class ZipCodeValidatorDomainType
Inheritance | ZipCodeValidatorDomainType Inheritance Object

The ZipCodeValidatorDomainType class defines the values for the domain property of the ZipCodeValidator class, which you use to specify the type of ZIP code to validate.

See also

mx.validators.ZipCodeValidator

Public Properties
Hide Inherited Public Properties
Show Inherited Public Properties
Property |  | Defined by
Inherited | constructor : Object A reference to the class object or constructor function for a given object instance. | Object
Inherited | prototype : Object [static] A reference to the prototype object of a class or function object. | Object
 | US_ONLY : String = "US Only" [static] Specifies to validate a United States ZIP code. | ZipCodeValidatorDomainType
 | US_OR_CANADA : String = "US or Canada" [static] Specifies to validate a United States or Canadian ZIP code. | ZipCodeValidatorDomainType
Public Methods
Hide Inherited Public Methods
Show Inherited Public Methods
Method |  | Defined by
Inherited | hasOwnProperty(name:String):Boolean Indicates whether an object has a specified property defined. | Object
Inherited | isPrototypeOf(theClass:Object):Boolean Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter. | Object
Inherited | propertyIsEnumerable(name:String):Boolean Indicates whether the specified property exists and is enumerable. | Object
Inherited | setPropertyIsEnumerable(name:String, isEnum:Boolean = true):void Sets the availability of a dynamic property for loop operations. | Object
Inherited | toString():String Returns the string representation of the specified object. | Object
Inherited | valueOf():Object Returns the primitive value of the specified object. | Object
Property detail
US_ONLY property
public static var US_ONLY:String = "US Only"

Specifies to validate a United States ZIP code.

US_OR_CANADA property
public static var US_OR_CANADA:String = "US or Canada"

Specifies to validate a United States or Canadian ZIP code.


All MX Packages (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
All MX Packages

This section describes the Flex mx.* packages.

Package | Description
mx.binding.utils | The mx.binding.utils package contains the classes for creating binding watchers and for defining bindings in ActionScript.
mx.charts | The mx.charts package contains the classes for Flex Charting.
mx.charts.chartClasses | The mx.charts.chartClasses package contains the base classes for the Flex charting components.
mx.charts.effects | The mx.charts.effects package contains the effect classes for the Flex charting components.
mx.charts.effects.effectClasses | The mx.charts.effects.effectClasses package contains the effect instance classes for the Flex charting components.
mx.charts.events | The mx.charts.events package contains the classes that define chart event objects.
mx.charts.renderers | The mx.charts.renderers package contains the item renderer classes for the Flex charting components.
mx.charts.series | The mx.charts.series package contains the series classes for the Flex charting components.
mx.charts.series.items | The mx.charts.series.items package contains the items series classes for the Flex charting components.
mx.charts.series.renderData | The mx.charts.series.renderData package contains the data classes for the Flex charting components.
mx.collections | The mx.collections package contains the classes for the Flex collection components.
mx.collections.errors | The mx.collections.errors package contains the error classes for the Flex collection components.
mx.containers | The mx.containers package contains the container classes.
mx.containers.accordionClasses | The mx.containers.accordionClasses package contains the classes used by the Accordion container.
mx.controls | The mx.controls package contains the Flex user-interface controls.
mx.controls.dataGridClasses | The mx.controls.dataGridClasses package contains the classes used by the DataGrid control.
mx.controls.listClasses | The mx.controls.listClasses package contains the classes used by the list-based controls.
mx.controls.menuClasses | The mx.controls.menuClasses package contains the classes used by the menu-based controls.
mx.controls.scrollClasses | The mx.controls.scrollClasses package contains the classes used by controls that support scroll bars.
mx.controls.sliderClasses | The mx.controls.sliderClasses package contains the classes used by the Slider control.
mx.controls.textClasses | The mx.controls.textClasses package contains the classes used by the text-based controls.
mx.controls.treeClasses | The mx.controls.treeClasses package contains the classes used by the Tree control.
mx.controls.videoClasses | The mx.controls.videoClasses package contains the classes used by the VideoDisplay control.
mx.core | The mx.core package contains the base classes and interfaces, such as UIComponent, used by Flex.
mx.data | The mx.data package contains classes for working with the Flex Data Management Service.
mx.data.errors | The mx.data.errors package contains the error classes used with the Flex Data Management Service.
mx.data.events | The mx.data.events package contains the event classes used with the Flex Data Management Service.
mx.data.messages | The mx.data.messages package contains the messages used with the Flex Data Management Service.
mx.data.mxml |
mx.data.utils |
mx.effects | The mx.effects package contains the Factory classes to support behaviors.
mx.effects.easing | The mx.effects.easing package contains the easing classes used by effects.
mx.effects.effectClasses | The mx.effects.effectClasses package contains the effect implementation classes corresponding to the effect factory classes in the mx.effects package.
mx.events | The mx.events package contains the classes that define Flex event objects.
mx.formatters | The mx.formatters package contains the classes to support data formatting.
mx.graphics | The mx.graphics package contains drawing classes.
mx.logging | The mx.logging package contains the logging classes.
mx.logging.errors | The mx.logging.errors package contains the error classes used by the logging components.
mx.logging.targets | The mx.logging.targets package contains the target classes used by the logging components.
mx.managers | The mx.managers package contains the Flax manager classes, such as DragManager and HistoryManager.
mx.messaging | The mx.messaging package contains the messaging classes used with Flex Data Services.
mx.messaging.channels | The mx.messaging.channels package contains the messaging channel classes used with Flex Data Services.
mx.messaging.config | The mx.messaging.config package contains the messaging configuration classes used with Flex Data Services.
mx.messaging.errors | The mx.messaging.errors package contains the messaging error classes used with Flex Data Services.
mx.messaging.events | The mx.messaging.events package contains the messaging event classes used used with Flex Data Services.
mx.messaging.management | The mx.messaging.management package contains the bean management classes used with Flex Data Services.
mx.messaging.messages | The mx.messaging.messages package contains the message classes used with Flex Data Services.
mx.preloaders | The mx.preloaders package contains the classes used by the download progress bar.
mx.printing | The mx.printing package contains the printing classes.
mx.resources | The mx.resources package contains the classes used to support localization.
mx.rpc | The mx.rpc package contains the RPC classes.
mx.rpc.events | The mx.rpc.events package contains the RPC event classes.
mx.rpc.http | The mx.rpc.http package contains the HTTPService classes.
mx.rpc.http.mxml | The mx.rpc.http.mxml package contains the HTTP service MXML classes.
mx.rpc.mxml | The mx.rpc.mxml package contains the RPC MXML interface.
mx.rpc.remoting | The mx.rpc.remoting package contains the remote object classes.
mx.rpc.remoting.mxml | The mx.rpc.remoting.mxml package contains the remote object MXML classes.
mx.rpc.soap | The mx.rpc.soap package contains the web service classes.
mx.rpc.soap.mxml | The mx.rpc.soap.mxml package contains the web service MXML class.
mx.rpc.xml | The mx.rpc.xml package contains the RPC XML-related classes.
mx.skins | The mx.skins package contains the classes that define the skinning components.
mx.skins.halo | The mx.skins.halo package contains the classes used to skin Flex user-interface controls.
mx.states | The mx.states package contains the classes to support view states.
mx.styles | The mx.styles package contains the classes used by the Flex styles components.
mx.utils | The mx.utils package contains Flex utility classes.
mx.validators | The mx.validators package contains the classes to support data validation.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Mon Jun 19 2006, 11:01 AM GMT-07:00


All Flash Player Packages (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
All Flash Player Packages

The Flash Player API classes are in the flash.* packages. The Flash Player API refers to All Packages, classes, functions, properties, constants, events, and errors that are in the flash package. They are unique to Flash Player, as opposed to the top-level classes, such as Date, Math, and XML, or the Language Elements, which are based on ECMAScript. The Flash Player API contains features that you expect to find in object-oriented programming languages, such as the flash.geom package for geometry classes, as well as features specific to the needs of rich Internet applications, such as the flash.filters package for expressiveness and the flash.net package for handling data transmission to and from a server.

Package | Description
Top Level | The top level contains the core ActionScript classes and global functions.
flash.accessibility | The flash.accessibility package contains classes for supporting accessibility in Flash content and applications.
flash.display | The flash.display package contains the core classes that the Flash Player uses to build visual displays.
flash.errors | The flash.errors package contains a set of commonly used error classes.
flash.events | The flash.events package supports the new DOM event model and includes the EventDispatcher base class.
flash.external | The flash.external package contains the ExternalInterface class which can be used to communicate with the Flash Player's container.
flash.filters | The flash.filters package contains classes for bitmap filter effects.
flash.geom | The flash.geom package contains geometry classes, such as points, rectangles and transformation matrixes, to support the BitmapData class and the bitmap caching feature.
flash.media | The flash.media package contains classes for working with multimedia assets such as sound and video.
flash.net | The flash.net package contains classes for sending and receiving from the network, such as URL downloading and Flash Remoting.
flash.printing | The flash.printing package contains classes for printing Flash-based content.
flash.profiler | The flash.profiler package contains functions used for debugging and profiling ActionScript code.
flash.system | The flash.system package contains classes for accessing system-level functionality, such as security, multilanguage content, etc.
flash.text | The flash.text package contains classes for working with text fields, text formatting, text metrics, style sheets, and layout.
flash.ui | The flash.ui package contains user interface classes, such as classes for interacting with the mouse and keyboard.
flash.utils | The flash.utils package contains utility classes, such as data structures like ByteArray.
flash.xml | The flash.xml package contains Flash Player's legacy XML support, and other Flash Player-specific XML functionality.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Mon Jun 19 2006, 11:01 AM GMT-07:00


All Classes (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | Language Elements | Index | Appendixes | Conventions Adobe Logo
All Classes

Documentation for classes includes syntax, usage information, and code samples for methods, properties, and event handlers and listeners for those APIs that belong to a specific class in ActionScript (as opposed to global functions or properties). The classes are listed alphabetically. If you are not sure to which class a certain method or property belongs, you can look it up in the Index.

Class Package Description
AbstractEvent
mx.rpc.events The base class for events that RPC services dispatch.
AbstractInvoker
mx.rpc An invoker is an object that actually executes an remote procedure call (RPC).
AbstractMessage
mx.messaging.messages Abstract base class for all messages.
AbstractOperation
mx.rpc The AbstractOperation class represents an is an individual method on a service.
AbstractService
mx.rpc the AbstractService class is the base class for the WebService and RemoteObject classes.
AbstractTarget
mx.logging This class provides the basic functionality required by the logging framework for a target implementation.
Accessibility
flash.accessibility The Accessibility class manages communication with screen readers.
AccessibilityProperties
flash.accessibility The AccessibilityProperties class lets you control the presentation of Flash objects to accessibility aids, such as screen readers.
Accordion
mx.containers An Accordion navigator container has a collection of child containers, but only one of them at a time is visible.
AccordionHeader
mx.containers.accordionClasses The AccordionHeader class defines the appearance of the navigation buttons of an Accordion.
AccordionHeaderSkin
mx.skins.halo The skin for all the states of an AccordionHeader in an Accordion.
AcknowledgeMessage
mx.messaging.messages An AcknowledgeMessage acknowledges the receipt of a message that was sent previously.
ActionEffectInstance
mx.effects.effectClasses The ActionEffectInstance class is the superclass for all action effect instance classes.
ActionScriptVersion
flash.display The ActionScriptVersion class is an enumeration of constant values that indicate the language version of a loaded SWF file.
ActivatorSkin
mx.skins.halo Defines the up, down, and over states for MenuBarItem objects.
ActivityEvent
flash.events Flash® Player dispatches an ActivityEvent object whenever a camera or microphone reports that it has become active or inactive.
AddChild
mx.states The AddChild class adds a child display object, such as a component, to a container as part of a view state.
AddChildAction
mx.effects The AddChildAction class defines an action effect that corresponds to the AddChild property of a view state definition.
AddChildActionInstance
mx.effects.effectClasses The AddChildActionInstance class implements the instance class for the AddChildAction effect.
Alert
mx.controls The Alert control is a pop-up dialog box that can contain a message, a title, buttons (any combination of OK, Cancel, Yes, and No) and an icon.
AMFChannel
mx.messaging.channels The AMFChannel class provides the AMF support for messaging.
AnimateProperty
mx.effects The AnimateProperty effect animates a property or style of a component.
AnimatePropertyInstance
mx.effects.effectClasses The AnimatePropertyInstance class implements the instance class for the AnimateProperty effect.
AntiAliasType
flash.text The AntiAliasType class provides values for anti-aliasing in the flash.text.TextField class.
Application
mx.core Flex defines a default, or Application, container that lets you start adding content to your application without explicitly defining another container.
ApplicationControlBar
mx.containers The ApplicationControlBar container holds components that provide global navigation and application commands.
ApplicationDomain
flash.system The ApplicationDomain class is a container for discrete groups of class definitions.
AreaChart
mx.charts The AreaChart control represents data as an area bounded by a line connecting the values in the data.
AreaRenderer
mx.charts.renderers The default class used to render the area beneath the dataPoints of an AreaSeries object.
AreaSeries
mx.charts.series Defines a data series for an AreaChart control.
AreaSeriesItem
mx.charts.series.items Represents the information required to render an item as part of an AreaSeries.
AreaSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the AreaSeries to render.
AreaSet
mx.charts.series A grouping set that can be used to stack AreaSeries objects in any chart.
ArgumentError
Top Level The ArgumentError class represents an error that occurs when the arguments supplied in a function do not match the arguments defined for that function.
arguments
Top Level An arguments object is used to store and access a function's arguments.
Array
Top Level The Array class lets you access and manipulate arrays.
ArrayCollection
mx.collections The ArrayCollection class is a wrapper class that exposes an Array as a collection that can be accessed and manipulated using the methods and properties of the ICollectionView or IList interfaces.
ArrayUtil
mx.utils The ArrayUtil utility class is an all-static class with methods for working with arrays within Flex.
AsyncErrorEvent
flash.events Flash® Player dispatches an AsyncErrorEvent when an exception is thrown from native asynchronous code, which could be from, for example, LocalConnection, NetConnection, SharedObject, or NetStream.
AsyncMessage
mx.messaging.messages AsyncMessage is the base class for all asynchronous messages.
AsyncRequest
mx.rpc The AsyncRequest class provides an abstraction of messaging for RPC call invocation.
AsyncToken
mx.rpc This class provides a place to set additional or token-level data for asynchronous rpc operations.
AVM1Movie
flash.display AVM1Movie is a simple class that represents AVM1 movie clips, which use ActionScript 1.0 or 2.0.
AxisBase
mx.charts.chartClasses The AxisBase class serves as a base class for the various axis types supported in Flex.
AxisLabel
mx.charts An AxisLabel object represents a single label on the chart axis.
AxisLabelSet
mx.charts.chartClasses An AxisLAbelSet represents the label and tick data generated by an implementation of IAxis.
AxisRenderer
mx.charts You use the AxisRenderer class to describe the horizontal and vertical axes of a chart.
Back
mx.effects.easing The Back class defines three easing functions to implement motion with Flex effect classes.
BarChart
mx.charts The BarChart control represents data as a series of horizontal bars whose length is determined by values in the data.
BarSeries
mx.charts.series Defines a data series for a BarChart control.
BarSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a BarSeries.
BarSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the BarSeries to render.
BarSet
mx.charts.series A grouping set that can be used to stack or cluster BarSeries objects in any chart.
BaseListData
mx.controls.listClasses The BaseListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors.
BevelFilter
flash.filters The BevelFilter class lets you add a bevel effect to display objects.
BindingUtils
mx.binding.utils The BindingUtils class defines utility methods for performing data binding from ActionScript.
Bitmap
flash.display The Bitmap class represents display objects that represent bitmap images.
BitmapAsset
mx.core BitmapAsset is a subclass of the Flash Player's Bitmap class which represents bitmap images that you embed in a Flex application.
BitmapData
flash.display The BitmapData class lets you work with the data (pixels) of a Bitmap object.
BitmapDataChannel
flash.display The BitmapDataChannel class is an enumeration of constant values that indicate which channel to use: red, blue, green, or alpha transparency.
BitmapFill
mx.graphics Defines a set of values used to fill an area on screen with a bitmap or other DisplayObject.
BitmapFilter
flash.filters The BitmapFilter class is the base class for all image filter effects.
BitmapFilterQuality
flash.filters The BitmapFilterQuality class contains values to set the rendering quality of a BitmapFilter object.
BitmapFilterType
flash.filters The BitmapFilterType class contains values to set the type of a BitmapFilter.
BlendMode
flash.display A class that provides constant values for visual blend mode effects.
Blur
mx.effects The Blur effect lets you apply a blur visual effect to a component.
BlurFilter
flash.filters The BlurFilter class lets you apply a blur visual effect to display objects.
BlurInstance
mx.effects.effectClasses The BlurInstance class implements the instance class for the Blur effect.
Boolean
Top Level A Boolean object is a data type that can have one of two values, either true or false, used for logical operations.
Border
mx.skins The Border class is an abstract base class for various classes that draw borders, either rectangular or non-rectangular, around UIComponents.
Bounce
mx.effects.easing The Bounce class defines three easing functions to implement bounce motion with Flex effect classes.
BoundedValue
mx.charts.chartClasses A bounded value is used to represent a datapoint that a chart element intends to render on screen.
Box
mx.containers A Box container lays out its children in a single vertical column or a single horizontal row.
BoxDirection
mx.containers The BoxDirection class specifies constant values for the direction property of the Box container.
BoxItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a rectangular area.
BrokenImageBorderSkin
mx.skins.halo The skin for the border of a SWFLoader or Image component when the content could not be loaded.
BubbleChart
mx.charts The BubbleChart control represents data with three values for each data point.
BubbleSeries
mx.charts.series Defines a data series for a BubbleChart control.
BubbleSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a BubbleSeries.
BubbleSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the BubbleSeries to render.
Button
mx.controls The Button control is a commonly used rectangular button.
ButtonAsset
mx.core ButtonAsset is a subclass of the Flash Player's SimpleButton class which represents button symbols that you embed in a Flex application from a SWF file produced by Flash.
ButtonBar
mx.controls The ButtonBar control defines a horizontal or vertical group of logically related push buttons with a common look and navigation.
ButtonBarButtonSkin
mx.skins.halo The skin for all the states of the ButtonBarButtons in a ButtonBar.
ButtonLabelPlacement
mx.controls The ButtonLabelPlacement class defines the constants for the allowed values of the labelPlacement property of a Button, CheckBox, LinkButton, or RadioButton control.
ButtonSkin
mx.skins.halo The skin for all the states of a Button.
ByteArray
flash.utils The ByteArray class provides methods and properties to optimize reading, writing, and working with binary data.
CalendarLayoutChangeEvent
mx.events The CalendarLayoutChangeEvent class represents the event object passed to the event listener for the change event for the DateChooser and DateField controls.
Camera
flash.media The Camera class is primarily for use with Flash Media Server, but can be used in a limited way without the server.
CandlestickChart
mx.charts The CandlestickChart control represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
CandlestickItemRenderer
mx.charts.renderers The default itemRenderer for a CandlestickSeries object.
CandlestickSeries
mx.charts.series Represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
Canvas
mx.containers A Canvas layout container defines a rectangular region in which you place child containers and controls.
Capabilities
flash.system The Capabilities class provides properties that describe the system and player that are hosting a SWF file.
CapsStyle
flash.display The CapsStyle class is an enumeration of constant values that specify the caps style to use in drawing lines.
CartesianChart
mx.charts.chartClasses The CartesianChart class is a base class for the common chart types.
CartesianTransform
mx.charts.chartClasses The CartesianTransform object represents a set of axes sed to map data values to x/y Cartesian screen coordinates and vice versa.
CategoryAxis
mx.charts The CategoryAxis class lets charts represent data grouped by a set of discrete values along an axis.
ChangeWatcher
mx.binding.utils The ChangeWatcher class defines utility methods that you can use with bindable Flex properties.
Channel
mx.messaging The Channel class is the base message channel class that all channels in the messaging system must extend.
ChannelError
mx.messaging.errors This is the base class for any channel related errors.
ChannelEvent
mx.messaging.events The ChannelEvent is used to propagate channel events within the messaging system.
ChannelFaultEvent
mx.messaging.events The ChannelFaultEvent class is used to propagate channel fault events within the messaging system.
ChannelSet
mx.messaging The ChannelSet is a set of Channels that are used to send messages to a target destination.
ChartBase
mx.charts.chartClasses The ChartBase class is the link between the Flex component architecture and the DualStyleObject architecture.
ChartElement
mx.charts.chartClasses The ChartElement class is the base class for visual chart elements.
ChartItem
mx.charts A ChartItem represents a single item in a ChartSeries.
ChartItemEvent
mx.charts.events The ChartItemEvent class represents events that are specific to the chart components, such as when a chart item is clicked.
ChartLabel
mx.charts.chartClasses Draws data labels on chart controls.
ChartState
mx.charts.chartClasses Describes the current state of a chart.
CheckBox
mx.controls The CheckBox control consists of an optional label and a small box that can contain a check mark or not.
CheckBoxIcon
mx.skins.halo The skin for all the states of the icon in a CheckBox.
ChildExistenceChangedEvent
mx.events Represents events that are dispatched when a the child of a control is created or destroyed.
CircleItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills an elliptical area.
Circular
mx.effects.easing The Circular class defines three easing functions to implement circular motion with Flex effect classes.
Class
Top Level A Class object is created for each class definition in a program.
ClassFactory
mx.core A ClassFactory instance is a "factory object" which Flex uses to generate instances of another class, each with identical properties.
CloseEvent
mx.events The CloseEvent class represents event objects specific to popup windows, such as the Alert control.
CollectionEvent
mx.events The mx.events.CollectionEvent class represents an event that is dispatched when the associated collection changes.
CollectionEventKind
mx.events The CollectionEventKind class contains constants for the valid values of the mx.events.CollectionEvent class kind property.
CollectionViewError
mx.collections.errors The CollectionViewError class represents general errors within a collection that are not related to specific activities such as Cursor seeking.
ColorMatrixFilter
flash.filters The ColorMatrixFilter class lets you apply a 4 x 5 matrix transformation on the RGBA color and alpha values of every pixel in the input image to produce a result with a new set of RGBA color and alpha values.
ColorPicker
mx.controls The ColorPicker control provides a way for a user to choose a color from a swatch list.
ColorPickerEvent
mx.events Represents events that are specific to the ColorPicker control, such as when the user rolls the mouse over or out of a swatch in the swatch panel.
ColorPickerSkin
mx.skins.halo The skin for all the states of a ColorPicker.
ColorTransform
flash.geom The ColorTransform class lets you adjust the color values in a display object.
ColorUtil
mx.utils The ColorUtil class is an all-static class with methods for working with RGB colors within Flex.
ColumnChart
mx.charts The ColumnChart control represents data as a series of vertical columns whose height is determined by values in the data.
ColumnSeries
mx.charts.series Defines a data series for a ColumnChart control.
ColumnSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a ColumnSeries.
ColumnSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the ColumnSeries to render.
ColumnSet
mx.charts.series ColumnSet is a grouping set that can be used to stack or cluster column series in any arbitrary chart.
ComboBase
mx.controls The ComboBase class is the base class for controls that display text in a text field and have a button that causes a drop-down list to appear where the user can choose which text to display.
ComboBox
mx.controls The ComboBox control contains a drop-down list from which the user can select a single value.
ComboBoxArrowSkin
mx.skins.halo The skin for all the states of the button in a ComboBox.
CommandMessage
mx.messaging.messages The CommandMessage class provides a mechanism for sending commands to the server infrastructure, such as commands related to publish/subscribe messaging scenarios, ping operations, and cluster operations.
ComponentDescriptor
mx.core ComponentDescriptor is the base class for the UIComponentDescriptor class, which encapsulates the information that you specified in an MXML tag for an instance of a visual component.
CompositeEffect
mx.effects The CompositeEffect class is the parent class for the Parallel and Sequence classes, which define the <mx:Parallel> and <mx:Sequence> MXML tags.
CompositeEffectInstance
mx.effects.effectClasses The CompositeEffectInstance class implements the instance class for the CompositeEffect class.
Conflict
mx.data The Conflict class is used to represent error that has occurred due to an update operation.
ConflictDetector
mx.data A DataService instance uses a ConflictDetector instance to determine when a conflict occurs for an operation pushed from a remote destination.
Conflicts
mx.data The Conflicts class represents a list of conflicts.
Consumer
mx.messaging A Consumer subscribes to a destination to receive messages.
Container
mx.core The Container class is an abstract base class for components that controls the layout characteristics of child components.
ContainerCreationPolicy
mx.core The ContainerCreationPolicy class defines the constant values for the creationPolicy property of the Container class.
ContainerLayout
mx.core The ContainerLayout class defines the constant values for the layout property of container classes.
ContextMenu
flash.ui The ContextMenu class provides control over the items in the Flash Player context menu.
ContextMenuBuiltInItems
flash.ui The ContextMenuBuiltInItems class describes the items that are built in to a context menu.
ContextMenuEvent
flash.events Flash® Player dispatches ContextMenuEvent objects when a user generates or interacts with the context menu.
ContextMenuItem
flash.ui Use the ContextMenuItem class to create custom menu items to display in the Flash Player context menu.
ControlBar
mx.containers The ControlBar container lets you place controls at the bottom of a Panel or TitleWindow container.
ConvolutionFilter
flash.filters The ConvolutionFilter class applies a matrix convolution filter effect.
CreditCardValidator
mx.validators The CreditCardValidator class validates that a credit card number is the correct length, has the correct prefix, and passes the Luhn mod10 algorithm for the specified card type.
CreditCardValidatorCardType
mx.validators The CreditCardValidatorCardType class defines value constants for specifying the type of credit card to validate.
CrossItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a cross in its assigned area.
CSMSettings
flash.text The CSMSettings class contains properties for use with the TextRenderer.setAdvancedAntiAliasingTable() method to provide continuous stroke modulation (CSM).
CSSStyleDeclaration
mx.styles The CSSStyleDeclaration class represents a set of CSS style rules.
Cubic
mx.effects.easing The Cubic class defines three easing functions to implement motion with Flex effect classes.
CuePointEvent
mx.events The CuePointEvent class represents the event object passed to the event listener for cue point events dispatched by the VideoDisplay control.
CuePointManager
mx.controls.videoClasses The CuePointManager class lets you use ActionScript code to manage the cue points associated with the VideoDisplay control.
CurrencyFormatter
mx.formatters The CurrencyFormatter class formats a valid number as a currency value.
CurrencyValidator
mx.validators The CurrencyValidator class ensures that a String represents a valid currency expression.
CurrencyValidatorAlignSymbol
mx.validators The CurrencyValidatorAlignSymbol class defines value constants for specifying currency symbol alignment.
CursorBookmark
mx.collections Encapsulates the positional aspects of a cursor in an ICollectionView.
CursorError
mx.collections.errors This error is thrown by a collection Cursor.
CursorManager
mx.managers The CursorManager class controls a prioritized list of cursors, where the cursor with the highest priority is currently visible.
CursorManagerPriority
mx.managers The CursorManagerPriority class defines the constant values for the priority argument to the CursorManager.setCursor() method.
DataAssociationMessage
mx.data.messages This message is used to add and remove associations between objects managed by different data services.
DataConflictEvent
mx.data.events This event informs users of a DataService instance that a conflict has occured.
DataDescription
mx.charts.chartClasses The DataDescription structure is used by ChartElements to describe the characteristics of the data they represent to Axis objects that auto-generate values from the data represented in the chart.
DataErrorMessage
mx.data.messages Special cases of ErrorMessage will be sent when a data conflict occurs.
DataEvent
flash.events Flash® Player dispatches DataEvent objects when raw data has completed loading into Flash Player.
DataGrid
mx.controls The DataGrid control is a like a List except that it can show more than one column of data making it suited for showing objects with multiple properties.
DataGridBase
mx.controls.dataGridClasses The DataGridBase class is the base class for controls that display lists of items in multiple columns.
DataGridColumn
mx.controls.dataGridClasses The DataGridColumn class describes a column in a DataGrid control.
DataGridColumnDropIndicator
mx.skins.halo The skin for the column drop indicator in a DataGrid.
DataGridColumnResizeSkin
mx.skins.halo The skin for the column resizer in a DataGrid.
DataGridDragProxy
mx.controls.dataGridClasses The DataGridDragProxy class defines the default drag proxy used when dragging data from a DataGrid control.
DataGridEvent
mx.events The DataGridEvent class represents event objects that are specific to the DataGrid control, such as the event that is dispatched when an editable grid item gets the focus.
DataGridEventReason
mx.events The DataGridEventReason class defines constants for the values of the reason property of a DataGridEvent object when the type property is itemEditEnd.
DataGridHeaderSeparator
mx.skins.halo The skin for the separator between column headers in a DataGrid.
DataGridItemRenderer
mx.controls.dataGridClasses The DataGridItemRenderer class defines the default item renderer for a DataGrid control.
DataGridListData
mx.controls.dataGridClasses The DataGridListData class defines the data type of the listData property that is implemented by drop-in item renderers or drop-in item editors for the DataGrid control.
DataGridSortArrow
mx.skins.halo The skin for the sort arrow in a column header in a DataGrid.
DataListError
mx.data.errors This error is thrown when an unanticipated problem occurs in a DataList.
DataMessage
mx.data.messages This message is used to transport an operation that occured on a managed object or collection.
DataService
mx.data.mxml The DataService class provides the top-level functionality for distributed data in Flex 2.
DataService
mx.data The DataService class provides the top-level functionality for Data Management Services in Flex 2.
DataServiceError
mx.data.errors This error is thrown when a an unanticipated problem occurs in a DataService component.
DataServiceFaultEvent
mx.data.events This event is sent when a DataService or DataStore has generated a fault.
DataStore
mx.data A DataStore batches transactions for one or more DataService instances.
DataTip
mx.charts.chartClasses The DataTip control provides information about a data point to chart users.
DataTransform
mx.charts.chartClasses The DataTransform object represents a portion of a chart that contains glyphs and can transform values to screen coordinates and vice versa.
Date
Top Level The Date class represents date and time information.
DateBase
mx.formatters The DateBase class contains the localized string information used by the mx.formatters.DateFormatter class and the parsing function that renders the pattern.
DateChooser
mx.controls The DateChooser control displays the name of a month, the year, and a grid of the days of the month, with columns labeled for the day of the week.
DateChooserEvent
mx.events The DateChooserEvent class represents the event object passed to the event listener for the scroll event for the DateChooser and DateField controls.
DateChooserEventDetail
mx.events Constants that define the values of the detail property of a DateChooserEvent object.
DateChooserIndicator
mx.skins.halo The skins of the DateChooser's indicators for displaying today, rollover and selected dates.
DateChooserMonthArrowSkin
mx.skins.halo The skin for all the states of the next-month and previous-month buttons in a DateChooser.
DateChooserYearArrowSkin
mx.skins.halo The skin for all the states of the next-year and previous-year buttons in a DateChooser.
DateField
mx.controls The DateField control is a text field that shows the date with a calendar icon on its right side.
DateFormatter
mx.formatters The DateFormatter class uses a format String to render date and time Strings from a String or a Date object.
DateTimeAxis
mx.charts The DateTimeAxis class maps time values evenly between a minimum and maximum value along a chart axis.
DateValidator
mx.validators The DateValidator class validates that a String or Object contains a proper date and matches a specified format.
DefaultDataDescriptor
mx.controls.treeClasses The DefaultDataDescriptor class provides a default implementation for accessing and manipulating data for use in controls such as Tree and Menu.
DeferredInstanceFromClass
mx.core A deferred instance factory that creates and returns an instance of a specified class.
DeferredInstanceFromFunction
mx.core A deferred instance factory that uses a generator function to create an instance of the required object.
DefinitionError
Top Level The DefinitionError class represents an error that occurs when user code attempts to define an identifier that is already defined.
DescribeTypeCache
mx.utils DescribeTypeCache is a convenience class that is used to cache the return values of flash.utils.describeType() so that calls made subsequent times return faster.
DescribeTypeCacheRecord
mx.utils This class represents a single cache entry, this gets created as part of the describeType method call on the DescribeTypeCache class.
DiamondItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a diamond in its assigned area.
Dictionary
flash.utils The Dictionary class lets you create a dynamic collection of properties, which uses strict equality (===) for key comparison.
DisplacementMapFilter
flash.filters The DisplacementMapFilter class uses the pixel values from the specified BitmapData object (called the displacement map image) to perform a displacement of an object.
DisplacementMapFilterMode
flash.filters The DisplacementMapFilterMode class provides values for the mode property of the DisplacementMapFilter class.
DisplayObject
flash.display The DisplayObject class is the base class for all objects that can be placed on the display list.
DisplayObjectContainer
flash.display The DisplayObjectContainer class is the base class for all objects that can serve as display object containers on the display list.
Dissolve
mx.effects Animate the component from transparent to opaque, or from opaque to transparent.
DissolveInstance
mx.effects.effectClasses The DissolveInstance class implements the instance class for the Dissolve effect.
DividedBox
mx.containers A DividedBox container measures and lays out its children horizontally or vertically in exactly the same way as a Box container, but it inserts draggable dividers in the gaps between the children.
DividerEvent
mx.events Represents events that are dispatched when a divider has been pressed, dragged or released.
DownloadProgressBar
mx.preloaders The DownloadProgressBar class displays download progress.
DragEvent
mx.events The DragEvent class represents event objects that are dispatched as part of a drag-and-drop operation.
DragManager
mx.managers The DragManager class manages drag and drop operations, which let you move data from one place to another in a Flex application.
DragSource
mx.core The DragSource class contains the data being dragged.
DropdownEvent
mx.events The DropdownEvent class represents the event object passed to the event listener for the open and close events.
DropShadowFilter
flash.filters The DropShadowFilter class lets you add a drop shadow to display objects.
DualStyleObject
mx.charts.chartClasses The DualStyleObject class serves as a base class for components that have a need to assign class selectors outside of the client developer's control.
DynamicEvent
mx.events This subclass of Event is dynamic, meaning that you can set arbitrary event properties on its instances at runtime.
EdgeMetrics
mx.core The EdgeMetrics class specifies the thickness, in pixels, of the four edge regions around a visual component.
Effect
mx.effects The Effect class is an abstract base class that defines the basic functionality of all Flex effects.
EffectEvent
mx.events Represents event objects that are specific to Flex effects.
EffectInstance
mx.effects The EffectInstance class represents an instance of an effect playing on a target.
EffectManager
mx.effects The EffectManager class listens for events, such as the show and move events, dispatched by objects in a Flex application.
EffectTargetFilter
mx.effects The EffectTargetFilter class defines a custom filter that is executed by each transition effect on each target of the effect.
Elastic
mx.effects.easing The Elastc class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
EmailValidator
mx.validators The EmailValidator class validates that a String has a single @ sign, a period in the domain name and that the top-level domain suffix has two, three, four, or six characters.
Endian
flash.utils The Endian class contains values that denote the byte order used to represent multibyte numbers.
EOFError
flash.errors An EOFError exception is thrown when you attempt to read past the end of the available data.
Error
Top Level The Error class contains information about an error that occurred in a script.
ErrorEvent
flash.events Flash® Player dispatches ErrorEvent objects when an error causes a network operation to fail.
ErrorMessage
mx.messaging.messages The ErrorMessage class is used to report errors within the messaging system.
EvalError
Top Level The EvalError class represents an error that occurs when user code calls the eval() function or attempts to use the new operator with the Function object.
Event
flash.events The Event class is used as the base class for the creation of Event objects, which are passed as parameters to event listeners when an event occurs.
EventDispatcher
flash.events The EventDispatcher class implements the IEventDispatcher interface and is the base class for the DisplayObject class.
EventPhase
flash.events The EventPhase class provides values for the eventPhase property of the Event class.
EventPriority
mx.core The EventPriority class defines constant values for the priority argument of the addEventListener() method of EventDispatcher.
Exponential
mx.effects.easing The Exponential class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
ExternalInterface
flash.external The ExternalInterface class is the External API, an application programming interface that enables straightforward communication between ActionScript and the Flash Player container; for example, an HTML page with JavaScript, or a desktop application with Flash Player embedded.
Fade
mx.effects The Fade effect animates the alpha property of a component, either from transparent to opaque, or from opaque to transparent.
FadeInstance
mx.effects.effectClasses The FadeInstance class implements the instance class for the Fade effect.
Fault
mx.rpc Object that represents a fault in an remote procedure call (RPC) service invocation.
FaultEvent
mx.rpc.events This event is dispatched when an RPC call has a fault.
FileFilter
flash.net The FileFilter class is used to indicate what files on the user's system are shown in the file-browsing dialog box that is displayed when FileReference.browse() or FileReferenceList.browse() is called.
FileReference
flash.net The FileReference class provides a means to upload and download files between a user's computer and a server.
FileReferenceList
flash.net The FileReferenceList class provides a means to let users select one or more files for uploading.
FlexBitmap
mx.core FlexBitmap is a subclass of the Player's Bitmap class.
FlexEvent
mx.events The FlexEvent class represents the event object passed to the event listener for many Flex events.
FlexMouseEvent
mx.events The FlexMouseEvent class represents the event object passed to the event listener for Flex-specific mouse activity.
FlexMovieClip
mx.core FlexMovieClip is a subclass of the Player's MovieClip class.
FlexPrintJob
mx.printing The FlexPrintJob class is a wrapper over the Flash Player's PrintJob API.
FlexPrintJobScaleType
mx.printing Values for the scaleType property of the FlexPrintJob.addObject() method parameter.
FlexShape
mx.core FlexShape is a subclass of the Player's Shape class.
FlexSimpleButton
mx.core FlexSimpleButton is a subclass of the Player's SimpleButton class.
FlexSprite
mx.core FlexSprite is a subclass of the Player's Sprite class and the superclass of UIComponent.
FlexTextField
mx.core FlexTextField is a subclass of the Player's TextField class and the superclass of UITextField.
FocusEvent
flash.events Flash® Player dispatches FocusEvent objects when the user changes the focus from one object in the display list to another.
FocusManager
mx.managers The FocusManager class manages the focus on components in response to mouse activity or keyboard activity (Tab key).
Font
flash.text The Font class is used to manage embedded fonts in SWF files.
FontStyle
flash.text The FontStyle class provides values for the TextRenderer class.
FontType
flash.text The FontType class contains the enumerated constants "embedded" and "device" for the fontType property of the Font class.
Form
mx.containers The Form container lets you control the layout of a form, mark form fields as required or optional, handle error messages, and bind your form data to the Flex data model to perform data checking and validation.
Formatter
mx.formatters The Formatter class is the base class for all data formatters.
FormHeading
mx.containers The FormHeading container is used to display a heading for a group of controls inside a Form container.
FormItem
mx.containers The FormItem container defines a label and one or more children arranged horizontally or vertically.
FormItemDirection
mx.containers The FormItem container defines the constant values for the direction property of the FormItem class.
FormItemLabel
mx.controls The FormItem container uses a FormItemLabel object to display the label portion of the FormItem container.
FrameLabel
flash.display The FrameLabel object contains properties that specify a frame number and the corresponding label name.
Function
Top Level A function is the basic unit of code that can be invoked in ActionScript.
Glow
mx.effects The Glow effect lets you apply a visual glow effect to a component.
GlowFilter
flash.filters The GlowFilter class lets you apply a glow effect to display objects.
GlowInstance
mx.effects.effectClasses The GlowInstance class implements the instance class for the Glow effect.
GradientBevelFilter
flash.filters The GradientBevelFilter class lets you apply a gradient bevel effect to display objects.
GradientEntry
mx.graphics The GradientEntry class defines the objects that control a transition as part of a gradient fill.
GradientGlowFilter
flash.filters The GradientGlowFilter class lets you apply a gradient glow effect to display objects.
GradientType
flash.display The GradientType class provides values for the type parameter in the beginGradientFill() and lineGradientFill() methods of the flash.display.Graphics class.
Graphics
flash.display The Graphics class contains a set of methods that you can use to create a vector shape.
GraphicsUtil
mx.utils The Graphics class is an all-static class with utility methods related to the Graphics class.
Grid
mx.containers A Grid container lets you arrange children as rows and columns of cells, similar to an HTML table.
GridFitType
flash.text The GridFitType class defines values for grid fitting in the TextField class.
GridItem
mx.containers The GridItem container defines a grid cell in GridRow container.
GridLines
mx.charts The GridLines class draws grid lines inside the data area of the chart.
GridRow
mx.containers The GridRow container defines a row in a Grid container, and contains GridCell containers.
HaloBorder
mx.skins.halo Defines the appearance of the default border for the Halo theme.
HaloColors
mx.skins.halo Defines the colors used by components that support the Halo theme.
HaloFocusRect
mx.skins.halo Defines the skin for the focus indicator.
HBox
mx.containers The HBox container lays out its children in a single horizontal row.
HDividedBox
mx.containers The HDividedBox container lays out its children horizontally in the same way as HBox container, but it inserts a draggable divider in the gap between each child.
HeaderEvent
mx.rpc.events The event that indicates an RPC operation, such as a WebService SOAP request, returned a header in the response.
HistoryManager
mx.managers History management lets users navigate through a Flex application using the web browser's Back and Forward navigation commands.
HitData
mx.charts The HitData class represents information about the data item at a specific location on the screen.
HLOCChart
mx.charts The HLOCChart (High Low Open Close) control represents financial data as a series of elements representing the high, low, closing, and optionally opening values of a data series.
HLOCItemRenderer
mx.charts.renderers The default item Rnderer for an HLOCSeries object.
HLOCSeries
mx.charts.series Represents financial data as a series of elements representing the high, low, closing, and, optionally, opening values of a data series.
HLOCSeriesBase
mx.charts.chartClasses HLOCSeriesBase is the base class for the two financial series types, HLOCSeries and CandlestickSeries.
HLOCSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a HLOCSeries.
HLOCSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the HLOCSeries and CandlestickSeries objects to render.
HorizontalList
mx.controls The HorizontalList control displays a horizontal list of items.
HRule
mx.controls The HRule control creates a single horizontal line.
HScrollBar
mx.controls The HScrollBar (horizontal ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
HSlider
mx.controls The HSlider control lets users select a value by moving a slider thumb between the end points of the slider track.
HTTPChannel
mx.messaging.channels The HTTPChannel class provides the HTTP support for messaging.
HTTPRequestMessage
mx.messaging.messages HTTP requests are sent to the HTTP endpoint using this message type.
HTTPService
mx.rpc.http When you call the HTTPService object's send() method, it makes an HTTP GET or POST request to the specified URL, and an HTTP response is returned.
HTTPService
mx.rpc.http.mxml You use the <mx:HTTPService> tag to represent an HTTPService object in an MXML file.
HTTPStatusEvent
flash.events Flash® Player dispatches HTTPStatusEvent objects when a network request returns an HTTP status code.
IAccessPrivileges
mx.data Objects that must restrict access must implement the IAccessPrivileges interface.
IAxis
mx.charts.chartClasses The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IAxisRenderer
mx.charts.chartClasses The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IBar
mx.charts.chartClasses The IBar interface is implemented by any any series that can be clustered vertically, such as a BarSeries.
IBitmapDrawable
flash.display The IBitmapDrawable interface is implemented by objects that can be passed as the source parameter of the draw() method of the BitmapData class.
IChangeObject
mx.data The IChangeObject interface provides the methods and properties needed when decting local conflicts.
IChartElement
mx.charts.chartClasses IChartElement defines the base set of properties and methods required by a UIComponent to be representable in the data space of a chart.
IChildList
mx.core The IChildList interface defines the properties and methods for accessing and manipulating child lists, which are subsets of a DisplayObjectContainer's children.
ICollectionView
mx.collections An ICollectionView is a view onto a collection of data.
IColumn
mx.charts.chartClasses ChartElements that can be clustered along the vertical axis should implement this interface.
IContainer
mx.core IContainer is a marker interface that indicates a component acts as a container for other components.
ID3Info
flash.media The ID3Info class contains properties that reflect ID3 metadata.
IDataInput
flash.utils The IDataInput interface provides a set of methods for reading binary data.
IDataOutput
flash.utils The IDataOutput interface provides a set of methods for writing binary data.
IDataRenderer
mx.core The IDataRenderer interface defines the interface for components that have a data property.
IDeferredInstance
mx.core The IDeferredInstance interface defines the Flex deferred instance factory interface.
IDeferredInstantiationUIComponent
mx.core The IDeferredInstantiationUIComponent interface defines the interface for a component or object that defers instantiation.
IDropInListItemRenderer
mx.controls.listClasses The interface for "drop-in" item renderers.
IDynamicPropertyOutput
flash.net This interface controls the serialization of dynamic properties of dynamic objects.
IDynamicPropertyWriter
flash.net This interface is used with the IDynamicPropertyOutput interface to control the serialization of dynamic properties of dynamic objects.
IEventDispatcher
flash.events The IEventDispatcher interface defines methods for adding or removing event listeners, checks whether specific types of event listeners are registered, and dispatches events.
IExternalizable
flash.utils The IExternalizable interface provides control over serialization of a class as it is encoded into a data stream.
IFactory
mx.core The IFactory interface defines the interface that factory classes such as ClassFactory must implement.
IFill
mx.graphics Defines the interface that classes that perform a fill must implement.
IFlexAsset
mx.core IFlexAsset is a marker interface with the following meaning: if a class declares that it implements IFlexAsset, then that class represents an asset -- such as a bitmap, a font, or a sound -- that has been embedded in a Flex application.
IFlexDisplayObject
mx.core The IFlexDisplayObject interface defines the interface for skin elements.
IFocusManager
mx.managers The IFocusManager interface defines the interface that components must implement to manage the focus on components in response to mouse activity or keyboard activity (Tab key), and to support a default button.
IFocusManagerComponent
mx.managers The IFocusManagerComponent interface defines the interface that focusable components must implement in order to receive focus from the FocusManager.
IFocusManagerContainer
mx.managers The IFocusManagerContainer interface defines the interface that containers implement to host a FocusManager.
IFocusManagerGroup
mx.managers The IFocusManagerGroup interface defines the interface that any component must implement if it is grouped in sets, where only one member of the set can be selected at any given time.
IHistoryManagerClient
mx.managers Interface that must be implemented by objects registered with the History Manager.
IIMESupport
mx.core The IIMESupport interface defines the interface for any component that supports IME (input method editor).
IInvalidating
mx.core The IInvalidating interface defines the interface for components that use invalidation to do delayed -- rather than immediate -- property commitment, measurement, drawing, and layout.
ILayoutManagerClient
mx.managers The ILayoutManagerClient interface defines the interface that a component must implement to participate in the LayoutManager's commit/measurement/layout sequence.
IList
mx.collections A collection of items organized in an ordinal fashion.
IListItemRenderer
mx.controls.listClasses Item renderers and item editors for list components must implement the IListItemRenderer interface.
IllegalOperationError
flash.errors The IllegalOperationError exception is thrown when a method is not implemented or the implementation doesn't cover the current usage.
ILogger
mx.logging All loggers within the logging framework must implement this interface.
ILoggingTarget
mx.logging All logger target implementations within the logging framework must implement this interface.
Image
mx.controls The Image control lets you import JPEG, PNG, GIF, and SWF files at runtime.
IManaged
mx.data The IPropertyChangeNotifier interface provides the contract for a managed object.
IME
flash.system The IME class lets you directly manipulate the operating system's input method editor (IME) in the Flash Player application that is running on a client computer.
IMEConversionMode
flash.system This class contains constants for use with the IME.conversionMode property.
IMEEvent
flash.events Flash® Player dispatches IMEEvent objects when a user enters text using an input method editor (IME).
IMenuDataDescriptor
mx.controls.menuClasses The IMenuDataDescriptor interface defines the interface that a dataDescriptor for a Menu or MenuBar control must implement.
IMenuItemRenderer
mx.controls.menuClasses The IMenuItemRenderer interface defines the interface that a menu item renderer for a Menu control must implement.
IMessage
mx.messaging.messages This interface defines the contract for message objects.
IMXMLObject
mx.core The IMXMLObject interface defines the APIs that a non-visual component must implement in order to work properly with the MXML compiler.
IMXMLSupport
mx.rpc.mxml Implementing this interface means that an RPC service can be used in an MXML document via tags since it supports the interfaces specified during Flex 1.
IndexChangedEvent
mx.events The IndexChangedEvent class represents events that are dispatched when an index changes.
InstanceCache
mx.charts.chartClasses InstanceCache is a utilty that governs the task of creating and managing a set of n object instances, where n changes frequently.
int
Top Level The int class lets you work with the data type representing a 32-bit signed integer.
InteractiveObject
flash.display The InteractiveObject class is the abstract base class for all display objects with which you can interact: mouse, keyboard, and focus.
InterpolationMethod
flash.display The InterpolationMethod class provides values for the interpolationMethod parameter in the Graphics.beginGradientFill() and Graphics.lineGradientStyle() methods.
InvalidCategoryError
mx.logging.errors This error is thrown when a category specified for a logger contains invalid characters or is malformed.
InvalidChannelError
mx.messaging.errors This error is thrown when a Channel can't be accessed or is not valid for the current destination.
InvalidDestinationError
mx.messaging.errors This error is thrown when a destination can't be accessed or is not valid.
InvalidFilterError
mx.logging.errors This error is thrown when a filter specified for a target contains invalid characters or is malformed.
InvalidSWFError
flash.errors
InvokeEvent
mx.rpc.events The event that indicates an RPC operation has been invoked.
IOError
flash.errors The IOError exception is thrown when some type of input or output failure occurs.
IOErrorEvent
flash.events Flash® Player dispatches an IOErrorEvent object when an error causes a send or load operation to fail.
IOverride
mx.states The IOverride interface is used for view state overrides.
IPreloaderDisplay
mx.preloaders The IPreloaderDisplay interface defines the inteface that a class must implement to be used as a download progress bar.
IPropertyChangeNotifier
mx.core The IPropertyChangeNotifier interface defines a marker interface.
IRawChildrenContainer
mx.core The IRawChildrenContainer interface defines the APIs for containers that can return an IChildList that represents all their children.
IRepeater
mx.core The IRepeater interface defines the APIs for Repeater public APIs of the Repeater object.
IRepeaterClient
mx.core The IRepeaterClient interface defines the APIs for components that can have multiple instances created by a Repeater.
IResponder
mx.rpc This interface provides the contract for any service that needs to respond to remote or asynchronous calls.
Iris
mx.effects The Iris effect animates the effect target by expanding or contracting a rectangular mask centered on the target.
IrisInstance
mx.effects.effectClasses The IrisInstance class implements the instance class for the Iris effect.
ISimpleStyleClient
mx.styles This interface describes the properties and methods that an object must implement so that it can participate in the style subsystem.
IStackable
mx.charts.chartClasses The IStackable interface is implemented by any series that can be stacked.
IStroke
mx.graphics Defines the interface that classes that define a line must implement.
IStyleClient
mx.styles This interface describes the properties and methods that an object must implement so that it can fully participate in the style subsystem.
ISystemManager
mx.managers An ISystemManager manages an "application window".
ItemClickEvent
mx.events Represents events that are dispatched when a navigation item on a navigator bar, such as a ButtonBar, LinkBar, or TabBar control, has been clicked.
ItemPendingError
mx.collections.errors This error is thrown when retrieving an item from a collection view requires an asynchronous call.
ItemReference
mx.data An ItemReference instance is returned from the DataService.getItem() and DataService.createItem() methods to provide you with a way to manage your reference to the remote object.
ItemResponder
mx.collections The ItemResponder class provides a default implementation of the mx.rpc.IResponder interface.
IToolTip
mx.core The IToolTip interface defines the API that tooltip-like components must implement in order to work with the ToolTipManager.
IToolTipManagerClient
mx.managers Components that implement IToolTipManagerClient can have tooltips and must have a toolTip getter/setter.
ITreeDataDescriptor
mx.controls.treeClasses Interface providing methods for parsing and adding nodes to a collection of data that is displayed by a Tree control.
IUIComponent
mx.core The IUIComponent interface defines the basic set of APIs that you must implement to create a child of a Flex container or list.
IUID
mx.core The IUID interface defines the interface for objects that must have Unique Identifiers (UIDs) to uniquely identify the object.
IValidatorListener
mx.validators The interface that components implement to support the Flex data validation mechanism.
IViewCursor
mx.collections Defines the interface for enumerating a collection view bi-directionally.
JointStyle
flash.display The JointStyle class is an enumeration of constant values that specify the joint style to use in drawing lines.
Keyboard
flash.ui The Keyboard class is used to build an interface that can be controlled by a user with a standard keyboard.
KeyboardEvent
flash.events Flash® Player dispatches KeyboardEvent objects in response to user input through a keyboard.
KeyLocation
flash.ui The KeyLocation class contains constants that indicate the location of a key pressed on the keyboard.
Label
mx.controls The Label control displays a single line of noneditable text.
LayoutManager
mx.managers The LayoutManager is the engine behind Flex's measurement and layout strategy.
Legend
mx.charts The Legend control adds a legend to your charts, where the legend displays the label for each data series in the chart and a key showing the chart element for the series.
LegendData
mx.charts.chartClasses The LegendData structure is used by charts to describe the items that should be displayed in an auto-generated legend.
LegendItem
mx.charts Controls the individual legend elements in a chart legend.
LegendMouseEvent
mx.charts.events The LegendMouseEvent class represents event objects that are specific to the chart legend components.
Linear
mx.effects.easing The Linear class defines easing functions to implement linear motion with Flex effect classes.
LinearAxis
mx.charts The LinearAxis class maps numeric values evenly between a minimum and maximum value along a chart axis.
LinearGradient
mx.graphics The LinearGradient class lets you specify the fill of a graphical element, where a gradient specifies a gradual color transition in the fill color.
LinearGradientStroke
mx.graphics The LinearGradientStroke class lets you specify a gradient filled stroke.
LineChart
mx.charts The LineChart control represents a data series as points connected by a continuous line.
LineFormattedTarget
mx.logging.targets All logger target implementations that have a formatted line style output should extend this class.
LineRenderer
mx.charts.renderers A simple implementation of a line segment renderer that is used by LineSeries objects.
LineScaleMode
flash.display The LineScaleMode class provides values for the scaleMode parameter in the Graphics.lineStyle() method.
LineSeries
mx.charts.series Defines a data series for a LineChart control.
LineSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a LineSeries.
LineSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the LineSeries to render.
LineSeriesSegment
mx.charts.series.items Represents the information required to render a segment in a LineSeries.
LinkBar
mx.controls A LinkBar control defines a horizontal or vertical row of LinkButton controls that designate a series of link destinations.
LinkButton
mx.controls The LinkButton control is a borderless Button control whose contents are highlighted when a user moves the mouse over it.
LinkButtonSkin
mx.skins.halo The skin for all the states of a LinkButton.
LinkSeparator
mx.skins.halo The skin for the separator between the Links in a LinkBar.
List
mx.controls The List control displays a vertical list of items.
ListBase
mx.controls.listClasses The ListBase class is the base class for controls that represent lists of items that can have one or more selected and can scroll through the items.
ListBaseSeekPending
mx.controls.listClasses An object that stores data about a seek operation that was interrupted by an ItemPendingError error.
ListBaseSelectionData
mx.controls.listClasses Records used by list classes to keep track of what is selected.
ListCollectionView
mx.collections The ListCollectionView class adds the properties and methods of the ICollectionView interface to an object that conforms to the IList interface.
ListData
mx.controls.listClasses The ListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the List control.
ListDropIndicator
mx.skins.halo The skin for the drop indicator of a list-based control.
ListEvent
mx.events The ListEvent class represents events associated with items in list-based controls such as List, Tree, Menu, and DataGrid.
ListEventReason
mx.events Constants for the values of the reason property of a ListEvent object where the value of the type property is ListEvent.ITEM_EDIT_END.
ListItemDragProxy
mx.controls.listClasses The default drag proxy used when dragging from a list-based control (except for the DataGrid class).
ListItemRenderer
mx.controls.listClasses The ListItemRenderer class defines the default item renderer for a List control.
ListRowInfo
mx.controls.listClasses Used by the list-based classes to store information about their IListItemRenderers.
Loader
flash.display The Loader class is used to load SWF files or image (JPG, PNG, or GIF) files.
LoaderConfig
mx.messaging.config This class acts as a context for the messaging framework so that it has access the URL and arguments of the SWF without needing access to the root MovieClip's LoaderInfo or Flex's Application class.
LoaderContext
flash.system The LoaderContext class provides options for loading SWF files and other media by using the Loader class.
LoaderInfo
flash.display The LoaderInfo class provides information about a loaded SWF file or a loaded image file (JPEG, GIF, or PNG).
LoadEvent
mx.rpc.soap This event is dispatched when the WSDL document has loaded sucessfully.
LocalConnection
flash.net The LocalConnection class lets you create a LocalConnection object that can invoke a method in another LocalConnection object, either within a single SWF file or between multiple SWF files.
Locale
mx.resources You can use this class to query the current Locale.
Log
mx.logging Provides psuedo-hierarchical logging capabilities with multiple format and output options.
LogAxis
mx.charts The LogAxis class maps numeric values logarithmically between a minimum and maximum value along a chart axis.
LogEvent
mx.logging Represents the log information for a single logging event.
LogEventLevel
mx.logging Static class containing constants for use in the level property.
LogLogger
mx.logging The logger that is used within the logging framework.
Managed
mx.data.utils Provides utility methods for DataService managed objects.
MaskEffect
mx.effects The MaskEffect class is an abstract base class for all effects that animate a mask, such as the wipe effects and the Iris effect.
MaskEffectInstance
mx.effects.effectClasses The MaskEffectInstance class is an abstract base class that implements the instance class for the MaskEffect class.
Math
Top Level The Math class contains methods and constants that represent common mathematical functions and values.
Matrix
flash.geom The Matrix class represents a transformation matrix that determines how to map points from one coordinate space to another.
MBeanAttributeInfo
mx.messaging.management Client representation of metadata for a MBean attribute.
MBeanFeatureInfo
mx.messaging.management Client representation of metadata for a MBean feature.
MBeanInfo
mx.messaging.management Client representation of metadata for a MBean.
MBeanOperationInfo
mx.messaging.management Client representation of metadata for a MBean operation.
MBeanParameterInfo
mx.messaging.management Client representation of metadata for a MBean operation parameter.
MemoryError
flash.errors The MemoryError exception is thrown when a memory allocation request fails.
Menu
mx.controls The Menu control creates a pop-up menu of individually selectable choices, similar to the File or Edit menu found in most software applications.
MenuBar
mx.controls A MenuBar control defines a horizontal menu bar that contains one or more child menus.
MenuBarBackgroundSkin
mx.skins.halo The skin for the background of a MenuBar.
MenuBarItem
mx.controls.menuClasses The MenuBarItem class defines an item displayed in a MenuBar control.
MenuEvent
mx.events The MenuEvent class represents events that are associated with menu activities in controls such as Menu, MenuBar, and PopUpMenuButton.
MenuItemRenderer
mx.controls.menuClasses The MenuItemRenderer class defines the default item renderer for menu items in any menu control.
MessageAckEvent
mx.messaging.events The MessageAckEvent class is used to propagate acknowledge messages within the messaging system.
MessageAgent
mx.messaging The MessageAgent class provides the basic low-level functionality common to message handling for a destination.

Note: For advanced use only.

MessageEvent
mx.messaging.events The MessageEvent class is used to propagate messages within the messaging system.
MessageFaultEvent
mx.messaging.events The MessageFaultEvent class is used to propagate fault messages within the messaging system.
MessageResponder
mx.messaging The MessageResponder class handles a successful result or fault from a message destination.
MessageSerializationError
mx.messaging.errors This error indicates a problem serializing a message within a channel.
MessagingError
mx.messaging.errors This is the base class for any messaging related error.
Microphone
flash.media The Microphone class lets you capture audio from a microphone attached to the computer that is running Flash Player.
MiniDebugTarget
mx.logging.targets Provides a logger target that outputs to a LocalConnection, connected to the MiniDebug application.
MorphShape
flash.display The MorphShape class represents MorphShape objects on the display list.
Mouse
flash.ui The methods of the Mouse class are used to hide and show the mouse pointer.
MouseEvent
flash.events Flash® Player dispatches MouseEvent objects into the event flow whenever mouse events occur.
Move
mx.effects The Move effect changes the position of a component over a specified time interval.
MoveEvent
mx.events Represents event objects that are dispatched when a Flex component moves.
MoveInstance
mx.effects.effectClasses The MoveInstance class implements the instance class for the Move effect.
MovieClip
flash.display The MovieClip class inherits from the following classes: Sprite, DisplayObjectContainer, InteractiveObject, DisplayObject, and EventDispatcher.
MovieClipAsset
mx.core MovieClipAsset is a subclass of the Flash Player's MovieClip class which represents movieclip symbols that you embed in a Flex application from a SWF file produced by Flash.
MovieClipLoaderAsset
mx.core MovieClipLoaderAsset is a subclass of the MovieClipAsset class which represents SWF files that you embed in a Flex application.
Namespace
Top Level The Namespace class contains methods and properties for defining and working with namespaces.
NameUtil
mx.utils The NameUtil utility class defines static methods for creating names for Flex objects.
NavBar
mx.controls The NavBar control is the superclass for navigator controls, such as the LinkBar and TabBar controls, and cannot be instantiated directly.
NetConnection
flash.net The NetConnection class lets you invoke commands on a remote application server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, and to play streaming Flash Video (FLV) files from either an HTTP address or a local drive.
NetConnectionChannel
mx.messaging.channels This NetConnectionChannel provides the basic NetConnection support for messaging.
NetStatusEvent
flash.events Flash® Player dispatches NetStatusEvent objects when a NetConnection, NetStream, or SharedObject object reports its status.
NetStream
flash.net The NetStream class opens a one-way streaming connection between Flash Player and a server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, or between Flash Player and the local file system through a connection made available by a NetConnection object.
NoChannelAvailableError
mx.messaging.errors This error is thrown when no Channel is available to send messages.
NoDataAvailableError
mx.data.errors This error is thrown when data requested is not local.
Number
Top Level A data type representing an IEEE-754 double-precision floating-point number.
NumberBase
mx.formatters The NumberBase class is a utility class that contains general number formatting capabilities, including rounding, precision, thousands formatting, and negative sign formatting.
NumberBaseRoundType
mx.formatters The NumberBaseRoundType class defines the constant values for formatter properties that specify a type of rounding.
NumberFormatter
mx.formatters The NumberFormatter class formats a valid number by adjusting the decimal rounding and precision, the thousands separator, and the negative sign.
NumberValidator
mx.validators The NumberValidator class ensures that a String represents a valid number.
NumericAxis
mx.charts.chartClasses The NumericAxis class acts as a common base class for axis types representing a continuous range of values between a defined minimum and maximum.
NumericStepper
mx.controls The NumericStepper control lets the user select a number from an ordered set.
NumericStepperDownSkin
mx.skins.halo The skin for all the states of the down button in a NumericStepper.
NumericStepperEvent
mx.events Represents events that are specific to the NumericStepper control.
NumericStepperUpSkin
mx.skins.halo The skin for all the states of the up button in a NumericStepper.
Object
Top Level The Object class is at the root of the ActionScript class hierarchy.
ObjectEncoding
flash.net The ObjectEncoding class allows classes that serialize objects (such as NetStream, NetConnection, SharedObject, and ByteArray) to work with prior versions of ActionScript.
ObjectInstance
mx.messaging.management Client representation of an object name instance for server-side management controls.
ObjectName
mx.messaging.management Client representation of the name for server-side management controls.
ObjectProxy
mx.utils This class provides the ability to track changes to an item managed by this proxy.
ObjectUtil
mx.utils The ObjectUtil class is an all-static class with methods for working with Objects within Flex.
Operation
mx.rpc.remoting An Operation used specifically by RemoteObjects.
Operation
mx.rpc.soap.mxml An Operation used specifically by WebServices.
Operation
mx.rpc.soap An Operation used specifically by WebServices.
Operation
mx.rpc.remoting.mxml The Operation used for RemoteObject when created in an MXML document
PagedMessage
mx.data.messages This messsage provides information about a partial sequence result.
PageInformation
mx.data The PageInformation object provides detailed data about what pages of a collection have been loaded, how many there are, and what the current page size is.
Panel
mx.containers A Panel container consists of a title bar, a caption, a border, and a content area for its children.
Parallel
mx.effects The Parallel effect plays multiple child effects at the same time.
ParallelInstance
mx.effects.effectClasses The ParallelInstance class implements the instance class for the Parallel effect.
Pause
mx.effects The Pause effect is useful when sequencing effects.
PauseInstance
mx.effects.effectClasses The PauseInstance class implements the instance class for the Pause effect.
PhoneFormatter
mx.formatters The PhoneFormatter class formats a valid number into a phone number format, including international configurations.
PhoneNumberValidator
mx.validators The PhoneNumberValidator class validates that a string is a valid phone number.
PieChart
mx.charts The PieChart control represents a data series as a standard pie chart.
PieSeries
mx.charts.series The PieSeries class defines the data series for a PieChart control.
PieSeriesItem
mx.charts.series.items Represents the information required to render a single wedge as part of a PieSeries.
PieSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the PieSeries to render.
PixelSnapping
flash.display The PixelSnapping class is an enumeration of constant values for setting the pixel snapping options by using the pixelSnapping property of a Bitmap object.
PlotChart
mx.charts The PlotChart control represents data with two values for each data point.
PlotSeries
mx.charts.series Defines a data series for a PlotChart control.
PlotSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a PlotSeries.
PlotSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the PlotSeries to render.
Point
flash.geom The Point object represents a location in a two-dimensional coordinate system, where x represents the horizontal axis and y represents the vertical axis.
PolarChart
mx.charts.chartClasses The PolarChart control serves as base class for circular charts based in polar coordinates.
PolarTransform
mx.charts.chartClasses The PolarTransform object represents a set of axes used to map data values to angle/distance polar coordinates and vice versa.
PollingChannel
mx.messaging.channels The PollingChannel class provides the polling behavior that all polling channels in the messaging system require.
PopUpButton
mx.controls The PopUpButton control adds a flexible pop-up control interface to a Button control.
PopUpButtonSkin
mx.skins.halo The skin for all the states of a PopUpButton.
PopUpIcon
mx.skins.halo The skin for all the states of the icon in a PopUpButton.
PopUpManager
mx.managers The PopUpManager singleton class creates new top-level windows and places or removes those windows from the layer on top of all other visible windows.
PopUpManagerChildList
mx.managers The PopUpManagerChildList class defines the constant values for the detail property of the PopUpManager addPopUp() and createPopUp() methods.
PopUpMenuButton
mx.controls The PopUpMenuButton control creates a PopUpButton control with a main sub-button and a secondary sub-button.
PopUpMenuIcon
mx.skins.halo The skin for all the states of the icon in a PopUpMenuButton.
Preloader
mx.preloaders The Preloader class is used by the SystemManager to monitor the download and initialization status of a Flex application.
PrintDataGrid
mx.printing The PrintDataGrid control is a DataGrid subclass that is styled to show a table with line borders and is optimized for printing.
PrintJob
flash.printing The PrintJob class lets you create content and print it to one or more pages.
PrintJobOptions
flash.printing The PrintJobOptions class contains properties to use with the options parameter of the PrintJob.addPage() method.
PrintJobOrientation
flash.printing This class provides values that are used by the PrintJob.orientation property for the image position of a printed page.
Producer
mx.messaging A Producer sends messages to a destination.
ProgrammaticSkin
mx.skins This class is the base class for skin elements which draw themselves programmatically.
ProgressBar
mx.controls The ProgressBar control provides a visual representation of the progress of a task over time.
ProgressBarDirection
mx.controls The ProgressBarDirection class defines the values for the direction property of the ProgressBar class.
ProgressBarLabelPlacement
mx.controls The ProgressBarLabelPlacement class defines the values for the labelPlacement property of the ProgressBar class.
ProgressBarMode
mx.controls The ProgressBarMode class defines the values for the mode property of the ProgressBar class.
ProgressBarSkin
mx.skins.halo The skin for a ProgressBar.
ProgressEvent
flash.events Flash® Player dispatches ProgressEvent objects when a load operation has begun or a socket has received data.
ProgressIndeterminateSkin
mx.skins.halo The skin for the indeterminate state of a ProgressBar.
ProgressTrackSkin
mx.skins.halo The skin for the track in a ProgressBar.
PropertyChangeEvent
mx.events The PropertyChangeEvent class represents the event object passed to the event listener when one of the properties of an object has changed, and provides information about the change.
PropertyChangeEventKind
mx.events The PropertyChangeEventKind class defines the constant values for the kind property of the PropertyChangeEvent class.
PropertyChanges
mx.effects.effectClasses The PropertyChanges class defines the start and end values for a set of properties of a target component of a transition.
Proxy
flash.utils The Proxy class lets you override the default behavior of ActionScript operations (such as retrieving and modifying properties) on an object.
QName
Top Level QName objects represent qualified names of XML elements and attributes.
Quadratic
mx.effects.easing The Quadratic class defines three easing functions to implement quadratic motion with Flex effect classes.
Quartic
mx.effects.easing The Quartic class defines three easing functions to implement motion with Flex effect classes.
Quintic
mx.effects.easing The Quintic class defines three easing functions to implement motion with Flex effect classes.
RadialGradient
mx.graphics The RadialGradient class lets you specify a gradual color transition in the fill color.
RadioButton
mx.controls The RadioButton control lets the user make a single choice within a set of mutually exclusive choices.
RadioButtonGroup
mx.controls The RadioButtonGroup control defines a group of RadioButton controls that act as a single mutually exclusive control; therefore, a user can select only one RadioButton control at a time.
RadioButtonIcon
mx.skins.halo The skin for all the states of the icon in a RadioButton.
RangeError
Top Level A RangeError exception is thrown when a numeric value is outside the acceptable range.
Rectangle
flash.geom A Rectangle object is an area defined by its position, as indicated by its top-left corner point (x, y) and by its width and its height.
RectangularBorder
mx.skins The RectangularBorder class is an abstract base class for various classes that draw rectangular borders around UIComponents.
RectangularDropShadow
mx.graphics Drop shadows are typically created using the DropShadowFilter class.
ReferenceError
Top Level A ReferenceError exception is thrown when a reference to an undefined property is attempted on a sealed (nondynamic) object.
RegExp
Top Level The RegExp class lets you work with regular expressions, which are patterns that you can use to perform searches in strings and to replace text in strings.
RegExpValidationResult
mx.validators The RegExpValidator class dispatches the valid and invalid events.
RegExpValidator
mx.validators The RegExpValidator class lets you use a regular expression to validate a field.
RemoteObject
mx.rpc.remoting The RemoteObject class gives you access to classes on a remote application server.
RemoteObject
mx.rpc.remoting.mxml The <mx:RemoteObject> tag gives you access to the methods of Java objects using Action Message Format (AMF) encoding.
RemotingMessage
mx.messaging.messages RemotingMessages are used to send RPC requests to a remote endpoint.
RemoveChild
mx.states The RemoveChild class removes a child display object, such as a component, from a container as part of a view state.
RemoveChildAction
mx.effects The RemoveChildAction class defines an action effect that corresponds to the RemoveChild property of a view state definition.
RemoveChildActionInstance
mx.effects.effectClasses The RemoveChildActionInstance class implements the instance class for the RemoveChildAction effect.
RenderData
mx.charts.chartClasses RenderData structures are used by chart elements to store all of the relevant values and data needed to fully render the chart.
Repeater
mx.core The Repeater class is the runtime object that corresponds to the <mx:Repeater> tag.
Resize
mx.effects The Resize effect changes the width, height, or both dimensions of a component over a specified time interval.
ResizeEvent
mx.events Represents event objects that are dispatched when the size of a Flex component changes.
ResizeInstance
mx.effects.effectClasses The ResizeInstance class implements the instance class for the Resize effect.
ResourceBundle
mx.resources This class can be used to internationalize the framework and applications.
Responder
flash.net The Responder class provides an object that is used in NetConnection.call() to handle return values from the server.
ResultEvent
mx.rpc.events The event that indicates an RPC operation has successfully returned a result.
RichTextEditor
mx.controls The RichTextEditor control lets users enter and format text.
Rotate
mx.effects The Rotate effect rotates a component around a specified point.
RotateInstance
mx.effects.effectClasses The RotateInstance class implements the instance class for the Rotate effect.
RoundedRectangle
mx.graphics RoundedRectangle represents a Rectangle with curved corners
RSLEvent
mx.events The RSLEvent class represents an event object used by the DownloadProgressBar class when an RSL is being downloaded by the Preloader class.
RTMPChannel
mx.messaging.channels The RTMPChannel class provides basic RTMP support for messaging.
Scene
flash.display The Scene class includes properties for identifying the name, labels, and number of frames in a scene.
ScriptTimeoutError
flash.errors The ScriptTimeoutError exception is thrown when the script timeout interval is reached.
ScrollArrowSkin
mx.skins.halo The skin for all the states of the up or down button in a ScrollBar.
ScrollBar
mx.controls.scrollClasses The ScrollBar class is the base class for the HScrollBar and VScrollBar controls.
ScrollBarDirection
mx.controls.scrollClasses The ScrollBarDirection class defines the values for the direction property of the ScrollBar control.
ScrollControlBase
mx.core The ScrollControlBase class is the base class for controls with scroll bars.
ScrollEvent
mx.events Represents events that are dispatched by the ScrollBar class.
ScrollEventDetail
mx.events Constants for the values of the detail property of a ScrollEvent.
ScrollEventDirection
mx.events Constants for the values of the direction property of a ScrollEvent.
ScrollPolicy
mx.core Values for the horizontalScrollPolicy and verticalScrollPolicy properties of the Container and ScrollControlBase classes.
ScrollThumb
mx.controls.scrollClasses The ScrollThumb class defines the thumb of a ScrollBar control.
ScrollThumbSkin
mx.skins.halo The skin for all the states of the thumb in a ScrollBar.
ScrollTrackSkin
mx.skins.halo The skin for the track in a ScrollBar.
SecureAMFChannel
mx.messaging.channels The SecureAMFChannel class is identical to the AMFChannel class except that it uses a secure protocol, HTTPS, to send messages to an AMF endpoint.
SecureHTTPChannel
mx.messaging.channels The SecureHTTPChannel class is identical to the HTTPChannel class except that it uses a secure protocol, HTTPS, to send messages to an HTTP endpoint.
SecureRTMPChannel
mx.messaging.channels The SecureRTMPChannel class is identical to the RTMPChannel class except that it uses a secure protocol, RTMPS, to send messages to an RTMPS endpoint.
Security
flash.system The Security class lets you specify how SWF files in different domains can communicate with each other.
SecurityDomain
flash.system The SecurityDomain class represents the current security "sandbox," also known as a security domain.
SecurityError
Top Level The SecurityError exception is thrown when some type of security violation takes place.
SecurityErrorEvent
flash.events Flash® Player dispatches SecurityErrorEvent objects to report the occurrence of a security error.
SecurityPanel
flash.system The SecurityPanel class provides values for specifying which Security Settings panel you want to display.
Sequence
mx.effects The Sequence effect plays multiple child effects one after the other, in the order in which they are added.
SequencedMessage
mx.data.messages Clients receive this message in response to DataService.fill() request.
SequenceInstance
mx.effects.effectClasses The SequenceInstance class implements the instance class for the Sequence effect.
Series
mx.charts.chartClasses The Series class is the base class for the classes that let you specify a data series for a chart control.
SeriesEffect
mx.charts.effects The base class for chart effects.
SeriesEffectInstance
mx.charts.effects.effectClasses The SeriesEffectInstance class implements the base instance class for the chart series effects.
SeriesInterpolate
mx.charts.effects The SeriesInterpolate effect moves the graphics that represent the existing data in a series to the new points.
SeriesInterpolateInstance
mx.charts.effects.effectClasses The SeriesInterpolateInstance class implements the instance class for the SeriesInterpolate effect.
SeriesSlide
mx.charts.effects The SeriesSlide effect slides a data series into and out of the chart's boundaries.
SeriesSlideInstance
mx.charts.effects.effectClasses The SeriesSlideInstance class implements the instance class for the SeriesSlide effect.
SeriesZoom
mx.charts.effects The SeriesZoom effect implodes and explodes chart data into and out of the focal point that you specify.
SeriesZoomInstance
mx.charts.effects.effectClasses The SeriesZoomInstance class implements the instance class for the SeriesZoom effect.
ServerConfig
mx.messaging.config This class provides access to the server messaging configuration information.
SetEventHandler
mx.states The SetEventHandler class specifies an event handler that is active only during a particular view state.
SetProperty
mx.states The SetProperty class specifies a property value that is in effect only during the parent view state.
SetPropertyAction
mx.effects The SetPropertyAction class defines an action effect that corresponds to the SetProperty property of a view state definition.
SetPropertyActionInstance
mx.effects.effectClasses The SetPropertyActionInstance class implements the instance class for the SetPropertyAction effect.
SetStyle
mx.states The SetStyle class specifies a style that is in effect only during the parent view state.
SetStyleAction
mx.effects The SetStyleAction class defines an action effect that corresponds to the SetStyle property of a view state definition.
SetStyleActionInstance
mx.effects.effectClasses The SetStyleActionInstance class implements the instance class for the SetStyleAction effect.
ShadowBoxItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a rectangular area and surrounds it with a drop shadow.
ShadowLineRenderer
mx.charts.renderers An implementation of a line segment renderer that is used by LineSeries objects.
Shape
flash.display The Shape class is used to create lightweight shapes by using the ActionScript drawing application program interface (API).
SharedObject
flash.net The SharedObject class is used to read and store limited amounts of data on a user's computer or on a server.
SharedObjectFlushStatus
flash.net The SharedObjectFlushStatus class provides values for the code returned from a call to the SharedObject.flush() method.
SimpleButton
flash.display The SimpleButton class lets you control all instances of button symbols in a SWF file.
SimpleXMLDecoder
mx.rpc.xml The SimpleXMLDecoder class deserialize XML into a graph of ActionScript objects.
SimpleXMLEncoder
mx.rpc.xml The SimpleXMLEncoder class take ActionScript Objects and encodes them to XML.
Sine
mx.effects.easing The Sine class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by a sine wave.
Slider
mx.controls.sliderClasses The Slider class is the base class for the Flex slider controls.
SliderDataTip
mx.controls.sliderClasses The SliderDataTip class defines the tooltip used in the mx.controls.Slider control.
SliderDirection
mx.controls.sliderClasses The SliderDirection class defines the constant values for the direction property of the Slider class.
SliderEvent
mx.events The SliderEvent class represents the event object passed to the event listener for the change, thumbDrag, thumbPress, and thumbRelease events of the HSlider and VSlider classes.
SliderEventClickTarget
mx.events The SliderEventClickTarget class defines the constants for the values of the clickTarget property of the SliderEvent class.
SliderHighlightSkin
mx.skins.halo The skin for the highlighted state of the track of a Slider.
SliderLabel
mx.controls.sliderClasses The SliderLabel class defines the label used in the mx.controls.Slider component.
SliderThumb
mx.controls.sliderClasses The SliderThumb class represents a thumb of a Slider control.
SliderThumbSkin
mx.skins.halo The skin for all the states of a thumb in a Slider.
SliderTrackSkin
mx.skins.halo The skin for the track in a Slider.
SOAPHeader
mx.rpc.soap You use a SOAPHeader to specify the headers that need to be added to a SOAP envelope of a WebService Operation request.
SOAPMessage
mx.messaging.messages SOAPMessages are similar to HTTPRequestMessages.
SocialSecurityValidator
mx.validators The SocialSecurityValidator class validates that a String is a valid United States Social Security number.
Socket
flash.net The Socket class enables ActionScript code to make socket connections and to read and write raw binary data.
SolidColor
mx.graphics Defines a representation for a color, including a color and an alpha value.
Sort
mx.collections Provides the sorting information required to establish a sort on an existing view (ICollectionView interface or class that implements the interface).
SortError
mx.collections.errors This error is thrown when a Sort class is not configured properly; for example, if the find criteria are invalid.
SortField
mx.collections Provides the sorting information required to establish a sort on a field or property in an existing view.
Sound
flash.media The Sound class lets you work with sound in an application.
SoundAsset
mx.core SoundAsset is a subclass of the Flash Player's Sound class which represents sounds that you embed in a Flex application.
SoundChannel
flash.media The SoundChannel class controls a sound in an application.
SoundEffect
mx.effects The SoundEffect class plays an MP3 audio file.
SoundEffectInstance
mx.effects.effectClasses The SoundEffectInstance class implements the instance class for the SoundEffect effect.
SoundLoaderContext
flash.media The SoundLoaderContext class provides security checks for SWF files that load sound.
SoundMixer
flash.media The SoundMixer class contains static properties and methods for global sound control in the SWF file.
SoundTransform
flash.media The SoundTransform class contains properties for volume and panning.
Spacer
mx.controls The Spacer control helps you lay out children within a parent container.
SpreadMethod
flash.display The SpreadMethod class provides values for the spreadMethod parameter in the beginGradientFill() and lineGradientStyle() methods of the Graphics class.
Sprite
flash.display The Sprite class is a basic display list building block: a display list node that can display graphics and can also contain children.
SpriteAsset
mx.core SpriteAsset is a subclass of the Flash Player's Sprite class which represents vector graphic images that you embed in a Flex application.
StackedSeries
mx.charts.chartClasses Stacked Series serves as the common base class for all of the stacking set series (BarSet, ColumnSet, and AreaSet).
StackOverflowError
flash.errors ActionScript throws a StackOverflowError exception when the stack available to the script is exhausted.
Stage
flash.display The Stage class represents the main drawing area.
StageAlign
flash.display The StageAlign class provides constant values to use for the Stage.align property.
StageQuality
flash.display The StageQuality class provides values for the Stage.quality property.
StageScaleMode
flash.display The StageScaleMode class provides values for the Stage.scaleMode property.
State
mx.states The State class defines a view state, a particular view of a component.
StateChangeEvent
mx.events The StateChangeEvent class represents an event that is dispatched when the currentState property of a component changes.
StaticText
flash.text This class represents StaticText objects on the display list.
StatusEvent
flash.events Flash® Player dispatches StatusEvent objects when a device, such as a camera or microphone, or an object such as a LocalConnection object reports its status.
String
Top Level The String class is a data type that represents a string of characters.
StringUtil
mx.utils The StringUtil utility class is an all-static class with methods for working with String objects within Flex.
StringValidator
mx.validators The StringValidator class validates that the length of a String is within a specified range.
Stroke
mx.graphics The Stroke class defines the properties for a line.
StyleManager
mx.styles The StyleManager class manages the following:
  • Which CSS style properties the class inherits
  • Which style properties are colors, and therefore get special handling
  • A list of strings that are aliases for color values
StyleSheet
flash.text The StyleSheet class lets you create a StyleSheet object that contains text formatting rules for font size, color, and other styles.
SwatchPanelSkin
mx.skins.halo The skin for the border of a SwatchPanel.
SwatchSkin
mx.skins.halo The skin used for all color swatches in a ColorPicker.
SWFLoader
mx.controls The SWFLoader control loads and displays a specified SWF file.
SWFVersion
flash.display The SWFVersion class is an enumeration of constant values that indicate the file format version of a loaded SWF file.
SwitchSymbolFormatter
mx.formatters The SwitchSymbolFormatter class is a utility class that you can use when creating custom formatters.
SyncEvent
flash.events Flash® Player dispatches SyncEvent objects when a remote SharedObject instance has been updated by the server.
SyntaxError
Top Level A SyntaxError exception is thrown when a parsing error occurs.
System
flash.system The System class contains properties related to certain operations that take place on the user's computer, such as operations with shared objects, local settings for cameras and microphones, and use of the Clipboard.
SystemManager
mx.managers The SystemManager class manages an application window.
TabBar
mx.controls The TabBar control lets you create a horizontal or vertical group of tab navigation items by defining the labels and data associated with each tab.
TabNavigator
mx.containers The TabNavigator container extends the ViewStack container by including a TabBar container for navigating between its child containers.
TabSkin
mx.skins.halo The skin for all the states of a Tab in a TabNavigator or TabBar.
Text
mx.controls The Text control displays multiline, noneditable text.
TextArea
mx.controls The TextArea control is a multiline text field with a border and optional scroll bars.
TextColorType
flash.text The TextColorType class provides color values for the flash.text.TextRenderer class.
TextDisplayMode
flash.text The TextDisplayMode class contains values that control the subpixel anti-aliasing of the FlashType system.
TextEvent
flash.events Flash® Player dispatches TextEvent objects when a user enters text in a text field or clicks a hyperlink in an HTML-enabled text field.
TextField
flash.text The TextField class is used to create display objects for text display and input.
TextFieldAsset
mx.core TextFieldAsset is a subclass of the Flash Player's TextField class which represents TextField symbols that you embed in a Flex application from a SWF file produced by Flash.
TextFieldAutoSize
flash.text The TextFieldAutoSize class is an enumeration of constant values used in setting the autoSize property of the TextField class.
TextFieldType
flash.text The TextFieldType class is an enumeration of constant values used in setting the type property of the TextField class.
TextFormat
flash.text The TextFormat class represents character formatting information.
TextFormatAlign
flash.text The TextFormatAlign class provides values for text alignment in the TextFormat class.
TextInput
mx.controls The TextInput control is a single-line text field that is optionally editable.
TextLineMetrics
flash.text The TextLineMetrics class contains information about the text position and measurements of a line of text within a text field.
TextRange
mx.controls.textClasses The TextRange class provides properties that select and format a range of text in the Label, Text, TextArea, TextEditor, and RichTextEditor controls.
TextRenderer
flash.text The TextRenderer class provides functionality for the advanced anti-aliasing capability of embedded fonts.
TextSnapshot
flash.text TextSnapshot objects let you work with static text in a movie clip.
Tile
mx.containers A Tile container lays out its children in a grid of equal-sized cells.
TileBase
mx.controls.listClasses The TileBase class is the base class for controls that display data items in a sequence of rows and columns.
TileBaseDirection
mx.controls.listClasses Values for the direction property of the TileList component.
TileDirection
mx.containers The TileDirection class defines the constant values for the direction property of the Tile container.
TileList
mx.controls The TileList control displays a number of items laid out in tiles.
TileListItemRenderer
mx.controls.listClasses The TileListItemRenderer class defines the default item renderer for the HorizontalList and TileList controls.
Timer
flash.utils The Timer class is the interface to Flash Player timers.
TimerEvent
flash.events Flash® Player dispatches TimerEvent objects whenever a Timer object reaches the interval specified by the Timer.delay property.
TitleBackground
mx.skins.halo The skin for a title bar area of a Panel.
TitleWindow
mx.containers A TitleWindow navigator container contains a title bar, a caption, a border, and a content area for its child.
ToggleButtonBar
mx.controls The ToggleButtonBar control defines a horizontal or vertical group of buttons that maintain their selected or deselected state.
ToolTip
mx.controls The ToolTip control lets you provide helpful information to your users.
ToolTipBorder
mx.skins.halo The skin for a ToolTip.
ToolTipEvent
mx.events The ToolTipEvent class represents ToolTip events, which are generated by the ToolTipManager class.
ToolTipManager
mx.managers The ToolTipManager lets you set basic ToolTip and error tip functionality, such as display delay and the disabling of ToolTips.
TraceTarget
mx.logging.targets Provides a logger target that uses the global trace() method to output log messages.
Transform
flash.geom The Transform class collects data about color transformations and coordinate transformations that are applied to a display object.
Transition
mx.states The Transition class defines a set of effects that play in response to a change of view state.
Tree
mx.controls The Tree control lets a user view hierarchical data arranged as an expandable tree.
TreeEvent
mx.events The TreeEvent class represents the event object passed to the event listener for events that are associated with activities in tree, such as when a tree branch opens or closes.
TreeItemRenderer
mx.controls.treeClasses The TreeItemRenderer class defines the default item renderer for a Tree control.
TreeListData
mx.controls.treeClasses The TreeListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the Tree control.
TriangleItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills an upright triangle in its assigned area.
Tween
mx.effects The Tween class defines a tween, a property animation performed on a target object over a period of time.
TweenEffect
mx.effects The TweenEffect class is the superclass for all effects that are based on the Tween object.
TweenEffectInstance
mx.effects.effectClasses The TweenEffectInstance class implements the instance class for the TweenEffect.
TweenEvent
mx.events Represents event objects that are specific to Flex tween effects.
TypeError
Top Level A TypeError exception is thrown when the actual type of an operand is different from the expected type.
UIComponent
mx.core The UIComponent class is the base class for all visual components, both interactive and noninteractive.
UIComponentCachePolicy
mx.core The ContainerCreationPolicy class defines the constant values for the cachePolicy property of the UIComponent class.
UIComponentDescriptor
mx.core A UIComponentDescriptor instance encapsulates the information that you specified in an MXML tag for an instance of a visual component.
UIDUtil
mx.utils The UIDUtil class is an all-static class with methods for working with UIDs (unique identifiers) within Flex.
uint
Top Level The uint class provides methods for working with a data type representing a 32-bit unsigned integer.
UITextField
mx.core The UITextField class defines the component used by many Flex components to display text.
UITextFormat
mx.core The UITextFormat class represents character formatting information for the UITextField class.
UnresolvedConflictsError
mx.data.errors This error is thrown when a commit request is made while there are still unresolved conflicts and no listener has been registered for UnresolvedConflictsEvent.FAULT.
UnresolvedConflictsEvent
mx.data.events A DataList throws this event when the commit() method is called while conflicts remain unresolved.
UpdateCollectionMessage
mx.data.messages This message is used to establish consistency between the remote sequence and the corresponding local collection.
UpdateCollectionRange
mx.data The UpdateCollectionRange class provides specific information about a range of add and remove operations made to a collection.
URIError
Top Level A URIError exception is thrown when one of the global URI handling functions is used in a way that is incompatible with its definition.
URLLoader
flash.net The URLLoader class downloads data from a URL as text, binary data, or URL-encoded variables.
URLLoaderDataFormat
flash.net The URLLoaderDataFormat class provides values that specify how downloaded data is received.
URLRequest
flash.net The URLRequest class captures all of the information in a single HTTP request.
URLRequestHeader
flash.net A URLRequestHeader object encapsulates a single HTTP request header and consists of a name/value pair.
URLRequestMethod
flash.net The URLRequestMethod class provides values that specify whether the URLRequest object should use the POST method or the GET method when sending data to a server.
URLStream
flash.net The URLStream class provides low-level access to downloading URLs.
URLUtil
mx.utils The URLUtil class is a static class with methods for working with full and relative URLs within Flex.
URLVariables
flash.net The URLVariables class allows you to transfer variables between a Flash® application and a server.
ValidationResult
mx.validators The ValidationResult class contains the results of a validation.
ValidationResultEvent
mx.events The ValidationResultEvent class represents the event object passed to the listener for the valid validator event or the invalid validator event.
Validator
mx.validators The Validator class is the base class for all Flex validators.
VBox
mx.containers The VBox container lays out its children in a single vertical column.
VDividedBox
mx.containers The VDividedBox container lays out its children vertically in the same way as the VBox container, but it inserts a draggable divider in the gap between each child.
VerifyError
Top Level The VerifyError class represents an error that occurs when a malformed or corrupted SWF file is encountered.
Video
flash.media The Video class enables you to display live streaming video in an application without embedding it in your SWF file.
VideoDisplay
mx.controls The VideoDisplay control lets you play an FLV file in a Flex application.
VideoError
mx.controls.videoClasses The VideoError class represents the error codes for errors thrown by the VideoDisplay control.
VideoEvent
mx.events The VideoEvent class represents the event object passed to the event listener for events dispatched by the VideoDisplay control, and defines the values of the VideoDisplay.state property.
ViewStack
mx.containers A ViewStack navigator container consists of a collection of child containers stacked on top of each other, where only one child at a time is visible.
VRule
mx.controls The VRule control creates a single vertical line.
VScrollBar
mx.controls The VScrollBar (vertical ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
VSlider
mx.controls The VSlider control lets users select a value by moving a slider thumb between the end points of the slider track.
WebService
mx.rpc.soap.mxml The <mx:WebService> tag gives you access to the operations of SOAP-compliant web services.
WebService
mx.rpc.soap The WebService class provides access to SOAP-based web services on remote servers.
WedgeItemRenderer
mx.charts.renderers The default itemRenderer for a PieSeries object.
WipeDown
mx.effects The WipeDown class defines a bar wipe down effect.
WipeDownInstance
mx.effects.effectClasses The WipeDownInstance class implements the instance class for the WipeDown effect.
WipeLeft
mx.effects The WipeLeft class defines a bar wipe left effect.
WipeLeftInstance
mx.effects.effectClasses The WipeLeftInstance class implements the instance class for the WipeLeft effect.
WipeRight
mx.effects The WipeRight class defines a bar wipe right effect.
WipeRightInstance
mx.effects.effectClasses The WipeRightInstance class implements the instance class for the WipeRight effect.
WipeUp
mx.effects The WipeUp class defines a bar wipe up effect.
WipeUpInstance
mx.effects.effectClasses The WipeUpInstance class implements the instance class for the WipeUp effect.
XML
Top Level The XML class contains methods and properties for working with XML objects.
XMLDocument
flash.xml The XMLDocument class represents the legacy XML object that was present in ActionScript 2.0.
XMLList
Top Level An XMLList object is an ordered collection of properties.
XMLListCollection
mx.collections The XMLListCollection class provides collection functionality to an XMLList object and makes available some of the methods of the native XMLList class.
XMLNode
flash.xml The XMLNode class represents the legacy XML object that was present in ActionScript 2.0 and that was renamed in ActionScript 3.0.
XMLNodeType
flash.xml The XMLNodeType class contains constants used with XMLNode.nodeType.
XMLSocket
flash.net The XMLSocket class implements client sockets that let the computer that is running Flash Player communicate with a server computer identified by an IP address or domain name.
XMLUtil
mx.utils The XMLUtil class is an all-static class with methods for working with XML within Flex.
ZipCodeFormatter
mx.formatters The ZipCodeFormatter class formats a valid number into one of the following formats, based on a user-supplied formatString property.
ZipCodeValidator
mx.validators The ZipCodeValidator class validates that a String has the correct length and format for a five-digit ZIP code, a five-digit+four-digit United States ZIP code, or Canadian postal code.
ZipCodeValidatorDomainType
mx.validators The ZipCodeValidatorDomainType class defines the values for the domain property of the ZipCodeValidator class, which you use to specify the type of ZIP code to validate.
Zoom
mx.effects The Zoom effect zooms the object in or out on a center point.
ZoomInstance
mx.effects.effectClasses The ZoomInstance class implements the instance class for the Zoom effect.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


All MX Classes (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
All MX Classes

Documentation for classes includes syntax, usage information, and code samples for methods, properties, and event handlers and listeners for those APIs that belong to a specific class in ActionScript (as opposed to global functions or properties). The classes are listed alphabetically. If you are not sure to which class a certain method or property belongs, you can look it up in the Index.

Class Package Description
AbstractEvent
mx.rpc.events The base class for events that RPC services dispatch.
AbstractInvoker
mx.rpc An invoker is an object that actually executes an remote procedure call (RPC).
AbstractMessage
mx.messaging.messages Abstract base class for all messages.
AbstractOperation
mx.rpc The AbstractOperation class represents an is an individual method on a service.
AbstractService
mx.rpc the AbstractService class is the base class for the WebService and RemoteObject classes.
AbstractTarget
mx.logging This class provides the basic functionality required by the logging framework for a target implementation.
Accordion
mx.containers An Accordion navigator container has a collection of child containers, but only one of them at a time is visible.
AccordionHeader
mx.containers.accordionClasses The AccordionHeader class defines the appearance of the navigation buttons of an Accordion.
AccordionHeaderSkin
mx.skins.halo The skin for all the states of an AccordionHeader in an Accordion.
AcknowledgeMessage
mx.messaging.messages An AcknowledgeMessage acknowledges the receipt of a message that was sent previously.
ActionEffectInstance
mx.effects.effectClasses The ActionEffectInstance class is the superclass for all action effect instance classes.
ActivatorSkin
mx.skins.halo Defines the up, down, and over states for MenuBarItem objects.
AddChild
mx.states The AddChild class adds a child display object, such as a component, to a container as part of a view state.
AddChildAction
mx.effects The AddChildAction class defines an action effect that corresponds to the AddChild property of a view state definition.
AddChildActionInstance
mx.effects.effectClasses The AddChildActionInstance class implements the instance class for the AddChildAction effect.
Alert
mx.controls The Alert control is a pop-up dialog box that can contain a message, a title, buttons (any combination of OK, Cancel, Yes, and No) and an icon.
AMFChannel
mx.messaging.channels The AMFChannel class provides the AMF support for messaging.
AnimateProperty
mx.effects The AnimateProperty effect animates a property or style of a component.
AnimatePropertyInstance
mx.effects.effectClasses The AnimatePropertyInstance class implements the instance class for the AnimateProperty effect.
Application
mx.core Flex defines a default, or Application, container that lets you start adding content to your application without explicitly defining another container.
ApplicationControlBar
mx.containers The ApplicationControlBar container holds components that provide global navigation and application commands.
AreaChart
mx.charts The AreaChart control represents data as an area bounded by a line connecting the values in the data.
AreaRenderer
mx.charts.renderers The default class used to render the area beneath the dataPoints of an AreaSeries object.
AreaSeries
mx.charts.series Defines a data series for an AreaChart control.
AreaSeriesItem
mx.charts.series.items Represents the information required to render an item as part of an AreaSeries.
AreaSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the AreaSeries to render.
AreaSet
mx.charts.series A grouping set that can be used to stack AreaSeries objects in any chart.
ArrayCollection
mx.collections The ArrayCollection class is a wrapper class that exposes an Array as a collection that can be accessed and manipulated using the methods and properties of the ICollectionView or IList interfaces.
ArrayUtil
mx.utils The ArrayUtil utility class is an all-static class with methods for working with arrays within Flex.
AsyncMessage
mx.messaging.messages AsyncMessage is the base class for all asynchronous messages.
AsyncRequest
mx.rpc The AsyncRequest class provides an abstraction of messaging for RPC call invocation.
AsyncToken
mx.rpc This class provides a place to set additional or token-level data for asynchronous rpc operations.
AxisBase
mx.charts.chartClasses The AxisBase class serves as a base class for the various axis types supported in Flex.
AxisLabel
mx.charts An AxisLabel object represents a single label on the chart axis.
AxisLabelSet
mx.charts.chartClasses An AxisLAbelSet represents the label and tick data generated by an implementation of IAxis.
AxisRenderer
mx.charts You use the AxisRenderer class to describe the horizontal and vertical axes of a chart.
Back
mx.effects.easing The Back class defines three easing functions to implement motion with Flex effect classes.
BarChart
mx.charts The BarChart control represents data as a series of horizontal bars whose length is determined by values in the data.
BarSeries
mx.charts.series Defines a data series for a BarChart control.
BarSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a BarSeries.
BarSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the BarSeries to render.
BarSet
mx.charts.series A grouping set that can be used to stack or cluster BarSeries objects in any chart.
BaseListData
mx.controls.listClasses The BaseListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors.
BindingUtils
mx.binding.utils The BindingUtils class defines utility methods for performing data binding from ActionScript.
BitmapAsset
mx.core BitmapAsset is a subclass of the Flash Player's Bitmap class which represents bitmap images that you embed in a Flex application.
BitmapFill
mx.graphics Defines a set of values used to fill an area on screen with a bitmap or other DisplayObject.
Blur
mx.effects The Blur effect lets you apply a blur visual effect to a component.
BlurInstance
mx.effects.effectClasses The BlurInstance class implements the instance class for the Blur effect.
Border
mx.skins The Border class is an abstract base class for various classes that draw borders, either rectangular or non-rectangular, around UIComponents.
Bounce
mx.effects.easing The Bounce class defines three easing functions to implement bounce motion with Flex effect classes.
BoundedValue
mx.charts.chartClasses A bounded value is used to represent a datapoint that a chart element intends to render on screen.
Box
mx.containers A Box container lays out its children in a single vertical column or a single horizontal row.
BoxDirection
mx.containers The BoxDirection class specifies constant values for the direction property of the Box container.
BoxItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a rectangular area.
BrokenImageBorderSkin
mx.skins.halo The skin for the border of a SWFLoader or Image component when the content could not be loaded.
BubbleChart
mx.charts The BubbleChart control represents data with three values for each data point.
BubbleSeries
mx.charts.series Defines a data series for a BubbleChart control.
BubbleSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a BubbleSeries.
BubbleSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the BubbleSeries to render.
Button
mx.controls The Button control is a commonly used rectangular button.
ButtonAsset
mx.core ButtonAsset is a subclass of the Flash Player's SimpleButton class which represents button symbols that you embed in a Flex application from a SWF file produced by Flash.
ButtonBar
mx.controls The ButtonBar control defines a horizontal or vertical group of logically related push buttons with a common look and navigation.
ButtonBarButtonSkin
mx.skins.halo The skin for all the states of the ButtonBarButtons in a ButtonBar.
ButtonLabelPlacement
mx.controls The ButtonLabelPlacement class defines the constants for the allowed values of the labelPlacement property of a Button, CheckBox, LinkButton, or RadioButton control.
ButtonSkin
mx.skins.halo The skin for all the states of a Button.
CalendarLayoutChangeEvent
mx.events The CalendarLayoutChangeEvent class represents the event object passed to the event listener for the change event for the DateChooser and DateField controls.
CandlestickChart
mx.charts The CandlestickChart control represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
CandlestickItemRenderer
mx.charts.renderers The default itemRenderer for a CandlestickSeries object.
CandlestickSeries
mx.charts.series Represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
Canvas
mx.containers A Canvas layout container defines a rectangular region in which you place child containers and controls.
CartesianChart
mx.charts.chartClasses The CartesianChart class is a base class for the common chart types.
CartesianTransform
mx.charts.chartClasses The CartesianTransform object represents a set of axes sed to map data values to x/y Cartesian screen coordinates and vice versa.
CategoryAxis
mx.charts The CategoryAxis class lets charts represent data grouped by a set of discrete values along an axis.
ChangeWatcher
mx.binding.utils The ChangeWatcher class defines utility methods that you can use with bindable Flex properties.
Channel
mx.messaging The Channel class is the base message channel class that all channels in the messaging system must extend.
ChannelError
mx.messaging.errors This is the base class for any channel related errors.
ChannelEvent
mx.messaging.events The ChannelEvent is used to propagate channel events within the messaging system.
ChannelFaultEvent
mx.messaging.events The ChannelFaultEvent class is used to propagate channel fault events within the messaging system.
ChannelSet
mx.messaging The ChannelSet is a set of Channels that are used to send messages to a target destination.
ChartBase
mx.charts.chartClasses The ChartBase class is the link between the Flex component architecture and the DualStyleObject architecture.
ChartElement
mx.charts.chartClasses The ChartElement class is the base class for visual chart elements.
ChartItem
mx.charts A ChartItem represents a single item in a ChartSeries.
ChartItemEvent
mx.charts.events The ChartItemEvent class represents events that are specific to the chart components, such as when a chart item is clicked.
ChartLabel
mx.charts.chartClasses Draws data labels on chart controls.
ChartState
mx.charts.chartClasses Describes the current state of a chart.
CheckBox
mx.controls The CheckBox control consists of an optional label and a small box that can contain a check mark or not.
CheckBoxIcon
mx.skins.halo The skin for all the states of the icon in a CheckBox.
ChildExistenceChangedEvent
mx.events Represents events that are dispatched when a the child of a control is created or destroyed.
CircleItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills an elliptical area.
Circular
mx.effects.easing The Circular class defines three easing functions to implement circular motion with Flex effect classes.
ClassFactory
mx.core A ClassFactory instance is a "factory object" which Flex uses to generate instances of another class, each with identical properties.
CloseEvent
mx.events The CloseEvent class represents event objects specific to popup windows, such as the Alert control.
CollectionEvent
mx.events The mx.events.CollectionEvent class represents an event that is dispatched when the associated collection changes.
CollectionEventKind
mx.events The CollectionEventKind class contains constants for the valid values of the mx.events.CollectionEvent class kind property.
CollectionViewError
mx.collections.errors The CollectionViewError class represents general errors within a collection that are not related to specific activities such as Cursor seeking.
ColorPicker
mx.controls The ColorPicker control provides a way for a user to choose a color from a swatch list.
ColorPickerEvent
mx.events Represents events that are specific to the ColorPicker control, such as when the user rolls the mouse over or out of a swatch in the swatch panel.
ColorPickerSkin
mx.skins.halo The skin for all the states of a ColorPicker.
ColorUtil
mx.utils The ColorUtil class is an all-static class with methods for working with RGB colors within Flex.
ColumnChart
mx.charts The ColumnChart control represents data as a series of vertical columns whose height is determined by values in the data.
ColumnSeries
mx.charts.series Defines a data series for a ColumnChart control.
ColumnSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a ColumnSeries.
ColumnSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the ColumnSeries to render.
ColumnSet
mx.charts.series ColumnSet is a grouping set that can be used to stack or cluster column series in any arbitrary chart.
ComboBase
mx.controls The ComboBase class is the base class for controls that display text in a text field and have a button that causes a drop-down list to appear where the user can choose which text to display.
ComboBox
mx.controls The ComboBox control contains a drop-down list from which the user can select a single value.
ComboBoxArrowSkin
mx.skins.halo The skin for all the states of the button in a ComboBox.
CommandMessage
mx.messaging.messages The CommandMessage class provides a mechanism for sending commands to the server infrastructure, such as commands related to publish/subscribe messaging scenarios, ping operations, and cluster operations.
ComponentDescriptor
mx.core ComponentDescriptor is the base class for the UIComponentDescriptor class, which encapsulates the information that you specified in an MXML tag for an instance of a visual component.
CompositeEffect
mx.effects The CompositeEffect class is the parent class for the Parallel and Sequence classes, which define the <mx:Parallel> and <mx:Sequence> MXML tags.
CompositeEffectInstance
mx.effects.effectClasses The CompositeEffectInstance class implements the instance class for the CompositeEffect class.
Conflict
mx.data The Conflict class is used to represent error that has occurred due to an update operation.
ConflictDetector
mx.data A DataService instance uses a ConflictDetector instance to determine when a conflict occurs for an operation pushed from a remote destination.
Conflicts
mx.data The Conflicts class represents a list of conflicts.
Consumer
mx.messaging A Consumer subscribes to a destination to receive messages.
Container
mx.core The Container class is an abstract base class for components that controls the layout characteristics of child components.
ContainerCreationPolicy
mx.core The ContainerCreationPolicy class defines the constant values for the creationPolicy property of the Container class.
ContainerLayout
mx.core The ContainerLayout class defines the constant values for the layout property of container classes.
ControlBar
mx.containers The ControlBar container lets you place controls at the bottom of a Panel or TitleWindow container.
CreditCardValidator
mx.validators The CreditCardValidator class validates that a credit card number is the correct length, has the correct prefix, and passes the Luhn mod10 algorithm for the specified card type.
CreditCardValidatorCardType
mx.validators The CreditCardValidatorCardType class defines value constants for specifying the type of credit card to validate.
CrossItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a cross in its assigned area.
CSSStyleDeclaration
mx.styles The CSSStyleDeclaration class represents a set of CSS style rules.
Cubic
mx.effects.easing The Cubic class defines three easing functions to implement motion with Flex effect classes.
CuePointEvent
mx.events The CuePointEvent class represents the event object passed to the event listener for cue point events dispatched by the VideoDisplay control.
CuePointManager
mx.controls.videoClasses The CuePointManager class lets you use ActionScript code to manage the cue points associated with the VideoDisplay control.
CurrencyFormatter
mx.formatters The CurrencyFormatter class formats a valid number as a currency value.
CurrencyValidator
mx.validators The CurrencyValidator class ensures that a String represents a valid currency expression.
CurrencyValidatorAlignSymbol
mx.validators The CurrencyValidatorAlignSymbol class defines value constants for specifying currency symbol alignment.
CursorBookmark
mx.collections Encapsulates the positional aspects of a cursor in an ICollectionView.
CursorError
mx.collections.errors This error is thrown by a collection Cursor.
CursorManager
mx.managers The CursorManager class controls a prioritized list of cursors, where the cursor with the highest priority is currently visible.
CursorManagerPriority
mx.managers The CursorManagerPriority class defines the constant values for the priority argument to the CursorManager.setCursor() method.
DataAssociationMessage
mx.data.messages This message is used to add and remove associations between objects managed by different data services.
DataConflictEvent
mx.data.events This event informs users of a DataService instance that a conflict has occured.
DataDescription
mx.charts.chartClasses The DataDescription structure is used by ChartElements to describe the characteristics of the data they represent to Axis objects that auto-generate values from the data represented in the chart.
DataErrorMessage
mx.data.messages Special cases of ErrorMessage will be sent when a data conflict occurs.
DataGrid
mx.controls The DataGrid control is a like a List except that it can show more than one column of data making it suited for showing objects with multiple properties.
DataGridBase
mx.controls.dataGridClasses The DataGridBase class is the base class for controls that display lists of items in multiple columns.
DataGridColumn
mx.controls.dataGridClasses The DataGridColumn class describes a column in a DataGrid control.
DataGridColumnDropIndicator
mx.skins.halo The skin for the column drop indicator in a DataGrid.
DataGridColumnResizeSkin
mx.skins.halo The skin for the column resizer in a DataGrid.
DataGridDragProxy
mx.controls.dataGridClasses The DataGridDragProxy class defines the default drag proxy used when dragging data from a DataGrid control.
DataGridEvent
mx.events The DataGridEvent class represents event objects that are specific to the DataGrid control, such as the event that is dispatched when an editable grid item gets the focus.
DataGridEventReason
mx.events The DataGridEventReason class defines constants for the values of the reason property of a DataGridEvent object when the type property is itemEditEnd.
DataGridHeaderSeparator
mx.skins.halo The skin for the separator between column headers in a DataGrid.
DataGridItemRenderer
mx.controls.dataGridClasses The DataGridItemRenderer class defines the default item renderer for a DataGrid control.
DataGridListData
mx.controls.dataGridClasses The DataGridListData class defines the data type of the listData property that is implemented by drop-in item renderers or drop-in item editors for the DataGrid control.
DataGridSortArrow
mx.skins.halo The skin for the sort arrow in a column header in a DataGrid.
DataListError
mx.data.errors This error is thrown when an unanticipated problem occurs in a DataList.
DataMessage
mx.data.messages This message is used to transport an operation that occured on a managed object or collection.
DataService
mx.data.mxml The DataService class provides the top-level functionality for distributed data in Flex 2.
DataService
mx.data The DataService class provides the top-level functionality for Data Management Services in Flex 2.
DataServiceError
mx.data.errors This error is thrown when a an unanticipated problem occurs in a DataService component.
DataServiceFaultEvent
mx.data.events This event is sent when a DataService or DataStore has generated a fault.
DataStore
mx.data A DataStore batches transactions for one or more DataService instances.
DataTip
mx.charts.chartClasses The DataTip control provides information about a data point to chart users.
DataTransform
mx.charts.chartClasses The DataTransform object represents a portion of a chart that contains glyphs and can transform values to screen coordinates and vice versa.
DateBase
mx.formatters The DateBase class contains the localized string information used by the mx.formatters.DateFormatter class and the parsing function that renders the pattern.
DateChooser
mx.controls The DateChooser control displays the name of a month, the year, and a grid of the days of the month, with columns labeled for the day of the week.
DateChooserEvent
mx.events The DateChooserEvent class represents the event object passed to the event listener for the scroll event for the DateChooser and DateField controls.
DateChooserEventDetail
mx.events Constants that define the values of the detail property of a DateChooserEvent object.
DateChooserIndicator
mx.skins.halo The skins of the DateChooser's indicators for displaying today, rollover and selected dates.
DateChooserMonthArrowSkin
mx.skins.halo The skin for all the states of the next-month and previous-month buttons in a DateChooser.
DateChooserYearArrowSkin
mx.skins.halo The skin for all the states of the next-year and previous-year buttons in a DateChooser.
DateField
mx.controls The DateField control is a text field that shows the date with a calendar icon on its right side.
DateFormatter
mx.formatters The DateFormatter class uses a format String to render date and time Strings from a String or a Date object.
DateTimeAxis
mx.charts The DateTimeAxis class maps time values evenly between a minimum and maximum value along a chart axis.
DateValidator
mx.validators The DateValidator class validates that a String or Object contains a proper date and matches a specified format.
DefaultDataDescriptor
mx.controls.treeClasses The DefaultDataDescriptor class provides a default implementation for accessing and manipulating data for use in controls such as Tree and Menu.
DeferredInstanceFromClass
mx.core A deferred instance factory that creates and returns an instance of a specified class.
DeferredInstanceFromFunction
mx.core A deferred instance factory that uses a generator function to create an instance of the required object.
DescribeTypeCache
mx.utils DescribeTypeCache is a convenience class that is used to cache the return values of flash.utils.describeType() so that calls made subsequent times return faster.
DescribeTypeCacheRecord
mx.utils This class represents a single cache entry, this gets created as part of the describeType method call on the DescribeTypeCache class.
DiamondItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a diamond in its assigned area.
Dissolve
mx.effects Animate the component from transparent to opaque, or from opaque to transparent.
DissolveInstance
mx.effects.effectClasses The DissolveInstance class implements the instance class for the Dissolve effect.
DividedBox
mx.containers A DividedBox container measures and lays out its children horizontally or vertically in exactly the same way as a Box container, but it inserts draggable dividers in the gaps between the children.
DividerEvent
mx.events Represents events that are dispatched when a divider has been pressed, dragged or released.
DownloadProgressBar
mx.preloaders The DownloadProgressBar class displays download progress.
DragEvent
mx.events The DragEvent class represents event objects that are dispatched as part of a drag-and-drop operation.
DragManager
mx.managers The DragManager class manages drag and drop operations, which let you move data from one place to another in a Flex application.
DragSource
mx.core The DragSource class contains the data being dragged.
DropdownEvent
mx.events The DropdownEvent class represents the event object passed to the event listener for the open and close events.
DualStyleObject
mx.charts.chartClasses The DualStyleObject class serves as a base class for components that have a need to assign class selectors outside of the client developer's control.
DynamicEvent
mx.events This subclass of Event is dynamic, meaning that you can set arbitrary event properties on its instances at runtime.
EdgeMetrics
mx.core The EdgeMetrics class specifies the thickness, in pixels, of the four edge regions around a visual component.
Effect
mx.effects The Effect class is an abstract base class that defines the basic functionality of all Flex effects.
EffectEvent
mx.events Represents event objects that are specific to Flex effects.
EffectInstance
mx.effects The EffectInstance class represents an instance of an effect playing on a target.
EffectManager
mx.effects The EffectManager class listens for events, such as the show and move events, dispatched by objects in a Flex application.
EffectTargetFilter
mx.effects The EffectTargetFilter class defines a custom filter that is executed by each transition effect on each target of the effect.
Elastic
mx.effects.easing The Elastc class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
EmailValidator
mx.validators The EmailValidator class validates that a String has a single @ sign, a period in the domain name and that the top-level domain suffix has two, three, four, or six characters.
ErrorMessage
mx.messaging.messages The ErrorMessage class is used to report errors within the messaging system.
EventPriority
mx.core The EventPriority class defines constant values for the priority argument of the addEventListener() method of EventDispatcher.
Exponential
mx.effects.easing The Exponential class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
Fade
mx.effects The Fade effect animates the alpha property of a component, either from transparent to opaque, or from opaque to transparent.
FadeInstance
mx.effects.effectClasses The FadeInstance class implements the instance class for the Fade effect.
Fault
mx.rpc Object that represents a fault in an remote procedure call (RPC) service invocation.
FaultEvent
mx.rpc.events This event is dispatched when an RPC call has a fault.
FlexBitmap
mx.core FlexBitmap is a subclass of the Player's Bitmap class.
FlexEvent
mx.events The FlexEvent class represents the event object passed to the event listener for many Flex events.
FlexMouseEvent
mx.events The FlexMouseEvent class represents the event object passed to the event listener for Flex-specific mouse activity.
FlexMovieClip
mx.core FlexMovieClip is a subclass of the Player's MovieClip class.
FlexPrintJob
mx.printing The FlexPrintJob class is a wrapper over the Flash Player's PrintJob API.
FlexPrintJobScaleType
mx.printing Values for the scaleType property of the FlexPrintJob.addObject() method parameter.
FlexShape
mx.core FlexShape is a subclass of the Player's Shape class.
FlexSimpleButton
mx.core FlexSimpleButton is a subclass of the Player's SimpleButton class.
FlexSprite
mx.core FlexSprite is a subclass of the Player's Sprite class and the superclass of UIComponent.
FlexTextField
mx.core FlexTextField is a subclass of the Player's TextField class and the superclass of UITextField.
FocusManager
mx.managers The FocusManager class manages the focus on components in response to mouse activity or keyboard activity (Tab key).
Form
mx.containers The Form container lets you control the layout of a form, mark form fields as required or optional, handle error messages, and bind your form data to the Flex data model to perform data checking and validation.
Formatter
mx.formatters The Formatter class is the base class for all data formatters.
FormHeading
mx.containers The FormHeading container is used to display a heading for a group of controls inside a Form container.
FormItem
mx.containers The FormItem container defines a label and one or more children arranged horizontally or vertically.
FormItemDirection
mx.containers The FormItem container defines the constant values for the direction property of the FormItem class.
FormItemLabel
mx.controls The FormItem container uses a FormItemLabel object to display the label portion of the FormItem container.
Glow
mx.effects The Glow effect lets you apply a visual glow effect to a component.
GlowInstance
mx.effects.effectClasses The GlowInstance class implements the instance class for the Glow effect.
GradientEntry
mx.graphics The GradientEntry class defines the objects that control a transition as part of a gradient fill.
GraphicsUtil
mx.utils The Graphics class is an all-static class with utility methods related to the Graphics class.
Grid
mx.containers A Grid container lets you arrange children as rows and columns of cells, similar to an HTML table.
GridItem
mx.containers The GridItem container defines a grid cell in GridRow container.
GridLines
mx.charts The GridLines class draws grid lines inside the data area of the chart.
GridRow
mx.containers The GridRow container defines a row in a Grid container, and contains GridCell containers.
HaloBorder
mx.skins.halo Defines the appearance of the default border for the Halo theme.
HaloColors
mx.skins.halo Defines the colors used by components that support the Halo theme.
HaloFocusRect
mx.skins.halo Defines the skin for the focus indicator.
HBox
mx.containers The HBox container lays out its children in a single horizontal row.
HDividedBox
mx.containers The HDividedBox container lays out its children horizontally in the same way as HBox container, but it inserts a draggable divider in the gap between each child.
HeaderEvent
mx.rpc.events The event that indicates an RPC operation, such as a WebService SOAP request, returned a header in the response.
HistoryManager
mx.managers History management lets users navigate through a Flex application using the web browser's Back and Forward navigation commands.
HitData
mx.charts The HitData class represents information about the data item at a specific location on the screen.
HLOCChart
mx.charts The HLOCChart (High Low Open Close) control represents financial data as a series of elements representing the high, low, closing, and optionally opening values of a data series.
HLOCItemRenderer
mx.charts.renderers The default item Rnderer for an HLOCSeries object.
HLOCSeries
mx.charts.series Represents financial data as a series of elements representing the high, low, closing, and, optionally, opening values of a data series.
HLOCSeriesBase
mx.charts.chartClasses HLOCSeriesBase is the base class for the two financial series types, HLOCSeries and CandlestickSeries.
HLOCSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a HLOCSeries.
HLOCSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the HLOCSeries and CandlestickSeries objects to render.
HorizontalList
mx.controls The HorizontalList control displays a horizontal list of items.
HRule
mx.controls The HRule control creates a single horizontal line.
HScrollBar
mx.controls The HScrollBar (horizontal ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
HSlider
mx.controls The HSlider control lets users select a value by moving a slider thumb between the end points of the slider track.
HTTPChannel
mx.messaging.channels The HTTPChannel class provides the HTTP support for messaging.
HTTPRequestMessage
mx.messaging.messages HTTP requests are sent to the HTTP endpoint using this message type.
HTTPService
mx.rpc.http When you call the HTTPService object's send() method, it makes an HTTP GET or POST request to the specified URL, and an HTTP response is returned.
HTTPService
mx.rpc.http.mxml You use the <mx:HTTPService> tag to represent an HTTPService object in an MXML file.
IAccessPrivileges
mx.data Objects that must restrict access must implement the IAccessPrivileges interface.
IAxis
mx.charts.chartClasses The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IAxisRenderer
mx.charts.chartClasses The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IBar
mx.charts.chartClasses The IBar interface is implemented by any any series that can be clustered vertically, such as a BarSeries.
IChangeObject
mx.data The IChangeObject interface provides the methods and properties needed when decting local conflicts.
IChartElement
mx.charts.chartClasses IChartElement defines the base set of properties and methods required by a UIComponent to be representable in the data space of a chart.
IChildList
mx.core The IChildList interface defines the properties and methods for accessing and manipulating child lists, which are subsets of a DisplayObjectContainer's children.
ICollectionView
mx.collections An ICollectionView is a view onto a collection of data.
IColumn
mx.charts.chartClasses ChartElements that can be clustered along the vertical axis should implement this interface.
IContainer
mx.core IContainer is a marker interface that indicates a component acts as a container for other components.
IDataRenderer
mx.core The IDataRenderer interface defines the interface for components that have a data property.
IDeferredInstance
mx.core The IDeferredInstance interface defines the Flex deferred instance factory interface.
IDeferredInstantiationUIComponent
mx.core The IDeferredInstantiationUIComponent interface defines the interface for a component or object that defers instantiation.
IDropInListItemRenderer
mx.controls.listClasses The interface for "drop-in" item renderers.
IFactory
mx.core The IFactory interface defines the interface that factory classes such as ClassFactory must implement.
IFill
mx.graphics Defines the interface that classes that perform a fill must implement.
IFlexAsset
mx.core IFlexAsset is a marker interface with the following meaning: if a class declares that it implements IFlexAsset, then that class represents an asset -- such as a bitmap, a font, or a sound -- that has been embedded in a Flex application.
IFlexDisplayObject
mx.core The IFlexDisplayObject interface defines the interface for skin elements.
IFocusManager
mx.managers The IFocusManager interface defines the interface that components must implement to manage the focus on components in response to mouse activity or keyboard activity (Tab key), and to support a default button.
IFocusManagerComponent
mx.managers The IFocusManagerComponent interface defines the interface that focusable components must implement in order to receive focus from the FocusManager.
IFocusManagerContainer
mx.managers The IFocusManagerContainer interface defines the interface that containers implement to host a FocusManager.
IFocusManagerGroup
mx.managers The IFocusManagerGroup interface defines the interface that any component must implement if it is grouped in sets, where only one member of the set can be selected at any given time.
IHistoryManagerClient
mx.managers Interface that must be implemented by objects registered with the History Manager.
IIMESupport
mx.core The IIMESupport interface defines the interface for any component that supports IME (input method editor).
IInvalidating
mx.core The IInvalidating interface defines the interface for components that use invalidation to do delayed -- rather than immediate -- property commitment, measurement, drawing, and layout.
ILayoutManagerClient
mx.managers The ILayoutManagerClient interface defines the interface that a component must implement to participate in the LayoutManager's commit/measurement/layout sequence.
IList
mx.collections A collection of items organized in an ordinal fashion.
IListItemRenderer
mx.controls.listClasses Item renderers and item editors for list components must implement the IListItemRenderer interface.
ILogger
mx.logging All loggers within the logging framework must implement this interface.
ILoggingTarget
mx.logging All logger target implementations within the logging framework must implement this interface.
Image
mx.controls The Image control lets you import JPEG, PNG, GIF, and SWF files at runtime.
IManaged
mx.data The IPropertyChangeNotifier interface provides the contract for a managed object.
IMenuDataDescriptor
mx.controls.menuClasses The IMenuDataDescriptor interface defines the interface that a dataDescriptor for a Menu or MenuBar control must implement.
IMenuItemRenderer
mx.controls.menuClasses The IMenuItemRenderer interface defines the interface that a menu item renderer for a Menu control must implement.
IMessage
mx.messaging.messages This interface defines the contract for message objects.
IMXMLObject
mx.core The IMXMLObject interface defines the APIs that a non-visual component must implement in order to work properly with the MXML compiler.
IMXMLSupport
mx.rpc.mxml Implementing this interface means that an RPC service can be used in an MXML document via tags since it supports the interfaces specified during Flex 1.
IndexChangedEvent
mx.events The IndexChangedEvent class represents events that are dispatched when an index changes.
InstanceCache
mx.charts.chartClasses InstanceCache is a utilty that governs the task of creating and managing a set of n object instances, where n changes frequently.
InvalidCategoryError
mx.logging.errors This error is thrown when a category specified for a logger contains invalid characters or is malformed.
InvalidChannelError
mx.messaging.errors This error is thrown when a Channel can't be accessed or is not valid for the current destination.
InvalidDestinationError
mx.messaging.errors This error is thrown when a destination can't be accessed or is not valid.
InvalidFilterError
mx.logging.errors This error is thrown when a filter specified for a target contains invalid characters or is malformed.
InvokeEvent
mx.rpc.events The event that indicates an RPC operation has been invoked.
IOverride
mx.states The IOverride interface is used for view state overrides.
IPreloaderDisplay
mx.preloaders The IPreloaderDisplay interface defines the inteface that a class must implement to be used as a download progress bar.
IPropertyChangeNotifier
mx.core The IPropertyChangeNotifier interface defines a marker interface.
IRawChildrenContainer
mx.core The IRawChildrenContainer interface defines the APIs for containers that can return an IChildList that represents all their children.
IRepeater
mx.core The IRepeater interface defines the APIs for Repeater public APIs of the Repeater object.
IRepeaterClient
mx.core The IRepeaterClient interface defines the APIs for components that can have multiple instances created by a Repeater.
IResponder
mx.rpc This interface provides the contract for any service that needs to respond to remote or asynchronous calls.
Iris
mx.effects The Iris effect animates the effect target by expanding or contracting a rectangular mask centered on the target.
IrisInstance
mx.effects.effectClasses The IrisInstance class implements the instance class for the Iris effect.
ISimpleStyleClient
mx.styles This interface describes the properties and methods that an object must implement so that it can participate in the style subsystem.
IStackable
mx.charts.chartClasses The IStackable interface is implemented by any series that can be stacked.
IStroke
mx.graphics Defines the interface that classes that define a line must implement.
IStyleClient
mx.styles This interface describes the properties and methods that an object must implement so that it can fully participate in the style subsystem.
ISystemManager
mx.managers An ISystemManager manages an "application window".
ItemClickEvent
mx.events Represents events that are dispatched when a navigation item on a navigator bar, such as a ButtonBar, LinkBar, or TabBar control, has been clicked.
ItemPendingError
mx.collections.errors This error is thrown when retrieving an item from a collection view requires an asynchronous call.
ItemReference
mx.data An ItemReference instance is returned from the DataService.getItem() and DataService.createItem() methods to provide you with a way to manage your reference to the remote object.
ItemResponder
mx.collections The ItemResponder class provides a default implementation of the mx.rpc.IResponder interface.
IToolTip
mx.core The IToolTip interface defines the API that tooltip-like components must implement in order to work with the ToolTipManager.
IToolTipManagerClient
mx.managers Components that implement IToolTipManagerClient can have tooltips and must have a toolTip getter/setter.
ITreeDataDescriptor
mx.controls.treeClasses Interface providing methods for parsing and adding nodes to a collection of data that is displayed by a Tree control.
IUIComponent
mx.core The IUIComponent interface defines the basic set of APIs that you must implement to create a child of a Flex container or list.
IUID
mx.core The IUID interface defines the interface for objects that must have Unique Identifiers (UIDs) to uniquely identify the object.
IValidatorListener
mx.validators The interface that components implement to support the Flex data validation mechanism.
IViewCursor
mx.collections Defines the interface for enumerating a collection view bi-directionally.
Label
mx.controls The Label control displays a single line of noneditable text.
LayoutManager
mx.managers The LayoutManager is the engine behind Flex's measurement and layout strategy.
Legend
mx.charts The Legend control adds a legend to your charts, where the legend displays the label for each data series in the chart and a key showing the chart element for the series.
LegendData
mx.charts.chartClasses The LegendData structure is used by charts to describe the items that should be displayed in an auto-generated legend.
LegendItem
mx.charts Controls the individual legend elements in a chart legend.
LegendMouseEvent
mx.charts.events The LegendMouseEvent class represents event objects that are specific to the chart legend components.
Linear
mx.effects.easing The Linear class defines easing functions to implement linear motion with Flex effect classes.
LinearAxis
mx.charts The LinearAxis class maps numeric values evenly between a minimum and maximum value along a chart axis.
LinearGradient
mx.graphics The LinearGradient class lets you specify the fill of a graphical element, where a gradient specifies a gradual color transition in the fill color.
LinearGradientStroke
mx.graphics The LinearGradientStroke class lets you specify a gradient filled stroke.
LineChart
mx.charts The LineChart control represents a data series as points connected by a continuous line.
LineFormattedTarget
mx.logging.targets All logger target implementations that have a formatted line style output should extend this class.
LineRenderer
mx.charts.renderers A simple implementation of a line segment renderer that is used by LineSeries objects.
LineSeries
mx.charts.series Defines a data series for a LineChart control.
LineSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a LineSeries.
LineSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the LineSeries to render.
LineSeriesSegment
mx.charts.series.items Represents the information required to render a segment in a LineSeries.
LinkBar
mx.controls A LinkBar control defines a horizontal or vertical row of LinkButton controls that designate a series of link destinations.
LinkButton
mx.controls The LinkButton control is a borderless Button control whose contents are highlighted when a user moves the mouse over it.
LinkButtonSkin
mx.skins.halo The skin for all the states of a LinkButton.
LinkSeparator
mx.skins.halo The skin for the separator between the Links in a LinkBar.
List
mx.controls The List control displays a vertical list of items.
ListBase
mx.controls.listClasses The ListBase class is the base class for controls that represent lists of items that can have one or more selected and can scroll through the items.
ListBaseSeekPending
mx.controls.listClasses An object that stores data about a seek operation that was interrupted by an ItemPendingError error.
ListBaseSelectionData
mx.controls.listClasses Records used by list classes to keep track of what is selected.
ListCollectionView
mx.collections The ListCollectionView class adds the properties and methods of the ICollectionView interface to an object that conforms to the IList interface.
ListData
mx.controls.listClasses The ListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the List control.
ListDropIndicator
mx.skins.halo The skin for the drop indicator of a list-based control.
ListEvent
mx.events The ListEvent class represents events associated with items in list-based controls such as List, Tree, Menu, and DataGrid.
ListEventReason
mx.events Constants for the values of the reason property of a ListEvent object where the value of the type property is ListEvent.ITEM_EDIT_END.
ListItemDragProxy
mx.controls.listClasses The default drag proxy used when dragging from a list-based control (except for the DataGrid class).
ListItemRenderer
mx.controls.listClasses The ListItemRenderer class defines the default item renderer for a List control.
ListRowInfo
mx.controls.listClasses Used by the list-based classes to store information about their IListItemRenderers.
LoaderConfig
mx.messaging.config This class acts as a context for the messaging framework so that it has access the URL and arguments of the SWF without needing access to the root MovieClip's LoaderInfo or Flex's Application class.
LoadEvent
mx.rpc.soap This event is dispatched when the WSDL document has loaded sucessfully.
Locale
mx.resources You can use this class to query the current Locale.
Log
mx.logging Provides psuedo-hierarchical logging capabilities with multiple format and output options.
LogAxis
mx.charts The LogAxis class maps numeric values logarithmically between a minimum and maximum value along a chart axis.
LogEvent
mx.logging Represents the log information for a single logging event.
LogEventLevel
mx.logging Static class containing constants for use in the level property.
LogLogger
mx.logging The logger that is used within the logging framework.
Managed
mx.data.utils Provides utility methods for DataService managed objects.
MaskEffect
mx.effects The MaskEffect class is an abstract base class for all effects that animate a mask, such as the wipe effects and the Iris effect.
MaskEffectInstance
mx.effects.effectClasses The MaskEffectInstance class is an abstract base class that implements the instance class for the MaskEffect class.
MBeanAttributeInfo
mx.messaging.management Client representation of metadata for a MBean attribute.
MBeanFeatureInfo
mx.messaging.management Client representation of metadata for a MBean feature.
MBeanInfo
mx.messaging.management Client representation of metadata for a MBean.
MBeanOperationInfo
mx.messaging.management Client representation of metadata for a MBean operation.
MBeanParameterInfo
mx.messaging.management Client representation of metadata for a MBean operation parameter.
Menu
mx.controls The Menu control creates a pop-up menu of individually selectable choices, similar to the File or Edit menu found in most software applications.
MenuBar
mx.controls A MenuBar control defines a horizontal menu bar that contains one or more child menus.
MenuBarBackgroundSkin
mx.skins.halo The skin for the background of a MenuBar.
MenuBarItem
mx.controls.menuClasses The MenuBarItem class defines an item displayed in a MenuBar control.
MenuEvent
mx.events The MenuEvent class represents events that are associated with menu activities in controls such as Menu, MenuBar, and PopUpMenuButton.
MenuItemRenderer
mx.controls.menuClasses The MenuItemRenderer class defines the default item renderer for menu items in any menu control.
MessageAckEvent
mx.messaging.events The MessageAckEvent class is used to propagate acknowledge messages within the messaging system.
MessageAgent
mx.messaging The MessageAgent class provides the basic low-level functionality common to message handling for a destination.

Note: For advanced use only.

MessageEvent
mx.messaging.events The MessageEvent class is used to propagate messages within the messaging system.
MessageFaultEvent
mx.messaging.events The MessageFaultEvent class is used to propagate fault messages within the messaging system.
MessageResponder
mx.messaging The MessageResponder class handles a successful result or fault from a message destination.
MessageSerializationError
mx.messaging.errors This error indicates a problem serializing a message within a channel.
MessagingError
mx.messaging.errors This is the base class for any messaging related error.
MiniDebugTarget
mx.logging.targets Provides a logger target that outputs to a LocalConnection, connected to the MiniDebug application.
Move
mx.effects The Move effect changes the position of a component over a specified time interval.
MoveEvent
mx.events Represents event objects that are dispatched when a Flex component moves.
MoveInstance
mx.effects.effectClasses The MoveInstance class implements the instance class for the Move effect.
MovieClipAsset
mx.core MovieClipAsset is a subclass of the Flash Player's MovieClip class which represents movieclip symbols that you embed in a Flex application from a SWF file produced by Flash.
MovieClipLoaderAsset
mx.core MovieClipLoaderAsset is a subclass of the MovieClipAsset class which represents SWF files that you embed in a Flex application.
NameUtil
mx.utils The NameUtil utility class defines static methods for creating names for Flex objects.
NavBar
mx.controls The NavBar control is the superclass for navigator controls, such as the LinkBar and TabBar controls, and cannot be instantiated directly.
NetConnectionChannel
mx.messaging.channels This NetConnectionChannel provides the basic NetConnection support for messaging.
NoChannelAvailableError
mx.messaging.errors This error is thrown when no Channel is available to send messages.
NoDataAvailableError
mx.data.errors This error is thrown when data requested is not local.
NumberBase
mx.formatters The NumberBase class is a utility class that contains general number formatting capabilities, including rounding, precision, thousands formatting, and negative sign formatting.
NumberBaseRoundType
mx.formatters The NumberBaseRoundType class defines the constant values for formatter properties that specify a type of rounding.
NumberFormatter
mx.formatters The NumberFormatter class formats a valid number by adjusting the decimal rounding and precision, the thousands separator, and the negative sign.
NumberValidator
mx.validators The NumberValidator class ensures that a String represents a valid number.
NumericAxis
mx.charts.chartClasses The NumericAxis class acts as a common base class for axis types representing a continuous range of values between a defined minimum and maximum.
NumericStepper
mx.controls The NumericStepper control lets the user select a number from an ordered set.
NumericStepperDownSkin
mx.skins.halo The skin for all the states of the down button in a NumericStepper.
NumericStepperEvent
mx.events Represents events that are specific to the NumericStepper control.
NumericStepperUpSkin
mx.skins.halo The skin for all the states of the up button in a NumericStepper.
ObjectInstance
mx.messaging.management Client representation of an object name instance for server-side management controls.
ObjectName
mx.messaging.management Client representation of the name for server-side management controls.
ObjectProxy
mx.utils This class provides the ability to track changes to an item managed by this proxy.
ObjectUtil
mx.utils The ObjectUtil class is an all-static class with methods for working with Objects within Flex.
Operation
mx.rpc.remoting An Operation used specifically by RemoteObjects.
Operation
mx.rpc.soap.mxml An Operation used specifically by WebServices.
Operation
mx.rpc.soap An Operation used specifically by WebServices.
Operation
mx.rpc.remoting.mxml The Operation used for RemoteObject when created in an MXML document
PagedMessage
mx.data.messages This messsage provides information about a partial sequence result.
PageInformation
mx.data The PageInformation object provides detailed data about what pages of a collection have been loaded, how many there are, and what the current page size is.
Panel
mx.containers A Panel container consists of a title bar, a caption, a border, and a content area for its children.
Parallel
mx.effects The Parallel effect plays multiple child effects at the same time.
ParallelInstance
mx.effects.effectClasses The ParallelInstance class implements the instance class for the Parallel effect.
Pause
mx.effects The Pause effect is useful when sequencing effects.
PauseInstance
mx.effects.effectClasses The PauseInstance class implements the instance class for the Pause effect.
PhoneFormatter
mx.formatters The PhoneFormatter class formats a valid number into a phone number format, including international configurations.
PhoneNumberValidator
mx.validators The PhoneNumberValidator class validates that a string is a valid phone number.
PieChart
mx.charts The PieChart control represents a data series as a standard pie chart.
PieSeries
mx.charts.series The PieSeries class defines the data series for a PieChart control.
PieSeriesItem
mx.charts.series.items Represents the information required to render a single wedge as part of a PieSeries.
PieSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the PieSeries to render.
PlotChart
mx.charts The PlotChart control represents data with two values for each data point.
PlotSeries
mx.charts.series Defines a data series for a PlotChart control.
PlotSeriesItem
mx.charts.series.items Represents the information required to render an item as part of a PlotSeries.
PlotSeriesRenderData
mx.charts.series.renderData Represents all the information needed by the PlotSeries to render.
PolarChart
mx.charts.chartClasses The PolarChart control serves as base class for circular charts based in polar coordinates.
PolarTransform
mx.charts.chartClasses The PolarTransform object represents a set of axes used to map data values to angle/distance polar coordinates and vice versa.
PollingChannel
mx.messaging.channels The PollingChannel class provides the polling behavior that all polling channels in the messaging system require.
PopUpButton
mx.controls The PopUpButton control adds a flexible pop-up control interface to a Button control.
PopUpButtonSkin
mx.skins.halo The skin for all the states of a PopUpButton.
PopUpIcon
mx.skins.halo The skin for all the states of the icon in a PopUpButton.
PopUpManager
mx.managers The PopUpManager singleton class creates new top-level windows and places or removes those windows from the layer on top of all other visible windows.
PopUpManagerChildList
mx.managers The PopUpManagerChildList class defines the constant values for the detail property of the PopUpManager addPopUp() and createPopUp() methods.
PopUpMenuButton
mx.controls The PopUpMenuButton control creates a PopUpButton control with a main sub-button and a secondary sub-button.
PopUpMenuIcon
mx.skins.halo The skin for all the states of the icon in a PopUpMenuButton.
Preloader
mx.preloaders The Preloader class is used by the SystemManager to monitor the download and initialization status of a Flex application.
PrintDataGrid
mx.printing The PrintDataGrid control is a DataGrid subclass that is styled to show a table with line borders and is optimized for printing.
Producer
mx.messaging A Producer sends messages to a destination.
ProgrammaticSkin
mx.skins This class is the base class for skin elements which draw themselves programmatically.
ProgressBar
mx.controls The ProgressBar control provides a visual representation of the progress of a task over time.
ProgressBarDirection
mx.controls The ProgressBarDirection class defines the values for the direction property of the ProgressBar class.
ProgressBarLabelPlacement
mx.controls The ProgressBarLabelPlacement class defines the values for the labelPlacement property of the ProgressBar class.
ProgressBarMode
mx.controls The ProgressBarMode class defines the values for the mode property of the ProgressBar class.
ProgressBarSkin
mx.skins.halo The skin for a ProgressBar.
ProgressIndeterminateSkin
mx.skins.halo The skin for the indeterminate state of a ProgressBar.
ProgressTrackSkin
mx.skins.halo The skin for the track in a ProgressBar.
PropertyChangeEvent
mx.events The PropertyChangeEvent class represents the event object passed to the event listener when one of the properties of an object has changed, and provides information about the change.
PropertyChangeEventKind
mx.events The PropertyChangeEventKind class defines the constant values for the kind property of the PropertyChangeEvent class.
PropertyChanges
mx.effects.effectClasses The PropertyChanges class defines the start and end values for a set of properties of a target component of a transition.
Quadratic
mx.effects.easing The Quadratic class defines three easing functions to implement quadratic motion with Flex effect classes.
Quartic
mx.effects.easing The Quartic class defines three easing functions to implement motion with Flex effect classes.
Quintic
mx.effects.easing The Quintic class defines three easing functions to implement motion with Flex effect classes.
RadialGradient
mx.graphics The RadialGradient class lets you specify a gradual color transition in the fill color.
RadioButton
mx.controls The RadioButton control lets the user make a single choice within a set of mutually exclusive choices.
RadioButtonGroup
mx.controls The RadioButtonGroup control defines a group of RadioButton controls that act as a single mutually exclusive control; therefore, a user can select only one RadioButton control at a time.
RadioButtonIcon
mx.skins.halo The skin for all the states of the icon in a RadioButton.
RectangularBorder
mx.skins The RectangularBorder class is an abstract base class for various classes that draw rectangular borders around UIComponents.
RectangularDropShadow
mx.graphics Drop shadows are typically created using the DropShadowFilter class.
RegExpValidationResult
mx.validators The RegExpValidator class dispatches the valid and invalid events.
RegExpValidator
mx.validators The RegExpValidator class lets you use a regular expression to validate a field.
RemoteObject
mx.rpc.remoting The RemoteObject class gives you access to classes on a remote application server.
RemoteObject
mx.rpc.remoting.mxml The <mx:RemoteObject> tag gives you access to the methods of Java objects using Action Message Format (AMF) encoding.
RemotingMessage
mx.messaging.messages RemotingMessages are used to send RPC requests to a remote endpoint.
RemoveChild
mx.states The RemoveChild class removes a child display object, such as a component, from a container as part of a view state.
RemoveChildAction
mx.effects The RemoveChildAction class defines an action effect that corresponds to the RemoveChild property of a view state definition.
RemoveChildActionInstance
mx.effects.effectClasses The RemoveChildActionInstance class implements the instance class for the RemoveChildAction effect.
RenderData
mx.charts.chartClasses RenderData structures are used by chart elements to store all of the relevant values and data needed to fully render the chart.
Repeater
mx.core The Repeater class is the runtime object that corresponds to the <mx:Repeater> tag.
Resize
mx.effects The Resize effect changes the width, height, or both dimensions of a component over a specified time interval.
ResizeEvent
mx.events Represents event objects that are dispatched when the size of a Flex component changes.
ResizeInstance
mx.effects.effectClasses The ResizeInstance class implements the instance class for the Resize effect.
ResourceBundle
mx.resources This class can be used to internationalize the framework and applications.
ResultEvent
mx.rpc.events The event that indicates an RPC operation has successfully returned a result.
RichTextEditor
mx.controls The RichTextEditor control lets users enter and format text.
Rotate
mx.effects The Rotate effect rotates a component around a specified point.
RotateInstance
mx.effects.effectClasses The RotateInstance class implements the instance class for the Rotate effect.
RoundedRectangle
mx.graphics RoundedRectangle represents a Rectangle with curved corners
RSLEvent
mx.events The RSLEvent class represents an event object used by the DownloadProgressBar class when an RSL is being downloaded by the Preloader class.
RTMPChannel
mx.messaging.channels The RTMPChannel class provides basic RTMP support for messaging.
ScrollArrowSkin
mx.skins.halo The skin for all the states of the up or down button in a ScrollBar.
ScrollBar
mx.controls.scrollClasses The ScrollBar class is the base class for the HScrollBar and VScrollBar controls.
ScrollBarDirection
mx.controls.scrollClasses The ScrollBarDirection class defines the values for the direction property of the ScrollBar control.
ScrollControlBase
mx.core The ScrollControlBase class is the base class for controls with scroll bars.
ScrollEvent
mx.events Represents events that are dispatched by the ScrollBar class.
ScrollEventDetail
mx.events Constants for the values of the detail property of a ScrollEvent.
ScrollEventDirection
mx.events Constants for the values of the direction property of a ScrollEvent.
ScrollPolicy
mx.core Values for the horizontalScrollPolicy and verticalScrollPolicy properties of the Container and ScrollControlBase classes.
ScrollThumb
mx.controls.scrollClasses The ScrollThumb class defines the thumb of a ScrollBar control.
ScrollThumbSkin
mx.skins.halo The skin for all the states of the thumb in a ScrollBar.
ScrollTrackSkin
mx.skins.halo The skin for the track in a ScrollBar.
SecureAMFChannel
mx.messaging.channels The SecureAMFChannel class is identical to the AMFChannel class except that it uses a secure protocol, HTTPS, to send messages to an AMF endpoint.
SecureHTTPChannel
mx.messaging.channels The SecureHTTPChannel class is identical to the HTTPChannel class except that it uses a secure protocol, HTTPS, to send messages to an HTTP endpoint.
SecureRTMPChannel
mx.messaging.channels The SecureRTMPChannel class is identical to the RTMPChannel class except that it uses a secure protocol, RTMPS, to send messages to an RTMPS endpoint.
Sequence
mx.effects The Sequence effect plays multiple child effects one after the other, in the order in which they are added.
SequencedMessage
mx.data.messages Clients receive this message in response to DataService.fill() request.
SequenceInstance
mx.effects.effectClasses The SequenceInstance class implements the instance class for the Sequence effect.
Series
mx.charts.chartClasses The Series class is the base class for the classes that let you specify a data series for a chart control.
SeriesEffect
mx.charts.effects The base class for chart effects.
SeriesEffectInstance
mx.charts.effects.effectClasses The SeriesEffectInstance class implements the base instance class for the chart series effects.
SeriesInterpolate
mx.charts.effects The SeriesInterpolate effect moves the graphics that represent the existing data in a series to the new points.
SeriesInterpolateInstance
mx.charts.effects.effectClasses The SeriesInterpolateInstance class implements the instance class for the SeriesInterpolate effect.
SeriesSlide
mx.charts.effects The SeriesSlide effect slides a data series into and out of the chart's boundaries.
SeriesSlideInstance
mx.charts.effects.effectClasses The SeriesSlideInstance class implements the instance class for the SeriesSlide effect.
SeriesZoom
mx.charts.effects The SeriesZoom effect implodes and explodes chart data into and out of the focal point that you specify.
SeriesZoomInstance
mx.charts.effects.effectClasses The SeriesZoomInstance class implements the instance class for the SeriesZoom effect.
ServerConfig
mx.messaging.config This class provides access to the server messaging configuration information.
SetEventHandler
mx.states The SetEventHandler class specifies an event handler that is active only during a particular view state.
SetProperty
mx.states The SetProperty class specifies a property value that is in effect only during the parent view state.
SetPropertyAction
mx.effects The SetPropertyAction class defines an action effect that corresponds to the SetProperty property of a view state definition.
SetPropertyActionInstance
mx.effects.effectClasses The SetPropertyActionInstance class implements the instance class for the SetPropertyAction effect.
SetStyle
mx.states The SetStyle class specifies a style that is in effect only during the parent view state.
SetStyleAction
mx.effects The SetStyleAction class defines an action effect that corresponds to the SetStyle property of a view state definition.
SetStyleActionInstance
mx.effects.effectClasses The SetStyleActionInstance class implements the instance class for the SetStyleAction effect.
ShadowBoxItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills a rectangular area and surrounds it with a drop shadow.
ShadowLineRenderer
mx.charts.renderers An implementation of a line segment renderer that is used by LineSeries objects.
SimpleXMLDecoder
mx.rpc.xml The SimpleXMLDecoder class deserialize XML into a graph of ActionScript objects.
SimpleXMLEncoder
mx.rpc.xml The SimpleXMLEncoder class take ActionScript Objects and encodes them to XML.
Sine
mx.effects.easing The Sine class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by a sine wave.
Slider
mx.controls.sliderClasses The Slider class is the base class for the Flex slider controls.
SliderDataTip
mx.controls.sliderClasses The SliderDataTip class defines the tooltip used in the mx.controls.Slider control.
SliderDirection
mx.controls.sliderClasses The SliderDirection class defines the constant values for the direction property of the Slider class.
SliderEvent
mx.events The SliderEvent class represents the event object passed to the event listener for the change, thumbDrag, thumbPress, and thumbRelease events of the HSlider and VSlider classes.
SliderEventClickTarget
mx.events The SliderEventClickTarget class defines the constants for the values of the clickTarget property of the SliderEvent class.
SliderHighlightSkin
mx.skins.halo The skin for the highlighted state of the track of a Slider.
SliderLabel
mx.controls.sliderClasses The SliderLabel class defines the label used in the mx.controls.Slider component.
SliderThumb
mx.controls.sliderClasses The SliderThumb class represents a thumb of a Slider control.
SliderThumbSkin
mx.skins.halo The skin for all the states of a thumb in a Slider.
SliderTrackSkin
mx.skins.halo The skin for the track in a Slider.
SOAPHeader
mx.rpc.soap You use a SOAPHeader to specify the headers that need to be added to a SOAP envelope of a WebService Operation request.
SOAPMessage
mx.messaging.messages SOAPMessages are similar to HTTPRequestMessages.
SocialSecurityValidator
mx.validators The SocialSecurityValidator class validates that a String is a valid United States Social Security number.
SolidColor
mx.graphics Defines a representation for a color, including a color and an alpha value.
Sort
mx.collections Provides the sorting information required to establish a sort on an existing view (ICollectionView interface or class that implements the interface).
SortError
mx.collections.errors This error is thrown when a Sort class is not configured properly; for example, if the find criteria are invalid.
SortField
mx.collections Provides the sorting information required to establish a sort on a field or property in an existing view.
SoundAsset
mx.core SoundAsset is a subclass of the Flash Player's Sound class which represents sounds that you embed in a Flex application.
SoundEffect
mx.effects The SoundEffect class plays an MP3 audio file.
SoundEffectInstance
mx.effects.effectClasses The SoundEffectInstance class implements the instance class for the SoundEffect effect.
Spacer
mx.controls The Spacer control helps you lay out children within a parent container.
SpriteAsset
mx.core SpriteAsset is a subclass of the Flash Player's Sprite class which represents vector graphic images that you embed in a Flex application.
StackedSeries
mx.charts.chartClasses Stacked Series serves as the common base class for all of the stacking set series (BarSet, ColumnSet, and AreaSet).
State
mx.states The State class defines a view state, a particular view of a component.
StateChangeEvent
mx.events The StateChangeEvent class represents an event that is dispatched when the currentState property of a component changes.
StringUtil
mx.utils The StringUtil utility class is an all-static class with methods for working with String objects within Flex.
StringValidator
mx.validators The StringValidator class validates that the length of a String is within a specified range.
Stroke
mx.graphics The Stroke class defines the properties for a line.
StyleManager
mx.styles The StyleManager class manages the following:
  • Which CSS style properties the class inherits
  • Which style properties are colors, and therefore get special handling
  • A list of strings that are aliases for color values
SwatchPanelSkin
mx.skins.halo The skin for the border of a SwatchPanel.
SwatchSkin
mx.skins.halo The skin used for all color swatches in a ColorPicker.
SWFLoader
mx.controls The SWFLoader control loads and displays a specified SWF file.
SwitchSymbolFormatter
mx.formatters The SwitchSymbolFormatter class is a utility class that you can use when creating custom formatters.
SystemManager
mx.managers The SystemManager class manages an application window.
TabBar
mx.controls The TabBar control lets you create a horizontal or vertical group of tab navigation items by defining the labels and data associated with each tab.
TabNavigator
mx.containers The TabNavigator container extends the ViewStack container by including a TabBar container for navigating between its child containers.
TabSkin
mx.skins.halo The skin for all the states of a Tab in a TabNavigator or TabBar.
Text
mx.controls The Text control displays multiline, noneditable text.
TextArea
mx.controls The TextArea control is a multiline text field with a border and optional scroll bars.
TextFieldAsset
mx.core TextFieldAsset is a subclass of the Flash Player's TextField class which represents TextField symbols that you embed in a Flex application from a SWF file produced by Flash.
TextInput
mx.controls The TextInput control is a single-line text field that is optionally editable.
TextRange
mx.controls.textClasses The TextRange class provides properties that select and format a range of text in the Label, Text, TextArea, TextEditor, and RichTextEditor controls.
Tile
mx.containers A Tile container lays out its children in a grid of equal-sized cells.
TileBase
mx.controls.listClasses The TileBase class is the base class for controls that display data items in a sequence of rows and columns.
TileBaseDirection
mx.controls.listClasses Values for the direction property of the TileList component.
TileDirection
mx.containers The TileDirection class defines the constant values for the direction property of the Tile container.
TileList
mx.controls The TileList control displays a number of items laid out in tiles.
TileListItemRenderer
mx.controls.listClasses The TileListItemRenderer class defines the default item renderer for the HorizontalList and TileList controls.
TitleBackground
mx.skins.halo The skin for a title bar area of a Panel.
TitleWindow
mx.containers A TitleWindow navigator container contains a title bar, a caption, a border, and a content area for its child.
ToggleButtonBar
mx.controls The ToggleButtonBar control defines a horizontal or vertical group of buttons that maintain their selected or deselected state.
ToolTip
mx.controls The ToolTip control lets you provide helpful information to your users.
ToolTipBorder
mx.skins.halo The skin for a ToolTip.
ToolTipEvent
mx.events The ToolTipEvent class represents ToolTip events, which are generated by the ToolTipManager class.
ToolTipManager
mx.managers The ToolTipManager lets you set basic ToolTip and error tip functionality, such as display delay and the disabling of ToolTips.
TraceTarget
mx.logging.targets Provides a logger target that uses the global trace() method to output log messages.
Transition
mx.states The Transition class defines a set of effects that play in response to a change of view state.
Tree
mx.controls The Tree control lets a user view hierarchical data arranged as an expandable tree.
TreeEvent
mx.events The TreeEvent class represents the event object passed to the event listener for events that are associated with activities in tree, such as when a tree branch opens or closes.
TreeItemRenderer
mx.controls.treeClasses The TreeItemRenderer class defines the default item renderer for a Tree control.
TreeListData
mx.controls.treeClasses The TreeListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the Tree control.
TriangleItemRenderer
mx.charts.renderers A simple chart itemRenderer implementation that fills an upright triangle in its assigned area.
Tween
mx.effects The Tween class defines a tween, a property animation performed on a target object over a period of time.
TweenEffect
mx.effects The TweenEffect class is the superclass for all effects that are based on the Tween object.
TweenEffectInstance
mx.effects.effectClasses The TweenEffectInstance class implements the instance class for the TweenEffect.
TweenEvent
mx.events Represents event objects that are specific to Flex tween effects.
UIComponent
mx.core The UIComponent class is the base class for all visual components, both interactive and noninteractive.
UIComponentCachePolicy
mx.core The ContainerCreationPolicy class defines the constant values for the cachePolicy property of the UIComponent class.
UIComponentDescriptor
mx.core A UIComponentDescriptor instance encapsulates the information that you specified in an MXML tag for an instance of a visual component.
UIDUtil
mx.utils The UIDUtil class is an all-static class with methods for working with UIDs (unique identifiers) within Flex.
UITextField
mx.core The UITextField class defines the component used by many Flex components to display text.
UITextFormat
mx.core The UITextFormat class represents character formatting information for the UITextField class.
UnresolvedConflictsError
mx.data.errors This error is thrown when a commit request is made while there are still unresolved conflicts and no listener has been registered for UnresolvedConflictsEvent.FAULT.
UnresolvedConflictsEvent
mx.data.events A DataList throws this event when the commit() method is called while conflicts remain unresolved.
UpdateCollectionMessage
mx.data.messages This message is used to establish consistency between the remote sequence and the corresponding local collection.
UpdateCollectionRange
mx.data The UpdateCollectionRange class provides specific information about a range of add and remove operations made to a collection.
URLUtil
mx.utils The URLUtil class is a static class with methods for working with full and relative URLs within Flex.
ValidationResult
mx.validators The ValidationResult class contains the results of a validation.
ValidationResultEvent
mx.events The ValidationResultEvent class represents the event object passed to the listener for the valid validator event or the invalid validator event.
Validator
mx.validators The Validator class is the base class for all Flex validators.
VBox
mx.containers The VBox container lays out its children in a single vertical column.
VDividedBox
mx.containers The VDividedBox container lays out its children vertically in the same way as the VBox container, but it inserts a draggable divider in the gap between each child.
VideoDisplay
mx.controls The VideoDisplay control lets you play an FLV file in a Flex application.
VideoError
mx.controls.videoClasses The VideoError class represents the error codes for errors thrown by the VideoDisplay control.
VideoEvent
mx.events The VideoEvent class represents the event object passed to the event listener for events dispatched by the VideoDisplay control, and defines the values of the VideoDisplay.state property.
ViewStack
mx.containers A ViewStack navigator container consists of a collection of child containers stacked on top of each other, where only one child at a time is visible.
VRule
mx.controls The VRule control creates a single vertical line.
VScrollBar
mx.controls The VScrollBar (vertical ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
VSlider
mx.controls The VSlider control lets users select a value by moving a slider thumb between the end points of the slider track.
WebService
mx.rpc.soap.mxml The <mx:WebService> tag gives you access to the operations of SOAP-compliant web services.
WebService
mx.rpc.soap The WebService class provides access to SOAP-based web services on remote servers.
WedgeItemRenderer
mx.charts.renderers The default itemRenderer for a PieSeries object.
WipeDown
mx.effects The WipeDown class defines a bar wipe down effect.
WipeDownInstance
mx.effects.effectClasses The WipeDownInstance class implements the instance class for the WipeDown effect.
WipeLeft
mx.effects The WipeLeft class defines a bar wipe left effect.
WipeLeftInstance
mx.effects.effectClasses The WipeLeftInstance class implements the instance class for the WipeLeft effect.
WipeRight
mx.effects The WipeRight class defines a bar wipe right effect.
WipeRightInstance
mx.effects.effectClasses The WipeRightInstance class implements the instance class for the WipeRight effect.
WipeUp
mx.effects The WipeUp class defines a bar wipe up effect.
WipeUpInstance
mx.effects.effectClasses The WipeUpInstance class implements the instance class for the WipeUp effect.
XMLListCollection
mx.collections The XMLListCollection class provides collection functionality to an XMLList object and makes available some of the methods of the native XMLList class.
XMLUtil
mx.utils The XMLUtil class is an all-static class with methods for working with XML within Flex.
ZipCodeFormatter
mx.formatters The ZipCodeFormatter class formats a valid number into one of the following formats, based on a user-supplied formatString property.
ZipCodeValidator
mx.validators The ZipCodeValidator class validates that a String has the correct length and format for a five-digit ZIP code, a five-digit+four-digit United States ZIP code, or Canadian postal code.
ZipCodeValidatorDomainType
mx.validators The ZipCodeValidatorDomainType class defines the values for the domain property of the ZipCodeValidator class, which you use to specify the type of ZIP code to validate.
Zoom
mx.effects The Zoom effect zooms the object in or out on a center point.
ZoomInstance
mx.effects.effectClasses The ZoomInstance class implements the instance class for the Zoom effect.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Mon Jun 19 2006, 11:01 AM GMT-07:00


All Flash Player Classes (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
All Flash Player Classes

Documentation for ActionScript classes includes syntax, usage information, and code samples for methods, properties, and event handlers and listeners that belong to a specific class in ActionScript (as opposed to global functions or properties). The classes are listed alphabetically. If you are not sure to which class a certain member belongs, you can look it up in the Index.

Class | Package | Description
Accessibility | flash.accessibility | The Accessibility class manages communication with screen readers.
AccessibilityProperties | flash.accessibility | The AccessibilityProperties class lets you control the presentation of Flash objects to accessibility aids, such as screen readers.
ActionScriptVersion | flash.display | The ActionScriptVersion class is an enumeration of constant values that indicate the language version of a loaded SWF file.
ActivityEvent | flash.events | Flash® Player dispatches an ActivityEvent object whenever a camera or microphone reports that it has become active or inactive.
AntiAliasType | flash.text | The AntiAliasType class provides values for anti-aliasing in the flash.text.TextField class.
ApplicationDomain | flash.system | The ApplicationDomain class is a container for discrete groups of class definitions.
ArgumentError | Top Level | The ArgumentError class represents an error that occurs when the arguments supplied in a function do not match the arguments defined for that function.
arguments | Top Level | An arguments object is used to store and access a function's arguments.
Array | Top Level | The Array class lets you access and manipulate arrays.
AsyncErrorEvent | flash.events | Flash® Player dispatches an AsyncErrorEvent when an exception is thrown from native asynchronous code, which could be from, for example, LocalConnection, NetConnection, SharedObject, or NetStream.
AVM1Movie | flash.display | AVM1Movie is a simple class that represents AVM1 movie clips, which use ActionScript 1.0 or 2.0.
BevelFilter | flash.filters | The BevelFilter class lets you add a bevel effect to display objects.
Bitmap | flash.display | The Bitmap class represents display objects that represent bitmap images.
BitmapData | flash.display | The BitmapData class lets you work with the data (pixels) of a Bitmap object.
BitmapDataChannel | flash.display | The BitmapDataChannel class is an enumeration of constant values that indicate which channel to use: red, blue, green, or alpha transparency.
BitmapFilter | flash.filters | The BitmapFilter class is the base class for all image filter effects.
BitmapFilterQuality | flash.filters | The BitmapFilterQuality class contains values to set the rendering quality of a BitmapFilter object.
BitmapFilterType | flash.filters | The BitmapFilterType class contains values to set the type of a BitmapFilter.
BlendMode | flash.display | A class that provides constant values for visual blend mode effects.
BlurFilter | flash.filters | The BlurFilter class lets you apply a blur visual effect to display objects.
Boolean | Top Level | A Boolean object is a data type that can have one of two values, either true or false, used for logical operations.
ByteArray | flash.utils | The ByteArray class provides methods and properties to optimize reading, writing, and working with binary data.
Camera | flash.media | The Camera class is primarily for use with Flash Media Server, but can be used in a limited way without the server.
Capabilities | flash.system | The Capabilities class provides properties that describe the system and player that are hosting a SWF file.
CapsStyle | flash.display | The CapsStyle class is an enumeration of constant values that specify the caps style to use in drawing lines.
Class | Top Level | A Class object is created for each class definition in a program.
ColorMatrixFilter | flash.filters | The ColorMatrixFilter class lets you apply a 4 x 5 matrix transformation on the RGBA color and alpha values of every pixel in the input image to produce a result with a new set of RGBA color and alpha values.
ColorTransform | flash.geom | The ColorTransform class lets you adjust the color values in a display object.
ContextMenu | flash.ui | The ContextMenu class provides control over the items in the Flash Player context menu.
ContextMenuBuiltInItems | flash.ui | The ContextMenuBuiltInItems class describes the items that are built in to a context menu.
ContextMenuEvent | flash.events | Flash® Player dispatches ContextMenuEvent objects when a user generates or interacts with the context menu.
ContextMenuItem | flash.ui | Use the ContextMenuItem class to create custom menu items to display in the Flash Player context menu.
ConvolutionFilter | flash.filters | The ConvolutionFilter class applies a matrix convolution filter effect.
CSMSettings | flash.text | The CSMSettings class contains properties for use with the TextRenderer.setAdvancedAntiAliasingTable() method to provide continuous stroke modulation (CSM).
DataEvent | flash.events | Flash® Player dispatches DataEvent objects when raw data has completed loading into Flash Player.
Date | Top Level | The Date class represents date and time information.
DefinitionError | Top Level | The DefinitionError class represents an error that occurs when user code attempts to define an identifier that is already defined.
Dictionary | flash.utils | The Dictionary class lets you create a dynamic collection of properties, which uses strict equality (===) for key comparison.
DisplacementMapFilter | flash.filters | The DisplacementMapFilter class uses the pixel values from the specified BitmapData object (called the displacement map image) to perform a displacement of an object.
DisplacementMapFilterMode | flash.filters | The DisplacementMapFilterMode class provides values for the mode property of the DisplacementMapFilter class.
DisplayObject | flash.display | The DisplayObject class is the base class for all objects that can be placed on the display list.
DisplayObjectContainer | flash.display | The DisplayObjectContainer class is the base class for all objects that can serve as display object containers on the display list.
DropShadowFilter | flash.filters | The DropShadowFilter class lets you add a drop shadow to display objects.
Endian | flash.utils | The Endian class contains values that denote the byte order used to represent multibyte numbers.
EOFError | flash.errors | An EOFError exception is thrown when you attempt to read past the end of the available data.
Error | Top Level | The Error class contains information about an error that occurred in a script.
ErrorEvent | flash.events | Flash® Player dispatches ErrorEvent objects when an error causes a network operation to fail.
EvalError | Top Level | The EvalError class represents an error that occurs when user code calls the eval() function or attempts to use the new operator with the Function object.
Event | flash.events | The Event class is used as the base class for the creation of Event objects, which are passed as parameters to event listeners when an event occurs.
EventDispatcher | flash.events | The EventDispatcher class implements the IEventDispatcher interface and is the base class for the DisplayObject class.
EventPhase | flash.events | The EventPhase class provides values for the eventPhase property of the Event class.
ExternalInterface | flash.external | The ExternalInterface class is the External API, an application programming interface that enables straightforward communication between ActionScript and the Flash Player container; for example, an HTML page with JavaScript, or a desktop application with Flash Player embedded.
FileFilter | flash.net | The FileFilter class is used to indicate what files on the user's system are shown in the file-browsing dialog box that is displayed when FileReference.browse() or FileReferenceList.browse() is called.
FileReference | flash.net | The FileReference class provides a means to upload and download files between a user's computer and a server.
FileReferenceList | flash.net | The FileReferenceList class provides a means to let users select one or more files for uploading.
FocusEvent | flash.events | Flash® Player dispatches FocusEvent objects when the user changes the focus from one object in the display list to another.
Font | flash.text | The Font class is used to manage embedded fonts in SWF files.
FontStyle | flash.text | The FontStyle class provides values for the TextRenderer class.
FontType | flash.text | The FontType class contains the enumerated constants "embedded" and "device" for the fontType property of the Font class.
FrameLabel | flash.display | The FrameLabel object contains properties that specify a frame number and the corresponding label name.
Function | Top Level | A function is the basic unit of code that can be invoked in ActionScript.
GlowFilter | flash.filters | The GlowFilter class lets you apply a glow effect to display objects.
GradientBevelFilter | flash.filters | The GradientBevelFilter class lets you apply a gradient bevel effect to display objects.
GradientGlowFilter | flash.filters | The GradientGlowFilter class lets you apply a gradient glow effect to display objects.
GradientType | flash.display | The GradientType class provides values for the type parameter in the beginGradientFill() and lineGradientFill() methods of the flash.display.Graphics class.
Graphics | flash.display | The Graphics class contains a set of methods that you can use to create a vector shape.
GridFitType | flash.text | The GridFitType class defines values for grid fitting in the TextField class.
HTTPStatusEvent | flash.events | Flash® Player dispatches HTTPStatusEvent objects when a network request returns an HTTP status code.
IBitmapDrawable | flash.display | The IBitmapDrawable interface is implemented by objects that can be passed as the source parameter of the draw() method of the BitmapData class.
ID3Info | flash.media | The ID3Info class contains properties that reflect ID3 metadata.
IDataInput | flash.utils | The IDataInput interface provides a set of methods for reading binary data.
IDataOutput | flash.utils | The IDataOutput interface provides a set of methods for writing binary data.
IDynamicPropertyOutput | flash.net | This interface controls the serialization of dynamic properties of dynamic objects.
IDynamicPropertyWriter | flash.net | This interface is used with the IDynamicPropertyOutput interface to control the serialization of dynamic properties of dynamic objects.
IEventDispatcher | flash.events | The IEventDispatcher interface defines methods for adding or removing event listeners, checks whether specific types of event listeners are registered, and dispatches events.
IExternalizable | flash.utils | The IExternalizable interface provides control over serialization of a class as it is encoded into a data stream.
IllegalOperationError | flash.errors | The IllegalOperationError exception is thrown when a method is not implemented or the implementation doesn't cover the current usage.
IME | flash.system | The IME class lets you directly manipulate the operating system's input method editor (IME) in the Flash Player application that is running on a client computer.
IMEConversionMode | flash.system | This class contains constants for use with the IME.conversionMode property.
IMEEvent | flash.events | Flash® Player dispatches IMEEvent objects when a user enters text using an input method editor (IME).
int | Top Level | The int class lets you work with the data type representing a 32-bit signed integer.
InteractiveObject | flash.display | The InteractiveObject class is the abstract base class for all display objects with which you can interact: mouse, keyboard, and focus.
InterpolationMethod | flash.display | The InterpolationMethod class provides values for the interpolationMethod parameter in the Graphics.beginGradientFill() and Graphics.lineGradientStyle() methods.
InvalidSWFError | flash.errors |
IOError | flash.errors | The IOError exception is thrown when some type of input or output failure occurs.
IOErrorEvent | flash.events | Flash® Player dispatches an IOErrorEvent object when an error causes a send or load operation to fail.
JointStyle | flash.display | The JointStyle class is an enumeration of constant values that specify the joint style to use in drawing lines.
Keyboard | flash.ui | The Keyboard class is used to build an interface that can be controlled by a user with a standard keyboard.
KeyboardEvent | flash.events | Flash® Player dispatches KeyboardEvent objects in response to user input through a keyboard.
KeyLocation | flash.ui | The KeyLocation class contains constants that indicate the location of a key pressed on the keyboard.
LineScaleMode | flash.display | The LineScaleMode class provides values for the scaleMode parameter in the Graphics.lineStyle() method.
Loader | flash.display | The Loader class is used to load SWF files or image (JPG, PNG, or GIF) files.
LoaderContext | flash.system | The LoaderContext class provides options for loading SWF files and other media by using the Loader class.
LoaderInfo | flash.display | The LoaderInfo class provides information about a loaded SWF file or a loaded image file (JPEG, GIF, or PNG).
LocalConnection | flash.net | The LocalConnection class lets you create a LocalConnection object that can invoke a method in another LocalConnection object, either within a single SWF file or between multiple SWF files.
Math | Top Level | The Math class contains methods and constants that represent common mathematical functions and values.
Matrix | flash.geom | The Matrix class represents a transformation matrix that determines how to map points from one coordinate space to another.
MemoryError | flash.errors | The MemoryError exception is thrown when a memory allocation request fails.
Microphone | flash.media | The Microphone class lets you capture audio from a microphone attached to the computer that is running Flash Player.
MorphShape | flash.display | The MorphShape class represents MorphShape objects on the display list.
Mouse | flash.ui | The methods of the Mouse class are used to hide and show the mouse pointer.
MouseEvent | flash.events | Flash® Player dispatches MouseEvent objects into the event flow whenever mouse events occur.
MovieClip | flash.display | The MovieClip class inherits from the following classes: Sprite, DisplayObjectContainer, InteractiveObject, DisplayObject, and EventDispatcher.
Namespace | Top Level | The Namespace class contains methods and properties for defining and working with namespaces.
NetConnection | flash.net | The NetConnection class lets you invoke commands on a remote application server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, and to play streaming Flash Video (FLV) files from either an HTTP address or a local drive.
NetStatusEvent | flash.events | Flash® Player dispatches NetStatusEvent objects when a NetConnection, NetStream, or SharedObject object reports its status.
NetStream | flash.net | The NetStream class opens a one-way streaming connection between Flash Player and a server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, or between Flash Player and the local file system through a connection made available by a NetConnection object.
Number | Top Level | A data type representing an IEEE-754 double-precision floating-point number.
Object | Top Level | The Object class is at the root of the ActionScript class hierarchy.
ObjectEncoding | flash.net | The ObjectEncoding class allows classes that serialize objects (such as NetStream, NetConnection, SharedObject, and ByteArray) to work with prior versions of ActionScript.
PixelSnapping | flash.display | The PixelSnapping class is an enumeration of constant values for setting the pixel snapping options by using the pixelSnapping property of a Bitmap object.
Point | flash.geom | The Point object represents a location in a two-dimensional coordinate system, where x represents the horizontal axis and y represents the vertical axis.
PrintJob | flash.printing | The PrintJob class lets you create content and print it to one or more pages.
PrintJobOptions | flash.printing | The PrintJobOptions class contains properties to use with the options parameter of the PrintJob.addPage() method.
PrintJobOrientation | flash.printing | This class provides values that are used by the PrintJob.orientation property for the image position of a printed page.
ProgressEvent | flash.events | Flash® Player dispatches ProgressEvent objects when a load operation has begun or a socket has received data.
Proxy | flash.utils | The Proxy class lets you override the default behavior of ActionScript operations (such as retrieving and modifying properties) on an object.
QName | Top Level | QName objects represent qualified names of XML elements and attributes.
RangeError | Top Level | A RangeError exception is thrown when a numeric value is outside the acceptable range.
Rectangle | flash.geom | A Rectangle object is an area defined by its position, as indicated by its top-left corner point (x, y) and by its width and its height.
ReferenceError | Top Level | A ReferenceError exception is thrown when a reference to an undefined property is attempted on a sealed (nondynamic) object.
RegExp | Top Level | The RegExp class lets you work with regular expressions, which are patterns that you can use to perform searches in strings and to replace text in strings.
Responder | flash.net | The Responder class provides an object that is used in NetConnection.call() to handle return values from the server.
Scene | flash.display | The Scene class includes properties for identifying the name, labels, and number of frames in a scene.
ScriptTimeoutError | flash.errors | The ScriptTimeoutError exception is thrown when the script timeout interval is reached.
Security | flash.system | The Security class lets you specify how SWF files in different domains can communicate with each other.
SecurityDomain | flash.system | The SecurityDomain class represents the current security "sandbox," also known as a security domain.
SecurityError | Top Level | The SecurityError exception is thrown when some type of security violation takes place.
SecurityErrorEvent | flash.events | Flash® Player dispatches SecurityErrorEvent objects to report the occurrence of a security error.
SecurityPanel | flash.system | The SecurityPanel class provides values for specifying which Security Settings panel you want to display.
Shape | flash.display | The Shape class is used to create lightweight shapes by using the ActionScript drawing application program interface (API).
SharedObject | flash.net | The SharedObject class is used to read and store limited amounts of data on a user's computer or on a server.
SharedObjectFlushStatus | flash.net | The SharedObjectFlushStatus class provides values for the code returned from a call to the SharedObject.flush() method.
SimpleButton | flash.display | The SimpleButton class lets you control all instances of button symbols in a SWF file.
Socket | flash.net | The Socket class enables ActionScript code to make socket connections and to read and write raw binary data.
Sound | flash.media | The Sound class lets you work with sound in an application.
SoundChannel | flash.media | The SoundChannel class controls a sound in an application.
SoundLoaderContext | flash.media | The SoundLoaderContext class provides security checks for SWF files that load sound.
SoundMixer | flash.media | The SoundMixer class contains static properties and methods for global sound control in the SWF file.
SoundTransform | flash.media | The SoundTransform class contains properties for volume and panning.
SpreadMethod | flash.display | The SpreadMethod class provides values for the spreadMethod parameter in the beginGradientFill() and lineGradientStyle() methods of the Graphics class.
Sprite | flash.display | The Sprite class is a basic display list building block: a display list node that can display graphics and can also contain children.
StackOverflowError | flash.errors | ActionScript throws a StackOverflowError exception when the stack available to the script is exhausted.
Stage | flash.display | The Stage class represents the main drawing area.
StageAlign | flash.display | The StageAlign class provides constant values to use for the Stage.align property.
StageQuality | flash.display | The StageQuality class provides values for the Stage.quality property.
StageScaleMode | flash.display | The StageScaleMode class provides values for the Stage.scaleMode property.
StaticText | flash.text | This class represents StaticText objects on the display list.
StatusEvent | flash.events | Flash® Player dispatches StatusEvent objects when a device, such as a camera or microphone, or an object such as a LocalConnection object reports its status.
String | Top Level | The String class is a data type that represents a string of characters.
StyleSheet | flash.text | The StyleSheet class lets you create a StyleSheet object that contains text formatting rules for font size, color, and other styles.
SWFVersion | flash.display | The SWFVersion class is an enumeration of constant values that indicate the file format version of a loaded SWF file.
SyncEvent | flash.events | Flash® Player dispatches SyncEvent objects when a remote SharedObject instance has been updated by the server.
SyntaxError | Top Level | A SyntaxError exception is thrown when a parsing error occurs.
System | flash.system | The System class contains properties related to certain operations that take place on the user's computer, such as operations with shared objects, local settings for cameras and microphones, and use of the Clipboard.
TextColorType | flash.text | The TextColorType class provides color values for the flash.text.TextRenderer class.
TextDisplayMode | flash.text | The TextDisplayMode class contains values that control the subpixel anti-aliasing of the FlashType system.
TextEvent | flash.events | Flash® Player dispatches TextEvent objects when a user enters text in a text field or clicks a hyperlink in an HTML-enabled text field.
TextField | flash.text | The TextField class is used to create display objects for text display and input.
TextFieldAutoSize | flash.text | The TextFieldAutoSize class is an enumeration of constant values used in setting the autoSize property of the TextField class.
TextFieldType | flash.text | The TextFieldType class is an enumeration of constant values used in setting the type property of the TextField class.
TextFormat | flash.text | The TextFormat class represents character formatting information.
TextFormatAlign | flash.text | The TextFormatAlign class provides values for text alignment in the TextFormat class.
TextLineMetrics | flash.text | The TextLineMetrics class contains information about the text position and measurements of a line of text within a text field.
TextRenderer | flash.text | The TextRenderer class provides functionality for the advanced anti-aliasing capability of embedded fonts.
TextSnapshot | flash.text | TextSnapshot objects let you work with static text in a movie clip.
Timer | flash.utils | The Timer class is the interface to Flash Player timers.
TimerEvent | flash.events | Flash® Player dispatches TimerEvent objects whenever a Timer object reaches the interval specified by the Timer.delay property.
Transform | flash.geom | The Transform class collects data about color transformations and coordinate transformations that are applied to a display object.
TypeError | Top Level | A TypeError exception is thrown when the actual type of an operand is different from the expected type.
uint | Top Level | The uint class provides methods for working with a data type representing a 32-bit unsigned integer.
URIError | Top Level | A URIError exception is thrown when one of the global URI handling functions is used in a way that is incompatible with its definition.
URLLoader | flash.net | The URLLoader class downloads data from a URL as text, binary data, or URL-encoded variables.
URLLoaderDataFormat | flash.net | The URLLoaderDataFormat class provides values that specify how downloaded data is received.
URLRequest | flash.net | The URLRequest class captures all of the information in a single HTTP request.
URLRequestHeader | flash.net | A URLRequestHeader object encapsulates a single HTTP request header and consists of a name/value pair.
URLRequestMethod | flash.net | The URLRequestMethod class provides values that specify whether the URLRequest object should use the POST method or the GET method when sending data to a server.
URLStream | flash.net | The URLStream class provides low-level access to downloading URLs.
URLVariables | flash.net | The URLVariables class allows you to transfer variables between a Flash® application and a server.
VerifyError | Top Level | The VerifyError class represents an error that occurs when a malformed or corrupted SWF file is encountered.
Video | flash.media | The Video class enables you to display live streaming video in an application without embedding it in your SWF file.
XML | Top Level | The XML class contains methods and properties for working with XML objects.
XMLDocument | flash.xml | The XMLDocument class represents the legacy XML object that was present in ActionScript 2.0.
XMLList | Top Level | An XMLList object is an ordered collection of properties.
XMLNode | flash.xml | The XMLNode class represents the legacy XML object that was present in ActionScript 2.0 and that was renamed in ActionScript 3.0.
XMLNodeType | flash.xml | The XMLNodeType class contains constants used with XMLNode.nodeType.
XMLSocket | flash.net | The XMLSocket class implements client sockets that let the computer that is running Flash Player communicate with a server computer identified by an IP address or domain name.
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Mon Jun 19 2006, 11:01 AM GMT-07:00


Language Elements (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Index | Appendixes | Conventions Adobe Logo
Language Elements

This section provides syntax, usage information, and code samples for global functions and properties (those elements that do not belong to an ActionScript class); and for the constants, operators, statements, and keywords used in ActionScript and defined in the ECMAScript (ECMA-262) edition 4 draft language specification.

Language Element | Description
Global Constants | Top level or global constants are available in every script, and are visible to every Timeline and scope in your document.
Global Functions | Top level or global functions are available in any part of a SWF file where ActionScript is used, or in any user-defined class.
Operators | Symbolic operators are characters that specify how to combine, compare, or modify the values of an expression.
Statements, Keywords & Directives | Statements are language elements that perform or specify an action at runtime.
Special Types | The three special types are the untyped specifier (*), void, and Null.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Operators (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Operators

Symbolic operators are characters that specify how to combine, compare, or modify the values of an expression.

Arithmetic
+ | addition | Adds numeric expressions.
-- | decrement | Subtracts 1 from the operand.
/ | division | Divides expression1 by expression2.
++ | increment | Adds 1 to an expression.
% | modulo | Calculates the remainder of expression1 divided by expression2.
* | multiplication | Multiplies two numerical expressions.
- | subtraction | Used for negating or subtracting.
Arithmetic compound assignment
+= | addition assignment | Assigns expression1 the value of expression1 + expression2.
/= | division assignment | Assigns expression1 the value of expression1 / expression2.
%= | modulo assignment | Assigns expression1 the value of expression1 % expression2.
*= | multiplication assignment | Assigns expression1 the value of expression1 * expression2.
-= | subtraction assignment | Assigns expression1 the value of expression1 - expression2.
Assignment
= | assignment | Assigns the value of expression2 (the operand on the right) to the variable, array element, or property in expression1.
Bitwise
& | bitwise AND | Converts expression1 and expression2 to 32-bit unsigned integers, and performs a Boolean AND operation on each bit of the integer parameters.
<< | bitwise left shift | Converts expression1 and shiftCount to 32-bit integers, and shifts all the bits in expression1 to the left by the number of places specified by the integer resulting from the conversion of shiftCount.
~ | bitwise NOT | Converts expression to a 32-bit signed integer, and then applies a bitwise one's complement.
| | bitwise OR | Converts expression1 and expression2 to 32-bit unsigned integers, and places a 1 in each bit position where the corresponding bits of either expression1 or expression2 are 1.
>> | bitwise right shift | Converts expression and shiftCount to 32-bit integers, and shifts all the bits in expression to the right by the number of places specified by the integer that results from the conversion of shiftCount.
>>> | bitwise unsigned right shift | The same as the bitwise right shift (>>) operator except that it does not preserve the sign of the original expression because the bits on the left are always filled with 0.
^ | bitwise XOR | Converts expression1 and expression2 to 32-bit unsigned integers, and places a 1 in each bit position where the corresponding bits in expression1 or expression2, but not both, are 1.
Bitwise compound assignment
&= | bitwise AND assignment | Assigns expression1 the value of expression1 & expression2.
<<= | bitwise left shift and assignment | Performs a bitwise left shift (<<=) operation and stores the contents as a result in expression1.
|= | bitwise OR assignment | Assigns expression1 the value of expression1 | expression2.
>>= | bitwise right shift and assignment | Performs a bitwise right-shift operation and stores the result in expression.
>>>= | bitwise unsigned right shift and assignment | Performs an unsigned bitwise right-shift operation and stores the result in expression.
^= | bitwise XOR assignment | Assigns expression1 the value of expression1 ^ expression2.
Comment
/*..*/ | block comment delimiter | Delimits one or more lines of script comments.
// | line comment delimiter | Indicates the beginning of a script comment.
Comparison
== | equality | Tests two expressions for equality.
> | greater than | Compares two expressions and determines whether expression1 is greater than expression2; if it is, the result is true.
>= | greater than or equal to | Compares two expressions and determines whether expression1 is greater than or equal to expression2 (true) or expression1 is less than expression2 (false).
!= | inequality | Tests for the exact opposite of the equality (==) operator.
< | less than | Compares two expressions and determines whether expression1 is less than expression2; if so, the result is true.
<= | less than or equal to | Compares two expressions and determines whether expression1 is less than or equal to expression2; if it is, the result is true.
=== | strict equality | Tests two expressions for equality, but does not perform automatic data conversion.
!== | strict inequality | Tests for the exact opposite of the strict equality (===) operator.
Logical
&& | logical AND | Returns expression1 if it is false or can be converted to false, and expression2 otherwise.
! | logical NOT | Inverts the Boolean value of a variable or expression.
|| | logical OR | Returns expression1 if it is true or can be converted to true, and expression2 otherwise.
Other
[] | array access | Initializes a new array or multidimensional array with the specified elements (a0, and so on), or accesses elements in an array.
 | as | Evaluates whether an expression specified by the first operand is a member of the data type specified by the second operand.
, | comma | Evaluates expression1, then expression2, and so on.
?: | conditional | Evaluates expression1, and if the value of expression1 is true, the result is the value of expression2; otherwise the result is the value of expression3.
 | delete | Destroys the object property specified by reference; the result is true if the property does not exist after the operation completes, and false otherwise.
. | dot | Accesses class variables and methods, gets and sets object properties, and delimits imported packages or classes.
 | in | Evaluates whether a property is part of a specific object.
 | instanceof | Evaluates whether an expression's prototype chain includes the prototype object for function.
 | is | Evaluates whether an object is compatible with a specific data type, class, or interface.
:: | name qualifier | Identifies the namespace of a property, a method, an XML property, or an XML attribute.
 | new | Instantiates a class instance.
{} | object initializer | Creates a new object and initializes it with the specified name and value property pairs.
() | parentheses | Performs a grouping operation on one or more parameters, performs sequential evaluation of expressions, or surrounds one or more parameters and passes them as arguments to a function that precedes the parentheses.
/ | RegExp delimiter | When used before and after characters, indicates that the characters have a literal value and are considered a regular expression (RegExp), not a variable, string, or other ActionScript element.
: | type | Used for assigning a data type; this operator specifies the variable type, function return type, or function parameter type.
 | typeof | Evaluates expression and returns a string specifying the expression's data type.
 | void | Evaluates an expression and then discards its value, returning undefined.
String
+ | concatenation | Concatenates (combines) strings.
+= | concatenation assignment | Assigns expression1 the value of expression1 + expression2.
" | string delimiter | When used before and after characters, indicates that the characters have a literal value and are considered a string, not a variable, numerical value, or other ActionScript element.
XML
@ | attribute identifier | Identifies attributes of an XML or XMLList object.
{ } | braces (XML) | Evaluates an expression that is used in an XML or XMLList initializer.
[ ] | brackets (XML) | Accesses a property or attribute of an XML or XMLList object.
+ | concatenation (XMLList) | Concatenates (combines) XML or XMLList values into an XMLList object.
+= | concatenation assignment (XMLList) | Assigns expression1, which is an XMLList object, the value of expression1 + expression2.
 | delete (XML) | Deletes the XML elements or attributes specified by reference.
.. | descendant accessor | Navigates to descendant elements of an XML or XMLList object, or (combined with the @ operator) finds matching attributes of descendants.
. | dot (XML) | Navigates to child elements of an XML or XMLList object, or (combined with the @ operator) returns attributes of an XML or XMLList object.
( ) | parentheses (XML) | Evaluates an expression in an E4X XML construct.
< > | XML literal tag delimiter | Defines an XML tag in an XML literal.
Operator detail
+ addition operator
Usage
expression1 + expression2

Adds numeric expressions. If both expressions are integers, the sum is an integer; if either or both expressions are floating-point numbers, the sum is a floating-point number.

If one expression is a string, all other expressions are converted to strings and concatenated instead of summed. Otherwise, if an expression is not a number, Flash® Player converts it to a number.

Operands
expression1:Number — A value to be added.
expression2:Number — A value to be added.

Result
Number — An integer or floating-point number.

Example
This statement adds the integers 2 and 3:
trace(2 + 3); // 5
This statement adds the floating-point numbers 2.5 and 3.25:
trace(2.5 + 3.25); // 5.75
This example shows that if one expression is a string, all other expressions are converted to strings and concatenated:
trace("Number " + 8 + 0); // Number 80
Variables associated with dynamic and input text fields have the data type String. In the following example, the variable deposit is an input text field on the Stage. After a user enters a deposit amount, the script attempts to add deposit to oldBalance. However, because deposit is of type String, the script concatenates (combines to form one string) the variable values rather than summing them.
var oldBalance:Number = 1345.23;
var currentBalance = deposit_txt.text + oldBalance;
trace(currentBalance);
For example, if a user enters 475 in the deposit text field, the trace() statement sends the value 4751345.23 to the Output panel. To correct this, use the Number() function to convert the string to a number, as shown here:
var oldBalance:Number = 1345.23;
var currentBalance:Number = Number(deposit_txt.text) + oldBalance;
trace(currentBalance);

See also

+ (concatenation)
Operators
Operators
Concatenating strings
+= addition assignment operator
Usage
expression1 += expression2

Assigns expression1 the value of expression1 + expression2. For example, the following two statements have the same result:

x += y;
x = x + y;
All the rules of the addition (+) operator apply to the addition assignment (+=) operator.

Operands
expression1:Number — A number.
expression2:Number — A number.

Result
Number — The result of the addition.

Example
The following example shows a numeric use of the addition assignment (+=) operator:
var x:Number = 5;
var y:Number = 10;
x += y;
trace(x); // 15

See also

+ (addition)
Operators
[] array access operator
Usage
myArray = [a0, a1,...aN]
myArray[i] = value
myObject[propertyName]

Initializes a new array or multidimensional array with the specified elements (a0, and so on), or accesses elements in an array. The array access operator lets you dynamically set and retrieve instance, variable, and object names. It also lets you access object properties.

Usage 1: An array is an object whose properties are called elements, which are each identified by a number called an index. When you create an array, you surround the elements with the array access ([]) operator (or brackets). An array can contain elements of various types. For example, the following array, called employee, has three elements; the first is a number and the second two are strings (inside quotation marks):

var employee:Array = [15, "Barbara", "Jay"];
You can nest brackets to simulate multidimensional arrays. You can nest arrays up to 256 levels deep. The following code creates an array called ticTacToe with three elements; each element is also an array with three elements:
var ticTacToe:Array = [[1, 2, 3], [4, 5, 6], [7, 8, 9]];

/* Select Debug > List Variables in test mode
to see a list of the array elements.*/
Usage 2: Surround the index of each element with brackets ([]) to access it directly; you can add a new element to an array, or you can change or retrieve the value of an existing element. The first index in an array is always 0, as shown in the following example:
var my_array:Array = new Array();
my_array[0] = 15;
my_array[1] = "Hello";
my_array[2] = true;
You can use brackets to add a fourth element, as shown in the following example:
my_array[3] = "George";
You can use brackets to access an element in a multidimensional array. The first set of brackets identifies the element in the original array, and the second set identifies the element in the nested array. The following trace() statement finds the third element (index 2) of the second array (index 1).
var ticTacToe:Array = [[1, 2, 3], [4, 5, 6], [7, 8, 9]];
trace(ticTacToe[1][2]); // 6
Usage 3: You can use the array access operator to dynamically set and retrieve values for a property of an object:
var obj:Object = new Object();
obj.prop1 = "foo";
trace(obj["prop" + 1]); // foo
obj.prop2 = "bar";
for (j in obj) {
    trace(obj[j]);
}
/* Output of for loop:
foo
bar */

Operands
myArray:Object — The name of an array.
a0, a1,...aN:Object — Elements in an array; any native type or object instance, including nested arrays.
i:Number — An integer index greater than or equal to 0.
myObject:Object — The name of an object.
propertyName:String — A string that names a property of the object.

Result
Object —

Usage 1: A reference to an array.

Usage 2: A value from the array; either a native type or an object instance (including an Array instance).

Usage 3: A property from the object; either a native type or an object instance (including an Array instance).

Example
The following example shows two ways to create a new empty Array object; the first line uses brackets:
var my_array:Array = [];
var my_array:Array = new Array();

The following example creates an array called employee_array with three elements and changes the third element in the array.

var employee_array = ["Barbara", "George", "Mary"];
trace(employee_array); // Barbara,George,Mary
employee_array[2] = "Sam";
trace(employee_array); // Barbara,George,Sam
In the following example, the expression inside the brackets is evaluated, and the result is used as the name of the variable to be retrieved from the obj object:
var obj:Object = new Object();
obj.prop1 = "foo";
obj.prop2 = "bar";

for (var i:int = 1;i < 3;i++) {
    trace(obj["prop"+i]);
}
/* Output of for loop:
foo
bar */

See also

Array class
Object class
Operators
as operator
Usage
expression as datatype

Evaluates whether an expression specified by the first operand is a member of the data type specified by the second operand. If the first operand is a member of the data type, the result is the first operand. Otherwise, the result is the value null.

The expression used for the second operand must evaluate to a data type.

Operands
expression:* — The value to check against the data type specified.
datatype:Class — The data type used to evaluate the expression operand. The special * type, which means untyped, cannot be used.

Result
Object — The result is expression if expression is a member of the data type specified in datatype. Otherwise, the result is the value null.

Example
The following example creates a simple array named myArray and uses the as operator with various data types.
public var myArray:Array = ["one", "two", "three"];
trace(myArray as Array);  // one,two,three
trace(myArray as Number); // null
trace(myArray as int);    // null

See also

instanceof
is
= assignment operator
Usage
expression1 = expression2

Assigns the value of expression2 (the operand on the right) to the variable, array element, or property in expression1. Assignment can be either by value or by reference. Assignment by value copies the actual value of expression2 and stores it in expression1. Assignment by value is used when expression2 is a primitive value, which means that its data type is either Boolean, Number, int, uint, or String. Assignment by reference stores a reference to expression2 in expression1. Assignment by reference is commonly used with the new operator. The new operator creates an object in memory, and a reference to that location in memory is assigned to a variable.

Note: In ActionScript 3.0 all values (including primitive values) are objects, and all assignment is done by reference, but primitive objects have special operators that allow them to behave as if they are assigned by value.

Operands
expression1:* — A variable, element of an array, or property of an object.
expression2:* — A value of any type.

Result
Object — The assigned value, expression2.

Example
The following example uses assignment by value to assign the value of 5 to the variable z.
var z:Number = 5;
The following example uses assignment by value to assign the value "hello" to the variable z:
var x:String;
x = "hello";
The following example uses assignment by reference to create the moonsOfJupiter variable, which contains a reference to a newly created Array object. Assignment by value is then used to copy the value "Callisto" to the first element of the array referenced by the variable moonsOfJupiter:
var moonsOfJupiter:Array = new Array();
moonsOfJupiter[0] = "Callisto";
The following example uses assignment by reference to create a new object and assign a reference to that object to the variable mercury. Assignment by value is then used to assign the value of 3030 to the diameter property of the mercury object:
var mercury:Object = new Object();
mercury.diameter = 3030; // in miles
trace(mercury.diameter); // 3030
The following example builds on the previous example by creating a variable named merkur (the German word for mercury) and assigning it the value of mercury. This creates two variables that reference the same object in memory, which means you can use either variable to access the object's properties. You can then change the diameter property to use kilometers instead of miles:
var merkur:Object = mercury;
merkur.diameter = 4878;  // in kilometers
trace(mercury.diameter); // 4878

See also

== (equality)
Operators
Operators
@ attribute identifier operator
Usage
 myXML.@attributeName

Identifies attributes of an XML or XMLList object. For example, myXML.@id identifies attributes named id for the myXML XML object. You can also use the following syntax to access attributes: myXML.attribute("id"), myXML["@id"], and myXML.@["id"]. The syntax myXML.@id is recommended. To return an XMLList object of all attribute names, use @*. To return an attribute with a name that matches an ActionScript reserved word, use the attribute() method instead of the @ operator.

Operands
attributeName:* — The name of the attribute.

Example
The first example shows how to use the @ (at sign) operator to identify an attribute of an element:
var myXML:XML =
    <item id = "42">
        <catalogName>Presta tube</catalogName>
        <price>3.99</price>
    </item>;

trace(myXML.@id); // 42
The next example returns all attribute names:
var xml:XML =<example id='123' color='blue'/>
 var xml2:XMLList = xml.@*;
 trace(xml2 is XMLList); // true
 trace(xml2.length());  // 2
 for (var i:int = 0; i < xml2.length(); i++)
 {
    trace(typeof(xml2[i]));    // xml
    trace(xml2[i].nodeKind()); // attribute
    trace(xml2[i].name());     // id and color
 }
The next example returns an attribute with a name that matches a reserved word in ActionScript. You cannot use the syntax xml.@class (since class is a reserved word in ActionScript). You need to use the syntax xml.attribute("class"):
var xml:XML = <example class='123'/>
trace(xml.attribute("class"));

See also

XML class
XMLList class
XML.attribute()
XML.attributes()
& bitwise AND operator
Usage
expression1 & expression2

Converts expression1 and expression2 to 32-bit unsigned integers, and performs a Boolean AND operation on each bit of the integer parameters. Floating-point numbers are converted to integers by discarding any digits after the decimal point. The result is a new 32-bit integer.

A positive integer is converted to an unsigned hexadecimal value with a maximum value of 4294967295 or 0xFFFFFFFF; a value larger than the maximum has its most significant digits discarded when it is converted so the value is still 32-bit. A negative number is converted to an unsigned hexadecimal value using the two's complement notation, with a minimum value of -2147483648 or 0x800000000; a number less than the minimum is converted to two's complement with greater precision before the most significant digits are discarded.

The result is interpreted as a 32-bit two's complement number, so the result is an integer in the range -2147483648 to 2147483647.

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
int — The result of the bitwise operation.

Example
The following example performs a bitwise AND of 13 (binary 1101) and 11 (binary 1011) by comparing the bit representations of the numbers. The resulting integer is composed of a sequence of bits, each of which is set to 1 only if the bits of both operands at the same position are 1.
var insert:Number = 13;
var update:Number = 11;
trace(insert & update); // 9 (or 1001 binary)
The bitwise AND of 13 (binary 1101) and 11 (binary 1011) is 9 because only the first and last positions in both numbers have the number 1.
  1101
& 1011
  ----
  1001

The following examples show the behavior of the return value conversion:

trace(0xFFFFFFFF); // 4294967295
trace(0xFFFFFFFF & 0xFFFFFFFF); // -1
trace(0xFFFFFFFF & -1); // -1
trace(4294967295 & -1); // -1
trace(4294967295 & 4294967295); // -1

See also

&= (bitwise AND assignment)
~ (bitwise NOT)
| (bitwise OR)
|= (bitwise OR assignment)
^ (bitwise XOR)
^= (bitwise XOR assignment)
&= bitwise AND assignment operator
Usage
expression1 &= expression2

Assigns expression1 the value of expression1 & expression2. For example, the following two expressions are equivalent:

x &= y;
x = x & y;

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
int — The value of expression1 & expression2.

Example
The following example assigns the value 9 to x:
var x:Number = 15;
var y:Number = 9;
trace(x &= y); // 9

See also

& (bitwise AND)
~ (bitwise NOT)
| (bitwise OR)
|= (bitwise OR assignment)
^ (bitwise XOR)
^= (bitwise XOR assignment)
<< bitwise left shift operator
Usage
expression1 << shiftCount

Converts expression1 and shiftCount to 32-bit integers, and shifts all the bits in expression1 to the left by the number of places specified by the integer resulting from the conversion of shiftCount. The bit positions that are emptied as a result of this operation are filled in with 0 and bits shifted off the left end are discarded. Shifting a value left by one position is the equivalent of multiplying it by 2.

A floating-point number is converted to an integer by discarding any digits after the decimal point. A positive integer is converted to an unsigned hexadecimal value with a maximum value of 4294967295 or 0xFFFFFFFF; a value larger than the maximum has its most significant digits discarded when it is converted so the value is still 32-bit. A negative number is converted to an unsigned hexadecimal value using the two's complement notation, with a minimum value of -2147483648 or 0x800000000; a number less than the minimum is converted to two's complement with greater precision before the most significant digits are discarded.

The result is interpreted as a 32-bit two's complement number, so the result is an integer in the range -2147483648 to 2147483647.

If the result is a negative integer, a runtime error occurs if you attempt to assign the result to a variable of type uint. Although ActionScript has no "unsigned bitwise left shift" operator, you can achieve the same effect, and avoid the runtime error, by using uint(expression1 << shiftCount):

var num1:uint = 0xFF;
var num2:uint = uint(num1 << 24); // uint() prevents runtime error

Operands
expression1:Number — A number or expression to be shifted left.
shiftCount:Number — A number or expression that converts to an integer from 0 to 31.

Result
int — The result of the bitwise operation.

Example
In the following example, the integer 1 is shifted 10 bits to the left:
x = 1 << 10
The result of the bitwise left shift operation is 1024. This is because 1 decimal equals 1 binary, 1 binary shifted left by 10 is 10000000000 binary, and 10000000000 binary is 1024 decimal:
   00000000001 binary
<<          10 decimal
--------------
   10000000000 binary equals 1024 decimal

In the following example, the integer 7 is shifted 8 bits to the left:

x = 7 << 8
The result of the bitwise left shift operation is 1792. This is because 7 decimal equals 111 binary, 111 binary shifted left by 8 bits is 11100000000 binary, and 11100000000 binary is 1792 decimal:
   00000000111 binary
<<           8 decimal
--------------
   11100000000 binary equals 1792 decimal

The following trace statement shows that the bits have been pushed three positions to the left:

// 1 binary == 0001
// 8 binary == 1000
trace(1 << 3); // 8

See also

<<= (bitwise left shift and assignment)
>> (bitwise right shift)
>>= (bitwise right shift and assignment)
>>> (bitwise unsigned right shift)
>>>= (bitwise unsigned right shift and assignment)
<<= bitwise left shift and assignment operator
Usage
expression1 <<= expression2

Performs a bitwise left shift (<<=) operation and stores the contents as a result in expression1. The following two expressions are equivalent:

A <<= B
A = (A << B)

Operands
expression1:Number — A number or expression to be shifted left.
expression2:Number — A number or expression that converts to an integer from 0 to 31.

Result
int — The result of the bitwise operation.

Example
The following example uses the bitwise left shift and assignment (<<=) operator to shift all bits one position to the left:
var x:Number = 4;
// Shift all bits one slot to the left.
x <<= 1;
trace(x); // 8
// 4 decimal = 0100 binary
// 8 decimal = 1000 binary

See also

<< (bitwise left shift)
>> (bitwise right shift)
>>= (bitwise right shift and assignment)
~ bitwise NOT operator
Usage
~expression

Converts expression to a 32-bit signed integer, and then applies a bitwise one's complement. That is, every bit that is a 0 is set to 1 in the result, and every bit that is a 1 is set to 0 in the result. The result is a signed 32-bit integer. This operator is also known as the one's complement operator or the bitwise complement operator.

For example, the hexadecimal value 0x7777 is represented as this binary number:

0111011101110111

The bitwise negation of that hexadecimal value, ~0x7777, is this binary number:

1000100010001000

In hexadecimal, this is 0x8888. Therefore, ~0x7777 is 0x8888.

The most common use of bitwise operators is for representing flag bits (Boolean values packed into 1 bit each).

A floating-point number is converted to an integer by discarding any digits after the decimal point. A positive integer is converted to an unsigned hexadecimal value with a maximum value of 4294967295 or 0xFFFFFFFF; a value larger than the maximum has its most significant digits discarded when it is converted so the value is still 32-bit. A negative number is converted to an unsigned hexadecimal value using the two's complement notation, with a minimum value of -2147483648 or 0x800000000; a number less than the minimum is converted to two's complement with greater precision before the most significant digits are discarded.

The result is interpreted as a 32-bit two's complement number, so the result is an integer in the range -2147483648 to 2147483647.

Operands
expression:Number — A number to be converted.

Result
int — The result of the bitwise operation.

Example
The following example demonstrates a use of the bitwise NOT (~) operator with flag bits:
var ReadOnlyFlag:int = 0x0001; // defines bit 0 as the read-only flag
var flags:int = 0;
trace(flags);
/* To set the read-only flag in the flags variable,
   the following code uses the bitwise OR:
*/
flags |= ReadOnlyFlag;
trace(flags);
/* To clear the read-only flag in the flags variable,
   first construct a mask by using bitwise NOT on ReadOnlyFlag.
   In the mask, every bit is a 1 except for the read-only flag.
   Then, use bitwise AND with the mask to clear the read-only flag.
   The following code constructs the mask and performs the bitwise AND:
*/
flags &= ~ReadOnlyFlag;
trace(flags);
// 0 1 0

See also

& (bitwise AND)
&= (bitwise AND assignment)
| (bitwise OR)
|= (bitwise OR assignment)
^ (bitwise XOR)
^= (bitwise XOR assignment)
| bitwise OR operator
Usage
expression1 | expression2

Converts expression1 and expression2 to 32-bit unsigned integers, and places a 1 in each bit position where the corresponding bits of either expression1 or expression2 are 1.

A floating-point number is converted to an integer by discarding any digits after the decimal point. A positive integer is converted to an unsigned hexadecimal value with a maximum value of 4294967295 or 0xFFFFFFFF; a value larger than the maximum has its most significant digits discarded when it is converted so the value is still 32-bit. A negative number is converted to an unsigned hexadecimal value using the two's complement notation, with a minimum value of -2147483648 or 0x800000000; a number less than the minimum is converted to two's complement with greater precision before the most significant digits are discarded.

The result is interpreted as a 32-bit two's complement number, so the result is an integer in the range -2147483648 to 2147483647.

Operands
expression1:Number — A number.
expression2:Number — A number.

Result
int — The result of the bitwise operation.

Example
The following is an example of a bitwise OR (|) operation:
// 15 decimal = 1111 binary
var a:Number = 15;
// 9 decimal = 1001 binary
var b:Number = 9;
// 1111 | 1001 = 1111
trace(a | b); // returns 15 decimal (1111 binary)
Don't confuse the single | (bitwise OR) with || (logical OR).

See also

& (bitwise AND)
&= (bitwise AND assignment)
~ (bitwise NOT)
|= (bitwise OR assignment)
^ (bitwise XOR)
^= (bitwise XOR assignment)
|= bitwise OR assignment operator
Usage
expression1 |= expression2

Assigns expression1 the value of expression1 | expression2. For example, the following two statements are equivalent:

x |= y;
x = x | y;

Operands
expression1:Number — A number to be converted.
expression2:Number — A number to be converted.

Result
int — The result of the bitwise operation.

Example
The following example uses the bitwise OR assignment (|=) operator:
// 15 decimal = 1111 binary
var a:Number = 15;
// 9 decimal = 1001 binary
var b:Number = 9;
// 1111 |= 1001 = 1111
trace(a |= b); // returns 15 decimal (1111 binary)

See also

& (bitwise AND)
&= (bitwise AND assignment)
~ (bitwise NOT)
| (bitwise OR)
^ (bitwise XOR)
^= (bitwise XOR assignment)
>> bitwise right shift operator
Usage
expression >> shiftCount

Converts expression and shiftCount to 32-bit integers, and shifts all the bits in expression to the right by the number of places specified by the integer that results from the conversion of shiftCount. Bits that are shifted off the right end are discarded. To preserve the sign of the original expression, the bits on the left are filled in with 0 if the most significant bit (the bit farthest to the left) of expression is 0, and filled in with 1 if the most significant bit is 1. Shifting a value right by one position is the equivalent of dividing by 2 and discarding the remainder.

A floating-point number is converted to an integer by discarding any digits after the decimal point. A positive integer is converted to an unsigned hexadecimal value with a maximum value of 4294967295 or 0xFFFFFFFF; a value larger than the maximum has its most significant digits discarded when it is converted so the value is still 32-bit. A negative number is converted to an unsigned hexadecimal value using the two's complement notation, with a minimum value of -2147483648 or 0x800000000; a number less than the minimum is converted to two's complement with greater precision before the most significant digits are discarded.

The result is interpreted as a 32-bit two's complement number, so the result is an integer in the range -2147483648 to 2147483647.

Operands
expression:Number — A number or expression to be shifted right.
shiftCount:Number — A number or expression that converts to an integer from 0 to 31.

Result
int — The result of the bitwise operation.

Example
The following example converts 65535 to a 32-bit integer and shifts it 8 bits to the right, resulting in a decimal value of 255:
var a:Number = 65535 >> 8;
trace(a); // 255
This is because 65535 decimal equals 00000000000000001111111111111111 binary (sixteen 0s followed by sixteen 1s); shifting right by 8 bits causes the 8 least significant bits (the bits farthest to the right) to be discarded. Because 65535 is positive, the bit position made available by the shift (the 8 bit positions farthest on the left) are filled in with 0s. The result is 00000000000000000000000011111111 (twenty-four 0s followed by eight 1s) binary, which represents the 32-bit integer 255.
    00000000000000001111111111111111 binary (65535 decimal)
>>                                 8 decimal
--------------------
    00000000000000000000000011111111 binary (255 decimal)
The following example converts -8 to a 32-bit integer and shifts it 1 bit to the right, resulting in a decimal value of -4:
var a:Number = -8 >> 1;
trace(a); // -4
This is because -8 decimal equals 11111111111111111111111111111000 binary (twenty-nine 1s followed by three 0s); shifting right by one bit causes the least significant bit (the bit farthest to the right) to be discarded. Because -8 is negative, the bit position made available by the shift (the 1 bit position farthest on the left) is filled in with 1. The result is 11111111111111111111111111111100 (thirty 1s followed by two 0s) binary, which represents the 32-bit integer -4.
    11111111111111111111111111111000 binary (-8 decimal)
>>                                1 decimal
--------------------
    11111111111111111111111111111100 binary (-4 decimal)

See also

>>= (bitwise right shift and assignment)
>>= bitwise right shift and assignment operator
Usage
expression >>= shiftCount

Performs a bitwise right-shift operation and stores the result in expression.

The following two statements are equivalent:

A >>= B;
A = (A >> B);

Operands
expression:Number — A number or expression to be shifted right.
shiftCount:Number — A number or expression that converts to an integer from 0 to 31.

Result
int — The result of the bitwise operation.

Example
The following code uses the bitwise right shift and assignment (>>=) operator:
function convertToBinary(numberToConvert:Number):String {
    var result:String = "";
    for (var i = 0; i < 32; i++) {
        // Extract least significant bit using bitwise AND.
        var lsb:Number = numberToConvert & 1;
        // Add this bit to the result.
        result = (lsb ? "1" : "0")+result;
        // Shift numberToConvert right by one bit, to see next bit.
        numberToConvert >>= 1;
    }
    return result;
}
trace(convertToBinary(479));
// Returns the string 00000000000000000000000111011111.
// This string is the binary representation of the decimal number 479.

See also

>> (bitwise right shift)
>>> bitwise unsigned right shift operator
Usage
expression >>> shiftCount

The same as the bitwise right shift (>>) operator except that it does not preserve the sign of the original expression because the bits on the left are always filled with 0.

A floating-point number is converted to an integer by discarding any digits after the decimal point. A positive integer is converted to an unsigned hexadecimal value with a maximum value of 4294967295 or 0xFFFFFFFF; a value larger than the maximum has its most significant digits discarded when it is converted so the value is still 32-bit. A negative number is converted to an unsigned hexadecimal value using the two's complement notation, with a minimum value of -2147483648 or 0x800000000; a number less than the minimum is converted to two's complement with greater precision before the most significant digits are discarded.

The result is interpreted as a 32-bit unsigned integer, so the result is an integer in the range 0 to 4294967295.

Note: ActionScript has no complementary "bitwise unsigned left shift" operator, but you can achieve the same effect by using uint(expression << shiftCount).

Operands
expression:Number — A number or expression to be shifted right.
shiftCount:Number — A number or expression that converts to an integer between 0 and 31.

Result
uint — The result of the bitwise operation.

Example
The following example converts -1 to a 32-bit integer and shifts it 1 bit to the right:
var a:Number = -1 >>> 1;
trace(a); // 2147483647
This is because -1 decimal is 11111111111111111111111111111111 binary (thirty-two 1s), and when you shift right (unsigned) by 1 bit, the least significant (rightmost) bit is discarded, and the most significant (leftmost) bit is filled with a 0. The result is 01111111111111111111111111111111 binary, which represents the 32-bit integer 2147483647.

See also

>> (bitwise right shift)
>>= (bitwise right shift and assignment)
>>>= bitwise unsigned right shift and assignment operator
Usage
expression >>>= shiftCount

Performs an unsigned bitwise right-shift operation and stores the result in expression. The following two statements are equivalent:

A >>>= B;
A = (A >>> B);

Operands
expression:Number — A number or expression to be shifted right.
shiftCount:Number — A number or expression that converts to an integer from 0 to 31.

Result
uint — The result of the bitwise operation.

Example
The following example converts -1 to a 32-bit integer and shifts it 1 bit to the right:
var a:Number = -1;
a >>>= 1;
trace(a); // 2147483647
This is because -1 decimal is 11111111111111111111111111111111 binary (thirty-two 1s), and when you shift right (unsigned) by 1 bit, the least significant (rightmost) bit is discarded, and the most significant (leftmost) bit is filled with a 0. The result is 01111111111111111111111111111111 binary, which represents the 32-bit integer 2147483647.

See also

>>> (bitwise unsigned right shift)
>>= (bitwise right shift and assignment)
^ bitwise XOR operator
Usage
expression1 ^ expression2

Converts expression1 and expression2 to 32-bit unsigned integers, and places a 1 in each bit position where the corresponding bits in expression1 or expression2, but not both, are 1.

A floating-point number is converted to an integer by discarding any digits after the decimal point. A positive integer is converted to an unsigned hexadecimal value with a maximum value of 4294967295 or 0xFFFFFFFF; a value larger than the maximum has its most significant digits discarded when it is converted so the value is still 32-bit. A negative number is converted to an unsigned hexadecimal value using the two's complement notation, with a minimum value of -2147483648 or 0x800000000; a number less than the minimum is converted to two's complement with greater precision before the most significant digits are discarded.

The result is interpreted as a 32-bit two's complement number, so the result is an integer in the range -2147483648 to 2147483647.

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
int — The result of the bitwise operation.

Example
The following example uses the bitwise XOR operator on the decimals 15 and 9, and assigns the result to the variable a:
// 15 decimal = 1111 binary
// 9 decimal = 1001 binary
var a:Number = 15 ^ 9;
trace(a);
// 1111 ^ 1001 = 0110
// returns 6 decimal (0110 binary)

See also

& (bitwise AND)
&= (bitwise AND assignment)
~ (bitwise NOT)
| (bitwise OR)
|= (bitwise OR assignment)
^= (bitwise XOR assignment)
^= bitwise XOR assignment operator
Usage
expression1 ^= expression2

Assigns expression1 the value of expression1 ^ expression2. For example, the following two statements are equivalent:

x ^= y
x = x ^ y

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
int — The result of the bitwise operation.

Example
The following example shows a bitwise XOR assignment (^=) operation:
// 15 decimal = 1111 binary
var a:Number = 15;
// 9 decimal = 1001 binary
var b:Number = 9;
trace(a ^= b); // returns 6 decimal (0110 binary)

See also

& (bitwise AND)
&= (bitwise AND assignment)
~ (bitwise NOT)
| (bitwise OR)
|= (bitwise OR assignment)
^ (bitwise XOR)
/*..*/ block comment delimiter operator
Usage
/* comment */
/* comment
   comment */

Delimits one or more lines of script comments. Characters that appear between the opening delimiter (/*) and the closing delimiter (*/) are interpreted as a comment and ignored by the ActionScript compiler. Use these delimiters to identify comments on multiple successive lines; for single-line comments, use the // delimiter.

You will receive an error message if you omit the closing block comment delimiter (*/), or if you attempt to nest comments. After an opening delimiter (/*) is used, the first closing delimiter (*/) ends the comment, regardless of the number of opening delimiters placed before it.

Operands
comment:* — Any characters.

Example
The following script uses block comment delimiters at the beginning of the script:
/* records the X and Y positions of
the ball and bat movie clips */
var ballX:Number = ball_mc._x;
var ballY:Number = ball_mc._y;
var batX:Number = bat_mc._x;
var batY:Number = bat_mc._y;
The following attempt to nest comments results in an error message:
/* This is an attempt to nest comments.
/* But the first closing tag will be paired
with the first opening tag */
and this text will not be interpreted as a comment */

See also

// (line comment delimiter)
{ } braces (XML) operator
Usage
 myXML = <{tagName} {attributeName} = {attributeValue}>{content}</{tagName}>

Evaluates an expression that is used in an XML or XMLList initializer. An XML or XMLList initializer is a literal value that is assigned to a variable of type XML or XMLList. An expression that is delimited by the XML { and } operators can be used in an XML or XMLList initializer instead of literal names or values. An expression can be used in place of tagName, attributeName, attributeValue, and content.

Operands
myXML:* — An XML or XMLList object.
tagName:* — An expression that evaluates to the name of an XML tag.
attributeName:* — An expression that evaluates to the name of an XML attribute.
attributeValue:* — An expression that evaluates to the value of an XML attribute.
content:* — An expression that evaluates to the contents of an XML tag.

Example
The following example shows how to use the { and } operators when defining an XML literal:
var tagname:String = "item";
var attributename:String = "id";
var attributevalue:String = "5";
var content:String = "Chicken";
var x:XML = <{tagname} {attributename}={attributevalue}>{content}</{tagname}>;
trace(x.toXMLString()); // <item id="5">Chicken</item>

See also

XML class
XMLList class
[ ] brackets (XML) operator
Usage
 myXML[expression]

Accesses a property or attribute of an XML or XMLList object. The brackets operator allows you to access property names that are not accessible with the dot (.) operator.

Operands
myXML:* — An XML or XMLList object.
expression:* — An expression that evaluates to the name of an XML tag or attribute.

Example
The following example shows how to use the [ and ] operators to access an XML property that is not accessible with the dot operator because of the hyphen in the tag name:
var myXML:XML = <a><foo-bar>44</foo-bar></a>;
trace(myXML["foo-bar"]);

See also

XML class
XMLList class
, comma operator
Usage
(expression1, expression2[, expressionN... ])

Evaluates expression1, then expression2, and so on. This operator is primarily used with the for loop statement and is often used with the parentheses () operator.

Operands
expression1:* — An expression to be evaluated.
expression2:* — An expression to be evaluated.
expressionN:* — Any number of additional expressions to be evaluated.

Result
Object — The values of the evaluated expressions.

Example
The following example uses the comma (,) operator in a for loop:
for (i = 0, j = 0; i < 3 && j < 3; i++, j+=2) {
    trace("i = " + i + ", j = " + j);
}
// output:
// i = 0, j = 0
// i = 1, j = 2
The following example uses the comma operator without the parentheses operator to show that the comma operator is of lower precedence than the assignment (=) operator:
var v:Number = 0;
v = 4, 5, 6;
trace(v); // 4
The following example uses the comma operator with parentheses and illustrates that the comma operator returns the value of the last expression:
var v:Number = 0;
v = (4, 5, 6);
trace(v); // 6
The following example uses the comma operator without parentheses and illustrates that the comma operator causes all of the expressions to be evaluated sequentially. The first expression, v + 4, is assigned to the variable v because the assignment (=) operator is of higher precedence than the comma operator. The second expression, z++, is evaluated and z is incremented by one.
var v:Number = 0;
var z:Number = 0;
v = v + 4 , z++, v + 6;
trace(v); // 4
trace(z); // 1
The following example is identical to the previous example except for the addition of parentheses, which changes the order of operations such that the comma operator is evaluated before the assignment (=) operator:
var v:Number = 0;
var z:Number = 0;
v = (v + 4, z++, v + 6);
trace(v); // 6
trace(z); // 1

See also

() (parentheses)
Operators
Operators
+ concatenation operator
Usage
expression1 + expression2

Concatenates (combines) strings. If one expression is a string, all other expressions are converted to strings and concatenated.

If both expressions are numbers, this operator behaves as an addition operator.

Operands
expression1:String — A string to be concatenated.
expression2:String — A string to be concatenated.

Result
String — The concatenated string.

Example
The following example concatenates two strings.
var lastName:String = "Cola";
var instrument:String = "Drums";
trace(lastName + " plays " + instrument); // Cola plays Drums
This example shows that if one expression is a string, all other expressions are converted to strings and concatenated:
trace("Number " + 8 + 0); // Number 80
The following example shows how numeric sums to the right of a string expression are not calculated because they are converted to strings:
var a:String = 3 + 10 + "asdf";
trace(a); // 13asdf
var b:String = "asdf" + 3 + 10;
trace(b); // asdf310

See also

+ (addition)
Operators
+ concatenation (XMLList) operator
Usage
expression1 + expression2

Concatenates (combines) XML or XMLList values into an XMLList object. An XMLList object results only if both operands are XML or XMLList values.

Operands
expression1:* — An XML or XMLList value.
expression2:* — An XML or XMLList value.

Result
XMLList — The concatenated XMLList object.

Example
The following example shows how to use the XMLList (+) (concatenation) operator:
var x1:XML =
        <employee id = "42">
            <firstName>Joe</firstName>
            <lastName>Smith</lastName>
        </employee>;

var x2:XML =
        <employee id = "43">
            <firstName>Susan</firstName>
            <lastName>Jones</lastName>
        </employee>;

var myXMLList:XMLList = x1 + x2;

trace(myXMLList.toXMLString());

The trace statement produces the following output:

<employee id = "42">
    <firstName>Joe</firstName>
    <lastName>Smith</lastName>
</employee>
<employee id = "43">
    <firstName>Susan</firstName>
    <lastName>Jones</lastName>
</employee>

See also

XMLList class
XMLList global function
+= concatenation assignment operator
Usage
expression1 += expression2

Assigns expression1 the value of expression1 + expression2. For example, the following two statements have the same result:

x += y;
x = x + y;
All the rules of the concatenation (+) operator apply to the concatenation assignment (+=) operator.

Operands
expression1:String — A string.
expression2:String — A string.

Result
Number — The result of the concatenation.

Example
This example uses the += operator with a string expression:
var x1:String = "My name is ";
x1 += "Gilbert";
trace(x1); // My name is Gilbert

See also

+ (concatenation)
+= concatenation assignment (XMLList) operator
Usage
expression1 += expression2

Assigns expression1, which is an XMLList object, the value of expression1 + expression2. For example, the following two statements have the same result:

x += y;
x = x + y;
All the rules of the XMLList concatenation (+) operator apply to the XMLList concatenation assignment (+=) operator.

Operands
expression1:XMLList — The XMLList object to which you are adding a new value.
expression2:* — An XML or XMLList value.

Example
The following example shows how to use the XMLList concatenation assignment (+=) operator:
var x1:XML = <location>Athens</location>;
var x2:XML = <location>Paris</location>;
myXMLList = x1 + x2;

var x3:XML = <location>Springfield</location>;
myXMLList += x3;

trace(myXMLList.toXMLString());

The trace statement produces the following output:

<location>Athens</location>

<location>Paris</location>

<location>Springfield</location>

See also

XML class
XMLList class
XML() global function
XMLList() global function
?: conditional operator
Usage
expression1 ? expression2 : expression3

Evaluates expression1, and if the value of expression1 is true, the result is the value of expression2; otherwise the result is the value of expression3.

Operands
expression1:Boolean — An expression that evaluates to a Boolean value; usually a comparison expression, such as x < 5.
expression2:* — A value of any type.
expression3:* — A value of any type.

Result
* — The value of expression2 or expression3.

Example
The following statement assigns the value of variable x to variable z because the first expression evaluates to true:
var x:Number = 5;
var y:Number = 10;
var z = (x < 6) ? x: y;
trace(z); // returns 5
The following example shows a conditional statement written in shorthand:
var timecode:String = (new Date().getHours() < 11) ? "AM" : "PM";
trace(timecode);
The same conditional statement could also be written in longhand, as shown in the following example:
if (new Date().getHours() < 11) {
    var timecode:String = "AM";
} else {
    var timecode:String = "PM";
}
trace(timecode);

See also

Operators
Operators
-- decrement operator
Usage
--expression
expression--

Subtracts 1 from the operand. The operand can be a variable, element in an array, or property of an object. The pre-decrement form of the operator (--expression) subtracts 1 from expression and returns the result. The post-decrement form of the operator (expression--) subtracts 1 from expression and returns the initial value of expression (the value prior to the subtraction).

Operands
expression:Number — A number or a variable that evaluates to a number.

Result
Number — The result of the decremented value.

Example
The pre-decrement form of the operator decrements x to 2 (x - 1 = 2) and returns the result as y:
var x:Number = 3;
var y:Number = --x; // y is equal to 2
The post-decrement form of the operator decrements x to 2 (x - 1 = 2) and returns the original value of x as the result y:
var x:Number = 3;
var y:Number = x--; // y is equal to 3
The following example loops from 10 to 1, and each iteration of the loop decreases the counter variable i by 1:
for (var i = 10; i > 0; i--) {
    trace(i);
}

See also

Operators
Operators
delete operator
Usage
 delete reference

Destroys the object property specified by reference; the result is true if the property does not exist after the operation completes, and false otherwise. The delete operator returns true if it is called on a nonexistent property.

The delete operator can fail and return false if the reference parameter cannot be deleted. You cannot delete fixed properties or variables that are declared with the var statement. A fixed property is a variable or method defined in a class definition.

Note: You cannot delete an object, but you can make an object eligible for garbage collection by removing all references to the object. The most common reference to an object is a variable that points to it. You can remove such a reference by setting the variable to null. The garbage collector removes any object that has no references.

Operands
reference:* — The name of the property to eliminate.

Result
Boolean — The value true if the deletion succeeded and false if it failed.

Example
The following example deletes a property of an object:
// create the new object "account"
var account:Object = new Object();
// assign property name to the account
account.name = "Jon";
// delete the property
delete account.name;
trace(account.name); // undefined

// delete a nonexistent property
var fooDeleted:Boolean = delete account.foo;
trace(fooDeleted); // true

The following example deletes the value of an array element, but the value of the length property is not changed:

var my_array:Array = new Array();
my_array[0] = "abc"; // my_array.length == 1
my_array[1] = "def"; // my_array.length == 2
my_array[2] = "ghi"; // my_array.length == 3
// my_array[2] is deleted, but Array.length is not changed
delete my_array[2];
trace(my_array.length); // 3
trace(my_array); // abc,def,

See also

var
delete (XML) operator
Usage
 delete reference

Deletes the XML elements or attributes specified by reference.

When used with an XMLList operand, the result of the delete operator is always true because the XMLList operand always refers to a valid (though possibly empty) XMLList object.

Operands
reference:XMLList — An XMLList object that specifies the XML elements or attributes to delete.

Result
Boolean — A value of true if the deletion succeeded, false if it failed.

Example
The following example shows how to delete an attribute, then delete a single element, then delete multiple elements:

var x1:XML = <x1>
                <a id = "52">AYY</a>
                <a>AYY 2 </a>
                <b>BEE</b>
                <c>CEE</c>
            </x1>;

trace(x1.toXMLString());
trace("___________");

delete x1.a.@id;

trace(x1.toXMLString());
trace("___________");

delete x1.b;

trace(x1.toXMLString());
trace("___________");

delete x1.a;

trace(x1.toXMLString());

The output is as follows:

<x1>
  <a id="52">AYY</a>
  <a>AYY 2</a>
  <b>BEE</b>
  <c>CEE</c>
</x1>
___________
<x1>
  <a>AYY</a>
  <a>AYY 2</a>
  <b>BEE</b>
  <c>CEE</c>
</x1>
___________
<x1>
  <a>AYY</a>
  <a>AYY 2</a>
  <c>CEE</c>
</x1>
___________
<x1>
  <c>CEE</c>
</x1>

The following example shows how to delete all contents of an element, including attributes and child elements, without deleting the element itself:

var xml:XML =
            <order>
                <item id="121">hamburger</item>
                <item id="122">fries</item>
                <item id="123">chocolate shake</item>
            </order>;
delete xml.item[1].*;
delete xml.item[1].@*;
trace(xml);

The output for this example is the following:

<order>
  <tem id="121">hamburger</item>
  <item/>
  <item id="123">chocolate shake</item>
</order>

.. descendant accessor operator
Usage
 myXML..childElement1..@attributeName

Navigates to descendant elements of an XML or XMLList object, or (combined with the @ operator) finds matching attributes of descendants. The matching elements or attributes need not be direct children of the XML or XMLList object; they can be lower in the tree (for example, grandchildren). The result is an XMLList object, because more than one child element or attribute can match.

The order of nodes in the XMLList object returned is the result of a depth-first traversal. For example, consider the following:

var myXML:XML = <a>
            <b>one
                <c>
                    <b>two</b>
                </c>
            </b>
            <b>three</b>
        </a>;

trace(myXML..b[0].toXMLString());
trace("______________");
trace(myXML..b[1].toXMLString());
trace("______________");
trace(myXML..b[2].toXMLString());

The following output would result:

<b>
  one
  <c>
    <b>two</b>
  </c>
</b>
______________
<b>two</b>
______________
<b>three</b>

To return descendants with names that match ActionScript reserved words, use the XML.descendants() method instead of the descendant (..) operator, as the following example shows:

var xml:XML =
<enrollees>
    <student id="239">
        <class name="Algebra" />
         <class name="Spanish 2"/>
    </student>
    <student id="206">
        <class name="Trigonometry" />
         <class name="Spanish 2" />
    </student>
 </enrollees>;
 trace(xml.descendants("class"));

Operands
myXML:Object — The XML or XMLList object.
childElement1_or_attributeName — The name of an XML property or the name of an attribute.

Example
The following example shows how to use the descendant accessor (..) operator to return descendant elements of an XML object and to return an attribute of an element:
var myXML:XML =
    <employees>
        <employee id = "42">
            <firstName>Billy</firstName>
            <lastName>Einstein</lastName>
        </employee>
        <employee id = "43">
            <firstName>Sally</firstName>
            <lastName>Shostakovich</lastName>
        </employee>
    </employees>

trace(myXML..firstName);
    // <firstName>Billy</firstName>
    // <firstName>Sally</firstName>

trace(myXML..@id); //4243

See also

XML class
XMLList class
XML.descendants()
/ division operator
Usage
expression1 / expression2

Divides expression1 by expression2. The result of the division operation is a double-precision floating-point number.

Operands
expression:Number — A number or a variable that evaluates to a number.

Result
Number — The floating-point result of the operation.

Example
The following example shows that the results of dividing by 0 differs if the dividend is positive, negative or 0.
trace(3/0);   // Infinity
trace(-3/0);  // -Infinity
trace(0/0);   // NaN

See also

% (modulo)
Operators
Operators
/= division assignment operator
Usage
expression1 /= expression2

Assigns expression1 the value of expression1 / expression2. For example, the following two statements are equivalent:

x /= y;
x = x / y;

Operands
expression1:Number — A number or a variable that evaluates to a number.
expression2:Number — A number or a variable that evaluates to a number.

Result
Number — A number.

Example
The following code shows the division assignment (/=) operator used with variables and numbers:
var a:Number = 10;
var b:Number = 2;
a /= b; trace(a); // 5

See also

/ (division)
. dot operator
Usage
object.property_or_method

Accesses class variables and methods, gets and sets object properties, and delimits imported packages or classes.

Operands
object:Object — An instance of a class. The object can be an instance of any of the built-in ActionScript classes or a class you define. This operand is always to the left of the dot (.) operator.
property_or_method:* — The name of a property or method associated with an object. All the valid methods and properties for the built-in classes are listed in the method and property summary tables for that class. This operand is always to the right of the dot (.) operator.

Result
* — The variable, method, or property named on the right side of the dot.

Example
The following example uses the dot operator as a delimiter when importing the Timer class.
import flash.utils.Timer;
The following example creates a generic object and uses the dot operator to add a new property.
var obj:Object = new Object();
obj.propertyA = "hello";
trace(obj.propertyA);  // hello

See also

dot (XML) operator
Syntax
Operators
Operators
. dot (XML) operator
Usage
myXML.childElement
myXML.@attributeName

Navigates to child elements of an XML or XMLList object, or (combined with the @ operator) returns attributes of an XML or XMLList object. The object returned is an XMLList, because more than one child element or attribute can match.

To return elements with names that match ActionScript reserved words, use the XML.elements() method or the XML.descendants() method instead of the XML dot (.) operator, as the following example shows:

var xml:XML =
    <student id="206">
        <class name="Trigonometry" />
        <class name="Spanish 2" />
    </student>;
trace(xml.elements("class"));
trace(xml.descendants("class"));

Operands
myXML:Object — The XML or XMLList object.
childElement:* — The name of an XML property.
attributeName:* — The name of an attribute.

Result
XMLList — The XMLList specified.

Example
The following example shows how to use the dot (.) operator to return to a child element of an XML object and to return an attribute of an element:
var myXML:XML =
    <employee id = "42">
        <firstName>Billy</firstName>
        <lastName>Einstein</lastName>
    </employee>;

trace(myXML.firstName); // Billy
trace(myXML.@id);       // 42

See also

XML class
XMLList class
XML.descendants()
XML.elements()
== equality operator
Usage
expression1 == expression2

Tests two expressions for equality. The result is true if the expressions are equal.

If the data types of the two operands match, the definition of equal depends on the data type of the operands:

  • Values of type int, uint, and Boolean are considered equal if they have the same value.
  • Numbers with matching values are considered equal, unless they are both NaN.
  • If the value of both operands is null or undefined, they are considered equal.
  • String expressions are equal if they have the same number of characters and the characters are identical.
  • For XML objects:
    • If one operand is a text or attribute node and the other has simple content, both operands are converted to strings with the toString() method and are considered equal if the resulting strings match.
    • Otherwise, objects are considered equal only if the qualified name, attributes, and child properties for both objects match.
  • XMLList objects are considered equal if they have the same number of properties and both the order and values of the properties match.
  • For Namespace objects, values are considered equal if the uri properties of both objects match.
  • For QName objects, values are considered equal if the uri properties of both objects match and the localName properties of both objects match.
  • Variables representing objects, arrays, and functions are compared by reference. Two such variables are equal if they refer to the same object, array, or function. Two separate arrays are never considered equal, even if they have the same number of elements.
If the data types of the operands do not match, the result is false except in the following circumstances:
  • The operands' values are undefined and null, in which case the result is true.
  • Automatic data type conversion converts the data types of String, Boolean, int, uint, and Number values to compatible types and the converted values are equal, in which case operands are considered equal.
  • One operand is of type XML with simple content (hasSimpleContent() == true), and after both operands are converted to strings with the toString() method, the resulting strings match.
  • One operand is of type XMLList, and either of the following conditions is true:
    • The length property of the XMLList object is 0, and the other object is undefined.
    • The length property of the XMLList object is 1, and one element of the XMLList object matches the other operand.

Operands
expression1:Object — A number, string, Boolean value, variable, object, array, or expression.
expression2:Object — A number, string, Boolean value, variable, object, array, or expression.

Result
Boolean — A value of true if the expressions are equal, and false otherwise.

Example
The following example uses the equality (==) operator with an if statement:
var a:String = "David"
var b:String = "David";
if (a == b) {
    trace("David is David");
}
The following examples show how the equality operator does automatic type conversion when comparing by value. String values are converted to numbers:
var a:Number = 5;
var b:String = "5";
trace(a == b); // true
Boolean values are converted to numbers, where true is converted to 1 and false is converted to 0:
var c:Number = 1;
var d:Boolean = true;
trace(c == d); // true
var e:Number = 0;
var f:Boolean = false;
trace(e == f); // true
However, string values are not converted to Boolean values, so the following returns false:
var g:String = "true";
var h:Boolean = true;
trace(g == h); // false
The following examples show comparison by reference. The first example compares two arrays with identical length and elements. The equality operator returns false for these two arrays. Although the arrays appear equal, comparison by reference requires that both firstArray and secondArray refer to the same array. The second example creates the thirdArray variable, which points to the same array as firstArray. The equality operator returns true for these two arrays because the two variables refer to the same array.
var firstArray:Array = new Array("one", "two", "three");
var secondArray:Array = new Array("one", "two", "three");
trace(firstArray == secondArray); // false
/* Arrays are only considered equal
if the variables refer to the same array. */
var thirdArray:Array = firstArray;
trace(firstArray == thirdArray); // true

See also

!= (inequality)
&& (logical AND)
! (logical NOT)
|| (logical OR)
=== (strict equality)
!== (strict inequality)
Operators
Operators
> greater than operator
Usage
expression1 > expression2

Compares two expressions and determines whether expression1 is greater than expression2; if it is, the result is true. If expression1 is less than or equal to expression2, the result is false.

If both operands are of type String, the operands are compared using alphabetical order; all capital letters come before lowercase letters. Otherwise, operands are first converted to numbers, then compared.

Operands
expression1:Object — A string, integer, or floating-point number.
expression2:Object — A string, integer, or floating-point number.

Result
Boolean — A value of true if expression1 is greater than expression2; false otherwise.

Example
The following example shows that strings are compared alphabetically, with capital letters before lowercase letters:
var a:String = "first";
var b:String = "First";
trace(a > b); // true
The following example shows how String and Boolean values are converted to numbers:
var c:Number = 5;
var d:String = "4";
trace(c > d); // true

var e: Number = 2;
var f:Boolean = true;
trace(e > f); // true

>= greater than or equal to operator
Usage
expression1 >= expression2

Compares two expressions and determines whether expression1 is greater than or equal to expression2 (true) or expression1 is less than expression2 (false).

Operands
expression1:Object — A string, integer, or floating-point number.
expression2:Object — A string, integer, or floating-point number.

Result
Boolean — A value of true if expression1 is greater than or equal to expression2; false otherwise.

Example
In the following example, the greater than or equal to (>=) operator is used to determine whether the current hour is greater than or equal to 12:
if (new Date().getHours() >= 12) {
    trace("good afternoon");
} else {
    trace("good morning");
}

See also

> (greater than)
in operator
Usage
expression1 in expression2

Evaluates whether a property is part of a specific object. To use the in operator, specify a property name as the first operand and an object as the second operand. If the object you specify contains such a property, the result is true; otherwise the result is false.

If the specified object is an Array object, you can use the in operator to check whether a particular index number is valid. If you pass an integer as the first operand, the result is true if the index is within the valid range of index numbers, and false otherwise.

Result
Boolean — A value of true if expression1 is a property of the object represented by expression2, and false otherwise.

Example
The following example uses the in operator to show that PI is a property of the Math object, but that myProperty is not.
trace("PI" in Math);         // true
trace("myProperty" in Math); // false

The following example uses the in operator to show that the numbers 0, 1, and 2 are valid index numbers in the myArray object, but that the number 3 is not.

public var myArray:Array = ["zero", "one", "two"];
trace(0 in myArray); // true
trace(1 in myArray); // true
trace(2 in myArray); // true
trace(3 in myArray); // false

See also

instanceof
++ increment operator
Usage
++expression
 expression++

Adds 1 to an expression. The expression can be a variable, an element in an array, or a property of an object. The pre-increment form of the operator (++expression) adds 1 to expression and returns the result. The post-increment form of the operator (expression++) adds 1 to expression and returns the initial value of expression (the value prior to the addition).

Operands
expression:Number — A number or a variable that evaluates to a number.

Result
Number — The result of the increment.

Example
The following example uses ++ as a pre-increment operator in a while loop to show that the value added to the array is the value that has been incremented:
var preInc:Array = new Array();
var i:int = 0;
while (i < 10) {
    preInc.push(++i);
}
trace(preInc); // 1,2,3,4,5,6,7,8,9,10
The following example uses ++ as a post-increment operator in a whileloop to show that the value added to the array is the initial value:

var postInc:Array = new Array();
var i:int = 0;
while (i < 10) {
   postInc.push(i++);
}
trace(postInc); // 0,1,2,3,4,5,6,7,8,9
The following example uses ++ as a post-increment operator to make a whileloop run five times:
var i:int = 0;
while (i++ < 5) {
    trace("this is execution " + i);
}
/* output:
   this is execution 1
   this is execution 2
   this is execution 3
   this is execution 4
   this is execution 5
*/

See also

Operators
Operators
!= inequality operator
Usage
expression1 != expression2

Tests for the exact opposite of the equality (==) operator. If expression1 is equal to expression2, the result is false. As with the equality (==) operator, the definition of equal depends on the data types being compared.

If the data types of the two operands match, the definition of equal depends on the data type of the operands:

  • Values of type int, uint, and Boolean are considered equal if they have the same value.
  • Numbers with matching values are considered equal, unless they are both NaN.
  • If the value of both operands is null or undefined, they are considered equal.
  • String expressions are equal if they have the same number of characters and the characters are identical.
  • For XML objects:
    • If one operand is a text or attribute node and the other has simple content, both operands are converted to strings with the toString() method and are considered equal if the resulting strings match.
    • Otherwise, objects are considered equal only if the qualified name, attributes, and child properties for both objects match.
  • XMLList objects are considered equal if they have the same number of properties and both the order and values of the properties match.
  • For Namespace objects, values are considered equal if the uri properties of both objects match.
  • For QName objects, values are considered equal if the uri properties of both objects match and the localName properties of both objects match.
  • Variables representing objects, arrays, and functions are compared by reference. Two such variables are equal if they refer to the same object, array, or function. Two separate arrays are never considered equal, even if they have the same number of elements.
If the data types of the operands do not match, the inequality operator (!=) returns true except in the following circumstances:
  • The operands' values are undefined and null, in which case the result is true.
  • Automatic data type conversion converts the data types of String, Boolean, int, uint, and Number values to compatible types and the converted values are equal, in which case operands are considered equal.
  • One operand is of type XML with simple content (hasSimpleContent() == true), and after both operands are converted to strings with the toString() method the resulting strings match.
  • One operand is of type XMLList, and either of the following conditions is true:
    • The length property of the XMLList object is 0, and the other object is undefined.
    • The length property of the XMLList object is 1, and one element of the XMLList object matches the other operand.

Operands
expression1:Object — A number, string, Boolean value, variable, object, array, or function.
expression2:Object — A number, string, Boolean value, variable, object, array, or function.

Result
Boolean — A value of true if the expressions are not equal, and false otherwise.

Example
The following example illustrates the result of the inequality (!=) operator:
trace(5 != 8); // true
trace(5 != 5); // false
The following example illustrates the use of the inequality (!=) operator in an if statement:
var a:String = "David";
var b:String = "Fool";
if (a != b) {
    trace("David is not a fool");
}
The following example illustrates comparison by reference with two functions:
var a:Function = function() { trace("foo"); };
var b:Function = function() { trace("foo"); };
a(); // foo
b(); // foo
trace(a != b); // true
a = b;
a(); // foo
b(); // foo
trace(a != b); // false
The following example illustrates comparison by reference with two arrays:
var a:Array = [ 1, 2, 3 ];
var b:Array = [ 1, 2, 3 ];
trace(a);      // 1,2,3
trace(b);      // 1,2,3
trace(a != b); // true
a = b;
trace(a);      // 1,2,3
trace(b);      // 1,2,3
trace(a != b); // false

See also

== (equality)
&& (logical AND)
! (logical NOT)
|| (logical OR)
=== (strict equality)
!== (strict inequality)
Operators
Operators
instanceof operator
Usage
expression instanceof function

Evaluates whether an expression's prototype chain includes the prototype object for function. The instanceof operator is included for backward compatibility with ECMAScript edition 3, but may be useful for advanced programmers who choose to use the prototype chain. To check whether an object is a member of a specific data type, us the is operator.

Note: The ActionScript is operator is the equivalent of the Java instanceof operator.

Operands
expression:Object — The object that contains the prototype chain to evaluate.
function:Object — A function object (or class).

Result
Boolean — Returns true if the prototype chain of expression includes the prototype object for function, and false otherwise.

Example
The following example creates an instance of the Sprite class named mySprite and uses the instanceof operator to test whether the prototype chain of mySprite includes the prototype objects of the Sprite and DisplayObject classes. The result is true with the Sprite class, because the prototype object for Sprite is on the prototype chain of mySprite. The result is false with the DisplayObject class even though Sprite inherits from DisplayObject, because inheritance is no longer implemented using the prototype chain.
var mySprite:Sprite = new Sprite();
trace(mySprite instanceof Sprite);        // true
trace(mySprite instanceof DisplayObject); // false

See also

is
prototype
is operator
Usage
expression1 is expression2

Evaluates whether an object is compatible with a specific data type, class, or interface. Use the is operator instead of the instanceof operator for type comparisons. You can also use the is operator to check whether an object implements an interface.

Result
Boolean — A value of true if expression1 is compatible with the data type, class, or interface specified in expression2, and false otherwise.

Example
The following example creates an instance of the Sprite class named mySprite and uses the is operator to test whether mySprite is an instance of the Sprite and DisplayObject classes, and whether it implements the IEventDispatcher interface.
import flash.display.*;
import flash.events.IEventDispatcher;

var mySprite:Sprite = new Sprite();
trace(mySprite is Sprite);           // true
trace(mySprite is DisplayObject);    // true
trace(mySprite is IEventDispatcher); // true

See also

as
instanceof
< less than operator
Usage
expression1 < expression2

Compares two expressions and determines whether expression1 is less than expression2; if so, the result is true. If expression1 is greater than or equal to expression2, the result is false.

If both operands are of type String, the operands are compared using alphabetical order; all capital letters come before lowercase letters. Otherwise, operands are first converted to numbers, then compared.

Operands
expression1:Object — A string, integer, or floating-point number.
expression2:Object — A string, integer, or floating-point number.

Result
Boolean — A value of true if expression1 is less than expression2; false otherwise.

Example
The following examples show true and false results for both numeric and string comparisons:
trace(5 < 10); // true
trace(2 < 2);            // false
trace(10 < 3);           // false
trace("Allen" < "Jack"); // true
trace("Jack" < "Allen"); // false
trace("11" < "3");       // true
trace("11" < 3);         // false (numeric comparison)
trace("C" < "abc");      // true
trace("A" < "a");        // true

<= less than or equal to operator
Usage
expression1 <= expression2

Compares two expressions and determines whether expression1 is less than or equal to expression2; if it is, the result is true. If expression1 is greater than expression2, the result is false.

If both operands are of type String, the operands are compared using alphabetical order; all capital letters come before lowercase letters. Otherwise, operands are first converted to numbers, then compared.

Operands
expression1:Object — A string, integer, or floating-point number.
expression2:Object — A string, integer, or floating-point number.

Result
Boolean — A value of true if expression1 is less than or equal to expression2; false otherwise.

Example
The following examples show true and false results for both numeric and string comparisons:
trace(5 <= 10); // true
trace(2 <= 2);            // true
trace(10 <= 3);           // false
trace("Allen" <= "Jack"); // true
trace("Jack" <= "Allen"); // false
trace("11" <= "3");       // true
trace("11" <= 3);         // false (numeric comparison)
trace("C" <= "abc");      // true
trace("A" <= "a");        // true

// line comment delimiter operator
Usage
// comment

Indicates the beginning of a script comment. Characters that appear between the comment delimiter (//) and the end-of-line character are interpreted as a comment and are ignored. Use this delimiter for single-line comments; for comments on multiple successive lines, use the /* and */ delimiters.

Operands
comment:* — Any characters.

Example
The following example shows a single-line comment:
// Any text following a line comment delimiter is ignored during compilation

See also

/*..*/ (block comment delimiter)
&& logical AND operator
Usage
expression1 && expression2

Returns expression1 if it is false or can be converted to false, and expression2 otherwise. Examples of values that can be converted to false are 0, NaN, null, and undefined. If you use a function call as expression2, the function is not called if expression1 evaluates to false.

If both operands are of type Boolean, the result is true only if both operands are true, as shown in the following table:

Expression | Evaluates
true && true | true
true && false | false
false && false | false
false && true | false

Operands
expression1:* — A value or expression of any type.
expression2:* — A value of expression of any type.

Result
* — A Boolean value if both operands are of type Boolean. Otherwise, the result is the value of either expression.

Example
The following example uses the logical AND (&&) operator to perform a test to determine if a player has won the game. The turns variable and the score variable are updated when a player takes a turn or scores points during the game. The script outputs "You Win the Game!" when the player's score reaches 75 or higher in three or fewer turns.
var turns:Number = 2;
var score:Number = 77;
if ((turns <= 3) && (score >= 75)) {
    trace("You Win the Game!");
} else {
    trace("Try Again!");
}

See also

== (equality)
!= (inequality)
! (logical NOT)
|| (logical OR)
=== (strict equality)
!== (strict inequality)
! logical NOT operator
Usage
!expression

Inverts the Boolean value of a variable or expression. If expression is a variable with the absolute or converted value true, the value of !expression is false. If the expression x && y evaluates to false, the expression !(x && y) evaluates to true.

The following expressions illustrate the result of using the logical NOT (!) operator:

!true returns false
!false returns true

Operands
expression:Boolean — An expression or a variable that evaluates to a Boolean value.

Result
Boolean — The Boolean result of the logical operation.

Example
In the following example, the variable happy is set to false. The if condition evaluates the condition !happy, and if the condition is true, the trace() statement outputs a string.
var happy:Boolean = false;
if (!happy) {
    trace("don't worry, be happy"); // don't worry, be happy
}
The trace statement executes because !false equals true.

See also

== (equality)
!= (inequality)
&& (logical AND)
|| (logical OR)
=== (strict equality)
!== (strict inequality)
|| logical OR operator
Usage
expression1 || expression2

Returns expression1 if it is true or can be converted to true, and expression2 otherwise. If you use a function call as expression2, the function is not called if expression1 evaluates to true.

If both operands are of type Boolean, the result is true if either or both expressions are true; the result is false only if both expressions are false, as shown in the following table:

Expression | Evaluates
true || true | true
true || false | true
false || false | false
false || true | true

Operands
expression1:* — A value of any type.
expression2:* — A value of any type.

Result
* — A Boolean value if both operands are members of the Boolean data type. Otherwise, the result will be the value of either of the two expressions.

Example
The following example uses the logical OR (||) operator in an if statement. The second expression evaluates to true, so the final result is true:
var a:Number = 10;
var b:Number = 250;
var start:Boolean = false;
if ((a > 25) || (b > 200) || (start)) {
    trace("the logical OR test passed"); // the logical OR test passed
}
The message "the logical OR test passed" appears because one of the conditions in the if statement is true (b > 200).

The following example demonstrates how using a function call as the second operand can lead to unexpected results. If the expression on the left of the operator evaluates to true, that result is returned without evaluating the expression on the right (the function fx2() is not called).

function fx1():Boolean {
    trace("fx1 called");
    return true;
}
function fx2():Boolean {
    trace("fx2 called");
    return true;
}
if (fx1() || fx2()) {
    trace("IF statement entered");
}

See also

== (equality)
!= (inequality)
&& (logical AND)
! (logical NOT)
=== (strict equality)
!== (strict inequality)
% modulo operator
Usage
expression1 % expression2

Calculates the remainder of expression1 divided by expression2. If either operand is non-numeric, the modulo (%) operator attempts to convert it to a number.

The sign of the modulo result matches the sign of the dividend (the first number). For example, -4 % 3 and -4 % -3 both evaluate to -1.

Operands
expression1:Number — A number or expression that evaluates to a number. A string that contains only numeric characters evaluates to a number.
expression2:Number — A number or expression that evaluates to a number. A string that contains only numeric characters evaluates to a number.

Result
Number — The result of the arithmetic operation.

Example
The following numeric example uses the modulo (%) operator:
trace(12 % 5);    // 2
trace(4.3 % 2.1); // 0.0999999999999996
trace(4 % 4);     // 0
The first trace returns 2, rather than 12/5 or 2.4, because the modulo (%) operator returns only the remainder. The second trace returns 0.0999999999999996 instead of the expected 0.1 because of the limitations of floating-point accuracy in binary computing.

See also

/ (division)
Math.round()
Operators
Operators
%= modulo assignment operator
Usage
expression1 %= expression2

Assigns expression1 the value of expression1 % expression2. The following two statements are equivalent:

x %= y;
x = x % y;

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
Number — The result of the arithmetic operation.

Example
The following example assigns the value 4 to the variable a:
var a:Number = 14;
var b:Number = 5;
a %= b;
trace(a); // 4

See also

% (modulo)
* multiplication operator
Usage
expression1 * expression2

Multiplies two numerical expressions. If both expressions are integers, the product is an integer. If either or both expressions are floating-point numbers, the product is a floating-point number.

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
Number — An integer or floating-point number.

Example
The following statement multiplies the integers 2 and 3, resulting in the integer 6:
trace(2*3); // 6
This statement multiplies the floating-point numbers 2.0 and 3.1416, resulting in 6.2832, which is a floating-point number:
trace(2.0 * 3.1416); // 6.2832

See also

Operators
Operators
*= multiplication assignment operator
Usage
expression1 *= expression2

Assigns expression1 the value of expression1 * expression2. For example, the following two expressions are equivalent:

x *= y
x = x * y

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
Number — The value of expression1 * expression2 . If an expression cannot be converted to a numeric value, it returns NaN (not a number).

Example
The following example assigns the value 50 to the variable a:
var a:Number = 5;
var b:Number = 10;
trace(a *= b); // 50
The second and third lines of the following example calculate the expressions on the right side of the equal sign and assign the results to c and d:
var i:Number = 5;
var c:Number = 4 - 6;
var d:Number = i + 2;
trace(c *= d); // -14

See also

* (multiplication)
:: name qualifier operator
Usage
namespace::property
namespace::method()
namespace::xmlObject.property
namespace::xmlObject.@attribute

Identifies the namespace of a property, a method, an XML property, or an XML attribute.

Operands
namespace:Object — The identifying namespace.
propertyName:Object — The property, method, XML property, or XML attribute to identify.

Example
The following example uses the :: operator to identify two methods that have the same name in two different namespaces:
public class NamespaceExample extends Sprite {
    public namespace French;
    public namespace Hawaiian;
    public function NamespaceExample() {
        trace(Hawaiian::hello()); // aloha
        trace(French::hello()); // bonjour
    }
    Hawaiian function hello():String {
        return "aloha";
    }

    French function hello():String {
        return "bonjour";
    }
}
The following example uses the :: operator to identify XML properties with specified namespaces:
var soap:Namespace = new Namespace("http://schemas.xmlsoap.org/wsdl/soap/");
var w:Namespace = new Namespace("http://weather.example.org/forecast");
var myXML:XML =
    <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/">
     <soap:Body>
      <w:forecast xmlns:w="http://weather.example.org/forecast">
       <w:city>Quito</w:city>
       <w:country>Ecuador</w:country>
       <date>2006-01-14</date>
      </w:forecast>
      </soap:Body>
    </soap:Envelope>;

trace(myXML.soap::Body.w::forecast.w::city); // Quito

See also

Namespace class
XML class
new operator
Usage
new constructor(parameters)

Instantiates a class instance. The new operator can be used with a class or a variable of type Class to create an instance of a class. The new operator is commonly used with a class object to create an instance of a class. For example, the statement new Sprite() creates an instance of the Sprite class.

The new operator can also be used to associate a class with an embedded asset, which is an external object such as an image, sound, or font that is compiled into a SWF file. Each embedded asset is represented by a unique embedded asset class. To access an embedded asset, you must use the new operator to instantiate its associated class. Subsequently, you can call the appropriate methods and properties of the embedded asset class to manipulate the embedded asset.

If you prefer to define classes with Function objects instead of the class keyword, you can use the new operator to create objects based on constructor functions. Do not confuse constructor functions with constructor methods of a class. A constructor function is a Function object that is defined with the function keyword, but that is not part of a class definition. If you use constructor functions to create objects, you must use prototype inheritance instead of class inheritance.

Operands
constructor:* — A class, a function, or a variable that holds a value of type Class.
parameters:* — One or more parameters, separated by commas.

Example
The following example creates the Book class and uses the new operator to create the objects book1 and book2.
class Book {
  var bName:String;
  var bPrice:Number;

  public function Book(nameParam:String, priceParam:Number){
    bName = nameParam;
    bPrice = priceParam;
  }
}

var book1:Book = new Book("Confederacy of Dunces", 19.95);
var book2:Book = new Book("The Floating Opera", 10.95);
trace(book1); // [object Book]
The following example uses the new operator to create an instance of the Array class with 18 elements:
var golfCourse:Array = new Array(18);

See also

[] (array access)
class statement
Object.constructor
Object.prototype
{} (object initializer)
Methods
Advanced topics
{} object initializer operator
Usage
object = {name1 : value1, name2 : value2,... nameN : valueN}

Creates a new object and initializes it with the specified name and value property pairs. Using this operator is the same as using the new Object syntax and populating the property pairs using the assignment operator. The prototype of the newly created object is generically named the Object object.

This operator is also used to mark blocks of contiguous code associated with flow control statements (for, while, if, else, switch) and functions.

Operands
object:Object — The object to create.
name1,2,...N:Object — The names of the properties.
value1,2,...N:Object — The corresponding values for each name property.

Result
Object — An Object object.

Example
The first line of the following code creates an empty object using the object initializer ({}) operator; the second line creates a new object using a constructor function:
var object:Object = {};
var object:Object = new Object();
The following example creates an object account and initializes the properties name, address, city, state, zip, and balance with accompanying values:
var account:Object = {name:"Adobe Systems, Inc.", address:"601 Townsend Street", city:"San Francisco", state:"California", zip:"94103", balance:"1000"};
for (i in account) {
    trace("account."+i+" = "+account[i]);
}
The following example shows how array and object initializers can be nested within each other:
var person:Object = {name:"Gina Vechio", children:["Ruby", "Chickie", "Puppa"]};
The following code uses the information in the previous example and produces the same result using a constructor function:
var person:Object = new Object();
person.name = "Gina Vechio";
person.children = new Array();
person.children[0] = "Ruby";
person.children[1] = "Chickie";
person.children[2] = "Puppa";

See also

braces (XML)
Object class
() parentheses operator
Usage
(expression1[, expression2])
(expression1, expression2)
function(parameter1,..., parameterN)

Performs a grouping operation on one or more parameters, performs sequential evaluation of expressions, or surrounds one or more parameters and passes them as arguments to a function that precedes the parentheses.

Usage 1: Controls the order in which the operators execute. Parentheses override the normal precedence order and cause the expressions within the parentheses to be evaluated first. When parentheses are nested, the contents of the innermost parentheses are evaluated before the contents of the outer ones.

Usage 2: Evaluates a series of expressions, separated by commas, in sequence, and returns the result of the final expression.

Usage 3: Surrounds one or more parameters and passes them to the function that precedes the parentheses.

Operands
expression1:Object — An expression, which can include numbers, strings, variables, or text.
expression2:Object — An expression, which can include numbers, strings, variables, or text.
function:Function — The function to be performed on the contents of the parentheses.
parameter1...parameterN:Object — A series of parameters to execute before the results are passed as arguments to the function outside the parentheses.

Example
Usage 1: The following statements show the use of parentheses to control the order in which expressions are executed:
trace((2 + 3) * (4 + 5)); // 45
trace(2 + (3 * (4 + 5))); // 29
trace(2 + (3 * 4) + 5);   // 19
trace(2 + (3 * 4) + 5);   // 19
Usage 2: The following example evaluates the function foo() and then the function bar(), and returns the result of the expression a + b:
var a:Number = 1;
var b:Number = 2;
function foo() {
  a += b;
}
function bar() {
  b *= 10;
}
trace((foo(), bar(), a + b)); // 23
Usage 3: The following example shows the use of parentheses with functions:
var today:Date = new Date();
trace(today.getFullYear()); // outputs current year
function traceParameter(param):void {
  trace(param);
}
traceParameter(2 * 2); // 4

See also

parentheses (XML)
with
Operators
Operators
( ) parentheses (XML) operator
Usage
myXML.(expression)

Evaluates an expression in an ECMAScript for XML (E4X) XML construct. For example, myXML.(lastName == "Smith") identifies XML elements with the name lastName and the value "Smith". The result is an XMLList object.

Operands
myXML:* — An XML or XMLList object.
expression:* — The expression defining the matching elements.

Result
XMLList — The XMLList specified by the parentheses.

Example
The following example shows how parentheses are used to identify elements and attributes:
var myXML:XML =
    <employees>
        <employee id = "42">
            <firstName>Joe</firstName>
            <lastName>Smith</lastName>
        </employee>
        <employee id = "43">
            <firstName>Susan</firstName>
            <lastName>Jones</lastName>
        </employee>
        <employee id = "44">
            <firstName>Anne</firstName>
            <lastName>Smith</lastName>
        </employee>
    </employees>;

trace(myXML.employee.(lastName == "Smith").@id.toXMLString());
    // 42
    // 44

trace(myXML.employee.(Number(@id) > 42).@id.toXMLString());
    // 43
    // 44

See also

XML class
XMLList class
/ RegExp delimiter operator
Usage
/pattern/flags

When used before and after characters, indicates that the characters have a literal value and are considered a regular expression (RegExp), not a variable, string, or other ActionScript element. Note, however, that two sequential forward slash characters (//) indicate the beginning of a comment.

Operands
pattern:String — A sequence of one or more characters, defining the pattern of the regular expression.
flags:String — A sequence of zero or more of the following characters: g (for the global flag), i (for the ignoreCase flag), s (for the dotall flag), x (for the extended flag).

Example
The following example uses forward slash characters (/) to set the value of a variable of type RegExp (the i flag is set, to ignore case sensitivity when matching):
var myRegExp:RegExp = /foo-\d+/i;
trace(myRegExp.exec("ABC Foo-32 def.")); // Foo-32

See also

RegExp class
=== strict equality operator
Usage
expression1 === expression2

Tests two expressions for equality, but does not perform automatic data conversion. The result is true if both expressions, including their data types, are equal.

The strict equality (===) operator is the same as the equality (==) operator in three ways:

  • Numbers and Boolean values are compared by value and are considered equal if they have the same value.
  • String expressions are equal if they have the same number of characters and the characters are identical.
  • Variables representing objects, arrays, and functions are compared by reference. Two such variables are equal if they refer to the same object, array, or function. Two separate arrays are never considered equal, even if they have the same number of elements.
The strict equality (===) operator differs from the equality (==) operator in only two ways:
  • The strict equality operator performs automatic data conversion only for the number types (Number, int, and uint), whereas the equality operator performs automatic data conversion for all primitive data types.
  • When comparing null and undefined, the strict equality operator returns false.
The strict equality operator generates different results in ActionScript 3.0 than it did in ActionScript 2.0 in two situations involving primitive values (for example, var x:Number = 1) with primitive objects (for example, var x:Number = new Number(1)). This is because ActionScript 3.0 removes the distinction between primitive values and primitive wrapper objects.

First, comparisons between primitive values and primitive objects that contain the same value return true in ActionScript 3.0, but false in earlier versions. In earlier versions, the data type of a primitive value is either Boolean, Number, or String, whereas the data type of a primitive object is always Object rather than Boolean, Number or String. The practical effect of this difference is that the following code results in false in previous versions of ActionScript because the data types of the operands do not match, but the result is true in ActionScript 3.0 because primitive values are typed as either Boolean, Number, int, uint, or String, whether they are wrapped in an object or not.

var num1:Number = 1;
var num2:Number = new Number(1);
trace(num1 === num2); // true in ActionScript 3.0, false in ActionScript 2.0
Second, comparisons between two primitive objects that contain the same value result in true in ActionScript 3.0, but false in previous versions.
var num1:Number = new Number(1);
var num2:Number = new Number(1);
trace(num1 == num2);  // true in ActionScript 3.0, false in ActionScript 2.0
trace(num1 === num2); // true in ActionScript 3.0, false in ActionScript 2.0
This is because in previous versions of ActionScript, both variables belong to the data type Object, so they are compared by reference and the result is false for both the equality and strict equality operations. In ActionScript 3.0, however, both variables belong to the data type Number, so they are compared by value and the result is true for both the equality and strict equality operators.

Operands
expression1:Object — A number, string, Boolean value, variable, object, array, or function.
expression2:Object — A number, string, Boolean value, variable, object, array, or function.

Result
Boolean — The Boolean result of the comparison.

Example
The following example shows that strict equality (===) is the same as equality (==) when both the value and data types match:
var string1:String = "5";
var string2:String = "5";
trace(string1 == string2);  // true
trace(string1 === string2); // true
The following example shows that the strict equality operator does not convert the String data type to Number, but the equality (==) operator does:
// The equality (==) operator converts 5 to "5", but the strict equality operator does not
var string1:String = "5";
var num:Number = 5;
trace(string1 == num);  // true
trace(string1 === num); // false
The following example shows that the strict equality operator does not convert Boolean values to numbers, but the equality operator does:
var num:Number = 1;
var bool:Boolean = true;
trace(num == bool);  // true
trace(num === bool); // false
The following example shows that the strict equality operator does convert int and uint data types:
var num1:Number = 1;
var num2:int = 1;
var num3:uint = 1;
trace(num1 === num2); // true
trace(num1 === num3); // true
The following example shows that the strict equality operator considers null and undefined not equal, but the equality operator considers them equal:
trace(null == undefined);  // true
trace(null === undefined); // false

See also

== (equality)
!= (inequality)
&& (logical AND)
! (logical NOT)
|| (logical OR)
!== (strict inequality)
!== strict inequality operator
Usage
expression1 !== expression2

Tests for the exact opposite of the strict equality (===) operator. The strict inequality operator performs the same as the inequality operator except that only the int and uint data types are converted.

If expression1 is equal to expression2, and their data types are equal, the result is false.

The strict inequality (!==) operator is the same as the inequality (!=) operator in three ways:

  • Numbers and Boolean values are compared by value and are considered equal if they have the same value.
  • String expressions are equal if they have the same number of characters and the characters are identical.
  • Variables representing objects, arrays, and functions are compared by reference. Two such variables are equal if they refer to the same object, array, or function. Two separate arrays are never considered equal, even if they have the same number of elements.
The strict inequality operator differs from the inequality (!=) operator in only two ways:
  • The strict inequality (!==) operator performs automatic data conversion only for the number types, Number, int, and uint, whereas the inequality (!=) operator performs automatic data conversion for all primitive data types.
  • When comparing null and undefined, the strict inequality (!==) operator returns true.

Operands
expression1:Object — A number, string, Boolean value, variable, object, array, or function.
expression2:Object — A number, string, Boolean value, variable, object, array, or function.

Result
Boolean — The Boolean result of the comparison.

Example
The comments in the following code show the returned value of operations that use the equality (==), strict equality (===), and strict inequality (!==) operators:
var s1:String = "5";
var s2:String = "5";
var s3:String = "Hello";
var n:Number = 5;
var b:Boolean = true;
trace(s1 == s2);  // true
trace(s1 == s3);  // false
trace(s1 == n);   // true
trace(s1 == b);   // false
trace(s1 === s2); // true
trace(s1 === s3); // false
trace(s1 === n);  // false
trace(s1 === b);  // false
trace(s1 !== s2); // false
trace(s1 !== s3); // true
trace(s1 !== n);  // true
trace(s1 !== b);  // true

See also

== (equality)
!= (inequality)
&& (logical AND)
! (logical NOT)
|| (logical OR)
=== (strict equality)
" string delimiter operator
Usage
 "text"

When used before and after characters, indicates that the characters have a literal value and are considered a string, not a variable, numerical value, or other ActionScript element.

Operands
text:String — A sequence of zero or more characters.

Example
The following example uses quotation marks (") to indicate that the value of the variable yourGuess is the literal string "Prince Edward Island" and not the name of a variable.
var yourGuess:String = "Prince Edward Island";
submit_btn.onRelease = function() { trace(yourGuess); };
// Prince Edward Island

See also

String class
String() function
- subtraction operator
Usage
-expression
 expression1 - expression2

Used for negating or subtracting.

Usage 1: When used for negating, the operator reverses the sign of a numerical expression.
Usage 2: When used for subtracting, the operator performs an arithmetic subtraction on two numerical expressions, subtracting expression2 from expression1. When both expressions are integers, the difference is an integer. When either or both expressions are floating-point numbers, the difference is a floating-point number.

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
Number — An integer or floating-point number.

Example
Usage 1: The following statement reverses the sign of the expression 2 + 3:
trace(-(2 + 3)); // -5
Usage 2: The following statement subtracts the integer 2 from the integer 5:
trace(5 - 2); // 3
The result, 3, is an integer.

The following statement subtracts the floating-point number 1.5 from the floating-point number 3.25:

trace(3.25 - 1.5); // 1.75
The result, 1.75, is a floating-point number.

See also

Operators
Operators
-= subtraction assignment operator
Usage
expression1 -= expression2

Assigns expression1 the value of expression1 - expression2. For example, the following two statements are equivalent:

x -= y ;
x = x - y;

String expressions must be converted to numbers; otherwise, the result is NaN (not a number).

Operands
expression1:Number — A number or expression that evaluates to a number.
expression2:Number — A number or expression that evaluates to a number.

Result
Number — The result of the arithmetic operation.

Example
The following example uses the subtraction assignment (-=) operator to subtract 10 from 5 and assign the result to the variable x:
var x:Number = 5;
var y:Number = 10;
x -= y;
trace(x); // -5
The following example shows how strings are converted to numbers:
var x:String = "5";
var y:String = "10";
x -= y;
trace(x); // -5

See also

- (subtraction)
: type operator
Usage
[modifiers] var variableName:type
function functionName():type { ... }
function functionName(parameter1:type, ..., parameterN:type) [:type]{ ... }

Used for assigning a data type; this operator specifies the variable type, function return type, or function parameter type. When used in a variable declaration or assignment, this operator specifies the variable's type; when used in a function declaration or definition, this operator specifies the function's return type; when used with a function parameter in a function definition, this operator specifies the variable type expected for that parameter.

Type checking always occurs at run time. However, when the compiler is set to strict mode, all types are also checked at compile time, and errors are generated when there is a mismatch. Mismatches can occur during assignment operations, function calls, and class member dereferencing using the dot (.) operator.

Types that you can use include all native object types, classes and interfaces that you define, and void. The recognized native types are Boolean, Number, int, uint, and String. All built-in classes are also supported as native types.

If you do not assign a data type, the variable, function return value, or function parameter is considered untyped, which means that the value can be of any data type. If you wish to make clear your intent to use an untyped value, you can use the asterisk (*) character as the type annotation. When used as a type annotation, the asterisk character is equivalent to leaving a variable, function return type, or function parameter untyped.

Operands
variableName:* — An identifier for a variable.
type:* — A native data type, class name that you have defined, or interface name.
functionName:Function — An identifier for a function.
parameter:* — An identifier for a function parameter.

Example
Usage 1: The following example declares a public variable named userName whose type is String and assigns an empty string to it:
var userName:String = "";
Usage 2: The following example shows how to specify a function's return type by defining a function named randomInt() that specifies its return type as int:
function randomInt(integer:int):int {
    return Math.round(Math.random()*integer);
}
trace(randomInt(8));
Usage 3: The following example defines a function named squareRoot() that takes a parameter named val of the Number type and returns the square root of val, also a Number type:
function squareRoot(val:Number):Number {
    return Math.sqrt(val);
}
trace(squareRoot(121));

See also

function statement
var statement
Operators
Operators
typeof operator
Usage
typeof expression

Evaluates expression and returns a string specifying the expression's data type. The result is limited to six possible string values: boolean, function, number, object, string, and xml. If you apply this operator to an instance of a user-defined class, the result is the string object. The typeof operator is included for backward compatibility. Use the is operator to check type compatibility.

Operands
expression:Object — An object to evaluate.

Result
String — A string representation of the type of expression. The following table shows the results of the typeof operator on each type of expression.

Expression Type | Result
Array | object
Boolean | boolean
Function | function
int | number
Number | number
Object | object
String | string
uint | number
XML | xml
XMLList | xml

Example
The following example shows the result of using typeof on various objects and values.
trace(typeof Array); // object
trace(typeof Date);  // object
trace(typeof 3);     // number
The following example shows that in ActionScript 3.0, the data type of a primitive object is the same whether you assign a literal value or use the new operator to create an object. This differs from previous versions of ActionScript in which the typeof operator returns object for variable b:
var a:String = "sample";
var b:String = new String("sample");
trace(typeof a); // string
trace(typeof b); // string

See also

as
instanceof
is
void operator
Usage
void expression

Evaluates an expression and then discards its value, returning undefined. The void operator is often used in comparisons that use the == operator to test for undefined values.

Operands
expression:Object — An expression to be evaluated.

Result
* — The value undefined.

See also

Data type descriptions
< > XML literal tag delimiter operator
Usage
 myXML= <{tagName} {attributeName} = {attributeValue}>{content}</{tagName}>

Defines an XML tag in an XML literal. Use the forward slash / to define the closing tag.

Operands
myXML:* — An XML or XMLList object.
tagName:* — An expression that evaluates to the name of an XML tag.
attributeName:* — An expression that evaluates to the name of an XML attribute.
attributeValue:* — An expression that evaluates to the value of an XML attribute.
content:* — An expression that evaluates to the contents of an XML tag.

Example
The following example shows how to use the < and > operators when defining an XML literal:
var x:XML = <item id= "324">cola</item>;

See also

XML class
XMLList class


Statements, Keywords and Directives (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Statements, Keywords & Directives

Statements are language elements that perform or specify an action at runtime. For example, the return statement returns a result value for the function in which it executes. The if statement evaluates a condition to determine the next action that should be taken. The switch statement creates a branching structure for ActionScript statements.

Attribute keywords alter the meaning of definitions, and can be applied to class, variable, function, and namespace definitions. Definition keywords are used to define entities such as variables, functions, classes, and interfaces. Primary expression keywords represent literal values. For a list of reserved words, see Programming ActionScript 3.0.

Directives include statements and definitions and can have an effect at compile time or runtime. Directives that are neither statements nor definitions are labeled as directives in the following table.

See also

Syntax

Statement summary
break | Appears within a loop (for, for..in, for each..in, do..while, or while) or within a block of statements associated with a particular case within a switch statement.
case | Defines a jump target for the switch statement.
continue | Jumps past all remaining statements in the innermost loop and starts the next iteration of the loop as if control had passed through to the end of the loop normally.
default | Defines the default case for a switch statement.
do..while | Similar to a while loop, except that the statements are executed once before the initial evaluation of the condition.
else | Specifies the statements to run if the condition in the if statement returns false.
for | Evaluates the init (initialize) expression once and then starts a looping sequence.
for..in | Iterates over the dynamic properties of an object or elements in an array and executes statement for each property or element.
for each..in | Iterates over the items of a collection and executes statement for each item.
if | Evaluates a condition to determine the next statement to execute.
label | Associates a statement with an identifier that can be referenced by break or continue.
return | Causes execution to return immediately to the calling function.
super | Invokes the superclass or parent version of a method or constructor.
switch | Causes control to transfer to one of several statements, depending on the value of an expression.
throw | Generates, or throws, an error that can be handled, or caught, by a catch code block.
try..catch..finally | Encloses a block of code in which an error can occur, and then responds to the error.
while | Evaluates a condition and if the condition evaluates to true, executes one or more statements before looping back to evaluate the condition again.
with | Establishes a default object to be used for the execution of a statement or statements, potentially reducing the amount of code that needs to be written.
Attribute keyword summary
dynamic | Specifies that instances of a class may possess dynamic properties added at runtime.
final | Specifies that a method cannot be overridden or that a class cannot be extended.
internal | Specifies that a class, variable, constant or function is available to any caller within the same package.
native | Specifies that a function or method is implemented by Flash Player in native code.
override | Specifies that a method replaces an inherited method.
private | Specifies that a variable, constant, method or namespace is available only to the class that defines it.
protected | Specifies that a variable, constant, method, or namespace is available only to the class that defines it and to any subclasses of that class.
public | Specifies that a class, variable, constant or method is available to any caller.
static | Specifies that a variable, constant, or method belongs to the class, rather than to instances of the class.
Definition keyword summary
... (rest) parameter | Specifies that a function will accept any number of comma-delimited arguments.
class | Defines a class, which lets you instantiate objects that share methods and properties that you define.
const | Specifies a constant, which is a variable that can be assigned a value only once.
extends | Defines a class that is a subclass of another class.
function | Comprises a set of statements that you define to perform a certain task.
get | Defines a getter, which is a method that can be read like a property.
implements | Specifies that a class implements one or more interfaces.
interface | Defines an interface.
namespace | Allows you to control the visibility of definitions.
package | Allows you to organize your code into discrete groups that can be imported by other scripts.
set | Defines a setter, which is a method that appears in the public interface as a property.
var | Specifies a variable.
Directive summary
default xml namespace | The default xml namespace directive sets the default namespace to use for XML objects.
import | Makes externally defined classes and packages available to your code.
include | Includes the contents of the specified file, as if the commands in the file are part of the calling script.
use namespace | Causes the specified namespaces to be added to the set of open namespaces.
Namespace summary
AS3 | Defines methods and properties of the core ActionScript classes that are fixed properties instead of prototype properties.
flash_proxy | Defines methods of the Proxy class.
object_proxy | Defines methods of the ObjectProxy class.
Primary expression keyword summary
false | A Boolean value representing false.
null | A special value that can be assigned to variables or returned by a function if no data was provided.
this | A reference to a method's containing object.
true | A Boolean value representing true.
Statement, Keyword & Directive detail
... (rest) parameter definition keyword
Usage
function functionName(parameter0, parameter1, ...rest){
    // statement(s)
}

Specifies that a function will accept any number of comma-delimited arguments. The list of arguments becomes an array that is available throughout the function body. The name of the array is specified after the ... characters in the parameter declaration. The parameter can have any name that is not a reserved word.

If used with other parameters, the ... (rest) parameter declaration must be the last parameter specified. The ... (rest) parameter array is populated only if the number of arguments passed to the function exceeds the number of other parameters.

Each argument in the comma-delimited list of arguments is placed into an element of the array. If you pass an instance of the Array class, the entire array is placed into a single element of the ... (rest) parameter array.

Use of this parameter makes the arguments object unavailable. Although the ... (rest) parameter gives you the same functionality as the arguments array and arguments.length property, it does not provide functionality similar to that provided by arguments.callee. Make sure you do not need to use arguments.callee before using the ... (rest) parameter.

Parameters
rest:* — An identifier that represents the name of the array of arguments passed in to the function. The parameter does not need to be called rest; it can have any name that is not a keyword. You can specify the data type of the ... (rest) parameter as Array, but this could cause confusion because the parameter accepts a comma-delimited list of values, which is not identical to an instance of the Array class.

Example
The following example uses the ... (rest) parameter in two different functions. The first function, traceParams, simply calls the trace() function on each of the arguments in the rest array. The second function, average(), takes the list of arguments and returns the average. The second function also uses a different name, args, for the parameter.
package {
    import flash.display.MovieClip;

    public class RestParamExample extends MovieClip {
        public function RestParamExample() {
            traceParams(100, 130, "two"); // Output: 100,130,two
            trace(average(4, 7, 13));     // Output: 8
        }
    }
}

function traceParams(... rest) {
     trace(rest);
 }

function average(... args) : Number{
    var sum:Number = 0;
    for (var i:uint = 0; i < args.length; i++) {
        sum += args[i];
    }
    return (sum / args.length);
}

See also

arguments object
AS3 namespace

Defines methods and properties of the core ActionScript classes that are fixed properties instead of prototype properties. When you set the "-as3" compiler option to true (which is the default setting in Flex Builder 2), the AS3 namespace is automatically opened for all the core classes. This means that an instance of a core class will use fixed properties and methods instead of the versions of those same properties and methods that are attached to the class's prototype object. The use of fixed properties usually provides better performance, but at the cost of backward compatibility with the ECMAScript edition 3 language specification (ECMA-262).

See also

Object class
Advanced topics
break statement
Usage

break [label]

Appears within a loop (for, for..in, for each..in, do..while, or while) or within a block of statements associated with a particular case in a switch statement. When used in a loop, the break statement instructs Flash to skip the rest of the loop body, stop the looping action, and execute the statement following the loop statement. When used in a switch, the break statement instructs Flash to skip the rest of the statements in that case block and jump to the first statement that follows the enclosing switch statement.

In nested loops, break only skips the rest of the immediate loop and does not break out of the entire series of nested loops. To break out of an entire series of nested loops, use label or try..catch..finally.

The break statement can have an optional label that must match an outer labeled statement. Use of a label that does not match the label of an outer statement is a syntax error. Labeled break statements can be used to break out of multiple levels of nested loop statements, switch statements, or block statements. For an example, see the entry for the label statement.

Parameters
label:* — The name of a label associated with a statement.

Example
The following example uses break to exit an otherwise infinite loop:
var i:int = 0;
while (true) {
    trace(i);
    if (i >= 10) {
        break; // this will terminate/exit the loop
    }
    i++;
}
/* output:
0
1
2
3
4
5
6
7
8
9
10*/

See also

do..while
for
for..in
for each..in
label
while
case statement
Usage
case jumpTarget: statements

Defines a jump target for the switch statement. If the jumpTarget parameter equals the expression parameter of the switch statement using strict equality (===), Flash Player executes the statements in the statements parameter until it encounters a break statement or the end of the switch statement.

If you use the case statement outside a switch statement, it produces an error and the script doesn't compile.

Note: Always end the statements parameter with a break statement. If you omit the break statement from the statements parameter, it continues executing with the next case statement instead of exiting the switch statement.

Parameters
jumpTarget:* — Any expression.
statements:* — Statements to execute if jumpTarget matches the conditional expression in the switch statement.

Example
The following example defines jump targets for the switch statement thisMonth. If thisMonth equals the expression in the case statement, the statement executes.
var thisMonth:int = new Date().getMonth();
switch (thisMonth) {
    case 0 :
        trace("January");
        break;
    case 1 :
        trace("February");
        break;
    case 5 :
    case 6 :
    case 7 :
        trace("Some summer month");
        break;
    case 8 :
        trace("September");
        break;
    default :
        trace("some other month");
}

See also

break
switch
class definition keyword
Usage
[dynamic] [public | internal] [final] class className [ extends superClass ] [ implements interfaceName[, interfaceName... ] ] {
    // class definition here
}

Defines a class, which lets you instantiate objects that share methods and properties that you define. For example, if you are developing an invoice-tracking system, you could create an Invoice class that defines all the methods and properties that each invoice should have. You would then use the new Invoice() command to create Invoice objects.

Each ActionScript source file can contain only one public class. If you include other classes in the same file that are not public, the public class must be placed below all the other classes. The name of the last class in the file must match the name of the ActionScript source file that contains the class. The name of the source file must be the name of the class with the file extension .as appended. For example, if you name a class Student, the file that defines the class must be named Student.as.

You cannot nest class definitions; that is, you cannot define additional classes within a class definition.

To indicate that objects can add and access dynamic properties at runtime, precede the class statement with the dynamic keyword. To declare that a class implements an interface, use the implements keyword. To create subclasses of a class, use the extends keyword. (A class can extend only one class, but can implement several interfaces.) You can use implements and extends in a single statement. The following examples show typical uses of the implements and extends keywords:

class C implements Interface_i, Interface_j // OK
class C extends Class_d implements Interface_i, Interface_j // OK
class C extends Class_d, Class_e // not OK

Parameters
className:Class — The fully qualified name of the class.

Example
The following example creates a class called Plant. The Plant constructor takes two parameters.
// Filename Plant.as
package {
  public class Plant {
    // Define property names and types
    private var _leafType:String;
    private var _bloomSeason:String;
    // Following line is constructor
    // because it has the same name as the class
    public function Plant(param_leafType:String, param_bloomSeason:String) {
        // Assign passed values to properties when new Plant object is created
        _leafType = param_leafType;
        _bloomSeason = param_bloomSeason;
    }
    // Create methods to return property values, because best practice
    // recommends against directly referencing a property of a class
    public function get leafType():String {
        return _leafType;
    }
    public function get bloomSeason():String {
        return _bloomSeason;
    }
  }
}
In your script, use the new operator to create a Plant object.
var pineTree:Plant = new Plant("Evergreen", "N/A");
// Confirm parameters were passed correctly
trace(pineTree.leafType);
trace(pineTree.bloomSeason);

See also

dynamic
extends
final
internal
public
Classes
Advanced topics
const definition keyword
Usage
const identifier = value

Specifies a constant, which is a variable that can be assigned a value only once.

You can strictly type a constant by appending a colon (:) character followed by the data type.

Parameters
identifier:* — An identifier for the constant.

Example
The following example shows that an error occurs if you attempt to assign a value to a constant more than once.
const MIN_AGE:int = 21;
MIN_AGE = 18; // error
The following example shows that if the constant is an array, you can still call Array class methods, including Array.push(). However, you cannot assign a new array literal.
const product_array:Array = new Array("Studio", "Dreamweaver", "Flash", "ColdFusion", "Contribute", "Breeze");
product_array.push("Flex"); // array operations are allowed
product_array = ["Other"];  // assignment is an error
trace(product_array);

See also

var
Variables
Methods
continue statement
Usage
continue [label]

Jumps past all remaining statements in the innermost loop and starts the next iteration of the loop as if control had passed to the end of the loop normally. The continue statement has no effect outside a loop. In nested loops, use the optional label parameter to skip more than just the innermost loop.

The continue statement can have an optional label that must match an outer labeled statement. Use of a label that does not match the label of an outer statement is a syntax error. Labeled continue statements can be used to skip multiple levels of nested loop statements.

Example
In the following while loop, the continue statement is used to skip the rest of the loop body whenever a multiple of 3 is encountered and jump to the top of the loop, where the condition is tested:
var i:int = 0;
while (i < 10) {
    if (i % 3 == 0) {
        i++;
        continue;
    }
    trace(i);
    i++;
}

In a for loop, the continue statement can also be used to skip the rest of the loop body. In the following example, if the i % 3 equals 0, the trace(i) statement is skipped:

for (var i:int = 0; i < 10; i++) {
    if (i % 3 == 0) {
        continue;
    }
    trace(i);
}

See also

do..while
for
for..in
for each..in
label
while
default statement
Usage
default: statements

Defines the default case for a switch statement. The statements execute if the expression parameter of the switch statement doesn't equal (using the strict equality [===] operation) any of the expression parameters that follow the case keywords for a given switch statement.

A switch statement does not require a default case statement. A default case statement does not have to be last in the list. If you use a default statement outside a switch statement, it produces an error and the script doesn't compile.

Parameters
statements:* — Any statements.

Example
In the following example, if the day of the week is Saturday or Sunday, none of the case statements apply, so execution moves to the default statement.
var dayOfWeek:int = new Date().getDay();
switch (dayOfWeek) {
    case 1 :
        trace("Monday");
        break;
    case 2 :
        trace("Tuesday");
        break;
    case 3 :
        trace("Wednesday");
        break;
    case 4 :
        trace("Thursday");
        break;
    case 5 :
        trace("Friday");
        break;
    default :
        trace("Weekend");
}

See also

switch
default xml namespace directive
Usage

default xml namespace = ns

The default xml namespace directive sets the default namespace to use for XML objects.

If you do not set default xml namespace, the default namespace is the unnamed namespace (with the URI set to an empty string). The scope of a default xml namespace declaration is within a function block, like the scope of a variable.

Example
The following example shows that the scope of default xml namespace is a function block:
var nsDefault1:Namespace = new Namespace("http://www.example.com/namespaces/");
default xml namespace = nsDefault1;

var x1:XML = <test1 />;
trace("x1 ns: " + x1.namespace());

scopeCheck();

var x2:XML = <test2 />;
trace("x2 ns: " + x2.namespace());

function scopeCheck(): void {

    var x3:XML = <test3 />;
    trace("x3 ns: " + x3.namespace());

    var nsDefault2:Namespace = new Namespace("http://schemas.xmlsoap.org/soap/envelope/");
    default xml namespace = nsDefault2;

    var x4:XML = <test4 />;
    trace("x4 ns: " + x4.namespace());

}

The trace() output for this example is the following:

x1 ns: http://www.example.com/namespaces/
x3 ns:
x4 ns: http://schemas.xmlsoap.org/soap/envelope/
x2 ns: http://www.example.com/namespaces/
The following example uses default xml namespace to assign the default namespace. The second XML object (x2) does not use this setting because x2 defines its own default namespace:
var nsDefault:Namespace = new Namespace("http://www.example.com/namespaces/");
default xml namespace = nsDefault;

var x1:XML = <test1 />;

trace(x1.namespace());
    // http://www.example.com/namespaces/

var x2:XML = <test2 xmlns = "http://www.w3.org/1999/XSL/Transform/" />;
trace(x2.namespace());
    // http://www.w3.org/1999/XSL/Transform/

var x3:XML = <test3 xmlns:soap-env="http://schemas.xmlsoap.org/soap/envelope/" />;
trace(x3.namespace());
    // http://www.example.com/namespaces/

See also

namespace
Namespace Class
use namespace
XML
do..while statement
Usage
do { statement(s) } while (condition)

Similar to a while loop, except that the statements are executed once before the initial evaluation of the condition. Subsequently, the statements are executed only if the condition evaluates to true.

A do..while loop ensures that the code inside the loop executes at least once. Although you can also do this with a while loop by placing a copy of the statements to be executed before the while loop begins, many programmers believe that do..while loops are easier to read.

If the condition always evaluates to true, the do..while loop is infinite. If you enter an infinite loop, you encounter problems with Flash Player and eventually get a warning message or crash the player. Whenever possible, use a for loop if you know the number of times you want to loop. Although for loops are easy to read and debug, they cannot replace do..while loops in all circumstances.

Parameters
condition:Boolean — The condition to evaluate. The statement(s) within the do block of code will execute as long as the condition parameter evaluates to true .

Example
The following example uses a do..while loop to evaluate whether a condition is true, and traces myVar until myVar is 5 or greater. When myVar is 5 or greater, the loop ends.
var myVar:Number = 0;
do {
    trace(myVar);
    myVar++;
}
while (myVar < 5);
/* output:
0
1
2
3
4
*/

See also

break
continue
while
Looping
dynamic attribute keyword
Usage
dynamic class className { // class definition here }

Specifies that instances of a class may possess dynamic properties added at runtime. If you use the dynamic attribute on a class, you can add properties to instances of that class at runtime. Classes that are not marked as dynamic are considered sealed, which means that properties cannot be added to instances of the class.

If a class is sealed (not dynamic), attempts to get or set properties on class instances result in an error. If you have your compiler set to strict mode and you specify the data type when you create instances, attempts to add properties to sealed objects generate a compiler error; otherwise, a runtime error occurs.

The dynamic attribute is not inherited by subclasses. If you extend a dynamic class, the subclass is dynamic only if you declare the subclass with the dynamic attribute.

Note: This keyword is supported only when used in external script files, not in scripts written in the Actions panel.

Example
The following example creates two classes, one dynamic class named Expando and one sealed class named Sealed, that are used in subsequent examples.
package {

    dynamic class Expando  {
    }

    class Sealed {
    }
}
The following code creates an instance of the Expando class and shows that you can add properties to the instance.
var myExpando:Expando = new Expando();
myExpando.prop1 = "new";
trace(myExpando.prop1); // output: new
The following code creates an instance of the Sealed class and shows that attempts to add a property result in an error.
var mySealed:Sealed = new Sealed();
mySealed.prop1 = "newer"; // error

See also

class
Classes
else statement
Usage
if (condition) {
    // statement(s)
}
else {
    // statement(s)
}

Specifies the statements to run if the condition in the if statement returns false. The curly braces ({}) that enclose the statements to be executed by the else statement are not necessary if only one statement will execute.

Parameters
condition:Boolean — An expression that evaluates to true or false.

Example
In the following example, the else condition is used to check whether the age_txt variable is greater than or less than 18:
if (age_txt.text>=18) {
    trace("welcome, user");
}
else {
    trace("sorry, junior");
    userObject.minor = true;
    userObject.accessAllowed = false;
}
In the following example, curly braces ({}) are not necessary because only one statement follows the else statement:
if (age_txt.text>18) {
    trace("welcome, user");
}
else trace("sorry, junior");
The following example uses a combination of the if and else statements to compare score_txtto a specified value:

if (score_txt.text>90) {
    trace("A");
}
else if (score_txt.text>75) {
    trace("B");
}
else if (score_txt.text>60) {
    trace("C");
}
else {
    trace("F");
}

See also

if
Conditionals
extends definition keyword
Usage
class className extends otherClassName {}
interface interfaceName extends otherInterfaceName {}

Defines a class that is a subclass of another class. The subclass inherits all the methods, properties, functions, and so on that are defined in the superclass. Classes that are marked as final cannot be extended.

You can also use the extends keyword to extend an interface. An interface that extends another interface includes all the original interface's method declarations.

Note: To use this keyword, you must specify ActionScript 2.0 and Flash Player 6 or later in the Flash tab of your FLA file's Publish Settings dialog box. This keyword is supported only when used in external script files, not in scripts written in the Actions panel.

Parameters
className:Class — The name of the class you are defining.

Example
In the following example, the Car class extends the Vehicle class so that all its methods, properties, and functions are inherited. If your script instantiates a Car object, methods from both the Car class and the Vehicle class can be used.

The following example shows the contents of a file called Vehicle.as, which defines the Vehicle class:

package {
    class Vehicle {
        var numDoors:Number;
        var color:String;
        public function Vehicle(param_numDoors:Number = 2, param_color:String = null) {
            numDoors = param_numDoors;
            color = param_color;
        }
        public function start():void {
            trace("[Vehicle] start");
        }
        public function stop():void {
            trace("[Vehicle] stop");
        }
        public function reverse():void {
            trace("[Vehicle] reverse");
        }
    }
}
The following example shows a second ActionScript file, called Car.as, in the same directory. This class extends the Vehicle class, modifying it in three ways. First, the Car class adds a variable fullSizeSpare to track whether the car object has a full-size spare tire. Second, it adds a new method specific to cars, activateCarAlarm(), that activates the car's antitheft alarm. Third, it overrides the stop() function to add the fact that the Car class uses an antilock braking system to stop.
package {

    public class Car extends Vehicle {
        var fullSizeSpare:Boolean;
        public function Car(param_numDoors:Number, param_color:String, param_fullSizeSpare:Boolean) {
            numDoors = param_numDoors;
            color = param_color;
            fullSizeSpare = param_fullSizeSpare;
        }
        public function activateCarAlarm():void {
            trace("[Car] activateCarAlarm");
        }
        public override function stop():void {
            trace("[Car] stop with antilock brakes");
        }
    }
}
The following example instantiates a Car object, calls a method defined in the Vehicle class (start()), then calls the method overridden by the Car class (stop()), and finally calls a method from the Car class (activateCarAlarm()):
var myNewCar:Car = new Car(2, "Red", true);
myNewCar.start(); // output: [Vehicle] start
myNewCar.stop(); // output: [Car] stop with anti-lock brakes
myNewCar.activateCarAlarm(); // output: [Car] activateCarAlarm

You could also write a subclass of the Vehicle class using the super statement, which the subclass can use to access the constructor of the superclass. The following example shows a third ActionScript file, called Truck.as, again in the same directory. The Truck class uses super in the constructor and in the overridden reverse() method.

package {
    class Truck extends Vehicle {
        var numWheels:Number;
        public function Truck(param_numDoors:Number, param_color:String, param_numWheels:Number) {
            super(param_numDoors, param_color);
            numWheels = param_numWheels;
        }
        public override function reverse():void {
            beep();
            super.reverse();
        }
        public function beep():void {
            trace("[Truck] make beeping sound");
        }
    }
}
The following example instantiates a Truck object, calls a method overridden by the Truck class (reverse()), then calls a method defined in the Vehicle class (stop()):
var myTruck:Truck = new Truck(2, "White", 18);
myTruck.reverse(); // output: [Truck] make beeping sound [Vehicle] reverse
myTruck.stop(); // output: [Vehicle] stop

See also

class
final
interface
Inheritance
false primary expression keyword
Usage
false

A Boolean value representing false. A Boolean value is either true or false; the opposite of false is true.

When automatic data typing converts false to a number, it becomes 0; when it converts false to a string, it becomes "false".

Note: The string "false" converts to the Boolean value true.

Example
This example shows how automatic data typing converts false to a number and to a string:
var bool1:Boolean = Boolean(false);

// converts it to the number 0
trace(1 + bool1); // outputs 1

// converts it to a string
trace("String: " + bool1); // outputs String: false

The following example shows that the string "false" converts to the Boolean value true:

trace(Boolean("false")); // output: true

if ("false") {
    trace("condition expression evaluated to true");
}
else {
    trace("condition expression evaluated to false");
}
// output: condition expression evaluated to true

See also

Boolean class
true
final attribute keyword
Usage
final function methodName() {
    // your statements here
}
final class className {}

Specifies that a method cannot be overridden or that a class cannot be extended. An attempt to override a method, or extend a class, marked as final results in an error.

Parameters
methodName:Function — The name of the method that cannot be overridden.
className:Class — The name of the class that cannot be extended.

See also

override
extends
Classes
flash_proxy namespace

Defines methods of the Proxy class. The Proxy class methods are in their own namespace to avoid name conflicts in situations where your Proxy subclass contains instance method names that match any of the Proxy class method names.

See also

Proxy class
for statement
Usage
for ([init]; [condition]; [next]) {
    // statement(s)
}

Evaluates the init (initialize) expression once and then starts a looping sequence. The looping sequence begins by evaluating the condition expression. If the condition expression evaluates to true, statement is executed and next is evaluated. The looping sequence then begins again with the evaluation of the condition expression.

The curly braces ({}) that enclose the block of statements to be executed by the for statement are not necessary if only one statement will execute.

Parameters
init — An optional expression to evaluate before beginning the looping sequence; usually an assignment expression. A var statement is also permitted for this parameter.
condition — An optional expression to evaluate before beginning the looping sequence; usually a comparison expression. If the expression evaluates to true, the statements associated with the for statement are executed.
next — An optional expression to evaluate after the looping sequence; usually an increment or decrement expression.

Example
The following example uses for to add the elements in an array:
var my_array:Array = new Array();
for (var i:Number = 0; i < 10; i++) {
    my_array[i] = (i + 5) * 10;
}
trace(my_array); // output: 50,60,70,80,90,100,110,120,130,140
The following example uses for to perform the same action repeatedly. In the code, the for loop adds the numbers from 1 to 100.
var sum:Number = 0;
for (var i:Number = 1; i <= 100; i++) {
    sum += i;
}
trace(sum); // output: 5050
The following example shows that curly braces ({}) are not necessary if only one statement will execute:
var sum:Number = 0;
for (var i:Number = 1; i <= 100; i++)
    sum += i;
trace(sum); // output: 5050

See also

++ (increment)
Looping
for..in statement
Usage
for (variableIterant:String in object){
    // statement(s)
}

Iterates over the dynamic properties of an object or elements in an array and executes statement for each property or element. Fixed properties, such as variables and methods defined in a class, are not enumerated by the for..in statement. To get a list of fixed properties, use the describeType() function, which is in the flash.utils package.

Parameters
variableIterant:String — The name of a variable to act as the iterant, referencing each property of an object or element in an array.

Example
The following example uses for..in to iterate over the properties of an object:
var myObject:Object = {firstName:"Tara", age:27, city:"San Francisco"};
for (var prop in myObject) {
    trace("myObject."+prop+" = "+myObject[prop]);
}
/* output:
myObject.firstName = Tara
myObject.age = 27
myObject.city = San Francisco
*/
The following example uses the typeof operator with for..in to iterate over a particular type of child:
var myObject:Object = {firstName:"Tara", age:27, city:"San Francisco"};
for (var name in myObject) {
    if (typeof (myObject[name]) == "string") {
        trace("I have a string property named "+name);
    }
}
/* output:
I have a string property named city
I have a string property named firstName
*/

See also

describeType()
Looping
Traversing XML structures
Storing local data
for each..in statement
Usage
for each (variableIterant in object){
    // statement(s)
}

Iterates over the items of a collection and executes statement for each item. Introduced as a part of the E4X language extensions, the for each..in statement can be used not only for XML objects, but also for objects and arrays. The for each..in statement iterates only through the dynamic properties of an object, not the fixed properties. A fixed property is a property that is defined as part of a class definition. To use the for each..in statement with an instance of a user-defined class, you must declare the class with the dynamic attribute.

Unlike the for..in statement, the for each..in statement iterates over the values of an object's properties, rather than the property names.

Parameters
variableIterant:* — The name of a variable to act as the iterant, referencing the item in a collection.
object:Object — The name of a collection over which to iterate. The collection can be an XML object, a generic object, or an array.

Example
The following example uses for each..in to iterate over the values held by the properties of an object:
var myObject:Object = {firstName:"Tara", age:27, city:"San Francisco"};
for each (var item in myObject) {
    trace(item);
}
/* output:
Tara
27
San Francisco
*/
The following example uses for each..in to iterate over the elements of an array:
var myArray:Array = new Array("one", "two", "three");
for each(var item in myArray)
    trace(item);
/* output:
one
two
three
*/
The following example uses the is operator with for each..in to iterate over a particular type of child:
var myObject:Object = {firstName:"Tara", age:27, city:"San Francisco"};
for each (var item in myObject) {
    if (item is String) {
        trace("I have a string property with value " + item);
    }
}

/* output:
I have a string property with value Tara
I have a string property with value San Francisco
*/
The following example shows using for each..in to iterate over the properties in an XMLList object (doc.p):
var doc:XML =
        <body>
            <p>Hello</p>
            <p>Hola</p>
            <hr />
            <p>Bonjour</p>
        </body>;
for each (var item in doc.p) {
    trace(item);
}

/* output:
Hello
Hola
Bonjour
*/

See also

Traversing XML structures
function definition keyword
Usage
function functionName([parameter0, parameter1,...parameterN]) : returnType{
    // statement(s)
}
var functionName:Function = function ([parameter0, parameter1,...parameterN]) : returnType{
    // statement(s)
}

Comprises a set of statements that you define to perform a certain task. You can define a function in one location and invoke, or call, it from different scripts in a SWF file. When you define a function, you can also specify parameters for the function. Parameters are placeholders for values on which the function operates. You can pass different parameters to a function each time you call it so you can reuse the function in different situations.

Use the return statement in a function's statement(s) block to cause a function to generate, or return, a value.

Usage 1: You can use the function keyword to define a function with the specified function name, parameters, and statements. When a script calls a function, the statements in the function's definition are executed. Forward referencing is permitted; within the same script, a function may be declared after it is called. A function definition replaces any prior definition of the same function. You can use this syntax wherever a statement is permitted.

Usage 2: You can also use function to create an anonymous function and return a reference to it. This syntax is used in expressions and is particularly useful for installing methods in objects.

For additional functionality, you can use the arguments object in your function definition. The arguments object is commonly used to create a function that accepts a variable number of parameters and to create a recursive anonymous function.

Parameters
functionName:Function — The name of the new function.
returnType:* — The data type of the return value.

Example
The following example defines the function sqr, which returns the value of a number squared:
function sqr(xNum:Number) {
    return Math.pow(xNum, 2);
}
var yNum:Number = sqr(3);
trace(yNum); // output: 9
If the function is defined and used in the same script, the function definition can appear after the function is used:
var yNum:Number = sqr(3);
trace(yNum); // output: 9
function sqr(xNum:Number) {
    return Math.pow(xNum, 2);
}

See also

arguments object
return
Methods
get definition keyword
Usage
function get property() : returnType{
    // your statements here
}

Defines a getter, which is a method that can be read like a property. A getter is a special function that returns the value of a property declared with the var or const keyword. Unlike other methods, a getter is called without parentheses (()), which makes the getter appear to be a variable.

Getters allow you to apply the principle of information hiding by letting you create a public interface for a private property. The advantage of information hiding is that the public interface remains the same even if the underlying implementation of the private property changes.

Another advantage of getters is that they can be overridden in subclasses, whereas properties declared with var or const cannot.

A getter can be combined with a setter to create a read-write property. To create a read-only property, create a getter without a corresponding setter. To create a write-only property, create a setter without a corresponding getter.

Note: To use this keyword, you must specify ActionScript 2.0 and Flash Player 6 or later in the Flash tab of your FLA file's Publish Settings dialog box. This keyword is supported only when used in external script files, not in scripts written in the Actions panel.

Parameters
property:* — The identifier for the property that get accesses; this value must be the same as the value used in the corresponding set command.
returnType:* — The data type of the return value.

Example
The following example defines a Team class. The Team class includes getter and setter methods that let you retrieve and set properties within the class:
package {
    public class Team {
        var teamName:String;
        var teamCode:String;
        var teamPlayers:Array = new Array();
        public function Team(param_name:String, param_code:String) {
            teamName = param_name;
            teamCode = param_code;
        }
        public function get name():String {
            return teamName;
        }
        public function set name(param_name:String):void {
            teamName = param_name;
        }
    }
}
Enter the following code in your script:
var giants:Team = new Team("San Fran", "SFO");
trace(giants.name);
giants.name = "San Francisco";
trace(giants.name);
/* output:
San Fran San Francisco */

When you trace giants.name, you use a getter method to return the value of the property.

See also

set
Methods
if statement
Usage
if (condition) {
    // statement(s)
}

Evaluates a condition to determine the next statement to execute. If the condition is true, Flash Player runs the statements that follow the condition inside curly braces ({}). If the condition is false, Flash Player skips the statements inside the curly braces and runs the statements following the curly braces. Use the if statement along with the else statement to create branching logic in your scripts.

The curly braces ({}) that enclose the statements to be executed by the if statement are not necessary if only one statement will execute.

Parameters
condition:Boolean — An expression that evaluates to true or false.

See also

else
Conditionals
Conditionals
Conditionals
implements definition keyword
Usage
myClass implements interface01 [, interface02 , ...]

Specifies that a class implements one or more interfaces. When a class implements an interface, the class must define all the methods declared in the interface. Any instance of a class that implements an interface is considered a member of the data type defined by the interface. As a result, the is operator returns true when the class instance is the first operand and the interface is the second; in addition, type coercions to and from the data type defined by the interface work.

Note: To use this keyword, you must specify ActionScript 2.0 and Flash Player 6 or later in the Flash tab of your FLA file's Publish Settings dialog box. This keyword is supported only when used in external script files, not in scripts written in the Actions panel.

See also

class
interface
Interfaces
import directive
Usage
import packageName.className
import packageName.*

Makes externally defined classes and packages available to your code. For example, if you want to use the flash.display.Sprite class in a script, you must import it. This requirement is different from previous versions of ActionScript, in which the import directive was optional.

After using the import directive, you can use the full class name, which includes the package name, or just the name of the class.

import flash.display.Sprite;

// name of class only
var mySprite:Sprite = new Sprite();

// full class name
var mySprite:flash.display.Sprite = new flash.display.Sprite();

If there are several classes in the package that you want to access, you can import them all in a single statement, as shown in the following example:

import flash.display.*;

The import directive imports only the classes, functions, and variables that reside at the top level of the imported package. Nested packages must be explicitly imported.

If you import a class but do not use it in your script, the class is not exported as part of the SWF file. This means you can import large packages without being concerned about the size of the SWF file; the bytecode associated with a class is included in a SWF file only if that class is actually used. One disadvantage of importing classes that you do not need is that you increase the likelihood of name collisions.

The import directive applies only to the current script (frame or object) in which it's called. For example, suppose on Frame 1 of a Flash document you import all the classes in the adobe.example package. On that frame, you can reference classes in that package by their simple names:

// On Frame 1 of a FLA:
import adobe.example.*;
var myFoo:foo = new foo();

On another frame script, however, you would need to reference classes in that package by their fully qualified names (var myFoo:foo = new adobe.example.foo();) or add an import directive to the other frame that imports the classes in that package.

Parameters
packageName:* — The name of a package you have defined in a separate class file.
className:Class — The name of a class you have defined in a separate class file.

See also

Options for organizing your code
include directive
Usage
include "[path]filename.as"

Includes the contents of the specified file, as if the commands in the file are part of the calling script. The include directive is invoked at compile time. Therefore, if you make any changes to an included file, you must save the file and recompile any SWF files that use it.

See also

Options for organizing your code
interface definition keyword
Usage
 interface InterfaceName [extends InterfaceName ] {}

Defines an interface. Interfaces are data types that define a set of methods; the methods must be defined by any class that implements the interface.

An interface is similar to a class, with the following important differences:

  • Interfaces contain only declarations of methods, not their implementation. That is, every class that implements an interface must provide an implementation for each method declared in the interface.
  • Interface method definitions cannot have any attribute such as public or private, but implemented methods must be marked as public in the definition of the class that implements the interface.
  • Multiple interfaces can be inherited by an interface by means of the extends statement, or by a class through the implements statement.

Unlike ActionScript 2.0, ActionScript 3.0 allows the use of getter and setter methods in interface definitions.

Note: To use this keyword, you must specify ActionScript 2.0 and Flash Player 6 or later in the Flash tab of your FLA file's Publish Settings dialog box. This keyword is supported only when used in external script files, not in scripts written in the Actions panel.

See also

class
implements
Interfaces
internal attribute keyword
Usage
[internal] var varName
[internal] const kName
[internal] function functionName()  {
    // your statements here
}
[internal] class className{
    // your statements here
}
[internal] namespace nsName

Specifies that a class, variable, constant, or function is available to any caller within the same package. Classes, properties, and methods belong to the internal namespace by default.

Parameters
className:Class — The name of the class that you want to specify as internal.
varName:* — The name of the variable that you want to specify as internal. You can apply the internal attribute whether the variable is part of a class or not.
kName:* — The name of the constant that you want to specify as internal. You can apply the internal attribute whether the constant is part of a class or not.
functionName:Function — The name of the function or method that you want to specify as internal. You can apply the internal attribute whether the function is part of a class or not.
nsName:Namespace — The name of the namespace that you want to specify as internal. You can apply the internal attribute whether the namespace is part of a class or not.

See also

package
private
protected
public
Classes
Class property attributes
Inheritance
label statement
Usage
label: statement
label: {
    statements
}

Associates a statement with an identifier that can be referenced by break or continue. In nested loops, a break or continue statement that does not reference a label can skip only the rest of the immediate loop and does not skip the entire series of loops. However, if the statement that defines the entire series of loops has an associated label, a break or continue statement can skip the entire series of loops by referring to that label.

Labels also allow you to break out of a block statement. You cannot place a break statement that does not reference a label inside a block statement unless the block statement is part of a loop. If the block statement has an associated label, you can place a break statement that refers to that label inside the block statement.

Parameters
label:* — A valid identifier to associate with a statement.
statements:* — Statement to associate with the label.

Example
The following example shows how to use a label with a nested loop to break out of the entire series of loops. The code uses a nested loop to generate a list of numbers from 0 to 99. The break statement occurs just before the count reaches 80. If the break statement did not use the outerLoop label, the code would skip only the rest of the immediate loop and the code would continue to output the numbers from 90 to 99. However, because the outerLoop label is used, the break statement skips the rest of the entire series of loops and the last number output is 79.
outerLoop: for (var i:int = 0; i < 10; i++) {
    for (var j:int = 0; j < 10; j++) {
        if ( (i == 8) && (j == 0)) {
            break outerLoop;
        }
        trace(10 * i + j);
    }
}
/* output:
1
2
...
79
*/

The following example shows how to use a label with a block statement. In the following example, a block statement is labeled foo, which allows the break statement to skip the final statement in the block:

foo: {
    trace("a");
    break foo;
    trace("b");
}
// output: a

See also

break
continue
namespace definition keyword
Usage
namespace name [= uri]

Allows you to control the visibility of definitions. Predefined namespaces include public, private, protected, and internal.

The following steps show how to create, apply, and reference a namespace:

  • First, define the custom namespace using the namespace keyword. For example, the code namespace version1 creates a namespace called version1.
  • Second, apply the namespace to a property or method by using your custom namespace in the property or method declaration. For example, the code version1 myProperty:String creates a property named myProperty that belongs to the version1 namespace
  • Third, reference the namespace by using the use keyword or by prefixing an identifier with the namespace. For example, the code use namespace version1; references the version1 namespace for subsequent lines of code, and the code version1::myProperty references the version1 namespace for the myProperty property.

Parameters
name:Namespace — The name of the namespace, which can be any legal identifier.
uri:String — The Uniform Resource Identifier (URI) of the namespace. This is an optional parameter.

See also

class
internal
package
private
protected
public
Class property attributes
native attribute keyword
Usage
native function functionName();
class className {
    native function methodName();
}

Specifies that a function or method is implemented by Flash Player in native code. Flash Player uses the native keyword internally to declare functions and methods in the ActionScript application programming interface (API). This keyword cannot be used in your own code.

null primary expression keyword
Usage
null

A special value that can be assigned to variables or returned by a function if no data was provided. You can use null to represent values that are missing or that do not have a defined data type.

The value null should not be confused with the special value undefined. When null and undefined are compared with the equality (==) operator, they compare as equal. However, when null and undefined are compared with the strict equality (===) operator, they compare as not equal.

Example
The following example checks the first six values of an indexed array and outputs a message if no value is set (if the value == null):

var testArray:Array = new Array();
testArray[0] = "fee";
testArray[1] = "fi";
testArray[4] = "foo";

for (i = 0; i < 6; i++) {
    if (testArray[i] == null) {
        trace("testArray[" + i + "] == null");
    }
}

/* output:
testArray[2] == null
testArray[3] == null
testArray[5] == null
*/

See also

undefined
Data type descriptions
object_proxy namespace

Defines methods of the ObjectProxy class. The ObjectProxy class methods are in their own namespace to avoid name conflicts in situations where a Proxy subclass contains instance method names that match any of the Proxy class method names.

override attribute keyword
Usage
override function name() {
    // your statements here
}

Specifies that a method replaces an inherited method. To override an inherited method, you must use the override attribute and ensure that the name, number, type of parameters, and the return type match exactly. It is an error to attempt to override a method without using the override attribute. Likewise, it is an error to use the override attribute if the method does not have a matching inherited method.

You cannot use the override attribute on any of the following:

  • Variables
  • Constants
  • Static methods
  • Methods that are not inherited
  • Methods that implement an interface method
  • Inherited methods that are marked as final in the superclass

Although you cannot override a property declared with var or const, you can achieve similar functionality by making the base class property a getter-setter and overriding the methods defined with get and set.

Parameters
name:Function — The name of the method to override.

See also

final
get
set
Inheritance
package definition keyword
Usage
package packageName {
    class someClassName {
    }
}

Allows you to organize your code into discrete groups that can be imported by other scripts. You must use the package keyword to indicate that a class is a member of a package.

Parameters
packageName:* — The name of the package.

See also

internal
public
class
private attribute keyword
Usage
class className{
    private var varName;
    private const kName;
    private function methodName() {
        // your statements here
    }
    private namespace nsName;
}

Specifies that a variable, constant, or method is available only to the class that declares or defines it. Unlike in ActionScript 2.0, in ActionScript 3.0 private no longer provides access to subclasses. Moreover, private restricts access at both compile time and runtime. By default, a variable or function is available to any caller in the same package. Use this keyword if you want to restrict access to a variable or function.

You can use this keyword only in class definitions, not in interface definitions. You cannot apply private to a class or to any other package-level definitions.

Parameters
varName:* — The name of the variable that you want to specify as private. You can apply the private attribute only if the variable is inside a class.
kName:* — The name of the constant that you want to specify as private. You can apply the private attribute only if the constant is inside a class.
methodName:Function — The name of the method that you want to specify as private. You can apply the private attribute only if the method is inside a class.
nsName:Namespace — The name of the namespace that you want to specify as private. You can apply the private attribute only if the namespace is inside a class.

Example
The following example demonstrates how you can hide certain properties within a class using the private keyword.
class A {
  private var alpha:String = "visible only inside class A";
  public var beta:String = "visible everywhere";
}

class B extends A {
  function B() {
    alpha = "Access attempt from subclass"; // error
  }
}

Because alpha is a private variable, you cannot access it from outside the A class, even from subclass B. Attempts to access the private variable generate an error.

See also

internal
protected
public
Class property attributes
Inheritance
protected attribute keyword
Usage
class className{
    protected var varName;
    protected const kName;
    protected function methodName() {
        // your statements here
    }
    protected namespace nsName;
}

Specifies that a variable, constant, method, or namespace is available only to the class that defines it and to any subclasses of that class. The definition of protected in ActionScript 3.0 is similar to the definition of the ActionScript 2.0 version of private, except that protected restricts access at both compile time and runtime. By default, a variable or function is available to any caller within the same package. Use this keyword if you want to restrict access to a variable or function.

You can use this keyword only in class definitions, not in interface definitions. You cannot apply private to a class, or to any other package-level definitions.

The definition of protected in ActionScript 3.0 is more restrictive than that of protected in the Java programming language. In ActionScript 3.0 protected limits access strictly to subclasses, whereas in Java protected also allows access to any class in the same package. For example, if a class named Base contains a property marked as protected, in ActionScript 3.0 only classes that extend Base can access the protected property. In Java, any class in the same package as Base has access to the protected property even if the class is not a subclass of Base.

Parameters
varName:* — The name of the variable that you want to specify as protected. You can apply the protected attribute only if the variable is inside a class.
kName:* — The name of the constant that you want to specify as protected. You can apply the protected attribute only if the constant is inside a class.
methodName:Function — The name of the method that you want to specify as protected. You can apply the protected attribute only if the method is inside a class.
nsName:Namespace — The name of the namespace that you want to specify as protected. You can apply the protected attribute only if the namespace is inside a class.

Example
The following example creates a protected class variable in class A, and successfully accesses that variable in class B because class B is a subclass of class A.
class A {
  private var alpha:String = "visible only inside class A";
  protected var beta:String = "visible inside class A and its subclasses";
}

class B extends A {
  public function B() {
    beta = "Access attempt from subclass succeeded";
    trace(beta);  // output: Access attempt from subclass succeeded
  }
}

See also

internal
private
public
Class property attributes
Inheritance
public attribute keyword
Usage
public var varName
public const kName
public function functionName()  {
    // your statements here
}
public class className {
    // your statements here
}
public namespace nsName

Specifies that a class, variable, constant, or method is available to any caller. Classes, variables, and methods are internal by default, which means that they are visible only within the current package. To make a class, variable, or method visible to all callers, you must use the public attribute.

Parameters
className:Class — The name of the class that you want to specify as public.
varName:* — The name of the variable that you want to specify as public. You can apply the public attribute whether the variable is part of a class or not.
kName:* — The name of the constant that you want to specify as public. You can apply the public attribute whether the constant is part of a class or not.
functionName:Function — The name of the function or method that you want to specify as public. You can apply the public attribute whether the function is part of a class or not.
nsName:Namespace — The name of the namespace that you want to specify as public. You can apply the public attribute whether the namespace is part of a class or not.

Example
The following example shows how you can use public variables in a class file:
class User {
    public var age:Number;
    public var fname:String;
} // end of class User definition

var jimmy:User = new User();
jimmy.age = 27;
jimmy.fname = "jimmy";
trace(jimmy.age, jimmy.fname); // output: 27 jimmy

If you change one of the public variables in the User class to a private variable, any attempt to access that variable outside the User class generates a compile-time error.

See also

class
internal
private
protected
Classes
Class property attributes
Inheritance
return statement
Usage
function functionName () {
    return [expression]
}

Causes execution to return immediately to the calling function. If the return statement is followed by an expression, the expression is evaluated and the result is returned.

If a function definition includes a return type, the return statement must be followed by an expression. If no return type is specified and the return statement is used alone, it returns undefined.

You cannot return multiple values. If you try to do so, only the last value is returned. In the following example, c is returned:

return a, b, c ;

If you need to return multiple values, use an array or object instead.

Parameters
expression:* — An expression to evaluate and return as a value of the function. This parameter is optional.

Result
* — The evaluated expression parameter, if provided.

Example
The following example uses the return statement inside the body of the sum() function to return the added value of the three parameters. The next line of code calls sum() and assigns the returned value to the variable newValue.
function sum(a:Number, b:Number, c:Number):Number {
    return (a + b + c);
}
var newValue:Number = sum(4, 32, 78);
trace(newValue); // output: 114

See also

function
set definition keyword
Usage
function set property(newValue:*) : void{
    // your statements here
}

Defines a setter, which is a method that appears in the public interface as a property. A setter is a special method that sets the value of a property declared with the var keyword. Unlike other methods, a setter is called without parentheses (()), which makes the setter appear to be a variable.

Setters allow you to apply the principle of information hiding by letting you create a public interface for a private property. The advantage of information hiding is that the public interface remains the same even if the underlying implementation of the private property changes.

Another advantage of setters is that they can be overridden in subclasses, whereas properties declared with var cannot.

The return type of a setter must be either void or not specified.

A setter can be combined with a getter to create a read-write property. To create a read-only property, create a getter without a corresponding setter. To create a write-only property, create a setter without a corresponding getter.

Note: This keyword is supported only when used in external script files, not in scripts written in the Actions panel.

Parameters
property:* — The identifier for the property that set modifies; this value must be the same as the value used in the corresponding get command.
newValue:* — The new value to assign.

Example
The following example creates a read-write property named age by defining a getter-setter.
package {
    class User {
        private var userAge:Number;

        public function get age():Number {
            return userAge;
        }

        public function set age(x:Number):void {
            userAge = x;
        }
    }
}
Enter the following code in your script:
var myUser:User = new User();
myUser.age = 25;
trace(myUser.age); // output: 25

See also

get
Methods
static attribute keyword
Usage
class someClassName{
    static var varName;
    static const kName;
    static function methodName() {
        // your statements here
    }
}

Specifies that a variable, constant, or method belongs to the class, rather than to instances of the class.

To access a static class member, use the name of the class instead of the name of an instance. For example, the Date class has a static method named parse(), which can only be called using the following syntax:

Date.parse()

The parse() method cannot be called on an instance of the Date class. For example, the following code generates an error:

var myDate:Date = new Date();
            myDate.parse("Jan 01 00:00:00 2006"); // error

You can use static in class definitions only, not in interface definitions.

Static class members are not inherited. You cannot refer to a static class member using the name of a subclass, as you can in Java or C++. You can, however, refer to a static variable or method within a class or subclass, without using any qualifier. See the example below.

You cannot use the super statement or the this keyword inside a static method.

Note: This keyword is supported only when used in external script files, not in scripts written in the Actions panel.

Parameters
varName:* — The name of the variable that you want to specify as static.
kName:* — The name of the constant that you want to specify as static.
methodName:Function — The name of the method that you want to specify as static.

Example
The following example demonstrates how you can use the static keyword to create a counter that tracks how many instances of the class have been created. Because the numInstances variable is static, it will be created only once for the entire class, not for every single instance. Create a new ActionScript file called Users.as and enter the following code:
class Users {
    private static var numInstances:Number = 0;
    function Users() {
        numInstances++;
    }
    static function get instances():Number {
        return numInstances;
    }
}
Enter the following code in your script:
trace(Users.instances);
var user1:Users = new Users();
trace(Users.instances);
var user2:Users = new Users();
trace(Users.instances);
The following example extends the Users class to show that static variables and methods are not inherited but can be referenced in subclasses.
class PowerUsers extends Users{
    function PowerUsers() {
        instances++;  // unqualified reference to static property Users.instances is legal
    }
}

trace(PowerUsers.instances); // error, cannot access static property using PowerUsers class

See also

Class property attributes
Variables
Methods
Inheritance
super statement
Usage
super([arg1, ..., argN])
super.method([arg1, ..., argN])

Invokes the superclass or parent version of a method or constructor. When used within the body of a class constructor, the super() statement invokes the superclass version of the constructor. The call to the superclass constructor must have the correct number of arguments. Note that the superclass constructor is always called, whether or not you call it explicitly. If you do not explicitly call it, a call with no arguments is automatically inserted before the first statement in the subclass constructor body. This means that if you define a constructor function in a subclass, and the superclass constructor takes one or more arguments, you must explicitly call the superclass constructor with the correct number of arguments or an error will occur. The call to the superclass constructor, however, does not need to be the first statement in your subclass constructor, as was required in ActionScript 2.0.

When used in the body of an instance method, super can be used with the dot (.) operator to invoke the superclass version of a method and can optionally pass arguments (arg1 ... argN) to the superclass method. This is useful for creating subclass methods that not only add additional behavior to superclass methods, but also invoke the superclass methods to perform their original behavior.

You cannot use the super statement in a static method.

Parameters
method:Function — The method to invoke in the superclass.
argN:* — Optional parameters that are passed to the superclass version of the method or to the constructor function of the superclass.

See also

class
extends
Methods
Inheritance
switch statement
Usage
switch (expression) {
    caseClause:
    [defaultClause:]
}

Causes control to transfer to one of several statements, depending on the value of an expression. All switch statements should include a default case that will execute if none of the case statements match the expression. Each case statement should end with a break statement, which prevents a fall-through error. When a case falls through, it executes the code in the next case statement, even though that case may not match the test expression.

Parameters
expression:* — Any expression.

Example
The following example defines a switch statement that falls through to the default case:

var switchExpression:int = 3;

switch (switchExpression) {
    case 0:
        trace(0);
        break;
    case 1:
        trace(1);
        break;
    case 2:
        trace(2);
        break;
    default:
        trace("Not 0, 1, or 2");
}

// output: Not 0, 1, or 2

See also

=== (strict equality)
case
default
Conditionals
this primary expression keyword
Usage
this

A reference to a method's containing object. When a script executes, the this keyword references the object that contains the script. Inside a method body, the this keyword references the class instance that contains the called method.

Example
To call a function defined in a dynamic class, you must use this to invoke the function in the proper scope:
// incorrect version of Simple.as
/*
dynamic class Simple {
    function callfunc() {
        func();
    }
}
*/
// correct version of Simple.as
dynamic class Simple {
    function callfunc() {
        this.func();
    }
}
Add the following code to your script:
var simpleObj:Simple = new Simple();
simpleObj.func = function() {
    trace("hello there");
}
simpleObj.callfunc();
The preceding code works when you use this in the callfunc() method. However, you would get a syntax error if you used the incorrect version of Simple.as, which was commented out in the above example.

See also

Methods
throw statement
Usage
throw expression

Generates, or throws, an error that can be handled, or caught, by a catch code block. If an exception is not caught by a catch block, the string representation of the thrown value is sent to the Output panel. If an exception is not caught by a catch or finally block, the string representation of the thrown value is sent to the log file.

Typically, you throw instances of the Error class or its subclasses (see the Example section).

Parameters
expression:* — An ActionScript expression or object.

Example
In this example, a function named checkEmail() checks whether the string that is passed to it is a properly formatted e-mail address. If the string does not contain an @ symbol, the function throws an error.
function checkEmail(email:String) {
    if (email.indexOf("@") == -1) {
        throw new Error("Invalid email address");
    }
}
checkEmail("someuser_theirdomain.com");
The following code then calls the same function, checkEmail(), within a try code block. If the e-mail string does not contain a valid e-mail address, the error message is output by the trace statement.
try {
    checkEmail("Joe Smith");
}
catch (e) {
    trace(e);
}
// output: Error: Invalid email address.
In the following example, a subclass of the Error class is thrown. The checkEmail() function is modified to throw an instance of that subclass.
// Define Error subclass InvalidEmailError
class InvalidEmailAddress extends Error {
    public function InvalidEmailAddress() {
        message = "Invalid email address.";
    }
}
Enter the following code in your script:
import InvalidEmailAddress;
function checkEmail(email:String) {
    if (email.indexOf("@") == -1) {
        throw new InvalidEmailAddress();
    }
}
try {
    checkEmail("Joe Smith");
}
catch (e) {
    trace(e);
}
// output: Error: Invalid email address.

See also

Error class
try..catch..finally
Handling synchronous errors in an application
true primary expression keyword
Usage
true

A Boolean value representing true. A Boolean value is either true or false; the opposite of true is false. When automatic data typing converts true to a number, it becomes 1; when it converts true to a string, it becomes "true".

Example
The following example shows the use of true in an if statement:

var shouldExecute:Boolean;
// ...
// code that sets shouldExecute to either true or false goes here
// shouldExecute is set to true for this example:

shouldExecute = true;

if (shouldExecute == true) {
    trace("your statements here");
}

// true is also implied, so the if statement could also be written:
// if (shouldExecute) {
//         trace("your statements here");
// }

The following example shows how automatic data typing converts true to the number 1:

var myNum:Number;
myNum = 1 + true;
trace(myNum); // output: 2

See also

Boolean class
false
try..catch..finally statement
Usage
try {
    // try block
} finally {
    // finally block
}

try {
    // try block
} catch(error[:ErrorType1]) {
    // catch block
} [catch(error[:ErrorTypeN]) {
    // catch block
}] [finally {
    // finally block
}]

Encloses a block of code in which an error can occur, and then responds to the error. Exception handling, which is implemented using the try..catch..finally statements, is the primary mechanism for handling runtime error conditions in ActionScript 3.0. When a runtime error occurs, Flash Player throws an exception, which means that Flash Player suspends normal execution and creates a special object of type Error. Flash Player then passes, or throws, the error object to the first available catch block. If no catch blocks are available, the exception is considered to be an uncaught exception. Uncaught exceptions cause the script to terminate.

You can use the throw statement to explicitly throw exceptions in your code. You can throw any value, but the best practice is to throw an object because it provides flexibility and matches the behavior of Flash Player.

To catch an exception, whether it is thrown by Flash Player or by your own code, place the code that may throw the exception in a try block. If any code in the try block throws an exception, control passes to the catch block, if one exists, and then to the finally block, if one exists. The finally block always executes, regardless of whether an exception was thrown. If code within the try block does not throw an exception (that is, if the try block completes normally), the code in the catch block is ignored, but the code in the finally block is still executed. The finally block executes even if the try block exits using a return statement.

A try block must be followed by a catch block, a finally block, or both. A single try block can have multiple catch blocks but only one finally block. You can nest try blocks as many levels deep as desired.

The error parameter specified in a catch handler must be a simple identifier such as e or theException or x. The parameter can also be typed. When used with multiple catch blocks, typed parameters let you catch multiple types of error objects thrown from a single try block.

If the exception thrown is an object, the type will match if the thrown object is a subclass of the specified type. If an error of a specific type is thrown, the catch block that handles the corresponding error is executed. If an exception that is not of the specified type is thrown, the catch block does not execute and the exception is automatically thrown out of the try block to a catch handler that matches it.

If an error is thrown within a function, and the function does not include a catch handler, Flash Player exits that function, as well as any caller functions, until a catch block is found. During this process, finally handlers are called at all levels.

Parameters
error:* — The expression thrown from a throw statement, typically an instance of the Error class or one of its subclasses.

Example
The following example demonstrates a try..catch statement. The code within the try block includes an illegal operation. A sprite cannot add itself as a child. As a result, Flash Player throws an exception, and passes an object of type ArgumentError to the corresponding catch block.
import flash.display.Sprite;

var spr:Sprite = new Sprite();
try {
    spr.addChild(spr);
}
catch (e:ArgumentError) {
    trace (e); // output: ArgumentError: Error #2024: An object may not be added as a child of itself.
}
In the following example, the RecordSetException and MalformedRecord objects are subclasses of the Error class.
class RecordSetException extends Error {
    public function RecordSetException () {
        message = "Record set exception occurred.";
    }
}

class MalformedRecord extends Error {
    public function MalformedRecord {
        message = "Malformed record exception occurred.";
    }
}
Within the RecordSet class's sortRows() method, one of these previously defined error objects is thrown, depending on the type of exception that occurred. The following example shows how this code might look:
class RecordSet {
    public function sortRows() {
        var returnVal:Number = randomNum();
        if (returnVal == 1) {
            throw new RecordSetException();
        }
        else if (returnVal == 2) {
            throw new MalformedRecord();
        }
    }
    public function randomNum():Number {
        return Math.round(Math.random() * 10) % 3;
    }
}
Finally, the following code invokes the sortRows() method on an instance of the RecordSet class. It defines catch blocks for each type of error object that is thrown by sortRows().
import RecordSet;
var myRecordSet:RecordSet = new RecordSet();
try {
    myRecordSet.sortRows();
    trace("everything is fine");
}
catch (e:RecordSetException) {
    trace(e.toString());
}
catch (e:MalformedRecord) {
    trace(e.toString());
}

See also

Error class
throw
Working with the debugger version of Flash Player
Handling synchronous errors in an application
use namespace directive
Usage
use namespace ns1[, ns2, ...nsN]

Causes the specified namespaces to be added to the set of open namespaces. The specified namespaces are removed from the set of open namespaces when the current code block is exited. The use namespace directive can appear at the top level of a program, package definition, or class definition.

Parameters
nsN:Namespace — One or more namespaces to add to the set of open namespaces.

See also

default xml namespace
namespace
XML class
var definition keyword
Usage
var variableName [= value1][...,variableNameN[=valueN]]

Specifies a variable. If you declare variables inside a function, the variables are local. They are defined for the function and expire at the end of the function call.

If you declare variables outside a function, the variables are available throughout the timeline containing the statement.

You cannot declare a variable that is in the scope of another object as a local variable.

my_array.length = 25; // ok
var my_array.length = 25; // syntax error

You can assign a data type to a variable by appending a colon character followed by the data type.

You can declare multiple variables in one statement, separating the declarations with commas (although this syntax may reduce clarity in your code):

var first:String = "Bart", middle:String = "J.", last:String = "Bartleby";

Parameters
variableName:* — An identifier.

Example
The following ActionScript creates a new array of product names. Array.push adds an element onto the end of the array.
var product_array:Array = new Array("Studio", "Dreamweaver", "Flash", "ColdFusion", "Contribute", "Breeze");
product_array.push("Flex");
trace(product_array);
// output: Studio,Dreamweaver,Flash,ColdFusion,Contribute,Breeze,Flex

See also

const
Variables
while statement
Usage
while (condition) {
    // statement(s)
}

Evaluates a condition and if the condition evaluates to true, executes one or more statements before looping back to evaluate the condition again. After the condition evaluates to false, the statements are skipped and the loop ends.

The while statement performs the following series of steps. Each repetition of steps 1 through 4 is called an iteration of the loop. The condition is tested at the beginning of each iteration, as shown in the following steps:

  1. The expression condition is evaluated.
  2. If condition evaluates to true or a value that converts to the Boolean value true, such as a nonzero number, go to step 3.
    Otherwise, the while statement is completed and execution resumes at the next statement after the while loop.
  3. Run the statement block statement(s). If a continue statement is encountered, skip the remaining statements and go to step 1. If a break statement is encountered, the while statement is completed and execution resumes at the next statement after the while loop.
  4. Go to step 1.

Looping is commonly used to perform an action while a counter variable is less than a specified value. At the end of each loop, the counter is incremented until the specified value is reached. At that point, the condition is no longer true, and the loop ends.

The curly braces ({}) that enclose the statements to be executed by the while statement are not necessary if only one statement will execute.

Parameters
condition:Boolean — An expression that evaluates to true or false.

Example
In the following example, the while statement is used to test an expression. When the value of i is less than 20, the value of i is traced. When the condition is no longer true, the loop exits.
var i:Number = 0;
while (i < 20) {
    trace(i);
    i += 3;
}
/* output:
0
3
6
9
12
15
18
*/

See also

break
continue
do..while
Looping
with statement
Usage
with (object:Object) {
    // statement(s)
}

Establishes a default object to be used for the execution of a statement or statements, potentially reducing the amount of code that needs to be written.

The object parameter becomes the context in which the properties, variables, and functions in the statement(s) parameter are read. For example, if object is my_array, and two of the properties specified are length and concat, those properties are automatically read as my_array.length and my_array.concat. In another example, if object is state.california, any actions or statements inside the with statement are called from inside the california instance.

To find the value of an identifier in the statement(s) parameter, ActionScript starts at the beginning of the scope chain specified by object and searches for the identifier at each level of the scope chain, in a specific order.

The scope chain used by the with statement to resolve identifiers starts with the first item in the following list and continues to the last item:

  • The object specified in the object parameter in the innermost with statement
  • The object specified in the object parameter in the outermost with statement
  • The Activation object (a temporary object that is automatically created when the script calls a function that holds the local variables called in the function)
  • The object that contains the currently executing script
  • The Global object (built-in objects such as Math and String)

To set a variable inside a with statement, you must have declared the variable outside the with statement, or you must enter the full path to the Timeline on which you want the variable to live. If you set a variable in a with statement without declaring it, the with statement will look for the value according to the scope chain. If the variable doesn't already exist, the new value will be set on the Timeline from which the with statement was called.

Parameters
object:Object — An instance of an ActionScript object or movie clip.

Example
The following example sets the _x and _y properties of the someOther_mc instance, and then instructs someOther_mc to go to Frame 3 and stop.
with (someOther_mc) {
    _x = 50;
    _y = 100;
    gotoAndStop(3);
}
The following code snippet shows how to write the preceding code without using a with statement.
someOther_mc._x = 50;
someOther_mc._y = 100;
someOther_mc.gotoAndStop(3);

The with statement is useful for accessing multiple items in a scope chain list simultaneously. In the following example, the built-in Math object is placed at the front of the scope chain. Setting Math as a default object resolves the identifiers cos, sin, and PI to Math.cos, Math.sin, and Math.PI, respectively. The identifiers a, x, y, and r are not methods or properties of the Math object, but because they exist in the object activation scope of the function polar(), they resolve to the corresponding local variables.

function polar(r:Number):void {
    var a:Number, x:Number, y:Number;
    with (Math) {
        a = PI * pow(r, 2);
        x = r * cos(PI);
        y = r * sin(PI / 2);
    }
    trace("area = " + a);
    trace("x = " + x);
    trace("y = " + y);
} polar(3);
/* output:
area = 28.2743338823081
x = -3
y = 3
*/


Special Types (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Special Types

The three special types are the untyped specifier (*), void, and Null.

Type | Description
* | Specifies that a property is untyped.
void | Specifies that a function cannot return any value.
Null | A special data type that represents the lack of a value.
Special Type detail
* special type
Usage
propertyName:*

Specifies that a property is untyped. Use of the asterisk symbol for a type annotation is equivalent to using no type annotation. Expressions that read from untyped properties are considered untyped expressions. Use of untyped expressions or properties is recommended in the following circumstances:

  • When you want to defer type checking to runtime. You can use an untyped property or expression to circumvent compile-time type checking in strict mode. Note, however, that runtime type checking of assignment statements occurs whether you use strict mode or not.
  • When you want to store the value undefined in a property. Unlike previous versions of ActionScript, the value undefined is not a member of the Object data type. You must use an untyped property to store the value undefined.

See also

Object
void special type
Usage
functionName():void {}

Specifies that a function cannot return any value. The void type is a special type that contains exactly one value: undefined. It is special in that its use is limited to the return type of a function. You cannot use void as a type annotation for a property.

See also

undefined
Data type descriptions
Null special type

A special data type that represents the lack of a value. The Null data type includes only one value: null. The Null data type is special in that it is not associated with a class. This means that you cannot use the Null data type as a type annotation for a property.

See also

null
Data type descriptions


Symbols Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
Symbols Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
@ (attribute identifier) — Operator
 | Identifies attributes of an XML or XMLList object.
* — Special Type
 | Specifies that a property is untyped.
+ (addition) — Operator
 | Adds numeric expressions.
+= (addition assignment) — Operator
 | Assigns expression1 the value of expression1 + expression2.
[] (array access) — Operator
 | Initializes a new array or multidimensional array with the specified elements (a0, and so on), or accesses elements in an array.
= (assignment) — Operator
 | Assigns the value of expression2 (the operand on the right) to the variable, array element, or property in expression1.
& (bitwise AND) — Operator
 | Converts expression1 and expression2 to 32-bit unsigned integers, and performs a Boolean AND operation on each bit of the integer parameters.
&= (bitwise AND assignment) — Operator
 | Assigns expression1 the value of expression1 & expression2.
<< (bitwise left shift) — Operator
 | Converts expression1 and shiftCount to 32-bit integers, and shifts all the bits in expression1 to the left by the number of places specified by the integer resulting from the conversion of shiftCount.
<<= (bitwise left shift and assignment) — Operator
 | Performs a bitwise left shift (<<=) operation and stores the contents as a result in expression1.
~ (bitwise NOT) — Operator
 | Converts expression to a 32-bit signed integer, and then applies a bitwise one's complement.
| (bitwise OR) — Operator
 | Converts expression1 and expression2 to 32-bit unsigned integers, and places a 1 in each bit position where the corresponding bits of either expression1 or expression2 are 1.
|= (bitwise OR assignment) — Operator
 | Assigns expression1 the value of expression1 | expression2.
>> (bitwise right shift) — Operator
 | Converts expression and shiftCount to 32-bit integers, and shifts all the bits in expression to the right by the number of places specified by the integer that results from the conversion of shiftCount.
>>= (bitwise right shift and assignment) — Operator
 | Performs a bitwise right-shift operation and stores the result in expression.
>>> (bitwise unsigned right shift) — Operator
 | The same as the bitwise right shift (>>) operator except that it does not preserve the sign of the original expression because the bits on the left are always filled with 0.
>>>= (bitwise unsigned right shift and assignment) — Operator
 | Performs an unsigned bitwise right-shift operation and stores the result in expression.
^ (bitwise XOR) — Operator
 | Converts expression1 and expression2 to 32-bit unsigned integers, and places a 1 in each bit position where the corresponding bits in expression1 or expression2, but not both, are 1.
^= (bitwise XOR assignment) — Operator
 | Assigns expression1 the value of expression1 ^ expression2.
/*..*/ (block comment delimiter) — Operator
 | Delimits one or more lines of script comments.
{ } (braces (XML)) — Operator
 | Evaluates an expression that is used in an XML or XMLList initializer.
[ ] (brackets (XML)) — Operator
 | Accesses a property or attribute of an XML or XMLList object.
, (comma) — Operator
 | Evaluates expression1, then expression2, and so on.
+ (concatenation) — Operator
 | Concatenates (combines) strings.
+= (concatenation assignment) — Operator
 | Assigns expression1 the value of expression1 + expression2.
+= (concatenation assignment (XMLList)) — Operator
 | Assigns expression1, which is an XMLList object, the value of expression1 + expression2.
+ (concatenation (XMLList)) — Operator
 | Concatenates (combines) XML or XMLList values into an XMLList object.
?: (conditional) — Operator
 | Evaluates expression1, and if the value of expression1 is true, the result is the value of expression2; otherwise the result is the value of expression3.
-- (decrement) — Operator
 | Subtracts 1 from the operand.
.. (descendant accessor) — Operator
 | Navigates to descendant elements of an XML or XMLList object, or (combined with the @ operator) finds matching attributes of descendants.
/ (division) — Operator
 | Divides expression1 by expression2.
/= (division assignment) — Operator
 | Assigns expression1 the value of expression1 / expression2.
. (dot) — Operator
 | Accesses class variables and methods, gets and sets object properties, and delimits imported packages or classes.
. (dot (XML)) — Operator
 | Navigates to child elements of an XML or XMLList object, or (combined with the @ operator) returns attributes of an XML or XMLList object.
== (equality) — Operator
 | Tests two expressions for equality.
> (greater than) — Operator
 | Compares two expressions and determines whether expression1 is greater than expression2; if it is, the result is true.
>= (greater than or equal to) — Operator
 | Compares two expressions and determines whether expression1 is greater than or equal to expression2 (true) or expression1 is less than expression2 (false).
++ (increment) — Operator
 | Adds 1 to an expression.
!= (inequality) — Operator
 | Tests for the exact opposite of the equality (==) operator.
< (less than) — Operator
 | Compares two expressions and determines whether expression1 is less than expression2; if so, the result is true.
<= (less than or equal to) — Operator
 | Compares two expressions and determines whether expression1 is less than or equal to expression2; if it is, the result is true.
// (line comment delimiter) — Operator
 | Indicates the beginning of a script comment.
&& (logical AND) — Operator
 | Returns expression1 if it is false or can be converted to false, and expression2 otherwise.
! (logical NOT) — Operator
 | Inverts the Boolean value of a variable or expression.
|| (logical OR) — Operator
 | Returns expression1 if it is true or can be converted to true, and expression2 otherwise.
% (modulo) — Operator
 | Calculates the remainder of expression1 divided by expression2.
%= (modulo assignment) — Operator
 | Assigns expression1 the value of expression1 % expression2.
* (multiplication) — Operator
 | Multiplies two numerical expressions.
*= (multiplication assignment) — Operator
 | Assigns expression1 the value of expression1 * expression2.
:: (name qualifier) — Operator
 | Identifies the namespace of a property, a method, an XML property, or an XML attribute.
{} (object initializer) — Operator
 | Creates a new object and initializes it with the specified name and value property pairs.
() (parentheses) — Operator
 | Performs a grouping operation on one or more parameters, performs sequential evaluation of expressions, or surrounds one or more parameters and passes them as arguments to a function that precedes the parentheses.
( ) (parentheses (XML)) — Operator
 | Evaluates an expression in an E4X XML construct.
/ (RegExp delimiter) — Operator
 | When used before and after characters, indicates that the characters have a literal value and are considered a regular expression (RegExp), not a variable, string, or other ActionScript element.
... (rest) parameter — Statement
 | Specifies that a function will accept any number of comma-delimited arguments.
=== (strict equality) — Operator
 | Tests two expressions for equality, but does not perform automatic data conversion.
!== (strict inequality) — Operator
 | Tests for the exact opposite of the strict equality (===) operator.
" (string delimiter) — Operator
 | When used before and after characters, indicates that the characters have a literal value and are considered a string, not a variable, numerical value, or other ActionScript element.
- (subtraction) — Operator
 | Used for negating or subtracting.
-= (subtraction assignment) — Operator
 | Assigns expression1 the value of expression1 - expression2.
: (type) — Operator
 | Used for assigning a data type; this operator specifies the variable type, function return type, or function parameter type.
< > (XML literal tag delimiter) — Operator
 | Defines an XML tag in an XML literal.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


A Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
A Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
a — Property in class flash.geom.Matrix
 | The value in the first row and first column of the Matrix object, which affects the positioning of pixels along the x axis when scaling or rotating an image.
abs(val:Number) — Static method in class Math
 | Computes and returns an absolute value for the number specified by the parameter val.
ABSOLUTE — Constant static property in class mx.core.ContainerLayout
 | Use absolute layout for the contents of this container.
AbstractEvent — Class in package mx.rpc.events
 | The base class for events that RPC services dispatch.
AbstractInvoker — Class in package mx.rpc
 | An invoker is an object that actually executes an remote procedure call (RPC).
AbstractMessage — Class in package mx.messaging.messages
 | Abstract base class for all messages.
AbstractMessage() — Constructor in class mx.messaging.messages.AbstractMessage
 | Constructs an instance of an AbstractMessage with an empty body and header.
AbstractOperation — Class in package mx.rpc
 | The AbstractOperation class represents an is an individual method on a service.
AbstractOperation(service:mx.rpc:AbstractService, name:String) — Constructor in class mx.rpc.AbstractOperation
 | Creates a new Operation.
AbstractService — Dynamic class in package mx.rpc
 | the AbstractService class is the base class for the WebService and RemoteObject classes.
AbstractService(destination:String) — Constructor in class mx.rpc.AbstractService
AbstractTarget — Class in package mx.logging
 | This class provides the basic functionality required by the logging framework for a target implementation.
AbstractTarget() — Constructor in class mx.logging.AbstractTarget
 | Constructor.
acceptAllClient() — Method in class mx.data.Conflicts
 | This is a convience method that iterates all of the conflicts within this list and invokes the Conflict.acceptClient() method.
acceptAllServer() — Method in class mx.data.Conflicts
 | This is a convience method that iterates all of the conflicts within this list and invokes the Conflict.acceptClient() method.
acceptClient() — Method in class mx.data.Conflict
 | Requeues the current local changes and updates the property values such that a subsequent call to DataService.commit() should succeed, causing these changes to override the previous ones.
acceptDragDrop(target:mx.core:IUIComponent) — Static method in class mx.managers.DragManager
 | Call this method from your dragEnter event handler if you accept the drag/drop data.
acceptServer() — Method in class mx.data.Conflict
 | Removes the conflicting local change and applies the property values found on Conflict.serverObject to the local item.
Accessibility — Final class in package flash.accessibility
 | The Accessibility class manages communication with screen readers.
accessibilityProperties — Property in class flash.display.DisplayObject
 | The current accessibility options for this display object.
AccessibilityProperties — Class in package flash.accessibility
 | The AccessibilityProperties class lets you control the presentation of Flash objects to accessibility aids, such as screen readers.
AccessibilityProperties() — Constructor in class flash.accessibility.AccessibilityProperties
 | Creates a new AccessibilityProperties object.
Accordion — Class in package mx.containers
 | An Accordion navigator container has a collection of child containers, but only one of them at a time is visible.
Accordion() — Constructor in class mx.containers.Accordion
 | Constructor.
AccordionHeader — Class in package mx.containers.accordionClasses
 | The AccordionHeader class defines the appearance of the navigation buttons of an Accordion.
AccordionHeader() — Constructor in class mx.containers.accordionClasses.AccordionHeader
 | Constructor.
AccordionHeaderSkin — Class in package mx.skins.halo
 | The skin for all the states of an AccordionHeader in an Accordion.
AccordionHeaderSkin() — Constructor in class mx.skins.halo.AccordionHeaderSkin
 | Constructor.
accurate — Property in class mx.charts.chartClasses.AxisLabelSet
 | When returned from the getLabelEsimate() function, set to true if the estimate accurately represents the final labels to be rendered.
acknowledge — Event in class mx.messaging.MessageAgent
 | Dispatched when an acknowledge message is received for a sent message.
acknowledge(ackMsg:mx.messaging.messages:AcknowledgeMessage, msg:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageAgent
 | Invoked by a MessageResponder upon receiving a result for a sent message.
ACKNOWLEDGE — Constant static property in class mx.messaging.events.MessageAckEvent
 | The ACKNOWLEDGE event type; dispatched upon receipt of an acknowledgement.
acknowledgeMessage — Property in class mx.messaging.events.MessageAckEvent
 | Utility property to get the message property from the MessageEvent as an AcknowledgeMessage.
AcknowledgeMessage — Class in package mx.messaging.messages
 | An AcknowledgeMessage acknowledges the receipt of a message that was sent previously.
AcknowledgeMessage() — Constructor in class mx.messaging.messages.AcknowledgeMessage
 | Constructs an instance of an AcknowledgeMessage with an empty body and header.
acos(val:Number) — Static method in class Math
 | Computes and returns the arc cosine of the number specified in the parameter val, in radians.
action — Property in class mx.events.DragEvent
 | The requested action.
ACTION — Constant property in class mx.messaging.management.MBeanOperationInfo
 | The operation is write-like, updating the control in some way.
ActionEffectInstance — Class in package mx.effects.effectClasses
 | The ActionEffectInstance class is the superclass for all action effect instance classes.
ActionEffectInstance(target:Object) — Constructor in class mx.effects.effectClasses.ActionEffectInstance
 | Constructor.
ACTION_INFO — Constant property in class mx.messaging.management.MBeanOperationInfo
 | The operation is both read-like and write-like, updating the control and returning information.
ACTIONSCRIPT2 — Constant static property in class flash.display.ActionScriptVersion
 | ActionScript language version 2.0 and earlier.
ACTIONSCRIPT3 — Constant static property in class flash.display.ActionScriptVersion
 | ActionScript language version 3.0.
actionScriptVersion — Property in class flash.display.LoaderInfo
 | The ActionScript version of the loaded SWF file.
ActionScriptVersion — Final class in package flash.display
 | The ActionScriptVersion class is an enumeration of constant values that indicate the language version of a loaded SWF file.
activate — Event in class flash.display.DisplayObject
 | Dispatched when Flash Player gains operating system focus and becomes active.
activate() — Method in class mx.managers.FocusManager
 | The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time.
activate() — Method in interface mx.managers.IFocusManager
 | The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time.
activate(f:mx.managers:IFocusManagerContainer) — Method in interface mx.managers.ISystemManager
 | Activates the FocusManager in an IFocusManagerContainer.
activate(f:mx.managers:IFocusManagerContainer) — Method in class mx.managers.SystemManager
 | Activates the FocusManager in an IFocusManagerContainer.
ACTIVATE — Constant static property in class flash.events.Event
 | Defines the value of the type property of an activate event object.
activating — Property in class flash.events.ActivityEvent
 | Indicates whether the device is activating (true) or deactivating (false).
ActivatorSkin — Class in package mx.skins.halo
 | Defines the up, down, and over states for MenuBarItem objects.
ActivatorSkin() — Constructor in class mx.skins.halo.ActivatorSkin
 | Constructor.
active — Static property in class flash.accessibility.Accessibility
 | Indicates whether a screen reader is currently active and the player is communicating with it.
activity — Event in class flash.media.Camera
 | Dispatched when a camera begins or ends a session.
activity — Event in class flash.media.Microphone
 | Dispatched when a microphone begins or ends a session.
ACTIVITY — Constant static property in class flash.events.ActivityEvent
 | The ActivityEvent.ACTIVITY constant defines the value of the type property of an activity event object.
ActivityEvent — Class in package flash.events
 | Flash® Player dispatches an ActivityEvent object whenever a camera or microphone reports that it has become active or inactive.
ActivityEvent(type:String, bubbles:Boolean, cancelable:Boolean, activating:Boolean) — Constructor in class flash.events.ActivityEvent
 | Creates an event object that contains information about activity events.
activityLevel — Property in class flash.media.Camera
 | A numeric value that specifies the amount of motion the camera is detecting.
activityLevel — Property in class flash.media.Microphone
 | The amount of sound the microphone is detecting.
actualCreationPolicy — Property in class mx.core.Container
 | The creation policy of this container.
actualListeners — Property in class mx.validators.Validator
 | Contains an Array of listener objects, if any, or the source object.
actualTrigger — Property in class mx.validators.Validator
 | Contains the trigger object, if any, or the source object.
add(v:flash.geom:Point) — Method in class flash.geom.Point
 | Adds the coordinates of another point to the coordinates of this point to create a new point.
add — Event in class mx.core.UIComponent
 | Dispatched when the component is added to a container as a content child by using the addChild() or addChildAt() method.
ADD — Constant static property in class flash.display.BlendMode
 | Adds the values of the constituent colors of the display object to the colors of its background, applying a ceiling of 0xFF.
ADD — Constant static property in class mx.events.CollectionEventKind
 | Indicates that the collection added an item or items.
ADD — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.ADD constant defines the value of the type property of the event object for an add event.
addCallback(functionName:String, closure:Function) — Static method in class flash.external.ExternalInterface
 | Registers an ActionScript method as callable from the container.
addChannel(channel:mx.messaging:Channel) — Method in class mx.messaging.ChannelSet
 | Adds a Channel to the ChannelSet.
addChild(child:flash.display:DisplayObject) — Method in class flash.display.DisplayObjectContainer
 | Adds a child DisplayObject instance to this DisplayObjectContainer instance.
addChild(child:flash.display:DisplayObject) — Method in class flash.display.Stage
 | Adds a child DisplayObject instance to this DisplayObjectContainer instance.
addChild(child:flash.display:DisplayObject) — Method in class mx.charts.chartClasses.ChartElement
 | Adds a child DisplayObject after the end of this child list.
addChild(child:flash.display:DisplayObject) — Method in class mx.core.Container
 | Adds a child DisplayObject to this Container.
addChild(child:flash.display:DisplayObject) — Method in interface mx.core.IChildList
 | Adds a child DisplayObject after the end of this child list.
addChild(childEffect:mx.effects:Effect) — Method in class mx.effects.CompositeEffect
 | Adds a new child effect to this composite effect.
AddChild — Class in package mx.states
 | The AddChild class adds a child display object, such as a component, to a container as part of a view state.
AddChild(relativeTo:mx.core:UIComponent, target:flash.display:DisplayObject, position:String) — Constructor in class mx.states.AddChild
 | Constructor.
AddChildAction — Class in package mx.effects
 | The AddChildAction class defines an action effect that corresponds to the AddChild property of a view state definition.
AddChildAction(target:Object) — Constructor in class mx.effects.AddChildAction
 | Constructor.
AddChildActionInstance — Class in package mx.effects.effectClasses
 | The AddChildActionInstance class implements the instance class for the AddChildAction effect.
AddChildActionInstance(target:Object) — Constructor in class mx.effects.effectClasses.AddChildActionInstance
 | Constructor.
addChildAt(child:flash.display:DisplayObject, index:int) — Method in class flash.display.DisplayObjectContainer
 | Adds a child DisplayObject instance to this DisplayObjectContainer instance.
addChildAt(child:flash.display:DisplayObject, index:int) — Method in class flash.display.Stage
 | Adds a child DisplayObject instance to this DisplayObjectContainer instance.
addChildAt(child:flash.display:DisplayObject, index:int) — Method in class mx.charts.chartClasses.ChartElement
 | Adds a child DisplayObject instance to this DisplayObjectContainer instance.
addChildAt(parent:Object, newChild:Object, index:int, model:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Add a child node to a node at the specified index.
addChildAt(parent:Object, newChild:Object, index:int, model:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Add a child node to a node at the specified index.
addChildAt(parent:Object, newChild:Object, index:int, model:Object) — Method in interface mx.controls.treeClasses.ITreeDataDescriptor
 | Adds a child node to a node at the specified index.
addChildAt(child:flash.display:DisplayObject, index:int) — Method in class mx.core.Container
 | Adds a child DisplayObject to this Container.
addChildAt(child:flash.display:DisplayObject, index:int) — Method in interface mx.core.IChildList
 | Adds a child DisplayObject to this child list at the index specified.
addChildSet(childSet:Array) — Method in class mx.effects.effectClasses.CompositeEffectInstance
 | Adds a new set of child effects to this Composite effect.
addCuePoint(cuePoint:Object) — Method in class mx.controls.videoClasses.CuePointManager
 | Adds a cue point.
addData(data:Object, format:String) — Method in class mx.core.DragSource
 | Adds data and a corresponding format String to the drag source.
addDragData(ds:Object) — Method in class mx.controls.listClasses.ListBase
 | Adds the selected items to the DragSource object as part of a drag-and-drop operation.
added — Event in class flash.display.DisplayObject
 | Dispatched when a display object is added to the display list.
ADDED — Constant static property in class flash.events.Event
 | Defines the value of the type property of an added event object.
addedEffect — Effect in class mx.core.UIComponent
 | Played when the component is added as a child to a Container.
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — Method in class flash.display.Stage
 | Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — Method in class flash.events.EventDispatcher
 | Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — Method in interface flash.events.IEventDispatcher
 | Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — Method in class mx.collections.ListCollectionView
 | Registers an event listener object with an EventDispatcher object so that the listener receives notification of an event.
addEventListener(type:String, listener:Function, useCapture:Boolean, priority:int, useWeakReference:Boolean) — Method in class mx.utils.ObjectProxy
 | Registers an event listener object so that the listener receives notification of an event.
addFocusManager(f:mx.managers:IFocusManagerContainer) — Method in interface mx.managers.ISystemManager
 | Registers a top-level window containing a FocusManager.
addFocusManager(f:mx.managers:IFocusManagerContainer) — Method in class mx.managers.SystemManager
 | Registers a top-level window containing a FocusManager.
addHaloColors(colors:Object, themeColor:uint, fillColor0:uint, fillColor1:uint) — Static method in class mx.skins.halo.HaloColors
 | Calculates colors that are used by components that support the Halo theme, such as the colors of beveled edges.
addHandler(handler:Function, format:String) — Method in class mx.core.DragSource
 | Adds a handler that is called when data for the specified format is requested.
addHeader(operation:String, mustUnderstand:Boolean, param:Object) — Method in class flash.net.NetConnection
 | Adds a context header to the AMF packet structure.
addHeader(header:mx.rpc.soap:SOAPHeader) — Method in class mx.rpc.soap.Operation
 | Adds a header that is applied only to this Operation.
addHeader(header:mx.rpc.soap:SOAPHeader) — Method in class mx.rpc.soap.WebService
 | Adds a header that will be applied to all operations of this web service.
addItem(item:Object) — Method in interface mx.collections.IList
 | Adds the specified item to the end of the list.
addItem(item:Object) — Method in class mx.collections.ListCollectionView
 | Adds the specified item to the end of the list.
addItemAt(item:Object, index:int) — Method in interface mx.collections.IList
 | Adds the item at the specified index.
addItemAt(item:Object, index:int) — Method in class mx.collections.ListCollectionView
 | Adds the item at the specified index.
addListenerHandler() — Method in class mx.validators.Validator
 | Sets up all of the listeners for the valid and invalid events dispatched from the validator.
addLogger(logger:mx.logging:ILogger) — Method in class mx.logging.AbstractTarget
 | Sets up this target with the specified logger.
addLogger(logger:mx.logging:ILogger) — Method in interface mx.logging.ILoggingTarget
 | Sets up this target with the specified logger.
addNamespace(ns:Object) — Method in class XML
 | Adds a namespace to the set of in-scope namespaces for the XML object.
addObject(obj:mx.core:IUIComponent, scaleType:String) — Method in class mx.printing.FlexPrintJob
 | Adds a UIComponent object to the list of objects being printed.
addPage(sprite:flash.display:Sprite, printArea:flash.geom:Rectangle, options:flash.printing:PrintJobOptions, frameNum:int) — Method in class flash.printing.PrintJob
 | Sends the specified Sprite object as a single page to the print spooler.
addPopUp(window:mx.core:IFlexDisplayObject, parent:flash.display:DisplayObject, modal:Boolean, childList:String) — Static method in class mx.managers.PopUpManager
 | Pops up a top-level window.
addResponder(responder:mx.rpc:IResponder) — Method in class mx.collections.errors.ItemPendingError
 | addResponder adds a responder to an Array of responders.
addResponder(responder:mx.rpc:IResponder) — Method in class mx.rpc.AsyncToken
 | addResponder adds a responder to an Array of responders.
addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String) — Method in class mx.rpc.soap.Operation
 | Adds a header that is applied only to this Operation.
addSimpleHeader(qnameLocal:String, qnameNamespace:String, headerName:String, headerValue:String) — Method in class mx.rpc.soap.WebService
 | Add a header that will be applied to all operations of this WebService.
addTarget(target:mx.logging:ILoggingTarget) — Static method in class mx.logging.Log
 | Allows the specified target to begin receiving notification of log events.
addToCreationQueue(id:Object, preferredIndex:int, callbackFunc:Function, parent:mx.core:IFlexDisplayObject) — Method in class mx.core.Application
 | Add a container to the Application's creation queue.
addToFreeItemRenderers(item:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.ListBase
 | Adds a renderer to the recycled renderer list, making it invisible and cleaning up references to it.
adjustBrightness(rgb:uint, brite:Number) — Static method in class mx.utils.ColorUtil
 | Performs a linear brightness adjustment of an RGB color.
adjustBrightness2(rgb:uint, brite:Number) — Static method in class mx.utils.ColorUtil
 | Performs a scaled brightness adjustment of an RGB color.
adjustFocusRect(obj:flash.display:DisplayObject) — Method in class mx.core.UIComponent
 | Adjust the focus rectangle.
adjustGutters(workingGutters:flash.geom:Rectangle, adjustable:Object) — Method in class mx.charts.AxisRenderer
 | Adjusts its layout to accomodate the gutters passed in.
adjustGutters(workingGutters:flash.geom:Rectangle, adjustable:Object) — Method in interface mx.charts.chartClasses.IAxisRenderer
 | Adjusts its layout to accomodate the gutters passed in.
adjustMinMax(minValue:Number, maxValue:Number) — Method in class mx.charts.chartClasses.NumericAxis
 | Adjusts the generated or assigned range of the axis's labels.
ADVANCED — Constant static property in class flash.text.AntiAliasType
 | Sets anti-aliasing to advanced anti-aliasing.
afterLast — Property in interface mx.collections.IViewCursor
 | If the cursor is located after the last item in the view, this property is true .
agent — Property in class mx.messaging.MessageResponder
 | Provides access to the MessageAgent that sent the message.
album — Property in class flash.media.ID3Info
 | The name of the album; corresponds to the ID3 2.0 tag TALB.
Alert — Class in package mx.controls
 | The Alert control is a pop-up dialog box that can contain a message, a title, buttons (any combination of OK, Cancel, Yes, and No) and an icon.
Alert() — Constructor in class mx.controls.Alert
 | Constructor.
align — Property in class flash.display.Stage
 | A value from the StageAlign class that specifies the alignment of the stage in Flash Player or the browser.
align — Property in class flash.text.TextFormat
 | Indicates the alignment of the paragraph.
alignLabelsToUnits — Property in class mx.charts.DateTimeAxis
 | Determines the placement of labels along the axis.
alignSymbol — Property in class mx.formatters.CurrencyFormatter
 | Aligns currency symbol to the left side or the right side of the formatted number.
alignSymbol — Property in class mx.validators.CurrencyValidator
 | Specifies the alignment of the currencySymbol relative to the rest of the expression.
ALL — Constant static property in class mx.core.ContainerCreationPolicy
 | Immediately create all descendants.
ALL — Constant static property in class mx.logging.LogEventLevel
 | Tells a target to process all messages.
allElements — Property in class mx.charts.chartClasses.ChartBase
 | The set of all chart elements displayed in the chart.
allowDisjointSelection — Property in class mx.controls.DateChooser
 | If true, specifies that non-contiguous(disjoint) selection is allowed in the DateChooser control.
allowDomain(... rest) — Method in class flash.net.LocalConnection
 | Specifies one or more domains that can send LocalConnection calls to this LocalConnection instance.
allowDomain(... rest) — Static method in class flash.system.Security
 | Lets SWF files and HTML files in the identified domains access objects and variables in the SWF file that contains the allowDomain() call.
allowDragSelection — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether drag-selection is enabled.
allowedFormatChars — Property in class mx.validators.CreditCardValidator
 | The set of formatting characters allowed in the cardNumber field.
allowedFormatChars — Property in class mx.validators.DateValidator
 | The set of formatting characters allowed for separating the month, day, and year values.
allowedFormatChars — Property in class mx.validators.PhoneNumberValidator
 | The set of allowable formatting characters.
allowedFormatChars — Property in class mx.validators.SocialSecurityValidator
 | Specifies the set of formatting characters allowed in the input.
allowedFormatChars — Property in class mx.validators.ZipCodeValidator
 | The set of formatting characters allowed in the ZIP code.
allowInsecureDomain(... rest) — Method in class flash.net.LocalConnection
 | Specifies one or more domains that can send LocalConnection calls to this LocalConnection object.
allowInsecureDomain(... rest) — Static method in class flash.system.Security
 | Lets SWF files and HTML files in the identified domains access objects and variables in the calling SWF file, which is hosted by means of the HTTPS protocol.
allowMultipleSelection — Property in class mx.controls.DateChooser
 | If true, specifies that multiple selection is allowed in the DateChooser control.
allowMultipleSelection — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether you can allow more than one item to be selected at the same time.
allowNegative — Property in class mx.validators.CurrencyValidator
 | Specifies whether negative numbers are permitted.
allowNegative — Property in class mx.validators.NumberValidator
 | Specifies whether negative numbers are permitted.
allowThumbOverlap — Property in class mx.controls.sliderClasses.Slider
 | If set to false, then each thumb can only be moved to the edge of the adjacent thumb.
allowTrackClick — Property in class mx.controls.sliderClasses.Slider
 | Specifies whether clicking on the track will move the slider thumb.
alpha — Property in class flash.display.DisplayObject
 | Indicates the alpha transparency value of the object specified.
alpha — Property in class flash.filters.ConvolutionFilter
 | The alpha transparency value of the substitute color.
alpha — Property in class flash.filters.DisplacementMapFilter
 | Specifies the alpha transparency value to use for out-of-bounds displacements.
alpha — Property in class flash.filters.DropShadowFilter
 | The alpha transparency value for the shadow color.
alpha — Property in class flash.filters.GlowFilter
 | The alpha transparency value for the color.
alpha — Property in interface mx.core.IFlexDisplayObject
 | The transparency of this object.
alpha — Property in class mx.graphics.GradientEntry
 | The transparency of a gradient fill.
alpha — Property in class mx.graphics.RectangularDropShadow
 | The alpha transparency value for the shadow color.
alpha — Property in class mx.graphics.SolidColor
 | The transparency of a color.
alpha — Property in class mx.graphics.Stroke
 | The transparency of a line.
ALPHA — Constant static property in class flash.display.BitmapDataChannel
 | The alpha channel.
ALPHA — Constant static property in class flash.display.BlendMode
 | Applies the alpha value of each pixel of the display object to the background.
alphaFrom — Property in class mx.effects.Dissolve
 | Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaFrom — Property in class mx.effects.Fade
 | Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaFrom — Property in class mx.effects.Glow
 | Starting transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaFrom — Property in class mx.effects.effectClasses.DissolveInstance
 | Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaFrom — Property in class mx.effects.effectClasses.FadeInstance
 | Initial transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaFrom — Property in class mx.effects.effectClasses.GlowInstance
 | Starting transparency level.
alphaMultiplier — Property in class flash.geom.ColorTransform
 | A decimal value that is multiplied with the alpha transparency channel value.
ALPHANUMERIC_FULL — Constant static property in class flash.system.IMEConversionMode
 | The string "ALPHANUMERIC_FULL", for use with the IME.conversionMode property.
ALPHANUMERIC_HALF — Constant static property in class flash.system.IMEConversionMode
 | The string "ALPHANUMERIC_HALF", for use with the IME.conversionMode property.
alphaOffset — Property in class flash.geom.ColorTransform
 | A number from -255 to 255 that is added to the alpha transparency channel value after it has been multiplied by the alphaMultiplier value.
alphas — Property in class flash.filters.GradientBevelFilter
 | An array of alpha transparency values for the corresponding colors in the colors array.
alphas — Property in class flash.filters.GradientGlowFilter
 | An array of alpha transparency values for the corresponding colors in the colors array.
alphaTo — Property in class mx.effects.Dissolve
 | Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaTo — Property in class mx.effects.Fade
 | Final transparency level, where 0.0 means transparent and 1.0 means fully opaque.
alphaTo — Property in class mx.effects.Glow
 | Ending transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaTo — Property in class mx.effects.effectClasses.DissolveInstance
 | Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaTo — Property in class mx.effects.effectClasses.FadeInstance
 | Final transparency level between 0.0 and 1.0, where 0.0 means transparent and 1.0 means fully opaque.
alphaTo — Property in class mx.effects.effectClasses.GlowInstance
 | Ending transparency level.
alternatingItemColors — Style in class mx.controls.ComboBox
 | The set of BackgroundColors for drop-down list rows in an alternating pattern.
alternatingItemColors — Style in class mx.controls.Menu
 | The colors used for menu or submenu menu items in an alternating pattern.
alternatingItemColors — Style in class mx.controls.Tree
 | Colors for rows in an alternating pattern.
alternatingItemColors — Style in class mx.controls.listClasses.ListBase
 | The colors to use for the backgrounds of the items in the list.
altKey — Property in class flash.events.KeyboardEvent
 | Reserved for future use.
altKey — Property in class flash.events.MouseEvent
 | Reserved for future use.
ALWAYS — Constant static property in class flash.display.PixelSnapping
 | A constant value used in the pixelSnapping property of a Bitmap object to specify that the bitmap image is always snapped to the nearest pixel, independent of any transformation.
alwaysShowSelection — Property in class flash.text.TextField
 | When set to true and the text field is not in focus, Flash Player highlights the selection in the text field in gray.
AMERICAN_EXPRESS — Constant static property in class mx.validators.CreditCardValidatorCardType
 | Specifies the card type as American Express.
AMF0 — Constant static property in class flash.net.ObjectEncoding
 | Specifies that objects are serialized using the Action Message Format for ActionScript 1.0 and 2.0.
AMF3 — Constant static property in class flash.net.ObjectEncoding
 | Specifies that objects are serialized using the Action Message Format for ActionScript 3.0.
AMFChannel — Class in package mx.messaging.channels
 | The AMFChannel class provides the AMF support for messaging.
AMFChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.AMFChannel
 | Creates an new AMFChannel instance.
anchorBookmark — Property in class mx.controls.listClasses.ListBase
 | A bookmark to the item that is the anchor.
anchorIndex — Property in class mx.controls.listClasses.ListBase
 | The offset of the item in the data provider that is the selection anchor point.
angle — Property in class flash.filters.BevelFilter
 | The angle of the bevel.
angle — Property in class flash.filters.DropShadowFilter
 | The angle of the shadow.
angle — Property in class flash.filters.GradientBevelFilter
 | The angle, in degrees.
angle — Property in class flash.filters.GradientGlowFilter
 | The angle, in degrees.
angle — Property in class mx.charts.series.items.PieSeriesItem
 | The angle, in radians, that this wedge subtends.
angle — Property in class mx.graphics.LinearGradient
 | Controls the transition direction.
angle — Property in class mx.graphics.LinearGradientStroke
 | By default, the LinearGradientStroke defines a transition from left to right across the control.
angle — Property in class mx.graphics.RadialGradient
 | Sets the location of the start of the radial fill.
angle — Property in class mx.graphics.RectangularDropShadow
 | The angle of the shadow.
angleFrom — Property in class mx.effects.Rotate
 | The starting angle of rotation of the target object, expressed in degrees.
angleFrom — Property in class mx.effects.effectClasses.RotateInstance
 | The starting angle of rotation of the target object, expressed in degrees.
angleTo — Property in class mx.effects.Rotate
 | The ending angle of rotation of the target object, expressed in degrees.
angleTo — Property in class mx.effects.effectClasses.RotateInstance
 | The ending angle of rotation of the target object, expressed in degrees.
angularAxis — Property in class mx.charts.chartClasses.PolarChart
 | The axis object used to map data values to an angle between 0 and 2 PI.
ANGULAR_AXIS — Constant static property in class mx.charts.chartClasses.PolarTransform
 | A string representing the angular axis.
animate — Property in class mx.events.TreeEvent
 | Whether to animate an opening or closing operation; used for ITEM_OPENING type events only.
AnimateProperty — Class in package mx.effects
 | The AnimateProperty effect animates a property or style of a component.
AnimateProperty(target:Object) — Constructor in class mx.effects.AnimateProperty
 | Constructor.
AnimatePropertyInstance — Class in package mx.effects.effectClasses
 | The AnimatePropertyInstance class implements the instance class for the AnimateProperty effect.
AnimatePropertyInstance(target:Object) — Constructor in class mx.effects.effectClasses.AnimatePropertyInstance
 | Constructor.
annotationElements — Property in class mx.charts.chartClasses.ChartBase
 | Sets an Array of ChartElements that appears on top of any data series rendered by the chart.
antiAliasType — Property in class flash.text.TextField
 | The type of anti-aliasing used for this text field.
antiAliasType — Property in class mx.core.UITextFormat
 | Defines the anti-aliasing setting for the UITextField class.
AntiAliasType — Final class in package flash.text
 | The AntiAliasType class provides values for anti-aliasing in the flash.text.TextField class.
ANY — Constant static property in class mx.validators.CurrencyValidatorAlignSymbol
 | Specifies "any" as the alignment of the currency symbol for the CurrencyValidator class.
ANY_INDEX_MODE — Constant static property in class mx.collections.Sort
 | When executing a find return the index any matching item.
appendChild(child:Object) — Method in class XML
 | Appends the given child to the end of the XML object's properties.
appendChild(node:flash.xml:XMLNode) — Method in class flash.xml.XMLNode
 | Appends the specified node to the XML object's child list.
appendText(newText:String) — Method in class flash.text.TextField
 | Appends the string specified by the newText parameter to the end of the text of the TextField.
application — Static property in class mx.core.Application
 | A reference to the top-level application.
application — Property in class mx.managers.SystemManager
 | The application parented by this SystemManager.
Application — Class in package mx.core
 | Flex defines a default, or Application, container that lets you start adding content to your application without explicitly defining another container.
Application() — Constructor in class mx.core.Application
 | Constructor.
APPLICATION — Constant static property in class mx.managers.PopUpManagerChildList
 | Indicates that the popup is placed in the same child list as the application.
applicationComplete — Event in class mx.core.Application
 | Dispatched after the Application has been initialized, processed by the LayoutManager, and attached to the display list.
applicationComplete — Event in class mx.managers.SystemManager
 | Dispatched when the application has finished initializing
APPLICATION_COMPLETE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.APPLICATION_COMPLETE constant defines the value of the type property of the event object for a applicationComplete event.
ApplicationControlBar — Class in package mx.containers
 | The ApplicationControlBar container holds components that provide global navigation and application commands.
ApplicationControlBar() — Constructor in class mx.containers.ApplicationControlBar
 | Constructor.
applicationDomain — Property in class flash.display.LoaderInfo
 | When an external SWF file is loaded, all ActionScript 3.0 definitions contained in the loaded class are stored in the applicationDomain property.
applicationDomain — Property in class flash.system.LoaderContext
 | Specifies the application domain to use for the Loader.load() or Loader.loadBytes() method.
ApplicationDomain — Final class in package flash.system
 | The ApplicationDomain class is a container for discrete groups of class definitions.
ApplicationDomain(parentDomain:flash.system:ApplicationDomain) — Constructor in class flash.system.ApplicationDomain
 | Creates a new application domain.
apply(thisObject:Object, argArray:Array) — Method in class Function
 | Specifies the value of thisObject to be used within any function that ActionScript calls.
apply(g:flash.display:Graphics) — Method in interface mx.graphics.IStroke
 | Applies the properties to the specified Graphics object.
apply(g:flash.display:Graphics) — Method in class mx.graphics.LinearGradientStroke
 | Applies the properties to the specified Graphics object.
apply(g:flash.display:Graphics) — Method in class mx.graphics.Stroke
 | Applies the properties to the specified Graphics object.
apply(parent:mx.core:UIComponent) — Method in class mx.states.AddChild
 | Applies the override.
apply(parent:mx.core:UIComponent) — Method in interface mx.states.IOverride
 | Applies the override.
apply(parent:mx.core:UIComponent) — Method in class mx.states.RemoveChild
 | Applies the override.
apply(parent:mx.core:UIComponent) — Method in class mx.states.SetEventHandler
 | Applies the override.
apply(parent:mx.core:UIComponent) — Method in class mx.states.SetProperty
 | Applies the override.
apply(parent:mx.core:UIComponent) — Method in class mx.states.SetStyle
 | Applies the override.
applyFilter(sourceBitmapData:flash.display:BitmapData, sourceRect:flash.geom:Rectangle, destPoint:flash.geom:Point, filter:flash.filters:BitmapFilter) — Method in class flash.display.BitmapData
 | Takes a source image and a filter object and generates the filtered image.
applyItemRendererProperties(instance:flash.display:DisplayObject, cache:mx.charts.chartClasses:InstanceCache) — Method in class mx.charts.series.AreaSeries
 | Customizes the item renderer instances used to represent the chart.
applyItemRendererProperties(instance:flash.display:DisplayObject, cache:mx.charts.chartClasses:InstanceCache) — Method in class mx.charts.series.BarSeries
 | Customizes the item renderer instances that are used to represent the chart.
applyItemRendererProperties(instance:flash.display:DisplayObject, cache:mx.charts.chartClasses:InstanceCache) — Method in class mx.charts.series.BubbleSeries
 | Applies style properties to the specified DisplayObject.
applyItemRendererProperties(instance:flash.display:DisplayObject, cache:mx.charts.chartClasses:InstanceCache) — Method in class mx.charts.series.ColumnSeries
 | Customizes the item renderer instances that are used to represent the chart.
applyItemRendererProperties(instance:flash.display:DisplayObject, cache:mx.charts.chartClasses:InstanceCache) — Method in class mx.charts.series.LineSeries
 | Customizes the item renderer instances that are used to represent the chart.
applyItemRendererProperties(instance:flash.display:DisplayObject, cache:mx.charts.chartClasses:InstanceCache) — Method in class mx.charts.series.PlotSeries
 | Customizes the item renderer instances that are used to represent the chart.
applySelectionEffect(indicator:flash.display:Sprite, uid:String, itemRenderer:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.ListBase
 | Sets up the effect for applying the selection indicator.
applySeriesSet(seriesSet:Array, transform:mx.charts.chartClasses:DataTransform) — Method in class mx.charts.chartClasses.ChartBase
 | Preprocesses the series and transform for display.
applySettings(settings:XML) — Method in class mx.messaging.Channel
 | Subclasses should override this method to apply any settings that may be necessary for an individual channel.
applyValueToTarget(target:Object, property:String, value, props:Object) — Method in class mx.effects.Effect
 | Used internally by the Effect infrastructure.
approximate — Property in class mx.controls.listClasses.ListBaseSelectionData
 | If true, then the index property is an approximate value and not the exact value.
AreaChart — Class in package mx.charts
 | The AreaChart control represents data as an area bounded by a line connecting the values in the data.
AreaChart() — Constructor in class mx.charts.AreaChart
 | Constructor.
areaCode — Property in class mx.formatters.PhoneFormatter
 | Area code number added to a seven-digit United States format phone number to form a 10-digit phone number.
areaCodeFormat — Property in class mx.formatters.PhoneFormatter
 | Default format for the area code when the areacode property is rendered by a seven-digit format.
areaFill — Style in class mx.charts.series.AreaSeries
 | Sets the fill for the area.
areaRenderer — Style in class mx.charts.series.AreaSeries
 | The class that the series uses to represent the filled area on the chart.
AreaRenderer — Class in package mx.charts.renderers
 | The default class used to render the area beneath the dataPoints of an AreaSeries object.
AreaRenderer() — Constructor in class mx.charts.renderers.AreaRenderer
 | Constructor.
AreaSeries — Class in package mx.charts.series
 | Defines a data series for an AreaChart control.
AreaSeries() — Constructor in class mx.charts.series.AreaSeries
 | Constructor.
AreaSeriesItem — Class in package mx.charts.series.items
 | Represents the information required to render an item as part of an AreaSeries.
AreaSeriesItem(element:mx.charts.series:AreaSeries, item:Object, index:uint) — Constructor in class mx.charts.series.items.AreaSeriesItem
 | Constructor.
AreaSeriesRenderData — Class in package mx.charts.series.renderData
 | Represents all the information needed by the AreaSeries to render.
AreaSeriesRenderData(element:mx.charts.series:AreaSeries, cache:Array, filteredCache:Array, renderedBase:Number, radius:Number) — Constructor in class mx.charts.series.renderData.AreaSeriesRenderData
 | Constructor.
AreaSet — Class in package mx.charts.series
 | A grouping set that can be used to stack AreaSeries objects in any chart.
AreaSet() — Constructor in class mx.charts.series.AreaSet
 | Constructor.
areaStroke — Style in class mx.charts.series.AreaSeries
 | Sets the line style for the area.
areInaccessibleObjectsUnderPoint(point:flash.geom:Point) — Method in class flash.display.DisplayObjectContainer
 | Indicates whether the security restrictions would cause any display objects to be omitted from the list returned by calling the DisplayObjectContainer.getObjectsUnderPoint() method with the specified point point.
areSoundsInaccessible() — Static method in class flash.media.SoundMixer
 | Determines whether any sounds are not accessible due to security restrictions.
ArgumentError — Dynamic class in Top Level
 | The ArgumentError class represents an error that occurs when the arguments supplied in a function do not match the arguments defined for that function.
ArgumentError(message:String) — Constructor in class ArgumentError
 | Creates an ArgumentError object.
argumentNames — Property in class mx.rpc.remoting.Operation
 | An ordered list of the names of the arguments to pass to a method invocation.
arguments — Class in Top Level
 | An arguments object is used to store and access a function's arguments.
arguments — Property in class mx.rpc.AbstractOperation
 | The arguments to pass to the Operation when it is invoked.
Array — Dynamic class in Top Level
 | The Array class lets you access and manipulate arrays.
Array(... rest) — Package function in Top Level
 | Creates a new array.
Array(numElements:int) — Constructor in class Array
 | Lets you create an array of the specified number of elements.
Array(... rest) — Constructor in class Array
 | Lets you create an array that contains the specified elements.
ArrayCollection — Class in package mx.collections
 | The ArrayCollection class is a wrapper class that exposes an Array as a collection that can be accessed and manipulated using the methods and properties of the ICollectionView or IList interfaces.
ArrayCollection(source:Array) — Constructor in class mx.collections.ArrayCollection
 | Constructor.
ArrayUtil — Class in package mx.utils
 | The ArrayUtil utility class is an all-static class with methods for working with arrays within Flex.
arrowButtonWidth — Style in class mx.controls.ComboBox
 | Width of the arrow button in pixels.
arrowButtonWidth — Style in class mx.controls.PopUpButton
 | Number of pixels between the divider line and the right edge of the component.
artist — Property in class flash.media.ID3Info
 | The name of the artist; corresponds to the ID3 2.0 tag TPE1.
as — Operator
 | Evaluates whether an expression specified by the first operand is a member of the data type specified by the second operand.
AS3 — Statement
 | Defines methods and properties of the core ActionScript classes that are fixed properties instead of prototype properties.
ascent — Property in class flash.text.TextLineMetrics
 | The ascent value of the text is the length from the baseline to the top of the line height in pixels.
asin(val:Number) — Static method in class Math
 | Computes and returns the arc sine for the number specified in the parameter val, in radians.
aspectRatio — Property in class mx.charts.chartClasses.LegendData
 | Determines the size and placement of the legend marker.
assignedMaximum — Property in class mx.charts.chartClasses.NumericAxis
 | The explicitly assigned maximum value.
assignedMinimum — Property in class mx.charts.chartClasses.NumericAxis
 | The explicitly assigned minimum value.
ASSOCIATION_ADD_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation requests the remote destination add a new association between the specified instances.
ASSOCIATION_REMOVE_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation requests the remote destination remove an association between the specified instances.
asyncError — Event in class flash.net.LocalConnection
 | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code.
asyncError — Event in class flash.net.NetConnection
 | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code.
asyncError — Event in class flash.net.NetStream
 | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code.
asyncError — Event in class flash.net.SharedObject
 | Dispatched when an exception is thrown asynchronously — that is, from native asynchronous code.
ASYNC_ERROR — Constant static property in class flash.events.AsyncErrorEvent
 | The AsyncErrorEvent.ASYNC_ERROR constant defines the value of the type property of an asyncError event object.
AsyncErrorEvent — Class in package flash.events
 | Flash® Player dispatches an AsyncErrorEvent when an exception is thrown from native asynchronous code, which could be from, for example, LocalConnection, NetConnection, SharedObject, or NetStream.
AsyncErrorEvent(type:String, bubbles:Boolean, cancelable:Boolean, text:String, error:Error) — Constructor in class flash.events.AsyncErrorEvent
 | Creates an AsyncErrorEvent object that contains information about asyncError events.
AsyncMessage — Class in package mx.messaging.messages
 | AsyncMessage is the base class for all asynchronous messages.
AsyncMessage(body:Object, headers:Object) — Constructor in class mx.messaging.messages.AsyncMessage
 | Constructs an instance of an AsyncMessage with an empty body and header.
AsyncRequest — Class in package mx.rpc
 | The AsyncRequest class provides an abstraction of messaging for RPC call invocation.
AsyncRequest() — Constructor in class mx.rpc.AsyncRequest
 | Constructs a new asynchronous request.
AsyncToken — Dynamic class in package mx.rpc
 | This class provides a place to set additional or token-level data for asynchronous rpc operations.
AsyncToken(message:mx.messaging.messages:IMessage) — Constructor in class mx.rpc.AsyncToken
 | Constructs an instance of the token with the specified message.
atan(val:Number) — Static method in class Math
 | Computes and returns the value, in radians, of the angle whose tangent is specified in the parameter val.
atan2(y:Number, x:Number) — Static method in class Math
 | Computes and returns the angle of the point y/x in radians, when measured counterclockwise from a circle's x axis (where 0,0 represents the center of the circle).
AT_BOTTOM — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar is at the bottom of its scrolling range.
AT_LEFT — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar is at the left of its scrolling range.
AT_RIGHT — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar is at the right of its scrolling range.
attachAudio(microphone:flash.media:Microphone) — Method in class flash.net.NetStream
 | Specifies an audio stream sent over the NetStream object, from a Microphone object passed as the source.
attachCamera(camera:flash.media:Camera) — Method in class flash.media.Video
 | Specifies a video stream from a camera to be displayed within the boundaries of the Video object in the application window.
attachCamera(theCamera:flash.media:Camera, snapshotMilliseconds:int) — Method in class flash.net.NetStream
 | Starts capturing video from the specified source, or stops capturing if theCamera is set to null.
attachCamera(camera:flash.media:Camera) — Method in class mx.controls.VideoDisplay
 | Specifies whether to play a video stream from a camera.
attachNetStream(netStream:flash.net:NetStream) — Method in class flash.media.Video
 | Specifies a video stream to be displayed within the boundaries of the Video object in the application window.
attachOverlay() — Method in class mx.core.Container
 | Used internally by the Dissolve Effect to add the overlay to the chrome of a container.
attachOverlay() — Method in class mx.core.UIComponent
 | This is an internal method used by the Flex framework to support the Dissolve effect.
AT_TARGET — Constant static property in class flash.events.EventPhase
 | The target phase, which is the second phase of the event flow.
AT_TOP — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar is at the top of its scrolling range.
attribute(attributeName) — Method in class XML
 | Returns the XML value of the attribute that has the name matching the attributeName parameter.
attribute(attributeName) — Method in class XMLList
 | Calls the attribute() method of each XML object and returns an XMLList object of the results.
attribute(attributeName:Object) — Method in class mx.collections.XMLListCollection
 | Calls the attribute() method of each XML object in the XMLList and returns an XMLList of the results, which match the given attributeName.
attributes() — Method in class XML
 | Returns a list of attribute values for the given XML object.
attributes() — Method in class XMLList
 | Calls the attributes() method of each XML object and returns an XMLList object of attributes for each XML object.
attributes — Property in class flash.xml.XMLNode
 | An object containing all of the attributes of the specified XMLNode instance.
attributes() — Method in class mx.collections.XMLListCollection
 | Calls the attributes() method of each XML object in the XMLList object and returns an XMList of attributes for each XML object.
attributes — Property in class mx.messaging.management.MBeanInfo
 | The attributes exposed by the MBean.
AUTHENTICATION_MESSAGE_REF_TYPE — Constant static property in class mx.messaging.messages.CommandMessage
 | The server message type for authentication commands.
AUTO — Constant static property in class flash.display.PixelSnapping
 | A constant value used in the pixelSnapping property of a Bitmap object to specify that the bitmap image is snapped to the nearest pixel if it is drawn with no rotation or skew and it is drawn at a scale factor of 99.9% to 100.1%.
AUTO — Constant static property in class mx.core.ContainerCreationPolicy
 | Delay creating some or all descendants until they are needed.
AUTO — Constant static property in class mx.core.ScrollPolicy
 | Show the scrollbar if the children exceed the owner's dimension.
AUTO — Constant static property in class mx.core.UIComponentCachePolicy
 | Specifies that the Flex framework should use heuristics to decide whether to cache the object as a bitmap.
autoAdjust — Property in class mx.charts.chartClasses.NumericAxis
 | Specifies whether Flex rounds values.
autoBandWidthDetection — Property in class mx.controls.VideoDisplay
 | Specifies whether the VideoDisplay control should use the built-in automatic bandwidth detection feature.
autoCommit — Property in class mx.data.DataService
 | Indicates if changes to the buffer are automatically committed.
autoCommit — Property in class mx.data.DataStore
 | If set to true, operations that modify the state managed by the DataService are committed immediately.
autoCommit — Property in class mx.data.mxml.DataService
 | Indicates if changes to the buffer are automatically committed.
autoLayout — Property in class mx.core.Container
 | If true, measurement and layout are done when the position or size of a child is changed.
autoLoad — Property in class mx.controls.SWFLoader
 | If true, the content loads automatically.
autoLoad — Property in class mx.effects.SoundEffect
 | If true, load the MP3 file when the source has been specified.
autoMerge — Property in class mx.data.DataService
 | If set to false, when changes are pushed from the remote destination to the client they are not immediately applied.
autoMerge — Property in class mx.data.DataStore
 | If set to false, when changes are pushed from the server to the client they are not immediately applied.
autoMerge — Property in class mx.data.mxml.DataService
 | If set to false, when changes are pushed from the remote destination to the client they are not immediately applied.
autoPlay — Property in class mx.controls.VideoDisplay
 | Specifies whether the video should start playing immediately when the source property is set.
autoRepeat — Property in class mx.controls.Button
 | Specifies whether to dispatch repeated buttonDown events if the user holds down the mouse button.
autoRewind — Property in class mx.controls.VideoDisplay
 | Specifies whether the FLV file should be rewound to the first frame when play stops, either by calling the stop() method or by reaching the end of the stream.
autoSize — Property in class flash.text.TextField
 | Controls automatic sizing and alignment of text fields.
autoSyncEnabled — Property in class mx.data.DataService
 | When true, fill(), createItem() and getItem() requests return items which listen for updates made to these items from the remote destination.
available — Static property in class flash.external.ExternalInterface
 | Indicates whether this player is in a container that offers an external interface.
avHardwareDisable — Static property in class flash.system.Capabilities
 | Specifies whether access to the user's camera and microphone has been administratively prohibited (true) or allowed (false).
AVM1Movie — Class in package flash.display
 | AVM1Movie is a simple class that represents AVM1 movie clips, which use ActionScript 1.0 or 2.0.
axes — Property in class mx.charts.chartClasses.DataTransform
 | The set of axes associated with this transform.
axis — Property in class mx.charts.AxisRenderer
 | The axis object associated with this renderer.
axis — Property in interface mx.charts.chartClasses.IAxisRenderer
 | The axis object associated with this renderer.
AxisBase — Class in package mx.charts.chartClasses
 | The AxisBase class serves as a base class for the various axis types supported in Flex.
AxisBase() — Constructor in class mx.charts.chartClasses.AxisBase
 | Constructor.
AxisLabel — Class in package mx.charts
 | An AxisLabel object represents a single label on the chart axis.
AxisLabel(position:Number, value:Object, text:String) — Constructor in class mx.charts.AxisLabel
 | Constructor.
AxisLabelSet — Class in package mx.charts.chartClasses
 | An AxisLAbelSet represents the label and tick data generated by an implementation of IAxis.
AxisLabelSet() — Constructor in class mx.charts.chartClasses.AxisLabelSet
 | Constructor.
AxisRenderer — Class in package mx.charts
 | You use the AxisRenderer class to describe the horizontal and vertical axes of a chart.
AxisRenderer() — Constructor in class mx.charts.AxisRenderer
 | Constructor.
axisStroke — Style in class mx.charts.AxisRenderer
 | Specifies the characteristics of the line for the axis.
axisTitleStyleName — Style in class mx.charts.AxisRenderer
 | The name of the CSS class selector to use when formatting the axis title.
axisTitleStyleName — Style in class mx.charts.chartClasses.CartesianChart
 | The name of the CSS class selector to use when formatting titles on the axes.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


B Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
B Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
b — Property in class flash.geom.Matrix
 | The value in the first row and second column of the Matrix object, which affects the positioning of pixels along the y axis when rotating or skewing an image.
Back — Class in package mx.effects.easing
 | The Back class defines three easing functions to implement motion with Flex effect classes.
background — Property in class flash.text.TextField
 | Specifies whether the text field has a background fill.
backgroundAlpha — Style in class mx.controls.DateChooser
 | Alpha level of the color defined by the backgroundColor property.
backgroundAlpha — Style in class mx.controls.MenuBar
 | Alpha level of the color defined by the backgroundColor property.
backgroundAlpha — Style in class mx.controls.NumericStepper
 | Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style.
backgroundAlpha — Style in class mx.controls.TextInput
 | Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style.
backgroundAlpha — Style in class mx.controls.ToolTip
 | Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style.
backgroundAlpha — Style in class mx.controls.ToolTip
 | Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style.
backgroundAlpha — Style in class mx.controls.VideoDisplay
 | Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style.
backgroundAlpha — Style in class mx.core.Container
 | Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style.
backgroundAlpha — Style in class mx.core.ScrollControlBase
 | Alpha level of the color defined by the backgroundColor property, of the image or SWF file defined by the backgroundImage style.
backgroundAlpha — Property in class mx.preloaders.DownloadProgressBar
 | Alpha level of the SWF file or image defined by the backgroundImage property, or the color defined by the backgroundColor property.
backgroundAlpha — Property in interface mx.preloaders.IPreloaderDisplay
 | Alpha level of the SWF file or image defined by the backgroundImage property, or the color defined by the backgroundColor property.
backgroundAttachment — Style in class mx.core.Container
 | If a background image is specified, this style specifies whether it is fixed with regard to the viewport ("fixed") or scrolls along with the content ("scroll").
backgroundColor — Property in class flash.text.TextField
 | The color of the text field background.
backgroundColor — Style in class mx.charts.Legend
 | Background color of the component.
backgroundColor — Style in class mx.charts.chartClasses.DataTip
 | Background color of the component.
backgroundColor — Style in class mx.controls.ColorPicker
 | Color of the SwatchPanel object's background.
backgroundColor — Style in class mx.controls.DateChooser
 | Background color of the DateChooser control.
backgroundColor — Style in class mx.controls.MenuBar
 | Background color of the component.
backgroundColor — Style in class mx.controls.NumericStepper
 | Background color of a component.
backgroundColor — Style in class mx.controls.TextInput
 | Background color of a component.
backgroundColor — Style in class mx.controls.ToolTip
 | Background color of a component.
backgroundColor — Style in class mx.controls.VideoDisplay
 | Background color of a component.
backgroundColor — Style in class mx.controls.dataGridClasses.DataGridColumn
 | The Background color of the column.
backgroundColor — Style in class mx.core.Container
 | Background color of a component.
backgroundColor — Style in class mx.core.ScrollControlBase
 | Background color of a component.
backgroundColor — Property in class mx.preloaders.DownloadProgressBar
 | Background color of a download progress bar.
backgroundColor — Property in interface mx.preloaders.IPreloaderDisplay
 | Background color of a download progress bar.
backgroundDisabledColor — Style in class mx.controls.DataGrid
 | The background color of the DataGrid when disabled.
backgroundDisabledColor — Style in class mx.controls.List
 | Background color of the component when it is disabled.
backgroundDisabledColor — Style in class mx.controls.Tree
 | Background color of the component when it is disabled.
backgroundDisabledColor — Style in class mx.core.Container
 | Background color of the component when it is disabled.
backgroundElements — Property in class mx.charts.chartClasses.ChartBase
 | Sets an Array of background chart elements that appear below any data series rendered by the chart.
backgroundGradientAlphas — Style in class mx.core.Application
 | Specifies the alpha transparency values used for the background gradient fill of the application.
backgroundGradientColors — Style in class mx.core.Application
 | Specifies the colors used to tint the background gradient fill of the application.
backgroundImage — Style in class mx.controls.NumericStepper
 | Background image of a component.
backgroundImage — Style in class mx.controls.TextInput
 | Background image of a component.
backgroundImage — Style in class mx.controls.ToolTip
 | Background image of a component.
backgroundImage — Style in class mx.controls.VideoDisplay
 | Background image of a component.
backgroundImage — Style in class mx.core.Container
 | Background image of a component.
backgroundImage — Style in class mx.core.ScrollControlBase
 | Background image of a component.
backgroundImage — Property in class mx.preloaders.DownloadProgressBar
 | The background image of the application, which is passed in by the preloader.
backgroundImage — Property in interface mx.preloaders.IPreloaderDisplay
 | The background image of the application, which is passed in by the preloader.
backgroundSize — Style in class mx.controls.NumericStepper
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSize — Style in class mx.controls.TextInput
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSize — Style in class mx.controls.ToolTip
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSize — Style in class mx.controls.VideoDisplay
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSize — Style in class mx.core.Container
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSize — Style in class mx.core.ScrollControlBase
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSize — Property in class mx.preloaders.DownloadProgressBar
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSize — Property in interface mx.preloaders.IPreloaderDisplay
 | Scales the image specified by backgroundImage to different percentage sizes.
backgroundSkin — Style in class mx.controls.MenuBar
 | The background skin of the MenuBar control.
BACKSPACE — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Backspace key (8).
bandwidth — Property in class flash.media.Camera
 | An integer that specifies the maximum amount of bandwidth the current outgoing video feed can use, in bytes.
BarChart — Class in package mx.charts
 | The BarChart control represents data as a series of horizontal bars whose length is determined by values in the data.
BarChart() — Constructor in class mx.charts.BarChart
 | Constructor.
barColor — Style in class mx.controls.ProgressBar
 | Determines the color of a ProgressBar.
barColor — Style in class mx.core.Container
 | Determines the color of a ProgressBar.
barFrameRect — Property in class mx.preloaders.DownloadProgressBar
 | The dimensions of the progress bar border.
barRect — Property in class mx.preloaders.DownloadProgressBar
 | The dimensions of the progress bar.
BarSeries — Class in package mx.charts.series
 | Defines a data series for a BarChart control.
BarSeries() — Constructor in class mx.charts.series.BarSeries
 | Constructor.
BarSeriesItem — Class in package mx.charts.series.items
 | Represents the information required to render an item as part of a BarSeries.
BarSeriesItem(element:mx.charts.series:BarSeries, data:Object, index:uint) — Constructor in class mx.charts.series.items.BarSeriesItem
 | Constructor.
BarSeriesRenderData — Class in package mx.charts.series.renderData
 | Represents all the information needed by the BarSeries to render.
BarSeriesRenderData(cache:Array, filteredCache:Array, renderedBase:Number, renderedHalfWidth:Number, renderedYOffset:Number) — Constructor in class mx.charts.series.renderData.BarSeriesRenderData
 | Constructor.
BarSet — Class in package mx.charts.series
 | A grouping set that can be used to stack or cluster BarSeries objects in any chart.
BarSet() — Constructor in class mx.charts.series.BarSet
 | Constructor.
barSkin — Style in class mx.controls.ProgressBar
 | Skin style for a determinate progress bar.
barWidthRatio — Style in class mx.charts.BarChart
 | Specifies how wide to draw the bars relative to the category width, as a percentage in the range of 0 to 1.
barWidthRatio — Property in interface mx.charts.chartClasses.IBar
 | Specifies how wide to render the items relative to the category.
barWidthRatio — Property in class mx.charts.series.BarSeries
 | Specifies how wide to render the bars relative to the category width.
barWidthRatio — Property in class mx.charts.series.BarSet
 | Specifies how wide to render the bars relative to the category width.
baseAtZero — Property in class mx.charts.chartClasses.NumericAxis
 | Specifies whether Flex tries to keep the minimum and maximum values rooted at zero.
basedOn — Property in class mx.states.State
 | The name of the view state upon which this view state is based, or null if this view state is not based on a named view state.
baseline — Property in class mx.charts.CategoryAxis
 | The baseline position for the axis.
baseline — Property in interface mx.charts.chartClasses.IAxis
 | The baseline position for the axis.
baseline — Property in class mx.charts.chartClasses.NumericAxis
 | The computed minimum value for the axis as long as this value is greater than 0.
baselinePosition — Property in class mx.controls.List
 | The baseline position for the control.
baselinePosition — Property in class mx.core.Container
 | The vertical distance (in pixels) between the top of the container and the baseline of the first line of text.
baselinePosition — Property in interface mx.core.IUIComponent
 | Determines the baseline y-coordinate of the first line of text of the component.
baselinePosition — Property in class mx.core.UIComponent
 | Determines the baseline y-coordinate of the first line of text of the component.
baselinePosition — Property in class mx.core.UITextField
 | Determines the baseline y-coordinate of the first line of text of the component.
BaseListData — Class in package mx.controls.listClasses
 | The BaseListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors.
BaseListData(label:String, uid:String, owner:mx.core:IUIComponent, rowIndex:int) — Constructor in class mx.controls.listClasses.BaseListData
 | Constructor.
BATCHED_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation represents a set of batched operations to be performed as a single unit.
beforeFirst — Property in interface mx.collections.IViewCursor
 | If the current is locatedbefore the first item in the view.
begin(target:flash.display:Graphics, rc:flash.geom:Rectangle) — Method in interface mx.graphics.IFill
 | Starts the fill.
begin(target:flash.display:Graphics, rc:flash.geom:Rectangle) — Method in class mx.graphics.LinearGradient
 | Starts the fill.
begin(target:flash.display:Graphics, rc:flash.geom:Rectangle) — Method in class mx.graphics.RadialGradient
 | Starts the fill.
begin(target:flash.display:Graphics, rc:flash.geom:Rectangle) — Method in class mx.graphics.SolidColor
 | Starts the fill.
beginBitmapFill(bitmap:flash.display:BitmapData, matrix:flash.geom:Matrix, repeat:Boolean, smooth:Boolean) — Method in class flash.display.Graphics
 | Fills a drawing area with a bitmap image.
beginFill(color:uint, alpha:Number) — Method in class flash.display.Graphics
 | Specifies a simple one-color fill that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
beginGradientFill(type:String, colors:Array, alphas:Array, ratios:Array, matrix:flash.geom:Matrix, spreadMethod:String, interpolationMethod:String, focalPointRatio:Number) — Method in class flash.display.Graphics
 | Specifies a gradient fill that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
beginIndex — Property in class mx.controls.textClasses.TextRange
 | Zero-based index in the control's text field of the first character in the range.
beginInterpolation(sourceRenderData:Object, destRenderData:Object) — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | Called by the SeriesInterpolate effect to initiate an interpolation.
beginInterpolation(sourceRenderData:Object, destRenderData:Object) — Method in class mx.charts.chartClasses.Series
 | Called by the SeriesInterpolate effect to initiate an interpolation.
beginInterpolation(sourceRenderData:Object, destRenderData:Object) — Method in class mx.charts.series.BubbleSeries
 | Called by the SeriesInterpolate effect to initiate an interpolation.
beginInterpolation(sourceRenderData:Object, destRenderData:Object) — Method in class mx.charts.series.PieSeries
 | Called by the SeriesInterpolate effect to initiate an interpolation.
beginTween(elementCount:int) — Method in class mx.charts.effects.effectClasses.SeriesEffectInstance
 | Initializes the tweening calculations and sets up the interpolationValues Array for the number of items equal to the elementCount property.
BEST — Constant static property in class flash.display.StageQuality
 | Specifies very high rendering quality: graphics are anti-aliased using a 4 x 4 pixel grid and bitmaps are always smoothed.
BEVEL — Constant static property in class flash.display.JointStyle
 | Specifies beveled joints in the joints parameter of the flash.display.Graphics.lineStyle() method.
BevelFilter — Final class in package flash.filters
 | The BevelFilter class lets you add a bevel effect to display objects.
BevelFilter(distance:Number, angle:Number, highlightColor:uint, highlightAlpha:Number, shadowColor:uint, shadowAlpha:Number, blurX:Number, blurY:Number, strength:Number, quality:int, type:String, knockout:Boolean) — Constructor in class flash.filters.BevelFilter
 | Initializes a new BevelFilter instance with the specified parameters.
bias — Property in class flash.filters.ConvolutionFilter
 | The amount of bias to add to the result of the matrix transformation.
BIG_ENDIAN — Constant static property in class flash.utils.Endian
 | Indicates the most significant byte of the multibyte number appears first in the sequence of bytes.
BINARY — Constant static property in class flash.net.URLLoaderDataFormat
 | Specifies that downloaded data is received as raw binary data.
Binding — MXML Only Component
 | You use the <mx:Binding> tag to tie the data in one object to another object.
BINDING — Constant static property in class mx.core.EventPriority
 | Autogenerated event handlers that evaluate data-binding expressions need to be executed before any others, so they have a higher priority than the default.
BindingUtils — Class in package mx.binding.utils
 | The BindingUtils class defines utility methods for performing data binding from ActionScript.
bindProperty(site:Object, prop:String, host:Object, chain:Object, commitOnly:Boolean) — Static method in class mx.binding.utils.BindingUtils
 | Binds a public property, prop on the site Object, to a bindable property or property chain.
bindSetter(setter:Function, host:Object, chain:Object, commitOnly:Boolean) — Static method in class mx.binding.utils.BindingUtils
 | Binds a setter function, setter, to a bindable property or property chain.
Bitmap — Class in package flash.display
 | The Bitmap class represents display objects that represent bitmap images.
Bitmap(bitmapData:flash.display:BitmapData, pixelSnapping:String, smoothing:Boolean) — Constructor in class flash.display.Bitmap
 | Initializes a Bitmap object to refer to the specified BitmapData object.
BitmapAsset — Class in package mx.core
 | BitmapAsset is a subclass of the Flash Player's Bitmap class which represents bitmap images that you embed in a Flex application.
BitmapAsset(bitmapData:flash.display:BitmapData, pixelSnapping:String, smoothing:Boolean) — Constructor in class mx.core.BitmapAsset
 | Constructor.
bitmapData — Property in class flash.display.Bitmap
 | The BitmapData object being referenced.
BitmapData — Class in package flash.display
 | The BitmapData class lets you work with the data (pixels) of a Bitmap object.
BitmapData(width:int, height:int, transparent:Boolean, fillColor:uint) — Constructor in class flash.display.BitmapData
 | Creates a BitmapData object with a specified width and height.
BitmapDataChannel — Final class in package flash.display
 | The BitmapDataChannel class is an enumeration of constant values that indicate which channel to use: red, blue, green, or alpha transparency.
BitmapFill — Class in package mx.graphics
 | Defines a set of values used to fill an area on screen with a bitmap or other DisplayObject.
BitmapFill() — Constructor in class mx.graphics.BitmapFill
 | Constructor.
BitmapFilter — Class in package flash.filters
 | The BitmapFilter class is the base class for all image filter effects.
BitmapFilterQuality — Final class in package flash.filters
 | The BitmapFilterQuality class contains values to set the rendering quality of a BitmapFilter object.
BitmapFilterType — Final class in package flash.filters
 | The BitmapFilterType class contains values to set the type of a BitmapFilter.
blendMode — Property in class flash.display.DisplayObject
 | A value from the BlendMode class that specifies which blend mode to use.
BlendMode — Final class in package flash.display
 | A class that provides constant values for visual blend mode effects.
blockIndent — Property in class flash.text.TextFormat
 | Indicates the block indentation in pixels.
blRadius — Property in class mx.graphics.RectangularDropShadow
 | The corner radius of the bottom left corner of the rounded rectangle that is casting the shadow.
BLUE — Constant static property in class flash.display.BitmapDataChannel
 | The blue channel.
blueMultiplier — Property in class flash.geom.ColorTransform
 | A decimal value that is multiplied with the blue channel value.
blueOffset — Property in class flash.geom.ColorTransform
 | A number from -255 to 255 that is added to the blue channel value after it has been multiplied by the blueMultiplier value.
Blur — Class in package mx.effects
 | The Blur effect lets you apply a blur visual effect to a component.
Blur(target:Object) — Constructor in class mx.effects.Blur
 | Constructor.
BlurFilter — Final class in package flash.filters
 | The BlurFilter class lets you apply a blur visual effect to display objects.
BlurFilter(blurX:Number, blurY:Number, quality:int) — Constructor in class flash.filters.BlurFilter
 | Initializes the filter with the specified parameters.
BlurInstance — Class in package mx.effects.effectClasses
 | The BlurInstance class implements the instance class for the Blur effect.
BlurInstance(target:Object) — Constructor in class mx.effects.effectClasses.BlurInstance
 | Constructor.
blurX — Property in class flash.filters.BevelFilter
 | The amount of horizontal blur, in pixels.
blurX — Property in class flash.filters.BlurFilter
 | The amount of horizontal blur.
blurX — Property in class flash.filters.DropShadowFilter
 | The amount of horizontal blur.
blurX — Property in class flash.filters.GlowFilter
 | The amount of horizontal blur.
blurX — Property in class flash.filters.GradientBevelFilter
 | The amount of horizontal blur.
blurX — Property in class flash.filters.GradientGlowFilter
 | The amount of horizontal blur.
blurXFrom — Property in class mx.effects.Blur
 | The starting amount of horizontal blur.
blurXFrom — Property in class mx.effects.Glow
 | The starting amount of horizontal blur.
blurXFrom — Property in class mx.effects.effectClasses.BlurInstance
 | The starting amount of horizontal blur.
blurXFrom — Property in class mx.effects.effectClasses.GlowInstance
 | The starting amount of horizontal blur.
blurXTo — Property in class mx.effects.Blur
 | The ending amount of horizontal blur.
blurXTo — Property in class mx.effects.Glow
 | The ending amount of horizontal blur.
blurXTo — Property in class mx.effects.effectClasses.BlurInstance
 | The ending amount of horizontal blur.
blurXTo — Property in class mx.effects.effectClasses.GlowInstance
 | The ending amount of horizontal blur.
blurY — Property in class flash.filters.BevelFilter
 | The amount of vertical blur, in pixels.
blurY — Property in class flash.filters.BlurFilter
 | The amount of vertical blur.
blurY — Property in class flash.filters.DropShadowFilter
 | The amount of vertical blur.
blurY — Property in class flash.filters.GlowFilter
 | The amount of vertical blur.
blurY — Property in class flash.filters.GradientBevelFilter
 | The amount of vertical blur.
blurY — Property in class flash.filters.GradientGlowFilter
 | The amount of vertical blur.
blurYFrom — Property in class mx.effects.Blur
 | The starting amount of vertical blur.
blurYFrom — Property in class mx.effects.Glow
 | The starting amount of vertical blur.
blurYFrom — Property in class mx.effects.effectClasses.BlurInstance
 | The starting amount of vertical blur.
blurYFrom — Property in class mx.effects.effectClasses.GlowInstance
 | The starting amount of vertical blur.
blurYTo — Property in class mx.effects.Blur
 | The ending amount of vertical blur.
blurYTo — Property in class mx.effects.Glow
 | The ending amount of vertical blur.
blurYTo — Property in class mx.effects.effectClasses.BlurInstance
 | The ending amount of vertical blur.
blurYTo — Property in class mx.effects.effectClasses.GlowInstance
 | The ending amount of vertical blur.
body — Property in class mx.messaging.messages.AbstractMessage
 | The body of a message contains the specific data that needs to be delivered to the remote destination.
body — Property in interface mx.messaging.messages.IMessage
 | The body of a message contains the specific data that needs to be delivered to the remote destination.
bold — Property in class flash.text.TextFormat
 | Specifies whether the text is boldface.
BOLD — Constant static property in class flash.text.FontStyle
 | Defines the bold style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method.
BOLD_ITALIC — Constant static property in class flash.text.FontStyle
 | Defines the combined bold and italic style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method.
bookmark — Property in interface mx.collections.IViewCursor
 | Provides access to a bookmark that corresponds to the item returned by the current property.
bookmark — Property in class mx.controls.listClasses.ListBaseSeekPending
 | The bookmark that was being used in the seek operation.
Boolean — Final class in Top Level
 | A Boolean object is a data type that can have one of two values, either true or false, used for logical operations.
Boolean(expression) — Package function in Top Level
 | Converts the expression parameter to a Boolean value and returns the value.
Boolean(expression:Object) — Constructor in class Boolean
 | Creates a Boolean object with the specified value.
border — Property in class flash.text.TextField
 | Specifies whether the text field has a border.
border — Property in class mx.controls.VideoDisplay
 | The border object for the control.
border — Property in class mx.core.ScrollControlBase
 | The border object.
Border — Class in package mx.skins
 | The Border class is an abstract base class for various classes that draw borders, either rectangular or non-rectangular, around UIComponents.
Border() — Constructor in class mx.skins.Border
 | Constructor.
borderAlpha — Style in class mx.containers.Panel
 | Alpha of the title bar, control bar and sides of the Panel.
borderColor — Property in class flash.text.TextField
 | The color of the text field border.
borderColor — Style in class mx.charts.chartClasses.DataTip
 | Black section of a three-dimensional border, or the color section of a two-dimensional border.
borderColor — Style in class mx.controls.Button
 | Color of the border.
borderColor — Style in class mx.controls.ColorPicker
 | Color of the outer border on the SwatchPanel object.
borderColor — Style in class mx.controls.ComboBox
 | Color of the border.
borderColor — Style in class mx.controls.DateChooser
 | Color of the border.
borderColor — Style in class mx.controls.DateField
 | Color of the border.
borderColor — Style in class mx.controls.MenuBar
 | Color of the border.
borderColor — Style in class mx.controls.NumericStepper
 | Color of the border.
borderColor — Style in class mx.controls.ProgressBar
 | Black section of a three-dimensional border, or the color section of a two-dimensional border.
borderColor — Style in class mx.controls.TextInput
 | Color of the border.
borderColor — Style in class mx.controls.ToolTip
 | Color of the border.
borderColor — Style in class mx.controls.VideoDisplay
 | Color of the border.
borderColor — Style in class mx.controls.scrollClasses.ScrollBar
 | Color of the border.
borderColor — Style in class mx.controls.sliderClasses.Slider
 | The color of the black section of the border.
borderColor — Style in class mx.core.Container
 | Color of the border.
borderColor — Style in class mx.core.ScrollControlBase
 | Color of the border.
borderMetrics — Property in class mx.controls.ComboBase
 | Returns an EdgeMetrics object that has four properties: left, top, right, and bottom.
borderMetrics — Property in class mx.controls.VideoDisplay
 | Returns an EdgeMetrics object that has four properties: left, top, right, and bottom.
borderMetrics — Property in class mx.core.Container
 | Returns an EdgeMetrics object that has four properties: left, top, right, and bottom.
borderMetrics — Property in class mx.core.ScrollControlBase
 | Returns an EdgeMetrics object that has four properties: left, top, right, and bottom.
borderMetrics — Property in class mx.skins.Border
 | The thickness of the border edges.
borderRect — Property in class mx.preloaders.DownloadProgressBar
 | The dimensions of the border of the display.
borderSides — Style in class mx.controls.NumericStepper
 | Bounding box sides.
borderSides — Style in class mx.controls.TextInput
 | Bounding box sides.
borderSides — Style in class mx.controls.ToolTip
 | Bounding box sides.
borderSides — Style in class mx.controls.VideoDisplay
 | Bounding box sides.
borderSides — Style in class mx.core.Container
 | Bounding box sides.
borderSides — Style in class mx.core.ScrollControlBase
 | Bounding box sides.
borderSkin — Style in class mx.controls.NumericStepper
 | The border skin of the component.
borderSkin — Style in class mx.controls.TextInput
 | The border skin of the component.
borderSkin — Style in class mx.controls.ToolTip
 | The border skin of the component.
borderSkin — Style in class mx.controls.VideoDisplay
 | The border skin of the component.
borderSkin — Style in class mx.core.Container
 | The border skin of the component.
borderSkin — Style in class mx.core.ScrollControlBase
 | The border skin of the component.
borderStyle — Style in class mx.charts.Legend
 | Bounding box style.
borderStyle — Style in class mx.charts.chartClasses.DataTip
 | Bounding box style.
borderStyle — Style in class mx.controls.NumericStepper
 | Bounding box style.
borderStyle — Style in class mx.controls.TextInput
 | Bounding box style.
borderStyle — Style in class mx.controls.ToolTip
 | Bounding box style.
borderStyle — Style in class mx.controls.VideoDisplay
 | Bounding box style.
borderStyle — Style in class mx.core.Container
 | Bounding box style.
borderStyle — Style in class mx.core.ScrollControlBase
 | Bounding box style.
borderThickness — Style in class mx.controls.ComboBox
 | The thickness of the border of the drop-down list.
borderThickness — Style in class mx.controls.DateChooser
 | Bounding box thickness.
borderThickness — Style in class mx.controls.DateField
 | The bounding box thickness of the DateChooser control.
borderThickness — Style in class mx.controls.NumericStepper
 | Bounding box thickness.
borderThickness — Style in class mx.controls.TextInput
 | Bounding box thickness.
borderThickness — Style in class mx.controls.ToolTip
 | Bounding box thickness.
borderThickness — Style in class mx.controls.VideoDisplay
 | Bounding box thickness.
borderThickness — Style in class mx.core.Container
 | Bounding box thickness.
borderThickness — Style in class mx.core.ScrollControlBase
 | Bounding box thickness.
borderThicknessBottom — Style in class mx.containers.Panel
 | Thickness of the bottom border of the Panel control.
borderThicknessLeft — Style in class mx.containers.Panel
 | Thickness of the left border of the Panel.
borderThicknessRight — Style in class mx.containers.Panel
 | Thickness of the right border of the Panel.
borderThicknessTop — Style in class mx.containers.Panel
 | Thickness of the top border of the Panel.
bottom — Property in class flash.geom.Rectangle
 | The sum of the y and height properties.
bottom — Property in class mx.core.EdgeMetrics
 | The height, in pixels, of the bottom edge region.
bottom — Style in class mx.core.UIComponent
 | The vertical distance in pixels from the lower edge of the component to the lower edge of its parent container.
BOTTOM — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned at the bottom.
BOTTOM — Constant static property in class mx.controls.ButtonLabelPlacement
 | Specifies that the label appears below the icon.
BOTTOM — Constant static property in class mx.controls.ProgressBarLabelPlacement
 | Specifies to place the label below the progress bar.
BOTTOM_LEFT — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned in the bottom-left corner.
bottomRight — Property in class flash.geom.Rectangle
 | The location of the Rectangle object's bottom-right corner, determined by the values of the right and bottom properties.
BOTTOM_RIGHT — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned in the bottom-right corner.
bottomScrollV — Property in class flash.text.TextField
 | An integer (1-based index) that indicates the bottommost line that is currently visible in the specified text field.
Bounce — Class in package mx.effects.easing
 | The Bounce class defines three easing functions to implement bounce motion with Flex effect classes.
BoundedValue — Class in package mx.charts.chartClasses
 | A bounded value is used to represent a datapoint that a chart element intends to render on screen.
BoundedValue(value:Number, lowerMargin:Number, upperMargin:Number) — Constructor in class mx.charts.chartClasses.BoundedValue
 | Constructor.
boundedValues — Property in class mx.charts.chartClasses.DataDescription
 | An Array of BoundedValue objects describing the data in the element.
bounds — Property in class mx.charts.chartClasses.RenderData
 | The bounds of all of the items a series displays on screen, relative to the series's coordinate system.
Box — Class in package mx.containers
 | A Box container lays out its children in a single vertical column or a single horizontal row.
Box() — Constructor in class mx.containers.Box
 | Constructor.
BoxDirection — Final class in package mx.containers
 | The BoxDirection class specifies constant values for the direction property of the Box container.
BoxItemRenderer — Class in package mx.charts.renderers
 | A simple chart itemRenderer implementation that fills a rectangular area.
BoxItemRenderer() — Constructor in class mx.charts.renderers.BoxItemRenderer
 | Constructor.
boxStroke — Style in class mx.charts.series.CandlestickSeries
 | Sets the stroke style used to outline the box defining the open-close region of the series.
branchDisabledIcon — Style in class mx.controls.Menu
 | The icon for all disabled menu items that have submenus.
branchIcon — Style in class mx.controls.Menu
 | The icon for all enabled menu items that have submenus.
branchIcon — Property in class mx.controls.menuClasses.MenuItemRenderer
 | The internal IFlexDisplayObject that displays the branch icon in this renderer.
break — Statement
 | Appears within a loop (for, for..in, for each..in, do..while, or while) or within a block of statements associated with a particular case within a switch statement.
bringToFront(popUp:mx.core:IFlexDisplayObject) — Static method in class mx.managers.PopUpManager
 | Makes sure a popup window is higher than other objects in its child list The SystemManager does this automatically if the popup is a top level window and is moused on, but otherwise you have to take care of this yourself.
brokenImageBorderSkin — Style in class mx.controls.SWFLoader
 | Name of class to use as the SWFLoader border skin if the control cannot load the content.
BrokenImageBorderSkin — Class in package mx.skins.halo
 | The skin for the border of a SWFLoader or Image component when the content could not be loaded.
BrokenImageBorderSkin() — Constructor in class mx.skins.halo.BrokenImageBorderSkin
 | Constructor.
brokenImageSkin — Style in class mx.controls.SWFLoader
 | Name of the class to use as the SWFLoader skin if the control cannot load the content.
browse(typeFilter:Array) — Method in class flash.net.FileReference
 | Displays a file-browsing dialog box that lets the user select a file to upload.
browse(typeFilter:Array) — Method in class flash.net.FileReferenceList
 | Displays a file-browsing dialog box that lets the user select one or more local files to upload.
brRadius — Property in class mx.graphics.RectangularDropShadow
 | The corner radius of the bottom right corner of the rounded rectangle that is casting the shadow.
BubbleChart — Class in package mx.charts
 | The BubbleChart control represents data with three values for each data point.
BubbleChart() — Constructor in class mx.charts.BubbleChart
 | Constructor.
bubbles — Property in class flash.events.Event
 | Indicates whether an event is a bubbling event.
BubbleSeries — Class in package mx.charts.series
 | Defines a data series for a BubbleChart control.
BubbleSeries() — Constructor in class mx.charts.series.BubbleSeries
 | Constructor.
BubbleSeriesItem — Class in package mx.charts.series.items
 | Represents the information required to render an item as part of a BubbleSeries.
BubbleSeriesItem(element:mx.charts.series:BubbleSeries, data:Object, index:uint) — Constructor in class mx.charts.series.items.BubbleSeriesItem
 | Constructor.
BubbleSeriesRenderData — Class in package mx.charts.series.renderData
 | Represents all the information needed by the BubbleSeries to render.
BubbleSeriesRenderData(cache:Array, filteredCache:Array) — Constructor in class mx.charts.series.renderData.BubbleSeriesRenderData
 | Constructor
BUBBLING_PHASE — Constant static property in class flash.events.EventPhase
 | The bubbling phase, which is the third phase of the event flow.
BUFFERING — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property immediately after a call to the play() or load() method.
bufferLength — Property in class flash.net.NetStream
 | The number of seconds of data currently in the buffer.
bufferTime — Property in class flash.media.SoundLoaderContext
 | The number of seconds to preload a streaming sound into a buffer before the sound starts to stream.
bufferTime — Static property in class flash.media.SoundMixer
 | The number of seconds to preload an embedded streaming sound into a buffer before it starts to stream.
bufferTime — Property in class flash.net.NetStream
 | Specifies how long to buffer messages before starting to display the stream.
bufferTime — Property in class mx.controls.VideoDisplay
 | Number of seconds of video to buffer in memory before starting to play the video file.
bufferTime — Property in class mx.effects.SoundEffect
 | The SoundEffect class uses an internal Sound object to control the MP3 file.
bufferTime — Property in class mx.effects.effectClasses.SoundEffectInstance
 | The SoundEffect class uses an internal Sound object to control the MP3 file.
buildLabelCache() — Method in class mx.charts.chartClasses.NumericAxis
 | Populates the labelCache property with labels representing the current values of the axis.
buildMinorTickCache() — Method in class mx.charts.DateTimeAxis
 | Builds an Array of positions for the minor tick marks Array that is generated by this axis.
buildMinorTickCache() — Method in class mx.charts.chartClasses.NumericAxis
 | Builds an Array of positions for the minor tick marks Array that is generated by this axis.
buildSubSeries() — Method in class mx.charts.chartClasses.StackedSeries
 | Processes the Array of sub-series for display, when necessary.
buildSubSeries() — Method in class mx.charts.series.ColumnSet
 | Processes the Array of sub-series for display, when necessary.
builtInItems — Property in class flash.ui.ContextMenu
 | An object that has the following properties of the ContextMenuBuiltInItems class: forwardAndBack, loop, play, print, quality, rewind, save, and zoom.
bullet — Property in class flash.text.TextFormat
 | Indicates that the text is part of a bulleted list.
bullet — Property in class mx.controls.textClasses.TextRange
 | Whether the text in the range is in a bulleted list.
busyCursor — Style in class mx.managers.CursorManager
 | The skin for the busy cursor
Button — Class in package mx.controls
 | The Button control is a commonly used rectangular button.
Button() — Constructor in class mx.controls.Button
 | Constructor.
ButtonAsset — Class in package mx.core
 | ButtonAsset is a subclass of the Flash Player's SimpleButton class which represents button symbols that you embed in a Flex application from a SWF file produced by Flash.
ButtonAsset() — Constructor in class mx.core.ButtonAsset
 | Constructor.
ButtonBar — Class in package mx.controls
 | The ButtonBar control defines a horizontal or vertical group of logically related push buttons with a common look and navigation.
ButtonBar() — Constructor in class mx.controls.ButtonBar
 | Constructor.
ButtonBarButtonSkin — Class in package mx.skins.halo
 | The skin for all the states of the ButtonBarButtons in a ButtonBar.
ButtonBarButtonSkin() — Constructor in class mx.skins.halo.ButtonBarButtonSkin
 | Constructor.
buttonDown — Property in class flash.events.MouseEvent
 | Indicates whether the primary mouse button is pressed (true) or not (false).
buttonDown — Event in class mx.controls.Button
 | Dispatched when the user presses the Button control.
BUTTON_DOWN — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.BUTTON_DOWN constant defines the value of the type property of the event object for a buttonDown event.
buttonFlags — Property in class mx.controls.Alert
 | A bitmask that contains Alert.OK, Alert.CANCEL, Alert.YES, and/or Alert.NO indicating the buttons available in the Alert control.
buttonHeight — Static property in class mx.controls.Alert
 | Height of each Alert button, in pixels.
buttonHeight — Style in class mx.controls.ButtonBar
 | Height of each button, in pixels.
ButtonLabelPlacement — Final class in package mx.controls
 | The ButtonLabelPlacement class defines the constants for the allowed values of the labelPlacement property of a Button, CheckBox, LinkButton, or RadioButton control.
buttonMode — Property in class flash.display.Sprite
 | Specifies the button mode of this sprite.
ButtonSkin — Class in package mx.skins.halo
 | The skin for all the states of a Button.
ButtonSkin() — Constructor in class mx.skins.halo.ButtonSkin
 | Constructor.
buttonStyleName — Style in class mx.controls.Alert
 | Name of the CSS style declaration that specifies styles for the Alert buttons.
buttonStyleName — Style in class mx.controls.ButtonBar
 | Name of CSS style declaration that specifies styles for the buttons.
buttonWidth — Static property in class mx.controls.Alert
 | Width of each Alert button, in pixels.
buttonWidth — Style in class mx.controls.ButtonBar
 | Width of each button, in pixels.
ByteArray — Class in package flash.utils
 | The ByteArray class provides methods and properties to optimize reading, writing, and working with binary data.
ByteArray() — Constructor in class flash.utils.ByteArray
 | Creates a ByteArray instance representing a packed array of bytes, so that you can use the methods and properties in this class to optimize your data storage and stream.
bytesAvailable — Property in class flash.net.Socket
 | The number of bytes of data available for reading in the input buffer.
bytesAvailable — Property in class flash.net.URLStream
 | Returns the number of bytes of data available for reading in the input buffer.
bytesAvailable — Property in class flash.utils.ByteArray
 | The number of bytes of data available for reading from the current position in the byte array to the end of the array.
bytesAvailable — Property in interface flash.utils.IDataInput
 | Returns the number of bytes of data available for reading in the input buffer.
bytesLoaded — Property in class flash.display.LoaderInfo
 | The number of bytes that are loaded for the media.
bytesLoaded — Property in class flash.events.ProgressEvent
 | The number of items or bytes loaded when the listener processes the event.
bytesLoaded — Property in class flash.media.Sound
 | Returns the currently available number of bytes in this sound object.
bytesLoaded — Property in class flash.net.NetStream
 | The number of bytes of data that have been loaded into the player.
bytesLoaded — Property in class flash.net.URLLoader
 | Indicates the number of bytes that have been loaded thus far during the load operation.
bytesLoaded — Property in class mx.controls.SWFLoader
 | Number of bytes of the SWF or image file already loaded.
bytesLoaded — Property in class mx.controls.VideoDisplay
 | Number of bytes already loaded that are available for playing.
bytesTotal — Property in class flash.display.LoaderInfo
 | The number of compressed bytes in the entire media file.
bytesTotal — Property in class flash.events.ProgressEvent
 | The total number of items or bytes that will be loaded if the loading process succeeds.
bytesTotal — Property in class flash.media.Sound
 | Returns the total number of bytes in this sound object.
bytesTotal — Property in class flash.net.NetStream
 | The total size in bytes of the file being loaded into the player.
bytesTotal — Property in class flash.net.URLLoader
 | Indicates the total number of bytes in the downloaded data.
bytesTotal — Property in class mx.controls.SWFLoader
 | Total size of the SWF or image file.
bytesTotal — Property in class mx.controls.VideoDisplay
 | Total number of bytes to load.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


C Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
C Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
c — Property in class flash.geom.Matrix
The value in the second row and first column of the Matrix object, which affects the positioning of pixels along the x axis when rotating or skewing an image.
cache — Property in class mx.charts.chartClasses.RenderData
The list of ChartItems representing the items in the series's dataProvider.
cacheAsBitmap — Property in class flash.display.DisplayObject
If set to true, Flash Player caches an internal bitmap representation of the display object.
cacheAsBitmap — Property in interface mx.core.IUIComponent
If set to true, Flash Player caches an internal bitmap representation of the object.
cacheDefaultValues(measureName:String, cache:Array, fieldName:String) — Method in class mx.charts.chartClasses.Series
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
cacheHeuristic — Property in interface mx.core.IDeferredInstantiationUIComponent
Used by Flex to suggest bitmap caching for the object.
cacheHeuristic — Property in class mx.core.UIComponent
Used by Flex to suggest bitmap caching for the object.
cacheIndexValues(measureName:String, cache:Array, fieldName:String) — Method in class mx.charts.chartClasses.Series
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
cacheNamedValues(measureName:String, cache:Array, fieldName:String) — Method in class mx.charts.chartClasses.Series
Caches the values stored in the measureName property from the original dataProvider items in the chart item's fieldName property.
cachePolicy — Property in interface mx.core.IDeferredInstantiationUIComponent
Specifies the bitmap caching policy for this object.
cachePolicy — Property in class mx.core.UIComponent
Specifies the bitmap caching policy for this object.
calculateDropIndex(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
Returns the index where the dropped items should be added to the drop target.
calculateDropIndicatorY(rowCount:Number, rowNum:int) — Method in class mx.controls.listClasses.ListBase
Calculates the y position of the drop indicator when performing a drag-and-drop operation.
calculatePreferredSizeFromData(numItems:int) — Method in class mx.controls.ComboBase
Determines default values of the height and width to use for the entries in the drop-down list.
calculatePreferredSizeFromData(count:int) — Method in class mx.controls.ComboBox
Determines default values of the height and width to use for each entry in the drop-down list, based on the maximum size of the label text in the first numItems items in the data provider.
calculateRowHeight(data:Object, hh:Number, skipVisible:Boolean) — Method in class mx.controls.dataGridClasses.DataGridBase
Calculates the row height of columns in a row.
CalendarLayoutChangeEvent — Class in package mx.events
The CalendarLayoutChangeEvent class represents the event object passed to the event listener for the change event for the DateChooser and DateField controls.
CalendarLayoutChangeEvent(type:String, bubbles:Boolean, cancelable:Boolean, newDate:Date, triggerEvent:flash.events:Event) — Constructor in class mx.events.CalendarLayoutChangeEvent
Constructor.
call(thisObject:Object, parameter1:String) — Method in class Function
Invokes the function represented by a Function object.
call(functionName:String, ... rest) — Static method in class flash.external.ExternalInterface
Calls a function exposed by the Flash Player container, passing zero or more arguments.
call(command:String, responder:flash.net:Responder, ... rest) — Method in class flash.net.NetConnection
Invokes a command or method on the server running Flash Media Server, or on an application server, to which the application instance is connected.
callee — Property in class arguments
A reference to the currently executing function.
callLater(method:Function, args:Array) — Method in class mx.core.UIComponent
Queues a function to be called later.
calloutGap — Style in class mx.charts.series.PieSeries
Specifies how much space, in pixels, to insert between the edge of the pie and the labels when rendering callouts.
calloutStroke — Style in class mx.charts.series.PieSeries
Specifies the line style used to draw the lines to callouts.
callProperty(name, ... rest) — Method in class flash.utils.Proxy
Overrides the behavior of an object property that can be called as a function.
callProperty(name, ... rest) — Method in class mx.utils.ObjectProxy
Returns the value of the proxied object's method with the specified name.
Camera — Final class in package flash.media
The Camera class is primarily for use with Flash Media Server, but can be used in a limited way without the server.
CAMERA — Constant static property in class flash.system.SecurityPanel
When passed to Security.showSettings(), displays the Camera panel in Flash Player Settings.
cancel — Event in class flash.net.FileReference
Dispatched when a file upload or download is canceled by the user.
cancel() — Method in class flash.net.FileReference
Cancels any ongoing upload or download operation on this FileReference object.
cancel — Event in class flash.net.FileReferenceList
Dispatched when the user dismisses the file-browsing dialog box.
cancel() — Method in class mx.rpc.AbstractInvoker
Cancels the last service invocation.
cancel() — Method in class mx.rpc.http.mxml.HTTPService
Cancels the most recent HTTPService request.
cancel() — Method in class mx.rpc.remoting.mxml.Operation
cancel() — Method in class mx.rpc.soap.mxml.Operation
Use superclass description.
CANCEL — Constant static property in class flash.events.Event
Defines the value of the type property of a cancel event object.
CANCEL — Constant static property in class mx.controls.Alert
Value that enables a Cancel button on the Alert control when passed as the flags parameter of the show() method.
cancelable — Property in class flash.events.Event
Indicates whether the behavior associated with the event can be prevented.
cancelLabel — Static property in class mx.controls.Alert
The label for the Cancel button.
CANCELLED — Constant static property in class mx.events.DataGridEventReason
Specifies that the user cancelled editing and that they do not want to save the edited data.
CANCELLED — Constant static property in class mx.events.ListEventReason
Specifies that the user cancelled editing and that they do not want to save the edited data.
CandlestickChart — Class in package mx.charts
The CandlestickChart control represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
CandlestickChart() — Constructor in class mx.charts.CandlestickChart
Constructor.
CandlestickItemRenderer — Class in package mx.charts.renderers
The default itemRenderer for a CandlestickSeries object.
CandlestickItemRenderer() — Constructor in class mx.charts.renderers.CandlestickItemRenderer
Constructor.
CandlestickSeries — Class in package mx.charts.series
Represents financial data as a series of candlesticks representing the high, low, opening, and closing values of a data series.
CandlestickSeries() — Constructor in class mx.charts.series.CandlestickSeries
Constructor.
canDropLabels — Style in class mx.charts.AxisRenderer
Specifies whether the AxisRenderer should drop labels as necessary to lay out correctly.
canLoadWSDL() — Method in class mx.rpc.soap.WebService
Returns a Boolean value that indicates whether the WebService ready to load a WSDL (does it have a valid destination or wsdl specified).
canonicalKeyPropertyListString — Property in class mx.messaging.management.ObjectName
A string representation of the list of key properties, with the key properties sorted in lexical order.
canonicalName — Property in class mx.messaging.management.ObjectName
The canonical form of the name; a string representation with the properties sorted in lexical order.
canStagger — Style in class mx.charts.AxisRenderer
Specifies whether to stagger labels on two label rows.
Canvas — Class in package mx.containers
A Canvas layout container defines a rectangular region in which you place child containers and controls.
Canvas() — Constructor in class mx.containers.Canvas
Constructor.
canWatch(host:Object, name:String, commitOnly:Boolean) — Static method in class mx.binding.utils.ChangeWatcher
Lets you determine if the host exposes a data-binding event on the property.
Capabilities — Final class in package flash.system
The Capabilities class provides properties that describe the system and player that are hosting a SWF file.
caps — Property in class mx.graphics.LinearGradientStroke
A value from the CapsStyle class that specifies the type of caps at the end of lines.
caps — Property in class mx.graphics.Stroke
Specifies the type of caps at the end of lines.
capsLock — Static property in class flash.ui.Keyboard
Specifies whether the Caps Lock key is activated (true) or not (false).
CAPS_LOCK — Constant static property in class flash.ui.Keyboard
Constant associated with the key code value for the Caps Lock key (20).
CapsStyle — Final class in package flash.display
The CapsStyle class is an enumeration of constant values that specify the caps style to use in drawing lines.
caption — Property in class flash.ui.ContextMenuItem
Specifies the menu item caption (text) displayed in the context menu.
captureRollEvents — Property in class mx.effects.Zoom
If true, prevents Flex from dispatching the rollOut and rollOver events if the mouse has not moved.
captureRollEvents — Property in class mx.effects.effectClasses.ZoomInstance
Prevents the rollOut and rollOver events from being dispatched if the mouse has not moved.
captureStartValues() — Method in class mx.effects.Effect
Captures the current values of the relevant properties on the effect's targets.
CAPTURING_PHASE — Constant static property in class flash.events.EventPhase
The capturing phase, which is the first phase of the event flow.
cardNumberListener — Property in class mx.validators.CreditCardValidator
The component that listens for the validation result for the card number subfield.
cardNumberProperty — Property in class mx.validators.CreditCardValidator
Name of the card number property to validate.
cardNumberSource — Property in class mx.validators.CreditCardValidator
Object that contains the value of the card number field.
cardTypeListener — Property in class mx.validators.CreditCardValidator
The component that listens for the validation result for the card type subfield.
cardTypeProperty — Property in class mx.validators.CreditCardValidator
Name of the card type property to validate.
cardTypeSource — Property in class mx.validators.CreditCardValidator
Object that contains the value of the card type field.
caretBookmark — Property in class mx.controls.listClasses.ListBase
A bookmark to the item under the caret.
caretIndex — Property in class flash.text.TextField
The index of the insertion point (caret) position.
caretIndex — Property in class mx.controls.listClasses.ListBase
The offset of the item in the data provider that is the selection caret point.
caretIndicator — Property in class mx.controls.listClasses.ListBase
The DisplayObject that contains the graphics that indicate which renderer is the caret.
caretItemRenderer — Property in class mx.controls.listClasses.ListBase
The renderer for the item under the caret.
caretUID — Property in class mx.controls.listClasses.ListBase
The UID of the item under the caret.
CartesianChart — Class in package mx.charts.chartClasses
The CartesianChart class is a base class for the common chart types.
CartesianChart() — Constructor in class mx.charts.chartClasses.CartesianChart
Constructor.
CartesianTransform — Class in package mx.charts.chartClasses
The CartesianTransform object represents a set of axes sed to map data values to x/y Cartesian screen coordinates and vice versa.
CartesianTransform() — Constructor in class mx.charts.chartClasses.CartesianTransform
Constructor.
case — Statement
Defines a jump target for the switch statement.
caseInsensitive — Property in class mx.collections.SortField
Specifies whether the sort for this field should be case insensitive.
CASEINSENSITIVE — Constant static property in class Array
Specifies case-insensitive sorting for the Array class sorting methods.
category — Property in interface mx.logging.ILogger
The category value for the logger.
category — Property in class mx.logging.LogLogger
The category this logger send messages for.
CategoryAxis — Class in package mx.charts
The CategoryAxis class lets charts represent data grouped by a set of discrete values along an axis.
CategoryAxis() — Constructor in class mx.charts.CategoryAxis
Constructor.
categoryField — Property in class mx.charts.CategoryAxis
Specifies the field of the data provider containing the text for the labels.
cause — Property in class mx.data.Conflict
Returns the DataMessage that caused the conflict.
cause — Property in class mx.data.messages.DataErrorMessage
The client oringinated message which caused the conflict.
ceil(val:Number) — Static method in class Math
Returns the ceiling of the specified number or expression.
center(width:Number, height:Number) — Method in class mx.preloaders.DownloadProgressBar
Centers the download progress bar based on the passed in dimensions.
CENTER — Constant static property in class flash.text.TextFieldAutoSize
Specifies that the text is to be treated as center-justified text.
CENTER — Constant static property in class flash.text.TextFormatAlign
Constant; centers the text in the text field.
CENTER — Constant static property in class mx.controls.ProgressBarLabelPlacement
Specifies to place at the center inside the progress bar.
centerPopUp(popUp:mx.core:IFlexDisplayObject) — Static method in class mx.managers.PopUpManager
Centers a popup window over whatever window was used in the call to the createPopUp() or addPopUp() method.
change — Event in class flash.text.TextField
Dispatched after a control's value is modified.
change — Event in class mx.containers.Accordion
Dispatched when the selected child container changes.
change — Event in class mx.containers.ViewStack
Dispatched when the selected child container changes.
change — Event in class mx.controls.Button
Dispatched when the selected property changes for a toggle Button control.
change — Event in class mx.controls.ColorPicker
Dispatched when the selected color changes as a result of user interaction.
change — Event in class mx.controls.ComboBox
Dispatched when the ComboBox contents changes as a result of user interaction: when the selectedIndex or selectedItem property changes, and, if the ComboBox control is editable, each time a keystroke is entered in the box.
change — Event in class mx.controls.DateChooser
Dispatched when a date is selected or changed.
change — Event in class mx.controls.DateField
Dispatched when a date is selected or changed, and the DateChooser control closes.
change — Event in class mx.controls.NumericStepper
Dispatched when the value of the NumericStepper control changes as a result of user interaction.
change — Event in class mx.controls.RadioButtonGroup
Dispatched when the value of the selected RadioButton control in this group changes.
change — Event in class mx.controls.RichTextEditor
Dispatched when the user changes the contents or format of the text in the TextArea control.
change — Event in class mx.controls.TextArea
Dispatched when text in the TextArea control changes through user input or data binding.
change — Event in class mx.controls.TextInput
Dispatched when text in the TextInput control changes through user input or data binding.
change — Event in class mx.controls.Tree
Dispatched when the user selects a tree item.
change — Event in class mx.controls.listClasses.ListBase
Dispatched when the selectedIndex or selectedItem property changes as a result of user interaction.
change — Event in class mx.controls.sliderClasses.Slider
Dispatched when the slider changes value due to mouse or keyboard interaction.
CHANGE — Constant static property in class flash.events.Event
Defines the value of the type property of a change event object.
CHANGE — Constant static property in class mx.events.CalendarLayoutChangeEvent
The CalendarLayoutChangeEvent.CHANGE constant defines the value of the type property of the event object for a change event.
CHANGE — Constant static property in class mx.events.ColorPickerEvent
The ColorPickerEvent.CHANGE constant defines the value of the type property of the event that is dispatched when the user selects a color from the ColorPicker control.
CHANGE — Constant static property in class mx.events.IndexChangedEvent
The IndexChangedEvent.CHANGE constant defines the value of the type property of the event object for a change event, which indicates that an index has changed, such as when and Accordion control changes the displayed panel or a ViewStack changes views.
CHANGE — Constant static property in class mx.events.NumericStepperEvent
The NumericStepperEvent.CHANGE constant defines the value of the type property of the event object for a change event.
CHANGE — Constant static property in class mx.events.SliderEvent
The SliderEvent.CHANGE constant defines the value of the type property of the event object for a change event.
changedPropertyNames — Property in interface mx.data.IChangeObject
Returns the list of property names which changed as part of an update.
changeList — Property in class flash.events.SyncEvent
An array with properties that describe the array's status.
ChangeWatcher — Class in package mx.binding.utils
The ChangeWatcher class defines utility methods that you can use with bindable Flex properties.
ChangeWatcher(access:Object, handler:Function, commitOnly:Boolean, next:mx.binding.utils:ChangeWatcher) — Constructor in class mx.binding.utils.ChangeWatcher
Constructor.
channel — Property in class mx.messaging.MessageResponder
Provides access to the Channel used to send the message.
channel — Property in class mx.messaging.events.ChannelEvent
The Channel that generated this event.
Channel — Class in package mx.messaging
The Channel class is the base message channel class that all channels in the messaging system must extend.
Channel(id:String, uri:String) — Constructor in class mx.messaging.Channel
Constructs an instance of a generic Channel that connects to the specified endpoint URI.
channelConnect — Event in class mx.messaging.Channel
Dispatched after the channel has connected to its endpoint.
channelConnect — Event in class mx.messaging.ChannelSet
Dispatched after a Channel in the ChannelSet has connected to its endpoint.
channelConnect — Event in class mx.messaging.MessageAgent
Dispatched when the underlying Channel the MessageAgent is using connects.
channelConnectHandler(event:mx.messaging.events:ChannelEvent) — Method in class mx.messaging.ChannelSet
Handles a CONNECT ChannelEvent and redispatches the event.
channelConnectHandler(event:mx.messaging.events:ChannelEvent) — Method in class mx.messaging.MessageAgent
Handles a CONNECT ChannelEvent.
channelDisconnect — Event in class mx.messaging.Channel
Dispatched after the channel has disconnected from its endpoint.
channelDisconnect — Event in class mx.messaging.ChannelSet
Dispatched after a Channel in the ChannelSet has disconnected from its endpoint.
channelDisconnect — Event in class mx.messaging.MessageAgent
Dispatched when the underlying Channel the MessageAgent is using disconnects.
channelDisconnectHandler(event:mx.messaging.events:ChannelEvent) — Method in class mx.messaging.ChannelSet
Handles a DISCONNECT ChannelEvent and redispatches the event.
channelDisconnectHandler(event:mx.messaging.events:ChannelEvent) — Method in class mx.messaging.MessageAgent
Handles a DISCONNECT ChannelEvent.
ChannelError — Class in package mx.messaging.errors
This is the base class for any channel related errors.
ChannelError(msg:String) — Constructor in class mx.messaging.errors.ChannelError
Constructs a new instance of a ChannelError with the specified message.
ChannelEvent — Class in package mx.messaging.events
The ChannelEvent is used to propagate channel events within the messaging system.
ChannelEvent(type:String, bubbles:Boolean, cancelable:Boolean, channel:mx.messaging:Channel, reconnecting:Boolean, rejected:Boolean) — Constructor in class mx.messaging.events.ChannelEvent
Constructs an instance of this event with the specified type and Channel instance.
channelFault — Event in class mx.messaging.Channel
Dispatched after the channel has faulted.
channelFault — Event in class mx.messaging.ChannelSet
Dispatched after a Channel in the ChannelSet has faulted.
channelFault — Event in class mx.messaging.MessageAgent
Dispatched when the underlying Channel the MessageAgent is using faults.
ChannelFaultEvent — Class in package mx.messaging.events
The ChannelFaultEvent class is used to propagate channel fault events within the messaging system.
ChannelFaultEvent(type:String, bubbles:Boolean, cancelable:Boolean, channel:mx.messaging:Channel, reconnecting:Boolean, code:String, level:String, description:String) — Constructor in class mx.messaging.events.ChannelFaultEvent
Constructs an instance of this event with the specified type.
channelFaultHandler(event:mx.messaging.events:ChannelFaultEvent) — Method in class mx.messaging.ChannelSet
Handles a ChannelFaultEvent and redispatches the event.
channelFaultHandler(event:mx.messaging.events:ChannelFaultEvent) — Method in class mx.messaging.MessageAgent
Handles a ChannelFaultEvent.
channelIds — Property in class mx.messaging.ChannelSet
The ids of the Channels used by the ChannelSet.
channelSet — Property in class mx.messaging.MessageAgent
Provides access to the ChannelSet used by the MessageAgent.
channelSet — Property in class mx.rpc.AbstractService
Provides access to the ChannelSet used by the service.
channelSet — Property in class mx.rpc.http.HTTPService
Provides access to the ChannelSet used by the service.
ChannelSet — Class in package mx.messaging
The ChannelSet is a set of Channels that are used to send messages to a target destination.
ChannelSet(channelIds:Array, clustered:Boolean) — Constructor in class mx.messaging.ChannelSet
Constructs a ChannelSet.
channelSets — Property in class mx.messaging.Channel
Provides access to the ChannelSets connected to the Channel.
charAt(index:Number) — Method in class String
Returns the character in the position specified by the index parameter.
charCode — Property in class flash.events.KeyboardEvent
Contains the character code value of the key pressed or released.
charCodeAt(index:Number) — Method in class String
Returns the numeric Unicode character code of the character at the specified index.
charCount — Property in class flash.text.TextSnapshot
The number of characters in a TextSnapshot object.
chart — Property in class mx.charts.AxisRenderer
The base chart for this AxisRenderer.
chart — Property in class mx.charts.chartClasses.ChartElement
Refers to the chart component containing this element.
ChartBase — Class in package mx.charts.chartClasses
The ChartBase class is the link between the Flex component architecture and the DualStyleObject architecture.
ChartBase() — Constructor in class mx.charts.chartClasses.ChartBase
Constructor.
chartDataProvider — Property in class mx.charts.chartClasses.AxisBase
The data provider assigned to the enclosing chart.
chartDataProvider — Property in class mx.charts.chartClasses.ChartElement
The data provider assigned to the enclosing chart.
chartDataProvider — Property in interface mx.charts.chartClasses.IAxis
The data provider assigned to the enclosing chart.
chartDataProvider — Property in interface mx.charts.chartClasses.IChartElement
The data provider assigned to the enclosing chart.
ChartElement — Class in package mx.charts.chartClasses
The ChartElement class is the base class for visual chart elements.
ChartElement() — Constructor in class mx.charts.chartClasses.ChartElement
Constructor.
chartItem — Property in class mx.charts.HitData
The chart item described by the hit data.
ChartItem — Class in package mx.charts
A ChartItem represents a single item in a ChartSeries.
ChartItem(element:mx.charts.chartClasses:IChartElement, item:Object, index:uint) — Constructor in class mx.charts.ChartItem
Constructor.
ChartItemEvent — Class in package mx.charts.events
The ChartItemEvent class represents events that are specific to the chart components, such as when a chart item is clicked.
ChartItemEvent(type:String, hitSet:Array, triggerEvent:flash.events:MouseEvent, target:mx.charts.chartClasses:ChartBase) — Constructor in class mx.charts.events.ChartItemEvent
Constructor.
ChartLabel — Class in package mx.charts.chartClasses
Draws data labels on chart controls.
ChartLabel() — Constructor in class mx.charts.chartClasses.ChartLabel
Constructor.
chartSeriesStyles — Style in class mx.charts.chartClasses.ChartBase
Contains a list of Strings, each corresponding to a CSS type selector to be used as the default CSS style for a series.
chartState — Property in class mx.charts.chartClasses.ChartBase
The current transition state of the chart.
ChartState — Final class in package mx.charts.chartClasses
Describes the current state of a chart.
chartStateChanged(oldState:uint, newState:uint) — Method in class mx.charts.AxisRenderer
Called by the chart to indicate when its current transition state has changed.
chartStateChanged(oldState:uint, v:uint) — Method in class mx.charts.chartClasses.ChartElement
Called by the enclosing chart to indicate that the current state of the chart has changed.
chartStateChanged(oldState:uint, v:uint) — Method in interface mx.charts.chartClasses.IAxisRenderer
Called by the enclosing chart to indicate that the current state of the chart has changed.
chartStateChanged(oldState:uint, v:uint) — Method in interface mx.charts.chartClasses.IChartElement
Called by the enclosing chart to indicate that the current state of the chart has changed.
CheckBox — Class in package mx.controls
The CheckBox control consists of an optional label and a small box that can contain a check mark or not.
CheckBox() — Constructor in class mx.controls.CheckBox
Constructor.
CheckBoxIcon — Class in package mx.skins.halo
The skin for all the states of the icon in a CheckBox.
CheckBoxIcon() — Constructor in class mx.skins.halo.CheckBoxIcon
Constructor.
checkCreate(remoteChange:mx.data:IChangeObject, localChange:mx.data:IChangeObject) — Method in class mx.data.ConflictDetector
Called by the DataService when a create operation is pushed/processed from the remote destination.
checkDelete(remoteChange:mx.data:IChangeObject, localChange:mx.data:IChangeObject) — Method in class mx.data.ConflictDetector
Called by the DataService when a delete operation is pushed/processed from the remote destination.
checkDisabledIcon — Style in class mx.controls.Menu
The icon for all dsiabled menu items whose type identifier is a check box.
checkIcon — Style in class mx.controls.Menu
The icon for all enabled menu items whose type identifier is a check box.
checkPolicyFile — Property in class flash.media.SoundLoaderContext
Specifies whether Flash Player should try to download a cross-domain policy file from the loaded sound's server before beginning to load the sound.
checkPolicyFile — Property in class flash.net.NetStream
Specifies whether Flash Player should try to download a cross-domain policy file from the loaded FLV file's server before beginning to load the FLV file.
checkPolicyFile — Property in class flash.system.LoaderContext
Specifies whether Flash Player should attempt to download a cross-domain policy file from the loaded object's server before beginning to load the object itself.
checkUpdate(remoteChange:mx.data:IChangeObject, localChange:mx.data:IChangeObject) — Method in class mx.data.ConflictDetector
Called by the DataService when an update operation is pushed/processed from the remote destination.
child(propertyName:Object) — Method in class XML
Lists the children of an XML object.
child(propertyName:Object) — Method in class XMLList
Calls the child() method of each XML object and returns an XMLList object that contains the results in order.
child(propertyName:Object) — Method in class mx.collections.XMLListCollection
Calls the child() method of each XML object in the XMLList and returns an XMLList containing the children of with the specified property name, in order.
childAdd — Event in class mx.core.Container
Dispatched after a child has been added to a container.
CHILD_ADD — Constant static property in class mx.events.ChildExistenceChangedEvent
The ChildExistenceChangedEvent.CHILD_ADD constant defines the value of the type property of the event object for a childAdd event.
childAllowsParent — Property in class flash.display.LoaderInfo
Expresses the trust relationship from content (child) to the Loader (parent).
childDescriptors — Property in class mx.core.Container
Array of UIComponentDescriptor objects produced by the MXML compiler.
childDescriptors — Property in class mx.core.Repeater
An Array of UIComponentDescriptor objects for this Repeater's children.
ChildExistenceChangedEvent — Class in package mx.events
Represents events that are dispatched when a the child of a control is created or destroyed.
ChildExistenceChangedEvent(type:String, bubbles:Boolean, cancelable:Boolean, relatedObject:flash.display:DisplayObject) — Constructor in class mx.events.ChildExistenceChangedEvent
Constructor.
childIndex() — Method in class XML
Identifies the zero-indexed position of this XML object within the context of its parent.
childIndexChange — Event in class mx.core.Container
Dispatched after the index (among the container children) of a container child changes.
CHILD_INDEX_CHANGE — Constant static property in class mx.events.IndexChangedEvent
The IndexChangedEvent.CHILD_INDEX_CHANGE constant defines the value of the type property of the event object for a childIndexChange event, which indicates that a component's index among a container's children has changed.
childMessageId — Property in class mx.data.messages.DataAssociationMessage
If the association involves a child that is being created in the same message batch, the server will use this message id to locate the child instead of relying on the identity provided by the client (the identity may be changed by the server).
childNodes — Property in class flash.xml.XMLNode
An array of the specified XMLNode object's children.
childRemove — Event in class mx.core.Container
Dispatched before a child of a container is removed.
CHILD_REMOVE — Constant static property in class mx.events.ChildExistenceChangedEvent
The ChildExistenceChangedEvent.CHILD_REMOVE constant defines the value of the type property of the event object for a childRemove event.
children() — Method in class XML
Lists the children of the XML object in the sequence in which they appear.
children() — Method in class XMLList
Calls the children() method of each XML object and returns an XMLList object that contains the results.
children() — Method in class mx.collections.XMLListCollection
Calls the children() method of each XML object in the XMLList and returns an XMLList containing the results.
children — Property in class mx.effects.CompositeEffect
An Array containing the child effects of this CompositeEffect.
childrenCreated() — Method in class mx.core.UIComponent
Performs any final processing after child objects are created.
childSequenceId — Property in class mx.data.messages.DataAssociationMessage
The index of the child sequence on the server.
CHINESE — Constant static property in class flash.system.IMEConversionMode
The string "CHINESE", for use with the IME.conversionMode property.
CircleItemRenderer — Class in package mx.charts.renderers
A simple chart itemRenderer implementation that fills an elliptical area.
CircleItemRenderer() — Constructor in class mx.charts.renderers.CircleItemRenderer
Constructor.
Circular — Class in package mx.effects.easing
The Circular class defines three easing functions to implement circular motion with Flex effect classes.
claimStyles(styles:Array, firstAvailable:uint) — Method in class mx.charts.chartClasses.ChartElement
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
claimStyles(styles:Array, firstAvailable:uint) — Method in interface mx.charts.chartClasses.IChartElement
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
claimStyles(styles:Array, firstAvailable:uint) — Method in class mx.charts.chartClasses.Series
Called by the chart to allow associated elements to claim style selectors from its chartSeriesStyles Array.
clamp — Property in class flash.filters.ConvolutionFilter
Indicates whether the image should be clamped.
CLAMP — Constant static property in class flash.filters.DisplacementMapFilterMode
Clamps the displacement value to the edge of the source image.
class — Statement
Defines a class, which lets you instantiate objects that share methods and properties that you define.
Class — Dynamic class in Top Level
A Class object is created for each class definition in a program.
ClassFactory — Class in package mx.core
A ClassFactory instance is a "factory object" which Flex uses to generate instances of another class, each with identical properties.
ClassFactory(generator:Class) — Constructor in class mx.core.ClassFactory
Constructor.
className — Property in class mx.core.UIComponent
The name of this instance's class, such as "Button".
className — Property in class mx.core.UITextField
The name of this instance's class, such as "DataGridItemRenderer".
className — Property in class mx.effects.Effect
The name of the effect class, such as "Fade".
className — Property in class mx.effects.EffectInstance
The name of the effect class, such as "FadeInstance".
className — Property in class mx.messaging.management.MBeanInfo
The class name for the MBean.
className — Property in class mx.messaging.management.ObjectInstance
The class name.
className — Property in interface mx.styles.IStyleClient
The name of component class.
clear() — Method in class flash.display.Graphics
Clears the graphics that were drawn to this Graphics object, and resets fill and line style settings.
clear() — Method in class flash.media.Video
Clears the image currently displayed in the Video object.
clear() — Method in class flash.net.SharedObject
For local shared objects, purges all of the data and deletes the shared object from the disk.
clear() — Method in class flash.text.StyleSheet
Removes all styles from the style sheet object.
clearHeaders() — Method in class mx.rpc.soap.Operation
Clears the headers for this individual Operation.
clearHeaders() — Method in class mx.rpc.soap.WebService
Clears the headers that applied to all operations.
clearIndicators() — Method in class mx.controls.listClasses.ListBase
Removes all selection and highlight and caret indicators.
clearInterval(id) — Package function in flash.utils
Cancels a specified setInterval() call.
clearResult(fireBindingEvent:Boolean) — Method in class mx.rpc.AbstractInvoker
Sets the result property of the invoker to null.
clearSelected(transition:Boolean) — Method in class mx.controls.listClasses.ListBase
Clears the set of selected items and removes all graphics depicting the selected state of those items.
clearSeparators() — Method in class mx.controls.DataGrid
Removes column header separators that the user normally uses to resize columns.
clearStyle(styleProp:String) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
Deletes a style property from this component instance.
clearStyle(styleProp:String) — Method in class mx.core.UIComponent
Deletes a style property from this component instance.
clearStyle(styleProp:String) — Method in class mx.styles.CSSStyleDeclaration
Clears a style property on this CSSStyleDeclaration.
clearStyle(styleProp:String) — Method in interface mx.styles.IStyleClient
Deletes a style property from this component instance.
clearStyleDeclaration(selector:String, update:Boolean) — Static method in class mx.styles.StyleManager
Clears the CSSStyleDeclaration object that stores the rules for the specified CSS selector.
clearTimeout(id) — Package function in flash.utils
Cancels a specified setTimeout() call.
click — Event in class flash.display.InteractiveObject
Dispatched when a user presses and releases the main button of the user's pointing device over the same InteractiveObject.
CLICK — Constant static property in class flash.events.MouseEvent
Defines the value of the type property of a click event object.
clickHandler(event:flash.events:MouseEvent) — Method in class mx.controls.Button
The default handler for the MouseEvent.CLICK event.
clickHandler(event:flash.events:MouseEvent) — Method in class mx.controls.NavBar
Handles the MouseEvent.CLICK event for the items in the NavBar control.
clickTarget — Property in class mx.events.SliderEvent
Specifies whether the slider track or a slider thumb was pressed.
client — Property in class flash.net.LocalConnection
Indicates the object on which callback methods are invoked.
client — Property in class flash.net.NetConnection
Indicates the object on which callback methods should be invoked.
client — Property in class flash.net.NetStream
Specifies the object on which callback methods are invoked.
client — Property in class flash.net.SharedObject
Indicates the object on which callback methods are invoked.
clientId — Property in class mx.messaging.MessageAgent
Provides access to the client id for the MessageAgent.
clientId — Property in class mx.messaging.messages.AbstractMessage
The clientId indicates which MessageAgent sent the message.
clientId — Property in interface mx.messaging.messages.IMessage
The clientId indicates which client sent the message.
clientObject — Property in class mx.data.Conflict
Returns the state of the client object (whose property was changed) at the time of the conflict.
CLIENT_PING_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
This operation is used to test connectivity over the current channel to the remote endpoint.
CLIENT_SYNC_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
This operation is used by a remote destination to sync missed or cached messages back to a client as a result of a client issued poll command.
CLIENT_UPDATE — Constant static property in class mx.data.messages.UpdateCollectionMessage
Indicates this update collection message was client generated.
clipContent — Property in class mx.charts.chartClasses.ChartBase
Determines if Flex clips the chart to the area bounded by the axes.
clipContent — Property in class mx.core.Container
Whether to apply a clip mask if the positions and/or sizes of this container's children extend outside the borders of this container.
clone() — Method in class flash.display.BitmapData
Returns a new BitmapData object that is a clone of the original instance with an exact copy of the contained bitmap.
clone() — Method in class flash.events.ActivityEvent
Creates a copy of an ActivityEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.AsyncErrorEvent
Creates a copy of the AsyncErrorEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.ContextMenuEvent
Creates a copy of the ContextMenuEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.DataEvent
Creates a copy of the DataEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.ErrorEvent
Creates a copy of the ErrorEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.Event
Duplicates an instance of an Event subclass.
clone() — Method in class flash.events.FocusEvent
Creates a copy of the FocusEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.HTTPStatusEvent
Creates a copy of the HTTPStatusEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.IMEEvent
Creates a copy of the IMEEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.IOErrorEvent
Creates a copy of the IOErrorEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.KeyboardEvent
Creates a copy of the KeyboardEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.MouseEvent
Creates a copy of the MouseEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.NetStatusEvent
Creates a copy of the NetStatusEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.ProgressEvent
Creates a copy of the ProgressEvent object and sets each property's value to match that of the original.
clone() — Method in class flash.events.SecurityErrorEvent
Creates a copy of the SecurityErrorEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.StatusEvent
Creates a copy of the StatusEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.SyncEvent
Creates a copy of the SyncEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.TextEvent
Creates a copy of the TextEvent object and sets the value of each property to match that of the original.
clone() — Method in class flash.events.TimerEvent
Creates a copy of the TimerEvent object and sets each property's value to match that of the original.
clone() — Method in class flash.filters.BevelFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.BitmapFilter
Returns a BitmapFilter object that is an exact copy of the original BitmapFilter object.
clone() — Method in class flash.filters.BlurFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.ColorMatrixFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.ConvolutionFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.DisplacementMapFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.DropShadowFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.GlowFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.GradientBevelFilter
Returns a copy of this filter object.
clone() — Method in class flash.filters.GradientGlowFilter
Returns a copy of this filter object.
clone() — Method in class flash.geom.Matrix
Returns a new Matrix object that is a clone of this matrix, with an exact copy of the contained object.
clone() — Method in class flash.geom.Point
Creates a copy of this Point object.
clone() — Method in class flash.geom.Rectangle
Returns a new Rectangle object with the same values for the x, y, width, and height properties as the original Rectangle object.
clone() — Method in class flash.ui.ContextMenu
Creates a copy of the specified ContextMenu object.
clone() — Method in class flash.ui.ContextMenuItem
Creates and returns a copy of the specified ContextMenuItem object.
clone() — Method in class mx.charts.ChartItem
Returns a copy of this ChartItem.
clone() — Method in class mx.charts.chartClasses.RenderData
Creates a copy of the render data.
clone() — Method in class mx.charts.series.items.LineSeriesSegment
Returns a copy of this segment.
clone() — Method in class mx.core.EdgeMetrics
Returns a copy of this EdgeMetrics object.
clone() — Method in class mx.messaging.events.ChannelEvent
Clones the ChannelEvent.
clone() — Method in class mx.messaging.events.ChannelFaultEvent
Clones the ChannelFaultEvent.
clone() — Method in class mx.messaging.events.MessageAckEvent
Clones the MessageAckEvent.
clone() — Method in class mx.messaging.events.MessageEvent
Clones the MessageEvent.
clone() — Method in class mx.messaging.events.MessageFaultEvent
Clones the MessageFaultEvent.
clone() — Method in class mx.rpc.soap.LoadEvent
cloneNode(deep:Boolean) — Method in class flash.xml.XMLNode
Constructs and returns a new XML node of the same type, name, value, and attributes as the specified XML object.
close() — Method in class flash.display.Loader
Cancels a load() method operation that is currently in progress for the Loader instance.
close() — Method in class flash.media.Sound
Closes the stream, causing any download of data to cease.
close() — Method in class flash.net.LocalConnection
Closes (disconnects) a LocalConnection object.
close() — Method in class flash.net.NetConnection
Closes the connection that was opened locally or with the server and dispatches the netStatus event with a code property of NetConnection.Connect.Close.
close() — Method in class flash.net.NetStream
Stops playing all data on the stream, sets the time property to 0, and makes the stream available for another use.
close() — Method in class flash.net.SharedObject
Closes the connection between a remote shared object and the server.
close — Event in class flash.net.Socket
Dispatched when the server closes the socket connection.
close() — Method in class flash.net.Socket
Closes the socket.
close() — Method in class flash.net.URLLoader
Closes the load operation in progress.
close() — Method in class flash.net.URLStream
Immediately closes the stream and cancels the download operation.
close — Event in class flash.net.XMLSocket
Dispatched when the server closes the socket connection.
close() — Method in class flash.net.XMLSocket
Closes the connection specified by the XMLSocket object.
close — Property in class mx.charts.series.items.HLOCSeriesItem
The close value of this item converted into screen coordinates.
close — Event in class mx.containers.Panel
Dispatched when the user selects the close button.
close — Event in class mx.controls.ColorPicker
Dispatched when the swatch panel closes.
close(trigger:flash.events:Event) — Method in class mx.controls.ColorPicker
Hides the drop-down SwatchPanel object.
close — Event in class mx.controls.ComboBox
Dispatched when the drop-down list is dismissed for any reason such when the user:
  • selects an item in the drop-down list
  • clicks outside of the drop-down list
  • clicks the drop-down button while the drop-down list is displayed
  • presses the ESC key while the drop-down list is displayed
close() — Method in class mx.controls.ComboBox
Hides the drop-down list.
close — Event in class mx.controls.DateField
Dispatched when a date is selected or the user clicks outside the drop-down list.
close() — Method in class mx.controls.DateField
Closes the DateChooser control.
close — Event in class mx.controls.PopUpButton
Dispatched when the specified UIComponent closes.
close() — Method in class mx.controls.PopUpButton
Closes the UIComponent object opened by the PopUpButton control.
close — Event in class mx.controls.VideoDisplay
Dispatched when the NetConnection object is closed, whether by timing out or by calling the close() method.
close() — Method in class mx.controls.VideoDisplay
Forces the close of an input stream and connection to Flash Media Server.
CLOSE — Constant static property in class flash.events.Event
Defines the value of the type property of a close event object.
CLOSE — Constant static property in class mx.events.CloseEvent
The CloseEvent.CHANGE constant defines the value of the type property of the event object for a close event.
CLOSE — Constant static property in class mx.events.DropdownEvent
The DropdownEvent.CLOSE constant defines the value of the type property of the event object for a close event.
CLOSE — Constant static property in class mx.events.VideoEvent
The VideoEvent.CLOSE constant defines the value of the type property of the event object for a close event.
closeButtonDisabledSkin — Style in class mx.containers.Panel
The close button disabled skin.
closeButtonDownSkin — Style in class mx.containers.Panel
The close button down skin.
closeButtonOverSkin — Style in class mx.containers.Panel
The close button over skin.
closeButtonUpSkin — Style in class mx.containers.Panel
The close button up skin.
closeDuration — Style in class mx.controls.ColorPicker
Length of a close transition, in milliseconds.
closeDuration — Style in class mx.controls.ComboBox
The length of the transition when the drop-down list closes, in milliseconds.
closeDuration — Style in class mx.controls.PopUpButton
Length of a close transition, in milliseconds.
closeEasingFunction — Style in class mx.controls.ColorPicker
Easing function to control component tweening.
closeEasingFunction — Style in class mx.controls.ComboBox
An easing function to control the close transition.
closeEasingFunction — Style in class mx.controls.PopUpButton
Easing function to control component closing tween.
CloseEvent — Class in package mx.events
The CloseEvent class represents event objects specific to popup windows, such as the Alert control.
CloseEvent(type:String, bubbles:Boolean, cancelable:Boolean, detail:int) — Constructor in class mx.events.CloseEvent
Constructor.
closeField — Property in class mx.charts.chartClasses.HLOCSeriesBase
Specifies the field of the data provider that determines the y-axis location of the closing value of the element.
closeFilter — Property in class mx.charts.series.items.HLOCSeriesItem
The close value of this item, filtered against the vertical axis of the containing chart.
closeNumber — Property in class mx.charts.series.items.HLOCSeriesItem
The close value of this item, converted to a number by the vertical axis of the containing chart.
closeTickLength — Style in class mx.charts.series.HLOCSeries
Specifies the length, in pixels, for the close tick mark.
closeTickStroke — Style in class mx.charts.series.HLOCSeries
Specifies the stroke to use for the close tick mark if an opening value is specified.
closeValue — Property in class mx.charts.series.items.HLOCSeriesItem
The close value of this item.
clustered — Property in class mx.messaging.ChannelSet
Indicates whether the ChannelSet targets a clustered destination.
CLUSTER_REQUEST_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
This operation is used to request a list of failover endpoint URIs for the remote destination based on cluster membership.
code — Property in class flash.events.StatusEvent
A description of the object's status.
code — Property in class mx.controls.videoClasses.VideoError
Contains the error code.
collection — Property in class mx.controls.ComboBase
The ICollectionView of items this component displays.
collection — Property in class mx.controls.listClasses.ListBase
An ICollectionView that represents the data provider.
collectionChange — Event in interface mx.collections.ICollectionView
Dispatched when the ICollectionView has been updated in some way.
collectionChange — Event in interface mx.collections.IList
Dispatched when the IList has been updated in some way.
collectionChange — Event in class mx.collections.ListCollectionView
Dispatched when the ICollectionView has been updated in some way.
COLLECTION_CHANGE — Constant static property in class mx.events.CollectionEvent
The CollectionEvent.COLLECTION_CHANGE constant defines the value of the type property of the event object for an event that is dispatched when a collection has changed.
collectionChangeHandler(event:flash.events:Event) — Method in class mx.controls.ComboBase
Responds to changes to the data provider.
collectionChangeHandler(event:flash.events:Event) — Method in class mx.controls.listClasses.ListBase
Handles CollectionEvents dispatched from the data provider as the data changes.
CollectionEvent — Class in package mx.events
The mx.events.CollectionEvent class represents an event that is dispatched when the associated collection changes.
CollectionEvent(type:String, bubbles:Boolean, cancelable:Boolean, kind:String, location:int, oldLocation:int, items:Array) — Constructor in class mx.events.CollectionEvent
Constructor.
CollectionEventKind — Final class in package mx.events
The CollectionEventKind class contains constants for the valid values of the mx.events.CollectionEvent class kind property.
collectionId — Property in class mx.data.messages.UpdateCollectionMessage
The unique identifier for the collection that was updated.
CollectionViewError — Class in package mx.collections.errors
The CollectionViewError class represents general errors within a collection that are not related to specific activities such as Cursor seeking.
CollectionViewError(message:String) — Constructor in class mx.collections.errors.CollectionViewError
Constructor.
collectTransitions(chartState:Number, transitions:Array) — Method in class mx.charts.chartClasses.ChartElement
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
collectTransitions(chartState:Number, transitions:Array) — Method in interface mx.charts.chartClasses.IChartElement
Called by the enclosing chart to collect any transitions a particular element might play when the chart changes state.
color — Property in class flash.filters.ConvolutionFilter
The hexadecimal color to substitute for pixels that are off the source image.
color — Property in class flash.filters.DisplacementMapFilter
Specifies what color to use for out-of-bounds displacements.
color — Property in class flash.filters.DropShadowFilter
The color of the shadow.
color — Property in class flash.filters.GlowFilter
The color of the glow.
color — Property in class flash.geom.ColorTransform
The RGB color value for a ColorTransform object.
color — Property in class flash.text.TextFormat
Indicates the color of the text.
color — Style in class mx.charts.AxisRenderer
Color of text in the component, including the component label.
color — Style in class mx.charts.chartClasses.ChartBase
Color of text in the component, including the component label.
color — Style in class mx.charts.chartClasses.DataTip
Text color of a component label.
color — Style in class mx.charts.chartClasses.DataTip
Color of text in the component, including the component label.
color — Style in class mx.charts.series.PieSeries
Color of text in the component, including the component label.
color — Style in class mx.containers.FormHeading
Color of text in the component, including the component label.
color — Style in class mx.controls.Button
Color of text in the component, including the component label.
color — Style in class mx.controls.ColorPicker
Color of text in the component, including the component label.
color — Style in class mx.controls.ComboBox
Color of text in the component, including the component label.
color — Style in class mx.controls.DateChooser
Color of text in the component, including the component label.
color — Style in class mx.controls.DateField
Color of text in the component, including the component label.
color — Style in class mx.controls.Label
Color of text in the component, including the component label.
color — Style in class mx.controls.MenuBar
Color of text in the component, including the component label.
color — Style in class mx.controls.NumericStepper
Color of text in the component, including the component label.
color — Style in class mx.controls.ProgressBar
Color of text in the component, including the component label.
color — Style in class mx.controls.TextInput
Color of text in the component, including the component label.
color — Style in class mx.controls.ToolTip
Color of text in the component, including the component label.
color — Style in class mx.controls.dataGridClasses.DataGridColumn
Color of text in the component, including the component label.
color — Style in class mx.controls.listClasses.ListItemRenderer
Text color of a component label.
color — Style in class mx.controls.listClasses.TileListItemRenderer
Text color of a component label.
color — Style in class mx.controls.menuClasses.MenuBarItem
Color of text in the component, including the component label.
color — Style in class mx.controls.menuClasses.MenuItemRenderer
Text color of the menu item label.
color — Property in class mx.controls.textClasses.TextRange
Color of the text in the range.
color — Style in class mx.controls.treeClasses.TreeItemRenderer
Text color of a component label.
color — Style in class mx.core.Container
Color of text in the component, including the component label.
color — Style in class mx.core.ScrollControlBase
Color of text in the component, including the component label.
color — Style in class mx.core.UITextField
Color of text in the component, including the component label.
color — Property in class mx.effects.Dissolve
Hex value that represents the color of the floating rectangle that the effect displays over the target object.
color — Property in class mx.effects.Glow
The color of the glow.
color — Property in class mx.effects.effectClasses.DissolveInstance
Hex value that represents the color of the floating rectangle that the effect displays over the target object.
color — Property in class mx.effects.effectClasses.GlowInstance
The color of the glow.
color — Property in class mx.events.ColorPickerEvent
The RGB color that was rolled over, rolled out of, selected, or entered.
color — Property in class mx.graphics.GradientEntry
The color value for a gradient fill.
color — Property in class mx.graphics.RectangularDropShadow
The color of the shadow.
color — Property in class mx.graphics.SolidColor
A color value.
color — Property in class mx.graphics.Stroke
The line color.
COLOR — Constant static property in class flash.filters.DisplacementMapFilterMode
If the displacement value is outside the image, substitutes the values in the color and alpha properties.
colorField — Property in class mx.controls.ColorPicker
Name of the field in the objects of the dataProvider Array that specifies the hexadecimal values of the colors that the swatch panel displays.
ColorMatrixFilter — Final class in package flash.filters
The ColorMatrixFilter class lets you apply a 4 x 5 matrix transformation on the RGBA color and alpha values of every pixel in the input image to produce a result with a new set of RGBA color and alpha values.
ColorMatrixFilter(matrix:Array) — Constructor in class flash.filters.ColorMatrixFilter
Initializes a new ColorMatrixFilter instance with the specified parameters.
ColorPicker — Class in package mx.controls
The ColorPicker control provides a way for a user to choose a color from a swatch list.
ColorPicker() — Constructor in class mx.controls.ColorPicker
Constructor.
ColorPickerEvent — Class in package mx.events
Represents events that are specific to the ColorPicker control, such as when the user rolls the mouse over or out of a swatch in the swatch panel.
ColorPickerEvent(type:String, bubbles:Boolean, cancelable:Boolean, index:int, color:uint) — Constructor in class mx.events.ColorPickerEvent
Constructor.
ColorPickerSkin — Class in package mx.skins.halo
The skin for all the states of a ColorPicker.
ColorPickerSkin() — Constructor in class mx.skins.halo.ColorPickerSkin
Constructor.
colors — Property in class flash.filters.GradientBevelFilter
An array of RGB hexadecimal color values to use in the gradient.
colors — Property in class flash.filters.GradientGlowFilter
An array of colors that defines a gradient.
colorTransform(rect:flash.geom:Rectangle, colorTransform:flash.geom:ColorTransform) — Method in class flash.display.BitmapData
Adjusts the color values in a specified area of a bitmap image by using a ColorTransform object.
colorTransform — Property in class flash.geom.Transform
A ColorTransform object containing values that universally adjust the colors in the display object.
ColorTransform — Class in package flash.geom
The ColorTransform class lets you adjust the color values in a display object.
ColorTransform(redMultiplier:Number, greenMultiplier:Number, blueMultiplier:Number, alphaMultiplier:Number, redOffset:Number, greenOffset:Number, blueOffset:Number, alphaOffset:Number) — Constructor in class flash.geom.ColorTransform
Creates a ColorTransform object for a display object with the specified color channel values and alpha values.
ColorUtil — Class in package mx.utils
The ColorUtil class is an all-static class with methods for working with RGB colors within Flex.
colSpan — Property in class mx.containers.GridItem
Number of columns of the Grid container spanned by the cell.
ColumnChart — Class in package mx.charts
The ColumnChart control represents data as a series of vertical columns whose height is determined by values in the data.
ColumnChart() — Constructor in class mx.charts.ColumnChart
Constructor.
columnCount — Style in class mx.controls.ColorPicker
Number of columns in the swatch grid.
columnCount — Property in class mx.controls.listClasses.ListBase
The number of columns to be displayed in a TileList control or items in a HorizontalList control.
columnDropIndicatorSkin — Style in class mx.controls.DataGrid
The class to use as the skin that indicates that a column can be dropped in the current location.
columnIndex — Property in class mx.controls.dataGridClasses.DataGridListData
The column index of the item in columns for the DataGrid control.
columnIndex — Property in class mx.events.DataGridEvent
The zero-based index in the DataGrid object's columns array of the column associated with the event.
columnIndex — Property in class mx.events.ListEvent
The zero-based index of the column that contains the item renderer where the event occurred.
columnMap — Property in class mx.controls.dataGridClasses.DataGridBase
A map of item renderes to columns.
columnResizeSkin — Style in class mx.controls.DataGrid
The class to use as the skin for a column that is being resized.
columns — Property in class mx.controls.DataGrid
An array of DataGridColumn objects, one for each column that can be displayed.
ColumnSeries — Class in package mx.charts.series
Defines a data series for a ColumnChart control.
ColumnSeries() — Constructor in class mx.charts.series.ColumnSeries
Constructor.
ColumnSeriesItem — Class in package mx.charts.series.items
Represents the information required to render an item as part of a ColumnSeries.
ColumnSeriesItem(element:mx.charts.series:ColumnSeries, data:Object, index:uint) — Constructor in class mx.charts.series.items.ColumnSeriesItem
Constructor.
ColumnSeriesRenderData — Class in package mx.charts.series.renderData
Represents all the information needed by the ColumnSeries to render.
ColumnSeriesRenderData(cache:Array, filteredCache:Array, renderedBase:Number, renderedHalfWidth:Number, renderedXOffset:Number) — Constructor in class mx.charts.series.renderData.ColumnSeriesRenderData
Constructor.
ColumnSet — Class in package mx.charts.series
ColumnSet is a grouping set that can be used to stack or cluster column series in any arbitrary chart.
ColumnSet() — Constructor in class mx.charts.series.ColumnSet
Constructor.
columnStretch — Event in class mx.controls.DataGrid
Dispatched when a user changes the width of a column, indicating that the amount of data displayed in that column may have changed.
COLUMN_STRETCH — Constant static property in class mx.events.DataGridEvent
The DataGridEvent.COLUMN_STRETCH constant defines the value of the type property of the event object for a columnStretch event, which indicates that a user expanded a column horizontally.
columnWidth — Property in class mx.controls.listClasses.ListBase
The width of the control's columns.
columnWidthRatio — Style in class mx.charts.CandlestickChart
Specifies a ratio of how wide to draw the candlesticks relative to the horizontal axis's category widths, as a percentage in the range of 0 to 1.
columnWidthRatio — Style in class mx.charts.ColumnChart
Specifies a ratio of wide to draw the columns relative to the category width, as a percentage in the range of 0 to 1.
columnWidthRatio — Style in class mx.charts.HLOCChart
Specifies a ratio of how wide to draw the HLOC lines relative to the horizontal axis's category widths, as a percentage in the range of 0 to 1.
columnWidthRatio — Property in class mx.charts.chartClasses.HLOCSeriesBase
Specifies the width of elements relative to the category width.
columnWidthRatio — Property in interface mx.charts.chartClasses.IColumn
Specifies the width of items relative to the category size.
columnWidthRatio — Property in class mx.charts.series.ColumnSeries
Specifies the width of columns relative to the category width.
columnWidthRatio — Property in class mx.charts.series.ColumnSet
Specifies the width of columns relative to the category width.
ComboBase — Class in package mx.controls
The ComboBase class is the base class for controls that display text in a text field and have a button that causes a drop-down list to appear where the user can choose which text to display.
ComboBase() — Constructor in class mx.controls.ComboBase
Constructor.
ComboBox — Class in package mx.controls
The ComboBox control contains a drop-down list from which the user can select a single value.
ComboBox() — Constructor in class mx.controls.ComboBox
Constructor.
ComboBoxArrowSkin — Class in package mx.skins.halo
The skin for all the states of the button in a ComboBox.
ComboBoxArrowSkin() — Constructor in class mx.skins.halo.ComboBoxArrowSkin
Constructor.
CommandMessage — Class in package mx.messaging.messages
The CommandMessage class provides a mechanism for sending commands to the server infrastructure, such as commands related to publish/subscribe messaging scenarios, ping operations, and cluster operations.
CommandMessage() — Constructor in class mx.messaging.messages.CommandMessage
Constructs an instance of a CommandMessage with an empty body and header and a default operation of UNKNOWN_OPERATION.
comment — Property in class flash.media.ID3Info
A comment about the recording; corresponds to the ID3 2.0 tag COMM.
comments() — Method in class XML
Lists the properties of the XML object that contain XML comments.
comments() — Method in class XMLList
Calls the comments() method of each XML object and returns an XMLList of comments.
commit() — Method in class mx.data.DataService
Commits any pending changes for all collections currently managed by this service.
commit() — Method in class mx.data.DataStore
Commits any pending changes for all collections currently managed by this DataService.
commit() — Method in class mx.data.mxml.DataService
Commits any pending changes for all collections currently managed by this service.
commitProperties() — Method in class mx.charts.Legend
Processes the properties set on the component.
commitProperties() — Method in class mx.charts.chartClasses.CartesianChart
Processes the properties set on the component.
commitProperties() — Method in class mx.controls.listClasses.ListBase
Calculates the column width and row height and number of rows and columns based on whether properties like columnCount columnWidth, rowHeight and rowCount were explicitly set.
commitProperties() — Method in class mx.core.UIComponent
Processes the properties set on the component.
commitRequired — Property in class mx.data.DataService
Indicates if there are changes that have not been committed and the commit() method should be called.
commitRequired — Property in class mx.data.DataStore
Indicates if there are pending updates that must be committed.
commitRequired — Property in class mx.data.mxml.DataService
Indicates if there are changes that have not been committed and the commit() method should be called.
compare(otherBitmapData:flash.display:BitmapData) — Method in class flash.display.BitmapData
Compares two BitmapData objects.
compare(a:Object, b:Object, depth:int) — Static method in class mx.utils.ObjectUtil
Compares the Objects and returns an integer value indicating if the first item is less than greater than or equal to the second item.
compareFunction — Property in class mx.collections.Sort
The method used to compare items when sorting.
compareFunction — Property in class mx.collections.SortField
The function that compares two items during a sort of items for the associated collection.
complete — Event in class flash.display.LoaderInfo
Dispatched when data has loaded successfully.
complete — Event in class flash.media.Sound
Dispatched when data has loaded successfully.
complete — Event in class flash.net.FileReference
Dispatched when download is complete or when upload generates an HTTP status code of 200.
complete — Event in class flash.net.URLLoader
Dispatched after all the received data is decoded and placed in the data property of the URLLoader object.
complete — Event in class flash.net.URLStream
Dispatched when data has loaded successfully.
complete — Event in class mx.controls.ProgressBar
Dispatched when the load completes.
complete — Event in class mx.controls.SWFLoader
Dispatched when content loading is complete.
complete — Event in class mx.controls.VideoDisplay
Dispatched when the playhead reaches the end of the FLV file.
complete — Event in class mx.core.MovieClipLoaderAsset
Dispatched after the SWF asset has been fully loaded.
complete — Event in class mx.effects.SoundEffect
Dispatched when the sound file finishes loading.
COMPLETE — Constant static property in class flash.events.Event
Defines the value of the type property of a complete event object.
COMPLETE — Constant static property in class mx.events.VideoEvent
The VideoEvent.COMPLETE constant defines the value of the type property of the event object for a complete event.
completeEffect — Effect in class mx.controls.ProgressBar
Effect called when Flex dispatches the complete event, which occurs when the load completes.
completeEffect — Effect in class mx.controls.SWFLoader
Effect called when the complete event is dispatched.
completeHandler(event:flash.events:Event) — Method in class mx.preloaders.DownloadProgressBar
Event listener for the Event.COMPLETE event.
Component — MXML Only Component
You use the <mx:Component> tag to define an inline cell renderer or cell editor in an MXML editor.
ComponentDescriptor — Class in package mx.core
ComponentDescriptor is the base class for the UIComponentDescriptor class, which encapsulates the information that you specified in an MXML tag for an instance of a visual component.
ComponentDescriptor(descriptorProperties:Object) — Constructor in class mx.core.ComponentDescriptor
Constructor
componentX — Property in class flash.filters.DisplacementMapFilter
Describes which color channel to use in the map image to displace the x result.
componentY — Property in class flash.filters.DisplacementMapFilter
Describes which color channel to use in the map image to displace the y result.
CompositeEffect — Class in package mx.effects
The CompositeEffect class is the parent class for the Parallel and Sequence classes, which define the <mx:Parallel> and <mx:Sequence> MXML tags.
CompositeEffect(target:Object) — Constructor in class mx.effects.CompositeEffect
Constructor.
CompositeEffectInstance — Class in package mx.effects.effectClasses
The CompositeEffectInstance class implements the instance class for the CompositeEffect class.
CompositeEffectInstance(target:Object) — Constructor in class mx.effects.effectClasses.CompositeEffectInstance
Constructor.
compress() — Method in class flash.utils.ByteArray
Compresses the byte array using zlib compression.
computedGutters — Property in class mx.charts.chartClasses.CartesianChart
The current computed size of the gutters of the CartesianChart.
computedInterval — Property in class mx.charts.chartClasses.NumericAxis
The computed interval represented by this axis.
computedMaximum — Property in class mx.charts.chartClasses.NumericAxis
The computed maximum value represented by this axis.
computedMinimum — Property in class mx.charts.chartClasses.NumericAxis
The computed minimum value represented by this axis.
computeSpectrum(outputArray:flash.utils:ByteArray, FFTMode:Boolean, stretchFactor:int) — Static method in class flash.media.SoundMixer
Takes a snapshot of the current sound wave and places it into the specified ByteArray object.
concat(... rest) — Method in class Array
Concatenates the elements specified in the parameters with the elements in an array and creates a new array.
concat(... rest) — Method in class String
Appends the supplied arguments to the end of the String object, converting them to strings if necessary, and returns the resulting string.
concat(second:flash.geom:ColorTransform) — Method in class flash.geom.ColorTransform
Concatenates the ColorTranform object specified by the second parameter with the current ColorTransform object and sets the current object as the result, which is an additive combination of the two color transformations.
concat(m:flash.geom:Matrix) — Method in class flash.geom.Matrix
Concatenates a matrix with the current matrix, effectively combining the geometric effects of the two.
concatenatedColorTransform — Property in class flash.geom.Transform
A ColorTransform object representing the combined color transformations applied to the display object and all of its parent objects, back to the root level.
concatenatedMatrix — Property in class flash.geom.Transform
A Matrix object representing the combined transformation matrixes of the display object and all of its parent objects, back to the root level.
concurrency — Property in class mx.rpc.http.mxml.HTTPService
Value that indicates how to handle multiple calls to the same service.
concurrency — Property in interface mx.rpc.mxml.IMXMLSupport
The concurrency setting of the RPC operation or HTTPService.
concurrency — Property in class mx.rpc.remoting.mxml.Operation
The concurrency for this Operation.
concurrency — Property in class mx.rpc.remoting.mxml.RemoteObject
Value that indicates how to handle multiple calls to the same service.
concurrency — Property in class mx.rpc.soap.mxml.Operation
The concurrency for this Operation.
concurrency — Property in class mx.rpc.soap.mxml.WebService
Value that indicates how to handle multiple calls to the same service.
condenseWhite — Property in class flash.text.TextField
A Boolean value that specifies whether extra white space (spaces, line breaks, and so on) in a text field with HTML text should be removed.
condenseWhite — Property in class mx.controls.Label
Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a Label control with HTML text.
condenseWhite — Property in class mx.controls.TextArea
Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a TextArea control with HTML text.
condenseWhite — Property in class mx.controls.TextInput
Specifies whether extra white space (spaces, line breaks, and so on) should be removed in a TextInput control with HTML text.
configured — Property in class mx.messaging.ChannelSet
Indicates whether the ChannelSet is using automatically configured Channels or manually assigned Channels.
configureScrollBars() — Method in class mx.controls.listClasses.ListBase
Configures the ScrollBars based on the number of rows and columns and viewable rows and columns.
conflict — Event in class mx.data.DataService
The DataConflictEvent.CONFLICT event is dispatched when a conflict is detected between either pending local changes and changes submitted by another client, or when changes submitted by this client are conflicting with those in the remote destination.
conflict — Event in class mx.data.DataStore
Dispatched when a conflict is detected between either pending changes on this client and changes submitted by another client, or when changes submitted by this client result detect a conflict error at the remote destination.
conflict(description:String, properties:Array) — Method in interface mx.data.IChangeObject
Declares that a conflict occurred while processing this change.
conflict — Property in class mx.data.events.DataConflictEvent
Conflict — Class in package mx.data
The Conflict class is used to represent error that has occurred due to an update operation.
Conflict(dataService, errMsg:mx.data.messages:DataErrorMessage, resolver) — Constructor in class mx.data.Conflict
Constructs an instance of a Conflict based on the specified error message
CONFLICT — Constant static property in class mx.data.events.DataConflictEvent
The CONFLICT event type.
conflictDetector — Property in class mx.data.DataService
Provides access to the current implementation being used to detect conflicts for remote operations pushed to this DataService.
conflictDetector — Property in class mx.data.mxml.DataService
Provides access to the current implementation being used to detect conflicts for remote operations pushed to this DataService.
ConflictDetector — Class in package mx.data
A DataService instance uses a ConflictDetector instance to determine when a conflict occurs for an operation pushed from a remote destination.
ConflictDetector(dataService) — Constructor in class mx.data.ConflictDetector
Constructs an instance of the default conflict detection mechanism.
conflicts — Property in class mx.data.DataService
Returns the Conflicts object, an ArrayList of Conflict instances.
conflicts — Property in class mx.data.DataStore
Returns a list of conflicts for all managed items.
conflicts — Property in class mx.data.mxml.DataService
Returns the Conflicts object, an ArrayList of Conflict instances.
Conflicts — Class in package mx.data
The Conflicts class represents a list of conflicts.
Conflicts() — Constructor in class mx.data.Conflicts
connect(connectionName:String) — Method in class flash.net.LocalConnection
Prepares a LocalConnection object to receive commands from a send() command (called the sending LocalConnection object).
connect(command:String, ... rest) — Method in class flash.net.NetConnection
Opens a connection to a server.
connect(myConnection:flash.net:NetConnection, params:String) — Method in class flash.net.SharedObject
Connects to a remote shared object on the server through the specified connection.
connect — Event in class flash.net.Socket
Dispatched when a network connection has been established.
connect(host:String, port:int) — Method in class flash.net.Socket
Connects the socket to the specified host and port.
connect — Event in class flash.net.XMLSocket
Dispatched after a successful call to the XMLSocket.connect() method.
connect(host:String, port:int) — Method in class flash.net.XMLSocket
Establishes a connection to the specified Internet host using the specified TCP port.
connect(channelSet:mx.messaging:ChannelSet) — Method in class mx.messaging.Channel
Connects the ChannelSet to the Channel.
connect(agent:mx.messaging:MessageAgent) — Method in class mx.messaging.ChannelSet
Connects a MessageAgent to the ChannelSet.
CONNECT — Constant static property in class flash.events.Event
Defines the value of the type property of a connect event object.
CONNECT — Constant static property in class mx.messaging.events.ChannelEvent
The CONNECT event type; indicates that the Channel connected to its endpoint.
connected — Property in class flash.net.NetConnection
Indicates whether Flash Player has connected to a server through a persistent RTMP connection (true) or not (false).
connected — Property in class flash.net.Socket
Indicates whether this Socket object is currently connected.
connected — Property in class flash.net.URLStream
Indicates whether this URLStream object is currently connected.
connected — Property in class flash.net.XMLSocket
Indicates whether this XMLSocket object is currently connected.
connected — Property in class mx.data.DataService
Indicates if the DataService is connected to the remote destination.
connected — Property in class mx.data.DataStore
Indicates whether the DataStore is connected.
connected — Property in class mx.messaging.Channel
Indicates whether this channel has established a connection to the remote destination.
connected — Property in class mx.messaging.ChannelSet
Indicates whether the ChannelSet is connected.
connected — Property in class mx.messaging.MessageAgent
Indicates whether this MessageAgent is currently connected to its destination via its ChannelSet.
connectedProxyType — Property in class flash.net.NetConnection
If a successful connection is made, indicates the method that was used to make it: a direct connection, the CONNECT method, or HTTP tunneling.
connectFailed(event:mx.messaging.events:ChannelFaultEvent) — Method in class mx.messaging.Channel
Processes a failed internal connect and dispatches the FAULT event for the channel.
CONNECTION_ERROR — Constant static property in class mx.events.VideoEvent
The value of the VideoDisplay.state property when the VideoDisplay control was unable to load the video stream.
connectSuccess() — Method in class mx.messaging.Channel
Processes a successful internal connect and dispatches the CONNECT event for the Channel.
connectTimeout — Property in class mx.messaging.Channel
Provides access to the connect timeout in seconds for the channel.
connectTimeoutHandler(event:flash.events:TimerEvent) — Method in class mx.messaging.Channel
Handles a connect timeout by dispatching a ChannelFaultEvent.
const — Statement
Specifies a constant, which is a variable that can be assigned a value only once.
constructor — Property in class Object
A reference to the class object or constructor function for a given object instance.
constructors — Property in class mx.messaging.management.MBeanInfo
The constructors exposed by the MBean.
Consumer — Class in package mx.messaging
A Consumer subscribes to a destination to receive messages.
Consumer(messageType:String) — Constructor in class mx.messaging.Consumer
Constructs a Consumer.
container — Property in interface mx.core.IRepeater
The container that contains this Repeater, and in which it will create its children.
container — Property in class mx.core.Repeater
The container that contains this Repeater.
Container — Class in package mx.core
The Container class is an abstract base class for components that controls the layout characteristics of child components.
Container() — Constructor in class mx.core.Container
Constructor.
ContainerCreationPolicy — Final class in package mx.core
The ContainerCreationPolicy class defines the constant values for the creationPolicy property of the Container class.
ContainerLayout — Final class in package mx.core
The ContainerLayout class defines the constant values for the layout property of container classes.
contains(value:XML) — Method in class XML
Compares the XML object against the given value parameter.
contains(value:XML) — Method in class XMLList
Checks whether the XMLList object contains an XML object that is equal to the given value parameter.
contains(child:flash.display:DisplayObject) — Method in class flash.display.DisplayObjectContainer
Determines whether the specified display object is a child of the DisplayObjectContainer instance or the instance itself.
contains(x:Number, y:Number) — Method in class flash.geom.Rectangle
Determines whether the specified point is contained within the rectangular region defined by this Rectangle object.
contains(item:Object) — Method in interface mx.collections.ICollectionView
Returns whether the view contains the specified object.
contains(item:Object) — Method in class mx.collections.ListCollectionView
Returns whether the view contains the specified object.
contains(child:flash.display:DisplayObject) — Method in interface mx.core.IChildList
Determines if a DisplayObject is in this child list, or is a descendant of an child in this child list.
contains(child:flash.display:DisplayObject) — Method in interface mx.managers.IFocusManagerContainer
Determines whether the specified display object is a child of the container instance or the instance itself.
containsPoint(point:flash.geom:Point) — Method in class flash.geom.Rectangle
Determines whether the specified point is contained within the rectangular region defined by this Rectangle object.
containsRect(rect:flash.geom:Rectangle) — Method in class flash.geom.Rectangle
Determines whether the Rectangle object specified by the rect parameter is contained within this Rectangle object.
content — Property in class flash.display.Loader
Contains the root display object of the SWF file or image (JPG, PNG, or GIF) file that was loaded by using the load() method.
content — Property in class flash.display.LoaderInfo
The loaded object associated with this LoaderInfo object.
content — Property in class mx.controls.SWFLoader
This property contains the object that represents the content that was loaded in the SWFLoader control.
content — Property in class mx.rpc.soap.SOAPHeader
The content to send for the header value; can be a String or flash.xml.XMLNode.
contentHeight — Property in class mx.containers.Accordion
The height of the area, in pixels, in which content is displayed.
contentHeight — Property in class mx.containers.ViewStack
The height of the area, in pixels, in which content is displayed.
contentHeight — Property in class mx.controls.SWFLoader
Height of the scaled content loaded by the control, in pixels.
contentLoaderInfo — Property in class flash.display.Loader
Returns a LoaderInfo object corresponding to the object being loaded.
contentMouseX — Property in class mx.core.Container
Returns the x position of the mouse, in the content coordinate system.
contentMouseX — Property in class mx.core.UIComponent
Returns the x position of the mouse, in the content coordinate system.
contentMouseY — Property in class mx.core.Container
Returns the y position of the mouse, in the content coordinate system.
contentMouseY — Property in class mx.core.UIComponent
Returns the y position of the mouse, in the content coordinate system.
contentToGlobal(point:flash.geom:Point) — Method in class mx.core.Container
Converts a Point object from content coordinates to global coordinates.
contentToGlobal(point:flash.geom:Point) — Method in class mx.core.UIComponent
Converts a Point object from content coordinates to global coordinates.
contentToLocal(point:flash.geom:Point) — Method in class mx.core.Container
Converts a Point object from content to local coordinates.
contentToLocal(point:flash.geom:Point) — Method in class mx.core.UIComponent
Converts a Point object from content to local coordinates.
contentType — Property in class flash.display.LoaderInfo
The MIME type of the loaded file.
contentType — Property in class flash.net.URLRequest
The MIME content type of any POST data.
contentType — Property in class mx.messaging.messages.HTTPRequestMessage
Indicates the content type of this message.
contentType — Property in class mx.rpc.http.HTTPService
Type of content for service requests.
CONTENT_TYPE_FORM — Constant static property in class mx.messaging.messages.HTTPRequestMessage
Indicates that the content of this message is a form.
CONTENT_TYPE_FORM — Constant static property in class mx.rpc.http.HTTPService
Indicates that the data being sent by the HTTP service is encoded as application/x-www-form-urlencoded.
CONTENT_TYPE_SOAP_XML — Constant static property in class mx.messaging.messages.HTTPRequestMessage
Indicates that the content of this message is XML meant for a SOAP request.
CONTENT_TYPE_XML — Constant static property in class mx.messaging.messages.HTTPRequestMessage
Indicates that the content of this message is XML.
CONTENT_TYPE_XML — Constant static property in class mx.rpc.http.HTTPService
Indicates that the data being sent by the HTTP service is encoded as application/xml.
contentWidth — Property in class mx.containers.Accordion
The width of the area, in pixels, in which content is displayed.
contentWidth — Property in class mx.containers.ViewStack
The width of the area, in pixels, in which content is displayed.
contentWidth — Property in class mx.controls.SWFLoader
Width of the scaled content loaded by the control, in pixels.
contentX — Property in class mx.containers.ViewStack
The x coordinate of the area of the ViewStack container in which content is displayed, in pixels.
contentY — Property in class mx.containers.ViewStack
The y coordinate of the area of the ViewStack container in which content is displayed, in pixels.
contextColor — Property in class mx.charts.HitData
An RGB value that can be used to associate an on-screen representation of the associated chartItem.
contextMenu — Property in class flash.display.InteractiveObject
Specifies the context menu associated with this object.
ContextMenu — Final class in package flash.ui
The ContextMenu class provides control over the items in the Flash Player context menu.
ContextMenu() — Constructor in class flash.ui.ContextMenu
Creates a ContextMenu object.
ContextMenuBuiltInItems — Final class in package flash.ui
The ContextMenuBuiltInItems class describes the items that are built in to a context menu.
ContextMenuBuiltInItems() — Constructor in class flash.ui.ContextMenuBuiltInItems
Creates a new ContextMenuBuiltInItems object so that you can set the properties for Flash Player to display or hide each menu item.
ContextMenuEvent — Class in package flash.events
Flash® Player dispatches ContextMenuEvent objects when a user generates or interacts with the context menu.
ContextMenuEvent(type:String, bubbles:Boolean, cancelable:Boolean, mouseTarget:flash.display:InteractiveObject, contextMenuOwner:flash.display:InteractiveObject) — Constructor in class flash.events.ContextMenuEvent
Creates an Event object that contains specific information about menu events.
ContextMenuItem — Final class in package flash.ui
Use the ContextMenuItem class to create custom menu items to display in the Flash Player context menu.
ContextMenuItem(caption:String, separatorBefore:Boolean, enabled:Boolean, visible:Boolean) — Constructor in class flash.ui.ContextMenuItem
Creates a new ContextMenuItem object that can be added to the ContextMenu.customItems array.
contextMenuOwner — Property in class flash.events.ContextMenuEvent
The display list object to which the menu is attached.
continue — Statement
Jumps past all remaining statements in the innermost loop and starts the next iteration of the loop as if control had passed through to the end of the loop normally.
CONTROL — Constant static property in class flash.ui.Keyboard
Constant associated with the key code value for the Control key (17).
controlBar — Property in class mx.containers.Panel
A reference to this Panel container's control bar, if any.
controlBar — Property in class mx.core.Application
The ApplicationControlBar for this Application.
ControlBar — Class in package mx.containers
The ControlBar container lets you place controls at the bottom of a Panel or TitleWindow container.
ControlBar() — Constructor in class mx.containers.ControlBar
Constructor.
controlBarStyleName — Style in class mx.containers.Panel
Name of the CSS style declaration that specifies styles to apply to any control bar child subcontrol.
conversion — Property in class mx.controls.ProgressBar
Number used to convert incoming current bytes loaded value and the total bytes loaded values.
conversionMode — Static property in class flash.system.IME
The conversion mode of the current IME.
ConvolutionFilter — Class in package flash.filters
The ConvolutionFilter class applies a matrix convolution filter effect.
ConvolutionFilter(matrixX:Number, matrixY:Number, matrix:Array, divisor:Number, bias:Number, preserveAlpha:Boolean, clamp:Boolean, color:uint, alpha:Number) — Constructor in class flash.filters.ConvolutionFilter
Initializes a ConvolutionFilter instance with the specified parameters.
copy() — Method in class XML
Returns a copy of the given XML object.
copy() — Method in class XMLList
Returns a copy of the given XMLList object.
copy() — Method in class mx.collections.XMLListCollection
Returns a deep copy of the XMLList object.
copy(value:Object) — Static method in class mx.utils.ObjectUtil
Copies the specified Object and returns a reference to the copy.
COPY — Constant static property in class mx.managers.DragManager
Constant that specifies that the type of drag action is "copy".
copyChannel(sourceBitmapData:flash.display:BitmapData, sourceRect:flash.geom:Rectangle, destPoint:flash.geom:Point, sourceChannel:uint, destChannel:uint) — Method in class flash.display.BitmapData
Transfers data from one channel of another BitmapData object or the current BitmapData object into a channel of the current BitmapData object.
copyCursor — Style in class mx.managers.DragManager
Cursor displayed during a copy operation.
copyPixels(sourceBitmapData:flash.display:BitmapData, sourceRect:flash.geom:Rectangle, destPoint:flash.geom:Point, alphaBitmapData:flash.display:BitmapData, alphaPoint:flash.geom:Point, mergeAlpha:Boolean) — Method in class flash.display.BitmapData
Provides a fast routine to perform pixel manipulation between images with no stretching, rotation, or color effects.
copySelectedItems(useDataField:Boolean) — Method in class mx.controls.listClasses.ListBase
Makes a copy of the selected items in the order they were selected.
cornerRadius — Style in class mx.containers.Panel
Radius of corners of the window frame.
cornerRadius — Style in class mx.controls.Button
Radius of component corners.
cornerRadius — Style in class mx.controls.ComboBox
Radius of component corners.
cornerRadius — Style in class mx.controls.DateChooser
Radius of component corners.
cornerRadius — Style in class mx.controls.DateField
Radius of component corners.
cornerRadius — Style in class mx.controls.LinkButton
Corner radius of the highlighted rectangle around a LinkButton.
cornerRadius — Style in class mx.controls.MenuBar
Radius of component corners.
cornerRadius — Style in class mx.controls.NumericStepper
Radius of component corners.
cornerRadius — Style in class mx.controls.TextInput
Radius of component corners.
cornerRadius — Style in class mx.controls.ToolTip
Radius of component corners.
cornerRadius — Style in class mx.controls.VideoDisplay
Radius of component corners.
cornerRadius — Style in class mx.controls.scrollClasses.ScrollBar
Radius of component corners.
cornerRadius — Style in class mx.core.Container
Radius of component corners.
cornerRadius — Style in class mx.core.ScrollControlBase
Radius of component corners.
cornerRadius — Property in class mx.graphics.RoundedRectangle
The radius of each corner (in pixels).
correlation — Property in class mx.messaging.events.MessageAckEvent
The original Message correlated with this acknowledgement.
correlationId — Property in class mx.messaging.messages.AsyncMessage
Provides access to the correlation id of the message.
cos(angleRadians:Number) — Static method in class Math
Computes and returns the cosine of the specified angle in radians.
count — Property in class mx.charts.chartClasses.InstanceCache
The number of items currently required in the cache.
count — Property in interface mx.core.IRepeater
The number of times this Repeater should execute.
count — Property in class mx.core.Repeater
The number of times this Repeater should execute.
count(... rest) — Method in class mx.data.DataService
Calls a count method on the remote destination.
count(... rest) — Method in class mx.data.mxml.DataService
Calls a count method on the remote destination.
COUNT_OPERATION — Constant static property in class mx.data.messages.DataMessage
This operation requests that a configured <count-method> be invoked on a remote destination.
country — Property in class mx.resources.Locale
The country of current locale [Read-Only].
create(params:Object) — Method in class mx.managers.SystemManager
Entry point for creating the application.
CREATE_AND_SEQUENCE_OPERATION — Constant static property in class mx.data.messages.DataMessage
This operation requests a create of the specified item from a remote destination.
createBorder() — Method in class mx.controls.VideoDisplay
Creates the border for this component.
createBorder() — Method in class mx.core.Container
Creates the container's border skin if it is needed and does not already exist.
createBorder() — Method in class mx.core.ScrollControlBase
Creates the border for this component.
createBox(scaleX:Number, scaleY:Number, rotation:Number, tx:Number, ty:Number) — Method in class flash.geom.Matrix
Includes parameters for scaling, rotation, and translation.
createChildren() — Method in class mx.charts.chartClasses.ChartLabel
Create child objects of the component.
createChildren() — Method in class mx.charts.chartClasses.DataTip
Create child objects of the component.
createChildren() — Method in class mx.charts.series.PieSeries
createChildren() — Method in class mx.controls.listClasses.ListBase
Create objects that are children of this ListBase, in this case the listContent object that will hold all the item renderers.
createChildren() — Method in class mx.core.ScrollControlBase
Creates objects that are children of this ScrollControlBase, which in this case are the border and mask.
createChildren() — Method in class mx.core.UIComponent
Create child objects of the component.
createChildren() — Method in class mx.preloaders.DownloadProgressBar
Creates the subcomponents of the display.
createComponentFromDescriptor(descriptor:mx.core:ComponentDescriptor, recurse:Boolean) — Method in class mx.core.Container
Given a single UIComponentDescriptor, create the corresponding component and add the component as a child of this Container.
createComponentsFromDescriptors(recurse:Boolean) — Method in class mx.core.Container
Iterate through the Array of childDescriptors, and call the createComponentFromDescriptor() method for each one.
createCursor() — Method in interface mx.collections.ICollectionView
Creates a new IViewCursor that works with this view.
createCursor() — Method in class mx.collections.ListCollectionView
Creates a new IViewCursor that works with this view.
createDataID(dataPointID:Number) — Method in class mx.charts.chartClasses.ChartElement
Creates a unique id to represent the a dataPoint for comparison purposes.
createElement(name:String) — Method in class flash.xml.XMLDocument
Creates a new XMLNode object with the name specified in the parameter.
createErrorMessage() — Method in class mx.messaging.events.ChannelFaultEvent
Creates an ErrorMessage based on the ChannelFaultEvent by copying over the faultCode, faultString, faultDetail and rootCause to the new ErrorMessage.
createEvent(c:mx.data:Conflict) — Static method in class mx.data.events.DataConflictEvent
createEvent(fault:mx.rpc:Fault, token:mx.rpc:AsyncToken, message:mx.messaging.messages:ErrorMessage, obj:Object, id:Object) — Static method in class mx.data.events.DataServiceFaultEvent
createEvent(type:String, channel:mx.messaging:Channel, reconnecting:Boolean, rejected:Boolean) — Static method in class mx.messaging.events.ChannelEvent
Utility method to create a new ChannelEvent that doesn't bubble and is not cancelable.
createEvent(channel:mx.messaging:Channel, reconnecting:Boolean, code:String, level:String, description:String) — Static method in class mx.messaging.events.ChannelFaultEvent
Utility method to create a new ChannelFaultEvent that doesn't bubble and is not cancelable.
createEvent(ack:mx.messaging.messages:AcknowledgeMessage, correlation:mx.messaging.messages:IMessage) — Static method in class mx.messaging.events.MessageAckEvent
Utility method to create a new MessageAckEvent that doesn't bubble and is not cancelable.
createEvent(type:String, msg:mx.messaging.messages:IMessage) — Static method in class mx.messaging.events.MessageEvent
Utility method to create a new MessageEvent that doesn't bubble and is not cancelable.
createEvent(msg:mx.messaging.messages:ErrorMessage) — Static method in class mx.messaging.events.MessageFaultEvent
Utility method to create a new MessageFaultEvent that doesn't bubble and is not cancelable.
createEvent(fault:mx.rpc:Fault, token:mx.rpc:AsyncToken, msg:mx.messaging.messages:IMessage) — Static method in class mx.rpc.events.FaultEvent
Given a Fault, this method constructs and returns a FaultEvent.
createEvent(header:Object, token:mx.rpc:AsyncToken, message:mx.messaging.messages:IMessage) — Static method in class mx.rpc.events.HeaderEvent
createEventFromMessageFault(value:mx.messaging.events:MessageFaultEvent, token:mx.rpc:AsyncToken) — Static method in class mx.rpc.events.FaultEvent
Given a MessageFaultEvent, this method constructs and returns a FaultEvent.
createFaultEvent(faultCode:String, faultString:String, faultDetail:String) — Method in class mx.rpc.soap.Operation
createGradientBox(width:Number, height:Number, rotation:Number, tx:Number, ty:Number) — Method in class flash.geom.Matrix
Creates the specific style of matrix expected by the beginGradientFill() and lineGradientStyle() methods of the Graphics class.
createInstance(target:Object) — Method in class mx.effects.Effect
Creates a single effect instance and initializes it.
createInstance() — Method in class mx.states.AddChild
Creates the child instance from the factory.
createInstances(targets:Array) — Method in class mx.effects.Effect
Takes an Array of target objects and invokes the createInstance() method on each target.
createItem(item:Object) — Method in class mx.data.DataService
Requests that the specified item be created in the remote store.
createItem(item:Object) — Method in class mx.data.mxml.DataService
Requests that the specified item be created in the remote store.
createItemEditor(colIndex:int, rowIndex:int) — Method in class mx.controls.DataGrid
Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.
createItemEditor(colIndex:int, rowIndex:int) — Method in class mx.controls.List
Creates the item editor for the item renderer at the editedItemPosition using the editor specified by the itemEditor property.
createMaskFunction — Property in class mx.effects.MaskEffect
Function called when the effect creates the mask.
createMaskFunction — Property in class mx.effects.effectClasses.MaskEffectInstance
Function called when the effect creates the mask.
createMenu(parent:flash.display:DisplayObjectContainer, mdp:Object, showRoot:Boolean) — Static method in class mx.controls.Menu
Creates and returns an instance of the Menu class.
createNavItem(label:String, icon:Class) — Method in class mx.controls.NavBar
Creates the individual navigator items.
CREATE_OPERATION — Constant static property in class mx.data.messages.DataMessage
Indicates a create operation.
createPopUp(parent:flash.display:DisplayObject, className:Class, modal:Boolean, childList:String) — Static method in class mx.managers.PopUpManager
Creates a top-level window and places it above other windows in the z-order.
createReferenceOnParentDocument(parentDocument:mx.core:IFlexDisplayObject) — Method in interface mx.core.IDeferredInstantiationUIComponent
Creates an id reference to this IUIComponent object on its parent document object.
createReferenceOnParentDocument(parentDocument:mx.core:IFlexDisplayObject) — Method in class mx.core.UIComponent
Creates an id reference to this IUIComponent object on its parent document object.
createRequestTimeoutErrorMessage() — Method in class mx.messaging.MessageResponder
Constructs an ErrorMessage that can be passed to the associated MessageAgent's callbacks upon a request timeout.
createTextNode(text:String) — Method in class flash.xml.XMLDocument
Creates a new XML text node with the specified text.
createToolTip(text:String, x:Number, y:Number, errorTipBorderStyle:String, context:mx.core:IUIComponent) — Static method in class mx.managers.ToolTipManager
Creates an instance of the ToolTip class with the specified text and displays it at the specified location in stage coordinates.
createTween(listener:Object, startValue:Object, endValue:Object, duration:Number, minFps:Number) — Method in class mx.effects.effectClasses.TweenEffectInstance
Creates a Tween instance, assigns it the start, end, and duration values.
createUID() — Static method in class mx.utils.UIDUtil
Generates a UID (unique identifier) based on ActionScript's pseudo-random number generator and the current time.
createUniqueName(object:Object) — Static method in class mx.utils.NameUtil
Creates a unique name for any Object instance, such as "Button12", by combining the unqualified class name with an incrementing counter.
createUpdateEvent(obj:mx.data:IManaged, property:Object, event:mx.events:PropertyChangeEvent) — Static method in class mx.data.utils.Managed
createUpdateEvent(source:Object, property:Object, oldValue:Object, newValue:Object) — Static method in class mx.events.PropertyChangeEvent
Returns a new PropertyChangeEvent of kind PropertyChangeEventKind.UPDATE with the specified properties.
createXMLDocument(str:String) — Static method in class mx.utils.XMLUtil
Creates XML out of the specified string, ignoring whitespace.
creationCallback — Property in class mx.charts.chartClasses.InstanceCache
A callback invoked when new instances are created.
creationComplete — Event in class mx.core.UIComponent
Dispatched when the component has finished its construction, property processing, measuring, layout, and drawing.
CREATION_COMPLETE — Constant static property in class mx.events.FlexEvent
The FlexEvent.CREATION_COMPLETE constant defines the value of the type property of the event object for a creationComplete event.
creationCompleteEffect — Effect in class mx.core.UIComponent
Played when the omponent is created.
creationDate — Property in class flash.net.FileReference
The creation date of the file on the local disk.
creationIndex — Property in class mx.core.Container
Specifies the order to instantiate and draw the children of the container.
creationPolicy — Property in class mx.core.Container
The child creation policy for this Container.
creationPolicy — Property in class mx.states.AddChild
The creation policy for this child.
creator — Property in class flash.net.FileReference
The Macintosh creator type of the file.
CreditCardValidator — Class in package mx.validators
The CreditCardValidator class validates that a credit card number is the correct length, has the correct prefix, and passes the Luhn mod10 algorithm for the specified card type.
CreditCardValidator() — Constructor in class mx.validators.CreditCardValidator
Constructor.
CreditCardValidatorCardType — Final class in package mx.validators
The CreditCardValidatorCardType class defines value constants for specifying the type of credit card to validate.
CrossItemRenderer — Class in package mx.charts.renderers
A simple chart itemRenderer implementation that fills a cross in its assigned area.
CrossItemRenderer() — Constructor in class mx.charts.renderers.CrossItemRenderer
Constructor
CRT — Constant static property in class flash.text.TextDisplayMode
Forces Flash Player to display grayscale anti-aliasing.
CSMSettings — Final class in package flash.text
The CSMSettings class contains properties for use with the TextRenderer.setAdvancedAntiAliasingTable() method to provide continuous stroke modulation (CSM).
CSMSettings(fontSize:Number, insideCutoff:Number, outsideCutoff:Number) — Constructor in class flash.text.CSMSettings
Creates a new CSMSettings object which stores stroke values for custom anti-aliasing settings.
CSSStyleDeclaration — Class in package mx.styles
The CSSStyleDeclaration class represents a set of CSS style rules.
CSSStyleDeclaration(selector:String) — Constructor in class mx.styles.CSSStyleDeclaration
Constructor.
ctrlKey — Property in class flash.events.KeyboardEvent
Indicates whether the Control key is active (true) or inactive (false).
ctrlKey — Property in class flash.events.MouseEvent
Indicates whether the Control key is active (true) or inactive (false).
Cubic — Class in package mx.effects.easing
The Cubic class defines three easing functions to implement motion with Flex effect classes.
cuePoint — Event in class mx.controls.VideoDisplay
Dispatched when the value of a cue point's time property is equal to the current playhead location.
CUE_POINT — Constant static property in class mx.events.CuePointEvent
The CuePointEvent.CUE_POINT constant defines the value of the type property of the event object for a cuePoint event.
CuePointEvent — Class in package mx.events
The CuePointEvent class represents the event object passed to the event listener for cue point events dispatched by the VideoDisplay control.
CuePointEvent(type:String, bubbles:Boolean, cancelable:Boolean, cuePointName:String, cuePointTime:Number, cuePointType:String) — Constructor in class mx.events.CuePointEvent
Constructor.
cuePointManager — Property in class mx.controls.VideoDisplay
The instance of the CuePointManager class associated with the VideoPlayer control.
CuePointManager — Class in package mx.controls.videoClasses
The CuePointManager class lets you use ActionScript code to manage the cue points associated with the VideoDisplay control.
CuePointManager(owner, id:uint) — Constructor in class mx.controls.videoClasses.CuePointManager
Constructor.
cuePointManagerClass — Property in class mx.controls.VideoDisplay
Cue point manager to use.
cuePointName — Property in class mx.events.CuePointEvent
The name of the cue point that caused the event.
cuePoints — Property in class mx.controls.VideoDisplay
The Array of cue points associated with the control.
cuePointTime — Property in class mx.events.CuePointEvent
The time of the cue point that caused the event, in seconds.
cuePointType — Property in class mx.events.CuePointEvent
The string "actionscript".
CurrencyFormatter — Class in package mx.formatters
The CurrencyFormatter class formats a valid number as a currency value.
CurrencyFormatter() — Constructor in class mx.formatters.CurrencyFormatter
Constructor.
currencySymbol — Property in class mx.formatters.CurrencyFormatter
Character to use as a currency symbol for a formatted number.
currencySymbol — Property in class mx.validators.CurrencyValidator
The single-character String used to specify the currency symbol, such as "$" or "£".
currencySymbolError — Property in class mx.validators.CurrencyValidator
Error message when the currency symbol, defined by currencySymbol, is in the wrong location.
CurrencyValidator — Class in package mx.validators
The CurrencyValidator class ensures that a String represents a valid currency expression.
CurrencyValidator() — Constructor in class mx.validators.CurrencyValidator
Constructor.
CurrencyValidatorAlignSymbol — Final class in package mx.validators
The CurrencyValidatorAlignSymbol class defines value constants for specifying currency symbol alignment.
current — Property in interface mx.collections.IViewCursor
Provides access the object at the location in the source collection referenced by this cursor.
CURRENT — Static property in class mx.collections.CursorBookmark
A bookmark representing the current item for the IViewCursor in an ICollectionView.
currentCount — Property in class flash.utils.Timer
The total number of times the timer has fired since it started at zero.
currentCursorID — Static property in class mx.managers.CursorManager
ID of the current custom cursor, or NO_CURSOR if the system cursor is showing.
currentCursorXOffset — Static property in class mx.managers.CursorManager
The x offset of the custom cursor, in pixels, relative to the mouse pointer.
currentCursorYOffset — Static property in class mx.managers.CursorManager
The y offset of the custom cursor, in pixels, relative to the mouse pointer.
currentDomain — Static property in class flash.system.ApplicationDomain
Gets the current application domain in which your code is executing.
currentDomain — Static property in class flash.system.SecurityDomain
Gets the current security domain.
currentFPS — Property in class flash.media.Camera
The rate at which the camera is capturing data, in frames per second.
currentFPS — Property in class flash.net.NetStream
The number of frames per second being displayed.
currentFrame — Property in class flash.display.MovieClip
Specifies the number of the frame in which the playhead is located in the timeline of the MovieClip instance.
currentIndex — Property in interface mx.core.IRepeater
The index of the item in the dataProvider currently being processed while this Repeater is executing.
currentIndex — Property in class mx.core.Repeater
The index of the item in the dataProvider currently being processed while this Repeater is executing.
currentItem — Property in interface mx.core.IRepeater
The item in the dataProvider currently being processed while this Repeater is executing.
currentItem — Property in class mx.core.Repeater
The item in the dataProvider currently being processed while this Repeater is executing.
currentLabel — Property in class flash.display.MovieClip
The current label in which the playhead is located in the timeline of the MovieClip instance.
currentLabels — Property in class flash.display.MovieClip
Returns an array of FrameLabel objects from the current scene.
currentPageHeight — Property in class mx.printing.PrintDataGrid
The height of PrintDataGrid that would be, if sizeToPage property is true and PrintDataGrid displays only completely viewable rows and no partial rows.
currentScene — Property in class flash.display.MovieClip
The current scene in which the playhead is located in the timeline of the MovieClip instance.
currentState — Property in class mx.core.UIComponent
The current view state of the component.
currentStateChange — Event in class mx.core.UIComponent
Dispatched after the view state has changed.
CURRENT_STATE_CHANGE — Constant static property in class mx.events.StateChangeEvent
The StateChangeEvent.CURRENT_STATE_CHANGE constant defines the value of the type property of the event that is dispatched when the view state has changed.
currentStateChanging — Event in class mx.core.UIComponent
Dispatched after the currentState property changes, but before the view state changes.
CURRENT_STATE_CHANGING — Constant static property in class mx.events.StateChangeEvent
The StateChangeEvent.CURRENT_STATE_CHANGING constant defines the value of the type property of the event that is dispatched when the view state is about to change.
currentTarget — Property in class flash.events.Event
The object that is actively processing the Event object with an event listener.
currentTarget — Static property in class mx.managers.ToolTipManager
The UIComponent that is currently displaying a ToolTip, or null if none is.
currentToolTip — Static property in class mx.managers.ToolTipManager
The ToolTip object that is currently visible, or null if none is shown.
currentVersion — Property in interface mx.data.IChangeObject
New version of the item.
cursor — Property in class mx.charts.chartClasses.ChartElement
Each ChartElement carries a cursor associated with their dataProvider for their own internal use.
CursorBookmark — Class in package mx.collections
Encapsulates the positional aspects of a cursor in an ICollectionView.
CursorBookmark(value:Object) — Constructor in class mx.collections.CursorBookmark
Creates a new instance of a bookmark with the specified value.
cursorChildren — Property in interface mx.managers.ISystemManager
An list of the custom cursors being parented by this ISystemManager.
cursorChildren — Property in class mx.managers.SystemManager
An list of the custom cursors being parented by this ISystemManager.
CursorError — Class in package mx.collections.errors
This error is thrown by a collection Cursor.
CursorError(message:String) — Constructor in class mx.collections.errors.CursorError
Constructor.
CURSOR_MANAGEMENT — Constant static property in class mx.core.EventPriority
The CursorManager has handlers for mouse events which must be executed before other mouse event handlers, so they have a high priority.
CursorManager — Class in package mx.managers
The CursorManager class controls a prioritized list of cursors, where the cursor with the highest priority is currently visible.
CursorManagerPriority — Final class in package mx.managers
The CursorManagerPriority class defines the constant values for the priority argument to the CursorManager.setCursor() method.
cursorUpdate — Event in interface mx.collections.IViewCursor
Dispatched whenever the cursor position is updated.
CURSOR_UPDATE — Constant static property in class mx.events.FlexEvent
The FlexEvent.CURSOR_UPDATE constant defines the value of the type property of the event object for a cursorUpdate event.
curveTo(controlX:Number, controlY:Number, anchorX:Number, anchorY:Number) — Method in class flash.display.Graphics
Draws a curve using the current line style from the current drawing position to (anchorX, anchorY) and using the control point that (controlX, controlY) specifies.
customFilter — Property in class mx.effects.Effect
Specifies a custom filter object, of type EffectTargetFilter, used by the effect to determine the targets on which to play the effect.
customItems — Property in class flash.ui.ContextMenu
An array of ContextMenuItem objects.
customizeSeries(seriesGlyph:mx.charts.chartClasses:Series, i:uint) — Method in class mx.charts.chartClasses.ChartBase
Applies per-series customization and formatting to the series of the chart.
customizeSeries(g:mx.charts.chartClasses:IChartElement, i:uint) — Method in class mx.charts.chartClasses.StackedSeries
Applies any customization to a sub-series when building the stacking behavior.
customizeSeries(g:mx.charts.chartClasses:IChartElement, i:uint) — Method in class mx.charts.series.ColumnSet
Applies any customization to a sub-series when building the stacking behavior.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


D Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
D Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
d — Property in class flash.geom.Matrix
 | The value in the second row and second column of the Matrix object, which affects the positioning of pixels along the y axis when scaling or rotating an image.
DARK_COLOR — Constant static property in class flash.text.TextColorType
 | Used in the colorType parameter in the setAdvancedAntiAliasingTable() method.
DARKEN — Constant static property in class flash.display.BlendMode
 | Selects the darker of the constituent colors of the display object and the colors of the background (the colors with the smaller values).
data — Property in class flash.events.DataEvent
 | The raw data loaded into Flash Player.
data — Property in class flash.net.SharedObject
 | The collection of attributes assigned to the data property of the object; these attributes can be shared and stored.
data — Property in class flash.net.URLLoader
 | The data received from the load operation.
data — Property in class flash.net.URLRequest
 | An object containing data to be transmitted with the URL request.
data — Event in class flash.net.XMLSocket
 | Dispatched after raw data is sent or received.
data — Property in class mx.charts.chartClasses.ChartLabel
 | Defines the contents of the label.
data — Property in class mx.charts.chartClasses.DataTip
 | The HitData structure describing the data point that the DataTip is rendering.
data — Property in class mx.charts.renderers.AreaRenderer
 | The data that the AreaRenderer renders.
data — Property in class mx.charts.renderers.BoxItemRenderer
 | The chartItem that this itemRenderer is displaying.
data — Property in class mx.charts.renderers.CandlestickItemRenderer
 | The chart item that this renderer represents.
data — Property in class mx.charts.renderers.CircleItemRenderer
 | The chartItem that this itemRenderer displays.
data — Property in class mx.charts.renderers.HLOCItemRenderer
 | The chart item that this renderer represents.
data — Property in class mx.charts.renderers.LineRenderer
 | The chart item that this renderer represents.
data — Property in class mx.charts.renderers.ShadowLineRenderer
 | The chart item that this renderer represents.
data — Property in class mx.charts.renderers.WedgeItemRenderer
 | The chart item that this renderer represents.
data — Property in class mx.containers.accordionClasses.AccordionHeader
 | Stores a reference to the content associated with the header.
data — Property in class mx.controls.Button
 | The data property lets you pass a value to the component when you use it as an item renderer or item editor.
data — Property in class mx.controls.ComboBox
 | The data property lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in class mx.controls.DateField
 | The data property lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in class mx.controls.Image
 | The data property lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in class mx.controls.Label
 | Lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in class mx.controls.NumericStepper
 | The data property lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in class mx.controls.TextArea
 | Lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in class mx.controls.TextInput
 | Lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in class mx.controls.dataGridClasses.DataGridItemRenderer
 | The implementation of the data property as defined by the IDataRenderer interface.
data — Property in class mx.controls.listClasses.ListBase
 | The item in the data provider this component should render when this component is used as an item renderer or item editor.
data — Property in class mx.controls.listClasses.ListBaseSelectionData
 | The data Object that is selected (selectedItem)
data — Property in class mx.controls.listClasses.ListItemRenderer
 | The implementation of the data property as defined by the IDataRenderer interface.
data — Property in class mx.controls.listClasses.ListRowInfo
 | The item in the dataprovider.
data — Property in class mx.controls.listClasses.TileListItemRenderer
 | The implementation of the data property as defined by the IDataRenderer interface.
data — Property in class mx.controls.menuClasses.MenuBarItem
 | The data property of the IListItemRenderer interface has no purpose in the MenuBarItem class.
data — Property in class mx.controls.menuClasses.MenuItemRenderer
 | The implementation of the data property as defined by the IDataRenderer interface.
data — Property in class mx.controls.treeClasses.TreeItemRenderer
 | The implementation of the data property as defined by the IDataRenderer interface.
data — Property in class mx.core.Container
 | The data property lets you pass a value to the component when you use it in an item renderer or item editor.
data — Property in interface mx.core.IDataRenderer
 | The data to render or edit.
DATA — Constant static property in class flash.events.DataEvent
 | Defines the value of the type property of a data event object.
DataAssociationMessage — Class in package mx.data.messages
 | This message is used to add and remove associations between objects managed by different data services.
DataAssociationMessage() — Constructor in class mx.data.messages.DataAssociationMessage
 | Creates a new instance of an empty association message.
dataChange — Event in class mx.controls.Button
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.ComboBox
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.DateField
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.Image
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.Label
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.NumericStepper
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.TextArea
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.TextInput
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.dataGridClasses.DataGridItemRenderer
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.listClasses.ListBase
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.listClasses.ListItemRenderer
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.listClasses.TileListItemRenderer
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.menuClasses.MenuItemRenderer
 | Dispatched when the data property changes.
dataChange — Event in class mx.controls.treeClasses.TreeItemRenderer
 | Dispatched when the data property changes.
dataChange — Event in class mx.core.Container
 | Dispatched when the data property changes.
DATA_CHANGE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.DATA_CHANGE constant defines the value of the type property of the event object for a dataChange event.
dataChanged() — Method in class mx.charts.chartClasses.AxisBase
 | Triggers events that inform the range object when the chart data has changed.
dataChanged() — Method in class mx.charts.chartClasses.ChartElement
 | Indicates the underlying data represented by the element has changed.
dataChanged() — Method in class mx.charts.chartClasses.DataTransform
 | Informs the DataTransform that some of the underlying data being represented on the chart has changed.
dataChanged() — Method in interface mx.charts.chartClasses.IAxis
 | Triggers events that inform the range object when the chart data has changed.
DataConflictEvent — Class in package mx.data.events
 | This event informs users of a DataService instance that a conflict has occured.
DataConflictEvent(type:String, bubbles:Boolean, cancelable:Boolean, c:mx.data:Conflict) — Constructor in class mx.data.events.DataConflictEvent
DataDescription — Class in package mx.charts.chartClasses
 | The DataDescription structure is used by ChartElements to describe the characteristics of the data they represent to Axis objects that auto-generate values from the data represented in the chart.
DataDescription() — Constructor in class mx.charts.chartClasses.DataDescription
 | Constructor.
dataDescriptions — Property in class mx.charts.chartClasses.NumericAxis
 | An Array of DataDescription structures describing the data being represented by the chart.
dataDescriptor — Property in class mx.controls.Menu
 | The object that accesses and manipulates data in the data provider.
dataDescriptor — Property in class mx.controls.MenuBar
 | The object that accesses and manipulates data in the data provider.
dataDescriptor — Property in class mx.controls.PopUpMenuButton
 | The data descriptor accesses and manipulates data in the data provider.
dataDescriptor — Property in class mx.controls.Tree
 | Tree delegates to the data descriptor for information about the data.
DataErrorMessage — Class in package mx.data.messages
 | Special cases of ErrorMessage will be sent when a data conflict occurs.
DataErrorMessage() — Constructor in class mx.data.messages.DataErrorMessage
 | Constructs an instance of a DataErrorMessage.
DataEvent — Class in package flash.events
 | Flash® Player dispatches DataEvent objects when raw data has completed loading into Flash Player.
DataEvent(type:String, bubbles:Boolean, cancelable:Boolean, data:String) — Constructor in class flash.events.DataEvent
 | Creates an event object that contains information about data events.
dataField — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The name of the field or property in the data provider item associated with the column.
dataField — Property in class mx.controls.dataGridClasses.DataGridListData
 | Name of the field or property in the data provider associated with the column.
dataField — Property in class mx.events.DataGridEvent
 | The name of the field or property in the data associated with the column.
dataForFormat(format:String) — Method in class mx.core.DragSource
 | Retrieves the data for the specified format.
dataFormat — Property in class flash.net.URLLoader
 | Controls whether the downloaded data is received as text (URLLoaderDataFormat.TEXT), raw binary data (URLLoaderDataFormat.BINARY), or URL-encoded variables (URLLoaderDataFormat.VARIABLES).
DataGrid — Class in package mx.controls
 | The DataGrid control is a like a List except that it can show more than one column of data making it suited for showing objects with multiple properties.
DataGrid() — Constructor in class mx.controls.DataGrid
 | Constructor.
DataGridBase — Class in package mx.controls.dataGridClasses
 | The DataGridBase class is the base class for controls that display lists of items in multiple columns.
DataGridBase() — Constructor in class mx.controls.dataGridClasses.DataGridBase
 | Constructor.
DataGridColumn — Class in package mx.controls.dataGridClasses
 | The DataGridColumn class describes a column in a DataGrid control.
DataGridColumn(columnName:String) — Constructor in class mx.controls.dataGridClasses.DataGridColumn
 | Constructor.
DataGridColumnDropIndicator — Class in package mx.skins.halo
 | The skin for the column drop indicator in a DataGrid.
DataGridColumnDropIndicator() — Constructor in class mx.skins.halo.DataGridColumnDropIndicator
 | Constructor.
DataGridColumnResizeSkin — Class in package mx.skins.halo
 | The skin for the column resizer in a DataGrid.
DataGridColumnResizeSkin() — Constructor in class mx.skins.halo.DataGridColumnResizeSkin
 | Constructor.
DataGridDragProxy — Class in package mx.controls.dataGridClasses
 | The DataGridDragProxy class defines the default drag proxy used when dragging data from a DataGrid control.
DataGridDragProxy() — Constructor in class mx.controls.dataGridClasses.DataGridDragProxy
 | Constructor.
DataGridEvent — Class in package mx.events
 | The DataGridEvent class represents event objects that are specific to the DataGrid control, such as the event that is dispatched when an editable grid item gets the focus.
DataGridEvent(type:String, bubbles:Boolean, cancelable:Boolean, columnIndex:int, dataField:String, rowIndex:int, reason:String, itemRenderer:mx.controls.listClasses:IListItemRenderer, localX:Number) — Constructor in class mx.events.DataGridEvent
 | Constructor.
DataGridEventReason — Final class in package mx.events
 | The DataGridEventReason class defines constants for the values of the reason property of a DataGridEvent object when the type property is itemEditEnd.
DataGridHeaderSeparator — Class in package mx.skins.halo
 | The skin for the separator between column headers in a DataGrid.
DataGridHeaderSeparator() — Constructor in class mx.skins.halo.DataGridHeaderSeparator
 | Constructor.
DataGridItemRenderer — Class in package mx.controls.dataGridClasses
 | The DataGridItemRenderer class defines the default item renderer for a DataGrid control.
DataGridItemRenderer() — Constructor in class mx.controls.dataGridClasses.DataGridItemRenderer
 | Constructor.
DataGridListData — Class in package mx.controls.dataGridClasses
 | The DataGridListData class defines the data type of the listData property that is implemented by drop-in item renderers or drop-in item editors for the DataGrid control.
DataGridListData(text:String, dataField:String, columnIndex:int, uid:String, owner:mx.core:IUIComponent, rowIndex:int) — Constructor in class mx.controls.dataGridClasses.DataGridListData
 | Constructor.
DataGridSortArrow — Class in package mx.skins.halo
 | The skin for the sort arrow in a column header in a DataGrid.
DataGridSortArrow() — Constructor in class mx.skins.halo.DataGridSortArrow
 | Constructor.
dataInterval — Property in class mx.charts.DateTimeAxis
 | Specifies the interval between data in your chart, specified in dataUnits.
DataListError — Class in package mx.data.errors
 | This error is thrown when an unanticipated problem occurs in a DataList.
DataListError(msg:String) — Constructor in class mx.data.errors.DataListError
 | Constructs a new instance of the error with the specified message.
DataMessage — Class in package mx.data.messages
 | This message is used to transport an operation that occured on a managed object or collection.
DataMessage() — Constructor in class mx.data.messages.DataMessage
 | Creates a new instance of an empty DataMessage.
dataProvider — Property in class mx.charts.CategoryAxis
 | Specifies the data source containing the label names.
dataProvider — Property in class mx.charts.Legend
 | Set of data to be used in the Legend.
dataProvider — Property in class mx.charts.chartClasses.ChartBase
 | Specifies the data provider for the chart.
dataProvider — Property in class mx.charts.chartClasses.ChartElement
 | A data provider assigned to the this specific element.
dataProvider — Property in class mx.controls.ComboBase
 | The set of items this component displays.
dataProvider — Property in class mx.controls.ComboBox
 | The set of items this component displays.
dataProvider — Property in class mx.controls.MenuBar
 | The hierarchy of objects that are displayed as MenuBar items and menus.
dataProvider — Property in class mx.controls.NavBar
 | Data used to populate the navigator control.
dataProvider — Property in class mx.controls.PopUpMenuButton
 | DataProvider for popUpMenu.
dataProvider — Property in class mx.controls.Tree
 | An object that contains the data to be displayed.
dataProvider — Property in class mx.controls.listClasses.ListBase
 | Set of data to be viewed.
dataProvider — Property in class mx.controls.menuClasses.MenuBarItem
 | The object that provides the data for the Menu that is popped up when this MenuBarItem is selected.
dataProvider — Property in interface mx.core.IRepeater
 | The data provider used by this Repeater to create repeated instances of its children.
dataProvider — Property in class mx.core.Repeater
 | The data provider used by this Repeater to create repeated instances of its children.
dataRegion — Property in class mx.charts.chartClasses.CartesianChart
 | The area of the chart used to display data.
dataRegion — Property in class mx.charts.chartClasses.ChartBase
 | The area of the chart used to display data.
dataRegion — Property in class mx.charts.chartClasses.PolarChart
 | The area of the chart used to display data.
DataService — Class in package mx.data
 | The DataService class provides the top-level functionality for Data Management Services in Flex 2.
DataService — Class in package mx.data.mxml
 | The DataService class provides the top-level functionality for distributed data in Flex 2.
DataService(destination:String) — Constructor in class mx.data.DataService
 | Constructs an instance of the DataService with the specified destination.
DataService(dest:String) — Constructor in class mx.data.mxml.DataService
 | Constructs an instance of the DataService with the specified destination.
DataServiceError — Class in package mx.data.errors
 | This error is thrown when a an unanticipated problem occurs in a DataService component.
DataServiceError(msg:String) — Constructor in class mx.data.errors.DataServiceError
 | Constructs a new instance of the error with the specified message.
DataServiceFaultEvent — Class in package mx.data.events
 | This event is sent when a DataService or DataStore has generated a fault.
DataServiceFaultEvent(type:String, bubbles:Boolean, cancelable:Boolean, fault:mx.rpc:Fault, token:mx.rpc:AsyncToken, message:mx.messaging.messages:ErrorMessage, obj:Object, id:Object) — Constructor in class mx.data.events.DataServiceFaultEvent
dataStore — Property in class mx.data.DataService
 | Returns an object of type mx.data.DataStore.
dataStore — Property in class mx.data.mxml.DataService
 | Returns an object of type mx.data.DataStore.
DataStore — Class in package mx.data
 | A DataStore batches transactions for one or more DataService instances.
DataStore(destination:String, useTransactions:Boolean) — Constructor in class mx.data.DataStore
 | Normally, a DataStore is created automatically for you but you can create your own DataStore and assign it to the dataStore property of a DataService.
DataTip — Class in package mx.charts.chartClasses
 | The DataTip control provides information about a data point to chart users.
DataTip() — Constructor in class mx.charts.chartClasses.DataTip
 | Constructor.
dataTipCalloutStroke — Style in class mx.charts.chartClasses.ChartBase
 | The Stroke to use to render the callout line from the data tip target to the tip.
dataTipField — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The name of the field in the data provider to display as the datatip.
dataTipField — Property in class mx.controls.listClasses.ListBase
 | Name of the field in the data provider items to display as the data tip.
dataTipFormatFunction — Property in class mx.controls.sliderClasses.Slider
 | Callback function that formats the data tip text.
dataTipFunction — Property in class mx.charts.HitData
 | A function provided by the HitData creator to generate a user-suitable String for display on screen that describes the referenced item.
dataTipFunction — Property in class mx.charts.chartClasses.ChartBase
 | Specifies a callback method used to generate DataTips from values.
dataTipFunction — Property in class mx.controls.dataGridClasses.DataGridColumn
 | Specifies a callback function to run on each item of the data provider to determine its dataTip.
dataTipFunction — Property in class mx.controls.listClasses.ListBase
 | User-supplied function to run on each item to determine its dataTip.
dataTipLayerIndex — Property in class mx.charts.chartClasses.ChartBase
 | The index of the child that is responsible for rendering DataTips.
dataTipMode — Property in class mx.charts.chartClasses.ChartBase
 | Specifies how Flex displays DataTip controls for the chart.
dataTipOffset — Style in class mx.controls.sliderClasses.Slider
 | The offset, in pixels, of the data tip relative to the thumb.
dataTipPlacement — Style in class mx.controls.HSlider
 | The location of the data tip relative to the thumb.
dataTipPlacement — Style in class mx.controls.VSlider
 | The location of the data tip relative to the thumb.
dataTipPrecision — Style in class mx.controls.sliderClasses.Slider
 | Number of decimal places to use for the data tip text.
dataTipRenderer — Style in class mx.charts.chartClasses.ChartBase
 | Specifies the class to use to render data tips.
dataTipStyleName — Style in class mx.controls.sliderClasses.Slider
 | The name of the style declaration to use for the data tip.
dataToLocal(... rest) — Method in class mx.charts.chartClasses.CartesianChart
 | Converts a tuple of data values to an x-y coordinate on screen.
dataToLocal(... rest) — Method in class mx.charts.chartClasses.ChartBase
 | Converts a tuple of data values to an x-y coordinate on screen.
dataToLocal(... rest) — Method in class mx.charts.chartClasses.PolarChart
 | Converts a tuple of data values to an x-y coordinate on screen.
dataTransform — Property in class mx.charts.chartClasses.ChartElement
 | The data dataTransform the element is associated with.
dataTransform — Property in interface mx.charts.chartClasses.IChartElement
 | The DataTransform object that the element uses to map between data and screen coordinates.
dataTransform — Property in class mx.charts.chartClasses.Series
 | The data dataTransform the element is associated with.
DataTransform — Class in package mx.charts.chartClasses
 | The DataTransform object represents a portion of a chart that contains glyphs and can transform values to screen coordinates and vice versa.
DataTransform() — Constructor in class mx.charts.chartClasses.DataTransform
 | Constructor.
dataUnits — Property in class mx.charts.DateTimeAxis
 | Specifies the units that you expect the data in your chart to represent.
date — Property in class Date
 | The day of the month (an integer from 1 to 31) specified by a Date object according to local time.
Date — Final dynamic class in Top Level
 | The Date class represents date and time information.
Date(yearOrTimevalue:Object, month:Number, date:Number, hour:Number, minute:Number, second:Number, millisecond:Number) — Constructor in class Date
 | Constructs a new Date object that holds the specified date and time.
DateBase — Class in package mx.formatters
 | The DateBase class contains the localized string information used by the mx.formatters.DateFormatter class and the parsing function that renders the pattern.
DateChooser — Class in package mx.controls
 | The DateChooser control displays the name of a month, the year, and a grid of the days of the month, with columns labeled for the day of the week.
DateChooser() — Constructor in class mx.controls.DateChooser
 | Constructor.
DateChooserEvent — Class in package mx.events
 | The DateChooserEvent class represents the event object passed to the event listener for the scroll event for the DateChooser and DateField controls.
DateChooserEvent(type:String, bubbles:Boolean, cancelable:Boolean, detail:String, triggerEvent:flash.events:Event) — Constructor in class mx.events.DateChooserEvent
 | Constructor.
DateChooserEventDetail — Final class in package mx.events
 | Constants that define the values of the detail property of a DateChooserEvent object.
DateChooserIndicator — Class in package mx.skins.halo
 | The skins of the DateChooser's indicators for displaying today, rollover and selected dates.
DateChooserIndicator() — Constructor in class mx.skins.halo.DateChooserIndicator
 | Constructor
DateChooserMonthArrowSkin — Class in package mx.skins.halo
 | The skin for all the states of the next-month and previous-month buttons in a DateChooser.
DateChooserMonthArrowSkin() — Constructor in class mx.skins.halo.DateChooserMonthArrowSkin
 | Constructor.
dateChooserStyleName — Style in class mx.controls.DateField
 | Name of the CSS Style declaration to use for the styles for the DateChooser control's drop-down list.
DateChooserYearArrowSkin — Class in package mx.skins.halo
 | The skin for all the states of the next-year and previous-year buttons in a DateChooser.
DateChooserYearArrowSkin() — Constructor in class mx.skins.halo.DateChooserYearArrowSkin
 | Constructor.
dateCompare(a:Date, b:Date) — Static method in class mx.utils.ObjectUtil
 | Compares the two Date objects and returns an integer value indicating if the first Date object is before, equal to, or after the second item.
DateField — Class in package mx.controls
 | The DateField control is a text field that shows the date with a calendar icon on its right side.
DateField() — Constructor in class mx.controls.DateField
 | Constructor
DateFormatter — Class in package mx.formatters
 | The DateFormatter class uses a format String to render date and time Strings from a String or a Date object.
DateFormatter() — Constructor in class mx.formatters.DateFormatter
 | Constructor.
DateTimeAxis — Class in package mx.charts
 | The DateTimeAxis class maps time values evenly between a minimum and maximum value along a chart axis.
DateTimeAxis() — Constructor in class mx.charts.DateTimeAxis
 | Constructor.
dateToString(value:Date, outputFormat:String) — Static method in class mx.controls.DateField
 | Formats a Date into a String according to the outputFormat argument.
dateUTC — Property in class Date
 | The day of the month (an integer from 1 to 31) of a Date object according to universal time (UTC).
DateValidator — Class in package mx.validators
 | The DateValidator class validates that a String or Object contains a proper date and matches a specified format.
DateValidator() — Constructor in class mx.validators.DateValidator
 | Constructor.
day — Property in class Date
 | The day of the week (0 for Sunday, 1 for Monday, and so on) specified by this Date according to local time.
dayListener — Property in class mx.validators.DateValidator
 | The component that listens for the validation result for the day subfield.
dayNames — Property in class mx.controls.DateChooser
 | The weekday names for DateChooser control.
dayNames — Property in class mx.controls.DateField
 | Weekday names for DateChooser control.
dayNamesLong — Static property in class mx.formatters.DateBase
 | Long format of day names.
dayNamesShort — Static property in class mx.formatters.DateBase
 | Short format of day names.
dayProperty — Property in class mx.validators.DateValidator
 | Name of the day property to validate.
daySource — Property in class mx.validators.DateValidator
 | Object that contains the value of the day field.
dayUTC — Property in class Date
 | The day of the week (0 for Sunday, 1 for Monday, and so on) of this Date according to universal time (UTC).
deactivate — Event in class flash.display.DisplayObject
 | Dispatched when Flash Player loses operating system focus and is becoming inactive.
deactivate() — Method in class mx.managers.FocusManager
 | The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time.
deactivate() — Method in interface mx.managers.IFocusManager
 | The SystemManager activates and deactivates a FocusManager if more than one IFocusManagerContainer is visible at the same time.
deactivate(f:mx.managers:IFocusManagerContainer) — Method in interface mx.managers.ISystemManager
 | Deactivates the FocusManager in an IFocusManagerContainer, and activate the FocusManager of the next highest window that is an IFocusManagerContainer.
deactivate(f:mx.managers:IFocusManagerContainer) — Method in class mx.managers.SystemManager
 | Deactivates the FocusManager in an IFocusManagerContainer, and activate the FocusManager of the next highest window that is an IFocusManagerContainer.
DEACTIVATE — Constant static property in class flash.events.Event
 | Defines the value of the type property of a deactivate event object.
deblocking — Property in class flash.media.Video
 | Indicates the type of filter applied to decoded video as part of post-processing.
debug(message:String, ... rest) — Method in interface mx.logging.ILogger
 | Logs the specified data using the LogEventLevel.DEBUG level.
debug(message:String, ... rest) — Method in class mx.logging.LogLogger
 | Logs the specified data using the LogEventLevel.DEBUG level.
DEBUG — Constant static property in class mx.logging.LogEventLevel
 | Designates informational level messages that are fine grained and most helpful when debugging an application.
DECIMAL_DIGITS — Constant static property in class mx.validators.Validator
 | A String containing the decimal digits 0 through 9.
decimalPointCountError — Property in class mx.validators.CurrencyValidator
 | Error message when the decimal separator character occurs more than once.
decimalPointCountError — Property in class mx.validators.NumberValidator
 | Error message when the decimal separator character occurs more than once.
decimalSeparator — Property in class mx.validators.CurrencyValidator
 | The character used to separate the whole from the fractional part of the number.
decimalSeparator — Property in class mx.validators.NumberValidator
 | The character used to separate the whole from the fractional part of the number.
decimalSeparatorFrom — Property in class mx.formatters.CurrencyFormatter
 | Decimal separator character to use when parsing an input string.
decimalSeparatorFrom — Property in class mx.formatters.NumberBase
 | Decimal separator character to use when parsing an input String.
decimalSeparatorFrom — Property in class mx.formatters.NumberFormatter
 | Decimal separator character to use when parsing an input String.
decimalSeparatorTo — Property in class mx.formatters.CurrencyFormatter
 | Decimal separator character to use when outputting formatted decimal numbers.
decimalSeparatorTo — Property in class mx.formatters.NumberBase
 | Decimal separator character to use when outputting formatted decimal numbers.
decimalSeparatorTo — Property in class mx.formatters.NumberFormatter
 | Decimal separator character to use when outputting formatted decimal numbers.
declineFill — Style in class mx.charts.series.CandlestickSeries
 | Sets the declining fill for this data series, used when the closing value of an element is less than the opening value.
decode(source:String) — Method in class flash.net.URLVariables
 | Converts the variable string to properties of the specified URLVariables object.
decodeURI(uri) — Package function in Top Level
 | Decodes an encoded URI into a string.
decodeURIComponent(uri) — Package function in Top Level
 | Decodes an encoded URI component into a string.
decodeXML(dataNode:flash.xml:XMLNode) — Method in class mx.rpc.xml.SimpleXMLDecoder
 | Converts a tree of XMLNodes into a tree of ActionScript Objects.
default — Statement
 | Defines the default case for a switch statement.
DEFAULT — Constant static property in class flash.net.ObjectEncoding
 | Specifies the default (latest) format for the current player.
DEFAULT — Constant static property in class flash.system.SecurityPanel
 | When passed to Security.showSettings(), displays the panel that was open the last time the user closed the Flash Player Settings.
DEFAULT — Constant static property in class flash.text.TextDisplayMode
 | Allows Flash Player to choose LCD or CRT mode.
DEFAULT — Constant static property in class mx.core.EventPriority
 | Event handlers on component instances are executed with the default priority, 0.
defaultButton — Property in class mx.core.Container
 | The Button control designated as the default button for the container.
defaultButton — Property in class mx.managers.FocusManager
 | A reference to the original default Button control.
defaultButton — Property in interface mx.managers.IFocusManager
 | A reference to the original default Button control.
defaultButtonEnabled — Property in class mx.managers.FocusManager
 | A flag that indicates whether the FocusManager should check for the Enter key being pressed to activate the default button.
defaultButtonEnabled — Property in interface mx.managers.IFocusManager
 | A flag that indicates whether the FocusManager should check for the Enter key being pressed to activate the default button.
defaultButtonFlag — Property in class mx.controls.Alert
 | A bitflag that contains either Alert.OK, Alert.CANCEL, Alert.YES, or Alert.NO to specify the default button.
defaultColumnCount — Property in class mx.controls.listClasses.ListBase
 | The default number of columns to display.
defaultCreateMask(targ:Object, bounds:flash.geom:Rectangle) — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Creates the default mask for the effect.
DefaultDataDescriptor — Class in package mx.controls.treeClasses
 | The DefaultDataDescriptor class provides a default implementation for accessing and manipulating data for use in controls such as Tree and Menu.
DefaultDataDescriptor() — Constructor in class mx.controls.treeClasses.DefaultDataDescriptor
 | Constructor
DEFAULT_DESTINATION_HTTP — Constant static property in class mx.rpc.http.HTTPService
 | Indicates that the HTTPService object uses the DefaultHTTP destination.
DEFAULT_DESTINATION_HTTP — Constant static property in class mx.rpc.soap.WebService
DEFAULT_DESTINATION_HTTPS — Constant static property in class mx.rpc.http.HTTPService
 | Indicates that the HTTPService object uses the DefaultHTTPS destination.
DEFAULT_DESTINATION_HTTPS — Constant static property in class mx.rpc.soap.WebService
defaultDragImageSkin — Style in class mx.managers.DragManager
 | Skin used to draw the default drag image, which is also called the drag proxy.
defaultFactory — Property in class mx.styles.CSSStyleDeclaration
 | This function, if it isn't null, is usually autogenerated by the MXML compiler.
defaultFilterFunction(propChanges:Array, instanceTarget:Object) — Method in class mx.effects.EffectTargetFilter
 | The default filter function for the EffectTargetFilter class.
DEFAULT_HANDLER — Constant static property in class mx.core.EventPriority
 | Some components listen to events that they dispatch on themselves and let other listeners call the preventDefault() method to tell the component not to perform a default action.
defaultHeaders — Property in class mx.messaging.Producer
 | The default headers to apply to messages sent by the Producer.
defaultInvalidFormatError — Property in class mx.formatters.Formatter
 | Error message for an invalid format string specified to the formatter.
defaultInvalidValueError — Property in class mx.formatters.Formatter
 | Error message for an invalid value specified to the formatter.
defaultLeafIcon — Style in class mx.controls.Tree
 | Specifies the default icon for a leaf item.
defaultLinkProtocol — Property in class mx.controls.RichTextEditor
 | The default protocol string to use at the start of link text.
DEFAULT_MAX_HEIGHT — Constant static property in class mx.core.UIComponent
 | The default value for the maxHeight property.
DEFAULT_MAX_WIDTH — Constant static property in class mx.core.UIComponent
 | The default value for the maxWidth property.
DEFAULT_MEASURED_HEIGHT — Constant static property in class mx.core.UIComponent
 | The default value for the measuredHeight property.
DEFAULT_MEASURED_MIN_HEIGHT — Constant static property in class mx.core.UIComponent
 | The default value for the measuredMinHeight property.
DEFAULT_MEASURED_MIN_WIDTH — Constant static property in class mx.core.UIComponent
 | The default value for the measuredMinWidth property.
DEFAULT_MEASURED_WIDTH — Constant static property in class mx.core.UIComponent
 | The default value for the measuredWidth property.
defaultObjectEncoding — Static property in class flash.net.NetConnection
 | The default object encoding (AMF version) for NetConnection objects created in the SWF file.
defaultObjectEncoding — Static property in class flash.net.SharedObject
 | The default object encoding (AMF version) for all local shared objects created in the SWF file.
defaultObjectEncoding — Static property in class flash.utils.ByteArray
 | Denotes the default object encoding for the ByteArray class to use for a new ByteArray instance.
defaultRowCount — Property in class mx.controls.listClasses.ListBase
 | The default number of rows to display.
defaultSettings() — Static method in class XML
 | Returns an object with the following properties set to the default values: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting.
defaultTextFormat — Property in class flash.text.TextField
 | Specifies the format applied to newly inserted text, such as text inserted with the replaceSelectedText() method or text entered by a user.
default xml namespace — Statement
 | The default xml namespace directive sets the default namespace to use for XML objects.
DeferredInstanceFromClass — Class in package mx.core
 | A deferred instance factory that creates and returns an instance of a specified class.
DeferredInstanceFromClass(generator:Class) — Constructor in class mx.core.DeferredInstanceFromClass
 | Constructor.
DeferredInstanceFromFunction — Class in package mx.core
 | A deferred instance factory that uses a generator function to create an instance of the required object.
DeferredInstanceFromFunction(generator:Function) — Constructor in class mx.core.DeferredInstanceFromFunction
 | Constructor.
DefinitionError — Dynamic class in Top Level
 | The DefinitionError class represents an error that occurs when user code attempts to define an identifier that is already defined.
DefinitionError(message:String) — Constructor in class DefinitionError
 | Creates a new DefinitionError object.
delay — Property in class flash.utils.Timer
 | The delay, in milliseconds, between timer events.
delete — Operator
 | Destroys the object property specified by reference; the result is true if the property does not exist after the operation completes, and false otherwise.
DELETE — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Delete key (46).
DELETE — Constant static property in class mx.events.PropertyChangeEventKind
 | Indicates that the property was deleted from the object.
DELETE_DEFAULT_PLAYER — Constant static property in class mx.controls.videoClasses.VideoError
 | Cannot delete default VideoPlayer
DELETE_FROM_COLLECTION — Constant static property in class mx.data.UpdateCollectionRange
 | Indicates a range of items that have been deleted from the collection.
deleteItem(item:Object) — Method in class mx.data.DataService
 | Requests that the specified item be deleted from the remote store.
deleteItem(item:Object) — Method in class mx.data.mxml.DataService
 | Requests that the specified item be deleted from the remote store.
DELETE_METHOD — Constant static property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates that the method used for this request should be "delete".
DELETE_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation indicates that the specified item should be removed.
deleteProperty(name) — Method in class flash.utils.Proxy
 | Overrides the request to delete a property.
deleteProperty(name) — Method in class mx.utils.ObjectProxy
 | Deletes the specified property on the proxied object and sends notification of the delete to the handler.
deleteReferenceOnParentDocument(parentDocument:mx.core:IFlexDisplayObject) — Method in interface mx.core.IDeferredInstantiationUIComponent
 | Deletes the id reference to this IUIComponent object on its parent document object.
deleteReferenceOnParentDocument(parentDocument:mx.core:IFlexDisplayObject) — Method in class mx.core.UIComponent
 | Deletes the id reference to this IUIComponent object on its parent document object.
delete (XML) — Operator
 | Deletes the XML elements or attributes specified by reference.
delta — Property in class flash.events.MouseEvent
 | Indicates how many lines should be scrolled for each unit the user rotates the mouse wheel.
delta — Property in class mx.events.DividerEvent
 | The number of pixels that the divider has been dragged.
delta — Property in class mx.events.ScrollEvent
 | The change in the scroll position value that resulted from the scroll.
deltaTransformPoint(point:flash.geom:Point) — Method in class flash.geom.Matrix
 | Given a point in the pretransform coordinate space, returns the coordinates of that point after the transformation occurs.
depth — Property in class mx.controls.treeClasses.TreeListData
 | The level of the item in the tree.
depthColors — Style in class mx.controls.Tree
 | Array of colors used in the Tree control, in descending order.
descendants(name:Object) — Method in class XML
 | Returns all descendants (children, grandchildren, great-grandchildren, and so on) of the XML object that have the given name parameter.
descendants(name:Object) — Method in class XMLList
 | Returns all descendants (children, grandchildren, great-grandchildren, and so on) of the XML object that have the given name parameter.
descendants(name:Object) — Method in class mx.collections.XMLListCollection
 | Calls the descendants() method of each XML object in the XMLList and returns an XMLList containing the results.
descending — Property in class mx.collections.SortField
 | Specifies whether the this field should be sorted in descending order.
DESCENDING — Constant static property in class Array
 | Specifies descending sorting for the Array class sorting methods.
descent — Property in class flash.text.TextLineMetrics
 | The descent value of the text is the length from the baseline to the bottom depth of the line in pixels.
describeData(dimension:String, requiredFields:uint) — Method in class mx.charts.chartClasses.AxisBase
 | Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
describeData(dimension:String, requiredFields:uint) — Method in class mx.charts.chartClasses.ChartElement
 | Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
describeData(dimension:String, requiredFields:uint) — Method in class mx.charts.chartClasses.DataTransform
 | Collects important displayed values for all elements associated with this data transform.
describeData(dimension:String, requiredFields:uint) — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
describeData(dimension:String, requiredFields:uint) — Method in interface mx.charts.chartClasses.IChartElement
 | Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
describeData(dimension:String, requiredFields:uint) — Method in class mx.charts.series.BubbleSeries
 | Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
describeData(dimension:String, requiredFields:uint) — Method in class mx.charts.series.ColumnSet
 | Called by the governing DataTransform to obtain a description of the data represented by this IChartElement.
describeType(value) — Package function in flash.utils
 | Produces an XML object that describes the ActionScript object named as the parameter of the method.
describeType(o) — Static method in class mx.utils.DescribeTypeCache
 | Calls flash.utils.describeType() for the first time and caches the return value so that subsequent calls return faster.
DescribeTypeCache — Class in package mx.utils
 | DescribeTypeCache is a convenience class that is used to cache the return values of flash.utils.describeType() so that calls made subsequent times return faster.
DescribeTypeCacheRecord — Dynamic class in package mx.utils
 | This class represents a single cache entry, this gets created as part of the describeType method call on the DescribeTypeCache class.
description — Property in class flash.accessibility.AccessibilityProperties
 | Provides a description for this display object in the accessible presentation.
description — Property in class flash.net.FileFilter
 | The description string for the filter.
description — Property in class mx.charts.chartClasses.ChartBase
 | A short description of the data described by the chart.
description — Property in class mx.messaging.management.MBeanFeatureInfo
 | The description of the MBean feature.
description — Property in class mx.messaging.management.MBeanInfo
 | The description for the MBean.
description — Property in class mx.rpc.soap.WebService
 | The description of the service for the currently active port.
descriptor — Property in interface mx.core.IDeferredInstantiationUIComponent
 | Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance.
descriptor — Property in class mx.core.UIComponent
 | Reference to the UIComponentDescriptor, if any, that was used by the createComponentFromDescriptor() method to create this UIComponent instance.
destination — Property in class mx.data.Conflict
 | Returns the destination for the data service of the item involved in this conflict.
destination — Property in class mx.data.DataService
 | Indicates which remote destination this service is associated with.
destination — Property in class mx.data.mxml.DataService
 | Indicates which remote destination this service is associated with.
destination — Property in class mx.messaging.MessageAgent
 | Provides access to the destination for the MessageAgent.
destination — Property in class mx.messaging.messages.AbstractMessage
 | The message destination.
destination — Property in interface mx.messaging.messages.IMessage
 | The message destination.
destination — Property in class mx.rpc.AbstractService
 | The destination of the service.
destination — Property in class mx.rpc.http.HTTPService
 | An HTTPService destination name in the services-config.xml file.
destination — Property in class mx.rpc.soap.WebService
 | The destination of the service.
DESTINATION_CLIENT_ID_HEADER — Constant static property in class mx.messaging.messages.AbstractMessage
 | Messages pushed from the server may arrive in a batch, with messages in the batch potentially targeted to different Consumer instances.
destroyItemEditor() — Method in class mx.controls.DataGrid
 | This method closes an item editor currently open on an item renderer.
destroyItemEditor() — Method in class mx.controls.List
 | Closes an item editor that is currently open on an item.
destroyToolTip(toolTip:mx.core:IToolTip) — Static method in class mx.managers.ToolTipManager
 | Destroys a specified ToolTip that was created by the createToolTip() method.
detail — Property in class mx.events.CloseEvent
 | Identifies the button in the popped uo control that was clicked.
detail — Property in class mx.events.DateChooserEvent
 | Indicates the direction of scrolling.
detail — Property in class mx.events.ScrollEvent
 | Provides the details of the scroll activity.
determineTextFormatFromStyles() — Method in class mx.core.UIComponent
 | Returns a UITextFormat object corresponding to the text styles for this UIComponent.
DEVICE — Constant static property in class flash.text.FontType
 | Indicates that this is a device font.
DiamondItemRenderer — Class in package mx.charts.renderers
 | A simple chart itemRenderer implementation that fills a diamond in its assigned area.
DiamondItemRenderer() — Constructor in class mx.charts.renderers.DiamondItemRenderer
 | Constructor.
Dictionary — Dynamic class in package flash.utils
 | The Dictionary class lets you create a dynamic collection of properties, which uses strict equality (===) for key comparison.
Dictionary(weakKeys:Boolean) — Constructor in class flash.utils.Dictionary
 | Creates a new Dictionary object.
DIFFERENCE — Constant static property in class flash.display.BlendMode
 | Compares the constituent colors of the display object with the colors of its background, and subtracts the darker of the values of the two constituent colors from the lighter value.
DINERS_CLUB — Constant static property in class mx.validators.CreditCardValidatorCardType
 | Specifies the card type as Diners Club.
direction — Style in class mx.charts.GridLines
 | Specifies the direction of the grid lines.
direction — Property in class mx.charts.effects.SeriesSlide
 | Defines the location from which the series slides.
direction — Property in class mx.charts.effects.effectClasses.SeriesSlideInstance
 | Defines the location from which the series slides.
direction — Property in class mx.containers.Box
 | The direction in which this Box container lays out its children.
direction — Property in class mx.containers.FormItem
 | Direction of the FormItem subcomponents.
direction — Property in class mx.containers.Tile
 | Determines how children are placed in the container.
direction — Property in class mx.controls.ProgressBar
 | Direction in which the fill of the ProgressBar expands toward completion.
direction — Property in class mx.controls.listClasses.TileBase
 | The direction in which this control lays out its children.
direction — Property in class mx.controls.scrollClasses.ScrollBar
 | Specifies whether the ScrollBar is for horizontal or vertical scrolling.
direction — Property in class mx.controls.sliderClasses.Slider
 | The orientation of the slider control.
direction — Property in class mx.events.ScrollEvent
 | The direction of motion.
direction — Property in class mx.skins.halo.ListDropIndicator
 | Should the skin draw a horizontal line or vertical line.
disableAutoUpdate() — Method in interface mx.collections.ICollectionView
 | Prevents changes to the collection itself and items within the collection from being dispatched by the view.
disableAutoUpdate() — Method in class mx.collections.ListCollectionView
 | Prevents changes to the collection itself and items within the collection from being dispatched by the view.
disabledColor — Style in class mx.charts.chartClasses.DataTip
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.containers.FormHeading
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.Button
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.ColorPicker
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.ComboBox
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.DateChooser
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.DateField
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.Label
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.MenuBar
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.NumericStepper
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.ProgressBar
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.TextArea
 | Color of the component if it is disabled.
disabledColor — Style in class mx.controls.TextInput
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.ToolTip
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.listClasses.ListItemRenderer
 | Text color of the component if it is disabled.
disabledColor — Style in class mx.controls.listClasses.TileListItemRenderer
 | Text color of the component if it is disabled.
disabledColor — Style in class mx.controls.menuClasses.MenuBarItem
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.controls.menuClasses.MenuItemRenderer
 | Color of the menu item if it is disabled.
disabledColor — Style in class mx.controls.treeClasses.TreeItemRenderer
 | Color of the component if it is disabled.
disabledColor — Style in class mx.core.Container
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.core.ScrollControlBase
 | Color of text in the component if it is disabled.
disabledColor — Style in class mx.core.UITextField
 | Color of text in the component if it is disabled.
disabledDays — Property in class mx.controls.DateChooser
 | The days to disable in a week.
disabledDays — Property in class mx.controls.DateField
 | Days to disable in a week.
disabledIcon — Style in class mx.controls.Button
 | Name of the class to use as the icon when the button is not disabled.
disabledOverlayAlpha — Style in class mx.core.Container
 | The alpha value for the overlay that is placed on top of the container when it is disabled.
disabledRanges — Property in class mx.controls.DateChooser
 | Disables single and multiple days.
disabledRanges — Property in class mx.controls.DateField
 | Disables single and multiple days.
disabledSkin — Style in class mx.controls.Button
 | Name of the class to use as the skin for the background and border when the button is not selected and is disabled.
disabledSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the control is disabled.
disablePolling() — Method in class mx.messaging.channels.PollingChannel
 | Disables polling based on the number of times enablePolling() and disablePolling() have been invoked.
discard — Property in class mx.charts.chartClasses.InstanceCache
 | Determines if unneeded instances are discarded.
disclosureClosedIcon — Style in class mx.controls.Tree
 | Specifies the icon that is displayed next to a parent item that is closed so that its children are not displayed (the subtree is collapsed).
disclosureIcon — Property in class mx.controls.treeClasses.TreeItemRenderer
 | The internal IFlexDisplayObject that displays the disclosure icon in this renderer.
disclosureIcon — Property in class mx.controls.treeClasses.TreeListData
 | A Class representing the disclosure icon for the item in the Tree control.
disclosureOpenIcon — Style in class mx.controls.Tree
 | Specifies the icon that is displayed next to a parent item that is open so that its children are displayed.
disconnect() — Method in class mx.data.DataService
 | Disconnects the DataService's network connection.
disconnect() — Method in class mx.data.mxml.DataService
 | Disconnects the DataService's network connection.
disconnect(channelSet:mx.messaging:ChannelSet) — Method in class mx.messaging.Channel
 | Disconnects the ChannelSet from the Channel.
disconnect(agent:mx.messaging:MessageAgent) — Method in class mx.messaging.ChannelSet
 | Disconnects a MessageAgent from the ChannelSet.
disconnect() — Method in class mx.messaging.Consumer
 | Disconnects the Consumer from its remote destination.
disconnect() — Method in class mx.messaging.MessageAgent
 | Disconnects the MessageAgent's network connection.
disconnect() — Method in class mx.rpc.AbstractService
 | Disconnects the service's network connection and removes any pending request responders.
disconnect() — Method in class mx.rpc.http.HTTPService
 | Disconnects the service's network connection.
DISCONNECT — Constant static property in class mx.messaging.events.ChannelEvent
 | The DISCONNECT event type; indicates that the Channel disconnected from its endpoint.
DISCONNECTED — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property when the video stream has timed out or is idle.
disconnectFailed(event:mx.messaging.events:ChannelFaultEvent) — Method in class mx.messaging.Channel
 | Processes a failed internal disconnect and dispatches the FAULT event for the channel.
disconnectSuccess(rejected:Boolean) — Method in class mx.messaging.Channel
 | Processes a successful internal disconnect and dispatches the DISCONNECT event for the Channel.
DISCOVER — Constant static property in class mx.validators.CreditCardValidatorCardType
 | Specifies the card type as Discover.
dispatcher — Property in class mx.utils.ObjectProxy
 | A reference to the EventDispatcher for this proxy.
dispatchEvent(event:flash.events:Event) — Method in class flash.display.Stage
 | Dispatches an event into the event flow.
dispatchEvent(event:flash.events:Event) — Method in class flash.events.EventDispatcher
 | Dispatches an event into the event flow.
dispatchEvent(event:flash.events:Event) — Method in interface flash.events.IEventDispatcher
 | Dispatches an event into the event flow.
dispatchEvent(event:flash.events:Event) — Method in class mx.collections.ListCollectionView
 | Dispatches an event into the event flow.
dispatchEvent — Property in class mx.events.TreeEvent
 | Whether to dispatch an event (ITEM_OPEN or ITEM_CLOSE) after the open or close animation is complete.
dispatchEvent(event:flash.events:Event) — Method in class mx.utils.ObjectProxy
 | Dispatches an event into the event flow.
DisplacementMapFilter — Final class in package flash.filters
 | The DisplacementMapFilter class uses the pixel values from the specified BitmapData object (called the displacement map image) to perform a displacement of an object.
DisplacementMapFilter(mapBitmap:flash.display:BitmapData, mapPoint:flash.geom:Point, componentX:uint, componentY:uint, scaleX:Number, scaleY:Number, mode:String, color:uint, alpha:Number) — Constructor in class flash.filters.DisplacementMapFilter
 | Initializes a DisplacementMapFilter instance with the specified parameters.
DisplacementMapFilterMode — Final class in package flash.filters
 | The DisplacementMapFilterMode class provides values for the mode property of the DisplacementMapFilter class.
displayAsPassword — Property in class flash.text.TextField
 | Specifies whether the text field is a password text field.
displayAsPassword — Property in class mx.controls.TextArea
 | Indicates whether this control is used for entering passwords.
displayAsPassword — Property in class mx.controls.TextInput
 | Indicates whether this control is used for entering passwords.
displayedMonth — Property in class mx.controls.DateChooser
 | Used together with the displayedYear property, the displayedMonth property specifies the month displayed in the DateChooser control.
displayedMonth — Property in class mx.controls.DateField
 | Used with the displayedYear property, the displayedMonth property specifies the month displayed in the DateChooser control.
displayedYear — Property in class mx.controls.DateChooser
 | Used together with the displayedMonth property, the displayedYear property specifies the month displayed in the DateChooser control.
displayedYear — Property in class mx.controls.DateField
 | Used with the displayedMonth property, the displayedYear property determines which year is displayed in the DateChooser control.
displayLocalTime — Property in class mx.charts.DateTimeAxis
 | When set to true, a DateTimeAxis considers all date values to be in the time zone of the client machine running the application.
displayMode — Static property in class flash.text.TextRenderer
 | Controls the rendering of FlashType text.
displayName — Property in class mx.charts.chartClasses.AxisBase
 | The name of the axis.
displayName — Property in interface mx.charts.chartClasses.IAxis
 | The name of the axis.
displayName — Property in class mx.charts.chartClasses.Series
 | The name of the series, for display to the user.
DisplayObject — Class in package flash.display
 | The DisplayObject class is the base class for all objects that can be placed on the display list.
DisplayObjectContainer — Class in package flash.display
 | The DisplayObjectContainer class is the base class for all objects that can serve as display object containers on the display list.
DisplayObjectContainer() — Constructor in class flash.display.DisplayObjectContainer
 | Calling the new DisplayObjectContainer() constructor throws an ArgumentError exception.
displayObjectToString(displayObject:flash.display:DisplayObject) — Static method in class mx.utils.NameUtil
 | Returns a string, such as "MyApplication0.addressForm.lastName.TextField17", for a DisplayObject object that indicates its position in the hierarchy of DisplayObject objects in an application.
displayText — Property in class mx.charts.HitData
 | A description of the associated item for display on screen.
dispose() — Method in class flash.display.BitmapData
 | Frees memory that is used to store the BitmapData object.
Dissolve — Class in package mx.effects
 | Animate the component from transparent to opaque, or from opaque to transparent.
Dissolve(target:Object) — Constructor in class mx.effects.Dissolve
 | Constructor.
DissolveInstance — Class in package mx.effects.effectClasses
 | The DissolveInstance class implements the instance class for the Dissolve effect.
DissolveInstance(target:Object) — Constructor in class mx.effects.effectClasses.DissolveInstance
 | Constructor.
distance — Property in class flash.filters.BevelFilter
 | The offset distance of the bevel.
distance — Property in class flash.filters.DropShadowFilter
 | The offset distance for the shadow, in pixels.
distance — Property in class flash.filters.GradientBevelFilter
 | The offset distance.
distance — Property in class flash.filters.GradientGlowFilter
 | The offset distance of the glow.
distance(pt1:flash.geom:Point, pt2:flash.geom:Point) — Static method in class flash.geom.Point
 | Returns the distance between pt1 and pt2.
distance — Property in class mx.charts.HitData
 | Specifies the distance between the data item on the screen and the location of the mouse pointer, in pixels.
distance — Property in class mx.graphics.RectangularDropShadow
 | The offset distance for the shadow, in pixels.
DividedBox — Class in package mx.containers
 | A DividedBox container measures and lays out its children horizontally or vertically in exactly the same way as a Box container, but it inserts draggable dividers in the gaps between the children.
DividedBox() — Constructor in class mx.containers.DividedBox
 | Constructor.
dividerAffordance — Style in class mx.containers.DividedBox
 | Thickness in pixels of the area where the user can click to drag a divider.
dividerAlpha — Style in class mx.containers.DividedBox
 | The alpha value that determines the transparency of the dividers.
dividerClass — Property in class mx.containers.DividedBox
 | The class for the divider between the children.
dividerColor — Style in class mx.containers.DividedBox
 | Color of the dividers when the user presses or drags the dividers if the liveDragging property is set to false.
dividerDrag — Event in class mx.containers.DividedBox
 | Dispatched multiple times as the user drags any divider.
DIVIDER_DRAG — Constant static property in class mx.events.DividerEvent
 | The DividerEvent.DIVIDER_DRAG constant defines the value of the type property of the event object for a dividerDrag event.
DividerEvent — Class in package mx.events
 | Represents events that are dispatched when a divider has been pressed, dragged or released.
DividerEvent(type:String, bubbles:Boolean, cancelable:Boolean, dividerIndex:int, delta:Number) — Constructor in class mx.events.DividerEvent
 | Constructor.
dividerIndex — Property in class mx.events.DividerEvent
 | The zero-based index of the divider being pressed or dragged.
dividerPress — Event in class mx.containers.DividedBox
 | Dispatched when the user presses any divider in this container.
DIVIDER_PRESS — Constant static property in class mx.events.DividerEvent
 | The DividerEvent.DIVIDER_PRESS constant defines the value of the type property of the event object for a dividerPress event.
dividerRelease — Event in class mx.containers.DividedBox
 | Dispatched when the user releases a divider.
DIVIDER_RELEASE — Constant static property in class mx.events.DividerEvent
 | The DividerEvent.DIVIDER_RELEASE constant defines the value of the type property of the event object for a dividerRelease event.
dividerSkin — Style in class mx.containers.DividedBox
 | The divider skin.
dividerThickness — Style in class mx.containers.DividedBox
 | Thickness in pixels of the dividers when the user presses or drags the dividers, if the liveDragging property is set to false.
divisor — Property in class flash.filters.ConvolutionFilter
 | The divisor used during matrix transformation.
dock — Property in class mx.containers.ApplicationControlBar
 | If true, specifies that the ApplicationControlBar should be docked to the top of the application.
doConversion() — Static method in class flash.system.IME
 | Instructs the IME to select the first candidate for the current composition string.
docTypeDecl — Property in class flash.xml.XMLDocument
 | Specifies information about the XML document's DOCTYPE declaration.
document — Property in class mx.core.ComponentDescriptor
 | A reference to the document Object in which the component is to be created.
document — Property in interface mx.core.IUIComponent
 | A reference to the document object associated with this component.
document — Property in class mx.core.UIComponent
 | A reference to the document object associated with this UIComponent.
document — Property in class mx.core.UITextField
 | A reference to the document object associated with this UITextField object.
document — Property in interface mx.managers.ISystemManager
 | A reference to the document object.
document — Property in class mx.managers.SystemManager
 | A reference to the document object.
document — Property in class mx.rpc.soap.LoadEvent
 | The raw XML for the WSDL document.
doDrag(dragInitiator:mx.core:IUIComponent, dragSource:mx.core:DragSource, mouseEvent:flash.events:MouseEvent, dragImage:mx.core:IFlexDisplayObject, xOffset:Number, yOffset:Number, imageAlpha:Number, allowMove:Boolean) — Static method in class mx.managers.DragManager
 | Initiates a drag and drop operation.
domain — Property in class flash.net.LocalConnection
 | A string representing the domain of the location of the current SWF file.
domain — Property in class mx.messaging.management.ObjectName
 | The domain part.
domain — Property in class mx.validators.NumberValidator
 | Type of number to be validated.
domain — Property in class mx.validators.ZipCodeValidator
 | Type of ZIP code to check.
domainPattern — Property in class mx.messaging.management.ObjectName
 | Indicates if the object name is a pattern on the domain part.
dotall — Property in class RegExp
 | Specifies whether the dot character (.) in a regular expression pattern matches new-line characters.
doubleClick — Event in class flash.display.InteractiveObject
 | Dispatched when a user presses and releases the main button of a pointing device twice in rapid succession over the same InteractiveObject when that object's doubleClickEnabled flag is set to true.
DOUBLE_CLICK — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a doubleClick event object.
doubleClickEnabled — Property in class flash.display.InteractiveObject
 | Specifies whether the object receives doubleClick events.
doubleClickEnabled — Property in class mx.core.UIComponent
 | Specifies whether the UIComponent object receives doubleClick events.
doValidation(value:Object) — Method in class mx.validators.CreditCardValidator
 | Override of the base class doValidation() method to validate a credit card number.
doValidation(value:Object) — Method in class mx.validators.CurrencyValidator
 | Override of the base class doValidation() method to validate a currency expression.
doValidation(value:Object) — Method in class mx.validators.DateValidator
 | Override of the base class doValidation() method to validate a date.
doValidation(value:Object) — Method in class mx.validators.EmailValidator
 | Override of the base class doValidation() method to validate an e-mail address.
doValidation(value:Object) — Method in class mx.validators.NumberValidator
 | Override of the base class doValidation() method to validate a number.
doValidation(value:Object) — Method in class mx.validators.PhoneNumberValidator
 | Override of the base class doValidation() method to validate a phone number.
doValidation(value:Object) — Method in class mx.validators.RegExpValidator
 | Override of the base class doValidation() method to validate a regular expression.
doValidation(value:Object) — Method in class mx.validators.SocialSecurityValidator
 | Override of the base class doValidation() method to validate a Social Security number.
doValidation(value:Object) — Method in class mx.validators.StringValidator
 | Override of the base class doValidation() method to validate a String.
doValidation(value:Object) — Method in class mx.validators.Validator
 | Executes the validation logic of this validator, including validating that a missing or empty value causes a validation error as defined by the value of the required property.
doValidation(value:Object) — Method in class mx.validators.ZipCodeValidator
 | Override of the base class doValidation() method to validate a ZIP code.
do..while — Statement
 | Similar to a while loop, except that the statements are executed once before the initial evaluation of the condition.
DOWN — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Down Arrow key (40).
DOWN — Constant static property in class mx.formatters.NumberBaseRoundType
 | Rounds a number down to an integer that is both closest to, and less than or equal to, the input number.
downArrowButton_buttonDownHandler(event:mx.events:FlexEvent) — Method in class mx.controls.ComboBase
 | Performs some action when the drop-down button is pressed.
downArrowDisabledSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the Up arrow when the arrow is disabled.
downArrowDisabledSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the down arrow button of the scroll bar when it is disabled.
downArrowDownSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the up arrow when the arrow is enabled and a user presses the mouse button over the arrow.
downArrowDownSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the down arrow button of the scroll bar when you click the arrow button .
downArrowOverSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is over the arrow.
downArrowOverSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the down arrow button of the scroll bar when the mouse pointer is over the arrow button.
downArrowUpSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is not on the arrow.
downArrowUpSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the down arrow button of the scroll bar.
downIcon — Style in class mx.controls.Button
 | Name of the class to use as the icon when the button is not selected and the mouse button is down.
download(request:flash.net:URLRequest, defaultFileName:String) — Method in class flash.net.FileReference
 | Opens a dialog box that lets the user download a file from a remote server.
downloadingLabel — Property in class mx.preloaders.DownloadProgressBar
 | The string to display as the label while in the downloading phase.
DOWNLOAD_PERCENTAGE — Property in class mx.preloaders.DownloadProgressBar
 | The percentage of the progress bar that the downloading phase fills when the SWF file is fully downloaded.
DownloadProgressBar — Class in package mx.preloaders
 | The DownloadProgressBar class displays download progress.
DownloadProgressBar() — Constructor in class mx.preloaders.DownloadProgressBar
 | Constructor
downSkin — Style in class mx.controls.Button
 | Name of the class to use as the skin for the background and border when the button is not selected and the mouse button is down.
downSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the user holds down the mouse button.
downState — Property in class flash.display.SimpleButton
 | Specifies a display object that is used as the visual object for the button "Down" state —the state that the button is in when the user clicks the hitTestState object.
dragComplete — Event in class mx.core.UIComponent
 | Dispatched by the drag initiator (the component that is the source of the data being dragged) when the drag operation completes, either when you drop the dragged data onto a drop target or when you end the drag-and-drop operation without performing a drop.
DRAG_COMPLETE — Constant static property in class mx.events.DragEvent
 | The DragEvent.DRAG_COMPLETE constant defines the value of the type property of the event object for a dragComplete event.
dragCompleteHandler(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles DragEvent.DRAG_COMPLETE events.
dragDrop — Event in class mx.core.UIComponent
 | Dispatched by the drop target when the user releases the mouse over it.
DRAG_DROP — Constant static property in class mx.events.DragEvent
 | The DragEvent.DRAG_DROP constant defines the value of the type property of the event object for a dragDrop event.
dragDropHandler(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles DragEvent.DRAG_DROP events.
dragEnabled — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether you can drag items out of this control and drop them on other controls.
dragEnter — Event in class mx.core.UIComponent
 | Dispatched by a component when the user moves the mouse over the component during a drag operation.
DRAG_ENTER — Constant static property in class mx.events.DragEvent
 | The DragEvent.DRAG_ENTER constant defines the value of the type property of the event object for a dragEnter event.
dragEnterHandler(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles DragEvent.DRAG_ENTER events.
DragEvent — Class in package mx.events
 | The DragEvent class represents event objects that are dispatched as part of a drag-and-drop operation.
DragEvent(type:String, bubbles:Boolean, cancelable:Boolean, dragInitiator:mx.core:IUIComponent, dragSource:mx.core:DragSource, action:String, ctrlKey:Boolean, altKey:Boolean, shiftKey:Boolean) — Constructor in class mx.events.DragEvent
 | Constructor.
dragExit — Event in class mx.core.UIComponent
 | Dispatched by the component when the user drags outside the component, but does not drop the data onto the target.
DRAG_EXIT — Constant static property in class mx.events.DragEvent
 | The DragEvent.DRAG_EXIT constant defines the value of the type property of the event object for a dragExit event.
dragExitHandler(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles DragEvent.DRAG_EXIT events.
draggableColumns — Property in class mx.controls.DataGrid
 | A flag that indicates whether the user is allowed to reorder columns.
dragImage — Property in class mx.controls.listClasses.ListBase
 | Gets an instance of a class that displays the visuals during a drag and drop operation.
dragImageOffsets — Property in class mx.controls.listClasses.ListBase
 | Gets the offset of the drag image for drag and drop.
dragInitiator — Property in class mx.events.DragEvent
 | The component that initiated the drag.
DragManager — Class in package mx.managers
 | The DragManager class manages drag and drop operations, which let you move data from one place to another in a Flex application.
dragMoveEnabled — Property in class mx.controls.Tree
 | Indicates that items can be moved instead of just copied from the Tree control as part of a drag-and-drop operation.
dragMoveEnabled — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether items can be moved instead of just copied from the control as part of a drag-and-drop operation.
dragOver — Event in class mx.core.UIComponent
 | Dispatched by a component when the user moves the mouse while over the component during a drag operation.
DRAG_OVER — Constant static property in class mx.events.DragEvent
 | The DragEvent.DRAG_OVER constant defines the value of the type property of the event object for a dragOver event.
dragOverHandler(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles DragEvent.DRAG_OVER events.
dragScroll() — Method in class mx.controls.listClasses.ListBase
 | Interval function that scrolls the list up or down if the mouse goes above or below the list.
dragSource — Property in class mx.events.DragEvent
 | The DragSource object containing the data being dragged.
DragSource — Class in package mx.core
 | The DragSource class contains the data being dragged.
DragSource() — Constructor in class mx.core.DragSource
 | Constructor.
DRAG_START — Constant static property in class mx.events.DragEvent
 | The DragEvent.DRAG_START constant defines the value of the type property of the event object for a dragStart event.
draw(source:flash.display:IBitmapDrawable, matrix:flash.geom:Matrix, colorTransform:flash.geom:ColorTransform, blendMode:String, clipRect:flash.geom:Rectangle, smoothing:Boolean) — Method in class flash.display.BitmapData
 | Draws the source display object onto the bitmap image, using the Flash Player vector renderer.
drawCaretIndicator(indicator:flash.display:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.ListBase
 | Draws the caret indicator into the given Sprite at the position, width and height specified using the color specified.
drawCircle(x:Number, y:Number, radius:Number) — Method in class flash.display.Graphics
 | Draws a circle.
drawColumnBackground(s:flash.display:Sprite, columnIndex:int, color:uint, column:mx.controls.dataGridClasses:DataGridColumn) — Method in class mx.controls.DataGrid
 | Draws a column background for a column with the suggested color.
drawEllipse(x:Number, y:Number, width:Number, height:Number) — Method in class flash.display.Graphics
 | Draws an ellipse.
drawFocus(focused:Boolean) — Method in class mx.core.UIComponent
 | Shows or hides the focus indicator around this component.
drawFocus(draw:Boolean) — Method in interface mx.managers.IFocusManagerComponent
 | Called by the FocusManager when the component receives focus.
drawHeaderBackground(headerBG:mx.core:UIComponent) — Method in class mx.controls.DataGrid
 | Draws the background of the headers into the given UIComponent.
drawHighlightIndicator(indicator:flash.display:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.ListBase
 | Draws the highlight indicator into the given Sprite at the position, width and height specified using the color specified.
drawHorizontalLine(s:flash.display:Sprite, rowIndex:int, color:uint, y:Number) — Method in class mx.controls.DataGrid
 | Draws a line between rows.
drawItem(item:mx.controls.listClasses:IListItemRenderer, selected:Boolean, highlighted:Boolean, caret:Boolean, transition:Boolean) — Method in class mx.controls.listClasses.ListBase
 | Draws the renderer with indicators that it is highlighted, selected, or the caret.
drawLinesAndColumnBackgrounds() — Method in class mx.controls.DataGrid
 | Draw lines between columns, and column backgrounds.
drawRect(x:Number, y:Number, width:Number, height:Number) — Method in class flash.display.Graphics
 | Draws a rectangle.
drawRoundRect(x:Number, y:Number, width:Number, height:Number, ellipseWidth:Number, ellipseHeight:Number) — Method in class flash.display.Graphics
 | Draws a rounded rectangle.
drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object, color:Object, alpha:Object, gradientMatrix:flash.geom:Matrix, gradientType:String, gradientRatios:Array, hole:Object) — Method in class mx.core.UIComponent
 | Programatically draws a rectangle into this skin's Graphics object.
drawRoundRect(x:Number, y:Number, width:Number, height:Number, cornerRadius:Object, color:Object, alpha:Object, gradientMatrix:flash.geom:Matrix, gradientType:String, gradientRatios:Array, hole:Object) — Method in class mx.skins.ProgrammaticSkin
 | Programatically draws a rectangle into this skin's Graphics object.
drawRoundRectComplex(graphics:flash.display:Graphics, x:Number, y:Number, width:Number, height:Number, topLeftRadius:Number, topRightRadius:Number, bottomLeftRadius:Number, bottomRightRadius:Number) — Static method in class mx.utils.GraphicsUtil
 | Draws a rounded rectangle using the size of a radius to draw the rounded corners.
drawRowBackground(s:flash.display:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int) — Method in class mx.controls.DataGrid
 | Draws a row background at the position and height specified using the color specified.
drawRowBackground(s:flash.display:Sprite, rowIndex:int, y:Number, height:Number, color:uint, dataIndex:int) — Method in class mx.controls.List
 | Draws a row background at the position and height specified.
drawRowBackgrounds() — Method in class mx.controls.listClasses.ListBase
 | Draws any alternating row colors, borders and backgrounds for the rows.
drawSelectionIndicator(indicator:flash.display:Sprite, x:Number, y:Number, width:Number, height:Number, color:uint, itemRenderer:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.ListBase
 | Draws the selection indicator into the given Sprite at the position, width and height specified using the color specified.
drawSeparators() — Method in class mx.controls.DataGrid
 | Creates and displays the column header separators that the user normally uses to resize columns.
drawShadow(g:flash.display:Graphics, x:Number, y:Number, width:Number, height:Number) — Method in class mx.graphics.RectangularDropShadow
 | Renders the shadow on the screen.
drawTileBackground(s:flash.display:Sprite, rowIndex:int, columnIndex:int, width:Number, height:Number, color:uint, item:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.TileBase
 | Draws the background for an individual tile.
drawTileBackgrounds() — Method in class mx.controls.listClasses.TileBase
 | Draws the backgrounds, if any, behind all of the tiles.
drawVerticalLine(s:flash.display:Sprite, colIndex:int, color:uint, x:Number) — Method in class mx.controls.DataGrid
 | Draw lines between columns.
dropdown — Property in class mx.controls.ComboBox
 | A reference to the List control that acts as the drop-down in the ComboBox.
dropdownBorderColor — Style in class mx.controls.ComboBox
 | The color of the border of the ComboBox.
DropdownEvent — Class in package mx.events
 | The DropdownEvent class represents the event object passed to the event listener for the open and close events.
DropdownEvent(type:String, bubbles:Boolean, cancelable:Boolean, triggerEvent:flash.events:Event) — Constructor in class mx.events.DropdownEvent
 | Constructor.
dropdownFactory — Property in class mx.controls.ComboBox
 | The IFactory that creates a ListBase-derived instance to use as the drop-down.
dropDownStyleName — Style in class mx.controls.ComboBox
 | The name of a CSSStyleDeclaration to be used by the drop-down list.
dropdownWidth — Property in class mx.controls.ComboBox
 | Width of the drop-down list, in pixels.
dropEnabled — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether dragged items can be dropped onto the control.
dropIndicatorSkin — Style in class mx.controls.listClasses.ListBase
 | The skin to use to indicate where a dragged item can be dropped.
dropShadowColor — Style in class mx.controls.NumericStepper
 | Color of the drop shadow.
dropShadowColor — Style in class mx.controls.TextInput
 | Color of the drop shadow.
dropShadowColor — Style in class mx.controls.ToolTip
 | Color of the drop shadow.
dropShadowColor — Style in class mx.controls.VideoDisplay
 | Color of the drop shadow.
dropShadowColor — Style in class mx.core.Container
 | Color of the drop shadow.
dropShadowColor — Style in class mx.core.ScrollControlBase
 | Color of the drop shadow.
dropShadowEnabled — Style in class mx.containers.Panel
 | Boolean property that controls the visibility of the Panel container's drop shadow.
dropShadowEnabled — Style in class mx.controls.NumericStepper
 | Boolean property that specifies whether the component has a visible drop shadow.
dropShadowEnabled — Style in class mx.controls.TextInput
 | Boolean property that specifies whether the component has a visible drop shadow.
dropShadowEnabled — Style in class mx.controls.ToolTip
 | Boolean property that specifies whether the component has a visible drop shadow.
dropShadowEnabled — Style in class mx.controls.VideoDisplay
 | Boolean property that specifies whether the component has a visible drop shadow.
dropShadowEnabled — Style in class mx.core.Container
 | Boolean property that specifies whether the component has a visible drop shadow.
dropShadowEnabled — Style in class mx.core.ScrollControlBase
 | Boolean property that specifies whether the component has a visible drop shadow.
DropShadowFilter — Final class in package flash.filters
 | The DropShadowFilter class lets you add a drop shadow to display objects.
DropShadowFilter(distance:Number, angle:Number, color:uint, alpha:Number, blurX:Number, blurY:Number, strength:Number, quality:int, inner:Boolean, knockout:Boolean, hideObject:Boolean) — Constructor in class flash.filters.DropShadowFilter
 | Creates a new DropShadowFilter instance with the specified parameters.
dropTarget — Property in class flash.display.Sprite
 | Specifies the display object over which the sprite is being dragged, or on which the sprite was dropped.
DualStyleObject — Class in package mx.charts.chartClasses
 | The DualStyleObject class serves as a base class for components that have a need to assign class selectors outside of the client developer's control.
DualStyleObject() — Constructor in class mx.charts.chartClasses.DualStyleObject
 | Constructor.
duration — Property in class mx.effects.Effect
 | Duration of the effect in milliseconds.
duration — Property in class mx.effects.EffectInstance
 | Duration of the effect in milliseconds.
duration — Property in class mx.effects.Tween
 | Duration of the animation, in milliseconds.
dynamic — Statement
 | Specifies that instances of a class may possess dynamic properties added at runtime.
DYNAMIC — Constant static property in class flash.text.TextFieldType
 | Used to specify a dynamic TextField.
DynamicEvent — Dynamic class in package mx.events
 | This subclass of Event is dynamic, meaning that you can set arbitrary event properties on its instances at runtime.
DynamicEvent(type:String, bubbles:Boolean, cancelable:Boolean) — Constructor in class mx.events.DynamicEvent
 | Constructor.
dynamicPropertyWriter — Static property in class flash.net.ObjectEncoding
 | Allows greater control over the serialization of dynamic properties of dynamic objects.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


E Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
E Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
E — Constant static property in class Math
 | A mathematical constant for the base of natural logarithms, expressed as e.
easeIn(t:Number, b:Number, c:Number, d:Number, s:Number) — Static method in class mx.effects.easing.Back
 | The easeIn() method starts the motion by backtracking, then reversing direction and moving toward the target.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Bounce
 | The easeOut() method starts the bounce motion fast, and then decelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Circular
 | The easeIn() method starts motion slowly, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Cubic
 | The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number, a:Number, p:Number) — Static method in class mx.effects.easing.Elastic
 | The easeIn() method starts motion slowly, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Exponential
 | The easeIn() method starts motion slowly, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Linear
 | The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quadratic
 | The easeIn() method starts motion from a zero velocity, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quartic
 | The easeIn() method starts motion from a zero velocity, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quintic
 | The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.
easeIn(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Sine
 | The easeIn() method starts motion from zero velocity, and then accelerates motion as it executes.
easeInOut(t:Number, b:Number, c:Number, d:Number, s:Number) — Static method in class mx.effects.easing.Back
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion by backtracking, then reversing direction and moving toward target, overshooting target slightly, reversing direction again, and then moving back toward the target.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Bounce
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the bounce motion slowly, accelerate motion, then decelerate.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Circular
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Cubic
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from zero velocity, accelerates motion, then decelerates back to a zero velocity.
easeInOut(t:Number, b:Number, c:Number, d:Number, a:Number, p:Number) — Static method in class mx.effects.easing.Elastic
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Exponential
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion slowly, accelerate motion, then decelerate.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Linear
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from zero velocity, accelerate motion, then decelerate back to zero velocity.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quadratic
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quartic
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quintic
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.
easeInOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Sine
 | The easeInOut() method combines the motion of the easeIn() and easeOut() methods to start the motion from a zero velocity, accelerate motion, then decelerate to a zero velocity.
easeNone(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Linear
 | The easeNone() method defines a constant motion, with no acceleration.
easeOut(t:Number, b:Number, c:Number, d:Number, s:Number) — Static method in class mx.effects.easing.Back
 | The easeOut() method starts the motion by moving towards the target, overshooting it slightly, and then reversing direction back toward the target.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Bounce
 | The easeIn() method starts the bounce motion slowly, and then accelerates motion as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Circular
 | The easeOut() method starts motion fast, and then decelerates motion as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Cubic
 | The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number, a:Number, p:Number) — Static method in class mx.effects.easing.Elastic
 | The easeOut() method starts motion fast, and then decelerates motion as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Exponential
 | The easeOut() method starts motion fast, and then decelerates motion as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Linear
 | The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quadratic
 | The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quartic
 | The easeOut() method starts motion fast, and then decelerates motion to a zero velocity.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Quintic
 | The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.
easeOut(t:Number, b:Number, c:Number, d:Number) — Static method in class mx.effects.easing.Sine
 | The easeOut() method starts motion fast, and then decelerates motion to a zero velocity as it executes.
easingFunction — Property in class mx.effects.Tween
 | Sets the easing function for the animation.
easingFunction — Property in class mx.effects.TweenEffect
 | The easing function for the animation.
easingFunction — Property in class mx.effects.effectClasses.TweenEffectInstance
 | The easing function for the animation.
EdgeMetrics — Class in package mx.core
 | The EdgeMetrics class specifies the thickness, in pixels, of the four edge regions around a visual component.
EdgeMetrics(left:Number, top:Number, right:Number, bottom:Number) — Constructor in class mx.core.EdgeMetrics
 | Constructor.
editable — Property in class mx.controls.ComboBase
 | A flag that indicates whether the control is editable, which lets the user directly type entries that are not specified in the dataProvider, or not editable, which requires the user select from the items in the dataProvider.
editable — Property in class mx.controls.DataGrid
 | A flag that indicates whether or not the user can edit items in the data provider.
editable — Property in class mx.controls.List
 | A flag that indicates whether or not the user can edit items in the data provider.
editable — Property in class mx.controls.TextArea
 | Indicates whether the user is allowed to edit the text in this control.
editable — Property in class mx.controls.TextInput
 | Indicates whether the user is allowed to edit the text in this control.
editable — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A flag that indicates whether the items in the column are editable.
editableDisabledSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the control is disabled, and the editable property is true.
editableDownSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the user holds down the mouse button, and the editable property is true.
editableOverSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the mouse is over the control, and the editable property is true.
editableUpSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the mouse is not over the control, and the editable property is true.
editedItemPosition — Property in class mx.controls.DataGrid
 | The column and row index of the item renderer for the data provider item being edited, if any.
editedItemPosition — Property in class mx.controls.List
 | The column and row index of the item renderer for the data provider item being edited, if any.
editedItemRenderer — Property in class mx.controls.DataGrid
 | A reference to the item renderer in the DataGrid control whose item is currently being edited.
editedItemRenderer — Property in class mx.controls.List
 | A reference to the item renderer in the DataGrid control whose item is currently being edited.
editorDataField — Property in class mx.controls.List
 | The name of the property of the item editor that contains the new data for the list item.
editorDataField — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The name of the property of the item editor that contains the new data for the list item.
editorHeightOffset — Property in class mx.controls.List
 | The height of the item editor, in pixels, relative to the size of the item renderer.
editorHeightOffset — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The height of the item editor, in pixels, relative to the size of the item renderer.
editorUsesEnterKey — Property in class mx.controls.List
 | A flag that indicates whether the item editor uses Enter key.
editorUsesEnterKey — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A flag that indicates whether the item editor uses Enter key.
editorWidthOffset — Property in class mx.controls.List
 | The width of the item editor, in pixels, relative to the size of the item renderer.
editorWidthOffset — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The width of the item editor, in pixels, relative to the size of the item renderer.
editorXOffset — Property in class mx.controls.List
 | The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item.
editorXOffset — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The x location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item.
editorYOffset — Property in class mx.controls.List
 | The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item.
editorYOffset — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The y location of the upper-left corner of the item editor, in pixels, relative to the upper-left corner of the item.
effect — Property in class mx.effects.EffectInstance
 | The Effect object that created this EffectInstance object.
effect — Property in class mx.states.Transition
 | The Effect object to play when you apply the transition.
Effect — Class in package mx.effects
 | The Effect class is an abstract base class that defines the basic functionality of all Flex effects.
Effect(target:Object) — Constructor in class mx.effects.Effect
 | Constructor.
EFFECT — Constant static property in class mx.core.EventPriority
 | Autogenerated event handlers that trigger effects are executed after other event handlers on component instances, so they have a lower priority than the default.
effectEnd — Event in class mx.core.UIComponent
 | Dispatched after an effect ends.
effectEnd — Event in class mx.effects.Effect
 | Dispatched when the effect finishes playing, either when the effect finishes playing or when the effect has been interrupted by a call to the end() method.
EFFECT_END — Constant static property in class mx.events.EffectEvent
 | The EffectEvent.EFFECT_END constant defines the value of the type property of the event object for an effectEnd event.
effectEndHandler(event:mx.events:EffectEvent) — Method in class mx.effects.Effect
 | Called when an effect instance has finished playing.
EffectEvent — Class in package mx.events
 | Represents event objects that are specific to Flex effects.
EffectEvent(eventType:String, bubbles:Boolean, cancelable:Boolean, effectInstance:mx.effects:EffectInstance) — Constructor in class mx.events.EffectEvent
 | Constructor.
effectFinished(effectInst:mx.effects:EffectInstance) — Method in class mx.core.UIComponent
 | Called by the effect instance when it stops playing on the component.
effectInstance — Property in class mx.events.EffectEvent
 | The effect instance object for the event.
EffectInstance — Class in package mx.effects
 | The EffectInstance class represents an instance of an effect playing on a target.
EffectInstance(target:Object) — Constructor in class mx.effects.EffectInstance
 | Constructor.
EffectManager — Class in package mx.effects
 | The EffectManager class listens for events, such as the show and move events, dispatched by objects in a Flex application.
effectMask — Property in class mx.effects.effectClasses.MaskEffectInstance
 | Contains the effect mask, either the default mask created by the defaultCreateMask() method, or the one specified by the function passed to the createMaskFunction property.
effects — Property in class mx.core.UIComponentDescriptor
 | An Array containing the effects for the component, as specified in MXML.
effectStart — Event in class mx.core.UIComponent
 | Dispatched just before an effect starts.
effectStart — Event in class mx.effects.Effect
 | Dispatched when the effect starts playing.
EFFECT_START — Constant static property in class mx.events.EffectEvent
 | The EffectEvent.EFFECT_START constant defines the value of the type property of the event object for an effectStart event.
effectStarted(effectInst:mx.effects:EffectInstance) — Method in class mx.core.UIComponent
 | Called by the effect instance when it starts playing on the component.
effectStartHandler(event:mx.events:EffectEvent) — Method in class mx.effects.Effect
 | This method is called when the effect instance starts playing.
EffectTargetFilter — Class in package mx.effects
 | The EffectTargetFilter class defines a custom filter that is executed by each transition effect on each target of the effect.
EffectTargetFilter() — Constructor in class mx.effects.EffectTargetFilter
 | Constructor.
Elastic — Class in package mx.effects.easing
 | The Elastc class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
element — Property in class mx.charts.ChartItem
 | The series or element that owns the ChartItem.
element — Property in class mx.charts.HitData
 | Specifies the chart element rendering this data item that generated the HitData structure.
element — Property in class mx.charts.LegendItem
 | The chart element that is responsible for generating this legend item.
element — Property in class mx.charts.chartClasses.LegendData
 | The chart item that generated this legend item.
element — Property in class mx.charts.series.items.LineSeriesSegment
 | The series or element that owns this segment.
element — Property in class mx.charts.series.renderData.AreaSeriesRenderData
 | The AreaSeries that this structure is associated with.
elementBounds — Property in class mx.charts.chartClasses.RenderData
 | An Array of rectangles describing the bounds of the series's ChartItems, relative to the series's coordinate system.
ELEMENT_NODE — Constant static property in class flash.xml.XMLNodeType
 | Specifies that the node is an element.
elementOffset — Property in class mx.charts.effects.SeriesEffect
 | Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series.
elementOffset — Property in class mx.charts.effects.effectClasses.SeriesEffectInstance
 | Specifies the amount of time, in milliseconds, that Flex delays the start of the effect on each element in the series.
elements(name:Object) — Method in class XML
 | Lists the elements of an XML object.
elements(name:Object) — Method in class XMLList
 | Calls the elements() method of each XML object.
elements — Property in class mx.charts.chartClasses.DataTransform
 | The elements that are associated with this transform.
elements(name:String) — Method in class mx.collections.XMLListCollection
 | Calls the elements() method of each XML object in the XMLList.
else — Statement
 | Specifies the statements to run if the condition in the if statement returns false.
EmailValidator — Class in package mx.validators
 | The EmailValidator class validates that a String has a single @ sign, a period in the domain name and that the top-level domain suffix has two, three, four, or six characters.
EmailValidator() — Constructor in class mx.validators.EmailValidator
 | Constructor.
EMBEDDED — Constant static property in class flash.text.FontType
 | Indicates that this is an embedded font.
embeddedFontList — Property in class mx.managers.SystemManager
 | The list of embedded fonts in this application.
embedFonts — Property in class flash.text.TextField
 | Specifies whether to render by using embedded font outlines.
emphasized — Property in class mx.controls.Button
 | Draws a thick border around the Button control when the control is in its up state if emphasized is set to true.
EMPTY — Static property in class mx.core.EdgeMetrics
 | An EdgeMetrics object with a value of zero for its left, top, right, and bottom properties.
enableAutoUpdate() — Method in interface mx.collections.ICollectionView
 | Enables auto-updating.
enableAutoUpdate() — Method in class mx.collections.ListCollectionView
 | Enables auto-updating.
enabled — Property in class flash.display.MovieClip
 | A Boolean value that indicates whether a movie clip is enabled.
enabled — Property in class flash.display.SimpleButton
 | A Boolean value that specifies whether a button is enabled.
enabled — Static property in class flash.system.IME
 | Indicates whether the system IME is enabled (true) or disabled (false).
enabled — Property in class flash.ui.ContextMenuItem
 | Indicates whether the specified menu item is enabled or disabled.
enabled — Property in class mx.controls.RadioButtonGroup
 | Determines whether selection is allowed.
enabled — Property in interface mx.core.IUIComponent
 | Whether the component can accept user interaction.
enabled — Property in class mx.core.UIComponent
 | Whether the component can accept user interaction.
enabled — Property in class mx.core.UITextField
 | A Boolean value that indicates whether the component is enabled.
enabled — Static property in class mx.managers.ToolTipManager
 | If true, the ToolTipManager will automatically show ToolTips when the user moves the mouse pointer over components.
enabled — Property in class mx.validators.Validator
 | Setting this value to false will stop the validator from performing validation.
enablePolling() — Method in class mx.messaging.channels.PollingChannel
 | Enables polling based on the number of times enablePolling() and disablePolling() have been invoked.
encodeDate(rawDate:Date, dateType:String) — Static method in class mx.rpc.xml.SimpleXMLEncoder
encodeURI(uri) — Package function in Top Level
 | Encodes a string into a valid URI (Uniform Resource Identifier).
encodeURIComponent(uri) — Package function in Top Level
 | Encodes a string into a valid URI component.
encodeValue(obj:Object, qname:QName, parentNode:flash.xml:XMLNode) — Method in class mx.rpc.xml.SimpleXMLEncoder
 | parentNode - optional, an XMLNode under which to put the encoded value.
end — Property in class mx.charts.series.items.LineSeriesSegment
 | The index into the items array of the last item in this segment, inclusive.
end(effectInstance:mx.effects:EffectInstance) — Method in class mx.effects.Effect
 | Interrupts an effect that is currently playing, and jumps immediately to the end of the effect.
end() — Method in class mx.effects.EffectInstance
 | Interrupts an effect instance that is currently playing, and jumps immediately to the end of the effect.
end() — Method in class mx.effects.effectClasses.ParallelInstance
 | Interrupts any effects that are currently playing, skips over any effects that haven't started playing, and jumps immediately to the end of the composite effect.
end — Property in class mx.effects.effectClasses.PropertyChanges
 | An Object containing the ending properties of the target component modified by the change in view state.
end() — Method in class mx.effects.effectClasses.SequenceInstance
 | Interrupts any effects that are currently playing, skips over any effects that haven't started playing, and jumps immediately to the end of the composite effect.
end() — Method in class mx.effects.effectClasses.TweenEffectInstance
 | Interrupts an effect that is currently playing, and immediately jumps to the end of the effect.
end(target:flash.display:Graphics) — Method in interface mx.graphics.IFill
 | Ends the fill.
end(target:flash.display:Graphics) — Method in class mx.graphics.LinearGradient
 | Ends the fill.
end(target:flash.display:Graphics) — Method in class mx.graphics.RadialGradient
 | Ends the fill.
end(target:flash.display:Graphics) — Method in class mx.graphics.SolidColor
 | Ends the fill.
END — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the End key (35).
endEdit(reason:String) — Method in class mx.controls.List
 | Stops the editing of an item in the data provider.
endEffectsForTarget(target:mx.core:IUIComponent) — Static method in class mx.effects.EffectManager
 | Immediately ends any effects currently playing on a target.
endEffectsStarted() — Method in class mx.core.UIComponent
 | Ends all currently playing effects on the component.
endFill() — Method in class flash.display.Graphics
 | Applies a fill to the lines and curves that were added since the last call to the beginFill(), beginGradientFill(), or beginBitmapFill() method.
endian — Property in class flash.net.Socket
 | Indicates the byte order for the data; possible values are constants from the flash.utils.Endian class, Endian.BIG_ENDIAN or Endian.LITTLE_ENDIAN.
endian — Property in class flash.net.URLStream
 | Indicates the byte order for the data; possible values are BIG_ENDIAN or LITTLE_ENDIAN.
endian — Property in class flash.utils.ByteArray
 | Changes or reads the byte order for the data; either "bigEndian" or "littleEndian".
endian — Property in interface flash.utils.IDataInput
 | The byte order for the data, either the "bigEndian" or "littleEndian" constant from the Endian class.
endian — Property in interface flash.utils.IDataOutput
 | The byte order for the data, either the "bigEndian" or "littleEndian" constant from the Endian class.
Endian — Final class in package flash.utils
 | The Endian class contains values that denote the byte order used to represent multibyte numbers.
endIndex — Property in class mx.controls.textClasses.TextRange
 | Zero-based index in the control's text field of the point immediately after the last character in the range; equivalent to the One-based index of the last character.
endInterpolation(interpolationData:Object) — Method in class mx.charts.chartClasses.Series
 | Called by the SeriesInterpolate effect to end an interpolation.
endpoint — Property in class mx.messaging.Channel
 | Provides access to the endpoint for this channel.
endpoint — Property in class mx.rpc.remoting.mxml.RemoteObject
 | This property allows the developer to quickly specify an endpoint for a RemoteObject destination without referring to a services configuration file at compile time or programmatically creating a ChannelSet.
ENDPOINT_HEADER — Constant static property in class mx.messaging.messages.AbstractMessage
 | Messages are tagged with the endpoint id for the Channel they are sent over.
endpointURI — Property in class mx.rpc.soap.Operation
 | The location of the WebService for this Operation.
endpointURI — Property in class mx.rpc.soap.WebService
 | The location of the WebService.
endTween() — Method in class mx.effects.Tween
 | Interrupt the tween, jump immediately to the end of the tween, and invoke the onTweenEnd() callback function.
enter — Event in class mx.controls.ColorPicker
 | Dispatched if the ColorPicker editable property is set to true and the user presses Enter after typing in a hexadecimal color value.
enter — Event in class mx.controls.ComboBox
 | Dispatched if the editable property is set to true and the user presses the Enter key while typing in the editable text field.
enter — Event in class mx.controls.TextInput
 | Dispatched when the user presses the Enter key.
ENTER — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Enter key (13).
ENTER — Constant static property in class mx.events.ColorPickerEvent
 | The ColorPickerEvent.ENTER constant defines the value of the type property of the event that is dispatched when the user presses the Enter key after typing in the color selector box.
ENTER — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.ENTER constant defines the value of the type property of the event object for a enter event.
enterFrame — Event in class flash.display.DisplayObject
 | Dispatched when the playhead is entering a new frame.
ENTER_FRAME — Constant static property in class flash.events.Event
 | Defines the value of the type property of an enterFrame event object.
enterState — Event in class mx.core.UIComponent
 | Dispatched after the component has returned to the root view state.
enterState — Event in class mx.states.State
 | Dispatched when the view state has been entered.
ENTER_STATE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.ENTER_STATE constant defines the value of the type property of the event object for a enterState event.
enumerateFonts(enumerateDeviceFonts:Boolean) — Static method in class flash.text.Font
 | Specifies whether to provide a list of the currently available embedded fonts.
EOFError — Dynamic class in package flash.errors
 | An EOFError exception is thrown when you attempt to read past the end of the available data.
EOFError(message:String) — Constructor in class flash.errors.EOFError
 | Creates a new EOFError object.
equals(toCompare:flash.geom:Point) — Method in class flash.geom.Point
 | Determines whether two points are equal.
equals(toCompare:flash.geom:Rectangle) — Method in class flash.geom.Rectangle
 | Determines whether the object specified in the toCompare parameter is equal to this Rectangle object.
ERASE — Constant static property in class flash.display.BlendMode
 | Erases the background based on the alpha value of the display object.
error — Property in class flash.events.AsyncErrorEvent
 | The exception that was thrown.
error — Event in class mx.core.Application
 | Dispatched when an error occurs anywhere in the application, such as an HTTPService, WebService, or RemoteObject fails.
error — Property in class mx.formatters.Formatter
 | Description saved by the formatter when an error occurs.
error(message:String, ... rest) — Method in interface mx.logging.ILogger
 | Logs the specified data using the LogEventLevel.ERROR level.
error(message:String, ... rest) — Method in class mx.logging.LogLogger
 | Logs the specified data using the LogEventLevel.ERROR level.
Error — Dynamic class in Top Level
 | The Error class contains information about an error that occurred in a script.
Error(message:String, id:int) — Constructor in class Error
 | Creates a new Error object.
ERROR — Constant static property in class flash.events.ErrorEvent
 | Defines the value of the type property of an error event object.
ERROR — Constant static property in class mx.logging.LogEventLevel
 | Designates error events that might still allow the application to continue running.
errorCode — Property in class mx.validators.ValidationResult
 | The validation error code if the value of the isError property is true.
errorColor — Style in class mx.core.UIComponent
 | Color of the component highlight when validation fails..
ERROR_DECODING — Constant static property in class mx.rpc.http.HTTPService
 | Indicates that an XML formatted result could not be parsed into an XML instance or decoded into an Object.
ERROR_ENCODING — Constant static property in class mx.rpc.http.HTTPService
 | Indicates that an input parameter could not be encoded as XML.
ErrorEvent — Class in package flash.events
 | Flash® Player dispatches ErrorEvent objects when an error causes a network operation to fail.
ErrorEvent(type:String, bubbles:Boolean, cancelable:Boolean, text:String) — Constructor in class flash.events.ErrorEvent
 | Creates an Event object that contains information about error events.
ERROR_HINT_HEADER — Constant static property in class mx.messaging.messages.AcknowledgeMessage
 | Header name for the error hint header.
errorID — Property in class Error
 | Contains the reference number associated with the specific error message.
errorMessage — Property in class mx.validators.ValidationResult
 | The validation error message if the value of the isError property is true.
ErrorMessage — Class in package mx.messaging.messages
 | The ErrorMessage class is used to report errors within the messaging system.
ErrorMessage() — Constructor in class mx.messaging.messages.ErrorMessage
 | Constructs an ErrorMessage instance.
errorString — Property in class mx.core.UIComponent
 | The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails.
errorString — Property in interface mx.validators.IValidatorListener
 | The text that will be displayed by a component's error tip when a component is monitored by a Validator and validation fails.
errorText — Property in class mx.events.RSLEvent
 | The error message if the type is RSL_ERROR; otherwise, it is null;
ERROR_URL_REQUIRED — Constant static property in class mx.rpc.http.HTTPService
 | Indicates that the useProxy property was set to false but a url was not provided.
escape(str) — Package function in Top Level
 | Converts the parameter to a string and encodes it in a URL-encoded format, where most nonalphanumeric characters are replaced with % hexadecimal sequences.
ESCAPE — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Escape key (27).
escapeMultiByte(value) — Package function in flash.utils
 | Returns an escaped copy of the input string encoded as either UTF-8 or system code page, depending on the value of System.useCodePage.
EvalError — Dynamic class in Top Level
 | The EvalError class represents an error that occurs when user code calls the eval() function or attempts to use the new operator with the Function object.
EvalError(message:String) — Constructor in class EvalError
 | Creates a new EvalError object.
Event — Class in package flash.events
 | The Event class is used as the base class for the creation of Event objects, which are passed as parameters to event listeners when an event occurs.
Event(type:String, bubbles:Boolean, cancelable:Boolean) — Constructor in class flash.events.Event
 | Creates an Event object to pass as a parameter to event listeners.
EVENT — Constant static property in class mx.controls.ProgressBarMode
 | The control specified by the source property must dispatch progress and completed events.
EventDispatcher — Class in package flash.events
 | The EventDispatcher class implements the IEventDispatcher interface and is the base class for the DisplayObject class.
EventDispatcher(target:flash.events:IEventDispatcher) — Constructor in class flash.events.EventDispatcher
 | Aggregates an instance of the EventDispatcher class.
eventPhase — Property in class flash.events.Event
 | The current phase in the event flow.
EventPhase — Final class in package flash.events
 | The EventPhase class provides values for the eventPhase property of the Event class.
EventPriority — Final class in package mx.core
 | The EventPriority class defines constant values for the priority argument of the addEventListener() method of EventDispatcher.
events — Property in class mx.core.ComponentDescriptor
 | An Object containing name/value pairs for the component's event handlers, as specified in MXML.
every(callback:Function, thisObject) — Method in class Array
 | Executes a test function on each item in the array until an item is reached that returns false for the specified function.
EXACT_FIT — Constant static property in class flash.display.StageScaleMode
 | Specifies that the entire Adobe® Flash® application be visible in the specified area without trying to preserve the original aspect ratio.
exactSettings — Static property in class flash.system.Security
 | Determines how Flash Player chooses the domain to use for certain Flash Player settings, including settings for camera and microphone permissions, storage quotas, and storage of persistent shared objects.
exceedsMaxError — Property in class mx.validators.CurrencyValidator
 | Error message when the value is greater than maxValue.
exceedsMaxError — Property in class mx.validators.NumberValidator
 | Error message when the value exceeds the maxValue property.
exec(str:String) — Method in class RegExp
 | Performs a search for the regular expression on the given string str.
EXEC_QUEUED_CMD — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property during execution of queued command.
executeBindings(recurse:Boolean) — Method in class mx.core.Container
 | Executes all the data bindings on this Container.
executeBindings(recurse:Boolean) — Method in interface mx.core.IDeferredInstantiationUIComponent
 | Executes the data bindings into this UIComponent object.
executeBindings(recurse:Boolean) — Method in class mx.core.UIComponent
 | Executes the data bindings into this UIComponent object.
executeChildBindings(recurse:Boolean) — Method in class mx.core.Container
 | Executes the bindings into this Container's child UIComponent objects.
executeChildBindings() — Method in interface mx.core.IRepeater
 | Executes the bindings into all the UIComponents created by this Repeater.
executeChildBindings() — Method in class mx.core.Repeater
 | Executes the bindings into all the UIComponents created by this Repeater.
exitState — Event in class mx.core.UIComponent
 | Dispatched before the component exits from the root view state.
exitState — Event in class mx.states.State
 | Dispatched before a view state is exited.
EXIT_STATE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.EXIT_STATE constant defines the value of the type property of the event object for a exitState event.
exp(val:Number) — Static method in class Math
 | Returns the value of the base of the natural logarithm (e), to the power of the exponent specified in the parameter x.
expandChildrenOf(item:Object, open:Boolean) — Method in class mx.controls.Tree
 | Opens or closes all the tree items below the specified item.
expandItem(item:Object, open:Boolean, animate:Boolean, dispatchEvent:Boolean, cause:flash.events:Event) — Method in class mx.controls.Tree
 | Opens or closes a branch item.
explicitColumnCount — Property in class mx.controls.listClasses.ListBase
 | The column count requested by explicitly setting the columnCount property.
explicitColumnWidth — Property in class mx.controls.listClasses.ListBase
 | The column width requested by explicitly setting the columnWidth.
explicitHeight — Property in interface mx.core.IUIComponent
 | The explicitly specified height for the component, in pixels, as the component's coordinates.
explicitHeight — Property in class mx.core.UIComponent
 | Number that specifies the explicit height of the component, in pixels, in the component's coordinates.
explicitHeight — Property in class mx.core.UITextField
 | Number that specifies the explicit height of the component, in pixels, in the component's coordinates.
explicitHeight — Property in class mx.managers.SystemManager
 | The explicit width of this object.
explicitMaxHeight — Property in interface mx.core.IUIComponent
 | Number that specifies the maximum height of the component, in pixels, as the component's coordinates.
explicitMaxHeight — Property in class mx.core.UIComponent
 | Number that specifies the maximum height of the component, in pixels, in the component's coordinates.
explicitMaxHeight — Property in class mx.core.UITextField
 | Number that specifies the maximum height of the component, in pixels, in the component's coordinates.
explicitMaxWidth — Property in interface mx.core.IUIComponent
 | Number that specifies the maximum width of the component, in pixels, as the component's coordinates.
explicitMaxWidth — Property in class mx.core.UIComponent
 | Number that specifies the maximum width of the component, in pixels, in the component's coordinates.
explicitMaxWidth — Property in class mx.core.UITextField
 | Number that specifies the maximum width of the component, in pixels, in the component's coordinates.
explicitMinHeight — Property in interface mx.core.IUIComponent
 | Number that specifies the minimum height of the component, in pixels, as the component's coordinates.
explicitMinHeight — Property in class mx.core.UIComponent
 | Number that specifies the minimum height of the component, in pixels, in the component's coordinates.
explicitMinHeight — Property in class mx.core.UITextField
 | Number that specifies the minimum height of the component, in pixels, in the component's coordinates.
explicitMinWidth — Property in interface mx.core.IUIComponent
 | Number that specifies the minimum width of the component, in pixels, as the component's coordinates.
explicitMinWidth — Property in class mx.core.UIComponent
 | Number that specifies the minimum width of the component, in pixels, in the component's coordinates.
explicitMinWidth — Property in class mx.core.UITextField
 | Number that specifies the minimum width of the component, in pixels, in the component's coordinates.
explicitRowCount — Property in class mx.controls.listClasses.ListBase
 | The row count requested by explicitly setting rowCount.
explicitRowHeight — Property in class mx.controls.listClasses.ListBase
 | The row height requested by explicitly setting rowHeight.
explicitWidth — Property in interface mx.core.IUIComponent
 | The explicitly specified width for the component, in pixels, as the component's coordinates.
explicitWidth — Property in class mx.core.UIComponent
 | Number that specifies the explicit width of the component, in pixels, in the component's coordinates.
explicitWidth — Property in class mx.core.UITextField
 | Number that specifies the explicit width of the component, in pixels, in the component's coordinates.
explicitWidth — Property in class mx.managers.SystemManager
 | The explicit width of this object.
explodeRadius — Property in class mx.charts.series.PieSeries
 | A number from 0 to 1, specifying how far all wedges of the pie series should be exploded from the center of the chart as a percentage of the total radius.
Exponential — Class in package mx.effects.easing
 | The Exponential class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by an exponentially decaying sine wave.
expression — Property in class mx.validators.RegExpValidator
 | The regular expression to use for validation.
extended — Property in class RegExp
 | Specifies whether to use extended mode for the regular expression.
extendedData — Property in class mx.messaging.messages.ErrorMessage
 | Extended data that the remote destination has chosen to associate with this error to facilitate custom error processing on the client.
extends — Statement
 | Defines a class that is a subclass of another class.
extension — Property in class flash.net.FileFilter
 | A list of file extensions.
ExternalInterface — Final class in package flash.external
 | The ExternalInterface class is the External API, an application programming interface that enables straightforward communication between ActionScript and the Flash Player container; for example, an HTML page with JavaScript, or a desktop application with Flash Player embedded.
extractMinInterval(cache:Array, measureName:String, desc:mx.charts.chartClasses:DataDescription) — Method in class mx.charts.chartClasses.Series
 | Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
extractMinMax(cache:Array, measureName:String, desc:mx.charts.chartClasses:DataDescription, calculateInterval:Boolean) — Method in class mx.charts.chartClasses.Series
 | Extracts the minimum value, maximum value, and, optionally, the minimum interval from an array of ChartItems.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


F Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
F Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
F1 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F1 key (112).
F10 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F10 key (121).
F11 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F11 key (122).
F12 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F12 key (123).
F13 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F13 key (124).
F14 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F14 key (125).
F15 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F15 key (126).
F2 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F2 key (113).
F3 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F3 key (114).
F4 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F4 key (115).
F5 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F5 key (116).
F6 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F6 key (117).
F7 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F7 key (118).
F8 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F8 key (119).
F9 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the F9 key (120).
factory — Property in class mx.charts.chartClasses.InstanceCache
 | A factory that generates the type of object to cache.
factory — Property in class mx.styles.CSSStyleDeclaration
 | This function, if it isn't null, is usually autogenerated by the MXML compiler.
Fade — Class in package mx.effects
 | The Fade effect animates the alpha property of a component, either from transparent to opaque, or from opaque to transparent.
Fade(target:Object) — Constructor in class mx.effects.Fade
 | Constructor.
FadeInstance — Class in package mx.effects.effectClasses
 | The FadeInstance class implements the instance class for the Fade effect.
FadeInstance(target:Object) — Constructor in class mx.effects.effectClasses.FadeInstance
 | Constructor.
failoverURIs — Property in class mx.messaging.Channel
 | Provides access to the set of endpoint URIs that this channel can attempt to failover to if the endpoint is clustered.
false — Statement
 | A Boolean value representing false.
fatal(message:String, ... rest) — Method in interface mx.logging.ILogger
 | Logs the specified data using the LogEventLevel.FATAL level.
fatal(message:String, ... rest) — Method in class mx.logging.LogLogger
 | Logs the specified data using the LogEventLevel.FATAL level.
FATAL — Constant static property in class mx.logging.LogEventLevel
 | Designates events that are very harmful and will eventually lead to application failure.
fault(info:Object) — Method in class mx.collections.ItemResponder
 | This method is called by a service when an error has been received.
fault — Event in class mx.data.DataService
 | The DataServiceFaultEvent.FAULT event is dispatched when a service call fails due to an error.
fault — Event in class mx.data.DataStore
 | The FaultEvent.FAULT event is dispatched when the commit call returns an error.
fault — Event in class mx.messaging.MessageAgent
 | Dispatched when a message fault occurs.
fault(errMsg:mx.messaging.messages:ErrorMessage, msg:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageAgent
 | Invoked by a MessageResponder upon receiving a fault for a sent message.
fault — Property in class mx.messaging.errors.MessageSerializationError
 | Provides specific information about the fault that occurred and for which message.
fault — Event in class mx.rpc.AbstractOperation
 | Dispatched when an Operation call fails.
fault — Event in class mx.rpc.AbstractService
 | The fault event is dispatched when a service call fails and isn't handled by the Operation itself.
fault(info:Object) — Method in interface mx.rpc.IResponder
 | This method is called by a service when an error has been received.
fault — Property in class mx.rpc.events.FaultEvent
 | The Fault object that contains the details of what caused this event.
fault — Event in class mx.rpc.http.HTTPService
 | Dispatched when an HTTPService call fails.
Fault — Class in package mx.rpc
 | Object that represents a fault in an remote procedure call (RPC) service invocation.
Fault(faultCode:String, faultString:String, faultDetail:String) — Constructor in class mx.rpc.Fault
 | Creates a new Fault object.
FAULT — Constant static property in class mx.data.events.DataServiceFaultEvent
 | The FAULT event type.
FAULT — Constant static property in class mx.data.events.UnresolvedConflictsEvent
 | The FAULT event type.
FAULT — Constant static property in class mx.messaging.events.ChannelFaultEvent
 | The FAULT event type; indicates that the Channel faulted.
FAULT — Constant static property in class mx.messaging.events.MessageFaultEvent
 | The FAULT event type; dispatched for a message fault.
FAULT — Constant static property in class mx.rpc.events.FaultEvent
 | The FAULT event type.
faultCode — Property in class mx.messaging.events.ChannelFaultEvent
 | Provides access to the destination-specific failure code.
faultCode — Property in class mx.messaging.events.MessageFaultEvent
 | Provides access to the destination specific failure code.
faultCode — Property in class mx.messaging.messages.ErrorMessage
 | The fault code for the error.
faultCode — Property in class mx.rpc.Fault
 | A simple code describing the fault.
faultDetail — Property in class mx.messaging.events.ChannelFaultEvent
 | Provides destination-specific details of the failure.
faultDetail — Property in class mx.messaging.events.MessageFaultEvent
 | Provides destination specific details of the failure.
faultDetail — Property in class mx.messaging.messages.ErrorMessage
 | Detailed description of what caused the error.
faultDetail — Property in class mx.rpc.Fault
 | Any extra details of the fault.
FaultEvent — Class in package mx.rpc.events
 | This event is dispatched when an RPC call has a fault.
FaultEvent(type:String, bubbles:Boolean, cancelable:Boolean, fault:mx.rpc:Fault, token:mx.rpc:AsyncToken, message:mx.messaging.messages:IMessage) — Constructor in class mx.rpc.events.FaultEvent
 | Create a new FaultEvent.
faultString — Property in class mx.messaging.events.ChannelFaultEvent
 | Provides access to the destination-specific reason for the failure.
faultString — Property in class mx.messaging.events.MessageFaultEvent
 | Provides access to the destination specific reason for the failure.
faultString — Property in class mx.messaging.messages.ErrorMessage
 | A simple description of the error.
faultString — Property in class mx.rpc.Fault
 | Text description of the fault.
field — Property in class mx.charts.series.PieSeries
 | Specifies the field of the data provider that determines the data for each wedge of the PieChart control.
field — Property in class mx.events.ValidationResultEvent
 | The name of the field that failed validation and triggered the event.
fields — Property in class mx.collections.Sort
 | An Array of SortField objects that specifies the fields to compare.
fieldSeparator — Property in class mx.logging.targets.LineFormattedTarget
 | The separator string to use between fields (the default is " ")
FileFilter — Final class in package flash.net
 | The FileFilter class is used to indicate what files on the user's system are shown in the file-browsing dialog box that is displayed when FileReference.browse() or FileReferenceList.browse() is called.
FileFilter(description:String, extension:String, macType:String) — Constructor in class flash.net.FileFilter
 | Creates a new FileFilter instance.
fileList — Property in class flash.net.FileReferenceList
 | An array of FileReference objects.
FileReference — Class in package flash.net
 | The FileReference class provides a means to upload and download files between a user's computer and a server.
FileReference() — Constructor in class flash.net.FileReference
 | Creates a new FileReference object.
FileReferenceList — Class in package flash.net
 | The FileReferenceList class provides a means to let users select one or more files for uploading.
FileReferenceList() — Constructor in class flash.net.FileReferenceList
 | Creates a new FileReferenceList object.
fill — Style in class mx.charts.LegendItem
 | Specifies an IFill object that defines the fill for the legend element.
fill — Style in class mx.charts.chartClasses.ChartBase
 | Specifies the fill style used for the chart background.
fill — Style in class mx.charts.series.AreaSeries
 | Sets the fill for this data series.
fill — Style in class mx.charts.series.BarSeries
 | Sets the fill for this data series.
fill — Style in class mx.charts.series.BubbleSeries
 | Sets the fill for this data series.
fill — Style in class mx.charts.series.CandlestickSeries
 | Sets the fill for this data series.
fill — Style in class mx.charts.series.ColumnSeries
 | Sets the fill for this data series.
fill — Style in class mx.charts.series.LineSeries
 | Sets the fill for this data series.
fill — Style in class mx.charts.series.PlotSeries
 | Sets the fill for this data series.
fill — Property in class mx.charts.series.items.PieSeriesItem
 | The fill value associated with this wedge of the PieChart control.
fill(value:mx.collections:ListCollectionView, ... rest) — Method in class mx.data.DataService
 | Fills the specified ListCollectionView based on the associated <fill-method> elements.
fill(value:mx.collections:ListCollectionView, ... rest) — Method in class mx.data.mxml.DataService
 | Fills the specified ListCollectionView based on the associated <fill-method> elements.
fillAlphas — Style in class mx.containers.Accordion
 | Specifies the alpha transparency values used for the background fill of components.
fillAlphas — Style in class mx.containers.ApplicationControlBar
 | Alpha values used for the background fill of the container.
fillAlphas — Style in class mx.containers.TabNavigator
 | Specifies the alpha transparency values used for the background fill of components.
fillAlphas — Style in class mx.controls.Button
 | Alphas used for the background fill of controls.
fillAlphas — Style in class mx.controls.ColorPicker
 | Alphas used for the background fill of controls.
fillAlphas — Style in class mx.controls.ComboBox
 | Alphas used for the background fill of controls.
fillAlphas — Style in class mx.controls.DateChooser
 | Alphas used for the background fill of controls.
fillAlphas — Style in class mx.controls.DateField
 | Alphas used for the background fill of controls.
fillAlphas — Style in class mx.controls.MenuBar
 | Alphas used for the background fill of controls.
fillAlphas — Style in class mx.controls.scrollClasses.ScrollBar
 | Alphas used for the background fill of controls.
fillAlphas — Style in class mx.controls.sliderClasses.Slider
 | Specifies the alpha transparency values used for the background fill of components.
fillColors — Style in class mx.containers.Accordion
 | Specifies the colors used to tint the background fill of the component.
fillColors — Style in class mx.containers.ApplicationControlBar
 | Colors used to tint the background of the container.
fillColors — Style in class mx.containers.TabNavigator
 | Specifies the colors used to tint the background fill of the component.
fillColors — Style in class mx.controls.Button
 | Colors used to tint the background of the control.
fillColors — Style in class mx.controls.ColorPicker
 | Colors used to tint the background of the control.
fillColors — Style in class mx.controls.ComboBox
 | Colors used to tint the background of the control.
fillColors — Style in class mx.controls.DateChooser
 | Colors used to tint the background of the control.
fillColors — Style in class mx.controls.DateField
 | Colors used to tint the background of the control.
fillColors — Style in class mx.controls.MenuBar
 | Colors used to tint the background of the control.
fillColors — Style in class mx.controls.scrollClasses.ScrollBar
 | Colors used to tint the background of the control.
fillColors — Style in class mx.controls.sliderClasses.Slider
 | Colors used to tint the slider thumb.
fillColors — Style in class mx.controls.sliderClasses.Slider
 | Specifies the colors used to tint the background fill of the component.
FILL_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation requests that the remote destination create a sequence using the remote destination's adapter.
FILL_PAGE — Constant static property in class mx.printing.FlexPrintJobScaleType
 | Scales the object to fill at least one page completely; that is, it selects the larger of the MATCH_WIDTH or MATCH_HEIGHT scale types.
fillRect(rect:flash.geom:Rectangle, color:uint) — Method in class flash.display.BitmapData
 | Fills a rectangular area of pixels with a specified ARGB color.
fills — Style in class mx.charts.series.PieSeries
 | Specifies an array of fill objects used to render each wedge of the PieChart control.
filter(callback:Function, thisObject) — Method in class Array
 | Executes a test function on each item in the array and constructs a new array for all items that return true for the specified function.
filter — Property in class mx.effects.Effect
 | Specifies an algorithm for filtering targets for an effect.
filterCache(cache:Array, field:String, filteredString:String) — Method in class mx.charts.CategoryAxis
 | Filters a set of values of arbitrary type to a set of numbers that can be mapped.
filterCache(cache:Array, field:String, filteredString:String) — Method in interface mx.charts.chartClasses.IAxis
 | Filters a set of values of arbitrary type to a set of numbers that can be mapped.
filterCache(cache:Array, field:String, filteredString:String) — Method in class mx.charts.chartClasses.NumericAxis
 | Filters a set of values of arbitrary type to a set of numbers that can be mapped.
filterData — Property in class mx.charts.chartClasses.Series
 | This property is true if the series filters its data before displaying.
filteredCache — Property in class mx.charts.chartClasses.RenderData
 | The list of ChartItems representing the items in the series's dataProvider that remain after filtering.
filterFunction — Property in interface mx.collections.ICollectionView
 | A function that the view will use to eliminate items that do not match the function's criteria.
filterFunction — Property in class mx.collections.ListCollectionView
 | A function that the view will use to eliminate items that do not match the function's criteria.
filterFunction — Property in class mx.effects.EffectTargetFilter
 | A function that defines custom filter logic.
filterInstance(propChanges:Array, targ:Object) — Method in class mx.effects.Effect
 | Determines the logic for filtering out an effect instance.
filterProperties — Property in class mx.effects.EffectTargetFilter
 | An Array of Strings specifying component properties.
filters — Property in class flash.display.DisplayObject
 | An indexed array that contains each filter object currently associated with the display object.
filters — Property in class mx.logging.AbstractTarget
 | In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category.
filters — Property in interface mx.logging.ILoggingTarget
 | In addition to the level setting, filters are used to provide a psuedo-hierarchical mapping for processing only those events for a given category.
filterStyles — Property in class mx.effects.EffectTargetFilter
 | An Array of Strings specifying style properties.
final — Statement
 | Specifies that a method cannot be overridden or that a class cannot be extended.
findAny(values:Object) — Method in interface mx.collections.IViewCursor
 | Finds an item with the specified properties within the collection and positions the cursor to that item.
findDataPoints(x:Number, y:Number) — Method in class mx.charts.chartClasses.ChartBase
 | Returns an Array of HitData objects that describe the nearest data point to the coordinates passed to the method.
findDataPoints(x:Number, y:Number, sensitivity2:Number) — Method in class mx.charts.chartClasses.ChartElement
 | Finds the closest data point represented by the element under the given coordinates.
findDataPoints(x:Number, y:Number, sensitivity2:Number) — Method in interface mx.charts.chartClasses.IChartElement
 | Returns a HitData object describing the nearest data point to the coordinates passed to the method.
findDataPoints(x:Number, y:Number, sensitivity2:Number) — Method in class mx.charts.series.BubbleSeries
 | Finds the closest data point represented by the element under the given coordinates.
findDataPoints(x:Number, y:Number, sensitivity:Number) — Method in class mx.charts.series.CandlestickSeries
findFirst(values:Object) — Method in interface mx.collections.IViewCursor
 | Finds the first item with the specified properties within the collection and positions the cursor to that item.
findFocusManagerComponent(o:flash.display:InteractiveObject) — Method in class mx.managers.FocusManager
 | Returns the IFocusManagerComponent that contains the given object, if any.
findFocusManagerComponent(o:flash.display:InteractiveObject) — Method in interface mx.managers.IFocusManager
 | Returns the IFocusManagerComponent that contains the given object, if any.
findItem(items:Array, values:Object, mode:String, returnInsertionIndex:Boolean, compareFunction:Function) — Method in class mx.collections.Sort
 | Finds the specified object within the specified array (or the insertion point if asked for), returning the index if found or -1 if not.
findKey(eventCode:int) — Method in class mx.controls.listClasses.ListBase
 | Tries to find the next item in the data provider that starts with the character in the eventCode parameter.
findLast(values:Object) — Method in interface mx.collections.IViewCursor
 | Finds the last item with the specified properties within the collection and positions the cursor on that item.
findString(str:String) — Method in class mx.controls.listClasses.ListBase
 | Finds an item in the list based on a string and moves the selection to it.
findText(beginIndex:int, textToFind:String, caseSensitive:Boolean) — Method in class flash.text.TextSnapshot
 | Searches the specified TextSnapshot object and returns the position of the first occurrence of textToFind found at or after beginIndex.
finishEffect() — Method in class mx.effects.EffectInstance
 | Called by the end() method when the effect finishes playing.
finishKeySelection() — Method in class mx.controls.listClasses.ListBase
 | Sets selected items based on the caretIndex and anchorIndex properties.
finishPrint(obj:Object, target:mx.core:IFlexDisplayObject) — Method in class mx.core.UIComponent
 | Called after printing is complete.
finishRepeat() — Method in class mx.effects.EffectInstance
 | Called after each iteration of a repeated effect finishes playing.
FIRST — Static property in class mx.collections.CursorBookmark
 | A bookmark for the first item in an ICollectionView.
firstButtonStyleName — Style in class mx.controls.ButtonBar
 | Name of CSS style declaration that specifies styles for the first button.
firstChild — Property in class flash.xml.XMLNode
 | Evaluates the specified XMLDocument object and references the first child in the parent node's child list.
firstDayOfWeek — Property in class mx.controls.DateChooser
 | Number representing the day of the week to display in the first column of the DateChooser control.
firstDayOfWeek — Property in class mx.controls.DateField
 | Day of the week (0-6, where 0 is the first element of the dayNames Array) to display in the first column of the DateChooser control.
FIRST_INDEX_MODE — Constant static property in class mx.collections.Sort
 | When executing a find return the index for the first matching item.
firstTabStyleName — Style in class mx.containers.TabNavigator
 | Name of CSS style declaration that specifies styles for the first tab.
firstTabStyleName — Style in class mx.controls.TabBar
 | Name of CSS style declaration that specifies the styles to use for the first tab navigation item.
firstVisibleItem — Property in class mx.controls.Tree
 | The item that is currently displayed in the top row of the tree.
flags — Property in class mx.validators.RegExpValidator
 | The regular expression flags to use when matching.
FLASH1 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 1.0.
FLASH2 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 2.0.
FLASH3 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 3.0.
FLASH4 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 4.0.
FLASH5 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 5.0.
FLASH6 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 6.0.
FLASH7 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 7.0.
FLASH8 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 8.0.
FLASH9 — Constant static property in class flash.display.SWFVersion
 | SWF file format version 9.0.
flash.accessibility — Package
 | The flash.accessibility package contains classes for supporting accessibility in Flash content and applications.
flash.display — Package
 | The flash.display package contains the core classes that the Flash Player uses to build visual displays.
flash.errors — Package
 | The flash.errors package contains a set of commonly used error classes.
flash.events — Package
 | The flash.events package supports the new DOM event model and includes the EventDispatcher base class.
flash.external — Package
 | The flash.external package contains the ExternalInterface class which can be used to communicate with the Flash Player's container.
flash.filters — Package
 | The flash.filters package contains classes for bitmap filter effects.
flash.geom — Package
 | The flash.geom package contains geometry classes, such as points, rectangles and transformation matrixes, to support the BitmapData class and the bitmap caching feature.
flash.media — Package
 | The flash.media package contains classes for working with multimedia assets such as sound and video.
flash.net — Package
 | The flash.net package contains classes for sending and receiving from the network, such as URL downloading and Flash Remoting.
flash.printing — Package
 | The flash.printing package contains classes for printing Flash-based content.
flash.profiler — Package
 | The flash.profiler package contains functions used for debugging and profiling ActionScript code.
flash_proxy — Statement
 | Defines methods of the Proxy class.
flash.system — Package
 | The flash.system package contains classes for accessing system-level functionality, such as security, multilanguage content, etc.
flash.text — Package
 | The flash.text package contains classes for working with text fields, text formatting, text metrics, style sheets, and layout.
flash.ui — Package
 | The flash.ui package contains user interface classes, such as classes for interacting with the mouse and keyboard.
flash.utils — Package
 | The flash.utils package contains utility classes, such as data structures like ByteArray.
flash.xml — Package
 | The flash.xml package contains Flash Player's legacy XML support, and other Flash Player-specific XML functionality.
FlexBitmap — Class in package mx.core
 | FlexBitmap is a subclass of the Player's Bitmap class.
FlexBitmap(bitmapData:flash.display:BitmapData, pixelSnapping:String, smoothing:Boolean) — Constructor in class mx.core.FlexBitmap
 | Constructor.
FlexEvent — Class in package mx.events
 | The FlexEvent class represents the event object passed to the event listener for many Flex events.
FlexEvent(type:String, bubbles:Boolean, cancelable:Boolean) — Constructor in class mx.events.FlexEvent
 | Constructor.
FlexMouseEvent — Class in package mx.events
 | The FlexMouseEvent class represents the event object passed to the event listener for Flex-specific mouse activity.
FlexMouseEvent(type:String, bubbles:Boolean, cancelable:Boolean, localX:Number, localY:Number, relatedObject:flash.display:InteractiveObject, ctrlKey:Boolean, altKey:Boolean, shiftKey:Boolean, buttonDown:Boolean, delta:int) — Constructor in class mx.events.FlexMouseEvent
 | Constructor.
FlexMovieClip — Class in package mx.core
 | FlexMovieClip is a subclass of the Player's MovieClip class.
FlexMovieClip() — Constructor in class mx.core.FlexMovieClip
 | Constructor.
FlexPrintJob — Class in package mx.printing
 | The FlexPrintJob class is a wrapper over the Flash Player's PrintJob API.
FlexPrintJob() — Constructor in class mx.printing.FlexPrintJob
 | Constructor.
FlexPrintJobScaleType — Final class in package mx.printing
 | Values for the scaleType property of the FlexPrintJob.addObject() method parameter.
FlexShape — Class in package mx.core
 | FlexShape is a subclass of the Player's Shape class.
FlexShape() — Constructor in class mx.core.FlexShape
 | Constructor.
FlexSimpleButton — Class in package mx.core
 | FlexSimpleButton is a subclass of the Player's SimpleButton class.
FlexSimpleButton() — Constructor in class mx.core.FlexSimpleButton
 | Constructor.
FlexSprite — Class in package mx.core
 | FlexSprite is a subclass of the Player's Sprite class and the superclass of UIComponent.
FlexSprite() — Constructor in class mx.core.FlexSprite
 | Constructor.
FlexTextField — Class in package mx.core
 | FlexTextField is a subclass of the Player's TextField class and the superclass of UITextField.
FlexTextField() — Constructor in class mx.core.FlexTextField
 | Constructor.
floodFill(x:int, y:int, color:uint) — Method in class flash.display.BitmapData
 | Performs a flood fill operation on an image starting at an (x, y) coordinate and filling with a certain color.
floor(val:Number) — Static method in class Math
 | Returns the floor of the number or expression specified in the parameter val.
flush(minDiskSpace:int) — Method in class flash.net.SharedObject
 | Immediately writes a locally persistent shared object to a local file.
flush() — Method in class flash.net.Socket
 | Flushes any accumulated data in the socket's output buffer.
flush() — Static method in class mx.logging.Log
 | This method removes all of the current loggers from the cache.
FLUSHED — Constant static property in class flash.net.SharedObjectFlushStatus
 | Indicates that the flush completed successfully.
focalPointRatio — Property in class mx.graphics.RadialGradient
 | Sets the location of the start of the radial fill.
focus — Property in class flash.display.Stage
 | The interactive object with keyboard focus; or null if focus is not set or if the focused object belongs to a security sandbox to which the calling object does not have access.
focusAlpha — Style in class mx.containers.Accordion
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.containers.TabNavigator
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.Button
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.ButtonBar
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.ColorPicker
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.ComboBox
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.DateChooser
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.DateField
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.MenuBar
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.NumericStepper
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.TextArea
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.TextInput
 | Specifies the alpha transparency value of the focus skin.
focusAlpha — Style in class mx.controls.listClasses.ListBase
 | Specifies the alpha transparency value of the focus skin.
focusBlendMode — Style in class mx.core.UIComponent
 | Blend mode used by the focus rectangle.
focusEnabled — Property in class mx.core.UIComponent
 | Indicates whether the component can receive focus when clicked on.
focusEnabled — Property in interface mx.managers.IFocusManagerComponent
 | A flag that indicates whether the component can receive focus when selected.
FocusEvent — Class in package flash.events
 | Flash® Player dispatches FocusEvent objects when the user changes the focus from one object in the display list to another.
FocusEvent(type:String, bubbles:Boolean, cancelable:Boolean, relatedObject:flash.display:InteractiveObject, shiftKey:Boolean, keyCode:uint) — Constructor in class flash.events.FocusEvent
 | Creates an Event object with specific information relevant to focus events.
focusIn — Event in class flash.display.InteractiveObject
 | Dispatched after a display object gains focus.
FOCUS_IN — Constant static property in class flash.events.FocusEvent
 | Defines the value of the type property of a focusIn event object.
focusInEffect — Effect in class mx.core.UIComponent
 | Played when the component gains keyboard focus.
focusInHandler(event:flash.events:FocusEvent) — Method in class mx.core.UIComponent
 | The event handler called when a UIComponent object gets focus.
focusManager — Property in class mx.core.UIComponent
 | Gets the FocusManager that controls focus for this component and its peers.
focusManager — Property in interface mx.managers.IFocusManagerContainer
 | The FocusManager for this component.
FocusManager — Class in package mx.managers
 | The FocusManager class manages the focus on components in response to mouse activity or keyboard activity (Tab key).
FocusManager(container:mx.managers:IFocusManagerContainer, popup:Boolean) — Constructor in class mx.managers.FocusManager
 | Constructor.
focusOut — Event in class flash.display.InteractiveObject
 | Dispatched after a display object loses focus.
FOCUS_OUT — Constant static property in class flash.events.FocusEvent
 | Defines the value of the type property of a focusOut event object.
focusOutEffect — Effect in class mx.core.UIComponent
 | Played when the component loses keyboard focus.
focusOutHandler(event:flash.events:FocusEvent) — Method in class mx.core.UIComponent
 | The event handler called when a UIComponent object loses focus.
focusPane — Property in interface mx.core.IUIComponent
 | A single Sprite object that is shared among components and used as an overlay for drawing focus.
focusPane — Property in class mx.core.UIComponent
 | The focus pane associated with this object.
focusPane — Property in class mx.core.UITextField
 | A single Sprite object that is shared among components and used as an overlay for drawing focus.
focusPane — Property in class mx.managers.FocusManager
 | A single Sprite that is moved from container to container as the focus moves to those containers.
focusPane — Property in interface mx.managers.IFocusManager
 | A single Sprite that is moved from container to container as the focus moves to those containers.
focusPane — Property in interface mx.managers.ISystemManager
 | A single Sprite shared among components used as an overlay for drawing focus.
focusPane — Property in class mx.managers.SystemManager
 | The focus pane associated with this object.
focusRect — Property in class flash.display.InteractiveObject
 | Specifies whether this object displays a focus rectangle.
focusRoundedCorners — Style in class mx.containers.Accordion
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.containers.TabNavigator
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.Button
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.ButtonBar
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.ColorPicker
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.ComboBox
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.DateChooser
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.DateField
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.MenuBar
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.NumericStepper
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.TextArea
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.TextInput
 | Specifies which corners of the focus rectangle should be rounded.
focusRoundedCorners — Style in class mx.controls.listClasses.ListBase
 | Specifies which corners of the focus rectangle should be rounded.
focusSkin — Style in class mx.core.UIComponent
 | Skin used to draw the focus rectangle.
focusThickness — Style in class mx.core.UIComponent
 | Thickness, in pixels, of the focus rectangle outline.
folderClosedIcon — Style in class mx.controls.Tree
 | Specifies the folder closed icon for a branch item of the tree.
folderOpenIcon — Style in class mx.controls.Tree
 | Specifies the folder open icon for a branch item of the tree.
font — Property in class flash.text.TextFormat
 | The name of the font for text in this text format, as a string.
Font — Class in package flash.text
 | The Font class is used to manage embedded fonts in SWF files.
fontAntiAliasType — Style in class mx.charts.chartClasses.DataTip
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.containers.FormHeading
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.Button
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.ColorPicker
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.ComboBox
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.DateChooser
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.DateField
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.Label
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.MenuBar
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.NumericStepper
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.ProgressBar
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.TextInput
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.ToolTip
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.controls.menuClasses.MenuBarItem
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.core.Container
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.core.ScrollControlBase
 | Sets the antiAliasType property of internal TextFields.
fontAntiAliasType — Style in class mx.core.UITextField
 | Sets the antiAliasType property of internal TextFields.
fontFamily — Style in class mx.charts.AxisRenderer
 | Name of the font to use.
fontFamily — Style in class mx.charts.chartClasses.ChartBase
 | Name of the font to use.
fontFamily — Style in class mx.charts.chartClasses.DataTip
 | Name of the font to use.
fontFamily — Style in class mx.charts.series.PieSeries
 | Name of the font to use.
fontFamily — Style in class mx.containers.FormHeading
 | Name of the font to use.
fontFamily — Style in class mx.controls.Button
 | Name of the font to use.
fontFamily — Style in class mx.controls.ColorPicker
 | Name of the font to use.
fontFamily — Style in class mx.controls.ComboBox
 | Name of the font to use.
fontFamily — Style in class mx.controls.DateChooser
 | Name of the font to use.
fontFamily — Style in class mx.controls.DateField
 | Name of the font to use.
fontFamily — Style in class mx.controls.Label
 | Name of the font to use.
fontFamily — Style in class mx.controls.MenuBar
 | Name of the font to use.
fontFamily — Style in class mx.controls.NumericStepper
 | Name of the font to use.
fontFamily — Style in class mx.controls.ProgressBar
 | Name of the font to use.
fontFamily — Style in class mx.controls.TextInput
 | Name of the font to use.
fontFamily — Style in class mx.controls.ToolTip
 | Name of the font to use.
fontFamily — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Name of the font to use.
fontFamily — Style in class mx.controls.menuClasses.MenuBarItem
 | Name of the font to use.
fontFamily — Property in class mx.controls.textClasses.TextRange
 | Name of the font for text in the range.
fontFamily — Style in class mx.core.Container
 | Name of the font to use.
fontFamily — Style in class mx.core.ScrollControlBase
 | Name of the font to use.
fontFamily — Style in class mx.core.UITextField
 | Name of the font to use.
fontGridFitType — Style in class mx.charts.chartClasses.DataTip
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.containers.FormHeading
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.Button
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.ColorPicker
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.ComboBox
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.DateChooser
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.DateField
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.Label
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.MenuBar
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.NumericStepper
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.ProgressBar
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.TextInput
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.ToolTip
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.controls.menuClasses.MenuBarItem
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.core.Container
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.core.ScrollControlBase
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontGridFitType — Style in class mx.core.UITextField
 | Sets the gridFitType property of internal TextFields that represent text in Flex controls.
fontName — Property in class flash.text.Font
 | The name of an embedded font.
fontSharpness — Style in class mx.charts.chartClasses.DataTip
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.containers.FormHeading
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.Button
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.ColorPicker
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.ComboBox
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.DateChooser
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.DateField
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.Label
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.MenuBar
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.NumericStepper
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.ProgressBar
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.TextInput
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.ToolTip
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.controls.menuClasses.MenuBarItem
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.core.Container
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.core.ScrollControlBase
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSharpness — Style in class mx.core.UITextField
 | Sets the sharpness property of internal TextFields that represent text in Flex controls.
fontSize — Property in class flash.text.CSMSettings
 | The size, in pixels, for which the settings apply.
fontSize — Style in class mx.charts.AxisRenderer
 | Height of the text in pixels.
fontSize — Style in class mx.charts.chartClasses.ChartBase
 | Height of the text in pixels.
fontSize — Style in class mx.charts.chartClasses.DataTip
 | Height of the text, in pixels.
fontSize — Style in class mx.charts.series.PieSeries
 | Height of the text in pixels.
fontSize — Style in class mx.containers.FormHeading
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.Button
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.ColorPicker
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.ComboBox
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.DateChooser
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.DateField
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.Label
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.MenuBar
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.NumericStepper
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.ProgressBar
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.TextInput
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.ToolTip
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Height of the text, in pixels.
fontSize — Style in class mx.controls.menuClasses.MenuBarItem
 | Height of the text, in pixels.
fontSize — Property in class mx.controls.textClasses.TextRange
 | Point size of the text in the range.
fontSize — Style in class mx.core.Container
 | Height of the text, in pixels.
fontSize — Style in class mx.core.ScrollControlBase
 | Height of the text, in pixels.
fontSize — Style in class mx.core.UITextField
 | Height of the text, in pixels.
fontStyle — Property in class flash.text.Font
 | The style of the font.
fontStyle — Style in class mx.charts.AxisRenderer
 | Determines whether the text uses an italic font face.
fontStyle — Style in class mx.charts.chartClasses.ChartBase
 | Determines whether the text is italic font.
fontStyle — Style in class mx.charts.chartClasses.DataTip
 | Determines whether the text is italic font.
fontStyle — Style in class mx.charts.series.PieSeries
 | Determines whether the text is italic font.
fontStyle — Style in class mx.containers.FormHeading
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.Button
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.ColorPicker
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.ComboBox
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.DateChooser
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.DateField
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.Label
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.MenuBar
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.NumericStepper
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.ProgressBar
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.TextInput
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.ToolTip
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Determines whether the text is italic font.
fontStyle — Style in class mx.controls.menuClasses.MenuBarItem
 | Determines whether the text is italic font.
fontStyle — Property in class mx.controls.textClasses.TextRange
 | Style of the font in the range, as "italic" or "normal".
fontStyle — Style in class mx.core.Container
 | Determines whether the text is italic font.
fontStyle — Style in class mx.core.ScrollControlBase
 | Determines whether the text is italic font.
fontStyle — Style in class mx.core.UITextField
 | Determines whether the text is italic font.
FontStyle — Final class in package flash.text
 | The FontStyle class provides values for the TextRenderer class.
fontThickness — Style in class mx.charts.chartClasses.DataTip
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.containers.FormHeading
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.Button
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.ColorPicker
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.ComboBox
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.DateChooser
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.DateField
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.Label
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.MenuBar
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.NumericStepper
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.ProgressBar
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.TextInput
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.ToolTip
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.controls.menuClasses.MenuBarItem
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.core.Container
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.core.ScrollControlBase
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontThickness — Style in class mx.core.UITextField
 | Sets the thickness property of internal TextFields that represent text in Flex controls.
fontType — Property in class flash.text.Font
 | The type of the font.
FontType — Final class in package flash.text
 | The FontType class contains the enumerated constants "embedded" and "device" for the fontType property of the Font class.
fontWeight — Style in class mx.charts.AxisRenderer
 | Determines whether the text uses a bold face.
fontWeight — Style in class mx.charts.LegendItem
 | Whether the text is bold or not.
fontWeight — Style in class mx.charts.chartClasses.ChartBase
 | Determines whether the text is boldface.
fontWeight — Style in class mx.charts.chartClasses.DataTip
 | Determines whether the text is boldface.
fontWeight — Style in class mx.charts.series.PieSeries
 | Determines whether the text is boldface.
fontWeight — Style in class mx.containers.FormHeading
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.Button
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.ColorPicker
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.ComboBox
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.DateChooser
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.DateField
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.Label
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.MenuBar
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.NumericStepper
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.ProgressBar
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.TextInput
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.ToolTip
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Determines whether the text is boldface.
fontWeight — Style in class mx.controls.menuClasses.MenuBarItem
 | Determines whether the text is boldface.
fontWeight — Property in class mx.controls.textClasses.TextRange
 | Weight of the font in the range, as "bold" or "normal".
fontWeight — Style in class mx.core.Container
 | Determines whether the text is boldface.
fontWeight — Style in class mx.core.ScrollControlBase
 | Determines whether the text is boldface.
fontWeight — Style in class mx.core.UITextField
 | Determines whether the text is boldface.
footerColors — Style in class mx.containers.Panel
 | Array of two colors used to draw the footer (area for the ControlBar container) background.
for — Statement
 | Evaluates the init (initialize) expression once and then starts a looping sequence.
forceSimple — Property in class flash.accessibility.AccessibilityProperties
 | If true, causes Flash® Player to exclude child objects within this display object from the accessible presentation.
forEach(callback:Function, thisObject) — Method in class Array
 | Executes a function on each item in the array.
for each..in — Statement
 | Iterates over the items of a collection and executes statement for each item.
for..in — Statement
 | Iterates over the dynamic properties of an object or elements in an array and executes statement for each property or element.
form — Style in class mx.charts.series.AreaSeries
 | Specifies the boundary type for the area.
form — Style in class mx.charts.series.LineSeries
 | Specifies the line type for the chart.
form — Property in class mx.charts.series.LineSeries
 | Specifies the line type for the chart.
Form — Class in package mx.containers
 | The Form container lets you control the layout of a form, mark form fields as required or optional, handle error messages, and bind your form data to the Flex data model to perform data checking and validation.
Form() — Constructor in class mx.containers.Form
 | Constructor.
format — Property in class mx.charts.chartClasses.InstanceCache
 | A TextFormat to apply to any instances created.
format(value:Object) — Method in class mx.formatters.CurrencyFormatter
 | Formats value as currency.
format(value:Object) — Method in class mx.formatters.DateFormatter
 | Formats a String as a date.
format(value:Object) — Method in class mx.formatters.Formatter
 | Formats a value and returns a String containing the new, formatted, value.
format(value:Object) — Method in class mx.formatters.NumberFormatter
 | Formats the number as a String.
format(value:Object) — Method in class mx.formatters.PhoneFormatter
 | Formats the String as a phone number.
format(value:Object) — Method in class mx.formatters.ZipCodeFormatter
 | Formats the String by using the specified format.
formatDataTip(hd:mx.charts:HitData) — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | Generates a text description of a ChartItem suitable for display as a DataTip.
formatDataTip(hitData:mx.charts:HitData) — Method in class mx.charts.chartClasses.StackedSeries
 | Provides custom text for DataTips.
formatDataTip(hitData:mx.charts:HitData) — Method in class mx.charts.series.ColumnSet
 | Provides custom text for DataTips.
formatDays(d:Date, previousValue:Date, axis:mx.charts:DateTimeAxis) — Method in class mx.charts.DateTimeAxis
 | The default formatting function used when the axis renders with day-based labelUnits.
formatDecimal(value:String) — Method in class mx.formatters.NumberBase
 | Formats a number by replacing the default decimal separator, ".", with the decimal separator specified by decimalSeparatorTo.
formatError — Property in class mx.validators.DateValidator
 | Error message when the inputFormat property is not in the correct format.
formatForScreen(value:Object) — Method in class mx.charts.CategoryAxis
 | Formats values for display in DataTips.
formatForScreen(value:Object) — Method in interface mx.charts.chartClasses.IAxis
 | Formats values for display in DataTips.
formatForScreen(value:Object) — Method in class mx.charts.chartClasses.NumericAxis
 | Formats values for display in DataTips.
formatMilliseconds(d:Date, previousValue:Date, axis:mx.charts:DateTimeAxis) — Method in class mx.charts.DateTimeAxis
 | The default formatting function used when the axis renders with millisecond-based labelUnits.
formatMinutes(d:Date, previousValue:Date, axis:mx.charts:DateTimeAxis) — Method in class mx.charts.DateTimeAxis
 | The default formatting function used when the axis renders with minute-based labelUnits.
formatMonths(d:Date, previousValue:Date, axis:mx.charts:DateTimeAxis) — Method in class mx.charts.DateTimeAxis
 | The default formatting function used when the axis renders with month-based labelUnits.
formatNegative(value:String, useSign:Boolean) — Method in class mx.formatters.NumberBase
 | Formats a negative number with either a minus sign (-) or parentheses ().
formatPrecision(value:String, precision:int) — Method in class mx.formatters.NumberBase
 | Formats a number by setting its decimal precision by using the decimalSeparatorTo property as the decimal separator.
formatRounding(value:String, roundType:String) — Method in class mx.formatters.NumberBase
 | Formats a number by rounding it.
formatRoundingWithPrecision(value:String, roundType:String, precision:int) — Method in class mx.formatters.NumberBase
 | Formats a number by rounding it and setting the decimal precision.
formats — Property in class mx.core.DragSource
 | Contains the formats of the drag data, as an Array of Strings.
formatSeconds(d:Date, previousValue:Date, axis:mx.charts:DateTimeAxis) — Method in class mx.charts.DateTimeAxis
 | The default formatting function used when the axis renders with second-based labelUnits.
formatString — Property in class mx.controls.DateField
 | The format of the displayed date in the text field.
formatString — Property in class mx.formatters.DateFormatter
 | The mask pattern.
formatString — Property in class mx.formatters.PhoneFormatter
 | String that contains mask characters that represent a specified phone number format.
formatString — Property in class mx.formatters.ZipCodeFormatter
 | The mask pattern.
Formatter — Class in package mx.formatters
 | The Formatter class is the base class for all data formatters.
Formatter() — Constructor in class mx.formatters.Formatter
 | Constructor.
formatThousands(value:String) — Method in class mx.formatters.NumberBase
 | Formats a number by using the thousandsSeparatorTo property as the thousands separator and the decimalSeparatorTo property as the decimal separator.
formatToString(className:String, ... rest) — Method in class flash.events.Event
 | A utility function for implementing the toString() method in your custom Event class.
formatValue(format:String, source:Object) — Method in class mx.formatters.SwitchSymbolFormatter
 | Creates a new String by formatting the source String using the format pattern.
formatYears(d:Date, previousValue:Date, axis:mx.charts:DateTimeAxis) — Method in class mx.charts.DateTimeAxis
 | The default formatting function used when the axis renders with year-based labelUnits.
FormHeading — Class in package mx.containers
 | The FormHeading container is used to display a heading for a group of controls inside a Form container.
FormHeading() — Constructor in class mx.containers.FormHeading
 | Constructor.
FormItem — Class in package mx.containers
 | The FormItem container defines a label and one or more children arranged horizontally or vertically.
FormItem() — Constructor in class mx.containers.FormItem
 | Constructor.
FormItemDirection — Final class in package mx.containers
 | The FormItem container defines the constant values for the direction property of the FormItem class.
FormItemLabel — Class in package mx.controls
 | The FormItem container uses a FormItemLabel object to display the label portion of the FormItem container.
FormItemLabel() — Constructor in class mx.controls.FormItemLabel
 | Constructor.
forwardAndBack — Property in class flash.ui.ContextMenuBuiltInItems
 | Lets the user move forward or backward one frame in a SWF file at run time (does not appear for a single-frame SWF file).
fps — Property in class flash.media.Camera
 | The maximum rate at which you want the camera to capture data, in frames per second.
fps — Property in class flash.net.SharedObject
 | Specifies the number of times per second that a client's changes to a shared object are sent to the server.
frame — Property in class flash.display.FrameLabel
 | The frame number containing the label.
FrameLabel — Final class in package flash.display
 | The FrameLabel object contains properties that specify a frame number and the corresponding label name.
frameRate — Property in class flash.display.LoaderInfo
 | The nominal frame rate, in frames per second, of the loaded SWF file.
frameRate — Property in class flash.display.Stage
 | Gets and sets the frame rate of the stage.
frameRate — Property in class mx.core.Application
 | Specifies the frame rate of the application.
framesLoaded — Property in class flash.display.MovieClip
 | The number of frames that are loaded from a streaming SWF file.
freeItemRenderers — Property in class mx.controls.listClasses.ListBase
 | A stack of unused item renderers.
freeItemRenderersTable — Property in class mx.controls.dataGridClasses.DataGridBase
 | A per-column table of unused item renderers.
fromCharCode(... rest) — Static method in class String
 | Returns a string comprising the characters represented by the Unicode character codes in the parameters.
fromState — Property in class mx.states.Transition
 | A String specifying the view state that your are changing from when you apply the transition.
fromValue — Property in class mx.effects.AnimateProperty
 | The starting value of the property for the effect.
fromValue — Property in class mx.effects.effectClasses.AnimatePropertyInstance
 | The starting value of the property for the effect.
fscommand(command, args) — Package function in flash.system
 | Lets the SWF file communicate with either Flash Player or the program hosting Flash Player, such as a web browser.
FULL — Constant static property in class flash.filters.BitmapFilterType
 | Defines the setting that applies a filter to the entire area of an object.
fullYear — Property in class Date
 | The full year (a four-digit number, such as 2000) of a Date object according to local time.
fullYearUTC — Property in class Date
 | The four-digit year of a Date object according to universal time (UTC).
function — Statement
 | Comprises a set of statements that you define to perform a certain task.
Function — Dynamic class in Top Level
 | A function is the basic unit of code that can be invoked in ActionScript.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


G Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
G Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
gain — Property in class flash.media.Microphone
 | The microphone gain—that is, the amount by which the microphone should multiply the signal before transmitting it.
generateFilterRect(sourceRect:flash.geom:Rectangle, filter:flash.filters:BitmapFilter) — Method in class flash.display.BitmapData
 | Determines the destination rectangle that the applyFilter() method call affects, given a BitmapData object, a source rectangle, and a filter object.
generator — Property in class mx.core.ClassFactory
 | The Class that the newInstance() method uses to generate objects from this factory object.
genre — Property in class flash.media.ID3Info
 | The genre of the song; corresponds to the ID3 2.0 tag TCON.
get — Statement
 | Defines a getter, which is a method that can be read like a property.
GET — Constant static property in class flash.net.URLRequestMethod
 | Specifies that the URLRequest object is a GET.
getAffectedProperties() — Method in class mx.effects.Effect
 | Returns an Array of Strings, where each String is the name of a property that is changed by this effect.
getAffectedProperties() — Method in class mx.effects.MaskEffect
 | Returns the component properties modified by this effect.
getAxis(dimension:String) — Method in class mx.charts.chartClasses.ChartBase
 | Retrieves the Axis instance for a particular dimension of the chart.
getAxis(dimension:String) — Method in class mx.charts.chartClasses.DataTransform
 | Retrieves the axis instance responsible for transforming the data dimension specified by the dimension parameter.
getBoolean(key:String, defaultValue:Boolean) — Method in class mx.resources.ResourceBundle
 | Gets a Boolean from a ResourceBundle.
getBounds(targetCoordinateSpace:flash.display:DisplayObject) — Method in class flash.display.DisplayObject
 | Returns a rectangle that defines the area of the display object relative to the coordinate system of the targetCoordinateSpace object.
getCacheKey(... rest) — Static method in class mx.skins.halo.HaloColors
 | Returns a unique hash key based on the colors that are passed in.
getCamera(name:String) — Static method in class flash.media.Camera
 | Returns a reference to a Camera object for capturing video.
getChannel(id:String, clustered:Boolean) — Static method in class mx.messaging.config.ServerConfig
 | Returns a shared instance of the configured Channel.
getChannelSet(destinationId:String, message:mx.messaging.messages:IMessage, serverMessageType:String) — Static method in class mx.messaging.config.ServerConfig
 | Returns a shared ChannelSet for use with the specified destination belonging to the service that handles the specified message type.
getCharBoundaries(charIndex:int) — Method in class flash.text.TextField
 | Returns a rectangle that is the bounding box of the character.
getCharIndexAtPoint(x:Number, y:Number) — Method in class flash.text.TextField
 | Returns the zero-based index value of the character at the point specified by the x and y parameters.
getChildAt(index:int) — Method in class flash.display.DisplayObjectContainer
 | Returns the child display object instance that exists at the specified index.
getChildAt(index:int) — Method in class mx.core.Container
 | Gets the nth child component object.
getChildAt(index:int) — Method in interface mx.core.IChildList
 | Gets the child DisplayObject at the specified index in this child list.
getChildByName(name:String) — Method in class flash.display.DisplayObjectContainer
 | Returns the child display object that exists with the specified name.
getChildByName(name:String) — Method in class mx.core.Container
 | Returns the child whose name property is the specified String.
getChildByName(name:String) — Method in interface mx.core.IChildList
 | Gets the child DisplayObject with the specified name in this child list.
getChildIndex(child:flash.display:DisplayObject) — Method in class flash.display.DisplayObjectContainer
 | Returns the index position of a child DisplayObject instance.
getChildIndex(child:flash.display:DisplayObject) — Method in class mx.core.Container
 | Gets the zero-based index of a specific child.
getChildIndex(child:flash.display:DisplayObject) — Method in interface mx.core.IChildList
 | Gets the index of a specific child in this child list.
getChildren(node:Object, model:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Provides access to a node's children.
getChildren(node:Object, model:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Provides access to a node's children.
getChildren(node:Object, model:Object) — Method in interface mx.controls.treeClasses.ITreeDataDescriptor
 | Provides access to a node's children, returning a collection view of children if they exist.
getChildren() — Method in class mx.core.Container
 | Returns an Array of DisplayObject objects consisting of the content children of the container.
getClassByAlias(aliasName) — Package function in flash.net
 | Looks up a class that previously had an alias registered through a call to the registerClassAlias() method.
getClassInfo(obj:Object, excludes:Array, options:Object) — Static method in class mx.utils.ObjectUtil
 | Returns information about the class, and properties of the class, for the specified Object.
getClassStyleDeclarations() — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | Returns an Array of CSSStyleDeclaration objects for the type selector that applies to this component, or null if none exist.
getClassStyleDeclarations() — Method in class mx.core.UIComponent
 | Finds the type selectors for this UIComponent instance.
getClassStyleDeclarations() — Method in interface mx.styles.IStyleClient
 | Returns an Array of CSSStyleDeclaration objects for the type selector that applies to this component, or null if none exist.
getColorBoundsRect(mask:uint, color:uint, findColor:Boolean) — Method in class flash.display.BitmapData
 | Determines a rectangular region that either fully encloses all pixels of a specified color within the bitmap image (if the findColor parameter is set to true) or fully encloses all pixels that do not include the specified color (if the findColor parameter is set to false).
getColorName(colorName:Object) — Static method in class mx.styles.StyleManager
 | Returns the numeric RGB color value that corresponds to the specified color string.
getColorNames(colors:Array) — Static method in class mx.styles.StyleManager
 | Converts each element of the colors Array from a color name to a numeric RGB color value.
getComplexProperty(name, value) — Method in class mx.utils.ObjectProxy
 | Provides a place for subclasses to override how a complex property that needs to be either proxied or daisy chained for event bubbling is managed.
getConflict() — Method in interface mx.data.IChangeObject
 | Returns the conflict created with a previous call to the conflict() method.
getContent() — Method in class mx.resources.ResourceBundle
 | You can override this method to provide your own keys and values for a ResourceBundle or to add objects to your custom ResourceBundle.
getCuePointByName(name:String) — Method in class mx.controls.videoClasses.CuePointManager
 | Search for a cue point with specified name.
getCuePoints() — Method in class mx.controls.videoClasses.CuePointManager
 | Returns an Array of all cue points.
getCurrent(sm:mx.managers:ISystemManager) — Static method in class mx.resources.Locale
 | Gets the current locale.
getData(node:Object, model:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Returns a node's data.
getData(node:Object, model:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Returns a node's data.
getData(node:Object, model:Object) — Method in interface mx.controls.treeClasses.ITreeDataDescriptor
 | Gets the data from a node.
getDate() — Method in class Date
 | Returns the day of the month (an integer from 1 to 31) specified by a Date object according to local time.
getDay() — Method in class Date
 | Returns the day of the week (0 for Sunday, 1 for Monday, and so on) specified by this Date according to local time.
getDefinition(name:String) — Method in class flash.system.ApplicationDomain
 | Gets a public definition from the specified application domain.
getDefinitionByName(name) — Package function in flash.utils
 | Returns a reference to the class object of the class specified by the name parameter.
getDefinitionByName(name:String) — Method in interface mx.managers.ISystemManager
 | Converts the given String to a Class or package-level Function.
getDefinitionByName(name:String) — Method in class mx.managers.SystemManager
 | Converts the given String to a Class or package-level Function.
getDescendants(name) — Method in class flash.utils.Proxy
 | Overrides the use of the descendant operator.
getDestination(obj:Object) — Static method in class mx.data.utils.Managed
 | Returns the destination the specified object is associated with.
getDividerAt(i:int) — Method in class mx.containers.DividedBox
 | Returns a reference to the specified BoxDivider object in this DividedBox container.
getElementBounds(renderData:Object) — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
getElementBounds(renderData:Object) — Method in class mx.charts.chartClasses.Series
 | Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
getElementBounds(renderData:Object) — Method in class mx.charts.series.BubbleSeries
 | Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
getElementBounds(renderData:Object) — Method in class mx.charts.series.PieSeries
 | Fills in the elementBounds, bounds, and visibleBounds properties of a renderData structure generated by this series.
getEvents(host:Object, name:String, commitOnly:Boolean) — Static method in class mx.binding.utils.ChangeWatcher
 | Returns all the binding events for all bindable properties in the host object.
getExplicitOrMeasuredHeight() — Method in interface mx.core.IUIComponent
 | A convenience method for determining whether to use the explicit or measured height
getExplicitOrMeasuredHeight() — Method in class mx.core.UIComponent
 | A convenience method for determining whether to use the explicit or measured height
getExplicitOrMeasuredHeight() — Method in class mx.core.UITextField
 | A convenience method for determining whether to use the explicit or measured height
getExplicitOrMeasuredHeight() — Method in class mx.managers.SystemManager
 | A convenience method for determining whether to use the explicit or measured height.
getExplicitOrMeasuredWidth() — Method in interface mx.core.IUIComponent
 | A convenience method for determining whether to use the explicit or measured width
getExplicitOrMeasuredWidth() — Method in class mx.core.UIComponent
 | A convenience method for determining whether to use the explicit or measured width
getExplicitOrMeasuredWidth() — Method in class mx.core.UITextField
 | A convenience method for determining whether to use the explicit or measured width
getExplicitOrMeasuredWidth() — Method in class mx.managers.SystemManager
 | A convenience method for determining whether to use the explicit or measured width.
getFeedback() — Static method in class mx.managers.DragManager
 | Returns the current drag and drop feedback.
getFirstCharInParagraph(charIndex:int) — Method in class flash.text.TextField
 | Given a character index, returns the index of the first character in the same paragraph.
getFocus() — Method in class mx.core.UIComponent
 | Gets the object that currently has focus.
getFocus() — Method in class mx.managers.FocusManager
 | Gets the IFocusManagerComponent component that currently has the focus.
getFocus() — Method in interface mx.managers.IFocusManager
 | Gets the IFocusManagerComponent component that currently has the focus.
getFullURL(rootURL:String, url:String) — Static method in class mx.utils.URLUtil
 | Converts a potentially relative URL to a full qualified URL.
getFullYear() — Method in class Date
 | Returns the full year (a four-digit number, such as 2000) of a Date object according to local time.
getGroupName(node:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Returns the name of the radio button group to which the node belongs, if any.
getGroupName(node:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Returns the name of the radio button group to which the node belongs, if any.
getHeader(qname:QName, headerName:String) — Method in class mx.rpc.soap.Operation
 | Returns a header if a match is found based on QName localName and URI.
getHeader(qname:QName, headerName:String) — Method in class mx.rpc.soap.WebService
 | Returns a header if a match is found based on QName localName and URI.
getHeaderAt(index:int) — Method in class mx.containers.Accordion
 | Returns a reference to the navigator button for a child container.
getHours() — Method in class Date
 | Returns the hour (an integer from 0 to 23) of the day portion of a Date object according to local time.
getImageReference(id:String) — Method in class flash.text.TextField
 | Returns a DisplayObject reference for the given id, for an image or SWF file that has been added to an HTML-formatted text field by using an <img> tag.
getInstance() — Method in class mx.core.DeferredInstanceFromClass
 | Creates and returns an instance of the class specified in the DeferredInstanceFromClass constructor, if it does not yet exist; otherwise, returns the already-created class instance.
getInstance() — Method in class mx.core.DeferredInstanceFromFunction
 | Returns a reference to an instance of the desired object.
getInstance() — Method in interface mx.core.IDeferredInstance
 | Creates an instance Object from a class or function, if the instance does not yet exist.
getInstance() — Static method in class mx.managers.LayoutManager
 | Returns the sole instance of this singleton class, creating it if it does not already exist.
getItem(identity:Object, defaultValue:Object) — Method in class mx.data.DataService
 | Makes an asynchronous request for an item matching the specified identity.
getItem(identity:Object, defaultValue:Object) — Method in class mx.data.mxml.DataService
 | Makes an asynchronous request for an item matching the specified identity.
getItemAt(index:int, prefetch:int) — Method in interface mx.collections.IList
 | Gets the item at the specified index.
getItemAt(index:int, prefetch:int) — Method in class mx.collections.ListCollectionView
 | Gets the item at the specified index.
getItemIndex(item:Object) — Method in interface mx.collections.IList
 | Returns the index of the item if it is in the list such that getItemAt(index) == item.
getItemIndex(item:Object) — Method in class mx.collections.ListCollectionView
 | Returns the index of the item if it is in the list such that getItemAt(index) == item.
getItemIndex(item:Object, source:Array) — Static method in class mx.utils.ArrayUtil
 | Returns the index of the item in the Array.
getKeyProperty(property:String) — Method in class mx.messaging.management.ObjectName
 | Returns the value associated with the specified property key.
getLabelEstimate() — Method in class mx.charts.CategoryAxis
 | Determines the range to estimate what the axis labels should be.
getLabelEstimate() — Method in interface mx.charts.chartClasses.IAxis
 | Determines the range to estimate what the axis labels should be.
getLabelEstimate() — Method in class mx.charts.chartClasses.NumericAxis
 | Determines the range to estimate what the axis labels should be.
getLabels(minimumAxisLength:Number) — Method in class mx.charts.CategoryAxis
 | Gets the labels text that is rendered.
getLabels(minimumAxisLength:Number) — Method in interface mx.charts.chartClasses.IAxis
 | Gets the labels text that is rendered.
getLabels(minimumAxisLength:Number) — Method in class mx.charts.chartClasses.NumericAxis
 | Gets the labels text that is rendered.
getLevelString(value:uint) — Static method in class mx.logging.LogEvent
 | Returns a string value representing the level specified.
getLineIndexAtPoint(x:Number, y:Number) — Method in class flash.text.TextField
 | Returns the zero-based index value of the line at the point specified by the x and y parameters.
getLineIndexOfChar(charIndex:int) — Method in class flash.text.TextField
 | Returns the zero-based index value of the line containing the character specified by the charIndex parameter.
getLineLength(lineIndex:int) — Method in class flash.text.TextField
 | Returns the number of characters in a specific text line.
getLineMetrics(lineIndex:int) — Method in class flash.text.TextField
 | Returns metrics information about a given text line.
getLineMetrics(lineIndex:int) — Method in class mx.controls.Label
 | Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
getLineMetrics(lineIndex:int) — Method in class mx.controls.TextArea
 | Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
getLineMetrics(lineIndex:int) — Method in class mx.controls.TextInput
 | Returns a TextLineMetrics object with information about the text position and measurements for a line of text in the control.
getLineOffset(lineIndex:int) — Method in class flash.text.TextField
 | Returns the character index of the first character in the line that the lineIndex parameter specifies.
getLineText(lineIndex:int) — Method in class flash.text.TextField
 | Returns the text of the line specified by the lineIndex parameter.
getLocal(name:String, localPath:String, secure:Boolean) — Static method in class flash.net.SharedObject
 | Returns a reference to a locally persistent shared object that is available only to the current client.
getLogger(category:String) — Static method in class mx.logging.Log
 | Returns the logger associated with the specified category.
getMenuAt(index:int) — Method in class mx.controls.MenuBar
 | Returns a reference to the Menu at the specified MenuBar item index.
getMessageResponder(agent:mx.messaging:MessageAgent, message:mx.messaging.messages:IMessage) — Method in class mx.messaging.Channel
 | Returns the appropriate MessageResponder for the Channel's send() method.
GET_METHOD — Constant static property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates that the method used for this request should be "get".
getMicrophone(index:int) — Static method in class flash.media.Microphone
 | To create or reference a Microphone object, use the Microphone.getMicrophone() method to get the index value of the current microphone.
getMilliseconds() — Method in class Date
 | Returns the milliseconds (an integer from 0 to 999) portion of a Date object according to local time.
getMinutes() — Method in class Date
 | Returns the minutes (an integer from 0 to 59) portion of a Date object according to local time.
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object) — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | Fills in missing values in an interpolation structure.
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object) — Method in class mx.charts.chartClasses.Series
 | Fills in missing values in an interpolation structure.
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object) — Method in class mx.charts.series.BubbleSeries
 | Fills in missing values in an interpolation structure.
getMissingInterpolationValues(sourceProps:Object, srcCache:Array, destProps:Object, destCache:Array, index:Number, customData:Object) — Method in class mx.charts.series.PieSeries
 | Fills in missing values in an interpolation structure.
getMonth() — Method in class Date
 | Returns the month (0 for January, 1 for February, and so on) portion of this Date according to local time.
getNamespaceForPrefix(prefix:String) — Method in class flash.xml.XMLNode
 | Returns the namespace URI that is associated with the specified prefix for the node.
getNextFocusManagerComponent(backward:Boolean) — Method in class mx.managers.FocusManager
 | Returns the IFocusManagerComponent that would receive focus if the user pressed the Tab key to navigate to another component.
getNextFocusManagerComponent(backward:Boolean) — Method in interface mx.managers.IFocusManager
 | Returns the IFocusManagerComponent that would receive focus if the user pressed the Tab key to navigate to another component.
getNumber(key:String) — Method in class mx.resources.ResourceBundle
 | Gets a Number from a ResourceBundle.
getObject(key:String) — Method in class mx.resources.ResourceBundle
 | Gets an object from a ResourceBundle.
getObjectsUnderPoint(point:flash.geom:Point) — Method in class flash.display.DisplayObjectContainer
 | Returns an array of objects that lie under the specified point and are children (or grandchildren, and so on) of this DisplayObjectContainer instance.
getObjectsUnderPoint(point:flash.geom:Point) — Method in interface mx.core.IChildList
 | Returns an array of DisplayObjects that lie under the specified point and are in this child list.
getOperation(name:String) — Method in class mx.rpc.AbstractService
 | Returns an Operation of the given name.
GET_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation requests that the remote destination get a specific managed object based on its unique ID.
getOperationAsString(op:uint) — Static method in class mx.data.messages.DataMessage
 | Provides a description of the operation specified.
getOperationAsString(op:uint) — Static method in class mx.messaging.messages.CommandMessage
 | Provides a description of the operation specified.
GET_OR_CREATE_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation requests an item with the specified identity from the remote destination.
getParagraphLength(charIndex:int) — Method in class flash.text.TextField
 | Given a character index, returns the length of the paragraph containing the given character.
getParentItem(item:Object) — Method in class mx.controls.Tree
 | Returns the known parent of a child item.
getPendingOperation(item:mx.data:IManaged) — Method in class mx.data.DataService
 | Returns the pending operation in the message cache for the specified item.
getPendingOperation(item:mx.data:IManaged) — Method in class mx.data.mxml.DataService
 | Returns the pending operation in the message cache for the specified item.
getPercentLoaded(loaded:Number, total:Number) — Method in class mx.preloaders.DownloadProgressBar
 | Returns the percentage value of the application loaded.
getPixel(x:int, y:int) — Method in class flash.display.BitmapData
 | Returns an integer that represents an RGB pixel value from a BitmapData object at a specific point (x, y).
getPixel32(x:int, y:int) — Method in class flash.display.BitmapData
 | Returns an ARGB color value that contains alpha channel data and RGB data.
getPixels(rect:flash.geom:Rectangle) — Method in class flash.display.BitmapData
 | Generates a byte array from a rectangular region of pixel data.
getPort(url:String) — Static method in class mx.utils.URLUtil
getPrefixForNamespace(ns:String) — Method in class flash.xml.XMLNode
 | Returns the prefix that is associated with the specified namespace URI for the node.
getProperties(destinationId:String, serviceId:String) — Static method in class mx.messaging.config.ServerConfig
 | Returns the property information for the specified destination
getProperty(name) — Method in class flash.utils.Proxy
 | Overrides any request for a property's value.
getProperty(obj:mx.data:IManaged, property:String, value) — Static method in class mx.data.utils.Managed
 | This method is used to retreive the a property from a managed object.
getProperty(name) — Method in class mx.utils.ObjectProxy
 | Returns the specified property value of the proxied object.
getProtocol(url:String) — Static method in class mx.utils.URLUtil
 | Returns the protocol section of the specified url.
getQualifiedClassName(value) — Package function in flash.utils
 | Returns the fully qualified class name of an object.
getQualifiedSuperclassName(value) — Package function in flash.utils
 | Returns the fully qualified class name of the base class of the object specified by the value parameter.
getRadioButtonAt(index:int) — Method in class mx.controls.RadioButtonGroup
 | Returns the RadioButton control at the specified index.
getRect(targetCoordinateSpace:flash.display:DisplayObject) — Method in class flash.display.DisplayObject
 | Returns a rectangle that defines the boundary of the display object, based on the coordinate system defined by the targetCoordinateSpace parameter, excluding any strokes on shapes.
getRemote(name:String, remotePath:String, persistence:Object, secure:Boolean) — Static method in class flash.net.SharedObject
 | Returns a reference to an object that can be shared across multiple clients by means of a server, such as Flash Media Server.
getRenderDataForTransition(type:String) — Method in class mx.charts.chartClasses.Series
 | Returns a copy of the data needed to represent this series's data.
getRepeaterItem(whichRepeater:int) — Method in class mx.core.UIComponent
 | Returns the item in the dataProvider that was used by the specified Repeater to produce this Repeater, or null if this Repeater isn't repeated.
getResourceBundle(baseName:String, currentDomain:flash.system:ApplicationDomain) — Static method in class mx.resources.ResourceBundle
 | Gets a ResourceBundle when provided with a className.
getSecondAxis(dimension:String) — Method in class mx.charts.chartClasses.CartesianChart
 | Retrieves axis instance for a particular secondary dimension of the chart.
getSeconds() — Method in class Date
 | Returns the seconds (an integer from 0 to 59) portion of a Date object according to local time.
getSelected(beginIndex:int, endIndex:int) — Method in class flash.text.TextSnapshot
 | Returns a Boolean value that specifies whether a TextSnapshot object contains selected text in the specified range.
getSelectedText(includeLineEndings:Boolean) — Method in class flash.text.TextSnapshot
 | Returns a string that contains all the characters specified by the corresponding setSelected() method.
GET_SEQUENCE_ID_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation requests a sequence id for a set of fill parameters.
getServerName(url:String) — Static method in class mx.utils.URLUtil
getServerNameWithPort(url:String) — Static method in class mx.utils.URLUtil
 | Pull the domain and port information out of a URL.
getServiceIdForMessage(message:mx.messaging.messages:IMessage) — Static method in class mx.messaging.config.ServerConfig
 | Returns the id for the first service found that will service the specified message.
getSOAPAction() — Method in class mx.messaging.messages.SOAPMessage
 | Provides access to the name of the remote method/operation that will be called.
getStackTrace() — Method in class Error
 | Returns the call stack for an error as a string at the time of the error's construction (for the debugger version of Flash Player only).
getStartValue() — Method in class mx.effects.effectClasses.ActionEffectInstance
 | Used internally to retrieve the values saved by the saveStartValue() method.
getString(key:String) — Method in class mx.resources.ResourceBundle
 | Gets a string from a ResourceBundle.
getStringArray(key:String) — Method in class mx.resources.ResourceBundle
 | Gets an array from a ResourceBundle.
getStyle(styleName:String) — Method in class flash.text.StyleSheet
 | Returns a copy of the style object associated with the style named styleName.
getStyle(styleProp:String) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | Gets a style property that has been set anywhere in this component's style lookup chain.
getStyle(styleProp:String) — Method in class mx.core.UIComponent
 | Gets a style property that has been set anywhere in this component's style lookup chain.
getStyle(styleProp:String) — Method in class mx.core.UITextField
 | Gets a style property that has been set anywhere in this component's style lookup chain.
getStyle(styleProp:String) — Method in class mx.skins.ProgrammaticSkin
 | Returns the value of the specified style property.
getStyle(styleProp:String) — Method in class mx.styles.CSSStyleDeclaration
 | Gets the value for a specified style property, as determined solely by this CSSStyleDeclaration.
getStyle(styleProp:String) — Method in interface mx.styles.IStyleClient
 | Gets a style property that has been set anywhere in this component's style lookup chain.
getStyleDeclaration(selector:String) — Static method in class mx.styles.StyleManager
 | Gets the CSSStyleDeclaration object that stores the rules for the specified CSS selector.
getSubscribeMessage() — Method in class mx.messaging.Consumer
 | Returns a subscribe message.
getSWFRoot(object:Object) — Static method in class mx.managers.SystemManager
 | Returns the root DisplayObject that loaded the application.
getTabAt(index:int) — Method in class mx.containers.TabNavigator
 | Returns the tab of the navigator's TabBar control at the specified index.
getText(beginIndex:int, endIndex:int, includeLineEndings:Boolean) — Method in class flash.text.TextSnapshot
 | Returns a string that contains all the characters specified by the beginIndex and endIndex parameters.
getTextFormat(beginIndex:int, endIndex:int) — Method in class flash.text.TextField
 | Returns a TextFormat object that contains formatting information for the range of text that the beginIndex and endIndex parameters specify.
getTextRunInfo(beginIndex:int, endIndex:int) — Method in class flash.text.TextSnapshot
 | Returns an array of objects that contains information about a run of text.
getTextStyles() — Method in class mx.core.UITextField
 | Returns the TextFormat object that represents character formatting information for this UITextField object.
getThumbAt(index:int) — Method in class mx.controls.sliderClasses.Slider
 | Returns the thumb object at the given index.
getTime() — Method in class Date
 | Returns the number of milliseconds since midnight January 1, 1970, universal time, for a Date object.
getTimer() — Package function in flash.utils
 | Returns the number of milliseconds that have elapsed since Flash Player was initialized, and is used to compute relative time.
getTimezoneOffset() — Method in class Date
 | Returns the difference, in minutes, between the computer's local time and universal time (UTC).
getType(node:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Returns the type identifier of a node.
getType(node:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Returns the type identifier of a node.
getUID(item:Object) — Static method in class mx.utils.UIDUtil
 | Returns the UID (unique identifier) for the specified object.
getUITextFormat() — Method in class mx.core.UITextField
 | Returns a UITextFormat object that contains formatting information for this component.
getUnsubscribeMessage() — Method in class mx.messaging.Consumer
 | Returns an unsubscribe message.
getUTCDate() — Method in class Date
 | Returns the day of the month (an integer from 1 to 31) of a Date object, according to universal time (UTC).
getUTCDay() — Method in class Date
 | Returns the day of the week (0 for Sunday, 1 for Monday, and so on) of this Date according to universal time (UTC).
getUTCFullYear() — Method in class Date
 | Returns the four-digit year of a Date object according to universal time (UTC).
getUTCHours() — Method in class Date
 | Returns the hour (an integer from 0 to 23) of the day of a Date object according to universal time (UTC).
getUTCMilliseconds() — Method in class Date
 | Returns the milliseconds (an integer from 0 to 999) portion of a Date object according to universal time (UTC).
getUTCMinutes() — Method in class Date
 | Returns the minutes (an integer from 0 to 59) portion of a Date object according to universal time (UTC).
getUTCMonth() — Method in class Date
 | Returns the month (0 [January] to 11 [December]) portion of a Date object according to universal time (UTC).
getUTCSeconds() — Method in class Date
 | Returns the seconds (an integer from 0 to 59) portion of a Date object according to universal time (UTC).
getValue() — Method in class mx.binding.utils.ChangeWatcher
 | Retrieves the current value of the watched property or property chain, or null if the host object is null.
getValueFromSource() — Method in class mx.validators.Validator
 | Returns the Object to validate.
getValueFromTarget(target:Object, property:String) — Method in class mx.effects.Effect
 | Called by the captureStartValues() method to get the value of a property from the target.
getViewIndex() — Method in class mx.collections.CursorBookmark
 | Get the approximate index of the item represented by this bookmark in its view.
global — Property in class RegExp
 | Specifies whether to use global matching for the regular expression.
globalToContent(point:flash.geom:Point) — Method in class mx.core.Container
 | Converts a Point object from global to content coordinates.
globalToContent(point:flash.geom:Point) — Method in class mx.core.UIComponent
 | Converts a Point object from global to content coordinates.
globalToLocal(point:flash.geom:Point) — Method in class flash.display.DisplayObject
 | Converts the point object from the Stage (global) coordinates to the display object's (local) coordinates.
Glow — Class in package mx.effects
 | The Glow effect lets you apply a visual glow effect to a component.
Glow(target:Object) — Constructor in class mx.effects.Glow
 | Constructor.
GlowFilter — Final class in package flash.filters
 | The GlowFilter class lets you apply a glow effect to display objects.
GlowFilter(color:uint, alpha:Number, blurX:Number, blurY:Number, strength:Number, quality:int, inner:Boolean, knockout:Boolean) — Constructor in class flash.filters.GlowFilter
 | Initializes a new GlowFilter instance with the specified parameters.
GlowInstance — Class in package mx.effects.effectClasses
 | The GlowInstance class implements the instance class for the Glow effect.
GlowInstance(target:Object) — Constructor in class mx.effects.effectClasses.GlowInstance
 | Constructor.
gotoAndPlay(frame:Object, scene:String) — Method in class flash.display.MovieClip
 | Starts playing the SWF file at the specified frame.
gotoAndStop(frame:Object, scene:String) — Method in class flash.display.MovieClip
 | Brings the playhead to the specified frame of the movie clip and stops it there.
GradientBevelFilter — Final class in package flash.filters
 | The GradientBevelFilter class lets you apply a gradient bevel effect to display objects.
GradientBevelFilter(distance:Number, angle:Number, colors:Array, alphas:Array, ratios:Array, blurX:Number, blurY:Number, strength:Number, quality:int, type:String, knockout:Boolean) — Constructor in class flash.filters.GradientBevelFilter
 | Initializes the filter with the specified parameters.
GradientEntry — Class in package mx.graphics
 | The GradientEntry class defines the objects that control a transition as part of a gradient fill.
GradientEntry(color:uint, ratio:Number, alpha:Number) — Constructor in class mx.graphics.GradientEntry
 | Constructor.
GradientGlowFilter — Final class in package flash.filters
 | The GradientGlowFilter class lets you apply a gradient glow effect to display objects.
GradientGlowFilter(distance:Number, angle:Number, colors:Array, alphas:Array, ratios:Array, blurX:Number, blurY:Number, strength:Number, quality:int, type:String, knockout:Boolean) — Constructor in class flash.filters.GradientGlowFilter
 | Initializes the filter with the specified parameters.
GradientType — Final class in package flash.display
 | The GradientType class provides values for the type parameter in the beginGradientFill() and lineGradientFill() methods of the flash.display.Graphics class.
graphics — Property in class flash.display.Shape
 | Specifies the Graphics object belonging to this Shape object, where vector drawing commands can occur.
graphics — Property in class flash.display.Sprite
 | Specifies the Graphics object that belongs to this sprite where vector drawing commands can occur.
Graphics — Final class in package flash.display
 | The Graphics class contains a set of methods that you can use to create a vector shape.
GraphicsUtil — Class in package mx.utils
 | The Graphics class is an all-static class with utility methods related to the Graphics class.
GREEN — Constant static property in class flash.display.BitmapDataChannel
 | The green channel.
greenMultiplier — Property in class flash.geom.ColorTransform
 | A decimal value that is multiplied with the green channel value.
greenOffset — Property in class flash.geom.ColorTransform
 | A number from -255 to 255 that is added to the green channel value after it has been multiplied by the greenMultiplier value.
Grid — Class in package mx.containers
 | A Grid container lets you arrange children as rows and columns of cells, similar to an HTML table.
Grid() — Constructor in class mx.containers.Grid
 | Constructor.
gridFitType — Property in class flash.text.TextField
 | The type of grid fitting used for this text field.
gridFitType — Property in class mx.core.UITextFormat
 | Defines the grid-fitting setting for the UITextField class.
GridFitType — Final class in package flash.text
 | The GridFitType class defines values for grid fitting in the TextField class.
GridItem — Class in package mx.containers
 | The GridItem container defines a grid cell in GridRow container.
GridItem() — Constructor in class mx.containers.GridItem
 | Constructor.
GridLines — Class in package mx.charts
 | The GridLines class draws grid lines inside the data area of the chart.
GridLines() — Constructor in class mx.charts.GridLines
 | Constructor.
gridLinesStyleName — Style in class mx.charts.chartClasses.CartesianChart
 | The class selector that defines the style properties for the default grid lines.
GridRow — Class in package mx.containers
 | The GridRow container defines a row in a Grid container, and contains GridCell containers.
GridRow() — Constructor in class mx.containers.GridRow
 | Constructor.
group — Property in class mx.controls.RadioButton
 | The RadioButtonGroup object to which this RadioButton belongs.
groupName — Property in class mx.controls.RadioButton
 | Specifies the name of the group to which this RadioButton control belongs, or specifies the value of the id property of a RadioButtonGroup control if this RadioButton is part of a group defined by a RadioButtonGroup control.
groupName — Property in interface mx.managers.IFocusManagerGroup
 | The name of the group of controls to which the control belongs.
guardMinMax(min:Number, max:Number) — Method in class mx.charts.chartClasses.NumericAxis
 | Protects the range against invalid values for this axis type.
gutterBottom — Style in class mx.charts.chartClasses.CartesianChart
 | The size of the region, in pixels, between the bottom of the chart data area and the bottom of the chart control.
gutterLeft — Style in class mx.charts.chartClasses.CartesianChart
 | The size of the region, in pixels, between the left of the chart data area and the left of the chart control.
gutterRight — Style in class mx.charts.chartClasses.CartesianChart
 | The size of the region, in pixels, between the right side of the chart data area and the outside of the chart control.
gutters — Property in class mx.charts.AxisRenderer
 | The distance between the axisRenderer and the sides of the surrounding chart.
gutters — Property in interface mx.charts.chartClasses.IAxisRenderer
 | The distance between the axisRenderer and the sides of the surrounding chart.
gutterTop — Style in class mx.charts.chartClasses.CartesianChart
 | The size of the region, in pixels, between the top of the chart data area and the top of the chart control.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


H Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
H Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
HaloBorder — Class in package mx.skins.halo
 | Defines the appearance of the default border for the Halo theme.
HaloBorder() — Constructor in class mx.skins.halo.HaloBorder
 | Constructor.
HaloColors — Class in package mx.skins.halo
 | Defines the colors used by components that support the Halo theme.
HaloFocusRect — Class in package mx.skins.halo
 | Defines the skin for the focus indicator.
HaloFocusRect() — Constructor in class mx.skins.halo.HaloFocusRect
 | Constructor.
handler — Event in class mx.states.SetEventHandler
 | The event handler function to execute in response to the event that is specified by the name property.
handleResults(errorResults:Array) — Method in class mx.validators.Validator
 | Returns a ValidationResultEvent from the Array of error results.
handlerFunction — Property in class mx.states.SetEventHandler
 | The handler function for the event.
HARDLIGHT — Constant static property in class flash.display.BlendMode
 | Adjusts the color of each pixel based on the darkness of the display object.
hasAccessibility — Static property in class flash.system.Capabilities
 | Specifies whether the player is running in an environment that supports (true) or does not support (false) communication with accessibility aids.
hasAudio — Static property in class flash.system.Capabilities
 | Specifies whether the player is running on a system that has audio capabilities.
hasAudioEncoder — Static property in class flash.system.Capabilities
 | Specifies whether the player can (true) or cannot (false) encode an audio stream, such as that coming from a microphone.
hasChildNodes() — Method in class flash.xml.XMLNode
 | Indicates whether the specified XMLNode object has child nodes.
hasChildren(node:Object, model:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Returns true if the node actually has children.
hasChildren(node:Object, model:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Returns true if the node actually has children.
hasChildren(node:Object, model:Object) — Method in interface mx.controls.treeClasses.ITreeDataDescriptor
 | Tests for the existence of children in a non-terminating node.
hasChildren — Property in class mx.controls.treeClasses.TreeListData
 | Contains true if the node has children.
hasComplexContent() — Method in class XML
 | Checks to see whether the XML object contains complex content.
hasComplexContent() — Method in class XMLList
 | Checks whether the XMLList object contains complex content.
hasDefinition(name:String) — Method in class flash.system.ApplicationDomain
 | Checks to see if a public definition exists within the specified application domain.
hasEmbeddedVideo — Static property in class flash.system.Capabilities
 | Specifies whether the player is running on a system that supports (true) or does not support (false) embedded video.
hasEventListener(type:String) — Method in class flash.display.Stage
 | Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
hasEventListener(type:String) — Method in class flash.events.EventDispatcher
 | Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
hasEventListener(type:String) — Method in interface flash.events.IEventDispatcher
 | Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
hasEventListener(type:String) — Method in class mx.collections.ListCollectionView
 | Checks whether the EventDispatcher object has any listeners registered for a specific type of event.
hasEventListener(type:String) — Method in class mx.utils.ObjectProxy
 | Checks whether there are any event listeners registered for a specific type of event.
hasFormat(format:String) — Method in class mx.core.DragSource
 | Returns true if the data source contains the requested format; otherwise, it returns false.
hasGlyphs(str:String) — Method in class flash.text.Font
 | Specifies whether a provided string can be displayed using the currently assigned font.
hasIllegalCharacters(value:String) — Static method in class mx.logging.Log
 | This method checks the specified string value for illegal characters.
hasIME — Static property in class flash.system.Capabilities
 | Specifies whether the player is running on a system that does (true) or does not (false) have an input method editor (IME) installed.
hasMetadata(obj:Object, propName:String, metadataName:String, excludes:Array, options:Object) — Static method in class mx.utils.ObjectUtil
 | Uses getClassInfo and examines the metadata information to determine whether a property on a given object has the specified metadata.
hasMP3 — Static property in class flash.system.Capabilities
 | Specifies whether the player is running on a system that does (true) or does not (false) have an MP3 decoder.
hasOwnProperty(name:String) — Method in class Object
 | Indicates whether an object has a specified property defined.
hasOwnProperty(p:String) — Method in class XML
 | Checks to see whether the object has the property specified by the p parameter.
hasOwnProperty(p:String) — Method in class XMLList
 | Checks for the property specified by p.
hasPrinting — Static property in class flash.system.Capabilities
 | Specifies whether the player is running on a system that does (true) or does not (false) support printing.
hasProperty(name) — Method in class flash.utils.Proxy
 | Overrides a request to check whether an object has a particular property by name.
hasProperty(name) — Method in class mx.utils.ObjectProxy
 | This is an internal function that must be implemented by a subclass of flash.utils.Proxy.
hasResponder() — Method in class mx.rpc.AsyncToken
 | Determines if this token has at least one mx.rpc.IResponder registered.
hasRoot — Property in class mx.controls.Menu
 | A flag that indicates that the current data provider has a root node; for example, a single top node in a hierarchical structure.
hasRoot — Property in class mx.controls.MenuBar
 | A flag that indicates that the current data provider has a root node; for example, a single top node in a hierarchical structure.
hasRoot — Property in class mx.controls.Tree
 | Indicates that the current dataProvider has a root item; for example, a single top node in a hierarchical structure.
hasScreenBroadcast — Static property in class flash.system.Capabilities
 | Specifies whether the player does (true) or does not (false) support the development of screen broadcast applications to be run through Flash Media Server.
hasScreenPlayback — Static property in class flash.system.Capabilities
 | Specifies whether the player does (true) or does not (false) support the playback of screen broadcast applications that are being run through Flash Media Server.
hasSimpleContent() — Method in class XML
 | Checks to see whether the XML object contains simple content.
hasSimpleContent() — Method in class XMLList
 | Checks whether the XMLList object contains simple content.
hasStreamingAudio — Static property in class flash.system.Capabilities
 | Specifies whether the player can (true) or cannot (false) play streaming audio.
hasStreamingVideo — Static property in class flash.system.Capabilities
 | Specifies whether the player can (true) or cannot (false) play streaming video.
hasTLS — Static property in class flash.system.Capabilities
 | Specifies whether the player is on a system that supports native SSL sockets through NetConnection (true) or does not (false).
hasVideoEncoder — Static property in class flash.system.Capabilities
 | Specifies whether the player can (true) or cannot (false) encode a video stream, such as that coming from a web camera.
HBox — Class in package mx.containers
 | The HBox container lays out its children in a single horizontal row.
HBox() — Constructor in class mx.containers.HBox
 | Constructor.
HDividedBox — Class in package mx.containers
 | The HDividedBox container lays out its children horizontally in the same way as HBox container, but it inserts a draggable divider in the gap between each child.
HDividedBox() — Constructor in class mx.containers.HDividedBox
 | Constructor.
header — Property in class mx.rpc.events.HeaderEvent
 | Header that the RPC call returned in the response.
HEADER — Constant static property in class mx.rpc.events.HeaderEvent
 | The HEADER event type.
headerColors — Style in class mx.containers.Panel
 | Array of two colors used to draw the header.
headerColors — Style in class mx.controls.DataGrid
 | An array of two colors used to draw the header background gradient.
headerColors — Style in class mx.controls.DateChooser
 | Colors of the band at the top of the DateChooser control.
headerColors — Style in class mx.controls.DateField
 | Colors of the band at the top of the DateChooser control.
headerDragProxyStyleName — Style in class mx.controls.DataGrid
 | The name of a CSS style declaration for controlling aspects of the appearance of column when the user is dragging it to another location.
HeaderEvent — Class in package mx.rpc.events
 | The event that indicates an RPC operation, such as a WebService SOAP request, returned a header in the response.
HeaderEvent(type:String, bubbles:Boolean, cancelable:Boolean, header:Object, token:mx.rpc:AsyncToken, message:mx.messaging.messages:IMessage) — Constructor in class mx.rpc.events.HeaderEvent
 | Creates a new HeaderEvent.
headerHeight — Style in class mx.containers.Accordion
 | Height of each accordion header, in pixels.
headerHeight — Style in class mx.containers.Panel
 | Height of the header.
headerHeight — Property in class mx.controls.dataGridClasses.DataGridBase
 | The height of the header cell of the column, in pixels.
headerRelease — Event in class mx.controls.DataGrid
 | Dispatched when the user releases the mouse button on a column header to request the control to sort the grid contents based on the contents of the column.
HEADER_RELEASE — Constant static property in class mx.events.DataGridEvent
 | The DataGridEvent.HEADER_RELEASE constant defines the value of the type property of the event object for a headerRelease event, which indicates that the user pressed and released the mouse on a column header.
headerRenderer — Property in class mx.containers.Accordion
 | A factory used to create the navigation buttons for each child.
headerRenderer — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The class factory for item renderer instances that display the column header for the column.
headers — Property in class mx.messaging.messages.AbstractMessage
 | The headers of a message are an associative array where the key is the header name and the value is the header value.
headers — Property in interface mx.messaging.messages.IMessage
 | Provides access to the headers of the message.
headers — Property in class mx.rpc.http.HTTPService
 | Custom HTTP headers to be sent to the third party endpoint.
headers — Property in class mx.rpc.soap.Operation
 | Accessor to an Array of SOAPHeaders that are to be sent on each invocation of the operation.
headers — Property in class mx.rpc.soap.WebService
 | Returns the array of SOAPHeaders registered for the WebService.
headerSeparatorSkin — Style in class mx.controls.DataGrid
 | The class to use as the skin for the separator between the DataGrid header and the rest of the rows.
headerShift — Event in class mx.controls.DataGrid
 | Dispatched when the user releases the mouse button on a column header after having dragged the column to a new location resulting in shifting the column to a new index.
HEADER_SHIFT — Constant static property in class mx.events.IndexChangedEvent
 | The IndexChangedEvent.HEADER_SHIFT constant defines the value of the type property of the event object for a headerShift event, which indicates that a header has changed its index, as when a user drags a DataGrid column to a new position.
headerStyleName — Style in class mx.containers.Accordion
 | Name of CSS style declaration that specifies styles for the accordion headers (tabs).
headerStyleName — Style in class mx.controls.DataGrid
 | The name of a CSS style declaration for controlling other aspects of the appearance of the column headers.
headerStyleName — Style in class mx.controls.DateChooser
 | Name of the style sheet definition to configure the text (month name and year) and appearance of the header area of the control.
headerStyleName — Style in class mx.controls.DateField
 | Name of the style sheet definition to configure the text (month name and year) and appearance of the header area of the control.
headerStyleName — Style in class mx.controls.dataGridClasses.DataGridColumn
 | The name of a CSS style declaration for controlling other aspects of the appearance of the column headers.
headerText — Property in class mx.controls.dataGridClasses.DataGridColumn
 | Text for the header of this column.
headerWordWrap — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A flag that indicates whether text in the header will be word wrapped if it doesn't fit on one line.
HEAD_METHOD — Constant static property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates that the method used for this request should be "head".
height — Property in class flash.display.BitmapData
 | The height of the bitmap image in pixels.
height — Property in class flash.display.DisplayObject
 | Indicates the height of the display object, in pixels.
height — Property in class flash.display.LoaderInfo
 | The nominal height of the loaded file.
height — Property in class flash.display.Stage
 | Indicates the height of the display object, in pixels.
height — Property in class flash.geom.Rectangle
 | The height of the rectangle, in pixels.
height — Property in class flash.media.Camera
 | The current capture height, in pixels.
height — Property in class flash.text.TextLineMetrics
 | The height value of the text of the selected lines (not necessarily the complete text) in pixels.
height — Property in class mx.controls.listClasses.ListRowInfo
 | The height of the row including margins.
height — Property in interface mx.core.IFlexDisplayObject
 | The height of this object, in pixels.
height — Property in class mx.core.UIComponent
 | Number that specifies the height of the component, in pixels, in the parent's coordinates.
height — Property in class mx.managers.SystemManager
 | The height of this object.
heightBy — Property in class mx.effects.Resize
 | Number of pixels by which to modify the height of the component.
heightBy — Property in class mx.effects.effectClasses.ResizeInstance
 | Number of pixels by which to modify the height of the component.
heightFrom — Property in class mx.effects.Resize
 | Initial height, in pixels.
heightFrom — Property in class mx.effects.effectClasses.ResizeInstance
 | Initial height.
heightLimit — Property in class mx.charts.AxisRenderer
 | The maximum amount of space, in pixels, that an axis renderer will take from a chart.
heightLimit — Property in interface mx.charts.chartClasses.IAxisRenderer
 | The maximum amount of space, in pixels, that an axis renderer will take from a chart.
heightTo — Property in class mx.effects.Resize
 | Final height, in pixels.
heightTo — Property in class mx.effects.effectClasses.ResizeInstance
 | Final height, in pixels.
hide() — Static method in class flash.ui.Mouse
 | Hides the pointer.
hide — Event in class mx.charts.chartClasses.DataTip
 | Dispatched when an object's state changes from visible to invisible.
hide — Property in class mx.charts.chartClasses.InstanceCache
 | Determines if unneeded instances should be hidden.
hide() — Method in class mx.controls.Menu
 | Hides the Menu control and any of its submenus if the Menu control is visible.
hide — Event in class mx.controls.ProgressBar
 | Dispatched when an object's state changes from visible to invisible.
hide — Event in class mx.core.UIComponent
 | Dispatched when an object's state changes from visible to invisible.
HIDE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.HIDE constant defines the value of the type property of the event object for a hide event.
hideBuiltInItems() — Method in class flash.ui.ContextMenu
 | Hides all built-in menu items (except Settings) in the specified ContextMenu object.
hideChildrenTargets — Property in class mx.effects.Resize
 | An Array of Panel containers.
hideChildrenTargets — Property in class mx.effects.effectClasses.ResizeInstance
 | An Array of Panels.
hideCursor() — Static method in class mx.managers.CursorManager
 | Makes the cursor invisible.
hideData() — Method in class mx.charts.chartClasses.ChartBase
 | Informs the chart that the underlying data being displayed in the chart has been changed.
hideDataEffect — Effect in class mx.charts.chartClasses.Series
 | Defines the effect that Flex uses as it hides the current data from view.
hideDelay — Static property in class mx.managers.ToolTipManager
 | The amount of time, in milliseconds, that Flex waits to hide the ToolTip after it appears.
hideDropFeedback(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
 | Hides the drop indicator under the mouse pointer that indicates that a drag and drop operation is allowed.
hideEffect — Effect in class mx.core.UIComponent
 | Played when the component becomes invisible.
hideEffect — Static property in class mx.managers.ToolTipManager
 | The effect that plays when a ToolTip is hidden, or null if the ToolTip should disappear with no effect.
hideFocus() — Method in class mx.managers.FocusManager
 | Sets showFocusIndicator to false and removes the visual focus indicator from the focused object, if any.
hideFocus() — Method in interface mx.managers.IFocusManager
 | Sets showFocusIndicator to false and removes the visual focus indicator from the focused object, if any.
hideObject — Property in class flash.filters.DropShadowFilter
 | Indicates whether or not the object is hidden.
HIDING_DATA — Constant static property in class mx.charts.chartClasses.ChartState
 | The chart is currently running transitions to hide the old chart data.
high — Property in class mx.charts.series.items.HLOCSeriesItem
 | The high value of this item converted into screen coordinates.
HIGH — Constant static property in class flash.display.StageQuality
 | Specifies high rendering quality: graphics are anti-aliased using a 4 x 4 pixel grid, and bitmaps are smoothed if the movie is static.
HIGH — Constant static property in class flash.filters.BitmapFilterQuality
 | Defines the high quality filter setting.
HIGH — Constant static property in class mx.managers.CursorManagerPriority
 | Constant that specifies the highest cursor priority when passed as the priority argument to setCursor().
highField — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | Specifies the field of the data provider that determines the y-axis location of the high value of the element.
highFilter — Property in class mx.charts.series.items.HLOCSeriesItem
 | The high value of this item, filtered against the vertical axis of the containing chart.
highlightAlpha — Property in class flash.filters.BevelFilter
 | The alpha transparency value of the highlight color.
highlightAlphas — Style in class mx.containers.Panel
 | Alphas used for the highlight fill of the header.
highlightAlphas — Style in class mx.controls.Button
 | Alpha transparencies used for the highlight fill of controls.
highlightAlphas — Style in class mx.controls.ColorPicker
 | Alphas used for the highlight fill of controls.
highlightAlphas — Style in class mx.controls.ComboBox
 | Alpha transparencies used for the highlight fill of controls.
highlightAlphas — Style in class mx.controls.DateChooser
 | Alpha transparencies used for the highlight fill of controls.
highlightAlphas — Style in class mx.controls.DateField
 | Alpha transparencies used for the highlight fill of controls.
highlightAlphas — Style in class mx.controls.MenuBar
 | Alpha transparencies used for the highlight fill of controls.
highlightAlphas — Style in class mx.controls.NumericStepper
 | Alphas used for the highlight fill of controls.
highlightAlphas — Style in class mx.controls.scrollClasses.ScrollBar
 | Alpha transparencies used for the highlight fill of controls.
highlightColor — Property in class flash.filters.BevelFilter
 | The highlight color of the bevel.
highlightIndicator — Property in class mx.controls.listClasses.ListBase
 | The DisplayObject that contains the graphics that indicates which renderer is highlighted.
highlightItemRenderer — Property in class mx.controls.listClasses.ListBase
 | The renderer that is currently rolled over or under the caret.
highlightUID — Property in class mx.controls.listClasses.ListBase
 | The UID of the item that is current rolled over or under the caret.
highNumber — Property in class mx.charts.series.items.HLOCSeriesItem
 | The high value of this item, converted to a number by the vertical axis of the containing chart.
highValue — Property in class mx.charts.series.items.HLOCSeriesItem
 | The high value of this item.
hiliteSelectedNavItem(index:int) — Method in class mx.controls.NavBar
 | Highlights the selected navigator item.
historyManagementEnabled — Property in class mx.containers.Accordion
 | If set to true, this property enables history management within this Accordion container.
historyManagementEnabled — Property in class mx.containers.ViewStack
 | If true, enables history management within this ViewStack container.
HistoryManager — Class in package mx.managers
 | History management lets users navigate through a Flex application using the web browser's Back and Forward navigation commands.
hitArea — Property in class flash.display.Sprite
 | Designates another sprite to serve as the hit area for a sprite.
hitData — Property in class mx.charts.events.ChartItemEvent
 | The first item in the hitSet array.
HitData — Class in package mx.charts
 | The HitData class represents information about the data item at a specific location on the screen.
HitData(id:Number, distance:Number, x:Number, y:Number, chartItem:mx.charts:ChartItem) — Constructor in class mx.charts.HitData
 | Constructor.
hitSet — Property in class mx.charts.events.ChartItemEvent
 | A set of HitData structures describing the chart items that triggered the event.
hitTest(firstPoint:flash.geom:Point, firstAlphaThreshold:uint, secondObject:Object, secondBitmapDataPoint:flash.geom:Point, secondAlphaThreshold:uint) — Method in class flash.display.BitmapData
 | Performs pixel-level hit detection between one bitmap image and a point, rectangle, or other bitmap image.
hitTestObject(obj:flash.display:DisplayObject) — Method in class flash.display.DisplayObject
 | Evaluates the display object to see if it overlaps or intersects with the obj display object.
hitTestPoint(x:Number, y:Number, shapeFlag:Boolean) — Method in class flash.display.DisplayObject
 | Evaluates the display object to see if it overlaps or intersects with the point specified by the x and y parameters.
hitTestState — Property in class flash.display.SimpleButton
 | Specifies a display object that is used as the hit testing object for the button.
hitTestTextNearPos(x:Number, y:Number, maxDistance:Number) — Method in class flash.text.TextSnapshot
 | Lets you determine which character within a TextSnapshot object is on or near the specified x, y coordinates of the movie clip containing the text in the TextSnapshot object.
HLOCChart — Class in package mx.charts
 | The HLOCChart (High Low Open Close) control represents financial data as a series of elements representing the high, low, closing, and optionally opening values of a data series.
HLOCChart() — Constructor in class mx.charts.HLOCChart
 | Constructor.
HLOCItemRenderer — Class in package mx.charts.renderers
 | The default item Rnderer for an HLOCSeries object.
HLOCItemRenderer() — Constructor in class mx.charts.renderers.HLOCItemRenderer
 | Constructor.
HLOCSeries — Class in package mx.charts.series
 | Represents financial data as a series of elements representing the high, low, closing, and, optionally, opening values of a data series.
HLOCSeries() — Constructor in class mx.charts.series.HLOCSeries
 | Constructor.
HLOCSeriesBase — Class in package mx.charts.chartClasses
 | HLOCSeriesBase is the base class for the two financial series types, HLOCSeries and CandlestickSeries.
HLOCSeriesBase() — Constructor in class mx.charts.chartClasses.HLOCSeriesBase
 | Constructor.
HLOCSeriesItem — Class in package mx.charts.series.items
 | Represents the information required to render an item as part of a HLOCSeries.
HLOCSeriesItem(element:mx.charts.chartClasses:HLOCSeriesBase, data:Object, index:uint) — Constructor in class mx.charts.series.items.HLOCSeriesItem
 | Constructor.
HLOCSeriesRenderData — Class in package mx.charts.series.renderData
 | Represents all the information needed by the HLOCSeries and CandlestickSeries objects to render.
HLOCSeriesRenderData(cache:Array, filteredCache:Array, renderedHalfWidth:Number, renderedXOffset:Number) — Constructor in class mx.charts.series.renderData.HLOCSeriesRenderData
 | Constructor.
HOME — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Home key (36).
horizontal — Property in class mx.charts.AxisRenderer
 | true if the axis renderer is being used as a horizontal axis.
horizontal — Property in interface mx.charts.chartClasses.IAxisRenderer
 | true if the axis renderer is being used as a horizontal axis.
HORIZONTAL — Constant static property in class flash.display.LineScaleMode
 | With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line scales only vertically.
HORIZONTAL — Constant static property in class mx.containers.BoxDirection
 | Specifies that children of the Box container are laid out horizontally.
HORIZONTAL — Constant static property in class mx.containers.FormItemDirection
 | Specifies that the children of the FormItem container are laid out horizontally.
HORIZONTAL — Constant static property in class mx.containers.TileDirection
 | Specifies that the children of the Tile container are laid out horizontally; that is, starting with the first row.
HORIZONTAL — Constant static property in class mx.controls.listClasses.TileBaseDirection
 | Arrange children horizontally.
HORIZONTAL — Constant static property in class mx.controls.scrollClasses.ScrollBarDirection
 | Specifies that a ScrollBar control is for horizontal scrolling.
HORIZONTAL — Constant static property in class mx.controls.sliderClasses.SliderDirection
 | Specifies to display a horizontal slider.
HORIZONTAL — Constant static property in class mx.core.ContainerLayout
 | Use horizontal layout for the contents of this container.
HORIZONTAL — Constant static property in class mx.events.ScrollEventDirection
 | The user scrolled horizontally.
horizontalAlign — Style in class mx.containers.Box
 | Horizontal alignment of children in the container.
horizontalAlign — Style in class mx.containers.FormItem
 | Horizontal alignment of children in the container.
horizontalAlign — Style in class mx.containers.GridRow
 | Horizontal alignment of children in the container.
horizontalAlign — Style in class mx.containers.Panel
 | Horizontal alignment of children in the container.
horizontalAlign — Style in class mx.containers.TabNavigator
 | Horizontal positioning of tabs at the top of this TabNavigator container.
horizontalAlign — Style in class mx.containers.Tile
 | Horizontal alignment of each child inside its tile cell.
horizontalAlign — Style in class mx.controls.ButtonBar
 | Horizontal alignment of the tabs.
horizontalAlign — Style in class mx.controls.SWFLoader
 | Horizontal alignment of the content when it does not have a one-to-one aspect ratio.
horizontalAlign — Style in class mx.controls.TabBar
 | Horizontal alignment of the tab navigation items.
horizontalAlign — Style in class mx.core.Application
 | Horizontal alignment of children in the container.
horizontalAlternateFill — Style in class mx.charts.GridLines
 | Specifies the fill pattern for alternating horizontal bands not defined by the fill property.
horizontalAxis — Property in class mx.charts.chartClasses.CartesianChart
 | Defines the labels, tick marks, and data position for items on the x-axis.
HORIZONTAL_AXIS — Constant static property in class mx.charts.chartClasses.CartesianTransform
 | A String representing the horizontal axis.
horizontalAxisRatio — Property in class mx.charts.chartClasses.CartesianChart
 | Determines the height limit of the horiztonal axis.
horizontalAxisRenderer — Property in class mx.charts.chartClasses.CartesianChart
 | Specifies how data appears along the x-axis of a chart.
horizontalAxisStyleName — Style in class mx.charts.chartClasses.CartesianChart
 | The class selector that defines the style properties for the horizontal axis.
horizontalCenter — Style in class mx.core.UIComponent
 | The horizontal distance in pixels from the center of the component's parent container to the center of the component.
horizontalChangeCount — Style in class mx.charts.GridLines
 | Specifies the number of tick marks between horizontal grid lines.
horizontalDividerCursor — Style in class mx.containers.DividedBox
 | The cursor skin for a horizontal DividedBox.
horizontalFill — Style in class mx.charts.GridLines
 | Specifies the fill pattern for every other horizontal band created by the grid lines.
horizontalFocus — Property in class mx.charts.effects.SeriesZoom
 | Defines the location of the focul point of the zoom.
horizontalFocus — Property in class mx.charts.effects.effectClasses.SeriesZoomInstance
 | Defines the location of the focul point of the zoom.
horizontalGap — Style in class mx.charts.Legend
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.charts.LegendItem
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.Accordion
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.Box
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.Form
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.FormItem
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.Grid
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.Panel
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.TabNavigator
 | Separation between tabs, in pixels.
horizontalGap — Style in class mx.containers.Tile
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.containers.ViewStack
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.controls.Button
 | Gap between the label and icon, when the labelPlacement property is set to left or right.
horizontalGap — Style in class mx.controls.ButtonBar
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.controls.ColorPicker
 | Horizontal gap between swatches in the swatch grid.
horizontalGap — Style in class mx.controls.DateChooser
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.controls.LinkBar
 | Number of pixels between the LinkButton controls in the horizontal direction.
horizontalGap — Style in class mx.controls.ProgressBar
 | Number of pixels between children in the horizontal direction.
horizontalGap — Style in class mx.controls.TabBar
 | Number of pixels between tab navigation items in the horizontal direction.
horizontalGap — Style in class mx.core.Application
 | Number of pixels between children in the horizontal direction.
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number) — Method in class mx.core.UIComponent
 | Returns a box Matrix which can be passed to the drawRoundRect() method as the rot parameter when drawing a horizontal gradient.
horizontalGradientMatrix(x:Number, y:Number, width:Number, height:Number) — Method in class mx.skins.ProgrammaticSkin
 | Utility function to create a horizontal gradient matrix.
horizontalGridLineColor — Style in class mx.controls.DataGrid
 | The color of the horizontal grid lines.
horizontalGridLines — Style in class mx.controls.DataGrid
 | A flag that indicates whether to show horizontal grid lines between the rows.
horizontalLineScrollSize — Property in class mx.core.Container
 | Number of pixels to move when the left- or right-arrow button in the horizontal scroll bar is pressed.
HorizontalList — Class in package mx.controls
 | The HorizontalList control displays a horizontal list of items.
HorizontalList() — Constructor in class mx.controls.HorizontalList
 | Constructor.
horizontalOriginStroke — Style in class mx.charts.GridLines
 | Specifies the line style for the horizontal origin.
horizontalPageScrollSize — Property in class mx.core.Container
 | Number of pixels to move when the track in the horizontal scroll bar is pressed.
horizontalScrollBar — Property in class mx.core.Container
 | The horizontal scrollbar used in this container.
horizontalScrollBar — Property in class mx.core.ScrollControlBase
 | The horizontal scroll bar.
horizontalScrollBarStyleName — Style in class mx.core.Container
 | The name of the horizontal scrollbar style.
horizontalScrollBarStyleName — Style in class mx.core.ScrollControlBase
 | Style name for horizontal scrollbar.
horizontalScrollPolicy — Property in class mx.controls.TextArea
 | Specifies whether the horizontal scroll bar is always on (ScrollPolicy.ON), always off (ScrollPolicy.OFF), or turns on when needed (ScrollPolicy.AUTO).
horizontalScrollPolicy — Property in class mx.core.Container
 | Specifies whether the horizontal scroll bar is always present, always absent, or automatically added when needed.
horizontalScrollPolicy — Property in class mx.core.ScrollControlBase
 | A property that indicates whether the horizontal scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method.
horizontalScrollPosition — Property in class mx.controls.DataGrid
 | The offset into the content from the left edge.
horizontalScrollPosition — Property in class mx.controls.TextArea
 | Pixel position in the content area of the leftmost pixel that is currently displayed.
horizontalScrollPosition — Property in class mx.controls.TextInput
 | / Pixel position in the content area of the leftmost pixel that is currently displayed.
horizontalScrollPosition — Property in class mx.core.Container
 | The current position of the horizontal scroll bar.
horizontalScrollPosition — Property in class mx.core.ScrollControlBase
 | The offset into the content from the left edge.
horizontalShowOrigin — Style in class mx.charts.GridLines
 | Determines whether to draw the horizontal origin.
horizontalStroke — Style in class mx.charts.GridLines
 | Specifies the line style for horizontal grid lines.
horizontalTickAligned — Style in class mx.charts.GridLines
 | Determines whether to align horizontal grid lines with tick marks.
hours — Property in class Date
 | The hour (an integer from 0 to 23) of the day portion of a Date object according to local time.
hoursUTC — Property in class Date
 | The hour (an integer from 0 to 23) of the day of a Date object according to universal time (UTC).
HRule — Class in package mx.controls
 | The HRule control creates a single horizontal line.
HRule() — Constructor in class mx.controls.HRule
 | Constructor
HScrollBar — Class in package mx.controls
 | The HScrollBar (horizontal ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
HScrollBar() — Constructor in class mx.controls.HScrollBar
 | Constructor.
HSlider — Class in package mx.controls
 | The HSlider control lets users select a value by moving a slider thumb between the end points of the slider track.
HSlider() — Constructor in class mx.controls.HSlider
 | Constructor.
htmlText — Property in class flash.text.TextField
 | Contains the HTML representation of the text field's contents.
htmlText — Property in class mx.controls.Label
 | Specifies the text displayed by the Label control, including HTML markup that expresses the styles of that text.
htmlText — Property in class mx.controls.RichTextEditor
 | Text containing HTML markup that displays in the RichTextEditor control's TextArea subcontrol.
htmlText — Property in class mx.controls.TextArea
 | Specifies the text displayed by the TextArea control, including HTML markup that expresses the styles of that text.
htmlText — Property in class mx.controls.TextInput
 | Specifies the text displayed by the TextInput control, including HTML markup that expresses the styles of that text.
htmlText — Property in class mx.controls.textClasses.TextRange
 | Contents of the range in the form of HTML text.
HTTPChannel — Class in package mx.messaging.channels
 | The HTTPChannel class provides the HTTP support for messaging.
HTTPChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.HTTPChannel
 | Creates an new HTTPChannel instance.
httpHeaders — Property in class mx.messaging.messages.HTTPRequestMessage
 | Contains specific HTTP headers that should be placed on the request made to the destination.
HTTPRequestMessage — Class in package mx.messaging.messages
 | HTTP requests are sent to the HTTP endpoint using this message type.
HTTPRequestMessage() — Constructor in class mx.messaging.messages.HTTPRequestMessage
 | Constructs an uninitialized HTTP request.
HTTPService — Class in package mx.rpc.http
 | When you call the HTTPService object's send() method, it makes an HTTP GET or POST request to the specified URL, and an HTTP response is returned.
HTTPService — Class in package mx.rpc.http.mxml
 | You use the <mx:HTTPService> tag to represent an HTTPService object in an MXML file.
HTTPService(rootURL:String) — Constructor in class mx.rpc.http.HTTPService
 | Creates a new HTTPService.
HTTPService() — Constructor in class mx.rpc.http.mxml.HTTPService
 | Creates a new HTTPService.
httpStatus — Event in class flash.display.LoaderInfo
 | Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code.
httpStatus — Event in class flash.net.FileReference
 | Dispatched when an upload fails and an HTTP status code is available to describe the failure.
httpStatus — Event in class flash.net.URLLoader
 | Dispatched if a call to URLLoader.load() attempts to access data over HTTP and the current Flash Player environment is able to detect and return the status code for the request.
httpStatus — Event in class flash.net.URLStream
 | Dispatched if a call to URLStream.load() attempts to access data over HTTP, and the current Flash Player is able to detect and return the status code for the request.
httpStatus — Event in class mx.controls.SWFLoader
 | Dispatched when a network request is made over HTTP and Flash Player can detect the HTTP status code.
HTTP_STATUS — Constant static property in class flash.events.HTTPStatusEvent
 | Defines the value of the type property of a httpStatus event object.
HTTPStatusEvent — Class in package flash.events
 | Flash® Player dispatches HTTPStatusEvent objects when a network request returns an HTTP status code.
HTTPStatusEvent(type:String, bubbles:Boolean, cancelable:Boolean, status:int) — Constructor in class flash.events.HTTPStatusEvent
 | Creates an Event object that contains specific information about HTTP status events.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


I Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
I Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
IAccessPrivileges — Interface in package mx.data
 | Objects that must restrict access must implement the IAccessPrivileges interface.
IAxis — Interface in package mx.charts.chartClasses
 | The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IAxisRenderer — Interface in package mx.charts.chartClasses
 | The IAxis class is an abstract interface for defining label, tick mark, and data positioning properties for a chart axis.
IBar — Interface in package mx.charts.chartClasses
 | The IBar interface is implemented by any any series that can be clustered vertically, such as a BarSeries.
IBitmapDrawable — Interface in package flash.display
 | The IBitmapDrawable interface is implemented by objects that can be passed as the source parameter of the draw() method of the BitmapData class.
IChangeObject — Interface in package mx.data
 | The IChangeObject interface provides the methods and properties needed when decting local conflicts.
IChartElement — Interface in package mx.charts.chartClasses
 | IChartElement defines the base set of properties and methods required by a UIComponent to be representable in the data space of a chart.
IChildList — Interface in package mx.core
 | The IChildList interface defines the properties and methods for accessing and manipulating child lists, which are subsets of a DisplayObjectContainer's children.
ICollectionView — Interface in package mx.collections
 | An ICollectionView is a view onto a collection of data.
IColumn — Interface in package mx.charts.chartClasses
 | ChartElements that can be clustered along the vertical axis should implement this interface.
icon — Style in class mx.controls.Button
 | Name of the class to use as the default icon.
icon — Property in class mx.controls.listClasses.ListData
 | A Class representing the icon for the item in the List control computed from the list class's itemToIcon() method
icon — Property in class mx.controls.listClasses.ListItemRenderer
 | The internal IFlexDisplayObject that displays the icon in this renderer.
icon — Property in class mx.controls.listClasses.TileListItemRenderer
 | The internal IFlexDisplayObject that displays the icon in this renderer.
icon — Property in class mx.controls.menuClasses.MenuItemRenderer
 | The internal IFlexDisplayObject that displays the icon in this renderer.
icon — Property in class mx.controls.treeClasses.TreeItemRenderer
 | The internal IFlexDisplayObject that displays the icon in this renderer.
icon — Property in class mx.controls.treeClasses.TreeListData
 | A Class representing the icon for the item in the Tree control.
icon — Property in class mx.core.Container
 | The Class of the icon displayed by some navigator containers to represent this Container.
iconClass — Property in class mx.controls.Alert
 | The class of the icon to display.
iconField — Property in class mx.controls.MenuBar
 | The name of the field in the data provider object that determines the icon to display for each menu item.
iconField — Property in class mx.controls.NavBar
 | Name of the field in the dataProvider object to display as the icon for each navigation item.
iconField — Property in class mx.controls.listClasses.ListBase
 | The name of the field in the data provider object that determines what to display as the icon.
iconFunction — Property in class mx.controls.listClasses.ListBase
 | A user-supplied function to run on each item to determine its icon.
IContainer — Interface in package mx.core
 | IContainer is a marker interface that indicates a component acts as a container for other components.
id — Property in class mx.charts.HitData
 | Specifies a unique identifier representing the data point.
id — Property in class mx.core.ComponentDescriptor
 | The identifier for the component, as specified in MXML.
id — Property in interface mx.core.IDeferredInstantiationUIComponent
 | ID of the component.
id — Property in class mx.core.UIComponent
 | ID of the component.
id — Property in class mx.logging.AbstractTarget
 | Provides access to the id of this target.
id — Property in class mx.messaging.Channel
 | Provides access to the id of this channel.
id3 — Event in class flash.media.Sound
 | Dispatched by a Sound object when ID3 data is available for an MP3 sound.
id3 — Property in class flash.media.Sound
 | Provides access to the metadata that is part of an MP3 file.
id3 — Event in class mx.effects.SoundEffect
 | Dispatched when ID3 data is available for an MP3 sound file.
ID3 — Constant static property in class flash.events.Event
 | Defines the value of the type property of an id3 event object.
ID3Info — Final dynamic class in package flash.media
 | The ID3Info class contains properties that reflect ID3 metadata.
IDataInput — Interface in package flash.utils
 | The IDataInput interface provides a set of methods for reading binary data.
IDataOutput — Interface in package flash.utils
 | The IDataOutput interface provides a set of methods for writing binary data.
IDataRenderer — Interface in package mx.core
 | The IDataRenderer interface defines the interface for components that have a data property.
IDeferredInstance — Interface in package mx.core
 | The IDeferredInstance interface defines the Flex deferred instance factory interface.
IDeferredInstantiationUIComponent — Interface in package mx.core
 | The IDeferredInstantiationUIComponent interface defines the interface for a component or object that defers instantiation.
identities — Property in class mx.data.UpdateCollectionRange
 | An Array of identity objects that represent which items were either deleted or inserted in the associated collection starting at the position indicated by the position property.
identity() — Method in class flash.geom.Matrix
 | Sets each matrix property to a value that causes a null transformation.
identity — Property in interface mx.data.IChangeObject
 | Identity of the item being changed.
identity — Property in class mx.data.events.DataServiceFaultEvent
 | The identity of the item that generated the fault.
identity — Property in class mx.data.messages.DataMessage
 | Provides access to the identity map which defines the unique identity of the item affected by this DataMessage (relevant for create/update/delete but not fill operations).
idle — Event in class mx.managers.SystemManager
 | Dispatched every 100 milliseconds when there has been no keyboard or mouse activity for 1 second.
IDLE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.IDLE constant defines the value of the type property of the event object for a idle event.
idleTimeout — Property in class mx.controls.VideoDisplay
 | Specifies the amount of time, in milliseconds, that the connection is idle (playing is paused or stopped) before the connection to the Flash Media Server is stopped.
idMap — Property in class flash.xml.XMLDocument
 | An Object containing the nodes of the XML that have an id attribute assigned.
IDropInListItemRenderer — Interface in package mx.controls.listClasses
 | The interface for "drop-in" item renderers.
IDynamicPropertyOutput — Interface in package flash.net
 | This interface controls the serialization of dynamic properties of dynamic objects.
IDynamicPropertyWriter — Interface in package flash.net
 | This interface is used with the IDynamicPropertyOutput interface to control the serialization of dynamic properties of dynamic objects.
IEventDispatcher — Interface in package flash.events
 | The IEventDispatcher interface defines methods for adding or removing event listeners, checks whether specific types of event listeners are registered, and dispatches events.
IExternalizable — Interface in package flash.utils
 | The IExternalizable interface provides control over serialization of a class as it is encoded into a data stream.
if — Statement
 | Evaluates a condition to determine the next statement to execute.
IFactory — Interface in package mx.core
 | The IFactory interface defines the interface that factory classes such as ClassFactory must implement.
IFill — Interface in package mx.graphics
 | Defines the interface that classes that perform a fill must implement.
IFlexAsset — Interface in package mx.core
 | IFlexAsset is a marker interface with the following meaning: if a class declares that it implements IFlexAsset, then that class represents an asset -- such as a bitmap, a font, or a sound -- that has been embedded in a Flex application.
IFlexDisplayObject — Interface in package mx.core
 | The IFlexDisplayObject interface defines the interface for skin elements.
IFocusManager — Interface in package mx.managers
 | The IFocusManager interface defines the interface that components must implement to manage the focus on components in response to mouse activity or keyboard activity (Tab key), and to support a default button.
IFocusManagerComponent — Interface in package mx.managers
 | The IFocusManagerComponent interface defines the interface that focusable components must implement in order to receive focus from the FocusManager.
IFocusManagerContainer — Interface in package mx.managers
 | The IFocusManagerContainer interface defines the interface that containers implement to host a FocusManager.
IFocusManagerGroup — Interface in package mx.managers
 | The IFocusManagerGroup interface defines the interface that any component must implement if it is grouped in sets, where only one member of the set can be selected at any given time.
IGNORE — Constant static property in class flash.filters.DisplacementMapFilterMode
 | If the displacement value is out of range, ignores the displacement and uses the source pixel.
ignoreCase — Property in class RegExp
 | Specifies whether the regular expression ignores case sensitivity.
ignoreComments — Static property in class XML
 | Determines whether XML comments are ignored when XML objects parse the source XML data.
ignorePadding — Property in class mx.core.UITextField
 | If true, the paddingLeft and paddingRight styles will not add space around the text of the component.
ignoreProcessingInstructions — Static property in class XML
 | Determines whether XML processing instructions are ignored when XML objects parse the source XML data.
ignoreWhite — Property in class flash.xml.XMLDocument
 | When set to true, text nodes that contain only white space are discarded during the parsing process.
ignoreWhitespace — Static property in class XML
 | Determines whether white space characters at the beginning and end of text nodes are ignored during parsing.
IHistoryManagerClient — Interface in package mx.managers
 | Interface that must be implemented by objects registered with the History Manager.
IIMESupport — Interface in package mx.core
 | The IIMESupport interface defines the interface for any component that supports IME (input method editor).
IInvalidating — Interface in package mx.core
 | The IInvalidating interface defines the interface for components that use invalidation to do delayed -- rather than immediate -- property commitment, measurement, drawing, and layout.
ILayoutManagerClient — Interface in package mx.managers
 | The ILayoutManagerClient interface defines the interface that a component must implement to participate in the LayoutManager's commit/measurement/layout sequence.
IList — Interface in package mx.collections
 | A collection of items organized in an ordinal fashion.
IListItemRenderer — Interface in package mx.controls.listClasses
 | Item renderers and item editors for list components must implement the IListItemRenderer interface.
ILLEGAL_CUE_POINT — Constant static property in class mx.controls.videoClasses.VideoError
 | Illegal cue point.
IllegalOperationError — Dynamic class in package flash.errors
 | The IllegalOperationError exception is thrown when a method is not implemented or the implementation doesn't cover the current usage.
IllegalOperationError(message:String) — Constructor in class flash.errors.IllegalOperationError
 | Creates a new IllegalOperationError object.
ILogger — Interface in package mx.logging
 | All loggers within the logging framework must implement this interface.
ILoggingTarget — Interface in package mx.logging
 | All logger target implementations within the logging framework must implement this interface.
Image — Class in package mx.controls
 | The Image control lets you import JPEG, PNG, GIF, and SWF files at runtime.
Image() — Constructor in class mx.controls.Image
 | Constructor.
IManaged — Interface in package mx.data
 | The IPropertyChangeNotifier interface provides the contract for a managed object.
ime — Static property in class flash.system.System
 | The currently installed system IME.
IME — Final class in package flash.system
 | The IME class lets you directly manipulate the operating system's input method editor (IME) in the Flash Player application that is running on a client computer.
imeComposition — Event in class flash.system.IME
 | Dispatched when a user has completed an input method editor (IME) composition and the reading string is available.
IME_COMPOSITION — Constant static property in class flash.events.IMEEvent
 | Defines the value of the type property of an imeComposition event object.
IMEConversionMode — Final class in package flash.system
 | This class contains constants for use with the IME.conversionMode property.
IMEEvent — Class in package flash.events
 | Flash® Player dispatches IMEEvent objects when a user enters text using an input method editor (IME).
IMEEvent(type:String, bubbles:Boolean, cancelable:Boolean, text:String) — Constructor in class flash.events.IMEEvent
 | Creates an Event object with specific information relevant to IME events.
imeMode — Property in class mx.controls.ComboBase
 | Specifies the IME (input method editor) mode.
imeMode — Property in class mx.controls.DataGrid
 | Specifies the IME (input method editor) mode.
imeMode — Property in class mx.controls.List
 | Specifies the IME (input method editor) mode.
imeMode — Property in class mx.controls.NumericStepper
 | Specifies the IME (Input Method Editor) mode.
imeMode — Property in class mx.controls.TextArea
 | Specifies the IME (input method editor) mode.
imeMode — Property in class mx.controls.TextInput
 | Specifies the IME (input method editor) mode.
imeMode — Property in class mx.controls.dataGridClasses.DataGridColumn
 | Specifies the IME (input method editor) mode.
imeMode — Property in interface mx.core.IIMESupport
 | The IME mode of the component.
imeMode — Property in class mx.core.UITextField
 | Specifies the IME (input method editor) mode.
IMenuDataDescriptor — Interface in package mx.controls.menuClasses
 | The IMenuDataDescriptor interface defines the interface that a dataDescriptor for a Menu or MenuBar control must implement.
IMenuItemRenderer — Interface in package mx.controls.menuClasses
 | The IMenuItemRenderer interface defines the interface that a menu item renderer for a Menu control must implement.
IMessage — Interface in package mx.messaging.messages
 | This interface defines the contract for message objects.
impact — Property in class mx.messaging.management.MBeanOperationInfo
 | The impact of the operation.
implements — Statement
 | Specifies that a class implements one or more interfaces.
import — Statement
 | Makes externally defined classes and packages available to your code.
IMXMLObject — Interface in package mx.core
 | The IMXMLObject interface defines the APIs that a non-visual component must implement in order to work properly with the MXML compiler.
IMXMLSupport — Interface in package mx.rpc.mxml
 | Implementing this interface means that an RPC service can be used in an MXML document via tags since it supports the interfaces specified during Flex 1.
in — Operator
 | Evaluates whether a property is part of a specific object.
include — Statement
 | Includes the contents of the specified file, as if the commands in the file are part of the calling script.
includeCategory — Property in class mx.logging.targets.LineFormattedTarget
 | Indicates if the category for this target should added to the trace.
includeDate — Property in class mx.logging.targets.LineFormattedTarget
 | Indicates if the date should be added to the trace.
includeInLayout — Property in interface mx.core.IUIComponent
 | Specifies whether this component is included in the layout of the parent container.
includeInLayout — Property in class mx.core.UIComponent
 | Specifies whether this component is included in the layout of the parent container.
includeInLayout — Property in class mx.core.UITextField
 | Specifies whether this component is included in the layout of the parent container.
includeLevel — Property in class mx.logging.targets.LineFormattedTarget
 | Indicates if the level for the event should added to the trace.
includeTime — Property in class mx.logging.targets.LineFormattedTarget
 | Indicates if the time should be added to the trace.
indent — Property in class flash.text.TextFormat
 | Indicates the indentation from the left margin to the first character in the paragraph.
indent — Property in class mx.controls.treeClasses.TreeListData
 | The default indentation for this row of the Tree control.
indentation — Style in class mx.controls.Tree
 | Indentation for each tree level, in pixels.
indeterminate — Property in class mx.controls.ProgressBar
 | Whether the ProgressBar control has a determinate or indeterminate appearance.
indeterminateSkin — Style in class mx.controls.ProgressBar
 | Skin style for an indeterminate progress bar.
index — Property in class flash.media.Camera
 | A zero-based integer that specifies the index of the camera, as reflected in the array returned by the names property.
index — Property in class flash.media.Microphone
 | The index of the microphone, as reflected in the array returned by Microphone.names.
index — Property in class mx.charts.ChartItem
 | The index of the data from the series' dataProvider that the ChartItem represents.
index — Property in class mx.charts.series.items.LineSeriesSegment
 | The index of this segment in the array of segments representing the line series.
index — Property in class mx.controls.listClasses.ListBaseSelectionData
 | The index in the data provider of the selected item.
index — Property in class mx.effects.AddChildAction
 | The index of the child within the parent.
index — Property in class mx.effects.effectClasses.AddChildActionInstance
 | The index of the child within the parent.
index — Property in class mx.events.ColorPickerEvent
 | The zero-based index in the Color's data provider that corresponds to the color that was rolled over, rolled out of, or selected.
index — Property in class mx.events.ItemClickEvent
 | The index of the associated navigation item.
index — Property in class mx.events.MenuEvent
 | The index of the associated menu item within its parent menu or submenu.
IndexChangedEvent — Class in package mx.events
 | The IndexChangedEvent class represents events that are dispatched when an index changes.
IndexChangedEvent(type:String, bubbles:Boolean, cancelable:Boolean, relatedObject:flash.display:DisplayObject, oldIndex:Number, newIndex:Number, triggerEvent:flash.events:Event) — Constructor in class mx.events.IndexChangedEvent
 | Constructor.
indexOf(searchElement, fromIndex:int) — Method in class Array
 | Searches for an item in an array by using strict equality (===) and returns the index position of the item.
indexOf(val:String, startIndex:Number) — Method in class String
 | Searches the string and returns the position of the first occurrence of val found at or after startIndex within the calling string.
indexToColumn(index:int) — Method in class mx.controls.listClasses.ListBase
 | The column for the data provider item at the given index.
indexToItemRenderer(index:int) — Method in class mx.controls.listClasses.ListBase
 | Get an item renderer for the index of an item in the data provider, if one exists.
indexToRow(index:int) — Method in class mx.controls.listClasses.ListBase
 | The row for the data provider item at the given index.
indicatorGap — Style in class mx.containers.Form
 | Number of pixels between the label and child components.
indicatorGap — Style in class mx.containers.FormHeading
 | Number of pixels between the label area and the heading text.
indicatorGap — Style in class mx.containers.FormItem
 | Number of pixels between the label and child components of the form item.
indicatorSkin — Style in class mx.containers.FormItem
 | Specifies the skin to use for the required field indicator.
indicesToIndex(rowIndex:int, colIndex:int) — Method in class mx.controls.listClasses.ListBase
 | Computes the offset into the data provider of the item at colIndex, rowIndex.
Infinity — Package constant property in Top Level
 | A special value representing positive Infinity.
-Infinity — Package constant property in Top Level
 | A special value representing negative Infinity.
inflate(dx:Number, dy:Number) — Method in class flash.geom.Rectangle
 | Increases the size of the Rectangle object by the specified amounts, in pixels.
inflatePoint(point:flash.geom:Point) — Method in class flash.geom.Rectangle
 | Increases the size of the Rectangle object.
info — Property in class flash.events.NetStatusEvent
 | An object with properties that describe the object's status or error condition.
info(message:String, ... rest) — Method in interface mx.logging.ILogger
 | Logs the specified data using the LogEvent.INFO level.
info(message:String, ... rest) — Method in class mx.logging.LogLogger
 | Logs the specified data using the LogEvent.INFO level.
info() — Method in class mx.managers.SystemManager
 | Overridden by autogenerated code.
INFO — Constant static property in class mx.logging.LogEventLevel
 | Designates informational messages that highlight the progress of the application at coarse-grained level.
INFO — Constant property in class mx.messaging.management.MBeanOperationInfo
 | The operation is purely informational with no side-effects, read-only.
inheritingStyles — Property in class mx.core.UIComponent
 | The beginning of this component's chain of inheriting styles.
inheritingStyles — Property in class mx.core.UITextField
 | The beginning of this UITextField's chain of inheriting styles.
inheritingStyles — Property in interface mx.styles.IStyleClient
 | An object containing the inheritable styles for this component.
init — Event in class flash.display.LoaderInfo
 | Dispatched when the properties and methods of a loaded SWF file are accessible.
init — Event in class mx.controls.SWFLoader
 | Dispatched when the properties and methods of a loaded SWF file are accessible.
INIT — Constant static property in class flash.events.Event
 | Defines the value of the type property of an init event object.
initChannelSet(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.Consumer
 | Consumer overrides this method and initializes its ChannelSet based upon the value of messageType.
initChannelSet(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageAgent
 | Used to automatically initialize the channelSet property for the MessageAgent before it connects for the first time.
INIT_COMPLETE — Constant static property in class mx.events.FlexEvent
 | Dispatched when a Flex application finishes initialization.
initEffect(event:flash.events:Event) — Method in class mx.effects.EffectInstance
 | This method is called if the effect was triggered by the EffectManager.
initialHeight — Property in class mx.core.MovieClipLoaderAsset
 | Backing storage for the measuredHeight property.
initializationComplete() — Method in class mx.core.UIComponent
 | Finalizes the initialization of this component.
initialize() — Method in interface mx.core.IUIComponent
 | Initialize the object.
initialize — Event in class mx.core.UIComponent
 | Dispatched when the component has finished its construction and has all initialization properties set.
initialize() — Method in class mx.core.UIComponent
 | Initializes the internal structure of this component.
initialize() — Method in class mx.core.UITextField
 | Initializes this component.
initialize(sm:mx.managers:ISystemManager) — Static method in class mx.managers.HistoryManager
 | Initializes the HistoryManager.
initialize() — Method in class mx.preloaders.DownloadProgressBar
 | Called by the Preloader after the download progress bar has been added as a child of the Preloader.
initialize() — Method in interface mx.preloaders.IPreloaderDisplay
 | Called by the Preloader after the download progress bar has been added as a child of the Preloader.
initialize(showDisplay:Boolean, displayClassName:Class, backgroundColor:uint, backgroundAlpha:Number, backgroundImage:Object, backgroundSize:String, displayWidth:Number, displayHeight:Number, libs:Array, sizes:Array) — Method in class mx.preloaders.Preloader
 | Called by the SystemManager to initialize a Preloader object.
initialize() — Method in class mx.states.AddChild
 | Initializes the override.
initialize() — Method in interface mx.states.IOverride
 | Initializes the override.
initialize() — Method in class mx.states.RemoveChild
 | IOverride interface method; this class implements it as an empty method.
initialize() — Method in class mx.states.SetEventHandler
 | IOverride interface method; this class implements it as an empty method.
initialize() — Method in class mx.states.SetProperty
 | IOverride interface method; this class implements it as an empty method.
initialize() — Method in class mx.states.SetStyle
 | IOverride interface method; this class implements it as an empty method.
INITIALIZE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.INITIALIZE constant defines the value of the type property of the event object for a initialize event.
initializeAccessibility() — Method in class mx.core.UIComponent
 | Initializes this component's accessibility code.
initialized(document:Object, id:String) — Method in class mx.collections.ListCollectionView
 | Called automatically by the MXML compiler when the ListCollectionView is created using an MXML tag.
initialized(document:Object, id:String) — Method in class mx.controls.RadioButtonGroup
 | Implementation of the IMXMLObject.initialized() method to support deferred instantiation.
initialized(document:Object, id:String) — Method in interface mx.core.IMXMLObject
 | Called after the implementing object has been created and all component properties specified on the MXML tag have been initialized.
initialized — Property in class mx.core.UIComponent
 | A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required).
initialized — Property in class mx.core.UITextField
 | A flag that determines if an object has been through all three phases of layout validation (provided that any were required)
initialized(document:Object, id:String) — Method in class mx.logging.AbstractTarget
 | Called after the implementing object has been created and all properties specified on the tag have been assigned.
initialized — Property in interface mx.managers.ILayoutManagerClient
 | A flag that determines if an object has been through all three phases of layout validation (provided that any were required) This flag should only be modified by the LayoutManager.
initialized(document:Object, id:String) — Method in class mx.messaging.MessageAgent
 | Called after the implementing object has been created and all properties specified on the tag have been assigned.
initialized(document:Object, id:String) — Method in class mx.rpc.http.mxml.HTTPService
 | If you create this class in ActionScript and want it to function with validation, you must call this method and pass in the MXML document and the HTTPService's id.
initialized(document:Object, id:String) — Method in class mx.rpc.remoting.mxml.RemoteObject
 | Called automatically by the MXML compiler if the RemoteObject is set up using a tag.
initialized(document:Object, id:String) — Method in class mx.rpc.soap.mxml.WebService
 | Called automatically by the MXML compiler if the WebService is setup using a tag.
initialized — Property in class mx.skins.ProgrammaticSkin
 | A flag that determines if an object has been through all three phases of layout: commitment, measurement, and layout (provided that any were required).
initialized(document:Object, id:String) — Method in class mx.validators.Validator
 | Called automatically by the MXML compiler when the Validator is created using an MXML tag.
initializeInterpolationData(srcCache:Array, dstCache:Array, iProps:Object, cacheType:Class, customData:Object) — Method in class mx.charts.chartClasses.Series
 | Helper function for Series to implement the interpolation effect.
initializeRepeater(container:mx.core:Container, recurse:Boolean) — Method in interface mx.core.IRepeater
 | Initializes a new Repeater object.
initializeRepeater(container:mx.core:Container, recurse:Boolean) — Method in class mx.core.Repeater
 | Initializes a new Repeater object.
initializeRepeaterArrays(parent:mx.core:IRepeaterClient) — Method in interface mx.core.IRepeaterClient
 | Initializes the instanceIndices, repeaterIndices, and repeaters properties.
initializeRepeaterArrays(parent:mx.core:IRepeaterClient) — Method in class mx.core.UIComponent
 | Initializes various properties which keep track of repeated instances of this component.
initializingLabel — Static property in class mx.preloaders.DownloadProgressBar
 | The string to display as the label while in the initializing phase.
initialWidth — Property in class mx.core.MovieClipLoaderAsset
 | Backing storage for the measuredWidth property.
initInstance(instance:mx.effects:EffectInstance) — Method in class mx.charts.effects.SeriesSlide
 | Copies properties of the effect to the effect instance.
initInstance(instance:mx.effects:EffectInstance) — Method in class mx.effects.Effect
 | Copies properties of the effect to the effect instance.
initListData(item:Object, treeListData:mx.controls.treeClasses:TreeListData) — Method in class mx.controls.Tree
 | Initializes a TreeListData object that is used by the tree item renderer.
initMaskEffect() — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Initializes the move and scale properties of the effect.
INIT_PROGRESS — Constant static property in class mx.events.FlexEvent
 | Dispatched when the Flex application completes an initialization phase, as defined by calls to the measure(), commitProperties(), or updateDisplayList() methods.
initProgressHandler(event:flash.events:Event) — Method in class mx.preloaders.DownloadProgressBar
 | Event listener for the FlexEvent.INIT_PROGRESS event.
initProtoChain() — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | Sets up the inheritingStyles and nonInheritingStyles objects and their proto chains so that the getStyle() method can work.
initSecondaryMode() — Method in class mx.charts.chartClasses.CartesianChart
 | Initializes the chart for displaying a second series.
inner — Property in class flash.filters.DropShadowFilter
 | Indicates whether or not the shadow is an inner shadow.
inner — Property in class flash.filters.GlowFilter
 | Specifies whether the glow is an inner glow.
inner — Property in class mx.effects.Glow
 | Specifies whether the glow is an inner glow.
inner — Property in class mx.effects.effectClasses.GlowInstance
 | The inner flag of the glow.
INNER — Constant static property in class flash.filters.BitmapFilterType
 | Defines the setting that applies a filter to the inner area of an object.
innerRadius — Style in class mx.charts.PieChart
 | Determines the size of the hole in the center of the pie chart.
innerRadius — Style in class mx.charts.series.PieSeries
 | A number from 0 to 1 specifying the distance from the center of the series to the inner edge of the rendered wedges, as a percentage of the total radius assigned to the series.
innerRadius — Property in class mx.charts.series.items.PieSeriesItem
 | The distance of the inner edge of this wedge from its origin, measured in pixels.
INPUT — Constant static property in class flash.text.TextFieldType
 | Used to specify an input TextField.
inputFormat — Property in class mx.validators.DateValidator
 | The date format to validate the value against.
inScopeNamespaces() — Method in class XML
 | Lists the namespaces for the XML object, based on the object's parent.
insert(item:Object) — Method in interface mx.collections.IViewCursor
 | Inserts the specified item before the cursor's current position.
INSERT — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Insert key (45).
insertBefore(node:flash.xml:XMLNode, before:flash.xml:XMLNode) — Method in class flash.xml.XMLNode
 | Inserts a new child node into the XML object's child list, before the beforeNode node.
insertChildAfter(child1:Object, child2:Object) — Method in class XML
 | Inserts the given child2 parameter after the child1 parameter in this XML object and returns the resulting object.
insertChildBefore(child1:Object, child2:Object) — Method in class XML
 | Inserts the given child2 parameter before the child1 parameter in this XML object and returns the resulting object.
INSERT_INTO_COLLECTION — Constant static property in class mx.data.UpdateCollectionRange
 | Indicates a range of items have been inserted into the collection.
insertPosition — Property in class mx.charts.chartClasses.InstanceCache
 | The position of the instance in the parent's child list.
insideCutoff — Property in class flash.text.CSMSettings
 | The inside cutoff value, above which densities are set to a maximum density value (such as 255).
insideLabelSizeLimit — Style in class mx.charts.series.PieSeries
 | Specifies the font size threshold, in points, below which inside labels are considered illegible.
InstanceCache — Class in package mx.charts.chartClasses
 | InstanceCache is a utilty that governs the task of creating and managing a set of n object instances, where n changes frequently.
InstanceCache(type:Object, parent:Object, insertPosition:int) — Constructor in class mx.charts.chartClasses.InstanceCache
 | Constructor.
instanceClass — Property in class mx.effects.Effect
 | An object of type Class that specifies the effect instance class class for this effect class.
instanceIndex — Property in class mx.core.UIComponent
 | The index of a repeated component.
instanceIndices — Property in interface mx.core.IRepeaterClient
 | An Array that contains the indices required to reference the repeated component instance from its document.
instanceIndices — Property in class mx.core.UIComponent
 | An Array containing the indices required to reference this UIComponent object from its parent document.
instanceof — Operator
 | Evaluates whether an expression's prototype chain includes the prototype object for function.
instances — Property in class mx.charts.chartClasses.InstanceCache
 | The Array of cached instances.
int — Final class in Top Level
 | The int class lets you work with the data type representing a 32-bit signed integer.
int(value) — Package function in Top Level
 | Converts a given numeric value to an integer value.
int(num:Object) — Constructor in class int
 | Constructor; creates a new int object.
integerError — Property in class mx.validators.NumberValidator
 | Error message when the number must be an integer, as defined by the domain property.
interactive — Property in class mx.charts.chartClasses.Series
 | Determines whether DataTips appear when users interact with chart data on the screen.
InteractiveObject — Class in package flash.display
 | The InteractiveObject class is the abstract base class for all display objects with which you can interact: mouse, keyboard, and focus.
InteractiveObject() — Constructor in class flash.display.InteractiveObject
 | Calling the new InteractiveObject() constructor throws an ArgumentError exception.
interface — Statement
 | Defines an interface.
internal — Statement
 | Specifies that a class, variable, constant or function is available to any caller within the same package.
internalConnect() — Method in class mx.messaging.Channel
 | Connects the Channel to its endpoint.
internalDisconnect(rejected:Boolean) — Method in class mx.messaging.Channel
 | Disconnects the Channel from its endpoint.
internalSend(messageResponder:mx.messaging:MessageResponder) — Method in class mx.messaging.Channel
 | Sends the Message out over the Channel and routes the response to the responder.
internalSend(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageAgent
 | Sends a Message from the MessageAgent to its destination using the agent's ChannelSet.
internalStyleName — Property in class mx.charts.chartClasses.DualStyleObject
 | The name of a class selector this instance inherits values from.
interpolate(pt1:flash.geom:Point, pt2:flash.geom:Point, f:Number) — Static method in class flash.geom.Point
 | Determines a point between two specified points.
interpolate(interpolationValues:Array, interpolationData:Object) — Method in class mx.charts.chartClasses.Series
 | Called by the SeriesInterpolate effect to advance an interpolation.
interpolate(interpolationValues:Array, interpolationData:Object) — Method in class mx.charts.series.PieSeries
 | Called by the SeriesInterpolate effect to advance an interpolation.
interpolateValues — Property in class mx.charts.series.LineSeries
 | Specifies how to represent missing data.
interpolationMethod — Property in class mx.graphics.LinearGradientStroke
 | A value from the InterpolationMethod class that specifies which value to use.
InterpolationMethod — Final class in package flash.display
 | The InterpolationMethod class provides values for the interpolationMethod parameter in the Graphics.beginGradientFill() and Graphics.lineGradientStyle() methods.
interpolationValues — Property in class mx.charts.effects.effectClasses.SeriesEffectInstance
 | The current position of each chart item being managed by this effect.
intersection(toIntersect:flash.geom:Rectangle) — Method in class flash.geom.Rectangle
 | If the Rectangle object specified in the toIntersect parameter intersects with this Rectangle object, returns the area of intersection as a Rectangle object.
intersects(toIntersect:flash.geom:Rectangle) — Method in class flash.geom.Rectangle
 | Determines whether the object specified in the toIntersect parameter intersects with this Rectangle object.
interval — Property in class mx.charts.DateTimeAxis
 | Specifies the number of labelUnits between label values along the axis.
interval — Property in class mx.charts.LinearAxis
 | Specifies the numeric difference between label values along the axis.
interval — Property in class mx.charts.LogAxis
 | Specifies the multiplier label values along the axis.
invalid — Event in class mx.core.UIComponent
 | Dispatched when a component is monitored by a Validator and the validation failed.
invalid — Event in class mx.validators.Validator
 | Dispatched when validation fails.
INVALID — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.INVALID constant defines the value of the type property of the event object for a invalid event.
INVALID — Constant static property in class mx.events.ValidationResultEvent
 | The ValidationResultEvent.INVALID constant defines the value of the type property of the event object for an invalid event.
invalidate() — Method in class flash.display.Stage
 | Calling the invalidate() method signals Flash Player to alert display objects on the next opportunity it has to render the display list (for example, when the playhead advances to a new frame).
invalidateCache() — Method in class mx.charts.chartClasses.NumericAxis
 | Invalidates the cached labels and tick marks that represent this axis's values.
invalidateChildOrder() — Method in class mx.charts.chartClasses.ChartBase
 | Informs the chart that its child list has been modified and should be re-ordererd.
invalidateData() — Method in class mx.charts.chartClasses.ChartBase
 | This method triggers a redraw of the chart.
invalidateData(invalid:Boolean) — Method in class mx.charts.chartClasses.Series
 | Informs the series that the underlying data in the dataProvider has changed.
invalidateData(invalid:Boolean) — Method in class mx.charts.series.AreaSeries
 | Informs the series that the underlying data in the dataProvider has changed.
invalidateData(invalid:Boolean) — Method in class mx.charts.series.BarSeries
 | Informs the series that the underlying data in the dataProvider has changed.
invalidateData(invalid:Boolean) — Method in class mx.charts.series.ColumnSeries
 | Informs the series that the underlying data in the dataProvider has changed.
invalidateDisplayList() — Method in class mx.charts.AxisRenderer
 | Marks a component so that its updateDisplayList() method gets called during a later screen update.
invalidateDisplayList() — Method in interface mx.core.IInvalidating
 | Calling this method results in a call to the component's validateDisplayList() method before the display list is rendered.
invalidateDisplayList() — Method in class mx.core.UIComponent
 | Marks a component so that its updateDisplayList() method gets called during a later screen update.
invalidateDisplayList() — Method in class mx.core.UITextField
 | Marks a component so that its updateDisplayList() method gets called during a later screen update.
invalidateDisplayList(obj:mx.managers:ILayoutManagerClient) — Method in class mx.managers.LayoutManager
 | Called when a component changes in some way that its layout and/or visuals need to be changed.
invalidateDisplayList() — Method in class mx.skins.ProgrammaticSkin
 | Marks a component so that its updateDisplayList() method gets called during a later screen update.
invalidateFilter(invalid:Boolean) — Method in class mx.charts.chartClasses.Series
 | Informs the series that the filter of the data against the axes has changed and must be recalculated.
invalidateList() — Method in class mx.controls.listClasses.ListBase
 | Refresh all rows on next update.
invalidateMapping(invalid:Boolean) — Method in class mx.charts.chartClasses.Series
 | Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
invalidateMapping(invalid:Boolean) — Method in class mx.charts.series.AreaSeries
 | Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
invalidateMapping(invalid:Boolean) — Method in class mx.charts.series.BarSeries
 | Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
invalidateMapping(invalid:Boolean) — Method in class mx.charts.series.ColumnSeries
 | Informs the series that the mapping of the data into numeric values has changed and must be recalculated.
invalidateProperties() — Method in class mx.core.ComponentDescriptor
 | Invalidates the cached properties property.
invalidateProperties() — Method in interface mx.core.IInvalidating
 | Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
invalidateProperties() — Method in class mx.core.UIComponent
 | Marks a component so that its commitProperties() method gets called during a later screen update.
invalidateProperties() — Method in class mx.core.UITextField
 | Marks a component so that its commitProperties() method gets called during a later screen update.
invalidateProperties(obj:mx.managers:ILayoutManagerClient) — Method in class mx.managers.LayoutManager
 | Adds an object to the list of components that want their validateProperties() method called.
invalidateProperties() — Method in class mx.skins.ProgrammaticSkin
 | Calling this method results in a call to the component's validateProperties() method before the display list is rendered.
invalidateSeries() — Method in class mx.charts.chartClasses.ChartBase
 | Informs the chart that its series Array has been modified and should be re-processed.
invalidateSeries() — Method in class mx.charts.chartClasses.StackedSeries
 | Call this method to trigger a call to the buildSubSeries() method on the next call to the commitProperties() method.
invalidateSeriesStyles() — Method in class mx.charts.chartClasses.ChartBase
 | Triggers a redraw of the chart.
invalidateSize() — Method in class mx.charts.AxisRenderer
 | Marks a component so that its measure() method gets called during a later screen update.
invalidateSize() — Method in class mx.charts.chartClasses.ChartLabel
 | Marks a component so that its measure() method gets called during a later screen update.
invalidateSize() — Method in interface mx.core.IInvalidating
 | Calling this method results in a call to the component's validateSize() method before the display list is rendered.
invalidateSize() — Method in class mx.core.UIComponent
 | Marks a component so that its measure() method gets called during a later screen update.
invalidateSize() — Method in class mx.core.UITextField
 | Marks a component so that its measure() method gets called during a later screen update.
invalidateSize(obj:mx.managers:ILayoutManagerClient) — Method in class mx.managers.LayoutManager
 | Adds an object to the list of components that want their validateSize() method called.
invalidateSize() — Method in class mx.skins.ProgrammaticSkin
 | Calling this method results in a call to the component's validateSize() method before the display list is rendered.
invalidateStacking() — Method in class mx.charts.chartClasses.StackedSeries
 | Call this method to trigger a regeneration of the stacked values on the next call to the commitProperties() method.
invalidateTransform(invalid:Boolean) — Method in class mx.charts.chartClasses.Series
 | Informs the series that the transform the data to screen coordinates has changed and must be recalculated.
invalidateTransitions() — Method in class mx.charts.chartClasses.Series
 | Informs the series that a significant change has occured in the display of data.
InvalidCategoryError — Class in package mx.logging.errors
 | This error is thrown when a category specified for a logger contains invalid characters or is malformed.
InvalidCategoryError(message:String) — Constructor in class mx.logging.errors.InvalidCategoryError
 | Constructor.
InvalidChannelError — Class in package mx.messaging.errors
 | This error is thrown when a Channel can't be accessed or is not valid for the current destination.
InvalidChannelError(msg:String) — Constructor in class mx.messaging.errors.InvalidChannelError
 | Constructs a new instance of an InvalidChannelError with the specified message.
invalidCharError — Property in class mx.validators.CreditCardValidator
 | Error message when the cardNumber field contains invalid characters.
invalidCharError — Property in class mx.validators.CurrencyValidator
 | Error message when the currency contains invalid characters.
invalidCharError — Property in class mx.validators.DateValidator
 | Error message when there are invalid characters in the date.
invalidCharError — Property in class mx.validators.EmailValidator
 | Error message when there are invalid characters in the e-mail address.
invalidCharError — Property in class mx.validators.NumberValidator
 | Error message when the value contains invalid characters.
invalidCharError — Property in class mx.validators.PhoneNumberValidator
 | Error message when the value contains invalid characters.
invalidCharError — Property in class mx.validators.SocialSecurityValidator
 | Error message when the value contains characters other than digits and formatting characters defined by the allowedFormatChars property.
invalidCharError — Property in class mx.validators.ZipCodeValidator
 | Error message when the ZIP code contains invalid characters.
INVALID_CONTENT_PATH — Constant static property in class mx.controls.videoClasses.VideoError
 | Invalid content path.
InvalidDestinationError — Class in package mx.messaging.errors
 | This error is thrown when a destination can't be accessed or is not valid.
InvalidDestinationError(msg:String) — Constructor in class mx.messaging.errors.InvalidDestinationError
 | Constructs a new instance of an InvalidDestinationError with the specified message.
invalidDomainError — Property in class mx.validators.EmailValidator
 | Error message when the suffix (the top level domain) is not 2, 3, 4 or 6 characters long.
invalidDomainError — Property in class mx.validators.ZipCodeValidator
 | Error message when the domain property contains an invalid value.
InvalidFilterError — Class in package mx.logging.errors
 | This error is thrown when a filter specified for a target contains invalid characters or is malformed.
InvalidFilterError(message:String) — Constructor in class mx.logging.errors.InvalidFilterError
 | Constructor.
invalidFormatCharsError — Property in class mx.validators.CurrencyValidator
 | Error message when the value contains an invalid formatting character.
invalidFormatCharsError — Property in class mx.validators.NumberValidator
 | Error message when the value contains invalid format characters, which means that it contains a digit or minus sign (-) as a separator character, or it contains two or more consecutive separator characters.
invalidIPDomainError — Property in class mx.validators.EmailValidator
 | Error message when the IP domain is invalid.
invalidNumberError — Property in class mx.validators.CreditCardValidator
 | Error message when the credit card number is invalid.
invalidPeriodsInDomainError — Property in class mx.validators.EmailValidator
 | Error message when there are continuous periods in the domain.
INVALID_SEEK — Constant static property in class mx.controls.videoClasses.VideoError
 | Invalid seek.
InvalidSWFError — Dynamic class in package flash.errors
INVALID_XML — Constant static property in class mx.controls.videoClasses.VideoError
 | Invalid XML.
invert() — Method in class flash.geom.Matrix
 | Performs the opposite transformation of the original matrix.
INVERT — Constant static property in class flash.display.BlendMode
 | Inverts the background.
invertTransform(value:Number) — Method in class mx.charts.CategoryAxis
 | Maps a position along the axis back to a numeric data value.
invertTransform(... rest) — Method in class mx.charts.chartClasses.CartesianTransform
 | Transforms x and y coordinates relative to the DataTransform coordinate system into a 2-dimensional value in data space.
invertTransform(... rest) — Method in class mx.charts.chartClasses.DataTransform
 | Transforms x and y coordinates relative to the DataTransform coordinate system into a two-dimensional value in data space.
invertTransform(value:Number) — Method in interface mx.charts.chartClasses.IAxis
 | Maps a position along the axis back to a numeric data value.
invertTransform(value:Number) — Method in class mx.charts.chartClasses.NumericAxis
 | Maps a position along the axis back to a numeric data value.
invoke — Event in class mx.rpc.AbstractService
 | The invoke event is dispatched when a service Operation is invoked so long as an Error is not thrown before the Channel attempts to send the message.
invoke(msg:mx.messaging.messages:IMessage, responder:mx.rpc:IResponder) — Method in class mx.rpc.AsyncRequest
 | Dispatches the asynchronous request and stores the responder to call later.
invoke — Event in class mx.rpc.http.HTTPService
 | The invoke event is fired when an HTTPService call is invoked so long as an Error is not thrown before the Channel attempts to send the message.
INVOKE — Constant static property in class mx.rpc.events.InvokeEvent
 | The INVOKE event type.
InvokeEvent — Class in package mx.rpc.events
 | The event that indicates an RPC operation has been invoked.
InvokeEvent(type:String, bubbles:Boolean, cancelable:Boolean, token:mx.rpc:AsyncToken, message:mx.messaging.messages:IMessage) — Constructor in class mx.rpc.events.InvokeEvent
 | Create a new InvokeEvent.
ioError — Event in class flash.display.LoaderInfo
 | Dispatched when an input or output error occurs that causes a load operation to fail.
ioError — Event in class flash.media.Sound
 | Dispatched when an input/output error occurs that causes a load operation to fail.
ioError — Event in class flash.net.FileReference
 | Dispatched when the upload or download fails.
ioError — Event in class flash.net.NetConnection
 | Dispatched when an input or output error occurs that causes a network operation to fail.
ioError — Event in class flash.net.NetStream
 | Dispatched when an input or output error occurs that causes a network operation to fail.
ioError — Event in class flash.net.Socket
 | Dispatched when an input/output error occurs that causes a send or load operation to fail.
ioError — Event in class flash.net.URLLoader
 | Dispatched if a call to URLLoader.load() results in a fatal error that terminates the download.
ioError — Event in class flash.net.URLStream
 | Dispatched when an input/output error occurs that causes a load operation to fail.
ioError — Event in class flash.net.XMLSocket
 | Dispatched when an input/output error occurs that causes a send or receive operation to fail.
ioError — Event in class mx.controls.SWFLoader
 | Dispatched when an input/output error occurs.
ioError — Event in class mx.effects.SoundEffect
 | Dispatched when an error occurs during the loading of the sound file.
IOError — Dynamic class in package flash.errors
 | The IOError exception is thrown when some type of input or output failure occurs.
IOError(message:String) — Constructor in class flash.errors.IOError
 | Creates a new IOError object.
IO_ERROR — Constant static property in class flash.events.IOErrorEvent
 | Defines the value of the type property of an ioError event object.
IOErrorEvent — Class in package flash.events
 | Flash® Player dispatches an IOErrorEvent object when an error causes a send or load operation to fail.
IOErrorEvent(type:String, bubbles:Boolean, cancelable:Boolean, text:String) — Constructor in class flash.events.IOErrorEvent
 | Creates an Event object that contains specific information about ioError events.
IOverride — Interface in package mx.states
 | The IOverride interface is used for view state overrides.
IPreloaderDisplay — Interface in package mx.preloaders
 | The IPreloaderDisplay interface defines the inteface that a class must implement to be used as a download progress bar.
IPropertyChangeNotifier — Interface in package mx.core
 | The IPropertyChangeNotifier interface defines a marker interface.
IRawChildrenContainer — Interface in package mx.core
 | The IRawChildrenContainer interface defines the APIs for containers that can return an IChildList that represents all their children.
IRepeater — Interface in package mx.core
 | The IRepeater interface defines the APIs for Repeater public APIs of the Repeater object.
IRepeaterClient — Interface in package mx.core
 | The IRepeaterClient interface defines the APIs for components that can have multiple instances created by a Repeater.
IResponder — Interface in package mx.rpc
 | This interface provides the contract for any service that needs to respond to remote or asynchronous calls.
Iris — Class in package mx.effects
 | The Iris effect animates the effect target by expanding or contracting a rectangular mask centered on the target.
Iris(target:Object) — Constructor in class mx.effects.Iris
 | Constructor.
IrisInstance — Class in package mx.effects.effectClasses
 | The IrisInstance class implements the instance class for the Iris effect.
IrisInstance(target:Object) — Constructor in class mx.effects.effectClasses.IrisInstance
 | Constructor.
is — Operator
 | Evaluates whether an object is compatible with a specific data type, class, or interface.
isAccessible() — Static method in class flash.ui.Keyboard
 | Specifies whether the last key pressed is accessible by other SWF files.
isAttribute(name) — Method in class flash.utils.Proxy
 | Checks whether a supplied QName is also marked as an attribute.
isBranch(node:Object, model:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Tests a node for termination.
isBranch(node:Object, model:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Tests a node for termination.
isBranch(node:Object, model:Object) — Method in interface mx.controls.treeClasses.ITreeDataDescriptor
 | Tests a node for termination.
isBuffering — Property in class flash.media.Sound
 | Returns the buffering state of external MP3 files.
isColorName(colorName:String) — Static method in class mx.styles.StyleManager
 | Tests to see if the given String is an alias for a color value.
isCompensating(msg:mx.data.messages:DataAssociationMessage) — Method in class mx.data.messages.DataAssociationMessage
 | Determines whether the passed message is compensating to the current message.
isCreate() — Method in interface mx.data.IChangeObject
 | Indicates if the change is due to a new item.
isCreate() — Method in class mx.data.messages.DataMessage
 | Returns true if this is a create operation.
isDebug() — Static method in class mx.logging.Log
 | Indicates whether a debug level log event will be processed by a log target.
isDebugger — Static property in class flash.system.Capabilities
 | Specifies whether the player is a special debugging version (true), or an officially released version (false).
isDefaultPrevented() — Method in class flash.events.Event
 | Checks whether preventDefault() has been called on the event.
isDelete() — Method in interface mx.data.IChangeObject
 | Indicates if the item was deleted.
isDocument — Property in interface mx.core.IRepeaterClient
 | Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component.
isDocument — Property in class mx.core.UIComponent
 | Determines whether this UIComponent instance is a document object, that is, whether it is at the top of the hierarchy of a Flex application, MXML component, or ActionScript component.
isDragging — Static property in class mx.managers.DragManager
 | Read-only property that returns true if a drag is in progress.
isEmpty() — Method in class flash.geom.Rectangle
 | Determines whether or not this Rectangle object is empty.
isEmptyUpdate() — Method in class mx.data.messages.DataMessage
 | Returns true if this message is both an update and its list of property names has a length of zero.
isEnabled(node:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Returns whether the node is enabled.
isEnabled(node:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Returns whether the node is enabled.
isError() — Static method in class mx.logging.Log
 | Indicates whether an error level log event will be processed by a log target.
isError — Property in class mx.validators.ValidationResult
 | Contains true if the field generated a validation failure.
isFatal() — Static method in class mx.logging.Log
 | Indicates whether a fatal level log event will be processed by a log target.
isFinite(num) — Package function in Top Level
 | Returns true if the value is a finite number, or false if the value is Infinity or -Infinity.
isFocusInaccessible() — Method in class flash.display.Stage
 | Determines whether the Stage.focus property returns null for security reasons.
isFontFaceEmbedded(tf:flash.text:TextFormat) — Method in interface mx.managers.ISystemManager
 | Returns true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.
isFontFaceEmbedded(tf:flash.text:TextFormat) — Method in class mx.managers.SystemManager
 | Returns true if the required font face is embedded in this application, or has been registered globally by using the Font.registerFont() method.
isHttpsURL(url:String) — Static method in class mx.utils.URLUtil
isHttpURL(url:String) — Static method in class mx.utils.URLUtil
 | Determines if the URL starts with either http:, https:, or rtmp: followed by two slashes.
ISimpleStyleClient — Interface in package mx.styles
 | This interface describes the properties and methods that an object must implement so that it can participate in the style subsystem.
isInfo() — Static method in class mx.logging.Log
 | Indicates whether an info level log event will be processed by a log target.
isInheritingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Tests to see if a style is inheriting.
isInheritingTextFormatStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Test to see if a TextFormat style is inheriting.
isInvalid() — Method in class mx.managers.LayoutManager
 | Returns true if there are components that need validating; false if all components have been validated.
isIs — Property in class mx.messaging.management.MBeanAttributeInfo
 | Indicates if the server-side getter for the attribute has an 'is' prefix.
isItemHighlighted(data:Object) — Method in class mx.controls.listClasses.ListBase
 | Determines if the item renderer for a data provider item is highlighted (is rolled over via the mouse or or under the caret via keyboard navigation).
isItemOpen(item:Object) — Method in class mx.controls.Tree
 | Returns true if the specified item branch is open (is showing its children).
isItemSelected(data:Object) — Method in class mx.controls.listClasses.ListBase
 | Determines if the item renderer for a data provider item is selected.
isItemVisible(item:Object) — Method in class mx.controls.listClasses.ListBase
 | Determines if an item is being displayed by a renderer.
isLoading — Property in class mx.effects.SoundEffect
 | This property is true if the MP3 has been loaded.
isLoading — Property in class mx.effects.effectClasses.SoundEffectInstance
 | This property is true if the MP3 has been loaded.
isNaN(num) — Package function in Top Level
 | Returns true if the value is NaN(not a number).
isOurFocus(target:flash.display:DisplayObject) — Method in class mx.core.UIComponent
 | Typically overridden by components containing UITextField objects, where the UITextField object gets focus.
isParentDisplayListInvalidatingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Tests to see if this style affects the component's parent container in such a way as to require that the parent container redraws itself when this style changes.
isParentSizeInvalidatingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Tests to see if the style changes the size of the component's parent container.
isPlaying — Property in class mx.effects.Effect
 | A read-only flag which is true if any instances of the effect are currently playing, and false if none are.
isPopUp — Property in class mx.core.UIComponent
 | Set to true by the PopUpManager to indicate that component has been popped up.
isPrototypeOf(theClass:Object) — Method in class Object
 | Indicates whether an instance of the Object class is in the prototype chain of the object specified as the parameter.
isRealValue(value:Object) — Method in class mx.validators.NumberValidator
 | Determines if the value is not null and not NaN value.
isRealValue(value:Object) — Method in class mx.validators.Validator
 | Returns true if value is null.
isSimple(value:Object) — Static method in class mx.utils.ObjectUtil
 | Returns true if the object reference specified is a simple data type.
isSizeInvalidatingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Tests to see if a style changes the size of a component.
isStyle — Property in class mx.effects.AnimateProperty
 | If true, the property attribute is a style and you set it by using the setStyle() method.
isStyle — Property in class mx.effects.effectClasses.AnimatePropertyInstance
 | If true, the property attribute is a style and you set it by using the setStyle() method.
IStackable — Interface in package mx.charts.chartClasses
 | The IStackable interface is implemented by any series that can be stacked.
isToggled(node:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Returns whether the node is toggled.
isToggled(node:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Returns whether the node is toggled.
isTopLevel() — Method in interface mx.managers.ISystemManager
 | Returns true if this ISystemManager is responsible for an application window, and false if this application has been loaded into another application.
isTopLevel() — Method in class mx.managers.SystemManager
 | Returns true if this ISystemManager is responsible for an application window, and false if this application has been loaded into another application.
isTopLevelWindow(object:flash.display:DisplayObject) — Method in class mx.managers.SystemManager
 | Returns true if the DisplayObject is the top-level window.
IStroke — Interface in package mx.graphics
 | Defines the interface that classes that define a line must implement.
IStyleClient — Interface in package mx.styles
 | This interface describes the properties and methods that an object must implement so that it can fully participate in the style subsystem.
isUpdate() — Method in interface mx.data.IChangeObject
 | Indicates if the change is due to an update.
isValid — Property in class mx.formatters.NumberBase
 | If true, the format succeeded, otherwise it is false.
isValidStyleValue(value) — Static method in class mx.styles.StyleManager
 | Determines if a specified parameter is a valid style property.
isWarn() — Static method in class mx.logging.Log
 | Indicates whether a warn level log event will be processed by a log target.
isWatching() — Method in class mx.binding.utils.ChangeWatcher
 | Returns true if each watcher in the chain is attached to at least one change event.
isWhitespace(character:String) — Static method in class mx.utils.StringUtil
 | Returns true if the specified string is a single space, tab, carriage return, newline, or formfeed character.
isXMLName(str) — Package function in Top Level
 | Determines whether the specified string is a valid name for an XML element or attribute.
ISystemManager — Interface in package mx.managers
 | An ISystemManager manages an "application window".
italic — Property in class flash.text.TextFormat
 | Indicates whether text in this text format is italicized.
ITALIC — Constant static property in class flash.text.FontStyle
 | Defines the italic style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method.
item — Property in class mx.charts.ChartItem
 | The item from the series' dataProvider that the ChartItem represents.
item — Property in class mx.charts.HitData
 | Specifies the data item that the HitData structure describes.
item — Property in class mx.charts.events.LegendMouseEvent
 | The item in the Legend on which this event was triggered.
item — Property in class mx.controls.treeClasses.TreeListData
 | The data for this item in the Tree control.
item — Property in class mx.data.events.DataServiceFaultEvent
 | Stores the item that generated the fault.
item — Property in class mx.events.ItemClickEvent
 | The item in the data provider of the associated navigation item.
item — Property in class mx.events.MenuEvent
 | The specific item in the dataProvider.
item — Property in class mx.events.TreeEvent
 | Storage for the node property.
itemClick — Event in class mx.charts.Legend
 | Dispatched when the user clicks on a LegendItem in the Legend control.
itemClick — Event in class mx.charts.chartClasses.ChartBase
 | Dispatched when a data point is found under the mouse pointer when it is clicked.
itemClick — Event in class mx.controls.ButtonBar
 | Dispatched when a user clicks a button.
itemClick — Event in class mx.controls.Menu
 | Dispatched when a menu item is selected.
itemClick — Event in class mx.controls.MenuBar
 | Dispatched when the user selects a menu item.
itemClick — Event in class mx.controls.NavBar
 | Dispatched when a navigation item is selected.
itemClick — Event in class mx.controls.PopUpMenuButton
 | Dispatched when a user selects an item from the pop-up menu.
itemClick — Event in class mx.controls.RadioButtonGroup
 | Dispatched when a user selects a RadioButton control in the group.
itemClick — Event in class mx.controls.TabBar
 | Dispatched when a tab navigation item is selected.
itemClick — Event in class mx.controls.listClasses.ListBase
 | Dispatched when the user clicks on an item in the control.
ITEM_CLICK — Constant static property in class mx.charts.events.ChartItemEvent
 | Event type constant; indicates that the user clicked the mouse button over a chart item representing data in the chart.
ITEM_CLICK — Constant static property in class mx.charts.events.LegendMouseEvent
 | Event type constant; indicates that the user clicked the mouse button over a legend item.
ITEM_CLICK — Constant static property in class mx.events.ItemClickEvent
 | The ItemClickEvent.ITEM_CLICK constant defines the value of the type property of the event object for an itemClick event.
ITEM_CLICK — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_CLICK constant defines the value of the type property of the ListEvent object for an itemClick event, which indicates that the user clicked the mouse over a visual item in the control.
ITEM_CLICK — Constant static property in class mx.events.MenuEvent
 | The MenuEvent.ITEM_CLICK event type constant indicates that the user selected a menu item.
ItemClickEvent — Class in package mx.events
 | Represents events that are dispatched when a navigation item on a navigator bar, such as a ButtonBar, LinkBar, or TabBar control, has been clicked.
ItemClickEvent(type:String, bubbles:Boolean, cancelable:Boolean, label:String, index:int, relatedObject:flash.display:InteractiveObject, item:Object) — Constructor in class mx.events.ItemClickEvent
 | Constructor.
itemClose — Event in class mx.controls.Tree
 | Dispatched when a branch is closed or collapsed.
ITEM_CLOSE — Constant static property in class mx.events.TreeEvent
 | The TreeEvent.ITEM_CLOSE event type constant indicates that a tree branch closed or collapsed.
itemDoubleClick — Event in class mx.charts.chartClasses.ChartBase
 | Dispatched when a data point is found under the mouse pointer when it is double clicked.
itemDoubleClick — Event in class mx.controls.listClasses.ListBase
 | Dispatched when the user double-clicks on an item in the control.
ITEM_DOUBLE_CLICK — Constant static property in class mx.charts.events.ChartItemEvent
 | Event type constant; indicates that the user double-clicked the mouse button over a chart item representing data in the chart.
ITEM_DOUBLE_CLICK — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_DOUBLE_CLICK constant defines the value of the type property of the ListEvent object for an itemDoubleClick event, which indicates that the user double clicked the mouse over a visual item in the control.
itemDownSkin — Style in class mx.controls.MenuBar
 | The skin when a MenuBar item is selected.
itemEditBegin — Event in class mx.controls.DataGrid
 | Dispatched when the editedItemPosition property has been set and the item can be edited.
itemEditBegin — Event in class mx.controls.List
 | Dispatched when the editedItemPosition property is set and the item can be edited.
ITEM_EDIT_BEGIN — Constant static property in class mx.events.DataGridEvent
 | The DataGridEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited.
ITEM_EDIT_BEGIN — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_EDIT_BEGIN constant defines the value of the type property of the event object for a itemEditBegin event, which indicates that an item is ready to be edited.
itemEditBeginning — Event in class mx.controls.DataGrid
 | Dispatched when the user releases the mouse button while over an item renderer, tabs to the DataGrid control or within the DataGrid control, or in any other way attempts to edit an item.
itemEditBeginning — Event in class mx.controls.List
 | Dispatched when the user releases the mouse button while over an item, tabs to the List or within the List, or in any other way attempts to edit an item.
ITEM_EDIT_BEGINNING — Constant static property in class mx.events.DataGridEvent
 | The DataGridEvent.ITEM__EDIT_BEGINNING constant defines the value of the type property of the event object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item.
ITEM_EDIT_BEGINNING — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_EDIT_BEGINNING constant defines the value of the type property of the ListEvent object for a itemEditBeginning event, which indicates that the user has prepared to edit an item, for example, by releasing the mouse button over the item.
itemEditEnd — Event in class mx.controls.DataGrid
 | Dispatched when an item editing session ends for any reason.
itemEditEnd — Event in class mx.controls.List
 | Dispatched when an item editing session is ending for any reason.
ITEM_EDIT_END — Constant static property in class mx.events.DataGridEvent
 | The DataGridEvent.ITEM_EDIT_END constant defines the value of the type property of the event object for a itemEditEnd event, which indicates that an edit session is ending.
ITEM_EDIT_END — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_EDIT_END constant defines the value of the type property of the ListEvent object for a itemEditEnd event, which indicates that an edit session is ending.
itemEditor — Property in class mx.controls.List
 | The class factory for the item editor to use for the control, if the editable property is set to true.
itemEditor — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A class factory for the instances of the item editor to use for the column, when it is editable.
itemEditorInstance — Property in class mx.controls.DataGrid
 | A reference to the currently active instance of the item editor, if it exists.
itemEditorInstance — Property in class mx.controls.List
 | A reference to the currently active instance of the item editor, if it exists.
itemFocusIn — Event in class mx.controls.DataGrid
 | Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the DataGrid control or navigates to the item using a keyboard.
itemFocusIn — Event in class mx.controls.List
 | Dispatched when an item renderer gets focus, which can occur if the user clicks on an item in the List control or navigates to the item using a keyboard.
ITEM_FOCUS_IN — Constant static property in class mx.events.DataGridEvent
 | The DataGridEvent.ITEM_FOCUS_IN constant defines the value of the type property of the event object for a itemFocusIn event, which indicates that an item has received the focus.
ITEM_FOCUS_IN — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_FOCUS_IN constant defines the value of the type property of the ListEvent object for an itemFocusIn event, which indicates that an item has received the focus.
itemFocusOut — Event in class mx.controls.DataGrid
 | Dispatched when an item renderer loses focus, which can occur if the user clicks another item in the DataGrid control or clicks outside the control, or uses the keyboard to navigate to another item in the DataGrid control or outside the control.
itemFocusOut — Event in class mx.controls.List
 | Dispatched when an item renderer loses the focus, which can occur if the user clicks another item in the List control or outside the list, or uses the keyboard to navigate to another item in the List control or outside the List control.
ITEM_FOCUS_OUT — Constant static property in class mx.events.DataGridEvent
 | The DataGridEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the event object for a itemFocusOut event, which indicates that an item has lost the focus.
ITEM_FOCUS_OUT — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_FOCUS_OUT constant defines the value of the type property of the ListEvent object for an itemFocusOut event, which indicates that an item has lost the focus.
itemIcons — Property in class mx.controls.Tree
 | An object that specifies the icons for the items.
itemMouseDown — Event in class mx.charts.Legend
 | Dispatched when the user presses the mouse button while over a LegendItem in the Legend control.
itemMouseDown — Event in class mx.charts.chartClasses.ChartBase
 | Dispatched when a data point is found under the mouse pointer when it is pressed down.
ITEM_MOUSE_DOWN — Constant static property in class mx.charts.events.ChartItemEvent
 | Event type constant; indicates that the user pressed the mouse button over a chart item representing data in the chart.
ITEM_MOUSE_DOWN — Constant static property in class mx.charts.events.LegendMouseEvent
 | Event type constant; indicates that the user clicked the mouse button over a legend item.
itemMouseMove — Event in class mx.charts.chartClasses.ChartBase
 | Dispatched when the mouse pointer moves while over a data point.
ITEM_MOUSE_MOVE — Constant static property in class mx.charts.events.ChartItemEvent
 | Event type constant; indicates that the user moved the mouse pointer while hovering over a chart item representing data in the chart.
itemMouseOut — Event in class mx.charts.Legend
 | Dispatched when the user moves the mouse off of a LegendItem in the Legend.
ITEM_MOUSE_OUT — Constant static property in class mx.charts.events.LegendMouseEvent
 | Event type constant; indicates that the user rolled the mouse pointer away from a legend item.
itemMouseOver — Event in class mx.charts.Legend
 | Dispatched when the user moves the mouse over a LegendItem in the Legend control.
ITEM_MOUSE_OVER — Constant static property in class mx.charts.events.LegendMouseEvent
 | Event type constant; indicates that the user rolled the mouse pointer over a legend item.
itemMouseUp — Event in class mx.charts.Legend
 | Dispatched when the user releases the mouse button while over a LegendItem in the Legend.
itemMouseUp — Event in class mx.charts.chartClasses.ChartBase
 | Dispatched when a data point is found under the mouse pointer when it is released.
ITEM_MOUSE_UP — Constant static property in class mx.charts.events.ChartItemEvent
 | Event type constant; indicates that the user released the mouse button while over a chart item representing data in the chart.
ITEM_MOUSE_UP — Constant static property in class mx.charts.events.LegendMouseEvent
 | Event type constant; indicates that the user released the mouse button while over a legend item.
itemOldY — Property in class mx.controls.listClasses.ListRowInfo
 | The last Y value for the renderer.
itemOpen — Event in class mx.controls.Tree
 | Dispatched when a branch is opened or expanded.
ITEM_OPEN — Constant static property in class mx.events.TreeEvent
 | The TreeEvent.ITEM_OPEN event type constant indicates that a tree branch opened or expaneded.
itemOpening — Event in class mx.controls.Tree
 | Dispatched when a branch open or close is initiated.
ITEM_OPENING — Constant static property in class mx.events.TreeEvent
 | The TreeEvent.ITEM_OPENING event type constant is dispatched immediately before a tree opens or closes.
itemOverSkin — Style in class mx.controls.MenuBar
 | The skin when focus is over a MenuBar item either.
ItemPendingError — Class in package mx.collections.errors
 | This error is thrown when retrieving an item from a collection view requires an asynchronous call.
ItemPendingError(message:String) — Constructor in class mx.collections.errors.ItemPendingError
 | Constructor.
ItemReference — Dynamic class in package mx.data
 | An ItemReference instance is returned from the DataService.getItem() and DataService.createItem() methods to provide you with a way to manage your reference to the remote object.
ItemReference(msg:mx.messaging.messages:IMessage) — Constructor in class mx.data.ItemReference
itemRenderer — Property in class mx.charts.ChartItem
 | The instance of the chart's itemRenderer that represents this ChartItem.
itemRenderer — Style in class mx.charts.chartClasses.HLOCSeriesBase
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Style in class mx.charts.series.AreaSeries
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Style in class mx.charts.series.BarSeries
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Style in class mx.charts.series.BubbleSeries
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Style in class mx.charts.series.ColumnSeries
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Style in class mx.charts.series.LineSeries
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Style in class mx.charts.series.PieSeries
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Style in class mx.charts.series.PlotSeries
 | A factory that represents the class the series will use to represent individual items on the chart.
itemRenderer — Property in class mx.controls.ComboBox
 | IFactory that generates the instances that displays the data for the drop-down list of the control.
itemRenderer — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The class factory for item renderer instances that display the data for each item in the column.
itemRenderer — Property in class mx.controls.listClasses.ListBase
 | The custom item renderer for the control.
itemRenderer — Property in class mx.events.DataGridEvent
 | The item renderer for the item that is being edited or the header render that is being clicked or stretched.
itemRenderer — Property in class mx.events.ListEvent
 | The item renderer where the event occurred.
itemRenderer — Property in class mx.events.TreeEvent
 | The ListItemRenderer for the node that closed or opened.
itemRendererContains(renderer:mx.controls.listClasses:IListItemRenderer, object:flash.display:DisplayObject) — Method in class mx.controls.listClasses.ListBase
 | Determines whether a renderer contains (or owns) a display object.
itemRendererToIndex(itemRenderer:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.ListBase
 | Returns the index of the item in the data provider of the item being rendered by this item renderer.
itemRendererToIndices(item:mx.controls.listClasses:IListItemRenderer) — Method in class mx.controls.listClasses.ListBase
 | Returns a Point containing the columnIndex and rowIndex of an item renderer.
ItemResponder — Class in package mx.collections
 | The ItemResponder class provides a default implementation of the mx.rpc.IResponder interface.
ItemResponder(result:Function, fault:Function, token:Object) — Constructor in class mx.collections.ItemResponder
 | Constructs an instance of the responder with the specified data and handlers.
itemRollOut — Event in class mx.charts.chartClasses.ChartBase
 | Dispatched when the closest data point under the mouse pointer changes.
itemRollOut — Event in class mx.controls.ColorPicker
 | Dispatched when the user rolls the mouse out of a swatch in the SwatchPanel object.
itemRollOut — Event in class mx.controls.ComboBox
 | Dispatched when user rolls the mouse out of a drop-down list item.
itemRollOut — Event in class mx.controls.MenuBar
 | Dispatched when the mouse pointer rolls out of a menu item.
itemRollOut — Event in class mx.controls.listClasses.ListBase
 | Dispatched when the user rolls the mouse pointer out of an item in the control.
ITEM_ROLL_OUT — Constant static property in class mx.charts.events.ChartItemEvent
 | Event type constant; indicates that the user rolled the mouse pointer away from a chart item representing data in the chart.
ITEM_ROLL_OUT — Constant static property in class mx.events.ColorPickerEvent
 | The ColorPickerEvent.ITEM_ROLL_OUT constant defines the value of the type property of the event that is dispatched when the user rolls the mouse out of a swatch in the swatch panel.
ITEM_ROLL_OUT — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_ROLL_OUT constant defines the value of the type property of the ListEvent object for an itemRollOut event, which indicates that the user rolled the mouse pointer out of a visual item in the control.
ITEM_ROLL_OUT — Constant static property in class mx.events.MenuEvent
 | The MenuEvent.ITEM_ROLL_OUT type constant indicates that the mouse pointer rolled out of a menu item.
itemRollOver — Event in class mx.charts.chartClasses.ChartBase
 | Dispatched when a new data point is found under the mouse pointer.
itemRollOver — Event in class mx.controls.ColorPicker
 | Dispatched when the user rolls the mouse over a swatch in the SwatchPanel object.
itemRollOver — Event in class mx.controls.ComboBox
 | Dispatched when the user rolls the mouse over a drop-down list item.
itemRollOver — Event in class mx.controls.MenuBar
 | Dispatched when the mouse pointer rolls over a menu item.
itemRollOver — Event in class mx.controls.listClasses.ListBase
 | Dispatched when the user rolls the mouse pointer over an item in the control.
ITEM_ROLL_OVER — Constant static property in class mx.charts.events.ChartItemEvent
 | Event type constant; indicates that the user rolled the mouse pointer over a chart item representing data in the chart.
ITEM_ROLL_OVER — Constant static property in class mx.events.ColorPickerEvent
 | The ColorPickerEvent.ITEM_ROLL_OVER constant defines the value of the type property of the event that is dispatched when the user rolls the mouse over of a swatch in the swatch panel.
ITEM_ROLL_OVER — Constant static property in class mx.events.ListEvent
 | The ListEvent.ITEM_ROLL_OVER constant defines the value of the type property of the ListEvent object for an itemRollOver event, which indicates that the user rolled the mouse pointer over a visual item in the control.
ITEM_ROLL_OVER — Constant static property in class mx.events.MenuEvent
 | The MenuEvent.ITEM_ROLL_OVER type constant indicates that the mouse pointer rolled over a menu item.
items — Property in class mx.charts.series.items.LineSeriesSegment
 | The array of chartItems representing the full line series that owns this segment.
items — Property in class mx.events.CollectionEvent
 | When the kind is CollectionEventKind.ADD or CollectionEventKind.REMOVE the items property is an Array of added/removed items.
itemsNeedMeasurement — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether the columnWidth and rowHeight properties need to be calculated.
itemsSizeChanged — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates that the size of the renderers may have changed.
itemToDataTip(data:Object) — Method in class mx.controls.dataGridClasses.DataGridColumn
 | Returns a String that the item renderer displays as the datatip for the given data object, based on the dataTipField and dataTipFunction properties.
itemToDataTip(data:Object) — Method in class mx.controls.listClasses.ListBase
 | Returns the dataTip string the renderer would display for the given data object based on the dataTipField and dataTipFunction properties.
itemToIcon(data:Object) — Method in class mx.controls.listClasses.ListBase
 | Returns the class for an icon, if any, for a data item, based on the iconField and iconFunction properties.
itemToItemRenderer(item:Object) — Method in class mx.controls.listClasses.ListBase
 | Returns the item renderer for a given item in the data provider, if there is one.
itemToLabel(item:Object) — Method in class mx.controls.ComboBox
 | Returns a string representing the item parameter.
itemToLabel(data:Object) — Method in class mx.controls.dataGridClasses.DataGridColumn
 | Returns the String that the item renderer displays for the given data object.
itemToLabel(data:Object) — Method in class mx.controls.listClasses.ListBase
 | Returns the string the renderer would display for the given data object based on the labelField and labelFunction properties.
itemToUID(data:Object) — Method in class mx.controls.ComboBase
 | Determines the UID for a dataProvider item.
itemToUID(data:Object) — Method in class mx.controls.listClasses.ListBase
 | Determines the UID for a data provider item.
itemType — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | The subtype of ChartItem used by this series to represent individual items.
itemType — Property in class mx.charts.series.AreaSeries
 | The subtype of ChartItem used by this series to represent individual items.
itemType — Property in class mx.charts.series.BarSeries
 | The subtype of ChartItem used by this series to represent individual items.
itemType — Property in class mx.charts.series.BubbleSeries
 | The subtype of ChartItem used by this series to represent individual items.
itemType — Property in class mx.charts.series.ColumnSeries
 | The subtype of ChartItem used by this series to represent individual items.
itemType — Property in class mx.charts.series.LineSeries
 | The subtype of ChartItem used by this series to represent individual items.
itemType — Property in class mx.charts.series.PieSeries
 | The subtype of ChartItem used by this series to represent individual items.
itemType — Property in class mx.charts.series.PlotSeries
 | The subtype of ChartItem used by this series to represent individual items.
itemUpdated(item:Object, property:Object, oldValue:Object, newValue:Object) — Method in interface mx.collections.ICollectionView
 | Notifies the view that an item has been updated.
itemUpdated(item:Object, property:Object, oldValue:Object, newValue:Object) — Method in interface mx.collections.IList
 | Notifies the view that an item has been updated.
itemUpdated(item:Object, property:Object, oldValue:Object, newValue:Object) — Method in class mx.collections.ListCollectionView
 | Notifies the view that an item has been updated.
itemUpSkin — Style in class mx.controls.MenuBar
 | The skin when a MenuBar item is not selected.
iterator — Property in class mx.controls.ComboBase
 | The main IViewCursor used to fetch items from the dataProvider and pass the items to the renderers.
iterator — Property in class mx.controls.listClasses.ListBase
 | The main IViewCursor used to fetch items from the data provider and pass the items to the renderers.
iteratorValid — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates that a page fault as occurred and that the iterator's position is not valid (not positioned at the topmost item being displayed).
IToolTip — Interface in package mx.core
 | The IToolTip interface defines the API that tooltip-like components must implement in order to work with the ToolTipManager.
IToolTipManagerClient — Interface in package mx.managers
 | Components that implement IToolTipManagerClient can have tooltips and must have a toolTip getter/setter.
ITreeDataDescriptor — Interface in package mx.controls.treeClasses
 | Interface providing methods for parsing and adding nodes to a collection of data that is displayed by a Tree control.
IUIComponent — Interface in package mx.core
 | The IUIComponent interface defines the basic set of APIs that you must implement to create a child of a Flex container or list.
IUID — Interface in package mx.core
 | The IUID interface defines the interface for objects that must have Unique Identifiers (UIDs) to uniquely identify the object.
IValidatorListener — Interface in package mx.validators
 | The interface that components implement to support the Flex data validation mechanism.
IViewCursor — Interface in package mx.collections
 | Defines the interface for enumerating a collection view bi-directionally.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


J Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
J Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
JAPANESE_HIRAGANA — Constant static property in class flash.system.IMEConversionMode
 | The string "JAPANESE_HIRAGANA", for use with the IME.conversionMode property.
JAPANESE_KATAKANA_FULL — Constant static property in class flash.system.IMEConversionMode
 | The string "JAPANESE_KATAKANA_FULL", for use with the IME.conversionMode property.
JAPANESE_KATAKANA_HALF — Constant static property in class flash.system.IMEConversionMode
 | The string "JAPANESE_KATAKANA_HALF", for use with the IME.conversionMode property.
join(sep) — Method in class Array
 | Converts the elements in an array to strings, inserts the specified separator between the elements, concatenates them, and returns the resulting string.
joints — Property in class mx.graphics.LinearGradientStroke
 | A value from the JointStyle class that specifies the type of joint appearance used at angles.
joints — Property in class mx.graphics.Stroke
 | Specifies the type of joint appearance used at angles.
JointStyle — Final class in package flash.display
 | The JointStyle class is an enumeration of constant values that specify the joint style to use in drawing lines.
JUSTIFY — Constant static property in class flash.text.TextFormatAlign
 | Constant; justifies text within the text field.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


K Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
K Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
kerning — Property in class flash.text.TextFormat
 | A Boolean value that indicates whether kerning is enabled (true) or disabled (false).
Keyboard — Final class in package flash.ui
 | The Keyboard class is used to build an interface that can be controlled by a user with a standard keyboard.
KeyboardEvent — Class in package flash.events
 | Flash® Player dispatches KeyboardEvent objects in response to user input through a keyboard.
KeyboardEvent(type:String, bubbles:Boolean, cancelable:Boolean, charCode:uint, keyCode:uint, keyLocation:uint, ctrlKey:Boolean, altKey:Boolean, shiftKey:Boolean) — Constructor in class flash.events.KeyboardEvent
 | Creates an Event object that contains specific information about keyboard events.
keyCode — Property in class flash.events.FocusEvent
 | The key code value of the key pressed to trigger a keyFocusChange event.
keyCode — Property in class flash.events.KeyboardEvent
 | The key code value of the key pressed or released.
keyCode — Property in class mx.events.SliderEvent
 | If the event was triggered by a key press, the keycode for the key.
keyDown — Event in class flash.display.InteractiveObject
 | Dispatched when the user presses a key.
KEY_DOWN — Constant static property in class flash.events.KeyboardEvent
 | Defines the value of the type property of a keyDown event object.
keyDownHandler(event:flash.events:KeyboardEvent) — Method in class mx.core.UIComponent
 | The event handler called for a keyDown event.
keyFocusChange — Event in class flash.display.InteractiveObject
 | Dispatched when the user attempts to change focus by using keyboard navigation.
KEY_FOCUS_CHANGE — Constant static property in class flash.events.FocusEvent
 | Defines the value of the type property of a keyFocusChange event object.
keyFrameInterval — Property in class flash.media.Camera
 | Specifies which video frames are transmitted in full (called keyframes) instead of being interpolated by the video compression algorithm.
keyLocation — Property in class flash.events.KeyboardEvent
 | Indicates the location of the key on the keyboard.
KeyLocation — Final class in package flash.ui
 | The KeyLocation class contains constants that indicate the location of a key pressed on the keyboard.
keyPropertyList — Property in class mx.messaging.management.ObjectName
 | The key properties as an Object, keyed by property name.
keyPropertyListString — Property in class mx.messaging.management.ObjectName
 | A string representation of the list of key properties.
keySelectionPending — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates if keyboard selection was interrupted by a page fault.
keyUp — Event in class flash.display.InteractiveObject
 | Dispatched when the user releases a key.
KEY_UP — Constant static property in class flash.events.KeyboardEvent
 | Defines the value of the type property of a keyUp event object.
keyUpHandler(event:flash.events:KeyboardEvent) — Method in class mx.core.UIComponent
 | The event handler called for a keyUp event.
kind — Property in class mx.events.CollectionEvent
 | Indicates the kind of event that occurred.
kind — Property in class mx.events.PropertyChangeEvent
 | Specifies the kind of change.
knockout — Property in class flash.filters.BevelFilter
 | Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document.
knockout — Property in class flash.filters.DropShadowFilter
 | Applies a knockout effect (true), which effectively makes the object's fill transparent and reveals the background color of the document.
knockout — Property in class flash.filters.GlowFilter
 | Specifies whether the object has a knockout effect.
knockout — Property in class flash.filters.GradientBevelFilter
 | Specifies whether the object has a knockout effect.
knockout — Property in class flash.filters.GradientGlowFilter
 | Specifies whether the object has a knockout effect.
knockout — Property in class mx.effects.Glow
 | Specifies whether the object has a knockout effect.
knockout — Property in class mx.effects.effectClasses.GlowInstance
 | The knockout flag of the glow.
KOREAN — Constant static property in class flash.system.IMEConversionMode
 | The string "KOREAN", for use with the IME.conversionMode property.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


L Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
L Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
label — Statement
 | Associates a statement with an identifier that can be referenced by break or continue.
label — Property in class mx.charts.LegendItem
 | Specifies the text that Flex displays alongside the legend element.
label — Property in class mx.charts.chartClasses.LegendData
 | The text identifying the series or item displayed in the legend item.
label — Property in class mx.containers.FormHeading
 | Form heading text.
label — Property in class mx.containers.FormItem
 | Text label for the FormItem.
label — Property in class mx.controls.Button
 | Text to appear on the Button control.
label — Property in class mx.controls.ProgressBar
 | Text that accompanies the progress bar.
label — Property in class mx.controls.listClasses.BaseListData
 | The textual representation of the item data, based on the list class's itemToLabel() method.
label — Property in class mx.controls.listClasses.ListItemRenderer
 | The internal UITextField that displays the text in this renderer.
label — Property in class mx.controls.listClasses.TileListItemRenderer
 | The internal UITextField that displays the text in this renderer.
label — Property in class mx.controls.menuClasses.MenuItemRenderer
 | The internal UITextField that displays the text in this renderer.
label — Property in class mx.controls.treeClasses.TreeItemRenderer
 | The internal UITextField that displays the text in this renderer.
label — Property in class mx.core.Container
 | The text displayed by some navigator containers to represent this Container.
label — Property in class mx.events.ItemClickEvent
 | The label of the associated navigation item.
label — Property in class mx.events.MenuEvent
 | The label text of the associated menu item.
label — Property in class mx.preloaders.DownloadProgressBar
 | Text to display when the progress bar is active.
Label — Class in package mx.controls
 | The Label control displays a single line of noneditable text.
Label() — Constructor in class mx.controls.Label
 | Constructor.
labelAngle — Property in class mx.charts.series.items.PieSeriesItem
 | The angle of the label, in radians, for this wedge.
labelCache — Property in class mx.charts.chartClasses.NumericAxis
 | The most recent set of AxisLabel objects generated to represent this axis.
labelContainer — Property in class mx.charts.chartClasses.ChartElement
 | The DisplayObject that displays labels rendered by this element.
labelContainer — Property in interface mx.charts.chartClasses.IChartElement
 | The DisplayObject that displays labels rendered by this element.
labelData — Property in class mx.charts.series.renderData.PieSeriesRenderData
 | a structure of data associated with the layout of the labels rendered by the pie series.
labelElements — Property in class mx.charts.chartClasses.ChartBase
 | The set of DisplayObjects representing the labels for the chart elements.
labelField — Property in class mx.controls.ColorPicker
 | Name of the field in the objects of the dataProvider Array that contain text to display as the label in the SwatchPanel object text box.
labelField — Property in class mx.controls.ComboBox
 | Name of the field in the items in the dataProvider Array to display as the label in the TextInput portion and drop-down list.
labelField — Property in class mx.controls.MenuBar
 | The name of the field in the data provider object that determines the text to display for each menu item.
labelField — Property in class mx.controls.NavBar
 | Name of the field in the dataProvider object to display as the label for each navigation item.
labelField — Property in class mx.controls.PopUpMenuButton
 | Name of the field in the dataProvider Array that contains the text to show for each menu item.
labelField — Property in class mx.controls.listClasses.ListBase
 | The name of the field in the data provider items to display as the label.
labelField — Property in class mx.controls.listClasses.ListData
 | The value of the labelField property in the list class.
labelFormat — Property in class mx.preloaders.DownloadProgressBar
 | The TextFormat object of the TextField component of the label.
labelFunction — Property in class mx.charts.CategoryAxis
 | Specifies a function that defines the labels that are generated for each item in the categoryAxis dataProvider.
labelFunction — Property in class mx.charts.chartClasses.NumericAxis
 | Called to format axis values for display as labels.
labelFunction — Property in class mx.charts.series.PieSeries
 | Specifies a callback function used to render each label of the PieSeries.
labelFunction — Property in class mx.controls.ComboBox
 | User-supplied function to run on each item to determine its label.
labelFunction — Property in class mx.controls.DateField
 | Function used to format the date displayed in the text field of the DateField control.
labelFunction — Property in class mx.controls.MenuBar
 | The function that determines the text to display for each menu item.
labelFunction — Property in class mx.controls.PopUpMenuButton
 | A function that determines the text to display for each menu item.
labelFunction — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A function that determines the text to display in this column.
labelFunction — Property in class mx.controls.listClasses.ListBase
 | A user-supplied function to run on each item to determine its label.
labelGap — Style in class mx.charts.AxisRenderer
 | Specifies the gap between the end of the tick marks and the top of the labels, in pixels.
labelMaximum — Property in class mx.charts.chartClasses.NumericAxis
 | The maximum value where a label should be placed.
labelMinimum — Property in class mx.charts.chartClasses.NumericAxis
 | The minimum value where a label should be placed.
labelOffset — Style in class mx.controls.sliderClasses.Slider
 | The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the labels relative to the track.
labelPlacement — Style in class mx.charts.Legend
 | Specifies the label placement of the legend element.
labelPlacement — Style in class mx.charts.LegendItem
 | Specifies the label placement of the legend element.
labelPlacement — Property in class mx.controls.Button
 | Orientation of the label in relation to a specified icon.
labelPlacement — Property in class mx.controls.ProgressBar
 | Placement of the label.
labelPlacement — Property in class mx.controls.RadioButton
 | Position of the label relative to the RadioButton icon.
labelPlacement — Property in class mx.controls.RadioButtonGroup
 | Position of the RadioButton label relative to the RadioButton icon for each control in the group.
labelPosition — Style in class mx.charts.series.PieSeries
 | Specifies how to render value labels.
labelRect — Property in class mx.preloaders.DownloadProgressBar
 | The dimensions of the TextField component for the label.
labelRenderer — Property in class mx.charts.AxisRenderer
 | A reference to the factory used to render the axis labels.
labelRotation — Style in class mx.charts.AxisRenderer
 | Specifies the label rotation.
labels — Property in class flash.display.Scene
 | An array of FrameLabel objects for the scene.
labels — Property in class mx.charts.chartClasses.AxisLabelSet
 | An array of AxisLabel objects representing the values of the generating axis.
labels — Property in class mx.controls.sliderClasses.Slider
 | An array of strings used for the slider labels.
labelScale — Property in class mx.charts.series.renderData.PieSeriesRenderData
 | the scale factor of the labels rendered by the pie series.
labelStyleName — Style in class mx.controls.sliderClasses.Slider
 | The name of the style to use for the slider label.
labelUnits — Property in class mx.charts.DateTimeAxis
 | The units that the axis uses to generate labels.
labelWidth — Style in class mx.containers.Form
 | Width of the form labels.
labelWidth — Style in class mx.containers.FormHeading
 | Width of the form labels.
labelWidth — Style in class mx.containers.FormItem
 | Width of the form labels.
labelWidth — Style in class mx.controls.ProgressBar
 | The width of the label in pixels.
LANDSCAPE — Constant static property in class flash.printing.PrintJobOrientation
 | The landscape (horizontal) image orientation for printing.
language — Static property in class flash.system.Capabilities
 | Specifies the language code of the system on which the player is running.
language — Property in class mx.resources.Locale
 | The language of current locale [Read-Only].
LAST — Static property in class mx.collections.CursorBookmark
 | A bookmark for the last item in an ICollectionView.
lastButtonStyleName — Style in class mx.controls.ButtonBar
 | Name of CSS style declaration that specifies styles for the last button.
lastChild — Property in class flash.xml.XMLNode
 | An XMLNode value that references the last child in the node's child list.
lastDropIndex — Property in class mx.controls.listClasses.ListBase
 | The most recently calculated index where the drag item should be added to the drop target.
lastIndex — Property in class RegExp
 | Specifies the index position in the string at which to start the next search.
LAST_INDEX_MODE — Constant static property in class mx.collections.Sort
 | When executing a find return the index for the last matching item.
lastIndexOf(searchElement, fromIndex:int) — Method in class Array
 | Searches for an item in an array, working backward from the last item, and returns the index position of the matching item using strict equality (===).
lastIndexOf(val:String, startIndex:Number) — Method in class String
 | Searches the string from right to left and returns the index of the last occurrence of val found before startIndex.
lastResult — Property in class mx.rpc.AbstractInvoker
 | The result of the last invocation.
lastSeekPending — Property in class mx.controls.listClasses.ListBase
 | The most recent seek that caused a page fault.
lastTabStyleName — Style in class mx.containers.TabNavigator
 | Name of CSS style declaration that specifies styles for the last tab.
lastTabStyleName — Style in class mx.controls.TabBar
 | Name of CSS style declaration that specifies the styles to use for the last tab navigation item.
LAYER — Constant static property in class flash.display.BlendMode
 | Forces the creation of a transparency group for the display object.
layout — Property in class mx.containers.Panel
 | Specifies the layout mechanism used for this container.
layout — Property in class mx.core.Application
 | Specifies the layout mechanism used for this application.
layoutChrome(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.controls.VideoDisplay
 | Responds to size changes by setting the positions and sizes of the borders.
layoutChrome(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.core.Container
 | Respond to size changes by setting the positions and sizes of this container's borders.
layoutChrome(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.core.ScrollControlBase
 | Responds to size changes by setting the positions and sizes of this control's borders.
layoutEditor(x:int, y:int, w:int, h:int) — Method in class mx.controls.List
 | Positions the item editor instance at the suggested position with the suggested dimensions.
LayoutManager — Class in package mx.managers
 | The LayoutManager is the engine behind Flex's measurement and layout strategy.
LayoutManager() — Constructor in class mx.managers.LayoutManager
 | Constructor.
LCD — Constant static property in class flash.text.TextDisplayMode
 | Forces Flash Player to use LCD subpixel anti-aliasing.
leading — Property in class flash.text.TextFormat
 | An integer representing the amount of vertical space (called leading) between lines.
leading — Property in class flash.text.TextLineMetrics
 | The leading value is the measurement of the vertical distance between the lines of text.
leading — Style in class mx.charts.chartClasses.DataTip
 | Additional vertical space between lines of text.
leading — Style in class mx.containers.FormHeading
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.Button
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.ColorPicker
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.ComboBox
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.DateChooser
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.DateField
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.MenuBar
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.NumericStepper
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.ProgressBar
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.ToolTip
 | Additional vertical space between lines of text.
leading — Style in class mx.controls.menuClasses.MenuBarItem
 | Additional vertical space between lines of text.
leading — Style in class mx.core.ScrollControlBase
 | Additional vertical space between lines of text.
leading — Style in class mx.core.UITextField
 | Additional vertical space between lines of text.
left — Property in class flash.geom.Rectangle
 | The x coordinate of the top-left corner of the rectangle.
left — Property in class mx.core.EdgeMetrics
 | The width, in pixels, of the left edge region.
left — Style in class mx.core.UIComponent
 | The horizontal distance in pixels from the left edge of the component's parent container to the left edge of the component.
LEFT — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned on the left.
LEFT — Constant static property in class flash.text.TextFieldAutoSize
 | Specifies that the text is to be treated as left-justified text, meaning that the left side of the text field remains fixed and any resizing of a single line is on the right side.
LEFT — Constant static property in class flash.text.TextFormatAlign
 | Constant; aligns text to the left within the text field.
LEFT — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Left Arrow key (37).
LEFT — Constant static property in class flash.ui.KeyLocation
 | Indicates the key activated is in the left key location (there is more than one possible location for this key).
LEFT — Constant static property in class mx.controls.ButtonLabelPlacement
 | Specifies that the label appears to the left of the icon.
LEFT — Constant static property in class mx.controls.ProgressBarDirection
 | Specifies to fill the progress bar from the right to the left.
LEFT — Constant static property in class mx.controls.ProgressBarLabelPlacement
 | Specifies to place the label to the left of the progress bar.
LEFT — Constant static property in class mx.validators.CurrencyValidatorAlignSymbol
 | Specifies "left" as the alignment of the currency symbol for the CurrencyValidator class.
leftMargin — Property in class flash.text.TextFormat
 | The left margin of the paragraph, in pixels.
leftPeak — Property in class flash.media.SoundChannel
 | The current amplitude (volume) of the left channel, from 0 (silent) to 1 (full amplitude).
leftToLeft — Property in class flash.media.SoundTransform
 | A value, from 0 (none) to 1 (all), specifying how much of the left input is played in the left speaker.
leftToRight — Property in class flash.media.SoundTransform
 | A value, from 0 (none) to 1 (all), specifying how much of the left input is played in the right speaker.
Legend — Class in package mx.charts
 | The Legend control adds a legend to your charts, where the legend displays the label for each data series in the chart and a key showing the chart element for the series.
Legend() — Constructor in class mx.charts.Legend
 | Constructor.
legendData — Property in class mx.charts.LegendItem
 | The LegendData instance that this LegendItem object represents.
legendData — Property in class mx.charts.chartClasses.ChartBase
 | An Array of Legend items.
legendData — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | An Array of LegendData instances that describe the items that should show up in a legend representing this series.
legendData — Property in class mx.charts.chartClasses.Series
 | An Array of LegendData instances that describe the items that should show up in a legend representing this series.
legendData — Property in class mx.charts.series.BubbleSeries
 | An Array of LegendData instances that describe the items that should show up in a legend representing this series.
LegendData — Class in package mx.charts.chartClasses
 | The LegendData structure is used by charts to describe the items that should be displayed in an auto-generated legend.
LegendData() — Constructor in class mx.charts.chartClasses.LegendData
 | Constructor.
legendDataChanged() — Method in class mx.charts.chartClasses.ChartBase
 | Dispatches a new LegendDataChanged event.
legendDataChanged() — Method in class mx.charts.chartClasses.Series
 | Updates the Legend items when the series display name changes by dispatching a new LegendDataChanged event.
LegendItem — Class in package mx.charts
 | Controls the individual legend elements in a chart legend.
LegendItem() — Constructor in class mx.charts.LegendItem
 | Constructor.
legendItemClass — Property in class mx.charts.Legend
 | The class used to instantiate LegendItem objects.
legendMarkerRenderer — Style in class mx.charts.LegendItem
 | Specifies the class that renders the marker portion of the legend item.
legendMarkerRenderer — Style in class mx.charts.chartClasses.HLOCSeriesBase
 | The class that the series uses to render the series's marker in any associated legends.
legendMarkerRenderer — Style in class mx.charts.series.AreaSeries
 | The class that the series uses to render the series's marker in any associated legends.
legendMarkerRenderer — Style in class mx.charts.series.BarSeries
 | The class that the series uses to render the series's marker in any associated legends.
legendMarkerRenderer — Style in class mx.charts.series.BubbleSeries
 | The class that the series uses to render the series's marker in any associated legends.
legendMarkerRenderer — Style in class mx.charts.series.ColumnSeries
 | The class that the series uses to render the series's marker in any associated legends.
legendMarkerRenderer — Style in class mx.charts.series.LineSeries
 | The class that the series uses to render the series's marker in any associated legends.
legendMarkerRenderer — Style in class mx.charts.series.PieSeries
 | The class that the series uses to render the series's marker in any associated legends.
legendMarkerRenderer — Style in class mx.charts.series.PlotSeries
 | The class that the series uses to render the series's marker in any associated legends.
LegendMouseEvent — Class in package mx.charts.events
 | The LegendMouseEvent class represents event objects that are specific to the chart legend components.
LegendMouseEvent(triggerEvent:flash.events:MouseEvent, item:mx.charts:LegendItem) — Constructor in class mx.charts.events.LegendMouseEvent
 | Constructor.
length — Property in class arguments
 | The number of arguments passed to the function.
length — Property in class Array
 | A non-negative integer specifying the number of elements in the array.
length — Property in class String
 | An integer specifying the number of characters in the specified String object.
length() — Method in class XML
 | For XML objects, this method always returns the integer 1.
length() — Method in class XMLList
 | Returns the number of properties in the XMLList object.
length — Property in class flash.geom.Point
 | The length of the line segment from (0,0) to this point.
length — Property in class flash.media.Sound
 | The length of the current sound in milliseconds.
length — Property in class flash.text.TextField
 | The number of characters in a text field.
length — Property in class flash.utils.ByteArray
 | The length of the ByteArray object, in bytes.
length — Property in class mx.charts.AxisRenderer
 | Specifies the length of the axis, in screen coordinates.
length — Property in class mx.charts.chartClasses.RenderData
 | The number of items represented in this render data.
length — Property in interface mx.collections.ICollectionView
 | The number of items in this view.
length — Property in interface mx.collections.IList
 | The number of items in this collection.
length — Property in class mx.collections.ListCollectionView
 | The number of items in this view.
length — Property in class mx.controls.TextArea
 | The number of characters of text displayed in the TextArea.
length — Property in class mx.controls.TextInput
 | The number of characters of text displayed in the TextArea.
letterSpacing — Property in class flash.text.TextFormat
 | An integer representing the amount of space that is uniformly distributed between all characters.
level — Property in class flash.events.StatusEvent
 | The category of the message, such as "status", "warning" or "error".
level — Property in class mx.logging.AbstractTarget
 | Provides access to the level this target is currently set at.
level — Property in interface mx.logging.ILoggingTarget
 | Provides access to the level this target is currently set at.
level — Property in class mx.logging.LogEvent
 | Provides access to the level for this log event.
LIGHT_COLOR — Constant static property in class flash.text.TextColorType
 | Used in the colorType parameter in the setAdvancedAntiAliasingTable() method.
LIGHTEN — Constant static property in class flash.display.BlendMode
 | Selects the lighter of the constituent colors of the display object and the colors of the background (the colors with the larger values).
Linear — Class in package mx.effects.easing
 | The Linear class defines easing functions to implement linear motion with Flex effect classes.
LINEAR — Constant static property in class flash.display.GradientType
 | Value used to specify a linear gradient fill.
LinearAxis — Class in package mx.charts
 | The LinearAxis class maps numeric values evenly between a minimum and maximum value along a chart axis.
LinearAxis() — Constructor in class mx.charts.LinearAxis
 | Constructor.
LinearGradient — Class in package mx.graphics
 | The LinearGradient class lets you specify the fill of a graphical element, where a gradient specifies a gradual color transition in the fill color.
LinearGradient() — Constructor in class mx.graphics.LinearGradient
 | Constructor.
LinearGradientStroke — Class in package mx.graphics
 | The LinearGradientStroke class lets you specify a gradient filled stroke.
LinearGradientStroke(weight:Number, pixelHinting:Boolean, scaleMode:String, caps:String, joints:String, miterLimit:Number) — Constructor in class mx.graphics.LinearGradientStroke
 | Constructor.
LINEAR_RGB — Constant static property in class flash.display.InterpolationMethod
 | Specifies that the linear RGB interpolation method should be used.
LineChart — Class in package mx.charts
 | The LineChart control represents a data series as points connected by a continuous line.
LineChart() — Constructor in class mx.charts.LineChart
 | Constructor.
LINE_DOWN — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved down by one line.
LineFormattedTarget — Class in package mx.logging.targets
 | All logger target implementations that have a formatted line style output should extend this class.
LineFormattedTarget() — Constructor in class mx.logging.targets.LineFormattedTarget
 | Constructor.
lineGradientStyle(type:String, colors:Array, alphas:Array, ratios:Array, matrix:flash.geom:Matrix, spreadMethod:String, interpolationMethod:String, focalPointRatio:Number) — Method in class flash.display.Graphics
 | Specifies a gradient for the line style that Flash Player uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
LINE_LEFT — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved left by one line.
LineRenderer — Class in package mx.charts.renderers
 | A simple implementation of a line segment renderer that is used by LineSeries objects.
LineRenderer() — Constructor in class mx.charts.renderers.LineRenderer
 | Constructor.
LINE_RIGHT — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved right by one line.
LineScaleMode — Final class in package flash.display
 | The LineScaleMode class provides values for the scaleMode parameter in the Graphics.lineStyle() method.
lineScrollSize — Property in class mx.controls.scrollClasses.ScrollBar
 | Amount to scroll when an arrow button is pressed, in pixels.
lineSegmentRenderer — Style in class mx.charts.series.LineSeries
 | A factory that represents the class the series uses to represent the individual line segments in the series.
lineSegmentType — Property in class mx.charts.series.LineSeries
 | The class used by this series to store all data necessary to represent a line segment.
LineSeries — Class in package mx.charts.series
 | Defines a data series for a LineChart control.
LineSeries() — Constructor in class mx.charts.series.LineSeries
 | Constructor.
LineSeriesItem — Class in package mx.charts.series.items
 | Represents the information required to render an item as part of a LineSeries.
LineSeriesItem(element:mx.charts.series:LineSeries, data:Object, index:uint) — Constructor in class mx.charts.series.items.LineSeriesItem
 | Constructor.
LineSeriesRenderData — Class in package mx.charts.series.renderData
 | Represents all the information needed by the LineSeries to render.
LineSeriesRenderData(cache:Array, filteredCache:Array, validPoints:Number, segments:Array, radius:Number) — Constructor in class mx.charts.series.renderData.LineSeriesRenderData
 | Constructor.
LineSeriesSegment — Class in package mx.charts.series.items
 | Represents the information required to render a segment in a LineSeries.
LineSeriesSegment(element:mx.charts.series:LineSeries, index:uint, items:Array, start:uint, end:uint) — Constructor in class mx.charts.series.items.LineSeriesSegment
 | Constructor.
lineStroke — Style in class mx.charts.series.LineSeries
 | Sets the stroke for the actual line segments.
lineStyle(thickness:Number, color:uint, alpha:Number, pixelHinting:Boolean, scaleMode:String, caps:String, joints:String, miterLimit:Number) — Method in class flash.display.Graphics
 | Specifies a line style that Flash uses for subsequent calls to other Graphics methods (such as lineTo() or drawCircle()) for the object.
lineTo(x:Number, y:Number) — Method in class flash.display.Graphics
 | Draws a line using the current line style from the current drawing position to (x, y); the current drawing position is then set to (x, y).
LINE_UP — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved up by one line.
link — Event in class flash.text.TextField
 | Dispatched when a user clicks a hyperlink in an HTML-enabled text field, where the URL begins with "event:".
LINK — Constant static property in class flash.events.TextEvent
 | Defines the value of the type property of a link event object.
LINK — Constant static property in class mx.managers.DragManager
 | Constant that specifies that the type of drag action is "link".
LinkBar — Class in package mx.controls
 | A LinkBar control defines a horizontal or vertical row of LinkButton controls that designate a series of link destinations.
LinkBar() — Constructor in class mx.controls.LinkBar
 | Constructor
LinkButton — Class in package mx.controls
 | The LinkButton control is a borderless Button control whose contents are highlighted when a user moves the mouse over it.
LinkButton() — Constructor in class mx.controls.LinkButton
 | Constructor.
LinkButtonSkin — Class in package mx.skins.halo
 | The skin for all the states of a LinkButton.
LinkButtonSkin() — Constructor in class mx.skins.halo.LinkButtonSkin
 | Constructor.
linkCursor — Style in class mx.managers.DragManager
 | Cursor displayed during a link operation.
LinkSeparator — Class in package mx.skins.halo
 | The skin for the separator between the Links in a LinkBar.
LinkSeparator() — Constructor in class mx.skins.halo.LinkSeparator
 | Constructor.
list — Property in class mx.collections.ListCollectionView
 | The IList that this collection view wraps.
List — Class in package mx.controls
 | The List control displays a vertical list of items.
List() — Constructor in class mx.controls.List
 | Constructor.
ListBase — Class in package mx.controls.listClasses
 | The ListBase class is the base class for controls that represent lists of items that can have one or more selected and can scroll through the items.
ListBase() — Constructor in class mx.controls.listClasses.ListBase
 | Constructor.
ListBaseSeekPending — Class in package mx.controls.listClasses
 | An object that stores data about a seek operation that was interrupted by an ItemPendingError error.
ListBaseSeekPending(bookmark:mx.collections:CursorBookmark, offset:int) — Constructor in class mx.controls.listClasses.ListBaseSeekPending
 | Constructor.
ListBaseSelectionData — Class in package mx.controls.listClasses
 | Records used by list classes to keep track of what is selected.
ListBaseSelectionData(data:Object, index:int, approximate:Boolean) — Constructor in class mx.controls.listClasses.ListBaseSelectionData
 | Constructor.
ListCollectionView — Class in package mx.collections
 | The ListCollectionView class adds the properties and methods of the ICollectionView interface to an object that conforms to the IList interface.
ListCollectionView(list:mx.collections:IList) — Constructor in class mx.collections.ListCollectionView
 | The ListCollectionView constructor.
listContent — Property in class mx.controls.listClasses.ListBase
 | An internal display object that parents all of the item renderers, selection and highlighting indicators and other supporting graphics.
listData — Property in class mx.controls.Button
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control.
listData — Property in class mx.controls.ComboBox
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control.
listData — Property in class mx.controls.DateField
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control.
listData — Property in class mx.controls.Image
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control.
listData — Property in class mx.controls.Label
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control.
listData — Property in class mx.controls.NumericStepper
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the List control.
listData — Property in class mx.controls.TextArea
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control.
listData — Property in class mx.controls.TextInput
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the appropriate data from the list control.
listData — Property in class mx.controls.dataGridClasses.DataGridItemRenderer
 | The implementation of the listData property as defined by the IDropInListItemRenderer interface.
listData — Property in interface mx.controls.listClasses.IDropInListItemRenderer
 | Implements the listData property using setter and getter methods.
listData — Property in class mx.controls.listClasses.ListBase
 | When a component is used as a drop-in item renderer or drop-in item editor, Flex initializes the listData property of the component with the additional data from the list control.
listData — Property in class mx.controls.listClasses.ListItemRenderer
 | The implementation of the listData property as defined by the IDropInListItemRenderer interface.
listData — Property in class mx.controls.listClasses.TileListItemRenderer
 | The implementation of the listData property as defined by the IDropInListItemRenderer interface.
listData — Property in class mx.controls.menuClasses.MenuItemRenderer
 | The implementation of the listData property as defined by the IDropInListItemRenderer interface.
listData — Property in class mx.controls.treeClasses.TreeItemRenderer
 | The implementation of the listData property as defined by the IDropInListItemRenderer interface.
ListData — Class in package mx.controls.listClasses
 | The ListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the List control.
ListData(text:String, icon:Class, labelField:String, uid:String, owner:mx.core:IUIComponent, rowIndex:int) — Constructor in class mx.controls.listClasses.ListData
 | Constructor.
ListDropIndicator — Class in package mx.skins.halo
 | The skin for the drop indicator of a list-based control.
ListDropIndicator() — Constructor in class mx.skins.halo.ListDropIndicator
 | Constructor.
listener — Property in class mx.effects.Tween
 | Object that is notified at each interval of the animation.
listener — Property in class mx.validators.Validator
 | Specifies the validation listener.
ListEvent — Class in package mx.events
 | The ListEvent class represents events associated with items in list-based controls such as List, Tree, Menu, and DataGrid.
ListEvent(type:String, bubbles:Boolean, cancelable:Boolean, columnIndex:int, rowIndex:int, reason:String, itemRenderer:mx.controls.listClasses:IListItemRenderer) — Constructor in class mx.events.ListEvent
 | Constructor.
ListEventReason — Final class in package mx.events
 | Constants for the values of the reason property of a ListEvent object where the value of the type property is ListEvent.ITEM_EDIT_END.
ListItemDragProxy — Class in package mx.controls.listClasses
 | The default drag proxy used when dragging from a list-based control (except for the DataGrid class).
ListItemDragProxy() — Constructor in class mx.controls.listClasses.ListItemDragProxy
 | Constructor.
ListItemRenderer — Class in package mx.controls.listClasses
 | The ListItemRenderer class defines the default item renderer for a List control.
ListItemRenderer() — Constructor in class mx.controls.listClasses.ListItemRenderer
 | Constructor.
listItems — Property in class mx.controls.listClasses.ListBase
 | An Array of Arrays that contains the itemRenderer instances that render each data provider item.
ListRowInfo — Class in package mx.controls.listClasses
 | Used by the list-based classes to store information about their IListItemRenderers.
ListRowInfo(y:Number, height:Number, uid:String, data:Object) — Constructor in class mx.controls.listClasses.ListRowInfo
 | Constructor.
LITTLE_ENDIAN — Constant static property in class flash.utils.Endian
 | Indicates the least significant byte of the multibyte number appears first in the sequence of bytes.
live — Property in class mx.controls.VideoDisplay
 | Specifies whether the control is streaming a live feed.
liveDelay — Property in class flash.net.NetStream
 | The number of seconds of data in the subscribing stream's buffer in live (unbuffered) mode.
liveDragging — Property in class mx.containers.DividedBox
 | If true, the children adjacent to a divider are continuously resized while the user drags it.
liveDragging — Property in class mx.controls.sliderClasses.Slider
 | Specifies whether live dragging is enabled for the slider.
liveScrolling — Property in class mx.core.ScrollControlBase
 | A flag that indicates whether scrolling is live as the scrollbar thumb is moved or the view is not updated until the thumb is released.
LN10 — Constant static property in class Math
 | A mathematical constant for the natural logarithm of 10, expressed as loge10, with an approximate value of 2.302585092994046.
LN2 — Constant static property in class Math
 | A mathematical constant for the natural logarithm of 2, expressed as loge2, with an approximate value of 0.6931471805599453.
load(request:flash.net:URLRequest, context:flash.system:LoaderContext) — Method in class flash.display.Loader
 | Loads a SWF, JPEG, progressive JPEG, unanimated GIF, or PNG file into an object that is a child of this Loader object.
load(stream:flash.net:URLRequest, context:flash.media:SoundLoaderContext) — Method in class flash.media.Sound
 | Initiates loading of an external MP3 file from the specified URL.
load(request:flash.net:URLRequest) — Method in class flash.net.URLLoader
 | Sends and loads data from the specified URL.
load(request:flash.net:URLRequest) — Method in class flash.net.URLStream
 | Begins downloading the URL specified in the request parameter.
load(url:Object) — Method in class mx.controls.SWFLoader
 | Loads an image or SWF file.
load() — Method in class mx.controls.VideoDisplay
 | Loads the media file without playing it.
load() — Method in class mx.effects.SoundEffect
 | Loads the MP3 if the source property points to a URL.
load — Event in class mx.rpc.soap.WebService
 | The LoadEvent.LOAD is dispatched when the WSDL document has loaded successfully.
LOAD — Constant static property in class mx.rpc.soap.LoadEvent
 | The LOAD event type.
loadBytes(bytes:flash.utils:ByteArray, context:flash.system:LoaderContext) — Method in class flash.display.Loader
 | Loads from binary data stored in a ByteArray object.
loadedPages — Property in class mx.data.PageInformation
 | Provides read-only access to the loaded page information for the collection.
loader — Property in class flash.display.LoaderInfo
 | The Loader object associated with this LoaderInfo object.
Loader — Class in package flash.display
 | The Loader class is used to load SWF files or image (JPG, PNG, or GIF) files.
Loader() — Constructor in class flash.display.Loader
 | Creates a Loader object that you can use to load files, such as SWF, JPEG, GIF, or PNG files.
LoaderConfig — Class in package mx.messaging.config
 | This class acts as a context for the messaging framework so that it has access the URL and arguments of the SWF without needing access to the root MovieClip's LoaderInfo or Flex's Application class.
LoaderConfig() — Constructor in class mx.messaging.config.LoaderConfig
 | Constructor.
loaderContext — Property in class mx.controls.SWFLoader
 | A LoaderContext object to use to load the content.
LoaderContext — Class in package flash.system
 | The LoaderContext class provides options for loading SWF files and other media by using the Loader class.
LoaderContext(checkPolicyFile:Boolean, applicationDomain:flash.system:ApplicationDomain, securityDomain:flash.system:SecurityDomain) — Constructor in class flash.system.LoaderContext
 | Creates a new LoaderContext object, with the specified settings.
loaderInfo — Property in class flash.display.DisplayObject
 | Returns a LoaderInfo object containing information about loading the file to which this display object belongs.
loaderInfo — Property in interface mx.managers.ISystemManager
 | The LoaderInfo object that represents information about the application.
LoaderInfo — Class in package flash.display
 | The LoaderInfo class provides information about a loaded SWF file or a loaded image file (JPEG, GIF, or PNG).
loaderURL — Property in class flash.display.LoaderInfo
 | The URL of the SWF file that initiated the loading of the media described by this LoaderInfo object.
LoadEvent — Class in package mx.rpc.soap
 | This event is dispatched when the WSDL document has loaded sucessfully.
LoadEvent(wsdl, document:flash.xml:XMLDocument) — Constructor in class mx.rpc.soap.LoadEvent
 | Creates a new LoadEvent.
LOADING — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property immediately after a call to the play() or load() method.
loadPolicyFile(url:String) — Static method in class flash.system.Security
 | Loads a cross-domain policy file from a location specified by the url parameter.
loadState(state:Object) — Method in class mx.containers.Accordion
 | Loads the state of this object.
loadState(state:Object) — Method in class mx.containers.ViewStack
 | Loads the state of this object.
loadState(state:Object) — Method in interface mx.managers.IHistoryManagerClient
 | Loads the state of this object.
loadWSDL(uri:String) — Method in class mx.rpc.soap.WebService
 | Instructs the WebService to download the WSDL document.
LocalConnection — Class in package flash.net
 | The LocalConnection class lets you create a LocalConnection object that can invoke a method in another LocalConnection object, either within a single SWF file or between multiple SWF files.
LocalConnection() — Constructor in class flash.net.LocalConnection
 | Creates a LocalConnection object.
Locale — Class in package mx.resources
 | You can use this class to query the current Locale.
Locale(localeStr:String) — Constructor in class mx.resources.Locale
 | Constructor.
localeCompare(other:String, ... rest) — Method in class String
 | Compares the sort order of two or more strings and returns the result of the comparison as an integer.
localFileReadDisable — Static property in class flash.system.Capabilities
 | Specifies whether read access to the user's hard disk has been administratively prohibited (true) or allowed (false).
localIndex — Property in class mx.collections.ListCollectionView
 | When the view is sorted or filtered the localIndex property contains an array of items in the sorted or filtered (ordered, reduced) view, in the sorted ordder.
localName — Property in class QName
 | The local name of the QName object.
localName() — Method in class XML
 | Gives the local name portion of the qualified name of the XML object.
localName — Property in class flash.xml.XMLNode
 | The local name portion of the XML node's name.
LOCAL_STORAGE — Constant static property in class flash.system.SecurityPanel
 | When passed to Security.showSettings(), displays the Local Storage Settings panel in Flash Player Settings.
localToContent(point:flash.geom:Point) — Method in class mx.core.Container
 | Converts a Point object from local to content coordinates.
localToContent(point:flash.geom:Point) — Method in class mx.core.UIComponent
 | Converts a Point object from local to content coordinates.
localToData(pt:flash.geom:Point) — Method in class mx.charts.chartClasses.CartesianChart
 | Converts a coordinate on screen to a tuple of data values.
localToData(pt:flash.geom:Point) — Method in class mx.charts.chartClasses.ChartBase
 | Converts a coordinate on screen to a tuple of data values.
localToData(pt:flash.geom:Point) — Method in class mx.charts.chartClasses.PolarChart
 | Converts a coordinate on screen to a tuple of data values.
localToGlobal(point:flash.geom:Point) — Method in class flash.display.DisplayObject
 | Converts the point object from the display object's (local) coordinates to the Stage (global) coordinates.
LOCAL_TRUSTED — Constant static property in class flash.system.Security
 | The SWF file is a local file and has been trusted by the user, using either the Settings Manager or a FlashPlayerTrust configuration file.
LOCAL_WITH_FILE — Constant static property in class flash.system.Security
 | The SWF file is a local file, has not been trusted by the user, and was not published with a networking designation.
LOCAL_WITH_NETWORK — Constant static property in class flash.system.Security
 | The SWF file is a local file, has not been trusted by the user, and was published with a networking designation.
localX — Property in class flash.events.MouseEvent
 | The horizontal coordinate at which the event occurred relative to the containing sprite.
localX — Property in class mx.events.DataGridEvent
 | The column's x-position; used for replaying column stretch events.
localY — Property in class flash.events.MouseEvent
 | The vertical coordinate at which the event occurred relative to the containing sprite.
location — Property in class mx.events.CollectionEvent
 | When the kind value is CollectionEventKind.ADD, CollectionEventKind.MOVE, CollectionEventKind.REMOVE, or CollectionEventKind.REPLACE, this property is the zero-base index in the collection of the item(s) specified in the items property.
lock() — Method in class flash.display.BitmapData
 | Locks an image so that any objects that reference the BitmapData object, such as Bitmap objects, are not updated when this BitmapData object changes.
lockedColumnCount — Property in class mx.controls.listClasses.ListBase
 | The index of the first column in the control that scrolls.
lockedRowCount — Property in class mx.controls.listClasses.ListBase
 | The index of the first row in the control that scrolls.
log(val:Number) — Static method in class Math
 | Returns the natural logarithm of the parameter val.
log(level:int, message:String, ... rest) — Method in interface mx.logging.ILogger
 | Logs the specified data at the given level.
log(level:int, message:String, ... rest) — Method in class mx.logging.LogLogger
 | Logs the specified data at the given level.
Log — Class in package mx.logging
 | Provides psuedo-hierarchical logging capabilities with multiple format and output options.
LOG — Constant static property in class mx.logging.LogEvent
 | Event type constant; identifies a logging event.
LOG10E — Constant static property in class Math
 | A mathematical constant for the base-10 logarithm of the constant e (Math.E), expressed as log10e, with an approximate value of 0.4342944819032518.
LOG2E — Constant static property in class Math
 | A mathematical constant for the base-2 logarithm of the constant e, expressed as log2e, with an approximate value of 1.442695040888963387.
LogAxis — Class in package mx.charts
 | The LogAxis class maps numeric values logarithmically between a minimum and maximum value along a chart axis.
LogAxis() — Constructor in class mx.charts.LogAxis
 | Constructor.
logEvent(event:mx.logging:LogEvent) — Method in class mx.logging.AbstractTarget
 | This method handles a LogEvent from an associated logger.
logEvent(event:mx.logging:LogEvent) — Method in class mx.logging.targets.LineFormattedTarget
 | This method handles a LogEvent from an associated logger.
LogEvent — Class in package mx.logging
 | Represents the log information for a single logging event.
LogEvent(message:String, level:int) — Constructor in class mx.logging.LogEvent
 | Constructor.
LogEventLevel — Final class in package mx.logging
 | Static class containing constants for use in the level property.
LOGIN_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
 | This operation is used to send credentials to the endpoint so that the user can be logged in over the current channel.
LogLogger — Class in package mx.logging
 | The logger that is used within the logging framework.
LogLogger(category:String) — Constructor in class mx.logging.LogLogger
 | Constructor.
logout() — Method in class mx.data.DataService
 | Logs the user out of the destination for the DataService.
logout() — Method in class mx.data.mxml.DataService
 | Logs the user out of the destination for the DataService.
logout(agent:mx.messaging:MessageAgent) — Method in class mx.messaging.Channel
 | Sends a CommandMessage to the server to logout if the Channel is connected.
logout(agent:mx.messaging:MessageAgent) — Method in class mx.messaging.ChannelSet
 | Clears the stored credentials and calls logout on every channel in the set.
logout() — Method in class mx.messaging.MessageAgent
 | Logs the MessageAgent out from its remote destination.
logout() — Method in class mx.rpc.AbstractService
 | Logs the user out of the destination.
logout() — Method in class mx.rpc.http.HTTPService
 | Logs the user out of the destination.
LOGOUT_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
 | This operation is used to log the user out of the current channel, and will invalidate the server session if the channel is HTTP based.
loop — Property in class flash.ui.ContextMenuBuiltInItems
 | Lets the user set a SWF file to start over automatically when it reaches the final frame (does not appear for a single-frame SWF file).
loopback — Property in class flash.media.Camera
 | Specifies whether a local view of what the camera is capturing is compressed and decompressed (true), as it would be for live transmission using Flash Media Server, or uncompressed (false).
loops — Property in class mx.effects.SoundEffect
 | The number of times to play the sound in a loop, where a value of 0 means play the effect once, a value of 1 means play the effect twice, and so on.
loops — Property in class mx.effects.effectClasses.SoundEffectInstance
 | The number of times to play the sound in a loop, where a value of 0 means play the effect once, a value of 1 means play the effect twice, and so on.
low — Property in class mx.charts.series.items.HLOCSeriesItem
 | The low value of this item converted into screen coordinates.
LOW — Constant static property in class flash.display.StageQuality
 | Specifies low rendering quality: graphics are not anti-aliased, and bitmaps are not smoothed.
LOW — Constant static property in class flash.filters.BitmapFilterQuality
 | Defines the low quality filter setting.
LOW — Constant static property in class mx.managers.CursorManagerPriority
 | Constant that specifies the lowest cursor priority when passed as the priority argument to setCursor().
lowerMargin — Property in class mx.charts.chartClasses.BoundedValue
 | The margin, in pixels, required below the value in order to render properly.
lowerThanMinError — Property in class mx.validators.CurrencyValidator
 | Error message when the value is less than minValue.
lowerThanMinError — Property in class mx.validators.NumberValidator
 | Error message when the value is less than minValue.
lowField — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | Specifies the field of the data provider that determines the y-axis location of the low value of the element.
lowFilter — Property in class mx.charts.series.items.HLOCSeriesItem
 | The low value of this item, filtered against the vertical axis of the containing chart.
lowNumber — Property in class mx.charts.series.items.HLOCSeriesItem
 | The low value of this item, converted to a number by the vertical axis of the containing chart.
lowValue — Property in class mx.charts.series.items.HLOCSeriesItem
 | The low value of this item.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


M Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
M Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
macType — Property in class flash.net.FileFilter
 | A list of Macintosh file types.
maintainAspectRatio — Property in class mx.controls.SWFLoader
 | If true, specifies to display the image with the same ratio of height to width as the original image.
maintainAspectRatio — Property in class mx.controls.VideoDisplay
 | Specifies whether the control should maintain the original aspect ratio while resizing the video.
makeListData(data:Object, uid:String, rowNum:int) — Method in class mx.controls.List
 | Creates a new ListData instance and populates the fields based on the input data provider item.
makeObjectsBindable — Property in class mx.rpc.AbstractInvoker
 | When this value is true, anonymous objects returned are forced to bindable objects.
makeObjectsBindable — Property in class mx.rpc.remoting.Operation
 | When this value is true, anonymous objects returned are forced to bindable objects.
makeObjectsBindable — Property in class mx.rpc.remoting.RemoteObject
 | When this value is true, anonymous objects returned are forced to bindable objects.
makeObjectsBindable — Property in class mx.rpc.soap.Operation
 | When this value is true, anonymous objects returned are forced to bindable objects.
makeObjectsBindable — Property in class mx.rpc.soap.WebService
 | When this value is true, anonymous objects returned are forced to bindable objects.
makeRowsAndColumns(left:Number, top:Number, right:Number, bottom:Number, firstColumn:int, firstRow:int, byCount:Boolean, rowsNeeded:uint) — Method in class mx.controls.listClasses.ListBase
 | Make enough rows and columns to fill the area described by left, top, right, bottom.
Managed — Class in package mx.data.utils
 | Provides utility methods for DataService managed objects.
MANUAL — Constant static property in class mx.controls.ProgressBarMode
 | You manually update the ProgressBar status.
manufacturer — Static property in class flash.system.Capabilities
 | Specifies the manufacturer of Flash Player, in the format "Adobe OSName".
map(callback:Function, thisObject) — Method in class Array
 | Executes a function on each item in an array, and constructs a new array of items corresponding to the results of the function on each item in the original array.
mapBitmap — Property in class flash.filters.DisplacementMapFilter
 | A BitmapData object containing the displacement map data.
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean) — Method in class mx.charts.CategoryAxis
 | Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean) — Method in interface mx.charts.chartClasses.IAxis
 | Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
mapCache(cache:Array, field:String, convertedField:String, indexValues:Boolean) — Method in class mx.charts.chartClasses.NumericAxis
 | Converts a set of values of arbitrary type to a set of numbers that can be transformed into screen coordinates.
mappingChanged() — Method in class mx.charts.chartClasses.ChartElement
 | Called when the mapping of one or more associated axes changes.
mappingChanged() — Method in interface mx.charts.chartClasses.IChartElement
 | Indicates to the element that the data mapping of the associated axes has changed.
mapPoint — Property in class flash.filters.DisplacementMapFilter
 | A value that contains the offset of the upper-left corner of the target display object from the upper-left corner of the map image.
marker — Property in class mx.charts.LegendItem
 | The marker displayed by this legend item.
marker — Property in class mx.charts.chartClasses.LegendData
 | A visual indicator associating the legend item with the series or item being represented.
markerAspectRatio — Property in class mx.charts.LegendItem
 | The aspect ratio for the marker associated with this legend item.
markerHeight — Style in class mx.charts.Legend
 | Specifies the height of the legend element.
markerHeight — Style in class mx.charts.LegendItem
 | Specifies the height of the legend element.
markerWidth — Style in class mx.charts.Legend
 | Specifies the width of the legend element.
markerWidth — Style in class mx.charts.LegendItem
 | Specifies the width of the legend element.
mask — Property in class flash.display.DisplayObject
 | The calling display object is masked by the specified mask object.
mask — Property in interface mx.core.IFlexDisplayObject
 | The DisplayObject used to mask this object so that only part of it is actually drawn.
MaskEffect — Class in package mx.effects
 | The MaskEffect class is an abstract base class for all effects that animate a mask, such as the wipe effects and the Iris effect.
MaskEffect(target:Object) — Constructor in class mx.effects.MaskEffect
 | Constructor.
MaskEffectInstance — Class in package mx.effects.effectClasses
 | The MaskEffectInstance class is an abstract base class that implements the instance class for the MaskEffect class.
MaskEffectInstance(target:Object) — Constructor in class mx.effects.effectClasses.MaskEffectInstance
 | Constructor.
maskShape — Property in class mx.core.ScrollControlBase
 | The mask.
MASTER_CARD — Constant static property in class mx.validators.CreditCardValidatorCardType
 | Specifies the card type as MasterCard.
match(pattern) — Method in class String
 | Matches the specifed pattern against the string.
matchedIndex — Property in class mx.validators.RegExpValidationResult
 | An integer that contains the starting index in the input String of the match.
matchedString — Property in class mx.validators.RegExpValidationResult
 | A String that contains the substring of the input String that matches the regular expression.
matchedSubstrings — Property in class mx.validators.RegExpValidationResult
 | An Array of Strings that contains parenthesized substring matches, if any.
MATCH_HEIGHT — Constant static property in class mx.printing.FlexPrintJobScaleType
 | Scales the object to fill the available page height.
MATCH_WIDTH — Constant static property in class mx.printing.FlexPrintJobScaleType
 | Scales the object to fill the available page width.
Math — Final class in Top Level
 | The Math class contains methods and constants that represent common mathematical functions and values.
matrix — Property in class flash.filters.ColorMatrixFilter
 | An array of 20 items for 4 x 5 color transform.
matrix — Property in class flash.filters.ConvolutionFilter
 | An array of values used for matrix transformation.
matrix — Property in class flash.geom.Transform
 | A Matrix object containing values that affect the scaling, rotation, and translation of the display object.
Matrix — Class in package flash.geom
 | The Matrix class represents a transformation matrix that determines how to map points from one coordinate space to another.
Matrix(a:Number, b:Number, c:Number, d:Number, tx:Number, ty:Number) — Constructor in class flash.geom.Matrix
 | Creates a new Matrix object with the specified parameters.
matrixX — Property in class flash.filters.ConvolutionFilter
 | The x dimension of the matrix (the number of columns in the matrix).
matrixY — Property in class flash.filters.ConvolutionFilter
 | The y dimension of the matrix (the number of rows in the matrix).
max(val1:Number, val2:Number, ... rest) — Static method in class Math
 | Evaluates val1 and val2 (or more values) and returns the largest value.
max — Property in class mx.charts.chartClasses.DataDescription
 | The maximum data value displayed by the element.
maxBarWidth — Style in class mx.charts.BarChart
 | Specifies how wide to draw the bars, in pixels.
maxBarWidth — Property in interface mx.charts.chartClasses.IBar
 | Specifies how wide to draw the items, in pixels.
maxBarWidth — Property in class mx.charts.series.BarSeries
 | Specifies the width of the bars, in pixels.
maxBarWidth — Property in class mx.charts.series.BarSet
 | Specifies how wide to draw the bars, in pixels.
maxChars — Property in class flash.text.TextField
 | The maximum number of characters that the text field can contain, as entered by a user.
maxChars — Property in class mx.controls.NumericStepper
 | The maximum number of characters that can be entered in the field.
maxChars — Property in class mx.controls.TextArea
 | Maximum number of characters that users can enter in the text field.
maxChars — Property in class mx.controls.TextInput
 | Maximum number of characters that users can enter in the text field.
maxColumns — Property in class mx.controls.listClasses.TileBase
 | The maximum number of columns that the control can have.
maxColumnWidth — Style in class mx.charts.CandlestickChart
 | Specifies how wide to draw the candlesticks, in pixels.
maxColumnWidth — Style in class mx.charts.ColumnChart
 | Specifies how wide to draw the columns, in pixels.
maxColumnWidth — Style in class mx.charts.HLOCChart
 | Specifies how wide to draw the HLOC lines, in pixels.
maxColumnWidth — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | Specifies the width of the elements, in pixels.
maxColumnWidth — Property in interface mx.charts.chartClasses.IColumn
 | Specifies how wide to draw the items, in pixels.
maxColumnWidth — Property in class mx.charts.series.ColumnSeries
 | Specifies the width of the columns, in pixels.
maxColumnWidth — Property in class mx.charts.series.ColumnSet
 | Specifies the width of the columns, in pixels.
maxHeight — Property in interface mx.core.IUIComponent
 | Number that specifies the maximum height of the component, in pixels, as the component's coordinates.
maxHeight — Property in class mx.core.UIComponent
 | Number that specifies the maximum height of the component, in pixels, in the component's coordinates.
maxHeight — Property in class mx.core.UITextField
 | Number that specifies the maximum height of the component, in pixels, in the component's coordinates.
maxHorizontalScrollPosition — Property in class mx.controls.TextInput
 | Maximum value of horizontalScrollPosition.
maxHorizontalScrollPosition — Property in class mx.controls.Tree
 | The maximum value for the maxHorizontalScrollPosition property for the Tree control.
maxHorizontalScrollPosition — Property in class mx.core.Container
 | The largest possible value for the horizontalScrollPosition property.
maxHorizontalScrollPosition — Property in class mx.core.ScrollControlBase
 | The maximum value for the horizontalScrollPosition property.
maximum — Property in class mx.charts.DateTimeAxis
 | Specifies the maximum value for an axis label.
maximum — Property in class mx.charts.LinearAxis
 | Specifies the maximum value for an axis label.
maximum — Property in class mx.charts.LogAxis
 | Specifies the maximum value for an axis label.
maximum — Property in class mx.controls.NumericStepper
 | Maximum value of the NumericStepper.
maximum — Property in class mx.controls.ProgressBar
 | Largest progress value for the ProgressBar.
maximum — Property in class mx.controls.sliderClasses.Slider
 | The maximum allowed value on the slider.
maximumDataTipCount — Style in class mx.charts.chartClasses.ChartBase
 | Specifies the maximum number of datatips a chart will show.
maximumLabelPrecision — Property in class mx.charts.LinearAxis
 | Specifies the maximum number of decimal places for representing fractional values on the labels generated by this axis.
maximumLabelPrecision — Property in class mx.charts.LogAxis
 | Specifies the maximum number of decimal places for representing fractional values on the labels generated by this axis.
maxLabelRadius — Property in class mx.charts.series.PieSeries
 | The maximum amount of the PieSeries's radius that can be allocated to labels.
maxLength — Property in class mx.validators.StringValidator
 | Maximum length for a valid String.
maxLevel — Static property in class flash.text.TextRenderer
 | The adaptively sampled distance fields (ADFs) quality level for advanced anti-aliasing.
maxRadius — Style in class mx.charts.BubbleChart
 | The maximum radius of the largest chart element, in pixels Flex assigns this radius to the data point with the largest value; all other data points are assigned a smaller radius based on their value relative to the largest value.
maxRadius — Property in class mx.charts.series.BubbleSeries
 | The radius of the largest item rendererd in this series.
maxRows — Property in class mx.controls.listClasses.TileBase
 | The maximum number of rows that the control can have.
maxScrollH — Property in class flash.text.TextField
 | The maximum value of scrollH.
maxScrollPosition — Property in class mx.controls.scrollClasses.ScrollBar
 | Number which represents the maximum scroll position.
maxScrollV — Property in class flash.text.TextField
 | The maximum value of scrollV.
maxTipWidth — Static property in class mx.charts.chartClasses.DataTip
 | Specifies the maximum width of the bounding box, in pixels, for new DataTip controls.
maxValue — Property in class mx.validators.CurrencyValidator
 | Maximum value for a valid number.
maxValue — Property in class mx.validators.NumberValidator
 | Maximum value for a valid number.
MAX_VALUE — Constant static property in class int
 | The largest representable 32-bit signed integer, which is 2,147,483,647.
MAX_VALUE — Constant static property in class Number
 | The largest representable number (double-precision IEEE-754).
MAX_VALUE — Constant static property in class uint
 | The largest representable 32-bit unsigned integer, which is 4,294,967,295.
maxVerticalScrollPosition — Property in class mx.core.Container
 | The largest possible value for the verticalScrollPosition property.
maxVerticalScrollPosition — Property in class mx.core.ScrollControlBase
 | The maximum value for the verticalScrollPosition property.
maxWidth — Static property in class mx.controls.ToolTip
 | Maximum width in pixels for new ToolTip controls.
maxWidth — Property in interface mx.core.IUIComponent
 | Number that specifies the maximum width of the component, in pixels, as the component's coordinates.
maxWidth — Property in class mx.core.UIComponent
 | Number that specifies the maximum width of the component, in pixels, in the component's coordinates.
maxWidth — Property in class mx.core.UITextField
 | Number that specifies the maximum width of the component, in pixels, in the component's coordinates.
maxYear — Property in class mx.controls.DateChooser
 | The last year selectable in the control.
maxYear — Property in class mx.controls.DateField
 | The last year selectable in the control.
MBeanAttributeInfo — Class in package mx.messaging.management
 | Client representation of metadata for a MBean attribute.
MBeanAttributeInfo() — Constructor in class mx.messaging.management.MBeanAttributeInfo
 | Creates a new instance of an empty MBeanAttributeInfo.
MBeanFeatureInfo — Class in package mx.messaging.management
 | Client representation of metadata for a MBean feature.
MBeanFeatureInfo() — Constructor in class mx.messaging.management.MBeanFeatureInfo
 | Creates a new instance of an empty MBeanFeatureInfo.
MBeanInfo — Class in package mx.messaging.management
 | Client representation of metadata for a MBean.
MBeanInfo() — Constructor in class mx.messaging.management.MBeanInfo
 | Creates a new instance of an empty MBeanInfo.
MBeanOperationInfo — Class in package mx.messaging.management
 | Client representation of metadata for a MBean operation.
MBeanOperationInfo() — Constructor in class mx.messaging.management.MBeanOperationInfo
 | Creates a new instance of an empty MBeanOperationInfo.
MBeanParameterInfo — Class in package mx.messaging.management
 | Client representation of metadata for a MBean operation parameter.
MBeanParameterInfo() — Constructor in class mx.messaging.management.MBeanParameterInfo
 | Creates a new instance of an empty MBeanParameterInfo.
measure() — Method in class mx.charts.AxisRenderer
 | Calculates the default size, and optionally the default minimum size, of the component.
measure() — Method in class mx.charts.Legend
 | Calculates the preferred, minimum, and maximum sizes of the Legend.
measure() — Method in class mx.charts.chartClasses.CartesianChart
measure() — Method in class mx.charts.chartClasses.ChartLabel
 | Calculates the default size, and optionally the default minimum size, of the component.
measure() — Method in class mx.charts.chartClasses.DataTip
 | Calculates the default size, and optionally the default minimum size, of the component.
measure() — Method in class mx.containers.Box
 | Calculates the default sizes and minimum and maximum values of the Box container.
measure() — Method in class mx.containers.Canvas
 | Calculates the preferred minimum and preferred maximum sizes of the Canvas.
measure() — Method in class mx.containers.Form
 | Calculates the preferred, minimum and maximum sizes of the Form.
measure() — Method in class mx.containers.FormItem
 | Calculates the preferred, minimum and maximum sizes of the FormItem.
measure() — Method in class mx.containers.Grid
 | Calculates the preferred, minimum, and maximum sizes of the Grid.
measure() — Method in class mx.containers.Panel
 | Calculates the default mininum and maximum sizes of the Panel container.
measure() — Method in class mx.containers.TabNavigator
 | Calculates the default sizes and mininum and maximum values of this TabNavigator container.
measure() — Method in class mx.containers.Tile
 | Calculates the default minimum and maximum sizes of the Tile container.
measure() — Method in class mx.containers.ViewStack
 | Calculates the default sizes and minimum and maximum values of the ViewStack container.
measure() — Method in class mx.controls.ComboBase
 | Determines the measuredWidth and measuredHeight properties of the control.
measure() — Method in class mx.controls.ComboBox
 | Makes sure the control is at least 40 pixels wide, and tall enough to fit one line of text in the TextInput portion of the control but at least 22 pixels high.
measure() — Method in class mx.controls.Menu
 | Calculates the preferred width and height of the Menu based on the widths and heights of its menu items.
measure() — Method in class mx.controls.MenuBar
 | Calculates the preferred width and height of the MenuBar based on the default widths of the MenuBar items.
measure() — Method in class mx.controls.listClasses.ListBase
 | Calculates the measured width and height of the component based on the rowCount, columnCount, rowHeight and columnWidth properties.
measure() — Method in class mx.controls.sliderClasses.Slider
 | Calculates the amount of space that the component takes up.
measure() — Method in class mx.core.UIComponent
 | Calculates the default size, and optionally the default minimum size, of the component.
measuredHeight — Property in class mx.core.BitmapAsset
 | The measured height of this object.
measuredHeight — Property in class mx.core.ButtonAsset
 | The measured height of this object.
measuredHeight — Property in interface mx.core.IFlexDisplayObject
 | The measured height of this object.
measuredHeight — Property in class mx.core.MovieClipAsset
 | The measured height of this object.
measuredHeight — Property in class mx.core.SpriteAsset
 | The measured height of this object.
measuredHeight — Property in class mx.core.TextFieldAsset
 | The measured height of this object.
measuredHeight — Property in class mx.core.UIComponent
 | The default height of the component, in pixels.
measuredHeight — Property in class mx.core.UITextField
 | The default height of the component, in pixels.
measuredHeight — Property in class mx.managers.SystemManager
 | The measuredHeight is the explicit or measuredHeight of the main mx.core.Application window or the starting height of the SWF if the main window has not yet been created or does not exist.
measuredHeight — Property in class mx.skins.ProgrammaticSkin
 | The measured height of this object.
measuredMinHeight — Property in interface mx.core.IUIComponent
 | The default minimum height of the component, in pixels.
measuredMinHeight — Property in class mx.core.UIComponent
 | The default minimum height of the component, in pixels.
measuredMinHeight — Property in class mx.core.UITextField
 | The default minimum height of the component, in pixels.
measuredMinWidth — Property in interface mx.core.IUIComponent
 | The default minimum width of the component, in pixels.
measuredMinWidth — Property in class mx.core.UIComponent
 | The default minimum width of the component, in pixels.
measuredMinWidth — Property in class mx.core.UITextField
 | The default minimum width of the component, in pixels.
measuredWidth — Property in class mx.core.BitmapAsset
 | The measured width of this object.
measuredWidth — Property in class mx.core.ButtonAsset
 | The measured width of this object.
measuredWidth — Property in interface mx.core.IFlexDisplayObject
 | The measured width of this object.
measuredWidth — Property in class mx.core.MovieClipAsset
 | The measured width of this object.
measuredWidth — Property in class mx.core.SpriteAsset
 | The measured width of this object.
measuredWidth — Property in class mx.core.TextFieldAsset
 | The measured width of this object.
measuredWidth — Property in class mx.core.UIComponent
 | The default width of the component, in pixels.
measuredWidth — Property in class mx.core.UITextField
 | The default width of the component, in pixels.
measuredWidth — Property in class mx.managers.SystemManager
 | The measuredWidth is the explicit or measuredWidth of the main mx.core.Application window, or the starting width of the SWF if the main window has not yet been created or does not exist.
measuredWidth — Property in class mx.skins.ProgrammaticSkin
 | The measured width of this object.
measureHeightOfItems(index:int, count:int) — Method in class mx.controls.listClasses.ListBase
 | Measures a set of items from the data provider using the current item renderer and returns the sum of the heights of those items.
measureHTMLText(htmlText:String) — Method in class mx.core.UIComponent
 | Measures the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
measureHTMLText(htmlText:String) — Method in class mx.core.UITextFormat
 | Returns measurement information for the specified HTML text, which may contain HTML tags such as <font> and <b>, assuming that it is displayed in a single-line UITextField, and using this UITextFormat object to define the text format.
measureText(text:String) — Method in class mx.core.UIComponent
 | Measures the specified text, assuming that it is displayed in a single-line UITextField using a UITextFormat determined by the styles of this UIComponent.
measureText(text:String) — Method in class mx.core.UITextFormat
 | Returns measurement information for the specified text, assuming that it is displayed in a single-line UITextField component, and using this UITextFormat object to define the text format.
measureWidthOfItems(index:int, count:int) — Method in class mx.controls.listClasses.ListBase
 | Measures a set of items from the data provider using the current item renderer and returns the maximum width found.
MEDIUM — Constant static property in class flash.display.StageQuality
 | Specifies medium rendering quality: graphics are anti-aliased using a 2 x 2 pixel grid, but bitmaps are not smoothed.
MEDIUM — Constant static property in class flash.filters.BitmapFilterQuality
 | Defines the medium quality filter setting.
MEDIUM — Constant static property in class mx.managers.CursorManagerPriority
 | Constant that specifies a medium cursor priority when passed as the priority argument to setCursor().
MemoryError — Dynamic class in package flash.errors
 | The MemoryError exception is thrown when a memory allocation request fails.
MemoryError(message:String) — Constructor in class flash.errors.MemoryError
 | Creates a new MemoryError object.
menu — Property in interface mx.controls.menuClasses.IMenuItemRenderer
 | A reference to this menu item renderer's Menu control, if it contains one.
menu — Property in class mx.controls.menuClasses.MenuItemRenderer
 | Contains a reference to the associated Menu control.
menu — Property in class mx.events.MenuEvent
 | The specific Menu instance associated with the event, such as the menu or submenu that was hidden or opened.
Menu — Class in package mx.controls
 | The Menu control creates a pop-up menu of individually selectable choices, similar to the File or Edit menu found in most software applications.
Menu() — Constructor in class mx.controls.Menu
 | Constructor.
menuBar — Property in class mx.events.MenuEvent
 | The MenuBar instance that is the parent of the selected Menu control, or null when the target Menu control is not parented by a MenuBar control.
MenuBar — Class in package mx.controls
 | A MenuBar control defines a horizontal menu bar that contains one or more child menus.
MenuBar() — Constructor in class mx.controls.MenuBar
 | Constructor
MenuBarBackgroundSkin — Class in package mx.skins.halo
 | The skin for the background of a MenuBar.
MenuBarBackgroundSkin() — Constructor in class mx.skins.halo.MenuBarBackgroundSkin
 | Constructor.
menuBarIndex — Property in class mx.controls.menuClasses.MenuBarItem
 | The index of this MenuBarItem relative to other MenuBarItems in the MenuBar.
MenuBarItem — Class in package mx.controls.menuClasses
 | The MenuBarItem class defines an item displayed in a MenuBar control.
MenuBarItem() — Constructor in class mx.controls.menuClasses.MenuBarItem
 | Constructor
menuBarItems — Property in class mx.controls.MenuBar
 | An Array of MenuBarItem objects that populate this MenuBar.
MenuEvent — Class in package mx.events
 | The MenuEvent class represents events that are associated with menu activities in controls such as Menu, MenuBar, and PopUpMenuButton.
MenuEvent(type:String, bubbles:Boolean, cancelable:Boolean, menuBar:mx.controls:MenuBar, menu:mx.controls:Menu, item:Object, itemRenderer:mx.controls.listClasses:IListItemRenderer, label:String, index:int) — Constructor in class mx.events.MenuEvent
 | Constructor.
menuHide — Event in class mx.controls.Menu
 | Dispatched when a menu or submenu is dismissed.
menuHide — Event in class mx.controls.MenuBar
 | Dispatched when a menu or submenu closes.
MENU_HIDE — Constant static property in class mx.events.MenuEvent
 | The MenuEvent.MENU_HIDE event type constant indicates that a menu or submenu closed.
MenuItemRenderer — Class in package mx.controls.menuClasses
 | The MenuItemRenderer class defines the default item renderer for menu items in any menu control.
MenuItemRenderer() — Constructor in class mx.controls.menuClasses.MenuItemRenderer
 | Constructor.
menuItemSelect — Event in class flash.ui.ContextMenuItem
 | Dispatched when a user selects an item from a context menu.
MENU_ITEM_SELECT — Constant static property in class flash.events.ContextMenuEvent
 | Defines the value of the type property of a menuItemSelect event object.
menus — Property in class mx.controls.MenuBar
 | An Array containing the Menu objects for this MenuBar.
menuSelect — Event in class flash.ui.ContextMenu
 | Dispatched when a user first generates a context menu but before the contents of the context menu are displayed.
MENU_SELECT — Constant static property in class flash.events.ContextMenuEvent
 | Defines the value of the type property of a menuSelect event object.
menuSelectionMode — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether menu-style selection should be used.
menuShow — Event in class mx.controls.Menu
 | Dispatched when a menu or submenu opens.
menuShow — Event in class mx.controls.MenuBar
 | Dispatched when a menu or submenu opens, or the mouse pointer rolls over an item with no drop-down menu.
MENU_SHOW — Constant static property in class mx.events.MenuEvent
 | The MenuEvent.MENU_SHOW type constant indicates that the mouse pointer rolled a menu or submenu opened.
merge(sourceBitmapData:flash.display:BitmapData, sourceRect:flash.geom:Rectangle, destPoint:flash.geom:Point, redMultiplier:uint, greenMultiplier:uint, blueMultiplier:uint, alphaMultiplier:uint) — Method in class flash.display.BitmapData
 | Performs per-channel blending from a source image to a destination image.
merge() — Method in class mx.data.DataService
 | Merges any pending updates into the managed set of objects.
merge() — Method in class mx.data.DataStore
 | Merges any pending updates into the managed set of objects.
merge() — Method in class mx.data.mxml.DataService
 | Merges any pending updates into the managed set of objects.
mergeRequired — Property in class mx.data.DataService
 | Indicates if there are any pending changes that must be merged.
mergeRequired — Property in class mx.data.DataStore
 | Indicates if there are any pending changes that must be merged.
mergeRequired — Property in class mx.data.mxml.DataService
 | Indicates if there are any pending changes that must be merged.
message — Property in class Error
 | Contains the message associated with the Error object.
message — Event in class mx.data.DataService
 | The MessageEvent.MESSAGE event is dispatched when the remote destination pushes a notification of a data operation.
message — Property in interface mx.data.IChangeObject
 | Provides access to the local DataMessage corresponding to the local changes.
message — Property in class mx.events.ValidationResultEvent
 | A single string that contains every error message from all of the ValidationResult objects in the results Array.
message — Property in class mx.logging.LogEvent
 | Provides access to the message that was logged.
message — Event in class mx.messaging.Channel
 | Dispatched when a channel receives a message from its endpoint.
message — Event in class mx.messaging.Consumer
 | Dispatched when a message is received by the Consumer.
message — Property in class mx.messaging.MessageResponder
 | Provides access to the sent Message.
message — Property in class mx.messaging.events.MessageEvent
 | The Message associated with this event.
message — Property in class mx.messaging.events.MessageFaultEvent
 | The ErrorMessage for this event.
message — Property in class mx.rpc.AsyncToken
 | Provides access to the associated message.
MESSAGE — Constant static property in class mx.messaging.events.MessageEvent
 | The MESSAGE event type; dispatched upon receipt of a message.
MessageAckEvent — Class in package mx.messaging.events
 | The MessageAckEvent class is used to propagate acknowledge messages within the messaging system.
MessageAckEvent(type:String, bubbles:Boolean, cancelable:Boolean, ack:mx.messaging.messages:AcknowledgeMessage, correlation:mx.messaging.messages:IMessage) — Constructor in class mx.messaging.events.MessageAckEvent
 | Constructs an instance of this event with the specified acknowledge message and original correlated message.
MessageAgent — Class in package mx.messaging
 | The MessageAgent class provides the basic low-level functionality common to message handling for a destination. Note: For advanced use only.
MessageAgent() — Constructor in class mx.messaging.MessageAgent
 | Constructor.
messageAgents — Property in class mx.messaging.ChannelSet
 | Provides access to the set of MessageAgents that use this ChannelSet.
MESSAGE_DELIVERY_IN_DOUBT — Constant static property in class mx.messaging.messages.ErrorMessage
 | If a message may not have been delivered, the faultCode will contain this constant.
MessageEvent — Class in package mx.messaging.events
 | The MessageEvent class is used to propagate messages within the messaging system.
MessageEvent(type:String, bubbles:Boolean, cancelable:Boolean, message:mx.messaging.messages:IMessage) — Constructor in class mx.messaging.events.MessageEvent
 | Constructs an instance of this event with the specified type and message.
MessageFaultEvent — Class in package mx.messaging.events
 | The MessageFaultEvent class is used to propagate fault messages within the messaging system.
MessageFaultEvent(type:String, bubbles:Boolean, cancelable:Boolean, message:mx.messaging.messages:ErrorMessage) — Constructor in class mx.messaging.events.MessageFaultEvent
 | Constructs an instance of a fault message event for the specified message and fault information.
messageId — Property in class mx.messaging.messages.AbstractMessage
 | The unique id for the message.
messageId — Property in interface mx.messaging.messages.IMessage
 | The unique id for the message.
messageRefType — Property in class mx.messaging.messages.CommandMessage
 | Targets the CommandMessage to a remote destination belonging to a specific service, based upon whether this server message type matches the message type the service handles.
MessageResponder — Class in package mx.messaging
 | The MessageResponder class handles a successful result or fault from a message destination.
MessageResponder(agent:mx.messaging:MessageAgent, message:mx.messaging.messages:IMessage, channel:mx.messaging:Channel) — Constructor in class mx.messaging.MessageResponder
 | Constructs a MessageResponder to handle the response for the specified Message for the specified MessageAgent.
MessageSerializationError — Class in package mx.messaging.errors
 | This error indicates a problem serializing a message within a channel.
MessageSerializationError(msg:String, fault:mx.messaging.messages:ErrorMessage) — Constructor in class mx.messaging.errors.MessageSerializationError
 | Constructs a new instance of the MessageSerializationError with the specified message.
messageStyleName — Style in class mx.controls.Alert
 | Name of the CSS style declaration that specifies styles for the Alert message text.
messageType — Property in class mx.messaging.Consumer
 | The server alias for the type of message the Consumer can process.
MessagingError — Class in package mx.messaging.errors
 | This is the base class for any messaging related error.
MessagingError(msg:String) — Constructor in class mx.messaging.errors.MessagingError
 | Constructs a new instance of a MessagingError with the specified message.
Metadata — MXML Only Component
 | You use the <mx:Metadata> tag to insert metadata tags in an MXML file.
method — Property in class flash.net.URLRequest
 | Controls whether the HTTP form submission method is a GET or POST operation.
method — Property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates what method should be used for the request.
method — Property in class mx.rpc.http.HTTPService
 | HTTP method for sending the request.
Microphone — Final class in package flash.media
 | The Microphone class lets you capture audio from a microphone attached to the computer that is running Flash Player.
MICROPHONE — Constant static property in class flash.system.SecurityPanel
 | When passed to Security.showSettings(), displays the Microphone panel in Flash Player Settings.
milliseconds — Property in class Date
 | The milliseconds (an integer from 0 to 999) portion of a Date object according to local time.
millisecondsUTC — Property in class Date
 | The milliseconds (an integer from 0 to 999) portion of a Date object according to universal time (UTC).
min(val1:Number, val2:Number, ... rest) — Static method in class Math
 | Evaluates val1 and val2 (or more values) and returns the smallest value.
min — Property in class mx.charts.chartClasses.DataDescription
 | The minimum data value displayed by the element.
min — Property in class mx.charts.series.items.AreaSeriesItem
 | The minimum value of this item converted into screen coordinates.
min — Property in class mx.charts.series.items.BarSeriesItem
 | The minimum value of this item converted into screen coordinates.
min — Property in class mx.charts.series.items.ColumnSeriesItem
 | The minimum value of this item converted into screen coordinates.
minColumnWidth — Property in class mx.controls.DataGrid
 | The minimum width of the columns, in pixels.
minField — Property in class mx.charts.series.AreaSeries
 | Specifies the field of the dataProvider that determines the bottom boundary of the area.
minField — Property in class mx.charts.series.BarSeries
 | Specifies the field of the data provider that determines the bottom of each bar.
minField — Property in class mx.charts.series.ColumnSeries
 | Specifies the field of the data provider that determines the y-axis location of the bottom of a column.
minFilter — Property in class mx.charts.series.items.AreaSeriesItem
 | The minimum value of this item, filtered against the vertical axis of the containing chart.
minFilter — Property in class mx.charts.series.items.BarSeriesItem
 | The minimum value of this item, filtered against the horizontal axis of the containing chart.
minFilter — Property in class mx.charts.series.items.ColumnSeriesItem
 | The minimum value of this item, filtered against the vertical axis of the containing chart.
minHeight — Property in interface mx.core.IUIComponent
 | Number that specifies the minimum height of the component, in pixels, as the component's coordinates.
minHeight — Property in class mx.core.UIComponent
 | Number that specifies the minimum height of the component, in pixels, in the component's coordinates.
minHeight — Property in class mx.core.UITextField
 | Number that specifies the minimum height of the component, in pixels, in the component's coordinates.
MiniDebugTarget — Class in package mx.logging.targets
 | Provides a logger target that outputs to a LocalConnection, connected to the MiniDebug application.
MiniDebugTarget(connection:String, method:String) — Constructor in class mx.logging.targets.MiniDebugTarget
 | Constructor.
minimum — Property in class mx.charts.DateTimeAxis
 | Specifies the minimum value for an axis label.
minimum — Property in class mx.charts.LinearAxis
 | Specifies the minimum value for an axis label.
minimum — Property in class mx.charts.LogAxis
 | Specifies the minimum value for an axis label.
minimum — Property in class mx.controls.NumericStepper
 | Minimum value of the NumericStepper.
minimum — Property in class mx.controls.ProgressBar
 | Smallest progress value for the ProgressBar.
minimum — Property in class mx.controls.sliderClasses.Slider
 | The minimum allowed value on the slider control.
MINIMUM_DISPLAY_TIME — Property in class mx.preloaders.DownloadProgressBar
 | The minimum number of milliseconds that the display should appear visible.
minimumElementDuration — Property in class mx.charts.effects.SeriesEffect
 | Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect.
minimumElementDuration — Property in class mx.charts.effects.effectClasses.SeriesEffectInstance
 | Specifies the amount of time, in milliseconds, that an individual element should take to complete the effect.
minInterval — Property in class mx.charts.chartClasses.DataDescription
 | The minimum interval, in data units, between any two values displayed by the element.
minLength — Property in class mx.validators.StringValidator
 | Minimum length for a valid String.
minNumber — Property in class mx.charts.series.items.AreaSeriesItem
 | The minimum value of this item, converted to a number by the vertical axis of the containing chart.
minNumber — Property in class mx.charts.series.items.BarSeriesItem
 | The minimum value of this item, converted to a number by the horizontal axis of the containing chart.
minNumber — Property in class mx.charts.series.items.ColumnSeriesItem
 | The minimum value of this item, converted to a number by the vertical axis of the containing chart.
minorInterval — Property in class mx.charts.LinearAxis
 | Specifies the numeric difference between minor tick marks along the axis.
minorTickCache — Property in class mx.charts.chartClasses.NumericAxis
 | The most recent set of minor tick marks generated to represent this axis.
minorTickInterval — Property in class mx.charts.DateTimeAxis
 | Specifies the number of minorTickUnits between minor tick marks along the axis.
minorTickLength — Style in class mx.charts.AxisRenderer
 | Specifies the length of the minor tick marks on the axis, in pixels.
minorTickPlacement — Style in class mx.charts.AxisRenderer
 | Specifies where to draw the minor tick marks.
minorTicks — Property in class mx.charts.AxisRenderer
 | Contains an array that specifies where Flex draws the minor tick marks along the axis.
minorTicks — Property in class mx.charts.chartClasses.AxisLabelSet
 | An array of values from 0 to 1 representing where to place minor tick marks along the axis.
minorTicks — Property in interface mx.charts.chartClasses.IAxisRenderer
 | Contains an array that specifies where Flex draws the minor tick marks along the axis.
minorTicks — Property in class mx.charts.chartClasses.NumericAxis
 | An Array of minor tick marks generated to represent this axis.
minorTickStroke — Style in class mx.charts.AxisRenderer
 | Specifies the characteristics of the minor tick marks on the axis.
minorTickUnits — Property in class mx.charts.DateTimeAxis
 | The units that the Axis considers when generating minor tick marks.
minScrollPosition — Property in class mx.controls.scrollClasses.ScrollBar
 | Number that represents the minimum scroll position.
minutes — Property in class Date
 | The minutes (an integer from 0 to 59) portion of a Date object according to local time.
minutesUTC — Property in class Date
 | The minutes (an integer from 0 to 59) portion of a Date object according to universal time (UTC).
minValue — Property in class mx.charts.series.items.AreaSeriesItem
 | The minimum value of this item.
minValue — Property in class mx.charts.series.items.BarSeriesItem
 | The minimum value of this item.
minValue — Property in class mx.charts.series.items.ColumnSeriesItem
 | The miniumum value of this item.
minValue — Property in class mx.validators.CurrencyValidator
 | Minimum value for a valid number.
minValue — Property in class mx.validators.NumberValidator
 | Minimum value for a valid number.
MIN_VALUE — Constant static property in class int
 | The smallest representable 32-bit signed integer, which is -2,147,483,648.
MIN_VALUE — Constant static property in class Number
 | The smallest representable non-negative, non-zero, number (double-precision IEEE-754).
MIN_VALUE — Constant static property in class uint
 | The smallest representable unsigned integer, which is 0.
minWidth — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The minimum width of the column.
minWidth — Property in interface mx.core.IUIComponent
 | Number that specifies the minimum width of the component, in pixels, as the component's coordinates.
minWidth — Property in class mx.core.UIComponent
 | Number that specifies the minimum width of the component, in pixels, in the component's coordinates.
minWidth — Property in class mx.core.UITextField
 | Number that specifies the minimum width of the component, in pixels, in the component's coordinates.
minYear — Property in class mx.controls.DateChooser
 | The first year selectable in the control.
minYear — Property in class mx.controls.DateField
 | The first year selectable in the control.
missingAtSignError — Property in class mx.validators.EmailValidator
 | Error message when there is no at sign in the email address.
missingPeriodInDomainError — Property in class mx.validators.EmailValidator
 | Error message when there is no period in the domain.
missingUsernameError — Property in class mx.validators.EmailValidator
 | Error message when there is no username.
MITER — Constant static property in class flash.display.JointStyle
 | Specifies mitered joints in the joints parameter of the flash.display.Graphics.lineStyle() method.
miterLimit — Property in class mx.graphics.LinearGradientStroke
 | A number that indicates the limit at which a miter is cut off.
miterLimit — Property in class mx.graphics.Stroke
 | Indicates the limit at which a miter is cut off.
modalTransparency — Style in class mx.containers.Panel
 | Modality of components launched by the PopUp Manager is simulated by creating a large translucent overlay underneath the component.
modalTransparency — Style in class mx.core.Application
 | Modality of components launched by the PopUp Manager is simulated by creating a large translucent overlay underneath the component.
modalTransparencyBlur — Style in class mx.containers.Panel
 | The blur applied to the application while a modal window is open.
modalTransparencyBlur — Style in class mx.core.Application
 | The blur applied to the application while a modal window is open.
modalTransparencyColor — Style in class mx.containers.Panel
 | Color of the modal overlay layer.
modalTransparencyColor — Style in class mx.core.Application
 | Color of the modal overlay layer.
modalTransparencyDuration — Style in class mx.containers.Panel
 | Duration, in milliseconds, of the modal transparency effect that plays when a modal window opens or closes.
modalTransparencyDuration — Style in class mx.core.Application
 | Duration, in milliseconds, of the modal transparency effect that plays when a modal window opens or closes.
mode — Property in class flash.filters.DisplacementMapFilter
 | The mode for the filter.
mode — Property in class mx.controls.ProgressBar
 | Specifies the method used to update the bar.
Model — MXML Only Component
 | You use the <mx:Model> tag to declare a data model in MXML.
modificationDate — Property in class flash.net.FileReference
 | The date that the file on the local disk was last modified.
modifiesSelection — Property in class mx.controls.textClasses.TextRange
 | Whether the TextRange modifies the currenly selected text.
month — Property in class Date
 | The month (0 for January, 1 for February, and so on) portion of a Date object according to local time.
monthListener — Property in class mx.validators.DateValidator
 | The component that listens for the validation result for the month subfield.
monthNames — Property in class mx.controls.DateChooser
 | Names of the months displayed at the top of the DateChooser control.
monthNames — Property in class mx.controls.DateField
 | Names of the months displayed at the top of the control.
monthNamesLong — Static property in class mx.formatters.DateBase
 | Long format of month names.
monthNamesShort — Static property in class mx.formatters.DateBase
 | Short format of month names.
monthProperty — Property in class mx.validators.DateValidator
 | Name of the month property to validate.
monthSource — Property in class mx.validators.DateValidator
 | Object that contains the value of the month field.
monthSymbol — Property in class mx.controls.DateChooser
 | This property is appended to the end of the value specified by the monthNames property to define the names of the months displayed at the top of the DateChooser control.
monthSymbol — Property in class mx.controls.DateField
 | This property is appended to the end of the value specified by the monthNames property to define the names of the months displayed at the top of the control.
monthUTC — Property in class Date
 | The month (0 [January] to 11 [December]) portion of a Date object according to universal time (UTC).
MorphShape — Final class in package flash.display
 | The MorphShape class represents MorphShape objects on the display list.
motionLevel — Property in class flash.media.Camera
 | A numeric value that specifies the amount of motion required to invoke the activity event.
motionTimeout — Property in class flash.media.Camera
 | The number of milliseconds between the time the camera stops detecting motion and the time the activity event is invoked.
Mouse — Final class in package flash.ui
 | The methods of the Mouse class are used to hide and show the mouse pointer.
mouseChildren — Property in class flash.display.DisplayObjectContainer
 | Determines whether or not the children of the object are mouse enabled.
mouseChildren — Property in class flash.display.Stage
 | Determines whether or not the children of the object are mouse enabled.
mouseClickHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles MouseEvent.MOUSE_CLICK events from any mouse targets contained in the list including the renderers.
mouseDoubleClickHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles MouseEvent.MOUSE_DOUBLE_CLICK events from any mouse targets contained in the list including the renderers.
mouseDown — Event in class flash.display.InteractiveObject
 | Dispatched when a user presses the pointing device button over an InteractiveObject instance in the Flash Player window.
MOUSE_DOWN — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a mouseDown event object.
mouseDownEffect — Effect in class mx.core.UIComponent
 | Played when the user presses the mouse button while over the component.
mouseDownHandler(event:flash.events:MouseEvent) — Method in class mx.controls.Button
 | The default handler for the MouseEvent.MOUSE_DOWN event.
mouseDownHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
mouseDownOutside — Event in class mx.core.UIComponent
 | Dispatched from a component opened using the PopUpManager when the user clicks outside it.
MOUSE_DOWN_OUTSIDE — Constant static property in class mx.events.FlexMouseEvent
 | The FlexMouseEvent.MOUSE_DOWN_OUTSIDE constant defines the value of the type property of the event object for a mouseDownOutside event.
mouseEnabled — Property in class flash.display.InteractiveObject
 | Specifies whether this object receives mouse messages.
MouseEvent — Class in package flash.events
 | Flash® Player dispatches MouseEvent objects into the event flow whenever mouse events occur.
MouseEvent(type:String, bubbles:Boolean, cancelable:Boolean, localX:Number, localY:Number, relatedObject:flash.display:InteractiveObject, ctrlKey:Boolean, altKey:Boolean, shiftKey:Boolean, buttonDown:Boolean, delta:int) — Constructor in class flash.events.MouseEvent
 | Creates an Event object that contains information about mouse events.
mouseEventToItemRenderer(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Determines which item renderer is under the mouse.
mouseFocusChange — Event in class flash.display.InteractiveObject
 | Dispatched when the user attempts to change focus by using a pointer device.
MOUSE_FOCUS_CHANGE — Constant static property in class flash.events.FocusEvent
 | Defines the value of the type property of a mouseFocusChange event object.
mouseFocusEnabled — Property in class mx.core.UIComponent
 | Whether you can receive focus when clicked on.
mouseFocusEnabled — Property in interface mx.managers.IFocusManagerComponent
 | A flag that indicates whether the component can receive focus when selected with the mouse.
mouseLeave — Event in class flash.display.Stage
 | Dispatched by the Stage object when the mouse pointer moves out of the Flash Player window area.
MOUSE_LEAVE — Constant static property in class flash.events.Event
 | Defines the value of the type property of a mouseLeave event object.
mouseMove — Event in class flash.display.InteractiveObject
 | Dispatched when a user moves the pointing device while it is over an InteractiveObject.
MOUSE_MOVE — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a mouseMove event object.
mouseMoveHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles MouseEvent.MOUSE_MOVE events from any mouse targets contained in the list including the renderers.
mouseOut — Event in class flash.display.InteractiveObject
 | Dispatched when the user moves a pointing device away from an InteractiveObject instance.
MOUSE_OUT — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a mouseOut event object.
mouseOutHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles MouseEvent.MOUSE_OUT events from any mouse targets contained in the list including the renderers.
mouseOver — Event in class flash.display.InteractiveObject
 | Dispatched when the user moves a pointing device over an InteractiveObject instance in the Flash Player window.
MOUSE_OVER — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a mouseOver event object.
mouseOverHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles MouseEvent.MOUSE_OVER events from any mouse targets contained in the list, including the renderers.
mouseSensitivity — Property in class mx.charts.chartClasses.ChartBase
 | Specifies the distance, in pixels, that Flex considers a data point to be under the mouse pointer when the mouse moves around a chart.
mouseTarget — Property in class flash.events.ContextMenuEvent
 | The display list object on which the user right-clicked to display the context menu.
mouseUp — Event in class flash.display.InteractiveObject
 | Dispatched when a user releases the pointing device button over an InteractiveObject instance in the Flash Player window.
MOUSE_UP — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a mouseUp event object.
mouseUpEffect — Effect in class mx.core.UIComponent
 | Played when the user releases the mouse button while over the component.
mouseUpHandler(event:flash.events:MouseEvent) — Method in class mx.controls.Button
 | The default handler for the MouseEvent.MOUSE_UP event.
mouseUpHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles MouseEvent.MOUSE_DOWN events from any mouse targets contained in the list including the renderers.
mouseWheel — Event in class flash.display.InteractiveObject
 | Dispatched when a mouse wheel is spun over an InteractiveObject instance in the Flash Player window.
MOUSE_WHEEL — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a mouseWheel event object.
mouseWheelEnabled — Property in class flash.text.TextField
 | A Boolean value that indicates whether Flash Player should automatically scroll multiline text fields when the user clicks a text field and rolls the mouse wheel.
mouseWheelHandler(event:flash.events:MouseEvent) — Method in class mx.controls.listClasses.ListBase
 | Handles mouseWheel events by changing scroll positions.
mouseWheelHandler(event:flash.events:MouseEvent) — Method in class mx.core.ScrollControlBase
 | Event handler for the mouse wheel scroll event.
mouseWheelOutside — Event in class mx.core.UIComponent
 | Dispatched from a component opened using the PopUpManager when the user scrolls the mouse wheel outside it.
MOUSE_WHEEL_OUTSIDE — Constant static property in class mx.events.FlexMouseEvent
 | The FlexMouseEvent.MOUSE_WHEEL_OUTSIDE constant defines the value of the type property of the event object for a mouseWheelOutside event.
mouseX — Property in class flash.display.DisplayObject
 | Indicates the x coordinate of the mouse position, in pixels.
mouseY — Property in class flash.display.DisplayObject
 | Indicates the y coordinate of the mouse position, in pixels.
move(x:Number, y:Number) — Method in class mx.charts.AxisRenderer
 | Moves this object to the specified x and y coordinates.
move(x:Number, y:Number) — Method in class mx.core.BitmapAsset
 | Moves this object to the specified x and y coordinates.
move(x:Number, y:Number) — Method in class mx.core.ButtonAsset
 | Moves this object to the specified x and y coordinates.
move(x:Number, y:Number) — Method in interface mx.core.IFlexDisplayObject
 | Moves this object to the specified x and y coordinates.
move(x:Number, y:Number) — Method in class mx.core.MovieClipAsset
 | Moves this object to the specified x and y coordinates.
move(x:Number, y:Number) — Method in class mx.core.SpriteAsset
 | Moves this object to the specified x and y coordinates.
move(x:Number, y:Number) — Method in class mx.core.TextFieldAsset
 | Moves this object to the specified x and y coordinates.
move — Event in class mx.core.UIComponent
 | Dispatched when the object has moved.
move(x:Number, y:Number) — Method in class mx.core.UIComponent
 | Moves the component to a specified position within its parent.
move(x:Number, y:Number) — Method in class mx.core.UITextField
 | Moves the component to a specified position within its parent.
move(x:Number, y:Number) — Method in class mx.managers.SystemManager
 | Calling the move() method has no effect as it is directly mapped to the application window or the loader.
move(x:Number, y:Number) — Method in class mx.skins.ProgrammaticSkin
 | Moves this object to the specified x and y coordinates.
Move — Class in package mx.effects
 | The Move effect changes the position of a component over a specified time interval.
Move(target:Object) — Constructor in class mx.effects.Move
 | Constructor.
MOVE — Constant static property in class mx.events.CollectionEventKind
 | Indicates that the item has moved from the position identified by the CollectionEvent oldLocation property to the position identified by the location property.
MOVE — Constant static property in class mx.events.MoveEvent
 | The MoveEvent.MOVE constant defines the value of the type property of the event object for a move event.
MOVE — Constant static property in class mx.managers.DragManager
 | Constant that specifies that the type of drag action is "move".
moveCursor — Style in class mx.managers.DragManager
 | Cursor displayed during a move operation.
moveDivider(i:int, amt:Number) — Method in class mx.containers.DividedBox
 | Move a specific divider a given number of pixels.
moveEasingFunction — Property in class mx.effects.MaskEffect
 | Easing function to use for moving the mask.
moveEasingFunction — Property in class mx.effects.effectClasses.MaskEffectInstance
 | Easing function to use for moving the mask.
moveEffect — Effect in class mx.core.UIComponent
 | Played when the component is moved.
MoveEvent — Class in package mx.events
 | Represents event objects that are dispatched when a Flex component moves.
MoveEvent(type:String, bubbles:Boolean, cancelable:Boolean, oldX:Number, oldY:Number) — Constructor in class mx.events.MoveEvent
 | Constructor.
MoveInstance — Class in package mx.effects.effectClasses
 | The MoveInstance class implements the instance class for the Move effect.
MoveInstance(target:Object) — Constructor in class mx.effects.effectClasses.MoveInstance
 | Constructor.
moveNext() — Method in interface mx.collections.IViewCursor
 | Moves the cursor to the next item within the collection.
movePrevious() — Method in interface mx.collections.IViewCursor
 | Moves the cursor to the previous item within the collection.
moveSelectionHorizontally(code:uint, shiftKey:Boolean, ctrlKey:Boolean) — Method in class mx.controls.listClasses.ListBase
 | Moves the selection in a horizontal direction in response to the user selecting items using the left-arrow or right-arrow keys and modifiers such as the Shift and Ctrl keys.
moveSelectionVertically(code:uint, shiftKey:Boolean, ctrlKey:Boolean) — Method in class mx.controls.listClasses.ListBase
 | Moves the selection in a vertical direction in response to the user selecting items using the up-arrow or down-arrow Keys and modifiers such as the Shift and Ctrl keys.
moveTo(x:Number, y:Number) — Method in class flash.display.Graphics
 | Moves the current drawing position to (x, y).
MovieClip — Dynamic class in package flash.display
 | The MovieClip class inherits from the following classes: Sprite, DisplayObjectContainer, InteractiveObject, DisplayObject, and EventDispatcher.
MovieClip() — Constructor in class flash.display.MovieClip
 | Creates a new MovieClip instance.
MovieClipAsset — Class in package mx.core
 | MovieClipAsset is a subclass of the Flash Player's MovieClip class which represents movieclip symbols that you embed in a Flex application from a SWF file produced by Flash.
MovieClipAsset() — Constructor in class mx.core.MovieClipAsset
 | Constructor.
movieClipData — Property in class mx.core.MovieClipLoaderAsset
 | A ByteArray containing the inner content.
MovieClipLoaderAsset — Class in package mx.core
 | MovieClipLoaderAsset is a subclass of the MovieClipAsset class which represents SWF files that you embed in a Flex application.
MovieClipLoaderAsset() — Constructor in class mx.core.MovieClipLoaderAsset
 | Constructor.
MULTI_BATCH_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation represents a set of operations to be performed as a single unit but which may contain multiple batched, create, update or delete operations that involve more than one destination, that is, more than one remote adapter.
multiline — Property in class RegExp
 | Specifies whether the m (multiline) flag is set.
multiline — Property in class flash.text.TextField
 | Indicates whether the text field is a multiline text field.
MULTIPLY — Constant static property in class flash.display.BlendMode
 | Multiplies the values of the display object constituent colors by the constituent colors of the background color, and normalizes by dividing by 0xFF, resulting in darker colors.
mustUnderstand — Property in class mx.rpc.soap.SOAPHeader
 | Specifies whether the header must be understood by the endpoint.
muted — Property in class flash.media.Camera
 | A Boolean value that specifies whether the user has denied access to the camera (true) or allowed access (false) in the Flash Player Privacy panel.
muted — Property in class flash.media.Microphone
 | Specifies whether the user has denied access to the microphone (true) or allowed access (false).
mx.binding.utils — Package
 | The mx.binding.utils package contains the classes for creating binding watchers and for defining bindings in ActionScript.
mx.charts — Package
 | The mx.charts package contains the classes for Flex Charting.
mx.charts.chartClasses — Package
 | The mx.charts.chartClasses package contains the base classes for the Flex charting components.
mx.charts.effects — Package
 | The mx.charts.effects package contains the effect classes for the Flex charting components.
mx.charts.effects.effectClasses — Package
 | The mx.charts.effects.effectClasses package contains the effect instance classes for the Flex charting components.
mx.charts.events — Package
 | The mx.charts.events package contains the classes that define chart event objects.
mx.charts.renderers — Package
 | The mx.charts.renderers package contains the item renderer classes for the Flex charting components.
mx.charts.series — Package
 | The mx.charts.series package contains the series classes for the Flex charting components.
mx.charts.series.items — Package
 | The mx.charts.series.items package contains the items series classes for the Flex charting components.
mx.charts.series.renderData — Package
 | The mx.charts.series.renderData package contains the data classes for the Flex charting components.
mx.collections — Package
 | The mx.collections package contains the classes for the Flex collection components.
mx.collections.errors — Package
 | The mx.collections.errors package contains the error classes for the Flex collection components.
mx.containers — Package
 | The mx.containers package contains the container classes.
mx.containers.accordionClasses — Package
 | The mx.containers.accordionClasses package contains the classes used by the Accordion container.
mx.controls — Package
 | The mx.controls package contains the Flex user-interface controls.
mx.controls.dataGridClasses — Package
 | The mx.controls.dataGridClasses package contains the classes used by the DataGrid control.
mx.controls.listClasses — Package
 | The mx.controls.listClasses package contains the classes used by the list-based controls.
mx.controls.menuClasses — Package
 | The mx.controls.menuClasses package contains the classes used by the menu-based controls.
mx.controls.scrollClasses — Package
 | The mx.controls.scrollClasses package contains the classes used by controls that support scroll bars.
mx.controls.sliderClasses — Package
 | The mx.controls.sliderClasses package contains the classes used by the Slider control.
mx.controls.textClasses — Package
 | The mx.controls.textClasses package contains the classes used by the text-based controls.
mx.controls.treeClasses — Package
 | The mx.controls.treeClasses package contains the classes used by the Tree control.
mx.controls.videoClasses — Package
 | The mx.controls.videoClasses package contains the classes used by the VideoDisplay control.
mx.core — Package
 | The mx.core package contains the base classes and interfaces, such as UIComponent, used by Flex.
mx.data — Package
 | The mx.data package contains classes for working with the Flex Data Management Service.
mx.data.errors — Package
 | The mx.data.errors package contains the error classes used with the Flex Data Management Service.
mx.data.events — Package
 | The mx.data.events package contains the event classes used with the Flex Data Management Service.
mx.data.messages — Package
 | The mx.data.messages package contains the messages used with the Flex Data Management Service.
mx.data.mxml — Package
mx.data.utils — Package
mx.effects — Package
 | The mx.effects package contains the Factory classes to support behaviors.
mx.effects.easing — Package
 | The mx.effects.easing package contains the easing classes used by effects.
mx.effects.effectClasses — Package
 | The mx.effects.effectClasses package contains the effect implementation classes corresponding to the effect factory classes in the mx.effects package.
mx.events — Package
 | The mx.events package contains the classes that define Flex event objects.
mx.formatters — Package
 | The mx.formatters package contains the classes to support data formatting.
mx.graphics — Package
 | The mx.graphics package contains drawing classes.
mx.logging — Package
 | The mx.logging package contains the logging classes.
mx.logging.errors — Package
 | The mx.logging.errors package contains the error classes used by the logging components.
mx.logging.targets — Package
 | The mx.logging.targets package contains the target classes used by the logging components.
mx.managers — Package
 | The mx.managers package contains the Flax manager classes, such as DragManager and HistoryManager.
mx.messaging — Package
 | The mx.messaging package contains the messaging classes used with Flex Data Services.
mx.messaging.channels — Package
 | The mx.messaging.channels package contains the messaging channel classes used with Flex Data Services.
mx.messaging.config — Package
 | The mx.messaging.config package contains the messaging configuration classes used with Flex Data Services.
mx.messaging.errors — Package
 | The mx.messaging.errors package contains the messaging error classes used with Flex Data Services.
mx.messaging.events — Package
 | The mx.messaging.events package contains the messaging event classes used used with Flex Data Services.
mx.messaging.management — Package
 | The mx.messaging.management package contains the bean management classes used with Flex Data Services.
mx.messaging.messages — Package
 | The mx.messaging.messages package contains the message classes used with Flex Data Services.
mx.preloaders — Package
 | The mx.preloaders package contains the classes used by the download progress bar.
mx.printing — Package
 | The mx.printing package contains the printing classes.
mx.resources — Package
 | The mx.resources package contains the classes used to support localization.
mx.rpc — Package
 | The mx.rpc package contains the RPC classes.
mx.rpc.events — Package
 | The mx.rpc.events package contains the RPC event classes.
mx.rpc.http — Package
 | The mx.rpc.http package contains the HTTPService classes.
mx.rpc.http.mxml — Package
 | The mx.rpc.http.mxml package contains the HTTP service MXML classes.
mx.rpc.mxml — Package
 | The mx.rpc.mxml package contains the RPC MXML interface.
mx.rpc.remoting — Package
 | The mx.rpc.remoting package contains the remote object classes.
mx.rpc.remoting.mxml — Package
 | The mx.rpc.remoting.mxml package contains the remote object MXML classes.
mx.rpc.soap — Package
 | The mx.rpc.soap package contains the web service classes.
mx.rpc.soap.mxml — Package
 | The mx.rpc.soap.mxml package contains the web service MXML class.
mx.rpc.xml — Package
 | The mx.rpc.xml package contains the RPC XML-related classes.
mx.skins — Package
 | The mx.skins package contains the classes that define the skinning components.
mx.skins.halo — Package
 | The mx.skins.halo package contains the classes used to skin Flex user-interface controls.
mx.states — Package
 | The mx.states package contains the classes to support view states.
mx.styles — Package
 | The mx.styles package contains the classes used by the Flex styles components.
mx.utils — Package
 | The mx.utils package contains Flex utility classes.
mx.validators — Package
 | The mx.validators package contains the classes to support data validation.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


N Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
N Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
name — Property in class Error
 | Contains the name of the Error object.
name() — Method in class XML
 | Gives the qualified name for the XML object.
name — Property in class flash.accessibility.AccessibilityProperties
 | Provides a name for this display object in the accessible presentation.
name — Property in class flash.display.DisplayObject
 | Indicates the instance name of the DisplayObject.
name — Property in class flash.display.FrameLabel
 | The name of the label.
name — Property in class flash.display.Scene
 | The name of the scene.
name — Property in class flash.media.Camera
 | A string that specifies the name of the current camera, as returned by the camera hardware.
name — Property in class flash.media.Microphone
 | The name of the current sound capture device, as returned by the sound capture hardware.
name — Property in class flash.net.FileReference
 | The name of the file on the local disk.
name — Property in class flash.net.URLRequestHeader
 | An HTTP request header name (such as Content-Type or SOAPAction).
name — Property in class mx.collections.SortField
 | The name of the field to be sorted.
name — Property in interface mx.core.IFlexDisplayObject
 | The instance name of this object.
name — Property in class mx.effects.SetPropertyAction
 | The name of the property being changed.
name — Property in class mx.effects.SetStyleAction
 | The name of the style property being changed.
name — Property in class mx.effects.effectClasses.SetPropertyActionInstance
 | The name of the property being changed.
name — Property in class mx.effects.effectClasses.SetStyleActionInstance
 | The name of the style property being changed.
name — Property in class mx.messaging.management.MBeanFeatureInfo
 | The name of the MBean feature.
name — Property in class mx.rpc.AbstractOperation
 | The name of this Operation.
name — Property in class mx.states.SetEventHandler
 | The name of the event whose handler is being set.
name — Property in class mx.states.SetProperty
 | The name of the property to change.
name — Property in class mx.states.SetStyle
 | The name of the style to change.
name — Property in class mx.states.State
 | The name of the view state.
nameField — Property in class mx.charts.series.PieSeries
 | Specifies the field of the data provider that determines the name of each wedge of the PieChart control.
names — Static property in class flash.media.Camera
 | Retrieves an array of strings reflecting the names of all available cameras without displaying the Flash Player Privacy panel.
names — Static property in class flash.media.Microphone
 | The names of all available sound capture devices.
namespace — Statement
 | Allows you to control the visibility of definitions.
namespace(prefix:String) — Method in class XML
 | If no parameter is provided, gives the namespace associated with the qualified name of this XML object.
Namespace — Final class in Top Level
 | The Namespace class contains methods and properties for defining and working with namespaces.
Namespace(uriValue) — Constructor in class Namespace
 | Creates a Namespace object.
Namespace(prefixValue, uriValue) — Constructor in class Namespace
 | Creates a Namespace object according to the values of the prefixValue and uriValue parameters.
namespaceDeclarations() — Method in class XML
 | Lists namespace declarations associated with the XML object in the context of its parent.
namespaceURI — Property in class flash.xml.XMLNode
 | If the XML node has a prefix, namespaceURI is the value of the xmlns declaration for that prefix (the URI), which is typically called the namespace URI.
NameUtil — Class in package mx.utils
 | The NameUtil utility class defines static methods for creating names for Flex objects.
NaN — Package constant property in Top Level
 | A special member of the Number data type that represents a value that is "not a number" (NaN).
NaN — Constant static property in class Number
 | The IEEE-754 value representing Not a Number (NaN).
native — Statement
 | Specifies that a function or method is implemented by Flash Player in native code.
NavBar — Class in package mx.controls
 | The NavBar control is the superclass for navigator controls, such as the LinkBar and TabBar controls, and cannot be instantiated directly.
NavBar() — Constructor in class mx.controls.NavBar
 | Constructor.
navigateToURL(request, window) — Package function in flash.net
 | Opens or replaces a window in the application that contains the Flash Player container (usually a browser).
NEAREST — Constant static property in class mx.formatters.NumberBaseRoundType
 | Rounds a number up or down to the nearest integer.
negativeError — Property in class mx.validators.CurrencyValidator
 | Error message when the value is negative and the allowNegative property is false.
negativeError — Property in class mx.validators.NumberValidator
 | Error message when the value is negative and the allowNegative property is false.
NEGATIVE_INFINITY — Constant static property in class Number
 | Specifies the IEEE-754 value representing negative infinity.
nestLevel — Property in class mx.core.UIComponent
 | Depth of this object in the containment hierarchy.
nestLevel — Property in class mx.core.UITextField
 | Depth of this object in the containment hierarchy.
nestLevel — Property in interface mx.managers.ILayoutManagerClient
 | The top-level SystemManager has a nestLevel of 1.
nestLevel — Property in class mx.skins.ProgrammaticSkin
 | Depth of this object in the containment hierarchy.
netConnection — Property in class mx.messaging.channels.NetConnectionChannel
 | Provides access to the associated NetConnection for this Channel.
NetConnection — Class in package flash.net
 | The NetConnection class lets you invoke commands on a remote application server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, and to play streaming Flash Video (FLV) files from either an HTTP address or a local drive.
NetConnection() — Constructor in class flash.net.NetConnection
 | Creates a NetConnection object that you can use with a NetStream object to invoke commands on a remote application server or to play back streaming video (FLV) files locally or from a server.
NetConnectionChannel — Class in package mx.messaging.channels
 | This NetConnectionChannel provides the basic NetConnection support for messaging.
NetConnectionChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.NetConnectionChannel
 | Creates a new NetConnectionChannel instance.
netStatus — Event in class flash.net.NetConnection
 | Dispatched when a NetConnection object is reporting its status or error condition.
netStatus — Event in class flash.net.NetStream
 | Dispatched when a NetStream object is reporting its status or error condition.
netStatus — Event in class flash.net.SharedObject
 | Dispatched when a SharedObject instance is reporting its status or error condition.
NET_STATUS — Constant static property in class flash.events.NetStatusEvent
 | Defines the value of the type property of a netStatus event object.
NetStatusEvent — Class in package flash.events
 | Flash® Player dispatches NetStatusEvent objects when a NetConnection, NetStream, or SharedObject object reports its status.
NetStatusEvent(type:String, bubbles:Boolean, cancelable:Boolean, info:Object) — Constructor in class flash.events.NetStatusEvent
 | Creates an Event object that contains information about netStatus events.
NetStream — Class in package flash.net
 | The NetStream class opens a one-way streaming connection between Flash Player and a server, such as Adobe's Macromedia Flash Media Server 2 or Adobe Flex, or between Flash Player and the local file system through a connection made available by a NetConnection object.
NetStream(connection:flash.net:NetConnection) — Constructor in class flash.net.NetStream
 | Creates a stream that can be used for playing FLV files through the specified NetConnection object.
NEVER — Constant static property in class flash.display.PixelSnapping
 | A constant value used in the pixelSnapping property of a Bitmap object to specify that no pixel snapping occurs.
new — Operator
 | Instantiates a class instance.
NEW_COLUMN — Constant static property in class mx.events.DataGridEventReason
 | Specifies that the user moved focus to a new column in the same row.
newDate — Property in class mx.events.CalendarLayoutChangeEvent
 | The selected date of the control.
newIndex — Property in class mx.events.IndexChangedEvent
 | The zero-based index after the change.
newInstance() — Method in class mx.core.ClassFactory
 | Creates a new instance of the generator class, with the properties specified by properties.
newInstance() — Method in interface mx.core.IFactory
 | Creates an instance of some class (determined by the class that implements IFactory).
NEW_ROW — Constant static property in class mx.events.DataGridEventReason
 | Specifies that the user moved focus to a new row.
NEW_ROW — Constant static property in class mx.events.ListEventReason
 | Specifies that the user moved focus to a new row in the control.
newState — Property in class mx.events.StateChangeEvent
 | The name of the view state that the component is entering.
newValue — Property in class mx.events.PropertyChangeEvent
 | The value of the property after the change.
newVersion — Property in interface mx.data.IChangeObject
 | Remote destinations current version of the item.
nextFrame() — Method in class flash.display.MovieClip
 | Sends the playhead to the next frame and stops it.
NEXT_MONTH — Constant static property in class mx.events.DateChooserEventDetail
 | Indicates that the user scrolled the calendar to the next month.
nextMonthDisabledSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next month arrow when the arrow is disabled.
nextMonthDownSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next month arrow when the user presses the mouse button down on the arrow.
nextMonthOverSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next month arrow when the user moves the mouse pointer over the arrow.
nextMonthUpSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next month arrow when the mouse pointer is not over the arrow.
nextName(index:int) — Method in class flash.utils.Proxy
 | Allows enumeration of the proxied object's properties by index number to retrieve property names.
nextName(index:int) — Method in class mx.utils.ObjectProxy
 | This is an internal function that must be implemented by a subclass of flash.utils.Proxy.
nextNameIndex(index:int) — Method in class flash.utils.Proxy
 | Allows enumeration of the proxied object's properties by index number.
nextNameIndex(index:int) — Method in class mx.utils.ObjectProxy
 | This is an internal function that must be implemented by a subclass of flash.utils.Proxy.
nextPage() — Method in class mx.printing.PrintDataGrid
 | Puts the next set of data rows in view; that is, it sets the PrintDataGrid verticalScrollPosition property to equal verticalScrollPosition + (number of scrollable rows).
nextScene() — Method in class flash.display.MovieClip
 | Moves the playhead to the next scene of the MovieClip instance.
nextSibling — Property in class flash.xml.XMLNode
 | An XMLNode value that references the next sibling in the parent node's child list.
nextTabIndex — Property in class mx.managers.FocusManager
 | The next unique tab index to use in this tab loop.
nextTabIndex — Property in interface mx.managers.IFocusManager
 | The next unique tab index to use in this tab loop.
nextValue(index:int) — Method in class flash.utils.Proxy
 | Allows enumeration of the proxied object's properties by index number to retrieve property values.
nextValue — Property in class mx.controls.NumericStepper
 | The value that is one step larger than the current value property and not greater than the maximum property value.
nextValue(index:int) — Method in class mx.utils.ObjectProxy
 | This is an internal function that must be implemented by a subclass of flash.utils.Proxy.
NEXT_YEAR — Constant static property in class mx.events.DateChooserEventDetail
 | Indicates that the user scrolled the calendar to the next year.
nextYearDisabledSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next year arrow when the arrow is disabled.
nextYearDownSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next Year arrow when the user presses the mouse button down on the arrow.
nextYearOverSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next Year arrow when the user moves the mouse pointer over the arrow.
nextYearUpSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the next Year arrow when the mouse pointer is not over the arrow.
NO — Constant static property in class mx.controls.Alert
 | Value that enables a No button on the Alert control when passed as the flags parameter of the show() method.
noAutoLabeling — Property in class flash.accessibility.AccessibilityProperties
 | If true, disables the Flash Player default auto-labeling system.
NO_BITRATE_MATCH — Constant static property in class mx.controls.videoClasses.VideoError
 | No bitrate match.
NO_BORDER — Constant static property in class flash.display.StageScaleMode
 | Specifies that the entire Flash application fill the specified area, without distortion but possibly with some cropping, while maintaining the original aspect ratio of the application.
NoChannelAvailableError — Class in package mx.messaging.errors
 | This error is thrown when no Channel is available to send messages.
NoChannelAvailableError(msg:String) — Constructor in class mx.messaging.errors.NoChannelAvailableError
 | Constructs a new instance of the NoChannelAvailableError with the specified message.
NO_CONNECTION — Constant static property in class mx.controls.videoClasses.VideoError
 | Unable to make connection to server or to find FLV on server.
NO_CUE_POINT_MATCH — Constant static property in class mx.controls.videoClasses.VideoError
 | No matching cue point found.
NO_CURSOR — Constant static property in class mx.managers.CursorManager
 | Constant that is the value of currentCursorID property when there is no cursor managed by the CursorManager and therefore the system cursor is being displayed.
NoDataAvailableError — Class in package mx.data.errors
 | This error is thrown when data requested is not local.
NoDataAvailableError(msg:String) — Constructor in class mx.data.errors.NoDataAvailableError
 | Constructs a new instance of the error with the specified message.
nodeKind() — Method in class XML
 | Specifies the type of node: text, comment, processing-instruction, attribute, or element.
nodeName — Property in class flash.xml.XMLNode
 | A string representing the node name of the XMLNode object.
nodeType — Property in class flash.xml.XMLNode
 | A nodeType constant value, either XMLNodeType.ELEMENT_NODE for an XML element or XMLNodeType.TEXT_NODE for a text node.
nodeValue — Property in class flash.xml.XMLNode
 | The node value of the XMLDocument object.
noExpressionError — Property in class mx.validators.RegExpValidator
 | Error message when there is no regular expression specifed.
noise(randomSeed:int, low:uint, high:uint, channelOptions:uint, grayScale:Boolean) — Method in class flash.display.BitmapData
 | Fills an image with pixels representing random noise.
noLabel — Static property in class mx.controls.Alert
 | The label for the No button.
noMatchError — Property in class mx.validators.RegExpValidator
 | Error message when there are no matches to the regular expression.
NONE — Constant static property in class flash.display.CapsStyle
 | Used to specify no caps in the caps parameter of the flash.display.Graphics.lineStyle() method.
NONE — Constant static property in class flash.display.LineScaleMode
 | With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line never scales.
NONE — Constant static property in class flash.text.GridFitType
 | Doesn't set grid fitting.
NONE — Constant static property in class flash.text.TextFieldAutoSize
 | Specifies that no resizing is to occur.
NONE — Constant static property in class mx.charts.chartClasses.ChartState
 | No state.
NONE — Constant static property in class mx.core.ContainerCreationPolicy
 | Do not create any children.
NONE — Constant static property in class mx.formatters.NumberBaseRoundType
 | Perform no rounding.
NONE — Constant static property in class mx.managers.DragManager
 | Constant that specifies that the type of drag action is "none".
NONE — Constant static property in class mx.printing.FlexPrintJobScaleType
 | Does not scale the output.
nonInheritingStyles — Property in class mx.core.UIComponent
 | The beginning of this component's chain of non-inheriting styles.
nonInheritingStyles — Property in class mx.core.UITextField
 | The beginning of this UITextField's chain of non-inheriting styles.
nonInheritingStyles — Property in interface mx.styles.IStyleClient
 | An object containing the noninheritable styles for this component.
NONMODAL — Constant static property in class mx.controls.Alert
 | Value that makes an Alert nonmodal when passed as the flags parameter of the show() method.
noNumError — Property in class mx.validators.CreditCardValidator
 | Error message when the cardNumber field is empty.
NORMAL — Constant static property in class flash.display.BlendMode
 | The display object appears in front of the background.
NORMAL — Constant static property in class flash.display.LineScaleMode
 | With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line always scales when the object is scaled (the default).
NORMAL — Constant static property in class flash.text.AntiAliasType
 | Sets anti-aliasing to the anti-aliasing that is used in Flash Player 7 and earlier.
normalize() — Method in class XML
 | For the XML object and all descendant XML objects, merges adjacent text nodes and eliminates empty text nodes.
normalize() — Method in class XMLList
 | Merges adjacent text nodes and eliminates empty text nodes for each of the following: all text nodes in the XMLList, all the XML objects contained in the XMLList, and the descendants of all the XML objects in the XMLList.
normalize(thickness:Number) — Method in class flash.geom.Point
 | Scales the line segment between (0,0) and the current point to a set length.
NO_SCALE — Constant static property in class flash.display.StageScaleMode
 | Specifies that the size of the Flash application be fixed, so that it remains unchanged even as the size of the player window changes.
NOT_A_COLOR — Constant static property in class mx.styles.StyleManager
 | The getColorName() method returns this value if the passed-in String is not a legitimate color name.
notifiers — Property in class mx.utils.ObjectProxy
 | A hashmap of property change notifiers that this proxy is listening for changes from; the key of the map is the property name.
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | Propagates style changes to the children of this component.
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean) — Method in class mx.core.UIComponent
 | Propagate style changes to the children.
notifyStyleChangeInChildren(styleProp:String, recursive:Boolean) — Method in interface mx.styles.IStyleClient
 | Propagates style changes to the children of this component.
noTypeError — Property in class mx.validators.CreditCardValidator
 | Error message when the cardType field is blank.
null — Statement
 | A special value that can be assigned to variables or returned by a function if no data was provided.
Null — Special Type
 | A special data type that represents the lack of a value.
number — Property in class mx.charts.series.items.PieSeriesItem
 | The value this wedge represents converted into screen coordinates
Number — Final class in Top Level
 | A data type representing an IEEE-754 double-precision floating-point number.
Number(expression) — Package function in Top Level
 | Converts a given value to a Number value.
Number(num:Object) — Constructor in class Number
 | Creates a Number object with the specified value.
NumberBase — Class in package mx.formatters
 | The NumberBase class is a utility class that contains general number formatting capabilities, including rounding, precision, thousands formatting, and negative sign formatting.
NumberBase(decimalSeparatorFrom:String, thousandsSeparatorFrom:String, decimalSeparatorTo:String, thousandsSeparatorTo:String) — Constructor in class mx.formatters.NumberBase
 | Constructor.
NumberBaseRoundType — Final class in package mx.formatters
 | The NumberBaseRoundType class defines the constant values for formatter properties that specify a type of rounding.
NumberFormatter — Class in package mx.formatters
 | The NumberFormatter class formats a valid number by adjusting the decimal rounding and precision, the thousands separator, and the negative sign.
NumberFormatter() — Constructor in class mx.formatters.NumberFormatter
 | Constructor.
NumberValidator — Class in package mx.validators
 | The NumberValidator class ensures that a String represents a valid number.
NumberValidator() — Constructor in class mx.validators.NumberValidator
 | Constructor.
numChildren — Property in class flash.display.DisplayObjectContainer
 | Returns the number of children of this object.
numChildren — Property in class flash.display.Stage
 | Returns the number of children of this object.
numChildren — Property in class mx.core.Container
 | Number of child components in this container.
numChildren — Property in interface mx.core.IChildList
 | The number of children in this child list.
numChildren — Property in class mx.managers.SystemManager
 | The number of non-floating windows.
numDividers — Property in class mx.containers.DividedBox
 | The number of dividers.
numeric — Property in class mx.collections.SortField
 | Specifies that if the field being sorted contains numeric (number/int/uint) values, or string representations of numeric values, the comparitor use a numeric comparison.
NUMERIC — Constant static property in class Array
 | Specifies numeric (instead of character-string) sorting for the Array class sorting methods.
NumericAxis — Class in package mx.charts.chartClasses
 | The NumericAxis class acts as a common base class for axis types representing a continuous range of values between a defined minimum and maximum.
NumericAxis() — Constructor in class mx.charts.chartClasses.NumericAxis
 | Constructor.
numericCompare(a:Number, b:Number) — Static method in class mx.utils.ObjectUtil
 | Compares two numberic values.
NumericStepper — Class in package mx.controls
 | The NumericStepper control lets the user select a number from an ordered set.
NumericStepper() — Constructor in class mx.controls.NumericStepper
 | Constructor.
NumericStepperDownSkin — Class in package mx.skins.halo
 | The skin for all the states of the down button in a NumericStepper.
NumericStepperDownSkin() — Constructor in class mx.skins.halo.NumericStepperDownSkin
 | Constructor.
NumericStepperEvent — Class in package mx.events
 | Represents events that are specific to the NumericStepper control.
NumericStepperEvent(type:String, bubbles:Boolean, cancelable:Boolean, value:Number) — Constructor in class mx.events.NumericStepperEvent
 | Constructor.
NumericStepperUpSkin — Class in package mx.skins.halo
 | The skin for all the states of the up button in a NumericStepper.
NumericStepperUpSkin() — Constructor in class mx.skins.halo.NumericStepperUpSkin
 | Constructor.
numFrames — Property in class flash.display.Scene
 | The number of frames in the scene.
numLines — Property in class flash.text.TextField
 | Defines the number of text lines in a multiline text field.
numLock — Static property in class flash.ui.Keyboard
 | Specifies whether the Num Lock key is activated (true) or not (false).
numModalWindows — Property in interface mx.managers.ISystemManager
 | The number of modal windows.
numModalWindows — Property in class mx.managers.SystemManager
 | Number of modal windows.
NUM_PAD — Constant static property in class flash.ui.KeyLocation
 | Indicates the key activation originated on the numeric keypad or with a virtual key corresponding to the numeric keypad.
NUMPAD_0 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 0 key on the number pad (96).
NUMPAD_1 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 1 key on the number pad (97).
NUMPAD_2 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 2 key on the number pad (98).
NUMPAD_3 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 3 key on the number pad (99).
NUMPAD_4 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 4 key on the number pad (100).
NUMPAD_5 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 5 key on the number pad (101).
NUMPAD_6 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 6 key on the number pad (102).
NUMPAD_7 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 7 key on the number pad (103).
NUMPAD_8 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 8 key on the number pad (104).
NUMPAD_9 — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the number 9 key on the number pad (105).
NUMPAD_ADD — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the addition key on the number pad (107).
NUMPAD_DECIMAL — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the decimal key on the number pad (110).
NUMPAD_DIVIDE — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the division key on the number pad (111).
NUMPAD_ENTER — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Enter key on the number pad (108).
NUMPAD_MULTIPLY — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the multiplication key on the number pad (106).
NUMPAD_SUBTRACT — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the subtraction key on the number pad (109).
numRadioButtons — Property in class mx.controls.RadioButtonGroup
 | The number of RadioButtons that belong to this RadioButtonGroup.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


O Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
O Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
object — Property in class mx.utils.ObjectProxy
 | The object being proxied.
Object — Dynamic class in Top Level
 | The Object class is at the root of the ActionScript class hierarchy.
Object(value) — Package function in Top Level
 | Every value in ActionScript 3.0 is an object, which means that calling Object() on a value returns that value.
Object() — Constructor in class Object
 | Creates an Object object and stores a reference to the object's constructor method in the object's constructor property.
objectEncoding — Property in class flash.net.NetConnection
 | The object encoding (AMF version) for this NetConnection instance.
objectEncoding — Property in class flash.net.NetStream
 | The object encoding (AMF version) for this NetStream object.
objectEncoding — Property in class flash.net.SharedObject
 | The object encoding (AMF version) for this shared object.
objectEncoding — Property in class flash.net.Socket
 | Controls the version of AMF used when writing or reading an object.
objectEncoding — Property in class flash.net.URLStream
 | Controls the version of Action Message Format (AMF) used when writing or reading an object.
objectEncoding — Property in class flash.utils.ByteArray
 | Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading from, a ByteArray instance.
objectEncoding — Property in interface flash.utils.IDataInput
 | Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading binary data.
objectEncoding — Property in interface flash.utils.IDataOutput
 | Used to determine whether the ActionScript 3.0, ActionScript 2.0, or ActionScript 1.0 format should be used when writing to, or reading binary data.
ObjectEncoding — Final class in package flash.net
 | The ObjectEncoding class allows classes that serialize objects (such as NetStream, NetConnection, SharedObject, and ByteArray) to work with prior versions of ActionScript.
objectID — Static property in class flash.external.ExternalInterface
 | Returns the id attribute of the <object> tag in Internet Explorer, or the name attribute of the <embed> tag in Netscape.
ObjectInstance — Class in package mx.messaging.management
 | Client representation of an object name instance for server-side management controls.
ObjectInstance() — Constructor in class mx.messaging.management.ObjectInstance
 | Creates a new instance of an empty ObjectInstance.
objectName — Property in class mx.messaging.management.ObjectInstance
 | The object name.
ObjectName — Class in package mx.messaging.management
 | Client representation of the name for server-side management controls.
ObjectName() — Constructor in class mx.messaging.management.ObjectName
 | Creates a new instance of an empty ObjectName.
object_proxy — Statement
 | Defines methods of the ObjectProxy class.
ObjectProxy — Dynamic class in package mx.utils
 | This class provides the ability to track changes to an item managed by this proxy.
ObjectProxy(item:Object, uid:String, proxyDepth:int) — Constructor in class mx.utils.ObjectProxy
 | Initializes this proxy with the specified object, id and proxy depth.
ObjectUtil — Class in package mx.utils
 | The ObjectUtil class is an all-static class with methods for working with Objects within Flex.
OFF — Constant static property in class mx.core.ScrollPolicy
 | Never show the scrollbar.
OFF — Constant static property in class mx.core.UIComponentCachePolicy
 | Specifies that the Flex framework should never attempt to cache the object as a bitmap.
offset(dx:Number, dy:Number) — Method in class flash.geom.Point
 | Offsets the Point object by the specified amount.
offset(dx:Number, dy:Number) — Method in class flash.geom.Rectangle
 | Adjusts the location of the Rectangle object, as determined by its top-left corner, by the specified amounts.
offset — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | Specifies how far to offset the center of the elements from the center of the available space, relative to the category width.
offset — Property in interface mx.charts.chartClasses.IBar
 | Specifies how far to offset the center of the items from the center of the available space, relative the category size.
offset — Property in interface mx.charts.chartClasses.IColumn
 | Specifies how far to offset the center of the items from the center of the available space, relative the category size.
offset — Property in class mx.charts.effects.SeriesEffect
 | Specifies the amount of time, in milliseconds, that Flex delays the effect.
offset — Property in class mx.charts.effects.effectClasses.SeriesEffectInstance
 | Specifies the amount of time, in milliseconds, that Flex delays the effect.
offset — Property in class mx.charts.series.BarSeries
 | Specifies how far to offset the center of the bars from the center of the available space, relative the category width.
offset — Property in class mx.charts.series.BarSet
 | Specifies how far to offset the center of the bars from the center of the available space, relative the category width.
offset — Property in class mx.charts.series.ColumnSeries
 | Specifies how far to offset the center of the columns from the center of the available space, relative to the category width.
offset — Property in class mx.charts.series.ColumnSet
 | Specifies how far to offset the center of the columns from the center of the available space, relative to the category width.
offset — Property in class mx.controls.listClasses.ListBaseSeekPending
 | The offset from the bookmark that was the target of the seek operation.
offsetPoint(point:flash.geom:Point) — Method in class flash.geom.Rectangle
 | Adjusts the location of the Rectangle object using a Point object as a parameter.
offsetX — Property in class mx.graphics.BitmapFill
 | How far the bitmap is horizontally offset from the origin.
offsetY — Property in class mx.graphics.BitmapFill
 | How far the bitmap is vertically offset from the origin.
OK — Constant static property in class mx.controls.Alert
 | Value that enables an OK button on the Alert control when passed as the flags parameter of the show() method.
okLabel — Static property in class mx.controls.Alert
 | The label for the OK button.
oldHeight — Property in class mx.events.ResizeEvent
 | The previous height of the object, in pixels.
oldIndex — Property in class mx.events.IndexChangedEvent
 | The zero-based index before the change.
oldLocation — Property in class mx.events.CollectionEvent
 | When the kind value is CollectionEventKind.MOVE, this property is the zero-based index in the target collection of the previous location of the item(s) specified by the items property.
oldState — Property in class mx.events.StateChangeEvent
 | The name of the view state that the component is exiting.
oldValue — Property in class mx.events.PropertyChangeEvent
 | The value of the property before the change.
oldWidth — Property in class mx.events.ResizeEvent
 | The previous width of the object, in pixels.
oldX — Property in class mx.events.MoveEvent
 | The previous x coordinate of the object, in pixels.
oldY — Property in class mx.controls.listClasses.ListRowInfo
 | The last Y value for the row.
oldY — Property in class mx.events.MoveEvent
 | The previous y coordinate of the object, in pixels.
ON — Constant static property in class mx.core.ScrollPolicy
 | Always show the scrollbar.
ON — Constant static property in class mx.core.UIComponentCachePolicy
 | Specifies that the Flex framework should always cache the object as a bitmap.
onCuePoint — Event in class flash.net.NetStream
 | Invoked when an embedded cue point is reached while playing an FLV file.
onEffectEnd(childEffect:mx.effects:EffectInstance) — Method in class mx.effects.effectClasses.CompositeEffectInstance
 | Called each time one of the child effects has finished playing.
onEffectEnd(childEffect:mx.effects:EffectInstance) — Method in class mx.effects.effectClasses.ParallelInstance
 | Each time a child effect of SequenceInstance or ParallelInstance finishes, Flex calls the onEffectEnd() method.
onEffectEnd(childEffect:mx.effects:EffectInstance) — Method in class mx.effects.effectClasses.SequenceInstance
 | Each time a child effect of SequenceInstance finishes, Flex calls the onEffectEnd() method.
onMetaData — Event in class flash.net.NetStream
 | Dispatched when Flash Player receives descriptive information embedded in the FLV file being played.
onMoveTweenEnd(value:Object) — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Callback method that is called when the x and y position of the mask should be updated by the effect for the last time.
onMoveTweenUpdate(value:Object) — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Callback method that is called when the x and y position of the mask should be updated by the effect.
onPlayStatus — Event in class flash.net.NetStream
 | Dispatched when a NetStream object has completely played a stream.
onScaleTweenEnd(value:Object) — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect for the last time.
onScaleTweenUpdate(value:Object) — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Callback method that is called when the scaleX and scaleY properties of the mask should be updated by the effect.
onTweenEnd(value:Object) — Method in class mx.effects.effectClasses.CompositeEffectInstance
 | Used internally to keep track of the value of the playheadTime property.
onTweenEnd(value:Object) — Method in class mx.effects.effectClasses.TweenEffectInstance
 | Callback method that is called when the target should be updated by the effect for the last time.
onTweenUpdate(value:Object) — Method in class mx.effects.effectClasses.CompositeEffectInstance
 | Used internally to keep track of the value of the playheadTime property.
onTweenUpdate(value:Object) — Method in class mx.effects.effectClasses.TweenEffectInstance
 | Callback method that is called when the target should be updated by the effect.
opaqueBackground — Property in class flash.display.DisplayObject
 | Specifies whether the display object is opaque with a certain background color.
opaqueBackground — Property in interface mx.core.IUIComponent
 | Specifies whether the display object is opaque with a certain background color.
open — Event in class flash.display.LoaderInfo
 | Dispatched when a load operation starts.
open — Event in class flash.media.Sound
 | Dispatched when a load operation starts.
open — Event in class flash.net.FileReference
 | Dispatched when an upload or download operation starts.
open — Event in class flash.net.URLLoader
 | Dispatched when the download operation commences following a call to the URLLoader.load() method.
open — Event in class flash.net.URLStream
 | Dispatched when a load operation starts.
open — Property in class mx.charts.series.items.HLOCSeriesItem
 | The open value of this item converted into screen coordinates.
open — Event in class mx.controls.ColorPicker
 | Dispatched when the color swatch panel opens.
open() — Method in class mx.controls.ColorPicker
 | Displays the drop-down SwatchPanel object that shows colors that users can select.
open — Event in class mx.controls.ComboBox
 | Dispatched when the user clicks the drop-down button to display the drop-down list.
open() — Method in class mx.controls.ComboBox
 | Displays the drop-down list.
open — Event in class mx.controls.DateField
 | Dispatched when a user selects the field to open the drop-down list.
open() — Method in class mx.controls.DateField
 | Opens the DateChooser control.
open — Event in class mx.controls.PopUpButton
 | Dispatched when the specified UIComponent opens.
open() — Method in class mx.controls.PopUpButton
 | Opens the UIComponent object specified by the popUp property.
open — Event in class mx.controls.SWFLoader
 | Dispatched when a network operation starts.
open — Property in class mx.controls.treeClasses.TreeListData
 | Contains true if the node is open.
OPEN — Constant static property in class flash.events.Event
 | Defines the value of the type property of an open event object.
OPEN — Constant static property in class mx.events.DropdownEvent
 | The DropdownEvent.OPEN constant defines the value of the type property of the event object for a open event.
openAlways — Property in class mx.controls.PopUpButton
 | If true, specifies to pop up the popUp when you click the main button.
openDuration — Style in class mx.containers.Accordion
 | Duration, in milliseconds, of the animation from one child to another.
openDuration — Style in class mx.controls.ColorPicker
 | Length of an open transition, in milliseconds.
openDuration — Style in class mx.controls.ComboBox
 | Length of the transition when the drop-down list opens, in milliseconds.
openDuration — Style in class mx.controls.Menu
 | The duration of the menu or submenu opening transition, in milliseconds.
openDuration — Style in class mx.controls.PopUpButton
 | Length of an open transition, in milliseconds.
openDuration — Style in class mx.controls.Tree
 | Length of an open or close transition, in milliseconds.
openEasingFunction — Style in class mx.containers.Accordion
 | Tweening function used by the animation from one child to another.
openEasingFunction — Style in class mx.controls.ColorPicker
 | Easing function to control component tweening.
openEasingFunction — Style in class mx.controls.ComboBox
 | An easing function to control the open transition.
openEasingFunction — Style in class mx.controls.PopUpButton
 | Easing function to control component opening tween.
openEasingFunction — Style in class mx.controls.Tree
 | Easing function to control component tweening.
openField — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | Specifies the field of the data provider that determines the y-axis location of the opening value of the element.
openFilter — Property in class mx.charts.series.items.HLOCSeriesItem
 | The open value of this item, filtered against the vertical axis of the containing chart.
opening — Property in class mx.events.TreeEvent
 | Used for an ITEM_OPENING type events only.
openItems — Property in class mx.controls.Tree
 | The items that have been opened or set opened.
openNumber — Property in class mx.charts.series.items.HLOCSeriesItem
 | The open value of this item, converted to a number by the vertical axis of the containing chart.
openTickLength — Style in class mx.charts.series.HLOCSeries
 | Specifies the length, in pixels, for the open tick mark if an opening value is specified.
openTickStroke — Style in class mx.charts.series.HLOCSeries
 | Specifies the stroke to use for the open tick mark if an opening value is specified.
openValue — Property in class mx.charts.series.items.HLOCSeriesItem
 | The open value of this item.
operation — Property in class mx.data.messages.DataMessage
 | Provides access to the operation/command of this DataMessage.
operation — Property in class mx.messaging.messages.CommandMessage
 | Provides access to the operation/command for the CommandMessage.
operation — Property in class mx.messaging.messages.RemotingMessage
 | Provides access to the name of the remote method/operation that should be called.
Operation — Class in package mx.rpc.remoting
 | An Operation used specifically by RemoteObjects.
Operation — Class in package mx.rpc.remoting.mxml
 | The Operation used for RemoteObject when created in an MXML document
Operation — Class in package mx.rpc.soap
 | An Operation used specifically by WebServices.
Operation — Class in package mx.rpc.soap.mxml
 | An Operation used specifically by WebServices.
Operation(remoteObject:mx.rpc:AbstractService, name:String) — Constructor in class mx.rpc.remoting.Operation
 | Creates a new Operation.
Operation(webService:mx.rpc:AbstractService, name:String) — Constructor in class mx.rpc.soap.Operation
 | Creates a new Operation.
Operation(webService:mx.rpc.soap:WebService, name:String) — Constructor in class mx.rpc.soap.mxml.Operation
operations — Property in class mx.messaging.management.MBeanInfo
 | The operations provided by the MBean.
operations — Property in class mx.rpc.AbstractService
 | The Operations array is usually only set by the MXML compiler if you create a service using an MXML tag.
OPTIONS_METHOD — Constant static property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates that the method used for this request should be "options".
orientation — Property in class flash.printing.PrintJob
 | The image orientation for printing.
origin — Property in class mx.charts.chartClasses.PolarTransform
 | The origin of the polar transform.
origin — Property in class mx.charts.series.items.PieSeriesItem
 | The origin, relative to the PieSeries's coordinate system, of this wedge.
originalHeight — Property in class mx.printing.PrintDataGrid
 | The height of PrintDataGrid as set by the user.
originalObject — Property in class mx.data.Conflict
 | Returns the state of the original client object before its properties were changed, as known at the time of the conflict.
originX — Property in class mx.effects.Rotate
 | The x-position of the center point of rotation.
originX — Property in class mx.effects.Zoom
 | Number that represents the x-position of the zoom origin when the effect target is in a container that supports absolute positioning, such as the Canvas container.
originX — Property in class mx.effects.effectClasses.RotateInstance
 | The x-position of the center point of rotation.
originX — Property in class mx.effects.effectClasses.ZoomInstance
 | Number that represents the x-position of the zoom origin, or registration point.
originX — Property in class mx.graphics.BitmapFill
 | The horizontal origin for the bitmap fill.
originY — Property in class mx.effects.Rotate
 | The y-position of the center point of rotation.
originY — Property in class mx.effects.Zoom
 | Number that represents the y-position of the zoom origin when the effect target is in a container that supports absolute positioning, such as the Canvas container.
originY — Property in class mx.effects.effectClasses.RotateInstance
 | The y-position of the center point of rotation.
originY — Property in class mx.effects.effectClasses.ZoomInstance
 | Number that represents the y-position of the zoom origin, or registration point.
originY — Property in class mx.graphics.BitmapFill
 | The vertical origin for the bitmap fill.
os — Static property in class flash.system.Capabilities
 | Specifies the current operating system.
OTHER — Constant static property in class mx.events.DataGridEventReason
 | Specifies that the list control lost focus, was scrolled, or is somehow in a state where editing is not allowed.
OTHER — Constant static property in class mx.events.ListEventReason
 | Specifies that the list control lost focus, was scrolled, or is somehow in a state where editing is not allowed.
otherAxes — Property in class mx.charts.AxisRenderer
 | An Array of axes.
otherAxes — Property in interface mx.charts.chartClasses.IAxisRenderer
 | An Array of axes.
OUTER — Constant static property in class flash.filters.BitmapFilterType
 | Defines the setting that applies a filter to the outer area of an object.
outerRadius — Property in class mx.charts.series.PieSeries
 | The percentage of the total space available to the PieSeries to use when rendering the contents of the series.
outerRadius — Property in class mx.charts.series.items.PieSeriesItem
 | The distance of the outer edge of this wedge from its origin, measured in pixels.
outsideCutoff — Property in class flash.text.CSMSettings
 | The outside cutoff value, below which densities are set to zero.
overIcon — Style in class mx.controls.Button
 | Name of the class to use as the icon when the button is not selected and the mouse is over the control.
OVERLAY — Constant static property in class flash.display.BlendMode
 | Adjusts the color of each pixel based on the darkness of the background.
OVERLAY_CREATED — Constant static property in class mx.events.ChildExistenceChangedEvent
 | The ChildExistenceChangedEvent.OVERLAY_CREATED constant defines the value of the type property of the event object for a overlayCreated event.
override — Statement
 | Specifies that a method replaces an inherited method.
overrides — Property in class mx.states.State
 | The overrides for this view state, as an Array of objects that implement the IOverride interface.
overrides — Property in class mx.styles.CSSStyleDeclaration
 | If the setStyle() method is called on a UIComponent or CSSStyleDeclaration at run time, this object stores the name/value pairs that were set; they override the name/value pairs in the objects produced by the methods specified by the defaultFactory and factory properties.
overSkin — Style in class mx.controls.Button
 | Name of the class to use as the skin for the background and border when the button is not selected and the mouse is over the control.
overSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the mouse is over the control.
overState — Property in class flash.display.SimpleButton
 | Specifies a display object that is used as the visual object for the button over state — the state that the button is in when the mouse is positioned over the button.
owner — Property in class mx.controls.listClasses.BaseListData
 | A reference to the list object that owns this item.
owner — Property in class mx.controls.textClasses.TextRange
 | The control that contains the text.
owner — Property in interface mx.core.IUIComponent
 | Your owner is usually your parent, however If you are a popup subcomponent, your owner will be the component that popped you up.
owner — Property in class mx.core.UIComponent
 | The owner of this UIComponent.
owner — Property in class mx.core.UITextField
 | By default, set to the parent container of this object.
owns(child:flash.display:DisplayObject) — Method in interface mx.core.IUIComponent
 | Returns true if the chain of owner properties points from child to this UIComponent.
owns(child:flash.display:DisplayObject) — Method in class mx.core.UIComponent
 | Returns true if the chain of owner properties points from child to this UIComponent.
owns(child:flash.display:DisplayObject) — Method in class mx.core.UITextField
 | Returns true if the child is parented or owned by this object.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


P Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
P Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
package — Statement
 | Allows you to organize your code into discrete groups that can be imported by other scripts.
packageResources — Static property in class mx.formatters.Formatter
 | A ResourceBundle object containing all symbols from formatters.properties.
PAD — Constant static property in class flash.display.SpreadMethod
 | Specifies that the gradient use the pad spread method.
padding — Property in class mx.charts.CategoryAxis
 | Specifies the padding added to either side of the axis when rendering data on the screen.
padding — Property in class mx.charts.chartClasses.DataDescription
 | The amount of padding, in data units, that the element requires beyond its min/max values to display its full values correctly .
padding — Property in class mx.charts.chartClasses.NumericAxis
 | Specifies padding that Flex adds to the calculated minimum and maximum values for the axis when rendering the values on the screen.
paddingBottom — Style in class mx.charts.chartClasses.ChartBase
 | Specifies the number of pixels between the chart's bottom border and its content area.
paddingBottom — Style in class mx.charts.chartClasses.DataTip
 | Number of pixels between the datatip's bottom border and its content area.
paddingBottom — Style in class mx.containers.Accordion
 | Number of pixels between the container's bottom border and its content area.
paddingBottom — Style in class mx.containers.Box
 | Number of pixels between the container's bottom border and the bottom of its content area.
paddingBottom — Style in class mx.containers.Form
 | Number of pixels between the container's bottom border and the bottom edge of its content area.
paddingBottom — Style in class mx.containers.FormItem
 | Number of pixels between the container's bottom border and the bottom edge of its content area.
paddingBottom — Style in class mx.containers.Panel
 | Number of pixels between the container's lower border and its content area.
paddingBottom — Style in class mx.containers.Tile
 | Number of pixels between the container's bottom border and its content area.
paddingBottom — Style in class mx.containers.ViewStack
 | Number of pixels between the container's bottom border and its content area.
paddingBottom — Style in class mx.controls.Button
 | Number of pixels between the container's bottom border and the bottom of its content area.
paddingBottom — Style in class mx.controls.ColorPicker
 | Bottom padding of SwatchPanel object below the swatch grid.
paddingBottom — Style in class mx.controls.LinkBar
 | Number of pixels between the bottom border and the LinkButton controls.
paddingBottom — Style in class mx.controls.listClasses.ListBase
 | The number of pixels between the bottom of the row and the bottom of the renderer in the row.
paddingBottom — Style in class mx.core.Application
 | Number of pixels between the application's bottom border and its content area.
paddingBottom — Style in class mx.core.Container
 | Number of pixels between the container's bottom border and the bottom of its content area.
paddingLeft — Style in class mx.charts.Legend
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.charts.LegendItem
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.charts.chartClasses.ChartBase
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.charts.chartClasses.DataTip
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.containers.FormHeading
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.Button
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.ColorPicker
 | Left padding of SwatchPanel object to the side of the swatch grid.
paddingLeft — Style in class mx.controls.ComboBox
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.DateField
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.Label
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.NumericStepper
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.ProgressBar
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.TextArea
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.TextInput
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.ToolTip
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.Tree
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.controls.dataGridClasses.DataGridColumn
 | The number of pixels between the container's left border and its content area.
paddingLeft — Style in class mx.controls.listClasses.ListBase
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.core.Container
 | Number of pixels between the container's left border and the left edge of its content area.
paddingLeft — Style in class mx.core.UITextField
 | Number of pixels between the container's left border and the left edge of its content area.
paddingRight — Style in class mx.charts.Legend
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.charts.LegendItem
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.charts.chartClasses.ChartBase
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.charts.chartClasses.DataTip
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.containers.FormHeading
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.containers.FormItem
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.Button
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.ColorPicker
 | Right padding of SwatchPanel object to the side of the swatch grid.
paddingRight — Style in class mx.controls.ComboBox
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.DateField
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.Label
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.NumericStepper
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.ProgressBar
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.TextArea
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.TextInput
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.ToolTip
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.Tree
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.controls.dataGridClasses.DataGridColumn
 | The number of pixels between the container's right border and its content area.
paddingRight — Style in class mx.controls.listClasses.ListBase
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.core.Container
 | Number of pixels between the container's right border and the right edge of its content area.
paddingRight — Style in class mx.core.UITextField
 | Number of pixels between the container's right border and the right edge of its content area.
paddingTop — Style in class mx.charts.chartClasses.ChartBase
 | Specifies the number of pixels between the chart's top border and its content area.
paddingTop — Style in class mx.charts.chartClasses.DataTip
 | Number of pixels between the datatip's top border and its content area.
paddingTop — Style in class mx.containers.Accordion
 | Number of pixels between the container's top border and its content area.
paddingTop — Style in class mx.containers.Box
 | Number of pixels between the container's top border and the top of its content area.
paddingTop — Style in class mx.containers.Form
 | Number of pixels between the container's top border and the top edge of its content area.
paddingTop — Style in class mx.containers.FormHeading
 | Number of pixels above the heading text.
paddingTop — Style in class mx.containers.FormItem
 | Number of pixels between the container's top border and the top edge of its content area.
paddingTop — Style in class mx.containers.Panel
 | Number of pixels between the container's top border and its content area.
paddingTop — Style in class mx.containers.Tile
 | Number of pixels between the container's top border and its content area.
paddingTop — Style in class mx.containers.ViewStack
 | Number of pixels between the container's top border and its content area.
paddingTop — Style in class mx.controls.Button
 | Number of pixels between the container's top border and the top of its content area.
paddingTop — Style in class mx.controls.ColorPicker
 | Top padding of SwatchPanel object above the swatch grid.
paddingTop — Style in class mx.controls.LinkBar
 | Number of pixels between the top border and the LinkButton controls.
paddingTop — Style in class mx.controls.listClasses.ListBase
 | The number of pixels between the top of the row and the top of the renderer in the row.
paddingTop — Style in class mx.core.Application
 | Number of pixels between the application's top border and its content area.
paddingTop — Style in class mx.core.Container
 | Number of pixels between the container's top border and the top of its content area.
pageCount — Property in class mx.data.PageInformation
 | Provides read-only access to the current number of pages in the collection.
pageCount — Property in class mx.data.messages.PagedMessage
 | Provides access to the number of total pages in a sequence based on the current page size.
PagedMessage — Class in package mx.data.messages
 | This messsage provides information about a partial sequence result.
PagedMessage() — Constructor in class mx.data.messages.PagedMessage
 | Creates a new instance of an empty PagedMessage.
PAGE_DOWN — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Page Down key (34).
PAGE_DOWN — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved down by one page.
pageHeight — Property in class flash.printing.PrintJob
 | The height of the actual printable area on the page, in points.
pageHeight — Property in class mx.printing.FlexPrintJob
 | The height of the printable area on the printer page; it does not include any user-set margins.
pageIndex — Property in class mx.data.messages.PagedMessage
 | Provides access to the index of the current page in a sequence.
PageInformation — Final class in package mx.data
 | The PageInformation object provides detailed data about what pages of a collection have been loaded, how many there are, and what the current page size is.
PageInformation(pageSize:int, pageCount:int, loadedPages:Object) — Constructor in class mx.data.PageInformation
PAGE_ITEMS_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation indicates a request for a page of items specified by identities.
PAGE_LEFT — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved left by one page.
PAGE_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation is used to retrieve a page of sequenced content that is delivered across several messages instead of in a single message.
PAGE_RIGHT — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved right by one page.
pageScrollSize — Property in class mx.controls.scrollClasses.ScrollBar
 | Amount to move the scroll thumb when the scroll bar track is pressed, in pixels.
pageSize — Property in class mx.controls.scrollClasses.ScrollBar
 | The number of lines equivalent to one page.
pageSize — Property in class mx.data.DataService
 | Provides access to the current page size setting for all collections.
pageSize — Property in class mx.data.PageInformation
 | Provides read-only access to the current page size for the collection
pageSize — Property in class mx.data.mxml.DataService
 | Provides access to the current page size setting for all collections.
pageTitle — Property in class mx.core.Application
 | Specifies a string that appears in the title bar of the browser.
PAGE_UP — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Page Up key (33).
PAGE_UP — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar has moved up by one page.
pageWidth — Property in class flash.printing.PrintJob
 | The width of the actual printable area on the page, in points.
pageWidth — Property in class mx.printing.FlexPrintJob
 | The width of the printable area on the printer page; it does not include any user-set margins.
pagingEnabled — Property in class mx.data.DataService
 | Indicates if the remote desintation is configured to allow paged requests.
pagingEnabled — Property in class mx.data.mxml.DataService
 | Indicates if the remote desintation is configured to allow paged requests.
paletteMap(sourceBitmapData:flash.display:BitmapData, sourceRect:flash.geom:Rectangle, destPoint:flash.geom:Point, redArray:Array, greenArray:Array, blueArray:Array, alphaArray:Array) — Method in class flash.display.BitmapData
 | Remaps the color channel values in an image that has up to four arrays of color palette data, one for each channel.
pan — Property in class flash.media.SoundTransform
 | The left-to-right panning of the sound, ranging from -1 (full pan left) to 1 (full pan right).
panEasingFunction — Property in class mx.effects.SoundEffect
 | The easing function for the pan effect.
panEasingFunction — Property in class mx.effects.effectClasses.SoundEffectInstance
 | The easing function for the pan effect.
Panel — Class in package mx.containers
 | A Panel container consists of a title bar, a caption, a border, and a content area for its children.
Panel() — Constructor in class mx.containers.Panel
 | Constructor.
panFrom — Property in class mx.effects.SoundEffect
 | Initial pan of the Sound object.
panFrom — Property in class mx.effects.effectClasses.SoundEffectInstance
 | Initial pan of the Sound object.
panTo — Property in class mx.effects.SoundEffect
 | Final pan of the Sound object.
panTo — Property in class mx.effects.effectClasses.SoundEffectInstance
 | Final pan of the Sound object.
paperHeight — Property in class flash.printing.PrintJob
 | The overall paper height, in points.
paperWidth — Property in class flash.printing.PrintJob
 | The overall paper width, in points.
Parallel — Class in package mx.effects
 | The Parallel effect plays multiple child effects at the same time.
Parallel(target:Object) — Constructor in class mx.effects.Parallel
 | Constructor.
ParallelInstance — Class in package mx.effects.effectClasses
 | The ParallelInstance class implements the instance class for the Parallel effect.
ParallelInstance(target:Object) — Constructor in class mx.effects.effectClasses.ParallelInstance
 | Constructor.
parameters — Property in class flash.display.LoaderInfo
 | An object that contains name-value pairs that represent the parameters provided to the loaded SWF file.
parameters — Property in class mx.core.Application
 | The parameters property returns an Object containing name-value pairs representing the parameters provided to this Application.
parameters — Static property in class mx.messaging.config.LoaderConfig
 | If the LoaderConfig has been initialized, this should represent the top-level MovieClip's parameters.
parent() — Method in class XML
 | Returns the parent of the XML object.
parent() — Method in class XMLList
 | Returns the parent of the XMLList object if all items in the XMLList object have the same parent.
parent — Property in class flash.display.DisplayObject
 | Indicates the DisplayObjectContainer object that contains this display object.
parent — Property in interface mx.core.IFlexDisplayObject
 | The parent of this object.
parent — Property in class mx.core.UIComponent
 | The parent container or component for this component.
parent — Property in class mx.core.UITextField
 | The parent container or component for this component.
PARENT — Constant static property in class mx.managers.PopUpManagerChildList
 | Indicates that the popup is placed in whatever child list the parent component is in.
parentAllowsChild — Property in class flash.display.LoaderInfo
 | Expresses the trust relationship from Loader (parent) to the content (child).
parentApplication — Property in class mx.core.UIComponent
 | A reference to the Application object that contains this UIComponent instance.
parentChanged(p:flash.display:DisplayObjectContainer) — Method in interface mx.core.IUIComponent
 | Called by Flex when a UIComponent object is added to or removed from a parent.
parentChanged(p:flash.display:DisplayObjectContainer) — Method in class mx.core.UIComponent
 | Called by Flex when a UIComponent object is added to or removed from a parent.
parentChanged(p:flash.display:DisplayObjectContainer) — Method in class mx.core.UITextField
 | This function is called when a UITextField object is assigned a parent.
parentDocument — Property in class mx.core.UIComponent
 | A reference to the parent document object for this UIComponent.
parentDomain — Property in class flash.system.ApplicationDomain
 | Gets the parent domain of this application domain.
parentMenu — Property in class mx.controls.Menu
 | The parent menu in a hierarchical chain of menus, where the current menu is a submenu of the parent.
parentMessageId — Property in class mx.data.messages.DataAssociationMessage
 | If the association involves a parent that is being created in the same message batch, the server will use this message id to locate the parent instead of relying on the identity provided by the client (the identity may be changed by the server)
parentNode — Property in class flash.xml.XMLNode
 | An XMLNode value that references the parent node of the specified XML object, or returns null if the node has no parent.
parentPropertyName — Property in class mx.data.messages.DataAssociationMessage
 | The property name by which the parent references the child.
parse(date:String) — Static method in class Date
 | Converts a string representing a date into a number equaling the number of milliseconds elapsed since January 1, 1970, UTC.
parseCSS(CSSText:String) — Method in class flash.text.StyleSheet
 | Parses the CSS in CSSText and loads the style sheet with it.
parseDateString(str:String) — Static method in class mx.formatters.DateFormatter
 | Converts a date that is formatted as a String into a Date object.
parseFloat(str) — Package function in Top Level
 | Converts a string to a floating-point number.
parseFunction — Property in class mx.charts.DateTimeAxis
 | Specifies a method that customizes the value of the data points.
parseFunction — Property in class mx.charts.chartClasses.NumericAxis
 | Specify a parseFunction to customize how the values rendered by your chart are converted into numeric values.
parseFunction — Property in class mx.controls.DateField
 | Function used to parse the date entered as text in the text field area of the DateField control and return a Date object to the control.
parseInt(str, radix) — Package function in Top Level
 | Converts a string to an integer.
parseNumberString(str:String) — Method in class mx.formatters.NumberBase
 | Extracts a number from a formatted String.
parseXML(source:String) — Method in class flash.xml.XMLDocument
 | Parses the XML text specified in the value parameter and populates the specified XMLDocument object with the resulting XML tree.
pattern — Property in class mx.messaging.management.ObjectName
 | Indicates if the object name is a pattern.
pause() — Method in class flash.net.NetStream
 | Pauses playback of a video stream.
pause() — Method in class mx.controls.VideoDisplay
 | Pauses playback without moving the playhead.
pause() — Method in class mx.effects.Effect
 | Pauses the effect until you call the resume() method.
pause() — Method in class mx.effects.EffectInstance
 | Pauses the effect until you call the resume() method.
pause() — Method in class mx.effects.Tween
 | Pauses the effect until you call the resume() method.
pause() — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Pauses the effect until you call the resume() method.
Pause — Class in package mx.effects
 | The Pause effect is useful when sequencing effects.
Pause(target:Object) — Constructor in class mx.effects.Pause
 | Constructor.
PAUSED — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property when an FLV file is loaded, but play is paused.
PauseInstance — Class in package mx.effects.effectClasses
 | The PauseInstance class implements the instance class for the Pause effect.
PauseInstance(target:Object) — Constructor in class mx.effects.effectClasses.PauseInstance
 | Constructor.
PENDING — Constant static property in class flash.net.SharedObjectFlushStatus
 | Indicates that the user is being prompted to increase disk space for the shared object before the flush can occur.
percentComplete — Property in class mx.controls.ProgressBar
 | Percentage of process that is completed.The range is 0 to 100.
percentFormat — Property in class mx.preloaders.DownloadProgressBar
 | The TextFormat of the TextField component for displaying the percent.
percentHeight — Property in interface mx.core.IUIComponent
 | Number that specifies the height of a component as a percentage of its parent's size.
percentHeight — Property in class mx.core.UIComponent
 | Number that specifies the height of a component as a percentage of its parent's size.
percentHeight — Property in class mx.core.UITextField
 | Number that specifies the height of a component as a percentage of its parent's size.
percentLoaded — Property in class mx.controls.SWFLoader
 | Percentage of the image or SWF file already loaded.
percentRect — Property in class mx.preloaders.DownloadProgressBar
 | The dimensions of the TextField component for displaying the percent.
percentValue — Property in class mx.charts.series.items.PieSeriesItem
 | The percentage this value represents of the total pie.
percentWidth — Property in interface mx.core.IUIComponent
 | Number that specifies the width of a component as a percentage of its parent's size.
percentWidth — Property in class mx.core.UIComponent
 | Number that specifies the width of a component as a percentage of its parent's size.
percentWidth — Property in class mx.core.UITextField
 | Number that specifies the width of a component as a percentage of its parent's size.
perlinNoise(baseX:Number, baseY:Number, numOctaves:uint, randomSeed:int, stitch:Boolean, fractalNoise:Boolean, channelOptions:uint, grayScale:Boolean, offsets:Array) — Method in class flash.display.BitmapData
 | Generates a Perlin noise image.
perWedgeExplodeRadius — Property in class mx.charts.series.PieSeries
 | An Array of numbers from 0 to 1, specifying how far each wedge of the pie series should be exploded from the center of the chart as a percentage of the total radius.
PhoneFormatter — Class in package mx.formatters
 | The PhoneFormatter class formats a valid number into a phone number format, including international configurations.
PhoneFormatter() — Constructor in class mx.formatters.PhoneFormatter
 | Constructor.
PhoneNumberValidator — Class in package mx.validators
 | The PhoneNumberValidator class validates that a string is a valid phone number.
PhoneNumberValidator() — Constructor in class mx.validators.PhoneNumberValidator
 | Constructor.
PI — Constant static property in class Math
 | A mathematical constant for the ratio of the circumference of a circle to its diameter, expressed as pi, with a value of 3.141592653589793.
PieChart — Class in package mx.charts
 | The PieChart control represents a data series as a standard pie chart.
PieChart() — Constructor in class mx.charts.PieChart
 | Constructor.
PieSeries — Class in package mx.charts.series
 | The PieSeries class defines the data series for a PieChart control.
PieSeries() — Constructor in class mx.charts.series.PieSeries
 | Constructor.
PieSeriesItem — Class in package mx.charts.series.items
 | Represents the information required to render a single wedge as part of a PieSeries.
PieSeriesItem(element:mx.charts.series:PieSeries, data:Object, index:uint) — Constructor in class mx.charts.series.items.PieSeriesItem
 | Constructor.
PieSeriesRenderData — Class in package mx.charts.series.renderData
 | Represents all the information needed by the PieSeries to render.
PieSeriesRenderData(cache:Array, filteredCache:Array, labelScale:Number, labelData:Object) — Constructor in class mx.charts.series.renderData.PieSeriesRenderData
 | Constructor.
PIXEL — Constant static property in class flash.text.GridFitType
 | Fits strong horizontal and vertical lines to the pixel grid.
pixelAspectRatio — Static property in class flash.system.Capabilities
 | Specifies the pixel aspect ratio of the screen.
pixelBounds — Property in class flash.geom.Transform
 | A Rectangle object that defines the bounding rectangle of the display object on the Stage.
pixelDissolve(sourceBitmapData:flash.display:BitmapData, sourceRect:flash.geom:Rectangle, destPoint:flash.geom:Point, randomSeed:int, numPixels:int, fillColor:uint) — Method in class flash.display.BitmapData
 | Performs a pixel dissolve either from a source image to a destination image or by using the same image.
pixelHeight — Property in class mx.charts.chartClasses.CartesianTransform
 | The height of the data area that the CartesianTransform represents, in pixels.
pixelHinting — Property in class mx.graphics.LinearGradientStroke
 | A Boolean value that specifies whether to hint strokes to full pixels.
pixelHinting — Property in class mx.graphics.Stroke
 | Specifies whether to hint strokes to full pixels.
pixelSnapping — Property in class flash.display.Bitmap
 | Controls whether or not the Bitmap object is snapped to the nearest pixel.
PixelSnapping — Final class in package flash.display
 | The PixelSnapping class is an enumeration of constant values for setting the pixel snapping options by using the pixelSnapping property of a Bitmap object.
pixelsToPercent(pxl:Number) — Method in class mx.containers.Box
 | Method used to convert number of pixels to a percentage relative to the contents of this container.
pixelWidth — Property in class mx.charts.chartClasses.CartesianTransform
 | The width of the data area that the CartesianTransform represents, in pixels.
placement — Property in class mx.charts.AxisRenderer
 | The side of the chart the axisRenderer will appear on.
placement — Property in interface mx.charts.chartClasses.IAxisRenderer
 | The side of the chart the axisRenderer will appear on.
placeSortArrow() — Method in class mx.controls.DataGrid
 | Draws the sort arrow graphic on the column that is the current sort key.
play() — Method in class flash.display.MovieClip
 | Moves the playhead in the timeline of the movie clip.
play(startTime:Number, loops:int, sndTransform:flash.media:SoundTransform) — Method in class flash.media.Sound
 | Generates a new SoundChannel object to play back the sound.
play(... rest) — Method in class flash.net.NetStream
 | Begins playback of external audio or a video (FLV) file.
play — Property in class flash.ui.ContextMenuBuiltInItems
 | Lets the user start a paused SWF file (does not appear for a single-frame SWF file).
play() — Method in class mx.controls.VideoDisplay
 | Plays the media file.
play(targets:Array, playReversedFromEnd:Boolean) — Method in class mx.effects.Effect
 | Begins playing the effect.
play() — Method in class mx.effects.EffectInstance
 | Plays the effect instance on the target.
playedAction — Property in class mx.effects.effectClasses.ActionEffectInstance
 | Indicates whether the effect has been played (true), or not (false).
playerType — Static property in class flash.system.Capabilities
 | Specifies the type of player.
playheadTime — Property in class mx.controls.VideoDisplay
 | Playhead position, measured in seconds, since the video starting playing.
playheadTime — Property in class mx.effects.EffectInstance
 | Current position in time of the effect.
playheadTime — Property in class mx.effects.effectClasses.TweenEffectInstance
 | The current position of the effect, in milliseconds.
playheadTime — Property in class mx.events.VideoEvent
 | The location of the playhead of the VideoDisplay control when the event occurs.
playheadUpdate — Event in class mx.controls.VideoDisplay
 | Dispatched every 0.25 seconds while the video is playing.
PLAYHEAD_UPDATE — Constant static property in class mx.events.VideoEvent
 | The VideoEvent.PLAYHEAD_UPDATE constant defines the value of the type property of the event object for a playheadUpdate event.
playheadUpdateInterval — Property in class mx.controls.VideoDisplay
 | Specifies the amount of time, in milliseconds, between each playheadUpdate event.
playing — Property in class mx.controls.VideoDisplay
 | If true, the media is currently playing.
PLAYING — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property when an FLV file is loaded and is playing.
PlotChart — Class in package mx.charts
 | The PlotChart control represents data with two values for each data point.
PlotChart() — Constructor in class mx.charts.PlotChart
 | Constructor.
PlotSeries — Class in package mx.charts.series
 | Defines a data series for a PlotChart control.
PlotSeries() — Constructor in class mx.charts.series.PlotSeries
 | Constructor
PlotSeriesItem — Class in package mx.charts.series.items
 | Represents the information required to render an item as part of a PlotSeries.
PlotSeriesItem(element:mx.charts.series:PlotSeries, data:Object, index:uint) — Constructor in class mx.charts.series.items.PlotSeriesItem
 | Constructor.
PlotSeriesRenderData — Class in package mx.charts.series.renderData
 | Represents all the information needed by the PlotSeries to render.
PlotSeriesRenderData(cache:Array, filteredCache:Array, radius:Number) — Constructor in class mx.charts.series.renderData.PlotSeriesRenderData
 | Constructor.
Point — Class in package flash.geom
 | The Point object represents a location in a two-dimensional coordinate system, where x represents the horizontal axis and y represents the vertical axis.
Point(x:Number, y:Number) — Constructor in class flash.geom.Point
 | Creates a new point.
polar(len:Number, angle:Number) — Static method in class flash.geom.Point
 | Converts a pair of polar coordinates to a Cartesian point coordinate.
PolarChart — Class in package mx.charts.chartClasses
 | The PolarChart control serves as base class for circular charts based in polar coordinates.
PolarChart() — Constructor in class mx.charts.chartClasses.PolarChart
 | Constructor.
PolarTransform — Class in package mx.charts.chartClasses
 | The PolarTransform object represents a set of axes used to map data values to angle/distance polar coordinates and vice versa.
PolarTransform() — Constructor in class mx.charts.chartClasses.PolarTransform
 | Constructor.
POLLED — Constant static property in class mx.controls.ProgressBarMode
 | The source property must specify an object that exposes the getBytesLoaded() and getBytesTotal() methods.
polling — Property in class mx.messaging.channels.AMFChannel
 | Reports whether the channel is actively polling.
polling — Property in class mx.messaging.channels.HTTPChannel
 | Reports whether the channel is actively polling.
PollingChannel — Class in package mx.messaging.channels
 | The PollingChannel class provides the polling behavior that all polling channels in the messaging system require.
PollingChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.PollingChannel
 | Creates a new PollingChannel instance with the specified id.
pollingEnabled — Property in class mx.messaging.channels.AMFChannel
 | Indicates whether this channel is enabled to poll.
pollingEnabled — Property in class mx.messaging.channels.HTTPChannel
 | Indicates whether this channel is enabled to poll.
pollingInterval — Property in class mx.messaging.channels.AMFChannel
 | Provides access to the polling interval for this Channel.
pollingInterval — Property in class mx.messaging.channels.HTTPChannel
 | Provides access to the polling interval for this Channel.
POLL_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
 | This operation is used to poll a remote destination for pending, undelivered messages.
pop() — Method in class Array
 | Removes the last element from an array and returns the value of that element.
popUp — Property in class mx.controls.PopUpButton
 | Specifies the UIComponent object, or object defined by a subclass of UIComponent, to pop up.
popUp — Property in class mx.controls.PopUpMenuButton
 | A reference to the pop-up Menu object.
POPUP — Constant static property in class mx.managers.PopUpManagerChildList
 | Indicates that the popup is placed in the popup child list which will cause it to float over other popups in the application layer.
PopUpButton — Class in package mx.controls
 | The PopUpButton control adds a flexible pop-up control interface to a Button control.
PopUpButton() — Constructor in class mx.controls.PopUpButton
 | Constructor.
PopUpButtonSkin — Class in package mx.skins.halo
 | The skin for all the states of a PopUpButton.
PopUpButtonSkin() — Constructor in class mx.skins.halo.PopUpButtonSkin
 | Constructor.
popUpChildren — Property in interface mx.managers.ISystemManager
 | An list of the topMost (popup) windows being parented by this ISystemManager.
popUpChildren — Property in class mx.managers.SystemManager
 | An list of the topMost (popup) windows being parented by this ISystemManager.
popUpDownSkin — Style in class mx.controls.PopUpButton
 | Skin class for the popUpDown state (when arrowButton is in down state) of the background and border.
popUpGap — Style in class mx.controls.PopUpButton
 | Number of vertical pixels between the PopUpButton and the specified popup UIComponent.
popUpIcon — Style in class mx.controls.PopUpButton
 | The icon used for the right button of PopUpButton.
PopUpIcon — Class in package mx.skins.halo
 | The skin for all the states of the icon in a PopUpButton.
PopUpIcon() — Constructor in class mx.skins.halo.PopUpIcon
 | Constructor
PopUpManager — Class in package mx.managers
 | The PopUpManager singleton class creates new top-level windows and places or removes those windows from the layer on top of all other visible windows.
PopUpManagerChildList — Final class in package mx.managers
 | The PopUpManagerChildList class defines the constant values for the detail property of the PopUpManager addPopUp() and createPopUp() methods.
popUpMenu(menu:mx.controls:Menu, parent:flash.display:DisplayObjectContainer, mdp:Object) — Static method in class mx.controls.Menu
 | Sets the dataProvider of an existing Menu control and places the Menu control in the specified parent container.
PopUpMenuButton — Class in package mx.controls
 | The PopUpMenuButton control creates a PopUpButton control with a main sub-button and a secondary sub-button.
PopUpMenuButton() — Constructor in class mx.controls.PopUpMenuButton
 | Constructor.
PopUpMenuIcon — Class in package mx.skins.halo
 | The skin for all the states of the icon in a PopUpMenuButton.
PopUpMenuIcon() — Constructor in class mx.skins.halo.PopUpMenuIcon
 | Constructor
popUpOverSkin — Style in class mx.controls.PopUpButton
 | Skin class for the popUpOver state (over arrowButton) of the background and border.
port — Property in class mx.rpc.soap.WebService
 | Specifies the port within the WSDL document that this WebService should use
PORTRAIT — Constant static property in class flash.printing.PrintJobOrientation
 | The portrait (vertical) image orientation for printing.
position — Property in class flash.media.SoundChannel
 | The current position of the playhead within the sound.
position — Property in class flash.utils.ByteArray
 | Moves, or returns the current position, in bytes, of the file pointer into the ByteArray object.
position — Property in class mx.charts.AxisLabel
 | The position, specified as a value between 0 and 1, of the label along the axis.
position — Property in class mx.data.UpdateCollectionRange
 | Indicates the begining index for the range of updates made to the associated collection.
position — Property in class mx.effects.AddChildAction
 | The position of the child in the display list, relative to the object specified by the relativeTo property.
position — Property in class mx.effects.effectClasses.AddChildActionInstance
 | The position of the child component, relative to relativeTo, where it is added.
position — Property in class mx.events.ScrollEvent
 | The new scroll position.
position — Property in class mx.states.AddChild
 | The position of the child in the display list, relative to the object specified by the relativeTo property.
positionDataTips() — Method in class mx.charts.chartClasses.ChartBase
 | Defines the locations of DataTips on the chart.
POSITIVE_INFINITY — Constant static property in class Number
 | Specifies the IEEE-754 value representing positive infinity.
POST — Constant static property in class flash.net.URLRequestMethod
 | Specifies that the URLRequest object is a POST.
POST_METHOD — Constant static property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates that the method used for this request should be "post".
pow(val1:Number, val2:Number) — Static method in class Math
 | Computes and returns val1 to the power of val2.
precision — Property in class mx.formatters.CurrencyFormatter
 | Number of decimal places to include in the output String.
precision — Property in class mx.formatters.NumberFormatter
 | Number of decimal places to include in the output String.
precision — Property in class mx.validators.CurrencyValidator
 | The maximum number of digits allowed to follow the decimal point.
precision — Property in class mx.validators.NumberValidator
 | The maximum number of digits allowed to follow the decimal point.
precisionError — Property in class mx.validators.CurrencyValidator
 | Error message when the value has a precision that exceeds the value defined by the precision property.
precisionError — Property in class mx.validators.NumberValidator
 | Error message when the value has a precision that exceeds the value defined by the precision property.
preferDropLabels() — Method in class mx.charts.CategoryAxis
 | Determines how the axis handles overlapping labels.
preferDropLabels() — Method in interface mx.charts.chartClasses.IAxis
 | Determines how the axis handles overlapping labels.
preferDropLabels() — Method in class mx.charts.chartClasses.NumericAxis
 | Determines how the axis handles overlapping labels.
prefix — Property in class Namespace
 | The prefix of the namespace.
prefix — Property in class flash.xml.XMLNode
 | The prefix portion of the XML node name.
preinitialize — Event in class mx.core.UIComponent
 | Dispatched at the beginning of the component initialization sequence.
PREINITIALIZE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.PREINITIALIZE constant defines the value of the type property of the event object for a preinitialize event.
preloader — Property in class mx.core.Application
 | Specifies the path of a SWC component class or ActionScript component class that defines a custom progress bar.
preloader — Property in class mx.preloaders.DownloadProgressBar
 | The Preloader class passes in a reference to itself to the display class so that it can listen for events from the preloader.
preloader — Property in interface mx.preloaders.IPreloaderDisplay
 | The Preloader class passes in a reference to itself to the display class so that it can listen for events from the preloader.
Preloader — Class in package mx.preloaders
 | The Preloader class is used by the SystemManager to monitor the download and initialization status of a Flex application.
Preloader() — Constructor in class mx.preloaders.Preloader
 | Constructor
preloaderBackgroundAlpha — Property in class mx.managers.SystemManager
 | The background alpha used by the child of the preloader.
preloaderBackgroundColor — Property in class mx.managers.SystemManager
 | The background color used by the child of the preloader.
preloaderBackgroundImage — Property in class mx.managers.SystemManager
 | The background color used by the child of the preloader.
preloaderBackgroundSize — Property in class mx.managers.SystemManager
 | The background size used by the child of the preloader.
prepareToPrint(target:mx.core:IFlexDisplayObject) — Method in class mx.core.UIComponent
 | Prepares an IFlexDisplayObject for printing.
PREPARING_TO_HIDE_DATA — Constant static property in class mx.charts.chartClasses.ChartState
 | The display of data has changed in the chart, and it is about to begin a transition to hide the current data.
PREPARING_TO_SHOW_DATA — Constant static property in class mx.charts.chartClasses.ChartState
 | The chart has finished any transitions to hide the old data, and is preparing to run transitions to display the new data
prependChild(value:Object) — Method in class XML
 | Inserts a copy of the provided child object into the XML element before any existing XML properties for that element.
preserveAlpha — Property in class flash.filters.ConvolutionFilter
 | Indicates if the alpha channel is preserved without the filter effect or if the convolution filter is applied to the alpha channel as well as the color channels.
prettyIndent — Static property in class XML
 | Determines the amount of indentation applied by the toString() and toXMLString() methods when the XML.prettyPrinting property is set to true.
prettyPrinting — Static property in class XML
 | Determines whether the toString() and toXMLString() methods normalize white space characters between some tags.
preventDefault() — Method in class flash.events.Event
 | Cancels an event's default behavior if that behavior can be canceled.
prevFrame() — Method in class flash.display.MovieClip
 | Sends the playhead to the previous frame and stops it.
previewHeight — Style in class mx.controls.ColorPicker
 | Height of the larger preview swatch that appears above the swatch grid on the upper left of the SwatchPanel object.
previewWidth — Style in class mx.controls.ColorPicker
 | Width of the larger preview swatch.
PREVIOUS_MONTH — Constant static property in class mx.events.DateChooserEventDetail
 | Indicates that the user scrolled the calendar to the previous month.
previousSibling — Property in class flash.xml.XMLNode
 | An XMLNode value that references the previous sibling in the parent node's child list.
previousValue — Property in class mx.controls.NumericStepper
 | The value that is one step smaller than the current value property and not smaller than the maximum property value.
previousVersion — Property in interface mx.data.IChangeObject
 | Previous version of the item.
PREVIOUS_YEAR — Constant static property in class mx.events.DateChooserEventDetail
 | Indicates that the user scrolled the calendar to the previous year.
prevMonthDisabledSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous month arrow when the arrow is disabled.
prevMonthDownSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous month arrow when the user presses the mouse button down over the arrow.
prevMonthOverSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous month arrow when the user holds the mouse pointer over the arrow.
prevMonthUpSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous month arrow when the mouse pointer is not over the arrow.
prevScene() — Method in class flash.display.MovieClip
 | Moves the playhead to the previous scene of the MovieClip instance.
prevYearDisabledSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous Year arrow when the arrow is disabled.
prevYearDownSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous Year arrow when the user presses the mouse button down over the arrow.
prevYearOverSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous Year arrow when the user holds the mouse pointer over the arrow.
prevYearUpSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the previous Year arrow when the mouse button not over the arrow.
print — Property in class flash.ui.ContextMenuBuiltInItems
 | Lets the user send the displayed frame image to a printer.
printAsBitmap — Property in class flash.printing.PrintJobOptions
 | Specifies whether the content in the print job is printed as a bitmap or as a vector.
printAsBitmap — Property in class mx.printing.FlexPrintJob
 | Specifies whether to print the job content as a bitmap (true) or in vector format (false).
PrintDataGrid — Class in package mx.printing
 | The PrintDataGrid control is a DataGrid subclass that is styled to show a table with line borders and is optimized for printing.
PrintDataGrid() — Constructor in class mx.printing.PrintDataGrid
 | Constructor.
PrintJob — Class in package flash.printing
 | The PrintJob class lets you create content and print it to one or more pages.
PrintJob() — Constructor in class flash.printing.PrintJob
 | Creates a PrintJob object that you can use to print one or more pages.
PrintJobOptions — Class in package flash.printing
 | The PrintJobOptions class contains properties to use with the options parameter of the PrintJob.addPage() method.
PrintJobOptions(printAsBitmap:Boolean) — Constructor in class flash.printing.PrintJobOptions
 | Creates a new PrintJobOptions object.
PrintJobOrientation — Final class in package flash.printing
 | This class provides values that are used by the PrintJob.orientation property for the image position of a printed page.
PRIVACY — Constant static property in class flash.system.SecurityPanel
 | When passed to Security.showSettings(), displays the Privacy Settings panel in Flash Player Settings.
private — Statement
 | Specifies that a variable, constant, method or namespace is available only to the class that defines it.
privileges — Property in interface mx.data.IAccessPrivileges
 | Returns the current privilege settings.
processedDescriptors — Property in class mx.core.UIComponent
 | Set to true after immediate or deferred child creation, depending on which one happens.
processedDescriptors — Property in class mx.core.UITextField
 | Set to true after the createChildren() method creates any internal component children.
processedDescriptors — Property in interface mx.managers.ILayoutManagerClient
 | Set to true after immediate or deferred child creation, depending on which one happens.
processedDescriptors — Property in class mx.skins.ProgrammaticSkin
 | Set to true after immediate or deferred child creation, depending on which one happens.
processingInstructions(name:String) — Method in class XML
 | If a name parameter is provided, lists all the children of the XML object that contain processing instructions with that name.
processingInstructions(name:String) — Method in class XMLList
 | If a name parameter is provided, lists all the children of the XMLList object that contain processing instructions with that name.
processNewDataProvider(value:Object) — Method in class mx.charts.chartClasses.ChartElement
 | Called when a new dataProvider is assigned to the element.
Producer — Class in package mx.messaging
 | A Producer sends messages to a destination.
Producer() — Constructor in class mx.messaging.Producer
 | Constructs a Producer.
ProgrammaticSkin — Class in package mx.skins
 | This class is the base class for skin elements which draw themselves programmatically.
ProgrammaticSkin() — Constructor in class mx.skins.ProgrammaticSkin
 | Constructor.
progress — Event in class flash.display.LoaderInfo
 | Dispatched when data is received as the download operation progresses.
progress — Event in class flash.media.Sound
 | Dispatched when data is received as a load operation progresses.
progress — Event in class flash.net.FileReference
 | Dispatched periodically during the file upload or download operation.
progress — Event in class flash.net.URLLoader
 | Dispatched when data is received as the download operation progresses.
progress — Event in class flash.net.URLStream
 | Dispatched when data is received as the download operation progresses.
progress — Event in class mx.controls.ProgressBar
 | Dispatched as content loads in event or polled mode.
progress — Event in class mx.controls.SWFLoader
 | Dispatched when content is loading.
progress — Event in class mx.controls.VideoDisplay
 | Dispatched continuously until the FLV file has downloaded completely.
progress — Event in class mx.effects.SoundEffect
 | Dispatched periodically as the sound file loads.
PROGRESS — Constant static property in class flash.events.ProgressEvent
 | Defines the value of the type property of a progress event object.
ProgressBar — Class in package mx.controls
 | The ProgressBar control provides a visual representation of the progress of a task over time.
ProgressBar() — Constructor in class mx.controls.ProgressBar
 | Constructor.
ProgressBarDirection — Final class in package mx.controls
 | The ProgressBarDirection class defines the values for the direction property of the ProgressBar class.
ProgressBarLabelPlacement — Final class in package mx.controls
 | The ProgressBarLabelPlacement class defines the values for the labelPlacement property of the ProgressBar class.
ProgressBarMode — Final class in package mx.controls
 | The ProgressBarMode class defines the values for the mode property of the ProgressBar class.
ProgressBarSkin — Class in package mx.skins.halo
 | The skin for a ProgressBar.
ProgressBarSkin() — Constructor in class mx.skins.halo.ProgressBarSkin
 | Constructor.
ProgressEvent — Class in package flash.events
 | Flash® Player dispatches ProgressEvent objects when a load operation has begun or a socket has received data.
ProgressEvent(type:String, bubbles:Boolean, cancelable:Boolean, bytesLoaded:uint, bytesTotal:uint) — Constructor in class flash.events.ProgressEvent
 | Creates an Event object that contains information about progress events.
progressHandler(event:flash.events:ProgressEvent) — Method in class mx.preloaders.DownloadProgressBar
 | Event listener for the ProgressEvent.PROGRESS event.
ProgressIndeterminateSkin — Class in package mx.skins.halo
 | The skin for the indeterminate state of a ProgressBar.
ProgressIndeterminateSkin() — Constructor in class mx.skins.halo.ProgressIndeterminateSkin
 | Constructor.
progressInterval — Property in class mx.controls.VideoDisplay
 | Specifies the amount of time, in milliseconds, between each progress event.
ProgressTrackSkin — Class in package mx.skins.halo
 | The skin for the track in a ProgressBar.
ProgressTrackSkin() — Constructor in class mx.skins.halo.ProgressTrackSkin
 | Constructor.
prompt — Property in class mx.controls.ComboBox
 | The prompt for the ComboBox control.
properties — Property in class mx.charts.chartClasses.InstanceCache
 | A hashmap of properties to assign to new instances.
properties — Property in class mx.core.ClassFactory
 | An Object whose name/value pairs specify the properties to be set on each object generated by the newInstance() method.
properties — Property in class mx.core.ComponentDescriptor
 | An Object containing name/value pairs for the component's properties, as specified in MXML.
propertiesFactory — Property in class mx.core.ComponentDescriptor
 | A Function that returns an Object containing name/value pairs for the component's properties, as specified in MXML.
property — Property in class mx.effects.AnimateProperty
 | The name of the property on the target to animate.
property — Property in class mx.effects.effectClasses.AnimatePropertyInstance
 | The name of the property on the target to animate.
property — Property in class mx.events.PropertyChangeEvent
 | A String, QName, or int specifying the property that changed.
property — Property in class mx.validators.Validator
 | A String specifying the name of the property of the source object that contains the value to validate.
propertyAffectsSort(property:String) — Method in class mx.collections.Sort
 | Return whether the specified property is used to control the sort.
propertyChange — Event in class mx.data.DataService
 | The PropertyChangeEvent.PROPERTY_CHANGE event is dispatched when a property of this service changes.
propertyChange — Event in class mx.messaging.Channel
 | Dispatched when a property of the channel changes.
propertyChange — Event in class mx.messaging.ChannelSet
 | Dispatched when a property of the channel set changes.
propertyChange — Event in class mx.messaging.MessageAgent
 | Dispatched when the connected property of the MessageAgent changes.
propertyChange — Event in class mx.rpc.AsyncToken
 | Dispatched when a property of the channel set changes.
PROPERTY_CHANGE — Constant static property in class mx.events.PropertyChangeEvent
 | The PropertyChangeEvent.PROPERTY_CHANGE constant defines the value of the type property of the event object for a PropertyChange event.
PropertyChangeEvent — Class in package mx.events
 | The PropertyChangeEvent class represents the event object passed to the event listener when one of the properties of an object has changed, and provides information about the change.
PropertyChangeEvent(type:String, bubbles:Boolean, cancelable:Boolean, kind:String, property:Object, oldValue:Object, newValue:Object, source:Object) — Constructor in class mx.events.PropertyChangeEvent
 | Constructor.
PropertyChangeEventKind — Final class in package mx.events
 | The PropertyChangeEventKind class defines the constant values for the kind property of the PropertyChangeEvent class.
propertyChangeHandler(event:mx.events:PropertyChangeEvent) — Method in class mx.utils.ObjectProxy
 | Called when a complex property is updated.
propertyChanges — Property in class mx.effects.EffectInstance
 | Specifies the PropertyChanges object containing the start and end values for the set of properties relevant to the effect's targets.
PropertyChanges — Class in package mx.effects.effectClasses
 | The PropertyChanges class defines the start and end values for a set of properties of a target component of a transition.
PropertyChanges(target:mx.core:IUIComponent) — Constructor in class mx.effects.effectClasses.PropertyChanges
 | The PropertyChanges constructor.
propertyIsEnumerable(name:String) — Method in class Object
 | Indicates whether the specified property exists and is enumerable.
propertyIsEnumerable(p:String) — Method in class XML
 | Checks whether the property p is in the set of properties that can be iterated in a for..in statement applied to the XML object.
propertyIsEnumerable(p:String) — Method in class XMLList
 | Checks whether the property p is in the set of properties that can be iterated in a for..in statement applied to the XMLList object.
propertyList — Property in class mx.utils.ObjectProxy
 | Contains a list of all of the property names for the proxied object.
propertyNames — Property in class mx.data.Conflict
 | Returns an Array of the names of the properties that were in conflict between the client change and the remote item state.
propertyNames — Property in class mx.data.messages.DataErrorMessage
 | An array of properties that were found to be conflicting between the client and server objects.
propertyPattern — Property in class mx.messaging.management.ObjectName
 | Indicates if the object name is a pattern on the key properties.
protected — Statement
 | Specifies that a variable, constant, method, or namespace is available only to the class that defines it and to any subclasses of that class.
protocol — Property in class mx.messaging.Channel
 | Provides access to the protocol that the channel uses.
protocol — Property in class mx.messaging.channels.AMFChannel
 | Returns the protocol for this channel (http).
protocol — Property in class mx.messaging.channels.HTTPChannel
 | Returns the protocol for this channel (http).
protocol — Property in class mx.messaging.channels.RTMPChannel
 | Returns the protocol for this channel (rtmp).
protocol — Property in class mx.messaging.channels.SecureAMFChannel
 | Returns the protocol for this channel (https).
protocol — Property in class mx.messaging.channels.SecureHTTPChannel
 | Returns the protocol for this channel (https).
protocol — Property in class mx.messaging.channels.SecureRTMPChannel
 | Returns the protocol for this channel (rtmps).
prototype — Static property in class Object
 | A reference to the prototype object of a class or function object.
Proxy — Class in package flash.utils
 | The Proxy class lets you override the default behavior of ActionScript operations (such as retrieving and modifying properties) on an object.
proxyClass — Property in class mx.utils.ObjectProxy
 | Indicates what kind of proxy to create when proxying complex properties.
proxyType — Property in class flash.net.NetConnection
 | Determines whether native SSL is used for RTMPS instead of HTTPS, and whether the CONNECT method of tunneling is used to connect through a proxy server.
public — Statement
 | Specifies that a class, variable, constant or method is available to any caller.
publish(name:String, type:String) — Method in class flash.net.NetStream
 | Sends streaming audio, video, and text messages from a client to a server, such as Flash Media Server 2, optionally recording the stream during transmission.
push(... rest) — Method in class Array
 | Adds one or more elements to the end of an array and returns the new length of the array.
PUT_METHOD — Constant static property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates that the method used for this request should be "put".
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


Q Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
Q Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
qname — Property in class mx.rpc.soap.SOAPHeader
 | The qualified name of the SOAP header.
QName — Final class in Top Level
 | QName objects represent qualified names of XML elements and attributes.
QName(qname:QName) — Constructor in class QName
 | Creates a QName object that is a copy of another QName object.
QName(uri:Namespace, localName:QName) — Constructor in class QName
 | Creates a QName object with a URI object from a Namespace object and a localName from a QName object.
qnamesEqual(qname1:QName, qname2:QName) — Static method in class mx.utils.XMLUtil
 | Returns true if the two QName parameters have identical uri and localName properties.
qnameToString(qname:QName) — Static method in class mx.utils.XMLUtil
 | Returns the concatenation of a Qname object's uri and localName properties, separated by a colon.
Quadratic — Class in package mx.effects.easing
 | The Quadratic class defines three easing functions to implement quadratic motion with Flex effect classes.
quality — Property in class flash.display.Stage
 | A value from the StageQuality class that specifies which rendering quality Flash Player uses.
quality — Property in class flash.filters.BevelFilter
 | The number of times to apply the filter.
quality — Property in class flash.filters.BlurFilter
 | The number of times to perform the blur.
quality — Property in class flash.filters.DropShadowFilter
 | The number of times to apply the filter.
quality — Property in class flash.filters.GlowFilter
 | The number of times to apply the filter.
quality — Property in class flash.filters.GradientBevelFilter
 | The number of times to apply the filter.
quality — Property in class flash.filters.GradientGlowFilter
 | The number of times to apply the filter.
quality — Property in class flash.media.Camera
 | An integer specifying the required level of picture quality, as determined by the amount of compression being applied to each video frame.
quality — Property in class flash.ui.ContextMenuBuiltInItems
 | Lets the user set the resolution of the SWF file at run time.
Quartic — Class in package mx.effects.easing
 | The Quartic class defines three easing functions to implement motion with Flex effect classes.
QUEUED — Constant static property in class mx.core.ContainerCreationPolicy
 | Add the container to a creation queue.
Quintic — Class in package mx.effects.easing
 | The Quintic class defines three easing functions to implement motion with Flex effect classes.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


R Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
R Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
RADIAL — Constant static property in class flash.display.GradientType
 | Value used to specify a radial gradient fill.
radialAxis — Property in class mx.charts.chartClasses.PolarChart
 | The axis object used to map data values to a radial distance between the center and the outer edge of the chart.
RADIAL_AXIS — Constant static property in class mx.charts.chartClasses.PolarTransform
 | A string representing the radial axis.
RadialGradient — Class in package mx.graphics
 | The RadialGradient class lets you specify a gradual color transition in the fill color.
RadialGradient() — Constructor in class mx.graphics.RadialGradient
 | Constructor.
radialStroke — Style in class mx.charts.series.PieSeries
 | Specifies the line style used to draw the border between the wedges of the pie.
RadioButton — Class in package mx.controls
 | The RadioButton control lets the user make a single choice within a set of mutually exclusive choices.
RadioButton() — Constructor in class mx.controls.RadioButton
 | Constructor.
RadioButtonGroup — Class in package mx.controls
 | The RadioButtonGroup control defines a group of RadioButton controls that act as a single mutually exclusive control; therefore, a user can select only one RadioButton control at a time.
RadioButtonGroup(document:mx.core:IFlexDisplayObject) — Constructor in class mx.controls.RadioButtonGroup
 | Constructor.
RadioButtonIcon — Class in package mx.skins.halo
 | The skin for all the states of the icon in a RadioButton.
RadioButtonIcon() — Constructor in class mx.skins.halo.RadioButtonIcon
 | Constructor.
radioDisabledIcon — Style in class mx.controls.Menu
 | The icon for all disabled menu items whose type identifier is a radio button.
radioIcon — Style in class mx.controls.Menu
 | The icon for all enabled menu items whose type identifier is a radio button.
radius — Property in class mx.charts.chartClasses.PolarTransform
 | The radius used by the transform to convert data units to polar coordinates.
radius — Style in class mx.charts.series.AreaSeries
 | Specifies the radius, in pixels, of the chart elements for the data points.
radius — Style in class mx.charts.series.LineSeries
 | Specifies the radius, in pixels, of the chart elements for the data points.
radius — Property in class mx.charts.series.LineSeries
 | Specifies the radius, in pixels, of the chart elements for the data points.
radius — Style in class mx.charts.series.PlotSeries
 | Specifies the radius, in pixels, of the chart element at each data point.
radius — Property in class mx.charts.series.PlotSeries
 | Specifies the radius, in pixels, of the chart element at each data point.
radius — Property in class mx.charts.series.items.PlotSeriesItem
 | The radius of this item, in pixels.
radius — Property in class mx.charts.series.renderData.AreaSeriesRenderData
 | The radius of the items of the AreaSeries.
radius — Property in class mx.charts.series.renderData.LineSeriesRenderData
 | The radius of the individual items in the line series.
radius — Property in class mx.charts.series.renderData.PlotSeriesRenderData
 | The radius of the individual PlotSeriesItem objects.
radiusAxis — Property in class mx.charts.BubbleChart
 | The axis the bubble radius is mapped against Bubble charts treat the size of the individual bubbles as a third dimension of data which is transformed in a similar manner to how x and y position is transformed.
RADIUS_AXIS — Constant static property in class mx.charts.series.BubbleSeries
 | The type of radius axis.
radiusField — Property in class mx.charts.series.BubbleSeries
 | Specifies the field of the data provider that determines the radius of each symbol, relative to the other data points in the chart.
random() — Static method in class Math
 | Returns a pseudo-random number n, where 0 <= n < 1.
RangeError — Dynamic class in Top Level
 | A RangeError exception is thrown when a numeric value is outside the acceptable range.
RangeError(message:String) — Constructor in class RangeError
 | Creates a new RangeError object.
rate — Property in class flash.media.Microphone
 | The rate at which the microphone is capturing sound, in kHz.
ratio — Property in class mx.graphics.GradientEntry
 | Where in the graphical element, as a percentage from 0 to 1, Flex starts the transition to the associated color.
ratios — Property in class flash.filters.GradientBevelFilter
 | An array of color distribution ratios for the corresponding colors in the colors array.
ratios — Property in class flash.filters.GradientGlowFilter
 | An array of color distribution ratios for the corresponding colors in the colors array.
rawChildren — Property in class mx.core.Container
 | A container typically contains child components, which can be enumerated using the Container.getChildAt() method and Container.numChildren property.
rawChildren — Property in interface mx.core.IRawChildrenContainer
 | Returns an IChildList representing all children.
rawChildren — Property in interface mx.managers.ISystemManager
 | A list of all children being parented by this ISystemManager.
rawChildren — Property in class mx.managers.SystemManager
 | A list of all children being parented by this ISystemManager.
readable — Property in class mx.messaging.management.MBeanAttributeInfo
 | Indicates if the attribute is readable.
readBoolean() — Method in class flash.net.Socket
 | Reads a Boolean value from the socket.
readBoolean() — Method in class flash.net.URLStream
 | Reads a Boolean value from the stream.
readBoolean() — Method in class flash.utils.ByteArray
 | Reads a Boolean value from the byte stream.
readBoolean() — Method in interface flash.utils.IDataInput
 | Reads a Boolean value from the byte stream or byte array.
readByte() — Method in class flash.net.Socket
 | Reads a signed byte from the socket.
readByte() — Method in class flash.net.URLStream
 | Reads a signed byte from the stream.
readByte() — Method in class flash.utils.ByteArray
 | Reads a signed byte from the byte stream.
readByte() — Method in interface flash.utils.IDataInput
 | Reads a signed byte from the byte stream or byte array.
readBytes(bytes:flash.utils:ByteArray, offset:uint, length:uint) — Method in class flash.net.Socket
 | Reads the number of data bytes specified by the length parameter from the socket.
readBytes(bytes:flash.utils:ByteArray, offset:uint, length:uint) — Method in class flash.net.URLStream
 | Reads length bytes of data from the stream.
readBytes(bytes:flash.utils:ByteArray, offset:uint, length:uint) — Method in class flash.utils.ByteArray
 | Reads the number of data bytes, specified by the length parameter, from the byte stream.
readBytes(bytes:flash.utils:ByteArray, offset:uint, length:uint) — Method in interface flash.utils.IDataInput
 | Reads the number of data bytes, specified by the length parameter, from the byte stream or byte array.
readDouble() — Method in class flash.net.Socket
 | Reads an IEEE 754 double-precision floating-point number from the socket.
readDouble() — Method in class flash.net.URLStream
 | Reads an IEEE 754 double-precision floating-point number from the stream.
readDouble() — Method in class flash.utils.ByteArray
 | Reads an IEEE 754 double-precision (64-bit) floating-point number from the byte stream.
readDouble() — Method in interface flash.utils.IDataInput
 | Reads an IEEE 754 double-precision floating point number from the byte stream or byte array.
readExternal(input:flash.utils:IDataInput) — Method in interface flash.utils.IExternalizable
 | A class implements this method to decode itself from a data stream by calling the methods of the IDataInput interface.
readExternal(input:flash.utils:IDataInput) — Method in class mx.utils.ObjectProxy
 | Since Flex only uses ObjectProxy to wrap anonymous objects, the server flex.messaging.io.ObjectProxy instance serializes itself as a Map that will be returned as a plain ActionScript object.
readFloat() — Method in class flash.net.Socket
 | Reads an IEEE 754 single-precision floating-point number from the socket.
readFloat() — Method in class flash.net.URLStream
 | Reads an IEEE 754 single-precision floating-point number from the stream.
readFloat() — Method in class flash.utils.ByteArray
 | Reads an IEEE 754 single-precision (32-bit) floating-point number from the byte stream.
readFloat() — Method in interface flash.utils.IDataInput
 | Reads an IEEE 754 single-precision floating point number from the byte stream or byte array.
readInt() — Method in class flash.net.Socket
 | Reads a signed 32-bit integer from the socket.
readInt() — Method in class flash.net.URLStream
 | Reads a signed 32-bit integer from the stream.
readInt() — Method in class flash.utils.ByteArray
 | Reads a signed 32-bit integer from the byte stream.
readInt() — Method in interface flash.utils.IDataInput
 | Reads a signed 32-bit integer from the byte stream or byte array.
readMultiByte(length:uint, charSet:String) — Method in class flash.net.Socket
 | Reads a multibyte string from the byte stream, using the specified character set.
readMultiByte(length:uint, charSet:String) — Method in class flash.net.URLStream
 | Reads a multibyte string of specified length from the byte stream using the specified character set.
readMultiByte(length:uint, charSet:String) — Method in class flash.utils.ByteArray
 | Reads a multibyte string of specified length from the byte stream using the specified character set.
readMultiByte(length:uint, charSet:String) — Method in interface flash.utils.IDataInput
 | Reads a multibyte string of specified length from the byte stream using the specified character set.
readObject() — Method in class flash.net.Socket
 | Reads an object from the socket, encoded in AMF serialized format.
readObject() — Method in class flash.net.URLStream
 | Reads an object from the socket, encoded in Action Message Format (AMF).
readObject() — Method in class flash.utils.ByteArray
 | Reads an object from the byte array, encoded in AMF serialized format.
readObject() — Method in interface flash.utils.IDataInput
 | Reads an object from the byte stream or byte array, encoded in AMF serialized format.
readShort() — Method in class flash.net.Socket
 | Reads a signed 16-bit integer from the socket.
readShort() — Method in class flash.net.URLStream
 | Reads a signed 16-bit integer from the stream.
readShort() — Method in class flash.utils.ByteArray
 | Reads a signed 16-bit integer from the byte stream.
readShort() — Method in interface flash.utils.IDataInput
 | Reads a signed 16-bit integer from the byte stream or byte array.
readUnsignedByte() — Method in class flash.net.Socket
 | Reads an unsigned byte from the socket.
readUnsignedByte() — Method in class flash.net.URLStream
 | Reads an unsigned byte from the stream.
readUnsignedByte() — Method in class flash.utils.ByteArray
 | Reads an unsigned byte from the byte stream.
readUnsignedByte() — Method in interface flash.utils.IDataInput
 | Reads an unsigned byte from the byte stream or byte array.
readUnsignedInt() — Method in class flash.net.Socket
 | Reads an unsigned 32-bit integer from the socket.
readUnsignedInt() — Method in class flash.net.URLStream
 | Reads an unsigned 32-bit integer from the stream.
readUnsignedInt() — Method in class flash.utils.ByteArray
 | Reads an unsigned 32-bit integer from the byte stream.
readUnsignedInt() — Method in interface flash.utils.IDataInput
 | Reads an unsigned 32-bit integer from the byte stream or byte array.
readUnsignedShort() — Method in class flash.net.Socket
 | Reads an unsigned 16-bit integer from the socket.
readUnsignedShort() — Method in class flash.net.URLStream
 | Reads an unsigned 16-bit integer from the stream.
readUnsignedShort() — Method in class flash.utils.ByteArray
 | Reads an unsigned 16-bit integer from the byte stream.
readUnsignedShort() — Method in interface flash.utils.IDataInput
 | Reads an unsigned 16-bit integer from the byte stream or byte array.
readUTF() — Method in class flash.net.Socket
 | Reads a UTF-8 string from the socket.
readUTF() — Method in class flash.net.URLStream
 | Reads a UTF-8 string from the stream.
readUTF() — Method in class flash.utils.ByteArray
 | Reads a UTF-8 string from the byte stream.
readUTF() — Method in interface flash.utils.IDataInput
 | Reads a UTF-8 string from the byte stream or byte array.
readUTFBytes(length:uint) — Method in class flash.net.Socket
 | Reads the number of UTF-8 data bytes specified by the length parameter from the socket, and returns a string.
readUTFBytes(length:uint) — Method in class flash.net.URLStream
 | Reads a sequence of length UTF-8 bytes from the stream, and returns a string.
readUTFBytes(length:uint) — Method in class flash.utils.ByteArray
 | Reads a sequence of UTF-8 bytes specified by the length parameter from the byte stream and returns a string.
readUTFBytes(length:uint) — Method in interface flash.utils.IDataInput
 | Reads a sequence of length UTF-8 bytes from the byte stream or byte array and returns a string.
ready — Event in class mx.controls.VideoDisplay
 | Dispatched when the FLV file is loaded and ready to play.
READY — Constant static property in class mx.events.VideoEvent
 | The VideoEvent.READY constant defines the value of the type property of the event object for a ready event.
reason — Property in class mx.events.DataGridEvent
 | The reason the itemEditEnd event was dispatched.
reason — Property in class mx.events.ListEvent
 | The reason the itemEditEnd event was dispatched.
receive(timestamp:Number) — Method in class mx.messaging.Consumer
 | Requests any messages that are pending from the server from the specified timestamp to the present.
receiveAudio(flag:Boolean) — Method in class flash.net.NetStream
 | Specifies whether incoming audio plays on the stream.
receiveVideo(flag:Boolean) — Method in class flash.net.NetStream
 | Specifies whether incoming video will play on the stream.
reconnecting — Property in class mx.messaging.Channel
 | Indicates whether this channel is in the process of reconnecting to an alternate endpoint.
reconnecting — Property in class mx.messaging.events.ChannelEvent
 | Indicates whether the Channel that generated this event is reconnecting.
recordHeaders — Property in class mx.messaging.messages.HTTPRequestMessage
 | Only used when going through the proxy, should the proxy send back the request and response headers it used.
rect — Property in class flash.display.BitmapData
 | The rectangle that defines the size and location of the bitmap image.
Rectangle — Class in package flash.geom
 | A Rectangle object is an area defined by its position, as indicated by its top-left corner point (x, y) and by its width and its height.
Rectangle(x:Number, y:Number, width:Number, height:Number) — Constructor in class flash.geom.Rectangle
 | Creates a new Rectangle object with the top-left corner specified by the x and y parameters and with the specified width and height parameters.
RectangularBorder — Class in package mx.skins
 | The RectangularBorder class is an abstract base class for various classes that draw rectangular borders around UIComponents.
RectangularBorder() — Constructor in class mx.skins.RectangularBorder
 | Constructor.
RectangularDropShadow — Class in package mx.graphics
 | Drop shadows are typically created using the DropShadowFilter class.
RectangularDropShadow() — Constructor in class mx.graphics.RectangularDropShadow
 | Constructor.
recycleChildren — Property in interface mx.core.IRepeater
 | A Boolean flag indicating whether this Repeater should re-use previously created children, or create new ones.
recycleChildren — Property in class mx.core.Repeater
 | A Boolean flag indicating whether this Repeater should re-use previously created children, or create new ones.
RED — Constant static property in class flash.display.BitmapDataChannel
 | The red channel.
redMultiplier — Property in class flash.geom.ColorTransform
 | A decimal value that is multiplied with the red channel value.
redOffset — Property in class flash.geom.ColorTransform
 | A number from -255 to 255 that is added to the red channel value after it has been multiplied by the redMultiplier value.
reduceLabels(intervalStart:mx.charts:AxisLabel, intervalEnd:mx.charts:AxisLabel) — Method in class mx.charts.CategoryAxis
 | Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
reduceLabels(intervalStart:mx.charts:AxisLabel, intervalEnd:mx.charts:AxisLabel) — Method in class mx.charts.DateTimeAxis
 | Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
reduceLabels(intervalStart:mx.charts:AxisLabel, intervalEnd:mx.charts:AxisLabel) — Method in interface mx.charts.chartClasses.IAxis
 | Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
reduceLabels(intervalStart:mx.charts:AxisLabel, intervalEnd:mx.charts:AxisLabel) — Method in class mx.charts.chartClasses.NumericAxis
 | Invoked when an AxisRenderer is unable to cleanly render the labels without overlap, and would like the Axis object to reduce the set of labels.
ReferenceError — Dynamic class in Top Level
 | A ReferenceError exception is thrown when a reference to an undefined property is attempted on a sealed (nondynamic) object.
ReferenceError(message:String) — Constructor in class ReferenceError
 | Creates a new ReferenceError object.
REFLECT — Constant static property in class flash.display.SpreadMethod
 | Specifies that the gradient use the reflect spread method.
refresh() — Method in interface mx.collections.ICollectionView
 | Applies the sort and filter to the view.
refresh() — Method in class mx.collections.ListCollectionView
 | Applies the sort and filter to the view.
REFRESH — Constant static property in class mx.events.CollectionEventKind
 | Indicates that the collection applied a sort, a filter, or both.
regenerateStyleCache(recursive:Boolean) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | Sets up the internal style cache values so that the getStyle() method functions.
regenerateStyleCache(recursive:Boolean) — Method in class mx.core.UIComponent
 | Builds or rebuilds the CSS style cache for this component and, if the recursive parameter is true, for all descendants of this component as well.
regenerateStyleCache(recursive:Boolean) — Method in interface mx.styles.IStyleClient
 | Sets up the internal style cache values so that the getStyle() method functions.
RegExp — Dynamic class in Top Level
 | The RegExp class lets you work with regular expressions, which are patterns that you can use to perform searches in strings and to replace text in strings.
RegExp(re:String, flags:String) — Constructor in class RegExp
 | Lets you construct a regular expression from two strings.
RegExpValidationResult — Class in package mx.validators
 | The RegExpValidator class dispatches the valid and invalid events.
RegExpValidationResult(isError:Boolean, subField:String, errorCode:String, errorMessage:String, matchedString:String, matchedIndex:int, matchedSubstrings:Array) — Constructor in class mx.validators.RegExpValidationResult
 | Constructor
RegExpValidator — Class in package mx.validators
 | The RegExpValidator class lets you use a regular expression to validate a field.
RegExpValidator() — Constructor in class mx.validators.RegExpValidator
 | Constructor
register(obj:mx.managers:IHistoryManagerClient) — Static method in class mx.managers.HistoryManager
 | Registers an object with the HistoryManager.
registerApplication(app:flash.events:IEventDispatcher) — Method in class mx.preloaders.Preloader
 | Called by the SystemManager after it has finished instantiating an instance of the application class.
registerCacheHandler(valueName:String, handler:Function) — Static method in class mx.utils.DescribeTypeCache
 | registerCacheHandler lets you add function handler for specific strings.
registerClassAlias(aliasName, classObject) — Package function in flash.net
 | Preserves the class (type) of an object when the object is encoded in Action Message Format (AMF).
registerColorName(colorName:String, colorValue:uint) — Static method in class mx.styles.StyleManager
 | Adds a color name to the list of aliases for colors.
registerDataTransform(transform:mx.charts.chartClasses:DataTransform, dimensionName:String) — Method in class mx.charts.chartClasses.AxisBase
 | Each DataTransform that makes use of an axis registers itself with that axis.
registerDataTransform(transform:mx.charts.chartClasses:DataTransform, dimensionName:String) — Method in interface mx.charts.chartClasses.IAxis
 | Each DataTransform that makes use of an axis registers itself with that axis.
registerEffects(effects:Array) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | For each effect event, registers the EffectManager as one of the event listeners.
registerEffects(effects:Array) — Method in interface mx.core.IDeferredInstantiationUIComponent
 | For each effect event, register the EffectManager as one of the event listeners.
registerEffects(effects:Array) — Method in class mx.core.UIComponent
 | For each effect event, register the EffectManager as one of the event listeners.
registerEffects(effects:Array) — Method in interface mx.styles.IStyleClient
 | For each effect event, registers the EffectManager as one of the event listeners.
registerFont(font:Class) — Static method in class flash.text.Font
 | Registers a font class in the global font list.
registerInheritingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Adds to the list of styles that can inherit values from their parents.
registerParentDisplayListInvalidatingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Adds to the list of styles which may affect the appearance or layout of the component's parent container.
registerParentSizeInvalidatingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Adds to the list of styles which may affect the measured size of the component's parent container.
registerSizeInvalidatingStyle(styleName:String) — Static method in class mx.styles.StyleManager
 | Adds to the list of styles which may affect the measured size of the component.
REGULAR — Constant static property in class flash.text.FontStyle
 | Defines the plain style of a font for the fontStyle parameter in the setAdvancedAntiAliasingTable() method.
rejectCursor — Style in class mx.managers.DragManager
 | Cursor displayed for a reject operation.
rejected — Property in class mx.messaging.events.ChannelEvent
 | Indicates whether the Channel that generated this event was rejected.
relatedObject — Property in class flash.events.FocusEvent
 | A reference to the complementary InteractiveObject instance that is affected by the change in focus.
relatedObject — Property in class flash.events.MouseEvent
 | A reference to a display list object that is related to the event.
relatedObject — Property in class mx.events.ChildExistenceChangedEvent
 | Reference to the child object that was created or destroyed.
relatedObject — Property in class mx.events.IndexChangedEvent
 | The child object whose index changed, or the object associated with the new index.
relatedObject — Property in class mx.events.ItemClickEvent
 | The child object that generated the event; for example, the button that a user clicked in a ButtonBar control.
relativeTo — Property in class mx.charts.effects.SeriesZoom
 | Controls the bounding box that Flex uses to calculate the focal point of the zooms.
relativeTo — Property in class mx.charts.effects.effectClasses.SeriesZoomInstance
 | Controls the bounding box that Flex uses to calculate the focal point of the zooms.
relativeTo — Property in class mx.effects.AddChildAction
 | The location where the child component is added.
relativeTo — Property in class mx.effects.effectClasses.AddChildActionInstance
 | The location where the child component is added.
relativeTo — Property in class mx.states.AddChild
 | The object relative to which the child is added.
release() — Method in class mx.data.DataService
 | Releases all managed collections and items for the DataService.
release() — Method in class mx.data.mxml.DataService
 | Releases all managed collections and items for the DataService.
releaseCollection(view:mx.collections:ListCollectionView, clear:Boolean) — Method in class mx.data.DataService
 | Releases any item within the specified collection from management by this service.
releaseCollection(view:mx.collections:ListCollectionView, clear:Boolean) — Method in class mx.data.mxml.DataService
 | Releases any item within the specified collection from management by this service.
RELEASE_COLLECTION_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation indicates that the client is no longer interested in receiving notificaion of operations performed on the specified collection.
releaseItem(item:mx.data:IManaged, allowCopy:Boolean) — Method in class mx.data.DataService
 | Releases the specified item from management by this service.
releaseItem(clear:Boolean) — Method in class mx.data.ItemReference
 | Releases the managed item reference retrieved with the getItem() or createItem() method call that returned this ItemReference.
releaseItem(item:mx.data:IManaged, allowCopy:Boolean) — Method in class mx.data.mxml.DataService
 | Releases the specified item from management by this service.
RELEASE_ITEM_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation indicates that the client is no longer interested in receiving notification of operations performed on the specified item.
relevantProperties — Property in class mx.effects.Effect
 | An Array of property names to use when performing filtering.
relevantStyles — Property in class mx.effects.Effect
 | An Array of style names to use when performing filtering.
relevantStyles — Property in class mx.effects.SetStyleAction
 | Contains the style properties modified by this effect.
REMOTE — Constant static property in class flash.system.Security
 | The SWF file is from an Internet URL and operates under domain-based sandbox rules.
REMOTE_CREDENTIALS_HEADER — Constant static property in class mx.messaging.messages.AbstractMessage
 | Messages that need to set remote credentials for a destination carry the Base64 encoded credentials in this header.
RemoteObject — Dynamic class in package mx.rpc.remoting
 | The RemoteObject class gives you access to classes on a remote application server.
RemoteObject — Dynamic class in package mx.rpc.remoting.mxml
 | The <mx:RemoteObject> tag gives you access to the methods of Java objects using Action Message Format (AMF) encoding.
RemoteObject(destination:String) — Constructor in class mx.rpc.remoting.RemoteObject
 | Creates a new RemoteObject.
RemoteObject(destination:String) — Constructor in class mx.rpc.remoting.mxml.RemoteObject
 | Create a new RemoteObject.
RemotingMessage — Class in package mx.messaging.messages
 | RemotingMessages are used to send RPC requests to a remote endpoint.
RemotingMessage() — Constructor in class mx.messaging.messages.RemotingMessage
 | Constructs an uninitialized RemotingMessage.
remove — Property in class mx.charts.chartClasses.InstanceCache
 | Determines if unneeded instances should be removed from their parent.
remove() — Method in interface mx.collections.IViewCursor
 | Removes the current item and returns it.
remove — Event in class mx.core.UIComponent
 | Dispatched when the component is removed from a container as a content child by using the removeChild() or removeChildAt() method.
remove(parent:mx.core:UIComponent) — Method in class mx.states.AddChild
 | Removes the override.
remove(parent:mx.core:UIComponent) — Method in interface mx.states.IOverride
 | Removes the override.
remove(parent:mx.core:UIComponent) — Method in class mx.states.RemoveChild
 | Removes the override.
remove(parent:mx.core:UIComponent) — Method in class mx.states.SetEventHandler
 | Removes the override.
remove(parent:mx.core:UIComponent) — Method in class mx.states.SetProperty
 | Removes the override.
remove(parent:mx.core:UIComponent) — Method in class mx.states.SetStyle
 | Removes the override.
REMOVE — Constant static property in class mx.events.CollectionEventKind
 | Indicates that the collection removed an item or items.
REMOVE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.REMOVE constant defines the value of the type property of the event object for an remove event.
removeAll() — Method in interface mx.collections.IList
 | Removes all items from the list.
removeAll() — Method in class mx.collections.ListCollectionView
 | Remove all items from the list.
removeAllChildren() — Method in class mx.core.Container
 | Removes all children from the child list of this container.
removeAllCuePoints() — Method in class mx.controls.videoClasses.CuePointManager
 | Removes all cue points.
removeAllCursors() — Static method in class mx.managers.CursorManager
 | Removes all of the cursors from the cursor list and restores the system cursor.
removeBusyCursor() — Static method in class mx.managers.CursorManager
 | Removes the busy cursor from the cursor list.
removeChannel(channel:mx.messaging:Channel) — Method in class mx.messaging.ChannelSet
 | Removes a Channel from the ChannelSet.
removeChild(child:flash.display:DisplayObject) — Method in class flash.display.DisplayObjectContainer
 | Removes the specified child DisplayObject instance from the child list of the DisplayObjectContainer instance.
removeChild(child:flash.display:DisplayObject) — Method in class mx.core.Container
 | Removes a child DisplayObject from the child list of this Container.
removeChild(child:flash.display:DisplayObject) — Method in interface mx.core.IChildList
 | Removes the specified child DisplayObject from this child list.
RemoveChild — Class in package mx.states
 | The RemoveChild class removes a child display object, such as a component, from a container as part of a view state.
RemoveChild(target:flash.display:DisplayObject) — Constructor in class mx.states.RemoveChild
 | Constructor.
RemoveChildAction — Class in package mx.effects
 | The RemoveChildAction class defines an action effect that corresponds to the RemoveChild property of a view state definition.
RemoveChildAction(target:Object) — Constructor in class mx.effects.RemoveChildAction
 | Constructor.
RemoveChildActionInstance — Class in package mx.effects.effectClasses
 | The RemoveChildActionInstance class implements the instance class for the RemoveChildAction effect.
RemoveChildActionInstance(target:Object) — Constructor in class mx.effects.effectClasses.RemoveChildActionInstance
 | Constructor.
removeChildAt(index:int) — Method in class flash.display.DisplayObjectContainer
 | Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
removeChildAt(index:int) — Method in class flash.display.Stage
 | Removes a child DisplayObject from the specified index position in the child list of the DisplayObjectContainer.
removeChildAt(parent:Object, child:Object, index:int, model:Object) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
 | Removes the child node from a node at the specified index.
removeChildAt(parent:Object, child:Object, index:int, model:Object) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
 | Removes the child node from a node at the specified index.
removeChildAt(parent:Object, child:Object, index:int, model:Object) — Method in interface mx.controls.treeClasses.ITreeDataDescriptor
 | Removes a child node to a node at the specified index.
removeChildAt(index:int) — Method in class mx.core.Container
 | Removes a child DisplayObject from the child list of this Container at the specified index.
removeChildAt(index:int) — Method in interface mx.core.IChildList
 | Removes the child DisplayObject at the specified index from this child list.
removeCuePoint(cuePoint:Object) — Method in class mx.controls.videoClasses.CuePointManager
 | Removes a cue point from the currently loaded FLV file.
removeCursor(cursorID:int) — Static method in class mx.managers.CursorManager
 | Removes a cursor from the cursor list.
removed — Event in class flash.display.DisplayObject
 | Dispatched when a display object is about to be removed from the display list.
REMOVED — Constant static property in class flash.events.Event
 | Defines the value of the type property of a removed event object.
removedEffect — Effect in class mx.core.UIComponent
 | Played when the component is removed from a Container.
removeEventListener(type:String, listener:Function, useCapture:Boolean) — Method in class flash.events.EventDispatcher
 | Removes a listener from the EventDispatcher object.
removeEventListener(type:String, listener:Function, useCapture:Boolean) — Method in interface flash.events.IEventDispatcher
 | Removes a listener from the EventDispatcher object.
removeEventListener(type:String, listener:Function, useCapture:Boolean) — Method in class mx.collections.ListCollectionView
 | Removes a listener from the EventDispatcher object.
removeEventListener(type:String, listener:Function, useCapture:Boolean) — Method in class mx.utils.ObjectProxy
 | Removes an event listener.
removeFocusManager(f:mx.managers:IFocusManagerContainer) — Method in interface mx.managers.ISystemManager
 | Unregisters a top-level window containing a FocusManager.
removeFocusManager(f:mx.managers:IFocusManagerContainer) — Method in class mx.managers.SystemManager
 | Unregisters a top-level window containing a FocusManager.
removeHeader(qname:QName, headerName:String) — Method in class mx.rpc.soap.Operation
 | Removes the header with the given QName from all operations.
removeHeader(qname:QName, headerName:String) — Method in class mx.rpc.soap.WebService
 | Removes the header with the given QName from all operations.
removeIndicators(uid:String) — Method in class mx.controls.listClasses.ListBase
 | Cleans up selection highlights and other associated graphics for a given item in the data provider.
removeItemAt(index:int) — Method in interface mx.collections.IList
 | Removes the item at the specified index and returns it.
removeItemAt(index:int) — Method in class mx.collections.ListCollectionView
 | Removes the item at the specified index and returns it.
removeListenerHandler() — Method in class mx.validators.Validator
 | Disconnects all of the listeners for the valid and invalid events dispatched from the validator.
removeLogger(logger:mx.logging:ILogger) — Method in class mx.logging.AbstractTarget
 | Stops this target from receiving events from the specified logger.
removeLogger(logger:mx.logging:ILogger) — Method in interface mx.logging.ILoggingTarget
 | Stops this target from receiving events from the specified logger.
removeNamespace(ns:Namespace) — Method in class XML
 | Removes the given namespace for this object and all descendants.
removeNode() — Method in class flash.xml.XMLNode
 | Removes the specified XML object from its parent.
removePopUp(popUp:mx.core:IFlexDisplayObject) — Static method in class mx.managers.PopUpManager
 | Removes a popup window popped up by the createPopUp() or addPopUp() method.
removeTarget(target:mx.logging:ILoggingTarget) — Static method in class mx.logging.Log
 | Stops the specified target from receiving notification of log events.
render — Event in class flash.display.DisplayObject
 | Dispatched when the display list is about to be updated and rendered.
RENDER — Constant static property in class flash.events.Event
 | Defines the value of the type property of a render event object.
renderData — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | Stores the information necessary to render this series.
renderData — Property in class mx.charts.chartClasses.Series
 | Stores the information necessary to render this series.
renderData — Property in class mx.charts.series.BubbleSeries
 | Stores the information necessary to render this series.
renderData — Property in class mx.charts.series.PlotSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
RenderData — Class in package mx.charts.chartClasses
 | RenderData structures are used by chart elements to store all of the relevant values and data needed to fully render the chart.
RenderData(cache:Array, filteredCache:Array) — Constructor in class mx.charts.chartClasses.RenderData
 | Constructor.
renderDataType — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderDataType — Property in class mx.charts.series.AreaSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderDataType — Property in class mx.charts.series.BarSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderDataType — Property in class mx.charts.series.BubbleSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderDataType — Property in class mx.charts.series.ColumnSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderDataType — Property in class mx.charts.series.LineSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderDataType — Property in class mx.charts.series.PieSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderDataType — Property in class mx.charts.series.PlotSeries
 | The subtype of ChartRenderData used by this series to store all data necessary to render.
renderedBase — Property in class mx.charts.series.renderData.AreaSeriesRenderData
 | The vertical position of the base of the area series, in pixels.
renderedBase — Property in class mx.charts.series.renderData.BarSeriesRenderData
 | The horizontal position of the base of the bars, in pixels.
renderedBase — Property in class mx.charts.series.renderData.ColumnSeriesRenderData
 | The vertical position of the base of the columns, in pixels.
renderedHalfWidth — Property in class mx.charts.series.renderData.BarSeriesRenderData
 | Half the width of a bar, in pixels.
renderedHalfWidth — Property in class mx.charts.series.renderData.ColumnSeriesRenderData
 | Half the width of a column, in pixels.
renderedHalfWidth — Property in class mx.charts.series.renderData.HLOCSeriesRenderData
 | Half the width of an item, in pixels.
renderedXOffset — Property in class mx.charts.series.renderData.ColumnSeriesRenderData
 | The offset of each column from its x value, in pixels.
renderedXOffset — Property in class mx.charts.series.renderData.HLOCSeriesRenderData
 | The offset of each item from its x value, in pixels.
renderedYOffset — Property in class mx.charts.series.renderData.BarSeriesRenderData
 | The offset of each bar from its y value, in pixels.
rendererChanged — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates that the renderer changed.
rendererIsEditor — Property in class mx.controls.List
 | Specifies whether the item renderer is also an item editor.
rendererIsEditor — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A flag that indicates that the item renderer is also an item editor.
repeat — Event in class mx.core.Repeater
 | Dispatched each time an item is processed and the currentIndex and currentItem properties are updated.
repeat — Property in class mx.graphics.BitmapFill
 | Whether the bitmap is repeated to fill the area.
REPEAT — Constant static property in class flash.display.SpreadMethod
 | Specifies that the gradient use the repeat spread method.
REPEAT — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.REPEAT constant defines the value of the type property of the event object for a repeat event.
repeatCount — Property in class flash.utils.Timer
 | The total number of times the timer is set to run.
repeatCount — Property in class mx.effects.Effect
 | Number of times to repeat the effect.
repeatCount — Property in class mx.effects.EffectInstance
 | Number of times to repeat the effect.
repeatDelay — Style in class mx.controls.Button
 | Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at each repeatInterval.
repeatDelay — Style in class mx.controls.HScrollBar
 | Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the repeatInterval.
repeatDelay — Style in class mx.controls.VScrollBar
 | Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the repeatInterval.
repeatDelay — Style in class mx.core.ScrollControlBase
 | Number of milliseconds to wait after the first buttonDown event before repeating buttonDown events at the value specified by repeatInterval.
repeatDelay — Property in class mx.effects.Effect
 | Amount of time, in milliseconds, to wait before repeating the effect.
repeatDelay — Property in class mx.effects.EffectInstance
 | Amount of time, in milliseconds, to wait before repeating the effect.
repeatEnd — Event in class mx.core.Repeater
 | Dispatched after all the subcomponents of a repeater are created.
REPEAT_END — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.REPEAT_END constant defines the value of the type property of the event object for a repeatEnd event.
repeater — Property in class mx.core.UIComponent
 | A reference to the Repeater object in the parent document that produced this UIComponent.
Repeater — Class in package mx.core
 | The Repeater class is the runtime object that corresponds to the <mx:Repeater> tag.
Repeater() — Constructor in class mx.core.Repeater
 | Constructor.
repeaterIndex — Property in class mx.core.UIComponent
 | The index of the item in the data provider of the Repeater that produced this UIComponent.
repeaterIndices — Property in interface mx.core.IRepeaterClient
 | An Array that contains the indices of the items in the data providers of the Repeaters that produced the component.
repeaterIndices — Property in class mx.core.UIComponent
 | An Array containing the indices of the items in the data provider of the Repeaters in the parent document that produced this UIComponent.
repeaters — Property in interface mx.core.IRepeaterClient
 | An Array that contains any enclosing Repeaters of the component.
repeaters — Property in class mx.core.UIComponent
 | An Array containing references to the Repeater objects in the parent document that produced this UIComponent.
repeatInterval — Style in class mx.controls.Button
 | Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button.
repeatInterval — Style in class mx.controls.HScrollBar
 | Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button.
repeatInterval — Style in class mx.controls.VScrollBar
 | Number of milliseconds between buttonDown events if the user presses and holds the mouse on a button.
repeatInterval — Style in class mx.core.ScrollControlBase
 | Number of milliseconds between buttonDown events if the user presses and holds on a button.
repeatStart — Event in class mx.core.Repeater
 | Dispatched when Flex begins processing the dataProvider property and begins creating the specified subcomponents.
REPEAT_START — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.REPEAT_START constant defines the value of the type property of the event object for a repeatStart event.
replace(pattern, repl:Object) — Method in class String
 | Matches the specifed pattern against the string and returns a new string in which the first match of pattern is replaced with the content specified by repl.
replace(propertyName:Object, value:XML) — Method in class XML
 | Replaces the properties specified by the propertyName parameter with the given value parameter.
replace — Property in class mx.data.messages.UpdateCollectionMessage
 | Indicates if the entire collection should be replaced by the contents of this message.
REPLACE — Constant static property in class mx.events.CollectionEventKind
 | Indicates that the item at the position identified by the CollectionEvent location property has been replaced.
replacePort(uri:String, newPort:uint) — Static method in class mx.utils.URLUtil
 | Returns a new string with the port replaced with the specified port.
replaceProtocol(uri:String, newProtocol:String) — Static method in class mx.utils.URLUtil
 | This method will replace the protocol of the specified uri with the given protocol.
replaceSelectedText(value:String) — Method in class flash.text.TextField
 | Replaces the current selection with the contents of the value parameter.
replaceText(beginIndex:int, endIndex:int, newText:String) — Method in class flash.text.TextField
 | Replaces the range of characters that the beginIndex and endIndex parameters specify with the contents of the newText parameter.
replaceTokens(url:String) — Static method in class mx.utils.URLUtil
request — Property in class mx.rpc.http.HTTPService
 | Object of name-value pairs used as parameters to the URL.
request — Property in class mx.rpc.soap.Operation
 | The request of the Operation is an object structure or an XML structure.
requestHeaders — Property in class flash.net.URLRequest
 | The array of HTTP request headers to be appended to the HTTP request.
requestTimedOut() — Method in class mx.messaging.MessageResponder
 | Subclasses must override this method to handle a request timeout and invoke the proper callbacks on the associated MessageAgent.
requestTimeout — Property in class mx.data.DataService
 | Provides access to the request timeout in seconds for an operation.
requestTimeout — Property in class mx.data.DataStore
 | Provides access to the request timeout in seconds for an operation.
requestTimeout — Property in class mx.data.mxml.DataService
 | Provides access to the request timeout in seconds for an operation.
requestTimeout — Property in class mx.messaging.Channel
 | Provides access to the default request timeout in seconds for the channel.
requestTimeout — Property in class mx.messaging.MessageAgent
 | Provides access to the request timeout in seconds for sent messages.
requestTimeout — Property in class mx.rpc.AbstractService
 | Provides access to the request timeout in seconds for sent messages.
requestTimeout — Property in class mx.rpc.http.HTTPService
 | Provides access to the request timeout in seconds for sent messages.
REQUEST_TIMEOUT_HEADER — Constant static property in class mx.messaging.messages.AbstractMessage
 | Messages sent with a defined request timeout use this header.
required — Property in class mx.containers.FormItem
 | If true, display an indicator that the FormItem children require user input.
required — Property in class mx.validators.Validator
 | If true, specifies that a missing or empty value causes a validation error.
REQUIRED_BOUNDED_VALUES — Constant static property in class mx.charts.chartClasses.DataDescription
 | A bitflag passed by the axis to an element's describeData() method.
requiredDescribedFields — Property in class mx.charts.DateTimeAxis
 | The fields of the DescribeData structure that this axis is interested in.
requiredDescribedFields — Property in class mx.charts.chartClasses.NumericAxis
 | The fields of the DescribeData structure that this axis is interested in.
requiredFieldError — Property in class mx.validators.Validator
 | Error message when a value is missing and the required property is true.
REQUIRED_MIN_INTERVAL — Constant static property in class mx.charts.chartClasses.DataDescription
 | A bitflag passed by the axis to an element's describeData() method.
REQUIRED_MIN_MAX — Constant static property in class mx.charts.chartClasses.DataDescription
 | A bitflag passed by the axis to an element's describeData() method.
REQUIRED_PADDING — Constant static property in class mx.charts.chartClasses.DataDescription
 | A bitflag passed by the axis to an element's describeData() method.
reserveExplodeRadius — Property in class mx.charts.series.PieSeries
 | A number from 0 to 1, specifying how much of the total radius of the pie series should be reserved to explode wedges at runtime.
reset() — Method in class flash.utils.Timer
 | Stops the timer, if it is running, and sets the currentCount property back to 0, like the reset button of a stopwatch.
reset(newHost:Object) — Method in class mx.binding.utils.ChangeWatcher
 | Resets this ChangeWatcher instance to use a new host object.
RESET — Constant static property in class mx.events.CollectionEventKind
 | Indicates that the collection has changed so drastically that a reset is required.
resetHistory — Property in class mx.core.Application
 | If true, the application's history state is reset to its initial state whenever the application is reloaded.
resetNavItems() — Method in class mx.controls.NavBar
 | Resets the navigator bar to its default state.
resizable — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A flag that indicates whether the user is allowed to resize the width of the column.
resizableColumns — Property in class mx.controls.DataGrid
 | A flag that indicates whether the user can change the size of the columns.
resize — Event in class flash.display.Stage
 | Dispatched when the scaleMode property of the Stage object is set to StageScaleMode.NO_SCALE and the SWF file is resized.
resize — Event in class mx.core.UIComponent
 | Dispatched when the component is resized.
resize — Event in class mx.managers.SystemManager
 | Dispatched when the Stage is resized.
Resize — Class in package mx.effects
 | The Resize effect changes the width, height, or both dimensions of a component over a specified time interval.
Resize(target:Object) — Constructor in class mx.effects.Resize
 | Constructor.
RESIZE — Constant static property in class flash.events.Event
 | Defines the value of the type property of a resize event object.
RESIZE — Constant static property in class mx.events.ResizeEvent
 | The ResizeEvent.RESIZE constant defines the value of the type property of the event object for a resize event.
resizeEffect — Effect in class mx.core.UIComponent
 | Played when the component is resized.
resizeEndEffect — Effect in class mx.containers.Panel
 | Specifies the effect to play after a Resize effect finishes playing.
ResizeEvent — Class in package mx.events
 | Represents event objects that are dispatched when the size of a Flex component changes.
ResizeEvent(type:String, bubbles:Boolean, cancelable:Boolean, oldWidth:Number, oldHeight:Number) — Constructor in class mx.events.ResizeEvent
 | Constructor.
ResizeInstance — Class in package mx.effects.effectClasses
 | The ResizeInstance class implements the instance class for the Resize effect.
ResizeInstance(target:Object) — Constructor in class mx.effects.effectClasses.ResizeInstance
 | Constructor.
resizeStartEffect — Effect in class mx.containers.Panel
 | Specifies the effect to play before a Resize effect begins playing.
resizeToContent — Property in class mx.containers.Accordion
 | If set to true, this Accordion automatically resizes to the size of its current child.
resizeToContent — Property in class mx.containers.DividedBox
 | If true, the DividedBox automatically resizes to the size of its children.
resizeToContent — Property in class mx.containers.ViewStack
 | If true, the ViewStack container automatically resizes to the size of its current child.
RESIZING — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property when the VideoDisplay control is resizing.
resolved — Property in class mx.data.Conflict
 | Indicates whether this Conflict has been resolved (acceptClient() or acceptServer() has been called).
resolved — Property in class mx.data.Conflicts
 | Indicates if there are any unresolved conflicts in the list.
ResourceBundle — Class in package mx.resources
 | This class can be used to internationalize the framework and applications.
ResourceBundle() — Constructor in class mx.resources.ResourceBundle
 | Constructor.
responder — Property in class mx.data.errors.NoDataAvailableError
 | If the data is not local and an asynchronous operation must be performed, an NoDataAvailableError will be thrown.
Responder — Class in package flash.net
 | The Responder class provides an object that is used in NetConnection.call() to handle return values from the server.
Responder(result:Function, status:Function) — Constructor in class flash.net.Responder
 | Creates a new Responder object.
responders — Property in class mx.collections.errors.ItemPendingError
 | An array of IResponder handlers that will be called when the asynchronous request completes.
responders — Property in class mx.rpc.AsyncToken
 | An array of IResponder handlers that will be called when the asynchronous request completes.
... (rest) parameter — Statement
 | Specifies that a function will accept any number of comma-delimited arguments.
restrict — Property in class flash.text.TextField
 | Indicates the set of characters that a user can enter into the text field.
restrict — Property in class mx.controls.ComboBase
 | Set of characters that a user can or cannot enter into the text field.
restrict — Property in class mx.controls.TextArea
 | Indicates the set of characters that a user can enter into the control.
restrict — Property in class mx.controls.TextInput
 | Indicates the set of characters that a user can enter into the control.
resubscribeAttempts — Property in class mx.messaging.Consumer
 | The number of resubscribe attempts that the Consumer makes in the event that the connection to its destination fails.
resubscribeInterval — Property in class mx.messaging.Consumer
 | The number of milliseconds between resubscribe attempts.
result(data:Object) — Method in class mx.collections.ItemResponder
 | This method is called by a service when the return value has been received.
result — Event in class mx.data.DataService
 | The ResultEvent.RESULT event is dispatched when a service call successfully returns.
result — Event in class mx.data.DataStore
 | The ResultEvent.RESULT event is dispatched when the commit call successfully returns.
result(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageResponder
 | Called by the channel that created this MessageResponder when a response returns from the destination.
result — Event in class mx.rpc.AbstractOperation
 | Dispatched when an Operation invocation successfully returns.
result — Event in class mx.rpc.AbstractService
 | The result event is dispatched when a service call successfully returns and isn't handled by the Operation itself.
result — Property in class mx.rpc.AsyncToken
 | The result that was returned by the associated RPC call.
result(data:Object) — Method in interface mx.rpc.IResponder
 | This method is called by a service when the return value has been received.
result — Property in class mx.rpc.events.ResultEvent
 | Result that the RPC call returns.
result — Event in class mx.rpc.http.HTTPService
 | Dispatched when an HTTPService call returns successfully.
RESULT — Constant static property in class mx.messaging.events.MessageEvent
 | The RESULT event type; dispatched when an RPC agent receives a result from a remote service destination.
RESULT — Constant static property in class mx.rpc.events.ResultEvent
 | The RESULT event type.
ResultEvent — Class in package mx.rpc.events
 | The event that indicates an RPC operation has successfully returned a result.
ResultEvent(type:String, bubbles:Boolean, cancelable:Boolean, result:Object, token:mx.rpc:AsyncToken, message:mx.messaging.messages:IMessage) — Constructor in class mx.rpc.events.ResultEvent
 | Create a new ResultEvent.
resultFormat — Property in class mx.rpc.http.HTTPService
 | Value that indicates how you want to deserialize the result returned by the HTTP call.
resultFormat — Property in class mx.rpc.soap.Operation
 | Determines how the Operation result is decoded.
RESULT_FORMAT_ARRAY — Constant static property in class mx.rpc.http.HTTPService
 | The result format "array" is similar to "object" however the value returned is always an Array such that if the result returned from result format "object" is not an Array already the item will be added as the first item to a new Array.
RESULT_FORMAT_E4X — Constant static property in class mx.rpc.http.HTTPService
 | The result format "e4x" specifies that the value returned is an XML instance, which can be accessed using ECMAScript for XML (E4X) expressions.
RESULT_FORMAT_FLASHVARS — Constant static property in class mx.rpc.http.HTTPService
 | The result format "flashvars" specifies that the value returned is text containing name=value pairs separated by ampersands, which is parsed into an ActionScript object.
RESULT_FORMAT_OBJECT — Constant static property in class mx.rpc.http.HTTPService
 | The result format "object" specifies that the value returned is XML but is parsed as a tree of ActionScript objects.
RESULT_FORMAT_TEXT — Constant static property in class mx.rpc.http.HTTPService
 | The result format "text" specifies that the HTTPService result text should be an unprocessed String.
RESULT_FORMAT_XML — Constant static property in class mx.rpc.http.HTTPService
 | The result format "xml" specifies that results should be returned as an flash.xml.XMLNode instance pointing to the first child of the parent flash.xml.XMLDocument.
resultHandler(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageResponder
 | Subclasses must override this method to perform custom processing of the result and invoke the proper callbacks on the associated MessageAgent.
resultHeaders — Property in class mx.rpc.soap.Operation
 | The headers that were returned as part of the last execution of this operation.
results — Property in class mx.events.ValidationResultEvent
 | An array of ValidationResult objects, one per validated field.
resume() — Method in class flash.net.NetStream
 | Resumes playback of a video stream that is paused.
resume() — Method in class mx.effects.Effect
 | Resumes the effect after it has been paused by a call to the pause() method.
resume() — Method in class mx.effects.EffectInstance
 | Resumes the effect after it has been paused by a call to the pause() method.
resume() — Method in class mx.effects.Tween
 | Resumes the effect after it has been paused by a call to the pause() method.
resume() — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Resumes the effect after it has been paused by a call to the pause() method.
resumeBackgroundProcessing() — Static method in class mx.core.UIComponent
 | Resumes the background processing of methods queued by callLater(), after a call to suspendBackgroundProcessing().
resumeEventHandling() — Static method in class mx.effects.EffectManager
 | Allows the EffectManager class to resume processing events after a call to the suspendEventHandling() method.
RETRYABLE_HINT_HEADER — Constant static property in class mx.messaging.messages.ErrorMessage
 | Header name for the retryable hint header.
return — Statement
 | Causes execution to return immediately to the calling function.
RETURNINDEXEDARRAY — Constant static property in class Array
 | Specifies that a sort returns an array that consists of array indices.
returnType — Property in class mx.messaging.management.MBeanOperationInfo
 | The return data type for the operation.
reverse() — Method in class Array
 | Reverses the array in place.
reverse() — Method in class mx.collections.Sort
 | Goes through all SortFields and calls reverse() on them.
reverse() — Method in class mx.collections.SortField
 | Reverse the criteria for this sort field.
reverse() — Method in class mx.effects.Effect
 | Plays the effect in reverse, if the effect is currently playing, starting from the current position of the effect.
reverse() — Method in class mx.effects.EffectInstance
 | Plays the effect in reverse, starting from the current position of the effect.
reverse() — Method in class mx.effects.Tween
 | Plays the effect in reverse, starting from the current position of the effect.
reverse() — Method in class mx.effects.effectClasses.MaskEffectInstance
 | Plays the effect in reverse, starting from the current position of the effect.
revertChanges(item:mx.data:IManaged) — Method in class mx.data.DataService
 | Reverts any uncommitted changes to the specified item.
revertChanges() — Method in class mx.data.DataStore
 | Reverts all pending (uncommitted) changes for all DataServices managed by this DataStore.
revertChanges(item:mx.data:IManaged) — Method in class mx.data.mxml.DataService
 | Reverts any uncommitted changes to the specified item.
rewind — Property in class flash.ui.ContextMenuBuiltInItems
 | Lets the user set a SWF file to play from the first frame when selected, at any time (does not appear for a single-frame SWF file).
rewind — Event in class mx.controls.VideoDisplay
 | Dispatched when the control autorewinds.
REWIND — Constant static property in class mx.events.VideoEvent
 | The VideoEvent.REWIND constant defines the value of the type property of the event object for a rewind event.
REWINDING — Constant static property in class mx.events.VideoEvent
 | The value of the VideoDisplay.state property during an autorewind triggered when play stops.
RGB — Constant static property in class flash.display.InterpolationMethod
 | Specifies that the RGB interpolation method should be used.
rgbMultiply(rgb1:uint, rgb2:uint) — Static method in class mx.utils.ColorUtil
 | Performs an RGB multiplication of two RGB colors.
RichTextEditor — Class in package mx.controls
 | The RichTextEditor control lets users enter and format text.
right — Property in class flash.geom.Rectangle
 | The sum of the x and width properties.
right — Property in class mx.core.EdgeMetrics
 | The width, in pixels, of the right edge region.
right — Style in class mx.core.UIComponent
 | The horizontal distance in pixels from the right edge of the component to the right edge of its parent container.
RIGHT — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned to the right.
RIGHT — Constant static property in class flash.text.TextFieldAutoSize
 | Specifies that the text is to be treated as right-justified text, meaning that the right side of the text field remains fixed and any resizing of a single line is on the left side.
RIGHT — Constant static property in class flash.text.TextFormatAlign
 | Constant; aligns text to the right within the text field.
RIGHT — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Right Arrow key (39).
RIGHT — Constant static property in class flash.ui.KeyLocation
 | Indicates the key activated is in the right key location (there is more than one possible location for this key).
RIGHT — Constant static property in class mx.controls.ButtonLabelPlacement
 | Specifies that the label appears to the right of the icon.
RIGHT — Constant static property in class mx.controls.ProgressBarDirection
 | Specifies to fill the progress bar from the left to the right.
RIGHT — Constant static property in class mx.controls.ProgressBarLabelPlacement
 | Specifies to place the label to the right of the progress bar.
RIGHT — Constant static property in class mx.validators.CurrencyValidatorAlignSymbol
 | Specifies "right" as the alignment of the currency symbol for the CurrencyValidator class.
rightMargin — Property in class flash.text.TextFormat
 | The right margin of the paragraph, in pixels.
rightPeak — Property in class flash.media.SoundChannel
 | The current amplitude (volume) of the right channel, from 0 (silent) to 1 (full amplitude).
rightToLeft — Property in class flash.media.SoundTransform
 | A value, from 0 (none) to 1 (all), specifying how much of the right input is played in the left speaker.
rightToRight — Property in class flash.media.SoundTransform
 | A value, from 0 (none) to 1 (all), specifying how much of the right input is played in the right speaker.
role — Property in class mx.rpc.soap.SOAPHeader
 | Specifies the URI for the role that this header is intended in a potential chain of endpoints processing a SOAP request.
rollOut — Event in class flash.display.InteractiveObject
 | Dispatched when the user moves a pointing device away from an InteractiveObject instance.
ROLL_OUT — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a rollOut event object.
rollOutEffect — Effect in class mx.core.UIComponent
 | Played when the user rolls the mouse so it is no longer over the component.
rollOutHandler(event:flash.events:MouseEvent) — Method in class mx.controls.Button
 | The default handler for the MouseEvent.ROLL_OUT event.
rollOver — Event in class flash.display.InteractiveObject
 | Dispatched when the user moves a pointing device over an InteractiveObject instance.
ROLL_OVER — Constant static property in class flash.events.MouseEvent
 | Defines the value of the type property of a rollOver event object.
rollOverColor — Style in class mx.controls.ComboBox
 | The rollOverColor of the drop-down list.
rollOverColor — Style in class mx.controls.DataGrid
 | The color of the row background when the user rolls over the row.
rollOverColor — Style in class mx.controls.DateChooser
 | Color of the highlight area of the date when the user holds the mouse pointer over a date in the DateChooser control.
rollOverColor — Style in class mx.controls.DateField
 | Color of the highlight area of the date when the user holds the mouse pointer over a date in the DateChooser control.
rollOverColor — Style in class mx.controls.LinkBar
 | Color of links as you roll the mouse pointer over them.
rollOverColor — Style in class mx.controls.LinkButton
 | Color of a LinkButton as a user moves the mouse pointer over it.
rollOverColor — Style in class mx.controls.Menu
 | The color of the menu item background when a user rolls the mouse over it.
rollOverColor — Style in class mx.controls.MenuBar
 | The color of the menu item background when a user rolls the mouse over it.
rollOverColor — Style in class mx.controls.Tree
 | Color of the background when the user rolls over the link.
rollOverColor — Style in class mx.controls.listClasses.ListBase
 | The color of the background of a renderer when the user rolls over it.
rollOverEffect — Effect in class mx.core.UIComponent
 | Played when the user rolls the mouse over the component.
rollOverHandler(event:flash.events:MouseEvent) — Method in class mx.controls.Button
 | The default handler for the MouseEvent.ROLL_OVER event.
rollOverIndicatorSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the highlight area of the date when the user holds the mouse pointer over a date in the DateChooser control.
ROMAN_LETTERS — Constant static property in class mx.validators.Validator
 | A string containing the upper- and lower-case letters of the Roman alphabet ("A" through "Z" and "a" through "z").
root — Property in class flash.display.DisplayObject
 | For a display object in a loaded SWF file, the root property is the top-most display object in the portion of the display list's tree structure represented by that SWF file.
rootCause — Property in class mx.messaging.events.ChannelFaultEvent
 | Provides access to the underlying reason for the failure if the channel did not raise the failure itself.
rootCause — Property in class mx.messaging.events.MessageFaultEvent
 | Provides access to the root cause of the failure, if one exists.
rootCause — Property in class mx.messaging.messages.ErrorMessage
 | Should a root cause exist for the error, this property contains those details.
rootCause — Property in class mx.rpc.Fault
 | The cause of the fault.
rootURL — Property in class mx.rpc.http.HTTPService
 | The URL that the HTTPService object should use when computing relative URLs.
rootURL — Property in class mx.rpc.soap.WebService
 | The URL that the WebService should use when computing relative URLs.
rotate(angle:Number) — Method in class flash.geom.Matrix
 | Applies a rotation transformation to the Matrix object.
Rotate — Class in package mx.effects
 | The Rotate effect rotates a component around a specified point.
Rotate(target:Object) — Constructor in class mx.effects.Rotate
 | Constructor.
rotatedGradientMatrix(x:Number, y:Number, width:Number, height:Number, rotation:Number) — Method in class mx.skins.ProgrammaticSkin
 | Utility function to create a rotated gradient matrix.
RotateInstance — Class in package mx.effects.effectClasses
 | The RotateInstance class implements the instance class for the Rotate effect.
RotateInstance(target:Object) — Constructor in class mx.effects.effectClasses.RotateInstance
 | Constructor.
rotation — Property in class flash.display.DisplayObject
 | Indicates the rotation of the DisplayObject instance, in degrees, from its original orientation.
rotation — Property in class mx.graphics.BitmapFill
 | The number of degrees to rotate the bitmap.
round(val:Number) — Static method in class Math
 | Rounds the value of the parameter val up or down to the nearest integer and returns the value.
ROUND — Constant static property in class flash.display.CapsStyle
 | Used to specify round caps in the caps parameter of the flash.display.Graphics.lineStyle() method.
ROUND — Constant static property in class flash.display.JointStyle
 | Specifies round joints in the joints parameter of the flash.display.Graphics.lineStyle() method.
roundedBottomCorners — Style in class mx.containers.Panel
 | Flag to enable rounding for the bottom two corners of the container.
RoundedRectangle — Class in package mx.graphics
 | RoundedRectangle represents a Rectangle with curved corners
RoundedRectangle(x:Number, y:Number, width:Number, height:Number, cornerRadius:Number) — Constructor in class mx.graphics.RoundedRectangle
 | Constructor.
rounding — Property in class mx.formatters.CurrencyFormatter
 | How to round the number.
rounding — Property in class mx.formatters.NumberFormatter
 | Specifies how to round the number.
roundValue — Property in class mx.effects.AnimateProperty
 | If true, round off the interpolated tweened value to the nearest integer.
roundValue — Property in class mx.effects.effectClasses.AnimatePropertyInstance
 | If true, round off the interpolated tweened value to the nearest integer.
rowCount — Property in class mx.controls.ComboBox
 | Maximum number of rows visible in the ComboBox control list.
rowCount — Property in class mx.controls.listClasses.ListBase
 | Number of rows to be displayed.
rowHeight — Property in class mx.controls.listClasses.ListBase
 | The height of the rows in pixels.
rowIndex — Property in class mx.controls.listClasses.BaseListData
 | The index of the item in the data provider.
rowIndex — Property in class mx.events.DataGridEvent
 | The zero-based index of the item in the data provider.
rowIndex — Property in class mx.events.ListEvent
 | In the zero-based index of the row that contains the item renderer where the event occured, or for editing events, the index of the item in the data provider that is being edited.
rowInfo — Property in class mx.controls.listClasses.ListBase
 | An array of ListRowInfo objects that cache row heights and other tracking information for the rows in listItems.
rowMap — Property in class mx.controls.listClasses.ListBase
 | A hash map of item renderers to their respective ListRowInfo object.
rowSpan — Property in class mx.containers.GridItem
 | Number of rows of the Grid container spanned by the cell.
RSL_COMPLETE — Constant static property in class mx.events.RSLEvent
 | Dispatched when the RSL has finished downloading.
rslCompleteHandler(event:mx.events:RSLEvent) — Method in class mx.preloaders.DownloadProgressBar
 | Event listener for the RSLEvent.RSL_COMPLETE event.
RSL_ERROR — Constant static property in class mx.events.RSLEvent
 | Dispatched when there is an error downloading the RSL.
rslErrorHandler(event:mx.events:RSLEvent) — Method in class mx.preloaders.DownloadProgressBar
 | Event listener for the RSLEvent.RSL_ERROR event.
RSLEvent — Class in package mx.events
 | The RSLEvent class represents an event object used by the DownloadProgressBar class when an RSL is being downloaded by the Preloader class.
RSLEvent(type:String, bubbles:Boolean, cancelable:Boolean, bytesLoaded:int, bytesTotal:int, rslIndex:int, rslTotal:int, url:flash.net:URLRequest, errorText:String) — Constructor in class mx.events.RSLEvent
 | Constructor.
rslIndex — Property in class mx.events.RSLEvent
 | The index number of the RSL currently being downloaded.
RSL_PROGRESS — Constant static property in class mx.events.RSLEvent
 | Dispatched when the RSL is downloading.
rslProgressHandler(event:mx.events:RSLEvent) — Method in class mx.preloaders.DownloadProgressBar
 | Event listener for the RSLEvent.RSL_PROGRESS event.
rslTotal — Property in class mx.events.RSLEvent
 | The total number of RSLs being downloaded by the preloader
RTMPChannel — Class in package mx.messaging.channels
 | The RTMPChannel class provides basic RTMP support for messaging.
RTMPChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.RTMPChannel
 | Creates an new RTMPChannel instance.
running — Property in class flash.utils.Timer
 | The timer's current state; true if the timer is running, otherwise false.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


S Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
S Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
sameDomain — Property in class flash.display.LoaderInfo
Expresses the domain relationship between the loader and the content: true if they have the same origin domain; false otherwise.
sandboxType — Static property in class flash.system.Security
Indicates the type of security sandbox in which the calling SWF file is operating.
save — Property in class flash.ui.ContextMenuBuiltInItems
Lets the user with Shockmachine installed save a SWF file.
save() — Static method in class mx.managers.HistoryManager
Saves the application's current state so it can be restored later.
saveStartValue() — Method in class mx.effects.effectClasses.ActionEffectInstance
Subclasses implement this method to save the starting state before the effect plays.
saveState() — Method in class mx.containers.Accordion
Saves the state of this object.
saveState() — Method in class mx.containers.ViewStack
Saves the state of this object.
saveState() — Method in interface mx.managers.IHistoryManagerClient
Saves the state of this object.
scale(sx:Number, sy:Number) — Method in class flash.geom.Matrix
Applies a scaling transformation to the matrix.
scale9Grid — Property in class flash.display.DisplayObject
The current scaling grid that is in effect.
scaleContent — Property in class mx.controls.SWFLoader
If true, the content scales to fit the SWFLoader control.
scaleEasingFunction — Property in class mx.effects.MaskEffect
Easing function to use for scaling the mask.
scaleEasingFunction — Property in class mx.effects.effectClasses.MaskEffectInstance
Easing function to use for scaling the mask.
scaleMode — Property in class flash.display.Stage
A value from the StageScaleMode class that specifies which scale mode to use.
scaleMode — Property in class mx.graphics.LinearGradientStroke
A value from the LineScaleMode class that specifies which scale mode to use.
scaleMode — Property in class mx.graphics.Stroke
Specifies how to scale a stroke.
scaleX — Property in class flash.display.DisplayObject
Indicates the horizontal scale (percentage) of the object as applied from the registration point.
scaleX — Property in class flash.filters.DisplacementMapFilter
The multiplier to use to scale the x displacement result from the map calculation.
scaleX — Property in interface mx.core.IFlexDisplayObject
The horizontal scaling factor for this object.
scaleX — Property in class mx.core.UIComponent
Number that specifies the horizontal scaling factor.
scaleX — Property in class mx.graphics.BitmapFill
The percent to horizontally scale the bitmap when filling, from 0 to 1.
scaleXFrom — Property in class mx.effects.MaskEffect
Initial scaleX for mask.
scaleXFrom — Property in class mx.effects.effectClasses.MaskEffectInstance
Initial scaleX for mask.
scaleXTo — Property in class mx.effects.MaskEffect
Ending scaleX for mask.
scaleXTo — Property in class mx.effects.effectClasses.MaskEffectInstance
Ending scaleX for mask.
scaleY — Property in class flash.display.DisplayObject
Indicates the vertical scale (percentage) of an object as applied from the registration point of the object.
scaleY — Property in class flash.filters.DisplacementMapFilter
The multiplier to use to scale the y displacement result from the map calculation.
scaleY — Property in interface mx.core.IFlexDisplayObject
The vertical scaling factor for this object.
scaleY — Property in class mx.core.UIComponent
Number that specifies the vertical scaling percentage.
scaleY — Property in class mx.graphics.BitmapFill
The percent to vertically scale the bitmap when filling, from 0 to 1.
scaleYFrom — Property in class mx.effects.MaskEffect
Initial scaleY for mask.
scaleYFrom — Property in class mx.effects.effectClasses.MaskEffectInstance
Initial scaleY for mask.
scaleYTo — Property in class mx.effects.MaskEffect
Ending scaleY for mask.
scaleYTo — Property in class mx.effects.effectClasses.MaskEffectInstance
Ending scaleY for mask.
Scene — Final class in package flash.display
The Scene class includes properties for identifying the name, labels, and number of frames in a scene.
scenes — Property in class flash.display.MovieClip
An array of Scene objects, each listing the name, the number of frames, and the frame labels for a scene in the MovieClip instance.
screen — Property in interface mx.core.IToolTip
A Rectangle that specifies the size and position of the base drawing surface for this tooltip.
screen — Property in class mx.core.UIComponent
Returns an object that contains the size and position of the base drawing surface for this object.
screen — Property in interface mx.managers.ISystemManager
The size and position of the application window.
screen — Property in class mx.managers.SystemManager
The size and position of the application window.
SCREEN — Constant static property in class flash.display.BlendMode
Multiplies the complement (inverse) of the display object color by the complement of the background color, resulting in a bleaching effect.
screenColor — Static property in class flash.system.Capabilities
Specifies the screen color.
screenDPI — Static property in class flash.system.Capabilities
Specifies the dots-per-inch (dpi) resolution of the screen, in pixels.
screenResolutionX — Static property in class flash.system.Capabilities
Specifies the maximum horizontal resolution of the screen.
screenResolutionY — Static property in class flash.system.Capabilities
Specifies the maximum vertical resolution of the screen.
Script — MXML Only Component
You use the <mx:Script> tag to define blocks of ActionScript code.
scriptRecursionLimit — Property in class mx.core.Application
Specifies the maximum depth of the Adobe Flash Player call stack before Flash Player stops.
scriptTimeLimit — Property in class mx.core.Application
Specifies the maximum duration, in seconds, that an ActionScript event handler can execute before the Flash Player assumes that it is hung, and aborts it.
ScriptTimeoutError — Dynamic class in package flash.errors
The ScriptTimeoutError exception is thrown when the script timeout interval is reached.
ScriptTimeoutError(message:String) — Constructor in class flash.errors.ScriptTimeoutError
Creates a new ScriptTimeoutError object.
scroll(x:int, y:int) — Method in class flash.display.BitmapData
Scrolls an image by a certain (x, y) pixel amount.
scroll — Event in class flash.text.TextField
Dispatched by a TextField object after the user scrolls.
scroll — Event in class mx.controls.ComboBox
Dispatched when the user scrolls the ComboBox control's drop-down list.
scroll — Event in class mx.controls.DateChooser
Dispatched when the month changes due to user interaction.
scroll — Event in class mx.controls.DateField
Dispatched when the month changes due to user interaction.
scroll — Event in class mx.controls.HScrollBar
Dispatched when the ScrollBar control scrolls through user initiated action or programmatically.
scroll — Event in class mx.controls.VScrollBar
Dispatched when the ScrollBar control scrolls through user initiated action or programmatically.
scroll — Event in class mx.core.Container
Dispatched when the user manually scrolls the container.
scroll — Event in class mx.core.ScrollControlBase
Dispatched when the content is scrolled.
SCROLL — Constant static property in class flash.events.Event
Defines the value of the type property of a scroll event object.
SCROLL — Constant static property in class mx.events.DateChooserEvent
The DateChooserEvent.SCROLL constant defines the value of the type property of the event object for a scrollevent.
SCROLL — Constant static property in class mx.events.ScrollEvent
The ScrollEvent.SCROLL constant defines the value of the type property of the event object for a scroll event.
scrollAreaChanged — Property in class mx.core.ScrollControlBase
A flag that the scrolling area changed due to the appearance or disappearance of scrollbars.
ScrollArrowSkin — Class in package mx.skins.halo
The skin for all the states of the up or down button in a ScrollBar.
ScrollArrowSkin() — Constructor in class mx.skins.halo.ScrollArrowSkin
Constructor.
ScrollBar — Class in package mx.controls.scrollClasses
The ScrollBar class is the base class for the HScrollBar and VScrollBar controls.
ScrollBar() — Constructor in class mx.controls.scrollClasses.ScrollBar
Constructor.
ScrollBarDirection — Final class in package mx.controls.scrollClasses
The ScrollBarDirection class defines the values for the direction property of the ScrollBar control.
scrollChildren() — Method in class mx.core.Container
Positions the container's content area relative to the viewable area based on the horizontalScrollPosition and verticalScrollPosition properties.
ScrollControlBase — Class in package mx.core
The ScrollControlBase class is the base class for controls with scroll bars.
ScrollControlBase() — Constructor in class mx.core.ScrollControlBase
Constructor.
ScrollEvent — Class in package mx.events
Represents events that are dispatched by the ScrollBar class.
ScrollEvent(type:String, bubbles:Boolean, cancelable:Boolean, detail:String, position:Number, direction:String, delta:Number) — Constructor in class mx.events.ScrollEvent
Constructor.
ScrollEventDetail — Final class in package mx.events
Constants for the values of the detail property of a ScrollEvent.
ScrollEventDirection — Final class in package mx.events
Constants for the values of the direction property of a ScrollEvent.
scrollH — Property in class flash.text.TextField
The current horizontal scrolling position.
scrollHandler(event:flash.events:Event) — Method in class mx.core.ScrollControlBase
Default event handler for the scroll event.
scrollHorizontally(pos:int, deltaPos:int, scrollUp:Boolean) — Method in class mx.controls.listClasses.ListBase
Adjusts the renderers in response to a change in scroll position.
ScrollPolicy — Final class in package mx.core
Values for the horizontalScrollPolicy and verticalScrollPolicy properties of the Container and ScrollControlBase classes.
scrollPosition — Property in class mx.controls.scrollClasses.ScrollBar
Number that represents the current scroll position.
scrollPositionToIndex(horizontalScrollPosition:int, verticalScrollPosition:int) — Method in class mx.controls.listClasses.ListBase
Returns the data provider index for the item at the first visible row and column for the given scroll positions.
scrollRect — Property in class flash.display.DisplayObject
The scroll rectangle bounds of the display object.
scrollRect — Property in interface mx.core.IUIComponent
The scroll rectangle bounds of the surface of the component.
ScrollThumb — Class in package mx.controls.scrollClasses
The ScrollThumb class defines the thumb of a ScrollBar control.
ScrollThumb() — Constructor in class mx.controls.scrollClasses.ScrollThumb
Constructor.
ScrollThumbSkin — Class in package mx.skins.halo
The skin for all the states of the thumb in a ScrollBar.
ScrollThumbSkin() — Constructor in class mx.skins.halo.ScrollThumbSkin
Constructor.
scrollTipFunction — Property in class mx.core.ScrollControlBase
A function that computes the string to be displayed as the ScrollTip.
scrollToIndex(index:int) — Method in class mx.controls.listClasses.ListBase
Ensures that the data provider item at the given index is visible.
ScrollTrackSkin — Class in package mx.skins.halo
The skin for the track in a ScrollBar.
ScrollTrackSkin() — Constructor in class mx.skins.halo.ScrollTrackSkin
Constructor.
scrollV — Property in class flash.text.TextField
The vertical position of text in a text field.
scrollVertically(pos:int, deltaPos:int, scrollUp:Boolean) — Method in class mx.controls.listClasses.ListBase
Adjusts the renderers in response to a change in scroll position.
scrubDelay — Static property in class mx.managers.ToolTipManager
The amount of time, in milliseconds, that a user can take when moving the mouse between controls before Flex again waits for the duration of showDelay to display a ToolTip.
search(pattern) — Method in class String
Searches for the specifed pattern and returns the index of the first matching substring.
secondDataProvider — Property in class mx.charts.chartClasses.CartesianChart
The second dataProvider for this chart.
secondHorizontalAxis — Property in class mx.charts.chartClasses.CartesianChart
Defines the labels, tick marks, and data position for items on the y-axis.
secondHorizontalAxisRenderer — Property in class mx.charts.chartClasses.CartesianChart
Specifies how data appears along the y-axis of a chart.
secondHorizontalAxisStyleName — Style in class mx.charts.chartClasses.CartesianChart
The class selector that defines the style properties for the second horizontal axis.
secondRadiusAxis — Property in class mx.charts.BubbleChart
The axis the bubble radius of secondary series is mapped against.
seconds — Property in class Date
The seconds (an integer from 0 to 59) portion of a Date object according to local time.
secondSeries — Property in class mx.charts.chartClasses.CartesianChart
An array of Series objects that define the secondary chart data.
secondsUTC — Property in class Date
The seconds (an integer from 0 to 59) portion of a Date object according to universal time (UTC).
secondVerticalAxis — Property in class mx.charts.chartClasses.CartesianChart
The second vertical axis definition for this chart.
secondVerticalAxisRenderer — Property in class mx.charts.chartClasses.CartesianChart
Defines the labels, tick marks, and data position for items on the x-axis.
secondVerticalAxisStyleName — Style in class mx.charts.chartClasses.CartesianChart
The class selector that defines the style properties for the second vertical axis.
SecureAMFChannel — Class in package mx.messaging.channels
The SecureAMFChannel class is identical to the AMFChannel class except that it uses a secure protocol, HTTPS, to send messages to an AMF endpoint.
SecureAMFChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.SecureAMFChannel
Creates an new SecureAMFChannel instance.
SecureHTTPChannel — Class in package mx.messaging.channels
The SecureHTTPChannel class is identical to the HTTPChannel class except that it uses a secure protocol, HTTPS, to send messages to an HTTP endpoint.
SecureHTTPChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.SecureHTTPChannel
Creates an new SecureHTTPChannel instance.
SecureRTMPChannel — Class in package mx.messaging.channels
The SecureRTMPChannel class is identical to the RTMPChannel class except that it uses a secure protocol, RTMPS, to send messages to an RTMPS endpoint.
SecureRTMPChannel(id:String, uri:String) — Constructor in class mx.messaging.channels.SecureRTMPChannel
Creates an new SecureRTMPChannel instance.
Security — Final class in package flash.system
The Security class lets you specify how SWF files in different domains can communicate with each other.
securityDomain — Property in class flash.system.LoaderContext
Specifies the security domain to use for a Loader.load() operation.
SecurityDomain — Class in package flash.system
The SecurityDomain class represents the current security "sandbox," also known as a security domain.
securityError — Event in class flash.display.LoaderInfo
Dispatched if a call to the load() method of a Loader object attempts to load data from a server outside the security sandbox.
securityError — Event in class flash.net.FileReference
Dispatched when a call to the FileReference.upload() or FileReference.download() method tries to upload a file to a server or get a file from a server that is outside the caller's security sandbox.
securityError — Event in class flash.net.LocalConnection
Dispatched if a call to LocalConnection.send() attempts to send data to a different security sandbox.
securityError — Event in class flash.net.NetConnection
Dispatched if a call to NetConnection.call() attempts to connect to a server outside the caller's security sandbox.
securityError — Event in class flash.net.Socket
Dispatched if a call to Socket.connect() attempts to connect either to a server outside the caller's security sandbox or to a port lower than 1024.
securityError — Event in class flash.net.URLLoader
Dispatched if a call to URLLoader.load() attempts to load data from a server outside the security sandbox.
securityError — Event in class flash.net.URLStream
Dispatched if a call to URLStream.load() attempts to load data from a server outside the security sandbox.
securityError — Event in class flash.net.XMLSocket
Dispatched if a call to the XMLSocket.connect() method attempts to connect either to a server outside the caller's security sandbox or to a port lower than 1024.
securityError — Event in class mx.controls.SWFLoader
Dispatched when a security error occurs while content is loading.
SecurityError — Dynamic class in Top Level
The SecurityError exception is thrown when some type of security violation takes place.
SecurityError(message:String) — Constructor in class SecurityError
Creates a new SecurityError object.
SECURITY_ERROR — Constant static property in class flash.events.SecurityErrorEvent
The SecurityErrorEvent.SECURITY_ERROR constant defines the value of the type property of a securityError event object.
SecurityErrorEvent — Class in package flash.events
Flash® Player dispatches SecurityErrorEvent objects to report the occurrence of a security error.
SecurityErrorEvent(type:String, bubbles:Boolean, cancelable:Boolean, text:String) — Constructor in class flash.events.SecurityErrorEvent
Creates an Event object that contains information about security error events.
SecurityPanel — Final class in package flash.system
The SecurityPanel class provides values for specifying which Security Settings panel you want to display.
seek(offset:Number) — Method in class flash.net.NetStream
Seeks the keyframe closest to the specified location (an offset, in seconds, from the beginning of the stream).
seek(bookmark:mx.collections:CursorBookmark, offset:int, prefetch:int) — Method in interface mx.collections.IViewCursor
Moves the cursor to a location at an offset from the specified bookmark.
seek(playheadTime:Number) — Method in class mx.effects.Tween
Advances the tween effect to the specified position.
seek(playheadTime:Number) — Method in class mx.effects.effectClasses.TweenEffectInstance
Advances the effect to the specified position.
SEEKING — Constant static property in class mx.events.VideoEvent
The value of the VideoDisplay.state property for a seek occurring due to the VideoDisplay.playHeadTime property being set.
seekPendingFailureHandler(data:Object, info:mx.controls.listClasses:ListBaseSeekPending) — Method in class mx.controls.listClasses.ListBase
The default failure handler when a seek fails due to a page fault.
seekPendingResultHandler(data:Object, info:mx.controls.listClasses:ListBaseSeekPending) — Method in class mx.controls.listClasses.ListBase
The default result handler when a seek fails due to a page fault.
segments — Property in class mx.charts.series.renderData.LineSeriesRenderData
An Array of LineSeriesSegment instances representing each discontiguous segment of the line series.
select — Event in class flash.net.FileReference
Dispatched when the user selects a file for upload or download from the file-browsing dialog box.
select — Event in class flash.net.FileReferenceList
Dispatched when the user selects one or more files to upload from the file-browsing dialog box.
SELECT — Constant static property in class flash.events.Event
Defines the value of the type property of a select event object.
selectable — Property in class flash.text.TextField
A Boolean value that indicates whether the text field is selectable.
selectable — Property in class mx.controls.Label
Specifies whether the text can be selected.
selectable — Property in class mx.controls.listClasses.ListBase
A flag that indicates whether the list shows selected items as selected.
selectableRange — Property in class mx.controls.DateChooser
Range of dates between which dates are selectable.
selectableRange — Property in class mx.controls.DateField
Range of dates between which dates are selectable.
selected — Property in class mx.controls.Button
Indicates whether a toggle button is toggled on (true) or off (false).
selected — Property in interface mx.managers.IFocusManagerGroup
A flag that indicates whether this control is selected.
selectedButtonTextStyleName — Style in class mx.controls.ToggleButtonBar
Name of CSS style declaration that specifies styles for the text of the selected button.
selectedChild — Property in class mx.containers.Accordion
A reference to the currently visible child container.
selectedChild — Property in class mx.containers.ViewStack
A reference to the currently visible child container.
selectedColor — Property in class mx.controls.ColorPicker
The value of the currently selected color in the SwatchPanel object.
selectedData — Property in class mx.controls.listClasses.ListBase
A hash table of ListBaseSelectionData objects that track which items are currently selected.
selectedDate — Property in class mx.controls.DateChooser
Date selected in the DateChooser control.
selectedDate — Property in class mx.controls.DateField
Date as selected in the DateChooser control.
selectedDisabledIcon — Style in class mx.controls.Button
Name of the class to use as the icon when the button is selected and disabled.
selectedDisabledSkin — Style in class mx.controls.Button
Name of the class to use as the skin for the background and border when a toggle button is selected and disabled.
selectedDownIcon — Style in class mx.controls.Button
Name of the class to use as the icon when the button is selected and the mouse button is down.
selectedDownSkin — Style in class mx.controls.Button
Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse button is down.
selectedField — Property in class mx.controls.Button
The name of the field in the data property which specifies the value of the Button control's selected property.
selectedFillColors — Style in class mx.containers.Accordion
The two colors used to tint the background of the component when in its selected state.
selectedIndex — Property in class mx.containers.Accordion
The zero-based index of the currently visible child container.
selectedIndex — Property in class mx.containers.ViewStack
The zero-based index of the currently visible child container.
selectedIndex — Property in class mx.controls.ColorPicker
Index in the dataProvider of the selected item in the SwatchPanel object.
selectedIndex — Property in class mx.controls.ComboBase
The index in the data provider of the selected item.
selectedIndex — Property in class mx.controls.ComboBox
Index of the selected item in the drop-down list.
selectedIndex — Property in class mx.controls.LinkBar
The index of the last selected LinkButton control if the LinkBar control uses a ViewStack container as its data provider.
selectedIndex — Property in class mx.controls.MenuBar
The index in the MenuBar control of the currently open Menu or the last opened Menu if none are currently open.
selectedIndex — Property in class mx.controls.NavBar
Index of the active navigation item, where the first item is at an index of 0.
selectedIndex — Property in class mx.controls.ToggleButtonBar
Index of the selected button.
selectedIndex — Property in class mx.controls.listClasses.ListBase
The index in the data provider of the selected item.
selectedIndices — Property in class mx.controls.listClasses.ListBase
An array of indices in the data provider of the selected items.
selectedItem — Property in class mx.controls.ComboBase
The item in the data provider at the selectedIndex.
selectedItem — Property in class mx.controls.ComboBox
Contains a reference to the selected item in the dataProvider.
selectedItem — Property in class mx.controls.listClasses.ListBase
A reference to the selected item in the data provider.
selectedItems — Property in class mx.controls.listClasses.ListBase
An array of references to the selected items in the data provider.
selectedLabel — Property in class mx.controls.ComboBox
The String displayed in the TextInput portion of the ComboBox.
selectedOverIcon — Style in class mx.controls.Button
Name of the class to use as the icon when the button is selected and the mouse is over the control.
selectedOverSkin — Style in class mx.controls.Button
Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is over the control.
selectedRanges — Property in class mx.controls.DateChooser
Selected date ranges.
selectedTabTextStyleName — Style in class mx.containers.TabNavigator
Name of CSS style declaration that specifies styles for the text of the selected tab.
selectedTabTextStyleName — Style in class mx.controls.TabBar
Name of CSS style declaration that specifies the styles to use for the text of the selected tab navigation item.
selectedUpIcon — Style in class mx.controls.Button
Name of the class to use as the icon when the button is selected and the mouse button is up.
selectedUpSkin — Style in class mx.controls.Button
Name of the class to use as the skin for the background and border when a toggle button is selected and the mouse is not over the control.
selectedValue — Property in class mx.controls.RadioButtonGroup
The value of the value property of the selected RadioButton control in the group, if this has been set to be something other than null (the default value).
selection — Property in class mx.controls.RadioButtonGroup
Contains a reference to the currently selected RadioButton control in the group.
selection — Property in class mx.controls.RichTextEditor
A TextRange object containing the selected text in the TextArea subcontrol.
selectionBeginIndex — Property in class flash.text.TextField
The zero-based character index value of the first character in the current selection.
selectionBeginIndex — Property in class mx.controls.TextArea
The zero-based character index value of the first character in the current selection.
selectionBeginIndex — Property in class mx.controls.TextInput
The zero-based character index value of the first character in the current selection.
selectionColor — Style in class mx.controls.ComboBox
The selectionColor of the drop-down list.
selectionColor — Style in class mx.controls.DataGrid
The color of the background for the row when the user selects an item renderer in the row.
selectionColor — Style in class mx.controls.DateChooser
Color of the highlight area of the currently selected date in the DateChooser control.
selectionColor — Style in class mx.controls.DateField
Color of the highlight area of the currently selected date in the DateChooser control.
selectionColor — Style in class mx.controls.LinkBar
Background color of the LinkButton control as you press it.
selectionColor — Style in class mx.controls.LinkButton
Background color of a LinkButton as a user presses it.
selectionColor — Style in class mx.controls.Menu
The color of the menu item background when a menu item is selected.
selectionColor — Style in class mx.controls.MenuBar
The color of the menu item background when a menu item is selected.
selectionColor — Style in class mx.controls.Tree
Color of the background when the user selects the link.
selectionColor — Style in class mx.controls.listClasses.ListBase
The color of the background of a renderer when the user selects it.
selectionDisabledColor — Style in class mx.controls.Tree
Specifies the disabled color of a list item.
selectionDisabledColor — Style in class mx.controls.listClasses.ListBase
The color of the background of a renderer when the component is disabled.
selectionDuration — Style in class mx.controls.ComboBox
The selectionDuration of the drop-down list.
selectionDuration — Style in class mx.controls.listClasses.ListBase
The duration of the selection effect.
selectionEasingFunction — Style in class mx.controls.ComboBox
The selectionEasingFunction of the drop-down list.
selectionEasingFunction — Style in class mx.controls.Menu
The reference to an easingFunction equation which is used to control programmatic tweening.
selectionEasingFunction — Style in class mx.controls.Tree
Reference to an easingFunction function used for controlling programmatic tweening.
selectionEasingFunction — Style in class mx.controls.listClasses.ListBase
The easingFunction for the selection effect.
selectionEndIndex — Property in class flash.text.TextField
The zero-based character index value of the last character in the current selection.
selectionEndIndex — Property in class mx.controls.TextArea
The zero-based index of the position afterthe last character in the current selection (equivalent to the one-based index of the last character).
selectionEndIndex — Property in class mx.controls.TextInput
The zero-based index of the position afterthe last character in the current selection (equivalent to the one-based index of the last character).
selectionIndicators — Property in class mx.controls.listClasses.ListBase
A hash table of selection indicators.
selectionIndicatorSkin — Style in class mx.controls.DateChooser
Name of the class to use as the skin for the highlight area of the currently selected date in the DateChooser control.
selectionLayer — Property in class mx.controls.listClasses.ListBase
The layer in listContent where all selection and highlight indicators are drawn.
selectionTweens — Property in class mx.controls.listClasses.ListBase
A hash table of selection tweens.
selectItem(item:mx.controls.listClasses:IListItemRenderer, shiftKey:Boolean, ctrlKey:Boolean, transition:Boolean) — Method in class mx.controls.listClasses.ListBase
Updates the set of selected items given that the item renderer provided was clicked by the mouse and the keyboard modifiers are in the given state.
selector — Property in class mx.messaging.Consumer
The selector for the Consumer.
SELECTOR_HEADER — Constant static property in class mx.messaging.messages.CommandMessage
Subscribe commands issued by a Consumer pass the Consumer's selector expression in this header.
send(connectionName:String, methodName:String, ... rest) — Method in class flash.net.LocalConnection
Invokes the method named methodName on a connection opened with the connect(connectionName) method (the receiving LocalConnection object).
send(handlerName:String, ... rest) — Method in class flash.net.NetStream
Sends a message on the specified stream to all subscribing clients.
send(... rest) — Method in class flash.net.SharedObject
Broadcasts a message to all clients connected to the specified remote shared object, including the client that sent the message.
send(object) — Method in class flash.net.XMLSocket
Converts the XML object or data specified in the object parameter to a string and transmits it to the server, followed by a zero (0) byte.
send() — Method in class flash.printing.PrintJob
Sends spooled pages to the printer after PrintJob.start() and PrintJob.addPage() have been successful.
send(agent:mx.messaging:MessageAgent, message:mx.messaging.messages:IMessage) — Method in class mx.messaging.Channel
Sends the specified message to its target destination.
send(agent:mx.messaging:MessageAgent, message:mx.messaging.messages:IMessage) — Method in class mx.messaging.ChannelSet
Sends a message from a MessageAgent over the currently connected Channel.
send(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.Producer
Sends the specified message to its destination.
send() — Method in class mx.printing.FlexPrintJob
Sends the added objects to the printer to start printing.
send(... rest) — Method in class mx.rpc.AbstractOperation
Executes the method.
send(parameters:Object) — Method in class mx.rpc.http.HTTPService
Executes an HTTPService request.
send(parameters:Object) — Method in class mx.rpc.http.mxml.HTTPService
Executes an HTTPService request.
send(... rest) — Method in class mx.rpc.remoting.Operation
send(... rest) — Method in class mx.rpc.remoting.mxml.Operation
send(... rest) — Method in class mx.rpc.soap.mxml.Operation
Execute the method.
sendToURL(request) — Package function in flash.net
Sends a URL request to a server, but ignores any response.
separationError — Property in class mx.validators.CurrencyValidator
Error message when the thousands separator is incorrectly placed.
separationError — Property in class mx.validators.NumberValidator
Error message when the thousands separator is in the wrong location.
separatorBefore — Property in class flash.ui.ContextMenuItem
Indicates whether a separator bar should appear above the specified menu item.
separatorColor — Style in class mx.controls.LinkBar
Separator color used by the default separator skin.
separatorSkin — Style in class mx.controls.LinkBar
Seperator symbol between LinkButton controls in the LinkBar.
separatorSkin — Style in class mx.controls.Menu
The skin for all menu items which are identified as separators.
separatorWidth — Style in class mx.controls.LinkBar
Separator pixel width, in pixels.
Sequence — Class in package mx.effects
The Sequence effect plays multiple child effects one after the other, in the order in which they are added.
Sequence(target:Object) — Constructor in class mx.effects.Sequence
Constructor.
SequencedMessage — Class in package mx.data.messages
Clients receive this message in response to DataService.fill() request.
SequencedMessage() — Constructor in class mx.data.messages.SequencedMessage
Creates a new instance of an empty SequencedMessage.
sequenceId — Property in class mx.data.messages.SequencedMessage
Provides access to the sequence id for this message.
SequenceInstance — Class in package mx.effects.effectClasses
The SequenceInstance class implements the instance class for the Sequence effect.
SequenceInstance(target:Object) — Constructor in class mx.effects.effectClasses.SequenceInstance
Constructor.
sequencePosition — Property in class mx.data.messages.DataAssociationMessage
For one-to-many relationships, the position of the child instance in the sequence, optionally used for adding and removing child relationships to a specific location in the sequence.
sequenceSize — Property in class mx.data.messages.SequencedMessage
Provides access to the sequence size for this message.
series — Property in class mx.charts.chartClasses.ChartBase
An Array of Series objects that define the chart data.
series — Property in class mx.charts.chartClasses.StackedSeries
An array of sub-series managed by this stacking set.
Series — Class in package mx.charts.chartClasses
The Series class is the base class for the classes that let you specify a data series for a chart control.
Series() — Constructor in class mx.charts.chartClasses.Series
Constructor.
SeriesEffect — Class in package mx.charts.effects
The base class for chart effects.
SeriesEffect(target:Object) — Constructor in class mx.charts.effects.SeriesEffect
Constructor.
SeriesEffectInstance — Class in package mx.charts.effects.effectClasses
The SeriesEffectInstance class implements the base instance class for the chart series effects.
SeriesEffectInstance(target:Object) — Constructor in class mx.charts.effects.effectClasses.SeriesEffectInstance
Constructor.
seriesFilters — Property in class mx.charts.chartClasses.ChartBase
An Array of filters that are applied to all series in the chart.
SeriesInterpolate — Class in package mx.charts.effects
The SeriesInterpolate effect moves the graphics that represent the existing data in a series to the new points.
SeriesInterpolate(target:Object) — Constructor in class mx.charts.effects.SeriesInterpolate
Constructor.
SeriesInterpolateInstance — Class in package mx.charts.effects.effectClasses
The SeriesInterpolateInstance class implements the instance class for the SeriesInterpolate effect.
SeriesInterpolateInstance(target:Object) — Constructor in class mx.charts.effects.effectClasses.SeriesInterpolateInstance
Constructor.
SeriesSlide — Class in package mx.charts.effects
The SeriesSlide effect slides a data series into and out of the chart's boundaries.
SeriesSlide(target:Object) — Constructor in class mx.charts.effects.SeriesSlide
Constructor.
SeriesSlideInstance — Class in package mx.charts.effects.effectClasses
The SeriesSlideInstance class implements the instance class for the SeriesSlide effect.
SeriesSlideInstance(target:Object) — Constructor in class mx.charts.effects.effectClasses.SeriesSlideInstance
Constructor.
SeriesZoom — Class in package mx.charts.effects
The SeriesZoom effect implodes and explodes chart data into and out of the focal point that you specify.
SeriesZoom(target:Object) — Constructor in class mx.charts.effects.SeriesZoom
Constructor.
SeriesZoomInstance — Class in package mx.charts.effects.effectClasses
The SeriesZoomInstance class implements the instance class for the SeriesZoom effect.
SeriesZoomInstance(target:Object) — Constructor in class mx.charts.effects.effectClasses.SeriesZoomInstance
Constructor.
ServerConfig — Class in package mx.messaging.config
This class provides access to the server messaging configuration information.
SERVER_NAME_TOKEN — Constant static property in class mx.utils.URLUtil
serverObject — Property in class mx.data.Conflict
Returns the value of server object whose property was to be changed.
serverObject — Property in class mx.data.messages.DataErrorMessage
The value that the server had for the object with the conflicting properties.
serverObjectReferencedIds — Property in class mx.data.Conflict
If the serverObject has any properties with lazy="true", returns an Object that stores the referencedId Arrays for each lazily loaded property, using the property name as the lookup key value.
SERVER_OVERRIDE — Constant static property in class mx.data.messages.UpdateCollectionMessage
Indicates this update collection message was client generated and the remote destination determined that it should be reverted on that client.
SERVER_PORT_TOKEN — Constant static property in class mx.utils.URLUtil
serverString — Static property in class flash.system.Capabilities
A URL-encoded string that specifies values for each Capabilities property.
SERVER_UPDATE — Constant static property in class mx.data.messages.UpdateCollectionMessage
Indicates this update collection message was remotely generated and is based on the current state of the remote sequence.
service — Property in class mx.rpc.AbstractOperation
Provides convenient access to the service on which the Operation is being invoked.
service — Property in class mx.rpc.soap.WebService
Specifies the service within the WSDL document that this WebService should use.
serviceName — Property in class mx.rpc.soap.mxml.WebService
SESSION_INVALIDATE_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
This operation is used to indicate that the client's session with a remote destination has timed out.
set — Statement
Defines a setter, which is a method that appears in the public interface as a property.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.charts.AxisRenderer
Sets the actual size of this object.
setActualSize(w:Number, h:Number) — Method in class mx.charts.chartClasses.ChartBase
Sizes the object.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.charts.chartClasses.Series
Sets the actual size of this object.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.core.BitmapAsset
Sets the actual size of this object.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.core.ButtonAsset
Sets the actual size of this object.
setActualSize(newWidth:Number, newHeight:Number) — Method in interface mx.core.IFlexDisplayObject
Sets the actual size of this object.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.core.MovieClipAsset
Sets the actual size of this object.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.core.SpriteAsset
Sets the actual size of this object.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.core.TextFieldAsset
Sets the actual size of this object.
setActualSize(w:Number, h:Number) — Method in class mx.core.UIComponent
Sizes the object.
setActualSize(w:Number, h:Number) — Method in class mx.core.UITextField
Sizes the object.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.managers.SystemManager
Calling the setActualSize() method has no effect if it is directly mapped to the application window and if it is the top-level window.
setActualSize(newWidth:Number, newHeight:Number) — Method in class mx.skins.ProgrammaticSkin
Sets the height and width of this object.
setAdvancedAntiAliasingTable(fontName:String, fontStyle:String, colorType:String, advancedAntiAliasingTable:Array) — Static method in class flash.text.TextRenderer
Sets a custom continuous stroke modulation (CSM) lookup table for a font.
setAxis(dimension:String, value:mx.charts.chartClasses:IAxis) — Method in class mx.charts.chartClasses.ChartBase
Assigns an axis instance to a particular dimension of the chart.
setAxis(dimension:String, v:mx.charts.chartClasses:IAxis) — Method in class mx.charts.chartClasses.DataTransform
Assigns an axis instance to a particular dimension of the transform.
setBusyCursor() — Static method in class mx.managers.CursorManager
Displays the busy cursor.
setChildIndex(child:flash.display:DisplayObject, index:int) — Method in class flash.display.DisplayObjectContainer
Changes the position of an existing child in the display object container.
setChildIndex(child:flash.display:DisplayObject, index:int) — Method in class flash.display.Stage
Changes the position of an existing child in the display object container.
setChildIndex(child:flash.display:DisplayObject, newIndex:int) — Method in class mx.core.Container
Sets the index of a particular child.
setChildIndex(child:flash.display:DisplayObject, newIndex:int) — Method in interface mx.core.IChildList
Changes the index of a particular child in this child list.
setChildren(value:Object) — Method in class XML
Replaces the child properties of the XML object with the specified set of XML properties, provided in the value parameter.
setClipboard(string:String) — Static method in class flash.system.System
Replaces the contents of the Clipboard with a specified text string.
setColor(color:uint) — Method in class mx.core.UITextField
Sets the font color of the text.
setCompositionString(composition:String) — Static method in class flash.system.IME
Sets the IME composition string.
setCredentials(username:String, password:String) — Method in class mx.data.DataService
Sets the credentials for this DataService destination.
setCredentials(username:String, password:String) — Method in class mx.data.mxml.DataService
Sets the credentials for this DataService destination.
setCredentials(credentials:String, agent:mx.messaging:MessageAgent) — Method in class mx.messaging.Channel
Sets the credentials to the specified value.
setCredentials(credentials:String, agent:mx.messaging:MessageAgent) — Method in class mx.messaging.ChannelSet
Stores the credentials and passes them through to every connected channel.
setCredentials(username:String, password:String) — Method in class mx.messaging.MessageAgent
Sets the credentials that the MessageAgent uses to authenticate to destinations.
setCredentials(username:String, password:String) — Method in class mx.rpc.AbstractService
Set the credentials for the destination accessed by the service.
setCredentials(username:String, password:String) — Method in class mx.rpc.http.HTTPService
Sets the credentials for the destination accessed by the service.
setCuePoints(cuePointArray:Array) — Method in class mx.controls.videoClasses.CuePointManager
Set the array of cue points.
setCurrentState(stateName:String, playTransition:Boolean) — Method in class mx.core.UIComponent
Set the current state.
setCursor(cursorClass:Class, priority:int, xOffset:Number, yOffset:Number) — Static method in class mx.managers.CursorManager
Creates a new cursor and sets an optional priority for the cursor.
setDate(day:Number) — Method in class Date
Sets the day of the month, according to local time, and returns the new time in milliseconds.
setDirty(propertyName:String) — Method in class flash.net.SharedObject
Indicates to the server that the value of a property (defined with the data property) in the shared object has changed.
setEmpty() — Method in class flash.geom.Rectangle
Sets all of the Rectangle object's properties to 0.
setEnabled(node:Object, value:Boolean) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
Sets the value of the field or attribute in the data provider that identifies whether the node is enabled.
setEnabled(node:Object, value:Boolean) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
Sets the value of the field or attribute in the data provider that identifies whether the node is enabled.
SetEventHandler — Class in package mx.states
The SetEventHandler class specifies an event handler that is active only during a particular view state.
SetEventHandler(target:flash.events:EventDispatcher, name:String) — Constructor in class mx.states.SetEventHandler
Constructor.
setFocus() — Method in class mx.core.UIComponent
Sets the focus to this component.
setFocus() — Method in class mx.core.UITextField
Sets the focus to this component.
setFocus(o:mx.managers:IFocusManagerComponent) — Method in class mx.managers.FocusManager
Sets focus to an IFocusManagerComponent component.
setFocus(o:mx.managers:IFocusManagerComponent) — Method in interface mx.managers.IFocusManager
Sets focus to an IFocusManagerComponent component.
setFocus() — Method in interface mx.managers.IFocusManagerComponent
Called by the FocusManager when the component receives focus.
setFullYear(year:Number, month:Number, day:Number) — Method in class Date
Sets the year, according to local time, and returns the new time in milliseconds.
setHandler(handler:Function) — Method in class mx.binding.utils.ChangeWatcher
Sets the handler function.
setHours(hour:Number, minute:Number, second:Number, millisecond:Number) — Method in class Date
Sets the hour, according to local time, and returns the new time in milliseconds.
setInterval(closure, delay, ... rest) — Package function in flash.utils
Runs a function at a specified interval (in milliseconds).
setItemAt(item:Object, index:int) — Method in interface mx.collections.IList
Places the item at the specified index.
setItemAt(item:Object, index:int) — Method in class mx.collections.ListCollectionView
Places the item at the specified index.
setItemIcon(item:Object, iconID:Class, iconID2:Class) — Method in class mx.controls.Tree
Sets the associated icon for the item.
setKeyFrameInterval(keyFrameInterval:int) — Method in class flash.media.Camera
Specifies which video frames are transmitted in full (called keyframes) instead of being interpolated by the video compression algorithm.
setLocalName(name:String) — Method in class XML
Changes the local name of the XML object to the given name parameter.
setLoopback(compress:Boolean) — Method in class flash.media.Camera
Specifies whether to use a compressed video stream for a local view of the camera.
setLoopBack(state:Boolean) — Method in class flash.media.Microphone
Sets the microphone into loopback mode or turns it off.
setMenuItemToggled(item:Object, toggle:Boolean) — Method in class mx.controls.Menu
Toggles the menu item.
setMilliseconds(millisecond:Number) — Method in class Date
Sets the milliseconds, according to local time, and returns the new time in milliseconds.
setMinutes(minute:Number, second:Number, millisecond:Number) — Method in class Date
Sets the minutes, according to local time, and returns the new time in milliseconds.
setMode(width:int, height:int, fps:Number, favorArea:Boolean) — Method in class flash.media.Camera
Sets the camera capture mode to the native mode that best meets the specified requirements.
setMonth(month:Number, day:Number) — Method in class Date
Sets the month and optionally the day of the month, according to local time, and returns the new time in milliseconds.
setMotionLevel(motionLevel:int, timeout:int) — Method in class flash.media.Camera
Specifies how much motion is required to dispatch the activity event.
setName(name:String) — Method in class XML
Sets the name of the XML object to the given qualified name or attribute name.
setNamespace(ns:Namespace) — Method in class XML
Sets the namespace associated with the XML object.
setPixel(x:int, y:int, color:uint) — Method in class flash.display.BitmapData
Sets a single pixel of a BitmapData object.
setPixel32(x:int, y:int, color:uint) — Method in class flash.display.BitmapData
Sets the color and alpha transparency values of a single pixel of a BitmapData object.
setPixels(rect:flash.geom:Rectangle, inputByteArray:flash.utils:ByteArray) — Method in class flash.display.BitmapData
Converts a byte array into a rectangular region of pixel data.
setProgress(value:Number, total:Number) — Method in class mx.controls.ProgressBar
Sets the state of the bar to reflect the amount of progress made when using manual mode.
setProgress(completed:Number, total:Number) — Method in class mx.preloaders.DownloadProgressBar
Updates the display of the download progress bar with the current download information.
setProperty(propertyName:String, value:Object) — Method in class flash.net.SharedObject
Updates the value of a property (defined with the data property) in a shared object and indicates to the server that the value of the property has changed.
setProperty(name, value) — Method in class flash.utils.Proxy
Overrides a call to change a property's value.
setProperty(obj:mx.data:IManaged, property:Object, oldValue, newValue) — Static method in class mx.data.utils.Managed
This method is used to set the property of a managed object.
setProperty(name, value) — Method in class mx.utils.ObjectProxy
Updates the specified property on the proxied object and sends notification of the update to the handler.
SetProperty — Class in package mx.states
The SetProperty class specifies a property value that is in effect only during the parent view state.
SetProperty(target:Object, name:String, value) — Constructor in class mx.states.SetProperty
Constructor.
SetPropertyAction — Class in package mx.effects
The SetPropertyAction class defines an action effect that corresponds to the SetProperty property of a view state definition.
SetPropertyAction(target:Object) — Constructor in class mx.effects.SetPropertyAction
Constructor.
SetPropertyActionInstance — Class in package mx.effects.effectClasses
The SetPropertyActionInstance class implements the instance class for the SetPropertyAction effect.
SetPropertyActionInstance(target:Object) — Constructor in class mx.effects.effectClasses.SetPropertyActionInstance
Constructor.
setPropertyIsEnumerable(name:String, isEnum:Boolean) — Method in class Object
Sets the availability of a dynamic property for loop operations.
setQuality(bandwidth:int, quality:int) — Method in class flash.media.Camera
Sets the maximum amount of bandwidth per second or the required picture quality of the current outgoing video feed.
setRemoteCredentials(username:String, password:String) — Method in class mx.data.DataService
Sets the credentials for the third party of this DataService destination.
setRemoteCredentials(username:String, password:String) — Method in class mx.data.mxml.DataService
Sets the credentials for the third party of this DataService destination.
setRemoteCredentials(username:String, password:String) — Method in class mx.messaging.MessageAgent
Sets the remote credentials that will be passed through to the remote destination for authenticating to secondary systems.
setRemoteCredentials(remoteUsername:String, remotePassword:String) — Method in class mx.rpc.AbstractService
The username and password to be used to authenticate a user when accessing a remote, third-party endpoint such as a webservice through a proxy or a remote object through a custom adapter.
setRemoteCredentials(remoteUsername:String, remotePassword:String) — Method in class mx.rpc.http.HTTPService
The username and password to authenticate a user when accessing the HTTP URL.
setRemoteCredentials(remoteUsername:String, remotePassword:String) — Method in class mx.rpc.remoting.RemoteObject
If a remote object is managed by an external service, such a ColdFusion Component (CFC), a username and password can be set for the authentication mechanism of that remote service.
setRemoteCredentials(remoteUsername:String, remotePassword:String) — Method in class mx.rpc.soap.WebService
The username and password to authenticate a user when accessing the webservice.
setRowCount(v:int) — Method in class mx.controls.listClasses.ListBase
Sets the rowCount property without causing invalidation or setting the explicitRowCount property, which permanently locks in the number of rows.
setRowHeight(v:Number) — Method in class mx.controls.listClasses.ListBase
Sets rowHeight without causing invalidation or setting of explicitRowHeight which permanently locks in the height of the rows
setScrollBarProperties(totalColumns:int, visibleColumns:int, totalRows:int, visibleRows:int) — Method in class mx.core.ScrollControlBase
Causes the ScrollControlBase to show or hide scrollbars based on the parameters passed in.
setScrollProperties(pageSize:Number, minScrollPosition:Number, maxScrollPosition:Number, pageScrollSize:Number) — Method in class mx.controls.scrollClasses.ScrollBar
Sets the range and viewport size of the ScrollBar control.
setSecondAxis(dimension:String, value:mx.charts.chartClasses:IAxis) — Method in class mx.charts.chartClasses.CartesianChart
Assigns an axis instance to a particular secondary dimension of the chart.
setSeconds(second:Number, millisecond:Number) — Method in class Date
Sets the seconds, according to local time, and returns the new time in milliseconds.
setSelectColor(hexColor:uint) — Method in class flash.text.TextSnapshot
Specifies the color to use when highlighting characters that have been selected with the setSelected() method.
setSelected(beginIndex:int, endIndex:int, select:Boolean) — Method in class flash.text.TextSnapshot
Specifies a range of characters in a TextSnapshot object to be selected or deselected.
setSelection(beginIndex:int, endIndex:int) — Method in class flash.text.TextField
Sets as selected the text designated by the index values of the first and last characters, which are specified with the beginIndex and endIndex parameters.
setSelection(beginIndex:int, endIndex:int) — Method in class mx.controls.TextArea
Selects the text in the range specified by the parameters.
setSelection(beginIndex:int, endIndex:int) — Method in class mx.controls.TextInput
Selects the text in the range specified by the parameters.
setSettings(... rest) — Static method in class XML
Sets values for the following XML properties: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting.
setSilenceLevel(silenceLevel:Number, timeout:int) — Method in class flash.media.Microphone
Sets the minimum input level that should be considered sound and (optionally) the amount of silent time signifying that silence has actually begun.
setSize(width:Number, height:Number) — Method in class mx.charts.chartClasses.PolarTransform
Sets the width and height that the PolarTransfor uses when calculating origin and radius.
setStyle(styleName:String, styleObject:Object) — Method in class flash.text.StyleSheet
Adds a new style with the specified name to the style sheet object.
setStyle(styleProp:String, newValue) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
Sets a style property on this component instance.
setStyle(styleProp:String, newValue) — Method in class mx.core.UIComponent
Sets a style property on this component instance.
setStyle(styleProp:String, value) — Method in class mx.core.UITextField
Does nothing.
setStyle(styleProp:String, newValue) — Method in class mx.styles.CSSStyleDeclaration
Sets a style property on this CSSStyleDeclaration.
setStyle(styleProp:String, newValue) — Method in interface mx.styles.IStyleClient
Sets a style property on this component instance.
SetStyle — Class in package mx.states
The SetStyle class specifies a style that is in effect only during the parent view state.
SetStyle(target:mx.styles:IStyleClient, name:String, value:Object) — Constructor in class mx.states.SetStyle
Constructor.
SetStyleAction — Class in package mx.effects
The SetStyleAction class defines an action effect that corresponds to the SetStyle property of a view state definition.
SetStyleAction(target:Object) — Constructor in class mx.effects.SetStyleAction
Constructor.
SetStyleActionInstance — Class in package mx.effects.effectClasses
The SetStyleActionInstance class implements the instance class for the SetStyleAction effect.
SetStyleActionInstance(target:Object) — Constructor in class mx.effects.effectClasses.SetStyleActionInstance
Constructor.
setStyleDeclaration(selector:String, styleDeclaration:mx.styles:CSSStyleDeclaration, update:Boolean) — Static method in class mx.styles.StyleManager
Sets the CSSStyleDeclaration object that stores the rules for the specified CSS selector.
setTextFormat(format:flash.text:TextFormat, beginIndex:int, endIndex:int) — Method in class flash.text.TextField
Applies the text formatting that the format parameter specifies to the specified text in a text field.
setThumbValueAt(index:int, value:Number) — Method in class mx.controls.sliderClasses.Slider
This method sets the value of a slider thumb, and updates the display.
setTime(millisecond:Number) — Method in class Date
Sets the date in milliseconds since midnight on January 1, 1970, and returns the new time in milliseconds.
setTimeout(closure, delay, ... rest) — Package function in flash.utils
Runs a specified function after a specified delay (in milliseconds).
settings() — Static method in class XML
Retrieves the following properties: ignoreComments, ignoreProcessingInstructions, ignoreWhitespace, prettyIndent, and prettyPrinting.
SETTINGS_MANAGER — Constant static property in class flash.system.SecurityPanel
When passed to Security.showSettings(), displays the Settings Manager (in a separate browser window).
setToggled(node:Object, value:Boolean) — Method in interface mx.controls.menuClasses.IMenuDataDescriptor
Sets the value of the field or attribute in the data provider that identifies whether the node is toggled.
setToggled(node:Object, value:Boolean) — Method in class mx.controls.treeClasses.DefaultDataDescriptor
Sets the value of the field or attribute in the data provider that identifies whether the node is toggled.
setTweenHandlers(updateFunction:Function, endFunction:Function) — Method in class mx.effects.Tween
By default, the Tween class invokes the mx.effects.effectClasses.TweenEffectInstance.onTweenUpdate() callback function on a regular interval on the effect instance for the duration of the effect, and the optional mx.effects.effectClasses.TweenEffectInstance.onTweenEnd() callback function at the end of the effect duration.
setupPropertyList() — Method in class mx.utils.ObjectProxy
This method creates an array of all of the property names for the proxied object.
setUseEchoSuppression(useEchoSuppression:Boolean) — Method in class flash.media.Microphone
Specifies whether to use the echo suppression feature of the audio codec.
setUTCDate(day:Number) — Method in class Date
Sets the day of the month, in universal time (UTC), and returns the new time in milliseconds.
setUTCFullYear(year:Number, month:Number, day:Number) — Method in class Date
Sets the year, in universal time (UTC), and returns the new time in milliseconds.
setUTCHours(hour:Number, minute:Number, second:Number, millisecond:Number) — Method in class Date
Sets the hour, in universal time (UTC), and returns the new time in milliseconds.
setUTCMilliseconds(millisecond:Number) — Method in class Date
Sets the milliseconds, in universal time (UTC), and returns the new time in milliseconds.
setUTCMinutes(minute:Number, second:Number, millisecond:Number) — Method in class Date
Sets the minutes, in universal time (UTC), and returns the new time in milliseconds.
setUTCMonth(month:Number, day:Number) — Method in class Date
Sets the month, and optionally the day, in universal time(UTC) and returns the new time in milliseconds.
setUTCSeconds(second:Number, millisecond:Number) — Method in class Date
Sets the seconds, and optionally the milliseconds, in universal time (UTC) and returns the new time in milliseconds.
setVisible(value:Boolean, noEvent:Boolean) — Method in interface mx.core.IUIComponent
Called when the visible property changes.
setVisible(value:Boolean, noEvent:Boolean) — Method in class mx.core.UIComponent
Called when the visible property changes.
setVisible(visible:Boolean, noEvent:Boolean) — Method in class mx.core.UITextField
Sets the visible property of this UITextField object.
shadowAlpha — Property in class flash.filters.BevelFilter
The alpha transparency value of the shadow color.
ShadowBoxItemRenderer — Class in package mx.charts.renderers
A simple chart itemRenderer implementation that fills a rectangular area and surrounds it with a drop shadow.
ShadowBoxItemRenderer() — Constructor in class mx.charts.renderers.ShadowBoxItemRenderer
Constructor.
shadowColor — Property in class flash.filters.BevelFilter
The shadow color of the bevel.
shadowColor — Style in class mx.charts.chartClasses.DataTip
Bottom inside color of a button's skin.
shadowColor — Style in class mx.controls.HRule
The shadow color of the line.
shadowColor — Style in class mx.controls.VRule
The shadow color of the line.
shadowDirection — Style in class mx.containers.Panel
Direction of drop shadow.
shadowDirection — Style in class mx.controls.NumericStepper
Direction of the drop shadow.
shadowDirection — Style in class mx.controls.TextInput
Direction of the drop shadow.
shadowDirection — Style in class mx.controls.ToolTip
Direction of the drop shadow.
shadowDirection — Style in class mx.controls.VideoDisplay
Direction of the drop shadow.
shadowDirection — Style in class mx.core.Container
Direction of the drop shadow.
shadowDirection — Style in class mx.core.ScrollControlBase
Direction of the drop shadow.
shadowDistance — Style in class mx.containers.Panel
Distance of drop shadow.
shadowDistance — Style in class mx.controls.NumericStepper
Distance of the drop shadow.
shadowDistance — Style in class mx.controls.TextInput
Distance of the drop shadow.
shadowDistance — Style in class mx.controls.ToolTip
Distance of the drop shadow.
shadowDistance — Style in class mx.controls.VideoDisplay
Distance of the drop shadow.
shadowDistance — Style in class mx.core.Container
Distance of the drop shadow.
shadowDistance — Style in class mx.core.ScrollControlBase
Distance of the drop shadow.
ShadowLineRenderer — Class in package mx.charts.renderers
An implementation of a line segment renderer that is used by LineSeries objects.
ShadowLineRenderer() — Constructor in class mx.charts.renderers.ShadowLineRenderer
Constructor.
Shape — Class in package flash.display
The Shape class is used to create lightweight shapes by using the ActionScript drawing application program interface (API).
Shape() — Constructor in class flash.display.Shape
Creates a new Shape object.
sharedEvents — Property in class flash.display.LoaderInfo
An EventDispatcher instance that can be used to exchange events across security boundaries.
SharedObject — Class in package flash.net
The SharedObject class is used to read and store limited amounts of data on a user's computer or on a server.
SharedObjectFlushStatus — Final class in package flash.net
The SharedObjectFlushStatus class provides values for the code returned from a call to the SharedObject.flush() method.
sharpness — Property in class flash.text.TextField
The sharpness of the glyph edges in this text field.
sharpness — Property in class mx.core.UITextFormat
Defines the sharpness setting for the UITextField class.
shift() — Method in class Array
Removes the first element from an array and returns that element.
SHIFT — Constant static property in class flash.ui.Keyboard
Constant associated with the key code value for the Shift key (16).
shiftKey — Property in class flash.events.FocusEvent
Indicates whether the Shift key modifier is activated, in which case the value is true.
shiftKey — Property in class flash.events.KeyboardEvent
Indicates whether the Shift key modifier is active (true) or inactive (false).
shiftKey — Property in class flash.events.MouseEvent
Indicates whether the Shift key is active (true) or inactive (false).
shortcut — Property in class flash.accessibility.AccessibilityProperties
Indicates a keyboard shortcut associated with this display object.
show() — Static method in class flash.ui.Mouse
Displays the pointer.
show — Event in class mx.charts.chartClasses.DataTip
Dispatched when the component becomes visible.
show(text:String, title:String, flags:uint, parent:flash.display:Sprite, closeHandler:Function, iconClass:Class, defaultButtonFlag:uint) — Static method in class mx.controls.Alert
Static method that pops up the Alert control.
show(xShow:Object, yShow:Object) — Method in class mx.controls.Menu
Shows the Menu control.
show — Event in class mx.controls.ProgressBar
Dispatched when the component becomes visible.
show — Event in class mx.core.UIComponent
Dispatched when an object's state changes from invisible to visible.
SHOW — Constant static property in class mx.events.FlexEvent
The FlexEvent.SHOW constant defines the value of the type property of the event object for a show event.
SHOW_ALL — Constant static property in class flash.display.StageScaleMode
Specifies that the entire Flash application be visible in the specified area without distortion while maintaining the original aspect ratio of the application.
SHOW_ALL — Constant static property in class mx.printing.FlexPrintJobScaleType
Scales the object to fit on a single page, filling one dimension; that is, it selects the smaller of the MATCH_WIDTH or MATCH_HEIGHT scale types.
showBusyCursor — Property in class mx.controls.SWFLoader
If true, shows a busy cursor while the content loads.
showBusyCursor — Property in class mx.rpc.http.mxml.HTTPService
If true, a busy cursor is displayed while a service is executing.
showBusyCursor — Property in interface mx.rpc.mxml.IMXMLSupport
Indicates whether the RPC operation or HTTPService should show the busy cursor while it is executing.
showBusyCursor — Property in class mx.rpc.remoting.mxml.Operation
Whether this operation should show the busy cursor while it is executing.
showBusyCursor — Property in class mx.rpc.remoting.mxml.RemoteObject
If true, a busy cursor is displayed while a service is executing.
showBusyCursor — Property in class mx.rpc.soap.mxml.Operation
Whether this operation should show the busy cursor while it is executing.
showBusyCursor — Property in class mx.rpc.soap.mxml.WebService
If true, a busy cursor is displayed while a service is executing.
showCaret — Property in class mx.controls.listClasses.ListBase
A flag that indicates whether to show caret.
showCloseButton — Property in class mx.containers.TitleWindow
Whether to display a Close button in the TitleWindow container.
showControlBar — Property in class mx.controls.RichTextEditor
Specifies whether to display the control bar that contains the text formatting controls.
showCursor() — Static method in class mx.managers.CursorManager
Makes the cursor visible.
showDataEffect — Effect in class mx.charts.chartClasses.Series
Defines the effect that Flex uses as it moves the current data into its final position on the screen.
showDataTip — Property in class mx.controls.sliderClasses.Slider
If set to true, show a data tip during user interaction containing the current value of the slider.
showDataTips — Property in class mx.charts.chartClasses.ChartBase
Specifies whether Flex shows DataTip controls for the chart.
showDataTips — Property in class mx.controls.dataGridClasses.DataGridColumn
A flag that indicates whether the datatips are shown in the column.
showDataTips — Property in class mx.controls.listClasses.ListBase
A flag that indicates whether dataTips are displayed for text in the rows.
showDataTipTargets — Style in class mx.charts.chartClasses.ChartBase
Specifies whether to show targets over the datapoints when showDataTips is set to true.
showDefaultContextMenu — Property in class flash.display.Stage
Specifies whether to show or hide the default items in the Flash Player context menu.
showDelay — Static property in class mx.managers.ToolTipManager
The amount of time, in milliseconds, that Flex waits before displaying the ToolTip box once a user moves the mouse over a component that has a ToolTip.
showDisplayForDownloading(elapsedTime:int, event:flash.events:ProgressEvent) — Method in class mx.preloaders.DownloadProgressBar
Defines the algorithm for determining whether to show the download progress bar while in the download phase.
showDisplayForInit(elapsedTime:int, count:int) — Method in class mx.preloaders.DownloadProgressBar
Defines the algorithm for determining whether to show the download progress bar while in the initialization phase, assuming that the display is not currently visible.
showDropFeedback(event:mx.events:DragEvent) — Method in class mx.controls.listClasses.ListBase
Displays a drop indicator under the mouse pointer to indicate that a drag and drop operation is allowed and where the items will be dropped.
showEffect — Effect in class mx.core.UIComponent
Played when the component becomes visible.
showEffect — Static property in class mx.managers.ToolTipManager
The effect that plays when a ToolTip is shown, or null if the ToolTip should appear with no effect.
showFeedback(feedback:String) — Static method in class mx.managers.DragManager
Sets the feedback indicator for the drag and drop operation.
showFocus() — Method in class mx.managers.FocusManager
Sets showFocusIndicator to true and draws the visual focus indicator on the focused object, if any.
showFocus() — Method in interface mx.managers.IFocusManager
Sets showFocusIndicator to true and draws the visual focus indicator on the focused object, if any.
showFocusIndicator — Property in class mx.managers.FocusManager
A flag that indicates whether to display an indicator that a component has focus.
showFocusIndicator — Property in interface mx.managers.IFocusManager
A flag that indicates whether to display an indicator that a component has focus.
showHeaders — Property in class mx.controls.dataGridClasses.DataGridBase
A flag that indicates whether the control should show column headers.
SHOWING_DATA — Constant static property in class mx.charts.chartClasses.ChartState
The chart is currently running transitions to show the new chart data.
showLabel — Property in class mx.preloaders.DownloadProgressBar
Controls whether to display the label, true, or not, false.
showLabels — Style in class mx.charts.AxisRenderer
Specifies whether labels should appear along the axis.
showLine — Style in class mx.charts.AxisRenderer
Specifies whether to display the axis.
showPercentage — Property in class mx.preloaders.DownloadProgressBar
Controls whether to display the percentage, true, or not, false.
showRedrawRegions(on, color) — Package function in flash.profiler
Shows or hides redraw regions.
showRoot — Property in class mx.controls.Menu
/ A Boolean flag that specifies whether to display the data provider's root node.
showRoot — Property in class mx.controls.MenuBar
A Boolean flag that specifies whether to display the data provider's root node.
showRoot — Property in class mx.controls.PopUpMenuButton
Specifies whether to display the top-level node or nodes of the data provider.
showRoot — Property in class mx.controls.Tree
Sets the visibility of the root item.
showScrollTips — Property in class mx.core.ScrollControlBase
A flag that indicates whether a tooltip should appear near the scroll thumb when it is being dragged.
showSettings(panel:String) — Static method in class flash.system.Security
Displays the Security Settings panel in Flash Player.
showTarget — Property in class mx.effects.MaskEffect
Specifies that the target component is becoming visible, true, or invisible, false.
showTarget — Property in class mx.effects.effectClasses.MaskEffectInstance
Specifies that the target component is becoming visible, false, or invisible, true.
showTextField — Property in class mx.controls.ColorPicker
Specifies whether to show the text box that displays the color label or hexadecimal color value.
showToday — Property in class mx.controls.DateChooser
If true, specifies that today is highlighted in the DateChooser control.
showToday — Property in class mx.controls.DateField
If true, specifies that today is highlighted in the DateChooser control.
showToolTips — Property in class mx.controls.RichTextEditor
Specifies whether to display tooltips for the text formatting controls.
showTrackHighlight — Style in class mx.controls.sliderClasses.Slider
Specifies whether to enable track highlighting between thumbs (or a single thumb and the beginning of the track).
signature — Property in class mx.messaging.management.MBeanOperationInfo
The parameter data types that make up the operation signature.
silenceLevel — Property in class flash.media.Microphone
The amount of sound required to activate the microphone and dispatch the activity event.
silenceTimeout — Property in class flash.media.Microphone
The number of milliseconds between the time the microphone stops detecting sound and the time the activity event is dispatched.
silent — Property in class flash.accessibility.AccessibilityProperties
If true, excludes this display object from accessible presentation.
SimpleButton — Class in package flash.display
The SimpleButton class lets you control all instances of button symbols in a SWF file.
SimpleButton(upState:flash.display:DisplayObject, overState:flash.display:DisplayObject, downState:flash.display:DisplayObject, hitTestState:flash.display:DisplayObject) — Constructor in class flash.display.SimpleButton
Creates a new SimpleButton instance.
simpleType(val:Object) — Static method in class mx.rpc.xml.SimpleXMLDecoder
Converts an ActionScript object into a Number, Boolean, or String.
SimpleXMLDecoder — Class in package mx.rpc.xml
The SimpleXMLDecoder class deserialize XML into a graph of ActionScript objects.
SimpleXMLEncoder — Class in package mx.rpc.xml
The SimpleXMLEncoder class take ActionScript Objects and encodes them to XML.
SimpleXMLEncoder(myXML:flash.xml:XMLDocument) — Constructor in class mx.rpc.xml.SimpleXMLEncoder
sin(angleRadians:Number) — Static method in class Math
Computes and returns the sine of the specified angle in radians.
Sine — Class in package mx.effects.easing
The Sine class defines three easing functions to implement motion with Flex effect classes, where the motion is defined by a sine wave.
size — Property in class flash.geom.Rectangle
The size of the Rectangle object, expressed as a Point object with the values of the width and height properties.
size — Property in class flash.net.FileReference
The size of the file on the local disk in bytes.
size — Property in class flash.net.SharedObject
The current size of the shared object, in bytes.
size — Property in class flash.text.TextFormat
The point size of text in this text format.
sizeToPage — Property in class mx.printing.PrintDataGrid
If true, the PrintDataGrid readjusts its height to display only completely viewable rows.
slice(startIndex:int, endIndex:int) — Method in class Array
Returns a new array that consists of a range of elements from the original array, without modifying the original array.
slice(startIndex:Number, endIndex:Number) — Method in class String
Returns a string that includes the startIndex character and all characters up to, but not including, the endIndex character.
slideDuration — Style in class mx.controls.sliderClasses.Slider
Duration in milliseconds for the sliding animation when you click on the track to move a thumb.
slideEasingFunction — Style in class mx.controls.sliderClasses.Slider
Tweening function used by the sliding animation when you click on the track to move a thumb.
Slider — Class in package mx.controls.sliderClasses
The Slider class is the base class for the Flex slider controls.
Slider() — Constructor in class mx.controls.sliderClasses.Slider
Constructor.
SliderDataTip — Class in package mx.controls.sliderClasses
The SliderDataTip class defines the tooltip used in the mx.controls.Slider control.
SliderDataTip() — Constructor in class mx.controls.sliderClasses.SliderDataTip
Constructor.
sliderDataTipClass — Property in class mx.controls.sliderClasses.Slider
A reference to the class to use for the data tip.
SliderDirection — Final class in package mx.controls.sliderClasses
The SliderDirection class defines the constant values for the direction property of the Slider class.
SliderEvent — Class in package mx.events
The SliderEvent class represents the event object passed to the event listener for the change, thumbDrag, thumbPress, and thumbRelease events of the HSlider and VSlider classes.
SliderEvent(type:String, bubbles:Boolean, cancelable:Boolean, thumbIndex:int, value:Number, triggerEvent:flash.events:Event, clickTarget:String, keyCode:int) — Constructor in class mx.events.SliderEvent
Constructor.
SliderEventClickTarget — Final class in package mx.events
The SliderEventClickTarget class defines the constants for the values of the clickTarget property of the SliderEvent class.
SliderHighlightSkin — Class in package mx.skins.halo
The skin for the highlighted state of the track of a Slider.
SliderHighlightSkin() — Constructor in class mx.skins.halo.SliderHighlightSkin
Constructor.
SliderLabel — Class in package mx.controls.sliderClasses
The SliderLabel class defines the label used in the mx.controls.Slider component.
SliderLabel() — Constructor in class mx.controls.sliderClasses.SliderLabel
Constructor.
SliderThumb — Class in package mx.controls.sliderClasses
The SliderThumb class represents a thumb of a Slider control.
SliderThumb() — Constructor in class mx.controls.sliderClasses.SliderThumb
Constructor.
sliderThumbClass — Property in class mx.controls.sliderClasses.Slider
A reference to the class to use for each thumb.
SliderThumbSkin — Class in package mx.skins.halo
The skin for all the states of a thumb in a Slider.
SliderThumbSkin() — Constructor in class mx.skins.halo.SliderThumbSkin
Constructor.
SliderTrackSkin — Class in package mx.skins.halo
The skin for the track in a Slider.
SliderTrackSkin() — Constructor in class mx.skins.halo.SliderTrackSkin
Constructor.
smooth — Property in class mx.graphics.BitmapFill
A flag indicating whether to smooth the bitmap data when filling with it.
smoothing — Property in class flash.display.Bitmap
Controls whether or not the bitmap is smoothed when scaled.
smoothing — Property in class flash.media.Video
Specifies whether the video should be smoothed (interpolated) when it is scaled.
snapInterval — Property in class mx.controls.sliderClasses.Slider
Specifies the increment value of the slider thumb as the user moves the thumb.
SOAP_ACTION_HEADER — Static property in class mx.messaging.messages.SOAPMessage
The HTTP header that stores the SOAP action for the SOAPMessage.
SOAPHeader — Class in package mx.rpc.soap
You use a SOAPHeader to specify the headers that need to be added to a SOAP envelope of a WebService Operation request.
SOAPHeader(qname:QName, content:Object) — Constructor in class mx.rpc.soap.SOAPHeader
Constructs a new SOAPHeader.
SOAPMessage — Class in package mx.messaging.messages
SOAPMessages are similar to HTTPRequestMessages.
SOAPMessage() — Constructor in class mx.messaging.messages.SOAPMessage
Constructs an uninitialized SOAPMessage.
SocialSecurityValidator — Class in package mx.validators
The SocialSecurityValidator class validates that a String is a valid United States Social Security number.
SocialSecurityValidator() — Constructor in class mx.validators.SocialSecurityValidator
Constructor.
Socket — Class in package flash.net
The Socket class enables ActionScript code to make socket connections and to read and write raw binary data.
Socket(host:String, port:int) — Constructor in class flash.net.Socket
Creates a Socket object.
socketData — Event in class flash.net.Socket
Dispatched when a socket has received data.
SOCKET_DATA — Constant static property in class flash.events.ProgressEvent
Defines the value of the type property of a socketData event object.
SolidColor — Class in package mx.graphics
Defines a representation for a color, including a color and an alpha value.
SolidColor(color:uint, alpha:Number) — Constructor in class mx.graphics.SolidColor
Constructor.
some(callback:Function, thisObject) — Method in class Array
Executes a test function on each item in the array until an item is reached that returns true.
songName — Property in class flash.media.ID3Info
The name of the song; corresponds to the ID3 2.0 tag TIT2.
sort(... rest) — Method in class Array
Sorts the elements in an array.
sort — Property in interface mx.collections.ICollectionView
The Sort that will be applied to the ICollectionView.
sort — Property in class mx.collections.ListCollectionView
The Sort that will be applied to the ICollectionView.
sort(items:Array) — Method in class mx.collections.Sort
Apply the current sort to the specified array (not a copy).
Sort — Class in package mx.collections
Provides the sorting information required to establish a sort on an existing view (ICollectionView interface or class that implements the interface).
Sort() — Constructor in class mx.collections.Sort
Constructor.
sortable — Property in class mx.controls.dataGridClasses.DataGridColumn
A flag that indicates whether the user can click on the header of this column to sort the data provider.
sortableColumns — Property in class mx.controls.DataGrid
A flag that indicates whether the user can sort the data provider items by clicking on a column header cell.
sortArrowSkin — Style in class mx.controls.DataGrid
The class to use as the skin for the arrow that indicates the column sort direction.
sortCompareFunction — Property in class mx.controls.dataGridClasses.DataGridColumn
A callback function that gets called when sorting the data in the column.
sortDescending — Property in class mx.controls.dataGridClasses.DataGridColumn
A flag that indicates, if the column is the field used the sort the dataprovider, whether the sort is in descending order.
SortError — Class in package mx.collections.errors
This error is thrown when a Sort class is not configured properly; for example, if the find criteria are invalid.
SortError(message:String) — Constructor in class mx.collections.errors.SortError
Constructor.
SortField — Class in package mx.collections
Provides the sorting information required to establish a sort on a field or property in an existing view.
SortField(name:String, caseInsensitive:Boolean, descending:Boolean, numeric:Boolean) — Constructor in class mx.collections.SortField
Constructor.
sortOn(fieldName:Object, options:Object) — Method in class Array
Sorts the elements in an array according to one or more fields in the array.
sortOnXField — Property in class mx.charts.series.AreaSeries
Requests the line datapoints be sorted from left to right before rendering.
sortOnXField — Property in class mx.charts.series.ColumnSeries
Requests the columns be sorted from left to right before rendering.
sortOnXField — Property in class mx.charts.series.LineSeries
Requests the line datapoints be sorted from left to right before rendering.
sound — Property in class mx.effects.SoundEffect
The Sound object that the MP3 file has been loaded into.
sound — Property in class mx.effects.effectClasses.SoundEffectInstance
Reference to the internal Sound object.
Sound — Class in package flash.media
The Sound class lets you work with sound in an application.
Sound(stream:flash.net:URLRequest, context:flash.media:SoundLoaderContext) — Constructor in class flash.media.Sound
Creates a new Sound object.
SoundAsset — Class in package mx.core
SoundAsset is a subclass of the Flash Player's Sound class which represents sounds that you embed in a Flex application.
SoundAsset() — Constructor in class mx.core.SoundAsset
Constructor.
soundChannel — Property in class mx.effects.effectClasses.SoundEffectInstance
The SoundChannel object that the MP3 file has been loaded into.
SoundChannel — Final class in package flash.media
The SoundChannel class controls a sound in an application.
soundComplete — Event in class flash.media.SoundChannel
Dispatched when a sound has finished playing.
SOUND_COMPLETE — Constant static property in class flash.events.Event
Defines the value of the type property of a soundComplete event object.
SoundEffect — Class in package mx.effects
The SoundEffect class plays an MP3 audio file.
SoundEffect(target:Object) — Constructor in class mx.effects.SoundEffect
Constructor.
SoundEffectInstance — Class in package mx.effects.effectClasses
The SoundEffectInstance class implements the instance class for the SoundEffect effect.
SoundEffectInstance(target:Object) — Constructor in class mx.effects.effectClasses.SoundEffectInstance
Constructor.
SoundLoaderContext — Class in package flash.media
The SoundLoaderContext class provides security checks for SWF files that load sound.
SoundLoaderContext(bufferTime:Number, checkPolicyFile:Boolean) — Constructor in class flash.media.SoundLoaderContext
Creates a new sound loader context object.
SoundMixer — Final class in package flash.media
The SoundMixer class contains static properties and methods for global sound control in the SWF file.
soundTransform — Property in class flash.display.SimpleButton
The SoundTransform object assigned to this button.
soundTransform — Property in class flash.display.Sprite
Controls sound within this sprite.
soundTransform — Property in class flash.media.Microphone
Controls the sound of this microphone object when it is in loopback mode.
soundTransform — Property in class flash.media.SoundChannel
The SoundTransform object assigned to the sound channel.
soundTransform — Static property in class flash.media.SoundMixer
The SoundTransform object that controls global sound properties.
soundTransform — Property in class flash.net.NetStream
Controls sound in this NetStream object.
SoundTransform — Final class in package flash.media
The SoundTransform class contains properties for volume and panning.
SoundTransform(vol:Number, panning:Number) — Constructor in class flash.media.SoundTransform
Creates a SoundTransform object.
source — Property in class RegExp
Specifies the pattern portion of the regular expression.
source — Property in class mx.charts.LegendItem
Contains a reference to the data series that the LegendItem was generated from if you bind the dataProvider property of the parent Legend control to a chart control.
source — Property in class mx.collections.ArrayCollection
The source of data in the ArrayCollection.
source — Property in class mx.collections.XMLListCollection
The underlying XMLList for this collection.
source — Property in class mx.controls.ProgressBar
Refers to the control that the ProgressBar is measuring the progress of.
source — Property in class mx.controls.SWFLoader
Specifies the content to load.
source — Property in class mx.controls.VideoDisplay
Relative path and filename of the FLV file to stream.
source — Property in class mx.effects.SoundEffect
The URL or class of the MP3 file to play.
source — Property in class mx.effects.effectClasses.SoundEffectInstance
The URL or class of the MP3 file to play.
source — Property in class mx.events.PropertyChangeEvent
The object that the change occured on.
source — Property in class mx.graphics.BitmapFill
The source used for the bitmap fill.
source — Property in class mx.messaging.messages.RemotingMessage
This property is provided for backwards compatibility.
source — Property in class mx.rpc.remoting.RemoteObject
Lets you specify a source value on the client; not supported for destinations that use the JavaAdapter.
source — Property in class mx.validators.Validator
Specifies the object containing the property to validate.
SPACE — Constant static property in class flash.ui.Keyboard
Constant associated with the key code value for the Spacebar (32).
Spacer — Class in package mx.controls
The Spacer control helps you lay out children within a parent container.
Spacer() — Constructor in class mx.controls.Spacer
Constructor
splice(startIndex:int, deleteCount:uint, ... rest) — Method in class Array
Adds elements to and removes elements from an array.
split(delimiter, limit:Number) — Method in class String
Splits a String object into an array of substrings by dividing it wherever the specified delimiter parameter occurs.
spreadMethod — Property in class mx.graphics.LinearGradientStroke
A value from the SpreadMethod class that specifies which spread method to use.
SpreadMethod — Final class in package flash.display
The SpreadMethod class provides values for the spreadMethod parameter in the beginGradientFill() and lineGradientStyle() methods of the Graphics class.
Sprite — Class in package flash.display
The Sprite class is a basic display list building block: a display list node that can display graphics and can also contain children.
Sprite() — Constructor in class flash.display.Sprite
Creates a new Sprite instance.
SpriteAsset — Class in package mx.core
SpriteAsset is a subclass of the Flash Player's Sprite class which represents vector graphic images that you embed in a Flex application.
SpriteAsset() — Constructor in class mx.core.SpriteAsset
Constructor.
sqrt(val:Number) — Static method in class Math
Computes and returns the square root of the specified number.
SQRT1_2 — Constant static property in class Math
A mathematical constant for the square root of one-half, with an approximate value of 0.7071067811865476.
SQRT2 — Constant static property in class Math
A mathematical constant for the square root of 2, with an approximate value of 1.4142135623730951.
SQUARE — Constant static property in class flash.display.CapsStyle
Used to specify square caps in the caps parameter of the flash.display.Graphics.lineStyle() method.
stack(stackedXValueDictionary:flash.utils:Dictionary, previousElement:mx.charts.chartClasses:IStackable) — Method in interface mx.charts.chartClasses.IStackable
Stacks the series.
stack() — Method in class mx.charts.chartClasses.StackedSeries
Updates the series data, and uses the values of the series data it is stacking on top of so it can stack correctly.
stack(stackedXValueDictionary:flash.utils:Dictionary, previousElement:mx.charts.chartClasses:IStackable) — Method in class mx.charts.series.AreaSeries
Stacks the series.
stack(stackedYValueDictionary:flash.utils:Dictionary, previousElement:mx.charts.chartClasses:IStackable) — Method in class mx.charts.series.BarSeries
Stacks the series.
stack(stackedXValueDictionary:flash.utils:Dictionary, previousElement:mx.charts.chartClasses:IStackable) — Method in class mx.charts.series.ColumnSeries
Stacks the series.
stackedMaximum — Property in class mx.charts.chartClasses.StackedSeries
The maximum sum represented by this stacked series.
StackedSeries — Class in package mx.charts.chartClasses
Stacked Series serves as the common base class for all of the stacking set series (BarSet, ColumnSet, and AreaSet).
StackedSeries() — Constructor in class mx.charts.chartClasses.StackedSeries
Constructor.
stacker — Property in interface mx.charts.chartClasses.IStackable
The StackedSeries associated with this series.
stacker — Property in class mx.charts.series.AreaSeries
The StackedSeries associated with this AreaSeries.
stacker — Property in class mx.charts.series.BarSeries
The StackedSeries associated with this BarSeries.
stacker — Property in class mx.charts.series.ColumnSeries
The StackedSeries associated with this BarSeries.
StackOverflowError — Dynamic class in package flash.errors
ActionScript throws a StackOverflowError exception when the stack available to the script is exhausted.
StackOverflowError(message:String) — Constructor in class flash.errors.StackOverflowError
Creates a new StackOverflowError object.
stackTotals — Property in interface mx.charts.chartClasses.IStackable
The stack totals for the series.
stackTotals — Property in class mx.charts.series.AreaSeries
The stack totals for the series.
stackTotals — Property in class mx.charts.series.BarSeries
The stack totals for the series.
stackTotals — Property in class mx.charts.series.ColumnSeries
The stack totals for the series.
stage — Property in class flash.display.DisplayObject
The Stage of the display object.
stage — Property in interface mx.managers.ISystemManager
The flash.display.Stage that represents the application window mapped to this SystemManager
Stage — Class in package flash.display
The Stage class represents the main drawing area.
StageAlign — Final class in package flash.display
The StageAlign class provides constant values to use for the Stage.align property.
stageFocusRect — Property in class flash.display.Stage
Specifies whether or not objects display a glowing border when they have focus.
stageHeight — Property in class flash.display.Stage
The current height, in pixels, of the Stage.
stageHeight — Property in class mx.preloaders.DownloadProgressBar
The height of the stage, which is passed in by the Preloader class.
stageHeight — Property in interface mx.preloaders.IPreloaderDisplay
The height of the stage, which is passed in by the Preloader class.
StageQuality — Final class in package flash.display
The StageQuality class provides values for the Stage.quality property.
StageScaleMode — Final class in package flash.display
The StageScaleMode class provides values for the Stage.scaleMode property.
stageWidth — Property in class flash.display.Stage
Specifies the current width, in pixels, of the Stage.
stageWidth — Property in class mx.preloaders.DownloadProgressBar
The width of the stage, which is passed in by the Preloader class.
stageWidth — Property in interface mx.preloaders.IPreloaderDisplay
The width of the stage, which is passed in by the Preloader class.
stageX — Property in class flash.events.MouseEvent
The horizontal coordinate at which the event occurred in global Stage coordinates.
stageY — Property in class flash.events.MouseEvent
The vertical coordinate at which the event occurred in global Stage coordinates.
STANDARD — Constant static property in class flash.ui.KeyLocation
Indicates the key activation is not distinguished as the left or right version of the key, and did not originate on the numeric keypad (or did not originate with a virtual key corresponding to the numeric keypad).
start() — Method in class flash.printing.PrintJob
Displays the operating system's Print dialog box, starts spooling, and sets the PrintJob read-only property values.
start() — Method in class flash.utils.Timer
Starts the timer, if it is not already running.
start — Property in class mx.charts.series.items.LineSeriesSegment
The index into the items array of the first item in this segment.
start — Property in class mx.effects.effectClasses.PropertyChanges
An Object containing the starting properties of the target component modified by the change in view state.
start() — Method in class mx.printing.FlexPrintJob
Initializes the PrintJob object.
startAngle — Property in class mx.charts.series.PieSeries
Specifies the starting angle for the first slice of the PieChart control.
startAngle — Property in class mx.charts.series.items.PieSeriesItem
The start angle, in radians, of this wedge.
startDelay — Property in class mx.effects.Effect
Amount of time, in milliseconds, to wait before starting the effect.
startDelay — Property in class mx.effects.EffectInstance
Amount of time, in milliseconds, to wait before starting the effect.
startDrag(lockCenter:Boolean, bounds:flash.geom:Rectangle) — Method in class flash.display.Sprite
Lets the user drag the specified sprite.
startDragging(event:flash.events:MouseEvent) — Method in class mx.containers.Panel
Called when the user starts dragging a Panel that has been popped up by the PopUpManager.
startEffect() — Method in class mx.effects.EffectInstance
Plays the effect instance on the target after the startDelay period has elapsed.
startingIndex — Property in interface mx.core.IRepeater
The index into the dataProvider at which this Repeater starts creating children.
startingIndex — Property in class mx.core.Repeater
The index into the dataProvider at which this Repeater starts creating children.
startTime — Property in class mx.effects.SoundEffect
The initial position in the MP3 file, in milliseconds, at which playback should start.
startTime — Property in class mx.effects.effectClasses.SoundEffectInstance
The initial position in the MP3 file, in milliseconds, at which playback should start.
state — Property in class mx.controls.VideoDisplay
The current state of the VideoDisplay control.
state — Property in class mx.events.VideoEvent
The value of the VideoDisplay.state property when the event occurs.
State — Class in package mx.states
The State class defines a view state, a particular view of a component.
State() — Constructor in class mx.states.State
Constructor.
stateChange — Event in class mx.controls.VideoDisplay
Dispatched when the state of the control changes.
STATE_CHANGE — Constant static property in class mx.events.VideoEvent
The VideoEvent.STATE_CHANGE constant defines the value of the type property of the event object for a stateChange event.
StateChangeEvent — Class in package mx.events
The StateChangeEvent class represents an event that is dispatched when the currentState property of a component changes.
StateChangeEvent(type:String, bubbles:Boolean, cancelable:Boolean, oldState:String, newState:String) — Constructor in class mx.events.StateChangeEvent
Constructor.
stateResponsive — Property in class mx.controls.VideoDisplay
Specifies whether the VideoDisplay control is in a responsive state, true, or in the unresponsive state, false.
stateResponsive — Property in class mx.events.VideoEvent
The value of the VideoDisplay.stateResponsive property when the event occurs.
states — Property in class mx.core.UIComponent
The view states that are defined for this component.
static — Statement
Specifies that a variable, constant, or method belongs to the class, rather than to instances of the class.
StaticText — Final class in package flash.text
This class represents StaticText objects on the display list.
status — Property in class flash.events.HTTPStatusEvent
The HTTP status code returned by the server.
status — Event in class flash.media.Camera
Dispatched when a camera reports its status.
status — Event in class flash.media.Microphone
Dispatched when a microphone reports its status.
status — Event in class flash.net.LocalConnection
Dispatched when a LocalConnection object reports its status.
status — Property in class mx.containers.Panel
Text in the status area of the title bar.
status(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageResponder
Called by the channel that created this MessageResponder when a fault response returns from the destination.
STATUS — Constant static property in class flash.events.StatusEvent
Defines the value of the type property of a status event object.
StatusEvent — Class in package flash.events
Flash® Player dispatches StatusEvent objects when a device, such as a camera or microphone, or an object such as a LocalConnection object reports its status.
StatusEvent(type:String, bubbles:Boolean, cancelable:Boolean, code:String, level:String) — Constructor in class flash.events.StatusEvent
Creates an Event object that contains information about status events.
statusHandler(message:mx.messaging.messages:IMessage) — Method in class mx.messaging.MessageResponder
Subclasses must override this method to perform custom processing of the status and invoke the proper callbacks on the associated MessageAgent.
statusStyleName — Style in class mx.containers.Panel
Style declaration name for the status in the title bar.
statusTextField — Property in class mx.containers.Panel
The UITextField sub-control that displays the status.
stepSize — Property in class mx.controls.NumericStepper
Non-zero unit of change between values.
stickyHighlighting — Property in class mx.controls.Button
If false, the Button displays its down skin when the user presses it but changes to its over skin when the user drags the mouse off of it.
stop() — Method in class flash.display.MovieClip
Stops the playhead in the movie clip.
stop() — Method in class flash.media.SoundChannel
Stops the sound playing in the channel.
stop() — Method in class flash.utils.Timer
Stops the timer.
stop() — Method in class mx.controls.VideoDisplay
Stops playback.
stopAll() — Static method in class flash.media.SoundMixer
Stops all sounds currently playing.
stopDrag() — Method in class flash.display.Sprite
Ends the startDrag() method.
stopDragging() — Method in class mx.containers.Panel
Called when the user stops dragging a Panel that has been popped up by the PopUpManager.
stopImmediatePropagation() — Method in class flash.events.Event
Prevents processing of any event listeners in the current node and any subsequent nodes in the event flow.
STOPPED — Constant static property in class mx.events.VideoEvent
The value of the VideoDisplay.state property when an FLV file is loaded but play has stopped.
stopPropagation() — Method in class flash.events.Event
Prevents processing of any event listeners in nodes subsequent to the current node in the event flow.
strength — Property in class flash.filters.BevelFilter
The strength of the imprint or spread.
strength — Property in class flash.filters.DropShadowFilter
The strength of the imprint or spread.
strength — Property in class flash.filters.GlowFilter
The strength of the imprint or spread.
strength — Property in class flash.filters.GradientBevelFilter
The strength of the imprint or spread.
strength — Property in class flash.filters.GradientGlowFilter
The strength of the imprint or spread.
strength — Property in class mx.effects.Glow
The strength of the imprint or spread.
strength — Property in class mx.effects.effectClasses.GlowInstance
The strength of the glow.
stretchCursor — Style in class mx.controls.DataGrid
The class to use as the skin for the cursor that indicates that a column can be resized.
String — Final class in Top Level
The String class is a data type that represents a string of characters.
String(expression) — Package function in Top Level
Returns a string representation of the specified parameter.
String(val:String) — Constructor in class String
Creates a new String object initialized to the specified string.
stringCompare(a:String, b:String, caseInsensitive:Boolean) — Static method in class mx.utils.ObjectUtil
Compares two String values.
stringToDate(valueString:String, inputFormat:String) — Static method in class mx.controls.DateField
Parses a String object that contains a date, and returns a Date object corresponding to the String.
StringUtil — Class in package mx.utils
The StringUtil utility class is an all-static class with methods for working with String objects within Flex.
StringValidator — Class in package mx.validators
The StringValidator class validates that the length of a String is within a specified range.
StringValidator() — Constructor in class mx.validators.StringValidator
Constructor.
stripNaNs(cache:Array, field:String) — Method in class mx.charts.chartClasses.Series
Removes any item from the provided cache whose field property is NaN.
stroke — Style in class mx.charts.Legend
Specifies the line stroke for the legend element.
stroke — Style in class mx.charts.LegendItem
Specifies the line stroke for the legend element.
stroke — Style in class mx.charts.series.AreaSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.BarSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.BubbleSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.CandlestickSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.ColumnSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.HLOCSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.LineSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.PieSeries
Sets the stroke style for this data series.
stroke — Style in class mx.charts.series.PlotSeries
Sets the stroke style for this data series.
Stroke — Class in package mx.graphics
The Stroke class defines the properties for a line.
Stroke(color:uint, weight:Number, alpha:Number, pixelHinting:Boolean, scaleMode:String, caps:String, joints:String, miterLimit:Number) — Constructor in class mx.graphics.Stroke
Constructor.
strokeColor — Style in class mx.controls.HRule
The color of the line.
strokeColor — Style in class mx.controls.VRule
The color of the line.
strokeWidth — Style in class mx.controls.HRule
The thickness of the rule in pixels.
strokeWidth — Style in class mx.controls.VRule
The thickness of the rule in pixels.
Style — MXML Only Component
You use the <mx:Style> tag to define styles that apply to the current document and its children.
styleChanged(styleProp:String) — Method in class mx.charts.chartClasses.CartesianChart
Detects changes to style properties.
styleChanged(styleProp:String) — Method in class mx.charts.chartClasses.HLOCSeriesBase
Detects changes to style properties.
styleChanged(styleProp:String) — Method in class mx.charts.series.BubbleSeries
Detects changes to style properties.
styleChanged(styleProp:String) — Method in class mx.core.UIComponent
Detects changes to style properties.
styleChanged(styleProp:String) — Method in class mx.core.UITextField
Detects changes to style properties.
styleChanged(styleProp:String) — Method in class mx.skins.ProgrammaticSkin
Whenever any style changes, redraw this skin.
styleChanged(styleProp:String) — Method in interface mx.styles.ISimpleStyleClient
Called when the value of a style property is changed.
styleDeclaration — Property in class mx.controls.dataGridClasses.DataGridItemRenderer
Storage for the inline inheriting styles on this object.
styleDeclaration — Property in class mx.core.UIComponent
Storage for the inline inheriting styles on this object.
styleDeclaration — Property in interface mx.styles.IStyleClient
The style declaration used by this object.
StyleManager — Class in package mx.styles
The StyleManager class manages the following:
  • Which CSS style properties the class inherits
  • Which style properties are colors, and therefore get special handling
  • A list of strings that are aliases for color values
styleName — Property in class mx.core.UIComponent
The class style used by this component.
styleName — Property in class mx.core.UITextField
The class style used by this component.
styleName — Property in class mx.skins.ProgrammaticSkin
A parent component used to obtain style values.
styleName — Property in interface mx.styles.ISimpleStyleClient
The source of this object's style values.
styleNames — Property in class flash.text.StyleSheet
An array that contains the names (as strings) of all of the styles registered in this style sheet.
stylesFactory — Property in class mx.core.UIComponentDescriptor
A Function that constructs an Object containing name/value pairs for the instance styles for the component, as specified in MXML.
styleSheet — Property in class flash.text.TextField
Attaches a style sheet to the text field.
styleSheet — Property in class mx.controls.TextArea
A flash.text.StyleSheet object that can perform rendering on the TextArea control's text.
StyleSheet — Dynamic class in package flash.text
The StyleSheet class lets you create a StyleSheet object that contains text formatting rules for font size, color, and other styles.
StyleSheet() — Constructor in class flash.text.StyleSheet
Creates a new StyleSheet object.
stylesInitialized() — Method in class mx.charts.chartClasses.Series
Calls the legendDataChanged() method.
stylesInitialized() — Method in class mx.core.UIComponent
Flex calls the stylesInitialized() method when the styles for a component are first initialized.
subField — Property in class mx.validators.ValidationResult
The name of the subfield that the result is associated with.
subFields — Property in class mx.validators.Validator
An Array of Strings containing the names for the properties contained in the value Object passed to the validate() method.
SUBPIXEL — Constant static property in class flash.text.GridFitType
Fits strong horizontal and vertical lines to the sub-pixel grid on LCD monitors.
subscribe(clientId:String) — Method in class mx.messaging.Consumer
Subscribes to the remote destination.
subscribed — Property in class mx.messaging.Consumer
Indicates whether the Consumer is currently subscribed.
SUBSCRIBE_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
This operation is used to subscribe to a remote destination.
substitute(str:String, ... rest) — Static method in class mx.utils.StringUtil
Substitutes "{n}" tokens within the specified string with the respective arguments passed in.
substr(startIndex:Number, len:Number) — Method in class String
Returns a substring consisting of the characters that start at the specified startIndex and with a length specified by len.
substring(startIndex:Number, endIndex:Number) — Method in class String
Returns a string consisting of the character specified by startIndex and all characters up to endIndex - 1.
subtopic — Property in class mx.messaging.Consumer
Setting the subtopic when the Consumer is connected and subscribed has the side effect of unsubscribing and resubscribing the Consumer.
subtopic — Property in class mx.messaging.MessageAgent
Provides access to the subtopic for the remote destination that the MessageAgent uses.
SUBTOPIC_HEADER — Constant static property in class mx.messaging.messages.AsyncMessage
Messages sent by a MessageAgent with a defined subtopic property indicate their target subtopic in this header.
subtract(v:flash.geom:Point) — Method in class flash.geom.Point
Subtracts the coordinates of another point from the coordinates of this point to create a new point.
SUBTRACT — Constant static property in class flash.display.BlendMode
Subtracts the values of the constituent colors in the display object from the values of the background color, applying a floor of 0.
super — Statement
Invokes the superclass or parent version of a method or constructor.
suspendBackgroundProcessing() — Static method in class mx.core.UIComponent
Blocks the background processing of methods queued by callLater(), until resumeBackgroundProcessing() is called.
suspendBackgroundProcessing — Property in class mx.effects.Effect
If true, blocks all background processing while the effect is playing.
suspendBackgroundProcessing — Property in class mx.effects.EffectInstance
If true, blocks all background processing while the effect is playing.
suspendEventHandling() — Static method in class mx.effects.EffectManager
After this method is called, the EffectManager class ignores all events, and no effects are triggered, until a call to resumeEventHandling().
swapChildren(child1:flash.display:DisplayObject, child2:flash.display:DisplayObject) — Method in class flash.display.DisplayObjectContainer
Swaps the z-order (front-to-back order) of the two specified child objects.
swapChildrenAt(index1:int, index2:int) — Method in class flash.display.DisplayObjectContainer
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
swapChildrenAt(index1:int, index2:int) — Method in class flash.display.Stage
Swaps the z-order (front-to-back order) of the child objects at the two specified index positions in the child list.
swatchBorderColor — Style in class mx.controls.ColorPicker
Color of the swatches' borders.
swatchBorderSize — Style in class mx.controls.ColorPicker
Size of the outlines of the swatches' borders.
swatchGridBackgroundColor — Style in class mx.controls.ColorPicker
Color of the background rectangle behind the swatch grid.
swatchGridBorderSize — Style in class mx.controls.ColorPicker
Size of the single border around the grid of swatches.
swatchHeight — Style in class mx.controls.ColorPicker
Height of each swatch.
swatchHighlightColor — Style in class mx.controls.ColorPicker
Color of the highlight that appears around the swatch when the user rolls over a swatch.
swatchHighlightSize — Style in class mx.controls.ColorPicker
Size of the highlight that appears around the swatch when the user rolls over a swatch.
SwatchPanelSkin — Class in package mx.skins.halo
The skin for the border of a SwatchPanel.
SwatchPanelSkin() — Constructor in class mx.skins.halo.SwatchPanelSkin
Constructor.
swatchPanelStyleName — Style in class mx.controls.ColorPicker
Name of the style for the SwatchPanel object.
SwatchSkin — Class in package mx.skins.halo
The skin used for all color swatches in a ColorPicker.
SwatchSkin() — Constructor in class mx.skins.halo.SwatchSkin
Constructor.
swatchWidth — Style in class mx.controls.ColorPicker
Width of each swatch.
SWFLoader — Class in package mx.controls
The SWFLoader control loads and displays a specified SWF file.
SWFLoader() — Constructor in class mx.controls.SWFLoader
Constructor.
swfVersion — Property in class flash.display.LoaderInfo
The file format version of the loaded SWF file.
SWFVersion — Final class in package flash.display
The SWFVersion class is an enumeration of constant values that indicate the file format version of a loaded SWF file.
switch — Statement
Causes control to transfer to one of several statements, depending on the value of an expression.
SwitchSymbolFormatter — Class in package mx.formatters
The SwitchSymbolFormatter class is a utility class that you can use when creating custom formatters.
SwitchSymbolFormatter(numberSymbol:String) — Constructor in class mx.formatters.SwitchSymbolFormatter
Constructor.
sync — Event in class flash.net.SharedObject
Dispatched when a remote shared object (SharedObject) has been updated by the server.
SYNC — Constant static property in class flash.events.SyncEvent
Defines the value of the type property of a sync event object.
SyncEvent — Class in package flash.events
Flash® Player dispatches SyncEvent objects when a remote SharedObject instance has been updated by the server.
SyncEvent(type:String, bubbles:Boolean, cancelable:Boolean, changeList:Array) — Constructor in class flash.events.SyncEvent
Creates an Event object that contains information about sync events.
SyntaxError — Dynamic class in Top Level
A SyntaxError exception is thrown when a parsing error occurs.
SyntaxError(message:String) — Constructor in class SyntaxError
Creates a new SyntaxError object.
System — Final class in package flash.system
The System class contains properties related to certain operations that take place on the user's computer, such as operations with shared objects, local settings for cameras and microphones, and use of the Clipboard.
systemManager — Property in interface mx.core.IUIComponent
A reference to the SystemManager object for this component.
systemManager — Property in class mx.core.UIComponent
Returns the SystemManager object used by this component.
systemManager — Property in class mx.core.UITextField
Returns the SystemManager object used by this component.
systemManager — Property in interface mx.managers.IFocusManagerContainer
Returns the SystemManager object used by this component.
SystemManager — Class in package mx.managers
The SystemManager class manages an application window.
SystemManager() — Constructor in class mx.managers.SystemManager
Constructor.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


T Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
T Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
TAB — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Tab key (9).
tabBar — Property in class mx.containers.TabNavigator
 | A reference to the TabBar inside this TabNavigator.
TabBar — Class in package mx.controls
 | The TabBar control lets you create a horizontal or vertical group of tab navigation items by defining the labels and data associated with each tab.
TabBar() — Constructor in class mx.controls.TabBar
 | Constructor.
tabChildren — Property in class flash.display.DisplayObjectContainer
 | Determines whether the children of the object are tab enabled.
tabChildren — Property in class flash.display.Stage
 | Determines whether the children of the object are tab enabled.
tabChildrenChange — Event in class flash.display.InteractiveObject
 | Dispatched when the value of the object's tabChildren flag changes.
TAB_CHILDREN_CHANGE — Constant static property in class flash.events.Event
 | Defines the value of the type property of a tabChildrenChange event object.
tabEnabled — Property in class flash.display.InteractiveObject
 | Specifies whether this object is in the tab order.
tabEnabled — Property in interface mx.managers.IFocusManagerComponent
 | A flag that indicates whether pressing the Tab key eventually moves focus to this component.
tabEnabledChange — Event in class flash.display.InteractiveObject
 | Dispatched when the object's tabEnabled flag changes.
TAB_ENABLED_CHANGE — Constant static property in class flash.events.Event
 | Defines the value of the type property of a tabEnabledChange event object.
tabHeight — Style in class mx.containers.TabNavigator
 | Height of each tab, in pixels.
tabHeight — Style in class mx.controls.TabBar
 | Height of each tab navigation item, in pixels.
tabIndex — Property in class flash.display.InteractiveObject
 | Specifies the tab ordering of objects in a SWF file.
tabIndex — Property in interface mx.managers.IFocusManagerComponent
 | If tabEnabled, the order in which the component receives focus.
tabIndexChange — Event in class flash.display.InteractiveObject
 | Dispatched when the value of the object's tabIndex property changes.
TAB_INDEX_CHANGE — Constant static property in class flash.events.Event
 | Defines the value of the type property of a tabIndexChange event object.
TabNavigator — Class in package mx.containers
 | The TabNavigator container extends the ViewStack container by including a TabBar container for navigating between its child containers.
TabNavigator() — Constructor in class mx.containers.TabNavigator
 | Constructor.
TabSkin — Class in package mx.skins.halo
 | The skin for all the states of a Tab in a TabNavigator or TabBar.
TabSkin() — Constructor in class mx.skins.halo.TabSkin
 | Constructor.
tabStops — Property in class flash.text.TextFormat
 | Specifies custom tab stops as an array of non-negative integers.
tabStyleName — Style in class mx.containers.TabNavigator
 | Name of CSS style declaration that specifies styles for the tabs.
tabStyleName — Style in class mx.controls.TabBar
 | Name of CSS style declaration that specifies the styles to use for the tab navigation items.
tabWidth — Style in class mx.containers.TabNavigator
 | Width of each tab, in pixels.
tabWidth — Style in class mx.controls.TabBar
 | Width of the tab navigation item, in pixels.
tan(angleRadians:Number) — Static method in class Math
 | Computes and returns the tangent of the specified angle.
target — Property in class flash.events.Event
 | The event target.
target — Property in class flash.text.TextFormat
 | Indicates the target window where the hyperlink is displayed.
target — Property in class mx.effects.Effect
 | The UIComponent object to which this effect is applied.
target — Property in class mx.effects.EffectInstance
 | The UIComponent object to which this effect is applied.
target — Property in class mx.effects.effectClasses.PropertyChanges
 | A target component of a transition.
target — Property in class mx.states.AddChild
 | The child to be added.
target — Property in class mx.states.RemoveChild
 | The child to remove from the view.
target — Property in class mx.states.SetEventHandler
 | The component that dispatches the event.
target — Property in class mx.states.SetProperty
 | The object containing the property to be changed.
target — Property in class mx.states.SetStyle
 | The object whose style is being changed.
targetArea — Property in class mx.effects.Dissolve
 | The area of the target to play the effect upon.
targetArea — Property in class mx.effects.effectClasses.DissolveInstance
 | The area of the target to play the effect upon.
targetArea — Property in class mx.effects.effectClasses.MaskEffectInstance
 | The area where the mask is applied on the target.
targetFactory — Property in class mx.states.AddChild
 | The factory that creates the child.
targetNamespace — Property in class mx.rpc.soap.Operation
targets — Property in class mx.effects.Effect
 | An Array of UIComponent objects that are targets for the effect.
targetSeries — Property in class mx.charts.effects.effectClasses.SeriesEffectInstance
 | The series targeted by this instance.
targetVisualBounds — Property in class mx.effects.effectClasses.MaskEffectInstance
 | The actual size of the effect target, including any drop shadows.
test(str:String) — Method in class RegExp
 | Tests for the match of the regular expression in the given string str.
text() — Method in class XML
 | Returns an XMLList object of all XML properties of the XML object that represent XML text nodes.
text() — Method in class XMLList
 | Calls the text() method of each XML object and returns an XMLList object that contains the results.
text — Property in class flash.events.TextEvent
 | For a textInput event, the character or sequence of characters entered by the user.
text — Property in class flash.text.StaticText
 | Returns the current text of the static text field.
text — Property in class flash.text.TextField
 | A string that is the current text in the text field.
text — Property in class mx.charts.AxisLabel
 | The text label that is actually rendered along the axis.
text() — Method in class mx.collections.XMLListCollection
 | Calls the text() method of each XML object in the XMLList and returns an XMLList containing the results.
text — Property in class mx.controls.Alert
 | The text to display in this alert dialog box.
text — Property in class mx.controls.ComboBase
 | Contents of the text field.
text — Property in class mx.controls.Label
 | Specifies the plain text displayed by this control.
text — Property in class mx.controls.RichTextEditor
 | Plain text without markup that displays in the RichTextEditor control's TextArea subcontrol.
text — Property in class mx.controls.TextArea
 | Plain text that appears in the control.
text — Property in class mx.controls.TextInput
 | Plain text that appears in the control.
text — Property in class mx.controls.ToolTip
 | The text displayed by the ToolTip.
text — Property in class mx.controls.textClasses.TextRange
 | Plain-text contents of the range.
text — Property in interface mx.core.IToolTip
 | The text that appears in the tooltip.
Text — Class in package mx.controls
 | The Text control displays multiline, noneditable text.
Text() — Constructor in class mx.controls.Text
 | Constructor.
TEXT — Constant static property in class flash.net.URLLoaderDataFormat
 | Specifies that downloaded data is received as text.
textAlign — Style in class mx.charts.PieChart
 | Alignment of text within a container.
textAlign — Style in class mx.charts.chartClasses.CartesianChart
 | Alignment of text within a container.
textAlign — Style in class mx.charts.chartClasses.DataTip
 | Alignment of text within a container.
textAlign — Style in class mx.containers.FormHeading
 | Alignment of text within a container.
textAlign — Style in class mx.controls.Button
 | Alignment of text within a container.
textAlign — Style in class mx.controls.ColorPicker
 | Alignment of text within a container.
textAlign — Style in class mx.controls.ComboBox
 | Alignment of text within a container.
textAlign — Style in class mx.controls.DateChooser
 | Alignment of text within a container.
textAlign — Style in class mx.controls.DateField
 | Alignment of text within a container.
textAlign — Style in class mx.controls.Label
 | Alignment of text within a container.
textAlign — Style in class mx.controls.MenuBar
 | Alignment of text within a container.
textAlign — Style in class mx.controls.NumericStepper
 | Alignment of text within a container.
textAlign — Style in class mx.controls.ProgressBar
 | Alignment of text within a container.
textAlign — Style in class mx.controls.TextInput
 | Alignment of text within a container.
textAlign — Style in class mx.controls.ToolTip
 | Alignment of text within a container.
textAlign — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Alignment of text within a container.
textAlign — Style in class mx.controls.menuClasses.MenuBarItem
 | Alignment of text within a container.
textAlign — Property in class mx.controls.textClasses.TextRange
 | Alignment of the text in the range.
textAlign — Style in class mx.core.Container
 | Alignment of text within a container.
textAlign — Style in class mx.core.ScrollControlBase
 | Alignment of text within a container.
textAlign — Style in class mx.core.UITextField
 | Alignment of text within a container.
TextArea — Class in package mx.controls
 | The TextArea control is a multiline text field with a border and optional scroll bars.
TextArea() — Constructor in class mx.controls.TextArea
 | Constructor.
textAreaStyleName — Style in class mx.controls.RichTextEditor
 | Name of the CSS Style declaration to use for the styles for the TextArea.
textColor — Property in class flash.text.TextField
 | The color of the text in a text field, in hexadecimal format.
TextColorType — Final class in package flash.text
 | The TextColorType class provides color values for the flash.text.TextRenderer class.
textDecoration — Style in class mx.charts.AxisRenderer
 | Determines whether the text is underlined.
textDecoration — Style in class mx.charts.chartClasses.ChartBase
 | Determines whether the text is underlined.
textDecoration — Style in class mx.charts.chartClasses.DataTip
 | Determines whether the text is underlined.
textDecoration — Style in class mx.charts.series.PieSeries
 | Determines whether the text is underlined.
textDecoration — Style in class mx.containers.FormHeading
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.Button
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.ColorPicker
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.ComboBox
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.DateChooser
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.DateField
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.Label
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.MenuBar
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.NumericStepper
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.ProgressBar
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.TextInput
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.ToolTip
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Determines whether the text is underlined.
textDecoration — Style in class mx.controls.menuClasses.MenuBarItem
 | Determines whether the text is underlined.
textDecoration — Property in class mx.controls.textClasses.TextRange
 | Decoration of the font in the range, as "underline" or "normal".
textDecoration — Style in class mx.core.Container
 | Determines whether the text is underlined.
textDecoration — Style in class mx.core.ScrollControlBase
 | Determines whether the text is underlined.
textDecoration — Style in class mx.core.UITextField
 | Determines whether the text is underlined.
TextDisplayMode — Final class in package flash.text
 | The TextDisplayMode class contains values that control the subpixel anti-aliasing of the FlashType system.
TextEvent — Class in package flash.events
 | Flash® Player dispatches TextEvent objects when a user enters text in a text field or clicks a hyperlink in an HTML-enabled text field.
TextEvent(type:String, bubbles:Boolean, cancelable:Boolean, text:String) — Constructor in class flash.events.TextEvent
 | Creates an Event object that contains information about text events.
textField — Property in class mx.controls.Button
 | The internal UITextField object that renders the label of this Button.
textField — Property in class mx.controls.Label
 | The internal UITextField that renders the text of this Label.
textField — Property in class mx.controls.TextArea
 | The internal UITextField that renders the text of this TextArea.
textField — Property in class mx.controls.TextInput
 | The internal UITextField that renders the text of this TextInput.
textField — Property in class mx.controls.ToolTip
 | The internal UITextField that renders the text of this ToolTip.
TextField — Class in package flash.text
 | The TextField class is used to create display objects for text display and input.
TextField() — Constructor in class flash.text.TextField
 | Creates a new TextField instance.
TextFieldAsset — Class in package mx.core
 | TextFieldAsset is a subclass of the Flash Player's TextField class which represents TextField symbols that you embed in a Flex application from a SWF file produced by Flash.
TextFieldAsset() — Constructor in class mx.core.TextFieldAsset
 | Constructor.
TextFieldAutoSize — Final class in package flash.text
 | The TextFieldAutoSize class is an enumeration of constant values used in setting the autoSize property of the TextField class.
TextFieldType — Final class in package flash.text
 | The TextFieldType class is an enumeration of constant values used in setting the type property of the TextField class.
textFieldWidth — Style in class mx.controls.ColorPicker
 | Width of the text box that appears above the swatch grid.
TextFormat — Class in package flash.text
 | The TextFormat class represents character formatting information.
TextFormat(font:String, size:Object, color:Object, bold:Object, italic:Object, underline:Object, url:String, target:String, align:String, leftMargin:Object, rightMargin:Object, indent:Object, leading:Object) — Constructor in class flash.text.TextFormat
 | Creates a TextFormat object with the specified properties.
TextFormatAlign — Final class in package flash.text
 | The TextFormatAlign class provides values for text alignment in the TextFormat class.
textHeight — Property in class flash.text.TextField
 | The height of the text in pixels.
textHeight — Property in class mx.controls.Label
 | The height of the text.
textHeight — Property in class mx.controls.TextArea
 | The height of the text.
textHeight — Property in class mx.controls.TextInput
 | The height of the text.
textIndent — Style in class mx.charts.chartClasses.DataTip
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.containers.FormHeading
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.Button
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.ColorPicker
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.ComboBox
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.DateChooser
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.DateField
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.Label
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.Menu
 | The offset of the first line of text from the left side of the menu or submenu menu item.
textIndent — Style in class mx.controls.MenuBar
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.NumericStepper
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.ProgressBar
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.TextInput
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.ToolTip
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.dataGridClasses.DataGridColumn
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.controls.menuClasses.MenuBarItem
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.core.Container
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.core.ScrollControlBase
 | Offset of first line of text from the left side of the container, in pixels.
textIndent — Style in class mx.core.UITextField
 | Offset of first line of text from the left side of the container, in pixels.
textInput — Event in class flash.text.TextField
 | Flash Player dispatches the textInput event when a user enters one or more characters of text.
textInput — Property in class mx.controls.ComboBase
 | The internal TextInput subcomponent that displays the current selection.
textInput — Event in class mx.controls.TextArea
 | Dispatched when the user types, deletes, or pastes text into the control.
textInput — Event in class mx.controls.TextInput
 | Dispatched when the user types, deletes, or pastes text into the control.
TextInput — Class in package mx.controls
 | The TextInput control is a single-line text field that is optionally editable.
TextInput() — Constructor in class mx.controls.TextInput
 | Constructor.
TEXT_INPUT — Constant static property in class flash.events.TextEvent
 | Defines the value of the type property of a textInput event object.
textInput_changeHandler(event:flash.events:Event) — Method in class mx.controls.ComboBase
 | Handles changes to the TextInput that serves as the editable text field in the component.
TextLineMetrics — Class in package flash.text
 | The TextLineMetrics class contains information about the text position and measurements of a line of text within a text field.
TextLineMetrics(x:Number, width:Number, height:Number, ascent:Number, descent:Number, leading:Number) — Constructor in class flash.text.TextLineMetrics
 | Creates a TextLineMetrics object.
TEXT_NODE — Constant static property in class flash.xml.XMLNodeType
 | Specifies that the node is a text node.
TextRange — Class in package mx.controls.textClasses
 | The TextRange class provides properties that select and format a range of text in the Label, Text, TextArea, TextEditor, and RichTextEditor controls.
TextRange(owner:mx.core:UIComponent, modifiesSelection:Boolean, beginIndex:int, endIndex:int) — Constructor in class mx.controls.textClasses.TextRange
 | Create a new TextRange Object that represents a subset of the contents of a text control, including the formatting information.
TextRenderer — Final class in package flash.text
 | The TextRenderer class provides functionality for the advanced anti-aliasing capability of embedded fonts.
textRollOverColor — Style in class mx.containers.Accordion
 | Color of header text when rolled over.
textRollOverColor — Style in class mx.controls.Button
 | Text color of the label as the user moves the mouse pointer over the button.
textRollOverColor — Style in class mx.controls.ComboBox
 | The textRollOverColor of the drop-down list.
textRollOverColor — Style in class mx.controls.LinkBar
 | Text color of the link as you move the mouse pointer over it.
textRollOverColor — Style in class mx.controls.LinkButton
 | Text color of a LinkButton as a user moves the mouse pointer over it.
textRollOverColor — Style in class mx.controls.Menu
 | The color of the menu item text when a user rolls the mouse over the menu item.
textRollOverColor — Style in class mx.controls.Tree
 | Color of the text when the user rolls over a row.
textRollOverColor — Style in class mx.controls.listClasses.ListBase
 | The color of the text of a renderer when the user rolls over a it.
textSelectedColor — Style in class mx.containers.Accordion
 | Color of selected text.
textSelectedColor — Style in class mx.controls.Button
 | Text color of the label as the user presses it.
textSelectedColor — Style in class mx.controls.ComboBox
 | The textSelectedColor of the drop-down list.
textSelectedColor — Style in class mx.controls.LinkBar
 | Text color of the link as you press it.
textSelectedColor — Style in class mx.controls.LinkButton
 | Text color of a LinkButton as a user presses it.
textSelectedColor — Style in class mx.controls.Menu
 | The color of the menu item text when the menu item is selected.
textSelectedColor — Style in class mx.controls.Tree
 | Color of the text when the user selects a row.
textSelectedColor — Style in class mx.controls.listClasses.ListBase
 | The color of the text of a renderer when the user selects it.
textSnapshot — Property in class flash.display.DisplayObjectContainer
 | Returns a TextSnapshot object for this DisplayObjectContainer instance.
textSnapshot — Property in class flash.display.Stage
 | Returns a TextSnapshot object for this DisplayObjectContainer instance.
TextSnapshot — Class in package flash.text
 | TextSnapshot objects let you work with static text in a movie clip.
textWidth — Property in class flash.text.TextField
 | The width of the text in pixels.
textWidth — Property in class mx.controls.Label
 | The width of the text.
textWidth — Property in class mx.controls.TextArea
 | The width of the text.
textWidth — Property in class mx.controls.TextInput
 | The width of the text.
themeColor — Style in class mx.controls.ProgressBar
 | Theme color of the ProgressBar control.
themeColor — Style in class mx.core.UIComponent
 | Theme color of a component.
thickness — Property in class flash.text.TextField
 | The thickness of the glyph edges in this text field.
thickness — Property in class mx.charts.renderers.CrossItemRenderer
 | The thickness of the cross rendered, in pixels.
thickness — Property in class mx.core.UITextFormat
 | Defines the thickness setting for the UITextField class.
THICKNESS — Constant static property in class mx.controls.scrollClasses.ScrollBar
 | The width of a vertical scrollbar, or the height of a horizontal scrollbar, in pixels.
this — Statement
 | A reference to a method's containing object.
thousandsSeparator — Property in class mx.validators.CurrencyValidator
 | The character used to separate thousands.
thousandsSeparator — Property in class mx.validators.NumberValidator
 | The character used to separate thousands in the whole part of the number.
thousandsSeparatorFrom — Property in class mx.formatters.CurrencyFormatter
 | Character to use as the thousands separator in the input String.
thousandsSeparatorFrom — Property in class mx.formatters.NumberBase
 | Character to use as the thousands separator in the input String.
thousandsSeparatorFrom — Property in class mx.formatters.NumberFormatter
 | Character to use as the thousands separator in the input String.
thousandsSeparatorTo — Property in class mx.formatters.CurrencyFormatter
 | Character to use as the thousands separator in the output string.
thousandsSeparatorTo — Property in class mx.formatters.NumberBase
 | Character to use as the thousands separator in the output String.
thousandsSeparatorTo — Property in class mx.formatters.NumberFormatter
 | Character to use as the thousands separator in the output String.
threshold(sourceBitmapData:flash.display:BitmapData, sourceRect:flash.geom:Rectangle, destPoint:flash.geom:Point, operation:String, threshold:uint, color:uint, mask:uint, copySource:Boolean) — Method in class flash.display.BitmapData
 | Tests pixel values in an image against a specified threshold and sets pixels that pass the test to new color values.
throw — Statement
 | Generates, or throws, an error that can be handled, or caught, by a catch code block.
THUMB — Constant static property in class mx.events.SliderEventClickTarget
 | Specifies that the Slider's thumb was clicked.
thumbCount — Property in class mx.controls.sliderClasses.Slider
 | The number of thumbs allowed on the slider.
thumbDisabledSkin — Style in class mx.controls.sliderClasses.Slider
 | The skin for the slider thumb disabled state.
thumbDownSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the thumb of the scroll bar when you click the thumb.
thumbDownSkin — Style in class mx.controls.sliderClasses.Slider
 | The skin for the slider thumb down state.
thumbDrag — Event in class mx.controls.sliderClasses.Slider
 | Dispatched when the slider's thumb is pressed and then moved by the mouse.
THUMB_DRAG — Constant static property in class mx.events.SliderEvent
 | The SliderEvent.THUMB_DRAG constant defines the value of the type property of the event object for a thumbDrag event.
thumbIcon — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the icon for the thumb of the scroll bar.
thumbIndex — Property in class mx.events.SliderEvent
 | The zero-based index of the thumb whose position has changed.
thumbOffset — Style in class mx.controls.sliderClasses.Slider
 | The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the thumb relative to the track.
thumbOverSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the thumb of the scroll bar when the mouse pointer is over the thumb.
thumbOverSkin — Style in class mx.controls.sliderClasses.Slider
 | The skin for the slider thumb over state.
THUMB_POSITION — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar thumb has stopped moving.
thumbPress — Event in class mx.controls.sliderClasses.Slider
 | Dispatched when the slider's thumb is pressed, meaning the user presses the mouse button over the thumb.
THUMB_PRESS — Constant static property in class mx.events.SliderEvent
 | The SliderEvent.THUMB_PRESS constant defines the value of the type property of the event object for a thumbPress event.
thumbRelease — Event in class mx.controls.sliderClasses.Slider
 | Dispatched when the slider's thumb is released, meaning the user releases the mouse button after a thumbPress event.
THUMB_RELEASE — Constant static property in class mx.events.SliderEvent
 | The SliderEvent.THUMB_RELEASE constant defines the value of the type property of the event object for a thumbRelease event.
THUMB_TRACK — Constant static property in class mx.events.ScrollEventDetail
 | Indicates that the scroll bar thumb is moving.
thumbUpSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the thumb of the scroll bar.
thumbUpSkin — Style in class mx.controls.sliderClasses.Slider
 | The skin for the slider thumb up state.
tickColor — Style in class mx.controls.sliderClasses.Slider
 | The color of the tick marks.
tickInterval — Property in class mx.controls.sliderClasses.Slider
 | The spacing of the tick marks relative to the maximum value of the control.
tickLength — Style in class mx.charts.AxisRenderer
 | Specifies the length of the tick marks on the axis, in pixels.
tickLength — Style in class mx.controls.sliderClasses.Slider
 | The length in pixels of the tick marks.
tickOffset — Style in class mx.controls.sliderClasses.Slider
 | The y-position offset (if direction is horizontal) or x-position offset (if direction is vertical) of the tick marks relative to the track.
tickPlacement — Style in class mx.charts.AxisRenderer
 | Specifies where to draw the tick marks.
ticks — Property in class mx.charts.AxisRenderer
 | Contains an array that specifies where Flex draws the tick marks along the axis.
ticks — Property in class mx.charts.chartClasses.AxisLabelSet
 | An array of values from 0 to 1 representing where to place tick marks along the axis.
ticks — Property in interface mx.charts.chartClasses.IAxisRenderer
 | Contains an array that specifies where Flex draws the tick marks along the axis.
ticks — Property in class mx.charts.chartClasses.NumericAxis
 | An Array of tick marks for this axis.
ticksBetweenLabels — Property in class mx.charts.CategoryAxis
 | Specifies the location of major tick marks on the axis, relative to the category labels.
tickStroke — Style in class mx.charts.AxisRenderer
 | Specifies the characteristics of the tick marks on the axis.
tickThickness — Style in class mx.controls.sliderClasses.Slider
 | The thickness in pixels of the tick marks.
Tile — Class in package mx.containers
 | A Tile container lays out its children in a grid of equal-sized cells.
Tile() — Constructor in class mx.containers.Tile
 | Constructor.
TileBase — Class in package mx.controls.listClasses
 | The TileBase class is the base class for controls that display data items in a sequence of rows and columns.
TileBase() — Constructor in class mx.controls.listClasses.TileBase
 | Constructor.
TileBaseDirection — Final class in package mx.controls.listClasses
 | Values for the direction property of the TileList component.
TileDirection — Final class in package mx.containers
 | The TileDirection class defines the constant values for the direction property of the Tile container.
tileHeight — Property in class mx.containers.Tile
 | Height of each tile cell, in pixels.
TileList — Class in package mx.controls
 | The TileList control displays a number of items laid out in tiles.
TileList() — Constructor in class mx.controls.TileList
 | Constructor.
TileListItemRenderer — Class in package mx.controls.listClasses
 | The TileListItemRenderer class defines the default item renderer for the HorizontalList and TileList controls.
TileListItemRenderer() — Constructor in class mx.controls.listClasses.TileListItemRenderer
 | Constructor.
tileWidth — Property in class mx.containers.Tile
 | Width of each tile cell, in pixels.
time — Property in class Date
 | The number of milliseconds since midnight January 1, 1970, universal time, for a Date object.
time — Property in class flash.net.NetStream
 | The position of the playhead, in seconds.
timeOfDay — Static property in class mx.formatters.DateBase
 | Time of day names.
timer — Event in class flash.utils.Timer
 | Dispatched whenever a Timer object reaches an interval specified according to the Timer.delay property.
Timer — Class in package flash.utils
 | The Timer class is the interface to Flash Player timers.
Timer(delay:Number, repeatCount:int) — Constructor in class flash.utils.Timer
 | Constructs a new Timer object with the specified delay and repeatCount states.
TIMER — Constant static property in class flash.events.TimerEvent
 | Defines the value of the type property of a timer event object.
timerComplete — Event in class flash.utils.Timer
 | Dispatched whenever it has completed the number of requests set by Timer.repeatCount.
TIMER_COMPLETE — Constant static property in class flash.events.TimerEvent
 | Defines the value of the type property of a timerComplete event object.
TimerEvent — Class in package flash.events
 | Flash® Player dispatches TimerEvent objects whenever a Timer object reaches the interval specified by the Timer.delay property.
TimerEvent(type:String, bubbles:Boolean, cancelable:Boolean) — Constructor in class flash.events.TimerEvent
 | Creates an Event object with specific information relevant to timer events.
timestamp — Property in class mx.messaging.Consumer
 | Contains the timestamp of the most recent message this Consumer has received.
timestamp — Property in class mx.messaging.messages.AbstractMessage
 | Provides access to the time stamp for the message.
timestamp — Property in interface mx.messaging.messages.IMessage
 | Provides access to the time stamp for the message.
timeToLive — Property in class mx.messaging.messages.AbstractMessage
 | The time to live value of a message indicates how long the message should be considered valid and deliverable.
timeToLive — Property in interface mx.messaging.messages.IMessage
 | The time to live value of a message indicates how long the message should be considered valid and deliverable.
timezoneOffset — Property in class Date
 | The difference, in minutes, between the computer's local time and universal time (UTC).
title — Property in class mx.charts.chartClasses.AxisBase
 | The text for the title displayed along the axis.
title — Property in interface mx.charts.chartClasses.IAxis
 | The text for the title displayed along the axis.
title — Property in class mx.containers.Panel
 | Title or caption displayed in the title bar.
TitleBackground — Class in package mx.skins.halo
 | The skin for a title bar area of a Panel.
TitleBackground() — Constructor in class mx.skins.halo.TitleBackground
 | Constructor.
titleBackgroundSkin — Style in class mx.containers.Panel
 | The title background skin.
titleBar — Property in class mx.containers.Panel
 | The TitleBar sub-control that displays the Panel container's title bar.
titleIcon — Property in class mx.containers.Panel
 | The icon displayed in the title bar.
titleStyleName — Style in class mx.containers.Panel
 | Style declaration name for the text in the title bar.
titleStyleName — Style in class mx.controls.Alert
 | Name of the CSS style declaration that specifies styles for the Alert title text.
titleTextField — Property in class mx.containers.Panel
 | The UITextField sub-control that displays the title.
TitleWindow — Class in package mx.containers
 | A TitleWindow navigator container contains a title bar, a caption, a border, and a content area for its child.
TitleWindow() — Constructor in class mx.containers.TitleWindow
 | Constructor.
tlRadius — Property in class mx.graphics.RectangularDropShadow
 | The corner radius of the top left corner of the rounded rectangle that is casting the shadow.
toArray() — Method in interface mx.collections.IList
 | Returns an Array that is populated in the same order as the IList implementation.
toArray() — Method in class mx.collections.ListCollectionView
 | Returns an Array that is populated in the same order as the IList implementation.
toArray(obj:Object) — Static method in class mx.utils.ArrayUtil
 | Ensures that an Object can be used as an Array.
toDateString() — Method in class Date
 | Returns a string representation of the day and date only, and does not include the time or timezone.
todayColor — Style in class mx.controls.DateChooser
 | Color of the background of today's date.
todayColor — Style in class mx.controls.DateField
 | Color of the highlight of today's date in the DateChooser control.
todayIndicatorSkin — Style in class mx.controls.DateChooser
 | Name of the class to use as the skin for the highlight area of today's date in the DateChooser control.
todayStyleName — Style in class mx.controls.DateChooser
 | Name of the style sheet definition to configure the appearance of the current day's numeric text, which is highlighted in the control when the showToday property is true.
todayStyleName — Style in class mx.controls.DateField
 | Name of the style sheet definition to configure the appearance of the current day's numeric text, which is highlighted in the control when the showToday property is true.
toExponential(fractionDigits:uint) — Method in class int
 | Returns a string representation of the number in exponential notation.
toExponential(fractionDigits:uint) — Method in class Number
 | Returns a string representation of the number in exponential notation.
toExponential(fractionDigits:uint) — Method in class uint
 | Returns a string representation of the number in exponential notation.
toFixed(fractionDigits:uint) — Method in class int
 | Returns a string representation of the number in fixed-point notation.
toFixed(fractionDigits:uint) — Method in class Number
 | Returns a string representation of the number in fixed-point notation.
toFixed(fractionDigits:uint) — Method in class uint
 | Returns a string representation of the number in fixed-point notation.
toggle — Property in class mx.controls.Button
 | Controls whether a Button is in a toggle state or not.
ToggleButtonBar — Class in package mx.controls
 | The ToggleButtonBar control defines a horizontal or vertical group of buttons that maintain their selected or deselected state.
ToggleButtonBar() — Constructor in class mx.controls.ToggleButtonBar
 | Constructor.
toggleOnClick — Property in class mx.controls.ToggleButtonBar
 | Specifies whether the currently selected button can be deselected by the user.
togglePause() — Method in class flash.net.NetStream
 | Pauses or resumes playback of a stream.
token — Property in class mx.rpc.events.AbstractEvent
 | The token that represents the call to the method.
toLocaleDateString() — Method in class Date
 | Returns a String representation of the day and date only, and does not include the time or timezone.
toLocaleLowerCase() — Method in class String
 | Returns a copy of this string, with all uppercase characters converted to lowercase.
toLocaleString() — Method in class Array
 | Returns a string that represents the elements in the specified array.
toLocaleString() — Method in class Date
 | Returns a String representation of the day, date, time, given in local time.
toLocaleTimeString() — Method in class Date
 | Returns a String representation of the time only, and does not include the day, date, year, or timezone.
toLocaleUpperCase() — Method in class String
 | Returns a copy of this string, with all lowercase characters converted to uppercase.
toLowerCase() — Method in class String
 | Returns a copy of this string, with all uppercase characters converted to lowercase.
tooLongError — Property in class mx.validators.StringValidator
 | Error message when the String is longer than the maxLength property.
toolTip — Property in class mx.core.UIComponent
 | Text to display in the ToolTip.
toolTip — Property in class mx.core.UITextField
 | Text to display in the ToolTip.
toolTip — Property in class mx.events.ToolTipEvent
 | The ToolTip object to which this event applies.
toolTip — Property in interface mx.managers.IToolTipManagerClient
 | The text of this component's tooltip.
ToolTip — Class in package mx.controls
 | The ToolTip control lets you provide helpful information to your users.
ToolTip() — Constructor in class mx.controls.ToolTip
 | Constructor.
ToolTipBorder — Class in package mx.skins.halo
 | The skin for a ToolTip.
ToolTipBorder() — Constructor in class mx.skins.halo.ToolTipBorder
 | Constructor.
toolTipChildren — Property in interface mx.managers.ISystemManager
 | A list of the tooltips being parented by this ISystemManager.
toolTipChildren — Property in class mx.managers.SystemManager
 | A list of the tooltips being parented by this ISystemManager.
toolTipClass — Static property in class mx.managers.ToolTipManager
 | The class to use for creating ToolTips.
toolTipCreate — Event in class mx.core.UIComponent
 | Dispatched by the component when it is time to create a ToolTip.
TOOL_TIP_CREATE — Constant static property in class mx.events.ToolTipEvent
 | The ToolTipEvent.TOOL_TIP_CREATE constant defines the value of the type property of the event object for a toolTipCreate event.
toolTipEnd — Event in class mx.core.UIComponent
 | Dispatched by the component when its ToolTip has been hidden and will be discarded soon.
TOOL_TIP_END — Constant static property in class mx.events.ToolTipEvent
 | The ToolTipEvent.TOOL_TIP_END constant defines the value of the type property of the event object for a toolTipEnd event.
ToolTipEvent — Class in package mx.events
 | The ToolTipEvent class represents ToolTip events, which are generated by the ToolTipManager class.
ToolTipEvent(type:String, bubbles:Boolean, cancelable:Boolean, toolTip:mx.core:IToolTip) — Constructor in class mx.events.ToolTipEvent
 | Constructor.
toolTipField — Property in class mx.controls.NavBar
 | Name of the the field in the dataProvider object to display as the tooltip label.
toolTipHide — Event in class mx.core.UIComponent
 | Dispatched by the component when its ToolTip is about to be hidden.
TOOL_TIP_HIDE — Constant static property in class mx.events.ToolTipEvent
 | The ToolTipEvent.TOOL_TIP_HIDE constant defines the value of the type property of the event object for a toolTipHide event.
ToolTipManager — Class in package mx.managers
 | The ToolTipManager lets you set basic ToolTip and error tip functionality, such as display delay and the disabling of ToolTips.
toolTipShow — Event in class mx.core.UIComponent
 | Dispatched by the component when its ToolTip is about to be shown.
TOOL_TIP_SHOW — Constant static property in class mx.events.ToolTipEvent
 | The ToolTipEvent.TOOL_TIP_SHOW constant defines the value of the type property of the event object for a toolTipShow event.
toolTipShowHandler(event:mx.events:ToolTipEvent) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | The event handler to position the tooltip.
toolTipShowHandler(event:mx.events:ToolTipEvent) — Method in class mx.controls.listClasses.ListItemRenderer
 | Positions the tooltip.
toolTipShowHandler(event:mx.events:ToolTipEvent) — Method in class mx.controls.listClasses.TileListItemRenderer
 | Positions the tooltip.
toolTipShown — Event in class mx.core.UIComponent
 | Dispatched by the component when its ToolTip has been shown.
TOOL_TIP_SHOWN — Constant static property in class mx.events.ToolTipEvent
 | The ToolTipEvent.TOOL_TIP_SHOWN constant defines the value of the type property of the event object for a toolTipShown event.
toolTipStart — Event in class mx.core.UIComponent
 | Dispatched by a component whose toolTip property is set, as soon as the user moves the mouse over it.
TOOL_TIP_START — Constant static property in class mx.events.ToolTipEvent
 | The ToolTipEvent.TOOL_TIP_START constant defines the value of the type property of the event object for a toolTipStart event.
tooManyAtSignsError — Property in class mx.validators.EmailValidator
 | Error message when there is more than one at sign in the e-mail address.
tooShortError — Property in class mx.validators.StringValidator
 | Error message when the string is shorter than the minLength property.
top — Property in class flash.geom.Rectangle
 | The y coordinate of the top-left corner of the rectangle.
top — Property in class mx.core.EdgeMetrics
 | The height, in pixels, of the top edge region.
top — Style in class mx.core.UIComponent
 | The vertical distance in pixels from the top edge of the component's parent container to the top edge of the component.
TOP — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned at the top.
TOP — Constant static property in class mx.controls.ButtonLabelPlacement
 | Specifies that the label appears above the icon.
TOP — Constant static property in class mx.controls.ProgressBarLabelPlacement
 | Specifies to place the label above the progress bar.
topLeft — Property in class flash.geom.Rectangle
 | The location of the Rectangle object's top-left corner, determined by the x and y coordinates of the point.
TOP_LEFT — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned in the top-left corner.
topLevelSystemManager — Property in interface mx.managers.ISystemManager
 | The ISystemManager responsible for the application window.
topLevelSystemManager — Property in class mx.managers.SystemManager
 | Returns the SystemManager responsible for the application window.
Top Level — Package
 | The top level contains the core ActionScript classes and global functions.
toPrecision(precision:uint) — Method in class int
 | Returns a string representation of the number either in exponential notation or in fixed-point notation.
toPrecision(precision:uint) — Method in class Number
 | Returns a string representation of the number either in exponential notation or in fixed-point notation.
toPrecision(precision:uint) — Method in class uint
 | Returns a string representation of the number either in exponential notation or in fixed-point notation.
TOP_RIGHT — Constant static property in class flash.display.StageAlign
 | Specifies that the Stage is aligned in the top-right corner.
toState — Property in class mx.states.Transition
 | A String specifying the view state that you are changing to when you apply the transition.
toString() — Method in class Array
 | Returns a string that represents the elements in the specified array.
toString() — Method in class Boolean
 | Returns the string representation ("true" or "false") of the Boolean object.
toString() — Method in class Date
 | Returns a String representation of the day, date, time, and timezone.
toString() — Method in class Error
 | Returns the string "Error" by default or the value contained in Error.message property, if defined.
toString(radix:uint) — Method in class int
 | Returns the string representation of an int object.
toString() — Method in class Namespace
 | Equivalent to the Namespace.uri property.
toString(radix:Number) — Method in class Number
 | Returns the string representation of the specified Number object (myNumber).
toString() — Method in class Object
 | Returns the string representation of the specified object.
toString() — Method in class QName
 | Returns a string composed of the URI, and the local name for the QName object, separated by "::".
toString(radix:uint) — Method in class uint
 | Returns the string representation of a uint object.
toString() — Method in class XML
 | Returns a string representation of the XML object.
toString() — Method in class XMLList
 | Returns a string representation of all the XML objects in an XMLList object.
toString() — Method in class flash.events.ActivityEvent
 | Returns a string that contains all the properties of the ActivityEvent object.
toString() — Method in class flash.events.AsyncErrorEvent
 | Returns a string that contains all the properties of the AsyncErrorEvent object.
toString() — Method in class flash.events.ContextMenuEvent
 | Returns a string that contains all the properties of the ContextMenuEvent object.
toString() — Method in class flash.events.DataEvent
 | Returns a string that contains all the properties of the DataEvent object.
toString() — Method in class flash.events.ErrorEvent
 | Returns a string that contains all the properties of the ErrorEvent object.
toString() — Method in class flash.events.Event
 | Returns a string containing all the properties of the Event object.
toString() — Method in class flash.events.FocusEvent
 | Returns a string that contains all the properties of the FocusEvent object.
toString() — Method in class flash.events.HTTPStatusEvent
 | Returns a string that contains all the properties of the HTTPStatusEvent object.
toString() — Method in class flash.events.IMEEvent
 | Returns a string that contains all the properties of the IMEEvent object.
toString() — Method in class flash.events.IOErrorEvent
 | Returns a string that contains all the properties of the IOErrorEvent object.
toString() — Method in class flash.events.KeyboardEvent
 | Returns a string that contains all the properties of the KeyboardEvent object.
toString() — Method in class flash.events.MouseEvent
 | Returns a string that contains all the properties of the MouseEvent object.
toString() — Method in class flash.events.NetStatusEvent
 | Returns a string that contains all the properties of the NetStatusEvent object.
toString() — Method in class flash.events.ProgressEvent
 | Returns a string that contains all the properties of the ProgressEvent object.
toString() — Method in class flash.events.SecurityErrorEvent
 | Returns a string that contains all the properties of the SecurityErrorEvent object.
toString() — Method in class flash.events.StatusEvent
 | Returns a string that contains all the properties of the StatusEvent object.
toString() — Method in class flash.events.SyncEvent
 | Returns a string that contains all the properties of the SyncEvent object.
toString() — Method in class flash.events.TextEvent
 | Returns a string that contains all the properties of the TextEvent object.
toString() — Method in class flash.events.TimerEvent
 | Returns a string that contains all the properties of the TimerEvent object.
toString() — Method in class flash.geom.ColorTransform
 | Formats and returns a string that describes all of the properties of the ColorTransform object.
toString() — Method in class flash.geom.Matrix
 | Returns a text value listing the properties of the Matrix object.
toString() — Method in class flash.geom.Point
 | Returns a string that contains the values of the x and y coordinates.
toString() — Method in class flash.geom.Rectangle
 | Builds and returns a string that lists the horizontal and vertical positions and the width and height of the Rectangle object.
toString() — Method in class flash.net.URLVariables
 | Returns a string containing all enumerable variables, in the MIME content encoding application/x-www-form-urlencoded.
toString() — Method in class flash.utils.ByteArray
 | Converts the byte array to a string.
toString() — Method in class flash.xml.XMLDocument
 | Returns a string representation of the XML object.
toString() — Method in class flash.xml.XMLNode
 | Evaluates the specified XMLNode object, constructs a textual representation of the XML structure, including the node, children, and attributes, and returns the result as a string.
toString() — Method in class mx.collections.ListCollectionView
 | Pretty prints the contents of this view to a string and returns it.
toString() — Method in class mx.collections.XMLListCollection
 | Returns a string representation of the XMLList by calling the toString() method for each XML object in the XMLList.
toString() — Method in class mx.core.ComponentDescriptor
 | Returns the string "ComponentDescriptor_" plus the value of the id property.
toString() — Method in class mx.core.FlexBitmap
 | Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
toString() — Method in class mx.core.FlexMovieClip
 | Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
toString() — Method in class mx.core.FlexShape
 | Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
toString() — Method in class mx.core.FlexSimpleButton
 | Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
toString() — Method in class mx.core.FlexSprite
 | Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
toString() — Method in class mx.core.FlexTextField
 | Returns a string indicating the location of this object within the hierarchy of DisplayObjects in the Application.
toString() — Method in class mx.data.Conflict
toString() — Method in class mx.logging.errors.InvalidCategoryError
 | Returns the messge as a String.
toString() — Method in class mx.logging.errors.InvalidFilterError
 | Returns the messge as a String.
toString() — Method in class mx.managers.FocusManager
 | Returns a String representation of the component hosting the FocusManager object, with the String ".focusManager" appended to the end of the String.
toString() — Method in interface mx.managers.IHistoryManagerClient
 | Converts this object to a unique string.
toString() — Method in class mx.messaging.ChannelSet
 | Returns the ids of the Channels in the ChannelSet.
toString() — Method in class mx.messaging.errors.MessagingError
 | Returns the string "[MessagingError]" by default, and includes the message property if defined.
toString() — Method in class mx.messaging.events.ChannelEvent
 | Returns a string representation of the ChannelEvent.
toString() — Method in class mx.messaging.events.ChannelFaultEvent
 | Returns a string representation of the ChannelFaultEvent.
toString() — Method in class mx.messaging.events.MessageAckEvent
 | Returns a string representation of the MessageAckEvent.
toString() — Method in class mx.messaging.events.MessageEvent
 | Returns a string representation of the MessageEvent.
toString() — Method in class mx.messaging.events.MessageFaultEvent
 | Returns a string representation of the MessageFaultEvent.
toString() — Method in class mx.messaging.management.MBeanFeatureInfo
 | Returns a string representation of the feature info.
toString() — Method in class mx.messaging.management.MBeanInfo
 | Returns a string representation of the MBean info.
toString() — Method in class mx.messaging.management.ObjectInstance
 | Returns a string representation of the object name instance.
toString() — Method in class mx.messaging.management.ObjectName
 | This method will return a string representation of the object name.
toString() — Method in class mx.messaging.messages.AbstractMessage
 | Returns a string representation of the message.
toString() — Method in class mx.messaging.messages.CommandMessage
 | Returns a string representation of the message.
toString() — Method in interface mx.messaging.messages.IMessage
 | This method will return a string representation of the message.
toString() — Method in class mx.resources.Locale
 | Returns locale in the form language_country_variant if variant is present else language_country
toString() — Method in class mx.rpc.Fault
toString() — Method in class mx.rpc.events.FaultEvent
 | Returns a string representation of the FaultEvent.
toString() — Method in class mx.rpc.events.HeaderEvent
 | Returns a string representation of the HeaderEvent.
toString() — Method in class mx.rpc.events.InvokeEvent
 | Returns a string representation of the InvokeEvent.
toString() — Method in class mx.rpc.events.ResultEvent
 | Returns a string representation of the ResultEvent.
toString() — Method in class mx.rpc.remoting.RemoteObject
 | Represents an instance of RemoteObject as a String, describing important properties such as the destination id and the set of channels assigned.
toString() — Method in class mx.rpc.soap.LoadEvent
toString() — Method in class mx.rpc.soap.WebService
 | Represents an instance of WebService as a String, describing important properties such as the destination id and the set of channels assigned.
toString(value:Object, namespaceURIs:Array, exclude:Array) — Static method in class mx.utils.ObjectUtil
 | Pretty-prints the specified Object into a String.
totalFrames — Property in class flash.display.MovieClip
 | The total number of frames in the MovieClip instance.
totalMemory — Static property in class flash.system.System
 | The amount of memory (in bytes) currently in use by Adobe® Flash® Player.
totalsByPrimaryAxis — Property in class mx.charts.chartClasses.StackedSeries
 | The summed totals of the stacked values.
totalTime — Property in class mx.controls.VideoDisplay
 | Total length of the media, in seconds.
toTimeString() — Method in class Date
 | Returns a String representation of the time and timezone only, and does not include the day and date.
toUpperCase() — Method in class String
 | Returns a copy of this string, with all lowercase characters converted to uppercase.
toUTCString() — Method in class Date
 | Returns a String representation of the day, date, and time in universal time (UTC).
toValue — Property in class mx.effects.AnimateProperty
 | The ending value for the effect.
toValue — Property in class mx.effects.effectClasses.AnimatePropertyInstance
 | The ending value for the effect.
toXMLString() — Method in class XML
 | Returns a string representation of the XML object.
toXMLString() — Method in class XMLList
 | Returns a string representation of all the XML objects in an XMLList object.
toXMLString() — Method in class mx.collections.XMLListCollection
 | Returns a string representation of the XMLList by calling the toXMLString() method for each XML object in the XMLList.
trace(... rest) — Package function in Top Level
 | Displays expressions, or writes to log files, while debugging.
TRACE_METHOD — Constant static property in class mx.messaging.messages.HTTPRequestMessage
 | Indicates that the method used for this request should be "trace".
TraceTarget — Class in package mx.logging.targets
 | Provides a logger target that uses the global trace() method to output log messages.
TraceTarget() — Constructor in class mx.logging.targets.TraceTarget
 | Constructor.
track — Property in class flash.media.ID3Info
 | The track number; corresponds to the ID3 2.0 tag TRCK.
TRACK — Constant static property in class mx.events.SliderEventClickTarget
 | Specifies that the Slider's track was clicked.
trackAsMenu — Property in class flash.display.MovieClip
 | Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events.
trackAsMenu — Property in class flash.display.SimpleButton
 | Indicates whether other display objects that are SimpleButton or MovieClip objects can receive mouse release events.
trackColors — Style in class mx.controls.ProgressBar
 | The colors of the track, as an array of two colors.
trackColors — Style in class mx.controls.scrollClasses.ScrollBar
 | The colors of the track, as an array of two colors.
trackColors — Style in class mx.controls.sliderClasses.Slider
 | The colors of the track, as an array of two colors.
trackHeight — Style in class mx.controls.ProgressBar
 | The height of the track in pixels.
trackHighlightSkin — Style in class mx.controls.sliderClasses.Slider
 | The skin for the slider track when it is selected.
trackMargin — Style in class mx.controls.sliderClasses.Slider
 | The size of the track margins, in pixels.
trackSkin — Style in class mx.controls.ProgressBar
 | Skin style for the progress indicator track.
trackSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the track of the scroll bar.
trackSkin — Style in class mx.controls.sliderClasses.Slider
 | The skin for the slider track.
TRANSACTED_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation is similar to the MULTI_BATCH_OPERATION with the addition that the server should encapsulate the multiple batches of messages within a transacation.
transform — Property in class flash.display.DisplayObject
 | An object with properties pertaining to a display object's matrix, color transform, and pixel bounds.
transform(formatObject:Object) — Method in class flash.text.StyleSheet
 | Extends the CSS parsing capability.
Transform — Class in package flash.geom
 | The Transform class collects data about color transformations and coordinate transformations that are applied to a display object.
transformCache(cache:Array, field:String, convertedField:String) — Method in class mx.charts.CategoryAxis
 | Maps a set of values from data space to screen space.
transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String) — Method in class mx.charts.chartClasses.CartesianTransform
 | Maps a set of numeric values representing data to screen coordinates.
transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String) — Method in class mx.charts.chartClasses.DataTransform
 | Maps a set of numeric values representing data to screen coordinates.
transformCache(cache:Array, field:String, convertedField:String) — Method in interface mx.charts.chartClasses.IAxis
 | Maps a set of values from data space to screen space.
transformCache(cache:Array, field:String, convertedField:String) — Method in class mx.charts.chartClasses.NumericAxis
 | Maps a set of values from data space to screen space.
transformCache(cache:Array, xField:String, xConvertedField:String, yField:String, yConvertedField:String) — Method in class mx.charts.chartClasses.PolarTransform
 | Maps a set of numeric values representing data to screen coordinates.
transformChange — Event in class mx.charts.chartClasses.DataTransform
 | Dispatched when the transformation from data space to screen space has changed, typically either because the axes that make up the transformation have changed in some way, or the data transform itself has size.
TRANSFORM_CHANGE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.TRANSFORM_CHANGE constant defines the value of the type property of the event object for a transformChange event.
transformPoint(point:flash.geom:Point) — Method in class flash.geom.Matrix
 | Returns the result of applying the geometric transformation represented by the Matrix object to the specified point.
transforms — Property in class mx.charts.chartClasses.ChartBase
 | The DataTransforms managed by this chart.
Transition — Class in package mx.states
 | The Transition class defines a set of effects that play in response to a change of view state.
Transition() — Constructor in class mx.states.Transition
 | Constructor.
transitionRenderData — Property in class mx.charts.chartClasses.Series
 | A render data structure passed in by a running transtion.
transitions — Property in class mx.core.UIComponent
 | An Array of Transition objects, where each Transition object defines a set of effects to play when a view state change occurs.
translate(dx:Number, dy:Number) — Method in class flash.geom.Matrix
 | Translates the matrix along the x and y axes, as specified by the dx and dy parameters.
transparent — Property in class flash.display.BitmapData
 | Defines whether the bitmap image supports per-pixel transparency.
Tree — Class in package mx.controls
 | The Tree control lets a user view hierarchical data arranged as an expandable tree.
Tree() — Constructor in class mx.controls.Tree
 | Constructor.
TreeEvent — Class in package mx.events
 | The TreeEvent class represents the event object passed to the event listener for events that are associated with activities in tree, such as when a tree branch opens or closes.
TreeEvent(type:String, bubbles:Boolean, cancelable:Boolean, item:Object, itemRenderer:mx.controls.listClasses:IListItemRenderer, triggerEvent:flash.events:Event) — Constructor in class mx.events.TreeEvent
 | Constructor.
TreeItemRenderer — Class in package mx.controls.treeClasses
 | The TreeItemRenderer class defines the default item renderer for a Tree control.
TreeItemRenderer() — Constructor in class mx.controls.treeClasses.TreeItemRenderer
 | Constructor.
TreeListData — Class in package mx.controls.treeClasses
 | The TreeListData class defines the data type of the listData property implemented by drop-in item renderers or drop-in item editors for the Tree control.
TreeListData(text:String, uid:String, owner:mx.controls.listClasses:ListBase, rowIndex:int) — Constructor in class mx.controls.treeClasses.TreeListData
 | Constructor.
TriangleItemRenderer — Class in package mx.charts.renderers
 | A simple chart itemRenderer implementation that fills an upright triangle in its assigned area.
TriangleItemRenderer() — Constructor in class mx.charts.renderers.TriangleItemRenderer
 | Constructor.
trigger — Property in class mx.validators.Validator
 | Specifies the component generating the event that triggers the validator.
triggerEvent — Property in class mx.effects.EffectInstance
 | The event, if any, which triggered the playing of the effect.
triggerEvent — Property in class mx.events.CalendarLayoutChangeEvent
 | The event that triggered the change of the date; usually a change event.
triggerEvent — Property in class mx.events.DateChooserEvent
 | The event that triggered this change; usually a scroll.
triggerEvent — Property in class mx.events.DropdownEvent
 | If the control is opened or closed in response to a user action, this property contains a value indicating the type of input action.
triggerEvent — Property in class mx.events.IndexChangedEvent
 | The event that triggered this event.
triggerEvent — Property in class mx.events.SliderEvent
 | Indicates the type of input action.
triggerEvent — Property in class mx.events.TreeEvent
 | The low level MouseEvent or KeyboardEvent that triggered this event or null if this event was triggered programatically.
triggerEvent — Property in class mx.validators.Validator
 | Specifies the event that triggers the validation.
trim(str:String) — Static method in class mx.utils.StringUtil
 | Removes all whitespace characters from the beginning and end of the specified string.
trRadius — Property in class mx.graphics.RectangularDropShadow
 | The corner radius of the top right corner of the rounded rectangle that is casting the shadow.
true — Statement
 | A Boolean value representing true.
truncateToFit — Property in class mx.controls.Label
 | If this propery is true, and the Label control size is smaller than its text, the text of the Label control is truncated using a localizable string, such as "...".
truncateToFit(truncationIndicator:String) — Method in class mx.core.UITextField
 | Truncate text to make it fit horizontally in the area defined for the control, and append an ellipsis, three periods (...), to the text.
trustContent — Property in class mx.controls.SWFLoader
 | If true, the content is loaded into your security domain.
try..catch..finally — Statement
 | Encloses a block of code in which an error can occur, and then responds to the error.
tween — Property in class mx.effects.effectClasses.TweenEffectInstance
 | The Tween object, which determines the animation.
Tween — Class in package mx.effects
 | The Tween class defines a tween, a property animation performed on a target object over a period of time.
Tween(listener:Object, startValue:Object, endValue:Object, duration:Number, minFps:Number) — Constructor in class mx.effects.Tween
 | Constructor.
TweenEffect — Class in package mx.effects
 | The TweenEffect class is the superclass for all effects that are based on the Tween object.
TweenEffect(target:Object) — Constructor in class mx.effects.TweenEffect
 | Constructor.
TweenEffectInstance — Class in package mx.effects.effectClasses
 | The TweenEffectInstance class implements the instance class for the TweenEffect.
TweenEffectInstance(target:Object) — Constructor in class mx.effects.effectClasses.TweenEffectInstance
 | Constructor.
tweenEnd — Event in class mx.effects.MaskEffect
 | Dispatched when the effect ends.
tweenEnd — Event in class mx.effects.TweenEffect
 | Dispatched when the tween effect ends.
TWEEN_END — Constant static property in class mx.events.TweenEvent
 | The TweenEvent.TWEEN_END constant defines the value of the event object's type property for a tweenEnd event.
TweenEvent — Class in package mx.events
 | Represents event objects that are specific to Flex tween effects.
TweenEvent(type:String, bubbles:Boolean, cancelable:Boolean, value:Object) — Constructor in class mx.events.TweenEvent
 | Constructor.
tweenEventHandler(event:mx.events:TweenEvent) — Method in class mx.effects.MaskEffect
 | Called when the TweenEffect dispatches a TweenEvent.
tweenEventHandler(event:mx.events:TweenEvent) — Method in class mx.effects.TweenEffect
 | Called when the TweenEffect dispatches a TweenEvent.
tweeningProperties — Property in interface mx.core.IUIComponent
 | Used by EffectManager.
tweeningProperties — Property in class mx.core.UIComponent
 | Array of properties that are currently being tweened on this object.
tweeningProperties — Property in class mx.core.UITextField
 | Array of properties that are currently being tweened on this object.
tweenStart — Event in class mx.effects.MaskEffect
 | Dispatched when the effect starts, which corresponds to the first call to the onMoveTweenUpdate() and onScaleTweenUpdate() methods.
tweenStart — Event in class mx.effects.TweenEffect
 | Dispatched when the tween effect starts, which corresponds to the first call to the onTweenUpdate() method.
TWEEN_START — Constant static property in class mx.events.TweenEvent
 | The TweenEvent.TWEEN_START constant defines the value of the event object's type property for a tweenStart event.
tweenUpdate — Event in class mx.effects.MaskEffect
 | Dispatched every time the effect updates the target.
tweenUpdate — Event in class mx.effects.TweenEffect
 | Dispatched every time the tween effect updates the target.
TWEEN_UPDATE — Constant static property in class mx.events.TweenEvent
 | The TweenEvent.TWEEN_UPDATE constant defines the value of the event object's type property for a tweenUpdate event.
tx — Property in class flash.geom.Matrix
 | The distance by which to translate each point along the x axis.
ty — Property in class flash.geom.Matrix
 | The distance by which to translate each point along the y axis.
type — Property in class flash.events.Event
 | The type of event.
type — Property in class flash.filters.BevelFilter
 | The placement of the bevel on the object.
type — Property in class flash.filters.GradientBevelFilter
 | The placement of the bevel effect.
type — Property in class flash.filters.GradientGlowFilter
 | The placement of the filter effect.
type — Property in class flash.net.FileReference
 | The file type.
type — Property in class flash.text.TextField
 | The type of the text field.
type — Property in class mx.charts.AreaChart
 | Type of area chart to render.
type — Property in class mx.charts.BarChart
 | The type of bar chart to render.
type — Property in class mx.charts.ColumnChart
 | The type of the column chart.
type — Property in class mx.charts.chartClasses.StackedSeries
 | The grouping behavior of this series.
type — Property in class mx.charts.effects.SeriesEffect
 | The type of transition this effect is being used for.
type — Property in class mx.charts.effects.effectClasses.SeriesEffectInstance
 | The type of transition this effect is being used for.
type — Property in class mx.core.ComponentDescriptor
 | The Class of the component, as specified in MXML.
type — Property in class mx.messaging.management.MBeanAttributeInfo
 | The data type of the attribute.
type — Property in class mx.messaging.management.MBeanParameterInfo
 | The data type of the operation parameter.
TypeError — Dynamic class in Top Level
 | A TypeError exception is thrown when the actual type of an operand is different from the expected type.
TypeError(message:String) — Constructor in class TypeError
 | Creates a new TypeError object.
typeof — Operator
 | Evaluates expression and returns a string specifying the expression's data type.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


U Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
U Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
UIComponent — Class in package mx.core
 | The UIComponent class is the base class for all visual components, both interactive and noninteractive.
UIComponent() — Constructor in class mx.core.UIComponent
 | Constructor.
UIComponentCachePolicy — Final class in package mx.core
 | The ContainerCreationPolicy class defines the constant values for the cachePolicy property of the UIComponent class.
UIComponentDescriptor — Class in package mx.core
 | A UIComponentDescriptor instance encapsulates the information that you specified in an MXML tag for an instance of a visual component.
UIComponentDescriptor(descriptorProperties:Object) — Constructor in class mx.core.UIComponentDescriptor
 | Constructor.
uid — Property in class mx.controls.listClasses.BaseListData
 | The unique identifier for this item.
uid — Property in class mx.controls.listClasses.ListRowInfo
 | The unique identifier of the item in the dataProvider
uid — Property in interface mx.core.IUID
 | The unique identifier for this object.
uid — Property in class mx.core.UIComponent
 | A unique identifier for the object.
uid — Property in class mx.utils.ObjectProxy
 | The unique identifier for this object.
UIDUtil — Class in package mx.utils
 | The UIDUtil class is an all-static class with methods for working with UIDs (unique identifiers) within Flex.
uint — Final class in Top Level
 | The uint class provides methods for working with a data type representing a 32-bit unsigned integer.
uint(value) — Package function in Top Level
 | Converts a given numeric value to an unsigned integer value.
uint(num:Object) — Constructor in class uint
 | Creates a new uint object.
UITextField — Class in package mx.core
 | The UITextField class defines the component used by many Flex components to display text.
UITextField() — Constructor in class mx.core.UITextField
 | Constructor.
UITextFormat — Class in package mx.core
 | The UITextFormat class represents character formatting information for the UITextField class.
UITextFormat(systemManager:mx.managers:ISystemManager, font:String, size:Object, color:Object, bold:Object, italic:Object, underline:Object, url:String, target:String, align:String, leftMargin:Object, rightMargin:Object, indent:Object, leading:Object) — Constructor in class mx.core.UITextFormat
 | Constructor.
uncompress() — Method in class flash.utils.ByteArray
 | Decompresses the byte array.
undefined — Package constant property in Top Level
 | A special value that applies to untyped variables that have not been initialized or dynamic object properties that are not initialized.
underline — Property in class flash.text.TextFormat
 | Indicates whether the text that uses this text format is underlined (true) or not (false).
unescape(str) — Package function in Top Level
 | Evaluates the parameter str as a string, decodes the string from URL-encoded format (converting all hexadecimal sequences to ASCII characters), and returns the string.
unescapeMultiByte(value) — Package function in flash.utils
 | Returns an unescaped copy of the input string, which is decoded from either system code page page or UTF-8 depending on the value of System.useCodePage.
union(toUnion:flash.geom:Rectangle) — Method in class flash.geom.Rectangle
 | Adds two rectangles together to create a new Rectangle object, by filling in the horizontal and vertical space between the two rectangles.
unique — Property in class mx.collections.Sort
 | Indicates if the sort should be unique.
UNIQUESORT — Constant static property in class Array
 | Specifies the unique sorting requirement for the Array class sorting methods.
unitSize — Property in class mx.charts.DateTimeAxis
 | The width, in pixels, of a single data unit.
unitSize — Property in class mx.charts.chartClasses.AxisBase
 | The size of one unit of data as represented by this axis.
unitSize — Property in interface mx.charts.chartClasses.IAxis
 | The size of one unit of data as represented by this axis.
UNKNOWN — Constant static property in class flash.system.IMEConversionMode
 | The string "UNKNOWN", which can be returned by a call to the IME.conversionMode property.
UNKNOWN — Constant property in class mx.messaging.management.MBeanOperationInfo
 | The side-effects for the operation are unknown.
UNKNOWN_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | Code for an unknown operation type.
UNKNOWN_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
 | This is the default operation for new CommandMessage instances.
unload() — Method in class flash.display.Loader
 | Removes a child of this Loader object that was loaded by using the load() method.
unload — Event in class flash.display.LoaderInfo
 | Dispatched by a LoaderInfo object whenever a loaded object is removed by using the unload() method of the Loader object, or when a second load is performed by the same Loader object and the original content is removed prior to the load beginning.
unload — Event in class mx.controls.SWFLoader
 | Dispatched when a loaded object is removed, or when a second load is performed by the same SWFLoader control and the original content is removed prior to the new load beginning.
UNLOAD — Constant static property in class flash.events.Event
 | Defines the value of the type property of an unload event object.
unlock(changeRect:flash.geom:Rectangle) — Method in class flash.display.BitmapData
 | Unlocks an image so that any objects that reference the BitmapData object, such as Bitmap objects, are updated when this BitmapData object changes.
unregister(obj:mx.managers:IHistoryManagerClient) — Static method in class mx.managers.HistoryManager
 | Unregisters an object with the HistoryManager.
unregisterDataTransform(transform:mx.charts.chartClasses:DataTransform) — Method in class mx.charts.chartClasses.AxisBase
 | Each DataTransform that makes use of an axis registers itself with that axis.
unregisterDataTransform(transform:mx.charts.chartClasses:DataTransform) — Method in interface mx.charts.chartClasses.IAxis
 | Each DataTransform that makes use of an axis registers itself with that axis.
UnresolvedConflictsError — Class in package mx.data.errors
 | This error is thrown when a commit request is made while there are still unresolved conflicts and no listener has been registered for UnresolvedConflictsEvent.FAULT.
UnresolvedConflictsError(msg:String) — Constructor in class mx.data.errors.UnresolvedConflictsError
 | Constructs a new instance of the error with the specified message.
UnresolvedConflictsEvent — Class in package mx.data.events
 | A DataList throws this event when the commit() method is called while conflicts remain unresolved.
UnresolvedConflictsEvent(type:String, bubbles:Boolean, cancelable:Boolean) — Constructor in class mx.data.events.UnresolvedConflictsEvent
unscaledHeight — Property in class mx.core.UIComponent
 | A convenience method for determining the unscaled height of the component All of a component's drawing and child layout should be done within a bounding rectangle of this height, which is also passed as an argument to updateDisplayList().
unscaledWidth — Property in class mx.core.UIComponent
 | A convenience method for determining the unscaled width of the component All of a component's drawing and child layout should be done within a bounding rectangle of this width, which is also passed as an argument to updateDisplayList().
unshift(... rest) — Method in class Array
 | Adds one or more elements to the beginning of an array and returns the new length of the array.
unsubscribe() — Method in class mx.messaging.Consumer
 | Unsubscribes from the remote destination.
UNSUBSCRIBE_OPERATION — Constant static property in class mx.messaging.messages.CommandMessage
 | This operation is used to unsubscribe from a remote destination.
unwatch() — Method in class mx.binding.utils.ChangeWatcher
 | Detaches this ChangeWatcher instance, and its handler function, from the current host.
UP — Constant static property in class flash.ui.Keyboard
 | Constant associated with the key code value for the Up Arrow key (38).
UP — Constant static property in class mx.formatters.NumberBaseRoundType
 | Rounds a number up to an integer value that is both closest to, and greater than or equal to, the input number.
upArrowDisabledSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the Up arrow when the arrow is disabled.
upArrowDisabledSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the up arrow button of the scroll bar when it is disabled.
upArrowDownSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the Up arrow when the arrow is enabled and a user presses the mouse button over the arrow.
upArrowDownSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the up arrow button of the scroll bar when you click the arrow button.
upArrowOverSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is over the arrow.
upArrowOverSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the up arrow button of the scroll bar when the mouse pointer is over the arrow button.
upArrowUpSkin — Style in class mx.controls.NumericStepper
 | Name of the class to use as the skin for the Up arrow when the arrow is enabled and the mouse pointer is not on the arrow.
upArrowUpSkin — Style in class mx.controls.scrollClasses.ScrollBar
 | Name of the class to use as the skin for the up arrow button of the scroll bar.
update() — Method in class mx.charts.CategoryAxis
 | Updates the chart.
update() — Method in interface mx.charts.chartClasses.IAxis
 | Updates the chart.
update() — Method in class mx.charts.chartClasses.NumericAxis
 | Updates the chart.
UPDATE — Constant static property in class mx.events.CollectionEventKind
 | Indicates that one or more items were updated within the collection.
UPDATE — Constant static property in class mx.events.PropertyChangeEventKind
 | Indicates that the value of the property changed.
updateAfterEvent() — Method in class flash.events.KeyboardEvent
 | Instructs Flash Player to render after processing of this event completes, if the display list has been modified
updateAfterEvent() — Method in class flash.events.MouseEvent
 | Instructs Flash Player to render after processing of this event completes, if the display list has been modified.
updateAfterEvent() — Method in class flash.events.TimerEvent
 | Instructs Flash Player to render after processing of this event completes, if the display list has been modified
updateBackground() — Method in class mx.controls.MenuBar
 | Updates the MenuBar background skin.
UPDATE_BODY_CHANGES — Constant static property in class mx.data.messages.DataMessage
 | This constant is used to access the list of changed property names.
UPDATE_BODY_NEW — Constant static property in class mx.data.messages.DataMessage
 | This constant is used to access the new value of a changed item.
UPDATE_BODY_PREV — Constant static property in class mx.data.messages.DataMessage
 | This constant is used to access the previous value of the changed item.
UpdateCollectionMessage — Class in package mx.data.messages
 | This message is used to establish consistency between the remote sequence and the corresponding local collection.
UpdateCollectionMessage() — Constructor in class mx.data.messages.UpdateCollectionMessage
 | Creates a new instance of an empty UpdateCollectionMessage.
UPDATE_COLLECTION_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation is sent when a local or remote sequence has been modified by insert(s) or delete(s).
UpdateCollectionRange — Class in package mx.data
 | The UpdateCollectionRange class provides specific information about a range of add and remove operations made to a collection.
UpdateCollectionRange() — Constructor in class mx.data.UpdateCollectionRange
 | Constructs an empty UpdateCollectionRange.
updateComplete — Event in class mx.core.UIComponent
 | Dispatched when an object has had its commitProperties(), measure(), and updateDisplayList() methods called (if needed).
UPDATE_COMPLETE — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.UPDATE_COMPLETE constant defines the value of the type property of the event object for a updateComplete event.
updateCompletePendingFlag — Property in class mx.core.UIComponent
 | A flag that determines if an object has been through all three phases of layout validation (provided that any were required).
updateCompletePendingFlag — Property in class mx.core.UITextField
 | A flag that determines if an object has been through all three phases of layout validation (provided that any were required)
updateCompletePendingFlag — Property in interface mx.managers.ILayoutManagerClient
 | A flag that determines if an object is waiting to have its updateComplete event dispatched.
updateCompletePendingFlag — Property in class mx.skins.ProgrammaticSkin
 | A flag that determines if an object has been through all three phases of layout validation (provided that any were required).
updateData() — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
updateData() — Method in class mx.charts.chartClasses.Series
 | This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
updateData() — Method in class mx.charts.series.BubbleSeries
 | This method is called when the underlying data that the series represents has changed and needs to be reloaded out of the data provider.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.AxisRenderer
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.Legend
 | Sets the size and position of each child of the Legend.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.chartClasses.CartesianChart
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.chartClasses.ChartLabel
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.chartClasses.DataTip
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.chartClasses.PolarChart
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.chartClasses.Series
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.series.BubbleSeries
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.charts.series.PieSeries
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.Box
 | Sets the size and position of each child of the Box container.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.Canvas
 | Sets the size of each child of the container.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.Form
 | Responds to size changes by setting the positions and sizes of this container's children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.FormItem
 | Responds to size changes by setting the positions and sizes of this container's children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.Grid
 | Sets the size and position of each child of the Grid.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.GridRow
 | Sets the size and position of each child of the GridRow container.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.TabNavigator
 | Responds to size changes by setting the positions and sizes of this container's tabs and children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.Tile
 | Sets the positions and sizes of this container's children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.containers.ViewStack
 | Responds to size changes by setting the positions and sizes of this container's children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.controls.ComboBase
 | Sizes and positions the internal components in the given width and height.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.controls.LinkBar
 | Responds to size changes by setting the positions and sizes of this LinkBar control's children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.controls.listClasses.ListBase
 | Adds or removes item renderers if the number of displayable items changed.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.controls.sliderClasses.Slider
 | Positions the elements of the control.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.core.Container
 | Respond to size changes by setting the positions and sizes of this container's children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.core.UIComponent
 | Draws the object and/or sizes and positions its children.
updateDisplayList(unscaledWidth:Number, unscaledHeight:Number) — Method in class mx.skins.ProgrammaticSkin
 | Programmatically draws the graphics for this skin.
updateFilter() — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
updateFilter() — Method in class mx.charts.chartClasses.Series
 | This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
updateFilter() — Method in class mx.charts.series.BubbleSeries
 | This method is called when the underlying data the series represents needs to be filtered against the ranges represented by the axes of the associated DataTransform.
updateList() — Method in class mx.controls.listClasses.ListBase
 | Refreshes all rows now.
updateMapping() — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | This method is called when the underlying data the series represents needs to be mapped to numeric representations.
updateMapping() — Method in class mx.charts.chartClasses.Series
 | This method is called when the underlying data the series represents needs to be mapped to numeric representations.
updateMapping() — Method in class mx.charts.series.BubbleSeries
 | This method is called when the underlying data the series represents needs to be mapped to numeric representations.
updateMode — Property in class mx.data.messages.UpdateCollectionMessage
 | Indicates the state of this update.
updateNavItemIcon(index:int, icon:Class) — Method in class mx.controls.NavBar
 | Resets the icon of a navigator item in the NavBar control.
updateNavItemLabel(index:int, label:String) — Method in class mx.controls.NavBar
 | Sets the label property of a navigator item in the NavBar control.
UPDATE_OPERATION — Constant static property in class mx.data.messages.DataMessage
 | This operation indicates an update to data object has been performed.
updateProperties() — Static method in class flash.accessibility.Accessibility
 | Tells Flash Player to apply any accessibility changes made by using the DisplayObject.accessibilityProperties property.
updateStacking() — Method in class mx.charts.chartClasses.StackedSeries
 | Iterates over the individual sub-series to build the stacked values.
updateTransform() — Method in class mx.charts.chartClasses.HLOCSeriesBase
 | This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
updateTransform() — Method in class mx.charts.chartClasses.Series
 | This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
updateTransform() — Method in class mx.charts.series.BubbleSeries
 | This method is called when the underlying data the series represents needs to be transformed from data to screen values by the axes of the associated DataTransform.
updateType — Property in class mx.data.UpdateCollectionRange
 | Indicates what operation this range represents.
upIcon — Style in class mx.controls.Button
 | Name of the class to use as the icon when a toggle button is not selected and the mouse is not over the button.
upload(request:flash.net:URLRequest, uploadDataFieldName:String, testUpload:Boolean) — Method in class flash.net.FileReference
 | Starts the upload of a file selected by a user to a remote server.
upperMargin — Property in class mx.charts.chartClasses.BoundedValue
 | The margin, in pixels, required above the value in order to render properly.
upSkin — Style in class mx.controls.Button
 | Name of the class to use as the skin for the background and border when the button is not selected and the mouse is not over the control.
upSkin — Style in class mx.controls.ComboBase
 | Name of the class to use as the skin for the background and border when the mouse is not over the control.
upState — Property in class flash.display.SimpleButton
 | Specifies a display object that is used as the visual object for the button up state — the state that the button is in when the mouse is not positioned over the button.
uri — Property in class Namespace
 | The Uniform Resource Identifier (URI) of the namespace.
uri — Property in class QName
 | The Uniform Resource Identifier (URI) of the QName object.
uri — Property in class flash.net.NetConnection
 | The URI of the application server that was passed to NetConnection.connect(), if connect was used to connect to a server.
uri — Property in class mx.messaging.Channel
 | Provides access to the URI used to create the whole endpoint URI for this channel.
URIError — Dynamic class in Top Level
 | A URIError exception is thrown when one of the global URI handling functions is used in a way that is incompatible with its definition.
URIError(message:String) — Constructor in class URIError
 | Creates a new URIError object.
url — Property in class flash.display.LoaderInfo
 | The URL of the media being loaded.
url — Property in class flash.media.Sound
 | The URL from which this sound was loaded.
url — Property in class flash.net.URLRequest
 | The URL to be requested.
url — Property in class flash.text.TextFormat
 | Indicates the target URL for the text in this text format.
url — Property in class mx.controls.textClasses.TextRange
 | URL for a hypertext link in the range.
url — Property in class mx.core.Application
 | The URL from which this Application's SWF file was loaded.
url — Property in class mx.events.RSLEvent
 | The URLRequest object that represents the location of the RSL being downloaded.
url — Static property in class mx.messaging.config.LoaderConfig
 | If the LoaderConfig has been initialized, this should represent the top-level MovieClip's URL.
url — Property in class mx.messaging.messages.HTTPRequestMessage
 | Contains the final destination for this request.
url — Property in class mx.rpc.http.HTTPService
 | Location of the service.
URLLoader — Class in package flash.net
 | The URLLoader class downloads data from a URL as text, binary data, or URL-encoded variables.
URLLoader(request:flash.net:URLRequest) — Constructor in class flash.net.URLLoader
 | Creates a URLLoader object.
URLLoaderDataFormat — Final class in package flash.net
 | The URLLoaderDataFormat class provides values that specify how downloaded data is received.
URLRequest — Final class in package flash.net
 | The URLRequest class captures all of the information in a single HTTP request.
URLRequest(url:String) — Constructor in class flash.net.URLRequest
 | Creates a URLRequest object.
URLRequestHeader — Final class in package flash.net
 | A URLRequestHeader object encapsulates a single HTTP request header and consists of a name/value pair.
URLRequestHeader(name:String, value:String) — Constructor in class flash.net.URLRequestHeader
 | Creates a new URLRequestHeader object that encapsulates a single HTTP request header.
URLRequestMethod — Final class in package flash.net
 | The URLRequestMethod class provides values that specify whether the URLRequest object should use the POST method or the GET method when sending data to a server.
URLStream — Class in package flash.net
 | The URLStream class provides low-level access to downloading URLs.
URLUtil — Class in package mx.utils
 | The URLUtil class is a static class with methods for working with full and relative URLs within Flex.
URLVariables — Dynamic class in package flash.net
 | The URLVariables class allows you to transfer variables between a Flash® application and a server.
URLVariables(source:String) — Constructor in class flash.net.URLVariables
 | Creates a new URLVariables object.
useCodePage — Static property in class flash.system.System
 | A Boolean value that tells Flash Player which code page to use to interpret external text files.
useDuration — Property in class mx.effects.SoundEffect
 | If true, stop the effect after the time specified by the duration property has elapsed.
useDuration — Property in class mx.effects.effectClasses.SoundEffectInstance
 | If true, stop the effect after the time specified by the duration property has elapsed.
useEchoSuppression — Property in class flash.media.Microphone
 | Returns true if echo suppression is enabled; false otherwise.
useHandCursor — Property in class flash.display.SimpleButton
 | A Boolean value that, when set to true, indicates whether Flash Player displays the hand cursor when the mouse rolls over a button.
useHandCursor — Property in class flash.display.Sprite
 | A Boolean value that indicates whether the pointing hand (hand cursor) appears when the mouse rolls over a sprite in which the buttonMode property is set to true.
use namespace — Statement
 | Causes the specified namespaces to be added to the set of open namespaces.
useNegativeSign — Property in class mx.formatters.CurrencyFormatter
 | If true, format a negative number by preceding it with a minus "-" sign.
useNegativeSign — Property in class mx.formatters.NumberFormatter
 | If true, format a negative number by preceding it with a minus "-" sign.
usePhasedInstantiation — Property in class mx.managers.LayoutManager
 | A flag that indicates whether the LayoutManager allows screen updates between phases.
usePreloader — Property in class mx.core.Application
 | If true, specifies to display the application preloader.
useProxy — Property in class mx.rpc.http.HTTPService
 | Specifies whether to use the Flex proxy service.
useProxy — Property in class mx.rpc.soap.WebService
 | Specifies whether to use the Flex proxy service.
useRichTextClipboard — Property in class flash.text.TextField
 | Specifies whether to copy and paste the text formatting along with the text.
useRollOver — Style in class mx.controls.listClasses.ListBase
 | A flag that controls whether items are highlighted as the mouse rolls over them.
useThousandsSeparator — Property in class mx.formatters.CurrencyFormatter
 | If true, split the number into thousands increments by using a separator character.
useThousandsSeparator — Property in class mx.formatters.NumberFormatter
 | If true, split the number into thousands increments by using a separator character.
usingTLS — Property in class flash.net.NetConnection
 | Indicates whether a secure connection was made using native Transport Layer Security (TLS) rather than HTTPS.
US_ONLY — Static property in class mx.validators.ZipCodeValidatorDomainType
 | Specifies to validate a United States ZIP code.
US_OR_CANADA — Static property in class mx.validators.ZipCodeValidatorDomainType
 | Specifies to validate a United States or Canadian ZIP code.
UTC(year:Number, month:Number, date:Number, hour:Number, minute:Number, second:Number, millisecond:Number) — Static method in class Date
 | Returns the number of milliseconds between midnight on January 1, 1970, universal time, and the time specified in the parameters.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


V Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
V Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
valid — Event in class mx.core.UIComponent
 | Dispatched when a component is monitored by a Validator and the validation succeeded.
valid — Property in class mx.data.ItemReference
 | Set to true if the ItemReference becomes invalid either because the server faulted when trying to retrieve the item or if the retrieved item was itself null.
valid — Property in class mx.data.ItemReference
valid — Event in class mx.validators.Validator
 | Dispatched when validation succeeds.
VALID — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.VALID constant defines the value of the type property of the event object for a valid event.
VALID — Constant static property in class mx.events.ValidationResultEvent
 | The ValidationResultEvent.VALID constant defines the value of the type property of the event object for a validevent.
validate(value:Object, suppressEvents:Boolean) — Method in class mx.validators.Validator
 | Performs validation and optionally notifies the listeners of the result.
validateAll(validators:Array) — Static method in class mx.validators.Validator
 | Invokes all the validators in the validators Array.
validateAsString — Property in class mx.validators.DateValidator
 | Determines how to validate the value.
validateClient(target:mx.managers:ILayoutManagerClient, skipDisplayList:Boolean) — Method in class mx.managers.LayoutManager
 | When properties are changed, components generally do not apply those changes immediately.
validateCreditCard(validator:mx.validators:CreditCardValidator, value:Object, baseField:String) — Static method in class mx.validators.CreditCardValidator
 | Convenience method for calling a validator.
validateCurrency(validator:mx.validators:CurrencyValidator, value:Object, baseField:String) — Static method in class mx.validators.CurrencyValidator
 | Convenience method for calling a validator.
validateData() — Method in class mx.charts.chartClasses.Series
 | Calls the series's updateData() and updateMapping() functions, if necessary.
validateDate(validator:mx.validators:DateValidator, value:Object, baseField:String) — Static method in class mx.validators.DateValidator
 | Convenience method for calling a validator from within a custom validation function.
validateDisplayList() — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | If Flex calls LayoutManager.invalidateDisplayList() method on this ILayoutManagerClient, then this function is called when it's time to update the display list.
validateDisplayList() — Method in class mx.core.UIComponent
 | Validates the position and size of children and draws other visuals.
validateDisplayList() — Method in interface mx.managers.ILayoutManagerClient
 | Validates the position and size of children and draws other visuals.
validateDisplayList() — Method in class mx.skins.ProgrammaticSkin
 | This function is called by the LayoutManager when it's time for this control to draw itself.
validateEmail(validator:mx.validators:EmailValidator, value:Object, baseField:String) — Static method in class mx.validators.EmailValidator
 | Convenience method for calling a validator from within a custom validation function.
validateNow() — Method in interface mx.core.IInvalidating
 | Validates and updates the properties and layout of this object by immediately calling validateProperties(), validateSize(), and validateDisplayList(), if necessary.
validateNow() — Method in class mx.core.UIComponent
 | Validate and update the properties and layout of this object and redraw it, if necessary.
validateNow() — Method in class mx.core.UITextField
 | Validate and update the properties and layout of this object and redraw it, if necessary.
validateNow() — Method in class mx.managers.LayoutManager
 | When properties are changed, components generally do not apply those changes immediately.
validateNow() — Method in class mx.skins.ProgrammaticSkin
 | Validate and update the properties and layout of this object and redraw it, if necessary.
validateNumber(validator:mx.validators:NumberValidator, value:Object, baseField:String) — Static method in class mx.validators.NumberValidator
 | Convenience method for calling a validator from within a custom validation function.
validatePhoneNumber(validator:mx.validators:PhoneNumberValidator, value:Object, baseField:String) — Static method in class mx.validators.PhoneNumberValidator
 | Convenience method for calling a validator from within a custom validation function.
validateProperties() — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | If Flex calls the LayoutManager.invalidateProperties() method on this ILayoutManagerClient, then this function is called when it's time to commit property values.
validateProperties() — Method in class mx.core.UIComponent
 | Used by layout logic to validate the properties of a component by calling the commitProperties() method.
validateProperties() — Method in interface mx.managers.ILayoutManagerClient
 | Validates the properties of a component.
validateProperties() — Method in class mx.skins.ProgrammaticSkin
 | This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
validateSize(recursive:Boolean) — Method in class mx.controls.dataGridClasses.DataGridItemRenderer
 | If Flex calls the LayoutManager.invalidateSize() method on this ILayoutManagerClient, then this function is called when it's time to do measurements.
validateSize(recursive:Boolean) — Method in class mx.core.UIComponent
 | Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
validateSize(recursive:Boolean) — Method in interface mx.managers.ILayoutManagerClient
 | Validates the measured size of the component If the LayoutManager.invalidateSize() method is called with this ILayoutManagerClient, then the validateSize() method is called when it's time to do measurements.
validateSize(recursive:Boolean) — Method in class mx.skins.ProgrammaticSkin
 | This function is an empty stub so that ProgrammaticSkin can implement the ILayoutManagerClient interface.
validateSocialSecurity(validator:mx.validators:SocialSecurityValidator, value:Object, baseField:String) — Static method in class mx.validators.SocialSecurityValidator
 | Convenience method for calling a validator.
validateString(validator:mx.validators:StringValidator, value:Object, baseField:String) — Static method in class mx.validators.StringValidator
 | Convenience method for calling a validator.
validateTransform() — Method in class mx.charts.chartClasses.Series
 | Calls the series's updateFilter() and updateTransform() functions, if necessary.
validateZipCode(validator:mx.validators:ZipCodeValidator, value:Object, baseField:String) — Static method in class mx.validators.ZipCodeValidator
 | Convenience method for calling a validator.
ValidationResult — Class in package mx.validators
 | The ValidationResult class contains the results of a validation.
ValidationResult(isError:Boolean, subField:String, errorCode:String, errorMessage:String) — Constructor in class mx.validators.ValidationResult
 | Constructor
ValidationResultEvent — Class in package mx.events
 | The ValidationResultEvent class represents the event object passed to the listener for the valid validator event or the invalid validator event.
ValidationResultEvent(type:String, bubbles:Boolean, cancelable:Boolean, field:String, results:Array) — Constructor in class mx.events.ValidationResultEvent
 | Constructor.
validationResultHandler(event:mx.events:ValidationResultEvent) — Method in class mx.core.UIComponent
 | Handles both the valid and invalid events from a validator assigned to this component.
validationResultHandler(event:mx.events:ValidationResultEvent) — Method in interface mx.validators.IValidatorListener
 | Handles both the valid and invalid events from a validator assigned to this component.
validationSubField — Property in class mx.core.UIComponent
 | Used by a validator to associate a subfield with this component.
validationSubField — Property in interface mx.validators.IValidatorListener
 | Used by a validator to assign a subfield.
Validator — Class in package mx.validators
 | The Validator class is the base class for all Flex validators.
Validator() — Constructor in class mx.validators.Validator
 | Constructor.
validNextPage — Property in class mx.printing.PrintDataGrid
 | Indicates the data provider contains additional data rows that follow the rows that the PrintDataGrid control currently displays.
validPatternChars — Property in class mx.formatters.PhoneFormatter
 | List of valid characters that can be used in the formatString property.
validPoints — Property in class mx.charts.series.renderData.LineSeriesRenderData
 | The number of points in the cache that were not filtered out by the axes.
value — Property in class flash.net.URLRequestHeader
 | The value associated with the name property (such as text/plain).
value — Property in class mx.charts.AxisLabel
 | The value that the label represents.
value — Property in class mx.charts.chartClasses.BoundedValue
 | The value to be rendered.
value — Property in class mx.charts.series.items.PieSeriesItem
 | The value this wedge represents from the PieSeries' dataProvider.
value — Property in class mx.collections.CursorBookmark
 | The underlying marker representation of the bookmark.
value — Property in class mx.controls.ComboBase
 | The value of the selected item.
value — Property in class mx.controls.NumericStepper
 | Current value displayed in the text area of the NumericStepper control.
value — Property in class mx.controls.ProgressBar
 | Read-only property that contains the amount of progress that has been made - between the minimum and maximum values.
value — Property in class mx.controls.RadioButton
 | Optional user-defined value that is associated with a RadioButton control.
value — Property in class mx.controls.listClasses.ListBase
 | The selected item, or the data or label field of the selected item.
value — Property in class mx.controls.sliderClasses.Slider
 | Contains the position of the thumb, and is a number between the minimum and maximum properties.
value — Property in class mx.effects.SetPropertyAction
 | The new value for the property.
value — Property in class mx.effects.SetStyleAction
 | The new value for the style property.
value — Property in class mx.effects.effectClasses.SetPropertyActionInstance
 | The new value for the property.
value — Property in class mx.effects.effectClasses.SetStyleActionInstance
 | The new value for the property.
value — Property in class mx.events.NumericStepperEvent
 | The value of the NumericStepper control when the event was dispatched.
value — Property in class mx.events.SliderEvent
 | The new value of the slider.
value — Property in class mx.events.TweenEvent
 | For a tweenStart or tweenUpdate event, the value passed to the onTweenUpdate() method; for a tweenEnd event, the value passed to the onTweenEnd() method.
value — Property in class mx.states.SetProperty
 | The new value for the property.
value — Property in class mx.states.SetStyle
 | The new value for the style.
valueCommit — Event in class mx.core.UIComponent
 | Dispatched when values are changed programmatically or by user interaction.
VALUE_COMMIT — Constant static property in class mx.events.FlexEvent
 | The FlexEvent.VALUE_COMMIT constant defines the value of the type property of the event object for a valueCommit event.
valueOf() — Method in class Boolean
 | Returns true if the value of the specified Boolean object is true; false otherwise.
valueOf() — Method in class Date
 | Returns the number of milliseconds since midnight January 1, 1970, universal time, for a Date object.
valueOf() — Method in class int
 | Returns the primitive value of the specified int object.
valueOf() — Method in class Namespace
 | Returns the URI value of the specified object.
valueOf() — Method in class Number
 | Returns the primitive value type of the specified Number object.
valueOf() — Method in class Object
 | Returns the primitive value of the specified object.
valueOf() — Method in class QName
 | Returns the QName object.
valueOf() — Method in class String
 | Returns the primitive value of a String instance.
valueOf() — Method in class uint
 | Returns the primitive uint type value of the specified uint object.
valueOf() — Method in class XML
 | Returns the XML object.
valueOf() — Method in class XMLList
 | Returns the XMLList object.
values — Property in class mx.controls.sliderClasses.Slider
 | An array of values for each thumb when thumbCount is greater than 1.
var — Statement
 | Specifies a variable.
variableRowHeight — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether the individual rows can have different height.
VARIABLES — Constant static property in class flash.net.URLLoaderDataFormat
 | Specifies that downloaded data is received as URL-encoded variables.
variant — Property in class mx.resources.Locale
 | The variant of current locale [Read-Only].
VBox — Class in package mx.containers
 | The VBox container lays out its children in a single vertical column.
VBox() — Constructor in class mx.containers.VBox
 | Constructor.
VDividedBox — Class in package mx.containers
 | The VDividedBox container lays out its children vertically in the same way as the VBox container, but it inserts a draggable divider in the gap between each child.
VDividedBox() — Constructor in class mx.containers.VDividedBox
 | Constructor.
VerifyError — Dynamic class in Top Level
 | The VerifyError class represents an error that occurs when a malformed or corrupted SWF file is encountered.
VerifyError(message:String) — Constructor in class VerifyError
 | Creates a new VerifyError object.
version — Static property in class flash.system.Capabilities
 | Specifies the Flash Player platform and version information.
VERTICAL — Constant static property in class flash.display.LineScaleMode
 | With this setting used as the scaleMode parameter of the lineStyle() method, the thickness of the line scales only horizontally.
VERTICAL — Constant static property in class mx.containers.BoxDirection
 | Specifies that children of the Box container are laid out vertically.
VERTICAL — Constant static property in class mx.containers.FormItemDirection
 | Specifies that the children of the FormItem container are laid out vertically.
VERTICAL — Constant static property in class mx.containers.TileDirection
 | Specifies that the children of the Tile container are laid out vertically; that is, starting with the first column.
VERTICAL — Constant static property in class mx.controls.listClasses.TileBaseDirection
 | Arrange chidren vertically.
VERTICAL — Constant static property in class mx.controls.scrollClasses.ScrollBarDirection
 | Specifies that a ScrollBar control is for vertical scrolling.
VERTICAL — Constant static property in class mx.controls.sliderClasses.SliderDirection
 | Specifies to display a vertical slider.
VERTICAL — Constant static property in class mx.core.ContainerLayout
 | Use vertical layout for the contents of this container.
VERTICAL — Constant static property in class mx.events.ScrollEventDirection
 | The user scrolled vertically.
verticalAlign — Style in class mx.containers.Box
 | Vertical alignment of children in the container.
verticalAlign — Style in class mx.containers.GridRow
 | Vertical alignment of children in the container.
verticalAlign — Style in class mx.containers.Panel
 | Vertical alignment of children in the container.
verticalAlign — Style in class mx.containers.Tile
 | Vertical alignment of each child inside its tile cell.
verticalAlign — Style in class mx.controls.ButtonBar
 | Vertical alignment of the tabs.
verticalAlign — Style in class mx.controls.SWFLoader
 | Vertical alignment of the content when it does not have a one-to-one aspect ratio.
verticalAlign — Style in class mx.controls.TabBar
 | Vertical alignment of the tab navigation items.
verticalAlign — Style in class mx.controls.listClasses.ListBase
 | The vertical alignment of a renderer in a row.
verticalAlign — Style in class mx.core.Application
 | Vertical alignment of children in the container.
verticalAlternateFill — Style in class mx.charts.GridLines
 | Specifies the fill pattern for alternating vertical bands not defined by the fill property.
verticalAxis — Property in class mx.charts.chartClasses.CartesianChart
 | Defines the labels, tick marks, and data position for items on the y-axis.
VERTICAL_AXIS — Constant static property in class mx.charts.chartClasses.CartesianTransform
 | A String representing the vertical axis.
verticalAxisRatio — Property in class mx.charts.chartClasses.CartesianChart
 | Determines the width limit of the vertical axis.
verticalAxisRenderer — Property in class mx.charts.chartClasses.CartesianChart
 | Specifies how data appears along the y-axis of a chart.
verticalAxisStyleName — Style in class mx.charts.chartClasses.CartesianChart
 | The class selector that defines the style properties for the vertical axis.
verticalCenter — Style in class mx.core.UIComponent
 | The vertical distance in pixels from the center of the component's parent container to the center of the component.
verticalChangeCount — Style in class mx.charts.GridLines
 | Specifies the number of tick marks between vertical grid lines.
verticalDividerCursor — Style in class mx.containers.DividedBox
 | The cursor skin for a vertical DividedBox.
verticalFill — Style in class mx.charts.GridLines
 | Specifies the fill pattern for alternating vertical bands created by the grid lines.
verticalFocus — Property in class mx.charts.effects.SeriesZoom
 | Defines the location of the focal point of the zoom.
verticalFocus — Property in class mx.charts.effects.effectClasses.SeriesZoomInstance
 | Defines the location of the focul point of the zoom.
verticalGap — Style in class mx.charts.Legend
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.charts.LegendItem
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.Accordion
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.Box
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.Form
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.FormItem
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.Grid
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.Panel
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.Tile
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.containers.ViewStack
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.controls.Button
 | Gap between the button's label and icon when the labelPlacement property is set to "top" or "bottom".
verticalGap — Style in class mx.controls.ButtonBar
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.controls.ColorPicker
 | Vertical gap between swatches in the grid.
verticalGap — Style in class mx.controls.DateChooser
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.controls.LinkBar
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.controls.ProgressBar
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.controls.TabBar
 | Number of pixels between tab navigation items in the vertical direction.
verticalGap — Style in class mx.controls.listClasses.TileListItemRenderer
 | Number of pixels between children in the vertical direction.
verticalGap — Style in class mx.core.Application
 | Number of pixels between children in the vertical direction.
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number) — Method in class mx.core.UIComponent
 | Returns a box Matrix which can be passed to drawRoundRect() as the rot parameter when drawing a vertical gradient.
verticalGradientMatrix(x:Number, y:Number, width:Number, height:Number) — Method in class mx.skins.ProgrammaticSkin
 | Utility function to create a vertical gradient matrix.
verticalGridLineColor — Style in class mx.controls.DataGrid
 | The color of the vertical grid lines.
verticalGridLines — Style in class mx.controls.DataGrid
 | A flag that indicates whether to show vertical grid lines between the columns.
verticalLineScrollSize — Property in class mx.core.Container
 | Number of pixels to scroll when the up- or down-arrow button in the vertical scroll bar is pressed.
verticalOriginStroke — Style in class mx.charts.GridLines
 | Specifies the line style for the vertical origin.
verticalPageScrollSize — Property in class mx.core.Container
 | Number of pixels to scroll when the track in the vertical scroll bar is pressed.
verticalScrollBar — Property in class mx.core.Container
 | The vertical scrollbar used in this container.
verticalScrollBar — Property in class mx.core.ScrollControlBase
 | The vertical scroll bar.
verticalScrollBarStyleName — Style in class mx.core.Container
 | The name of the vertical scrollbar style.
verticalScrollBarStyleName — Style in class mx.core.ScrollControlBase
 | Style name for vertical scrollbar.
verticalScrollPolicy — Property in class mx.controls.TextArea
 | Whether the vertical scroll bar is always on (ScrollPolicy.ON), always off (ScrollPolicy.OFF), or turns on when needed (ScrollPolicy.AUTO).
verticalScrollPolicy — Property in class mx.core.Container
 | Specifies whether the vertical scroll bar is always present, always absent, or automatically added when needed.
verticalScrollPolicy — Property in class mx.core.ScrollControlBase
 | A property that indicates whether the vertical scroll bar is always on, always off, or automatically changes based on the parameters passed to the setScrollBarProperties() method.
verticalScrollPosition — Property in class mx.controls.TextArea
 | Line number of the top row of characters that is currently displayed.
verticalScrollPosition — Property in class mx.core.Container
 | The current position of the vertical scroll bar.
verticalScrollPosition — Property in class mx.core.ScrollControlBase
 | The offset into the content from the top edge.
verticalShowOrigin — Style in class mx.charts.GridLines
 | Determines whether to draw the vertical Origin.
verticalStroke — Style in class mx.charts.GridLines
 | Specifies the line style for vertical grid lines.
verticalTickAligned — Style in class mx.charts.GridLines
 | Determines whether to align vertical grid lines with tick marks.
Video — Class in package flash.media
 | The Video class enables you to display live streaming video in an application without embedding it in your SWF file.
Video(width:int, height:int) — Constructor in class flash.media.Video
 | Creates a new Video instance.
VideoDisplay — Class in package mx.controls
 | The VideoDisplay control lets you play an FLV file in a Flex application.
VideoDisplay() — Constructor in class mx.controls.VideoDisplay
 | Constructor.
VideoError — Class in package mx.controls.videoClasses
 | The VideoError class represents the error codes for errors thrown by the VideoDisplay control.
VideoError(errCode:uint, msg:String) — Constructor in class mx.controls.videoClasses.VideoError
 | Constructor
VideoEvent — Class in package mx.events
 | The VideoEvent class represents the event object passed to the event listener for events dispatched by the VideoDisplay control, and defines the values of the VideoDisplay.state property.
VideoEvent(type:String, bubbles:Boolean, cancelable:Boolean, state:String, playheadTime:Number) — Constructor in class mx.events.VideoEvent
 | Constructor.
videoHeight — Property in class flash.media.Video
 | An integer specifying the height of the video stream, in pixels.
videoHeight — Property in class mx.controls.VideoDisplay
 | Height of the loaded FLV file.
videoWidth — Property in class flash.media.Video
 | An integer specifying the width of the video stream, in pixels.
videoWidth — Property in class mx.controls.VideoDisplay
 | Width of the loaded FLV file.
view — Property in interface mx.collections.IViewCursor
 | A reference to the ICollectionView with which this cursor is associated.
viewMetrics — Property in class mx.core.Container
 | Returns an object that has four properties: left, top, right, and bottom.
viewMetrics — Property in class mx.core.ScrollControlBase
 | An EdgeMetrics object taking into account the scroll bars, if visible.
viewMetricsAndPadding — Property in class mx.core.Container
 | Returns an object that has four properties: left, top, right, and bottom.
viewSourceURL — Property in class mx.core.Application
 | URL where the application's source can be viewed.
ViewStack — Class in package mx.containers
 | A ViewStack navigator container consists of a collection of child containers stacked on top of each other, where only one child at a time is visible.
ViewStack() — Constructor in class mx.containers.ViewStack
 | Constructor.
VISA — Constant static property in class mx.validators.CreditCardValidatorCardType
 | Specifies the card type as Visa.
visible — Property in class flash.display.DisplayObject
 | Whether or not the display object is visible.
visible — Property in class flash.ui.ContextMenuItem
 | Indicates whether the specified menu item is visible when the Flash Player context menu is displayed.
visible — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A flag that indicates whethe the column is visible.
visible — Property in interface mx.core.IFlexDisplayObject
 | A flag that indicates whether this object is visible.
visible — Property in class mx.core.UIComponent
 | Controls the visibility of this UIComponent.
visible — Property in class mx.preloaders.DownloadProgressBar
 | Specifies whether the download progress bar is visible.
visibleData — Property in class mx.controls.listClasses.ListBase
 | A hash table of data provider item renderers currently in view.
visibleRegion — Property in class mx.charts.chartClasses.RenderData
 | The rectangle describing the possible coordinate range that a series can display on screen.
void — Operator
 | Evaluates an expression and then discards its value, returning undefined.
void — Special Type
 | Specifies that a function cannot return any value.
volume — Property in class flash.media.SoundTransform
 | The volume, ranging from 0 (silent) to 1 (full volume).
volume — Property in class mx.controls.VideoDisplay
 | The volume level, specified as an value between 0 and 1.
volumeEasingFunction — Property in class mx.effects.SoundEffect
 | The easing function for the volume effect.
volumeEasingFunction — Property in class mx.effects.effectClasses.SoundEffectInstance
 | The easing function for the volume effect.
volumeFrom — Property in class mx.effects.SoundEffect
 | Initial volume of the Sound object.
volumeFrom — Property in class mx.effects.effectClasses.SoundEffectInstance
 | Initial volume of the Sound object.
volumeTo — Property in class mx.effects.SoundEffect
 | Final volume of the Sound object.
volumeTo — Property in class mx.effects.effectClasses.SoundEffectInstance
 | Final volume of the Sound object.
VRule — Class in package mx.controls
 | The VRule control creates a single vertical line.
VRule() — Constructor in class mx.controls.VRule
 | Constructor
VScrollBar — Class in package mx.controls
 | The VScrollBar (vertical ScrollBar) control lets you control the portion of data that is displayed when there is too much data to fit in a display area.
VScrollBar() — Constructor in class mx.controls.VScrollBar
 | Constructor.
VSlider — Class in package mx.controls
 | The VSlider control lets users select a value by moving a slider thumb between the end points of the slider track.
VSlider() — Constructor in class mx.controls.VSlider
 | Constructor.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


W Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
W Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
warn(message:String, ... rest) — Method in interface mx.logging.ILogger
 | Logs the specified data using the LogEventLevel.WARN level.
warn(message:String, ... rest) — Method in class mx.logging.LogLogger
 | Logs the specified data using the LogEventLevel.WARN level.
WARN — Constant static property in class mx.logging.LogEventLevel
 | Designates events that could be harmful to the application operation.
watch(host:Object, chain:Object, handler:Function, commitOnly:Boolean) — Static method in class mx.binding.utils.ChangeWatcher
 | Creates and starts a ChangeWatcher instance.
WebService — Dynamic class in package mx.rpc.soap
 | The WebService class provides access to SOAP-based web services on remote servers.
WebService — Dynamic class in package mx.rpc.soap.mxml
 | The <mx:WebService> tag gives you access to the operations of SOAP-compliant web services.
WebService(destination:String, rootURL:String) — Constructor in class mx.rpc.soap.WebService
 | Creates a new WebService.
WebService(destination:String) — Constructor in class mx.rpc.soap.mxml.WebService
 | Creates a new WebService component.
WedgeItemRenderer — Class in package mx.charts.renderers
 | The default itemRenderer for a PieSeries object.
WedgeItemRenderer() — Constructor in class mx.charts.renderers.WedgeItemRenderer
 | Constructor.
weekDayStyleName — Style in class mx.controls.DateChooser
 | Name of the style sheet definition to configure the weekday names of the control.
weekDayStyleName — Style in class mx.controls.DateField
 | Name of the style sheet definition to configure the weekday names of the control.
weight — Property in interface mx.graphics.IStroke
 | The line weight, in pixels.
weight — Property in class mx.graphics.LinearGradientStroke
 | The line weight, in pixels.
weight — Property in class mx.graphics.Stroke
 | The line weight, in pixels.
while — Statement
 | Evaluates a condition and if the condition evaluates to true, executes one or more statements before looping back to evaluate the condition again.
width — Property in class flash.display.BitmapData
 | The width of the bitmap image in pixels.
width — Property in class flash.display.DisplayObject
 | Indicates the width of the display object, in pixels.
width — Property in class flash.display.LoaderInfo
 | The nominal width of the loaded content.
width — Property in class flash.display.Stage
 | Indicates the width of the display object, in pixels.
width — Property in class flash.geom.Rectangle
 | The width of the rectangle, in pixels.
width — Property in class flash.media.Camera
 | The current capture width, in pixels.
width — Property in class flash.text.TextLineMetrics
 | The width value is the width of the text of the selected lines (not necessarily the complete text) in pixels.
width — Property in class mx.controls.dataGridClasses.DataGridColumn
 | The width of the column, in pixels.
width — Property in interface mx.core.IFlexDisplayObject
 | The width of this object, in pixels.
width — Property in class mx.core.UIComponent
 | Number that specifies the width of the component, in pixels, in the parent's coordinates.
width — Property in class mx.managers.SystemManager
 | The width of this object.
widthBy — Property in class mx.effects.Resize
 | Number of pixels by which to modify the width of the component.
widthBy — Property in class mx.effects.effectClasses.ResizeInstance
 | Number of pixels by which to modify the width of the component.
widthFrom — Property in class mx.effects.Resize
 | Initial width, in pixels.
widthFrom — Property in class mx.effects.effectClasses.ResizeInstance
 | Initial width.
widthTo — Property in class mx.effects.Resize
 | Final width, in pixels.
widthTo — Property in class mx.effects.effectClasses.ResizeInstance
 | Final width, in pixels.
willTrigger(type:String) — Method in class flash.display.Stage
 | Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
willTrigger(type:String) — Method in class flash.events.EventDispatcher
 | Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
willTrigger(type:String) — Method in interface flash.events.IEventDispatcher
 | Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
willTrigger(type:String) — Method in class mx.collections.ListCollectionView
 | Checks whether an event listener is registered with this EventDispatcher object or any of its ancestors for the specified event type.
willTrigger(type:String) — Method in class mx.utils.ObjectProxy
 | Checks whether an event listener is registered with this object or any of its ancestors for the specified event type.
WipeDown — Class in package mx.effects
 | The WipeDown class defines a bar wipe down effect.
WipeDown(target:Object) — Constructor in class mx.effects.WipeDown
 | Constructor.
WipeDownInstance — Class in package mx.effects.effectClasses
 | The WipeDownInstance class implements the instance class for the WipeDown effect.
WipeDownInstance(target:Object) — Constructor in class mx.effects.effectClasses.WipeDownInstance
 | Constructor.
WipeLeft — Class in package mx.effects
 | The WipeLeft class defines a bar wipe left effect.
WipeLeft(target:Object) — Constructor in class mx.effects.WipeLeft
 | Constructor.
WipeLeftInstance — Class in package mx.effects.effectClasses
 | The WipeLeftInstance class implements the instance class for the WipeLeft effect.
WipeLeftInstance(target:Object) — Constructor in class mx.effects.effectClasses.WipeLeftInstance
 | Constructor.
WipeRight — Class in package mx.effects
 | The WipeRight class defines a bar wipe right effect.
WipeRight(target:Object) — Constructor in class mx.effects.WipeRight
 | Constructor.
WipeRightInstance — Class in package mx.effects.effectClasses
 | The WipeRightInstance class implements the instance class for the WipeRight effect.
WipeRightInstance(target:Object) — Constructor in class mx.effects.effectClasses.WipeRightInstance
 | Constructor.
WipeUp — Class in package mx.effects
 | The WipeUp class defines a bar wipe up effect.
WipeUp(target:Object) — Constructor in class mx.effects.WipeUp
 | Constructor.
WipeUpInstance — Class in package mx.effects.effectClasses
 | The WipeUpInstance class implements the instance class for the WipeUp effect.
WipeUpInstance(target:Object) — Constructor in class mx.effects.effectClasses.WipeUpInstance
 | Constructor.
with — Statement
 | Establishes a default object to be used for the execution of a statement or statements, potentially reducing the amount of code that needs to be written.
wordWrap — Property in class flash.text.TextField
 | A Boolean value that indicates whether the text field has word wrap.
wordWrap — Property in class mx.controls.TextArea
 | Indicates whether the text automatically wraps at the end of a line.
wordWrap — Property in class mx.controls.dataGridClasses.DataGridColumn
 | A flag that indicates whether the text in a row of this column is word wrapped if it doesn't fit on one line If undefined, the DataGrid control's wordWrap property is used.
wordWrap — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether text in the row should be word wrapped.
wordWrapChanged — Property in class mx.controls.listClasses.ListBase
 | A flag that indicates whether the value of the wordWrap property has changed since the last time the display list was updated.
WRAP — Constant static property in class flash.filters.DisplacementMapFilterMode
 | Wraps the displacement value to the other side of the source image.
writable — Property in class mx.messaging.management.MBeanAttributeInfo
 | Indicates if the attribute is writable.
writeBoolean(value:Boolean) — Method in class flash.net.Socket
 | Writes a Boolean value to the socket.
writeBoolean(value:Boolean) — Method in class flash.utils.ByteArray
 | Writes a Boolean value.
writeBoolean(value:Boolean) — Method in interface flash.utils.IDataOutput
 | Writes a Boolean value.
writeByte(value:int) — Method in class flash.net.Socket
 | Writes a byte to the socket.
writeByte(value:int) — Method in class flash.utils.ByteArray
 | Writes a byte to the byte stream.
writeByte(value:int) — Method in interface flash.utils.IDataOutput
 | Writes a byte.
writeBytes(bytes:flash.utils:ByteArray, offset:uint, length:uint) — Method in class flash.net.Socket
 | Writes a sequence of bytes from the specified byte array.
writeBytes(bytes:flash.utils:ByteArray, offset:uint, length:uint) — Method in class flash.utils.ByteArray
 | Writes a sequence of length bytes from the specified byte array, bytes, starting offset (zero-based index) bytes into the byte stream.
writeBytes(bytes:flash.utils:ByteArray, offset:uint, length:uint) — Method in interface flash.utils.IDataOutput
 | Writes a sequence of length bytes from the specified byte array, bytes, starting offset(zero-based index) bytes into the byte stream.
writeDouble(value:Number) — Method in class flash.net.Socket
 | Writes an IEEE 754 double-precision floating-point number to the socket.
writeDouble(value:Number) — Method in class flash.utils.ByteArray
 | Writes an IEEE 754 double-precision (64-bit) floating-point number to the byte stream.
writeDouble(value:Number) — Method in interface flash.utils.IDataOutput
 | Writes an IEEE 754 double-precision (64-bit) floating point number.
writeDynamicProperties(obj:Object, output:flash.net:IDynamicPropertyOutput) — Method in interface flash.net.IDynamicPropertyWriter
 | Writes the name and value of an IDynamicPropertyOutput object to an object with dynamic properties.
writeDynamicProperty(name:String, value) — Method in interface flash.net.IDynamicPropertyOutput
 | Adds a dynamic property to the binary output of a serialized object.
writeExternal(output:flash.utils:IDataOutput) — Method in interface flash.utils.IExternalizable
 | A class implements this method to encode itself for a data stream by calling the methods of the IDataOutput interface.
writeExternal(output:flash.utils:IDataOutput) — Method in class mx.utils.ObjectProxy
 | Since Flex only serializes the inner ActionScript object that it wraps, the server flex.messaging.io.ObjectProxy populates itself with this anonymous object's contents and appears to the user as a Map.
writeFloat(value:Number) — Method in class flash.net.Socket
 | Writes an IEEE 754 single-precision floating-point number to the socket.
writeFloat(value:Number) — Method in class flash.utils.ByteArray
 | Writes an IEEE 754 single-precision (32-bit) floating-point number to the byte stream.
writeFloat(value:Number) — Method in interface flash.utils.IDataOutput
 | Writes an IEEE 754 single-precision (32-bit) floating point number.
writeInt(value:int) — Method in class flash.net.Socket
 | Writes a 32-bit signed integer to the socket.
writeInt(value:int) — Method in class flash.utils.ByteArray
 | Writes a 32-bit signed integer to the byte stream.
writeInt(value:int) — Method in interface flash.utils.IDataOutput
 | Writes a 32-bit signed integer.
writeMultiByte(value:String, charSet:String) — Method in class flash.net.Socket
 | Writes a multibyte string from the byte stream, using the specified character set.
writeMultiByte(value:String, charSet:String) — Method in class flash.utils.ByteArray
 | Writes a multibyte string to the byte stream using the specified character set.
writeMultiByte(value:String, charSet:String) — Method in interface flash.utils.IDataOutput
 | Writes a multibyte string to the byte stream using the specified character set.
writeObject(object) — Method in class flash.net.Socket
 | Write an object to the socket in AMF serialized format.
writeObject(object) — Method in class flash.utils.ByteArray
 | Writes an object into the byte array in AMF serialized format.
writeObject(object) — Method in interface flash.utils.IDataOutput
 | Writes an object to the byte stream or byte array in AMF serialized format.
writeShort(value:int) — Method in class flash.net.Socket
 | Writes a 16-bit integer to the socket.
writeShort(value:int) — Method in class flash.utils.ByteArray
 | Writes a 16-bit integer to the byte stream.
writeShort(value:int) — Method in interface flash.utils.IDataOutput
 | Writes a 16-bit integer.
writeUnsignedInt(value:uint) — Method in class flash.net.Socket
 | Writes a 32-bit unsigned integer to the socket.
writeUnsignedInt(value:uint) — Method in class flash.utils.ByteArray
 | Writes a 32-bit unsigned integer to the byte stream.
writeUnsignedInt(value:uint) — Method in interface flash.utils.IDataOutput
 | Writes a 32-bit unsigned integer.
writeUTF(value:String) — Method in class flash.net.Socket
 | Writes the following data to the socket: a 16-bit unsigned integer, which indicates the length of the specified UTF-8 string in bytes, followed by the string itself.
writeUTF(value:String) — Method in class flash.utils.ByteArray
 | Writes a UTF-8 string to the byte stream.
writeUTF(value:String) — Method in interface flash.utils.IDataOutput
 | Writes a UTF-8 string to the byte stream.
writeUTFBytes(value:String) — Method in class flash.net.Socket
 | Writes a UTF-8 string to the socket.
writeUTFBytes(value:String) — Method in class flash.utils.ByteArray
 | Writes a UTF-8 string to the byte stream.
writeUTFBytes(value:String) — Method in interface flash.utils.IDataOutput
 | Writes a UTF-8 string.
wrongCAFormatError — Property in class mx.validators.ZipCodeValidator
 | Error message for an invalid Canadian postal code.
wrongDayError — Property in class mx.validators.DateValidator
 | Error message when the day is invalid.
wrongFormatError — Property in class mx.validators.SocialSecurityValidator
 | Error message when the value is incorrectly formatted.
wrongLengthError — Property in class mx.validators.CreditCardValidator
 | Error message when the cardNumber field contains the wrong number of digits for the specified credit card type.
wrongLengthError — Property in class mx.validators.DateValidator
 | Error message when the length of the date doesn't match that of the inputFormat property.
wrongLengthError — Property in class mx.validators.PhoneNumberValidator
 | Error message when the value has fewer than 10 digits.
wrongLengthError — Property in class mx.validators.ZipCodeValidator
 | Error message for an invalid US ZIP code.
wrongMonthError — Property in class mx.validators.DateValidator
 | Error message when the month is invalid.
wrongTypeError — Property in class mx.validators.CreditCardValidator
 | Error message the cardType field contains an invalid credit card type.
wrongUSFormatError — Property in class mx.validators.ZipCodeValidator
 | Error message for an incorrectly formatted ZIP code.
wrongYearError — Property in class mx.validators.DateValidator
 | Error message when the year is invalid.
wsdl — Property in class mx.rpc.soap.LoadEvent
 | The parsed WSDL document.
wsdl — Property in class mx.rpc.soap.WebService
 | The location of the WSDL document for this WebService.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


X Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
X Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
x — Property in class flash.display.DisplayObject
 | Indicates the x coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer.
x — Property in class flash.geom.Point
 | The horizontal coordinate of the point.
x — Property in class flash.geom.Rectangle
 | The x coordinate of the top-left corner of the rectangle.
x — Property in class flash.text.TextLineMetrics
 | The x value is the left position of the first character in pixels.
x — Property in class mx.charts.HitData
 | Specifies the X coordinate of the data item on the screen.
x — Property in class mx.charts.series.items.AreaSeriesItem
 | The x value of this item converted into screen coordinates.
x — Property in class mx.charts.series.items.BarSeriesItem
 | The x value of this item converted into screen coordinates.
x — Property in class mx.charts.series.items.BubbleSeriesItem
 | The x value of this item converted into screen coordinates.
x — Property in class mx.charts.series.items.ColumnSeriesItem
 | The x value of this item converted into screen coordinates.
x — Property in class mx.charts.series.items.HLOCSeriesItem
 | The x value of this item converted into screen coordinates.
x — Property in class mx.charts.series.items.LineSeriesItem
 | The x value of this item converted into screen coordinates.
x — Property in class mx.charts.series.items.PlotSeriesItem
 | The x value of this item converted into screen coordinates.
x — Property in interface mx.core.IFlexDisplayObject
 | The horizontal position of this object relative to its parent, in pixel coordinates.
x — Property in class mx.core.UIComponent
 | Number that specifies the component's horizontal position, in pixels, within its parent container.
xBy — Property in class mx.effects.Move
 | Number of pixels to move the components along the x axis.
xBy — Property in class mx.effects.effectClasses.MoveInstance
 | Number of pixels to move the components along the x axis.
xField — Property in class mx.charts.chartClasses.HLOCSeriesBase
 | Specifies the field of the data provider that determines the x-axis location of the element.
xField — Property in class mx.charts.series.AreaSeries
 | Specifies the field of the data provider that determines the position of the data points on the horizontal axis.
xField — Property in class mx.charts.series.BarSeries
 | Specifies the field of the data provider that determines the x-axis location of the top of each bar.
xField — Property in class mx.charts.series.BubbleSeries
 | Specifies the field of the data provider that determines the x-axis location of each data point.
xField — Property in class mx.charts.series.ColumnSeries
 | Specifies the field of the data provider that determines the x-axis location of the column.
xField — Property in class mx.charts.series.LineSeries
 | Specifies the field of the data provider that determines the x-axis location of each data point.
xField — Property in class mx.charts.series.PlotSeries
 | Specifies the field of the data provider that determines the x-axis location of each data point.
xFilter — Property in class mx.charts.series.items.AreaSeriesItem
 | The x value of this item, filtered against the horizontal axis of the containing chart.
xFilter — Property in class mx.charts.series.items.BarSeriesItem
 | The x value of this item, filtered against the horizontal axis of the containing chart.
xFilter — Property in class mx.charts.series.items.BubbleSeriesItem
 | The x value of this item, filtered against the horizontal axis of the containing chart.
xFilter — Property in class mx.charts.series.items.ColumnSeriesItem
 | The x value of this item, filtered against the horizontal axis of the containing chart.
xFilter — Property in class mx.charts.series.items.HLOCSeriesItem
 | The x value of this item, filtered against the horizontal axis of the containing chart.
xFilter — Property in class mx.charts.series.items.LineSeriesItem
 | The x value of this item, filtered against the horizontal axis of the containing chart.
xFilter — Property in class mx.charts.series.items.PlotSeriesItem
 | The x value of this item, filtered against the horizontal axis of the containing chart.
xFrom — Property in class mx.effects.MaskEffect
 | Initial position's x coordinate for mask.
xFrom — Property in class mx.effects.Move
 | Initial position's x coordinate.
xFrom — Property in class mx.effects.effectClasses.MaskEffectInstance
 | Initial position's x coordinate for mask.
xFrom — Property in class mx.effects.effectClasses.MoveInstance
 | Initial position's x coordinate.
xml — Static property in class mx.messaging.config.ServerConfig
 | The XML configuration; this value must contain the relevant portions of the <services> tag from the services-config.xml file.
XML — MXML Only Component
 | You can declare a data model in MXML in an <mx:XML> tag.
XML — Final dynamic class in Top Level
 | The XML class contains methods and properties for working with XML objects.
XML(expression) — Package function in Top Level
 | Converts an object to an XML object.
XML(value:Object) — Constructor in class XML
 | Creates a new XML object.
xmlDecl — Property in class flash.xml.XMLDocument
 | A string that specifies information about a document's XML declaration.
xmlDecode — Property in class mx.rpc.http.HTTPService
 | ActionScript function used to decode a service result from XML.
XMLDocument — Class in package flash.xml
 | The XMLDocument class represents the legacy XML object that was present in ActionScript 2.0.
XMLDocument(source:String) — Constructor in class flash.xml.XMLDocument
 | Creates a new XMLDocument object.
xmlEncode — Property in class mx.rpc.http.HTTPService
 | ActionScript function used to encode a service request as XML.
XMLList — Final dynamic class in Top Level
 | An XMLList object is an ordered collection of properties.
XMLList(expression) — Package function in Top Level
 | Converts an object to an XMLList object.
XMLList(value:Object) — Constructor in class XMLList
 | Creates a new XMLList object.
XMLListCollection — Class in package mx.collections
 | The XMLListCollection class provides collection functionality to an XMLList object and makes available some of the methods of the native XMLList class.
XMLListCollection(source:XMLList) — Constructor in class mx.collections.XMLListCollection
 | Constructor.
XMLNode — Class in package flash.xml
 | The XMLNode class represents the legacy XML object that was present in ActionScript 2.0 and that was renamed in ActionScript 3.0.
XMLNode(type:uint, value:String) — Constructor in class flash.xml.XMLNode
 | Creates a new XMLNode object.
XMLNodeType — Final class in package flash.xml
 | The XMLNodeType class contains constants used with XMLNode.nodeType.
XMLSocket — Class in package flash.net
 | The XMLSocket class implements client sockets that let the computer that is running Flash Player communicate with a server computer identified by an IP address or domain name.
XMLSocket(host:String, port:int) — Constructor in class flash.net.XMLSocket
 | Creates a new XMLSocket object.
XMLUtil — Class in package mx.utils
 | The XMLUtil class is an all-static class with methods for working with XML within Flex.
xNumber — Property in class mx.charts.series.items.AreaSeriesItem
 | The x value of this item, converted to a numeric representation by the horizontal axis of the containing chart.
xNumber — Property in class mx.charts.series.items.BarSeriesItem
 | The x value of this item, converted to a number by the horizontal axis of the containing chart.
xNumber — Property in class mx.charts.series.items.BubbleSeriesItem
 | The x value of this item, converted to a number by the horizontal axis of the containing chart.
xNumber — Property in class mx.charts.series.items.ColumnSeriesItem
 | The x value of this item, converted to a number by the horizontal axis of the containing chart.
xNumber — Property in class mx.charts.series.items.HLOCSeriesItem
 | The x value of this item, converted to a number by the horizontal axis of the containing chart.
xNumber — Property in class mx.charts.series.items.LineSeriesItem
 | The x value of this item, converted to a number by the horizontal axis of the containing chart.
xNumber — Property in class mx.charts.series.items.PlotSeriesItem
 | The x value of this item, converted to a number by the horizontal axis of the containing chart.
xPosition — Property in class mx.controls.sliderClasses.SliderThumb
 | Specifies the position of the center of the thumb on the x-axis.
xTo — Property in class mx.effects.MaskEffect
 | Destination position's x coordinate for mask.
xTo — Property in class mx.effects.Move
 | Destination position's x coordinate.
xTo — Property in class mx.effects.effectClasses.MaskEffectInstance
 | Destination position's x coordinate for mask.
xTo — Property in class mx.effects.effectClasses.MoveInstance
 | Destination position's x coordinate.
xValue — Property in class mx.charts.series.items.AreaSeriesItem
 | The x value of this item.
xValue — Property in class mx.charts.series.items.BarSeriesItem
 | The x value of this item.
xValue — Property in class mx.charts.series.items.BubbleSeriesItem
 | The x value of this item.
xValue — Property in class mx.charts.series.items.ColumnSeriesItem
 | The x value of this item.
xValue — Property in class mx.charts.series.items.HLOCSeriesItem
 | The x value of this item.
xValue — Property in class mx.charts.series.items.LineSeriesItem
 | The x value of this item.
xValue — Property in class mx.charts.series.items.PlotSeriesItem
 | The x value of this item.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


Y Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
Y Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
y — Property in class flash.display.DisplayObject
 | Indicates the y coordinate of the DisplayObject instance relative to the local coordinates of the parent DisplayObjectContainer.
y — Property in class flash.geom.Point
 | The vertical coordinate of the point.
y — Property in class flash.geom.Rectangle
 | The y coordinate of the top-left corner of the rectangle.
y — Property in class mx.charts.HitData
 | Specifies the Y coordinate of the data item on the screen.
y — Property in class mx.charts.series.items.AreaSeriesItem
 | The y value of this item converted into screen coordinates.
y — Property in class mx.charts.series.items.BarSeriesItem
 | The y value of this item converted into screen coordinates.
y — Property in class mx.charts.series.items.BubbleSeriesItem
 | The y value of this item converted into screen coordinates.
y — Property in class mx.charts.series.items.ColumnSeriesItem
 | The y value of this item converted into screen coordinates
y — Property in class mx.charts.series.items.LineSeriesItem
 | The y value of this item converted into screen coordinates.
y — Property in class mx.charts.series.items.PlotSeriesItem
 | The y value of this item converted into screen coordinates
y — Property in class mx.controls.listClasses.ListRowInfo
 | The y-position value for the row.
y — Property in interface mx.core.IFlexDisplayObject
 | The vertical position of this object relative to its parent, in pixel coordinates.
y — Property in class mx.core.UIComponent
 | Number that specifies the component's vertical position, in pixels, within its parent container.
yBy — Property in class mx.effects.Move
 | Number of pixels to move the components along the y axis.
yBy — Property in class mx.effects.effectClasses.MoveInstance
 | Number of pixels to move the components along the y axis.
year — Property in class flash.media.ID3Info
 | The year of the recording; corresponds to the ID3 2.0 tag TYER.
yearListener — Property in class mx.validators.DateValidator
 | The component that listens for the validation result for the year subfield.
yearNavigationEnabled — Property in class mx.controls.DateChooser
 | Enables year navigation.
yearNavigationEnabled — Property in class mx.controls.DateField
 | Enables year navigation.
yearProperty — Property in class mx.validators.DateValidator
 | Name of the year property to validate.
yearSource — Property in class mx.validators.DateValidator
 | Object that contains the value of the year field.
yearSymbol — Property in class mx.controls.DateChooser
 | This property is appended to the end of the year displayed at the top of the DateChooser control.
yearSymbol — Property in class mx.controls.DateField
 | This property is appended to the end of the year displayed at the top of the control.
YES — Constant static property in class mx.controls.Alert
 | Value that enables a Yes button on the Alert control when passed as the flags parameter of the show() method.
yesLabel — Static property in class mx.controls.Alert
 | The label for the Yes button.
yField — Property in class mx.charts.series.AreaSeries
 | Specifies the field of the data provider that determines the position of the data point on the vertical axis.
yField — Property in class mx.charts.series.BarSeries
 | Specifies the field of the data provider that determines the y-axis location of the bottom of each bar in the chart.
yField — Property in class mx.charts.series.BubbleSeries
 | Specifies the field of the data provider that determines the y-axis location of each data point.
yField — Property in class mx.charts.series.ColumnSeries
 | Specifies the field of the data provider that determines the y-axis location of the top of a column.
yField — Property in class mx.charts.series.LineSeries
 | Specifies the field of the data provider that determines the y-axis location of each data point.
yField — Property in class mx.charts.series.PlotSeries
 | Specifies the field of the data provider that determines the y-axis location of each data point.
yFilter — Property in class mx.charts.series.items.AreaSeriesItem
 | The y value of this item, filtered against the vertical axis of the containing chart.
yFilter — Property in class mx.charts.series.items.BarSeriesItem
 | The y value of this item, filtered against the vertical axis of the containing chart.
yFilter — Property in class mx.charts.series.items.BubbleSeriesItem
 | The y value of this item, filtered against the vertical axis of the containing chart.
yFilter — Property in class mx.charts.series.items.ColumnSeriesItem
 | The y value of this item, filtered against the vertical axis of the containing chart.
yFilter — Property in class mx.charts.series.items.LineSeriesItem
 | The y value of this item, filtered against the vertical axis of the containing chart.
yFilter — Property in class mx.charts.series.items.PlotSeriesItem
 | The y value of this item, filtered against the vertical axis of the containing chart.
yFrom — Property in class mx.effects.MaskEffect
 | Initial position's y coordinate for mask.
yFrom — Property in class mx.effects.Move
 | Initial position's y coordinate.
yFrom — Property in class mx.effects.effectClasses.MaskEffectInstance
 | Initial position's y coordinate for mask.
yFrom — Property in class mx.effects.effectClasses.MoveInstance
 | Initial position's y coordinate.
yNumber — Property in class mx.charts.series.items.AreaSeriesItem
 | The y value of this item, converted to a numeric representation by the vertical axis of the containing chart.
yNumber — Property in class mx.charts.series.items.BarSeriesItem
 | The y value of this item, converted to a number by the vertical axis of the containing chart.
yNumber — Property in class mx.charts.series.items.BubbleSeriesItem
 | The y value of this item, converted to a number by the vertical axis of the containing chart.
yNumber — Property in class mx.charts.series.items.ColumnSeriesItem
 | The y value of this item, converted to a number by the vertical axis of the containing chart.
yNumber — Property in class mx.charts.series.items.LineSeriesItem
 | The y value of this item, converted to a number by the vertical axis of the containing chart.
yNumber — Property in class mx.charts.series.items.PlotSeriesItem
 | The y value of this item, converted to a number by the vertical axis of the containing chart.
yTo — Property in class mx.effects.MaskEffect
 | Destination position's y coordinate for mask.
yTo — Property in class mx.effects.Move
 | Destination position's y coordinate.
yTo — Property in class mx.effects.effectClasses.MaskEffectInstance
 | Destination position's y coordinate for mask.
yTo — Property in class mx.effects.effectClasses.MoveInstance
 | Destination position's y coordinate.
yValue — Property in class mx.charts.series.items.AreaSeriesItem
 | The y value of this item.
yValue — Property in class mx.charts.series.items.BarSeriesItem
 | The y value of this item.
yValue — Property in class mx.charts.series.items.BubbleSeriesItem
 | The y value of this item.
yValue — Property in class mx.charts.series.items.ColumnSeriesItem
 | The y value of this item.
yValue — Property in class mx.charts.series.items.LineSeriesItem
 | The y value of this item.
yValue — Property in class mx.charts.series.items.PlotSeriesItem
 | The y value of this item.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


Z Index (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Appendixes | Conventions Adobe Logo
Z Index

Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
z — Property in class mx.charts.series.items.BubbleSeriesItem
 | The z value of this item converted into a pixel-based radius.
zeroStartError — Property in class mx.validators.SocialSecurityValidator
 | Error message when the value contains an invalid Social Security number.
zFilter — Property in class mx.charts.series.items.BubbleSeriesItem
 | The z value of this item, filtered against the radius axis of the containing chart.
ZipCodeFormatter — Class in package mx.formatters
 | The ZipCodeFormatter class formats a valid number into one of the following formats, based on a user-supplied formatString property.
ZipCodeFormatter() — Constructor in class mx.formatters.ZipCodeFormatter
 | Constructor.
ZipCodeValidator — Class in package mx.validators
 | The ZipCodeValidator class validates that a String has the correct length and format for a five-digit ZIP code, a five-digit+four-digit United States ZIP code, or Canadian postal code.
ZipCodeValidator() — Constructor in class mx.validators.ZipCodeValidator
 | Constructor.
ZipCodeValidatorDomainType — Final class in package mx.validators
 | The ZipCodeValidatorDomainType class defines the values for the domain property of the ZipCodeValidator class, which you use to specify the type of ZIP code to validate.
zNumber — Property in class mx.charts.series.items.BubbleSeriesItem
 | The z value of this item, converted to a number by the radius axis of the containing chart.
zoom — Property in class flash.ui.ContextMenuBuiltInItems
 | Lets the user zoom in and out on a SWF file at run time.
Zoom — Class in package mx.effects
 | The Zoom effect zooms the object in or out on a center point.
Zoom(target:Object) — Constructor in class mx.effects.Zoom
 | Constructor.
zoomHeightFrom — Property in class mx.effects.Zoom
 | Number that represents the scale at which to start the height zoom, as a percent between 0.01 and 1.0.
zoomHeightFrom — Property in class mx.effects.effectClasses.ZoomInstance
 | Number that represents the scale at which to start the height zoom, as a percent between 0.01 and 1.0.
zoomHeightTo — Property in class mx.effects.Zoom
 | Number that represents the scale at which to complete the height zoom, as a percent between 0.01 and 1.0.
zoomHeightTo — Property in class mx.effects.effectClasses.ZoomInstance
 | Number that represents the scale at which to complete the height zoom, as a percent between 0.01 and 1.0.
ZoomInstance — Class in package mx.effects.effectClasses
 | The ZoomInstance class implements the instance class for the Zoom effect.
ZoomInstance(target:Object) — Constructor in class mx.effects.effectClasses.ZoomInstance
 | Constructor.
zoomWidthFrom — Property in class mx.effects.Zoom
 | Number that represents the scale at which to start the width zoom, as a percent between 0.01 and 1.0.
zoomWidthFrom — Property in class mx.effects.effectClasses.ZoomInstance
 | Number that represents the scale at which to start the width zoom, as a percent between 0.01 and 1.0.
zoomWidthTo — Property in class mx.effects.Zoom
 | Number that represents the scale at which to complete the width zoom, as a percent between 0.01 and 1.0.
zoomWidthTo — Property in class mx.effects.effectClasses.ZoomInstance
 | Number that represents the scale at which to complete the width zoom, as a percent between 0.01 and 1.0.
zValue — Property in class mx.charts.series.items.BubbleSeriesItem
 | The z value of this item.
Symbols A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:23 PM GMT-07:00


Appendixes (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Conventions Adobe Logo
Appendixes

The Flex 2 Language Reference contains these appendixes.

Appendix | Description
MXML Only Components | This section describes the Flex components that are available in MXML only.
Compiler Errors | List and explanations of compiler error codes.
Compiler Warnings | List and explanations of compiler warning codes.
Run-Time Errors | List and explanations of run-time error messages.
ActionScript 2.0 Migration | List of differences between ActionScript 2.0 and 3.0.


MXML Only Components (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
MXML Only Components

This section describes the Flex components that are available in MXML only. The Flex MXML compiler implements these components; therefore, they are not available in ActionScript.

Component | Description
mx:Binding | You use the <mx:Binding> tag to tie the data in one object to another object.
mx:Component | You use the <mx:Component> tag to define an inline cell renderer or cell editor in an MXML file.
mx:Metadata | You use the <mx:Metadata> tag to insert metadata tags in an MXML file.
mx:Model | You use the <mx:Model> tag to declare a data model in MXML.
mx:Script | You use the <mx:Script> tag to define blocks of ActionScript code.
mx:Style | You use the <mx:Style> tag to define styles that apply to the current document and its children.
mx:XML | You can declare an XML format data model in MXML in an <mx:XML> tag.
mx:XMLList | You can create an E4X XMLList object from a text-format model in MXML in an <mx:XML> tag.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Binding (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Binding

<mx:Binding> tag implemented by the compiler

You use the <mx:Binding> tag to tie the data in one object to another object. When you use the <mx:Binding> tag, you provide a source property and a destination property. You can use the <mx:Binding> tag to completely separate the view, or user interface, from the model. the <mx:Binding> tag also lets you bind different source properties to the same destination property.

MXML Syntax

The <mx:Binding> tag has the following syntax:

    <mx:Binding
        source="No default."
        destination="No default"
    />

For example, you might bind the text property of the name field of one form to the text property of the name field of another form, as follows:

        <mx:Binding
            source="billForm.name.text"
            destination="shipform.name.text"
        />

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Component (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Component

<mx:Component> tag implemented by the compiler

You use the <mx:Component> tag to define an inline item renderer or item editor in an MXML file.

The <mx:Component> tag defines a new scope within an MXML file, where the local scope of the item renderer or item editor is defined by the MXML code block delimited by the <mx:Component> and </mx:Component> tags. To access elements outside of the local scope of the item renderer or item editor, you prefix the element name with the outerDocument keyword.

For example, you define one variable named localVar in the scope of the main application, and another variable with the same name in the scope of the item renderer. From within the item renderer, you access the application's localVar by prefixing it with outerDocument keyword, as the following example shows:

    <?xml version="1.0"?>
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">

      <mx:Script>
        <![CDATA[

          // Variable in the Application scope.
          public var localVar:String="Application localVar";

          // Data includes URL to album cover.
          private var initDG:Array = [
            { Artist:'Pavement', Album:'Slanted and Enchanted', Price:11.99,
              Cover:'http://localhost:8100/f15/slanted.jpg'},
            { Artist:'Pavement', Album:'Brighten the Corners', Price:11.99,
              Cover:'http://localhost:8100/f15/brighten.jpg'}
          ];
        ]]>
      </mx:Script>

      <mx:DataGrid id="myGrid" dataProvider="{initDG}"
          variableRowHeight="true">
        <mx:columns>
          <mx:DataGridColumn dataField="Artist"/>
          <mx:DataGridColumn dataField="Album"/>
          <mx:DataGridColumn dataField="Cover">
            <mx:itemRenderer>
              <mx:Component>
                <mx:VBox>
                  <mx:Script>
                    <![CDATA[
                      // Variable in the renderer scope.
                      public var localVar:String="Renderer localVar";
                    ]]>
                  </mx:Script>

                  <mx:Text id="albumName" width="100%" selectable="false" text="{data.Album}"/>
                  <mx:Image id="albumImage" height="45" source="{data.Cover}"/>
                  <mx:TextArea text="{'Renderer localVar= ' + localVar}"/>
                  <mx:TextArea text="{'App localVar= ' + outerDocument.localVar}"/>
                </mx:VBox>
              </mx:Component>
            </mx:itemRenderer>
          </mx:DataGridColumn>
          <mx:DataGridColumn dataField="Price"/>
        </mx:columns>
      </mx:DataGrid>
    </mx:Application>

One use of the outerDocument keyword is to initialize the data provider of a control within the inline item editor. For example, you can use a web service, or other mechanism, to pass data into the application, such as the list of U.S. states. You can then initialize all ComboBox controls that are used as item editors from a single property of the application that contains the list of U.S. states.

MXML Syntax

The <mx:Component> tag has the following syntax:

      <mx:Component
        id=""
        className=""
      >
          ...
          child tags
          ...
      </mx:Component>

You cannot create an empty <mx:Component></mx:Component> tag; you must define at least one child tag within the <mx:Component></mx:Component> tags.

The id property lets you specify an identifier for the inline component so that you can use it as the source for a data binding expression.

The className property lets you specify the name of the class generated by Flex for the inline component so that you can reference the elements of the component in ActionScript. For more information, see the Using Item Renderers and Item Editors chapter in the Developing Flex Applications book.

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Metadata (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Metadata

Metadata

<mx:Metadata> tag implemented by the compiler

You use the <mx:Metadata> tag to insert metadata tags in an MXML file. Metadata tags provide information to the Flex compiler that describes how your MXML components are used in a Flex application. Metadata tags do not get compiled into executable code, but provide information to control how portions of your code get compiled.

Note that you can only insert metadata tags in the <mx:Metadata> block; you cannot insert MXML or ActionScript code.

For example, you may create an MXML component that defines a new event. To make that event known to the Flex compiler so that you can reference it in MXML, you insert the [Event] metadata tag into your component, as the following example shows:

<mx:Metadata>
  [Event("darken")]
</mx:Metadata>

In this example, you use metadata to make the darken event available to the MXML compiler. Metadata tags include [Event], [Effect], [Style], [Inspectable], and others. For more information, see the Using Metadata Tags chapter in the Creating and Extending Flex Components book.

When using metadata tags in ActionScrip class files, you insert the metadata tag directly into the class definition; you do not use the <mx:Metadata> tag.

In an MXML file, you insert the metadata tags either in an <mx:Script> block along with your ActionScript code, or in an <mx:Metadata> block, as the following example shows:

<?xml version="1.0"?>
<mx:TextArea xmlns:mx="http://www.adobe.com/2006/mxml">

  <mx:Metadata>
    [Event("enableChange")]
  </mx:Metadata>

  <mx:Script>
    <![CDATA[

      // Import Event class.
      import flash.events.Event;

      // Define class properties/methods
      private var _enableTA:Boolean;

      // Add the [Inspectable] metadata tag before the individual property.
      [Inspectable(defaultValue="false")]
      public function set enableTA(val:Boolean):void {
        _enableTA = val;
        this.enabled = val;

        // Define event object, initialize it, then dispatch it.
        var eventObj:Event = new Event("enableChange");
        dispatchEvent(eventObj);
      }
    ]]>
  </mx:Script>
</mx:TextArea>

MXML Syntax

The <mx:Metadata> tag has the following syntax:

  <mx:Metadata>
    <!-- Metadata tags go here. -->
  </mx:Metadata>

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Model (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Model

<mx:Model> tag implemented by the compiler

You use the <mx:Model> tag to declare a data model in MXML. An <mx:Model> tag is compiled into a tree of ActionScript objects; the leaves of the tree are scalar values.

MXML Syntax

You can place an <mx:Model> tag in a Flex application file, or in an MXML component file. The tag must have an id value. It cannot be the root tag of an MXML component. The <mx:Model> tag has the following syntax:

 <mx:Model id="modelID">
   model declaration
 </mx:Model>

or:

 <mx:Model id="modelID" source="fileName" />

where source specifies an external source, such as a file, for the data model. The external source can contain static data and data binding expressions. The file referenced in a source property resides on the server and not on the client machine. The compiler reads the source value and compiles the source into the application; the source value is not read at runtime.

The model declaration, either in-line in the tag or in the source file, must have a single root node that contains all other nodes. You can use MXML binding expressions, such as {myForm.lastName.text} in the model declaration. This way you can bind the contents of form fields to a structured data representation.

In the following example, the myEmployee model is placed in an MXML application file:

    <?xml version="1.0"?>
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml">
    ...
      <mx:Model id="MyEmployee">
        <root>
            <name>
               <first>Will</first>
               <last>Tuckerman</last>
            </name>
            <department>Accounting</department>
            <email>wtuckerman@wilsoncompany.com</email>
        </root>
      </mx:Model>
    ...
    </mx:Application>

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Script (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Script

<mx:Script> tag implemented by the compiler

You use the <mx:Script> tag to define blocks of ActionScript code. ActionScript blocks can contain variable and function definitions. You can place blocks of ActionScript code in the body of the tag, or you can include an external file by specifying the source with the source property of the tag, as shown below:

<mx:Script source="file_name.as" />

The script within an <mx:Script> tag is accessible from any component in the MXML file. The <mx:Script> tag must be located at the top level of the MXML file, within the Application or other top level component tag. You can define multiple script blocks in your MXML files, but you should try to keep them in one location to improve readability.

MXML Syntax

When using a script block in the body of the tag, you must wrap the contents in a CDATA construct. This prevents the compiler from interpreting the contents of the script block as XML, and allows ActionScript to be properly generated. As a result, it is a good practice to write all your <mx:Script> and </mx:Script> tags as follows:

 <mx:Script
   <![CDATA[
       //ActionScript statements
   ]]>
 </mx:Script>

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Style (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Style

<mx:Style> tag implemented by the compiler

You use the <mx:Style> tag to define styles that apply to the current document and its children. You define styles in the <mx:Style> tag using CSS syntax and can define styles that apply to all instances of a control or to individual controls.

If you reference a file by using the source property, that file must reside on the server and not on the client machine. The compiler reads the source value and compiles the source into the application at compile-time; the source value is not read at runtime.

MXML Syntax

The <mx:Style> tag has the following syntax:

<mx:Style [source="style_sheet"]>
  [selector_name {
    style_property: value;
    [...]
  }]
</mx:Style>

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


XML (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
XML

<mx:XML> tag implemented by the compiler

The <mx:XML> tag is a compile-time tag that generates an XML object or XMLNode object from a text model. The tag has the following features that are not provided directly by the Flash classes:

  • You can specify a file as the source of the XML text model.
  • You can use MXML binding expressions in the XML text to extract node contents from variable data; for example, you could bind a node's name attribute to a text input value, as in the following line:
       <child name="{textInput1.text}"/>
  • You can use the format="xml" attribute to generate a legacy XMLNode object instead of an E4X-format XML object.

MXML Syntax

You can place an <mx:XML> tag in a Flex application file or in an MXML component file. The <mx:XML> tag must have an id attribute value to be referenced by another component. The <mx:XML> tag does not need an id attribute value if the tag is a direct child of an <mx:dataProvider> tag. The tag body must have a single root node containing all child nodes. The <mx:XML> tag cannot be the root tag of an MXML component. You cannot specify Flash XML or XMLNode class properties in the tag; you must specify these in ActionScript.

The <mx:XML> tag has the following syntax:

    <mx:XML
       id="modelID"
       format="e4x|xml">
          <root>
             child nodes
          </root>
    </mx:XML>

or:

    <mx:XML
       id="modelID"
       format="e4x|xml"
       source="fileName"
       />

The default format property value of e4x creates an XML object, which implements the XML-handling standards defined in the ECMA-357 specification (known as "E4X"). For backward compatibility, you can set the format property to xml to generate an object of the type flash.xml.XMLNode.

The source property specifies an external source, such as a file, for the data model. The external source can contain static data and data binding expressions. The compiler reads the source value and compiles the source into the application; the source value is not read at runtime.

The following example uses the tag to define a model for a MenuBar control:

    <?xml version="1.0"?>
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" backgroundColor="#FFFFFF">

        <mx:XML format="e4x" id="myMenuModel">
            <root label="Menu">
            <menuitem label="MenuItem A">
                <menuitem label="SubMenuItem 1-A"/>
                <menuitem label="SubMenuItem 2-A" />
            </menuitem>
            <menuitem label="MenuItem B"/>
            <menuitem label="MenuItem C" type="check"/>
            <menuitem type="separator"/>
            <menuitem label="MenuItem D">
                <menuitem label="SubMenuItem 1-D" type="radio" groupName="one"/>
                <menuitem label="SubMenuItem 2-D" type="radio" groupName="one"/>
                <menuitem label="SubMenuItem 3-D" type="radio" groupName="one"/>
            </menuitem>
            </root>
        </mx:XML>

        <mx:MenuBar id="myMenu" labelField="@label" showRoot="true">
            <mx:dataProvider>
                {myMenuModel}
            </mx:dataProvider>
        </mx:MenuBar>

    </mx:Application>

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


XMLList (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
XMLList

<mx:XMLList> tag implemented by the compiler

The <mx:XMLList> tag is a compile-time tag that generates an XMLList object from a text model that consists of valid XML nodes.

Unlike the XMLList class in ActionScript, this tag lets you use MXML binding expressions in the XML text to extract node contents from variable data. For example, you can bind a node's name attribute to a text input value, as in the following line:

<child name="{textInput1.text}"/>

MXML Syntax

You can place an <mx:XMLList> tag in a Flex application file or in an MXML component file. The <mx:XMLList> tag must have an id attribute value to be referenced by another component. The <mx:XMLList> tag does not need an id attribute value if the tag is a direct child of an <mx:dataProvider> tag. The <mx:XMLList> tag cannot be the root tag of an MXML component.

The <mx:XML> tag has the following syntax:

    <mx:XMLList
       id="list ID">
          model declaration
    </mx:XMLList>

The following example uses the tag to define a model for MenuBar control:

    <?xml version="1.0"?>
    <mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" backgroundColor="#FFFFFF">

        <mx:XMLList id="myMenuModel">
            <menuitem label="MenuItem A" >
                <menuitem label="SubMenuItem 1-A" />
                <menuitem label="SubMenuItem 2-A" />
            </menuitem>
            <menuitem label="MenuItem B" />
            <menuitem label="MenuItem C" type="check" />
            <menuitem type="separator" />
            <menuitem label="MenuItem D" >
                <menuitem label="SubMenuItem 1-D" type="radio" groupName="one" />
                <menuitem label="SubMenuItem 2-D" type="radio" groupName="one" />
                <menuitem label="SubMenuItem 3-D" type="radio" groupName="one" />
            </menuitem>
        </mx:XMLList>

        <mx:MenuBar id="myMenu" labelField="@label" showRoot="true">
            <mx:dataProvider>
                {myMenuModel}
            </mx:dataProvider>
        </mx:MenuBar>

    </mx:Application>

© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Compiler Errors (Flex™ 2 Language Reference)

Compiler Errors | Compiler Warnings | Run-Time Errors

The following is a list of compilation errors that the compiler generates when it encounters invalid code. A subset of these errors is detected only when compiling code in strict mode. Strict mode adds three constraints not found in the standard language:

  • Expressions have static types and type errors are verification errors.
  • Additional verification rules catch common programming errors.
  • Verification errors are reported ahead of time. These are the verification errors that occur only in strict mode:
    • Function call signature matching, which checks the number of parameters supplied and their types.
    • Duplicate definition conflicts.
    • Unbound references, which occur when accessing methods or properties that are not defined at compile time.
    • Dynamically adding properties on sealed objects.
    • Writing to constant variables.
    • Deleting fixed properties.
    • Comparison expressions that use incompatible types.
    • Unfound packages.

See also

Compiler Warnings
Run-Time Errors

Code | Message | Description
1000 Ambiguous reference to _. A reference might be to more than one item. For example, the following uses the namespaces rss and xml, each of which defines a different value for the hello() function. The trace (hello()) statement returns this error because it cannot determine which namespace to use.
private namespace rss;
private namespace xml;

public function ErrorExamples() {
      use namespace rss;
       use namespace xml;
    trace(hello());
}

rss function hello():String {
          return "hola";
    }

    xml function hello():String {
        return "foo";
    }

Correct an ambiguous reference by making the reference specific. The following example uses the form namespace::function to specify which namespace to use:

public function ErrorExamples() {

    trace(rss::hello());
    trace(xml::hello());
}
1003 | Access specifiers are not allowed with namespace attributes. | You can not use both an access specifier (such as private or public) and a namespace attribute on a definition.
1004 | Namespace was not found or is not a compile-time constant. | The namespace is either unknown or is an expression that could have different values at run time. Check that you are spelling the namespace correctly and that its definition is imported correctly.
1006 | A super expression can be used only inside class instance methods.
1007 | A super statement can be used only inside class instance constructors. | You cannot use the super statement within static members. You can use the super statement only within class instances.
1008 | Attribute is invalid.
1010 | The override attribute may be used only on class property definitions. | You cannot use the override keyword within a function block.
1011 | The virtual attribute may be used only on class property definitions. | You cannot use the virtual attribute when you declare a property that does not belong to a class (for example, when you declare a variable within a function block).
1012 | The static attribute may be used only on definitions inside a class.
1013 | The private attribute may be used only on class property definitions.
1014 | The intrinsic attribute is no longer supported. | ActionScript 3.0 does not support the intrinsic keyword.
1016 | Base class is final. | The superclass cannot be extended because it is marked as final.
1017 | The definition of base class _ was not found.
1018 | Duplicate class definition: _.
1020 | Method marked override must override another method.
1021 | Duplicate function definition. | You cannot declare more than one function with the same identifier name within the same scope.
1022 | Cannot override a final accessor.
1023 | Incompatible override. | A function marked override must exactly match the parameter and return type declaration of the function it is overriding. It must have the same number of parameters, each of the same type, and declare the same return type. If any of the parameters are optional, that must match as well. Both functions must use the same access specifier (public, private, and so on) or namespace attribute as well.
1024 Overriding a function that is not marked for override. If a method in a class overrides a method in a base class, you must explicitly declare it by using the override attribute, as this example shows:
public override function foo():void{};
1025 | Cannot redefine a final method. | The method cannot be extended because it is marked as final in the base class.
1026 | Constructor functions must be instance methods.
1027 | Functions cannot be both static and override.
1028 | Functions cannot be both static and virtual.
1029 | Functions cannot be both final and virtual.
1030 | Must specify name of variable arguments array. | The ...(rest) parameter definition specifies that all values supplied after ...(rest) are collected into any array. You must specify a name for the array, as in the expression function foo(x,...(rest)).
1033 | Virtual variables are not supported.
1034 | Variables cannot be native.
1035 | Variables cannot be both final and virtual.
1037 | Packages cannot be nested.
1038 | Target of break statement was not found.
1039 | Target of continue statement was not found.
1040 | Duplicate label definition.
1041 | Attributes are not callable.
1042 | The this keyword can not be used in static methods. It can only be used in instance methods, function closures, and global code. | You cannot use the this keyword within a static member, because this would have no context.
1043 | Undefined namespace.
1044 | Interface method _ in namespace _ not implemented by class _.
1045 | Interface _ was not found.
1046 Type was not found or was not a compile-time constant: _. The class used as a type declaration is either unknown or is an expression that could have different values at run time. Check that you are importing the correct class and that its package location has not changed. Also, check that the package that contains the code (not the imported class) is defined correctly (for example, make sure to use proper ActionScript 3.0 package syntax, and not ActionScript 2.0 syntax).

The error can also occur if the class being referenced is not defined in a namespace that is in use or is not defined as public:

public class Foo{}

If you are using Flex™ Builder™ 2 and the class is in a library, make sure to set the class path for the project.
1047 | Parameter initializer unknown or is not a compile-time constant. | The value used as the default value for the parameter is either undefined or could have different values at run time. Check that the initializer is spelled correctly, and that the initializer value isn't an expression that could result in different possible values at run time.
1048 Method cannot be used as a constructor. It is not possible to create an instance of a method of a class. Only global functions can be used in new expressions.
class D { function xx() { return 22; } }
var d:D = new D();
var x = new d.xx(); // error, method cannot be used as constructor
function yy() { this.a = 22; }
var z = new yy(); // no error, global functions can be used as constructors.
1049 | Illegal assignment to a variable specified as constant.
1050 | Cannot assign to a non-reference value.
1051 | Return value must be undefined. | You are attempting to use the return statement within a method that has a declared return type void.
1052 | Constant initializer unknown or is not a compile-time constant. | The value used to initialize the constant is either undefined or could have different values at run time. Check that the initializer is spelled correctly, and that the initializer value isn't an expression that could result in different possible values at run time.
1053 | Accessor types must match.
1054 Return type of a setter definition must be unspecified or void. You cannot specify a return value for a setter function. For example, the following is invalid:
public function set gamma(g:Number):Number;

The following is valid:

public function set gamma(g:Number):void;
1058 | Property is write-only.
1059 Property is read-only. This property is defined through a getter function, which allows you to retrieve that property's value. There is no setter function defined for this property, however, so it is read-only.

In the following example, line 3 generates an error because there is no setter function defined for xx:

class D { function get xx() { return 22; } }
var d:D = new D();
d.xx = 44; // error, property is read-only
1061 | Call to a possibly undefined method _ through a reference with static type _. | You are calling a method that is not defined.
1063 | Unable to open file: _.
1064 | Invalid metadata. | This metadata is unrecognized.
1065 | Metadata attributes cannot have more than one element.
1067 | Implicit coercion of a value of type _ to an unrelated type _. | You are attempting to cast an object to a type to which it cannot be converted. This can happen if the class you are casting to is not in the inheritance chain of the object being cast. This error appears only when the compiler is running in strict mode.
1068 | Unable to open included file: _.
1069 | Syntax error: definition or directive expected. | Check the syntax in the line.
1071 Syntax error: expected a definition keyword (such as function) after attribute _, not _. This error will occur if the author forgets to use the "var" or "function" keyword in a declaration.
public int z;// should be 'public var z:int;'
This error might also occur when the compiler encounters an unexpected character. For example, the following use of the trace() function is invalid, because of the missing parentheses (the correct syntax is trace("hello")):
import flash.utils.trace;
trace "hello"
1072 | Syntax error: expecting xml before namespace. | The correct statement syntax is default xml namespace = ns. Either the keyword xml (note the lowercase) is missing or an incorrect keyword was used. For more information, see the default xml namespace directive.
1073 | Syntax error: expecting a catch or a finally clause.
1075 | Syntax error: the 'each' keyword is not allowed without an 'in' operator.
1076 | Syntax error: expecting left parenthesis before the identifier.
1077 Expecting CaseLabel. The compiler expected a case statement at this point in the switch block. The following switch block incorrectly includes a call to print before the first case statement:
switch(x)
{
trace(2);
case 0:  trace(0);
break
}
1078 | Label must be a simple identifier.
1079 | A super expression must have one operand.
1080 | Expecting increment or decrement operator.
1082 | Expecting a single expression within parentheses.
1083 Syntax error: _ is unexpected. The line of code is missing some information. In the following example, some expression (such as another number) needs to be included after the final plus sign:
var sum:int = 1 + 2 + ;
1084 Syntax error: expecting _ before _. The expression was unexpected at this point. If the error says "Expecting right brace before end of program," a block of code is missing a closing brace (}).

If the error says "Expecting left parenthesis before _," you may have omitted a parenthesis from a conditional expression, as shown in the following example, which is intentionally incorrect:

var fact:int = 1 * 2 * 3;
if fact > 2 {
    var bigger:Boolean = true;
}
1086 | Syntax error: expecting semicolon before _.
1087 | Syntax error: extra characters found after end of program.
1093 | Syntax error.
1094 | Syntax error: A string literal must be terminated before the line break.
1095 | Syntax error: A string literal must be terminated before the line break.
1097 | Syntax error: input ended before reaching the closing quotation mark for a string literal.
1099 | Syntax error.
1100 | Syntax error: XML does not have matching begin and end tags.
1102 | Cannot delete super descendants.
1103 | Duplicate namespace definition. | You defined the namespace more than once. Delete or modify the duplicate definition.
1105 | Target of assignment must be a reference value. | You can assign a value to a variable, but you cannot assign a value to another value.
1106 | Operand of increment must be a reference. | The operand must be a variable, an element in an array, or a property of an object.
1107 | Increment operand is invalid. | The operand must be a variable, an element in an array, or a property of an object.
1108 | Decrement operand is invalid. | The operand must be a variable, an element in an array, or a property of an object.
1109 Expecting an expression. An expression is missing in a part of the code. For example, the following produces this error (there is a condition missing from the if statement:
var x = (5>2) ?
trace(x)
1110 | Missing XML tag name.
1112 Possible infinite recursion due to this file include: _. A file that is included in the source being compiled contains other include statements that would cause an infinite loop. For example, the following files. a.as and b.as, generate this error because each file tries to include the other.

File a.as contains the following, which attempts to include the file b.as:

import foo.bar.baz;
include "b.as"
trace(2);

File b.as contains the following, which attempts to include the file a.as:

include "a.as"
1113 Circular type reference was detected in _. A class is trying to extend a superclass. For example, class A cannot extend class B if B inherits from A:
class a extends b { }
class b extends a { }
1114 | The public attribute can only be used inside a package.
1115 | The internal attribute can only be used inside a package.
1116 | A user-defined namespace attribute can only be used at the top level of a class definition.
1118 Implicit coercion of a value with static type _ to a possibly unrelated type _. You are using a value that is not of the expected type and no implicit coercion exists to convert it to the expected type.

Perhaps you are using a supertype where a subtype is expected. For example:

class A {}
var a:A = new A();
class B extends A { function f() }
var b : B = a // error

The last statement generates an error because it attempts to assign an object of type A to a variable of type B.

Similarly, the following defines the foo() function, which takes a parameter of type B. The statement foo(a); generates an error because it attempts to use a parameter of type A:

function foo(x:B) { }
foo(a);

Also, the following statement generates an error because the returned value for foo2() must be type B:

function foo2():B { return new A(); }
1119 Access of possibly undefined property _ through a reference with static type _. You are attempting to access a property that does not exist for the specified object. For example, the following code generates this error because an int object does not have a property named assortment:
var i:int = 44;
var str:String = i.assortment;
This error appears only when the compiler is running in strict mode.
1120 Access of undefined property _. You are attempting to access an undefined variable. For example, if the variable huh has not been defined, a call to it generates this error:
huh = 55;
This error can appear only when the compiler is running in strict mode.
1121 | A getter definition must have no parameters.
1122 | A setter definition must have exactly one parameter.
1123 | A setter definition cannot have optional parameters.
1124 | Return type of a getter definition must not be void. | A getter function simulates a variable. Because variables cannot be of type void, you cannot declare getter functions to return type void.
1125 | Methods defined in an interface must not have a body.
1126 | Function does not have a body.
1127 | Attribute _ was specified multiple times. | You specified an attribute more than once in the same statement. For example, the statement public static public var x; generates this error because it specifies that the variable x is public twice. Delete duplicate declarations.
1129 | Duplicate interface definition: _. | Change or delete the duplicate definitions.
1130 | A constructor cannot specify a return type.
1131 | Classes must not be nested.
1132 | The attribute final can only be used on a method defined in a class.
1133 | The native attribute can only be used with function definitions.
1134 | The dynamic attribute can only be used with class definitions.
1135 | Syntax error: _ as not a valid type.
1136 Incorrect number of arguments. Expected _. The function expects a different number of arguments than those you provided. For example, the following defines function goo, which has two arguments:
class A { static function goo(x:int,y:int)
{ return(x+y); } }

The following statement would generate an error because it provides three arguments:

A.goo(1,2,3);
1137 | Incorrect number of arguments. Expected no more than _.
1138 | Required parameters are not permitted after optional parameters.
1139 | Variable declarations are not permitted in interfaces.
1140 | Parameters specified after the ...rest parameter definition keyword can only be an Array data type.
1141 | A class can only extend another class, not an interface.
1142 | An interface can only extend other interfaces, but _ is a class. | You are attempting to have the interface extend a class. An interface can only extend another interface.
1143 | The override attribute can only be used on a method defined in a class.
1144 | Interface method _ in namespace _ is implemented with an incompatible signature in class _. | Method signatures must match exactly.
1145 | Native methods cannot have a body. | You cannot use native because it is a reserved keyword.
1146 | A constructor cannot be a getter or setter method.
1147 | An AS source file was not specified.
1149 | The return statement cannot be used in static initialization code.
1150 | The protected attribute can only be used on class property definitions.
1151 A conflict exists with definition _ in namespace _. You cannot declare more than one variable with the same identifier name within the same scope unless all such variables are declared to be of the same type. In ActionScript 3.0, different code blocks (such as those used in two for loops in the same function definition) are considered to be in the same scope.

The following code example correctly casts the variable x as the same type:

function test()
{
    var x:int = 3;
    for(var x:int = 33; x < 55; x++)
    trace(x);
    for(var x:int = 11; x < 33; x++)
    trace(x)
}

The following code example generates an error because the type casting in the variable declaration and the for loops are different:

function test()
{
    var x:String = "The answer is";
    for(var x:int = 33; x < 55; x++) // error
    trace(x);
    for(var x:unit = 11; x < 33; x++) // error
    trace(x)
}
1152 | A conflict exists with inherited definition _ in namespace _.
1153 | A constructor can only be declared public.
1154 | Only one of public, private, protected, or internal can be specified on a definition.
1155 | Accessors cannot be nested inside other functions.
1156 | Interfaces cannot be instantiated with the new operator.
1157 | Interface members cannot be declared public, private, protected, or internal.
1158 | Syntax error: missing left brace ({) before the function body.
1159 | The return statement cannot be used in package initialization code.
1160 | The native attribute cannot be used in interface definitions. | You cannot use native because it is a reserved keyword.
1162 | Only one namespace attribute can be used per definition.
1163 | Method _ conflicts with definition inherited from interface _.
1165 | Interface attribute _ is invalid.
1166 | Namespace declarations are not permitted in interfaces.
1167 Class _ implements interface _ multiple times. The class implements the same interface more than once. For example, the following generates this error because class C implements interface A twice:
interface A {  public function f();  };
class C implements A,A {
public function f() { trace("f"); }
}

The correct implementing statement should be class C implements A {.

1168 Illegal assignment to function _. You are attempting to redefine a function. For example, the following defines the function topLevel() to print the word "top". The second statement generates an error because it assigns a different return value to the function:
function topLevel() { trace("top"); }
topLevel = function() { trace("replacement works in ~");} // error
1169 | Namespace attributes are not permitted on interface methods.
1170 Function does not return a value. Every possible control flow in a function must return a value whenever the return type is something other than void. The following function f(x) does not generate an error because the if..else statement always returns a value:
function f(x):int
{
if (x)
        return 2;
else
        return 3;
} // no error

However, the function g(x) below generates the error because the switch statement does not always return a value.

function g(x:int):int
{
switch(x)
{
          case 1: return 1;
          case 2: return 2:
}
// return 2;//uncomment to remove the error
}

This checking is enabled only when the function declares a return type other than void.

1171 | A namespace initializer must be either a literal string or another namespace.
1172 | Definition _ could not be found.
1173 | Label definition is invalid.
1176 | Comparison between a value with static type _ and a possibly unrelated type _. | This error is enabled in strict mode.
1177 | The return statement cannot be used in global initialization code.
1178 | Attempted access of inaccessible property _ through a reference with static type _.
1180 | Call to a possibly undefined method _. | This error appears only when the compiler is running in strict mode.
1181 | Forward reference to base class _.
1182 | Package cannot be used as a value: _.
1184 | Incompatible default value of type _ where _ is expected.
1185 | The switch has more than one default, but only one default is allowed.
1188 | Illegal assignment to class _.
1189 | Attempt to delete the fixed property _. Only dynamically defined properties can be deleted. | Delete removes dynamically defined properties from an object. Declared properties of a class can not be deleted. This error appears only when the compiler is running in strict mode.
1190 | Base class was not found or is not a compile-time constant.
1191 | Interface was not found or is not a compile-time constant.
1192 | The static attribute is not allowed on namespace definitions.
1193 | Interface definitions must not be nested within class or other interface definitions.
1194 | The prototype attribute is invalid.
1195 | Attempted access of inaccessible method _ through a reference with static type _. | You are either calling a private method from another class, or calling a method defined in a namespace that is not in use. If you are calling a method defined in an unused namespace, add a use statement for the required namespace.
1196 | Syntax error: expecting an expression after the throw.
1197 | The class _ cannot extend _ since both are associated with library symbols or the main timeline.
1198 | Attributes are not allowed on package definition.
1199 | Internal error: _.
1200 | Syntax error: invalid for-in initializer, only 1 expression expected.
1201 | A super statement cannot occur after a this, super, return, or throw statement.
1202 Access of undefined property _ in package _. You are attempting to access an undefined variable in a package. For example, if the variable p.huh has not been defined, a call to it generates this error:
p.huh = 55;
This error can only appear when the compiler is running in strict mode.


Compiler Warnings (Flex™ 2 Language Reference)

View comments | RSS feed
Compiler Warnings | Compiler Errors | Run-Time Errors

Compiler warning messages identify code that is valid and compiles successfully, but may not be what the author intended. To enable detecting these possible problems, compile ActionScript projects in warning mode.

Some of these warnings (for example, "Missing type declaration.") are coding style choices that you have the option whether to enforce. Others (for example, "Impossible assignment to null.") point out statements that are valid, but are unlikely to behave as the user expects. A third class of warnings covers issues you may encounter when porting ActionScript 2.0 code to ActionScript 3.0.

See also

Compiler Errors
Run-Time Errors

Code | Message | Description
1009 | _ '_' has no type declaration. | Not declaring a data type is a coding style preference. A function return type, parameter, or variable has no type declaration. However, using type declarations enables the compiler to write more efficient code, as well as detect more errors at compile time. Enable this warning if you want to be reminded when you fail to use a type declaration.
1013 | Variables of type _ cannot be undefined. The value undefined will be type coerced to _ before comparison. | Only variables of type * can be undefined. With a few exceptions, uninitialized variables have a default value of null rather than undefined. The exceptions include: Boolean variables, which have a default value of false. Number variables, which have a default value of NaN, and int or uint variables, which have a default value of 0.
1031 Migration issue: Result of new _ will be the return value of _, rather than a new instance of that function. This is a code migration warning. The detected code behaves differently in ActionScript 3.0 than in ActionScript 2.0, as shown in the following example:
function f(){
   this.b = 22;
   this.a = new Array(2);
   this.a[0] = 33;
   this.a[1] = 44;
   return a;
   }
   // returns a new instance of f in ActionScript 2.0 and a new 2 element array in ActionScript 3.0
   var d = new f();  // Warning here
   trace(d.a);       // undefined in ActionScript 3.0, [33,44] in ActionScript 2.0.
1035 | Use of Boolean() with no arguments. | This is a code migration warning. The Boolean() function returns false in ActionScript 3.0, but undefined in ActionScript 2.0.
1039 | Migration issue: When the Number('') function is called with an empty string argument it returns 0 in ActionScript 3.0, and NaN in ActionScript 2.0. | This is a code migration warning. The Number() method called with a String argument skips over all white space in the string and return a default value of 0 if no digits are detected. In ActionScript 2.0, any white space in the string causes the result to be NaN.
1045 | Migration issue: Array.toString() handling of null and undefined elements has changed. | This is a code migration warning. In ActionScript 2.0, null array elements convert to null and undefined elements convert to undefined. In ActionScript 3.0, both null and undefined elements convert to the empty string ''. If you have code that parses the toString() output from an Array, you may need to adjust your code for this difference.
1059 | Migration issue: The property _ is no longer supported. _. | This is a code migration warning. The property you are attempting to use does not exist in ActionScript 3.0.
1061 | Migration issue: The method _ is no longer supported. _. | This is a code migration warning. The method you are attempting to use does not exist in ActionScript 3.0.
1066 | __resolve is no longer supported.
1067 | Migration issue: __resolve is no longer supported. Use the new Proxy class for similar functionality. | This is a code migration warning. See Proxy in this language reference for more information on the replacement for __resolve.
1071 | Migration issue: _level is no longer supported. For more information, see the flash.display package. | This is a code migration warning. The property you are attempting to use does not exist in ActionScript 3.0.
1073 | Migration issue: _ is not a dynamic class. Instances cannot have members added to them dynamically. | This is a code migration warning. In ActionScript 2.0, many classes such as Number are dynamic, which means that new properties can be added to instances of those classes at run time. This warning results from code that tries to add a property to an instance of a non-dynamic class.
1083 Migration issue: Method _ will behave differently in ActionScript 3.0 due to the change in scoping for the this keyword. See the entry for warning 1083 for additional information. This is a code migration warning. This warning is generated when a method of an object is used as a value, usually as a callback function. In ActionScript 2.0, functions are executed in the context they are called from. In ActionScript 3.0, functions are always executed in the context where they were defined. Thus, variable and method names are resolved to the class that the callback is part of, rather than relative to the context it is called from, as in the following example:
class a
{
   var x;
   function a() { x = 1; }
   function b() { trace(x); }
}

var A:a = new a();
var f:Function = a.b; // warning triggered here
var x = 22;
f(); // prints 1 in ActionScript 3.0, 22 in ActionScript 2.0
1085 | _ will be scoped to the default namespace: _ internal. It will not be visible outside of this package. | Not declaring a namespace is a coding style preference. Enable this warning if you want to be reminded when you forget to declare a namespace or access specifier for a definition. Without one, the definition is not visible to code located outside of this file. To make it visible to code outside this file, declare it with the access specifier public or with a namespace declaration. To keep the definition local to this file and avoid this warning, declare the definition as private.
1087 | Migration issue: ActionScript 3.0 iterates over an object's properties within a "for x in target" statement in random order. | This is a code migration warning. In ActionScript 2.0, the order in which the properties of an object were processed was always the same. In ActionScript 3.0, the order is random and can change from machine to machine. If unexpected ordering behavior occurs, inspect this loop to determine if this change in behavior may affect your code.
1089 | Error code: _. | This is due to either a corrupt source file or a bug in the compiler code. Please contact Adobe, Inc. to file a bug.
1091 | Migration issue: _ | This is a code migration warning. In ActionScript 2.0 declaring a method by a special name (such as onMouseDown) would cause Flash to call that method when a certain event occurred. In ActionScript 3.0, you must call addEventListener() with a method in order to register it to receive that event. See addEventListener in this language reference for details.
1093 | Negative value used where a uint (non-negative) value is expected. | Assigning a negative value to a uint data type results in an extremely large positive value. var x:uint = -1; trace(x); // 4294967295.
1097 | Illogical comparison with null. Variables of type _ cannot be null. | Instances of Boolean, int, uint, and Number cannot be null. The comparison operator type converts null to false before comparing it to a Boolean, or to 0 before comparing it with a Number, int, or uint data type.
1099 Illogical comparison with NaN. This statement always evaluates to false. NaN has the unique mathematical property that any comparison involving it evaluates to false. Use the global isNaN() function to detect a NaN value instead, as in the following example:
trace(NaN == NaN); // false!
trace(NaN != NaN); // false again!
trace(isNaN(NaN)); // true
1101 Assignment within conditional. Did you mean == instead of =? The result of an = assignment statement is the value of the right-hand side of the = statement. You can use an assignment statement as a conditional test, but it is not recommended. It usually is the result of a typo where a == equality test was intended, as the following example shows:
var x:Boolean = false;
var y:Boolean = true;
// it is hard to determine if the line below intentionally sets x's value to y's or if its a typo
if (x = y) { trace("x is assigned y's value of true, making the conditional test evaluate as true."); }
1103 | null used where a _ value was expected. | Boolean, Number, int, and uint variables cannot be assigned null as a value. The null value is implicitly cast to false when assigned to a Boolean, and to 0 when assigned to an int, uint, or Number.
1105 | No constructor function was specified for class _. | Not specifying a constructor function is a coding style preference. Enable this warning if you want to always declare constructors for classes. This warning is intended to help find cases where a class name is changed but its constructor's name is not. Conditions such as this are not flagged as a problem without this warning, the former constructor appears to be a normal function.
1111 | The constant was not initialized.
1113 | Array(x) behaves the same as new Array(x). To cast a value to type Array use the expression x as Array instead of Array(x).
1115 | The super() statement will be executed prior to entering this constructor. Add a call to super() within the constructor if you want to explicitly control when it is executed. | Adding a call to super() within the constructor is a coding style preference. Enable this warning if you want to always be explicit about when super() is called. This can help catch cases where you meant to call super() after some local initialization code and forgot to add it.
3552 | Appending text to a TextField using += is many times slower than using the TextField.appendText() method. | See this language reference for the appendText() method of the TextField class for details on this significant text optimization.
3554 | Function value used where type _ was expected. Possibly the parentheses () are missing after this function reference. | You can use functions themselves as values in ActionScript. The code in question is using a value of type Function where a type other than Function, Object, or * is expected. Usually, this indicates a typo where the parentheses () were omitted after the function name.
3556 | The instanceof operator is deprecated, use the is operator instead.
3574 | Migration issue: The ActionScript 2.0 XML class has been renamed XMLDocument. | This is a code migration warning. XML is a different class in ActionScript 3.0 than it was in ActionScript 2.0. In ActionScript 3.0, the XMLDocument class is the equivalent of the XML class in ActionScript 2.0. The ActionScript 3.0 XML class offers improved functionality with an easier and more powerful API. See XML in the ActionScript Language Reference for additional details.
3576 | Date(x) behaves the same as new Date().toString(). To cast a value to type Date use "x as Date" instead of Date(x).
3582 | Importing a package by the same name as the current class will hide that class identifier in this scope.
3584 | More than one argument named '_' specified. References to that argument will always resolve to the last one.
3590 | Non-Boolean value used where a Boolean value was expected.
3591 | _ used where a Boolean value was expected. The expression will be type coerced to Boolean.
3593 | _ is not a recognized property of the dynamic class _. | The strict compilation mode does not check for undefined properties on instances of dynamic classes. The types Date, RegExp, and Error are dynamic for backwards compatibility with ECMAScript. This warning finds usages of undefined properties on instances of those classes. A common problem is attempting to get or set a non-existent year property on a Date value. The correct property name is fullYear.
3595 | _ is not a recognized method of the dynamic class _. | The strict compilation mode does not check for undefined methods on instances of dynamic classes. The types Date, RegExp, and Error are dynamic for backwards compatibility with ECMAScript. This warning finds usages of undefined methods on instances of those classes.
3597 Duplicate variable definition. This declaration is superceded by the declaration _. The compiler has detected a duplicate definition for a variable. This can lead to unexpected results. ActionScript does not support block level scoping of variables. All variables defined within a function body exist within the same scope, even if they are defined within an if statement, while statement, for statement, and so on: for example, the following code redeclares the variable x twice:

function test() {
    var x:Number = 10;
    if (true) {
        for (var x=0; x < 5; x++)  // warning here, this is the second defintion of x
        trace(x);
    }
    trace(x); // 5, not 10.  The last value set by the for loop above is the current value of x
}
3598 | Definition name is the same as an imported package name. Unqualified references to that name will resolve to the package and not the definition.
3599 | Definition name is the same as an imported package name. Unqualified references to that name will resolve to the package and not the definition. | If a definition is named the same as a package that is in scope, then any unqualified references to that name will resolve to the package instead of the definition. This can result in unexpected errors when attempting to reference the variable. Any references to the definition need to be qualified to resolve to the definition and not the package.

The Flex 2 Language Reference chm file is compressed by slobber.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:21 PM GMT-07:00

No screen name said on Jun 30, 2006 at 2:46 PM :
Error 1099 as listed in documentation is actually error 1098 in the compiler.

RSS feed| Send me an e-mail when comments are added to this page | Comment Report

Current page: http://livedocs.macromedia.com/flex/2/langref/compilerWarnings.html


Run-Time Errors (Flex™ 2 Language Reference)

Run-Time Errors | Compiler Errors | Compiler Warnings

The following errors can occur at run time. Run-time type checking occurs in ActionScript 3.0 whether you compile in strict mode or warning mode.

See also

Compiler Errors
Compiler Warnings

Code | Message | Description
1000 | The system is out of memory. | Flash Player needs more memory to compile your code than your system has available. Close some of the applications or processes running on your system.
1001 | The method _ is not implemented.
1002 | The precision argument must be between 0 and 20; _ is invalid. | You specified a value less than 0 or greater than 20 for the precision argument of a method or property. Pass a value between 0 and 20 as a precision argument.
1003 | The radix argument must be between 2 and 36; got _. | You passed a value less than 2 or greater than 36 for the radix argument of a method or property. Pass a value between 2 and 36 as a radix argument.
1004 | Method _ was invoked on an incompatible object. | You tried to call a method that is not available to the specified object. This error occurs when you have copied a prototype function from one object to another, and then invoked it, but the target object is not the same type as the original object. Ensure that the target object and original object are the same type. See the ECMAScript Language Specification, 3rd Edition, Chapter 15 for more details.
1005 | Array index is not a positive integer (_). | You tried to access a member of an array using an index value that is not a positive integer. Pass only positive integers as index values for arrays.
1006 _ is not a function. This error occurs when you attempt to call a function that does not exist. Make sure you are calling the correct function, and that the API has not changed from ActionScript 2.0. Also, make sure you are using the correct object. For example, you will see this error when you use the following code (because the last line mistakenly calls the variable big instead of blg):
var blg:String = "foo";
var big:Sprite = new Sprite();
var error:int = big.length();
1007 | Instantiation attempted on a non-constructor.
1008 | _ is ambiguous; Found more than one matching binding.
1009 Cannot access a property or method of a null object reference. An object that evaluates to null can have no properties. This error can occur in some unexpected (though valid) situations. For example, consider the following code, which creates a Sprite object. Because this Sprite object is never added to the display list (through the addChild() method of a DisplayObjectContainer object), its stage property is set to null. Thus, the example generates this error because Sprite object's stage property cannot have any properties:
import flash.display.Sprite;
var sprite1:Sprite = new Sprite();
var q:String = sprite1.stage.quality;
1010 A term is undefined and has no properties. This error can occur if you try to access a property of an object that does not exist. For example:
var obj:Object = new Object();
obj.a = "foo";
trace(obj.b.prop);

You can also see this error because of a misspelling, for example in the following, where mc represents a MovieClip object in the display list, and the stage property is misspelled with a capital S (it should be stage):

trace(mc.Stage.quality);
1011 | Method _ contained illegal opcode _ at offset _. | See the note at the bottom of this table.*
1012 | The last instruction exceeded code size. | See the note at the bottom of this table.*
1013 | Cannot call OP_findproperty when scopeDepth is 0. | See the note at the bottom of this table.*
1014 | Class _ could not be found.
1015 | Method _ cannot set default xml namespace | See the note at the bottom of this table.*
1016 | Descendants operator (..) not supported on type _.
1017 | Scope stack overflow occurred. | See the note at the bottom of this table.*
1018 | Scope stack underflow occurred. | See the note at the bottom of this table.*
1019 | Getscopeobject _ is out of bounds. | See the note at the bottom of this table.*
1020 | Code cannot fall off the end of a method. | See the note at the bottom of this table.*
1021 | At least one branch target was not on a valid instruction in the method. | See the note at the bottom of this table.*
1022 | Type void may only be used as a function return type. | See the note at the bottom of this table.*
1023 | Stack overflow occurred. | See the note at the bottom of this table.*
1024 | Stack underflow occurred. | See the note at the bottom of this table.*
1025 | An invalid register _ was accessed. | See the note at the bottom of this table.*
1026 | Slot _ exceeds slotCount=_ of _. | See the note at the bottom of this table.*
1027 | Method_info _ exceeds method_count=_. | See the note at the bottom of this table.*
1028 | Disp_id _ exceeds max_disp_id=_ of _. | See the note at the bottom of this table.*
1029 | Disp_id _ is undefined on _. | See the note at the bottom of this table.*
1030 | Stack depth is unbalanced. _ != _. | See the note at the bottom of this table.*
1031 | Scope depth is unbalanced. _ != _. | See the note at the bottom of this table.*
1032 | Cpool index _ is out of range _. | See the note at the bottom of this table.*
1033 | Cpool entry _ is wrong type. | See the note at the bottom of this table.*
1034 | Type Coercion failed: cannot convert _ to _.
1035 | Illegal super expression found in method _. | See the note at the bottom of this table.*
1037 | Cannot assign to a method _ on _. | See the note at the bottom of this table.*
1038 | _ is already defined. | You cannot declare a variable or function with the same identifier name more than once within the same scope. In ActionScript 3.0, different code blocks (such as those used in two for loops in the same function definition) are considered to be in the same scope. See the note at the bottom of this table.*
1039 | Cannot verify method until it is referenced. | See the note at the bottom of this table.*
1040 | The right-hand side of instanceof must be a class or function. | The expression on the right side of the instanceof operator must be a class or function.
1041 | The right-hand side of operator must be a class. | The expression on the right side of the is operator must be a class.
1042 | Not an ABC file. major_version=_ minor_version=_. | You are attempting to use an invalid file with the player: the tool that generates the SWF may be out of date or the SWF itself may be corrupt.
1043 | Invalid code_length=_. | See the note at the bottom of this table.*
1044 | MethodInfo-_ unsupported flags=_. | See the note at the bottom of this table.*
1045 | Unsupported traits kind=_. | See the note at the bottom of this table.*
1046 | MethodInfo-_ referenced before definition. | See the note at the bottom of this table.*
1047 | No entry point was found. | See the note at the bottom of this table.*
1049 | Prototype objects must be vanilla Objects. | See the note at the bottom of this table.*
1050 | Cannot convert _ to primitive. | See the note at the bottom of this table.*
1051 | Illegal early binding access to _. | See the note at the bottom of this table.*
1052 | Invalid URI passed to _ function. | See the note at the bottom of this table.*
1053 | Illegal override of _ in _. | See the note at the bottom of this table.*
1054 | Illegal range or target offsets in exception handler. | See the note at the bottom of this table.*
1056 | Cannot create property _ on _. | You are trying to assign a value to a nonexistent property on an instance of a non-dynamic class. This is only possible for instances of dynamic classes
1057 | _ can only contain methods. | See the note at the bottom of this table.*
1058 | Illegal operand type: _ must be _. | See the note at the bottom of this table.*
1059 | ClassInfo-_ is referenced before definition. | See the note at the bottom of this table.*
1060 | ClassInfo _ exceeds class_count=_. | See the note at the bottom of this table.*
1061 The value _ cannot be converted to _ without losing precision. This error appears if you attempt to assign a decimal number to a property that has data type int.

This error also appears for out-of-range assignments, such as the following:

var m0:int = 2147483648; // int.MAX_VALUE == 2147483647

You can also see this error when using the bitwise left shift operator (<<). For example, consider the following code:

var m0:uint = 0xFF;
var m1:uint = m0<<24;

The result of left shift operator (<<) is interpreted as a 32-bit two's complement number with sign. In the example, the result is a negative value, which causes the error when assigned to the uint typed property. A workaround is the following:

var m0:uint = 0xFF;
var m1:uint = uint(m0<<24);
1063 | Argument count mismatch on _. Expected _, got _.
1064 Cannot call method _ as constructor. Extracted methods are permanently bound to the object they are extracted from. Therefore, they can not later be called as a constructor. For example, the following creates function f() in Class A:
class A {
       function f() {}
    }
In the following code, extracting the function causes no error. However, creating a new instance of the function causes an error.
var a = new A()
    var m = a.f // extract f, don't call it
    m() // same as a.f()
    new m() // causes this error
1065 Variable _ is not defined. You are using an undefined lexical reference. For example, in the following statements, the statement trace(x) generates an error because x is undefined. However, the statement trace(y) doesn't generate an error because y is defined:
trace("hello world")
    trace(x) // x is undefined
    var y
    trace(y) // No error, y is defined.
1066 | The form function('function body') is not supported. | Unlike JavaScript, Flash does not compile code on-the-fly using eval() and function(). Thus, calling these as a constructor in ActionScript 3.0 generates this error.
1067 | Native method _ has illegal method body. | See the note at the bottom of this table.*
1068 | _ and _ cannot be reconciled. | See the note at the bottom of this table.*
1069 Property _ not found on _ and there is no default value. You are referencing an undefined property on a non-dynamic class instance. For example, the following generates this error when it references property x, which is not defined and cannot be created dynamically:
class A {} // sealed class, not dynamic
    trace(new A().x) // no property x defined on A, and A is not dynamic
1070 Method _ not found on _ You are using a super statement to call a function, but the function doesn't exist in the super class. For example, the following code generates the error:
class A() {}
class B extends A {
  function f() { trace(super.f()); } // error 1070, there is no f on A
}
1071 | Function _ has already been bound to _.
1072 | Disp_id 0 is illegal. | See the note at the bottom of this table.*
1073 | Non-override method _ replaced because of duplicate disp_id _. | See the note at the bottom of this table.*
1074 | Illegal write to read-only property _ on _.
1075 | Math is not a function. | You are trying to call math() as a function, but the Math class is a class with static methods.
1076 | Math is not a constructor. | You can not instantiate the Math class.
1077 | Illegal read of write-only property _ on _.
1078 | Illegal opcode/multiname combination: _<_>. | See the note at the bottom of this table.*
1079 | Native methods are not allowed in loaded code. | See the note at the bottom of this table.*
1080 | Illegal value for namespace. | See the note at the bottom of this table.*
1081 | Property _ not found on _ and there is no default value.
1082 | No default namespace has been set. | See the note at the bottom of this table.*
1083 The prefix "_" for element "_" is not bound. An attribute name or element name has a prefix but no matching namespace was found. This statement generates an error because there is no foo namespace to match foo:x:
<foo:x xmlns:clowns='http://circuscenter.org'>
1084 | Element or attribute ("_") does not match QName production: QName::=(NCName':')?NCName. | You have foo: or :foo as an element or attribute name, but there is nothing on the other side of the colon.
1085 | The element type "_" must be terminated by the matching end-tag "</_>".
1086 The _ method only works on lists containing one item. The XMLList class propagates the XML-specific functions to one child if it has only one item in its list. If more than one item is in the list, the routines fail with this error. This happens for the following XMLList functions that mimic XML functions:

addNamespace, appendChild, childIndex, inScopeNamespaces, insertChildAfter, insertChildBefore, name, namespace, localName, namespaceDeclarations, nodeKind, prependChild, removeNamespace, replace, setChildren, setLocalName, setName, and setNamespace.

1087 | Assignment to indexed XML is not allowed.
1088 The markup in the document following the root element must be well-formed. These are possible causes of this error:
  • Parsing an XMLList style object as XML
  • Misbalanced strings
1089 | Assignment to lists with more than one item is not supported.
1090 XML parser failure: element is malformed. An element name is malformed. This example of an element name is malformed because a trailing right angle bracket > is missing:
<a/><b></b
1091 | XML parser failure: Unterminated CDATA section.
1092 | XML parser failure: Unterminated XML declaration.
1093 | XML parser failure: Unterminated DOCTYPE declaration.
1094 | XML parser failure: Unterminated comment.
1095 | XML parser failure: Unterminated attribute.
1096 | XML parser failure: Unterminated element.
1097 | XML parser failure: Unterminated processing instruction.
1098 Illegal prefix _ for no namespace. The namespace constructor throws this error if you try to pass in an empty URI with a non-empty prefix as in this example:
ns = new Namespace ("prefix", "");
1100 Cannot supply flags when constructing one RegExp from another. Creating a new regular expression from an existing one also copies its flags. To create a regular expression with different flags, use the new operator and set the flags as desired. For example, this statement creates a regular expression and specifies flag settings:
var re:RegExp = new RegExp("ali", /s)
Alternatively, this statement creates a regular expression that has the same flags as re:
var re2:RegExp = new RegExp(re, ...)
1101 | Cannot verify method _ with unknown scope. | See the note at the bottom of this table.*
1102 | Illegal default value for type _. | See the note at the bottom of this table.*
1103 | Class _ cannot extend final base class. | See the note at the bottom of this table.*
1104 | Attribute "_" was already specified for element "_".
1107 | The ABC data is corrupt, attempt to read out of bounds. | See the note at the bottom of this table.*
1108 | The OP_newclass opcode was used with the incorrect base class. | See the note at the bottom of this table.*
1109 | Attempt to directly call unbound function _ from method _. | See the note at the bottom of this table.*
1110 | _ cannot extend _. | See the note at the bottom of this table.*
1111 | _ cannot implement _. | See the note at the bottom of this table.*
1112 | Argument count mismatch on class coercion. Expected 1, got _.
1113 | OP_newactivation used in method without NEED_ACTIVATION flag. | See the note at the bottom of this table.*
1114 | OP_getglobalslot or OP_setglobalslot used with no global scope. | See the note at the bottom of this table.*
1115 | _ is not a constructor.
1116 | second argument to Function.prototype.apply must be an array.
1117 | Invalid XML name: _.
1118 | Illegal cyclical loop between nodes.
1119 | Delete operator is not supported with operand of type _.
1120 | Cannot delete property _ on _.
1121 | Method _ has a duplicate method body.
1122 | Interface method _ has illegal method body.
1123 | Filter operator not supported on type _.
1124 | OP_hasnext2 requires object and index to be distinct registers.
1502 | A script has executed for longer than the default timeout period of 15 seconds. | A script executed after the timeout period. (The default timeout period is 15 seconds.) After this error occurs, the script can continue to execute for 15 seconds more, after which the script terminates and throws run-time error number 1503 (A script failed to exit after 30 seconds and was terminated.)
1503 | A script failed to exit after 30 seconds and was terminated. | The script was still executing after 30 seconds. Flash Player first throws run-time error number 1502 (A script has executed for longer than the default timeout period of 15 seconds.) if the script executed more than 15 seconds, which is the default timeout period. This error occurs 15 seconds after Error 1502 occurs.
1507 | Argument _ cannot be null.
1508 The value specified for argument _ is invalid. You are possibly trying to pass the wrong data type. For example, the code
public function doSomething(const:int):void {
    }
    this ["doSomething"] ("str")
generates an error at runtime because doSomething is cast as an int data type.
1510 | When the callback argument is a method of a class, the optional this argument must be null.
2000 | No active security context.
2001 | Too few arguments were specified; got _, _ expected.
2002 | Operation attempted on invalid socket.
2003 | Invalid socket port number specified. | The valid range is 0 to 65535. For more information, see Socket Connections in this language reference.
2004 | One of the parameters is invalid.
2005 | Parameter _ is of the incorrect type. Should be type _.
2006 | The supplied index is out of bounds.
2007 | Parameter _ must be non-null.
2008 | Parameter _ must be one of the accepted values.
2009 | This method cannot be used on a text field with a style sheet.
2010 | Local-with-filesystem SWF files are not permitted to use sockets.
2011 | Socket connection failed to _:_. | There is a network problem. Possibly a DNS name is not resolving or a TCP socket is not connecting.
2012 | _ class cannot be instantiated.
2013 | Feature can only be used in Flash Authoring.
2014 | Feature is not available at this time. | The feature is not supported on this system.
2015 | Invalid BitmapData.
2017 | Only trusted local files may cause the Flash Player to exit.
2018 | System.exit is only available in the standalone Flash Player.
2019 | Depth specified is invalid.
2020 | MovieClips objects with different parents cannot be swapped.
2021 | Object creation failed.
2022 | Class _ must inherit from DisplayObject to link to a symbol.
2023 | Class _ must inherit from Sprite to link to the root.
2024 | An object cannot be added as a child of itself.
2025 | The supplied DisplayObject must be a child of the caller.
2026 | An error occurred navigating to the URL _. | Possibly the URL does not exist, the network connection has a problem, or the URL is outside the security sandbox.
2027 | Parameter _ must be a non-negative number; got _.
2028 | Local-with-filesystem SWF file _ cannot access Internet URL _.
2029 | This URLStream object does not have a stream opened.
2030 | End of file was encountered.
2031 | Socket Error. | A socket error occurred. For more information, see Socket Connections in this language reference.
2032 | Stream Error.
2033 | Key Generation Failed.
2035 | URL Not Found.
2036 | Load Never Completed.
2037 | Functions called in incorrect sequence, or earlier call was unsuccessful.
2038 | File I/O Error.
2039 | Invalid remote URL protocol. The remote URL protocol must be HTTP or HTTPS.
2041 | Only one file browsing session may be performed at a time.
2044 | Unhandled _:.
2047 | Security sandbox violation: _: _ cannot access _.
2048 | Security sandbox violation: _ cannot load data from _.
2049 | Security sandbox violation: _ cannot upload data to _.
2051 | Security sandbox violation: _ cannot evaluate scripting URLs within _ (allowScriptAccess is _). Attempted URL was _.
2052 | Only String arguments are permitted for allowDomain and allowInsecureDomain.
2053 | Security sandbox violation: _ cannot clear an interval timer set by _.
2054 | The value of Security.exactSettings cannot be changed after it has been used.
2055 | The print job could not be started.
2056 | The print job could not be sent to the printer.
2057 | The page could not be added to the print job. | The addPage() method is not used correctly. See the addPage() entry in this language reference.
2058 | There was an error decompressing the data.
2059 | Security sandbox violation: _ cannot overwrite an ExternalInterface callback added by _.
2060 | Security sandbox violation: ExternalInterface caller _ cannot access _.
2061 | No ExternalInterface callback _ registered.
2062 | Children of Event must override clone() {return new MyEventClass (...);}.
2063 Error attempting to execute IME command. One of the IME services has failed.
  • If you are using the setConversionMode() or setEnabled() method, ActionScript 3.0 replaces these methods with the access property.
  • If you are using the doConversion() or setComposition() method, these methods are not supported for Macintosh OSX and Macintosh Classic.
2065 | The focus cannot be set for this target.
2066 | The Timer delay specified is out of range.
2067 | The ExternalInterface is not available in this container. ExternalInterface requires Internet Explorer ActiveX, Firefox, Mozilla 1.7.5 and greater, or other browsers that support NPRuntime.
2068 | Invalid sound.
2069 | The Loader class does not implement this method.
2070 | Security sandbox violation: caller _ cannot access Stage owned by _.
2071 | The Stage class does not implement this property or method.
2074 | The stage is too small to fit the download ui.
2075 | The downloaded file is invalid. | Possibly the file decompression failed, the file format is invalid, or the signature validation failed.
2077 | This filter operation cannot be performed with the specified input parameters.
2078 | The name property of a Timeline-placed object cannot be modified.
2079 | Classes derived from Bitmap can only be associated with defineBits characters (bitmaps).
2082 | Connect failed because the object is already connected.
2083 | Close failed because the object is not connected.
2084 | The AMF encoding of the arguments cannot exceed 40K.
2085 | Parameter _ must be non-empty string.
2086 | A setting in the mms.cfg file prohibits this FileReference request.
2087 | The FileReference.download() file name contains prohibited characters. | The filename cannot contain spaces or any of the following characters: /, \, :, *, ?, ", <, >, |, %, or the ASCII control characters 0 through 31 (0x00 through 0X1F). Also, filenames longer than 256 characters may fail on some browsers or servers.
2088 | The Proxy class does not implement getProperty. It must be overridden by a subclass.
2089 | The Proxy class does not implement setProperty. It must be overridden by a subclass.
2090 | The Proxy class does not implement callProperty. It must be overridden by a subclass.
2091 | The Proxy class does not implement hasProperty. It must be overridden by a subclass.
2092 | The Proxy class does not implement deleteProperty. It must be overridden by a subclass.
2093 | The Proxy class does not implement getDescendants. It must be overridden by a subclass.
2094 | Event dispatch recursion overflow. | The recursion exceeds the maximum recursion depth. (The default maximum is 256.)
2095 | _ was unable to invoke callback _.
2096 The HTTP request header _ cannot be set via ActionScript. You are adding a disallowed HTTP header to an HTTP request. The following headers are disallowed:
  • NULL header string
  • Accept-Ranges
  • Age
  • Allow
  • Allowed
  • Connection
  • Content-Length
  • Content-Location
  • Content-Range
  • ETag
  • Host
  • Last-Modified
  • Location
  • Max-Forwards
  • Proxy-Authenticate
  • Proxy-Authorization
  • Public
  • Range
  • Retry-After
  • Server
  • TE
  • Trailer
  • Transfer-Encoding
  • Upgrade
  • URI
  • Vary
  • Via
  • Warning
  • WWW-Authenticate
2097 The FileFilter Array is not in the correct format. There are two valid formats:
  • A description with Windows file extensions only
  • A description with Windows file extensions and Macintosh file formats.

The two file formats and not interchangeable; you must use one or the other. For more information, see the FileFilter class in this language reference.

2098 | The loading object is not a .swf file, you cannot request SWF properties from it.
2099 | The loading object is not sufficiently loaded to provide this information.
2100 | The ByteArray parameter in Loader.loadBytes() must have length greater than 0.
2101 | The String passed to URLVariables.decode() must be a URL-encoded query string containing name/value pairs.
2102 | The before XMLNode parameter must be a child of the caller.
2103 XML recursion failure: new child would create infinite loop. Possibly you are trying to make objects child objects of each other. For example, the following code generates this error because a and b both try to add the other as a child object.
a.addChild(b);
b.addChild(a);
2105 | The Proxy class does not implement nextNameIndex. It must be overridden by a subclass.
2106 | The Proxy class does not implement nextName. It must be overridden by a subclass.
2107 | The Proxy class does not implement nextValue. It must be overridden by a subclass.
2108 | Scene _ was not found.
2109 | Frame label _ not found in scene _.
2110 | The value of Security.disableAVM1Loading cannot be set unless the caller can access the stage and is in an ActionScript 3.0 SWF file.
2111 | Security.disableAVM1Loading is true so the current load of the ActionScript 1.0/2.0 SWF file has been blocked.
2112 | Provided parameter LoaderContext.ApplicationDomain is from a disallowed domain.
2113 | Provided parameter LoaderContext.SecurityDomain is from a disallowed domain.
2114 | Parameter _ must be null.
2115 | Parameter _ must be false.
2116 | Parameter _ must be true.
2118 | The LoaderInfo class does not implement this method.
2119 | Security sandbox violation: caller _ cannot access LoaderInfo.applicationDomain owned by _.
2121 | Security sandbox violation: _: _ cannot access _. This may be worked around by calling Security.allowDomain.
2122 | Security sandbox violation: _: _ cannot access _. A policy file is required, but the checkPolicyFile flag was not set when this media was loaded.
2123 | Security sandbox violation: _: _ cannot access _. No policy files granted access.
2124 | Loaded file is an unknown type.
2125 | Security sandbox violation: _ cannot use Runtime Shared Library _ because crossing the boundary between ActionScript 3.0 and ActionScript 1.0/2.0 objects is not allowed.
2126 | NetConnection object must be connected.
2127 | FileReference POST data cannot be type ByteArray.
2129 | Connection to _ failed.
2130 | Unable to flush SharedObject.
2131 | Definition _ cannot be found.
2132 | NetConnection.connect cannot be called from a netStatus event handler.
2133 | Callback _ is not registered.
2134 | Cannot create SharedObject.
2135 | Security sandbox violation: _: _ cannot access _. RTMP content cannot be accessed using this API.
2136 | The SWF file _ contains invalid data.
2137 | Security sandbox violation: _ cannot navigate window _ within _ (allowScriptAccess is _). Attempted URL was _.
2138 | Rich text XML could not be parsed.
2139 | SharedObject could not connect.
2140 | Security sandbox violation: _ cannot load _. Local-with-filesystem and local-with-networking SWF files cannot load each other.
2141 | Only one PrintJob may be in use at a time.
2142 | Security sandbox violation: local SWF files cannot use the LoaderContext.securityDomain property. _ was attempting to load _.
2143 | AccessibilityImplementation.get_accRole() must be overridden from its default.
2144 | AccessibilityImplementation.get_accState() must be overridden from its default.
2145 | Cumulative length of requestHeaders must be less than 8192 characters.
2146 | Security sandbox violation: _ cannot call _ because the HTML/container parameter allowNetworking has the value _.
2147 | Forbidden protocol in URL _.
2148 | SWF file _ cannot access local resource _. Only local-with-filesystem and trusted local SWF files may access local resources.
2149 | Security sandbox violation: _ cannot make fscommand calls to _ (allowScriptAccess is _).

* Note: This error indicates that the ActionScript in the SWF is invalid. If you believe that the file has not been corrupted, please report the problem to Adobe.

Compiler Errors | Compiler Warnings
All Packages | All Classes | Language Elements | Index | Appendixes | Conventions | No Frames


ActionScript 2.0 Migration (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
ActionScript 2.0 Migration

The following table describes the differences between ActionScript 2.0 and 3.0.

ActionScript 2.0 | ActionScript 3.0 | Comments
Compiler directives
#endinitclip | Removed
#include | Removed | See the include statement for similar functionality.
#initclip | Removed
Constants
false | false | The value false, rather than undefined, is the default value of a Boolean object.
NaN | NaN | The value NaN, rather than undefined, is the default value of a Number object.
newline | Removed | Use the escape sequence composed of the backslash character followed by the character "n" (\n).
null | null | The value null, rather than undefined, is the default value of the Object and String classes.
undefined | undefined | The value undefined can be assigned only to untyped variables; it is not the default value of any typed object.
Global functions
asfunction | flash.text.TextField dispatches event: link | Replaced by the new event handling model. You now get the same functionality by using the syntax Event: instead of asfunction:. When a user clicks the link, Flash Player dispatches a TextEvent object of type TextEvent.LINK, which your code can listen for with the addEventListener() method. Any text that you decide to include is stored in the event object's text property.
call() | Removed
chr() | Removed
clearInterval() | flash.utils.clearInterval() | Moved to flash.utils package.
clearTimeout() | flash.utils.clearTimeout() | Moved to flash.utils package.
duplicateMovieClip() | flash.display.MovieClip.MovieClip() | Replaced by new MovieClip class constructor function.
eval() | Removed
fscommand() | flash.system.fscommand() | Moved to flash.system package. Also, see flash.external.ExternalInterface class for JavaScript/ActionScript communication.
getProperty() | Removed | To directly access properties, use the dot (.) operator.
getTimer() | flash.utils.getTimer() | Moved to flash.utils package.
getURL() | flash.net.navigateToURL() | Replaced by the navigateToURL() function.
getVersion() | flash.system.Capabilities.version | Moved to Capabilities class and changed to accessor property.
gotoAndPlay() | flash.display.MovieClip.gotoAndPlay() | This function is no longer a global function, but is still available as a method of the MovieClip class.
gotoAndStop() | flash.display.MovieClip.gotoAndStop() | This function is no longer a global function, but it is still available as a method of the MovieClip class.
ifFrameLoaded() | flash.display.MovieClip.framesLoaded
int() | int() | Resurrected from deprecated status as a conversion function for the new int data type.
length() | String.length | This property is no longer a global property, but it is still available as a property of the String class.
loadMovie() | flash.display.Loader | Use the Loader class instead.
loadMovieNum() | flash.display.Loader | Use the Loader class instead.
loadVariables() | flash.net.URLLoader | Use the URLLoader class instead.
loadVariablesNum() | flash.net.URLLoader | Use the URLLoader class instead.
mbchr() | String.fromCharCode() | Removed. Use the static String.fromCharCode() method instead.
mblength() | String.length | Removed. Use String.length instead.
mbord() | String.charCodeAt() | Removed. Use String.charCodeAt() instead.
mbsubstring() | String.substr() | Removed. Use String.substr() instead.
nextFrame() | flash.display.MovieClip.nextFrame() | This function is no longer a global function, but it is still available as a method of the MovieClip class.
nextScene() | flash.display.MovieClip.nextScene() | This function is no longer a global function, but it is still available as a method of the MovieClip class.
on() | flash.events.EventDispatcher | Removed. Use the new event handling system in the flash.events package instead.
onClipEvent() | flash.events.EventDispatcher | Removed. Use the new event handling system in the flash.events package instead.
ord() | String | Removed. Use String class methods instead.
parseInt() | parseInt() | A string with a leading 0 is interpreted as decimal rather than octal. For octal numbers, pass the number 8 for the radix parameter.
play() | flash.display.MovieClip.play() | This function is no longer a global function, but it is still available as a method of the MovieClip class.
prevFrame() | flash.display.MovieClip.prevFrame() | This function is no longer a global function, but it is still available as a method of the MovieClip class.
prevScene() | flash.display.MovieClip.prevScene() | This function is no longer a global function, but it is still available as a method of the MovieClip class.
print() | flash.printing.PrintJob | Removed. Use the PrintJob class instead.
printAsBitmap() | flash.printing.PrintJob | Removed. Use the PrintJob class instead.
printAsBitmapNum() | flash.printing.PrintJob | Removed. Use the PrintJob class instead.
printNum() | flash.printing.PrintJob | Removed. Use the PrintJob class instead.
random() | Math.random() | Removed. Use Math.random() instead.
removeMovieClip() | Removed | Set all references to a movie clip to null to make the movie clip eligible for garbage collection.
setInterval() | flash.utils.setInterval() | Moved to flash.utils package. Consider using the Timer class instead.
setProperty() | Removed | To set the value of a writable property, use the dot (.) operator.
setTimeout() | flash.utils.setTimeout() | Moved to flash.utils package.
showRedrawRegions() | flash.profiler.showRedrawRegions() | Moved to flash.profiler package.
startDrag() | flash.display.Sprite.startDrag() | This is no longer a global function, but it is still available as a method of the Sprite class.
stop() | flash.display.MovieClip.stop() | This is no longer a global function, but it is still available as a method of the MovieClip class.
stopAllSounds() | flash.media.SoundMixer.stopAll() | This is no longer a global function, but it is still available as a method of the SoundMixer class, which provides global sound control.
stopDrag() | flash.display.Sprite.stopDrag() | This is no longer a global function, but it is still available as a method of the Sprite class.
substring() | String.substring() | This is no longer a global function, but it is still available as a method of the String class.
targetPath() | Removed
tellTarget() | Removed | Use the dot (.) operator or the with statement instead.
toggleHighQuality() | flash.display.Stage.quality | Removed as a global property. Use the Stage class version instead.
trace() | trace() | The trace() method accepts a comma-delimited list of arguments.
unloadMovie() | flash.display.Loader.unload() | Removed. Use Loader.unload() instead.
unloadMovieNum() | flash.display.Loader.unload() | Removed. Use Loader.unload() instead.
updateAfterEvent() | flash.events.TimerEvent.updateAfterEvent() | This is no longer a global function, but it is still available as a method of the TimerEvent, MouseEvent, and KeyboardEvent classes.
Global properties
_accProps | flash.accessibility.AccessibilityProperties | Replaced by the AccessibilityProperties class.
_focusrect | flash.display.InteractiveObject.focusRect | Replaced by the focusRect property of the InteractiveObject class.
_global | Removed | Use a static member of a class instead.
_highquality | flash.display.Stage.quality | Replaced by the quality property of the Stage class.
_level | Removed | The concept of levels does not exist in ActionScript 3.0, which instead provides direct access to the display list. See the flash.display package for details.
maxscroll | flash.text.TextField | Replaced by the maxScrollH and maxScrollV properties of the TextField class.
_parent | flash.display.DisplayObject.parent | Replaced by the parent property of the DisplayObject class.
_quality | flash.display.Stage.quality | Replaced by the quality property of the Stage class.
_root | flash.display.DisplayObject.stage | Removed. The closest equivalent is the Stage, which serves as the root of the ActionScript 3.0 display list.
scroll | flash.text.TextField | Removed. Replaced by the scrollH and scrollV properties of the TextField class.
_soundbuftime | flash.media.SoundMixer.bufferTime | Replaced by the bufferTime property of the SoundMixer class.
this | this | Instance methods are bound to the instance that implemented the method; therefore, the this reference inside the body of an instance method always refers to the instance that implemented the method.
Operators
add (concatenation (strings)) | Removed | Use the concatenation (+) operator instead.
eq (equality (strings)) | Removed | Use the equality (==) operator instead.
gt (greater than (strings)) | Removed | Use the greater than (>) operator instead.
ge (greater than or equal to (strings)) | Removed | Use the greater than or equal to (>=) operator instead.
<> (inequality) | Removed | Use the inequality (!=) operator instead.
instanceof | is | Although the instanceof operator is available, it only checks the prototype chain, which is not the primary inheritance mechanism in ActionScript 3.0. Use the is operator to check whether an object is a member of a specific data type.
lt (less than (strings)) | Removed | Use the less than (<) operator instead.
le (less than or equal to (strings)) | Removed | Use the less than or equal to (<=) operator instead.
and (logical AND) | Removed | Use the logical AND (&&) operator instead.
not (logical NOT) | Removed | Use the logical NOT (!) operator instead.
or (logical OR) | Removed | Use the logical OR (||) operator instead.
ne (not equal (strings)) | Removed | Use the inequality (!=) operator instead.
Statements
delete | delete | The delete operator works only on properties of objects, but not on variables that hold references to objects.
import | import | The import statement is not optional. To use a class, you must import it, whether or not you use a fully qualified name.
intrinsic | Removed | ActionScript 3.0 has a similar, but not identical, keyword named native. The native keyword is similar to intrinsic in that it directs the compiler not to expect a function body, but is dissimilar in that native has no effect on compile-time type checking.
private | private | The ActionScript 3.0 private keyword specifies that an identifier is visible only within a class, and does not extend to subclasses. Moreover, in ActionScript 3.0 the private keyword is enforced at both compile time and run time.
set variable | Removed | Use the assignment (=) operator instead.
super | super | In ActionScript 3.0, the call to super() in a subclass constructor does not have to be the first statement in the constructor body.
Accessibility class | flash.accessibility.Accessibility
isActive() Method | flash.accessibility.Accessibility.active | Changed from function to accessor property. Name changed from isActive to active.
updateProperties() Method | flash.accessibility.Accessibility.updateProperties()
arguments class | arguments
caller Property | Removed | You can achieve the same functionality by passing arguments.callee from the caller function as an argument to the callee function. See the Examples section of arguments.callee for an example.
Array class
CASEINSENSITIVE Constant | Array.CASEINSENSITIVE | Data type changed to uint.
DESCENDING Constant | Array.DESCENDING | Data type changed to uint.
length Property | Array.length | Data type changed to uint.
NUMERIC Constant | Array.NUMERIC | Data type changed to uint.
RETURNINDEXEDARRAY Constant | Array.RETURNINDEXEDARRAY | Data type changed to uint.
UNIQUESORT Constant | Array.UNIQUESORT | Data type changed to uint.
Array Constructor | Array.Array() | Parameter changed to use the ...(rest) parameter format.
push() Method | Array.push() | Parameter changed to use the ...(rest) parameter format.
sort() Method | Array.sort() | Data type of the options parameter changed to uint.
sortOn() Method | Array.sortOn() | Data type of the options parameter changed to uint. The ActionScript 3.0 version also has added functionality; you can now sort on more than one field name by passing an array of objects for the fieldName parameter, and each sort field can have its own matching options parameter if you also pass in a matching array of options flags for the options parameter.
splice() Method | Array.splice() | The parameters can have any data type, but the preferred data types are int and uint. The value parameter changed to the ...(rest) parameter format.
unshift() Method | Array.unshift() | The value parameter changed to the ...(rest) format. Data type of the return value changed to uint.
AsBroadcaster class | flash.events.EventDispatcher
_listeners Property[read-only] | flash.events.EventDispatcher.willTrigger() | Not a direct equivalent. The willTrigger() method tells you whether any listeners are registered, but not how many.
addListener() Method | flash.events.EventDispatcher.addEventListener() | Not a direct equivalent, because the ActionScript 3.0 event model lets you add event listeners to any object in the event flow, not just to the broadcasting object.
broadcastMessage() Method | flash.events.EventDispatcher.dispatchEvent() | Not a direct equivalent, because the ActionScript 3.0 event model works differently. The dispatchEvent() method dispatches an event object into the event flow, while the broadcastMessage() method sends messages directly to each registered listener object.
initialize() Method | Removed | There is no direct equivalent in ActionScript 3.0, but similar functionality is achieved by subclassing the EventDispatcher class. For example, the DisplayObject class extends EventDispatcher, so all instances of the DisplayObject and DisplayObject subclasses are capable of sending and receiving event objects.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | Not a direct equivalent, because the ActionScript 3.0 event model lets you add event listeners to and remove them from any object in the event flow, not just the broadcasting object.
BitmapData class | flash.display.BitmapData | ActionScript 3.0 uses the BitmapDataChannel class as an enumeration of constants that indicate which channel to use.
height Property[read-only] | flash.display.BitmapData.height | Data type changed from Number to int.
rectangle Property[read-only] | flash.display.BitmapData.rect | Property renamed for consistency with other members of the API.
width Property[read-only] | flash.display.BitmapData.width | Data type changed from Number to int.
copyChannel() Method | flash.display.BitmapData.copyChannel() | The sourceChannel and destChannel parameters are now uint data types.
draw() Method | flash.display.BitmapData.draw() | The source parameter is now IBitmapDrawable; DisplayObject and BitmapData both implement the IBitmapDrawable interface, so you can pass either a DisplayObject or a BitmapData object to the source parameter.
fillRect() Method | flash.display.BitmapData.fillRect() | The color parameter is now a uint value.
floodFill() Method | flash.display.BitmapData.floodFill() | Now accepts int values for the x and y parameters and a uint value for color.
getColorBoundsRect() Method | flash.display.BitmapData.getColorBoundsRect() | Now accepts uint values for the mask and color parameters.
getPixel() Method | flash.display.BitmapData.getPixel() | Now accepts int parameter values and returns a uint value.
getPixel32() Method | flash.display.BitmapData.getPixel32() | Now accepts int parameter values and returns a uint value.
hitTest() Method | flash.display.BitmapData.hitTest() | Now accepts uint values for the firstAlphaThreshold and secondAlphaThreshold parameters.
loadBitmap() Method | Removed
merge() Method | flash.display.BitmapData.merge() | Now accepts uint values for the multiplier parameters.
noise() Method | flash.display.BitmapData.noise() | Now accepts an int value for the randomSeed parameter and uint values for the low, high, and channelOptions parameters.
perlinNoise() Method | flash.display.BitmapData.perlinNoise() | Now accepts an int value for the randomSeed parameter and uint values for the numOctaves and channelOptions parameters.
pixelDissolve() Method | flash.display.BitmapData.pixelDissolve() | Now accepts an int value for the randomSeed and numPixels parameters and a uint value for the fillColor parameter. (The numPixels parameter is named numberOfPixels in ActionScript 2.0.)
scroll() Method | flash.display.BitmapData.scroll() | Now accepts int values for the x and y parameters.
setPixel() Method | flash.display.BitmapData.setPixel() | Now accepts int values for the x and y parameters and a uint value for color.
setPixel32() Method | flash.display.BitmapData.setPixel32() | Now accepts int values for the x and y parameters and a unit value for color.
threshold() Method | flash.display.BitmapData.threshold() | Now accepts uint values for the threshold, color, and mask parameters, and returns a uint value.
BlurFilter class
quality Property | flash.filters.BlurFilter.quality | The quality property data type changed from a Number to uint.
Button class | flash.display.SimpleButton
_alpha Property | flash.display.DisplayObject.alpha
blendMode Property | flash.display.DisplayObject.blendMode
cacheAsBitmap Property | flash.display.DisplayObject.cacheAsBitmap
enabled Property | flash.display.SimpleButton.enabled
filters Property | flash.display.DisplayObject.filters | In ActionScript 3.0, the data type is Array.
_focusrect Property | flash.display.InteractiveObject.focusRect
_height Property | flash.display.DisplayObject.height
_highquality Property | Removed
_name Property | flash.display.DisplayObject.name
_parent Property | flash.display.DisplayObject.parent
_quality Property | Removed | You can set rendering quality for all display objects by using flash.display.Stage.quality.
_rotation Property | flash.display.DisplayObject.rotation
scale9Grid Property | flash.display.DisplayObject.scale9Grid
_soundbuftime Property | flash.media.SoundMixer.bufferTime | Moved to the SoundMixer class, which is used for global sound control. Renamed without abbreviations. Removed the initial underscore from the name.
tabEnabled Property | flash.display.InteractiveObject.tabEnabled
tabIndex Property | flash.display.InteractiveObject.tabIndex
_target Property[read-only] | Removed
trackAsMenu Property | flash.display.SimpleButton.trackAsMenu
_url Property[read-only] | Removed
useHandCursor Property | flash.display.SimpleButton.useHandCursor
_visible Property | flash.display.DisplayObject.visible
_width Property | flash.display.DisplayObject.width
_x Property | flash.display.DisplayObject.x
_xmouse Property[read-only] | flash.display.DisplayObject.mouseX
_xscale Property | flash.display.DisplayObject.scaleX
_y Property | flash.display.DisplayObject.y
_ymouse Property[read-only] | flash.display.DisplayObject.mouseY
_yscale Property | flash.display.DisplayObject.scaleY
getDepth() Method | flash.display.DisplayObjectContainer.getChildIndex() | ActionScript 3.0 provides direct access to the display list, so depth is handled differently.
onDragOut() EventHandler | flash.display.InteractiveObject dispatches event: mouseOut | Replaced in the new event model by a mouseOut event, after a call to InteractiveObject.setCapture().
onDragOver() EventHandler | flash.display.InteractiveObject dispatches event: mouseOver | Replaced in the new event model by a mouseOver event after a call to the InteractiveObject.setCapture() method.
onKeyDown() EventHandler | flash.display.InteractiveObject dispatches event: keyDown | Replaced in the new event model by a keyDown event.
onKeyUp() EventHandler | flash.display.InteractiveObject dispatches event: keyUp | Replaced in the new event model by a keyUp event.
onKillFocus() EventHandler | flash.display.InteractiveObject dispatches event: focusOut | Replaced in the new event model by a focusOut event.
onPress() EventHandler | flash.display.InteractiveObject dispatches event: mouseDown | Replaced in the new event model by a mouseDown event.
onRelease() EventHandler | flash.display.InteractiveObject dispatches event: mouseUp | Replaced in the new event model by a mouseUp event.
onReleaseOutside() EventHandler | flash.display.InteractiveObject dispatches event: mouseUp | Replaced in the new event model by a mouseUp event after a call to flash.display.InteractiveObject.setCapture().
onRollOut() EventHandler | flash.display.InteractiveObject dispatches event: mouseOut | Replaced in the new event model by a mouseOut event.
onRollOver() EventHandler | flash.display.InteractiveObject dispatches event: mouseOver | Replaced in the new event model by a mouseOver event.
onSetFocus() EventHandler | flash.display.InteractiveObject dispatches event: focusIn | Replaced in the new event model by a focusIn event.
Camera class | flash.media.Camera
activityLevel Property[read-only] | flash.media.Camera.activityLevel
bandwidth Property[read-only] | flash.media.Camera.bandwidth
currentFps Property[read-only] | flash.media.Camera.currentFPS | Change in capitalization of FPS.
fps Property[read-only] | flash.media.Camera.fps
height Property[read-only] | flash.media.Camera.height | Data type changed from Number to int.
index Property[read-only] | flash.media.Camera.index | Data type changed from String to int.
motionLevel Property[read-only] | flash.media.Camera.motionLevel | Data type changed from Number to int.
motionTimeOut Property[read-only] | flash.media.Camera.motionTimeout | Data type changed from Number to int.
muted Property[read-only] | flash.media.Camera.muted
name Property[read-only] | flash.media.Camera.name
names Property[read-only] | flash.media.Camera.names
quality Property[read-only] | flash.media.Camera.quality | Data type changed from Number to int.
width Property[read-only] | flash.media.Camera.width | Data type changed from Number to int.
get() Method | flash.media.Camera.getCamera()
onActivity() EventHandler | flash.events.ActivityEvent.ACTIVITY
onStatus() EventHandler | flash.media.Camera dispatches event: status | Replaced in the new event model by a status StatusEvent object.
setMode() Method | flash.media.Camera.setMode() | The width and height parameters changed to data type int.
setMotionLevel() Method | flash.media.Camera.setMotionLevel() | Both parameters changed to data type int.
setQuality() Method | flash.media.Camera.setQuality() | Both parameters changed to data type int.
capabilities class | flash.system.Capabilities | The class name changed from lowercase to initial capitalization.
Color class | flash.geom.ColorTransform | The Color class has been removed because all of its functionality can be achieved with the flash.geom.ColorTransform class. Color values can be assigned directly by using the ColorTransform class constructor or properties. ColorTransform objects can then be assigned to the colorTransform property of a Transform object, which in turn can be assigned to the transform property of a DisplayObject instance.
Color Constructor | flash.geom.ColorTransform.ColorTransform() | Removed. You can specify color values by using the ColorTransform() constructor.
getRGB() Method | flash.geom.ColorTransform.color | The RGB color value can be accessed by using the color accessor property of the ColorTransform class.
getTransform() Method | Removed | Color values can be assigned directly by using the ColorTransform() class constructor or properties.
setRGB() Method | flash.geom.ColorTransform.color | The RGB color value can be set by using the color accessor property of the ColorTransform class.
setTransform() Method | Removed | Color values can be assigned directly by using the ColorTransform() class constructor or properties.
ContextMenu class | flash.ui.ContextMenu | The ContextMenu class is now part of the flash.ui package.
builtInItems Property | flash.ui.ContextMenu.builtInItems
customItems Property | flash.ui.ContextMenu.customItems
ContextMenu Constructor | flash.ui.ContextMenu.ContextMenu()
copy() Method | flash.ui.ContextMenu.clone()
hideBuiltInItems() Method | flash.ui.ContextMenu.hideBuiltInItems()
onSelect() EventHandler | flash.ui.ContextMenu dispatches event: menuSelect | Instead of invoking the onSelect() event handler, the ActionScript 3.0 class dispatches a menuSelect event.
ContextMenuItem class | flash.ui.ContextMenuItem | The ContextMenuItem class is now part of the flash.ui package.
caption Property | flash.ui.ContextMenuItem.caption
enabled Property | flash.ui.ContextMenuItem.enabled
separatorBefore Property | flash.ui.ContextMenuItem.separatorBefore
visible Property | flash.ui.ContextMenuItem.visible
ContextMenuItem Constructor | flash.ui.ContextMenuItem.ContextMenuItem()
copy() Method | flash.ui.ContextMenuItem.clone()
onSelect() EventHandler | flash.ui.ContextMenuItem dispatches event: menuItemSelect | Instead of invoking the onSelect() event handler, the ActionScript 3.0 class dispatches a menuSelect event.
ConvolutionFilter class
clone() Method | flash.filters.ConvolutionFilter.clone() | Now returns a BitmapFilter object.
Date class | Date | ActionScript 3.0 includes a new set of read accessors for all the methods that start with getxxx(). For example, in ActionScript 3.0, Date.getDate() and Date.date return the same value.
getUTCYear() Method | Date.getUTCFullYear() | This method was removed because it is not part of ECMAScript. Use Date.getUTCFullYear() instead.
getYear() Method | Date.getFullYear() | This method was removed because it is not part of ECMAScript. Use Date.getFullYear() instead.
setYear() Method | Date.setFullYear() | This method was removed because it is not part of ECMAScript. Use Date.setFullYear() instead.
DisplacementMapFilter class | flash.filters.DisplacementMapFilter | The data type of several parameters changed from Number to uint.
color Property | flash.filters.DisplacementMapFilter.color | The data type of this parameter is now uint.
componentX Property | flash.filters.DisplacementMapFilter.componentX | The data type of this parameter is now uint.
componentY Property | flash.filters.DisplacementMapFilter.componentY | The data type of this parameter is now uint.
DisplacementMapFilter Constructor | flash.filters.DisplacementMapFilter.DisplacementMapFilter() | The data type of the componentX, componentY, and color parameters is now uint.
clone() Method | flash.filters.DisplacementMapFilter.clone() | Now returns a BitmapFilter object.
DropShadowFilter class | flash.filters.DropShadowFilter
color Property | flash.filters.DropShadowFilter.color | The data type of this parameter changed from Number to uint.
quality Property | flash.filters.DropShadowFilter.quality | The data type of this parameter changed from Number to uint.
DropShadowFilter Constructor | flash.filters.DropShadowFilter.DropShadowFilter() | All parameters now have a default value, and some parameter types have changed.
clone() Method | flash.filters.DropShadowFilter.clone() | Now returns a BitmapFilter object instead of a DropShadowFilter object.
Error class | Error | Added a new getStackTrace() method to assist in debugging.
ExternalInterface class | flash.external.ExternalInterface | Parameters changed for two methods in this class.
addCallback() Method | flash.external.ExternalInterface.addCallback() | The ActionScript 3.0 version of this method does not accept the instance parameter. The method parameter is replaced by a closure parameter, which can take a reference to a function, a class method, or a method of a particular class instance. In addition, if the calling code cannot access the closure reference for security reasons, a SecurityError exception is thrown.
call() Method | flash.external.ExternalInterface.call() | If a problem occurs, the ActionScript 3.0 version of this method throws an Error or SecurityError exception, in addition to returning null.
FileReference class | flash.net.FileReference | The ActionScript 3.0 version inherits the addEventListener() and removeEventListener() methods from the EventDispatcher class. Dispatched events replace the event handler functions.
postData Property | flash.net.URLRequest.data | The postData property is added to ActionScript 2.0 in Flash Player 9 to send POST data with the file upload or download. In ActionScript 3.0, use the data property of the URLRequest class to send either POST or GET data. See flash.net.URLRequest.data in this language reference for details.
size Property[read-only] | flash.net.FileReference.size | Returns a uint data type instead of a Number data type.
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new event model, there is no need to have a class-specific addListener() method, because the class inherits the addEventListener() method from the EventDispatcher class.
browse() Method | flash.net.FileReference.browse() | In ActionScript 2.0, returns false when there is an error. In ActionScript 3.0, throws an IllegalOperationError or ArgumentError exception. However, the method still returns false if the parameters are invalid, the file-browsing dialog box does not open, or another browser session is in progress. Also, the typelist parameter changed. In ActionScript 2.0, you can pass the browse() method an array of strings to specify a file filter. In ActionScript 3.0, you pass an array of FileFilter objects.
download() Method | flash.net.FileReference.download() | When an error occurs, throws exceptions instead of returning false. The data type for the first parameter has changed. In ActionScript 2.0, the first parameter you pass to download() is a string. In ActionScript 3.0, you pass a URLRequest object.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new event model, there is no need to have a class-specific removeListener() method, because the class inherits the removeEventListener() method from the EventDispatcher class.
upload() Method flash.net.FileReference.upload() Various changes have occurred:
  • The data type for the first parameter has changed. In ActionScript 2.0, the first parameter you pass to upload() is a string. In ActionScript 3.0, you pass a URLRequest object.
  • In ActionScript 3.0, there is a new second parameter, uploadDataFieldName, which is the field name that precedes the file data in the upload POST operation.
  • In ActionScript 3.0, there is a new third parameter, testUpload, that lets you control whether Flash Player performs a test upload before uploading the file.
  • When an error occurs, browse() throws exceptions instead of returning false.
onCancel Listener | flash.net.FileReference dispatches event: cancel | In ActionScript 3.0, instead of invoking the onCancel() event handler, this class dispatches an event named cancel.
onComplete Listener | flash.net.FileReference dispatches event: complete | In ActionScript 3.0, instead of invoking the onComplete() event handler, this class dispatches an event named complete.
onHTTPError Listener | flash.net.FileReference dispatches event: httpStatus | In ActionScript 3.0, instead of invoking the onHTTPError() event handler, this class dispatches an event named httpStatus.
onIOError Listener | flash.net.FileReference dispatches event: ioError | In ActionScript 3.0, instead of invoking the onIOError() event handler, this class dispatches an event named ioError.
onOpen Listener | flash.net.FileReference dispatches event: open | In ActionScript 3.0, instead of invoking the onOpen() event handler, this class dispatches an event named open.
onProgress Listener | flash.net.FileReference dispatches event: progress | In ActionScript 3.0, instead of invoking the onProgress() event handler, this class dispatches an event named progress.
onSecurityError Listener | flash.net.FileReference dispatches event: securityError | In ActionScript 3.0, instead of invoking the onSecurityError() event handler, this class dispatches an event named securityError.
onSelect Listener | flash.net.FileReference dispatches event: select | In ActionScript 3.0, instead of invoking the onSelect() event handler, this class dispatches an event named select.
FileReferenceList class | flash.net.FileReferenceList | The ActionScript 3.0 class inherits the addEventListener() and removeEventListener() methods from the EventDispatcher class. Instead of the onCancel() and onSelect() event handlers, the ActionScript 3.0 class uses events named cancel and select.
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new event model, there is no need to have a class-specific addListener() method, because the class inherits the addEventListener() method from the EventDispatcher class.
browse() Method | flash.net.FileReferenceList.browse() | In ActionScript 3.0, instead of returning false when there is an error, this method throws an IllegalOperationError exception. Also, the typelist parameter changed. In ActionScript 2.0, you can pass the browse() method an array of strings to specify a file filter. In ActionScript 3.0, you pass an array of FileFilter objects.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new event model, there is no need to have a class-specific removeListener() method, because the class inherits the removeEventListener() method from the EventDispatcher class.
onCancel Listener | flash.net.FileReferenceList dispatches event: cancel | In ActionScript 3.0, instead of invoking the onCancel() event handler, this class dispatches an event named cancel.
onSelect Listener | flash.net.FileReferenceList dispatches event: select | In ActionScript 3.0, instead of invoking the onSelect() event handler, this class dispatches an event named select.
GlowFilter class | flash.filters.GlowFilter | The data type of several properties changed from Number to unit.
color Property | flash.filters.GlowFilter.color | The data type of this property changed from Number to unit.
quality Property | flash.filters.GlowFilter.quality | The data type of this property changed from Number to unit.
GlowFilter Constructor | flash.filters.GlowFilter.GlowFilter() | The color and quality parameters are now uint and int data types, respectively, instead of Number. All parameters are now assigned a default value.
clone() Method | flash.filters.GlowFilter.clone() | Returns a BitmapFilter object instead of a GlowFilter object.
GradientBevelFilter class | flash.filters.GradientBevelFilter
quality Property | flash.filters.GradientBevelFilter.quality | The data type of this property changed from Number to int.
clone() Method | flash.filters.GradientBevelFilter.clone() | Returns a BitmapFilter object instead of a GradientBevelFilter object.
GradientGlowFilter class | flash.filters.GradientGlowFilter
quality Property | flash.filters.GradientGlowFilter.quality | The data type of this property changed from Number to int.
GradientGlowFilter Constructor | flash.filters.GradientGlowFilter.GradientGlowFilter() | Default values added to all parameters and the data type of the quality parameter changed from Number to int.
clone() Method | flash.filters.GradientGlowFilter.clone() | Returns a BitmapFilter object instead of a GradientGlowFilter object.
IME class | flash.system.IME | This class has been moved to the flash.system package.
ALPHANUMERIC_FULL Constant | flash.system.IMEConversionMode.ALPHANUMERIC_FULL
ALPHANUMERIC_HALF Constant | flash.system.IMEConversionMode.ALPHANUMERIC_HALF
CHINESE Constant | flash.system.IMEConversionMode.CHINESE
JAPANESE_HIRAGANA Constant | flash.system.IMEConversionMode.JAPANESE_HIRAGANA
JAPANESE_KATAKANA_FULL Constant | flash.system.IMEConversionMode.JAPANESE_KATAKANA_FULL
JAPANESE_KATAKANA_HALF Constant | flash.system.IMEConversionMode.JAPANESE_KATAKANA_HALF
KOREAN Constant | flash.system.IMEConversionMode.KOREAN
UNKNOWN Constant | flash.system.IMEConversionMode.UNKNOWN
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new event model, there is no need to have a class-specific addListener() method, because the class inherits the addEventListener() method from the EventDispatcher class.
getConversionMode() Method | flash.system.IME.conversionMode | Changed to an accessor property.
getEnabled() Method | flash.system.IME.enabled | Changed to an accessor property.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new event model, there is no need to have a class-specific removeListener() method, because the class inherits the removeEventListener() method from the EventDispatcher class.
setConversionMode() Method | flash.system.IME.conversionMode | Changed to an accessor property.
setEnabled() Method | flash.system.IME.enabled | Changed to an accessor property.
onIMEComposition Listener | flash.system.IME dispatches event: imeComposition | In ActionScript 3.0, instead of invoking the onIMEComposition() event handler, this class dispatches an event named imeComposition.
Key class | flash.ui.Keyboard | This class has a new name in ActionScript 3.0 to match other classes that pertain to the Keyboard class, such as KeyboardEvent.
BACKSPACE Constant | flash.ui.Keyboard.BACKSPACE | Declared as a constant in ActionScript 3.0 and data type changed to unit.
CAPSLOCK Constant | flash.ui.Keyboard.CAPS_LOCK | Declared as a constant in ActionScript 3.0, underscore added, and data type changed to uint.
CONTROL Constant | flash.ui.Keyboard.CONTROL | Declared as a constant in ActionScript 3.0 and data type changed to uint.
DELETEKEY Constant | flash.ui.Keyboard.DELETE | Name changed to DELETE in ActionScript 3.0, declared as a constant, and data type changed to uint.
DOWN Constant | flash.ui.Keyboard.DOWN | Declared as a constant in ActionScript 3.0 and data type changed to uint.
END Constant | flash.ui.Keyboard.END | Declared as a constant in ActionScript 3.0 and data type changed to uint.
ENTER Constant | flash.ui.Keyboard.ENTER | Declared as a constant in ActionScript 3.0 and data type changed to uint.
ESCAPE Constant | flash.ui.Keyboard.ESCAPE | Declared as a constant in ActionScript 3.0 and data type changed to uint.
HOME Constant | flash.ui.Keyboard.HOME | Declared as a constant in ActionScript 3.0 and data type changed to uint.
INSERT Constant | flash.ui.Keyboard.INSERT | Declared as a constant in ActionScript 3.0 and data type changed to uint.
LEFT Constant | flash.ui.Keyboard.LEFT | Declared as a constant in ActionScript 3.0 and data type changed to uint.
_listeners Property[read-only] | flash.events.EventDispatcher.willTrigger() | Not a direct equivalent. The willTrigger() method tells you whether any listeners are registered, but not how many.
PGDN Constant | flash.ui.Keyboard.PAGE_DOWN | Name changed to PAGE_DOWN in ActionScript 3.0, declared as a constant, and data type changed to uint.
PGUP Constant | flash.ui.Keyboard.PAGE_UP | Name changed to PAGE_UP in ActionScript 3.0, declared as a constant, and data type changed to uint.
RIGHT Constant | flash.ui.Keyboard.RIGHT | Declared as a constant in ActionScript 3.0 and data type changed to uint.
SHIFT Constant | flash.ui.Keyboard.SHIFT | Declared as a constant in ActionScript 3.0 and data type changed to uint.
SPACE Constant | flash.ui.Keyboard.SPACE | Declared as a constant in ActionScript 3.0 and data type changed to uint.
TAB Constant | flash.ui.Keyboard.TAB | Declared as a constant in ActionScript 3.0 and data type changed to uint.
UP Constant | flash.ui.Keyboard.UP | Declared as a constant in ActionScript 3.0 and data type changed to uint.
addListener() Method | flash.events.EventDispatcher.addEventListener() | In ActionScript 3.0, there is no need to have a class-specific addListener() method, because all display objects inherit the addEventListener() method from the EventDispatcher class.
getAscii() Method | flash.events.KeyboardEvent.charCode
getCode() Method | flash.events.KeyboardEvent.keyCode
isAccessible() Method | flash.ui.Keyboard.isAccessible()
isDown() Method | Removed | Removed for security reasons.
isToggled() Method | Removed | Removed for security reasons.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In ActionScript 3.0, there is no need to have a class-specific removeListener() method, because all display objects inherit the removeEventListener() method from the EventDispatcher class.
onKeyDown Listener | flash.display.InteractiveObject dispatches event: keyDown | In ActionScript 3.0, instead of invoking the onKeyDown event handler, the InteractiveObject class dispatches a keyDown KeyboardEvent object.
onKeyUp Listener | flash.display.InteractiveObject dispatches event: keyUp | In ActionScript 3.0, instead of invoking the onKeyUp event handler, the InteractiveObject class dispatches a keyUp KeyboardEvent object.
LoadVars class | flash.net.URLLoader | The LoadVars class functionality is replaced by the URLLoader, URLRequest, URLStream, and URLVariables classes.
contentType Property | flash.net.URLRequest.contentType
loaded Property | Removed | There is no corresponding Boolean property in ActionScript 3.0, but you can use flash.events.Event.COMPLETE to set up listeners that receive notification when data is loaded.
LoadVars Constructor | flash.net.URLLoader.URLLoader()
addRequestHeader() Method | flash.net.URLRequestHeader
decode() Method | flash.net.URLVariables.decode()
getBytesLoaded() Method | flash.net.URLLoader.bytesLoaded | Class changed to URLLoader; changed from function to property accessor; and name changed from getBytesLoaded to bytesLoaded.
getBytesTotal() Method | flash.net.URLLoader.bytesTotal | Class changed to URLLoader; changed from function to property accessor; and name changed from getBytesTotal to bytesTotal.
load() Method | flash.net.URLLoader.load()
onData() EventHandler | flash.net.URLLoader dispatches event: complete | See the URLLoader class. A complete event is dispatched when the download operation is complete but before any data is parsed.
onHTTPStatus() EventHandler | flash.net.URLLoader dispatches event: httpStatus | In ActionScript 3.0, instead of invoking the onHTTPStatus event handler, the URLLoader class dispatches an HTTPStatusEvent object named httpStatus.
onLoad() EventHandler | flash.net.URLLoader dispatches event: complete | See the URLLoader class. A complete event is dispatched when the download operation is complete.
send() Method | flash.net.sendToURL()
sendAndLoad() Method | flash.net.sendToURL() | The sendToURL() method sends a URL request to the server, but ignores the response. To receive the response, use flash.net.sendToURL().
toString() Method | Removed
LocalConnection class | flash.net.LocalConnection | This class has been moved to the flash.net package.
LocalConnection Constructor | flash.net.LocalConnection.LocalConnection()
allowDomain() EventHandler | flash.net.LocalConnection.allowDomain() | Changed to a regular method in ActionScript 3.0, no longer an event handler. Parameter changed to use the ...(rest) parameter format. Return value changed to void.
allowInsecureDomain() EventHandler | flash.net.LocalConnection.allowInsecureDomain() | Changed to a regular method in ActionScript 3.0, no longer an event handler. Parameter changed to use the ...(rest) parameter format. Return value changed to void.
close() Method | flash.net.LocalConnection.close()
connect() Method | flash.net.LocalConnection.connect()
domain() Method | flash.net.LocalConnection.domain | Changed to a property accessor.
onStatus() EventHandler | flash.net.LocalConnection dispatches event: status | In the new event model, callback functions are replaced by event objects.
send() Method | flash.net.LocalConnection.send() | Third parameter changed to use the ...(rest) parameter format. Return type changed to void.
Microphone class | flash.media.Microphone | This class has been moved to the flash.media package.
index Property[read-only] | flash.media.Microphone.index | Data type changed to uint.
rate Property[read-only] | flash.media.Microphone.rate | Data type changed to uint.
silenceTimeOut Property[read-only] | flash.media.Microphone.silenceTimeout | Change in capitalization to "Timeout." Data type changed to int.
get() Method | flash.media.Microphone.getMicrophone() | Name changed from get() to getMicrophone(). Data type of parameter changed to uint.
onActivity() EventHandler | flash.media.Microphone dispatches event: activity | In ActionScript 3.0, instead of invoking the onActivity event handler, this class dispatches an activity event.
onStatus() EventHandler | flash.media.Microphone dispatches event: status | In ActionScript 3.0, instead of invoking the onStatus event handler, this class dispatches a status event.
setGain() Method | flash.media.Microphone.gain | Combined gain property and setGain() method into a get/set property accessor named gain. Data type changed to uint.
setRate() Method | flash.media.Microphone.rate | Combined rate property and setRate() method into a get/set property accessor named rate. Data type changed to uint.
setSilenceLevel() Method | flash.media.Microphone.setSilenceLevel() | Data type of timeOut parameter changed to int. Capitalization of the timeOut parameter changed to timeout.
setUseEchoSuppression() Method | flash.media.Microphone.setUseEchoSuppression()
Mouse class | flash.ui.Mouse
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new ActionScript 3.0 event model, there is no need to have a class-specific addListener() method, because all display objects inherit the addEventListener() method from the EventDispatcher class.
hide() Method | flash.ui.Mouse.hide() | Changed to return void.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new ActionScript 3.0 event model, there is no need to have a class-specific removeListener() method, because all display objects inherit the removeEventListener() method from the EventDispatcher class.
show() Method | flash.ui.Mouse.show() | Changed to return void.
onMouseDown Listener | flash.display.InteractiveObject dispatches event: mouseDown | Replaced in the new event model by a mouseDown event.
onMouseMove Listener | flash.display.InteractiveObject dispatches event: mouseMove | Replaced in the new event model by a mouseMove event.
onMouseUp Listener | flash.display.InteractiveObject dispatches event: mouseUp | Replaced in the new event model by a mouseUp event.
onMouseWheel Listener | flash.display.InteractiveObject dispatches event: mouseWheel | Replaced in the new event model by a mouseWheel event.
MovieClip class | flash.display.MovieClip | Many of the MovieClip methods have been moved to other classes in ActionScript 3.0. All event handlers have been replaced by event objects in the new event model.
_alpha Property | flash.display.DisplayObject.alpha | Moved to DisplayObject class and removed initial underscore from name.
blendMode Property | flash.display.DisplayObject.blendMode
cacheAsBitmap Property | flash.display.DisplayObject.cacheAsBitmap
_currentframe Property[read-only] | flash.display.MovieClip.currentFrame | Removed initial underscore from name.
_droptarget Property[read-only] | flash.display.Sprite.dropTarget | Moved to Sprite class, removed initial underscore from name, and changed to mixed case.
filters Property | flash.display.DisplayObject.filters
focusEnabled Property | Removed
_focusrect Property | flash.display.InteractiveObject.focusRect | Moved to InteractiveObject class, removed initial underscore from name, and changed to mixed case.
_framesloaded Property[read-only] | flash.display.MovieClip.framesLoaded | Removed initial underscore from name and changed to mixed case.
_height Property | flash.display.DisplayObject.height | Moved to DisplayObject class and removed initial underscore from name.
_highquality Property | Removed
hitArea Property | flash.display.Sprite.hitArea | Moved to Sprite class.
_lockroot Property | Removed
menu Property | Removed
_name Property | flash.display.DisplayObject.name | Moved to DisplayObject class and removed initial underscore from name.
opaqueBackground Property | flash.display.DisplayObject.opaqueBackground
_parent Property | flash.display.DisplayObject.parent | Moved to DisplayObject class and removed initial underscore from name.
_quality Property | flash.display.Stage.quality
_rotation Property | flash.display.DisplayObject.rotation | Moved to DisplayObject class and removed initial underscore from name.
scale9Grid Property | flash.display.DisplayObject.scale9Grid
scrollRect Property | flash.display.DisplayObject.scrollRect | Changed to Rectangle data type.
_soundbuftime Property | flash.media.SoundMixer.bufferTime | Moved to SoundMixer class, which is used for global sound control, renamed without abbreviations, and removed initial underscore from name.
tabChildren Property | flash.display.DisplayObjectContainer.tabChildren
tabEnabled Property | flash.display.InteractiveObject.tabEnabled
tabIndex Property | flash.display.InteractiveObject.tabIndex
_target Property[read-only] | Removed
_totalframes Property[read-only] | flash.display.MovieClip.totalFrames | Changed to mixed case and removed initial underscore from name.
trackAsMenu Property | flash.display.MovieClip.trackAsMenu
transform Property | flash.display.DisplayObject.transform
_url Property[read-only] | flash.display.Loader.contentLoaderInfo
useHandCursor Property | flash.display.Sprite.useHandCursor
_visible Property | flash.display.DisplayObject.visible | Moved to DisplayObject class and removed initial underscore from name.
_width Property | flash.display.DisplayObject.width | Moved to DisplayObject class and removed initial underscore from name.
_x Property | flash.display.DisplayObject.x | Moved to DisplayObject class and removed initial underscore from name.
_xmouse Property[read-only] | flash.display.DisplayObject.mouseX | Moved to DisplayObject class, changed name to mouseX, and removed initial underscore from name.
_xscale Property | flash.display.DisplayObject.scaleX | Moved to DisplayObject class, changed name to scaleX, and removed initial underscore from name.
_y Property | flash.display.DisplayObject.y | Moved to DisplayObject class and removed initial underscore from name.
_ymouse Property[read-only] | flash.display.DisplayObject.mouseY | Moved to DisplayObject class, changed name to mouseY, and removed initial underscore from name.
_yscale Property | flash.display.DisplayObject.scaleY | Moved to DisplayObject class, changed name to scaleY, and removed initial underscore from name.
attachAudio() Method Removed If the audio source is a Microphone object, use NetStream.attachAudio() or Microphone.setLoopBack().

If the audio source is an FLV file, use Video.attachNetStream() and a NetStream object.
attachBitmap() Method | Removed | In ActionScript 3.0, use addChild() to add child display objects.
attachMovie() Method | Removed | In ActionScript 3.0, use addChild() to add child display objects.
beginBitmapFill() Method | flash.display.Graphics.beginBitmapFill()
beginFill() Method | flash.display.Graphics.beginFill() | Moved to Graphics class and changed data type of the first parameter to uint.
beginGradientFill() Method | flash.display.Graphics.beginGradientFill()
clear() Method | flash.display.Graphics.clear()
createEmptyMovieClip() Method | Removed | In ActionScript 3.0, use the new operator to create movie clips.
createTextField() Method | Removed | In ActionScript 3.0, use the new operator to create text fields.
curveTo() Method | flash.display.Graphics.curveTo()
duplicateMovieClip() Method | Removed | In ActionScript 3.0, use the new operator to create a new instance.
endFill() Method | flash.display.Graphics.endFill()
getBounds() Method | flash.display.DisplayObject.getBounds()
getBytesLoaded() Method | flash.net.URLLoader.bytesLoaded | Moved to URLLoader class and data type changed from Number to int.
getBytesTotal() Method | flash.net.URLLoader.bytesTotal | Moved to URLLoader class and data type changed from Number to int.
getDepth() Method | flash.display.DisplayObjectContainer.getChildIndex() | ActionScript 3.0 provides direct access to the display list, so depth is handled differently.
getInstanceAtDepth() Method | flash.display.DisplayObjectContainer.getChildAt() | ActionScript 3.0 provides direct access to the display list, so depth is handled differently.
getNextHighestDepth() Method | flash.display.DisplayObjectContainer.addChild() | Not a direct equivalent, but the addChild() method adds a child behind all other children of the DisplayObjectContainer instance, so there is no need for a method that determines the next available depth.
getRect() Method | flash.display.DisplayObject.getRect()
getSWFVersion() Method | flash.display.LoaderInfo.swfVersion | Moved to LoaderInfo class and changed data type to uint.
getTextSnapshot() Method | flash.display.DisplayObjectContainer.textSnapshot
getURL() Method | flash.net.navigateToURL() | Replaced by the flash.net.navigateToURL() and flash.net.sentToURL() methods. Also see URLLoader class.
globalToLocal() Method | flash.display.DisplayObject.globalToLocal()
gotoAndStop() Method | flash.display.MovieClip.gotoAndStop()
hitTest() Method | flash.display.DisplayObject.hitTestObject()
lineGradientStyle() Method | flash.display.Graphics.lineGradientStyle()
lineStyle() Method | flash.display.Graphics.lineStyle()
lineTo() Method | flash.display.Graphics.lineTo()
loadMovie() Method | flash.display.Loader.load() | See Loader class.
loadVariables() Method | flash.net.URLLoader | Removed. See URLLoader class.
localToGlobal() Method | flash.display.DisplayObject.localToGlobal()
moveTo() Method | flash.display.Graphics.moveTo()
nextFrame() Method | flash.display.MovieClip.nextFrame()
onData() EventHandler | flash.display.LoaderInfo dispatches event: complete | Replaced in the new event model by a complete event, which is dispatched when the download operation is complete but before any data is parsed.
onDragOut() EventHandler | flash.display.InteractiveObject dispatches event: mouseOut | Replaced in the new event model by a mouseOut event, after a call to InteractiveObject.setCapture().
onDragOver() EventHandler | flash.display.InteractiveObject dispatches event: mouseOver | Replaced in the new event model by a mouseOver event, after a call to InteractiveObject.setCapture().
onEnterFrame() EventHandler | flash.display.DisplayObject dispatches event: enterFrame | Replaced in the new event model by an enterFrame event.
onKeyDown() EventHandler | flash.display.InteractiveObject dispatches event: keyDown | Replaced in the new event model by a keyDown event.
onKeyUp() EventHandler | flash.display.InteractiveObject dispatches event: keyUp | Replaced in the new event model by a keyUp event.
onKillFocus() EventHandler | flash.display.InteractiveObject dispatches event: focusOut | Replaced in the new event model by a focusOut event.
onLoad() EventHandler | flash.display.LoaderInfo dispatches event: complete | Also see URLLoader class. A complete event is dispatched when the download operation is complete.
onMouseDown() EventHandler | flash.display.InteractiveObject dispatches event: mouseDown | Replaced in the new event model by a mouseDown event.
onMouseMove() EventHandler | flash.display.InteractiveObject dispatches event: mouseMove | Replaced in the new event model by a mouseMove event.
onMouseUp() EventHandler | flash.display.InteractiveObject dispatches event: mouseUp | Replaced in the new event model by a mouseUp event.
onPress() EventHandler | flash.display.InteractiveObject dispatches event: mouseDown | Replaced in the new event model by a mouseDown event.
onRelease() EventHandler | flash.display.InteractiveObject dispatches event: mouseUp | Replaced in the new event model by a mouseUp event.
onReleaseOutside() EventHandler | flash.display.InteractiveObject dispatches event: mouseUp | Replaced in the new event model by a mouseUp event after a call to flash.display.InteractiveObject.setCapture().
onRollOut() EventHandler | flash.display.InteractiveObject dispatches event: mouseOut | Replaced in the new event model by a mouseOut event.
onRollOver() EventHandler | flash.display.InteractiveObject dispatches event: mouseOver | Replaced in the new event model by a mouseOver event.
onSetFocus() EventHandler | flash.display.InteractiveObject dispatches event: focusIn | Replaced in the new event model by a focusIn event.
onUnload() EventHandler | flash.display.LoaderInfo dispatches event: unload | Replaced in the new event model by an unload event.
play() Method | flash.display.MovieClip.play()
prevFrame() Method | flash.display.MovieClip.prevFrame()
removeMovieClip() Method | flash.display.DisplayObjectContainer.removeChild() | Removed. Call the removeChild() method of the parent display object container that contains the movie clip.
setMask() Method | flash.display.DisplayObject.mask
startDrag() Method | flash.display.Sprite.startDrag()
stop() Method | flash.display.MovieClip.stop()
stopDrag() Method | flash.display.Sprite.stopDrag()
swapDepths() Method | Removed | In ActionScript 3.0, you can achieve similar functionality by using the methods of the DisplayObjectContainer class, such as the addChildAt(), setChildIndex(), swapChildren(), and swapChildrenAt() methods.
unloadMovie() Method | flash.display.Loader.unload()
MovieClipLoader class | flash.display.Loader | Replaced by the flash.display.Loader class.
MovieClipLoader Constructor | flash.display.Loader.Loader()
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new event model, there is no need to have a class-specific addListener() method, because the class inherits the addEventListener() method from the EventDispatcher class.
getProgress() Method | flash.display.LoaderInfo dispatches event: progress | Replaced in the new event model by a progress event. Event objects of progress type contain properties named bytesLoaded and bytesTotal.
loadClip() Method | flash.display.Loader.load() | Replaced by the load() method of flash.display.Loader class.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new event model, there is no need to have a class-specific removeListener() method, because the class inherits the removeEventListener() method from the EventDispatcher class.
unloadClip() Method | flash.display.Loader.unload() | Replaced by unload() method of flash.display.Loader class.
onLoadComplete Listener | flash.display.LoaderInfo dispatches event: complete | Replaced in the new event model by a complete event.
onLoadError Listener | flash.display.LoaderInfo dispatches event: ioError | Replaced in the new event model by an ioError event.
onLoadInit Listener | flash.display.LoaderInfo dispatches event: init | Replaced in the new event model by an init event.
onLoadProgress Listener | flash.display.LoaderInfo dispatches event: progress | Replaced in the new event model by a progress event.
onLoadStart Listener | flash.display.LoaderInfo dispatches event: open | Replaced in the new event model by an open event.
NetConnection class | flash.net.NetConnection | This class has been moved to the flash.net package.
NetConnection Constructor | flash.net.NetConnection.NetConnection()
connect() Constructor | flash.net.NetConnection.connect() | ActionScript 3.0 version adds a ...(rest) parameter.
NetStream class | flash.net.NetStream | This class has been moved to the flash.net package.
bytesLoaded Property[read-only] | flash.net.NetStream.bytesLoaded | Data type changed to uint.
bytesTotal Property[read-only] | flash.net.NetStream.bytesTotal | Data type changed to uint.
currentFps Property[read-only] | flash.net.NetStream.currentFPS | In ActionScript 3.0, FPS is all uppercase.
onStatus() EventHandler | flash.net.NetStream dispatches event: netStatus | Replaced in the new event model by a netStatus event.
pause() Method | flash.net.NetStream.pause() | In ActionScript 3.0, the pause method does not take a parameter. Two new methods are available to achieve the same functionality: resume() and togglePause().
play() Method | flash.net.NetStream.play() | The name, start, len, and reset parameters are no longer valid; ...arguments is used instead.
setBufferTime() Method | flash.net.NetStream.bufferTime | In ActionScript 3.0, changed to read-write accessor property.
Number class | Number
Number Constructor | Number.Number() | In ActionScript 3.0, the Number() constructor and the Number() global function have the same effect. Also, there is no difference between a Number object and a literal Number value.
Object class | Object
__proto__ Property | Removed | In ActionScript 3.0, direct manipulation of the prototype chain is not allowed. To create a subclass, use the extends statement in the subclass declaration. For information about an object's inheritance tree and data type, use the new reflection API flash.utils.describeType().
__resolve Property | flash.utils.Proxy | Use the new Proxy class for similar functionality.
addProperty() Method | Removed | In ActionScript 3.0, accessor properties can be created directly using the keywords get and set.
registerClass() Method | Removed | In ActionScript 3.0, all classes are registered by default. If you are encoding an object using AMF, the class of the object is not preserved during the encoding process unless you use the flash.utils.registerClassAlias() function.
unwatch() Method | Removed
watch() Method | Removed | Use accessor properties (get/set functions) or the flash.utils.Proxy class for similar functionality.
PrintJob class | flash.printing.PrintJob
orientation Property[read-only] | flash.printing.PrintJob.orientation | This property now has a value from the PrintJobOrientation class.
pageHeight Property[read-only] | flash.printing.PrintJob.pageHeight | Data type changed to int.
pageWidth Property[read-only] | flash.printing.PrintJob.pageWidth | Data type changed to int.
paperHeight Property[read-only] | flash.printing.PrintJob.paperHeight | Data type changed to int.
paperWidth Property[read-only] | flash.printing.PrintJob.paperWidth | Data type changed to int.
PrintJob Constructor | flash.printing.PrintJob.PrintJob()
addPage() Method | flash.printing.PrintJob.addPage() | In ActionScript 3.0, changed data types of parameters: First parameter target is a Sprite data type; second parameter printArea is a Rectangle data type; third parameter options is the new PrintJobOptions data type; and fourth parameter frameNum is an int data type.
send() Method | flash.printing.PrintJob.send()
start() Method | flash.printing.PrintJob.start()
Rectangle class
containsRectangle() Method | flash.geom.Rectangle.containsRect() | Renamed for consistency.
security class | flash.system.Security | This class has been moved to the flash.system package.
Selection class | Removed | Methods of this class have been moved to other classes.
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new event model, there is no need to have a class-specific addListener() method, because any display object inherits the addEventListener() method from the EventDispatcher class.
getBeginIndex() Method | flash.text.TextField.selectionBeginIndex | Changed from method to accessor property and name changed to selectionBeginIndex.
getCaretIndex() Method | flash.text.TextField.caretIndex | Changed from method to accessor property and name changed to caretIndex.
getEndIndex() Method | flash.text.TextField.selectionEndIndex | Changed from method to accessor property and name changed to selectionEndIndex.
getFocus() Method | flash.display.Stage.focus | Changed from method to property accessor and name changed to focus. In ActionScript 2.0 the data type of the return value is String, but in ActionScript 3.0 the property has the InteractiveObject data type.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new event model, there is no need to have a class-specific removeListener() method, because display objects inherit the removeEventListener() method from the EventDispatcher class.
setFocus() Method | flash.display.Stage.focus | Changed from method to accessor property and name changed to focus. In ActionScript 2.0 the data type of the return value is String, but in ActionScript 3.0 the property has the InteractiveObject data type.
setSelection() Method | flash.text.TextField.setSelection() | Both parameters changed from Number to uint data type.
onSetFocus Listener | flash.display.InteractiveObject dispatches event: focusIn | Replaced in the new event model by a focusIn event.
SharedObject class | flash.net.SharedObject | This class has been moved to the flash.net package.
flush() Method | flash.net.SharedObject.flush() | This method no longer returns a Boolean value. If the flush fails, Flash Player throws an exception; if the flush succeeds or is pending user interaction, Flash Player returns a string "flushed" or "pending". Also, the data type of the minDiskSpace parameter changed to int.
getSize() Method | flash.net.SharedObject.size | Changed to accessor property. Data type changed to uint.
onStatus() EventHandler | flash.net.SharedObject dispatches event: netStatus | Replaced in the new event model by a netStatus event.
Sound class | flash.media.Sound | This class has been moved to the flash.media package.
checkPolicyFile | flash.media.SoundChannel.stop() | Replaced by the flash.media.SoundChannel.stop() method.
duration Property[read-only] | flash.media.Sound.length
id3 Property[read-only] | flash.media.Sound.id3 | Data type changed from Object to ID3Info. ID3Info is a new class that contains the ID3 properties. Also, the spelling of the songname property changed to songName.
position Property[read-only] | flash.media.SoundChannel.position | Moved to the SoundChannel class.
attachSound() Method | Removed | Create an instance of a Sound subclass that is associated with sound data; for example, by using new Sound() instead.
getBytesLoaded() Method | flash.media.Sound.bytesLoaded | Changed to accessor property and data type changed to uint.
getBytesTotal() Method | flash.media.Sound.bytesTotal | Changed to property accessor and data type changed to uint.
getPan() Method | flash.media.SoundTransform.pan | Changed to accessor property and moved to the SoundTransform class.
getTransform() Method | flash.media.SoundMixer.soundTransform | Changed to accessor property and data type changed to SoundTransform.
getVolume() Method | flash.media.SoundTransform.volume | Set the flash.media.SoundTransform.volume property to control sound volume.
loadSound() Method | flash.media.Sound.load() | The first parameter changed from a simple URL string to a URLRequest object. The second parameter changed from a Boolean value representing whether sound begins playing as soon as possible to a SoundLoaderContext object.
onID3() EventHandler | flash.media.Sound dispatches event: id3 | Replaced in the new event model by an id3 event.
onLoad() EventHandler | flash.media.Sound dispatches event: complete | Replaced in the new event model by a complete event.
onSoundComplete() EventHandler | flash.media.SoundChannel dispatches event: soundComplete | Replaced in the new event model by a soundComplete event.
setPan() Method | flash.media.SoundTransform.pan | Changed to accessor property and moved to SoundTransform class.
setTransform() Method | flash.media.SoundMixer.soundTransform | Changed to accessor property and data type changed to SoundTransform.
setVolume() Method | flash.media.SoundChannel | Removed. Use flash.media.SoundChannel.leftPeak and flash.media.SoundChannel.rightPeak to monitor the amplitude of a sound channel.
start() Method | flash.media.Sound.play() | The loops parameter data type changed from Number to int. Added a third parameter, sndTransform, to specify the initial sound transform to be used by the sound channel.
stop() Method | flash.media.SoundChannel.stop()
Stage class | flash.display.Stage | This class has been moved to the flash.display package. In ActionScript 3.0, the Stage is no longer a global object. You access the Stage by using the new DisplayObject.stage property.
align Property | flash.display.Stage.align
height Property | flash.display.Stage.stageHeight | Name changed from height to stageHeight so that it does not conflict with the flash.display.DisplayObject.height property.
scaleMode Property | flash.display.Stage.scaleMode
showMenu Property | flash.display.Stage.showDefaultContextMenu | Name changed to better reflect which menu is shown.
width Property | flash.display.Stage.stageWidth | Name changed from width to stageWidth so that it does not conflict with the flash.display.DisplayObject.width property.
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new event model, there is no need to have a class-specific addListener() method, because the class inherits the addEventListener() method from the EventDispatcher class.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new event model, there is no need to have a class-specific removeListener() method, because the class inherits the removeEventListener() method from the EventDispatcher class.
onResize Listener | flash.display.Stage dispatches event: resize | Replaced in the new event model by a resize event.
String class | String | Adds support for regular expressions with three new methods: match(), replace(), and search().
concat() Method | String.concat() | Parameter changed to ...(rest) parameter format.
StyleSheet class | flash.text.StyleSheet | This class has been moved to the flash.text package. The load() and onLoad() members have been removed, and some private functions and variables have been added.
StyleSheet Constructor | flash.text.StyleSheet.StyleSheet()
clear() Method | flash.text.StyleSheet.clear()
getStyle() Method | flash.text.StyleSheet.getStyle() | Parameter name changed to n.
getStyleNames() Method | flash.text.StyleSheet.styleNames | Changed to accessor property.
load() Method | flash.net.URLLoader.load() | Use the new URLLoader and URLRequest classes for loading URLs.
onLoad() EventHandler | flash.net.URLLoader dispatches event: complete | Replaced in the new event model by a complete event.
parseCSS() Method | flash.text.StyleSheet.parseCSS() | In ActionScript 3.0, returns void instead of a Boolean value.
setStyle() Method | flash.text.StyleSheet.setStyle() | Parameter name changed to n and style to s.
transform() Method | flash.text.StyleSheet.transform()
System class | flash.system.System
exactSettings Property | flash.system.Security.exactSettings | Moved to the flash.System.Security class.
useCodepage Property | flash.system.System.useCodePage | In ActionScript 3.0, the letter 'P' in useCodePage is uppercase.
onStatus() EventHandler | Removed
setClipboard() Method | flash.system.System.setClipboard()
showSettings() Method | flash.system.Security.showSettings()
TextField class | flash.text.TextField | This class has been moved to the flash.text package.
_alpha Property | flash.display.DisplayObject.alpha | This property is now inherited from the DisplayObject class. Removed the initial underscore.
antiAliasType Property | flash.text.TextField.antiAliasType
autoSize Property | flash.text.TextField.autoSize
background Property | flash.text.TextField.background
backgroundColor Property | flash.text.TextField.backgroundColor
border Property | flash.text.TextField.border
borderColor Property | flash.text.TextField.borderColor | In ActionScript 3.0, returns a uint instead of a Number.
bottomScroll Property[read-only] | flash.text.TextField.bottomScrollV | In ActionScript 3.0, returns a uint instead of a Number.
condenseWhite Property | flash.text.TextField.condenseWhite
embedFonts Property | flash.text.TextField.embedFonts
filters Property | flash.display.DisplayObject.filters
gridFitType Property | flash.text.TextField.gridFitType
_height Property | flash.display.DisplayObject.height | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_highquality Property | flash.display.Stage.quality | Removed. Replaced by the quality property of the Stage class.
hscroll Property | flash.text.TextField.scrollH | Data type changed from Number to uint. Name changed from hscroll to scrollH.
html Property | flash.text.TextField.htmlText | Removed. In ActionScript 3.0, all text fields are treated as HTML text fields. Use the TextField.htmlText property to set HTML text.
htmlText Property | flash.text.TextField.htmlText
length Property[read-only] | flash.text.TextField.length | Data type changed from Number to uint.
maxChars Property | flash.text.TextField.maxChars | Data type changed from Number to uint.
maxhscroll Property[read-only] | flash.text.TextField.maxScrollH | Data type changed from Number to uint.
maxscroll Property[read-only] | flash.text.TextField.maxScrollV | Data type changed from Number to uint. Name changed to use uppercase S and to add the letter V to represent vertical scrolling.
menu Property | flash.display.InteractiveObject.contextMenu | This property is now inherited from the InteractiveObject class.
mouseWheelEnabled Property | flash.text.TextField.mouseWheelEnabled
multiline Property | flash.text.TextField.multiline
_name Property | flash.display.DisplayObject.name | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_parent Property | flash.display.DisplayObject.parent | This property is now inherited from the DisplayObject class. Removed the initial underscore. Data type changed from MovieClip to DisplayObjectContainer.
password Property | flash.text.TextField.displayAsPassword | Renamed property for consistency.
_quality Property | flash.display.Stage.quality | Moved to Stage class.
restrict Property | flash.text.TextField.restrict
_rotation Property | flash.display.DisplayObject.rotation | This property is now inherited from the DisplayObject class. Removed the initial underscore.
scroll Property | flash.text.TextField.scrollV | Data type changed from Number to uint and name changed from scroll to scrollV.
selectable Property | flash.text.TextField.selectable
sharpness Property | flash.text.TextField.sharpness
_soundbuftime Property | flash.media.SoundMixer.bufferTime | Properties and methods for global sound control in a SWF file are now in the flash.media.SoundMixer class.
styleSheet Property | flash.text.TextField.styleSheet
tabEnabled Property | flash.display.InteractiveObject.tabEnabled | This property is now inherited from the InteractiveObject class.
tabIndex Property | flash.display.InteractiveObject.tabIndex | This property is now inherited from the InteractiveObject class.
_target Property[read-only] | Removed
text Property | flash.text.TextField.text
textColor Property | flash.text.TextField.textColor | Data type changed from Number to uint.
textHeight Property | flash.text.TextField.textHeight
textWidth Property | flash.text.TextField.textWidth
thickness Property | flash.text.TextField.thickness
type Property | flash.text.TextField.type
_url Property[read-only] | flash.display.LoaderInfo.url
variable Property | Removed
_visible Property | flash.display.DisplayObject.visible | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_width Property | flash.display.DisplayObject.width | This property is now inherited from the DisplayObject class. Removed the initial underscore.
wordWrap Property | flash.text.TextField.wordWrap
_x Property | flash.display.DisplayObject.x | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_xmouse Property[read-only] | flash.display.DisplayObject.mouseX | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_xscale Property | flash.display.DisplayObject.scaleX | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_y Property | flash.display.DisplayObject.y | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_ymouse Property[read-only] | flash.display.DisplayObject.mouseY | This property is now inherited from the DisplayObject class. Removed the initial underscore.
_yscale Property | flash.display.DisplayObject.scaleY | This property is now inherited from the DisplayObject class. Removed the initial underscore.
addListener() Method | flash.events.EventDispatcher.addEventListener() | In the new event model, there is no need to have a class-specific addListener() method, because the class inherits the addEventListener() method from the EventDispatcher class.
getDepth() Method | flash.display.DisplayObjectContainer | Removed. Use the methods of the DisplayObjectContainer class to ascertain text field depth.
getFontList() Method | flash.text.Font.enumerateFonts() | Removed. Use Font.enumerateFonts() with the enumerateDeviceFonts parameter set to true.
getNewTextFormat() Method | flash.text.TextField.defaultTextFormat | Name changed from getNewTextFormat to defaultTextFormat. Changed from method to accessor property.
getTextFormat() Method | flash.text.TextField.getTextFormat() | Data type of both parameters changed from Number to uint.
onChanged() EventHandler | flash.text.TextField dispatches event: change | Replaced in the new event model by a change event.
onKillFocus() EventHandler | flash.display.InteractiveObject dispatches event: focusOut | Replaced in the new event model by a focusOut event.
onScroller() EventHandler | flash.text.TextField dispatches event: scroll | Replaced in the new event model by a scroll event.
onSetFocus() EventHandler | flash.display.InteractiveObject dispatches event: focusIn | Replaced in the new event model by a focusIn event.
removeListener() Method | flash.events.EventDispatcher.removeEventListener() | In the new event model, there is no need to have a class-specific removeListener() method, because the class inherits the removeEventListener() method from the EventDispatcher class.
removeTextField() Method | flash.display.DisplayObjectContainer.removeChild() | Removed. Call the removeChild() method of the parent display object container that contains the text field.
replaceSel() Method | flash.text.TextField.replaceSelectedText() | Name changed from replacesel() to replaceSelectedText(). Replaced the newText parameter with a string value.
replaceText() Method | flash.text.TextField.replaceText() | Data types of first two parameters changed from Number to uint.
setNewTextFormat() Method | flash.text.TextField.defaultTextFormat | Name changed from setNewTextFormat to defaultTextFormat. Changed from method to accessor property.
setTextFormat() Method | flash.text.TextField.setTextFormat() | Order of parameters changed. Index parameters data type changed from Number to int.
TextFormat class | flash.text.TextFormat | This class has been moved to the flash.text package.
align Property | flash.text.TextFormat.align
blockIndent Property | flash.text.TextFormat.blockIndent | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
bold Property | flash.text.TextFormat.bold | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Boolean data type in ActionScript 3.0.
bullet Property | flash.text.TextFormat.bullet | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Boolean data type in ActionScript 3.0.
color Property | flash.text.TextFormat.color | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
font Property | flash.text.TextFormat.font
indent Property | flash.text.TextFormat.indent | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
italic Property | flash.text.TextFormat.bullet | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Boolean data type in ActionScript 3.0.
kerning Property | flash.text.TextFormat.kerning | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Boolean data type in ActionScript 3.0.
leading Property | flash.text.TextFormat.leading | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
leftMargin Property | flash.text.TextFormat.leftMargin | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
letterSpacing Property | flash.text.TextFormat.letterSpacing | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
rightMargin Property | flash.text.TextFormat.rightMargin | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
size Property | flash.text.TextFormat.size | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Number data type in ActionScript 3.0.
underline Property | flash.text.TextFormat.underline | In ActionScript 3.0, data type changed to Object because one of the possible values is null, which is not a member of the Boolean data type in ActionScript 3.0.
url Property | flash.text.TextFormat.url
TextFormat Constructor | flash.text.TextFormat.TextFormat() | The size, color, bold, italic, underline, url, leftMargin, rightMargin, indent, and leading parameters have all been converted to objects.
getTextExtent() Method | Removed | Use the properties of flash.text.TextField for the measurements of a field containing a line of text, and use flash.text.TextLineMetrics for the measurements of the content within the text field.
TextRenderer class | flash.text.TextRenderer | Location changed. Moved to flash.text package.
maxLevel Property | flash.text.TextRenderer.maxLevel | Defined as a uint in ActionScript 3.0.
setAdvancedAntialiasingTable() Method | flash.text.TextRenderer.setAdvancedAntiAliasingTable() | The fontStyle and colorType parameter values can now be set using the FontStyle and TextColorType constants, respectively. The advancedAntiAliasingTable parameter now takes an array of one or more CSMSettings objects.
TextSnapshot class | flash.text.TextSnapshot | This class has been moved to the flash.text package. Several parameters have changed, as well as some method names and some return types.
findText() Method | flash.text.TextSnapshot.findText() | Name of the startIndex parameter changed to beginIndex. Data type of the startIndex parameter changed from Number to int.
getCount() Method | flash.text.TextSnapshot.charCount | Changed from method to accessor property. Data return type changed from Number to uint.
getSelected() Method | flash.text.TextSnapshot.getSelected() | Data type of parameters changed from Number to uint and names changed from start and end to beginIndex and EndIndex.
getSelectedText() Method | flash.text.TextSnapshot.getSelectedText() | In ActionScript 3.0, the parameter has a default value of false.
getText() Method | flash.text.TextSnapshot.getText() | Data type of start and end parameters changed from Number to uint and names changed from start and end to beginIndex and endIndex.
getTextRunInfo() Method | flash.text.TextSnapshot.getTextRunInfo() | Data type of parameters changed from Number to uint.
hitTestTextNearPos() Method | flash.text.TextSnapshot.hitTestTextNearPos() | Name of the closeDist parameter changed to maxDistance; now has a default value = 0.
setSelectColor() Method | flash.text.TextSnapshot.setSelectColor() | Data type of parameter changed from Number to uint and has a default value = 0xFFFF00.
setSelected() Method | flash.text.TextSnapshot.setSelected() | Data type of start and end parameters changed from Number to uint and names changed from start and end to beginIndex and endIndex.
Video class | flash.media.Video | This class has been moved to the flash.media package. Video objects can now be created dynamically in ActionScript with the Video() constructor. Attach a video stream to the Video object by using attachCamera() or attachNetStream().
_alpha Property | flash.display.DisplayObject.alpha | This property is inherited from the DisplayObject class. Removed the initial underscore.
deblocking Property | flash.media.Video.deblocking | Data type changed from Number to int.
_height Property | flash.display.DisplayObject.height | This property is inherited from the DisplayObject class Removed the initial underscore.
height Property[read-only] | flash.media.Video.videoHeight | Data type changed from Number to int.
_name Property | flash.display.DisplayObject.name | This property is inherited from the DisplayObject class. Removed the initial underscore.
_parent Property | flash.display.DisplayObject.parent | This property is inherited from the DisplayObject class. Removed the initial underscore.
_rotation Property | flash.display.DisplayObject.rotation | This property is inherited from the DisplayObject class. Removed the initial underscore.
smoothing Property | flash.media.Video.smoothing
_visible Property | flash.display.DisplayObject.visible | This property is inherited from the DisplayObject class. Removed the initial underscore.
_width Property | flash.display.DisplayObject.width | This property is inherited from the DisplayObject class. Removed the initial underscore.
width Property[read-only] | flash.media.Video.videoWidth | Data type changed from Number to int.
_x Property | flash.display.DisplayObject.x | This property is inherited from the DisplayObject class. Removed the initial underscore.
_xmouse Property[read-only] | flash.display.DisplayObject.mouseX | This property is inherited from the DisplayObject class. Removed the initial underscore.
_xscale Property | flash.display.DisplayObject.scaleX | This property is inherited from the DisplayObject class. Removed the initial underscore.
_y Property | flash.display.DisplayObject.y | This property is inherited from the DisplayObject class. Removed the initial underscore.
_ymouse Property[read-only] | flash.display.DisplayObject.mouseY | This property is inherited from the DisplayObject class. Removed the initial underscore.
_yscale Property | flash.display.DisplayObject.scaleY | This property is inherited from the DisplayObject class. Removed the initial underscore.
attachVideo() Method | flash.media.Video.attachNetStream() | To specify a video stream from a camera object, use flash.media.Video.attachCamera().
clear() Method | flash.media.Video.clear()
XML class | flash.xml.XMLDocument | This class has been moved to the flash.xml package and its name has been changed to XMLDocument to avoid conflict with the new top-level XML class that implements ECMAScript for XML (E4X).
contentType Property | flash.net.URLRequest.contentType
docTypeDecl Property | flash.xml.XMLDocument.docTypeDecl
idMap Property | flash.xml.XMLDocument.idMap
ignoreWhite Property | flash.xml.XMLDocument.ignoreWhite
loaded Property | Removed | File loading functionality was removed from the XMLDocument class. Use URLLoader instead.
status Property | Removed | Parse failures are now reported by exceptions.
xmlDecl Property | flash.xml.XMLDocument.xmlDecl
XML Constructor | flash.xml.XMLDocument.XMLDocument()
addRequestHeader() Method | flash.net.URLRequest.requestHeaders
createElement() Method | flash.xml.XMLDocument.createElement()
createTextNode() Method | flash.xml.XMLDocument.createTextNode()
getBytesLoaded() Method | flash.net.URLLoader.bytesLoaded | File loading functionality was removed from the XMLDocument class. Use URLLoader instead.
getBytesTotal() Method | flash.net.URLLoader.bytesTotal | File loading functionality was removed from the XMLDocument class. Use URLLoader instead.
load() Method | Removed | File loading functionality was removed from the XMLDocument class (formerly the XML class in ActionScript 2.0). Use URLLoader instead.
onData() EventHandler | flash.net.URLLoader dispatches event: complete | File loading functionality was removed from the XMLDocument class. Use URLLoader instead. Replaced in the new event model by a complete event.
onHTTPStatus() EventHandler | flash.net.URLLoader dispatches event: httpStatus | File loading functionality was removed from the XMLDocument class. Use URLLoader instead. Replaced in the new event model by an httpStatus event.
onLoad() EventHandler | flash.net.URLLoader dispatches event: complete | File loading functionality was removed from the XMLDocument class. Use URLLoader instead. Replaced in the new event model by a complete event.
parseXML() Method | flash.xml.XMLDocument.parseXML()
send() Method | Removed | Send functionality was removed from the XMLDocument class (formerly the XML class in ActionScript 2.0). Use the functions and classes of the flash.net package instead.
sendAndLoad() Method | Removed | Send and load functionality were removed from the XMLDocument class (formerly the XML class in ActionScript 2.0). Use URLRequest and URLLoader instead.
XMLNode class | flash.xml.XMLNode | Location changed. This class has been moved to the flash.xml package.
nodeType Property[read-only] | flash.xml.XMLNode.nodeType | Data type changed from Number to uint.
XMLNode Constructor | flash.xml.XMLNode.XMLNode() | Data type of the type parameter changed from Number to uint.
XMLSocket class | flash.net.XMLSocket | This class has been moved to the flash.net package.
XMLSocket Constructor | flash.net.XMLSocket.XMLSocket() | Added two optional parameters to specify host and port.
connect() Method | flash.net.XMLSocket.connect() | Data type of the port parameter changed to int.
onClose() EventHandler | flash.net.XMLSocket dispatches event: close | Replaced in the new event model by a close event.
onConnect() EventHandler | flash.net.XMLSocket dispatches event: connect | Replaced in the new event model by a connect event.
onData() EventHandler | flash.net.XMLSocket dispatches event: data | Replaced in the new event model by a data event.
onXML() EventHandler | Removed | In ActionScript 3.0, only the data event is dispatched, so that you can choose whether to use E4X or the legacy XML (XMLDocument class) parser. The old onXML event handler was called after XML was parsed, so it doesn't make sense in ActionScript 3.0 because you can now choose between the XML (E4X) class and the XMLDocument (legacy) class to parse the XML.

All Packages | All Classes | Language Elements | Index | Appendixes | Conventions | No Frames


Conventions (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Conventions

This page explains the conventions used in the Adobe Flex 2 Language ReferenceActionScript 3.0 Language Reference.

Typographical conventions

This reference uses the following typographical conventions:

  • Italic font indicates a value that you replace with a specific value.
  • Bold font indicates language elements.
  • Code font indicates code snippets or language elements in the text.
  • In ActionScript, double forward slashes (//) precede comments.
  • In ActionScript, forward slashes and asterisks (/*... */) denote the beginning and end, respectively, of commented lines.
  • In MXML, the characters <!-- and --> denote the beginning and end of commented lines, respectively.
  • Numeric value ranges in code are represented as 0..59.

Note: In code examples, long lines of code may be broken for readability. If an error occurs when you copy and paste example code, verify that a long line of code does not contain a return.

Presentation of class APIs

APIs are presented in typical API documentation format, but with the following modifications to help you better understand the ActionScript language:

  • The Package entry lists the package to which the class belongs.
  • The Class entry lists the class and its attributes.
  • Inheritance information shows the inheritance path and list inherited elements. Two types of arrow indicate inheritance:
    • In the Inheritance entry at the top of the class description, a right-hand arrow points to the superclass that the class inherits from.
    • In the Public Properties and Public Methods sections, an upward arrow appears to the left of a property or method inherited from another class.
  • The Implements entry lists any interfaces that the class implements.
  • The Subclasses entry lists any classes that inherit from this class.
  • Constructors are listed as the first method in each Public Methods summary; thereafter, the methods are listed alphabetically.
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


All Classes - Adobe® Flex™ 2 Language Reference

All Classes

AbstractEvent
AbstractInvoker
AbstractMessage
AbstractOperation
AbstractService
AbstractTarget
Accessibility
AccessibilityProperties
Accordion
AccordionHeader
AccordionHeaderSkin
AcknowledgeMessage
ActionEffectInstance
ActionScriptVersion
ActivatorSkin
ActivityEvent
AddChild
AddChildAction
AddChildActionInstance
Alert
AMFChannel
AnimateProperty
AnimatePropertyInstance
AntiAliasType
Application
ApplicationControlBar
ApplicationDomain
AreaChart
AreaRenderer
AreaSeries
AreaSeriesItem
AreaSeriesRenderData
AreaSet
ArgumentError
arguments
Array
ArrayCollection
ArrayUtil
AsyncErrorEvent
AsyncMessage
AsyncRequest
AsyncToken
AVM1Movie
AxisBase
AxisLabel
AxisLabelSet
AxisRenderer
Back
BarChart
BarSeries
BarSeriesItem
BarSeriesRenderData
BarSet
BaseListData
BevelFilter
BindingUtils
Bitmap
BitmapAsset
BitmapData
BitmapDataChannel
BitmapFill
BitmapFilter
BitmapFilterQuality
BitmapFilterType
BlendMode
Blur
BlurFilter
BlurInstance
Boolean
Border
Bounce
BoundedValue
Box
BoxDirection
BoxItemRenderer
BrokenImageBorderSkin
BubbleChart
BubbleSeries
BubbleSeriesItem
BubbleSeriesRenderData
Button
ButtonAsset
ButtonBar
ButtonBarButtonSkin
ButtonLabelPlacement
ButtonSkin
ByteArray
CalendarLayoutChangeEvent
Camera
CandlestickChart
CandlestickItemRenderer
CandlestickSeries
Canvas
Capabilities
CapsStyle
CartesianChart
CartesianTransform
CategoryAxis
ChangeWatcher
Channel
ChannelError
ChannelEvent
ChannelFaultEvent
ChannelSet
ChartBase
ChartElement
ChartItem
ChartItemEvent
ChartLabel
ChartState
CheckBox
CheckBoxIcon
ChildExistenceChangedEvent
CircleItemRenderer
Circular
Class
ClassFactory
CloseEvent
CollectionEvent
CollectionEventKind
CollectionViewError
ColorMatrixFilter
ColorPicker
ColorPickerEvent
ColorPickerSkin
ColorTransform
ColorUtil
ColumnChart
ColumnSeries
ColumnSeriesItem
ColumnSeriesRenderData
ColumnSet
ComboBase
ComboBox
ComboBoxArrowSkin
CommandMessage
ComponentDescriptor
CompositeEffect
CompositeEffectInstance
Conflict
ConflictDetector
Conflicts
Consumer
Container
ContainerCreationPolicy
ContainerLayout
ContextMenu
ContextMenuBuiltInItems
ContextMenuEvent
ContextMenuItem
ControlBar
ConvolutionFilter
CreditCardValidator
CreditCardValidatorCardType
CrossItemRenderer
CSMSettings
CSSStyleDeclaration
Cubic
CuePointEvent
CuePointManager
CurrencyFormatter
CurrencyValidator
CurrencyValidatorAlignSymbol
CursorBookmark
CursorError
CursorManager
CursorManagerPriority
DataAssociationMessage
DataConflictEvent
DataDescription
DataErrorMessage
DataEvent
DataGrid
DataGridBase
DataGridColumn
DataGridColumnDropIndicator
DataGridColumnResizeSkin
DataGridDragProxy
DataGridEvent
DataGridEventReason
DataGridHeaderSeparator
DataGridItemRenderer
DataGridListData
DataGridSortArrow
DataListError
DataMessage
DataService
DataService
DataServiceError
DataServiceFaultEvent
DataStore
DataTip
DataTransform
Date
DateBase
DateChooser
DateChooserEvent
DateChooserEventDetail
DateChooserIndicator
DateChooserMonthArrowSkin
DateChooserYearArrowSkin
DateField
DateFormatter
DateTimeAxis
DateValidator
DefaultDataDescriptor
DeferredInstanceFromClass
DeferredInstanceFromFunction
DefinitionError
DescribeTypeCache
DescribeTypeCacheRecord
DiamondItemRenderer
Dictionary
DisplacementMapFilter
DisplacementMapFilterMode
DisplayObject
DisplayObjectContainer
Dissolve
DissolveInstance
DividedBox
DividerEvent
DownloadProgressBar
DragEvent
DragManager
DragSource
DropdownEvent
DropShadowFilter
DualStyleObject
DynamicEvent
EdgeMetrics
Effect
EffectEvent
EffectInstance
EffectManager
EffectTargetFilter
Elastic
EmailValidator
Endian
EOFError
Error
ErrorEvent
ErrorMessage
EvalError
Event
EventDispatcher
EventPhase
EventPriority
Exponential
ExternalInterface
Fade
FadeInstance
Fault
FaultEvent
FileFilter
FileReference
FileReferenceList
FlexBitmap
FlexEvent
FlexMouseEvent
FlexMovieClip
FlexPrintJob
FlexPrintJobScaleType
FlexShape
FlexSimpleButton
FlexSprite
FlexTextField
FocusEvent
FocusManager
Font
FontStyle
FontType
Form
Formatter
FormHeading
FormItem
FormItemDirection
FormItemLabel
FrameLabel
Function
Glow
GlowFilter
GlowInstance
GradientBevelFilter
GradientEntry
GradientGlowFilter
GradientType
Graphics
GraphicsUtil
Grid
GridFitType
GridItem
GridLines
GridRow
HaloBorder
HaloColors
HaloFocusRect
HBox
HDividedBox
HeaderEvent
HistoryManager
HitData
HLOCChart
HLOCItemRenderer
HLOCSeries
HLOCSeriesBase
HLOCSeriesItem
HLOCSeriesRenderData
HorizontalList
HRule
HScrollBar
HSlider
HTTPChannel
HTTPRequestMessage
HTTPService
HTTPService
HTTPStatusEvent
IAccessPrivileges
IAxis
IAxisRenderer
IBar
IBitmapDrawable
IChangeObject
IChartElement
IChildList
ICollectionView
IColumn
IContainer
ID3Info
IDataInput
IDataOutput
IDataRenderer
IDeferredInstance
IDeferredInstantiationUIComponent
IDropInListItemRenderer
IDynamicPropertyOutput
IDynamicPropertyWriter
IEventDispatcher
IExternalizable
IFactory
IFill
IFlexAsset
IFlexDisplayObject
IFocusManager
IFocusManagerComponent
IFocusManagerContainer
IFocusManagerGroup
IHistoryManagerClient
IIMESupport
IInvalidating
ILayoutManagerClient
IList
IListItemRenderer
IllegalOperationError
ILogger
ILoggingTarget
Image
IManaged
IME
IMEConversionMode
IMEEvent
IMenuDataDescriptor
IMenuItemRenderer
IMessage
IMXMLObject
IMXMLSupport
IndexChangedEvent
InstanceCache
int
InteractiveObject
InterpolationMethod
InvalidCategoryError
InvalidChannelError
InvalidDestinationError
InvalidFilterError
InvalidSWFError
InvokeEvent
IOError
IOErrorEvent
IOverride
IPreloaderDisplay
IPropertyChangeNotifier
IRawChildrenContainer
IRepeater
IRepeaterClient
IResponder
Iris
IrisInstance
ISimpleStyleClient
IStackable
IStroke
IStyleClient
ISystemManager
ItemClickEvent
ItemPendingError
ItemReference
ItemResponder
IToolTip
IToolTipManagerClient
ITreeDataDescriptor
IUIComponent
IUID
IValidatorListener
IViewCursor
JointStyle
Keyboard
KeyboardEvent
KeyLocation
Label
LayoutManager
Legend
LegendData
LegendItem
LegendMouseEvent
Linear
LinearAxis
LinearGradient
LinearGradientStroke
LineChart
LineFormattedTarget
LineRenderer
LineScaleMode
LineSeries
LineSeriesItem
LineSeriesRenderData
LineSeriesSegment
LinkBar
LinkButton
LinkButtonSkin
LinkSeparator
List
ListBase
ListBaseSeekPending
ListBaseSelectionData
ListCollectionView
ListData
ListDropIndicator
ListEvent
ListEventReason
ListItemDragProxy
ListItemRenderer
ListRowInfo
Loader
LoaderConfig
LoaderContext
LoaderInfo
LoadEvent
LocalConnection
Locale
Log
LogAxis
LogEvent
LogEventLevel
LogLogger
Managed
MaskEffect
MaskEffectInstance
Math
Matrix
MBeanAttributeInfo
MBeanFeatureInfo
MBeanInfo
MBeanOperationInfo
MBeanParameterInfo
MemoryError
Menu
MenuBar
MenuBarBackgroundSkin
MenuBarItem
MenuEvent
MenuItemRenderer
MessageAckEvent
MessageAgent
MessageEvent
MessageFaultEvent
MessageResponder
MessageSerializationError
MessagingError
Microphone
MiniDebugTarget
MorphShape
Mouse
MouseEvent
Move
MoveEvent
MoveInstance
MovieClip
MovieClipAsset
MovieClipLoaderAsset
Namespace
NameUtil
NavBar
NetConnection
NetConnectionChannel
NetStatusEvent
NetStream
NoChannelAvailableError
NoDataAvailableError
Number
NumberBase
NumberBaseRoundType
NumberFormatter
NumberValidator
NumericAxis
NumericStepper
NumericStepperDownSkin
NumericStepperEvent
NumericStepperUpSkin
Object
ObjectEncoding
ObjectInstance
ObjectName
ObjectProxy
ObjectUtil
Operation
Operation
Operation
Operation
PagedMessage
PageInformation
Panel
Parallel
ParallelInstance
Pause
PauseInstance
PhoneFormatter
PhoneNumberValidator
PieChart
PieSeries
PieSeriesItem
PieSeriesRenderData
PixelSnapping
PlotChart
PlotSeries
PlotSeriesItem
PlotSeriesRenderData
Point
PolarChart
PolarTransform
PollingChannel
PopUpButton
PopUpButtonSkin
PopUpIcon
PopUpManager
PopUpManagerChildList
PopUpMenuButton
PopUpMenuIcon
Preloader
PrintDataGrid
PrintJob
PrintJobOptions
PrintJobOrientation
Producer
ProgrammaticSkin
ProgressBar
ProgressBarDirection
ProgressBarLabelPlacement
ProgressBarMode
ProgressBarSkin
ProgressEvent
ProgressIndeterminateSkin
ProgressTrackSkin
PropertyChangeEvent
PropertyChangeEventKind
PropertyChanges
Proxy
QName
Quadratic
Quartic
Quintic
RadialGradient
RadioButton
RadioButtonGroup
RadioButtonIcon
RangeError
Rectangle
RectangularBorder
RectangularDropShadow
ReferenceError
RegExp
RegExpValidationResult
RegExpValidator
RemoteObject
RemoteObject
RemotingMessage
RemoveChild
RemoveChildAction
RemoveChildActionInstance
RenderData
Repeater
Resize
ResizeEvent
ResizeInstance
ResourceBundle
Responder
ResultEvent
RichTextEditor
Rotate
RotateInstance
RoundedRectangle
RSLEvent
RTMPChannel
Scene
ScriptTimeoutError
ScrollArrowSkin
ScrollBar
ScrollBarDirection
ScrollControlBase
ScrollEvent
ScrollEventDetail
ScrollEventDirection
ScrollPolicy
ScrollThumb
ScrollThumbSkin
ScrollTrackSkin
SecureAMFChannel
SecureHTTPChannel
SecureRTMPChannel
Security
SecurityDomain
SecurityError
SecurityErrorEvent
SecurityPanel
Sequence
SequencedMessage
SequenceInstance
Series
SeriesEffect
SeriesEffectInstance
SeriesInterpolate
SeriesInterpolateInstance
SeriesSlide
SeriesSlideInstance
SeriesZoom
SeriesZoomInstance
ServerConfig
SetEventHandler
SetProperty
SetPropertyAction
SetPropertyActionInstance
SetStyle
SetStyleAction
SetStyleActionInstance
ShadowBoxItemRenderer
ShadowLineRenderer
Shape
SharedObject
SharedObjectFlushStatus
SimpleButton
SimpleXMLDecoder
SimpleXMLEncoder
Sine
Slider
SliderDataTip
SliderDirection
SliderEvent
SliderEventClickTarget
SliderHighlightSkin
SliderLabel
SliderThumb
SliderThumbSkin
SliderTrackSkin
SOAPHeader
SOAPMessage
SocialSecurityValidator
Socket
SolidColor
Sort
SortError
SortField
Sound
SoundAsset
SoundChannel
SoundEffect
SoundEffectInstance
SoundLoaderContext
SoundMixer
SoundTransform
Spacer
SpreadMethod
Sprite
SpriteAsset
StackedSeries
StackOverflowError
Stage
StageAlign
StageQuality
StageScaleMode
State
StateChangeEvent
StaticText
StatusEvent
String
StringUtil
StringValidator
Stroke
StyleManager
StyleSheet
SwatchPanelSkin
SwatchSkin
SWFLoader
SWFVersion
SwitchSymbolFormatter
SyncEvent
SyntaxError
System
SystemManager
TabBar
TabNavigator
TabSkin
Text
TextArea
TextColorType
TextDisplayMode
TextEvent
TextField
TextFieldAsset
TextFieldAutoSize
TextFieldType
TextFormat
TextFormatAlign
TextInput
TextLineMetrics
TextRange
TextRenderer
TextSnapshot
Tile
TileBase
TileBaseDirection
TileDirection
TileList
TileListItemRenderer
Timer
TimerEvent
TitleBackground
TitleWindow
ToggleButtonBar
ToolTip
ToolTipBorder
ToolTipEvent
ToolTipManager
TraceTarget
Transform
Transition
Tree
TreeEvent
TreeItemRenderer
TreeListData
TriangleItemRenderer
Tween
TweenEffect
TweenEffectInstance
TweenEvent
TypeError
UIComponent
UIComponentCachePolicy
UIComponentDescriptor
UIDUtil
uint
UITextField
UITextFormat
UnresolvedConflictsError
UnresolvedConflictsEvent
UpdateCollectionMessage
UpdateCollectionRange
URIError
URLLoader
URLLoaderDataFormat
URLRequest
URLRequestHeader
URLRequestMethod
URLStream
URLUtil
URLVariables
ValidationResult
ValidationResultEvent
Validator
VBox
VDividedBox
VerifyError
Video
VideoDisplay
VideoError
VideoEvent
ViewStack
VRule
VScrollBar
VSlider
WebService
WebService
WedgeItemRenderer
WipeDown
WipeDownInstance
WipeLeft
WipeLeftInstance
WipeRight
WipeRightInstance
WipeUp
WipeUpInstance
XML
XMLDocument
XMLList
XMLListCollection
XMLNode
XMLNodeType
XMLSocket
XMLUtil
ZipCodeFormatter
ZipCodeValidator
ZipCodeValidatorDomainType
Zoom
ZoomInstance


Supported Character Sets (Flex™ 2 Language Reference)

Adobe® Flex™ 2 Language Reference All Packages | All Classes | Language Elements | Index | Appendixes | Conventions Adobe Logo
Supported Character Sets

Flash Player supports a subset of the style character set definitions specified by the IANA (http://www.iana.org/assignments/character-sets). The following table lists the supported character sets, and either the label value or an alias value (aliases point to the same base definition) can be used to specify the desired character set:

Character Set | Label | Alias
Arabic (ASMO 708) | ASMO-708 |
Arabic (DOS) | DOS-720 |
Arabic (ISO) | iso-8859-6 | arabic, csISOLatinArabic, ECMA-114, ISO_8859-6, ISO_8859-6:1987, iso-ir-127
Arabic (Mac) | x-mac-arabic |
Arabic (Windows) | windows-1256 | cp1256
Baltic (DOS) | ibm775 | CP500
Baltic (ISO) | iso-8859-4 | csISOLatin4, ISO_8859-4, ISO_8859-4:1988, iso-ir-110, l4, latin4
Baltic (Windows) | windows-1257 |
Central European (DOS) | ibm852 | cp852
Central European (ISO) | iso-8859-2 | csISOLatin2, iso_8859-2, iso_8859-2:1987, iso8859-2, iso-ir-101, l2, latin2
Central European (Mac) | x-mac-ce |
Central European (Windows) | windows-1250 | x-cp1250
Chinese Simplified (EUC) | EUC-CN | x-euc-cn
Chinese Simplified (GB2312) | gb2312 | chinese, CN-GB, csGB2312, csGB231280, csISO58GB231280, GB_2312-80, GB231280, GB2312-80, GBK, iso-ir-58
Chinese Simplified (HZ) | hz-gb-2312 |
Chinese Simplified (Mac) | x-mac-chinesesimp |
Chinese Traditional (Big5) | big5 | cn-big5, csbig5, x-x-big5
Chinese Traditional (CNS) | x-Chinese-CNS |
Chinese Traditional (Eten) | x-Chinese-Eten |
Chinese Traditional (Mac) | x-mac-chinesetrad |
Cyrillic (DOS) | cp866 | ibm866
Cyrillic (ISO) | iso-8859-5 | csISOLatin5, csISOLatinCyrillic, cyrillic, ISO_8859-5, ISO_8859-5:1988, iso-ir-144, l5
Cyrillic (KOI8-R) | koi8-r | csKOI8R, koi, koi8, koi8r
Cyrillic (KOI8-U) | koi8-u | koi8-ru
Cyrillic (Mac) | x-mac-cyrillic |
Cyrillic (Windows) | windows-1251 | x-cp1251
Europa | x-Europa |
German (IA5) | x-IA5-German |
Greek (DOS) | ibm737 |
Greek (ISO) | iso-8859-7 | csISOLatinGreek, ECMA-118, ELOT_928, greek, greek8, ISO_8859-7, ISO_8859-7:1987, iso-ir-126
Greek (Mac) | x-mac-greek |
Greek (Windows) | windows-1253 |
Greek, Modern (DOS) | ibm869 |
Hebrew (DOS) | DOS-862 |
Hebrew (ISO-Logical) | iso-8859-8-i | logical
Hebrew (ISO-Visual) | iso-8859-8 | csISOLatinHebrew, hebrew, ISO_8859-8, ISO_8859-8:1988, ISO-8859-8, iso-ir-138, visual
Hebrew (Mac) | x-mac-hebrew |
Hebrew (Windows) | windows-1255 | ISO_8859-8-I, ISO-8859-8, visual
IBM EBCDIC (Arabic) | x-EBCDIC-Arabic |
IBM EBCDIC (Cyrillic Russian) | x-EBCDIC-CyrillicRussian |
IBM EBCDIC (Cyrillic Serbian-Bulgarian) | x-EBCDIC-CyrillicSerbianBulgarian |
IBM EBCDIC (Denmark-Norway) | x-EBCDIC-DenmarkNorway |
IBM EBCDIC (Denmark-Norway-Euro) | x-ebcdic-denmarknorway-euro |
IBM EBCDIC (Finland-Sweden) | x-EBCDIC-FinlandSweden |
IBM EBCDIC (Finland-Sweden-Euro) | x-ebcdic-finlandsweden-euro |
IBM EBCDIC (Finland-Sweden-Euro) | x-ebcdic-finlandsweden-euro | X-EBCDIC-France
IBM EBCDIC (France-Euro) | x-ebcdic-france-euro |
IBM EBCDIC (Germany) | x-EBCDIC-Germany |
IBM EBCDIC (Germany-Euro) | x-ebcdic-germany-euro |
IBM EBCDIC (Greek Modern) | x-EBCDIC-GreekModern |
IBM EBCDIC (Greek) | x-EBCDIC-Greek |
IBM EBCDIC (Hebrew) | x-EBCDIC-Hebrew |
IBM EBCDIC (Icelandic) | x-EBCDIC-Icelandic |
IBM EBCDIC (Icelandic-Euro) | x-ebcdic-icelandic-euro |
IBM EBCDIC (International-Euro) | x-ebcdic-international-euro |
IBM EBCDIC (Italy) | x-EBCDIC-Italy |
IBM EBCDIC (Italy-Euro) | x-ebcdic-italy-euro |
IBM EBCDIC (Japanese and Japanese Katakana) | x-EBCDIC-JapaneseAndKana |
IBM EBCDIC (Japanese and Japanese-Latin) | x-EBCDIC-JapaneseAndJapaneseLatin |
IBM EBCDIC (Japanese and US-Canada) | x-EBCDIC-JapaneseAndUSCanada |
IBM EBCDIC (Japanese katakana) | x-EBCDIC-JapaneseKatakana |
IBM EBCDIC (Korean and Korean Extended) | x-EBCDIC-KoreanAndKoreanExtended |
IBM EBCDIC (Korean Extended) | x-EBCDIC-KoreanExtended |
IBM EBCDIC (Multilingual Latin-2) | CP870 |
IBM EBCDIC (Simplified Chinese) | x-EBCDIC-SimplifiedChinese |
IBM EBCDIC (Spain) | X-EBCDIC-Spain |
IBM EBCDIC (Spain-Euro) | x-ebcdic-spain-euro |
IBM EBCDIC (Thai) | x-EBCDIC-Thai |
IBM EBCDIC (Traditional Chinese) | x-EBCDIC-TraditionalChinese |
IBM EBCDIC (Turkish Latin-5) | CP1026 |
IBM EBCDIC (Turkish) | x-EBCDIC-Turkish |
IBM EBCDIC (UK) | x-EBCDIC-UK |
IBM EBCDIC (UK-Euro) | x-ebcdic-uk-euro |
IBM EBCDIC (US-Canada) | ebcdic-cp-us |
IBM EBCDIC (US-Canada-Euro) | x-ebcdic-cp-us-euro |
Icelandic (DOS) | ibm861 |
Icelandic (Mac) | x-mac-icelandic |
ISCII Assamese | x-iscii-as |
ISCII Bengali | x-iscii-be |
ISCII Devanagari | x-iscii-de |
ISCII Gujarathi | x-iscii-gu |
ISCII Kannada | x-iscii-ka |
ISCII Malayalam | x-iscii-ma |
ISCII Oriya | x-iscii-or |
ISCII Panjabi | x-iscii-pa |
ISCII Tamil | x-iscii-ta |
ISCII Telugu | x-iscii-te |
Japanese (EUC) | euc-jp | csEUCPkdFmtJapanese, Extended_UNIX_Code_Packed_Format_for_Japanese, x-euc, x-euc-jp
Japanese (JIS) | iso-2022-jp |
Japanese (JIS-Allow 1 byte Kana - SO/SI) | iso-2022-jp | _iso-2022-jp$SIO
Japanese (JIS-Allow 1 byte Kana) | csISO2022JP | _iso-2022-jp
Japanese (Mac) | x-mac-japanese |
Japanese (Shift-JIS) | shift_jis | csShiftJIS, csWindows31J, ms_Kanji, shift-jis, x-ms-cp932, x-sjis
Korean | ks_c_5601-1987 | csKSC56011987, euc-kr, iso-ir-149, korean, ks_c_5601, ks_c_5601_1987, ks_c_5601-1989, KSC_5601, KSC5601
Korean (EUC) | euc-kr | csEUCKR
Korean (ISO) | iso-2022-kr | csISO2022KR
Korean (Johab) | Johab |
Korean (Mac) | x-mac-korean |
Latin 3 (ISO) | iso-8859-3 | csISO, Latin3, ISO_8859-3, ISO_8859-3:1988, iso-ir-109, l3, latin3
Latin 9 (ISO) | iso-8859-15 | csISO, Latin9, ISO_8859-15, l9, latin9
Norwegian (IA5) | x-IA5-Norwegian |
OEM United States | IBM437 | 437, cp437, csPC8, CodePage437
Swedish (IA5) | x-IA5-Swedish |
Thai (Windows) | windows-874 | DOS-874, iso-8859-11, TIS-620
Turkish (DOS) | ibm857 |
Turkish (ISO) | iso-8859-9 | csISO, Latin5, ISO_8859-9, ISO_8859-9:1989, iso-ir-148, l5, latin5
Turkish (Mac) | x-mac-turkish |
Turkish (Windows) | windows-1254 | ISO_8859-9, ISO_8859-9:1989, iso-8859-9, iso-ir-148, latin5
Unicode | unicode | utf-16
Unicode (Big-Endian) | unicodeFFFE |
Unicode (UTF-7) | utf-7 | csUnicode11UTF7, unicode-1-1-utf-7, x-unicode-2-0-utf-7
Unicode (UTF-8) | utf-8 | unicode-1-1-utf-8, unicode-2-0-utf-8, x-unicode-2-0-utf-8
US-ASCII | us-ascii | ANSI_X3.4-1968, ANSI_X3.4-1986, ascii, cp367, csASCII, IBM367, ISO_646.irv:1991, ISO646-US, iso-ir-6us
Vietnamese (Windows) | windows-1258 |
Western European (DOS) | ibm850 |
Western European (IA5) | x-IA5 |
Western European (ISO) | iso-8859-1 | cp819, csISO, Latin1, ibm819, iso_8859-1, iso_8859-1:1987, iso8859-1, iso-ir-100, l1, latin1
Western European (Mac) | macintosh |
Western European (Windows) | Windows-1252 | ANSI_X3.4-1968, ANSI_X3.4-1986, ascii, cp367, cp819, csASCII, IBM367, ibm819, ISO_646.irv:1991, iso_8859-1, iso_8859-1:1987, ISO646-US, iso8859-1, iso-8859-1, iso-ir-100, iso-ir-6, latin1, us, us-ascii, x-ansi
© 2004-2006 Adobe Systems Incorporated. All rights reserved.
Thu Jun 22 2006, 10:24 PM GMT-07:00


Adobe Flex 2 Language Reference

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link to Non-frame version.


Adobe® Flex™ 2 Language Reference

This part describes the Flex MXML and ActionScript API. It is intended to be used with other instructional media, such as the Programming ActionScript 3.0 guide, and resources on the Adobe website, such as the ActionScript Topic Center.

The following sections are included in this reference:

All Packages
All MX Packages
All Flash Player Packages
All Classes
All MX Classes
All Flash Player Classes
Language Elements
Index
Appendixes
Conventions

For information on using this API reference, including documentation conventions, see the Conventions page.


Adobe Flex 2 Language Reference

Frame Alert

This document is designed to be viewed using the frames feature. If you see this message, you are using a non-frame-capable web client.
Link toNon-frame version.


Package List - Adobe® Flex™ 2 Language Reference

Packages

Top Level
flash.accessibility
flash.display
flash.errors
flash.events
flash.external
flash.filters
flash.geom
flash.media
flash.net
flash.printing
flash.profiler
flash.system
flash.text
flash.ui
flash.utils
flash.xml
mx.binding.utils
mx.charts
mx.charts.chartClasses
mx.charts.effects
mx.charts.effects.effectClasses
mx.charts.events
mx.charts.renderers
mx.charts.series
mx.charts.series.items
mx.charts.series.renderData
mx.collections
mx.collections.errors
mx.containers
mx.containers.accordionClasses
mx.controls
mx.controls.dataGridClasses
mx.controls.listClasses
mx.controls.menuClasses
mx.controls.scrollClasses
mx.controls.sliderClasses
mx.controls.textClasses
mx.controls.treeClasses
mx.controls.videoClasses
mx.core
mx.data
mx.data.errors
mx.data.events
mx.data.messages
mx.data.mxml
mx.data.utils
mx.effects
mx.effects.easing
mx.effects.effectClasses
mx.events
mx.formatters
mx.graphics
mx.logging
mx.logging.errors
mx.logging.targets
mx.managers
mx.messaging
mx.messaging.channels
mx.messaging.config
mx.messaging.errors
mx.messaging.events
mx.messaging.management
mx.messaging.messages
mx.preloaders
mx.printing
mx.resources
mx.rpc
mx.rpc.events
mx.rpc.http
mx.rpc.http.mxml
mx.rpc.mxml
mx.rpc.remoting
mx.rpc.remoting.mxml
mx.rpc.soap
mx.rpc.soap.mxml
mx.rpc.xml
mx.skins
mx.skins.halo
mx.states
mx.styles
mx.utils
mx.validators

Language Elements

Global Constants
Global Functions
Operators
Statements, Keywords & Directives
Special Types

Appendixes

MXML Only Components
Compiler Errors
Compiler Warnings
Run-Time Errors
ActionScript 2.0 Migration


Adobe Flex 2 Language Reference

Adobe® Flex™ 2 Language Reference |  | All Packages | All Classes | Language Elements Index | Appendixes | Conventions | No Frames | Adobe Logo
 | Properties | Properties | Constructor | Methods | Functions | Events | Styles | Effects | Constants | Constants | Interfaces | Classes | Use | Examples